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Typographical Conventions

This document uses the conventions in the following table to distinguish elements of text.

NOTE  Some pathnames in this document that are identical (except for the directory-separator character) 
on both UNIX and Windows platforms are specified in UNIX syntax only (that is, with forward-slash 
directory separators).

WARNING  This document contains examples of text to be typed on a command line. Be sure to manually 
type the command, rather than copying and pasting it from this document. Otherwise, your command line 
may contain unrecognized characters and will not execute properly.

Convention Usage

UPPERCASE Environment variables, status codes, utility names.

Bold Program names and selected terms such as command 
parameters or environment variables that require emphasis.

Bold Gray Clickable user-interface elements (such as buttons).

Bold Olive Paths and file names. 

Italic User-supplied variables and new terms introduced in text, 
names of additional documents (such as IBM FileNet P8 
Platform Installation and Upgrade Guide).

<italic> User-supplied variables that replace everything between and 
including the angle bracket delimiters (< and >).

Monospace Code samples, examples, display text, and error 
messages.



Revision Log

The following table identifies changes made to this document since the IBM FileNet P8 Rendition 
Engine 4.0.0 release.

Date Revision

07/08 Updated “Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” 
on page 12.

Updated Step 3 “Configure Microsoft Word publishing requirements.” on page 29.

Updated “Remove Rendition Engine Software from a Rendition Engine” on page 71.

11/07 Updated web-site locations for IBM FileNet product information, documentation, 
and software updates.

Added “Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” on 
page 12 to clarify how to find product documentation on the IBM web site.

09/07 Version 4.0.1.

Added “To install Database Drivers on Content Engine (JBoss)” on page 41.

06/07 Added Task 6 “Set the site preferences on the Application Engine to use path-based 
URLs” on page 54.

03/07 Minor updates.

12/06 Initial revision.
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About this Document

Installation by a FileNet® Certified Professional (FCP) Recommended. For more information on 
the FCP program, refer to the IBM® web site (http://www.ibm.com/us), Products > Software > 
Information Management > Training and certification > Professional Certification > FileNet 
Certified Professional Program (FCP).

Every effort has been made to provide you with complete installation instructions. If information 
becomes available after the creation of the documentation release from which you accessed this 
guide, we will provide an updated version of the guide. To download this guide from the IBM 
support page, see “Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” on 
page 12. 

Send your comments by e-mail to comments@us.ibm.com. Be sure to include the name of the 
product, the version number of the product, and the name and part number of the book (if 
applicable). If you are commenting on specific text, include the location of the text (for example, a 
chapter and section title, a table number, a page number, or a help topic title).

This guide provides instructions for installing and/or upgrading the IBM FileNet Rendition Engine 
to its current released version. Be aware that each release of a IBM FileNet P8 component or 
expansion product may have multiple  service packs, fix packs or interim fixes available for 
installation, each with potentially different dependencies and installation requirements. Therefore, 
before you attempt to install or upgrade IBM FileNet Rendition Engine, review the list of releases 
and their associated dependencies in the IBM FileNet Compatability Matrix on the IBM support 
page (www.ibm.com/software/data/support/). See “Access IBM FileNet Documentation, Compatibility 
Matrices, and Fix Packs” on page 12.

http://www.ibm.com/software/data/support/
http://www.ibm.com/
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Installation Planning and Procedures

This installation section contains the following major topics:

• “Plan the Installation” on page 11

• “Prerequisite Tasks” on page 22

• “Installation Tasks” on page 43
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Plan the Installation
Before you begin to install IBM FileNet P8 Rendition Engine:

• Retrieve updates to IBM FileNet P8 documentation and software, see “Access IBM FileNet 
Documentation, Compatibility Matrices, and Fix Packs” on page 12.

• Review the “Installation Planning Considerations” on page 12 for a list of auxiliary documentation 
you should gather and a list of tasks you should perform before you install IBM FileNet 
Rendition Engine software.

• Read “Prerequisite Tasks” on page 22 and “Installation Tasks” on page 43 to become familiar with 
the tasks you will perform when you set up your IBM FileNet Rendition Engine software.

NOTE  FileNet recommends you follow the planning, installation, and configuration tasks in the 
order presented in these topics. If you do otherwise, or you install FileNet P8 components on 
machines containing components for existing FileNet P8 systems, you may encounter unforeseen 
problems or be required to perform additional setup steps. See the IBM FileNet P8 Platform 
Troubleshooting Guide. To download this document from the IBM support page, see “Access IBM 
FileNet Documentation, Compatibility Matrices, and Fix Packs” on page 12.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Installation Planning Considerations
This section lists details that will help you prepare your environment for the installation of 
Rendition Engine. In many cases, the items you see listed are links to more detailed information. 
Please review this information thoroughly before you start to set up a Rendition Engine or 
required third-party software.

General Requirements 
Before you install Rendition Engine, you must first install and configure the IBM FileNet P8 4.0.0 
platform. Then follow the procedures in this guide to install Rendition Engine.

About Rendition Engine
Rendition Engine is a software server responsible for transforming documents into another format, 
such as PDF or HTML. The Rendition Engine software is based on the Liquent RenderPerfect 
product. To install and configure the RenderPerfect components on the Rendition Engine server 
and Content Engine server follow the instructions in this document. 

For more information about RenderPerfect, see the FileNet P8 Help topic FileNet P8 Administration 
> Enterprise-wide Administration > Publishing > Publishing Overview > About Rendition Engine.

Access IBM FileNet Documentation, Compatibility Matrices, and Fix 
Packs
To access documentation for IBM FileNet products

1. Access the Product Documentation for FileNet P8 Platform support page
(www.ibm.com/support/docview.wss?rs=3247&uid=swg27010422). 

2. Select the appropriate product link.

To access compatibility matrices and fix packs for IBM FileNet products

1. Access the Fix Packs for FileNet P8 Platform support page
(www.ibm.com/support/docview.wss?&uid=swg27010146). 

2. From the Fix Pack page:

• To access the compatibility matrix, under FileNet P8 Compatibility Matrices, click Matrix.

• To access the fix pack you need, under a specific product name, click the release number.

Gather auxiliary documentation
NOTE  For general instructions on how to navigate to this and other IBM FileNet product 
documentation on the IBM web site, see “Access IBM FileNet Documentation, Compatibility Matrices, 
and Fix Packs” on page 12.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Before you begin installing the software, retrieve the following documents:

• IBM FileNet Rendition Engine Installation and Upgrade Guide (This document). This 
document provides details on how to install and upgrade Rendition Engine components.

• IBM FileNet P8 Hardware and Software Requirements. This document provides details for all 
FileNet P8 system components, as well as the minimum supported levels of third-party 
software components. The information throughout the IBM FileNet P8 Platform Installation 
and Upgrade Guide assumes you have met all applicable requirements listed in that 
document. 

• IBM FileNet P8 Platform Release Notes. This document provides details on new features, 
known issues, and resolved problems. 

• IBM FileNet P8 Platform Installation and Upgrade Guide. This document provides details for 
installation, upgrade, and configuration of the core components for the FileNet P8 system.

• FileNet P8 Platform user and group security help. 

This help topic provides a complete list of the user and group roles, accounts, and 
responsibilities required to install, configure, and maintain a FileNet P8 system. For more 
information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Security > Users and groups. 

• FileNet P8 Platform Shutdown and Startup. 

This help topic describes how to shut down and restart FileNet P8 Platform components and 
some expansion products. Manual, command line, and some sample batch file procedures are 
provided. For more information, see the FileNet P8 Help topic FileNet P8 Administration > 
Enterprise-wide Administration > Shutdown and Startup. 

• Installing IBM FileNet P8 Platform in a Non-English Environment Technical Notice. This 
document will help you set up the product if your environment is not English-language based. 

• IBM FileNet P8 Platform Deployment Guide. This document provides details on how to deploy 
a FileNet P8 system from a staging environment into a full production environment. 

• IBM FileNet P8 Platform Troubleshooting Guide. This document provides troubleshooting 
information on all aspects of the product.

• IBM FileNet P8 Platform Performance Tuning Guide. This document provides performance 
tuning information on all aspects of the product. 

Installation Checklist
A consolidated checklist of the requirements and planning considerations for installing RE is 
available in “Installation Checklist” on page 18. This checklist identifies information you will need to 
supply during the installation and configuration process.

NOTE We strongly recommend that you print and fill out this form before you begin the RE 
installation and configuration process.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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The Installation Package
The following is a brief description of the contents of the RE installation package:

• Installer (folder) - Contains the setup.exe file used to install RE.

• Resources (folder) - Contains the Oracle-repository.sql script and the 
FileNetP8RenditionEngineLicense.xml file used during the installation.

• Readme.htm - Contains information about the RE documentation.

Operating System Considerations

Network Considerations
• Ensure TCP/IP settings. Verify TCP/IP configuration settings on the RE server.

• Ensure communication. Make sure the RE server can communicate with the database server 
and the Content Engine server, and that the Content Engine server can communicate with the 
RE server.

• Ensure availability of required port numbers. Several port numbers are required by the various 
FileNet P8 components. For a list, see “FileNet P8 Port Numbers” on page 74. 

Content Engine and Rendition Engine
• For performance reasons, unless you plan to install more than one Rendition Engine in your 

environment, FileNet recommends that you install Rendition Engine and Content Engine on 
separate servers. This will spread the performance load between the publishing servers.

• You must install Rendition Engine on a server that has an NTFS drive partition.

If you don’t install RE on an NTFS partition you won’t be able to complete the task “Set security 
on the VistaTempDir shared folder.” on page 50. 

• When you first run the Rendition Engine setup program, you create a new Liquent Vista 
domain—an administrative entity that’s used to manage Rendition Engine services. For each 
subsequent execution of the Rendition Engine setup program on a machine, you can join an 
existing Liquent Vista domain or create another Liquent Vista domain.

Third-Party Native Applications
Before you install Rendition Engine, to ensure proper MIME type recognition, you must install all 
applications that your users will run to create and render publication documents on the Rendition 
Engine server(s). In addition, a number of these applications require configuration before you can 
use them for FileNet publishing. See “Configure Native Applications” on page 29.

These applications require configuration: 

• Microsoft® Word
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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• Microsoft Excel

• Microsoft Power Point 

• Microsoft Visio

• Microsoft Project

• WordPerfect

NOTE  For a complete list of supported applications, see IBM FileNet P8 Hardware and Software 
Requirements.

Security Authentication Considerations
Check required user account privileges. For installing, configuring, and running Rendition 
Engine, you must use specific user and group accounts with particular access privileges. See 
“Users Required for Rendition Engine Installation” on page 17.

Database Considerations 
For a checklist version of these considerations, see “Database Considerations” on page 19.

If you plan to collocate the RE database with CE or PE databases, you should use the supplied 
database instance (Microsoft SQL Server) or database (Oracle) for these components. For more 
information, see IBM FileNet P8 Platform Installation and Upgrade Guide and the tasks Install 
Microsoft SQL Server for FileNet P8 or Install Oracle Server for FileNet P8.

If you plan to install and configure a standalone database instance (Microsoft SQL Server) or 
database (Oracle) for RE, follow the instructions in this guide.

All platforms
• Determine your local vs. remote database engine preference. The database engine is local if it 

is installed on a server where you will also be installing Content Engine, Process Engine and/
or Rendition Engine software. The database is remote if it is on a server where no Content 
Engine, Process Engine or Rendition Engine software is installed.

• Determine what type of database engine you want to use. Rendition Engine supports only 
Microsoft SQL Server and Oracle. 

NOTE  Rendition Engines and Content Engines in a Liquent Vista domain must use the same 
database. 

• Determine the Purge and Archive intervals for the RE database.

By default, the RE database is set to autogrow. To keep the database size down, RE is set up 
to archive the content of the database daily and to purge the archived content weekly. These 
intervals can be modified using the Domain Manager interface. See “(Optional) Set the Rendition 
Engine Purge and Archive Intervals.” on page 49.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Microsoft SQL Server
• Determine whether you want to use a dedicated or shared database. 

– You can assign Rendition Engine a dedicated instance. You can use the default instance or 
a named instance of your choice.

– Rendition Engine can share a Microsoft SQL Server instance with Content Engine or Pro-
cess Engine. 

– Rendition Engine must have its own database, separate from Content Engine and Process 
Engine. 

NOTE  There is no need to create an SQL database before you install Rendition Engine 
software. The Rendition Engine installer will prompt for appropriate database information 
and will create the necessary database.

– Remote Microsoft SQL connections for Rendition Engine are handled by Microsoft Data 
Access Components, which is installed by default on Rendition Engine servers. There is 
no need to install the Microsoft SQL client software on the Rendition Engine server.

• An SQL Login is required for Rendition Engine purposes. Under Microsoft SQL Server, you 
must ensure that an SQL Login account exists before you install the first Rendition Engine. 
See “To configure Microsoft SQL Login for Rendition Engine” on page 23.

Oracle
• Determine whether you want to use a dedicated or shared database.

– Rendition Engine can have a dedicated Oracle database service or share a database ser-
vice with Content Engine, Process Engine, or non-FileNet applications. 

– Rendition Engine must have its own tablespace, separate from Content Engine and Pro-
cess Engine. 

NOTE  This tablespace will be created by executing an Oracle SQL script prior to installing 
the first Rendition Engine. See “To create an Oracle database” on page 26.

• Database client software requirements. For Rendition Engine, if the database is remote, you 
must install database client software on the Rendition Engine server. See “Install Oracle Client 
for Rendition Engine” on page 28. 

NOTE  While the Content Engine also requires installation of the database client software, that 
installation and configuration will have already been completed during installation of the 
FileNet P8 system.

• To create a valid user and tablespace for RE, you will run the Oracle-repository.sql script on 
the database server as part of “Install Oracle Server for Rendition Engine” on page 25 before you 
perform the installation tasks. 
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Users Required for Rendition Engine Installation
NOTE Under Windows® Active Directory authentication, FileNet P8 supports only security groups, 
not distribution groups. Supported groups can have a scope of domain local (as long as they are 
in the same domain as Content Engine), global, or universal.

The following table lists the user accounts needed for installing Rendition Engine, including the 
minimum permissions required. For a checklist version of this listing, see “Installation Checklist” on 
page 18.

For a complete list of the user and group roles, accounts, and responsibilities required to install, 
configure, and maintain a FileNet P8 system, see the FileNet P8 Help topic FileNet P8 
Administration > Enterprise-wide Administration > Security > Users and groups > FileNet P8 Platform user 
and group security help and the IBM FileNet P8 Platform Installation and Upgrade Guide task 
“Specify FileNet P8 Accounts.”

Users required to install and configure Rendition Engine 

Role/Account Description

<FNRE_Admin> A local or domain user account that must be 
added directly to the local Administrators group 
on all Rendition Engine servers.

Permissions: Local administrator privileges on the 
machine where Rendition Engine is installed.

<GCD administrator user> A FileNet P8 Platform user that is part of the GCD 
administrators. 

You will need this user when you configure the 
Rendition Engine Connection on CE. See “Set up 
Rendition Engine Connection (REC) on the Content 
Engine.” on page 52.

<SQL Login> (Microsoft SQL Server only)  Any SQL Server 
user with SQL Server's "Database Creators" 
server role.

This user will be created as part of the Microsoft 
SQL Server installation and is a safer alternative 
to using SQL Server's SA or SYS users, which will 
also satisfy the configuration requirements.

See “To configure Microsoft SQL Login for Rendition 
Engine” on page 23.

<VISTAUSER> (Oracle Server only) This user will be created as 
part of the Oracle Server installation. See “To 
create an Oracle database” on page 26.
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Installation Checklist
For a successful installation or upgrade of FileNet Rendition Engine, please use the following 
checklists.

You can print these lists and record the information as you perform the prerequisite and 
installation tasks.

FileNet P8 Platform Environment Prerequisites 
The core components of the FileNet P8 suite of products—Content Engine (CE), Process 
Engine (PE), and Application Engine (AE)—must be installed and configured before you start 
the RE installation.

The Content Engine, Application Engine, and Process Engine must be updated to the latest fix 
pack and interim fix levels that are compatible with Rendition Engine before you start the RE 
installation.

Refer to the "Hotfix Pack and Patch Dependencies" document (p840xPatchDependency.xls). 
To download this guide from the IBM support page, see “Access IBM FileNet Documentation, 
Compatibility Matrices, and Fix Packs” on page 12.

FileNet P8 Workplace must be installed and deployed.

Object stores that will be used for publishing must be configured with the Publishing AddOns. 

NOTE  The publishing add-ons are added to an object store by default. 

The environment must meet all applicable requirements listed in the FileNet P8 Hardware and 
Software Requirements document. To download this guide from the IBM support page, see 
“Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” on page 12.

Verify that you can access the Content Engine and database servers from the servers on 
which you will be installing the RE components.

Verify that Content Engine can access the rendition Engine server(s).

Documentation 
Make sure that you have updated copies of all relevant documentation as listed in “Gather 
auxiliary documentation” on page 12.

Native Applications
Verify that you have installed all native applications you plan to use for publishing.

(Upgrade only) Do you plan to upgrade or add native applications to your setup?

Yes. You must perform these upgrades or additions before you reinstall Rendition Engine. 
See “(Optional) Upgrade native applications.” on page 68.

No.

FileNet P8 Workplace URL:   
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Database Considerations 
Identify the type of database used by Rendition Engine.

Oracle.

Microsoft SQL Server.

Will the database be remote or local to the Rendition Engine?

Remote.

Local.

Microsoft SQL Server
Microsoft SQL Server server name:

Will the Microsoft SQL Server instance be shared or dedicated?

Shared.

Dedicated.

Microsoft SQL Server port:

Verify that a SQL Login exists for Rendition Engine purposes. 

See“<SQL Login>” on page 20.

Oracle
Will the Oracle database service be shared or dedicated?

Shared.

Dedicated.

Server name:  

Instance name:  

Port Number:  

Service name:  
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Oracle port:

Oracle tablespace parameters.

NOTE  If you plan to use different settings for your database tablespace, you must reconfigure 
the script prior to running it.

You will need these values when you run the Oracle-Repository.sql script and when you install 
Rendition engine. See:

• “To create a tablespace for Rendition Engine” on page 26.

NOTE  If you plan to use different settings for your database tablespace, you must 
reconfigure the script before you run it.

• “(Oracle 9/10) Oracle Database Information” on page 47.

Authentication Requirements
The following are the privileges for which you will need a user name and password.

<SQL Login>

You will need this user when you configure the Microsoft SQL login. See “To configure Microsoft 
SQL Login for Rendition Engine” on page 23.

The user selected:

• Must exist before you configure the Microsoft SQL login. 

• Will be given SQL Server's "Database Creators" server role.

<FNRE_Admin> 

You will need this user when you install RE. See “Log on to the Rendition Engine server as the 
<FNRE_Admin> user.” on page 44.

Port Number:  

Parameter Default Value (If modified) Actual Value 
Assigned

data tablespace VISTADAT1  

index tablespace VISTAIND1  

user name VISTAUSER  

password none (assigned at 
runtime)

 

User Name:  Password:  

User Name:  Password:  
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The user selected:

• Must be added to the local Administrators group on all Rendition Engine servers.

<GCD administrator user> 

You will need this user when you configure the Rendition Engine Connection on CE. See “Set 
up Rendition Engine Connection (REC) on the Content Engine.” on page 52.

For more information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Security > Users and groups.  

The user selected:

• Must be a GCD administrator.

User Name:  Password:  
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Prerequisite Tasks
To set up and configure prerequisite software for Rendition Engine

1. Configure database software:

• For Microsoft SQL Server, do Task 1a “Install Microsoft SQL Server for Rendition Engine” on 
page 23.

• For Oracle, do:

i. Task 1b “Install Oracle Server for Rendition Engine” on page 25.

ii. Task 1c “Install Oracle Client for Rendition Engine” on page 28.

2. Configure native applications for Rendition Engine. Do Task 2 “Configure Native Applications” on 
page 29.
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Task 1a: Install Microsoft SQL Server for Rendition 
Engine
If you plan to collocate the RE database with CE or PE databases, you should use the existing 
database instance for these components. For more information, see the FileNet P8 Platform 
Installation and Upgrade Guide, task Install Microsoft SQL Server for FileNet P8.

If you plan to install and configure a standalone database instance for RE, follow the instructions 
in this task.

NOTES

• Install Microsoft SQL Server on the server where Rendition Engine software will be installed 
as a local database or on a separate server as a remote database. 

• Database creation for Rendition Engine will be handled automatically when you install and 
configure Rendition Engine.

• You do not need to install Microsoft SQL client software on the Rendition Engine server.

• (Microsoft SQL Server 2000) Verify that the required Microsoft SQL Server 2000 Service Pack 
is available. See the FileNet P8 Hardware and Software Requirements. 

• Record the values for the following settings as you work through the database installation. 
This information must be entered during subsequent installations. 

– Server name.

– Instance (e.g., P8_inst).

– TCP/IP port number assigned. 

NOTE  A checklist entry for this information can be found at “Microsoft SQL Server” on page 19.

To install and configure Microsoft SQL Server

FileNet Rendition Engine does not require any specific configuration settings when you install 
Microsoft SQL Server. Refer to the Microsoft SQL Server 2000/2005 installation instructions. 

To configure Microsoft SQL Login for Rendition Engine

On the Microsoft SQL database computer, use Microsoft SQL Server Enterprise Manager to 
create a Microsoft SQL Login (<SQL Login>).

1. Start the Microsoft SQL Enterprise Manager.

2. Expand the Microsoft SQL Server <Server name>[\<Instance name>] node. 

3. Expand the Security folder, right-click Logins and select New Login....

4. In the SQL Server Login Properties screen, under the General tab, do the following:

a. In the Name field, enter a name for the <SQL Login> user.

b. In the Password field, enter a password for the new SQL user.
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c. Verify that the default database for the login is “master.”

5. Grant the SQL login created in the step above the Database Creators server role.

a. In the SQL Server Login Properties screen, select the Server Roles tab.

b. Under Server Roles, check Database Creators.

6. Using the SQL Query Analyzer, validate that you can successfully log on to the SQL database 
using this user name and password. 
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Task 1b: Install Oracle Server for Rendition Engine
If you plan to collocate the RE database with CE or PE databases, you should use the existing 
database for these components. For more information, see the FileNet P8 Platform Installation 
and Upgrade Guide, task Install Oracle Server for FileNet P8.

If you plan to install and configure a standalone database for RE, follow the instructions in this 
task.

A database is local if it is on a machine where you will also be installing Rendition Engine. A 
database is remote if it is on a machine where no Rendition Engine is installed. 

NOTES

• Perform this task on the UNIX®, Linux®, or Windows server that will host the Oracle database 
to be used by the Rendition Engine.

• Make sure that the server that will host the database satisfies all pre-installation requirements 
specified in the Oracle installation documentation.

• If the server where you install the Oracle database will also host an installation of Rendition 
Engine, the machine must meet the Rendition Engine requirements listed in FileNet P8 
Hardware and Software Requirements.   

• Refer to FileNet P8 Hardware and Software Requirements for operating-system service pack 
and Oracle version and patch set requirements. The Oracle patch-installation procedure may 
be less complicated if you do it before you create any databases.

• If your Oracle database will be remote, after you complete the procedures in this topic, you 
must also complete the procedures in “Install Oracle Client for Rendition Engine” on page 28 on 
each machine where you will install Rendition Engine.

• FileNet suggests that you record the values for the following settings as you work through the 
database installation. This information must be entered during subsequent installations.

– Global Database Service Name

– Oracle temporary tablespace name

– Oracle data tablespace name

– Oracle index tablespace name (optional)

NOTE  A checklist entry for this information can be found at “Oracle” on page 19.

To install an Oracle database engine

FileNet Rendition Engine does not require any specific configuration settings when you install 
Oracle. Refer to Oracle installation instructions. 

You do not need to create a tablespace as part of the installation. This will be handled in “To create 
a tablespace for Rendition Engine” on page 26. 

During installation, select Enterprise Edition or Custom to install the necessary components (if you 
don't need all the components in the Enterprise Edition).
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If you selected Custom the following minimum components must be installed:

• Oracle 9i

– Oracle 9i Server

– Oracle Net Services

• Oracle Net Listener

– Oracle 9i Development Kit

• Oracle Call Interface (OCI)

– (Windows) Oracle Windows Interfaces

• Oracle Services for Microsoft Transaction Server

– Oracle 9i Documentation (recommended)

• Oracle 10g

– Oracle 10g Server

– Oracle Net Services

• Oracle Net Listener

– Oracle 10g Development Kit

• Oracle Call Interface (OCI)

– (Windows) Oracle Windows Interfaces

• Oracle Services for Microsoft Transaction Server

– Oracle 10g Documentation (recommended) 

To create an Oracle database

Oracle documentation describes several ways to create a database. FileNet recommends you use 
the Database Configuration Assistant (DBCA).

When you create the database, specify the following settings:

• Server process type

NOTE  “Dedicated Server Mode” offers better performance than “Shared Server Mode.”

• Database character set

Choose a database character set as specified in “FileNet P8 Database Character Sets” in the 
FileNet P8 Platform Installation and Upgrade Guide.

To create a tablespace for Rendition Engine

You will use the Oracle-Repository.sql script to create a user and tablespaces for use by Rendition 
Engine. The tablespaces are for the exclusive use of Rendition Engine and should not be shared 
with any other FileNet P8 component.
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1. Log on to the Oracle server as an Oracle administrative user . 

2. Access the IBM FileNet Rendition Engine installation package.

3. Navigate to \Resources.

4. Copy the Oracle-Repository.sql script locally, and open it for editing.

Several parameters in the script can be modified to meet specific business requirements. The 
following table shows those parameters and the default values. Make a note of the actual 
values that are assigned. 

Specifically, note the user name and the password that is assigned when the script is run. 
That user name and password must be supplied later when you install the Rendition Engine 
software. 

5. Run the modified Oracle-Repository.sql script. 

Supply the required password for the <VISTAUSER> when prompted.

Parameter Default Value (If modified) Actual Value 
Assigned

data tablespace VISTADAT1

index tablespace VISTAIND1

user name VISTAUSER

password none (assigned at 
runtime)
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE



Task 1c: Install Oracle Client for Rendition Engine
To install the Oracle client

28

IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE

Task 1c: Install Oracle Client for Rendition Engine
The procedure in this task describes how to install the Oracle Client software to prepare for the 
installation of Rendition Engine.

NOTES

• Install Oracle Client on servers that will host Rendition Engine if the database will be remote 
from the Rendition Engine server.

• Make sure that the machine where you will install Oracle Client satisfies all the pre-installation 
requirements specified in the Oracle installation documentation.

• Refer to FileNet P8 Hardware and Software Requirements for operating-system service pack 
and Oracle version and patch set requirements.

To install the Oracle client

The following procedure describes the minimum options for installing Oracle Client. Consult the 
Oracle installation documentation for complete instructions and pre-installation requirements.

1. Log on with an appropriate local account to install and configure the Oracle Client software.

NOTE FileNet strongly recommends that you log on to the machine locally (not through a 
Windows domain) to install the Oracle Client software. 

2. If the machine where you are installing Oracle Client does not use DNS to resolve host names, 
place in its hosts file the IP address of the machine where the Oracle database is installed.

3. Launch the Oracle Client installation.

4. From the Available Products dialog, click Oracle Client.

5. From the Installation Types dialog box, click Runtime, and proceed with the installation.

6. After the installation completes, click Next Installation. 

7. On the Installation Types dialog box, click Custom and select Oracle Windows Interfaces from 
the list in the Available Product Components Dialog box, then proceed with and complete the 
installation.

8. Using Oracle Net Configuration Assistant, test the connection to the Oracle database server 
with the user name and password created in “To create a tablespace for Rendition Engine” on 
page 26. 

9. Install all required Oracle patches, as specified in the FileNet P8 Hardware and Software 
Requirements. To download this guide from the IBM support page, see “Access IBM FileNet 
Documentation, Compatibility Matrices, and Fix Packs” on page 12. 
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Task 2: Configure Native Applications
Before you install and configure the Rendition Engine software, you must install and configure the 
native applications that are used to publish and convert documents. Do these steps on each 
Rendition Engine server. See the steps below for any of the applications that apply to your 
environment.

To configure Microsoft Word

1. Before you install Rendition Engine, ensure the following folders contain no files:

<MS_Office_home>\Microsoft Office\Office\Startup

<MS_Office_home>\Microsoft Office\Office\XLStart

2. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. In Microsoft Word, choose Tools > Options. 

b. On the General tab click Web Options. 

c. Select the Files tab.

d. Check the Use long file names whenever possible item.

 Do this wherever the MS Office applications reside — on the Rendition Engine server and 
on each client machine from which source documents are added and rendering is initiated. 
By default, MS Office 2000 has this Web Options check box cleared, while MS Office 2003 
and MS Office XP have it set.

Be aware that under MS Office 2000, if you open an MS Word document that has this Web 
Options check box cleared, that setting will be used during the publishing operation even if 
the Web Options check box in your client Office 2000 application is set by default. This 
override does not occur with MS Office 2003 or MS Office XP.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

e. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

3. Configure Microsoft Word publishing requirements.

a. In Microsoft Word, choose Tools > Options

b.  Select the View tab and clear the following options:

• Show

– Startup Task Pane 
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– Status Bar 

– Screen Tips 

– Smart Tags 

– Animated Text 

– Windows in Taskbar 

– Field Codes 

• Formatting Marks

– Hidden Text 

– All 

• Print and Web Layout Options

– Background Colors and Images (2003)

c. Select the General tab and clear the following:

• Provide feedback with animation 

• Confirm conversion at Open 

• Update automatic links at Open 

• Mail as attachment 

• Automatically create drawing canvas when inserting AutoShapes 

• Allow starting in reading layout (2003)

d. Select the Edit tab and clear the following:

• Editing options

– Typing replaces selection 

– Drag-and-drop text editing 

– Use smart cursoring (2003)

– Use smart paragraph selection 

– Use CTRL + Click to follow hyperlink 

– When selecting, automatically select entire word 

– Keep track of formatting 

– Show paste Options buttons 

• Cut and paste options

– Smart cut and paste 
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e. Select the Print tab and clear the following:

• Printing Options

– Update fields 

– Allow A4/Letter paper resizing 

– Background printing 

• Include With Document

– Field Codes 

– Hidden Text 

– XML Tags (2003)

– Background Colors and Images (2003)

f. Select the Save tab and clear the following:

• Allow fast saves

• Allow background saves

• Save AutoRecover info every:

• Embed smart tags 

g. Select the Spelling & Grammar tab and clear the following:

• Spelling

– Check spelling as you type

– Always suggest corrections

• Grammar

– Check grammar as you type

– Check grammar with spelling

h. Select the Track Changes tab and do the following:

• Set Use Balloons (Print and Web Layout) to Never. (2003)

• Clear Use Balloons in Print and Web Layout. (XP)

To configure Microsoft Excel

1. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. In Microsoft Excel, choose Tools > Options. 

b. In the General tab click Web Options. 

c. Select the Files tab.
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d. Check the Use long file names whenever possible item.

 Do this wherever the MS Office applications reside — on the Rendition Engine server and 
on each client machine from which source documents are added and rendering is initiated. 
By default, MS Office 2000 has this Web Options check box cleared, while MS Office 2003 
and MS Office XP have it set.

Be aware that under MS Office 2000, if you open an MS Word document that has this Web 
Options check box cleared, that setting will be used during the publishing operation even if 
the Web Options check box in your client Office 2000 application is set by default. This 
override does not occur under MS Office 2003 or MS Office XP.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

e. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

2. Configure Microsoft Excel publishing requirements.

a. In Microsoft Excel, choose Tools > Options.

b. Select the View tab and clear the following options:

• Startup Task Pane 

• Status Bar 

• Windows in Taskbar 

• List Data Validation (2003) 

c. Select the General tab and clear the following:

•  Function tooltips 

d. Select the Edit tab and clear the following:

• Show Paste Options buttons 

• Show Insert Options buttons 

• Ask to update automatic links 

• Provide feedback with Animation 

e. Select the International tab and clear the following:

• Allow A4/Letter paper resizing 

f. Select the Save tab and clear the following:

• Save AutoRecover info every: 
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g. Select the Error Checking tab and clear the following:

• Enable background error checking 

• List Data Validation (2003)

To configure Microsoft PowerPoint

1. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. In Microsoft PowerPoint, choose Tools > Options. 

b. In the General tab click Web Options. 

c. Select the Files tab.

d. Check the Use long file names whenever possible item.

 Do this wherever the MS Office applications reside — on the Rendition Engine server and 
on each client machine from which source documents are added and rendering is initiated. 
By default, MS Office 2000 has this Web Options check box cleared, while MS Office 2003 
and MS Office XP have it set.

Be aware that under MS Office 2000, if you open an MS Word document that has this Web 
Options check box cleared, that setting will be used during the publishing operation even if 
the Web Options check box in your client Office 2000 application is set by default. This 
override does not occur under MS Office 2003 or MS Office XP.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

e. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

2. Configure Microsoft PowerPoint publishing requirements.

a. In Microsoft PowerPoint, choose Tools > Options.

b. Select the View tab and clear the following options:

• Startup Task Pane 

• Slide Layout task pane when inserting new slides 

• Status Bar 

• Windows in Taskbar 

• Prompt to keep ink annotations when exiting (2003) 

• Popup menu on right mouse click 
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• Show menu on right mouse click (2003)

• Show popup menu button 

• Show popup toolbar (2003)

• End with blank slide 

c. Select the General tab and clear the following:

• Provide feedback with sound to screen elements 

d. Select the Edit tab and clear the following:

• Show Paste Options buttons 

• Use smart cut and paste 

• When selecting, automatically select entire word 

• Drag-and-drop text editing 

e. Select the Print tab and clear the following:

• Background printing 

f. Select the Save tab and clear the following:

• Allow fast saves 

• Save AutoRecover info every: 

g. Select the Spelling and Style tab and clear the following:

• Check spelling as you type 

• Always suggest corrections 

To configure Microsoft Project 

1. In Microsoft Project, choose Tools > Options.

2. Select the View tab and clear the following options:

• Project Screentips

3. Select the General tab and clear the following:

• Show startup Task Pane 

• Advice from Planning Wizard 

• Automatically add new resources and tasks 

4. Select the Edit tab and clear the following:

• Ask to update automatic links 

5. Select the Scheduling Options tab and clear the following:

• Show scheduling messages 
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6. Select the Spelling Options tab and clear the following:

• Always suggest 

To configure Microsoft Visio 

1. In Microsoft Visio, choose Tools > Options.

2. Select the Save tab and clear the following options:

• Prompt for document properties 

• Save preview with file 

• Show XML file save warnings (XP) 

• Show file save warnings (2003) 

• Show XML file open warnings (XP) 

• Show file open warnings (2003) 

3. Select the Spelling tab and clear the following: 

• Check spelling as you type 

• Ignore words with number should be checked 

To configure WordPerfect

For information on these options, see your WordPerfect documentation.

1. In Corel WordPerfect, choose Tools > Settings.

2. Click Environment. 

3. In the Environment Settings screen select the Prompts tab and clear the following:

• Confirm deletion of table formulas

• [Beep] On hyphenation

4. Select the Interface tab and do the following:

• Clear Quick Tips

• Check [Save workspace (documents and windows layout)] Never

5. Click OK.

6. Click Files. 

7. In the Files Settings screen, select the Document tab and clear the following:

• Timed document backup every 

• Use enhanced file dialogs 

8. Click OK and Close to close the Settings dialog box.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE



Task 2: Configure Native Applications
To disable the Corel Office DAD components

36
9. Clear the following:

• Tools > Proofread > Prompt-As-You-Go

10. Select the following:

• Tools > Proofread > Off

11. Choose Tools > Workplace Manager... and clear the following:

• Show at Startup

To disable the Corel Office DAD components

For WordPerfect Office, you must disable the Corel Office DAD system tray icons and remove 
CorelCentral from the Startup folder.

1. In the Windows System tray, right-click any of the DAD icons.

2. Clear Display DAD on Startup.

3. Select Exit DAD.
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Task 3: Install Database Drivers on Content Engine
CAUTION  This task is only required if your CE and RE are using different databases. 

Rendition Engine may be configured to use a different database brand (i.e. MS SQL Server versus 
Oracle) than the CE/object store. In this case you must configure CE with the corresponding 
JDBC driver. 

Depending on the Content Engine application server, do one of the following:

• “To install Database Drivers on Content Engine (WebSphere)” on page 37.

• “To install Database Drivers on Content Engine (WebLogic)” on page 40.

• “To install Database Drivers on Content Engine (JBoss)” on page 41.

To install Database Drivers on Content Engine (WebSphere)

1. Install the JDBC driver for the RE database on Content Engine. 

a. Designate an existing profile for Content Engine. 

b. Navigate to Application servers > server1 > Java™ and Process Management > Java Virtual 
Machine. 

c. Depending on your database, copy one of the following JDBC driver files to a directory on 
the WebSphere® machine: 

• (SQL Server) Obtain sqljdbc_1.1.1501.100_enu.exe from the Microsoft Download Cen-
ter web site. 

• (Oracle) Obtain ojdbc14.jar from Oracle Software Downloads web site. 

For example, you can copy the JDBC driver file to one of the following locations: 

• (UNIX) /opt/jars 

• (Windows) C:\jars 

CAUTION  Do not copy the JDBC driver file to either of the following directories. 

• (UNIX) ...WebSphere/AppServer/lib/ext (ensure that this directory is empty) 

• (Windows) ...WebSphere\AppServer\lib\ext (ensure that this directory is empty) 

d. Start the WebSphere Administrative Console and log on to your profile. 

e. Navigate to Environment > WebSphere Variables, and click Cell. 

f. Depending on your database and the operating system of the WebSphere machine, create a 
JDBC parameter environment variable and set its value to the location you specified in 
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Step c, as shown in the following table (the JDBC parameter values shown in the table are 
only suggestions): 

g. Save your changes to the master configuration, and then stop and start WebSphere Applica-
tion Server. 

2. Add the JDBC driver to the classpath. 

NOTE  The following procedure is written for WebSphere 6.0.x. Steps for the WebSphere 5.1.1 
environment will be similar.  Please consult your WebSphere 5.1.1 documentation for 
guidance. 

•  RE database is SQL Server 

i. Start WebSphere Administrative Console. 

ii. Expand the Resources node in the left-hand pane of the console, and click JDBC Providers. 

iii. In the JDBC Providers screen, specify a node and server and then click New. 

iv. In the General Properties section, specify the values in the following table and then click 
Apply: 

Database Operating 
System

JDBC Parameter Name Value

SQL 
Server

UNIX MSSQLSERVER_JDBC_DRIVER_PATH /opt/jars

SQL 
Server

Windows MSSQLSERVER_JDBC_DRIVER_PATH C:\jars

Oracle UNIX ORACLE_JDBC_DRIVER_PATH /opt/jars

Oracle Windows ORACLE_JDBC_DRIVER_PATH C:\jars

Parameter Value

Database type User-defined

Provider type User-defined JDBC Provider
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• RE database is Oracle 

i. Start WebSphere Administrative Console. 

ii. In the JDBC Providers screen, specify a node and server and then click New. 

iii. In the General Properties section, specify the values in the following table and then click 
Apply:  

3. Restart WebSphere.

Implementation 
type

User-defined

Name A descriptive name for the JDBC provider (e.g. RE database 
JDBC provider)

Class path ${MSSQLSERVER_JDBC_DRIVERPATH}/sqljdbc.jar

Implementation 
class name

com.microsoft.sqlserver.jdbc.SQLServerConnectionPoolDataSou
rce

Statement Cache 
Size

0

Parameter Value

Database type User-defined

Provider type User-defined JDBC Provider

Implementation 
type

User-defined

Name A descriptive name for the JDBC provider (e.g. RE database 
JDBC provider)

Class path ${ORACLE_JDBC_DRIVER_PATH}/ojdbc14.jar

Implementation 
class name

oracle.jdbc.pool.OracleConnectionPoolDataSource

Statement Cache 
Size

0

Parameter Value
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To install Database Drivers on Content Engine (WebLogic)

1. Install the JDBC driver for the RE database on Content Engine. 

• RE database is SQL Server 

Download Microsoft SQL Server Driver 2005 JDBC Driver from the Microsoft Download 
Center (http://msdn.microsoft.com/data/ref/jdbc/) to a directory <jdbc_path> on your 
application server machine, such as: 

• (UNIX) /opt/jars 

• (Windows) C:\jars 

• RE database is Oracle 

i. Check to see if the Oracle JDBC Driver file is already on your WebLogic machine by searching 
for ojdbc##.jar in the <wls_install_path>/server/lib directory, where <wls_install_path> is 
the WebLogic Server installation path, such as C:\bea\weblogic92. 

ii. If no Oracle JDBC Driver file is present, download the file (the one that matches the version of 
the JDK on your WebLogic machine) from the Oracle JDBC Driver Downloads web site (http://
www.oracle.com/technology/software/tech/java/sqlj_jdbc/index.html) to a directory on the 
WebLogic machine. 

NOTE If you intend to install AddOns (extensions to FileNet P8 core components), and your 
Content Engine database will be Oracle, your Oracle JDBC Driver file requirements may be 
more restrictive. For the required version and patch number, see the IBM FileNet P8 Hardware 
and Software Requirements. To download this document from the IBM support page, see 
“Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” on page 12. 

2.  Add the JDBC driver to the classpath. 

• RE database is SQL Server 

(Windows) Edit the file startWebLogic.cmd for the CE WebLogic domain, as follows: 

• (WebLogic 8.1.5) Insert the following lines immediately after the JDBC information you 
added for the CE Oracle JDBC driver during CE installation: 

set JDBC_MSSQL_PATH=<jdbc_path>\sqljdbc_1.0\enu\sqljdbc.jar 
set CLASSPATH=%JDBC_ MSSQL_PATH%;%<LDAP_JAR>%;%CLASSPATH% 

• (WebLogic 9.2.x) Insert the following lines immediately after the JDBC information you 
added for the CE Oracle JDBC driver during CE installation: 

set JDBC_ MSSQL_PATH=<jdbc_path>\sqljdbc_1.0\enu\sqljdbc.jar 
set CLASSPATH=%JDBC_ MSSQL_PATH%;%CLASSPATH% 

(UNIX) Edit the file startWebLogic.sh by inserting the following lines immediately after the 
JDBC information you added for the CE Oracle JDBC driver during CE installation: 

JDBC_ MSSQL_PATH=<jdbc_path>/sqljdbc_1.0/enu/sqljdbc.jar 
CLASSPATH=$JDBC_ MSSQL_PATH:$CLASSPATH 
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• RE database is Oracle. 

Edit the file startWebLogic.cmd for the CE WebLogic domain by adding the following line 
immediately JDBC information you added for the CE MS SQL Server JDBC driver during CE 
installation. 

(Windows) 

set JDBC_PATH=<jdbc_path>\ojdbc##.jar 
set CLASSPATH=%JDBC_PATH;%CLASSPATH%; 

(UNIX) 

set JDBC_PATH=<jdbc_path>/ojdbc##.jar 
set CLASSPATH=%JDBC_PATH;%CLASSPATH%; 

3. Restart WebLogic. 

To install Database Drivers on Content Engine (JBoss)

1. Install the JDBC driver for the RE database on Content Engine. 

• RE database is SQL Server 

Download Microsoft SQL Server Driver 2005 JDBC Driver from the Microsoft Download 
Center (http://msdn.microsoft.com/data/ref/jdbc/) to a directory <jdbc_path> on your 
application server machine, such as: 

• (UNIX) /opt/jars 

• (Windows) C:\jars 

• RE database is Oracle 

Download the ojdbc##.jar file (the one that matches the version of the JDK on your JBoss 
machine) from the Oracle JDBC Driver Downloads web site (http://www.oracle.com/
technology/software/tech/java/sqlj_jdbc/index.html) to a directory on the WebLogic 
machine, such as: 

• (UNIX) /opt/jars 

• (Windows) C:\jars 

NOTE If you intend to install AddOns (extensions to FileNet P8 core components), and 
your Content Engine database will be Oracle, your Oracle JDBC Driver file requirements 
might be more restrictive. For the required version and patch number, see the IBM FileNet 
P8 Hardware and Software Requirements. To download this document from the IBM 
support page, see “Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” 
on page 12.

2.  Add the JDBC driver to the JBoss class loading architecture. 

• RE database is SQL Server

Copy the sqljdbc.jar file from the installed location:

<jdbc_path>/Microsoft SQL Server 2005 JDBC Driver/sqljdbc_1.1/enu/

to the JBoss server lib directory:
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<jboss-dir>/server/myserver/lib

• RE database is Oracle. 

Copy the Oracle type 4 thin driver jar file (ojdbc14.jar) from the installed location:

<jdbc_path>/

to the JBoss server lib directory:

<jboss-dir>/server/myserver/lib

3. Restart JBoss.
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Installation Tasks
To install Rendition Engine

1. Install the RE software. Do Task 4 “Install Rendition Engine” on page 44.

2. Configure the publishing environment. 

• Do Task 5 “Configure Rendition Engine Connection on Content Engine” on page 52.

• Do Task 6 “Set the site preferences on the Application Engine to use path-based URLs” on 
page 54.

• Do Task 7 “Enable word processing macros for rendering” on page 55.

3. Verify the installation. Do Task 8 “(Optional) Verify Installation” on page 57.

4. Install RE service packs and fix packs. Do Task 9 “Install Service Packs, Fix Packs and Interim 
Fixes for Rendition Engine” on page 58.
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Task 4: Install Rendition Engine
This procedure covers the installation and initial configuration of the Rendition Engine.

WARNING  If you enter invalid database user credentials and complete the Rendition Engine 
installation, you must correct these using the Domain Manager before you attempt to use 
Rendition Engine. For more information, see the FileNet P8 Help topic FileNet P8 Administration > 
Enterprise-wide Administration > Publishing > How to... > Change the Rendition Engine database 
password.

CAUTION  If this is an upgrade you can’t use a database that was used for an earlier version of the 
Rendition Engine software. You must create and identify a new database.

NOTES  

• This task covers installation of the first RE in a Liquent Vista domain, and installation of a 
second and consecutive RE in the same domain to increase publishing throughput. If you 
intend to install more than one Rendition Engine in your environment, make sure that each 
installation is completed and that RE is configured before you start the next installation.For 
more information about adding additional RE servers to a Liquent Vista Domain, see the 
FileNet P8 Platform Performance Tuning Guide.

• During the installation, you might be prompted to install additional Microsoft software. 
Specifically, if the .NET Framework 1.1 or XML Parser 4.0 software is not already on your 
server, the Rendition Engine installer will do that installation. See “Setup Status” on page 47.

• After installing RE you should confirm that the necessary macros have been installed to the 
external applications you plan to use for rendering. For information and procedures, see 
“Enable word processing macros for rendering” on page 55.

NOTE If you install a word processing applications after you have installed Rendition Engine 
you must update the application with the required macro files. See “To update applications 
installed after Rendition Engine” on page 56.

To install Rendition Engine

1. Log on to the Rendition Engine server as the <FNRE_Admin> user.

NOTE  Unless otherwise directed use this <FNRE_Admin> account to install and configure all 
the Publishing components.

2. If it isn’t already running, start the Print Spooler Windows service. 

3. Start the Rendition Engine setup wizard.

a. Access the IBM FileNet Rendition Engine installation package.

b. Launch the setup program (\Installer\setup.exe).
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4. Complete the Setup screens as follows:

In this screen... Perform this action...

Customer Information Enter a value in the User Name and Company Name fields, 
select the Anyone who uses this computer (all users) option.

License Agreement Review and accept the license agreement.

Choose Destination 
Location

Accept the default installation location or click Browse to select 
another location.  

NOTE  The installation program creates a Liquent directory at 
the selected location and installs the Records Manager 
software in this directory:

<RE_install_path>\Liquent\

Select the feature you 
want to install

Choose both Administrative Tools and Framework.

Vista License File Browse to and select the Rendition Engine license file. 

NOTE  The license file FileNetP8RenditionEngineLicense.xml is 
located on the IBM FileNet Rendition Engine installation package 
in the \Resources folder. 

Vista User Information Enter the required information for the Vista User 
(<FNRE_Admin>).

• Domain: This field defaults to the domain your server is a 
member of or to the server name of a standalone machine.

• User: Enter the name of the <FNRE_Admin> user. 

NOTE  The User field defaults to the user account with 
which you logged in to the server.

• Password: Enter the <FNRE_Admin> password in the 
password field.

• Confirm Password: Confirm the <FNRE_Admin> password.
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Add Server to an Existing 
Vista Domain

Choose to leave the server as a stand alone device and create 
a new Liquent Vista domain or to add the server to an existing 
Liquent Vista domain.

• If this is the first Rendition Engine, choose Leave as a stand 
alone Server. 

NOTE  This will create a new Liquent Vista domain. Any 
additional Rendition Engine servers can later be joined to 
this Liquent Vista domain.

• If you are installing a second or consecutive Rendition 
Engine to use an already existing Liquent Vista domain, 
choose Add to an Existing Vista domain. Continue with 
“Start Copying Files” on page 47.

Vista Database Type Choose SQL Server or Oracle 9/10. 

Depending on your choice, you will be prompted for additional 
information appropriate on that database type.

NOTE  MSDE and MS Access are not supported for Rendition 
Engine even though they are available in the installer interface.

(SQL Server) SQL 
Server Database 
Information 

WARNING If you enter invalid database user credentials and 
complete the Rendition Engine installation, you must correct 
these using the Domain Manager before you attempt to use 
Rendition Engine. For more information, see the FileNet P8 
Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Change the Rendition 
Engine database password.

Enter the database information:

• Machine: Enter or browse for the machine name where the 
SQL Server database will be created. If you plan to use a 
named instance rather than the default instance, you must 
enter this value: 

<db server name>\<instance name>

• Database: Enter the database name to be created for 
Rendition Engine use.

CAUTION  If this is an upgrade, you cannot use a database 
that was used for an earlier version of Rendition Engine 
software. You must identify a new database.

• User: Enter the <SQL Login> user name.

• Password: This is the <SQL Login> user’s password.

In this screen... Perform this action...
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(Oracle 9/10) Oracle 
Database Information 

WARNING  If you enter invalid database user credentials and 
complete the Rendition Engine installation, you must correct 
these using the Domain Manager before you attempt to use 
Rendition Engine. For more information, see the FileNet P8 
Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Change the Rendition 
Engine database password.

NOTE There is a warning on this screen that you must already 
have the Vista database tables created. All necessary tables 
were created when you executed the Oracle-repository.sql 
script earlier. See “To create a tablespace for Rendition Engine” on 
page 26. 

The user name and password requested here are the ones you 
assigned when you ran that script.

Enter the database information:

• Service: Enter the Oracle service name to use with 
Rendition Engine. 

CAUTION  If this is an upgrade, you cannot use a database 
that was used for an earlier version of Rendition Engine 
software. You must identify a new database.

• User: Enter the name of the <VISTAUSER>.

• Password: Enter the password of the <VISTAUSER>.

Start Copying Files Confirm your selections.

Setup Status The progress bar indicates the status of your installation.

NOTE  At this stage the installer will check for required 
Microsoft software (.NET Framework 1.1 or XML Parser 4.0). If 
the required software is not installed, the Rendition Engine 
installer will perform the necessary installations.

Follow the instructions in the installation wizards that the 
Rendition Engine installer launches.

In this screen... Perform this action...
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(Add to an Existing Vista 
Domain only) Move 
Repository to another 
domain

If you selected Add to an Existing Vista Domain in“Add Server to 
an Existing Vista Domain” on page 46, the installer prompts you for 
information about the existing Liquent Vista domain. 

Specify the machine or the database that hosts the Liquent 
Vista domain that the Rendition Engine will connect to.

• Machine

Name: Select the machine name of the existing Rendition 
Engine that hosts the existing Liquent Vista domain, or 
browse to find the server on the network.

• Database

Database Type: Select the database type used by the 
existing Liquent Vista domain.

– SQL Server/MSDE:

• Machine: Enter or browse for the machine name 
hosting the SQL Server database for the existing 
Liquent Vista domain. 

• Database: Enter the database name of the existing 
Liquent Vista domain.

• User: Enter the <SQL Login> user name.

• Password: This is the <SQL Login> user’spassword.

– Oracle: 

• Oracle Service Name: Enter the Oracle service name 
to use with Rendition Engine.

• Oracle user name: Enter the <VISTAUSER> user 
name.

• Oracle user’s password: Enter the password of the 
<VISTAUSER> user.

Test Database: Click to test the connection to the database.

Create Tables: (Do not use this option) The database has 
already been created.

NOTE  The information you enter here must be the same as 
the information you entered when you installed the first 
Rendition Engine. 

Reboot Request When the file-copy process has completed, select Yes, I want to 
restart my computer now, and click Finish.

In this screen... Perform this action...
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5. When the Rendition Engine server has restarted, log on using the <FNRE_Admin> account.

6. Create a Java Repository on the Content Engine server.

NOTE  Perform this step on the first Rendition Engine server in each Liquent Vista domain 
only. Additional RE servers will use the settings of the Liquent Vista domain they connect to.

a. On the Rendition Engine server, navigate to Start > Programs > Liquent > Domain Manager 
to launch the Domain Manager.

b. Select File > Add Repository… menu, and click Yes in the confirmation pop-up to verify that 
you intend to add a repository to this domain.

c. In the "New Repository Properties" dialog box, complete the following fields:

• Machine: Enter the CE Machine name in the "machine" entry field.

• Platform (drop-down): Select "java" in the "Platform" drop-down list.

• Notify Port: Keep the default value or type in a new value.

• Event Port: Keep the default value or type in a new value.

• Admin Port: Keep the default value or type in a new value.

• File Transfer Port: Keep the default value or type in a new value. 

NOTE  Use the default values in the port fields unless you are collocating RE and CE, in 
which case you must make sure these ports are unique and are not clashing with existing 
CE ports. For a list of the default values, see “FileNet P8 Port Numbers” on page 74.

d. Confirm the new repository by selecting File > Save and clicking Yes in the confirmation pop-
up to verify that you intend to make these changes to the database.

7. (Optional) Set the Rendition Engine Purge and Archive Intervals.

To keep the size of your database down, you should configure RE to regularly purge the RE 
database of old data. You can also keep the default values to archive data once a day, and 
purge the archived data once a week.

a. On the Rendition Engine server, navigate to Start > Programs > Liquent > Domain Manager 
to launch the Domain Manager.

b. In the Configuration tab, right-click the Domain node and select Properties.

c. In the General tab of the Domain Properties dialog box, set the Purge (Default: 7 days) and 
Archive (Default: 1 day) intervals to suit your environment.

8. Configure the BusinessServiceServer service.

NOTE  Perform this step on all Rendition Engine servers in each Liquent Vista domain.

a. Navigate to Start > All Programs > Administrative Tools > Services.

b. Right-click BusinessServiceServer and select Properties.

c. Verify that the Startup type is set to Automatic, and then Stop the service if it is running. 

d. Select the Log On tab.
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e. Select This account and click Browse.

f. For the “Look in” field, leave it at the local server or select the correct domain.

g. Select the proper Rendition Engine user account (<FNRE_Admin>). 

NOTE  Windows cannot set the XML Printer for Rendition Engine as the default printer 
unless you set the Rendition user account (<FNRE_Admin>) for the BusinessServiceServer 
service.

h. Enter and confirm the <FNRE_Admin> user password, and click Apply. 

NOTE  Confirm that the account has been granted the Log On As A Service right.

i. Select the General tab, and click Start to start the service.

j. Click OK to close the BusinessServiceServer Properties window.

k. Close the Services application.

9. Set security on the VistaTempDir shared folder.

NOTE  Perform this step on all Rendition Engine servers in each Liquent Vista domain.

a. On the Rendition Engine server, use Windows Explorer to navigate to the temp folder 
defined for the server (typically drive:\WINDOWS\Temp on Windows 2003).

NOTE  Rendition Engine uses a standard Windows call to check, in order, the environment 
variables TMP, TEMP, and USERPROFILE for the correct value for the Windows temp 
folder, and places the VistaTempDir folder in this directory. 

If no temp folder is set, Rendition Engine will use the Windows program directory.

b. Right-click the \VistaTempDir folder and select Properties.

c. In the VistaTempDir Properties screen, verify that the \VistaTempDir folder is shared. If not, 
select the Sharing tab and select Share this folder. 

d. Select the Security tab and click Advanced. 

NOTE  A missing Security tab usually means that the drive where the \VistaTempDir folder 
is located is not a Windows NTFS partition. See “You must install Rendition Engine on a 
server that has an NTFS drive partition.” on page 14.

e. In the Access Control Settings for VistaTempDir screen, clear Allow inheritance permis-
sions, and then click Remove in the security confirmation pop-up.

f. In the Access Control Settings for VistaTempDir screen, click Add. 

g. In the Select User or Group screen, leave the “Look in” at the local server or select the cor-
rect domain.

h. Select the proper Rendition Engine user account (<FNRE_Admin>).

i. In the Permission Entry for VistaTempDir, give the account all access rights.

j. In the Access Control Settings for VistaTempDir screen, click OK.

k. In the VistaTempDir Properties screen, click OK.
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10. (If you have added a second or consecutive Rendition Engine to your Liquent Vista domain) 
Restart the BusinessServiceServer service.

Every time a Rendition Engine is added to the FileNet P8 Platform domain, you must manually 
restart the BusinessServiceServer services on every Rendition Engine connected to the 
Liquent Vista domain.
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Task 5: Configure Rendition Engine Connection on 
Content Engine
This topic covers the required configuration steps to enable publishing on the Content Engine.

1. Set up Rendition Engine Connection (REC) on the Content Engine.

a. Launch Enterprise Manager as a <GCD administrator user>. See “Authentication Require-
ments” on page 20.

b. Right-click the Enterprise Manager [<p8 domain>] node and select Properties.

c. In the Enterprise Manager [<p8 domain>] Properties screen, select the Publishing tab.

d. Verify that the Enable Dispatcher checkbox is checked.

e. In the Select Rendition Engine Connection Field, click New. 

The Create Rendition Engine Connection wizard opens.

f. In the Enterprise Manager [<p8 domain>] Properties screen, click Apply to save your 
changes. 

In this screen... Perform this action...

Specify the Site Select the site you want to associate with this connection.

Name and Describe the 
Rendition Engine 
Connection

Enter a name and description for your new connection.

Configure the Database Enter the specifics for connecting to the Rendition Engine 
Database. MSSQL default port address is 1433. Username 
is the database connection username.

Database Type: Select MSSQL or Oracle 

Database Server Name: Enter the name of the database 
server.

Database Name: Enter the database name (Microsoft SQL 
Server) or the Service name (Oracle).

Database Server Port: Enter the server port used by the 
database. For default ports, see “FileNet P8 Port Numbers” on 
page 74.

Username: Type in the <SQL Login> (Microsoft SQL Server) 
or Oracle user name (Oracle). See “To create an Oracle 
database” on page 26.

Click Create. 
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g. The newly created <Rendition Engine Connection> will now be listed in the "Select Rendition 
Engine Selection" list box.

h. Click Properties next to the connection to set the password and Connection State. 

i. In the <Rendition Engine Connection> Properties screen, select Set Password and enter the 
password. Click OK, and OK again to set it. 

j. In the <Rendition Engine Connection> Properties screen, Connection State drop-down list, 
select Enabled. 

k. Click Apply, and then click OK to save the changes, and click OK to close the Enterprise 
Manager [<p8 domain>] Properties screen.
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Task 6: Set the site preferences on the Application 
Engine to use path-based URLs
In order to view HTML publication documents, you must first configure the path-based URL 
parameter. 

When Publishing a document to HTML, the resulting HTML publication document will in most 
cases contain references to graphics or other files that are required to correctly display the 
document. If you choose not to use path-based URLs the references in the HTML code can not be 
resolved and the HTML publication documents will not display correctly.

PDF publication documents are self contained and do not require the use of path-based URLs.

To configure the path-based URL parameter

1. Sign in to Workplace as a user assigned the Application Engine Administrators access role. 

2. Choose Admin > Site Preferences.

3. Under General Settings > Application section, set Use path based URLs to Yes.

4. Click Apply to save the setting.

5. Click Exit.
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Task 7: Enable word processing macros for rendering
To enable word processing macros for rendering

In order to support RenderPerfect rendering functionality, such as bookmarking and preserving 
links, Microsoft Word, Corel WordPerfect and Adobe FrameMaker require additional macro files. 
Provided the applications are installed prior to installing RenderPerfect, the macro files are 
automatically copied to the appropriate directories by the RenderPerfect installer.

Complete this section to confirm, and if necessary, enable the macro files. Also, if you install a 
word processing applications after RenderPerfect has been installed, this section describes the 
process for updating the application with the required macro files.

1. Confirm and enable the Microsoft Word macro

a. Open Microsoft Word.

When Word opens, you receive a security warning about the file cdmacros.dot.

b. Select the option Always Trust macros from this publisher.

c. Click Enable Macros to allow the macro to run when Word opens.

d. Choose Tools > Templates and Add-Ins.

e. Under Global templates and add-ins, click cdmacros.dot and at the bottom of the dialog box, 
confirm that the full path for the template is 

<root>:\Program Files\Microsoft Office\<Office version>\STARTUP

f. If the path is incorrect, click Remove to remove the currently loaded cdmacros.dot template, 
and then click Add to add the cdmacros.dot template with the correct directory path.

g. Close Microsoft Word.

2. Confirm and enable Corel WordPerfect

 In Windows Explorer, navigate to \Program Files\WordPerfect Office12\Macros\WPWin and 
confirm that the following macro files exist:

• espsdtoc.wcm

• espsdtoc11.wcm

• espsdtoc12.wcm

• espsdtoc2k.wcm

• espsdtoc9.wcm

• espsrsym.wcm

• espsrsym11.wcm

• espsrsym12.wcm

• espsrsym2k.wcm
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• espsrsym9.wcm

• generate.wcm

• removehf11.wcm

• removehf12.wcm

• removehf2k.wcm

NOTE  Perform these procedure on each repository in a domain.

3. Confirm and enable Adobe FrameMaker

In Windows Explorer, navigate to \Program Files\Adobe\FrameMaker7.1 and confirm that the 
following macro file exists:

• esfmdde.dll

To update applications installed after Rendition Engine

1. In the Domain Manager application, choose File > Configure Applications.

The Configure Applications dialog box opens.

NOTE  A check mark to the left of the check box indicates that the application has been 
updated with the required macro files, and no further action is required.

2. If the box isn’t checked (the macro(s) isn’t installed), check the check box next to the application 
and click OK.

3. Choose File > Save to save your changes.

4. Reopen the dialog box and confirm that a check mark appears to the left of the check box of the 
application you updated.

5. Continue with “Enable word processing macros for rendering” on page 55 for your application.
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Task 8: (Optional) Verify Installation
Successfully completing all the steps below confirms that the basic functionality of RE is working 
and that the application has been correctly installed and configured.

For more information about the RE user interface and the procedures you are working on, use the 
Help links in the RE user interface to access context-sensitive help.

For a more extensive description of how to start using RE past this simple functionality test. See 
the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide Administration > Publishing and 
the Publishing Designer help located at Workplace > Advanced Author Tools > Publishing Designer.

For more details on adding and publishing documents using Workplace, refer to the Workplace 
help topic FileNet P8 Documentation > Workplace > Workplace User Help > Manage Documents.

To verify RE installation

1. Create Publishing Templates.

The FileNet P8 Platform publishing feature is delivered with default style templates for both 
PDF and HTML renditions. You will use those default style templates for this procedure. 

For more information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Create publishing templates.

2. Add and publish a test document.

This procedure shows you how to add and publish a test document to verify that you have 
correctly installed and configured the publishing components. 

For more information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Publish your first document.
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Task 9: Install Service Packs, Fix Packs and Interim 
Fixes for Rendition Engine
Install any Service Packs, Fix Packs, and/or Test Fixes required for Rendition Engine.

To install the Rendition Engine software updates

1. To download the latest software updates, and to determine which of these updates might be 
required for use with other components and expansion products, review the list of releases and 
their associated dependencies in the IBM FileNet Compatability Matrix on the Information 
Management support page (www.ibm.com/software/data/support/). See “Access IBM FileNet Docu-
mentation, Compatibility Matrices, and Fix Packs” on page 12.

2. Open the readmes for the following software updates and perform the installation procedures 
provided:

a. P8RE-4.0.1 Service Pack (or later)

b. Any subsequent Test Fixes (typically optional)

http://www.ibm.com/software/data/support/
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Upgrade Planning and Procedures 

This upgrade section contains the following major tasks:

• “Plan the Upgrade” on page 60.

• “Upgrade Tasks” on page 63.
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Plan the Upgrade
Information for upgrading the Rendition Engine from the 3.5.x release to the 4.0.0 release is 
covered in this topic. The upgrade involves uninstalling and reinstalling the software. 

• You will reinstall Rendition Engine on the existing Rendition Engine servers.

• Rendition Engine 4.0.0 does not use the publishing plugin. This component is uninstalled as 
part of the CE upgrade.

NOTES  FileNet recommends that you plan and test the upgrade on a test system first. Verify the 
upgrade is successful by running functionality and stress tests. After successful verification, 
perform the production upgrade. 

General Requirements
In addition to the general requirements for FileNet P8 RE 4.0.0 that are listed in “Installation 
Planning Considerations” on page 12, the following requirements apply when you upgrade an 
existing RE 3.5.x system to version 4.0.0. 

Third-Party Native Applications
If you plan to upgrade the native applications used by Rendition Engine, you must do this before 
you reinstall Rendition Engine.

Network Considerations
Ensure the availability of required port numbers. For a composite list of port numbers required for 
FileNet P8 4.0.0, see “FileNet P8 Port Numbers” on page 74.

Database Considerations

Updating Database Software
Update to the appropriate database patches before you upgrade Rendition Engine. 

Oracle Clients
Ensure you have applied appropriate Oracle patches to Oracle clients and servers. Be sure that 
clients remote to an Oracle database engine have the same patches as the database server. 
Oracle clients include any machines remote from the Oracle database server where Rendition 
Engine software is installed. Install all required Oracle patches, as specified in the FileNet P8 
Hardware and Software Requirements. To download this guide from the IBM support page, see 
“Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” on page 12.
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RE Database
You will need to identify a new database for use by the 4.0.0 version of Rendition Engine. You 
cannot use existing databases after the upgrade. FileNet recommends that you delete the old 
database and create a new one as part of the upgrade procedure. See “Uninstall Previous Version of 
Rendition Engine” on page 66 and “Upgrade Rendition Engine” on page 68.

NOTE  If you decide to not delete the old database you must:

• (Microsoft SQL Server) Configure the new database using a new name.

• (Oracle) Configure the new tablespace with a new name and a new <VISTAUSER> user.
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Upgrade Overview
This section provides details that will help you prepare your environment for the upgrade of 
Rendition Engine. In many cases, the items you see are links to more detailed information, which 
will help you plan a system upgrade. Please review this information thoroughly before you start to 
upgrade FileNet P8 components or required third-party software.

NOTE

• This guide does not address migrations to different databases or directory services. To 
migrate from one database to another (for example, from a Microsoft SQL Server database 
engine to Oracle), you must contact your service representative to arrange a possible  
Professional Services engagement. 

• The upgrades described in the guide assume that you will:

– retain your basic platform configuration from the previous release. 

– make no changes to user or group definitions during the upgrade.

– apply only the necessary supported software updates and patches, as noted in this guide 
and in the FileNet P8 Hardware and Software Requirements document.
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Upgrade Tasks
To upgrade the Rendition Engine components

1. Gather required information. Do Task 1 “Gather Pre-upgrade Information” on page 64.

2. Prepare your servers for upgrade. Do Task 2 “Uninstall Previous Version of Rendition Engine” on 
page 66.

3. Install RE. Do Task 3 “Upgrade Rendition Engine” on page 68.

4. Install RE fix packs and interim fixes. Do Task 4 “Install Service Packs, Fix Packs and Interim Fixes 
for Rendition Engine” on page 69.
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Task 1: Gather Pre-upgrade Information

Database Engine
• Note your current Database Instance Names, NLS, and character set configurations. 

• You cannot use existing databases for the upgrade. You must identify new databases for use 
by the 4.0.0 version of Rendition Engine. 

Content Engine
• Ensure that you have the necessary local administrator user accounts and passwords to 

perform configuration tasks on the Content Engine server.

• Verify that all object stores you want to use for publishing are configured with the publishing 
add-ons. 

NOTE  In RE 4.0.0, publishing is configured per site rather than per object store. Object stores 
that will be used for publishing must be configured with the Publishing addons. By default, 
these are added when you create an object store, custom stores that aren't configured with 
these add-ons may exist. If necessary you can manually add the add-ons using FileNet 
Enterprise Manager. 

• The publishing templates are upgraded as part of the CE upgrade. 

CAUTION  If your current publishing templates use VBScript Event Actions, these must be 
rewritten in Java before they can be used for RE 4.0.0. Furthermore, the Java class must be 
located on the server; it cannot be on a client and streamed to the server for execution as for 
CE 3.5.x.  The rewrite must be done after the upgrade and before you start using RE. For 
more information on how to rewrite the event actions in Java, see the FileNet P8 Help topic 
FileNet P8 Administration > Content Engine Administration > Events and subscriptions > How to... > 
Work with event actions.

Rendition Engine
• Ensure that you have the necessary local administrator user accounts and passwords to run 

the upgrade program on the Rendition Engine. See “Users Required for Rendition Engine 
Installation” on page 17.

• Verify the security settings for the Rendition Engine temporary directory. 

Before You Begin the Upgrade
• Be sure to read the “What’s New” topic in the FileNet P8 Platform Release Notes. Many of the 

new features may be interesting for your implementation of FileNet P8 Platform. To download 
this guide from the IBM support page, see “Access IBM FileNet Documentation, Compatibility 
Matrices, and Fix Packs” on page 12.
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• Make sure the site has restorable backups of system and data, in case you need to back out of 
the upgrade. For details on what to back up for FileNet P8 components, see the FileNet P8 
Help topic Enterprise-wide Administration > Back up and Restore FileNet P8.

• In some cases it may be necessary for FileNet Engineering and Support personnel to access 
the system for support. To facilitate such access, we request that you implement a reliable 
remote access method.

• Before you begin the upgrade:

– Make sure no users or processes are accessing the FileNet P8 system.

– Complete any pending publishing jobs.

– Disable scheduled automated backups.

– Disable virus scanning.
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Task 2: Uninstall Previous Version of Rendition Engine
Before you can install the 4.0.0 version of Rendition Engine, you must uninstall the previous 
version of the software.

To uninstall the 3.5.x version of Rendition Engine

1. Back up your existing installation.

Rendition Engine does not require backup. In case you need to roll back to the previous 
version of the FileNet P8 Platform and Rendition Engine, you need only reinstall the previous 
version of the software.

NOTE  Some Rendition components such as publishing templates and publishing style 
templates are located on a Content Engine (CE) server and were backed up as part of the 
preparation for CE upgrade.

2. Uninstall existing Liquent Vista Component Server server software.

You must uninstall the existing Liquent Vista Component Server software from all Rendition 
Engine 3.5.x servers before upgrading (re-installing) the publishing components for 4.0.0.

NOTE  The publishing plug-in components are uninstalled as part of the CE 4.0.0 upgrade and 
do not need to be removed.

a. Log on to the server as <FNRE_Admin>.

b. Stop the Vista Component Server BusinessServiceServer service before you uninstall the 
software.

c. Navigate to Start > Settings > Control Panel and double-click Add/Remove Programs.

d. Select FileNet P8 Rendition Engine 3.0.0a/3.5.1and click Change/Remove.

e. Follow the screen prompts to remove the Vista Component Server software.

f. Navigate to Start > Settings > Control Panel and double-click Printers.

g. On the Printers window, delete the printer Liquent XML Printer. Then select File > Server 
Properties.

h. On the Print Server Properties dialog box, select the Ports tab and delete the local ports that 
point to C:\Program Files\Common Files\Liquent\liquent.xml and C:\Program Files\Liq-
uent\Vista\ESPS.PS.

i. Select the Drivers tab, remove the printer driver Liquent XML Printer.

j. (If you uninstalled an RE version prior to 3.0.0a/3.5.1) Run the Vista cleanup tool.

If the version of RE you uninstalled in Step d above was prior to 3.0.0a/3.5.1, you must run 
the cleanup tool provided with the  IBM FileNet Rendition Engine installation package to 
prepare your environment for a new RE installation.

On your RE installation media (versions prior to 3.0.0a/3.5.1):

\Resources\Liquent\Unsupported Apps\Xtent2.0\VistaCleanUtility.exe
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On your RE 4.0.0 installation media:

\Resources\Liquent\Unsupported Apps\Vista2.x\VistaClean.exe

k. Reboot the server.

3. Verify Removal of Native Application Macros.

If the following Microsoft Word macro is present on the Rendition Engine server, remove it:

• cdmacros.dot

If any of the following Word Perfect macros are present on the Rendition Engine server, 
remove them:

• espsdtoc.wcm

• espsdtoc11.wcm

• espsdtoc12.wcm

• espsdtoc2k.wcm

• espsdtoc9.wcm

• espsrsym.wcm

• espsrsym11.wcm

• espsrsym12.wcm

• espsrsym2k.wcm

• espsrsym9.wcm

• generate.wcm

• removehf11.wcm

• removehf12.wcm

• removehf2k.wcm

4. (Optional) Remove the existing RE database.

The RE upgrade includes the creation of a new database for RE use. If you want to use the 
same database name as your previous setup, you must first remove the existing RE database.

CAUTION  (Oracle) If you choose to create new databases using new names, you must modify 
the entries in the Oracle-Repository.sql script with the new information. See “To create an 
Oracle database” on page 26.
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Task 3: Upgrade Rendition Engine
1. Verify that all requirements in “Prerequisite Tasks” on page 22 and its subtasks have been met.

Of specific interest is:

• Create a new Rendition Engine database.

When you upgrade, you cannot use an existing Rendition Engine database. When you 
install and configure the new software, you must also identify a new database for use. 

– For Microsoft SQL server, the database will be created by the installer.

– For Oracle, you must create the database before you install RE. See “To create an Ora-
cle database” on page 26. 

2. (Optional) Upgrade native applications.

If you plan to upgrade the native applications used by Rendition Engine, you must do this 
before you install Rendition Engine.

3. Install the 4.0.0 version of Rendition Engine.

Follow the tasks listed in “Installation Tasks” on page 43 to install Rendition Engine. 
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Task 4: Install Service Packs, Fix Packs and Interim 
Fixes for Rendition Engine
Install any service packs, fix packs or interim fixes required for RE. To determine whether 
additional fixes are needed, contact your service representative
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Remove Software

This topic includes:

• “Remove a Rendition Engine from a Liquent Vista domain” on page 71

• “Remove Rendition Engine Software from a Rendition Engine” on page 71.
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Remove a Rendition Engine from a Liquent Vista 
domain
To uninstall an existing Rendition Engine 4.0.0, you must first remove the server from the Liquent 
Vista domain and then uninstall the software. 

1. Log on to the Rendition Engine server as <FNRE_Admin>.

2. Launch the Domain Manager application.

3. Select the Configuration tab in the left navigation pane. Then expand Domain and Repositories 
to view the server machines in the domain. 

4. Click the machine name to be removed from the Liquent Vista domain. 

5. Select Delete from the Edit menu.

6. Confirm the deletion and select Save from the File menu.

Remove Rendition Engine Software from a Rendition 
Engine
To complete the uninstallation, you must uninstall the Rendition Engine software, remove the local 
printer ports, and remove native application macros. 

1. Log on to the Rendition Engine server as <FNRE_Admin>.

2. Stop the BusinessServiceServer Windows service prior to uninstalling the software. 

a. Navigate to Start > Settings > Control Panel.

b. Double-click Administrative Tools.

c. Double-click Services.

d. Double-click BusinessServiceServer.

e. Click the Stop button. 

3. Remove the Rendition Engine software.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Select FileNet P8 Rendition Engine 4.0.0 and click Change/Remove.

d. Follow the screen prompts to remove the software. At the final screen, click Finish.

4. Remove the printers.

a. Navigate to Start > Settings > Control Panel. Double-click Printers.

b. On the Printers window, select File > Server Properties.
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c. On the Print Server Properties dialog box, select the Ports tab and delete the local ports that 
point to:

<Drive>:\Program Files\Liquent\filenet\liquent.xml 

<Drive>:\Program Files\Liquent\filenet\ESPS.PS

d. Select the Drivers tab and remove the printer driver Liquent XML Printer.

5. Verify removal of native application macros.

If the following Microsoft Word macro is present on the Rendition Engine server, remove it:

• cdmacros.dot 

If any of the following Word Perfect macros are present on the Rendition Engine server, 
remove them:

• espsdtoc.wcm

• espsdtoc11.wcm

• espsdtoc12.wcm

• espsdtoc2k.wcm

• espsdtoc9.wcm

• espsrsym.wcm

• espsrsym11.wcm

• espsrsym12.wcm

• espsrsym2k.wcm

• espsrsym9.wcm

• generate.wcm

• removehf11.wcm

• removehf12.wcm

• removehf2k.wcm

6. Reboot the server.

7. Verify that the Vista software has been removed.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Verify that the FileNet P8 Rendition Engine 4.0.0 entry and the Vista entry have been 
removed.  

d. If the Vista entry is still there, remove it.

i. Select the Vista entry and click Change/Remove.  
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ii. Follow the screen prompts to remove the software. 

iii. At the final screen, click Finish, and reboot the server.

e. Verify that all files are removed from C:\Program Files\Liquent and C:\Program Files\Com-
mon Files\Liquent. 

NOTE If there are files in these directories, delete them manually.

f. Verify that the LIQUENT key has been removed.

i. Select Start > Run.

ii. Type Regedit.

iii. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE.

iv. Verify that the LIQUENT key has been removed.  

NOTE  If the LIQUENT key is there, delete it.

g. Reboot the server.
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FileNet P8 Port Numbers

The table below lists the default port numbers used by Rendition Engine. 

Rendition Engine Ports

Liquent notify port 2868

Liquent event port 2869

Liquent admin port 2870

Liquent file transfer port 2871

Microsoft SQL Server 1433

Oracle 1521
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This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries.
Consult your local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or imply that
only that IBM product, program, or service may be used. Any functionally equivalent product, program,
or service that does not infringe any IBM intellectual property right may be used instead. However, it is
the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or
service.

IBM may have patents or pending patent applications covering subject matter described in this
document. The furnishing of this document does not grant you any license to these patents. You can send
license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some
states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this
statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.
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OPYRIGHT LICENSE:

his information contains sample application programs in source language, which illustrate programming
echniques on various operating platforms. You may copy, modify, and distribute these sample programs
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IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business
Trademarks
Machines Corporation in the United States, other countries, or both. If these and other IBM trademarked
terms are marked on their first occurrence in this information with a trademark symbol (® or ™), these
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was published. Such trademarks may also be registered or common law trademarks in other countries. A
current list of IBM trademarks is available on the Web at ″Copyright and trademark information″ at
www.ibm.com/legal/copytrade.shtml.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other
countries, or both.

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other countries, or
both.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other company, product, and service names may be trademarks or service marks of others.
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