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 Typographical Conventions 6
Typographical Conventions

This document uses the conventions in the following table to distinguish elements of text.

Convention Usage

UPPERCASE Environment variables, status codes, utility names.

Bold Program names and selected terms such as command 
parameters or environment variables that require emphasis.

Bold Gray Clickable user-interface elements (such as buttons).

Bold Olive Paths and file names. 

Italic User-supplied variables and new terms introduced in text, 
names of additional documents (such as IBM FileNet® P8 
Platform Installation and Upgrade Guide).

<italic> User-supplied variables that replace everything between and 
including the angle bracket delimiters (< and >).

Monospace Code samples, examples, display text, and error messages.

NOTE  Some path names in this document that are identical (except for the directory-separator character) 
on both UNIX® and Windows® platforms are specified in UNIX syntax only (that is, with forward-slash 
directory separators).

WARNING  This document contains examples of text to be typed on a command line. Be sure to manually 
type the command, rather than copying and pasting it from this document. Otherwise, your command line 
may contain unrecognized characters and will not execute properly.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Revision Log

The following table identifies changes made to this document since the IBM FileNet P8 3.5.0 
release.

Date Revision

09/08 Updated information about installing in non-English environments in “Installation 
Planning Considerations” on page 10 and “Install and configure FileNet P8 Publishing 
components” on page 25.

08/06 
(3.5.2b)

Repaired a number of broken links.

01/04/06 The topic “Remove Rendition Engine” on page 52 was changed to correct the utility 
name for VistaCleaner.

The topic “Install and configure FileNet P8 Publishing components” on page 25 was 
changed to correct the directory location for the configuration .xml file, and to direct the 
user to choose the Content Engine server from available machines when installing on 
the publishing plug-in server.

10/20/05 
(3.5.1) 

This new standalone FileNet Rendition Engine Installation and Upgrade Guide was 
introduced in release 3.5.1 to replace similar topics once found in the 3.5.0 release of 
the FileNet P8 Platform Installation and Upgrade Guide, 

This 3.5.1 guide incorporates new instructions related to the updated 2.2 version of the 
embedded Liquent RenderPerfect software. 
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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About this Document

Installation by a FileNet® Certified Professional (FCP) Recommended. For more information on 
the FCP program, refer to the IBM® web site (http://www.ibm.com/us), Products > Software > 
Information Management > Training and certification > Professional Certification > FileNet 
Certified Professional Program (FCP).

Every effort has been made to provide you with complete installation instructions. If information 
becomes available after the creation of the documentation release from which you accessed this 
guide, we will provide an updated version of the guide. To download this guide from the IBM 
support page, see “Access IBM FileNet Documentation, Compatibility Matrices, and Fix Packs” on 
page 9. 

Send your comments by e-mail to comments@us.ibm.com. Be sure to include the name of the 
product, the version number of the product, and the name and part number of the book (if 
applicable). If you are commenting on specific text, include the location of the text (for example, a 
chapter and section title, a table number, a page number, or a help topic title).

This guide provides instructions for installing and/or upgrading the IBM FileNet Rendition Engine 
to its current released version. Be aware that each release of a IBM FileNet P8 component or 
expansion product may have multiple service packs, fix packs or interim fixes available for 
installation, each with potentially different dependencies and installation requirements. Therefore, 
before you attempt to install or upgrade IBM FileNet Rendition Engine, review the list of releases 
and their associated dependencies in the IBM FileNet Compatability Matrix on the IBM support 
page (www.ibm.com/software/data/support/). See “Access IBM FileNet Documentation, Compatibility 
Matrices, and Fix Packs” on page 9.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Access IBM FileNet Documentation, Compatibility Matrices, and Fix 
Packs
To access documentation for IBM FileNet products

1. Access the Product Documentation for FileNet P8 Platform support page 
(www.ibm.com/support/docview.wss?rs=3247&uid=swg27010422). 

2. Select the appropriate product link.

To access compatibility matrices and fix packs for IBM FileNet products

1. Access the Fix Packs for FileNet P8 Platform support page 
(www.ibm.com/support/docview.wss?&uid=swg27010146). 

2. From the Fix Pack page:

• To access the compatibility matrix, under FileNet P8 Compatibility Matrices, click Matrix.

• To access the fix pack you need, under a specific product name, click the release number.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Installation Planning Considerations
This section lists details that will help you prepare your environment for the installation of  
Rendition Engine and the Publishing Plug-in components. In many cases, the items you see listed 
will be links to more detailed information. Please review this information thoroughly before you 
start to set up a Rendition Engine or Publishing Plug-in component or required third-party 
software.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE



 General Requirements
About Rendition Engine

11
General Requirements 
FileNet P8 3.5.0 must first be installed and configured and the 3.5.1 service pack must have been 
applied to all components before installing Rendition Engine or Publishing. Follow the installation 
or upgrade tasks provided in the IBM FileNet P8 Installation and Upgrade Guide to either install a 
new 3.5.0 system, or upgrade an existing 3.0.0 system to 3.5.1. After your system is successfully 
running 3.5.1, follow the procedures in this guide to install Rendition Engine and associated 
publishing components.

About Rendition Engine
Rendition Engine is based on the Liquent RenderPerfect software.

Gather auxiliary documentation
NOTE  For general instructions on how to navigate to this and other IBM FileNet product 
documentation on the IBM web site, see “Access IBM FileNet Documentation, Compatibility Matrices, 
and Fix Packs” on page 9.

Before you begin installing the software, retrieve the following documents:

• IBM FileNet Rendition Engine Installation and Upgrade Guide (This document). This 
document provides details on how to install and upgrade Rendition Engine components.

• IBM FileNet P8 Hardware and Software Requirements. This document provides details for all 
FileNet P8 system components, as well as the minimum supported levels of third-party 
software components. The information throughout the IBM FileNet P8 Platform Installation 
and Upgrade Guide assumes you have met all applicable requirements listed in that 
document. 

• IBM FileNet P8 Platform Release Notes. This document provides details on new features, 
known issues, and resolved problems. 

• IBM FileNet P8 Platform Installation and Upgrade Guide. This document provides details for 
installation, upgrade, and configuration of the core components for the FileNet P8 system.

• FileNet P8 Platform user and group security help. 

This help topic provides a complete list of the user and group roles, accounts, and 
responsibilities required to install, configure, and maintain a FileNet P8 system. For more 
information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Security > Users and groups. 

• FileNet P8 Platform Shutdown and Startup. 

This help topic describes how to shut down and restart FileNet P8 Platform components and 
some expansion products. Manual, command line, and some sample batch file procedures are 
provided. For more information, see the FileNet P8 Help topic FileNet P8 Administration > 
Enterprise-wide Administration > Shutdown and Startup. 

• Installing IBM FileNet P8 Platform in a Non-English Environment Technical Notice. This 
document will help you set up the product if your environment is not English-language based. 
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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• IBM FileNet P8 Platform Deployment Guide. This document provides details on how to deploy 
a FileNet P8 system from a staging environment into a full production environment. 

• IBM FileNet P8 Platform Troubleshooting Guide. This document provides troubleshooting 
information on all aspects of the product.

• IBM FileNet P8 Platform Performance Tuning Guide. This document provides performance 
tuning information on all aspects of the product. 

Operating System Considerations

Content Engine
Windows 2003

• Configure MSDTC and COM Security. To create object stores, you must manually configure 
MSDTC and COM Security on all servers running Content Engine and Microsoft® SQL Server 
software. Content Engine uses MSCOM+ technology. When a COM+ application requires a 
transaction to span multiple computers, using MSDTC makes the application more reliable by 
offering a unified mechanism. Content Engine, therefore, uses MSDTC to accomplish 
distributed transactions to achieve consistency, reliability and scalability. Refer to Windows 
Online Help on MSDTC and COM+, or refer to the FileNet P8 Platform 3.5.1 Installation and 
Upgrade Guide.

• Enable Microsoft Internet Information Services (IIS). If you plan to use the Content Engine 
WebDAV Provider, you must ensure that Microsoft Internet Information Services (IIS) software 
is enabled on all Content Engine servers. IIS is enabled by default when you install Windows 
2000, but you must manually install and enable this service under Windows 2003.

Network Considerations
• Ensure static IP addresses. Assign all FileNet P8 servers a static IP address.

• Ensure TCP/IP settings. Verify TCP/IP configuration settings on all UNIX and Windows 
servers and FileNet Enterprise Manager clients.

• Ensure availability of required port numbers. Several port numbers are required by the 
various FileNet P8 components. For a composite list, see “FileNet P8 Port Numbers” on page 53. 

Non-english Environments
Ensure English versions of Microsoft Office. Rendition Engine does not support the use of a 
localized Microsoft Office and Visio suite with the Rendition Engine software. Use English 
versions of the Microsoft Office suite for all Rendition Engine installations and deployments.

Windows Domain Considerations

General
• Consider including all Windows-based FileNet P8 servers in the Windows domain. In this 

regard:
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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– For a list of the components you can install only in a Windows domain, see the following 
topic “Content Engine and Rendition Engine” on page 13.

– For all other FileNet P8 components on Windows servers, FileNet recommends installation 
in the same Windows domain as the Content Engine and Rendition Engine, if only to 
centralize your administrative tasks in the Active Directory environment. The associated 
primary DNS server address on each machine must point to the same DNS server as the 
Content Engine and Rendition Engine.

– You can use a single FileNet Enterprise Manager instance to administer multiple object 
stores as long as they are in a single FileNet P8 domain (i.e., a “deployment” domain). You 
can do this by setting up Terminal Server (with Enterprise Manager installed) on a 
machine in the FileNet P8 domain and running Enterprise Manager remotely, via Terminal 
Server Client, on a single machine. Do not install Terminal Services on any Process 
Engine machine.

• Be aware that FileNet P8 3.5.X does not support multi-forest configurations. 

Content Engine and Rendition Engine
In FileNet P8 production systems, do not install FileNet P8 software on the domain controller 
machine.

• Determine what to install in the Windows domain. You must install the following software 
only on machines that are in the Windows domain:

– Content Engine (all components and services)

– FileNet Enterprise Manager

– Microsoft SQL Server

– Rendition Engine (rendition servers and plug-ins)

• Be aware that you cannot rename Content Engine servers. Name your servers carefully. 
Once you install a Content Engine server component onto a server (Object Store Service, File 
Store Service, or Content Cache Service) and begin using your FileNet P8 system, you cannot 
rename the server.

• FileNet recommends you install the FileNet Rendition Engine component on a dedicated 
server containing no other Content Engine software. This would spread the performance load 
between Rendition Engine and Publishing Plug-in (Content Engine) servers.

• Install the FileNet Publishing Plug-in component only on a Content Engine server containing 
an Object Store Service. 

• If you use Oracle 9i as your Rendition Engine database, you must run the Oracle-
repository.sql script on the database server to create a valid user and tablespace prior to 
performing the following procedures. The script file is located in the \Resources directory in 
the Rendition Engine software package.

– The size requirements for the database and the tablespace are specified in Oracle-
repository.sql.

– Unless publish jobs are routinely archived/deleted, the tablespace will continue to grow (by 
default the tablespace is set to autogrow).
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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– There is no schedule to automatically remove the information in the database. Nor is there 
any need to manually remove information from the database unless the tablespace grows 
larger than desired.

– If you intend to have more than five Rendition Engine servers being supported by the 
Oracle database, contact your FileNet support representative.

• The database used (Microsoft SQL Server or Oracle) can be a local or remote installation. A 
local database can be collocated with either the Publishing Plug-in (Content Engine) or 
Rendition Engine server components.

• Install the publishing components on a machine that has an NTFS drive partition.

• You must have all applications that your users will run to create and render publication 
documents installed on Rendition Engine server(s) to ensure proper MIME type recognition 
(such as Microsoft Word, Excel, PowerPoint, and WordPerfect 2002).

Security Authentication Considerations

General

• Ensure you have a supported LDAP authentication provider. You must have one of the 
following directory services in place for authenticating your FileNet P8 users and groups:

– Microsoft Windows Active Directory

– Novell eDirectory

– Sun Java™ System Directory Server (formerly known as Sun ONE Directory Server)

NOTE You must have Microsoft Windows Active Directory for use by the Content Engine, even 
if your authentication provider for other components is not Active Directory.

• Check required user and group account privileges. For purposes of installing, configuring, 
and running the services for a FileNet P8 system, you must use several user and group 
accounts with particular access privileges. For example:

– In some cases, you must use accounts that FileNet software expects (e.g., the four-
character fnsw local-machine user account that you must allow the Process Engine setup 
program to create).

– In other cases, you can either use the default user and group names presented by the 
FileNet P8 setup programs (e.g., Content Engine’s FNCE_<machinename> user account), 
or you can specify comparable accounts you want to use instead, based on your existing 
security policies and directory service accounts.

NOTE  In the case of Rendition Engine, define a user as discussed in the following help 
topic, where that user is identified as <FNRE_admin>.  Be aware that all references in the 
documentation to this user will be as <FNRE_admin>, however you choose to name that 
user.

For a complete list of these required accounts and privileges, and the system-generated 
default names, see the help topic FileNet P8 Documentation > FileNet P8 Administration > 
Enterprise-wide Administration > Security > Users and groups.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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• Be aware that logons to FileNet P8 applications cannot share user credentials. The fact 
that you log on to FileNet Enterprise Manager does not allow you to access Workplace without 
signing in. However, note that Office Application Integration does honor Workplace sign-ins. 
Also, some functional expansion add-ons that are Workplace integrated will support 
Workplace user tokens, and thus will not require a user to perform another sign-in to access 
Workplace functionality from the functional expansion application.

• For Rendition Engine, note the following:

– User <FNRE_admin>must be a domain user who exists in the local Administrator's group 
on each Rendition Engine and Publishing Plug-in server. This account must be used to 
install and configure the required Liquent third-party software. 

– When you first run Rendition Engine setup program in a Windows domain, you create a 
new Vista domain—an administrative entity, separate from a Windows domain, to manage 
Rendition Engine services. For each subsequent execution of Rendition Engine setup 
program on a machine in the Windows domain, you can either join an existing Vista 
domain or create another Vista domain.

Database Considerations

All platforms
• Determine your local vs. remote database engine preference. The database engine is 

local if it is installed on a server where you will also be installing Content Engine, Process 
Engine and/or Rendition Engine software. The database is remote if it is on a server where no 
Content Engine, Process Engine or Rendition Engine software is installed.  An Oracle 
database must  be remote if it is installed on a Linux® server.

• Determine what type of database engine you want to use. Rendition Engine and publishing 
components support only MS SQL Server and Oracle 9i . Rendition Engines and Content 
Engines within a Vista domain must use the same database.  

Microsoft SQL Server
• Determine whether you want to use a dedicated or shared database. In this regard:

– Content Engine, Process Engine, and Rendition Engine can share a database engine, or 
they can each have a dedicated database engine. 

– Content Engine, Process Engine, and Rendition Engine components can share a MS SQL 
Server instance or they can each have a dedicated instance. You can use the default 
instance or a named instance of your choosing.

– Content Engine, Process Engine, and Rendition Engine must each have their own 
databases. Likewise, functional expansions (such as Process Analyzer) must have their 
own databases.

– Remote MS SQL connections for Rendition Engine are handled by Microsoft Data Access 
Components, which is installed by default on Rendition Engine servers.  There is no need 
to install the MS SQL client software on Rendition Engine server.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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– There is no need to create a SQL database prior to installation of Rendition Engine 
software.  The Rendition Engine installer will prompt for appropriate database information 
and will create the necessary database.

• Verify that a SQL Login exists for Rendition Engine purposes. Under MS SQL Server, you 
must ensure that a SQL Login account exists before you install the first Rendition Engine.  
Initially that user must have the create-database privilege. For SQL Authentication, you can 
use any database user.  You must grant the account the Database Creators roles.

Oracle
General

• Determine whether you want to use a dedicated or shared database. In this regard:

– Content Engine, Process Engine, and Rendition Engine can share a database engine, or 
they can each have a dedicated (i.e., unique) database engine.

– Content Engine, Process Engine, and Rendition Engine can each have a dedicated Oracle 
database instance, or they can share a database instance with one another or with non-
FileNet applications.

– Content Engine, Process Engine, and Rendition Engine must each have their own 
tablespaces. 

• Be aware of database client software requirements. For Rendition Engine if the database 
is remote, you must install database client software on the Rendition Engine server.  While the 
Content Engine also requires installation of the database client software, that installation and 
configuration will have already been completed during installation of the FileNet P8 system.

• Unlike with SQL database, the Rendition Engine installer requires that an Oracle database 
already exists for its use. You will be directed to create that database by executing an Oracle 
SQL script prior to installing the first Rendition Engine.  See “Install Oracle Server for Rendition 
Engine” on page 21 for more information on that script.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Task 1: Create required groups and users
All FileNet P8 environments require a Windows Active Directory domain/forest, including a 
Windows domain controller and Windows accounts that are used for Content Engine services. 
This requirement applies regardless of the authentication provider you use (e.g., Windows Active 
Directory, Sun, or Novell). This task assumes that an authentication provider is properly installed 
and configured.

NOTES

• Under Windows Active Directory authentication, FileNet P8 supports only security groups, not 
distribution groups. Supported groups can have a scope of domain local (as long as they are 
in the same domain as Content Engine), global, or universal.

• The following table lists the user and group accounts needed for installing Rendition Engine 
and Publishing components, including the minimum permissions required.

• For more details on these accounts and the roles and security permissions required for each, 
see the FileNet P8 Platform user and group security help found at: FileNet P8 Administration > 
Enterprise-wide Administration > Security > Users and groups. This help topic provides a 
complete list of the user and group roles, accounts, and responsibilities required to install, 
configure, and maintain a FileNet P8 system

Role/Account Description

<SQL Login>  Any user with SQL Server's “Create Database” 
permission.  Any SQL Server user with SQL 
Server's "Database Creators" server role. 

In SQL Server Enterprise Manager, navigate to 
Security > Logins. Right-click the user's name and 
select Properties. Click the Server Roles tab and 
select at least Database Creators. 

This user is a safer alternative to using SQL 
Server's SA or SYS users, which will also satisfy 
the configuration requirements. (This user is not 
the same as the <FNRE_admin> user.) 

Validate that you can successfully log on to the 
SQL database using this user name and 
password.

<FNRE_Admin> A Windows domain user account that must be 
added to the local Administrators group on all 
Rendition Engine servers.

Permissions: Domain privileges in the Windows 
domain that contains the FileNet P8 domain and 
local administrator privileges on the machine 
where Rendition Engine is installed.

.
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Task 2a: Install Microsoft SQL Server for Rendition 
Engine
This task uses 3rd-party software. Be sure to read all pertinent documentation from the 3rd-party 
software vendor. Contact your system/network/database administrator with 3rd-party vendor or 
environment questions before continuing.

NOTES

• Install Microsoft SQL Server on either the computer where Rendition Engine software will be 
installed (subsequently referred to as a local database) or on a separate server (subsequently 
referred to as a remote database). 

• The Microsoft SQL Server must be in the same Active Directory forest if you want to use 
Windows authentication for connecting to the SQL Server database instance. Otherwise, if 
using SQL Authentication, there is no need to be in the same forest.

• Rendition Engine requires mixed mode authentication (Windows Authentication and SQL 
Server Authentication). 

• The MS SQL instance can optionally be shared by the Content Engine, Process Engine, and 
Rendition Engine components.

• If you are using Microsoft SQL Server with Windows Authentication, a Windows Active 
Directory group account (default: Content Engine Servers) must be configured as a valid 
Microsoft SQL Server Login.

• Database creation for Rendition Engine will be handled automatically when you install and 
configure Rendition Engine.

• You do not need to install MS SQL client software on the Rendition Engine server.

• Record the values for the following settings as you work through the database installation. 
This information must be entered during subsequent installations. Be aware that Process 
Engine Setup allows only alphanumeric characters and underscores.

– Server name

– Instance (e.g. P8_inst)

– TCP/IP port number assigned 

To install and configure Microsoft SQL Server

Refer to Microsoft’s SQL Server 2000 installation instructions, which are available at  
http://www.microsoft.com. In addition, when installing Microsoft SQL Server software:

• Log on as a local user with Administrator privileges on the computer where the database will 
be installed.

• Create a database instance for use by Rendition Engine or Publishing, or verify that such an 
instance already exists. 
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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• If creating a new instance, indicate an appropriate name based on whether Content Engine or 
Rendition Engine will use the instance, and whether the database is local or remote. Be aware 
of the following rules for instance names:

– The name cannot exceed 16 characters

– The first character cannot be numeric or '$

– The name cannot contain special characters, except an underscore or period.

– The name cannot contain spaces

– The name cannot be "Default" or "MSSQLServer"

• Verify a Custom Microsoft SQL Server installation. 

• Verify a Mixed Mode Microsoft SQL Server installation and verify the sa password for your site.

• Verify the Collation Settings. Dictionary order, case-insensitive, for use with 1252 Character 
Set (or any case-insensitive MS-SQL collation) should be used.

• Assign a TCP/IP port number for the instance.

– If your instance is the only instance on the server, you can accept port 1433 (default value) 
in the TCP/IP port number box. If you already have a default or other instance on the 
server, set 0 as the port number to allow dynamic assignment at instance startup, or set a 
specific port number. 

– If the instance is for Content Engine and you have defined a static port number that is 
anything but 1433, you must also follow the steps in “Configure a server alias” on page 20.

• Verify that the required Microsoft SQL Server 2000 Service Pack is installed. See the IBM 
FileNet P8 Hardware and Software Requirements document.

To configure Microsoft SQL Login for Rendition Engine

On the Microsoft SQL database computer, use Microsoft SQL Server Enterprise Manager to 
create a Microsoft SQL Login.

1. Start the Microsoft SQL Enterprise Manager.

2. Expand the Microsoft SQL Server <Server name>[\<Instance name>] node. 

3. Expand the Security folder, right-click Logins and select New Login.

4. Choose SQL Server Authentication and create a new user and password (take note of this 
information for when installing and configuring Rendition Engine and Publishing Plug-in 
components).

5. Grant the SQL login created in the step above the Database Creator server role.

6. Click OK to save the new login.
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Configure a server alias 

If the database instance is for Content Engine and has a static TCP/IP port defined that is 
anything other than the default port 1433, you must take the following steps.

1. On the server that has MS SQL Server installed, determine the TCP/IP port assignment of the 
MS SQL Server instance. 

2. Open the MS SQL Server Client Network Utility application.

3. Select the DB-Library Options tab, de-select Automatic ANSI to OEM conversion. 

4. Select the Alias tab and click the Add button.

5. Select the TCP/IP option from the Network libraries.

6. Uncheck the Dynamically determine port option.

7. Enter the Server alias: (e.g., <server_name>\<instance_name>)

8. Enter the Server name: (e.g.,<server_name>\<instance_name>)

9. Enter the Port number determined during setup. 
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Task 2b: Install Oracle Server for Rendition Engine
The procedures in this task describe how to install and configure an Oracle database that is 
dedicated or shared by one or more of the following FileNet P8 components:

• dedicated to Rendition Engine

• shared by two or more of Content Engine, Process Engine, and Rendition Engine

In the shared configuration, the FileNet P8 components use the same database instance. You can 
also share the database with other (non-FileNet) applications. In the dedicated configuration, the 
Content Engine, Process Engine, and Rendition Engine use separate database instances. 

A database is local if it is on a machine where you will also be installing Content Engine, Process 
Engine, or Rendition Engine. A database is remote if it is on a machine where no Content Engine, 
Process Engine, Rendition Engine is installed.

NOTES

• Perform this task on the UNIX, Linux, or Windows machine that will host the Oracle database 
to be used by the Content Engine, Process Engine, or Rendition Engine.

• Make sure that the machine that will host the database satisfies all pre-installation 
requirements specified in the Oracle 9i installation documentation.

• If the machine where you install the Oracle database will also host an installation of Rendition 
Engine, the machine must meet the Rendition Engine requirements listed in FileNet P8 
Hardware and Software Requirements.  

• Refer to FileNet P8 Hardware and Software Requirements for operating-system service pack 
and Oracle 9i version and patch set requirements. The Oracle patches are available at 
OracleMetaLink. The Oracle patch-installation procedure may be less complicated if done 
before you create any databases.

• If your Oracle database will be remote, then after completing the procedures in this topic you 
must also complete the procedures in “Install Oracle Client for Rendition Engine” on page 24 on 
each machine where you will install Rendition Engine.

To Install an Oracle database engine

The following procedure shows the minimal choices for installing a database engine. Consult the 
Oracle 9i installation documentation for complete preinstallation requirements and instructions. 
The size requirement for a database dedicated to Rendition Engine is specified in the file Oracle-
Repository.sql (located in the Rendition Engine installation software package).

1. Launch the Oracle 9i installer.

2. From the Available Products dialog, select Oracle 9i Database.

3. From the Installation Types dialog, choose the type of Oracle installation. Click Enterprise 
Edition and skip to Step 5, or click Custom (if you don't need all the components in Enterprise 
Edition). 
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4. If you clicked Custom in Step 3, then on the Available Product Components dialog select as a 
minimum the following components to be installed:

• Oracle 9i Server

• Oracle Net Services

– Oracle Net Listener

• Oracle 9i Development Kit

– Oracle Call Interface (OCI)

• (Windows) Oracle Windows Interfaces

– Oracle Services for Microsoft Transaction Server

• Oracle 9i Documentation (recommended)

5. (Windows) From the Oracle Services for Microsoft Transaction Server screen, type a valid port 
number (default: 2030). If Microsoft Transaction Server is not detected on the machine, you will 
be prompted to install it after installing the database engine.

6. From the Create Database dialog, click No to defer creation of a new database. 

7. Follow the steps in the Oracle Net Configuration Assistant to configure the listener.

8. Install the latest Oracle patch sets, as specified in the FileNet P8 3.5.1 Hardware and Software 
Requirements document. 

9. Start the listener and the Oracle database service/processes (Windows/UNIX) if they haven't 
started automatically.

To Create an Oracle database

Oracle documentation describes several ways to create a database, one of them being the 
Database Configuration Assistant (DBCA).

1. Launch DBCA (choose Start > Programs > Oracle - OraHome92 > Configuration and Migration 
Tools > Database Configuration Assistant).

2. On the Welcome screen, click Next.

3. On the Operations screen, click Create a database.

4. When creating the database, specify the following settings:

• Database configuration type

If this database is dedicated to Content Engine, or if it will be shared by Content Engine 
and Process Engine, then Transaction Processing (also known as OLTP) is the required 
configuration type.

• Server process type

Dedicated Server Mode offers better performance than Shared Server Mode.

• Database character set
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Choose a database character set as specified “FileNet P8 Database Character Sets  
in the in IBM FileNet P8 Platform 3.5.1 Installation and Upgrade Guide.

5. On the Creation Options screen, click Create Database.

To create a tablespace for Rendition Engine

Log on as an Oracle administrative user and run the script file Oracle-Repository.sql (located in 
the Rendition Engine installation software package). This script will create a user and tablespaces 
for use by Rendition Engine. These tablespaces are for the exclusive use of Rendition Engine and 
should not be shared with any other FileNet P8 component.

Several parameters in the script could be modified to meet specific business requirements. The 
following table shows those parameters and the default values.  Make note of the actual values 
that are assigned.  Specifically, note the user name and the password that is assigned when the 
script is run.  That user name and password must be supplied later when installing the Rendition 
Engine software.

Parameter Default Value Actual Value Assigned

data tablespace VISTADAT1

index tablespace VISTAIND1

user name VISTAUSER

password none (assigned at 
runtime)

To configure automatic transaction recovery

In a distributed database environment, Oracle MTS Recovery Service (automatically installed with 
Oracle Services for Microsoft Transaction Server) can resolve in-doubt transactions on the 
computer that started the failed transaction.

To enable automatic transaction recovery, perform the tasks shown in the section "Scheduling 
Automatic Microsoft Transaction Server Recovery" in Oracle Services for Microsoft Transaction 
Server Developer's Guide (Oracle Part Number A95496-01).

In addition, if you are using an Oracle Fail Safe configuration, perform the procedure shown in 
“Modifying Registry Values for Oracle Fail Safe Configurations” in Oracle Services for Microsoft 
Transaction Server Developer's Guide (Oracle Part Number A95496-01).

To edit the listener.ora file

Use the Oracle utilities to configure the listener, which creates the listener.ora file.
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Task 2c: Install Oracle Client for Rendition Engine
The procedure in this task describe how to install the Oracle Client software to prepare for the 
installation of Rendition Engine.

NOTES

• Install Oracle Client on any machine that will host Rendition Engine, or any other FileNet P8 
component that needs to access an Oracle database.

• Make sure that the machine where you will install Oracle Client satisfies all pre-installation 
requirements specified in the Oracle 9i installation documentation.

• Refer to FileNet P8 Hardware and Software Requirements for operating-system service pack 
and Oracle 9i version and patch set requirements.

To install the Oracle client

The following procedure shows the minimal choices you need for installing Oracle Client. Consult 
the Oracle 9i installation documentation for complete instructions and pre-installation 
requirements.

1. Log on with an appropriate local account to install and configure the Oracle Client software.

NOTE It is strongly recommended that you log on to the machine locally (not via a Windows 
domain) to install the Oracle Client software.

2. If the machine where you are installing Oracle Client does not use DNS to resolve host names, 
place in its hosts file the IP address of the machine where the Oracle database is installed.

3. Launch the Oracle 9i Client installation.

4. From the Available Products dialog, click Oracle 9i Client.

5. From the Installation Types dialog, click Administrator or Custom.

6. If you clicked Custom, select the following components from the list in the Available Product 
Components dialog: 

• Oracle 9i Client

• Oracle Network Utilities

• Oracle Database Utilities

• SQL*PLUS

• Microsoft Transaction Server (MTS)

7. Using Oracle Net Configuration Assistant, test the connection to the Oracle database server 
with the user name and password created in “To create a tablespace for Rendition Engine” on 
page 23. 

8. Install all required Oracle patches, as specified in the IBM FileNet P8 Hardware and Software 
Requirements document. These patches are available at OracleMetaLink.
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Task 3: Install and configure FileNet P8 Publishing 
components
This task includes installing and configuring the FileNet Publishing components:

• FileNet Rendition Engine

• FileNet Publishing Plug-in (collocated on Content Engine servers)

Topic Install or configure on:

To create the Publishing user account Windows Domain Controller or 
other server configured to modify 
domain-wide accounts.

To configure Publishing user account Rendition Engine and Plug-in 
servers (Content Engine)

To configure native applications.  There are a 
number of additional topics related to configuring 
native applications, generally broken out by 
application.

Rendition Engine servers (all)

To install Publishing software on the first 
Rendition Engine

Rendition Engine server (first)

To test the connection to the database Rendition Engine and Plug-in 
servers (Content Engine)

To configure the BusinessServiceServer service Rendition Engine and Plug-in 
servers (Content Engine)

To set security on VistaPubDir shared folder Rendition Engine and Plug-in 
servers (Content Engine)

To install Publishing software on the Publishing 
Plug-in server

Publishing Plug-in server (Content 
Engine)

To create folders to be used by publishing Plug-in servers (Content Engine)

To configure the Service Controller Plug-in servers (Content Engine)

To create Publishing Templates Using Workplace

To add and publish a test document Using Workplace

To add additional Rendition Engine or Publishing 
Plug-in servers

any additional Rendition Engine or 
Publishing Plug-in servers 
(Content Engine)

The following table shows on what machine(s) each of the following topics should be run:
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This procedure is designed to first install and configure a single Rendition Engine server, then 
install and configure a single Publishing Plug-in server.  It is possible to configure multiple 
Rendition Engine and Publishing Plug-in servers. To do that, some steps will need to be repeated 
on those additional servers.  For the additional servers, there will be some variations in the steps. 
Information specific to adding additional servers is detailed at the end of this procedure.

NOTES

• The Rendition Engine server must be a member of the same Windows domain that contains 
the Content Engine server.

• To ensure that the Liquent-based Rendition Engine properly converts MS Word and MS Excel 
documents containing hyperlinks, external links, image links, etc., set the Web Options check 
box “Use long file names whenever possible” presented in the Tools or Properties of those 
applications.

For example, in MS Word 2000 choose Tools > Options and click Web Options. In the Files tab 
set the Web Options check box “Use long file names whenever possible”. Do this wherever the 
MS Office applications reside — on the Rendition Engine server and on each client machine 
from which source documents are added and rendering is initiated. By default, MS Office 2000 
has this Web Options check box cleared, while MS Office 2003 and MS Office XP have it set.

Be aware that under MS Office 2000 only, if you open an MS Word document that has this 
Web Options check box cleared, that setting will be used during the publishing operation even 
if the Web Options check box in your client Office 2000 application is set by default. This 
override does not occur under MS Office 2003 or MS Office XP.

• Ensure English versions of Microsoft Office. Rendition Engine does not support the use of a 
localized Microsoft Office and Visio suite with the Rendition Engine software. Use English 
versions of the Microsoft Office suite for all Rendition Engine installations and deployments.

• When you add a new Rendition Engine or Publishing Plug-in server to a FileNet P8 domain, 
you must manually restart the BusinessServiceServer service on all existing Rendition Engine 
and Publishing Plug-in servers.

• You may be prompted to install additional Microsoft software.  Specifically, if the .NET 
Framework 1.1 or XML Parser 4.0 software is not already on your server, the Rendition Engine 
installer will do that installation. 

• If you will be installing with an Oracle database, you will be prompted for the user name and 
password assigned in “Install Oracle Server for Rendition Engine” on page 21, in the section 
covering “To create a tablespace for Rendition Engine” on page 23.

To create the Publishing user account 

From the domain controller (or other server within the Windows domain that is configured to 
modify Users and Groups), run the Windows Active Directory Users and Computers snap-in to 
create the following domain user account (if the account does not already exist):

• <FNRE_admin>
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To configure Publishing user account

On all servers where you intend to install Publishing components (Publishing Plug-in servers and 
Rendition Engine servers that will contain the publishing software), log on as a local administrator 
and add the domain\<FNRE_admin> account to the local Administrators group. To do so, right-
click the My Computer icon on the desktop and select Manage.

To configure native applications

You must change the following native application configuration settings on the Rendition Engine 
server where you will publish documents.  See the specific steps below for any of the applications 
that apply to your environment.

To configure Microsoft Word 2000, 2003, and XP

1. Prior to installing Rendition Engine software, ensure the following folders contain no files:

\Program Files\Microsoft Office\Office\Startup 

\Program Files\Microsoft Office\Office\XLStart 

2. In Microsoft Word, choose Tools > Options > View and uncheck the following options:

• Startup Task Pane

• Highlight

• Status Bar

• Screen Tips

• Smart Tags

• Animated Text

• Windows in Taskbar

• Field Codes

• Hidden Text

• All

• Background Colors and Images (Version 2003)

3. Select the General tab and uncheck the following:

• Provide feedback with Animation

• Confirm conversion at Open

• Update automatic links at Open

• Mail as attachment

• Automatically create drawing canvas when inserting AutoShapes

• Allow starting in reading layout (Version 2003)
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4. Select the Edit tab and uncheck the following:

• Typing replaces selection

• Drag-and-drop text editing

• Use smart paragraph selection

• Use CTRL + Click to follow hyperlink

• When selecting, automatically select entire word

• Keep track of formatting

• Show paste Options buttons

• Smart cut and paste

• Use smart cursoring (Version 2003)

5. Select the Print tab and uncheck the following:

• Update fields

• Allow A4/Letter paper resizing

• Background printing

• Field Codes

• Hidden Text

• XML Tags (Version 2003)

• Background Colors and Images (Version 2003)

6. Select the Save tab and uncheck the following:

• Allow fast saves

• Allow background saves

• Save AutoRecover info every:

• Embed smart tags

7. Select the Spelling & Grammar tab and uncheck the following:

• Check spelling as you type

• Always suggest Corrections

• Check grammar as you type

• Check grammar with spelling

To configure Microsoft Excel

1. In Microsoft Excel, choose Tools > Options > View and uncheck the following options:

• Startup Task Pane
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• Status Bar

• Windows in Taskbar

• List Data Validation (Version 2003)

2. Select the General tab and uncheck the following:

•  Function tooltips

3. Select the Edit tab and uncheck the following:

• Show paste Options buttons

• Show Insert Options buttons

• Ask to update automatic links

• Provide feedback with animation

4. Select the International tab and uncheck the following:

• Allow A4/Letter paper resizing

5. Select the Save tab and uncheck the following:

• Save AutoRecover info every:

6. Select the Error Checking tab and uncheck the following:

• Enable background error checking

To configure Microsoft PowerPoint

1. In Microsoft PowerPoint, choose Tools > Options > View and uncheck the following options:

• Startup Task Pane

• Slide Layout task pane when inserting new slides

• Status Bar

• Windows in Taskbar

• Popup menu on right mouse click (Version XP)

• Show menu on Right Click (Version 2003)

• End with blank slide

2. Select the General tab and uncheck the following:

• Provide feedback with sound to screen elements

3. Select the Edit tab and uncheck the following:

• Show paste Options buttons

• Use smart cut and paste

• When selecting, automatically select entire word
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• Drag-and-drop text editing

4. Select the Print tab and uncheck the following:

• Background printing

5. Select the Save tab and uncheck the following:

• Allow fast saves

• Save AutoRecover info every:

6. Select the Spelling and Style tab and uncheck the following:

• Check spelling as you type

• Always suggest corrections

To configure Microsoft Project

1. In Microsoft Project, choose Tools > Options > View and uncheck the following options:

• Project Screen tips

2. Select the General tab and uncheck the following:

• Show startup Task Pane

• Advice from Planning Wizard

• Automatically add new resources and tasks

3. Select the Edit tab and uncheck the following:

• Ask to update automatic links

4. Select the Scheduling Options tab and uncheck the following:

• Show scheduling messages

5. Select the Spelling Options tab and uncheck the following:

• Always suggest

To configure Microsoft Visio

1. In Microsoft Visio, choose Tools > Options > Save Options and uncheck the following options:

• Prompt for document properties

• Save preview with file

• Show XML file save warnings (Version 2003)

• Show XML file open warnings (Version 2003)

2. Select Spelling Options and uncheck the following:

• Check spelling as you type
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• Ignore words with number should be checked

To configure WordPerfect

1. In Corel WordPerfect, choose Tools > Settings.

2. Choose Settings > Environment > Prompts and set the following options:

• Confirm Deletion of Table Formulas (Deselect)

• Beep on Hyphenation (Deselect)

3. Choose Settings > Environment>  Interface and set the following options:

• Save workspace > Never (Select)

• Quick Tips (Deselect)

4. Choose Settings > Files > Documents and set the following options:

• Timed document backup every (Deselect)

• Use Enhanced File Dialogs (Deselect)

5. Choose Tools > Proofread and set the following options:

• Prompt as you go (Deselect)

• Off (Selected)

6. Choose Tools >  Workplace Manager and set the following options:

• Show at Startup (Deselect)

For information on these options, see your WordPerfect documentation.

To Configure WordPerfect Office 12

For WordPerfect Office 12, you must disable the Corel Office DAD system tray icons and remove 
CorelCentral from the Startup folder.

To disable the Corel Office DAD components

1. In the System tray, right-click on any of the DAD icons.

2. Deselect Display DAD on Startup.

3. Select Exit DAD.

Additional native application configuration

You must change the following Microsoft Office configuration setting on the Rendition Engine 
server in any Office application in which you will publish documents. This ensures that hyperlinks 
are not updated but kept relative. If this is not done, a document with an HTML link would point 
back to the location where the source document was copied during publishing.

NOTE  This change will take effect on all installed Microsoft Office applications.
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Perform this procedure on all Rendition Engine servers:

1. Open all native applications (Word, Excel, etc.) at least once. The first time you start the 
application, from the Office Assistant, select to Start the program.

2. Open Microsoft Word or other supported Microsoft Office (Excel, PowerPoint) application.

3. From the menu bar, choose Tools > Options...

4. Select the General tab.

5. Click the Web Options... button.

6. Select the Files tab.

7. Uncheck the Update links on save item.

8. Click OK.

9. Click OK.

10. Close the application.

To install Publishing software on the first Rendition Engine

Perform this procedure on the Rendition Engine server.  First install and configure the publishing 
software on the Rendition Engine server, then install and configure the publishing software on the 
Publishing Plug-in server. 

1. Log on as the <FNRE_admin> user.

NOTE  Use this <FNRE_admin> account to install and configure all the Publishing 
components, unless otherwise directed.

2. If it isn’t already running, start the Print Spooler service. 

3. Access the Rendition Engine software package and start the \Install\setup.exe program.

Do not run this setup program on multiple servers concurrently.

CAUTION  If you enter invalid database user credentials and complete the Rendition Engine 
installation, you will not be able to enter them correctly later.  Instead, you will have to 
uninstall and reinstall Rendition Engine.

In this screen... Perform this action...

Customer Information Enter a value in the User Name and Company Name fields, 
select the Anyone who uses this computer (all user) option, and 
click Next.

License Agreement Review and accept the license agreement for FileNet P8 
software products and then proceed with the installation.

Choose Destination 
Location

Accept the default installation location and click Next. 

NOTE You can click Browse and change the destination folder 
location.
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Select the features you 
want to install

Choose the default to install Administrative Tools and 
Framework and click Next.

Vista License File Browse to the location of the license file.  It is located in the 
Rendition Engine software package in the Resources directory. 
Click Open. Click Next.

Vista User Information • The Windows Domain field should default to the domain that 
this server is a member of.

• The User field should default to <FNRE_admin>.  If it does 
not, correct it.

• Enter the <FNRE_admin> password in the password field.

• Confirm the <FNRE_admin> password and click Next.

Add Server to an Existing 
Vista Domain

Because this is the first Rendition Engine, choose Leave as a 
stand alone Server and click Next. This will create a new Vista 
domain.  The Publishing Plug-in server and any additional 
Rendition Engine servers will later be joined to this Vista 
domain.

Vista Database Type Choose either Microsoft SQL or Oracle 9i.  Depending upon 
your choice you will be prompted for additional information 
appropriate to that database type

Oracle Database 
Information (displays if 
you chose Oracle 9i)

• Oracle Service Name

NOTES  

• If this is an upgrade you can not use a database that was 
used for an earlier version of Rendition Engine software.  
You must identify a new database.

– Oracle user name

– Oracle user’s password

– Click Next.

• There is a warning on this screen that you must already 
have the Vista database tables created.  All necessary 
tables were created when you executed the Oracle-
repository.sql script earlier.  The user name and password 
requested here are those that were assigned when that 
script ran.

In this screen... Perform this action...
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4. Once the file-copy process has completed, select Yes, I want to restart my computer now, and 
click Finish.

5. Once the Content Engine/Publishing Plug-in server has restarted, log back on as the 
<FNRE_admin> account.

6. Browse to the installation directory.  The default installation location is Program 
Files\Liquent\filenet. Execute the file called RP22-VistaConfig.exe.  

7. In the Configuration File field, browse to the Resources subdirectory in the Rendition Engine 
installation software package and select FileNetP8RenditionEngineConfig.xml. 

8. From the Available Machine Configurations list, choose Rendition Engine Server and click 
Select.

9. Launch the Microsoft Word application.

10. Check the Always trust... checkbox. Then click Disable Macros. 

To test the connection to the database

Perform the following steps on the Rendition Engine server. 

1. Select Start > All Programs > Liquent > Domain Manager.

2. Right click on the Domain node.

3. Select Properties.

4. Select the Database tab.  

SQL Database 
Information (displays if 
you chose Microsoft SQL 
Server)

• Machine Name: Enter the machine name where the SQL 
Server database will be installed.  If you will use a named 
instance rather than the default instance, that value should 
be entered here too.  Enter the value in the following format:

machine name \<instance name>

• Database name: Enter the database name to be created for 
Rendition Engine use.

NOTE If this is an upgrade you can not use a database that was 
used for an earlier version of Rendition Engine software.  You 
must identify a new database.

• User name: This is a SQL Server user name.

• Password:  This is the SQL Server user’s password.

• Click Next.

Start Copying Files  Confirm your settings and click Next.

In this screen... Perform this action...
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5. Click the Test Database button. You should receive a message saying the connection was 
successful.

6. Click OK once the test is completed.

To configure the BusinessServiceServer service

Perform this procedure on the Rendition Engine server.

1. Select Start > All Programs > Administrative Tools > Services.

2. Right-click BusinessServiceServer and select Properties.

3. Set Startup type to Automatic, and then Start the service.

4. Click the Log On tab.

NOTE Windows cannot set the XML Printer for Rendition Engine as the default printer unless 
you set the Rendition user account (<FNRE_admin>) for the BusinessServiceServer service.

5. Select This account and click Browse.

6. For the Look in field, select the correct domain.

7. Select the proper Rendition Engine user account (<FNRE_admin>) and password, then click OK.

NOTE If prompted that the account has been granted Log On As A Service right, click OK.

8. Click OK if prompted that the new logon name will not take effect until you stop and restart the 
service, otherwise, click OK to close the BusinessServiceServer Properties window.

9. Right-click the BusinessServiceServer service and click Restart.

10. Close the Services application.

NOTE When a Rendition Engine or Publishing Plug-in server is added to the FileNet P8 
Platform domain, the BusinessServiceServer services must be manually restarted on every 
Rendition Engine and Publishing Plug-in server.

To set security on VistaTempDir shared folder 

Perform this procedure on the Rendition Engine server.

1. Run Windows Explorer and open the temp folder defined for the server (typically 
drive:\WINNT\Temp on Windows 2000, drive:\WINDOWS\Temp on Windows 2003.

NOTE To determine the location for the temp folder, Rendition Engine uses a standard 
Windows call that checks, in order, the environment variables TMP, TEMP, and 
USERPROFILE. If no values are found, use the Windows program directory.

2. Right-click the \VistaTempDir folder and select Properties.

3. Verify the \VistaTempDir folder is shared. If it is not, select the Sharing tab and select Share this 
folder. 

4. Select the Security tab and click Advanced.  
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NOTE  A missing Security tab generally means that the drive where the \VistaTempDir folder is 
located, is not a Windows NTFS partition.

5. Uncheck Allow inheritance permissions, and then click Remove.

NOTE  On Windows 2003, you must click the Advanced button to see the checkbox.

6. Add the <FNRE_admin> and Content Engine Servers accounts.

7. Give the accounts Full Control access rights.

8. Click Apply and then OK.

9. Close all programs.

To install Publishing software on the Publishing Plug-in server

Perform this procedure on the Publishing Plug-in server.

1. Log on as the <FNRE_admin> user.

2. If it isn’t already running, start the Print Spooler service. 

3. Access the Rendition Engine software package and start the \Install\setup.exe program.

Do not run this setup program on multiple servers concurrently.

CAUTION  If you enter invalid database user credentials and complete the Rendition Engine 
installation, you will not be able to enter them correctly later.  Instead, you will have to 
uninstall and reinstall Rendition Engine.

In this screen... Perform this action...

Customer Information Enter a value in the User Name and Company Name fields, 
select the Anyone who uses this computer (all user) option, and 
click Next.

License Agreement Review and accept the license agreement for FileNet P8 
software products and then proceed with installation

Choose Destination 
Location

Accept the default installation location and click Next. 

NOTE  You can click Browse and change the destination folder 
location.

Select the features you 
want to install

Choose the default to install Administrative Tools and 
Framework and click Next.

Vista License File Browse to the location of the license file.  It is located in the 
Rendition Engine software package in the Resources directory. 
Click Next.
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4. Once the file-copy process has completed, select Yes, I want to restart my computer now, and 
click Finish.

5. Once the Rendition Engine server has restarted, log back on as the <FNRE_admin> account.

6. Browse to the installation directory.  The default installation location is Program 
Files\Liquent\filenet. Execute the file called RP22-VistaConfig.exe.   

7. In the Configuration File field, browse to the Resources subdirectory on the installation software 
package and select FileNetP8RenditionEngineConfig.xml. 

8. From the Available Machine Configurations list, choose Content Engine Server and click Select.

To test the connection to the database 

Perform the following steps on the Publishing Plug-in (Content Engine) server. 

1. Select Start > All Programs > Liquent > Domain Manager.

2. Right click on the Domain node.

3. Select Properties.

4. Select the Database tab.  

5. Click the Test Database button. You should receive a message saying the connection was 
successful.

Vista User Information • The Windows Domain field should default to the domain that 
this server is a member of.

• The User field should default to <FNRE_admin>. If it does 
not, correct it.

• Enter the <FNRE_admin> password in the password field.

• Confirm the <FNRE_admin> password and click Next.

Add Server to an Existing 
Vista Domain

Choose Add to an existing domain. 

Start Copying Files Confirm your settings and click Next.

Move Repository Join the existing Vista Domain by choosing your database type 
and entering appropriate database information as entered in the 
Database Type dialog when the first Rendition Engine was 
installed.  See “Vista Database Type” on page 33, “Oracle Database 
Information (displays if you chose Oracle 9i)” on page 33, and “SQL 
Database Information (displays if you chose Microsoft SQL Server)” 
on page 34 for more information.  The information entered here 
must be the same as you entered when installing the first 
Rendition Engine.  Click OK and files will continue copying.

In this screen... Perform this action...
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6. Click OK once the test is completed.

To configure the BusinessServiceServer service

Perform the following steps on the Publishing Plug-in (Content Engine) server. 

1. Select Start > All Programs > Administrative Tools > Services.

2. Right-click BusinessServiceServer and select Properties.

3. Set Startup type to Automatic, and then Start the service.

4. Click the Log On tab.

NOTE Windows cannot set the XML Printer for Rendition Engine as the default printer unless 
you set the Rendition user account (<FNRE_admin>) for the BusinessServiceServer service.

5. Select This account and click Browse.

6. For the Look in field, select the correct domain.

7. Select the proper Rendition Engine user account (<FNRE_admin>) and password, then click 
OK.

NOTE If prompted that the account has been granted Log On As A Service right, click OK.

8. Click OK if prompted that the new logon name will not take effect until you stop and restart the 
service, otherwise, click OK to close the BusinessServiceServer Properties window.

9. Right-click the BusinessServiceServer service and click Restart.

10. Close the Services application.

NOTE  When a Rendition Engine or Publishing Plug-in server is added to the FileNet P8 
Platform domain, the BusinessServiceServer services must be manually restarted on every 
Rendition Engine and Publishing Plug-in server.

To set security on VistaTempDir shared folder  

Perform the following steps on the Publishing Plug-in (Content Engine) server. 

1. Run Windows Explorer and open the temp folder defined for the server (typically 
drive:\WINNT\Temp on Windows 2000, drive:\WINDOWS\Temp on Windows 2003.

NOTE To determine the location for the temp folder, Rendition Engine uses a standard 
Windows call that checks, in order, the environment variables TMP, TEMP, and 
USERPROFILE. If no values are found, use the Windows program directory.

2. Right-click the \VistaTempDir folder and select Properties.

3. Verify the \VistaTempDir folder is shared. If it is not, select the Sharing tab and select Share this 
folder. 

4. Select the Security tab and click Advanced.  

NOTE A missing Security tab generally means that the drive where the \VistaTempDir folder is 
located, is not a Windows NTFS partition.
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5. Uncheck Allow inheritance permissions, and then click Remove.

NOTE  On Windows 2003, you must click the Advanced button to see the checkbox.

6. Add the <FNRE_admin> and Content Engine Servers accounts.

7. Give the accounts Full Control access rights.

8. Click Apply and then OK.

9. Close all programs.

To create folders to be used by publishing

In order to publish to either PDF or HTML formats, you must first configure the FileNet P8 Platform 
environment for publishing by creating folders to support publishing.

From a Publishing Plug-in server (Content Engine server or FileNet Enterprise Manager only 
machine):

1. Open the FileNet Enterprise Manager and log on as a FileNet P8 domain administrator.

2. Create or navigate to the object store to be used for publishing.

From the Root folder or other subfolder of the object store, create the following folders:

• Templates 

• Documents 

• Published 

• Published\PDF 

• Published\HTML 

To configure the Service Controller

From a Publishing Plug-in server (Content Engine server) where the Service Controller is 
installed:

1. Select Start > Programs > FileNet P8 Platform > Publishing > Service Controller and log on as a 
FileNet P8 domain administrator if prompted.

2. In the Services drop-down, select the Publishing PDF Plug-in Service.

3. Click Start and select (check) the Auto start service when OS starts option.

4. Click the Select... button.

NOTE This process may take some time depending on the number of object stores in the 
system that have Style Templates associated with them.

5. Once the Add/Remove Object Stores dialog box opens, move all of the publishing object stores 
to the Select Object Stores pane and click OK.

6. Click Yes to restart the service.
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7. Perform Step 2 through Step 6 for the HTML Plug-in.

8. Exit the Service Controller.

To create Publishing Templates

You will use the FileNet P8 Workplace to create publish templates for PDF and HTML renditions. 

The FileNet P8 Platform publishing feature is delivered with default style templates for both PDF 
and HTML renditions. You will be using those default style templates for this procedure. After you 
have completed these publishing procedures, you may want to read the Publishing Designer help 
located at FileNet P8 Documentation > Workplace > Advanced Author Tools > Publishing Designer for 
more details.

NOTE The sample object store and subfolder names used in this procedure were created in the 
previous procedure. If you made changes to the object store folder or subfolder names, substitute 
the names you used.

From a server that can access FileNet P8 Workplace:

1. Open Workplace and sign in as a FileNet P8 domain administrator.

2. Select Author and then select Advanced Tools.

3. Click Publishing Designer. At the Security dialog, choose Always.

NOTE This dialog only displays the first time you click Publishing Designer.

4. From the Object Store to host publish operation using this template drop-down, select the 
Publishing Object Store (or other object store to be use for publishing).

5. From the Destination Folder object, click Browse and select the Published\PDF subfolder and 
click Select.

6. Under Optional Settings, select Use a Style Template to transform the content, select the 
Default PDF Style Template and click OK.

7. Click the Add New...(+) button.

8. Click Browse and navigate to the published document Templates folder.

9. Click Select and then click Next.

10. Enter Publish Template Properties (Document Title and Description) and click Next.

11. Verify the Security Settings and click Finish.

12. Perform Step 4 through Step 11 for the HTML Publish Template.

NOTE In Step 5 and Step 6, be sure to browse to the Published\HTML subfolder and select the 
default HTML Style Template.

13. From the Publishing Designer, select File > Exit.

14. Close your browser window.
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To add and publish a test document

This procedure shows you how to add and publish a test document. This provides you a quick way 
to verify that you have correctly installed and configured the publishing components. For more 
details on adding and publishing documents through Workplace, refer to the Workplace help topic 
FileNet P8 Documentation > Workplace > Workplace User Help > Manage Documents.

1. Set the site preferences on the Application Engine to use path-based URLs:

a. Sign in to Workplace as a member of the Application Engine Administrators group.

b. Choose Admin > Site Preferences.

c. Under General Settings > Application section, set Use path based URLs to Yes.

d. Click Apply to save the setting.

e. Click Exit.

NOTE If you choose not to use path-based URLs, graphics and other internal references will 
not be resolved when viewing documents that have been published to HTML.

2. Add a test document to publish, as follows:

a. Open Workplace and sign in as FileNet P8 domain administrator.

b. Select Author and then select the General Tools.

c. Click Add Document.

d. Click the Publishing object store.

e. Click the Documents subfolder.

f. Click Next twice.

g. Enter the Document Title and click Next.

NOTE If you do not enter the document title, Workplace will default to the file name.

h. At Security Settings dialog, click Next.

i. Browse for the document and select Open, then click Finish.

j. Click OK.

3. Publish the test document, as follows:

a. In Workplace under Browse, click the object store.

b. Click the Documents folder.

c. Right-click the document and select Publish.

d. Click Publish New.

e. Click Select under the PDF (or HTML) template.

f. Click Next.
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g. Click Finish.

4. Go to the destination folder defined above in “To create Publishing Templates” on page 40 and 
verify that the document was successfully published.

To install additional Rendition Engine or Publishing Plug-in Servers

1. Log on as the <FNRE_admin> user.

2. If it isn’t already running, start the Print Spooler service. 

3. Access the Rendition Engine software package and start the \Install\setup.exe program.

Do not run this setup program on multiple servers concurrently.

CAUTION  If you enter invalid database user credentials and complete the Rendition Engine 
installation, you will not be able to enter them correctly later.  Instead, you will have to 
uninstall and reinstall Rendition Engine.

In this screen... Perform this action...

Customer Information Enter a value in the User Name and Company Name fields, 
select the Anyone who uses this computer (all user) option, and 
click Next.

License Agreement Review and accept the license agreement for FileNet P8 
software products and then proceed with installation

Choose Destination 
Location

Accept the default installation location and click Next. 

NOTE You can click Browse and change the destination folder 
location.

Select the features you 
want to install

Choose the default to install Administrative Tools and 
Framework and click Next.

Vista License File Browse to the location of the license file.  It is located in the 
Rendition Engine software package in the Resources directory. 
Click Next.

Vista User Information • The Windows Domain field should default to the domain that 
this server is a member of.

• The User field should default to <FNRE_admin>.  If it does 
not, correct it.

• Enter the <FNRE_admin> password in the password field.

• Confirm the <FNRE_admin> password and click Next.

Add Server to an Existing 
Vista Domain

Choose Add to an existing domain.

Start Copying Files Confirm your settings and click Next.
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4. Once the file-copy process has completed, select Yes, I want to restart my computer now, and 
click Finish.

5. Once the Rendition Engine server has restarted, log back on as the <FNRE_admin> account.

6. Browse to the installation directory.  The default installation location is Program 
Files\Liquent\filenet. Execute the file called RP22-VistaConfig.exe.  

7. In the Configuration File field, browse to the Resources subdirectory in the installation software 
package and select FileNetP8RenditionEngineConfig.xml. 

8. From the Available Machine Configurations list, choose Rendition Engine Server and click 
Select.

9. If this is a Rendition Engine server, proceed to steps 10-11.  Otherwise, proceed to “To test the 
connection to the database” on page 43.

10. Launch the Microsoft Word application.

11. Check the Always trust... checkbox. Then click Disable Macros.

To test the connection to the database 

Perform the following steps on Rendition Engine and Publishing Plug-in (Content Engine) servers. 

1. Select Start > All Programs > Liquent > Domain Manager

2. Right click on the Domain node.

3. Select Properties.

4. Select the Database tab.  

5. Click the Test Database button. You should receive a message saying the connection was 
successful.

6. Click OK once the test is completed.

Move Repository Join the existing Vista domain by choosing your database type 
and entering appropriate database information as entered in the 
Database Type dialog when the first Rendition Engine was 
installed.  See “Vista Database Type” on page 33, “Oracle Database 
Information (displays if you chose Oracle 9i)” on page 33, and “SQL 
Database Information (displays if you chose Microsoft SQL Server)” 
on page 34 for more information.  The information entered here 
must be the same as you entered when installing the first 
Rendition Engine.  Click OK and files will continue copying.

In this screen... Perform this action...
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To configure the BusinessServiceServer service

Perform the following steps on Rendition Engine and Publishing Plug-in (Content Engine) servers. 

1. Select Start > All Programs > Administrative Tools > Services.

2. Right-click BusinessServiceServer and select Properties.

3. Set Startup type to Automatic, and then Start the service.

4. Click the Log On tab.

NOTE Windows cannot set the XML Printer for Rendition Engine as the default printer unless 
you set the Rendition user account (<FNRE_admin>) for the BusinessServiceServer service.

5. Select This account and click Browse.

6. For the Look in field, select the correct domain.

7. Select the proper Rendition Engine user account (<FNRE_admin>) and password, then click 
OK.

NOTE If prompted that the account has been granted Log On As A Service right, click OK.

8. Click OK if prompted that the new logon name will not take effect until you stop and restart the 
service, otherwise, click OK to close the BusinessServiceServer Properties window.

9. Right-click the BusinessServiceServer service and click Restart.

10. Close the Services application.

NOTE When a Rendition Engine or Publishing Plug-in server is added to the FileNet P8 
Platform domain, the BusinessServiceServer services must be manually restarted on every 
Rendition Engine and Publishing Plug-in server.

To set security on VistaTempDir shared folder

Perform the following steps on Rendition Engine and Publishing Plug-in (Content Engine) servers. 

1. Run Windows Explorer and open the temp folder defined for the server (typically 
drive:\WINNT\Temp on Windows 2000, drive:\WINDOWS\Temp on Windows 2003.

NOTE To determine the location for the temp folder, Rendition Engine uses a standard 
Windows call that checks, in order, the environment variables TMP, TEMP, and 
USERPROFILE. If no values are found, use the Windows program directory.

2. Right-click the \VistaTempDir folder and select  Properties.

3. Verify the \VistaTempDir folder is shared. If it is not, select the Sharing tab and select Share this 
folder. 

4. Select the Security tab and click Advanced.  

NOTE A missing Security tab generally means that the drive where the \VistaTempDir folder is 
located, is not a Windows NTFS partition.

5. Uncheck Allow inheritance permissions, and then click Remove.
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NOTE On Windows 2003, you must click the Advanced button to see the checkbox.

6. Add the <FNRE_admin> and Content Engine Servers accounts.

7. Give the accounts Full Control access rights.

8. Click Apply and then OK.

9. Close all programs.
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Upgrade Overview
This section lists details that will help you prepare your environment for the upgrade of a 
Rendition Engine and the FileNet Publishing Plug-in components. In many cases, the items you 
see listed will be links to more detailed information, which will help you plan a system upgrade. 
Please review this information thoroughly before you start to upgrade FileNet P8 components or 
required third-party software.

NOTE

• This guide does not address migrations to different operating systems, databases, or directory 
services. To migrate from one platform to another (for example, from MS SQL Server database 
engine to Oracle), contact your FileNet support representative. 

• The upgrades described in the guide assume that you will:

– retain your basic platform configuration from the previous release. 

– make no changes to user or group definitions during the upgrade.

– apply only the necessary supported software updates and patches, as noted in this guide 
and in the IBM FileNet P8 Hardware and Software Requirements document.

• If you are running FileNet P8 3.0.0 with Rendition Engine and Publishing Plug-in components, 
you must first upgrade to 3.5.0 and apply the 3.5.1 service pack. 

• If you are running FileNet 3.5.0 with Rendition Engine and Publishing Plug-in components, 
you must first apply the 3.5.1 service pack.
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Upgrade Planning Considerations 

Gather auxiliary documentation
NOTE  For general instructions on how to navigate to this and other IBM FileNet product 
documentation on the IBM web site, see “Access IBM FileNet Documentation, Compatibility Matrices, 
and Fix Packs” on page 9.

Before you begin installing the software, retrieve the following documents:

• IBM FileNet Rendition Engine Installation and Upgrade Guide (This document). This 
document provides details on how to install and upgrade Rendition Engine components.

• IBM FileNet P8 Hardware and Software Requirements. This document provides details for all 
FileNet P8 system components, as well as the minimum supported levels of third-party 
software components. The information throughout the IBM FileNet P8 Platform Installation 
and Upgrade Guide assumes you have met all applicable requirements listed in that 
document. 

• IBM FileNet P8 Platform Release Notes. This document provides details on new features, 
known issues, and resolved problems. 

• IBM FileNet P8 Platform Installation and Upgrade Guide. This document provides details for 
installation, upgrade, and configuration of the core components for the FileNet P8 system.

• FileNet P8 Platform user and group security help. 

This help topic provides a complete list of the user and group roles, accounts, and 
responsibilities required to install, configure, and maintain a FileNet P8 system. For more 
information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Security > Users and groups. 

• FileNet P8 Platform Shutdown and Startup. 

This help topic describes how to shut down and restart FileNet P8 Platform components and 
some expansion products. Manual, command line, and some sample batch file procedures are 
provided. For more information, see the FileNet P8 Help topic FileNet P8 Administration > 
Enterprise-wide Administration > Shutdown and Startup. 

• Installing IBM FileNet P8 Platform in a Non-English Environment Technical Notice. This 
document will help you set up the product if your environment is not English-language based. 

• IBM FileNet P8 Platform Deployment Guide. This document provides details on how to deploy 
a FileNet P8 system from a staging environment into a full production environment. 

• IBM FileNet P8 Platform Troubleshooting Guide. This document provides troubleshooting 
information on all aspects of the product.

• IBM FileNet P8 Platform Performance Tuning Guide. This document provides performance 
tuning information on all aspects of the product. 
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General Requirements for all FileNet P8 Systems
• Plan and test the upgrade on a designated test system first. Verify the upgrade is 

successful by running functionality and stress tests. 

• Complete any pending publishing jobs before upgrading. 

Network Security Considerations
• Ensure availability of required port numbers. For a composite list of port numbers required 

for FileNet P8 3.5.X, see “FileNet P8 Port Numbers” on page 53.

Database Considerations

General
Update to the appropriate patches BEFORE you upgrade FileNet P8 components. 

Oracle
Ensure you have applied appropriate Oracle patches to Oracle clients as well as servers. Be 
sure that clients remote to an Oracle database engines have comparable patches to the database 
server. Oracle clients include any machines remote from the Oracle database server where 
Content Engine, Rendition Engine, Process Engine, and FileNet Enterprise Manager software is 
installed. You can download all the required Oracle 9i database server patches from 
OracleMetaLink and install them.
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Gather Pre-upgrade Information

Content Engine
• Ensure that you have the necessary local administrative user accounts and passwords 

to run the upgrade program on the various Rendition Engine and Publishing Plug-in (Content 
Engine) servers.

• You must know the password of the user (e.g. <FNRE_admin>) that runs Rendition Engine 
services. If this is not available, you must reset the password to a known string before running 
the upgrade process.

Rendition Engine
You will need to identify new databases for use by the 3.5.1 version of Rendition Engine. You 
cannot use existing databases after the upgrade.
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Before You Begin the Upgrade
• Be sure to read the “What’s New” topic in the FileNet P8 Platform Release Notes. Many of the 

new features may be interesting for your implementation of FileNet P8 Platform.

• Make sure the site has restorable backups of system and data. In case of an emergency, you 
may need to back out of the upgrade. For details on what to back up for FileNet P8 
components, see the topic FileNet P8 Documentation > Enterprise-wide Administration > 
Backup and Restore in the general FileNet P8 Platform help.

• Before beginning the upgrade, make sure no users or processes are accessing the FileNet P8 
system.

• Before beginning the upgrade, make sure you disable tasks such as:

– scheduled automated backups (Windows)

– cron jobs (UNIX)

– virus scanning
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Task 1: Upgrade FileNet Publishing Components
This topic covers upgrades of the Rendition Engine software from the 3.0.0 release to the 3.5.1 
release. The upgrade involves uninstalling and reinstalling the associated software.

• You will need to upgrade the FileNet Publishing components on the following servers:

– Publishing Plug-in (Content Engine) servers

– FileNet Rendition Engine servers

• You will need to verify the values for the Rendition Engine temporary directory.

• You will need to verify or upgrade the embedded Liquent Vista software license key. 

To uninstall existing Liquent Vista Component Server server software

You must uninstall the existing Liquent Vista Component Server software from all Rendition 
Engine or Publishing plug-in 3.0.0 servers before upgrading (re-installing) the Publishing 
components for 3.5.1.

1. Log on to the server as <FNRE_admin>.

2. Stop the Vista Component Server BusinessServiceServer service prior to uninstalling the 
software.

3. Select Start > Settings > Control Panel and double-click Add/Remove Programs.

4. Select the Vista Component Server item and click Change/Remove.

5. Follow the screen prompts to remove the Vista Component Server software.

6. Select Start > Settings > Control Panel and double-click Printers.

7. On the Printers window, delete the printer Liquent XML Printer, then select File > Server 
Properties.

8. On the Print Server Properties dialog box, select the Ports tab and delete the local ports that 
point to Program Files\Common Files\Liquent\liquent.xml and Program 
Files\Liquent\Vista\ESPS.PS.

9. Select the Drivers tab, remove the printer driver Liquent XML Printer, and then click OK.

10. Run the VistaCleaner.exe located in the Rendition Engine software package in 
\Resources\Liquent\Unsupported Apps\Xtent2.0.

11. Reboot the server.

To install the 3.5.1 version of Rendition Engine, follow the procedures in “Install and configure 
FileNet P8 Publishing components” on page 25.  

You can not use an existing Rendition Engine database.  When you install and configure the new 
software you must also identify a new database for use. 
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Remove Rendition Engine
Remove a Rendition Engine from a Vista Domain 

To uninstall existing Rendition Engine software you must first remove the server from the Vista 
domain, then uninstall the software.  

1. Log in as <FNRE_admin>.

2. In the Vista Domain Manager application, select the Configuration tab in the left navigation 
pane, then expand Domain and Repositories to view the server machines in the domain. 

3. Click on the server name to be removed from the Liquent domain. Select  Delete from the Edit 
menu.

4. Confirm the deletion and select Save from the File menu.

Remove Rendition Engine software from a Rendition Engine or Publishing Plug-in server

1. Stop the Vista Component Server BusinessServiceServer service prior to uninstalling the 
software. 

2. Select Start > Settings > Control Panel and double-click Add/Remove Programs.

3. Select FileNet P8 Rendition Engine 3.0.0a/3.5.1 and click Change/Remove.

4. Follow the screen prompts to remove the software. At the final screen, click Finish.

5. Select Start > Settings > Control Panel. Double-click Printers.

6. On the Printers window, select File > Server Properties.

7. On the Print Server Properties dialog box, select the Ports tab and delete the local ports that 
point to:

\Program Files\Liquent\filenet\liquent.xml 

\Program Files\Liquent\filenet\ESPS.PS 

8. Select the Drivers tab, remove the printer driver Liquent XML Printer.  Click OK.

9. If the following word macro is present on the Rendition Engine server, remove it:

cdmacros.dot 

10. Run the VistaCleaner.exe located in the Rendition Engine software package in:

\Resources\Liquent\Unsupported Apps\Vista2.x 

11. Click the Cleanup button.

12. Click OK to close the program when it has completed.

13. Reboot the server.
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The table below lists the port numbers used by Rendition Engine and Publishing Plug-in 
components.

Rendition Engine Ports

Liquent / Print Server on Local Port 1 Program Files\Common 
Files\Liquent\liquent.xml 

Liquent / Print Server on Local Port 2 Program Files\Liquent\Vista\ESPS.PS 

Liquent notify port 2868

Liquent event port 2869

Liquent admin port 2870

MSSQL Server / Oracle 1433 / 1521

Web Content Manager 5000
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Notices
Notices  

This  information  was  developed  for  products  and  services  offered  in  the U.S.A.  

IBM  may  not  offer  the  products,  services,  or  features  discussed  in this  document  in other  countries.  

Consult  your  local  IBM  representative  for  information  on  the  products  and  services  currently  available  in 

your  area.  Any  reference  to an  IBM  product,  program,  or  service  is not  intended  to state  or  imply  that  

only  that  IBM  product,  program,  or  service  may  be  used.  Any  functionally  equivalent  product,  program,  

or service  that  does  not  infringe  any  IBM  intellectual  property  right  may  be  used  instead.  However,  it is 

the  user’s  responsibility  to evaluate  and  verify  the  operation  of  any  non-IBM  product,  program,  or  

service.  

IBM  may  have  patents  or  pending  patent  applications  covering  subject  matter  described  in this  

document.  The  furnishing  of this  document  does  not  grant  you  any  license  to these  patents.  You can  send  

license  inquiries,  in  writing,  to:  

IBM  Director  of Licensing  

IBM  Corporation  

North  Castle  Drive  

Armonk,  NY  10504-1785  

U.S.A.

For  license  inquiries  regarding  double-byte  (DBCS)  information,  contact  the  IBM  Intellectual  Property  

Department  in  your  country  or  send  inquiries,  in  writing,  to: 

IBM  World  Trade  Asia  Corporation  

Licensing  

2-31  Roppongi  3-chome,  Minato-ku  

Tokyo  106-0032,  Japan

The  following  paragraph  does  not  apply  to the  United  Kingdom  or  any  other  country  where  such  

provisions  are  inconsistent  with  local  law:  INTERNATIONAL  BUSINESS  MACHINES  CORPORATION  

PROVIDES  THIS  PUBLICATION  “AS  IS”  WITHOUT  WARRANTY  OF  ANY  KIND,  EITHER  EXPRESS  

OR  IMPLIED,  INCLUDING,  BUT  NOT  LIMITED  TO,  THE  IMPLIED  WARRANTIES  OF  

NON-INFRINGEMENT,  MERCHANTABILITY  OR  FITNESS  FOR  A  PARTICULAR  PURPOSE.  Some  

states  do  not  allow  disclaimer  of  express  or implied  warranties  in certain  transactions,  therefore,  this  

statement  may  not  apply  to you.  

This  information  could  include  technical  inaccuracies  or  typographical  errors.  Changes  are  periodically  

made  to the  information  herein;  these  changes  will  be  incorporated  in  new  editions  of  the  publication.  

IBM  may  make  improvements  and/or  changes  in the  product(s)  and/or  the  program(s)  described  in  this  

publication  at  any  time  without  notice.  

Any  references  in  this  information  to non-IBM  Web sites  are  provided  for  convenience  only  and  do  not  in  

any  manner  serve  as  an  endorsement  of those  Web sites.  The  materials  at  those  Web sites  are  not  part  of  

the  materials  for  this  IBM  product  and  use  of  those  Web sites  is  at your  own  risk.  

IBM  may  use  or  distribute  any  of  the  information  you  supply  in  any  way  it  believes  appropriate  without  

incurring  any  obligation  to  you.  
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Licensees  of  this  program  who  wish  to  have  information  about  it for  the  purpose  of  enabling:  (i)  the  

exchange  of information  between  independently  created  programs  and  other  programs  (including  this  

one)  and  (ii)  the  mutual  use  of the  information  which  has  been  exchanged,  should  contact:  
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BM  Corporation  

46A/G4  

55  Bailey  Avenue  

an  Jose,  CA  95141-1003  

.S.A.

uch  information  may  be  available,  subject  to appropriate  terms  and  conditions,  including  in some  cases,  

ayment  of  a fee.  

he  licensed  program  described  in this  document  and  all  licensed  material  available  for  it  are  provided  

y  IBM  under  terms  of  the  IBM  Customer  Agreement,  IBM  International  Program  License  Agreement  or  

ny  equivalent  agreement  between  us.  

ny  performance  data  contained  herein  was  determined  in a controlled  environment.  Therefore,  the  

esults  obtained  in  other  operating  environments  may  vary  significantly.  Some  measurements  may  have  

een  made  on  development-level  systems  and  there  is no  guarantee  that  these  measurements  will  be  the  

ame  on  generally  available  systems.  Furthermore,  some  measurements  may  have  been  estimated  through  

xtrapolation.  Actual  results  may  vary.  Users  of  this  document  should  verify  the  applicable  data  for  their  

pecific  environment.  

nformation  concerning  non-IBM  products  was  obtained  from  the  suppliers  of  those  products,  their  

ublished  announcements  or  other  publicly  available  sources.  IBM  has  not  tested  those  products  and  

annot  confirm  the  accuracy  of  performance,  compatibility  or  any  other  claims  related  to  non-IBM  

roducts.  Questions  on  the  capabilities  of  non-IBM  products  should  be  addressed  to the  suppliers  of  

hose  products.  

ll  statements  regarding  IBM’s  future  direction  or  intent  are  subject  to  change  or withdrawal  without  

otice,  and  represent  goals  and  objectives  only.  

his  information  contains  examples  of  data  and  reports  used  in daily  business  operations.  To illustrate  

hem  as  completely  as  possible,  the  examples  include  the  names  of individuals,  companies,  brands,  and  

roducts.  All  of  these  names  are  fictitious  and  any  similarity  to  the  names  and  addresses  used  by an  

ctual  business  enterprise  is  entirely  coincidental.  

OPYRIGHT  LICENSE:  

his  information  contains  sample  application  programs  in source  language,  which  illustrate  programming  

echniques  on  various  operating  platforms.  You may  copy,  modify,  and  distribute  these  sample  programs  

 any  form  without  payment  to IBM,  for  the  purposes  of developing,  using,  marketing  or  distributing  

pplication  programs  conforming  to  the  application  programming  interface  for  the  operating  platform  for  

hich  the  sample  programs  are  written.  These  examples  have  not  been  thoroughly  tested  under  all  

onditions.  IBM,  therefore,  cannot  guarantee  or  imply  reliability,  serviceability,  or function  of  these  

rograms.  
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IBM,  the  IBM  logo,  and  ibm.com  are  trademarks  or registered  trademarks  of  International  Business  

Machines  Corporation  in  the  United  States,  other  countries,  or  both.  If these  and  other  IBM  trademarked  

terms  are  marked  on  their  first  occurrence  in  this  information  with  a trademark  symbol  (® or  

™), these  

symbols  indicate  U.S.  registered  or  common  law  trademarks  owned  by  IBM  at the  time  this  information  

was  published.  Such  trademarks  may  also  be  registered  or  common  law  trademarks  in other  countries.  A 

current  list  of  IBM  trademarks  is available  on  the  Web at ″Copyright  and  trademark  information″ at  

www.ibm.com/legal/copytrade.shtml.  

Java  and  all  Java-based  trademarks  are  trademarks  of  Sun  Microsystems,  Inc.  in the  United  States,  other  

countries,  or  both.  

Microsoft  and  Windows  are  trademarks  of  Microsoft  Corporation  in the  United  States,  other  countries,  or  

both.  

Linux  is a trademark  of  Linus  Torvalds  in  the  United  States,  other  countries,  or  both.  

UNIX  is a registered  trademark  of  The  Open  Group  in the  United  States  and  other  countries.  

Other  company,  product,  and  service  names  may  be  trademarks  or  service  marks  of  others.
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