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This document describes installation, upgrade scenarios and known issues for IDM on Windows Vista. It also includes 
alternative methods to overcome the known issues. 
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IDM Installation on Windows Vista

Follow the procedure below for installation of IDM Desktop on Windows Vista:

1.      Install IDM Desktop 4.0a. 

2.      Install IDM Desktop 4.0.1. 

3.      Install IDM Desktop 4.0.1 Fix Pack 7 or later 
OR 
Install IDM Desktop 4.0.2 fix pack 2.

4.      Edit the "services" and "hosts" files.

Upgrading Windows XP Service Pack 2 with IDM to Windows Vista

The following scenarios are applicable once the user upgrades to Windows Vista:

Upgrading Windows XP Service Pack 2 with IDM Desktop 4.0.2 with or without respective Fix Packs 

For upgrading Windows XP Service Pack 2 with IDM Desktop 4.0.2 with or without respective Fix Packs

1.      Install IDM Desktop 4.0.2. 

2.      Install IDM Desktop 4.0.2 with fix pack 2. 

3.      Edit the "services" and "hosts" files. 
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Upgrading Windows XP Service Pack 2 with IDM Desktop 4.0/4.0a GA with or without respective Fix Packs 

For upgrading Windows XP Service Pack 2 with IDM Desktop 4.0/4.0a GA with or without respective Fix Packs

1.      Install IDM Desktop 4.0.1. 

2.      Install IDM Desktop 4.0.1 Fix Pack 7 or later. 

3.      Edit the "services" and "hosts" files. 

Upgrading Windows XP Service Pack 2 with IDM Desktop 4.0.1, with or without respective Fix Packs up to Fix 
Pack 6 

For upgrading Windows XP Service Pack 2 with IDM Desktop 4.0.1, with or without respective Fix Packs 
up to Fix Pack 6

1.  Install IDM Desktop 4.0.1 Fix Pack 7 or later. 

2.  Edit the "services" and "hosts" files.

Upgrading Windows XP Service Pack 2 with IDM Desktop 4.0.1 Fix Pack 7 onwards 

For upgrading Windows XP Service Pack 2 with IDM Desktop 4.0.1 Fix Pack 7 or later applied:

1.  Install the same or later IDM 4.0.1 Fix Pack after upgrading to Windows Vista. 

2.  Edit the "services" and "hosts" files. 

For IDM 4.0a installation and upgrade scenarios on Windows Vista, the following steps need to be performed for 
editing "services" and "hosts" files: 

a.      Open the "services" file located at <System Drive>:\WINDOWS\system32\drivers\etc. 

b.      Add "cor 32769/tcp" and "nch 32770/udp" entries under the <service name> <port number>/
<protocol> sections of this file. 

c.      Open the "hosts" file located at <System Drive>:\WINDOWS\system32\drivers\etc. 

d.      Add "<IPaddress> <library_name>-filenet-nch-server" entries for all IS libraries. For example: 
"10.224.1.123 islib-filenet-nch-server". 

Return to Contents

Known Issues for IDM Installation on Windows Vista 

FnSysMgr.exe throws an error stating failure to update registry (ecmdb00663673) 

Due to security enhancements in Windows Vista, once system is restarted after running IDM Desktop 
4.0.1 setup, FnSysMgr.exe throws an error stating failure to update registry. However, these registry 
entries are created successfully once IDM 4.0.1 Fix Pack 7 or later are applied.

"Problem Reports and Solution" application generates a report and logs a warning after silent 
installation of IDM 4.0a on Vista through SMS server (ecmdb00664098) 
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After silent installation of IDM on Vista through SMS server, a report is generated by "Problem Reports 
and Solution" application of Vista. This application logs a warning stating, ‘The program might not have 
installed correctly'. However, installation is successful and there is no functionality degradation. 

Return to Contents

Known Issues for IDM on Windows Vista 

Scroll-bar down-arrow does not function in Add document wizard of IS library (ecmdb00838559)

In IDM Desktop->Add document wizard for IS library, if the document class has more than 11 properties 
then the down arrow of the scroll bar will not function properly in case of Windows Vista.

MS PowerPoint Add-ins unavailable for fresh Office 2007 (ecmdb00786030)

In Windows Vista Enterprise edition of base version, PowerPoint Add-ins are not available for fresh 
integration with MS Office 2007.

Installation of IDM Desktop forbid in Office Integration (ecmdb00751329)

While installing IDM Desktop GA, it reads the registry key (HKEY_CLASSES_ROOT\.doc) to determine 
whether MS Word is installed. It also determines the 

Installation of IDM Desktop forbid in Office Integration (ecmdb00751329)

While installing IDM Desktop GA, it reads the registry key (HKEY_CLASSES_ROOT\.doc) to determine 
whether MS Word is installed. It also determines the installation path based on this registry value. The 
value of this registry key should be "Word.Document.8". This value is created by MS Office installation. 

If this registry key value is other than "Word.Document.8" then IDM 4.0/4.0a installation will not allow MS 
Word integration on Windows Vista.

Similarly, for Excel,

While installing IDM Desktop GA, it reads the registry key (HKEY_CLASSES_ROOT\.xls) to determine 
whether MS Excel is installed. It also determines the installation path based on this registry value. The 
value of this registry key should be "Excel.Sheet.8". This value is created by MS Office installation. 

If this registry key value is other than "Excel.Sheet.8" then IDM 4.0/4.0a installation will not allow MS 
Excel integration on Windows Vista.

IDM Desktop help files incompatible on Windows Vista (ecmdb00663676) 

Microsoft has stopped supporting .hlp help file format on Windows Vista. Consequently, IDM Help File(s) 
cannot be viewed. A message stating that the Windows Help format used is not supported is displayed 
when attempting to view IDM Help File(s). To view the .hlp files, download the Winhlp32.exe by following 
the instructions at Microsoft Download Center. 
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Radio buttons to enable user preferences invisible in IDM Configure (ecmdb00663683) 

"Set preferences for currently logged on user” and “Set preferences for all users" radio buttons to enable 
user preferences are not visible to a non-default administrator/standard user. This problem occurs due 
to the security feature of User Account Control (UAC) in Windows Vista. A non-default administrator can 
set the user preferences by running IDM Configure as default administrator by following the procedure 
below:

Right click the idmcfg.exe located at IDM install path and select "Run as Administrator".

or,

Right click the IDM Configure shortcut in the Windows start menu and "Run as Administrator".

IDM Desktop Application Integration macros do not run with macro security set to High when 
upgrading to Windows Vista (ecmdb00663756) 

Due to security enhancements in Windows Vista, IDM Desktop Application Integration macros do not 
run with macro security set to High. This is applicable for all scenarios on upgrading Windows XP 
Service Pack 2 with IDM to Windows Vista. However, this issue can be overcome by setting the macro 
security to Medium.

Clicking "FileNet IDM Desktop" link on the IDM 4.0.1 Splash screen does not invoke the setup.exe 
(ecmdb00663993)

Clicking "FileNet IDM Desktop" link on the IDM 4.0.1 Splash screen does not invoke the setup.exe. The 
following procedure can be used to overcome this problem: 

Locate setup.exe in IDM 4.0.1 Media. 

Run setup.exe. 

IDM Web Client users logged in as non-default administrators with Internet Explorer "Protected Mode" 
enabled encounter the following issues:

Microsoft Internet Explorer 7 runs in Protected Mode due to security features of Windows Vista. This 
enables Internet Explorer to run with restricted privileges thereby protecting users from online threats. 
Due to this security feature, IDM Web Client users face the following issues: 

When a user opens a document in IDM Viewer, IDM Menu options such as File, Go to, Favorites are 
absent. Also, menu options such as Edit, View, Image, Help which are present, do not work. 
(ecmdb00664355) 

Security warning dialog box pops up with the options “Allow” and “Don't Allow” when user opens or 
closes a document in IDM Viewer. On clicking "Don't Allow", the same dialog box is displayed. On 
clicking “Allow” on this dialog box, a blank IDM Viewer window opens. (ecmdb00664356, 
ecmdb00664359) 

Security warning dialog box pops up with the options “Allow” and “Don't Allow” when user opens a 
document in IDM Viewer. On clicking "Allow" on the dialog box, IDM Viewer window minimizes. 
(ecmdb00664361) 
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User is unable to save a document at the specified location on the local machine while performing 
checkout operation. (ecmdb00664613) '

While performing the "Copy local and Open" operation in the CS library, user is unable to save a local 
copy of the document at the specified location and on viewing the document the error message 
“Windows cannot find ‘C:\Users\qavista\Desktop\abc.doc. Make sure you typed the name correctly, and 
then try again” is displayed. (ecmdb00556676) 

The following procedure can be followed to overcome these issues: 

Click Tools > Internet Options in the Internet Explorer Browser and select the Security tab. 

Select "Trusted sites" and click "Sites". 

Uncheck the "Required server verification (https:) for all sites" combo box. 

Add web-server URL http://<servername>/IDMWS to the "Trusted sites" list and click Ok. 

Click Custom level and go to Downloads Settings. 

Enable "Automatic prompting for downloads" and click OK. 

Click "Yes" for the prompt and OK to continue. 

Explorer Integration support on Windows Vista (ecmdb00554350)

Explorer Integration is supported with IDM 4.0.2 patch 2 on Windows Vista. 

But the Explorer Integration is not supported with IDM 4.0/4.0a on Windows Vista as the following 
document operations through FileNet Neighborhood are not working due to certain third party software 
limitations:

Updating document properties through document properties dialog box (IS/CS) 

Checking-in a document (CS) 

Publishing a document (CS) 

Committing a document to libraries through drag and drop (IS/CS) 

Committing a document to libraries through copy and paste (IS/CS) 

The following alternative methods can be used to perform the above mentioned document operations: 

For Updating document properties: 

Open the document in IDM Viewer. 

Click File > Properties to open the document property dialog box. 
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From the "Properties" tab change the required document properties. 

For Checking-in a document:

Open the document in IDM Viewer. 

Click File -> Properties to open the document property dialog box. 

Go to "Version" tab in the property window to view the document versions. 

Right-click the checked-out version of the document and select check-in option. 

For Publishing a document: 

Find the document through IDM Find. 

Right Click the document and select "Publish" option to publish the document. 

For Committing a document: 

After installing IDM 4.0.1 Fix Pack 7, reboot the system and access the Task Manager. 

Go to the "Process" tab, select "FnContextint.exe" and click "End Process". 

Exit the Task Manager. 

Right-click the document to be added. 

Select "Add to FileNet Library" option to add the document.

Note: Since this issue has been resolved in IDM DT/WS 4.0.2 fix pack 2, you can install patch 2 to avoid 
this problem. 

Windows Vista Service Pack 2 is not supported by IDM

The user will not be able to view multi-page documents in IDM Viewer in Windows Vista SP2 in IE7 
client (ecmdb00854010).

Queue Maintainence Application crashes on Windows Vista SP2, when renaming the queue name with 
an invalid name (ecmdb00854157).

Launching MS PowerPoint 2007 in Windows Vista SP2, throws an error in IDM 4.0.2 FixPack 7 
(ecmdb00854203).

Return to Contents

Contact customer support
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For more information about contacting customer support, see the IBM Customer Service and Support web site for 
FileNet customers. You will need a IBM-issued login name and password to access the web site. 

Notices 

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local 
IBM representative for information on the products and services currently available in your area. Any reference to an 
IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may 
be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property 
right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM 
product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The 
furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, 
to: 

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY  10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in 
your country or send inquiries, in writing, to: 

Intellectual Property Licensing 

 

Legal and Intellectual Property Law 

 

IBM Japan, Ltd. 

 

3-2-12, Roppongi, Minato-ku, Tokyo 106-8711 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions 
are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS 
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT 
NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR 
A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain 
transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the 
information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner 
serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any 
obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of 
information between independently created programs and other programs (including this one) and (ii) the mutual use of 
the information which has been exchanged, should contact: 

IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA  95141-1003
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a 
fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under 
terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement 
between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in 
other operating environments may vary significantly. Some measurements may have been made on development-level 
systems and there is no guarantee that these measurements will be the same on generally available systems. 
Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of 
this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published 
announcements or other publicly available sources. IBM has not tested those products and cannot confirm the 
accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities 
of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or withdrawal without notice, and 
represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as 
completely as possible, the examples include the names of individuals, companies, brands, and products. All of these 
names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely 
coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques 
on various operating platforms. You may copy, modify, and distribute these sample programs in any form without 
payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to 
the application programming interface for the operating platform for which the sample programs are written. These 
examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, 
serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. 
IBM shall not be liable for any damages arising out of your use of the sample programs. 

Trademarks
•              IBM is a registered trademark of International Business Machines Corporation in the United States, other 
countries, or both. 
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•              FileNet is a registered trademark of FileNet Corporation, in the United States, other countries, or both. 

•              Microsoft, Windows, Windows Vista, and the Windows logo are trademarks of Microsoft Corporation in the 
United States, other countries, or both. 

•              Other company, product, or service names might be trademarks or service marks of others. 

Document change history
Date Release Description of change   
06 Aug 2009  IDM DTWS 4.0.2-006 Started documentation changes tracking.
06 Aug 2009  IDM DTWS 4.0.2-006 Defect # ecmdb00838559 updated. Notice content changed. 
03 Dec 2009 IDM DTWS 4.0.2-007 Defects #ecmdb00854010, #ecmdb00854157, #ecmdb00854203 updated.
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