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1 INTRODUCTION

This document describes how to configure Email Manager to support failover using Microsoft Cluster
Server and Veritas Cluster Server. The document also describes configuring Email Manager in a
symmetrical server setup to maximize resource usage when creating an active/passive cluster.

Email Manager does not support load balancing or server farming. Email Manager only supports and
active/passive cluster configuration.

This document does not contain instructions for installing and configuring either Microsoft or Veritas
Cluster Server software. Consult the vendor documentation for details on installing those products.
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2 ACTIVE/PASSIVE CLUSTER

CONFIGURATION

Assumptions:

2.1

The cluster server software has been installed and configured.
Two servers are being used

An active/passive cluster is being configured. Email Manager does not support an active/active.
To maximize resource usage of a passive machine, a symmetrical configuration of Email
Manager may be utilized. See the section Symmetrical Server Configuration in this document
for details.

Microsoft Cluster Server Configuration

To configure Microsoft Cluster Server, do the following:

1.

Install Email Manager on both servers. Ensure the configuration of the machines is identical. It is
suggested that both instances of Email Manager utilize the same Email Manager database. Do
not enable the Email Manager services on both servers at the same time. This will result in erratic
behavior of the system.

Launch the Windows Cluster Administrator from Start > Programs > Administrative Tools >
Cluster Administrator

Create a new group by selecting File > New Group.

a. Enter “Group0Q” in the name field and a description and click Next.

T hiz wizard will help pou guickly et up a new resource

gQroup.
I arne; IGru:uupEI
Dezcription; IEIuster Group for Email Managed

To continue, click Mext.

< Back I Mext > I Cancel
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b. Select the node in the cluster that the Email Manager should use at its preferred node
and click Finish.

Preferred Owners =

Groupl

Lizt all preferred owners on the nght, and then arrange them in the order of preference.

Ayailable nodes; Prefered awners:

M amne | [ arme |
WOC-EM-MODEA 3DC-EM-MWODER

<- Hemove

e e

fd e Do

AL

¢ Back | Finizh Cancel

4. To create a new resource, right click on Group0 and select New Resource.
a. Inthe New Resource screen:
i. Enter “UFIService” in the Name field
ii. Enter “UFIService” in the Description field
iii. Select “Generic Service” in the Resource Type field.

iv. Select “Group0” in the Group field.
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v. Click Next.

|. IFIService

M ame: IUFIService
Deszcrption; ILIFISer'-.-'ice
R esource bpe: I Genernic Service j
Group: I Groupd j

[ Bun this resource in a separate Fesource Monitar

To continue, click Mest.

< Back I MNest > I Cancel

b. In the Possible Owners screen, select the nodes that will be in the cluster and click Next.

Possible Dwners ]

|. UFIServicel

Fozzible owners are nodes in the cluster on which thiz rezource can be brought online.
Specify the pogzible owners for thiz rezource.

Ayailable nodes; Pozzible owners;

M ame | M ame |
@ YOCEM-NODES
@ ¥DC-EM-NODER

Sdd -
<- Hemove |

¢ Back I MNest > I Cancel
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c. Inthe Dependencies screen, click Next.

| UFIServicel

Dependencies are rezources which must be brought online by the cluster service first,
Specify the dependencies for thiz rezource.

Ayailable rezources: R ezource dependencies:

Hesource | Resc Rezource I Resc

<- Hemove

&=
3
L
i

1| | §a ol | i

¢ Back I MNest > I Cancel |

d. Inthe Generic Service Parameters screen:

i. Enter “UFIService” in the Service name field.

ii. Inthe Start parameters field, enter the path to the Email Manager configuration
file prefixed with the text “-cfg=". The configuration file is located in the Email
Manager installation folder in the sub folder “Config” and is named “default.emgr
by default. The full path should be used and the path should be enclosed in
guotation marks. To verify the path, in the Services screen, select “eMgr
Universal File Importer”, right click and select and select Properties. The Path to
executable field will contain a reference to the location of the configuration file
used by Email Manager. The following is the default value:

-cfg="C:\Program Files\FileNet\Email Manager Server 3.7\Config\default.emgr"
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ii. Click Next

Generic Service Paramekters E
| UFIService22

Service name: IUFISEWice{

Start parameters: I-u:fg="E:'xF'n:ugram Filez\FileMet'Email Manager Server 3.

[T Use Hetwark M ame for computer name

¢ Back I MNest > I Cancel

iv. Inthe Registry Replication screen, click Finish.

Registry Replication E
| 23

Programs ar 2ervices may stare data in the registn). Therefare, it iz impartant to have this
data awailable on the node o which they are running, Specify the regizt ke below
HEEY LOCAL MACHIME that should be replicated to all nodes in the cluster.

Foot Reqistry Key |

Add. | bodiy. | Bemove |

¢ Back I Finizh I Cancel |

5. In Cluster Administrator, find GroupO in the Active Groups of one of the nodes. Right Click on
Group0 and select New > Resource to open the New Resource Screen.
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a. Inthe New Resource screen:
i. If Email Manager for Exchange is being used:
1. Enter “ExchConn” in name field
2. Enter “ExchConn Service” in description field
ii. If Email Manager for Lotus Domino is being used:
1. Enter “LotusConn” in name field
2. Enter “LotusConn Service” in description field
iii. If Email Manager for PST files is being used:
1. Enter “PSTConnector” in name field
2. Enter “PSTConnector Service” in description field
iv. Select “Generic Service” in resource type field.
v. Select “Group0” in group field.
vi. Click Next.

|. ExchConn Service

M arne:; IE:-:chl:l:unn Service
Deszcrption; IE:-:::hEu:-nn Service
R esource bpe: I Genernic Service j
Group: I Groupd j

[ Bun this resource in a separate Fesource Monitar

To continue, click Mest.

< Back I MNest > I Cancel

b. Inthe Dependencies screen:

i. Select UFIService and click Add to add it to the Resource Dependencies list.
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Click Next.

| ExchConn

Dependencies are rezources which must be brought online by the cluzster service first,
Specify the dependencies for thiz rezource.

Ayailable rezources: R ezource dependencies:

Hesource | Resc Reszource ] Hesc
e L

Service

<- Hemove

il

1| | §a ol | i

¢ Back | MNext > | Cancel |

c. Inthe Generic Service Parameters screen:

If Email Manager for Exchange is being used:
1. Enter “ExchConn” in the Service name field
If Email Manager for Lotus Domino is being used:
1. Enter “LotusConn” in the Service name field
If Email Manager for PST files is being used:
1. Enter “PSTConnector” in the Service name field

In the Start parameters field, enter the path to the Email Manager configuration
file prefixed with the text “-cfg=". The configuration file is located in the Email
Manager installation folder in the sub folder “Config” and is named “default.emgr
by default. The full path should be used and the path should be enclosed in
guotation marks. To verify the path, in the Services screen, select “eMgr
Universal File Importer”, right click and select and select Properties. The Path to
executable field will contain a reference to the location of the configuration file
used by Email Manager. The following is the default value:

-cfg="C:\Program Files\FileNet\Email Manager Server 3.7\Config\default.emgr"
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v. Click Next.

Generic Service Parameters
| ExchConn

Semrvice name: IE:-:-:hl:l:unrl

Start parameters: I'xFiIeN ethEmail Manager Server 3.7\ Confighdefault. emgr

[T Use Hetwark M ame for computer name

¢ Back I MNest > I Cancel

d. Inthe Registry Replication screen, click Finish.

Registry Replication
| ExchConn

Programs ar zervices may stare data in the registn). Therefare, it iz impartant to have this
data awailable on the node o which they are running, Specify the regizt ke below
HEEY _LOCAL MACHIME that should be replicated to all nodes in the cluster.

Foot Reqistry Key |

Add. Modfy. | Bemove |

¢ Back

Cancel |
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6. To enable the cluster for of Email Manager, right click on Group0 and select Bring Online.

2.2

Veritas Cluster Server Configuration

To configure Veritas Cluster Server, do the following:

1.

4.

Install Email Manager on both servers. Ensure the configuration of the machines is identical. It is
suggested that both instances of Email Manager utilize the same Email Manager database. Do
not enable the Email Manager services on both servers at the same time. This will result in erratic
behavior of the system.

Click Start>Programs>Veritas>Vertias Cluster Manager — Java Console to run the Veritas
console.

Right click on the cluster name and select Add Service Group.

£ clusterveritas - Cluster Explorer : ADMINISTRATOR@YTGOAPS3S ( Cluster Admini

File Edit Wew Tools Help

QA & A BOOFERAE @

] | T | I =" I ‘ Statusl Remote Cluster Statusl Service Groupsl 4 system Connectivityl [£] Properties
1
E? z Tlclusterveritas E ¥iew: clusterveritas
= 3

A ce

Iluster option is enabled for this cluster clusterveritas.

add/Delete Remote Clusters,,,  |ote clusters configured.

ol sl Gl All Groups status on systems) : clusterveritas

Configure Heartbeats. ..
5 b 'ﬂ 'ﬂ
Open Configuration
s WDC-EN-MODES WDC-EN-MODEE
Saye Configuration =
Close Configuration @ i‘l&
Crline CFfline

In the Add Service Group dialogue box:

a.
b. Under the Available Systems box, add both nodes in the cluster to Systems for Service

Enter “Instance0” as the Service Group Name.

Group.
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c. Click Ok.

+* Add Service Group -

c% Add Service Group

Service Qroup name:

Available Systems

Systems For Service Group

Selected Templake: Mone

YD -EM-NODES Swskem name Startup I Priarity
VDiZ-EM-NODEE

4

1
Service Group Type: (% Falover © Parallel € Hybrid

Templates ... |

% | Show Command )5 | Cancel |
Right Click the InstanceO just created and select Add Resource.
1'“ clusterveritas - Cluster Explorer : ADMINISTRATOR@Y TGQAPS35 ( Cluster Administrator ) = |EI|5|

File:

Edit Wew Tools Help

b wed & BB HOOy BwdERBE @

State
Offline
Offline

AutoDisabled, Disabled

i | ] | | "] | Statusl Resourcesl = Propertiesl
sk it.
i henale Efi Status Yiew: Instanced
Instanced
Wiew » up Status on Member Systems
I:r Systems
Oriline » |-NODEA
Cffline » |-NODEEB
Siwitch Tia 3
ource Status
Cleat Fault ]

pup does not have any resources.

Configure As Global...

» |ent Critical /Error Logs

5 are available.

Enable

Disable »
Autoenable »
Freeze ]
lnfreeze

Enable Resources

Disable Resources

LKy

Lrlirabees

Ignicre b
Flush ]
Delete

In the Add Resource dialogue box:,

a.

Enter “UFIService” in the Resource Name box.
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b. Select GenericService in the resource type box.
c. Click Ok.

€ addResource Xl

ﬁﬁj Add Resource

(GrOUp Name: Instanced

Resource name: I

Resource Type: ; 3 |

IGenerlcﬁerwce ;I 2

Akkribuke name Type Dimension Yalue Edit
DelayafterConline  Inkeger ?
DelavafterOffline  Integer [ralar 10 (|
ServiceMame String Scalar £ |
|Iserfccount Bhring Scalar @*
Password Bkring Aicalar £ |
Mamain =krinn =ralar el ;I

¥ Critical [~ Enabled

%1, Show Cormand (8% | Cancel |

7. Click the icon in the edit column for the Service Name attribute to open the Edit Attribute screen:
a. Enter “UFIService” in the Scaler Value box.
b. Click Ok.

F* Edit Attribute : =

# Edit Attribute

ServiceName
Mame af the service to be monitored, The service name can be the Service
Display Mame ar the Service Key Mame, This attribute can take localized values,

+ Global Scalar Yalue |
" Per System |
VDCEN-NODES. v |

Ik | Zancel |

8. Click the icon in the edit column for the UserAccount attribute.

eMgr High Availability Configuration 14



a. Enter the administrative account name used in the cluster setup in the Scaler Value Box.
b. Click Ok.

F* Edit Attribute 3 x|

[:i UFIService

UserAccount ot
& valid user account in whose context the service will be monitored. Username

can be of the form wsername@domain, com or domain. comiusername, IF wou do

not specify a value For this attribute, then the user account of the service in

the SCM is ignored. To monitor service under builk-in accounts, wou must

provide explicit values, For example, on \Windows

2000 Userfccount="LocalSystem' On Windows 2003; ﬂ

+ GElobal Scalar Walue I

¢ ‘Per=ietem Adrminiskrator |

VDCEN-NODEA v |

Ik Cancel

9. Click the icon in the edit column for the Password attribute.
a. Enter administrative account password used in cluster setup in the Scaler Value box.
b. Click Ok.

4 Edit Attribute g X

d  UFIService

Password

The password of the user, under the context of which, the service would be
started, IF the Userdccount attribute is emply or a built-in service account, this
atbribute is ignored.

Scalar Yalue I

£~ Per Syskem |
VDC-EN-NODEA v ]

Ik Cancel

10. Click the icon in the edit column for the Domain attribute.

a. Enter the Domain information used in cluster setup in the Scaler Value box.
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b. Click Ok.

F* Edit Attribute X

[:i UFIService

Domain
The damain name ko which the user specified in the Userfccount attribute belonags.
Moke This attribute can take localized values.

+ GElobal Scalar Walue I

= Per System |
VDCEN-NODEA v |

Ik Cancel

11. Click the icon in the edit column for the Service Arguments attribute.

a. Inthe Vector Values field, enter the path to the Email Manager configuration file prefixed
with the text “-cfg=". The configuration file is located in the Email Manager installation
folder in the sub folder “Config” and is named “default.emgr” by default. The full path
should be used and the path should be enclosed in quotation marks. To verify the path, in
the Services screen, select “eMgr Universal File Importer”, right click and select and
select Properties. The Path to executable field will contain a reference to the location of
the configuration file used by Email Manager. The following is the default value:

-cfg="C:\Program Files\FileNet\Email Manager Server 3.7\Config\default.emgr"
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b. Click Ok.

F* Edit Attribute X

@  Edit Attribute

service_arg
an array of arguments passed to the service,

+ Global Yeckar Yalues
¢ Per System cFg="C:\Program Files'FilehetiEmail Mang

+
VDC-EN-NODER. v | e

Ok Zancel

12. In Cluster Manager, right click on the UFIService and then click Enabled.

1" clusterveritas - Cluster Explorer : ADMINISTRATOR@YTGOAPS3S5 { Cluster Administrator ) = |EI|£|

File Edit Yiew Tools Help

b R & L BOOERALB @

) I & | "] | Statusl = Propertiesl
5 clusterveritas i :
2 Inskancel ¥ Status View: UFIService
IJ:'|—‘ GenericService
8 %) Pnacaepee Status on Member Systems
UFIService
T y pme State Istate Flags
anline » DEA Offline Mok 'Waiting Mormal
Cffline ¥ DEB Offline Mok 'Waiting Mormal
Offline Frap 3
Cleat Fault i I Critical /Error Logs
e ; e available.
v Critical
Ll
Lrlirabe o
Akions..,
RefreshResource Infa k
Clear Resource Infio
Zopy 3
Paste 3
Delate
I
13. In Cluster Manager, right click UFIService and select Online for the appropriate node.
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14. Select Yes when prompted.

o Are wou sure you wank to bring UFIService online on YDiC-EMN-MODEE?

]

15. In Cluster Manager, right click InstanceO and select Add Resource.

16. In the Add Resource dialogue box:

a. Enter “ExchConn” in the resource name box.
b. Click Ok

:" Add Resource y

E@ Add Resource

Group name: Instancel

Resource name: IExchCDnn

Resource Tvpe:

IGenericService LI = !

Attribuke name I Type I Dimension I Yalue I Edit I
Celayafteronline  Inkeger Scalar 10 &3 - |
Celayafterffline Inkeger Scalar 10 £
ServiceMame String Scalar ¥
Llserfccount Skring Scalar £
Password Bkring Scalar ¥
Ninrnain =krimn =ralar for ;I

¥ Critical v
% |, Show Command ok, | Cancel |

17. Click the icon in the edit column for the ServiceName attribute.

a. Enter “ExchConn” in the Scaler Value box.
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b. Click Ok.

F* Edit Attribute X

@ EmchConn

ServiceNMame
Mame of the service to be monitored, The service name can be the Service
Display Mame or the Service Eey Mame, This attribute can take localized values,

Scalar Value I

£~ Per System |
VDCEN-MODER. v |

Ok Zancel

18. Click the icon in the edit column for the UserAccount attribute.
a. Enter the administrative account name used in the cluster setup in the Scaler Value box.
b. Click Ok.

+* Edit Attribute Pl

@ ExchConn

can be of the Form username@domain, com or domain.comiusernames, IF vou ;I
do not specify a value for this attribute, then the user account of the service

in the SCM is ignored, Ta monitar service under built-in accaunts, you musk
provide explicit values, For example, on Windows

2000; Userdccount="Local3ystem’ On Windows 2003:

serAccount="LocalSvstem', 'Local Service', or MWetwork Service', Domain="MT
Authority', This sktribuke can bake localized values, ;I

+ GElobal Scalar Walue I

£ Per System |
[iocentopes 7|

Ik | Zancel |

19. Click the icon in the edit column for the Password attribute.

a. Enter the administrative account password used in cluster setup in the Scaler Value box.
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b. Click Ok

F* Edit Attribute X

@ EmchConn

Password

The password of the user, under the context of which, the service would be
started, If the UserfAccount attribute is empty or a built-in service account, this
attribute is ignored.

(+ Globat Scalar Value |

£~ Per System |
VDCEN-MODER. v |

Ok Zancel

20. Click the icon in the edit column for the Domain attribute.
a. Enter the Domain information used in cluster setup in the Scaler Value box.
b. Click Ok.

+* Edit Attribute Pl

@ ExchConn

Domain
The domain name ko which the user specified in the Userdccount atkribute
belongs. Mote This attribute can bake localized values,

% rGlobat Scalar Walue I

£ Per System |
[iocentopes 7|

Ik | Zancel |

21. Click the icon in the edit column for the Service Arguments attribute.

a. Inthe Vector Values field, enter the path to the Email Manager configuration file prefixed
with the text “-cfg=". The configuration file is located in the Email Manager installation
folder in the sub folder “Config” and is named “default.emgr” by default. The full path
should be used and the path should be enclosed in quotation marks. To verify the path, in
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the Services screen, select “eMgr Universal File Importer”, right click and select and
select Properties. The Path to executable field will contain a reference to the location of

the configuration file used by Email Manager. The following is the default value:

-cfg="C:\Program Files\FileNet\Email Manager Server 3.7\Config\default.emgr"

b. Click Ok.

22. In Cluster Manager, right click ExchConn and select Link.

File Edit Miew Tools Help

£ clusterveritas - Cluster Explorer : ADMINISTRATOR@YTGOAPS35 ( Cluster Administrator )

=1ol x|

i HLd & OB HEOO yERER @

E%l o | & | . Statusl = Propertiesl

Just it
= c%u s;r;::;so G#  Status ¥iew: ExchConn

@ GenericService
.'I"EI UFIService @ Resource Status on Member Systems

o | Ee— Pm Mame State

EN-NODEA Offline
EM-NODEB Offline

View

-

Online

Istate
Mok YWaiting
Mok Waiting

Flags
Marmal

Normal

Offline:

Offline Prop iecent Critical /Error Logs

Clear Fault gs are available.

- v v v w

Probe

 Enabled
w Critical

e —

Irmlirabe. o

Aekions, .,

RefrestiResource Infa. b

Clear Resource Info

Copy L]
Paste ]

Delste

23. In the Link Resources dialogue box:
a. Select UFIService.
b. Click Ok.

4 Link Resources

':i Parent Resource: ExchConn

Group: Inskancel
Child Resource:

Ik Zancel
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24. In Cluster Manager, right click ExchConn and select Online for the appropriate node.

2 clusterveritas - Cluster Explorer : ADMINISTRATOR@YTGQAPS35 { Cluster Administrator ) =10 =]
_Eile Edit Wiew Tools Help
ddhm Eed & DD BOOyEwdEE @
:f’i‘a| =T | | "] I ) Statusl = Propertiesl
cé:_;l;st;r;z:t;sﬂ i# Status ¥Yiew: ExchConn
@ GenericService
.EE' UFIService (+) Resource Status on Member Systems
5 B Ey chConn h Mame State IState Flags
Wiew * J-NODEA Offline Mot taiting Marrnal
YDC-EN-MODEA | Offline Mot Waiting Mormal
Offline » -EN-NODEB
Offline Brop » fent Critical/Error Logs
Clear Fault » & are available.
Frobe 4
v Enabled
v Critical
Limke
unlink. ..
Ackions,,
Refresh Resource Infa k.
ClearResourtce Info
Copy L]
FPaste »
Delete
1l
25. Select Yes when prompted.
guestion x|
o Are wou sure you wank to bring ExchConn online on YDC-ER-MODER?
Mo
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3 SYMMETRICAL SERVER CONFIGURATION

To maximize resource usage when deploying an active/passive cluster, two or more completely separate
instances of Email Manager may be run on each node in the cluster. At any given time, a node in the
cluster will be running one active instance of Email Manager, and have other instances in a passive state
— providing failover for the other nodes in the cluster. The email folders to be monitored must be split
between two different Email Manager servers. Each server will provide failover support for the other — if
one email manager server goes down, the other will start doing double duty.

Note: When running two instances of Email Manager concurrently, ensure that the Monitored Locations
that each instance of Email Manager is configured to monitor do not overlap. Overlap of Monitored
Locations may result in unexpected behaviour of the system.

3.1 Email Manager Installation

To install two instances of Email Manager on a single machine, do the following:
1. Start the Email Manager Server installer.

2. Step through the installation wizard as described in the Email Manager Setup Guide until the
Setup Type screen is reached. In this screen, choose “Custom”

il FileNet Email Manager Server 3.7 Setup = x|

Setup Type

Choose the setup type that best suits vour needs,

Please select a setup kype,

" Complete
[ All program Features For your chosen mail server and repository will
I o be installed.

Choose which program Features wou want installed and where thew
will be installed, Recommended for advanced users,

< Back I Mexk = I Cancel

3. Inthe Custom Setup screen, under the node “Install second instance of eMgr services, select the
source connector being used. And click Next.
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i FileNet Email Manager Server 3.7 Setup

Custom Setup

Select the program features ywou want installed,

Zlick. on an icon in the list belov to change how a Feature is installed.

;I = Feature Mescription

Installs a second instance of the
Exchange Connector For

e » v| File System Conneckor
i =l = | eMar Clienk Web Services

--------- i=3 = | Universal File Importer Service supporting high-awailability
......... ¥ = | Symbal Files {.pdb) installations of Microsoft
U] =)l = | Install second inskance eMgr services. Exchange

This Feature requires OKE on
vour hard drive,

Install second Exchange Connector in
Install second PST Conneckar instance
Install second Lotus Mokes Conneckor

Kl — |

Help | < Back I Mexk = I Zancel

4. In the Ready to Install the Program screen, click Install to complete the installation.

5. Click Finish to close the installer.

Configure the first instance of Email Manager as follows:

1. Launch the Configuration Manger be selecting Start > FileNet Email Manager 3.7 > Server >
Configuration Manager.

2. Enter the database connection information for the database that will store the configuration
settings for the first instance of Email Manager.
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Database Connection . x|

[3 Database Connection

Server Mame:

~Logon Information
User Mame: Password:

I I Retrieve Databases |

~Database Information

Database

(a4 I Cancel |

3. Configure the first instance of Email Manager (create Rules, Index Templates and Profiles as
required).

Configure the second instance of Email Manager as follows:

1. Launch the Configuration Manger be selecting Start > FileNet Email Manager 3.7 > Server >
Configuration Manager 1.

2. Enter the database connection information for the database that will store the configuration
settings for the second instance of Email Manager. Ensure that the second instance is connecting
to a different database than the first instance.

3. Ensure the file folders and communication ports used by the second instance do not conflict with
the first instance. To do this, open the Configuration Options screen by clicking on the
Configuration Options node and right clicking and selecting Edit

a. Change the Temporary File Folder and Log File Locations values to be different than the
values entered for the first instance of Email Manager.

b. Inthe UFI Remote Interface section, change the value of port number by incrementing or
decrementing the default value by one.

c. Click Ok to save the updates.

4. Complete the rest of the configuration of the second instance of Email Manager (create Rules,
Index Template and Profiles as required). Ensure that Monitored Locations in any Profiles created
do not overlap with Monitored Locations used in Profiles in the first instance of Email Manager.

eMgr High Availability Configuration 25



Repeat the above installation and configuration steps for Email Manager on the second node in the
cluster. Note that the database user by instance one on the second node should match the database
used by instance one on first node. As well, the database user by instance two on the second node
should match the database used by instance two on first node.

3.2 Microsoft Cluster Server Configuration

After installing the two instances of Email Manager on each node in the cluster, configure each instance
of Email Manager.

Configure the first instance of Email Manager according to the instructions in the section 2.1 Microsoft
Cluster Server Configuration.

Configure the second instance of Email Manager as follows:

1. Launch the Windows Cluster Administrator from Start > Programs > Administrative Tools >
Cluster Administrator

2. Create a new group by selecting File > New Group.
a. Enter “Groupl” in the name field and a description and click Next.

b. Select the node in the cluster that the second instance of Email Manager should use at
its preferred node and click Finish. It is suggested a node other than the node that was
selected as the preferred node for the first instance of email manager be used.

3. To create a new resource, right click on Groupl and select New Resource.
a. Inthe New Resource screen:
i. Enter “UFIServicel” in the Name field
ii. Enter “UFIServicel” in the Description field
iii. Select “Generic Service” in the Resource Type field.
iv. Select “Groupl” in the Group field.
v. Click Next.
b. Inthe Possible Owners screen, select the nodes that will be in the cluster and click Next.
c. Inthe Dependencies screen, click Next.
d. Inthe Generic Service Parameters screen:
i. Enter “UFIServicel” in the Service name field.

ii. Inthe Start parameters field, enter the path to the Email Manager configuration
file prefixed with the text “-cfg=". The configuration file is located in the Email
Manager installation folder in the sub folder “Config” and is named
“instancel.emgr” by default. The full path should be used and the path should be
enclosed in quotation marks. To verify the path, in the Services screen, select
“eMgr Universal File Importer-1”, right click and select and select Properties. The
Path to executable field will contain a reference to the location of the
configuration file used by Email Manager. The following is the default value:

-cfg="C:\Program Files\FileNet\Email Manager Server
3.7\Config\instancel.emgr"

ii. Click Next
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iv. Inthe Registry Replication screen, click Finish.

4. In Cluster Administrator, find Group1l in the Active Groups of one of the nodes. Right Click on
Groupl and select New > Resource to open the New Resource Screen.

a. Inthe New Resource screen:
i. If Email Manager for Exchange is being used:
1. Enter “ExchConnl” in name field
2. Enter “ExchConn Servicel” in description field
ii. If Email Manager for Lotus Domino is being used:
3. Enter “LotusConnl” in name field
4. Enter “LotusConn Servicel” in description field
iii. If Email Manager for PST files is being used:
5. Enter “PSTConnectorl” in name field
6. Enter “PSTConnector Servicel” in description field
iv. Select “Generic Service” in resource type field.
v. Select “Groupl” in group field.
vi. Click Next.
b. Inthe Dependencies screen:
i. Select UFIServicel and click Add to add it to the Resource Dependencies list.
ii. Click Next.
c. Inthe Generic Service Parameters screen:
i. If Email Manager for Exchange is being used:
7. Enter “ExchConnl” in the Service name field
ii. If Email Manager for Lotus Domino is being used:
8. Enter “LotusConnl” in the Service name field
iii. If Email Manager for PST files is being used:
9. Enter “PSTConnectorl” in the Service name field

iv. Inthe Start parameters field, enter the path to the Email Manager configuration
file prefixed with the text “-cfg=". The configuration file is located in the Email
Manager installation folder in the sub folder “Config” and is named
“instancel.emgr” by default. The full path should be used and the path should be
enclosed in quotation marks. To verify the path, in the Services screen, select
“eMgr Universal File Importer-1”, right click and select and select Properties. The
Path to executable field will contain a reference to the location of the
configuration file used by Email Manager. The following is the default value:

-cfg="C:\Program Files\FileNet\Email Manager Server
3.7\Config\instancel.emgr"
v. Click Next.

d. Inthe Registry Replication screen, click Finish.
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e. To enable the cluster for the second instance of Email Manager, right click on Groupl
and select Bring Online.

3.3 Veritas Cluster Server Configuration

After installing the two instances of Email Manager on each node in the cluster, configure each instance
of Email Manager.

Configure the first instance of Email Manager according to the instructions in the section 2.2 Veritas
Cluster Server Configuration.

Configure the second instance of Email Manager as follows:

1. Click Start>Programs>Veritas>Vertias Cluster Manager — Java Console to run the Veritas
console.

2. Right click on the cluster name and select Add Service Group.
3. Inthe Add Service Group dialogue box:
a. Enter “Instancel” as the Service Group Name.

b. Under the Available Systems box, add both nodes in the cluster to Systems for Service
Group.

c. Click Ok.
4. Right Click the Instancel just created and select Add Resource.
In the Add Resource dialogue box:,
a. Enter “UFIServicel” in the Resource Name box.
b. Select GenericService in the resource type box.
c. Click Ok.
6. Click the icon in the edit column for the Service Name attribute to open the Edit Attribute screen:
a. Enter “UFIServicel” in the Scaler Value box.
b. Click Ok.
7. Click the icon in the edit column for the UserAccount attribute.
a. Enter the administrative account name used in the cluster setup in the Scaler Value Box.
b. Click Ok.
8. Click the icon in the edit column for the Password attribute.
a. Enter administrative account password used in cluster setup in the Scaler Value box.
b. Click Ok.
9. Click the icon in the edit column for the Domain attribute.
a. Enter the Domain information used in cluster setup in the Scaler Value box.
b. Click Ok.
10. Click the icon in the edit column for the Service Arguments attribute.

a. Inthe Vector Values field, enter the path to the Email Manager configuration file prefixed
with the text “-cfg=". The configuration file is located in the Email Manager installation
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11.
12.
13.
14.
15.

16.

17.

18.

19.

20.

21.
22.

folder in the sub folder “Config” and is named “instancel.emgr” by default. The full path
should be used and the path should be enclosed in quotation marks. To verify the path, in
the Services screen, select “eMgr Universal File Importer-1”, right click and select and
select Properties. The Path to executable field will contain a reference to the location of
the configuration file used by Email Manager. The following is the default value:
--cfg="C:\Program Files\FileNet\Email Manager Server 3.7\Config\instancel.emgr"
b. Click Ok.
In Cluster Manager, right click on the UFIServicel and then click Enabled.
In Cluster Manager, right click UFIServicel and select Online for the appropriate node.
Select Yes when prompted.
In Cluster Manager, right click Instancel and select Add Resource.
In the Add Resource dialogue box:
a. Enter “ExchConnl” in the resource name box.
b. Click Ok
Click the icon in the edit column for the ServiceName attribute.
a. Enter “ExchConnl” in the Scaler Value box.
b. Click Ok.
Click the icon in the edit column for the UserAccount attribute.
a. Enter the administrative account name used in the cluster setup in the Scaler Value box.
b. Click Ok.
Click the icon in the edit column for the Password attribute.
a. Enter the administrative account password used in cluster setup in the Scaler Value box.
b. Click Ok
Click the icon in the edit column for the Domain attribute.
c. Enter the Domain information used in cluster setup in the Scaler Value box.
d. Click Ok.
Click the icon in the edit column for the Service Arguments attribute.

e. Inthe Vector Values field, enter the path to the Email Manager configuration file prefixed
with the text “-cfg=". The configuration file is located in the Email Manager installation
folder in the sub folder “Config” and is named “instancel.emgr” by default. The full path
should be used and the path should be enclosed in quotation marks. To verify the path, in
the Services screen, select “eMgr Universal File Importer-1”, right click and select and
select Properties. The Path to executable field will contain a reference to the location of
the configuration file used by Email Manager. The following is the default value:

--cfg="C:\Program Files\FileNet\Email Manager Server 3.7\Config\instancel.emgr"
f.  Click Ok.
In Cluster Manager, right click ExchConn1 and select Link.
In the Link Resources dialogue box:

g. Select UFIServicel.
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h. Click Ok.
23. In Cluster Manager, right click ExchConnl and select Online for the appropriate node.

24. Select Yes when prompted.
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