[image: image1.png]== FILENET




FileNet Vancouver Development Centre 

[image: image1.png]

Email Manager 3.5 to 3.6 Upgrade Guide TITLE  \* MERGEFORMAT 
Email Manager 3.5 to 3.6 Upgrade Guide

This document describes how to upgrade an Email Manager 3.5 system to Email Manager 3.6. The upgrade involves the following steps:
· Update Email Manager database

· Update Email Manager Server software

· Update Email Manager Client software

To following is required to perform an upgrade:

· Email Manager 3.6 GA release software

· Email Manager 3.5 to 3.6 database upgrade scripts

An Upgrade Worksheet is included at the end of this document. Use this worksheet to record current Email Manager 3.5 settings that will need to be reset after installing Email Manager 3.6.
Updating the Email Manager Database
The Email Manager database contains all configuration data used by Email Manager. A database script must be run against the Email Manager database to allow a 3.5 database to be used by Email Manager 3.6. Before upgrading the database, it is suggested a backup or copy of the database be made.

The following table shows the database types supported by Email Manager and the name of the upgrade script required. The upgrade script is available in the Email Manager upgrade package.
	Database Type
	Script Name

	Microsoft SQL Server 7.0/2000
	mssql_em35_em36_upgrade.sql

	Oracle 8i/9i/10g
	ora_em35_em36_upgrade.sql


SQL Server Upgrade
In the Upgrade Worksheet, record the database connection information for the Email Manager Database. The database connection information may be accessed in the Email Manager Configuration Manager by selecting the menu option File -> Update Database Connection.

· Record Server Name under SQL Server Host Machine
· Record User Name under SQL Server Username/Password
· Record Database under SQL Server Database
Upgrade the Email Manager 3.5 database as follows:

1. Open SQL Server Enterprise Manager.
2. Either backup or make a copy of the Email Manager database.

a. To make a copy of the database, do following:

i. Expand the node in the tree for the SQL Server that the Email Manager database is installed on (SQL Server Host Machine in the Upgrade Worksheet).

ii. Create a new database by right clicking on the Databases node and select the option New Database.

iii. Copy the Email Manager database (SQL Server Database in the Upgrade Worksheet) to the newly created database.

1. Select the newly created database in the tree and select the option All Tasks -> Import Data.

2. In introduction screen, click Next.
3. In the Choose a Data Source screen: 

a. For Server, enter the name of the database server the Email Manager database is located on. 

b. Select Use SQL Server Authentication, and enter the username and password for the SQL Server user.

c. In the database drop down, select the Email Manager database

d. Click Next.

4. In the Choose a Destination screen, values for the destination database should be pre-selected. Click Next.

5. In the Specify Table Copy or Query screen, select the option “Copy objects and data between SQL Server databases”. Click Next.
6. In the Select Objects to Copy screen, accept the default values. Click Next.

7. In the Save, Schedule, and Replicate Package screen, ensure the option Run Immediately is selected, and click Next to copy the database.

8. Click Finish after the copy if completed.

b. To backup the database, do the following:

i. Expand the node in the tree for the SQL Server that the Email Manager database is installed on.

ii. Expand the Databases node, select the Email Manager database, right click and select All Tasks -> Backup.

iii. In the Backup screen, specify the Destination for the backup by clicking the Add button in the Destination section.

iv. Click Ok to run the backup

3. In the Database section in the tree, select the Email Manager Database (SQL Server Database in the Upgrade Worksheet). In the menu, select Tools -> SQL Query Analyzer to open the Query Analyzer tool.

4. In Query Analyzer, in the menu, select File -> Open and select the script file mssql_em35_em36_upgrade.sql, include with the Email Manager 3.6 upgrade package. Ensure the database currently selected is the Email Manager database.
5. To run the script, in the menu select Query -> Execute. 
6. If any error messages are displayed, contact FileNet support for assistance.

Oracle Upgrade

In the Upgrade Worksheet, record the database connection information for the Email Manager Database. The database connection information may be accessed in the Email Manager Configuration Manager by selecting the menu option File -> Update Database Connection.

· Record Service under Oracle Host/SID
· Record User Name under Oracle Username/Password
Upgrade the Email Manager 3.5 database as follows:

1. Open Oracle Enterprise Manager Console.

2. Expand the Databases section and select the database that contains the Email Manager schema (Oracle Host/SID in the Upgrade Worksheet).
3. Login as the user that contains the Email Manager schema  (Oracle Username/Password in the Upgrade Worksheet).

4. To backup the database, right click on the database and select Backup Management -> Backup. Follow the instructions for backup of the database. Contact the local Oracle administrator if further assistance is required.
5. Open SQL*Plus.

6. Login as the user that contains the Email Manager schema (Oracle Username/Password in the Upgrade Worksheet).

7. To run the script, enter “@” followed by the location of the database script, ora_em35_em36_upgrade.sql. i.e. @c:\ora_em35_em36_upgrade.sql

8. If any error messages are displayed, contact FileNet support for assistance.

Email Manager Server Upgrade
To upgrade the Email Manager server from 3.5 to 3.6, the Email Manager 3.6 GA installer is required.
1. Login to the Email Manager Server machine.

2. Open the Services screen, and make a note of the service accounts used to run the following services and record the values in the Upgrade Worksheet.
a. eMgr Exchange Connector (if Exchange Server is being used)

b. eMgr Lotus Connector  (If Lotus Domino is being used)

c. eMgr Universal File Importer

3. Open the registry editor, by selecting Start -> Run and entering the command regedit.
a. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Yaletown Technology Group Inc.\eCW\5.0\RMWrapper and note the value of the RMPath key in the Upgrade Worksheet next to RM API Path.

b. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Yaletown Technology Group Inc.\eCW\5.0\Settings\Debug and, if it exists, note the value of the ResolveDistributionLists key in the Upgrade Worksheet next to Resolve Distribution Lists Flag. 
4. Stop the following services:

a. eMgr Exchange Connector (if Exchange Server is being used)

b. eMgr Lotus Connector  (If Lotus Domino is being used)

c. eMgr Universal File Importer

5. If the Services window is open, close it.

6. If Outlook or Lotus Notes is open, close it.

7. If the Email Manager Configuration Manager is open, close it.

8. Open Control Panel by selecting Start -> Control Panel, and run Add/Remove Programs.

9. Select FileNet Email Manager Server 3.5 and click Remove.

10. Run the Email Manager 3.6 installer included in the Email Manager 3.6 GA release. 

a. In the Introduction screen, click Next.
b. In the License Agreement screen, select “I accept the terms in the license agreement” and click Next.

c. In the Customer Information screen, click Next.

d. In the Server Options screen, select the Email Server being used, FileNet Repository Type and Database Type. Click Next.

e. In the Setup Type screen, select Complete and click Next.

f. Click Finish to complete the installation.

11. Open the registry editor, by selecting Start -> Run and entering the command ‘”regedit”.

a. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\FileNET\Email Manager\3.6\Settings\RMWrapper and enter the value recorded in Upgrade Worksheet for RM API Path in the key RMPath.

12. If the Email Manager database has not already been upgraded, upgrade it now. The remaining steps will fail if the database has not been upgraded to Email Manager 3.6.

13. Select Email Manager Configuration Manager in the menu Start -> Programs -> FileNet Email Manager 3.6 -> Server
14. In the Database Connection screen, select the Data Store Type.

a. For Microsoft SQL Server, referencing the Upgrade Worksheet, enter the Server Name (SQL Server Host Machine), and the User Name and Password (SQL Server Username/Password). Click Retrieve Databases, and select the SQL Server Database.

b. For Oracle, referencing the Upgrade Worksheet, enter the Service (Oracle HOST/SID), and the User Name and Password (Oracle Username/Password). Click Validate Database to verify the information entered is correct.

c. Click Ok to login to the selected database.

15. If any error messages show while opening the Configuration Manager, contact FileNet support for assistance.

16. Right click on the node Configuration Options and select Edit.

a. Verify that the locations specified for Temporary Files Folder and Log File Location exist on the server. If they do not exist, either create the folders or change the location to a location that does exist. Ensure the users used for the Email Manager services have “Full Control” on the folders. The users can be found in the Upgrade Worksheet under eMgr Exchange Connector Service Username/password, eMgr Lotus Connector Service Username/password, eMgr Universal File Importer Service Username/password.
17. Right click on the node for the Email Server Connector being used (either Microsoft Exchange Connector or Lotus Notes Connector) and select Edit.

18. In the Email Connector screen, in the General Settings section, set the value of “Resolve address in distribution lists” as follows based on the value in the Upgrade Worksheet for Resolve Distribution Lists Flag:

a. If the value is “1”, select the option “Resolve address in distribution lists”
b. If the value is “0”, de-select the option “Resolve address in distribution lists”

19. Click Ok to accept the updates.

20. Open the Services screen, and update the service accounts used to run the following services based on the corresponding values entered in the Upgrade Worksheet.

a. eMgr Exchange Connector (if Exchange Server is being used)

b. eMgr Lotus Connector  (If Lotus Domino is being used)

c. eMgr Universal File Importer

21. The upgrade is now complete. To restart Email Manager, start the following services:

a. eMgr Universal File Importer.

b. eMgr Exchange Connector (if Exchange Server is being used)

c. eMgr Lotus Connector  (If Lotus Domino is being used)
Email Manager Client Upgrade
End user workstations that have the Email Manager 3.5 Client installed must be upgraded to Email Manager 3.6. Prior to upgrading the Client, determine the Email Manager Web Services URL and record it in the Upgrade Worksheet under Email Manager Web Services URL. The web services URL can be found on a client workstation under the following registry key HKEY_LOCAL_MACHINE\SOFTWARE\Yaletown Technology Group Inc.\eCW Client API\5.0\eCWWebServicesURL
Upgrade each workstation as follows:

1. Login to the workstation as a user who has permissions to install software.

2. Ensure Outlook or Lotus Notes are closed.

3. Run the Email Manager 3.6 Client installer included in the Email Manager 3.6 GA release. 
4. In the Welcome screen click Next.

5. In the License Agreement screen, if you agree with terms in the license, select the “I accept the term in the license agreement” radio button and click Next.

6. In the Customer Information screen, update customer information as required and click Next.

7. In the Email Manager Client Options screen, select the email client being used and click Next

8. In the Email Manager Document Repository screen, select the document repository being used and click Next

9. In the Email Manager Server Information screen, in the eMgr Web Service URL field, enter the Email Manager Web Services URL recorded in the Upgrade Worksheet. Click Next.
10. Click Install to begin the installation.
The following additional steps are required if using Lotus Notes:

1. Close the Lotus Notes Client if it is open.

2. In the menu, select Start -> Programs -> FileNet Email Manager 3.6 -> Install Lotus Notes Toolbar

3. Open the Lotus Notes Client. 

4. If using Lotus Notes 6.x, the Email Manager components should be added to the toolbar. If using Lotus Notes 5.x, follow these additional steps:

a. To include the Email Manager smart icon in the toolbar, select the menu option File -> Preferences -> SmartIcon Settings. The SmartIcon Settings screen showing available icons will appear.
b. If the Email Manager 3.5 SmartIcon is installed it will appear in the right-hand panel.  Select the existing SmartIcon and drag it to the left-hand Available Icons panel.  This will remove the button from the current SmartIcon set.
c. Scroll down in the Available Icons panel and locate the Email Manager 3.6 Capture icon (this usually appears at the bottom below the existing Macro buttons).  Drag the Capture Icon into the right‑hand panel to add it to the current SmartIcon set.  Click OK.
d. The client icon will now appear on the toolbar of the Lotus Notes Client 5.0.
To run the Email Manager Client installer in “silent” mode or via a script, use msiexec.exe with the flag “/q”. The following table summarizes flag that may be used when installing using msiexec.exe.

	Parameter
	Description

	ECWWEBSERVICESURL 
	May be used to specify Email Manager Web Services URL that will be used. The default value is “http://<host_name>/ecwwscs50/ecwwscs.asmx?wsdl“

Example:

msiexec /i "FileNet Email Manager Client 3.6.msi" ECWRWEBSERVICESURL="http://my_server/ECWWSCS50/ECWWSCS.asmx?wsdl"

	INSTALLDIR
	May be used to specify what folder Email Manager should be installed in. The default value is “%Program Files%/\FileNet\Email Manager Client 3.6”

Example:

msiexec /i "FileNet Email Manager Client 3.6.msi" INSTALLDIR ="C:\eMgr" 

	EMAILCLIENT
	May be used to specify which email client the software should be installed for. The default value is “OUTLOOK”

For Outlook XP/2003, specify "OUTLOOKXP"
For Outlook 2000, specify "OUTLOOK2000"
For Lotus Notes 6.0.3 to 6.5.x, 7.0, specify "NOTES6DXL"
For Lotus Notes 6.0.2, specify "NOTES6"
For Lotus Notes 5.0.x, specify "NOTES5"
Example:

msiexec /i "FileNet Email Manager Client 3.6.msi" EMAILCLIENT="OUTLOOKXP"

	FILENETREPOSITORY
	May be used to specify which document repository the software should be installed for. The default value is “FILENET_CS”
For FileNet Content Services, specify “FILENET_CS”

For FileNet Image Services, specify “FILENET_IS”

For FileNet P8 Content Engine, specify “P8_CE”

Example:
msiexec /i "FileNet Email Manager Client 3.6.msi" FILENETREPOSITORY="P8_CE"

	DXLIMPORTENABLED
	May be used to specify whether the option to import DXL files into Lotus Notes should be enabled. The default value is “0”, representing “off”.

To turn on DXL file import support, set the value to 1.

To turn off DXL file import support, set the value to 0.

Example:

msiexec /i "FileNet Email Manager Client 3.6.msi" DXLIMPORTENABLED="1"

	LOTUSCLIENTDBPATH
	For Lotus Notes, may be used to specify the client database to use. If set, this setting will override the client database specified via the Configuration Manager. 

Example:

msiexec /i "FileNet Email Manager Client 3.6.msi" LOTUSCLIENTDBPATH="clientdb.nsf"

	LOTUSCLIENTDBSERVER
	For Lotus Notes, may be used to specify the Domino server that the client database resides on. If set, this setting will override the client server location specified via the Configuration Manager. 

Example:

msiexec /i "FileNet Email Manager Client 3.6.msi" LOTUSCLIENTDBSERVER="mailserver"

	TRAYICON
	For Lotus Notes, may be used to specify whether the client icon should show in the task tray to indicate that the client has been loaded. Setting the value to 1 will enable the tray icon and setting the value to 0 will disable the tray icon. The default value is 1.

Example:

msiexec /i "FileNet Email Manager Client 3.6.msi" TRAYICON="1"

	/q
	This parameter may be specified for msiexec (the Windows Installer application) if a “silent” install (no user interface is shown for the installer) is required. If this mode is being used, if values other than the defaults are required for the parameters, those values must be specified.
Example:

msiexec /i /q "FileNet Email Manager Client 3.6.msi" TARGETDIR="C:\eMgr" ECWWEBSERVICESURL=http://my_server/ecwwscs50/ecwwscs.asmx?wsdl EMAILCLIENT="OUTLOOKXP" FILENETREPOSITORY="P8_CE"


Upgrade Worksheet

	Item
	Value

	SQL Server Host Machine
	

	SQL Server Database
	

	SQL Server Username/Password
	

	Oracle HOST/SID
	

	Oracle Username/Password
	

	eMgr Exchange Connector Service Username/password
	

	eMgr Lotus Connector Service Username/password
	

	eMgr Universal File Importer Service Username/password
	

	RM API Path
	

	Resolve Distribution Lists Flag
	

	Email Manager Web Services URL
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