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nector Module
mponent of the RightFax Connector for 
ightFax server and FileNet Capture 
 higher. Capture Professional is then 
ents from the RightFax server to the 
et product suite supported by your 

ional.

received by the RightFax server can be 
 or per-user basis. Once the Connector 
and configured, fax documents from one 
ill be automatically imported into your 

ector module
nsists of these components:

or for FileNet P8  This is the software 
rver to communicate with each of the 
nd the FileNet P8 server. This connector 
 server.

t Connector (EDC)  This is a service 
erver during the server installation. The 
ctor monitors RightFax for files to store 
 then coordinates the activities of the 
ectors as fax documents are passed 
Chapte

er 1

alling the RightFax Connector for FileNet P8

iew of the RightFax Connector
eNet P8
he RightFax Connector for FileNet P8 lets you archive both sent 
nd received fax documents from your RightFax server into a 
ileNet data repository. With the RightFax Connector for FileNet 
8 you can:

Send documents from your FileNet data repositories as faxes via 
the RightFax server. 

Automatically or manually index fax documents received via the 
RightFax server.

Use capture paths to commit RightFax documents to a document 
data repository.
Use Fax Entry to commit RightFax documents to a document 
repository.

Print archived RightFax documents based on document data, 
such as the RightFax user ID, billing information, or job type 
(received, sent, or print job).

he RightFax Connector for FileNet P8 consists of two modules: 
he Connector module and the Outbound module (described in 
hapter 3, “Using the Outbound Module to Send FileNet 
ocuments as Faxes”. You can install both of these modules or 
ither module separately, depending on the needs of your 
rganization.

Understanding the Con
The Connector module co
FileNet P8 connects the R
Professional version 4.0 or
configured to move docum
data repository of any FileN
version of Capture Profess

Documents sent from and 
archived on a system-wide
module has been installed 
or more RightFax servers w
FileNet data repository.

Components of the Conn
The Connector module co

The RightFax Connect
that allows the RightFax se
connector’s components a
is installed on the RightFax

The External Documen
installed on the RightFax s
External Document Conne
in the FileNet repository. It
other processors and conn
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am illustrates the progress of a document as it 
ghtFax server into a FileNet data repository.

 Documents in a FileNet data repository

Installation
he RightFax Connector for FileNet P8, make 
tFax and FileNet P8 systems meet the following 

r version 9.0 or higher is installed and operating.

s/RightFax folder and all subfolders must be 
 access to the Capture Professional workstation 
e incoming fax documents.
Professional version 4.0 or higher must be 
 network and must have all available patches 
into the repository. This chapter includes information on installing 
and configuring the External Document Connector. For a more 
complete description of the External Document Connector, see 
Appendix A, “Understanding the External Document Connector”.

The RightFax Connector for Capture Professional  This is 
the software that allows the RightFax External Document 
Connector to pass files into Capture Professional or to Fax Entry, 
which moves them into the FileNet repository. The RightFax 
Connector for Capture Professional is installed on a Capture 
Professional workstation and emulates an intelligent scanner. It 
bundles the RightFax documents into batches and delivers them to 
Capture Professional or it holds them for retrieval by Fax Entry.

How documents are moved into the FileNet repository
Fax documents on the RightFax server are picked up by the 
External Document Connector and passed through the RightFax 
Convert processor, the RightFax Connector for Capture 
Professional, and the RightFax Print processor.

� The Convert processor converts the document files to the 
required single-page TIFF format.

� The RightFax Connector for Capture Professional organizes the 
fax documents into batches (including the fax images and 
document data that can be used for indexing purposes) and 
imports them into Capture Professional.

� The Print processor optionally prints the fax documents. Capture 
Professional then moves the fax documents into the FileNet data 
repository via capture paths or via Fax Entry.

The following diagr
is routed from a Ri

Figure 1.1  Archiving

Preparing for the 
Before you install t
sure that your Righ
requirements:

� A RightFax serve

� The Program File
shared, providing
which will manag

� FileNet Capture 
installed on your
applied.
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r on the RightFax Server
server and insert the Connector for 
D. If AutoRun is enabled, a menu of 

 If AutoRun is not enabled, browse the 
xe.

ll the Connector on the RightFax 
connector installation wizard.

ng screen to view the RightFax license 
ccept the license agreement in order to 
. Click Next.

 installation is complete, click Finish.

ort to activate
or FileNet P8
tor for FileNet P8 has been installed, the 
. To activate the connector software, 
ct Support Group at (520) 320-7070. A 

 assist you through the activation 

mponent to the EDC
tor for FileNet P8 has been installed, and 
st add the FileNet P8 module to the 

ctor.

odule to the EDC

, select Start > All Programs > 
. This opens the EDC Monitor 

ration to open the Captaris EDC 
ox.
Chapte

nce you have met these requirements, complete the following 
teps to install and configure the RightFax Connector for 
ileNet P8:

. Install the Connector on the RightFax server (page 11).

. Activate and configure the External Document Connector on the 
RightFax server (page 12).

. Install the RightFax Connector for Capture Professional on the 
Capture Professional workstation (page 13).

. Optionally install and Configure the Outbound Module 
(page 27).

ortant information about installations and upgrades
o not re-run the Connector installation if you have already 

nstalled this version of the Connector for FileNet P8 or if you have 
nstalled any of the RightFax MFP Module 2.0 products (which use 
he same installation architecture as this product). Doing so will 
etect the existing installation and offer the options Repair and 
ninstall. Selecting Repair will cause any existing configuration 
ettings to be overwritten with default settings.

f you have already installed this product or any of the RightFax 
FP Module 2.0 products, reinstallation is not necessary. Instead, 

ou only need to contact Captaris Support to activate the 
onnector.

f you are running a new installation, or if you are upgrading an 
arlier release of the RightFax Connector for FileNet P8, then you 
hould proceed with the installation instructions as described in 
he next section.

Installing the Connecto
1. Log on to the RightFax 

FileNet P8 installation C
install options appears.
CD and run AutoRun.e

2. Select the option Insta
Server. This opens the 

3. Click Next at the openi
agreement. You must a
continue the installation

4. Click Install. When the

Contacting Captaris Supp
the RightFax Connector f

After the RightFax Connec
software must be activated
contact the RightFax Produ
support representative will
process.

Adding the FileNet P8 co
After the RightFax Connec
its license enabled, you mu
External Document Conne

To add the FileNet P8 m

1. On the RightFax server
RightFax EDC Monitor
application.

2. Select Tools > Configu
Configuration dialog b
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A
i

ting the External Document Connector

 Document Connector, click the Enabled 

d Receives boxes, specify the types of fax 
 want to store in the FileNet repositories. You 
ments that have been both transmitted via the 
 (the Sends option) and received into the 
 (the Receives option).

ese fax documents will not be stored.

ly specific RightFax users that have this feature 
eir user records will have their fax documents 
ribed in the next section).
eceives. All fax documents of this type will be 
3. Click the Modules tab. This tab lists all of the connector 
components that have been added to the External Document 
Connector.

4. Click Add. This opens the Add Module dialog box. All of the 
RightFax connector components for which you are licensed, but 
which have not yet been enabled in the External Document 
Connector are listed.

5. Select the FileNet Panagon/P8 component in the list and click 
OK.

6. The Add Module dialog box closes and the added component 
is displayed in the list on the Modules tab.

7. Click OK to close the Captaris EDC Configuration dialog box. 

8. Select Tools > Services to open the Services dialog box.

9. Click Start All Services. When the icon next to each service 
turns green, indicating that the service is running, click Close.

10.Close the EDC Monitor application.

ctivating the External Document Connector
n RightFax

1. When the RightFax server has restarted, run Enterprise Fax 
Manager.

2. In the list of RightFax servers in the left pane, select the local 
RightFax server.

3. In the list of services in the bottom pane, double-click RightFax 
Server Module. This opens the Server Configuration dialog 
box. Click the Advanced tab.

Figure 1.2  Activa

4. Under External
check box.

5. In the Sends an
documents you
can store docu
RightFax server
RightFax server

� Disabled. Th

� By User. On
enabled in th
stored (desc

� All Sends/R
stored.

6. Click OK.
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s Received Faxes check box if you 
d fax documents to be stored. Select the 
es check box if you want the user’s sent 

ored. Select both options to store both 
.

r each RightFax user whose fax 
d on the FileNet server.

Connector
nal WorkStation
nt Connector has been activated and 
ou must install the RightFax Connector 
he RightFax connector supports 
on 4.0 and higher.

r Capture Professional organizes the fax 
cluding the fax images and document 
dexing purposes) and imports them into 

Connector on a Capture 
on

nds that the RightFax Connector for 
installed on the RightFax server, even if the 
 Professional installed.

rofessional workstation.

ed Program Files\RightFax folder on the 

r FileNet P8 installation CD. If AutoRun 
stall options appears. If AutoRun is not 

D and run AutoRun.exe.
Chapte

ring fax documents for specific users
f you select By User in either the Sends or Receives boxes in the 
erver Configuration dialog box (described in the previous 
ection), you must designate which RightFax users will have their 
ocuments stored in FileNet P8.

. Run Enterprise Fax Manager.

. Click Users under the appropriate RightFax server in the list of 
fax servers in the left pane.

. Double-click a user ID whose documents will be stored in 
FileNet P8. The User Edit dialog box opens. Click the 
Permissions tab.

Figure 1.3  Selecting the EDC Processing Options

4. Select the EDC Proces
want the user’s receive
EDC Process Sent Fax
fax documents to be st
sent and received faxes

5. Click OK and repeat fo
documents will be store

Installing the RightFax 
on a Capture Professio

After the External Docume
configured as necessary, y
for Capture Professional. T
Capture Professional versi

The RightFax Connector fo
documents into batches (in
data that can be used for in
Capture Professional.

To install the RightFax 
Professional WorkStati

Caution  Captaris recomme
Capture Professional not be 
RightFax server has Capture

1. Log on to the Capture P

2. Map a drive to the shar
RightFax server.

3. Insert the Connector fo
is enabled, a menu of in
enabled, browse the C



RightFax Connector for FileNet P8 Guide 14

C
f

me of documents to process
al requires that all documents be archived in the 

atches are distinct groups of documents and 
t have been formatted for Capture Professional. 
 format of batches to process and number of 

ts in each batch.

ches of documents

essional, select your settings collection for 
cuments (to set the default configuration for all 
ct an individual batch (to configure that batch 

 Configure > RightFax Fax. The RightFax 
Panagon Capture Professional Properties 
s.

ment Options tab.

ting a Capture Professional Processing Mode
4. In the menu of install options, select Install the RightFax 
Connector for Capture Professional on a Capture 
Professional Workstation. The Connector for Capture 
Professional install wizard opens.

5. Click Next at the opening screen to view the RightFax license 
agreement. You must accept the license agreement in order to 
continue the installation. Click Next.

6. Click Install. When the installation is complete, click Finish.

To add the RightFax.ocx Capture Professional component

1. On the same Capture Professional workstation where you 
installed the RightFax Connector for Capture Professional, open 
the FileNet P8 Capture Manager.

2. Click Add next to the Components list. The Add Capture 
Component dialog box opens.

3. Navigate to the RightFax folder under the Capture\Programs 
folder and select the component file RightFax.ocx.

4. Click Close to close the FileNet P8 Capture Manager.

onfiguring the RightFax Connector
or Capture Professional

You have the following options for customizing the RightFax 
Connector for Capture Professional:

� “Specifying the volume of documents to process” (page 14).

� “Defining which documents to import based on document data 
filters” (page 15).

Specifying the volu
Capture Profession
form of batches. B
document data tha
You can specify the
RightFax documen

To configure bat

1. In Capture Prof
RightFax fax do
batches) or sele
only).

2. Select Tools >
Connector for 
dialog box open

3. Click the Docu

Figure 1.4  Selec
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4

ts to import
 filters
r Capture Professional organizes 
atches and imports them into Capture 
te a filter that limits the documents to 
document data, such as a RightFax user 

ocuments to import

l, select your settings collection for 
 (to set the default configuration for all 
dividual batch (to configure that batch 

re > RightFax Fax. The RightFax 
n Capture Professional Properties 

nnector Properties

ptions tab.
Chapte

Processing Mode  The RightFax Connector for Capture 
Professional can create three types of batches for delivery to 
Capture Professional:

� Pages Only with Batch Breaks. This option creates a batch 
for each fax. This processing mode requires assembly before 
documents can be passed to the repository.

� Pages Only with Document Breaks. This option creates 
multiple fax documents under the batch in which they were 
originally received. This processing mode requires assembly 
before documents can be passed to the repository.

� Document/Page. This option creates multiple fax 
documents under the batch in which they were originally 
received and does not require assembly before documents 
can be passed to the repository.

Note  Because the Document/Page processing mode is 
exceptionally demanding on system resources, this option should only 
be used if you are unable to use the other two processing modes.

Maximum Faxes  This is the maximum number of fax 
documents that will be pulled from the job folder at one time. 
Enter a number from 1 to 20.

Tip  If the batch already contains faxes, the number of faxes you enter 
in this box will be added to the existing faxes in the batch.

Maximum Pages  This is the maximum number of individual 
fax pages that will be pulled from the job folder at one time. 
Enter a number from 1 to 999.

. When you have completed the RightFax Connector for 
Panagon Capture Professional Properties dialog box, click 
Apply, and then click OK.

Defining which documen
based on document data

The RightFax Connector fo
RightFax documents into b
Professional. You can crea
import based on RightFax 
ID or billing code.

To specify criteria for d

1. In Capture Professiona
RightFax fax documents
batches) or select an in
only).

2. Select Tools > Configu
Connector for Panago
dialog box opens.

Figure 1.5  Setting the Co

3. Click the Connector O
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elect Exclusive filtering if you want to process 
obs and throw away anything that doesn't meet 
ria. You may have more than one workstation 

is mode only if they have identical filters.
pecify filter keywords.

 process only the jobs that meet your filter 
ify filter data in the Include Filter box.

 process most jobs, but specifically exclude 
et your filter criteria specify filter data in the 
er box.

xclude Filter box will be evaluated by the 
and it will override criteria in the Include Filter 

nd data are not case-sensitive. To enter a string 
d data, type a semicolon between each keyword 
he semicolon acts as a logical OR statement, 

hat meet any one of your keyword criteria will be 
4. To specify documents that should be imported from this 
connector based on RightFax document characteristics, select 
a filter mode.

� All Filtering. Select this option if all documents should be 
imported.

� Cooperative Filtering. Select this option to allow multiple 
capture paths to monitor one job directory for documents. 
With cooperative filtering, jobs remain stored in the job 
directory until they are imported by one of the RightFax 
Connectors for Capture Professional. Criteria for importing 
documents are based on keywords you specify in the 
Include Filter and Exclude Filter boxes.

Cooperative filtering is used if you want to use different 
filters. Unlike Exclusive filtering, Cooperative filtering will not 
delete a job that doesn't meet its filter criteria. The job stays 
in the job directory until it is picked up by the appropriate 
filter.

If you select Cooperative filtering, Captaris recommends 
creating a catch-all filter that periodically picks up any jobs 
that do not meet other filter criteria. For example, if you have 
one filter configured as “UserID=TechSupport” and another 
configured as “UserID=Sales,” there should be a third 
catch-all filter that has “UserID=TechSupport;UserID=Sales” 
for it's Exclude settings and a blank Include setting. This 
filter will pick up any jobs that don't happen to be for 
TechSupport or Sales so they don't remain unprocessed in 
the job directory indefinitely. 

� Exclusive Filtering. Select this option if a single connector 
will evaluate and import files from this job directory. Criteria 
for importing documents are based on keywords you specify 
in the Include Filter and Exclude Filter boxes. The 
connector evaluates the filter criteria, and it imports the 
documents that meet the criteria. If the filter criteria are not 
met by the document, the connector passes the document to 
the RightFax Print processor.

You should s
only certain j
the filter crite
running in th

5. Under Filters, s

� If you want to
criteria, spec

� If you want to
jobs that me
Exclude Filt

Criteria in the E
connector first, 
box.

The keywords a
of keywords an
and value pair. T
so documents t
filtered.
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re Professional workstations and you 
axes only on one workstation, Marketing 
tation, and all other faxes on the third 
hould be set up as follows:

n would have UserID=Sales in the 
The Exclude Filters box is left empty.

tation would have UserID=Marketing in 
ox. The Exclude Filters box is left 

orkstation would have 
D=Marketing in the Exclude Filters box. 
ox is left empty.

ted the RightFax Connector for 
fessional Properties dialog box, click 
K.

� �

ote caller 
ber ID (CSID) of 
htFax document.

remoteID=5550022

que ID of the 
nt, assigned by 

htFax server.

uniqueID=
SAR3D64FD3F1D16

htFax user ID of 
on who sent the 
nt.

userid=sales

ords used for filtering (Continued)

tion Example
Chapte

To filter documents, the data values for the keyword must match 
the RightFax document data. For example, to import all 
documents that include the user ID “sales,” documents with the 
user ID “sales23” will not be imported.

You can create filters based on any keyword in the job file. You 
can view many of these keywords by opening the sample sent 
and received fax job files you create with the External Document 
Connector. The sample job files are saved in the 
Program Files\RightFax\EDC\Processors\FileNet folder and 
can be viewed with any text editor. These files are numbered 
consecutively and have the extension .job. The following table 
lists some of the keywords most commonly used for creating 
filters.

Example

If there are three Captu
want to capture Sales f
faxes only on another s
workstation, the filters s

� The Sales workstatio
Include Filters box. 

� The Marketing works
the Include Filters b
empty.

� The third catch-all w
UserID=Sales;UserI
The Include Filters b

6. When you have comple
Panagon Capture Pro
Apply, and then click O

� 

Table 1a  Common keywords used for filtering

Keyword Description Example

BillingInfo1

BillingInfo2

Billing information from 
the RightFax document.

billinginfo1=marketing

GenericFlag1

GenericFlag2

If an application in your 
enterprise is customized 
to work with the 
RightFax API, this 
keyword refers to the 
API constants 
FAXFLAG_GENERIC1 
and 
FAXFLAG_GENERIC2.

The value for the 
keyword is true or false.

genericflag1=true

genericflag1=false

JobType Job types are:

� SendJob
� ReceiveJob
� PrintJob

jobtype=sendjob

RemoteCSID

RemoteID

The rem
subscri
the Rig

UniqueID The uni
docume
the Rig

UserID The Rig
the pers
docume

Table 1a  Common keyw

Keyword Descrip
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 Professional

r FileNet P8 supports the Capture 
ure. With a few exceptions, the 
 the connector to work with Fax Entry 
FileNet product. The instructions are 

pes of data to a repository and/or to a 
irectory. Each type of data is described 

sed by Fax Entry

cription

Entry accepts faxes from a remote 
tion through a fax server.

Entry processes all files it finds in a 
ified directory.

Entry creates a journal log, recording 
ts that occur as inbound faxes or 
rted files are processed.
Chapter 2 Configuring Capture Professiona

er 2

figuring Capture Professional to Commit Documen
ileNet Data Repositories

rted FileNet Product Suites
ileNet P8 is comprised of several unique product suites that store 
nd manage your documents and data. The RightFax Connector for 
ileNet P8 can be used to store RightFax documents in the data 
epositories of any FileNet product suite supported by your version 
f Capture Professional.

or example, Capture Professional version 4.0 supports these 
roduct suites:

Image Services

Content Services

apture Professional version 4.1 supports these additional product 
uites:

Image Manager Suite
Content Manager Suite

Web Content Manager Suite

Business Process Manager Suite

hese are the content management systems that let you receive 
axes from the RightFax server directly into your FileNet document 
epository.

Support for the Capture
Fax Entry Feature

The RightFax Connector fo
Professional Fax Entry feat
instructions for configuring
the same as those for the 
provided in this chapter.

Fax Entry commits three ty
specific local or network d
in the following table.

Table 2a  Data That Is Proces

Data Des

Inbound faxes Fax 
loca

Imported files Fax 
spec

Journal entries 
created by Fax Entry

Fax 
even
impo
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C
F

ing capture path components from the 
st into the list under the name of your new 
 the exact order they are listed here:

x

bly component is unnecessary if you select 
as your processing mode (see “Configuring the 
tor for Capture Professional” on page 14).

inished moving the capture path components, 
 opens the Capture Path Layout window (a type 
strating the data flow through your capture 

imize option.

 added components are laid out in this order:

Assembly � Index � Commit � End

 Fax are the only required components of a path for 
nts. This capture path commits all available RightFax 
 data repository.

p to add a new Save/Stop object between the 
d objects.

ly object, locate the box labeled Empty. 
sor over this box until the cursor changes to a 
rag the box from the Assembly object to the 

ect.

t. to add a new Save/Cont. object between the 
 End objects.
reating a Capture Path to Move
ax Documents into the Repository

Capture paths automate the process of committing documents into 
a FileNet data repository after they have been received by Capture 
Professional. If you are using Fax Entry to commit fax documents to 
the FileNet data repository, capture paths are not required.

The instructions provided here create a capture path that commits 
all available RightFax documents to a FileNet data repository. Other 
capture path configurations can be created to meet the needs of 
your organization.

To create a capture path for RightFax fax documents

In this procedure you must specify a repository to which the 
capture path will commit fax documents. This can be either a new 
or an existing repository. If you want to use a new repository, create 
the repository before beginning this procedure. For information on 
creating a new repository, refer to the documentation for your 
FileNet product suite.

1. Run Capture Professional and select the repository in which you 
will be storing fax documents.

2. Select File > New > Capture Path. The FileNet P8 Capture 
Path wizard opens. Click Next on the introductory screen.

3. Select the repository where you want inbound fax documents to 
be stored. Click Next.

4. In the Name box under Define New Capture Path, type a name 
for the new capture path. Leave the remaining options 
unchanged and click Next.

5. Move the follow
Components li
capture path in

� RightFax Fa
� Assembly
� Index
� Commit

Note  The Assem
Page/Document 
RightFax Connec

6. When you are f
click Next. This
of flow chart illu
path).

7. Check the Max

8. Ensure that the

Begin � Fax � 

Note  Begin and
RightFax docume
documents to the

9. Click Save/Sto
Commit and En

10.On the Assemb
Position the cur
double-arrow. D
Save/Stop obj

11.Click Save/Con
Save/Stop and
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1

1

1

Config
to Wo

T
m
f
C
m
c

s collection

onfigure several settings under the data 
 inbound fax documents to be stored. 
r existing repository. If you want to use a 
repository before beginning this 
 on creating a new repository, refer to 
r FileNet product suite.

nal.

iner in the repository where you want 
 to be stored, click Settings.

ttings. The FileNet P8 Capture settings 
xt on the introductory screen.

here you want inbound fax documents to 

tings Collection, in the Name box, type 
tings collection. Leave the remaining 
 click Next.

cument class for indexing (described 
cument class name and click Next.

figuration screen, select RightFax Fax 
e RightFax Connector for Capture 
s dialog box opens.

e box, enter the name for this connector 
n. You can define unique connectors for 

e Connector to work with Fax Entry, in 
Minutes box, enter the interval that Fax 
ctor for documents. Enter a number of 
Chapter 2 Configuring Capture Professiona

2.On the Save/Cont. object, locate the box labeled Empty. 
Position the cursor over this box until the cursor changes to a 
double-arrow. Drag the box from the Save/Cont. object to the 
Fax object.

The final diagram should look like this:

Figure 2.1  The Completed Capture Path Layout

3.Click Next.

4.Finally, click Finish to close the FileNet P8 Capture Path wizard.

uring Capture Professional
rk with the RightFax Connector
o configure the RightFax Connector for Capture Professional, you 
ust create and configure a new settings collection and template 

or RightFax documents. As described in “Installing the RightFax 
onnector on a Capture Professional WorkStation” (page 13), you 
ay have installed one or multiple capture paths and settings 
ollections on one or more Capture Professional workstations.

To create a new setting

In this procedure you will c
repository where you want
This can be either a new o
new repository, create the 
procedure. For information
the documentation for you

1. Run Capture Professio

2. Under the Config conta
inbound fax documents

3. Select File > New > Se
wizard opens. Click Ne

4. Select the repository w
be stored. Click Next.

5. Under Define new Set
a name for the new set
options unchanged and

6. If you created a new do
page 22), select the do

7. On the component con
and click Configure. Th
Professional Propertie

8. In the Connector Nam
in this settings collectio
settings collections.

9. If you are configuring th
the Polling Interval in 
Entry will poll the conne
minutes.



RightFax Connector for FileNet P8 Guide 22

sitory where you want inbound fax documents to 
 Next.

ew Settings Collection, in the Name box type a 
w template. Leave the remaining options 
 click Next.

 settings collections screen, select the name of 
lection you created in the previous steps and 

e following options:

nfiguring a template for Fax Entry, click Next to 
.

onfigured a capture path for RightFax fax 
described on page 20) select the capture path 
re Path box and click Next. 

ish to close the FileNet P8 Capture template 

ment Indexing
ct Suite
matically index fax documents when they are 
a repository, you must specify the data fields you 
link those fields to the data that is included with 

ents. 

nstructions are specific to FileNet Image Services. If 
nnector for FileNet P8 to commit documents to a 
ifferent product suite, you may want to review these 

ly the principles for document indexing to your 
e.

so is available in Capture Professional. Refer to 
sional documentation for more information.
10.In the Job Directory box, type the path to the Panagon folder on 
the source RightFax server. Type the UNC path to a folder on 
the server or the absolute path to the folder on the local 
computer. Click Apply, and then click OK.

Note  This step is required to enable communication between the 
RightFax source server and the Capture module. There are several 
additional options in this dialog box that let you customize the 
operation of the connector. For a complete description of all of the 
options in this dialog box, see “Configuring the RightFax Connector 
for Capture Professional” on page 14.

Figure 2.2  Specifying the Path to the Panagon Folder on the Source 
RightFax Server

11.Click Next, and then click Finish to close the FileNet P8 
Capture settings wizard.

To create a new template

1. In Capture Professional, under the Config container, click 
Templates.

2. Select File > New > Template. The FileNet P8 Capture 
template wizard opens. Click Next on the introductory screen.

3. Select the repo
be stored. Click

4. Under Define n
name for the ne
unchanged and

5. On the available
the settings col
click Next.

6. Select one of th

� If you are co
skip this step

� If you have c
documents (
in the Captu

7. Finally, click Fin
wizard.

Enabling Fax Docu
in a FileNet Produ

If you want to auto
committed to a dat
want indexed and 
RightFax fax docum

Important  These i
you are using the Co
data repository in a d
instructions and app
specific product suit

Manual indexing al
the Capture Profes
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 this dialog box according to your 
ents. The document class you configure 
RightFax fax documents archived in your 
.

ate Class dialog box is completed, 
ave the settings.

e User Defined Index dialog box 

ields you created in step 7.

lds have been added, click Cancel, and 
rn to the Database Maintenance dialog 

ave the settings and then File > Exit to 
intenance dialog box.

start the Image Services server. This 
changes to take effect.

ent Data to the FileNet Index
se a sample RightFax document to map 
xing fields you set up on the Image 
x fax documents.

set up your Image Services server to 
 documents (described on page 22).

o your index

sional workstation, run Capture 

you created in the previous step and 
RightFax Fax.

the RightFax component, a Fax button was 
fessional toolbar. Clicking this button is the 
 Start > RightFax Fax.
Chapter 2 Configuring Capture Professiona

o enable fax document indexing

ote  The following instructions assume that you have access to and are 
amiliar with the FileNet Image Services server. If you need further 
nformation on any of the dialog boxes or options described in this 
ection, refer to your FileNet documentation.

. On the Image Services server, run Application Executive.

. Select Applications > Database Maintenance to open the 
Database Maintenance dialog box.

. Select Families > Define/Update Family. The Define/Update 
Media Families dialog box opens.

. Complete this dialog box according to your organizational 
requirements. The family you configure here will contain a new 
document class for RightFax fax documents. You can either 
create a new family or select an existing family.

. When the Define/Update Media Families dialog box is 
completed, select File > Save to save the settings, and then 
File > Exit to return to the Database Maintenance dialog box.

. Select Indexes > Define/Update Index. The Define/Update 
Index dialog box opens.

. For each data field that you want to index, complete the entries 
in this dialog box according to your organizational requirements. 
The index fields you add here must correspond to (but do not 
need to have the same names as) the data fields that are 
included with RightFax fax documents. For a list of the RightFax 
document data fields, see Appendix B, “RightFax Document 
Data Fields”.

. When the Define/Update Index dialog box is completed, 
select File > Save to save the settings, and then File > Exit to 
return to the Database Maintenance dialog box.

. Select Classes > Define/Update Class. The Define/Update 
Class dialog box opens.

10.Complete the entries in
organizational requirem
here will be used for all 
Image Services system

11.When the Define/Upd
select File > Save to s

12.Select Index > Edit. Th
opens.

13.Add each of the index f

14.When all of the index fie
then click Close to retu
box.

15.Select File > Save to s
close the Database Ma

16.Finally, stop and then re
step is required for the 

Mapping RightFax Docum
In this procedure you will u
available data fields to inde
Services server for RightFa

This is required only if you 
index archived RightFax fax

To map RightFax data t

1. On the Capture Profes
Professional.

2. Select the new setting 
select Tools > Start > 

Note  When you added 
added to the Capture Pro
same as selecting Tools >
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eld value box, type a value that will populate this 
 data is unavailable in the RightFax fax 

g the Default Field Value

Index tab.

roup box, select FAX.

ame box, select the field from the RightFax 
corresponds to the index field you are mapping.

uto Index String. An index string appears in the 
ng box.

ing the Auto-Index String
3. Click the settings collection you created for RightFax fax 
documents and select Tools > Configure > Index. The 
Panagon Capture Index Control Properties dialog box opens.

4. On the General tab, click Set fields by priority, and then select 
Auto Index, Default, Stored in the list.

5. If you set up a capture path to automate moving fax documents 
into the repository (described on page 20), select the Process 
documents using initial values above check box.

Figure 2.3  Setting the Field Priority

6. Click the Field tab.

7. Select the first index field in the list and click Configure. The 
Field Properties dialog box opens.

Note  These instructions provide information on options required to 
enable indexing of RightFax document data only. For more 
information on the options on each tab of this dialog box, refer to your 
FileNet documentation.

8. Click the Input Masks tab.

9. In the Default fi
index field if the
document.

Figure 2.4  Settin

10.Click the Auto-

11.In the Source G

12.In the Source N
document that 

13.Click Append A
Auto Index stri

Figure 2.5  Creat
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1
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Chapter 2 Configuring Capture Professiona

4.Click OK. Repeat these steps for each index field listed in the 
Panagon Capture Index Control Properties dialog box.

5.When each index field in the Panagon Capture Index Control 
Properties dialog has been configured, click Apply, and then 
click OK to close the dialog box.

� � �
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ing the Outbound Module
x Outbound Module from any previous 
stall the old version using Add/Remove 
trol Panel. When you uninstall the 
e module settings and configurations 
ecommends that you make a note of the 
ll it.

ound module of the RightFax Connector 
hat your RightFax and FileNet systems 
ents:

t be version 9.0 or higher.
or higher must be installed and 
rint server on your network. 

 Outbound module, complete the 

bound module on the FileNet Print 
ge 28).

nter (described on page 28).

inistrator (described on page 31).

ger (described on page 32).
Chapter 3 Using the Ou

er 3

g the Outbound Module
end FileNet Documents as Faxes

he RightFax Connector for FileNet P8 can be used to send 
mages from a FileNet data repository as faxes via the RightFax 
erver. This component of the RightFax Connector for FileNet P8 is 
alled the Outbound module, because documents are transmitted 
s faxes from your data repository.

ith the Outbound module, the RightFax server is configured as a 
eneric fax printer on a FileNet Print server. When a user prints to 
his RightFax printer from the IDM desktop client, the user is 
rompted for fax addressing information (fax number, recipient 
ame, etc.), and then the image and addressing information are 
ent to the RightFax server for transmission.

he following diagram illustrates the process of faxing a document 
rom a FileNet product Suite via a RightFax server.

igure 3.1  Faxing a Document Via the RightFax Server

Installing and Configur
To upgrade to the RightFa
version, you must first unin
Programs in Windows Con
Outbound module, all of th
will be removed. Captaris r
settings before you uninsta

Before you install the Outb
for FileNet P8, make sure t
meet the following requirem

� The RightFax server mus
� FileNet Print version 4.2 

configured on a FileNet P

To install and configure the
following steps:

1. Install the RightFax Out
server (described on pa

2. Create the RightFax pri

3. Start FileNet Print Adm

4. Start FileNet Fax Mana
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I
o

C

Fax printer
duct suite server

nstructions are specific to FileNet Image Services. If 
ightFax printer in a different product suite, you may 
 instructions and apply the principles for creating the 
our specific product suite.

ervices server, run the FileNet P8 Configuration 
ing Start > Programs > FileNET IMS 
> Configuration Editor. The Open 
Database dialog box opens.

ase and domain name of the Image Services 
ure. Verify that the Read-only option is not 
lick OK. This opens the FileNet IMS System 
ditor.

dures tab.

rinter, and then click Run. The Add a Printer 
s.

/Fax 3.0 as the printer type, and then click 

r the new RightFax printer, and click Next.

ude spaces in the name of the printer. Substitute 
 other characters for spaces in the printer name 
ightFax_Fax_Printer).

ress of the FileNet Print server, and then click 

r sizes to support, and then click Next.

solutions to support, and then click Next.

ant to set the printer as the default printer, and 
.

the message “Edit procedure completed 
ick OK.
nstalling the Outbound Module
n the FileNet Print Server

This step installs the Outbound module on your FileNet Print 
server. If you have more than one FileNet Print server on your 
network, you must follow these installation instructions on each 
server that you want to support faxing via RightFax.

To install the Outbound module

1. On the FileNet Print server, insert the Connector for FileNet P8 
CD. If AutoRun is enabled, a menu of install options appears. If 
AutoRun is not enabled, browse the CD and run AutoRun.exe.

2. In the menu of install options, select the option Install the 
Outbound Module on a FileNet Print server.

3. Follow the instructions on the screen.

4. When the Setup program is complete, click Finish.

reating the RightFax Printer
After you have installed the Outbound module on the FileNet Print 
server, you must create a RightFax fax printer. Documents printed 
to this printer will be routed to the RightFax server for transmission.

Creating the RightFax printer requires these basic steps:

1. Create the RightFax printer on the FileNet product suite server 
(described on page 28).

2. Configure the RightFax print queue on the Print server 
(described on page 29).

Creating the Right
on the FileNet pro

Important  These i
you are creating a R
want to review these
RightFax printer in y

1. On the Image S
Editor by select
Configuration 
Configuration 

2. Enter the datab
server to config
selected, and c
Configuration E

3. Click the Proce

4. Select Add a P
dialog box open

5. Select WorkFlo
Next.

6. Type a name fo

You cannot incl
underscores or
(for example, R

7. Enter the IP add
Next.

8. Select the pape

9. Select the fax re

10.Specify if you w
then click Next

11.When you see 
successfully,” cl
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ver, select Start > Programs > FileNET 
e Control. The FileNet Print Service 
ns.

int Service Control Dialog Box
Chapter 3 Using the Ou

2.To confirm the new printer has been successfully added, click 
the Printing tab. The new printer should appear in the list of 
available printers.

3.Close the FileNet IMS System Configuration Editor. Click Yes 
when you are prompted to save the changes.

4.Restart the Image Services server.

figuring the RightFax print queue on the FileNet Print 
er
his step configures the RightFax print queue on the FileNet Print 
erver to communicate with the RightFax server. All documents 
ent to the RightFax server via this RightFax print queue will be 
ssociated with a single RightFax user ID. The properties and 
ermissions of this user ID will be used for all outbound faxes sent 

rom the Image Services repository. Although any existing user ID 
ill work for this purpose, you may want to create a special 
ightFax user ID dedicated to faxes originating from FileNet P8 
sers.

f a document is created with PostScript fonts, then it must be sent 
o the RightFax server from the FileNet Print server with the fonts. In 
his step, you will specify that fonts be downloaded with the 
ocument. 

1. On the FileNet Print ser
Print > FileNET Servic
Control dialog box ope

Figure 3.2  The FileNet Pr
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 RightFax print queue

figuration dialog box, under IDMIS Selection 
Image Services Selection (in Print 4.3), select 
e for the Print server you are configuring. The 
htFax printer you created on the Image Services 
in the FileNET Queues to Configure list.

tFax printer name and click Configure. The 
inter Configuration dialog box opens.

eneric Fax Printer Configuration Dialog Box

ame box, enter the name of the RightFax server.

ype box, select RightFax Server.

ame box, type the name of a RightFax user ID. 
ID on the RightFax server that all outbound faxes 
 to.
2. Click Configure, and the Print Configuration dialog box opens. 
Complete the following steps:

� Configure the RightFax print queue (described on page 30).

� Configure font downloading (described on page 31).

Figure 3.3  The Print Configuration Dialog Box

To configure the

1. In the Print Con
(in Print 4.2) or 
the domain nam
name of the Rig
server appears 

2. Select the Righ
Generic Fax Pr

Figure 3.4  The G

3. In the Server N

4. In the Server T

5. In the Logon N
This is the user 
will be assigned
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1

2

3

dministrator
 monitors the FileNet product suite 
quests for printers configured on the 

ministrator in FileNet Print 4.2
 Print Administrator is an application that 
 server and picks up print requests for 
Print server. FileNet Print Administrator 
e Print server in order to continually 
erver. After you start FileNet Print 
imized, but do not close the application.

nistrator, select Start > Programs > 
Applications > Panagon Print 

ministrator in FileNet Print 4.3
Net Print service is a Windows NT 
roduct suite server and picks up print 
ured on the Print server. The FileNet 
unning on the Print server in order to 
duct suite server.
Chapter 3 Using the Ou

. In the Password box, type the password for the RightFax user 
ID you entered in the Logon Name box.

. Under PostScript, verify that the Send “Exitserver” 
Commands check box is not selected. Click to clear the check 
box.

. Complete the remaining entries in this dialog box according to 
your requirements. When you are done, click OK. The Generic 
Fax Printer Configuration dialog box closes.

o download fonts

. In the Print Configuration dialog box, click Fonts. The Fonts 
and Character Sets dialog box opens.

Figure 3.5  The Fonts and Character Sets Dialog Box

. Under PostScript Printer Fonts, in the Automatically 
Download list, click Beginning of Each Job.

. Complete the remaining entries in this dialog box according to 
your requirements. When you are done, click OK. The Fonts 
and Character Sets dialog box closes.

Starting FileNet Print A
FileNet Print Administrator
server and picks up print re
Print server.

Starting FileNet Print Ad
In FileNet Print 4.2, FileNet
monitors the product suite
printers configured on the 
must remain running on th
monitor the product suite s
Administrator, it can be min

To start FileNet Print Admi
FileNET Panagon Server 
Administrator.

Starting FileNet Print Ad
In FileNet Print 4.3, the File
service that monitors the p
requests for printers config
Print service must remain r
continually monitor the pro
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S

x Manager in FileNet Print 4.3
 Manager in FileNet Print 4.3, select Start > 
ET Print > Fax Manager.

 RightFax from the IDM Viewer
 printer is created and properly configured, you 
axes from the IDM Viewer.

m the IDM Viewer

P8 client computer, run FileNet IDM Viewer.

from the data repository.

leNET Print/Fax. The FileNET Print/Fax dialog 

ting the RightFax Printer

x, select the name of your RightFax printer.
To start the FileNet Print service

1. Select Start > Programs > FileNET Print Service Control. 
The FileNet Print Service Control dialog box opens.

Figure 3.6  The FileNet Print Service Control Dialog Box

2. Click Start.

tarting FileNet Fax Manager
FileNet Fax Manager requests and processes fax addressing 
information for print jobs sent to fax printers. It must remain running 
on the Print server in order to process print jobs sent to fax printers. 
After you start FileNet Fax Manager, it can be minimized, but do not 
close the application.

Tip  The FileNet Fax Manager screen may need to refreshed in order to 
get the status of RightFax faxes from the RightFax server.

Starting FileNet Fax Manager in FileNet Print 4.2
To start FileNet Fax Manager in FileNet Print 4.2, select Start > 
Programs > FileNET Panagon Server Applications > Panagon 
Fax Manager.

Starting FileNet Fa
To start FileNet Fax
Programs > FileN

Sending a Fax via
Once the RightFax
are ready to send f

To send a fax fro

1. On any FileNet 

2. Load an image 

3. Select File > Fi
box opens.

Figure 3.7  Selec

4. In the Name bo
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. Click Properties. The FileNet Printer/Fax dialog box opens.

Figure 3.8  Entering Fax Addressing Information

. Under Fax Options, in the Phone number box, type the 
destination fax number. This is a required entry. All other entries 
are optional. The text you enter in the From, To, Subject, and 
Memo boxes will appear on the fax cover sheet.

If you enter a subject in the Subject box, it will appear in the 
Notes section of the RightFax cover sheet along with any text 
you enter in the Memo box.

. When you have completed the fax addressing information, click 
Save Print/Fax Settings.

. Click OK to send the fax.

� � �
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 P8 FlowPoints
ataFlow contains two numbered 
RightFax Connector for FileNet P8. 
d” FlowPoints, generic to all DataFlows, 
 total of four FlowPoints.

points 
P8 DataFlow

 select Start > All Programs > 
 to open the EDC Monitor application.

ration to open the Captaris EDC 
ox.

b.
er 4

anced Configuration Settings 
e FileNet P8 DataFlow

he RightFax Connector for FileNet P8 is installed as a component 
alled the “FileNet Panagon/P8 DataFlow” in the External 
ocument Connector. A DataFlow is a series of individual steps 
alled “FlowPoints.” Each FlowPoint performs a specific task 
equired to import RightFax documents into the FileNet system.

he preceding chapters in this guide have provided all of the 
onfiguration information necessary to integrate the RightFax 
onnector for FileNet P8 with your RightFax and FileNet servers. 
owever, there are some advanced settings in the FileNet 
anagon/P8 DataFlow which are not discussed in this guide and 
hich are used mainly for troubleshooting and support purposes. 
hese settings do not apply to normal operation of the RightFax 
onnector for FileNet P8.

his chapter discusses the FileNet Panagon/P8 DataFlow and its 
ndividual FlowPoints in more depth, and describes some of the 
dditional functionality that is available. For any option that you find 

n the External Document Connector that is not described in this 
uide, you can click the [?] icon displayed in the title bar of each 
ialog box, and then click the option you want described.

Configuring the FileNet
The FileNet Panagon/P8 D
FlowPoints specific to the 
Additional “Begin” and “En
are also included making a

To open the list of Flow
in the FileNet Panagon/

1. On the RightFax server,
RightFax EDC Monitor

2. Select Tools > Configu
Configuration dialog b

3. Click the DataFlows ta
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8 FlowPoints” describes all of the FlowPoints in 
aFlow.

ters
t P8 FlowPoints let you configure filter options. 
set of documents that will be processed by the 

ents that do not meet the filter criteria will be 
Point and passed on to the next FlowPoint in 

of filter options on a FlowPoint configuration screen

 FlowPoints 

Description

Initializes the DataFlow. No configuration 
necessary.

Converts the RightFax images to 
single-page TIFF image format. The options 
in this FlowPoint are not editable.

Imports the converted images into the 
FileNet repository.

Terminates the dataFlow and deletes 
temporary files. No configuration necessary.
4. Select FileNet Panagon/P8 in the list of DataFlows and click 
Edit. This opens the FileNet_Panagon/P8 DataFlow dialog 
box. This dialog box lists all of the FlowPoints in the FileNet 
DataFlow.

Figure 4.1  The FlowPoints in the FileNet Panagon/P8 DataFlow

5. To edit a FlowPoint’s configuration settings, select the 
FlowPoint in the list and click Edit.

“Table 4a: FileNet P
the FileNet P8 Dat

Understanding Fil
Some of the FileNe
Filters define a sub
FlowPoint. Docum
ignored by the Flow
the chain.

Figure 4.2  Example 

Table 4a  FileNet P8

FlowPoint Name

Begin

Convert_To_TIFF

FileNet_Import

End
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have the extension .job. The following 
ords most commonly used for creating 

l;{UserID}=sales;{UserID}=marketing

lter must be added in several related 
 as expected. This is true for FlowPoints 
nage print notifications, and for 
, which all manage e-mail notifications. If 
ese FlowPoints, you must also add the 
wPoints.

� �

s used for filtering 

ion Example

ormation from 
Fax document.

{billinginfo1}=marketing

 are:

b
Job

jobtype=sendjob

te caller 
r ID (CSID) of 

Fax document.

{remoteID}=5550022

e ID of the 
t, assigned by 
Fax server.

{uniqueID}= 
SAR3D64FD3F1D16

Fax user ID of 
n who sent the 
t.

{userid}=sales
Chapter 4 Advanc

y default, the Process all jobs option is selected for most 
lowPoints and no filters are configured, so all documents will be 
rocessed.

o create a filter, specifying whether jobs should be explicitly 
ncluded or explicitly excluded by the FlowPoint, select Process 
nly the jobs specified by the filters.

f you want to process only the jobs that meet your filter criteria, 
pecify filter data (keywords) in the Include box. If you want to 
rocess most jobs, but specifically exclude jobs that meet your 

ilter criteria specify filter data in the Exclude box. Criteria in the 
xclude box will be evaluated by the connector first, and it will 
verride criteria in the Include box.

he keywords and data are not case-sensitive. To enter a string of 
eywords and data, type a semicolon between each keyword and 
alue pair. The semicolon acts as a logical OR statement, so 
ocuments that meet any one of your keyword criteria will be 

iltered.

o filter documents, the data values for the keyword must match the 
ightFax document data. For example, to process all documents 

hat include the user ID “sales,” documents with the user ID 
sales23” will not be imported.

ou can create filters based on any keyword in the job file. You can 
iew many of these keywords by opening the sample sent and 
eceived fax job files you create with the External Document 
onnector. The sample job files are saved in the Program Files 

RightFax\EDC\Modules\RightFax folder and can be viewed with 

any text editor. These files 
table lists some of the keyw
filters.

Example
{BillingInfo1}=internationa

In some cases, the same fi
FlowPoints in order to work
7 through 10, which all ma
FlowPoints 12 through 14
you add a filter to any of th
same filter to its related Flo

� 

Table 4b  Common keyword

Keyword Descript

{BillingInfo1}

{BillingInfo2}

Billing inf
the Right

JobType Job types

� SendJo
� Receive
� PrintJob

{RemoteCSID}

{RemoteID}

The remo
subscribe
the Right

{UniqueID} The uniqu
documen
the Right

{UserID} The Right
the perso
documen
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ogram, select Start > Programs > 
e EDC Monitor program window 

ment Connector Monitor

 in the top left pane, and the DataFlow 
re displayed in the bottom left pane. In 

e processors that are required by the 
Appendix 

dix A

erstanding the 
rnal Document Connector

iew of the External Document Connector
he External Document Connector (EDC) is a module for the 
ightFax server that allows it to communicate with FileNet P8. The 
xternal Document Connector processes documents using a set of 
teps called a “DataFlow.” The DataFlow is comprised of several 
istinct processes called “FlowPoints.” Each FlowPoint performs a 
istinct task and then passes the document on to the next 
lowPoint.

 the EDC Monitor
he External Document Connector includes a management tool 
alled the External Document Connector Monitor (EDC Monitor). 
se the EDC Monitor to monitor the status of the connectors and 
rocessors under the control of the EDC, add and delete 
rocessor services, and configure the EDC components.

aution  The EDC Monitor application does not display errors that 
ccur with individual processors. It will only report specific job files that 
ave encountered errors. To check for errors in the External Document 
onnector’s processors, you must review the Event Log.

To run the EDC Monitor pr
RightFax EDC Monitor. Th
opens.

Figure 4.3  The External Docu

Installed modules are listed
and individual FlowPoints a
the top right pane, all of th
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cessor Services
ment Connector EDC Manager component and 
 processors managed by the External Document 
alled as services on the computer running the 
t Connector. The External Document Connector 
 tool that can be used to view the status of these 
nd remove services.

tatus of the External Document Connector 
es

x server, select Start > Programs > RightFax 
he EDC Monitor program window opens.

 Services. This opens the Services dialog box.

ervices dialog box

displays the status of the EDC Manager service 
 all of the processors) as well as the status of the 
ssors.

 a service, select the service name and click 
r Stop Service. To start or stop all of the 
 the computer name at the top of the list and 
ervices or Stop All Services.
FlowPoints are listed, and the separate instances of each 
processor are listed in the bottom right pane. Current status 
information is displayed for all objects listed in the EDC Monitor. 
The following table defines each of the status columns in the right 
pane.

Monitoring the Pro
The External Docu
all of the individual
Connector are inst
External Documen
Monitor includes a
services and add a

To monitor the s
processor servic

1. On the RightFa
EDC Monitor. T

2. Select Tools >

Figure 4.4  The S

This dialog box 
(which controls
individual proce

To start or stop
Start Service o
services, select
click Start All S

Table A1  EDC Monitor Status Definitions

Column 
heading Definition

Status The External Document Connector component’s 
status. Possible values are:

� Failed - The component has shut down.
� Hung - The component is no longer responding.
� Job Errors - Errors prevented the image from 

processing.
� OK - The image was processed successfully.

Processed The total number of fax images that have been 
processed by this component.

Pending The total number of jobs currently queued for 
processing by this component.

Errors The total number of processing errors that have 
been logged by this component.

Activity The current active state of the component. 
Possible values are:

� Idle - The component is currently inactive.
� Processing Job- The component is currently 

processing a job.
� Paused- The component has been paused. No 

jobs will be processed.
� Shut Down- The component service is currently 

stopped.
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enter the user name and password of 
e service will use to start up. This user 
ll administrative privileges to the 
 in step 3.

rocessors to a remote computer and you 
C Manager has not been properly 
es to be installed,” or if the services fail to 
ction on adding processes to a remote 
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ing and removing processors

ou can run a maximum of 16 of each type of processor. 
rocessors can be run on the same computer that runs the External 
ocument Connector (the RightFax server) or on remote 
omputers to take advantage of the additional processor power.

ote  Although it is possible to install and configure more than 16 of 
ach type of processor, only 16 of each will actually function at any given 
ime.

o add new instances of a processor

. Run the EDC Monitor and select Tools > Services to open the 
Services dialog box.

. If you want to add the service to a remote computer that is not 
listed, click Add Computer and specify the name of the remote 
computer.

. Select the computer to which you want to add the service and 
click Add Service. This opens the Add a Service dialog box.

Figure 4.5  The Add a Service Dialog Box

. Under Services, select the type of service to add.

5. Under Login Account, 
the user account that th
account should have fu
computer you selected

6. Click OK.

Note  If you are adding p
receive the message “ED
configured to allow servic
start, see the following se
computer.

�
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Appen
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ightFax server.

ightFax server.

ox where the fax was received. This data 
rts it.

f the recipient fax machine.

received. The date is stored in the format 
dix B

tFax Document Data Fields

he following table lists the data fields that are included with each 
ightFax fax document that can be used to index fax documents 

hat have been archived in an Image Services repository.

The data field column lists each RightFax document data field. 
On the Image Services server, the corresponding index fields are 
not required to use field names that are identical to these.
The field type and maximum length are needed when you 
configure data fields in the FileNet Image Services system. 

The fax type indicates whether the data is included with sent or 
received faxes. Some data is included with sent faxes only, some 
data is included with received faxes only, and some data is 
included with both sent and received faxes.

able B1  RightFax Document Data Fields

Data field
Field
type Max. length Fax type Description

{BillingInfo1} String 15 Sent Billing code 1, if defined on the R

{BillingInfo2} String 15 Sent Billing code 2, if defined on the R

{CallerID} String 21 Received The RightFax user ID of the mailb
is available if the fax board suppo

{Caller Station ID} String 21 Received The caller subscriber ID (CSID) o

{Date} Date N/A Sent/Received The date that the fax was sent or 
YYYY/MM/DD.
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e fax was sent or received. The data is stored in 
 HH:MM:SS.

r the ANI routing data for the RightFax user who 
d on the RightFax server).

g key attributes of the fax in the format 
Attribute, ...)”. Available attributes are:

he RightFax server on which the fax was received.

 server where the fax was received.

nder’s organization.

sender’s organization.

 number.

ice number.

d by the RightFax External Document Connector 
 RightFax Connector for FileNet P8.

s in the fax (including the cover page).
{DateTime} Special N/A Sent/Received The date and time that th
the format YYYY/MM/DD

{DID/DTMF/ANI} String 21 Received The DID or DTMF code o
received the fax (if define

{FaxAttributes} String Variable Sent/Received A custom string displayin
“FaxAttributes (Attribute, 

� Broadcast
� Gateway
� Production
� InternetLink
� WinFax

{Fax Channel} Integer N/A Received The channel number on t

{Fax Server} String 31 Received The name of the RightFax

{FromCompanyFaxNumber} String 31 Sent The fax number of the se

{FromCompanyVoiceNumber} String 31 Sent The voice number of the 

{FromFaxNumber} String 31 Sent The sender’s personal fax

{FromName} String 99 Sent The sender’s name.

{FromVoiceNumber} String 31 Sent The sender’s personal vo

{Job ID} Unsigned long 15 Received The ID of the fax assigne
(EDC) component of the

{JobType} String Variable Sent/Received The type of fax:

� Send
� Receive
� Print
� Unknown

{NumberOfImages} Integer N/A Sent/Received The total number of page

Table B1  RightFax Document Data Fields (Continued)

Data field
Field
type Max. length Fax type Description
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irst fax page is page 1. For sent faxes, the 
ge number 0.

. The format of the date and time is based 

s received. The data is stored in the 
S. The time is stored in 24-hour format.

f the remote fax machine.

to transmit the fax.

received. The time is stored in 24-hour 

ient.

ization.

ss or error).

ne).

 by the RightFax server.

ID of the sender. 

ser ID of the recipient.

T

� � �

{PageNum} Integer N/A Sent/Received The page number of the fax. The f
cover page (if any) is assigned pa

{Receive Time} COleDateTime N/A Received The time that the fax was received
on the local machine settings.

{Receive Time String} String N/A Received The date and time that the fax wa
format MM/DD/YYYY HH:MM:S

{RemoteCSID} String 21 Sent/Received The caller subscriber ID (CSID) o

{SendDuration} Integer N/A Sent/Received The number of seconds required 

{Time} Special N/A Sent/Received The time that the fax was sent or 
format as HH:MM:SS.

{ToCityState} String 59 Sent The city and state of the fax recip

{ToCompany} String 59 Sent The name of the recipient’s organ

{ToFaxNumber} String 31 Sent The destination fax number.

{ToName} String 59 Sent The fax recipient’s name.

{ToVoiceNumber} String 31 Sent The fax recipient’s voice number.

{Transmission Status} String 35 Received Status of the transmission (succe

{Transmission Type} Integer
enumerated

5 Received Fax image resolution (normal or fi

{UniqueID} String 15 Sent/Received The unique ID of the fax assigned

{UserID} String 21 Sent/Received For sent faxes, the RightFax user 

For received faxes, the RightFax u

able B1  RightFax Document Data Fields (Continued)

Data field
Field
type Max. length Fax type Description
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activate the EDC 12-13
activating the FileNet connector 11
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FileNet component 11-12
processors 41
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C
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Capture Professional

See also Connector for Capture 
Professional

capture path 20-21
configuring 21-22
configuring batches 14-15
importing documents with filters 15
processing mode 15
settings collection 21-22
support for Fax Entry 19
templates 22
versions supported 10

configure
Capture Professional 21-22
Connector for Capture 

Professional 14-17

RightFax print queue 29-31
RightFax users 13

Connector for Capture Professional

D
data fields in RightFax documents 43-45

activating 12-13
adding processors 41
EDC Monitor 39-40

onitoring services 40
ightFax user permissions 13
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sive filtering 16
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ntry support 19
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FileNet
add module to EDC 11-12
Fax Manager, starting 32
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overview 13
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Outbound module 27
overview 9-10
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components 9-10
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overview 9-10
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product suites 19

services, start 12

settings collection, creating 21-22
start

FileNet Fax Manager 32
FileNet Print Administrator 31-32

start services 12
supported FileNet product suites 19

T
templates in Capture Professional 22
nstall
Connector for Capture 

Professional 13-14
Outbound module 27-28
overview 10
server component 11

nstalling the FileNet connector 10-11

eywords, filter 17

apping RightFax index data 23-25
onitor services 40

R
RightFax

document data fields 43-45
print queue 29-31
printer, creating 28-29
sending a fax from the IDM Viewer 32-33
server component installation 11
server version, required 10
user permissions 13

RightFax Connector for FileNet P8  See 
Connector for FileNet P8

RightFax.ocx file, installing 14

S
sending a fax 32-33
sending faxes 27
server component installation 11
ileNet Capture Professional  See Capture 
Professional

ileNet connector
activating 11
installing 10-11

ileNet Print Administrator, starting 31
ilter keywords 17
iltering documents in batches 15-17
lowPoints

configuring 35-36
onts, downloading 31

DM Viewer 32-33
nbound faxes, moving to the repository  See 

Connector module

O
Outbound module

installing 27-28
overview 27

P
path, capture 20-21
permissions, RightFax user 13
Print Administrator, FileNet 31
Print Administrator, starting 31-32
print queue, RightFax 29-31
printer, RightFax 28-31
processing mode 15
processors

adding 41
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