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Chapter 1. The Supply Collaboration Business Application
Module

Introducing the Supply Collaboration Business Application Module

This book concentrates on the rules and setup configurations that make up the
IBM® Sterling Supply Collaboration business application module in the
Applications Manager. This book is intended for both Hub and Enterprise
administrators using the Applications Manager to set up the IBM Sterling Selling
and Fulfillment Foundation environment. Business analysts should also use this
book to plan appropriate business practices as they pertain to Sterling Selling and
Fulfillment Foundation. Programmers should refer to the Sterling Selling and
Fulfillment Foundation: Customization Basics for information about extending Sterling
Selling and Fulfillment Foundation. System Integrators should refer to the Sterling
Selling and Fulfillment Foundation: Integration Guide for information about extending
or integrating external applications with Sterling Selling and Fulfillment
Foundation.

This book assumes that you have read and are familiar with the concepts and
business functionality detailed in the Sterling Selling and Fulfillment Foundation:
Product Concepts Guide.

The Applications Manager is a collection of all the rules and setup configurations
necessary to implement Sterling Selling and Fulfillment Foundation grouped
together by business application module. The following business application
module configuration groupings are available in the Applications Manager:

* IBM Sterling Distributed Order Management
* IBM Sterling Global Inventory Visibility

* Catalog Management

* IBM Sterling Logistics Management

* Sterling Supply Collaboration

 IBM Sterling Reverse Logistics

* IBM Sterling Application Platform

There is no one specific way to configure the Sterling Selling and Fulfillment
Foundation environment. Each should be modeled to fit in with your business
practices. However, it is not possible to run Sterling Selling and Fulfillment
Foundation without having the necessary infrastructure components configured.

Business Models

There is no single business model that encompasses the environment in which all
the Sterling Selling and Fulfillment Foundation applications can be used. Therefore,
there is no single way in which to configure your Sterling Selling and Fulfillment
Foundation environment.

For example, your company might be considered a multidivisional corporation, a
third-party logistics company, or a marketplace business. Each of these business
models require a different conceptual approach to the Sterling Selling and
Fulfillment Foundation configuration.

© Copyright IBM Corp. 1999, 2012 1



Multi-Divisional Corporation

The multidivisional corporation model is a business corporation whose primary
focus is managing purchase and sales activities. A typical multidivisional
corporation can be a buyer, a seller, or both. It could also be a retailer, a
manufacturer, or both. Whatever form the multidivisional corporation takes, it
normally has multiple channels with different types of customers, such as,
consumers, retailers, dealers, and original equipment manufacturers.

The Internet has significantly altered this picture, with manufacturers able to go
online to sell directly to consumers, and the role of suppliers to each retailer
changing to include a host of different and hybrid fulfillment models.

In the multidivisional corporation model, each division might be set up as an
Enterprise in Sterling Selling and Fulfillment Foundation. This setup allows both
segregation of transactions by division and global visibility at the corporate level.
Each Enterprise configures their own business rules, workflow, and transaction
processing.

Third-Party Logistics
Traditional third-party logistics companies provide a range of outsourced services
such as warehousing, transportation, and contract manufacturing.

The Internet has dramatically altered supply chain management and the
third-party logistics industry. Large companies have begun to recognize the
competitive advantage they can gain through the real-time management of their
supply chains. These advantages include lower costs and improved customer
service. Additionally, new sales channels such as web stores, hand-held devices,
and in-store kiosks provide companies new methods of reaching their customers.
All of these issues have increased the complexity of the fulfillment process.

Sterling Selling and Fulfillment Foundation provides the engine needed to run the
operations of a contract fulfillment provider as well as a centralized system for
real-time order execution and event-driven problem solving for an entire
fulfillment network. It enables fulfillment providers to configure the fulfillment
process to meet the needs of their clients.

In the third-party logistics model, each client might be set up as an Enterprise. This
setup allows the third-party logistics Hub to have visibility of all transactions in
the Hub environment, while the clients that are set up as Enterprises only have
visibility to their own transactions. This allows the third-party logistics business to
provide unique transaction processing to its clients.

Marketplace

A marketplace is an online intermediary that connects Buyers and Sellers.
Marketplaces eliminate inefficiencies by aggregating offerings from many Sellers or
by matching Buyers and Sellers in an exchange or auction. For Buyers, they lower
purchasing costs and help them reach new Sellers. For Sellers, they lower sales
costs and give them access to new customers. It is a central location, or Hub,
where a trusted intermediary integrates both procedures and technology to lower
the costs and enhance the effectiveness of Buyer and Seller transactions.

In the marketplace model, each market might be set up as an Enterprise. This
setup allows each market to be unique with their own product or service handling.
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Supply Collaboration Configuration

Sterling Selling and Fulfillment Foundation is a collection of common components
used in the Supply Collaboration business application. The Sterling Supply
Collaboration business application helps organizations effectively manage purchase
order life cycles, including all interactions with external parties. It provides both
internal and external users with immediate access to purchase orders, allowing
them to negotiate changes, redirect orders and inventory, and resolve unexpected
problems or delays.

In the Applications Manager you can use the Supply Collaboration configuration
grouping to establish both cross-application and order document-specific rules and
attributes. Cross-application rules and attributes can impact other applications,
such as Distributed Order Management and Reverse Logistics. Order document
specific rules and attributes pertain only to the order document type you are
configuring, such as Purchase Order and Transfer Order. You can define different
configurations for individual order document types without impacting other
applications or order document types.

Logistics

You can configure the components used by different logistics related
functionality throughout the Distributed Order Management business
application module.

For more information about Logistics, see Chapter 3, "Configuring
Cross-Application Logistics Components".

Negotiation

Negotiation is the process in which two organizations can settle the conditions
of an order document. You can define rules and common codes that pertain to the
negotiation process.

For more information about Negotiation, see [“Configuring Cross Application|
Negotiation Components” on page 39}

Vendor
You can define the vendors that sell to an organization in the Supply Collaboration
module.

For more information about Vendor, see [‘Defining Vendor Classifications” on page|

Order Attributes

You can define common codes as they pertain to order documents viewed in the
Application Consoles.

For more information about Order Attributes, see Chapter 7, "Configuring a
Document’s Attributes".

Order Validation

You can define configuration for defaulting the Buyer’s vendor validation during
order creation.

For more information about Order Validation, see Chapter 6, "Configuring a
Document’s Order Validation".
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Instruction Types
You can define the common codes used when adding special instructions to an
order.

For more information about instruction types, see Chapter 8, "Configuring a
Document’s Instruction Types".

Modification Reasons
You can define common codes for modification reasons. These codes define why a
modification was made by a user.

For more information about Modification Reasons, see Chapter 9, "Configuring a
Document’s Modification Reasons".

Backorder Reasons
You can define common codes for backorder reasons. These codes describe why an
order was backordered.

For more information about Backorder Reasons, see Chapter 10, "Configuring a
Document’s Backorder Reasons".

Process Type Configuration

To complete an order document's life cycle, each document has a set of different
processes that it can go through. These processes are called process types. Every
order document has a defined set of process types in Sterling Selling and
Fulfillment Foundation.

The following process types are defined in Sterling Selling and Fulfillment
Foundation for the order document types:

 Fulfillment
* Negotiation
e Shipment
* Receipt

You can configure the rules and components that define an order document's
process types.

Financials
You can configure the components used by the Sterling Selling and Fulfillment
Foundation financial engine.

For more information about Financials, see [“Configuring a Document’s Financial
IComponents” on page 135|

Purge Criteria
You can define the parameters used when purging order document related records
from the system.

For more information about Purge Criteria, see Chapter 19, "Configuring a
Document’s Purge Criteria".
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Ilcons Used in This Guide

The following table describes the icons used in this guide.

Table 1. Icons Used in This Guide

Icon

Name

Description

o o

Create New

Click this icon to create new
information for components
used to manage purchase
order life cycles. As shown,
you may see this icon with
different backgrounds,
depending on the context
within which you are
working.

o il

Details

Click this icon to view or
change details for
components used to manage
purchase order life cycles. As
shown, you may see this
icon with different
backgrounds, depending on
the context within which you
are working.

Save

Click this icon to save entries
you have made. The Save
icon may be displayed in
blue or gold.

o K e

Delete

Click this icon to delete
components used to manage
purchase order life cycles. As
shown, you may see this
icon with different
backgrounds, depending on
the context within which you
are working.

Search

Click this icon to search for
configuration information
about managing purchase
order life cycles.

Transactions

Click to display the
Transactions list.

Statuses

Click to display the Statuses
list.

Conditions

Click to display the
Conditions list.

Actions

Click to display the Actions
list.

Right Arrow

Click to move the item to the
list on the right.

Left Arrow

Click to move the item to the
list on the left.
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Chapter 2. Navigating the Applications Manager

Starting the Applications Manager
About this task

To access the Applications Manager:

Procedure

1. Point your browser to http://<hostname>:<portname>/smcfs/console/
start.jsp
where,

* hostname is the computer name or IP address of the computer where Sterling
Selling and Fulfillment Foundation is installed.

* portnumber is the listening port of the computer where Sterling Selling and
Fulfillment Foundation is installed.

The browser displays the Sign In window.

2. Enter your login ID and password and choose the Sign In button. The Console
Home Page is displayed.

3. From the menu bar, choose Configuration > Launch Applications Manager. The
Applications Manager opens in a new window.
Additionally, enterprise users who maintain an enterprise can access the
Applications Manager by means of http://<Sterling Selling and Fulfillment
Foundation installation server>/smcfs/console/login.jsp.
If both the Applications Manager and the monitor in the System Management
Console are opened at the same time, and if a dialogue window is opened in
either application, the other stops responding to user input until that dialogue
window is closed. This is due to a bug in the Java platform.

The Applications Manager Layout

The Applications Manager is a graphical user interface that can be used to
configure different aspects of Sterling Selling and Fulfillment Foundation. The
different configurations are defined by logical groupings called applications that
can be accessed from the Applications Manager menu bar.

Applications Help
B Distributed Order Management
d# Global Inventory Visibility

@ Catalog Management

£ Logistics Management

L5 supply Collaboration

J# Reverse Logistics

Application Platform

Figure 1. Applications Menu
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Each application focuses on a particular aspect of Sterling Selling and Fulfillment
Foundation and contains all of the rules, common codes, and settings necessary for
Sterling Selling and Fulfillment Foundation to work in a real-world business
setting.

The following applications can be configured in this version of Sterling Selling and
Fulfillment Foundation:

* Distributed Order Management
* Global Inventory Visibility

* Catalog Management

* Logistics Management

* Supply Collaboration

* Reverse Logistics

e Application Platform

When you select the application that you want to configure, the Applications
Manager displays a side panel containing all of the available configuration rules
for the selected application and a work area in which these rules can be
configured.

! Applications Manager g

File Applications Help Henu Bar

pplication Platform ( DEFAU =
& > A A

Application Platform

i Participant Madeling
Process Modeling

& 3

= Security

System Administration
1 || Unit Of Measure
Internationalization

0

Application Rules Side Panel

L,

eeeee ol
) et

o
E)
-
w
L |
l"
I

#- Alert
r Bar Codes

‘— *H Configuration Version Labels
; [ Attribute Postfix
[EF= Password Policy Management
5] Change Project Management
Qualified Tag Information
.‘m Business Inteligence

York frea

: [ P0R
Figure 2. The Standard Applications Manager Interface

Application Rules Side Panel

The application rules side panel displays a hierarchical tree of elements specific to
processes used within the application.
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Organization You Are Defining Rules For

Application T
You Are Plattol DEFAULT | b
Configuring ; AR ‘

i— [z Participant Modeling

rocess Modeling

ecurity

System Adrministration

Unit OF Measure

Inkternationalization

Presentation

Communication

®= BF Nomenclature

= @ CQueue Management
Region Definition

!— @ Device

- & Prints

P
=5
{Configuration

Elements —

PP RER

P GG D

Figure 3. Example of Application Rules Side Panel

The application rules side panel also identifies the organization you are
configuring rules for and what, if any, rules are inherited from another
organization.

You can use the application rules side panel for accessing configuration screens,
determining inheritance, and loading another organization's rules.

Accessing Configuration Screens

The main purpose of the application rules side panel is to provide an interface to
access the application’s individual configuration screens. To access a configuration
screen, browse through the application tree and double-click on the applicable
configuration element, the element’s configuration screen displays in the work
area.

Determining Inheritance

In Sterling Selling and Fulfillment Foundation, when an Enterprise is created it can
inherit all or part of an existing Enterprise's configuration rules. This inheritance is
done at the configuration group level. A configuration group is a classification of
similar configuration elements. For example, all of the rules and configurations
dealing with items are grouped together into one configuration group and all of
the rules and configurations dealing with organizations are grouped into another.

An administrator organization is set for every organization defined within the
system. Only the administrator organization can modify the rules defined for a
particular organization. If a particular organization administers multiple
organizations, then they can load the rules of organization that it administers
within the application tree. For more information about loading another
organization's rules, see [‘Loading Another Organization's Rules” on page 14

Configuration groups are associated with organization levels. Organization levels
determine how configuration groups are inherited and which organizations can
maintain them. The organization levels defined in Sterling Selling and Fulfillment
Foundation are:

* Hub Level - Configuration groups that are associated with the Hub organization
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Enterprise Level - Configuration groups that are associated with the individual
Enterprise organizations within the Hub environment

Catalog Organization - Configuration groups that are associated with the
organization(s) that maintains the catalog(s) within the Hub environment
Inventory Organization - Configuration groups that are associated with the
organization(s) that maintains the inventory within the Hub environment
Pricing Organization - Configuration groups that are associated with the
organization(s) that maintains the pricing within the Hub environment
Organization - Configuration groups that are associated with any organization
within the Hub environment

The Applications Manager does not load configuration data and permissions based
on Data Access Policies that are described in the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

Enhanced Inheritance for Process Models

An Enterprise can inherit the configurations of the following entities from other
Enterprises:

Pipelines
User Exits
Services
Actions
Conditions
Statuses
Transactions

Events

When an Enterprise inherits these entities from some other Enterprise, the current
Enterprise can view the configurations that are inherited from all other Enterprises
(including the Hub) in the inheritance hierarchy. In addition, the current Enterprise
can view the configurations that are defined for the Hub.

For example, consider the following inheritance hierarchy:

In this hierarchy, Enterprise E1 is inheriting from Enterprise E2, which in turn is
inheriting from Enterprise E3. Enterprise E1 can view the configurations that are
defined for Enterprise E2 and Enterprise E3. In addition, Enterprise E1 can view
the configurations that are defined for the Hub.
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Organization Level Rules

The following table details the rules used to determine which organizations can
maintain a configuration group as defined by the organization level. The table also
describes the rules that determine how configuration groups are inherited when an
organization is created.

Table 2. Organization Level Rules

modify configuration groups at
the Hub level. All other
organizations have read-only
access.

Organization Organizations That Can Modify
Level at this Level... Inheritance Details
Hub Level Only the Hub organization can | All organizations share this

information.

Enterprise Level

Only Enterprise organizations
can modify configuration groups
at the Enterprise level.

Any business transaction
requiring Enterprise
configuration is picked up from
the Enterprise established by the
transactional context. For
example, order documents have
a specific Enterprise.

An Enterprise can inherit this
configuration from another
Enterprise. Additionally, this
configuration can be overridden at a
configuration group level.

(Seller, Buyer, etc.) can modify
configuration groups at the
organization level.

Catalog Organizations that are designated | None.
Organization as catalog organizations can

modify configuration groups at

the catalog organization level.
Inventory Organizations that are designated | None.
Organization as inventory organizations can

modify configuration groups at

the inventory organization level.
Pricing Organizations that are designated | None.
Organizations as pricing organizations can

modify configuration groups at

the pricing organization level.
Organization Any organization assigned a role | None.

You cannot inherit from an Enterprise that does not have the same inventory,
capacity, and catalog organizations as the organization you are configuring.

Applications Rule Side Panel

The application rules side panel displays rules that have been inherited as grayed

out.

Chapter 2. Navigating the Applications Manager
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Figure 4. Inherited Rules in the Application Rules Side Panel

As stated in the table above, depending on the organization you are logged in as,
you may be able to override some inherited rules. If a rule can be overridden, the

Override Configuration icon becomes available in the application rule side panel
when you highlight the rule.

Owverride Configuration Icon is Availahle

File Applications Helg

E_‘ Distributed Crder Management

7 ﬁ Cross Application
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= . Item Level Conkrols
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— 8% Customer Definition 1

E Document Specific
Vas

Figure 5. Override Configuration Icon

When you choose to override a rule you also override any other rules in the
configuration group the rule you are overriding is associated with. When you
choose the Override Configuration icon the Configuration Override Details pop-up
window displays. This window provides the list of rules that are overridden.
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Configuration Override Details

Cannot override a single rule, All rules listed below have to be overriden.

r Configuration Rules List

Transfer Order - Qrder Attributes

Transfer Order - Qrder Yalidation

TransFer Order - Instruction Types

TransFer Order - Modification Reasons
TransFer Order - Backorder Reasons
Transfer Order - Order Modification Rules
Transfer Order - Fulfillment Rules

Transfer Order - Transackion Specific Rules
TransFer Order - Maonitor Events

TransFer Order - Shipment Modification Rules
TransFer Order - Shipping Preference
Transfer Order - Payment Terms

Transfer Order - Financial Attributes
Transfer Order - Receiving Discrepancy Reasons
Transfer Order - Purge Criteria

[ ] Copy Rules

| 0] 4 || Cancel |

Figure 6. Example of Configuration Override Details Pop-Up Window

Overriding a Configuration Group

If you override a configuration group and then decide to "re-inherit" the original
rules, you can choose the Give Back Configuration Ownership icon. This icon
becomes available in the application rules side panel for rules that have been
overridden.

Chapter 2. Navigating the Applications Manager
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Figure 7. Give Back Configuration Ownership Icon

When you select the Give Back Configuration Ownership Icon, the Configuration
Override Details pop-up window displays. This window provides the list of rules
that are re-inherited.

Note: If you select the Delete Rules field on the Configuration Override Details
pop-up window, you give back rule ownership to the organization you originally
inherited from, but you do not retain any of the rules that you inherited from
them. If you do not select this field, you give back rule ownership to the
organization you originally inherited from, but you retain the rules that you
inherited from them.

Loading Another Organization's Rules
About this task

An administrator organization is set for every organization defined within the
system. Only the administrator organization can modify the rules defined for a
particular organization. If a particular organization administers multiple
organizations, then they can load the rules of organization that it administers
within the application tree. See [Table 2 on page 11| for the rules that determine
which organizations you can administer.

The rules that are available from the tree in the application rules side panel may
vary depending on the type of organization you select and the roles it has been
assigned.

To load another organization's rules:

Procedure

1. From the applicable application rules side panel, choose the Load Rules for
Organization icon. The Load Organizations for Configuration pop-up window
displays.

2. From Organization, select the organization that you want to work with.

3. Choose OK. The organization's rules display in the application rules side panel.

Results

The application rules side panel displays the organization you are working with in
parentheses.
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Work Area

The work area is the main area in which different configuration screens appear.
The main types of screens that you can see in the work area are the Search, List,
Details, and Drag and Drop windows.

Search Window

A search window provides you with a means to perform a filtered search. The
upper panel of a search window offers criteria applicable to the entity you are
searching through which you can narrow your search. The lower panel lists the
results of a search once it has been performed.

| Organization Search

Organization Code hd | | Roles
Search
Criteria Organization Name - ||

Enterprise | > | Max Records |1,DDD

COrganization Code Mame it
DEFALILT Hub Organization
UPSH United Parcel Service
USPS United States Postal Service
FED® FED™
AIRE AIRE
UPSC UP3 Canada
UPSa LIPS Asia Pacific
Search UPSE LIPS Europe
Results LPSL LIPS Latin Ametica
E1 El Dallas

Results 10

Figure 8. Search Window Example
List Window
When you choose to configure a specific rule or code that does not require a

search, the Applications Manager may display a basic list window of the rules and
codes that have previously been configured.
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Results 6 Of A

Figure 9. List Window Example

Details Window

A details window is the main interface through which a bulk of the configuration
is done. A details window can contain editable fields and tables, tabs to configure

different aspects of an entity, and additional actions that can be performed on an
entity.
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Figure 10. Details Window Example

Drag and Drop Window
You can use a graphical drag and drop window to ease the construction of

pipelines, pipeline determination, event handlers, status monitoring rules, and
services. A drag and drop window consists of a pallet and a graphical work area.
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Figure 11. Drag and Drop Window Example

To begin building any of these entities, choose a component, such as a transaction,
from the pallet. Drag the component into the graphical work area. The transaction
is now displays as a graphical representation of itself.

To connect one component to another, you must drag the mouse from the outgoing
port of a component until it forms a connecting line with the incoming port of
another component. The links between components can be set up either
horizontally or vertically.

To delete components or links, right-click on the component and choose Delete.
Once components and links have been established you can move them around by
dragging them, the links redraw themselves according to the new position. If you
press and hold the CTRL key while dragging a component, the component is
copied within the graphical work area.

Actions Available in the Applications Manager

Through the Applications Manager, you can use the lookup functionality, view
logged in users, use lists and list filtering, troubleshoot errors, and use special
characters.
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Using the Applications Manager's Lookup Functionality

Throughout the Applications Manager there are many fields that have a lookup
functionality to find or create additional records as they pertain to that field. For
example, on the Primary Info tab of the Organization Details screen, the Locale
field has a lookup functionality to create a new locale from that screen. When you
choose the Create New lookup button the Locale Details information displays in a
pop-up screen for you to modify.

ATP Rule ~ B

Figure 12. Lookup Icon Example

The information that displays in a lookup field varies depending on how many
records you have pertaining to that particular field. When there are 20 or less
records, the lookup displays as a drop-down list with a Create New button. When
there are between 21 and 75 records, the lookup displays as a drop-down list with
a Search button.

When there are more than 75 records, the lookup displays as a text box with a
Search button. You can type the value in the text box or search for the value using
the Search button. If you enter a value, it is validated when it is saved. You should
always type the value as it would appear if it was displayed as a drop-down list.
For example, for a currency lookup, you should type the currency description in
the text box even though the currency code is saved in the table. An error displays
on save if the user has entered an invalid value.

When you use a lookup for a particular field in the Applications Manager, you
should refer to the corresponding section in this guide to set up the particular
information.

Viewing the Document Types Associated with an Application

In the Distributed Order Management, Supply Collaboration, Reverse Logistics,
and Logistic Management configuration applications, you can view all of the
document types associated with the application. Sales Order, Transfer Order,
Master Order, Quote, and Purchase Order are all examples of document types.

To view an application's associated document types, open the applicable
application from the menu and choose the Create New icon from the application
rules side panel. The Associated Document Types window displays displaying a
list of all of the document types associated with the application you are working
in.
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Figure 13. Associated Document Types Window

Adding a Document Type to an Application
About this task

You can add a document type that is associated with another application to the
application you are currently working in.

An added document type's associated screens may be irrelevant to the application
you are associating it with.

To add a document type to an application:

Procedure

1. From the Associated Document Types window, choose the Create New icon.
The Associated Document Type pop-up window displays.

2. From Document Type, select the document type that you want to associate with
the application.

3. Select Enable Access To This Document Through This Application's Console.

4. Choose the Save icon.

Viewing the User Logged into the Applications Manager
About this task

You can view the user logged into the Applications Manager and their locale at
any time. To view this information, move your mouse over the User icon and
Locale icons in the bottom right-hand corner of the application to display the tool
tips.
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Using Lists and List Filtering
About this task

When viewing any list in the Applications Manager, it is possible to filter the
contents of the list based in criteria that you define. Filtering is accomplished by
right-clicking anywhere on the list's column headings and using the Table Filter
Editor associated with the list.

old Types : Sales Order ( DEFA ;
Haold Tvpe Haold Type Descripkion

Fuald huold

payment payment

Colurmn Heading

Figure 14. Column Headings in a List

Table 3. Table Filter Editor Window

Field Description

Apply To Existing Records | Checking this box applies a new filter set of results that have
been previously filtered instead of the whole set.

Max Records Specify the maximum number of records that are to be
returned from a filter. The default number is 100

Dynamic Fields Fields such as "Hold Type" and "Hold Type Description" are
dynamically populated based on the list you are currently
viewing.

These fields can be searched using text strings combined with
criteria such as Is, Starts With, or Contains.

Search strings are case sensitive. For example, "Item" does not return the same
values as "item".

Date and Time Entry

Date fields through the Applications Manager have a calendar icon that can be
used to find dates as it pertains to that field. When you click on this icon, a small
calendar displays. You can navigate through this calendar to determine the
appropriate date. For example, on the Create Calendar window, the Default
Effective To field has a calendar icon that you can use to verify the appropriate
ship by date to populate the field.

Defaulk Effective Ta | | g

Figure 15. Calendar Icon example
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You can also enter time of day information throughout the Applications Manager.
To do this, double click on the time field, and enter the time of day.

| Shift Mame | Start Time | End Time\

Figure 16. Time Field example

Time should be entered in a 24 hour time format everywhere throughout the
Applications Manager .

Troubleshooting Errors

About this task

You can view the description and cause of any error raised in Sterling Selling and
Fulfillment Foundation, as well as the actions to troubleshoot it.

To view the Sterling Selling and Fulfillment Foundation system error descriptions:

Procedure

1. From the menu bar, choose Help > Troubleshooting. The Error Search window
displays.

2. Enter the applicable search criteria and choose the Search icon. A list of error
codes and their descriptions display.

3. Choose the Details icon to view the cause of the error and action to
troubleshoot it.

Using Special Characters

Throughout the Applications Manager there may be instances where you need to
use special characters in data entry. For information about the use of special
characters in Sterling Selling and Fulfillment Foundation, see the Sterling Selling
and Fulfillment Foundation: Customization Basics.
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Chapter 3. Configuring Cross-Application Logistics
Components

Configuring Cross-Application Logistics Components

You can configure the components used by different logistics related functionality
throughout the business application module.

You can use the Logistics branch for defining logistical attributes, delivery codes,
shipment modes, and outbound constraints.

Defining Logistics Attributes

You can define rules and common codes associated logistics of shipping an order.

You can use the Logistics Attributes branch for defining freight terms, shipment
modes, carrier modification reasons, and additional logistic rules.

Defining Freight Terms

You can define common codes used when associating a freight term to a Carrier. A
freight term identifies how transportation costs are calculated.

The default freight terms of Sterling Selling and Fulfillment Foundation are:

* Cost Insurance and Freight (CIF) - The freight cost is completely paid by either
the Seller, the Enterprise, or the Hub.

* Cost and Freight (CFR) - The freight cost is paid by the Buyer and either the
Seller, the Enterprise, or the Hub.

* Free On Board (FOB) - The freight cost is paid by the Buyer.

You can use the Freight Terms tab for creating, modifying, and deleting freight
terms.

Creating a Freight Term
About this task

To create a freight term:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Logistics Attributes. The Logistics window displays in the work
area.

2. Choose the Freight Terms tab.

3. Choose the Create New icon. The Freight Terms Details pop-up window
displays.

4. Enter information in the applicable fields. Refer to[Table 4 on page 24| for field
value descriptions.

5. Enter Choose the Save icon.
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Table 4. Freight Terms Details

Field

Description

Freight Terms

Enter the name of the freight term.

Short Description

Enter a brief description of the freight term.

Long Description

Enter a more detailed description of the freight term.

Consider Buyer's Routing
Guide

Both the Buyer and the Enterprise can establish routing
guides (rules for shipping), and Economic Shipping
parameters (ESP), which control how items are shipped. In
some cases only the Buyer organization has established
values for these rules. In other cases, only the enterprise has
established values for these rules. If neither is set, then Hub
rules are used.

In cases where both the Buyer and the Enterprise have set
values for these rules, this setting determines whether to
apply the Buyer's routing rules before applying the routing
rules of the Enterprise. See the Sterling Selling and Fulfillment
Foundation: Product Concepts Guide for more information about
these shipping concepts.

First Buyer then Enterprise

Select to use any shipping rules established by the buyer first.
Enterprise rules are applied if no applicable Buyer rule exists.

First Enterprise then Buyer

Select to use any shipping rules established by the enterprise
first. Buyer rules are applied if no applicable Enterprise rule
exists.

Charges paid by

Buyer

Select this option if the Buyer pays shipping charges.

Shipper

Select this option if the Shipper pays shipping charges.

Modifying a Freight Term

About this task
To modify a freight term:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Logistics Attributes. The Logistics window displays in the work

area.

2. Choose the Freight Terms tab.

3. Select the applicable freight term and choose the Details icon. The Freight
Terms Details pop-up window displays.

4. Enter the new information in the applicable fields. Refer to for field

value descriptions.
5. Choose the Save icon.

Deleting a Freight Term

About this task

To delete a freight term:
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Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Logistics Attributes. The Logistics window displays in the work
area.

2. Choose the Freight Terms tab.
3. Select the applicable freight term and choose the Delete icon.

Defining Carrier Modification Reasons

You can define common codes that appear in the Reason Code drop-down list
when you modify a Carrier. This code should provide a standard reason for
modifying a Carrier, such as ‘Requested Change' which would be used when the
customer requests a change of Carrier.

The default carrier modification reason of Sterling Selling and Fulfillment
Foundation is "Requested Change."

You can use the Modify Carrier Reason tab for creating, modifying, and deleting a
carrier modification reason.

Creating a Carrier Modification Reason
About this task

To create a carrier modification reason:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Logistics Attributes. The Logistics window displays in the work
area.

2. Choose the Modify Carrier Reason tab.

3. Choose the Create New icon. The Modify Carrier Reason Details pop-up
window displays.

4. In Modify Carrier Reason, enter the name of the carrier modification reason.
5. In Short Description, enter a brief description of the carrier modification reason.

6. In Long Description, enter a more detailed description of the carrier
modification reason.

7. Choose the Save icon.

Modifying a Carrier Modification Reason
About this task

To modify a carrier modification reason:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Logistics Attributes. The Logistics window displays in the work
area.

2. Choose the Modify Carrier Reason tab.

3. Select the applicable carrier modification reason and choose the Details icon.
The Modify Carrier Reason Details pop-up window displays.

4. In Short Description, enter a brief description of the carrier modification reason.

5. In Long Description, enter a more detailed description of the carrier
modification reason.
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6. Choose the Save icon.

Deleting a Carrier Modification Reason
About this task

To delete a carrier modification reason:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Logistics Attributes. The Logistics window displays in the work
area.

2. Choose the Modify Carrier Reason tab.

3. Select the applicable carrier modification reason and choose the Delete icon.

Defining Additional Logistic Rules
About this task

You can define additional rules that pertain to an order document type.
To define additional logistic rules:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Logistics Attributes. The Logistics window displays in the work
area.

2. Choose the Other Rules tab.

3. Enter information in the applicable fields. Refer to for field value
descriptions.

4. Choose the Save icon.

Table 5. Other Rules Tab

Field Description

Advance Transit Time Calculation

Use Advanced Transit Select this field if advance transit time calculation is required
Time Calculation when considering ship dates and delivery dates.

Transit time is calculated as Lead Time + Distance Per Day
(either from the Distance Per Day for a selected Carrier

service).
Based on SCAC and Select Based on Carrier if you want transit time calculations
Carrier Service to be based on the carrier and carrier service being used for
an order.

Based on Carrier Service | Select Based on Carrier Service if you want transit time
calculations to be based on the specific carrier service being
used for an order.
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Table 5. Other Rules Tab (continued)

Field

Description

Delivery Lead Time (Days)

Enter the default delivery lead time.

Delivery lead time is used to determine when an order line
must be shipped based on the requested delivery date. The
delivery lead time indicates the amount of time it takes to
transport a load from a ship node to a customer. When
calculating the delivery date:

* If neither the ship date or delivery date are provided, the
ship date is defaulted to the current days date and the
delivery date is defaulted to that date + delivery lead time.

* If the ship date is provided but the delivery date is not, the
delivery date is defaulted to ship date + delivery lead time.

* If the delivery date is provided but the ship date is not, the
ship date is defaulted to delivery date - delivery lead time.

* If both the ship date and delivery date are provided, this
rule is not applied.

Round Up Transit Time To
Nearest Day

If selected, transit time calculations are not specific down to
the actual hour. Instead, the system performs the calculations
and rounds up to the next available day.

Distance Per Day

Enter the default distance for calculating transit time if a
Carrier service is not selected or the service selected does not
have a distance per day associated with it.

UOM

Select the distance unit of measure.

Default Carrier Service for
Transfer

Select the carrier service you want to use to compute the
transfer time between two nodes if they do not have a
transfer schedule configured for them.

For more information about configuring transfer schedules
between nodes, see the Sterling Selling and Fulfillment
Foundation: Distributed Order Management Configuration Guide.

Defining Delivery Codes

You can define common codes used for indicating the delivery code when creating
or modifying a Carrier. The delivery code identifies the entity that pays for the

transportation costs.

The default delivery codes of Sterling Selling and Fulfillment Foundation are:

* ENTERPRISE
* MARKETPLACE
» SUPPLIER

You can use the Delivery Codes branch for creating, modifying, and deleting a

delivery code.

Creating a Delivery Code

About this task

To create a delivery code:

Chapter 3. Configuring Cross-Application Logistics Components 27



Procedure

1.

ook w

From the tree in the application rules side panel, choose Cross Application >
Logistics > Delivery Codes. The Delivery Codes window displays in the work
area.

Choose the Create New icon. The Delivery Code Details pop-up window
displays.

In Delivery Code, enter the name of the delivery code.

In Short Description, enter a brief description of the delivery code.

In Long Description, enter a more detailed description of the delivery code.
Choose the Save icon.

Modifying a Delivery Code
About this task

To modify a delivery code:

Procedure

1.

3.
4.
5.

From the tree in the application rules side panel, choose Cross Application >
Logistics > Delivery Codes. The Delivery Codes window displays in the work
area.

Select the applicable delivery code and choose the Details icon. The Delivery
Code Details pop-up window displays.

In Short Description, enter a brief description of the delivery code.
In Long Description, enter a more detailed description of the delivery code.
Choose the Save icon.

Deleting a Delivery Code
About this task

To delete a delivery code:

Procedure

1.

2.

From the tree in the application rules side panel, choose Cross Application >
Logistics > Delivery Codes. The Delivery Codes window displays in the work
area.

Select the applicable delivery code and choose the Delete icon.

Defining Shipment Modes

28

You can define common codes used when indicating the ship mode. The shipment
mode describes how an order is being shipped.

The default shipment modes of Sterling Selling and Fulfillment Foundation are:
e TL - Truckload

* LTL - Less-Than Truckload

* PARCEL

You can use the Shipment Modes tab for creating, modifying, and deleting a
shipment mode.
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Creating a Shipment Mode
About this task

To create a shipment mode:

Procedure

1.

o o A~ w

From the tree in the application rules side panel, choose Cross Application >
Logistics > Shipment Modes. The Shipment Modes window displays in the
work area.

Choose the Create New icon. The Shipment Mode Details pop-up window
displays.
In Shipment Mode, enter the name of the shipment mode.

In Short Description, enter a brief description of the shipment mode.

In Long Description, enter a more detailed description of the shipment mode.

Choose the Save icon.

Modifying a Shipment Mode
About this task

To modify a shipment mode:

Procedure

1.

3.
4.
5.

From the tree in the application rules side panel, choose Cross Application >
Logistics > Shipment Modes. The Shipment Modes window displays in the
work area.

Select the applicable shipment mode and choose the Create New icon. The
Shipment Mode Details pop-up window displays.

In Short Description, enter a brief description of the shipment mode.

In Long Description, enter a more detailed description of the shipment mode.

Choose the Save icon.

Deleting a Shipment Mode
About this task

To delete a shipment mode:

Procedure

1.

2.

From the tree in the application rules side panel, choose Cross Application >
Logistics > Shipment Modes. The Shipment Modes window displays in the
work area.

Select the applicable shipment mode and choose the Delete icon.

Defining Outbound Constraints

Outbound constraints are used to describe conditions that control how shipping is
done. These include whether certain items can be shipped together, such as regular
and rush orders, whether to use Economic Shipping Parameters, and how routing
is performed. You can also use Outbound Constraints for creating, modifying, and
deleting a routing guide.
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The Outbound Constraints node does not apply to Reverse Logistics or Supply

Collaboration.

To define outbound constraints:

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Outbound Constraints. The Outbound Constraints window displays

in the work area.

2. Enter information in the applicable fields. Refer to for field value

descriptions.
3. Choose the Save icon.

Table 6. Outbound Constraint Window

Field

Description

Do not mix in a shipment

If any of the following are selected, separate shipments must
be create for items that have different values for these
attributes.

For example, if Department Code is selected, items that are
for different departments can not be included in the same
shipment.

Buyer Mark For
Node Id

The buyer mark for node id.

Customer PO #

Customer's Purchase Order number.

Department Code

The department for which the item is intended.

Gift Flag

The gift flag.

Level of Service

The level of service on the order.

Mark For Person for whom this shipment is marked for
Order # The order number.
Order Type The order type.

Transportation optimization

Economic shipping
parameters maintained

Economic Shipping Parameters (ESP) are used in shipping
consolidation. Select this field to enable the following
Economic Shipping Parameters fields.

ESP support consolidation of shipments until a weight or
volume threshold is met, or until an certain time elapses. By
consolidating shipments, shipping costs can be reduced

For example, you can set that shipments should be
consolidated until the shipment weight is 300 pounds, or 50
cubic feet in volume. To ensure that eventually the shipment
is set, you can establish a maximum number of days to wait
until the conditions are met.

When either the weight, volume or delay shipment threshold
is met, the shipment is moved to the next stage in shipping.

Delay shipment by not
more than __ Days

Enter the number of days this shipment can be delayed
before it should be shipped.

For example, if a value is set for weight threshold of 300
pounds, and this field has been set to 3 days, the shipment is
shipped after 3 days, regardless of whether the weight
threshold has been met.
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Table 6. Outbound Constraint Window (continued)

Field Description

Consolidate up to weight |Enter a weight.
threshold of

Consolidate up to volume |Enter a volume
threshold of

Routing Guide

Not Maintained Select this to use manual routing. Shipments are managed in
the shipment console, and any routing guides are not
consulted.

Maintained in Sterling Select this to use the Routing Guides maintained in Sterling

Selling and Fulfillment Foundation to determine how
shipments should be routed. Seel”Creating a Routing Guide.”|

In addition to the routing guide maintained here by the
enterprise, there may be a routing guide for the buyer
organization.

For more information about using both buyer and enterprise
routing guides, see |“Creating a Freight Term” on page 23]

Maintained Externally Select this to indicate that an external routing system is used.
The routing guides maintained in Sterling Selling and
Fulfillment Foundation is not consulted.

Examples of external routing systems include using an
integrated Transportation Management System (TMS), or
implementing a User Exit which consults with the buyer
organization.

Creating a Routing Guide
About this task

Routing Guides are a list of conditions which determine how a shipment should be
routed. A routing guide has a time period for which is effective, and conditions for
when it should be applied. These conditions are based on Freight Terms and
Department.

Each routing guide contains a list of routing guide lines, each of which describe
detailed conditions for selecting a carrier. The routing guide information is based
on data used by VICS (Voluntary InterIndustry Commerce Standards) routing.

To create a routing guide:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Outbound Constraints. The Outbound Constraints window displays
in the work area.

2. Select the Create New icon on the Routing Guides list window. The Routing
Guide Details window displays in the work area.

3. Enter information in the applicable fields. Refer to|Table 7 on page 32| for field
value descriptions.

4. Choose the Save icon.
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Table 7. Routing Guide Details Window

Field Description

Name Enter a name for the routing guide.

Routing Guide # A number for the routing guide.

Publish Date When this routing guide is available within the system.
Supersedes Routing Tracking information. For example, if a minor revision is
Guide # made to routing guide "1234", you might create a routing

guide "1234-A", and enter that it supersedes routing guide
"1234". This field is for informational purposes and is not
used to determine the effective routing guide.

Effective Date The start date for applying the routing information in this
routing guide. You can use the effective date and expiration
date to apply routing guidelines for particular periods of
time.

Expiration Date The end date for applying the routing information in this
routing guide.

Apply this Routing Guide when

Freight Terms Apply this routing guide when this condition is met. Select is,

is in, or is not. Use:

* is to specify a single Freight Term.

* is in to specify a group of Freight Terms, one of which
must be matched.

* is not in to specify a group of Freight Terms. The routing

guide is used if the Freight Term does not match one of
these values.

Item Classification Items can be classified.

This field displays when valid item classifications have been
set up for Routing Guide.

Modifying a Routing Guide
About this task

To modify a routing guide:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Outbound Constraints. The Outbound Constraints window displays
in the work area.

2. Select a routing guide in the Routing Guide list window, and select the Details
icon.

3. The Routing Guide Details window displays in the work area.

4. Enter information in the applicable fields. Refer to for field value
descriptions.

5. Choose the Save icon.

Creating a Routing Guide Line
About this task

Routing guide lines contain the specific conditions to use when routing a shipment.
A routing guide can contain multiple routing guide lines.
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When routing occurs, the shipment is matched against the routing guide lines.
Based on the criteria specified, a carrier and carrier service is selected.

When routing results in a change to the shipment destination, the system reroutes,
with the revised destination as the factor for routing. This type of configuration is
used for consolidator nodes. While routing the second time, system looks for the
routing guide entry that contains destination node, but without any other
destination parameters filled out (such as address, etc.).

To create a routing guide line:

Procedure

1. From the Routing Guide Details window, select the Routing Guidelines Tab. To
have access to the Routing Guidelines Tab, save the information you have
entered on the Primary Info Tab.

2. A Routing Guide Line search window displays.

3. Select the Create New icon. A Routing Guide Line Details screen displays in

the work area.

4. Enter information in the applicable fields. Refer to for field value

descriptions.

5. Choose the Save icon.

Table 8. Routing Guide Line Details

Setting conditions:

value. Use:

values match.

Florida would not.

In many of the following fields, you can select is, is in, or is not in and then specify a

* is to specify that a single value must be matched
* is in to specify a group of values, one of which must be matched.

* is not in to specify a group of values. The routing guide line is used if none of these

For example to match any one of a group of states, specify State is in California,
Washington, Oregon, Nevada. When assessing the condition, California would match,

Field Description
Ship From
Node Select the node.

When ship from is not
node, select the following
attribute(s)

Enter this option if not shipping from the node and then
enter one or more of the following conditions.

Country/Region Select the country or region name(s).
State Enter the state name(s).

City Enter the city name(s).

Zip Code Enter the zip code or zip code range.
Ship To

Node Select the node.

Region Enter the region.

When ship to is not node
and region, select the
following attribute(s)

Select this option if not shipping to a node within a specific
region and then select one or more of the following
conditions.
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Table 8. Routing Guide Line Details (continued)

Country/Region Select the country or region name(s).
State Enter the state name(s).

City Enter the city name(s).

Zip Code Enter the zip code or zip code range.
Consolidator Select the consolidator name(s).
Store# Select the store number(s).

And weight is in the range:

You can match weight. For example, if you want packages
that weigh between 100 and 500 pounds to be shipped using
a specific carrier, you would specify From as ‘100" and To as
‘500'.

From

Enter the minimum value.

To

Enter the maximum value.

And volume is in the
range:

You can match volume. For example, if you want packages
that are between 3 and 10 cubic feet to be shipped using a
specific carrier, you would specify From as ‘3' and To as ‘10"

From

Enter the minimum value.

To

Enter the maximum value.

And handling units are in
the range:

Number of containers.

From

Enter the minimum value.

To

Enter the maximum value.

And if requested carrier
service code is

Carrier Service Code

Select a carrier service code.

For more information about

defining carrier services, see ['Defining Carrier Services” on|

Then ship via:

Priority

Indicates the number to give this rule a relative importance.

When a shipment is compared to the routing guide lines,
there may be two carrier services that could be used. This
priority serves as a tie breaker. The carrier service with the
lowest number is used.

Carrier / Service

Indicates the carrier and service code that is desired.

Break Bulk Node

The break bulk node that is close to the buyer.

Contact Specified

Indicates whether the contact details for the shipment is
specified.

With overrides:

Override Freight Terms

Select to override the shipment's Freight Term.

Override Ship To

To override the Ship To value, select this field, and then select
one of the following. This is only used when performing
routing again due to a revised ship to address.

Node Select the node name.
Consolidator Select the consolidator name.
Store# Select the store number.
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Results

When the conditions set are assessed, the routing guide line which matches the
most conditions is used. For example, imagine there are three routing guide lines:

Routing guide line A - What to do when shipping from Massachusetts

Routing guide line B - What to do when shipping from Massachusetts, and when
shipping from the zip code 01810.

Routing guide line C - What to do when shipping from Massachusetts or NY.

If the shipment originates from the zip code 01810, it matches all of these routing
guide lines. The actions specified in Routing guide line B is used, as more conditions
are met (both the state and the zip code).

If the shipment originates from Massachusetts, but not from zip code 01810, then
both Routing guideline A and Routing guide line C match. The priority on the
guidelines are used to determine which is used, with the lowest numbered priority
being selected. If Routing guideline A had a priority number of 3, and Routing
guideline C had a priority number of 5, Routing quideline A is used.

Defining Carrier Services: When routing occurs, the shipment is matched against
the routing guidelines. Based on the criteria specified, you select a carrier service
to use.

You can use the Carrier Services panel for creating, modifying, or deleting a carrier
service.

Creating a Carrier Service:
About this task

To create a carrier service:

Procedure

1. From the Routing Guidelines Details window, in the Carrier Services panel,
select the Create New icon. The Carrier Services window displays.

2. Enter information in the applicable fields. Refer to|Table 9 for field value
descriptions.

3. Choose the Save icon.

Table 9. Carrier Services

Field Description

Priority Enter a number to give this rule a relative importance.

When a shipment is compared to the routing guide lines,
there may be two carrier services that could be used. This
priority serves as a tie breaker. The carrier service with the
lowest number is used.

Carrier/Service Select the carrier or service code that is desired.
Break Bulk Node Select the break bulk node that is close to the buyer.
Contact Address This is used to specify the address information for the carrier

service's contact person. Click the Details icon to change the
contact Address.
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Modifying a Carrier Service:
About this task

To modify a carrier service:

Procedure

1. From the Routing Guidelines Details window, in the Carrier Services panel,
select a carrier service from the list in the Carrier Services list window, and
select the Details icon. The Carrier Services window displays.

2. Enter the new information in the applicable fields. Refer to [Table 9 on page 35|
for field value descriptions.

3. Choose the Save icon.

Deleting a Carrier Service:
About this task

To delete a carrier service:

Procedure

1. From the Routing Guidelines Details window, in the Carrier Services panel,
select a carrier service in the Carrier Services list window and select the Delete
icon.

2. Choose the Save icon.

Modifying a Routing Guide Line
About this task

To modify a routing guide line:

Procedure

1. From the Routing Guidelines Details window, select the Routing Details Tab. A
Routing Guide Line search window displays.

2. Select a routing guide line in the Routing Guide Line list window, and select
the Modify icon. The Routing Guide Line Details window displays.

3. Enter the new information in the applicable fields. Refer to the "Routing Guide
Line Details" table for field value descriptions.

4. Choose the Save icon.

Deleting a Routing Guide Line
About this task

To delete a Routing Guide Line:

Procedure

1. From the Routing Guide Lines Details window, select the Routing Details Tab.
A Routing Guide Line search window displays.

2. Select a routing guide line in the Routing Guide Line list window, and choose
the Delete icon.

Deleting a Routing Guide
About this task

To delete a routing guide:
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Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Logistics > Outbound Constraints. The Outbound Constraints window displays
in the work area.

2. Select the applicable Routing Guide and choose the Delete icon.
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Chapter 4. Configuring Cross Application Negotiation
Components

Configuring Cross Application Negotiation Components

Negotiation is the process in which two organizations can settle the conditions
of an order document. You can define rules and common codes that pertain to the
negotiation process.

Defining Response Actions

You can define common codes for response actions used in the negotiation
process. These codes identify specific actions taken when responses to negotiation
are made between two organizations.

Following are the Sterling Selling and Fulfillment Foundation default response
actions:

* 1100 - Offer

* 1200 - CounterOffer
* 1300 - Reject

* 1400 - Remove

* 1500 - Accept

Modifying a Response Action
About this task

To modify a response action:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Negotiation > Negotiation Response Actions. The Negotiation Response Action
window displays in the work area.

2. Select the applicable response action and choose the Details icon. The Response
Action Details pop-up window displays.

3. In Short Description, enter a brief description of the response action.

4. In Long Description, enter a more detailed description of the response action.

5. Choose the Save icon.

Defining Rejection Reasons

You can define common codes for rejection reasons used in the negotiation
process. These codes identify the specific reason an offer in the negotiation process
is rejected.

Creating a Rejection Reason
About this task

To create a rejection reason:
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Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Negotiation > Negotiation Reject Reasons. The Negotiation Reject Reasons
window displays in the work area.

2. Choose the Create New icon. The Rejection Reason Details pop-up window
displays.
In Rejection Reason, enter the rejection reason.

In Short Description, enter a brief description of the rejection reason.

o bk w

In Long Description, enter a more detailed description of the rejection reason.
6. Choose the Save icon.

Modifying a Rejection Reason
About this task

To modify a rejection reason:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Negotiation > Negotiation Reject Reasons. The Negotiation Reject Reasons
window displays in the work area.

2. Select the applicable rejection reason and choose the Details icon. The Rejection
Reason Details pop-up window displays.

3. In Short Description, enter a brief description of the rejection reason.
4. In Long Description, enter a more detailed description of the rejection reason.
5. Choose the Save icon.

Deleting a Rejection Reason
About this task

To delete a rejection reason:

Procedure

1. From the tree in the application rules side panel, choose Cross Application >
Negotiation > Negotiation Reject Reasons. The Negotiation Reject Reasons
window displays in the work area.

2. Select the applicable rejection reason and choose the Delete icon.
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Chapter 5. Configuring Cross Application Vendor Components

Defining Vendor Classifications

You can configure the vendor classification codes used to associate with a vendor
identification master.

Creating a Vendor Classification
About this task

To create a vendor classification:

Procedure

1.

7.

From the menu bar, choose Applications > Supply Collaboration. The Supply
Collaboration tree displays in the side panel.

From the Supply Collaboration tree, choose Cross Application > Vendor >
Vendor Classifications. The Vendor Classification Codes window displays in the
work area.

Choose the Create New icon. The Vendor Classification Code Details pop-up
window displays.

In Vendor Classification Code, enter the classification ID code.
In Short Description, enter a brief description of the classification ID code.

In Long Description, enter a more detailed description of the classification ID
code.

Choose the Save icon.

Modifying a Vendor Classification
About this task

To modify a vendor classification:

Procedure

1.

6.

From the menu bar, choose Applications > Supply Collaboration. The Supply
Collaboration tree displays in the side panel.

From the Supply Collaboration tree, choose Cross Application > Vendor >
Vendor Classifications. The Vendor Classification Codes window displays in the
work area.

Select the applicable vendor classification code and choose the Details icon.
The Vendor Classification Code Details pop-up window displays.

In Short Description, enter a brief description of the classification ID code.

In Long Description, enter a more detailed description of the classification ID
code.

Choose the Save icon.

Deleting a Vendor Classification
About this task

To delete a vendor classification:
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Procedure

1. From the menu bar, choose Applications > Supply Collaboration. The Supply
Collaboration tree displays in the side panel.

2. From the Supply Collaboration tree, choose Cross Application > Vendor >
Vendor Classifications. The Vendor Classification Codes window displays in the
work area.

3. Select the applicable vendor classification code and choose the Delete icon.

Defining Vendor Definitions

You can configure vendor definitions used to establish a relationship between an
organization and its Seller. When creating a vendor definition you associate an
existing Seller organization with a specific vendor ID and classification. The vendor
identification uniquely identifies the Seller organization in instances where
multiple ERP systems download Seller information into Sterling Selling and
Fulfillment Foundation.

Creating a Vendor Definition
About this task

To create a vendor definition:

Procedure

1. From the menu bar, choose Applications > Supply Collaboration. The Supply
Collaboration tree displays in the side panel.

2. From the Supply Collaboration tree, choose Cross Application > Vendor >
Vendor Definitions. The Vendor Search window displays in the work area.

3. Choose the Create New icon. The Vendor pop-up window displays.

4. Enter information into the applicable fields. Refer to [Table 10| for field value
descriptions.

5. Choose the Save icon.

Table 10. Vendor Pop-Up Window

Field Description

Vendor ID Enter the identifier of the vendor.

Vendor Classification Select the classification, if applicable.

Select An Existing Choose this option and select the applicable Seller if you

Organization want to associate the vendor with an existing Seller
organization.

Create A New Organization | Choose this option if you want to create a new organization
to associate with the vendor.

Organization Code Enter the organization code.

Organization Name Enter the name of the organization.

This Organization Is Also A |Select this if the new organization is also a ship node.

Ship Node

DUNS Number Enter the DUNS number of the seller.

Account Number With Hub | Enter the account number of the seller assigned by the Hub
organization.

Locale Select the locale of the seller.
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Table 10. Vendor Pop-Up Window (continued)

Field Description

Sends Functional Check this box if the supplier sends a functional

Acknowledgment acknowledgment for a PO.

Functional Enter the number of hours the supplier took to send the

Acknowledgment Time functional acknowledgement for a PO.

Sends Commitment Check this box if the supplier sends a commitment for a PO.

Commitment Time Enter the number of hours the supplier took to send the
commitment for a PO.

Sends ASN Check this box if the supplier sends an Advanced Shipment
Notice (ASN) for a PO.

Modifying a Vendor Definition
About this task

To modify a vendor definition:

Procedure

1. From the menu bar, choose Applications > Supply Collaboration. The Supply
Collaboration tree displays in the side panel.

2. From the Supply Collaboration tree, choose Cross Application > Vendor >
Vendor Definitions. The Vendor Search window displays in the work area.

3. Enter applicable search criteria and choose the Search icon. A list of vendors
displays.

4. Locate the applicable vendor and choose the Details icon. The Vendor pop-up
window displays.

5. From Vendor Classification, select the Seller's customer classification, if
applicable.

6. From Seller Organization, select the Seller organization to associate with the
vendor ID.

7. Choose the Save icon.

Deleting a Vendor Definition
About this task

To delete a vendor definition:

Procedure

1. From the menu bar, choose Applications > Supply Collaboration. The Supply
Collaboration tree displays in the side panel.

2. From the Supply Collaboration tree, choose Cross Application > Vendor >
Vendor Definitions. The Vendor Search window displays in the work area.

3. Enter applicable search criteria and choose the Search icon. A list of vendors
displays.

4. Locate the applicable vendor and choose the Delete icon.
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Defining Contact Types

You can configure the contact types when specifying the contact information of a
vendor on inbound order notes. For more information about creating a customer,
see [“Defining Vendor Definitions” on page 42)

Creating a Contact Type
About this task

To create a contact type:

Procedure

1.

ook

From the tree in the application rules side panel, choose Cross Application >
Vendor > Contact Types. The Contact Types window displays in the work area.

Click the Create New icon. The Contact Type Details pop-up window displays.
In Contact Type, enter the contact type.

In Short Description, enter a brief description of the contact type.

In Long Description, enter a more detailed description of the contact type.
Click the Save icon.

Modifying a Contact Type
About this task

To modify a contact type:

Procedure

1.

3.
4.
5.

From the tree in the application rules side panel, choose Cross Application >
Vendor > Contact Types. The Contact Types window displays in the work area.

Select the applicable contact type and click the Details icon. The Contact Type
Details pop-up window displays.

In Short Description, enter a brief description of the contact type.

In Long Description, enter a more detailed description of the contact type.
Click the Save icon.

Deleting a Contact Type
About this task

To delete a contact type:

Procedure

1.

2.

From the tree in the application rules side panel, choose Cross Application >
Vendor > Contact Types. The Contact Types window displays in the work area.

Select the contact type and click the Delete icon.
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Chapter 6. Configuring a Document's Order Validation

Configuring a Document's Order Validation
About this task

You can define the configuration for defaulting Seller and Buyer validation during
order creation for a particular Enterprise and document type. This validation is
used to determine the Sellers and Buyers available to create an order for, and
narrows the search results in the Application Consoles based on the validation type
you configured.

For example, you are configuring a Hub environment with 10 Enterprises, 50
Sellers, and 100 Buyers. A particular Enterprise only interacts with 10 of the 50
Sellers and 25 of the 100 Buyers as defined in the organization hierarchy. If you set
both the Seller and Buyer validations to 'Defined In The Enterprise Hierarchy’,
when a user creates an order the system verifies that the Seller on the order is one
of the 10 Sellers defined in the Enterprise's hierarchy and the Buyer on the order is
one of the 25 Buyers defined in the Enterprise's hierarchy. Also, if the user chooses
the lookup for either the Seller or Buyer fields, only the Sellers and Buyers defined
for the Enterprise appear in the results.

To define an order document's order validation:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Validation. The Order Validation pop-up window
displays in the work area.

2. Enter information into the applicable fields. Refer to [Table 11| for field value
descriptions.

3. Choose the Save icon.

Table 11. Order Validation Pop-Up Window

Field Description

Seller Validation Select the type of validation you want to use to verify the
Seller on the order document. You can choose from the
following options:

* None - No validation is performed for Sellers on an order.
All Sellers in the system can be used during order creation.
Also, all Sellers in the system display when the Seller
lookup is chosen in the Application Consoles.
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Table 11. Order Validation Pop-Up Window (continued)

Field

Description

* Same As Enterprise - The system validates the Seller on the
order is the Enterprise.

* Defined In The Enterprise Hierarchy - The system validates
that the Seller on the order is defined within the
Enterprise's organizational hierarchy. Also, only the Sellers
defined within the Enterprise's organizational hierarchy
display when the Seller lookup is chosen in the Application
Consoles. For more information about configuring the
organizational hierarchy, see the Sterling Selling and
Fulfillment Foundation: Configuration Guide.

Customer Of The Enterprise - The system validates that the
Seller on the order has been configured as a customer. Also,
only the organizations defined as customers of the Enterprise
display when the Seller lookup is chosen in the Application
Consoles.

Buyer Validation

Select the type of validation you want to use to verify the
Buyer on the order document. You can choose from the
following options:

* None - No validation is performed for Buyers on an order.
All Buyers in the system can be used during order creation.
Also, all Buyers in the system display when the Buyer
lookup is chosen in the Application Consoles.

* Save As Enterprise - The system validates the Buyer on the
order is the Enterprise.

* Defined In The Enterprise Hierarchy - The system validates
that the Buyer on the order is defined within the
Enterprise's organizational hierarchy. Also, only the Buyers
defined within the Enterprise's organizational hierarchy
display when the Buyer lookup is chosen in the
Application Consoles. For more information about
configuring the organizational hierarchy, see the Sterling
Selling and Fulfillment Foundation: Confiquration Guide.

* Customer of the Enterprise - The system validates that the
Buyer on the order has been configured as a customer.
Also, only the organizations defined as customers of the
Enterprise display when the Buyer lookup is chosen in the
Application Consoles.

Validate Bill To ID As
Customer ID

Select Validate Bill To ID As Customer ID if you want to
validate that the customer ID on an order is defined for the
Enterprise.

Validate Vendor ID

Select Validate Vendor ID if you want to validate that the
vendor ID on an order is defined for the Enterprise.

Validate Item

Select Validate Item if you want to validate that the product
items on the order belong to the Enterprises catalog. Service
items, on the other hand, always need to exist within .
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Chapter 7. Configuring a Document's Attributes

Configuring a Document's Attributes

You can define common codes as they pertain to order documents viewed in the
Application Consoles.

You can use the Order Attributes branch to:

* Define order types

* Define order sources

* Define external references for the order level

* Define external references for the order line level
* Define order address types

* Define line types

* Define other attributes

Defining Order Types
About this task

You can define codes for order types that appear on a document type. This code
has no application logic associated with it and can be set up as per your business
practices. Examples of order types are Consumer Orders, Service Rep Orders, and
Retail Orders.

You can use the Order Types tab for creating, modifying, and deleting an order
type.

Creating an Order Type
About this task

To create an order type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Order Types tab.

Choose the Create New icon. The Order Type Details pop-up window displays.
In Order Type, enter the name of the order type.

In Short Description, enter a brief description of the order type.

In Long Description, enter a more detailed description of the order type.

N o oo

Choose the Save icon.

Modifying an Order Type
About this task

To modify a order type:

© Copyright IBM Corp. 1999, 2012 47



Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order Types tab.

3. Select the applicable order type and choose the Details icon. The Order Type
Details pop-up window displays.

4. In Short Description, enter a brief description of the order type.

5. In Long Description, enter a more detailed description of the order type.

6. Choose the Save icon.

Deleting an Order Type
About this task

To delete a order type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order Types tab.

3. Select the applicable order type and choose the Delete icon.

Defining Order Sources

You can define codes for order sources that appear on a document type. This code
has no application logic associated with it and can be set up as per your business
practices.

You can use the Order Sources tab for creating, modifying, or deleting an order
source.

Creating an Order Source
About this task

To create an order source:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Order Sources tab.

Choose the Create New icon. The Order Source Details pop-up window
displays.

© N

In Order Source, enter the name of the order source.
In Short Description, enter a brief description of the order source.

In Long Description, enter a more detailed description of the order source.

N oo~

Choose the Save icon.
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Modifying an Order Source
About this task

To modify a order source:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order Sources tab.

3. Select the applicable order source and choose the Details icon. The Order
Source Details pop-up window displays.

4. In Short Description, enter a brief description of the order source.
5. In Long Description, enter a more detailed description of the order source.
6. Choose the Save icon.

Deleting an Order Source
About this task

To delete a order source:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order Sources tab.
3. Select the applicable order source and choose the Delete icon.

Defining External References for the Order Level

You can define codes for external references that appear on a document type at the
order level. This code has no application logic associated with it and can be set up
as per your business practices. You can create, modify, and delete external
references.

You can use the Order References tab to create, modify, or delete an external
reference for the order header level.

Creating an External Reference for the Order Header Level
About this task

To create an order reference for the order level:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order References tab.

3. From the Order Header External References list choose the Create New icon.
The External Reference Details pop-up window displays.

4. In External Reference, enter the name of the external reference.
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5. In Short Description, enter a brief description of the external reference.
6. In Long Description, enter a more detailed description of the external reference.

7. Choose the Save icon.

Modifying an External Reference for the Order Header Level
About this task

To modify an external reference for the order level:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order References tab.

3. In Order Header External References select the applicable external reference
and choose the Details icon. The External Reference Details pop-up window
displays.

4. In Short Description, enter a brief description of the external reference.

5. In Long Description, enter a more detailed description of the external reference.

6. Choose the Save icon.

Deleting an External Reference for the Order Header Level
About this task

To delete an external reference for the order level:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order References tab.

3. In Order Header External References select the applicable external reference
and choose the Delete icon.

Defining External References for the Order Line Level

You can define codes for external references that appear on a document type at the
order line level. This code has no application logic associated with it and can be set
up as per your business practices. You can create, modify, and delete external
references.

You can use the Order References tab to create, modify, or delete an external
reference for the order line level.

Creating an External Reference for the Order Line Level
About this task

To create an order reference for the order line level:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order References tab.

From the Order Line External References list choose the Create New icon. The
External Reference Details pop-up window displays.

w

In External Reference, enter the name of the external reference.
In Short Description, enter a brief description of the external reference.
In Long Description, enter a more detailed description of the external reference.

N o o s

Choose the Save icon.

Modifying an External Reference for the Order Line Level
About this task

To modify an external reference for the order line level:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order References tab.

3. In Order Line External References select the applicable external reference and
choose the Details icon. The External Reference Details pop-up window
displays.

4. In Short Description, enter a brief description of the external reference.

5. In Long Description, enter a more detailed description of the external reference.

6. Choose the Save icon.

Deleting an External Reference for the Order Line Level
About this task

To delete an external reference for the order level:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Order References tab.

3. In the Order Line External References list select the applicable external
reference and choose the Delete icon.

Defining Order Address Types

You can define codes for order address types that appear in the Additional
Addresses view in the User Interface for a document type.

You can use the Order Address Types tab to create, modify, or delete an order
address type.
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Creating an Order Address Type
About this task

To create an order address type:

Procedure

1.

7.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Order Address Types tab.

Choose the Create New icon. The Order Address Type Details pop-up window
displays.

In Order Address Type, enter the name of the order address type.

In Short Description, enter a brief description of the order address type.

In Long Description, enter a more detailed description of the order address
type.
Choose the Save icon.

Modifying an Order Address Type
About this task

To modify a order address type:

Procedure

1.

5.
6.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Order Address Types tab.

Select the applicable order address type and choose the Details icon. The Order
Address Type Details pop-up window displays.

In Short Description, enter a brief description of the order type.
In Long Description, enter a more detailed description of the order type.
Choose the Save icon.

Deleting an Order Address Type
About this task

To delete a order address type:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Order Address Types tab.

Select the applicable order address type and choose the Delete icon.
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Defining Line Types

You can define codes and for line types that appear on a document type.

You can use the Line Types tab to create, modify, or delete a line type.

Creating a Line Type
About this task

To create a line type:

Procedure

1.

ook

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Line Types tab.

Choose the Create New icon. The Line Type Details pop-up window displays.
In Line Type, enter the name of the line type.

In Description, enter a brief description of the line type.

Choose the Save icon.

Modifying a Line Type
About this task

To modify a line type:

Procedure

1.

4.
5.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Line Types tab.

Select the applicable line type and choose the Details icon. The Line Type
Details pop-up window displays.

In Description, enter a brief description of the line type.

Choose the Save icon.

Deleting a Line Type
About this task

To delete a line type:

Procedure

1.

2.
3.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

Choose the Line Types tab.
Select the applicable line type and choose the Delete icon.

Defining Other Attributes

You can define other attributes that appear on the document type.
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You can use the Others tab for generating a prime line number from a
pre-configured number.

Generating a Prime Line Number for a New Line from a
Pre-Configured Number
About this task

Generating a prime line number for a new line from a pre-configured number
prevents conflicts between prime line numbers in Sterling Selling and Fulfillment
Foundation and in an external system when order synchronization occurs.

To specify a pre-configured starting number:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Order Attributes. The Order Attributes window displays in
the work area.

2. Choose the Others tab.

3. In Generate Prime Line No. For New Line Starting From, enter the starting
number. The starting prime line number must be a positive integer

4. If you select the Assign Group Sequence Number To Order Lines option, order
lines created during order creation or order modification are assigned sequence
numbers to sort order lines based on their relationships.

5. Choose the Save icon.
Results
The value entered in the "Generate Prime Line Number for New Line Starting

From:" field only affects orders created through the Console UI, not through direct
API calls (e.g. createOrder())
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Chapter 8. Configuring a Document's Instruction Types

Configuring a Document's Instruction Types

You can define the common codes used when adding special instructions to an
order document.

The default instruction types of Sterling Selling and Fulfillment Foundation are:
+ PICK

* PACK

+ SHIP

+ GIFT

* ORDERING

* OTHER

You can use the Instruction Types branch to create, modify, or delete an instruction

type.

Creating an Instruction Type
About this task

To create an instruction type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Instruction Types. The Instruction Types window displays in
the work area.

2. Choose the Create New icon. The Instruction Type Details pop-up window
displays.

In Instruction Type, enter the instruction type.

In Short Description, enter a brief description of the instruction type.

In Long Description, enter a more detailed description of the instruction type.

IR -

Check Automatically Copy Item Instruction with Matching Type To Order Line
to force the system to automatically copy item instructions with matching
instruction types to order lines when the items are added onto an order.

7. Choose the Save icon.

Modifying an Instruction Type
About this task

To modify an instruction type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Instruction Types. The Instruction Types window displays in
the work area.
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2. Select the applicable instruction type and choose the Details icon. The
Instruction Type Details pop-up window displays.

3. In Short Description, enter a brief description of the instruction type.
4. In Long Description, enter a more detailed description of the instruction type.

5. Check Automatically Copy Item Instruction with Matching Type To Order Line
to force the system to automatically copy item instructions with matching
instruction types to order lines when the items are added onto an order.

6. Choose the Save icon.

Deleting an Instruction Type
About this task

To delete an instruction type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Instruction Types. The Instruction Types window displays in
the work area.

2. Select the applicable instruction type and choose the Delete icon.
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Chapter 9. Configuring a Document's Modification Reasons

Configuring a Document’s Modification Reasons

You can define common codes for modification reasons. These codes define why a
modification was made by a user in the Application Consoles.

In addition to modification reasons, the codes that you define are used as hold
reasons when you put an order on hold in the Application Consoles.

You can use the Modification Reasons branch for creating, modifying, and deleting
a modification reason.

Creating a Modification Reason
About this task

To create a modification reason:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Modification Reasons. The Modification Reasons window
displays in the work area.

Choose the Create New icon. The Modification Reason Details pop-up window
displays.

In Modification Reason, enter the modification reason.

In Short Description, enter a brief description of the modification reason.

In Long Description, enter a more detailed description of the modification
reason.

If this modification reason requires that the order be repriced due to a reduced
quantity, check the Re-Price Order With Reduced Quantity checkbox.

This flag is applicable only if this modification reason is used for cancellations,
where repricing needs to occur against a reduced quantity: the quantity against
which the order line is repriced (repricing quantity) is adjusted to the reduced
quantity. For more information about repricing quantity, see the Sterling Selling
and Fulfillment Foundation: Javadocs.

If this modification reason is used for a modification that does not reduce
quantity, this flag is not applicable.

This field does not exist for Load Modification Reasons.

Choose the Save icon.

Modifying a Modification Reason
About this task

To modify a modification reason:
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Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Modification Reasons. The Modification Reasons window
displays in the work area.

Select the applicable modification reason and choose the Details icon. The
Modification Reason Details pop-up window displays.
In Short Description, enter a brief description of the modification reason.

In Long Description, enter a more detailed description of the modification
reason.

If this modification reason requires that the order be repriced due to a reduced
quantity, check the Re-Price Order With Reduced Quantity checkbox.

This flag is applicable only if this modification reason is used for cancellations,
where repricing needs to occur against a reduced quantity: the quantity against
which the order line is repriced (repricing quantity) is adjusted to the reduced
quantity. For more information about repricing quantity, see the Sterling Selling
and Fulfillment Foundation: Javadocs.

If this modification reason is used for a modification that does not reduce
quantity, this flag is not applicable.

This field does not exist for Load Modification Reasons.

Choose the Save icon.

Deleting a Modification Reason
About this task

58

To delete a modification reason:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Modification Reasons. The Modification Reasons window
displays in the work area.

Select the applicable modification reason and choose the Delete icon.
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Chapter 10. Configuring a Document's Backorder Reasons

Configuring a Document's Backorder Reasons

You can define common codes for backorder reasons. These codes describe why an
order was backordered.

The default backorder reason of Sterling Selling and Fulfillment Foundation is "No
Stock."

You can use the Backorder Reasons branch for creating, modifying, and deleting a
backorder reason.

Creating a Backorder Reason
About this task

To create a backorder reason:

Procedure

1.

o o bk~ w

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Backorder Reasons. The Backorder Reasons window displays
in the work area.

Choose the Create New icon. The Backorder Reason Details pop-up window
displays.

In Backorder Reason, enter the backorder reason.

In Short Description, enter a brief description of the backorder reason.

In Long Description, enter a more detailed description of the backorder reason.
Choose the Save icon.

Modifying a Backorder Reason
About this task

To modify a backorder reason:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Backorder Reasons. The Backorder Reasons window displays
in the work area.

Select the applicable backorder reason and choose the Details icon. The
Backorder Reason Details pop-up window displays.

In Short Description, enter a brief description of the backorder reason.
In Long Description, enter a more detailed description of the backorder reason.

Choose the Save icon.
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Deleting a Backorder Reason
About this task

To delete a backorder reason:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >

(Document Type) > Backorder Reasons. The Backorder Reasons window displays
in the work area.

2. Select the applicable backorder reason and choose the Delete icon.
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Chapter 11. Configuring a Document's Modification
Components

Configuring a Document's Modification Components

You can configure the modification rules and types of a document when it is in a
specific status. These rules determine which parts of a document can be modified
as well as in which status the modifications can be performed. The set of rules and
types can be classified into modification groups. Each modification group can be
associated with a user-defined condition.

If you are using the Distributed Order Management module, you can configure
modification components at the following process type levels:

e Fulfillment

* Outbound Logistics

If you are using the Logistics Management module, you can configure modification
components at the load process type level.

If you are using the Supply Collaboration module, you can configure modification
components at the following process type levels:

¢ Fulfillment

* Inbound Logistics
* Receipt

* Negotiation

If you are using the Reverse Logistics module, you can configure modification
components at the following process type levels:

* Fulfillment

* Logistics

* Receipt

You can use the Order Modification branch to define custom modification types,

modification groups, modifications impacting pricing, and modifications requiring
auditing.

Defining Custom Modification Types

You can define custom modification types for a process type. Creating a
modification type allows you to classify certain attributes (including extended
attributes) into one group. Later, when you define status modification groups, you
can configure modification rules for the custom modification type. Modification
rules determine modification permissions for the attributes. You can decide
whether to allow, disallow, or ignore the custom modification type for a given
status.

You can use the Order Modification Types branch for creating, modifying, and
deleting a custom modification type. After you define a custom modification type,
use the Status Modification Group Details window to configure modification rules
for the custom modification type.
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Creating a Custom Modification Type
About this task

To create a custom modification type:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > (Process Type) > (Process Type) Modification > (Process Type)
Modification Types. The Custom Modification List window displays in the
work area.

From the Custom Modification List, click the Create New icon. The Custom
Modification window displays. Enter information in the applicable fields. Refer
to[Table 12| for field value descriptions.

Click the Save icon. A pop-up warning you to sign out of the application for
changes to take place displays.

Table 12. Custom Modification Window

Field Description

Modification Level Select the level of the modification type. For example, Header,
Line, or Release.

Modification Type Enter the name of the modification type.

Description Enter a brief description of the modification type.

Min Allowed Status Select the minimum status the modification type can be

performed at.

Max Allowed Status Select the maximum status the modification type can be

performed at.

Available A list of XML attributes that can be associated with the

modification type. To add an available attribute to the
modification type, select the attribute you want to add and
click the Right Arrow icon.

Subscribed A list of XML attributes that have been associated with the

modification type. To remove a subscribed attribute, select the
attribute you want to remove and click the Left Arrow icon.

Modifying a Custom Modification Type
About this task

To modify a custom modification type:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > (Process Type) > (Process Type) Modification > (Process Type)
Modification Types. The Custom Modification List window displays in the
work area.

From the Custom Modification List, locate the applicable Custom Modification
and click the Details icon. The Custom Modification window displays.

Enter information in the applicable fields. Refer to|Table 12| for field value
descriptions.

4. Click the Save icon.
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Deleting a Custom Modification Type
About this task

To delete a custom modification type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > (Process Type) > (Process Type) Modification > (Process Type)
Modification Types. The Custom Modification List window displays in the
work area.

2. From the Custom Modification List, locate the applicable Custom Modification
and click the Delete icon.

Defining Status Modification Groups

Status modification groups enable you to configure status modification rules that
are based on enterprise, process type, and order conditions. You define a status
modification group by configuring the following functionalities:

* Modification Rules - Define modification rules for subscribed modification types.
* Condition - Specify a condition for validating the status modification group.

¢ Is Override - Specify the status modification group has priority over other status
modification groups.

* Inherited From Status Modification Group - Specify the status modification
group inherits status modification rules from another status modification group.

Defining Modification Rules

Most documents flow through a pipeline without requiring any intervention by a
customer service representative. However, there are times when modifications are
required, such as changing credit card information or quantity. Sterling Selling and
Fulfillment Foundation supports modification through the Console and APIs. It is
critical for you to decide which modifications are allowed for each modification
type, modification level, and status combination.

Note: Contemplate business and system integration implications before allowing a
modification that is disallowed as part of the system defaults. For example, adding
instructions to a document type is disallowed after the release has been sent to the
node. If you change the modification to be allowed, the system has no way of
communicating the new instruction to the node center because the release has
already been sent.

The modification type indicates the type of modification carried out on a
document. Sterling Selling and Fulfillment Foundation provides the ability to
perform modifications on specific attributes. An example of a modification type is
adding an order line to an order.

Modification level indicates the level at which a particular modification type is
carried out. These include the following levels:

* Header

* Line

* Release

* Release Line
* Negotiation
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* Negotiation Line
* Shipment
* Receipt

For a complete list of the system modification types and their modification levels,
see [“Order Modification Types” on page 323

Modifications are applied to a particular level and a particular processing status.
For example, if modifications are requested for a document at the header level or
at the line level, then the order lines, as well as the order release lines, are picked
up for validating whether or not modifications are allowed for those order
statuses. If modifications are requested at the release or release line level, then
order release lines are picked up for validating whether or not modifications are
allowed for those order statuses.

You can group modifications in the Modification Rules tab of the Status
Modification Group Details window by modification type, modification level, or
status, by selecting the corresponding grouping from Group By. The Modification
Rules tab then displays the grouping you have chosen in a hierarchical structure.

All modification rules operate within a certain system-defined range. For instance,
for Sales Orders, the Cancel modification on the order entity is always defined to
be between the statuses 1000 (Draft Order Created) and 3350 (Included In
Shipment). The system never allows a Cancel modification at a status of 3701
(Return Created). On the other hand, you are able to allow modifications between
the statuses 1000 and 3350. If an entity is in multiple statuses, the modification is
allowed, provided that at least one of the statuses is within the system-defined
range.

If you make modifications such as changing a Bill To address after an order has
shipped or a return has been created, the changed Bill To address will not be
propagated to the shipment, the return order, and so forth.

The following table defines the different settings you can apply to modifications:

Table 13. Order Document Type Rule Modifications

Field Description

Status Indicates each status that is applicable to a modification level
and type.

Allow Indicates whether or not modifications may be made at this

modification level and type for the specified status.

Disallow Indicates that no modifications may be made at this
modification level and type for the specified status.

Ignore Indicates that modifications are ignored at this modification
level and type for the specified status.
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Table 13. Order Document Type Rule Modifications (continued)

Field Description

Within a status modification group, there are several scenarios to consider for the Allow,
Disallow, and Ignore settings:

e If one line is in status 1 and another line is in status 2 - and both statuses are set to
Allow, the modification is allowed.

¢ If one line is in status 1, another line is in status 2, and another is in status 3 - and the 1
and 2 statuses are set to Allow, but the 3 status is set to Disallow, all modifications are
disallowed, because one of the currently applied statuses is disallowed.

e If one line is in status 1 and one is in the extended status 2 - If the 1 status is set to
Allow, but the extended status is set to Ignore (all extended statuses are defaulted to
ignore, so that they pick up their base status settings unless you have explicitly
overridden the setting) then all modifications are allowed only if the base status is set to
allow. If the base status is set to disallow, then all modifications are disallowed.

If all lines are set to Ignore, then all modifications are disallowed, regardless of the base
status settings.

Application Console users can be granted permission to override the modification
rules through user group permissions. When a user has been granted this
permission, the user can perform a modification that has been disallowed within
the Application Consoles. For more information about configuring user group
permissions, see the Sterling Selling and Fulfillment Foundation: Configuration Guide.

Specifying a Condition for a Status Modification Group

You can define a condition for a status modification group that determines how
the group is validated against status modifications. For example, when a user of an
enterprise performs an operation on a supported document type or calls an
order-related API, such as getOrderDetails, the status modification is validated
using this process:

* Obtain the conditional XML file from the order. The conditional XML file is
created when you specify a condition for the status modification group.

* Obtain all applicable status modification groups that meet the conditions
specified in the conditional XML file.

* Obtain all modification types from applicable status modification groups,
including inherited configurations. Then, any conflicting status modification
rules are resolved.

Conditions for status modification groups are specified by order attribute. For
example, the CurrentUserRole attribute lets you configure status modification rules
for a primary user group, such as Field Sales. Consider a scenario in which you
want to give field sales representatives the ability to create quotes. However, you
do not want to allow them to change the price on existing quotes. To configure this
scenario, you would create a status modification group where the CurrentUserRole
attribute is set to the primary user group id for field sales representatives. As part
of creating the status modification group, you would define status modification
rules that allow changes to quotes but prevent changes to prices on existing
quotes. Additionally, you could create a different status modification group that
allows supervisors to change the price on existing quotes. In this example, assume
that the enterprise and process type are the same for both status modification
groups.
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If you do not specify a condition for a status modification group, the status
modification group validation is enforced. Use the Condition field in the Status
Modification Group Details window to specify a condition for a status modification

group.

Overriding Status Modification Groups

You can use the Is Override option to specify that a status modification group has
priority over other status modification groups. For example, if three status
modification groups contain the same status modification rule, where one group
has the Is Override option selected, the modification rule is set to the value
specified in the override group.

When multiple status modification groups have the Is Override option selected,
conflicts are resolved using the logic described in [Table 14

Table 14. Multiple Status Modification Groups and the Is Override Option

Status Status Status Status Status Status
Is Override | Allow Allow Ignore Disallow Allow Disallow
- checked
for Group 1
Is Override | Allow Disallow Ignore Disallow Ignore Ignore
- checked
for Group 2
Result Allow Disallow Disallow Disallow Allow Disallow

Inheriting Modification Rules from a Status Modification
Group

When you create a status modification group, it inherits modification rules from
the default status modification group. You can then define the group by
configuring its modification rules. Additionally, modification groups can inherit
status modification rules from other status modification groups. For example, you
can create a status modification group that allows field sales representatives to
create orders. If you create a group for managers that inherits status modifications
rules from the Field Sales Representative Group, the managers can also create
orders. Later, if you want to prevent field sales representatives and managers from
creating orders, you only need to disallow the create order status for the Field
Sales Representative Group. The Manager Group inherits the updated status
modification.

When one group inherits rules from another group, the modification rules defined
in the child modification group override the parent's modification rules. For
example, the Field Sales Representative Group can create orders but cannot change
the price on a quote. If you want the Manager Group to have the ability to create
orders and change the price on quotes, configure the Manager Group to inherit
status modification rules from the Field Sales Representative group, and then
configure the Manager Group to have the ability to change the price on a quote.

Additionally, the Is Override option can be enabled for child groups. For example,
a manager belongs to the following status modification groups:

* Manager Group 1 - This group is not allowed to create orders.

* Manager Group 2 - This group inherits the ability to create orders from the Field
Sales Group. Manager Group 2 has the Is Override option enabled.
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Because the Is Override option is enabled for Manager Group 2, the manager has

the ability to create orders.

Resolving Conflicts Between Status Modification Groups

In some cases, multiple status modification groups contain conflicting status
modification rules. Conflicts between status modification groups are resolved in

the following way:

* If two status modification groups contain the same rule, where one group has

the rule set to Allow and the other group has the rule set to Disallow, the rule is

set to Allow.

* If no status modification group has the rule defined, the rule is set to the value

specified in the parent group. If there is no parent group, the rule is set to the

value in Default Group.

* If multiple status modification groups have the Is Override option selected, but
the groups do not have the rule defined, the rule is set to the value specified in

the parent group. If there is no parent group, the rule is set to the value in

Default Group.

The following example provides a scenario for resolving conflicts between status

modification groups.

Example: Resolving Conflicts Between Status Modification

Groups

In this example, three status modification groups contain status modification rules

that affect the same order.

Table 15. Default Status Modification Group

1500 OrderLine Cancel Disallow
2300 Order ShipTo Change Disallow
2400 Order ShipNode Change Disallow

Use Status Modification Group 1 when condition 1 is true:

Table 16. Status Modification Group 1

Inherits from Default Group

1500 OrderLine Cancel

Disallow

2400 Order ShipNode Change

Disallow

Use Status Modification Group 2 when condition 2 is true:

Table 17. Status Modification Group 2

Inherits from Default Group

1500 OrderLine Cancel

Disallow

Use Status Modification Group 3 when condition 3 is true:

Table 18. Status Modification Group 3

Inherits from Default Group

Is Override is Yes

2400 Order ShipNode Change

Disallow
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If the order satisfies all conditions, status modification groups 1, 2, and 3 are
applicable. As a result, the following access is granted:

Table 19. Resulting Access for Conflicting Status Modification Groups

1500 OrderLine Cancel Allowed Condition 1 applied
2300 Order ShipTo Change Disallow Default applied
2400 Order ShipNode | Change Disallow Condition 3 applied

Creating a Status Modification Group
About this task

To create a status modification group:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > (Process Type) > (Process Type) Modification > (Process Type)
Modification Groups. The Status Modification Group List window displays in
the work area.

2. From the Status Modification Group List, click the Create New icon. The Status
Modification Group Details window displays.

3. Enter information in the applicable fields. For field value descriptions, see

fable 20

4. Click the Save icon to save the modification group.

Table 20. Status Modification Group Details Window

Field Description

Status Modification Group ID Enter a name for the status modification
group.

Description Enter a description for the status

modification group.

Inherited From Status Modification Group |(Optional) Select a parent status
modification group if you want to inherit
modification rules from another group.

Is Override (Optional) Check this option if you want
this status modification group to take
precedence.

Condition (Optional) Select a condition if you want to

specify a condition for this status
modification group. Or, you can create a
condition by clicking the Create New icon,
which opens the Condition Detail window.
Refer to|“Adding Conditions to a Status|
[Modification Group” on page 69| for
information about configuring conditions for
status modification groups.

Note: If you do not specify a condition, this
group's validation is enforced.

Subscribed Modification Types
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Table 20. Status Modification Group Details Window (continued)

Field

Description

Available

Displays a list of available modification
types. This list includes all system-supplied
modification types as well as the custom
modification types that you created in the
Custom Modification window. To subscribe
a modification type, select the modification
type in the Available list and click the Right
Arrow icon.

Subscribed

Displays a list of the modification types for
which you want to define modification
rules. To remove a modification type from
the subscribed list, select the modification
type in the Subscribed list and click the Left
Arrow icon. Click the Save icon to display
the subscribed modification types in the
Modification Rules tab.

Modification Rules

Group By

Select a sort option for displaying
modification types in the Primary Info tab.
You can sort modification types by type,
level, and status.

Primary Info

Displays the modification types that you
subscribed in the Subscribed Modification
Types tab. Expand the applicable
modification types and levels for which you
want to set up modification rules. Right
click on the applicable rule and choose
Allow, Disallow, or Ignore as per your
business practices.

Adding Conditions to a Status Modification Group

About this task

The Condition Detail window allows you to create a new condition for the status
modification group. The Condition Detail window opens when you click the
Create New icon, next to the Condition field, in the Status Modification Group

Details window.

To create a condition for the status modification group:

Procedure

In the Condition Detail window, enter information in the following fields:

Option

Description

Condition ID

Enter the condition ID.

Condition Name

Enter the name of the condition for the
status modification group.

Condition Group

Enter the name of the condition's group, if
applicable. Condition Group allows you to
group related conditions within the
condition tree.
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Option Description

Static If this is checked, you must enter a
condition value for the static condition.

Dynamic If this is checked, you must enter a Java

class name that evaluates the condition at
runtime.

Advanced XML

If you are creating a new condition, this
option is disabled as a new condition of the
advanced XML type must be created using
the IBM Greex Editor IDE tool. For more
information about creating an advanced
XML condition using the IBM Greex Editor,
see the Sterling Selling and Fulfillment
Foundation: Extending the Condition Builder.

This option is automatically selected
whenever you modify a condition of the
advanced XML type.

Condition Value (if Static is checked)

Click the Condition Builder icon to use the
condition builder, which is where you set up
the conditional value for the status
modification group. You can set it up in a
formulaic readout using the available
symbols. You can enter your own attribute
or an extended attribute if Static condition is
checked. For example, if you are configuring
a status modification group for the Field
Sales Representative Group, use the {Enter
Your Own Attribute} option in the Condition
Builder to set the CurrentUserGroup
attribute equal to the primary user group id
for field sales. For more information about
creating these attributes, see the Sterling
Selling and Fulfillment Foundation: Extending
the Condition Builder.

Class Name (if Dynamic is checked)

Enter the class name that implements the
following Java interface:
com.yantra.ycp.japi.YCPDynamicCondition
Note: To use extended attributes for a
condition, implement the
YCPDynamicConditionEx interface. For
more information about implementing this
interface, refer to the Sterling Selling and
Fulfillment Foundation: Extending the Condition
Builder.

Condition Properties (if Dynamic is
checked)

Specify the custom name or value properties
which are set into the condition evaluating
Java class file before evaluating the
condition. For more information about
creating custom attributes, see the Sterling
Selling and Fulfillment Foundation: Extending
the Condition Builder.
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Modifying a Status Modification Group
About this task

To modify a status modification group:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > (Process Type) > (Process Type) Modification > (Process Type)

Modification Groups. The Status Modification Group List window displays in
the work area.

From the Status Modification Group List, select the applicable modification
group and choose the Details icon. The Status Modification Group Details
window displays.

Enter information in the applicable fields. Refer to|Table 20 on page 68| for field
value descriptions.

4. Click the Save icon.

Deleting a Status Modification Group
About this task

To delete a status modification group:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > (Process Type) > (Process Type) Modification > (Process Type)

Modification Groups. The Status Modification Group List window displays in
the work area.

From the Status Modification Group List, locate the applicable status
modification group and click the Delete icon.

Defining Modifications Impacting Pricing

You can specify whether a modification type impacts pricing on an order. When
modifications of these modification types occur, OrderRepricingUE is called to
update price and charge information at the level indicated for that modification
type. For more information about OrderRepricingUE, see the Sterling Selling and
Fulfillment Foundation: Javadocs.

Adding/Removing a Modification Type for Modifications
Impacting Pricing
About this task

To specify whether a modification type has pricing impact:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > (Process Type) > (Process Type) Modification > Modifications
Impacting Pricing. The Modifications Impacting Pricing List window displays
in the work area.

From the Modifications Impacting Pricing List, choose the Details icon. The
Modification Type List window displays.
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3. To add a modification type to the Modifications Impacting Pricing list, select

5.

the desired modification type(s) from the Modification Types and choose the
Right Arrow icon.

To remove a modification type from the Modifications Impacting Pricing list,
select the desired modification type(s) from the Modification Types and choose
the Left Arrow icon.

Choose the Save icon.

Defining Modifications Requiring Auditing

72

You can specify which modification types will require an audit after being
completed.

To specify which modification types require an audit:

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Order Modification > Modifications Requiring
Auditing. The Modifications Requiring Auditing window displays in the work
area.

From the Modifications Requiring Auditing window, choose the Details icon.

When opening the Modifications Requiring Auditing screen for the first time,
all modification types are listed as requiring audits.

To add a modification type to the Modifications Requiring Auditing list, select
the desired modification type(s) from the Modification Types column and
choose the Right Arrow icon.

To remove a modification type from the Modifications Requiring Auditing list,
select the desired modification type(s) from the Modification Types column and
choose the Left Arrow icon.

Choose the Save icon.
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Chapter 12. Configuring a Document's Note Reasons

Configuring a Document's Note Reasons

You can define reason codes for entering a note. These codes define why a note
was entered by a user in the Console.

You can use the Note Reasons branch for creating, modifying, and deleting a note
reason.

Creating a Note Reason
About this task

To create a note reason:

Procedure

1.

o

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Note Reasons. The Note Reasons window displays in the
work area.

Choose the Create New icon. The Note Reason Details window displays.

In Note Reason, enter the note reason as you want it to appear throughout the
system.

In Short Description, enter a brief description of the note reason.
In Long Description, enter a more detailed description of the note reason.
Choose the Save icon.

Modifying a Note Reason
About this task

To modify a note reason:

Procedure

1.

2.

3.
4.
5.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Note Reasons. The Note Reasons window displays in the
work area.

Select the applicable appointment failure reason and choose the Details icon.
The Note Reason Details window displays.

In Short Description, enter a brief description of the note reason.
In Long Description, enter a more detailed description of the note reason.
Choose the Save icon.

Creating a New Note Reason Based on an Existing One
About this task

To create a new note reason based on an existing one:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Note Reasons. The Note Reasons window displays in the
work area.

2. Select the applicable note reason and choose the Save As icon. The Note
Reason Details window displays.

3. Enter information in the applicable fields.
4. Choose the Save icon.

Deleting a Note Reason

74

About this task

To delete a note reason:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Note Reasons. The Note Reasons window displays in the
work area.

2. Select the applicable appointment failure reason and choose the Delete icon.
The Confirmation window displays.

3. Choose OK.
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Chapter 13. Configuring a Document's Line Relationship Type

Configuring a Document’s Line Relationship Type

You can define the relationship types used when linking two related lines together.
These relationships are used to group similar products together on an order.

Defining a Line Relationship Type
About this task

To create a line relationship type:

Procedure

1.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Line Relationship Type. The Line Relationship Type window
appears in the work area.

Choose the Create New icon. The Line Relationship Details window appears.

In Relationship Type, enter the relationship type as you want it to appear
throughout the system.

In Short Description, enter a brief description of the relationship type.
In Long description, enter a more detailed description of the relationship type.

To enable sorting on this relationship type, check the Consider For Sorting
checkbox.

Choose the Save icon.

Modifying a Line Relationship Type
About this task

To modify a line relationship type:

Procedure

1.

6.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Line Relationship Type. The Relationship Type window
appears in the work area.

Select the applicable relationship and choose the Details icon. The Relationship
Type Details window appears.

In Short Description, enter a brief description of the relationship type.
In Long description, enter a more detailed description of the relationship type.

To enable sorting on this relationship type, check the Consider For Sorting
checkbox.

Choose the Save icon.

Creating a New Line Relationship Type Based on an Existing One
About this task

To create a new line relationship type based on an exiting one.
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Line Relationship Type. The Relationship Type window
appears in the work area.

2. Select the applicable relationship type and choose the Save As icon. The
Relationship Type Details window appears.

3. Enter information in the applicable fields

4. Choose the Save icon.

Deleting a Line Relationship Type
About this task

To delete a line relationship type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Line Relationship Type. The Relationship Type window
appears in the work area.

2. Select the applicable relationship type and choose the Delete icon. The
Confirmation window appears.

3. Choose OK.
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Chapter 14. Configuring an Inbound Order Document's
Fulfillment Specific Components

To complete an order document's lifecycle, each document has a set of different
processes that it can go through. These processes are called process types. Every
order document has a defined set of process types in Sterling Selling and
Fulfillment Foundation.

The following process types are defined in Sterling Selling and Fulfillment
Foundation for the order document types:

¢ Fulfillment
* Negotiation
¢ Shipment
* Receipt

You can configure the rules and components specific to an order document's
fulfillment process type.

Order Fulfillment: Defining Hold Types

Orders and order lines can be placed on hold manually or automatically, by
applying a particular hold type. Certain transactions can be configured to not
process documents that are on a specific type of hold. Likewise, modification types
can be configured to not process documents that are on a specific type of hold. By
default, all transactions and modification types are allowed to process all
documents for all hold types.

The transactions that can be prevented from processing orders or order lines on a
specific type of hold have the checkbox, This Transaction Can Be Stopped From
Processing Orders That Are On Hold, checked in the Others tab of the transaction
details screen. For more information about viewing transaction details, see the
Sterling Selling and Fulfillment Foundation: Configuration Guide.

Order Fulfillment: Creating a Hold Type
About this task

Hold types can be created at either the order or order line level. Selecting Hold
Types from the application rules side panel displays the Order Hold Types screen.
This screen provides a list of previously created holds and their associated level.

Order Fulfillment: Creating an Order Level Hold Type
About this task

To create an order level hold type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Hold Types. The Hold Types window displays
in the work area.
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2. Click the Create New icon in the Order Hold Types panel. The Hold Type
pop-up window displays.

3. In the Hold Type field,

enter the type of the hold.

4. In the Description field, enter the description of the hold type.

5. Enter the information in the applicable fields. For field value descriptions, see

[Table 21| [Table 22 on page 79 and [Table 23 on page 80}

6. Click the Save icon.

Table 21. Hold Type Screen, Hold Creation tab

Field

Description

Hold Created Automatically

On Draft Order Creation

Check this option to apply this hold type to all orders during
draft order creation.

On Draft Order
Confirmation

Check this option to apply this hold type to all orders during
draft order confirmation.

On Order Creation

Check this option to apply this hold type to all orders during
order creation.

On Resolution Of The Hold
Type

Check this option to apply this hold type during the
resolution of another hold type. From the drop-down list,
select the hold type that, upon resolution, triggers this hold
type.

Note: Sterling Selling and Fulfillment Foundation does not
check whether or not you are defining a circular hold type
definition. For example, if you define hold type B as being
applied during the resolution of hold type A, and hold type
A as being applied during the resolution of hold type B, you
can create an infinite loop that Sterling Selling and
Fulfillment Foundation does not warn you against.

When The Following
Modifications Are
Performed

Modification types that automatically apply this hold type to
an order.

Click the Details icon to modify the list. In the subsequent

pop-up window:

* Use the right arrow to move the available modification
types that you wish to associate with this hold type to the
subscribed list.

* Use the left arrow to unsubscribe the modification types
that you wish to disassociate with this hold type and move
them back into the available list.

For All Orders

Select this radio button if the above conditions should be
checked for all orders.

Note: You can only select this option after the created hold
has been saved.
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Table 21. Hold Type Screen,

Hold Creation tab (continued)

Field

Description

Only For Orders Satisfying
The Following Condition

Select this radio button if the above conditions should only be
checked for orders satisfying a certain condition. Click the
Details icon to build or modify the condition that is
evaluated. For more information about using the condition
builder, see the Sterling Selling and Fulfillment Foundation:
Configuration Guide.

The available attributes for this condition can be extended.
For more information about extending condition attributes,
see the Sterling Selling and Fulfillment Foundation: Extending the
Condition Builder.

Note: You can only select this option after the created hold
has been saved

Hold Created Manually

By All Users

Select this radio button if all user groups can apply this hold
to an order.

By Users Who Belong To
The Following Groups

Select this radio button if only users belonging to certain user
groups can apply this hold to an order.

Click the Details icon to modify the list of user groups. In the

subsequent pop-up window:

* Use the right arrow to move the available user groups that
you wish to associate with this hold type to the subscribed
list.

* Use the left arrow to unsubscribe the user groups that you

wish to disassociate with this hold type and move them
back into the available list.

Table 22. Hold Type Screen,

Hold Resolution tab

Field

Description

Hold Resolved Automatically

The Following
Time-Triggered Transaction
Will Process Created Holds

From the drop-down list, select the time-triggered transaction
that will process the created holds.

The Following
Time-Triggered Transaction
Will Process Rejected Holds

From the drop-down list, select the time-triggered transaction
that will process the rejected holds.

Hold Resolved Manually

By All Users

Select this radio button if all user groups can process this
hold.

By Users Who Belong To
The Following Groups

Select this radio button if only users belonging to certain user
groups can process this hold.

Click the Details icon to modify the list. In the subsequent

pop-up window:

* Use the right arrow to move the available user groups that
you wish to associate with this hold type to the subscribed
list.

* Use the left arrow to unsubscribe the user groups that you

wish to disassociate with this hold type and move them
back into the available list.
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Table 23. Hold Type Screen, Hold Effects tab

Fields Description

The Following Transactions | Transactions that are disallowed when this hold type is
Will Be Stopped From applied to an order.

Processing Orders On This

Hold Click the Details icon to modify the list. In the subsequent

pop-up window:
* Use the right arrow to move the available transactions that

you wish to associate with this hold type to the subscribed
list.

* Use the left arrow to unsubscribe the transactions that you
wish to disassociate with this hold type and move them
back into the available list.

The Following Modification types that are disallowed when this hold type is
Modifications Are Not applied to an order.

Allowed For Orders On

This Hold Click the Details icon to modify the list. In the subsequent

pop-up window:
* Use the right arrow to move the available modification

types that you wish to associate with this hold type to the
subscribed list.

* Use the left arrow to unsubscribe the modification types
that you wish to disassociate with this hold type and move
them back into the available list.

Order Fulfillment: Creating an Order Line Level Hold Type
About this task

To create an order line level hold type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Hold Types. The Hold Types window displays
in the work area.

2. Click the Create New icon in the Order Line Hold Types panel. The Hold Type
pop-up window displays.

3. In the Hold Type field, enter the type of the hold.

4. In the Description field, enter the description of the hold type.

5. Enter the information in the applicable fields. For field value descriptions, see
[Table 24} [Table 25 on page 82| and [Table 26 on page 83

6. Click the Save icon.

Table 24. Hold Type Screen, Hold Creation tab

Field | Description

Hold Created Automatically

On Draft Order Creation Check this option to apply this hold type to all lines on an

With Lines Or Adding order upon entering Draft Order Created status or when a

Lines To Draft Order line is added to an order that is already in Draft Order
Created status.

On Draft Order Check this option to apply this hold type to a line upon

Confirmation confirmation of a draft order.
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Table 24. Hold Type Screen,

Hold Creation tab (continued)

Field

Description

On Order Creation Or
Adding Lines To An Order

Check this option to apply this hold type to a line upon
creation or addition to an order.

On Resolution Of The Hold
Type

Check this option to apply this hold type during the
resolution of another hold type. From the drop-down list,
select the hold type that, upon resolution, triggers this hold
type.

Note: Sterling Selling and Fulfillment Foundation do not
check whether or not you are defining a circular hold type
definition. For example, if you define hold type B as being
applied during the resolution of hold type A, and hold type
A as being applied during the resolution of hold type B, you
could create an infinite loop that Sterling Selling and
Fulfillment Foundation do not warn you against.

When The Following
Modifications Are
Performed

Modification types that automatically apply this hold type to
an order.

Click the Details icon to modify the list. In the subsequent

pop-up window:

* Use the right arrow to move the available modification
types that you wish to associate with this hold type to the
subscribed list.

* Use the left arrow to unsubscribe the modification types
that you wish to disassociate with this hold type and move
them back into the available list.

For All Order Lines

Select this radio button if the above conditions should be
checked for all order lines.

Note: You can only select this option after the created hold
has been saved.

Only For Order Lines
Satisfying The Following
Condition

Select this radio button if the above conditions should only be
checked for order lines satisfying a certain condition. Click
the Details icon to build or modify the condition that is
evaluated. For more information about using the condition
builder, see the Sterling Selling and Fulfillment Foundation:
Configuration Guide.

The available attributes for this condition can be extended.
For more information about extending condition attributes,
see the Sterling Selling and Fulfillment Foundation: Extending the
Condition Builder.

Note: You can only select this option after the created hold
has been saved.

Hold Created Manually

By All Users

Select this radio button if all user groups can apply this hold
to an order.

Chapter 14. Configuring an Inbound Order Document's Fulfillment Specific Components

81



82

Table 24. Hold Type Screen,

Hold Creation tab (continued)

Field

Description

By Users Who Belong To
The Following Groups

Select this radio button if only users belonging to certain user
groups may apply this hold to an order.

Click the Details icon to modify the list. In the subsequent

pop-up window:

* Use the right arrow to move the available user groups that
you wish to associate with this hold type to the subscribed
list.

* Use the left arrow to unsubscribe the user groups that you
wish to disassociate with this hold type and move them
back into the available list.

Table 25. Hold Type Screen,

Hold Resolution tab

Field

Description

Hold Resolved Automatically

The Following
Time-Triggered Transaction
Will Process Created Holds

From the drop-down list, select the time-triggered transaction
that will process the created holds.

The Following
Time-Triggered Transaction
Will Process Rejected Holds

From the drop-down list, select the time-triggered transaction
that will process the rejected holds.

Hold Resolved Manually

By All Users

Select this radio button if all user groups can process this
hold.

By Users Who Belong To
The Following Groups

Select this radio button if only users belonging to certain user
groups can process this hold.

Click the Details icon to modify the list. In the subsequent

pop-up window:

* Use the right arrow to move the available user groups that
you wish to associate with this hold type to the subscribed
list.

* Use the left arrow to unsubscribe the user groups that you
wish to disassociate with this hold type and move them
back into the available list.
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Table 26. Hold Type Screen, Hold Effects tab

Fields

Description

The Following Transactions
Will Be Stopped From
Processing Orders On This
Hold

Transactions that are disallowed when this hold type is
applied to an order.

Click the Details icon to modify the list. In the subsequent

pop-up window:

* Use the right arrow to move the available transactions that
you wish to associate with this hold type to the subscribed
list.

* Use the left arrow to unsubscribe the transactions that you

wish to disassociate with this hold type and move them
back into the available list.

The third column is used to select the effect level of the hold.
This determines at whether the transaction will be held at the
order or order line level.

The Following
Modifications Are Not
Allowed For Orders On
This Hold

Modification types that are disallowed when this hold type is
applied to an order.

Click the Details icon to modify the list. In the subsequent

pop-up window:

* Use the right arrow to move the available modification
types that you wish to associate with this hold type to the
subscribed list.

* Use the left arrow to unsubscribe modification types that
you wish to disassociate with this hold type and move
them back into the available list.

Order Fulfillment: Modifying a Hold Type

About this task
To modify a hold type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Hold Types. The Hold Types window displays

in the work area.

2. Select the applicable hold type and click the Details icon. The Hold Type
pop-up window displays. Enter information in the applicable fields.

3. Click the Save icon.

Order Fulfillment: Deleting a Hold Type

About this task
To delete a hold type:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Hold Types. The Hold Types window displays

in the work area.

2. Select the applicable hold type and click the Delete icon.
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Order Fulfillment: Process Type Pipeline Configuration

A process type pipeline is a series of transactions and statuses that guide
document types, such as a Purchase Order, through a predefined process. A
pipeline consists of the different statuses a document goes through during
fulfillment, negotiation, shipment, or receipt. You can also set up transactions
consisting of events, actions, and conditions, as they pertain to the pipeline you are
configuring.

Repositories

A repository is a logical collection of entities that define the business process
workflow.

The following entities are included in a repository:
* Pipelines

* Transactions

 Statuses

* Conditions

¢ Actions

e Services

Sterling Selling and Fulfillment Foundation provides a base repository for each of
the system-defined process types. Some of the entities within a repository are
copied when creating a new document type. For more information about creating a
new document type, see the Sterling Selling and Fulfillment Foundation: Configuration
Guide.

The process of purchase order fulfillment is modeled through a pipeline. This
represents the process configuration that is unique to an organization. An
organization may also specify unique processes for each participating Enterprise.

Order Fulfillment: Defining Pipeline Determination

Pipeline determination is used to set up conditions that affect which pipeline is
used during the start of the business process workflow. For example, an
organization deals with sales orders that sometimes contain hazardous materials.
They have two separate pipelines, one in which orders with order lines without
any hazardous materials go through and one in which orders with order lines
containing hazardous materials must go through for inspection before continuing
through the order process. The organization uses pipeline determination to set up
a condition that determines whether or not order lines contain hazardous materials
and sends the order line down the correct pipeline.

When you expand the Pipeline Determination branch, the components displayed
depends on what role you are logged in as. If you are logged in as a Hub role, the
Hub Rule displays. If you are logged in as an Enterprise role, both the Hub Rule
and My Rule components display. Double-click on the applicable node to display
the pipeline determination rules.

Note: If you are logged in as an Enterprise role, the Hub Rule screen is grayed out
and cannot be modified.
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Drag conditions and pipelines into the work area to construct pipeline
determination rules. A single pipeline or condition must be the root. Conditions
cannot link back to an earlier component in the chain and a pipeline cannot be
linked to twice.

Note: When configuring pipeline determination for an order document type
pipeline, please note that pipeline determination is only considered when adding a
line or creating an order. When changes are made to draft orders pipeline
determination does not occur.

Order Fulfillment: Pipelines
About this task

For more information about configuring pipelines, see the Sterling Selling and
Fulfillment Foundation: Configuration Guide.

To view the purchase order pipeline details,

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Fulfillment Process Model. The Purchase Order
Execution window displays.

2. In the Purchase Order Execution window, choose Purchase Order Execution
Repository > Pipelines > Purchase Order Execution.

3. The Pipeline Detail: Purchase Order Execution (Purchase Order Execution)
window displays.

Results

For more information about creating and modifying a pipeline, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.
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Figure 17. The Pipeline Detail: Purchase Order Execution Window

Order Fulfillment: Transactions

About this task

Every process type has a set of base transactions defined for it. A transaction is a
logical unit of work that is necessary for performing activity within Sterling Selling
and Fulfillment Foundation. Base transactions are predefined transactions that
contain information about how the transaction behaves, such as how many copies
of a transaction can be kept in a process type and whether or not it can have
configurable base pick and drop statuses. Base transactions can be used to create
new transactions. These transactions can be changed within the limits defined in
the base transaction.

For more information about transactions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the transaction details for a purchase order pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Fulfillment Process Model. The Purchase Order
Execution window displays.

2. In the Purchase Order Execution window, choose the Transactions icon.

3. The Transactions tab window displays. Refer to the following table for field
value descriptions.
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Results

For more information about creating and modifying transactions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

Table 27. Purchase Order Pipeline - Transactions Tab Window

Field

Description

Chained Purchase Order
Create

This transaction represents a point in the pipeline where a
chained purchase order is created.

Change Purchase Order

This transaction represents any modifications that may be
made to a purchase order.

Change Purchase Order
Release

This transaction represents any modifications that may be
made to a purchase order release.

Change Schedule

This transaction represents any modifications that may be
made to the scheduling determinations for a purchase order
or order line.

Close Purchase Order

This transaction represents a purchase order being closed.

Close Receipt

This transaction represents a purchase order receipt being
closed.

Confirm Draft Purchase
Order

This transaction represents a draft purchase order is manually
confirmed and considered an actual purchase order in the
system.

Consolidate To Shipment

This transaction the process of finding a shipment into which
a given purchase order release can be included.

Create Draft Purchase
Order

This transaction represents the creation of a draft purchase
order in the system.

Create Purchase Order

This transaction represents the creation of a purchase order in
the system.

Create Purchase Order
Invoice

This transaction represents the creation of an invoice for an
existing purchase order.

Enhanced Purchase Order
Monitor

This transaction represents the an alternate purchase order
monitor featuring an advanced set of parameters used to
monitor purchase orders in the system.

Import Purchase Order

This transaction represents the process of importing a
purchase order that has already been processed to some
extent by an external system.

Include Purchase Order In
Shipment

This transaction represents the process of creating a shipment.
This transaction is internally invoked the confirmShipment
API. See the Sterling Selling and Fulfillment Foundation: Javadocs
for more information.

Purchase Order Monitor

This transaction represents the basic set of parameters used to
monitor orders in the system.

Purge Purchase Order

This transaction represents a purchase order that can be
purged moved from the tables into history tables.

Purge Purchase Order
History

This transaction represents the process of purging purchase
orders from the history tables and removing them from the
system.

Purge Status Audit

This transaction represents the process of removing purchase
order status audit data from the system.

Receive Negotiation

This transaction represents receiving negotiation requests
from the Seller on the purchase order.
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Table 27. Purchase Order Pipeline - Transactions Tab Window (continued)

Field Description

Receive Purchase Order This listener transaction represents the process of receiving a
purchase order at the receiving node.

Release Purchase Order This transaction represents the process of releasing purchase
orders to specific ship nodes, making sure that the scheduled
ship nodes have enough inventory to process the order.

Remove Purchase Order This transaction represents the process of removing a
From Shipment purchase order from an existing shipment.

Schedule Purchase Order This transaction represents the process of scheduling purchase
orders to specific ship nodes making sure that the scheduled
ship nodes have enough inventory to process the order.

Send Purchase Order This transaction represents the process of dispatching releases
Release to ship nodes.
Ship Purchase Order This transaction is internally invoked the confirmShipment

API. See the Sterling Selling and Fulfillment Foundation: Javadocs
for more information.

Ship Shipment This transaction is internally invoked the confirmShipment
API. See the Sterling Selling and Fulfillment Foundation: Javadocs
for more information.

Start Negotiation - This transaction represents the process of initiating the

Purchase Order negotiation process with the Seller on an order.

Synchronize Task Queue This transaction represents the process of synchronizing the
purchase order fulfillment task queue.

Unschedule Order This transaction represents the process of unscheduling a
purchase order that has already been scheduled to a ship
node.

Unreceive This transaction represents the process of unreceiving a
purchase order that has already been received by a receiving
node.

Order Fulfillment: Statuses
About this task

Statuses are the actual states that a document moves through in the pipeline. A
transaction can contain two types of statuses, a drop status and a pickup status. A
document is moved into a drop status when the events and conditions of a
transaction have been completed. A pickup status takes the document from the
previous drop status and moves it through the next transaction. Created and
Scheduled are examples of statuses.

For more information about statuses, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the status details of a purchase order pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Fulfillment Process Model. The Purchase Order
Execution window displays.

2. In the Purchase Order Execution window, choose the Statuses icon.
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3. The Statuses tab window displays. Refer to the following table for field value

descriptions.

Results

For more information about creating and modifying statuses, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.

Table 28. Order Fulfillment Pipeline - Statuses Tab Window

Field

Description

Draft Order Created

This indicates that a draft purchase order has been created.

Created

This indicates that a purchase order has been created.

Reserved

This indicates the purchase order has been created, but it is
not ready to schedule yet.

Being Negotiated

This indicates that the purchase order is undergoing the
negotiation process with the Buyer on the order.

Accepted This indicates that a purchase order has been manually
accepted.

Backordered This indicates that a purchase order is backordered until
sufficient inventory is available.

Unscheduled This indicates that the purchase order has been removed from

Scheduled status and any inventory that has been reserved
for the order at the scheduled node(s) is canceled.

Backordered From Node

This indicates that the purchase order has been created and
released to the node, but the node does not have enough
inventory to fulfill the order.

Scheduled

This indicates that the applicable node(s) have the inventory
to fulfill the purchase order and can be scheduled for release.

Awaiting Chained Order
Creation

This indicates that the purchase order is waiting on the
creation of a chained order.

Awaiting Shipment
Consolidation

This indicates the purchase order is waiting on the
consolidation of its shipments.

Chained Order Created

This indicates that a chained purchase order must be created
and sent to the applicable node.

Released

This indicates that there is enough inventory to schedule to
the purchase order for fulfillment. The order is released to the
Application Consoles, the Sterling Warehouse Management
System version 9.1, or another third-party warehouse
management system.

Sent To Node

This indicates that the purchase order is sent in the form of a
purchase order release.

Included In Shipment

This indicates that the purchase order is included in a
shipment.

Shipped This indicates that the purchase order has been shipped

Unreceived This indicates that a purchase order that was originally
received at a receiving node needs to be re-received.

Received This indicates that the purchase order has been received by

the receiving node and is in Receipt In Progress status in the
Purchase Order Receipt pipeline.
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Table 28. Order Fulfillment Pipeline - Statuses Tab Window (continued)

Field Description

Receipt Closed This indicates that the purchase order has been fully received
and the receipt can be removed from the system.

Note: A purchase order moves into Receipt Closed status
after a purchase order receipt moves into Received status in
the Purchase Order Receipt pipeline.

Purchase Order Invoiced This indicates that an invoice has been created for a purchase
order.

Held This indicates that the purchase order is being held and no
modifications can be made until it is released from the hold.

Shipment Delayed This indicates that all or part of the purchase order shipment
has been delayed.

Cancelled This indicates that the purchase order has been canceled.

Shorted This indicates that the purchase order contains less quantity

than requested.

Received As Components | This indicates that the purchase order has been received as
one or more individual components.

Order Fulfillment: Conditions

About this task

A condition matches document type attributes against decision points and routes
the documents to different paths based on the specified attribute and value
combinations. The document type attributes against which conditions can be
created are predefined in Sterling Selling and Fulfillment Foundation. You can use
these attributes in any combination or you can create conditions that run the
appropriate application logic for specific circumstances.

For more information about conditions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the condition details of a purchase order pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Fulfillment Process Model. The Purchase Order
Execution window displays.

2. In the Purchase Order Execution window, choose the Conditions icon.

3. The Conditions tab window displays. Refer to the following table for field
value descriptions.

Results

For more information about creating and modifying conditions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

Table 29. Purchase Order Pipeline - Conditions Tab Window

Field Description

Conditions Displays conditions that are specific to the purchase order
pipeline, if any.
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Order Fulfillment: Actions
About this task

An action is a process or program that is triggered by an event. These processes
and programs send user alert notifications and automatically resolve issues.

For example, when an order is released (the event), you can set an action to send
the customer an e-mail.

For more information about Actions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the action details of a purchase order pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Fulfillment Process Model. The Purchase Order
Execution window displays.

2. In the Purchase Order Execution window, choose the Actions icon.

3. The Actions tab window displays.
Results

For more information about creating and modifying actions, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.

Defining Transaction Rules
About this task

You can define additional rules for shipment advice, shipment confirmation, order
entry, order monitoring, and negotiation monitoring.

To define additional transaction rules:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Transaction Specific Rules. The Transaction
Rules window displays.

2. Enter information in the applicable fields. Refer to[Table 30| for field value
descriptions.

3. Choose the Save icon.

Table 30. Transaction Rules Window

Field Description
Ship Advice

Include Price Information When selected, the system sends down price information on
in Instruction the order as a part of the ship advice instructions.

This is a DCS-specific parameter. Key price-related elements
from Sterling Selling and Fulfillment Foundation are sent to
DCS as instructions of type SHC (shipping and handling
charges at order header level), PRM (discount amount at the
order header level), and STX (tax at the order header level).

Chapter 14. Configuring an Inbound Order Document's Fulfillment Specific Components 91



Table 30. Transaction Rules

Window (continued)

Field

| Description

Ship Confirm

Cancel Order on Inventory
Shortage

When selected, items are canceled or backordered in case of
inventory shortage.

Note: This flag is used by the confirm shipment agent; it is
not used by the confirmShipment API. If you want to cancel
warehouse backorders, you need to pass the
CancelRemovedQuantity=Y flag in the changeShipment APL

Order Monitor

Order Monitor Relog
Interval

Enter the number of hours after which the order monitor
raises an action if a document type remains in the same
status in a pipeline.

The Inventory Monitor and Order Monitor run at predefined
(scheduled) intervals. Once an alert is raised, the same alert
should not be raised over and over again at every run. Relog
intervals control how soon after the previous alert the next
alert should be triggered.

Important: This field has no impact on the Enhanced Order
Monitor.

Negotiation Monitor

Negotiation Monitor Relog
Interval

Enter the number of hours after which the Negotiation
Monitor raises an action if a document type remains in the
same status in a negotiation pipeline.

Post Voided Sale on Order

Mark Post Voided Sale for
Auto-Cancellation After

Enter the number of hours based on which the auto-cancel
date is set on the order.

Reship Order

Minimum Reship Window

Enter the minimum number of days allowed to pass after an
order line has been shipped before an order line may need to
be reshipped.

Action to take on parent lin

e when chained line is canceled

Unschedule

When selected the unschedule action is performed on the
parent order line when a chained order line is canceled. An
unscheduled parent line is synonymous with a backordered
line. For more information about chained orders, see the
Sterling Selling and Fulfillment Foundation: Configuration Guide.

Cancel

When selected the parent line is canceled when a chained
order line is canceled. For more information about chained
orders, see the Sterling Selling and Fulfillment Foundation:
Configuration Guide.

Cancellation of Order Lines

with Work Orders
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Table 30. Transaction Rules Window (continued)

Field

Description

Allow Cancellation Even If
Work Order Cannot Be
Cancelled

An order may have generated a work order to customize the
item for the customer. In some scenarios, the work order
cannot be cancelled. For example, the work order cannot be
cancelled because the work order has already been
completed, or because the work order is performed by an
organization that does not accept work order cancellations.

By default, the order associated with the work order cannot
be cancelled. Select ‘Allow Cancellation Even If Work Order
Cannot Be Cancelled' to permit the parent orders to be
cancelled if the work order cannot be cancelled.

Synchronize Dates

Synchronize Dates Between
Master Order Dates And
Dates On Order Line And
Schedules

Check this box to synchronize the requested dates and the
expected ship dates for the Order, Order Header, Order Line,
and Order Line Schedules.

The requested dates synchronize with the requested ship,
requested deliver, and cancel dates on the order line or
header.

The expected dates synchronize with the order schedules.
Note: If this rule is not chosen, the synchronization between
dates is not possible.

Expected Dates On Order

Do Not Recompute
Expected Dates When
Requested Dates On The
Order Are Changed

Check this box when you do not want the requested dates on
the order line to be synchronized with the expected dates on
the order line schedule.

Note: The dates are synchronized only during the line
creation.

Note: Scheduling should not be used on orders which have
expected and requested dates that are not synchronized.

Confirm Draft Order

Update Order Date On
Confirm Draft Order

Check this box to set the order date to the date when the
order is confirmed and not the date when the order is
created.

Synchronize Items

Use Fulfillment Items
When Order Is Created As
A Chained Order

Check this box to display fulfillment items on the chained
orders of purchase orders and drop-ship orders. Before
enabling this option, ensure that "GTIN" is selected in the
"Read Availability Across Items Sharing the Same" field in the
Sterling Global Inventory Visibility application.

Action To Take When Unsch

eduling Last Product Line

Remove Association To
Delivery Service Line

When selected, if the last product line on a work order is
cancelled, the association with the delivery line is removed.

Keep Association To
Delivery Service Line

When selected, if the last product line on a work order is
cancelled, the association with the delivery line is kept.

Customer Contact Status

Hold Type To Be Applied
To An Order When
Customer Contact Is On
Hold

Select the hold type you want to be applied on an order
when a customer contact is on hold.

Order Approval
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Table 30. Transaction Rules Window (continued)

Field

Description

Hold Type To Be Applied
When Order Needs
Approval

Select the hold type you want to be applied when an order
requires approval.

Note: The hold is triggered internally by the system, and
therefore, should not be set to automatically apply in the hold
configuration.

Enable Order Approval
Hold Determination On
Order Change

Check this box if you want order approval holds to be
resolved automatically when an order is changed and the
conditions necessary to require approval are no longer met.

Pending Order Changes

Pending Order Changes
Will Expire In

Enter the number of hours after which the pending changes
on the order will expire.

Hold To Be Applied When
Order Has Pending

Changes

Select the hold type you want to be applied on an order that
has pending changes.

Defining Status Inventory Types

You can define how and when inventory is updated for Sellers and Buyers
tracking inventory, on a status-by-status basis. The Status Inventory Types table is
used to associate statuses with specific supply and demand types according to
organization. When an order moves through the statuses of a given fulfillment
pipeline the values corresponding to the Buyer supply type and Seller demand
type associated with the original status are decreased and the values for the status
the order is moving into are increased.

Example

Assume you have the following records in the Status Inventory Type table:

Table 31. Sample Status Inventory Type Records

Buyer Supply |Seller Demand Increment Seller
Status Type Type Seller Supply Type |Supply
1100 Purchase Open Order Onhand N
Order Placed
3200 Purchase Released Onhand N
Order Released
3700 Intransit Y

When an order with a line
the Purchase Order Placed

item quantity of 10 is created in Created (1100) status,
supply record is updated with a quantity of 10. A Open

Order demand type with a quantity of 10 is created for the Seller.

In this example, if a quantity of 3 is moved into Released (3200) status, the
Purchase Order Placed supply record is decreased by 3 and a new supply record
with a quantity of 3 is created for the Purchase Order Released supply type. The
Open Order demand record is also decreased by 3 and a new demand record is
with a quantity of 3 is created for the Released demand type.

When the order moves from Released (3200) status to Shipped (3700) status, the
Buyer's supply is decreased for the Purchase Order Released supply type and
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increased for Intransit. The Seller's demand is decreased for the Released demand
type. However, the demand type is not increased for a new type, because the Seller
Demand Type associated with the Shipped (3700) status is blank.

In the above configuration, the Increment Seller Supply flag is set to 'Y' and the
Seller's supply type for the Shipped (3700) status is Onhand. The Increment Seller
Supply flag indicates that the Seller's supply must be adjusted when moving any
quantity into the Shipped (3700) status.

The value in the Seller Supply Type column indicates the supply type that should
be updated, in this example, Onhand. Since the record for the Released (3200)
status has the Onhand Seller supply type associated with it and the Shipped (3700)
status record has a blank Seller supply type associated with it, the Onhand Seller
supply type decreases when moving from Released (3200) status to Shipped (3700)
status. The Seller supply type is not increased with this status move because the
value in the Seller Supply Type column for the Shipped (3700) status is blank.

To view a process type's status inventory types, from the tree in the application
rules side panel, choose Document Specific > (Document Type) > Fulfillment >
Status Inventory Types. The Status Inventory window displays. Refer to[Table 3

for assistance.

Table 32. Status Inventory Types Window

Field Description

Orders Without Select the Orders Without Chaining tab to view the status
Chaining/Orders With inventory types for orders that flow through the process
Chained type pipeline without having any associated chained orders.
Children/Procurement

Orders Select the Orders With Chained Children tab to view the

status inventory types of orders having associated
drop-ship chained orders.

Select the Procurement Orders tab to view the status
inventory types of procurement orders.

Status The order document's status.

Buyer Supply Type The Buyer's supply type associated with the order
document's status.

Seller Supply Type The Seller's supply type associated with the order
document's status.

Update Seller Supply Indicates if inventory updates are made when an order
document moves into the associated status.

Seller Demand Type The Seller's demand type associated with the order
document's status.

Creating a Status Inventory Type
About this task

To create a status inventory type:

Procedure

1. In the Status Inventory Types window, choose the Create New icon. The Status
Inventory Type Details window displays.
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2. Enter information in the applicable fields. Refer to[Table 33 for field level
descriptions.

3. Choose the Save icon.

Table 33. Status Inventory Type Details Window

Field Description

Status Select the order document status that you want to associate
inventory types with.

Buyer Supply Type Select the Buyer supply type that you want to associate with
the order document status.

Seller Supply Type Select the Seller supply type that you want to associate with
the order document status.

Update Seller Supply Select this field if you want inventory updates to be
performed on the associated inventory types when the order
document enters this status.

Note: If you are integrating with Sterling Warehouse
Management System version 9.1, this field must be selected
and you must specify the Seller Supply Type.

Seller Demand Type Select the Seller demand type that you want to associate with
the order document status.

Modifying a Status Inventory Type
About this task

To modify a status inventory type:

Procedure

1. In the Status Inventory Types window, locate the applicable status inventory
type and choose the Details icon. The Status Inventory Type Details window
displays.

2. Enter information in the applicable fields. Refer to the following table for field
level descriptions.

3. Choose the Save icon.

Deleting a Status Inventory Type
About this task

To delete a status inventory type, locate the applicable status inventory type in the
Status Inventory Types window and choose the Delete icon.

Note: Default status inventory types which are originally shipped with Sterling
Selling and Fulfillment Foundation cannot be deleted.

Defining Monitoring Components

You can define the components used to measure and report unexpected conditions
and delays in the order document’s lifecycle. For more information about using
these components to configure monitoring rules, see the Sterling Selling and
Fulfillment Foundation: Configuration Guide.
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To define a process type’s monitoring components, from the tree in the application
rules side panel, choose Document Specific > (Document Type) > Fulfillment >
Order Monitoring. The Monitoring window displays.

Order Fulfillment: Defining Date Types

You can define custom date types. These dates automatically appear in the
configuration screen and the Order/Shipment Dates window in the Application
Console.

Order Fulfillment: Creating a Date Type
About this task

To create a date type:

Procedure

1. In the Monitoring window, choose the Date Types tab.

2. From the Date Types list, choose the Create New icon. The Date Type Details
window displays.

3. Enter information in the applicable fields. Refer to the table that follows for
field level descriptions.

4. Choose the Save icon.

Table 34. Date Type Details Window

Field Description

Date Type Enter the name of the date type.

Description Enter a brief description of the date type.

Requested Select this field to indicate if the date type represents a date

requested by a Buyer, user, etc.

Expected Select this field to indicate if the date type represents a date

the system expects or has calculated something to occur.

Actual Select this field to indicate if the date type represents the

actual date.

Order Fulfillment: Modifying a Date Type
About this task

To modify a date type:

Procedure

1. In the Monitoring window, choose the Date Types tab.

2. From the Date Types list, locate the applicable date type and choose the Details
icon. The Date Type Details window displays.

3. Enter information in the applicable fields. Refer to the table that follows for
field level descriptions.

4. Choose the Save icon.

Chapter 14. Configuring an Inbound Order Document's Fulfillment Specific Components 97



Order Fulfillment: Deleting a Date Type
About this task

To delete a date type:

Note: The following system dates cannot be deleted:
* Delivery Date

* Order Date

¢ Ship Date

Procedure
1. In the Monitoring window, choose the Date Types tab.

2. From the Date Types list, locate the applicable date type and choose the Delete
icon.

Order Fulfillment: Defining Milestones

You can configure applicable statuses in a process type to be milestones. A
milestone is a type of date that Sterling Selling and Fulfillment Foundation
automatically determines when an order moves from one status to another. A
milestone represents a significant point in the processing lifecycle that can be used
as a criterion for monitoring. Milestones can be defined at the order, order line,
order release, and order release line levels.

Note: A milestone can be reached whenever there is a change in an order line.
Sterling Selling and Fulfillment Foundation marks a milestone as reached if an
order line reaches a status marked as a milestone. However, there may be times
that only part of an order line reaches a particular status defined as milestone.

Order Fulfillment: Creating a Milestone
About this task

To create a milestone:

Procedure
1. In the Monitoring window, choose the Milestones tab.

2. From the Milestones list, choose the Create New icon. The Milestone Details
window displays.

3. Enter information in the applicable fields. Refer to the table that follows for
field level descriptions.

4. Choose the Save icon.

Table 35. Milestone Details

Field Description

Primary Info

Date Type Enter the name of the milestone being created.
Note: You cannot use date types you have created on the
date type tab. You must create a unique name for the

milestone.
Description Enter a brief description of the milestone.
Requested Select this field to indicate if the milestone represents a date

requested by a Buyer, user, etc.
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Table 35. Milestone Details (continued)

Field Description

Expected Select this field to indicate if the milestone represents a date
the system expects or has calculated something to occur.

Actual This field is not applicable for milestones.

Milestone Statuses You can add statuses to associate with the milestone by

selecting the Create New icon and entering information in the
applicable fields.

Note: This tab can only be accessed once the Primary Info
tab has been filled out and saved.

Date Type The date type if any associated with the milestone.

Status Select the status you want use to indicate the milestone has
been reached.

Level Select Order to indicate this status must be reached at the
order header level.

Select Order Line to indicate that this status must be reached
at the order line level.

Select Order Release to indicate that this status must be
reached at the order release level.

Quantity Type Select Initial to indicate that the milestone is met when any
quantity at the above selected level moves into the status.

Select Complete to indicate that the milestone is met when all
quantity at the above selected level moves into the status.

Order Fulfillment: Modifying a Milestone
About this task

Note: If modifications are made to an existing milestone, the changes are only
applied to new orders. Existing orders for which milestone records have already
been created are not considered.

To modify a milestone:

Procedure
1. In the Monitoring window, choose the Milestones tab.

2. From the Milestones list, locate the applicable milestone and choose the Details
icon. The Milestone Details window displays.

3. Enter information in the applicable fields. Refer to|Table 35 on page 98] for field
level descriptions.

4. Choose the Save icon.

Order Fulfillment: Deleting a Milestone
About this task

To delete a milestone:

Procedure
1. From the Monitoring window, choose the Milestones tab.

2. From the Milestones list, locate the applicable milestone and choose the Delete
icon.
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Order Fulfillment: Defining Monitoring Events

Events are used in instances where the Enhanced Order Monitor may raise
multiple alerts of the same type. For example, if an order with multiple lines that
are shipped together has a shipment delay and you have configured the Enhanced
Order Monitor to raise alerts when shipments are delayed at the line level, an alert
of the same type would be raised against each line in the order. You can create
rules to aggregate all of these similar alerts and raise one "root cause".

About this task

To create an event rule:

Procedure

Order Fulfillment: Creating an Event Rule

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Monitor Events. The Monitor Events window

displays.

2. From the Monitor Events list, choose the Create New icon. The Monitor Events
Details window displays.

3. Enter information in the applicable fields. Refer to the table that follows for

field level descriptions.
4. Choose the Save icon.

Table 36. Monitor Event Details Pop-Up Window

Field Description
Event Id Enter the event ID.
Description Enter a brief description of the event.

Requires Realert

Select this field if you want users to be re-alerted if the issue
has not been resolved within a certain timeframe.

Realert Interval

If you selected Requires Realert, enter the interval (in hours)
that re-alerts should be sent.

Automatically Resolve
Alerts

Select this field to automatically remove an alert if the alert
condition is no longer valid. Once the alert is resolved, a new
alert is raised if the condition is detected again.

Event Identified By

Order

Select this field if you want two or more alert conditions to
be treated the same if they belong to the same order.

Note: This field can be selected in conjunction with Order
Line and/or Order Release fields.

Order Line

Select this field if you want two or more alert conditions to
be treated the same if they belong to the same order line.
Note: This field can be selected in conjunction with Order
and/or Order Release fields.

Order Release

Select this field if you want two or more alert conditions to
be treated the same if they belong to the same order release.
Note: This field can be selected in conjunction with Order
and/or Order Line fields.

Ship Node

Select this field if you want two or more alert conditions to
be treated the same if they belong to the same ship node.
Note: This field must be used in conjunction with the Order,
Order Line, and/or Order Release fields.
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Table 36. Monitor Event Details Pop-Up Window (continued)

Field Description

Seller Organization Select this field if you want two or more alert conditions to
be treated the same if they belong to the same Seller.

Note: This field must be used in conjunction with the Order,
Order Line, and/or Order Release fields.

Buyer Organization Select this field if you want two or more alert conditions to
be treated the same if they belong to the same Buyer.

Note: This field must be used in conjunction with the Order,
Order Line, and/or Order Release fields.

Service To Be Invoked Select the alert service to be invoked should the event
consolidation rule conditions be met.

Aggregate And Invoke Service For

Order Select this field if you want only one alert to be raised for an
order when alert conditions are detected.

Order Line Select this field if you want only one alert to be raised per
order line when alert conditions are detected.

Order Release Select this field if you want only one alert to be raised for an
order release when alert conditions are detected.

Ship Node Select this field if you want only one alert to be raised for a
particular ship node when alert conditions are detected.

Seller Organization Select this field if you want only one alert to be raised for a
particular Seller when alert conditions are detected.

Buyer Organization Select this field if you want only one alert to be raised for a
particular Buyer when alert conditions are detected.

Note: In most cases the attributes that identify an event should be a subset of
the attributes that specify event aggregation.

Order Fulfillment: Modifying an Event
About this task

To modify an event rule:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Monitor Events. The Monitor Events window
displays.

2. From the Monitor Events list, select the applicable event rule and choose the
Details icon. The Monitor Event Details window displays.

3. Enter information in the applicable fields. Refer to [Table 36 on page 100| for
field level descriptions.

4. Choose the Save icon.

Order Fulfillment: Deleting an Event
About this task

To delete an event rule:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Monitor Events. The Monitor Events window
displays.

2. From the Monitor Events list, select the applicable event rule and choose the
Delete icon.

102 Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide



Chapter 15.

Configuring an Order Document's Shipment

Specific Components

Configuring an Order Document's Shipment Specific Components

To complete an order document's lifecycle, each document has a set of different
processes that it can go through. These processes are called process types. Every
order document has a defined set of process types in Sterling Selling and
Fulfillment Foundation.

The following process types are defined in Sterling Selling and Fulfillment
Foundation for the order document types:

¢ Fulfillment
* Negotiation
¢ Shipment
* Receipt

* Receipt

You can configure the rules and components specific to an order document's
shipment process type.

Shipments: Defining Hold Types

Shipments can be placed on hold manually or automatically by applying a
particular hold type. Certain transactions can be configured to ensure that
shipments put on hold are not processed. Likewise, modification types can be
configured to ensure shipments that are on hold are not processed. By default, all
transactions and modification types are allowed to process all documents for all
hold types.

To prevent transactions from processing shipments that are put on hold, in the
Others tab in the Transaction Detail screen, check the "This Transaction Can Be
Stopped From Processing Shipments That Are On Hold" box. For more information
about viewing transaction details, see the Sterling Selling and Fulfillment Foundation:
Configuration Guide.

To create, modify, and delete hold types, from the tree in the application rules side
panel, choose Document Specific > (Document Type) > Inbound Logistics > Hold
Types. For more information about defining hold types, see the Sterling Selling and
Fulfillment Foundation: Logistics Management Configuration Guide.

Shipments: Process Type Pipeline Configuration

© Copyright IBM Corp.

A process type pipeline is a series of transactions and statuses that guide
document types, such as a Sales Order, through a predefined process. A pipeline
consists of the different statuses a document goes through during fulfillment,
negotiation, shipment, or receipt. You can also set up transactions consisting of
events, actions, and conditions, as they pertain to the pipeline you are configuring.
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Repositories

A repository is a logical collection of entities that define the business process
workflow.

The following entities are included in a repository:
* Pipelines

¢ Transactions

¢ Statuses

* Conditions

¢ Actions

* Services

Sterling Selling and Fulfillment Foundation provide a base repository for each of
the system defined process types. Some of the entities within a repository are
copied when creating a new document type. For more information about creating a
new document type, see the Sterling Selling and Fulfillment Foundation: Configuration
Guide.

The process of purchase order shipment is modeled through a pipeline. This
represents the process configuration that is unique to an organization. An
organization may also specify unique processes for each participating Enterprise.

Shipments: Defining Pipeline Determination

Pipeline determination is used to set up conditions that affect which pipeline is
used during the start of the business process workflow. For example, an
organization deals with sales orders that sometimes contain hazardous materials.
They have two separate pipelines, one in which orders with order lines without
any hazardous materials go through and one in which orders with order lines
containing hazardous materials must go through for inspection before continuing
through the order process. The organization uses pipeline determination to set up
a condition that determines whether or not order lines contain hazardous materials
and sends the order line down the correct pipeline.

When you expand the Pipeline Determination branch, the components displayed
depends on what role you are logged in as. If you are logged in as a Hub role, the
Hub Rule displays. If you are logged in as an Enterprise role, both the Hub Rule
and My Rule components display. Double-click on the applicable node to display
the pipeline determination rules.

Note: If you are logged in as an Enterprise role, the Hub Rule screen is grayed out
and cannot be modified.

Drag conditions and pipelines into the work area to construct pipeline
determination rules. A single pipeline or condition must be the root. Conditions
cannot link back to an earlier component in the chain and a pipeline cannot be
linked to twice.

Note: When configuring pipeline determination for an order document type
pipeline, please note that pipeline determination is only considered when adding a
line or creating an order. When changes are made to draft orders pipeline
determination does not occur.

104 Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide



Shipments: Pipelines
About this task

“To view the inbound shipment pipeline details,

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipment Process Model. The Inbound
Shipment window displays.

2. In the Inbound Shipment window, choose Inbound Shipment Repository >
Pipelines > Inbound Shipment.

3. The Pipeline Detail: Inbound Shipment (Inbound Shipment) window displays.

Results

For more information about creating and modifying a pipeline, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

*Z Pipeline Detail: Inbound Shipment (#51) { Inbound Shipment )

Pipeline IT |PO-SHIPMENT-?51

| Pipeline Description |Inb0undShipment (751) |

Pipeline Definition

Enterprize

? Shiprnent Created
Create Shipment

Fulfillmment Center

Create And Confirm SHiprment

Print Pick Lizt i i
Hibui=atehpoed Create Shipment Invaice

Shiprment Being Picked

Receiving Mode

" Recaip Closad
5

Confirrn Shipment

Shipment Shipped .ﬁxl'

Feceipt Closure Listener

Included In Recaipt

y

Include In Receipt

[4]

Shipments: Transactions
About this task

Every process type has a set of base transactions defined for it. A transaction is a
logical unit of work that is necessary for performing activity within Sterling Selling
and Fulfillment Foundation. Base transactions are predefined transactions that
contain information about how the transaction behaves, such as how many copies
of a transaction can be kept in a process type and whether or not it can have
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configurable base pick and drop statuses. Base transactions can be used to create
new transactions. These transactions can be changed within the limits defined in

the base transaction.

For more information about transactions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the transaction details for an inbound shipment pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipment Process Model. The Inbound
Shipment window displays.

2. In the Inbound Shipment window, choose the Transactions icon.

3. The Transactions tab window displays. Refer to the following table for field

value descriptions.

Results

For more information about creating and modifying transactions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

Table 37. Inbound Shipment Pipeline - Transactions Tab Window

Field

Description

Change Shipment

This transaction represents any modifications that may be
made to a shipment.

Change Shipment Status

This transaction represents any modifications that may be
made involving an order or order line's status.

Close Shipment

This transaction represents a shipment being closed and
archived in the system.

Confirm Shipment

This transaction represents a shipment is manually confirmed
and shipped.

Create And Confirm
Shipment

This transaction represents the process of creating a shipment
and shipping it.

Create Shipment

This transaction represents the creation of a shipment in the
system.

Create Shipment Invoice

This transaction represents the creation of a shipment invoice.

Deliver Shipment

This transaction represents a shipment being delivered.

Import Shipment

This transaction represents the process of importing a
shipment that has already been processed to some extent by
an external system.

Include In Receipt

This transaction represents the process of including a
shipment in an existing receipt.

Pack Shipment

This transaction represents the process of packing a shipment.

Print Pick List

This transaction represents the process of printing a pick list.

Purge Pick List

This transaction represents a pick list that can be purged from
the system.

Purge Shipment

This transaction represents the process of moving shipments
to the history tables.

Purge Shipment History

This transaction represents the process of purging shipments
from the history tables and removing them from the system.
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Table 37. Inbound Shipment Pipeline - Transactions Tab Window (continued)

Field Description

Receipt Closure Listener This transaction listens to the inbound receipt process and
identifies whether the receipt is closed for the shipment.

Shipment Monitor This transaction represents the process of monitoring
shipments in the system based on defined parameters.

Synchronize Task Queue This transaction represents the process of synchronizing the
order fulfillment task queue.

Unpack Shipment This transaction indicates that a shipment that has moved
through the Pack Shipment transaction is unpacked.

Shipments: Statuses
About this task

Statuses are the actual states that a document moves through in the pipeline. A
transaction can contain two types of statuses, a drop status and a pickup status. A
document is moved into a drop status when the events and conditions of a
transaction have been completed. A pickup status takes the document from the
previous drop status and moves it through the next transaction. Created and
Scheduled are examples of statuses.

For more information about statuses, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the status details of an inbound shipment pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipment Process Model. The Inbound
Shipment window displays.

2. In the Inbound Shipment window, choose the Statuses icon.

3. The Statuses tab window displays. Refer to the following table for field value
descriptions.

Results

For more information about creating and modifying statuses, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.

Table 38. Inbound Shipment Pipeline - Statuses Tab Window

Field Description

Shipment Created This indicates that a shipment has been created.

Shipment Being Picked This indicates that the line items are physically being picked
in preparation for shipment.

Shipment Shipped This indicates that the shipment has been shipped to the ship
to address.

Shipment Delivered This indicates that the shipment has been delivered to the
ship node address.

Included In Receipt This indicates that the shipment has been included in the
receipt.

Receipt Closed This indicates the receipt for the shipment has been closed.
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Table 38. Inbound Shipment Pipeline - Statuses Tab Window (continued)

Field Description
Shipment Invoiced This indicates that an invoice has been created for the
shipment.

Shipments: Conditions
About this task

A condition matches document type attributes against decision points and routes
the documents to different paths based on the specified attribute and value
combinations. The document type attributes against which conditions can be
created are predefined in Sterling Selling and Fulfillment Foundation. You can use
these attributes in any combination or you can create conditions that run the
appropriate application logic for specific circumstances.

For more information about conditions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the condition details of an inbound shipment pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipment Process Model. The Inbound
Shipment window displays.

2. In the Inbound Shipment window, choose the Conditions icon.

3. The Conditions tab window displays. Refer to the following table for field
value descriptions.

Results

For more information about creating and modifying conditions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

Table 39. Inbound Shipment Pipeline - Conditions Tab Window

Field Description

Conditions Displays conditions that are specific to the inbound shipment
pipeline, if any.

Shipments: Actions
About this task

An action is a process or program that is triggered by an event. These processes
and programs send user alert notifications and automatically resolve issues.

For example, when an order is released (the event), you can set an action to send
the customer an e-mail.

For more information about actions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the action details of an inbound shipment pipeline:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipment Process Model. The Inbound
Shipment window displays.

2. In the Inbound Shipment window, choose the Actions icon.
3. The Actions tab window displays.

Results

For more information about creating and modifying actions, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.

Shipments: Defining Monitoring Components

You can define the components used to measure and report unexpected conditions
and delays in the order document’s lifecycle. For more information about using
these components to configure monitoring rules, see the Sterling Selling and
Fulfillment Foundation: Configuration Guide.

To define monitoring components, from the tree in the application rules side panel,
choose Document Specific > (Document Type) > Outbound Logistics > Shipment
Monitoring. The Monitoring window displays.

Shipments: Defining Date Types

You can define custom date types. These dates automatically appear in the
configuration screen and the Order/Shipment Dates window in the Application
Console.

Shipments: Creating a Date Type:
About this task

To create a date type:

Procedure
1. In the Monitoring window, choose the Date Types tab.

2. From the Date Types list, choose the Create New icon. The Date Type Details
window displays.

3. Enter information in the applicable fields. Refer to the table that follows for
field level descriptions.

4. Choose the Save icon.

Table 40. Date Type Details Window

Field Description

Date Type Enter the name of the date type.

Description Enter a brief description of the date type.

Requested Select this field to indicate if the date type represents a date

requested by a Buyer, user, etc.

Expected Select this field to indicate if the date type represents a date
the system expects or has calculated something to occur.

Actual Select this field to indicate if the date type represents the
actual date.

Shipments: Modifying a Date Type:
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About this task
To modify a date type:

Procedure
1. In the Monitoring window, choose the Date Types tab.

2. From the Date Types list, locate the applicable date type and choose the Details
icon. The Date Type Details window displays.

3. Enter information in the applicable fields. Refer to|Table 40 on page 109) for
field level descriptions.

4. Choose the Save icon.

Shipments: Deleting a Date Type:
About this task

To delete a date type:

Note: The following system dates cannot be deleted:
* Delivery Date
* Ship Date

Procedure
1. In the Monitoring window, choose the Date Types tab.

2. From the Date Types list, locate the applicable date type and choose the Delete
icon.

Shipments: Defining Milestones

You can configure applicable statuses in a process type to be milestones. A
milestone is a type of date Sterling Selling and Fulfillment Foundation
automatically determines when an order moves from one status to another. A
milestone represents a significant point in the processing lifecycle that can be used
as a criterion for monitoring. Milestones can be defined at the order, order line,
order release, and order release line levels.

Note: A milestone can be reached whenever there is a change in an order line.
Sterling Selling and Fulfillment Foundation marks a milestone as reached if an
order line reaches a status marked as a milestone. However, there may be times
that only part of an order line reaches a particular status defined as milestone.

Shipments: Creating a Milestone:
About this task

To create a milestone:

Procedure
1. In the Monitoring window, choose the Milestones tab.

2. From the Milestones list, choose the Create New icon. The Milestone Details
window displays.

3. Enter information in the applicable fields. Refer to the table that follows for
field level descriptions.

4. Choose the Save icon.

110 Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide



Table 41. Milestone Details

Field Description

Date Type Enter the name of the milestone being created.
Note: You cannot use date types you have created on the
date type tab. You must create a unique name for the

milestone.

Description Enter a brief description of the milestone.

Requested Select this field to indicate if the milestone represents a date
requested by a Buyer, user, etc.

Expected Select this field to indicate if the milestone represents a date
the system expects or has calculated something to occur.

Actual This field is not applicable for milestones.

Milestone Statuses You can add statuses to associate with the milestone by

selecting the Create New icon and entering information in the
applicable fields.

Note: This tab can only be accessed once the Primary Info
tab has been filled out and saved.

Date Type The date type if any associated with the milestone.

Status Select the status you want use to indicate the milestone has
been reached.

Level Select Order to indicate this status must be reached at the
order header level.

Select Order Line to indicate that this status must be reached
at the order line level.

Select Order Release to indicate that this status must be
reached at the order release level.

Quantity Type Select Initial to indicate that the milestone is met when any
quantity at the above selected level moves into the status.

Select Complete to indicate that the milestone is met when all
quantity at the above selected level moves into the status.

Shipments: Modifying a Milestone:
About this task

Note: If modifications are made to an existing milestone, the changes are only
applied to new orders. Existing orders for which milestone records have already
been created are not considered.

To modify a milestone:

Procedure
1. In the Monitoring window, choose the Milestones tab.

2. From the Milestones list, locate the applicable milestone and choose the Details
icon. The Milestone Details window displays.

3. Enter information in the applicable fields. Refer to|Table 41| for field level
descriptions.

4. Choose the Save icon.

Shipments: Deleting a Milestone:
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About this task
To delete a milestone:

Procedure
1. From the Monitoring window, choose the Milestones tab.

2. From the Milestones list, locate the applicable milestone and choose the Delete
icon.

Shipments: Defining Monitoring Events

Events are used in instances where the Order Monitor may raise multiple alerts of
the same type. For example, if an order with multiple lines that are shipped
together has a shipment delay and you have configured the Order Monitor to raise
alerts when shipments are delayed at the line level, an alert of the same type
would be raised against each line in the order. You can create rules to aggregate all
of these similar alerts and raise one "root cause".

Shipments: Creating an Event Rule
About this task

To create an event rule:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Monitor Events. The Monitor Events window
displays.

2. From the Monitor Events list, choose the Create New icon. The Monitor Events
Details window displays.

3. Enter information in the applicable fields. Refer to the table that follows for
field level descriptions.

4. Choose the Save icon.

Table 42. Monitor Event Details Pop-Up Window

Field Description

Event Id Enter the event ID.

Description Enter a brief description of the event.

Requires Realert Select this field if you want users to be re-alerted if the issue
has not been resolved within a certain timeframe.

Realert Interval If you selected Requires Realert, enter the interval (in hours)
that re-alerts should be sent.

Automatically Resolve Select this field to automatically remove an alert if the alert

Alerts condition is no longer valid. Once the alert is resolved, a new

alert is raised if the condition is detected again.

Event Identified By

Shipment Select this field if you want two or more alert conditions to
be treated the same if they belong to the same shipment.

Service To Be Invoked Select the alert service to be invoked should the event
consolidation rule conditions be met.

Aggregate And Invoke Service For

Shipment Select this field if you want only one alert to be raised for a
shipment when alert conditions are detected.

Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide



Note: In most cases the attributes that identify an event should be a subset of
the attributes that specify event aggregation.

Shipments: Modifying an Event
About this task

To modify an event rule:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Monitor Events. The Monitor Events window
displays.

2. From the Monitor Events list, select the applicable event rule and choose the
Details icon. The Monitor Event Details window displays.

3. Enter information in the applicable fields. Refer to [Table 42 on page 112| for
field level descriptions.

4. Choose the Save icon.

Shipments: Deleting an Event
About this task

To delete an event rule:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Fulfillment > Monitor Events. The Monitor Events window
displays.

2. From the Monitor Events list, select the applicable event rule and choose the
Delete icon.

Defining Shipment Preferences

Shipment preferences can be created to enable over shipment of products, or allow
the creation of shipments without order information in the system.

Over Shipping Preferences
Over shipment is the ability to ship more than an ordered quantity. Over shipment
tolerance definitions can be configured using the following criteria:

* Line Type

¢ Seller Organization Code

¢ CustomerVendor Classification/BuyerSeller Organization Code

e Jtem Classification/Item ID

During shipment, if a shipping preference has not been configured that matches
the criteria of the shipment line, over shipment is not allowed. Otherwise, over

shipment within the specified percentage is allowed.

Creating a Shipment Preference:
About this task

To create a shipment preference:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipping Preference. The Shipping
Preference Search window displays.

2. In the Shipping Preference window, choose the Over Shipping Preferences tab.
The Shipping Preference Search panel displays.

3. In the Search Results panel, choose the Create New icon. The Shipping
Preference Details pop-up window displays.

4. Enter information into the applicable fields. Refer to the table that follows for
field value descriptions.

5. Choose the Save icon.

Table 43. Shipping Preference Details

Field Description

Line Type Select the line type you want to allow over shipment for.

Item ID Enter the item ID of the item you want to allow over

shipment for, if applicable.

Item Classification Enter the item classification group you want to allow over

shipment for, if applicable. For more information about item
classification, see the Catalog Management: Configuration Guide.

Seller Organization Select the Seller organization that you want to allow to over
ship.
Buyer Organization Select the Buyer organization that you want to be able to

receive over shipments.

Customer Classification Select the customer classification that you want to be able to

receive over shipments, if applicable.

Over Ship Percentage Enter the percentage allowed for over shipment.

Modifying a Shipment Preference:
About this task

To modify a shipment preference:

Procedure

1.

6.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipping Preference. The Shipping
Preference Search window displays.

In the Shipping Preference window, choose the Over Shipping Preferences tab.
The Shipping Preference Search panel displays.

Enter the applicable search criteria and choose the Search icon. A list of
preferences displays.

Select the applicable preference and choose the Details icon. The Shipping
Preference Details pop-up window displays.

Enter information into the applicable fields. Refer to [Table 43 for field value
descriptions.

Choose the Save icon.

Deleting a Shipment Preference:
About this task

To delete a shipment preference:
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Procedure

1.

4.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Inbound Logistics > Shipping Preference. The Shipping
Preference Search window displays.

In the Shipping Preference window, choose the Over Shipping Preferences tab.
The Shipping Preference Search panel displays.

Enter the applicable search criteria and choose the Search icon. A list of
preferences displays.

Select the applicable preference and choose the Delete icon.

Transaction Rules
About this task

Transaction Rules define whether the system allows creation of shipments without
order information on the system.

To define transaction rules:

Procedure

1.

4.

From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Outbound Logistics > Shipping Preference. The Shipping
Preference Search window displays.

In the Shipping Preference Search window, choose the Transaction Rules tab.

Enter information in the applicable fields. Refer to the table that follows for
field level descriptions.

Choose the Save icon.

Table 44. Transaction Rules Tab

Field Description

Order Available On System | Select the appropriate option from the drop-down list to

ensure that the shipments are either created against existing
orders or not. The options are:

* May Be - Select this option if the orders might be available
on the system.

* No - Select this option if the orders are not available on the
system.

* Yes - Select this option if the orders are available on the
system.
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Chapter 16. Configuring an Order Document's
Receipt-Specific Components

Configuring an Order Document's Receipt-Specific Components

To complete an order document's lifecycle, each document has a set of different
processes that it can go through. These processes are called process types. Every
order document has a defined set of process types in Sterling Selling and
Fulfillment Foundation.

The following process types are defined in Sterling Selling and Fulfillment
Foundation for the order document types:

¢ Fulfillment
* Negotiation
¢ Shipment
* Receipt

You can configure the rules and components specific to an order document's
receipt process type.

Receipts: Process Type Pipeline Configuration

A process type pipeline is a series of transactions and statuses that guide
document types, such as a Sales Order, through a predefined process. A pipeline
consists of the different statuses a document goes through during fulfillment,
negotiation, shipment, or receipt. You can also set up transactions consisting of
events, actions, and conditions, as they pertain to the pipeline you are configuring.

Repositories

A repository is a logical collection of entities that define the business process
workflow.

The following entities are included in a repository:
* Pipelines

¢ Transactions

* Statuses

 Conditions

¢ Actions

* Services

Sterling Selling and Fulfillment Foundation provides a base repository for each of
the system-defined process types. Some of the entities within a repository are
copied when creating a new document type. For more information about creating a
new document type, see the Sterling Selling and Fulfillment Foundation: Configuration
Guide.

The process of purchase order receipt is modeled through a pipeline. This
represents the process configuration that is unique to an organization. An
organization may also specify unique processes for each participating Enterprise.
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Receipts: Defining Pipeline Determination

Pipeline determination is used to set up conditions that affect which pipeline is
used during the start of the business process workflow. For example, an
organization deals with sales orders that sometimes contain hazardous materials.
They have two separate pipelines, one in which orders with order lines without
any hazardous materials go through and one in which orders with order lines
containing hazardous materials must go through for inspection before continuing
through the order process. The organization uses pipeline determination to set up
a condition that determines whether or not order lines contain hazardous materials
and sends the order line down the correct pipeline.

When you expand the Pipeline Determination branch, the components displayed
depends on what role you are logged in as. If you are logged in as a Hub role, the
Hub Rule displays. If you are logged in as an Enterprise role, both the Hub Rule
and My Rule components display. Double-click on the applicable node to display
the pipeline determination rules.

Note: If you are logged in as an Enterprise role, the Hub Rule screen is grayed out
and cannot be modified.

Drag conditions and pipelines into the work area to construct pipeline
determination rules. A single pipeline or condition must be the root. Conditions
cannot link back to an earlier component in the chain and a pipeline cannot be
linked to twice.

Note: When configuring pipeline determination for an order document type
pipeline, please note that pipeline determination is only considered when adding a
line or creating an order. When changes are made to draft orders pipeline
determination does not occur.

Receipts: Pipelines
About this task

For more information about configuring pipelines, see the Sterling Selling and
Fulfillment Foundation: Configuration Guide.

To view the purchase order receipt pipeline details:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receipt Process Model. The Purchase Order
Receipt window displays.

2. In the Purchase Order Receipt window, choose Purchase Order Receipt
Repository > Pipelines > Purchase Order Receipt.

3. The Pipeline Detail: Purchase Order Receipt (Purchase Order Receipt) window
displays.

Results

For more information about creating and modifying a pipeline, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.
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Receipts: Transactions
About this task

Every process type has a set of base transactions defined for it. A transaction is a
logical unit of work that is necessary for performing activity within Sterling Selling
and Fulfillment Foundation. Base transactions are predefined transactions that
contain information about how the transaction behaves, such as how many copies
of a transaction can be kept in a process type and whether or not it can have
configurable base pick and drop statuses. Base transactions can be used to create
new transactions. These transactions can be changed within the limits defined in
the base transaction.

For more information about transactions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the transaction details for an purchase order receipt pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receipt Process Model. The Purchase Order
Receipt window displays.

2. In the Purchase Order Receipt window, choose the Transactions icon.

3. The Transactions tab window displays. Refer to the following table for field
value descriptions.
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Results

For more information about creating and modifying transactions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

Table 45. Purchase Order Receipt Pipeline - Transactions Tab Window

Field

Description

Change Receipt

This transaction represents any modifications that may be
made to a purchase order receipt.

Close Pre-Receipt

This transaction represents the completion of the
pre-receiving process.

Inspect

This transaction represents the purchase order receipt being
manually inspected.

Pre-Receive

This transaction represents the pre-receipt of a container. The
contents of the container are not known by the system until
the actual receipt is performed.

Purge Receipt

This transaction represents the process of moving purchase
order receipts to the history tables.

Purge Receipt History

This transaction represents the process of purging purchase
order receipts from the history tables and removing them
from the system.

Receipt Complete

This transaction represents the completion of a receipt.

Receive

This transaction represents the process of receiving a
purchase order receipt.

Start Receipt

This transaction indicates the start of the purchase order
receipt process.

Unreceive

This transaction represents the reversal of any performed
receipt. This is used to correct any receipt that may have been
recorded incorrectly.

Receipts: Statuses

About this task

Statuses are the actual states that a document moves through in the pipeline. A
transaction can contain two types of statuses, a drop status and a pickup status. A
document is moved into a drop status when the events and conditions of a
transaction have been completed. A pickup status takes the document from the
previous drop status and moves it through the next transaction. Created and
Scheduled are examples of statuses.

For more information about statuses, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the status details of a purchase order receipt pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receipt Process Model. The Purchase Order
Receipt window displays.

2. In the Purchase Order Receipt window, choose the Statuses icon.
3. The Statuses tab window displays. Refer to the following table for field value

descriptions.
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Results

For more information about creating and modifying statuses, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.

Table 46. Return Receipt Pipeline - Statuses Tab Window

Field Description
Receipt Started This indicates that a purchase order receipt has started.
Pre-Receipt In Progress This indicates that the purchase order receipt is being

pre-received and cannot continue in the pipeline until
pre-receipt is complete.

Pre-Received This indicates that the purchase order receipt has been
pre-received.

Receipt In Progress This indicates that the purchase order receipt is being
received and cannot continue in the pipeline until marked as
received.

Note: When the purchase order receipt is moved to Receipt
In Progress status, the purchase order is moved to Received
status in the Purchase Order Execution pipeline.

Received This indicates that the purchase order receipt has been
received.

Note: When the purchase order receipt is moved to Received
status, the purchase order is moved to Receipt Closed status
in the Purchase Order Execution pipeline.

Receipts: Conditions
About this task

A condition matches document type attributes against decision points and routes
the documents to different paths based on the specified attribute and value
combinations. The document type attributes against which conditions can be
created are predefined in Sterling Selling and Fulfillment Foundation. You can use
these attributes in any combination or you can create conditions that run the
appropriate application logic for specific circumstances.

For more information about conditions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the condition details of a purchase order receipt pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receipt Process Model. The Purchase Order
Receipt window displays.

2. In the Purchase Order Receipt window, choose the Conditions icon.

3. The Conditions tab window displays. Refer to the following table for field
value descriptions.

Results

For more information about creating and modifying conditions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.
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Table 47. Purchase Order Receipt Pipeline - Conditions Tab Window

Field Description

Conditions Displays conditions that are specific to the purchase order
receipt pipeline, if any.

Receipts: Actions
About this task

An action is a process or program that is triggered by an event. These processes
and programs send user alert notifications and automatically resolve issues.

For example, when an order is released (the event), you can set an action to send
the customer an e-mail.

For more information about actions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the action details of a purchase order receipt pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receipt Process Model. The Purchase Order
Receipt window displays.

2. In the Purchase Order Receipt window, choose the Actions icon.
3. The Actions tab window displays.

Results

For more information about creating and modifying actions, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.

Defining Receipt Preferences

Receipt preferences can be created to enable over receipt of products in the system.
Over receipt is the ability to receive more than an ordered quantity. Over receipt
tolerance definitions can be configured using the following criteria:

* Line Type

¢ Seller Organization Code

* CustomerVendor Classification/BuyerSeller Organization Code

¢ Item Classification/Item ID

During receipt, if a receiving preference has not been configured that matches the
criteria of the receipt line, over receipt is not allowed. Otherwise, over receipt

within the specified percentage is allowed.

Note: IBM recommends that at a minimum you should create a default receiving
preference that can be used across all nodes.

Creating a Receipt Preference
About this task

To create a receipt preference:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Preference. The Receiving Preference
Search window displays.

2. Choose the Create New icon. The Receiving Preference Details pop-up window
displays.

3. Enter information into the applicable fields. Refer to the table that follows for
field value descriptions.

4, Choose the Save icon.

Table 48. Receiving Preference Details

Field Description
Line Type Select the line type you want to allow over receipt for.
Item ID Enter the item ID of the item you want to allow over receipt

for, if applicable.

Item Classification Enter the item classification group you want to allow over
receipt for, if applicable. For more information about item
classification, see the Catalog Management: Configuration Guide.

Seller Organization Select the Seller organization that you want to allow to over
receive.

Buyer Organization Select the Buyer organization that you want to be able to
receive over receipts.

Over Receipt Percentage Enter the percentage allowed for over receipt.

QC Required Select this field if you require a quality control check upon
receipt.

Case Content Entry Select this field if you require the contents of cases to be

Required entered into the system upon receipt.

Modifying a Receipt Preference
About this task

To modify a receipt preference:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Preference. The Receiving Preference
Search window displays.

2. Enter the applicable search criteria and choose the Search icon. A list of
preferences displays.

3. Select the applicable preference and choose the Details icon. The Receiving
Preference Details pop-up window displays.

4. Enter information into the applicable fields. Refer to [Table 48| for field value
descriptions.

5. Choose the Save icon.

Deleting a Receipt Preference
About this task

To delete a receipt preference:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Preference. The Receiving Preference
Search window displays.

2. Enter the applicable search criteria and choose the Search icon. A list of
preferences displays.

3. Select the applicable preference and choose the Delete icon.

Defining Receiving Dispositions
You can define common codes for receiving dispositions used when handling a
receipt. This common code identifies what happens to items for the document type
when they are received.

Creating a Receiving Disposition
About this task

To create a receiving disposition:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Disposition. The Return Disposition
window displays.

2. Choose the Create New icon. The Receiving Disposition Details pop-up
window displays.

3. Enter information into the applicable fields. Refer to the table that follows for
field value descriptions.

4. Choose the Save icon.

Table 49. Receiving Disposition Details

Field Description

Receiving Disposition Enter the name of the receiving disposition.

Short Description Enter a brief description of the receiving disposition.
Product Class Select a product class to associate with received items, if

applicable. For example, by you could assign the product
class of Returned to any returned items.

Damaged Select Damaged if the receiving disposition is used for
handling damaged items.

Final Disposition Select Final Disposition if the receiving disposition is to be
used as final disposition for the receipt.

Final Disposition marks the disposition code as final, and
does not allow any further disposition transitions.

Disposition Transitions This displays the existing Receiving Disposition codes that
are available for associating a transition with the Receiving
Disposition being created or modified.

Receiving Disposition Existing Receiving Disposition Code available for transition
association.

Modifying a Receiving Disposition
About this task

To modify a receiving disposition:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Disposition. The Return Disposition
window displays.

2. Select the applicable receiving disposition and choose the Details icon. The
Receiving Disposition Details pop-up window displays.

3. Enter information into the applicable fields. Refer to [Table 49 on page 124 for
field value descriptions.

4, Choose the Save icon.

Deleting a Receiving Disposition
About this task

To delete a receiving disposition:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Disposition. The Return Disposition
window displays.

2. Select the applicable receiving disposition and choose the Delete icon.

Defining Receiving Discrepancy Reasons

You can define codes to specify reasons for any discrepancies that may occur
during the receipt of a shipment or return.

The different types of receiving discrepancies that occur are:

* Over Receipt—Occurs when a receiving node receives additional quantity than
the quantity expected.

* Under Receipt—Occurs when a receiving node receives less than the expected
quantity for the receipt.

* Damaged Receipt—Occurs when the receiving disposition code indicates that a
damaged product has been received.

Note: You can define multiple reason codes for a given discrepancy type. For
example, if you receive any shipment with a quantity of 10, which is less than
the expected quantity, then for the Under Receipt discrepancy type, you can
specify two different reasons for the receipt, such as 6 units SHORT_SHIPMENT
and 4 units CARRIER_FAULT.

Creating a Receiving Discrepancy Reason
About this task

To create a receiving discrepancy reason:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Discrepancy Reasons. The Receiving
Discrepancy Reasons window displays.

2. Choose the Create New icon. The Receiving Discrepancy Reason Details
pop-up window displays.

3. Enter information in the applicable fields. For field value descriptions, see the
table that follows.
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4. Choose the Save icon.

Table 50. Receiving Discrepancy Reason Details

Fields

Description

Discrepancy Reason Code

Enter the name of the discrepancy reason code as you want it
to appear throughout the system.

Discrepancy Reason
Description

Enter a brief description of the discrepancy reason.

Discrepancy Reference

Enter any additional reference information according to your
business practices.

Discrepancy Type Group

Over Receipt

Choose this option if you want the discrepancy reason to
identify scenarios in which a receiving node receives more
than the expected quantity.

Under Receipt

Choose this option if you want the discrepancy reason to
identify scenarios in which a receiving node receives less than
the expected quantity.

Damaged Receipt

Choose this option to identify scenarios in which a receiving
node receives items with a receiving disposition identifying
them as damaged.

Requires Invoice
Adjustment

Check this box if a monetary adjustment need to be made
when a receipt discrepancy is associated with the discrepancy
reason.

Invoice Adjustment Type G

roup

Credit

Choose this option if the adjustment amount results in a
credit invoice.

Debit

Choose this option if the adjustment amount results in a debit
invoice.

Invoice Line Reference

If you select the Requires Invoice Adjustment option, you
must enter a name for the adjustment. This name can be used
when multiple adjustment invoices are created for the same
order line. In such situations, the invoices are split into
different invoice lines only if the invoices have different
invoice line references.

Modifying a Receiving Discrepancy Reason

About this task

To modify a receiving discrepancy reason:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Discrepancy Reasons. The Receiving
Discrepancy Reasons window displays.

2. Select the receiving discrepancy reason and choose the Details icon. The

Receiving Discrepancy

Reason Details pop-up window displays.

3. Enter information in the applicable fields. For field value descriptions, see

[Table 53

4. Choose the Save icon.
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Deleting a Receiving Discrepancy Reason
About this task

To delete a receiving discrepancy reason:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Receipt > Receiving Discrepancy Reasons. The Receiving
Discrepancy Reasons window displays.

2. Select the receiving discrepancy reason and choose the Delete icon.
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Chapter 17. Configuring an Order Document's
Negotiation-Specific Components

Configuring an Order Document's Negotiation-Specific Components

Note: Be aware that return fulfillment requires sourcing configuration. Sourcing
configuration is accessible through the Distributed Order Management
configuration grouping. For more information about configuring sourcing, see the
Sterling Selling and Fulfillment Foundation: Distributed Order Management
Configuration Guide.

To complete an order document's lifecycle, each document has a set of different
processes that it can go through. These processes are called process types. Every
order document has a defined set of process types in Sterling Selling and
Fulfillment Foundation.

The following process types are defined in Sterling Selling and Fulfillment
Foundation for the order document types:

* Fulfillment
* Negotiation
* Shipment
* Receipt

* Receipt

You can configure the rules and components specific to an order document's
negotiation process type.

Negotiation: Process Type Pipeline Configuration

A process type pipeline is a series of transactions and statuses that guide
document types, such as a Sales Order, through a predefined process. A pipeline
consists of the different statuses a document goes through during fulfillment,
negotiation, shipment, or receipt. You can also set up transactions consisting of
events, actions, and conditions, as they pertain to the pipeline you are configuring.

Repositories

A repository is a logical collection of entities that define the business process
workflow.

The following entities are included in a repository:
* Pipelines

¢ Transactions

* Statuses

 Conditions

* Actions

e Services

Sterling Selling and Fulfillment Foundation provides a base repository for each of
the system-defined process types. Some of the entities within a repository are
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copied when creating a new document type. For more information about creating a
new document type, see the Sterling Selling and Fulfillment Foundation: Confiquration
Guide.

The process of negotiation is modeled through a pipeline. This represents the
process configuration that is unique to an organization. An organization may also
specify unique processes for each participating Enterprise.

Negotiation: Defining Pipeline Determination

Pipeline determination is used to set up conditions that affect which pipeline is
used during the start of the business process workflow. For example, an
organization deals with sales orders that sometimes contain hazardous materials.
They have two separate pipelines, one in which orders with order lines without
any hazardous materials go through and one in which orders with order lines
containing hazardous materials must go through for inspection before continuing
through the order process. The organization uses pipeline determination to set up
a condition that determines whether or not order lines contain hazardous materials
and sends the order line down the correct pipeline.

When you expand the Pipeline Determination branch, the components displayed
depends on what role you are logged in as. If you are logged in as a Hub role, the
Hub Rule displays. If you are logged in as an Enterprise role, both the Hub Rule
and My Rule components display. Double-click on the applicable node to display
the pipeline determination rules.

Note: If you are logged in as an Enterprise role, the Hub Rule screen is grayed out
and cannot be modified.

Drag conditions and pipelines into the work area to construct pipeline
determination rules. A single pipeline or condition must be the root. Conditions
cannot link back to an earlier component in the chain and a pipeline cannot be
linked to twice.

Note: When configuring pipeline determination for an order document type
pipeline, please note that pipeline determination is only considered when adding a
line or creating an order. When changes are made to draft orders pipeline
determination does not occur.

Negotiation: Pipelines
About this task

For more information about configuring pipelines, see the Sterling Selling and
Fulfillment Foundation: Configuration Guide.

To view the negotiation pipeline details,

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Negotiation > Negotiation Process Model. The Purchase
Order Negotiation window displays.

2. In the Purchase Order Negotiation window, choose Purchase Order Negotiation
Repository > Pipelines > Purchase Order Negotiation.

3. The Pipeline Detail: Purchase Order Negotiation (Purchase Order Negotiation)
window displays.
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Results

For more information about creating and modifying a pipeline, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.
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Negotiation: Transactions
About this task

Every process type has a set of base transactions defined for it. A transaction is a
logical unit of work that is necessary for performing activity within Sterling Selling
and Fulfillment Foundation. Base transactions are predefined transactions that
contain information about how the transaction behaves, such as how many copies
of a transaction can be kept in a process type and whether or not it can have
configurable base pick and drop statuses. Base transactions can be used to create
new transactions. These transactions can be changed within the limits defined in
the base transaction.

For more information about transactions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the transaction details for a negotiation pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Negotiation > Negotiation Process Model. The Purchase
Order Negotiation window displays.

2. In the Purchase Order Negotiation window, choose the Transactions icon.

3. The Transactions tab window displays. Refer to the following table for field
value descriptions.
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Results

For more information about creating and modifying transactions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

Table 51. Negotiation Pipeline - Transactions Tab Window

Field

Description

Create Initiator Response

This transaction represents the creation of a negotiation
response from the initiating organization.

Create Negotiation

This transaction represents a the creation of a negotiation for
a purchase order.

Create Negotiator Response

This transaction represents the creation of a negotiation
response from the negotiating organization.

Modify Negotiation

This transaction represents any modifications made to a
negotiation.

Negotiation Monitor

This transaction represents the process of monitoring
negotiations in the system based on defined parameters.

Publish Negotiation

This transaction represents the process of publishing the
negotiated terms to an order.

Purge Negotiation

This transaction represents the process of moving negotiations
to the history tables.

Purge Negotiation History

This transaction represents the process of purging
negotiations from the history tables and removing them from
the system.

Synchronize Task Queue

This transaction represents the process of synchronizing the
negotiation fulfillment task queue.

Negotiation: Statuses

About this task

Statuses are the actual states that a document moves through in the pipeline. A
transaction can contain two types of statuses, a drop status and a pickup status. A
document is moved into a drop status when the events and conditions of a
transaction have been completed. A pickup status takes the document from the
previous drop status and moves it through the next transaction. Created and
Scheduled are examples of statuses.

For more information about statuses, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the status details of a negotiation pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Negotiation > Negotiation Process Model. The Purchase
Order Negotiation window displays.

2. In the Purchase Order Negotiation window, choose the Statuses icon.

3. The Statuses tab window displays. Refer to the following table for field value

descriptions.
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Results

For more information about creating and modifying statuses, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.

Table 52. Negotiation Pipeline - Statuses Tab Window

Field Description

Offered This indicates that a set of negotiation terms have been
offered.

Counter Offered This indicates that a revised set of negotiation terms have
been counter offered.

Completed This indicates that the terms of the negotiation have been
agreed upon and are ready to be published to the order.

Published This indicates that the negotiation results have been
published to the order.

Expired This indicates that the negotiation terms were never agreed
upon.

Negotiation: Conditions
About this task

A condition matches document type attributes against decision points and routes
the documents to different paths based on the specified attribute and value
combinations. The document type attributes against which conditions can be
created are predefined in Sterling Selling and Fulfillment Foundation. You can use
these attributes in any combination or you can create conditions that run the
appropriate application logic for specific circumstances.

For more information about conditions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the condition details of a negotiation pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Negotiation > Negotiation Process Model. The Purchase
Order Negotiation window displays.

2. In the Purchase Order Negotiation window, choose the Conditions icon.

3. The Conditions tab window displays. Refer to the following table for field
value descriptions.

Results

For more information about creating and modifying conditions, see the Sterling
Selling and Fulfillment Foundation: Configuration Guide.

Table 53. Negotiation Pipeline - Conditions Tab Window

Field Description

Conditions Displays conditions that are specific to the negotiation
pipeline, if any.
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Negotiation: Actions
About this task

An action is a process or program that is triggered by an event. These processes
and programs send user alert notifications and automatically resolve issues.

For example, when an order is released (the event), you can set an action to send
the customer an e-mail.

For more information about actions, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

To view the action details of an outbound shipment pipeline:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Negotiation > Negotiation Process Model. The Purchase
Order Negotiation window displays.

2. In the Purchase Order Negotiation window, choose the Actions icon.
3. The Actions tab window displays.

Results

For more information about creating and modifying actions, see the Sterling Selling
and Fulfillment Foundation: Configuration Guide.
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Chapter 18. Configuring a Document's Financial Components

Configuring a Document’s Financial Components

You can define rules and common codes as they pertain to payments and charges
for a given order document.

Defining Payment Terms

You can define common codes for payment terms that you may have with your
customers. These terms are predefined methods of payment.

Creating a Payment Term
About this task

To create a payment term:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Payment Terms. The Payment Terms window
displays in the work area.

2. Choose the Create New icon. The Payment Term Details pop-up window
displays.
In Payment Term, enter the name of the payment term.

In Short Description, enter a brief description of the payment term.

IS

In Long Description, enter a more detailed description of the payment term.
6. Choose the Save icon.

Modifying a Payment Term
About this task

To modify a payment term:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Payment Terms. The Payment Terms window
displays in the work area.

2. Select the applicable payment term and choose the Details icon. The Payment
Term Details pop-up window displays.

3. In Short Description, enter a brief description of the payment term.
4. In Long Description, enter a more detailed description of the payment term.

5. Choose the Save icon.

Deleting a Payment Term
About this task

To delete a payment term:
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Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Payment Terms. The Payment Terms window
displays in the work area.

2. Select the applicable payment term and choose the Delete icon.

Defining Charge Definitions

You can define charge definitions that you can associate with orders and invoices
by creating charge categories. These categories contain a group of related charge
names that can be used when the particular category is used. When adding a
charge to an order header or an order line, you must use the charge categories that
you have defined here. The charge name that is used on the order header or on the
order line may or may not be defined, depending on the Validate Charge Name
rule in the additional payment rules. For more information on this rule, refer to
[“Defining Additional Payment Rules” on page 139

Following are the Sterling Selling and Fulfillment Foundation default charge
definitions:

* Shipping
¢ Handling
e Personalization

¢ Discount

Note: The default charge definitions are only available to the Hub organization
at the time of installation. Any Enterprises that are created must create their own
charge definitions.

Creating a Charge Category
About this task

To create a charge category:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Financial Attributes. The Financial Attributes
window displays in the work area.

Choose the Charge Definitions tab.

Choose the Create New icon. The Charge Category Details window displays.
In Charge Category, enter the name of the charge category.

In Description, enter a brief description of the charge category.

o ok wDn

Select Billable if the charge is billable. Non-billable charges are not considered
in order totals, but do appear in invoices.

7. Select Is Fee (or Discount if applied to a pickup request) if the charge you are
creating is a discount charge type.

8. Select Consider For Profit Margin Total if the category should be used for profit
margin calculation.

9. Choose the Save icon.

Note: Charge categories cannot be localized. For more information about
localization, see the Sterling Selling and Fulfillment Foundation: Localization Guide.

Adding a Charge Name Associated with a Charge Category:
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About this task
Charge names are names of the actual charges included in the charge definition.

Note: IBM recommends that you clearly specify between order charges and
discount charges when naming a charge. In the Application Consoles both order
charges and discount charges appear on the same screens and drop-down menu.
There is no way for the user to distinguish which is an order charge and which is
a discount charge other than its naming convention.

To add a charge name to a charge category:

Procedure

1. In the Charge Category Details window, choose the Create New icon. The
Charge Name Details pop-up window displays.

2. In Charge Name, enter the charge name.

w

In Description, enter a brief description of the charge name.
4. Choose the Save icon.

Note: Charge names cannot be localized. For more information about
localization, see the Sterling Selling and Fulfillment Foundation: Localization Guide.

Modifying a Charge Name Associated with a Charge Category:
About this task

To modify a charge category's charge name:

Procedure

1. In the Charge Category Details window, select the applicable charge name and
choose the Details icon. The Charge Name Details pop-up window displays.

2. In Description, enter a brief description of the charge name.
3. Choose the Save icon.

Deleting a Charge Name Associated with a Charge Category:
About this task

To delete a charge category's charge name select the applicable charge name in the
Charge Category Details window and choose the Delete icon.

Modifying a Charge Category
About this task

To modify a charge category:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Financial Attributes. The Financial window
displays in the work area.

2. Choose the Charge Definitions tab.

3. Select the applicable charge category and choose the Details icon. The Charge
Category Details window displays.

4. In Description, enter a brief description of the charge category.
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5. Select Billable if the charge is billable. Non-billable charges are not considered
in order totals, but do appear in invoices.

6. Select Discount if the charge you are creating is a discount charge type.

7. Select Consider For Profit Margin Total if the category should be used for profit
margin calculation.

8. Choose the Save icon.

Deleting a Charge Category
About this task

To delete a charge definition:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Financial Attributes. The Financial window
displays in the work area.

2. Choose the Charge Definitions tab.
3. Select the applicable charge category and choose the Delete icon.

Defining Tax Names

You can define common codes for tax names. Tax names are any specific taxes that
may pertain to orders and invoices.

Sterling Selling and Fulfillment Foundation understands three different types of
taxes: a tax against a price, against a charge, or a flat tax.

* A tax against a price is an additional cost for a percentage of the price of the
order line.

* A tax against a charge is an additional cost for a percentage of an existing charge
on the order header, or order line. When adding a tax against a charge, the
charge category must be one that already exists on the order header, or on the
order line.

* A flat tax is a fixed tax applied on an order, independently of any charge, or
price.

Creating a Tax Name
About this task

To create a tax name:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Financial Attributes. The Financial window
displays in the work area.

Choose the Tax Names tab.

Choose the Create New icon. The Tax Name Details pop-up window displays.
In Tax Name, enter the name of the tax name.

In Short Description, enter a brief description of the tax name.

In Long Description, enter a more detailed description of the tax name.

No ok

Choose the Save icon.
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Modifying a Tax Name
About this task

To modify a tax name:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Financial Attributes. The Financial window
displays in the work area.

2. Choose the Tax Names tab.

3. Select the applicable tax name and choose the Details icon. The Tax Name
Details pop-up window displays.

4. In Short Description, enter a brief description of the tax name.

5. In Long Description, enter a more detailed description of the tax name.

6. Choose the Save icon.

Deleting a Tax Name
About this task

To delete a tax name:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Financial Attributes. The Financial window
displays in the work area.

2. Choose the Tax Names tab.
3. Select the applicable tax name and choose the Delete icon.

Defining Additional Payment Rules
About this task

You can set up payment collection rules that are used when an order is sent for
payment authorization.

To define additional payment rules:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Financials > Financial Attributes. The Financial window
displays in the work area.

2. Choose the Others tab.

3. Enter information in the applicable fields. Refer to[Table 54 on page 140| for
field value descriptions.

4. Choose the Save icon.
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Results
Table 54. Financial Window, Others Tab

Field

Description

Validate Charge Name

Select this field to indicate that the system is
to check that the charge names used for an
order document are valid before proceeding
with payment collection.

Create Invoice Before Order or Shipment

Select this option if you want to be able to
create an info invoice before an order of a
shipment.

Create Shipment Invoice for Bundle Parent
On Invoicing Of

Select the option which describes when you
would like to create the shipment invoice
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Chapter 19. Configuring a Document's Purge Criteria

Purge Criteria business rules are used to define qualifications around each type of
purge. Purges are the process by which old data is removed from the system
database. Purges minimize the number of unused database records to increase
search efficiency and reduce the size of the required physical disk. In Purge
Criteria Rules, default purge rules are provided. These can be modified for your
system operations.

able 55 lists the purge rules provided for order document ty es in Sterling Sellin
and Fulfillment Foundation.

Table 55. Order Document Type Purge Rules

Default
Rule Description Retention Days
PRG_SHIP_STATS Purges shipment statistics and 30
archives them in the history
tables.
STATUSAUDITPRG Purges order age alerts (if you 30
have configured the system to
trigger alerts when the order
document type stays in a
particular status for a specified
time period).
NEGOTIATIONPRG Purges negotiation information 30
and archives it in the history
tables.
NEGOTIATIONHISTPRG Purges negotiation information 30
from the negotiation history
tables.
RECEIPTPRG Purges receipt information and 30
archives it in the history tables.
RECEIPTHISTPRG Purges receipt information from 30
the receipt history tables.
ORDERHISTPRG Purges order information from the | 30
order history tables.
ORDERPRG Purges order information and 30
archives it in the history tables.
ORDER_RELEASE_STATUS_PURGE | Purges order release status 30
records with a quantity of 0.
PICKLISTPRG Purges pick list information. 30
SHIPMENTHISTPRG Purges shipment information from | 30
the shipment history tables.
SHIPMENTPRG Purges shipment information and |30
archives it in the history tables.
DRAFTORDERNOLINEPRG Purges draft orders that do not 30
have any order lines.
DRAFTORDERNOLINEHISTPRG Purges draft orders without any |30
order lines from the history table.
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Table 55. Order Document Type Purge Rules (continued)

Default

Rule Description Retention Days
DRAFTORDERHISTPRG Purges draft order information 30

from the draft order history

tables.
DRAFTORDERPRG Purges draft order information 30

and archives it in the history

tables.

lists the purge rules provided for the opportunity document type in
Sterling Selling and Fulfillment Foundation.

Table 56. Opportunity Document Type Purge Rules

Default
Retention
Rule Description Days
OPPORTUNITYPRG Purges opportunity information and archives |30
it in the history tables.
OPPORTUNITYHISTPRG | Purges opportunity information from the 30

opportunity history tables.

Modifying an Order Document Type's Purge Criteria Rule

About this task

To modify an order document type's purge criteria rule:

Procedure

1. From the tree in the application rules side panel, choose Document Specific >
(Document Type) > Purge Criteria. The Purge Criteria List window displays in

the work area.

2. Enter information in the applicable fields. Refer to|Table 57| for field value

descriptions.

3. Choose the Save icon.

Table 57. Purge Criteria Details Pop-up Window

Field Description
Purge Code Identifies a purge program. This is a system defined code.
Description Describes the type of purge.

Rollback Segment

Defines the rollback segment that should be explicitly used
for the purge transaction qualified by the purge code. This is
useful when there are huge logical data sets that have to be
purged. This is optional and used for order related purges.

Retention Days

Enter the number of days the data is to be retained in the
database (going backwards from the time the program runs).
Make sure that your table size takes into account the number
of retention days entered here.

Write to Log File

Check this box if you want purged data written to a log file.
The log file can be backed up and used as a journal at a later
date.
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Table 57. Purge Criteria Details Pop-up Window (continued)

Field

Description

Log File Name

Enter a log file name. The log file is created in the directory
specified in the yfs.purge.path property. If this is not passed,
it defaults to the value specified in the yfs.properties file. If
a variable is introduced, then the yfs.purge.path is ignored.

To override this property, add an entry for it in the
<INSTALL_DIR>/properties/customer_overrides.properties
file. For additional information about overriding properties
using the customer_overrides.properties file, see the Sterling
Selling and Fulfillment Foundation: Properties Guide.

For more information about using variables for the log file
directory, see the Sterling Selling and Fulfillment Foundation:
Extending the Condition Builder.

For information about filename limitations related to
internationalization, see the Sterling Selling and Fulfillment
Foundation: Localization Guide.

Additional Purge Criteria

and document type levels.

(ORDHISTPRG) criteria.

These parameters are used to override the order history purge retention days. This
override is configured based on the line types within each order defined at the enterprise

Note: These additional parameters can be defined only for order history purge

Line Type

Select the line types from the drop-down list. For more
information about defining line types, see the Sterling Selling
and Fulfillment Foundation: Distributed Order Management
Configuration Guide.

Additional Retention Days

Enter the additional number of days (apart from the retention
days specified by the order history purge) the data is to be
retained in the database. Make sure that your table size takes
into account the number of retention days entered here.
Note: To be considered for additional retention days, the
order line must have at least some quantity that is not
cancelled or shorted.

Note: The history purge date cannot be reset when you restore the order after
it was purged. For example, if an order is purged with a history purge date of
20070801 and when the order is restored in the year 2006, the history purge
date still remains as 20070801.

Results

The following example provides an use-case of the line type purge in an order

placement scenario:

An order is placed with the following 4 order lines:

e Order Line 1 - Television

* Order Line 2 - 2 year Television service plan with Line Type as
2YR_WARRANTY. Therefore, the additional retention days are 721.

e Order Line 3 - Stereo

* Order Line 4 - 4 year Stereo service plan with Line Type as 4YR_WARRANTY.
Therefore, the additional retention days are 1451.
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Assume that the order is set to be purged after 30 days. On day 1, the order moves
into a purgeable status. On day 30, the order is purged to the history table. The
purge history date is set as:

Today + 10 + Maximum(721, 1491) = 1491 days, where 10 is the number of
retention days for the history purge.

On day 40, the history purge agent does not pick up this order to purge, since the
purge history date is set. Rather, the order is purged from the history on day 1491.

144 Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide



Chapter 20. Time-Triggered Transaction Reference

Time-Triggered Transaction Reference

Sterling Selling and Fulfillment Foundation provides a collection of time-triggered
transactions, which are utilities that perform a variety of individual functions,
automatically and at specific time intervals.

Time-triggered transactions perform repetitive actions on a scheduled basis,
typically performing database updates, raising events, or calling APIs. One type of
transaction, monitors, are designed to watch for processes or circumstances that are
out of bounds and then raise alerts. Often, but not always, they retrieve tasks from
the task queue or work from the pipeline.

Some transactions enable you to collect statistical data regarding the application's
health. This data is collected periodically, using the value specified for the
yantra.statistics.persist.interval attribute in the yfs.properties file. By
default, statistics collection set to on. To override this property, add an entry in the
<INSTALL DIR>/properties/customer overrides.properties file. For additional
information about overriding properties using the customer_overrides.properties
file, see the Sterling Selling and Fulfillment Foundation: Properties Guide.

For more information about statistics persistence, see the Sterling Selling and
Fulfillment Foundation: Performance Management Guide. For more information about
the specific statistics parameters used, see the applicable time-triggered
transactions.

The time-triggered transactions described in this chapter are unique transactions,
that may or may not be document type specific. For document specific
transactions, the nomenclature helps define which unique transaction it is based
on: a transaction ID is in the format Unique_Transaction_ID.Document_Type_Code.
For example, the transaction ID for Purge Return is PURGE.0003, indicating that it is
based on the unique transaction PURGE, for document type 0003, which is Return
Order. Therefore, in order to be able to configure Purge Return, you should look
for the PURGE transaction ID in this chapter, which is Order Purge.

Sterling Selling and Fulfillment Foundation provides the following types of
time-triggered transactions:

* [Business Process Time-Triggered Transactions|- responsible for processing

* |Time-Triggered Purge Transactiong - clear out data that may be discarded after
having been processed

Task Queue Syncher Time-Triggered Transactions|- update the task queue
repository with the latest list of open tasks to be performed by each transaction,
based on the latest pipeline configuration

. - watch and send alerts for processing delays and exceptions

Sterling Selling and Fulfillment Foundation tracks the following statistics for each
time-triggered transaction:

* ExecuteMessageCreated - The number of jobs added to the JMS queue in a given
time interval.

* ExecuteMessageSuccess - The number of jobs that were run successfully in a
given time interval.
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* ExecuteMessageError - The number of jobs that failed to run in a given time
interval.

* GetJobsProcessed - The number of GetJob messages that were processed in a
given time interval.

Note: Some of the statistics collected and tracked in Release 9.1 for
time-triggered transactions, monitors, and integration and application servers
may change with the next release of Sterling Selling and Fulfillment Foundation.

Running Time-Triggered Transactions

All time-triggered transactions are threadable. This means that you can run
multiple instances of a transaction within a single process. For more information
about running time-triggered transactions, see the Sterling Selling and Fulfillment
Foundation: Installation Guide. For more information about fine-tuning system
performance while running them concurrently, see the Sterling Selling and
Fulfillment Foundation: Performance Management Guide.

Steps to Complete Before Scheduling Time-Triggered
Transactions
About this task

Before running and scheduling a time-triggered transaction, ensure that you have
completed the following;:

Procedure

1. Configure a JMS Connection Factory to correlate with the QCF name
configured for the time-triggered transaction. The Sterling Selling and
Fulfillment Foundation factory defaults include the AGENT_QCF as the JMS
Connection Factory. For more information about configuring JMS, see the
documentation for your specific application server.

2. Configure JMS Server Destinations to correlate with the group or individual
name of the time-triggered transaction. The Sterling Selling and Fulfillment
Foundation factory defaults include the DefaultAgentQueue as the server
destination.

Do not put a dot (.) in the name of a JMS Server Destination, for
example,'A.0001". If you do, Sterling Selling and Fulfillment Foundation is
unable to communicate with it.

3. Using the Applications Manager, configure each time-triggered transaction
required for your business process as described in the section entitled "Defining
Transactions” in the Sterling Selling and Fulfillment Foundation: Configuration
Guide. Each set of time-triggered transaction criteria parameters must ensure
the appropriate association of a JMS Agent Server.

Configuring Communication Between an Agent and a JMS Server
About this task
Setting up communication between an agent (time-triggered transaction) and a
remote JMS server requires that you do some prerequisite setup on your JMS

system, then do some configuration within the application, which consists of the
following procedures:
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* If an initial context factory code for your JMS system is not provided with the
application, you must create one. See |“Create an Initial Context Factory Code’]
for the list of codes that are provided.

* Defining the transaction details — the time-triggered transaction, or agent, must
be edited to include connection information for yvour JMS system and the initial
context factory you create. See[“Define the Transaction Information” on page]
[148]

For more information about time-triggered transactions and how they fit into the
larger picture of application business process modeling, see the Configuring Process
Models chapter. Also see the Configuring Alert Queues chapter for additional
information about queues and agents.

Prerequisites
About this task

Before starting, complete these tasks for your JMS Server. See your JMS Server
documentation for more information about performing these tasks.

Procedure
1. Configure the J]MS Queue Connection Factory (QCF) and queues on your JMS
server.

2. Configure the JNDI representation of the queues on your JMS server.
Ensure that you have the following information available from these tasks:
¢ JNDI name for each queue
* JNDI QCF lookup
* JMS location - the provider URL for the JMS server

Results

Once you have completed the preceding tasks, complete the next two procedures
in the order shown. These are both done in the application.

Create an Initial Context Factory Code
About this task

Using an Initial Context Factory (ICF) class enables remote Java clients to connect
to your application. This class is provided by the application vendor. The
application uses ICF codes to identify these when setting up agents. Initial context
factory codes are predefined in the application for the following JMS vendors:

« IBM WebSphere® MQ (for MQSeries® accessed through a IBM WebSphere
Internet Inter-ORB Protocol URL)

* File (for MQSeries accessed through a file URL, as with Oracle WebLogic)
* Oracle WebLogic (for WebLogic JMS)
* JBoss (for JBoss JMS)

If you are using a JMS server that is not in the preceding list (for example,
ActiveMQ), you must create an initial context factory code for it in the application:
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Procedure
1.

Open the Applications Manager. From the tree in the application rules side
panel, choose System Administration > Initial Context Factory Codes. The
Initial Context Factory Codes window displays in the work area.

2. Select the + icon to create a new initial context factory code. The Initial Context
Factory window is displayed.

3. In the Initial Context Factory field, enter the name of the class provided by
your JMS vendor. For example, for ActiveMQ, the class name is
org.apache.activemq.jndi. ActiveMQInitial ContextFactory.

4. In the Short Description field, enter a descriptive name, up to 40 characters.
Make note of this name, because you will use it in the next procedure (see
|”Define the Transaction Information”b. For ActiveMQ, enter ActiveMQ.

5. In the Long Description field, enter a more detailed description for the initial
context factory, up to 100 characters.

6. Save the new initial context factory code and close the window.

Results

For more information about ICFs, see Creating an Initial Context Factory Code.

Define the Transaction Information
About this task

For the JMS server to communicate with the application, there must be a
time-triggered transaction configured with the JMS server and ICF information.

Procedure

1

1

1

1.

ook w

0.

1.

2.

Open the Applications Manager. From the tree in the application rules side
panel, double-click Process Modeling. The Process Modeling window displays
in the work area.

Select the desired tab, then Base Document Type, then double-click Process
Type.

Double-click the transaction that corresponds to the agent to be run.

Select the Time Triggered tab.

Create or select an existing Agent Criteria Definition to edit.

The Agent Criteria Details screen is displayed. Select the Runtime Properties
tab.

Select an existing Agent Server from the list or create your own
(recommended).

Select an existing Alert Queue from the list or create your own.

In the JMS Queue Name field, enter the J]NDI name for the queue that you
created. See [“Prerequisites” on page 147

Enter the desired number of threads the agent should run (recommended not
to exceed 5 threads - if more than 5 are needed, start another agent in its own
JVM).

Select the Initial Context Factory code you created. See [‘Create an Initial|
[Context Factory Code” on page 147

In the QCF Lookup field, enter the JNDI QCF lookup for the queue that you
created (this is the Queue Connection Factory created for the applicable JMS
Server). See [‘Prerequisites” on page 147.|
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13. Enter the Provider URL. This is the location where the JMS system resides,
and is JMS vendor specific.

14. Select whether the agent should trigger itself (recommended) and at what
interval (in minutes) or use an external trigger (triggeragent.sh in the
<install_dir>/install /bin directory).

15. See Setting up the JMS Security Properties for information about setting the
JMS Security option.

16. Leave the Criteria Parameters tab values at the default values.
17. Save the Agent Criteria Details and close the window.

18. Launch the agent in its own JVM by executing the startagentserver.sh/cmd
script in the <install_dir>/install/bin directory.

Results
For additional information about defining transactions and about this procedure,

see the sections Defining Transactions and Specifying a Transaction as Time-Triggered in
the Sterling Selling and Fulfillment Foundation: Configuration Guide.

Business Process Time-Triggered Transactions

All Business Process Time-Triggered Transactions have a CollectPendingJobs
criteria parameter. If this parameter is set to N, the agent does not collect
information about the pending jobs pertaining to this monitor. This pending job
information is used for monitoring the monitor in the System Management
Console.

By default, CollectPendingJobs is set to Y. It can be helpful to set it to N if one
particular time-triggered transaction is performing a significant amount of
getPendingJobs queries, and the overhead cost is too high.

Asynchronous Request Processor

This transaction completes any API request or service request in offline mode. It
picks up the API messages or service messages from the YFS_ASYNC_REQ table
and invokes the corresponding API or service. The messages can be inserted into
the YFS_ASYNC_REQ table using the createAsyncRequest APL

Attributes

Following are the attributes for this time-triggered transaction:

Table 58. Asynchronous Request Processor Attributes

Attribute Value

Base Transaction ID ASYNC_REQ_PROCESSOR
Base Process Type General

Abstract Transaction No
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Criteria Parameters

Following are the criteria parameters for this transaction:

Table 59. Asynchronous Request Processor Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Lead Days Number of days before the present date the agent will purge
the records. If left blank or specified as 0 (zero), it defaults to
30.

Maximum Error Count Maximum number of times the record is processed if an

exception is thrown. Once the number of unsuccessful
attempts equals this number, that record is not processed
further by the agent. If left blank or specified as 0 (zero), it
defaults to 20.

Reprocess Interval In Time in minutes after which the transaction will be

Minutes reprocessed - after it has been processed and has thrown an
exception.

ColonyID Required in a multischema deployment where the

YFS_ASYNC_REQ table may exist in multiple schemas. Runs
the agent for the colony.

Statistics Tracked
None

Pending Job Count
None

Events Raised

The following events are raised by this time-triggered transaction:

Table 60. Events Raised by the Asynchronous Request Processor

Template
Transaction/Event Key Data Data Published* Support?
HAS_EXCEPTIONS None YCP_ASYNC_REQ _ Yes
PROCESSOR.HAS _
EXCEPTIONS.html

*These files are located in the following directory:

<INSTALL_DIR>/xapidocs/api_javadocs/XSD/HTML

Case Insensitive Data Loader

The Case Insensitive Data Loader agent migrates data from columns marked
CaselnsensitiveSearch to shadow columns. The agent uses the transaction criteria
to identify the records that need to be updated and then converts the original
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column values to lowercase values in the shadow columns. For more information
about enabling case insensitive searches, refer to the Sterling Selling and Fulfillment
Foundation: Extending the Database.

The Case Insensitive Data Loader agent is required for updating the existing data.
Once the shadow columns have been created, the Case Insensitive Data Loader
agent only needs to be run once for each table or table type. The shadow columns
are then populated in real-time by the application.

Attributes

The following are the attributes for this time-triggered transaction:

Table 61. Case Insensitive Data Loader Attributes

Attribute Value

Base Transaction ID DATA_LOADER
Base Document Type General

Base Process Type General
Abstract Transaction No

APIs Called None

User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 62. Case Insensitive Data Loader Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one

time.

e If left blank or the number specified is less than 10000, it
defaults to 5000.

e If the number specified is greater than 10000, then that
value is used.

CollectPendingJobs

If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

TableType

Required in a multischema deployment when a table may
exist in multiple schemas.

Valid Values: CONFIGURATION, TRANSACTION, MASTER.

If set to CONFIGURATION, the agent runs for the records
associated with tables that have TableType as
CONFIGURATION.

If set to TRANSACTION, the agent runs for the records
associated with tables that have TableType as TRANSACTION.

Table Name

Required. The table name for the records to be migrated to
shadow columns.
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Table 62. Case Insensitive Data Loader Criteria Parameters (continued)

Parameter Description

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked
None.

Pending Job Count
None.

Events Raised

None.

Change Load Status

This transaction is equivalent to the changeLoadStatus() APL For detailed
information about this transaction, see the Sterling Selling and Fulfillment Foundation:
Javadocs.

To be configured as part of your load processing pipeline, this transaction can be
used whenever an automatic change in the status of a load is required. This
automatic change could represent exporting load information to load planning
software or transmission to the load's carrier.

This transaction should be configured to work from the task queue.
Attributes

The following are the attributes for this time-triggered transaction:

Table 63. Change Load Status Attributes

Attribute Value

Base Transaction ID CHANGE_LOAD_STATUS
Base Document Type Load

Base Process Type Load Execution

Abstract Transaction Yes

APIs Called changelLoadStatus ()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 64. Change Load Status Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.
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Table 64. Change Load Status Parameters (continued)

Parameter Description

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 65. Change Load Status Statistics

Statistic Name Description

NumLoadsChanged Number of loads whose status was changed.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the CurrentDate value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the changeLoadStatus() API in the
Sterling Selling and Fulfillment Foundation: Javadocs.

Change Shipment Status

This transaction is equivalent to the changeShipmentStatus() APL For detailed
information about this transaction, see the Sterling Selling and Fulfillment Foundation:

Javadocs.

To be configured as part of your shipment processing pipeline, this transaction can
be used whenever an automatic change in the status of a shipment is required. For
example, this automatic change could represent exporting shipment information to
a warehouse management system or to transmit an Advance Shipping Notice to
the buyer.

This transaction should be configured to work from the task queue.

Attributes

The following are the attributes for this time-triggered transaction:

Table 66. Change Shipment Status Attributes

Attribute Value

Base Transaction ID CHANGE_SHIPMENT_STATUS
Base Document Type Order

Base Process Type Order Delivery

Abstract Transaction Yes

APIs Called None
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 67. Change Shipment Status Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID Required in a multischema deployment where a table may

exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 68. Create Chained Order Statistics

Statistic Name Description

NumShipmentsChanged Number of shipments whose status was changed.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the changeShipmentStatus() API
in the Sterling Selling and Fulfillment Foundation: Javadocs.

Close Delivery Plan

To boost system performance, this transaction serves as a temporary purge until
the Delivery Plan Purge deletes delivery plan-related data (see|Delivery Pla

[Purge” on page 224).

This transaction picks all delivery plans that do not have any of their loads or
shipments still open and marks the deliveryplan_closed_flag="Y". This flag
indicates no further operations are possible on the plan.

This transaction corresponds to the base transaction close delivery plan
(CLOSE_DELIVERY_PLAN) in the load pipeline.

Any enterprise using the Console must schedule purge jobs.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 69. Close Delivery Plan Attributes

Attribute Value
Base Transaction ID CLOSE_DELIVERY_PLAN
Base Document Type Load

Base Process Type

Load Execution

Abstract Transaction

No

APIs Called

None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 70. Close Delivery Plan Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID

Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 71. Close Delivery Plan Statistics

Statistic Name

Description

NumDeliveryPlansClosed

Number of delivery plans closed.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

The following events are raised by this time-triggered transaction:

Table 72. Events Raised by Close Delivery Plan Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS delivery_plan_ YDM_CLOSE_DELIVERY | Yes
dbd.txt _PLAN.ON_
SUCCESS.xml
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However, note that the template name would read
<Transactionld>.ON_SUCCESS.xml.

Close Load

To boost system performance, this transaction serves as a temporary purge until
the Load Purge deletes load-related data (see[“Load Purge” on page 238).

This transaction corresponds to the base transaction Close Load (CLOSE_LOAD) in
the load pipeline.

If you use the Load processing pipeline, you must schedule this transaction. Only
closed loads are picked up by the purge transaction. Therefore, it is required that
this transaction be made part of the pipeline and scheduled to run at the end of
the day.

This transaction should be made part of the pipeline. In addition, it should be
configured to work from the task queue.

Attributes

The following are the attributes for this time-triggered transaction:

Table 73. Close Load Attributes

Attribute Value
Base Transaction ID CLOSE_LOAD
Base Document Type Load

Base Process Type

Load Execution

Abstract Transaction

No

APIs Called

None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 74. Close Load Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval

Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID

Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide




Statistics Tracked

The following statistics are tracked for this transaction:

Table 75. Close Load Statistics

Statistic Name Description

NumLoadsClosed Number of loads closed.

Pending Job Count

For this transaction the pending job count is the number of open delivery plans,
which are not associated to any open loads and open shipments.

Events Raised

The following events are raised by this time-triggered transaction:

Table 76. Events Raised by the Close Load Transaction

Template
Transaction/Event Data Published Support?
ON_SUCCESS YDM_CLOSE_LOAD_PLAN.ON_ Yes
SUCCESS.xml

However, note that the template name would read
<Transactionld>.ON_SUCCESS.xml.

Close Manifest

This time-triggered transaction sets the manifest's MANIFEST_CLOSED_FLAG flag
to ‘Y' and updates the manifest status to CLOSED. This time-triggered transaction
confirms all the shipments that are pending confirmation, and closes the manifest.

Note: If the Close Manifest Agent is triggered without any criteria, it closes all the
candidate manifests across all ShipNodes.

The yfs.closemanifest.online property in the yfs.properties_ysc_ext.in file is
used to set this time-triggered transaction to work in online or offline mode.

* Online mode: In the online mode, the close manifest transaction runs as usual,
confirming all shipments in the manifest and then closing the manifest.

* Offline mode: In the offline mode, the close manifest transaction triggers an
agent and changes the manifest status to ‘Closure Requested'. When the agent
runs, it confirms either each shipment of the manifest, or closes the manifest, in
an execution call.

The mode of operation (online or offline) is decided on the basis of the value
specified for the yfs.closemanifest.online property in the
yfs.properties_ycs_ext.in file. To override this property, add an entry for it in
the <INSTALL_DIR>/properties/customer _overrides.properties file. For additional
information about overriding properties using the customer_overrides.properties
file, see the Sterling Selling and Fulfillment Foundation: Properties Guide.

The default out-of-the-box shipped property causes the Close Manifest transaction
to run in online mode.
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In instances where the Close Manifest transaction is run in offline mode, ensure
that all Agent Criteria defined for the transaction are configured properly.

Attributes

The following are the attributes for this time-triggered transaction:

Table 77. Close Manifest Attributes

Attribute Value

Base Transaction ID CLOSE_MANIFEST
Base Document Type General

Base Process Type Manifesting
Abstract Transaction No

APIs Called confirmShipment()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 78. Close Manifest Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

AgentCriteriaGroup

Optional. Used to classify nodes. This value can be accepted
by Sterling Selling and Fulfillment Foundation time-triggered
transactions that only perform their tasks on the nodes with a
matching node transactional velocity value.

Valid values are: LOW, HIGH, and any additional values
defined by the Hub from Application Platform > System
Administration > Agent Criteria Groups.

ShipNode

Optional. Ship node for which the Close Manifest needs to be
run. If not passed, then all ship nodes are monitored.

ColonyID

Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following are statistics are tracked for this transaction:

Table 79. Close Manifest Statistics

Statistic Name

Description

NumShipmentsConfirmed

Number of shipments confirmed.

NumManifestsClosed

Number of manifests closed.

NumManifestsErrored

Number of manifests errored.

NumShipmentsErrored

Number of shipments errored.
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Pending Job Count

For this transaction the pending job count is the sum of open manifests and
shipments belonging to manifests (with MANIFEST_STATUS='1200").

Events Raised

The following events are raised by this time-triggered transaction:

Table 80. Events Raised by the Close Manifest Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS manifest_dbd.txt | YDM_CLOSE_MANIFEST | Yes
.ON_SUCCESS.xml

Close Order

This time-triggered transaction sets the order's ORDER_CLOSED flag to “Y' and
raises the ON_SUCCESS event. These actions are only performed when the entire
ORDER_QTY for all the order lines reaches the configured pickup status. If an
order has ORDER_CLOSED set to ‘Y', it is not picked up for monitoring.

The Close Order agent must be configured along with the Purge transaction in the
pipeline.

Many of this transaction's elements and attributes are template-driven. Refer to the
XML for element level details.

The Close Order agent must be run before running the Monitor agent in order to
avoid alerts getting raised for cancelled orders.

Attributes

The following are the attributes for this time-triggered transaction:

Table 81. Close Order Attributes

Attribute Value

Base Transaction ID CLOSE_ORDER
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 82. Close Order Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.
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Table 82. Close Order Criteria Parameters (continued)

Parameter Description
Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval |Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 83. Close Order Statistics

Statistic Name Description
NumOrdersProcessed Number of orders processed.
NumOrdersClosed Number of orders closed.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table, if tasks on hold are not
ready to be processed.

Events Raised

The following events are raised by this time-triggered transaction:

Table 84. Events Raised by the Close Order Transaction

Transaction/Event Data Published Template Support?
ON_SUCCESS YFS_CLOSE_ORDER.ON_ Yes
SUCCESS.xml

Close Receipts
This time-triggered transaction closes receipts using the receiving rule specified.
Attributes

The following are the attributes for this time-triggered transaction:

Table 85. Close Receipts Attributes

Attribute Value

Base Transaction ID RECEIPT_COMPLETE

Base Document Type Order

Base Process Type Receipt (Purchase Order Receipt, Return Receipt, Transfer
Order Receipt, Receipt)

Abstract Transaction No
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Table 85. Close Receipts Attributes (continued)

Attribute Value
APIs Called None
User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 86. Close Receipts Criteria Parameters

Parameter Description

Action Triggers the transaction. If left blank, it defaults to Get, the
only valid value.

Number of Records To Number of records to retrieve and process at one time. If left

Buffer blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Enterprise for which the Close Receipts needs to be run. If not

passed, then all enterprises are monitored.

Node Node for which the Close Receipts needs to be run.

Note: Both Node and AgentCriteriaGroup cannot be blank.
You must specify a value for the Node parameter, the
AgentCriteriaGroup parameter, or both parameters.

AgentCriteriaGroup Used to classify nodes. This value can be accepted by Sterling
Selling and Fulfillment Foundation time-triggered transactions
that only perform their tasks on the nodes with a matching
node transactional velocity value.

Valid values are: LOW, HIGH, and any additional values
defined by the Hub from Application Platform > System
Administration > Agent Criteria Groups.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 87. Close Receipts Statistics

Statistic Name Description

NumReceiptsClosed Number of receipts closed.

Pending Job Count

For this transaction the pending job count is the number of Receipts that can be
closed (with OPEN_RECEIPT_FLAG="Y").
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Events Raised

The following events are raised by this time-triggered transaction:

Table 88. Events Raised by the Close Receipts Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS receipt_dbd.txt YFS_RECEIPT_COMPLETE | Yes
.ON_SUCCESS.xml

Close Shipment

To boost system performance, this transaction serves as a temporary purge until
the Shii ment Purge deletes all shipment-related data (see|’Shipment Purge” on|

This transaction picks all shipments eligible to be closed, based on the pipeline
configuration for pickup for transaction CLOSE_SHIPMENT, and marks the
shipment_closed_flag="Y". This flag indicates no further operations are possible on
the shipment. There is no status change involved. This transaction can be
configured in the pipeline so that it picks up either Shipped or Delivered status.

This transaction corresponds to the base transaction close shipment
(CLOSE_SHIPMENT) in the shipment pipeline.

This transaction should be made part of the pipeline. In addition, it should be
configured to work from the task queue.

Attributes

The following are the attributes for this time-triggered transaction:

Table 89. Close Shipment Attributes

Attribute Value

Base Transaction ID CLOSE_SHIPMENT
Base Document Type Order

Base Process Type Order Delivery
Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 90. Close Shipment Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
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Table 90. Close Shipment Criteria Parameters (continued)

Parameter Description

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following are statistics are tracked for this transaction:

Table 91. Close Shipment Statistics

Statistic Name Description

NumShipmentsClosed Number of shipments closed.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

The following events are raised by this time-triggered transaction:

Table 92. Events Raised by the Close Shipment Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS shipment_dbd.txt | YDM_CLOSE_SHIPMENT. | Yes
ON_SUCCESS.xml

Collect Shipment Statistics

Collect Shipment Statistics is a time-triggered transaction which can be invoked to
process the shipments, and generate information required for the Daily Shipment
Report.

Attributes

The following are the attributes for this time-triggered transaction:

Table 93. Collect Shipment Statistics Attributes

Attribute Value

Transaction Name Collect Shipment Statistics
Transaction ID COLLECT_STATISTICS
Base Document Type Order

Base Process Type Order Delivery

Abstract Transaction No

APIs Called None
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Table 93. Collect Shipment Statistics Attributes (continued)

Attribute Value

User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 94. Collect Shipment Statistics Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Node Required. The ship node for which records are being
processed.

AgentCriteriaGroup Optional. Used to classify nodes. This value can be accepted

by Sterling Selling and Fulfillment Foundation time-triggered
transactions that only perform their tasks on the nodes with a
matching node transactional velocity value.

Valid values are: LOW, HIGH, and any additional values
defined by the Hub from Application Platform > System
Administration > Agent Criteria Groups.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 95. Statistics for Collect Shipment Statistics

Statistic Name Description
NumDaysStatisticsCollected Number of days for which shipment statistics have
been collected.

Pending Job Count

For this transaction the pending job count is the number of days for which
shipment statistics needs to be collected. The number of days is calculated as the
difference (in days) between the current date and the last date when shipment
statistics was collected.
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Events Raised

The following events are raised by this time-triggered transaction:

Table 96. Events Raised by the Collect Shipment Statistics Transaction

Template
Transaction/Event Data Published Support?
ON_SUCCESS YDM_COLLECT_STATISTICS.ON_  |No
SUCCESS.xml

Consolidate Additional Inventory

The Consolidate Additional Inventory time-triggered transaction consolidates
supply and demand from the YFS_INVENTORY_SUPPLY_ADDNL and
YFS_INVENTORY_DEMAND_ADDNL tables. Consolidation is performed by
summing up the quantities of additional supply and demand in the
YFS_INVENTORY_SUPPLY and YFS_INVENTORY_DEMAND tables.

If no matching supply or demand is found, a new supply or demand is created
with the sum quantity of the changes in the YFS_INVENTORY_SUPPLY_ADDNL
and YFS_INVENTORY_DEMAND_ADDNL tables. After the changes are applied,
the records in the YFS_INVENTORY_SUPPLY_ADDNL and
YFS_INVENTORY_DEMAND_ADDNL tables that were used in the consolidation
process, are deleted.

Attributes

The following are the attributes for this time-triggered transaction:

Table 97. Consolidate Additional Inventory Attributes

Attribute Value

Base Transaction ID CONSOLIDATE_ADDNL_INV
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the parameters for this transaction:

Table 98. Consolidate Additional Inventory Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of inventory item records (whose

Buffer additional supplies and demands are consolidated) to retrieve

and process at one time. If left blank or specified as 0 (zero),
it defaults to 5000.
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Table 98. Consolidate Additional Inventory Criteria Parameters (continued)

Parameter Description

ColonyID Required in a multischema deployment where the
YFS_INVENTORY_SUPPLY_ADDNL and
YFS_INVENTORY_DEMAND_ADDNL tables may exist in
multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 99. Consolidate Additional Inventory Statistics

Statistic Name Description
NumlInventorySupplyAddnlsProcessed Number of additional inventory supply
records processed in the consolidation.
NumInventoryDemandAddnlsProcessed Number of additional inventory
demand records processed in the
consolidation.
NumInventoryDemandDtlsProcessed Number of inventory demand details

records processed in the consolidation.

Pending Job Count

For this transaction the pending job count is the number of distinct inventory items
in the YFS_INVENTORY_SUPPLY_ADDNL and
YFS_INVENTORY_DEMAND_ADDNL tables, multiplied by two.

Events Raised

None.

Consolidate To Shipment

This is a task queue based transaction in the order pipeline that corresponds to
base transaction CONSOLIDATE_TO_SHIPMENT. This transaction finds a
shipment into which a given order release can be included. If it finds an existing
shipment, it calls changeShipment() APIL Otherwise, it calls the createShipment ()
APL

To find the existing shipments it matches ShipNode, ShipTo Address,
SellerOrganizationCode, Carrier, DocumentType and so forth, of the Order Release
with that of existing shipments.

This transaction is applicable only to the shipments in one of the following
Statuses:

* Shipment Created

e ESP Check Required

* On ESP Hold

* Released from ESP Hold
* Released For Routing

* Awaiting Routing
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* Shipment Routing
* Sent To Node

To successfully consolidate an Order Release to an existing shipment, the Add Line
and related modification types on shipment in its current status should be allowed.

This transaction is a part of the Order Fulfillment pipeline. In addition, it should
be configured to work from the task queue.

Order releases with GIFT_FLAG set to Y are never consolidated with any other

release.

For more information, see the details provided under the createShipment(),
changeShipment (), releaseOrder(), and consolidateToShipment() APIs in the
Sterling Selling and Fulfillment Foundation: Javadocs.

Attributes

The following are the attributes for this time-triggered transaction:

Table 100. Consolidate to Shipment Attributes

Attribute Value

Base Transaction ID CONSOLIDATE_TO_SHIPMENT
Base Document Type Order

Base Process Type Order Fulfillment

Abstract Transaction No

APIs Called

createShipment () and changeShipment ()

User Exits

* It calls beforeConsolidateToShipment in
com.yantra.ydm.japi.ue.

* YDMBeforeConsolidateToShipment for each release before
it begins processing.
* After it finds the shipments, it calls

determineShipmentToConsolidateWith in
com.yantra.ydm.japi.ue.

YDMDetermineShipmentToConsolidateWith.

For more information, see the Sterling Selling and Fulfillment
Foundation: Javadocs.

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 101. Consolidate to Shipment Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.
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Table 101. Consolidate to Shipment Criteria Parameters (continued)

Parameter Description

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 102. Consolidate to Shipment Statistics

Statistic Name Description

NumOrderReleasesConsolidated Number of order releases consolidated.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

The following events are raised by this time-triggered transaction:

Table 103. Events Raised by the Consolidate to Shipment Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS shipment_dbd.txt | YDM_CONSOLIDATE_TO | Yes
_SHIPMENT.ON_
SUCCESS.xml

This transaction also raises events as specified under the createShipment () and
changeShipment () APIs in the Sterling Selling and Fulfillment Foundation: Javadocs.

However, note that the template name would read
<Transactionld>.ON_SUCCESS.xml.

Create Catalog Index

The Create Catalog Index transaction builds the Apache Lucene index file that is
used by catalog search. This index file enhances search performance by storing
denormalized item data that has been extracted from the Sterling Selling and
Fulfillment Foundation database or from an external source.

The Create Catalog Index transaction can be configured to perform the following
tasks:
* Run either a scheduled index build or user-initiated index build

e Build either a full or incremental index file

e Activate the index file
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The Index Building Process

The Create Catalog Index transaction provides an agent for index building. Index
building is a multithread process in which the index building agent extracts item
and item-related information from the active selling catalog in the Sterling Selling
and Fulfillment Foundation database. If the corresponding XML configuration file
has been extended, the agent may extract this information from an external source.

The agent writes this information to multiple files, which identify the item data
that should be included in the final index. After the agent finishes writing the files,
it merges them into the final index file.

The multithread process provides the advantage of parallel processing. Large
amounts of database data are segmented and processed simultaneously, which is
faster and more scalable than sequentially processing one long file.

When writing information to multiple files, the index building agent performs the
following tasks for each item before looping to the next item:

* Queries the Sterling Selling and Fulfillment Foundation database or an external
source for data about the item.

* Uses information from the XML configuration file and extension file to
determine the data that be retrieved from the query.

* Retrieves relevant data from the Sterling Selling and Fulfillment Foundation
database.

e Creates a Lucene document for the item.

After the transaction creates a Lucene document for each item, the transaction
writes the documents to the index file based on the organization and the
organization's locales.

Configuration Options for Accessing Catalog Index Files

You can configure catalog index builds in one of the following two ways,
depending on your business requirements:

e Build the index on a shared, central disk that is accessible from all servers.
— Advantages:
- Centralized control of shared index

- No file transfer issues because the index is not copied across multiple
servers

— Limitation:
- Shared disk could become a single point of failure (if no redundancy is
involved)

- Volume of reads and writes from shared disk might slow performance,
depending on the setup

* Build and push a copy of the index to multiple servers via file transfer.
Automate this file transfer process to occur on completion of an index build, but
do not automatically activate the index. When all servers have acknowledged
the completion of the file transfer, call the manageSearchIndexTrigger API to
activate the index.

— Advantage:
- No central point of failure
— Limitation:
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- Possible overhead to building an pushing index files across servers

If you choose this method of building the index in one location and reading
it from another, refer to the Sterling Selling and Fulfillment Foundation:
Properties Guide for information about enabling different properties for
individual processes.

For more information about building and searching catalog indexes, see the Sterling
Selling and Fulfillment Foundation: Catalog Management Concepts Guide.

Attributes

The following table displays the attributes for the Create Catalog Index transaction.

Table 104. Create Catalog Index Attributes

Attribute Value

Base Transaction ID Create_Catalog_Index

Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YCMParseAssetUE
YCMGetAdditionalCatalogIndexInformationUE

Criteria Parameters

The following table displays the criteria parameters for the Create Catalog Index
transaction.

Table 105. Create Catalog Index Criteria Parameters

Parameter Description

Organization Code Required. The organization code of the catalog organization or
subcatalog organization that maintains the search index.

Number of Messages Required. Number of messages to use when building the
index file.

Sterling Selling and Fulfillment Foundation processes only one
message per thread. For example, if Number of Messages is
set to 10 and Threads is set to 3, Sterling Selling and
Fulfillment Foundation processes only 3 messages at a time.
For more information about fine-tuning system performance,
see the Sterling Selling and Fulfillment Foundation: Performance
Management Guide.
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Table 105. Create Catalog Index Criteria Parameters (continued)

Parameter

Description

Incremental Build

Y or N.

Y to rebuild the existing index file. If you specify Y, Sterling
Selling and Fulfillment Foundation rebuilds the index based
on the last successful index build. The MaxModifyTS column
in the YFS_ITEM table determines whether or not an item's
attributes have changed. If any external attributes of an item
have changed, update the MaxModifyTS column by calling the
manageltem API on the item.

N to build a full index file.

This parameter is ignored for user-initiated index builds.
However, if scheduled builds are configured, ensure that you
specify whether you want a full or incremental index build.

Category Domain

Optional. The catalog from which the index is built. The active
selling catalog of the catalog organization or subcatalog
organization is the default. If scheduled builds are configured,
ensure that you specify a catalog.

Auto Activate

Y or N. Optional.
Y to activate the index after building the index file.

The default is N.

Auto Insert Search Index
Trigger

Y or N. Optional.

Y to enable scheduled builds of the catalog index file. The
agent refers to information stored in the
YFS_SEARCH_INDEX_TRIGGER table to determine when to
run the scheduled index build. Specify the type of index build,
whether full or incremental, in the agent criteria.

N to enable user-initiated builds of the catalog index file. The
agent continuously queries the
YFS_SEARCH_INDEX_TRIGGER table to determine whether
an index build is indicated. If a user starts an index build from
the IBM Sterling Business Center, the status setting in the table
changes to Scheduled, triggering the agent to build the index.
The user specifies the type of index build, whether full or
incremental, from the Sterling Business Center.

After a scheduled or user-initiated build runs, the user can
activate the index from the Sterling Business Center.
Alternatively, the agent can be configured to automatically
activate the index.

To allow both scheduled and user-initiated index builds,
configure the transaction to include two instances of the agent.
Configure one instance to trigger user-initiated builds and the
second instance to trigger scheduled index builds.

ColonyID

Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.
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Statistics Tracked

The following table shows the statistics for the Create Catalog Index transaction.

Table 106. Create Catalog Index Statistics

Statistic Name Description

SearchIndicesBuilt Number of search indices that have been built.

Pending Job Count
None.
Events Raised

The following events are raised by this time-triggered transaction:

Table 107. Events Raised by the Create Catalog Index Transaction

Template
Transaction/Event | Key Data Data Published Support?
ON_SUCCESS Not Published |CATALOG_INDEX_BUILD.ON | Yes
_SUCCESS.xml

Create Chained Order

This transaction creates one or more chained orders from an order whose
OrderHeaderKey is stored in the task queue object. Chainable lines of the order
can also be added to existing chained orders, instead of creating new chained
orders with these lines. The existing chained orders must be identified by the
determineChainedOrderForConsolidation user exit. If the user exit is not
implemented, or if the user exit returns a blank document, one or more new
chained orders are created.

For more information about the creation of chained orders, see the information
provided under the createChainedOrder() API and the
YFSDetermineChainedOrderForConsolidation user exit in the Sterling Selling and
Fulfillment Foundation: Javadocs.

This transaction should be invoked after order scheduling.
Attributes

The following are the attributes for this time-triggered transaction:

Table 108. Create Chained Order Attributes

Attribute Value

Base Transaction ID CHAINED_ORDER_CREATE
Base Document Type Order

Base Process Type Order Fulfillment

Abstract Transaction Yes

APIs Called createChainedOrder()
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 109. Create Chained Order Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to

5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 110. Create Chained Order Statistics

Statistic Name Description

NumOrdersProcessed Number of orders processed for creating chained
order.

NumOrdersCreated Number of chained orders created.

If there are 2 orders being processed and the first order creates a chained order, the
DetermineChainedOrderForConsolidation user exit causes the lines of the 2nd
order to be added to the first order. The number of chained orders created is
counted as 2.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the createChainedOrder() API in
the Sterling Selling and Fulfillment Foundation: Javadocs.

Create Derived Order

This transaction creates one or more derived orders from an order whose
OrderHeaderKey is stored in the task queue object. For existing derived orders,
you can add derivable lines or create new derived orders with these lines. The
existing derived orders must be identified by the
determineDerivedOrderForConsolidation user exit. If the user exit is not
implemented or if the user exit returns a null document, new derived orders are
created. For more information about the creation of derived orders, see the details
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provided under the createDerivedOrder() API and
YFSDetermineDerivedOrderForConsolidation user exit in the Sterling Selling and

Fulfillment Foundation: Javadocs.

Attributes

The following are the attributes for this time-triggered transaction:

Table 111. Create Derived Order Attributes

Attribute Value

Base Transaction ID DERIVED_ORDER_CREATE
Base Document Type Order

Base Process Type Order Fulfillment

Abstract Transaction Yes

APIs Called createDerivedOrder()

The TransactionKey posted in the task queue object must be an instance of the
Abstract Transaction DERIVED_ORDER_CREATE for the ProcessType associated
with the Order. Otherwise, an exception is thrown.

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 112. Create Derived Order Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to

5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 113. Create Derived Order Statistics

Statistic Name Description
NumOrdersProcessed Number of orders processed.
NumOrdersCreated Number of derived orders created.

If there are 2 orders being processed and the first order creates a derived order, the
DetermineChainedOrderForConsolidation user exit causes the lines of the 2nd
order to be added to the first order. The number of derived orders created is

counted as 2.
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Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the createDerivedOrder() API in
the Sterling Selling and Fulfillment Foundation: Javadocs.

Create Order Invoice

This transaction creates one or more invoices from an order whose
OrderHeaderKey is stored in a task queue object. The createOrderInvoice() API is
called for the OrderHeaderKey.

Configure this transaction in the pipeline only after all processing that can impact
quantity or price has been completed. Post invoice creation, the line quantity
cannot be reduced below the invoiced quantity.

Both the Create Order Invoice and Create Shipment Invoice transactions can create
invoices for an Order. When configuring your pipeline, ensure that only one of
these two transactions is configured to create invoices for a particular order line.
For more information, see [“Create Shipment Invoice” on page 176

Attributes

The following are the attributes for this time-triggered transaction:

Table 114. Create Order Invoice Attributes

Attribute Value

Base Transaction ID CREATE_ORDER_INVOICE
Base Document Type Order

Base Process Type Order Fulfillment

Abstract Transaction Yes

APIs Called createOrderInvoice()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 115. Create Order Invoice Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID Required in a multischema deployment where a table may

exist in multiple schemas. Runs the agent for the colony.
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Statistics Tracked

The following statistics are tracked for this transaction:

Table 116. Create Order Invoice Statistics

Statistic Name Description

NumOrderInvoicesCreated Number of order invoices created.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the createOrderInvoice() API in
the Sterling Selling and Fulfillment Foundation: Javadocs.

Create Shipment Invoice

Invoicing is mandatory if an order requires payment processing. Invoicing occurs if
the following conditions are met:

* Invoicing is enabled at the document parameter level.

* The Seller requires payment processing.

This transaction creates one or more invoices for the shipment whose ShipmentKey
is stored in the task queue object. The createShipmentInvoice() API is called for
the ShipmentHeaderKey.

This transaction should be configured in the shipment pipeline only after the
shipment has reached a shipped status.

Both the Create Order Invoice and Create Shipment Invoice can create invoices for
an order. When configuring your pipeline, ensure that only one of these two
transactions is configured to create invoices for a particular order line. See
Order Invoice” on page 175

Attributes

The following are the attributes for this time-triggered transaction:

Table 117. Create Shipment Invoice Attributes

Attribute Value

Base Transaction ID CREATE_SHIPMENT_INVOICE
Base Document Type Order

Base Process Type Order Delivery

Abstract Transaction Yes

APIs Called createShipmentInvoice()
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 118. Create Shipment Invoice Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID Required in a multischema deployment where a table may

exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 119. Create Shipment Invoice Statistics

Statistic Name Description

NumShipmentInvoicesCreated Number of shipment invoices created.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the createShipmentInvoice() API
in the Sterling Selling and Fulfillment Foundation: Javadocs.

ESP Evaluator

The ESP Evaluator time-triggered transaction verifies whether a shipment meets
certain economic shipping parameters (ESP). ESP can be configured either for
buyer or enterprise, with the freight terms on the shipment determining which one
is used.

If the configuration is defined to hold shipment for ESP, the shipment when
created is held for ESP (with status On ESP Hold). This task queue based
time-triggered transaction evaluates the shipment for ESP, and passes it on to the
next step in the shipment pipeline if the criteria (weight and volume limits, plus
maximum days of hold up) are met. The shipment status is now set to Released
from ESP hold, and routing processing begins.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 120. ESP Evaluator Attributes

Attribute Value

Base Transaction ID ESP_EVALUATOR.0001

Base Document Type Order

Base Process Type Outbound Shipment

Abstract Transaction No

APIs Called None

User Exits Called getNodeMinimumNotificationTime

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 121. ESP Evaluator Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

EnterpriseCode Optional. Enterprise for which the ESP Evaluator needs to be
run. If not passed, then all enterprises are monitored.

Number of Records to Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval |Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to

5 hours.

Node Required. The ship node for which records are being
processed.

AgentCriteriaGroup Optional. Used to classify nodes. This value can be accepted

by Sterling Selling and Fulfillment Foundation time-triggered
transactions that only perform their tasks on the nodes with a
matching node transactional velocity value.

Valid values are: LOW, HIGH, and any additional values
defined by the Hub from Application Platform > System
Administration > Agent Criteria Groups.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

None.

Pending Job Count

For this transaction the pending job count is the number of records available to be

processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.
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Events Raised

The following events are raised by this time-triggered transaction:

Table 122. Events Raised by ESP Evaluator Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS shipment_dbd.txt | ESP_EVALUATOR.ON_ Yes
SUCCESS.xml

ltem Based Allocation

The Item Based Allocation transaction allocates unpromised and promised
demands of existing orders to more suitable supplies based upon inventory items
and nodes which have been triggered for the Item Based Allocation process in the
YFS_IBA_TRIGGER table.

The Item Based Allocation agent obtains and processes all Item Based Allocation
triggers from the YFS_IBA_TRIGGER table that meet the following conditions:

e IBA_RUN_REQUIRED = "Y"

e LAST IBA_PROCESSED_TS was 'x' hours before current time, where 'x' is from
the ‘Item Based Allocation Agent Execution Interval (in hours)' rule in the
Installation rules. For more information about installation rules, refer to the topic
"System Administration Components: Defining Installation Rules" in the Sterling
Selling and Fulfillment Foundation: Configuration Guide. This rule is used to
indicate the interval that the Item Based Allocation agent should not reprocess
the triggers in the YFS_IBA_TRIGGER table, which were processed earlier. This
prevents the IBA agent from over-processing the item and node combination in
the given time interval to avoid any high loads on the system.

* PROCESSING_BY_AGENT="N" or PROCESS_OVER_BY_TS is before the current
timestamp. The PROCESSING_BY_AGENT field is used to prevent the picking
up of the IBA trigger which is being processed by another instance of the agent.

If InventoryOrganizationCode is specified in the agent criteria, only the IBA trigger
with inventory items of that inventory organization is retrieved.

For each triggered item and node combination, the agent finds all of the applicable
order lines or order line reservations that contain the item and node and tries to
move their unpromised and promised demands to more suitable available supplies
based on user-configured IBA selection rules or FIFO (First-In-First-Out) IBA
selection rules.

Sterling Selling and Fulfillment Foundation creates new positive order line
reservations with the matched supply's first ship date and negative order line
reservations for the existing demand ship date. Once all orders are processed, they
are placed on hold to be rescheduled if changes are detected in the order line
reservations.

The following configuration is required for the Item Based Allocation process:
e The Use Item Based Allocation rule needs to be enabled.
¢ Jtem and node need to have Item Based Allocation Allowed enabled.
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* A hold type is required to be set up for the change order line reservations
modification type so that the order can be placed on hold for rescheduling. For
more information, refer to the Sterling Selling and Fulfillment Foundation: Javadocs.

The ‘When a line is backordered, backorder against the highest priority ship node'
rule should be checked in order to reallocate backordered demand. For more
information, see the Fulfillment Rules section in the Sterling Selling and Fulfillment
Foundation: Distributed Order Management Configuration Guide.

Before processing the Item Based Allocation logic, the Item Based Allocation agent
updates the following fields on the Item Based Allocation trigger:

¢ PROCESSING_BY_AGENT = “Y”. This indicates that an instance of the agent is
currently processing this trigger.

* PROCESS_OVER_BY_TS = current time + 1 hr. This indicates the expected time
that the agent should finish with processing this IBA trigger. One hour is the
fixed window and cannot be changed. Sterling Selling and Fulfillment
Foundation treats the PROCESSING_BY_AGENT flag as “N” regardless of the
actual value when current timestamp is after this timestamp.

* IBA_RUN_REQUIRED = “N”. This resets the IBA_RUN_REQUIRED flag back to
/1NII‘

Obtaining a List of Demands Based on Applicable Order Release
Statuses and Order Line Reservations to be Allocated

A list of demands is derived from applicable order release statuses and order line
reservations, which have the item and node in the IBA trigger. The following types
of demands are retrieved:

* Demands of chained orders
¢ Demands of orders with chained order already created

* Demands of orders with procurement node but chained order creation is not yet
created

* Demands of orders without procurement node

¢ Demands from order line reservations

The demand quantity is derived based on the order release status quantity with
the status from the Status Inventory Type configuration that has a demand type,
which considers the supply type with ‘Use Consider Demand Type for Item Based
Allocation' enabled. For more information, refer to the Sterling Selling and
Fulfillment Foundation: Global Inventory Visibility Configuration Guide.

Obtaining a List of Available Supplies for Allocation

Sterling Selling and Fulfillment Foundation obtains the available supply based on
the availability of the item at the node by ignoring unpromised and promised
demands. If the inventory organization maintains its inventory externally, the
external availability can be read by the YFSGetExternallInventoryUE user exit. Only
the availability of supplies that consider the ‘Demand Type Look for Availability
during Item Based Allocation' are used in the allocation logic. For more
information, refer to the Sterling Selling and Fulfillment Foundation: Global Inventory
Visibility Configuration Guide.

Allocated demands should be matched with the same supplies as "Demand to look
for during release".
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Matching Demands Against Supplies in FIFO (First-In-First-Out)
Order

Sterling Selling and Fulfillment Foundation sorts the list of available supplies in
the order of the first shippable date (ETA), and matches the obtained list of
demands using the top-down logic (unlike the normal matching logic for obtaining
availability, where matches are based on the closest ETA). Demands are allocated
in the following orders:

* Demands of chained orders - first based on user-configured sequencing rules,
and then in ascending order of order creation date. (These types of demands are
matched based on the closest ETA to avoid any changes in the chained orders).

* Demands of orders with a chained order already created - first based on
user-configured sequencing rules, then in ascending order of product availability
date. (These types of demands are matched based on the closest ETA to avoid
any changes in the orders).

* Demands of orders for which procurement node and chained order creation is
imminent (within the advanced notification time window) - first based on
user-configured sequencing rules, then in order of order creation date.

* Demands of orders without a procurement node and within the release window
(advanced notification time window) - first based on user-configured sequencing
rules, then in order of order creation date.

¢ Demands from order line reservations on the order lines in the order of
requested reservation date, and leftover demands (outside of the advanced
notification time window) of orders with or without a procurement node, first
based on user-configured sequencing rules and then in the order of order
creation date.

¢ Demands from inventory reservations in the order of ship date.

Notice that different types of demands are given different priorities based on their
significance. The demands of chained orders or orders related to chained orders
are treated with a higher priority than the demands of normal orders. Furthermore,
the demands with a ship date within the advanced notification time window also
have a higher priority than the demands with a date outside of the advanced
notification time window.

Updating Order Reservations for the Matched Demands

After matching the available supply and demand in user-configured sequencing
and then in FIFO order, the system builds up a list of order line reservation
changes and inventory demand changes (corresponding to the order line
reservation changes) and summarize them to optimize the number of order
reservation updates and inventory updates. Negative order line reservations are
added for the matched demands. Positive order reservations are added for the
matched demands with the product availability date set to the matched supplies'
first ship date.

After the Item Based Allocation agent completes its tasks for an Item Based
Allocation trigger, it updates the fields of the trigger with the following values:

* IBA_REQUIRED = "N"

* LAST_IBA_PROCESSED_TS = current timestamp.
* PROCESS_OVER_BY_TS = current timestamp.

* PROCESSING_BY_AGENT = "N”
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The Item Based Allocation agent should be used in conjunction with the
rescheduling process as the rescheduling process reschedules the affected orders by
utilizing the order line reservations created by the Item Based Allocation process.

Attributes

The following are the attributes for this time-triggered transaction:

Table 123. Item Based Allocation Attributes

Attribute Value

Base Transaction ID ITEM_BASED_ALLOCATION
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called

changeOrder — for updating the order line reservations created
as part of the Item Based Allocation process.

User Exits Called

None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 124. Item Based Allocation Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

InventoryOrganization

The inventory organization code of the inventory items which

Code are processed by the Item Based Allocation agent. If provided,
only the IBA triggers with the inventory item that belongs to
this inventory organization are processed.

ColonyID Required in a multischema deployment where the

YFS_IBA_TRIGGER table may exist in multiple schemas. Runs
the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 125. Item Based Allocation Statistics

Statistic Name Description

NumOrdersProcessed Number of orders processed by the Item Based
Allocation agent.

NumOrdersRequiredReschedule Number of orders required rescheduling as the

result of Item Based Allocation process.

Pending Job Count

None.
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Events Raised

This transaction raises events as specified under the changeOrder API in the
Sterling Selling and Fulfillment Foundation: Javadocs.

Mark Load as Trailer Loaded

This is a time-triggered transaction which works on “Load pipeline”.

This time-triggered transaction gets records from the Task Q. This transaction is
used to mark the load as trailer loaded when all containers for the load are on the

trailer.

Attributes

The following are the attributes for this time-triggered transaction:

Table 126. Mark Load As Trailer Loaded Attributes

Attribute Value
Base Transaction ID MARK_AS_TRAILER_LOADED
Base Document Type Load

Base Process Type

Load Execution

Abstract Transaction No
APIs Called None
User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 127. Mark Load As Trailer Loaded Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

ReprocessInterval Optional. Reprocess Interval is the time taken to reprocess the
load.
ColonyID Required in a multischema deployment where a table may

exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 128. Mark Load As Trailer Loaded Statistics

Statistic Name

Description

NumLoadsChanged

Number of trailer loads changed.
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Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

None.

Match Inventory

Match Inventory processes all pending records in the
YFS_INVENTORY_SHIPMENT table. Pending records have a smaller number in
POSTED_QUANTITY than in QUANTITY.

Each pending record is matched against the receipt records in
YFS_INVENTORY_RECEIPT table by applying the inventory cost determination
logic. The unit cost at which the sales and receipt data are matched is also posted
in YFS_INVENTORY_MATCH table.

Use this transaction if any of the configured ship nodes maintain inventory cost.

Attributes

The following are the attributes for this time-triggered transaction:

Table 129. Match Inventory Attributes

Attribute Value

Base Transaction ID

INVENTORY_MATCH

Base Document Type General
Base Process Type General
Abstract Transaction No
APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 130. Match Inventory Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it
defaults to Get, the only valid value.

Number of Records To Buffer

Optional. Number of records to retrieve and process at
one time. If left blank or specified as 0 (zero), it
defaults to 5000.

InventoryOrganizationCode

Optional. Valid inventory owner organization.
Organization to process in this run. If not passed, all
inventory organizations are processed.

CutOffDate

Optional. If passed, records are matched up to this
date. Defaults to all unmatched records in Database.
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Table 130. Match Inventory Criteria Parameters (continued)

Parameter Description

ColonyID Required in a multischema deployment where the
YFS_INVENTORY_SHIPMENT,
YFS_INVENTORY_RECEIPT, and the
YFS_INVENTORY_MATCH tables may exist in
multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 131. Match Inventory Statistics

Statistic Name Description

NumInventoryShipmentsProcessed |Number of inventory shipments processed.

NumlInventoryMatchesInserted Number of inventory matches inserted.

Pending Job Count

For this transaction the pending job count is the number of distinct inventory items
that exist in the YFS_INVENTORY_SHIPMENT table where the QUANTITY value
is not equal to the POSTED_QUANTITY value.

Events Raised

None.

Payment Collection

This transaction requests credit validation for orders that are pending authorization
or charging.

Use this transaction for creating authorization and charge requests.

This transaction works in combination with the Payment Execution transaction.
Although this transaction can run independent of that transaction, authorization
and collection occurs only after the Payment Execution dependencies are met. For
more details, see ["Payment Execution” on page 187 |

Attributes

The following are the attributes for this time-triggered transaction:

Table 132. Payment Collection Attributes for Sales Orders

Attribute Value

Base Transaction ID PAYMENT_COLLECTION
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called requestCollection()
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Table 133. Payment Collection Attributes for Return Orders

Attribute Value

Base Transaction ID PAYMENT_COLLECTION.0003
Base Document Type Order

Base Process Type Reverse Logistics

Abstract Transaction No

APIs Called

requestCollection()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 134. Payment Collection Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode

Optional. The enterprise for which the transaction needs to be
run. If left blank, orders for all enterprises are processed. If
specified, only orders for that enterprise are processed.

ColonyID

Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

HoldTypeOnRollback

If the HoldTypeOnRollback criteria is populated and the
requestCollection agent throws an exception, for example,
from the getFundsAvailable user exit, HoldTypeOnRollback
will be used to put the order on hold. If using the old order
hold functionality, this will be used as the hold reason. If the
hold type does not exist, an exception is thrown.

=

If the HoldTypeOnRollback criteria is not populated, the orde
will not be put on hold if an exception is thrown.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 135. Payment Collection Statistics

Statistic Name

Description

NumOrdersProcessed

Number of orders processed.

NumChargeReqsCreated

Number of charge requests created.

NumAuthorizationReqsCreated

Number of authorization requests created.

Pending Job Count

For this transaction the pending job count is the number of orders in the
appropriate payment statuses with the value of the
AUTHORIZATION_EXPIRATION_DATE is less than or equal to (<=) the current
date. The appropriate payment statuses for such orders are:

 AWAIT _PAY_INFO
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« AWAIT AUTH

* REQUESTED_AUTH

* REQUEST_CHARGE

* AUTHORIZED, INVOICED
* PAID

* RELEASE _HOLD

* FAILED_AUTH

* FAILED_CHARGE

* VERIFY

* FAILED

Events Raised

The following events are raised by this time-triggered transaction:

Table 136. Events Raised by the Payment Collection Transaction

Template
Transaction/Event Key Data Data Published Support?
INCOMPLETE_PAYMENT | modifyOrder YFS_PAYMENT _ Yes
_INFORMATION _dbd.txt COLLECTON.INCOMPLETE
_PAYMENT
_INFORMATION.xml
PAYMENT_STATUS YFS_PAYMENT | YFS_PAYMENT_ Yes
_COLLECTION |COLLECTION.
.PAYMENT PAYMENT_STATUS.xml
_STATUS_
dtd.txt
REQUEST_PAYMENT_ YFS_PAYMENT _ Yes
STATUS COLLECTION.REQUEST
_PAYMENT_STATUS.
xml
ON_LIABILITY_ modifyOrder YFS_PAYMENT_ Yes
TRANSFER _dbd.txt COLLECTION.ON_
LIABILITY_TRANSFER.xml
ON_INVOICE_ order_dbd/txt | YFS_CREATE_ORDER_ Yes
COLLECTION INVOICE.ON_
INVOICE_
COLLECTION.xml

Payment Execution

This transaction processes all requests that are pending authorization and charging.

Note: If the charge transaction request has an open authorization reversal, the
charges are not collected.

Use this time-triggered transaction for processing all authorization and charge
requests.

This transaction requires interfacing with a product that provides financial services.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 137. Payment Execution Attributes for Sales Orders

Attribute Value

Base Transaction ID PAYMENT_EXECUTION
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called

executeCollection()

User Exits Called

collectionCreditCard, collectionOthers,
collectionCustomerAcct

Table 138. Payment Execution Attributes for Return Orders

Attribute

Value

Base Transaction ID

PAYMENT_EXECUTION.0003

Base Document Type

Order

Base Process Type

Reverse Logistics

Abstract Transaction

No

APIs Called

executeCollection()

User Exits Called

collectionCreditCard, collectionOthers,
collectionCustomerAcct

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 139. Payment Execution Criteria Parameters

Parameter Description
Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.
Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
ChargeType Type of credit card process. Valid values are:
¢ AUTHORIZATION - Validates the credit card account
* CHARGE - Applies the charge to the credit card
ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 140. Payment Execution Statistics

Statistic Name

Description

NumAuthTransProcessed

Number of authorization transaction
processed.
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Table 140. Payment Execution Statistics (continued)

Statistic Name Description

NumAuthTransSuccessfullyProcessed Number of successful returns from user exit
for authorization transaction processed.

NumChargeTransProcessed Number of charge transaction processed.

NumChargeTransSuccessfullyProcessed | Number of successful returns from user exit
for charge transaction processed.

NumCollectionValidations Number of successful returns from the
invoked validate collection user exits.

NumCreditCardCollections Number of credit card collections.

NumCustomerAccountCollections Number of successful returns from the
customer account collection user exits.

NumOtherCollections Number of successful returns from the other
collection user exits.

Pending Job Count

For this transaction the pending job count is the number of open charge and
authorization transactions.

Events Raised

The following events are raised by this time-triggered transaction:

Table 141. Events Raised by Payment Execution Transaction

Template
Transaction/Event Key Data Data Published Support?
CHARGE_FAILED modifyOrder PAYMENT_EXECUTION_ No
dbd.txt CHARGE_FAILED_dbd.txt

This transaction raises events as specified under the executeCollection() API in
the Sterling Selling and Fulfillment Foundation: Javadocs.

Post Inventory Match

This transaction processes all open records in YFS_INVENTORY_MATCH table
and posts the records to a financial system. An open record in the
YFS_INVENTORY_MATCH table has the status of 01. After posting, the status is
changed to 02.

Use this transaction if any of the configured ship nodes maintain inventory cost.
Attributes

The following are the attributes for this time-triggered transaction:

Table 142. Post Inventory Match Attributes

Attribute Value
Base Transaction ID POST_INVENTORY_MATCH
Base Document Type General
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Table 142. Post Inventory Match Attributes (continued)

Attribute Value
Base Process Type General
Abstract Transaction No
APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 143. Post Inventory Match Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID Required in a multischema deployment where the

YFS_INVENTORY_MATCH table may exist in multiple
schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 144. Post Inventory Match Statistics

Statistic Name Description

NumlInventoryMatchPosted Number of inventory match records posted.

Pending Job Count

For this transaction the pending job count is the number of inventory matches with
an open status.

Events Raised

The following events are raised by this time-triggered transaction:

Table 145. Events Raised by the Post Inventory Match Transaction

Template
Transaction/Event Key Data Data Published Support?
POST_INVENTORY_MATCH POST_ YFS_postInventory No

INVENTORY_ | Match_output.xml
MATCH_dbd.txt

Process Order Hold Type

You can create a time-triggered transaction, derived from the
PROCESS_ORDER_HOLD_TYPE abstract transaction. It can be configured as the
processing transaction for one or more hold types. If an order is associated with a
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hold type that has a transaction configured as the processing transaction, a record
is created in the YFS_TASK_Q table for processing that transaction.

When the processing transaction is triggered, it checks the hold types that it can
process based on the hold type configuration. If no hold types can be processed,
the YFS_TASK_Q record is deleted. If some hold types can be processed, the
processOrderHold Type user exit is invoked with the list of hold types to be
processed. The processOrderHoldType user exit returns the list of hold types that
can be removed from the order.

The transaction then modifies the order and updates the order hold type list based
on the output returned by the processOrderHoldType user exit. If now no hold
types can be processed, the YFS_TASK_Q record is deleted. If some hold types can
still be processed, YFS_TASK_Q is updated with the next available date.

You can also call the processOrderHoldType user exit to add new hold types or
change the status of a hold type that is already applied to an order. For more
information about the processOrderHoldType user exit, see the Sterling Selling and
Fulfillment Foundation: Javadocs.

Attributes

The following are the attributes for this time-triggered transaction:

Table 146. Process Order Hold Type Attributes

Attribute Value

Base Transaction ID PROCESS_ORDER_HOLD_TYPE
Base Document Type Order

Base Process Type Order Fulfillment

Abstract Transaction Yes

APIs Called changeOrder

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 147. Process Order Hold Type Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval

Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID

Required in a multischema deployment where the
YFS_TASK_Q table may exist in multiple schemas. Runs the
agent for the colony.

Statistics Tracked

None.
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Pending Job Count
None
Events Raised

The following events are raised by this time-triggered transaction:

Table 148. Events Raised by Process Order Hold Type Transaction

Template
Transaction/Event |Raised when... Key Data Data Published |Support?
ON_SUCCESS On success modifyOrder_ | YFS_ORDER_ Yes *
dbd.txt CHANGE.ON_
SUCCESS.xml
ON_HOLD_TYPE |The status of a |modifyOrder_ |YFS_ON_ Yes
_STATUS_ hold type is dbd.txt HOLD_TYPE_
CHANGE changed. STATUS_
CHANGE.xml
ON_ORDER_ The status of a |modifyOrder_ | YFS_ON_ Yes
LINE_HOLD_ hold type is dbd.txt ORDER_LINE
TYPE_STATUS_ changed. _HOLD_TYPE
CHANGE _STATUS_
CHANGE.xml
* Note: Some of the elements and attributes are not template-driven. Refer to the xml for
element level details.

Process Work Order Hold Type

This time-triggered transaction is identical to the|Process Order Hold Type|
transaction, but it is used for work orders instead.

Attributes

The following are the attributes for this time-triggered transaction:

Table 149. Process Work Order Hold Type Attributes

Attribute Value

Base Transaction ID PROCESS_WO_ORDER_HOLD_TYPE
Base Document Type Work Order

Base Process Type VAS Process

Abstract Transaction Yes

APIs Called modifyWorkOrder

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 150. Process Work Order Hold Type Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.
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Table 150. Process Work Order Hold Type Parameters (continued)

Parameter Description
Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be

suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID

Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

None.

Pending Job Count

None

Events Raised

The following events are raised by this time-triggered transaction:

Table 151. Events Raised by Process Work Order Hold Type Transaction

Template
Transaction/Event | Raised when... Key Data Data Published |Support?
ON_SUCCESS On success workOrder_ VAS_MODIFY_ | Yes *
dbd.txt WORK_ORDER
.ON_SUCCESS.
xml
ON_HOLD_TYPE_ | The status of a |workOrder_ VAS_ON_HOLD | Yes
STATUS_ hold type is | dbd.txt _TYPE_STATUS
CHANGE changed. _CHANGE .xml

* Note: Some of the elements and attributes are not template driven. Refer to the xml for
elements level details.

Publish Negotiation Results

This transaction publishes the negotiated terms to the order.

Use this transaction in environments where an order must go through a

negotiation phase.

This transaction needs to be run after negotiation is completed.

Attributes

The following are the attributes for this time-triggered transaction:

Table 152. Publish Negotiation Results Attributes

Attribute

Value

Base Transaction ID

PUBLISH_ORD_NEGOTIATION
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Table 152. Publish Negotiation Results Attributes (continued)

Attribute Value

Base Document Type Order

Base Process Type Order Negotiation
Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 153. Publish Negotiation Results Criteria Parameters

Parameter Description

Required. Triggers the transaction. If left blank, it defaults to

Action

Get, the only valid value.
Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to

5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 154. Publish Negotiation Results Statistics

Statistic Name Description
NumNegotiationsProcessed Number of negotiations processed.
NumNegotiationsPublished Number of negotiations published.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

The following events are raised by this time-triggered transaction:

Table 155. Events Raised by Publish Negotiation Results Transaction

Template
Base Transaction Raised when... Key Data Data Published |Support?
PUBLISH_ORD On success Negotiation_dbd| YCP_get Yes *
_NEGOTIATION/ xt Negotiation
ON_SUCCESS Details_output.
xml
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Table 155. Events Raised by Publish Negotiation Results Transaction (continued)

Template
Base Transaction Raised when... Key Data Data Published |Support?
RECEIVE_ORD On success, when|Number of receiveOrder No

_NEGOTIATION/
ON_SUCCESS

DocumentType is
0001, EntityType
is ORDER.

concurrent time-
triggered
transactions

Negotiation_dbd.
txt

running.

* Note: Template used for this event is the same template used by the
getNegotiationDetails() API to form the output XML.

Release

This transaction releases orders to specific ship nodes, making sure that the
scheduled ship nodes have enough inventory to process the order.

This transaction should be invoked after the scheduling process.

For more details, see the information provided under the releaseOrder() API in
the Sterling Selling and Fulfillment Foundation: Javadocs.

If you run the combined ‘Schedule and Release' agent, do not also run the
individual Schedule or the individual Release agents.

Attributes

The following are the attributes for this time-triggered transaction:

Table 156. Release Attributes

Attribute Value
Base Transaction ID RELEASE
Base Document Type Order

Base Process Type

Order Fulfillment

APIs Called

releaseOrder()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 157. Release Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

IgnoreReleaseDate

Optional. Determines whether the schedule process should
ignore line release date criteria. Valid values are:

* Y - Releases line quantities regardless of release date criteria

* N - Default value. Releases line quantities only after release
date criteria have been met.
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Table 157. Release Criteria Parameters (continued)

Parameter Description

CheckInventory Optional. Determine whether inventory should be checked.
Valid values are:

* Y - Default value. Inventory needs to be checked.

* N - Inventory does not need to be checked.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 158. Release Criteria Statistics

Statistic Name Description
NumFutureDateFailures Number of orders did not attempt to release
because of future date failures.
NumOrdersAttempted Number of orders attempted to release.
NumOrdersCannotBeProcessed Number of orders did not attempt to release
Failures because of cannot be processed failures.
NumOrdersProcessed Number of orders processed.
NumOrdersReleased Number of orders released.
NumOrdersBackordered Number of orders backordered.
NumOrderLinesReleased Number of order lines released.
NumOrderLinesBackordered Number of order lines backordered.
NumReleasesCreated Number of order releases created.
NumOrdersCannotBeProcessed Number of orders that were not released due to
Failures process failure.

If the release process results in splitting of an order line, NumOrderLinesReleased,
NumOrderLinesBackordered, and NumOfReleasesCreated may result in more than
one count.

Pending Job Count
For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal

to (<=) the current date value in the YFS_Task_Q table, if tasks on hold are not
ready to be processed.

Events Raised

This transaction raises events as specified under the releaseOrder() API in the
Sterling Selling and Fulfillment Foundation: Javadocs.
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Route Shipment

This time-triggered transaction is used to route shipments and belongs to the
Outbound Shipment pipeline. It assigns the Carrier and Carrier Service codes for
the shipment based on the Routing Guide configured.

The Route Shipment transaction either includes shipments in an existing load or
creates a new load and includes the shipments in it.

Shipments can be consolidated to a load, only if the following conditions are met:

* Expected Ship Date - The expected ship date of the shipments must be less than
or equal to the must ship before date of the load.

* Expected Load Departure Date - The expected load departure date must be less
than or equal to the must ship before date of the shipments in the load.

The must ship before date is a date computed for the load, based on all
shipments present in the load. For example, if a load has three shipments with
their must ship before dates as 12.22.2005, 12.12.2005, and 12.19.2005 respectively,
then the must ship before date of the load is computed as 12.12.2005, as it is the
earliest of the three dates.

Attributes

The following are the attributes for this time-triggered transaction:

Table 159. Route Shipment

Attribute Value

Base Transaction ID ROUTE_SHIPMENT.0001

Base Document Type Order

Base Process Type ORDER_DELIVERY

Abstract Transaction No

APIs Called None

User Exits Called com.yantra.ydm.japi.ue.YDMOverrideDetermineRoutingUE
com.yantra.ydm.japi.ue.YDMBeforeDetermineRoutingUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 160. Route Shipment Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval

Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID

Required in a multischema deployment where
YFS_SHIPMENT table may exist in multiple schemas. Runs
the agent for the colony.
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Table 160. Route Shipment Criteria Parameters (continued)

Parameter Description

CollectPendingJobs If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 161. Route Shipment Statistics

Statistic Name Description

NumRouted Number of shipments routed.

Pending Job Count

For this transaction the pending job count is the number of records representing
the unheld orders that are available to be processed by the transaction with the
AVAILABLE_DATE value less than or equal to (<=) the current date value in the
YFS_Task_Q table.

Events Raised

The following events are raised by this time-triggered transaction:

Table 162. Events Raised by the Route Shipment Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS shipment_dbd.txt | YDM_ROUTE_SHIPMENT | Yes
.ON_SUCCESS.xml
ON_FAILURE shipment_dbd.txt | YDM_ROUTE_SHIPMENT | Yes
.ON_FAILURE.xml

However, note that the template name would read
<TransactionId>.ON_SUCCESS.xml.

Schedule

This transaction schedules orders to specific ship nodes making sure that the
scheduled ship nodes have enough inventory to process the order.

Run this transaction after order creation.

Do not run the individual Schedule or Release agents when running the combined
"Schedule and Release" agent.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 163. Schedule Attributes

Attribute Value

Base Transaction ID SCHEDULE

Base Document Type Order

Base Process Type Order Fulfillment
APIs Called scheduleOrder()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 164. Schedule Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

MaximumRecords

Determines the maximum number of possible solutions that
the Schedule Agent can find. This parameter may improve the
best solution found, but it also impacts the performance of this
agent.

If left blank or specified as 0 (zero), it defaults to 5.

OptimizationType

Optional. Determines the optimization rules to apply to the
scheduling process. Valid values are:

e 01 - Optimize on date (Default)
¢ 02 - Optimize on ship node priority

* 03 - Optimize on number of shipments

OrderFilter

Optional. Determines the types of orders to filter. Possible
values are:

* A - All orders (Default)
¢ B - Backorders only

* N - New orders only

ScheduleAndRelease

Optional. Notify the schedule process to release all releasable
line quantities. Valid values are:

* Y - Releases successfully scheduled line quantities.
* N - Default value. Only schedules line quantities.

Enabling this parameter does not validate hold types
configured for the release transaction.

IgnoreReleaseDate

Optional. Determines whether the schedule process should
ignore line release date criteria. Valid values are:

* Y - Releases line quantities regardless of release date criteria.

* N - Releases lines quantities only after release date criteria
have been met. Default.
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Table 164. Schedule Criteria Parameters (continued)

Parameter

Description

Next Task Queue Interval

Not used. This agent updates a failed task so that it is
suspended for the back order retry interval setup in the
appropriately scheduled rule.

ColonyID

Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 165. Schedule Statistics

Statistic Name

Description

NumPFutureDateFailures

Number of orders that Sterling Selling and
Fulfillment Foundation did not attempt to schedule
because of future date failures.

Failures can be caused by any of the following:

e If the OrderFilter is “B” (Backorders Only) and
there are no backordered or unscheduled lines.

e If the OrderFilter is “N” (New orders Only) and
there are some backordered or unscheduled lines.

* If order has order lines within only backordered
or unscheduled status and the status modify
timestamp is after the current time - the back
order wait period specified in the scheduling
rule.

NumOrdersAttempted

Number of orders attempted to schedule. This
statistic does not include the values for
NumFutureDateFailures and
NumOrdersCannotBeProcessedFailures statistics.

NumOrderLinesReleased

Number of order lines that have been released.

Failures

NumOrdersCannotBeProcessed Number of orders that Sterling Selling and

Fulfillment Foundation did not attempt to schedule
because of cannot be processed failures.

Failures can be caused by any of the following:

e The result of the
YFSCheckOrderBeforeProcessingUE user exit
returns as false.

* The Order has the HoldFlag attribute set to “Y".
e The Order has the SaleVoided attribute set to “Y'".

* The Order does not have PaymentStatus as
AUTHORIZED, INVOICED, PAID, nor
NOT_APPLICABLE.

NumOrdersCreated Number of orders created. This also includes the
number of procurement orders created.

NumOrderLinesCreated Number of order lines created.

NumOrdersProcessed Number of orders processed.
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Table 165. Schedule Statistics (continued)

Statistic Name Description
NumOrdersScheduled Number of orders that have at least one line that
was scheduled.
This includes scheduled lines in any status except
BACKORDER.
NumOrdersProcOrdersCreated Number of procurement orders created.
NumWorkOrdersCreated Number of work orders created.
NumOrdersBackordered Number of orders backordered.
NumOrderLinesScheduled Number of order lines scheduled.
NumOrderLinesBackordered Number of order lines backordered.
NumReleasesCreated Number of order releases created.

Pending Job Count

For this transaction the pending job count is the number of records representing
the unheld orders that are available to be processed by the transaction with the
AVAILABLE_DATE value less than or equal to (<=) the current date value in the
YFS_Task_Q table, if tasks on hold are not ready to be processed.

Events Raised

This transaction raises events as specified under the schedul eOrder() API in the
Sterling Selling and Fulfillment Foundation: Javadocs.

Providing Oracle Hints

You can provide Oracle Hints to increase the performance of the scheduleOrder
agent. The two hints that can be provided for each criteria ID of the scheduleOrder
agent are the Outer Hint and the Inner Hint. The Outer Hint is always used for the
YFS_TASK_Q table. The Inner Hint is used for the YFS_ORDER_HEADER table
only if the earlier hold functionality is used; otherwise, the Inner Hint is used for
the YFS_ORDER_RELEASE_STATUS table.

Insert the following entries in the yfs.properties file in order to enable Oracle
Hints:

1. Edit the <INSTALL_DIR>/properties/yfs.properties file.

2. Insert yfs.<agent criteria_id>.getjobs.hint.outer=/*+ parallel (YFS_TASK Q
8) full(yfs_ task_q) */

Insert yfs.<agent criteria_id>.getjobs.hint.inner=/*+ NL_SJ */

Send Invoice

This transaction publishes invoice data that can be directed to an external accounts
receivable system.

In environments that require an interface with accounts receivable systems, this

transaction needs to be scheduled. This transaction raises an event for an invoice
based on the following configuration at the following times in the order lifecycle:
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* Publish invoice at shipment creation - This implies that your accounts payable
system takes care of payment collection. Invoices can be published as soon as

they are created.

* Publish invoice after payment collection - This implies that the Console take care
of the payment collection. When payment is in the AT_COLLECT status and the
payment is not from an external system, an invoice is published only if the
entire payment amount is collected. If the payment is in the AT_CREATE status
or the payment is from an external system, the invoice is published
unconditionally.

Many of this transaction's elements and attributes are template driven. Refer to the
XML for element level details.

Attributes

The following are the attributes for this time-triggered transaction:

Table 166. Send Invoice Attributes

Attribute Value

Base Transaction ID SEND_INVOICE

Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called getOrderInvoiceDetails()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 167. Send Invoice Criteria Parameters

Parameter Description

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Action

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Number of Records To
Buffer

Required in a multischema deployment where a table may

ColonyID
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 168. Send Invoice Statistics

Statistic Name Description

NumlInvoicesSent Number of invoices sent.

Pending Job Count

For this transaction the pending job count is the number of order invoices in
created (“00”) status.
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Events Raised

The following events are raised by this time-triggered transaction:

Table 169. Events Raised by the Send Invoice Transaction

Template
Transaction/Event Key Data Data Published Support?
PUBLISH_INVOICE_ modifyOrder_dbd. | YFS_getOrderInvoice Yes
DETAIL txt and Details_output.xml
sendInvoice_dbd
Axt

Additional events may be raised by the getOrderInvoiceDetails() APIL For
detailed information about the events, see the details provided under this API in
the Sterling Selling and Fulfillment Foundation: Javadocs.

Send Item Changes

In integrated environments, this transaction publishes item data changes that are
directed to an external system.

When item changes occur in Sterling Selling and Fulfillment Foundation, they need
to be communicated to the external system.

The business process may require the synchronization of items all at once in a
batch. For example, at the end of each business day, the sendltemChanges agent
can be configured to synchronize items based on the synchronization logic. This
transaction retrieves all items that are not logical kit or dynamic physical kit items
and whose SyncTS is null or MaxModifyTS is greater than the SyncTS.

The MaxModifyTS of an item is updated with the current timestamp whenever an
item is modified. The transaction then retrieves detailed information about those
items and raises the ON_SUCCESS event. This event should be configured to
invoke the Send Item Changes action.

For more information about how this integration is implemented, see the Sterling
Selling and Fulfillment Foundation: Integration Guide.

Attributes

The following are the attributes for this time-triggered transaction:

Table 170. Send Item Changes Attributes

Attribute Value

Base Transaction ID SEND_ITEM_CHANGES
Base Document Type None

Base Process Type General

Abstract Transaction No

APIs Called None
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 171. Send Item Changes Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Organization Code Optional. The organization from which items are

synchronized. This field is blank by default.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

None.

Pending Job Count

For this transaction the pending job count is the number of items requiring
synchronization. This is determined for product items that are not logical kit or
dynamic physical kit items and whose SyncTS is null or MaxModifyTS is greater
than the SyncTS.

Events Raised

The following events are raised by this time-triggered transaction:

Table 172. Events Raised by the Send ltem Changes Transaction

Template
Transaction/Event Key Data Data Published Support?
ON_SUCCESS None YCM_SEND_ITEM_ Yes
CHANGES_ON_
SUCCESS. XML

Send Customer Changes

In integrated environments, this transaction publishes customer data changes that
are directed to an external system.

When customer changes occur in Sterling Selling and Fulfillment Foundation, they
need to be communicated to the external system.

The business process may require the synchronization of customers all at once in a
batch. For example, at the end of each business day, the sendltemChanges agent
can be configured to synchronize items based on the synchronization logic. This
transaction retrieves all customers that are consumers, have a user ID present, and
are required to synchronize. This transaction can also be used to complete the
initial synchronization of users between the two systems. For example, if an
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external system is already in place, and Sterling Selling and Fulfillment Foundation
is then added, the SendCustomerChanges agent synchronizes the users from the
external system.

The sendCustomerChanges agent also serves as a backup mechanism. If a
customer synchronization event fails, the agent automatically retries the
synchronization after a specified amount of time.

The MaxModifyTS of an customer is updated with the current timestamp
whenever an customer is modified, whenever syncTS is less than MaxModifyTS, or
when syncTS is null. The transaction then retrieves detailed information about
those customers and raises the ON_SUCCESS event. This event should be
configured to invoke the Send Customer Changes action.

For more information about how this integration is implemented, see the Sterling
Selling and Fulfillment Foundation: Integration Guide.

Attributes

The following are the attributes for this time-triggered transaction:

Table 173. Send Customer Changes Attributes

Attribute Value

Base Transaction ID SEND_CUSTOMER_CHANGES
Base Document Type None

Base Process Type General

Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 174. Send Customer Changes Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Organization Code Optional. The organization from which customers are

synchronized. This field is blank by default.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked
None.
Pending Job Count

For this transaction the pending job count is the number of customers requiring
synchronization. This is determined for customers that are consumers, have a user
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ID present, and are required to synchronize.
Events Raised

The following events are raised by this time-triggered transaction:

Table 175. Events Raised by the Send Customer Changes Transaction

Template
Transaction/Event Key Data Data Published Support?
SEND_CUSTOMER_ None YSC_SEND_CUSTOMER | Yes
CHANGES.ON_SUCCESS _CHANGES.ON_
SUCCESS. XML

Send Order

This transaction tries to raise the ON_SUCCESS event for an order whose
OrderHeaderKey is stored in the task queue object. The event is raised only if all
of the order lines of the order reach particular status(es) completely. That is, the
entire ORDERED_QTY of each line must be in the particular status(es). In addition
to raising the event, the line statuses are also changed to the drop statuses,
corresponding to the pickup statuses. The SendOrder transaction, derived from the
abstract transaction SEND_ORDER, should have the event, pickup, and drop
statuses configured. For more information, see the details provided under the
sendOrder() API in the Sterling Selling and Fulfillment Foundation: Javadocs.

If an order needs to be communicated to a third party, use this transaction.
The TransactionKey posted in the task object must be an instance of the Abstract

Transaction SEND_ORDER for the ProcessType associated with the Order.
Otherwise, an exception is thrown.

Attributes

The following are the attributes for this time-triggered transaction:

Table 176. Send Order Attributes

Attribute Value

Base Transaction ID SEND_ORDER
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction Yes

APIs Called sendOrder()

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 177. Send Order Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to

Get, the only valid value.
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Table 177. Send Order Criteria Parameters (continued)

Parameter Description
Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to

5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

None.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the sendOrder() API in the
Sterling Selling and Fulfillment Foundation: Javadocs.

Send Release
The Send Release Agent dispatches releases to ship nodes.

Attributes

The following are the attributes for this time-triggered transaction:

Table 178. Send Release Attributes

Attribute Value

Transaction Name Send Release

Transaction ID SHIP_ADVICE

Base Process Type Order Fulfillment

Abstract Transaction No

APIs Called com.yantra.yfs.agent. YFSWMSShip AdviceAgent

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 179. Send Release Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.
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Table 179. Send Release Criteria Parameters (continued)

Parameter Description
Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval |Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to

5 hours.

ColonyID Required in a multischema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 180. Send Release Statistics

Statistic Name Description
NumReleasesProcessed Number of order releases processed.
NumReleasesSent Number of order releases sent.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

The following events are raised by this time-triggered transaction:

Table 181. Events Raised by the Send Release Transaction

Transaction/Event Data Published

PUBLISH_SHIP_ADVICE YFS_publishShipAdvice_output.xml

Start Order Negotiation

This transaction creates the negotiations for orders that are configured to go
through the negotiation process.

Use this transaction in environments where an Order needs to go through a
Negotiation phase before it is released.

Attributes

The following are the attributes for this time-triggered transaction:

Table 182. Start Order Negotiation Attributes

Attribute Value

Base Transaction ID START_ORD_NEGOTIATION
Base Document Type Order

Base Process Type Order Fulfillment
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Table 182. Start Order Negotiation Attributes (continued)

Attribute Value

Abstract Transaction No

APIs Called createNegotiation()

User Exits Called YCPBeforeCreateNegotiationUE, YCPGetNegotiationNoUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 183. Start Order Negotiation Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to

5 hours.

Node Required. The ship node for which records are being
processed.

ColonyID Required in a multischema deployment where a table may

exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 184. Start Order Negotiation Statistics

Statistic Name Description
NumOrdersProcessed Number of orders processed.
NumNegotiationsCreated Number of negotiations created.

Pending Job Count

For this transaction the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

This transaction raises events as specified under the createNegotiation() API in
the Sterling Selling and Fulfillment Foundation: Javadocs.

Synchronize Colony Map

The Colony Map Synchronizer agent inserts or updates colony mappings of
organizations and users in the PLT_COLONY_MAP table. When you run the agent
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for the first time, it populates this table, which is a necessary step in upgrading to
multischema mode after installing or upgrading Sterling Selling and Fulfillment

Foundation.

For more information about upgrading to multischema mode, see the Sterling
Selling and Fulfillment Foundation: Multi-Tenant Enterprise Guide.

Attributes

The following are attributes for this time-triggered transaction:

Table 185. Colony Map Synchronizer Attributes

Attribute Value

Base Transaction ID COLONY_MAP_SYNC
Base Process Type General

Abstract Transaction No

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 186. Colony Map Synchronizer Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records to
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID

The colony to be synchronized.

Initially, you must run the agent on the DEFAULT colony
provided by the Sterling Selling and Fulfillment Foundation
installation so that it populates the PLT_COLONY_MAP table.
After this, you can run the agent on another ColonyID.

InsertDefaultMappings

If set to Y, users for which the colony cannot be determined
will be mapped to the colony for which the Colony Map
Synchronizer agent is run.

Statistics Tracked

None.

Pending Job Count

None.
Events Raised
None.

Tables Purged

None.

210 Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide




Update Best Match Region

The Update Best Match Region transaction manages the
YFS_REGION_BEST_MATCH table, which is used by Data Warehouse Analytics to
report best match region data. The best match region is defined by the following
five address attributes in person info records:

ADDRESS_LINE6
CITY

STATE
SHORT_ZIP_CODE
COUNTRY

Note: COUNTRY refers to Country/Region.

The agent for the Update Best Match Region transaction runs in two modes that
allow you to set up and update the YFS_REGION_BEST_MATCH table.

Attributes

The following are the attributes for this time-triggered transaction:

Table 187. Update Best Match Region Attributes

Attribute

Value

Base Transaction ID

UPDATE_BEST_MATCH_REGION

Base Document Type General
Base Process Type General
Abstract Transaction No
APIs Called None

User Exits Called

YSCGetShortZipCode UE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 188. Update Best Match Region Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If UpdateOnly = N, only distinct records are returned
per agent call. If left blank, it defaults to 1000.
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Table 188. Update Best Match Region Criteria Parameters (continued)

Parameter

Description

TableType

Required in a multischema deployment when YFS_Person_Info
table may exist in multiple schemas.

Valid Values: CONFIGURATION, TRANSACTION, MASTER.

If set to CONFIGURATION, the agent runs for the
YFS_Person_Info records associated with tables that have
TableType as CONFIGURATION; for example,
YFS_Organization, YFS_Ship_Node, and so forth.

If set to TRANSACTION, the agent runs for the
YFS_Person_Info records associated with tables that have
TableType as TRANSACTION; for example,
YFS_Order_Header, YFS_Shipment, and so forth.

Note that the agent would run for all TableTypes that exist in
the same schema as the one passed. For example, if set to
TRANSACTION, the agent would also run for
YFS_Person_Info records associated with tables that have
TableType as MASTER, since they reside in the same schema.

ColonyID

Required in a multi schema deployment where the
YFS_PERSON_INFO table may exist in multiple schemas.
Runs the agent for the colony.

UpdateOnly

Mode in which to run. Valid values are:

* N - Default value. Adds records from the
YFS_PERSON_INFO table to the
YFS_REGION_BEST_MATCH table and populates the
region key in the YFS_BEST_MATCH table. To perform the
initial setup of Best Match Region for Analytics, set
UpdateOnly to N.

* Y - Update mode. Updates region keys based on addresses
in YFS_REGION_BEST_MATCH. After performing the initial
setup of Best Match Region for Analytics, set this value to Y
to specify update mode.

LastPersonInfoKey

Optional. If UpdateOnly is set to N, LastPersonInfoKey
determines the first person info record to populate. If no key is
specified, the value defaults to Null.

LastRegionBest
MatchKey

Optional. If UpdateOnly is set to Y, LastRegionBestMatchKey
determines the first region best match key to update. If no key
is specified, the value defaults to Null.

Statistics Tracked
None.

Pending Job Count
None.

Events Raised

None.
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Tables Purged

None.

PopulateOwnershipTransferSummary
This method updates the YFS_OWNERSHIP_TRANSFER_SUMMARY table.

This transaction updates the YFS_OWNERSHIP_TRANSFER_SUMMARY table by
checking the records in YFS_INV_OWN_TRANSFER_RCD table.

It also updates the IS_STATISTICS_UPDATED to 'Y' in
YFS_INV_OWN_TRANSFER_RCD table after the record has been used by the
transaction.

Attributes

Following are the attributes for this time-triggered transaction:

Table 189. YFSPopulateOwnershipTransfer Attributes

Attribute Value

Base Transaction ID POPULATE_OWN_TRANS_SUMM
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

Criteria Parameters

Following are the criteria parameters for this transaction:

Table 190. YFSPopulateOwnershipTransfer Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, which is the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID Required in a multi schema deployment where the

YFS_OWNERSHIP_TRANSFER_SUMMARY and
YFS_INV_OWN_TRANSFER_RCD tables may exist in multiple
schemas. Runs the agent for the colony.

Statistics Tracked
None

Pending Job Count
None

Events Raised
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None

Time-Triggered Purge Transactions

There are several transactions that you can use to purge your database tables at
specific time intervals.

Purge transactions determine when a table should be purged by determining the
current date and subtracting the retention days specified by the purge. If the
timestamp on the table is less than or equal to (current day - retention days) the
table is purged.

In some cases, a purge may look at another field other than the table's timestamp.
These are pointed out in the documentation.

When an entity is being purged, the related or dependent information that is
present in other tables should be taken into consideration for purging along with
it. For example, if a sales order with live shipments is being purged, any cross
reference to that order is not accurate in the Order Shipment Console. As another
example, agents such as Purge Order and Purge Order History also purge the
records from extension tables, such as yfs_order_header_extension and
yfs_order_line_extension, as well as their associated histories.

Some of the statistics collected and tracked in Release 9.1 for time-triggered
transactions, monitors, and integration and application servers may change with
the next release of Sterling Selling and Fulfillment Foundation.

All Time-Triggered Purge Transactions have a CollectPendingJobs criteria
parameter. If this parameter is set to N, the agent does not collect information on
the pending jobs for that time-triggered transaction. This pending job information
is used for monitoring the monitor in the System Management Console.

By default, CollectPendingJobs is set to Y. It can be helpful to set it to N if one
particular time-triggered transaction is performing a significant amount of
getPendingJobs queries, and the overhead cost is too high.

Purge Strategy

The following recommendations should be taken into consideration when planning
a purge strategy for each purge transaction:

* Test purges by setting Live to 'N’.
* Turn on logging to test what is purged.

* Set up purge traces in the System Management Console and analyze the
information.

Configuring Purge Transaction Log Files
About this task
You can configure purges to write log files to a directory you specify. Each time
you run a particular purge, new data is appended to this file. If no file exists, one

is created.

To specify a purge log file directory:
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Procedure

1. Configure the yfs.purge.path property in the <INSTALL_DIR>/properties/
customer_overrides.properties file. For example, on UNIX you might specify
the log files to be written to the /app/yfs/1ogs/purges directory.

For additional information about overriding properties using the
customer_overrides.properties file, see the Sterling Selling and Fulfillment
Foundation: Properties Guide.

2. Run the <INSTALL_DIR>/bin/setupfiles.sh script on UNIX, or the
<INSTALL_DIR>/bin/setupfiles.cmd script on Windows.

Available Purges

This section contains details of all purge transactions in alphabetical order.
Access Token Purge

This purge removes access tokens from the system. If all of the following
conditions are met, the PLT_ACCESS_TOKEN table is picked up for purge:

* The access token is expired or is in inactive state.

* The last modified date is earlier than or equal to the current date minus the
purge criteria's retention days.

Attributes

The following are the attributes for this time-triggered transaction:

Table 191. Access Token Purge Attributes

Attribute Value

Base Transaction ID ACCESSTOKPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 192. Access Token Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

CollectPendingJobs If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the .

Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
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Table 192. Access Token Purge Criteria Parameters (continued)

Parameter Description

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 193. Access Token Purge Statistics

Statistic Name Description

NumA ccessTokenPurged Number of access token records purged.

Pending Job Count

For this transaction the pending job count is the number of records that can be
purged from the PLT_ACCESS_TOKEN table.

Events Raised
None.

Tables Purged
PLT_ACCESS_TOKEN
Capacity Purge

This purge removes capacity data from the system. This reduces the load on
frequently accessed tables.

Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the following

conditions are met, a capacity data gets picked up for purge:

 All resource pool standard capacity periods with effective to date earlier than or
equal to the current date minus the purge criteria's retention days.

* All resource pool overridden capacity with the capacity date earlier than or
equal to the current date minus the purge criteria's retention days.

* All resource pool capacity consumption with consumption date less than or
equal to the current date minus the purge criteria's retention days.

* All resource pool capacity consumption details where appointment date is
earlier than the system date minus the purge criteria's retention days (or
ManualReservationPurgeLeadDays for manually created reservations).
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* All resource pool capacity consumption details where expiration date has passed
and reservation Id is not blank.

Attributes

The following are the attributes for this time-triggered transaction:

Table 194. Capacity Purge Attributes

Attribute Value

Base Transaction ID CAPACITYPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 195. Capacity Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 196. Capacity Purge Statistics

Statistic Name Description

NumStdCapacityPeriodsPurged Number of standard capacity periods purged.
NumCapacityOverridesPurged Number of capacity overrides purged.
NumCapacityConsumptionsPurged |Number of capacity consumptions purged.
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Pending Job Count

For this transaction the pending job count is the total number of records that can
be purged from the YFS_RES_POOL_STD_CAPCTY_PERD,
YFS_RES_POOL_CAPCTY_OVERRIDE, YFS_RES_POOL_CONSMPTN_DTLS and
YFS_RES_POOL_CAPCTY_CONSMPTN tables.

Events Raised
None.
Tables Purged

The YFS_RES_POOL_STD_CAPCTY_PERD table is purged when
EFFECTIVE_TO_DATE <= (CurrentDate - LeadDays)

The YFS_RES_POOL_CAPCTY_OVERRIDE table is purged when
CAPACITY_DATE <= (CurrentDate - LeadDays)

The YFS_RES_POOL_CAPCTY_CONSMPTN table is purged when
CONSUMPTION_DATE <= (CurrentDate - LeadDays), or if a manual reservation
is taken, when CONSUMPTION_DATE <= (CurrentDate - Manual Reservation
Retention Days). When this table is purged, YFS_RES_POOL_CONSMPTN_DTLS is
also purged.

The YFS_RES_POOL_CONSMPTN_DTLS table is purged when
RESERVATION_EXPIRATION_DATE <= (CurrentDate - LeadDays)

Draft Order History Purge

This purge deletes data from history tables after a specified interval, which in turn,
reduces the load on frequently accessed tables.

You can use purge codes' pseudo-logic to analyze the purges. If the following
condition is met, a draft order is picked up for history purge:

* The last modified date of the draft order exceeds the retention day period.

All the enterprise using the Console must schedule purge transactions.

For more information about Additional Purge Criteria Based on Line Type, see the
Sterling Selling and Fulfillment Foundation: Distributed Order Management
Configuration Guide.

Note: The draft order must be purged and moved to the history tables before you
purge the draft order history tables. See [‘Draft Order Purge” on page 221

Sterling Selling and Fulfillment Foundation does not provide a transaction for draft
order history purges. If you are defining a transaction that purges draft order
history tables, refer to the following Criteria Parameters section for information
about the transaction criteria.

If you do not want to define your own transaction to purge draft order history
tables, you can use the Order Purge transaction and specify
DRAFTORDERHISTPRG for the PurgeCode. To configure the Order Purge
transaction for draft order history table purges, refer to [“Order Purge” on page 249
for more information.
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Criteria Parameters

The following are the criteria parameters for defining a draft order history

transaction:

Table 197. Draft Order History Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode

Required. Enterprise for which the Draft Order History Purge
has to be run. If not passed, all the enterprises are monitored.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Removes qualifying records from the
history tables that are listed in [Tables Purged

* N - Test mode. Determines the rows that are removed
without actually removing them.

PurgeCode

Required. Set to DRAFTORDERHISTPRG. Used for internal
calculations, such as determining retention days. Corresponds
to the PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked
None.

Events Raised
None.

Tables Purged

YFS_ANSWER_SET_TRAN_H

YFS_ANSWER_TRAN_H

YFS_CHARGE_TRAN_DIST_H

YFS_CHARGE_TRANSACTION_H

YFS_CREDIT_CARD_TRANSACTION_H

YFS_ENTITY_ADDRESS_H

YFS_HEADER_CHARGES_H

YFS_INSTRUCTION_DETAIL_H

YFS_INVOICE_COLLECTION_H

YFS_LINE_CHARGES_H
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YFS_NOTES_H
YFS_ORDER_AUDIT_DETAIL_H
YFS_ORDER_AUDIT_H
YFS_ORDER_AUDIT_LEVEL_H
YFS_ORDER_DATE_H
YFS_ORDER_HEADER_H
YFS_ORDER_HEADER_H_EXTENSION
YFS_ORDER_HOLD_TYPE_H
YFS_ORDER_HOLD_TYPE_LOG_H
YFS_ORDER_INVOICE_DETAIL_H
YFS_ORDER_INVOICE_H
YFS_ORDER_KIT_LINE_H
YFS_ORDER_KIT_LINE_SCHEDULE_H
YFS_ORDER_LINE_H
YFS_ORDER_LINE_H_EXTENSION
YFS_ORDER_LINE_OPTION_H
YFS_ORDER_LINE_REQ_TAG_H
YFS_ORDER_LINE_SCHEDULE_H
YFS_ORDER_PROD_SER_ASSOC_H
YFS_ORDER_RELEASE_H
YFS_ORDER_RELEASE_STATUS_H
YFS_ORDER_SER_PROD_ITEM_H
YFS_PAYMENT _H
YFS_PROMOTION_AWARD_H
YFS_PROMOTION_H
YFS_RECEIVING_DISCREPANCY_DTL_H
YFS_RECEIVING_DISCREPANCY_H

YFS_REFERENCE_TABLE_H
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YFS_TAX_BREAKUP_H
Draft Order Purge

This purge archives data into history tables after a specified interval, which in
turn, reduces the load on frequently accessed tables. For information about purging
draft orders from history tables, see [‘Draft Order History Purge” on page 218

Sterling Selling and Fulfillment Foundation does not provide a transaction for draft
order purges. If you are defining a transaction that purges draft orders, refer to the
following Criteria Parameters section for details about the transaction criteria.

If you do not want to define your own transaction to purge draft orders, you can
use the Order Purge transaction and specify DRAFTORDERPRG for the
PurgeCode. To configure the Order Purge transaction for draft order purges, refer
to ["Order Purge” on page 249| for more information.

All the enterprise using the Console must schedule purge transactions.

Draft orders are picked up by the agent for validation when the following
conditions are met:

* Draft order flag is set to Y.
* Modifyts is set for the retention date.

After the draft orders are picked up, each draft order is validated for purging
based on the following conditions:

* No eligible order release status records (records with a status larger than zero)
exist for the order.

* All the open child orders (derived, chained, return, exchange, or refund
fulfillment) for the order are already purged.

If a draft order meets the set of conditions for validation listed earlier, the agent
continues to verify the draft orders against the following criteria:

* Contains the Draft Created (1000) status, and all the extended Draft Created
statuses.

* Does not have an order release status record that does not meet the retention
days.

* The order's last modification should be before the lead time (in days) setup.

* In the case when an exchange order is part of a return order, the exchange order
should be purged from history tables before the return order is purged.

* In the case of an order line reservation, the draft order cannot be purged.

e If the Draft Order Payment Processing flag is set to N, the draft orders are
purged.

¢ If the Draft Order Payment Processing flag is set to Y and a charge exists on a
draft order, the draft order is not purged. However, authorizations are not
considered when validating draft orders for purge.

* For order lines, except service order lines:

— If the Seller inventory update is required, the Status Inventory Type has the
Update Seller Supply option turned on, and the Seller Supply Type is
Onhand, or blank. (The Seller Supply Type can also be a custom seller supply
type, with the Onhand Supply check box enabled.)

— If the Seller Demand Type is blank.
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— If the Buyer inventory update is required, and the Buyer Supply Type is

Onhand, or blank.

Criteria Parameters

The following are the criteria parameters for defining a draft order purge

transaction:

Table 198. Draft Order Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval

Optional. Specifies (in hours) how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

EnterpriseCode

Required. Enterprise for which the Draft Order Purge has to
be run. If not passed, all the enterprises are monitored.

When the EnterpriseCode is blank, the purge criteria
configured for the DEFAULT enterprise is used, and not the
purge criteria configured for the draft order's enterprise.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Purged} to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode

Required. Set to DRAFTORDERPRG. Used for internal
calculations, such as determining retention days. Corresponds
to the PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked
None.

Events Raised
None.

Tables Purged

YFS_ACTIVITY_DEMAND

YFS_ANSWER_SET_TRAN

YFS_ANSWER_TRAN

YFS_CHARGE_TRANSACTION

YFS_CHARGE_TRAN_DIST
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YFS_CREDIT_CARD_TRANSACTION
YFS_ENTITY_ADDRESS
YFS_HEADER_CHARGES
YFS_INSTRUCTION_DETAIL
YFS_INVOICE_COLLECTION
YFS_LINE_CHARGES
YFS_MONITOR_ALERT
YFS_NOTES

YFS_ORDER_AUDIT
YFS_ORDER_AUDIT_DETAIL
YFS_ORDER_AUDIT_LEVEL
YFS_ORDER_HEADER
YFS_ORDER_HEADER_EXTENSION
YFS_ORDER_HOLD_TYPE
YFS_ORDER_HOLD_TYPE_LOG
YFS_ORDER_INVOICE
YFS_ORDER_INVOICE_DETAIL
YFS_ORDER_KIT_LINE
YFS_ORDER_KIT_LINE_SCHEDULE
YFS_ORDER_LINE
YFS_ORDER_LINE_EXTENSION
YFS_ORDER_LINE_OPTION
YFS_ORDER_LINE_REQ TAG
YFS_ORDER_LINE_RESERVATION
YFS_ORDER_LINE_SCHEDULE
YFS_ORDER_LINE_SRC_CNTRL
YFS_ORDER_PROD_SER_ASSOC

YFS_ORDER_RELEASE
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YFS_ORDER_RELEASE STATUS
YFS_ORDER_SER_PROD_ITEM
YFS_ORDER_DATE

YFS_PAYMENT
YFS_PMNT_TRANS_ERROR
YFS_PROMOTION
YFS_PROMOTION_AWARD
YFS_RECEIVING_DISCREPANCY
YFS_RECEIVING_DISCREPANCY_DTL
YFS_REFERENCE_TABLE

YFS_TAX_BREAKUP
Delivery Plan Purge

This purge deletes delivery plans after they have completed their typical life cycle.
All the loads and shipments that are associated with the delivery plans should
have been purged before running this purge agent.

It purges all the delivery plans that have been marked as ‘Closed’ for a period
greater than the retention days specified in the criteria parameters and those that
do not have any shipments or loads. The order should have been moved to history
before the lead time (in days) setup.

Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, a delivery plan is picked up for purge:

¢ The delivery plan should be in the "Closed" status.
* The delivery plan should not be associated with any load or shipment.
 All orders associated with the delivery plan should be purged.

* The last modification performed on the delivery plan should fall before the lead
time (in days) setup.

Attributes

The following are the attributes for this time-triggered transaction:

Table 199. Delivery Plan Purge Attributes

Attribute Value

Base Transaction ID DELIVERYPLANPRG
Base Document Type Load

Base Process Type Load Execution
Abstract Transaction No
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Table 199. Delivery Plan Purge Attributes (continued)

Attribute Value
APIs Called None
User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 200. Delivery Plan Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Delivery Plan Purge needs

to be run. If not passed, then all enterprises are monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under |Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

BatchDelete Required. The method by which all records are deleted from
the table. Valid values are:

* Y - Default value. Records are deleted in batches.

* N - Records are deleted one by one.

ColonyID Required in a multi schema deployment where the
YFS_DELIVERY_PLAN table may exist in multiple schemas.
Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 201. Delivery Plan Purge Statistics

Statistic Name Description

NumDeliveryPlansPurged Number of delivery plans purged.

Pending Job Count

For this transaction the pending job count is the number of records that can be
purged from the YFS_DELIVERY_PLAN table.

7 Events Raised

None.
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Tables Purged
YFS_DELIVERY_PLAN
Export Table Purge

This purge removes export table data from the system. This reduces the load on
frequently accessed tables.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, the YFES_EXPORT table is picked up for purge:

* YFS_EXPORT records should be marked as processed (Status = 10).

* The last modified time should fall before the lead time (in days) setup.
This purge reads only the rules defined by the hub. Enterprise overridden rules
are not considered. This purge should be single threaded when you run it in
batch delete mode(BatchDelete=Y).

Any enterprise using the Application Console must schedule purge transactions.
Attributes

The following are the attributes for this time-triggered transaction:

Table 202. Export Table Purge Attributes

Attribute Value

Base Transaction ID EXPORTTBLPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 203. Export Table Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

¢ N - Test mode. Determines the rows that are moved to
history tables without actually moving them.
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Table 203. Export Table Purge Criteria Parameters (continued)

Parameter Description

BatchDelete Required. The method by which all records are deleted from
the table. Valid values are:

* Y - Records are deleted in batches.

* N - Default value. Records are deleted one by one.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

CollectPending]Jobs If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This
pending job information is used for monitoring the monitor
in the System Management Console.

ColonyID Required in a multi schema deployment where the
YFS_EXPORT table may exist in multiple schemas. Runs the
agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 204. Export Table Purge Statistics

Statistic Name Description

NumExportsPurged Number of exports purged.

Pending Job Count

For this transaction the pending job count is the number of records that can be
purged from the YFS_Export table.

Events Raised

None.

Tables Purged
YFS_EXPORT

Import Table Purge

This purge removes import table data from the system. This reduces the load on
frequently accessed tables.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, the YFS_IMPORT table is picked up for purge:

* YFS_IMPORT records should be marked as processed (Status = "10").

¢ The "last modified time" should fall before the lead time (in days) setup.
This purge reads only the rules defined by the hub. Enterprise overridden rules
are not considered. This purge should be single threaded when you run it in
batch delete mode(BatchDelete=Y).

Any enterprise using the Console must schedule purge transactions.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 205. Import Table Purge Attributes

Attribute Value

Base Transaction ID IMPORTTBLPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 206. Import Table Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

¢ N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

BatchDelete

Required. The method by which all records are deleted from
the table. Valid values are:

* Y - Records are deleted in batches.

* N - Default value. Records are deleted one by one.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

CollectPendingJobs

If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This
pending job information is used for monitoring the monitor
in the System Management Console.

ColonyID

Required in a multi schema deployment where the
YFS_IMPORT table may exist in multiple schemas. Runs the
agent for the colony.
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Statistics Tracked

The following statistics are tracked for this transaction:

Table 207. Import Table Purge Statistics

Statistic Name Description

NumImportsPurged Number of import tables purged.

Pending Job Count

For this transaction the pending job count is the number of records that can be
purged from the YFS_Import table.

Events Raised
None.
Tables Purged

YFS_IMPORT
Inventory Audit Purge

This purge removes inventory audit data from the system. This reduces the load
on frequently accessed tables.

Any enterprise using the Console must schedule purge transactions.

All inventory audits of the provided organization with modify timestamp earlier
than the current date minus the purge criteria's retention days can be configured to
be picked up by the Inventory Audit Purge.

You can use purge codes pseudo-logic to analyze purges. If the following condition
is met, an inventory audit record is picked up for purge:

* The inventory audit record's last modification is earlier than the current
timestamp minus the retention days.
Number of threads for this purge's agent criteria details must be set to 1. For
more information about agent criteria, see the Sterling Selling and Fulfillment
Foundation: Configuration Guide.

The following are the attributes for this time-triggered transaction:

Table 208. Inventory Audit Purge Attributes

Attribute Value

Base Transaction ID INVENTORYAUDITPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 209. Inventory Audit Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. The inventory organization for which the Inventory

Audit Purge needs to be run. If not passed, then all enterprises
are monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Table Purged| to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 210. Inventory Audit Statistics

Statistic Name Description

NumlInventoryAuditsPurged Number of inventory audits purged.

Pending Job Count

For this transaction the pending job count is the number of records that can be
purged from the YFS_Inventory_Audit table.

Events Raised

None.

Table Purged
YFS_INVENTORY_AUDIT

Inventory Purge

This purge removes inventory data from the system. This reduces the load on
frequently accessed tables. This purge does not take retention days into account
when purging.

You can use purge codes pseudo-logic to analyze purges.
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For YFS_INVENTORY_SUPPLY, if the following conditions are met, an inventory

supply is picked up for purge:

¢ Supply record has the same availability type as the node. For example, TRACK
or INFINITE.

* Supply record has 0 quantity.

¢ Supply record does not contain the supply type “INFO”.

For YFES_INVENTORY_DEMAND, if the following conditions are met, an
inventory demand is picked up for purge:

¢ Demand record has 0 quantity or lesser.

* Demand record does not have demand details as well as matching demand
record in YFS_INVENTORY_DEMAND_ ADDNL tables.

For YFS_INVENTORY_TAG, it is purged if the INVENTORY_TAG_KEY is not
used by any of the existing supply and demand.

For YFES_INVENTORY_RESERVATION, an inventory reservation is picked up for
purge if it meets the following conditions:

 Inventory reservation record has 0 quantity or ship date is earlier than the
system date minus the purge criteria's retention days.

For YFS_INVENTORY_NODE_CONTROL, it is purged if the
INV_PIC_INCORRECT_TILL_DATE is earlier than the current time stamp minus
the purge criteria's retention days.

For YFS_IBA_TRIGGER, it is purged if IBA_REQUIRED = 'N/,
IBA_RUN_REQUIRED = 'N', and LAST_IBA_PROCESSED_TS is earlier than the
current time stamp minus the purge criteria's retention days.

Any enterprise using the Console must schedule purge transactions.

Attributes

The following are the attributes for this time-triggered transaction:

Table 211. Inventory Purge Attributes

Attribute Value

Base Transaction ID INVENTORYPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 212. Inventory Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode The inventory organization for which the Inventory Purge

needs to be run.

Live Optional. Mode in which to run. Valid values are:

¢ Y - Default value. Moves qualifying records from the
regular tables listed under [[ables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 213. Inventory Purge Statistics

Statistic Name Description

NumlInventoryDemandsPurged Number of inventory demands purged.

NumInventoryNodeControlsPurged |Number of inventory node controls purged.

NumlInventoryReservationsPurged | Number of inventory reservations purged.

NumInventoryTagsPurged Number of inventory tags purged.
NumlItemBasedAllocationTriggers Number of item based allocation triggers purged.
Purged

Pending Job Count

For this transaction, the pending job count is the total number of records that can
be purged from the YFS_Inventory_Supply, YFS_Inventory_Demand,
YFS_Inventory_Tag, YFS_Inventory_Reservation, YFS_IBA_Trigger, and
YFS_Inventory_Node_Control tables.

Events Raised

None.
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Tables Purged
YFS_IBA_TRIGGER
YFS_INVENTORY_DEMAND
YFS_INVENTORY_TAG
YFS_INVENTORY_RESERVATION
YFS_INVENTORY_SUPPLY

YFS_INVENTORY_NODE_CONTROL
Inventory Supply Temp Purge

The Inventory Supply Temp purge agent cleans up the contents in the temporary
inventory tables generated by the process of synchronizing the Sterling Selling and
Fulfillment Foundation inventory picture with the actual inventory picture at the
nodes.

The node inventory picture is stored during the loading process into the
YFS_INVENTORY_SUPPLY_TEMP table. Once the synchronization phase is
complete and the YFS_INVENTORY_SUPPLY table has been updated, the
YFS_INVENTORY_SUPPLY_TEMP table needs to be purged, which is done
through this agent.

For more information about configuring the synchronization with node inventory,
see the Sterling Selling and Fulfillment Foundation: Global Inventory Visibility
Configuration Guide.

The Inventory Supply Temp purge agent is used to purge all records in the
YFS_INVENTORY_SUPPLY_TEMP table whose modify timestamp is less then
current time minus the purge criteria's retention days for a group of
YantraMessageGroupID.

Attributes

The following are the attributes for this time-triggered transaction:

Table 214. Inventory Supply Temp Purge Attributes

Attribute Value

Base Transaction ID SUPPLYTEMPPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called None
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 215. Inventory Supply Temp Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

e N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

EnterpriseCode

Optional. The inventory organization for which the Inventory
Supply Temp Purge needs to be run. If not passed, then all
enterprises are monitored.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where the
YFS_INVENTORY_SUPPLY_TEMP table may exist in multiple
schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 216. Inventory Supply Temp Purge Statistics

Statistic Name

Description

NumlInventorySupplyTempsPurged |Number of entries in the

YFS_INVENTORY_SUPPLY_TEMP table purged.

Pending Job Count

Number of unique YantraMessageGrouplDs from
YFS_INVENTORY_SUPPLY_TEMP table whose maximum modify timestamp is
less than current timestamp minus purge criteria's lead day.

Events Raised
None.

Tables Purged

YFS_INVENTORY_SUPPLY_TEMP
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Item Audit Purge

This purge removes the YFS_AUDIT table data from the system, which reduces the
load on frequently accessed tables. It purges records in the YFES_AUDIT and the
YFS_AUDIT_HEADER tables that meet the following conditions:

* YFS_AUDIT records that have ‘modifyts' greater than the retention days
specified and the records have the table name as "YFS_ITEM'.

* The last modified time is before the lead time (in days) setup.

When the enterprise modifies records in the YFS_ITEM table through the
Applications Manager, the YES_ITEM is audited and the audit records are inserted
in the YFS_AUDIT table. In order to clean up the audit records, this purge
transaction can be used.

Any enterprise using the Console must schedule purge transactions accordingly.
Attributes

The following are the attributes for this time-triggered transaction:

Table 217. Item Audit Purge Attributes
Attribute Value

Base Transaction ID

YFS_ITEM_AUDIT_PURGE

Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 218. Item Audit Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, the value
defaults to Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), this value defaults
to 5000.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Production mode. Deletes records from
the regular tables.

e N - Test mode.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where the
YFS_AUDIT and YFS_AUDIT_HEADER tables may exist in
multiple schemas. Runs the agent for the colony.
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Statistics Tracked

The following statistics are tracked for this transaction:

Table 219. Item Audit Purge Statistics

Statistic Name Description
NumlItemAuditRecords Number of item audit records purged.
Purged

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_AUDIT table that match the criteria values.

Events Raised

None.

Tables Purged

YFS_AUDIT, YFS_AUDIT_HEADER
Load History Purge

This purge deletes the load data from history tables after it completes its typical
lifecycle. This reduces the load on frequently accessed tables.

Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the last modification
made to the load is before the lead time (in days) is met, a load is picked up for

purge.

Before you run this transaction, ensure to purge loads and move them to history
tables. For more information about purging loads, see[“Load Purge” on page 238.|

Attributes

The following are the attributes for this time-triggered transaction:

Table 220. Load History Purge Attributes

Attribute Value

Base Transaction ID LOADHISTPRG
Base Document Type Load

Base Process Type Load Execution
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 221. Load History Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Load Purge needs to be

run. If not passed, all enterprises are monitored.

Live Optional. Mode in which to run. Valid values are:

¢ Y - Default value. Moves qualifying records from the
regular tables listed under [[ables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

Purge Code Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 222. Load History Purge Statistics

Statistic Name Description

NumLoadHistoriesPurged |Number of load histories purged.

NumLoadShipment Number of load shipment histories purged.
HistoriesPurged

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Load_H table.

Events Raised

None.

Tables Purged

YFS_LOAD_H

YFS_LOAD_STOP_H
YFS_LOAD_SHIPMENT_CHARGE_H

YFS_LOAD_STATUS_AUDIT_H
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YFS_SHIPMENT_CONTAINER_H

YFS_CONTAINER_ACTIVITY_H

YFS_LOADED_CONTAINER_H

YFS_LOAD_SHIPMENT_H

YFS_ADDITIONAL_DATE_H

YFS_LOAD_HOLD_TYPE_H

YFS_LOAD_HOLD_TYPE_LOG_H

Load Purge

This purge removes load data from the system. It picks up all loads that have been

marked as ‘Closed' and purges them. Empty Loads (for example, loads with no
shipments) are not considered for purge. As a part of this purge, the associated
child tables are also purged.

This is not a pipeline transaction. It also does not work from the task queue.

Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the following condition

is met, a load is picked up for purge:

* The Load's last modification should fall before the lead time (in days) setup.

Attributes

The following are the attributes for this time-triggered transaction:

Table 223. Load Purge Attributes

Attribute Value
Base Transaction ID LOADPRG
Base Document Type Load

Base Process Type

Load Execution

Abstract Transaction No
APIs Called None
User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 224. Load Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.
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Table 224. Load Purge Criteria Parameters (continued)

Parameter Description

EnterpriseCode Optional. Enterprise for which the Load Purge needs to be
run. If not passed, then all enterprises are monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 225. Load Purge Statistics

Statistic Name Description
NumLoadShipmentsPurged Number of load shipments purged.
NumLoadsPurged Number of loads purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Load table.

Events Raised

None.

Tables Purged

YFS_ADDITIONAL_DATE

YFS_LOAD

YFS_LOAD_HOLD_TYPE

YFS_LOAD_HOLD_TYPE_LOG

YFS_LOAD_STOP

YFS_LOAD_SHIPMENT

YFS_LOAD_SHIPMENT_CHARGES (charges that pertain to this load)

YFS_LOAD_STATUS_AUDIT
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YFS_LOADED_CONTAINER

YFS_SHIPMENT_CONTAINER

YFS_CONTAINER_ACTIVITY

Negotiation History Purge

This purge deletes negotiation history data from the system. This reduces the load
on frequently accessed tables. It purges data from the order negotiation history

tables.

You can use purge codes pseudo-logic to analyze purges. If the following condition
is met, a negotiation is picked up for history purge:

* The last modified date of the negotiation exceeds the retention day period.
Any enterprise using the Console must schedule purge transactions.

Attributes

The following are the attributes for this time-triggered transaction:

Table 226. Negotiation History Purge Attributes

Attribute Value

Base Transaction ID NEGOTIATIONHISTPRG
Base Document Type Order

Base Process Type Order Negotiation
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 227. Negotiation History Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Negotiation History Purge
needs to be run. If not passed, then all enterprises are
monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

e N - Test mode. Determines the rows that are moved to
history tables without actually moving them.
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Table 227. Negotiation History Purge Criteria Parameters (continued)

Parameter Description

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 228. Negotiation History Purge Statistics

Statistic Name Description

NumNegotiationHistoriesPurged Number of negotiation histories purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Negotiation_Hdr_H table.

Events Raised

None.

Tables Purged

YFS_AUDIT
YFS_NEGOTIATION_HDR_H
YFS_NEGOTIATION_LINE_H
YFS_RESPONSE_H
YFS_RESPONSE_HDR_H
YFS_RESPONSE_LINE_H

YFS_RESPONSE_LINE_DTL_H
Negotiation Purge

This purge archives data into history tables after it completes its typical lifecycle.
This reduces the load on frequently accessed tables. It works from the task queue
(YFS_TASK_Q) table.

You can use purge codes pseudo-logic to analyze purges. If the following condition

is met, a negotiation is picked up for purge:

* The last modification performed on the negotiation falls before the lead time (in
days) setup.

* The negotiation is in pickable status.
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Any enterprise using the Console must schedule purge transactions.
Attributes

The following are the attributes for this time-triggered transaction:

Table 229. Negotiation Purge Attributes

Attribute Value

Base Transaction ID ORD_NEGOTIATION_PURGE
Base Document Type Order

Base Process Type Order Negotiation

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 230. Negotiation Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Negotiation Purge needs to

be run. If not passed, then all enterprises are monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Next Task Queue Interval | Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 231. Negotiation Purge Statistics

Statistic Name Description

NumOrderNegotiationsPurged Number of order negotiations purged.
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Pending Job Count

For this transaction, the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised
None
Tables Purged

YFS_AUDIT

YFS_NEGOTIATION_HDR

YFS_NEGOTIATION_LINE

YFS_RESPONSE

YFS_RESPONSE_HDR

YFS_RESPONSE_LINE

YFS_RESPONSE_LINE_DTL

Opportunity History Purge

This transaction deletes tasks previously archived by the Opportunity Purge. See

[“Opportunity Purge” on page 245/

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, an opportunity that is previously purged by the opportunity
purge agent is picked up for history purge:

* The last modified date of the opportunity should exceed the retention day

period.

* The quote history is purged.

Attributes

The following are the attributes for this time-triggered transaction:

Table 232. Opportunity History Purge Attributes

Attribute Value
Base Transaction ID OPPORTUNITYHISTPRG
Base Document Type Opportunity

Base Process Type

Opportunity Fulfillment

Abstract Transaction No
APIs Called None
User Exits Called None
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 233. Opportunity History Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Live Optional. Mode in which to run. Defaults to N.

* Y - Default value. Removes qualifying records from the
history tables listed under [Tables Purged

e N- Test mode. Determines the rows that are removed
without actually removing them.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode

Optional. Enterprise for which the Opportunity History Purge
needs to be run. If not passed, then all enterprises are
monitored.

When the EnterpriseCode is blank, the purge criteria
configured for the DEFAULT enterprise is used; not the purge
criteria configured for the opportunity's enterprise.

CollectPending]Jobs

If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 234. Opportunity History Purge Statistics

Statistic Name

Description

NumOpportunityHistory
Purged

Number of opportunity histories purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_OPPORTUNITY_H table.

Events Raised

None.
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Tables Purged
YFS_OPPORTUNITY_H

YFS_OPPORTUNITY_H_EXTENSION
Opportunity Purge

This time-triggered transaction purges all the opportunities for a period greater
than the retention days specified in the Opportunity Purge criteria, and those
which are either in the status of cancelled or completed.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, an opportunity is picked up for purge:

* The last modified date of the opportunity should exceed the retention day
period.

* The quote associated with the opportunity should be purged.
* The opportunity should be in pickable status by the purge transaction.

Attributes

The following are the attributes for this time-triggered transaction:

Table 235. Opportunity Purge Attributes

Attribute Value

Base Transaction ID OPPORTUNITYPRG
Base Document Type Opportunity

Base Process Type Opportunity Fulfillment
Abstract Transaction No

APIs Called None

User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 236. Opportunity Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Live Optional. Mode in which to run. Defaults to Y.

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Purgedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
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Table 236. Opportunity Purge Criteria Parameters (continued)

Parameter Description

EnterpriseCode Optional. Enterprise for which the Opportunity Purge needs to
be run. If not passed, then all enterprises are monitored.

When the EnterpriseCode is blank, the purge criteria
configured for the DEFAULT enterprise is used; not the purge
criteria configured for the opportunity's enterprise.

CollectPendingJobs If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 237. Opportunity Purge Statistics

Statistic Name Description

NumOpportunityPurged Number of opportunities purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YES_OPPORTUNITY table.

Events Raised

None.

Tables Purged
YFS_OPPORTUNITY
YFS_OPPORTUNITY_EXTENSION

Order History Purge

This purge deletes data from history tables after it completes its typical lifecycle.
This reduces the load on frequently accessed tables.

The order should have been purged and moved into the history tables before you
can run this transaction. For more information about this, see I"Order Purge” on|
page 249.

You can use purge codes pseudo-logic to analyze purges. If the following condition
is met, an order is picked up for history purge:

¢ The last modified date of the order exceeds the retention day period.

Any enterprise using the Console must schedule purge transactions.
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For more information about Additional Purge Criteria Based on Line Type, see the
Sterling Selling and Fulfillment Foundation: Distributed Order Management
Configuration Guide.

Attributes

The following are the attributes for this time-triggered transaction:

Table 238. Order History Purge Attributes

Attribute Value

Base Transaction ID ORDERHISTPRG
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 239. Order History Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Order History Purge needs

to be run. If not passed, then all enterprises are monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Removes qualifying records from the
history tables listed under [Tables Purged

e N- Test mode. Determines the rows that are removed
without actually removing them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 240. Order History Purge Statistics

Statistic Name Description

NumOrderHistoriesPurged Number of order histories purged.
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Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Order_ HEADER_H table.

Events Raised

None.

Tables Purged
YFS_ANSWER_SET_TRAN_H
YFS_ANSWER_TRAN_H
YFS_CHARGE_TRAN_DIST_H
YFS_CHARGE_TRAN_REQUEST_H
YFS_CHARGE_TRAN_RQ_MAP_H
YFS_CHARGE_TRANSACTION_H
YFS_CREDIT_CARD_TRANSACTION_H
YFS_ENTITY_ADDRESS_H
YFS_HEADER_CHARGES_H
YFS_INSTRUCTION_DETAIL_H
YFS_INVOICE_COLLECTION_H
YFS_LINE_CHARGES_H
YFS_NOTES_H
YFS_ORDER_AUDIT_DETAIL_H
YFS_ORDER_AUDIT_H
YFES_ORDER_AUDIT_LEVEL_H
YFS_ORDER_DATE_H
YFS_ORDER_HEADER_H
YFS_ORDER_HEADER_H_EXTENSION
YFS_ORDER_HOLD_TYPE_H
YFS_ORDER_HOLD_TYPE_LOG_H
YFS_ORDER_INVOICE_DETAIL_H

YFS_ORDER_INVOICE_H
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YFS_ORDER_KIT_LINE_H
YFS_ORDER_KIT_LINE_SCHEDULE_H
YFS_ORDER_LINE_H
YFS_ORDER_LINE_H_EXTENSION
YFS_ORDER_LINE_OPTION_H
YFS_ORDER_LINE_REQ TAG_H
YFS_ORDER_LINE_SCHEDULE_H
YFS_ORDER_PROD_SER_ASSOC_H
YFS_ORDER_RELEASE_H
YFS_ORDER_RELEASE STATUS_H
YFS_ORDER_SER_PROD_ITEM_H
YFS_PAYMENT_H
YFS_PROMOTION_AWARD_H
YFS_PROMOTION_H
YFS_RECEIVING_DISCREPANCY_DTL_H
YFS_RECEIVING_DISCREPANCY_H
YFS_REFERENCE_TABLE_H
YFS_TAX_BREAKUP_H
YIC_BOM_HEADER_H
YIC_BOM_LINE_H
YIC_BOM_MESSAGE_H

YIC_BOM_PROP_H

Order Purge

This purge archives data into history tables after it completes its typical lifecycle.
To purge orders from history tables, see [“Order History Purge” on page 246/ This
reduces the load on frequently accessed tables. It works on a task queue. It picks
up the orders from YFS_TASK_Q table that are available for the transaction
PURGE.

If purge criteria are not met, AVAILABLE_DATE is calculated based on the modify
time stamp of the order in YFS_ORDER_HEADER table as well as the
YFS_TASK_Q table, whichever is maximum. To this value, retention days is added
to the new AVAILABLE DATE.
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This transaction depends on all lines of an order being in a status pickable by the
Purge transaction.

The following statuses are available for configuration to be picked up by Order
Purge:

* Draft Created (1000) and all extended Draft Created Statuses.

* Created (1100) and all extended Created statuses. These statuses are available
only for document types Sales Order, Purchase Order and Transfer Order.

* Released (3200) and all extended Released statuses.
 Shipped (3700) and all extended Shipped statuses.

* Completed (3700) and all extended Completed statuses. These statuses are
available only for the document type Master Order.

* Received (3900) and all extended Received statuses.
* Cancelled (9000) and all extended Cancelled statuses.
* Shorted (9020) and all extended Shorted statuses.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, an order is picked up for purge:

* All open child orders (derived, chained, return, exchange, procurement, or
refund fulfillment) for the order must already be purged.

* No pending transfer-out charges to another order exceeding the transfer-ins.
* No pending adjustment invoices.

An order is purged immediately if it meets the above three criteria and is
completely cancelled with payment collection complete.

For the purge agent to pick up a cancelled order, the payment status of the order
must be one of the following;:

* Paid
* Not Applicable

If an order does not meet any of the above criteria, continue checking for the
criteria given below:

* No order release status record that does not meet the retention days.
* It should be in the correct status for purge. For example,

— All service requests for the order should have Shipped or extended Shipped
status.

— The payment status for the order should be Paid or Not Applicable.
— It must not have any unpurged negotiations.
* For all order lines other than service request lines:

— If the Seller inventory update is required, the Status Inventory Type has the
“Update Seller Supply” option turned on, and the Seller Supply Type is
“Onhand”, or blank. (The Seller Supply Type can also be a custom seller
supply type with the “Onhand Supply” checkbox enabled.)

— If the Seller Demand Type is blank.

— If the Buyer inventory update is required and the Buyer Supply Type is
“Onhand”, or blank.

e The order's last modification should fall before the lead time (in days) setup.
* Any enterprise using the Console must schedule purge transactions.
* The order must not have a undelivered service line.
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* In the case of an exchange order for processing a return order, the exchange
order should be purged from history before the return order can be purged.

With no change to status inventory type, a in Shipped (3700) status or its extended
status is purged if the Buyer is not passed.

An order in Shipped status or extended Shipped status in the default pipeline is
not purged if the Buyer passed on the is tracking inventory. This prevents the
purging of the order relating to the pending supply for the Buyer tracking

inventory.

To purge such orders, the status inventory type for the Shipped or extended
Shipped status should be configured such that the Buyer Supply Type is
ONHAND for the status inventory type.

When the purge agent is run, the draft order without lines are purged to the order
history table. Once the purge history agent is run, the draft orders without lines

gets deleted permanently.

Attributes

The following are the attributes for this time-triggered transaction:

Table 241. Order Purge Attributes

Attribute Value

Base Transaction ID PURGE

Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 242. Order Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval

Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

EnterpriseCode

Optional. Enterprise for which the Order Purge needs to be
run. If not passed, then all enterprises are monitored.

When the EnterpriseCode is blank, the purge criteria
configured for the DEFAULT enterprise is used; not the purge
criteria configured for the order's enterprise.
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Table 242. Order Purge Criteria Parameters (continued)

Parameter Description

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Used for internal calculations, such as determining

retention days. Corresponds with the PurgeCode used in

Business Rules Purge Criteria. You can set this parameter to

the following values:

* DRAFTORDERHISTPRG to purge draft order information
from the order history tables.

* DRAFTORDERNOLINEHISTPRG to purge draft orders
without order lines from the order history tables.

* DRAFTORDERNOLINEPRG to purge draft orders that have
no order lines.

* DRAFTORDERPRG to purge draft order information and
archive it in the order history tables.

PurgeCode cannot be set to the value
ORDER_RELEASE_STATUS_PURGE.

AdditionalPurgeCode Optional. To purge order release status records, set this
parameter to ORDER_RELEASE_STATUS_PURGE.

For more information, see [“Order Release Status Purge” on|

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 243. Order Purge Statistics

Statistic Name Description
NumOrdersProcessed Number of order processed.
NumOrdersPurged Number of orders purged.

Pending Job Count

For this transaction, the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

None.
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Tables Purged
YFS_ACTIVITY_DEMAND
YFS_ANSWER_SET_TRAN
YFS_ANSWER_TRAN
YFS_CHARGE_TRANSACTION
YFS_CHARGE_TRAN_DIST
YFS_CHARGE_TRAN_REQUEST
YFS_CHARGE_TRAN_RQ_MAP
YFS_CREDIT_CARD_TRANSACTION
YFS_ENTITY_ADDRESS
YFS_HEADER_CHARGES
YFS_INSTRUCTION_DETAIL
YFS_INVOICE_COLLECTION
YFS_LINE_CHARGES
YFS_MONITOR_ALERT
YFS_NOTES

YFS_ORDER_AUDIT
YFS_ORDER_AUDIT_DETAIL
YFS_ORDER_AUDIT_LEVEL
YFS_ORDER_HEADER
YFS_ORDER_HEADER_EXTENSION
YFS_ORDER_HOLD_TYPE
YFS_ORDER_HOLD_TYPE_LOG
YFS_ORDER_INVOICE
YFS_ORDER_INVOICE_DETAIL
YFS_ORDER_KIT_LINE
YFS_ORDER_KIT_LINE_SCHEDULE

YFS_ORDER_LINE
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YFS_ORDER_LINE_EXTENSION
YFS_ORDER_LINE_OPTION
YFS_ORDER_LINE_REQ_TAG
YFS_ORDER_LINE_RESERVATION
YFS_ORDER_LINE_SCHEDULE
YFS_ORDER_LINE_SRC_CNTRL
YFS_ORDER_PROD_SER_ASSOC
YFS_ORDER_RELEASE
YFS_ORDER_RELEASE_STATUS
YFS_ORDER_SER_PROD_ITEM
YFS_ORDER_DATE
YFS_PAYMENT
YFS_PMNT_TRANS_ERROR
YFS_PROMOTION
YFS_PROMOTION_AWARD
YFS_RECEIVING_DISCREPANCY
YFS_RECEIVING_DISCREPANCY_DTL
YFS_REFERENCE_TABLE
YFS_TAX_BREAKUP
YIC_BOM_HEADER
YIC_BOM_LINE
YIC_BOM_MESSAGE

YIC_BOM_PROP
Order Release Status Purge

The Order Release Status Purge agent extends the Order Purge agent's capabilities
by purging order release status records before the Order Purge agent completely
purges data to history tables.

If an order meets the criteria for purging, the order release status records with

quantities of 0 are deleted from the YFS_ORDER_RELEASE_STATUS table and are
not put into the history table.
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When the Order Release Status Purge agent has completed, the task queue's
AVAILABLE_DATE is reset to the date specified by the purge criteria for Order
Purge. This enables the Order Purge agent to pick up and process an order as
necessary. Order Purge will continue to purge order release status records as usual.

If the following conditions are met, the Order Purge agent purges order release

status records:

* All conditions for Order Purge have been met. See [‘Order Purge” on page 249
for information about conditions for Order Purge.

* Order release records have 0 quantity.

* AdditionalPurgeCode in the Order Purge criteria is set to
ORDER_RELEASE_STATUS_PURGE.

* The order has been modified within the Order Purge lead days

AdditionalPurgeCode.

Criteria Parameters

The following are the criteria parameters for Order Release Status Purge:

Table 244. Order Release Status Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Next Task Queue Interval

Optional. Specifies in hours how long a failed task should be
suspended before it is considered for reprocessing. Defaults to
5 hours.

EnterpriseCode

Optional. Enterprise for which the Order Purge needs to be
run. If not passed, then all enterprises are monitored.

When the EnterpriseCode is blank, the purge criteria
configured for the DEFAULT enterprise is used; not the purge
criteria configured for the order's enterprise.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode

Required. To extend the Order Purge agent to purge order
release status records, set to ORDERPRG. Used for internal
calculations, such as determining retention days. You must
also set AddtionalPurgeCode.

AdditionalPurgeCode

Required. To purge order release status records, set this
parameter to ORDER_RELEASE_STATUS_PURGE.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

None.
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Pending Job Count

The pending job count is the number of records available to be processed by Order
Purge with the AVAILABLE_DATE value less than or equal to (<=) the current
date value in the YFS_Task_Q table.

Events Raised

None.

Tables Purged

YFS_ORDER_RELEASE_STATUS

Order Status Audit Purge

This purge removes order status audit data from the system. This reduces the load
on frequently accessed tables.

You can use purge codes pseudo-logic to analyze purges. If the following condition
is met, an order status audit is picked up for history purge:

* The last modified time falls before the lead time (in days) setup.
Any enterprise using the Console must schedule purge transactions.
This transaction needs to be run after negotiation is completed.
Attributes

The following are the attributes for this time-triggered transaction:

Table 245. Order Status Audit Purge Attributes

Attribute Value

Base Transaction ID STATUSAUDITPRG
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 246. Order Status Audit Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.
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Table 246. Order Status Audit Purge Criteria Parameters (continued)

Parameter Description

EnterpriseCode Optional. Enterprise for which the Order Status Audit Purge
needs to be run. If not passed, then all enterprises are
monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where the
YFS_STATUS_AUDIT Table may exist in multiple schemas.
Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 247. Order Status Audit Purge Statistics

Statistic Name Description

NumStatusAuditsPurged Number of status audits purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Status_Audit table.

Events Raised
None.
Tables Purged

YFS_STATUS_AUDIT
Organization Audit Purge

This purge removes the YFS_AUDIT table data from the system, which reduces the

load on frequently accessed tables. It purges records in the YFS_AUDIT and the

YFS_AUDIT_HEADER tables that meet the following conditions:

* The YFS_AUDIT records that have ‘modifyts' greater than the retention days
specified and the records have the table name as "YFS_ORGANIZATION'.

* The last modified time is before the lead time (in days) setup.

When the enterprise modifies records in the YFS_ORGANIZATION table through
the Applications Manager, the YFS_ORGANIZATION is audited and the audit
records are inserted in the YFS_AUDIT table. In order to clean up the audit
records, this purge transaction can be used.
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Any enterprise using the Console must schedule purge transactions.

Attributes

The following are the attributes for this time-triggered transaction:

Table 248. Organization Audit Purge Attributes

Attribute Value

Base Transaction ID YFS_ORGANIZATION_AUDIT_PURGE
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 249. Organization Audit Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, the value
defaults to Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), this value defaults
to 5000.

Live Optional. Mode in which to run. Valid values are:

¢ Y - Default value. Production mode. Deletes records from
the regular tables.

¢ N - Test mode.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds to the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where the
YFS_AUDIT and YFS_AUDIT_HEADER tables may exist in
multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 250. Organization Audit Purge Statistics

Statistic Name Description
NumOrganizationAudit Number of organization audit records purged.
RecordsPurged

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_AUDIT table that match the criteria values.
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Events Raised
None.
Tables Purged

YFS_AUDIT

YFS_AUDIT_HEADER

Person Info Purge

This purge gets a list of dates with the person info record count and sorts them by
date in ascending order. Then, based on the specified number of records to buffer
and the modify timestamp, it purges the applicable records and places them in the
YFS_PERSON_INFO_H table.

Attributes

The following are the attributes for this time-triggered transaction:

Table 251. Personinfo Purge Attributes

Attribute Value

Base Transaction ID PERSONINFOPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 252. Personinfo Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one

time.

e If left blank or the number specified is less than 10000, it
defaults to 10000.

¢ If the number specified is greater than 10000, then that
value is used.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under |Tables Purgedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

Chapter 20. Time-Triggered Transaction Reference 259



260

Table 252. Personinfo Purge Criteria Parameters (continued)

Parameter

Description

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

CollectPending]Jobs

If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

EnterpriseCode

Optional. Enterprise for which the PersonInfo Purge needs to
be run. If not passed, then all enterprises are monitored.

TableType

Required in a multi schema deployment when
YFS_Person_Info table may exist in multiple schemas.

Valid Values: CONFIGURATION, TRANSACTION, MASTER.

If set to CONFIGURATION, purge runs for the
YFS_Person_Info records associated with tables that have
TableType as CONFIGURATION; for example,
YFS_Organization, YFS_Ship_Node, and so forth.

If set to TRANSACTION, purge runs for the YFS_Person_Info
records associated with tables that have TableType as
TRANSACTION; for example, YFS_Order_Header,
YFS_Shipment, and so forth.

Note that purge would run for all TableTypes that exist in the
same schema as the one passed. For example, if set to
TRANSACTION, purge would also run for YFS_Person_Info
records associated with tables that have TableType as
MASTER, since they reside in the same schema.

ColonyID

Required in a multi schema deployment where the
YFS_PERSON_INFO table may exist in multiple schemas.
Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

If it is left blank or any number less than 10,000 is specified, then it defaults to
10,000. But if any number > 10,000 is specified, then that value would be used.

Table 253. Personinfo Purge Statistics

Statistic Name

Description

NumPersonInfoPurged

Number of person info records purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_PERSON_INFO table.

Events Raised

None.
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Tables Purged

YFS_PERSON_INFO

Person Info History Purge

This purge deletes records from the YFS_PERSON_INFO_H table based on the

purge criteria.

Attributes

The following are the attributes for this time-triggered transaction:

Table 254. Personinfo History Purge Attributes

Attribute Value

Base Transaction ID PERSONINFOHISTPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 255. Personinfo History Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one

time.

+ If left blank or the number specified is less than 10000, it
defaults to 10000.

* If the number specified is greater than 10000, then that
value is used.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

CollectPending]Jobs

If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

EnterpriseCode

Optional. Enterprise for which the PersonInfo Purge needs to
be run. If not passed, then all enterprises are monitored.
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Table 255. Personinfo History Purge Criteria Parameters (continued)

Parameter

Description

TableType

Required in a multi schema deployment when
YFS_Person_Info table may exist in multiple schemas.

Valid Values: CONFIGURATION, TRANSACTION, MASTER.

If set to CONFIGURATION, purge runs for the
YFS_Person_Info records associated with tables that have
TableType as CONFIGURATION; for example,
YFS_Organization, YFS_Ship_Node, and so forth.

If set to TRANSACTION, purge runs for the YFS_Person_Info
records associated with tables that have TableType as
TRANSACTION; for example, YFS_Order_Header,
YFS_Shipment, and so forth.

Note that purge would run for all TableTypes that exist in the
same schema as the one passed. For example, if set to
TRANSACTION, purge would also run for YFS_Person_Info
records associated with tables that have TableType as
MASTER, since they reside in the same schema.

ColonyID

Required in a multi schema deployment where the
YFS_PERSON_INFO_H table may exist in multiple schemas.
Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 256. Personinfo History Purge Statistics

Statistic Name

Description

Purged

NumPersonInfoHIstoryRecords Number of person info history records purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_PERSON_INFO_H table.

Events Raised

None.

Tables Purged
YFS_PERSON_INFO_H

Picklist Purge

This purge picks up all picklists that have been existing for a period greater than
the retention days specified in the criteria parameters and those that do not have

any shipments.

Any enterprise using the Console must schedule purge transactions.
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You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, a picklist is picked up for purge:

* The picklist should exist for more than the specified retention period.

* The picklist should not be associated with any shipment.

All shipments associated with the picklists should have been purged before

running this purge agent.

Attributes

The following are the attributes for this time-triggered transaction:

Table 257. Picklist Purge Attributes

Attribute Value

Base Transaction ID PICKLISTPRG
Base Document Type Order

Base Process Type Order Delivery
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 258. Picklist Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where the
YFS_PICK_LIST table may exist in multiple schemas. Runs the
agent for the colony.
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Statistics Tracked

The following statistics are tracked for this transaction:

Table 259. Picklist Purge Statistics

Statistic Name Description

NumPickListsPurged Number of picklists purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_PICK_LIST table.

Events Raised
None.

Tables Purged
YFS_PICK_LIST
Price List Purge

This purge removes price list data from the system. This reduces the load on
frequently accessed tables.

Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the following condition

is met, a price list is picked up for purge:

* The price list has valid date less than the current date minus the purge criteria's
retention days.

Attributes

The following are the attributes for this time-triggered transaction:

Table 260. Price List Purge Attributes

Attribute Value

Base Transaction ID PRICELISTPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 261. Price List Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

e N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 262. Price List Purge Statistics

Statistic Name Description

NumPriceSetsPurged Number of price sets purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Price_Set table.

Events Raised
None.
Tables Purged

YFS_PRICE_SET table with VALID_TILL_DATE less than or equal to (CurrentDate
- LeadDays)

YFS_PRICE_PROGRAM_DEFN
YFS_ITEM_PRICE_SET

YFS_ITEM_PRICE_SET_DTL
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Purge Catalog Mass Audits

This purge removes old audit records from the YFS_CATALOG_MASS_AUDIT
table. This table contains data about changes to the catalog due to assignment of
attributes and attribute values to categories and items. It also contains information
about inherited attributes and attribute values. The purge transaction finds mass
audit records that have not been modified in a specified number of days and
removes those records from the database.

Attributes

The following are the attributes for this time-triggered transaction:

Table 263. Purge Catalog Mass Audits Attributes

Attribute

Value

Base Transaction ID

CATALOG_MASS_AUDIT_PURGE

Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 264. Purge Catalog Mass Audits Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Live

Optional. Mode in which to run. Valid values are:

¢ Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

¢ N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where the
YFS_CATALOG_MASS_AUDIT table may exist in multiple
schemas. Runs the agent for the colony.
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Statistics Tracked

The following statistics are tracked for this transaction:

Table 265. Purge Catalog Mass Audits Statistics

Statistic Name Description

NumCatalogMassAuditsPurged Number of mass audit records purged.

Pending Job Count

For this transaction the pending job count is the total number of records that can
be purged from the YFS_CATALOG_MASS_AUDIT table.

Events Raised
None.
Tables Purged

The YFS_CATALOG_MASS_AUDIT table is purged when MODIFYTS <
(CurrentDate - LeadDays)

Receipt History Purge

This transaction deletes receipts previously archived by the Receipt Purge. See
[“Receipt Purge” on page 269.|

Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, a receipt that is previously purged by the receipt purge agent is
picked up for history purge:

* The last modified date of the receipt should exceed the retention day period.

¢ The shipment associated with the receipt should be purged from the history
table.

To purge a receipt history, ensure that the Receipts are closed and Shipments are
purged.

Attributes

The following are the attributes for this time-triggered transaction:

Table 266. Receipt History Purge Attributes

Attribute Value

Base Transaction ID RECEIPTHISTPRG
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 267. Receipt History Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Receipt History Purge
needs to be run. If not passed, then all enterprises are
monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Removes qualifying records from the
history tables listed under|Tables Purged

* N- Test mode. Determines the rows that are removed
without actually removing them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 268. Receipt History Purge Statistics

Statistic Name Description
NumReceiptLineHistoriesPurged Number of receipt line histories purged.
NumReceiptHistoriesPurged Number of receipt histories purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Receipt_Header_H table.

Events Raised

None.

Tables Purged
YFS_RECEIPT_HEADER_H
YFS_RECEIPT_LINE_H
YFS_RECEIPT_STATUS_AUDIT_H

YFS_INSTRUCTION_DETAIL_H
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Receipt Purge

This purge removes receipt data from the system. This reduces the load on
frequently accessed tables. This transaction picks up all receipts that are not open
and not pending inspection and archives them into their history tables. See
[“Receipt History Purge” on page 267.|It also archives and purges the receipt's child
tables.

This is a pipeline transaction and works from a task queue.
Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, a receipt is picked up for purge:

* The last modified date of the receipt should exceed the retention day period.
* The shipment associated with the receipt should be purged.

* The receipt should be in pickable status for the purge transaction.

¢ The value of the OpenReceiptFlag field should be set to "N".

* The receipt should not have pending inspections.

* There is no inventory in the warehouse for the receipt.

To purge a receipt, ensure that the receipts are closed and Shipments are purged.
Attributes

The following are the attributes for this time-triggered transaction:

Table 269. Receipt Purge Attributes

Attribute Value

Base Transaction ID RECEIPTPRG
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 270. Receipt Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Receipt Purge needs to be
run. If not passed, then all enterprises are monitored.
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Table 270. Receipt Purge Criteria Parameters (continued)

Parameter Description

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 271. Receipt Purge Statistics

Statistic Name Description
NumReceiptLinesPurged Number of Receipt Lines purged.
NumReceiptsPurged Number of receipts purged.

Pending Job Count

For this transaction, the pending job count is the number of records available to be
processed by the transaction with the AVAILABLE_DATE value less than or equal
to (<=) the current date value in the YFS_Task_Q table.

Events Raised

None.

Tables Purged

YFS_RECEIPT_HEADER

YFS_RECEIPT_LINE

YFS_RECEIPT_STATUS_AUDIT

YFS_INSTRUCTION_DETAIL

Reprocess Error Purge

This purge deletes reprocess errors from the system. This reduces the load on
frequently accessed tables.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, a YFS_REPROCESS_ERROR table is picked up for purge:

* YFS_REPROCESS_ERROR records with State = Fixed or Ignored is processed.
* The last modified time is earlier than the lead time (in days) setup.
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This purge reads only the rules defined by the hub. Enterprise overridden rules are

not considered.

Any enterprise using the Console must schedule purge transactions.

Attributes

The following are the attributes for this time-triggered transaction:

Table 272. Reprocess Error Purge Attributes

Attribute Value

Base Transaction ID REPROCESSPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 273. Reprocess Error Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where the
YFS_REPROCESS_ERROR table may exist in multiple
schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 274. Reprocess Error Purge Statistics

Statistic Name

Description

NumReprocessErrorsPurged Number of reprocess errors purged.
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Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_REPROCESS_ERROR table.

Events Raised

None.

Tables Purged

YFS_REPROCESS_ERROR

Reservation Purge

This purge deletes expired inventory reservations from the system. This reduces
the load on frequently accessed tables as well as free up demands that are

consumed by expired reservations.

You can use purge codes pseudo-logic to analyze purges. If the following condition

is met, all records in the YFS_INVENTORY_RESERVATION tables are picked up

for purge:

* EXPIRATION_DATE is earlier than the current date or quantity is less than or
equal to 0

Any enterprise using the Console must schedule purge transactions.
Attributes

The following are the attributes for this time-triggered transaction:

Table 275. Reservation Purge Attributes

Attribute Value

Base Transaction ID RESERVATIONPRG
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 276. Reservation Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.
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Table 276. Reservation Purge Criteria Parameters (continued)

Parameter Description

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where the
YFS_INVENTORY_RESERVATION table may exist in multiple
schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 277. Reservation Purge Statistics

Statistic Name Description

NumReservationsPurged Number of reservations purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_INVENTORY_RESERVATION table.

Events Raised

None.

Tables Purged
YFS_INVENTORY_RESERVATION
Shipment History Purge

This transaction deletes shipments previously archived by the Shipment Purge. See
[“Shipment Purge” on page 275.|

Any enterprise using the Console must schedule purge transactions.

You can use purge codes pseudo-logic to analyze purges. If the following condition
is met, all records archived in the history table are picked up for purge:

* The last modification performed on the shipment falls before the lead time (in
days) setup.

Orders related to the shipments should have been purged by order purge.
Shipments should have been closed by the Close Shipment transaction. See
Shipment” on page 162]
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Attributes

The following are the attributes for this time-triggered transaction:

Table 278. Shipment History Purge Attributes

Attribute Value
Base Transaction ID SHIPMENTHISTPRG
Base Document Type Order

Base Process Type

Order Delivery

Abstract Transaction No
APIs Called None
User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 279. Shipment History Purge Criteria Parameters

Parameter Description
Action Required. Triggers the transaction.
Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
EnterpriseCode Optional. Enterprise for which the Shipment History Purge
needs to be run. If not passed, then all enterprises are
monitored.
Live Optional. Mode in which to run. Valid values are:
* Y - Default value. Removes qualifying records from the
history tables listed under [Tables Purged
* N- Test mode. Determines the rows that are removed
without actually removing them.
PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.
ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 280. Shipment History Purge Statistics

Statistic Name

Description

NumShipmentHistoriesPurged

Number of shipment histories purged.

NumShipmentLineHistoriesPurged

Number of shipment line histories purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_Shipment_H table.
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Events Raised

None.

Tables Purged
YFS_ADDITIONAL_ATTRIBUTE_H
YFS_ADDITIONAL_DATE_H
YFS_AUDIT
YFS_CONTAINER_DETAILS_H
YFS_CONTAINER_STS_AUDIT_H
YFS_INSTRUCTION_DETAIL_H
YFS_SHIPMENT_CONTAINER_H
YFS_SHIPMENT_H
YFS_SHIPMENT_LINE_H
YFS_SHIPMENT_LINE_REQ_TAG_H
YFS_SHIPMENT_STATUS_AUDIT_H
YFS_SHIPMENT_TAG_SERIAL_H

YFS_CONTAINER_ACTIVITY_H
Shipment Purge

This purge removes shipment data from the system. This reduces the load on
frequently accessed tables. This transaction picks up all shipments that have been
marked as ‘Closed' and archives them into their history tables. See
History Purge” on page 2731t also archives and purges the shipment's child
tables.

This is not a pipeline transaction. It also does not work from the task queue.
Any enterprise using the Console must schedule purge transactions.
Orders related to the shipments should have been purged by order purge.

Shipments should have been closed by the Close Shipment transaction. For more
information, see [“Close Shipment” on page 162}

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, a shipment is picked up for purge:

* The last modification performed on the shipment should fall before the lead
time (in days) setup.

* The value of the ShipmentClosedFlag field should be set to "Y".

* The order record should already be purged for all shipment lines.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 281. Shipment Purge Attributes

Attribute Value

Base Transaction ID SHIPMENTPRG
Base Document Type Order

Base Process Type Order Delivery
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 282. Shipment Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction.

Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
Number of Days To Optional. Maximum number of days before the lead days the
Execute agent will look for shipment records to purge.

EnterpriseCode Optional. Enterprise for which the Shipment Purge needs to be

run. If not passed, then all enterprises are monitored.

Live Optional. Mode in which to run. Valid values are:

¢ Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 283. Shipment Purge Statistics

Statistic Name Description
NumShipmentsPurged Number of Shipments purged.
NumShipmentLinesPurged Number of Shipment Lines purged.
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Pending Job Count

For this transaction, the pending job count is the number of records that can be

purged from the YFS_Shipment table.
Events Raised

None.

Tables Purged
YFS_ADDITIONAL_ATTRIBUTES
YFS_ADDITIONAL_DATE
YFS_AUDIT
YFS_CONTAINER_DETAILS
YFS_LOAD_SHIPMENT_CHARGE
YFS_MONITOR_ALERT
YFS_SHIPMENT_CONTAINER
YFS_SHIPMENT_STATUS_AUDIT
YFS_SHIPMENT
YFS_INSTRUCTION_DETAIL
YFS_SHIPMENT_MONITOR_ALERT
YFS_HEADER_CHARGES
YFS_LINE_CHARGES
YFS_TAX_BREAKUP
YFS_SHIPMENT_HOLD_TYPE
YFS_SHIPMENT_HOLD_TYPE_LOG
YFS_SHIPMENT_TAG_SERIALS
YFS_SHIPMENT_LINE
YFS_SHIPMENT_LINE_REQ_TAG
YFS_ACTIVITY_DEMAND
YFS_CONTAINER_STS_AUDIT

YFS_CONTAINER_ACTIVITY
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Shipment Statistics Purge

This transaction deletes the shipment statistics from the table older than the
specified retention days.

This agent should be used whenever shipment statistics records need to be
removed, such as after application server restart.

You can use purge codes pseudo-logic to analyze purges. If the following condition
is met, the shipment statistics are picked up for purge:

* The last modification performed on the shipment statistics should fall before the
lead time (in days) setup.

Attributes

The following are the attributes for this time-triggered transaction:

Table 284. Shipment Statistics Purge Attributes

Attribute Value

Base Transaction ID PRG_SHIP_STATS
Base Document Type Order

Base Process Type Order Delivery
Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 285. Shipment Statistics Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Shipment Statistics Purge
needs to be run. If not passed, then all enterprises are
monitored.

Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the

corresponding history tables.

e N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where the
YFS_SHIPMENT_STATISTICS table may exist in multiple
schemas. Runs the agent for the colony.
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Statistics Parameters

The following are the statistics parameters for this transaction:

Table 286. Shipment Statistics Purge Statistics

Parameter Description

NumShipmentStatisticsPurged Number of shipment statistics purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_SHIPMENT_STATISTICS table.

Events Raised

None.

Tables Purged

YFS_SHIPMENT_STATISTICS

User Activity Purge

This purge deletes the user activity data from the system. It purges all records
older than the specified retention days, and those records which have a logged out

status. This purge must be single threaded when you run it in batch delete mode
(BatchDelete=Y).

The following limitation is assumed when purging records:

This purge do not purge any record if the Application server goes down abruptly
because the audit records of users connected to the application server at the time
when the server went down cannot be updated. As a result, the last activity time
or the logout time is not populated. The purge does not know whether the user
has logged out or still logged in. Therefore, you need to manually delete these
records.

The following are the attributes for this time-triggered transaction:

Table 287. User Activity Purge Attributes

Attribute Value
Base Transaction ID USERACTIVITYPRG
Base Document Type None
Base Process Type None
APIs Called None
User Exits Called None
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 288. User Activity Purge Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under to the corresponding history
tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

CollectPendingJobs

If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This
pending job information is used for monitoring the monitor
in the System Management Console.

Number of Records To
Buffer

Required. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 100.

BatchDelete

Required. The method by which all records are deleted from
the table. Valid values are:

¢ Y - Default value. Records are deleted in batches.

* N - Records are deleted one by one.

ColonyID

Required in a multi schema deployment where the
YFS_USER_ACTIVITY table may exist in multiple schemas.
Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 289. Statistics Purge Statistics

Statistic Name

Description

NumStatisticsPurged

Number of statistics purged

Pending Job Count

None.
Events Raised
None.

Tables Purged

YFS_USER_ACTIVITY
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User Activity Audit Purge

This purge removes user activity audit data from the system. It purges all records
older than the specified retention days. It purges only those records which have a
logged out status (records with a Login_Type of “T' or ‘N'). This purge should be

single threaded when you run it in batch delete mode(BatchDelete=Y).

The following limitation is assumed when purging records:

* This purge does not purge any records if the Application server goes down
abruptly because the audit records of users connected to application servers at
the time the server went down cannot be updated. As a result, the last activity
time or the logout time does not get populated and the purge does not know
whether the user was logged out or was still logged in. These records have to be

deleted manually.

The following are the attributes for this time-triggered transaction:

Table 290. User Activity Audit Purge Attributes

Attribute Value
Base Transaction ID USERACTAUDPURGE
Base Document Type None
Base Process Type None
APIs Called None
User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 291. User Activity Audit Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under to the corresponding history
tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

CollectPending]Jobs

If this parameter is set to "N", the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

Number of Records To
Buffer

Required. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 100.
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Table 291. User Activity Audit Purge Criteria Parameters (continued)

Parameter Description

BatchDelete Required. The method by which all records are deleted from
the table. Valid values are:

* Y - Default value. Records are deleted in batches.

* N - Records are deleted one by one.

ColonyID Required in a multi schema deployment where the
YFS_USER_ACT_AUDIT table may exist in multiple schemas.
Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 292. Statistics Purge Statistics

Statistic Name Description

NumStatisticsPurged Number of statistics purged

Pending Job Count
None.

Events Raised
None.

Tables Purged
YFS_USR_ACT_AUDIT

Work Order History Purge

This transaction deletes tasks previously archived by the Work Order Purge. See
[“Work Order Purge” on page 284

You can use purge codes pseudo-logic to analyze purges. If the last modified date
of the work order exceeds the retention day period, a work order that is previously
purged by the work order purge agent is picked up for history purge.

Attributes

The following are the attributes for this time-triggered transaction:

Table 293. Work Order History Purge Attributes

Attribute Value

Base Transaction ID WORK_ORDER_HISTORY_PURGE
Base Document Type Work Order

Base Process Type VAS

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE
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Criteria Parameters

The following are the criteria parameters for this transaction:

Table 294. Work Order History Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Live Optional. Mode in which to run. Defaults to N.

e Y - Default value. Removes qualifying records from the
history tables listed under [Tables Purged

* N- Test mode. Determines the rows that are removed
without actually removing them.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Node

Optional. Node for which the Work Order History Purge
needs to be run. If not passed, then all nodes are monitored.

AgentCriteriaGroup

Optional. Used to classify nodes. This value can be accepted
by Sterling Selling and Fulfillment Foundation time-triggered
transactions that only perform their tasks on the nodes with a
matching node transactional velocity value.

Valid values are: LOW, HIGH, and any additional values
defined by the Hub from Application Platform > System
Administration > Agent Criteria Groups.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 295. Work Order History Purge Statistics

Statistic Name

Description

NumWorkOrderHistoriesPurged Number of work order histories purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_WORK_ORDER_H table.

Events Raised

None.
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Tables Purged

YFS_AUDIT

YFS_WO_APPT_USER_H
YFS_WORK_ORDER_H
YFS_WORK_ORDER_APPT_H
YFS_WORK_ORDER_ACTIVITY_H
YFS_WORK_ORDER_ACTY_DTL_H
YFS_WORK_ORDER_AUDT_DTL_H
YFS_WORK_ORDER_COMPONENT_H
YFS_WORK_ORDER_COMP_TAG_H
YFS_WORK_ORDER_HOLD_TYPE_H
YFS_WORK_ORDER_HOLD_TYPE_LOG_H
YFS_WORK_ORDER_PROD_DEL_H
YFS_WORK_ORDER_SERVICE_LINE_H
YFS_WORK_ORDER_STS_AUDIT_H

YFS_WORK_ORDER_TAG_H
Work Order Purge

This time-triggered transaction purges all the work orders for a period greater than
the retention days specified in the Work Order Purge criteria and those, which are
either in the status of cancelled or completed.

You can use purge codes pseudo-logic to analyze purges. If the following
conditions are met, a work order is picked up for purge:

* The last modified date of the work order should exceed the retention day
period.

¢ The order associated with the work order should be purged.
¢ The work order should be in pickable status by the purge transaction.

Attributes

The following are the attributes for this time-triggered transaction:

Table 296. Work Order Purge Attributes

Attribute Value

Base Transaction ID WORK_ORDER_PURGE
Base Document Type Work Order

Base Process Type VAS
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Table 296. Work Order Purge Attributes (continued)

Attribute Value

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 297. Work Order Purge Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Live Optional. Mode in which to run. Defaults to Y.

* Y - Default value. Moves qualifying records from the
regular tables listed under |Tables Puréedl to the

corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
Node Optional. Node for which the Work Order Purge needs to be

run. If not passed, then all nodes are monitored.

AgentCriteriaGroup Optional. Used to classify nodes. This value can be accepted
by Sterling Selling and Fulfillment Foundation time-triggered
transactions that only perform their tasks on the nodes with a
matching node transactional velocity value.

Valid values are: LOW, HIGH, and any additional values
defined by the Hub from Application Platform > System
Administration > Agent Criteria Groups.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 298. Work Order Purge Statistics

Statistic Name Description

NumWorkOrdersPurged Number of work orders purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_WORK_ORDER table.
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Events Raised

None.

Tables Purged

YFS_AUDIT

YFS_WO_APPT_USER
YFS_WORK_ORDER
YFS_WORK_ORDER_ACTIVITY
YFS_WORK_ORDER_ACTY_DTL
YFS_WORK_ORDER_HOLD_TYPE
YFS_WORK_ORDER_HOLD_TYPE_LOG
YFS_WORK_ORDER_APPT
YFS_WORK_ORDER_AUDT_DTL
YFS_WORK_ORDER_COMPONENT
YFS_WORK_ORDER_COMP_TAG
YFS_WORK_ORDER_PROD_DEL
YFS_WORK_ORDER_SERVICE_LINE
YFS_WORK_ORDER_STS_AUDIT

YFS_WORK_ORDER_TAG
YFS Audit Purge

This purge removes the YFS_AUDIT table data from the system, which reduces the
load on frequently accessed tables. It purges records in the YFS_AUDIT and the
YFS_AUDIT_HEADER tables that meet the following conditions:

* YFS_AUDIT records that have ‘modifyts' greater than the retention days
specified and the value of table name matches in the YFS_AUDIT table.

* The last modified time is before the lead time (in days) setup.

The way you configure the YFS Audit Purge may have some effect on the
functioning of the Configuration Data Versioning Tool. For more information about
configuration of the Data Versioning Tool, see the Sterling Selling and Fulfillment
Foundation: Configuration Deployment Tool Guide.

When the enterprise extends the entities and sets the extended entities attribute
AuditTable="Y", the extended tables are audited and the audit records are inserted
in the YFS_AUDIT table. In order to clean up the audit records, this purge
transaction can be used.

Any enterprise using the Console must schedule purge transactions.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 299. YFS Audit Purge Attributes

Attribute Value

Base Transaction ID YFS_AUDIT_PURGE
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called YFSBeforePurgeUE

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 300. YFS Audit Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, this value
defaults to Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), this value defaults
to 5000.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Production mode. Deletes records from
the regular tables.

e N - Test mode.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

Table Name

Required. The table name for which the audit records need to
be purged.

TableType

Required in a multischema deployment when YFS_AUDIT
table may exist in multiple schemas.

Valid Values: CONFIGURATION, TRANSACTION, MASTER.

If set to CONFIGURATION, the agent runs for the
YFS_AUDIT records associated with tables that have
TableType as CONFIGURATION; for example,
YFS_Organization, YFS_Ship_Node, and so forth.

If set to TRANSACTION, the agent runs for the YFS_AUDIT
records associated with tables that have TableType as
TRANSACTION; for example, YFS_Order_Header,
YFS_Shipment, and so forth.

Note that the agent would run for all TableTypes that exist in
the same schema as the one passed. For example, if set to
TRANSACTION, the agent would also run for YFS_AUDIT
records associated with tables that have TableType as
MASTER, since they reside in the same schema.
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Table 300. YFS Audit Purge Criteria Parameters (continued)

Parameter Description

ColonyID Required in a multi schema deployment where the
YFS_AUDIT and YFS_AUDIT_HEADER tables may exist in
multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 301. YFS Audit Purge Statistics

Statistic Name Description

NumAuditRecordsPurged | Number of audit records purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the YFS_AUDIT table that match the criteria values.

Events Raised

None.

Tables Purged

YFS_AUDIT, YFS_AUDIT_HEADER

YFSInventoryOwnershipAudit Purge

This transaction purges all the records from YFS_INV_OWN_TRANSFER_RCD
prior to the lead days specified in criteria parameters.

Attributes

Following are the attributes for this time-triggered transaction:

Table 302. YFSInventoryOwnership Purge Attributes

Attribute Value

Base Transaction ID PURGE_INV_TRANSFR_RECORD
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None

User Exits Called None
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Criteria Parameters

Following are the criteria parameters for this transaction:

Table 303. YFSInventoryOwnership Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, this value
defaults to Get, which is the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), this value defaults
to 5000.

EnterpriseCode

Optional. The inventory organization for which the
YFSInventoryOwnership Audit Purge needs to run. If not
passed, all the enterprises are monitored.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Production mode. Deletes records from
the regular tables.

¢ N - Test mode.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds to the
PurgeCode used in the Business Rules Purge Criteria.

Lead Days

Number of days before the present date, the agent will purge
the records.

ColonyID

Required in a multi schema deployment where the
YFS_INV_OWN_TRANSFER_RCD table may exist in multiple
schemas. Runs the agent for the colony.

Statistics Tracked
None.

Pending Job Count
None.

Tables Purged

YFS_INV_OWN_TRANSFER_RCD

Password Reset Request Purge

This purge deletes password reset request data from the system.

You can use purge codes pseudo-logic to analyze purges.

Any enterprise using the Console must schedule purge transactions.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 304. Password Reset Request Purge Attributes

Attribute Value
Base Transaction ID None
Base Document Type General
Base Process Type General
Abstract Transaction No
APIs Called None
User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 305. Password Reset Request Purge Criteria Parameters

Parameter Description
Action Required. Triggers the transaction. If left blank, it defaults to

Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
Live Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under|Tables Puréedl to the
corresponding history tables.

e N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the

PurgeCode used in Business Rules Purge Criteria.

ColonyID Required in a multi schema deployment where the

PLT_PWD_REQ table may exist in multiple schemas. Runs the

agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 306. Password Reset Request Purge Statistics

Statistic Name

Description

NumPasswordRequestPurged Number of password requests purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the PLT_PWD_REQ table.
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Events Raised
None.
Tables Purged

PLT _PWD_REQ

User Login Failure Purge

This purge deletes data on number of failed login attempts of users from the

system.

You can use purge codes pseudo-logic to analyze purges.

Any enterprise using the Console must schedule purge transactions.

Attributes

The following are the attributes for this time-triggered transaction:

Table 307. User Login Failure Purge Attributes

Attribute Value
Base Transaction ID None
Base Document Type General
Base Process Type General
Abstract Transaction No
APIs Called None
User Exits Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 308. User Login Failure Purge Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Live

Optional. Mode in which to run. Valid values are:

* Y - Default value. Moves qualifying records from the
regular tables listed under [Tables Purged|to the
corresponding history tables.

* N - Test mode. Determines the rows that are moved to
history tables without actually moving them.

PurgeCode

Required. Cannot be modified. Used for internal calculations,
such as determining retention days. Corresponds with the
PurgeCode used in Business Rules Purge Criteria.

ColonyID

Required in a multi schema deployment where the
PLT_USER_LOGIN_FAILED table may exist in multiple
schemas. Runs the agent for the colony.
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Statistics Tracked

The following statistics are tracked for this transaction:

Table 309. User Login Failure Purge Statistics

Statistic Name Description

NumUserLoginFailPurged Number of failed login attempts purged.

Pending Job Count

For this transaction, the pending job count is the number of records that can be
purged from the PLT_USER_LOGIN_FAILED table.

Events Raised
None.
Tables Purged

PLT_USER_LOGIN_FAILED

Task Queue Syncher Time-Triggered Transactions

Many transactions use the task queue as their work repository. The workflow
manager automatically creates tasks for transactions to handle the next processing
step, as configured in your pipeline.

In some situations, the task queue repository may become out of date. For
example, when reconfiguring the processing pipeline while the pipeline is active,
the queue may go out of synch with the new pipeline configuration.

Alerts that indicate a halt in the lifecycle of a business document may indicate an
outdated task queue repository.

The task queue syncher transactions are designed to update the task queue
repository with the latest list of open tasks to be performed by each transaction,
based on the latest pipeline configuration.

Some of the statistics collected and tracked in Release 9.1 for time-triggered
transactions, monitors, and integration and application servers may change with
the next release.

Load Execution Task Queue Syncher

This transaction synchronizes the task queue for the load execution process type.

You can use the following pseudo-logic to analyze this time-triggered transaction.
If the following conditions are met, a task queue for the load execution process
type is synchronized:

* LOAD_CLOSED_FLAG of Load should not be 'Y'.
* Load should be in a status that is pickable by a transaction in the pipeline.
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* There should not be any Task Q record for the load, transaction combination in
the Task Q table. In this case, the system inserts one Task Q record for this load,
transaction combination with the current database time as the available date.

Attributes

The following are the attributes for this time-triggered transaction:

Table 310. Load Execution Task Queue Syncher Attributes

Attribute Value

Base Transaction ID TASK_QUEUE_SYNCHER_L_D
Base Document Type Load

Base Process Type Load Execution

Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 311. Load Execution Task Queue Syncher Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID Required in a multi schema deployment where a table may

exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 312. Load Execution Task Queue Syncher Statistics

Statistic Name Description

NumTasksCreated Number of tasks created.

Pending Job Count
None.
Events Raised

None.

Order Delivery Task Queue Syncher

This transaction synchronizes the order delivery process type.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 313. Order Delivery Task Queue Syncher Attributes

Attribute Value
Base Transaction ID TASK_QUEUE_SYNCHER_O_D
Base Document Type Order

Base Process Type

Order Delivery

Abstract Transaction

No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 314. Order Delivery Task Queue Syncher Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to

Get, the only valid value.

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Number of Records To
Buffer

Required in a multi schema deployment where a table may

ColonyID
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 315. Order Delivery Task Queue Syncher Statistics

Statistic Name Description

NumTasksCreated Number of tasks created.

Pending Job Count
None.
Events Raised

None.

Order Fulfillment Task Queue Syncher

This transaction synchronizes the order fulfillment process type.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 316. Order Fulfillment Task Queue Syncher Attributes

Attribute Value

Base Transaction ID TASK_QUEUE_SYNCHER_O_F
Base Document Type Order

Base Process Type Order Fulfillment

Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 317. Order Fulfillment Task Queue Syncher Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 318. Order Fulfillment Task Queue Syncher Statistics

Statistic Name

Description

NumTasksCreated

Number of tasks created.

Pending Job Count

None.
Events Raised

None.

Order Negotiation Task Queue Syncher

This transaction synchronizes the order negotiation process type.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 319. Order Negotiation Task Queue Syncher Attributes

Attribute Value

Base Transaction ID TASK_QUEUE_SYNCHER_O_N
Base Document Type Order

Base Process Type Order Negotiation

Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 320. Order Negotiation Task Queue Syncher Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to

Get, the only valid value.

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

Number of Records To
Buffer

Required in a multi schema deployment where a table may

ColonyID
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 321. Order Negotiation Task Queue Syncher Statistics

Statistic Name Description

NumTasksCreated Number of tasks created.

Pending Job Count
None.
Events Raised

None.

Quote Fulfillment Task Queue Syncher

This transaction synchronizes the quote fulfillment process type.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 322. Quote Fulfillment Task Queue Syncher Attributes

Attribute Value

Base Transaction ID TASK_QUEUE_SYNCHER_Q_F
Base Document Type Order

Base Process Type Quote Fulfillment

Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 323. Quote Fulfillment Task Queue Syncher Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 324. Quote Fulfillment Task Queue Syncher Statistics

Statistic Name

Description

NumTasksCreated

Number of tasks created.

Pending Job Count
None.
Events Raised

None.

Monitors

Monitors are transactions that watch for processes or circumstances that are out of
bounds and then raise alerts.

Some of the statistics collected and tracked in Release 9.1 for time-triggered
transactions, monitors, and integration and application servers may change with
the next release of Sterling Selling and Fulfillment Foundation.
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All Monitors have a CollectPending]obs criteria parameter. If this parameter is set
to N, the agent does not collect information on the pending jobs for that monitor.
This pending job information is used for monitoring the monitor in the System
Management Console. By default, CollectPendingJobs is set to Y. It can be helpful
to set it to N if one monitor is performing a significant amount of getPendingJobs
queries and the overhead cost is too high.

Availability Monitor

This time-triggered transaction monitors inventory availability. The Availability
Monitor raises global alerts when the available inventory falls below the
configured quantities on the current day, on subsequent days within the ATP time
frame, and on subsequent days outside of the ATP time frame. The quantities for
the days outside of the ATP time frame are determined by the maximum
monitoring days. Unlike the schedule and release transactions, the Availability
Monitor calculates the actual availability beyond the ATP horizon and does not

assume infinite inventory.

Attributes

The following are the attributes for this time-triggered transaction:

Table 325. Availability Monitor Attributes

Attribute

Value

Base Transaction ID

ATP_MONITOR

Base Document Type General
Base Process Type General
Abstract Transaction No
APIs Called None

Criteria Parameters

The following are the criteria parameters for this monitor:

Table 326. Availability Monitor Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it
defaults to Get, the only valid value.

MonitorOption Optional. Specifies how to monitor inventory. Valid

values are:
* 1 - current inventory

* 0 - inventory within and outside of the ATP time
frame. This is the default value.

Number of Records To Buffer

Optional. Number of records to retrieve and process
at one time. If left blank or specified as 0 (zero), it
defaults to 5000.

InventoryOrganizationCode

Optional. Valid owner inventory organization.
Organization to process in this run. If not passed,
all inventory organizations are processed.
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Table 326. Availability Monitor Criteria Parameters (continued)

Parameter Description

CollectPendingJobs If this parameter is set to N, the agent does not
collect information on the pending jobs for this
monitor. This pending job information is used for
monitoring the monitor in the System Management

Console.
Status The negotiation status you are monitoring.
ColonyID Required in a multi schema deployment where a

table may exist in multiple schemas. Runs the agent
for the colony.

Statistics Tracked
None.

Pending Job Count
None.

Events Raised

No events are raised. Individual actions associated with the monitoring rule are
run.

Data published to the actions is AVAILABILITY_MONITOR dbd.txt.

Exception Monitor

This time-triggered transaction monitors exceptions in your system as noted below.
It monitors the exceptions logged in the system and escalates these exceptions:

 If an exception has not been assigned to a user by a certain time
* If an exception has not been resolved by a certain time
e If the active size of the queue is more than a certain maximum size

In order to prevent re-alerts on exceptions during every run of the Exception
Monitor, specify a re-alert interval through Alert Management in the Applications
Manager. This attribute is associated with a queue and can be configured for each
queue.

Attributes

The following are the attributes for this time-triggered transaction:

Table 327. Exception Monitor Attributes

Attribute Value

Base Transaction ID EXCEPTION_MONITOR
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called None
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Criteria Parameters

The following are the criteria parameters for this monitor:

Table 328. Exception Monitor Criteria Parameters

Parameter Description

Action Required. Triggers the transaction.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

QueuelD Optional. Defines the Alert Queue into which exceptions from
this monitor are stored.

OrganizationCode Optional. Organization to process in this run. If not passed, all
inventory organizations are processed.

CollectPendingJobs If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

QueueGroup Optional. Defines the set of Queues for which the exceptions
will be monitored. If both Queueld and QueueGroup are
supplied, Queueld is ignored.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 329. Exception Monitor Statistics

Statistic Name Description

NumlInboxProcessed Number of alerts processed.

NumExceededQueueSizeAlerts Number of actions raised when the number of
unresolved alerts exceeds the queue's maximum
active size.

NumUnResolvedAlerts Number of actions raised when the unresolved
alert time of an alert exceeds the queue's resolution
time.

NumUnAssignedAlerts Number of actions raised when the unassigned
alert time of an alert exceeds the queue's
assignment time.

Pending Job Count
None.

Events Raised

No events are raised. Individual actions associated with the monitoring rule are

run.
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Inventory Monitor

This time-triggered transaction monitors inventory availability at ship node level. It
raises alerts at the ship node level when the available inventory exceeds or drops
below the configured quantities.

This monitor uses the OPEN_ORDER demand type to calculate available inventory
at a given node. All supplies assigned to a supply type that is considered by the
OPEN_ORDER demand type are considered. For more information about
configuring inventory supply and demand considerations, refer to the Sterling
Selling and Fulfillment Foundation: Global Inventory Visibility Configuration Guide.

Attributes

The following are the attributes for this time-triggered transaction:

Table 330. Inventory Monitor Attributes

Attribute Value

Base Transaction ID INVENTORY_MONITOR
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called checkAvailability()

Criteria Parameters

The following are the criteria parameters for this monitor:

Table 331. Inventory Monitor Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it
defaults to Get, the only valid value.

Number of Records To Buffer Optional. Number of records to retrieve and process
at one time. If left blank or specified as 0 (zero), it
defaults to 5000.

InventoryOrganizationCode Optional. Valid inventory owner organization.
Organization to process in this run. If not passed, all
inventory organizations are processed.

CollectPendingJobs If this parameter is set to N, the agent does not
collect information on the pending jobs for this
monitor. This pending job information is used for
monitoring the monitor in the System Management
Console.

AllowedOverriddenCriteria If this parameter is set to Y, the overriding value for
the agent criteria parameters can be provided in the
command line in the following format when
triggering the agent:

<AgentCriteriaAttribute>
<OverriddenValue>

For more information about passing these attributes,
see the Sterling Selling and Fulfillment Foundation:
Installation Guide
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Table 331. Inventory Monitor Criteria Parameters (continued)

Parameter Description

ShipNodes Optional. Comma-separated list of valid ship nodes
that should be processed in this run. If not passed,
all the ship nodes are processed.

ColonyID Required in a multi schema deployment where a
table may exist in multiple schemas. Runs the agent
for the colony.

Statistics Tracked
None.

Pending Job Count
None.

Events Raised

No events are raised. Individual actions associated with the monitoring rule are
run.

Data published to the actions is <INSTALL_DIR>/xapidocs/api_javadocs/dbd/
INVENTORY_MONITOR dbd.txt.

Negotiation Monitor

This time-triggered transaction alerts the Enterprise when a negotiation remains in
a particular status for a specific amount of time. This also monitors the negotiation
expiration date. This time-triggered transaction invokes the actions configured
against the negotiation statuses. Configure status Expired (2000) to monitor
negotiation expiration date.

Use this monitor in environments where Order or order release has to go through
a negotiation phase and you want to monitor the negotiation.

Attributes

The following are the attributes for this time-triggered transaction:

Table 332. Negotiation Monitor Attributes

Attribute Value

Base Transaction ID ORD_NEGOTIATION_MONITOR
Base Document Type Order

Base Process Type Order Negotiation

Abstract Transaction No

APIs Called None
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Criteria Parameters

The following are the criteria parameters for this monitor:

Table 333. Negotiation Monitor Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Negotiation Monitor needs
to be run. If not passed, then all enterprises are monitored.

CollectPending]Jobs If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

Status The negotiation status you are monitoring.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 334. Negotiation Monitor Statistics

Statistic Name

Description

NumNegotiationsProcessed

Number of negotiations processed.

NumNegotiationsRequiringAlert Number of negotiations which have at least one

alert raised.

Pending Job Count
None.
Events Raised

This invokes the actions ¢

onfigured against the negotiation statuses.

Key Data - Not Applicable.

Data Published - YCP_getNegotiationDetails_output.xml

Enhanced Order Monito

r

The enhanced order monitor enables you to monitor the following situations:
* Milestone x has not been reached y hours before a given date type.

* Milestone x has not been reached within y hours of a given date type.

* Milestone x has not been reached within y hours of milestone z.

* Milestone x has been reached y hours before a given date type.

¢ Milestone x has been reached within y hours of a given date type.

* Milestone x has been reached within y hours after milestone z.
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* The order has been in status x for y hours.

* Date type x is y hours before date type z.

* Date type x is y hours after date type z.

* The order has been in hold type x for y hours.

* The order has been in hold type x for y hours before date type z.

The order monitor can be configured to monitor the following system date types
for and Purchase Order document types:

¢ Actual Order Date - Read from the ORDER_DATE column of the
YFS_ORDER_HEADER table.

e Actual Next Iteration Date - Read from the NEXT _ITER_DATE column of the
YFS_ ORDER_HEADER table.

* Requested Ship Date - If there is an order release, read from the
REQ_SHIP_DATE column of the YFS_ORDER_RELEASE table. Otherwise, read
from the REQ_SHIP_DATE of the YFS_ORDER_LINE table.

* Expected Ship Date - Read from the EXPECTED_SHIPMENT_DATE column of
the YFS_ORDER_LINE_SCHEDULE table. If it is null, uses the same logic as
Requested Ship Date.

* Actual Ship Date - If the date is before 01/01/2500, read from he
EXPECTED_SHIPMENT_DATE column of the YFS_ORDER_LINE_SCHEDULE
table. If the date is on or after 01/01/2500, this date type is returned as null.

* Requested Delivery Date - If there is a release, read from the
REQ_DELIVERY_DATE column of the YFS_ORDER_RELEASE table.

* Expected Delivery Date - Read from the EXPECTED_DELIVERY_DATE column
of the YFS_ORDER_LINE_SCHEDULE table. If it is null, uses the same logic as
Requested Delivery Date.

* Actual Delivery Date - If the date is before 01/01/2500, read from he
EXPECTED_DELIVERY_DATE column of the YFS_ORDER_LINE_SCHEDULE
table. If the date is on or after 01/01/2500, this date type is returned as null.

For Order Fulfillment, Planned Order Execution, Reverse Logistics, and Purchase
Order Execution pipelines, the system defined dates such as Shipment and
Delivery are stored without a time component. Therefore when you configure a
rule using these dates, all time computations are carried out assuming they are
always 12:00:00 AM.

For more information about milestones, date types, and monitoring rules, refer to
the Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration
Guide, the Sterling Selling and Fulfillment Foundation: Distributed Order Management
Configuration Guide, and the Sterling Selling and Fulfillment Foundation: Reverse
Logistics Configuration Guide.

If you run the Enhanced Order Monitor, you must configure and run the Close
Order time-triggered transaction in all applicable pipelines. For more information
about the Close Order time-triggered transaction, see [‘Close Order” on page 159,

The same relog interval is used for all document types.
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Attributes

The following are the attributes for this time-triggered transaction:

Table 335. Enhanced Order Monitor Attributes

Attribute Value

Base Transaction ID ORDER_MONITOR_EX
Base Document Type Order

Base Process Type Order Fulfillment
Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this monitor:

Table 336. Enhanced Order Monitor Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode

Optional. Enterprise for which the Order Monitor needs to be
run. If not passed, then all enterprises are monitored.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this monitor:

Table 337. Enhanced Order Monitor Statistics

Statistic Name

Description

NumOrdersProcessed

Number of orders processed.

NumAlertsRaised

Number of alerts raised.

Pending Job Count

For this transaction the pending job count is the number of open orders with the
value of NEXT_ALERT_TS less than or equal to (<=) the current date.

Events Raised

The Enhance Order Monitor transaction raises the ON_AUTO_CANCEL event, but
does not cancel the order. A service on this event should be configured to cancel

the order.
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Table 338. Events Raised by the Enhanced Order Monitor Transaction

Template
Transaction/Event Key Data Data Published* Support?
ON_AUTO_CANCEL ORDER_ YFS_ORDER_MONITOR_EX.ON_ | Yes
MONITOR | AUTO_CANCEL.html
_dbd.txt

* These files are located in the following directory:
<INSTALL_DIR>/xapidocs/api_javadocs/XSD/HTML

Monitor Rule's Condition Template

If a monitor rule contains a condition, the <INSTALL_DIR>/repository/xapi/
template/source/smcfs/monitor/ORDER_MONITOR_EX_CONDITION.xml template file is
used to obtain both the order details and the evaluating monitor rule details. See
the provided <INSTALL_DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX CONDITION.xml.sample file for more details.

If the <INSTALL DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX_CONDITION.xml template file does not exist, the
MonitorConsolidation->Order element of the default monitor template, the
<INSTALL _DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX.xml file, is used.

If the default monitor template is used, the MonitorConsolidation->
Order->OrderStatuses-> OrderStatus-> MonitorRule element is ignored and is not
passed into the condition.

Enhanced Quote Monitor

The enhanced quote monitor enables you to monitor the following situations:
* Milestone x has not been reached y hours before a given date type.

* Milestone x has not been reached within y hours of a given date type.

* Milestone x has not been reached within y hours of milestone z.

* Milestone x has been reached y hours before a given date type.

* Milestone x has been reached within y hours of a given date type.

* Milestone x has been reached within y hours after milestone z.

* The order has been in status x for y hours.

* Date type x is y hours before date type z.

* Date type x is y hours after date type z.

The quote monitor can be configured to monitor the following system date types:

* Actual Expiration Date - Read from the EXPIRATION_DATE column of the
YFS_ORDER_HEADER table.

For more information about milestones, date types, and monitoring rules, refer to
the Sterling Selling and Fulfillment Foundation: Distributed Order Management
Configuration Guide.

If you run the Enhanced Quote Monitor, you must configure and run the Close
Order time-triggered transaction in all applicable pipelines. For more information
about the Close Order time-triggered transaction, see [‘Close Order” on page 159,
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The same relog interval is used for all document types.

Attributes

The following are the attributes for this time-triggered transaction:

Table 339. Enhanced Quote Monitor Attributes

Attribute Value

Transaction ID ORDER_MONITOR_EX.0015
Document Type Quote

Process Type Quote Fulfillment

Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this monitor:

Table 340. Enhanced Quote Monitor Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To
Buffer

Optional. Number of records to retrieve and process at one
time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode

Optional. Enterprise for which the Quote Monitor needs to be
run. If not passed, then all enterprises are monitored.

CollectPending]Jobs

If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

ColonyID

Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this monitor:

Table 341. Enhanced Quote Monitor Statistics

Statistic Name

Description

NumOrdersProcessed

Number of quotes processed.

NumAlertsRaised

Number of alerts raised.

Pending Job Count

For this transaction the pending job count is the number of open orders with the
value of NEXT_ALERT_TS less than or equal to (<=) the current date.
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Events Raised

No events are raised. Individual actions associated with the monitoring rule are
run.

The data published is ORDER_MONITOR_EX.0015.xml.
Monitor Rule's Condition Template

If a monitor rule contains a condition, the <INSTALL_DIR>/repository/xapi/
template/source/smcfs/monitor/ORDER_MONITOR_EX_CONDITION.xml template file is
used to obtain both the order details and the evaluating monitor rule details. See
the provided <INSTALL_DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX_CONDITION.xml.sample file for more details.

If the <INSTALL _DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX_CONDITION.xml template file does not exist, the
MonitorConsolidation->Order element of the default monitor template, the
<INSTALL_DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX.xml file, is used.

If the default monitor template is used, the MonitorConsolidation->
Order->OrderStatuses-> OrderStatus-> MonitorRule element is ignored and is not
passed into the condition.

Enhanced Return Monitor

The enhanced return monitor allows you to monitor the following situations:
* Milestone x has not been reached y hours before a given date type.

* Milestone x has not been reached within y hours of a given date type.

* Milestone x has not been reached within y hours of milestone z.

* Milestone x has been reached y hours before a given date type.

* Milestone x has been reached within y hours of a given date type.

* Milestone x has been reached within y hours after milestone z.

* The order has been in status x for y hours.

* Date type x is y hours before date type z.

e Date type x is y hours after date type z.

The enhanced return monitor can be configured to monitor the following system
date types:

¢ Actual Order Date - Read from the ORDER_DATE column of the
YFS_ORDER_HEADER table

* Requested Ship Date - If there is an order release, read from the
REQ_SHIP_DATE column of the YFS_ORDER_RELEASE table. Otherwise, read
from the REQ_SHIP_DATE of the YFS_ORDER_LINE table.

* Expected Ship Date - Read from the EXPECTED_SHIPMENT_DATE column of
the YFS_ORDER_LINE_SCHEDULE table. If it is null, uses the same logic as
Requested Ship Date.

* Actual Ship Date - If the date is before 01/01/2500, read from he
EXPECTED_SHIPMENT_DATE column of the YFS_ ORDER_LINE_SCHEDULE
table. If the date is on or after 01/01/2500, this date type is returned as null.
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¢ Requested Delivery Date - If there is a release, read from the
REQ_DELIVERY_DATE column of the YFS_ORDER_RELEASE table. Otherwise,
read from the REQ_DELIVERY_DATE of the YFS_ORDER_LINE table.

* Expected Delivery Date - Read from the EXPECTED_DELIVERY_DATE column
of the YFS_ORDER_LINE_SCHEDULE table. If it is null, uses the same logic as
Requested Delivery Date.

* Actual Delivery Date - If the date is before 01/01/2500, read from he
EXPECTED_DELIVERY_DATE column of the YFS_ORDER_LINE_SCHEDULE
table. If the date is on or after 01/01/2500, this date type is returned as null.

For Order Fulfillment, Planned Order Execution, Reverse Logistics, and Purchase
Order Execution pipelines, the system defined dates such as Shipment and
Delivery are stored without a time component. Therefore when you configure a
rule using these dates, all time computations are carried out assuming they are
always 12:00:00 AM.

For more information about milestones, date types, and monitoring rules, refer to
the Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration
Guide, the Sterling Selling and Fulfillment Foundation: Distributed Order Management
Configuration Guide, and the Sterling Selling and Fulfillment Foundation: Reverse
Logistics Configuration Guide.

If you run the Enhanced Return Monitor, you must configure and run the Close
Order time-triggered transaction in all applicable pipelines. For more information
about the Close Order time-triggered transaction, see [‘Close Order” on page 159.|

The same relog interval is used for all document types.
Attributes

The following are the attributes for this time-triggered transaction:

Table 342. Enhanced Order Monitor Attributes

Attribute Value

Base Transaction ID RETURN_MONITOR_EX
Base Document Type Return Order

Base Process Type Reverse Logistics
Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this monitor:

Table 343. Enhanced Order Monitor Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Order Monitor needs to be

run. If not passed, then all enterprises are monitored.
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Table 343. Enhanced Order Monitor Criteria Parameters (continued)

Parameter Description

FromStatus Optional. Statuses to monitor that are greater than or equal to
the passed status.

ToStatus Optional. Statuses to monitor that are less than or equal to the
passed status.

CollectPending]Jobs If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this monitor:

Table 344. Enhanced Order Monitor Statistics

Statistic Name Description
NumOrdersProcessed Number of orders processed.
NumAlertsRaised Number of alerts raised.

Pending Job Count

For this transaction the pending job count is the number of open orders with the
value of NEXT_ALERT_TS less than or equal to (<=) the current date.

Events Raised

No events are raised. Individual actions associated with the monitoring rule are
run.

The data published is RETURN_MONITOR_EX.xml.
Monitor Rule's Condition Template

If a monitor rule contains a condition, the <INSTALL_DIR>/repository/xapi/
template/source/smcfs/monitor/ORDER_MONITOR_EX_CONDITION.xml template file is
used to obtain both the order details and the evaluating monitor rule details. See
the provided <INSTALL_DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX_CONDITION.xml.sample file for more details.

If the <INSTALL DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX_CONDITION.xml template file does not exist, the
MonitorConsolidation->Order element of the default monitor template, the
<INSTALL DIR>/repository/xapi/template/source/smcfs/monitor/
ORDER_MONITOR_EX.xml file, is used.

If the default monitor template is used, the MonitorConsolidation-> Order->

OrderStatuses-> OrderStatus-> MonitorRule element is ignored and is not passed
into the condition.
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Real-time Availability Monitor

The Real-time Availability Monitor time-triggered transaction monitors the
inventory availability of inventory items. It can be configured to raise the
REALTIME_AVAILABILITY_CHANGE event when the inventory level for a given item
changes between the thresholds defined in the Applications Manager in the Global
Inventory Visibility module.

It can be run in three modes:

* Activity Based: Raises the event in real time every time an item goes above or
below one of the thresholds.

* Quick Sync: Re-sends the most recently published inventory availability
information.

* Full Sync: Monitors all of the items regardless of activity and publishes the
inventory information for all of the items.

In all cases, the percentage of future inventory availability is used for considering
inventory availability at retrieval time. For more information about future
inventory availability, see the Sterling Selling and Fulfillment Foundation: Global
Inventory Visibility Configuration Guide.

Demand of type OPEN_ORDER is used in getting the inventory availability
picture. If sourcing is maintained, the Real-time Availability Monitor can either
monitor the total availability across nodes or the availability at individual nodes.
Inventory items without an Availability Monitor rule, or with a rule that is
disabled, are unable to be processed by this time-triggered transaction.

If item information is not available on the system, such as when inventory between
databases is not in sync, default inventory monitor rules can be configured so that
monitoring will proceed. Setting these default inventory monitor rules also ensures
that inventory activity will be recorded when the system is running in
activity-based mode.

When monitoring the total availability across nodes, the Real-time Availability
Monitor monitors all nodes in the default distribution group of the inventory
organization.

When monitoring the availability at individual nodes, the Real-time Availability
Monitor monitors all nodes in a specified distribution group. For more information
about configuring distribution groups and node-level inventory monitoring, see the
Sterling Selling and Fulfillment Foundation: Global Inventory Visibility Configuration
Guide.

If configured, the Real-time Availability Monitor also considers the onhand and
future inventory availability safety factor during monitoring. For more information
about the inventory availability safety factors and the findInventory() API, see the
Sterling Selling and Fulfillment Foundation: Global Inventory Visibility Configuration
Guide and the Sterling Selling and Fulfillment Foundation: Javadocs.

When the onhand quantity is greater than the configured low threshold, the
REALTIME_ONHAND alert type is raised, and the alert level is based on the onhand

quantity.

When the onhand quantity falls below the configured low threshold, the
REALTIME_FUTURE_MAX alert type is raised, and the alert level is based on the total
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future supply (FutureAvailableQuantity) with FirstFutureAvailableDate set to
the date on which the first future supply is available, and FutureAvailableDate set
to the date on which the maximum future supply is available.

When the Real-time Availability Monitor is run in activity based mode, changing
one of the thresholds of an inventory item does not cause the agent to monitor it
unless there is a change in activity. For example, if item I with available quantity
700 is being monitored with a low threshold of 600, and the low threshold is then
changed to 1000, no event is published unless there is change in I's activity. In
order to ensure that in such a scenario I is not left unmonitored, call the
createInventoryActivity API when changing a monitoring rule for an item.

Computing and Publishing the Maximum Ship Dates for Available
Quantities

If enabled, the Real-Time Availability Monitor computes and publishes a matrix of
maximum ship dates for available quantities, which includes the following
information:

* Available Quantity - Refers to the number of items that are available for
shipping on the maximum ship date.

* Maximum Ship Date - Refers to the time and date when available quantities are
shipped by.

e Effective Until Date - Refers to the last time and date that an order can be
placed if it is to be shipped by the maximum ship date.

The matrix is published to the REALTIME_AVAILABILITY_CHANGE event and stored in
XML format in the AVAILABILITY_INFO field of the YFS_INVENTORY_ALERTS
table. The monitorItemAvailability() API can be used to update the matrix. For

more information about the monitorItemAvailability() API, refer to the Sterling

Selling and Fulfillment Foundation: Javadocs.

For information about using the Real-Time Availability Monitor to calculate and
publish a matrix of maximum ship dates for available quantities, refer to the
chapter on Configuring Inventory Rules in the Sterling Selling and Fulfillment
Foundation: Global Inventory Visibility Configuration Guide.

Computing the Maximum Ship Date

The maximum ship date is equal to the maximum expected ship date across all the
nodes being considered. For information about calculating the expected ship date,
refer to the Sterling Selling and Fulfillment Foundation: Product Concepts Guide.
Additionally, the following options can be configured as part of the maximum ship
date:

* Maximum Ship Date Time
* Number of Days To Offset the Maximum Ship Date

Maximum Ship Date Time - If you specify a time for the maximum ship date, the
Real-Time Availability Monitor calculates the maximum ship date, as described
earlier, and then applies the following logic:

* If the time specified for the maximum ship date occurs later in the day than the
calculated ship date, the Real-Time Availability Monitor resets the maximum
ship date to the specified time. For example, if the Real-Time Availability
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Monitor calculates the maximum ship date to be 10 a.m. on July 21 and
Maximum Ship Date Time is set to 11 a.m., the maximum ship date is
recalculated to be 11 a.m. on July 21.

* If the time specified for the maximum ship date occurs earlier in the day than
the calculated ship date, the maximum ship date is incremented by one day and
reset to the specified time. For example, if the maximum ship date is calculated
to be 11 a.m. on July 21 and Maximum Ship Date Time is set to 10 a.m., the
Real-Time Availability Monitor recalculates the maximum ship date to be 10 a.m.
on July 22.

Number of Days To Offset the Maximum Ship Date - You can specify a number
of days to offset the maximum ship date. The Real-Time Availability Monitor
calculates the maximum ship date, including the maximum ship date time, and
then increments the maximum ship date by the number of days specified by the
offset number. For example, if the Real-Time Availability Monitor has calculated a
maximum ship date to be 11 a.m. on July 19 and Number of Days to Offset the
Maximum Ship Date is set to 1, the maximum ship date is recalculated to be 11
a.m. on July 20.

Calculating the Effective Until Date

The Real-Time Availability Monitor calculates the effective until date by subtracting
the node's minimum notification time from the maximum ship date and then
adjusting for the preceding notification time on the node's notification schedule.
The effective until date is only valid while supplies are available at the node.

For example, if an available quantity has a maximum ship date of 4 p.m. on July
19 and the shipping node has the following notification schedule, the effective until
date is calculated to be 3 p.m. on July 18:

* 24-hour minimum notification time

* 3 p.m. and 5 p.m. notification times

In this example, the effective until date is calculated by first subtracting the
24-hour minimum notification time from the 4 p.m., July 19 maximum ship date
and then adjusting for the 3 p.m. notification time. If an order is not placed before
3 p.m. on July 18, the July 19 maximum ship date is no longer available because
the node must be notified at least 24 hours before shipping the items, by 4 p.m. on
July 19. Also, if a different order reduces available quantities at the node before the
order is placed at 3 p.m. on July 19, the maximum ship date cannot be met and the
effective until date becomes invalid.

Additionally, offset days are not considered when calculating the effective until
date. Thus, if the maximum ship date in the earlier example is updated to 4 p.m.
July 20 by setting Number of Days to Offset Maximum Ship Date to 1, the effective
until date is updated to 3 p.m., July 19.

Example 1: Computing Maximum Ship Dates for Available Quantities

Node 1 has the following supply picture:

* 24-hour minimum notification time

* Notification times are 3 p.m. and 5 p.m. daily
* Work Days are 24 hours-a-day, 7 days-a-week

Node 2 has the following supply picture:
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* 48-hour minimum notification time
* Notification times are 2 p.m. and 5 p.m. daily
* Work Days are 24 hours-a-day, 7 days-a-week

The following table shows the availability matrix for Node 1 and Node 2, where
the following conditions are true:

* Current date is July 19

* Estimated time of arrival (ETA) equals the date that the quantity is expected to
be available at the node

* Maximum Ship Date Time is set to 4 p.m.
* Number of Days to Offset the Maximum Ship Date is set to 0

Table 345. Example: Availability Matrix of Maximum Ship Dates for Available Quantities

ETA | Quantity |Maximum Ship Date |Effective Until Date
Node 1

7/19/2010 80 4 p.m., July 20 3 p.m., July 19
7/22/2010 10 4 p.m. July 22 3 pm., July 21
Node 2

7/19/2010 100 4 p.m., July 21 2 pm., July 19
7/22/2010 20 4 p.m., July 22 2 p.m., July 20

In this example, July 19 is the ETA for a quantity of 80 items at Node 1 and 100
items at Node 2. The matrix shows a 4 p.m., July 20 maximum ship date for the 80
available items from Node 1 and a 4 p.m., July 21 maximum ship date for the 100
available items from Node 2. For Node 1, the maximum ship date is calculated by
adding the 24-hour minimum notification time to the 3 p.m. notification time on
July 19, and then adjusting for the 4 p.m. maximum ship date time. The effective
until date is calculated by subtracting the 24-hour minimum notification time from
the maximum ship date and then adjusting for the 3 p.m. notification time. For
Node 2, the maximum ship date and effective until date are calculated similarly,
with the exception that Node 2 has a 48-hour minimum notification time and a 2
p-m. notification time.

Additionally, the example shows July 22 as the ETA for a quantity of 10 items at
Node 1 and 20 items at Node 2. The maximum ship date is 4 p.m., July 22 for the
10 items at Node 1 and 4 p.m., July 22 for the 20 items at Node 2. If the difference
between the current date and the ETA is greater than the node's minimum
notification time, the ETA date is used for the maximum ship date. In this example,
the difference between the current date, July 19, and the ETA date, July 22, is
greater than the minimum notification times at both nodes. Thus, the maximum
ship date is set to the maximum ship date time on the ETA date at the nodes,
which is 4 p.m., July 22 at Node 1 and 4 p.m., July 22 at Node 2.

Example 2: Computing the Maximum Ship Date at Nodes With Non-Working
Days

The following table displays the availability matrix for Node 1 and Node 2 when

the supply picture and conditions from Example 1 are applied. However, in this
scenario, July 19 and July 20 are nonworking days.
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Table 346. Example: Availability Matrix for Nodes with Non-Working Days

ETA |Quantity |Maximum Ship Date |Effective Until Date
Node 1

7/19/2010 |80 |4 p.m., July 22 |3 p.m., July 21
Node 2

7/19/2010 [ 100 |4 pm, July 23 |2 pm, July 21

In the example, Node 1 has an available quantity of 80 on July 19 and a minimum
notification time of 24 hours. Because July 19 and July 20 are nonworking days at
Node 1, the 80 items are not considered available until July 21. In this case, the
maximum ship date is calculated by adding the 24-hour minimum notification time
to July 21 and adjusted for the 4 p.m. maximum ship date time. For Node 2, the
maximum ship date is calculated similarly, with the exception of a 48-hour
minimum notification time.

Example 3: Offsetting the Maximum Ship Date

The following table displays the availability matrix for Node 1 and Node 2 when
the supply picture and conditions from Example 2 are applied. However, in this
scenario, Number of Days To Offset the Maximum Ship Date is set to 1.

Table 347. Example: Availability Matrix When Offsetting the Maximum Ship Date

ETA |Quantity |Maximum Ship Date |Effective Until Date
Node 1

7/19/2010 |80 |4 p.m., July 23 |3 p.m., July 22
Node 2

7/19/2010 | 100 |4 pm, July 24 |2 pm, July 22

In the example, the maximum ship dates for Nodes 1 and 2 are calculated similarly
to Example 2. However, the maximum ship dates are incremented by 1 because
Number of Days to Offset the Maximum Ship Date is set to 1. In this example, the
effective until date is set to 3 p.m., July 22 for Node 1 and 2 p.m., July 22 for Node
2 because the offset days are not considered when calculating the effective until
date.

Attributes

The following are the attributes for this time-triggered transaction:

Table 348. Real-time Availability Monitor Attributes

Attribute Value

Base Transaction ID REALTIME_ATP_MONITOR
Base Document Type General

Base Process Type General

Abstract Transaction No

APIs Called FindInventory
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Criteria Parameters

The following are the criteria parameters for this monitor:

Table 349. Real-time Availability Monitor Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it
defaults to Get, the only valid value.

Number of Records To Buffer

Optional. Number of records to retrieve and process
at one time. If left blank or specified as 0 (zero), it
defaults to 5000.

InventoryOrganizationCode

Inventory organization code to use when
MonitorOption is passed as 3. The inventory
organization has to be an enterprise.

If this is not passed, the monitor runs for all
inventory organizations.

MonitorOption

1 - Activity Based (Monitor based on distinct
inventory items in YFS_INVENTORY_ACTIVITY table).

2 — Quick Sync (Re-raise event to publish
information from the YFS_INVENTORY_ALERTS
table).

3 — Full Sync (Monitor based on all inventory items
maintained by the inventory organization provided.
If no InventoryOrganizationCode is provided, all
inventory item is monitored).

If not provided, default value is 1.

ItemStatuses

List of valid statuses of items to be processed.
Statuses must be separated by a , for example
3000,2000. This is only used when MonitorOption is
passed as 2 or 3. If provided, only items with the
matching statuses is monitored.

FromAlertTimestamp

This is only used when MonitorOption is passed as
2. If provided, the agent raises the
REALTIME_AVAILABILITY_CHANGE event to
republish inventory availability information which
was published between the time that the agent
started and FromAlertTimestamp.

If not provided, all inventory availability
information published before the time that the agent
started is republished.

AllowedOverriddenCriteria

If set to Y, the overridden value for the agent criteria
parameters can be provided at the command line
while triggering the agent in the following format:

<AgentCriteriaAttribute> <OverriddenValue>

For more information about passing these attributes,
see the Sterling Selling and Fulfillment Foundation:
Installation Guide.
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Table 349. Real-time Availability Monitor Criteria Parameters (continued)

Parameter Description

FromLastNumberOfHours This is only used when MonitorOption is passed as
2 to calculate the FromAlertTimestamp parameter, if
necessary.

If the FromAlertTimestamp parameter is not
provided, it is calculated as current timestamp
minus FromLastNumberOfHours.

CollectPendingJobs If this parameter is set to N, the agent does not
collect information on the pending jobs for this
monitor. This pending job information is used for
monitoring the monitor in the System Management

Console.
RaiseEventsOnAllAvailability When set to Y,
Changes REALTIME_AVAILABILITY_CHANGE event is

raised on all availability changes regardless of
whether availability exceeds or falls below specified
thresholds. This is only used when MonitorOption is
passed as 1. Valid values: Y or N. Default value: N.

ColonyID Required in a multi schema deployment where a
table may exist in multiple schemas. Runs the agent
for the colony.

Note: Distribution Rule Id is used for internal purposes and should be left blank.
Statistics Tracked

None.

Pending Job Count

None.

Events Raised

The following events are raised by this time-triggered transaction:

Table 350. Events Raised by the Realtime Availability Monitor Transaction

Template
Transaction/Event Key Data Data Published* Support?
REALTIME_ None YFS_REALTIME_ATP_MONITOR. | Yes
AVAILABILITY_ REALTIME_AVAILABILITY
CHANGE _CHANGE html

* These files are located in the following directory:
<INSTALL_DIR>/xapidocs/api_javadocs/XSD/HTML

Although described as 'real time', availability changes may not be triggered
immediately as inventory changes occur if the agent has a backlog of messages to
process. Furthermore, this monitor exists as a time-triggered transaction, and thus
monitors availability of inventory items only when the monitor is triggered based
on the configured runtime properties.
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Shipment Monitor

This time-triggered transaction reports the states of a shipment, based on rules in
the YFS_MONITOR_RULE table. This transaction enables you to monitor the
following situations:

* If the Shipment has been in a status for more than a specified amount of time.
* If a specified date that is associated with the shipment is:
— n hours before another specified date
— n hours after another specified date
— n hours not before another specified date
— n hours not after another specified date
¢ If the Shipment has been in a hold type for a specified amount of time.
* If the Shipment has been in a hold type for n hours before a specified date.

Monitoring rules can be configured for shipment's origin and destination points.

Monitoring rules cannot be configured for a shipment's intermediate pickup and
drop off points. A shipment has intermediate pickup or drop off only if it has
multiple pickup or drop off points. For example, a shipment has more than one
loads carrying it. The shipment status on first load deposit, second load deposit,
and so forth cannot be monitored. Once the last load deposits the shipment at its
destination, then the shipment status can be marked and monitored.

This is not a pipeline transaction. It also does not work from the task queue.

For more information about milestones, date types, and monitoring rules, see the
Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide,
the Sterling Selling and Fulfillment Foundation: Distributed Order Management
Configuration Guide, and the Sterling Selling and Fulfillment Foundation: Reverse
Logistics Configuration Guide.

Attributes

The following are the attributes for this time-triggered transaction:

Table 351. Shipment Monitor Attributes

Attribute Value

Base Transaction ID SHIPMENT_MONITOR
Base Document Type Order

Base Process Type Order Delivery
Abstract Transaction No

APIs Called None

Criteria Parameters

The following are the criteria parameters for this monitor:

Table 352. Shipment Monitor Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.
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Table 352. Shipment Monitor Criteria Parameters (continued)

Parameter Description

Number of Records To Optional. Number of records to retrieve and process at one
Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.
EnterpriseCode Optional. Enterprise for which the Shipment Monitor needs to

be run. If not passed, then all enterprises are monitored.

CollectPendingJobs If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This pending
job information is used for monitoring the monitor in the
System Management Console.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 353. Shipment Monitor Statistics

Statistic Name Description

NumShipmentsMonitored Number of shipments monitored.

Pending Job Count

For this transaction the pending job count is the number of open shipments with
the value of NEXT_ALERT_TS less than or equal to (<=) the current date.

Events Raised

This invokes the actions configured against shipment statuses.

Key Data - Not Applicable.

Data Published - SHIPMENT_MONITOR.xm1

Monitor Rule's Condition Template

If a monitor rule contains a condition, the <INSTALL_DIR>/repository/xapi/
template/source/smcfs/monitor/SHIPMENT_MONITOR_CONDITION.xml template file is
used to obtain the shipment details and the evaluating monitor rule details. See the
provided <INSTALL_DIR>/repository/xapi/template/source/smcfs/monitor/
SHIPMENT_MONITOR_CONDITION.xml.sample file for more details.

If the <INSTALL DIR>/repository/xapi/template/source/smcfs/monitor/
SHIPMENT_MONITOR_CONDITION.xml template file does not exist, the
MonitorConsolidation->Shipment element of the default monitor template, the
<INSTALL_DIR>/repository/xapi/template/source/smcfs/monitor/
SHIPMENT_MONITOR.xm]1 file, is used.

If the default monitor template is used, the MonitorConsolidation->Shipment->
MonitorRule element is ignored and is not passed into the condition.
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Work Order Monitor

This time-triggered transaction alerts the enterprise when a work order remains in
a particular state or hold type for a specific amount of time.

Use this monitor to track how long work orders stay in a particular state or hold
type.

Attributes

The following are the attributes for this time-triggered transaction:

Table 354. Work Order Monitor Attributes

Attribute Value

Base Transaction ID WORK_ORDER_MONITOR
Base Document Type Work Order

Base Process Type VAS Process

Abstract Transaction No

Criteria Parameters

The following are the criteria parameters for this monitor:

Table 355. Work Order Monitor Criteria Parameters

Parameter Description

Action Required. Triggers the transaction. If left blank it defaults to
Get, the only valid value.

Number of Records To Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

EnterpriseCode Optional. Enterprise for which the Work Order Monitor
needs to be run. If not passed, then all enterprises are
monitored.

Node Optional. Node for which the Work Order Monitor needs to

be run. If not passed, then all nodes are monitored.

CollectPendingJobs If this parameter is set to N, the agent does not collect
information on the pending jobs for this monitor. This
pending job information is used for monitoring the monitor
in the System Management Console.

ColonyID Required in a multi schema deployment where a table may
exist in multiple schemas. Runs the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 356. Work Order Monitor Statistics

Statistic Name Description

NumWorkOrdersMonitored Number of work orders monitored.
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Pending Job Count

For this transaction the pending job count is the number of Work Orders that are
monitored, where NEXT_ALERT_TS less than or equal to (<=) current date.

Events Raised

No events are raised. Individual actions associated with the monitoring rule are
run. Data published to the actions is workOrder_dbd.txt.

Monitor Rule's Condition Template

If a monitor rule contains a condition, the <INSTALL_DIR>/repository/xapi/
template/source/smcfs/monitor/monitor/WORK_ORDER_MONITOR_CONDITION.xmI
template file is used to obtain the work order details and the evaluating monitor
rule details. See the provided <INSTALL_DIR>/repository/xapi/template/source/
smcfs/monitor/WORK_ORDER_MONITOR_CONDITION.xml.sample file for more details.

If the <INSTALL DIR>/repository/xapi/template/source/smcfs/monitor/
WORK_ORDER_MONITOR_CONDITION.xml template file does not exist, the
MonitorConsolidation->WorkOrder element of the default monitor template, the
<INSTALL DIR>/repository/xapi/template/source/smcfs/monitor/
WORK_ORDER_MONITOR.xnl file, is used.

If the default monitor template is used, the MonitorConsolidation-> WorkOrder->
MonitorRule element is ignored and is not passed into the condition.
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Chapter 21. Order Modification Types

Order Modification Types

The following are the default order modification types and their associated

modification levels:

Table 357. Order Document Modification Types

added to an order document's
line or release line.

Modification Types Description Modification Levels
Add Component A bundle component can be Line
added to an order document
line.
Add Instruction An instruction can be added to | Header
an order document's header, .
line, or shipment. Line
For example, you may want to Shipment
add an instruction stating that .
a line item needs to be gift Receipt
wrapped.
Add Line A line can be added to an order | Header
document's header, release,
negotiation, or shipment. Release
Important: When adding a line Negotiation
to an order, the Add Line )
modification type does not get Shipment
audited, if the prices are not
configured.
Add Line Relationship A line relationship type can be |Line
added to an order document
line.
Add Note A note can be added to an Header
order document's header or
release. Release
Add Option An option can be added to a Line
provided service or delivery
service order line.
Add Product Item For A product item for a Line
Stand Alone Service Line |standalone service line can be
added to an order document
line.
Add Quantity Additional quantity can be Line

Release Line
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Add/Remove Additional

Date

A date type used for shipment
monitoring (such as, Ship Date)
can either be added to or
removed from an order
document's shipment.

For example, you may want to
add an additional delivery date
used by your organization to
monitor shipments.

Shipment

Add/Remove Charge

A charge can either be added
to or removed from an order
document's shipment.

For example, if a shipment
contains hazardous materials
and your organization has an
extra shipping charge for
shipment of hazardous
materials, you can add an extra
charge to the shipment.

Shipment

Add/Remove Container

A container can either be
added to or removed from an
order document's shipment.

Shipment

Associate Delivery Line
With Product Line

When the delivery method of a
product order line is delivery,
the product line can be
associated to a delivery line to
indicate how the product line is
delivered.

Line

Associate Product Line
With Delivery Line

When the delivery method of a
product order line is delivery,
the product line can be
associated to a delivery line to
indicate how the product line is
delivered.

Line

Associate Product Line
With Service Line

A provided service can be
associated to a product line to
indicate that the service is
somehow dependent on the
product line.

Line

Associate Service Line
With Product Line

A provided service can be
associated to a product line to
indicate that the service is
somehow dependent on the
product line.

Line

Attribute Modification

A receipts attributes can be
modified. For a list of attributes
that can be modified, see the
changeReceipt API in the
Sterling Selling and Fulfillment
Foundation: Javadocs.

Receipt
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Table 357. Order Document Modification Types (continued)

Modification Types Description Modification Levels
Backorder An order document's line, Line
release, or release line can be
backordered. Release
For example, if an order is Release Line
released to a node and the
node does not have enough
quantity to fulfill the order,
they can backorder the release.
Cancel An order document's header, Header
line, release, or release line can
be manually cancelled from the Line
Application Consoles.
Release

Release Line

Change Additional
Address

A modification can be made to
the fields of any additional
addresses that may have been
configured for an order
document's header or line.

Header

Line

Change Answer Set

A modification can be made to
an answer associated with an
order document header.

Header

Change Appointment

Appointments can be taken and
changed for delivery and
provided service order lines.

Line

Change Bill To

A modification can be made to
any bill to address field
associated with an order
document's header or release.

Header

Release

Change Bundle Definition

The existing bundle definition
can be replaced with the new
bundle definition.

For example, you can change
an existing bundle definition by
passing the
'REPLACE_BUNDLE' action to
the bundle parent. All the
components passed remain
with order and as well as with
bundle. All remaining
components are deleted.

Important: In addition to this,
the modification type DELETE
is executed on all the
components getting removed
and modification type
ADD_LINE is executed on
components getting added.
This modification is applied to
bundle parent's immediate
components.

Line
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Change Bundle Parent

A modification can be made to
the bundle parent associated
with an order document line.

Line

Change Buyer
Organization

The buyer organization
associated with an order
document's header can be
changed. This modification can
only be made in the Order
Detail screen.

Header

Change Carrier

A modification can be made to
the Carrier/Service or Carrier
field associated with an order
document's header, line, or
release.

For example, you can change
the carrier and service from
UPS Next Day Air to FedEx
Express® Saver Pack.

Important: If you want this
modification type to be
allowed, Change Carrier
Service Code must also be
allowed.

Header
Line

Release

Change Carrier Account
No

A modification can be made to
the Carrier Account # field
associated with an order
document's header, line, or
release.

Header
Line

Release

Change Carrier Service
Code

A modification can be made to
the Carrier/Service field
associated with an order
document's header, line, or
release.

For example, you can change
the carrier and service from
UPS Next Day Air to FedEx
Express Saver Pack.

Important: If you want this
modification type to be
allowed, Change Carrier must
also be allowed.

Header
Line

Release

Change Contact Info

A modification can be made
the fields for the Buyer/Seller
contact information associated
with an order document's
header.

Header

Change Cost

A adjustment can be made to
the Unit Cost field associated
with an order document's
release or release line.

Release

Release Line
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Change Currency

The currency associated with
an order document's header
can be changed. Upon a change
to the currency, Sterling Selling
and Fulfillment Foundation
automatically reprices the
order. However, preexisting
charges and taxes have to be
converted manually.

Header

Change Custom Date

A modification can be made to
the date type fields used for
order monitoring associated
with an order document's
header, line, or release.

The following custom date
fields can be modified when
this modification type is
allowed:

* Requested
* Expected
e Actual

For example, if there is a delay
in a release's processing, you
can change the expected
delivery date.

Header
Line

Release

Change Delivery Code

A modification can be made to
the Delivery Code field
associated with an order
document's header, line, or
release.

For example, if you want to
indicate that an order's freight
charges are paid by the
Enterprise, you can choose the
ENTERPRISE delivery code.

Header
Line

Release

Change Delivery Method

A product order line indicates
how the product id sent to its
final destination. It can be
changed to SHIP, DELIVER, or
PICKUP.

Line

Change Freight Terms

A modification can be made to
the Freight Terms field
associated with an order
document's header, line, or
release.

For example, you can change
an order line's freight term
from CIF (Cost Insurance and
Freight) to CFR (Cost and
Freight).

Header
Line

Release
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Change Gift Flag

A modification can be made to
the Gift Flag field associated
with an order document line.

Line

Change Gift Wrap

A modification can be made to
the Gift Wrap fields associated
with an order document line.

Line

Change Instruction

A modification can be made to
an instruction associated with
an order document's header,
line, or shipment.

The following instruction fields
can be modified when this
modification type is allowed:

* Instruction Type
e Text
« URL

Header
Line
Shipment

Receipt

Change Inventory
Attributes

A modification can be made to
inventory attributes associated
with an order document line.

Line

Change Item Description

A modification can be made to
the Description field of an item
associated with an order
document's line.

Line

Change Iteration

A modification can be made to
the iteration fields associated
with an order document's
header or line.

For example, you can change
the next iteration date of a
master order to a time in the
future.

Header

Line

Change Level of Service

A modification can be made to
the Level of Service fields
associated with an order
document's header or line.

Header

Line

Change Mark For

A modification can be made to
the fields of the mark for
address associated with an
order document's header, line,
or release.

Header
Line

Release

Change Order Name

A modification can be made to
the Order Name field
associated with an order
document's header.

Header
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Change Other Attributes

A modification can be made to
fields that do not have system
or user-defined modification
types associated with them.

Header

Line

Release
Negotiation
Negotiation Line

Shipment

Change Other
Relationships

Not used in this version.

Shipment

Change Payment Method

A modification can be made to
the Payment Type field
associated with an order
document's header or release.

For example, you can change
an order's payment type from
Check to Credit Card.

Header

Release

Change Payment Rule ID

The Payment Rule field
associated with an order
document's header can be
changed.

For example, you can change
the payment rule from the
default rule to a custom rule
that pertains to the order.

Header

Change Payment Status

The Payment Status field
associated with an order
document's header can be
changed.

For example, you can change
an order's payment status from
Await Authorization to
Authorized.

Header

Change Pipeline

A change can be made to the
pipeline associated with an
order document line.

Line

Change Price

Charges can be added to an
order document's header or
line.

Header

Line

Change Promotion

An order document's
promotion can be changed at
the header or line. Promotions
include coupons and manual
pricing rules.

Header

Line
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Change Receiving Node

The Receiving Node field
associated with an order
document's line can be
changed.

For example, if for some reason
it has been determined that an
order line's original receiving
node cannot receive the line,
you can change it to another
receiving node.

Line

Change References

A modification can be made to
the name/value pair in the
YFS_REFERENCE_TABLE
using APlIs.

Header

Line

Change Requested Ship

Date

A modification can be made to
the Requested Ship Date
associated with an order
document's header, line, or
release.

For example, if the customer
decides they want an order to
be shipped on a date later than
what they originally requested,
you can change the requested
shipment date.

Header
Line

Release

Change Schedule

A modification can be made to
schedule attributes, such as
expected ship date, expected
delivery date, and lot number,
associated with an order
document's header, line,
release, or release line.

Header
Line
Release

Release Line

Change Schedule Rule ID

A modification can be made to
the schedule rule associated
with an order document's
header. This allows the user to
select the scheduling rule they
want to use for the order from
the Scheduling Rule drop-down
list on the Schedule Order
popup window.

Header

Change Seller
Organization

The seller organization
associated with an order
document's header can be
changed. This modification can
only be made in the Order
Detail screen.

Header
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Change Ship Node

The Ship Node field associated
with an order document's
header or line can be changed.

For example, if for some reason
it has been determined that an
order line's original ship node
cannot handle the order line,
you can change it to another
node.

Header

Line

Change Ship To

A modification can be made to
the fields of a ship to address
associated with an order
document's header, line, or
release.

Header
Line

Release

Change Status

The order status (such as,
Created) associated with an
order document's header, line,
release, release line, or
negotiation can be changed.

Only order statuses existing in
process type repositories are
affected by this modification
type. Actions performed
against order documents, such
as putting an order on hold or
canceling an order, are not
impacted.

Header

Line

Release
Release Line

Negotiation

Change Tax

A modification can be made to
the Tax Amount associated
with an order document's
header or line.

Header

Line

Delete

An order line can be deleted.

Line

Delete Shipment

An order document's shipment
can be deleted.

Shipment

Expiration Date

A modification can be made to
the expiration date associated
with an order document's
negotiation.

Negotiation

Hold

An order document's header or
release can be manually put on
hold.

For example, you may want to
perform a security check on a
particular Buyer, you can then
place the order on hold until
you clear the necessary
information before the order is
scheduled.

Header

Release
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Table 357. Order Document Modification Types (continued)

Modification Types

Description

Modification Levels

Hold Type Modifications

A modification can be made to
the Hold Type fields associated

Header

with an order document's Line
header or line.

Include In Load An order document's shipment |Shipment
can be included in a load
document.

Include Shipment in An order document's shipment |Shipment

Delivery Plan can be included in a delivery
plan.

Pack Shipment An order document's shipment |Shipment
can be packed.

Price Program The price program associated | Header
with an order document's
header can be changed.

Receipt Complete An order document's receipt Receipt
can be marked as complete.

Release from Hold An order document's header Header
can be released from hold.

Remove Component A bundle component can be Line
removed from an order
document line.

Remove Delivery Line Delivery lines can be removed | Line

From Product Line from product order lines.

Association

Remove Order Line A line can be removed from an | Header
order document's header, line, )
and shipment. Line

Shipment

Remove Option Options can be removed from |Line
delivery and provided services.

Remove Product Item For | A product item for a stand Line

Stand Alone Service Line |alone service line can be
removed from an order
document line.

Remove Product Line Product lines can be removed |Line

From Delivery Line from delivery lines.

Association

Remove Product Line Product lines can be removed |Line

From Service Line from provided service order

Association lines.

Remove Promotion An order document's Header
promotion can be removed )
from the header or line. Line
Promotions include coupons
and manual pricing rules.

Remove Service Line Provided service lines can be Line

From Product Line
Association

removed from product order
lines.
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Table 357. Order Document Modification Types (continued)

Modification Types Description Modification Levels
Remove Shipment From | An order document's shipment |Shipment
Delivery Plan can be removed from a

delivery plan.
Rework Quote A quote can be reworked. Header
Short An order document's header, Header

line, release, release line, and )

receipt can be shorted. This Line

occurs when there is a shortage

Release

in the expected quantity.

Release Line

Receipt
Sourcing Control Modifications can be made to |Line
Modifications the Sourcing Control fields
associated with an order
document's line.
Split Line An order document's line or Line

release line can be split into
multiple lines.

Release Line

Unpack Shipment

An order document's shipment
can be unpacked.

Shipment

Unreceive

An order document's receipt
can be fully or partially
unreceived. This moves the
quantity you are identifying as
unreceived back to Shipped
status.

Receipt

Unschedule

An order document's header or
line can be unscheduled from a
scheduled node. This cancels
any inventory that has been
reserved for the order at the
scheduled node.

Header

Line
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Chapter 22. Condition Builder Attributes

Condition Builder Attributes

Statements in the condition builder are built using attributes that are defined
throughout the Applications Manager.

These attributes are grouped as follows:

Sales Order

* Order fulfillment

* Order negotiation

* Outbound shipment
* Receipt

Planned Order

e Planed order execution

* Planned order negotiation

Return Order
* Reverse logistics
¢ Return shipment
* Return receipt

Template Order

* Template order

Purchase Order

* Purchase order execution

* Purchase order negotiation
* Inbound shipment

* Purchase order receipt

Transfer Order

» Transfer order execution
* Transfer order delivery
* Transfer order receipt

Master Order
¢ Master order fulfillment

Quote
* Quote fulfillment

Load

* Load execution
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General

* General

* WMS putaway

* WMS layout definition
* WMS inventory

¢ Trailer loading

* Task execution

* Move request execution
* Manifesting

* Over pack build

Count

¢ Count execution

Container
* Pack process

Wave
* Outbound picking

Work Order
* VAS process

Opportunity
* Opportunity fulfillment

Item-Based Allocation (IBA)
* Item-based allocation (IBA) order

Sales Order

Order Fulfillment

The Condition Builder attributes for Order Fulfillment, Order Execution, Quote
Fulfillment, Transfer Order Execution, and Template Order are identical.

Table 358. Order Fulfillment Condition Builder Attributes

Attribute

Description

Order Attributes

Condition Variable 1

A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the
database.

Condition Variable 2

A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the
database.

Delivery Method

The delivery method of the order (shipment, pickup or
delivery).
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Table 358. Order Fulfillment Condition Builder Attributes (continued)

Attribute

Description

Disposition Code

The disposition code of the item. This field is only applicable
for Reverse Logistics and Supply Collaboration.

Line Type The type of the order line. Sterling Selling and Fulfillment
Foundation has no application logic associated with the order
line type. This field can be set up as per your business
practices.

Order Type The type of the order. Sterling Selling and Fulfillment

Foundation has no application logic associated with the order
type. This field can be set up as per your business practices.

Payment Status

The payment status of the order.

Sale Voided

The flag indicating whether the order is voided.

Transaction ID

The ID of the last transaction that was run on the order.

Participant Attributes

Bill To ID

The ID of the bill to address for the order.

Buyer Organization Code

The code of the organization that is buying the goods or
services.

Enterprise Code

The code of the enterprise on the order.

Receiving Node

The node that receives the shipment for the order.

Seller Organization Code

The code of the organization that is selling the goods or
services.

Ship Node

The node that ships the shipment for the order.

Ship Node Interface Type

The interface type of the ship node on the order (External
Application, Console, Sterling Store Inventory Management,
or WMS 6.2).

Ship To ID

The ID of the ship to address for the order.

Supplier Code

The code of the supplier for the order.

Item Attributes

Item ID

The ID of the item on the order line.

Item Group Code

The group code of the service item. For example, if the
service is a provided service item, then the item group code
is PS.

Product Line

The product line of the item on the order line.

Sourcing Attributes

Fulfillment Type

The fulfillment type of the order.

Intentional Backorder

The flag indicating whether the order was intentionally
dropped into backordered status at order creation.

Is Firm Predefined Node

The flag indicating whether the node on the order is a firm
predefined node.

Order Sourcing
Classification

The order sourcing classification of the order.

Reservation Mandatory

The flag indicating whether the reservation is mandatory.

Related Order Attributes

Chain Type

The chain type of the order.

Is Chained Line

The flag indicating whether the order line is chained with
another order line.
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Table 358. Order Fulfillment Condition Builder Attributes (continued)

Attribute

Description

Is Derived Line

The flag indicating whether the order line is derived from
another order line.

Order Purpose

The purpose of the order. If this is an exchange order, this
field is set to EXCHANGE.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Order Negotiation

The Condition Builder attributes for Order Negotiation and Planned Order

Negotiation are identical.

Table 359. Order Negotiation Condition Builder Attributes

Attribute

Description

Enterprise Code

The code of the enterprise on the order.

Initiator Organization
Code

The code of the organization that initiates the negotiation.

Negotiator Organization
Code

The code of the organization that can accept, counter-offer, or
reject the initiator's offer.

Negotiation Pipeline Key

The key of the negotiation pipeline this order is going
through.

Negotiation Number

The negotiation number of this order.

Negotiation Rule Key

The key of the negotiation rule for this order.

Header Entity

The entity for which the negotiation was initiated. Currently,
the only applicable entity is Order.

Negotiation Status

The status of the negotiation for this order.

Document Type

The document type for this order. Typical value is Sales
Order.

Freight Terms

The freight terms for this order.

Payment Terms

The payment terms for this order.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.
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Outbound Shipment

The condition builder attributes for Outbound Shipment, Inbound Shipment,
Transfer Order Delivery, and Return Shipment are identical.

Table 360. Outbound Shipment Condition Builder Attributes

Attribute

Description

Enterprise Code

The code of the enterprise on the outbound shipment.

Buyer Organization Code

The code of the organization that is buying the goods or
services.

Seller Organization Code

The code of the organization that is selling the goods or
services.

Ship Node

The node that ships this shipment.

Ship Node Interface Type

The interface type of the ship node on the order (External
Application, Console, Sterling Store Inventory Management,
or WMS 6.2).

Receiving Node

The node that receives this shipment.

Ship Mode

The shipment mode that is used for the shipment. For
example, Parcel, Truck Load, Less-Than Truck Load.

Freight Terms

The freight terms for this shipment.

Carrier Type

The shipment's carrier type for this shipment.

Hazardous Materials Flag

The flag indicating whether these materials are hazardous.

ESP Check Required

The flag indicating whether an Economic Shipping
Parameters check is required at shipment consolidation time.

Is Appointment Required

The flag indicating whether an appointment is required for a
service execution.

Routing Guide Maintained

The flag indicating whether a routing guide is maintained for
this shipment.

Carrier

The carrier for the shipment.

Real-time Integration with
WMS 6.2

The flag indicating whether the node this shipment is
shipping from is integrating with the Sterling Store Inventory
Management. Setting this field to N means that you are
integrating with WMS 6.2, or any other warehouse
management system.

Manually Entered

The flag indicating whether or not the shipment was entered
through the Console.

Delivery Code

The code of the entity that pays for the transportation costs.

Country/Region

The country or region that the shipment is being shipped to.

Delivery Method

The delivery method of the shipment (shipment, pickup or
delivery).

Is Serial Requested

The flag indicating whether the shipment has any line with a
specific serial number passed. If that is the case, a different
outbound shipment process can be selected in the pipeline.

Is Provided Service

The flag indicating whether the shipment has an associated
provided service item.

Shipment Type

Indicates a set of shipments that are of the same nature.
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Table 360. Outbound Shipment Condition Builder Attributes (continued)

Attribute Description

{Enter Your Own A customizable condition builder attribute. For more

Attribute} information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Receipt

The Receipt condition builder attributes are identical to the Return Receipt
attributes.

Planned Order

Planned Order Execution

The Planned Order Execution condition builder attributes are identical to the Order
Fulfillment attributes.

Planned Order Negotiation

The Planned Order Negotiation condition builder attributes are identical to the
Order Negotiation attributes.

Return Order

Reverse Logistics

Table 361. Return Fulfillment Condition Builder Attributes

Attribute Description
Order Attributes

Condition Variable 1 A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the
database.

Condition Variable 2 A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the

database.

Delivery Method The delivery method of the return (shipment, pickup or
delivery).

Disposition Code The disposition code of the item.

Line Type The type of the return line. Sterling Selling and Fulfillment

Foundation has no application logic associated with the
return line type. This field can be set up as per your business
practices.
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Table 361. Return Fulfillment Condition Builder Attributes (continued)

Attribute

Description

Order Type

The type of the return. Sterling Selling and Fulfillment
Foundation has no application logic associated with the
return type. This field can be set up as per your business
practices.

Payment Status

The payment status of the return.

Sale Voided

The flag indicating whether the return is voided.

Transaction ID

The ID of the last transaction that was run on the return.

Participant Attributes

Bill To ID

The ID of the bill to address for the return.

Buyer Organization Code

The code of the organization that is buying the goods or
services.

Enterprise Code

The code of the enterprise on the return.

Receiving Node

The node that receives the shipment for the return.

Seller Organization Code

The code of the organization that is selling the goods or
services.

Ship Node

The node that be ships the shipment for the return.

Ship Node Interface Type

The interface type of the ship node on the return (External
Application, Console, Sterling Store Inventory Management,
or WMS 6.2).

Ship To ID The ID of the ship to address for the return.
Supplier Code The code of the supplier for the return.
Item Attributes

Item ID The ID of the item on the return line.

Item Group Code

The group code of the service item. For example, if the
service is a provided service item, then the item group code
is PS.

Product Line

The product line of the item on the return line.

Sourcing Attributes

Fulfillment Type

The fulfillment type of the return.

Intentional Backorder

The flag indicating whether the return was intentionally
dropped into backordered status at return creation.

Is Firm Predefined Node

The flag indicating whether the node on the return is a firm
predefined node.

Order Sourcing
Classification

The order sourcing classification of the return.

Reservation Mandatory

The flag indicating whether the reservation is mandatory.

Related Order Attributes

Chain Type

The chain type of the return.

Is Chained Line

The flag indicating whether the return line is chained with
another return line.

Is Derived Line

The flag indicating whether the return line is derived from
another return line.

Order Purpose

This field is only applicable to sales orders.
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Table 361. Return Fulfillment Condition Builder Attributes (continued)

Attribute

Description

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Return Shipment

The Return Shipment condition builder attributes are identical to the Outbound

Shipment attributes.

Return Receipt

The Condition Builder attributes for Receipt, Purchase Order Receipt, Return
Receipt, Transfer Order Receipt are identical.

Table 362. Return Receipt Condition Builder Attributes

Attribute

Description

Document Type

The document type on the receipt. Typical value is Return
Order.

Enterprise Code

The code of the enterprise that owns the receipt.

Seller Organization Code

The code of the organization that is selling the goods or
services.

Ship Node

The node where the shipment was shipped out of.

Buyer Organization Code

The code of the organization that is buying the goods or
services.

Receiving Node

The node where the shipment was received.

Receiving Node Interface
Type

The interface type of the receiving node on the order
(External Application, Console, Sterling Store Inventory
Management, or WMS 6.2).

Ship Mode

The shipment mode that is used for the shipment. For
example, Parcel, Truck Load, Less-Than Truck Load.

Freight Terms

The freight terms on the receipt.

Carrier Type

The carrier type on the receipt.

Is Hazardous Material

The flag indicating whether there are hazardous materials
that are being received.

Is Inspection Pending

The flag indicating whether there is an inspection pending on
this return.

Is Receiving Node
Integrated Real Time

The flag indicating whether the receiving node is integrating
with WMS 6.2, or with another WMS system.
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Table 362. Return Receipt Condition Builder Attributes (continued)

Attribute

Description

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Template Order

The Template Order condition builder attributes are identical to the Order

Fulfillment attributes.

Purchase Order

Purchase Order Execution

Table 363. Purchase Order Execution Condition Builder Attributes

Attribute

| Description

Order Attributes

Condition Variable 1

A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the
database.

Condition Variable 2

A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the
database.

Delivery Method

The delivery method of the inbound order (shipment, pickup
or delivery).

Disposition Code

The disposition code of the item.

Line Type The type of the inbound order line. Sterling Selling and
Fulfillment Foundation has no application logic associated
with the inbound order line type. This field can be set up as
per your business practices.

Order Type The type of the inbound order. Sterling Selling and

Fulfillment Foundation has no application logic associated
with the inbound order type. This field can be set up as per
your business practices.

Payment Status

The payment status of the inbound order.

Sale Voided

The flag indicating whether the inbound order is voided.

Transaction ID

The ID of the last transaction that was run on the inbound
order.

Participant Attributes

Bill To ID

The ID of the bill to address for the inbound order.

Buyer Organization Code

The code of the organization that is buying the goods or
services.
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Table 363. Purchase Order Execution Condition Builder Attributes (continued)

Attribute

Description

Enterprise Code

The code of the enterprise on the inbound order.

Receiving Node

The node that receives the shipment for the inbound order.

Seller Organization Code

The code of the organization that is selling the goods or
services.

Ship Node

The node that ships the shipment for the inbound order.

Ship Node Interface Type

The interface type of the ship node on the inbound order
(External Application, Console, Sterling Store Inventory
Management, or WMS 6.2).

Ship To ID

The ID of the ship to address for the inbound order.

Supplier Code

The code of the supplier for the inbound order.

Item Attributes

Item ID

The ID of the item on the inbound order line.

Item Group Code

The group code of the service item. For example, if the
service is a provided service item, then the item group code
is PS.

Product Line

The product line of the item on the inbound order line.

Sourcing Attributes

Fulfillment Type

The fulfillment type of the inbound order.

Intentional Backorder

The flag indicating whether the inbound order was
intentionally dropped into backordered status at inbound
order creation.

Is Firm Predefined Node

The flag indicating whether the node on the inbound order is
a firm predefined node.

Order Sourcing
Classification

The order sourcing classification of the inbound order.

Reservation Mandatory

The flag indicating whether the reservation is mandatory.

Related Order Attributes

Chain Type

The chain type of the inbound order.

Is Chained Line

The flag indicating whether the inbound order line is chained
with another inbound order line.

Is Derived Line

The flag indicating whether the inbound order line is derived
from another inbound order line.

Order Purpose

This field is only applicable to sales orders.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.
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Purchase Order Negotiation

Table 364. Purchase Order Negotiation Condition Builder Attributes

Attribute Description

Enterprise Code The code of the enterprise on the inbound order.

Initiator Organization The code of the organization that initiates the negotiation.
Code

Negotiator Organization The code of the organization that can accept, counter-offer, or
Code reject the initiator's offer.

Negotiation Pipeline Key | The key of the negotiation pipeline this inbound order is
going through.

Negotiation Number The negotiation number of this inbound order.

Negotiation Rule Key The key of the negotiation rule for this inbound order.

Header Entity The entity for which the negotiation was initiated. Currently,
the only applicable entity is Order.

Negotiation Status The status of the negotiation for this inbound order.

Document Type The document type for this inbound order. Typical value is
Purchase Order.

Freight Terms The freight terms for this inbound order.

Payment Terms The payment terms for this inbound order.

{Enter Your Own A customizable condition builder attribute. For more

Attribute} information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Inbound Shipment

The Inbound Shipment condition builder attributes are identical to the Outbound
Shipment attributes.

Purchase Order Receipt

The Purchase Order Receipt condition builder attributes are identical to the Return
Receipt attributes.

Transfer Order

Transfer Order Execution

The Transfer Order Execution condition builder attributes are identical to the Order
Fulfillment attributes.

Transfer Order Delivery

The Transfer Order Delivery condition builder attributes are identical to the
Outbound Shipment attributes.
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Transfer Order Receipt

The Transfer Order Receipt condition builder attributes are identical to the Return

Receipt attributes.

Master Order Fulfillment

Table 365. Master Order Fulfillment Condition Builder Attributes

Attribute

Description

Master Order Attributes

Condition Variable 1

A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the
database.

Condition Variable 2

A variable that can be used for condition building. This is an
existing field in the YFS_ORDER_LINE database table, and
can be used to create conditions without extending the
database.

Delivery Method

The delivery method of the order (shipment, pickup or
delivery).

Disposition Code

The disposition code of the item. This field is only applicable
for Reverse Logistics and Supply Collaboration.

Line Type The type of the order line. Sterling Selling and Fulfillment
Foundation has no application logic associated with the order
line type. This field can be set up as per your business
practices.

Order Type The type of the order. Sterling Selling and Fulfillment

Foundation has no application logic associated with the order
type. This field can be set up as per your business practices.

Payment Status

The payment status of the order.

Sale Voided

The flag indicating whether the order is voided.

Transaction ID

The ID of the last transaction that was run on the order.

Participant Attributes

Bill To ID

The ID of the bill to address for the order.

Buyer Organization Code

The code of the organization that is buying the goods or
services.

Enterprise Code

The code of the enterprise on the order.

Receiving Node

The node that receives the shipment for the order.

Seller Organization Code

The code of the organization that is selling the goods or
services.

Ship Node

The node that ships the shipment for the order.

Ship Node Interface Type

The interface type of the ship node on the order (External
Application, Console, Sterling Store Inventory Management,
or WMS 6.2).

Ship To ID

The ID of the ship to address for the order.

Supplier Code

The code of the supplier for the order.

Item Attributes

Item ID

The ID of the item on the order line.
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Table 365. Master Order Fulfillment Condition Builder Attributes (continued)

Attribute Description

Item Group Code The group code of the service item. For example, if the
service is a provided service item, then the item group code
is PS.

Product Line The product line of the item on the order line.

Sourcing Attributes

Fulfillment Type The fulfillment type of the order.

Intentional Backorder The flag indicating whether the order was intentionally
dropped into backordered status at order creation.

Is Firm Predefined Node The flag indicating whether the node on the order is a firm
predefined node.

Order Sourcing The order sourcing classification of the order.
Classification
Reservation Mandatory The flag indicating whether the reservation is mandatory.

Related Master Order Attributes

Chain Type The chain type of the order.

Is Chained Line The flag indicating whether the order line is chained with
another order line.

Is Derived Line The flag indicating whether the order line is derived from
another order line.

Order Purpose The purpose of the order. If this is an exchange order, this
field is set to EXCHANGE.

{Enter Your Own A customizable condition builder attribute. For more

Attribute} information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Quote

Quote Fulfillment

The Quote Fulfillment condition builder attributes are identical to the Order
Fulfillment condition builder attributes.

Load Execution

Table 366. Load Execution Condition Builder Attributes

Attribute Description
Load Type The type of the load document.
Enterprise Code The code of the enterprise on the load document.

Owner Organization Code | The code of the organization that owns the load document.

Carrier The carrier used to carry the load.

Carrier Service Code The code of the carrier service used to carry the load.
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Table 366. Load Execution Condition Builder Attributes (continued)

Attribute Description

Ship Mode The shipment mode that is used for the shipment. For
example, Parcel, Truck Load, Less-Than Truck Load.

Hazardous Material The flag indicating whether hazardous materials are being
carried in this load.

Origin Node The node where the load originated from.

Destination Node The node where the load is being shipped to.

Multiple Load Stop The flag indicating whether or not a shipment goes through
multiple stops to load or unload additional shipments.

{Enter Your Own A customizable condition builder attribute. For more

Attribute} information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

General

The following Condition Builder attributes are identical to those for WMS Putaway,
WMS Layout Definition, WMS Inventory, Trailer Loading, Task Execution, Move
Request Execution, Manifesting, and Over Pack Build.

Table 367. General Condition Builder Attributes

Attribute Description

Enterprise Code The code of the enterprise.

Organization Code The code of the organization.

Provider Organization The code of the organization that provides the service.

Code

Ship Node The node that ships this shipment.

Supply Type The supply type associated with the inventory status. Typical
values are Onhand, Held, etc.

Item ID The ID of the item on the order line.

Unit Of Measure The unit of measure of the item.

Product Class The inventory classification of an item based on the product's

characteristics. Typical values are FQ - First Quality, SQ -
Second Quality, etc.

Inventory Status The inventory sub classification of the product, based on the
results of the inventory control processes within the
warehouse. Typical values are Good - Good Inventory,
Damaged - Damaged inventory, Qlty-Hold - Quality Hold,

etc.

Adjustment Type The type of inventory adjustment. Typical values are Cycle
Count, Receipt, Picking, Packing, Shipping, etc.

Alert Type The type of alert raised when an exception occurs.

Carrier The carrier used to carry the shipment.
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Table 367. General Condition Builder Attributes (continued)

Attribute Description

Task Type The Task Type applicable to a task. Typical values are Receipt,
QC, Count, Replenishment, Retrieval, Putaway, VAS, Pack,
Shipping, and Picking.

Assigned To User ID The ID of the user to whom the task is assigned.

Task Status The Task Status within the pipeline that the task travels
through. Typical values are Open, Suggested, In Progress,
Held, Completed, Canceled, etc.

Document Type The document type for this order. Typical values are Sales
Order, Purchase Order, Transfer Order, and Return Order.

SC UI Client Version The Rich Client Platform application version number.

Activity Group ID The identifier for the activity group.

{Enter Your Own A customizable condition builder attribute. For more

Attribute} information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

WMS Putaway

The WMS Putaway condition builder attributes are identical to the General
attributes.

WMS Layout Definition

The WMS Layout Definition condition builder attributes are identical to the
General attributes.

WMS Inventory

The WMS Layout Inventory condition builder attributes are identical to the
General attributes.

Trailer Loading

The Trailer Loading condition builder attributes are identical to the General
attributes.

Task Execution

The Task Execution condition builder attributes are identical to the General
attributes.
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Move Request Execution

The Move Request Execution condition builder attributes are identical to the

General attributes.

Manifesting

The Manifesting condition builder attributes are identical to the General attributes.

Over Pack Build

The Over Pack Build condition builder attributes are identical to the General

attributes.

Count Execution

Table 368. Count Execution Condition Builder Attributes

Attribute

Description

Enterprise Code

The code of the enterprise for which the count request is
created.

Request Type

The type of count requested.

Count Program Name

The name of the count program for which the count request
is created.

Node Key

The node where the count request is processed.

Zone ID

The zone where the count must be performed.

Location Size Code

The capacity of the location where the count must be
performed.

Is LPN Level

The flag indicating whether the count tasks are be performed
at the LPN level.

Is Case Level

The flag indicating whether the count tasks are be performed
at the case level.

Is Pallet Level

The flag indicating whether the count tasks are be performed
at the pallet level.

Is Item Level

The flag indicating whether the count tasks are be performed
at the item level.

Is Resolvable

The flag indicating whether variance can be resolved for this
count result.

Product Class

The inventory classification of an item based on the product's
characteristics. Typical values are FQ - First Quality, SQ -
Second Quality, etc.

Unit Of Measure

The unit of measure of the item that was counted.

Item Classification 1

The first item classification attribute for determining the
Count Strategy.

Item Classification 2

The second item classification attribute for determining the
Count Strategy.

Item Classification 3

The third item classification attribute for determining the
Count Strategy.

Has Variance

The flag indicating whether the count request has a variance.
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Table 368. Count Execution Condition Builder Attributes (continued)

Attribute

Description

Has Absolute Variance

The flag indicating whether the count request has an absolute
variance.

Variance Quantity

The difference in quantity (+/-) between the count result and
system quantity.

Absolute Variance
Quantity

The absolute difference between the count result and system
quantity.

Variance Value

The difference in cost/value (+/-) between the count result
and system quantity.

Absolute Variance Value

The absolute difference in cost/value between the count
result and system quantity.

Has Variance With
Previous Count

The flag indicating whether the variance between the current
count result and previous count results displays.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Pack Process

Table 369. Pack Process Condition Builder Attributes

Attribute Description
Node Attributes
Ship Node The node that ships this shipment.

Receiving Node

The node that receives this shipment.

Ship from Ship Node
Interface Type

The interface type of the ship node from which the shipment
is shipped (External Application, Console, Sterling Store
Inventory Management, or WMS 6.2).

Ship from Supplier Code

The code of the supplier that is shipping the shipment.

Ship from DCM
Integration Real Time

The flag indicating whether the node from which the
shipment is shipped uses WMS 6.2.

Ship from Country/Region

The code of the country or region from which the shipment is
being shipped.

Ship to Ship Node
Interface Type

The interface type of the ship node to which the shipment is
shipped (External Application, Console, Sterling Store
Inventory Management, or WMS 6.2).

Ship to Supplier Code

The code of the supplier to whom the shipment is being
shipped.

Ship to DCM Integration
Real Time

The flag indicating whether the node to which the shipment
is shipped uses WMS 6.2.

Ship to Country/Region

The code of the country or region to which the shipment is
being shipped.

Organization Attributes

Enterprise Code

The code of the enterprise that owns the shipment.
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Table 369. Pack Process Condition Builder Attributes (continued)

Attribute

Description

Buyer Organization Code

The code of the organization that is buying the goods or
services.

Seller Organization Code

The code of the organization that is selling the goods or
services.

Shipment Attributes

Ship Mode The shipment mode that is used for the shipment. For
example, Parcel, Truck Load, Less-Than Truck Load.
Carrier The carrier used to carry the shipment.

Freight Terms

The freight terms of the shipment.

Delivery Code

The code of the entity that pays for the transportation costs.

Pack And Hold

The flag indicating whether the shipment needs to be packed
and put away for retrieval at a later date.

Shipment Container Count

The number of containers in the shipment.

Shipment Containerized
Flag

The flag indicating the containerization state of the shipment.
The values are: 01 - not containerized, 02 - containerization in
progress and 03 - containerization completed.

Container Attributes

Is Shipment Container

The flag indicating whether the container belongs to a
shipment.

Is Load Container

The flag indicating whether the container is part of a load.

Is Inventory Pallet

The flag indicating whether the container is an inventory
pallet.

Is Converted From LPN

The flag indicating whether the inventory container has been
converted to a shipment container.

Is Serial Capture Pending

The flag indicating whether the serial capture is pending for
the container.

Is Pack Process Complete

The flag indicating whether any more pack activities are
pending for the container.

Is Product Placing
Complete

The flag indicating whether placing the product into the
container according to the system's suggestion has been
completed.

Requires VAS

The flag indicating whether the container requires value
added services.

Has Child Containers

The flag indicating whether a container is a parent container
having other containers.

Number of Items

The number of items contained in the container.

Container Type

The attribute that specifies whether a shipment container is a
case or pallet.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.
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Outbound Picking

Table 370. Outbound Picking Condition Builder Attributes

Attribute

Description

Activity Group ID

The identifier for the activity group.

Shipment Group ID

The identifier for the shipment group.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

VAS Process

Table 371. VAS Process Condition Builder Attributes

Attribute

Description

Enterprise Code

The code of the enterprise that owns the item or license plate.

Provider Organization
Code

The code of the organization that provides the service.

Node Key

The node, where the work orders are run.

Purpose

The purpose for the work order (ORDER / STOCK / SHIP)

Service Item Group Code

The code of the service item group (KIT/DKIT/COMPL/
INVC/PS)

Service Item ID

The identifier for the service Item.

Segment Type

The type of segment. This may be MTO (made to order) or
MTC (made to customer).

Segment

The segment to which the inventory involved in the work
order belongs.

Has Components

The flag indicating whether the work order has component
items.

Status

The status of the work order.

Pre Call Status

The flag indicating the status of the pre-call process.

Appt Status

The status of the appointment. This is in sync with the
service order line. The appointment status is used in case of
provided service work order.

Number Of Attempts

The number of attempts made to run the work order.

Number Of Hours until

The number of hours left before the appointment for the

Appointment service item.
Number Of Hours After The number of hours after the last appointment for the
Appointment service item.

Number Of Hours After
Last Execution

The number of hours after the last attempt to run the service.

Last Execution Success

The flag indicating whether the last attempt to run the service
was successful or not.
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Table 371. VAS Process Condition Builder Attributes (continued)

Attribute

Description

Open Work Order Flag

The flag indicating whether the execution of the work order
has ended or not.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Opportunity

354

Opportunity Fulfillment

Table 372. Opportunity Fulfillment Condition Builder Attributes

Attribute

| Description

Opportunity Attributes

Opportunity ID

The ID of the opportunity.

Opportunity Name

The name of the opportunity.

Status

The status of the opportunity.

Currency Value

The currency value of the opportunity.

Probable Success Rate

The likelihood of whether an order will be created from the
opportunity.

Participant Attributes

Bill To ID

The ID of the bill to address for the opportunity.

Buyer Organization Code

The code of the organization that may buy the goods or
services.

Enterprise Code

The code of the enterprise for the opportunity.

Owner User ID

The user ID of the opportunity owner.

Co-Owner User ID

The user ID of the opportunity co-owner.

Customer Contact ID

The ID of the customer contact for the opportunity.

Team Code

The code of the team that manages the opportunity.

{Enter Your Own
Attribute}

A customizable condition builder attribute. For more
information about customizing this field, see the Sterling
Selling and Fulfillment Foundation: Extending the Condition
Builder.

This field is limited only to unexposed key attributes that are
predefined by Sterling Selling and Fulfillment Foundation as
opposed to any XML attribute that you can enter.

Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide




ltem Based Allocation

The Item Based Allocation transaction allocates unpromised and promised
demands of existing orders to more suitable supplies based upon inventory items
and nodes which have been triggered for the Item Based Allocation process in the
YFS_IBA_TRIGGER table.

The Item Based Allocation agent obtains and processes all Item Based Allocation
triggers from the YFS_IBA_TRIGGER table that meet the following conditions:

e IBA_RUN_REQUIRED = "Y"

 LAST IBA_PROCESSED_TS was 'x' hours before current time, where 'x' is from
the ‘Item Based Allocation Agent Execution Interval (in hours)' rule in the
Installation rules. For more information about installation rules, refer to the topic
"System Administration Components: Defining Installation Rules" in the Sterling
Selling and Fulfillment Foundation: Configuration Guide. This rule is used to
indicate the interval that the Item Based Allocation agent should not reprocess
the triggers in the YFS_IBA_TRIGGER table, which were processed earlier. This
prevents the IBA agent from over-processing the item and node combination in
the given time interval to avoid any high loads on the system.

¢ PROCESSING_BY_AGENT="N" or PROCESS_OVER_BY_TS is before the current
timestamp. The PROCESSING_BY_AGENT field is used to prevent the picking
up of the IBA trigger which is being processed by another instance of the agent.

If InventoryOrganizationCode is specified in the agent criteria, only the IBA trigger
with inventory items of that inventory organization is retrieved.

For each triggered item and node combination, the agent finds all of the applicable
order lines or order line reservations that contain the item and node and tries to
move their unpromised and promised demands to more suitable available supplies
based on user-configured IBA selection rules or FIFO (First-In-First-Out) IBA
selection rules.

Sterling Selling and Fulfillment Foundation creates new positive order line
reservations with the matched supply's first ship date and negative order line
reservations for the existing demand ship date. Once all orders are processed, they
are placed on hold to be rescheduled if changes are detected in the order line
reservations.

The following configuration is required for the Item Based Allocation process:
e The Use Item Based Allocation rule needs to be enabled.
e Ttem and node need to have Item Based Allocation Allowed enabled.

* A hold type is required to be set up for the change order line reservations
modification type so that the order can be placed on hold for rescheduling. For
more information, refer to the Sterling Selling and Fulfillment Foundation: Javadocs.

The ‘When a line is backordered, backorder against the highest priority ship node'
rule should be checked in order to reallocate backordered demand. For more
information, see the Fulfillment Rules section in the Sterling Selling and Fulfillment
Foundation: Distributed Order Management Configuration Guide.

Before processing the Item Based Allocation logic, the Item Based Allocation agent
updates the following fields on the Item Based Allocation trigger:

¢ PROCESSING_BY_AGENT = “Y”. This indicates that an instance of the agent is
currently processing this trigger.
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* PROCESS_OVER_BY_TS = current time + 1 hr. This indicates the expected time
that the agent should finish with processing this IBA trigger. One hour is the
fixed window and cannot be changed. Sterling Selling and Fulfillment
Foundation treats the PROCESSING_BY_AGENT flag as “N” regardless of the
actual value when current timestamp is after this timestamp.

e IBA_RUN_REQUIRED = “N”. This resets the IBA_RUN_REQUIRED flag back to
IINI/.

Obtaining a List of Demands Based on Applicable Order Release
Statuses and Order Line Reservations to be Allocated

A list of demands is derived from applicable order release statuses and order line
reservations, which have the item and node in the IBA trigger. The following types
of demands are retrieved:

* Demands of chained orders
* Demands of orders with chained order already created

* Demands of orders with procurement node but chained order creation is not yet
created

* Demands of orders without procurement node

¢ Demands from order line reservations

The demand quantity is derived based on the order release status quantity with
the status from the Status Inventory Type configuration that has a demand type,
which considers the supply type with ‘Use Consider Demand Type for Item Based
Allocation' enabled. For more information, refer to the Sterling Selling and
Fulfillment Foundation: Global Inventory Visibility Configuration Guide.

Obtaining a List of Available Supplies for Allocation

Sterling Selling and Fulfillment Foundation obtains the available supply based on
the availability of the item at the node by ignoring unpromised and promised
demands. If the inventory organization maintains its inventory externally, the
external availability can be read by the YFSGetExternalInventoryUE user exit. Only
the availability of supplies that consider the ‘Demand Type Look for Availability
during Item Based Allocation' are used in the allocation logic. For more
information, refer to the Sterling Selling and Fulfillment Foundation: Global Inventory
Visibility Configuration Guide.

Allocated demands should be matched with the same supplies as "Demand to look
for during release".

Matching Demands Against Supplies in FIFO (First-In-First-Out)
Order

Sterling Selling and Fulfillment Foundation sorts the list of available supplies in
the order of the first shippable date (ETA), and matches the obtained list of
demands using the top-down logic (unlike the normal matching logic for obtaining
availability, where matches are based on the closest ETA). Demands are allocated
in the following orders:

* Demands of chained orders - first based on user-configured sequencing rules,
and then in ascending order of order creation date. (These types of demands are
matched based on the closest ETA to avoid any changes in the chained orders).

356  Sterling Selling and Fulfillment Foundation: Supply Collaboration Configuration Guide



* Demands of orders with a chained order already created - first based on
user-configured sequencing rules, then in ascending order of product availability
date. (These types of demands are matched based on the closest ETA to avoid
any changes in the orders).

* Demands of orders for which procurement node and chained order creation is
imminent (within the advanced notification time window) - first based on
user-configured sequencing rules, then in order of order creation date.

¢ Demands of orders without a procurement node and within the release window
(advanced notification time window) - first based on user-configured sequencing
rules, then in order of order creation date.

¢ Demands from order line reservations on the order lines in the order of
requested reservation date, and left-over demands (outside of the advanced
notification time window) of orders with or without a procurement node, first
based on user-configured sequencing rules and then in the order of order
creation date.

* Demands from inventory reservations in the order of ship date.

Notice that different types of demands are given different priorities based on their
significance. The demands of chained orders or orders related to chained orders
are treated with a higher priority than the demands of normal orders. Furthermore,
the demands with a ship date within the advanced notification time window also
have a higher priority than the demands with a date outside of the advanced
notification time window.

Updating Order Reservations for the Matched Demands

After matching the available supply and demand in user-configured sequencing
and then in FIFO order, the system builds up a list of order line reservation
changes and inventory demand changes (corresponding to the order line
reservation changes) and summarize them to optimize the number of order
reservation updates and inventory updates. Negative order line reservations are
added for the matched demands. Positive order reservations are added for the
matched demands with the product availability date set to the matched supplies'
first ship date.

After the Item Based Allocation agent completes its tasks for an Item Based
Allocation trigger, it updates the fields of the trigger with the following values:

* IBA_REQUIRED = "N"

* LAST_IBA_PROCESSED_TS = current timestamp.
e PROCESS_OVER_BY_TS = current timestamp.

* PROCESSING_BY_AGENT = "N”

The Item Based Allocation agent should be used in conjunction with the
rescheduling process as the rescheduling process reschedules the affected orders by
utilizing the order line reservations created by the Item Based Allocation process.

Attributes

The following are the attributes for this time-triggered transaction:
Table 373. Item Based Allocation Attributes

Attribute Value
Base Transaction ID ITEM_BASED_ALLOCATION
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Table 373. Item Based Allocation Attributes (continued)

Attribute Value
Base Document Type General
Base Process Type General
Abstract Transaction No

APIs Called

changeOrder — for updating the order line reservations created
as part of the Item Based Allocation process.

User Exits Called

None

Criteria Parameters

The following are the criteria parameters for this transaction:

Table 374. Iltem Based Allocation Criteria Parameters

Parameter

Description

Action

Required. Triggers the transaction. If left blank, it defaults to
Get, the only valid value.

Number of Records To

Optional. Number of records to retrieve and process at one

Buffer time. If left blank or specified as 0 (zero), it defaults to 5000.

InventoryOrganization The inventory organization code of the inventory items which

Code are processed by the Item Based Allocation agent. If provided,
only the IBA triggers with the inventory item that belongs to
this inventory organization are processed.

ColonyID Required in a multischema deployment where the

YFS_IBA_TRIGGER table may exist in multiple schemas. Runs
the agent for the colony.

Statistics Tracked

The following statistics are tracked for this transaction:

Table 375. Item Based Allocation Statistics

Statistic Name

Description

NumOrdersProcessed Number of orders processed by the Item Based
Allocation agent.
NumOrdersRequiredReschedule Number of orders required rescheduling as the

result of Item Based Allocation process.

Pending Job Count

None.

Events Raised

This transaction raises events as specified under the changeOrder API in the
Sterling Selling and Fulfillment Foundation: Javadocs.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.

1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
J46A/G4

555 Bailey Avenue

San Jose, CA 95141-1003
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.
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This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© IBM 2012. Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2012.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “/Copyright and]
ftrademark information|’ at |http:/ /www.ibm.com /legal /copytrade.shtml|

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise®, Gentran®,
Gentran®:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce ",
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.
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