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Localization of Sterling Business Intelligence: An Overview
The Sterling Business Intelligence solution can be used by users from different locales to generate 
dashboards and reports. Localization of Sterling Business Intelligence is the process of adapting Sterling 
Business Intelligence for a particular country or region. Localization enables Sterling Business Intelligence 
to support the character set of a user’s locale, and display numbers, literals, and report data that is 
appropriate to the locale.

Localization of Sterling Business Intelligence includes the following tasks:

✦ Localize Sterling Business Intelligence User Interface
✦ Localize Sterling Business Intelligence Dashboard Literals
✦ Localize Sterling Business Intelligence Report Literals
✦ Localize Sterling Business Intelligence Reports and Dashboard Data

Intended Audience
This manual is intended to provide a general localization procedure for users who are responsible for 
localizing the Sterling Business Intelligence solution. 



Localize Sterling Business Intelligence User Interface
The user interface components in Sterling Business Intelligence use resource bundles that contain all the 
static literals displayed throughout the application. After you perform the translation into multiple languages 
ensure that you create a folder corresponding to each of the locales and the corresponding bundle files. The 
folder name must be in the format <language>_<country>. For example, if a locale has been created 
for Japan in Japanese language, a folder named ja_JP must be created. In addition, literals used in the 
customized screens have their own resource bundles and must also be considered during the localization 
process.

A resource bundle is a file that consists of the resource bundle keys and the corresponding values. Each field 
in the user interface has a resource bundle key associated with it. The values pertaining to these resource 
bundle keys are translated as part of localization. To display the translated literal pertaining to a field in the 
user interface, the localized value of the key associated with the field is fetched from the bundle file. 

Sterling Business Intelligence supports the following resource bundles:

✦ Menu: The menu resource bundle file enables the localization of menu entries by fetching the values 
from the sbibundle.properties file located in the \resources\sbibundle.properties file.

✦ Screen Literals and Messages: The bundle-index.properties enables to localize the following:
Error and warning messages displayed on the user interface

Descriptions pertaining to labels, panels, and headings in the user interface

Dynamic data within a literal. For example, the user interface may have to display a literal that 
informs a user that an input value cannot exceed a certain number of characters, and that the 
number of characters is dynamic. In this case, if the maximum character length for a description is 
set at 428 characters, 428 is the value of the parameter. The corresponding bundle entry is defined 
as "b_MaxCharLengthExceeded":"The value cannot exceed {0} characters”.

The bundle-index.properties file is located in the \Files\resources\ folder.

For more information about understanding the localizable components and data, refer to the Sterling 
Multi-Channel Fulfillment Solution Localization Guide.

Deploy the Localized Resource Bundle
Perform the following steps after the localization of resource bundle:

1. Rename the localized sbibundle.properties file to 
sbibundle_<language>_<country>.properties.
For example, if you are localizing the Sterling Business Intelligence application for Japanese language, 
then rename
the localized file to sbibundle_ja_JP.properties.

2. Copy the renamed file to the following location:
<INSTALL_DIR>/resources folder.
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Localize Sterling Business Intelligence User Interface
3. Rename the localized bundle-index file to bundle-index_<language>_<country>.
For example, if you are localizing the Sterling Business Intelligence application for Japanese language, 
then rename the localized file to bundle-index_ja_JP.

4. Create the resource jar using the ./deployer.sh -t resourcejar.Navigate to the <INSTALL_DIR>/bin 
folder.

5. Run the following command:
Note: Ensure that the directory <INSTALL_DIR> is set as environment variable.

ant -f jsUtil.xml bundle.map

-Dsourcedir=<INSTALL_DIR>/repository/eardata/sbi/war

-Dindexdir=<localization directory having the localized bundle-index file>

-Dindexfile=<localization directory having the localized bundle-index 
file>/bundle-index -Dwebcontentdepth=0

For example, if you have localized to French locale and the localization directory is:
<localization dir>/Files/resources/fr/FR, then you must run the following 
command:

ant -f jsUtil.xml bundle.map

-Dsourcedir=<INSTALL DIR>/repository/eardata/sbi/war

-Dindexdir=<localization dir>/Files/resources/fr/FR

-Dindexfile=<localization dir>/Files/resources/fr/FR/bundle-index

-Dwebcontentdepth=0

6. To create minified file for Java Scripts file, run the following command:
ant -f jsUtil.xml minify-js -DsrcDir=/<Root directory where the Sterling 
Business Intelligence application is installed> -DdestDir=/< Root directory 
where the Sterling Business Intelligence application is installed>/ 
-Dminify=true -DcreateIndividualFile=false -DjsbDir=/< Directory where jsb 
file is installed>/

For example, the root directory where the Sterling Business Intelligence application is as follows:
data4/autoDeployment/InstallDirs/SBI/Install/repository/eardata/sbi/war

7. Re-create the smcfs.ear file. This file is the Selling and Order Management Foundation EAR 
package.
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Localize Sterling Business Intelligence Dashboard Literals
The dashboards in Sterling Business Intelligence use a common resource bundle that contains the literals 
displayed on the screens. You can localize the dashboard headers, column titles, field names, chart titles, 
and chart legends. 

The resource bundles of Sterling Business Intelligence are located in the 
<BI_COGNOS8_HOME>/resources/sbianalyticsbundle.properties file. IBM® Cognos® 8 
Business Intelligence Content is installed in the <BI_COGNOS8_HOME> folder.

Note: Sterling Commerce always releases all the resource bundles in the 
sbianalyticsbundle.properties file with the localized versions of Sterling Business 
Intelligence. Incremental updates for the sbianalyticsbundle.properties file are not 
provided. When localizing the Sterling Business Intelligence dashboards, it is your responsibility or 
that of your localizing company to compare and validate the differences between the resource 
bundles.

To localize the resource bundles, perform the following tasks:

1. Open the <BI_COGNOS8_HOME>/resources/sbianalyticsbundle.properties file from the 
<BI_COGNOS8_HOME>/resources folder and save it as 
<BI_COGNOS8_HOME>/resources/sbianalyticsbundle_<language>_<country>.propert
ies.

2. Each resource bundle contains a <key>=<value> pair, where key is the resource key, and value is 
the literal displayed for the corresponding locale. Replace <value> with the translated value.

3. Save the modified file. If the file is in UTF-8 format, convert it to ASCII by running the 
native2ascii command as follows:
native2ascii -encoding UTF-8 <source file> <target file>

The file should be returned in the following format:
<filename>_<2 letter code for language as given by ISO 639>_<2 letter code 
for territory as given by ISO 3166>.<file extension>

For example, sbianalyticsbundle.properties should be returned as 
sbianalyticsbundle_fr_FR.properties.
Note: Files localized in Latin1 languages do not require this conversion.
Sterling Commerce, Inc. 8



Localize Sterling Business Intelligence Dashboard Literals
To localize the dashboard literals, perform the following tasks:

1. Ensure that the environment variable BI_RT is correctly set, for example in UNIX, export BI_RT = 
<BI_COGNOS8_HOME>. 

Note: The <BI_COGNOS8_HOME> directory is the root directory where IBM Cognos 8 Business 
Intelligence Content is installed.

2. Copy the following jar files to <BI_COGNOS8_HOME>/lib folder from 
<COGNOS_HOME>/ap/webapps/p2pd/WEB-INF/lib folder.

axis.jar

axisCrnpClient.jar

CAM_AAA.jar

CAM_AAA_CustomIF.jar

commons-discovery.jar

commons-logging-1.0.4.jar

dom4j.jar

jaxrpc.jar

saaj.jar

soap.jar

xalan.jar

xercesImpl.jar

xml-apis.jar

3. To localize the dashboard literals in the <BI_COGNOS8_HOME> folder, execute the following 
command:

If you have you have installed IBM® Cognos® 8 Business Intelligence and Sterling Business 
Intelligence on the same machine, run the following command:
ant -f sbilocalizer.xml import

If you have installed IBM Cognos 8 Business Intelligence and Sterling Business Intelligence on 
two different machines, modify the following line of the XML by replacing localhost with the 
IP address of the machine on which IBM Cognos 8 Business Intelligence has been installed:
<property name="cognosurl" 
value="http://localhost:9300/p2pd/servlet/dispatch"/>

Then run the following command:
ant -f sbilocalizer.xml import 

Note: The sbilocalizer.xml file can be executed in the following modes:
ant -f sbilocalizer.xml validate, to validate the dashboard literals in the 
sbianalyticsbundle_<language>_<country>.properties file.

ant -f sbilocalizer.xml extract, to export the dashboard literals.
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Localize Sterling Business Intelligence Dashboard Literals
The sbilocalizer.xml command reads all the bundles in the <BI_COGNOS8_HOME>/resources 
folder. It then adds the literal translations for each locale into the dashboard definitions present in the 
<BI_COGNOS8_HOME>/reports folder. The modified dashboard definitions are copied into the 
<BI_COGNOS8_HOME>/localizedreports folder, and added into the content repository. When the 
dashboards are generated again, the literals are displayed according to the user’s locale.
Sterling Commerce, Inc. 10



Localize Sterling Business Intelligence Report Literals
You can localize the Sterling Business Intelligence report labels and report titles by exporting and importing 
language translation files using the IBM® Cognos® Adaptive Analytics application. 

To localize the Sterling Business Intelligence report literals, perform the following tasks:

1. Launch the IBM Cognos Adaptive Analytics application and open the project that you want to localize.
2. From Project menu, navigate to Languages > Define Languages.

The Define Languages window is displayed. 
3. From the Available Languages list, select each language that you want to add and click the arrow 

button to move it to the Project languages box and click OK. 
4. From the Project menu, navigate to Languages > Export Translation File.

The Export Translation File window is displayed.
5. Select each language that you want to export, and click the arrow button to move them into the 

Languages to be exported box. 
6. Enter the location of the folder from where the 

<AC_INSTALL_DIR>\resources\sbiaabundle_<languagecode>_<localecode>.csv 
translation file must be exported. 

7. Open the sbiaabundle_<languagecode>_<localecode>.csv file and modify the contents of 
the file to match your locale and save the file using the File > Save option.

8. From the Project menu, navigate to Languages > Import Translation File.
The Import Translation File window is displayed. 

9. From the Project Languages list, select the required project language.
10. Select the 

<AC_INSTALL_DIR>\resources\sbiaabundle_<languagecode>_<localecode>.csv file 
that must be imported. Sterling Business Intelligence Analytics Content is installed in the 
<AC_INSTALL_DIR> folder.

11. Click OK.
12. Click Save.
13. From the Actions menu, select Generate Deployment Archive.

The Save As window is displayed. 
14. In the File name box, enter a name for the archive.
15. Click Save. 

The Validate Object dialog box is displayed. 
16. Click Close.

The deployment archive is created. You can now publish your reports in IBM Cognos Connection. 
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Localize Sterling Business Intelligence Report Literals
For more information about publishing your reports in IBM Cognos Connection, refer to the IBM® Cognos® 
8 Analytic Applications Adaptive Analytics User Guide.
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Localize Sterling Business Intelligence Reports and 
Dashboard Data
You can localize the data in the Sterling Business Intelligence reports and dashboards using the IBM® 
Cognos® Adaptive Warehouse application. All the data present in a dashboard that describing an entity, for 
example, Category Description, Region Description, Buyer Description and so on, are localized in the data 
warehouse database. The data warehouse database contains localized data from the 
YFS_LOCALIZED_STRINGS table, which is transformed and added as additional columns.

Note: Before you start the data localization process, the database factory default values must be localized. 
For more information about localization for multilanguage installation, refer to the Sterling 
Multi-Channel Fulfillment Solution Localization Guide.

To localize the data in the Sterling Business Intelligence reports and dashboards, perform the following 
tasks:

1. Launch the IBM Cognos Adaptive Warehouse application. By default, the application opens in the 
Warehouse view.

2. From the Actions menu, select Edit Data languages.
The Specify Project Languages pop-up window is displayed.

3. Click Add. 
4. Enter the New Languages and Language code.
5. Click OK.
6. Click Synchronize Target Metadata. 
7. Click Save and perform the load management. 

For more information about performing load management, refer to the IBM® Cognos® 8 Analytic 
Applications Adaptive Warehouse User Guide.

.



Sterling Commerce, Inc. 14

Factory Setup Data
Besides storing your transactional data, the database also stores configuration data. This means that the 
database may need to store values in a language-specific format. If these database literals are not localized, 
screen literals display inconsistently, with some displaying in the localized language and others displaying 
in English.

The sbifcliterals2translate.properties contains all the Sterling Business Intelligence factory 
setup literals that need to be localized.

To localize the factory setup data, perform the following tasks:

1. Open the sbifcliterals2translate.properties file and enter the corresponding literals for 
the required locale after the corresponding delimiter.

2. Rename the sbifcliterals2translate.properties file to en_US_ 
sbifcliterals2translate.properties_<language>_<country>.properties.
For example, in the case of French customers, sbifcliterals2translate.properties should 
be renamed to en_US_ sbifcliterals2translate.properties_fr_FR.properties, where 
fr indicates the language, that is French, and FR indicates the country, France.

3. Copy the following files to the 
<INSATLL_DIR>/installed_data/sscap/components/complete_installation/factory
setup/XMLS/<language>_<country> folder. The <INSATLL_DIR> is where the Selling and 
Fulfillment Foundation installed.

4. Run the following command from <INSATLL_DIR>/bin folder
For Windows:
sci_ant.cmd -f localizedstringreconciler.xml import 
-Dsrc=<INSATLL_DIR>/installed_data/sscap/components/complete_installation/f
actorysetup/XMLS -Dbasefilename=sbifcliterals2translate

For UNIX or Linux:
sci_ant.sh -f localizedstringreconciler.xml import 
-Dsrc=<INSATLL_DIR>\installed_data\sscap\components\complete_installation\f
actorysetup\XMLS -Dbasefilename=sbifcliterals2translate

Note: The <BI_COGNOS8_HOME> is the directory where Cognos 8 Business Intelligence Content is 
installed.
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