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Chapter 1. Working with VDA Standards

About the VDA Standards
VDA is the German automotive standard. The VDA standards are not included in
the IBM® Sterling Gentran® Standards Database for EDI.

Support for VDA requires special procedures in setting up trading partners and in
configuring IBM Sterling Gentran:Server® for Microsoft Windows. This document
describes these steps and provides a tutorial for processing a sample VDA
message.

VDA has several features that distinguish it from most other standards supported
by Sterling Gentran:Server:
v It does not use a common set of interchange envelopes for all messages.
v It does not use functional groups.
v It uses a positional, nondelimited format.
v It uses looping but not composite elements.
v It uses a new control number (for the current transmission) and an old control

number (for the previous one). As a result, control numbers do not need to be
sequential.

v In some messages, it processes date formats differently.
v It uses a separate message to identify the communications protocol. A message is

defined by a four-digit number, which doesn't appear in the data.
v The first record has six fields: version, customer, supplier, old transmission

number, new transmission number, and transmission date.
v Each record begins with a three-byte record ID and a two-byte version number.

IBM provides VDA support for Sterling Gentran:Server by providing file format
definitions, or .ifd files, on a separate DVD. You install the file format definitions
using the install program on the DVD. The install program places all .ifd files and
build and break maps into the Gensrvnt\Maps\Vda folder and all .tpl files into the
Gensrvnt\Transobj\Vda folder. The tutorial data files are stored in the
Gensrvnt\Tutorial\Vda folder.

For more information on the VDA standard, go to:

http://www.vda.de/index.html

For more information on ordering VDA recommendations, go to the following and
select the VDA-Empfehlungen option:

http://www.vda.de/de/publikationen

VDA Support in Sterling Gentran:Server
Sterling Gentran:Server currently supports the following VDA message types:
v 4905
v 4906
v 4907
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v 4908
v 4913
v 4915

To use VDA with Sterling Gentran:Server, you must make changes to following
functions:
v translation objects (compiled maps)
v trading partner definitions, and the
v Sterling Gentran:Server configuration

IBM provides the following map files to support VDA messages. Similar files are
used to support the other message types.

File Name Description

BrkIvda.map Interchange break map

BrkTvda.map Transaction break map

BldIvda.map Interchange build map

BldTvda.map Transaction build map

*.ifd VDA side of map

IBM provides an .ifd file (for example, 4908.ifd) for each supported VDA message
type. As support is provided for additional messages, IBM will update the
provided maps.

Note: The CDA version of a specified message is part of the name of the .IFD file.
For example, the name of file 4905_ED4_0496.IFD indicates that this file contains
the VDA structure of the VDA message 4905 of edition 4, that is dated from April
1996.

This table lists the headers and trailers for other supported VDA message types:

Message type Header Trailer

4905 511 519

4906 811 819

4907 911 919

4908 821 829

4913 711 719

4915 551 559

Outbound VDA Envelope Dialog Box
Use the Outbound VDA Envelope dialog box to assign values to be used with
specific headers in VDA messages.

Use the Outbound VDA Envelope dialog box when you want to provide
information to be included in the outbound interchange envelope using the
Trading Partner information, rather than through the application file.

This diagram illustrates the Outbound VDA Envelope.
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This table describes the fields on the Outbound VDA Envelope dialog box, as well
as the length of each field.

Field Name
Field
Length Description

Supplier Number 9 An identification number assigned to a supplier by a
customer. All fields of a record structure that contain the
field Supplier Number are subject to data privacy protection.
Data entries are left justified.

Customer
Number

9 An identification number assigned to a customer by a
supplier. All fields of a record structure that contain the field
Customer Number are subject to data privacy protection.
Data entries are left justified.

Sender Number 9 An identification number that the data sender arranges with
the data receiver.

Receiver Number 9 An identification number that the data receiver arranges
with the data sender.

Data Sender 9 An identification number that the data sender arranges with
the data receiver.

Data Source
Number

9 An identification number that the data source arranges with
the data receiver.

Sub Suppliers 9 An identification number that is assigned to a sub supplier
by a customer.

Sales Tax ID
Recipient

20 An identification number of the national tax office for the
recipient. This field is mandatory for delivery of goods
within the European Union. Data entries are left justified.

Sales Tax ID
Sender

20 An identification number of the national tax office for the
sender. This field is mandatory for delivery of goods within
the European Union. Data entries are left justified.

Payment
Indication
Number

6 A link between data transmission payment notification and
real payments received. This includes the Check number
and remittal number. Data entries are left justified.
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Field Name
Field
Length Description

Comp. Reg.
Number

25 An identification of the National Register of Business Names
(Commercial Register) for the supplier. This field is
mandatory for some European countries.

Carrier Number 9 The carrier data number of VDA message 4920. If relevant,
the contents of this field will be identical to the contents of
the field in record type 712, position 13.

Warehouse
Keeper Code

1 A code that identifies the person who created the
interchange.

Purpose Code 2 Not used in this release.

This table shows the fields of the Outbound VDA Envelope and the VDA message
headers that the field is used with. An X indicates that the field is used with that
VDA message and is required on the Outbound VDA Envelope dialog box.

Field Name

Message/Release Date

4905/
1088

4905/
0496

4906/
0593

4907/
0893

4908/
0596

4913/
1094

4915/
1189

Supplier Number X X X X X X

Customer Number X X X X X X

Sender Number

Receiver Number

Data Sender X

Data Source Number X

Sub Suppliers X

Sales Tax ID Recipient X X

Sales Tax ID Sender X X

Payment Indication
Number

X

Comp Reg. Number X

Carrier Number X

Warehouse Keeper
Code

X

Purpose code
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Chapter 2. VDA Standards Tutorial

About the Tutorial
This tutorial provides an example of how to set up Sterling Gentran:Server with
VDA message 4908.

In this tutorial, you will do the following:
v Install the VDA tutorial files, maps, and file format definitions.
v Configure Sterling Gentran:Server for use with VDA standards.
v Set up a trading partner mailbox.
v Import a VDA trading partner.
v Compile and register maps.
v Process a sample message, both inbound and outbound.

Installing the VDA Tutorial Data
Before you begin

Before you begin installing the VDA Tutorial data, ensure that you have installed
the latest version of Sterling Gentran:Server.

About this task

Use this procedure to install the VDA tutorial data onto your Sterling
Gentran:Server system.

Procedure
1. Insert the DVD containing the VDA tutorial data, maps, and file format

definitions into the appropriate disk drive.
2. Navigate to the VDA folder on the DVD and double-click Setup.

Windows launches the installation program.
3. Click Next.

The Choose Destination Location dialog box is displayed.
4. Click Next to accept the default installation location.
5. Click OK to complete the installation procedure.
6. Before you begin the tutorial, create a folder called Vda_out in the \Gensrvnt

folder on your hard drive.

Registering the Tutorial Translation Objects
About this task

Use this procedure to register the translation objects provided with the tutorial
data.

Procedure
1. Start Sterling Gentran:Server and select View > Translation Objects.

The EDI Translation Objects dialog is displayed.
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2. Click New to open the Register Translation Object dialog box.
3. Browse to the Gensrvnt\Transobj\Vda folder and select the following files:

v BrkIvda.tpl
v BrkTvda.tpl
v BldIvda.tpl
v BldTvda.tpl

4. Click Open.
The translation objects are now registered and can be used.

5. Click New to open the Register Translation Object dialog box.
6. Browse to the Gensrvnt\Tutorial\Vda folder and select the following files:

v VDA4908_IN.tpl
v VDA4908_OUT.tpl
v Sys_Import_Header.tpl

7. Click Open.
The translation objects are now registered and can be used.

Setting the Import Path
About this task

Use this procedure to set the Sterling Gentran:Server Import Path.

Procedure
1. From the Windows Start menu, select Sterling Gentran:Server > Gentran

Server Configuration.
2. Select the Imports tab.
3. In the File Path box, enter c:\gensrvnt utorial\vda\*.txt.

4. Select Sys Header – VDA from the Translation Object list.
5. Click Move Up so that the path you typed is moved to the top of the list and

thus takes priority.

Creating a Splitter Entry
About this task

Use this procedure to create a new entry in the splitter table.

Procedure
1. From the Windows Start menu, select Sterling Gentran:Server > Gentran

Server Configuration.
2. Select the Splitter tab and click New.
3. Select Positional from the Type list.
4. In the Start box, enter 821, which is the number for the header record in

message 4908.
5. In the End box, enter 829, which is the number for the trailer record in

message 4908.
6. Select VDA Int Break from the Interchange Break list.
7. Select VDA Trn Break from the Transaction Set Break box.
8. Enter 500 in the Max length of End segment box.
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9. Click Apply.
The dialog box should now look like this.

10. Click OK to save your changes and leave Configuration.

Note: You must repeat this procedure for every VDA message type that you
intend to use.

Creating a Trading Partner Mailbox
About this task

Use this procedure to create a trading partner mailbox.

Procedure
1. Select Tools > Mailbox.

The Mailbox Server Manager is displayed.
2. Double-click Gentran:Server Mailbox to expand it. If the mailbox doesn't

expand, the server has not been registered. To register it, follow these steps:
a. Right-click Gentran:Server Mailbox and select Register Server. The

Register Server dialog box is displayed.
b. Enter the machine name of the of the primary system controller and click

OK.
3. Double-click the name of the machine.
4. Right-click Mailboxes and select Create.

The Create Mailbox Wizard is displayed.
5. Name the mailbox VDA Outfile.
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Note: It is normal, but not required, to identify the partner in the mailbox.
The sample VDA partner has not been created yet, so do not identify the
partner.
The second Create Mailbox Wizard dialog box is displayed.

6. For the purposes of this tutorial, select Yes, use this mailbox as a gateway,
and select File System as the type.

7. Click Next to see the summary screen so you can verify the information for
this mailbox.

8. Click Finish.
The File System Gateway properties dialog is displayed.

9. Select the Extraction tab to define the folder to which outbound VDA files are
extracted.

10. Select Extract files from this mailbox and type c:\gensrvnt\vda_out in the
box below it.

11. Select Append all messages to a single file and enter vda4908.out in the box
below it.

12. Click OK to complete the process.

Importing the Tutorial Partner Profile
The Partner Profile defines the parameters that control the processing and structure
of inbound and outbound data. For this tutorial, we have provided a sample
Partner Profile.

About this task

Use this procedure to import the Partner Profile provided for this tutorial.

Procedure
1. Select Partner from the Desktop.

The Partner Editor is displayed.
2. Click Import.

The Import File Select dialog box is displayed.
3. Browse to the Gensrvnt\Tutorial\Vda folder, select VDAPART.PAR and click

Open.
The Import dialog box is displayed.

4. Verify that the Partner to Import box shows VDAPART and click Save.
The system imports the partner details and displays the Partner Editor dialog
box. Sterling Gentran:Server prompts you for any additional information that it
needs by displaying the appropriate Partner Editor dialog box.

5. Click Save when you have finished entering information.
The system displays the message Import Process Complete. Please note any
warnings or errors.

6. Click OK.
7. Click Exit.

Creating an Outbound VDA Map
The normal procedure for using VDA requires that when you create a new map for
outbound messages, you import an .ifd file for the output side of the map. For the
purpose of this tutorial you will use a map that we have already created.

8 IBM Sterling Gentran:Server for Windows: VDA User Guide



About this task

Note: The CDA version of a specified message is part of the name of the .IFD file.
For example, the name of file 4905_ED4_0496.IFD indicates that this file contains
the VDA structure of the VDA message 4905 of edition 4, that is dated from April
1996.

Use this procedure to create an Outbound VDA Map.

Procedure
1. Open Sterling Gentran:Server Application Integration.
2. Select File > Open.
3. Browse to the Gensrvnt\Tutorial\Vda folder and select VDA4908_Out.map.

The Output side of the map now looks like this:

4. Select the top row of the left side of the map, and select View > Expand All.
5. Select the top row of the right side of the map, and select View > Expand All.

Note: If you do not see the link lines, select Options > Preferences and click
the Links tab. Select the Show links to or from all visible elements option.

6. Select Edit > Details.
The Translation Object Details dialog box is displayed.

Note: The entries in the Output section serve as the basis for defining the
Trading Partner information.

Compiling and Registering Tutorial Maps
Before you can use maps, you must compile and register them.

About this task

The following maps are supplied with Sterling Gentran:Server for use with this
tutorial:
v BrkIvda.map - Interchange break map
v BrkTvda.map - Transaction break map
v BldIvda.map - Interchange build map
v BldTvda.map - Transaction build map

Use this procedure to compile and register the tutorial maps.

Procedure
1. To compile the maps, start Sterling Gentran:Server - Application Integration.
2. Select File > Open.
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3. Select a .map file and click OK.
4. Select File > Compile.

Note: The compiled maps (*.tpl files) are saved in the \TransObj folder.
You are now ready to register the translation objects.

5. Select View > Translation Objects.
The Translation Objects dialog box lists the templates that are already registered
with Sterling Gentran:Server.

6. Click New to open the Register Translation Object dialog box.
7. Select the files to register and click Open.

The translation objects are now registered and can be used.

Creating an Outbound Relationship
You need to identify your partner with the outbound translation objects that you
have registered.

About this task

Use this procedure to create an outbound trading partner relationship.

Procedure
1. In Sterling Gentran:Server, click Partners to display the list of partners.
2. From the Partner Editor, click New.
3. In the Profile ID box, enter VDAPART.
4. In the Name box, enter VDATEST.
5. In the EDI Code box and the Application Code box, enter VDATEST.
6. In the Mailbox list, select VDA Outfile or the name you gave when you

created a mailbox.
7. Click Save to save the information and return to the Partner Editor.
8. Select the new partner and click Outbound to begin setting up the outbound

relationship.
The Outbound Relationship dialog box is displayed.

9. Click New

10. Enter Outbound 4908 in the new description box.
11. Click Save to return to the Outbound Relationship dialog box.
12. Select V-VDA from the Standard list.
13. Select 4908 from the Version and Transaction Set lists.

Note: These items are available here because you registered maps that contain
this information in the Translation Objects Details dialog.

14. Click Groups and select <none>.
15. Click Translation to define the Outbound Translation Objects dialog box.
16. Select Sample App to 4908 from the Import list.
17. Select VDA Trn Build from the Transaction list.

The Outbound Translation Objects dialog box should now look like this.
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18. Click Save.
19. Click Interchanges from the Outbound Relationship dialog box to create an

Outbound Interchange Entry.
20. Click New from the Outbound Interchange Select dialog box to create a new

Outbound Interchange. Notice the value in the Interchange Transl. Obj. box.
21. Click Envelope.

The Outbound VDA dialog box is displayed.
22. Complete the fields as necessary and click Save.

See Outbound VDA Envelope Dialog Box for more information about how to
complete this dialog box.

23. Click Save until you have closed all dialog boxes.

Note: If you have problems setting up the partner, import the sample partner
file (Partners\vdapart.par) included for use with this tutorial. Make sure you
have registered all the compiled templates first.

Creating an Inbound VDA Map
About this task

Use this procedure to open, compile, and register the maps for inbound data.

Procedure
1. Open Sterling Gentran:Server Application Integration.
2. Select File > Open.
3. Browse to Gensrvnt\Tutorial\Vda folder and select VDA4908_IN.map.

The Input side of the map now looks like this:
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4. Select File > Compile and save the file as a .tpl file in the \TransObj folder.
5. To view the Translation Object Details, select Edit > Details.

The Translation Object Details dialog box should look like this.

6. Register the translation object.
See Compiling and Registering Tutorial Maps for more information.

Creating an Inbound Relationship
You need to identify your trading partner with the inbound translation objects that
you created, compiled, and registered.

About this task

Use this procedure to create an inbound Trading Partner Relationship.

Procedure
1. From the Partner Editor, select the VDA partner that you created earlier and

click Inbound.
2. Click New.
3. Enter Inbound 4908 as the description and click Save.
4. Select Inbound 4908 from the Relationship Description list.
5. Select V-VDA from the Standard list.
6. Select 4908 from the Version and Transaction Set lists.
7. Click Groups and select <none>.
8. Click Interchanges.
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The Inbound Interchange Entry dialog box is displayed.
9. Click Translation to define the Inbound Translation Objects.

10. Select 4908 to Positional from the Export File list.
11. Select VDA Trn Break from the Transaction list.
12. Click Save.
13. Click Interchanges from the Inbound Relationship dialog box to create an

Inbound Interchange Entry.
14. Click New to create a new Inbound Interchange.
15. Select 821 from the Interchange ID list.

Note: 821 is the header record in message 4908.
16. Click Save until you close all Partner Editor dialog boxes.

Processing a Sample Outbound Application File
To test your work in this tutorial, you will import an application file, post it, and
send it through the Sterling Gentran:Server system.

About this task

We have provided a simple application file (Gensrvnt\Tutorial\Vda\VDA4908.vda)
to serve as the basis for our test.

Use this procedure to test outbound processing.

Procedure
1. Open Sterling Gentran:Server and click Workspace.
2. Click Import to import the application file.
3. Use the Application Files to Import dialog box to select the file VDA4908.vda

in the Gensrvnt\Tutorial\Vda folder and click Open.
After a few seconds, the imported file appears in the Workspace.

4. To view the imported file, select it and do the following:
v Click View.
v Leave Raw EDI selected on the View Choice dialog box.
v Click OK.
You can see that it has been translated to VDA format.

5. In the Workspace dialog box, select the imported file and click Post to send it
to the Out box.

6. Click Close to close the Workspace.
7. Click Out on the Sterling Gentran:Server desktop.

The Out Documents Summary is displayed.
8. Select VDAPART 4908 and click View to open the document-level Out

Documents dialog box.
9. Select the document you posted and click Send to send it to the Out Drawer.

10. After the communications session is opened and the document is sent, click
Close twice to close both of the Document Summary dialog boxes.

11. Click Out Drawer on the Sterling Gentran:Server desktop.
The Out Drawer Summary dialog box is displayed.
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12. Select VDAPART 4908 and click View to open the document-level Out
Drawer dialog box.
As indicated in the Status column, the VDAPART 4908 document has been
sent.

Processing a Sample Inbound Application File
To test inbound processing, you will process the file that you transmitted and
receive it as an inbound VDA file.

About this task

Use this procedure to process a VDA file and export it to your application format.

Procedure
1. Open Sterling Gentran:Server and select Commands > Process File.
2. In the Process File dialog box, select file VDA4908i.txt from the

Gensrvnt\Tutorial\Vda folder and click Open.
The CommPost dialog box is displayed, indicating the progress of the
translation.

3. Click In to open the In Documents Summary dialog box.
4. Select the VDAPART 4908 line and click View to open the document-level In

Documents dialog box.
5. Select the VDAPART 4908 document and click Export.

The Select Export Method dialog box is displayed.
6. Select Export to Single File.
7. Select the folder and file name for the export from the Choose file to Export

document dialog box.
A dialog box is displayed to show progress as Sterling Gentran:Server
translates the VDA file into the application format.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law

IBM Japan Ltd.

19-21, Nihonbashi-Hakozakicho, Chuo-ku

Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

J46A/G4

555 Bailey Avenue

San Jose, CA 95141-1003

U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.
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This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© IBM 2012. Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2012.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise®, Gentran®,
Gentran:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™,
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce®, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.

18 IBM Sterling Gentran:Server for Windows: VDA User Guide



Index

E
envelopes

fields and message headers 2
outbound VDA 2

F
features 1

I
import paths

setting 6
inbound relationships

creating 12
installation

overview 1

M
mailboxes

creating a trading partner mailbox 7
registering 7

maps
compiling and registering 9
inbound VDA map 11
outbound VDA maps 9
registering 5
supplied maps 1
tutorial 9

message types
supported 1

O
outbound relationships

creating 10

P
partner profiles

importing 8

S
splitter entries

creating 6
supplied maps 1

T
testing

inbound processing 14
outbound processing 13

translation objects
registering 5

tutorial
compiling and registering tutorial

maps 9
create an inbound relationship 12
creating a splitter entry 6
creating a trading partner mailbox 7
creating an inbound map 11
creating an outbound map 9
creating an outbound relationship 10
importing a partner profile 8
installing data 5
overview 5
registering translation objects 5
setting the import path 6
testing inbound processing 14
testing outbound processing 13

© Copyright IBM Corp. 1996, 2012 19



20 IBM Sterling Gentran:Server for Windows: VDA User Guide





����

Product Number: 5725-D09

Printed in USA


	Contents
	Chapter 1. Working with VDA Standards
	About the VDA Standards
	VDA Support in Sterling Gentran:Server
	Outbound VDA Envelope Dialog Box

	Chapter 2. VDA Standards Tutorial
	About the Tutorial
	Installing the VDA Tutorial Data
	Registering the Tutorial Translation Objects
	Setting the Import Path
	Creating a Splitter Entry
	Creating a Trading Partner Mailbox
	Importing the Tutorial Partner Profile
	Creating an Outbound VDA Map
	Compiling and Registering Tutorial Maps
	Creating an Outbound Relationship
	Creating an Inbound VDA Map
	Creating an Inbound Relationship
	Processing a Sample Outbound Application File
	Processing a Sample Inbound Application File

	Notices
	Index
	E
	F
	I
	M
	O
	P
	S
	T


