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Chapter 1. Getting Started

About Sterling Gentran:Server
Welcome to IBM® Sterling Gentran:Server® for Microsoft Windows, the IBM EDI
software for the Windows operating system.

Sterling Gentran:Server provides the easy-to-use tools you need to electronically
exchange data with your trading partners, including the following functions:
v data translation
v process control
v communications system

Support for Sterling Gentran:Server
Sterling Gentran:Server software is supported by trained product support
personnel who are available to help with product questions or concerns.

You can access the Sterling Gentran:Server Customer Support page (Support
Portal) at:

http://www.ibm.com/support/entry/portal/Overview/Software/
Other_Software/Sterling_Gentran:Server_for_Microsoft_Windows

You can also call Customer Support at 1-800-IBM-SERV (1-800-426-7378).

To help us provide prompt service, we ask that you do the following:
v Attempt to recreate any problem that you encounter and record the exact

sequence of events.
v When you call product support, you should be prepared to provide us with the

information below.

Information Description

Identification Your company name, your name, telephone number and
extension, your company’s IBM customer number (ICN), and
the problem management record (PMR) number (if the
question refers to a previously reported issue)

System Configuration Sterling Gentran:Server version (and any patches or options
installed) and information about the primary Sterling
Gentran:Server system controller and all machines
experiencing problems, including

v Microsoft Windows operating system version

v amount of memory

v available disk space

v database type and version

v browser version

Also, please describe any recent changes in your hardware,
software, or the configuration of your system.

System Data Store Servers containing folders in the system data store

© Copyright IBM Corp. 1996, 2015 1
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Information Description

Error Messages If possible, get a screen capture of any error messages and the
point at which the error occurred, as well as any log files. (If
you cannot get a screen capture, record the exact wording of
the error.)

Attempted Solutions Record any steps that you took attempting to resolve the
problem and note all outcomes. Provide an estimate on how
many times the problem occurred and whether it can be
reproduced.

Sterling Gentran:Server System Components
Sterling Gentran:Server for Microsoft Windows is a combined data translation,
process control, and communication system that operates within the Microsoft
Windows environment.

Through the process control system, you can integrate Sterling Gentran:Server with
a wide variety of business applications in a manner that makes Sterling
Gentran:Server a complementary extension of the applications, rather than an
add-on.

The Sterling Gentran:Server system consists of several logical components. Sterling
Gentran:Server can be deployed in many ways in this environment through a
combination of database, system data store, process controllers, communication
controllers, and user interface clients.

Each system must have a primary Sterling Gentran:Server system controller,
system data store, and a database.

Database

The database is the relational database that Sterling Gentran:Server uses to store
system data. This database enables multiple users to access the same data. The
other components of the product interact with this database using ODBC (Open
Database Connectivity), which allows for many different database management
systems on the database controller.

See the Getting Support card to determine which database management systems
have been certified for use with Sterling Gentran:Server.

System Data Store

The system data store serves as the repository of all shared Sterling Gentran:Server
data. The system data store may reside on any machine that is a file server to the
machines in the Sterling Gentran:Server system. There is only one system data
store in the Sterling Gentran:Server system, but the associated folders and files
may be distributed across multiple machines, if necessary.

Note: The machines where the system data store resides must be accessible by all
machines in the Sterling Gentran:Server system.

Process Controllers

There are two types of controllers in the Sterling Gentran:Server system:
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v A single primary system controller - The primary system controller controls the
management and dispatching of processing requests within the system, manages
the audit functionality, and controls all other system components.

v One or more secondary controllers (if required) - If you purchased a distributed
license, you can deploy additional controllers (secondary controllers) across the
Windows network to allow the processing load to be distributed for fast and
efficient throughput. The secondary controller can be either or both of the
following:
– The process controllers provide similar functions to the primary system

controller. They are controlled by the primary system controller and are used
to distribute processes across multiple machines in a Windows network.

– Communication controllers regulate communication between Sterling
Gentran:Server and the organizations (value-added networks (VANs) or
trading partners) with whom data is exchanged. The communication
controllers can support leased or dialed connections, as well as interaction
with third-party communication packages using the file interface capability. A
communication controller is installed via a communications gateway.

User Interface Clients

The user interface clients provide the functions that are necessary to monitor and
control the system. The main data management component provides a graphical
user interface to the following:
v Document locations
v Partner profiles
v Communication setup and logs
v System Audit Log
v Process control setup and management

The five main components of the Sterling Gentran:Server user interface client are
the following:
v The EDI Manager window is a data management component that serves as a

high-level navigation tool, as well as a document management tool. The EDI
Manager also provides access to the Partner Editor, the Document Editor,
Application Integration, and Forms Integration.

v Partner Editor allows you to define, edit, and delete all partner information for
your company and for all of your trading partners.

v Document Editor is your data entry tool. It allows you to create, modify, and
view documents.

v Application Integration is a subsystem that enables you to generate import,
export, and document turnaround translation objects.

v Forms Integration is a subsystem that enables you to generate screen entry and
print translation objects.

Logical Components

The user interface client and controller components are the logical components of
the Sterling Gentran:Server system. These components can be deployed on a single
machine or over a number of machines, depending on your needs.
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Typically, your system initially consists of a small number of machines operating as
Sterling Gentran:Server user interface clients, and a larger, more powerful machine
operating as a combined primary system controller/communication
controller/process controller.

After you complete the necessary translation objects for your installation (using
Application Integration), you can add other process controllers and communication
controllers as required, to distribute the processing workload.

The following diagram illustrated the interaction of the logical components of the
Sterling Gentran:Server system:
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About the EDI Manager Window
The EDI Manager Window is the mail interface for Sterling Gentran:Server.

The following illustrates the Sterling Gentran:Server EDI Manager window:

The following are the components of the main Sterling Gentran:Server window:
v The Control Menu contains the following commands: Restore, Move, Size,

Minimize, Maximize, and Close.
v The Title Bar contains the name of the application and, on the Sterling

Gentran:Server desktop, it displays the name of the system you are logged in to.
You can use this to move the position of the EDI Manager window on your
desktop.

v The Minimize button reduces the window to an icon. The Maximize button
enlarges the window to its maximum size.

v The Main Menu Bar contains the drop-down menus. Detailed descriptions of
each of the commands on these menus are found in the Online Help.
Unavailable items are dimmed.

v The Main Toolbar gives you access to some of the most common browsers and
functions in Sterling Gentran:Server. Unavailable items are dimmed. The Main
Toolbar is a dockable toolbar, so you can affix it to any edge of the EDI Manager
window. The following illustrates the Main Toolbar.
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v The Browser Toolbar gives you access to the functions that are available from
browsers in Sterling Gentran:Server. Unavailable items are dimmed. The Browser
Toolbar is a dockable toolbar, so you can affix it to any edge of the EDI Manager
window. The following illustrates the Browser Toolbar:

v The Desk is a graphic representation of the Sterling Gentran:Server components
and document locations. It provides a quick and easy way to access some of the
most commonly used browsers, functions, and subsystems of Sterling
Gentran:Server. You can click the appropriate part of The Desk any time you
need to access a browser, function, or subsystem represented on The Desk.
Some of the browser icons display a graphic representation of paper if the
document location contains documents. The Desk also allows you to access the
Partner Editor subsystem, the Help system, the Process Control function (clock
icon), and the Send/Receive functions (phone icon), and allows you to quit
Sterling Gentran:Server (Exit/door icon).

v The Status Bar displays status information about a selection, command, or
process, defines menu items as you highlight each item in the menu, and
indicates any current keyboard-initiated modes for typing.

Inbound Translation Process
The following diagram illustrates the inbound translation process:
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Table 1. Inbound Translation Process

Stage Description

1 The Communicator receives interchanges from your trading partners through
a network.

2 The Communicator passes the interchanges to the translator.

3 The translator uses a system interchange break translation object to unwrap
the interchange envelopes and separate each group into temporary storage.

4 The translator uses a system group break translation object to unwrap the
group envelopes and separate each transaction set into temporary storage.

5 The translator uses a system transaction break translation object to do the
following:

v Unwrap the transaction envelopes.

v Separate each document into a separate file on the system data store.

v Write a record to the database with reference information about the
document.
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Table 1. Inbound Translation Process (continued)

Stage Description

6 Does the translator locate a trading relationship for each document?

v If yes (a trading relationship is located), the translator attempts to identify
the export, document turnaround, or print translation object associated
with that relationship. If the translator locates a trading relationship and
translation object, it uses that translation object to compliance check the
document.

v If no (the translator does not locate the trading relationship or translation
object), the document is marked as not compliant and is moved to ?In
Documents.

7 Is the document compliant with the EDI standard?

v If yes, the translator changes the document status to compliant and moves
the document to In Documents.

v If no, the document remains in ?In Documents. The translator writes a
detailed error report to help you determine the problem that was
encountered.

8 In the trading relationship, if you specify that the system needs to generate a
functional acknowledgement for a document, the translator uses the system
acknowledgement translation object to generate the acknowledgement.

v Compliant acknowledgements are moved to Out Documents to be sent.

v Non-compliant acknowledgements are moved to ?Out Documents. If an
error occurred with the acknowledgement translation object, the
acknowledgement is also moved to ?Out Documents.

The translator also reconciles acknowledgements if you receive an
acknowledgement-type transaction (such as 997 or CONTRL).

9 If you specified either automatic export or automatic turnaround in the
trading relationship, the translator uses the specified export or document
turnaround translation object to either export or generate the appropriate
response document.

Outbound Translation Process
The following diagram illustrates the outbound translation process:
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Table 2. Outbound Translation Process

Stage Description

1 Use one of the following three processes to initiate an outbound translation:

v Import a file through the process control system using a timed or polled
session. This writes all valid documents to the database with a compliant
status and moves the documents to Out Documents. Invalid documents are
marked with a non-compliant status and are moved to ?Out Documents.

v Import an application file. Documents that you import manually are located
in the Workspace.

v Use the Document Editor to enter documents (if there is an appropriate
data entry translation object registered with Sterling Gentran:Server). These
documents are located in the Workspace.

2 If you import a file, the translator checks the import definitions from the
system configuration to match the file name with a system import translation
object.
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Table 2. Outbound Translation Process (continued)

Stage Description

3 The translator uses the system import translation object to determine which
trading relationship (established in Partner Editor) corresponds to each
document in the application file, so the system knows which import map to
use to process the document.

4 The translator ascertains which import translation object is specified in the
trading relationship.

5 The translator uses the import translation object to compliance check the
document. If the document is compliant (valid), it is marked OK. If the
document is not compliant (invalid), it is marked NotOK.

6 If there is another document remaining in the import file, the translator
repeats steps 3 - 5 until all documents are processed.

7 If you manually import a file through the EDI Manager or use the Document
Editor, you need to post the compliant document to Out Documents.Once
documents are located in Out Documents, they can be sent using the process
control system or by using the EDI Manager transmit option.

Changing your Password
Your Sterling Gentran:Server password is stored in your User Access profile.

About this task

Notes:

v You must know your old password to change it. If you have forgotten your
password, please contact your system administrator.

v If you are using Integrated security, you may also need to change your Sterling
Gentran:Server and database passwords if you change your Windows password.

v See your system administrator if you have any questions about which security
mode you use.

Use this procedure to change your password.

Procedure
1. Select Options > Preferences.

The Preferences dialog box is displayed.
2. Select the Change Password tab.
3. Enter your old password.
4. Enter your new password twice (for confirmation).

Note: Passwords can be up to 126 characters long.
5. Click OK to save the changes.

The system is updated and the next time you log on to the system you will
need to enter the new password.

Setting up an External Text Editor
You can select an external editor so you can view, edit, and save your documents
outside of the Sterling Gentran:Server EDI Manager.
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About this task

Use this procedure to set up an external application for editing documents.

Procedure
1. Select Options > Preferences.
2. Click the Document Viewer tab.
3. Navigate to the executable file for the text editor.

For example: C:\Program Files (x86)\TextPad 4\TextPad.exe

4. Click OK.
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Chapter 2. Translation Objects

About Translation Objects
A translation object is a set of definitions, links, and rules that combine to provide
the translator with all the information necessary to convert data from one format to
another. Translation objects are used in Sterling Gentran:Server to control the
processing of the translator subsystem.

Translation objects are created by compiling an application map or a form
definition using the Application or Forms Integration subsystem in Sterling
Gentran:Server.

See the IBM Sterling Gentran:Server for Microsoft Windows Application Integration User
Guide and IBM Sterling Gentran:Server for Microsoft Windows Forms Integration User
Guide more information about those subsystems.

There are two types of translation objects:
v System translation objects control the creation and separation of interchanges,

functional groups, and transaction sets. They are also used to generate and
reconcile functional acknowledgements.

v User translation objects control screen entry, importing, exporting, and creating
printed reports. All required system translation objects are automatically
installed with the Sterling Gentran:Server system.

EDI Translation Object Browser
EDI Translation Object browser allows you to view, print, delete, and register
translation objects.

The following illustrates the EDI Translation Object browser.

The following lists the parts of the EDI Translation Object browser and their
functions.
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Part Function

Type Describes the type of translation object defined, such as export, import,
or system import.

Description Displays a description that further identifies the translation object.

Used Indicates whether the translation object is currently associated with an
Inbound or Outbound Partner Relationship. Valid values are:

v Yes - Indicates the translation object is in use.

v No - Indicates the translation object is not in use.

v SYS* - Indicates a system translation object that is in use.

v SYS - Indicates a system translation object that is not in use

Note: If a translation object is currently used (associated with an
Inbound or Outbound Partner Relationship), you cannot delete it. Also,
the system prevents you from deleting translation objects that are
designated as system translation objects (SYS* or SYS).

System Translation Objects are all translation objects except Import,
Export, Data Entry, Screen Entry, Turn Around, and Print. Also, any
translation object with “system” in the description is a system
translation object.

View Displays a window containing descriptive information for the selected
translation object, including the following:

v Description of the translation object

v Type of translation object (for example, Export)

v Input and output agency (for example, X for ANSI X12)

v Input and output version (for example, 003030)

v Input and output transaction ID (for example, 850)

v Input and output release (for TRADACOMS only)

v File name of the translation object (for example, 3030.tpl)

Print Displays the Print Choice dialog box, which allows you to specify
whether you want to print the selected translation objects or print a
summary list of the selected translation objects.
Note: The Formatted option is unavailable because a formatted version
is always printed for a translation object.

Registering New Translation Objects
The Register Translation Object function enables you to register your translation
object file with Sterling Gentran:Server so the system can identify the translation
object.

About this task

You can set the auto-register feature to automatically register translation objects
when they are compiled. See the topic on setting the auto-register option in the
IBM Sterling Gentran:Server for Microsoft Windows Application Integration User Guide.

Use this procedure to register a translation object.

Procedure
1. Select View > Translation Objects.

The system displays the EDI Translation Object browser.
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2. Click New.
The system displays the Register Translation Object dialog box.

3. Select the translation object file that you want to register with the system from
the list or type it in the File name box.

4. Click Open.
The system registers the translation object files exits the Register Translation
Object dialog box.

Notes:

v If the selected file is invalid, you receive a warning message. Only valid
Sterling Gentran:Server translation object files can be installed.

v If the translation object is a duplicate, you are prompted with a message
asking whether or not you want to overwrite the existing translation object.

Deleting Translation Objects
You can delete old or unused translation objects from the system only if they are
not currently associated with an Inbound or Outbound Partner Relationship. This
displays as "No" in the Used column on the EDI Translation Object browser.

About this task

Note: The system prevents you from deleting translation objects that are
designated as system translation objects.

Use this procedure to delete a translation object.

Procedure
1. Select View > Translation Objects.

The EDI Translation Object browser is displayed.
2. Select the translation object or objects you want to delete.
3. Click Delete.

The Delete confirmation dialog box is displayed.
4. Click Yes to confirm the delete.
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Chapter 3. Trading Partners

About the Partner Editor
The Partner Editor allows you to define, edit, and delete all partner relationship
information for your company and all of your trading partners.

The Partner Editor also allows you to use an internal system partner (Internal
System User) to define your company to the system.

Partner relationships allow you to send and receive data to and from your trading
partners. A partner profile begins with a partner definition. The partner definition
contains the basic information about that partner that the system needs before you
define the rest of the partner profile. You need to create a partner definition for
each partner with whom you are going to exchange data.

For information about defining partners for use with RosettaNet, see the topic on
using the Partner Editor in the IBM Sterling Gentran:Server for Microsoft Windows for
RosettaNet User Guide.

Partner Profiles

Methods for Creating Partner Profiles
Partner profiles define the parameters that control the processing and structure of
inbound and outbound data for each partner.

You can set up your partner profiles using any of three methods: importing,
copying, and creating them yourself. The method you use depends on whether
you have a partner profile to use as a starting point, as shown in the following
table:

Partner profile
creation method When to use

Import existing profile Use this method if you receive partner profiles from IBM or if you
have an existing profile from which you can import partner details.
The profile can be exported from another copy of the Sterling
Gentran:Server system.

See Importing Partner Profiles for more information.

Copy existing profile Use this method when you have an existing profile that you can
copy and then enter a unique partner definition and key
enveloping information for the copied partner.

See Copying Partner Profiles for more information.

Create a new profile Use this method when you do not have a profile to import or copy.

See Process of defining a partner profile for more information.

To complete the partner profile, you need to define an inbound or outbound
relationship or both:
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v If you are receiving and processing information from this trading partner, you
need to define an appropriate inbound relationship.

v If you are sending information to this trading partner, you need to define an
outbound relationship.

You need to create a partner profile for each partner with whom you are going to
exchange data.

Process for defining a partner profile

The following describes the partner profile creation process:

Stage Description

1 Create the partner definition.

See Creating a Partner Definition.

2 If necessary, create the inbound relationship.

See Creating an Inbound Relationship .

3 If necessary, create the outbound relationship.

See Creating an Outbound Relationship.

4 To use a cross-reference or lookup table with the partner relationship to
supplement or convert data you enter or receive, see Creating Partner
Tables.

5 To use locations to contain address- and contact-related information
about the partner, see Creating Partner Locations .

Partner Editor Dialog Box
The Partner Editor enables you to define, edit, and delete all partner information
for your company and all of your trading partners.

The following illustrates the Partner Editor dialog box:
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The following describes the parts of the Partner Editor dialog box.

Part Function

Select a Partner Displays the list of partner profiles to select from.

Copy Displays the Partner Copy Dialog Box, which allows you to copy a
partner profile.

Import Displays the Import File Select Dialog Box, which allows you to
import a partner profile.

Export Displays the Export File Build Dialog Box, which allows you to
export a partner profile.

Edit Displays the Partner Definition (New/Edit) Dialog Box, which
allows you to change information about the selected partner.

Inbound Displays the Inbound Relationship Dialog Box for the selected
partner.

Outbound Displays the Outbound Relationship Dialog Box for the selected
partner.

Tables Displays the Partner Tables Dialog Box for the selected partner.

Locations Displays the Location Select Dialog Box for the selected partner.

Refresh Refreshes the dialog box display.

Partner Definition (New/Edit) Dialog Box
The Partner Definition dialog box enables you to create a new partner definition or,
if you select a previously defined partner definition, it allows you to edit it.

The following illustrates the Partner Definition - New dialog box:
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Note: See the IBM Sterling Gentran:Server for Microsoft Windows Communications
User Guide for more information.

The following describes the parts of the Partner Definition dialog box.

Part Function

Profile ID Specify a unique identifier for the selected partner.

Name Specify a unique name for the partner.
Note: Make this name as descriptive as possible, because this is
the name displayed in the partner selection list.

EDI Code Specify the EDI identifier for this partner. The system uses this
value during inbound processing to select the correct trading
partner definition.

Application Code Specify an application code used to identify this partner. The
system uses this value during outbound import processing to select
the correct trading partner definition.

Default Mailbox Select a default mailbox to use to identify this partner for
non-RosettaNet EDI relationships.

Default E-mail
Address

Specify a default e-mail address to use to identify this partner for
non-RosettaNet EDI relationships.

New Mailbox Displays the Create New Mailbox wizard, which allows you to
create a new mailbox.

Edit Mailbox Displays the Mailbox Properties dialog box, which allows you to
edit the mailbox.

Inbound Relationship Dialog Box
Inbound relationships define the parameters the system needs to receive an EDI
document from a trading partner. The Inbound Relationship dialog box controls
other subordinate dialogs that allow you to define everything that is necessary to
establish the relationship.

You are required to specify exactly which document is to be received. You also
define which translation objects are used to define the turnaround documents,
export rules, or printing requirements.

The following illustrates the Inbound Relationship dialog box with the Advanced
options displayed:
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The following describes the parts of the Inbound Relationship dialog box.

Part Function

Relationship
Description

Select the existing inbound relationship.

Standard Specifies the EDI standard to be used in this relationship.
Note: Only standards for which you have existing translation
objects are displayed. This box cannot be changed for an existing
relationship. Selection of this box is mandatory.

Valid values are:

v A - TRADACOMS

v C - CII

v D - NCPDP

v E - EDIFACT

v O - ODETTE

v P - OTHER

v R - ROSETTANET

v T - TDCC

v U - UCS

v V - VDA

v X - X12

Version Select the EDI standard version to be used in this relationship.
Note: Only versions of the selected standard for which you have
existing translation objects are displayed. If this box is changed for
an existing relationship, all of the information defined below it is
cleared and must be reselected. Selection of this box is mandatory.
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Part Function

Transaction Set Select the transaction set to be used in this relationship.
Note: Only transaction sets for the selected version for which you
have existing translation objects are displayed. If this box is
changed for an existing relationship, all of the information defined
below it is cleared and must be reselected. Selection of this box is
mandatory.

Release Select the release number to be used in this relationship.
Note: Only releases for the selected transaction set for which you
have existing translation objects are displayed. This box is
currently only used for messages defined in the TRADACOMS
standard. Selection of this box is mandatory for all TRADACOMS
messages.

Transaction is an
Acknowledgement

Specify if the transaction defined in this partner relationship is an
acknowledgement.

Groups Accesses the Inbound Group Select Dialog Box.

Interchanges Accesses the Inbound Interchange Select Dialog Box.

Sequence Checking Specify if the system will use sequence checking and whether
sequence checking will be incremental or chronological. You can
also indicate that the system must check for duplicate control
numbers.

v None - Do not use sequence checking.

v Duplicate - Check for duplicate control numbers.

v Incremental - The control number must be one greater than the
last number.

v Chronological - The control number must be greater than the last
number.

Note: If the system detects duplicate control numbers or detects
incremental or chronological control numbers that are out of
sequence, those documents will be put in the ?In Documents.

Last Used Control
Number

Specify a value that is used to sequence check the next transaction
set control number or message reference. This value is replaced
with the sequence number of the last transaction set or message
received. This box is initially set to zero.
Note: This box is disabled if Sequence Checking is None.

Duplicate Documents Specify if the system will check for duplicate document names.
Notes::

v If the system detects duplicate document name it will locate
those documents in ?In Documents.

v If duplicate document checking is activated for a relationship the
translation object used in this relationship must update the
document name via a standard or extended rule.

See the IBM Sterling Gentran:Server for Microsoft Windows Application
Integration User Guide for more information about using standard
and extended rules.

Skip Compliance
Check

Specify if you want the system to compliance check the documents
for this relationship.
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Part Function

Generate
Acknowledgements

Instructs the system to generate a functional acknowledgement to
this trading partner when you receive the transaction set (message)
defined in this relationship. The default value for this box is No.
Valid values:

v No�Do not generate acknowledgements.

v Yes - No Error Detail�Generate acknowledgements without error
detail.

v Yes - With Error Detail�Generate acknowledgements with error
detail.

Note: This entire box is inactive (dimmed) if the document
(transaction set) in this relationship is an acknowledgement.

Test Indicator Specify if this relationship definition is in test or production mode.
The default value is Production.

Acknowledgement
Processing

Specify if acknowledgement reconciliation will occur during the
inbound break session (Immediate) or during its scheduled interval
(Deferred). The default is Immediate.

Delete Removes the specified inbound relationship from the system.

Translation Accesses the Inbound Translation Object Dialog Box.

Advanced Displays the advanced options.

Inbound Translation Object Dialog Box
The Inbound Translation Objects dialog box is used to specify which translation
objects will be used to process the data defined by this relationship.

The following lists the inbound translation levels (from the lowest level up):

Translation Level Description

Document Validate the document against the specified translation object to
verify if the document is compliant with the standard and translate
from EDI to print or application format.

Transaction Remove the EDI-specific enveloping around a single document.

Group Remove the EDI-specific enveloping around a set of related
transactions (the transactions do not have to be the same type).

Interchange Remove the EDI-specific enveloping around groups destined for
the same trading partner.

See the IBM Sterling Gentran:Server for Microsoft Windows Communications User Guide
for more information.

The following illustrates the Inbound Translation Object dialog box with the
Advanced options displayed:
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The following describes the parts of the Inbound Translation Object dialog box.

Part Function

Select Translation Objects
Notes:

v The lists display all translation objects registered in the system that are appropriate for
the type of translation object (such as Export or Print) and the transaction set.

v If there are no translation objects displayed in the drop-down lists, no translation objects
of that type are registered for the version of the document defined in the relationship.

Turn Around/Auto Displays all turnaround document options. When a document is
received, the turnaround document created is the natural response
document that contains as many elements from the received
document as possible.
Note: Select the Auto check box if you want the defined
turnaround process to be automatic. If the Auto box is not selected,
the received document will remain in the In Documents until it is
selected for processing.
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Part Function

Export File/Auto Displays all registered Export translation objects relative to the
Standard, Version, Transaction Set and Release defined by this
relationship. This allows you to specify that when an EDI
document is received, it will be exported into an output file.

Notes::

v Select the Auto check box if you want the export file created
automatically upon receipt of the document. If the Auto box is
not selected, the received document will remain in the In
Documents until it is selected for processing.

v If the Export File Name is defined for this relationship, each
document can be exported individually to a unique file. If you
use formatting characters in the file name, the document key
changes for each document that is exported, the Process ID stays
the same (for all documents exported from the same
interchange), and the unique ID changes. Therefore, using the
“document key” and “unique ID” special characters (defined
below), a unique file name can be derived.

Print Displays all print translation objects on the system for the
Standard, Version, Transaction Set, and Release defined by the
relationship. The selected translation object will be used to print
documents received from this partner.
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Part Function

Export File Name Specify the name of the file to be created or appended to as a
result of performing an export operation. This file name can
contain a mix of alphanumeric characters and formatting
characters, which are replaced by the translator with the runtime
value they represent.
Notes:

v The filename can contain a mix of regular characters and
formatting characters that are replaced by the translator with the
runtime values they represent.

v You can use a special character, such as an underscore, to
separate values with the filename. For example, you could
specify %Y_%M_%D to indicate year_month_day as the
filename. However, do not use a period in a filename to separate
values. A period can only be used to indicate the filename
extension, such as .txt.

Formatting characters supported:

v %y (two-digit year)

v %Y (four-digit year)

v %m (abbreviated month name)

v %M (month as a decimal number)

v %d (abbreviated weekday name)

v %D (day of the month as a decimal number)

v %H (hour in 24-hour format)

v %N (minutes)

v %S (seconds)

v %K (document key)

v %P (process identifier)

v %U (unique number derived using the current time, export
filename, process identifier, and the rand() function)

Note:

The runtime file name is generated once per export.

The following is an example of a runtime file name using
formatting characters:

d:\GENSRVNT\exports\dockey%Kprocid%Puniqueid%U.dat

Export to Mailbox
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Part Function

Export to Mailbox Invokes the "Export to Mailbox" function, which delivers the
output of an inbound translation to the Mailbox Server Manager.
This allows the Mailbox Server Manager to act as a message broker
responsible for delivering the data to its final destination.
Note: If you specified the Export File Name, it is still valid and
will become the Attachment Filename. Formatting characters are
still valid for the filename and could cause multiple attachments to
be created if document key is used. For example, if the following
filename is used:

d:\gensrvnt\exports\dockey%Kprocid%Puniqueid%U.dat

a new attachment is created for each document because the
document key creates a unique name for each document processed.

To set up an export to a mailbox, you must complete the following
components on the Inbound Translation Objects dialog box:

v In the Export File Name box, type the file name.

v Select the Export to Mailbox checkbox.

v From the Recipient Mailbox list, select the mailbox (the Recipient
E-mail Address is optional).

v In the Content Type/SubType box, type a content type (content
subtype is optional).

Use Partner Default
Mailbox and E-mail
Address

Specify if the output of the inbound translation is exported to the
default mailbox and e-mail address configured for this partner.

Recipient
Mailbox/�New
Mailbox

Select the mailbox to which the output of an inbound translation is
delivered.

Optionally, click New Mailbox to display the Create New Mailbox
wizard, which allows you to create a new mailbox.

Recipient E-mail
Address/�Edit
Mailbox

Specify the e-mail address to which the output of an inbound
translation is delivered.

Optionally, click Edit Mailbox to display the Create New Mailbox
wizard, which allows you to edit the mailbox.

Content
Type/SubType

Specify the content type/sub type of the message containing the
output of the inbound translation.

Application ID Specify the application identifier that indicates the destination of
the documents.

Application Alias
Value

Specify criteria for this relationship definition that is used during
the application import function.

Example: The application contains data that can generate either an
invoice or a credit memo. Use one relationship definition for
invoices and another for credit memos.

There is a box in the application that defines whether this is an
invoice or a credit memo. The box will display CREDIT if a credit
memo is created and INVOICE if an invoice is created. Type
CREDIT in the Application Alias Value for the relationship
defining the credit memo and type INVOICE for the invoice.
Note: This box is only used if you receive translation objects that
are defined to use the Application Alias Value.

Additional Translation Objects
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Part Function

Import Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.
Note: You must select a translation object from the Import list if
you have created a specific import translation object for this
relationship and if you want to change the way the system behaves
for this partner relationship. Import translation objects may not be
appropriate for an Inbound Relationship.

Data Entry Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.
Note: You must select a translation object from the Data Entry list
if you have created a specific data entry translation object for this
relationship and if you want to change the way the system behaves
for this partner relationship (e.g., if you want to change the
formatted view of Inbound data).

Transaction Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.
Note: You must select a translation object from the Transaction list
if you have created a specific Transaction Break translation object
for this relationship and if you want to change the way the system
behaves for this partner relationship.

Acknowledge Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.
Note: You must select a translation object from the Acknowledge
list if you have created a specific translation object for this
relationship and if you want to change the way the system behaves
for this partner relationship.

When the system reconciles an acknowledgement, it maps the
acknowledgement to an internal file and then processes it. If you
need the system to process acknowledgements differently, you
should select an additional translation object from the
Acknowledge list.

If the transaction set is an acknowledgement and you choose an
Acknowledge additional translation object, the system will use the
additional translation object in place of the export translation object
for acknowledgement reconciliation.

Inbound Group Select Dialog Box
The Inbound Group Select dialog box is used to select an existing functional group
definition to be associated with this relationship. It can also be used to initiate the
definition of a new functional group or to modify or delete an existing definition.
The groups available to you are determined by the version you selected on the
Inbound Relationship dialog.
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Note: Functional groups are required for ANSI X12, TDCC, and UCS standards,
optional for EDIFACT and ODETTE, and not specified for TRADACOMS.

The following illustrates the Inbound Group Select dialog box:

The following describes the parts of the Inbound Group Select dialog box.

Part Function

Groups Displays all functional group definitions established for this
trading partner.

Select Selects the indicated functional group to be used with this
relationship.
Note: Select <none> if the standard you are using does not require
groups and you do not want to use one.

Inbound Group Entry Dialog Box
The Inbound Group Entry dialog box is used to specify a functional group
definition.

The following illustrates the Inbound Group Entry dialog box with the Advanced
options displayed:

The following describes the parts of the Inbound Group Entry dialog box.

Part Function

Description Specify the name of the functional group description.
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Part Function

Standard Displays the EDI standard the system is using for this relationship
definition.

Version Displays the version of the EDI standard the system is using for
this relationship.

Functional Group ID Specify the functional group. These identification boxes are defined
by each appropriate standards group to group like documents. The
standard defines which functional group ID should be used with
each document type. This is a mandatory box.

Examples

v IN 810 - X12 Invoice

v PO - 850 X12 Purchase Order

v IG - 830 UCS Invoice

v OG - 875 UCS P. O.

v INVOIC - EDIFACT INVOIC

v ORDERS - EDIFACT ORDERS

v INVOIC - Tradacoms INVOIC

v ORDERS - Tradacoms ORDERS

This element is located in:

v ANSI X12 - GS01

v EDIFACT - UNG01

v TRADACOMS - BAT

Sequence Checking Specify if inbound sequence checking will be used and whether the
type of sequence checking will be incremental or chronological.
You can also indicate that the system must check for duplicate
control numbers.

v None - Do not use sequence checking.

v Duplicate - Check for duplicate control numbers.

v Incremental - The control number must be one greater than the
last number.

v Chronological - The control number must be greater than the last
number.

Note: If the system detects duplicate control numbers or detects
incremental or chronological control numbers that are out of
sequence, those documents will be put in the ?In Documents.

Last Used Group
Control Number

Specifies a value that the system will use to sequence check the
group control number. The number will be replaced by the group
control number that the system receives. This box will initially be
set to zero.

Acknowledge Group Instructs the system to send a functional acknowledgement to this
trading partner when you receive the group defined in this
relationship. The default value for this box is not checked (do not
expect an acknowledgement).
Note: This check box is dimmed (inactive) if the transaction set is
an acknowledgement.
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Part Function

Ack Translation Set ID Select the acknowledgement you want generated for this group.

Example

v ANSI X12 - 997 Functional Acknowledgement

v UCS/EDIA - 999 Acceptance/Rejection Advice

v EDIFACT - CNTRL

Group Transl. Obj. Select a partner-specific Group Break Map translation object if this
trading partner group deviates from the normal system behavior.
You must select a translation object from this list if you want the
system to perform partner-specific grouping.
Important: We strongly recommend that you do not change the
translation objects in the Group Transl. Obj. and Acknowledge
Transl. Obj. lists, unless you have a specific reason for doing so.

Acknowledge Transl.
Obj.

Select an Acknowledgement Break Map if one exists on the system.
Note: You must select a translation object from the Acknowledge
Transl. Obj. list if you have created a specific translation object for
this relationship and if you want to change the way the system
behaves for this partner group. When the system reconciles an
acknowledgement, it maps the acknowledgement to an internal file
and then processes it. If you need the system to process
acknowledgements differently, you should select an additional
translation object from the Acknowledge list.
Important: We strongly recommend that you do not change the
translation objects in the Group Transl. Obj. and Acknowledge
Transl. lists, unless you have a specific reason for doing so.

Inbound Interchange Select Dialog Box
The Inbound Interchanges Select dialog box is used to select an existing
interchange definition to be associated with this relationship. You can also use it to
initiate the definition of a new interchange or to modify or delete an existing
definition. The interchanges available to you are determined by the version you
selected on the Inbound Relationships dialog. Interchanges are required for
EDIFACT, ODETTE, TRADACOMS, and UCS, and optional for ANSI X12 and
TDCC.

The following illustrates the Inbound Interchange Select dialog box:

The following describes the parts of the Inbound Interchange Select dialog box.

Part Function

Interchanges Displays all Interchange definitions established for this trading
partner.
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Part Function

Select Selects the indicated interchange to be used with this relationship.
Note: Select <none> if the standard you are using does not require
interchanges and you do not want to use one.

Inbound Interchange Entry Dialog Box
The Inbound Interchange Entry dialog box is used to specify a new interchange
definition.

Note: EDIFACT version 4 defines the infrastructure necessary to support the
creation (and processing) of interchanges that have been encoded using a character
set other than 8-bit ASCII. Sterling Gentran:Server for Microsoft Windows supports
the processing of an encoded interchange as long as the encoding of the
interchange matches the default code page of the operating system where Sterling
Gentran:Server is running.

The following illustrates the Inbound Interchange Entry dialog box with the
Advanced options displayed:

The following describes the parts of the Inbound Interchange Entry dialog box.

Part Function

Description Contains the name of the interchange description.

Standard Displays the EDI standard the system is using for this relationship
definition.

Version Displays the version of the EDI standard the system is using for
this relationship.
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Part Function

Interchange ID Select the type of interchange. The standard defines which
interchange ID should be used with each standard. This is a
mandatory box.

Examples

v ANSI X12 - ISA

v ANSI X12 - ICS

v UCS - BG

v EDIFACT - UNB

v Tradacoms - STX

Sequence Checking Specify if the system will use sequence checking and whether the
sequence checking will be incremental or chronological. You can
also indicate that the system must check for duplicate control
numbers.

v None - Do not use sequence checking.

v Duplicate - Check for duplicate control numbers.

v Incremental - The control number must be one greater than the
last number.

v Chronological - The control number must be greater than the last
number.

Note: If the system detects duplicate control numbers or detects
incremental or chronological control numbers that are out of
sequence, those documents will be put in the ?In Documents.

Last Used Control
Number

Specifies a value that will be used to sequence check the next
interchange control number. The number will be replaced by the
control number on the last interchange received. This box will
initially be set to zero.
Note: This box is disabled if Sequence Checking is None.

Acknowledge
Interchange

Instructs the system to send a functional acknowledgement to this
trading partner when you receive the interchange set defined in
this relationship. The default value for this box is not checked (do
not expect an acknowledgement).

Ack Translation Set ID Select the acknowledgement you want generated for this
interchange.

Examples

v ANSI X12 - 997 Functional Acknowledgement

v UCS/EDIA - 999 Acceptance/Rejection Advice

v EDIFACT - CNTRL

Interchange Transl.
Obj.

Select a partner-specific Interchange Break Map translation object if
this trading partner interchange deviates from the normal system
behavior. You must select a translation object from this list if you
want the system to perform partner-specific interchanging.
Important: We strongly recommend that you do not change the
translation objects in the Interchange Transl. Obj. and Acknowledge
Transl. Obj. lists, unless you have a specific reason for doing so.
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Part Function

Acknowledge Transl.
Obj.

Select an Acknowledgement Break Map if one exists on the system.

You must select a translation object from the Acknowledge Transl.
Obj. list if you have created a specific translation object for this
relationship and if you want to change the way the system behaves
for this partner interchange. When the system reconciles an
acknowledgement, it maps the acknowledgement to an internal file
and then processes it. If you need the system to process
acknowledgements differently, you should select an additional
translation object from the Acknowledge list.
Important: We strongly recommend that you do not change the
translation objects in the Interchange Transl. Obj. and Acknowledge
Transl. Obj. lists, unless you have a specific reason for doing so.

Outbound Relationship Dialog Box
Outbound relationships define the parameters needed to send an EDI document to
a trading partner. The Outbound Relationship dialog box controls other
subordinate dialogs that allow you to define everything that is necessary to
establish the relationship.

You are required to specify exactly which document the system sends. You must
also specify which translation objects will be used to define the data entry dialogs,
import rules, or printing requirements. In addition, you need to define the specific
EDI-enveloping requirements that you agreed on with your trading partner.

The following illustrates the Outbound Relationship dialog box with the Advanced
options displayed:

The following describes the parts of the Outbound Relationship dialog box.

Part Function

Relationship
Description

Select the relationship description.

34 IBM Sterling Gentran:Server for Microsoft Windows: User Guide



Part Function

Standard Specifies the EDI standard to be used in this relationship.
Note: Only standards for which you have existing translation
objects are displayed. This box cannot be changed for an existing
relationship. Selection of this box is mandatory.

Valid values are:

v A-TRADACOMS

v C-CII

v D-NCPDP

v E-EDIFACT

v O-ODETTE

v P-OTHER

v R-ROSETTANET

v T-TDCC

v U-UCS

v V-VDA

v X-X12

Version Select the EDI standard version to be used in this relationship.
Note: Only versions of the selected standard for which you have
existing translation objects are displayed. If this box is changed for
an existing relationship, all of the information defined below it is
cleared and must be reselected. Selection of this box is mandatory.

Transaction Set Select the transaction set to be used in this relationship.
Note: Only transaction sets for the selected version for which you
have existing translation objects are displayed. If this box is
changed for an existing relationship, all of the information defined
below it is cleared and must be reselected. Selection of this box is
mandatory.

Release Select the release number to be used in this relationship.
Note: Only releases for the selected transaction set for which you
have existing translation objects will be displayed. This box is
currently only used for messages defined in the TRADACOMS
standard. Selection of this box is mandatory for all TRADACOMS
messages.

Groups Accesses the Outbound Group Select Dialog Box.

Interchanges Accesses the Outbound Interchange Select Dialog Box.

Last Used Control
Number

Specify a value that will be used to generate the next transaction
set control number or message reference. The number generated
will always be one more than the number in this box. Initially, this
box will be set to zero.

Expect
Acknowledgement

Instructs the system to expect a functional acknowledgement to be
received from this trading partner as a result of your partner
receiving the transaction set (message) defined in this relationship.
The default value for this box is not checked (do not expect an
acknowledgement).
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Part Function

Hours Overdue Defines how many hours must elapse before an expected
functional acknowledgement is considered overdue. This box is
only valid if the Expect Acknowledgement box is checked. The
default value for this box is “48,” indicating that the
acknowledgement will be considered overdue in two days. If you
enter a value of zero in this box, the acknowledgement will be
immediately considered overdue.
Note: This box is disabled if Expect Acknowledgement is not
checked.

Duplicate Documents Instructs the system to check for duplicate document names.
Notes::

v If you manually import documents into the Workspace, this
function checks for duplicate documents. Duplicate documents
remain in the Workspace until they are deleted. If you try to
move or post a duplicate document, a warning message is
displayed. If you use the Process Control import feature to
import documents, the duplicate document is located in ?Out
Documents.

v If duplicate document checking is activated for a relationship,
the translation object used in this relationship must update the
document name via a standard or extended rule.

See the IBM Sterling Gentran:Server for Microsoft Windows Application
Integration User Guide for more information about using standard
and extended rules.

Test Indicator Specify if this relationship definition is in test or production mode.
The default value is production.

Translation Accesses the Outbound Translation Object Dialog Box.

Envelope Accesses one of the following Outbound Envelope dialog boxes
depending on which version you specified:

v Outbound UNH Envelope

v Outbound MHD Envelope

v Outbound ST Envelope

Advanced Displays the advanced options.

Outbound Translation Object Dialog Box
The Outbound Translation Objects dialog box is used to specify which translation
objects are used to process the data defined by this relationship.

The following lists the outbound translation levels (from the lowest level up):

Translation Level Description

Document Translate from import format or data entry to EDI.

Transaction Build the EDI-specific enveloping around a single document.

Group Build the EDI-specific enveloping around a set of related
transactions (the transactions do not have to be the same type).

Interchange Build the EDI-specific enveloping around groups destined for the
same trading partner.

The following illustrates the Outbound Translation Object dialog box with the
Advanced options displayed:

36 IBM Sterling Gentran:Server for Microsoft Windows: User Guide



The following describes the parts of the Outbound Translation Object dialog box.

Part Function

Import Displays all import translation objects in the system for the
Standard, Version, Transaction Set, and Release defined by the
relationship.

Print Displays all print translation objects in the system for the Standard,
Version, Transaction Set, and Release defined by the relationship.
The selected translation object will be used to print documents sent
to this partner.

Data Entry Displays all screen entry translation objects in the system for the
Standard, Version, Transaction Set, and Release defined by the
relationship.

Application ID Specify the application identifier that indicates the destination of
the documents.

Application Alias
Value

Specify the criteria for this relationship definition, which will be
used during the application import function.

For example: The application contains data that can generate either
an invoice or a credit memo. Use one relationship definition for
invoices and another for credit memos.

There is a box in the application that defines whether this is an
invoice or a credit memo. The box will display CREDIT if a credit
memo is created and INVOICE if an invoice is created. Type
CREDIT in the Application Alias Value for the relationship
defining the credit memo or INVOICE for the invoice.
Note: This box will only be used if you receive translation objects
that are defined to use the Application Alias Value.
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Part Function

TurnAround Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.

You must select a translation object from the TurnAround list if
you have created a specific turnaround translation object for this
relationship and if you want to change the way the system behaves
for this partner relationship.
Note: TurnAround translation objects may not be appropriate for
an Outbound Relationship.

Export Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.

You must select a translation object from the Export list if you have
created a specific export translation object for this relationship and
if you want to change the way the system behaves for this partner
relationship. Export translation objects are used to export an
outbound document to a file.

Transaction Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.

You must select a translation object from the Transaction list if you
have created a specific Transaction Build translation object for this
relationship and if you want to change the way the system behaves
for this partner relationship.

Acknowledge Select other translation objects associated with the relationship,
which gives you the capability to change the system behavior at
the transaction and document translation level. This allows you to
use translation objects that are as partner-specific as required
and/or perform as many functions as required.

You must select a translation object from the Acknowledge list if
you have created a specific translation object for this relationship
and if you want to change the way the system behaves for this
partner relationship. When the system generates an
acknowledgement, it writes the acknowledgement to an internal
file containing the acknowledgement details and then maps that
internal file. If you need the system to process acknowledgements
differently, you should select an additional translation object from
the Acknowledge list.

Outbound Group Select Dialog Box
The Outbound Group Select dialog box is used to select an existing functional
group definition to be associated with this relationship. You can also use it to
initiate the definition of a new functional group or to modify or delete an existing
definition. The groups that are available to you are determined by the version you
selected on the Outbound Relationship dialog box.
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Functional groups are required for ANSI X12, TDCC, and UCS standards, are
optional for EDIFACT and ODETTE, and are not specified for TRADACOMS.

The following illustrates the Outbound Group Select dialog box:

The following describes the parts of the Outbound Group Select dialog box.

Part Function

Groups Displays all functional group definitions established for this
trading partner.

Select Selects the indicated functional group as the one the system uses
for this relationship.

Outbound Group Entry Dialog Box
The Outbound Group Entry dialog box is used to specify a new functional group
definition.

The following illustrates the Outbound Group Entry dialog box with the Advanced
options displayed:

The following describes the parts of the Outbound Group Entry dialog box.
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Part Function

Description Specify the name of the functional group description.

Standard Displays the EDI standard the system is using for this relationship
definition.

Version Displays the version of the EDI standard the system is using for
this relationship.

Functional Group ID Specifies the functional group. These identification boxes are
defined by each appropriate standards group to group like
documents. The standard defines which functional group ID
should be used with each document type. This is a mandatory box.

Examples

v IN 810 - X12 Invoice

v PO - 850 X12 Purchase Order

v IG - 830 UCS Invoice

v OG - 875 UCS P. O.

v INVOIC - EDIFACT INVOIC

v ORDERS - EDIFACT ORDERS

v INVOIC - Tradacoms INVOIC

v ORDERS - Tradacoms ORDERS

This element is located in:

v ANSI X12 - GS01

v EDIFACT - UNG01

v TRADACOMS - BAT

Last Used Group
Control Number

Specify a value that is used to generate the next interchange
control number. The number generated will always be one more
than the number in this box. This box will initially be set to zero.
Note: To ensure that functional acknowledgements work correctly,
you must define a unique control number for each group
relationship that exists for the same partner relationship.

Expect
Acknowledgement

Instruct the system to expect a functional acknowledgement to be
received from this trading partner as a result of your partner
receiving the group defined in this relationship. The default value
for this box is not checked (do not expect an acknowledgement).

Hours Overdue Specify how many hours must elapse before an expected functional
acknowledgement is considered overdue. This box is only valid if
the Expect Acknowledgement box is checked. The default value for
this box is “48,” indicating that the acknowledgement will be
considered overdue in two days. If you enter a value of “0” (zero)
in this box, the acknowledgement will be immediately considered
overdue.
Note: This box is disabled if Expect Acknowledgement is not
checked.

Sequence From Group Specify if the transaction set control number options for this group
setup should be controlled at the group level. If this box is not
checked, the following two fields are disabled.

Last Used Control
Number

Specify a value that will be used to generate the next transaction
set control number for the sets defined within this functional
group. The number generated will always be one more than the
number in this box. This box will initially be set to zero.
Note: This box is disabled if Sequence From Group is not checked.
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Part Function

Format Select the format of the transaction set control number that will be
generated:

v Normal - The number will be generated by incrementing the last
used control number. The length of the number will be defined
by the standard.

v 6/3 - The number will be a composite of two numbers. The first
six digits are the last six digits of the functional group control
number. The last three digits are a counter beginning at “1”
within the functional group. Use this format only as instructed
by your trading partner.

v 5/4 - The number will be a composite of two numbers. The first
five digits are the last five digits of the functional group control
number. The last four digits are a counter beginning at “1”
within the functional group. This is the normal TDCC
numbering convention. It is used by the Motor, Rail, and Ocean
transportation industries.

v 5/3 - The number will be a composite of two numbers. The first
five digits are the last five digits of the functional group control
number. The last three digits are a counter beginning at “1”
within the functional group. This is the normal UCS convention,
which is used by the Grocery and Warehousing industries.

Note: This box is disabled if Sequence From Group is not checked.

Group Transl. Obj. Select a partner-specific Group Build Map translation object if this
trading partner group deviates from the normal system behavior.
You must select a translation object from this list if you want the
system to perform partner-specific grouping.
Important: We strongly recommend that you do not change the
translation objects in the Group Transl. Obj. and Acknowledge
Transl. Obj. lists, unless you have a specific reason for doing so.

Acknowledge Transl.
Obj.

Select an Acknowledgement Build Map if one exists on the system.

You must select a translation object from the Acknowledge Transl.
Obj. list if you have created a specific translation object for this
relationship and if you want to change the way the system behaves
for this partner group. When the system reconciles an
acknowledgement, it maps the acknowledgement to an internal file
and then processes it. If you need the system to process
acknowledgements differently, you should select an additional
translation object from the Acknowledge list.
Important: We strongly recommend that you do not change the
translation objects in the Group Transl. Obj. and Acknowledge
Transl. Obj. lists, unless you have a specific reason for doing so.

Envelope Accesses one of the following Outbound Functional Group
Envelope dialog boxes depending on which version you specified
on the Outbound Relationship Dialog Box:

v Outbound GS Functional Group

v Outbound UNG Functional Group

v Outbound BAT Functional Group

Refer to the Partner Editor online help for specific information
about the envelope dialog boxes.
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Outbound Interchange Select Dialog Box
The Outbound Interchange Select dialog box is used to select an existing
interchange definition to be associated with this relationship. It can also be used to
initiate the definition of a new interchange, or to modify or delete an existing
definition. The interchanges available to you are determined by the version you
selected on the Outbound Relationship dialog box. Interchanges are required for
EDIFACT, ODETTE, TRADACOMS, and UCS, and are optional for ANSI X12 and
TDCC.

The following illustrates the Outbound Interchange Select dialog box:

The following describes the parts of the Outbound Interchange Select dialog box.

Part Function

Interchanges Displays all interchange definitions established for this trading
partner.

Select Selects the indicated interchange to be used with this relationship.
Note: Select <none> if the standard you are using does not require
interchanges and you do not want to use one.

Outbound Interchange Entry Dialog Box
The Outbound Interchange Entry dialog box is used to specify a new interchange
definition.

Note: EDIFACT version 4 defines the infrastructure necessary to support the
creation (and processing) of interchanges that have been encoded using a character
set other than 8-bit ASCII. Sterling Gentran:Server for Microsoft Windows supports
the processing of an encoded interchange as long as the encoding of the
interchange matches the default code page of the operating system where Sterling
Gentran:Server is running.

See the IBM Sterling Gentran:Server for Microsoft Windows Communications User Guide
for more information.

The following illustrates the Outbound Interchange Entry dialog box with the
Advanced options displayed:

42 IBM Sterling Gentran:Server for Microsoft Windows: User Guide



The following describes the parts of the Outbound Interchange Entry dialog box.

Part Function

Description Displays the name of the interchange description.

Standard Displays the EDI standard the system is using for this relationship
definition.

Version Displays the version of the EDI standard the system is using for
this relationship.

Interchange ID Displays the type of interchange you specified. The standard
defines which interchange ID should be used with each standard.
This is a mandatory box.

Examples

v ANSI X12 - ISA

v ANSI X12 - ICS

v UCS - BG

v EDIFACT - UNB

v Tradacoms - STX

Use the default
Mailbox and E-mail
Address

Specify that the system will use the default Mailbox and E-mail
address specified on the Partner Definition (New/Edit) Dialog Box.

Mailbox/�New
Mailbox

Specify a mailbox to use to identify this partner for RosettaNet
relationships.

Optionally, click New Mailbox to display the Create New Mailbox
wizard, which allows you to create a new mailbox.
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Part Function

E-mail Address/�Edit
Mailbox

Specify an e-mail address to identify this partner for RosettaNet
relationships.

Optionally, click Edit Mailbox to display the Mailbox Properties
dialog box, which allows you to edit the mailbox.

Content Type Specify the content type of the interchange.

Set Max Number of
Documents per
Interchange

Instruct the system to only allow the specified maximum number
of documents per interchange for this relationship.

Max Number of
Documents per
Interchange

Specify the maximum number of documents allowed per
interchange for this relationship.

Last Used Control
Number

Specify a value that will be used to generate the next interchange
control number. The number generated is always one more than
the number in this box. Initially, this box will be set to zero.

Expect
Acknowledgement

Instruct the system to expect a functional acknowledgement to be
received from this trading partner as a result of your partner
receiving the interchange set defined in this relationship. The
default value for this box is not checked (do not expect an
acknowledgement).

Hours Overdue Specify how many hours must elapse before an expected functional
acknowledgement is considered overdue. This box is only valid if
the Expect Acknowledgement box is checked. The default value for
this box is “48,” indicating that the acknowledgement will be
considered overdue in two days. If you enter a value of zero in
this box, the acknowledgement will be immediately considered
overdue.
Note: This box is disabled if Expect Acknowledgement is not
checked.

Interchange Transl.
Obj.

Select a partner-specific Interchange Build Map translation object if
this trading partner interchange deviates from the normal system
behavior. You must select a translation object from this list if you
want the system to perform partner-specific interchanging.
Important: We strongly recommend that you do not change the
translation objects in the Interchange Transl. Obj. and Acknowledge
Transl. Obj. lists, unless you have a specific reason for doing so.

Acknowledge Transl.
Obj.

Select an Acknowledgement Build Map if one exists on the system.

You must select a translation object from the Acknowledge Transl.
Obj. list if you have created a specific translation object for this
relationship and if you want to change the way the system behaves
for this partner interchange. When the system reconciles an
acknowledgement, it maps the acknowledgement to an internal file
and then processes it. If you need the system to process
acknowledgements differently, you should select an additional
translation object from the Acknowledge list.
Important: We strongly recommend that you do not change the
translation objects in the Interchange Transl. Obj. and Acknowledge
Transl. Obj. lists, unless you have a specific reason for doing so.
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Part Function

Envelope Accesses one of the following Outbound Interchange Envelope
dialog boxes depending on which version you specified on the
Outbound Relationship Dialog Box:

v Outbound ISA Envelope

v Outbound ICS Envelope

v Outbound BG Envelope

v Outbound UNB Envelope

v Outbound UNA Envelope

v Outbound STX Envelope

v Outbound VDA Envelope

v Outbound NCPDP Envelope

v Outbound Envelope PIP Initiation

Creating a Partner Definition
The partner definition contains the basic information about the trading partner that
the system needs before you define the rest of the partner profile.

Before you begin

Before setting up a new partner definition, you must have the following
information:
v The communication profile name you use to communicate with this partner
v The EDI code for this partner
v The application code used to identify this partner in the import file�This

application code is needed only if the transactions are processed using the file
Import facility.

About this task

To create a partner definition, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Click New.

The system displays the Partner Definition (New/Edit) Dialog Box.
3. In the Profile ID box, type a unique alphanumeric Profile ID for this partner.

Note: Do not use special characters.
4. In the Name box, type the partner name.
5. In the EDI Code box, type the EDI identifier for this partner.

Note: The system uses this identifier during inbound processing to select the
correct partner.

6. If necessary, in the Application Code box, type an application code to identify
this partner.

Note: The system uses this identifier during outbound import processing, to
select the correct partner.
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7. Select the appropriate mailbox from the Default Mailbox list or click New
Mailbox to create a new mailbox.

Note: See the IBM Sterling Gentran:Server for Microsoft Windows Communications
User Guide for more information about creating mailboxes.

8. After you enter all the partner definition information, click Save.
9. Click Exit to return to the Partner Editor dialog box.

Notes: To complete the partner profile, you need to define an inbound or
outbound relationship or both:
v If you are receiving and processing information from this trading partner,

you need to define an appropriate inbound relationship established.
v If you are sending information to this trading partner, you need to define an

outbound relationship.

About Inbound Relationships
To correctly receive and process information from a trading partner, you must have
an appropriate inbound relationship established that defines the parameters
needed to receive data files from that partner. Each inbound relationship defines
which business documents are received from a partner.

You must set up several parameters that are used to create an inbound
relationship. These parameters tell the system the following information:
v The type of data received
v The criteria the system uses to validate the information it receives
v The functional groups and interchanges in which you expect to receive the

documents

Translation Objects

Each inbound relationship must have one or more associated inbound translation
objects. These translation objects determine how the received data is processed.
You need to specify which translation objects are used to define the rules for
exporting, printing, and creating turnaround documents. At a minimum, one
translation object must be available.

Note: If this relationship requires a new translation object, you must register that
translation object with the system before creating the inbound relationship. See
Registering New Translation Objects for instructions.

Inbound Groups and Interchanges

You must define or select an inbound interchange and/or inbound functional
group before the system allows you to complete the setup of an inbound
relationship. The inbound functional group defines the format of the functional
group and the parameters that should be used to verify it. The inbound
interchange defines the format of the interchange and the parameters that should
be used to verify it.

However, for some transactions, the functional group or interchange is optional
and if your trading partner has chosen not to use it then it is not necessary for you
to select one. Refer to the following standards to determine whether or not you are
required to select an inbound functional group or interchange:
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v For some ANSI X12 documents, the interchange is optional and the functional
group is required. However, for most documents, both an interchange and
functional group are required.

v For TDCC, the interchange is optional and the functional group is required.
v For UCS, the interchange is required and the functional group is also required.
v For EDIFACT, the interchange is required and the functional group is optional.
v For ODETTE, the interchange is required and the functional group is optional.
v For TRADACOMS, the Interchange is required and there is no functional group.

Note: If you do not want to use an optional functional group or interchange, you
must still select <none> from the appropriate dialog box to alert the system that
you are not using a group.

Process for Creating an Inbound Relationship

The following describes the process for defining an inbound relationship:

Stage Description

1 Create a new inbound relationship.

2 Create and register the inbound translation object to be used with this
relationship.

See the IBM Sterling Gentran:Server for Microsoft Windows Application
Integration User Guide for more information about creating a translation
object. Also see Registering New Translation Objects for more
information.

3 Select at least one inbound translation object.

4 Create and select at least one inbound group to define how the
document is received from this partner.
Note: Depending on the standards you are using, either the functional
group or interchange may be optional.

5 Create and select at least one inbound interchange to define how the
document is received from this partner.
Note: Depending on the standards you are using, either the functional
group or interchange may be optional.

6 If you are generating functional acknowledgements as a result of
receiving documents for an inbound relationship, you must set up the
corresponding outbound relationship to generate the
acknowledgements your partner requests.

See Creating an Outbound Relationship for more information.

Creating an Inbound Relationship
Before you begin

Before setting up an inbound relationship, you must know the following
information to plan the implementation of this partner:
v The EDI standard you expect from this trading partner (such as ANSI)
v The standard version you expect from this trading partner (such as 003020 for

ANSI or 090001 for EDIFACT)
v The code for the transaction set you expect from this trading partner (such as

INVOIC for an EDIFACT invoice)
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v The type of functional group and interchange the transaction set is wrapped in
when it is received from this partner

The information required for this task should be provided to you by your trading
partner when this partner defines the details of the transactions they send you.

About this task

To create an inbound relationship, complete the following steps.

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile for which you want to create an inbound

relationship and click Inbound.
The system displays the Inbound Relationship Dialog Box.

Note: You must have already created a partner definition for this partner.
3. Click New.

The system displays the New Inbound Relationship dialog box.
4. In the description box, type a unique relationship name.
5. Click Save.

The system creates an inbound relationship and returns to the Inbound
Relationship dialog box.

6. Select values for the following:
v Standard
v Version
v Transaction Set
v Release (for TRADACOMS only)

7. If you need to define parameters to comply with the processing needs of your
partner (such as Sequence Checking, Last Used Control, Duplicate Documents,
or Generate Acknowledgement), click Advanced.

Important: Do not change the translation objects in the Interchange Transl.
Obj. and Acknowledge Transl. Obj. lists, unless you have a specific reason to
do so.

8. You now need to select an inbound translation object for this partner. Do the
following:
a. On the Inbound Relationship dialog box, click Translation.

The system displays the Inbound Translation Object Dialog Box.
b. Select the translation objects required for this inbound relationship.
c. If you selected an Export File translation object and you want to export to

a specific file, type the universal naming convention (UNC) name of that
file in the Export File Name box.

d. To use the Export to Mailbox function to specify a mailbox and E-mail
address so the output of the inbound translation object can be delivered
directly back to the Mailbox Server Manager, select Export to Mailbox and
complete the appropriate boxes.

e. Click Save to save your selections and return to the Inbound Relationship
dialog box.
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9. You now need to select an inbound functional group. Do the following:
a. On the Inbound Relationship dialog box, click Groups to display a list of

existing groups.
The system displays the Inbound Group Select Dialog Box.

b. Do one of the following:
v If you are not using groups, select <none> and click Select. Continue

with Step 10.
v If the required group is in the Groups list, select the group. Continue

with Step 10.
v If the required group is not in the list, you will need to create it.

Continue with step c.
c. On the Inbound Group Select dialog box, click New.

The system displays the Inbound Group Entry Dialog Box.
d. In the Description box, type the group description.
e. In the Functional Group ID box, type the identification of the functional

group you are specifying.
f. If you have more complex requirements for processing the functional

group, click Advanced to display the full list of functional group setup
options.

Important: Do not change the translation objects in the Interchange Transl.
Obj. and Acknowledge Transl. Obj. lists, unless you have a specific reason
to do so.

g. After you set up the required parameters in this dialog box, click Save to
store the information and return to the Inbound Group Select dialog box.

h. Highlight the new group and click Select.
The system selects the group and returns to the Inbound Relationship
dialog box.

10. You now need to select an inbound interchange. Do the following:
a. On the Inbound Relationship dialog box, click Interchanges to display a

list of existing interchanges.
The system displays the Inbound Interchange Select Dialog Box.

b. Do one of the following:
v If you are not using groups, select <none> and click Select. Continue

with Step 11.
v If the required interchange is in the Interchanges list, select the

interchange. Continue with Step 11.
v If the required interchange is not in the list, you will need to create it.

Continue with step c.
c. On the Inbound Interchange Select dialog box, click New.

The system displays the Inbound Interchange Entry Dialog Box.
d. In the Description box, type the interchange description.
e. In the Interchange ID box, type the identification of the interchange you

are specifying.
f. If you have more complex requirements for processing the interchange,

click Advanced to display the full list of interchange setup options.
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Important: Do not change the translation objects in the Interchange Transl.
Obj. and Acknowledge Transl. Obj. lists, unless you have a specific reason
to do so.

g. After you set up the required parameters in this dialog box, click Save to
store the information and return to the Inbound Interchange Select dialog
box.

h. Highlight the new interchange and click Select.
The system selects the interchange and returns to the Inbound Relationship
dialog box.

11. On the Inbound Relationship dialog box, click Save to save the inbound
relationship.

12. Click Exit to return to the Partner Editor dialog box.

About Outbound Relationships
To correctly send information to a trading partner, you need to define an outbound
relationship. Outbound relationships define the parameters needed to send a data
file to a trading partner. Each outbound relationship defines the format of a single
business document, and how that business document is formatted and sent to the
specified trading partner.

You must set up several parameters that are used to create an outbound
relationship. These parameters tell the system the following information:
v How to create the required message
v The criteria that the system uses to validate the information entered
v How to create the functional group and interchange envelopes in preparation for

sending

Translation Objects

Each outbound relationship must have one or more associated outbound
translation objects. These translation objects determine how the sent data is
formatted. You need to specify which translation objects are used to define the
rules for screen entry or file import. At a minimum, one translation object must be
available.

Note: If this relationship requires a new translation object, you must register that
translation object with the system before creating the outbound relationship. See
Registering New Translation Objects for instructions.

Outbound Groups and Interchanges

You must define or select an outbound interchange and/or outbound functional
group before the system allows you to complete the setup of an outbound
relationship. The outbound functional group defines the format of the functional
group and the parameters that should be used to verify it. The outbound
interchange defines the format of the interchange and the parameters that should
be used to verify it.

However, for some transactions, the functional group or interchange is optional,
and if your trading partner has chosen not to use it, it is not necessary for you to
select one. Refer to the following standards descriptions to determine whether or
not you are required to select an outbound functional group or interchange:
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v For some ANSI X12 documents, the interchange is optional and the functional
group is required. However, for most documents, both an interchange and
functional group are required.

v For TDCC, the interchange is optional and the functional group is required.
v For UCS, the interchange is required and the functional group is also required.
v For EDIFACT, the interchange is required and the functional group is optional.
v For ODETTE, the interchange is required and the functional group is optional.
v For TRADACOMS, the Interchange is required and there is no functional group.

Note: If you do not want to use an optional functional group or interchange, you
must still select <none> from the appropriate dialog box to alert the system that
you are not using a group.

Process for Creating an Outbound Relationship

The following describes the process of defining an outbound relationship.

Stage Description

1 Create a new outbound relationship.

2 If you are using the EDIFACT, ODETTE, or TRADACOMS standard,
you must complete the envelope (header) information for this type of
document. For the ANSI, UCS, and TDCC standards, the envelope
information is optional.

3 Create and register the inbound translation object to be used with this
relationship.

See the IBM Sterling Gentran:Server for Microsoft Windows Application
Integration User Guide for more information about creating a translation
object. Also see Registering New Translation Objects for more
information.

4 Select at least one outbound translation object.

5 Create and select at least one outbound group (including enveloping
information) to define how the document is received from this partner.
Note: Depending on the standards you are using, either the functional
group or interchange may be optional.

6 Create and select at least one outbound interchange (including
enveloping information) to define how the document is received from
this partner.
Note: Depending on the standards you are using, either the functional
group or interchange may be optional.

7 If you will receive functional acknowledgements for the outbound
documents, set up the corresponding inbound relationship to receive
the acknowledgements you expect from your partner.

Creating an Outbound Relationship
Before you begin

Before setting up an outbound relationship, you must know the following
information to plan the implementation of this partner:
v The EDI standard this trading partner expects (such as ANSI X12)
v The standard version that this partner expects (such as 003020 for ANSI or

090001 for EDIFACT)
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v The code for the transaction set you use (such as “INVOIC” for an EDIFACT
invoice)

v The type of functional group and interchange envelope the transaction set is
wrapped in when it is sent to this partner

The information required for this task should be provided to you by your trading
partner when this partner defines the details of the transactions they send you.

About this task

To create an outbound relationship, complete the following steps.

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile for which you want to create an outbound

relationship and click Outbound.
The system displays the Outbound Relationship Dialog Box.

Note: You must have already created a partner definition for this partner.
3. Click New.

The system displays the New Outbound Relationship dialog box.
4. In the description box, type a unique relationship name.
5. Click Save.

The system creates an outbound relationship and returns to the Outbound
Relationship dialog box.

6. Select values for the following:
v Standard
v Version
v Transaction Set
v Release (for TRADACOMS only)

7. If you need to define parameters to comply with the processing needs of your
partner (such as Last Used Control Number, Expect Acknowledgement, Hours
Overdue, Duplicate Documents, or Test Indicator), click Advanced.
The system displays the Advanced fields on the Outbound Relationship dialog
box.

8. If you are using the EDIFACT, ODETTE, or TRADACOMS standard, you must
select a transaction envelope. For the ANSI, UCS, and TDCC standards, the
envelope information is optional. Do the following:
a. Click Envelope to complete the envelope (header) information.

The system displays an outbound envelope dialog box.
b. Enter the appropriate information and click Save.

Saves the information and returns to the Outbound Relationship dialog
box.

9. You now need to select an outbound translation object for this partner. Do the
following:
a. On the Outbound Relationship dialog box, click Translation.

The system displays the Outbound Translation Object Dialog Box.
b. Select the translation objects required for this outbound relationship.
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c. If you selected an Import translation object, you may need to define the
following:
v In the Application ID box, type the application identifier that indicates

the destination for the documents.
v In the Application Alias Value box, type criteria that the system will use

to distinguish this relationship from others during the application
import function.

d. Click Save to save your selections and return to the Outbound
Relationship dialog box.

10. You now need to select an outbound functional group for this partner. Do the
following:
a. On the Outbound Relationship dialog box, click Groups to display a list of

existing groups.
The system displays the Outbound Group Select Dialog Box.

b. Do one of the following:
v If you are not using groups, select <none> and click Select. Continue

with Step 11.
v If the required group is in the Groups list, select the group. Continue

with Step 11.
v If the required group is not in the list, you will need to create it.

Continue with step c.
c. On the Outbound Group Select dialog box, click New.

The system displays the Outbound Group Entry Dialog Box.
d. In the Description box, type the group description.
e. In the Functional Group ID box, type the identification of the functional

group.
f. If you have more complex requirements for processing the functional

group, click Advanced.

Important: Do not change the translation objects in the Group Transl. Obj.
and Acknowledge Transl. Obj. lists, unless you have a specific reason to do
so.

g. Click Envelope to set up the parameters for the generation of the
Functional Group segment.
An outbound functional group dialog box is displayed.

h. After you set up the required parameters in the enveloping dialog box,
click Save to store the information and return to the Outbound Group
Entry dialog box.

i. Click Save to store the information about the Outbound Group Entry
dialog box and return to the Outbound Group Select dialog box.

j. Highlight the new group and click Select.
Selects the group and returns to the Outbound Relationship dialog box.

11. You now need to select an outbound interchange. Do the following:
a. On the Outbound Relationship dialog box, click Interchanges.

The system displays the Outbound Interchange Select Dialog Box.
b. Do one of the following:

v If you are not using groups, select <none> and click Select. Continue
with Step 12.
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v If the required interchange is in the Interchanges list, select the
interchange. Continue with Step 12.

v If the required interchange is not in the list, you will need to create it.
Continue with step c.

c. On the Outbound Interchange Select dialog box, click New.
The system displays the Outbound Interchange Entry Dialog Box.

d. In the Description box, type the interchange description.
e. In the Interchange ID box, type the identification of the interchange.
f. If you have more complex requirements for processing the interchange,

click Advanced.

Important: Do not change the translation objects in the Interchange Transl.
Obj. and Acknowledge Transl. Obj. lists, unless you have a specific reason
to do so.

g. If you do not want to use the default Mailbox and E-mail Address, select
the appropriate mailbox from the Default Mailbox list or click New
Mailbox to create a new mailbox.

h. Click Envelope to set up the parameters for the generation of the
interchange segment.
An outbound interchange dialog box is displayed.

i. After you set up the required parameters in the enveloping dialog box,
click Save to store the information and return to the Outbound Interchange
Entry dialog box.

j. Click Save to store the information about the Outbound Interchange Entry
dialog box and return to the Outbound Interchange Select dialog box.

k. Highlight the new interchange and click Select.
Selects the interchange and returns to the Outbound Relationship dialog
box.

12. On the Outbound Relationship dialog box, click Save to save the outbound
relationship.

13. Click Exit to return to the Partner Editor dialog box.

Editing a Partner Profile
About this task

Notes:

v You can also edit other aspects of a partner relationship (such as inbound
relationship or outbound relationship) by clicking the appropriate button
(Inbound or Outbound) on the Partner Editor dialog box.

v You are not able to edit any boxes that are grayed; these are the keys to the
relationship. In this case, you must create a new inbound or outbound
relationship for that partner.

To edit a partner profile, complete the following steps.

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the appropriate partner from the Select a Partner list.
3. Click Edit.
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The system displays the Partner Definition (New/Edit) Dialog Box for that
partner.

4. Make the necessary changes.
5. Click Save.

The system returns to the Partner Editor dialog box.

Deleting a Partner Profile
About this task

Important:

v When you delete a partner relationship, the documents and interchanges
associated with that partner are also deleted.

v If any documents or interchanges exist for a partner you choose to delete, you
are warned before the actual deletion.

To delete a partner profile, complete the following steps.

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the appropriate partner from the Select a Partner list.
3. Click Delete.

You are prompted to confirm the deletion.
4. Click Yes to delete the selected partner profile.

The partner profile and all associated records are deleted.

Routing Partner Profiles

Partner Copy Dialog Box
The partner copy feature allows you to copy partner information. Once you copy
the partner, this dialog enables you to change the partner definition and other
identifying boxes for the copied partner.

Note: You must export the partner profile before you copy it. See Exporting
Partner Profiles for more information. If you do not know which EDI standard that
partner profile uses, check the profile to obtain that information before you export
and copy it.

The following illustrates the Partner Copy dialog box:
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The following describes the parts of the Partner Copy dialog box.

Part Function

Profile ID Specify a unique identifier for the selected partner.

Select Partner Accesses the Import File Select Dialog Box, which allows you to
select a partner profile to copy.

Name Specify a unique name for the partner.
Note: Make this name as descriptive as possible because this is the
name displayed in the partner selection list.

EDI Code Specify the EDI identifier for this partner. The system uses this
value during inbound processing to select the correct trading
partner definition.

Application Code Specify an application code used to identify this partner. The
system uses this value during outbound import processing to select
the correct trading partner definition.

Default Mailbox Select the mailbox to identify this partner.

See the IBM Sterling Gentran:Server for Microsoft Windows
Communications User Guide for more information.

Group Receiver
Qualifier

Specify your partner's Qualifier as it will appear on the UNG
group header. Qualifiers are predefined by the EDI standards.
Note: If the partner profile uses the EDIFACT or ODETTE
standard, you must complete this box. If you do not complete this
box, the system uses the value from the copied partner profile's
envelope information.

Group Receiver ID Specify your partner's Group ID. The value can be up to 15
characters.
Note: If the partner profile uses the ANSI, EDIFACT, ODETTE,
UCS, or TDCC standard, you must complete this box. If you do
not complete this box, the system uses the value from the copied
partner profile's envelope information.
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Part Function

Interchange Receiver
Qualifier

Specify your partner's Qualifier as it will appear on the interchange
header. Qualifiers are predefined by the EDI standards. The value
can be up to four characters.
Note: If the partner profile uses the ANSI, EDIFACT, ODETTE,
UCS, or TDCC standard, you must complete this box. If you do
not complete this box, the system uses the value from the copied
partner profile's envelope information.

Interchange Receiver
ID

Specify your partner's Interchange ID. The value can be up to 15
characters.
Note: If the partner profile uses the ANSI, EDIFACT, ODETTE,
UCS, or TDCC standard, you must complete this box. If you do
not complete this box, the system uses the value from the copied
partner profile's envelope information.

Interchange
Communication ID

Specify your BG communication identifier. This ID will appear on
the BG Interchange Header.
Note: If the partner profile uses the UCS standard, you must
complete this box. If you do not complete this box, the system uses
the value from the copied partner profile's envelope information.

Interchange Password Specify a password that is agreed upon by you and your trading
partner. This password will appear on the BG Interchange Header.
Note: If the partner profile uses the UCS standard, you must
complete this box. If you do not complete this box, the system uses
the value from the copied partner profile's envelope information.

Recipient Code Specify the code agreed on by you and your partner.
Notes:

v If the partner profile uses the TRADACOMS standard, you must
complete this box. If you do not complete this box, the system
uses the value from the copied partner profile's envelope
information.

v The Recipient Code is mandatory if you do not complete the
Recipient Name box.

Recipient Name Specify your partner's name.
Notes:

v If the partner profile uses the TRADACOMS standard, you must
complete this box. If you do not complete this box, the system
uses the value from the copied partner profile's envelope
information.

v The Recipient Name is mandatory if you do not complete the
Recipient Code box.

Receiver DUNS+4 Mandatory. Specify the DUNS number of your partner.

Importing Partner Profiles
Partner profiles may become complex and may require you to define a significant
number of parameters. To simplify this process, Sterling Gentran:Server includes
the import partner feature, which enables you to import partner details from a file.

Before you begin

You must create a mailbox for the partner prior to loading the partner profile. See
the IBM Sterling Gentran:Server for Microsoft Windows Communications Guide for
more information.
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About this task

You can also use the import facility to update information for existing partners. If
you import to an existing partner profile, you can add new trading relationships.
Existing relationships are not modified.

Note: Any tables (cross-reference, lookup, or location) attached to the partner
profile are also imported.

See the IBM Sterling Gentran:Server for Microsoft Windows Administration Guide for
more information about partner file layouts.

To import a partner profile, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Click Import.

The system displays the Import File Select Dialog Box.
3. Navigate to the folder and enter or select the name of the partner file.
4. Click Open.

The system displays the Import dialog box.

Note: This dialog box allows you verify this partner is the correct one.
5. Click Save to continue.
6. If you are prompted to enter additional partner information, enter that

information and click Save.
The system imports the partner details (if they do not already exist on the
system) and any relationships for which there are translation objects. During
this process, the system prompts you for any additional information it needs by
displaying the appropriate Partner Editor dialog box. You are prompted with
dialog boxes when you would normally be required to provide information
about your site. This is usually restricted to your EDI identifiers, which the
system uses to generate outbound EDI envelopes. The system continues
displaying Partner Editor dialog boxes until it has all the information it needs.
When the import is complete, the system displays the following message:
Import process completed. Please note any warnings or errors.

7. Click OK to return to the Import dialog box.
8. Click Exit to return to the Partner Editor dialog box.

Exporting Partner Profiles
Sterling Gentran:Server includes a feature that enables you to export existing
partner details to a file. You can also export your partners to disk to use as a
backup of your partner system.

About this task

Note: Any tables (cross-reference, lookup, or location) attached to the partner
profile are also exported. See the Partner File Layouts appendix in the IBM Sterling
Gentran:Server for Microsoft Windows Administration Guide for more information.

To export a partner profile, complete the following steps:
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Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select a partner.
3. Click Export.

The system displays the Export File Build Dialog Box.
4. Navigate to the correct folder and enter a name for the export file.

Note: The system automatically prompts you to name the export file with the
name of the partner and the .par extension.

5. Click Save to export the partner.

Copying Partner Profiles
The partner copy function enables you to copy partner information so you do not
have to type in similar partner profiles from scratch. Instead, you can copy from an
existing profile and enter unique partner definition and key enveloping
information for the copied partner.

About this task

The partner copy function provides a quick method for establishing partners that
have similar or identical trading relationships.

Note: You must export the partner profile before you copy it. If you do not know
which EDI standard that partner profile uses, check the profile to obtain that
information before you export and copy it.

To copy a partner profile, complete the following steps.

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Click Copy.

The system displays the Partner Copy Dialog Box.
3. Click Select Partner.

The system displays the Import File Select Dialog Box.
4. Navigate to the folder and select the file you want to copy.
5. Click Open to copy that partner.

Note: The system displays the model partner profile name in the title bar of
the Partner Copy dialog box. The default file extension for exported partners
is .par.

6. On the Partner Copy dialog box, do the following:
a. Type a unique profile identifier in the Profile ID box.
b. Type the partner name.
c. Type the EDI identifier for this partner.

Note: The system uses this identifier during inbound processing to select
the correct partner.

d. If necessary, type an application code to identify this partner.
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Note: The system uses this identifier during outbound import processing
to select the correct partner.

e. elect the appropriate mailbox from the Default Mailbox list.
7. Complete the appropriate boxes in the enveloping section of the dialog box.

Notes:

v You should only complete those boxes that are necessary for the standard
that the copied partner profile uses. The standards are listed to the right of
each box.

v If the partner profile you copied uses a standard, you must complete all the
necessary enveloping boxes for that standard. If you do not complete the
necessary boxes for the standard, the system takes the necessary
information from the copied partner profile envelope.

For example: If the copied partner profile uses the UCS standard, you must
complete the Interchange Communication ID box, among others.

8. After you enter all the partner information, click Save.
The system displays the Outbound Interchange Entry Dialog Box.

9. To change the default mailbox, select the appropriate mailbox from the
Default Mailbox list or click New Mailbox and create a new mailbox.

10. Click Save.
The system completes the partner copy operation, displays a completion
message.

11. Click OK.
The system returns to the Partner Copy dialog box.

12. Click Exit to return to the Partner Editor dialog box.
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Chapter 4. Partner Tables

About Partner Tables
The translation process allows you to set up tables to use information in the
Partner database when a document is entered into the system, either from a file or
from the Document Editor facility.

The Partner Editor allows you to use an internal system partner (Internal System
User) to define your company to the system. Tables may be set up to be used
either with a trading partner or with the special system partner.
v Tables that you establish under a specific partner are valid only for that partner.
v Tables that you set up under the internal system user can be used globally.

The use of partner or system partner tables is defined in the translation objects at
design time. This allows commonly used items such as names and addresses to be
inserted into the outbound data without the need to type it. It also allows you to
use Lookup and Cross-reference tables to supplement or convert data that you
either enter or receive.

You can create cross-reference and lookup tables in Sterling Gentran:Server, or you
can import and export existing tables to and from your system.

Notes:

v You can only import and export Sterling Gentran:Server partner tables.
v Tables are used only if you create a translation object that specifically accesses

those tables.

Partner Tables Dialog Box
The Partner Tables dialog box enables you to create, edit, or delete cross-reference
or lookup tables. Tables are only used with translation objects that are designed to
incorporate that data. When you receive a translation object from IBM, you will be
informed if you need to create tables to be used with that translation object.

The following illustrates the Partner Tables dialog box:

The following describes the parts of the Partner Tables dialog box.

Part Function

Tables Displays all currently defined partner tables.
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Part Function

New Opens the New Table dialog box, which allows you to create a
new table.

Delete Removed the partner table from the system.

Edit Opens either the CrossRef Select dialog box or the Lookup Select
dialog box, which allows you to edit the selected table.

Import Opens the Table Import File Select dialog box, which enables you
to import a partner table.

Export Opens the Table Export File Build dialog box, which enables you to
export a partner table.

New Table Dialog Box
The New Table dialog box enables you to create a cross-reference or lookup table.

The following illustrates the New Table dialog box:

The following lists the parts of the New Tables dialog box and their functions:

Part Function

Table Name Specify the name of the table.
Notes:

v The table name must be the same as the name used in the translation
object that requires the table. If your database is case-sensitive, when
you reference the table using standard or extended rules, you must
type the exact name of the table (including case).

v See the IBM Sterling Gentran:Server for Microsoft Windows Application
Integration User Guide for more information about standard and
extended rules.

Table Type Specify the type of table. Valid values:

v Cross-Reference - Used to convert your values to your trading
partner's values during outbound processing, and to convert your
trading partner's values to your values during inbound processing.

v Lookup - Used to find values in inbound or outbound data.
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CrossRef Select Dialog Box
The CrossRef Select dialog box contains all cross-reference partner tables.

The following illustrates the CrossRef Select dialog box:

The following describes the parts of the CrossRef Select dialog box.

Part Function

Table Name Displays the name of the cross-reference table.

Items Displays a list of table items.

New Opens the CrossRef Entry Dialog Box, which allows you to create a
new table.

Edit Opens the CrossRef Entry Dialog Box, which allows you to edit the
selected table item.

CrossRef Entry Dialog Box
The CrossRef Entry dialog box enables you to create a new table item and edit
existing table items.

The following illustrates the CrossRef Entry dialog box:

The following describes the parts of the CrossRef Entry dialog box.

Part Function

Table Name Displays the name of the Cross-reference table.

My Value Specify your data value that corresponds to your partner's data
value.
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Part Function

Partner Value Specify your partner's data value that corresponds to your data
value.

Description Specify a description of the codes.

Reference Data Specify up to four values that can be mapped when they are
associated with a specific code value.
Note: These boxes are not currently used by Sterling
Gentran:Server.

Lookup Select Dialog Box
The Lookup Select dialog box contains all lookup partner tables.

The following illustrates the Lookup Select dialog box.

The following describes the parts of the Lookup Select dialog box.

Part Function

Table Name Displays the name of the Lookup table.

Items Displays a list of table items.

New Opens the Lookup Entry dialog box, which allows you to create a
new table item.

Edit Opens the Lookup Entry dialog box, which allows you to edit the
selected table item.

Lookup Entry Dialog Box
The Lookup Entry dialog box enables you to create a new table item and edit
existing table items.

The following illustrates the Lookup Entry dialog box:
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The following describes the parts of the Lookup Entry dialog box.

Part Function

Table Name Displays the name of the Lookup table.

Lookup Value Specify the value that will be looked up in the data during
inbound or outbound processing.

Description Specify a description of the code.

Reference Data Specify up to four values that can be mapped when they are
associated with a specific code value.
Note: These boxes are not currently used by Sterling
Gentran:Server.

Creating Partner Tables
About this task

To create a partner table, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile or the system partner (Internal System User) for

which you want to create a Cross-reference or Lookup table and click Tables.
The system displays the Partner Tables Dialog Box.

3. Click New.
The system displays the New Table Dialog Box.

4. In the Table Name box, type the unique table name.

Note: The table name must be the same as the name used in the translation
object that requires the table. If your database is case-sensitive, when you
reference the table using standard or extended rules, you must type the exact
name of the table (including case).

5. In the Table Type section, select Cross-reference or Lookup.
6. Click Save.
7. Click New.
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Displays either the CrossRef Entry Dialog Box or Lookup Entry Dialog Box
depending on which type of table you selected.

8. Enter the following, depending on which table type you selected:
v For a cross-reference table, enter your data value and your partner’s data

value.
v For a lookup table, enter the lookup value.

Note: How your data is used depends on how the translation object is
defined. Consult with the translation object designer if you are unclear about
what is required.

9. Enter a description for that record.
10. Click Save after each entry to save the information and enter another table

record.
11. Once you finish typing all entries, click Exit.
12. Click Exit to return to the Partner Editor dialog box.

Editing Partner Tables
About this task

To edit a partner table, complete the following steps:

Procedure
1. Select Tool > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile or the system partner (Internal System User) for

which you want to modify a Cross-reference or Lookup table and click Tables.
The system displays the Partner Tables Dialog Box.

3. Select the table you want to modify and click Edit.
The system displays either the CrossRef Select Dialog Box or Lookup Select
Dialog Box depending on the type of table.

4. Select the item you want to modify and click Edit.
The system displays either the CrossRef Entry Dialog Box or Lookup Entry
Dialog Box depending on the type of table.

5. Modify the entry.
6. After you finish modifying all necessary table entries, click Save.
7. Click Exit.

The system returns to the Partner Editor dialog box.

Deleting Entries in a Partner Table
About this task

To delete entries in a partner table, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile or the system partner (Internal System User) for

which you want to delete a table entry and click Tables.
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The system displays the Partner Tables Dialog Box.
3. Select the table you want to modify and click Edit.

The system displays either the CrossRef Select Dialog Box or Lookup Select
Dialog Box depending on the type of table.

4. Select the item you want and click Delete.
5. Click Yes to confirm the deletion.
6. Click Exit.

The system returns to the Partner Editor dialog box.

Deleting Partner Tables
About this task

To delete a partner table, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile for which you want to delete a table and click Tables.

The system displays the Partner Tables Dialog Box
3. Select the table and click Delete.
4. Click Yes to confirm the deletion.

The system returns to the Partner Editor dialog box.

Partner Table Fields
The Table Export function allows you to export partner cross-reference and lookup
tables to a sequential file. This allows you to define a table for one trading partner
and copy that table to another partner profile.

Typically, you export and then import tables created for another partner profile.
However, if necessary, you can build tables outside of Sterling Gentran:Server by
formatting your data in the export file layout.

The export file layout is a free-format ASCII text file. Each field must be delimited
(separated) with Hex01 because the field lengths are variable.

Note: You can create the file with a text editor (such as Notepad). The default file
extension for a lookup export file is .lkp. The default file extension for a
cross-reference file is .xrf.

The following table identifies the fields in lookup tables. Mandatory fields are
designated with an asterisk (*).

Field Description

PartnerKEY* Unique identifier for the partner

TableCode For lookup, this value is “L”.

TableName* Descriptive name for the table

This value is displayed in the table selection list.
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Field Description

Item* Value that is looked up in the data during inbound or outbound
processing

Description Brief comment about the item

Text1, Text2, Text3,
Text4

Additional reference information as required by the translation
object using this table

The following table identifies the fields in cross-reference tables. Mandatory fields
are designated with an asterisk (*).

Field Description

PartnerKEY* Unique identifier for the partner

TableCode For cross-reference, this value is “C”.

TableName* Descriptive name for the table

This value is displayed in the table selection list.

MyItem* Your data value that corresponds to your partner’s data value

PartnerItem* Your partner’s data value that corresponds to your data value

Description Brief comment about the item

Text1, Text2, Text3,
Text4

Additional reference information as required by the translation
object using this table

Exporting a Partner Table
About this task

To export a partner table, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile or the system partner (Internal System User) for

which you want to export a Cross-reference or Lookup table and click Tables.
The system displays the Partner Tables Dialog Box.

3. Click Export.
The system displays the Table Export File Build Dialog Box.

4. Navigate to the location of the exported table file and enter or select the name
of the file.

Notes:

v You can only export Sterling Gentran:Server partner tables.
v The default file extension for cross-reference tables is .xrf. The default file

extension for lookup tables is .lkp.
5. Click Save to begin the export process.

When the export process is complete, the system displays an informational
dialog box.

6. Click OK.
The system returns to the Partner Tables dialog box.
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7. Click Exit.
The system returns to the Partner Editor dialog box.

Importing Partner Tables
The Table Import function allows you to import partner cross-reference and lookup
tables from a sequential file. This allows you to import tables created for another
partner profile and build tables outside of Sterling Gentran:Server by formatting
your data in the export file layout.

About this task

To import a partner table, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile or the system partner (Internal System User) for

which you want to import a Cross-reference or Lookup table and click Tables.
The system displays the Partner Tables Dialog Box.

3. Click Import.
The system displays the Table Import File Select Dialog Box.

4. Navigate to the location of the table file and select or enter the name of the file.

Notes:

v You can only import Sterling Gentran:Server partner tables.
v The default file extension for cross-reference tables is .xrf. The default file

extension for lookup tables is .lkp.
5. Click Open to begin the import process.

When the export process is complete the system displays an informational
dialog box.

6. Click OK.
The system returns to the Partner Tables dialog box.

7. Click Exit.
The system returns to the Partner Editor dialog box.
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Chapter 5. Partner Locations

About Partner Locations
Each partner profile may have many associated location tables. The location tables
may contain address- and contact-related information about the partner.

You can use location tables in many different ways. Locations are referenced in
translation objects through one of the location keys (reference codes). Locations are
used only if you use a translation object that specifically accesses those locations.

For example: You may need a list of a partner’s store addresses, warehouse
addresses, or "invoice to" addresses. Any or all of these can be stored in a location
table.

You must set up two parameters that contain the following information:
v The name of the trading partner location
v The reference codes that the system uses to identify this location

These parameters are used to create a partner location.

Before setting up a partner location, you must know the following information to
plan the implementation of this partner:
v The unique name that identifies this partner location
v At least one reference code to identify the location

Location Select Dialog Box
The Location Select dialog box allows you to add, edit, and delete partner-specific
name and address information. Locations are only used with translation objects
that are designed to incorporate that data.

The following illustrates the Location Select dialog box:

The following describes the parts of the Location Select dialog box.

Part Function

Locations Displays all defined locations.

New Opens the Location Entry dialog box, which allows you to create a
new location.

Edit Opens the Location Entry dialog box, which allows you to edit the
selected location.
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Location Entry Dialog Box
The Location Entry dialog box enables you to create and edit location information.

The following illustrates the Location Entry dialog box:

The following describes the parts of the Location Entry dialog box.

Part Function

Name Specify the name of this trading partner location. This name
should accurately describe the location because this box will be
displayed in the location selection list.
Note: This box is mandatory.

Reference Code1 Specify a reference code to identify the location being defined
(such as a DUNS number).
Note: This box is mandatory.

Reference Code2 Specify a reference code to identify the location being defined
(such as a DUNS number).

Contact Specify the name of a personal contact.

Address1, Address2,
Address3

Specify the partner’s business address.

City Specify the partner’s city.

State Specify the partner’s state.

Zip Code Specify the partner’s zip or postal code.

Country Specify the partner’s country.

Phone Specify the partner’s phone number.

Fax Specify the partner’s fax number.

Creating Partner Locations
About this task

To create partner locations, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.

72 IBM Sterling Gentran:Server for Microsoft Windows: User Guide



2. Select the partner profile or the system partner (Internal System User) for
which you want to create a location and click Locations.
The system displays the Location Select Dialog Box.

3. Click New.
The system displays the Location Entry Dialog Box.

4. In the Name box, type a unique identifier that defines this location within the
partner.

5. In the Reference Code 1 box, type the unique identifier for the location you are
defining.
Example - The DUNS number for the location.

6. Complete the remaining boxes, as necessary.

Note: If you use Reference Code 2, it must be unique.
7. Click Save.

The system saves the location information and displays a blank Location Entry
dialog box.

8. If you want to enter additional locations for this partner, repeat steps 4 through
7 as many times as necessary.

9. Click Exit.
The system returns to the Partner Editor dialog box.

Editing Partner Locations
About this task

To edit a partner location, complete the following steps:

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile or the system partner (Internal System User) for

which you want to create a location and click Locations.
The system displays the Location Select Dialog Box.

3. From the Locations list, select a location and click Edit.
The system displays the Location Entry Dialog Box.

4. Make any necessary changes.

Note: The Reference Code1 box must be completed.
5. Click Save to save the location information and return to the Location Select

dialog box.
6. Click Exit.

The system returns to the Partner Editor dialog box.

Delete Partner Locations
About this task

To delete a partner location and all associated records, complete the following
steps.
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Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the partner profile or the system partner (Internal System User) for

which you want to create a location and click Locations.
The system displays the Location Select Dialog Box.

3. From the Locations list, select a location and click Delete.
The system displays the Delete Confirmation dialog box.

4. Click Yes to confirm the deletion.
5. Click Exit.

The system returns to the Partner Editor dialog box.
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Chapter 6. The Document Editor

About the Document Editor
The Document Editor is a data entry tool that allows you to create, modify, and
view documents.

Note: To use the Document Editor, you must register the appropriate screen entry
translation object with the system and set up a corresponding outbound
relationship for the partner.

EDI Documents

Sterling Gentran:Server tracks the relationship between an EDI document and the
corresponding application data. For import processing, the system makes a
persistent copy of the application data at the start of processing. For inbound
(export) processing, the system assigns a unique identifier to the document, which
is then permeated throughout the system for all database entries associated with
the received document.

Document Browsers

About Document Browsers
You can access document browsers in Sterling Gentran:Server through the Desk,
the Main Toolbar, and the View menu.

If you select the In Documents, ?In Documents, Out Documents, ?Out Documents,
In Drawer, or Out Drawer browser, the system displays the appropriate summary
dialog box for that browser.

The summary dialog box displays the number of each type of document for each
partner contained in the appropriate browser. This enables you to filter the display
of documents in the browser to only those of the document type and partner that
you want.

The following lists the columns displayed in all browsers:

Part Function

Partner Identifies the trading partner.

Type Identifies the specific type of EDI document.

For example: 810 identifies an invoice.

Name Displays the user-assigned name of the document.

Status The allowable status depends on the browser.

RefData Displays the reference data assigned by the translation object
designer to identify this document:

v Segment/element positional value (such as a PO Number for a
purchase order)

v Blank (no reference data is assigned)
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Part Function

Processed Time The date and time the document was processed by the system.
Format used is specified in your server system settings.

Note: In the browsers, you can click a column heading to sort the display by that
values in that column.

Setting Browser Preferences
By default, Sterling Gentran:Server maintains your current page sizes and positions
after you have changed them. You can reset your browser window sizes and
positions to the default.

About this task

To access Preference dialog box and result the default views, complete the
following steps:

Procedure
1. From the appropriate area of The Desk, select Options > Browser Views.

The system displays the dialog box.
2. To reset the default view, deselect the Save All Browser Positions and Sizes

check box.
3. Click OK.

The system displays the browser containing those documents.

In Documents Browser
The In Documents browser contains a list of documents that the system received
but that have not yet been processed by the user. After the documents are
processed (printed or exported) the documents are transferred to the In Drawer.

The following illustrates the In Documents browser:

The following describes the parts of the In Documents browser.

Part Function

Partner Name of the partner from whom the document was received.

Type Type of document that was received.
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Part Function

Name Name of the received document.

Status Status of the received document.

Processed Time The date and time the document was processed by the system.
Format used is specified in your server system settings.

View Accesses the View Choice Dialog Box, which allows you view the
selected document.

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Delete Deletes the selected document.
Note: If a document is waiting for acknowledgement processing
(acknowledgement generation or reconciliation), you may not
delete it until this processing is complete.

Export Accesses the Select Export Method Dialog Box, which allows you
to export the selected document

Move Moves the selected document to the In Drawer.

?In Documents Browser
The ?In Documents browser contains a list of documents that the system received
but failed compliance checking or do not have an identifiable partner or
transaction set.

The following illustrates the ?In Documents browser:

The following describes the parts of the ?In Documents browser.

Part Function

Partner Name of the partner from whom the document was received.

Type Type of document that was received.

Name Name of the received document.

Status Status of the received document.

Processed Time The date and time the document was processed by the system.
Format used is specified in your server system settings.

View Accesses the View Choice Dialog Box, which allows you view the
selected document.
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Part Function

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Delete Deletes the selected document.
Note: If a document is waiting for acknowledgement processing
(acknowledgement generation or reconciliation), you may not
delete it until this processing is complete.

Export Accesses the Select Export Method Dialog Box, which allows you
to export the selected document

Move Moves the selected document to the In Drawer.

In Drawer Browser
The In Drawer browser contains a list of documents that the system received and
processed.

The following illustrates the In Drawer browser:

The following describes the parts of the In Drawer browser.

Part Function

Partner Name of the partner from whom the document was received.

Type Type of document that was received.

Name Name of the received document.

Status Status of the received document.

Processed Time The date and time the document was processed by the system.
Format used is specified in your server system settings.

View Accesses the View Choice Dialog Box, which allows you view the
selected document.

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Delete Deletes the selected document.

Export Accesses the Select Export Method Dialog Box, which allows you
to export the selected document.
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Part Function

Respond Creates a turnaround document in response to the selected
document or documents.
Note: The Respond function is only valid when one or more
documents are selected and Turn Around translation objects exist
for the selected documents.

Workspace Browser
The Workspace browser contains a list of documents that the system received but
that have not yet been processed by the user. After the documents are processed
(printed or exported) the documents are transferred to the In Drawer.

The following illustrates the Workspace browser:

The following describes the parts of the Workspace browser.

Part Function

Partner Name of the partner from whom the document was received.

Type Type of document that was received.

Name Name of the received document.

Status Status of the received document.

View Accesses the View Choice Dialog Box, which allows you view the
selected document.

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Delete Deletes the selected document.

Export Not a valid function for this browser.

Open Accesses the Document Editor facility, which allows you to edit the
selected document.

Post Moves the selected compliant document to the Out Documents
Browser.
Note: Post documents to the Out Documents before sending them.
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Part Function

New Accesses the Create New Document dialog box, which allows you
to select a partner/transaction set combination for which you want
to enter a new document using the Document Editor facility.
Note: The Document Editor uses the associated screen entry
translation object to allow information to be entered into the
system.

Import Accesses the Application Files to Import Dialog Box, which allows
you to import data from an external application file.
Note: Depending on the content of the file, the system may
prompt you for partner, transaction, or translation object
information. The Import function does not affect any selected
documents.

Out Documents Browser
The Out Documents browser contains a list of documents that are ready to be sent.
After the documents are successfully sent, they are automatically transferred to the
Out Drawer.

The following illustrates the Out Documents browser:

The following describes the parts of the Out Documents browser.

Part Function

Partner Name of the partner for whom the document is to be sent.

Type Type of document that is to be sent.

Name Name of the document.

Status Status of the document.

Processed Time The date and time the document was processed by the system.
Format used is specified in your server system settings.

View Accesses the View Choice Dialog Box, which allows you view the
selected document.

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Delete Deletes the selected document.

Export Not a valid function from this browser.
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Part Function

Send Accesses the Send/Receive dialog box, which enables you to
manually start a communications session to send data.
Notes:

v Only selected documents will be enveloped and sent. If no
documents are selected then all documents will be sent.
Successfully sent documents will be moved to the Out Drawer.

v Initiating a Send session also prompts the system to receive any
documents that are waiting to be received.

v The Send function is only valid if Out Documents is the
currently selected browser and documents are present or if
interchanges in the Interchanges browser have a Ready status.

UnPost Moves the selected document back to the Workspace browser.

?Out Documents Browser
The ?Out Documents browser contains a list of documents that were imported into
the system but are invalid.

The following illustrates the ?Out Documents browser:

The following describes the parts of the ?Out Documents browser.

Part Function

Partner Name of the partner associated with the document.

Type Type of document.

Name Name of the document.

Status Status of the document.

Processed Time The date and time the document was processed by the system.
Format used is specified in your server system settings.

View Accesses the View Choice Dialog Box, which allows you view the
selected document.

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Delete Deletes the selected document.

Export Not a valid function from this browser.

Move Moves the selected document to the In Drawer.
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Out Drawer Browser
The Out Drawer browser contains a list of documents that the system successfully
sent.

The following illustrates the Out Drawer browser:

The following describes the parts of the Out Drawer browser.

Part Function

Partner Name of the partner for whom the document is to be sent.

Type Type of document that is to be sent.

Name Name of the sent document.

Status Status of the sent document.

Processed Time The date and time the document was processed by the system.
Format used is specified in your server system settings.

View Accesses the View Choice Dialog Box, which allows you view the
selected document.

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Delete Deletes the selected document.

Export Not a valid function from this browser.

Copy Copies the selected documents to the Workspace.
Note: This function enables you to reprocess and resend
documents that were already sent by the system.

Ack Changes the status of the selected documents to Acknowledged.

Processing Browser
The Processing browser contains a list of documents that the system is currently
processing.

Note: The Processing browser displays the current status of the processing
document. If the document is processing, the status code is set to 1. If the
document or acknowledgement is deferred, the status code is set to 2.

The following illustrates the Processing browser:
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The following describes the parts of the Processing browser.

Part Function

Partner Name of the partner associated with the document.

Type Type of document being processed.

Name Name of the document.

Status Status of the document.

Reset Returns to their previous location any documents that are
displayed on this dialog box but for which processing has
terminated.
Note: This function is typically used for exception cases when the
processing of a document terminated improperly.

Related Dialog Boxes

View Choice Dialog Box
The View Choice dialog box enables you to specify how you want to view the
selected document.

The following illustrates the View Choice dialog box:

The following describes the parts of the View Choice dialog box. You can select
only one of these options.
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Part Function

Gentran Data Displays the raw EDI data.

External Data Displays the data file used in translation.
Note: This option is not available if the external data file used in
translation does not exist.

Formatted Document Displays the data in the Document Editor using a screen entry
translation object.
Note: This option is not available if no screen entry translation
object exists for the document.

Translator Report Displays a report of the actions the translator took on this
document and lists any EDI- or translation object-based compliance
errors.

Data Audit Displays the document tracking information that is available for a
single document.
Note: This function is not available if document level auditing is
disabled.

Tracking Information Displays information that tracks an external data file.

Translator Report - Document
If you select Translator Report from the View Choice dialog box, a report of all the
actions the translator took on this document will be displayed.

The following describes the parts of the Translator Report:

Part Description

Trading Partner Displays the name of your partner.

Direction Indicates whether this document is inbound or outbound.

Interchange Control Displays either the interchange control number or "Not
Interchanged" if there is no interchange.

Group Control Displays either the group control number or "Not Grouped" if there
is no functional group.

Document Control Displays the document control number.

Mode Indicates whether the system is in Test or Production mode.

Document Name Displays the name of the document.

Document Reference Displays the document reference data.

Standard Displays the EDI standard that is used in this trading relationship.

Version Displays the version of the EDI standard that is used in this trading
relationship.

Transaction Set Displays the transaction set (document) that is used in this trading
relationship.

Segment/Record ID Displays the either the segment ID (for EDI files) or the record ID
(for positional flat files).

Sequence Displays the number of the sequential position of the segment or
record (that is in error) in the file.

Element Displays the sequential position of the element (EDI files) or box
(positional flat files) that is in error, within the segment.

Composite Displays the sequential position of the component element that is in
error, within the composite element.
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Part Description

Data Displays pertinent information about certain errors.

Message Number Contains a prefix, a dash ("-"), and a four digit number that
identifies the error. The following are the prefixes:

v INF - Used only with information messages. Informational
message are not defined here, because they are intended to be
self-explanatory.

v EDI - Used with all the messages listed below (all messages that
are not informational). It is used if the error is related to an EDI
file.

v POS - Used with all the messages listed below (all messages that
are not informational). It is used if the error is related to a
positional flat file.

Message Displays the error message.

Print Choice Dialog Box
The Print Choice dialog box enables you to specify whether you want to print the
selected item (document or translation object) or a summary list of all items in the
browser.

The following illustrates the Print Choice dialog box:

The following describes the parts of the Print Choice dialog box.

Part Function

Selected Items Tells the system to perform the selected items or items (the
following two fields).

Formatted Tells the system to print the items as formatted (using the
appropriate translation object).
Note: This option is unavailable when printing a translation object
(always formatted) or when a print translation object does not exist
for the item.

Move documents to
In Drawer

Tells the system to move the document to the In Drawer.
Note: This option is only available for the In Documents and ?In
Documents browsers.

Summary List of
Items

Tells the system to print a summary list of the items selected in the
browser.

Select Export Method Dialog Box
The Select Export Method dialog box enables you to write documents to an
external file for processing by another application.

Notes:
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v There must be a system export translation object for the document or a
partner-specific export translation object for the document.

v The Export function is only valid when one or more documents are selected
from one of the following browsers: In Documents, In Drawer, or ?In
Documents.

The following illustrates the Select Export Method dialog box:

The following describes the parts of the Select Export Method dialog box. You can
select only one of these options.

Part Function

Export to Single File Converts all selected documents to data and accesses the Choose
File to Export Document Dialog Box to write them to a single file.

Export to Default
Files

Writes selected documents to the files set up in the partner
inbound relationship.

Select File by
Document

Accesses the Choose File to Export Document Dialog Box, which
enables you to rename selected documents to be exported.

Document Search Dialog Box
The Document Search dialog box enables you to specify criteria for which Sterling
Gentran:Server performs a system-wide search. This enables you to quickly access
a subset of documents without searching each browser manually.

The following illustrates the Document Search dialog box:
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The following describes the document search criteria.

Function Description

Document Name Searches for documents with the specified user-assigned document
name.

RefData Searches for documents with the specified reference data (assigned
by the translation object designer).

Partner Searches for documents with the selected partner ID (identifies the
partner for/from whom the document was generated or received).

Document Type Searches for documents of the specified EDI type.

For example: 810 identifies an invoice.

Application Field 1 Searches for documents with the specified value in Application
Field 1.

Application Field 2 Searches for documents with the specified value in Application
Field 2.

Application Field 3 Searches for documents with the specified value in Application
Field 3.

Application Field 4 Searches for documents with the specified value in Application
Field 4.

Application Field 5 Searches for documents with the specified value in Application
Field 5.

Application Field 6 Searches for documents with the specified value in Application
Field 6.

Search Results Dialog Box
After you enter criteria and click Search, the system displays the Search Results
dialog box as shown below:

The following describes the search results functions.

Function Description

Document Data Displays data for a document. To display data for the document,
select the document from the list and click Document Data
Note: You can also use this function by right-clicking the
document and selecting Document Data.
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Function Description

Interchange Data Opens the Interchange Browser and displays interchange data for
the document. To display for interchange data for the document,
select the document from the list and either click Interchange Data.
Note: You can also use this function by right-clicking the
document and selecting Interchange Data.

Minimize results on
view

Minimizes the Search Results dialog box when viewing data,
tracking information, or an interchange. To minimize results, select
the check box.

Double-click Displays the tracking information for the document. To display
information, select an item and then double-click.

Filter Dialog Box
The Filter function can be used when the Out Drawer is active to filter the display
of documents by status.

If you want to filter the display of documents in the Out Drawer by the document
status you can choose not to display documents with a certain status by selecting
the check box next to each status that you do not want displayed.

Note: When you clear a check box, the display of that status is turned “off.” The
default is to display documents regardless of status.

The following illustrates the Filter dialog box:

The following describes the filter criteria.

Part Function

Sent Filters for documents that were successfully transmitted.

Received by Network Filters for documents that were successfully delivered to a Value
Added Network (VAN).

Warning from
Network

Filters for documents that were delivered to a VAN, which
detected non-critical errors in the data.
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Part Function

Error from Network Filters for documents that were delivered to a VAN, which
detected critical errors in the data.

Picked up by Trading
Partner

Filters for documents that were successfully delivered to a trading
partner through a VAN.

Acknowledged with
No Errors

Filters for documents that were acknowledged by your partner
with no errors.

Waiting for
Acknowledgement

Filters for documents that are waiting to be reconciled with an
inbound functional acknowledgement.

Acknowledgements
Overdue

Filters for documents that are waiting to be reconciled with an
inbound functional acknowledgement but have exceeded the
number of hours by which the acknowledgement is deemed late.

Acknowledgements
with Errors

Filters for documents that were acknowledged by your partner
with errors. These documents were accepted by your partner in
spite of the errors.

Partially
Acknowledged

Filters for documents that were partially acknowledged.
Note: If your partner is going to issue partial acknowledgements
at the interchange or group level, they should also indicate
acceptance or rejection at the transaction level.

Acknowledged but
Rejected

Filters for documents that were acknowledged by your partner
with errors. These documents were rejected by your partner.

Send Failed Filters for documents for which the send transmission failed.

Preferences Dialog Box
Click Preferences to access the Preferences dialog box.

The following describes the parts of the Preferences dialog box.

Part Description

Refresh Allows you to automatically refresh document browsers at the
specified interval.

Directories Allows you to set default folders for imports, exports, and partners.

Change Password Allows you to change your password.

Send Options Allows you specify to automatically check for interchanges that are
stuck in the Send Queue.

Interchange Filter Displays the “Interchange Filter Dialog Box” on page 120.

External Data Filter Displays the “External Data Filter Dialog Box” on page 114.

Browser Views Allows you set the following Interchange Browser and Restored
Interchange Browser settings:

v Turn on External Data View

v Turn on Gentran Data View

v Turn on Translator Report View

Document Viewer Select an external editor so you can view, edit, and save your
documents outside of the EDI Manager.
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Chapter 7. Managing Documents

Creating Documents
To create a document using the Document Editor, the system must be set up to
support screen entry for the partner/transaction set combination you want to enter.

About this task

Note: The appropriate Screen Entry translation object must be registered and a
corresponding Outbound relationship must be set up for the partner.

To create a document, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Workspace.

The system displays the Workspace Browser.
2. Click New.

The system displays the Create New Document dialog box.
3. Select the appropriate partner/transaction set combination from the list and

click OK.
The system displays the translation object for the selected combination.

4. Type all the required data items into the boxes on the document translation
object.

Note: If the document contains a looping structure (lower-level detail records
such as line items), the input translation object contains a list.

5. To access items in a list, highlight the first entry and click New.
The system displays the list box.

6. Enter the data for the item.

Notes:

v To enter a second or subsequent item, click Next or press ALT + T.
v After all loop items are entered, click Store to save and exit the loop dialog

box.
v If the document contains codes, press SHIFT + F1 from each code field to

access a list of the codes.
7. If the document contains calculated fields, select File > Recalculate before

saving the document.
The system updates the totals and checks the document for errors.

8. When you are finished entering data, save the file.
The system saves the information and automatically recalculates and check for
errors. If errors are found, you are prompted to view the errors.

9. Select File > Exit.
The system prompts you to save the document before closing.

Note: You can now open and edit this document from the Workspace Browser.
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Editing Documents
To edit a document using the Document Editor, you need to set up the system to
support screen entry for the partner/transaction set combination you want to edit.

About this task

Note: The appropriate Screen Entry translation object must be loaded and a
corresponding outbound relationship must be set up for the partner.

To edit a document, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Workspace.

The system displays the Workspace Browser.
2. Select the desired document from the Workspace.

Notes:

v Only documents in the Workspace can be edited.
v If the document has already been moved to the Out Documents and has not

been sent, you can move it back to the Workspace using the UnPost function
(see UnPosting Documents).

v If a document has been sent, it cannot be modified. However, you can move
a copy of the document from the Out Drawer to the Workspace, modify the
copy, and send it (see Copying a Document (to Reprocess and Resend)).

3. Click Open.
The system displays the document in the Document Editor facility.

4. Modify the data as required.

Note: If the document contains a looping structure (lower-level detail records
such as line items), the input translation object contains a list.

5. To add a new line item, highlight the first entry and click New. To access items
in the list, highlight the entry to be changed and click Open (or double-click the
item).
The system displays the list item details.

6. You can now change or enter the data for the item.

Notes:

v To move through the entries, use Next and Prev.
v To enter a second or subsequent item, click Next or press ALT + T.
v After all loop items are entered, click Store to save and exit the loop dialog

box.
v If the document contains codes, press SHIFT + F1 from each code field to

access a list of the codes.
7. If the document contains calculated fields, select File > Recalculate before

saving the document.
The system updates the totals and checks the document for errors.

8. When you are finished entering data, save the file.
The system saves the information and automatically recalculates and checks for
errors. If errors are found, you are prompted to view the errors.

9. Select File > Exit.
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The system prompts you to save the document before closing.

About Viewing Documents
The View function enables you to view various types of information, depending on
the format selected in the View Choice Dialog Box.

The view types include:
v Raw input data
v External data
v EDI-formatted data
v Translator report
v Data audit
v Tracking information

Notes:

v The formatted view option is only active if a Screen Entry translation object is
available in the Partner Relationship record.

v The external data option is only active if the data file used in translation is
available.

v When viewing raw input or external data, you can switch from Text to Hex
format by selecting the appropriate command from the View menu.

The View function can be accessed using either of the following methods:
v A document browser is active and a single document is selected.
v The Interchanges or Restored Interchanges browser is active and a single

document within an interchange is selected.

Viewing a Document from the Document Browsers
About this task

To view a document from a document browser, complete the following steps:

Procedure
1. From the appropriate area of The Desk, select one of the document browsers.

The system displays the appropriate summary dialog box for that browser.
2. Select the type of document for the appropriate partner and click View.

The system displays the browser containing those documents.
3. Select a single document from the appropriate browser.
4. Click View.

The system displays the View Choice Dialog Box.
5. Select an option to display the input data:

v To display raw EDI data, select Gentran Data.
v To display the data file used in translation, select External Data.

Note: This option is not available if the external data file used in translation
does not exist.

v To display the data in the Document Editor using a screen entry translation
object, select Formatted Document.
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Note: This option is not available if no screen entry translation object exists
for the document.

v To display a report of the actions the translator took on this document and
list any EDI- or translation object-based compliance errors, select Translator
Report.

v To display the document tracking information available for a single
document, select Data Audit.

Note: This function is not available if document level auditing is disabled.
v To display information that tracks an external data file, select Track

Information.
6. Click OK to access the view that you specified.

Viewing a Document from the Interchanges Browser
About this task

To view a document from the Interchanges or Restored Interchanges browser,
complete the following steps:

Procedure
1. From the appropriate area of The Desk, select the Interchanges browser.
2. Select a single document.
3. Click the Data icon on the Toolbar.

The system displays the raw EDI data view of the Interchange (displayed in the
Data View window on the Interchanges or Restored Interchanges browser).

Note: When viewing raw input or external data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.

Viewing Currently Processing Documents
The Processing Browser displays any document that is currently being processed in
the Sterling Gentran:Server system.

About this task

This browser enables you to ascertain which documents are currently being
processed by you or other users in the Sterling Gentran:Server system.

Note: Any document that is currently being processed in the Sterling
Gentran:Server system is displayed in the appropriate browser as unavailable, and
you are not permitted to access that document until processing is complete and the
document has been released to the system.

The Processing Browser enables you to use the Reset function to return to their
previous location any documents that are displayed in the browser but for which
processing has terminated. Typically, you use this function for exception cases
when the processing of a document terminated improperly.

Procedure

To view the documents that are currently being processed, complete the following
steps:
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Procedure
1. Select View > Processing.

The system displays the Processing Browser.
2. You can view the currently processing documents or perform the function

listed in this table.

Note: You can use the Reset function to return to their previous location
documents that are displayed in the Processing browser but for which
processing has terminated. This is typically done when the processing of a
document terminated improperly.

Finding Specific Text in a Document
This function enables you to find specified text in the active data-view window.

About this task

The Find function is available when a data-view is the active window. The
following are the data-view windows.
v Audit Log
v Document Tracking
v Interchange Tracking
v Raw Data-View of an Interchange
v Raw Data-View of a Document
v External Data-View of an Interchange
v External Data-View of a Document

To find specific text, complete the following steps.

Procedure
1. Access one of the following data-view windows.

Note: When viewing raw input or external data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.

To display this window Do the following:

Audit Log Select View > Audit Log.

Document Tracking 1. Select a document in a browser.

2. Select Commands > View.

3. Click the Tracking information option.

4. Click OK.

Interchange Tracking 1. Select an interchange in the Interchanges browser.

2. Select Commands > View.

3. Click the Tracking information option.

4. Click OK.

Raw Data View of an
Interchange

1. Select Interchanges from the appropriate area of The
Desk.

2. Select an interchange from the Interchanges browser.

3. Select View > Interchanges > Data.
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To display this window Do the following:

Raw Data View of a
Document

1. Select a document in the Interchanges browser.

2. Select Commands > View.

3. Click OK.

External Data View of an
Interchange

1. Select Interchanges from the appropriate area of The
Desk.

2. Select an interchange from the Interchanges browser.

3. Select View > Interchanges > External Data.

External Data View of a
Document

1. Select a document in the Interchanges browser.

2. Select Commands > View.

3. Click External Data and click OK on the View Choice
dialog box.

2. Select Edit > Find.
The system displays the Find dialog box.

3. Type the text you want to locate.
4. To search for case-sensitive text, select Match Case.
5. Click Find Next to find the first occurrence of the specified text.

Notes:

v If the system locates that text, it is highlighted in the data-view window.
v If the system does not find the specified text, the system beeps. If this is the

case, skip to step 7.
6. Continue clicking Find Next to find each subsequent occurrence of that text.
7. Click Cancel.

The system returns to the data-view window.

Searching for Documents
The Document Search facility enables you to quickly and easily locate specific
documents in the system. This facility returns the available tracking information
for each matching document.

About this task

To search for documents, complete the following steps.

Procedure
1. From the Commands menu, select Document Search.

The system displays the Document Search Dialog Box.
2. Enter the appropriate criteria.
3. Click Search.

The system displays the tracking data for each document it locates that matches
the criteria you specified.

4. Double-click a document to display the associated tracking information.

96 IBM Sterling Gentran:Server for Microsoft Windows: User Guide



Filtering Out Drawer Documents by Status
When the Out Drawer Browser is active, you can use the Filter function to filter
the display of documents by status.

About this task

To filter the document display in the Out Drawer browser, complete the following
steps.

Procedure
1. From the appropriate area of The Desk, select the Out Drawer.

The system displays the Out Drawer Summary dialog box.
2. Select the type of document for the appropriate partner and click View.

The system displays the Out Drawer Browser.
3. Click Filter.

The system displays the Filter Dialog Box.
4. If you want to filter the display of documents in the Out Drawer by the

document status, you can choose not to display documents with a certain
status by selecting the check box next to each status that you do not want
displayed.

Note: When you clear a check box, the display of that status is turned off. The
default is to display documents regardless of status.

5. Click OK.
The contents of the Out Drawer browser are filtered as specified.

Deleting Documents
The Delete function is used to remove a document or group of documents from the
system.

About this task

Notes:

v When a document is deleted, all the associated document information, tracking
information, and translation report information is also deleted. When the last
document in an interchange is deleted, the interchange entry is also deleted.

v Documents in the Send Queue can only be deleted from the Interchanges
Browser.

To delete a document or group of documents, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the location of the document.

If you select one of the document browsers, the system displays the appropriate
summary dialog box for that browser.

2. If the system displays a summary dialog box, select the type of document for
the appropriate partner and click View.

3. Click Delete.
The system displays a confirmation dialog box.

4. Click Yes.
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The document is deleted.

Printing Documents
If no documents are selected, the Print function prints a summary list of all
documents in the browser.

About this task

For selected documents, the Print function prints one of the following:
v Raw EDI data
v Formatted version of the documents using the print translation object

established (partner relationship)
v Summary list of those documents

To print a document or group of documents, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the location of the document.

If you select one of the document browsers, the system displays the appropriate
summary dialog box for that browser.

2. Select the type of document for the appropriate partner and click View.
The system displays the browser containing those documents.

3. To print a summary list of all documents, click Print and continue with step 6.
Otherwise, continue with step 4.

4. To print selected documents (formatted or not) or a summary list of selected
documents, select a document or group of documents and click Print.
Otherwise, continue with step 6.
The system displays the Print Choice Dialog Box.

5. On the Print Choice Dialog Box, select one of the following options and click
OK:
v To print selected unformatted documents, click Selected Items.
v To print the selected documents as formatted (a print translation object must

exist for the documents to be printed as formatted), click Selected Items and
select Formatted.

v To print from the In Documents Browser or ?In Documents Browser, either
move the document to the In Drawer Browser or leave the document in
place.

v To print a summary list of selected documents, select Summary List of
Items.

The system displays the Print dialog box.
6. Set the appropriate options and click OK.

Note: The system displays the Print dialog box if you either selected no
documents from the browser and clicked Print, or if you chose Summary List
of Items from the Print Choice dialog box.
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Moving Documents to the In Drawer
This function moves a selected document or group of documents to the In Drawer
browser. Documents are automatically moved from the In Documents browser or
?In Documents browser to the In Drawer browser by the system at the completion
of a successful export or print. However, you might want to manually move a
document to the In Drawer browser so you can create a turnaround (response)
document.

About this task

To move a document or group of documents, complete the following steps:

Procedure
1. From the appropriate area of The Desk, select the In Documents browser or ?In

Documents browser.
The system displays the appropriate summary dialog box for that browser.

2. Select the type of document for the appropriate partner and click View.
The system displays the browser containing those documents.

3. Select the documents that you want to move to the In Drawer Browser and
click Move.
The selected documents are moved to the In Drawer Browser.

Copying a Document (to Reprocess and Resend)
The Copy function copies a document (that was already sent successfully) to the
Workspace Browser so you can modify the document and resend it.

About this task

Notes:

v The Copy function can only be used when Out Drawer is active.
v This function can result in sending duplicate documents to a trading partner.
v After you modify the documents, you may want to resend them. See Resending

Documents for more information.

To copy a document or group of documents, complete the following steps:

Procedure
1. From the appropriate area of The Desk, select Out Drawer.

The system displays the Out Drawer Summary dialog box.
2. Select the type of document for the appropriate partner and click View.

The system displays the Out Drawer Browser.
3. Select the documents that you want to copy to the Workspace Browser and

click Copy.
The selected documents are copied to the Workspace Browser.

Posting Documents
The Post function moves a selected compliant document or group of compliant
documents to the Out Documents browser.
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About this task

A document is compliant if it conforms to the validation rules as defined by the
translation object. A document is designated compliant if the Status column
contains OK. If the Status column contains NotOk, the document is not compliant
and is not posted.

Note: The Post function can only be used when the Workspace is active.

To post a document or group of documents, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the Workspace.

The system displays the Workspace Browser.
2. Select the compliant documents that you want to move to the Out Documents

Browser.

Note: A document is designated compliant if the Status column contains OK. If
the Status column contains NotOk, the document is not compliant and is not
posted.

3. Click Post.
The selected documents are moved to the Out Documents Browsers.

UnPosting Documents
The UnPost function moves a selected document or group of documents to the
Workspace browser.

About this task

You can use UnPost to prevent a document from being sent to a trading partner or
to allow the document to be modified before it is sent. The UnPost function can
only be used when the Out Documents Browser is the active browser.

To UnPost a document or group of documents, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the Out Documents.

The system displays the Out Documents Summary dialog box.
2. Select the type of document for the appropriate partner and click View.

The system displays the Out Documents Browser.
3. Select the documents that you want to move back to the Workspace Browser

and click UnPost.
The selected documents are moved back to the Workspace Browser.

Responding to Documents
The Respond function automatically generates a response document by
transferring data from an inbound source document.
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About this task

The Respond function is only available when all of the following are true:
v The In Drawer is the currently selected browser.
v One or more documents are selected.
v Turn Around translation objects exist for the selected documents.

The Respond function creates a turnaround document (using the Turn Around
translation object from the Partner relationship) in response to the currently
selected documents. You can create a turnaround document for non-compliant
documents (documents with a NotOK status), as well as for compliant documents.

The documents generated by the turnaround process are placed in the Workspace,
where you can modify them prior to sending.

Note: To modify a document, a Screen Entry translation object must be set up in
the outbound relationship for the created document.

To respond to one or more documents, complete the following steps:

Procedure
1. From the appropriate area of The Desk, select In Drawer.

The system displays the In Drawer Summary dialog box.
2. Select the type of document for the appropriate partner and click View.

The system displays the In Drawer Browser.
3. Select the document or documents for which you want to create a turnaround

(response) document and click Respond.
v The system automatically creates a turnaround document in response to each

document you selected by using the Turn Around translation object that you
specified in the Partner relationship.

v The turnaround documents that are produced are displayed in the
Workspace for you to modify, if necessary, before posting to the Out
Documents Browser.

Importing Documents
Sterling Gentran:Server allows you to import data from data files as an alternative
to using the Document Editor to enter data directly into the system.

About this task

To import a document, you must have a system import and/or import translation
object for the transaction set that is imported, registered with the system.

For each type of import file, you need to define an import specification on the
Import tab in the System Configuration program that indicates which import or
system import translation object is used to begin translation during the import
process.

You need to see your system administrator about adding the UNC file path or file
name to the System Configuration program if either of the following are true
(because the system may be unable to import the file):
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v You select a file from a UNC file path and a local drive is specified for imports
of that file type in the System Configuration program.

v You select a file from a local drive and a UNC filename is specified for imports
of that type in the System Configuration program.

To import a document, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the Workspace.

The system displays the Workspace Browser.
2. Click Import.

The system displays the Application Files to Import dialog box.
3. Select the file or files to be imported and click Open.

Note: You may not send non-compliant documents—either delete those
documents and reprocess them from the data file, or correct the documents in
the Document Editor (if you have Screen Entry translation objects for them).

Important: If you import a file and no documents are displayed in the
Workspace Browser, check the Audit Log.
The system imports the documents into the Workspace Browser. The
documents either have an OK status (the documents were successfully read and
compliance checked) or a NotOK status (the documents failed compliance
checking).

Exporting Documents
To export a document to a data file, an export translation object for the transaction
set must be loaded into the system, registered, and set up as the export translation
object in the inbound relationship record for the partner.

About this task

Notes:

v After performing an export command, any subsequent exports to the same
export file increases the size of the file by appending the new external data to
this file.

v If you set up the Export to Mailbox command on the Inbound Translation
Objects dialog box, the document is exported to the mailbox you specify.

To export a document, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the In Documents Browser, ?In

Documents Browser, or In Drawer Browser.
The system displays the appropriate summary dialog box for the selected
browser.

2. Select the type of document for the appropriate partner and click View.
The system displays the appropriate document browser.

3. Select the document or documents that are to be exported, and click Export.
The system displays the Select Export Method Dialog Box.

4. Select one of the following options and click OK:
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v To convert all selected documents to data and write them to a single file,
select the Export to Single File option.

v To write selected documents to the files set up in the partner inbound
relationship, select the Export to Default Files option.

v To rename selected documents, select the Select File by Document option.
The system displays the Choose File to Export Document Dialog Box.
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Chapter 8. Communications

About Communications
The Communications feature enables you to send and receive data from your
trading partners.

The following describes the system process that occurs when you send an
interchange:

Stage Description

1 The documents in the selected interchange are batched into EDI envelopes
and the required information (including control numbers) is generated
from the information in the partner profile.

2 After the interchange is built, it is listed in the Interchange browser.

3 Communication is established with the remote end. The status of the
message is updated based on the success or failure of the communications
session.

v If the communication fails because there is no mailbox set up or the
Mailbox service is not started, the interchange and documents are left in
a Ready to send status.

v If communication fails because there is no modem, the interchange and
documents are left in a Queued status.

Note: No user action is required at this point. Interchanges that failed to
send are automatically sent as part of the next transmission session.

4 After a successful communications session, the documents are moved to
the Out Drawer and the interchange status is set to Sent.

Send Queue Browser
The Send Queue browser contains a list of documents that are currently queued
for the system to send.

Note: To delete a document that is in the Send Queue, you must open the
Interchanges Browser and delete the document from there.

The following illustrates the Send Queue browser:
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The following describes the parts of the Send Queue browser.

Part Function

Partner Name of the partner to whom the document is being sent.

Type Type of document being sent.

Name Document name.

Status Status of the document.

RefData

View Accesses the View Choice Dialog Box, which allows you view the
selected document.

Print Accesses the Print Choice Dialog Box, which allows you to print
the selected document.

Communication Session Dialog Box
The Communications Session dialog box enables you to select mailboxes and
initiate a communications session to send and receive data.

The following illustrates the Communications Session dialog box:

The following describes the parts of the Communications Session dialog box.

Part Function

Select the mailbox
you wish to
communicate with

Displays the list of Sterling Gentran:Server mailboxes.
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Sending Documents
To send a selected document or set of documents, complete the following steps:

Procedure
1. From the appropriate area of The Desk, select Out Documents.

The system displays the Out Documents Summary dialog box.

Note: If the documents to be sent are not in the Out Documents Browser, you
must post the documents from the Workspace Browser to the Out Documents
Browser.

2. Select the type of document for the appropriate partner and click View.
The system displays the Out Documents Browser.

3. Select the document or documents that need to be sent.
4. Click Send.
5. Click Yes to start the transmission session.

Sending All Documents

Sending All Documents Method 1
This action sends all documents currently located in the Out Documents for which
the partner is using one of the selected mailboxes.

About this task

To send all documents, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Transmit.
2. Click Yes to start the transmission session.

The system displays the Communications Session Dialog Box.
3. Select one or more mailboxes for which you want to send data.
4. Click OK to start a communication session to send data (click Cancel if you

want to cancel the transmission session).
If there are no documents in the Out Documents or interchanges with a Ready
status in the Interchanges browser, a receive-only session is performed and, as a
result, the In Documents and ?In Documents are updated with any data
received.

Sending All Documents Method 2
All documents in the Out Documents are sent to the appropriate mailboxes.

About this task

To send all documents, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Out Documents.

The system displays the Out Documents Summary dialog box.
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Note: If the documents to be sent are not in the Out Documents, you must
post the documents from the Workspace to the Out Documents.

2. Select the type of document for the appropriate partner and click View.
The system displays the Out Documents Browser.

3. Do not select any documents. If any documents are selected, press Ctrl and
click on the documents to deselect them.

4. Click Send.
5. Click Yes to start the transmission session.

Resending Documents
After a document is successfully enveloped and sent, it is stored in the Out
Drawer. If you need to resend the document, you must make a copy of the
document and execute the Send process again on the copied version.

About this task

To resend a document, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Out Drawer.

The system displays the Out Drawer Summary dialog box.
2. Select the type of document for the appropriate partner and click View.

The system displays the Out Drawer Browser.
3. Select the document or documents that need to be resent.
4. Click Copy to make a copy of the document and place the copy in the

Workspace.
5. From the appropriate area of The Desk, select Workspace.

The system displays the Workspace Browser.
6. Make any necessary changes to the documents.

Note: You can modify a document only if there is a Screen Entry translation
object for the partner relationship.

7. Select the documents and click Post.
The documents are posted to the Out Documents Browser.

8. From the appropriate area of The Desk, select Out Documents.
The system displays the Out Documents Summary dialog box.

9. Select the type of document for the appropriate partner and click View.
The system displays the Out Documents Browser.

10. Select the documents and click Send.
11. Click Yes to start the transmission session.

Receiving Documents

Receiving Documents Method 1
Any time a Send session is executed, the system automatically checks your
Mailbox for any information waiting to be received by your system. If any data is
in the Mailbox, it is received without any action from you.
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About this task

To start a receive-only session, complete the following steps.

Procedure
1. Select Commands > Receive.

The system displays the Communications Session Dialog Box.
2. Click OK to start a communication session to send data.

Note: The system initiates a receive-only session and the In Documents
Browser and ?In Documents Browser are updated with any data received.

Receiving Documents Method 2
This action initiates a communications session and updates the In Documents
browser and ?In Documents browser with any data received as a result of that
session.

About this task

To start a receive-only session, complete the following steps.

Procedure
1. Select View > In Documents.

The system displays the In Documents Summary dialog box.
2. Select the type of document for the appropriate partner and click View.

The system displays the In Documents Browser.
3. Click Receive.

The system displays the Communications Session Dialog Box.
4. Select one or more mailboxes for which you want to send data.
5. Click OK to start a communication session to send data.

Viewing the Send Queue
The Send Queue browser displays a list of the documents that are currently
queued to be sent and enables you to perform document-based tasks similar to
those available in the main system browsers.

About this task

Note: The Send Queue contains documents only if a transmission session failed.
The documents remain in the Send Queue until a successful transmission session
occurs; no user intervention is required.

To view the Send Queue, complete the following steps.

Procedure
1. Select View > Send Queue.

The system displays the Send Queue Browser.
2. Select a document or documents.
3. Click View to view the contents of any of the following:

v Selected document (raw EDI data)
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v Formatted document
v Translation report

4. Click Print to print the selected documents or summary of the documents.

Processing Data Files
The Process File feature invokes the post-communications process with any data
file as if the file was received during a communications session. This enables you
to process a data file from anywhere on your system.

About this task

To send a data file to the Communicator, complete the following steps.

Procedure
1. Select Commands > Process File.

The system displays the Process File Dialog Box.
2. Navigate to and select the desired data file and click Open.
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Chapter 9. External Data

About External Data
Sterling Gentran:Server can track the relationship between an EDI document or
interchange and the corresponding external (application) data.

For import processing, the system makes a persistent copy of the external data at
the start of processing. For inbound (process file and export) processing, the
system again copies the external data file for persistent storage. Sterling
Gentran:Server also enables you to archive external data.

You can specify which external data (process file, import, and export) is copied to
the External Data folder in the System Configuration subsystem.

Note: If you do not specify that the system should copy external data for at least
one of the export, import, or process file functions, the option to view external data
is not available.

External Data Viewer

The External Data viewer enables you to do the following:
v View a list of all external data files associated with documents or interchanges

that were sent or received.
v Filter the display of external data.
v View external data, correlated EDI data, and the related translator report (if they

are available).

Note: When viewing EDI or external data, you can switch from Text to Hex
format by selecting the appropriate command from the View menu.

External Data Summary Viewer
The External Data Summary Viewer enables you to view a list of all external data
files associated with documents or interchanges that were sent or received. The
External Data Summary Viewer can always be accessed.

The information displayed in the External Data Summary Viewer is organized in a
hierarchical manner, as shown below:

Level How to access Information displayed

External data file
(numbered)

Open External Data
Summary Viewer.

v File path and name

v Date and time the file was created
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Level How to access Information displayed

Document or
Interchange

Double-click an
external data file.

v Document or interchange control number

v Associated partner

v Document type

v Acknowledgement status

v Document name

v Reference data

v Date and time the document was created

Note: If any of these components are
missing or not appropriate for a particular
group, they are not displayed.

You can perform the following functions on the External Data Summary Viewer:
v Filter the display of external data by date/time and action from the External

Data Filter dialog box.
v Display the external data, raw-EDI data, and translator report data for the

selected external data file in the appropriate browser panes.
v Print a selected item.
v Delete the external data file from the External Data folder.

The following illustrates the External Data Summary Viewer with external data,
EDI data, and translator report options turned on:

The following describes the parts of the External Data Summary Viewer.

Part Function

Status bar Displays the filer specifications from the External Data Filter
Dialog Box.

left pane - external
tree

Displays a list of all external data files and (if available) an
associated EDI document or interchange that was sent or received.

upper right pane -
External Data

Displays the data file used in translation (if this option is selected
from the View > External Data menu).

middle right pane -
Gentran® Data

Displays the associated document in EDI format (if this option is
selected from the View > External Data menu).
Note: This option is not available if the document used in
translation does not exist.
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Part Function

lower right pane -
Export Document
Summary Translator
Report

Displays a report of the external actions the translator took on this
document and lists any EDI- or translation object-based compliance
errors (if this option is selected from the View > External Data
menu).

Icons

The following lists the icons that the system uses on the External Data Summary
Viewer:

Icon Description

Indicates a process file or mailbox process file system activity.

Indicates a send system activity.

Indicates an import or mailbox import system activity.

Indicates an export system activity.

Indicates an interchange related to the external data file.

Indicates a document related to the external data file.
Note: If this icon is red, it indicates that the document contains errors.

Viewing External Data Files
About this task

To view external data files, complete the following steps.

Procedure
1. Select View > External Data > Browser.

The system displays the External Data Summary Viewer.
2. To filter the display of external data files by action or date, see Filtering

External Data Files.
3. Select an external data file.
4. To view the external data for a single selected file, select View > External Data

> Related External Data.

Note: When viewing raw-EDI or external data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.

5. To view the related EDI data, select View > External Data > Gentran Data.

Note: When viewing raw-EDI or external data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.

6. To view the translator report for actions taken on the external data file, select
View > External Data > Translator Report.

7. To delete the external data file from the External Data folder, select the
appropriate file in the left pane of the viewer. Select View > Delete.
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8. To print the external data file, EDI data, or translator report, select the
appropriate right pane of the viewer. Select File > Print.

External Data Filter Dialog Box
The External Data Filter dialog box allows you to filter the display of external data
files by date and system action (process file, mailbox process file, import, mailbox
import, send, and export).

When the External Data Browser is active, select Filter from the Commands menu.
Or, from the Options menu, select Preferences and click on the External Data Filter
tab.

The following illustrates the External Data Filter dialog box:

The following describes the parts of the External Data Filter dialog box.

Part Function

Date From Select the beginning date and time of a date/time range, from
which the system filters the display of external data files.
Note: The Date From box is only active if the No Date/Time
Checking check box is not selected.

Date To Select the end date and time of a date/time range, to which the
system filters the display of external data files.
Note: The Date To box is not active if either the No Date/Time
Checking check box is selected or the Always Current check box is
selected.

Always Current Indicate that the end date for the date range is always the current
system date and time.
Note: The Always Current check box is only active if the No
Date/Time Checking check box is not selected.

No Date/Time
Checking

Indicate if the system filters the display of external data files by
date and time (if selected).

Action Contains a list of all the actions the system can perform using
external data files. This list allows you to filter the display of
external data files by the actions you specify.
Note: The default display is all actions, but you can clear them.

Unselect All Actions Clears all the actions.
Note: This allows you to filter the display of external data files by
the actions you specify.
Important: At least one action must be selected.
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Filtering External Data Files
When the External Data Summary viewer is active, the Filter function enables you
to filter the display of external data files by date and action.

About this task

To sort external data files by date and/or action, complete the following steps.

Procedure
1. Select View > External Data > Browser.

The system displays the External Data Summary Viewer.
2. Select Commands > Filter.

The system displays the External Data Filter Dialog Box.
3. To filter the display of external data files by date and time, clear the No

Date/Time Checking check box. Otherwise, select No Date/Time Checking and
continue with step 6.

4. Use the Date From slide bar to select the beginning date of a date range, from
which the system filters the display of external data files.

5. If you want the end date for the date range to always be the current system
date and time, select Always Current. Otherwise, clear the Always Current
check box and move the Date to slide bar to the date and time you want to
use.

6. To filter the display of external data files by action, from the Action list, select
the actions that you want displayed.

Note: The default display is all actions, but you can click actions to clear them
and change the display. Alternately, you can click Unselect All Actions to clear
all actions, so you can then click the one or more actions to select them. At least
one action must be selected.

7. Click OK.
The system filters the display of the external data files using the criteria you
specified.
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Chapter 10. Interchanges

Interchanges Browser
The Interchanges browser enables you to view a list of all the interchanges, groups,
and documents that were sent or received. The Interchanges browser can always
be accessed. This browser contains status information about the interchanges (such
as whether or not a functional acknowledgement was received and the status of
that acknowledgement).

The Interchanges browser enables you to do any of the following:
v View a hierarchical list of all the interchanges, group, and documents that were

sent or received.
v View status information for the interchanges (such as whether or not a

functional acknowledgement was received and the status of that
acknowledgement).

v Filter the display of interchanges.
v Access the documents within the interchanges.
v View external data, EDI data, and the related translator report (if they are

available).

Note: When viewing EDI data, you can switch from Text to Hex format by
selecting the appropriate command from the View menu.

The information about the Interchanges browser is organized in a hierarchical
manner. The following table describes the hierarchical organization of the
information about the Interchanges browser:

Level How to access Information displayed �(in middle pane)

Interchange Open Interchanges browser. v Direction of the interchange

v Date and time the interchange was
created

v Partner name

v Control number

v Interchange process status

v Network status

v Interchange acknowledgement status

v Message status

Note: If any of these components are
missing or not appropriate for a particular
interchange, they are not displayed.

Group Double-click an interchange. v Group control number

v Group type

v Group acknowledgement status

Note: If any of these components are
missing or not appropriate for a particular
group, they are not displayed.
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Level How to access Information displayed �(in middle pane)

Document Double-click a group. v Document compliant status

v Document control number

v Document type

v Document name

v Reference data

v Document compliant status

v Transaction acknowledgement status

Note: If any of these components are
missing or not appropriate for a particular
document, they are not displayed.

document data Double-click a document. Document data
Note: A screen entry translation object for
that document must available on your
system.

You can perform the following functions on the Interchanges browser:
v Filter the display of interchanges by date, partner, and direction (inbound and

outbound) from the Interchanges Filter dialog box.
v Display the external data, raw-EDI data, and translator report data for the

selected interchange or document in the appropriate browser panes.

Note: When viewing raw-EDI or external data, you can switch from Text to Hex
format by selecting the appropriate command from the View menu.

v Toggle the status of interchanges between Ready to Send and Hold.
v Manually change the status of groups to Acknowledged.
v Print or delete a selected item.

Note: You might want to use the toggle function if you do not want to send an
interchange right away.

The following illustrates the Interchanges browser with external data, EDI data,
and translator report options turned on:

The following describes the parts of the Interchanges browser.

Part Function

Status bar Reflects the filer specifications from the Interchange Filter Dialog
Box.
Note: The EDI Manager status bar is updated when you select a
single item from the middle pane.
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Part Function

left pane -
Interchanges tree

Displays a list of all the interchanges, groups, and documents that
were sent or received. Also displays the time created and partner
name.

middle pane -
detailed list

Displays a detailed list of the selected interchange, group, or
document. The information displayed depends on the level.

upper right pane -
External Data

Displays the data file used in translation (if this option is selected
from the View > Interchanges menu).
Notes:

v This option is only available if a single item is selected from the
detailed list.

v This option is not available if the external data file used in
translation does not exist.

v When viewing raw-EDI or external data, you can switch from
Text to Hex format by selecting the appropriate command from
the View menu.

middle right pane -
Gentran Data

Displays the data in EDI format (if this option is selected from the
View > Interchanges menu).
Notes:

v This option is only available if a single item is selected from the
detailed list.

v When viewing raw-EDI or external data, you can switch from
Text to Hex format by selecting the appropriate command from
the View menu.

lower right pane -
Translator Report

Displays a report of the actions the translator took on this
document and lists any EDI- or translation object-based compliance
errors (if this option is selected from the View > Interchanges
menu).
Note: This option is only available if a single item is selected from
the detailed list.

The following lists the status icons that the system may use at the document level
on the Interchanges browser:

Status Icon Description

OK (green, thumbs-up) - Indicates that the documents are fully compliant
with the EDI standard and are eligible for further processing.
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Status Icon Description

NotOK (red, thumbs-down) - Indicates one of the following:

v The document failed to comply with the EDI standard. If this is the
cause of the error, the errors will be indicated on a translator report
associated with the document. Despite the fact that the document is
not fully compliant, it is eligible for further processing.

v The received document could not be associated with a specific
trading partner. If this is the case, the partner for the document is
listed as Unknown. To associate this document, and the other
documents received in the interchange with a partner, attach the
documents from the Interchange browser.

v A suitable trading relationship or translation object could not be
associated with the document. Detailed information concerning
what information was used to locate the relationship and/or the
translation object will be listed in the audit log. To correct this
problem, a valid relationship must be established using the Partner
Editor and a valid export, print, or turn-around translation object
must be defined for that relationship.

v A major error occurred while processing the interchange, functional
group, or transaction level enveloping structures. This error may
include header and trailer control numbers that do not match, an
invalid trailer control count, or a control number sequence checking
error. If any of these errors occur, they will be listed on the
translator report for the interchange containing the document.

Duplicate (yellow, thumbs-down) - Indicates the document has the same name
as another document on the system.

Translator Report
Click Translator Report to toggle the display of the interchange or document
translator report (depending on which item has focus) in the Translator Report
section of the Interchanges or Restored Interchanges browser for the selected item.
A checkmark means that the display of translator report is on.

Note: The Translator Report function is only active if the Interchanges or Restored
Interchanges browser has focus.

Interchange Filter Dialog Box
The Interchange Filter dialog box allows you to filter the display of interchanges
by date, partner, and direction (inbound and outbound).

Note: You can set global Interchange Filter preferences in the Sterling
Gentran:Server Preferences dialog box on Interchange Filter tab. Access the
Preferences dialog box by selecting Preferences from the Options menu.

The following illustrates the Interchange Filter dialog box:
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The following describes the parts of the Interchange Filter dialog box.

Part Function

Date From Select the beginning date of a date range, from which the system
should filter the display of interchanges.
Note: The Date From box is only active if the No Date/Time
Checking check box is not selected.

Date To Select the end date of a date range, from which the system should
filter the display of interchanges.
Note: The Date To box is not active if either the No Date/Time
Checking check box is selected or if the Always Current check box
is selected.

Always Current Indicate that the end date for the date range is always the current
system date and time.
Note: The Always Current check box is only active if the No
Date/Time Checking check box is not selected.

No Date/Time
Checking

Indicate if the system filters the display of interchanges by date
and time (if selected).

Partner Contains a list of all partner profiles on your system. This list
allows you to filter the display of interchanges by the partners you
specify.
Note: The default display is all partners, but you can click on
partner profiles to clear them.

Unselect All Partners Clears all partner profiles.
Note: This allows you to filter the display of interchange by the
partners you specify.
Important: At least one partner must be selected.

Inbound�Outbound Select the direction of traffic (inbound and outbound) for the
system to filter the display of interchanges.
Note: The default display is both inbound and outbound
interchanges.
Important: At least one of the Inbound/Outbound check boxes
must be selected.

Viewing Interchanges
About this task

To view interchanges, complete the following steps.
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Procedure
1. From the appropriate area of The Desk, select Interchanges.

The system displays the Interchanges Browser.
2. To filter the display of interchanges by status, see Filtering the Display of

Interchanges.

Note: The Filter function enables you to filter the display of interchanges by
date, partner, and direction (inbound and outbound).

3. Select an interchange.
4. To view the related external data for a single selected interchange, select View

> Interchanges > Related External Data.

Note: When viewing raw-EDI or External Data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.

5. To view the content of a single selected interchange in raw EDI data format,
select View > Interchanges > Gentran Data.

Note: When viewing raw-EDI or External Data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.

6. To view the translator report for a single selected interchange, select View >
Interchanges > Translator Report.

7. To print a selected interchange or a summary of interchanges, select File >
Print.

8. To delete a selected interchange and all associated documents, select Document
> Delete.

Notes:

v If you delete an interchange with a status of Queued, you receive a warning
that you must remove specified messages from Out Documents and from
your trading partner’s inbox. If you proceed, you are warned that if your
partner bases processing results on control number sequencing, you should
modify the transaction, group, and interchange control numbers.

v If you delete an interchange with a status of Ready to send, you are warned
that if your partner bases processing results on control number sequencing,
you should modify the transaction, group, and interchange control numbers.

v If an interchange contains a document that is waiting for acknowledgement
processing (acknowledgement generation or reconciliation), you cannot delete
it until this processing is complete.

9. To attach an interchange to a partner, select Document > Attach.

Filtering the Display of Interchanges
When the Interchanges browser is active, the Filter function enables you to filter
the display of interchanges by date, partner, and direction (inbound and
outbound).

About this task

To filter interchanges by partner and/or date, complete the following steps.
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Procedure
1. From the appropriate area of The Desk, select Interchanges.

The system displays the Interchanges Browser.
2. Select Commands > Filter.

The system displays the Interchange Filter Dialog Box.
3. To filter the display of interchanges by date and time, clear the No Date/Time

Checking check box. Otherwise, select No Date/Time Checking and continue
with step 6.

4. Use the Date From slide bar to select the beginning date of the date range, from
which the system will filter the display of interchanges.

5. If you want the end date for the date range to always be the current system
date and time, select Always Current. Otherwise, clear the Always Current
check box and move the Date to slide bar to the date and time you want to
use.

6. To filter the display of interchanges by partner, select the partners that you
want displayed from the Partner list (lists all partner profiles on your system).

Note: The default display is all partners, but you can click partner profiles to
clear them and change the display. Alternately, you can click Unselect All
Partners to deselect all partner profiles. You can then click one or more profiles
to select them. At least one partner must be selected.

7. Select the direction you want to filter the interchange.
The default display is both inbound and outbound interchanges.

Note: At least one of the Direction check boxes must be selected.
8. Click OK.

The system filters the interchange display based on the criteria you selected.

Viewing Documents within Interchanges
You can view the individual documents in an interchange as long as a screen entry
translation object for each document is available on your system.

About this task

Use this procedure to view the documents within an interchange.

Procedure
1. From the appropriate area of The Desk, select Interchanges.

The system displays the Interchanges Browser.
2. Select a document and proceed with the next steps or double-click a document

to view it.

Note: You must have a screen entry translation object for this document
available on your system.

3. To view a translator report of the actions the translator took on this document,
select View > Interchanges > Translator Report.

4. To view the content of a single selected interchange in raw EDI data format,
select View > Interchanges > Gentran Data.

Note: When viewing raw-EDI or External Data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.
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5. To view the related external data of a single selected interchange, select View >
Interchanges > Related External Data.

Note: When viewing raw-EDI or External Data, you can switch from Text to
Hex format by selecting the appropriate command from the View menu.

6. To print a selected document or translation report, select File > Print.
7. To delete a selected document, select Document > Delete.
8. To copy the document to the appropriate browser, select Document > Copy

and select the appropriate browser from the submenu.

Attaching Interchanges to a Partner
The Attach to Partner dialog box can be accessed when the Interchanges browser is
active and one interchange is selected. The Attach function enables you to link the
interchanges to a partner. Use this function if you received documents that did not
have an identifiable partner and are now listed without a partner in the ?In
Documents browser.

Before you begin

You must create the partner before you can complete this task. See Creating a
Partner Definition for instructions.

About this task

Note: The interchanges for these documents are listed without a partner in the
Interchanges browser.

Use this procedure to attach an interchange to a partner.

Procedure
1. From the appropriate area of The Desk, select Interchanges.

The system displays the Interchanges Browser.
2. Select one interchange.
3. Select Document > Attach.

The system displays the Select Partner dialog box.
4. Select the desired partner from the list and click OK.

The system links the selected interchange to this partner and returns to the
Interchanges browser.
If the partner to which you are attaching the interchange has more than one
interchange definition, you are prompted with an additional dialog box. If not,
continue with step 8.

5. If your partner has more than one interchange definition, select the appropriate
interchange definition and click OK.

6. If your partner has more than one group definition, select the appropriate
group definition and click OK.

7. If your partner has more than one relationship defined for a document type in
the interchange, select the appropriate relationship definition and click OK.

8. After you attach the interchange to a partner, open ?In Documents from the
appropriate area of The Desk.
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Note: You can then export, print, or move the documents to the In Drawer
Browser.

About Resending Interchanges
There are several ways to resend interchanges.
v To automatically resend all outbound interchanges, you can set the Send Options

preference.
v To resend specific outbound interchanges, you can use the Resend command

from the Interchanges browser.
v To resend interchanges during the next communications session, you can use the

Queue for the Resend command from the Interchange browser

Note: You can only resend interchanges that were previously sent or that have a
status of Ready to send.

The following describes the system process that occurs when you resend an
interchange:

Stage Description

1 When the resend command is executed, the system first determines if it is
a TRADACOMS interchange. If the interchange is TRADACOMS, the
system increments the current version number in the FIL segment by one.
After this update, the interchange is resent in the same manner as all other
interchanges.
Note: Other standards do not use a version number.

2 Communication is established with the remote end. The status of the
message is updated based on the success or failure of the communications
session.

v If communication fails because there is no mailbox set up or the
Mailbox service is not started, the interchange and documents are left in
a Ready to send status.

v If communication fails because there is no modem, the interchange and
documents are left in a Queued status.

Note: No user action is required at this point. Interchanges that failed to
send are automatically sent as part of the next transmission session.

3 The documents are moved to the Out Drawer Browser and the interchange
status is set to Sent.

Resending Interchanges Automatically
You can set an option for the system to automatically check for interchanges that
are stuck in the Send Queue. The interval for checking the Send Queue is set by
default to 30 minutes in the Registry. However, you can change this value in the
UPIDValidationInterval key.

About this task

During the first system check, the Sterling Gentran:Server Executive Service checks
for interchanges that are possibly stuck and places those interchanges into a queue.
During the next system check, the Executive Service checks if those interchanges
are still in the queue. Any that are still in the queue at the second system check are
flagged to be sent during the next communications session.
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To automatically resend outbound interchanges, complete the following steps.

Procedure
1. Select Options > Preferences.

The system displays the Preferences dialog box.
2. Click the Send Options tab.
3. Select Check for interchanges that did not send.
4. Click OK.

Optional -
5. Change the System Check Interval in the registry.

Note: This is an optional step. The default is 30 minutes.
6. Restart services.

Queueing Interchanges
Interchanges queued for sending are sent with then next matching communications
session. If the next session targets a specific partner or mailbox, and the
interchanges do not match that criteria, the interchanges are not resent.

About this task
v Example 1 - Interchanges are queued for resending to mailbox SIB. A

communications session for the “Gentran Tutorial” mailbox executes. The
queued interchange are not sent.

v Example 2 - Interchanges for the partner PETZONE are queued for resending. A
communications session for data only for the partner PETZONE2 executes. The
queued interchanges are not sent.

To queue interchanges for sending with the next communications session, complete
the following steps.

Procedure
1. From the appropriate area of The Desk, select Interchanges.

The system displays the Interchanges Browser.
2. Select the outbound interchange that needs to be resent.
3. Select Document > Queue for Resend.

The Interchanges Process Status changes to "Ready to Send."

Resending a Specific Interchange
About this task

To resend a specific outbound interchange, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Interchanges.

The system displays the Interchanges Browser.
2. Select the outbound interchange that needs to be resent.
3. Select Document > Resend.
4. Click Yes to start the transmission session.
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Manually Acknowledging an Interchange, Group, or Document
The Acknowledge function does not generate an acknowledgement; it merely
changes the status of the outbound document.

About this task

The status of an interchange, group, or document in the Interchanges browser may
need to be manually set to acknowledged for many reasons. For example, you
contact a partner about an overdue document and the partner verifies that it was
received but they did not send an acknowledgement.

To manually change the status of an interchange, group, or document to
acknowledged, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Interchanges.

The system displays the Interchanges Browser.
2. Select an unacknowledged interchange, group, or document that needs to be set

to acknowledged.

Note: Unacknowledged documents are marked with one of the following:
v Overdue
v Waiting
v Sent
v OnNet
v PickedUp
v NetErr
v NetWarn

3. Select Document > Ack.
The system sets the status of the document to acknowledged.

Deleting Interchanges
You can delete a single selected interchange, or you can choose to delete all the
interchanges filtered in the display.

Procedure
1. Highlight an interchange and click Delete or just click Delete if you want to

delete all the interchanges based on the filter selection.
The Selected Interchanges for Deletion dialog box is displayed.

2. To delete a single selected interchange, click Selected Interchange.
To delete all the interchanges, based on what you selected on the Filter
Interchanges dialog box, click All Interchanges based on filter selection.

3. Click OK to remove the selected interchanges and all the associated database
entries.
The Delete confirmation dialog box is displayed.

4. Click Yes to confirm or No to cancel.
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Chapter 11. Envelopes

Outbound BAT Envelope
The Outbound Envelope allows you to determine outbound parameters for the
BAT (TRADACOMS) option. The Outbound BAT Envelope dialog box is displayed.

The following describes the parts of the Outbound BAT Envelope.

Part Description

Send BAT Segment Select this to send the BAT segment.

Functional Group ID Displays the functional group ID assigned by the standards (such as,
"BAT").

Message Reference
Number (BAT01)

Define the beginning group control number for generating group
control envelopes. The system will assign control numbers
sequentially, adding one to the number you specify here. If you
specify "0", the system will assign "1" as the beginning group control
number.

Controlling Agency Mandatory. Define the code that identifies the agency controlling the
specification, maintenance, and publication of the message type. For
the TRADACOMS standard, the controlling agency code is "A."

Version Number Mandatory. Enter the version number of the message type in the
functional group.

Last Control
Number

Displays the group control number that was last used for generating
group control envelopes. The system will assign control numbers
sequentially, adding one to the number specified here.

fields 1 - 10 Fields 1 - 10 are available for your use, regardless of whether or not
you send the BAT segment. You can use these fields to add segments
to the header and trailer of a Group Build Map. See the Application
Integration User Guide for more information.

Outbound BG Envelope
The Outbound Envelope allows you to determine outbound parameters for the BG
(UCS) option. The Outbound BG Envelope dialog box is displayed.

The following describes the parts of the Outbound BG Envelope.

Note: All entries in this dialog box are mandatory.

Part Description

Communication ID
(BG01)

Define your BG communication identifier. This ID will appear on the
BG interchange header.

Communication
Password (BG02)

Define a password that is agreed upon by you and your trading
partner. This password will appear on the BG Interchange Header.

Applications Sender
Code (BG03)

Enter your sender EDI ID. This identifies your sender ID in outgoing
messages. This value will appear in the BG interchange header
segment.
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Part Description

Applications
Receiver Code
(BG04)

Designate this trading partner's application receiver code as it will
appear on the BG interchange header. This identifies your partner's
sender ID in outgoing messages.

Last Used Control
Number (BG07)

Define the group control number that was last used for generating
group control envelopes. The system will assign control numbers
sequentially, adding one to the number you specify here. If you
specify zero, the system will assign "1" as the beginning group
control number.

Element Separator Define the value that separates the elements in an outbound data
segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Segment Terminator Define the value that identifies the end of an outbound data
segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Outbound GS Envelope
The Outbound Envelope allows you to determine outbound parameters for the GS
(X12, EDIA, or UCS) option. The Outbound GS Envelope dialog box is displayed.

The following describes the parts of the Outbound GS Envelope.

Part Description

Functional Group ID
(GS01)

Displays the Group ID as defined for the Partner ID. This is the
functional group ID assigned by the standards.

Applications
Senders Code (GS02)

Mandatory. Enter the ID for your company. This value will appear in
the GS segment.
Note: The minimum length is 2 and the maximum length is 15.

Applications
Receivers Code
(GS03)

Mandatory. Enter your Trading Partner’s ID. This value will appear
in the GS segment.
Note: The minimum length is 2 and the maximum length is 15.

Last Used Control
Number (GS06)

Define the group control number that was last used for generating
group control envelopes. The system will assign control numbers
sequentially, adding one to the number you specify here. If you
specify zero, the system will assign "1" as the beginning group
control number.
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Part Description

Responsible Agency
Code (GS07)

Mandatory. Define the standards agency responsible for the standard
in the GS segment:

v T = TDCC

v U = UCS

v X = ANSI X12

Note: The minimum length is 1 and the maximum length is 2.

Version (GS08) Mandatory. Enter the version number of the message type in the
functional group.

Outbound ICS Envelope
The Outbound Envelope allows you to determine outbound parameters for the ICS
(X12) option. The Outbound ICS Envelope dialog box is displayed.

The following describes the parts of the Outbound ICS Envelope.

Part Description

Element Separator
(ICS01)

Mandatory. Define the value that separates the elements in an
outbound data segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Sub-element
Separator (ICS02)

Mandatory. Define the value that separates the parts of an outbound
element. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Control Standards
ID (ICS03)

Mandatory. Define the organization responsible for the EDI standard
used in the interchange:

v T = TDCC

v U = USA EDI community

v X = ANSI X12

v E = EDIFACT

Version (ICS04) Mandatory. Enter the version of the EDI standards the system uses
to process control envelopes sent to or received from this Trading
Partner. Example: 002000.

Sender ID Qualifier
(ICS05)

Mandatory. Define your Qualifier as it will appear on the
interchange header segment sent to this Trading Partner. Qualifiers
are predefined by the EDI standards.

Chapter 11. Envelopes 131



Part Description

Sender ID (ICS06) Mandatory. Define your interchange ID. This identifies your sender
ID in outgoing messages.

Receiver ID
Qualifier (ICS07)

Mandatory. Define your Trading Partner's Qualifier as it will appear
on the interchange header. Qualifiers are predefined by the EDI
standards.

Receiver ID (ICS08) Mandatory. Define this Trading Partner's interchange ID. This
identifies your partner's sender ID in outgoing messages.

Control Number
(ICS11)

Mandatory. Designate the beginning control sequence number for
generating outbound interchange envelopes. The system will assign
control numbers sequentially, adding 1 to the number you specify
here. If you specify a zero, the system will assign "1" as the
beginning control number for your first transmission.

Segment Terminator
(ICS12)

Mandatory. Define the value that identifies the end of an outbound
data segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Outbound ISA Envelope
The Outbound Envelope allows you to determine outbound parameters for the ISA
(X12 or EDIA) option. The Outbound ISA Envelope dialog box is displayed.

The following describes the parts of the Outbound ISA Envelope.

Part Description

Authorization Code
Qualifier (ISA01)

Mandatory. Indicate if an authorization code is present.
Note: The minimum length is 1 and the maximum length is 2.

Authorization Code
(ISA02)

Define the authorization code that your Trading Partner assigned to
you.
Note: This is mandatory if the Authorization Code Qualifier is not
equal to "00." The minimum length is 1 and the maximum length is
10.

Security Code
Qualifier (ISA03)

Mandatory. Indicate if a security code is present.
Note: The minimum length is 1 and the maximum length is 2.

Security Code
(ISA04)

Define the security code that your Trading Partner assigned to you.
Note: This is mandatory if the Authorization Code Qualifier is not
equal to "00." The minimum length is 1 and the maximum length is
10.

Sender ID Qualifier
(ISA05)

Mandatory. Define your Qualifier as it will appear on the
interchange header segment sent to this Trading Partner. Qualifiers
are predefined by the EDI standards.
Note: The minimum length is 1 and the maximum length is 2.

Sender ID (ISA062) Mandatory. Define your interchange ID. This identifies your sender
ID in outgoing messages.
Note: The minimum length is 1 and the maximum length is 15.
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Receiver ID
Qualifier (ISA07)

Mandatory. Define your Trading Partner's Qualifier as it will appear
on the interchange header. Qualifiers are predefined by the EDI
standards.
Note: The minimum length is 1 and the maximum length is 2.

Receiver ID (ISA08) Mandatory. Define this Trading Partner's interchange ID. This
identifies your partner's sender ID in outgoing messages.
Note: The minimum length is 1 and the maximum length is 15.

Control Standards
Identifier (ISA11)

If the standard used is earlier than 4020, this displays the control
standards identifier. If the standard is 4020 or later, this is
inactivated.

The Control Standards Identifier is the organization responsible for
the EDI standard used in the interchange:

v T = TDCC

v U = USA EDI community

v X = ANSI X12

v E = EDIFACT

Note: Mandatory if the standard is earlier than 4020; one character.

Version (ISA12) Mandatory. Enter the version of the EDI standards the system uses
to process control envelopes sent to or received from this Trading
Partner. Example: 002000.
Note: The minimum length is 1 and the maximum length is 5.

Control Number
(ISA13)

Designate the beginning control sequence number for generating
outbound interchange envelopes. The system will assign control
numbers sequentially, adding 1 to the number you specify here. If
you specify a zero, the system will assign "1" as the beginning
control number for your first transmission.

Acknowledgement
Requested (ISA14)

Mandatory; default is 0. Set the acknowledgement request box on an
outbound ISA:

v "0" = No, interchange acknowledgement not requested.

v "1" = Yes, interchange acknowledgement requested.

Test Indicator
(ISA15)

Mandatory. Specify whether the interchange is in test or production
mode:

v blank = The interchange is in production mode.

v "1" = The interchange is in test mode.

Element Separator Mandatory. Define the value that separates the elements in an
outbound data segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."
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Sub-element
Separator

Mandatory. Define the value that separates the parts of an outbound
element. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Segment Terminator Mandatory. Define the value that identifies the end of an outbound
data segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Repetition
Terminator (ISA11)

If the standard is 4020 or later, this displays the repeating element
separator. If the standard is earlier than 4020, then this field is
inactivated.
Notes:

v If the ISA11 is blank, and the version is less than 4020, the
element separator is used as the repeating element separator. For
the EDIFACT standard, this separator defaults to asterisk (*).

v Mandatory if the standard is earlier than 4020; one character.

Outbound MHD Envelope
The Outbound Envelope allows you to determine outbound parameters for the
MHD (TRADACOMS) option. The Outbound MHD Envelope dialog box is
displayed.

The following describes the parts of the Outbound MHD Envelope.

Part Description

Message Reference
Number (MHD01)

Displays a consecutive count of messages within a transmission.
This is a unique reference number assigned by the system.

Message Type
(MHD02)

Displays the type of message.

Message Release
(MHD02)

Displays the release number of the current version number. This
distinguishes the different versions of a message.
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Outbound NCPDP Envelope Dialog Box
The Outbound NCPDP Envelope enables you to specify outbound parameters for
the NCPDP standard. The translator uses this information during the build process
to generate batch segments.

This diagram illustrates the Outbound Envelope NCPDP Envelope dialog box.

This table describes the parts of the Outbound NCPDP Envelope dialog box.

Part Function

Transmission
Type

Identifies whether the transmission is a Transaction or Response.

Sender ID Specifies the sender identifier defined by the processor/switch.

Batch Number Specifies the number of the batch, which matches the trailer record and
is assigned by the sender.

File Type Specifies whether the file is Production or Test.

Version/Release
Number

Specifies the version/release number of the header data.

Receiver ID Specifies the sender identifier defined by the processor.

Outbound Envelope PIP Initiation Dialog Box
The Outbound Envelope PIP Initiation dialog box is used to specify enveloping
options for a PIP.

Note: The PIP Initiation requirements vary depending on which version of
RosettaNet you are using.

RosettaNet version 1.1

This diagram illustrates the Outbound Envelope PIP Initiation dialog box (version
1.1).
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This table describes the parts of the Outbound Envelope PIP Initiation dialog box
for RosettaNet version 1.1.

Part Function

Global Administering
Authority Code

Specifies the controlling agency (RosettaNet). The applicable
RosettaNet codes are listed in the Service Header Guideline. This
value is mandatory.

Version ID Specifies the RNIF version number. This value is mandatory.

Global Usage Code Indicates whether the PIP is test or production. The applicable
RosettaNet codes are listed in the Service Header Guideline. This
value is mandatory.

Action Identity

Transaction Version ID Specifies the version of message guideline that is used. This value
is mandatory.

Process Identity
Version ID

Specifies the PIP version. This value is mandatory.

Global Indicator Code Specifies the RosettaNet-defined process. The applicable RosettaNet
codes are listed in the Service Header Guideline. This value is
mandatory.

Global Doc Function
Code

Indicates whether the message is a "Request" or "Response." The
applicable RosettaNet codes are listed in the Service Header
Guideline. This value is mandatory.

Sender: DUNS+4 Specifies the DUNS number of the partner sending the PIP. This
value is mandatory.

Receiver: DUNS+4 Specifies the DUNS number of the partner receiving the PIP. This
value is mandatory.

Sender: Global Partner
Classification Code

Specifies the code used to describe the function of the partner
sending the PIP. This value is mandatory.
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Part Function

Receiver: Global
Partner Classification
Code

Specifies the code used to describe the function of the partner
receiving the PIP. The applicable RosettaNet codes are listed in the
Service Header Guideline. This value is mandatory.

Receiver: Global
Business Service Code

Specifies the service that the receiving partner is performing. The
applicable RosettaNet codes are listed in the Service Header
Guideline. This value is mandatory.

Time Allowance to
Ack Acceptance

Specifies the amount of time allowed to acknowledge receipt of
acceptance, other than the designated default amount of time.

Format: Type time in minutes.

Time Allowance to
Ack Receipt

Specifies the amount of time allowed to acknowledge receipt other
than the designated default amount of time.

Format: Type time in minutes.

Time Allowance to
Perform

Specifies the time allotted to perform other than the designated
default time.

Format: Type time in minutes.

Sender: Global Partner
Role Classification
Code

Specifies a code used to describe the role of the partner sending
the PIP. The applicable RosettaNet codes are listed in the Service
Header Guideline. This value is mandatory.

Receiver: Global
Partner Role
Classification Code

Specifies a code used to describe the role of the partner receiving
the PIP. The applicable RosettaNet codes are listed in the Service
Header Guideline. This value is mandatory.

Global Transaction
Code

Describes the message. The applicable RosettaNet codes are listed
in the Service Header Guideline. This value is mandatory.

Global Process Code Specifies the RosettaNet-defined code that describes the message
type. The applicable RosettaNet codes are listed in the Service
Header Guideline. This value is mandatory.

PIP Initiating Partner:
Global Business
Identifier

Specifies the DUNS number of the partner sending the PIP. This
value is mandatory.

Sender: Global
Business Service Code

Specifies a code used to describe the service the sending partner is
performing. The applicable RosettaNet codes are listed in the
Service Header Guideline. This value is mandatory.

RosettaNet version 2.0

This diagram illustrates the Outbound Envelope PIP Initiation dialog box (version
2.0).
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This table describes the parts of the Outbound Envelope PIP Initiation dialog box
for RosettaNet version 2.0.

Part Function

Global Administering
Authority Code

Specifies the controlling agency (RosettaNet). The applicable
RosettaNet codes are listed in the Service Header Guideline. This
value is mandatory.

PIP Version Specifies the version number of the PIP. This value is mandatory.

Version ID Specifies the RNIF version number. This value is mandatory.

Global Usage Code Indicates whether the PIP is test or production. The applicable
RosettaNet codes are listed in the Service Header Guideline. This
value is mandatory.

Sender: DUNS+4 Specifies the DUNS number of the partner sending the PIP. This
value is mandatory.

Receiver: DUNS+4 Specifies the DUNS number of the partner receiving the PIP. This
value is mandatory.

To Global Partner
Role Classification
Code

Specifies a code used to describe the role of the partner receiving
the PIP. The applicable RosettaNet codes are listed in the Service
Header Guideline. This value is mandatory.

From Global Partner
Role Classification
Code

Specifies a code used to describe the role of the partner sending
the PIP. The applicable RosettaNet codes are listed in the Service
Header Guideline. This value is mandatory.

Business Activity
Identifier

Specifies an identifier for special validation and processing rules
corresponding to the currently executing PIP and activity. This
value is mandatory.

From Global Business
Service Code

Specifies a code used to describe the service the sending partner is
performing. The applicable RosettaNet codes are listed in the
Service Header Guideline. This value is mandatory.

Global Process
Indicator Code

Specifies the RosettaNet-defined process. The applicable RosettaNet
codes are listed in the Service Header Guideline. This value is
mandatory.

Secure Transport
Required

Indicates to the trading partner that all responses to this document
must be sent using the SSL protocol.
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Part Function

To Global Business
Service Code

Specifies the service that the receiving partner is performing. The
applicable RosettaNet codes are listed in the Service Header
Guideline. This value is mandatory.

Receiver Identification
Domain

Specifies the DUNS number. This value is mandatory.

Receiver Location
Identifier

Specifies a logical business location associated with this trading
partner. This value is mandatory.

Sender Identification
Domain

Specifies the DUNS number. This value is mandatory.

Sender Location
Identifier

Specifies your logical business location associated with this trading
partner. This value is mandatory.

Outbound ST Envelope
The Outbound Envelope allows you to determine optional outbound parameters
for the ST (ANSI, UCS, TDCC) option. The Outbound ST Envelope dialog box is
displayed.

The following describes the parts of the Outbound ST Envelope.

Part Description

Implementation
Convention
Reference (ST03)

Optional. Type up to 35 characters for the implementation
convention reference.

Outbound STX Envelope
The Outbound Envelope allows you to determine outbound parameters for the
STX (TRADACOMS) option. The Outbound STX Envelope dialog box is displayed.

The following describes the parts of the Outbound STX Envelope.

Part Description

Syntax ID (STX01) Mandatory. Enter the Controlling Agency:

v ANA

v ANAA (if the reconciliation facility is used)

Syntax
Version(STX01)

Mandatory. Define the version number associated with the syntax
identifier.

Sender ID Code
(STX02)

Define your interchange ID code as it will appear on the interchange
header segment sent to this trading partner.
Note: The Sender ID Code is mandatory if you do not complete the
Sender ID Name box.

Sender ID Name
(STX02)

Define your name as it will appear on the interchange header
segment sent to this trading partner.
Note: The Sender ID Name is mandatory if you do not complete the
Sender ID Code box.

Recipient ID Code
(STX03)

Define this trading partner's interchange ID code agreed on by you
and your trading partner.
Note: The Recipient ID Code is mandatory if you do not complete
the Recipient ID Name box.
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Recipient ID Name
(STX03)

Define your trading partner's name as it will appear on the
interchange header.
Note: The Recipient ID Name is mandatory if you do not complete
the Recipient ID Code box.

Senders Reference
(STX05)

Displays your reference number for this transmission.

Recipients Reference
(STX06)

Define your trading partner's reference number for this transmission,
if you know it.

Application
Reference (STX07)

Enter a message identification if the interchange contains only one
type of message. This is used by the networks to validate the
transmission by determining if you have the authority to send this
type of message to the designated recipient.

Priority Code
(STX08)

Enter the transmission priority code as mutually agreed upon with
your trading partner. This code value must appear in the Code
Values List 1 (Transmission Priority Codes):

v A = Urgent

v B = Normal

v C = Low

Segment Code
Separator

Define the value that separates the segment codes. Do one of the
following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Component Element
Separator

Define the value that separates the component data elements in a
composite data element. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Element Separator Define the value that separates the elements in an outbound data
segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."
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Segment Terminator Define the value that identifies the end of an outbound data
segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Release Indicator
(SCH05)

Mandatory. Displays a character that is used to restore any character
used as a syntactical separator to its original meaning.

Decimal Notation Type either a comma or a period to indicate the decimal point in a
numeric box. The period is recommended.
Note: This box is mandatory and must be either a period or a
comma.

Outbound UNA Envelope
The Outbound Envelope allows you to determine outbound parameters for the
UNA (EDIFACT) option. The Outbound UNA Envelope dialog box is displayed.

Note: EDIFACT version 4 defines the infrastructure necessary to support the
creation (and processing) of interchanges that have been encoded using a character
set other than 8-bit ASCII. Microsoft Windows supports the processing of an
encoded interchange as long as the encoding matches the default code page of the
operating system where it is running.

The following describes the parts of the Outbound UNA Envelope.

Part Description

Send UNA Segment Select this to send the UNA segment.

Component Element
(UNA01)

Mandatory. Define the value that separates the component data
elements in a composite data element. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."
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Element Separator
(UNA02)

Mandatory. Define the value that separates the elements in an
outbound data segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Decimal Notation
(UNA03)

Type either a comma or a period to indicate the decimal point in a
numeric box. The period is recommended.
Note: This box is mandatory and must be either a period or a
comma.

Release Indicator
(UNA04)

Mandatory. Type a character to restore any character used as a
syntactical separator to its original meaning.

Repetition Separator
(UNA05)

Displays the repeating element character.

Segment Terminator
(UNA06)

Mandatory. Define the value that identifies the end of an outbound
data segment. Do one of the following:

v In the first box, type the special character (such as * or ^). The
system converts it and enters the hex value for that character in
the second box.

v In the second box, type the hex value. The system converts it and
enters the special character for that hex value in the first box. If
there is no printable character that corresponds to the hex value,
the character box will be blank.

Note: The value must be between HEX "01" and HEX "FF."

Outbound UNB Envelope
The Outbound Envelope allows you to determine outbound parameters for the
UNB (EDIFACT) option. The Outbound UNB Envelope dialog box is displayed.

Note: EDIFACT version 4 defines the infrastructure necessary to support the
creation (and processing) of interchanges that have been encoded using a character
set other than 8-bit ASCII. Microsoft Windows supports the processing of an
encoded interchange as long as the encoding matches the default code page of the
operating system where it is running.

The following describes the parts of the Outbound UNB Envelope.

Part Description

Syntax ID
(UNB0101)

Mandatory. Enter the Controlling Agency (for example, UNOA).

Syntax Version
(UNB0102)

Define the version number associated with the syntax identifier.
Note: If you type a version number earlier than version 4 in the
Syntax Version box on the Outbound UHB Envelope dialog box, the
system disables the version 4 fields in both the UNB and UNH
dialogs and any data in those fields will not be saved when you exit
the Outbound UNB Envelope dialog box.
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Service List
Directory Version
(UNB0103)

Enter the version number of the service code list directory.

Character Encoding
(UNB104)

Enter the coded identification of the character encoding used in the
interchange.

Sender ID
(UNB0201)

Mandatory. Define your interchange ID as it will appear on the
interchange header segment sent to this trading partner.

Sender ID Qualifier
(UNB0202)

Define your qualifier as it will appear on the interchange header
segment sent to this Trading Partner.

Reverse Routing
Address (UNB0203)

Define your reverse route code as mutually agreed on with this
trading partner.
Note: This is only displayed for EDIFACT versions earlier than
version 4.

Sender Internal ID
(UNB0203)

Enter the sender internal identifier.
Note: This parameter is only displayed if you are using EDIFACT
version 4. For version 4, this value allows 35 characters. For versions
prior to 4, this value allows 14 characters.

Sender Internal
Sub-ID (UNB0204)

Enter the sender internal sub-identifier. Sub-level of sender internal
identification, when further sub-level identification is required.
Note: This is only displayed for EDIFACT versions earlier than
version 4.

Receiver ID
(UNB0301)

Mandatory. Define this trading partner's interchange ID.

Receiver ID
Qualifier
(UNB0302)

Define your trading partner's qualifier as it will appear on the
interchange header.

Receiver Routing
Address (UNB0303)

Identify your trading partner's receive route code, as mutually agreed
upon.
Note: This is only displayed for EDIFACT versions earlier than
version 4.

Recipient Internal
ID (UNB0303)

Enter the recipient internal identifier.
Note: This parameter is only displayed if you are using EDIFACT
version 4. For version 4, this value allows 35 characters. For versions
prior to 4, this value allows 14 characters.

Recipient Internal
Sub-ID (UNB0304)

Enter the recipient internal sub-identifier. Sub-level of recipient
internal identification, when further sub-level identification is
required.
Note: This is disabled for EDIFACT versions earlier than version 4.

Control Number
(UNB05)

Displays the beginning control sequence number for generating
interchange envelopes. The system will assign control numbers
sequentially, adding one to the number you specify here. If you
specify a "0", the system will assign "1" as the beginning control
sequence number.

Receiver Password
(UNB0601)

Define the password to the trading partner's system or third-party
network.

Password Qualifier
(UNB0602)

Define the qualifier associated with your trading partner’s system or
third-party network.

Application
Reference (UNB07)

Enter a message identification if the interchange contains only one
type of message.

Priority Code
(UNB08)

Enter this trading partner's processing priority code as mutually
agreed upon.
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Acknowledgement
Requested

Specify that you want this trading partner to acknowledge your
request:

v "1" = Yes, you want your Trading Partner to acknowledge your
request.

v blank = No, you do not expect an acknowledgement (system
default).

Comm Agreement
ID (UNB10)

Define the type of communication agreement controlling the
interchange (for example, Customs or ECE agreement).

Test Indicator Specify whether the interchange is in test mode or production mode:

v "1" = The interchange is in test mode.

v blank = The interchange is in production mode.

UNA Displays the Outbound UNA Envelope.

Outbound UNG Envelope
The Outbound Envelope allows you to determine outbound parameters for the
UNG (EDIFACT) option. The Outbound UNG Envelope dialog box is displayed.

Note: EDIFACT version 4 defines the infrastructure necessary to support the
creation (and processing) of interchanges that have been encoded using a character
set other than 8-bit ASCII. Microsoft Windows supports the processing of an
encoded interchange as long as the encoding matches the default code page of the
operating system where it is running.

The following describes the parts of the Outbound UNG Envelope.

Part Description

Functional Group ID
(UNG01)

Displays the Group ID as defined for the Partner ID. This is the
functional group ID assigned by the standards.

Sender ID (UNG02) Mandatory. Enter the ID for your company. This identifies your
sender ID in outgoing messages. This value will appear on the UNA
segment.
Note: The minimum length is 1 and the maximum length is 35.

Qualifier (UNG02) Enter the Qualifier Code associated with your Sender ID (if
applicable). This value will appear on the UNA segment.

Recipients ID
(UNG03)

Mandatory. Enter your Trading Partner’s ID. This value will appear
on the UNA segment.
Note: The minimum length is 1 and the maximum length is 35.

Qualifier (UNG031) Enter the Qualifier Code associated with your Trading Partner's
Recipients ID (if applicable). This value will appear on the UNA
segment.

Reference Number
(UNG05)

Displays the beginning group control number for generating group
control envelopes. The system will assign control numbers
sequentially, adding one to the number you specify here. If you
specify zero, the system will assign "1" as the beginning group
control number. If you are using the EDIFACT standard and if there
is no value here, the UNG will not be created.

Controlling Agency
(UNG06)

Mandatory; three characters. Enter the code that identifies the
agency controlling the specification, maintenance, and publication of
the message type.
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Part Description

Version Number
(UNG07)

Mandatory. Enter the version number of the message type in the
functional group.

Release (UNG07) Enter the release number of the current version number.

Association
(UNG07)

Enter the code assigned by the association responsible for the design
and maintenance of the message type.

Application
Password (UNG08)

Define the application password for your trading partner’s division,
department, or sectional system (if required).

Outbound UNH Envelope
The Outbound Envelope allows you to determine outbound parameters for the
UNH (EDIFACT) option. The Outbound UNH Envelope dialog box is displayed.

Note: EDIFACT version 4 defines the infrastructure necessary to support the
creation (and processing) of interchanges that have been encoded using a character
set other than 8-bit ASCII. Microsoft Windows supports the processing of an
encoded interchange as long as the encoding matches the default code page of the
operating system where it is running.

The following describes the parts of the Outbound UNH Envelope.

Table 3. Outbound UNH Envelope parts

Part Description

Message Reference
Number (UNH01)

Enter a unique reference number assigned by your company.

Message Type
(UNH0201)

Enter the message type as defined for the Partner ID.

Version Number
(UNH0202)

Enter the version number of the message type in the functional
group. For example, "92" for version "92.1."

Version Release
Number (UNH0203)

Define the release number of the current version number. For
example, "1" for version "92.1."

Controlling Agency
(UNH0204)

Enter the code that identifies the agency controlling the specification,
maintenance, and publication of the message type (for example,
"UN"). This must contain three alphanumeric characters if you are
using EDIFACT version 4 or later or two alphanumeric characters if
you are using an EDIFACT version earlier than version 4.

Version Association
Code (UNH0205)

Enter the code assigned by the association responsible for the design
and maintenance of the message type.

Common Access
Reference (UNH03)

Define the key that relates all subsequent transfers of data to this
partner.

EDIFACT Syntax
Version 4

See the table of parameters below.
Note: If you type a version number earlier than version 4 in the
Syntax Version box on the Outbound UHB Envelope dialog box, the
system disables the version 4 fields in both the UNB and UNH
dialogs and any data in those fields will not be saved when you exit
the Outbound UNB Envelope dialog box.
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Table 4. EDIFACT Syntax Version 4 parameters

Parameter Name Definition

Service Code List
Directory Version
(UNH0206)

Version number of the code list directory

Message Type
Sub-function
(UNH0207)

Code identifying a sub-function of a message type.

Message Subset ID
(UNH0501)

Coded identification of a message subset, assigned by its
controlling agency.
Note: This parameter is mandatory for EDIFACT version 4.

Message Subset Version
Number (UNH0502)

Version number of this message subset.

Message Subset Release
Number (UNH0503)

Release number within the message subset version number.

Message Subset
Controlling Agency
(UNH0504)

Code identifying the controlling agency.

Message
Implementation ID
(UNH0601)

Code identifying the message implementation guideline
identification.
Note: This parameter is mandatory for EDIFACT version 4.

Message
Implementation Version
Number (UNH0602)

Version number of this message implementation guideline.

Message
Implementation Release
Number (UNH0603)

Release number within the message implementation guideline
version number.

Message
Implementation
Controlling Agency
(UNH0604)

Code identifying the controlling agency.

Scenario ID (UNH0701) Code identifying the scenario.
Note: This parameter is mandatory for EDIFACT version 4.

Scenario Version
Number (UNH0702)

Coded identification of the scenario’s version number, assigned
by its controlling agency.

Scenario Release
Number (UNH0703)

Release number within the scenario’s version number.

Scenario Controlling
Agency (UNH0704)

Code identifying the controlling agency.

Outbound VDA Envelope Dialog Box
Use the Outbound VDA Envelope dialog box to assign values to be used with
specific headers in VDA messages.

Use the Outbound VDA Envelope dialog box when you want to provide
information to be included in the outbound interchange envelope using the
Trading Partner information, rather than through the application file.

This diagram illustrates the Outbound VDA Envelope.
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This table describes the fields on the Outbound VDA Envelope dialog box, as well
as the length of each field.

Field Name
Field
Length Description

Supplier Number 9 An identification number assigned to a supplier by a
customer. All fields of a record structure that contain the
field Supplier Number are subject to data privacy protection.
Data entries are left justified.

Customer
Number

9 An identification number assigned to a customer by a
supplier. All fields of a record structure that contain the field
Customer Number are subject to data privacy protection.
Data entries are left justified.

Sender Number 9 An identification number that the data sender arranges with
the data receiver.

Receiver Number 9 An identification number that the data receiver arranges
with the data sender.

Data Sender 9 An identification number that the data sender arranges with
the data receiver.

Data Source
Number

9 An identification number that the data source arranges with
the data receiver.

Sub Suppliers 9 An identification number that is assigned to a sub supplier
by a customer.

Sales Tax ID
Recipient

20 An identification number of the national tax office for the
recipient. This field is mandatory for delivery of goods
within the European Union. Data entries are left justified.

Sales Tax ID
Sender

20 An identification number of the national tax office for the
sender. This field is mandatory for delivery of goods within
the European Union. Data entries are left justified.

Payment
Indication
Number

6 A link between data transmission payment notification and
real payments received. This includes the Check number
and remittal number. Data entries are left justified.
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Field Name
Field
Length Description

Comp. Reg.
Number

25 An identification of the National Register of Business Names
(Commercial Register) for the supplier. This field is
mandatory for some European countries.

Carrier Number 9 The carrier data number of VDA message 4920. If relevant,
the contents of this field will be identical to the contents of
the field in record type 712, position 13.

Warehouse
Keeper Code

1 A code that identifies the person who created the
interchange.

Purpose Code 2 Not used in this release.

This table shows the fields of the Outbound VDA Envelope and the VDA message
headers that the field is used with. An X indicates that the field is used with that
VDA message and is required on the Outbound VDA Envelope dialog box.

Field Name

Message/Release Date

4905/
1088

4905/
0496

4906/
0593

4907/
0893

4908/
0596

4913/
1094

4915/
1189

Supplier Number X X X X X X

Customer Number X X X X X X

Sender Number

Receiver Number

Data Sender X

Data Source Number X

Sub Suppliers X

Sales Tax ID Recipient X X

Sales Tax ID Sender X X

Payment Indication
Number

X

Comp Reg. Number X

Carrier Number X

Warehouse Keeper
Code

X

Purpose code
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Chapter 12. Acknowledgements

Defining Inbound Acknowledgement Criteria
Acknowledgements are sent to a trading partner to inform them that you received
a transmission they sent and to inform them of any errors. You must define the
level of acknowledgements that you expect from your trading partners and you are
sending to your trading partners upon receipt of a transmission.

About this task

The criteria that the system uses to acknowledge inbound documents, functional
groups, and interchanges is defined at the partner level on the Partner Editor
Inbound Relationship dialog boxes. The translation objects used by the system to
generate functional acknowledgements are included as system translation objects
and are registered automatically when you install Sterling Gentran:Server.

Note: If you generate functional acknowledgements as a result of receiving
documents for an inbound relationship, you must set up the corresponding
outbound relationship to generate the acknowledgements your partner requests.

To define criteria to generate acknowledgements, complete the following steps.

Procedure
1. Define document acknowledgement criteria when you set up the partner

relationship. Select the Advanced options on the Inbound Relationship Dialog
Box.

Note: If you select Immediate acknowledgement processing, acknowledgement
reconciliation occurs during the inbound break session. If you select Deferred
acknowledgement processing (the default), reconciliation occurs at its scheduled
interval.

2. Define functional group acknowledgement criteria when you set up the
Inbound Group Entry. Select the Advanced options on the Inbound Group
Entry Dialog Box.

3. Define interchange acknowledgement criteria when you set up the Inbound
Interchange Entry. Select the Advanced options on the Inbound Interchange
Entry Dialog Box.

Defining Outbound Acknowledgement Criteria
Acknowledgements are sent to a trading partner to inform them that you received
a transmission they sent and to inform them of any errors. You must define the
level of acknowledgements that you expect from your trading partners and you are
sending to your trading partners upon receipt of a transmission.

About this task

Reconciling documents and their acknowledgements is a function that the system
automatically performs for you. The translation objects that are necessary to
process the acknowledgements you receive are included as system translation
objects and are registered when you install Sterling Gentran:Server.
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However, you must establish the level of acknowledgements that you expect by
completing the Partner Editor Outbound Relationship dialog boxes.

Note: If you are receiving functional acknowledgements as a result of sending
documents for an outbound relationship, you must set up the corresponding
inbound relationship to receive the acknowledgements you expect to receive.

Procedure

To set up the level of acknowledgements that you expect to receive from your
partners, complete the following steps.

Procedure
1. Set the requirement for receiving interchange acknowledgements in the

Advanced section of the Outbound Interchange Entry Dialog Box.

Note: Do not change the translation objects in the Interchange Transl. Obj. and
Acknowledge Transl. Obj. lists, unless you are certain of the result.

2. Set the requirement for receiving functional group acknowledgements in the
Advanced section of the Outbound Group Entry Dialog Box.

Note: If the acknowledgement is overdue (it is not received within the number
of hours designated in the Hours Overdue box), it is indicated with a status of
Overdue on the Interchanges Browser.

3. Set the requirement for receiving transaction set acknowledgements in the
Advanced section of the Outbound Relationship Dialog Box, as illustrated
below.

Manually Acknowledging Documents
The Acknowledge function does not generate an acknowledgement; it merely
changes the status of the outbound document.

About this task

The status of a document in the Out Drawer browser may need to be manually set
to Acknowledged for many reasons. For example, you have contacted a partner
about an overdue document, and that partner verified that it was received but they
are not sending you an acknowledgement.

To manually change the status of a document to Acknowledged, complete the
following steps.

Procedure
1. From the appropriate area of The Desk, select Out Drawer.

The Out Drawer Summary dialog box is displayed.
2. Select the type of document for the appropriate partner and click View.

The system displays the Out Drawer Browser.
3. Select an unacknowledged document that needs to be acknowledged.

Note: Unacknowledged documents are marked with one of these states:
v Overdue
v Waiting
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v Sent
v OnNet
v PickedUp
v NetErr
v NetWarn

4. Click Ack.
The system sets the status of the document to "Ack’d."

Checking for Overdue Acknowledgements
You can manually check for overdue acknowledgements by using the Overdue
Check feature.

About this task

Note: You can specify the frequency at which the system will check for overdue
acknowledgements (in whole minutes) in the System Configuration program. This
allows you to disable or reduce the frequency of overdue acknowledgement
checking.

To check for overdue acknowledgements, complete the following steps.

Procedure

Select Commands > Overdue Check.
The system checks if any interchange, group, or document that requires an
acknowledgement is overdue (the system has not received an acknowledgement
for it and the specified time to do so has expired). For any overdue interchange,
group, or document, the system sets the status to Overdue on the Interchanges
Browser.

Obtaining the Sender ID and Receiver ID (for EDIFACT)
About this task

To use the CntrlBld_DLL.tpl functionality to obtain the Sender ID and Receiver ID,
complete the following steps.

Procedure
1. Select Tools > Partner Editor.

The system displays the Partner Editor Dialog Box.
2. Select the Outbound Control Build relationship from the Select a Partner list

and click Outbound.
The system displays the Outbound Relationship Dialog Box for that partner.

3. On the Outbound Relationship dialog box, click Translation.
The system displays the Outbound Translation Object Dialog Box.

4. From the Import list, select ACKBUILD_CONTRL_DLL.

Note: The default translation object selected for the Outbound Control Build
relationship is the ACKBUILD_CONTRL.

5. Click Save to save your selections and return to the Outbound Relationship
dialog box.

Chapter 12. Acknowledgements 151



152 IBM Sterling Gentran:Server for Microsoft Windows: User Guide



Chapter 13. Document Tracking

Tracking Inbound Information
The system writes a document tracking record for every significant event that
occurs for a document. For example, a document tracking record is written when
the document is created, when it is modified, and when it is exported.

For inbound processing, the system may receive an inbound transmission file (such
as external data) through the Process File command within Sterling Gentran:Server
or through a mailbox message (when the content type is configured to
Application/EDI). After the file is received by the system, you may either export
the file or configure the system to export it automatically.

Process File Process

When data arrives directly into the system through a Process File command,
Commpost performs the following actions to save the information pertaining to
this file:

Stage Description

1 If the system configuration is configured to copy process file data,
Commpost copies the file to the external data directory.

2 Commpost updates the ExtData_tb with a new record containing the type
of external data being saved (such as ExtData), a new external data key
(after allocating a new one), and other relevant data pertaining to this
external data reference.

3 Commpost splits this file into interchanges and creates INT files
(interchanges) and IPC files for the Translator.

4 Commpost invokes the Translator, which continues with the inbound
process and creates a record in ExtDataXref_tb linking the external data
reference to the interchange just created. There is one IPC file for each
interchange, and the IPC file passes information to the Translator,
including the starting and ending offset indicators in the transmission file
for the interchange to which it corresponds and the external data type and
key.

This ensures that the system can reference this file (external data) in the event you
want to view tracking information or external data.

Note: If you do not configure Sterling Gentran:Server to copy external information,
the external data viewer is unavailable.

Mailbox Process File Process

When data enters the system through a mailbox, all associated message identifiers
are tracked using the following process:

Stage Description

1 Your trading partner creates a data file (in which ContentType is set to
Application/EDI. An associated message ID is created in the Outbox.
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Stage Description

2 Your partner sends it to your Sterling Gentran:Server Application Inbox,
which creates a new target message ID.

3 The CommMgr (the Sterling Gentran:Server Executive service) recognizes
the ContentType as Application/EDI. It receives the data and stores the
external data reference in the ExtData_tb in the same way as described in
the previous section, except that since CommMgr receives the data, it
saves this database entry.

4 The CommMgr builds a temporary session file using the
GDW_Process_MBFile command for unattended processing to execute,
and Process Control invokes Commpost.

5 Commpost builds the IPC file, which includes writing the external data
key and the start and end offset indicators in the transmission file for the
given interchange.

6 Commpost invokes the Translator for each interchange to finish processing
the data, and writes the entry in the ExtDataXref_tb to link the external
data reference to the Sterling Gentran:Server data.

Export Process

Data that is exported is already in the system, so the external data that creates the
export file is the Translator. Therefore, the Translator stores the tracking
information in the database.

Stage Description

1 The Translator uses the document or documents as input to the export
translation object.

2 Depending on the specifications of the translation object, the system
generates an export file.

3 The Translator copies the newly generated export file to the external data
folder in the system data store, updates the ExtData_tb with the
appropriate information, and updates the ExtDataXref_tb with the external
data and associated document information.

Tracking Outbound Information
The system writes a Document Tracking record for every significant event that
occurs for a document. For example, a Document Tracking record is written when
the document is created, when it is modified, and when it is exported.

For outbound processing, the system can import external data through the Import
command within Sterling Gentran:Server or through a mailbox message (when the
content type is configured to Application/Import). After the file is imported into
the system, you can send the file or configure process control to send the file
automatically. After a send command, a new mailbox message is created and any
subsequent send transmissions create a new mailbox message that is related to the
same external data file that was initially imported.
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Import Process

Data is imported using the following process:

Stage Description

1 The external data is imported directly into Sterling Gentran:Server. This
data is either coming from an unattended process control (GDW_Import)
or a manual import.

2 Depending on how the data is imported, either UNATTEND or EDIMGR
copies the external data file to the external data folder in the system data
store.

3 UNATTEND or EDIMGR updates the ExtData_tb with an entry that
indicates the filename, the date and time from the timestamp on the file,
the date and time of the action, and the ExtDataKEY

4 UNATTEND or EDIMGR writes the ExtDataType and ExtDataKEY
parameters to the IPC file (they are called "Type" and "Key," respectively,
in this file).

5 The Translator executes the import translation object. It obtains the
ExtDataType and ExtDataKEY from the IPC file and writes the
ExtDataXref_tb entries that link the documents to the external data
reference created by EDIMGR or UNATTEND.

Mailbox import process

When an external data file is imported using a Collection Mailbox, all the
associated message identifiers are tracked by the system according to the following
process:

Stage Description

1 When outbound data flows through the system, the Collection Mailbox
creates a data file and an associated message ID in its Outbox (with
ContentType set to Application/Import).

2 The Collection Mailbox sends it to your Application Inbox, creating a new
target message ID.
Note: For a Mailbox Import, you must specify the UNC path and file
name on the System Configuration Imports tab. This specification must
exactly match the path you set for the TRANSIN directory on the System
Configuration Directories tab.

3 The CommMgr recognizes the content type as Application/Import and
initiates the import of this file.

4 The CommMgr stores the external data reference in the ExtData_tb and
then builds the unattended processing session file (with the new
GDW_MBImport command) to import the data into Sterling
Gentran:Server.

5 After the session file is created, unattended processing creates the IPC file
and writes the external data information that the Translator needs to
perform an import.

7 The Translator runs the import map stores tracking information in the
ExtDataXref_tb.
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Send Process

After a file has been imported, the Sterling Gentran:Server documents that are
created can be sent to a Mailbox according to the following process:

Stage Description

1 The system creates an associated mailbox message in the Sterling
Gentran:Server Application mailbox.

2 It sends the message to the partner’s mailbox. Like the process file and
import actions, the send action has a source and target message ID
associated with the external data. However, unlike the other actions, the
external data is a message and it is related to an interchange.

3 The links between the interchange that is sent and the mailbox message to
which it is sent are preserved in the ExtDataXref_tb. When you want to
view this information, it is available in the External Data Summary
Viewer.

In this scenario, the user has selected to send multiple documents in one
interchange. After the Translator builds the interchange, the CommMgr sends the
interchange to the mailbox. While the CommMgr is sending the interchange, it
receives a message ID for the mailbox to create a message in the Sterling
Gentran:Server Application mailbox. Then, it creates an external data reference in
the ExtData_tb where the type is Message. Finally, CommMgr has enough
information to create a record in the ExtDataXref_tb linking the interchange to the
message.

Viewing and Printing Data Audit Information
Typically, you view data audit (document tracking information that is available for
a single document) to get information to help resolve a problem with a document.
These records can be viewed from any of the document browsers.

About this task

To view or print data audit information, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the desired browser.
2. To access the browser containing those documents, select the type of document

for the appropriate partner and click View.
3. Select a single document and select Commands > View.

The system displays the View Choice Dialog Box.
4. Select Data Audit and click OK.

The system displays a Document Audit window for that document.

Note: The Document Audit window contains the audit messages specific to the
selected document. The information in this window includes the severity of the
message, event ID, event name, audit number, user name, machine name, and
message.

5. To print the displayed data audit information, select File > Print.
6. Click Close to exit the Tracking window.
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Viewing and Printing Tracking Information
This function displays information that tracks an external data file. These records
can be viewed from any of the document browsers.

About this task

To view or print tracking information, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select the desired browser.
2. To access the browser containing those documents, select the type of document

for the appropriate partner and click View.
3. Select a single document and select Commands > View.

The system displays the View Choice Dialog Box.
4. Select Tracking Information and click OK.

The system displays a Tracking Information window for that document.

Note: The Tracking Information window contains an entry for each set of
correlated files. If there are more events than can be displayed in the window, a
scroll bar enables you to view the remaining records.

5. To print the displayed tracking information, select File > Print.
6. Click Close to exit the Tracking window.
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Chapter 14. Archive and Restore

Archiving Data

About Archiving
The Archive feature provides a record of past interchanges (inbound and
outbound), application data, and mailbox messages. This enables you to produce
an offline archive data file of interchanges, external data, or mailbox messages with
stored parameters (archive definitions) that you define. This archive data file can
be stored long-term.

You can also use Sterling Gentran:Server Process Control to purge and archive data
at predefined intervals.

We recommend that you archive your system data on a weekly basis. Using this
feature is critical in large volume operations.

The Archive feature enables you to archive the following types of data:
v Inbound and outbound interchanges (Sterling Gentran:Server EDI)
v Mailbox messages (and any corresponding attachments)
v External data

Note: If a document is waiting for acknowledgement processing
(acknowledgement generation or reconciliation), you will not be able to archive it
until this processing is complete.

Archive Definitions

You can completely configure the Archive feature by using stored archive
definitions. An archive definition is a set of archive parameters that you set to
specify the exact data that you want the system to archive. The system saves the
archive definition file (*.ARD file) so you can execute the same archive process
repeatedly without having to define parameters again.

See Creating an Archive Definition for more information.
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The Archive Process

The following table describes the archive process:

Stage Description

1 Define the archiving parameters (*.ARD file). The archive parameters
available depend on the type of data you are archiving.

If you archive Then the available archive parameters are

Sterling Gentran:Server EDI v partner profile ID

v whether the interchange is inbound or
outbound

v age

v processed status

v network status

v acknowledgement status

Mailbox messages v mailbox (a particular mailbox or all
mailboxes)

v location (Inbox, Outbox, or both)

v age

v status

v content type

external data v action taken

v age

2 Execute the archive process, which creates the archive files (*.ARV) in the
Archive folder.
Note: This definition can be run interactively or on a scheduled basis via
Process Control.

3 In the archive process, the system copies (or removes) data both from the
database tables and the system data store.

Archive Manager
The Archive Manager is the facility through which you archive and restore data.

The Archive Manager enables you to view the following.
v archive definition files
v summary data about the control information that was archived
v the detailed contents of the data stored in the archive data file

Notes:

v When viewing raw-EDI or external data, you can switch from Text to Hex
format by selecting the appropriate command from the View menu.

v You can sort the Archive tree by filename or by date/time.

The Archive Manager also provides you with a search facility that enables you to
quickly define search parameters that are used to find a specific piece of
information. The system displays the matching results in the How to Archive Data.
You can then select the desired information and the system highlights it in the
Archive Manager tree view.
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Archived Information

The Archive Manager retains extensive data for the information you archive and
enables you to easily view it. The user interface uses a tree structure that displays
the hierarchical levels of the archived data. This table lists the information
available for each level of the archive entry for Sterling Gentran:Server EDI,
mailbox, and external data.

Note: N/A indicates that the item is a graphical placeholder used only to illustrate
the type of data that was archived.

If you select the Then you can view

archive file at the
Sterling
Gentran:Server EDI,
mailbox, or external
data level

summary information, including the following:

v date and time the archive started

v date and time the archive ended

v number of items archived

v number of items deleted (if any)

interchange summary information, including the following:

v partner profile ID

v direction

v date and time

v interchange control number

data audit

tracking information

group summary information, including the following:

v group control number

v functional group ID

v group control key

document summary information, including the following:

v transaction ID

v transaction control number

v document name

data audit

tracking information

mailbox N/A

Inbox/Outbox N/A

message summary information, including the following:

v series ID

v message ID

v source ID

v content type

v sender ID/recipient ID

v sender name/recipient name

v sender mailbox e-mail/recipient mailbox e-mail

v subject

v status

v time message created

data audits
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If you select the Then you can view

attachment summary information, including the following:

v attachment ID

v content type

v filename

data audits

file, which is viewed either in an external viewer (the default
viewer is Notepad) or on screen in the Archive Manager.
Note: When viewing raw-EDI or external data, you can switch
from text to hex format by selecting the appropriate command
from the View menu.

external data any one of the following:

v external data type

v external data key

v action

v date and time of action

v original filename

data audits

Upper-right pane any one of the following, depending on the level and type of the
selection:

v file information (start, end, number of items archived, and if any
items were deleted)

v interchange information

v group information

v document information

v message information

v attachment information

v external data information

v data audit information

v tracking information

Lower-right pane the content of the selected attachment.

The Archive Manager Dialog Box

The following illustrates the Archive Manager, shown with the Archive tree
expanded and a Mailbox message selected:
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The following describes the parts of the Archive Manager.

Part Function

File menu Exit Archive Manager.

Archives menu Contains the following options:

v Restore data.

v Mark data for restoration (single item or all items).

v Unmark data (single item or all items).

v Refresh (archive-level).

v View data audits at the interchange, document message, or
external data level.

v View data audits and data at the interchange, document,
attachment, or external data level.

v Delete archive files.

v Search for specific archived data.

v Select how you want the Archive data sorted.

Definitions menu Contains the following options:

v Create new archive definition.

v Edit or delete archive definition.

v Archive data.

Help menu Access Archive Help and information about the Archive Manager.

Create new archive definition.

Archive data.

Mark selected item to be restored to the system.
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Part Function

Restore marked data to the system.

Left pane Archive, view, and restore data.

Upper right pane The display depends on the level and type of the selection, but
may contain any one of the following:

v file information (start, end, number of items archived, and if any
items were deleted)

v interchange information

v group information

v document information

v message information

v attachment information

v external data information

v data audit information

v tracking information

Lower right pane Displays the content of the selected interchange, document,
attachment, or external data file.

EDI Archive Definition Dialog Box
Use the EDI Archive Definition dialog box to create archive definitions for EDI
data.

The following illustrates the Sterling Gentran:Server EDI Archive Definition dialog
box:

The following describes the parts of the EDI Archive Definition dialog box.

Part Function

Name Specify the name of the archive definition file.
Note: This name must be unique.

Delete Data After
Archive

Tell the system to remove the interchange data after archiving it.

Add Accesses the Mailbox Selection Criteria Dialog Box and enables
you to define new archive criteria.
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Part Function

Edit Accesses the Mailbox Selection Criteria Dialog Box for the selected
criteria and enables you to modify the archive criteria.

Delete Deletes the selected EDI criteria from the system.
Important: The system removes the criteria without prompting
you to confirm the deletion.

Partner Displays the partner profile ID.

Direction Displays the direction of the interchanges.

Days Old Displays the age of the interchanges.

Processed Status Displays the processed status of the interchanges. The default is
All.

Network Status Displays the network status of the interchanges. The default is All.

Acknowledgement
Status

Displays the acknowledgement status of the interchanges. The
default is All.

Overdue groups and
Interchanges

Displays whether overdue groups and interchanges are archived.
The default is No.

Interchange Selection Criteria Dialog Box
Use the Interchange Selection Criteria dialog box to specify which interchanges
should be archived.

The following illustrates the Interchange Selection Criteria dialog box:

The following describes the parts of the Interchange Selection Criteria dialog box.

Part Function

Partner Select a partner profile ID (default is All).

Direction Choose Both (inbound and outbound), Inbound, or Outbound.

Days old Specify the age (in days) of the interchanges to be archived.

Archive Overdue
Groups and
Interchanges

Specify whether overdue groups and interchanges are archived.
The default is No. If selected, the system behavior prior to the
implementation of Deferred Acknowledgements is implemented
where overdue groups and interchanges are archived if the user
selects All or ReconcileOverdue for the acknowledgement status
and the direction is Both or Outbound.

If this checkbox is not selected, outbound overdue groups and
interchanges are not archived.
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Part Function

Processed Status Select the processed status of the interchanges that are to be
archived. Valid values:

v All (default)

v Received

v Sent

v ReadyToSend

v Queued

v Held

v SendFailed

Network Status Select the network status of the interchanges that are to be
archived. Valid values:

v All (default)

v NotSent

v ReceivedOK

v ReceivedWarning

v ReceivedError

v PickedUp

v ThirdParty

Ack Status Select the acknowledgement status of the interchanges that are to
be archived. Valid values:

v All (default)

v ReconcileNotRequired

v ReconcileWaiting

v ReconciledOK

v ReconciledErrors

v ReconciledPartial

v ReconciledReject

v ReconcileOverdue

Interchange Search Dialog Box
You can use the Interchange Search dialog box to search for interchanges, including
those that have been archived.

The following illustrates the Interchange Search dialog box:
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The following describes the parts of the Interchange Search dialog box.

Part Function

Partner Select a partner profile ID (default is All).

Direction Choose Both (inbound and outbound), Inbound, or Outbound.

Control No. Specify a control number.

Inbound Criteria

Received Between Define a range of dates and times to search (in YYYY/MM/DD
and HH:MM:SS format) for received interchanges.

Outbound Criteria

Processed Status Select the processed status of the interchanges to search for. Valid
values:

v All (default)

v Received

v Sent

v ReadyToSend

v Queued

v Held

v SendFailed

Network Status Select the network status of the interchanges to search for. Valid
values:

v All (default)

v NotSent

v ReceivedOK

v ReceivedWarning

v ReceivedError

v PickedUp

v ThirdParty
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Part Function

Ack Status Select the acknowledgement status of the interchanges to search
for. Valid values:

v All (default)

v ReconcileNotRequired

v ReconcileWaiting

v ReconciledOK

v ReconciledError

v ReconciledPartial

v ReconciledReject

v ReconcileOverdue

Sent Between Define a range of dates and times to search (in YYYY/MM/DD
and HH:MM:SS format) for sent interchanges.
Note: Click the arrow to access the calendar control.

Find Finds the appropriate interchanges based on the criteria you
selected and displays them in the Search Results Dialog Box.

Group Search Dialog Box
You can use the Group Search dialog box to search for groups, including those that
have been archived.

The following illustrates the Group Search dialog box:

The following describes the parts of the Group Search dialog box.

Part Function

Partner Select a partner profile ID (default is All).

Direction Choose Both (inbound and outbound), Inbound, or Outbound.

Control No. Specify control number.

Group ID Specify group identifier.

Ack Status Select the acknowledgement status of the groups to search for.
Valid values:

v All (default)

v ReconcileNotRequired

v ReconcileWaiting

v ReconciledOK

v ReconciledErrors

v ReconciledPartial

v ReconciledReject

v ReconcileOverdue
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Part Function

Find Finds the appropriate groups based on the criteria you selected
and displays them in the Search Results Dialog Box.

Document Search Dialog Box
You can use the Document Search dialog box to search for interchanges, including
those that have been archived.

The following illustrates the Document Search dialog box:

The following describes the parts of the Document Search dialog box.

Part Function

Partner Select a partner profile ID (default is All).

Direction Choose both (inbound and outbound), Inbound, or Outbound.

Control Number Specify a control number.

Trans ID Specify a transaction identifier.

Ref Data Specify the reference data from the translation object.

Document Name Specify the document name established for the translation object.

Ack Status Select the acknowledgement status of the documents to search for.
Valid values:

v All (default)

v Received

v ReconcileWaiting

v ReconciledOK

v ReconciledErrors

v ReconciledPartial

v ReconciledReject

v ReconcileOverdue

Exact Match Searches for an exact match of the field, instead of a partial match
(the default).

Find Finds the appropriate documents based on the criteria you selected
and displays them in the Search Results Dialog Box.

Mailbox Archive Definition Dialog Box
You can use the Mailbox Archive Definition dialog box to specify what messages in
a mailbox should be archived.
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The following illustrates the Mailbox Archive Definition dialog box:

The following describes the parts of the Mailbox Archive Definition dialog box.

Part Function

Name Specify the name of the archive definition file.
Note: This name must be unique.

Delete Data After
Archive

Tell the system to remove the message data after archiving it.

Add Accesses the Mailbox Selection Criteria Dialog Box and enables
you to define new archive criteria.

Edit Accesses the Mailbox Selection Criteria Dialog Box for the selected
mailbox criteria and enables you to modify the archive criteria.

Delete Deletes the selected mailbox criteria from the system.
Important: The system removes the criteria without prompting
you to confirm the deletion.

Mailbox Displays the mailbox name.

Location Displays the location of the messages.

Days Old Displays the age (in days) of the messages to be archived.

Status Displays the status of the messages that are to be archived. The
default is All.

Content type Displays the content type of the messages. The default is Any.

Mailbox Selection Criteria Dialog Box
Use the Mailbox Selection Criteria dialog box to specify which mailbox data should
be archived.

The following illustrates the Mailbox Selection Criteria dialog box:

The following describes the parts of the Mailbox Selection Criteria dialog box.
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Part Function

Mailbox Select a mailbox (default All).

Location Choose Both (Inbox and Outbox), Inbox, or Outbox.

Days old Specify the age (in days) of the messages to be archived.

Status Select the status of the messages that are to be archived. Valid
values:

v All (default)

v Delivered

v Picked Up

v Read

v Sent

v Sent Third Party

Content type Select the content type of the messages. Valid values:

v Any (default)

v Application/EDI

v Application/Document-EDI

v Application/Import

v Application/RosettaNet-agent (only if Sterling Gentran:Server
for RosettaNet is installed)

Note: This edit box allows you to enter any content type you
created.

Mailbox Search Dialog Box
The following illustrates the Mailbox Search dialog box:

The following lists the parts of the Mailbox Search dialog box and their functions:

Part Function

Mailbox Select a mailbox (default is All).

Location Choose Both (Inbox and Outbox), Inbox, or Outbox
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Part Function

Status Select the status of the messages to be archived. Valid values:

v All (default)

v Sent

v Read

v Delivered

v Picked Up

v Sent Third Party

Content type Select the content type of the messages. The default is Any, but you
can type in any content type you have created.

Created Between Define a created between range of dates and times to search (in
YYYY/MM/DD and HH:MM:SS format).
Note: Click the arrow to access the calendar control.

Sent Between Define a sent between range of dates and times to search (in
YYYY/MM/DD and HH:MM:SS format).
Note: Click the arrow to access the calendar control.

Received Between Define a received between range of dates and times to search (in
YYYY/MM/DD and HH:MM:SS format).
Note: Click the arrow to access the calendar control.

Find Finds the appropriate messages based on the criteria you selected
and displays them in the Search Results Dialog Box.

External Data Archive Definition Dialog Box
Use the External Data Archive Definition dialog box to create archive definitions
for external data.

The following illustrates the External Data Archive Definition dialog box:

The following describes the parts of the External Data Archive Definition dialog
box.

Part Function

Name Specify the name of the archive definition file.
Note: This name must be unique.

Delete Data After
Archive

Tell the system to remove the message data after archiving it. This
is selected by default.

Add Accesses the External Data Selection Criteria Dialog Box and
enables you to define new archive criteria.
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Part Function

Edit Accesses the External Data Selection Criteria Dialog Box for the
selected mailbox criteria and enables you to modify the archive
criteria.

Delete Deletes the selected external data criteria from the system.
Important: The system removes the criteria without prompting
you to confirm the deletion.

Action Taken Displays the action taken on the external data file. Value values:

v All (default value)

v ProcessFile

v MBProcessFile

v Import

v MBImport

v Send

v Export

Days old Displays the age (in days) of the external data files to be archived.

Archive Ext Data Files Displays the archived external data files.

External Data Selection Criteria Dialog Box
The following illustrates the External Data Selection Criteria dialog box:

The following describes the parts of the External Data Selection Criteria dialog box.

Part Function

Action Taken Select the action to be taken on the external data file. Value values:

v All (default value)

v ProcessFile

v MBProcessFile

v Import

v MBImport

v Send

v Export

Days old Specify the age (in days) of the external data files to be archived.

Archive Files Indicate that the external data files will be archived.
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External Data Search Dialog Box
The following illustrates the External Data Search dialog box:

The following describes the parts of the External Data Search dialog box.

Part Function

Action Taken Select the action to be taken on the external data file for which to
search. Value values:

v All (default)

v ProcessFile

v MBProcessFile

v Import

v MBImport

v Send

v Export

Action Performed
Between

Define a range of dates and times on which to search, defining
when the action was performed on the external data file (in
YYYY/MM/DD and HH:MM:SS format).
Note: Click the arrow to access the calendar control.

Original Filename Specify the original name of the external data file for which to
search.

External Data Key Specify the external data key for which to search.

Exact Match Searches for an exact match of the field, instead of a partial match
(the default).

Find Finds the appropriate messages based on the criteria you selected
and displays them in the Search Results Dialog Box.

Search Results Dialog Box
The following illustrates the Search Results dialog box, illustrating the result of a
search performed on archived mailbox messages:
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The following describes the parts of the Search Results dialog box.

Part Function

(list) Displays context-specific information, depending on whether you
searched for interchanges, groups, documents, messages, or
external data.

Mark All Marks all items in the Search Results dialog box to be restored.

Previous Selects the previous item in the list.
Note: This button is only enabled if you select an archive file.

Next Selects the next item in the list.
Note: This button is only enabled if you select an archive file.

Mark/Unmark Flags the selected item to be restored (or deselect a previously
selected item).
Note: This button is only enabled if you select an archive file.

Archive Preferences Dialog Box
The archive Preferences dialog box allows you to select the sort order of the data
in the Archive tree view and to defer the delete phase of the archive process.

To access the archive Preferences dialog box, select Preferences from the Archive
Manager menu.

Note: Also, see “Creating an Archive Definition” on page 176.

The following diagram shows the archive Preferences dialog box:
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The following table describes the parts of the archive Preferences dialog box:

Part Function

Select how you want
your archives sorted
in the display

Select one of the following methods for sorting:

v Date/Time

v Filename

Set Archive Wait
Timer

When you have selected Delete in the archive definition, the
system attempts to suspend Process Control events to ensure that
there are no conflicts with any database activity. This parameter
allows you to delay only the deletion of the data and only if an
active event is running.

If the system cannot suspend all events, it will wait for the
specified time and try again. Only one re-attempt will occur. If the
system still cannot suspend the events, a message displays stating
that the delete could not be performed because the Process Control
events could not be suspended. In addition, a message is written to
the audit log. However, the archive session will complete.
Note: This option is not activated by default.

Time Interval
(minutes)

Specify a time between 1 and 1440 minutes (24 hours) that the
archive process waits to delete data.
Notes:

v This option is only available when the Set Archive Wait Timer is
selected.

v If you enter a number outside the range, the system will display
an error message.

Creating an Archive Definition
Before archiving data, you must create an archive definition file that contains your
selection criteria.
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About this task

To create an archive definition file, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Archive.

The system displays the Archive Manager.
2. Expand the Archive tree.

Note: This is necessary to create a new archive definition.
3. Depending on what type of archive definition you want to create, right-click

Definitions under EDI, Mailbox, or External Data, and select New.
The system displays the EDI Archive Definition Dialog Box, the Mailbox
Archive Definition Dialog Box, or the External Data Archive Definition Dialog
Box.

4. In the Name box, type the name of the archive definition.
5. To remove the data from the system after archiving it, select Delete Data

After Archive.

Note: You can specify a wait timer for the archive process to delay the delete
action. See “Archive Preferences Dialog Box” on page 175 for details.

6. Click Add.
The system displays the appropriate Selection Criteria dialog box.

7. Complete the appropriate parameters.
See the following for more information:
v Interchange Selection Criteria Dialog Box
v Mailbox Selection Criteria Dialog Box
v External Data Selection Criteria Dialog Box

Note: All elements on the Selection Criteria dialog boxes are automatically set
to the defaults, which results in the archival of all data.

8. Click Save.
The system exits the Selection Criteria dialog box.
To create additional archive criteria, repeat Steps 6 through 8.

9. Click Save on the appropriate Archive Definition dialog box.
The system creates an archive definition file that contains the archive
parameters. The definition file is stored with an .ARD extension.

10. To edit the archive criteria, select the item on the appropriate Archive
Definition dialog box and click Edit.

11. To delete archive criteria, select the item on the appropriate Archive Definition
dialog box and click Delete.

Archiving Data
Before you begin

Before archiving data, you must create an archive definition file that contains your
selection criteria.

Use your company’s computer backup process to back up the Sterling
Gentran:Server system before executing the archive process.
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About this task

Note: The system naming convention for creating the archive files uses the same
name of the archive definition file, plus the unique date and time of archival, with
an .ARV file extension.

To archive data, complete the following steps:

Procedure
1. From the appropriate area of The Desk, select Archive.

The system displays the Archive Manager.
2. Expand the archive tree and open the appropriate Definitions folder.
3. Right-click the appropriate archive definition and select Archive Data.

v The system executes the archive process. An interactive progress dialog box
displays the current state of the archive process and enables you to cancel
the archive, if necessary.

v The system archives the data by the parameters you specified and creating a
new file in the Archives folder.

4. When the archive process is complete, right-click the appropriate Archive folder
in the Archive Manager tree view and select Refresh.
The system displays the archive file along with the date and time on which the
archive data file was created.

Viewing Archived Data
About this task

To view archived information, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Archive.

The system displays the Archive Manager.
2. Expand the archive tree and open the appropriate Archives folder.
3. In the Archive folder, locate the archive data file for which you want to view

the contents (summary or detailed) or search for a specific piece of data, and
click the + to the left of that file.
The system displays the archived files. When you select an archive file, the
system displays summary information for each item.

4. Select Archive > Preferences, choose how you want your archive data sorted in
the Archive tree view, and click OK.

5. To view additional information, select the appropriate level of the tree and do
one of the following:
v To view the archive file information, select the archive file.
v To view the interchange information, select the interchange.
v To view the interchange data audit, right-click the interchange and select

View > Data Audits.
v To view the interchange tracking information, right-click the interchange and

select View > Tracking Info.
v To view the interchange file, right-click the interchange and select View >

Data > External Viewer.
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v To view the interchange file, right-click the interchange and select View >
Data > Screen.

v To view the group information, select the group.
v To view the document information, select the document.
v To view the document data audit, right-click the document and select View >

Data Audits.
v To view the document tracking information, right-click the document and

View > Tracking Info.
v To view the document file, right-click the document and select View > Data

> External Viewer.
v To view the document file, right-click the document and select View > Data

> Screen.
v To view the message information, select the message.
v To view the message data audit, right-click the message and select View >

Data Audits.
v To view the attachment information, select the attachment.
v To view the attachment data audit, right-click the attachment and select View

> Data Audits.
v To view the attachment file, right-click the attachment and select View >

Data > External Viewer.
v To view the attachment file, right-click the attachment and select View >

Data > Screen.
v To view the external data information, select the external data file.
v To view the external data audit, right-click the external data file and select

View > Data Audits.
v To view the external data file, right-click the external data file and select

View > Data > External Viewer.
v To view the external data file, right-click the external data file and select

View > Data > Screen.

Searching Archived Data
The Archive Manager Search facility enables you to quickly define parameters that
are used to search all archive files or one archive file and find a specific piece of
information. You can then select the desired information, and the system highlights
it in the Archive Manager tree view.

About this task

To search for a specific piece of archived data, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Archive.

The system displays the Archive Manager.
2. From the Archive Subsystem tree, select the appropriate Archives folder

(Gentran EDI, Mailbox, or External Data).
3. From the Archives menu, select Search and then select one of the following:

v Message
v Interchange
v Group
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v Document
v External Data

4. Select the appropriate parameters.

Note: If you do not change any parameters on a search dialog box, the system
finds the default (all items).

5. Click Find to execute the search.
The system displays the Search Results Dialog Box.

6. Click Close to exit the Search Results dialog box.

Restoring Archived Data

About Restoring Archived Data
The Restore feature enables you to view and reprocess data via the Restored
Interchanges browser. This feature copies data from an archive data file back to the
active system.

When data is restored, the archive data file (*.ARV file) is not altered. You can
restore data from the same archive file again, if you wish. For restored
interchanges, you can then view the data in the Restored Interchange browser and
reprocess it, if necessary.

To restore data to your system, the following must be true:
v The item must have been deleted after it was archived.
v For message data, the original mailbox must still exist on your system.

Note: If the original mailbox does not exist, Archive Manager attempts to recreate
it. This facsimile mailbox does not contain all the properties of the original one.

As the number of archive data files created by the Archive function increases and
corresponding disk space is used, you may determine that you want to move
archive data files to tape.

Note: Copying archive files to tape is not part of the Sterling Gentran:Server
functionality. If you move an archive file to tape, the Archive Search facility is no
longer aware of the existence of the file. Files that are moved to tape cannot be
viewed while on tape. However, if you reload an archive file from tape to the
Archives folder, you can once again view the data via the Archive Manager.

Tip: Use some type of management system to track the archive files saved to tape.

Restoring Archived Data
About this task

To restore archived data, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Archive.

The system displays the Archive Manager.
2. Expand the archive tree and locate the item that you want to restore.
3. Right-click the item and select Mark\Unmark.
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The system flags that item for restoration.
4. Click Restore Data.

The marked data is restored to your system.

Note: If the system is unable to restore data, you are prompted to view the
Audit Log for detailed information about why the failure occurred.

5. Do one of the following:
v You can view a restored interchange in the Restored Interchanges browser.
v You can view a restored message in the mailbox subsystem.
v You can view a restored external data file in the External Data Summary

viewer.

Restored Interchanges Browser
The Restored Interchanges browser enables you to view a list of all interchanges,
groups, and documents that were restored from an archive file. This browser
contains status information about the interchanges, such as whether a functional
acknowledgement was received and the status of that acknowledgement.

You can perform the following functions on the Restored Interchanges browser:
v Filter the display of interchanges by date, partner, and direction (inbound and

outbound) from the Interchanges Filter dialog box.
v Display the external data, raw-EDI data, and translator report data for the

selected interchange or document in the appropriate browser panes.

Note: When viewing raw-EDI or external data, you can switch from Text to Hex
format by selecting the appropriate command from the View menu.

v Toggle the status of interchanges between Ready to Send and Hold.
v Print or delete a selected item.

Note: You might want to use the toggle function if you do not want to send an
interchange right away.

The following illustrates the Restored Interchanges browser:

The following describes the parts of the Restored Interchanges browser.

Part Function

Status bar Reflects the filer specifications from the Interchange Filter Dialog
Box.
Note: The Electronic Commerce Manager status bar is updated
when you select a single item from the middle pane.
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Part Function

left pane -
Interchanges tree

Displays a list of all the restored interchanges, groups, and
documents. Also displays the time created and partner name.
Note: To refresh the display of the Restored Interchanges browser,
press F5.

middle pane -
detailed list

Displays detailed information about the document, group, or
interchange selected. The information displayed depends on the
level.
Notes:

v To select multiple items, press and hold the CTRL key while
selecting the items.

v To refresh the display of the Interchanges browser, right-click the
middle pane and select Refresh from the shortcut menu (or press
F5).

upper right pane -
External Data

Displays the data file used in translation (when selected from the
View > Restored Interchanges menu).
Notes:

v This option only available if a single item is selected from the
detailed list.

v This option is not available if the external data file used in
translation does not exist.

v When viewing raw-EDI or External Data, you can switch from
Text to Hex format by selecting the appropriate command from
the View menu.

middle right pane -
Gentran Data

Displays the data in EDI format when selected from the View >
Restored Interchanges menu).
Notes:

v This option only available if a single item is selected from the
detailed list.

v When viewing raw-EDI or External Data, you can switch from
Text to Hex format by selecting the appropriate command from
the View menu.

lower right pane -
Translator Report

Displays a report of the actions the translator took on this
document and lists any EDI- or translation object-based compliance
errors (when selected from the View > Restored Interchanges
menu).
Note: This option only available if a single item is selected from
the detailed list.

See Error Messages in the IBM Sterling Gentran:Server for Microsoft
Windows Administration Guide, for a detailed explanation of
translator reports.

Interchanges Hierarchy

The information about the Restored Interchanges browser is organized in a
hierarchical manner. The following table describes the hierarchical organization of
the information on the Restored Interchanges browser.
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Level How to access
Information displayed (in middle
pane)�(all information may not appear)

Interchange Open Restored Interchanges
browser

v direction of the interchange

v date and time the interchange was
created

v partner name

v control number

v interchange process status

v network status

v interchange acknowledgement status

v message status

Note: If any of these components are
missing or not appropriate for a particular
interchange, they are not displayed.

Group Double-click an interchange v group control number

v group type

v group acknowledgement status

Note: If any of these components are
missing or not appropriate for a particular
group, they are not displayed.

Document Double-click a group v document compliant status

v document control number

v document type

v document name

v reference data

v document compliant status

v transaction acknowledgement status

Note: If any of these components are
missing or not appropriate for a particular
document, they are not displayed.

document
data

Double-click a document
Note: A screen entry
translation object for that
document must available on
your system.

document data

Document Level Status Icons

The following lists the status icons that the system may use at the document level
on the Restored Interchanges browser:

Status Icon Description

OK (green) - Indicates that the documents are fully compliant
with the EDI standard and are eligible for further
processing.
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Status Icon Description

NotOK (red) - Indicates one of the following:

v The document failed to comply with the EDI standard.
If this is the cause of the error, the errors will be
indicated on a translator report associated with the
document. Although the document is not fully
compliant, it is eligible for further processing.

v The received document could not be associated with a
specific trading partner. If this is the case, the partner
listed for the document will be Unknown. To associate
this document and the other documents received in the
interchange with a partner, attach the documents from
the Interchange browser.

v A suitable trading relationship or translation object
could not be associated with the document. Detailed
information concerning what information was used to
locate the relationship and/or the translation object will
be listed in the audit log. To correct this problem, a
valid relationship must be established using the Partner
Editor, and a valid export, print, or turn-around
translation object must be defined for that relationship.

v A major error occurred while processing the
interchange, functional group, or transaction level
enveloping structures. This error may include header
and trailer control numbers that do not match, an
invalid trailer control count, or a control number
sequence checking error. If any of these errors occur,
they will be listed on the translator report for the
interchange containing the document

Duplicate (yellow) - Indicates the document has the same name as
another document on the system.

Viewing Restored Interchanges
About this task

To view restored interchanges, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Restored Interchanges.

The system displays the Restored Interchanges Browser.
2. To filter the display of interchanges by status, see Filtering the Display of

Restored Interchanges.

Note: The Filter function enables you to filter the display of restored
interchanges by date, partner, and direction (inbound and outbound).

3. Select an interchange.
4. To view the content of a single selected interchange in raw EDI data format,

select View > Restored Interchanges > Gentran Data.

Note: When viewing raw-EDI or external data, you can switch from text to hex
format by selecting the appropriate command from the View menu.

5. To view the corresponding external data file, select View > Restored
Interchanges > External Data.
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Note: When viewing raw-EDI or external data, you can switch from text to hex
format by selecting the appropriate command from the View menu.

6. To view the translator report for a single selected interchange, select View >
Restored Interchanges > Translator Report.

7. To print a selected interchange or a summary of interchanges, select File >
Print.

8. To delete a selected interchange and all associated documents, select Document
> Delete.

Notes:

v If you delete an interchange with a status of Queued, you receive a warning
that you must remove specified messages from Out Documents and from
your trading partner’s Inbox. If you proceed, you are warned that if your
partner bases processing results on control number sequencing, you should
modify the transaction, group, and interchange control numbers.

v If you delete an interchange with a status of Ready to send, you are warned
that if your partner bases processing results on control number sequencing,
you should modify the transaction, group, and interchange control numbers.

Filtering the Display of Restored Interchanges
About this task

To filter restored interchanges by partner and/or date, complete the following
steps.

Procedure
1. From the appropriate area of The Desk, select Restored Interchanges.

The system displays the Restored Interchanges Browser.
2. Select Commands > Filter.

The system displays the Interchange Filter Dialog Box.
3. To filter the display of interchanges by date and time, clear the No Date/Time

Checking check box. Otherwise, select No Date/Time Checking and proceed
with step 6.

4. Use the Date From slide bar to select the beginning of the date range from
which the system should filter the display of interchanges.

5. To set the end date for the date range to the current system date and time,
select Always Current. Otherwise, clear the Always Current check box and
move the Date To slide bar to the end of the date range.

6. To filter the display of restored interchanges by partner, select the partners that
you want displayed from the Partner list (which contains a list of all the
partner profiles on your system).

Note: The default display is all partners, but you can click partner profiles to
unselect them and change the display. Alternately, you can click Unselect All
Partners to clear all the partner profiles. You can then click one or more profiles
to select them. At least one partner must be selected.

7. Specify the direction in which you want to filter the interchange.
The default display is both inbound and outbound interchanges.

Note: At least one of the Direction check boxes must be selected.
8. Click OK.
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The system filters the restored interchange display based on the criteria you
selected.

Viewing Restored Documents
You can view the individual documents in an interchange as long as a screen entry
translation object for each document is available on your system.

About this task

To view the documents within a restored interchange, complete the following
steps.

Procedure
1. From the appropriate area of The Desk, select Restored Interchanges.

The system displays the Restored Interchanges Browser.
2. Double-click a document to view it.

Note: You must have a screen entry translation object for this document
available on your system.

3. To view a translator report of the actions the translator took on this document,
select View > Interchanges > Translator Report.

4. To view the content of a single selected interchange in raw EDI data format,
select View > Interchanges > Gentran Data.

Note: When viewing raw-EDI or external data, you can switch from text to hex
format by selecting the appropriate command from the View menu.

5. To view the related external data of a single selected interchange, select View >
Interchanges > Related External Data.When viewing raw-EDI or external data,
you can switch from text to hex format by selecting the appropriate command
from the View menu.

6. To print a selected document or translation report, select File > Print.
7. To delete a selected document, select Document > Delete.
8. To copy the document to the appropriate browser, select Document > Copy,

then select the appropriate browser from the submenu. ?In Documents Browser
or In Documents Browser for compliant Inbound documents. Workspace
Browser for outbound documents.

Reprocessing Restored Documents
To reprocess data from the Restored Interchanges browser, you must use the Copy
command to move the selected outbound documents to the Workspace and the
compliant inbound documents to the In Documents or ?In Documents browsers.

About this task

To reprocess data, complete the following steps.

Procedure
1. From the appropriate area of The Desk, select Restored Interchanges.

The system displays the Restored Interchanges Browser.
2. Select the documents that you wish to copy to the Workspace Browser, In

Documents Browser, or ?In Documents Browser so you can reprocess and/or
resend them.
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3. Select Document > Copy.
4. Select the appropriate browser from the cascading menu to copy the restored

interchanges to that browser.

Resending Restored Interchanges
To resend outbound interchanges from the Restored Interchanges browser, you
must use the Resend command.

About this task

Note: You can only resend interchanges that were previously sent or that have a
status of Ready to send.

The following table describes the process that occurs when you resend a selected
interchange.

Stage Description

1 The restored interchange is listed in the Restored Interchanges Browser.

2 When the resend command is executed, the system first determines if it is
a TRADACOMS interchange. If the interchange is TRADACOMS, the
system increments the current version number in the FIL segment by one.
After this update, the interchange is resent in the same manner as all other
interchanges.

3 Communication is established with the remote end. The status of the
message is updated based on the success or failure of the communications
session.

v If the communication fails because there is no mailbox set up or because
the Mailbox service is not started, the interchange and documents are
left in a Ready to send status.

v If communication fails because there is no modem, the interchange and
documents are left in a Queued status.

Note: No user action is required at this point. Interchanges that failed to
send are automatically sent as part of the next transmission session.

4 After communication is successful, the documents are moved to the Out
Drawer Browser and the interchange status is set to Sent.

To resend restored outbound interchanges, complete the following steps:

Procedure
1. From the appropriate area of The Desk, select Restored Interchanges.

The system displays the Restored Interchanges Browser.
2. Select the outbound interchange that needs to be resent.
3. Select Document > Resend.
4. Click Yes to start the transmission session.
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Chapter 15. Process Control

About Process Control
The process control feature enables you to automate your message processing.
Essentially, you need to tell the system what you want done and when, and
process control takes care of it for you automatically.

With process control, you can build customized events to initiate the processing
functions of Sterling Gentran:Server. These processing functions include the
following.
v importing data from your application files
v exporting data to your application files
v sending
v receiving

In addition, file and process management functions can be executed that provide
additional flexibility in integrating your application with Sterling Gentran:Server.

Process control is regulated by events, which are a combination of what you want
done (a session) and when to process a session (calendar, days, a date, or based on
whether or not a file exists). The following describes the event creation process:

Stage Description

1 Create a process control session.

See Creating Sessions for more information.

2 Create a process control calendar (if necessary).

See Creating and Editing Calendars for more information.

3 Create the process control event.

See Creating New Events for more information.

4 Activate the event.

See Activating and Suspending Events for more information.

Sessions

About Sessions
A session definition is an integral part of a process control event. The session setup
process enables you to configure and edit process control session scripts. Sessions
are defined independently from the event, so the same session definition can be
scheduled multiple times.

A session script consists of a list of commands (Sterling Gentran:Server functions)
that the system executes in the sequence listed. You can set parameters for each
allowable command. You can also place conditions on the command you choose.
These conditions determine whether or not the command is executed within the
session.
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You can specify two types of conditions: The system can query for the presence or
absence of a specific file; the system can determine whether or not documents exist
in a specific location. If the evaluated condition is true, the command is executed.
If the condition is false, the command is skipped and processing continues with
the next defined command.

Commands

The following lists the script commands and their actions:

Command Action

Exec_Program Indicates a program for the system to run.
Note: When this command is executed, the system writes an
informational message to the Audit Log indicating which program
(command line in working directory) was run.

Exec_Program_Ex Indicates a program for the system to run and for which the
system will pass the Event ID and controller name.
Note: This function is used by the Sterling Gentran:Server for
RosettaNet install program.

File_Copy Copies a file.
Note: When this command is executed, the system writes an
informational message to the Audit Log indicating that the file
copy was successful.

File_Rename Changes the name of a file.

File_Delete Removes a file from the system.
Note: When this command is executed, the system writes an
informational message to the Audit Log indicating that the deletion
of the file was successful.

GDW_Archive Performs the archive command according to the specifications of a
selected archive definition file.

GDW_Audit_Rpt Copies the audit records to a specified file.

GDW_Audit_Purge Deletes all audit records in the system.
Note: The purged Audit Log entries are removed from the
database and appended to a text file. To ensure that the text file
does not grow unchecked, you may want to use a File_Delete
command prior to this command.

GDW_Audit_Write Writes a processing user audit message to the Audit Log, based on
the specified parameters.

GDW_Document_
Purge

Removes document records from the Sterling Gentran:Server
database according to the specified age/date, location, partner
name, transaction, and/or status.

GDW_Document_Rpt Creates a specified file that contains document data (as well as
group and interchange data, if applicable) for documents in the
Sterling Gentran:Server database according to the specified status,
location, and/or age/date.

GDW_Export Performs the Export function and can perform the send mailbox
function to enable the output of an inbound translation to be
delivered back to the Mailbox Server Manager.
Note: You must have an export translation object registered with
the system.

GDW_ExtData_Delete Deletes external data references based on the action taken on the
external data and/or age.
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Command Action

GDW_Import Performs the Import function on a specified file.
Note: You must have an import translation object registered with
the system.

GDW_Notify_Purge Deletes all notification records in the system or deletes them by
age, if specified.
Note: The purged notification log entries are removed from the
database and appended to a text file. To ensure that the text file
does not grow unchecked, you may want to use a File_Delete
command prior to this command.

GDW_Partner_Delete Executes the partner delete command.

GDW_Partner_Import Executes the partner import command.

GDW_Partner_Export Executes the partner export command.

GDW_Print Performs the Print function.
Note: You must have a print translation object registered with the
system.

GDW_Process_File Invokes the post-communications process with any EDI file as if
the file was received via a communication session.
Note: You must have an export translation object registered with
the system.

GDW_Receive Performs the Receive Only function.

GDW_Send Performs an automated send for all partners and mailboxes that
have documents posted to be sent (unless you specify a particular
partner, mailbox, and transaction combination).

GDW_Send_Receive Performs the Send/Receive function. This function does not wait
for previously executed Send/Receive sessions to finish; it executes
the Send/Receive when you specify.

Inbound_Recovery Executes the Executive service inbound mailbox recovery.

Outbound_Recovery Executes the Executive service outbound mailbox recovery.

Terminate_Script Terminates the script.

The following lists the script conditions and their actions:

If the condition is... Then it indicates that...

If File Below Exists the system must look for the file you specify and then execute the
command based on whether the file is found or not found.

If Docs Are In the
Location Below

the system must look for the documents in the location you specify
and then execute the command based on whether or not the
documents are found in that location.
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Process Control Dialog Box - Sessions Tab
The following illustrates the Sessions tab of the Process Control dialog box:

The following describes the parts of the Process Control dialog box Session tab.

Part Function

(list) Displays all currently defined session scripts.

Session Displays the script of the currently-selected session.

Ins Accesses the Action Setup dialog box so you can insert a script
command above the current line.

Edit Accesses the Action Setup dialog box so you can modify the
selected script command.

Delete Deletes the selected script command.

Up Moves the selected command up one line in the script.

Down Moves the selected command down one line in the script.

Action Setup Dialog Box
The following illustrates the Action Setup dialog box:

The following describes the parts of the Action Setup dialog box.

Part Function

Command
Specification

Select which command you want to add to the script.
Note: Selecting a command allows you to access the parameters
for that command, which the system displays in the Command
Setup section.
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Part Function

Write to Audit Log if
execution time
exceeds

Specify that the system write an audit message if the command
execution time exceeds the specified number of minutes (next
field).
Note: If a command exceeds the allotted time, the system writes a
warning message to the Audit Log and the command continues to
run until it completes.

minutes Specify the number of minutes after which the system writes a
message to the Audit Log if the command has not finished
processing.

Condition Select conditions for the command. These conditions determine
whether or not the command is executed within the session.
Notes:

v Each script command can have an associated condition. These
conditions are evaluated just prior to execution of the command
and can be used to control the processing flow of your session.

v If you select the "If file Below Exists" condition, you can use a
wildcard (*) to specify the name of the file for which you want
the system to check.

v In the Result list, if you select True, you are indicating that the
command should be executed only if there are documents in the
specific location or if the file is present. If you select False, you
are indicating that the command should be executed only if
there are no documents in the specific location or if the specified
file does not exist.

Creating and Editing Sessions
If an event calls a session that is currently processing or is activated, you are
unable to edit and save the session until the event has either finished processing or
you suspend the event. However, you can edit the session and use the Save As
function to save it under another name.

About this task

To create a process control session, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Sessions tab.
3. To create a new session, do the following:

a. Click New.
b. In the Session Name box, type in the new session name, using

alphanumeric characters.
c. Click OK to add the new session.

4. Select your session and click Ins to insert a command above the current line.
The system displays the Action Setup dialog box. This dialog box allows you
to create script commands.

5. In the Command Specification section, do the following:
a. From the Command list, select a command.
b. Complete the boxes with the appropriate values.
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c. To specify a limit on how long this command should process before the
system writes a message to the Audit Log, select the check box and type
the number of minutes in the box.

6. If you want to apply a condition, in the Condition section do the following:
a. Select a condition from the list.
b. Complete the boxes with the appropriate values.

7. Select True or False from the Result list.
8. Click OK.

The command is saved and you return to the Process Control dialog box.
Repeat Steps 1 through 13 until you finish adding commands to the session
script.

Notes:

v If you need to resequence the commands in the script, use Up and Down.
v If you need to edit a command in the script, select that command and click

Edit.
v If you need to delete a command from a script, select that command and

click Delete.
9. Click Save to save the new session script.

10. Click OK to exit the Process Control dialog box.

Deleting Sessions
If an event calls a session that is currently processing or is activated, you are
unable to delete the session until the event has either finished processing or you
suspend the event.

About this task

To delete a session, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Sessions tab.
3. Select a session and click Delete.
4. Click Yes to delete the current selection.
5. Click OK to exit the Process Control dialog box.

Events

About Events
The Process Control enables you to process an event at a specified time, every day.
Additional options enable you to restrict processing to certain days of the week or
a specific date. In addition, you can define calendars to exclude specific holidays or
days of the week from the processing schedule.

Events are a combination of the following:
v A time or day to execute or a filename for which the system checks
v The controller on which the event is processed
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v A session definition

The Process Control runs events based on whether they are timed or polled. You
define the events in a session definition.

You manage events by using the following dialog boxes:
v Process Control dialog box (Events tab)
v Event Setup dialog box
v Process Control dialog box (Active Events tab)

You must have already defined the session definition to be executed before
creating an event.

When a timed event is activated, the Sterling Gentran:Server Scheduler initiates
that event at the correct time on the appropriate day or date.

When a polled event is activated, the Sterling Gentran:Server Poller polls the
controller for the presence or absence of a defined file (depending on what is
indicated in the event definition), and initiates the event when the specified file
either exists or does not exist (based on the event definition).

Process Control Dialog Box - Events Tab
The Sterling Gentran:Server Process Control dialog enables you to view all the
events defined in your system.

On the Events tab, the following specifications are listed for each event:
v Event description
v Time
v Parameters (day of week if timed or result if polled)
v Controller on which the event runs
v Time started
v Time ended
v Session name
v Calendar name (timed events only)
v File name (polled events only)

You can filter the display of events on the Events tab by the controller on which
the events are scheduled to run. You can also sort the events by description,
controller, and status.

The Events tab enables you to change the status of an event by activating or
suspending the event. The indicator in the far left column of the list on the Events
tab registers the status of the event. The indicator can be one of the following
colors:
v Red - The event is currently executing and you are not able to edit the event

until processing completes.
v Yellow - The event is suspended (and is not processed until activated).
v Green - The event is activated for processing.
v Green with red x - The event is activated for processing but is currently blocked

because the number of currently processing events is equal to the limit of events
that may concurrently execute.
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The following illustrates the Events tab of the Process Control dialog box:

The following describes the parts of the Process Control dialog box Events tab.

Part Function

(list) Displays all scheduled events.

Controller Select the controller whose events you want filtered.

Sort Select how you want the list of events sorted:

If you sort by... Then the events are listed...

description (the
default)

in alphabetic order of the event
descriptions.

controller in alphabetic order by controller.
Note: For each controller, the events are
listed in alphabetic order by event
description.

status by currently processing events first (red
indicator), activated events second (green
indicator), and suspended events third
(yellow indicator).
Note: Within each status, the events are
listed in alphabetic order by event
description.

Seconds Specify the interval (in seconds) at which you want the system to
refresh the dialog box (default is 20 seconds).

Auto Refresh Indicate whether you want the Process Control dialog box to
automatically refresh (so you do not have to click Refresh).

Activate/Suspend v If a selected event is suspended (yellow indicator), the
Activate/Suspend toggle button reads Activate.

v If a selected event is activated (green indicator), the
Activate/Suspend toggle button reads Suspend.
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Part Function

Execute Executes the selected event immediately, which allows you to
manually invoke an unattended session. This also enables you to
test a new event or an event that failed.
Notes:

v Executing an event immediately using this button does not
replace the next scheduled run of the event.

v When you click this button, an informational message box is
displayed.

v If the selected event is scheduled to execute within the next 30
minutes, you are notified when the event is scheduled to run
and prompted to specify whether you want to run it now (click
OK) or cancel the request (click Cancel).

v If the selected event is not scheduled to execute within the next
30 minutes, you are prompted to either confirm the request to
execute it immediately (click OK) or cancel the request (click
Cancel).

Refresh Refreshes the display of the Events tab.

Event Setup Dialog Box
The following illustrates the Event Setup dialog box:

The following describes the parts of the Event Setup dialog box.

Part Function

Description Enter a description of the event.

Session Select one of the sessions you defined on the Sessions tab.

Controller Specify the name of the controller on which the event is run.

Notification Type
Event

Designate this event as a “notify type,” which means that the
system executes it based on parameters set in the Notification Log.
Note: Selecting this check box deactivates the Timed and Polled
tabs.

Timed tab

Start Indicate the beginning run time of a session.
Note: You must enter the time in 24-hour HH:MM format. If you
do not enter the time in this format, the system attempts to
determine the correct 24 hour time from what you entered.
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Part Function

Until Specify a stop time for the event.
Notes:

v You can either use 24-hour HH:MM format or 12-hour HH:MM
or H:MM format with the designator "a" (am) or "p" (pm).

v An event will always execute on its end time regardless of the
interval that is set. To have an event execute once, do not enter
an end time or interval.

Minutes Specify an interval of time after which the event is to be executed.

For example, if you specify "15" minutes, the event is executed
every 15 minutes.

Calendar Select one of the calendars you defined on the Calendars tab that
you want the system to check against when scheduling this
session.
Notes:

v A calendar allows you to specify days in each month that you
do not want the selected session to be run.

v If you use the Date box, you cannot use the Calendar box.

Sun/Mon/Tue/Wed/
Thu/Fri/Sat

Indicate which days of the week the event is to be executed.
Note: By default, every day of the week is selected. If any days are
selected in this section, then the schedule is executed only on those
days. If you select days from this section, you cannot use the Date
box.

Date Specify a date on which the event is to be executed.
Notes:

v This enables you to specify a date on which this session should
run one time only. The system then removes the session from the
database.

v You can enter this date in any format, but the sequence of the
date you enter must correspond to the international Windows
date formats (for example, in the United State, dates must be
entered in month/day/year format).

v If you select a calendar from the Calendar box or days of the
week, you cannot use the Date box.

Polled tab

File name Specify the name of the file for which the system checks.
Note: You can use a wildcard (*) to specify the name of the file.

Browse Accesses the Choose Network Server dialog box so you can browse
for the file for which you want the system to check.

Result Indicate whether the event should be executed if the result is True
or False.
Notes:

v If you select True, you are indicating that the event should be
executed only when the specified file is present.

v If you select False, you are indicating that the event should be
executed only when the specified file does not exist.

Process Control Dialog Box - Active Events Tab
The Active Events tab enables you to view only the events that are currently
processing. This feature also allows you to view currently processing system events
(such as temporary communication sessions).
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On the Active Events tab, all currently processing events and the controller on
which each event are being processed are listed in the Event list (on the left side of
the dialog).

The Session list (on the right side of the Active Events tab) displays the session
script for the event that is currently selected in the Events list. The Session list also
contains all of the parameters for each command. This detailed view enables you
to see which programs are currently being executed by the Sterling Gentran:Server
Executive. The session command that is currently being processed is indicated with
a green arrow.

The following illustrates the Active Events tab of the Process Control dialog box:

The following describes the parts of the Process Control dialog box Active Events
tab.

Part Function

(Event list) Displays the events that are currently processing.

(Session list) Lists each command and the associated parameters for the session
script for the event that is currently processing.

A green arrow indicates which command the system is currently
processing.

Refresh Events
seconds

Specify the default interval (10 seconds) for refreshing the Active
Events list. Valid values are 2 –300 seconds.

v This value is saved when you change focus on the dialog box
(click another box).

v The Auto Refresh check box must be selected (checked) for the
Seconds boxes to be available.

Refresh Actions
seconds

Specify the default interval (2 seconds) for refreshing the Sessions
list. Valid values are 2 seconds – 300 seconds.

v This value is saved when you change focus on the dialog box
(click another box).

v The Auto Refresh check box must be selected (checked) for the
Seconds boxes to be available.

Auto Refresh Indicate whether you want automatic refresh enabled. The default
is Enabled, which means that you do not have to click Refresh.
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Part Function

Refresh Manually refreshes the Active Events display.

If the Active Events tab has not been refreshed after an event has
expired (is no longer active), the system continues to display the
event on the Active Events tab (even though it is inactive), until
the Active Events tab is refreshed.

Creating and Editing Events
You can specify that the event runs as timed or as polled. You are not able to edit
an event unless the event is suspended.

About this task

If the event is running as timed, you must specify a time, a pre-defined calendar
and/or days of the week to run, or a date to run one time only. When it is time for
the event to be run, the Sterling Gentran:Server Scheduler service initiates the
processing of the event.

If the event is running as polled, you can specify a file name and whether the
event should run if the file exists or not. The Sterling Gentran:Server Poller service
polls the process controller.
v If you specified that the file must exist, the Poller initiates the processing of the

event when the file appears.
v If you specified that the file must not exist, the Poller initiates the processing of

the event when the file no longer exists on the controller.

To create a new event, complete the following steps:

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Events tab.
3. Click either New or Edit.

The system displays the Event Setup dialog box so you can create a new event
entry.

4. In the Description box, type a description of the event.
5. From the Session list, select the session that you want to be executed.
6. In the Controller box, type or select the machine name of the controller on

which you want this event to be run.
7. For notification events, select the Notification Type Event check box and

continue with Step 17. Otherwise, continue with the next step.
8. For timed events, you must specify times and days that the event should run.

Do the following:
a. Enter a starting time.
b. If you want to specify a stop time for the event, type that time in the Until

box.
c. To specify an interval of time after which the event is run, type the

number of minutes after which you want the event to be executed.
d. To use a predefined calendar, select that calendar from the Calendar list.
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Note: If you select a calendar, you cannot use a specific date.
e. Select a day or days of the week on which you want this session to be

scheduled

Note: If you select days of the week, you cannot use a specific date.
f. To specify a date on which you want this session to run one time only, type

that date in the Date box.

Note: If you use a specific date, you cannot select from the days of the
week.

9. For polled events, do the following:
a. Click the Polled tab.
b. Navigate to or type the path and name of the file for which you want the

system to check.
c. From the Result list, select True or False.

10. Click OK.
The event is saved and you exit the Event Setup dialog box.

11. Click OK.
The system exits the Process Control dialog box.

Deleting Events
You are not able to delete an event unless the event is suspended.

About this task

To delete an event, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Events tab.
3. Select an event and click Delete.
4. Click OK to confirm the deletion.
5. Click OK.

The system exits the Process Control dialog box.

Viewing All Events
About this task

To view all events, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Events tab.
3. If you want to filter events by the controller on which the events are run, select

that controller from the Controller list.
4. You can sort by any of the following options:

v Description (default)
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v Controller
v Status - Events are listed by:

– currently processing events (red indicator)
– blocked events (green indicator with red X)
– activated events (green indicator)
– suspended events (yellow indicator)

5. If necessary, change the Refresh options:
v If you want to change the interval in which the dialog box is automatically

refreshed, in the Seconds box, type the interval (in seconds) at which you
want to refresh the dialog box (the default is 20 seconds). Valid values are 2
– 300 seconds.

Note: This value is saved when you change focus on the dialog box (click
another box). The Auto Refresh check box must be selected (checked) for the
Seconds box to be available.

v If you do not want the Events tab to automatically refresh, click the Auto
Refresh check box to deselect it.

Note: The default for automatic refresh (so you do not have to click Refresh)
is enabled (checked).

6. Click OK.
The system exits the Process Control dialog box.

Viewing Active Events
About this task

To view active events, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. From the Event list, select the event for which you want to view further detail.

The system displays each command and its associated parameters in the
session script for that event in the Session list. The session command currently
being processed is indicated with a green arrow.

3. If necessary, change the Refresh options:
v If you want to change the interval in which the dialog box is automatically

refreshed, in the Seconds box, type the interval (in seconds) at which you
want to refresh the dialog box (the default is 20 seconds). Valid values are 2
– 300 seconds.

Note: This value is saved when you change focus on the dialog box (click
another box). The Auto Refresh check box must be selected (checked) for the
Seconds box to be available.

v If you do not want the Events tab to automatically refresh, click the Auto
Refresh check box to deselect it.

Notes:

v The default for automatic refresh (so you do not have to click Refresh) is
enabled (checked).

v The default interval for refreshing the Event list is 10 seconds.

202 IBM Sterling Gentran:Server for Microsoft Windows: User Guide



v The default for refreshing the display of the Session list is 2 seconds.
v If the Active Events tab has not been refreshed after an event has expired (is

no longer active), the system displays the event on the Active Events tab
(even though it is inactive), until the Active Events tab is refreshed.

4. Click OK.
The system exits the Process Control dialog box.

Activating an Event
About this task

To activate an event, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Events tab.
3. Select the suspended event that you want to activate and click Activate.
4. Click OK.

The system exits the Process Control dialog box.

Suspending an Event
About this task

To suspend an event, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Events tab.
3. Select the activated event that you want to suspend and click Suspend.

Note: If an event is currently processing, you are not able to suspend it until
processing has terminated.

4. Click OK.
The system exits the Process Control dialog box.

Executing an Event Immediately
The Events tab of the Sterling Gentran:Server Process Control dialog enables you
to execute the selected event immediately. This function allows you to manually
invoke an unattended session and also enables you to test a new event or an event
that failed.

About this task

To execute an event immediately, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Events tab.
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3. Select the suspended event that you want to execute immediately and click
Execute.

4. Either click OK to run the event immediately or click Cancel (the event will
execute at its scheduled time).

5. Click OK.
The system exits the Process Control dialog box.

Calendars

Process Control Dialog Box - Calendars Tab
The process control Calendar feature enables you to configure system calendars
that excludes specific dates (such as holidays) or days of the week from processing.

Like session definitions, these calendars are defined independently from the event,
so that they can be “attached” to multiple event entries. The calendar begins with
the current month and year.

The following illustrates the Calendars tab of the Process Control dialog box:

The following describes the parts of the Process Control dialog box Calendars tab.

Part Function

(Calendars list) Displays a list of all defined calendars.

(Calendar) Displays the current month of the selected calendar.

Previous Displays the previous month in the calendar.
Note: This button is only activated if a calendar is selected and a
previous month exists for the calendar.

Next Displays the next month in the calendar.
Note: This button is only activated if a calendar is selected.

Exclude Select which days of the week to exclude from processing. These
are displayed with red Xs through them.

New Accesses the New Calendar dialog box so you can create a new
calendar.

Save Saves the current calendar.
Note: The Save command is only active if a calendar is displayed
in the middle of the dialog box.

Save As Saves the current calendar under another name.
Note: The Save As command is only active if a calendar is
displayed in the middle of the dialog box.
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Part Function

Delete Deletes the selected calendar.

Creating and Editing Calendars
About this task

To create or edit a calendar, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Calendars tab.
3. To create a new calendar, click New. Otherwise, select the calendar that you

want to edit and continue with Step 6.
4. In the Calendar Name box, type the new calendar name using up to 8

alphanumeric characters.
5. Click OK to add the new calendar.

The system displays the new calendar in the middle of the Calendars tab.
6. To exclude a specific date from processing, click that date on the calendar.

Note: The system displays a mark for that date on the calendar to signify that
it is excluded from processing. Click Previous or Next to access the preceding
or succeeding calendar months in the calendar.

7. To exclude a specific day or days of the week, select the check box in the
Exclude section for each day of the week that you want to exclude from
processing.

Notes:

v You can select one or more days of the week on which you never want
processing to occur.

v The system allows you to exclude all seven days of the week, if that is your
intention. In this situation, processing never occurs.

v To deselect a day, clear the check box.
8. Click Save to save the new calendar.
9. Click OK.

The system exits the Process Control dialog box.

Deleting Calendars
About this task

To delete a calendar, complete the following steps.

Procedure
1. On The Desk, click Process Control.

The system displays the Process Control dialog box.
2. Click the Calendars tab.
3. Select a calendar and click Delete to delete the current selection.
4. Click Yes to delete the current selection.
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5. Click OK.
The system exits the Process Control dialog box.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law

IBM Japan Ltd.

19-21, Nihonbashi-Hakozakicho, Chuo-ku

Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

J46A/G4

555 Bailey Avenue

San Jose, CA 95141-1003

U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.
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This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© IBM 2015. Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2015.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise®, Gentran®,
Gentran:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™,
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce®, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.
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