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Chapter 1. Getting Started

About this Tutorial
This tutorial for the Sterling Gentran:Server® Forms Integration subsystem
references the ANSI X12, EDIFACT, and TRADACOMS standards. Any sections in
this tutorial that do not apply to all three standards are marked with the applicable
standard name. If a section heading does not include a standard name, then the
section applies to all three standards. In some tasks, the steps and information
apply to all three standards but a specific detail may be different, such as a field
name. For example:

In the "What is the name of the form" box, enter one of the following:
v Print 850 Pet Zone (for ANSI X12)
v Print ORDERS Pet Zone (for EDIFACT)
v Print TRADACOMS ORDERS Pet Zone (for TRADACOMS)

This tutorial includes a print example (purchase order) and a screen entry example
(invoice). This tutorial defines the tasks necessary to create forms and describes
how to customize and format a form before it is compiled into a translation object.
A print form enables you to print customized EDI data that has been processed
through the translation object. A screen entry form is a predesigned layout that,
when compiled into a translation object, enables users in your company to enter
the data necessary to create a business document.

The form that you create is a source form. When that source form is compiled, the
result is a compiled translation object. You must register the translation object with
Sterling Gentran:Server to be able to use the translation object to enter EDI data in
messages of that type.

To access reference information, refer to the IBM® Sterling Gentran:Server for
Microsoft Windows Forms Integration User Guide. For additional information on the
various tasks described in this guide, refer to the IBM Sterling Gentran:Server for
Microsoft Windows User Guide.

This guide assumes that you are familiar with using a PC and with Microsoft
Windows functions, including:
v The terminology used to describe mouse and cursor actions.
v The terminology used to describe Windows-specific attributes, including dialog

boxes, icons, windows, and buttons.
v Using the Windows Program Manager.

The Forms Integration Subsystem
A form is a set of instructions you define in the Forms Integration subsystem that
indicates how the system should format data. When you compile the form, Sterling
Gentran:Server generates a translation object. After you register the translation
object with Sterling Gentran:Server and associate the translation object with a
partner relationship, the system uses the translation object to format EDI
documents. The Forms Integration subsystem enables you to create print and
screen entry translation objects.
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Regardless of whether the translation object is print or screen entry, Sterling
Gentran:Server generates the actual format of the translation object based on the
EDI file format (in the EDI File Format Pane) and displays it in the Layout Pane.

A print translation object organizes and formats the printout of EDI documents
that are received from or sent to the trading partners for which you have
established a trading relationship that uses that print translation objects. The print
translation object enables you to view the EDI document in an easy-to-read format.

A screen entry translation object provides a standardized format for entering an
EDI document into the Document Editor for translation and transmission to your
trading partners. The screen entry translation object ensures that your users enter
all the data necessary to create the required EDI document.

Sterling Gentran:Server generates the translation object format based on the EDI
file format in the EDI File Format Pane and displays that format in the Layout
Pane.

Forms Integration Window
The following diagram illustrates the Forms Integration Window. (This is an ANSI
X12 example.)

This table describes the Forms Integration window components.

Part Function

Main Menu Bar Contains drop-down menus. Unavailable items are dimmed.

2 IBM Sterling Gentran:Server for Windows: Forms Integration Tutorial for Screen Entry Forms



Part Function

Main Toolbar Enables you access to some of the most common operations in the
Application Integration subsystem. Unavailable items are dimmed. The
Main Toolbar is a dockable toolbar, so you can affix it to any edge of
the client window.

EDI File Format
Pane

Cntains the EDI file format. When you click a segment or group in the
EDI file format, the corresponding frame is displayed in the Layout
Pane. When you click an element in the EDI file format, the
corresponding layout component is highlighted in the Layout Pane.

Layout Pane Contains the format of the translation object. Each group (with a
maximum usage greater than one) and repeating segment has a
corresponding frame in the Layout Pane. When you click a segment or
group in the EDI file format, the corresponding frame is displayed in
the Layout Pane. When you click an element in the EDI file format, the
corresponding layout component is highlighted in the Layout Pane.

Status Bar Displays status information about a selection, command, or process,
defines menu items as you highlight each item in the menu, and
indicates any current keyboard-initiated modes for typing (e.g., CAP
for the "Caps Lock" key, NUM for the "Num Lock" key, etc.).

The Main Toolbar gives you access to some of the most common operations in
Sterling Gentran:Server. Unavailable items are dimmed. The Main Toolbar is a
dockable toolbar, so you can affix it to any edge of the client window. This
diagram illustrates the Main Toolbar.

EDI File Format Pane
The EDI File Format Pane (left side of the Forms Integration subsystem main
window) contains the EDI file format. The EDI file must contain all the
information that you need to include to either create a document using the
Document Editor (screen entry translation object) or print documents (print
translation object), so that your system can accurately process the data.

Generating EDI files

Sterling Gentran:Server generates an EDI file for you, based on the standard
(agency), version, transaction set, and release (for the TRADACOMS standard
only) you selected. The system includes all the groups, segments, composites, and
elements that are defined by the standards agency for the version of the document
you selected.

You typically need to customize the system-generated EDI file by modifying the
properties of the form components, and using specialized Sterling Gentran:Server
functions to manipulate the EDI file structure.
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Generating specialized EDI standard versions

If you want to use a specialized version of an EDI standard that is not available in
the IBM Sterling Gentran® Standards Database for EDI, it may be appropriate for
you to define the EDI file yourself.

Regardless of whether the system generates the EDI file or you define it, the
specific EDI form components that you use depend on the type of form you are
creating. This includes the standard, version, and transaction set (document)
selected, and which groups, segments, composites, and elements your company
requires.

We recommend that you determine which form components you are using before
generating or defining an EDI file.

Form components

This table describes form components that Sterling Gentran:Server uses to define
the EDI file format.

Icon Description

Group A group is a looping structure that contains related segments and/or groups
that repeat in sequence until either the group data ends or the maximum
number of times that the loop is allowed to repeat is exhausted. Groups are
defined by the EDI standards. A group that is subordinate to another group
is a subgroup (this corresponds to a nested looping structure – a loop within
a loop). The EDI file is a group and therefore, it is visually represented the
same way as other groups and subgroups in Sterling Gentran:Server.

Segment A segment contains a group of related elements or composite data elements
that combine to communicate useful data. Segments are defined by the EDI
standards. A segment can occur once or can repeat multiple times.

Maximum use: Refers to the number of times that a segment can be used
within the structure in which the segment is defined. For example, if a
segment can be used only once within a group, but the group can be used
multiple times, the segment still has a maximum use of one within each
occurrence of the group. The standard defines the maximum number of
times a segment can be used, but you must determine how many times a
segment is used, based on what you are sending your trading partner.

Composite A composite is a data element that contains two or more component data
elements or subelements. Composites are defined by the EDI standards that
use them (EDIFACT, TRADACOMS, and certain ANSI X12 standards).

Element An element is the smallest piece of information defined by the EDI
standards.

v When an element has an operation performed against it, a red checkmark
is displayed over the element icon.

v When an element contains a standard or extended rule, a black asterisk
appears to the right of the element icon.
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Layout Pane
The Layout Pane (right side of the Forms Integration subsystem main window)
contains the actual format of the translation object. Sterling Gentran:Server uses
frames to format the EDI file for the translation object. Each frame contains the
groups, repeating segments, and elements at that level (single segments are not
represented on the frame).

For screen entry translation objects, groups (with a maximum usage greater than
one) and repeating segments are formatted as lists. Elements are formatted as edit
boxes (fields) or drop-down lists on the frame. Elements are typically formatted as
fields, but are formatted as a drop-down list if you apply a standard rule that
allows a selection of multiple items. Each group and repeating segment also has a
corresponding frame that contains all the groups (with a maximum usage greater
than one), repeating segments, and elements at that level.

For print translation objects, groups, repeating segments, and elements are always
formatted as fields.

Each group and repeating segment also has a corresponding frame that contains all
the groups (with a maximum usage greater than one), repeating segments, and
elements at that level.

When you click a segment or group in the EDI File Format Pane, the
corresponding frame is displayed in the Layout Pane. When you click an element
in the EDI File Format Pane, the corresponding layout component is highlighted in
the Layout Pane.

About Forms
Sterling Gentran:Server generates a basic form based on the following information:
v Type of form (such as print or screen entry)
v Standard agency (such as ANSI X12, EDIFACT)
v Standard version (such as 003040, 90.1)
v Document/message type (such as 810 INVOICE, INVOIC)
v Release or message version (such as 9 for TRADACOMS)

All mandatory groups, segments, composites, and elements for the standard,
version, and transaction set/message you specify are available for use (activated)
when Sterling Gentran:Server creates a form. Only these mandatory form
components (groups, segments, composites, and elements) are activated
automatically. You must activate additional form components that you want to be
displayed in the screen entry form, and then customize and format the form so
that it is appropriate and useful for your company’s needs.

Before you begin to customize a form, you should be familiar with the following
elements of form design:
v EDI standards (how EDI standards work and how the information that your

users need is translated to and from the standards)
v Your users (the individuals who are using the forms to either create printouts of

processed EDI data or enter EDI data on a screen)
v Your trading partners (the organizations exchanging the EDI documents with

your company)
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You can create a different form for each combination of transaction set/message,
trading partner, and standard version. The number of screen entry forms that you
create is not limited and does not affect the number of print forms you can create,
and vice versa.

We recommend that you mock up a layout of the form the way you ultimately
want it to look. As you design the layout, make sure that the form will makes
sense to the people who will use it. By analyzing your company’s needs before
you actually create the form, you reduce the amount of time spent later on
redesigning or reformatting the form.

You should include the following design considerations in your form planning:
v Which fields should be printed, and which are necessary for the EDI data but do

not need to be displayed on the printout
v Where fields should be located on the form
v What labels you are using to identify the fields on the form

Building a Form with Forms Integration
This table describes the steps required to build a form using Forms Integration.

Stage Description

1 Prepare and Analyze. Obtain a layout of how you want the form to be
displayed and determine how it corresponds to the EDI standard you are
using. Determine what operations need to be performed to generate the
required layout.

2 Set Global Defaults (first time only). The first time you use the Sterling
Gentran:Server Forms Integration subsystem, you should verify the default
date format that the system uses.

3 Create, Save, and Name a New Form.

4 Activate the Appropriate EDI Groups, Segments, and Elements.

5 Promote, Split, and Change Segments and Groups.

6 Customize the EDI Data.

7 Define the Layout of the Form.

8 Compile the Form.

9 Print the Report. Validate and review the form, and make modifications as
needed.

10 Test the Translation Object. For a screen entry translation object, create a
new document in Document Editor, using that translation object. For a print
translation object, print a document. Verify that the output is correct.

Getting Started
This tutorial is meant to be completed in its entirety. We recommend that you
complete each task sequentially. When you create your own forms, the phases may
overlap and you may have to return to one or more of the phases several times
before the form is completed. The purpose of completing each task in this tutorial
in sequential order is not only to teach you how to perform the individual tasks,
but also to teach you a logical approach and methods that should be used when
you create your own form.
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In these tutorials, you create a screen entry form for an invoice and a print form
for purchase order. In both of these tutorials, you will be using one of the
following standards:
v ANSI X12 003040
v EDIFACT 92.1
v TRADACOMS ANA001 release 9

The default folder is GENSRVNT\Forms. The tutorial data is in the
C:\GENSRVNT\TUTORIALS subfolder.

The steps involved in creating forms are broken down into manageable pieces so
that you can learn the tasks and procedures involved in creating a form. Then, you
can apply the knowledge gained from using this tutorial to create your own forms.

In this scenario, your company is MWT Manufacturing Co., which manufactures a
wide variety of pet supplies for pet stores. One of your trading partners, Pet Zone
(a large pet supply retailer), orders products from your company. Your company
then invoices Pet Zone for those products.

You will create a form that formats and arranges the EDI data you receive from Pet
Zone to produce a printout of a purchase order.. You do not want to alter the
integrity of the EDI data. However, you want to interpret some of the codes
included in the EDI message into more meaningful text.

Then, you will create a form that your data entry users will use to enter EDI data
for the invoice that you will send to Pet Zone. From discussions with Pet Zone,
you know the requirements for the invoices that they receive from you.

Analyze the EDI File
You and your partner must agree on which standard, version, and
message/transaction set you are using. It is helpful to review the EDI standard
that you are using before analyzing the EDI file. We recommend that you obtain an
EDI standard manual for the standard and version that you are using. Standard
manuals are available from EDI standard agencies.

For purchase orders, you must first determine what data your trading partner will
be sending you and what data is contained in each element. Discuss with your
partner what they will send and which segments and elements your company
requires. You can then make a list of the items that you will need to use. You will
then make the form components you need available for use

For invoices, you must determine what data you need to send your trading partner
and what data your trading partner expects to receive and what data is contained
in each element. It is important to analyze the data in this way so that the invoice
contains all the necessary information, and so that your company can bill your
partner correctly for the order you shipped to them. Discuss with your partner
what you are sending and which segments and elements your partner requires.
You can then make a list of the items that you will need to use.

Sterling Gentran:Server generates a form based on the groups, segments,
composites, and elements that are defined by the standard agency for the version
of the document you selected. The system activates all the groups, segments,
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composites, and elements that are defined as mandatory by the standard. The
system does not enable you to deactivate mandatory groups, segments, composites,
and elements.

Note: The TRADACOMS standard uses a header with each interchange (ORDHDR
for the ORDERS message). The header message contains information that pertains
to each message in the interchange. Sterling Gentran:Server copies the header
segments to the beginning of each document, to ensure that all the relevant
information is contained in the document. Therefore, you will need to load the
header message (ORDHDR) into the ORDERS EDI file, so that all the segments
and elements are available for use.

When translating data, the system does not process groups, segments, and
elements that are not activated. Therefore, you must activate the groups, segments,
and elements that are not defined as mandatory by the standard but that you have
determined you need to use in the form.

Note: When you activate a conditional group or segment, the mandatory
subordinate segments and elements are activated automatically. A conditional
group or segment is used only if there is EDI data available for that element.

The first step in creating a form is to analyze the form requirements. If the analysis
you perform is complete, you have all the information you need to create the form
in an efficient and logical manner. If you omit this critical step and proceed
directly to creating the form, it is likely that creating the form will be a longer and
more arduous task, and the form may not work the way you need it to, due to
oversights and omissions.

Creating a screen entry or print form for an invoice or purchase order requires
several steps. Some steps are performed at the document/message level (such as
activating form components), and others are iterative steps that are performed for
each group, segment, or element in the form. In the analysis phase, you must
determine what EDI data is being sent, as well as what information is required to
process the data. The fields on the form must account for all information.

For each segment activated (either mandatory or optional), you must ask the
following questions:
v Is the segment a group?
v Does the segment have a maximum use greater than one?
v What elements need to be activated for the segment?

EDI Delimiters
If you are using an EDI standard that contains composite elements or subelements,
you must verify that Sterling Gentran:Server is specifying the correct delimiters.
Delimiters are flags that you define to the system as separating specific EDI
components. Delimiters are necessary for all variable field-length standards,
because the data is compressed (and the leading zeroes and trailing blanks are
removed). The fields vary in length, so the system needs a flag to determine where
one element ends and another begins. For example, an element delimiter marks the
beginning of a new element.

Note: Although setting EDI delimiters in Sterling Gentran:Server is mandatory
only if you are using a standard with composite elements or subelements, we
recommend that you perform this task regardless of which standard you use.
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This table lists the default EDI delimiters.

Field

ANSI X12 EDIFACT TRADACOMS

Default Char Default Hex Default Char Default Hex Default Char Default Hex

Tag Delimiter + (plus sign) = (equal sign) Ox3D

Segment Delimiter ~ (tilde) 0x7E ‘ (apostrophe) 0x27 ’ (apostrophe) Ox27

Element Delimiter * (asterisk) 0x2A + (plus sign) 0x2B + (plus sign) Ox2B

Sub Element
Delimiter

: (colon) 0x3A : (colon) 0x3A : (colon) Ox3A

Decimal Separator . (period) 0x2E . (full stop) Ox2E

Release Character ? (question
mark)

0x3F ? (question
mark)

Ox3F

Verifying the Global EDI Date Formats
The Forms Integration subsystem enables you to customize the global EDI date
formats for all forms. You can specify the default EDI format of dates for both six-
and eight-character dates. When you customize the global EDI date formats, the
settings are valid for all forms created in the current session of Sterling
Gentran:Server. However, you can override the default date formats for an
individual element on the Element Properties dialog for that element.

About this task

You must verify that you are using the correct global date formats the first time
you use Sterling Gentran:Server. Typically, you verify the global EDI date formats
one time only. You can change the default date formats if they do not match the
formats you intend to use.

Use this procedure to verify the global EDI date formats.

Procedure
1. Launch the Forms Integration subsystem.
2. Select Options > Preferences. The Preferences dialog is a property sheet that

enables you to set global defaults for Sterling Gentran:Server.
3. Select the Standard Formats tab and verify the default date formats that are

used when elements are read from the standards database.
4. Verify that the Six-character dates list contains YYMMDD to define the format

of the six-character EDI dates in your forms.
5. Verify that the Eight character dates list contains YYYYMMDD to define the

format of the eight-character EDI dates in your forms.
6. Click OK to accept the default date formats for 6- and 8-character date fields

and exit the Preferences dialog.

Note: To change the order in which the date formats appear in the
Six-character dates and Eight character dates lists or to add a new date format
to the lists, select Options > Date Formats.
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Tips and Recommendations
File naming conventions

You allocate a file name to a form when you save the form for the first time or use
the Save As function to save a copy of the form under a different name. The name
of the form should define the form in a meaningful way.

The default file extension for forms is .STP. Using this extension distinguishes
source form files from other types of files, such as compiled translation objects. The
naming conventions in Sterling Gentran:Server are as follows:
v The source form (form created in Sterling Gentran:Server) should be named

using the file extension .STP.
v The compiled translation object (translation object that is the result of compiling

the source form) should be named using the same file name that was allocated
to the source form, but with the file extension .TPL.

We recommend that you use these naming conventions to distinguish source forms
and compiled translation objects from other types of files. We also recommend that
you use the same file name (with different file extensions) for a source form and
the translation object that was compiled from it.

When you make a major change to the form, increase the version to the next
higher sequential number (for example, 2.0, 3.0). If you make a minor change to
the form, increase the release to the next higher sequential number (for example,
2.1, 2.2).

We recommend that you save the form as often as possible, to mitigate the possible
loss of additions or modifications in the event of a hardware or system error.

If you have performed any function that invalidates the current format of the
translation object, the Save function is unavailable until you regenerate the layout.

Document names

We recommend that you set up a Document Name for each form to make the
identification of a document created by this form easier in Sterling Gentran:Server.
This allows you to differentiate between documents in the document browsers in
Sterling Gentran:Server. Document names can be up to 255 characters in length.

To set up a Document Name, you must select an element or field in the form that
contains data that distinguishes this document. (If you choose a non-string element
or field, you need to convert it to a string first.) Then, the Name field of the
document browsers that contain this document contain the data from the selected
element or field. You can choose any element or field as the Document Name, but
we strongly recommend that you select an element or field that occurs only once
in the document and has a data type of String.

Generating

You should regenerate the form periodically as you customize it to ensure that the
most recent changes to the frame are reflected in the Layout Window.

When you first generate the form, each field in the Layout Window is labeled with
the same name as its corresponding element in the EDI File Format Window. As
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you customize the form, however, you change some of the labels and remove
others, so all the fields are not labeled the same as their corresponding elements.
Even though you change or remove some field labels, each field still corresponds
to one element.

Activating

If you click a group, segment, composite, or element that you did not mean to
activate, right-click the component and select Deactivate.

When you activate an element in a print form, the tag Printed is displayed before
that element’s description to indicate that this field will be printed. If you later
prevent a field from being displayed on the printout, then the tag Not Printed is
displayed before that element’s description.

When you activate an element in a screen entry form, either the tag Edit Box or the
tag Drop Down is displayed before that element’s description. Edit Box indicates
that the element is formatted as a field. Drop Down indicates that the element is
formatted as a list because you applied a standard rule that allows a selection of
multiple items.

To hide the groups, segments, and elements that you are not using, select View >
Show Active Only.

When you activate a conditional group or segment, the mandatory subordinate
segments and elements are activated automatically. A conditional group or segment
is used only if there is EDI data available for an element contained in it.

When you activate a conditional group, segment, or composite, the mandatory
subordinate segments, composites, and elements are activated automatically. A
conditional group, segment, or composite is used only if there is EDI data available
for an element contained in it.

Promoting and Changing Segments and Groups

The Promote function extracts one iteration (instance) of a group or repeating
segment. Promote is a specialized function that preserves the integrity of the EDI
structure. By default, the fields corresponding to each group and repeating
segment are displayed on a separate frame from the rest of the fields in the
document. When you promote a group to the parent frame, the fields
corresponding to the group are displayed on the frame to which the group is
subordinate. If you do not promote a group to the parent frame, the fields
corresponding to the group are displayed on their own frame.

When you promote a segment, the new segment is defined as mandatory (with a
minimum use of one). If you want to make the segment conditional, you must
change the minimum use to zero.

Changing the minimum use of a segment or group from zero to one changes the
status of the segment or group from conditional to mandatory. If EDI data is not
present for a segment or group that has a minimum use of one or greater, a
compliance error occurs during translation for that segment or group.

Changing the maximum use of a segment or group changes the maximum number
of times the segment or group can be used. A segment or group with a maximum
use greater than one repeats (loops), and is placed on a separate frame than the
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segment or group to which it is subordinate. A segment or group with a maximum
use of one does not repeat, and its fields are displayed on the same frame as the
group or segment to which they are subordinate.

If a segment or element occurs more than once in a form, it is identified by its
name <ID>. The second and subsequent occurrences are identified by <ID>:n,
where n is the number of the occurrence in the form.

Accumulators

There is only one set of accumulators for each form. This means that accumulator
0, whether it is used in the Primary Accumulator or Alternate Accum box, is the
same accumulator with the same content. If you assign calculations to accumulator
0 at the beginning of the form and then use accumulator 0 again later in the form,
the content of that accumulator will be the result of the earlier calculation. Any
additional calculations you assign to that accumulator will be performed on the
content resulting from an earlier calculation.

Formatting

When the form is generated, the upper left corner of each frame in the form is
placed in the upper left corner of the Layout Window.

Use the horizontal ruler at the top of the frame to help you resize the frame. The
instructions in this tutorial are given in centimeters. You can toggle from inches to
centimeters by double-clicking the yellow square where the vertical and horizontal
rulers meet. Use the horizontal ruler to help you find specific locations on the
ruler, or to help you measure width. Use the vertical ruler to the left of the frame
to help you measure length.

You should be able to view the entire width of the frame. If the right side of the
header frame and the vertical scroll bar for the frame are not visible in the Layout
Window, move the center bar between the EDI File Format Window and the
Layout Window farther to the left so the entire frame is displayed. Alternatively,
you can use the horizontal scroll bar at the bottom of the Forms main window to
bring the right side of the header frame into view.

Drag the bottom of the frame to the bottom of the Forms window, so that as many
of the fields on the frame are displayed as possible.

If a field is not in the part of the frame that currently is displayed, use the scroll
bar to scroll down the frame until you locate the hidden fields.

To select more than one field or field label, click and drag the mouse diagonally
across all the fields and field labels you want to select. All the fields and field
labels completely included within the dragged-across area are selected.

If the template is larger than the frame (there is a scroll bar on the right side of the
frame), the static text is displayed in the upper left corner of the part of the
template that is displayed, not at the top of the template.

If you format a form component in a way you did not intend, select Display >
Undo.
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If you forget which unlabeled field contains what data, you can click the field. Its
associated element is highlighted in the EDI File Format Window, providing you
with a description of the field.

If a field and its corresponding field label move together, the Lock Labels to Fields
option is turned on. Click Lock Labels on the Main Toolbar to turn off the Lock
Labels option.

Screen Entry Forms

In general, the column width should be wider than the actual content of the
column. The extra space that is not used for the content of the column will provide
white space separating the columns. If the width for each column is the exact
width of the data, then there will not be space separating the columns of data.
However, the last column on the screen does not need to be made wider than the
content.

The reference is the item (field, field label, list box, or static text) relative to which
all other selected items are formatted. The reference is indicated by an outline of
diagonal lines, whereas all other selected items are outlined by a solid line. The
last item selected in a group of selected items is the reference.
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Chapter 2. About Screen Entry Forms

Invoice Components for ANSI X12
Mandatory components

This table lists the following groups, segments, and elements have been defined as
mandatory by the standard committee for an ANSI X12 invoice (810). These
components are activated automatically when you create a new form.

Segment Element Description Data Type Length

BIG Beginning Segment for Invoice

BIG01 Invoice Date Dt/Tm 6

BIG02 Invoice Number String 22

TDS Total Monetary Summary

TDS01 Total Invoice Amount Real 10

CTT Transaction Totals

CTT01 Number of Line Items Integer 6

When translating data, the system does not process groups, segments, and
elements that are not activated. Therefore, you must make available (activate) the
groups, segments, and elements that are not defined as mandatory by the
standard, but that you have determined that you need to use in the form.

Required components

This table lists the form components that are required (need to be activated) and
are not mandatory for the standard for this tutorial.

Element Description Data Type Length
Code Value/Format to
Be Assigned

Beginning Segment for Invoice (BIG Segment) (Already Activated)

BIG03 Purchase Order Date Dt/Tm 6

BIG04 Purchase Order Number String 22

Reference Numbers (REF Segment)

REF01 Reference Number
Qualifier

String 2 CT (Contract Number)

REF02 Reference Number String 30

Name and Address (N1 Group)

Name (N1 Segment)

N101 Entity Identifier Code String 2 ST (Ship To)

RT (Remit To)

N102 Name String 35

Address Information (N3 Segment)

N301 Address Information String 35
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Element Description Data Type Length
Code Value/Format to
Be Assigned

N302 Address Information String 35

Geographic Information (N4 Segment)

N401 City String 30

N402 State or Province Code String 2

N403 Postal Code String 9

Terms of Sale/Deferred Terms of Sale (ITD Segment)

ITD01 Terms Type Code String 2 Any valid code

Date/Time Reference (DTM Segment)

DTM01 Date/Time Qualifier String 3 090 (Contract Effective)

DTM02 Date Dt/Tm 6

Baseline Item Data (IT1 Group)

Baseline Item Data (Invoice) (IT1 Segment in the IT1 Group)

IT101 Assigned Identification String 11

IT102 Quantity Invoiced Real 10

IT103 Unit or Basis for
Measurement Code

String 2 Any valid code

IT104 Unit Price Real 14 Format = R2

IT106 Product/Service ID String 30

IT107 Product/Service ID
Qualifier

String 2 UP (UPC Consumer
Package Code)

Product/Item Description (PID Group in the IT1 Group)

Product/Item Description (PID:2 Segment in the PID Group)

PID:201 Item Description Type String 1 F (Free-Form
Description)

PID:205 Description String 80

Date/Time Reference (DTM:2 Segment in the IT1 Group)

DTM:201 Date/Time Qualifier String 3 011 (Date Shipped)

DTM:202 Date Dt/Tm 6

Carrier Detail (CAD Segment in the IT1 Group)

CAD01 Transportation
Method/Type Code

String 2 Any valid code

CAD08 Reference Number String 30

Customization tasks

Sterling Gentran:Server generates a form based on the groups, segments, and
elements you activate. At this point, the form is compliant with the standard and it
contains all the necessary components based on the data you send Pet Zone.
However, you need to customize the form components to produce a form that is
easy to use to enter data in a logical manner.

This table lists the customization tasks described in this tutorial.
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Form Component Description Customization Task

BIG01 element Invoice Date Your users enter the date in the format "MM/DD/YY," but the date
in the EDI data should be in the format of "YYMMDD," so you set
the format accordingly.

BIG03 element Purchase Order Date Your users enter the date in the format "MM/DD/YY," but the date
in the EDI data should be in the format of "YYMMDD," so you set
the format accordingly.

REF segment Reference Numbers The standard allows this segment to be used up to twelve times, but
you and your trading partner have decided to use this segment only
once. Therefore, you change the maximum use of this segment to
one.

REF01 element Reference Number
Qualifier

The only type of reference number that you use is the contract
number, so you do not need to load the entire code list table. You
define a constant value in this field designating the type of number
(contract number) you expect your users to enter. Then, you prevent
this field from being displayed in the screen entry form, because the
value for this field ("CT" for contract number) is entered
automatically.

N1 group Name and Address The standard allows this group to be used up to two hundred times,
but you and your trading partner have decided to use two iterations
of this segment and use each iteration once: one iteration is for the
Ship To name and address, and one iteration is for the Remit To
name and address. You promote this group twice so that one iteration
of the N1 group is used for the Ship To name and address and
another N1 group is used for the Remit To name and address. Then,
you use the key field function to ensure that only the Ship To name
and address are displayed in the first N1 group, and only the Remit
To name and address are displayed in the second N1 group.

N3 segment in the
N1 group

Address Information The standard allows this segment to be used up to two times for each
occurrence of the N1 group. You need this segment to be used only
once for each name and address, so you change the maximum use of
this segment to one.

N101 element in the
Ship To address

Entity Identifier Code The only type of entity identifier code that you use in this element is
the Ship To name, so you do not need to load the entire code list
table. You define a constant value in this field designating the type of
name (Ship To name) you expect your users to enter. Then, you
prevent this field from being displayed in the screen entry form,
because the value for this field ("ST" for Ship To name) is entered
automatically.

N101 element in the
Remit To address

Entity Identifier Code The only type of entity identifier code that you use in this element is
the Remit To name, so you do not need to load the entire code list
table. You define a constant value in this field designating the type of
name (Remit To name) you expect your users to enter. Then, you
prevent this field from being displayed in the screen entry form,
because the value for this field ("RI" for Remit To name) is entered
automatically.

ITD segment Terms of
Sale/Deferred Terms
of Sale

The standard allows this segment to be used up to five times in one
invoice to specify the terms under which this invoice is valid. You
need this segment to be used only once for each invoice, so you
change the maximum use of this segment to one.

ITD01 element Terms Type Code Your users can enter any of the terms type codes that the standard
designates as valid codes. You load the entire code list for this
element, which creates a list containing valid codes from which users
can select.
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Form Component Description Customization Task

DTM segment Date/Time Reference The standard allows the date to be used up to ten times. You use the
DTM segment only once (for the contract date), so you change the
maximum usage of the DTM segment.

DTM01 element Date/Time Qualifier The only type of date that you use in the DTM segment is the
contract date, so you do not need to load the entire code list table.
You define a constant value in this field designating the type of date
(contract date) you expect your users to enter. Then, you prevent this
field from being displayed in the screen entry form, because the
value for this field ("090" for contract date) is entered automatically.

DTM02 element Date Your users enter the date in the format MM/DD/YY, but the date in
the EDI data should be in the format YYMMDD, so you set the
format accordingly.

IT101 element Assigned
Identification

You use an accumulator for this element to count line items in the
invoice. This accumulator is used in the Number of Line Items
element (CTT01) to calculate the total number of line items in the
invoice.

IT102 element Quantity Invoiced You use an accumulator for this element to calculate a running total
of the invoice amount, which is used to calculate the total invoice
amount. This accumulator is used in the Total Invoice Amount
element (TDS01) to identify the total dollar amount invoiced.

IT103 element Unit or Basis for
Measurement Code

Your users can enter any of the unit codes that the standard
designates as valid codes. You load the entire code list for this
element, which creates a list containing valid codes from which users
can select.

IT104 element Unit Price Both the EDI data and the data that your users enter in the screen
entry form should be formatted with an explicit decimal point and
two decimal places. Also, you use an accumulator for this element to
calculate the total dollar amount of the invoice. This accumulator is
used in the Total Invoice Amount element (TDS01) to identify the
total dollar amount invoiced.

IT106 element Product/Service ID
Qualifier

The only type of qualifier that you use in this element is the UPC
code for the item, so you do not need to load the entire code list
table. You define a constant value in this field designating the type of
qualifier (UPC code) you expect your users to enter. Then, you
prevent this field from being displayed in the screen entry form,
because the value for this field ("UP" for UPC code) is entered
automatically.

PID group in the IT1
group

Product/Item
Description

The standard allows this group containing line item information to be
used up to two thousand times in one invoice. Your users complete
the fields in this group only once per invoiced item, so you change
the maximum use of this segment to one.

PID:201 element in
the IT1 group

Item Description
Type

The only type of item description that you use in this element is a
free-form description for the item, so you do not need to load the
entire code list table. You define a constant value in this field
designating the type of description (free-form) you expect your users
to enter. Then, you prevent this field from being displayed in the
screen entry form, because the value for this field ("F" for free-form
description) is entered automatically.

DTM:2 segment in
the IT1 group

Date/Time Reference The standard allows the date segment to be used up to ten times for
each invoiced item. Your users complete the fields in this segment
only once per invoiced item. You change the maximum use of this
segment to one, which places the Date/Time Reference fields on the
same frame as the rest of the line item fields.
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Form Component Description Customization Task

DTM:201 element in
the IT1 group

Date/Time Qualifier The only type of date that you use in the DTM:2 segment is the date
shipped, so you do not need to load the entire code list table. You
define a constant value in this field designating the type of date (date
shipped) you expect your users to enter. You then prevent this field
from being displayed in the screen entry form, because the value for
this field ("011" for date shipped) is entered automatically.

DTM:202 element in
the IT1 group

Date Your users enter the date in the format MM/DD/YY, but the date in
the EDI data should be in the format YYMMDD, so you set the
format accordingly.

CAD segment Carrier Detail The standard allows this segment to be used up to 999,999 times for
each line item. Your users use the fields in this segment only once
per invoiced item. You change the maximum use of this segment to
one (which places the Carrier Detail fields on the same frame as the
rest of the line item fields).

CAD01 element Transportation
Method/Type Code

Your users can enter any of the transportation type codes that the
standard designates as valid codes. You load the entire code list for
this element, which creates a list containing valid codes from which
users can select when completing a screen entry form.

TDS01 element Total Invoice Amount You use an accumulator to generate a running total of price (obtained
by multiplying the quantity invoiced for each line item by the unit
price) for this element.

CTT01 element Number of Line
Items

You use an accumulator to generate a total of the number of line
items in the invoice for this element.

Invoice Components for EDIFACT
Mandatory components

This table lists the groups, segments, composites, and elements that have been
defined as mandatory by the standards committee for an EDIFACT invoice
(INVOIC).

Group Segment Composite Element Description

BGM Beginning of Message

DTM Date/Time/Period

C507

DTM01 Date/Time/Period Qualifier

UNS Section Control

UNS01 Section Identification

MOA Monetary Amount

Required components

This table lists the form components for this tutorial that are required (need to be
activated) and are not mandatory for the standard.

Element Description DataType Length
Constant, Code Value, or
Format to Be Assigned

Beginning of Message (BGM Segment) (Already Activated)
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Element Description DataType Length
Constant, Code Value, or
Format to Be Assigned

BGM05 Document/Message
Number

String 35

Date/Time/Period (DTM Segment) (Already Activated)

DTM01 Date/Time/Period
Qualifier

String 3 3 (Invoice Date/Time)

DTM02 Date/Time/Period String 35

Reference (RFF Group)

Reference (RFF Segment in RFF Group)

RFF01 Reference Qualifier String 3 v CT (Contract Number)

v ON (Order Number
(Purchase))

RFF02 Reference Number String 35

Date/Time/Period (DTM:2 Segment in RFF Group)

DTM:201 Date/Time/Period
Qualifier

String 3 v 92 (Contract Effective
Date)

v 4 (Order Date/Time)

DTM:202 Date/Time/Period String 35

Name and Address (NAD Group)

Name and Address (NAD Segment in NAD Group)

NAD01 Party Qualifier String 3 v ST (Ship To)

v RE (Party To Receive
Commercial Invoice
Remittance)

NAD10 Party Name String 35

NAD16 Street and Number/P.O.
Box

String 35

NAD17 Street and Number/P.O.
Box

String 35

NAD19 City Name String 35

NAD20 Country Sub-Entity
Identification

String 9

NAD21 Postcode Identification String 9

Payment Terms (PAT Group)

Payment Terms Basis (PAT Segment in PAT Group)

PAT01 Payment Terms Type
Qualifier

String 3 Any valid code

Line Item (LIN Group)

Line Item (LIN Segment in LIN Group)

LIN01 Line Item Number Number 6

Additional Product ID (PIA Segment in LIN Group)

PIA01 Product ID Function
Qualifier

String 3 5 (Product Identification)
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Element Description DataType Length
Constant, Code Value, or
Format to Be Assigned

PIA02 Item Number String 35

PIA03 Item Number Type,
Coded

String 3 UP (UPC (Universal
Product Code))

Item Description (IMD:2 Segment in LIN Group)

IMD:201 Item Description Type,
Coded

String 3 F (Free Form)

IMD:206 Item Description String 35

Measurements (MEA:2 Segment in LIN Group)

MEA:201 Measurement Application
Qualifier

String 3 AAE (Measurement)

MEA:202 Measurement Dimension,
Coded

String 3

Quantity (QTY:2 Segment in LIN Group)

QTY:201 Quantity Qualifier String 3 47 (Invoiced Quantity)

QTY:202 Quantity Number 15 Format = R0

Date/Time/Period (DTM:11 Segment in LIN Group)

DTM:1101 Date/Time/Period
Qualifier

String 3 186 (Departure Date/Time,
Actual)

DTM:1102 Date/Time/Period String 35

Monetary Amount (MOA Group in LIN Group)

Monetary Amount (MOA:5 Segment in MOA Group in LIN Group)

MOA:501 Monetary Amount Type
Qualifier

String 3 146 (Unit Price)

MOA:502 Monetary Amount Number 18 Format = R2

Details of Transport (TDT Group in LIN Group)

Details of Transport (TDT:2 Segment in TDT Group in LIN Group)

TDT:201 Transport Stage Qualifier String 3 20 (Main-Carriage
Transport)

TDT:205 Type of Means of
Transport Identification

String 8 Any valid code

TDT:207 Carrier Identification String 17

Section Control (UNS Segment)

UNS01 Section Identification String 1 S (Summary)

Control Total (CNT Segment)

CNT01 Control Qualifier String 3 2 (Number of Line Items)

CNT02 Control Value Number 8 Format = N0

Monetary Amount (MOA Group) (Already Activated)

Monetary Amount (MOA:10 Segment in MOA Group)

MOA:1001 Monetary Amount Type
Qualifier

String 3 77 (Invoice Amount)

MOA:1002 Monetary Amount Number 18 Format = R2
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Customization tasks

Sterling Gentran:Server generates a form based on the groups, segments,
composites, and elements you activate. At this point, the form is compliant with
the standard and it contains all the necessary components based on the data you
send Pet Zone. You need to customize the form components to produce a form that
is easy to use to enter data in a logical manner.

This table lists the customization tasks described in this tutorial.

Form Component Description Customization Task

BGM05 element Document/Message
Number

You will set up the document name (which enables you to
differentiate between messages in the document browsers in Sterling
Gentran:Server) in this element. Also, your users will enter no longer
than an eight-character string in this element, so you will change the
maximum length for this element to eight. In addition, you will
change the field label to Invoice No., which better describes the data
your users will enter.

DTM segment Date/Time/Period You and your trading partner will use this segment only once, so you
will change the maximum use of this segment to one.

DTM01 element Date/Time/Period
Qualifier

Your users will enter only the invoice date in this segment, so you do
not need to load the entire code list table. You will define a constant
value in this element for the invoice date. Then, you will prevent this
field from being displayed in the screen entry form, because the
value for this field will be entered automatically.

DTM02 element Date/Time/Period Your users will enter a string no longer than eight characters in this
element, so you will change the maximum length for this element to
eight. Also, you will change the field label to Invoice Date.

RFF group Reference You and your trading partner will use this group only once, so you
will change the maximum use of this group to one. You will promote
this group so that the fields in this group are placed on the main
Invoice Message frame. Also, you need two iterations of this group:
one for the contract number, and one for the purchase order number.
You will copy this segment so that you will have the two iterations of
this group you need.

RFF01 element Reference Qualifier Your users will enter only the contract number in this segment, so
you do not need to load the entire code list table. You will define a
constant value in this field for the contract number. Then, you will
prevent this field from being displayed in the screen entry form,
because the value for this field will be entered automatically. You will
perform the same task (with a different constant value) for the
Reference Qualifier field in the new RFF group that you created by
copying the original RFF group.

RFF02 element Reference Number Your users will enter a string no longer than ten characters in this
element, so you will change the maximum length for this element to
ten. Also, you will change the field label to P.O. No. ("Contract No."
for the Reference Number field in the second iteration of the RFF
segment).

DTM:2 segment Date/Time/Period You and your trading partner will use this segment only once, so you
will change the maximum use of this segment to one.
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Form Component Description Customization Task

DTM:201 element Date/Time/Period
Qualifier

Your users will enter only the contract date in this segment, so you
do not need to load the entire code list table. You will define a
constant value in this field for the contract date. Then, you will
prevent this field from being displayed in the screen entry form,
because the value for this field will be entered automatically. You will
perform the same task (with a different constant value) for the
Date/Time/Period Qualifier field in the new RFF group that you
created by copying the original RFF group.

DTM:202 element Date/Time/Period Your users will enter a string no longer than eight characters in this
element, so you will change the maximum length for this element to
eight. Also, you will change the field label to P.O. Date ("Contract
Date" for the Date/Time/Period field in the second iteration of the
RFF segment).

NAD group Name and Address You and your trading partner have decided to use this group only
once, so you will change the maximum use of this group to one. You
will promote this group so that the fields in this group are placed on
the main Invoice Message frame. Also, you need two iterations of
this group: one for the Ship To name and address, and one for the
Remit To name and address. You will copy this segment so that you
will have the two iterations of this group you need.

NAD01 element Party Qualifier Your users will enter only the Ship To name and address in this
group, so you do not need to load the entire code list table. You will
define a constant value in this element for the contract number. Then,
you will prevent this field from being displayed in the screen entry
form, because the value for this field will be entered automatically.
You will perform the same task (with a different constant value) for
the Party Qualifier field in the new NAD group that you created by
copying the original NAD group.

NAD10 element Party Name You will change the field label for this element to Ship To ("Remit To"
for the Party Name field in the new NAD group).

NAD16 element Street and
Number/P.O. Box

The data in this element will be self-explanatory, so you will remove
the label from this field.

NAD17 element Street and
Number/P.O. Box

The data in this element will be self-explanatory, so you will remove
the label from this field.

NAD19 element City Name The data in this element will be self-explanatory, so you will remove
the label from this field. Also, your users will enter no longer than a
thirty-character string in this element, so you will change the
maximum length for this element to thirty.

NAD20 element Country Sub-Entity
Identification

The data in this element will be self-explanatory, so you will remove
the label from this field. Also, your users will enter no longer than a
two-character string in this element, so you will change the
maximum length for this element to two.

NAD21 element Postcode
Identification

The data in this element will be self-explanatory, so you will remove
the label from this field.

PAT group Payment Terms You and your trading partner will use this group only once, so you
will change the maximum use of this group to one. You will promote
this group so that the fields in this group are placed on the main
Invoice Message frame.

PAT01 element Payment Terms Type
Qualifier

Your users can enter any of the payment terms type codes that the
standard designates as valid codes. You will load the entire code list
for this element, which will create a list containing valid codes from
which users can select. Also, you will change the field label to
Payment Terms Code.
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Form Component Description Customization Task

LIN group Line Item You will add the more descriptive title, Line Items, to the group
description to label the fields contained on the LIN frame.

LIN01 element Line Item Number You will use an accumulator for this element to count line items in
the invoice. This accumulator will be used in the Control Value field
(CNT02) to calculate the total number of line items in the invoice.
You will instruct the system to display the value in this field in the
first column in the Line Items list on the Invoice Message frame.
Also, the line item number will be no longer than five digits, so you
will change the maximum length for this element to five. In addition,
you will change the field label to Item No.

PIA segment in the
LIN group

Additional Product
ID

You and your trading partner will use this segment only once per
line item, so you will change the maximum use of this segment to
one.

PIA01 element Product ID Function
Qualifier

Your users will enter only the item number in this segment, so you
do not need to load the entire code list table. You will define a
constant value in this element for the item number. Then, you will
prevent this field from being displayed in the screen entry form,
because the value for this field will be entered automatically.

PIA02 element Item Number Your users will enter a string no longer than ten characters in this
segment, so you will change the maximum length for this element to
ten. Also, you will change the field name to Product Code. In
addition, you will instruct the system to display the value in this
field in the second column in the Line Items list on the Invoice
Message frame.

PIA03 element Item Number Type,
Coded

Your users will enter only the product identification in this segment,
so you do not need to load the entire code list table. You will define a
constant value in this element for the product identification. Then,
you will prevent this field from being displayed in the screen entry
form, because the value for this field will be entered automatically.
Also, the constant you defined for this element is only two characters
long, so you will change the maximum length of this element to two.

IMD:2 segment in the
LIN group

Item Description You and your trading partner have decided to use this segment only
once per line item, so you will change the maximum use of this
segment to one.

IMD:201 element Item Description
Type, Coded

Your users will enter only the free-form description in this segment,
so you do not need to load the entire code list table. You will define a
constant value in this field for the free-form description. Then, you
will prevent this field from being displayed in the screen entry form,
because the value for this field will be entered automatically.

MEA:2 segment in
the LIN group

Measurements You and your trading partner have decided to use this segment only
once per line item, so you will change the maximum use of this
segment to one.

MEA:201 element Measurement
Application Qualifier

Your users will enter only the measurement dimension in this
element, so you do not need to load the entire code list table. You
will define a constant value in this element for the measurement
dimension. Then, you will prevent this field from being displayed in
the screen entry form, because the value for this field will be entered
automatically.

MEA:202 element Measurement
Dimension, Coded

Your users can enter any of the measurement dimension codes that
the standard designates as valid codes. You will load the entire code
list for this element, which will create a list containing valid codes
from which users can select. Also, you will change the field label to
UOM (indicating "Unit of Measure").
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Form Component Description Customization Task

QTY:2 segment in the
LIN group

Quantity You and your trading partner will use this segment only once, so you
will change the maximum use of this segment to one.

QTY:201 element Quantity Qualifier Your users will enter only the invoiced quantity in this segment, so
you do not need to load the entire code list table. You will define a
constant value in this element for the invoiced quantity. Then, you
will prevent this field from being displayed in the screen entry form,
because the value for this field will be entered automatically.

QTY:202 element Quantity You will use an accumulator for this element to generate a running
total of the invoice amount. This accumulator will be used in the
Monetary Amount field (MOA:1002) to identify the total dollar
amount invoiced. You will instruct the system to display the value in
this field in the third column in the Line Items list on the Invoice
Message frame. Also, your users will enter a number no longer than
five digits in this element, so you will change the maximum length
for this element to five. In addition, Your users will not use decimal
places for the data in this field, so you will format the data with an
explicit decimal point and no decimal places.

DTM:11 segment in
the LIN group

Date/Time/Period You and your trading partner will use this segment only once per
line item, so you will change the maximum use of this segment to
one.

DTM:1101 element Date/Time/Period
Qualifier

Your users will enter only the actual departure date in this segment,
so you do not need to load the entire code list table. You will define a
constant value in this element for the actual departure date. Then,
you will prevent this field from being displayed in the screen entry
form, because the value for this field will be entered automatically.

DTM:1102 element Date/Time/Period Your users will enter a string no longer than eight characters in this
element, so you will change the maximum length for this element to
eight. Also, you will change the field label to Date Shipped.

MOA group in the
LIN group

Monetary Amount You and your trading partner will use this group only once per line
item, so you will change the maximum use of this group to one. You
will promote this group so that the fields in this group are placed on
the main Invoice Message frame.

MOA:501 element Monetary Amount
Type Qualifier

Your users will enter only the unit price in this segment, so you do
not need to load the entire code list table. You will define a constant
value in this element for the unit price. Then, you will prevent this
field from being displayed in the screen entry form, because the
value for this field will be entered automatically.

MOA:502 element Monetary Amount You will use an accumulator for this element to generate the total
dollar amount of the invoice amount. This accumulator will be used
in the Monetary Amount field (MOA:1002) to identify the total dollar
amount invoiced. You will instruct the system to display the value in
this field in the fourth column in the Line Items list on the Invoice
Message frame. Also, your users will enter a number no longer than
eight digits in this element, so you will change the maximum length
for this element to eight. In addition, your users will enter prices
with two decimal points in this field, so you will format the data
with an explicit decimal point and two decimal places. Finally, you
will change the field label to Price.

TDT group in the
LIN group

Details of Transport You and your trading partner have decided to use this group only
once per line item, so you will change the maximum use of this
group to one. You will promote this group so that the fields in this
group are placed on the main Invoice Message frame.
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TDT:201 element Transport Stage
Qualifier

Your users will enter only the main-carriage transport in this
segment, so you do not need to load the entire code list table. You
will define a constant value in this field for the transport stage. Then,
you will prevent this field from being displayed in the screen entry
form, because the value for this field will be entered automatically.

TDT:205 element Type of Means of
Transport
Identification

Your users can enter any of the type of means of transport
identification codes that the standard designates as valid codes. You
will load the entire code list for this element, which will create a list
containing valid codes from which users can select. Also, you will
change the field label to Transport Method. In addition, your users
will enter a string no longer than two characters in this element, so
you will change the maximum length for this element to two.

TDT:207 element Carrier Identification Your users will enter a string no longer than twelve characters in this
element, so you will change the maximum length for this element to
twelve. Also, you will change the field name to Carrier Code.

UNS01 element Section Identification The only type of section identification used in this segment is
summary, so you do not need to load the entire code list table. You
will define a constant value in this element for the summary. Then,
you will prevent this field from being displayed in the screen entry
form, because the value for this field will be entered automatically.

CNT segment Control Total You and your trading partner have decided to use this segment only
once, so you will change the maximum use of this segment to one.

CNT01 element Control Qualifier The only type of control used in this segment is the number of line
items, so you do not need to load the entire code list table. You will
define a constant value in this element for the number of line items.
Then, you will prevent this field from being displayed in the screen
entry form, because the value for this field will be entered
automatically.

CNT02 element Control Value You will use an accumulator for this element to generate a total of
the number of line items in the invoice. You will make this field
display-only, so that users cannot change the value in this field. Also,
the total in this field will be no longer than a six-character string, so
you will change the maximum length for this element to six. You will
change the field label to Number of Line Items. In addition, the value
in this field always will be a whole number, so you will format the
data with an explicit decimal point and no decimal places.

MOA group Monetary Amount You and your partner will use this group only once, so you will
change the maximum use of this group to one. You will promote this
group so that the fields in this group are placed on the main Invoice
Message frame.

MOA:1001 element Monetary Amount
Type Qualifier

The only type of monetary amount used in this segment is the
invoice amount, so you do not need to load the entire code list table.
You will define a constant value in this field for the invoice amount.
Then, you will prevent this field from being displayed in the screen
entry form, because the value for this field will be entered
automatically.

MOA:1002 element Monetary Amount You will use an accumulator for this element to generate a running
total of price (the quantity invoiced for each line item multiplied by
the unit price). You will make this field display-only, so that users
cannot change the value in this field. Also, the total in this field will
be no longer than a ten-character string, so you will change the
maximum length for this element to ten. You will change the field
label to Total Invoice Amount. Finally, the value in this field will be a
price with two decimal places, so you will format the data with an
explicit decimal point and two decimal places.
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Invoice Components for TRADACOMS
Mandatory components

This table lists the groups, segments, composites, and elements that have been
defined as mandatory by the standards committee for a TRADACOMS ANA001
INVOIC release 9 invoice, and are activated automatically when you create a new
form.

Group Group Segment Composite Element Description

CLO Customer’s Location

CLOC

IRF Invoice References

INVN Invoice Number

IVDT Date of Invoice

TXDT Tax-Point Date

ODD

ILD

STL VAT Rate Invoice Sub Trailer

SEQA:7 First Level Sequence Number

CD12:2 VAT Rate Category Code

VATP:2 VAT Rate Percentage

NRIL Number of Item Lines

LVLA Lines Sub-Total (Excluding
VAT)

EVLA Extended Sub-Total Amount
(Excluding VAT)

ASDA Extended Sub-Total Amount
(After Settlement Discount
Has Been Applied)

VATA VAT Amount Payable

APSI Payable Sub-Total Amount
Including Settlement Discount

TLR Invoice Trailer

NSTL Number of Total Segments

LVLT Lines Total Amount
(Excluding VAT)

EVLT Total Extended Amount Ex
Settlement Discount

ASDT Total Amount Exc VAT Inc
Sett

TVAT Total VAT Amount Payable

TPSI Total Payable Inc Settlement
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Required components

When translating data, the system does not process groups, segments, composites,
and elements that are not activated. Therefore, you must make available (activate)
the groups, segments, composites, and elements that are not defined as mandatory
by the standard, but that you have determined that you need to use in the form.

For this tutorial, the form components that are required (need to be activated) and
are not mandatory for the standard are the following:

Element Description Data Type Length
Constant, Code Value, or
Format to Be Assigned

Customer’s Location (CLO Segment) (Already Activated)

CLO CLOC CLO0 Customer’s ANA Location Code String 13 Format = 9

CLO CLOC CLO1 Customer’s Own Location Code String 17

CLO CNAM Customer’s Name String 40

CLO CADD CAD0 Customer’s Address Line 1 String 35

CLO CADD CAD1 Customer’s Address Line 2 String 35

CLO CADD CAD2 Customer’s Address Line 3 String 35

CLO CADD CAD3 Customer’s Address Line 4 String 35

CLO CADD CAD4 Customer’s Post Code String 8

Settlement Terms (PYT Segment)

PYT PAYT Terms of Payment String 40

Data Narrative (DNA Segment)

DNA GNAR GNA0 General Narrative Line 1 String 40

DNA GNAR GNA1 General Narrative Line 2 String 40

DNA GNAR GNA2 General Narrative Line 3 String 40

DNA GNAR GNA3 General Narrative Line 4 String 40

Order and Delivery Terms (ODD Group) (Already Activated)

Order and Delivery Terms (ODD:2 Segment)

ODD:2 ORNO ORN0 Customer’s Order Number String 17

ODD:2 ORNO ORN2 Date Order Placed by Customer Dt/Tm 6 Screen Format =
�DD/MM/YY

ODD:2 DELN DEL0 Delivery Note Number String 17

ODD:2 DELN DEL1 Date of Despatch by Supplier Dt/Tm 6 Screen Format =
�DD/MM/YY

Invoice Line Details (ILD Group in ODD Group) (Already Activated)

Invoice Line Details (ILD:2 Segment)

ILD:2 SPRO SPR0 EAN-13 Code for the Traded Unit String 13

ILD:2 SPRO SPR1 Supplier’s Code for the Traded Unit String 30

ILD:2 CPRO CPR1 Customer’s Item Code String 30

ILD:2 QTYI QTY0 Number of Order Units Invoice String 15 Format = N0 (Number
data type)

ILD:2 QTYI CD04:2 Measure Indicator String 6 Any valid code

ILD:2 TDES TDE0 Traded Unit Descr. Line 1 String 40
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Customization tasks

Sterling Gentran:Server generates a form based on the groups, segments,
composites, and elements you activate. At this point, the form is compliant with
the standard and it contains all the necessary components based on the data you
will send Pet Zone. However, you need to customize the form components to
produce a form that is easy to use to enter data in a logical manner.

This table lists the required customization tasks described in this tutorial.

Form Component Description Customization Task

INVOIC file Invoice Details Use an extended rule to calculate the VAT summary for the fields in
the STL and TLR segments.

CLO CLOC CLO0
element

Customer’s ANA
Location Code

Your users will enter the ANA code for the customer’s location to
which the invoiced items are to be shipped as a string data type
accepting numeric characters only. Therefore, you will designate the
appropriate string format for this element. Also, you will change the
field label to "Location ANA Code."

CLO CLOC CLO1
element

Customer’s Own
Location Code

Your users will enter a string no longer than ten characters in this
element, so you will change the maximum length for this element to
ten. Also, you will change the field label to "Location Own Code."

CLO CNAM element Customer’s Name Your users will enter a string no longer than thirty-five characters in
this element, so you will change the maximum length for this
element to thirty-five. Also, you will shorten the field label to
"Name."

CLO CADD CAD0
element

Customer’s Address
Line 1

You will shorten the field label for this element to "Address Line 1."

CLO CADD CAD1
element

Customer’s Address
Line 2

You will shorten the field label for this element to "Address Line 2."

CLO CADD CAD2
element

Customer’s Address
Line 3

You will shorten the field label for this element to "Address Line 3."

CLO CADD CAD3
element

Customer’s Address
Line 4

You will shorten the field label for this element to "Address Line 4."

CLO CADD CAD4
element

Customer’s Post
Code

You will shorten the field label for this element to "Post Code."

IRF segment Invoice References You and your trading partner will use this segment only once, so you
will change the maximum use of this segment to one.

IRF INVN element Invoice Number You will shorten the field label for this element to "Invoice No." In
addition, you will set up the document name (which enables you to
differentiate between messages in the document browsers in Sterling
Gentran:Server) for this element.

IRF IVDT element Date of Invoice Your users will enter the invoice date in DD/MM/YY format (not
YYMMDD format, the default format defined by the standard).
Therefore, you will change the screen format accordingly. You will
change the maximum length for this field and element to eight (to
accommodate the longer date format). In addition, you will change
the field label to "Invoice Date."

IRF TXDT element Tax-Point Date Your users will enter the tax-point date in DD/MM/YY format (not
YYMMDD format, the default format defined by the standard).
Therefore, you will change the screen format accordingly. You will
change the maximum length for this field and element to eight (to
accommodate the longer date format).

PYT segment Settlement Terms You and your trading partner will use this segment only once, so you
will change the maximum use of this segment to one.
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PYT SEQA element First Level Sequence
Number

This element is required in the invoice, but is not meaningful for
your purposes. You will prevent this field from being displayed in
the screen entry translation object. Also, you will define a constant
value for this field, as this field will always have the same value
(because each invoice corresponds to only one purchase order).

PYT PAYT element Terms of Payment You will shorten the field label for this element to "Payment Terms."

DNA segment Data Narrative You and your trading partner will use this segment only once, so you
will change the maximum use of this segment to one.

DNA SEQA:2
element

First Level Sequence
Number

This element is required in the invoice, but is not meaningful for
your purposes. You will prevent this field from being displayed in
the screen entry translation object. Also, you will define a constant
value for this field, as this field will always have the same value
(because each invoice corresponds to only one purchase order).

DNA GNAR GNA0
element

General Narrative
Line 1

You will shorten the field label for this element to "Invoice Notes."

DNA GNAR GNA1
element

General Narrative
Line 2

The data in this element will be self-explanatory, so you will remove
the label from this field.

DNA GNAR GNA2
element

General Narrative
Line 3

The data in this element will be self-explanatory, so you will remove
the label from this field.

DNA GNAR GNA3
element

General Narrative
Line 4

The data in this element will be self-explanatory, so you will remove
the label from this field.

ODD group Order and Delivery
Terms

You and your trading partner will use this group only once, so you
will change the maximum use of this group to one. You will promote
this group so that the fields in this group are placed on the main
Invoice Details frame.

ODD:2 SEQA
element

First Level Sequence
Number

This element is required in the invoice, but is not meaningful for
your purposes. You will prevent this field from being displayed in
the screen entry translation object. Also, you will define a constant
value for this field, as this field will always have the same value
(because each invoice corresponds to only one purchase order).

ODD:2 ORNO ORN0
element

Customer’s Order
Number

You will change the field label for this element to "Customer’s P.O.
No."

ODD:2 ORNO ORN2
element

Date Order Placed by
Customer

Your users will enter the purchase order date in DD/MM/YY format
(not YYMMDD format, the default format defined by the standard).
Therefore, you will change the screen format accordingly. You will
change the maximum length for this field and element to eight (to
accommodate the longer date format). In addition, you will shorten
the field label to "P.O. Date."

ODD:2 DELN DEL0
element

Delivery Note
Number

You will add Help text to this field.

ODD:2 DELN DEL1
element

Date of Despatch by
Supplier

Your users will enter the delivery date in DD/MM/YY format (not
YYMMDD format, the default format defined by the standard).
Therefore, you will change the screen format accordingly. You will
change the maximum length for this field and element to eight (to
accommodate the longer date format). In addition, you will shorten
the field label to "Delivery Date."

ILD group in the
ODD group

Invoice Line Details You will add the more descriptive title "Line Items" to the group
description to label the fields contained on the ILD:2 frame. In
addition, you will use an extended rule to calculate the extended line
cost for the line items, and to convert the VAT rate percentage from a
string (its data type in the partner database) to a number (the data
type required in the VAT Rate Percentage element).
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Form Component Description Customization Task

ILD:2 SEQA element First Level Sequence
Number

This element is required in the invoice, but is not meaningful for
your purposes. You will prevent this field from being displayed in
the screen entry translation object. Also, you will define a constant
value for this field, as this field will always have the same value
(because each invoice corresponds to only one purchase order)

ILD:2 SEQB element 2nd Level Sequence
No.

You will use the Loop Count standard rule to count the number of
this iteration of the group in this field (to provide a count of the
number of line items in the invoice). You will instruct the system to
display the value from this field in the first column in the Line Items
list box on the Invoice Details frame. Also, the line item number will
be no longer than five digits, so you will change the maximum
length for this element to five. In addition, you will shorten the field
label to "Item No." and make the field display-only (as the users will
not need to enter a value in this field).

ILD:2 SPRO SPR0
element

EAN-13 Code for the
Traded Unit

You will shorten the field label for this element to "EAN Code."

ILD:2 SPRO SPR1
element

Supplier’s Code for
the Traded Unit

You will instruct the system to display the value from this field in the
second column in the Line Items list box on the Invoice Details
frame. Also, you will change the field label to "Supplier’s Product
Code."

ILD:2 CPRO CPR1
element

Customer’s Item
Code

You will change the field label for this element to "Customer’s
Product Code."

ILD:2 QTYI QTY0
element

Number of Order
Units Invoice

Your users will enter the quantity as a number with N0 format
(formatted with an implicit decimal point and no decimal places).
Therefore, you will change the data type from String to Number and
the screen and EDI formats to N0 formats. You will instruct the
system to display the value from this field in the third column in the
Line Items list box on the Invoice Details frame. Also, the quantity
will be no longer than five digits, so you will change the maximum
length for this element to five. In addition, you will shorten the field
label to "Quantity."

ILD:2 QTYI CD04:2
element

Measure Indicator Your users can enter any of the measure indicator codes that the
standard designates as valid codes. You will load the entire code list
for this element, which will create a drop-down list box containing
valid codes from which users can select. Also, you will change the
field label to "Unit of Measure."

ILD:2 AUCT AUC0
element

Cost Price (Excluding
VAT)

Your users will enter the unit price in R4 format (formatted with an
explicit decimal point and up to four decimal places). Therefore, you
will change the screen format to R4. You will instruct the system to
display the value from this field in the fourth column in the Line
Items list box on the Invoice Details frame. Also, you will change the
field label to "Unit Price (Ex. VAT)."

ILD:2 LEXC element Extended Line Cost
(Excluding VAT)

The extended line cost will be formatted as an R4 number (formatted
with an explicit decimal point and up to four decimal places).
Therefore, you will change the screen format to R4. In addition, you
will prevent this field from being displayed in the screen entry
translation object, as users will not need to enter or view a value in
this field.

ILD:2 CD12 element VAT Rate Category
Code

You will use a Select standard rule so that all of the available codes
from the VAT rate category code table (VATCODES table) will be
available in a drop-down list box for your screen entry translation
object users. Also, you will shorten the field label to "VAT Code."
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Form Component Description Customization Task

ILD:2 VATP element VAT Rate Percentage You will create a temporary storage field for the VAT rate (with a
string data type, to accommodate the VAT rate from the partner
database). The extended rule you used on the ILD group will convert
the string data in the temporary storage field to a number, then place
the number in the ILD:2 VATP element (which has a number data
type) and delete the value from the temporary field. You will prevent
the ILD:2 VATP field from being displayed on the screen entry
translation object.

ILD:2 TDES TDE0
element

Traded Unit Descr.
Line 1

You will shorten the field label for this element to "Description."

STL segment VAT Rate Invoice Sub
Trailer

You will add the more descriptive title "VAT Summary" to the group
description to label the fields contained on the STL frame.

STL SEQA:7 element First Level Sequence
Number

This element is required in the invoice, but screen entry translation
object users will not need to enter a value in this field (this field will
be assigned a value in an extended rule used on the INVOIC file).
You will prevent this field from being displayed in the screen entry
translation object.

STL CD12:2 element VAT Rate Category
Code

You will instruct the system to display the value from this field in the
first column in the VAT Summary list box on the Invoice Details
frame. Also, you will shorten the field label to "VAT Code" and make
the field display-only (as users will not need to enter a value in this
field).

STL VATP:2 element VAT Rate Percentage The VAT rate will be displayed in the screen entry translation object
in R3 format (formatted with an explicit decimal point and up to
three decimal places). Therefore, you will change the screen format to
R3. You will instruct the system to display the value from this field in
the second column in the VAT Summary list box on the Invoice
Details frame. Also, you will shorten the field label to "VAT rate" and
make the field display-only (as users will not need to enter a value in
this field).

STL NRIL element Number of Item
Lines

This field will be assigned a value in an extended rule (used on the
INVOIC file). You will change the field label to "Number of Line
Items" and make the field display-only (as users will not need to
enter a value in this field).

STL LVLA element Lines Sub-Total
(Excluding VAT)

The lines subtotal will be displayed in the screen entry translation
object in R2 format (formatted with an explicit decimal point and up
to two decimal places). Therefore, you will change the screen format
to R2. You will instruct the system to display the value from this field
in the third column in the VAT Summary list box on the Invoice
Details frame. Also, you will make this field display-only (as users
will not need to enter a value in this field) and make minor changes
to the field label.

STL EVLA element Extended Sub-Total
Amount (Excluding
VAT)

This element is required in the invoice, but is not meaningful for
your purposes. You will prevent this field from being displayed in
the screen entry translation object (this field will be assigned a value
in the extended rule used on the INVOIC file).

STL ASDA element Extended Sub-Total
Amount (After
Settlement Discount
Has Been Applied)

This element is required in the invoice, but is not meaningful for
your purposes. You will prevent this field from being displayed in
the screen entry translation object (this field will be assigned a value
in the extended rule used on the INVOIC file).
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STL VATA element VAT Amount Payable The VAT amount payable will be displayed in the screen entry
translation object in R2 format (formatted with an explicit decimal
point and up to two decimal places). Therefore, you will change the
screen format to R2. Also, you will make this field display-only (as
users will not need to enter a value in this field).

STL APSI element Payable Sub-Total
Amount Including
Settlement Discount

The payable subtotal will be displayed in the screen entry translation
object in R3 format (formatted with an explicit decimal point and up
to three decimal places). Therefore, you will change the screen format
to R3. Also, you will make this field display-only (as users will not
need to enter a value in this field) and shorten the field label to
"Payable Subtotal (Inc. Sett. Disc.)."

TLR NSTL element Number of Total
Segments

This element is required in the invoice, but is not meaningful for
your purposes. You will prevent this field from being displayed in
the screen entry translation object (this field will be assigned a value
in the extended rule used on the INVOIC file).

TLR LVLT element Lines Total Amount
(Excluding VAT)

The invoice amount (excluding VAT) will be displayed in the screen
entry translation object in R2 format (formatted with an explicit
decimal point and up to two decimal places). Therefore, you will
change the screen format to R2. Also, you will make this field
display-only (as users will not need to enter a value in this field).

TLR EVLT element Total Extended
Amount Ex
Settlement Discount

The invoice amount (excluding settlement discount) will be displayed
in the screen entry translation object in R2 format (formatted with an
explicit decimal point and up to two decimal places). Therefore, you
will change the screen format to R2. Also, you will make this field
display-only (as users will not need to enter a value in this field).

TLR ASDT element Total Amount Exc
VAT Inc Sett

The invoice amount (excluding VAT, including settlement discount)
will be displayed in the screen entry translation object in R2 format
(formatted with an explicit decimal point and up to two decimal
places). Therefore, you will change the screen format to R2. Also, you
will make this field display-only (as users will not need to enter a
value in this field).

TLR TVAT element Total VAT Amount
Payable

The VAT total will be displayed in the screen entry translation object
in R2 format (formatted with an explicit decimal point and up to two
decimal places). Therefore, you will change the screen format to R2.
Also, you will make this field display-only (as users will not need to
enter a value in this field).

TLR TPSI element Total Payable Inc
Settlement

The total invoice amount will be displayed in the screen entry
translation object in R2 format (formatted with an explicit decimal
point and up to two decimal places). Therefore, you will change the
screen format to R2. Also, you will make this field display-only (as
users will not need to enter a value in this field).

Creating a Screen Entry Form
The first task in creating a new form is to define the type of form and EDI
standard, version, and message/transaction set (document). In this tutorial, you are
creating a screen entry form so that your data entry users can enter EDI data in an
invoice translation object in Sterling Gentran:Server. Instead of defining the
message/transaction set yourself, you want Sterling Gentran:Server to use the
standards database on your system to build the invoice according to the standard.
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Before you begin

Before you begin this procedure, verify that you have installed the Sterling
Gentran Standards Database for EDI.

About this task

Use this procedure to create a screen entry form.

Procedure
1. Select File > New to display the New Form Wizard.
2. From the "What kind of form are you creating" list, select Screen Entry.
3. In the "What is the name of the form" box, enter Screen Invoice Pet Zone.

This description allows you to differentiate it from similar translation objects
in Sterling Gentran:Server.

4. Click Next.
5. Select Delimited EDI as the data format syntax.
6. Click Customize.

The New Delimited EDI Wizard is displayed.
7. Click Next.
8. From the Data Source list, select Gentran Standards as the ODBC data.
9. Click Next.

10. From the Agency list, select one of the following as the EDI standard:
v [X] X12

v [E] Edifact

v [A] Tradacoms

11. From the Version list, select one of the following for the version of the
standard:
v [003040] ANSI X 12 VERSION 3 RELEASE 4
v [092001] EDIFACT 1992 RELEASE 1

v [ANA001] (for Tradacoms)
12. From the Transaction list, select one of the following for the transaction set

(document/message) for this translation object:
v [810] INVOICE (for ANSI X12)
v [INVOIC] INVOICE MESSAGE (for EDIFACT)
v [INVOIC] INVOICE DETAILS (for TRADACOMS)

13. For TRADACOMS: From the Release drop-down list box, select 9. This is the
message version for this translation object.

14. Click Next.
15. Click Finish to create the EDI file This may take a few seconds.

The form should look similar to the following. (This is an ANSI X12 example;
some details may be different for EDIFACT and TRADACOMS.)
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16. Select Edit > Details.
The Translation Object Details box is displayed.

17. Verify that Screen Entry is selected in the Translation Object Function list.
18. In the Major version box, enter 1 to designate the version number for this

translation object.
19. In the Minor version box, accept the default value 0 to designate the release

number for this translation object.

Note: When you make a major change to this form, increase the version to
the next higher sequential number (for example, 2.0, 3.0). If you make a minor
change to the form, increase the release to the next higher sequential number
(for example, 2.1, 2.2).

20. The Input and Output boxes (Agency, Version, Transaction, Release, and F
Group) contain information only if the Input and/or Output sides of the form
are of EDI format. For this tutorial, do not change the information in these
boxes.

Note: The system allows you to change the information in the Input and
Output boxes, but modifying this information does not alter the content of the
form. An example of when you might want to alter these boxes is when you
want the form to reflect a standard version that is not loaded on your system.
You can change the version in this dialog and then physically alter the form to
be compliant with that version.

21. Click OK to save the translation object details.
22. Select File > Save. If necessary, navigate to the folder where Sterling

Gentran:Server is installed.

Note: If you have performed any function that invalidates the current format
of the translation object, you cannot save until you regenerate the layout.

23. Enter one of the following to replace the default file name:
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v pet_810s.stp (for ANSI X12)
v peteinvs.stp (for EDIFACT)
v pettinvs.stp (for TRADACOMS)

24. Click Save.

About Activating Invoice Groups, Segments, and Elements
When Sterling Gentran:Server generates the form, the system includes all the
groups, segments, and elements that are defined by the standard agency for the
version of the transaction set you selected. The system activates all the groups,
segments, composites, and elements that are defined as mandatory by the
standard. The system does not enable you to deactivate the mandatory groups,
segments, and elements.

When translating data, the system does not process groups, segments, and
elements that are not activated. Therefore, you must activate the groups, segments,
composites, and elements that are not defined as mandatory by the standard, but
that you have determined that you need to use in the form.

To view the segments, composites, and elements in a group, segment, or composite
on your form, double-click the form component in the EDI File Format Window
(left side of the Forms main window). To activate an inactive form component,
click Activate on the Main Toolbar, then click the form component. The component
is no longer dimmed.

Example for ANSI X12

In the example below, the 810 INVOICE file icon and BIG segment are mandatory
for the invoice. You do not need to activate these components. The NTE, CUR, and
REF segments are not mandatory, so they are dimmed on the form. To view the
segments and elements in a group or segment on your form, double-click the form
component in the EDI File Format Window (left side of the Forms main window).
To activate an inactive form component, click Activate on the Main Toolbar, then
click the form component. The component is no longer dimmed.

Example for EDIFACT

In the example below, the INVOIC file icon, BGM and DTM segments, C507
composite, and DTM01 element are mandatory for the invoice. You do not need to
activate these components. The DTM02 and DTM03 elements are not mandatory,
so they are dimmed on the form.
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Example for TRADACOMS

In the example below, the INVOIC group, CLO segment, and CLO CLOC
composite are mandatory for the invoice. You do not need to activate these
components. The CLO CLOC CLO0, CLO CLOC CLO1, and CLO CLOC CLO2
elements are not mandatory, so they are dimmed on the form.

Activating Invoice Groups, Segments, and Elements
You must activate ALL required groups, segments, composites, and elements.
Failure to do so will hinder your ability to perform steps later in this tutorial.

About this task

See the following sections for lists of required components:
v Invoice Components for ANSI X12
v Invoice Components for EDIFACT
v Invoice Components for TRADACOMS

These tables list all the groups, segments, and elements that you need to activate.
Opening all the necessary groups and segments before you start to activate enables
you to scroll down the form and activate the groups, segments, and elements
sequentially.

When you activate a conditional group, segment, or composite, the mandatory
subordinate segments and elements are activated automatically.

Use this procedure to activate the required groups, segments, and elements..

Procedure
1. Click Activate on the Main Toolbar.
2. Click each inactive group that you need to use. Clicking an object activates it.
3. Click each inactive segment that you need.
4. Click each inactive composite that you need.
5. Click each inactive element that you need.
6. Click Activate on the Main Toolbar to turn activation mode off.
7. Select File > Save.

Adding Frame Help Text and Verifying EDI Delimiters
Use this procedure to add frame Help text and set EDI delimiters.

About this task

Procedure
1. Right-click the invoice file icon and select Properties.

The File Format Properties dialog is displayed.
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2. On the Display tab, enter the following text in the Frame Help Text list. (Press
Enter at the end of each line of text.)
This frame contains information pertaining
to the entire invoice. For online Help
on an individual field on this frame,
select the field and press F1.

Note: Pressing Enter creates line breaks for the online Help that the screen
entry translation object users in Document Editor view when they press F1. If
you do not create line breaks, the online Help is displayed on one line of text
in the pop-up window (the text does not wrap to the next line), and text that
extends beyond the width of the user’s monitor is not displayed.
When you generate the form (display the fields in the Layout Window), there is
one frame in the Layout Window (right side of Forms main window) for every
group and repeating segment in the EDI File Format Window (left side of
Forms main window). Entering frame Help text for the group or segment
corresponding to each frame enables screen entry translation object users to
access context-sensitive Help text for the frame.

3. On the Delimiters tab, verify that the correct delimiters are being used for the
standard. If the delimiters differ from the default values listed in EDI
Delimiters , you can enter either the character or the hexadecimal value.

Note: The hexadecimal value must begin with "0x" (that is, the number zero
and the letter "x").

Note: For this tutorial, do not select Stream segments. The translator will
insert a carriage return after every segment. If Stream segments is selected,
carriage returns are not used after every segment, and the segments are
"streamed."

4. Click OK to save the changes.

Segment and Group Modifications
The Promote function extracts one iteration (instance) of a group or repeating
segment. Promote is a specialized function that preserves the integrity of the EDI
structure.

The Split function enables you to split (break) a group or repeating segment into
two loops. This function is useful when you need more than one instance of the
same form component that occurs multiple times. When you split a group, the
Promote flag is not set. If you want the split group to be displayed on the parent
frame, you must set the Promote flag after you split the group.

Changing the maximum use of a segment or group changes the maximum number
of times the segment or group can be used. A segment or group with a maximum
use greater than one repeats (loops) and is placed on a separate frame than the
segment or group to which it is subordinate. A segment or group with a maximum
use of one does not repeat, and its fields are displayed on the same frame as the
segment or group or segment to which it is subordinate.

In the next part of the tutorial, you will promote, split, and change the maximum
use of the groups and segments before you generate the form (display the fields in
the Layout Window). By customizing the group and segment properties first, all
fields are placed on their appropriate frames the first time you generate the form.
If you promote, split, and change the maximum use of the groups and segments
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after you generate the form, the fields are placed on several more frames than you
need. Therefore, changing the group and segment properties before you first
generate the form enables the fields to be placed on as few frames as necessary.

Generating the Screen Entry Form
Generating a form is different from compiling a form. When you compile a form,
the source form is translated into a compiled translation object. When you generate
a form, the fields of the form are displayed on a frame in the Layout Window
(right side of the Forms main window), based on the groups, segments, and
elements that are activated.

About this task

Use this procedure to generate the screen entry form based on the groups,
segments, and elements you activated.

Procedure
1. Select the invoice file icon. Selecting the file icon before you generate the layout

allows you to view the beginning of the invoice layout in the Layout Window
after the layout is generated. However, selecting the file icon is not a
prerequisite to generating the layout.

2. Click Generate Layout on the Main Toolbar.
The screen entry form should look similar to the following. (This is an ANSI
X12 example; some details may be different for EDIFACT and TRADACOMS.)

After Generating the Form
When you generate the form, there is one field on the right side of your screen
(Layout Window) for every activated element on the left side of your screen (EDI
File Format Window). You can click either the field or its corresponding element to
select it. To access the Element Properties dialog for a field or element, either
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double-click the element, or use the right mouse button to click the field or
element, and then select Properties from the shortcut menu.

Note: When you first generate the form, each field in the Layout Window is
labeled with the same name as its corresponding element in the EDI File Format
Window. However, as you customize the form, you change some of the labels and
remove others, so all the fields are not labeled the same as their corresponding
elements. Even though you change or remove some field labels, each field still
corresponds to one element.

When the screen entry form is generated, the fields associated with each
non-repeating segment or group are displayed on a frame in the Layout Window.
If a segment or group is defined as repeating, then a list is displayed on the parent
frame, and the fields for that repeating segment or group are displayed on the
parent frame, and the fields for that repeating segment or group are displayed on a
separate frame.

All frames in a screen entry form are titled. The default title for each frame is its
transaction set, group, or segment name, but you can change the default titles to
better identify the information that is entered.

About Customization
You can customize the form, including the properties of each type of form
component (group, segment, and element).

Customizing the form is an iterative process. This tutorial guides you through all
the steps involved in customizing the form, component by component. When you
create forms, you usually activate the form components you need to use, customize
and format the form components, then compile the form and test the translation
object (and print a report, if necessary). As you substantially customize the form,
you usually compile the form and test the translation object several times to view
your changes before the form truly is finalized.

This following part of the tutorial explains how to customize the form components
for each sequential component in this tutorial.

Finalize Screen Entry Forms

Compiling the Invoice Form
The Compile function compiles the form. The form that you create using Sterling
Gentran:Server is a source form. When that source form is compiled, the result is a
compiled translation object.

About this task

After you save the translation object, you must register it with the Sterling
Gentran:Server system before you can use it. Use the Compile function after the
form is completed and saved.

Use this procedure to compile the form.

Procedure
1. Select File > Compile.
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2. Click Save to accept the translation object name. This name for the compiled
translation object (.TPL file) is the same file name as the source form (.STP file).
Preserving the same file name (with different file extensions) ensures that the
relationship between the source form and the compiled translation object
remains evident.
The system compiles the form and generates an error report. The error report is
displayed in the Compile Errors dialog.

3. Click OK to exit the Compile Errors dialog.

Note: If the Compile Errors dialog contains errors, you must fix the problems
by redoing the appropriate section of the tutorial. Recompile the form after you
correct the errors and save the form.

4. Select File > Save. The date on which you compiled the form is automatically
loaded into the Compiled on box on the Translation Object Details dialog.

Printing the Invoice Report
The Sterling Gentran:Server report enables you to validate and review the
translation object, and make modifications as needed. If you review the report and
determine that the translation object is incorrect, you need to make modifications,
save and recompile the form, then print the report again.

About this task

Use this procedure to print the Sterling Gentran:Server report.

Procedure
1. Select File > Print.
2. Click OK to accept the defaults on this dialog (all options checked), so the

report includes all sections and only the activated form components.
3. If you need to change setup options, click Properties. Set the appropriate

options. Click OK to begin the print process.

Testing the Invoice Translation Object
After you compile the form, print and verify the report, and register the translation
object with Sterling Gentran:Server, you should test the translation object to verify
that the data is translated correctly. To test the compiled translation object, you
should use the translation object to create a new document. You also should verify
acknowledgement processing (if applicable) and verify communications with your
network.

About this task

Important: The translation object must be registered with the Sterling
Gentran:Server system before you can use it. See the IBM Sterling Gentran:Server for
Microsoft Windows User Guide for information on registering the translation object.

Use this procedure to test the screen entry translation object you just created.

Procedure
1. Register your translation object with Sterling Gentran:Server. The filename

should be one of the following:
v PET_810S.TPL (for ANSI X12)
v PETEINVS.TPL (for EDIFACT)
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v PETTINVS.TPL (for TRADACOMS)
2. If you have not done so already, import the partner relationship into Sterling

Gentran:Server.
3. Verify (in Partner Editor) that the screen entry translation object is selected for

the Outbound Relationship.
4. Create a new document to enter the data in the screen entry translation object

you created.

42 IBM Sterling Gentran:Server for Windows: Forms Integration Tutorial for Screen Entry Forms



Chapter 3. Creating Screen Entry Forms for ANSI X12

Modifying the Maximum Use of the Invoice REF Segment
The REF segment contains Reference Numbers used in the EDI data, such as a
contract number used to identify when a relationship began between your
company and your trading partner. The standard allows the REF segment to be
used up to twelve times in one invoice. In this tutorial, you use the REF segment
only once (for the contract number). You change the maximum use of the REF
segment to one, which places the associated fields on the same frame as the header
segment.

About this task

Use this procedure to change the maximum use of the REF segment.

Procedure
1. Right-click the REF segment and select Properties.

The EDI Segment Properties dialog is displayed.
2. On the Looping tab, enter 1 in the Max Usage box to designate that this

segment can be used only once per invoice.
3. Click OK to exit the EDI Segment Properties dialog.

Modifying the Maximum Use of the N3 Segment
The N3 segment in the N1 group contains the Address of the entity or individual
named in the N1 segment. If the form were generated now (displaying the layout
of the fields in the form on the right side of your screen), the fields associated with
the N1 and N4 segments would be located on the main invoice frame, but the
fields associated with the N3 segment would be located on a separate frame. The
separate frame is necessary because the N3 segment has a maximum use of two, so
it requires another frame for users to enter two sets of address information. (In
screen entry forms, each group with a maximum use greater than one and
repeating segment has a corresponding frame that contains all the groups,
segments, and elements at that level.)

About this task

Your users need the N3 segment to be used only once in one invoice, so you
change the maximum use from two, as the standard allows, to one. When you
generate the form, the fields associated with the N3 segment are displayed on the
same frame as the fields for the N1 and N4 segments.

Use this procedure to change the maximum use of the N3 segment.

Procedure
1. Right-click the N3 segment and select Properties.

2. On the Looping tab, enter 1 in the Max Usage box to designate that this
segment can be used only once per invoice.

3. Click Yes at the prompt.
4. Click OK to exit the EDI Segment Properties dialog.
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Promoting the N1 Group
The standard allows the N1 group to be used up to two hundred times in one
invoice. The N1 group contains the N1, N3, and N4 segments to provide the name
and address of an entity or individual.

About this task

You promote the N1 group twice to accommodate the information for both the
Ship To and Remit To names and addresses. Promoting the N1 group causes two
singly-occurring N1 groups to exist in the form.

Use this procedure to promote the N1 group.

Procedure
1. Right-click the N1 segment and select Promote.

Promoting the N1 group extracts one iteration of the N1 group and places it
directly above the N1 group that you selected to promote. The new iteration of
the N1 group is named N1:2.

2. Right-click the original N1 group and select Promote.
Another iteration of the N1 group is extracted and placed above the N1 group.
The new iteration of the N1 group is named N1:3.

3. Right-click the original N1 group and select Deactivate to deactivate this group.

Changing the Maximum Use of the ITD Segment
The ITD segment is a conditional segment that specifies the Terms of
Sale/Deferred Terms of Sale for the invoice. The standard specifies that the ITD
segment can be used up to five times in one invoice. For this tutorial, you know
that your users must use the ITD segment only once, so you change the maximum
use of this field from five to one.

About this task

If the form were generated now, the Terms Type Code would be displayed on a
separate frame than the majority of the invoice fields because the ITD segment has
a maximum use of five. After you change the maximum use to one and generate
the form, the Terms Type Code field is displayed on the parent frame.

Use this procedure to change the maximum use of the ITD segment.

Procedure
1. Right-click the ITD segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box to designate that this

segment can be used only once per invoice.
3. Click OK to exit the EDI Segment Properties dialog.

Changing the Maximum Use of the DTM Segment
The DTM segment contains the Date/Time Reference Numbers for the invoice. In
this tutorial, the DTM segment is used for the contract date associated with the
contract number (in the REF segment). The standard allows the DTM segment to
be used up to ten times in one invoice. In this tutorial, you use the DTM segment
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only once (for the contract date). You change the maximum use of the DTM
segment to one, which places the associated fields on the main Invoice frame with
the majority of the invoice fields.

About this task

Use this procedure to change the maximum use of the DTM segment.

Procedure
1. Right-click the DTM segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box to designate that this

segment can be used only once per invoice.
3. Click OK to exit the EDI Segment Properties dialog.

Changing the Maximum Use of the PID Group
The standard allows the PID group (Product Item/Description) in the IT1 group to
be used up to one thousand times in one invoice. If the invoice were generated
now, the fields associated with the PID group would be displayed on a separate
frame than the majority of the invoice fields. For this tutorial, you know that your
users complete the fields in the PID group only once per invoiced item. You
change the maximum use of the PID group to one, which moves the Product
Item/Description fields to the frame containing line item information.

About this task

Use this procedure to change the maximum use of the PID group.

Procedure
1. Right-click the PID group and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box.
3. On the Display tab, click the Promote group to parent frame check box to

promote this group.

Note: If you change the maximum usage of this group, but do not select
Promote group to parent frame, the fields in this group are not displayed in
the same frame as the fields in the parent group.

4. Click OK to exit the Group Properties dialog.

Changing the Maximum Use of the DTM:2 Segment
The standard allows the DTM:2 segment (Date/Time Reference) in the IT1 group
to be used up to ten times in one invoice. If the invoice were generated now, the
fields associated with the DTM:2 segment would be displayed on a separate frame
than the majority of the invoice fields. For this tutorial, you know that your users
complete the fields in the DTM:2 segment only once per invoiced item. You change
the maximum use of the segment from ten to one, which enables the Date/Time
Reference fields to be displayed on the frame containing other line item
information.

About this task

Use this procedure to change the maximum use of the DTM:2 segment.
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Procedure
1. Right-click the DTM:2 segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box to indicate that this segment

can be used only once per invoice.
3. Click OK to exit the EDI Segment Properties dialog.

Changing the Maximum Use of the CAD Segment
The standard allows the CAD segment (Carrier Detail) to be used up to 999,999
times in one invoice. If the form were generated now, the fields associated with the
CAD segment would be displayed on a separate frame than the majority of the
invoice fields. For this tutorial, you know that your users complete the fields in the
CAD segment only once per invoiced item. You change the maximum use of the
CAD segment, which moves the Carrier Detail fields to the frame containing other
line item information.

About this task

Use this procedure to change the maximum use of the CAD segment.

Procedure
1. Right-click the CAD segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box to indicate that this segment

can be used only once per invoice.
3. Click OK to exit the EDI Segment Properties dialog.
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Chapter 4. Modifying Screen Entry Forms for ANSI X12

Setting up the Document Name for the Screen Entry Form
The document name makes the identification of a document created by the form
easier by enabling you to differentiate between documents.

About this task

We recommend that you set up a Document Name for each form. You can choose
any string element as the document name, but we strongly recommend that you
select an element that occurs only once in the document and has a data type of
string. For an ANSI X12 810 invoice, the document name usually is the Invoice
Number. For an EDIFACT 92.1 invoice, the document name is usually the
Document/Message Number.

Use this procedure to set up the document name.

Procedure
1. Double-click the one of the following elements:

v BIG02 (for ANSI X12)
v BGM05 (for EDIFACT)
v IRF INVN (for TRADACOMS)
We recommend that you select this element because it is a non-recurring and
mandatory element, and it helps to identify this document meaningfully in
Sterling Gentran:Server.

2. On Standard Rule tab, do the following:
v Select Update from the list.
v Click Yes at the prompt.
v From the Table/Group list, select Document record to indicate that you are

updating the document record in Sterling Gentran:Server.
v From the Column/Field list, select Document Name to indicate that you are

updating the Name field (in the Sterling Gentran:Server document browsers
that contain this message) with the contents of the B1G02 element.

3. Click OK to set up the document name.

The BIG Segment

Customizing the BIG01 Element
The BIG segment contains the Beginning Segment for the invoice. This segment
uses two mandatory elements: Invoice Date and Invoice Number. You also have
activated the Purchase Order Date and Purchase Order Number elements for this
segment. Each of these elements contains information that pertains to the entire
invoice.

About this task

The BIG01 element is a mandatory element that contains the Invoice Date. Your
users format the date as MM/DD/YY when they enter the date in the screen entry
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translation object, but the EDI data is sent to your trading partner as YYMMDD.
You must change the maximum length of this field from six to eight, to
accommodate the entire date (including the / separators). Also, you add Help text
to this field.

Use this procedure to set the date format, change the element and field lengths,
and add Help text to the Invoice Date field.

Procedure
1. Double-click the BIG01 element.
2. On the Validation tab, do the following:

v In the Max box, enter 8 to allow the entire date (including the / separators)
to be contained in this element.

v From the Data Format list, select MM/DD/YY to indicate that this field on
the translation object accepts a date entered in the format MM/DD/YY.

v Verify that YYMMDD is selected in the File Format list to indicate that the
EDI data is sent in the format YYMMDD.

3. On the Display tab, enter 8 in the Maximum number of characters box to allow
the entire date (including the / separators) to be contained in this element.

4. On the Help tab, enter the following text in the Help Text list:
Enter the invoice date. Use the format MM/DD/YY.

5. Click OK to exit the dialog.

Customizing the BIG02 Element
The BIG02 element is a mandatory element containing the Invoice Number. This
element is defined by the standard to be a string of twenty-two alphanumeric
characters. You know that your invoice number is an eight-character alphanumeric
string, so you change the element and field lengths to accommodate the shorter
invoice number. In addition, you rename the field label and add Help text to the
field.

About this task

Use this procedure to change the field and element lengths and the field label, and
add Help text to the Invoice Number field.

Procedure
1. Double-click the BIG02 element.
2. On the Validation tab, enter 8 in the Max box to allow an eight-character string

in this element.
3. On the Display tab, do the following:

v In the Label box, enter Invoice No. to replace the existing text.
v In the Maximum number of characters box, enter 8 to allow eight characters

to be entered in this field.
4. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the invoice number. The invoice number cannot
exceed 8 alphanumeric characters.

5. Click OK to exit the dialog.
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Customizing the BIG03 Element
The BIG03 element contains the Purchase Order Date, which is the date when your
trading partner sent the purchase order. Your users format the date as
MM/DD/YY when they enter the date into the screen entry translation object, but
the EDI data is sent to your trading partner as YYMMDD. You change the
maximum length of this field to eight to accommodate the entire date, including
separators (/). To save space in the screen entry form, you rename this field. Also,
you add Help text to the field.

About this task

Use this procedure to set the date format, change the element and field lengths,
change the field name, and add Help text to the Purchase Order Date field.

Procedure
1. Double-click the BIG03 element.
2. On the Validation tab, do the following:

v In the Max box, enter 8 to allow the entire date (including the / separators)
to be contained in this element.

v From the Form Format list, select MM/DD/YY to indicate that this field on
the translation object accepts a date entered in the format MM/DD/YY.

v Verify that YYMMDD is selected in the File Format list to indicate that the
EDI data is sent in the format YYMMDD.

3. On the Display tab, do the following:
v In the Label box, enter P.O. Date to replace the existing field label.
v In the Max box, enter 8 to allow the entire date (including the / separators)

to be contained in this element.
4. On the Help tab, enter the following text in the Help Text list:

Enter the purchase order date. Use the format MM/DD/YY.

5. Click OK to exit the dialog.

Customizing the BIG04 Element
The BIG04 element contains the Purchase Order Number. This element is defined
by the standard to be a string of twenty-two alphanumeric characters. You know
that your trading partner’s purchase order number is always a ten-character
alphanumeric string, so you change the element and field lengths to accommodate
the shorter purchase order number. In addition, you rename the field label and add
Help text to the field.

About this task

Use this procedure to change the field and element lengths, change the field label,
and add Help text to the Purchase Order Number field.

Procedure
1. Double-click the BIG04 element.
2. On the Validation tab, enter 10 in the Max box to allow a ten-character string

in this element.
3. On the Display tab, do the following:

v In the Label box, enter P.O. No. to replace the existing text.
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v In the Maximum number of characters box, enter 10 to allow ten characters
to be entered in this field.

4. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the purchase order number. The purchase order
number cannot exceed 10 alphanumeric characters.

5. Click OK to exit the dialog.
6. Click Generate Layout on the Main Toolbar to refresh the display of the screen

entry form.

Results

The section of the Invoice frame that contains the fields in the BIG segment now
should look like this:

The REF Segment

Customizing the Invoice REF01 Element
The REF segment contains Reference Numbers used in the EDI data, such as a
contract number. The standard allows the REF segment to be used up to twelve
times in one invoice. In this tutorial, you use the REF segment only once (for the
contract number). You already have promoted the REF segment to obtain just one
instance of the reference number, and to place the associated fields on the same
frame as the BIG segment.

About this task

The REF01 element (Reference Number Qualifier) is a mandatory element for the
REF segment. The REF01 element contains the two-character code to indicate what
type of reference number follows (for example, contract number). Because you
know that the only type of reference number your users enter for this invoice is a
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contract number, you define a constant value for the Reference Number Qualifier
field, designating that the constant "CT" always qualifies the number in the
Reference Number field. Then, you hide the Reference Number Qualifier field,
because it does not need to be displayed in the translation object.

When a user enters a contract number in the Reference Number field, the system
assigns the code "CT" to the Reference Number Qualifier field.

Use this procedure to define a constant value in the Reference Qualifier field and
hide the field.

Procedure
1. Double-click the REF01 element.
2. On the Standard Rule tab, do the following:

v Select the Use Constant option.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Contract Number to identify the constant.
v From the Type list, select String to indicate that the literal constant is

formatted as a string data type.
v In the Value box, enter CT to indicate that the Reference Number Qualifier

field must contain the contract number. This value is the actual value of the
literal constant.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, do the following:

v From the Constants list, select CT to identify the constant that is used for
this element.

v From the Qualifies list, select 0127 REFERENCE NUMBER, which is the
element that the Reference Number Qualifier field qualifies.

7. On the Display tab, select This field should not be displayed.
8. Click OK to exit the dialog.

Customizing the Invoice REF02 Element
The REF02 element contains the Reference Number. This element is defined by the
standard to be a string of thirty alphanumeric characters. In this tutorial, you know
that the reference number (the contract number) is an eight-character alphanumeric
string, so you change the element and field lengths to accommodate the shorter
reference number. In addition, you rename the field label and add Help text to the
field.

About this task

Use this procedure to change the field and element lengths, change the field label,
and add Help text to the Reference Number field.

Procedure
1. Double-click the REF02 element.
2. On the Validation tab, enter 8 in the Max box.
3. On the Display tab, do the following:
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v In the Label box, enter Contract No. to replace the existing text.
v In the Maximum number of characters box, enter 8 to allow an

eight-character string to be entered.
4. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the contract number. The contract number cannot
exceed 8 alphanumeric characters.

5. Click OK to exit the dialog.
6. Click Generate Layout on the Main Toolbar to refresh the display of the screen

entry form.

Results

The REF segment of the Invoice frame should now look like this:

N1 Groups
You already promoted the N1 group twice to accommodate the information for
both the Ship To and Remit To names and addresses. There are now two N1
groups activated in the form: N1:2 (for the Ship To name and address) and N1:3
(for the Remit To name and address).

You activated the N1, N3, and N4 segments in each N1 group to provide the name
and address of an entity or individual. For this tutorial, you use the N1 groups to
identify these two types of addresses:
v Ship to name and address (Entity Identifier Code "ST")
v Remit to name and address (Entity Identifier Code "RI")

To make the screen entry translation object more convenient for your users, you
changed the maximum use of the N3 segment (for both N1 groups) from two to
one. Changing the maximum use of the N3 segment enabled the Address
Information fields of the N3 segment to be displayed on the Invoice frame with the
N1 and N4 fields.
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The N1:3 Segment
The N1:3 segment in the N1:2 group identifies the Name of the entity or
individual. If the N1:3 segment is used, then the N1:301 element is mandatory. The
N1:301 element contains the Entity Identifier Code, which identifies the type of
name and address in that iteration of the group.

To ensure that Sterling Gentran:Server displays the correct name and address in
the Ship To and Remit To fields, you should use the key field function. The key
field function enables you to specify a second qualification in selecting a segment
(the segment name is the first qualification). Data must be provided in the order
designated through the use of key fields. For example, for this tutorial, your screen
entry translation object users enter the ship to name and address (N1:2 group) first,
and then the remit to name and address (N1:3 group).

By using the key field function, if a screen entry translation object user enters only
a Remit To name and address (N1:3 group) in a document using this invoice
translation object, then saves the document and opens it later, the Remit To name
and address are displayed in the correct fields. If you do not use the key field
function, then in the same scenario described above, the Remit To name and
address are displayed in the Ship To fields (since they are the first N1 fields in
which data can be displayed).

Using a Key Field for the N1:3 Segment
Use this procedure to use a key field for the N1:3 segment (in the N1:2 group).

About this task

Procedure
1. Right-click the N1:3 segment and select Properties.

2. On the Key Field tab, do the following:
v From the Field list, select 0098 ENTITY IDENTIFIER CODE.
v Verify that the Use constant option is selected.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to display the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Ship To to identify the unique literal constant.
v From the Type list, select String.
v In the Value box, enter ST to identify the actual value of the constant.
v Click OK to exit the Edit Constant dialog.

5. Click Close to exit the Map Constants dialog.
6. On the Key Field tab, select ST from the Use Constant list to indicate that this

is the Ship To name.
7. Click OK to exit the dialog.

Customizing the N1:301 Element
The N1:301 element (in the N1:3 segment) contains the Entity Identifier Code,
which is used to identify whether the name and address that follows is the Ship To
or Remit To name and address. For this tutorial, you know that your users enter
only the Ship To name and address information in the fields associated with the
N1:2 group. Therefore, you use the constant value "ST" (which you defined in the
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previous section) in the Entity Identifier Code field, indicating that this group
(N1:2) contains only shipping information. Then, you hide the Entity Identifier
Code field, because it does not need to be displayed on the translation object.

About this task

Use this procedure to use a constant value for the Entity Identifier Code field and
hide the field.

Procedure
1. Double-click the N1:301 element (in the N1:2 group).
2. On the Standard Rule tab, do the following:

v Select Use Constant.
v Click the second Constant option.
v From the Constants list, select ST to identify the constant used for this

element.
v From the Qualifies list, select 0093 NAME, which is the element that the

Entity Identifier Code field qualifies.
3. On the Display tab, select This field should not be displayed.
4. Click OK to exit the dialog.

Customizing the N1:302 Element
The N1:302 element (in the N1:3 segment) contains the name of the person or
company that received the order for which you are sending an invoice. Your users
are familiar with the standard address format (the name on the first line; the
address on the next lines; the city, state, and postal code on the last line). For this
reason, you do not need to label the fields containing the address, city, state, and
postal code. You rename the field label and add Help text to the field.

About this task

Use this procedure to rename the field label and add Help text to the Name field.

Procedure
1. Double-click the N1:302 element (in the N1:2 group).
2. On the Display tab, enter Ship To in the Label box to replace the existing text.

This label is the heading for the Ship To name and address information.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the name of the person or organization
to whom the order was shipped. The name
cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

The N3:3 Segment
The N3:3 segment (in the N1:2 group) contains the Address of the entity or
individual named in the N1:3 segment. If the N3:3 segment is used, then the
N3:301 element is mandatory. The N3:301 element contains Address Information,
which can identify the street name, suite number, or any other address
information. This element does not contain the city, state/province, or postal code;
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that data is contained in the N4:3 segment. You already activated the N3:302
element, which is a conditional element that contains an additional line of address
information, if it is necessary.

Your users need the N3:3 segment to be used only once, so you changed the
maximum use from two, as the standard allows, to one. Because you have changed
the maximum use, the fields associated with the N3:3 segment are displayed on
the Invoice frame with the fields for the N1:3 and N4:3 segments.

Customizing the N3:301 Element
The address information in the N3:301 element (in the N3:3 segment) corresponds
to the name in the N1:301 element, so there is no need to display the labels
associated with the address information. For the N3:301 and N3:302 elements, you
hide the field labels and add Help text to the fields.

About this task

Use this procedure to hide the Address Information field label and add Help text.

Procedure
1. Double-click the N3:301 element (in the N1:2 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the first line of the address. This address
line cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the N3:302 Element
Use this procedure to hide the second Address Information field label of the Remit
To address and add Help text.

About this task

Procedure
1. Double-click the N3:302 element (in the N1:2 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the second line of the address. This address
line cannot�exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

The N4:3 Segment
The N4:3 segment in the N1:2 group contains the Geographic Location of the entity
or individual named in the N1:3 segment. The N4:301 element contains the name
of the city, the N4:302 element contains the code for the state or province, and the
N4:303 element contains the postal code.

The geographic information in the N4:3 segment corresponds to the name in the
N1:301 element, so there is no need to display the labels associated with the
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geographic information. You hide the field labels for the N4:31, N4:302, and N4:303
elements and add Help text to those fields.

Customizing the N4:301 Element
About this task

Use this procedure to hide the field label and add Help text to the City Name
field.

Procedure
1. Double-click the N4:301 element in the N1:2 group.
2. On the Validation tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the city name. The city name
cannot exceed 30 alphanumeric�characters.

4. Click OK to exit the dialog.

Customizing the N4:302 Element
About this task

Use this procedure to hide the field label and add Help text to the State or
Province Code field.

Procedure
1. Double-click the N4:302 element (in the N1:2 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the state or province code. The code
cannot exceed 2 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the N4:303 Element
About this task

Use this procedure to hide the field label and add Help text to the Postal Code
field.

Procedure
1. Double-click the N4:303 element (in the N1:2 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the postal code. The postal code cannot exceed 9
alphanumeric characters. Do not enter a hyphen (-)
before the�4-digit postal code extension (if used).

4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display of the screen

entry form.
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Results

The section of the Invoice frame that contains the fields in the N1:2 group now
should look like this:

Customizing the N1:401 Element
The N1:4 segment in the N1:3 group identifies the Name of the entity or
individual. If the N1:4 segment is used, then the N1:401 element is mandatory. The
N1:401 element contains the Entity Identifier Code, which identifies the type of
name and address in that iteration of the group.

About this task

The N1:401 element (in the N1:4 segment) contains the Entity Identifier Code,
which is used to identify whether the name and address that follows is the Ship To
or Remit To name and address. For this tutorial, you know that your users enter
only the Remit To name and address information in the fields associated with the
N1:3 group. Therefore, you define the constant value "RI" in the Entity Identifier
Code field, indicating that this group (N1:3) contains only Remit To information.
Then, you hide the Entity Identifier Code field, because it does not need to be
displayed on the translation object.

Use this procedure to define a constant value for the Entity Identifier Code field
and hide the field.

Procedure
1. Double-click the N1:401 element (in the N1:3 group).
2. On the Standard Rule tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Remit To to identify the constant.
v From the Type list, select String to indicate that the literal constant is

formatted as a string data type.
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v In the Value box, enter RI to indicate that the Entity Identifier Code field
must contain the Remit To name and address. This value is the actual value
of the literal constant.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, do the following:

v From the Constants list, select RI to identify the constant used for this
element.

v From the Qualifies list, select 0093 NAME, which is the element that the
Entity Identifier Code field qualifies.

7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the N1:402 Element
The N1:402 element (in the N1:4 segment) contains the name of the person or
company to whom the invoice should be remitted. Your users are familiar with the
standard address format (the name on the first line; the address on the next lines;
the city, state, and postal code on the last line). For this reason, you do not need to
label the fields containing the address, city, state, and postal code. You rename the
field label and add Help text to the field.

About this task

Use this procedure to rename the field label and add Help text to the Name field.

Procedure
1. Double-click the N1:402 element (in the N1:3 group).
2. On the Display tab, enter Remit To in the Label box to replace the existing

field label. This label is the heading for the Remit To name and address
information.

3. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the name of the person or organization to whom
the �invoice should be remitted. The name cannot exceed
35 �alphanumeric characters.

4. Click OK to exit the dialog.

The N3:4 Segment
The N3:4 segment (in the N1:3 group) contains the Address of the entity or
individual named in the N1:4 segment. If the N3:4 segment is used, then the
N3:401 element is mandatory. The N3:401 element contains Address Information,
which can identify the street name, suite number, or any other address
information. This element does not contain the city, state/province, or postal code;
that data is contained in the N4:4 segment. You already activated the N3:402
element, which is a conditional element that contains an additional line of address
information, if it is necessary.

Your users need the N3:4 segment to be used only once in one invoice, so you
changed the maximum use from two, as the standard allows, to one. Changing the
maximum use of this segment enables the fields associated with the N3:4 segment
to be displayed on the Invoice frame with the fields for the N1:4 and N4:4
segments.
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Customizing the N3:401 Element
The address information in the N3:401 element (in the N3:4 segment) corresponds
to the name in the N1:401 element, so there is no need to display the labels
associated with the address information. For the N3:401 and N3:402 elements, you
hide the field labels and add Help text to the fields.

About this task

Use this procedure to hide the first Address Information field label of the Remit To
address and add Help text.

Procedure
1. Double-click the N3:401 element (in the N1:3 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the first line of the address. This address line
cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the N3:402 Element
About this task

Use this procedure to hide the second Address Information field label and add
Help text.

Procedure
1. Double-click the N3:402 element (in the N1:3 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the second line of the address. This address line
cannot�exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

The N4:4 Segment
The N4:4 segment in the N1:3 group contains the Geographic Location of the entity
or individual named in the N1:4 segment in the N1:3 group. The N4:401 element
contains the name of the city, the N4:402 element contains the code for the state or
province, and the N4:403 element contains the postal code.

The geographic location in the N4:4 segment corresponds to the name in the
N1:401 element, so there is no need to display the labels associated with the
geographic location. You hide the field labels for the N4:401, N4:402, and N4:403
elements and add Help text to those fields.

Customizing the N4:401 Element
About this task

Use this procedure to hide the field label and add Help text to the City Name
field.
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Procedure
1. Double-click the N4:401 element (in the N1:3 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the city name. The city name cannot
exceed 30 alphanumeric�characters.

4. Click OK to exit the dialog.

Customizing the N4:402 Element
About this task

Use this procedure to hide the field label and add Help text to the State or
Province Code field.

Procedure
1. Double-click the N4:402 element (in the N1:3 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the state or province code. The code
cannot exceed �2 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the N4:403 Element
About this task

Use this procedure to hide the field label and add Help text to the Postal Code
field.

Procedure
1. Double-click the N4:403 element (in the N1:3 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the postal code. The postal code cannot exceed
9 alphanumeric characters. Do not enter a hyphen (-)
before�the 4-digit postal code extension (if used).

4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display.

Results

The section of the Invoice frame that contains the fields in the N1:3 group) now
should look like this (you may need to scroll down the frame to see all of these
fields):
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Customizing the ITD Segment
The ITD segment is a conditional segment that specifies the Terms of
Sale/Deferred Terms of Sale for the invoice. The standard specifies that the ITD
segment can be used up to five times in one invoice. For this tutorial, you know
that your users must use the ITD segment only once, so you changed the
maximum use of this segment from five to one.

About this task

The ITD01 element contains the Terms Type Code, a two-character code that
identifies the terms under which this invoice is valid. Sterling Gentran:Server uses
a list (instead of an edit box, or field) when you apply a standard rule that allows
a selection of multiple items. When users use a translation object that contains a
list, they select an item from the list, instead of typing a value in a field. You
customize the ITD01 element so that a list containing all valid codes in the Terms
Type Code code list is available to your users when they use the screen entry
translation object. The Terms Type Code list enables them to select the appropriate
EDI code from the code list.

After you specify the code list table to use for the list for the Terms Type Code
field, you rename the field label. Also, you add Help text to the field.

Use this procedure to load the Terms Type Code code list from the standard,
rename the field label, and add Help text to the Terms Type Code field.

Procedure
1. Double-click the ITD01 element.
2. On the Standard Rule tab, do the following:

v Select Use Code.
v Click Edit to access the Edit Code List dialog.
The Table ID box contains 0336, the name of the element for which this code
list table is used. The Desc box contains TERMS TYPE CODE, the description
of the element for which this code list table is used.

3. On the Edit Code List dialog, click Load. You are prompted to select an ODBC
data source name.
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4. Select the appropriate DSN and click OK to access the Load Code List dialog.
5. On the Load Code List dialog, do the following:

v Click Add All to select all the codes and move them to the Codes Selected
list.

v Click OK to load the code list and exit the Load Code List dialog.
6. Click Close to exit the Edit Code List dialog.
7. On the Display tab, enter Payment Terms Code in the Label box to replace

the existing text
8. On the Help tab, enter the following text in the Help Text list:

Select the payment terms code from the list.

9. Click OK to exit the dialog.
10. Click Generate Layout on the Main Toolbar to refresh the display.

Results

The section of the Invoice frame that contains the field in the ITD segment now
should look like this (you may need to scroll down the frame to see the field):

The DTM Segment

Customizing the DTM01 Element
The DTM segment contains the Date/Time Reference Numbers for the invoice. In
this tutorial, the DTM segment is used for the contract date associated with the
contract number (in the REF segment). The standard allows the DTM segment to
be used up to ten times in one invoice. In this tutorial, you use the DTM segment
only once (for the contract effective date). You already changed the maximum use
of the DTM segment to obtain just one instance of the DTM segment, and to place
the associated fields on the same frame as the majority of the invoice fields.

About this task

The DTM01 element (Date/Time Qualifier) is a mandatory element for the DTM
segment. The DTM01 element contains the two-character code from your EDI data
to indicate what type of date follows (e.g., contract effective date). You define a
constant value for the Date/Time Qualifier field, designating that the constant
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"090" qualifies the date in the Date field. Defining the constant indicates that the
Date field contains the contract effective date.

When a user enters a contract effective date in the Date field, the system
automatically assigns the code "090" to the Date/Time Qualifier field.

Use this procedure to define a constant value and hide the Date/Time Qualifier
field.

Procedure
1. Double-click the DTM01 element.
2. On the Standard Rule tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Contract Effective to identify the constant.
v From the Type list, select String to indicate that the literal constant is

formatted as a string data type.
v In the Value box, enter 090 to indicate that the Date/Time Qualifier field

must contain the contract date. This value is the actual value of the literal
constant.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, do the following:

v From the Constants list, select 090 to identify the constant that is used for
this element.

v From the Qualifies list, select 0373:6 DATE, which is the element that the
Date/Time Qualifier field qualifies.

7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the DTM02 Element
The DTM02 element in the DTM segment contains the contract effective date. This
element is defined by the standard to be a date/time data type, consisting of six
alphanumeric characters. In this tutorial, you know that the contract date is always
an eight-character alphanumeric string, so you change the element and field
lengths to accommodate the longer date. In addition, you rename the field label to
more accurately reflect the field contents, and add Help text to the field.

About this task

Use this procedure to change the field and element lengths, change the field label,
and add Help text to the Date field.

Procedure
1. Double-click the DTM02 element.
2. On the Validation tab, do the following:

v In the Max box, enter 8 to allow the entire date (including the / separators)
to be contained in this element.
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v From the Form Format list, select MM/DD/YY to indicate that this field on
the translation object accepts a date entered in the format MM/DD/YY.

v Verify that YYMMDD is selected in the File Format list to indicate that the
EDI data is sent in the format YYMMDD.

3. On the Display tab, do the following:
v In the Label box, enter Contract Date to replace the existing text.
v In the Maximum number of characters box, enter 8 to allow the entire date

(including the / separators) to be displayed.
4. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the contract date. Use the format MM/DD/YY.

5. Click OK to exit the dialog.
6. Click Generate Layout on the Main Toolbar to refresh the display of the screen

entry form.

Results

The section of the Invoice frame that contains the fields in the DTM segment now
should look like this (you may need to scroll down the frame to see the fields):

Customizing the IT1 Group
The standard allows the IT1 group to be used up to one hundred thousand times
in one invoice. The IT1 group contains the following segments and group that you
already activated: IT1 segment, PID group, DTM:2 segment, and CAD segment.

About this task

The fields associated with the IT1 group are arranged on the 0400_It1 frame, which
is separate from the Invoice frame that you have been working with thus far in
this tutorial. Your users complete the fields on the 0400_It1 frame for each item in
the invoice. The list of all line items in the invoice is displayed in a list on the
Invoice frame. In that list, the invoiced items are displayed line by line, forming
columns of information.
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You already promoted or changed the maximum use of the following form
components: PID group, DTM:2 segment, and CAD segment. Now, you are ready
to customize these components and rename the IT1 group.

Use this procedure to rename the IT1 group and its frame and add Help text to the
list that is displayed on the Invoice frame.

Procedure
1. Right-click the IT1 group and select Properties.
2. In the Desc box, enter Line Items to describe the group.
3. On the Display tab, do the following:

v In the Frame Caption box, enter Line Items to rename the frame.
v In the List Caption box, enter Line Items to rename the list that is displayed

on the Invoice frame (listing the line items entered on the Line Items frame).
4. On the Help tab, enter the following text in the Frame Help Text list. (Press

Enter at the end of each line of text.)
This frame contains the line item detail �information.
For online Help on an�individual field on this frame,
select the �field and press F1.

5. On the Help tab, enter the following text in the Listbox Help Text list. (Press
Enter at the end of each line of text.)
This list contains the line item detail for�the invoice.
The data in this list is�entered or changed on the
Line Items frame. To enter a new line item, click the
list and click New. To modify an �existing line item,
click that item and click �Open.

6. Click OK to exit the Group Properties dialog.

The IT1 Segment
The IT1 segment contains the Baseline Item Data that identifies the line item detail
for each item invoiced. For some of the elements in the IT1 segment, you only
need to add Help text and rename the field labels so they more accurately reflect
your company’s needs. With other elements, you change the maximum lengths for
some of the fields, use accumulators to calculate the number of line items, or
define a constant value.

The IT1 group is subordinate to the Invoice frame, so Sterling Gentran:Server
creates a separate frame (the Line Items frame) to contain the group data (the line
item details). The system also creates a list (the Line Items list) on the Invoice
frame to allow the user to access the items in the list. Each set of data is displayed
as a row in the list. After you customize the line item fields, the Line Items list
contains these four columns of data: Item No., Product Code, Quantity, and Price.

Customizing the IT101 Element
The IT101 element (in the IT1 segment in the IT1 group) contains the Assigned
Identification for one item in the invoice. In this tutorial, you use the Assigned
Identification field to identify sequentially each line item in the invoice. You use
the Use Accum function to obtain an incremental count of the number of line
items. This number is used in the Number of Line Items field (CTT01 element).
The data type currently selected for this element is "String," so you must change
the type to "Number" for the accumulators to work properly. You change the
screen and EDI formats from "X" (a format appropriate for a string data type) to
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"N0" (a format appropriate for a number data type) to indicate that you expect
numbers with implied decimal points and no decimal places in both the screen
entry translation object and the EDI data.

About this task

You create a list definition for the IT101 element to include the line number in the
list, and rename the field label to more accurately reflect the purpose of this field
in this invoice. You change the minimum use of this element to zero to make this
element conditional. Also, you know that your users enter no more than 99,999 line
items per invoice. Each line item is numbered sequentially, starting with one, so
you need a maximum length of only five digits for this field. You change the
maximum length for this field from the default setting of eleven to five.

Use this procedure to count line items in the IT1 segment and generate a control
total in the CTT01 element of the number of line items, rename the IT101 field
label, change the field length and data type, change the screen and EDI formats,
add Help text, and create the list definition for the Assigned Identification field.

Procedure
1. Double-click the IT101 element.
2. On the Validation tab, do the following:

v In the Min box, enter 0 to make this element conditional.
v In the Max box, enter 5 to allow a five-digit number in this element.
v From the Type list, select Number as the data type in this element.
v From the Form Format list, select N0 to indicate that this field on the

translation object accepts a number with an implied decimal point and no
decimal places.

v From the File Format list, select N0 to indicate that the EDI data contains a
number with an implied decimal point and no decimal places.

3. On the Standard Rule tab, do the following:
v Select Use Accum.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation using this element.
4. In the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 0. Before any calculations are
performed on an accumulator, its content is 0. When you use this
accumulator, the system adds a new accumulator to the bottom of this list.

v In the Name box, enter Item Number. This allows you to differentiate the
purposes of the accumulators you create.

v From the First list, select Increment primary to specify that the system
increments the value in this accumulator by one for each iteration of the IT1
group. This operation is the first operation the system performs.

v From the Second list, select Use primary to specify that the system loads
the current value of the accumulator into the IT101 (Assigned Identification)
element. This operation is the second operation the system performs.

v Click OK to add the accumulator.
5. On the Display tab, do the following:

v Select Displayed but not editable to make this field display-only.
v In the Label box, enter Item No. to replace the existing text.
v In the Maximum number of characters box, enter 5.
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6. On the Summary List tab, do the following:
v In the Summary List section, select Display this field in summary. The

value in the Item No. field is displayed in a column in the Line Items list.
v In the Column Width box, enter 8 to set the width of this column in the

Line Items list.

Note: The column width should be wider than the actual content of the
column. The extra space that is not used for the content of the column
provides white space separating the columns.

v From the Sequence list, select 1 to indicate that this field is the first column
in the list.

7. Click OK to exit the dialog.
8. Double-click the CTT01 element (in the CTT segment).
9. On the Standard Rule tab, do the following:

v Select Use Accum.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation for this element.
10. In the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 0.
v From the First list, select Use primary to specify that the system loads the

current value of the accumulator into the CTT01 (Number of Line Items)
element.

v Click OK to add the accumulator.
11. On the Display tab, select Displayed but not editable. The data in the

Number of Line Items field will be display-only.
12. Click OK to exit dialog.

Customizing the IT102 Element
The IT102 element contains the Quantity Invoiced for each item in the invoice. The
quantity for each line item is used to calculate the total dollar amount of the
invoice. From this calculation, you generate a running total of extended price and
load the final total into the TDS01 (Total Invoice Amount) element.

About this task

You create a list definition for the IT102 element to include the quantity invoiced in
the list. For brevity on the translation object, you rename the field label. The
standard allows up to a ten-digit number in this field. You know that your users
do not enter a quantity of more than 99,999 (a five-digit number) for any one item,
so you change the maximum length for this field and element to five.

Use this procedure to use an accumulator in the IT102 element to generate a
running total of extended price that is used in the TDS01 element, rename the field
label, change the field and element lengths, add Help text, and create the list
definition for this field.

Procedure
1. Double-click the IT102 element (in the IT1 group).
2. On the Standard Rule tab, do the following:

v Select Use Accum.
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v Click New to access the Edit Accumulator Entry dialog to create a new
calculation using this element.

3. In the Edit Accumulator Entry dialog, do the following:
v From the Primary Accumulator list, select 1.
v In the Name box, enter Extended Price. This allows you to differentiate the

purpose of the accumulators you create.
v From the First list, select Load primary to specify that the system loads the

content of the IT102 element into the Primary Accumulator for each
iteration of the IT1 group. This operation is the first operation that the
system performs.

v Click OK to add the accumulator.
4. On the Validation tab, do the following:

v In the Max box on the Element Properties dialog, enter 5 to allow a
five-digit number in this element.

v In the Max box on the Element Properties dialog, enter 5 to allow a
five-digit number in this element.

v From the Form Format list, select R0 to indicate that this field accepts a
number with an explicit decimal point and no decimal places.

5. On the Display tab, do the following:
v In the Label box, enter Quantity to replace the existing field label.
v In the Maximum number of characters box, enter 5 to allow five numeric

digits to be displayed in this field.
6. On the Summary List tab, do the following:

v Select Display this field in summary list. The value in the Quantity field is
displayed in a column in the Line Items list.

v In the Column Width box, enter 8 to set the width of this column in the
Line Items list.

v From the Sequence list, select 3 to indicate that this field is the third column
in the list.

7. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the quantity of this invoiced item.
The quantity cannot�exceed 5 digits.

8. Click OK to exit the dialog.
9. Double-click the IT104 element.

10. On the Standard Rule tab, do the following:
v Select Use Accum.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation using this element.
11. In the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 1.
v From the First list, select Multiply with primary. The system multiplies the

value of the IT104 (Unit Price) element by the content of the primary
accumulator, and stores the result in the primary accumulator for each
iteration of the IT1 group. This operation is the first operation that the
system performs.

v Click OK to add the accumulator.
12. Click New to access the Edit Accumulator Entry dialog to create a new

calculation for this element.
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13. In the Edit Accumulator Entry dialog, do the following:
v From the Primary Accumulator list, select 2.
v In the Name box, enter Running Price. This allows you to differentiate the

purposes of the accumulators you create.
v From the First list, select Add primary to alternate. The system adds the

content of the primary accumulator to the content of the alternate
accumulator and stores the result in the primary accumulator for each
iteration of the IT1 group.

v From the Alternate Accum list, select 1. The system adds the value of
accumulator 1 (which contains the extended price for a line item) to the
value of accumulator 2. The sum is stored in accumulator 2, which contains
a running total of the extended price with each iteration of the IT1 group.

v Click OK to add the accumulator.
14. Click OK to exit the Element Properties dialog.
15. Double-click the TDS01 element (in the TDS segment).
16. On the Standard Rule tab, do the following:

v Select Use Accum.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation using this element.
17. In the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 2.
v From the First list, select Use primary. The system loads the content of the

primary accumulator into the TDS01 (Total Invoice Amount) element.
v Click OK to add the accumulator.

18. On the Validation tab, select R2 from the Form Format list to indicate that
this field accepts a number with an explicit decimal point and two decimal
places.

19. On the Display tab, select Displayed but not editable. Users are able to read
the data in the Total Invoice Amount field, but are not able to enter a value in
this field.

20. Click OK to exit the dialog.

Customizing the IT103 Element
The IT103 element contains the Unit or Basis for Measurement Code for each item
in the invoice. For brevity on the translation object, you rename the field label.
Also, you customize the IT103 element so that a list containing all valid codes in
the Unit or Basis for Measurement Code code list is available to your users when
they use the screen entry translation object. The list enables them to select the
appropriate EDI code from the ones available.

About this task

Use this procedure to rename the field label, add Help text, and load the code list
table from the standard for the Unit or Basis for Measurement Code field.

Procedure
1. Double-click the IT103 element (in the IT1 group).
2. On the Display tab, enter UOM in the Label box to replace the existing text.
3. On the Help tab, enter the following text in the Help Text list.

Select the unit of measurement for the invoiced item.
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4. On the Standard Rule tab, do the following:
v Select Use Code.
v Click Edit to access the Edit Code List dialog.

The Table ID box contains 0355, which is the name of the element for which
this code list table is used. The Desc box contains UNIT OR BASIS FOR
MEASUREMENT CODE, which is the description of the element for which
this code list table is used.

5. On the Edit Code List dialog, click Load. You are prompted to select an ODBC
data source name.

6. Select the appropriate DSN and click OK to access the Load Code List dialog.
7. On the Load Code List dialog, do the following:

v Click Add All to select all the codes and move them to the Codes Selected
list.

v Click OK to load the code list and exit the Load Code List dialog.
8. Click Close to exit the Edit Code List dialog.
9. Click OK to exit the dialog.

Customizing the IT104 Element
The IT104 element contains the Unit Price for each item in the invoice. You already
used an accumulator for this field so that the price for each line item is used to
calculate the total dollar amount of the invoice. From this calculation, a running
total of extended price is generated and the final total is loaded into the TDS01
(Total Invoice Amount) element. You create a list definition for the IT104 element
to include the unit price in the list.

About this task

For this tutorial, you rename the field label. Also, the standard designates an "R9"
screen format for this field, meaning that the price is formatted with an explicit
decimal point and up to nine decimal places. Your users enter a price in an "R2"
format (a number with up to two decimal places), so you change the screen format
from "R9" to "R2."

The standard defines this element as having a maximum length of fourteen. For
this tutorial, the items you sell Pet Zone are not priced at more than $9,999.99 each,
so this field needs a maximum length of only eight (four places for the dollars; two
places for the cents; one place for the decimal point; and one place for a plus or
minus sign, if present).

Use this procedure to rename the field label, change the field length and number
format, add Help text, and create the list definition for the Unit Price field.

Procedure
1. Double-click the IT104 element.
2. On the Validation tab, do the following:

v In the Max box, enter 8 to allow eight numeric digits in this field, including a
plus or minus sign and a decimal point.

v From the Form Format list, select R2 to indicate that this field on the
translation object accepts a number with an explicit decimal point and up to
two decimal places.

3. On the Display tab, do the following:
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v In the Label box, enter Price to replace the existing text.
v In the Maximum number of characters box, enter 8 to allow eight numeric

digits in this field, including a plus or minus sign and a decimal point.
4. On the Summary List tab, do the following:

v Select Display this field in summary list. The value in the Price field is
displayed in a column in the Line Items list box.

v In the Column Width box, enter 8 to set the width of this column in the Line
Items list.

v From the Sequence list, select 4 to indicate that this field is the fourth column
in the list.

5. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the unit price for this item. The price cannot exceed 8
digits, including a plus or minus sign and a decimal point.

6. Click OK to exit the dialog.

Customizing the IT106 Element
The IT106 element contains the Product/Service ID Qualifier for each item in the
invoice. The IT101 element contains the two-character code to indicate what type
of product/service ID is in the Product Code field (IT107 element). You know that
the only type of product/service ID that your users enter for this invoice is the
UPC code, so you define a constant value for the Product/Service ID Qualifier
field, designating that the constant "UP" qualifies the number in the Product Code
field. When a user enters a UPC code in the Product Code field, the system
automatically assigns the code "UP" to the Product/Service ID Qualifier field.

About this task

Use this procedure to define a constant value and hide the Product/Service ID
field.

Procedure
1. Double-click the IT106 element.
2. On the Standard Rule tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter UPC Package Code to identify the constant.
v From the Type list, select String.
v In the Value box, enter UP.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, do the following:

v From the Constants list, select UP.
v From the Qualifies list, select 0234 PRODUCT/SERVICE ID, which is the

element that the Product/service ID Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.
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Customizing the IT107 Element
The IT107 element contains the Product/Service ID for each item in the invoice.
For this tutorial, you rename the field label to Product Code. The standard allows
up to a thirty-character string in this field. You know that your users enter product
identification numbers (UPC codes) that are no longer than ten characters, so you
change the maximum length for this field. Also, you create a list definition for the
IT107 element to include the product code in the Line Items list on the Invoice
frame.

About this task

Use this procedure to rename the field label, change the field length, add Help
text, and create the list definition for the Product/Service ID field.

Procedure
1. Double-click the IT107 element.
2. On the Validation tab, enter 10 in the Max box.
3. On the Display tab, do the following:

v In the Label box, enter Product Code.
v In the Maximum number of characters box, enter 10.

4. On the Summary List tab, do the following:
v Select Display this field in summary list. The value in the Price field is

displayed in a column in the Line Items list box.
v In the Column Width box, enter 13 to set the width of this column in the

Line Items list.
v From the Sequence list, select 2 to indicate that this field is the second

column in the list.
5. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter your company’s product code for this item
in the invoice. The product code cannot exceed
10 alphanumeric characters.

6. Click OK to exit the dialog.

The PID:2 Segment
The PID group contains the Product/Item Description for each item in the invoice.
You already activated the PID:2 segment in the PID group.

The PID:2 segment (in the PID group) contains the Product/Item Description for
each item in the invoice. When the PID:2 segment is activated, the PID:201 element
is mandatory. Earlier in this tutorial, you activated the PID:205 element also. The
PID:205 element provides a description of each item in the invoice, and the
PID:201 element qualifies that description.

Customizing the PID:201 Element
By standard definition, the PID:201 element contains the Item Description Type ("F"
for free-form item description, "S" for structured description, or "X" for
semi-structured description) for the invoiced item. For this tutorial, you know that
the only type of description your users enter for this invoice is a free-form
description. You define a constant value for the Item Description Type field to
indicate that the constant "F" qualifies the text in the Description field. When a
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user enters a free-form description in the Description field, the system
automatically assigns the code "F" to the Item Description Type field.

About this task

Use this procedure to define a constant value and hide the Item Description Type
field.

Procedure
1. Double-click the PID:201 element.
2. On the Standard Rule tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Free-Form Description to identify the constant.
v From the Type list, select String.
v In the Value box, enter F. The Product/Service ID Qualifier field is a

free-form description. This value is the actual value of the literal constant.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, do the following:

v From the Constants list, select F to identify the constant that is used for this
element.

v From the Qualifies list, select 0352 DESCRIPTION, which is the element that
the Item Description Type field qualifies.

7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the PID:205 Element
The PID:205 element contains the Description of each invoiced item and is defined
by the standard to be a string of up to eighty alphanumeric characters. Add Help
text to this field.

About this task

Use this procedure to add Help text to the Description field.

Procedure
1. Double-click the PID:205 element.
2. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the description of the invoiced item.
The description�cannot exceed 80 alphanumeric characters.

3. Click OK to exit the dialog.
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The DTM:2 Segment for an Invoice

Customizing the DTM:201 Element
In this tutorial, you use two iterations of the DTM segment (Date/Time Reference).
The first active DTM segment in the invoice (the DTM:2 segment) is used to enter
the contract date of the invoice. The DTM:2 segment you customize first is in the
IT1 group (on the Line Items frame) and specifies the date on which each item in
the invoice was shipped. You already changed the maximum use of the DTM:2
segment so that its associated fields are displayed on the same frame as the PID:2
and IT1 fields.

About this task

The DTM:201 element (Date/Time Qualifier) is a mandatory element for the
DTM:2 segment. The DTM:201 element contains the three-character code from your
EDI data to indicate what type of date follows (e.g., date shipped). You define a
constant value for the Date/Time Qualifier field, designating that the constant
"011" qualifies the date in the Date field.

When a user enters the date on which the item was shipped in the Date field, the
system automatically assigns the code 011 to the Date/Time Qualifier field. The
user does not need to enter the code in the qualifier field, so the qualifier field
does not need to be displayed.

Use this procedure to define a constant and hide the Date/Time Qualifier field.

Procedure
1. Double-click the DTM:201 element.
2. On the Standard Rule tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Date Shipped to identify the constant.
v From the Type list, select String.
v In the Value box, enter 011. The Date/Time Qualifier field contains the Date

Shipped.. This value is the actual value of the literal constant.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, do the following:

v From the Constants list, select 011.
v From the Qualifies list, select 0373:6 DATE, which is the element that the

Date/Time Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the DTM:202 Element
The DTM:202 element in the DTM:2 segment contains the Date qualified by the
Date/Time Qualifier field. This element is defined by the standard to be a
Date/Time data type of six characters. In this tutorial, you know that the shipped
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date is always an eight-character date, so you change the element and field lengths
to accommodate the new length. Also, you rename the field label and add Help
text to the field.

About this task

Your users format the date as MM/DD/YY when they enter the date in the screen
entry translation object, but the EDI data is sent to your trading partner as
YYMMDD. You set the screen format and EDI format for this element accordingly.

Use this procedure to set the date format, change the element and field lengths,
rename the field label, and add Help text to the Date field.

Procedure
1. Double-click the DTM:202 element.
2. On the Validation tab, do the following:

v In the Max box, enter 8 to allow the entire date (including the / separators)
to be contained in this element.

v From the Form Format list, select MM/DD/YY to indicate that this field on
the translation object accepts a date entered in the format MM/DD/YY.

v Verify that YYMMDD is selected in the File Format list to indicate that the
EDI data is sent in the format YYMMDD.

3. On the Display tab, do the following:
v In the Label box, enter Date Shipped.
v In the Maximum number of characters box, enter 8 to allow the entire date

(including the / separators) to be displayed.
4. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the date on which this invoiced item
was shipped. Use �the format MM/DD/YY.

5. Click OK to exit the Display dialog.

The CAD Segment

Customizing the CAD01 Element
The CAD segment contains Carrier Detail, such as the transportation method. For
this tutorial, you provide a list for users from which users select the transportation
method for the invoiced item, and provide a field so they can enter a reference
number to identify the carrier.

About this task

The CAD01 element, the Transportation Method/Type Code, contains the
two-character code that identifies the transportation method (e.g., parcel post, air
express, etc.) for each invoiced item. You customize the CAD01 element so that a
list containing all valid codes in the Transportation Method/Type Code list is
available to your users when they use the screen entry translation object.

After you specify the code list table to use for the list for the Transportation
Method/Type Code field, you rename the field label to identify this field better.
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Use this procedure to load the code list table from the standard, rename the field
label, and add Help text to the Transportation Method/Type Code field.

Procedure
1. Double-click the CAD01 element.
2. On the Standard Rule tab do the following:

v Select Use Code.
v Click Edit to access the Edit Code List dialog.

The Table ID box contains 0091, the name of the element for which this code
list table is used. The Desc box contains TRANSPORTATION
METHOD/TYPE CODE, the description of the element for which this code
list table is used.

3. On the Edit Code List dialog, click Load. You are prompted to select an ODBC
data source name.

4. Select the appropriate DSN and click OK to access the Load Code List dialog.
5. On the Load Code List dialog, do the following:

v Click Add All to select all the codes and move them to the Codes Selected
list.

v Click OK to load the code list and exit the Load Code List dialog.
6. Click Close to exit the Edit Code List dialog.
7. On the Display tab, enter Transport Method in the Label box.
8. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Select the transportation method code
for this invoiced item�from the list.

9. Click OK to exit the dialog.

Customizing the CAD08 Element
The CAD08 element contains a Reference Number, which is used in this tutorial to
identify the carrier for an invoiced item. This element is defined by the standard to
be a string of thirty alphanumeric characters. Your company has assigned reference
numbers to the carriers with whom they have contracted. In this tutorial, you
know that the carrier reference number cannot exceed twelve alphanumeric
characters. You change the element and field lengths to accommodate the shorter
reference number. In addition, you rename the field label and add Help text to the
field.

About this task

Use this procedure to change the field and element lengths, rename the field label,
and add Help text for the Reference Number field.

Procedure
1. Double-click the CAD08 element.
2. On the Validation tab, enter 12 in the Max box.
3. On the Display tab, do the following:

v In the Label box, enter Carrier Code.
v In the Maximum number of characters box, enter 12.

4. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
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Enter your company’s reference number for this carrier.
The�reference number cannot exceed 12 alphanumeric�characters.

5. Click OK to exit the dialog.
6. Click Generate Layout on the Main Toolbar to refresh the display of the screen

entry form.
7. Click Save from the File menu to save the form.

Results

The Line Items list now should look like this:

The TDS Segment
The TDS segment contains the Total Monetary Value Summary for the invoice.

You already used an accumulator in the TDS01 element to calculate the total dollar
amount invoiced, and made this field display-only so that users cannot change the
value in this field.

The CTT Segment
The CTT segment is a mandatory segment that displays Transaction Totals for the
invoice.

For this tutorial, you use the CTT01 element to display the total number of line
items invoiced. You already used an accumulator in the CTT01 element to generate
a total of the number of line items, and made this field display-only so that users
cannot change the value in this field.

Now that you have customized all of the elements used in this invoice, you are
ready to format the fields and labels to make the frames more consistent and
visually attractive.
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Chapter 5. Customizing Screen Entry Forms for ANSI X12

Resizing the Invoice Frame
When a form is compiled into a translation object, the fields are arranged
according to how the frames and the fields contained on them were arranged
when the form was compiled. You should eliminate unnecessary space as you
arrange the fields on each frame.

About this task

Important: When you resize the frames of a screen entry form, you must resize
based on the resolution of the target monitor (for example, the monitor on which
the end user views the translation object).

Use this procedure to resize the Invoice frame.

Procedure
1. Click the invoice file icon to display the Invoice frame in the Layout Window.

Note: When the form is generated, the upper left corner of each frame in the
form is placed in the upper left corner of the Layout Window.

2. To display more of the form on your screen, click and drag the center bar
between the EDI File Format Window and the Layout Window to the left until
the Layout Window is wide enough to display as much of the form as you
want to view.

3. To resize the Invoice frame, click and drag the right side of the frame
approximately to the 14 cm. mark on the horizontal ruler so that the form is
wide enough to format the fields according to the instructions in this tutorial.

Fields on the Invoice Frame
You begin formatting the screen entry form by arranging the fields on the Invoice
frame. You place the fields in the translation object in a logical order, then align the
fields to give the frame a consistent and orderly appearance.

By default, each field and its associated label are displayed on their own line.
However, it is common for invoices to place two or more fields on a line.

You prevented some of the field labels from being displayed (by removing the field
label in the Label field of the Display dialog). For these fields, the fields are
displayed on your screen entry form, but their associated labels are not displayed.
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The Invoice frame now should look like this:

EDIFACT

The Invoice Message frame now should look like this:
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TRADACOMS

The Invoice Details frame now should look like this:

Arranging Fields

Rearranging the Fields
Use this procedure to resize, move, and align the fields on the Invoice frame of the
screen entry form:

About this task

Procedure
1. Select the following fields and select Display > Size to Length.

v Invoice Date
v Invoice No.
v P.O. Date
v P.O. No.
v Contract No.
v Contract Date
The selected fields are resized to the lengths specified in the Maximum
number of characters box of the Display dialog for each field.

2. Drag the following fields closer to their respective labels:
v Invoice Date
v Invoice No.
v P.O. Date
v P.O. No.
v Contract No.
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v Contract Date
3. Drag the Invoice Date label and field to the upper right corner of the Invoice

frame.
4. Drag the Invoice No. label and field to the upper left corner of the frame.
5. Drag the P.O. Date label and field to the right side of the frame, below the

Invoice Date label and field.
6. Drag the P.O. No. label and field to the left side of the frame, below the

Invoice No. label and field.
7. Drag the Contract No. label and field to the left side of the frame, below the

P.O. No. label and field.
8. Drag the Contract Date label and field to the right side of the frame, below

the P.O. Date label and field.
9. Rearrange the fields of the Ship To address as follows:

v Select the Ship To field (not the label), the two Address Information fields,
and the City Name field.

v Select Display > Align Controls > Left.
v Drag the State or Province Code field to the immediate right of the City

Name field.
v Drag the Postal Code field to the immediate right of the State or Province

Code field.
v Drag all of the Ship To fields (including the Ship To field label) to the left

side of the frame, below the Contract No. label and field.
v Drag all of the Ship To fields (not including the Ship To field label) closer

to the Ship To field label.
10. Rearrange the fields of the Remit To address as follows:

v Select the Remit To field (not the label), the two Address Information fields,
and the City Name field.

v Select Display > Align Controls > Left.
v Drag the State or Province Code field to the immediate right of the City

Name field.
v Drag the Postal Code field to the immediate right of the State or Province

Code field.
v Drag all of the Remit To fields (not including the Remit To field label)

closer to the Remit To field label.
v Drag all of the Remit To fields (including the Remit To field label) below

the Ship To address.
11. Select the Payment Terms Code list and do the following:

v Click and drag its right handle so that the list is approximately 1.5 cm. wide
(including the down arrow).

v Click and drag its bottom handle to make the drop-down part of the list
long enough to list approximately four codes.

v Drag the Payment Terms Code list and label to the center of the frame,
below the Remit To address.

12. Rearrange the fields of the Line Items as follows:
v Drag the Line Items list closer to its label.
v Drag the Line Items list and label to the center of the frame, below the

Payment Terms Code list and label.

82 IBM Sterling Gentran:Server for Windows: Forms Integration Tutorial for Screen Entry Forms



Leave extra space between the Payment Terms Code list and label, and the
Line Items list and label, to add column headings (using static text) to label
the data in the list.

v Drag the Number of Line Items field closer to its label.
v Drag the Number of Line Items label and field to the center of the frame,

below the Line Items list and label.
13. Drag the Total Invoice Amount field closer to its label. Then drag its label

and field to the center of the frame, below the Number of Line Items label
and field.

Resizing the Invoice Frame
You should resize the Invoice frame to make the most efficient use of space. You
already resized the frame horizontally before you began arranging the fields. Then,
you arranged the fields on the frame, so the fields do not use the same amount of
vertical space as before you arranged the fields.

About this task

To make better use of the frame space, resize the frame vertically now.

Procedure
1. To resize the Invoice frame, click and drag the bottom of the frame to just

below the Total Invoice Amount label and field.
2. Select File > Save.

Results

The Invoice frame now should look like this:

Chapter 5. Customizing Screen Entry Forms for ANSI X12 83



Aligning the Fields and Labels
Now that the fields in the Invoice frame are resized and moved to their proper
locations, you can align the fields and labels.

About this task

Use this procedure to align the fields and field labels on the Invoice frame.

Procedure
1. Select the following labels and select Display > Align Controls > Left.

v Invoice No.
v P.O. No.
v Contract No.
v Ship To
v Remit To

2. Select the following fields and select Display > Align Controls > Left.
v Invoice No.
v P.O. No.
v Contract No.

3. Select the following labels and select Display > Align Controls > Left.
v Invoice Date
v P.O. Date
v Contract Date

4. Select the following fields and select Display > Align Controls > Left.
v Invoice Date
v P.O. Date
v Contract Date

5. Select the following labels and select Display > Align Controls > Left.
v Number of Line Items
v Total Invoice Amount

6. Select the following fields and select Display > Align Controls > Left.
v Number of Line Items
v Total Invoice Amount

7. To align the tops of all of the field labels and fields, select each row of items
(one row at a time) as listed below. Then select Display > Align Controls >
Top.
v Invoice No. label and field, Invoice Date label and field
v P.O. No. label and field, P.O. Date label and field
v Contract No. label and field, Contract Date label and field
v Ship To label and field
v City Name, State or Province Code, and Postal Code fields of the Ship To

address
v Remit To label and field
v City Name, State or Province Code, and Postal Code fields of the Remit To

address
v Payment Terms Code label and list
v Line Items label and list
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v Number of Line Items label and field
v Total Invoice Amount label and field

Results

The Invoice frame now should look like this:

Adding Column Headings to the Line Items List
When you moved the fields on the frame, you already left space in the appropriate
locations for the static text. In this section of the tutorial, you will add the static
text and move it to the proper locations in the frame.

About this task

Sterling Gentran:Server labels the fields on the Line Items frame but does not label
the column headings for the Line Items list on the Invoice frame. The Line Items
list displays the information entered into the fields on the Line Items frame. To
label the columns in the Line Items list, you must add the column headings with
static text.

You will add the following column headings to the Line Items list on the Invoice
frame:

Column Heading (Static
Text) Placement Above Line Items List

Item First column

Product Second column

Qty. Third column

Price Fourth column

After you add the column headings and move each column heading to its proper
location, the Line Items list and the column headings should look like this:
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Use this procedure to add and position the column headings.

Procedure
1. Click Add Text on the Main Toolbar. Text is added to the current frame,

displayed in the upper left corner of the frame. If the template is larger than
the frame (there is a scroll bar on the right side of the frame), the static text is
displayed in the upper left corner of the part of the template that is displayed,
not at the top of the template.

2. In the new text box, enter Item and click OK.
3. Click Add Text on the Main Toolbar and enter Product in the text box and

click OK.
4. Click Add Text and enter Qty. in the text box and click OK.
5. Click Add Text and enter Price in the text box and click OK.
6. The column headings you added are displayed in the upper left corner of the

frame.
7. Drag the Item static text to above the Line Items list,starting about 1 cm from

the left margin of the Line Items list.
8. Drag the Product static text to above the Line Items list, to the right of the

Item column heading.
9. Drag the Qty. static text to above the Line Items list, , nearly 8 cm. from the

left margin of the list box.
10. Drag the Price static text to above the Line Items list, near the right margin of

the list box.
11. To ensure that the column headings (static text) you just added are aligned

properly, select all the static text you just added (Item, Qty., Product, Price).
Select Display > Align Controls > Top.
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Results

The Invoice frame now should look like this:

Setting the Tab Sequence on the Invoice Frame
The tab sequence is the order in which the cursor moves from field to field in the
screen entry translation object when a user presses Tab. When you create a screen
entry form, the system automatically positions the fields and sets the tab sequence
for those fields. However, usually you want to modify the tab sequence of the
fields to meet your screen entry requirements and the new positions of the fields
on the frame.

About this task

Note: If you click a field out of sequence, you must begin setting the tab sequence
again. To start over, select Display > Set Tab Order so that the tab sequence
numbers are no longer displayed in the fields on the frame. Then begin the steps
again. When you click the last field in the sequence, the tab sequence is set, and
the tab sequence numbers no longer are displayed in the fields.

Use this procedure to set the tab sequence for the fields on the Invoice frame.

Procedure
1. Select Display > Set Tab Order.

Numbers are displayed in the fields on the frame to indicate the current tab
sequence.

2. Click the items below in the order in which they are listed. As you click each
field, the tab sequence number for that field will change to the next sequential
number in the tab sequence.
a. Invoice No.
b. Invoice Date
c. P.O. No.
d. P.O. Date
e. Contract No.
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f. Contract Date
g. Ship To name
h. Ship To address (first line of address)
i. Ship To address (second line of address)
j. Ship To city
k. Ship To state or province code
l. Ship To postal code
m. Remit To name
n. Remit To address (first line of address)
o. Remit To address (second line of address)
p. Remit To city
q. Remit To state or province code
r. Remit To postal code
s. Payment Terms Code
t. Line Items
u. Number of Line Items
v. Total Invoice Amount

Results

The new tab sequence should look like this:

Fields in the Line Items Frame
Now that the fields, labels, and static text are arranged on the Invoice frame, you
are ready to arrange the fields on the Line Items frame.
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About this task

You will place the fields in a logical order, then align the fields (as you did with
the fields on the Invoice frame) to give the frame a consistent and orderly
appearance.

When you finish arranging the fields, the Line Items frame in your form should
look like the one in the example below.

Resizing the Line Items Frame and Fields
Before you begin arranging the fields on the Line Items frame, you should resize
the frame so that it is the same width as the Invoice frame. When this form is
compiled into a translation object, the fields will be arranged according to how the
frames and the fields contained on them were arranged when the form was
compiled. You should eliminate unnecessary space as you arrange the fields on
each frame.

About this task

Use this procedure to resize the line items frame.

Procedure
1. Click the IT1 group to display the Line Items frame in the Layout Window.
2. To resize the Line Items frame, click and drag the right side of the frame to the

14 cm. mark on the horizontal ruler.
3. To display more of the form on your screen, drag the center bar between the

EDI File Format Window and the Layout Window to the left until the Layout
Window is wide enough to display as much of the form as you want.

4. Select the following fields and select Display > Size to Length.
v Item No.
v Quantity
v Price
v Product Code
v Date Shipped
v Carrier Code
The selected fields are resized to the lengths specified in the Maximum number
of characters box of the Display dialog for each field.
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Moving and Aligning the Fields
About this task

Use this procedure to move and align the fields on the Line Items frame of the
screen entry form.

Procedure
1. Select the UOM list and drag its right handle so that it is approximately 2 cm.

wide (including the down arrow).
2. Drag its bottom handle so that the list is long enough for four codes to be

displayed in it when the drop-down section is open (approximately 2 cm. on
the vertical ruler).

3. Select the Transport Method and UOM lists (in that order) and select Display
> Size Equally. The Transport Method list is the same size as the UOM list
(the reference).

4. Select each field on the frame individually and move it closer to its respective
field label. If the field overlaps its label (for example, Date Shipped), move the
field slightly to the right of the label.

5. Drag the Product Code label and field to the right of the Item No. label and
field.

Note: The Item No. label and field are already positioned where you want
them (in the upper left corner of the frame). You do not need to move them.

6. Drag the Quantity label and field to the right of the Product Code label and
field.

7. Drag the UOM label and list below the Item No. label and field. The left side
of the UOM field label should be aligned with the left side of the Item No.
field label.

8. Drag the Price label and field below the Product Code label and field. The left
side of the Price field label should be aligned with the left side of the Product
Code field label.

9. Drag the Description label and field below the UOM and Price labels and
fields. The left side of the Description field label should be aligned with the
left side of the Item No. and UOM field labels.

10. Drag the Date Shipped label and field to the left side of the frame, below the
Description label and field. The left side of the Date Shipped field label should
be aligned with the left side of the Item No., UOM, and Description field
labels.

11. Drag the Transport Method label and list to the right of the Date Shipped
label and field.

12. Drag the Carrier Code label and field to the right of the Transport Method
label and field.

Resizing the Line Items Frame
About this task

Use this procedure to resize the Line Items frame.

Procedure

To resize the Line Items frame, click and drag the bottom of the frame to below the
last row of fields and labels (Date Shipped, Transport Method, and Carrier Code).
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Note: Allow enough space between the last row of fields/labels and the bottom of
the frame for the Transport Method list to be opened.

Aligning the Fields and Field Labels
About this task

Use this procedure to align the fields and field labels on the Line Items frame.

Procedure
1. Select the following labels and fields and select Display > Align Controls >

Top.
v Item No.
v Product Code
v Quantity

2. Select the following labels and fields and select Display > Align Controls >
Top.
v UOM
v Price

3. Select the Description label and field and select Display > Align Controls >
Top.

4. Select the following labels and fields and select Display > Align Controls >
Top.
v Date Shipped
v Transport Method
v Carrier Code

5. Select the following field labels and select Display > Align Controls > Left.
v Item No.
v UOM
v Description
v Date Shipped

6. Select the following fields and select Display > Align Controls > Left.
v Item No.
v UOM
v Description

7. Select the following field labels and select Display > Align Controls > Left.
v Product Code
v Price

8. Select the following fields (in this order) and select Display > Align Controls >
Left.
v Price
v Product Code
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Results

The Line Items frame now should look like this:

Setting the Tab Sequence on the Line Items Frame
About this task

Use this procedure to set the tab sequence of the fields on the Line Items frame.

Procedure
1. Select Display > Set Tab Order.

Numbers are displayed in the fields on the frame to indicate the current tab
sequence.

2. Click the items below in the order in which they are listed. As you click each
field, the tab sequence number for that field change to the next sequential
number in the tab sequence you are now setting.
a. Product Code
b. Quantity
c. UOM
d. Price
e. Description
f. Date Shipped
g. Transport Method
h. Carrier Code
i. Item No.

Note: The Item No. field is the last field in the tab sequence, although it is the
first field in the layout of the Line Items frame. This field is display-only,
displaying the next consecutive line item number (the line item number is
generated by an extended rule in the IT1 segment). By placing the Item No.
field last in the tab sequence, this field can be skipped easily by users entering
data. The first field in the sequence is the Product Code field, which is the first
field into which users can enter a value.
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Results

The new tab sequence should look like this:

When you click the last field in the sequence (Item No.), the tab sequence is set,
and the tab sequence numbers no longer are displayed in the fields.

Changing the Invoice Frame Title
The system automatically titles the frames in a screen entry form when the form is
created, based on the name of the file, segments, or groups. You can modify the
frame titles (for example, at the file or document level) to distinguish one form
from the others. The parent frame of the invoice currently is titled Invoice. You
give this frame a more descriptive title to distinguish it from other invoices that
your company uses.

About this task

Use this procedure to change the frame title.

Procedure
1. Right-click the invoice file icon and select Properties.
2. On the Display tab, enter ANSI X12 Invoice (810) - Pet Zone in the Frame

Caption box.
3. Click OK.

The new frame title is displayed in the frame title in the Layout Window.
4. Click Generate Layout on the Main Toolbar to refresh the display.
5. Select File > Save.

Results

You have completed your Invoice form. Now, you are ready to finalize the form.
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Chapter 6. Creating Screen Entry Forms for EDIFACT

Modifying the DTM Segment
The DTM segment contains the Date/Time Reference Numbers for the invoice. The
DTM segment is used for the invoice date associated with the invoice number (in
the BGM segment). The standard allows the DTM segment to be used up to 35
times in one invoice. You will use the DTM segment only once (for the invoice
date). You will change the maximum use of the DTM segment to one, which will
place the associated fields on the main Invoice Message frame with the majority of
the invoice fields.

About this task

The DTM:2 segment (in the RFF group) contains the Date/Time Reference
information for the reference. In this tutorial, the DTM:2 segment is used for the
purchase order date associated with the purchase order number (in the RFF
segment). The standard allows the DTM:2 segment to be used up to five times
each time the RFF group is used. You need use the DTM:2 segment once (for the
purchase order date). You will change the maximum use of the DTM:2 segment to
one, which will place the associated fields on the main Invoice Message frame with
the majority of the invoice fields.

Use this procedure to change the maximum use of the DTM segment.

Procedure
1. Right-click the DTM segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box to designate that this

segment can be used only once per invoice.
3. Click OK to exit the Segment Properties dialog.
4. Right-click the DTM:2 segment and select Properties.
5. On the Looping tab, enter 1 in the Max Usage box to designate that this

segment can be used only once per invoice.
6. Click Yes at the prompt.
7. Click OK to exit the Segment Properties dialog.

Modifying the RFF Group
The standard allows the RFF group (Reference) to be used up to 10 times in one
invoice. If the invoice were generated now, the fields associated with the RFF
group would be displayed on a separate frame than the majority of the invoice
fields. You need two iterations of the RFF group, each with a maximum use of one.
You will enter the purchase order number and date in the first RFF group and the
contract number and date in the second RFF group.

About this task

You need to split the RFF group to obtain a second iteration of the RFF group (the
new RFF group will be named RFF:2), then you need to change the maximum use
of the original group (RFF).

© Copyright IBM Corp. 1996, 2012 95



Use this procedure to modify the RFF group.

Procedure
1. Right-click the RFF group and select Split.
2. Click Yes at the prompt.

The system displays the Split dialog.
3. In the First Loop Entries box, enter 1 to indicate that you want the RFF group

to be split after the first iteration.
The resulting split will generate one RFF group (RFF:2) that has a maximum
use of one, and will retain the original RFF group (with a maximum use of
nine).

4. Click OK to exit the Split dialog.
5. Right-click the RFF:2 group and select Properties.
6. On the Display tab, select Promote group to parent frame to display the

fields in this group on the same frame as the fields in the parent group.
7. Click OK to exit the Group Properties dialog.
8. Right-click the RFF group and select Properties.
9. On the Looping tab, enter 1 in the Max Usage box to designate that this

group can be used only once per invoice.
10. On the Display tab, select Promote group to parent frame to display the

fields in this group on the same frame as the fields in the parent group.
11. Click OK to exit the Group Properties dialog.

Modifying the NAD Group
The standard allows the NAD group (Name and Address) to be used up to 20
times in one invoice. If the invoice were generated now, the fields associated with
the NAD group would be displayed on a separate frame than the majority of the
invoice fields. You know that your users complete the fields in this iteration of the
NAD group only once per invoice. You need to change the maximum use of the
NAD group to one, which moves the Name and Address fields to the parent frame
(the main Invoice Message frame).

About this task

After you change the maximum use of the NAD group, you need to copy the
NAD group and paste the copy at the same level as the original group to create a
second iteration of the NAD group. Users will enter the Ship To name and address
in the first iteration of the NAD group, and they will enter the Remit To name and
address in the second iteration of the NAD group (NAD:2).

Use this procedure to modify the NAD group

Procedure
1. Right-click the NAD group and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box .
3. On the Display tab, select Promote group to parent frame to display the fields

in this group on the same frame as the fields in the parent group.
4. Click OK to exit the Group Properties dialog.
5. With the NAD group still selected, click Copy on the Main Toolbar.
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6. Click Paste on the Main Toolbar to paste the NAD group after the existing
NAD group.

7. Click Paste after the selected item (at the same level) option to paste the
Clipboard contents after the original NAD group. The pasted NAD group is
named NAD:2.

8. Click OK to exit the dialog.

Modifying the Invoice PAT Group
The standard allows the PAT group (Payment Terms) to be used up to 10 times in
one invoice. If the invoice were generated now, the fields associated with the PAT
group would be displayed on a separate frame than the majority of the invoice
fields. For this tutorial, you know that your users complete the fields in the PAT
group only once per invoice. You need to change the maximum use of the PAT
group to one, which moves the Payment Terms fields to the main Invoice Message
frame.

About this task

Use this procedure to change the maximum use of the PAT group.

Procedure
1. Right-click the PAT group and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box .
3. On the Display tab, select Promote group to parent frame to display the fields

in this group on the same frame as the fields in the parent group.
4. Click OK to exit the dialog.

The LIN Group

Changing the Maximum Use of the PIA Segment
The PIA segment (in the LIN group) contains the Additional Product ID for each
line item. The standard allows the PIA segment to be used up to 25 times per line
item. Your users use the PIA segment only once per line item (for the product
code). You need to change the maximum use of the PIA segment to one, which
places the associated fields on the frame containing other line item fields.

About this task

Use this procedure to change the maximum use of the PIA segment.

Procedure
1. Right-click the PIA segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box .
3. Click OK to exit the Segment Properties dialog.

Changing the Maximum Use of the IMD:2 Segment
The IMD:2 segment (in the LIN group) contains the Item Description for each line
item. The standard allows the IMD:2 segment to be used up to 10 times per line
item. Your users use the IMD:2 segment only once per line item (for the free-form
description). You need to change the maximum use of the IMD:2 segment to one,
which places the associated fields on the frame containing other line item fields.
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About this task

Use this procedure to change the maximum use of the IMD:2 segment.

Procedure
1. Right-click the IMD:2 segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box .
3. Click OK to exit the Segment Properties dialog.

Changing the Maximum Use of the MEA:2 Segment
The MEA:2 segment (in the LIN group) contains the Measurements for each line
item. The standard allows the MEA:2 segment to be used up to five times per line
item. Your users use the MEA:2 segment only once per line item (for the unit of
measure). You need to change the maximum use of the MEA:2 segment to one,
which places the associated fields on the frame containing other line item fields.

About this task

Use this procedure to change the maximum use of the MEA:2 segment.

Procedure
1. Right-click the MEA:2 segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box .
3. Click OK to exit the Segment Properties dialog.

Changing the Maximum Use of the QTY:2 Segment
The QTY:2 segment (in the LIN group) contains the Quantity for each line item.
The standard allows the QTY:2 segment to be used up to five times per line item.
Your users use the QTY:2 segment only once per line item (for the invoiced
quantity). You need to change the maximum use of the QTY:2 segment to one,
which places the associated fields on the frame containing other line item fields.

About this task

Use this procedure to change the maximum use of the QTY:2 segment.

Procedure
1. Right-click the QTY:2 segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box.
3. Click OK to exit the Segment Properties dialog.

Changing the Maximum Use of the DTM:11 Segment
The DTM:11 segment (in the LIN group) contains the Date/Time/Period for each
line item. The standard allows the DTM:11 segment to be used up to 35 times per
line item. Your users use the DTM:11 segment only once per line item (for the date
shipped). You need to change the maximum use of the DTM:11 segment to one,
which places the associated fields on the frame containing other line item fields.

About this task

Use this procedure to change the maximum use of the DTM:11 segment.
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Procedure
1. Right-click the DTM:11 segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box.
3. Click OK to exit the Segment Properties dialog.

Changing the Maximum Use of the MOA Group in the LIN
Group

The standard allows the MOA group (Monetary Amount) in the LIN group to be
used up to five times per line item. If the invoice were generated now, the fields
associated with the MOA group would be displayed on a separate frame than the
majority of the line item fields. For this tutorial, you know that your users will
complete the fields in the MOA group only once per line item. You will change the
maximum use of the MOA group to one, which will place the Monetary Amount
fields on the frame containing other line item fields.

About this task

Use this procedure to change the maximum use of the MOA group.

Procedure
1. Right-click the MOA group and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box.
3. On the Display tab, select Promote group to parent frame.
4. Click OK to exit the Group Properties dialog.

Changing the Maximum Use of the TDT Group
The standard allows the TDT group (Details of Transport) in the LIN group to be
used up to five times per line item. If the invoice were generated now, the fields
associated with the TDT group would be displayed on a separate frame than the
majority of the line item fields. For this tutorial, you know that your users will
complete the fields in the TDT group only once per line item. You will change the
maximum use of the TDT group to one, which will place the Details of Transport
fields on the frame containing other line item fields.

About this task

Use this procedure to change the maximum use of the TDT group.

Procedure
1. Right-click the TDT group select Properties.
2. On the Looping tab, enter 1 in the Max Usage box.
3. On the Display tab, select Promote group to parent frame.
4. Click OK to exit the Group Properties dialog.

Changing the Maximum Use of the CNT Segment
The CNT segment contains the Control Totals for each line item. The standard
allows the CNT segment to be used up to 10 times per line item. Your users use
the CNT segment only once per line item (for the total number of line items). You
need to change the maximum use of the CNT segment to one, which moves the
Control Total fields to the main Invoice Message frame.
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About this task

Use this procedure to change the maximum use of the CNT segment.

Procedure
1. Right-click the CNT segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box.
3. Click OK to exit the Segment Properties dialog.

Changing the Maximum Use of the MOA Group
The standard allows the MOA group (Monetary Amount), in the summary section,
to be used up to one hundred times per invoice. If the invoice were generated
now, the fields associated with the MOA group would be displayed on a separate
frame than many of the invoice fields. You know that your users complete the
fields in the MOA group only once per invoice. You need to change the maximum
use of the MOA group to one, which places the Monetary Amount fields on the
main Invoice Message frame.

About this task

Use this procedure to change the maximum use of the MOA group.

Procedure
1. Right-click the MOA group and select Properties.
2. On the Looping tab, enter 1 in the Max Usage box .
3. On the Display tab, select Promote group to parent frame.
4. Click OK to exit the Group Properties dialog.
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Chapter 7. Modiyfing Screen Entry Forms for EDIFACT

Setting up the Document Name for the Screen Entry Form
The document name makes the identification of a document created by the form
easier by enabling you to differentiate between documents.

About this task

We recommend that you set up a Document Name for each form. You can choose
any string element as the document name, but we strongly recommend that you
select an element that occurs only once in the document and has a data type of
string. For an ANSI X12 810 invoice, the document name usually is the Invoice
Number. For an EDIFACT 92.1 invoice, the document name is usually the
Document/Message Number.

Use this procedure to set up the document name.

Procedure
1. Double-click the one of the following elements:

v BIG02 (for ANSI X12)
v BGM05 (for EDIFACT)
v IRF INVN (for TRADACOMS)
We recommend that you select this element because it is a non-recurring and
mandatory element, and it helps to identify this document meaningfully in
Sterling Gentran:Server.

2. On Standard Rule tab, do the following:
v Select Update from the list.
v Click Yes at the prompt.
v From the Table/Group list, select Document record to indicate that you are

updating the document record in Sterling Gentran:Server.
v From the Column/Field list, select Document Name to indicate that you are

updating the Name field (in the Sterling Gentran:Server document browsers
that contain this message) with the contents of the B1G02 element.

3. Click OK to set up the document name.

Customizing the BGM Segment
The BGM segment contains the Beginning of Message for the invoice. This
mandatory segment contains information that is pertinent to the entire invoice.

About this task

The BGM05 element contains the Document/Message Number. This element is
defined by the standard to be a string of 35 alphanumeric characters. You know
that the invoice number your users enter is always an eight-character
alphanumeric string so you need to change the element and field lengths to
accommodate the shorter invoice number. You also need to rename the field label
and add Help text to the field.
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Use this procedure to change the field and element lengths, rename the field label,
and add Help text to the Document/Message Number field.

Procedure
1. Double-click the BGM05 element.
2. On the Validation tab, enter 8 in the Max box for the maximum number of

characters allowed for this element.
3. On the Display tab, do the following:

v In the Label box, enter Invoice No. to replace the existing text.
v In the Maximum number of characters to be printed box, enter 8 to allow

eight characters to be entered in this field.
4. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the invoice number. The invoice number
cannot�exceed 8 alphanumeric characters.

5. Click OK to exit the dialog.

The DTM Segment

Customizing the DTM01 Element
The DTM segment (Date/Time/Period) is used to enter the invoice date. The
standard allows the DTM segment to be used up to 35 times per invoice. You will
use the DTM segment only once per invoice. You have already changed the
maximum use of the DTM segment to obtain just one instance of the DTM
segment and to place the invoice date on the same frame as the invoice number.

About this task

The DTM01 element contains the Date/Time/Period Qualifier, a mandatory
three-character code that qualifies the date that follows (in the DTM02 element).
You know that the only type of date your users enter in the Date/Time/Period
element (DTM02) is an invoice number so you need to define a constant value for
the Date/Time/Period Qualifier field, designating that the constant 3 (Invoice
Date/Time) always qualifies the date in the Date/Time/Period field. You need to
hide the qualifier field because it does not need to be displayed in the translation
object.

When a user enters the invoice date in the Date/Time/Period field, the system
automatically assigns the code 3 to the Date/Time/Period Qualifier field.

Use this procedure to define a constant value in the Date/Time/Period Qualifier
field and hide the field.

Action

Procedure
1. Double-click the DTM01 element.
2. Select the Standard Rule tab.
3. Select Use Constant from the list.
4. Click Edit to access the Map Constants dialog.
5. Click New to access the Edit Constant dialog.
6. In the ID box, enter Invoice Date/Time to identify the constant.
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7. From the Type list, select String to indicate that the literal constant will be
formatted as a string data type.

8. In the Value box, enter 3 to indicate that the Date/Time/Period Qualifier field
must contain the invoice date. This value is the actual value of the literal
constant.

9. Click OK to add the constant.
10. Click Close to exit the Map Constants dialog.
11. From the Constants list, select 3 to identify the constant that will be used for

this element.
12. From the Qualifies list, select 2380 DATE/TIME/PERIOD, which is the

element that the Date/Time/Period Qualifier field qualifies.
13. On the Display tab, select This field should not appear on the form.
14. Click OK to exit the Display Properties dialog.

Customizing the DTM02 Element
The DTM02 element (Date/Time/Period) contains the invoice date. The standard
allows this field to contain up to a 35 character string but your users enter shorter
dates. You need to change the element and field lengths to accommodate the
shorter dates and then rename the field label.

About this task

Use this procedure to change the element and field lengths, rename the field label,
and add Help text to the Date/Time/Period field.

Procedure
1. Double-click the DTM02 element.
2. On the Validation tab, enter 8 in the Max box, enter 8 to allow the entire date

(including the / separators) to be contained in this element.
3. On the Display tab, do the following:

v In the Label box, enter Invoice Date.
v In the Maximum number of characters to be printed box, enter 8.

4. On the Help tab, enter the following text in the Help Text list.
Enter the invoice date. Use the format MM/DD/YY.

5. Click OK to exit the dialog.

The RFF:2 Group
The RFF:2 group (Reference) is used to enter the purchase order number (RFF:11
segment) and date (DTM:22 segment). You have already promoted the RFF:2 group
to place the purchase order number and date on the main Invoice Message frame.

The RFF:11 Segment

Customizing the RFF:1101 Element
The RFF:11 segment (Reference) is used to enter the purchase order number. Your
users enter the purchase order number in the Reference Number element
(RFF:1102). You need to set a constant in the Reference Qualifier element so that
the constant value is entered automatically when a user enters the purchase order
number.
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About this task

The RFF:1101 element contains the Reference Qualifier, a mandatory three-character
code that identifies the type of reference that follows (in the RFF:1102 element).
You know that the only type of reference your users enter in the Reference
Number element is the purchase order number so you need to define a constant
value for the Reference Qualifier field, designating that the constant "ON" (Order
Number (Purchase)) always qualifies the reference in the Reference Number field.
You must also hide the qualifier field because it does not need to be displayed in
the translation object.

When a user enters the purchase order number in the Reference Number field, the
system automatically assigns the code ON to the Reference Qualifier field.

Use this procedure to define a constant value in the first Reference Qualifier field
and hide the field.

Procedure
1. Double-click the RFF:1101 element (in the RFF:2 group).
2. Select the Standard Rule tab.
3. Select Use Constant from the list.
4. Click Edit to access the Map Constants dialog.
5. Click New to access the Edit Constant dialog.
6. In the ID box, enter Order Number to identify the constant.
7. From the Type list, select String.
8. In the Value box, enter ON.
9. Click OK to add the constant.

10. Click Close to exit the Map Constants dialog.
11. From the Constants list, select ON.
12. From the Qualifies list, select 1154 REFERENCE NUMBER, which is the

element that the Reference Qualifier field qualifies.
13. On the Display tab, select This field should not appear on the form.
14. Click OK to exit the dialog.

Customizing the RFF:1102 Element
The RFF:1102 element contains the Reference Number. This element is defined by
the standard to be a string of 35 alphanumeric characters. You know that the
reference number (the purchase order number) is a 10-character alphanumeric
string, so you need to change the element and field lengths to accommodate the
shorter reference number. In addition, you must rename the field label and add
Help text to the field.

About this task

Use this procedure to change the field and element lengths, rename the field label,
and add Help text to the first Reference Number field.

Procedure
1. Double-click the RFF:1102 element.
2. On the Validation tab, enter 10 in the Max box.
3. On the Display tab, do the following:
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v In the Label box, enter P.O. No. (note the period included in the label) to
replace the existing field label.

v In the Maximum number of characters to be printed box, enter 10.
4. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the purchase order number. The purchase order
number cannot exceed 10 alphanumeric characters.

5. Click OK to exit the dialog.

The DTM:22 Segment

Customizing the DTM:2201 Element
The DTM:22 segment (Date/Time/Period) is used to enter the purchase order date.
The standard allows the DTM:22 segment to be used up to five times per invoice.
You use the DTM:22 segment only once per invoice. You have already changed the
maximum use of the DTM:22 segment to obtain just one instance of the segment
and to place the purchase order date on the same frame as the invoice date and
number.

About this task

The DTM:2201 element contains the Date/Time/Period Qualifier, a mandatory
three-character code that identifies the type of date that follows. The only type of
date your users enter in the Date/Time/Period element (DTM:2202) that follows is
the purchase order date so you need to define a constant value for the
Date/Time/Period Qualifier field, designating that the constant 4 (Order
Date/Time) always qualifies the date in the Date/Time/Period field. Then you
need to hide the qualifier field because it does not need to be displayed in the
translation object.

When a user enters the purchase order date in the Date/Time/Period field, the
system automatically assigns the code 4 to the Date/Time/Period Qualifier field.

Use this procedure to define a constant value in the first Date/Time/Period
Qualifier field and hide the field.

Procedure
1. Double-click the DTM:2201 element.
2. Select the Standard Rule tab.
3. Click Use Constant from the list.
4. Click Edit to access the Map Constants dialog.
5. Click New to access the Edit Constant dialog.
6. In the ID box, enter Order Date/Time to identify the constant.
7. From the Type list, select String.
8. In the Value box, enter 4 to indicate that the Date/Time/Period Qualifier field

must contain the purchase order date.
9. Click OK to add the constant.

10. Click Close to exit the Map Constants dialog.
11. From the Constants list, select 4 to identify the constant that will be used for

this element.
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12. From the Qualifies list, select 2380 DATE/TIME/PERIOD, which is the
element that the Date/Time/Period Qualifier field qualifies.

13. On the Display tab, select This field should not appear on the form.
14. Click OK to exit the dialog.

Customizing the DTM:2202 Element
The DTM:2202 element (Date/Time/Period) contains the purchase order date. The
standard allows this field to contain up to a 35 character string but your users
enter shorter dates. You need to change the element and field lengths to
accommodate the shorter dates, rename the field label and add Help text.

About this task

Use this procedure to change the element and field lengths, rename the field label,
and add Help text to the first Date/Time/Period field.

Procedure
1. Double-click the DTM:2202 element.
2. On the Validation tab, enter 8 in the Max box.
3. On the Display tab, do the following:

v In the Label box, enter P.O. Date.
v In the Maximum number of characters to be printed box, enter 8.

4. On the Help tab, enter the following text in the Help Text list.
Enter the purchase order date. Use the format MM/DD/YY.

5. Click OK to exit the dialog.

The RFF Segment

Customizing the RFF01 Element
The RFF group (Reference) is used to enter the contract number (RFF segment) and
date (DTM:2 segment). Your users enter the contract number in the Reference
Number element, and you will set a constant in the Reference Qualifier element so
that the constant value is entered automatically when the users enter the contract
number.

About this task

The RFF01 element contains the Reference Qualifier, a mandatory three-character
code that identifies the type of reference that follows. You know that the only type
of reference your users enter in the Reference Number element (RFF02) is the
contract number, so you need to define a constant value for the Reference Qualifier
field, designating that the constant CT (Contract Number) always qualifies the
reference in the Reference Number field. You need to hide the qualifier field
because it does not need to be displayed in the translation object.

When a user enters the contract number in the Reference Number field, the system
automatically assigns the code CT to the Reference Qualifier field.

Use this procedure to define a constant value in the second Reference Qualifier
field and hide the field.
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Procedure
1. Double-click the RFF01 element.
2. Select the Standard Rule tab.
3. Select Use Constant from the list.
4. Click Edit to access the Map Constants dialog.
5. Click New to access the Edit Constant dialog.
6. In the ID box, enter Contract Number to identify the constant.
7. From the Type list, select String.
8. In the Value box, enter CT to indicate that the Reference Qualifier field must

contain the contract number.
9. Click OK to add the constant.

10. Click Close to exit the Map Constants dialog.
11. From the Constants list, select CT to identify the constant that will be used for

this element.
12. From the Qualifies list, select 1154 REFERENCE NUMBER, which is the

element that the Reference Qualifier field qualifies.
13. On the Display tab, select This field should not appear on the form.
14. Click OK to exit the dialog.

Customizing the RFF02 Element
The RFF02 element contains the Reference Number. This element is defined by the
standard to be a string of 35 alphanumeric characters. You know that the reference
number (the contract number) is always an eight-character alphanumeric string, so
you need to change the element and field lengths to accommodate the shorter
reference number. You need to rename the field label and add Help text to the
field.

About this task

Use this procedure to change the field and element lengths, rename the field label,
and add Help text to the second Reference Number field.

Procedure
1. Double-click the RFF02 element.
2. On the Validation tab, enter 8 in the Max box.
3. On the Display tab, do the following:

v In the Label box, enter Contract No. (note the period included in the label) to
replace the existing field label.

v In the Maximum number of characters to be printed box, enter 8.
4. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the contract number. The contract number
cannot�exceed 8 alphanumeric characters.

5. Click OK to exit the dialog.
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The DTM:2 Segment

Customizing the DTM:201 Element
The DTM:2 segment (Date/Time/Period) is used to enter the contract date. The
standard allows the DTM:2 segment to be used up to five times per invoice. You
use this segment only once per invoice. You have already changed the maximum
use of the DTM:2 segment to obtain just one instance of this segment, and to place
the contract date on the same frame as the invoice date and number.

About this task

The DTM:201 element contains the Date/Time/Period Qualifier, a mandatory
three-character code that identifies the type of date that follows. You know that the
only type of date your users enter in the Date/Time/Period element (DTM:202) is
the contract date so you need to define a constant value for the Date/Time/Period
Qualifier field, designating that the constant "92" (Contract Effective Date) always
qualifies the date in the Date/Time/Period field. Then, you need to hide the
qualifier field because it does not need to be displayed in the translation object.

When a user enters the contract date in the Date/Time/Period field, the system
automatically assigns the code 92 to the Date/Time/Period Qualifier field.

Use this procedure to define a constant value in the second Date/Time/Period
Qualifier field and hide the field.

Procedure
1. Double-click the DTM:201 element.
2. Select the Standard Rule tab.
3. Select Use Constant from the list.
4. Click Edit to access the Map Constants dialog.
5. Click New to access the Edit Constant dialog.
6. In the ID box, enter Contract Effective Date.
7. From the Type option, select String.
8. In the Value box, enter 92 to indicate that the Date/Time/Period Qualifier

field must contain the contract date.
9. Click OK to add the constant.

10. Click Close to exit the Map Constants dialog.
11. From the Constants option, select 92 to identify the constant that is used for

this element.
12. From the Qualifies option, select 2380 DATE/TIME/PERIOD, which is the

element that the Date/Time/Period Qualifier field qualifies.
13. On the Display tab, select This field should not appear on the form.
14. Click OK to exit the dialog.

Customizing the DTM:202 Element
The DTM:202 element (Date/Time/Period) contains the contract date. The standard
allows this field to contain up to a 35 character string but your users enter shorter
dates. You need to change the element and field lengths to accommodate the
shorter dates. In addition, you need to rename the field label and add Help text.
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About this task

Use this procedure to change the element and field lengths, rename the field label,
and add Help text to the second Date/Time/Period field.

Procedure
1. Double-click the DTM:202 element.
2. On the Validation tab, enter 8 in the Max box.
3. On the Display tab, do the following:

v In the Label box, enter Contract Date.
v In the Maximum number of characters to be printed box, enter 8.

4. On the Help tab, enter the following text in the Help Text list.
Enter the contract date. Use the format MM/DD/YY.

5. Click OK to exit the dialog.

The NAD Segment
You have already changed the maximum use and promoted the NAD group, then
copied the NAD group to create a second iteration of this group (NAD:2). Your
users enter the ship to name and address in the first iteration of the NAD group,
and the remit to name and address in the second iteration of the group (NAD:2).
By promoting the NAD group to the parent frame before copying the group, you
cause all the Ship To and Remit To fields to be placed on the main Invoice Message
frame.

The NAD segment (in the NAD group) identifies the Name and Address of an
entity or individual. In this iteration of the NAD segment, users enter the Ship To
name and address for the invoice.

Customizing the NAD01 Element
The NAD01 element (in the NAD segment) contains the Party Qualifier, which is
used to identify whether the name and address information that follows pertains
to the Ship To or Remit To name. Your users enter only the Ship To name and
address in the segment associated with the first NAD group. You need to define
the constant value "ST" in the Party Qualifier element, indicating that this group
(NAD) contains only Ship To information. You need to hide the Party Qualifier
field because it does not need to be displayed on the translation object.

About this task

Use this procedure to define a constant value for the Party Qualifier field and hide
the field.

Procedure
1. Double-click the NAD01 element (in the NAD group).
2. Select the Standard Rule tab.
3. Select Use Constant from the list.
4. Click Edit to access the Map Constants dialog.
5. Click New to access the Edit Constant dialog.
6. In the ID box, enter Ship To to identify the constant.
7. From the Type option, select String.
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8. In the Value box, enter ST to indicate that the Entity Identifier Code field
must contain the Ship To name and address.

9. Click OK to add the constant.
10. Click Close to exit the Map Constants dialog.
11. From the Constants option, select ST.
12. From the Qualifies option, select 3036 PARTY NAME, which is the element

that the Entity Identifier Code field qualifies.
13. On the Display tab, select This field should not appear on the form.
14. Click OK to exit the dialog.

Customizing the Invoice NAD10 Element
The NAD10 element (Party Name) contains the name of the entity or individual to
whom the order will be shipped. Your users are familiar with the standard address
format (the name on the first line; the address on the next line(s); the city, state (or
province or country), and postal code on the last line). For this reason, you do not
need to label the fields containing the address, city, state, and postal code. You
need to rename the field label (so that your users know that the fields that follow
contain the Ship To information) and add Help text to the field.

About this task

Use this procedure to rename the field label and add Help text to the first Party
Name field.

Procedure
1. Double-click the NAD10 element.
2. On the Display tab, enter Ship To in the Label box to replace the existing field

label. This label is the heading for the Ship To name and address information.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the name of the person or organization
to whom the�order will be shipped. The name
cannot exceed 35�alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the Invoice NAD16 Element
The address information in the NAD16 element (in the NAD segment) corresponds
to the name in the NAD10 element so there is no need to display the label
associated with the address. For the NAD16 element, you need to remove the field
label and add Help text.

About this task

Use this procedure to remove the field label and add Help text to the first Street
and Number/P.O. Box field of the Ship To address.

Procedure
1. Double-click the NAD16 element (in the NAD group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
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Enter the first line of the address. This address
line cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the Invoice NAD17 Element
About this task

Use this procedure to remove the field label and add Help text to the second Street
and Number/P.O. Box field of the Ship To address.

Procedure
1. Double-click the NAD17 element (in the NAD group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the second line of the address. This address
line cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the Invoice NAD19 Element
The NAD19 element contains the City Name of the Ship To address. You will
remove the field label for this element, because it will be evident to your users that
they should enter the city name associated with the name and street address they
have entered already. Also, you will change the element and field lengths, because
the City Name field does not need to be longer than thirty characters.

About this task

Use this procedure to remove the field label, change the element and field lengths,
and add Help text to the City Name field of the Ship To address.

Procedure
1. Double-click the NAD19 element (in the NAD group).
2. On the Validation tab, enter 30 in the Max box for the maximum number of

characters allowed for this element.
3. On the Display tab, do the following:

v In the Label box, delete the existing text.
v In the Maximum number of characters to be printed box, enter 30.

4. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the city name. The city name
cannot exceed 30�alphanumeric characters.

5. Click OK to exit the dialog.

Customizing the Invoice NAD20 Element
The NAD20 element contains the Country Sub-Entity Identification. You need to
remove the field label for this element, because it is evident to your users that they
should enter the country sub-entity identification (e.g., state) associated with the
name and street address they have entered already. Also, you need to change the
field and element lengths because this field does not need to be longer than two
characters.

Chapter 7. Modiyfing Screen Entry Forms for EDIFACT 111



About this task

Use this procedure to remove the field label, change the element and field lengths,
and add Help text to the Country Sub-Entity Identification field of the Ship To
address.

Procedure
1. Double-click the NAD20 element (in the NAD group).
2. On the Validation tab, enter 2 in the Max box.
3. On the Display tab, do the following:

v In the Label box, delete the existing text.
v In the Maximum number of characters to be printed box, enter 2.

4. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the country sub-entity identification.
The code cannot exceed 2 alphanumeric characters.

5. Click OK to exit the dialog.

Customizing the Invoice NAD21 Element
About this task

Use this procedure to remove the field label and add Help text to the Postcode
Identification field.

Procedure
1. Double-click the NAD21 element (in the NAD group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the postal code. The postal code cannot exceed
9 alphanumeric characters. Do not enter a hyphen (-)
before the 4-character postal code extension (if used).

4. Click OK to exit the dialog.

The NAD:3 Segment
The NAD:2 group was created when you copied the NAD group to create a second
iteration of that group. Your users enter the Remit To name and address in the
NAD:2 group.

The NAD:3 segment (in the NAD:2 group) identifies the Name and Address of an
entity or individual. In the NAD:3 segment, your users enter the Remit To name
and address for the invoice.

Customizing the NAD:301 Element
The NAD:301 element (in the NAD:2) group contains the Party Qualifier, which is
used to identify whether the name and address information that follows pertains
to the Ship To or Remit To name. Your users enter only the Remit To name and
address in the fields associated with the NAD:2 group. You need to define the
constant value "RE" in the Party Qualifier element, indicating that this group
(NAD:2) contains only Remit To information. You need to hide the Party Qualifier
field, because it does not need to be displayed on the translation object.
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About this task

Use this procedure to define a constant value for the second Party Qualifier field
and hide the field.

Procedure
1. Double-click the NAD:301 element (in the NAD:2 group).
2. Select the Standard Rule tab.
3. Select Use Constant from the list.
4. Click Edit to access the Map Constants dialog.
5. Click New to access the Edit Constant dialog.
6. In the ID box, enter Remit To Party.
7. From the Type list, select String.
8. In the Value box, enter RE to indicate that the Entity Identifier Code field

must contain the Remit To name and address.
9. Click OK to add the constant.

10. Click Close to exit the Map Constants dialog.
11. From the Constants list, select RE.
12. From the Qualifies list, select 3036 PARTY NAME, which is the element that

the Entity Identifier Code field qualifies.
13. On the Display tab, select This field should not appear on the form.
14. Click OK to exit the dialog.

Customizing the NAD:310 Element
The NAD:310 element (Party Name) contains the name of the entity or individual
to whom the invoice will be remitted. Your users are familiar with the standard
address format (the name on the first line; the address on the next line(s); the city,
state (or province or country), and postal code on the last line). For this reason,
you do not need to label the fields containing the address, city, state, and postal
code. You need to rename the field label (so that your users know that the fields
that follow contain the remit to information) and add Help text to the field.

About this task

Use this procedure to rename the field and add Help text to the second Party
Name field.

Procedure
1. Double-click the NAD:310 element (in the NAD:2 group).
2. On the Display tab, enter Remit To in the Label box to replace the existing

text. This label is the heading for the Remit To name and address information.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the name of the person or organization
to whom the invoice will be remitted. The name
cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.
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Customizing the NAD:316 Element
The address information in the NAD:316 element (in the NAD:2 group)
corresponds to the name in the NAD:310 element so there is no need to display the
label associated with the address. For the NAD:316 element, you will remove the
field label and add Help text.

About this task

Use this procedure to remove the field label and add Help text to the first Street
and Number/P.O. Box field of the Remit To address.

Procedure
1. Double-click the NAD:316 element (in the NAD:2 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the first line of the address. This address
line cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the NAD:317 Element
About this task

Use this procedure to remove the field label and add Help text to the second Street
and Number/P.O. Box field of the Remit To address.

Procedure
1. Double-click the NAD:317 element (in the NAD:2 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the second line of the address. This address
line cannot exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the NAD:319 Element
The NAD:319 element contains the City Name of the Remit To address. You need
to remove the field label for this element, because it is evident to your users that
they should enter the city name associated with the name and street address they
have entered already. Also, you need to change the element and field lengths,
because the City Name field does not need to be longer than 30 characters.

About this task

Use this procedure to remove the field label, change the element and field lengths,
and add Help text to the City Name field of the Remit To address.

Procedure
1. Double-click the NAD:319 element (in the NAD:2 group).
2. On the Validation tab, enter 30 in the Max box.
3. On the Display tab, do the following:
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v In the Label box, delete the existing text.
v In the Maximum number of characters to be printed box, enter 30.

4. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the city name. The city name cannot
exceed 30 alphanumeric characters.

5. Click OK to exit the dialog.

Customizing the NAD:320 Element
The NAD:320 element contains the Country Sub-Entity Identification. You will
remove the field label for this element, because it will be evident to your users that
they should enter the country sub-entity identification (such as state, province, or
country) associated with the name and street address they have entered already.
Also, you will change the element and field lengths, because you do not need this
field to be longer than two characters.

About this task

Use this procedure to remove the field label, change the element and field lengths,
and add Help text to the Country Sub-Entity Identification field of the Remit To
address.

Procedure
1. Double-click the NAD:320 element (in the NAD:2 group).
2. On the Validation tab, enter 2 in the Max box.
3. On the Display tab, do the following:

v In the Label box, delete the existing text.
v In the Maximum number of characters to be printed box, enter 2.

4. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter the country sub-entity identification.
The code cannot exceed 2 alphanumeric characters.

5. Click OK to exit the dialog.

Customizing the NAD:321 Element
About this task

Use this procedure to remove the field label and add Help text to the Postcode
Identification field.

Procedure
1. Double-click the NAD:321 element (in the NAD:2 group).
2. On the Display tab, delete the text in the Label box.
3. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the postal code. The postal code cannot exceed
9 alphanumeric characters. Do not enter a hyphen (-)
before the 4-character postal code extension (if used).

4. Click OK to exit the dialog.
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Customizing the PAT01 Element
The PAT group (Payment Terms) is used to enter the payment terms code for the
invoice. The standard allows the PAT group to be used up to 10 times in an
invoice.You know that your users need to use the PAT segment only once per
invoice so you have already changed the maximum use of this segment from five
to one.

About this task

The PAT segment is a conditional segment that specifies the Payment Terms Basis
for the invoice.

The PAT01 element contains the Payment Terms Type Qualifier, a three-character
code that identifies the payment terms under which this invoice is valid. Sterling
Gentran:Server uses a list (instead of an edit box or field) when you apply a
standard rule that allows a selection of multiple items. When users use a
translation object that contains a list, they select an item from the list instead of
typing a value in the field. You will customize the PAT01 element so that a list
containing all valid codes in the Payment Terms Type Qualifier code list is
available to your users when they use the screen entry translation object. The
Payment Terms Type Qualifier list enables them to select the appropriate EDI code
from the code list.

After you specify the code list table to use for the list for the Payment Terms Type
Qualifier field, you need to rename the field label. You also need add Help text to
the field.

Use this procedure to load the entire code list from the standard, rename the field
label, and add Help text to the Payment Terms Type Qualifier field.

Procedure
1. Double-click the PAT01 element.
2. Select the Standard Rule tab.
3. Select Use Code from the list.
4. Click Edit to access the Edit Code List dialog.
5. The Table ID box contains 4279, the name of the element for which this code

list table will be used. The Desc box contains PAYMENT TERMS TYPE
QUALIFIER, the description of the element for which this code list table will
be used.

6. Click Load. You are prompted to select an ODBC data source name.
7. Select the appropriate DSN and click OK to access the Load Code List dialog.
8. Click Add All to select all the codes and move them to the Codes Selected

list.

Note: Adding all the codes in the table (by using Add All) creates a much
larger form than if you use only selected codes. However, it is necessary for
your users to have all the codes available from which to select.

9. Click OK to load the code list and exit the Load Code List dialog.
10. Click Close to exit the Edit Code List dialog.
11. On the Display tab, enter Payment Terms Code in the Label box.
12. On the Help tab, enter the following text in the Help Text list.

Select the payment terms code from the drop-down box.
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13. Click OK to exit the dialog.
14. Click Generate Layout on the Main Toolbar to refresh the display.

The Invoice Message frame now should look like this:

15. Select File > Save.

Customizing the LIN Group
The standard allows the LIN group to be used up to 200000 times in one invoice.
The LIN group contains the following form components that you have already
activated: LIN, PIA, IMD:2, MEA:2, QTY:2, and DTM:11 segments; MOA and TDT
groups.

About this task

The fields associated with the LIN group are arranged on the 2200_Lin frame,
which is separate from the Invoice Message frame that you have been working
with thus far. Your users need to complete the fields on the 2200_Lin frame for
each item in the invoice. The list of all line items in the invoice are displayed in a
list box on the Invoice Message frame. In that list box, the invoiced items are
displayed line by line, forming columns of information.

Use this procedure to rename the LIN frame and list box, provide a description for
the LIN group, and add Help text to the line items list box.

Procedure
1. Right-click the LIN group and select Properties.
2. In the Desc box, enter Line Items.
3. Select the Display tab.
4. In the Frame Caption box, enter Line Items.
5. In the List Caption box, enter Line Items to rename the list box that is

displayed on the Invoice Message frame (listing the line items entered on the
Line Items frame).

6. In the Frame Help Text list box, enter the following text:
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This frame contains line item detail information.
For online Help on an individual field on this frame,
select the field and press F1.

7. In the Listbox Help Text list box, enter the following text:
This box contains the line item detail for the invoice.
The data in this list box is entered or changed on the
Line Items frame. To enter a new line item, click the
list box and click New. To modify an existing line item,
click that item and click Open.

8. Click OK to exit the Group Properties dialog.

Customizing the LIN Segment
The LIN segment contains the details of the items on the invoice. For some of the
elements in the LIN segment, you only need to add Help text and rename the field
labels so they more accurately reflect your company’s needs. With other elements,
you need to change the maximum lengths for some of the fields, use accumulators
to calculate the number of line items, or define a constant value.

About this task

The LIN group is subordinate to the Invoice Message frame, so Sterling
Gentran:Server creates a separate frame (the Line Items frame) to contain the group
data (the line item details). The system also creates a list box (the Line Items list
box) on the Invoice Message frame to allow you to access the items in the list box.
Each set of data is displayed as a row in the list box. After you customize the line
item fields, the Line Items list box contains these four columns of data: Item No.,
Product Code, Quantity, and Price.

The LIN01 element (in the LIN group) contains the Line Item Number for each
item in the invoice. You use the Line Item Number field to identify sequentially
each line item in the invoice. You use the Use Accum function to obtain an
incremental count of the number of line items. This number is used in the Control
Value field (CNT02 element).

You create a list box definition for the LIN01 element to include the line number in
the list box, and rename the field label to more briefly label this field. Also, you
know that your users will enter no more than 99,999 line items per invoice. Each
line item is numbered sequentially, starting with one so you need a maximum
length of only five digits for this field. You need to change the maximum length
for this field to five.

Use this procedure to count line items in the LIN segment and generate a control
total in the CNT02 element of the number of line items, rename the LIN01 field
label, change the field and element lengths and create the list box definition for the
Line Item Number field.

Procedure
1. Double-click the LIN01 element.
2. On the Validation tab, enter 5 in the Max box to allow a five-digit number in

this element.
3. On the Standard Rule tab, do the following:

v Select Use Accumulator from the list.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation using this element.
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4. From the Primary Accumulator list, select 0. Before any calculations are
performed on an accumulator, its content is 0. When you use this accumulator,
the system adds a new accumulator to the bottom of this list.

Note: There is only one set of accumulators for each form. This means that
accumulator 0, whether it is used in the Primary Accumulator or Alternate
Accum box, is the same accumulator with the same content. If you assign
calculations to accumulator 0 at the beginning of the form and then use
accumulator 0 again later in the form, the content of that accumulator will be
the result of the earlier calculation. Any additional calculations you assign to
that accumulator will be performed on the content resulting from an earlier
calculation.

5. In the Name box, enter Item Number to give the accumulator a descriptive
alias that enables you to distinguish it from other accumulators you create.

6. From the First list, select Increment primary to specify that the system
increments the value in this accumulator by one for each iteration of the LIN
group. This operation is the first operation that the system performs.

7. From the Second list, select Use primary to specify that the system loads the
current value of the accumulator into the LIN01 (Line Item Number) element.
This operation is the second operation that the system performs, after the first
operation is completed.

8. Click OK to add the accumulator and exit the Edit Accumulator Entry dialog.
9. On the Display tab, do the following:

v Select This field should be displayed but not editable.
v In the Label box, enter Item No. to replace the existing field label.
v In the Maximum number of characters to be printed box, enter 5 to allow

five digits to be displayed in this field.
10. On the Summary List tab, do the following:

v Select Display this field in summary list. The value in the Item No. field is
displayed in a column in the Line Items list box.

v In the Column Width box, enter 8 to set the width of this column in the
Line Items list.

Note: The column width should be wider than the actual content of the
column. The extra space that is not used for the content of the column will
provide white space separating the columns. If the column width is the
exact width of the data, then there will not be space separating the columns
of data.

v From the Sequence list, select 1 to indicate that this field is the first column
in the list box.

11. Click OK to exit the dialog.
12. Double-click the CNT02 element (in the CNT segment).
13. On the Standard Rule tab, do the following:

v Click the Use Accumulator option.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation for this element.
14. On the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 0.
v In the Name box, enter Item Number.
v From the First list, select Use primary to specify that the system loads the

current value of the accumulator into the CNT02 (Control Value) element.
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v Click OK to add the accumulator.
15. On the Display tab, select This field should displayed but not editable

option.
16. Click OK to exit the dialog.

The PIA Segment

Customizing the PIA01 Element
The PIA segment (in the LIN group) contains the Additional Product ID for each
item in the invoice. The standard allows the PIA segment to be used up to 25 times
per line item. Your users enter information in the PIA segment only once per line
item so you have already changed the maximum use of this segment to one.

About this task

The PIA01 element contains the Product ID Function Qualifier, a mandatory
three-character code that identifies the type of product identification that follows.
You know that the only type of product identification your users enter in the Item
Number field (PIA02) is the product code, so you need to define a constant value
for the Product ID Function Qualifier field, designating that the constant "5"
(Product Identification) always qualifies the value in the Item Number field. You
need to hide the qualifier field, because it does not need to be displayed in the
translation object.

When you enter the product code in the Item Number field, the system assigns the
code "5" to the Product ID Function Qualifier field.

Use this procedure to define a constant value in the Product ID Function Qualifier
field and hide the field.

Procedure
1. Double-click the PIA01 element.
2. On the Standard Rule tab, do the following:

v Select Use Constant.

v Click Edit to access the Map Constants dialog.
3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Product Identification to identify the constant.
v From the Type list, select String to indicate that the literal constant will be

formatted as a string data type.
v In the Value box, enter 5 to indicate that the Reference Qualifier field must

contain the product identification. This value is the actual value of the literal
constant.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, do the following:

v From the Constants list, select 5 to identify the constant that will be used for
this element.

v From the Qualifies list, select 7140:2 ITEM NUMBER, which is the element
that the Reference Qualifier field qualifies.

7. On the Display tab, select This field should not appear on the form.
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8. Click OK to exit the dialog.

Customizing the PIA02 Element
The PIA02 element contains the Item Number for each item in the invoice. For this
tutorial, you need to rename the field label. Also, the standard allows up to 35
characters in this field. You know that your users will enter product identification
numbers that are no longer than 10 characters, so you need to change the element
and field lengths. In addition, you need to create a list box definition for the PIA02
element to include the product code in the Line Items list box on the Invoice
Message frame.

About this task

Use this procedure to rename the field label, change the field and element lengths,
add Help text, and create the list box definition for the Item Number field.

Procedure
1. Double-click the PIA02 element.
2. On the Validation tab, enter 10 in the Max box.
3. On the Display tab, do the following:

v In the Label box, enter Product Code.
v In the Maximum number of characters to be printed box, enter 10.

4. On the Summary List tab, do the following:
v In the Summary List section, select Display this field in summary list. The

value in the Product Code field will be displayed in a column in the Line
Items list box.

v In the Column Width box, enter 13 to set the width of this column in the
Line Items list box.

v From the Sequence list, select 2 to indicate that this field will be the second
column in the list box.

5. On the Help tab, enter the following text in the Help Text list. (Press Enter at
the end of each line of text.)
Enter your company’s product code for this item
in the invoice. The product code cannot exceed
10 alphanumeric characters.

6. Click OK to exit the dialog.

Customizing the PIA03 Element
The PIA03 element contains the Item Number Type, Coded, a three-character code
that identifies the type of item number in the PIA02 element. You know that the
only type of product code your users enter in the Item Number field (PIA02) is the
UPC code, so you need to define a constant value for the Item Number Type,
Coded field, designating that the constant, UP (UPC (Universal Product Code)),
always qualifies the value in the Item Number field. Then, you will hide the
qualifier field, because it does not need to be displayed in the translation object.

About this task

When a user enters the product code in the Item Number field, the system
automatically assigns the code UP to the Item Number Type, Coded field.
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Use this procedure to define a constant value in the Item Number Type, Coded
field and hide the field.

Procedure
1. Double-click the PIA03 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter UPC Code.
v From the Type list, select String.
v In the Value box, enter UP.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select UP.
v From the Qualifies list, select 7140:2 ITEM NUMBER, which is the element

that the Reference Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

The IMD:2 Segment

Customizing the IMD:201 Element
The IMD:2 segment (in the LIN group) contains the Item Description for each item
in the invoice. The standard allows the IMD:2 segment to be used up to ten times
per line item. Your users enter information in the IMD:2 segment only once per
line item, so you have already changed the maximum use of this segment to one.

About this task

The IMD:201 element contains the Item Description Type, Coded for the invoiced
item. You know that the only type of item description your users enter for this
invoice is a free-form description. You need to define a constant value for the Item
Description Type field, to indicate that the constant "F" (Free Form) qualifies the
text in the Item Description field. When a user enters a free-form description in the
Description field, the system automatically will assign the code "F" to the Item
Description Type, Coded field.

Use this procedure to define a constant value and hide the Item Description Type,
Coded field.

Procedure
1. Double-click the IMD:201 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
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4. On the Edit Constant dialog, do the following:
v In the ID box, enter Free Form.
v From the Type list, select String.
v In the Value box, enter F to indicate that the Item Description Type, Coded

field will be a free-form description. This value is the actual value of the
literal constant.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select F.
v From the Qualifies list, select 7008 ITEM DESCRIPTION, which is the

element that the Item Description Type, Coded field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the Invoice IMD:206 Element
The IMD:206 element contains the Item Description for each invoiced item, and is
defined by the standard to be a string of up to 35 alphanumeric characters. You
need to add Help text to this field.

About this task

Use this procedure to add Help text to the Item Description field.

Procedure
1. Double-click the IMD:206 element.
2. On the Help tab, enter the following text in the Help Text list. (Press Enter at

the end of each line of text.)
Enter the description of the invoiced item. The item
description cannot exceed 35 alphanumeric characters.

3. Click OK to exit the dialog.

The MEA:2 Segment

Customizing the MEA:201 Element
The MEA:2 segment (in the LIN group) contains the Measurements for each item
in the invoice. The standard allows the MEA:2 segment to be used up to five times
per line item. Your users enter information in the MEA:2 segment only once per
line item, so you have already changed the maximum use of this segment to one.

About this task

The MEA:201 element contains the Measurement Application Qualifier for each
invoiced item. You know that the only type of measurement application your users
enter for this invoice is a measurement. You need to define a constant value for the
Measurement Application Qualifier field to indicate that the constant "AAE"
(Measurement) qualifies the text in the Measurement Dimension, Coded field.
When a user enters a measurement in the Measurement Dimension, Coded field,
the system automatically assigns the code "AAE" to the Measurement Application
Qualifier field.
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Use this procedure to define a constant value and hide the Measurement
Application Qualifier field.

Procedure
1. Double-click the MEA:201 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Measurement.
v From the Type list, select String.
v In the Value box, enter AAE to indicate that the Item Description Type,

Coded field will be a free-form description. This value is the actual value of
the literal constant.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select AAE.
v From the Qualifies list, select 6313 MEASUREMENT DIMENSION,

CODED, which is the element that the Item Description Type, Coded field
qualifies.

7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the Display Properties dialog.

Customizing the MEA:202 Element
The MEA:202 element contains the Measurement Dimension, Coded for each item
in the invoice. For brevity on the translation object, you need to rename the field
label. Also, you need to customize the MEA:202 element so that a drop-down list
box containing all valid codes in the code list is available to your users when they
use the screen entry translation object. The drop-down list box will enable them to
select the appropriate EDI code from the ones available

About this task

Use this procedure to rename the field label, add Help text, and load the code list
table from the standard for the Measurement Dimension, Coded field.

Procedure
1. Double-click the MEA:202 element (in the LIN group).
2. On the Display tab, enter UOM in the Label box.
3. On the Help tab, enter the following text in the Help Text list.

Select the unit of measurement for the invoiced item.

4. On the Standard Rule tab, do the following:
v Select Use Code.
v Click Edit to access the Edit Code List dialog.

The Table ID box contains 6313, which is the name of the element for which
this code list table will be used. The Desc box contains MEASUREMENT
DIMENSION, CODED, which is the description of the element for which this
code list table is used.
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v Click Load. You are prompted to select an ODBC data source name.
5. Select the appropriate DSN and click OK to access the Load Code List dialog.
6. On the Load Code List dialog, do the following:

v Click Add All to select all the codes and move them to the Codes Selected
list. Adding all the codes in the table (by using Add All) creates a much
larger form than if you only use selected codes.

v Click OK to load the code list and exit the Load Code List dialog.
7. Click Close to exit the Edit Code List dialog.
8. Click OK to exit the dialog.

The QTY:2 Segment

Customizing the QTY:201 Element
The QTY:2 segment (in the LIN group) contains the Quantity for each item in the
invoice. The standard allows the QTY:2 segment to be used up to five times per
line item. Your users enter information in the QTY:2 segment only once per line
item so you have already changed the maximum use of this segment to one.

About this task

The QTY:201 element contains the Quantity Qualifier for each invoiced item. For
this tutorial, you know that the only type of quantity your users enter for this
invoice is the invoiced quantity. You need to define a constant value for the
Quantity Qualifier field, to indicate that the constant, 47 (Invoiced Quantity),
qualifies the text in the Quantity field. When a user enters a measurement in the
Quantity field, the system automatically assigns the code, 47, to the Quantity
Qualifier field.

Use this procedure to define a constant value and hide the Quantity Qualifier field.

Procedure
1. Double-click the QTY:201 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Invoiced Quantity.
v From the Type list, select String.
v In the Value box, enter 47 to indicate that the Quantity Qualifier field will be

the invoiced quantity.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select 47.
v From the Qualifies list, select 6060 QUANTITY, which is the element that the

Quantity Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.
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Customizing the QTY:202, MOA:502, and MOA:1002 Elements
The QTY:202 element contains the Quantity for each item on the invoice. The
quantity for each line item is used to calculate the total dollar amount of the
invoice. From this calculation, you need to generate a running total of extended
price and load the final total into the MOA:1002 (Monetary Amount) element.

About this task

You need to create a list box definition for the QTY:202 element to include the
quantity invoiced in the list box. The standard allows up to 15 digits in this field.
You know that your users do not enter a quantity of more than 99,999 (a five-digit
number) for any one item, so you need to change the maximum lengths for this
field and element to five.

Also, the screen format and EDI format of the data currently use the number
format R9, indicating a number with an explicit decimal point and up to nine
decimal places. Your users do not enter any quantities with a decimal point so you
need to change the screen and EDI formats to R0, indicating a number with an
explicit decimal point and no decimal places.

Use this procedure to use an accumulator in the QTY:202 element to generate a
running total of extended price that is used in the MOA:1002 element, change the
screen and EDI formats, change the field and element lengths, add Help text, and
create the list box definition for the Quantity field.

Procedure
1. Double-click the QTY:202 element (in the LIN group).
2. On the Validation tab, do the following:

v In the Max box, enter 5 for the maximum number of digits allowed in this
element.

v From the Form Format list, select R0 to allow a number with an explicit
decimal point and no decimal places to be entered in this field.

v From the File Format list, select R0 to format the EDI data with an explicit
decimal point and no decimal places.

3. On the Standard Rule tab, do the following:
v Click the Use Accumulator option.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation using this element.
4. On the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 1.
v In the Name box, enter Extended Price. This allows you to differentiate the

purposes of the accumulators you create.
v From the First list, select Load primary to load the content of the QTY:202

element into the Primary Accumulator for each iteration of the LIN group.
This operation is the first operation that the system performs.

v Click OK to add the accumulator.
5. On the Display tab, enter 5 in the Maximum number of characters to be

printed box to allow five digits to be displayed in this field.
6. On the Summary List tab, do the following:

v Select Display this field in summary list. The value in the Quantity field is
displayed in a column in the Line Items list box.
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v In the Column Width box, enter 8 to set the width of this column in the
Line Items list box.

v From the Sequence list, select 3 to indicate that this field is the third column
in the list box.

7. On the Help tab, enter the following text in the Help Text box.
Enter the quantity of this invoiced item.
The quantity cannot exceed 5 digits.

8. Click OK to exit the dialog.
9. Double-click the MOA:502 element (in the LIN group).

10. On the Standard Rule tab, do the following:
v Click the Use Accumulator option.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation using this element.
11. On the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 1.
v From the First list, select Multiply with primary to specify that the system

multiply the value of the MOA:502 (Monetary Amount) element (in the LIN
group) by the content of the primary accumulator, and store the result in
the primary accumulator for each iteration of the LIN group. This operation
is the first operation that the system performs.

v Click OK to add the accumulator.
12. Click New to access the Edit Accumulator Entry dialog to create a new

calculation for this element.
13. On the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 2.
v In the Name box, enter Running Price. This allows you to differentiate the

purposes of the accumulators you create.
v From the First list, select Add primary to alternate to specify that the

system add the content of the primary accumulator to the content of the
alternate accumulator, and store the result in the primary accumulator for
each iteration of the LIN group.

v From the Alternate Accum list, select 1 to add the value of accumulator 1
(the extended price for a line item) to the value of accumulator 2. The
system stores the sum in accumulator 2, which contains a running total of
the extended price with each iteration of the LIN group.

v Click OK to add the accumulator.
14. Click OK to exit the Element Properties dialog.
15. Double-click the MOA:1002 element (in the MOA group).
16. On the Standard Rule tab, do the following:

v Click the Use Accumulator option.
v Click New to access the Edit Accumulator Entry dialog to create a new

calculation using this element.
17. On the Edit Accumulator Entry dialog, do the following:

v From the Primary Accumulator list, select 2.
v From the First list, select Use primary to load the content of the primary

accumulator into the MOA:1002 (Monetary Amount) element.
v Click OK to add the accumulator.

18. On the Display tab, select This field should be displayed but is not editable.
19. Click OK to exit the dialog.
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The DTM:11 Segment

Customizing the DTM:1101 Element
The DTM:11 segment (in the LIN group) contains the Date/Time/Period for each
item in the invoice. The standard allows the DTM:11 segment to be used up to 35
times per line item. Your users enter information in the DTM:11 segment only once
per line item so you have already changed the maximum use of this segment to
one.

About this task

The DTM:1101 element (Date/Time Qualifier) is a mandatory element for the
DTM:11 segment. The DTM:1101 element contains the two-character code from
your EDI data to indicate what type of date follows (e.g., date shipped). You need
to define a constant value for the Date/Time/Period Qualifier field, designating
that the constant, 186 (Departure Date/Time, Actual), qualifies the date in the
Date/Time/Period field.

When a user enters the date on which the item is shipped in the
Date/Time/Period field, the system assigns the code 186 to the Date/Time/Period
Qualifier field. The qualifier field does not need to be displayed.

Use this procedure to define a constant and hide the Date/Time/Period Qualifier
field.

Procedure
1. Double-click the DTM:1101 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Date Shipped.
v From the Type list, select String.
v In the Value box, enter 186.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select 186.
v From the Qualifies list, select 2380 DATE/TIME/PERIOD.

7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the DTM:1102 Element
The DTM:1102 element in the DTM:11 segment contains the Date/Time/Period
qualified by the Date/Time/Period Qualifier field. This element is defined by the
standard to be a string of 35 characters. In this tutorial, you know that the ship
date always is an eight-character string, so you need to change the element and
field lengths to accommodate the new length. Also, you need to rename the field
label and add Help text to the field
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About this task

Use this procedure to change the element and field lengths, rename the field label,
and add Help text to the Date field.

Procedure
1. Double-click the DTM:1102 element.
2. On the Validation tab, enter 8 in the Max box to allow the entire date

(including the / separators) in this element.
3. On the Display tab, do the following:

v In the Label box, enter Date Shipped.
v In the Maximum number of characters to be printed box, enter 8.

4. On the Help tab, enter the following text in the Help Text box.
Enter the date on which this invoiced item was shipped. Use the format MM/DD/YY.

5. Click OK to exit the dialog.

The MOA:5 Segment

Customizing the MOA:501 Element
The MOA group (in the LIN group) contains the Monetary Amount for each line
item. The standard allows the MOA group to be used up to five times per line
item. You have already changed the maximum use of the MOA group and
promoted the group to obtain just one instance of the MOA group, and to place
the price on the Line Items frame.

About this task

The MOA:5 segment (in MOA group which is in the LIN group) contains the
Monetary Amount for each item in the invoice.

The MOA:501 element (Monetary Amount Type Qualifier) is a mandatory element
for the MOA:5 segment. The MOA:501 element contains the three-character code
from your EDI data to indicate what type of monetary amount follows (e.g., price).
You need to define a constant value for the Monetary Amount Type Qualifier field,
designating that the constant 146 (Unit Price) qualifies the monetary amount in the
Monetary Amount field.

When a user enters the price for an item in the Monetary Amount field, the system
assigns the code 146 to the Monetary Amount Type Qualifier field. The qualifier
field does not need to be displayed.

Use this procedure to define a constant and hide the Monetary Amount Type
Qualifier field.

Procedure
1. Double-click the MOA:501 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:
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v In the ID box, enter Unit Price.
v From the Type list, select String.
v In the Value box, enter 146.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select 146.
v From the Qualifies list, select 5004 MONETARY AMOUNT, which is the

element that the Monetary Amount Type Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the MOA:502 Element
The MOA:502 element contains the Monetary Amount for each item in the invoice.
You have already used an accumulator for this field so that the price for each line
item is used to calculate the total dollar amount of the invoice. From this
calculation, a running total of extended price is generated and the final total will
be loaded into the MOA:1002 (Monetary Amount) element. You need to create a
list box definition for the MOA:502 element to include the unit price in the Line
Items list box.

About this task

You need to rename the field label. The standard designates an R9 screen format
and EDI format for this field, meaning that the price is formatted with an explicit
decimal point and up to nine decimal places. Your users enter a price in an R2
format (a number with up to two decimal places) so you need to change the screen
and EDI formats from R9 to R2.

The standard defines this element as having a maximum length of 18. The items
you sell to Pet Zone are not priced at more than $9,999.99 each, so this field needs
a maximum length of only eight (four places for the dollars; two places for the
cents; one place for the decimal point; and one place for a plus or minus sign, if
present).

Use this procedure to rename the field label, change the field and element lengths,
change the number formats, add Help text, and create the list box definition for the
Monetary Amount field.

Procedure
1. Double-click the MOA:502 element.
2. On the Validation tab, do the following:

v In the Max box, enter 8.
v From the Screen Format list, select R2 to indicate that this field on the

translation object accept a number with an explicit decimal point and up to
two decimal places.

v From the EDI Format list, select R2 to format the EDI data with an explicit
decimal point and two decimal places.

3. On the Display tab, do the following:
v In the Label box, enter Price to replace the existing text.
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v In the Maximum number of characters to be printed box, enter 8 to allow
eight numeric digits in this field, including a plus or minus sign and a
decimal point.

4. On the Summary List tab, do the following:
v Select Display this field in summary list. The value in the Price field is

displayed in a column in the Line Items list box.
v In the Column Width box, enter 8 to set the width of this column in the Line

Items list box.
v From the Sequence list, select 4 to indicate that this field is the fourth column

in the list box.
5. On the Help tab, enter the following text in the Help Text box.

Enter the unit price for this item. The price cannot exceed
8 digits, including a plus or minus sign and a decimal point.

6. Click OK to exit the dialog.

The TDT:2 Segment

Customizing the TDT:201 Element
The TDT group (in the LIN group) contains the Details of Transport for each line
item. The standard allows the TDT group to be used up to 10 times per line
item.You use the TDT group only once per line item. You have already changed
the maximum use of the TDT group and promoted the group to obtain just one
instance of the TDT group and to place the transport method on the Line Items
frame.

About this task

The TDT:2 segment (in the LIN group) contains the Details of Transport for each
item in the invoice.

The TDT:201 element (Transport Stage Qualifier) is a mandatory element for the
TDT:2 segment. The TDT:201 element contains the three-character code from your
EDI data to indicate the type of transport (e.g., main-carriage transport). You need
to define a constant value for the Transport Stage Qualifier field, designating that
the constant "20" (Main-Carriage Transport) qualifies the transport type in the Type
of Means of Transport Identification field.

When a user selects a transport method from the Type of Means of Transport
Identification list box, the system assigns the code "20" to the Transport Stage
Qualifier field. The qualifier field does not need to be displayed.

Use this procedure to define a constant and hide the Transport Stage Qualifier
field.

Procedure
1. Double-click the TDT:201 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Main-Carriage Transport.
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v From the Type list, select String.
v In the Value box, enter 20.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select 20.
v From the Qualifies list, select 3127 CARRIER IDENTIFICATION, which is

the element that the Transport Stage Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the TDT:205 Element
The TDT:205 element, the Type of Means of Transport Identification, contains the
eight-character string that identifies the means of transportation (e.g., ship) for
each invoiced item. You need to customize the TDT:205 element so that a
drop-down list box containing all valid codes in the Transportation Method/Type
Code list is available to your users when they use the screen entry translation
object.

About this task

After you specify the code list table to use for the drop-down list box for the Type
of Means of Transport Identification field, you need to rename the field label to
identify this field better.

Also, the standard allows this field to contain an eight-character string. You know
that the codes from which your users will select are no longer than two characters,
so you need to change the element and field lengths to two.

Use this procedure to load the code list table from the standard, change the
element and field lengths, rename the field label, and add Help text to the
Transportation Method/Type Code field.

Procedure
1. Double-click the TDT:205 element.
2. On the Validation tab, enter 2 in the Max box for the maximum number of

characters allowed in this element.
3. On the Standard Rule tab, do the following:

v Select Use Code from the list.
v Click Edit to access the Edit Code List dialog.

The Table ID box contains 8179, the name of the element for which this code
list table is used. The Desc box contains, TYPE OF MEANS OF TRANSPORT
IDENTIFICATION, the description of the element for which this code list
table is used.

v Click Load. You are prompted to select an ODBC data source name.
4. Select the appropriate DSN and click OK to access the Load Code List dialog.
5. On the Load Code List dialog, do the following:

v Click Add All to select all the codes and move them to the Codes Selected
list box.

v Click OK to load the code list and exit the Load Code List dialog.
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6. Click Close to exit the Edit Code List dialog.
The dialog should now should look like this:

7. On the Display tab, do the following:
v In the Label box, enter Transport Method.
v In the Maximum number of characters to be printed box, enter 2.

8. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Select the transportation method code for this
invoiced item from the drop-down list box.

9. Click OK to exit the dialog.

Customizing the TDT:207 Element
The TDT:207 element contains the Carrier Identification, a 17-character string that
identifies the carrier for each line item. Your users enter a carrier code no longer
than 12 characters, so you need to change the element and field lengths. You also
need to rename the field label to more accurately describe the contents of this field
for your users and add Help text to this field.

About this task

Use this procedure to change the element and field lengths, rename the field, and
add Help text to the Carrier Identification field.

Procedure
1. Double-click the TDT:207 element.
2. On the Validation tab, enter 12 in the Max box.
3. On the Display tab, do the following:

v In the Label box, enter Carrier Code.
v In the Maximum number of characters to be printed box, enter 12.

4. On the Help tab, enter the following text in the Help Text box.
Enter your company's reference number for this carrier.
The reference number cannot exceed 12 alphanumeric characters.

5. Click OK to exit the dialog.
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Customizing the Invoice UNS Segment
The UNS segment contains the Section Control for the invoice. The Section Control
contains EDI data to instruct the system that the data that follows pertains to the
summary section of the invoice, not the header or detail sections.

About this task

The UNS01 element (Section Identification) is a mandatory element for the invoice.
The UNS01 element contains the one-character code to indicate that the data that
follows pertains to the summary section of the invoice. You need to define a
constant value for the Section Identification field, designating that the constant S
(Summary) indicates that the summary section follows. The system assigns the
code S to the Section Identification field, which does not need to be displayed.

Use this procedure to define a constant and hide the Section Identification field.

Procedure
1. Double-click the UNS01 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Summary.
v From the Type list, select String.
v In the Value box, enter S.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, select S from the Qualifies list.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.
9. Click Generate Layout on the Main Toolbar to refresh the screen entry form

display.
10. Click File > Save.
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Results

The Line Items frame now should look like this:

The CNT Segment

Customizing the CNT01 Element
The CNT segment contains the Control Total for the invoice. You have already
used an accumulator to generate the total number of line items in the invoice. The
standard allows the CNT segment to be used up to 10 times per invoice. You need
to use the CNT segment only once per invoice so you have already changed the
maximum use of this segment to one. Changing the maximum use of this segment
placed the total number of line items on the main Invoice Message frame.

About this task

The CNT01 element (Control Qualifier) is a mandatory element for the CNT
segment. The CNT01 element contains the three-character code from your EDI data
to indicate what type of control follows (e.g., total number of line items). You need
to define a constant value for the Control Qualifier field, designating that the
constant, 2 (Number of Line Items in Message), qualifies the value in the Control
Value field. The system assigns the code 2 to the Control Qualifier field so this
field does not need to be displayed.

Use this procedure to define a constant and hide the Control Qualifier field.

Procedure
1. Double-click the CNT01 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Number of Line Items.
v From the Type list, select String.
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v In the Value box, enter 2 to indicate that the Control Qualifier field will
contain the total number of line items in the invoice.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select 2.
v From the Qualifies list, select 6066 CONTROL VALUE, which is the element

that the Monetary Amount Type Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the CNT02 Element
The CNT02 element contains the Control Value for the invoice. You have already
used an accumulator for this field to generate a total of the number of line items
and made this field display-only so that users cannot change the value in this field.

About this task

You must rename the field label to more clearly identify its contents. The standard
designates an R9 screen format and EDI format for this field, meaning that the
number is formatted with an explicit decimal point and up to nine decimal places.
The data is formatted in the N0 format (a number with an implicit decimal point
and no decimal places) so you need to change the screen format and EDI format
from R9 to N0.

The standard defines this element as having a maximum length of eight. Your
users enter no more than 99,999 line items so this field needs a maximum length of
only six.

Use this procedure to rename the field label, change the field and element lengths,
and change the screen and EDI formats for the Control Value field.

Procedure
1. Double-click the CNT02 element.
2. On the Validation tab, do the following:

v In the Max box, enter 6.
v From the Screen Format list, select N0 to indicate that this field on the

translation object will accept a number with an implicit decimal point and no
decimal places.

v From the EDI Format list, select N0 to format the EDI data with an implicit
decimal point and no decimal places.

3. On the Display tab, do the following:
v In the Label box, enter Number of Line Items.
v In the Maximum number of characters to be printed box, enter 6.

4. Click OK to exit the dialog.

The MOA:10 Segment
The MOA group contains the Monetary Amount for the invoice. The standard
allows this MOA group to be used up to 100 times per invoice.
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You need to use this MOA group only once per invoice. You have already changed
the maximum use of the MOA group to one and promoted the group to obtain just
one instance of the MOA group and to place the total invoice amount on the main
Invoice Message frame.

Note: The MOA group that you want to customize is at the bottom of the map
NOT in the LIN group.

The MOA:10 segment contains the invoice’s Monetary Amount. You have already
used an accumulator to calculate the total dollar amount invoiced.

Customizing the MOA:1001 Element
The MOA:1001 element (Monetary Amount Type Qualifier) is a mandatory element
for the MOA:10 segment. The MOA:1001 element contains the three-character code
from your EDI data to indicate what type of monetary amount follows (e.g., total
invoice amount). You need to define a constant value for the Monetary Amount
Type Qualifier field, designating that the constant "77" (Invoice Amount) qualifies
the value in the Monetary Amount field. The system automatically will assign the
code "77" to the Monetary Amount Type Qualifier field, so this field does not need
to be displayed on the translation object.

About this task

Use this procedure to define a constant and hide the Monetary Amount Type
Qualifier field.

Procedure
1. Double-click the MOA:1001 element.
2. On the Standard tab, do the following:

v Select Use Constant.
v Click Edit to access the Map Constants dialog.

3. On the Map Constants dialog, click New to access the Edit Constant dialog.
4. On the Edit Constant dialog, do the following:

v In the ID box, enter Invoice Amount.
v From the Type list, select String.
v In the Value box, enter 77 to indicate that the Control Qualifier field will

contain the total number of line items in the invoice.
v Click OK to add the constant.

5. Click Close to exit the Map Constants dialog.
6. On the Standard tab, do the following:

v From the Constants list, select 77.
v From the Qualifies list, select 5004 MONETARY AMOUNT, which is the

element that the Monetary Amount Type Qualifier field qualifies.
7. On the Display tab, select This field should not appear on the form.
8. Click OK to exit the dialog.

Customizing the MOA:1002 Element
The MOA:1002 element contains the Monetary Amount for the invoice. You have
already used an accumulator for this field to calculate the total dollar amount
invoiced and made this field display-only so that users cannot change the value in
this field.
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About this task

You need to rename the field label to more clearly identify its contents. Also, the
standard designates an "R9" screen format and EDI format for this field, meaning
that the number is formatted with an explicit decimal point and up to nine decimal
places. The data is formatted in the "R2" format (a number with an explicit decimal
point and up to two decimal places) so you need to change the screen format and
EDI format from "R9" to "R2."

The standard defines this element as having a maximum length of 18. The total
invoice amount will total no more than $999,999.99 so this field needs a maximum
length of only 10 (six places for the dollars; two places for the cents; one place for
the decimal point, and one place for a plus or minus sign, if present).

Use this procedure to rename the field label, change the field and element lengths
and to change the screen and EDI formats for the Monetary Amount field.

Procedure
1. Double-click the MOA:1002 element.
2. On the Validation tab, do the following:

v In the Max box, enter 10 to allow a10-digit number in this element, including
a plus or minus sign and a decimal point.

v From the Please choose the format of the data in the form list, select R2.
v From the Please choose the format of the data in the file, select R2.

3. On the Display tab, do the following:
v In the Label box, enter Total Invoice Amount..
v In the Maximum number of characters to be printed box, enter 10.

4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the print form display.
6. Click Save from the File menu to save the form.

What to do next

Now that you have customized all of the elements used in this invoice, you are
ready to format the fields and labels to make the frames more consistent and
visually attractive.
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Chapter 8. Customizing Screen Entry Forms for EDIFACT

Resizing the Invoice Frame
When a form is compiled into a translation object, the fields are arranged
according to how the frames and the fields contained on them were arranged
when the form was compiled. You should eliminate unnecessary space as you
arrange the fields on each frame.

About this task

Important: When you resize the frames of a screen entry form, you must resize
based on the resolution of the target monitor (for example, the monitor on which
the end user views the translation object).

Use this procedure to resize the Invoice frame.

Procedure
1. Click the invoice file icon to display the Invoice frame in the Layout Window.

Note: When the form is generated, the upper left corner of each frame in the
form is placed in the upper left corner of the Layout Window.

2. To display more of the form on your screen, click and drag the center bar
between the EDI File Format Window and the Layout Window to the left until
the Layout Window is wide enough to display as much of the form as you
want to view.

3. To resize the Invoice frame, click and drag the right side of the frame
approximately to the 14 cm. mark on the horizontal ruler so that the form is
wide enough to format the fields according to the instructions in this tutorial.

Fields on the Invoice Frame
You begin formatting the screen entry form by arranging the fields on the Invoice
frame. You place the fields in the translation object in a logical order, then align the
fields to give the frame a consistent and orderly appearance.

By default, each field and its associated label are displayed on their own line.
However, it is common for invoices to place two or more fields on a line.

You prevented some of the field labels from being displayed (by removing the field
label in the Label field of the Display dialog). For these fields, the fields are
displayed on your screen entry form, but their associated labels are not displayed.
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ANSI X12

The Invoice frame now should look like this:

EDIFACT

The Invoice Message frame now should look like this:
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TRADACOMS

The Invoice Details frame now should look like this:

Arranging Fields

Rearranging the Fields
About this task

Use this procedure to resize, move, and align the fields on the Invoice Message
frame of the screen entry form.

Procedure
1. Select the following fields and select Display > Size to Length.

v Invoice No.
v Invoice Date
v P.O. No.
v P.O. Date
v Contract No.
v Contract Date
v City Name (both Ship To and Remit To)
v Country Sub-Entity Identification (both Ship To and Remit To)
v Number of Line Items
v Total Invoice Amount
The selected fields are resized to the lengths specified in the Maximum
number of characters box of the Display dialog for each field.

2. Drag the following fields closer to their respective labels:
v Invoice No.
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v Invoice Date
v P.O. No.
v P.O. Date
v Contract No.
v Contract Date

3. Drag the Invoice Date label and field to the upper right corner of the Invoice
Message frame.

4. Drag the P.O. No. label and field to the left side of the frame, below the
Invoice No. label and field.

5. Drag the P.O. Date label and field to the right side of the frame, below the
Invoice Date label and field.

6. Drag the Contract No. label and field to the left side of the frame, below the
P.O. No. label and field.

7. Drag the Contract Date label and field to the right side of the frame, below
the P.O. Date label and field.

8. Rearrange the fields of the Ship To address as follows:
v Select the Ship To field (not the label), the two Street and Number/P.O. Box

fields, and the City Name field.
v Select Display > Align Controls > Left.
v Drag the Country Sub-Entity Identification field to the immediate right of

the City Name field.
v Drag the Postcode Identification field to the immediate right of the

Country Sub-Entity Identification field.
v Drag all of the Ship To fields (not including the Ship To label) closer to the

Ship To label, so that none of the fields extend beyond the right side of the
frame.

v Drag all of the Ship To fields (including the Ship To field label) to the left
side of the frame, below the Contract No. label and field.

9. Rearrange the fields of the Remit To address as follows:
v Select the Remit To field (not the label), the two Street and Number/P.O.

Box fields, and the City Name field of the Remit To address.
v Select Display > Align Controls > Left.
v Drag the Country Sub-Entity Identification field to the immediate right of

the City Name field.
v Drag the Postcode Identification field to the immediate right of the

Country Sub-Entity Identification Code field.
v Drag all of the Remit To fields (not including the Remit To label) closer to

the Remit To label, so that none of the fields extend beyond the right side
of the frame.

v Drag all of the Remit To fields (including the Remit To label) below the
Ship To address.

10. Select the Payment Terms Code list, and do the following:
v Click and drag its right handle so that the list is approximately 1.5 cm.

wide (including the down arrow).
v Click and drag its bottom handle to make the drop-down part of the list

box long enough to list approximately four codes (approximately 2 cm. long
on the vertical ruler).

v Drag the Payment Terms Code drop-down list box closer to its label.
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v Drag the Payment Terms Code drop-down list box and label to the center
of the frame, below the Remit To address.

11. Rearrange the fields of the Line Items as follows:
v Drag the Line Items list box closer to its label.
v Drag the Line Items list box and label to the center of the frame, below the

Payment Terms Code list box and label.
Leave extra space between the Payment Terms Code list box and label, and
the Line Items list box and label, to add column headings (using static text)
to label the data in the list box.

v Drag the Number of Line Items field closer to its label.
v Drag the Number of Line Items label and field to the center of the frame,

below the Line Items list box.
12. Drag the Total Invoice Amount field closer to its label.Drag the Total Invoice

Amount label and field to the center of the frame, below the Number of Line
Items label and field.

Resizing the Invoice Message Frame
You should resize the Invoice Message frame to make the most efficient use of
space. You have already resized the frame horizontally before you began arranging
the fields. Then, you arranged the fields on the frame so the fields do not use the
same amount of vertical space as before you arranged the fields.

About this task

To make better use of the frame space, you need to resize the frame vertically.

Procedure
1. To resize the Invoice Message frame, scroll to the top of the Invoice Message

frame, then click and drag the bottom of the frame to just below the Total
Invoice Amount label and field.

2. Select File > Save.

Aligning the Fields and Labels
Now that the fields in the Invoice Message frame are resized and moved to their
proper locations, you can align the fields and labels.

About this task

Use this procedure to align the fields and field labels on the Invoice Message
frame.

Procedure
1. Select the following labels and select Display > Align Controls > Left.

v Invoice No.
v P.O. No.
v Contract No.
v Ship To
v Remit To

2. Select the following fields and select Display > Align Controls > Left.
v Invoice No.
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v P.O. No.
v Contract No.

3. Select the following labels and select Display > Align Controls > Left.
v Invoice Date
v P.O. Date
v Contract Date

4. Select the following fields and select Display > Align Controls > Left.
v Invoice Date
v P.O. Date
v Contract Date

5. Select the following labels and select Display > Align Controls > Left.
v Number of Line Items
v Total Invoice Amount

6. Select the following fields and select Display > Align Controls > Left.
v Number of Line Items
v Total Invoice Amount

7. To align the tops of all of the field labels and fields, select each row of items
(one row at a time) as listed below. Then select Display > Align Controls >
Top.
v Invoice No. label and field, Invoice Date label and field
v P.O. No. label and field, P.O. Date label and field
v Contract No. label and field, Contract Date label and field
v Ship To label and field
v City Name, Country Sub-Entity Identification, and Postcode Identification

fields of the Ship To address
v Remit To label and field
v City Name, Country Sub-Entity Identification, and Postcode Identification

fields of the Remit To address
v Payment Terms Code label and drop-down list box
v Line Items label and list box
v Number of Line Items label and field
v Total Invoice Amount label and field
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Results

The Invoice Message frame now should look like this:

Adding Column Headings to the Line Items List Box
Sterling Gentran:Server labels the fields on the Line Items frame, but does not label
the column headings for the Line Items list box on the Invoice Message frame. The
Line Items list box displays the information entered into the fields on the Line
Items frame. To label the columns in the Line Items list box, you must add the
column headings with static text (text that is always included in the screen entry
translation object).

About this task

You will add the following column headings to the Line Items list box on the
Invoice Message frame:

Column Heading (Static
Text) Placement Above Line Items List

Item First column

Product Second column

Qty. Third column

Price Fourth column

Use this procedure to add and position the column headings.

Procedure
1. Click Add Text on the Main Toolbar. Text is added to the current frame,

displayed in the upper left corner of the frame. If the template is larger than
the frame (there is a scroll bar on the right side of the frame), the static text is
displayed in the upper left corner of the part of the template that is displayed,
not at the top of the template.

2. In the new text box, enter Item and click OK.
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3. Click Add Text on the Main Toolbar and enter Product in the text box and
click OK.

4. Click Add Text and enter Qty. in the text box and click OK.
5. Click Add Text and enter Price in the text box and click OK.

The column headings you added are displayed in the upper left corner of the
frame.

6. Drag the Item static text to above the Line Items list, immediately to the right
of the left margin of the Line Items list.

7. Drag the Product static text to above the Line Items list, to the right of the
Item column heading.

8. Drag the Qty. static text to above the Line Items list, to the right of the
Product column heading.

9. Drag the Price static text to above the Line Items list, to the right of the Qty.
column heading.

10. To ensure that the column headings (static text) you just added are aligned
properly, select all the static text you just added (Item, Qty., Product, Price).
Select Display > Align Controls > Top.

Results

The Invoice Message frame now should look like this:

Setting the Tab Sequence on the Invoice Message Frame -
EDIFACT

The tab sequence is the order in which the cursor moves from field to field in the
screen entry translation object when a user presses Tab. When you create a screen
entry form, the system automatically positions the fields and sets the tab sequence
for those fields. However, you usually will want to modify the tab sequence of the
fields to meet your screen entry requirements and the new positions of the fields
on the frame.
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About this task

Note: If you click a field out of sequence, you must begin setting the tab sequence
again. To start over, select Display > Set Tab Order so that the tab sequence
numbers are no longer displayed in the fields on the frame, and then begin the
steps again. When you click the last field in the sequence, the tab sequence is set,
and the tab sequence numbers no longer are displayed in the fields.

Use this procedure to set the tab sequence for the fields on the Invoice Message
frame.

Procedure
1. Select Display > Set Tab Order.

Numbers are displayed in the fields on the frame to indicate the current tab
sequence.

2. Click the items below in the order in which they are listed. As you click each
field, the tab sequence number for that field will change to the next sequential
number in the tab sequence.
a. Invoice No.
b. Invoice Date
c. P.O. No.
d. P.O. Date
e. Contract No.
f. Contract Date
g. Ship To Party Name
h. Ship To Street and Number/P.O. Box (first line of address)
i. Ship To Street and Number/P.O. Box (second line of address)
j. Ship To City Name
k. Ship To Country Sub-Entity Identification
l. Ship To Postcode Identification
m. Remit To Party Name
n. Remit To Street and Number/P.O. Box (first line of address)
o. Remit To Street and Number/P.O. Box (second line of address)
p. Remit To City Name
q. Remit To Country Sub-Entity Identification
r. Remit To Postcode Identification
s. Payment Terms Code
t. Line Items
u. Number of Line Items
v. Total Invoice Amount
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Results

The new tab sequence should look like this:

Fields on the Line Items Frame

Resizing the Line Items Frame and Fields
Now that the fields, labels, and static text are arranged on the Invoice Message
frame, you are ready to arrange the fields on the Line Items frame. You will place
the fields in a logical order, then align the fields (as you did with the fields on the
Invoice Message frame) to give the frame a consistent and orderly appearance.

About this task

Before you begin arranging the fields on the Line Items frame, you should resize
the frame so that it is the same width as the Invoice Message frame. When this
form is compiled into a translation object, the fields will be arranged according to
how the frames and the fields contained on them were arranged when the form
was compiled. You should eliminate unnecessary space as you arrange the fields
on each frame.

Use this procedure to resize the line items frame.

Procedure
1. Click the LIN group to display the Line Items frame in the Layout Window.
2. To resize the Line Items frame, click and drag the right side of the frame to the

14 cm. mark on the horizontal ruler.
3. To display more of the form on your screen, drag the center bar between the

EDI File Format Window and the Layout Window to the left until the Layout
Window is wide enough to display as much of the form as you want.

4. Select the following fields and select Display > Size to Length.
v Item No.
v Product Code
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v Quantity
v Date Shipped
v Price
v Transport Method
v Carrier Code
The selected fields are resized to the lengths specified in the Maximum number
of characters box of the Display dialog for each field.

Moving and Aligning Fields
About this task

Use this procedure to move and align the fields on the Line Items frame of the
screen entry form.

Procedure
1. Select the UOM field and drag its right handle so that it is approximately 2

cm. wide (including the down qrrow).
2. Drag its bottom handle so that the field is long enough for four codes to be

displayed in it when the drop-down list is open (approximately 2 cm. on the
vertical ruler).

3. Select the Transport Method and UOM fields (in that order) and select
Display > Size Equally. The Transport Method list is the same size as the
UOM list (the reference).

4. Select each field on the frame individually and move it closer to its respective
field label. If the field overlaps its label (for example, Date Shipped), move the
field slightly to the right of the label.

5. Drag the Product Code label and field to the right of the Item No. label and
field.

Note: The Item No. label and field are already positioned where you want
them (in the upper left corner of the frame). You do not need to move them.

6. Drag the Quantity label and field to the right of the Product Code label and
field.

7. Drag the UOM label and field below the Item No. label and field. The left
side of the UOM field label should be aligned with the left side of the Item
No. label.

8. Drag the Price label and field below the Product Code label and field. The left
side of the Price field label should be aligned with the left side of the Product
Code label.

9. Drag the Item Description label and field below the UOM and Price labels
and fields. The left side of the Description field label should be aligned with
the left side of the Item No. and UOM labels.

10. Drag the Date Shipped label and field to the left side of the frame, below the
Item Description label and field. The left side of the Date Shipped field label
should be aligned with the left side of the Item No., UOM, and Item
Description labels.

11. Drag the Transport Method label and field to the right of the Date Shipped
label and field.

12. Drag the Carrier Code label and field to the right of the Transport Method
label and field.
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Resizing the Line Items Frame
Use this procedure to resize the line items frame.

About this task

Procedure

To resize the Line Items frame, click and drag the bottom of the frame to below the
last row of fields and labels (Date Shipped, Transport Method, and Carrier Code).

Note: Allow enough space between the last row of fields/labels and the bottom of
the frame for the Transport Method drop-down list box to be opened.

Results

The Line Items frame now should look like this:

Aligning the Fields and Field Labels
About this task

Use this procedure to align the fields and field labels on the Line Items frame.

Procedure
1. Select the following labels and fields and select Display > Align Controls >

Top.
v Item No.
v Product Code
v Quantity

2. Select the following labels and fields and select Display > Align Controls >
Top.
v UOM
v Price

3. Select the Item Description label and field and select Display > Align Controls
> Top.

4. Select the following labels and fields and select Display > Align Controls >
Top.
v Date Shipped
v Transport Method
v Carrier Code

5. Select the following field labels and select Display > Align Controls > Left.
v Item No.
v UOM
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v Item Description
v Date Shipped

6. Select the following fields (in this order) and select Display > Align Controls >
Left.
v UOM
v Item No.

7. Select the following field labels and select Display > Align Controls > Left.
v Product Code
v Price

8. Select the following fields (in this order) and select Display > Align Controls >
Left.
v Price
v Product Code

Results

The Line Items frame now should look like this:

Setting the Tab Sequence on the Line Items Frame
About this task

Use this procedure to set the tab sequence of the fields on the Line Items frame.

Procedure
1. Select Display > Set Tab Order.

Numbers are displayed in the fields on the frame to indicate the current tab
sequence.

2. Click the items below in the order in which they are listed. As you click each
field, the tab sequence number for that field changes to the next sequential
number in the tab sequence you are now setting.
a. Product Code
b. Quantity
c. UOM
d. Price
e. Item Description
f. Date Shipped
g. Transport Method
h. Carrier Code
i. Item No.
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Note: The Item No. field is the last field in the tab sequence, although it is the
first field in the layout of the Line Items frame. This field is display-only,
displaying the next consecutive item number for the invoice (the item number
is generated by an accumulator in the Item No. field). By placing the Item No.
field last in the tab sequence, this field can be skipped easily by users entering
data. The first field in the sequence is the Product Code field, which is the first
field into which users can enter a value.

Results

The new tab sequence should look like this:

When you click the last field in the sequence (Item No.), the tab sequence is set,
and the tab sequence numbers no longer are displayed in the fields.

Changing the Invoice Message Frame Title - EDIFACT
The system automatically titles the frames in a screen entry form when the form is
created, based on the name of the file, segment(s), or group(s). You can modify the
frame titles (for example, at the file or message level) to distinguish one form from
the others. The parent frame of the invoice currently is titled Invoice Message. You
need to give this frame a more descriptive title to distinguish it from other invoices
that your company uses.

About this task

Use this procedure to change the frame title.

Procedure
1. Right-click the invoice file icon and select Properties.
2. On the Display tab, enter EDIFACT Invoice (INVOIC) - Pet Zone in the

Frame Caption box.
3. Click OK.

The new frame title is displayed in the frame title in the Layout Window.
4. Click Generate Layout on the Main Toolbar to refresh the display.
5. Select File > Save.

Results

When you have finished arranging the fields, your Invoice Message frame should
look like the following.
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What to do next

You have completed your Invoice form. Now, you are ready to finalize the form.

Chapter 8. Customizing Screen Entry Forms for EDIFACT 153



154 IBM Sterling Gentran:Server for Windows: Forms Integration Tutorial for Screen Entry Forms



Chapter 9. Creating Screen Entry Forms for TRADACOMS

Changing the Maximum Use of the IRF Segment
The IRF segment contains the Invoice References for the invoice. In this tutorial,
the IRF segment will be used for the invoice number, invoice date, and tax-point
date. The standard allows the IRF segment to be used up to 999,999 times in one
invoice. In this tutorial, you will use the IRF segment only once per invoice. You
will change the maximum use of the IRF segment to one, which will place the
associated fields on the main Invoice Details frame with the majority of the invoice
fields.

About this task

Use this procedure to change the maximum use of the IRF segment.

Procedure
1. Right-click the IRF segment and select Properties.

The EDI Segment Properties dialog is displayed.
2. On the Looping tab, enter 1 in the Max Usage field to designate that this

segment can be used only once per invoice.
3. Click OK to exit the EDI Segment Properties dialog.

Changing the Maximum Use of the PYT Segment
The PYT segment contains the Settlement Terms for the invoice. In this tutorial, the
PYT segment will be used for the describing the terms of payment. The standard
allows the PYT segment to be used up to 999,999 times in one invoice. In this
tutorial, you will use the PYT segment only once per invoice. You will change the
maximum use of the PYT segment to one, which will place the associated fields on
the main Invoice Details frame with the majority of the invoice fields.

About this task

Use this procedure to change the maximum use of the PYT segment.

Procedure
1. Right-click the PYT segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage field to designate that this

segment can be used only once per invoice.
3. Click OK to exit the EDI Segment Properties dialog.

Changing the Maximum Use of the DNA Segment
The DNA segment contains the Data Narrative for the invoice. In this tutorial, the
DNA segment will be used for narrative (descriptive text) describing information
that cannot be sent in a coded form. The standard allows the DNA segment to be
used up to 999,999 times in one invoice. In this tutorial, you will use the DNA
segment only once per invoice. You will change the maximum use of the DNA
segment to one, which will place the associated fields on the main Invoice Details
frame with the majority of the invoice fields.
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About this task

Use this procedure to change the maximum use of the DNA segment.

Procedure
1. Right-click the DNA segment and select Properties.
2. On the Looping tab, enter 1 in the Max Usage field to designate that this

segment can be used only once per invoice.
3. Click OK to exit the Segment Properties dialog.

Changing the Maximum Use of the ODD Group
The ODD group contains the Order and Delivery Terms information for the
invoice. In this tutorial, the ODD group will be used for information about the
customer’s order number, the date the order was placed, and the delivery number
and date. The standard allows the ODD group to be used up to 999,999 times per
invoice (because you are addressing only one order with this invoice). In this
tutorial, you will use the ODD group only once per invoice. You will change the
maximum use of the ODD group to one, which will place the associated fields on
the main Invoice Details frame with the majority of the invoice fields.

About this task

Use this procedure to change the maximum use of the ODD group.

Procedure
1. Right-click the ODD group and select Properties.
2. On the Looping tab, enter 1 in the Max Usage field to designate that this

segment can be used only once per invoice.
3. On the Display tab, select Promote group to parent frame to promote this

group. The fields in this group will be displayed on the same frame as the
fields in the parent group (INVOIC).

4. Click OK to exit the Group Properties dialog.
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Chapter 10. Modifying Screen Entry Forms for TRADACOMS

Setting up the Document Name for the Screen Entry Form
The document name makes the identification of a document created by the form
easier by enabling you to differentiate between documents.

About this task

We recommend that you set up a Document Name for each form. You can choose
any string element as the document name, but we strongly recommend that you
select an element that occurs only once in the document and has a data type of
string. For an ANSI X12 810 invoice, the document name usually is the Invoice
Number. For an EDIFACT 92.1 invoice, the document name is usually the
Document/Message Number.

Use this procedure to set up the document name.

Procedure
1. Double-click the one of the following elements:

v BIG02 (for ANSI X12)
v BGM05 (for EDIFACT)
v IRF INVN (for TRADACOMS)
We recommend that you select this element because it is a non-recurring and
mandatory element, and it helps to identify this document meaningfully in
Sterling Gentran:Server.

2. On Standard Rule tab, do the following:
v Select Update from the list.
v Click Yes at the prompt.
v From the Table/Group list, select Document record to indicate that you are

updating the document record in Sterling Gentran:Server.
v From the Column/Field list, select Document Name to indicate that you are

updating the Name field (in the Sterling Gentran:Server document browsers
that contain this message) with the contents of the B1G02 element.

3. Click OK to set up the document name.

The CLO Segment
The CLO segment (Customer’s Location) contains details about the specific
customer location pertaining to this invoice. In this tutorial, the CLO segment
contains details relating to the specific Pet Zone store you are invoicing.

The CLO CLOC CLO0 element (Customer’s ANA Location Code) contains the
code assigned by the Article Numbering Association for the customer’s location. In
this tutorial, your users will enter the customer’s ANA location code (which they
will obtain from the purchase order for the invoiced items).

Your trading partner, Pet Zone, uses a string of numbers for the ANA location
code, so you will create a syntax token that allows only numbers in the screen and
EDI formats of the data. Syntax tokens enable you to designate a "token" that
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defines ranges of characters and/or numbers that are allowed to be used for a
string-type element. The characters defined in the syntax token are used while
compliance checking each element to ensure that the data in the element falls
within the range of allowed characters.

In addition to creating a syntax token to be used for the screen and EDI formats of
the data, you will rename the field label to make it shorter and add Help text to
the field.

Creating a Syntax Token for the CLO Segment
About this task

Use this procedure to create a syntax token.

Procedure
1. Select Edit > Syntax Tokens.

The Token column contains the value designated as the syntax token for each
existing syntax token. The Token contains a range of characters that, when
applied to an element, dictate the way that element must be formatted. If the
element is not formatted as specified, the system will generate a compliance
error.
The Allowed character ranges column contains the range(s) of characters that
are permitted for each existing syntax token. Each range consists of a pair of
characters that define the start and end characters.

2. Click New to access the Edit Syntax Token dialog.
3. In the Token field, enter 9 to designate the unique one-character alphanumeric

value that the system will recognize as containing the allowed range of
characters you designate.
The Character Ranges list box contains the character range or ranges that you
defined for this token. You can define more than one character range for each
token.

4. Click New to access the Edit Character Range dialog, which enables you to
create a character range.

Note: Sterling Gentran:Server uses the ANSI character set when determining
the start-end range.

5. Enter 0 in the Start character field and 9 in the End character field to define the
token range.

6. Click OK to exit the Edit Character Range dialog.
7. Click OK to save the syntax token and exit the Edit Syntax Token dialog.
8. Click Close to exit the Syntax Tokens dialog.

Changing the CLO CLOC CLO0 Element and Field Properties
About this task

Use this procedure to change the screen and EDI formats for the data, rename the
field label, and add Help text to the Customer’s ANA Location Code field.

Procedure
1. Double-click the CLO CLOC CLO0 element.
2. On the Validation tab, do the following:
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v In the Form Format field, enter 9, which is the name of the syntax token you
just created for allowing users to enter data with only the characters 0–9 in
this element.

v In the File Format field, enter 9, which is the name of the syntax token you
just created for allowing the EDI data to consist of only the characters 0–9 in
this element.

3. On the Display tab, enter Location ANA Code in the Label field to replace the
existing text.

4. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Enter the EAN location number identifying this customer's
location. You must enter a numeric value in this field.

5. Click OK to exit the dialog.

Customizing the CLO CLOC CLO1 Element
The CLO CLOC CLO1 element (Customer’s Own Location Code) contains the code
assigned by the customer for the location to which the invoiced items are to be
delivered. In this tutorial, your users will enter the customer’s own location code
(which you have obtained from Pet Zone).

About this task

In this tutorial, you know that Pet Zone’s own location code will not exceed ten
characters, so you will change the field and element lengths to ten. In addition,
you will rename the field label and add Help text to the field.

Use this procedure to change the field and element lengths, rename the field label,
and add Help text to the Customer’s Own Location Code field.

Procedure
1. Double-click the CLO CLOC CLO1 element.
2. On the Validation tab, enter 10 in the Max field to allow a ten-character string

in this element.
3. On the Display tab, do the following:

v In the Label field, enter Location Own Code to replace the existing text.
v In the Display Length field, enter 10 to allow ten characters to be entered in

this field.
4. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the customer's own location number identifying
the location to which the invoiced items are to be
delivered.�The customer's location number may not
exceed 10�alphanumeric characters.

5. Click OK to exit the dialog.

Customizing the CLO CNAM Element
The CLO CNAM element (Customer’s Name) contains the customer’s registered
legal name.

About this task

In this tutorial, you want the Customer’s Name field to be the same length as the
address fields that follow (in the CLO CADD composite), so you will change the
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field and element lengths for the Customer’s Name field to thirty-five. In addition,
you will rename the field label and add Help text to the field.

Use this procedure to change the field and element lengths, rename the field label,
and add Help text to the Customer’s Name field.

Procedure
1. Double-click the CLO CNAM element.
2. On the Validation tab, enter 35 in the Max field to allow a thirty-five-character

string in this element.
3. On the Display tab, do the following:

v In the Label field, enter Name to replace the existing text.
v In the Display Length field, enter 35 to allow thirty-five characters to be

entered in this field.
4. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the customer's name. The name may not
exceed 35 alphanumeric characters.

5. Click OK to exit the dialog.

Customizing the CLO CADD CAD0 Element
The CLO CADD CAD0 element (Customer’s Address Line 1) contains the first line
of the customer’s address. You will rename the field label to shorten it and add
Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the Customer’s
Address Line 1 field.

Procedure
1. Double-click the CLO CADD CAD0 element.
2. On the Display tab, enter Address Line 1 in the Label field to replace the

existing text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the first line of the customer's address.
This address line may not exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the CLO CADD CAD1 Element
The CLO CADD CAD1 element (Customer’s Address Line 2) contains the second
line of the customer’s address. You will rename the field label to shorten it and
add Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the Customer’s
Address Line 2 field.

Procedure
1. Double-click the CLO CADD CAD1 element.
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2. On the Display tab, enter Address Line 2 in the Label field to replace the
existing text.

3. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Enter the second line of the customer's address.
This address line may not exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the CLO CADD CAD2 Element
The CLO CADD CAD2 element (Customer’s Address Line 3) contains the third
line of the customer’s address. You will rename the field label to shorten it and
add Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the Customer’s
Address Line 3 field.

Procedure
1. Double-click the CLO CADD CAD2 element.
2. On the Display tab, enter Address Line 3 in the Label field to replace the

existing text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the third line of the customer's address.
This address�line may not exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the CLO CADD CAD3 Element
The CLO CADD CAD3 element (Customer’s Address Line 4) contains the fourth
line of the customer’s address. You will rename the field label to shorten it and
add Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the Customer’s
Address Line 4 field.

Procedure
1. Double-click the CLO CADD CAD3 element.
2. On the Display tab, enter Address Line 4 in the Label field to replace the

existing text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the fourth line of the customer's address.
This address�line may not exceed 35 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the CLO CADD CAD4 Element
The CLO CADD CAD4 element (Customer’s Post Code) contains the post code of
the customer’s address. You will rename the field label to shorten it and add Help
text to this field.
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About this task

Use this procedure to rename the field label and add Help text to the Customer’s
Post Code field.

Procedure
1. Double-click the CLO CADD CAD4 element.
2. On the Display tab, enter Post Code in the Label field to replace the existing

text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the post code of the customer's address.
The post code may not exceed 8 alphanumeric characters.

4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display.

The IRF Segment

Customizing the IRF INVN Element
The IRF segment (Invoice References) contains details about the invoice, such as
the invoice number, invoice date, and tax-point date. This segment, and all the
elements contained in it, must be present in the invoice. You already changed the
maximum use for this segment, so that this segment will be used only once in an
invoice.

About this task

The IRF INVN element (Invoice Number) contains the number assigned by the
supplier for this invoice (in this tutorial, you are the supplier). You will rename the
field label to shorten it and add Help text to this field. (You already set up this
element as the document name.)

Use this procedure to rename the field label and add Help text to the Invoice
Number field.

Procedure
1. Double-click the IRF INVN element.
2. On the Display tab, enter Invoice No. in the Label field to replace the existing

text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the invoice number. The invoice number
may not�exceed 17 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the IRF IVDT Element
The IRF IVDT element (Date of Invoice) contains the invoice date. You will change
the screen format for the invoice date to DD/MM/YY. Also, this element is defined
by the standard to be a six-digit date. In this tutorial, your users will enter the
invoice date as an eight-digit date, so you will change the element and field
lengths to accommodate the longer date. In addition, you will rename the field
label and add Help text to this field.
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About this task

Use this procedure to change the screen format, change the field and element
lengths, rename the field label, and add Help text to the Date of Invoice field.

Procedure
1. Double-click the IRF IVDT element.
2. On the Validation tab, do the following:

v In the Max field, enter 8 to allow the entire date (including the / separators)
to be contained in this element.

v From the Form Format drop-down list box, select DD/MM/YY to indicate
that this field on the translation object will accept a date entered in that
format.

3. On the Display tab, do the following:
v In the Label field, enter Invoice Date to replace the existing text.
v In the Display Length field, enter 8 to allow the entire date (including the /

separators) to be displayed.
4. On the Help tab, enter the following text in the Help Text box.

Enter the invoice date. Use the format DD/MM/YY.

5. Click OK to exit the dialog.

Customizing the IRF TXDT Element
The IRF TXDT element (Tax-Point Date) contains the date on which the VAT is
applied. The tax-point date often is the same as the invoice date. You will change
the screen format for the tax-point date to DD/MM/YY. Also, this element is
defined by the standard to be a six-digit date. In this tutorial, your users will enter
the invoice date as an eight-digit date, so you will change the element and field
lengths to accommodate the longer date. In addition, you will add Help text to this
field.

About this task

Use this procedure to change the screen format, change the field and element
lengths, and add Help text to the Date of Invoice field.

Procedure
1. Double-click the IRF TXDT element.
2. On the Validation tab, do the following:

v In the Max field, enter 8 to allow the entire date (including the / separators)
to be contained in this element.

v From the Form Format drop-down list box, select DD/MM/YY to indicate
that this field on the translation object will accept a date entered in that
format.

3. On the Display tab, enter 8 in the Display Length field to allow the entire date
(including the / separators) to be displayed.

4. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Enter the tax-point date. The tax-point date is the
date the VAT was applied. Use the format DD/MM/YY.

5. Click OK to exit the dialog.
6. Click Generate Layout on the Main Toolbar to refresh the display.

Chapter 10. Modifying Screen Entry Forms for TRADACOMS 163



Results

The Invoice Details frame now should look like this:

The PYT Segment

Customizing the PYT SEQA Element
The PYT segment (Settlement Terms) specifies the settlement terms that apply to
the invoice. You already changed the maximum use of the PYT segment to one.

About this task

The PYT SEQA element (First Level Sequence Number) contains the sequence
number for the PYT segment. According to the standard, this number starts at one
and increases for each occurrence of the PYT segment. You already changed the
maximum use of the PYT segment to one (indicating that you will use the PYT
segment only once per invoice). You will define a constant value for this field,
designating that the constant "ONE" (which has a value of "1") is always the value
in the PYT SEQA element. Then, you will prevent this field from being displayed
in the screen entry form, since users will not need to enter a value in this field.

Use this procedure to define a constant and hide the First Level Sequence Number
field.

Procedure
1. Double-click the PYT SEQA element.
2. On the Standard Rule tab, do the following:

v Select Use Constant from the drop-down list.
v Click Edit to access the Map Constants dialog.

3. In the Map Constants dialog, click New to access the Edit Constant dialog.
4. In the Edit Constant dialog, do the following:
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v In the ID field, enter ONE to identify the constant.
v From the Type drop-down list box, select Integer to indicate that the literal

constant will be formatted as an integer data type.
v In the Value field, enter 1 to indicate that the First Level Sequence Number

field must contain the value 1. This value is the actual value of the literal
constant.

v Click OK to add the constant.
5. Click Close to exit the Map Constants dialog.
6. On the Standard Rule tab, select 1 in the Constants drop-down list box to

identify the constant that will be used for this element.
7. On the Display tab, select Hidden to prevent the field from being displayed.
8. Click OK to exit the dialog.

Customizing the PYT PAYT Element
The PYT PAYT element (Terms of Payment) contains the description of the
settlement terms. You will rename the field label and add Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the Terms of
Payment field.

Procedure
1. Double-click the PYT PAYT element.
2. On the Display tab, enter Payment Terms in the Label field to replace the

existing text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the payment terms. The payment terms
may not exceed 40 alphanumeric characters.

4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display.
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Results

The Invoice Details frame now should look like this:

The DNA Segment

Customizing the DNA SEQA:2 Element
The DNA segment (Data Narrative) contains narrative (descriptive text) pertaining
to the invoice. The standard allows this segment to be used up to 999,999 times in
an invoice. Your users will use this segment only once per segment, so you already
changed the maximum use to one.

About this task

The DNA SEQA:2 element (First Level Sequence Number) contains the sequence
number for the DNA segment. According to the standard, this number starts at one
and increases for each occurrence of the DNA segment. You already changed the
maximum use of the DNA segment to one (indicating that you will use the DNA
segment only once per invoice). You will use the constant "ONE" (which has a
value of "1"), so that "1" is always the value in the DNA SEQA:2 element. Then,
you will prevent this field from being displayed in the screen entry form, since
users will not need to enter a value in this field.

Procedure
1. Double-click the DNA SEQA:2 element.
2. On the Standard Rule tab, do the following:

v Select Use Constant from the drop-down list.
v In the Constants drop-down list box, select 1 to identify the constant that will

be used for this element.
3. On the Display tab, select Hidden to prevent the field from being displayed.
4. Click OK to exit the dialog.
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Customizing the DNA GNAR GNA0 Element
The DNA GNAR GNA0 element (General Narrative Line 1) contains descriptive
text pertaining to the invoice. Users can enter up to four lines (each with up to
forty characters) of descriptive text. For this tutorial, you will rename the field
label Invoice Notes® and add Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the General
Narrative Line 1 field.

Procedure
1. Double-click the DNA GNAR GNA0 element.
2. On the Display tab, enter Invoice Notes in the Label field to replace the

existing text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the first line of the invoice notes. The invoice
notes consist of descriptive text that pertains to the
entire invoice. This line of invoice notes may not
exceed 40 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the DNA GNAR GNA1 Element
The DNA GNAR GNA1 element (General Narrative Line 2) contains the second
line of descriptive text pertaining to the invoice. Users can enter up to four lines
(each with up to forty characters) of descriptive text. For this tutorial, only the first
line of descriptive text (General Narrative Line 1) will be labelled. Therefore, you
will remove the field label for the General Narrative Line 2 field and add Help text
to this field.

About this task

Use this procedure to remove the field label and add Help text to the General
Narrative Line 2 field.

Procedure
1. Double-click the DNA GNAR GNA1 element.
2. On the Display tab, delete the text in the Label field.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the second line of the invoice notes. The invoice
notes consist of descriptive text that pertains to the
entire invoice. This line of invoice notes may not
exceed 40 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the DNA GNAR GNA2 Element
The DNA GNAR GNA2 element (General Narrative Line 3) contains the third line
of descriptive text pertaining to the invoice. Users can enter up to four lines (each
with up to forty characters) of descriptive text. For this tutorial, only the first line

Chapter 10. Modifying Screen Entry Forms for TRADACOMS 167



of descriptive text (General Narrative Line 1) will be labelled. Therefore, you will
remove the field label for the General Narrative Line 3 field and add Help text to
this field.

About this task

Use this procedure to remove the field label and add Help text to the General
Narrative Line 3 field.

Procedure
1. Double-click the DNA GNAR GNA2 element.
2. On the Display tab, delete the text in the Label field.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the third line of the invoice notes. The invoice
notes consist of descriptive text that pertains to the
entire invoice. This line of invoice notes may not
exceed 40 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the DNA GNAR GNA3 Element
The DNA GNAR GNA3 element (General Narrative Line 4) contains the fourth
line of descriptive text pertaining to the invoice. Users can enter up to four lines
(each with up to forty characters) of descriptive text. For this tutorial, only the first
line of descriptive text (General Narrative Line 1) will be labelled. Therefore, you
will remove the field label for the General Narrative Line 4 field and add Help text
to this field.

About this task

Use this procedure to remove the field label and add Help text to the General
Narrative Line 4 field.

Procedure
1. Double-click the DNA GNAR GNA3 element.
2. On the Display tab, delete the text in the Label field.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the fourth line of the invoice notes. The invoice
notes consist of descriptive text that pertains to the
entire invoice. This line of invoice notes may not
exceed 40 alphanumeric characters.

4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display.

The ODD Group

Customizing the ODD:2 SEQA Element
The ODD group contains the Order and Delivery Terms information for the
invoice. In this tutorial, the ODD group will be used for information about the
customer’s order number, the date the order was placed, and the delivery number
and date. The standard allows the ODD group to be used up to 999,999 times per
invoice. In this tutorial, you will use the ODD group only once per invoice. You
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already changed the maximum use of the ODD group to one, which placed the
associated fields on the main Invoice Details frame with the majority of the invoice
fields.

About this task

The ODD:2 SEQA element (First Level Sequence Number) contains the sequence
number for the ODD:2 segment. According to the standard, this number starts at
one and increases for each occurrence of the ODD:2 segment. The ODD:2 segment
has a maximum use of only one, so the value in the ODD:2 SEQA element will
always be "1". You will use the constant "ONE" (which has a value of "1"), so that
"1" is always the value in the ODD:2 SEQA:2 element. Then, you will prevent this
field from being displayed in the screen entry form, since users will not need to
enter a value in this field.

Procedure
1. Double-click the ODD:2 SEQA element.
2. On the Standard Rule tab, do the following:

v Select Use Constant from the drop-down list.
v In the Constants drop-down list box, select 1 to identify the constant that will

be used for this element.
3. On the Display tab, select Hidden to prevent the field from being displayed.
4. Click OK to exit the dialog.

Customizing the ODD:2 ORNO ORN0 Element
The ODD:2 ORNO ORN0 element (Customer’s Order Number) contains the
number assigned by the customer to identify the order. You will rename the field
label and add Help text to this field.

About this task

Use this procedure to change the field label for the Customer’s Order Number
field.

Procedure
1. Double-click the ODD:2 ORNO ORN0 element.
2. On the Display tab, enter Customer’s P.O. No. in the Label field to replace the

existing text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the customer's purchase order number. The purchase
order number may not exceed 17 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the ODD:2 ORNO ORN2 Element
The ODD:2 ORNO ORN2 element (Date Order Placed by Customer) contains the
date on which the customer placed the purchase order. You will change the screen
format for the purchase order date to DD/MM/YY. Also, this element is defined
by the standard to be a six-digit date. In this tutorial, the purchase order date will
be printed as an eight-digit date, so you will change the element and field lengths
to accommodate the longer date. For brevity, you will change the field label to P.O.
Date.
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About this task

Use this procedure to change the screen format, change the element and field
lengths, and rename the field label for the Date Order Placed by Customer field.

Procedure
1. Double-click the ODD:2 ORNO ORN2 element.
2. On the Validation tab, do the following:

v In the Max field, enter 8 to allow the entire date (including the / separators)
to be contained in this element.

v From the Form Format drop-down list box, select DD/MM/YY to indicate
that this field on the translation object will accept a date entered in the
format DD/MM/YY.

3. On the Display tab, do the following:
v In the Label field, enter P.O. Date to replace the existing text.
v In the Display Length field, enter 8 to allow the entire date (including the /

separators) to be displayed.
4. On the Help tab, enter the following text in the Help Text box.

Enter the purchase order date. Use the format DD/MM/YY.

5. Click OK to exit the dialog.

Customizing the ODD:2 DELN DEL0 Element
The ODD:2 DELN DEL0 element (Delivery Note Number) contains the number
corresponding to the delivery note. The only customizing you will perform for this
field is adding Help text.

About this task

Use this procedure to add Help text to the Delivery Note Number field.

Procedure
1. Double-click the ODD:2 DELN DEL0 element.
2. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the number corresponding to the delivery note.
The �delivery note number may not exceed 17
alphanumeric characters.

3. Click OK to exit the dialog.

Customizing the ODD:2 DELN DEL1 Element
The ODD:2 DELN DEL1 element (Date of Despatch by Supplier) contains the date
on which the order was delivered. You will change the screen format for the
delivery date to DD/MM/YY. Also, this element is defined by the standard to be a
six-digit date. In this tutorial, the delivery date will be printed as an eight-digit
date, so you will change the element and field lengths to accommodate the longer
date. For brevity, you will change the field label to P.O. Date.

About this task

Use this procedure to change the screen format, change the element and field
lengths, and rename the field label for the Date of Despatch by Supplier field.

170 IBM Sterling Gentran:Server for Windows: Forms Integration Tutorial for Screen Entry Forms



Procedure
1. Double-click the ODD:2 DELN DEL1 element.
2. On the Validation tab, do the following:

v In the Max field, enter 8 to allow the entire date (including the / separators)
to be contained in this element.

v From the Screen Format drop-down list box, select DD/MM/YY to indicate
that this field on the translation object will accept a date entered in the
format DD/MM/YY.

3. On the Display tab, do the following:
v In the Label field, enter Delivery Date to replace the existing text.
v In the Display Length field, enter 8 to allow the entire date (including the /

separators) to be displayed.
4. On the Help tab, enter the following text in the Help Text box.

Enter the delivery date. Use the format DD/MM/YY.

5. Click OK to exit the dialog.

Customizing the ILD Group
The ILD group (Invoice Line Details) contains the line item detail for each item
invoiced. The standard allows the ILD group to be used up to 999,999 times per
invoice.

About this task

The fields associated with the ILD group are arranged on the ILD frame, which is
separate from the Invoice Details frame that you have been working with thus far
in this tutorial. Your users will complete the fields on the ILD frame for each item
in the invoice. The list of all line items in the invoice will be displayed in a list box
on the Invoice Details frame. In that list box, the invoiced items will be displayed
line by line, forming columns of information.

Use this procedure to rename the ILD frame and list box, provide a description for
the ILD group, and add Help text to the line items list box.

Procedure
1. Right-click the ILD group and select Properties.
2. In the Desc field, enter Line Items to describe the group.
3. On the Display tab, do the following:

v In the Frame Caption field, enter Line Items to rename the frame.
v In the List Caption field, enter Line Items to rename the list box that is

displayed on the Invoice Details frame (listing the line items entered on the
Line Items frame).

4. In the Frame Help Text list box, enter the following text. (Press Enter at the end
of each line of text.)
This frame contains line item detail�information.
For online Help on an individual field on this frame,
select the field and press F1.

5. In the Listbox Help Text list box, enter the following text. (Press Enter at the
end of each line of text.)
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This list box contains the line item detail for�
the invoice. The data in this list box is�entered
or changed on the Line Items�frame. To enter a new
line item, click the�list box and click New. To modify
an�existing line item, click that item and click�Open.

6. Click OK to exit the Group Properties dialog.

The ILD:2 Segment
The ILD:2 segment (Invoice Line Details) contains the line item detail for each item
invoiced. For some of the elements in the ILD:2 segment, you only need to add
Help text and rename the field labels so they more accurately reflect your
company’s needs. With other elements, you will change the maximum lengths for
some of the fields, use accumulators to calculate the number of line items, or
define a constant value.

The ILD:2 group is subordinate to the Invoice Details frame, so Sterling
Gentran:Server creates a separate frame (the Line Items frame) to contain the group
data (the line item details). The system also creates a list box (the Line Items list
box) on the Invoice Details frame to allow the user to access the items in the list
box. Each set of data is displayed as a row in the list box. After you customize the
line item fields, the Line Items list box will contain these four columns of data:
Item, Product, Qty, and Price.

Customizing the ILD:2 SEQA Element
The ILD:2 SEQA element (First Level Sequence Number) contains the sequence
number for the ODD group (the parent group in which the ILD:2 SEQA element
resides). According to the standard, this number starts at one and increases for
each occurrence of the ODD group. The ODD group has a maximum use of only
one, so the value in the ILD:2 SEQA element will always be "1". You will use the
constant "ONE" (which has a value of "1"), so that "1" is always the value in the
ILD:2 SEQA:2 element. Then, you will prevent this field from being displayed in
the screen entry form, since users will not need to enter a value in this field.

About this task

Use this procedure to use a constant and hide the First Level Sequence Number
field.

Procedure
1. Double-click the ILD:2 SEQA element.
2. On the Use Standard Rule tab, do the following:

v Select Use Constant.
v In the Constants drop-down list box, select 1 to identify the constant that will

be used for this element.
3. On the Display tab, select Hidden to prevent the field from being displayed.
4. Click OK to exit the dialog.

Customizing the ILD:2 SEQB Element
The ILD:2 SEQB element (Second Level Sequence No.) contains the second-level
sequence number for the ILD:2 segment in the ILD group (the subordinate group
in which the ILD:2 SEQB element resides). According to the standard, this number
starts at one and increases for each occurrence of the ILD group. You will use the
Loop Count function to obtain the value of the current loop count, and then you
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will make this field display-only (since the users will not need to enter a value in
this field). Also, since the value in this field reflects the sequential number for each
line item, you will rename the field label Item No.

About this task

You will create a list box definition for this element to include the item number in
the list box. Also, you know that your users will enter no more than 99,999 line
items per invoice. Each line item will be numbered sequentially, starting with one,
so you need a maximum length of only five digits for this field. You will change
the field and element lengths for this field to five.

Use this procedure to rename the field label, change the field and element lengths,
add Help text, and create the list box definition for the Second Level Sequence No.
field.

Procedure
1. Double-click the ILD:2 SEQB element.
2. On the Validation tab, enter 5 in the Max field to allow a five-digit number in

this element.
3. On the Use Standard Rule tab, do the following:

v Select the Loop Count option from the drop-down list.
v In the Groups drop-down list box, select ILD to identify the loop for which

you want to obtain the current value of the loop count. The ILD group is a
nested group (the ODD group is the parent group of the ILD group).

4. On the Display tab, do the following:
v In the Display section, select Display to make this field display-only.
v In the Label field, enter Item No. to replace the existing text.
v In the Display Length field, enter 5 to allow five numeric digits to be

displayed in the field.
5. On the Summary List tab, do the following:

v Select Display this field in summary list. The value in the Item No. field
will be displayed in a column in the Line Items list box.

v In the Column Width field, enter 8 to set the width of this column in the
Line Items list box.

v From the Sequence drop-down list box, select 1 to indicate that this field will
be the first column in the list box.

6. Click OK to exit the dialog.

Customizing the ILD:2 SPRO SPR0 Element
The ILD:2 SPRO SPR0 element (EAN-13 Code for the Traded Unit) contains the
number of the thirteen-digit European Article Number allocated to the unit of
trade (the invoiced item). In this tutorial, you will rename the field label to shorten
it and add Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the EAN-13
Code for the Traded Unit field.

Procedure
1. Double-click the ILD:2 SPRO SPR0 element.
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2. On the Display tab, enter EAN Code in the Label field to replace the existing
text.

3. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Enter the EAN code for the invoiced item. The EAN code
must be exactly 13 alphanumeric characters long.

4. Click OK to exit the dialog.

Customizing the ILD:2 SPRO SPR1 Element
The ILD:2 SPRO SPR1 element (Supplier’s Code for the Traded Unit) contains the
supplier’s internal reference identifying the invoiced item (in this tutorial, your
company is the supplier). You will rename the field label and add Help text to this
field.

About this task

Also, you will create a list box definition for this element to include the supplier’s
product code in the Line Items list box on the Invoice Details frame.

Use this procedure to rename the field label, add Help text, and create the list box
definition for the Supplier’s Code for the Traded Unit field.

Procedure
1. Double-click the ILD:2 SPRO SPR1 element.
2. On the Display tab, enter Supplier’s Product Code in the Label field to replace

the existing text.
3. On the Summary List tab, do the following:

v Select Display this field in summary. The value in the Supplier’s Product
Code field will be displayed in a column in the Line Items list box.

v In the Column Width field, enter 33 to set the width of this column in the
Line Items list box.

v From the Sequence drop-down list box, select 2 to indicate that this field will
be the second column in the list box.

4. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Enter the supplier's product code for the invoiced item.
The �product code may not exceed 30 alphanumeric characters.

5. Click OK to exit the dialog.

Customizing the ILD:2 CPRO CPR1 Element
The ILD:2 CPRO CPR1 element (Customer’s Item Code) contains the customer’s
internal reference identifying the invoiced item. Your users can obtain this
information from the customer’s purchase order. In this tutorial, you will rename
the field label and add Help text to this field.

About this task

Use this procedure to rename the field label and add Help text to the Customer’s
Item Code field.

Procedure
1. Double-click the ILD:2 CPRO CPR1 element.
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2. On the Display tab, enter Customer’s Product Code in the Label field to
replace the existing text.

3. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Enter the customer's product code for the invoiced item.
The �code may not exceed 30 alphanumeric characters.

4. Click OK to exit the dialog.

Customizing the ILD:2 QTYI QTY0 Element
The ILD:2 QTYI QTY0 element (Number of Order Units Invoiced) contains the
quantity of invoiced items for this line item. You will create a list box definition for
this element to include the quantity invoiced in the list box on the Invoice Details
frame. For brevity, you will rename the field label. Also, the standard defines this
field as a string data type, and allows up to fifteen alphanumeric characters in this
element. However, your users will enter number-type data in N0 format (formatted
with an implicit decimal point and no decimal places). Therefore, you will change
the data type and the screen and EDI formats to reflect the data your users will
enter.

About this task

In addition, your users will enter quantities no greater than five digits (e.g. 99,999).
You will change the field and element lengths to reflect the smaller data length.
Then, you will add Help text to this field.

Use this procedure to change the data type and screen and EDI formats, rename
the field label, change the field and element lengths, add Help text, and create the
list box definition for the Number of Order Units Invoiced field.

Procedure
1. Double-click the ILD:2 QTYI QTY0 element.
2. On the Validation tab, do the following:

v In the Max field, enter 5 to allow a five-digit number in this element.
v From the Data Type drop-down list box, select Number. Sterling

Gentran:Server prompts you that changing the field’s data type will
invalidate its format. Click Yes.

v From the Form Format drop-down list box, select N0 to indicate that this
field will accept a number with an implied decimal point and no decimal
places.

v From the File Format drop-down list box, select N0 to format the EDI data
with an implied decimal point and no decimal places.

3. On the Display tab, do the following:
v In the Label field, enter Quantity to replace the existing text.
v In the Display Length field, enter 5 to allow five numeric digits to be

displayed in the field.
4. On the Summary List tab, do the following:

v Select Display this field in summary list. The value in the Quantity field
will be displayed in a column in the Line Items list box on the Invoice
Details frame.

v In the Column Width field, enter 8 to set the width of this column in the
Line Items list box.
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v From the Sequence drop-down list box, select 3 to indicate that this field will
be the third column in the list box.

5. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Enter the quantity of this invoiced item.
The quantity may not exceed 5 digits.

6. Click OK to exit the dialog.

Customizing the ILD:2 QTYI CD04:2 Element
The ILD:2 QTYI CD04:2 element (Measure Indicator) contains the abbreviation for
the measure of the invoiced item (e.g. kilometres, metres, litres). You want all the
available codes from Code Values List 4 to be available to your screen entry users,
so you will load the entire code list. Loading the code list in this element causes a
drop-down list box to be displayed on the Invoice Details frame (instead of a
field). Users will select an appropriate code from the list box, instead of entered a
value in the field.

About this task

After you specify the code list table to use for the drop-down list box for the
Measure Indicator field, you will rename the field label and add Help text to the
field.

Use this procedure to load Code Values List 4 from the standard, rename the field
label, and add Help text to the Measure Indicator field.

Procedure
1. Double-click the ILD:2 QTYI CD04:2 element.
2. On the Standard Rule tab, do the following:

v Select the Use Code option.
v Click Edit to access the Edit Code List dialog. The Table ID field contains

CD04, the name of the element for which this code list table will be used.
The Desc field contains "Measure Indicator", the description of the element
for which this code list table will be used.

3. In the Edit Code List dialog, click Load. You will be prompted to select an
ODBC data source name.

4. Select the appropriate DSN and click OK to access the Load Code List dialog.
The Codes In Standard list box contains the entire code list.

5. Click Add All to move all of the codes in the code list table to the Codes
Selected list box.

Note: Adding all the codes in the list (by using Add All) creates a much
larger form than if you use only selected codes. However, it is necessary for
your users to have all the codes available from which to choose.

6. Click OK to load the code list table and exit the Load Code List dialog.
7. Click Close to exit the Edit Code List dialog.
8. On the Standard Rule tab, select Raise a compliance error to specify that the

element must contain one of the codes from Code Values List 4 (nothing else
is valid for that element).

9. On the Display tab, enter Unit of Measure in the Label field to replace the
existing text.
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10. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Select the unit of measure for this invoiced item from the drop-down list box.

11. Click OK to exit the dialog.

Customizing the ILD:2 AUCT AUC0 Element
The ILD:2 AUCT AUC0 element (Cost Price (Excluding VAT)) contains the price
per unit invoiced. This price is the cost in pounds before line discounts and VAT
have been applied. The EDI data will be formatted in N4 format (formatted with
an implicit decimal point and four decimal places), but your users will enter the
price in the translation object in R4 format (formatted with an explicit decimal
point). Therefore, you will change the screen format to reflect how you want the
price to be entered in the translation object.

About this task

You will create a list box definition for this element to include the unit price in the
list box on the Invoice Details frame. Also, you will rename the field label and add
Help text to this field.

Use this procedure to change the screen format, rename the field label, add Help
text, and create the list box definition for the Cost Price (Excluding VAT) field.

Procedure
1. Double-click the ILD:2 AUCT AUC0 element.
2. On the Validation tab, select R4 from the Form Format drop-down list box to

indicate that this field will accept a number with an explicit decimal point and
up to four decimal places.

3. On the Display tab, enter Unit Price (Ex. VAT) in the Label field to replace the
existing text.

4. On the Summary List tab, do the following:
v Select Display this field in summary list. The value in the Unit Price (Ex.

VAT) field will be displayed in a column in the Line Items list box on the
Invoice Details frame.

v In the Column Width field, enter 14 to set the width of this column in the
Line Items list box.
You do not need to make the column width for this field wider than the
actual content of the column. The data from this field will form the last
column in the list box, and you do not need to leave white space between
the last column and the side of the list box.

v From the Sequence drop-down list box, select 4 to indicate that this field will
be the third column in the list box.

5. On the Help tab, enter the following text in the Help Text box.
Enter the unit price for this invoiced item.

6. Click OK to exit the dialog.

Customizing the ILD:2 LEXC Element
The ILD:2 LEXC element (Extended Line Cost (Excluding VAT)) contains the price
per unit invoiced, after any line discounts have been applied. This price is the net
cost in pounds (e.g. after deducting line discounts, etc., but before the application
of VAT). The EDI data will be formatted in N4 format (formatted with an implicit
decimal point and four decimal places), but your users will enter the price in the
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translation object in R4 format (formatted with an explicit decimal point).
Therefore, you will change the screen format to reflect how you want the price to
be formatted in the translation object.

About this task

Also, you will prevent this field from being displayed in the translation object. The
extended line cost will be calculated automatically when users click Store on the
Line Items frame when they use this translation object in Sterling Gentran:Server.
You can hide this field because users will not need to enter the value in the field.

Use this procedure to change the screen format for the Extended Line Cost
(Excluding VAT) field, and prevent this field from being displayed.

Procedure
1. Double-click the ILD:2 LEXC element.
2. On the Validation tab, select R4 from the Form Format drop-down list box to

indicate that this field will accept a number with an explicit decimal point and
up to four decimal places.

3. On the Display tab, select Hidden to prevent the field from being displayed.
4. Click OK to exit the dialog.

Calculating the Extended Price
You want to automate the calculation that results in the extended price for each
line item, so that the screen entry users who use your invoice translation object do
not have to perform this calculation manually. A simple way to perform this
calculation is to use an extended rule to define the operation in the ILD group. You
define extended rule with the Sterling Gentran:Server proprietary programming
language, which gives you access to the entire Sterling Gentran:Server internal
storage area.

About this task

Use this procedure to define an extended rule to calculate the extended price.

Procedure
1. Right-click the ILD group (in the ODD group) and select Extended Rules.

The Loop Level Extended Rules dialog is displayed.
2. Select On Store to indicate that you want the rule to be executed when you

store a group.
3. In the Editor list box, enter the following extended rule:

#LEXC = #QTY0 * #AUC0;

This extended rule means that the value of the ILD:2 LEXC field is equal to the
product of the values in the ILD:2 QTYI QTY0 and ILD:2 AUCT AUC0 fields.
In other words, the quantity invoiced for one line item, multiplied by the price
(excluding VAT) for each unit invoiced, equals the extended price (excluding
VAT).

4. Click Compile to compile the extended rule and verify that this rule does not
cause errors or warnings.
If you receive any errors or warnings when you compile the rule, verify that
you entered the rule exactly as it is written in the previous step. After you
make any change to the extended rule to correct it, click Compile again. Repeat
this process until there are no errors generated.
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5. Click OK to add the extended rule to the form and exit the Loop Level
Extended Rules dialog.

The ILD:2 CD12 Element
The ILD:2 CD12 element (VAT Rate Category Code) contains the code from Codes
Values List 12 to designate the VAT rate category for this invoiced item (e.g.
standard rate, exemption from VAT, higher rate, etc.). You will use a Select
standard rule on the VAT Rate Category Code field, but first you need to create a
temporary VATP element.

Sterling Gentran:Server enables you to use selected information from the Sterling
Gentran:Server partner database in your forms via a Select standard rule. You can
map information from your trading partner’s profile in the Partner Editor to a
selected element in the form. The information that you can use in the form
includes any fields in a table (location, lookup, or cross-reference) or data from the
partner record.

For this form, you need to map the appropriate VAT rate based on the code in the
ILD:2 CD12 element from a lookup table, to look up data that you will map (via a
standard rule) to the temporary VATP_TEMP field that you create. When you use
tables, you must decide whether to create a code table in Sterling Gentran:Server
that can be used only with this form, or to add the table to either the partner
relationship or the internal system partner in Partner Editor. In this tutorial, you
will set up the table you use under the internal system partner (Internal System
User) so the table can be used globally.

In this tutorial, you need to extract information from a lookup table and insert it
into the form. A lookup table is used when you want to supplement data before it
is sent to your partner. See the IBM Sterling Gentran:Server for Microsoft Windows
User Guide for more information on lookup tables.

Note: You do not need to create this lookup table (INVATCO.LKP). It is included
with the tutorial data that is provided when you install Sterling Gentran:Server.

After you use the Select function, all the available codes from the selected table
will be available in a drop-down list box (instead of a field) on the Invoice Details
frame. Users will select an appropriate code from the drop-down list box, instead
of entered a value in the field.

In addition to using the Select function, you will rename the field label and add
Help text to the field.

Creating a Temporary VATP Element
About this task

Use this procedure to create a temporary VATP element.

Procedure
1. Select the ILD:2 VATP element.
2. Click Copy on the Main Toolbar.
3. Select the ILD:2 SCRF composite, which is the last form component in the

ILD:2 segment. The ILD:2 SCRF composite is the composite after which you
want the ILD:2 VATP element to be pasted.

4. Click Paste on the Main Toolbar to paste the ILD:2 VATP element.
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5. Select Paste after selected item (at the same level) to paste the Clipboard
contents after the ILD:2 SCRF composite. A new element (ILD:2 VATP:2) is
created. The ILD:2 VATP:2 element is an exact copy of the ILD:2 VATP element.

6. Click OK to exit the dialog.

Note: You should rename the ILD:2 VATP:2 element to give it a more
descriptive name.

7. Double-click the ILD:2 VATP:2 element.
8. In the Name field, enter VATP_TEMP to replace the existing text.
9. Click OK to exit the Element Properties dialog.

The ILD:2 VATP:2 element is renamed ILD:2 VATP_TEMP.

Changing the ILD:2 CD12 Element and Field Properties
About this task

Use this procedure to use the Select function, rename the field label, and add Help
text to the VAT Rate Category Code field.

Procedure
1. Double-click the ILD:2 CD12 element.
2. On the Standard Rule tab, do the following:

v Click the Select option.
v In the Table drop-down list box, select Division lookup. You are using the

Division lookup because the VAT codes do not vary on a partner-by-partner
basis, so you can use the Internal System User partner and map from any
field on the Lookup Entry dialog (in Partner Editor in Sterling
Gentran:Server). You will be able to set up the lookup only once, regardless
of the number of partners with which you will use this translation object.

v In the Sub Table field, enter VATCODES, which is the name of the table
name for the Internal System User partner that you will import.

v In the Map From list box, select Text 1, which is the field on the Lookup
Entry dialog in Partner Editor from which the contents will be mapped.

v In the Map To list box, select VATP_TEMP, which is the temporary VATP
element you just created. The system will map the value from Partner Editor
to the VATP_TEMP element.

The dialog now should look like the following:
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3. On the Display tab, enter VAT Code in the Label field to replace the existing
text.

4. On the Help tab, enter the following text in the Help Text box. (Press Enter at
the end of each line of text.)
Select the VAT code for this invoiced item from the drop-down list box.

5. Click OK to exit the dialog.

Customizing the ILD:2 VATP Element
The ILD:2 VATP element (VAT Rate Percentage) contains the percentage rate for
the VAT category code. Screen entry translation object users will not need to enter
a value in this field because Sterling Gentran:Server will look up the percentage in
the VATCODES table in Partner Editor and place the result in the ILD:2 VATP
element automatically. You will prevent the ILD:2 VATP element from being
displayed on the translation object.

About this task

Use this procedure to hide the VAT Rate Percentage field.

Procedure
1. Double-click the ILD:2 VATP element.
2. On the Display tab, select Hidden to prevent the field from being displayed.
3. Click OK to exit the dialog.

Customizing the ILD:2 VATP_TEMP Element
The ILD:2 VATP_TEMP element (VAT Rate Percentage) is the temporary element
you created to map the VAT rate percentage in the VATCODES division lookup
table. To map from the partner database to the VATP_TEMP field, the target field
(VATP_TEMP) needs to be a string-type element. You will use the ILD:2
VATP_TEMP element to convert the VAT rate percentage (a string) into a real
number (the data type required in the ILD:2 VATP field). For compliance reasons,
you cannot change the data type in the ILD:2 VATP element; therefore, you created
the ILD:2 VATP_TEMP element, whose data type you may change.
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About this task

The system will be able to look up the VAT rate percentage (a string data type) in
the VATCODES table, and map the string to the ILD:2 VATP_TEMP element. Later,
you will add an extended rule to the ILD group to convert the string in the ILD:2
VATP_TEMP element to a number in the ILD:2 VATP element, then remove all
data from the ILD:2 VATP_TEMP element (so that element is empty). After having
executed these functions, the system will have converted a string data type to a
real number, maintaining the integrity of the data and the compliance of the
invoice.

Use this procedure to hide the VAT Rate Percentage field and change the data type
for this field to string.

Procedure
1. Double-click the ILD:2 VATP_TEMP element.
2. On the Validation tab, do the following:

v Select Mandatory to make this element conditional.
v In the Min field, enter 0 for the minimum number of digits allowed for this

element.
v From the Data Type drop-down list box, select String. Sterling

Gentran:Server prompts you that changing the field’s data type will
invalidate its format. Click Yes.

3. On the Display tab, select Hidden to prevent the field from being displayed.
4. Click OK to exit the dialog.

Converting Strings into Real Numbers
You created the ILD:2 VATP_TEMP element as a temporary element for converting
strings into numbers. The first step in converting strings into elements, in this
tutorial, was to create the ILD:2 VATP_TEMP element so that the system will use
that element to look up the VAT rate percentage (a string data type) in the
VATCODES table, then map the string to the ILD:2 VATP_TEMP element. The next
step is to use an extended rule in the ILD group to convert the string in the ILD:2
VATP_TEMP element into a real number that can be used in the ILD:2 VATP
element, and then delete any data left in the temporary element (ILD:2
VATP_TEMP).

About this task

Use this procedure to define an extended rule to convert strings into numbers.

Procedure
1. Right-click the ILD group (in the ODD group) and select Extended Rules.
2. Select On Store to indicate that you want the rule to be executed when you

store a group. (The extended rule you added to calculate an extended price is
displayed in the Editor list box of the Loop Level Extended Rules dialog.)
When the screen entry users click Store on the Line Items frame, all On Store
extended rules in the Loop Level Extended Rules dialog will be executed.

3. On the next two lines in the Editor list box, enter the following extended rule:
#VATP = ATON(#VATP_TEMP);�
empty(#VATP_TEMP);

The ATON function tells the system to convert the string data in the ILD:2
VATP_TEMP element into a real number.
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The calculation you entered on the first line places the number data in the
ILD:2 VATP element.
The empty function sets the value of the ILD:2 VATP_TEMP field to null.

4. Click Compile to compile the extended rule and verify that this rule does not
cause errors or warnings. If you receive any errors or warnings when you
compile the rule, verify that you entered the rule exactly as it is written in step
4 above. After you make any change to the extended rule to correct it, click
Compile again. Repeat this process until there are no errors generated.

5. Click OK to add the extended rule to the form and exit the Loop Level
Extended Rules dialog.

Customizing the ILD:2 TDES TDE0 Element
The ILD:2 TDES TDE0 element (Traded Unit Descr. Line 1) contains the description
of the invoiced item. You will rename the field label to shorten it and add Help
text to this element.

About this task

Use this procedure to rename the field label and add Help text to the Traded Unit
Descr. Line 1 field.

Procedure
1. Double-click the ILD:2 TDES TDE0 element.
2. On the Display tab, enter Description in the Label field to replace the existing

text.
3. On the Help tab, enter the following text in the Help Text box. (Press Enter at

the end of each line of text.)
Enter the description of the invoiced item.
The description may not exceed 40 alphanumeric characters.

4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display.
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Results

The Line Items frame now should look like this:

The STL Segment
The STL segment (VAT Rate Invoice Sub Trailer) contains the invoice amounts
relating to the VAT rate.

All monetary values in this segment are in pounds. You will use an extended rule
to perform the calculations that will be displayed in the fields in the STL segment.
Screen entry translation object users will be able to view the values in these fields
(in the VAT Summary frame), but will not be able to change the values. See The
VAT Summary and the Invoice Trailer for details on how to add the extended rule.

The fields associated with the STL segment are arranged on the STL frame. Your
users will complete the fields on the STL frame for each VAT rate calculation. The
list of all VAT rates in the invoice will be displayed in a list box on the Invoice
Details frame. In that list box, the VAT rates will be displayed for each line item,
forming columns of information.

Customizing the STL Segment
Use this procedure to rename the STL frame and list box, provide a description for
the STL segment, and add Help text to the list box.

About this task

Procedure
1. Right-click the STL segment and select Properties.
2. On the Display tab, enter VAT Summary in the Frame Caption field to rename

the frame.
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3. In the List Caption field, enter VAT Summary to rename the list box that is
displayed on the Invoice Details frame (listing the VAT rates entered on the
VAT Summary frame).

4. In the Frame Help Text list box, enter the following text. (Press Enter at the end
of each line of text below.)
This frame contains VAT summary information. All of the
fields on this frame are �display-only. You may view the
values in these fields, but you cannot change any of the
values. All calculations will be updated �when you click
the Recalculate button on the Invoice Details frame.

5. In the Listbox Help Text list box, enter the following text. (Press Enter at the
end of each line of text below.)
This list box contains VAT summary �information. To view
details about a VAT �rate listed in the VAT Summary list box,
click that VAT rate and click Open. You �will be able to view
the values in these fields, but you will not be able to change
any of them. All calculations will be �updated when you click
the Recalculate button on the Invoice Details frame.

6. Click OK to exit the EDI Segment Properties dialog.

Customizing the STL SEQA:7 Element
The STL SEQA:7 element (First Level Sequence Number) contains the sequence
number for the STL segment. This element is mandatory, but your screen entry
translation object users will not need to enter a value in this field (the value will be
assigned in the extended rule you add later in this tutorial in the INVOIC file).
Therefore, you will prevent this field from being displayed in the screen entry
translation object, since users will not need to enter a value in this field.

About this task

Use this procedure to hide the First Level Sequence Number field.

Procedure
1. Double-click the STL SEQA:7 element.
2. On the Display tab, select Hidden to prevent the field from being displayed.
3. Click OK to exit the dialog.

Customizing the STL CD12:2 Element
The STL CD12:2 element (VAT Rate Category Code) contains the VAT rate category
as listed in Code Values List 12. You will create a list box definition for this
element to include the VAT rate category code in the VAT Summary list box on the
Invoice Details frame. You will make this field display-only, as the screen entry
translation object users who use this invoice translation object should be able to
view, but not change, the value in this field. (The values in this field will be
assigned in the extended rule you add later in this tutorial in the INVOIC file.)
Also, you will rename the field label.

About this task

Use this procedure to rename the field label, make this field display-only, and
create the list box definition for the VAT Rate Category Code field.
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Procedure
1. Double-click the STL CD12:2 element.
2. On the Display tab, do the following:

v Select Display to make this field display-only.
v In the Label field, enter VAT Code to replace the existing text.

3. On the Summary List tab, do the following:
v Select Display this field in summary list. The value in the VAT Code field

will be displayed in a column in the VAT Summary list box.
v In the Column Width field, enter 4 to set the width of this column in the

VAT Summary list box.
v From the Sequence drop-down list box, select 1 to indicate that this field will

be the first column in the list box.
4. Click OK to exit the dialog.

Customizing the STL VATP:2 Element
The STL VATP:2 element (VAT Rate Percentage) contains the percentage rate for
the VAT category code (in the STL CD12:2 element). The EDI data will be
formatted in N3 format (formatted with an implicit decimal point and three
decimal places), but you want the VAT rate percentage to be displayed in the
translation object in R3 format (formatted with an explicit decimal point).
Therefore, you will change the screen format to reflect how you want the amount
to be formatted in the translation object.

About this task

You will create a list box definition for this element to include the VAT rate
percentage in the VAT Summary list box on the Invoice Details frame. You will
make this field display-only, as the screen entry translation object users who use
this invoice translation object should be able to view, but not change, the value in
this field. Also, you will rename the field label.

Use this procedure to change the screen format, make the field display-only,
rename the field label, and create the list box definition for the VAT Rate
Percentage field.

Procedure
1. Double-click the STL VATP:2 element.
2. From the Form Format drop-down list box, select R3 to indicate that this field

will display a number with an explicit decimal point and up to three decimal
places.

3. On the Display tab, do the following:
v Select Displayed but not editable to make this field display-only.
v In the Label field, enter VAT Rate to replace the existing text.

4. On the Summary List tab, do the following:
v Select Display this field in summary list. The value in the VAT Rate field

will be displayed in a column in the VAT Summary list box on the Invoice
Details frame.

v In the Column Width field, enter 9 to set the width of this column in the
VAT Summary list box.

v From the Sequence drop-down list box, select 2 to indicate that this field will
be the second column in the list box.
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5. Click OK to exit the dialog.

Customizing the STL NRIL Element
The STL NRIL element (Number of Item Lines) contains the number of ILD
segments with the VAT category code specified in the STL CD12:2 element. You
will make this field display-only, as the screen entry translation object users who
use this invoice translation object should be able to view, but not change, the value
in this field. Also, you will rename the field label.

About this task

Use this procedure to make the field display-only and rename the field label for
the Number of Item Lines field.

Procedure
1. Double-click the STL NRIL element.
2. On the Display tab, do the following:

v Select Displayed but not editable to make this field display-only.
v In the Label field, enter Number of Line Items to replace the existing text.

3. Click OK to exit the dialog.

Customizing the STL LVLA Element
The STL LVLA element (Lines Sub-Total (Excluding VAT)) contains the subtotal for
this line item, before VAT has been applied. The value in this field equals the total
of the extended line cost (in the ILD:2 LEXC element) for line items with this VAT
category code. The EDI data will be formatted in N2 format (formatted with an
implicit decimal point and two decimal places), but you want the lines subtotal
(excluding VAT) to be displayed in the translation object in R2 format (formatted
with an explicit decimal point). Therefore, you will change the screen format to
reflect how you want the amount to be formatted in the translation object.

About this task

You will create a list box definition for this element to include the lines subtotal
(excluding VAT) in the VAT Summary list box on the Invoice Details frame. You
will make this field display-only, as the screen entry translation object users who
use this invoice translation object should be able to view, but not change, the value
in this field. Also, you will rename the field label.

Use this procedure to change the screen format, make the field display-only,
rename the field label, and create the list box definition for the Lines Sub-Total
(Excluding VAT) field:

Procedure
1. Double-click the STL LVLA element.
2. On the Validation tab, select R2 from the Form Format drop-down list box to

indicate that this field will display a number with an explicit decimal point and
up to two decimal places.

3. On the Display tab, do the following:
v Select Displayed but not editable to make this field display-only.
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v In the Label field, enter Lines Subtotal (Excluding VAT) to replace the
existing text. (Making these slight changes to the field label maintains the
consistency of labelling in this form.)

4. On the Summary List tab, do the following:
v Select Display this field in summary list. The value in the Lines Subtotal

(Excluding Vat) field will be displayed in a column in the VAT Summary list
box on the Invoice Details frame.

v In the Column Width field, enter 12 to set the width of this column in the
VAT Summary list box.

v From the Sequence drop-down list box, select 3 to indicate that this field will
be the third column in the list box.

5. Click OK to exit the dialog.

Customizing the STL EVLA Element
The STL EVLA element (Extended Sub-Total Amount (Excluding VAT)) contains
the extended subtotal before the VAT has been applied. In this tutorial, the value in
the STL EVLA element equals the value in the STL LVLA element (because we are
not using settlement discounts in this tutorial). For this reason, you do not need to
display the STL EVLA element (the STL LVLA element will be displayed).
Therefore, you will prevent this field from being displayed in the screen entry
translation object, since users will not need to enter or view a value in this field
(the value will be assigned in the extended rule you add later in this tutorial in the
INVOIC file).

About this task

Use this procedure to hide the Extended Sub-Total Amount (Excluding VAT) field.

Procedure
1. Double-click the STL EVLA element.
2. On the Display tab, select Hidden to prevent the field from being displayed
3. Click OK to exit the dialog.

Customizing the STL ASDA Element
The STL ASDA element (Extended Sub-Total Amount (After Settlement Discount
Has Been Applied) contains the extended subtotal amount before VAT has been
applied. In this tutorial, the value in the STL ASDA element equals the value in the
STL EVLA element (which is equal to the STL LVLA element), because we are not
using settlement discounts in this tutorial. For this reason, you do not need to
display the STL ASDA element (the STL LVLA element will be displayed).
Therefore, you will prevent this field from being displayed in the screen entry
translation object, since users will not need to enter or view a value in this field
(the value will be assigned in the extended rule you add later in this tutorial in the
INVOIC file).

About this task

Use this procedure to hide the Extended Sub-Total Amount (After Settlement
Discount Has Been Applied) field.
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Procedure
1. Double-click the STL ASDA element.
2. On the Display tab, select Hidden to prevent the field from being displayed
3. Click OK to exit the dialog.

Customizing the STL VATA Element
The STL VATA element (VAT Amount Payable) contains the VAT amount at the
quoted VAT rate. The EDI data will be formatted in N2 format (formatted with an
implicit decimal point and two decimal places), but you want the VAT amount
payable to be displayed in the translation object in R2 format (formatted with an
explicit decimal point). Therefore, you will change the screen format to reflect how
you want the amount to be formatted in the translation object. In addition, you
will make this field display-only, as the screen entry translation object users who
use this invoice translation object should be able to view, but not change, the value
in this field. Also, you will rename the field label.

About this task

Use this procedure to change the screen format, make the field display-only, and
rename the field label for the VAT Amount Payable field.

Procedure
1. Double-click the STL VATA element.
2. From the Form Format drop-down list box, select R2 to indicate that this field

will display a number with an explicit decimal point and up to two decimal
places.

3. On the Display tab, do the following:
v Select Display to make this field display-only.
v In the Label field, enter VAT Amount Payable to replace the existing text.

Making these slight changes to the field label maintains the consistency of
labelling in this form.

4. Click OK to exit the dialog.

Customizing the STL APSI Element
The STL APSI element (Payable Sub-Total Amount Including Settlement Discount)
contains the amount after VAT has been applied. The value in this element equals
the sum of the values in the STL ASDA and STL VATA elements. The EDI data will
be formatted in N2 format (formatted with an implicit decimal point and three
decimal places), but you want the VAT amount payable to be displayed in the
translation object in R2 format (formatted with an explicit decimal point).
Therefore, you will change the screen format to reflect how you want the amount
to be formatted in the translation object. In addition, you will make this field
display-only, as the screen entry translation object users who use this invoice
translation object should be able to view, but not change, the value in this field.
Also, you will rename the field label.

About this task

Use this procedure to change the screen format, make the field display-only, and
rename the field label for the Payable Sub-Total Amount Including Settlement
Discount field.
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Procedure
1. Double-click the STL APSI element.
2. On the Validation tab, select R2 from the Form Format drop-down list box to

indicate that this field will display a number with an explicit decimal point and
up to two decimal places.

3. On the Display tab, do the following:
v Select Display to make this field display-only.
v In the Label field, enter Payable Subtotal (Inc. Sett. Disc.) to replace the

existing text
4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display.

The TLR Segment

Customizing the TLR NSTL Element
About this task

The TLR segment (Invoice Trailer) contains the total invoice amounts. All monetary
values in this segment are in pounds. You will use an extended rule to perform the
calculations that will be displayed in the fields in the TLR segment. Screen entry
translation object users will be able to view the values in these fields (on the
Invoice Details frame), but will not be able to change the values. See The VAT
Summary and the Invoice Trailer for details on how to add the appropriate
extended rule.

The TLR NSTL element (Number of Total Segments) contains the number of STL
segments in the invoice. You do not need to display the this element, as the screen
entry translation object users will not need to enter or view a value in this field.

Use this procedure to hide the Number of Total Segments field.

Procedure
1. Double-click the TLR NSTL element.
2. On the Display tab, select Hidden to prevent the field from being displayed
3. Click OK to exit the dialog.

Customizing the TLR LVLT Element
The TLR LVLT element (Lines Total Amount (Excluding VAT)) contains the sum of
the STL LVLA elements in the preceding STL segments (before VAT is applied).
The EDI data will be formatted in N2 format (formatted with an implicit decimal
point and two decimal places), but you want the total amount (excluding VAT) to
be displayed in the translation object in R2 format (formatted with an explicit
decimal point). Therefore, you will change the screen format to reflect how you
want the amount to be formatted in the translation object. In addition, you will
make this field display-only, as the screen entry translation object users who use
this invoice translation object should be able to view, but not change, the value in
this field. Also, you will rename the field label.

About this task

Use this procedure to change the screen format, make the field display-only, and
rename the field label for the Lines Total Amount (Excluding VAT) field.
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Procedure
1. Double-click the TLR LVLT element.
2. On the Validation tab, select R2 from the Form Format drop-down list box to

indicate that this field will display a number with an explicit decimal point and
up to two decimal places.

3. On the Display tab, do the following:
v Select Display to make this field display-only.
v In the Label field, enter Invoice Amount (Excluding VAT) to replace the

existing text
4. Click OK to exit the dialog.

Customizing the TLR EVLT Element
The TLR EVLT element (Total Extended Amount Ex Settlement Discount) contains
the sum of the STL EVLA elements in the preceding STL segments (before VAT is
applied). The EDI data will be formatted in N2 format (formatted with an implicit
decimal point and two decimal places), but you want the total amount (excluding
settlement discount and VAT) to be displayed in the translation object in R2 format
(formatted with an explicit decimal point). Therefore, you will change the screen
format to reflect how you want the amount to be formatted in the translation
object. In addition, you will make this field display-only, as the screen entry
translation object users who use this invoice translation object should be able to
view, but not change, the value in this field. Also, you will rename the field label.

About this task

Use this procedure to change the screen format, make the field display-only, and
rename the field label for the Total Extended Amount Ex Settlement Discount field.

Procedure
1. Double-click the TLR EVLT element.
2. On the Validation tab, select R2 from the Form Format drop-down list box to

indicate that this field will display a number with an explicit decimal point and
up to two decimal places.

3. On the Display tab, do the following:
v Select Display to make this field display-only.
v In the Label field, enter Invoice Amount (Ex. Settlement Disc.) to replace the

existing text
4. Click OK to exit the dialog.

Customizing the TLR ASDT Element
The TLR ASDT element (Total Amount Exc VAT Inc Sett) contains the sum of the
STL ASDA elements in the preceding STL segments (before VAT is applied). The
EDI data will be formatted in N2 format (formatted with an implicit decimal point
and two decimal places), but you want the total amount (excluding settlement
discount and VAT) to be displayed in the translation object in R2 format (formatted
with an explicit decimal point). Therefore, you will change the screen format to
reflect how you want the amount to be formatted in the translation object. In
addition, you will make this field display-only, as the screen entry translation
object users who use this invoice translation object should be able to view, but not
change, the value in this field. Also, you will rename the field label.
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About this task

Use this procedure to change the screen format, make the field display-only, and
rename the field label for the Total Amount Exc VAT Inc Sett field.

Procedure
1. Double-click the TLR ASDT element.
2. On the Validation tab, select R2 from the Form Format drop-down list box to

indicate that this field will display a number with an explicit decimal point and
up to two decimal places.

3. On the Display tab, do the following:
v Select Display to make this field display-only.
v In the Label field, enter Invoice Amount (Ex. VAT Inc. Sett.) to replace the

existing text
4. Click OK to exit the dialog.

Customizing the TLR TVAT Element
The TLR TVAT element (Total VAT Amount Payable) contains the sum of the STL
VATA elements in the preceding STL segments. The EDI data will be formatted in
N2 format (formatted with an implicit decimal point and two decimal places), but
you want the total amount to be displayed in the translation object in R2 format
(formatted with an explicit decimal point). Therefore, you will change the screen
format to reflect how you want the amount to be formatted in the translation
object. In addition, you will make this field display-only, as the screen entry
translation object users who use this invoice translation object should be able to
view, but not change, the value in this field. Also, you will rename the field label.

About this task

Use this procedure to change the screen format, make the field display-only, and
rename the field label for the Total VAT Amount Payable field.

Procedure
1. Double-click the TLR TVAT element.
2. On the Validation tab, select R2 from the Form Format drop-down list box to

indicate that this field will display a number with an explicit decimal point and
up to two decimal places.

3. On the Display tab, do the following:
v Select Display to make this field display-only.
v In the Label field, enter VAT Total to replace the existing text

4. Click OK to exit the dialog.

Customizing the TLR TPSI Element
The TLR TPSI element (Total Payable Inc. Settlement) contains the sum of the STL
APSI elements in the preceding STL segments. The EDI data will be formatted in
N2 format (formatted with an implicit decimal point and two decimal places), but
you want the total amount to be displayed in the translation object in R2 format
(formatted with an explicit decimal point). Therefore, you will change the screen
format to reflect how you want the amount to be formatted in the translation
object. In addition, you will make this field display-only, as the screen entry
translation object users who use this invoice translation object should be able to
view, but not change, the value in this field. Also, you will rename the field label.
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About this task

Use this procedure to change the screen format, make the field display-only, and
rename the field label for the Total Payable Inc. Settlement field.

Procedure
1. Double-click the TLR TPSI element.
2. From the Screen Format drop-down list box, select R2 to indicate that this field

will display a number with an explicit decimal point and up to two decimal
places.

3. On the Display tab, do the following:
v Select Display to make this field display-only.
v In the Label field, enter Total Invoice Amount (Inc. Sett. Disc.) to replace

the existing text
4. Click OK to exit the dialog.
5. Click Generate Layout on the Main Toolbar to refresh the display.

Results

The section of the Invoice Details frame that contains the fields in the TLR segment
now should look like this:

The VAT Summary and the Invoice Trailer
Now that you have customized the individual elements in the invoice, one last
customizing task remains: to produce the VAT summary and invoice trailer. The
VAT summary and invoice trailer calculations include calculating the totals for the
invoice for each of the different VAT rates and grouping the totals by VAT rate. To
produce the VAT summary calculations for the invoice, you will use an extended
rule to define operations with the Sterling Gentran:Server proprietary
programming language.
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There are two sections for extended rules: a declarations section and a statements
section. The declarations section is used to declare the names and types of any
variables you will use. The statements section is where you define the operations
that you want the rule to execute. Within the statements section, you can leave
blank lines to visually separate portions of an extended rule. (Blank lines are used
more often in complex extended rules, rather than in simple one- or two-line
extended rules.) Leaving a blank line does not affect the execution of extended
rules.

As you define the operations for the VAT summary calculations, you will enter
many lines of rules in the Loop Level Extended Rules dialog. This section describes
each of the individual operations that you will define, and explains what you
should enter in order to execute each operation.

Note: As an alternative to entered the extended rule yourself, you may copy the
extended rule from the example form provided with the tutorial data in the
C:\GENSRVNT\TUTORIALS subfolder.

You will define the VAT summary and invoice trailer calculations on the INVOIC
group so that the calculations are run when the screen entry translation object
users in Sterling Gentran:Server either calculates or saves the file. After Sterling
Gentran:Server stores the data in the fields, the system will run the calculations
and store them in the appropriate VAT summary and invoice trailer fields. The
extended rule will be used with the On Store function so the system will perform
the calculations last, after the group is stored.

Defining the Operations for the VAT Summary
About this task

Use this procedure to access the Loop Level Extended Rules dialog to define the
operations for the VAT summary calculations.

Procedure
1. Right-click the INVOIC EDI file icon and select Extended Rules.
2. Select On Store to indicate that you want the rule to be executed when you

save or recalculate the screen entry translation object. When the screen entry
users save or recalculate the Invoice Details frame in Sterling Gentran:Server,
all On Store extended rules in the Loop Level Extended Rules dialog will be
executed.

Declaring Variables
Before you begin defining any operations in the statements section of the extended
rule, you must first define the variables that you will use in the extended rule.
Variables consist of a name and a data type, and are used to store values.

About this task

For this extended rule, you will use these four variables (all of which have a data
type of integer).
v i (temporary variable assigned any value you define in the extended rule)
v j (another temporary variable assigned any value you define in the extended

rule)
v ildlimit (temporary variable that contains the number of ILD segments)
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v stllimit (temporary variable that contains the number of STL segments)

Use this procedure to declare the four integer variables listed above.

Procedure
1. On the first line in the Editor list box, enter the following declaration:

integer i,j,ildlimit,stllimit;

2. Press Enter twice to insert a blank line after the declarations section.

Note: It is not necessary to include a blank line after the declaration and
statement sections. However, doing so may improve readability of the extended
rule.

What to do next

You are now ready to define the statements section of the extended rule.

Counting the STL Segments and Deleting them
The STL segment is a repeating segment, so there is one STL segment for each VAT
code used in the invoice. You want Sterling Gentran:Server to count the STL
segments used in the invoice (the value from counting the STL segments will be
placed in variable "i"). Next, you want the system to visit each STL segment and
delete the segment. The reason you want the system to delete the STL segments is
that the system makes the assumption that the form has been modified and,
therefore, deletes the STL segments to reset the form before performing any
calculations relating to the STL segments. Finally, you want the system to initialize
the value of the last STL segment to zero.

About this task

Use this procedure to define a statement that counts the STL segments and deletes
them, then initializes the value of the last STL to zero.

Procedure
1. On the next line in the Editor list box, enter the following statement:

i=count($STL[*]);�
while i > 0 do�
begin�

delete($STL[i]);�
i=i-1;�

end�
stllimit = 0;

2. Press Enter twice to insert a blank line after the statement.

Counting the ILD Groups
The ILD group is a repeating group, so there is one ILD group for each line item in
the invoice. You want Sterling Gentran:Server to count the ILD groups used in the
invoice (the value from counting the ILD groups will be placed in variable
"ildlimit").

About this task

Use this procedure to define a statement that counts the ILD groups.
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Procedure
1. On the next line in the Editor list box, enter the following statement:

ildlimit = count($ILD[1][*]);

2. Press Enter twice to insert a blank line after the statement.

Compatible VAT Codes in the STL Segments
Now that Sterling Gentran:Server has counted (and deleted) the STL segments and
counted the ILD groups in the invoice, you want the system to determine which
VAT code is used for each line item (each instance of the ILD group). Next, you
want to group the line items that use the same VAT code so you can determine the
VAT rate percentage (based on each VAT code) and then calculate the total VAT
payable for each group of line items.

If the system finds a VAT code that is the same in both an ILD group and an STL
segment (compatible VAT codes), then you want the system to execute the
following operations:
v Add the extended line cost (ILD:2 LEXC element) into the lines subtotal (ILD:2

LVLA element) to add the line item from the ILD group to the compatible STL
segment

v Increment a counter in the STL segment of how many of the existing ILD
segments are compatible with that STL segment

If the system does not find an STL segment with the same VAT code as the ILD
group it is visiting, then it executes the following operations:
v Creates an STL segment with the VAT code of the current ILD group
v Sets the number of STL segments (STL SEQA:7 element) to be the number of the

last STL segment (the current segment, which was just created)
v Sets the VAT rate percentage of the STL segment (STL VATP:2 element) to equal

the VAT rate percentage of the ILD group (ILD:2 VATP element)
v Sets the VAT code of the STL segment (STL CD12:2 element) to equal the VAT

code of the ILD group (ILD:2 CD12 element)
v Sets the lines subtotal of the STL segment (STL LVLA element) to be the

extended line cost of the ILD group (ILD:2 LEXC element)
v Sets the number of line items to be "1" (STL NRIL element)
v Sets the number of STL segments to be the number of the current STL segment

(which was just created)

Finally, you want the system to repeat the process described above (finding
compatible VAT codes in the STL segments and ILD segments) until it has no more
ILD groups to count (each line item has been assessed).

Grouping Line Items
About this task

Use this procedure to define a statement that groups line items with the same VAT
code.

Procedure
1. On the next line in the Editor list box, enter the following statement:

i=1;�
while i <= ildlimit do�
begin�

196 IBM Sterling Gentran:Server for Windows: Forms Integration Tutorial for Screen Entry Forms



j=1;
while j <= stllimit do�
begin�

if $ILD[1][i].#CD12 = $STL[j].#CD12:2 then�
begin�

$STL[j].#LVLA = $STL[j].#LVLA + $ILD[1][i].#LEXC;
$STL[j].#NRIL = $STL[j].#NRIL + 1;�
break;�

end�
j=j+1;�

end�
if j > stllimit then�
begin�

$STL[j].#SEQA:7 = j;�
$STL[j].#VATP:2 = $ILD[1][i].#VATP;�
$STL[j].#CD12:2 = $ILD[1][i].#CD12;�
$STL[j].#LVLA = $ILD[1][i].#LEXC;�
$STL[j].#NRIL = 1;�
stllimit = stllimit + 1;�

end�
i=i+1;�

end

2. Press Enter twice to insert a blank line after the statement.

Note: It is not necessary to include a blank line after this statement. However,
doing so may improve readability of the extended rule.

How to Calculate the VAT Amount and Produce the Invoice
Trailer

Up to this point, the extended rule you have defined instructs Sterling
Gentran:Server to calculate the totals for the invoice for each of the different VAT
rates. Now you will define a rule that calculates the total VAT amount and
produces the invoice trailer.

First, the system will initialize the lines total amount (TLR LVLT element) and the
total VAT amount payable (TLR TVAT element) to zero. Next, the system will
perform the following calculations for every STL segment:
v Set the VAT amount payable (STL VATA element) equal to the product of the

lines subtotal (STL LVLA element) and the VAT rate percentage (STL VATP:2
element), divided by one hundred (to calculate the VAT payable).

v Set the extended subtotal amount (STL EVLA element) equal to the lines subtotal
(STL LVLA element), because you are not using settlement discounts in this
tutorial.

v Set the extended subtotal amount (STL ASDA element) equal to the lines
subtotal (STL LVLA element), because you are not using settlement discounts in
this tutorial.

v Set the payable subtotal amount (STL APSI element) equal to the sum of the
lines subtotal (STL LVLA element) and the VAT amount payable (STL VATA
element).

v Set the lines total amount (TLR LVLT element) equal to the sum of the lines total
amount (TLR LVLT element) and the extended subtotal amount (STL EVLA
element).

v Set the total VAT amount payable (TLR TVAT element) equal to the sum of the
total VAT amount payable (TLR VATA element) and the VAT amount payable
(STL VATA element).
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Finally, you want the system to repeat the calculations described above until all
STL segments have been processed.

Grouping Invoice Totals
About this task

Use this procedure to define a statement that groups the invoice totals by VAT rate.

Procedure
1. On the next line in the Editor list box, enter the following statement:

#LVLT = 0;�
#TVAT = 0;�
j=1;�
while j <= stllimit do�
begin�

$STL[j].#VATA = ($STL[j].#LVLA * $STL[j].#VATP:2) / 100.0;�
$STL[j].#EVLA = $STL[j].#LVLA;
$STL[j].#ASDA = $STL[j].#LVLA;�
$STL[j].#APSI = $STL[j].#LVLA + $STL[j].#VATA;�

� #LVLT = #LVLT + $STL[j].#LVLA;�
#TVAT = #TVAT + $STL[j].#VATA;�

� j=j+1;�
end

2. Press Enter twice to insert one blank line after the statement.

Note: It is not necessary to include a blank line after this statement. However,
doing so may improve readability of the extended rule.

Trailer Calculations
The final operation that Sterling Gentran:Server will execute when processing the
extended rule is to calculate the line value total and VAT. You want the system to
perform these calculations:
v Set the number of total segments (TLR NSTL element) equal to the count of STL

segments.
v Set the total extended amount (TLR EVLT element) equal to the lines total

amount (TLR LVLT element).
v Set the total amount (TLR ASDT element) equal to the lines total amount (TLR

LVLT element).
v Set the total amount payable (TLR TPSI element) equal to the sum of the lines

total amount (TLR LVLT element) and the total VAT amount payable (TLR TVAT
element).

To calculate the line value total and VAT, on the next line in the Editor list box,
enter the following statement:
#NSTL = stllimit;�
#EVLT = #LVLT;�
#ASDT = #LVLT;�
#TPSI = #LVLT + #TVAT;

Extended Rule for the INVOIC Group
Now that you have entered the entire extended rule that will be processed for the
INVOIC group, your extended rule should look like this:
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integer i,j,ildlimit,stllimit;

i=count($STL[*]);
while i > 0 do�
begin�

delete($STL[i]);�
i=i-1;�

end�
stllimit = 0;�

ildlimit = count($ILD[1][*]);�

i=1;�
while i <= ildlimit do�
begin�

j=1;�
while j <= stllimit do�
begin�

if $ILD[1][i].#CD12 = $STL[j].#CD12:2 then�
begin�

$STL[j].#LVLA = $STL[j].#LVLA + $ILD[1][i].#LEXC;�
$STL[j].#NRIL = $STL[j].#NRIL + 1;�
break;�

end�
j=j+1;�

end�
if j > stllimit then�
begin�

$STL[j].#SEQA:7 = j;�
$STL[j].#VATP:2 = $ILD[1][i].#VATP;�
$STL[j].#CD12:2 = $ILD[1][i].#CD12;�
$STL[j].#LVLA = $ILD[1][i].#LEXC;�
$STL[j].#NRIL = 1;�
stllimit = stllimit + 1;�

end�
i=i+1;�

end

#LVLT = #TVAT = 0;�
j=1;�
while j <= stllimit do�
begin�

$STL[j].#VATA = ($STL[j].#LVLA * $STL[j].#VATP:2) / 100.0;�
$STL[j].#EVLA = $STL[j].#LVLA;�
$STL[j].#ASDA = $STL[j].#LVLA;�
$STL[j].#APSI = $STL[j].#LVLA + $STL[j].#VATA;

�� #LVLT = #LVLT + $STL[j].#LVLA;�
#TVAT = #TVAT + $STL[j].#VATA;�

� j=j+1;�
end��

#NSTL = stllimit;�
#EVLT = #LVLT;�
#ASDT = #LVLT;�
#TPSI = #LVLT + #TVAT;

Compiling the Extended Rule
Now that you have entered the extended rule to perform all the INVOIC
group-level calculations for the invoice, you should compile the extended rule to
verify that you have entered the rule correctly.
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About this task

Use this procedure to compile the extended rule.

Procedure
1. Click Compile to compile the extended rule.

Note: If you receive any errors or warnings when you compile the rule, verify
that you entered the rule exactly as it is written in this tutorial. After you make
any changes to the extended rule to correct it, click Compile again. Repeat this
process until there are no errors generated.

2. Click OK to add the extended rule to the form and exit the Loop Level
Extended Rules dialog.

3. Save the form.
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Chapter 11. Customizing Screen Entry Forms for
TRADACOMS

Resizing the Invoice Frame
When a form is compiled into a translation object, the fields are arranged
according to how the frames and the fields contained on them were arranged
when the form was compiled. You should eliminate unnecessary space as you
arrange the fields on each frame.

About this task

Important: When you resize the frames of a screen entry form, you must resize
based on the resolution of the target monitor (for example, the monitor on which
the end user views the translation object).

Use this procedure to resize the Invoice frame.

Procedure
1. Click the invoice file icon to display the Invoice frame in the Layout Window.

Note: When the form is generated, the upper left corner of each frame in the
form is placed in the upper left corner of the Layout Window.

2. To display more of the form on your screen, click and drag the center bar
between the EDI File Format Window and the Layout Window to the left until
the Layout Window is wide enough to display as much of the form as you
want to view.

3. To resize the Invoice frame, click and drag the right side of the frame
approximately to the 14 cm. mark on the horizontal ruler so that the form is
wide enough to format the fields according to the instructions in this tutorial.

Fields on the Invoice Frame
You begin formatting the screen entry form by arranging the fields on the Invoice
frame. You place the fields in the translation object in a logical order, then align the
fields to give the frame a consistent and orderly appearance.

By default, each field and its associated label are displayed on their own line.
However, it is common for invoices to place two or more fields on a line.

You prevented some of the field labels from being displayed (by removing the field
label in the Label field of the Display dialog). For these fields, the fields are
displayed on your screen entry form, but their associated labels are not displayed.
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ANSI X12

The Invoice frame now should look like this:

EDIFACT

The Invoice Message frame now should look like this:
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TRADACOMS

The Invoice Details frame now should look like this:

Arranging Fields

Rearranging the Fields
About this task

Use this procedure to resize, move, and align the fields on the Invoice Details
frame of the screen entry form:

Procedure
1. Select the following fields and select Display > Size to Length.

v Location Own Code
v Name
v Invoice Date
v Tax-point Date
v P.O. Date
v Delivery Date
The selected fields are resized to the lengths specified in the Maximum
number of characters box of the Display dialog for each field.

2. Select each field in the form individually and drag it closer to its respective
label.

3. Select all of the items (fields, field labels, list boxes) on the frame and drag
them a few centimetres lower on the frame. You will be arranging the fields at
the top of the frame, so moving the fields and field labels out of the way
initially will give you room to work with at the top of the frame.
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4. Click Lock Labels on the Main Toolbar to turn on the Lock Labels function.
When you select a field, its corresponding field label will be selected also.

5. Drag the Invoice No. label and field to the upper left corner of the Invoice
Details frame. (Their field labels will be selected, too, because you have the
Lock Labels function turned on.)

6. Drag the Invoice Date label and field to the upper right corner of the Invoice
Details frame (at approximately 8 cm on the horizontal ruler).

7. Drag the Tax-point Date label and field under the Invoice Date label and
field.

8. Drag the Customer’s P.O. No. label and field under the Invoice No. label and
field (but not on the same line as the Tax-point Date label and field).

9. Drag the P.O. Date label and field below the Tax-point Date label and field.
10. Drag the Delivery Note Number label and field below the Customer’s P.O.

No. label and field.
11. Drag the Delivery Date label and field below the P.O. Date label and field.
12. Drag the Location ANA Code label and field below the Delivery Note

Number label and field (and indented about half a centimetre).

Note: You will add static text later in this tutorial to label all the fields
providing customer details. Therefore, leave extra space between the Delivery
Note Number and Delivery Date labels and fields, and the Location ANA
Code and Location Own Code labels and fields, to insert the static text
between them.

13. Drag the Location Own Code label and field to the right of the Location ANA
Code label and field (at approximately 7 cm on the horizontal ruler).

14. Select the following fields and labels and drag them below the Location ANA
Code label and field:
v Name
v Address Line 1
v Address Line 2
v Address Line 3
v Address Line 4
v Post Code

15. Drag the Payment Terms label and field below the Post Code field. (The left
margin of the Payment Terms label should be aligned with the left margin of
the Delivery Note Number label.)

Note: Leave extra space between the Post Code field and label, and the
Payment Terms field and label, to designate the end of the Customer Details
section.

16. Drag the Invoice Notes label and fields (there are four fields, three of which
are unlabeled) below the Payment Terms label and field.

17. Drag the Line Items label and list box below the fourth Invoice Notes field
(the second, third, and fourth Invoice Notes fields are unlabeled).

Note: Leave extra space above the Line Items field and list box to add column
headings (using static text) to label the data in the list box.

18. Drag the right or left handle on the Line Items list box until the list box is
approximately 11.25 cm wide. The list box must be at least 11.25 cm wide to
be able to display all of the summary list data.

204 IBM Sterling Gentran:Server for Windows: Forms Integration Tutorial for Screen Entry Forms



19. Drag the VAT Summary label and list box below the Line Items label and list
box.

Note: Leave extra space above the VAT Summary field and list box to add
column headings (using static text) to label the data in the list box.

20. Drag the right or left handle on the VAT Summary list box until the list box is
approximately 4.5 cm wide. The list box must be approximately 4.5 cm wide
to display all of the summary list data appropriately.

21. Select the following fields and labels and drag them below the VAT Summary
list box (so the fields and labels are approximately centred horizontally on the
frame):
v Invoice Amount (Excluding VAT)
v Invoice Amount (Ex. Settlement Disc.)
v Invoice Amount (Ex. VAT Inc. VAT)
v VAT Total
v Total Invoice Amount (Inc. Sett. Disc.)

22. Click Lock Labels on the Main Toolbar to turn off the Lock Labels function.

Aligning the Fields and Labels
Now that the fields in the Invoice Details frame are resized and moved to their
proper locations, you can align the fields and labels.

About this task

Use this procedure to align the fields and field labels on the Invoice Details frame.

Procedure
1. Select the following labels and select Display > Align Controls > Left.

v Invoice No.
v Customer’s P.O. No.
v Delivery Note Number
v Payment Terms
v Invoice Notes
v Line Items
v VAT Summary
The left margins of the selected field labels are aligned.

2. Select the following labels and select Display > Align Controls > Left.
v Invoice Date
v Tax-point Date
v P.O. Date
v Delivery Date

3. Select the following labels and select Display > Align Controls > Left.
v Location ANA Code
v Name
v Address Line 1
v Address Line 2
v Address Line 3
v Address Line 4
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v Post Code
4. Select the following labels and select Display > Align Controls > Left.

v Invoice Amount (Excluding VAT)
v Invoice Amount (Ex. Settlement Disc.)
v Invoice Amount (Ex. VAT Inc. Sett.)
v VAT Total
v Total Invoice Amount (Inc. Sett. Disc.)

5. Select the following fields and select Display > Align Controls > Left.
v Invoice No.
v Customer’s P.O. No.
v Delivery Note Number
v Name
v Address Line 1
v Address Line 2
v Address Line 3
v Address Line 4
v Post Code
v Location ANA Code

Note: Select the Location ANA Code field last so it is the reference. The
reference is the item (field, field label, list box, or static text) relative to which
all other selected items are formatted. The reference is indicated by an outline
of diagonal lines, whereas all other selected items are outlined by a solid line.
The last item selected in a group of selected items is the reference.

6. Select the Line Items and VAT Summary list boxes and select Display > Align
Controls > Left.
Select the VAT Summary field last so it is the reference.

7. Select the following fields and select Display > Align Controls > Left.
v Invoice Date
v Tax-point Date
v P.O. Date
v Delivery Date

Note: Select the Tax-point Date field last so it is the reference.
8. Select the following fields and select Display > Align Controls > Left.

v Payment Terms
v Invoice Notes (all four fields)

Note: Select the Payment Terms field last so it is the reference.
9. Select the following fields and select Display > Align Controls > Left.

v Invoice Amount (Excluding VAT)
v Invoice Amount (Ex. Settlement Disc.)
v Invoice Amount (Ex. VAT Inc. Sett.)
v VAT Total
v Total Invoice Amount (Inc. Sett. Disc.)

Note: Select the Total Invoice Amount (Inc. Sett. Disc.) field last so it is the
reference.
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10. To align the tops of all of the field labels, fields, and list boxes, select each row
of items (one row at a time). Then select Display > Align Controls > Top. The
items in each row are listed below:
v Invoice No. label and field, Invoice Date label and field
v Tax-point Date label and field
v Customer’s P.O. No. label and field, P.O. Date label and field
v Delivery Note Number label and field, Delivery Date label and field
v Location ANA Code label and field, Location Own Code label and field
v Name label and field
v Address Line 1 label and field
v Address Line 2 label and field
v Address Line 3 label and field
v Address Line 4 label and field
v Post Code label and field
v Payment Terms label and field
v Invoice Notes label and field (first Invoice Notes field only)
v Line Items label and list box
v VAT Summary label and list box
v Invoice Amount (Excluding VAT) label and field
v Invoice Amount (Ex. Settlement Disc.) label and field
v Invoice Amount (Ex. VAT Inc. Sett.) label and field
v VAT Total label and field
v Total Invoice Amount (Inc. Sett. Disc.) label and field
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Results

The Invoice Details frame now should look like this:

Adding the Customer Details Label
About this task

You need to add static text (text that is always included in the screen entry
template) to the Invoice Details frame to do the following:
v Label the area of the frame containing customer detail fields
v Add column headings to the Line Items list box
v Add column headings to the VAT Summary list box

When you moved the fields on the frame, you already left space in the appropriate
locations for the static text. In this section of the tutorial, you will add the static
text and move it to the proper locations in the frame.

Use this procedure to add static text that will label the group of customer detail
fields on the frame.

Procedure
1. Click Add Text on the Main Toolbar. Text is added to the current frame,

displayed in the upper left corner of the frame. If the template is larger than
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the frame (there is a scroll bar on the right side of the frame), the static text is
displayed in the upper left corner of the part of the template that is displayed,
not at the top of the template.

2. In the new text field, enter CUSTOMER DETAILS, all in capital letters. The
Text Properties dialog is displayed as you are typing. Click OK to add the text.
The text you added is displayed in the upper left corner of the frame.

3. Select the CUSTOMER DETAILS static text and drag it below the Delivery
Note Number label and field (The left margin of the static text should be
aligned with the left margin of the Delivery Note Number label.).

Adding Column Headings to the Line Items List Box
Sterling Gentran:Server labels the fields on the Line Items frame but does not label
the column headings for the Line Items list box on the Invoice Details frame. The
Line Items list box displays the information entered into the fields on the Line
Items frame. To label the columns in the Line Items list box, you must add the
column headings with static text.

About this task

After you add the column headings and move each column heading to its proper
location, the Line Items list box and the column headings should look like this:

Use this procedure to add and position the column headings.

Procedure
1. Click Add Text on the Main Toolbar. Text is added to the current frame,

displayed in the upper left corner of the frame. If the template is larger than
the frame (there is a scroll bar on the right side of the frame), the static text is
displayed in the upper left corner of the part of the template that is displayed,
not at the top of the template.

2. In the new text box, enter Item and click OK.
3. Click Add Text on the Main Toolbar and enter Product in the text box and

click OK.
4. Click Add Text and enter Qty. in the text box and click OK.
5. Click Add Text and enter Price in the text box and click OK.
6. The column headings you added are displayed in the upper left corner of the

frame.
7. Drag the Item static text to above the Line Items list, starting about 1 cm from

the left margin of the Line Items list.
8. Drag the Product static text to above the Line Items list, to the right of the

Item column heading.
9. Drag the Qty. static text to above the Line Items list, , nearly 8 cm. from the

left margin of the list box.
10. Drag the Price static text to above the Line Items list, near the right margin of

the list box.
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11. To ensure that the column headings (static text) you just added are aligned
properly, select all the static text you just added (Item, Qty., Product, Price).
Select Display > Align Controls > Top.

Adding Column Headings to the VAT Summary List Box
Sterling Gentran:Server labels the fields on the VAT Summary frame, but does not
label the column headings for the VAT Summary list box on the Invoice Details
frame. The VAT Summary list box displays the information entered into the fields
on the Line Items frame. To label the columns in the VAT Summary list box, you
must add the column headings with static text.

About this task

After you add the column headings and move each column heading to its proper
location, the VAT Summary list box and the column headings should look like this:

Use this procedure to add and position the column headings.

Procedure
1. Click Add Text.
2. In the new text field, enter Code. Click OK to add the text.
3. Drag it to above the VAT Summary list box, immediately to the right of the

left margin of the VAT Summary list box (refer to the example above).
4. Click Add Text.
5. In the new text field, enter VAT. Click OK to add the text.
6. Drag it to above the "Code" static text.
7. Click Add Text.
8. In the new text field, enter VAT Rate. Click OK to add the text.
9. Drag it to above the VAT Summary list box, about 1 cm from the left margin

of the list box.
10. Click Add Text.
11. In the new text field, enter Lines Subtotal. Click OK to add the text.
12. Drag it to above the VAT Summary list box, nearly to the right margin of the

list box.
13. To ensure that the column headings (static text) you just added are aligned

properly, select the following static text and select Display > Align Controls >
Top.
v Code
v VAT Rate
v Lines Subtotal

14. Select the VAT and Code static text and select Display > Align Controls >
Left.
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Setting the Tab Sequence on the Invoice Details Frame
The tab sequence is the order in which the cursor moves from field to field in the
screen entry translation object when a user presses Tab. When you create a screen
entry form, the system automatically positions the fields and sets the tab sequence
for those fields. However, you usually will want to modify the tab sequence of the
fields to meet your screen entry requirements and the new positions of the fields
on the frame.

About this task

Note: If you click a field out of sequence, you must begin setting the tab sequence
again. To start over, select Display > Set Tab Order so the tab sequence numbers
are no longer displayed in the fields on the frame. Then begin the steps again.
When you click the last field in the sequence, the tab sequence is set, and the tab
sequence numbers no longer are displayed in the fields.

Use this procedure to set the tab sequence for the fields on the Invoice Details
frame.

Procedure
1. Select Display > Set Tab Order. Numbers are displayed in the fields on the

frame to indicate the current tab sequence.
2. Click the items below in the order in which they are listed. As you click each

field, the tab sequence number for that field will change to the next sequential
number in the tab sequence.
a. Invoice No.
b. Invoice Date
c. Tax-point Date
d. Customer’s P.O. No.
e. P.O. Date
f. Delivery Note Number
g. Delivery Date
h. Location ANA Code
i. Location Own Code
j. Name
k. Address Line 1
l. Address Line 2
m. Address Line 3
n. Address Line 4
o. Post Code
p. Payment Terms
q. Invoice Notes (first field)
r. Invoice Notes (second field, unlabeled)
s. Invoice Notes (third field, unlabeled)
t. Invoice Notes (fourth field, unlabeled)
u. Line Items
v. VAT Summary
w. Invoice Amount (Excluding VAT)
x. Invoice Amount (Ex. Settlement Disc.)
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y. Invoice Amount (Ex. VAT Inc. Sett.)
z. VAT Total
aa. Total Invoice Amount (Inc. Sett. Disc.)

Fields on the Line Item Frame

Fields on the Line Items Frame
Now that the fields, labels, and static text are arranged on the Invoice Details
frame, you are ready to arrange the fields on the Line Items frame. You will place
the fields in a logical order, then align the fields (as you did with the fields on the
Invoice Details frame) to give the frame a consistent and orderly appearance.

When you finish arranging the fields, the Line Items frame in your form should
look like the one in the example below.

Resizing the Line Items Frame and Fields
Before you begin arranging the fields on the Line Items frame, you should resize
the frame so that it is the same width as the Invoice Details frame. When this form
is compiled into a translation object, the fields will be arranged according to how
the frames and the fields contained on them were arranged when the form was
compiled. You should eliminate unnecessary space as you arrange the fields on
each frame.

About this task

Use this procedure to resize the line items frame and fields.

Procedure
1. Click the ILD group to display the Line Items frame in the Layout Window.
2. To resize the Line Items frame, click and drag the right side of the frame to the

14 cm mark on the ruler.
3. To display more of the form on your screen, drag the center bar between the

EDI File Format Window and the Layout Window to the left until the Layout
Window is wide enough to display as much of the form as you want.

4. Select the following fields and select Display > Size to Length.
v Item No.
v Quantity
The selected fields are resized to the lengths specified in the Maximum number
of characters box of the Display dialog for each field.
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Moving and Aligning the Fields
About this task

Use this procedure to move and align the fields on the Line Items frame of the
screen entry form.

Procedure
1. Select the Unit of Measure field and drag its bottom handle so that the field

is long enough for four codes to be displayed in it when the drop-down part
of the drop-down list is open (approximately 2 cm on the vertical ruler).

2. Select the VAT Code and Unit of Measure fields (in that order) and select
Display > Size Equally.

Notes:

v Select the Unit of Measure field last, so that it is the reference.
v The Unit of Measure and VAT Code drop-down list boxes have slightly

different appearances. When Exclusive is selected (in the Advanced section
of the Field Properties dialog), the text box is attached to the drop-down
arrow. When Exclusive is not selected, there is a gap between the text box
and the drop-down arrow.

3. Select each field and list box on the frame individually and move it closer to
its respective label.

4. Click Lock Labels on the Main Toolbar to turn on the Lock Labels function.
When you select a field, its corresponding field label will be selected also.

5. Drag the Item No. label and field to the upper left corner of the frame.
6. Select the EAN Code label and field and drag them to the upper right corner

of the frame.
7. Drag the following fields and labels below the Item No. label and field:

v Supplier’s Product Code
v Customer’s Product Code
v Quantity

8. Drag the Unit of Measure label and list box to the right of the Quantity label
and field.

9. Drag the Unit Price (Ex. VAT) label and field below the Quantity label and
field.

10. Drag the VAT Code label and field under the Unit of Measure label and list
box.

11. Drag the Description label and field below the Unit Price (Ex. VAT) label and
field.

12. Click Lock Labels on the Main Toolbar to turn off the Lock Labels function.

Resizing the Line Items Frame
About this task

Use this procedure to resize the Line Items frame.

Procedure

To resize the Line Items frame, click and drag the bottom of the frame to below the
Description label and field.
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Note: Allow enough space between the Description label and field, and the bottom
of the frame, for the VAT Code drop-down list box to be opened.

Results

The Line Items frame now should look like this:

Aligning the Fields and Field Labels
About this task

Use this procedure to align the fields and field labels on the Line Items frame.

Procedure
1. Select the following labels and select Display > Align Controls > Left.

v Item No.
v Supplier’s Product Code
v Customer’s Product Code
v Quantity
v Unit Price (Ex. VAT)
v Description

Note: The left margins of the selected field labels are aligned.
2. Select the following fields and select Display > Align Controls > Left.

v Item No.
v Supplier’s Product Code
v Quantity
v Unit Price (Ex. VAT)
v Customer’s Product Code

Note: Select the Customer’s Product Code field last so it is the reference.
3. Select the following labels and select Display > Align Controls > Left.

v EAN Code
v Unit of Measure
v VAT Code

4. Select the following items and select Display > Align Controls > Left.

v EAN Code
v Unit of Measure
v VAT Code

Note: Select the Unit of Measure list box last so it is the reference.
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5. Select the Description and EAN Code fields and select Display > Align
Controls > Right.

Note: Select the EAN Code field last so it is the reference.
6. Select each row of items (one row at a time) and select Display > Align

Controls > Top. The items in each row are listed below:
v Item No. label and field and EAN Code label and field
v Supplier’s Product Code label and field
v Customer’s Product Code label and field
v Quantity label and field and Unit of Measure label and drop-down list box
v Unit Price (Ex. VAT) label and field and VAT Code label and drop-down list

box
v Description label and field

Results

The Line Items frame now should look like this:

Setting the Tab Sequence on the Line Items Frame
About this task

Use this procedure to set the tab sequence of the fields on the Line Items frame.

Procedure
1. Select Display > Set Tab Order. Numbers are displayed in the fields on the

frame to indicate the current tab sequence.
2. Click the items below in the order in which they are listed. As you click each

field, the tab sequence number for that field will change to the next sequential
number in the tab sequence you are now setting.
a. EAN Code
b. Supplier’s Product Code
c. Customer’s Product Code
d. Quantity
e. Unit of Measure
f. Unit Price (Ex. VAT)
g. VAT Code
h. Description
i. Item No.

Note: The Item No. field is the last field in the tab sequence, although it is the
first field in the layout of the Line Items frame. This field is display-only,
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displaying the next consecutive line item number (the line item number is
generated by an extended rule in the ILD group). By placing the Item No. field
last in the tab sequence, this field can be skipped easily by users entering data.
The first field in the sequence is the EAN Code field, which is the first field
into which users can enter a value.

Results

The new tab sequence for the Line Items frame should look like this:

When you click the last field in the sequence (Item No.), the tab sequence is set,
and the tab sequence numbers no longer are displayed in the fields.

Fields on the VAT Summary Frame

Resizing the VAT Summary Frame - TRADACOMS
Just as you arranged the fields, labels, and static text on the Invoice Details and
Line Items frames, now you will arrange the items on the VAT Summary frame.
You will place the fields in a logical order, then align the fields to give the frame a
consistent and orderly appearance.

About this task

When you finish arranging the fields, the VAT Summary frame in your form
should look like the one in the example below.

Before you begin arranging the fields on the VAT Summary frame, you should
resize the frame so that it is the same width as the Invoice Details and Line Items
frames. When this form is compiled into a translation object, the fields will be
arranged according to how the frames and the fields contained on them were
arranged when the form was compiled. You should eliminate unnecessary space as
you arrange the fields on each frame.

Procedure
1. Click the STL segment to display the VAT Summary frame in the Layout

Window.
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2. To resize the VAT Summary frame, click and drag the right side of the frame to
the 14 cm mark on the ruler so all the fields on the frame are visible.

3. To display more of the form on your screen, click and drag the centre bar
between the EDI File Format Window and the Layout Window to the left until
the Layout Window is wide enough to display as much of the form as you
want to view.

Results

The VAT Summary frame now should look like this:

Resizing the VAT Code Field
Sterling Gentran:Server bases the lengths of fields on the widths of lowercase
letters. For example, if a field has a display length (defined on the Display
Properties dialog) of five, then Sterling Gentran:Server produces a field with a
length able to accommodate the average width of lowercase letters.

About this task

The VAT Code field will contain a code in an uppercase letter. Therefore, you
should adjust the width of the field to prevent the code in the VAT Code field
from being truncated.

Use this procedure to resize the VAT Code field.

Procedure
1. Select the VAT Code field.
2. Drag its handles so the field is approximately twice as wide as originally.

Moving and Aligning the VAT Summary Fields
About this task

Use this procedure to move and align the fields on the VAT Summary frame of the
screen entry form.
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Procedure
1. Drag the VAT Amount Payable and Payable Subtotal (Inc. Sett. Disc.) fields

and labels closer to the Lines Subtotal (Excluding VAT) field and label.
2. Select all of the fields on the frame.

Note: Select the VAT Amount Payable field last so it is the reference.
3. Select Display > Align Controls > Left . The left margins of the selected field

labels are aligned.
4. Click and drag the bottom of the frame to below the Payable Subtotal (Inc. Sett.

Disc.) label and field.

Results

The VAT Summary frame now should look like this:

You do not need to set the tab sequence for the VAT Summary frame. All the fields
on this frame (other than the hidden fields) are display-only. Screen entry
translation object users will not be able to enter a value in any of the fields, so the
tab sequence is irrelevant.

Changing the Invoice Details Frame Title
The system automatically titles the frames in a screen entry form when the form is
created, based on the name of the file, segment(s), or group(s). You can modify the
frame titles (for example, at the file or message level) to distinguish one form from
the others. The parent frame of the invoice currently is titled Invoice Details. You
will give this frame a more descriptive title to distinguish it from other invoices
that your company uses.

About this task

Use this procedure to change the frame title.

Procedure
1. Right-click the invoice file icon and select Properties.
2. In the Frame Caption field, enter TRADACOMS ANA001 INVOIC Release 9 -

Pet Zone.
3. Click OK.

The new frame title is displayed in the frame title in the Layout Window.
4. Click Generate Layout on the Main Toolbar to refresh the display.
5. Select File > Save.
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Results

When you have finished arranging the fields, your Invoice Details frame should
look like the one in the example below (only part of the frame is shown below).

What to do next

You have completed your Invoice form. Now, you are ready to finalize the form.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

Intellectual Property Licensing

Legal and Intellectual Property Law

IBM Japan Ltd.

19-21, Nihonbashi-Hakozakicho, Chuo-ku

Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
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incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation

J46A/G4

555 Bailey Avenue

San Jose, CA 95141-1003

U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.
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This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© IBM 2012. Portions of this code are derived from IBM Corp. Sample Programs. ©
Copyright IBM Corp. 2012.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at http://www.ibm.com/legal/copytrade.shtml.

Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States,
and/or other countries.

IT Infrastructure Library is a registered trademark of the Central Computer and
Telecommunications Agency which is now part of the Office of Government
Commerce.

Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo,
Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or
registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

ITIL is a registered trademark, and a registered community trademark of the Office
of Government Commerce, and is registered in the U.S. Patent and Trademark
Office.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java™ and all Java-based trademarks and logos are trademarks or registered
trademarks of Oracle and/or its affiliates.

Cell Broadband Engine is a trademark of Sony Computer Entertainment, Inc. in the
United States, other countries, or both and is used under license therefrom.

Linear Tape-Open, LTO, the LTO Logo, Ultrium and the Ultrium Logo are
trademarks of HP, IBM Corp. and Quantum in the U.S. and other countries.

Connect Control Center®, Connect:Direct®, Connect:Enterprise®, Gentran®,
Gentran:Basic®, Gentran:Control®, Gentran:Director®, Gentran:Plus®,
Gentran:Realtime®, Gentran:Server®, Gentran:Viewpoint®, Sterling Commerce™,
Sterling Information Broker®, and Sterling Integrator® are trademarks or registered
trademarks of Sterling Commerce®, Inc., an IBM Company.

Other company, product, and service names may be trademarks or service marks
of others.
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