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Overall Lab Guide  

 
This lab is an extension of the WebFacing Converstion and Testing Lab which 
demonstrates how to use the IBM Webfacing tool to generate the base 
application. This lab shows customization techniques that can be used to 
enhance the base application. It assumed the student already has or is familiar 
with how to use the IBM WebFacing tool to create this base application.  

 

Note: The pictures in these labs show a similar application 
being built. Some of the names and icons may be different 
from the environment you are working with. 
 

The Steps in this Lab 
1. Using the Style Properties 
2. Using a user defined Sign-on 
3. Hyperlinks and Hiding Fields 
4. Adding Tool Tips 
5. Using JavaScript to add a Clock  
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1. Using the Style properties 
Using the Style Wizard to change the IBM WebFaced application user interface. During this 
exercise you will change the User Interface of your application by using the Style 
properties that are part of the IBM WebFacing Tool environment. The style changes will be 
applied on a project level, so all pages in a project will contain the changes you apply to a 
style. In this lab we want you to change the text color and font for all highlighted fields. Also 
you will learn how to apply changes to command key definitions that don’t follow the 
Common User Access (CUA) rules.  

The following tasks will be covered in this lab: 

� Starting the properties dialog 
� Creating a new style 
� Working with Style settings in the change style wizard  
� Specifying the new style to be used for this project 
� Refreshing the project with the new style   

What You Should be Able to Do 

As a result of this exercise you will be able to change a style to tailor the web 

interface to your needs:  

� Create a new style using the IBM WebFacing Style properties 

� Use the field level property pages to change the looks of your web pages 

� Change the project to use a different style 

Using the IBM WebFacing Style properties     

During this exercise you will use the IBM WebFacing Style properties to tailor your 

web user interface.  Highlighted fields in the 5250 panels will get changed to show 

the fact they are highlighted a little bit more in the web user interface. You will 

change the IBM WebFacing conversion results of highlighted fields so the 

conversion will generate code to apply a yellow text color and a bigger font for 

these parts. 
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__ 1.  Invoking the WebFacing Style properties dialog 

� Start the WDSc workbench and open the WebFacing perspective, if it is not up 
and opened already 

� In the WebFacing perspective, locate the WebFacing project you are working 
with in this Lab. 

� Right mouse click on the WebFacing project node WebFacedApp 

� Select Properties from the pop up menu 

 The WebFacing project properties dialog will show 

 

 
 

� Select the Style--DDS field display attributes node in the list on the left side, 
the arrow in the figure above indicates where to find the node. 
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The DDS field display attributes page will appear on the right side of the dialog 

 

 

� Click the .. push button in the High intensity combo box. 
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 The Font dialog appears 

 

� Select Font: Comic Sans MS 

� Select Font style: Bold   

� Select Size: 16 

� Click the OK push button on this dialog   

This will change font size, and font appearance for parts with the high intensity 

attribute active. 

� Click the OK push button on the properties dialog 

Now you are back in the workbench 
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__ 2.  Using the WebSphere Application Server Express V5.0 test environment 
to show the changes 

 
• Right mouse click on the WebFacedApp project icon 

 

 
 

�  Select Run on server from the pop up menu 
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A Server Selection pop up window will ask for you to use existing server or create a new 
server. 

Select WebSphere Application Server Express v5.0 Test Environment (Status: 
Configured)  under Use an existing server. 

You may also select Set Server as project default (do not prompt) radio button as 
we will be using the same test environment throughout this lab.  

  

Click Finish. 
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You will see publishing window pop-up as it has to publish the modified web application to 
WebSphere Application Server Environment.  

 You will see the first screen of your application. 

  

� Notice the different font and font size in some of the text, these are the 

highlighted areas of your 5250 screen. 
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� Prompt for the customer, notice the font changes in the sub-file window 

also as follows: 

 

 Return to Index page by completing the order entry and exiting the application. 
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2. Using the User Defined Signon 
Using the User Defined Signon to create a new sign on page. 

During this exercise you will change the runtime behavior of your application. 

Instead of using the integrated signon, the one you used when you selected the 

members to convert your DDS source, you will now modify the default signon. 

 The following tasks will be covered in this lab: 

� Select the properties for User Defined Signon 

� Modifying the default logon page 

 

What You Should be Able to Do 

As a result of this exercise you will be able to secure your application by forcing 

authentication before the application gets invoked. 

 
� Understand the how to modify the logon page 

� Change the project properties to enable User Defined Signon 
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__ 1.  Using the project properties dialog     

During this exercise you will use the Runtime , Project properties page to select 

Use user-defined signon page  

Start the workbench and open the WebFacing perspective, if it is not up and 

running already. 

In the WebFacing Perspective in the project view,  

� Right mouse click on the WebFacedApp project icon 

� Select Properties from the pull down menu 

The Properties for WebFacedApp dialog will appear 

 

 

� Under Runtime  … Click on Project 
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� Check the Use user-defined signon page check box, in the middle of the 

dialog  

� Click the OK push button, at the bottom of this dialog 

You are back in the workbench 

You have changed the logon behavior for this link (application).  

__ 2.  Modifying logon.jsp  

• Make sure you are in the WebFacing Perspective 

• Select the Navigator tab at the bottom of the WebFacing Perspective window 
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• Once in the Navigator expand your WebFacing project WebFacedApp and then the Web 

Content Folder. In the Web Content Folder you will find the logon.jsp 
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• Select logon.jsp, right click on it select open with Page Designer as showb 

below 
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• Note that there is a Design, Source, and Preview view of the jsp. Feel free to brows e the 

other views. 

 

If you do not see Attribute view in the lower part of above screen, you can open the attribute 

view by selecting Window –> Show View -> Attributes  
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Using the Attributes [body] window change the colors of the logon.jsp  

 

Click on the box next to Background and select any color you like so we can identify 

that the modified jsp is being used. 
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Here is the sample modified JSP page: 

 

• Save your work by clicking on File -> Save All  from menu bar.  
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__ 4.  Using the WebSphere Application Server Express V5.0 test environment to 
show the changes 

 
• Go back to WebFacing Projects view by clicking on WebFacing Projects tab 
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• Right mouse click on the WebFacedApp project icon 
 

 
 

�  Select Run on server from the pop up menu 

In the Server Selection pop-up window select WebSphere Express V5.0 Test 
Environment under User Existing Server Click Finish 
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• In your browser pane click on the top Order Entry Application  link and you 
will see a user defined signon page displayed with modified background 
color. 

 

 

Return to Index page by completing the order entry and exiting the application. 
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3. Hyperlinks and Hiding Fields  
Using WebSettings to change the user interface of the WebFaced application 

During this exercise you will change the User Interface of your application by using 

CODE designer. CODE designer is the GUI based screen design tool for 5250 

panels. For WebFacing we have added a new function to CODE designer, this new 

function is called WebSettings. It allows to change certain aspects of the user 

interface related to the WebFacing conversion process. CODE designer will store 

this WebSetting information as comment lines in the DDS source. These specific 

DDS source comment lines will be picked up at WebFacing conversion and applied 

to the WebFaced user interface.  

You will not be able to use SDA for your DDS source after you used WebSettings. 

The following tasks will be covered in this lab: 

• Specifying the DDS source member to work with  

• Starting CODE Designer 

• Working with WebSettings in CODE Designer  

• Reconverting the application 

As a result of this exercise, you will be able to enhance your WebFaced user 

interface for the browser environment. 

What You Should be Able to Do 

As a result of this exercise you will be able to change the DDS source and add 

WebFacing specific Websettings to it.  

§ Use CODE designer to access DDS source 

§ Use WebSettings to add web user interface changes  

§ Reconvert the changed DDS 
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Using CODE designer to access DDS display file source      

During this exercise you will use Code designer to add some WebSettings to 

the DDS source. We want you to improve the web user interface for the 

customer list window. 

In this window, currently users have to enter a 1 in the options field to select a 

specific customer from the subfile. We want you to change this because it is not 

the way you typically select things in a web interface. On a web page, a link would 

be more natural, to cause a selection of a record to happen. 

You will change the second column customer name  in the subfile, from a simple 

text field to a link. The WebFacing conversion will add logic to the user interface, 

to accomplish the following: 

� When the end user is clicking on this link,  

� Under the covers the options field will be filled with a 1 and 

�  An Enter key press will be invoked.  

The changed user interface still returns to the application the same information as before the 
WebSetting was applied, but the user interface appears more web like to the end user. The 
application itself doesn’t have to be changed. 
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__ 1.  Start the WDSc workbench, if it is not up and running 

� In the workbench, select the WebFacing  perspective  

� Make sure you are on the project page and not the navigator notebook page 

� Expand  your project WebFacedApp in  the tree view by clicking on the +   

 

__ 2.  Modifying DDS Member Through CODE Designer 

� Expand the DDS folder 

� Right mouse click on the SLTCUSTD member  

Start the Code designer by:  

� Selecting Open With -->CODE Designer from the pop up menu 

CODE designer is loading the member. This will take a moment. 
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Eventually you will see the DDS member loaded in CODE designer as shown below: 

 

Select the SCREEN1 tab on the notebook, cursor in the figure above, points at the tab. 
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You should see a dialog similar to the figure below 

 

You will work with the green screen image in CODE designer, do you recognize the screen? 
It is the customer selection list, we want you to change it, so it appears more “webbish” to 
the end user. 
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Click on the first row second column in the subfile (the customer name field) see the 
figure below. 

 

Applying WebSettings 
 

You will notice that the notebook tabs of the notebook at the bottom of the designer dialog 

are context sensitive and changed as soon as you selected the customer field 

� Select the WebSettings tab in this notebook  
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The CODE designer window appearance will be similar to the figure below 

 

On the Websettings page on the bottom of the CODE designer window 

� Locate the list that shows the different Websettings available for the customer 

field  

� Scroll down to the bottom of the list  

� Select Create hyper link 

� Check the Create hyper link check box in the dialog on the right side of the 

list 

� Select the Set Action hyperlink radio button 

� Select the Position cursor to the field check box  

� Select &(OPT) in the field pulldown and enter 1 in the Enter data field. 

� Select the Submit checkbox 

� Select the Function key radio button 
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� Select ENTER from the Function Key pulldown 

 
Just to recap, you have specified the following: 

During WebFacing conversion:  

1. the customer name  fields  in the subfile will be generated so they appear as 

links in the browser window  

At runtime: 

2. When the link is clicked a 1 will be placed in the option field 

3. Also a submit request will be initiated to generate the equivalent of an 

ENTER key press.  

Now that you have created the link for the customer field you have to get rid of the Option 

field so it is not visible any more. 
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__ 3.  Hiding the Option column 

On the design page, you now need to select the Option field to indicate that you want to work 

with it.   

� Click on the option field(column) on the first record in the subfile to select it 

Then on the WebSettings notebook page 

 

� Click on the Visibility choice in the list box  

� Click on the Hide field radio button 

Now this column in the subfile will be hidden. 
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__ 4.  Hiding the Option heading 

Now you need to hide the heading for the option field as well. In order to do this 
you will have to put focus to a different record format in the design screen. CODE 
designer shows all record formats belonging to a screen, this is called a group of 
record formats. You can see all record formats but you can only work with one 
record format at a time, the one that has focus. 
 

To shift focus to next record format:  
 

� Click on the arrow on top of the design page, as shown in the picture 
below. 
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You will notice that the top portion of the design window is now highlighted, the 
bottom one only has half intensity. The highlighted portion is the one you can work 
with. 

 
� Select the OPT Customer constant on the design page 
 

 
 

� Select Appearance and Text from the list box on the WebSettings page 

� Select the Hide characters  check box 

� Specify 1 in the From entry field 

� Specify 3 in the To entry field  

Now you need to hide the instructions  on the panel that guide the user to put a 1 

into the option field to select a specific customer. 
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__ 5.  Hiding the Select instruction 

� Select the constant 1=Select in the 5250 design panel  
 
 On the WebSettings page 
 

 
  
  

� Select Visibility from the list box 

� Select the radio button Hide field 

 You also want to change the instruction text:  Type choices press Enter  
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__ 6.  Change instruction (Type choice press Enter)   

� Select the constant (Type choices press Enter) on the design page 

 Then on the Web Setting Notebook page 

 

� Select Appearance and Text from the list box on the WebSettings page 

� Select the check box Override constant text and key into the entry field 

to the right of the check box this new text: Click on link to select    

  
Now all WebSettings are in place and you can go ahead and save the DDS  
 
source and reconvert this DDS member. 
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__ 7.  Closing CODE designer and re-convert DDS member   

� Click on the x button (top right corner) of the CODE Designer dialog 

� Specify Yes to save, when asked to do so.  

You are done with CODE designer 

� Go back to the WDSc workbench and the WebFacing perspective. 

� Select your project WebFacedApp in the WebFacing view 

� Expand the project +  if you can’t see the DDS folder as part of the 

project 

� Select the member SLTCUSTD you just changed  

� Right mouse click on the SLTCUSTD DDS member 

� Select Convert from the popup menu  

Only this member will be converted 

A conversion report will show up after the conversion is finished 

Now test the new modified application with hyperlinks.  

__ 8.  Using the Websphere Application Server Express V5.0 test environment to 
show the changes 

 
Right mouse click on the WebFacedApp project icon 

 
Select Run on server from the pop up menu 

In the Server Selection pop-up window select WebSphere Express V5.0 Test 
Environment under User Existing Server Click Finish 

In your browser pane click  on the top Order Entry Application  link and sign in 
with your iSeries user name and password when prompted. 
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 On Parts order entry screen prompt for the customer number, which should show the 
hyperlinks for selecting customer in the customer sub-file window. 

  

Return to Index page by completing the order entry and exiting the application. 
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4. Adding ToolTips  
 HTML provides a title attribute which may be rendered by browsers to display the 
title as a "tool tip" (a short message that appears when the pointing device pauses 
over an object such as a field). This enhancement is easily added to a WebFacing 
Application. 
 

The following tasks will be covered in this lab: 

• Specifying the DDS source member to work with  

• Starting CODE Designer 

• Working with WebSettings in CODE Designer  

• Reconverting the application 

As a result of this exercise, you will be able to enhance your WebFaced user 

interface for the browser environment. 

What You Should be Able to Do 

As a result of this exercise you will be able to change the DDS source and add  a 

“Tool Tip” to an Entry Field.  

§ Use CODE designer to access DDS source 

§ Use WebSettings to add web user interface changes  

§ Reconvert the changed DDS 

Using CODE designer to access DDS display file source     

 
During this exercise you will use Code designer to add some WebSettings to 

the DDS source. We want you to improve the web user interface for the 

customer list window. 

In this window, currently users have to enter a valid customer ID.   Users may not 

know that pressing F4 brings up a list of valid customers. 

� You will enhance this application by adding a “Tool Tip” when the mouse 

cursor is hovered over the customer entry field.  
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__ 1.  Use page designer components to create a more attractive browser  interface Start 

the WDSc workbench, if it is not up and running 

� In the workbench, select the WebFacing  perspective  

� Make sure you are on the WebFacing project view and not the navigator 
view 

� Expand  your project in  the tree view by clicking on the +   

__ 2.  Modifying DDS Member Through CODE Designer 

� Expand the DDS folder 

 

� Right mouse click on the ORDENTD member  

Start the Code designer by:  

� Selecting Open With -->CODE Designer from the pop up menu 

CODE designer is loading the member. This will take a moment. 
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Eventually you will see the DDS member loaded in CODE designer as shown below: 

 

Select the SCREEN2 tab on the notebook. 
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You should see a dialog similar to the figure below 

 

 

__ 3.  Modifying DDS Member Through CODE Designer 

• Right Click on the Customer Number Entry Field 

• Select the WebSettings Tab 

• Select Insert HTML 

• Select the Inside Tab 

• Within the Inside tab type   

title=”F4 Prompts for Customer Number” 
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• Save the changes by clicking on File -> Save from menu bar. 

• Close Code Designer 

__ 4.  If the WebFacing perspective, Select the project you have been working on in the 
previous exercise WebFacingApp 

� Expand this project by clicking on the + sign beside its icon in the tree view 

� You should see an icon named DDS in the expanded tree 

 If you don’t see a DDS folder: 

 You might be in the Navigator view,  

� Check the pane title bar, 

  If it shows Navigator,  

� Locate the WebFacing projects Tab at the bottom of the list pane 

� Click on it.  

 Now the WebFacing projects view should be active and you should be able 
to locate the DDS folder.   

__ 5.  Expand the DDS folder by clicking on the + sign, beside it 
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You should see all 3 members that you selected in the previous exercise. 
 
Since you only made changes to one member it is only necessary to convert that one 
member. 
 
Right mouse click on the ORDENTD member in the DDS folder 

 

Select Convert from the pop up menu 
 
The conversion process starts.  
(You may be prompted for a signon and password.  Look for the screen and use 

your team id and password, if you don’t see a prompt, it is OK, just continue.) 

 
Wait until the conversion finishes 
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__ 6.  Using the Websphere Application Server Express V5.0 test environment to 
show the changes 

 
• Right mouse click on the WebFacedApp project icon 

 
�  Select Run on server from the pop up menu 

� In the Server Selection pop-up window select WebSphere Express V5.0 Test 
Environment under User Existing Server Click Finish 

• In your browser pane click on the top Order Entry Application  link and sign 
in with your iSeries user name and password when prompted. 

 
• Position the Mouse Cursor over the Customer Number field. Notice how the 

“Tool Tip” is displayed. 
 

 

  
Custom html can be added in a similar way to any field. 
 
Return to Index page by completing the order entry and exiting the application. 
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5. Using Javascript to add a Clock 
Changing the Pagebuilder.jsp page using page designer 

During this exercise you will use the Web tools in the WDSc workbench to add a a 

clock to the status bar of the browser window of the IBM Webfaced application. 

 

All javascript in the Client Script\user folder is executed at page load time. This 

makes it very easy to add Javascript to an IBM Webfacing application. For this 

example we will add a Clock.js  to the \ClientScript\user folder of the project. 

Clock.js will display the current date and time in the status bar of the browser 

 The following tasks will be covered in this lab:  

� Switching to the navigator view 

� Locating the the ClientScript folder in the WebFacing project 

� Adding Javascript to the application    

� Testing the changed page        

As a result of this exercise, you will enhance the IBM Webfaced Applicaiton  

What You Should be Able to Do 

You will be able to locate the ClientScritp folder in your WebFacing project.  

� Use the navigator view to identify objects created by the WebFacing tool 

� Use a Wizard to insert new Javascript file  

� Use page designer components to create a more attractive browser  interface 
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__ 1.  Switching to the navigator view 

� Go to the  WebFacing perspective 

Switch to the Navigator view by selecting the Navigator tab 

 

__ 2.  Navigator view 

You now have a view that shows you all the files in your WebFacing project. You will 

use this view to locate the ClientScript . 

Expand the WebFacedApp project 

� Expand Web Content folder 

� Expand the ClientScript folder 

� Expand the user folder 



IBM WebFacing Tool – Customizing a WebFaced Application 
 

© COPYRIGHT IBM Corporation 2003                                                                           Page 46 / 50 
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__ 3.  Add Javascript file to user directory 

� Right click on the WebContent/ClientScript/user directory. 

� From the Popup menu select New à Other 
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� From the Dialog Box select Web à JavaScript File 

 

• Click Next 
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• For the Filename enter Clock 

• Click Finish 

__ 4.  Modify Javascript  File for desired functionality 

� Change the Clock.js file source code EXACTLY as shown below  
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• Be sure your code matches exactly or the clock will get runtime errors 

• Save the Changes by clicking on File -> Save Clock.js from menu bar 

 

__ 5.  Using the WebSphere Application Server Express V5.0 test environment to 
show the changes 

 
• Go back to WebFacing Projects view by clicking on WebFacing Projects tab 
 
• Right mouse click on the WebFacedApp project icon 

 
�  Select Run on server from the pop up menu 

� In the Server Selection pop-up window select WebSphere Express V5.0 Test 
Environment under User Existing Server Click Finish 

• In your browser pane click on the top Order Entry Application link and sign 
in with your iSeries user name and password when prompted. 

 
• Notice that in the status bar of the browser window the clock is displayed and 

is updated every second.  
 

 
Congratulations, you have completed Customizing the WebFaced Application Lab. 


