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Preface

This guide contains information and instructions for installing and
configuring IBM® WebSphere® Studio Business Integrator Extensions (referred
to as Solution Studio throughout this documentation).

Who should read this book

This document is intended for the application development administrator
responsible for installing and configuring Solution Studio and setting up
projects for the project team. It is assumed that personnel assigned to
installation tasks have experience with installation procedures for the
Microsoft® Windows NT® operating system, MQSeries® product family,
WebSphere Studio, and Rational® ClearCase® LT (hereafter referred to as
ClearCase LT). It is assumed that personnel assigned to administration tasks
have experience in using Windows®-based applications.

Before you implement WebSphere Business Integrator

WebSphere Business Integrator uses multiple underlying products and
technologies to support the solutions that you create and run. In general,
before you implement Business Integrator, you need to understand the
underlying products and technologies that support your solution.

Before you implement Business Integrator, you or other members of your
organization need to be generally skilled in the activities listed below for
similar solutions, products, and underlying products and technologies. If you
and other members of your organization do not possess these skills, you need
to obtain assistance from qualified services staff, either from IBM or from
third parties, to implement Business Integrator. You must be prepared to use
the documentation of the underlying products and technologies. (This
documentation is provided with Business Integrator or otherwise from IBM.)

When you plan, install, and configure Business Integrator, you need to
understand how to install and configure the underlying products and
technologies that you use in your installation. Business Integrator provides the
installation of most of the underlying products and technologies into its
run-time environment. However, you might need to install and configure
certain underlying products separately into either the build-time or run-time
environment. You might also need to diagnose and correct installation
problems with underlying products and technologies.

Before you design, develop, and publish solutions, you need to be:
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* Generally familiar with system-integration techniques in a business
environment.

* Prepared to use the tools of the underlying products and technologies that
your solution requires.

* Familiar with the run-time behavior of the underlying products and
technologies that your solution requires.

* Familiar with modeling concepts and techniques such as Unified Modeling
Language and related tools, with state machine concepts, and with visual
flow composition-modeling concepts and techniques.

* Familiar with Internet and Electronic Data Interchange (EDI) concepts and
technologies, if required by your solution.

* Prepared to research the existing applications, systems, and networks that
you integrate with Business Integrator.

— Inside your enterprise, they can be known as legacy systems, back-end
systems, enterprise applications, or endpoint applications.

— Outside your enterprise, they can be known as trading networks, private
EDI networks, or similar networks that your solution requires.

Before you deploy, run, manage, diagnose, and tune Business Integrator, you
need to be prepared to use the management, trace, audit, exception handling,
diagnostic and related tools of the underlying products and technologies that
support your solution. You need to be prepared to understand the solution
itself to the degree needed for these tasks.

How to send your comments
IBM welcomes your comments. You can send your comments by any one of
the following methods:
1. Electronically to the following address:
idrcf@hursley.ibm.com

Be sure to include your network address if you want a reply.
2. By FAX to the following numbers:

UK: 01962-842327
Other countries: +44-1962-842327

3. By mail to the following address:

User Technologies

Mail Point 095

IBM United Kingdom Laboratories
Hursley Park

Winchester
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Hampshire
SO21 2JN
United Kingdom

Documentation conventions

Throughout this book, the following conventions distinguish different
elements of text:

bold Menu bar and menu choices, push-button names, icons, check
boxes, radio buttons, entry fields, command names, and user
input at the command prompt or in an entry field

plain text Window, screen, and dialog box titles, file names, directories,
and keyboard key names

italic First occurrence of words with special meaning, variables, and
emphasis

monospaced Output to the display

Preface X1
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Chapter 1. Solution Studio installation and configuration

This chapter provides information on installing the IBM WebSphere Studio
Business Integrator Extensions (referred to throughout this documentation as
Solution Studio). It provides information on minimum hardware and software
required for both the server and client machines, additional software for client
machines, and an overview of installation. It also provides information on
using the InstallShield wizard to install Solution Studio. Additionally, this
chapter provides information about configuration for Solution Studio.

Planning overview

Before installing Solution Studio, your project team must plan how to use
Solution Studio to create solutions. The system requirements must be defined
before installation begins. The system requirements include the following
items:

¢ The numbers and types of machines to be used.

* The software products that are used on each machine to create the artifacts
for a solution. This includes any products required to support them. For
instance, if you are creating MQSeries Workflow artifacts on a particular
machine, the MQSeries Workflow Buildtime product must be installed on
that machine. DB2 and MQSeries, as MQSeries Workflow prerequisites,
must also be installed on the machine.

You must also be familiar with the predefined topology of the run-time
environment for which your solutions are developed. For more information

about Eredeﬁned topologies, refer to the WWehSphere Business Integratar Conceptd

book.

The solutions that run in a run-time environment are created in a separate
build-time environment provided by WebSphere Studio, Solution Studio, and
Rational ClearCase LT.

For the build-time environment, Solution Studio uses a client-server model for
creating and publishing solution artifacts. Typically, Application Developers,
specialists at creating a particular type of artifact (for example, application
adapters, message queues, servlets, and JavaServer PagesTM (JSP files)), create
the artifacts on a client machine and store them in a repository on a server
machine under a version control and change management system. This
enables many application developers to collaborate simultaneously on the
creation of solution artifacts. The build-time environment is set up by an

© Copyright IBM Corp. 2001 1



application development administrator who installs the tools used to create
artifacts and maintains the version control system.

Note: The average team size is 10 persons. Twenty persons to a team is the
maximum size for effective use of Solution Studio.

Solution Studio uses ClearCase LT server and client software to provide
check-in and check-out of files, version control, and general management of
solution creatlon through WebSphere Studlo See U

7”7

for more
information on setting up a project for Solution Studio. Information about
setting up projects is also available in the online help.

Accessing online help

You can access online help for Solution Studio as soon as you install it and

before you install other products. You can access the online help in two ways:

1. Click Help from any Solution Studio wizard to provide context-sensitive
help for that wizard.

2. Click Start > IBM WebSphere » Studio 3.5 » Solution Studio Help. This
brings up the help’s Welcome screen and lets you navigate from there.
This is the best route for users who are accessing help at installation.

Solution Studio installation

The following figure shows a typical Solution Studio client/server installation
for a build-time environment.

Client 1
Solution —»
Studio
Server
Client 2
>
> Client n

Figure 1. Build-time installation

The server and clients have dlfferent hardware and software requirements. See
! i for more information.
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Minimum hardware requirements

Solution Studio runs on one or more Intel®-based machines in a local area
network. The number and configuration of these machines depend on how
you choose to create the artifacts that make up a solution. A minimum of two
machines is recommended: one running the ClearCase server, and one
running WebSphere Studio and the ClearCase client. Assuming that the
project involves a team of tools specialists who are using a variety of tools to
create the various artifacts, many client machines are possible. The following
table lists the minimum requirements for server and client machines.

Table 1. Minimum hardware requirements

Server machine Client machine
Processor Intel Pentium® IIT 550-MHz Intel Pentium IIT 550-MHz
Memory 512 MB 512 MB
Storage 40 GB free disk space 10 GB free disk space

The storage requirements for client machines vary depending on your specific
installation. As a general rule, 5 GB of free disk space are required for each
software product you plan to install on the machine. For instance, if you plan
for one client machine to be used for MQSeries Workflow development, that
machine must have a total of 25 GB free disk space. MQSeries Workflow
requires that MQSeries and DB2® are installed. The calculation is as follows:

Table 2. Calculating free disk space requirements for client machines (example)

Product Amount (GB)

Solution Studio (minimum) 10
MQSeries 5
MQSeries Workflow 5
DB2 5
Total 25
See L. iti ” for additional information about software

used with Solution Studio to create artifacts.

Solution Studio software requirements
The following sections list prerequisite software, Solution Studio software, and
other software you use to create the artifacts for your solution.

Software prerequisites
The following table lists the required software for a minimum Solution Studio
installation.
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Table 3. Software prerequisites

Software product Version Server Client
Windows NT Server 4.0 with Service |X
Pack 6a or
higher
Windows NT Workstation 4.0 with Service X
Pack 6a or
higher
Rational ClearCase LT 4.1 X X
WebSphere Studio Advanced 3.5.2 X
Edition
Solution Studio 2.1 X X

It is assumed that the operating system is installed on all machines before you
install ClearCase LT, WebSphere Studio, Solution Studio, and any additional
software products you intend to use to create solution artifacts.

Note: Microsoft Internet Explorer 4.0 or higher is corequisite software. It is
not required to install Solution Studio; however, it is required to run
parts of Solution Studio, such as the help system.

Additional software

Additional software is used to develop solution artifacts with Solution Studio.
This software can include the following;:

* DB2 (client and server) version 7.2 (not required directly by Solution Studio,
but required by other products)

e MQSeries (client and server) version 5.2

* MQSeries Adapter Builder version 1.0.1

* MQSeries Adapter Kernel version 1.1.1

* MQSeries Integrator version 2.0.1

* MQSeries Workflow version 3.3

* Partner Agreement Manager (PAM) Public Process Editor version 2.1
* VisualAge® for Java version 3.5.3

Additionally, Datalnterchange client version 2.1 can be used to develop

Datalnterchange artifacts, although the Datalnterchange client does not
interact directly with Solution Studio.

Many of these products have patches that must be installed for them to work

correctly with Solution Studio and Business Integrator. See the Solution Studio
release notes for a listing of the current supported levels.
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Some additional software products have prerequisites that must be installed
for them to work. Additionally, some products listed here are build-time
products only and require run-time products when the artifacts are tested and
deployed; for instance, adapters created in MQSeries Adapter Builder require
MQSeries Adapter Kernel to run, and FDL files created in MQSeries Workflow
Buildtime require MQSeries Workflow Runtime to run. Refer to the product
documentation for more information. Some software requires DB2, which
must be installed before you install the dependent product.

The additional products that are installed on a given machine depend on the
type of development to be done on that machine. For example, if a client
machine is to be used to develop only Web applications, then VisualAge for
Java is the only product other than Solution Studio that needs to be installed
on the machine. However, if a machine is to be used to develop both Web
applications and MQSeries Integrator artifacts, then the following products
need to be installed on the client:

* DB2 client (prerequisite for MQSeries Integrator)

* MQSeries (prerequisite for MQSeries Integrator)

* MQSeries Integrator

* VisualAge for Java

Additionally, the server machine in this case must run DB2 server to support
the DB2 client.

It is recommended that additional software products be installed, configured,
and verified before Solution Studio is installed, and that each product be
installed, configured, and verified as a unit (for instance, if you are installing
both DB2 and MQSeries, first install, configure, and verify DB2, then install
MQSeries). It is recommended that additional software products be installed
in the following order:

DB2

MQSeries

MQSeries Integrator
MQSeries Workflow

Partner Agreement Manager
MQSeries Adapter Kernel
MQSeries Adapter Builder
VisualAge for Java

© N o oAb~

©

Solution Studio

For example, if you install software to support MQSeries Workflow
development, install the software in the following order:
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Table 4. Example of recommended installation order for software products

Client Server

1. DB2 client 1. DB2 server

2. MQSeries 2. Solution Studio server
3. MQSeries Workflow

4. Solution Studio client

Installing Solution Studio

Solution Studio software is installed from the Solution Studio CD. A Solution
Studio InstallShield wizard leads you through installation of software for both
the server and client machines. The installation assumes that the appropriate
operating systems are installed on both the server and client machines. Note
the following installation considerations for ClearCase LT:

* ClearCase LT cannot be installed on a machine that is running the full
ClearCase.

 If ClearCase LT is already running on a machine, installing another copy of
ClearCase LT supersedes the running version.

The installation instructions assume that you are installing a server and one or
more client machines. You use the same CD to install both server and clients.
When installing Solution Studio, you must install server software before
installing the client software. The Solution Studio components are
automatically installed on both the server and the clients.

Installing the server software
Use the InstallShield wizard to install the server. Follow the wizard panels to
install the following items on the server machine:
1. ClearCase LT server software.

2. Solution Studio folder with the project directory. This is created as a
shared folder as part of the installation process.

Installing the client software

Use the InstallShield wizard to install the client software. Follow the wizard
panels to install components on the client machine. The installation program
checks whether the following items are installed on the machine. If a
component is not installed, the installation wizard automatically checks that
component’s checkbox on the list of components to be installed. Before you
begin installing components, verify that the appropriate checkboxes are
checked for the components to be installed on the machine.

1. IBM Java Development Kit.
2. WebSphere Studio Advanced Edition.
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3. ClearCase LT client software.

You are prompted to give the name of the installation directory and the
ClearCase server name when installing ClearCase LT during installation.
After this information is provided, the installation completes silently. If
you do not provide a valid server name during installation, the ClearCase
LT client is not installed.

4. Gateway tooling for PAM.

Gateway tooling provides the Partner Agreement Manager Public Process
Editor. If your run-time environment does not include Partner Agreement
Manager, you cannot install this component. If your run-time environment
includes Partner Agreement Manager and you plan to create public
processes by using the editor, check this checkbox for each client on which
you want to use the Public Process Editor. During installation, you are
prompted for the host name of your Partner Agreement Manager gateway
machine.

The Solution Studio client components, including the wizards and standard
solution templates, are automatically installed by installing the client software.
The standard solution templates are installed in the WebSphere Studio root
directory (for example, x:\websphere_studio\templates, where x is the letter of
the drive where WebSphere Studio is installed and websphere_studio is the root
directory).

Configuring

Before using the tools to create solution artifacts, you must configure Solution
Studio by registering the products you use as tools. If you are using
VisualAge for Java, you must also configure WebSphere Studio and VisualAge
for Java to work with each other. Before starting work on a solution, you must
set up projects in ClearCase LT. The following sections provide information on
configuring WebSphere Studio, Solution Studio, and VisualAge for Java. See

% for information on setting up ClearCase LT projects for Solution

Studio.

You access tools in Solution Studio by using Solution Studio wizards. Solution
Studio uses the following types of wizards:

* Studio wizards—Wizards that are registered automatically when Solution
Studio is installed. Studio wizards include the following;:

Wizard Registration wizard

— MQSeries Queue Definition wizard

WebSphere Artifact Configuration wizard

Solution Deployment wizard

Application Configuration wizard
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— Adapter Routing wizard

* Standard wizards—Wizards that interface with optional software such as
MQSeries Integrator, MQSeries Adapter Builder, and MQSeries Workflow.
These wizards must be registered manually on each Solution Studio client
on which the optional software is installed. Standard wizards include the
following:

— MQSI wizard
- MQ Adapter Builder wizard
— Workflow wizard

* Simple wizards—Wizards that enable you to launch third-party software
such as graphics and office applications from Solution Studio. Unlike studio
wizards and standard wizards, simple wizards do not provide Solution
Studio-specific functionality. These wizards must be registered manually on
each Solution Studio client on which the third-party software is installed.

See the ehSphere Studio Business Integrator Extensions Developer’s Guidd and

the online help for information about these wizards.

Configuring Solution Studio

To configure Solution Studio, you must register any products that are used as
tools on client machines to create solution artifacts. These products are
discussed in £ " . Each product must be installed
on the client machine before you register it in Solution Studio. No
configuration is required on the server machine. Use the Solution Studio
Wizard Registration wizard on the client machine to register tools. To access
the Wizard Registration wizard, do the following:

1. Start WebSphere Studio.

Select your solution in the project view.

2
3. From the menu bar, click Tools » Wizards » Wizard Registration.
4

The Wizard Registration wizard appears, as shown in Eigure 2 on page d.

It shows the wizards that are registered for use. If the standard wizards
are not registered, click Apply Standard Wizards to register them.
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Studio Wizards | Wizard Registration |

Solution Studio Wizards

Registered Wizards:
=Moo userwizards registered=

Refresh Delete Apply Standard Wizards

Click MEXT to register a new wizard

Bk | Finish I Cancel | M et | Help |

Figure 2. The Studio Wizards page of the Wizard Registration wizard

5. You can select other products to use with Solution Studio from the Wizard
Registration page. With the Wizard Registration wizard open, click the
Wizard Registration tab. The Wizard Registration page opens, as shown

in Eigure 3 on page 10.
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Studio Wizards Wizard Registration |

Solution Studio Import Wizard Registration

Select the application to be registered as a wizard:

4 Applications

H-_ ] Access [Bh

I Accessories

f- | Adrninistrative Tools
&) Adobe

Ll

Acrobat Reader 4.0
Register Acrohat 4.0
Uninstall Adobe Acrobat 4.0
Bookmark Converter 2.85

# RAnnkmark Cnnverter 2 A5

Back | Finish I Cancel | W et | Help |

Figure 3. The Wizard Registration page of the Wizard Registration wizard

6. Select the product from the list and click Register. This creates a simple
wizard.

Repeat this step for all of the software products installed on the client
machine that are to be used to create solution artifacts.

7. When you have finished registering products, click Finish.

8. To view a list of all registered wizards, select the Studio Wizards tab on
the Wizard Registration wizard, then click Refresh.

Note: After a wizard is installed, WebSphere Studio must be closed and
reopened for the wizard to appear in the Tools » Wizards menu.

10  WebSphere® Studio Business Integrator Extensions for Windows NT®: Installation Guide



Online help is available for the Wizard Registration wizard.

Configuring WebSphere Studio and VisualAge for Java to work together

If VisualAge for Java is installed on the client machine, you must configure it
to work correctly with WebSphere Studio so that the following can occur:

* Java classes can be moved back and forth between the two products.
* Java classes can be updated in either product.

* Java class status in WebSphere Studio can be checked from within
VisualAge for Java.

¢ The VisualAge Java editor can be launched on any Java class in a
WebSphere Studio project.

Refer to the WebSphere Studio and VisualAge for Java documentation for
configuring these products to work together. To install WebSphere Studio tools
in VisualAge for Java, do the following:

1. Start WebSphere Studio.
2. From the WebSphere Studio menu bar, select Project » VisualAge for Java
> Install Studio Tools in VisualAge.

This is a one-time procedure for each client machine. WebSphere Studio tells
you when the tools have been installed.

To prepare VisualAge for Java for WebSphere Studio Integration, perform the
following steps:

1. Start VisualAge for Java.

2. Select Window » Options.

3. When the Options dialog box appears, do the following:
a. Select the Remote Access To Tool API item in the left tree structure.
b. Check the Start Remote Access To Tool API on VisualAge startup

checkbox.
4. Click the Start Remote Access To Tool API button.
5. Click OK.
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Chapter 2. Setting up servers and clients for use by
Solution Studio

The procedures in this chapter enable you to set up ClearCase LT and
WebSphere Studio for use in creating solutions under version control. These
procedures assume you have installed all the necessary software on both
client and server, that a shared folder with a project exists on the server, and
that a template folder exists on the client. A shared folder named
StudioTeamFiles is set up and shared automatically when a Solution Studio
server is installed; a template folder is set up automatically when a Solution
Studio client is installed. These procedures also assume that you have created
all necessary user IDs.

Overview

Solution Studio requires activities to be performed on both the server and
clients to create and store the elements of a solution. In WebSphere Studio, the
solution can be thought of as a project. The WebSphere Studio project, and
thus the Solution Studio solution elements and artifacts that comprise it, is
stored in the ClearCase LT repository under the versioned object base (VOB)
on the server. A Solution Studio solution is a work in progress until it is
published.

On the server, create a VOB in ClearCase LT to prepare the ClearCase LT
server to store the artifacts for your solution under version control and create
a shared folder to hold the repository. See L'Creating a VOR” on page 14. This
step must be performed by someone with ClearCase LT Administrator
authority.

Perform the following steps on each client machine that uses WebSphere
Studio and ClearCase LT clients. Note that when a Solution Studio client is
installed, the installation process automatically maps a network drive to the
StudioTeamFiles folder on the ClearCase LT server on which the repository
resides.

1. Define views. A view is the way in which a ClearCase LT client looks at

data in a VOB. See [!Creating a view” on page 14,

2. Create a project for Solution Studio in WebSphere Studio. See ['Creating 4

”

3. Set u_El tool preferences. See I’Creating a project for Solution Studia” od
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4. Add the project to version control. See I‘Creating a project for Solution
Btudia” on page 1.

2

After these steps are completed, Application Developers can join the project
and collaborate to develop the solution under version control.

Online help for setting up projects is available in Solution Studio.

Creating a WebSphere project on the ClearCase LT server

The following sections describe how to set up a WebSphere Studio project in
ClearCase LT. You can create a VOB for each project or solution you are
creating. You can create a new VOB at any time.

Creating a VOB
To create a VOB, do the following on the ClearCase LT server:
1. Verify that you have ClearCase LT Administrator privileges.

2. From the Start menu, click Programs » Rational ClearCase LT Server »
Create VOB to start the VOB Creation wizard.

Provide a name for the VOB. Typically, this is the name of your solution.
Enter a comment about your VOB.

Click Finish. The wizard creates the VOB.

Click OK on the confirmation panel.

N o ok

When the VOB creation wizard confirmation panel appears, click Finish.

As part of the VOB-creation process, a folder that holds the repository is
created on the server machine. This folder is automatically shared for use by
clients across the network.

Setting up the project on the client

To enable those creating a solution to work on the artifacts for the solution,
the client must be set up to work within change management and version
control and to use the WebSphere Studio graphical user interface (GUI), as
described in the following steps. The following procedures assume that a VOB
is created on the server.

Creating a view

In ClearCase LT, a view is a work area. To create a view on the client, do the
following:

1. Start the View Creation wizard by clicking Start » Programs » Rational
ClearCase LT Server > Create View.

2. Do not select a project. Click Next.
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8.
9.

Provide a location on a local drive where the view is to be located. You
can enter any valid drive and directory or click Browse to select a drive
and directory.

If desired, enter comments.
Click Finish. The wizard presents a confirmation window.
Click OK. The Choose Elements to Load window is displayed.

Ensure that the Show All VOBs checkbox is checked. From the Available
Elements list, select a VOB on the server as the element to load.

Click Add to add the element to the Selected Elements list.
Click OK to confirm the success.

Creating a project for Solution Studio

This procedure assumes that WebSphere Studio is running. When WebSphere
Studio starts for the first time, you are given the opportunity to create a
project. To create a project for Solution Studio, do the following:

1.

3.

4.

In the New Project dialog box, do the following:
a. Give the project a name.
b. Browse to the shared projects folder and select it.

c. In the Create using field, browse for a Solution Studio standard
template folder (UserRegistration or PurchaseOrder) and select it.

d. Click OK.

Create a new project by doing the following;:

a. Click File » New Project. The New Project dialog box appears.
b. Give your project a name (for example, UserReg).

c. Browse to the shared projects folder and select it.
d

. In the Create using field, open the drop-down menu and select the
template for your solution (for example, UserRegistration).

e. Click OK.
Click Tools » Preferences. In the dialog box that appears, do the following:

a. Change the Local check-out folder by browsing to the local view and
selecting it.

b. Click Set as Default.
c. Click OK.
Add the project to version control by doing the following:

a. Select the project you have created in the WebSphere Studio project
view pane.

b. Click Project » Version Control > Add to Version Control » ClearCase.
This process can take a considerable length of time to complete.

c. Click OK.
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Joining a WebSphere Studio project

Application Developers can join a project by creating views on their client
machines. To create a view on a client machine, do the following:

1. With WebSphere Studio running, select the project in the project view
pane.

2. Click Project » Version Control » Update with latest version.
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Notices

This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give
you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the
IBM Intellectual Property Department in your country or send inquiries, in
writing, to:

IBM World Trade Asia Corporation Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions; therefore,
this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
be incorporated in new editions of the publication. IBM may make

© Copyright IBM Corp. 2001 17



improvements and/or changes in the product(s) and/or program(s) described
in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for
this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:

IBM United Kingdom Limited,
Intellectual Property Department
Hursley Park

Winchester SO21 2JN

United Kingdom

Such information may be available, subject to appropriate terms and
conditions, including, in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
agreement between us.

Any performance data contained here in was determined in a controlled
environment. Therefore, the results obtained in other operating environments
may vary significantly. Some measures may have been made on
development-level systems, and there is no guarantee that these
measurements will be the same on generally available system. Furthermore,
some measurements may have been estimated through extrapolation. Actual
results may vary. Users of this document should verify the application data of
their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available
sources. IBM has not tested those products and cannot confirm the accuracy
of performance, compatibility or any other claim related to non-IBM products.
Questions on capabilities of non-IBM products should be addressed to the
suppliers of those products.
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development-level systems, and there is no guarantee that these
measurements will be the same on generally available system. Furthermore,
some measurements may have been estimated through extrapolation. Actual
results may vary. Users of this document should verify the application data of
their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available
sources. IBM has not tested those products and cannot confirm the accuracy
of performance, compatibility or any other claim related to non-IBM products.
Questions on capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include
names of individuals, companies, brands, and products. All of these names
are fictitious and any similarity to the names and addresses used by an actual
business enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language,
which illustrates programming techniques on various operating platforms.
You may copy, modify, and distribute these sample programs in any form
without payment to IBM, for the purpose of developing, using, marketing or
distributing application programs conforming to IBM’s application
programming interfaces for the operating platform for which the sample
programs are written. These examples have not been thoroughly tested under
all conditions. IBM, therefore, cannot guarantee or imply reliability,
serviceability, or function of these programs.

Trademarks

The following terms are trademarks of the International Business Machines
Corporation in the United States or other countries, or both:

+ DB2

« IBM

* MQSeries

* Process Choreographer
* SecureWay

* VisualAge
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* WebSphere

Java and all Java-related trademarks are trademarks of Sun Microsystems, Inc.
in the United States, or other countries, or both.

Microsoft, Windows, and Windows NT are registered trademarks of Microsoft
Corporation in the United States and/or other countries.

Rational and ClearCase are registered trademarks of Rational Software
Corporation.

Other company product, and service names may be trademarks or services
marks of others.
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Bibliography

This bibliography lists the books in the IBM WebSphere Business Integrator
and associated libraries.

IBM WebSphere Business Integrator library

The Business Integrator library consists of the following books:

o WehSphere Business Integrator Concepts and Planning, GC34-5960

This book introduces the Business Integrator system, providing a high-level
system overview, defining the system capabilities, and describing its value
to e-businesses. This book also provides the information that you need to
plan the installation of Business Integrator.

« WehSphere Business Integrator Installation Guidd, GC34-5961

This book is a guide to installing and configuring Business Integrator. It
contains information about:

— Selecting your required topology

— Installing and configuring the base products and software components of
Business Integrator on each machine in the topology

- Installing and configuring firewalls and proxies

o WehSphere Studio Business Integrator Extensions Installation Guidd, SC34-5962

This book is a guide to installing and configuring Solution Studio. It also
contains information about setting up clients and servers, and creating
projects.

This book is a comprehensive guide to the Business Integrator runtime
system, providing the following information:

— Detailed conceptual information about the run-time components of
Business Integrator

— Deployment of solutions to the run-time system

— System administration, such as starting and stopping software
components and base products, defining users, and using the Exception
Console

— General problem determination information, including how to trace and
debug, and information on obtaining help from technical support
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. thq‘nhprp Business Integrator Mpqqagpc{

This book lists the error messages that are produced by Business Integrator
and provides references to the documentation for the messages of base
products.

. thqlnhprp Studio Business Integrator Extensions Dpnplnppr’c Guidd

This book describes how to create a Business Integrator solution, beginning
with the solution design phase, to the solution implementation phase, and
finally the solution deployment phase by using a sample business problem.
This book also provides procedures for assembling a Business Integrator
solution in the run-time environment and a description of how to use
Solution Studio for solution design and implementation.

SC34-5963

This book is a guide to installing and using Datalnterchange in the Business
Integrator environment.

You can find the latest versions of the books at the following Web site:

YT, E - I

This site contains links to the Web sites of the underlying products of IBM
WebSphere Business Integrator.

Related documentation

The utilities subdirectory on the Documentation CD contains documentation
about utilities that can prove useful in building and running solutions. This
documentation is not available on the IBM WebSphere Business Integrator
Web site.

WebSphere Business Integrator also provides a number of external application
programming interfaces (APIs). HTML documentation that is generated by
using the Javadoc tool is provided for these APIs. For a list of the APISs, refer

to the WehSphere Business Integrator Run Timd book.
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WebSphere Partner Agreement Manager library

The Partner Agreement Manager Version 2 Release 1 library consists of:

Partner Agreement Manager Installation Guide, GC34-5964
Partner Agreement Manager Administrator’s Guide

Partner Agreement Manager User’s Guide

Partner Agreement Manager Adapter Developer’s Guide

Partner Agreement Manager Script Developer’s Guide

Partner Agreement Manager API Guide

Partner Agreement Manager Adapters for MQSeries User’s Guide
Partner Agreement View User’s Guide, GC34-5965

Datalnterchange library

The Datalnterchange Version 3 Release 1 library consists of:

Datalnterchange Client User’s Guide, SB34-2010
Datalnterchange Administrator’s Guide, SB34-2002
Datalnterchange Installation Guide, GB09-8070
Datalnterchange Messages and Codes, SB34-2000
Datalnterchange Programmer’s Reference, SB34-2001

Other libraries

You can find important information in the libraries of the following products:

DB2® UDB

— IBM DB2 Universal Database Quick Beginnings Version 6.1, S10]-8149
MQSeries®

— MQSeries for Windows NT Quick Beginnings, GC34-5389

— MQSeries System Administration, SC33-1873

— MQSeries Using Java, SC34-5456

— MQSeries MQSC Command Reference, SC33-1369

— MQSeries Queue Manager Clusters, SC34-5349

— MQSeries Integrator Introduction and Planning, GC24-5599

— MQSeries Workflow Getting Started with Buildtime, SH12-6286

— MQSeries Workflow Getting Started with Runtime, SH12-6287

— MQSeries Adapter Kernel for Multiplatforms: Quick Beginnings, GC34-5855
— MQSeries Adapter Kernel: Problem Determination Guide, GC34-5897
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— MQSeries Adapter Builder for Windows NT: Using the Control Center,
GC34-5882

* SecureWay®

— SecureWay Policy Director Up and Running, SCT6-3KNA

— SecureWay Policy Director Base Administration Guide

— SecureWay Firewall User’s Guide, CG31-8658
* VisualAge®

— VisualAge Java, Enterprise Edition Getting Started

— VisualAge C++ Professional for Windows NT Getting Started
 WebSphere® Application Server

— Introduction to WebSphere Application Server, SC09-4430
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