
Network License Administrator’s
Guide

The following instructions are for administrators at sites with a network license for IBM® SPSS®
Modeler Text Analytics 15. This license allows you to install IBM SPSS Modeler Text Analytics
on any number of computers. However, only the number of users for which you purchased the
license can run the application concurrently.

Before You Start

You will need your authorization code. This may be on a separate sheet of paper or is available
from http://www.ibm.com/software/getspss. The authorization code enables you to get a license
for the network license manager. The network license manager controls your network license
and allows end users to run IBM® SPSS® Modeler Text Analytics . If you cannot find your
authorization code, contact your sales representative.

To ensure that you set up the network license correctly, follow these steps:

E Install the network license manager. The network license manager is the utility that will serve
up the network licenses to end users. You can install the license manager on any computer on
your network. This is typically a server to which desktop computers can connect. For more
information, see the topic Installing the Network License Manager on p. 1 .

E License your product. This action will give the license manager the required information for
serving up the licenses. For more information, see the topic Licensing Your Product on p. 5 .

E Test the network license manager. You should test license manager to make sure it is serving up
licenses. For more information, see the topic Testing the License Manager on p. 9 .

E Install IBM SPSS Modeler Text Analytics on the local desktop computers. You or your end users will
complete the full installation on the desktop computers. During an installation, an end user can
specify the computer on which the license manager is running. When an end user tries to launch
IBM SPSS Modeler Text Analytics , the product communicates with this license manager to
get a license. If a license is available, IBM SPSS Modeler Text Analytics launches. For more
information, see the topic Installing the Product on the Local Desktop Computers on p. 9 .

No administration steps are required for the installation, but if any problems arise, see
Administering the Network License on p. 10.

Installing the Network License Manager

Before end users install IBM® SPSS® Modeler Text Analytics on their desktop computers, you
must install the network license manager. This utility is a continuously executing service or
daemon that you will typically install on one computer on your network. (You also have the option
of installing on multiple computers, in which case you would set up redundant license managers.
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For more information, see the topic Setting Up Redundant License Servers on p. 11.) You do not
install the network license manager on the desktop computers.

Whenever an end user starts a network-licensed IBM SPSS application, the application will
request a license from the license manager. This utility will deliver licenses up to a fixed number
of simultaneous end users, determined by the license that you have purchased. After this number
has been met, any further requests for licenses will be refused. If you find that end users are
often being refused licenses, you can contact your sales representative to purchase a license that
will allow more simultaneous users.

License managers are available on a separate DVD. They can also be downloaded as an eImage.

Note: The license manager will record the number of active end-user sessions and information
about each session in a log file, which you can use to troubleshoot connection problems. For more
information, see the topic Obtaining Log Information on p. 11.

Multiple Operating Systems

The platform on which the network license manager is running does not have to match the
platform on which the client is running. For example, a Linux license manager can serve up
licenses for Windows clients.

Administering the License Manager

You administer the license manager using the license manager tools, which are available only
for Windows. Therefore, you need at least one Windows machine on which to install the license
manager tools.

System Requirements

The computer on which you install the network license manager must meet the following
requirements:

550 Mhz or higher processor
128 MB of RAM or more

Important! If a firewall is running on the license server, you must open port 5093 for UDP.
Otherwise, client computers will not be able to retrieve a license from the license manager.
Furthermore, if you are using redundant license servers, you must open port 5099 for UDP to
enable the license servers to communicate with each other.

Upgrading the License Manager

If you have a previous version of the license manager installed, you must perform the following
steps:

E Go to the directory in which you installed the old license manager.

E Copy the lservrc file. On Windows, look in the winnt subdirectory.

E Save the lservrc file to a safe location.
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E If any users have checked out commuter licenses, make sure those users check the licenses back in.

E Shutdown the license manager. For more information, see the topic Starting and Stopping the
License Manager on p. 14.

E Uininstall the old license manager. For more information, see the topic Uninstalling the License
Manager on p. 15.

E Install the new license manager. For information about installing on Windows, see the topic
Installing the License Manager on Windows on p. 3 . For information about installing on
UNIX/Linux, see the topic Installing the License Manager on UNIX/Linux on p. 4 . For
information about installing on Mac OS, see the topic Installing the License Manager on Mac OS
on p. 4 .

E Copy the saved lservrc file to the directory in which you installed the new license manager or
the winnt subdirectory of the installation directory on Windows. If you accepted the default
location on Windows, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\ folder.

Installing the Concurrent Licensing Tools (All Platforms)

Before you can install the license manager and the license manager tools, you must run the
concurrent licensing tools installer. This installer will copy the installer files for the license
manager and/or the license manager tools to your computer. During installation, you will be able
to choose which installer files you want to copy.

The concurrent licensing tools installer requires Java 1.5 or higher.

E Insert the DVD into the DVD drive of the network computer on which you want to run the
license manager and/or license manager tools. Look for the installer for your operating system
and launch it from the DVD.

or

E If you downloaded an eImage file, use an archive utility such as WinZip to extract all the files in
the appropriate eImage. Launch the installer file for your operating system.

Note: There may be multiple eImages for the concurrent license tools: one for the license manager,
one for the license manager tools, and one for hardware key drivers. Each eImage installs the
concurrent licensing tools and the installer for the named component.

E Follow the instructions that appear on the screen. Be sure to note the installation directory. If you
chose to install the license manager and/or the license manager tools, the installation process for
these will be started automatically.

Installing the License Manager on Windows
Note: On Windows Vista or 7, you must launch the installer as administrator. When instructed to
launch an installer file, right-click the file and choose Run As Administrator.

Note: Ensure that the machine on which you are installing has Java installed.
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E If you haven’t installed the concurrent licensing tools, install them and be sure to select Sentinel
License Manager if prompted. For more information, see the topic Installing the Concurrent
Licensing Tools (All Platforms) on p. 3 .

E When you install the concurrent licensing tools from the DVD, the installer for the license
manager should start automatically. If it didn’t or you cancelled the installation, browse to the
licensemanager directory in the concurrent licensing tools installation directory.

E Launch setup.exe. On Windows Vista or 7, be sure the launch the installer as administrator.

E Follow the instructions that appear on the screen.

Installing the License Manager on UNIX/Linux

E If you haven’t installed the concurrent licensing tools, install them and be sure to select Sentinel
License Manager if prompted. For more information, see the topic Installing the Concurrent
Licensing Tools (All Platforms) on p. 3 .

E Browse to the licensemanager directory in the concurrent licensing tools installation directory.

E Untar the license manager file.

E Install the license manager tools on a Windows machine. For more information, see the topic
Installing the License Manager Tools on p. 4 .

E Refer to Starting and Stopping the License Manager on p. 14 for information about starting
the license manager.

Installing the License Manager on Mac OS

E If you haven’t installed the concurrent licensing tools, install them and be sure to select Sentinel
License Manager when prompted. For more information, see the topic Installing the Concurrent
Licensing Tools (All Platforms) on p. 3 .

E Browse to the licensemanager directory in the concurrent licensing tools installation directory.

E Double-click the license manager ZIP file to extract the contents of the file.

E Double-click the extracted license manager installer.

E Follow the instructions that appear on the screen.

E Install the license manager tools on a Windows machine. For more information, see the topic
Installing the License Manager Tools on p. 4 .

E Refer to Starting and Stopping the License Manager on p. 14 for information about starting
the license manager.

Installing the License Manager Tools

The Windows-only license manager tools are used to administer the license manager. Depending
on your operating system, you may need to manually install these tools.
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Windows. You can install the license manager tools on the same machine on which you
installed the license manager. You also have the option of installing on another Windows
machine if you want to administer the license manger remotely.
Other Operating Systems. If you installed the license manager on a non-Windows machine, you
must install the license manager tools on a Windows machine.

E If you haven’t installed the concurrent licensing tools, install them and be sure to select Tools
when prompted. For more information, see the topic Installing the Concurrent Licensing Tools
(All Platforms) on p. 3 .

E Browse to the tools directory in the concurrent licensing tools installation directory.

E Launch setup.exe.

E Follow the instructions that appear on the screen.

Licensing Your Product

After the main part of the installation is complete on Windows, click Finish to launch the License
Authorization Wizard. The License Authorization Wizard allows you to obtain a license for
IBM® SPSS® Modeler Text Analytics . On other operating systems, you must install the license
from the command prompt after installing the license manager.

If you do not get a license now, you can enable IBM SPSS Modeler Text Analytics to be used for
a temporary usage period by a limited number of users. After the temporary usage period has
completed—and which begins when the product is first used—IBM SPSS Modeler Text Analytics
will no longer run. Therefore, it is recommended that you obtain a license as soon as possible.
You must either obtain a license or enable for temporary usage to use IBM SPSS Modeler Text
Analytics .

Note: Licenses are tied to the network computer’s hardware with a lock code. If you replace the
network computer or its hardware, you will have a new lock code and will need to contact your
sales representative to obtain a new authorization code. Also note that your authorization code
was generated for a specific number of CPUs. If you have a greater number of CPUs than that
specified by the authorization code, you will receive a warning message and the product will stop
working 30 days after authorization.

Warning: The license is sensitive to time changes. If you must change the system time
and then cannot run the product, contact IBM Corp. Technical Support by visiting
http://www.ibm.com/support.

Using the License Authorization Wizard (Windows Only)

The License Authorization Wizard is available only on Windows. If you need to license the
license manager on a different operating system, you must license from the command prompt. For
more information, see the topic Installing a License from the Command Prompt on p. 6 .

E If you don’t launch the License Authorization Wizard during installation or cancel the License
Authorization Wizard before obtaining a license, you can launch it by running law.exe, which

http://www.ibm.com/support
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can be found the license manager installation directory. On Windows Vista or 7, you must run as
administrator. Right-click law.exe and choose Run As Administrator.

E When prompted, choose License my product now.

E When prompted, enter one or more authorization codes. If you downloaded IBM SPSS Modeler
Text Analytics , your authorization code is available from http://www.ibm.com/software/getspss. If
you received physical installation media, your authorization code may be delivered on a separate
sheet of paper along with your software or on the inside cover of the DVD case. You should have
received the authorization code(s) from your administrator.

The License Authorization Wizard sends your authorization code over the Internet to IBM Corp.
and automatically retrieves your license. If your computer is behind a proxy, click Configure
proxy settings and enter the appropriate settings.

If the authorization process fails, you will be prompted to send an e-mail message. Choose
whether you want to send the e-mail message through your desktop e-mail program or through a
Web-based e-mail application.

If you choose the desktop option, a new message with the appropriate information will be
created automatically.
If you choose the Web-based option, you must first create a new message in your Web-based
e-mail program. Then copy the message text from the License Authorization Wizard and
paste it into your e-mail application.

Send the e-mail message and respond to the prompt in the License Authorization Wizard. The
e-mail message will be processed almost instantaneously. You can click Enter License Code(s)
to enter any license code(s) that you receive. If you already closed the License Authorization
Wizard, restart it and select License my product now. On the Enter Codes panel, add the license
code that you received and click Next to complete the process.

Installing a License from the Command Prompt

You have two options for installing from the command prompt. You can use licenseactivator to
get a license from the Internet automatically, or you can use echoid to get a license manually.

Using licenseactivator to Install a License Automatically

The computer on which you are installing the license must be connected to the Internet. If it isn’t,
install the license manually. For more information, see the topic Installing a License Manually
on p. 7 .

E Log in as the user who installed the license manager.

E Open a command prompt and change directories to the license manager installation directory.
Note that this is the directory in which you installed the license manager, not the directory in
which you installed IBM® SPSS® Modeler Text Analytics . If you accepted the default location
on Windows, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS License
Manager\ folder.

http://www.ibm.com/software/getspss
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E Windows Only. Change directories to the winnt subdirectory.

E You typically have an authorization code. In the simplest case, you enter the following at the
command prompt. See below for more details about the command prompt usage.

licenseactivator <auth-code>

where <auth-code> is your authorization code.

You should see a message that the license was added successfully. If it wasn’t, note the error code
and try installing the license manually. For more information, see the topic Installing a License
Manually on p. 7 .

When you use licenseactivator, it licenses the product and writes a log file to its directory. The
name of the log file is licenseactivator_<month>_<day>_<year>.log. If any errors occur, you
can check the log file for more information. This information is also useful if you contact IBM
Corp. for support.

Using licenseactivator with Authorization Codes

licenseactivator is typically used with one or more authorization codes that you received when
you purchased the product. Enter all of the text on one line.

licenseactivator authcode1[:authcode2:...:authcodeN] [PROXYHOST=proxy-hostname]
[PROXYPORT=proxy-port-number] [PROXYUSER=proxy-userid] [PROXYPASS=proxy-password]

Multiple authorization codes are separated by colons (:).
The proxy settings are optional, but you may need them if your computer is behind a proxy.
Which proxy settings are needed depend on the operating system.
Windows. On Windows, the proxy settings work only when the Local Area Network (LAN)
settings in the Internet Settings control panel reference a specific proxy server (host) address
and port. You do not enter the proxy host and port on the command line. But you do need to
enter values for PROXYUSER and PROXYPASS.
Other Operating Systems. On other operating systems, you may need to enter all of the proxy
settings on the command line, depending on your specific proxy configuration.

Using licenseactivator with License Codes

In less common scenarios, IBM Corp. may have sent you a license.

licenseactivator licensecode[:licensecode2:...:licensecodeN]

Multiple license codes are separated by colons (:).
When using license codes, licenseactivator does not connect to the Internet, so you do not
need to specify proxy information.

Installing a License Manually

E Log in as the user who installed the license manager.
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E Open a command prompt and change directories to the license manager installation directory.
Note that this is the directory in which you installed the license manager, not the directory in
which you installed IBM® SPSS® Modeler Text Analytics . If you accepted the default location
on Windows, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS License
Manager\ folder.

E Windows Only. Change directories to the winnt subdirectory.

E Get the lock code for the server machine. At the command prompt, type echoid (other operating
systems) or ./echoid (UNIX).

E Send the lock code and your authorization code to IBM Corp. by calling your local office or
sending an e-mail message to spsscs@us.ibm.com. IBM Corp. will then provide a license code
or a file containing a license code.

E Use licenseactivator to enter the license code or codes.

Enabling for Temporary Usage

If you did not install the license, you can enable IBM® SPSS® Modeler Text Analytics for
temporary usage.

E If you have physical installation media, make sure that the DVD is in the DVD drive. If you
downloaded an eImage, open and/or extract the contents of the eImage.

E Start the WlmAdmin application. For more information, see the topic Starting the WlmAdmin
Application on p. 10.

E In the left pane of the WlmAdmin application, click the + sign next to Subnet Servers. If the
license manager server is not listed, specify the computer by choosing Defined Server List from
the Edit menu.

E Right-click the name of the network computer on which the license manager is running and choose:
Add Feature > From a File > To Server and its File

Note: If you select To Server rather than To Server and its File, the temporary usage information is
stored in memory. You will lose this information when the network computer is rebooted.

E In the Open dialog box, type D:\Sentinel\LicenseManager\lservrc.temp, where D is your
installation disk drive. If you are not using D for the disk drive, enter the appropriate drive location.

E When the application displays your license, click OK. For information about viewing the license’s
details, see Viewing Details about a License on p. 11.

Adding a License

You may want to add a license at a later time. The process for adding a license is the same as
installing the original license.
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Viewing Your License

You can view your network license (including the number of users) in the WlmAdmin application.
For information about the WlmAdmin application and specifics about viewing the license, see
Administering the Network License on p. 10.

Testing the License Manager

To make sure the license manager is serving up licenses correctly, you should test it.

E If you haven’t installed the license manager tools on another machine, install them on a Windows
machine that is not running the license manager you want to test. For more information, see the
topic Installing the License Manager Tools on p. 4 .

E Start the WlmAdmin application. For more information, see the topic Starting the WlmAdmin
Application on p. 10.

E Add the remote license manager server that you want to test. For more information, see the topic
Adding a Server on p. 10.

E View the licenses on the remote server. For more information, see the topic Viewing Details
about a License on p. 11.

If you are able to view the license, the license manager is ready for local desktop computers to
connect to it. You can proceed with installing the product on local desktop computers. If you are
not able to view the license, review the previous steps to ensure the license manager was installed
correctly.

Installing the Product on the Local Desktop Computers
Note: We do not officially support connecting to the network license manager through VPN.

E Make the installation media available. Download the eImage for the product and extract the files to
a shared network drive. If you have physical installation media, make as many copies of the DVD
as you need or place it on a shared network drive.

E Copy the installation instructions and prepare licensing information. Make as many copies of the
product installation instructions as you need. The installation instructions are available from the
download site or, if you received physical installation media, in the Documentation directory on
the DVD. Look for the instructions that correspond to your license type. You can distribute the full
or abbreviated versions of the instructions. After installation, the end user must enter the IP address
or the name of the network computer on which the network license manager is running. Fill out
this information in the space provided at the beginning of the instructions before copying them.

E Distribute the installation materials to end users. Distribute the installation DVD ( or network
location), the installation instructions, and the licensing information to end users who can
manually install on each computer as needed.
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Administering the Network License

The license manager maintains your network license. To administer the license manager itself and
to view information about the network licenses that it is maintaining, you can use the WlmAdmin
application, which is the main user interface for the license manager tools. The license manager
tools are installed automatically with the network license manager on Windows. If you are
administering a license manager on a non-Windows machine or a remote Windows machine,
install the license manager tools on a separate Windows machine. For more information, see the
topic Installing the License Manager Tools on p. 4 .

Note: If you need additional administration information, refer to the SafeNet documentation,
which is installed with the concurrent licensing tools. This documentation is in the
licensemanager/documentation directory in the concurrent licensing tools installation directory.

Starting the WlmAdmin Application

From a Windows Computer where the License Manager is Installed

E From the Windows Start menu, choose:
[All] Programs > Sentinel RMS License Manager > Sentinel RMS Server Administration

From a Windows Computer where the License Manager Tools are Installed

E From the Windows Start menu, choose:
[All] Programs > Sentinel RMS Tools > Sentinel RMS License Server Administration

Adding a Server

Before you can administer a network license manager, you need to add its server to the WlmAdmin
application. You have two options for adding the server.

To Manually Add a Server

E From the WlmAdmin application menus, choose:
Edit > Defined Server List

E In the Defined Server List dialog, enter the name or IP address of the server on which the license
manager is running.

E Click Add.

E Click OK.

The server now appears in the Defined Servers lists in the left pane of the WlmAdmin application.

To View a List of Servers on the Subnet

E In the left pane of the WlmAdmin application, click the + sign next to Subnet Servers.
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A list of network license manager servers on your subnet appears. If you can’t find a specific
server with this method, manually add it as described above.

Obtaining Log Information

If end users have difficulty checking out licenses, the log files may contain useful information.
You can use the LSERVOPTS environment variable and the -f <trace-log-file> and -l

<usage-log-file> options to specify that log files should be created. For more information
about this environment variable and its options, refer to the SafeNet documentation in the
licensemanager/documentation directory in the concurrent licensing tools installation directory.

Viewing Details about a License

You can view details about licenses that you added either manually or through the License
Authorization Wizard.

E In the left pane of the WlmAdmin application, click the + sign next to the license manager server
to see the license(s).

E Click the name of the license. The right pane displays details about the license. Codes are used to
identify the licenses. The first part of the code indicates the feature. The second part indicates
the version.

To See the Names Associated with the Feature Codes

E Using a command prompt, change to the directory in which the license manager or the license
manager tools are installed.

E Type lmshowlic <server> (Windows) or ./lmshowlic <server> (other operating systems), where
<server> is the name or IP address of the server on which the license manager is running.

The output lists all the features available on the server, grouped by product and version.

Setting Up Redundant License Servers

You can set up multiple, redundant license servers that support the same users. Redundant servers
can help prevent any interruption that may occur when a server crashes. Another redundant server
can take over the management of the license when the first server crashes.

You will need a special authorization code to enable the redundancy feature. The authorization
code shipped with the software will not enable redundancy. Be advised that by installing the
code that ships with the software, you will forfeit your ability to use the redundancy feature. If
you wish to enable redundancy, complete the preparation steps described below. Then contact
Customer Service at spsscs@us.ibm.com or call (800) 521-1337 between 8:30 A.M. and 5:00 P.M.
U.S. Central Time. For customers outside of North America, please contact your local office.

There must be an odd number of servers (at least three of them), and a majority must be
running at the same time. For example, if there are three redundant license servers, two of them
must be running.
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To Prepare Each Redundant License Server

E Install the license manager. For more information, see the topic Installing the Network License
Manager on p. 1 .

E Using a command prompt, change to the directory in which you installed the license manager.

E Get the lock code for each server machine. At the command prompt, type echoid (Windows) or
./echoid (other operating systems).

E Write down the lock code. You will need this when you contact Customer Support or your local
office.

E Repeat these steps for each redundant license server.

To Set Up the Redundant License Server Pool

E If a license manager is running on any of the redundant license servers, stop the license manager
on each computer.

E From the WlmAdmin application menus, choose:
Edit > Redundant License File

This action opens the WrlfTool application.

E From the WrlfTool application menus, choose:
File > New

E For each redundant license server, click Add to specify the hostname and IP address of each server.

E Change the order of the servers to indicate the order in which the redundant license servers are
used. The first one in the list is the primary server.

E Click Add License to add the license(s) that you received from Customer Service or your local
office. If you received multiple licenses, be sure to add every one.

E Click OK.

E Click Done when you are finished.

To Save the Redundant License File

E From the WrlfTool application menus, choose:
File > Save As

E Save the redundant license file (lservrlf) to an easily accessible location. You will need to copy the
file in the next steps.

To Configure the Redundant License Servers

E Copy the redundant license file (lservrlf) to the winnt subfolder of the license manager installation
directory on Windows. If you accepted the default location, check the C:\Program Files\Common
Files\SafeNet Sentinel\Sentinel RMS License Manager\ folder. On other operating systems,
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copy the file directly to the license manager installation directory. There must be at least three
redundant license servers.

E Start the license manager on each redundant license server.

To Configure End-User Computers

When the end user installs the product, the user specifies all redundant servers, with the server
names or IP addresses separated by a colon (for example, server1:server2:server3). The setup
program then adds the necessary configuration information to the end user’s computer. If the
product is already installed on the desktop computers, you can perform the following manual steps
to add the configuration information. You can also push an uninstall followed by a new install
that defines all the servers.

E Using a text editor, open spssprod.inf, which is located in the product installation directory on
the desktop computer.

E Comment out the line for DAEMONHOST. For example:

#DAEMONHOST=server1

E Save spssprod.inf.

E Create an LSHOST environment variable. Set this variable to include all redundant servers, with
the server names or IP addresses separated by a colon (for example, server1:server2:server3).

Configuring License Reservations

You can create a reservation file, which specifies how many licenses are reserved for specific users
or groups of users. Users are identified by network IDs or computer names (not IP addresses). For
example, you can set up a reservation file that reserves the license for a group of power users.
Licenses will always be available for these users. You can also use the reservations to prevent
certain users from accessing the license.

To Create a New Reservation File

E From the WlmAdmin application menus, choose:
Edit > Reservation File

This action opens the Wlsgrmgr application.

E From the Wlsgrmgr application menus, choose:
File > New

To Add Licenses and Users to the Reservation File

E From the Wlsgrmgr application menus, choose:
Feature > Add

E Click Next on the first screen of the wizard.
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E Specify the feature code associated with the license that you want to reserve. Refer to Viewing
Details about a License on p. 11 for information about getting the feature codes associated
with licenses. Also define a specific version, which is entered as it appears in the WlmAdmin
application (for example, 160). The version is not optional. Ignore the Capacity controls, because
capacity licenses are not supported.

E Click Next.

E Specify a name for a group of users. The name is arbitrary, but you should make it descriptive
(for example, Sales).

E Specify the number of licenses that are reserved for the group. Group members can still access all
licenses, but the number of licenses you specify will no longer be available for users who are not
included in the group. That is, if you have 10 licenses and you reserve five, members of the group
have 10 licenses available to them, while other users have only five.

E On the Members window, click Add to specify a user or computer name associated with the
group (do not use IP addresses). If the user or machine is included in the group, that user or
machine can use the reserved license. If the user or machine is excluded from the group, that
user or machine cannot access the license at all. Specify as many users or machines as needed.
Note that groups must be mutually exclusive. Therefore, different groups for the same license
cannot contain common users or computers.

E Click Finish when all users have been added to the group.

E Add other groups or licenses as needed. You can also modify or delete licenses and groups by
right-clicking one and choosing Properties.

To Save the Reservation File

E When finished defining the reservation file, from the menus choose:
File > Save As

E Save the file to an easily accessible location. You will need to copy the file in the next step.

E To enable the license server to automatically find the lsreserv file at start up, copy the file to the
winnt subfolder of the license manager installation directory on Windows. If you accepted the
default location, check the C:\Program Files\Common Files\SafeNet Sentinel\Sentinel RMS
License Manager\ folder. On other operating systems, copy the file directly to the license manager
installation directory.

E If you want the same reservations to apply for all redundant servers, copy the reservation file
(lsreserv) to each server.

E Restart each license manager when finished.

Starting and Stopping the License Manager

The method for starting the license manager depends on your operating system.
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Windows

On Windows machines, the license manager is a System Service. The service is automatically
started by default. However, if you need to start it manually:

E In the Windows Control Panel, double-click Administrative Tools.

E Double-click Services.

E Locate Sentinel RMS License Manager in the Services list.

E Right-click the service and choose Start or Stop.

Other Operating Systems

On other operating systems, the license manager is a daemon service. Complete the following
steps to start it manually. You can also configure the license manager to start automatically
(instructions follow).

E Using the command prompt, browse to the directory in which you installed the license manager.

E Starting. As root, type ./lserv & at the command prompt and press Enter.

E Stopping. As root, type ./lsrvdown <hostname> at the command prompt, where <hostname> is the
network name of the computer on which the license manager is running. Then press Enter.

Configuring the License Manager to Start Automatically

Windows

E In the Windows Control Panel, double-click Administrative Tools.

E Double-click Services.

E Locate Sentinel RMS License Manager in the Services list.

E Right-click the service and choose Properties.

E Set the Startup type to Automatic.

E Click OK.

Other Operating Systems

E Add ./lserv & to one of the operating system startup files.

Uninstalling the License Manager

Windows

E From the Windows Start menu, choose:
Settings > Control Panel
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E Double-click Add/Remove Programs.

E Select Sentinel RMS License Manager and then click Remove.

E Click Yes when prompted to remove the license manager.

Other Operating Systems

E Using the command prompt, browse to the directory to which you installed the license manager.

E As root, stop the license manager by typing ./lsrvdown <hostname> at the command prompt,
where <hostname> is the network name of the computer on which the license manager is running.
Then press Enter.

E Remove the directory where the license manager is installed.

Uninstalling the Concurrent Licensing Tools

Windows

E From the Windows Start menu, choose:
Settings > Control Panel

E Double-click Add/Remove Programs.

E Select IBM SPSS Concurrent Licensing Tools and then click Remove.

E Click Yes when prompted to remove the concurrent licensing tools.

Other Operating Systems

E Remove the directory where the concurrent licensing tools are installed.

Troubleshooting Desktop Computers

If the end users’ desktop computers are having trouble finding the license manager:

E Run lswhere to verify that the desktop computer can find the network computer on which the
license manager is running. For more information, see the topic Running lswhere on p. 17.

E Make sure the license manager service is running on the network computer.

E Check the appropriate spssprod.inf file. This file is located in the product installation directory
on the desktop computer. Open spssprod.inf and make sure DAEMONHOST is set to the correct
name or IP address of the computer on which the license manager is running. If you are using
redundant servers, this should be blank.

E If you are using redundant servers, make sure the LSHOST environment variable defines all of them.
Each name is separated by a colon (:) character. For example, if the license manager computers
are SERVER1, SERVER2, and SERVER3, LSHOST is set to SERVER1:SERVER2:SERVER3.
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Running lswhere

You can run lswhere from an end user’s desktop computer to check which computer is running the
network license manager.

E Using a command prompt, change the current directory to the IBM® SPSS® Modeler Text
Analytics installation directory.

E Type lswhere.

Defining Environment Variables on End Users’ Computers

The following instructions are for defining environment variables on end users’ computers.

To Define an Environment Variable on Windows 2000/Windows XP/Windows 2003

E In the Windows Control Panel, double-click System.

E Click the Advanced tab.

E Click Environment Variables.

E In the System Variables area of the tab, click New.

E In the Variable Name text box, type LSHOST.

E In the Variable Value text box, type the name or IP address of the computer on which the license
manager is running—for example, myserver or 204.171.64.2.

E Click OK.

Service and Support
To contact IBM Corp. Technical Support, visit http://www.ibm.com/support and submit a case.
You will need to register with IBM Corp. Technical Support if you haven’t done so previously.

IBM Corp. provides public training seminars for IBM Corp. products on a regular basis. You
can also arrange to have training presented onsite. For information on training seminars, visit
http://www.ibm.com/training/spss.

http://www.ibm.com/support
http://www.ibm.com/training/spss
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