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Agenda

• Overview

• UI modernization

• New Features

• Questions?



© Copyright IBM Corporation 2021

3

Strategy changes in the last year (“Take aways”)

• Improved performance, stability and usability

  - Collections caching

  - Consistency in drill-down flow

  - Running SQL in the background 

• Modernizing the UI experience

• Removing functions that are not used and simplifying the rest 
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Overview

• iDoctor is a suite of dynamic performance tools offered by the IBM i Global 

Support Center and sold via Technology Services.

• We cover most areas of performance on IBM i.

• Been around for roughly 24 years.



© Copyright IBM Corporation 2021

5

Dynamic on demand

• iDoctor was created primarily to help IBM support solve performance problems.

• Working on unique customer problems required ability to make changes to 

analysis tooling more quickly than at release boundaries.

• Feedback from users also drives enhancements, but our #1 focus remains on 

helping support help you.
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Grouped MDI 

• iDoctor uses a multiple document interface with Grouped mode by default.

• The tabs / views can be moved into new vertical or horizontal tab groups.

• Drag and drop will create these too.

• By default, 1 view shown at a time.
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Standard MDI 

• Some users prefer this style of interface where each view can be resized individually, maximized, minimized or 

tiled.

• This mode also features a caption bar per tab/view.
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Modal interfaces vs Panes

• A modal popup interface is one where you must finish a task before returning to the previous window.  

• This is why panes were added to make completing common tasks faster by avoiding extra steps.

• We also use tabbed panes to show appropriate content for the interface you are currently using.
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All Wizards are non-modal

• Since modal interfaces tend to restrict use, all Wizards are non-modal and act like a 

tab/view.

• Wizard navigation buttons were moved to the top.
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Property Sheets

• Property sheets are used for things like Libraries, Collections and Preferences.

• Buttons are up top now.

• Most are non-modal now.
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UI modernization (1/2)

• Custom font support

• Auto resize controls options

• MDI Tabbed Styles updates

 

• Panes

• Replaced message boxes with message bars.

• New toolbar buttons
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Custom font support

• Uses the windows default font (Segoe UI – 9) but adjusts based on windows 

scaling.

• Change font size or settings with these toolbar buttons:   

• Can also use Ctrl + or Ctrl - to change font size.

• Most of the GUI will honor the setting except:

1. Popup message boxes (disabled by default)

2. MDI tab flyovers (disabled by default)

3. Menu bars don’t update immediately until a Data Viewer is opened.
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Resize controls

• If enabled, GUI elements (controls) will resize when windows resize.  See 

Preferences -> Resize tab or View -> Resize Controls menu to configure.

• Resize controls has 4 options and the % value is how dramatic the resize should 

be:

1. Minimally (20%)  - Default  Requires a font size of 12 or less.

2. Compact (33%) – Requires font size of 14 or less.

3. Standard (50%) – Font size 16 or less.

4. Full (100%) – Font size 17+

• If Minimally still resizes too much you can use the override option on Preferences 

-> Resize.  Minimum value is 2%.

• A few interfaces don’t support this yet.  
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MDI Tabbed Styles 

• This defines the style of interface used.  (See View -> MDI Tabbed Style menu)

• MDI Tabbed Style None (Classic MDI) removed.

• Grouped (the default) or Standard can be used.

• New toolbar buttons can help you switch between Standard or Grouped for 

different types of scenarios and remembers the previous layout. 

1. Grouped mode - New vertical tabbed group 

2. Grouped mode – New horizontal tabbed group

3. MDI Style Grouped 

4. Standard mode – Tile Horizontally

5. Standard mode – Tile Vertically
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Tabbed Panes

• Panes now use tabs, meaning only 1 is shown at a time.

• They help with switching tasks more quickly, like viewing perf data, active jobs, 

IFS, or objects.

• These automatically hide/reappear if you use F11 (full screen mode)
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Libraries Pane

• A shortcut to get into the desired performance data.

• Include old data checkbox can be used to show/hide data older than 1 year.  Use 

Preferences -> Display -> Old at N months option to change the threshold.

• Verify procs should be checked if moving to a new GUI build, at least temporarily 

or reinstall server builds.

• Tip: Use Tables, IFS, Objects or Active jobs panes to get into IBM i Explorer.
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Find Pane

• This help you find something on the screen and cycle through the results.

• Works for tables, graphs, graph legends, SQL editors.

• Can’t be used in trees or modal interfaces.



© Copyright IBM Corporation 2021

18

Find Pane – Type ahead support

• If you want to find something in a list, follow these steps:

1. Click on list.

2. Start typing something.

3. Find pane will automatically appear.   

4. Press enter to search.  

5. Press enter again to cycle through results (if applicable.)
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Message bars (1/2)

• ALL windows contain a message bar at the top of each interface.

• Replaces popup message boxes and also gives status of operations.

• Blue highlight color is used when asking questions.    

• Yellow background color means something is running.
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Message bars (2/2)

• Dark grey color background is just an informational message or error.

• On errors, the control with an issue is highlighted (light blue).  
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Toolbar button – Select Fields

• This modifies the columns shown by default for the current folder.

• Shown in Main Window toolbar for the component views only.
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Toolbar button – Find Pane 

• This opens the Find Pane.
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Toolbar button – Copy Window 

• This copies the current interface to the clipboard.

• Also available under Edit -> Copy Window menu.

• Only works for tables (lists) and property pages.

• 3 formats are copied to clipboard TXT (or CSV), RTF and HTML.

• Up to target app to decide format to use.

• See Preferences -> Clipboard for options.
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Toolbar button - Full screen mode (F11)

• If enabled these things happen:

 - Maximizes the window

 - Autohides the panes

 - Hides the status bar

• Also available under View -> Full screen menu.

• Some settings to control behavior are under Preferences -> Resize.
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Toolbar button – Merge Groups (F12)

• When using Grouped MDI only, consolidates all views into 1 row/group.

• Useful if you wish to switch a view to full screen mode.

• Currently this does not toggle back to restore the previous layout.
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Toolbar button – Maximize List (F9)

• This option will toggle a list to take up the entire view.

• Only applies to property sheet interfaces. (i.e. JW – Interval Details – Call stack)
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Toolbar button – Show previous/next tab 

• This moves to the previous/next tab in the current tabbed group.

• Show previous tab shortcut:  Ctrl+Shift+Tab

• Show next tab: Ctrl+Tab

 

• Works for both Grouped and Standard MDI modes.
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Toolbar button – New vertical group (Ctrl+Shift+V)

• This moves the current view into a new vertical tabbed group.

• Useful when you want to compare something or better utilize screen space. 

• Grouped MDI mode only
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Toolbar button – New horizontal group (Ctrl+Shift+B)

• This moves the current view into a new horizontal tabbed group.

• Useful when you want to compare something or better utilize screen space. 

• Grouped MDI mode only

 



© Copyright IBM Corporation 2021

30

Toolbar button – Move to previous group (Ctrl+Shift+P)

• This moves the current view back to the previous tabbed group.

• Grouped MDI mode only
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Toolbar button – Move to next group (Ctrl+Shift+N)

• This moves the current view to the next tabbed group.

• Grouped MDI mode only
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Toolbar button – Tile Horizontally 

• This switches to Standard MDI mode and rearranges windows in a horizontal 

layout.

• Available from both Grouped/Standard MDI modes.

• Also available under Window -> Tile Horizontally 

• If more than 6 views exist, only 1st 6 are tiled. Note: In the future, this will change 

to 4 max but has not yet been changed.

• This ignores any minimized views.
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Toolbar button – Tile Vertically

• This switches to Standard MDI mode and rearranges windows in a vertical layout.

• Available from both Grouped/Standard MDI modes.

• Also available under Window -> Tile Vertically

• If more than 6 views exist, only 1st 6 are tiled.   Note: In the future, this will change 

to 4 max but has not yet changed.

• This ignores any minimized views.
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Toolbar button – MDI Style Grouped 

• This switches to Grouped MDI mode and restores the previous grouped mode 

layout.

• Available from Standard MDI mode only.

• Also available under View -> MDI Tabbed Style -> Grouped menu.
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UI modernization (2/2)

• DPI - windows scaling support

• Tab previews

• PDF support (situations, spool files)
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DPI – Windows scaling support

• GUI updated to detect and auto update based on windows scaling changes.

• Dragging a window from one monitor to another works better.

• Large icons will be used if scaling is >= 175%.   See View -> Icon Size menu to 

override this behavior. 

• Scroll bars will appear if property sheets are cut off.

• Not perfect; more work remains.
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Tab previews

• When mouse is over a tab, these appear to show you what is behind that tab/view.

• Screenshots saved to %AppData% folder.

• Customize these under Preferences -> Display.

• Not shown for the current view.
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PDF support

• Double-click a situation to view a PDF. (collection properties or graph legend)

• Spool files can be downloaded / viewed as a PDF.  (7.3+)
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Graphing updates 

• View -> Graph title format menu

• View -> Graph margin % menu

• View -> X-axis menu

• Legend updates

• Widget size

• Zoom in/out 
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Graph Title Format

• Available under the View menu or Preferences -> Display.

• Now supports multiline graph titles.  CR designates a new line.   3 lines max.
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View -> Graph Margin % menu (1/3)

• Available under the View menu only.

• This controls how much white space is around the X/Y axis labels.   Higher % means more 

white space.  Default is 80%.

• Smaller value increases the size of the graph itself by sacrificing space in the label area.

 



© Copyright IBM Corporation 2021

42

View -> Graph Margin % menu (2/3)

• 100%
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View -> Graph Margin % menu (3/3)

• 60%
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View -> X-axis menu

• These options let you decide what appears on the X-axis labels on graphs.

• Tips are the single character flags that appear in JW/CS graphs to tell you what exists in the data. (i.e.  

H = Holder)

• Note: These options modify the SQL statement, so reopening the graph after making changes is 

required.
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Graph legend updates 

• Double-click a situation shows a PDF with more detail.

• Widgets drawn in legend now.  Set widget size under Preferences -> Display.

• Added find support for legend or graph itself (drawn label text only.)
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Graph widget size

• These are the small characters drawn on Y2 lines to help distinguish them.

• See Preferences -> Display -> Widgets and (Widget) Size settings.
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Zoom in / out

• Hold down left mouse button and drag over an area to zoom in.  You can do this multiple times.

• Zoom out via this toolbar button or Alt+Z keyboard shortcut.
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General changes summary (1/2)

• Crash management

• Select all and Select all visible

• JW – call stack report drill downs

• Data Viewer View menu updates 

• Connection status view
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Crash management

• In the past year, improved usability by analyzing and fixing several crash bugs.

• Crash dumps can be analyzed if sent to me at idoctor@us.ibm.com

• See Preferences -> Misc -> Copy crash dumps setting.

 

mailto:idoctor@us.ibm.com
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Select All (Ctrl+A)

• This is used to select all rows in a table, or all bars in a graph.

• Available from the Edit -> Select All menu or use the keyboard shortcut.
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Select All Visible (Alt+A)

• This is used to select all currently visible rows in a table, or bars in a graph.

• Useful on a graph after zooming in, prior to drilling down.

• Use the Edit -> Select All Visible menu or keyboard shortcut.
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Job Watcher interval details - QRO hash/Plan ID/Client Job

• Changed the SQL client job label to be a drop-down list to let you choose which to see of:

• SQL client job, Plan ID, QRO hash or QRO + plan ID

• Note: Drop-down list only enabled if more than 1 choice exists.   If nothing exists, it won’t appear at all.

• Plan ID requires PTFs at 7.4+ (not yet released).
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Job Watcher call stack report drill downs

• Select a single level options:

1. Trace back table (TBT) address + offset 

2. TBT address only

• Select multiple call levels option:

1. Multiple TBTs
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Letting non-*ALLOBJ users use iDoctor

• More work remains in the installer to create more files/objects to make this easier. 

• The installer does not create the monitor files QUSRSYS/QAIDRJWM2 for 

example but will in the future.

• See FAQ 4.8:

• File list in speaker notes.

https://public.dhe.ibm.com/services/us/igsc/idoctor/html/iDoctorFAQs.pdf
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Data Viewer View menu updates

• Some options do not appear in preferences.
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Connection Status View

• Identifies iDoctor connections in use.

• Use Main Window -> View -> Connection Status menu.

• Status bar identifies connection for the view with focus and how long idle.
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Connection Indexes Used by iDoctor

• List applies to ACS RC/ODBC connections only.

• These threads help avoid hangs and improve usability but can take 

1-8 seconds to kick off depending on how slow your network 

connection is to the IBM i.

• With 1732 or higher, connections 10, 20, 30, 3, 2, 102 are pre-

created in the background (in that order) when creating a 

component view.

• Avoid using the same connection at the same time, or you will hang 

until things complete. 

 - Resorting/rerunning multiple already open views can cause this.

 - Use a new DV to avoid this.

Index Description

0 Main GUI thread

1, 101, 201, etc. Component views

2 Remote command status

102 Remote SQL statement 
status

3, 103, 203, etc. Interval Details, Interval 
Summary interfaces 

10, 20, 30, etc. Data Viewer (DV) 
graphs/tables

11-19, 21-29, 31-39, etc. DV if 10, 20, 30, in use.
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Questions?

• Let me know what questions you have? 

• Or I will be at ask the experts later and we can chat or demo something then.

• You can reach me at either idoctor@us.ibm.com or mccargar@us.ibm.com

• Thank you!

 

mailto:idoctor@us.ibm.com
mailto:mccargar@us.ibm.com
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Links You Need Twitter #Hashtags

IBM i Home Page:    https://www.ibm.com/it-infrastructure/power/os/ibm-i

IBM Strategy Whitepaperhttps://www.ibm.com/it-infrastructure/us-
en/resources/power/i-strategy-roadmap/

IBM Client Success:   https://www.ibm.com/it-infrastructure/us-
en/resources/power/ibm-i-customer-stories/

Support Life Cycle:   https://www.ibm.com/support/lifecycle/

License Topics:   https://www-01.ibm.com/support/docview.wss?uid=nas8N1022087

Fortra 2024 Marketplace Survey

https://www.fortra.com/resources/guides/ibm-i-marketplace-survey-results

@IBMservers
@COMMONug

@IBMChampions
@IBMSystemsISVs

@LinuxIBMMag
@OpenPOWERorg
@ITJungleNews 

@SAPonIBMi
@SiDforIBMi

@IBMAIXeSupp
@IBMAIXdoc

#IBMPower
#IBMi

#IBMAIX
#Power10

#LinuxonPower
#HANAonPower
#ITinfrastructure

#OpenSource
#HybridCloud

https://www.ibm.com/it-infrastructure/power/os/ibm-i
https://www.ibm.com/it-infrastructure/us-en/resources/power/i-strategy-roadmap/
https://www.ibm.com/it-infrastructure/us-en/resources/power/i-strategy-roadmap/
https://www.ibm.com/it-infrastructure/us-en/resources/power/ibm-i-customer-stories/
https://www.ibm.com/it-infrastructure/us-en/resources/power/ibm-i-customer-stories/
https://www.ibm.com/support/lifecycle/
https://www-01.ibm.com/support/docview.wss?uid=nas8N1022087
https://www.fortra.com/resources/guides/ibm-i-marketplace-survey-results
https://twitter.com/ibmservers?lang=en
https://twitter.com/COMMONug
https://twitter.com/IBMChampions
https://twitter.com/IBMSystemsISVs
https://twitter.com/LinuxIBMMag
https://twitter.com/OpenPOWERorg
https://twitter.com/ITJungleNews
https://twitter.com/SAPonIBMi
https://twitter.com/SiDforIBMi
https://twitter.com/IBMAIXeSupp
https://twitter.com/IBMAIXdoc
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