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Abstract  

This document attempts to summarize the changes made to iDoctor and provides links 
to download both client + server levels for each major iDoctor release for client builds 
1268 and higher. 

 

For more details, please visit the update history within the iDoctor GUI under the Help -> 
Update History menu. 
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iDoctor Updates Summary 

Note: Click on the date – build # link to download 

June 17th, 2025 - Client 1785 + server builds 

• Made updates to reduce flicker and fix drawing issues. 

• Added a List Max Size preference under Preferences -> Resize to help avoid overlapping 
scrollbars. 

• Compare mode updates. 

• Added a check and idle messaging that user is connecting with CCSID 37. 

• Added a Check Truncation setting for Table views.  Use View -> Tables -> Check Truncation 
to toggle on/off as desired. 

• Added options to use Graph Jobs to graph by Thread, Job, Generic Job, Current user or 
Subsystem. 

• In Plan Cache Analyzer added support to Split or Search by program name. 

• In CSI added new Communications -> HTTP graphs. 

• Updated graph definition properties. 

• Added a Join function under the Window menu to merge 2 tabs into 1. 

• Fixes for flattened style graphs if trying to sort or filter. 

• Added new right-click options for tables. 

• Added an Indexes Pane. 

• Added more indexes to the Collection Summary in JW/CSI. 

• Flyovers in lists are now tied to the status bar. 

 

April 18th, 2025 - Client 1776 + server builds 

• Added 7.6 server builds. 

• Updated Clients + Workers analysis support in Job Watcher. 

• Resize Controls support can no longer be disabled.  Added a Minimally 2% option instead. 

• Removed the PAD SQL function.  Analyses changed were: NMON, CS Job Summary and 
Run All Default Analyses. 

• To do the Copy Screen function (take a screenshot of the current window) you can use 
CTRL+SHIFT+C 

• Corrected several SQL issues in CSI graphs. 

• Collection “Old” status fixes. 

• Bookmark fixes. 

• Replaced Cut/Copy/Paste in IBM i Explorer with Copy and Move. 

• Keyboard shortcut fixes for text boxes in Panes. 

 

March 19th, 2025 - Client 1770 + server builds 

• Redesigned the reconnect mechanism when connection lost. 

• Updated SQL canceling behavior to help avoid crashing, especially in property sheets. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01785.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01776.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01770.exe
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• Added support to define Bookmarks which act like a shortcut for a particular interface or 
menu option.  These replace the Copy URL function and can be added using the Edit -> Add 
Bookmark menu, toolbar button or Add Bookmark popup menu.  The shortcut key for this is 
CTRL+D.   

• Updated about half the JW situations to improve performance. 

• Renamed the Libraries Pane to Filter and added additional components to the drop-down list 
to perform filtering more consistently across all the components. 

• Various crash fixes. 

• Added a Reports component to show Generate Reports results via the Filter Pane. 

• Generate Reports will now automatically try to send reports generated to the IFS under 
/QIBM/UserData/iDoctor/reports.  If you don’t want this to happen, uncheck the Preferences -
> Generate Reports -> Upload to IFS option. 

• Find Pane improvements and Use SQL option. 

• Preferences -> SQL QAQQINI changes. 

• Fixed Record Position Indicator in the toolbar of the Data Viewer. 

• In JW under the Waits -> Dispatched CPU rankings graphs added 2 new grouping options:   
By client thread or By worker thread but only if the Clients + Workers analysis has been ran. 

• Added a Duplicate options for Graphs and Tables and under the Find Pane. 

• IBM i Explorer -> Power functions have moved into a new Nmon component. (via the Filter 
Pane) 

• Added keyboard shortcuts to open the table below the graph (CTRL+T) or SQL Editor 
(CTRL+E) 

• Added a Session History interface that allows you to review past actions in the GUI, 
depending on which tab preview filters have been enabled.  Access the interface via the Filter 
Pane. 

• Plan Cache Analyzer interface fixes. 

• Graph Jobs interface fixes/improvements. 

 

January 22nd, 2025 - Client 1759 + server builds 

• Resize controls improvements 

• Save -> View As renamed to Export. 

• Copy/export fixes and added Copy Screen option. 

• Added context sensitive tips in the status bar for most controls, menus and interfaces.  If you 
prefer these, use Disable GUI tips checkbox from Preferences -> Tips to avoid popup tooltips. 

• Added options to control mouse-wheel scrolling speed under Edit -> Mouse-wheel scroll 
speed. 

• Tab preview behavior fixes. 

• Added checks that iDoctor.exe file version matches iDoctorMRI.dll to avoid potential issues. 

• Improvements for batch download/upload messaging when using Wininet. 

• Added context menus for caption bars. 

• Added PTF checking for Plan Cache Analyzer from IBM i Connections view. 

• CSI – Disk free space map graph minor fixes. 

• Fix for GDI memory % and updated Ready status warning message if not set to Windows 
max value. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01759.exe
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• Added scrollbar support for Wizards.  

• Added additional options under the View menu to tweak preferences. 

• Removed “Show property sheets in a view” Preference.   

• Fixed issues with sync scrolling data in the table below the graph. 

• Updated legend toolbar button behavior. 

• Added Bars toolbar button to control bars per page or tweak the preference. 

• Added a PEX QAYPERUNI file check to ensure it only contains 1 record.  If not a “Data 
dumped twice status” will appear for the collection. 

• Fixed message bar bugs especially if asking questions from a Modal Dialog. 

• Job Watcher collection search now offers QRO hash (7.2+) and Plan ID (7.4+) options. 

• The check for ACS Windows application packaged moved to the installer.  The GUI won’t run 
without it. 

• Updated drop down lists so that data isn’t truncated if the width of the control is too small. 

• Updated the Window Manager with more options to control which Windows appear and better 
use the compare mode/sync options. 

• Added Find Next (F3) and Find Previous (SHIFT+F3) keyboard shortcut support. 

• Fixed bug relating to 1st click on caption bar buttons not working. 

• Added Max tabs to Tile preference. 

• Improved tooltips in graphs. 

 

 

 

October 11th, 2024 - Client 1741 + server builds 

• Crash fixes (Remote SQL Statement Status and JW Interval Details -> SQL / Client) 

• Changed column orderings for lists of libraries / collections in the component views. 

• Fixed issue where Select Fields interface did not preserve changes between sessions. 

• Added “Max tabs to tile” setting in Preferences -> MDI Tabs for Tile Horz/Vert. 

• Fixes for Change Password interface or signing on then canceling. 

• JW split collection fix (requires updated server builds) 

• JW Interval Details -> SQL client job label replaced with QRO hash, plan ID, SQL client job 
drop down list based on what’s in the data. 

• Graph legend will now indicate if something has changed. 

• Wait Bucket Preferences removed 

• Add Filter interface fixes 

 

September 18th, 2024 - Client 1737 + server builds 

• Program flyovers now includes XPF component information. 

• Added support to precreate 3 DV connections in background when opening component view. 

• Added more flyovers to CSI/JW and a Graph Flyovers Preferences tab. 

• Fixed tooltip truncation issues. 

• Resize controls now adjusts based on the font size.    

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01741.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01737.exe
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• Added better error handling for PEX PDIO and the QAPMHDWR file. 

• Removed resizable width/height preferences. 

• Libraries couldn’t show more than 200 collections and is fixed. 

• Fixed problems with remembering window positions incorrectly. 

• Replaced message boxes with a message bar. 

• Added tab preview support. 

• Crash fixes. 

• Added a table in the Collection Summary analysis in JW/CSI to speed up the interval 
summary interface.  

• Data pane enhancements 

• Toolbar buttons to make it easier to move views around or switch between Grouped or 
Standard MDI. 

• Added Full screen mode, Maximize List and Merge Groups toolbar buttons. 

• Added Verify procs option to the Libraries pane to optionally improve performance at startup. 

• Copy to clipboard improvements and added a Copy Window toolbar button. 

• Multiple monitors with mixed DPI (Windows Scaling) settings fix. 

• Added resize controls support to more interfaces. 

 

June 6th, 2024 - Client 1709 + server builds 

• Added custom font support in more locations (caption bars, tooltips).   

• Crash fixes. 

• Resize controls is now enabled by default and added support for this in additional interfaces.  
Also added options under View -> Resize Controls menu. 

• Fixed maximize bug if using a secondary monitor and the window exceeding the monitor’s 
space. 

• The Power Connections interface has been removed due to lack of use.  Support to view 
nmon data remains but only via the IBM i Explorer -> Power folder under one of the IBM i 
components.  

• Added find support for graphs and the graph legend. 

• Added multiline graph titles support. 

• Added a View -> Graph Margin (%) option in the Data Viewer. 

• Situations toolbar button in the Data Viewer added to control whether situations are shown in 
the current DV. 

• Added more DPI improvements, but more work remains. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01709.exe
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April 4th, 2024 - Client 1688 + server builds 

• Cleaned up error handling and status message handling in graphs/tables. 

• Crash fixes. 

• Added custom font support for tabs and menus.  The only piece remaining are dialog/frame 
window title bars. 

• DPI improvements for icons, but more work remains. 

• Color customization added under Preferences -> Fonts. 

• JW call stack report changes to add offset option. 

• View -> X-axis menu option in Data Viewer added with Dates, Milliseconds and Tips. 

• Multiple collection design change: only drill-down reports that support multiple collections are 
shown if multiple collections selected. 

• Autohide preference added for Panes under Preferences -> Display – Advanced. 

 

March 4th, 2024 - Client 1675 + server builds 

• Made improvements to the Find pane interface, although this is still new and a work in 
progress.  Let us know what else you’d like to see added. 

• Fixed several potential crash issues and added support to manage crash dumps in 
Preferences -> Misc.   

• Added more graph view preferences in Preferences -> Display.   

• Fixes for the Edit -> Reset Preferences menu from the Main Window. 

• Title preferences apply to everyone now.  Previously there were differences between IBM 
users and external users. 

• Added a “Recreate stale connections” option under Preferences -> Misc. 

 

Feb 15th, 2024 - Client 1666 + server builds 

• Made enhancements to improve usability with 4K monitors.  This includes better font 
customization and options to resize controls if windows are resized larger/smaller.  Also resized 
all GUI interfaces to use more consistent spacing.   

• Added a Fonts tab to Preferences.  This allows a user to use default windows fonts (which is the 
new default setting.) 

• Added toolbar buttons to increase/decrease the current font size on the Main Window. 

• The GUI is now coded with Visual Studio 2022.  This requires the appropriate MS redistributable 
package.   The installer is not yet updated so still requires the VS 2012 redistributable. 

• Replaced the Find interface and moved this into a Pane. 

• Fixed problems with the Add Filter window. 

• Added a scroll position indicator in graphs when moving through the data in a table below it. 

• All iDoctor shipped *FILE objects and libraries are now shipped with *PUBLIC *EXCLUDE 
authority.  This may cause issues which will need to be resolved by reporting them to 
idoctor@us.ibm.com.  Authority may need to be granted manually for now.   

• The number of selected rows will be included in the status bar on the last pane on the right in 
parentheses. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01688.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01675.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01666.exe
mailto:idoctor@us.ibm.com
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• In JW, interval details – call stack screen, the message indicating the reason the stack was 
collected has been removed since the support is broken in the OS.  (ADDJWDFN – WAITSTK 
parm) 

• Improved performance when scrolling through tables. 

• Remove the Cancel options in the Remote Command Status View due to potential crash issues 
(for now.) 

• Moved saved iDoctor passwords and debug log files from %temp% to Windows 
%AppData%\IBM\iDoctor.  Also added logic to only keep 100 max log files by default. 

• Fixed issues with recovering from lost connections and garbage text in tables. 

• Added back in the remembering of last used window sizes and locations and fixes issues with 
that. 

• The PEX Filter Wizard has been removed. 

• Encountering an ODBC function sequence error will no longer drop the connection and 
reconnect.  This is also now a preference on the SQL tab if this causes issues. 

• Tooltip visible time increased in preferences from 5 to 10 seconds by default.  

• Removed several preferences (see the update history for details.) 

• Added new JW situation “Program object might be full” 

• In the Data Viewer under View, there are options to change the graph title format now. 

• The status bar will now show connection information behind the view you are currently using.  

• Added more messaging while things are happening such as fetching data, resizing columns, 
reconnecting, etc. 

• The Libraires Pane now has a collection name filter option.  This only works against data in the 
collections database. 

• In the Data Viewer, you can right-click tabs to copy or move them to another Data Viewer. 

• Hold down CTRL or ALT while opening a graph or table will open this in a new Data Viewer. 

• In the Main Window under Edit menu added options to Reset Preferences. 

• In JW, the Clients + Workers analysis is now optionally ran and separate from the Collection 
Summary. 

• In the JW/CSI the Collections folder has been removed. 

• In JW, the Collection Summary will automatically replace bad IFS data with all 0s, if the required 
PTF is not installed at 7.5 

• Added a preference in Misc tab to control how analyses are sorted. 
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Sept 19th, 2023 - Client 1641 + server builds 

1. Made additional updates to the Data ready column in CSI/JW. 

2. In PEX, the activation groups analysis has been divided into 2. 

3. In PEX, added additional call stack detail reports in all analyses where available. 

4. Added PEX Analyzer documentation on our website at: 
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDoctor_PEX.pdf 

5. Fixed nmon import problems when data has SEA stats. 

6. Made CSI JVM graph changes. 

7. In CSI added Active threads, Threads created graphs under the Job counts folder. 

8. In CSI more fixes for the RUNTIME calculation in ranking graphs. 

9. In JW, added the Holder chase analysis. 

10. In JW, added 3 new situations. 

11. Double-clicking a situation in the graph legend now shows a PDF. 

12. Added FTP Definitions support and updated the monitor commands to utilize them to send data 
captured to another LPAR you define. 

13. The Tables folder/pane replaces the Open File/Member window. 

14. Removed the Tables metrics support (under DB2 for i.) 

15. The Filter Libraries pane replaces the Filter Libraries window/menu. 

16. Fixes in Graph History. 

17. Fixes in the Active Data, Active Job functions. 

18. Moved the Record Quick View popup menu option under View in both the Main Window and Data 
Viewer. 

19. Added Check -> QMGTOOLS options under the IBM i Connections View to check current version 
and also perform PTF checking. 

20. Added an option to turn off use of cwblogon to avoid passing the password in clear text (under 
the covers in a hidden Windows command prompt) in the IBM i Connections View.  Use the 
Password cache-> Disable for all systems menu. 

21. Added a few videos to the ftp site under here:  
https://public.dhe.ibm.com/services/us/igsc/idoctor/videos/ 

 

 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01641.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01641.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDoctor_PEX.pdf
https://public.dhe.ibm.com/services/us/igsc/idoctor/videos/
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Note: Click on the date – build # link to download 

May 26th, 2023 - Client 1615 + server builds 

1. At startup if critical stored procedures are replaced, then the collection repository will be cleared 
to avoid potential issues.  To rebuild contents, you may need to refresh it manually using the 
Collections database -> Refresh all menu from the Job Watcher or Collection Services 
Investigator icon if you want the new columns in the list of libraries to be filled correctly.  

2. Added additional columns to the list of libraries in JW, CS and PEX from the collection repository.   

3. Added a Data ready column in the list of collections to indicate which special types of data exist in 
the collection.  Also moved several of the less often collected data types from the Status column 
to the Data ready column 

4. Replaced CSI Historical Summaries with Graph History support at 7.3+.  Note: There are 
problems with the data that will need fixed in the OS which are noted where applicable in the list 
of graphs. 

5. Changed default time grouping (clock icon) from 1 minute to collected interval size. 

6. Renamed Entitled CPU to Dispatched CPU active.  Job virtual CPU delay is now called 
Dispatched CPU wait. 

7. Made improvements in the Transfer collection support (to optionally use 
QMGTOOLS/FTP2IBMCMD) 

8. Added JW SQL PDIO and clock time graphs back into iDoctor.  This requires 7.3+ and the latest 
JW PTFs.    

9. Job Watcher Holder chase options added to go up to 15 levels deep. 

10. Added option / fixes to be able to retrieve the full SQL statement correctly in both Job Watcher 
and Plan Cache Analyzer.  In JW, double-click on the SQL statement from the SQL/Client tab to 
retrieve it if it is truncated. 

11. Improved auto refresh of collection list after analysis finishes running.   

12. Added checks to avoid doing an extra SQL statement (to count number of records returned) in 
most cases for overview graphs in CSI, JW and DW. 

13. Added a new JW situation "Data queue auto reclaim may be causing poor performance". 

14. WRKOBJLCK Pane renamed to Object lock info.  It appears automatically when using the 
General functions -> Work management -> Object lock info folder. 

15. WRKOBJ pane renamed to Objects and is used to do filtering in IBM i Explorer/General 
Functions for the Libraries and Objects folders. 

16. WRKLNK pane renamed to IFS and appears automatically when using the IFS folder under 
General Functions. 

17. Added options to grant authority to use iDoctor under General Functions -> System -> User 
profiles. 

18. Generate reports can now work against user-defined graphs and reports. 

19. Added buttons in the Data Viewer to move to the next or previous collections. 

20. Added options to control graph titles based on the graph type under Preferences -> Display. 

 

 

 

 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01615.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01615.exe
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Note: Click on the date – build # link to download 

February 21st, 2023 - Client 1589 + server builds 

1. SQL preferences min/max fetch size reduced to 200 due to a bug in the ODBC driver. 

2. Default GUI install location is now C:\iDoctor\<CNNNNN> where the subdirectory is the build 
number being installed.  

3. In the installation, added more SSH options for sending the SAVFs to the IBM i (use Putty or 
Windows SCP.exe) 

4. Created a new component called Knowledge Base to help with saving information like graphs, 
call stacks or other screenshots and reviewing it later.  Those features are offered “as-is” and are 
not officially supported.  TIP:  Default system (checked) in your list of IBM i Connections is the 
current Knowledge Base system. 

5. In Job Watcher, created an analysis called Active Collection Summary that lets the user run the 
collection summary analysis alongside an actively running collection.  Also updated the 
STRJWMON command at 7.3+ to optionally use this feature. 

6. Made fixes relating to component view virtual list support.  Keep in mind to scroll through these 
interfaces when dealing with large numbers of rows you must use the list side and not the tree 
side. 

7. Replaced Dispatched CPU wait bucket in CSI/JW with Entitled CPU and virtual CPU delay if 
report visibility setting is Advanced.  Removed Dispatched CPU breakdown graphs. 

8. Added Top 10 and Top N right-click comparison options from the Job Summary folder SQL table 
outputs.  Removed Comparison Wizard support due to lack of use. 

9. Removed VP_PCT “VCPU delays as a percentage of Dispatched CPU (%)” field from secondary 
Y-axis wait bucket graphs in JW/CSI. 

10. Added several additional columns to JW Job Summary SQL tables and fixed problems with some 
metrics being added up incorrectly. 

11. Removed instructions per second graphs in CSI. 

12. Fixed problems with PEX TPROF trees. 

13. Replaced Transfer to -> PC menu with Download. 

14. Added a Clear option for IFS directories.   

15. Improved file transfer support.  Replaced use of Putty for SSH transfer in the GUI with Windows 
SCP.exe instead. 

16. In JW, added a new situation “QDBSRVXR job may not be running well.” 

17. In JW, added new situation “Resident stack pool is being depleted”. 

18. Added an Active Data menu from the component icon to graph the currently running JW or CS 
collection more easily.  Latest server builds required if you wish to use this along with 
STRJWMON. 

19. Many enhancements were added under General Functions -> Work management.  Also added a 
General Functions -> System folder with things like WRKSYSSTS like output. 

20. In CSI, situational analysis has been disabled for “R” named collections. 

21. Fixed additional problems with the nmon import function at 7.3+. 

22. In JW, Interval Details -> SQL / Client if SQL statement is truncated, double-click it to retrieve the 
full value. 

23. QMGTOOLS no longer shipped or installed by default. 

24. Added PTF checking support at 7.5. 

September 10th, 2022 – Client 1565 + server builds 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01589.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01589.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01565.exe
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1. 2 new SQL preferences relating to the Component views to improve usability: 

a. Component views fetch size (500 default so scrolling works better with poor network 
connections) 

b. Force a refresh when tree folders expanded (default unchecked) 

2. Component view tree behavior fixes. 

3. Nmon analysis options weren’t working – latest server builds required. 

4. Fixed issue with the clock icon it may change the type of job grouping (from job to thread) 

incorrectly. 
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Note: Click on the date – build # link to download 

September 1st, 2022 – Client 1561 + server builds 

1. ODBC connection management changes.  Each Data Viewer and Main Window will now use 
separate ODBC connections to allow for user to run multiple queries at the same time as long as 
they are ran in different MDI windows. 

2. Canceling SQL statements is much more reliable now.   Previously this could cause the cancel to 
fail and the GUI to appear to hang. 

3. Created a WRKSPLF / WRKOUTQ interface and toolbar button in the Main Window. 

4. CSI added new graph rankings: 1) by generic current user and 2) by submitter 

5. CSI – added GEO mirroring detected situation 

6. CSI – CS Objects folder updates 

7. CSI – Collection properties – System tab contains additional data about QAPMCONF GKEY 
values. 

8. CSI – SVC/StorWize graphs added at 7.5 if QAPMXS* files exist. 

9. CSI - Command QIDRGUI/STRIDRSUM now allows a value of *LATEST for the collection 
parameter.  This can be used with scheduled jobs to run CS iDoctor analyses automatically daily.  
However, no automated cleanup method exists yet. 

10. JW - Now shipping several STRJWMON stored procedures to run as *OWNER user profile to 
avoid a potential collection cleanup problem. 

11. JW – Fixed issues relating to graphing holders. 

12. JW – Interval Details fixes relating to find next, find previous buttons. 

13. JW/DW - When collections are starting up the refresh status will now occur automatically when 
the user refreshes the view while the status still shows required files missing. 

14. PEX – Updated the activation group analysis reports. 

15. PEX – Some drill down changes in TPROF. 

16. Report Generator – Added option to use latest collection if scheduling the report to run later.  
Fixed scheduling options.    Added Save As PDF option.  Added Email report to option (via 
Outlook.) 

17. Fixed the support to use flattened style graphs against multiple collections.   

18. Added options to open some reports in the Main Window now instead of the Data Viewer. 

19. Listing collections will no longer fail completely if > 500 exist in the library.  Now only the 1st 500 
are shown. 

20. Time filters can now be done within graph by holding down SHIFT or CTRL and performing a left-
click drag zoom operation. 

21. Made caching changes relating to reading/writing to the Windows registry to improve 
performance. 

22. IBM i Explorer – improvements for the Libraries and Objects folders. 

23. Many folders in the component views will now fetch only the rows visible to improve performance.  
Clicking column headings will cause a resort on the server now instead of within the GUI. 

24. WRKOBJLCK interface now supports generic object names or library names. 

25. WRKOBJ interface now supports generic object names or library names. 

26. Fixes related to sending data to IBM. 

27. Removed functionality from Power Connections.  Only HMC and VIOS remain as valid 
connection types. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01561.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01561.exe
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May 26th, 2022 – Client 1542 + server builds 

1. Released 7.5 server builds. 

2. Removed SQLSTMT from JW ranking graph groupings, tips and flyovers for perf reasons. 

3. Removed nmon analyzer (no launch option and no longer shipped with the GUI.) 

4. CSI – unable to read QAPMCONF fix 

5. CSI – fixed ability to graph multiple ASPs at once and compare (3+) 

6. Removed Data Explorer 

7. Fixed slow performance in JW – Interval Details -> SQL / Client tab 

8. Changes made to user-defined graphs/reports.  Table-specific filter and view options. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01542.exe
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April 14th, 2022 – Client 1535 + server builds 

1. Design flaw fixed related to Windows UAC virtualization when installing under C:\Program Files 
(x86)\IBM\iDoctor.  This caused some users to be running older versions of SQL statements and 
to experience errors and wrong results. 

2. Many updates in CSI and reordering of some graphs.  External storage now under Disk.  System 
-> Interrupts and CPU -> Shared pool CPU utilization now only appears after Collection Summary 
ran and required data exists.   

3. CSI -> Hardware -> Save/restore graphs redesigned.  Also updates to SQL -> Plan cache, DB2 
mirror and Hardware -> Tape. 

4. CSI -> Disk -> Flattened graphs removed 

5. Fixes to CSI -> Disk -> Free space map rankings 

6. Fix for potential signon bug infinite loop if user id no longer exists.  

7. Added new DB2 for i -> IBM i Services reports under Applications and Communications at 7.3+. 

8. Plan Cache Analyzer import/split fixes and browse/search functions added. 

9. Removed Plan Cache Analyzer dump support. 

10. Some JW -> J9 JVM graphs were removed and others fixed. 

11. SQL editor improvements and active job menu options. 

12. iDoctor FTP GUI is now called IBM i Explorer. 

13. General Functions -> Browse Collections removed 

14. Removed SQLite support 

15. Opening HMC or VIOS connections would crash the GUI with 1523. 

16. Under Power Connections removed support for all types of non-IBM i connections except VIOS 
and HMC. 

17. Options to save/open iDoctor sessions were broken and have been removed. 

 

January 28th, 2022 – Client 1523 + server builds 

1. Fixed an issue that meant most SQL statements were running in a single QZDASOINIT job per 
LPAR.  This along with some newly discovered problems with OVRDBF and QTEMP aliases, 
meant there was a high chance of reports showing wrong results.   

2. Removed use of OVRDBF throughout the iDoctor GUI and replaced this with QTEMP aliases.  
This was due to a major design flaw that could potentially cause incorrect results.  Options that 
prompt you for a specific collection/member have been removed.  If writing your own SQL, you 
will need to create your aliases to point to specific database file members.  User-defined reports 
will need to have their SQL recreated or a work around would be to only have 1 collection per 
library.   

3. In JW, fixed drill down problems into a single call stack from Call stack summary reports. 

4. In JW, updated the Collection Summary analysis to remove fields CURRUP and PRIORITY from 
the QAIDRJWGAP_<MBR> SQL table.  Existing collections will need to have the analysis reran 
to be viewable.   

5. Reworked the design and SQL statements for most of the Job Watcher interval details interface 
for performance reasons.  

6. In CSI, “R” collections will no longer complain about files missing that were not applicable to 
them.  

7. Made additional updates / fixes related to the collections cache.   This fixes a potential “Unable to 
read QAPMCONF” error in CSI. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01535.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01523.exe
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8. Usability improvements relating to the running of SQL statements and error handling.  For syntax 
errors, the position of the error should be indicated correctly.   
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November 24th, 2021 – Client 1508 + server builds 

1. More performance improvements when listing collections.  Server builds must be reinstalled. 

2. Keep alive preference reenabled and fixed issues related to it, but its use should be limited to 
avoid potential problems which still could exist. 

3. Added Refresh Status menu option for collections in in PEX, JW, DW and CSI. 

4. The preferences to limit the number of collections displayed was broken in the previous update 
but fixed now. 

5. Made several improvements related to successful recovery if the GUI loses connection (without 
requiring a restart of iDoctor.) 

6. Fixed a problem with several PEX Analyses that caused the analysis to fail if collection was > 38 
minutes in duration if using 1/10th intervals and > 35 minutes if using 1/100th second intervals. 

7. A bug in Job Watcher monitors was fixed that caused all of the monitor’s collections to be deleted 
when the active collection rolls over from 999 back to 001. 

 

 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01508.exe
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October 13th, 2021 – Client 1498 + server builds 

1. Made many additional updates related to running SQL in background threads.  A mouse pointer 

of  means an SQL statement is currently running.  Hit ESC on the keyboard to attempt a 
cancelation.  If currently in an hour glass state, then at those times you cannot cancel and must 
wait however. 

2. Several updates to try to fix crashes and hangs. The keep alive preference has been disabled 
since it could cause the user to hang for long periods of time. 

3. Performance improvements when listing collections.   Server builds are required to be reinstalled. 

4. Status improvements for lists of collections in Collection Services Investigator, Disk Watcher and 
Job Watcher.  This tells you what files/data was not collected.   

5. Job Watcher call stack screen now has a Save button that lets you save a call stack for review 
later to a repository.  See the Data Repository folder to view those. 

6. Plan Cache Analyzer Split snapshot and/or Link with Job Watcher (on QRO hash) related 
enhancements. 

7. Alternate view interface is now a pane instead of a popup window.  It also now supports options 
for some perspective options for tables (CS Job Summary or QAPMSYSTEM.) 

8. Change Description option on collections in PEX, JW, DW and CSI. 

9. QAIDRPCRM table updated with latest Performance Capability Reference Manual updates for 
CSI and P9/P10 systems. 

10. Transfer collections now supports the IBMSDDUU options again. 

11. Categorized graphs now include the worst buckets average response times and counts in the 
flyover.  A tip is shown on the X-axis label in extremely poor performing cases. 

12. Flyover tips are no longer shown for situations (if mouse pointer over background areas).  The 
mouse pointers must be over a bar or line.  This was done to avoid excessive tips popping up. 

13. IFS browsing support now includes the symbolic link values if required DB PTFs for the 
IFS_OBJECT_STATISTICS SQL table function have been installed. 

14. JW/CSI now offer new graphs for wait counts, average wait times, average CPU times and 
average disk wait times for all 3 types (overview, rankings, and selection over time.) 

15. In CSI added a new analysis called “Fix Missing Intervals”.  This can be used to try to improve 
iDoctor by adding missing QAPMSYSTEM file intervals into the data.  This modifies the Collection 
Services QAPM* files which is necessary to graph the data properly in some situations.  Make a 
copy of the collection before using is recommended. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01498.exe
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May 13th, 2021 – Client 1466 + server builds 

1. More fixes in PEX – heap storage analysis 

2. Tree report fixes 

3. Miscellaneous cleanup 

4. Installation fix (files not being copied successfully still showed a successful install) 

5. Preference -> Always show dates on graphs removed (they are always shown now) 

6. Fixes and updates related to VIOS monitors. 

 

April 9th, 2021 – Client 1455 + server builds 

1.  Fix for ODBC bug with latest ACS (Aug 2020) is here if you need it (this would apply if you need 
to use a client < 1418):  
https://public.dhe.ibm.com/services/us/igsc/idoctor/odbc_userid_password_fix.zip 

2. Many folders in the component views will now run SQL statements in background threads to try to 
avoid hangs and possible “focus shifting” problems on Windows Server.       

3. Most SQL statements ran in the Interval Summary and Interval details screens in JW and CSI are 
now ran in background threads.  You can also now right-click columns in most lists and use 
options to filter the lists. 

4. Added a report visibility setting under the View menu which controls which reports are shown.  
There are 3 modes: Basic, Intermediate or Advanced.   

5. Several new preferences added on the SQL tab designed to try to improve performance. 

6. Updated most JW SQL statements and graphing to show helpful fields on the flyovers (if unique 
values exist for things like holders and waiter) and X-axis labels will contain tips to tell you which 
if any are set. 

7. In JW added QRO hash and SQL statement groupings at 7.2+. 

8. Removed support to run the GUI on Linux KVMs or Linux via Wine. 

9. PEX collection properties updates: 

a. General tab – Fetch events button ran in background thread 

b. Most lists can now be filtered, and some run in background threads. 

10. Preferences -> Data Viewer -> Always display new real-time data option was broken and now 
fixed. 

11. Memory Watcher and Data Explorer (IBM internal components) updates  

12. The ability to run PEX stats analyses was broken from 1423-1428. 

13. DLTJWCOL changes: 

a. No longer does excl lock on the collection  

b. iDoctor SQL table cleanup always occurs now even if collection does not exist. 

14. STRJWMON cleanup changes: 

a. Rewrote cleanup to improve performance 

b. QIDRRMVJW1 now creates a temporary data area in QIDRGUI when it runs to avoid 
multiple QIDRRMVJW1 jobs being created 

15. In CSI/JW/PEX/DW added support to graph multiple collections by right clicking the library.  (See 
update history for more details on this.) 

16. If using multiple component drill down support, the current component’s default option is now 
shown at the top.   

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01466.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01455.exe
https://public.dhe.ibm.com/services/us/igsc/idoctor/odbc_userid_password_fix.zip
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17. Query Definition interface reenabled but now simplified (less options.) 

18. WRKACTJOB interface now support creating graphs or launching table view results in the Data 
Viewer. 

19. CSI – Launch Workload Estimator option removed. 

20. Collection search results now sorted by Dispatched CPU by default instead of interval. 

21. Signon fixes to try to avoid getting locked out due to too many failed login attempts especially 
after password has changed. 

22. PEX heap storage analysis fixes. 

23. The nmon created NPIV graphs for selection over time were broken and now fixed. 

24. Fixes related to running out of GDI objects (graphing limits) 

25. Browsing the IFS or using the WRKLNK interface is done via SQL using 
IFS_OBJECT_STATISTICS at 7.3+. 

26. The FTP auto detect option removed. 

27. In the component window removed WARNING messages about server or client builds being too 
old.  

28. Removed about 7 preferences (see the update history.) 

29. Redesigned how data is fetched to improve performance. 

30. Component views are virtual now (only fetch what you see) to improve performance.  The 
downside is you can no longer type ahead to find something in the list but the Edit-> Find option 
works instead. 

31. Find Collections menu option added to help locate specific data on a system more easily (see the 
examples.)  Use caution as this could be resource intensive. 

32. Rewrote column resizing code to try to improve performance. 

33. JW – interval details SQL tab changes: 

a. renamed SQL tab to SQL / Client.   

b. SQL statement shown is no longer truncated unless it exceeds 16 KB. 

c. If 2 statements were collected, then both should now be listed. 

d. added SQL client register fields to the list at 7.4+.   

e. added support to show host variables in the list, open cursor lists or prepared statement 
areas 

34. In CSI added pie graphs again under Waits -> Collection totals or I/O -> Collection totals. 

35. In CSI added situation for Excessive interrupt handling delays. 

36. In JW added situation for Interactive capacity check. 

37. Increased max flyovers allowed on graphs to 30 (from 10) 

38. Updated Collection summary analysis in both JW/CSI to add more indexes. 

39. Added Index advisor views under General functions -> DB2 for I -> Index advisor. 

40. Added an iDoctor Messages View to the Main window and toolbar button.  This mostly contains 
debugging information but at times may tell you why an SQL statement is not running or folder is 
empty.  

41. Added new command QIDRWCH/CPYCSCOL.  Also updated CPYDWCOL and CPYJWCOL to 
support an option to control whether record formats are checked.  (see the update history.) 

42. Find window remembers the last 20 find values used.   Collection search remembers the last 20 
values used as well. 

43. JW – I/O -> Synchronous response graph replaced (see update history) 
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44. Job Summary ranking graph options fixed / updated. 

 

Nov 10th, 2020 – Client 1425 + server builds 

45. Work around ACS Windows Application Package - bug with August 2020 update  

a. ODBC - User ID not recognized error. 

b. Clients older than 1418 cannot be used with this level of ACS. 

46. Performance improvements when starting the GUI (latest server builds required for best results.) 

47. Filter libraries enhancements: 

a. Supports multiple generic library names with custom descriptions 

b. Press Delete key to remove something from history list. 

c. Browse feature for individual libraries 

48. SQL Editor fixes  

a. Running multiple statements and handling errors. 

b. Choose collection or DB member issues (case sensitivity issues with collection names 
bug) 

49. Export to CSV file fixes 

a. You can now export from lists not in the Data Viewer (i.e.  IBM i connections, etc) 

b. Tree tables can no longer export to CSV (it was broken a little too complex to include) 

50. Record Quick View or Quick View enhancements 

a. Hide all 0 or blank option 

b. Multi-record comparison enhancements 

51. Collection transfer fixes 

52. Library properties – cross check tab.    

a. Verify if DB files are out of date when compared to QSYS. 

53. In CSI added support to analyze/graph “R” collections. 

a. Graphing will better handle missing files if using these collections. 

b. From Configure Collection Services window added options to Enable system monitoring 
or control data category settings and retention periods 

54. In CSI, most overview graphs and some rankings now support graphing multiple collections from 
multiple libraries.      

55. In CSI - some job counts graphs’ metrics were wrong and now fixed. 

56. In CSI – historical summary fixes. 

57. In CSI – fixes relating to deleting collections. 

58. In CSI situation updates: 

a. Added “Cycles per instruction (CPI) is high” 

b. Updates resolution text for “Temp storage > 7% of free storage in ASP 1” 

59. In CSI – disk graphs ASP selection issues fixed. 

60. In CSI – fix (or possibly a work around) for read cache hit % metric. 

a.   Disk type D910 (EMC) may have a bug 

61. PEX groupings changes 

a. Pgm or lic mod renamed to Program 

b. Pgm or lic mod – procedure renamed to Procedure 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01425.exe
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62. PEX TPROF - cacheline breakouts not appearing on P9 fix. 

63. PEX ranking graph fixes – several types would not work due to TIMESTAMPDIFF function issue 
if collection duration > 35 minutes. 

64. Job Watcher fixes related to Show holder. 

65. Job Watcher and CSI collection search fixes + enhancements. 

66. Job Watcher overview graphs and some rankings now support graphing multiple collections from 
multiple libraries.  Kick this off from the Collections folder after specifying a library filter. 

67. Job Watcher call stack view – include LIC option 

68. Job Watcher updated QIDRWCH/STRJWMON command to abort data collection if target DB files 
are outdated (wrong release.) 

69. Job Watcher QRO hash support added in several spots. 

a. 7.2  MF66612 

b. 7.3  MF66613 

c. 7.4  MF65997 

70. Added a Temp Storage Analyzer component – this is included with a JW license.  Analyzes data 
from the SYSTMPSTG view. 

71. Power – when browsing directories added option to go up a level. 

72. Change SQL Parameters updates 

a. Removed many parameters from view that are internal only 

b. Added validity checking for most used parameters 

c. Fixed potential crash and bugs 

73. Fixes to the warning messages shown in the iDoctor components window 

74. Updates for the PCRM table used in CSI. 

75. IBM i Connections view 

a. Can now set a default system 

76. View -> Auto resize column widths (or F8) can be used to auto resize the column widths of 
current list you are looking at if something is not drawn correctly. 

77. Disk Watcher has new groupings and other fixes. 

78. Plan Cache Analyzer  

a. Added the ability to view the system's current plan cache with several graphs/reports 
under the "System plan cache" folder 

b. Plan cache snapshots folder now lists newest collections first. 

c. Added Clear system plan cache menu option. 

d. Added Change plan cache size threshold menu option. 

 

June 19th, 2020 – Client 1405 + server builds 

1. Power Connections – SSH connection fixes for certain environments 

2. Graph legend – hold CTRL and click on flyover fields crashed the GUI 

3. Monitor commands STRJWMON/STRDWMON/STRPAMON now checks the following: 

a. Library exists or not 

b. Definition file exists  

c. Definition exists 

4. WRKACTJOB – new JVM perspective and Analyze JVM option via PRTJVMJOB *GCTABLE 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01405.exe
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5. CS/JW – Graphing multiple collections made it difficult to turn off situations. (no option via legend) 

6. PEX/JW - Changes to all call stacks reports.  Instructions/stmts on by procedure call stack 
groupings no longer shown. 

7. PEX – STRPACOL command collects PMCO *Format2 or TSWOUTQ *format 2 by default now if 
the problem type used includes either of these events. 

8. PEX – changed almost all trace analyses (except TCP/IP).  

a. Many new reports and more advanced rankings options 

b. Changes to SQL tables and in some cases interval summary files added to improve perf. 

c. Most trace analyses now support 1 second, 1/10th second or 1/100th second intervals 
analysis options.   

9. PEX – PDIO changed to more closely match the look and feel of CSI – Disk graphs 

10. PEX – Starting points – new or changed reports for CPI, CPU switch, Events, file server, call 
stacks, Mutex cleanup ,Netsize, SARs, PMCO – PRTPEXRPT 

11. PEX – Added new analyses and graphs for Page faults, SARs 

12. PEX – Removed Mutex cleanup analysis (see Starting points instead) 

13. PEX – TPROF – Cacheline breakouts changes/fixes 

14. CS – Updated Expected CPU rate calculation 

15. CS – At 7.4+ removed situation “Temp storage > 7% of free storage in ASP 1 “ 

16. CS – At 7.4+ the External storage cache statistics analysis is now obsolete; the new QAPM* files 
generated are accessed instead.   

17. CS – Free space map rankings added  

18. CS – CPU, I/O, Logical I/O, SQL, External storage graph changes 

19. CS – Disk graphs updated to reflect latest design changes.  Rankings menu works better on drill-
downs. 

20. CS – CPU rankings changes:  

a. Added new metric “Job runtime CPU utilization” 

b. “CPU utilization” now based on the selected time period instead of job run time. 

21. JW – Fix for restoring 7.1/7.2 collection to 7.3 showing incorrect VRM 

22. Collection repository/database fixes 

 

 

 

 

 

 

Feb 27th, 2020 – Client 1394 + server builds 

1. Changed how stored procedures get loaded at startup to reduce failure chance. 

2. Option added to disable FTP connection (edit your IBM i connection) 

3. JW interval details – move next/move previous navigation fixes 

4. Graph legend – infinite loop redraw fix 

5. Saving user-defined reports fixes 

6. Save password checkbox fixed for Windows 10 

7. Support added for internal users - next IBM i release. 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01394.exe
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8. Improvements to drill down flow and options for Rankings menu (2nd level options). 

9. Attempted fixes for focus shift problems. 

10. PEX - TPROF tree counts wrong for system tasks 

11. PEX - TPROF by component more breakouts added for Eric B. 

12. PEX - LDIO option bits parsing 

13. PEX – Starting points – PMCO PRTPEXRPT *PROFILE added 

14. PEX – Cacheline breakouts changes (P7 vs P8 reports – Note: does not appear on P6/P9) 

15. CS overview – interval summary table added Type-model, nominal frequency (from QAPMCONF) and 

processor feature.   

16. CS overview – Expected CPU rate tweak:  set to 100% for P7/P8 if calc gives < 100%. 

17. CS overview – added affinity score and situation 

18. JW overview– added Average CPU rate 

19. JW/CSI logical I/O, page allocations and temp storage graphs updated. 

20. Power type column added when listing collections and added to collection properties. 

21. WRKOBJ interface perspectives (Basic/Detailed/Advanced) 

22. WRKACTJOB properties improvements – Perspectives options 

 

Dec 19th, 2019 – Client 1386 + server builds 

1. Data Viewer toolbar tooltip related memory corruption crash 

2. Graph compare – sync scaling fix 

3. Install changes/fixes (Note: This build or higher can no longer be used to install on 6.1 or 7.1) 

4. Check for new server builds button fixed 

5. Gantt chart fixes 

6. Attempted focus shifting fixes  

7. PEX – TPROF – cacheline breakouts drill down object resolution and total hits bug fix (Note: it is 
still wrong with this version and only shows seize/lock objects and not all) 

8. CS – Collection properties system tab - added info from QIDRGUI/QAIDRPCRM 

9. CS – DB2 mirror graphs added at 7.4 

10. CS Overview – TIME02A fix ( CPUQ remainder) 

11. CS Overview - graphs faster if collection summary ran. 

12. CS Overview – workload capping related updates 

13. CS - SQL full opens rates graph wrong 

14. CS – External storage – PPRC Links updated 

15. CS – High disk storage consumed situation fix 

16. CS Job Summary – new field JBPRTY 

17. JW - listing collections too slow fix related to workload capping 

18. JW Job summary – new fields ORIGPRI, PRIORITY, THREADPRI 

 

Nov 7th, 2019 – Client 1381 + server builds 

1. iDoctor now supports multiple clients installed on the same PC (in different directories) 

2. Fixes made to allow the latest client to work again with 7.1 servers.  

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01386.exe
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3. Fix related to check for /QIBM/UserData/iDoctor/tmp path and use of RTVDIRINF that caused 
issues. 

4. Graph selections now appear in flyovers automatically 

5. “Encountered an improper argument” bug when opening graphs with 1377 

6. Startup crash if user had adjusted windows scaling default to > 100% 

7. Installation – QMGTOOLs 7.4 support and FTP SSL Tls12 

8. PEX drill down fixes (IN operator listed twice) 

9. CS/JW - Create indexes analysis option removed - always done now 

10. CS/JW – overview graphs provide situation information in the graph legend. 

11. CS overview – PCRM table added, CPU frequency and energy management graphs 

12. CS collection summary – added SQL count fields 

13. CS overview - Scaled CPU ratio renamed to Average CPU rate.   

14. CS overview - Added Expected CPU rate:  (SCALEDCPU/100 * NOMGHZ_QAPMCONF) / (CASE WHEN 

P9_MINGHZ IS NULL THEN NOMGHZ_PCRM ELSE P9_MINGHZ END) * 100.00 AS EXPCPU 

15. CS - situation fixes (No situations found, High ext stg to IBM i latency, Seize lock table) 

16. CS – new situations - Interactive limit = 0%, QAMPMLPARH check 

17. CS - Memory pools – 4K pages stolen graphs added 

18. CS – External storage cache statistics graphs updated 

19. CS rankings – option to include Y2 PCTCPU per job. 

20. CS – Interval summary top section updated 

21. JW/CS - run all default analyses (or when ECUREP data loaded internally) situations were not 
being built 

22. JW monitor cleanup program fix (CPC7333 msg) 

23. QIDRGUI/FTPFILE fix to support Blue Diamond 

 

August 15th, 2019 – Client 1368 + server builds 

1. 7.4 support fixes 

2. Tooltip related fixes and preferences changes 

3. Secure FTP support updates (TLS 1.2) – GUI only; not in installation yet 

4. Visual borders around bucket 1 (Dispatched CPU), bucket 2 (CPUQ) breakdowns. 

5. Drill down support for 1/100th of a second in some cases where data allows it. 

6. PEX – DB opens – options list parsing 

7. PEX – TPROF - link register resolution update 

8. CS – free space map updates 

9. CS/JW overview – total situations occurred /descriptions displayed while SQL runs. 

10. JW – workload capping graphs added 

 

July 18th, 2019 – Client 1363 + server builds 

1. Tooltip related fixes and preferences changes 

2. License agreements updated 

3. Signon issues fixed (multiple prompts) 

4. 7.4 support fixes (JW – DB files VRM incorrect) 

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFullC01368.exe
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5. Collection search – default now a “Job contains” search 

6. PEX – fixes in many analyses related to PDIO changes and 1/100th second intervals 

7. PEX – PDIO support for 1 second, 1/10th second or 1/100th second intervals. 

8. PEX – DB Opens new rankings added (by thread/pgm/file or by thread/pgm) 

9. PEX – max trace collection duration analysis support (at 1 second intervals) increased from 1.15 
days to 37 days.  This is about 9 hours max when analyzing at 1/100th second intervals. 

10. PEX – updates several analyses to avoid misleading PDIO stats 

11. PEX – fixes in the Add/Change PEX Definition Wizard 

12. DW (Disk Watcher)  

a.  Graphing of idle time period support.   

b. Trace summary fixed at 7.3 due to SQL changes. 

13. CS/JW – fix to allow drill down on “No subsystem” 

14. CS/JW – Change sensitive user data analysis rewritten 

15. CS/JW – Collections folder added – to show/graph collections from multiple libraries at once 

16. CS – Historical summary analysis updates 

17. CS – Job Summary analysis – new fields JBPGAI, JBPDI, JBTMPPGAI, JBTMPPGDI 

18. CS – Disk graphs updated (reordering, 6.1 graphs removed) 

19. CS – Page allocation graphs – Ignore DBL3s, special handling added for broken unsigned 4-byte 
fields 

20. CS – Disk graphs DRIVECAP value wrong in some cases. 

21. CS – Situation fix “Temp storage used is potentially too high and may disrupt SQL plan cache auto-sizing”  

22. CS – added bucket 2 (CPUQ) breakdown:  

a. CPU queueing - remainder  

b. CPU queueing – workload capping delay 

23. CS – temp storage > 7% of free storage added 

24. CS – disk graph fixes related to LOCCOD field 

25. CS – new disk graph rankings added for Ext Stg 

26. CS – disk configuration – raid type parity set check 

27. CS – Ethernet graphs – line speed was wrong (divide by 1000) 

28. CS – Temporary storage graphs added 

29. CS – External storage links and ranks graphs updated 

30. CS – System graph updates 

31. JW – Holder chase updates 

32. JW – Interval summary and interval details properties windows updated 

33. JW – Page allocation graphs – Ignore DBL3s, special handling for negative numbers in JW data 

34. JW – Temporary storage graph updates 

35. JW – New situation added - Reclaim resource CPP detected 

 

January 3rd, 2019 – Client 1340 + server builds 

1. Removed QMGTOOLS GUI 

2. Re-added support to connect to 6.1 systems (some builds older than 1268 removed this)  

https://public.dhe.ibm.com/services/us/igsc/idoctor/iDocInstallFull_Client1340_Jan2019.exe
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3. Added math in the status bar based on the current selection. 

4. Data Viewer – Fixes related to side-by-side comparisons 

5. Graph legend – Sort menu now support multiple columns 

6. iDoctor now remembers your preferred toggle graph format settings for graphs. 

7. Power Connections – Nmon graph fixes 

8. Power Connections – fixes related to Create Disk Mapping and FTP related preferences 

9. Added a graph search function  (Note: The ability to hide/reappear graphs in later builds is 
becoming very problematic from a maintenance perspective and this ability may be removed in a 
later build.) 

10. Updates to the Transfer to function (fixes + new features) 

11. User-defined reports DB format change ( can now use IBM i library or local .mdb file) 

12. PEX – PEX Collection Wizard (Start PEX+) fixes related to QMGTOOLS changes  

13. PEX – Collection properties Events for *PROFILE fix 

14. PEX - PDIO – support for user-defined response time buckets 

15. PEX – PDIO redesigned 

16. PEX – Locks analysis added 

17. PEX – added mutex cleanup reports 

18. PEX –analyses updated: Events, Heap, CPU profile, data area, dataq, LDIO, DB open, netsize, 
act grps 

19. CS/JW Situations preferences enhanced (contrast/width, etc) 

20. CS – new situations added: 

a. Seize lock table large 

b. Temporary storage is > 7% of the free storage in ASP 1 

21. CS – Situation fixes – SMT context changed 

22. CS – Job Summary – new fields JBHSQLSTMT, JBTICC, JBTICU, JBTTMBU and JBPICC 

23. CS – Free space map graphs added  

24. CS – System graphs – Interrupts added 

25. CS – Memory pool graphs added tuning type, description, pool size and pool name 

26. CS – CPU Graphs - Active virtual processors graph added 

27. CS – Communication graphs - Ethernet Graphs fixes 

28. CS – Disk graphs – advanced - support added for QAPMCONF response time buckets 

29. CS – Disk configuration – GEO mirror flag 

 

30. JW – Overview Y2 changes 

31. JW – Added Virtual CPU delays graph 

32. JW – Temp storage rankings fixes 

33. JW – Detail reports – Objects waited on updates 

34. JW – Job Watcher monitor fixes related to collection cleanup 

35. JW – Situation fixes: 

a. Potentially large number of locks 

b. Gate contention in ASM finding free space 

36. JW – New situations added: 
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a. RMSL lock clean-up 

b. QDBSRVXR2 job busy 

c. QDBSRVXR2 job may not be running well 

37. JW – J9 JVM graphs by thread fix 

38. JW – Added Time waiting on objects graphs 

39. JW – Job counts graphs fixes 

40. JW – Detail reports – call stacks – options added to show J9 call levels 

41. JW – Call stack summary analysis includes J9 call stacks 

42. JW – Clients + workers support added to the Collection Summary 

  

March 29th, 2017 – Client 1267 + server builds 

 

January 12th, 2016 – Client 1200 + server builds 
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