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Server database Lab



Connecting WDI 3.3 Client to Server db

Pre-requisite to beginning this lab, you must have:

1)WebSphere Data Interchange V3.3 Client
Installed.

2) DB2 V8.2 (or higher) UDB Workgroup or
Enterprise Edition installed

3) and have WebSphere Data Interchange V3.3
MP Server for Windows installed and the Server
(DB2) database setups successfully completed.



Connecting WDI 3.3 Client to Server db — same machine

 |If you are setting up the WDI Client on the same
machine as the WDI Server;

 On the menu bar, click Start > All Programs >
IBM DB2 > Set-up Tools > Configuration
Assistant .

@ f"i Eq D2 LB ) Bummess Inbeligenos Tools ]
NI P V3,2 Thent |

1 % = nfoprin k|| S Command Ling Tooks b ﬂ
ﬁ- T p— I B9 lxvm Web Start w4 k|| ) Devslopment Took '
rj =i MatesBudd 3 'j Ganeral Sdrrresiraton Tooks ¢
T 5 Personal Communicstons k| Information
O BM Supoert Apsisian | ) Heritaning Tools b
e LT ——
W OO0 M Websphere MO ] £ Frat Steea
| M rfooring Salact ] E, Risgister Visusl Studio Add-Ins
: ¥ (0 Erfariview . B sabelite Syndwoner
W . o { T ISCITooks E B warehouse Control Database Mansgement
. ':".: O Lavasal Ad-Apeare SE Persons K F H e =



Connecting WDI 3.3 Client to Server db — same machine

This will result in the DB2 Configuration Assistant

window being opened.
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Connecting WDI 3.3 Client to Server db — same machine

Select the WDI 3.3 database (default name is EDIEC33E) and double-
click to open the Change Database Wizard. This should result in the
“Select a communications protocol” screen being displayed (as

shown in the example below). Verify that the “Local” radio button is
selected and press the Next > button.

= Change Database Wizard - EDIEC33E

|1_. Frotocol

Select a communications protocol

2. Local Select the communications protocol that wou wweant to u=ze to connect to the DE2 databaze. If wou
et are using S, select APPC a=s the protocol. Indicate if your database is located on a host or

=000 =y=term. If your client has DEZ2 Connect installed and the =elected database iz a gateway
4 . Data Source connection, then s=lect the type of connection route to the zerver( Task Owerview.

S, Security Options

{ APFC 7 Mamed pipes (MNFIFE)

 APPM = Local (LOCAL)

| Mext bk I Fini=h Cancel




Connecting WDI 3.3 Client to Server db — same machine

This should result in the “Specify information for a database
on this system” screen being displayed (as shown in the
example below). Verify that the “Database in the current

Instance” radio button is selected and press the Next >
button.

(== Change Database Wizard - EDIEC3 3E

1. Protocal Specify information for a database on this system

2. Local Local iz not a communication protocal. Y ou usze it when you are defining a connection to a
database on your awwr Sy stem. To use local you must have installed a DEZ server wwith local

3. Datalbase :

- clierts.

4. Data Source
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5. Security Options ' Database in another instance

=+ Database inthe current instance
1 | >
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Connecting WDI 3.3 Client to Server db — same machine

This should result in the “Specify the name of the database to which you

want to connect” screen being displayed (as shown in the example
below). Verify that the Database Name and Database Alias are correct

and press the Next > button.

I___";' Change Database Wizard - EDIEC33E

R |

3. Databazse
4. Data Source
9. Tecurity Options

Specify the name of the database to which you want to

connect

S ou must idertity the database to which you are connecting. The database name 1z dependent an
the type of server to which vou are connecting . For O=0390 and 2005 databases specity the
Location name. For OS400 cdatabases use the RDE name. For %Sy SE specity the DERAME.

Ctherwize use the name of the database on the server.

Databese name | EDIECZ3E]

Database alias I EDIECIZE

Carmmernt ]
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Connecting WDI 3.3 Client to Server db — same machine

This should result in the “Register this database as a data source” screen
being displayed (as shown in the example below). Verify that the Data
Source Name is correct and that the Register this database for ODBC

Is checked and press the Finish button.

"% Change Database Wizard - EDIEC33E
_ulll
1. Protocol Register this database as a data source
2. Local The ODEC (Open Database Connectivity interface allowws different programs to access relational
3 Diatab databazes. If ODBC applications will be using this databasze, then vyou must specity how it =hould
= aRaze be registered. & =yvstem data =ource i available to all uzers on the sy=stem. A user data source
4. Data Source means that wou are the only u=ser who can access the datalbyasze. A file data source creates a file

containing data source information. This data source file can be shared with other wworkstations it

5. Zecurity Options wou have a TCPAP connection. Otherwwise the file can only be used on this machine . “ou can
aptitnize the data source =ettings for a particular application by selecting it from the list.

= f= =ystemn data source § As user data source {

Data source name EDIECZSSE

Cptimize for application
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Connecting WDI 3.3 Client to Server db — same machine

Next, start up the WDI 3.3 Client. This may be done via Start > All
Programs > IBM WebSphere Data Interchange V3.3 Client > WDI
V3.3 Client or by selecting the WDI 3.3 Client icon on your desktop. This
should result in the WDI 3.3 Client Main window being displayed.

System
|SHOGUNZ




Connecting WDI 3.3 Client to Server db — same machine

Next, select View > Administration > Systems...
from the Toolbar on the WDI 3.3 Client.
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Connecting WDI 3.3 Client to Server db — same machine

This should result in the Configuration Systems window being
displayed. Select either File\New... or select the Create a
New object icon/button to add the EDIEC33E WDI 3.3

system/database.

=

(D) WebSphere Data Interchange for Multiplatforms V3.3 - Configuration (Systems) - Query: All M= <

File Actions \iew Window Help
i i e = =|| System
l~5DJ_I_JJ : | L@l ~H |@'|:EP| S;I [sHoGUNZ =] el
""" Eﬂnﬁgumtmn {Svstemm—:} Quer]r All L_.JLI;[_J

E‘ll.@l 7| =] 2| 5] 22| o

System IData Source Hal&lﬂua]ifier Iﬂescriptinn

AUTOTESTZ AUTOC33E EDIENU33
beppo BEPPC33E EDIEXNU33
Development ¥DIClient33DEY Default Development Svy=ter
EDIEC33X EDIEC33X EDIENU33
NY WDI 3.3 EDIEC33E EDIEXNU33
SANURAT 3.3 SANFC33E EDIEXNU33
SHOGUNZ SHOGC33E EDIEXUC33
¥DI 3.3 DEY DB DBE9EB EDISZDEY
DI 3.3 FYT DB DB9B8 EDIS2FYT
¥DI 3.3 GLOBAL DEY DBE9E EDISZGEL
YBORCITY YBORC33E EDIEXUC33

< ] iiii




Connecting WDI 3.3 Client to Server db — same machine

This should result in the Configuration - System -
untitled window being displayed.

€20 WebSphere Data Interchange for Multiplatforms V3.3 - Configuration - System - <untitled> =] =< |
Eile Actons Edit MNavigate View Window Help
e = ==k
0 _|_,|-'I| —

dptions=

*System Name |EDIEC33E

Description

IIDI 3.3 Server on this machine

Server Platform I‘indurs vI

Opon SysLeuI
—Databaszoc Connection Information

Note: Plea=se enszure the
*Data Source Name IEDIEC33E v!

ODBC Data Source ha=s been

setup using the ODBC
Databa=se Qualifier !EDIEEESE Administrator and the

connections can be properly

eztabli=hed.
—Default Sy=tem Colorx

Select the color that Change. . . I
will be used as the
default Sy=tom color
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Connecting WDI 3.3 Client to Server db — same machine

Input the value EDIEC33E in the System Name
field or whatever value you will be referencing the
system by in the future (example: My WDI 3.3).

Input a value in the Description field if you wish to.

Select a value of Windows in the dropdown list of
the Server Platform field.

Select the value EDIEC33E in the dropdown list of
the Data Source Name field.

Input a value of EDIENU33 in the Database
Qualifier field.

Select File\Save on the Tool bar or press the Save
the Active object icon/button.



Connecting WDI 3.3 Client to Server db — same machine

The WDI 3.3 Server database has now been defined to
the WDI 3.3 Client.

To access the database via the WDI 3.3 Client, select
the value that you specified for the WDI 3.3 database
(using our example EDIEC33E) from the System
dropdown list on the Tool bar.

You may be prompted to logon to the WDI 3.3 Server
database the first time that you access it. You can set up
In ODBC to have the User ID and Password already
provided instead of being prompted. However, you will
need to update these values whenever a User ID or
Password is changed for the DB2 database.



Connecting WDI 3.3 Client to Server db — same machine

To validate that you can access the WDI 3.3 Server
database select any of the Icons/buttons on the
Tool bar (examples: Trading Partners, Envelope

Profiles, Data Formats, EDI Standards, XML
Documents, Mapping, etc.
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Connecting WDI 3.3 Client to Server db — same machine

You should see something like the example below.

” — o System
n E - /| [Ep1EC33E ] 6

£E EDIEC33E (Trading Partners) - Query: All I—.__||E|@

££ EDIEC33E (Envelope Profiles) - Query: All (=t <

== EDIEC33E (Rules and Usages) - Query: Find
E1|&¥5| 7| 2] & 2] 2] =i

Data Transformation Map Rules |Send Map U=sage= | Receive Map U=zages

Dictio... | Docume. . . | Map. .. | | I Sending Trading... | Receiving Tradin
TESTS POXMLASE POX. .. ANY ANY




Connecting WDI 3.3 Client to Server db — same machine

 If you do see the functional areas, such as
Trading Partners windows displayed, then
Congratulations ! You are ready to use the
WDI 3.3 Client with the WDI 3.3 Server
database.

 If you do not see them, note the error and
contact your Lab instructor for additional
support.



Connecting WDI 3.3 Client to Server db — same machine

 End of Connecting WDI 3.3 Client to
Server database — same machine Lab.

 The next slides are for information/help on
how to setup ODBC/DB2 definitions for
connecting you WDI 3.3 Client to a WDI
3.3 Server on a different/separate
machine.



Connecting WDI 3.3 Client to Server db — different machine

* Notes on how to define a remote WDI 3.3
Server database to your WDI 3.3 Client
begin with the next slide...



Connecting WDI 3.3 Client to Server db — different machine

 |If you are setting up the WDI Client on a different
machine as the WDI Server;

 On the menu bar, click Start > All Programs >
IBM DB2 > Set-up Tools > Configuration
Assistant .
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Connecting WDI 3.3 Client to Server db — different machine

This will result in the DB2 Configuration Assistant

window being opened.

= Configuration Assistant

Configure  Selected Edit  View  Toolz  Help
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Connecting WDI 3.3 Client to Server db — different machine

o Select the Selected option on the Tool bar and
choose the “Add Database Using Wizard...” option.

= Configuration Assistant g @ %
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Connecting WDI 3.3 Client to Server db — different machine

This should result in starting the Add Database Wizard with the “Select
how you want to set up a connection” screen being displayed (as
shown in the example below). Select the “Manually configure a
connection to a database” radio button and press the Next > button.

= Add Database Wizard
1

[1. Source Select how you want to set up a connection

2. Protocaol

U=ze this wizard to help you configure a connection to a DE2 database . When you or one of yvour application programs needs to
conhect to a database, yvou establizh the connection by communicating with the server on wwhich the database resides . Each DE2
client maintains a list of the databases to which it knowws howe to connect. This wizard lets you add databazes to that list(Task

O Eriea).

" Use g profie

Select it you have a file containing all the necessary information for accessing a remote server.
Typically, your database administrator will provide you with the name of the access profile that £

contains all the information necessary to configure connections to the required databazes. E:_-:; ¢_; i -
) i

;
|

(" Search the network

—%

Select to find databa=zes on your local netwwark.

f= hlanually configure a connection to a database

Select if you khowy all the information necessary to connect to the desired database. This includes the

protocaols supported by the remote =erver, the connection configuration information, and the name of
the database.

Flesdt b | | Cancel




Connecting WDI 3.3 Client to Server db — different machine

This should result in the “Select a communications protocol” screen being

displayed (as shown in the example below). Select the “TCP/IP” radio
button and press the Next > button.

Note: If the WDI 3.3 Server database resides on z/OS, check “The database
physically resides on a host or OS/400 system” checkbox.

'S Add Database Wizard

1. Source

|g. Protocol

3. TCRAP

Select a communications protocol

Select the communications protocol that vou want to use to connect to the DE2 database . If yvou are using SHA, select APPC as the
protocol. Indicate if yvour database iz located on a host or OZ/400 system. If yvour client has DEZ2 Connect installed and the selected
databasze iz a gateway connection, then select the type of connection route to the server.

{ ~APPC 7 mMamed pipes (MNPIPE)

i~ APPM 7 Local (LChCAL)

| The databasze physically resides on a host or OS400 system.

= : L

4 Back I Mext k | | I Cancel




Connecting WDI 3.3 Client to Server db — different machine

This should result in the “Specify TCP/IP communication parameters”
screen being displayed (as shown in the example below). Input the
hostname of the machine that the WDI 3.3 database resides on and port
number (Windows is usually 50000) and press the Next > button.

= Add Database Wizard
1. Source Specify TCFRIP communication parameters

2. Protocal o must provicde the communication information required to connect to the database that vou wwant to acdd. Your databasze

% TCEAR administrator can provide the information necessary to configure communications for a database connection. If you specify a

Service name only, there must be an existing service name entry in the TCPAP services file.
4. Databaze

Host name | seminole tampa usflibm.com

Service narme |

Port number | 50000 - |

4 Back rext b | | | Cancel




Connecting WDI 3.3 Client to Server db — different machine

This should result in the “Specify the name of the database to which you want to
connect” screen being displayed (as shown in the example below). Input the
name of the WDI 3.3 database that you are attempting to connect to in the
Database name field and then specify a unique value for the Database alias field

and press the Next > button.
Note: You may want to identify the database in the Comments field.

= Add Database Wizard
1. Source Specifiy the name of the database to vwhich you vwant to connect
2. Protocol You must idertify the database to which you are connecting . The database name is dependent on the type of server to wwhich
5 ToPAR oL are connecting. For O=0330 and z/0% databases specify the Location narme. For O=/400 dastabases use the RDEBE name. For
= Yl SE specify the DERAME. Cithervwise use the name of the database on the server.

S ot SouicE Database name | EDIECIIE

E. Mode Options Databaze alias |SEMIC33E

Cotrtmert [ vl 3.3 on SEMIMGCLE]

4 Back Mext b | | | Cancel




Connecting WDI 3.3 Client to Server db — different machine

This should result in the “Register this database as a data source” screen
being displayed (as shown in the example below). Ensure that the
Register this database for ODBC checkbox is checked, the As system
data source radio button is selected, the Data source name field has the
correct system name and press the Next > button.

= Add Database Wizard
1. Source Register this database as a data source
2. Protocol The QODEBEC (Open Database Connectivity) interface allows different programs to access relational databases . If ODEBC
% TopaR applications will be using this databaze, then vou must specify how it should be registered. & system data source is available to
= all user=s on the system. & user data s=ource means that you are the only user who can access the databasze. A file data source

crestes a file containing data =ource information. This data source file can be shared with other workstations if you have 3
TCPARP connection. Ctherwvize the file can only be used on this machine. You can optimize the data source =ettings for a
5. Data Source particular application by selecting it from the list.

E. Mode Cptions

v Redgister thiz databaze for QDEC

f= M= system data source (7 As user dats source " Az file data source

Data =aurce hame SEMICSSE

Cptirmize for application

|NDnE.- j
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Connecting WDI 3.3 Client to Server db — different machine

This should result in the “Specify the node options” screen being displayed (as
shown in the example below). Select the appropriate value in the dropdown list
of the Operating system (example: Windows), ensure that the Instance name
field has a value of DB2 and press the Next > button.

= Add Database Wizard ==
1. Source Specify the node options

2. Protocol “ou must provice the following information in order to configure the node for the database connection.

3. TCPARP

i Operating =w=tern h-“-ﬂndnws b |

4. Database
5. Data Source Instance name |DEFE

6. hlode Options
7. System Options

Cammert |

4 Back ] Mlext » ] | I Zarcel




Connecting WDI 3.3 Client to Server db — different machine

This should result in the “Specify the system options” screen being displayed (as
shown in the example below). Input the appropriate value in the System name,
ensure that the Host name field has the correct value and the Operating system
value is correct and press the Finish button.

'S Add Database Wizard

Source

(LS i L L b
]
0
o
=
o

. Data Source

o]
=
7]
el
]
(9]

E
7]
=
)

7. Swvstem Options
g. Security Options

Specify the system options

Yo must provide the following information in arder to configure the system for the database connection.

Systerm name J SEMIMNOLE Discowver |

Host name |seminnle tarmpa.usflibm.com igw Details. .. I
Operating syvstem |".-"~.'1I"|dDWS L]
Commert |

4 Eack Mext » I | Finizh I

Cancel




Connecting WDI 3.3 Client to Server db — different machine

This should result in the “Add Database

Confirmation” screen being " Add Database Confirmation - SEMIC33E
displayed (as shown in the example —
b e| OW) The configuration for database "SEMICIEE" was added successully.
i . oL Car;
Press the IeSt CO n nection button to Exit the &dd Database Wizard by clicking Close.
verify connectivity to the specified Add another database by clicking Add.
D b Change the databaze configuration by clicking Change.
ata ase. Test the connection ta the databaze by clicking Test Connection.
This will result in the “Test Connection” s _
window being displayed. Input a | cleange Test Connecton_|
valid value for the User ID and

Password and press the Test

Connection button. If you setup T —— T
correctly and provided valid User ID Connections | Resutts |
and Password values, you should Selert connection typs
get “CLI connection tested  EREE T oLEDB
successfully.” > au — upBC
After validating the Connection, press mCoEE meme

the Cancel button on the Test
Connection window.

When completed, press the Close
button on the Add Database
Conformation window. cancet | rew |

U=er IC |

Paz=sword |

Test Connection I




Connecting WDI 3.3 Client to Server db — different machine

 End of Connecting WDI 3.3 Client to
Server db for both same machine and
different machine.



