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About this guide

This guide tells how to install the Support Pack for HIPAA and how to configure

its components.

See [“How to use this guide” on page vil for a description of the parts of this guide.

Who should read this guide

You should know the following products and specifications and have access to

their documentation:

* IBM DB2 Universal Database
e IBM WebSphere Data Interchange

* IBM WebSphere Business Integration Collaborations for HIPAA Transactions

* IBM WebSphere InterChange Server

e IBM WebSphere MQ

Conventions and typography used in this guide

Typographical conventions

Usage

Italic

Indicates a variable name or a
cross-reference.

Monospace

Indicates a literal value, such as a command
name, file name, information that you type,
or information that the system prints on the
screen.

blue text

Indicates a cross-reference hyperlink. Blue
text is visible only when you view this guide
online. Click the blue text to jump to the
object of the reference.

In a syntax line, square brackets surround an
optional parameter.

In a syntax line, curly braces surround a set
of options from which you must select one
and only one.

In a syntax line, ellipses indicate a repetition
of the previous parameter. For example, [, ...]
means that you can enter multiple,
comma-separated options.

ProductDir

Represents the directory where a product is
installed. All product path names are relative
to the directory where the product is
installed on your system.

/ or \

Use the forward slash or the backslash when
appropriate for your platform.

© Copyright IBM Corp. 2004



The package distribution

You must obtain the products, files, and other components that make up the
Support Pack for HIPAA. These items are available for download. This guide
assumes that you have obtained these items, stored them in known directories, and
unpackaged them.

Throughout the documentation, you will be instructed to install products and files
from the directories where you installed them. |“User names, passwords, and file|
inames used” on page vii|lists the names given to the various installation
directories.

How to use this guide

vi

This section gives some basic instructions, tells how to use the step-by-step tables,
and lists the variables used throughout the guide.

This guide makes the following assumptions:
* All the required basic software is already installed.

* The user IDs, file names, project names, and database names given in the book
are only suggestions. If you substitute your own, you are responsible for using
the substitutes consistently.

Which part of the guide to use

This section tells which part of the guide to use, depending on your installation
and needs.

Part 1 Tells how to install and use the Support Pack for HIPAA with WebSphere
Data Interchange on an AIX system.

Part 2 Tells how to install and use the Support Pack for HIPAA with WebSphere
Data Interchange on a Microsoft Windows system.

Part 3 Tells how to install and use the Support Pack for HIPAA with WebSphere
Business Integration on an AIX system. After using Part 3, you can skip to
[Part 5, “Using the collaborations,” on page 39|

Part 4 Tells how to install and use the Support Pack for HIPAA with WebSphere
Business Integration on a Windows system.

Part 5 Tells how to install and use the HIPAA Collaborations and the Support
Pack for HIPAA Collaborations with both platforms.

Part 6 Contains an appendix listing some considerations and limitations for both
platforms. It also contains the Notices section.

Using the step-by-step tables in this guide

The steps for installing, configuring, or modifying each component of the Support
Pack for HIPAA are in 3-column tables. This section tells how to use the tables.

Left column
Window or prompt. This column tells where you are, what window is
open, or what the prompt is on the screen. For example, you might be at
the Windows system desktop or at a DB2 command window.

Center column
A sequence number to help you keep track of what to do next.

IBM WebSphere Data Interchange: Support Pack for HIPAA



Right column
Action. What to do, what to look for, or what the system displays.

Some commands within a table might be reformatted to fit the page. A
command with an indented line should be entered as one long line. For
example,

define
channel (CHANNEL1)
chltype (SVRCONN)

should be entered as
define channel (CHANNEL1) chltype(SVRCONN)

Table 1. Sample table

Window or prompt Action

Desktop Start » Programs > Accessories » Calculator.
Click 7.
Click +.
Click 8.
Click =.

The calculator displays 15.

Calculator

N ||| RN

Click X to close the calculator.

User names, passwords, and file names used

This guide uses the following user names, passwords, and file names throughout
the installation instructions. You can substitute your own names and passwords,
but you must be consistent in their usage. The names and passwords are in italics
throughout the guide.

This list contains names and passwords for both AIX systems and Windows
systems. Use those names that apply to your platform.

hostname_server
The name of your AIX or Windows server. This is also the server on which
you are installing the product. For example, hostname_server.queue.manager
is a queue manager name.

hipaa_admin
The administrative user who manages the databases. You create this user
and assign the necessary privileges. This user ID can have a maximum
length of 8 characters. If you are using an AIX system server, use the same
user ID and password for both the AIX system server and the Windows
system client.

hipaa_admin_password
The password used for the hipaa_admin user. Use the same user ID and
password for the AIX or Windows system server and the Windows system
client.

hipaa_home
The directory where you installed the collaborations and other .eif files.
This is the full path name down to that directory.

About this guide vii



viii

ics_database
The database that contains the WebSphere InterChange Server repository.
The database is created when installing the WebSphere InterChange Server.

ics_home
The directory where you installed WebSphere Business Integration. This is
the full path name down to that directory.

server_ICL_project
The Integrated Component Library project you define to hold the
WebSphere Business Integration files: collaborations, connectors, business
objects, and related files.

server_user_ project
The name of the user project on the server.

wdi_home
The directory where you installed the WebSphere Data Interchange server.
This is the full path name down to that directory.

IBM WebSphere Data Interchange: Support Pack for HIPAA



Part 1. Using the Support Pack for HIPAA with WebSphere
Data Interchange on an AIX system
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Chapter 1. Requirements for an AIX system

This chapter lists the hardware and software requirements for an AIX system.

Hardware and software requirements

These requirements are only for the HIPAA software required for an AIX system.
Other related and required software have additional requirements. The hardware
and software requirements listed are those that support only the products or
product components required for HIPAA. In some instances you install only
selected components of a product.

Some products consist of a server and client components. Those products might
require both an AIX system server and a Windows system client.

AIX system hardware requirements
The Support Pack for HIPAA has the following server hardware requirements:
* Two-way 750 MHz processor
* 2 GB RAM
* 40 GB free disk space
* Ethernet or token ring network connection

Software requirements

You need the following software installed on your AIX system before you install
the HIPAA component. This guide assumes the software is already installed.

* IBM AIX 5.1 maintenance level 4 or IBM AIX 5.2 maintenance level 1
* IBM DB2 Universal Database (DB2) 8.1 Fixpack 2

* IBM WebSphere Data Interchange Server 3.2 CSD 10

* IBM WebSphere MQ 5.3.1 CSD 5

Client system requirements

Several components require the installation of a client interface that runs only in a
Windows system environment. Therefore you also need a Windows system:

Windows system client

* Processor 400 MHz or faster

* Memory 256 MB or more

* Disk space 50 MB or more, 1 GB for applications and other documentation
* TCP/IP network interface

* A persistent Internet connection

Software requirements: You need the following software installed before you
install the HIPAA component. This guide assumes the software is already installed.

* Windows 2000, with Service Pack 4

* Windows Internet Explorer, Version 4.01 or higher

* IBM DB2 Universal Database (DB2) 8.1.2

* IBM WebSphere Data Interchange Client 3.2 Fixpack 8

© Copyright IBM Corp. 2004 3



* IBM WebSphere MQ 5.3.1 CSD 05
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Chapter 2. Installing and configuring

In this chapter you install the Support Pack for HIPAA packages.

distribution” on page vi| lists the information for downloading the packages.

Unpacking the Support Pack for HIPAA files at the Windows system

Table 2. Unpacking the Support Pack for HIPAA files at the Windows system

Window or prompt Action

Windows system prompt 1. Locate the directory where you downloaded and
stored the Support Pack for HIPAA tar file.

2. Create a directory called hipaa_home.

3. Unpack the Support Pack for HIPAA tar file into
hipaa_home.

WebSphere Data Interchange configuration for Support Pack for HIPAA

When you configure WebSphere Data Interchange to work with the Support Pack
for HIPAA you must create several WebSphere MQ queues. Do the following steps
to create the queues:

Table 3. Configuring the queues

Window or prompt Action

AIX system prompt 1. Copy the wdimgcommands.txt file from
hipaa_home/config to the wdi_home/samples directory.

2. To make wdimgcommands.txt executable, as root, enter:
chmod 777 wdi_home/samples/wdimgcommands.txt

3. To create the queue manager, enter the command:

crtmgm hostname_server.queue.manager

4. To start the queue manager, enter the command:

strmgm hostname_server.queue.manager

5. To create the WebSphere MQ queues, enter the
following commands:
cd wdi_home/samples

runmqsc hostname_server.queue.manager
< wdimgcommands.txt

Remote administration of a queue manager from the Windows
MQSeries Explorer interface to an AIX machine

The Queue Manager interface runs on the Windows system. Therefore, you must
do some of these steps at a Windows system and some at your AIX system.

© Copyright IBM Corp. 2004 5
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Administering the Queue Manager at the AIX system
On the AIX system, do the following:

Table 4. Administering the Queue Manager at the AIX system

Window or prompt

Action

AIX system prompt

. To create the channel, SYSTEM.ADMIN.SVRCONN,

enter the following two commands, each on a single

line:

runmgsc  hostname_server.queue.manager

define channel (SYSTEM.ADMIN.SVRCONN)
chltype(SVRCONN) trptype(TCP)

end

. Make sure you have set up your listener port for this

queue manager in the /etc/services file.

Edit the /etc/services file. Add the line:
MQSeries 1414/tcp

. Make sure you have set up your listener port for this

queue manager in the /etc/inetd.conf file.

Edit the file /etc/inetd.conf file. Enter the following
as a single line:

MQSeries stream tcp nowait
mgm
/usr/mgm/bin/amgcrsta
amqcrsta -m hostname_server.queue.manager

System prompt

. To refresh the command list, enter the command:

refresh -s inetd

. To start your queue manager, enter:

strmqcsv hostname_server.queue.manager

Administering the Queue Manager at the Windows system
Make sure the user that is logged on to your Windows system is also defined on
your AIX system and is part of the mgm group on the AIX system. In this guide

the user is hipaa_admin.

At the Windows system, do the following;:

Table 5. Administering the Queue Manager at the Windows system

Window or prompt

Action

Windows system Desktop

. Start the WebSphere MQ Explorer: Click Start »

Programs » IBM WebSphere MQ » WebSphere MQ
Explorer.

WebSphere MQ Explorer

. Right-click the Queue Managers folder > Show queue

manager.

. In the dialog box, enter the name of your queue

manager:
hostname_server .queue.manager

(The hostname is case sensitive.)

IBM WebSphere Data Interchange: Support Pack for HIPAA



Table 5. Administering the Queue Manager at the Windows system (continued)

Window or prompt

Action

Enter the IP address and port number of the AIX
system connection:

n.nnn.nnn.nnn (port)

For example, 1.234.567.890(1234). You can use
hostname_server in place of the IP address.

Click OK.

A new entry should show the queue manager and
that it is currently active.

Do not close the WebSphere MQ Explorer.

Defining triggers at the Windows system for the queues

Do the following steps to define triggers for the queues:

Table 6. Defining triggers for the queues at the Windows system

Window or prompt

Action

WebSphere MQ Explorer 1.

Expand WebSphere MQ Queue Manager -
hostname_server.queue.manager »> Queues.

The right panel displays a list of the queues:

DIEDIIN
DIEDIOUT
DIXMLIN
DIXMLOUT

Right-click DIEDIIN.

Click Properties » General tab.

Default Persistence

Select Persistent in the drop-down list.

Click the Triggering tab.

Click Trigger Control ON in the drop-down list.

Bl I A I Il

Enter the following information:

Initiation Queue Name: WDI.INIT.Q
Process Name: WDI.PROC

Right-click DIXMLIN and repeat steps 4 through 8.

10.

Close the MQ Explorer window.

Confirmation 11.

Click Yes.

Importing the configuration at the Windows system client

Do the following steps at the Windows system client:

Table 7. Importing the configuration at the Windows system client

Window or prompt

Action

WebSphere Data Interchange 1.

Windows Client desktop

Start the WebSphere Data Interchange Client: Click
Start » Programs » IBM WebSphere Data Interchange
MP V3.2 > WDI MP V3.2 Client.

Click File » Open Import File > HIPAAWDIConfig.eif
in the hipaa_home\config directory.

Chapter 2. Installing and configuring 7
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Table 7. Importing the configuration at the Windows system client (continued)

Window or prompt

Action

Import File 3. Expand each of the following folders. Use
Ctrl/left-mouse to select the files in one folder, then
click Import Selected Documents:

Mailbox

Network Profile
MQSeries Queues
Service Profile
Trading Partner

X Envelope Profile

Select a system 4. Specify the local host name of your AIX system and
click OK. This is the system you defined when you
configured WebSphere Data Interchange.

Extraction 5. The message Import completed is displayed.

Import Map Rules Options 6. Click Replace the existing map rule with active
imported map rule.

7. Click OK.
8. Click Close.
9. Repeat steps 2 through 5 for each folder.

Specifying the Queue Manager name
You must change the queue manager name from hipaa.queue.manager to
hostname_server.queue.manager for each of the queues.

Table 8. Specifying the Queue Manager name at the Windows system

Window or prompt

Action

Windows system, WebSphere
Data Interchange Client

1.

Click the Setup icon.

Setup 2. Click the MQSeries Queues tab.
3. Double-click the queue profile ID DIEDIIN.
General Properties 4. In the Queue Manager Name field change,

hipaa.queue.manager to
hostname_server.queue.manager.

Click Save.

6. Close the window.

Repeat steps 3 through 6 for the other three queues:
DIEDIOUT

DIXMLIN
DIXMLOUT

Close the window.

IBM WebSphere Data Interchange: Support Pack for HIPAA



Creating the HIPAA_XML_DICTIONARY at the Windows system
client
Do the following steps to create the HIPAA_XML_DICTIONARY:

Table 9. Creating the HIPAA_XML_DICTIONARY at the Windows system

Window or prompt Action
WebSphere Data Interchange 1. Click the XML icon.
Client

hipaa(xml)-Query:All Click the New icon.

Dictionary Name field Specify HIPAA_XML_DICTIONARY.

Description field This field is optional.

Click Save and close the window.

ook ||

Close the hipaa(xml)-Query:All window.

Importing the DTDs at the Windows system client
Do the following steps at the Windows client:

Table 10. Importing the DTDs at the Windows system client

Window or prompt Action

WebSphere Data Interchange 1. cd to the hipaa_home\collabs directory.
Windows Client desktop

2. Select the HIPAAdtds.zip file, and unzip it to the
wdi_home\runtime\dtds directory.

WDI Client 3. Click File » Open Import File.

4. In the wdi_home\runtime\dtds directory, select a DTD
you unzipped and click Open.

Select a system 5. Click hostname_server and click OK.
Import XML DTD 6. Accept the default DTD name.
Dictionary Name 7. Click the drop-down list and select

HIPAA_XML_DICTIONARY.

Root Element Name 8. Enter the same name as the DTD name.

9. Click Import.

10. Repeat steps 4 through 9 for each DTD you unzipped.

Configuring the DTDs at the Windows system client
Do the following steps to configure the DTDs at the Windows client:

Table 11. Configuring the DTDs at the Windows system client

Window or prompt Action
WebSphere Data Interchange 1. Click Setup.
Client
2. Click the Service Profiles Tab.
3. Double-click DIXMLIN.
PERFORM command, 4. Edit XMLDTDS (wdi_home) at the end of the file.
General tab Replace /pathname /DTDs with

wdi_home/runtime/dtds.

Chapter 2. Installing and configuring 9
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Table 11. Configuring the DTDs at the Windows system client (continued)

Window or prompt

Action

Click Save.

Click the X on the top-right corner to close the
window.

Enabling event logging at the Windows system

Turning on event logging enables you to view the Event log which contains more
detailed messages for WebSphere Data Interchange (WDI) Adapter return codes.
These messages are in the file WDIAdapter.trace.

To turn on event logging, do the following in the HIPAA Server Window at the

Windows system:

Table 12. Enabling event logging

Window or prompt

Action

hostname_server

Click the Application Defaults tab.

Double-click EDIMP.

Select Event Log Active at the bottom.

Click Save and close the window.

Double-click EDIFFS.

Select Event Log Active at the bottom.

N[ |G @

Click Save and close the window.

Importing and configuring the Support Pack for HIPAA at the

Windows client

In this series of steps, you import and configure the following:

e HIPAA standards files

e HIPAA code sets and forward translation

* HIPAA validation maps
* HIPAA transformation maps

Importing the HIPAA standards files
Do the following steps to import the HIPAA standards files:

Table 13. Importing the standards files at the Windows system

Window or prompt

Action

WebSphere Data Interchange
Client at the Windows
system

1.

Select File » Open Import File.

Select the HIPAA standards files, HIPAAStandards.eif
in the hipaa_home\data directory and click Open.

Expand the directory and select all the files.

Import File

Click Import Selected Documents.

Select a system

Specify hostname_server and click OK.

Extraction

The message Import completed is displayed.

N| ||

Click Close.
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Importing the HIPAA code sets and forward translation
Do the following steps to import the HIPAA code sets:

Table 14. Importing the code sets

Window or prompt Action
WebSphere Data Interchange 1. Select File » Open Import File.
Client

2. Select the HIPAA code sets HIPAACodeSets.eif in the
hipaa_home\data directory.

3. Expand the directory and select Code List. Select all
the files in the folder.

Import File Click Import Selected Documents.

Select a system Specify hostname_server and click OK.

Extraction The message Import completed is displayed.

Click Close.

PN

Repeat steps 3 through 7 for the file in the Forward
Translation folder.

Importing the validation maps
Do the following steps to import the validation maps:

Table 15. Importing the validation maps

Window or prompt Action
WebSphere Data Interchange 1. Click File » Open Import File.
Client
Import File 2. Select the HIPAA validation maps
HIPAAValidationMaps.eif in the hipaa_home\data
directory.
3. Expand the directory and select all the files.
Import File 4. Click Import Selected Documents.
Select a system 5. Specify hostname_server and click OK.
Extraction 6. The message Import completed is displayed.
7. Click Close.

Importing transformation maps
Do the following steps to import the transformation maps:

Table 16. Importing the transformation maps

Window or prompt Action
WebSphere Data Interchange 1. Click File » Open Import File.
Client

2. Select the HIPAA transformation maps
HIPAATransformationMaps.eif in the hipaa_home\data
directory.

Expand the directory and select all the files.

Import File Click Import Selected Documents.

Select a system Specify hostname_server and click OK.

SN IS I

Extraction The message Import completed is displayed.

Chapter 2. Installing and configuring 11



Table 16. Importing the transformation maps (continued)

Window or prompt Action
7. Click Close.

Compiling the control maps
Do the following steps to compile the control strings:

Table 17. Compiling the control strings

Window or prompt Action

WebSphere Data Interchange 1. Click the Mapping icon.
Client

Click the Data Transformation Maps tab.
Select all the Maps.

Click the Compile icon.
Click the Validation Maps tab.
Select all the Maps.

Click the Compile icon again.

PRI [T ®

Click X to close the Mapping window.

You must recompile the maps after you apply a Corrective Service Diskette (CSD)
at the client.

Validating the WebSphere Data Interchange installation
This validation checks whether the WebSphere Data Interchange installation is
working correctly with HIPAA-specific messages. The test uses files in the
hipaa_home\sample directory.

Do the following steps to validate the installation:

Table 18. Validating the WebSphere Data Interchange installation

Window or prompt Action
WebSphere Data Interchange 1. Ensure that the command file HIPAAWDITest8371.cmd is
server prompt in the same path as HIPAA8371.X12.

2. Set the environment. Enter:

. /usr/wdi/D1v32/samples/setdienv.sh

3. Log out, then log in again as hipaa_admin to have the
environment change take effect. To verify the
environment, enter:

echo $LIBPATH

and see that /usr/wdi/D1v32/bin is in the libpath.

4. To specify that the command is executable, enter:
chmod 777 HIPAAWDITest837I.cmd

WDI server prompt 5. Enter the command:
HIPAAWDITest8371.cmd

12 1BM WebSphere Data Interchange: Support Pack for HIPAA



Table 18. Validating the WebSphere Data Interchange installation (continued)

Window or prompt Action

6. The following messages are displayed:

DI Translator Started, build date time stamp
DI Translator processed your request.
DI Translator shutdown.

7. After successful translation, the WDI Server has
received a message for processing and a new file has
been created in the current directory.

8. The file contains information similar to

1Audit Trail Report -Datalnterchange Utility- Date: 04/01/22 Time: 11:23:25 Page: 00001

FF0588 Command: PERFORM TRANSFORM WHERE INFILE(EDIFILE) OUTFILE(OUTFILE)
SYNTAX(E) CLEARFILE(Y) TRACELEVEL(A2)

Message: EVOO19 Severity: 04

No trading partner found. Qualifier = 20 ID = 15.
Message: EVOO19 Severity: 04
No trading partner found. Qualifier = 20 ID = 15.

Message: RUOOO3 Severity: 00
The best rule match for the document was: map name 837INST_TO_XML,
sending TP nickname ANY, receiving TP nickname ANY,
usage indicator P, document 837, dictionary name HIPAAI, syntax edi.
Message: UTO008 Severity: 00
Map name being processed: X12_837INST.
Message: UTO008 Severity: 00
Map name being processed: 837INST_TO XML.
Message: UTO008 Severity: 00
Map name being processed: $DT_FA997V3R7.

FFO007 Data was written to OUTFILE. Message control number or document id was .
FFO007 Data was written to QDATA. Message control number or document id was 0000000
FF0584 The PERFORM TRANSFORM command completed with a severity code of 04.

See associated messages to determine the acceptability

of the transformation.

Figure 1. Output from validating the WebSphere Data Interchange installation
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Part 2. Using the Support Pack for HIPAA with WebSphere
Data Interchange on a Windows system
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Chapter 3. Requirements for a Windows system

This chapter lists the hardware and software requirements for a Windows system.

Hardware and software requirements

These requirements are only for the HIPAA software. Other related and required
software have additional requirements.

For the AIX operating system requirements, see [Part 1, “Using the Support Pack for|
[HIPAA with WebSphere Data Interchange on an AIX system,” on page 1]

Because each software component has specific requirements, you might be required
to have more than one level of a component simultaneously.

Hardware requirements

You can install all of the required program products on one system. This guide
assumes that you are installing all the program products on a single system.

The WebSphere Data Interchange Server has the following requirements:

* A system (or equivalent) with a minimum processor speed of 1 GHz or dual
processors each with a minimum speed of 667 MHz (for high availability)

e 512 MB menory

Server

* Processor 1 GHz or faster
* Memory 512 MB or more
* Disk space 20 GB or more
e TCP/IP network interface

* A persistent Internet connection

Client

* Processor 400 MHz or faster

* Memory 256 MB or more

¢ Disk space 50 MB or more, 1 GB for applications and other documentation
e TCP/IP network interface

* A persistent Internet connection

Software requirements

You need the following software installed before you install the Support Pack for
HIPAA component. This guide assumes the software and any prerequisites are
already installed.

* IBM DB2 Universal Database, Version 8.1 Fixpack 2

* IBM WebSphere MQ, Version 5.3.1 CSD 05

* IBM WebSphere Data Interchange Server, Version 3.2 CSD 10

e IBM WebSphere Data Interchange Client, Version 3.2 Fixpack 8

© Copyright IBM Corp. 2004 17



Support Pack for HIPAA requires the Windows 2000 (Professional, Server, or
Advanced Server) with Service Pack 3 operating system.

Before you install the Support Pack for HIPAA product files
Before you install the Support Pack for HIPAA product files, the following
products should be installed:

* WebSphere Data Interchange Server and Client with any Corrective Service
Diskettes (CSDs) installed and configured

* WebSphere MQ and any CSDs installed
* DB2 installed and configured, and the required databases created
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Chapter 4. Installing and configuring

This chapter describes installing and configuring the Support Pack for HIPAA.

Unpacking the Support Pack for HIPAA product files

Do the following steps to unpack the product files:

Table 19. Unpacking the Support Pack for HIPAA product files

Window or prompt

Action

Windows Desktop

. cd to the directory where you installed the Support

Pack for HIPAA zip file.

. Create a directory called hipaa_home.

. Unpack the Support Pack for HIPAA zip file into

hipaa_home.

Creating WebSphere MQ queues

Do the following steps to create WebSphere MQ queues:

Table 20. Creating WebSphere MQ queues

Window or prompt

Action

Windows Desktop

. Copy the hipaa_home\config\wdimgcommands.txt file

to the wdi_home\samples directory.

. cd to wdi_home\samples.

. To create the queue manager, enter the following

command:

crtmgm hostname_server.queue.manager

. To start the queue manager, enter the command:

strmgm hostname_server.queue.manager

. Enter the following command on one line:

runmgsc hostname_server.queue.manager
< wdimgcommands.txt

Defining triggers for the queues

Do the following steps to define triggers for the queues:

Table 21. Defining triggers for the queues

Window or prompt

Action

Desktop

. Start the WebSphere MQ Explorer: Click Start »

Programs » IBM WebSphere MQ » WebSphere MQ
Explorer.

WebSphere MQ Explorer

. Expand WebSphere MQ Queue Manager -

hostname_server.queue.manager » Queues.

© Copyright IBM Corp. 2004
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Table 21. Defining triggers for the queues (continued)

Window or prompt Action

3. The right panel displays a list of the queues:

DIEDIIN
DIEDIOUT
DIXMLIN
DIXMLOUT

4. Right-click DIEDIIN.

DIEDIIN Properties 5. Click Properties » General tab.

6. Default Persistence: Click Persistent in the drop-down
list.

7. Click the Triggering tab.

8. Click Trigger Control ON in the drop-down list.

9. Enter the following information:

Initiation Queue Name: WDI.INIT.Q
Process Name: WDI.PROC

Click OK.

10. Right-click DIXMLIN and repeat steps 5 through 9.

11. Close the MQ Explorer window.

Confirmation 12. Click Yes.

Importing the configuration

Do the following steps to import the configuration:

Table 22. Importing the configuration

Window or prompt Action

WebSphere Data Interchange 1. Click File » Open Import File > HIPAAWdiConfig.eif
Client in the hipaa_home\config directory.

Import File 2. Expand each of the following folders. Use

Ctrl/left-mouse to select the files in one folder, then
click Import Selected Documents:

MaiTbox

Network Profile
MQSeries Queues
Service Profile
Trading Partner

X Envelope Profile

Select a system 3. Specify hostname_server and click OK.
Extraction 4. The message Import completed is displayed.
Import Map Rules Options 5. Click Replace the existing map rule with active
imported map rule.
6. Click OK.

7. Click Close.

8. Repeat steps 2 through 5 for each folder.
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Specifying the Queue Manager name

You must change the queue manager name from hipaa.queue.manager to
hostname_server.queue.manager for each of the queues. Do the following steps to

specify the queue manager name:

Table 23. Specifying the Queue Manager name

Window or prompt

Action

WebSphere Data Interchange 1. Click the Setup icon.
Client
Set up 2. Click the MQSeries Queues tab.
3. Double-click the queue profile ID DIEDIIN.

General Properties

4. In the Queue Manager Name field change

hipaa.queue.manager to
hostname_server.queue.manager.

Click Save.

Close the window.

Repeat steps 3 through 6 for the other three queues:

DIEDIOUT
DIXMLIN
DIXMLOUT

Close the window.

Importing the DTDs

Do the following steps to import the DTDs:

Table 24. Importing the DTDs

Window or prompt

Action

Command window 1. Unzip hipaa_home\collabs\HIPAAdtds.zip to the
wdi_home\runtime\dtds directory.
WebSphere Data Interchange 2. Click File » Open Import File.
Client
3. Set "Files of Type” to "XML DTD File (*.dtd).”
Select Import File 4. Select a DTD you unzipped and click Open.
5. Click hostname_server and click OK.
Import XML DTD 6. Accept the default DTD name.
7. Dictionary Name: Click the drop-down list and select

HIPAA_XML_DICTIONARY.

Specify the root element name, the same value as the
DTD name. Add a Description if you want.

Click Import.

10.

Repeat the steps for each DTD you unzipped.
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Configuring the DTDs

Do the following steps to configure the DTDs:

Table 25. Configuring the DTDs

Window or prompt

Action

WebSphere Data Interchange
Client

Click Setup.

Click the Service Profiles tab.

Service Profile

Double-click DIXMLIN.

PERFORM command,
General tab

Edit XMLDTDS (wdi_home) at the end of the file. Replace
\pathname\DTDs with wdi_home\runtime\dtds.

Click Save.

Click the X to close the window.

Installing and configuring the Support Pack for HIPAA
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In these sections you import the following:

e HIPAA standards files

e HIPAA code sets and forward translation

* HIPAA validation maps

e HIPAA transformation maps

Importing the HIPAA standards files

Do the following steps to import the HIPAA standards files:

Table 26. Importing the standards files

Window or prompt

Action

WebSphere Data Interchange
Client

1.

Select File » Open Import File.

Select Import File

Select the HIPAA standards files, HIPAAStandards.eif
in the hipaa_home\data directory.

Expand the directory and select all the files.

Click the Import Selected Documents icon.

Select a system

Specify hostname_server and click OK.

Extraction

SN S

Click OK to replace the file. You can ignore messages
about overwriting existing files.

Verify that the message Import completed is
displayed. Click Close.

A blue check icon indicates each item that was
successfully imported.

Close the window.
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Importing the HIPAA code sets and forward translation
Do the following steps to import the HIPAA code sets:

Table 27. Importing the code sets

Window or prompt Action
WebSphere Data Interchange 1. Select File » Open Import File.
Client

2. Select the HIPAA code sets HIPAACodeSets.eif in the
hipaa_home\data directory.

3. Expand the directory and select Code List. Select all
the files in the folder.

Import File 4. Click Import Selected Documents.
Select a system 5. Specify hostname_server and click OK.
Extraction 6. You can ignore messages about overwriting existing

files. The message Import completed is displayed.
7. Click Close.

8. Repeat steps 3 through 7 for the file in the Forward
Translation folder.

Importing the validation maps
Do the following steps to import the validation maps:

Table 28. Importing the validation maps

Window or prompt Action

WebSphere Data Interchange 1. Click File » Open Import File.

Client

Import File 2. Select the HIPAA validation maps
HIPAAValidationMaps.eif in the hipaa_home\data
directory.

Import File Click Import Selected Documents.

Expand the directory and select all the files.

Select a system Specify hostname_server and click OK.

SN IS I

Extraction You can ignore messages about overwriting existing

files. The message Import completed is displayed.
7. Click Close.

Importing the transformation maps

Do the following steps to import the transformation maps:

Table 29. Importing the transformation maps

Window or prompt Action

WebSphere Data Interchange 1. Click File » Open Import File.

2. Select the HIPAA transformation maps
HIPAATransformationMaps.eif in the hipaa_home\data
directory.

Import File 3. Click Import Selected Documents.

4. Expand the directory and select all the files.
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Table 29. Importing the transformation maps (continued)

Window or prompt

Action

Select a system

Specify hostname_server and click OK.

Extraction

You can ignore messages about overwriting existing
files. The message Import completed is displayed.

Click Close.

Compiling the validation and transformation maps

Do the following steps to compile the validation and transformation maps:

Table 30. Compiling the validation and transformation maps

Window or prompt

Action

WebSphere Data Interchange

1.

Click the Mapping icon.

hostname_server(Mapping)
— Query:All

N

Click the Data Transformation Maps tab.

Select all the Maps.

Click the Compile icon.

Click the Validation Maps tab.

Select all the Maps.

N |G

Click the Compile icon again.

You must recompile the maps after you apply a Corrective Service Diskette (CSD)

at the client.

Enabling event logging

24

Turning on event logging enables you to view the Event log which contains more
detailed messages for WDI Adapter return codes. These messages are in the file,

WDIAdapter.trace.

To turn on event logging, do the following in the HIPAA Server Window:

Table 31. Enabling event logging

Window or prompt

Action

hostname_server
(Setup)-Query:All

Click the Application Defaults tab.

Double-click EDIMP.

Select Event Log Active at the bottom.

Click Save and close the window.

Double-click EDIFFS.

Select Event Log Active at the bottom.

N |G ®

Click Save and close the window.
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Validating the WebSphere Data Interchange installation

Validation checks whether the WebSphere Data Interchange installation is working
correctly with HIPAA-specific messages. The test uses the HIPAAWDITest8371.cmd
file in the hipaa_home\sample directory.

Do the following steps at the WebSphere Data Interchange server prompt:

Table 32. Validating the WDI installation

Window or prompt Action

WebSphere Data Interchange 1. Ensure that the command file HIPAAWDITest8371.cmd is
server prompt in the same path as HIPAA8371.X12.

WDI server prompt 2. Enter the command:

ediservr < HIPAAWDITest8371.cmd

3. The following messages are displayed:

DI Translator Started, build date time stamp
DI Translator processed your request.
DI Translator shutdown.

4. After successful translation, the WebSphere Data
Interchange Server has received a message for
processing and a new file has been created in the
current directory.

5. The file contains information similar to

1Audit Trail Report -Datalnterchange Utility- Date: 04/01/22 Time: 11:23:25 Page: 00001

FF0588 Command: PERFORM TRANSFORM WHERE INFILE(EDIFILE) OUTFILE(OUTFILE)
SYNTAX(E) CLEARFILE(Y) TRACELEVEL(A2)

Message: EVOO19 Severity: 04

No trading partner found. Qualifier = 20 ID = 15.
Message: EVOO19 Severity: 04
No trading partner found. Qualifier = 20 ID = 15.

Message: RUOOO3 Severity: 00
The best rule match for the document was: map name 837INST_TO_XML,
sending TP nickname ANY, receiving TP nickname ANY,
usage indicator P, document 837, dictionary name HIPAAI, syntax edi.
Message: UTO008 Severity: 00
Map name being processed: X12_837INST.
Message: UTO008 Severity: 00
Map name being processed: 837INST_TO XML.
Message: UTO008 Severity: 00
Map name being processed: $DT_FA997V3R7.

FFO007 Data was written to OUTFILE. Message control number or document id was .
FFO007 Data was written to QDATA. Message control number or document id was 0000000
FF0584 The PERFORM TRANSFORM command completed with a severity code of 04.

See associated messages to determine the acceptability

of the transformation.

Figure 2. Output from validating the WebSphere Data Interchange installation
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Part 3. Using the Support Pack for HIPAA with WebSphere
Business Integration on an AIX system
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Chapter 5. Getting started

This section lists the requirements for using the Support Pack for HIPAA with IBM
WebSphere Business Integration on an AIX system.

HIPAA software requirements

You need the following software installed on your AIX system. This guide assumes
the software is already installed.

IBM AIX 5.1 maintenance level 4 or IBM AIX 5.2 maintenance level 1
IBM DB2 Universal Database (DB2) 8.1 Fixpack 2

IBM WebSphere MQ 5.3.1 installed with CSD 05

IBM Java Development Kit 1.3.1 SR5

IBM WebSphere InterChange Server 4.2.2

IBM WebSphere Business Integration Toolset 4.2.2

IBM WebSphere Business Integration Data Handler for XML 2.5.0

IBM WebSphere Business Integration Adapter for eMail 5.2.0

IBM WebSphere Business Integration Adapter for JDBC 2.4.0

IBM WebSphere Business Integration Adapter for WebSphere MQ 2.5.0

Adobe Acrobat Reader (available free for download from
[http: / /www.adobe.coml)

A browser

Installing the HIPAA Collaborations

See the Support Pack for HIPAA readme for the latest information on installing the
HIPAA collaborations.
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Chapter 6. Configuring

Do these steps to configure your software for the Support Pack for HIPAA.

Defining queues and starting the WebSphere MQ Queue Manager

After the InterChange Server is installed, you must configure the WebSphere MQ
messaging system to work with the InterChange Server by:

* Configuring the WebSphere MQ scripts

 Setting up the WebSphere MQ messaging system

Do the following steps to configure the WebSphere MQ scripts:

Table 33. Starting the WebSphere MQ Queue Manager

Window or prompt

Action

AIX system prompt

. Use an ASCII editor to edit the file,

hipaa_home/config/hipaa mq.tst.

In these lines, substitute your local host name, where
hostname_server is the correct value for your
InterChange Server installation:

DEFINE QLOCAL
(IC/hostname_server/JDBC_PROConnector)
DEFINE QLOCAL
(AP/JDBC_PROConnector/hostname_server)
DEFINE QLOCAL
(IC/hostname_server/JDBC_MSGConnector)
DEFINE QLOCAL
(AP/JDBC_MSGConnector/hostname_server)
DEFINE QLOCAL
(AP/WDI_MQConnector/hostname_server)
DEFINE QLOCAL
(IC/hostname_server/WDI_MQConnector)
DEFINE QLOCAL
(AP/Col1ab_MQConnector/hostname_server)
DEFINE QLOCAL
(IC/hostname_server/Collab_MQConnector)
DEFINE QLOCAL
(AP/Legacy_MQConnector/hostname_server)
DEFINE QLOCAL
(IC/hostname_server/Legacy_MQConnector)
DEFINE QLOCAL
(AP/EmailConnector/hostname_server)
DEFINE QLOCAL
(IC/hostname_server/EmailConnector)

3.

Save the modified file.

4.

To make the file executable, enter:
chmod +x hipaa_home/config/hipaa_mq.tst

5.

To create the queues, enter, on a single line:

runmgsc hostname_server.queue.manager
< hipaa_home.../config/hipaa_mq.tst
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Creating an Integration Component Library at the Windows system

client

Do the following steps to create an Integration Component Library:

Table 34. Creating an Integration Component Library at the Windows system

Window or prompt Action

Windows system desktop 1. Start the ICS System Manager: Start > Programs -
IBM WebSphere InterChange Server »
Administrative > System Manager.

System Manager 2. Right-click Integration Component Library.
InterChange Server dialog 3. Click New Integration Component Library.
box

4. Enter the name for your project: server_ICL_project.

5. Click Finish.

Creating connector directories

Use the hipaa_ConnectorActivate.sh script to set up the connector directory
structure and copy files.

This guide assumes the JDBC connector has been enabled for multi-driver support,
specifically DB2 support. The JDBC connector’s start file should already include all
relevant class path names in the JDBCDRIVERPATH variable. If this configuration
is not done before running the hipaa_ConnectorActivate.sh script, it must be done
for each JDBC connector instance later.

Do the following steps to create the connectors:

Table 35. Creating the connectors for AlX at the Windows system

Window or prompt Action

AIX system 1. Copy the file hipaa_ConnectorActivate.sh from
hipaa_home/config to ics_home/connectors.

2. Copy the file hipaa_ActivateAl1Connectors.sh from
hipaa_home/config to ics_home/bin.

3. Add execute permission to
hipaa_ConnectorActivate.sh and
hipaa_ActivateAllConnectors.sh.

4. cd to ics_home/connectors.

5. Run ./hipaa_ConnectorActivate.sh.

After configuring WebSphere InterChange Server and deploying the
server_user_project project, run the ./hipaa ActivateAllConnectors.sh script to
activate the connectors as described in [“Activating the connectors” on page 64/
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Part 4. Using the Support Pack for HIPAA with WebSphere
Business Integration on a Windows system
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Chapter 7. Getting started

This section lists the requirements for using the Support Pack for HIPAA with IBM
WebSphere Business Integration on a Windows system.

HIPAA software requirements

You need the following software installed on your AIX system. This guide assumes
the software is already installed.

* Windows 2000 with SP 4

* IBM DB2 Universal Database (DB2) 8.1 Fixpack 2

* IBM WebSphere MQ installed with CSD 05

* IBM Java Development Kit 1.3.1.6

* IBM WebSphere InterChange Server 4.2.2

* IBM WebSphere Business Integration Toolset 4.2.2

* IBM WebSphere Business Integration Data Handler for XML 2.5.0

¢ IBM WebSphere Business Integration Adapter for eMail 5.2.0

* IBM WebSphere Business Integration Adapter for JDBC 2.4.0

* IBM WebSphere Business Integration Adapter for WebSphere MQ 2.5.0

» Adobe Acrobat Reader (available free for download from
[http: / /www.adobe.coml)

e A browser

Installing the HIPAA Collaborations

See the Support Pack for HIPAA readme for the latest information on installing the
HIPAA collaborations.

Defining queues for WebSphere MQ

You must configure the WebSphere MQ queues needed for the adapters.
WebSphere MQ includes a batch file and a text file that helps you configure the
queues. You must edit the text file, hipaa_mg.tst, to replace the default
information with the name of your system.

Do the following steps to configure the queues:

Table 36. Defining queues for WebSphere MQ

Window or prompt Action

Windows Desktop 1. Use an ASCII editor to edit the file,
hipaa_home\config\hipaa_mg.tst.
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Table 36. Defining queues for WebSphere MQ (continued)

Window or prompt

Action

. In these lines, substitute your local host name, where

hostname_server is the correct value for your
InterChange Server installation:

DEFINE QLOCAL(IC/hostname_server/JDBC_PROConnector)
DEFINE QLOCAL(AP/JDBC_PROConnector/hostname_server)
DEFINE QLOCAL(IC/hostname_server/JDBC_MSGConnector)
DEFINE QLOCAL(AP/JDBC_MSGConnector/hostname_server)
DEFINE QLOCAL(AP/WDI_MQConnector/hostname_server)
DEFINE QLOCAL(IC/hostname_server/WDI_MQConnector)
DEFINE QLOCAL(AP/Collab_MQConnector/hostname_server)
DEFINE QLOCAL(IC/hostname_server/Collab_MQConnector)
DEFINE QLOCAL(AP/Legacy MQConnector/hostname_server)
DEFINE QLOCAL(IC/hostname_server/Legacy MQConnector)
DEFINE QLOCAL(AP/EmailConnector/hostname_server)
DEFINE QLOCAL(IC/hostname_server/EmailConnector)

. Save the modified file.

Windows System command
prompt

. To create the queues, enter, on a single line:

runmgsc hostname_server.queue.manager
< hipaa_home...\config\hipaa_mq.tst

Creating an Integration Component Library

Do the following steps to create an Integration Component Library:

Table 37. Creating an Integration Component Library

Window or prompt

Action

System Manager

. Start the Persistent Name Server and InterChange

Server, then start the System Manager and connect it
to the server.

. Create a new Integration Component Library, if one

does not already exist.

System Manager

. Right-click on Integration Component Libraries, click

Select New Integration Component Library.

. Enter a name for your project. The name can be

characters or numbers. Spaces are not allowed. This
guide assumes server_ICL_project as the name.

. Click Finish.

Creating connector directories

36

Use the hipaa_ConnectorActivate.bat utility to set up the connector directory

structure and copy files.

This guide assumes the JDBC connector has been enabled for multi-driver support,
specifically DB2 support. The JDBC connector’s start file should already include all
relevant class path names in the JDBCDRIVERPATH variable. If this is not done
before this section, it must be done for each JDBC connector instance later.
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Do the following steps to create the connectors:

Table 38. Creating the connectors at the Windows system

Window or prompt Action

Windows desktop 1. Copy the file hipaa_ConnectorActivate.bat from
hipaa_home/config to ics_home/connectors.

2. Copy the file hipaa_ActivateAl1Connectors.bat from
hipaa_home/config to ics_home/connectors.

3. cd to ics_home/connectors.

4. Run hipaa_ConnectorActivate.bat.

After configuring WebSphere InterChange Server and deploying the
server_user_project project, run the ./hipaa ActivateAllConnectors.bat script to
activate the connectors as described in [“Activating the connectors” on page 64/
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Part 5. Using the collaborations
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Chapter 8. Installing and configuring the collaborations

This chapter tells how to install the Support Pack for HIPAA collaborations. The
chapter contains information for both AIX systems and Windows systems. Use the
information that is appropriate for your platform.

On an AIX system, you install the collaborations with the WebSphere Business
Integration System Manager at the Windows client. On a Windows system, you
install everything at the Windows system.

About the Support Pack for HIPAA bridge collaborations

The Support Pack for HIPAA includes a set of bridge collaboration templates
designed to interact with the existing IBM HIPAA collaborations and WebSphere
Data Interchange to enable insurance companies and other payers to comply with
the United States Health Insurance Portability and Accountability Act of 1996. The
Support Pack for HIPAA bridge collaboration templates work with the existing
HIPAA collaboration templates.

Creating the HIPAA databases and tables

Scripts are provided to set up your HIPAA collaboration databases and tables. The
databases are:

* HIPAADB, used by a variety of collaboration objects to hold specific state data.
* HIPAAMSG, used to store the 837 messages for the payer perspective.
* HIPAAPRO, used to store the 837 messages for the provider perspective.

Refer to HIPAA Collaboration documentation for information on creating the
HIPAA databases and tables.

Maintenance and management of the records held in the HIPAA databases are the
responsibility of your database administrator. No database pruning or maintenance
is done by the HIPAA collaborations.

Importing Support Pack for HIPAA bridge collaborations using the
System Manager at the Windows system

Do these steps for both AIX and Windows systems.

To install Support Pack for HIPAA, complete the following steps in the System
Manager window:

Table 39. Importing the Support Pack for HIPAA bridge collaborations using the System

Manager

Window or prompt Action

System Manager at the 1. In the Integration Component Libraries, right-click
Windows system server_ICL project.

2. Select Import Repository File.

3. Browse for the InterChange Server repository file.
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Table 39. Importing the Support Pack for HIPAA bridge collaborations using the System
Manager (continued)

Window or prompt Action

4. Select the
hipaa_home\collabs\HIPAABridgeCollabs.jar file.

5. Click Open.

Import Repository File 6. Click Finish.

Importing HIPAA collaborations files

Import the HIPAA collaboration templates, business objects, and relationships jar
files into the server ICL project through the System Manager. See [Chapter 5]
[‘Getting started,” on page 29|and [Chapter 7, “Getting started,” on page 35| for AIX
and Windows systems respectively for the latest version of the HIPAA
collaborations. Refer to the HIPAA collaboration documentation for information on
importing collaboration files.

Adding business objects to server_ICL_project

Use the Business Object Designer to add the business objects to
server_ICL_project.

Table 40. Adding business objects to server ICL project

Window or prompt Action

Windows Desktop 1. Start the Business Object Designer: Start > Programs >
IBM WebSphere InterChange Server » IBM
WebSphere Business Integration Toolset >
Development » Business Object Designer.

Business Object Designer 2. Click File » Open From File.
Import Business Objects from 3. Change "files of type” to "*.txt".
Files

4. In the directory
IBM\ICSWebSphere\repository\DataHandlers, select:

MO_DATAHandler_Default
MO_DATAHandler Delimited
MO_DATAHandler EDI
MO_DATAHandler_FixedWidth
MO_DATAHandler_NameValue
MO_DATAHandler_Swift
MO_DATAHandler_ XML

5. Click Open.

6. Edit the file MO_DATAHandler_DefaultXMLConfig and
remove "XMLTEST” from the default BOPrefix.

7. Save the file and close the editor.

8. Select the directory edk.

9. Select MO_Server_DataHandler.

10. Click Open.

11. Close all the data handlers in the Business Object
Designer window.

12. Close the Business Object Designer window.
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Creating the business objects

In this section you create the MetaObject business objects used with the WebSphere

MQ connectors.

Business object

DI_MetaObject
[Legacy_MetaObject]
[Collab_MetaObject]|

Connector

[DBC and WebSphere MQ)|

PortConnector|

[WDI_MQConnector]|

[Legacy_ MQConnector]

[Collab MQConnector]

Creating the WDI_MetaObject business object

The WDI_MetaObject business object is used by the MO_DataHandler_Default and
the WDI_MQConnector. You configure it to process each HIPAA Collaboration
business object, and send a copy to an output queue. Do the following steps to
create the WDI_MetaObject business object:

Table 41. Creating the WDI_MetaObject Business Object

Window or prompt

Action

System Manager

. Expand Integration Component Libraries »

server_ICL_project.

. Right-click Business Objects » Create a New

Business Object.

New Business Object

. Enter the Business Object Name: WDI_MetaObject.

Business Object designer

. Click OK.

. Add the attributes to the WDI_MetaObject business

object. Set the following attributes for the first entry:

Name: Default
Type: String
Key:

The App Spec Info column is:

OutputQueue=queue://hostname_server.queue.
manager/DIXMLIN?targetClient=1

6. Click File and Save.

Creating the Legacy_MetaObject business object

You must use a separate metaobject for the Legacy_ MQConnector. The
Legacy_MetaObject is used with the Legacy_MQConnector. Perform the following
steps to create the Legacy_MetaObject:

Table 42. Creating the Legacy_MetaObject business object

Window or prompt

Action

System Manager

1. Expand Integration Component Libraries -

server_ICL project.

2. Right-click Business Objects > Create a New

Business Object.
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Table 42. Creating the Legacy_MetaObject business object (continued)

Window or prompt Action
New Business Object 3. Enter the Business Object Name: Legacy_MetaObject.
Business Object designer 4. Click OK.

5. Add the attributes to the new Legacy_MetaObject
business object. Set the following attributes for the
first entry:

Name: Default
Type: String
Key:

The App Spec Info column is:

OutputQueue=queue://hostname_server.queue.
manager/LEGACYCONN.OUT?targetClient=1

6. Click File and Save.

Creating the Collab_MetaObject business object

You must use a separate metaobject for the Collab_MQConnector. The
Collab_MetaObject is used with the Collab_MQConnector. Perform the following
steps to create the Collab_MetaObject:

Table 43. Creating the Collab_MetaObject Business Object

Window or prompt Action

System Manager 1. Expand Integration Component Libraries »
server_ICL _project.

2. Right-click Business Objects » Create a New
Business Object.

New Business Object 3. Enter the Business Object Name: Collab_MetaObject.

Business Object designer 4. Click OK.

5. Add the attributes to the Collab_MetaObject business
object. Set the following attributes for the first entry:

Name: Default
Type: String
Key:

The App Spec Info column is:

OutputQueue=queue://hostname_server.queue.
manager/COLLABCONN.OUT?targetClient=1

6. Click File and Save.

Creating connectors

44

In this section you create and configure connectors. The WebSphere Business
Integration Adapter for WebSphere MQ allows applications to communicate using
WebSphere MQ messages. It uses the WebSphere Business Integration DataHandler
for XML, which converts business objects to and from the XML format without the
need to provide a complex mapping between an XML document and
application-specific business objects. It generates business objects from DTD or
XML Schema definitions.

In this section, you create the following connectors:
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[(WDI_MQConnector|
* [Legacy_ MQConnector|
[Collab_MQConnector

. PortConnectoﬂ

* JDBC_PRO connector|
[J[DBC_MSG connector|

Adding JDBC and WebSphere MQ connectors
Do the following steps to add JDBC and WebSphere MQ connectors:

Table 44. Adding a JDBC connector at the Windows system

Window or prompt Action

Windows system Desktop 1. Start the Connector Configurator: Start » Programs -
IBM WebSphere InterChange Server » IBM
WebSphere Business Integration Toolset -
Development » Connector Configurator.

Connector Configurator 2. Click File » Open ~ From File.

Browse 3. Browse to WebSpherelCS - repository > JDBC.

4. Change "files of type” to "all files **" and open the
file CN_JDBC. txt.

5. Click the Messaging tab and fill in the information

from [Table 45

Click File » Save » To Project.

Click server_ICL project.
Click OK.

Repeat steps 2 through 8 for the WebSphere MQ
adapter in the directory WebSphereAdapters »
repository » WebSphere MQ » CN_WebSphereMQ. txt.

V| X | N

10. Close the Connector Configurator window.

Setting messaging properties
lists the messaging properties for all connectors:

Table 45. Connector Configurator — Messaging properties

Field Value

Messaging Type MQSERIES

Host Name hostname_server

Queue Manager hostname_server.queue.manager
Client Channel CHANNEL1

Port 1414

Creating the PortConnector

Create the PortConnector to bind any extra ports that are not used. The HIPAA
collaborations have extra ports that could be used in your installation, but if they
are not used, they can be bound with the PortConnector.
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This PortConnector never runs, but it must be configured to work with the
business objects in [Table 48 on page 47 Other property fields need not be
configured.

To create this connector, do the following steps:

Table 46. Creating the PortConnector

Window or prompt Action

System Manager 1. Expand Integration Component Libraries »
server_ICL_project » Connectors.

2. Double click WebSphereMQConnector.

3. Click File » Save as » To Project. Save as
PortConnector in the server_ICL project.

4. In the Standard Properties tab, specify the values
contained in

5. In the Connector-Specific Properties tab, remove all
lines; no connector-specific properties are necessary.

6. In the Supported Business Objects tab, set the
values contained in[Table 48 on page 47]

7. In the Messaging tab, set the values contained in
[Table 45 on page 45

8. Click File » Save » To Project.

9. Click server_ICL project. Click OK.

10. Close the Connector Configurator window.

Table 47. Connector Configurator — PortConnector, Standard Properties

Property Value Update Method

1 AgentConnections 1 component restart
2 AgentTraceLevel 0 dynamic

3 ApplicationName PortConnector component restart
4 Broker Type ICS connector restart
5 CharacterEncoding ascii7 component restart
6 ConcurrentEventTriggeredFlows 1 component restart
7 ControllerStoreAndForwardMode true dynamic

8 ControllerTraceLevel 0 dynamic

9 DeliveryTransport MQ component restart
10 JvmMaxHeapSize 128m component restart
11 JvmMaxNativeStackSize 128k component restart
12 JvmMinHeapSize 1m component restart
13 ListenerConcurrency 1 component restart
14 Locale en_US component restart
15 LogAtInterchangeEnd False component restart
16 MaxEventCapacity 2147483647 dynamic

17 MessageFileName PortConnector.txt component restart
18 OADAutoRestartAgent false dynamic

19 OADMaxNumRetry 10000 dynamic
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Table 47. Connector Configurator — PortConnector, Standard Properties (continued)

Property Value Update Method

20 OADRetryTimelnterval 10 dynamic

21 PollEndTime HH:MM component restart
22 PollFrequency 10000 dynamic

23 PollStartTime HH:MM component restart
24 RepositoryDirectory <REMOTE> agent restart

25 RestartRetryCount 3 dynamic

26 RestartRetryInterval 1 dynamic

27 WireFormat CwBO agent restart

Table 48. Supported Business Objects for the PortConnector

Business Object Name

Agent Support

Hipaa837Resp

MO_DataHandler_Default

MO_DataHandler_DefaultXMLConfig

Serial837

X12_A1_270

X12_A1_271

X12_A1_276

X12_A1_277

O |0 | I[N |G| |[W|IN|-

X12_A1_278

[y
o

X12_A1_820

—_
=

X12_A1_834

[y
N

X12_A2_278

—_
(O8]

X12_Q1_837

—_
1N

X12_Q2_837

—_
1

X12_Q3_837

—_
(o)}

X12_U1_837

—_
N

X12_U2_837

—_
o]

X12_U3_837

—_
\O

X12_W1_835

YAV AVAVANANAN AN AVANASANANAVNASRA WA WA WAY

Creating the WDI_MQConnector

You create the WDI_MQConnector using the WebSphere MQ connector in the

repository as an example.

To create the WDI_MQConnector, perform the following steps:

Table 49. Creating the WDI_MQConnector at the Windows system

Window or prompt

Action

System Manager

1. Expand Integration Component Libraries -

server_ICL_project » Connectors.

Chapter 8. Installing and configuring the collaborations

47



Table 49. Creating the WDI_MQConnector at the Windows system (continued)

Window or prompt Action

2. Double-click WebSphereMQConnector.

3. Click File » Save as » To Project and type the name
WDI_MQConnector and click Save.

Connector Configurator 4. Set the Standard Property values as shown in

5. Click File » Save - To Project.

Table 50. Connector Configurator — WDI_MQConnector, standard properties

Property Value Update Method
1 AgentConnections 1 component restart
2 AgentTraceLevel 0 dynamic
3 ApplicationName WDI_MQConnector component restart
4 Broker Type (@) connector restart
5 CharacterEncoding ascii7 component restart
6 ConcurrentEventTriggeredFlows 1 component restart
7 ControllerStoreAndForwardMode true dynamic
8 ControllerTraceLevel 0 dynamic
9 DeliveryTransport MQ component restart
10 JvmMaxHeapSize 128m component restart
11 JvmMaxNativeStackSize 128k component restart
12 JvmMinHeapSize 1m component restart
13 ListenerConcurrency 1 component restart
14 Locale en_US component restart
15 LogAtInterchangeEnd False component restart
16 MaxEventCapacity 2147483647 dynamic
17 MessageFileName ics home component restart
/connectors
/messages
/WebSphereMQConnector. txt
18 OADAutoRestartAgent false dynamic
19 OADMaxNumRetry 10000 dynamic
20 OADRetryTimelnterval 10 dynamic
21 PollEndTime HH:MM component restart
22 PollFrequency 10000 dynamic
23 PollStartTime HH:MM component restart
24 RepositoryDirectory <REMOTE> agent restart
25 RestartRetryCount 3 dynamic
26 RestartRetryInterval 1 dynamic
27 WireFormat CwBO agent restart

See [Table 51 on page 49| for the steps to add rows to a Connector Configurator

window.
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Note:

To add a row to a Connector Configurator window, do the following steps:

Table 51. Adding a row to a Connector Configurator window

Window or prompt

Action

Right-click on a number in the left column.

Click ADD.

Type the name of the property you want to add.

Click OK.

Enter the value you want to set.

S|P | RN

You can drag-and-drop to change the order of entries.

Set the connector-specific values as follows:

Window or prompt

Action

Connector Specific Properties

7. Set the property values as shown in|[Table 52

Table 52. Connector Configurator — WDI_MQConnector, connector-specific properties

Property Value
1 ApplicationUserName
2 ApplicationPassword
3 ArchiveQueue queue:/ /hostname_server.queue.manager/ WDICONN.ARCHIVE
4 CCsID
5 Channel CHANNEL1
6 ConfigurationMetaObject WDI_MetaObject
7 DataHandlerClassName com.crossworlds.DataHandlers.text.xml
8 DataHandlerConfigMO MO_DataHandler_Default
9 DataHandlerMimeType text/xml
10 DefaultVerb Create
11 ErrorQueue queue:/ /hostname_server.queue.manager/ WDICONN.ERROR
12 HostName hostname_server
13 InDoubtEvents Reprocess
14 InProgressQueue queue:/ /hostname_server.queue.manager/ WDICONN.IN_PROGRESS
15 InputQueue queue:/ /hostname_server.queue.manager/ DIXMLOUT
16 Port 1414
17 ReplyToQueue queue:/ /hostname_server.queue.manager/ WDICONN.REPLY
18 ReplyToQueuePollFrequency 250

19

UnsubscribedQueue

queue:/ /hostname_server.queue.manager/ WDICONN.UNSUBSCRIBED

20

UseDefaults

true

Window or prompt

Action

Supported Business Objects

8. %ic the property values as shown in|Table 53 on page
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Table 53. Supported business objects for the WDI_MQConnector

Business Object Name Agent Support

MO_DataHandler_Default

MO_DataHandler_DefaultXMLConfig

X12_A1_270

X12_A1_271

X12_A1_276

X12_A1_277

X12_A1_278

X12_A1_820

O |0 [ I[N |Gl || W|N|=—

X12_A1_834

—_
o

X12_A2_278

—_
—_

X12_Q1_837

—_
N

X12_Q2_837

—_
@

X12_Q3_837

—_
>~

X12_U1_837

—_
1

X12_U2_837

—_
o)

X12_U3_837

—_
N

X12_W1_835

—_
(o)

WDI_MetaObject
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—_
O

Hipaa837Resp

Window or prompt Action

Messaging 9. Verify the values you set.

10. Save the connector. Click File » Save to project.

Creating the Legacy_MAQConnector

The back-end legacy is also connected with a WebSphere MQ Connector. However,
two WebSphere MQ connectors with the same name cannot exist at the same time,
so you must create a clone, called here, the Legacy_MQConnector. This section
creates the Legacy_MQConnector, repeating the WDI_MQConnector connector
section.

To create this Legacy_MQConnector, do the following steps:
Table 54. Creating the Legacy._MQConnector

Window or prompt Action

System Manager 1. Expand Integration Component Libraries -
server_ICL_project » Connectors.

2. Double-click WDI_MQConnector.

3. Click File » Save as » To Project and type the name
Legacy_MQConnector and click Save.

Connector Configurator 4. Set the Standard Property values as shown in
[Table 55 on page 51|

5. Click File » Save » To Project.
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On the Standard Properties page, set the property values as follows:

Table 55. Connector Configurator — Legacy._ MQConnector, standard properties

Property Value Update Method
1 AgentConnections 1 component restart
2 AgentTraceLevel 0 dynamic
3 ApplicationName Legacy_MQConnector component restart
4 Broker Type ICS connector restart
5 CharacterEncoding ascii7 component restart
6 ConcurrentEventTriggeredFlows 1 component restart
7 ControllerStoreAndForwardMode true dynamic
8 ControllerTraceLevel 0 dynamic
9 DeliveryTransport MQ component restart
10 JvmMaxHeapSize 128m component restart
11 JvmMaxNativeStackSize 128k component restart
12 JvmMinHeapSize 1m component restart
13 ListenerConcurrency 1 component restart
14 Locale en_US component restart
15 LogAtInterchangeEnd False component restart
16 MaxEventCapacity 2147483647 dynamic
17 MessageFileName ics home component restart
/connectors
/messages
/WebSphereMQConnector. txt
18 OADAutoRestartAgent false dynamic
19 OADMaxNumRetry 10000 dynamic
20 OADRetryTimelnterval 10 dynamic
21 PollEndTime HH:MM component restart
22 PollFrequency 10000 dynamic
23 PollStartTime HH:MM component restart
24 RepositoryDirectory <REMOTE> agent restart
25 RestartRetryCount 3 dynamic
26 RestartRetryInterval 1 dynamic
27 WireFormat CwBO agent restart

On the Connector-Specific Properties page, set the property values as follows:

Table 56. Connector Configurator — Legacy._MQConnector, connector-specific properties

Property Value
1 ApplicationUserName
2 DefaultVerb Create
3 ReplyToQueue queue:/ /hostname_server.queue.manager/ LEGACYCONN.REPLY
4 UnsubscribedQueue queue:/ / hostname_server.queue.manager/ LEGACYCONN.UNSUBSCRIBED
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Table 56. Connector Configurator — Legacy._MQConnector, connector-specific properties (continued)

Property Value
5 InDoubtEvents Reprocess
6 Channel CHANNEL1
7 CCsID
8 InProgressQueue queue:/ /hostname_server.queue.manager/ LEGACYCONN.IN_PROGRESS
9 DataHandlerConfigMO MO_DataHandler_Default
10 ConfigurationMetaObject Legacy_MetaObject
11 ArchiveQueue queue:/ /hostname_server.queue.manager/ LEGACYCONN.ARCHIVE
12 DataHandlerMimeType text/xml
13 ErrorQueue queue:/ /hostname_server.queue.manager/ LEGACYCONN.ERROR
14 InputQueue queue:/ /hostname_server.queue.manager/ LEGACYCONN.IN
15 DataHandlerClassName com.crossworlds.DataHandlers.text.xml
16 HostName hostname_server
17 Port 1414
18 ApplicationPassword
19 UseDefaults true
20 ReplyToQueuePollFrequency 250

Table 57. Supported business objects for the Legacy_MQConnector

Business Object Name Agent Support

MO_DataHandler_Default

MO_DataHandler_DefaultXMLConfig

X12_A1_270

X12_A1_271

X12_A1_276

X12_A1_277

X12_A1_278

X12_A1_820

O[O ([ I | |G| |[W|N|~-

X12_A1_834
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)

X12_A2_278
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[

X12_Q1_837
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N

X12_Q2_837

—_
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X12_Q3_837
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S

X12_U1_837

—_
Q1

X12_U2_837

—_
(o)}

X12_U3_837

—_
N

X12_W1_835

—_
o]

Legacy_MetaObject
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Creating the Collab_MQConnector

Create a third connector, Collab_MQConnector, for use between the bridge
collaborations and the HIPAA collaborations. Instead of creating a collaboration

group, link the collaborations with this middle connector. The output queue of the
Collab_MQConnector is also its input queue.

This section creates the Collab_MQConnector, repeating the WDI_MQConnector

section.

To create this Collab_MQConnector, do the following steps:

Table 58. Creating the Collab_MQConnector

Window or prompt

Action

System Manager

. Expand Integration Component Libraries »

server_ICL_project » Connectors.

Double-click WDI_MQConnector.

3. Click File » Save as » To Project and enter the name
Collab_MQConnector and click Save.

Connector Configurator

4. Set the Standard Property values as shown in

5. Click File » Save » To Project.

On the Standard Properties page, set the property values as follows:

Table 59. Connector Configurator — Collab_MQConnector, standard properties

Property Value Update Method
1 AgentConnections 1 component restart
2 AgentTraceLevel 0 dynamic
3 ApplicationName Collab_MQConnector component restart
4 Broker Type ICS connector restart
5 CharacterEncoding ascii’/ component restart
6 ConcurrentEventTriggeredFlows 1 component restart
7 ControllerStoreAndForwardMode true dynamic
8 ControllerTraceLevel 0 dynamic
9 DeliveryTransport MQ component restart
10 JvmMaxHeapSize 128m component restart
11 JvmMaxNativeStackSize 128k component restart
12 JvmMinHeapSize 1lm component restart
13 ListenerConcurrency 1 component restart
14 Locale en_US component restart
15 LogAtInterchangeEnd False component restart
16 MaxEventCapacity 2147483647 dynamic
17 MessageFileName ics home component restart
/connectors
/messages
/WebSphereMQConnector. txt
18 OADAutoRestartAgent false dynamic
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Table 59. Connector Configurator — Collab_MQConnector, standard properties (continued)

Property Value Update Method

19 OADMaxNumRetry 10000 dynamic

20 OADRetryTimelnterval 10 dynamic

21 PollEndTime HH:MM component restart
22 PollFrequency 10000 dynamic

23 PollStartTime HH:MM component restart
24 RepositoryDirectory <REMOTE> agent restart

25 RestartRetryCount 3 dynamic

26 RestartRetryInterval 1 dynamic

27 WireFormat CwBO agent restart

On the Connector-Specific Properties page, set the property values as follows:

Table 60. Connector Configurator — Collab_MQConnector, connector-specific properties

Property Value
1 ApplicationUserName
2 DefaultVerb Create
3 ReplyToQueue queue:/ /hostname_server.queue.manager/ COLLABCONN.REPLY
4 UnsubscribedQueue queue:/ /hostname_server.queue.manager/ COLLABCONN.UNSUBSCRIBED
5 InDoubtEvents Reprocess
6 Channel CHANNEL1
7 CCSID
8 InProgressQueue queue:/ /hostname_server.queue.manager/ COLLABCONN.IN_PROGRESS
9 DataHandlerConfigMO MO_DataHandler_Default
10 ConfigurationMetaObject Collab_MetaObject
11 ArchiveQueue queue:/ /hostname_server.queue.manager/ COLLABCONN.ARCHIVE
12 DataHandlerMimeType text/xml
13 ErrorQueue queue:/ /hostname_server.queue.manager/ COLLABCONN.ERROR
14 InputQueue queue:/ /hostname_server.queue.manager/ COLLABCONN.OUT
15 DataHandlerClassName com.crossworlds.DataHandlers.text.xml
16 HostName hostname_server
17 Port 1414
18 ApplicationPassword
19 UseDefaults true
20 ReplyToQueuePollFrequency 250

Table 61. Supported business objects for the Collab_MQConnector

Business Object Name Agent Support
1 MO_DataHandler_Default I
2 MO_DataHandler_DefaultXMLConfig I
3 X12_A1_270 I
4 X12_A1_271 -
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Table 61. Supported business objects for the Collab_MQConnector (continued)

Business Object Name

Agent Support

X12_A1_276

X12_A1_277

X12_A1_278

X12_A1_820

O |0 [ [ | O

X12_A1_834

10 X12_A2_278

11 X12_Q1_837

12 X12_Q2_837

13 X12_Q3_837

14 X12_U1_837

15 X12_U2_837

16 X12_U3_837

17 X12_W1_835

18 Collab_MetaObject

19 Hipaa837Resp
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Configuring the JDBC adapter

To enable the X12_Ux_837_Store collaborations that call the JDBC connector using
the NameValueDatahandler, you must edit the MO_Server_DataHandler metaobject

as shown below and add the text_namevalue attribute. This corresponds to the

MIME_TYPE collaboration property in the Serial 837 Store collaborations.

To configure the JDBC adapter for use with WebSphere Business Integration
Collaboration for HIPAA Transaction, complete the following steps:

Table 62. Configuring the JDBC adapter

Window or prompt

Action

System Manager 1. Expand Integration Component Libraries »
server_ICL project » Business Objects.
Business Object Designer 2. Double-click MO_Server_DataHandTer.
3. Right-click the first column and select Insert below.
Name column 4. Enter text_xml.
Name field, Type column 5. In the drop-down box, select
MO_DataHandler_DefaultXMLConfig.
6. Expand text_xml.
Default column 7. Remove the BO prefix value.
8. Collapse the text_xml field.
9. Right-click text_xml and select Insert below.
Name column 10. Enter text_namevalue.
11. In the drop-down list, select
MO_DataHandler_defaultNameValueConfig.
File menu 12. Click Save.
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Table 62. Configuring the JDBC adapter (continued)

Window or prompt Action

Console window 13. The following messages are displayed:

Validating "MO_Server_DataHandler..."
Validating "MO_DataHandler_DefaultXMLConfig..."
Validating

"MO_DataHandler_DefaultNameValueConfig..."
Succeeded saving

"MO_Server_DataHandler" to

project "server_ICL project"

14. Close the Business Object Designer.

Considerations for defining the JDBC connector

Each set of collaborations has its own SERIALS837 table that it writes to in its
respective database.

Be sure to set the DatabaseURL property to indicate the HIPAAMSG (or
HIPAAPRO) database name according to the type of database software used. For
example, if the database HIPAAMSG is local to the WebSphere InterChange Server
and is using DB2, the URL might look as follows:

jdbc:db2:HIPAAMSG

If the database HIPAAPRO is local to the WebSphere InterChange Server and is
using DB2, the URL might look like this:

jdbc:db2:HIPAAPRO

The collaborations that support the 837 and 835 message types rely upon the JDBC
connector to interface with the HIPAAMSG database. If you create both HIPAA837
and HIPAAS835 collaborations and HIPAA837Prov and HIPAA835Prov
collaborations, you must create another copy of the JDBC adapter file structure
along with its files, and give it a unique name (for example, JDBCConnector2).
This duplicate file structure is needed to support both the HIPAAMSG database
used by the HIPAA837 and HIPAAS835 collaborations, and the HIPAAPRO
database used by the HIPAA837Prov and HIPAA835Prov collaborations.

Be sure to set the ApplicationUserName and ApplicationPassword properties to
your appropriate user ID and password.

If the standard property called ControllerStoreAndForwardMode is set to true and
the JDBCConnector agent is not started, the collaboration accessing the
JDBCConnector will wait for the JDBCConnector agent to start. If the property is
set to false and the JDBCConnector agent is not available, the JDBCConnector
request returns a failure to the calling collaboration.

Ensure that you have set your system-specific values for the JDBCConnector in the
Messaging Notebook tab (at the far right of the Connector Configurator window) if
required by your selected DeliveryTransport type.

Set the MessageFileName to correspond to the path where WebSphere InterChange
Server is installed.

Set the PollFrequency value to no to avoid Connector Agent start-up problems.
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If more than one message database is required, a unique JDBC connector instance
is required for each, including a unique copy of the JDBCAgentConfig.cfg file.

The userid used to start the JDBC connector must be the same ID used to create
the HIPAAMSG or HIPAAPRO database and table.

Creating the JDBC_MSG connector

The JDBC_MSG connector is one of two JDBC connectors. ((“Specifying another|
finstance of the JDBC connector” on page 59| tells how to create the
JDBC_PROConnector.)

You create the JDBC_MSG connector using the JDBC connector in the repository as
an example:

Table 63. Creating the JDBC_MSG Connector

Window or prompt Action

System Manager 1. Expand Integration Component Libraries -»
server_ICL_project » Connectors.

2. Double-click JDBCConnector.

3. Click File » Save to project and enter the name
JDBC_MSGConnector and click Save.

Connector Configurator 4. Set the Standard Property values as shown in

5. Click File » Save » To Project.

shows the settings for the Standard Properties tab for the JDBC connector
sample.

Table 64. Connector Configurator — JDBC_MSG Connector, standard properties

Property Value Update Method
1 AgentConnections 1 component restart
2 AgentTraceLevel 0 dynamic
3 ApplicationName JDBC_MSGConnector component restart
4 Broker Type ICS connector restart
5 CharacterEncoding ascii7 component restart
6 ConcurrentEventTriggeredFlows 1 component restart
7 ControllerStoreAndForwardMode true dynamic
8 ControllerTraceLevel 0 dynamic
9 DeliveryTransport MQ component restart
10 JvmMaxHeapSize 128m component restart
11  JvmMinHeapSize 128k component restart
12 JvmMinHeapSize 1m component restart
13 Locale en_US component restart
14  LogAtInterchangeEnd False component restart
15 MaxEventCapacity 2147483647 dynamic
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Table 64. Connector Configurator — JDBC_MSG Connector, standard properties (continued)

Property Value Update Method
16 MessageFileName ics home component restart
/connectors
/messages
/JDBCConnector. txt
17 OADAutoRestartAgent false dynamic
18  OADMaxNumRetry 10000 dynamic
19  OADRetryTimelnterval 10 dynamic
20  PollEndTime HH:MM component restart
21  PollFrequency no dynamic
22 PollStartTime HH:MM component restart
23 RepositoryDirectory <REMOTE> agent restart
24  RestartRetryCount 3 dynamic
25  RestartRetryInterval 1 dynamic
26  WireFormat CwBO agent restart

On the Connector-Specific Properties page, set the property values as follows:

Table 65. Connector Configurator — JDBC_MSG, connector-specific properties

Property Value
1 ApplicationPassword hipaa_admin_password
2 ApplicationUserName hipaa_admin
3 ArchiveProcessed true
4 ArchiveTableName xworlds_archive_events
5 AutoCommit false
6 CheckForEventTableInInit true
7 ChildUpdatePhyDelete false
8 CloseDBConnection false
9 ConnectorID NONE
10 DatabaseURL idbc:db2:HIPAAMSG (See |“Specifying another]
linstance of the JDBC connector” on page 59)
11 DateFormat MM/dd/yyyy HH:mm:ss
12 DriverConnectionProperties
13 DriverSupportForLong true
14 EventKeyDel ;
15 EventOrderBy
16 EventQueryType Fixed
17 EventTableName null
18 JDBCDriverClass COM.ibm.db2 jdbc.app.DB2Driver
19 MaximumDatabaseConnections 12
20 PingQuery
21 PollQuantity 19
22 PreserveUIDSeq true
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Table 65. Connector Configurator — JDBC_MSG, connector-specific properties (continued)

Property Value
23 RDBMS.initsession
24 RDBMSVendor DB2
25 ReplaceAllStr false
26 ReplaceStrList Q,DSQ
27 RetryCountAndInterval 3,20

28 SchemaName
29 SPBeforePollCall

30 StrDelimiter P

31 TimingStats 0

32 UniquelDTableName xworlds_uid
33 UseDefaults false

Supported business objects
Set the JDBC-supported business object values:

Table 66. Supported business object for the JDBC Connector

Business Object Name Agent Support
1 Serial837 1/
2 X12_U1_837 I
3 X12_U2_837 I
4 X12_U3_837 I

Specifying another instance of the JDBC connector

You must define the database URL for each instance of the JDBC connector. You
must also define the database URL for jdbc:db2:HIPAAPRO. After you have saved
the first JDBC connector, define a second connector following the steps in
[“Considerations for defining the JDBC connector” on page 56] Make sure to make
the following changes:

+ In[Table 64 on page 57, change the Application to JDBC_PROConnector.
* In|[Table 65 on page 58 change the DatabaseURL to jdbc:db2:HIPAAPRO.

Compiling the collaboration templates

You must compile each collaboration template before creating the collaboration
objects.

You must have the JDK installed and defined in your path before performing this
step.

To create the collaboration objects, perform the following steps:

Table 67. Compiling the collaboration templates

Window or prompt Action

System Manager 1. Expand Integration Component Libraries »
server_ICL_project.
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Table 67. Compiling the collaboration templates (continued)

Window or prompt Action

2. Right-click Collaboration Templates >+ Compile All.

Setting up collaboration objects

60

Setting up a collaboration involves specifying the items to use; the collaboration

template, the ports, whether to use a store database, and the queues to use. This

section tells how to set up the parts of the collaboration. The following tables are
examples of a matrix of the parts you can use in each collaboration object:

* |Table 75 on page 71
* |Table 76 on page 75
* |Table 77 on page 79
* |Table 78 on page 84

This guide refers to [Table 75 on page 71| for the rest of this section, as a reference.
However, use the table that correlates to your system scenario.

Note: When you create the connection pool, described in [‘Creating a connection|
[pool at the Windows system” on page 62 |the value defined in the Name
field for New connection pool table window is HIPAA_STATE_DATA. The value
you use here must match that value. If you specify a different name here,
you must specify that matching name in [“Creating a connection pool at the]
[Windows system” on page 62.|

Do the following steps to set up a collaboration:

Table 68. Setting up collaboration objects

Window or prompt Action
System Manager 1. Expand server_ICL_project.
2. Right-click Collaboration Objects.
3. Click Create New Collaboration Object.
Create New Collaboration 4. Specify a template name and enter a collaboration
object name from [Table 75 on page 71|
5. Click Next.
Bind Ports window 6. Based on bind each port for the

corresponding collaboration object or connector.

See [“Bind considerations” on page 61| for more
information.

7. Click Next.

Collaboration General 8. System Trace Level

Properties
For debugging or test, you can set the trace level

high. For efficiency in production, set the level to
zero (0).

Collaboration General 9. Collaboration Trace Level

Properties
For debugging or test, you can set the trace level

high. For efficiency in production, set the level to
zero (0).
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Table 68. Setting up collaboration objects (continued)

Window or prompt Action
Collaboration General 10. Fill in any other necessary information.
Properties

11. Click Next.
Properties 12. If necessary, edit the properties page.

Some collaborations require properties to be
configured:

* Verify the DB_CONN_POOL_NAME property is
correct. (See [“Creating a connection pool at the|
[Windows system” on page 62| for the name that is
used.)

« See ['Collaboration properties”| for any necessary
custom properties.

13. Click Finish.

11. Repeat each step until you have created all the
collaboration objects in [Table 75

Bind considerations

Review the following bind considerations:

Binding to a collaboration instead of to a connector
If shows a port binding to a collaboration instead of to a connector, the
collaboration must exist before you can bind to it.

For example, assume you are creating the U1_837_Inst1 collaboration object. You
cannot configure the From port with the collaboration object 837.Store yet.
Similarly, the Store port for the collaboration object 837Prof cannot be configured

yet.

After you have created both, edit the U1_837_Inst1 collaboration object to bind the
From port with the collaboration 837.Store. Edit the 837Prof collaboration object to
bind the Store port to collaboration U1_837.Instl.From.

Binding without using all the ports

If you do not bind all the ports when you bind the collaboration objects, you get
an error when you deploy the collaboration object. Bind the extra ports with the
generic PortConnector to prevent the error. The collaboration tables do not show
the PortConnector. Whenever a port is not shown as bound, bind it to the
PortConnector.

[“Creating the PortConnector” on page 49 tells how to configure the PortConnector.

Collaboration properties

CLAIMID_REQUIRED and PRIVACY_ENABLE are fields that exist in some
HIPAA collaborations. If you create collaborations that use these fields, you must
set these fields to false when creating collaborations objects.

CLAIMID_REQUIRED must be set to true in the collaborations objects associated
with the following HIPAA collaboration templates:

HIPAA837Dental

HIPAA837Inst
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HIPAA837Prof
HIPAA837DentalProv
HIPAA837InstProv
HIPAA837ProfProv

PRIVACY_ENABLE must be set to false in the collaborations objects associated
with the following HIPAA collaboration templates:

HIPAA271

HIPAA277

HIPAA278Resp

HIPAA835

HIPAA270Prov

HIPAA276Prov

HIPAA278ReqProv

HIPA A837DentalProv

HIPA A837InstProv

HIPAA837ProfProv

Creating a connection pool at the Windows system

Do the following steps to create a connection pool:

Table 69. Creating a connection pool at the Windows system

Window or prompt Action
At the Windows system 1. Expand Integration Component Libraries »
System Manager server_ICL_project.

2. Right-click Database Connection Pools » Create New
Database Connection.

Database Driver menu 3. Select DB2 and specify the HIPAADB.
4. Enter the DBConnection Name HIPAADB.

o1

Enter the login hipaa_admin and password
hipaa_admin_password.

Connected Servers Select server_ICL_project.

Click Unlimited.

New connection pool table Right-click, and select New Connection Pool.

For the Name field, enter HIPAA_STATE_DATA.

0| XN

10. For the Minimum connections field, enter 20.
11. Click OK.
12. Click Finish.

Modifying static relationships at the Windows client

If the front-end application or back-end application requires relationships, use
these steps to modify the relationships.

This step is only necessary if relationships are required. If relationships are not
required, you can skip this step. Also, when deploying the project, as described in
[“‘Deploying the project at the Windows client” on page 63) do not deploy the
relationships.
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This step specifies the type of database software used, the database name, user
name and password:

Table 70. Modifying static relationships at the Windows client

Window or prompt Action

System Manager 1. Expand Integration Component Libraries »
server_ICL _project » Relationships »> Static.

2. Double-click to open the Relationship Designer.

3. Right-click on a relationship and select Advanced
Settings.

4. Update the URL to jdbc:db2:ics_database (the
database name must be all uppercase).

5. Set the login ID to hipaa_admin.

6. Enter the password.
7. Click OK.

Do steps 3 through 6 for each relationship, then close the Relationship Designer.

Creating a user project at the Windows client

Do the following steps to create a user project:

Table 71. Creating a user project at the Windows client

Window or prompt Action

System Manager 1. Right-click User Projects » New User Project. Enter a
project name. The name can be characters or
numbers. Spaces are not allowed. This guide assumes
server_user_project as the name.

New Project 2. Click OK.

New User Project window 3. In the window at the bottom, expand the Integration
Component Library, and use the check boxes to add
the following components to your user project:

Business Objects
Collaboration Objects
Connectors

Database Connection Pools
Maps, if applicable
Relationships, if applicable

4. Clear JDBC and WebSphere MQ from Connectors.
5. Click Finish.

Deploying the project at the Windows client

Do the following steps to deploy the project:
Table 72. Deploying the project at the Windows client

Window or prompt Action

System Manager, WebSphere 1. Expand User Project » InterChange Server Projects -»
Business Integration System server_user_ project.

Manager
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Table 72. Deploying the project at the Windows client (continued)

Window or prompt

Action

System Manager,
InterChange Servers window

. Right-click server_user_ project. Select Deploy

User Project.

Deploy window

Select hostname_server from the drop-down list.

. Expand server_user_ project. Select the following

objects to be deployed:
Business Objects
Collaboration Objects
Collaboration Templates
Connectors
Database Connection Pools
Maps (if applicable)
Relationships (if applicable)

. Click Finish.

System Manager, WebSphere
Business Integration System
Manager

. After the project has deployed, shut down the server:

Right-click your server instance and select Shut
down > Gracefully.

Restarting the server

Do the following steps to start the server:

Table 73. Restarting the server

Window or prompt

Action

Windows Desktop

. To start the server, click Start > Programs > IBM

WebSphere InterChange Server > IBM WebSphere
InterChange Server » IBM WebSphere InterChange
Server.

. Look in ics_home/InterChange Server.log for the

message InterChange Server hostname_server is
ready.

Activating the connectors

Verify each JDBC Connector (JDBC_MSGConnector and JDBC_PROConnector) is
enabled for DB2 driver support. Each connector’s start file should include the
relevant class path names in the JDBCDRIVERPATH variable.

64

Note: You must edit this file to ensure the hostname matches the name of your
WebSphere InterChange Server.
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Do the following steps to activate the connectors:

Table 74. Activating the connectors

Window or prompt Action
AIX system or Windows L.« For the AIX server, from the AIX system:
Desktop

1. cd to ics_home/bin
2. Run ./hipaa_ActivateAllConnectors.sh.
* For the Windows server, from a Windows desktop:
1. cd to ics_home/connectors
2. Run hipaa_ActivateAllConnectors.bat.
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Chapter 9. Overview of the collaborations

The Support Pack for HIPAA supports two points of view: the Provider and the
Payer. Use the appropriate point of view setup for your solution. Both the Provider
and the Payer solutions support the same software products, however the setup of
each is different.

The Provider point of view includes a message originating at a legacy front-end
system. The message is processed by the WebSphere Business Integration
component, including the collaborations, and then by WebSphere Data Interchange
and sent to a trading partner. The response message is received by the trading
partner, and processed by WebSphere Data Interchange and then the WebSphere
Business Integration component, including the collaborations.

The Payer point of view includes a message originating at the trading partner. The
message is processed by the WebSphere Data Interchange and then the WebSphere
Business Integration and the collaborations. The legacy back-end system processes
the message and returns the response message to the WebSphere Business
Integration, including the collaborations, and then to the WebSphere Data
Interchange. The message is then returned to the trading partner.

The collaborations used in the Support Pack for HIPAA include the HIPAA
collaborations and bridge collaborations. The bridge collaborations bridge the
WebSphere Business Integration component with WebSphere Data Interchange. The
bridge collaborations split 270, 271, 278Req, 278Resp, 837Dental, 837Institutional,
and 837Professional messages, if the messages contain multiple loops. When
messages are received by the trading partner, the user cannot be guaranteed the
message does not contain multiple loops. The bridge collaborations split the
message so the HIPAA collaborations can process it.

If the legacy front end or the legacy back end give the WebSphere Business
Integration component a 270, 271, 278Req, 278Resp, 837Dental, 837Institutional, or
837Professional message that contains multiple loops, the optional bridge
collaborations must be configured.

In the Provider point of view, the optional bridge collaborations are used when
270, 278Req, 837Dental, 837Institutional, or 837Professional messages with multiple
loops are sent to the WebSphere Business Integration component. If the legacy
front-end system sends the WebSphere Business Integration component messages
that contain single loops, the optional bridge collaborations are not needed.

In the Payer point of view, the optional bridge collaborations are used when 271
and 278Resp messages with multiple loops are sent to the WebSphere Business
Integration component. If the legacy front-end system sends the WebSphere
Business Integration component messages that contain single loops, the optional
bridge collaborations are not needed.

A detailed description of the overall Support Pack for HIPAA solution is as
follows:
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Figure 3. Overview of the HIPAA collaboration environment

1.

10.

11.

The Provider’s legacy front end puts an XML file on a queue, LegacyConn.in.
WebSphere Business Integration processes the message.

WebSphere Business Integration processes the message by using
WebSphereMQ, WebSphereMQ Adapters, DB2, and the HIPAA and bridge
collaborations. The processed messages are placed on the queue DIXMLIN.

WebSphere Data Interchange transforms the message to X12 and validates the
message. The X12 message is sent through the Internet to the trading partner.

The Payer’s WebSphere Data Interchange gets the X12 file from the queue
DIEDIIN.

WebSphere Data Interchange validates the X12 message, transforms it to XML,
and then puts it on the queue DIXMLOUT. WebSphere Business Integration
picks up the XML message.

WebSphere Business Integration processes the XML message by using
WebSphereMQ, WebSphereMQ Adapters, DB2, and the HIPAA and bridge
collaborations. The processed messages are placed on the queue
LegacyConn.out. The Payer’s legacy back end processes the XML messages.

The response messages that the Payer’s legacy back end produces are sent
back through WebSphere Business Integration.

WebSphere Business Integration processes the messages using WebSphereMQ),
WebSphereMQ Adapters, DB2, and the HIPAA and bridge collaborations. The
processed messages are placed on the queue DIXMLIN.

WebSphere Data Interchange transforms the message to X12 and validates the
message. The X12 message is sent through the Internet to the trading partner.
The Provider’s WebSphere Data Interchange gets the X12 file from the queue

DIEDIIN.

WebSphere Data Interchange validates the X12 message, transforms it to XML,
and puts it on the queue DIXMLOUT. WebSphere Business Integration picks
up the XML message.

WebSphere Business Integration processes the XML message by using
WebSphereMQ, WebSphereMQ Adapters, DB2, and the HIPAA and bridge
collaborations. The processed messages are placed on the queue
LegacyConn.out. The Provider’s legacy back end processes the XML messages.
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Figure 4. Provider point of view

1. The legacy front end puts a 270, 278Req, 837Dental, 837Institutional,
837Professional, or 276 XML message on the queue, LegacyConn.in. The
Legacy_MQConnector receives the message.

2. The Legacy_MQConnector processes the message, converts it to a Generic
Business Object using the XMLDataHandler, and then sends this business
object to the corresponding HIPAA collaboration.

If the message contains multiple loops, it will fail in theHIPAA collaborations.
If the message does contain multiple loops, then the Provider needs to use the
bridge collaborations in the solution. See [‘Provider point of view with|
[optional bridge collaborations” on page 72]

a. If the messages are to write to the HIPAADB DB2 database, the following
tables are updated:
CLAIMINPROV
CLAIMRSPPROV
INQUIRYINPROV
PROCINPROV
PROCRSPPROV
SVCINCPROV

b. If configured to do so, the 837ProfProv, 837InstProv, and 837DentProv send
data through the Store port to the collaborations U1_837_InstProl,
U2_837_InstProl, and U3_837_InstProl, respectively.

c. Each of the U1_837_InstProl, U2_837_InstProl, and U3_837_InstProl
collaborations store to the DB2 JDBC_PRO database using a JDBC
Connector, to be used later by the 835Prov collaboration.

3. The HIPAA collaboration processes the business object, and then sends it to
the WDI_MQConnector.

4. The WDI_MQConnector converts the business object to XML and puts it on
the DIXMLIN queue.
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o

10.

11.

12.

13.

14.

WebSphere Data Interchange gets the XML file from DIXMLIN, transforms
the message to X12, and validates the message. The X12 message is sent to the
queue DIEDIOUT, where the trading partner, using the Internet, gets the
message.

After the Payer has sent a reply, the message taken from the trading partner,
and put on the DIEDIIN queue.

WebSphere Data Interchange gets the X12 message, validates it, and
transforms it to XML. The message is put on the DIXMLOUT queue.

WDI_MQConnector gets the message, and converts it to XML to a business
object with the XMLDataHandler.

a. If the message is a 271 or a 278Response, the business object is sent to the
bridge collaborations. Since the Provider does not know if the incoming
message has multiple loops, the 271 or 278Response message may need to
be split by the bridge collaborations. Processing continues at

b. If the message is a 277 or 835, the business object does not need to be split.
The business object is sent to the HIPAA collaborations. Processing
continues at .

The bridge collaborations split the business object, if need be. Each split
message is sent to the Collab_MQConnector.

The COLLAB_MQConnector converts the message to XML and puts it on the
CollabConn.out queue. The XML is immediately picked up off the
CollabConn.out queue and picked up again by the Collab_MQConnector.

The message is converted to a business object by the XMLDataHandler and
sent to the HIPAA Collaborations.

If the message is written to the HIPAADB DB2 database, the following tables
are updated:

CLAIMINPROV

CLAIMRSPPROV

INQUIRYINPROV

PROCINPROV

PROCRSPPROV

SVCINCPROV

The 835Prov uses the Ul_837_InstPro2, U2_837 InstPro2, and U3_837_InstPro2
collaborations. The U1_837_InstPro2, U2_837_InstPro2, and U3_837_InstPro2
collaborations write to the JDBC_PRO DB2 database using a JDBC Connector.

The HIPAA collaborations process the business object and sends it to the
Legacy_MQConnector.

The Legacy_MQConnector converts the business object to XML using the
XMLDataHandler and puts it on the LegacyConn.out queue. The legacy
front-end system may now process the response message.

Port setup for the Provider point of view
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Provider point of view with optional bridge collaborations
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Figure 5. Provider point of view with optional bridge collaborations

1.

The legacy front end (not included with Support Pack for HIPAA) puts 270,
278Req, 837Dental, 837Institutional, 837Professional, or 276 XML messages on
the queue, LegacyConn.in. The Legacy_MQConnector receives the message.

The Legacy_MQConnector processes the message and converts it to a Generic

Business Object using the XMLDataHandler.

a. If the message writes to the HIPAADB DB2 database, the following tables

are updated:
CLAIMINPROV
CLAIMRSPPROV
INQUIRYINPROV
PROCINPROV
PROCRSPPROV
SVCINCPROV

b. If the business object is a 270, 278Request, 837Dental, 837Institutional, or
an 837Professional message, the business object is sent to its corresponding
bridge collaboration. The Provider can use the bridge collaborations to
split the message that gets sent through the HIPAA collaborations.

c. If the business object is a 276 message, it is sent to its corresponding

HIPAA collaboration and processing continues at step

The bridge collaborations split the business object, if need be. Each split

message is sent to the COLLAB_MQConnector.

The COLLAB_MQConnector uses the XMLDataHandler to convert the
message to XML and then puts it on the CollabConn.out queue. The XML is
immediately picked up off the CollabConn.out queue and picked up again by

the Collab_MQConnector.

The message is converted to a business object by the XMLDataHandler and

sent to the HIPAA collaborations.
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10.

11.

12.

13.

14.

15.

16.

a. If the message writes to the HIPAADB DB2 database, the following tables
will be updated:

CLAIMINPROV

CLAIMRSPPROV

INQUIRYINPROV

PROCINPROV

PROCRSPPROV

SVCINCPROV

b. If configured to do so, the 837ProfProv, 837InstProv, and 837DentProv send
data through the Store port to the collaborations U1_837_InstProl,
U2_837_InstProl, and U3_837_InstProl, respectively.

c. Each of the U1_837_InstProl, U2_837_InstProl, and U3_837_InstProl
collaborations store to the DB2 JDBC_PRO database using a JDBC
Connector, to be used later by the 835Prov collaboration.

The HIPAA collaboration processes the business object, and then sends it to
the WDI_MQConnector.

The WDI_MQConnector converts the business object to XML and puts it on
the DIXMLIN queue.

WebSphere Data Interchange gets the XML file from DIXMLIN, transforms the
message to X12, and validates the message. The X12 message is sent to the
queue DIEDIOUT, where the trading partner, via the Internet, gets the
message.

After the Payer has sent a reply, the message taken from the trading partner,
is put on the DIEDIIN queue.

WebSphere Data Interchange gets the X12 message, validates it, and
transforms it to XML. The message is put on the DIXMLOUT queue.

WDI_MQConnector gets the message, and converts it to XML to a business
object with the XMLDataHandler.

a. If the message is written to the HIPAADB DB2 database, the following
tables will be updated: CLAIMINPROV, CLAIMRSPPROV,
INQUIRYINPROV, PROCINPROV, PROCRSPPROV, SVCINCPROV.

b. If the message is a 271 or a 278Response, the business object is sent to the
bridge collaborations. Since the Provider does not know if the incoming
message has multiple loops, the 271 or 278Response message may need to
be split by the bridge collaborations. Processing continues at

c. If the message is a 277 or 835, the business object does not need to be
split. The business object is sent to the HIPAA collaborations. Processing
continues at

The bridge collaborations split the business object, if need be. Each split
message is sent to the COLLAB_MQConnector.

The COLLAB_MQConnector converts the message to XML and puts it on the
CollabConn.out queue. The XML is immediately picked up off the
CollabConn.out queue and picked up again by the Collab_MQConnector.

The message is converted to a business object by the XMLDataHandler and
sent to the HIPAA collaborations.

a. The 835Prov uses the Ul_837_InstPro2, U2_837 InstPro2, and
U3_837_InstPro2 collaborations.

b. The U1_837_InstPro2, U2_837_InstPro2, and U3_837_InstPro2
collaborations write to the JDBC_PRO DB2 database using a JDBC
Connector.
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17. The HIPAA collaborations process the business object and sends it to the
Legacy_MQConnector.

18. The Legacy_MQConnector converts the business object to XML using the
XMLDataHandler and puts it on the LegacyConn.out queue. The legacy front
end system may now process the response message.

Port setup for the Provider point of view with the optional
bridge collaborations
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Payer point of view
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Figure 6. The Support Pack for HIPAA collaborations from the Payer point of view

1. After the Provider has sent a message, it is taken from the trading partner, via
the Internet, and put on the DIEDIIN queue, where WebSphere Data
Interchange picks it up.

2. WebSphere Data Interchange gets the X12 message, validates it and transforms
it to XML. The message is put on the DIXMLOUT queue.

3. WDI_MQConnector gets the XML message, and converts it to a Generic
Business Object (business object) with the XMLDataHandler.

a.

C.

If the message is written to the HIPAADB DB2 database, the following
tables are updated:

CLAIMIN

CLAIMRSP

INQUIRYIN

PROCIN

PROCRSP

SVCINC

If the message is a 270, 278Request, 837Dental, 837Institutional, or
837Professional, the business object is sent to the bridge collaborations.
Since the Payer does not know if the incoming message has multiple
loops, these messages need to be split by the bridge collaborations, before
going through the HIPAA collaborations.

If the message is a 276, 820, or 834, the message does not need to be split.

The message is sent to the HIPAA collaborations and processing continues at

Step

4. If necessary, the bridge collaborations split the business object into individual
messages. Each split message is sent to the COLLAB_MQConnector.

5. The COLLAB_MQConnector converts the message to XML and puts it on the
CollabConn.out queue. The XML is immediately picked up off the
CollabConn.out queue and picked up again by the Collab_MQConnector.
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10.

11.

12.

13.

14.

15.

16.

The message is converted to a business object by the XMLDataHandler and
sent to the HIPAA Collaborations.

If configured to do so, the 837Prof, 837Inst, and 837Dent send data through
the Store port to the collaborations U1_837_Instl, U2_837_Inst1, and
U3_837_Instl, respectively.

Each of the U1_837_Instl, U2_837 Instl, and U3_837_Instl collaborations store
to the DB2 JDBC_MSG database using a JDBC Connector, to be used later by
the 837RespProv and 835Prov collaborations.

The HIPAA collaborations process the business object and sends it to the
Legacy_MQConnector.

The Legacy_MQConnector converts the business object to XML using the
XMLDataHandler and puts it on the LegacyConn.out queue. The legacy back
end system now processes the response message.

As the legacy back end produces response XML messages, if the 271 and
278Response messages do not have multiple loops, they can be sent directly to
the HIPAA collaborations. If they contain multiple loops, the bridge
collaborations must be used, before the HIPAA collaborations can process
these messages. If this is the case, see [“Payer point of view with optional|
[bridee collaborations” on page 81)

The legacy back end puts the response XML messages (271, 278Response, 277,
837Response, or 835) on the LegacyConn.in queue.

If the message is written to the HIPAADB DB2 database, the following tables
are updated:

CLAIMIN

CLAIMRSP

INQUIRYIN

PROCIN

PROCRSP

SVCINC

The 837Resp and 835 use the U1_837_Inst2, U2_837_Inst2, and U3_837_Inst2
collaborations. 12¢c. The U1_837_Inst2, U2_837_Inst2, and U3_837_Inst2
collaborations write to the JDBC_MSG DB2 database using a JDBC Connector.

The Legacy_MQConnector receives the message. The Legacy_MQConnector
processes the XML message, converts it to a business object using the
XMLDataHandler, and sends the business object to its corresponding HIPAA
collaboration.

The HIPAA collaboration processes the business object, and then sends it to
the WDI_MQConnector.

The WDI_MQConnector converts the business object to XML and puts it on
the DIXMLIN queue.

WebSphere Data Interchange gets the XML file from DIXMLIN, transforms the
message to X12, and validates the message. The X12 message is sent to the
queue DIEDIOUT, where the trading partner, via the Internet, gets the
message.

Port setup for the Payer point of view
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Payer point of view with optional bridge collaborations
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Figure 7. Payer point of view with optional bridge collaborations

1. After the Provider has sent a message, it is taken from the trading partner, via
the Internet, and put on the DIEDIIN queue, where WebSphere Data
Interchange picks it up.

2. WebSphere Data Interchange gets the X12 message, it validates it and
transforms it to XML. The message is put on the DIXMLOUT queue.

3. WDI_MQConnector gets the XML message, and converts it to a Generic
Business Object (business object) with the XMLDataHandler.

a. If the message is written to the HIPAADB DB2 database, the following
tables are updated:

CLAIMIN

CLAIMRSP

INQUIRYIN

PROCIN

PROCRSP

SVCINC

b. If the message is a 270, 278Request, 837Dental, 837Institutional, or
837Professional, the business object is sent to the bridge collaborations.
Since the Payer does not know if the incoming message has multiple
loops, these messages need to be split by the bridge collaborations, before
going through the HIPAA collaborations.

c. If the message is a 276, 820, or 834, the message does not need to be split.
The message is sent to the HIPAA collaborations. Processing continues atlz

4. The bridge collaborations split the business object, if need be. Each split
message is sent to the Collab_MQConnector.

5. The Collab_MQConnector converts the message to XML and puts it on the
CollabConn.out queue. The XML is immediately picked up off the
CollabConn.out queue and picked up again by the Collab_MQConnector.
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10.

11.

12.

13.

14.

15.

16.

17.

The message is converted to a business object by the XMLDataHandler and
sent to the HIPAA Collaborations.

a. If configured to do so, the 837Prof, 837Inst, and 837Dent send data
through the Store port to the collaborations U1_837_Inst1, U2_837_Inst1,
and U3_837_Instl, respectively.

b. Each of the U1_837_Instl, U2_837 Instl, and U3_837 Instl collaborations
store to the DB2 JDBC_MSG database using a JDBC Connector, to be used
later by the 837RespProv and 835Prov collaborations.

The HIPAA collaborations process the business object and sends it to the
Legacy_MQConnector.

The Legacy_MQConnector converts the business object to XML using the
XMLDataHandler and puts it on the LegacyConn.out queue. The legacy back
end system may now process the response message.

As the legacy back end produces response XML messages, if the 271 and
278Response messages do not have multiple loops, they can be sent directly to
the HIPAA collaborations. If they contain multiple loops, the bridge
collaborations must be used, before the HIPAA collaborations can process
these messages. If this is not the case, use the scenario in

[view” on page 77

The legacy back end puts the response XML messages (271, 278Response, 277,
837Response, or 835) on the LegacyConn.in queue.

The Legacy_MQConnector receives the message and converts it to a business
object using the XMLDataHandler. It then sends the business object to its
corresponding HIPAA collaboration.

a. If the message is written to the HIPAADB DB2 database, the following
tables are updated:

CLAIMIN

CLAIMRSP

INQUIRYIN

PROCIN

PROCRSP

SVCINC

b. If the message is 271 or 278Response, it is sent to the bridge collaborations.

c. If the message is 277, 837Response, or 835, it is sent to the HIPAA
collaborations. Processing continues at Step

The bridge collaborations split the business object, if need be. Each split
message is sent to the Collab_MQConnector.

The Collab_MQConnector converts the message to XML and puts it on the
CollabConn.out queue. The XML is immediately picked up off the
CollabConn.out queue and picked up again by the Collab_MQConnector.

The message is converted to a business object by the XMLDataHandler and
then sent to the HIPAA Collaborations.

a. The 837Resp and 835 use the U1l_837_Inst2, U2_837_Inst2, and
U3_837_Inst2 collaborations.

b. The U1_837 Inst2, U2_837_Inst2, and U3_837_Inst2 collaborations write to
the JDBC_MSG DB2 database using a JDBC Connector.

The HIPAA collaboration processes the business object, and then sends it to
the WDI_MQConnector.

IBM WebSphere Data Interchange: Support Pack for HIPAA



18. The WDI_MQConnector converts the business object to XML and puts it on
the DIXMLIN queue.

19. WebSphere Data Interchange gets the XML file from DIXMLIN, transforms the
message to X12, and validates the message. The X12 message is then sent to
the queue DIEDIOUT, where the trading partner, via the Internet, gets the
message.

Port setup for the Payer point of view with optional bridge
collaborations
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Chapter 10. Code sets and conversions

This section tells where to obtain the code sets and how to convert them to EIF
format.

Externally-obtained code sets

The WebSphere Data Interchange validation maps use externally-obtained code sets
for SNIP level 5 and 6 validation. See [“Setting SNIP type options for validation|
Imaps” on page 97| for more information. A Tist of the code sets is available at the
following Web site:

[http://www.wpc-edi.con

WebSphere Data Interchange requires the code sets to be in EIF file format. To
assist with this, a utility is included that converts code sets from comma separated
value (CSV) file format into EIF format before importing the code set. See
“Converting CSV-formatted files to EIF-formatted files with the CodeSetHandler]
utility” on page 89| for the syntax of the conversion utility. It is the customer’s
responsibility to obtain the external code sets and to provide them in CSV format.

The external HIPAA code sets are a prerequisite for processing SNIP level 5 and 6
messages and that these must be obtained from a third party source. See
ISNIP type options for validation maps” on page 97| for SNIP settings.

The following code sets are used by Support Pack for HIPAA. You are responsible
for updating these code sets as necessary.

All of these code sets must be provided for error-free processing if you specify
SNIP level 5. If one or more code sets are missing, then multiple error messages
are produced during processing.

Table 79. List of code sets

X12 Code Set  Description Name

Number

4 ABA Routing Number HPA4

5 Countries-ISO3166 HPA5
Currencies and Funds-ISO4217

16 D-U-N-S Number HPA16

22 States and Outlying Areas of the U.S. HPA22

41 Universal Product Code HPA41

43 FIPS-55 (Named Populated Places) HPA43

51 Zip Code HPA51

60 Depository Financial Institution (DFI) HPA60
Identification Number

77 X12 Directories HPA77

91 Canadian Financial Institution Branch and HPA91

Institution Number

94 International Organization for Standardization HPA9%4
(Date and Time)

© Copyright IBM Corp. 2004 87


http://www.wpc-edi.com/

Table 79. List of code sets (continued)

X12 Code Set  Description Name
Number
102 Languages HPA102
121 Health Industry Identification Number HPA121
130 Health Care Financing Administration Common  HPA130

Procedural Coding System

HCPCS - Level I

HCPCS - Level I

HCPCS - Level III
131 International Classification of Diseases Clinical HPA131

Mod (ICD-9-CM) Procedure
132 National Uniform Billing Committee (NUBC) HPA132

Codes

UB92 Revenue Codes

UB92 Bill Type Code

UB92 Facility Type Code

Occurrence Span Codes

Occurrence Codes

Value Codes

Condition Codes
133 Common Procedural Terminology (CPT) codes HPA133
134 National Drug Code HPA134
135 American Dental Association Codes HPA135
139 Claim Adjustment Reason Code HPA139
158 Health Care Financing Administration (HCFA) HPA158
229 Diagnosis Related Group Number (DRG) HPA229
230 Admission Source Code HPA230
231 Admission Type Code HPA231
235 Claim Frequency Type Code HPA235
236 Uniform Billing Claim Form Bill Type HPA236
237 Place of Service from Health Care Financing HPA237

Administration Claim Form
239 Patient Status Code HPA239
240 National Drug Code by Format HPA240
245 National Association of Insurance Commissioners HPA245

(NAIC) Code
307 National Association of Boards of Pharmacy HPA307

Number
359 Treatment Codes HPA359
411 Remittance Remark Codes HPA411
457 NISO Z39.53 Language Code List HPAA457
507 Health Care Claim Status Category Code HPA507
508 Health Care Claim Status Code HPA508
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Table 79. List of code sets (continued)

X12 Code Set  Description Name

Number

513 Home Infusion EDI Coalition (HIEC) HPA513
Product/Service Code List

522 Health Industry Labeler Identification Code HPA522

530 National Council for Prescription Drug Programs HPA530
Reject/Payment Codes

537 Health Care Financing Administration National =~ HPA537
Provider Identifier

540 Health Care Financing Administration National HPA540
Plan ID

663 Logical Observation Identifier Names and Codes HPA663
(LOINC)

DOD1 Military Rank HPADOD1

Health Care Service Region*
DOD2 Paygrade HPADOD2
HCFA Public Use Files

Canadian Province Abbreviations

CLIA Number

IHS/CHS Tribal Residency Codes
HPTC Provider Taxonomy Codes HPAHPTC
HIPPS Health Insurance Prospective Payment System HPAHIPPS

(HIPPS) Code
Skilled Nursing Facility
Home Health

Inpatient Rehab Facilities

Converting CSV-formatted files to EIF-formatted files with the
CodeSetHandler utility

WebSphere Data Interchange requires that the code set files be EIF-formatted files.
Use the CodeSetHandler utility to parse the content of one or more CSV-formatted
code set files and convert them to a single EIF-formatted file. The CodeSetHandler
utility accepts parameters passed on the command line to create an EIF-formatted
file that can be imported into WebSphere Data Interchange. The utility can run on
any platform with an installed Java runtime, and has no special memory or system
requirement. The Java runtime must be installed and the utility program must be
in the current directory.

CSV input file

You can specify multiple input CSV files to be converted to one EIF file.
The CodeSetHandler utility expects the CSV file to begin with a title, such as

"KEY", "NAME", "VALUE" although the text need not be these exact words. Blank
spaces can precede or interspace these values. The second record in the file is the
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most important and it defines the output file. The second and subsequent records
must have the format "tt_yyyymmdd","var1","var2" with or without white spaces in
between, where:

tt Table ID (up to 5 characters in length)
_ Separator

yyyy Yyear

mm  Month

dd Day

varl ~ Code set-dependent value string

var2  Code set-dependent value description

The underscore character (_)need not be present. The utility uses all characters up
to the underscore or a maximum of five characters as the name of the code set
with the prefix "HPA". This limits the code set name to a maximum of eight
characters, five of which are up to the builder’s discretion. After the code set name
is set, the utility validates subsequent records in the file to ensure they belong to
the current code set. If a record does not belong to the code set formed from the
information in the second record in the file, the utility skips the record and
displays an invalid record message. The utility discards the characters representing
the date separator, if one exists. It also discards the remaining date, and any
duplicate occurrence of varl.

The CodeSetHandler utility truncates varl and var2 to a maximum of 35 and 63
characters respectively and inserts escape characters needed by WebSphere Data
Interchange; however these escape characters are not part of the total length of
varl and var2.

Running the utility

To run CodeSetHandler utility, use the following syntax. Note that parameters
starting with a dash (-) can be in any order, but the input and output file names
must be at the end:

java -jar CodeSetHandler.jar [-debug = ON | OFF]
[-trace = ON | OFF]
[-emttext="8ATrecordinformation "]
[-tbldsc="description"]
[outputFileName]
inputFilel [inputFile2 ...]

-debug
When set to ON, the utility displays each input record as read from the
CSV file and written to the EIF file. The utility also shows the information
written for records one through three, which are values not read directly
from the CSV file.

A count of records read and written is displayed to indicate the number of
records in the input file that were not written to the output file. You can
redirect the output to a file.

The default is OFF, if the parameter is not specified. This parameter is
optional.
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-trace Displays the methods called by the program as it runs. This information
can be redirected to a file.

The default is OFF, if the parameter is not specified. This parameter is
optional.

-cmttext
Lets you include additional information to identify the CSV source file in
the output EIF file. The —cmttext parameter creates an 8A1l record when
present. Enclose the text in double quotation marks.

This parameter is optional.

-tbldsc
Further identify the Code Set. Enclose the text in double quotation marks if
it contains one or more blanks. If this parameter is not supplied, the value
of the TBLID in the input file is used.

This parameter is optional.

outputFileName
Specifies the name of the EIF output file. If not provided, the name of the
first CSV file is used with the extension EIF appended. This file is created
in the local directory, or the directory specified on the command line. If
this parameter is not present, the file is created in the same directory as the
source file.

inputFilen
Specifies the name of the input CSV file. If this file is not in the current
directory, the directory path must be part of the file name. To specify more
than one input file, separate file names with a space. If a file name
includes spaces, surround that file name with quotation marks.

At least one inputFile name is required.

Importing code sets into WebSphere Data Interchange

To import code sets into WebSphere Data Interchange, refer to the steps described
in ["Importing the HIPAA code sets and forward translation” on page 11/
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Appendix A. Considerations, limitations, and modifications

This appendix contains considerations pertaining to [WebSphere Data Interchange]

and Jother more general considerations} including troubleshooting tips.

WebSphere Data Interchange considerations

Considerations pertaining to WebSphere Data Interchange are discussed in this

section.

Creating the Any-to-Any translation profile

Use an Any-to-Any translation profile only when a trading partner authentication
product, such as TPI, is used. Otherwise a trading partner profile must be set up
and map usages defined for each trading partner. You might just verify that the

values are set as indicated.

See [“Trading partner considerations” on page 9§ for trading partner considerations.

Do or verify the following steps in the WebSphere Data Interchange Client

window:

Table 80. Creating the Any-to-Any translation profile

Window or prompt

Action

WDI Client

Click the Trading Partner icon.

Click Any profile.

Click the Rules/Usages icon.

Click the Data Transformation Map Rules tab.

Click create new usage.

Click map name.

Associated with: Trading
Partner

N |G @

Set the values:

Sender: ANY
Receiver: ANY

8. Click Property: Active.

Click the Envelopes Attributes tab.

10.

Set the values:

Envelope: X
Profile: hipaa

11.

Click the WDI Options tab.

12.

Select Ack expected.

13.

Set the values:

Funackmap = $DT_Fa997V3R7
Envelope: X
Profile: hipaa

14.

Click Save.

Trading Partner

15.

Double-click Trading Partner Nickname column ANY.

Development-Trading Partner
- Any

16.

Click the WDI Proc Options tab.
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Table 80. Creating the Any-to-Any translation profile (continued)

Window or prompt Action

Special Characters 17. Specify the following values:

drop-down list Segment ID Separator: FF - None
Segment Delimiter: 7E.Y

Data Element Delimiter: 2A.=*

Subelement Delimiter: 3A-:

Release Character: 00 - default
Repetition Separator: 20 (the default)

18. Click Save.

19. Close the window. Click X in the top-right corner.

20. Close the Development-Trading Partner - Any
window.

Using an alternate WebSphere Data Interchange Client user ID

The installation instructions specified hipaa_admin as the user ID for all the
installation steps. This user ID should be used consistently throughout the
installation process.

However, if you attempt to run the WebSphere Data Interchange from a different
ID, the message Configuration Database: Data source name not found and not
default driver specified is displayed.

Click OK to display 12004 - Failed to initialize the application. Click OK to
close the message window. The WebSphere Data Interchange Client does not start.

Do the following steps at the client to recover:

Table 81. Using an alternate WebSphere Data Interchange Client user ID

Window or prompt Action

Windows System client 1. Start » Settings » Control Panel » Administrative

desktop Tools » Data Sources (ODBC).

ODBC Data Source 2. Click the User DSN tab, and click Add.

Administrator

Create New Data Source 3. Click Microsoft Access Driver (*.mdb) and click
Finish.

ODBC Microsoft Access 4. Enter the following information:

Setup Enter Data Source Name: wdiclient32cfg
Description: Config32 MP

and click Select.

Select Database 5. Select wdi_home\wdiclient32cfg.mdb, and click OK
ODBC Microsoft Access 6. Click OK.
Setup

7. Repeat steps 2 through 6, changing wdiclient32cfg to
wdiclient32dev in each instance.

Note: The original user 1D, hipaa_admin, remains valid.
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Specifying a non-default installation drive

You can specify a non-default installation drive for WebSphere Data Interchange.
However, if you do so, you must also make the following changes in your
installation specifications.

In the following directories:

C:\WDIServer32\samples
C:\WDIServer32\runtime\dicmd

change the following lines in the wdi.properties file to point to the correct
directory:

runtimedirectory=C:\WDIServer32\bin
datadirectory=C:\WDIServer32\runtime

In the hipaa_home/config directory, change the following lines in the
wdimgcommands. txt file to point to the correct directory:

USERDATA('C:\WDIServer32\runtime\dicmd') +
ENVRDATA('>> "C:\WDIServer32\runtime\prt\WDIAdapter.trace"")

Validation map considerations and limitations

This section lists considerations and limitations of validation map processing.

Setting SNIP type options for validation maps

You can set SNIP Type 5 or 6 on or off, based on your requirements. The default is
off. Specifying Y turns on validation mapping. If you have set Y, you must have
provided the external code sets. See [Chapter 10, “Code sets and conversions,” on|
for a list of the external code sets.

Do the following to change the SNIP settings:
Table 82. Selecting SNIP Typefor validation maps

Window or prompt Action
Windows System client 1. Start » Programs » IBM WebSphere Data Interchange
desktop MP V3.2 > WDI MP V32 Client.

2. Click the Mapping icon.
3. Click the Global Variables tab, SNIPType5.

4. To set SNIP validation Type 5 on, change the N (the
default) to Y.

To set SNIP validation Type 5 off, change the Y to N.

5. Click the Save icon and close the window.

6. Repeat steps 3 through 5 with SNIPType6 to set SNIP
validation Type 6 on or off.

Validation maps version updates

SNIP Type 6 validations enable customization of the validation maps. Importing
validation maps will override any custom code. If you import any maps, you must
re-code your customizations.

Transformation limitations

This section lists transformation limitations.
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Blank fields within alphanumeric fields

Blank fields, such as leading blanks, trailing blanks, and completely blank records
within alphanumeric fields are eliminated or skipped when transforming from
XML to X12 format or when transforming from X12 to XML. This action conserves
space when transmitting records.

Trading partner considerations

You can modify some of the trading partners settings that were defined during
installation.

Enabling and disabling functional acknowledgment for a map
From the WebSphere Data Interchange client, you can enable or disable a
functional acknowledgment.

Disabling functional acknowledgment for a map: Do the following steps to
disable a functional acknowledgement for a map:

Table 83. Disabling functional acknowledgment for a map

Window or prompt Action
Windows System client 1. Start the WebSphere Data Interchange Client: Click
desktop Start » Programs > IBM WebSphere Data Interchange

MP V3.2 » WDI MP V3.2 Client.

Click the Trading Partner icon.

Click Any profile.

Click the Rules/Usages icon.

IS I

In the Data Transformation Map Rule tab, select the
map name for which the acknowledgment needs to be
disabled.

Double-click the map name.

6. Click the WebSphere Data Interchange Options tab.

7. Under Acknowledgement Options, do the following:
1. Clear the Acknowledgement Expected check box.
2. Remove the values in the field Functional
Acknowledgment Map.

8. Click Save.

Enabling functional acknowledgment for a map: Do the following steps to
enable a functional acknowledgement for a map:

Table 84. Enabling functional acknowledgment for a map

Window or prompt Action
Windows System client 1. Start the WebSphere Data Interchange Client: Click
desktop Start » Programs » IBM WebSphere Data Interchange

MP V3.2 » WDI MP V3.2 Client.

2. Click the Trading Partner icon.
3. Click Any profile.

4. Click the Rules/Usages icon.
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Table 84. Enabling functional acknowledgment for a map (continued)

Window or prompt Action

5. In the Data Transformation Map Rule tab, select the
map name for which the acknowledgment needs to be
enabled.

Double-click the map name.

6. Click the WebSphere Data Interchange Options tab.

7. Under Acknowledgement Options do the following:
1. Check Acknowledgement Expected.

2. Set the value for Functional Acknowledgment
Map:
$DT_Fa997V3R7

8. Click Save.

Queue manager startup

After you enter the command:
runmqtrm -m hostname_server.queue.manager -q WDI.INIT.Q

you might receive the this error message in the WebSphere Data Interchange server
window:

SQL Error Code : -1013
SQL1013N The database alias name or database name "" could not be found.
SQLSTATE=42705

Open the file C:\WDIServer32\runtime\prt\WDIAdapter.trace for more
information. If the error is wdi.properties not found!, do the following steps:

1. Shut down both the WebSphere Data Interchange client and the server.
2. Copy the properties file into the correct directory.

3. Restart the WebSphere Data Interchange server and client. The conversion of
the message from X12 to XML now works correctly.

Error starting the InterChange Server

If the following error message is displayed when you start the InterChange Server:

[Mesg: Failed to access the InterChange Server repository.
Reason An error occurred during the schema creation for the repository.
Reason CxTransBlobs

Make sure your AIX system installation points to the alias name of the database.

Other considerations

This section describes some possible situations and gives suggestions for handling
them. This section is not a replacement for the complete problem diagnosis and
resolution information provided by each of the component products.
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Unique TRN values required for 278Request and 270
messages

The Support Pack for HIPAA requires all incoming 278 Request and 270 messages
to contain a unique TRN value for digitally linking requests with responses
278Response and 271, respectively. For 278 Request messages, the TRN must be
unique in the 2000F loop. For 270 messages, the TRN must be unique in the 2000C
or 2000D loops, depending on which loop is the patient.

Provider systems must ensure they send a unique TRN segment. Payer systems
must guarantee all incoming 278 Request and 270 messages contain a unique TRN
value. This must be a requirement in the Companion Guide.

You can provide for these unique TRN values by customizing the Support Pack for
HIPAA.

837Institutional line item control number

The line item control number (L2000A.L2000B.L.2000C.2300.2400.REF) of 837
Institutional messages is reserved. The HIPAA collaboration DTDs define this
segment, but the implementation guide for 837Institutional does not. The 837
Institutional transformation maps will not transform this segment. The line item
control number for the 837 Dental and 837 Professional are defined in the
implementation guides and can be used.

Log file considerations

Your log files might overflow. You can check the log file size and increase the log
file size.

Table 85. Changing the log file size

Window or prompt Action

Windows System client 1. Start » Programs » IBM DB2 » General

desktop Administrative Tools » Control Center.

DB2 Control Center 2. Expand All Cataloged Systems > hostname_server

Instances » DB2 » Databases - ics_database.

3. Right-click CWREPOS and click Configure Database
Logging

- Or -

select ics_database, click Configure Database Logging
in the Selected menu.

Logging Type 4. Verify that Circular Logging is specified and click
Next.

Logging Size 5. Specify the following values:
Number of primary log files: 3
Number of secondary log files: 2

Size of each log file (4K Pages): 1000

Click Next.
Logging Location 6. Accept the Active Log Path.
Schedule 7. Accept the checked Run now without saving task

history and click Next.

Summary 8. Verify that each log file size is set to 1000.
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Table 85. Changing the log file size (continued)

Window or prompt Action

9. Click Finish.

Server problems, all platforms

Rule problem

Problem
RUOGO1*08 — No active rule record found for the message when a rule
is defined and is marked active.

Solution
Check test message’s ISA-15 segment for a usage indicator (P or T).
Change map usage indicator (Test or Production). Set ISA-15 to T while
testing.

Parsing error

Problem
UPO001+08 — Error parsing XML document-message could not open DTD
file in Event Log.

Solution
WebSphere Data Interchange attempts to locate the DTD file and never
finds it. Check the incoming message’s DOCTYPE for the expected location
of the DTD. WebSphere Data Interchange does not understand http, and
cannot use DTDs located on the Web. Do one of the following:

¢ In Service Profile for incoming XML messages, add to PERFORM
statement XMLVALIDATE(0) — this will disable XML validation against
the DTD.

* In Service Profile for incoming XML messages, add to PERFORM
statement XMLDTDS(path). Where path is the absolute location of the
DTDs.

Server problems, AIX systems

SQL errors

Problem
SQL errors are reported be the WebSphere Data Interchange Server Trigger
monitor and WebSphere Data Interchange trace file.

Solution
Check your AIX configuration. See WebSphere Data Interchange Messages and
Codes.

Event Log error

Problem
Out of space errors in the event log.

Solution
Clear the print files. Use the command:

rm usr/wdi/Div32/runtime/prt/*.prt
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DTDs missing

Problem
The WebSphere InterChange Server on an AIX system might report it is
unable to find the DTDs needed to create the business objects, when
messages are processed by the collaborations.

Solution
Unzip the DTD files in hipaa_home\collabs\HIPAAdtds.zip to the
\home\hipaa_admin directory. Resend the message.

Client problems, Windows systems

Database error

Problem
Error SQL0O204N received when connecting to the database in the client.

Solution
Open the database in the DB2 Control Center and check the schema name.
Make sure that the schema name matches the database qualifier in the
View > Systems » HIPAA definition.
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Appendix B. Notices

This information was developed for products and services offered in the U.S.A.
IBM® might not offer the products, services, or features discussed in this document
in other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter in
this document. The furnishing of this document does not give you any license to
these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the information. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
information at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

© Copyright IBM Corp. 2004 103



Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Department LZKS
11400 Burnet Road
Austin, TX 78758
US.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM’s suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

Disclaimer

CUSTOMERS ARE RESPONSIBLE FOR ENSURING THEIR OWN COMPLIANCE
WITH THE HEALTH INSURANCE PORTABILITY AND ACCOUNTABILITY ACT
(HIPAA) OF 1996. IT IS A CUSTOMER’S SOLE RESPONSIBILITY TO OBTAIN
ADVICE OF COMPETENT LEGAL COUNSEL AS TO THE IDENTIFICATION
AND INTERPRETATION OF ANY RELEVANT LAWS, INCLUDING BUT NOT
LIMITED TO, THE HEALTH INSURANCE PORTABILITY AND
ACCOUNTABILITY ACT (HIPAA) OF 1996, THAT MAY AFFECT CUSTOMER’S
BUSINESS AND ANY ACTIONS CUSTOMER MAY NEED TO TAKE TO COMPLY
WITH SUCH LAWS. IBM DOES NOT PROVIDE LEGAL, ACCOUNTING OR
AUDIT ADVICE OR REPRESENT OR WARRANT THAT ITS SERVICES OR
PRODUCTS WILL ENSURE THAT CUSTOMER IS IN COMPLIANCE WITH ANY
LAW.
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Trademarks

The following terms are trademarks of International Business Machines
Corporation in the United States, or other countries, or both:

AIX

DB2

IBM

Redbooks

RS/6000

Universal database
WebSphere

Microsoft®, Windows®, Windows NT®, and the Windows logo are trademarks or
registered trademarks of Microsoft Corporation in the United States and other
countries.

Java'" and all Java-based trademarks and logos, and Solaris are trademarks or
registered trademarks of Sun Microsystems, Inc. in the United States, other

countries, or both.

Other company, product, and service names may be trademarks or service marks
of others.
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