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Purpose

This guide provides the information you need to build OLAP metaoutlines. It
explainsall Hyperion® Integration Server™ OLAP metaoutline features and
options, and contains the concepts, processes, procedures, formats, tasks, and
examples that you need to use the Hyperion Integration Server Desktop software.

Audience

Thisguideisfor Hyperion Integration Server database administrators who are
responsiblefor installing, implementing, and deploying the system.

To use dl the information in this book, you need the following skills:

Knowledge of where the datafor your business resides; for example, in a
relational database.

Knowledge of how to create and maintain Open Database Connectivity
(ODBC) data sources.

Knowledge of the data requirements for your business so you can apply the
Hyperion® Integration Server product family to your specific application.

A fundamental understanding of Microsoft Windows and basic Microsoft
Windows terminology, such asdialog box, list box, and button. See Microsoft
Windows documentation for more information on these terms.

Experience with the setup and operation of Hyperion® Essbase® OLAP Server.

A basic understanding of multidimensional concepts.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide M ix
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Document Structure

x H

This document contains the following information:

Chapter 1, “About Hyperion Integration Server,” introduces basic OLAP and
multidimensional concepts and describes how to use the desktop to create
metaoutlines.

Chapter 2, “ Creating and Working with Metaoutlines,” describes how to open a
metaoutline, connect to an OLAP Catalog and to arelational data source, and
create, save, delete, and print a metaoutline.

Chapter 3, “Adding Dimensions, Member Levels, and Measuresto a
Metaoutline,” describes how to use the dimensions, member levels, and measures
defined in the OLAP model to create a metaoutline.

Chapter 4, “ Setting L oad Properties,” describes how to set the actions that OLAP
Integration Server performs on dimensions, member levels, and measures as it
builds a Hyperion Essbase outline or loads data into a Hyperion Essbase outline.

Chapter 5, “Working with Filters,” demonstrates how to set filters on member
levels and measures that determine what member levels or data OLAP Integration
Server loads into the Hyperion Essbase database.

Chapter 6, “ Setting Hyperion Essbase Properties,” describes how to set the
properties that dimensions and member levels will have after you build the
Hyperion Essbase outline.

Chapter 7, “Loading Dimensions and Members,” steps you through using a
metaoutline to add dimensions and member levels to a Hyperion Essbase outline.

Chapter 8, “Loading Data,” steps you through loading datainto a Hyperion
Essbase database.

Chapter 9, “ Creating Drill-Through Reports,” describes how to create
Drill-Through reports that users can access using Hyperion Essbase Spreadsheet
Add-in.

Chapter 10, “Troubleshooting,” providestips on dealing with common problems
you may encounter while building a Hyperion Essbase database and |oading data
into it.

Glossary, alist of key Hyperion Integration Server terms and their definitions.

Index, alist of Hyperion Integration Server terms and their page numbers. In the
PDF version of this guide, select an index entry to view that page.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide
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Sample Applications

Note: The capitalization of column and table names in the sample

applications depends on the relational database management system
(RDBMS) that you use.

The person who installs Hyperion Integration Server isresponsible for making the
sampl e databases, the OL AP model, and the metaoutline available to end users. If
any of thefollowing problems occur when you launch Hyperion I ntegration Server
Desktop, contact the Hyperion Integration Server administrator:

You cannot find the sample databases, the OLAP model, or the metaoutline.

You do not have adequate access to the sample databases, the OLAP model,
or the metaoutline.

You do not see any data in the sample databases.

Related Documentation

Hyperion provides the following documentation for this product:

Hyperion Integration Server Desktop OLAP Model User’s Guide, for
information about basic modeling concepts and descriptions of how to design,
create, and maintain one or more OLAP models on top of the relational
database.

Hyperion Integration Server System Administrator’s Guide, for information
about how to use OLAP Integration Server, OLAP Metadata Catalog, and
OLAP Command Interface, and about how to create and manage ODBC
connections.

Hyperion Integration Server Installation Guide, for information about
installing the software, about Hyperion Integration Server directories and
files, and about connecting relational data sourcesto an OLAP Metadata
Catalog.

Hyperion Essbase Database Administrator’s Guide, for information about
basic multidimensional concepts and descriptions of how to design, create,
and maintain a Hyperion Essbase database.

Hyperion Essbase SQL Interface Guide, for information about the data
sources supported through Hyperion Essbase SQL Interface.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide M xi
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e Hyperion Essbase Soreadsheet Add-in User’s Guide for Excel, for
information about how to use Hyperion Essbase Spreadsheet Add-in with
Microsoft Excel.

e Hyperion Essbase Spreadsheet Add-in User’s Guide for 1-2-3, for
information about how to use Hyperion Essbase Spreadsheet Add-in with
L otus 1-2-3 for Windows.

e Theonline Technical Reference in the bocs directory for information about
Hyperion Esshase calculation and report commands and functions.

Online Help

» To access online help:
1. Inadiaog box, click Help.
2. Inthe help dialog box, to display information about an item, click theitem.

» To print an online help topic, display the topic and select File > Print.

Online Guides

The online guides are electronic versions of the printed documentation.

» Todisplay an online guide, select Help > Help Topics.

xii W Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Conventions

Preface

The following table shows the conventions used in this document:

Table i: Conventions Used in This Document

Item Meaning

) o Arrowsindicate the beginning of aprocedure consisting of
sequential steps.

Brackets|] In examples, brackets indicate that the enclosed elements
are optional.

Bold Bold text indicates words or characters that you type

exactly asthey appear on the page. Bold in procedural
steps highlights major interface elements.

CAPITAL LETTERS

Capital letters denote commands and various IDs.
(Example: CLEARBLOCK command)

Example text

Courier font indicates that the material shown isacode or
syntax example.

Ctrl +0

Keystroke combinations shown with the plus symbol (+)
indicate that you should press the first key and hold it
while you press the next key. Do not type the + symbol.

Courier italics

Courier italic text indicates avariable field in command
syntax. Substitute avalue in place of the variable shownin
Courier italics.

Italics Italicsin a product-related term indicates that the term is
also included in the glossary of the book.
Ellipses(...) Ellipsis points indicate that text has been omitted from an

example.

Mouse orientation

This document provides examples and procedures using
aright-handed mouse. If you use a left-handed mouse,
adjust the procedures accordingly.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide

W xii



Preface

Table i: Conventions Used in This Document (Continued)

Item Meaning

Menu options Options in menus are shown in the following format:
Menu name > Menu command > Extended menu command
For example:
Connections > OLAP Metadata Catalog > Connect

n, X The variable n indicates that you must supply ageneric

number; the variable x indicates that you must supply a
generic letter.

Note: The term right-click, used throughout this guide, means to click the
secondary mouse button to open a pop-up menu.

xiv Il
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About Hyperion Integration
Server

Hyperion Integration Server Desktop provides a suite of graphical tools that you
use to create OL AP models and metaoutlines. Y ou use the tables of arelational
datasourceto define alogical model that representstherelational datain an online
anaytical processing (OLAP) context. Y ou then use the OLAP model to create a
metaoutline that serves as a template for a Hyperion Essbase database outline.

This chapter explains basic OL AP concepts, describes a metaoutline, provides a
workflow for using OLAP Metaoutline Assistant or the Hyperion Integration
Server Desktop standard user interface, and provides an overview of Hyperion
Integration Server.

This chapter contains the following topics:

e “About OLAP’ on page 1-2

e “About Multidimensional Databases’ on page 1-3

e “About Hyperion Integration Server” on page 1-5

e “Components of Hyperion Integration Server” on page 1-7

e “Workflow for Using Hyperion Integration Server” on page 1-9

e “About Metaoutlines’ on page 1-10

e “Components of aMetaoutline” on page 1-11

e “Workflow for Creating a Metaoutline” on page 1-12

Note: You must create an OLAP model before you create a metaoutline.

For more information on creating OLAP models, see the Hyperion
Integration Server Desktop OLAP Model User’s Guide.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide m 11



Chapter 1

About OLAP

OLAP isadecision-support computing environment for business managers who
need to analyze consolidated enterprise datain real time. OLAP enables usersto
answer complex “what if” questions and to create sales and marketing scenariosto
test budgeting, sales promotion, and sales planning strategies. Hyperion Essbase
OLAP Server supports amultidimensional, multi-user database that enterprise
users can access with standard retrieval tools, such as spreadsheets.

The Hyperion Essbase OL AP Server supports multiple views of datasetsfor users
who need to analyze the rel ationships between data categories. For example, a
decision-support user might want answers to the following questions:

e How did Product A sell last month? How does this figure compareto salesin
the same month in each of the last five years? How did Product A sell by
branch, region, and territory? How will Product A sell next month, next
guarter, and next year?

e Did Product A sell better in particular regions? Do regional trends exist?

e Did customers return Product A last year? Were returns due to product
defects? Were defective products manufactured in a specific plant?

e Did commissions and pricing affect how salespeople sold Product A? Did
particular salespeople do a better job of selling the product?

Y ou can use Hyperion Integration Server to create Hyperion Essbase databases
and thus answer these types of questions quickly and easily.

Thefirst step in advancing from arelational database to a Hyperion Esshase
database is the creation of alogical data model that represents the relational
database. Y ou use Hyperion Integration Server Desktop to create the data model.
Then you use OLAP Metaoutline to create one or more metaoutlines and use a
metaoutline to build a Hyperion Essbase database and load members and datainto
the database.

1-2 | Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide
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About Multidimensional Databases

A multidimensional database stores consolidated data at the intersections of its
members and dimensions. For example, if acompany sellsatota of 20 units of all
products in the East region in the first quarter, Hyperion Essbase stores 20 at the
intersection of Product, East, Quarterl, and Unit Sales.

Dimensions represent core components of a business plan and often relate to
businessfunctions. Product, Region, and Y ear are examples of typical dimensions.
Dimensions are static in most databases and rarely change over thelife of an
application.

A member is an individual component of adimension. For example, Product A,
Product B, and Product C might be members of the Product dimension. Each
member has a unique name. A dimension can contain an unlimited number of
members. Members in some dimensions change frequently over the life of an
application.

Members can, simultaneously, be parents of members and children of members.
The Hyperion Essbase outline indents members below one another to indicate a
consolidation relationship. For example, salestotals for the Product dimension
might be totalled by product description, broken down by product code, and
further broken down by product ID.

User Interactions with Data

Hyperion Essbase OL AP Server consolidates and calcul ates data to provide
different views of the data. With amultidimensional database, users can do all of
the following:

Consolidate (aggregate or roll up) data

The consolidation process computes the data relationships for all parent-child
combinations within adimension. For example, the consolidation for the Y ear
dimensionisasfollows:

Year = Quarterl + Quarter2 + Quarter3 + Quarter4

A consolidation is typically additive, but it can be any type of calculation.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide m 13
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1-4 1

Create sophisticated “what if” scenarios

For example, assume that you set a sales goal of ten percent growth for the
upcoming year on al product lines that your company manufactures. With
Hyperion Essbase, you can compare the sales forecasts, as estimated by planners,
with the actual dataretrieved from the online transaction processing (OLTP)
database to see whether you are achieving your sales goals. If actual sales are
running lower than projected sales for a given period, salespeople can access the
forecast data, input new product sales scenarios (for example, What if | sell 2000
widgetsto our biggest corporate customer?), update the forecast data, and provide
revised figures to headquarters.

I nput strategic planning assumptions

Assume that your company is planning for 50 percent growth over the next three
years. Y ou have afairly good grasp of how many new products are required to
meet your goal, but how do you know how many new engineers, sal espeople, and
support personnel you can afford to add while still optimizing profits and gross
margin? With Hyperion Essbase, you can input projected sales and projected
expenses for each product and cal culate downward to determine the cost of goods
sold. Thus, you obtain arealistic picture of the bottom line. If the picture does not
look practical, you can create different scenarios with different mixes of products,
people, and expenses until you produce the profit picture that you require.

Spreadsheet operations

Drilling down or drilling up on data retrieves progressively more detailed or
progressively less detailed datarelative to a selected dimension. Drilling down on
a database dimension provides you with greater detail on the dimension, while
drilling up provides you a higher level perspective of the dimension, aview of a
higher consolidation level. For example, you drill down onthe Y ear dimension to
view thevaluesfor each quarter. Thenyou drill down on Quarter1 to seethevalues
for each month of Quarterl. Conversely, you view Quarterl salesfor the Chicago
office and drill up to view salestotals for the entire East region.

Pivoting data alters the user’ s view of retrieved data. When Hyperion Essbase
retrievesadimension, it displays aconfiguration of rows and columns. A user can
pivot (rearrange) the datato obtain a different view.

For more information about spreadsheet operations, such as drill up, drill down,
and pivot, see the Hyperion Essbase Soreadsheet Add-in User’s Guide for Excel
or the Hyperion Essbase Spreadsheet Add-in User’s Guide for 1-2-3.
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Sources for Data

The datain a multidimensional database can originate from avariety of sources,
such as OL TP databases, text files, and spreadsheet files. OL TP databases contain
awealth of operational data, such as the answers to the following questions:

e How many units of Product A are on hand?
e What isthe current customer’s name, address, and billing status?

e What isan employee's saary, job title, and address?

Datain an OL TP database must be up to date and easy to change and must use as
little space as possible. The datais stored in rows and columnsin relational
database tables.

Hyperion Integration Server enables you to access datafor a metaoutline from a
data source that is configured for Open Database Connectivity (ODBC) and that
supports SQL 92 or later.

About Hyperion Integration Server

Hyperion Integration Server transfers data from relational tables to a Hyperion
Essbase database quickly. To enable the transfer, you must determine which
datato transfer and consolidate the selected data into aform that is useful for
decision-support users. Then you must identify the tables, rows, or columns that
contain the required data and determine how the tables, rows, or columns map to
the structure of the multidimensional database.

Asillustrated in Figure 1-1, Hyperion Integration Server provides graphical tools
to help you accomplish the following tasks:

e Usethetables, views, and columnsin arelational databaseto create an OLAP
model. An OLAP model isalogical star schemathat consists of afact table
surrounded by related dimension tables.
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e Usethe OLAP model to create ametaoutline, an outline template that contains
the structure and the rules required to generate a Hyperion Essbase outline.

e Usethe metaoutline to create and populate a Hyperion Essbase database.

Relational Data Source

OLAP Model
| | —
= — OLAP MetaoLtiine
—1 —
B B Market
EE MARKET.REGIOMN
B & Measures
O Profit

O Ratios ‘

Hyperion Essbase Database

Figure 1-1: Workflow for Creating a Hyperion Essbase Database from a
Relational Data Source
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Components of Hyperion Integration Server

Relational
Data Source

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide

Hyperion Integration Server

Hyperion Integration Server Desktop

OLAP Model OLAP Metaoutline
— (I Assistants and = S.gk;;HKET.HEGIDN
— — | Standard User fi g & Measures
Interface o Profit
I — o Ratios

OLAP Integration
Server

TCPRAP

TCPRAP

Hyperion Integration Server, pictured in Figure 1-2, consists of two major
components: Hyperion Integration Server Desktop and OLAP Integration Server.

TCPRAP

I

OLAP Command
Interface

OLAP Metadata
Catalog

Hyperion
Esshase Server

Figure 1-2: Hyperion Integration Server

Hyperion Integration Server Desktop

Hyperion Integration Server Desktop, a graphical user interface, is used for
creating OLAP models and metaoutlines. Hyperion Integration Server Desktop
includes the following components:

Hyperion Esshase
Database

e OLAP Model Assistant: A wizard for building centralized and reusable
OLAP models that are based on arelational data source. The relational data
source consists of the tables and views in asingle relational database and
contains the data that you want to report in Hyperion Essbase.
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-8 |

Use OLAP Model Assistant to create abasic OL AP model. For more complex
model-building functions, such as recursive self-joins, use the standard
Hyperion Integration Server Desktop user interface. Use the OLAP models
that you create from information in the relational data source to build one or
more metaoutlines.

OLAP Metaoutline Assistant: A wizard for creating one or more
metaoutlines from an OLAP model. A metaoutline determines the structure
and content of the final Hyperion Essbase database outline.

Use OLAP Metaoutline Assistant to create a basic metaoutline. For more
complex metaoutline functions, such as scheduling member loads, use the
standard Hyperion Integration Server Desktop user interface. After you create
ametaoutline, you can build a Hyperion Esshase database and |oad data from
the relational data source directly into the Hyperion Essbase database.

Note: Thisuser’'s guide provides detailed procedures for creating and
editing a metaoutline using the standard user interface. To create
ametaoutline using OL AP Metaoutline Assistant, refer to
“Working in OLAP Metaoutline Assistant” on page 2-7 (or click
Overview in the Welcome dialog box), the assistant online help,
and the inline help that appears within each assistant tab.

Hyperion Integration Server Desktop standard user interface: A
graphical user interface for creating OLAP models and metaoutlines. Use the
standard user interface to perform advanced functions, such as performing
recursive self-joinsin an OLAP model or scheduling member loads for a
metaoutline.

To create ametaoutline using the standard user interface, you must connect to
OLAP Metadata Catal og and therelational data source. For moreinformation,
see Chapter 2, “Creating and Working with Metaoutlines”.

OLAP Integration Server

OLAP Integration Server isthe primary component of Hyperion Integration
Server. OLAP Integration Server is software that uses the information stored in
OLAP Metadata Catal og to extract from the relational data source the dimension
and member names needed to build an associated Hyperion Essbase outline. When
the Hyperion Esshase outline is complete, OLAP Integration Server extracts data
fromtherelational data source, performs the operations specified in the associated
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metaoutline, and loads the data into the Hyperion Essbase database. For more
information about OLAP Integration Server, see the Hyperion Integration Server
System Administrator’s Guide.

OLAP Integration Server includes the following subcomponents, asillustrated in
Figure 1-2:

e OLAP Metadata Catalog: An SQL relational database that contains the
following information:

— Metadata describing the nature, source, location, and type of datato
retrieve from the relational data source

— Metadata describing the information required to generate a Hyperion
Essbase outline

— OLAP models and metaoutlines

Y ou can create more than one OLAP Metadata Catalog to store OLAP
models and metaoutlines. However, you cannot move OLAP models and
metaoutlines to a different OLAP Metadata Catal og after you have
created and saved them to a specific catal og.

The OLAP Metadata Catalog is a data source that is configured for Open
Database Connectivity (ODBC). If you do not know how to create an ODBC
data source, see the Hyperion Integration Server Installation Guide or the
ODBC user documentation.

e OLAP Command Interface: A command-line tool used to access OLAP
Integration Server to perform operations on the Hyperion Essbase outline and
the datain the Hyperion Essbase database. For more information, see the
Hyperion Integration Server System Administrator’s Guide.

Workflow for Using Hyperion Integration Server

Figure 1-3 provides an overview of the Hyperion Integration Server components
that you use to prepare relational data for OLAP reporting through Hyperion
Essbase OLAP Server.

» To create a Hyperion Esshase database from arelational data source:

1. Build an OLAP model that is based on the tables of arelational data source.
OLAP Integration Server stores the OLAP model and the information
necessary toretrievetherelevant tablesand viewsin OLAP M etadata Catal og.
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Create ametaoutline from the OLAP model. OLAP Integration Server stores
the metaoutline in OLAP Metadata Catal og.

L oad members and data into an associated Hyperion Essbase database.

Update the Hyperion Essbase outline with new members and data.

About Metaoutlines

OLAP metaoutlines have the following features:

1-10 |

Arereusable. You can use a metaoutline as the basis for more than one
Hyperion Essbase outline.

Are centralized. You can define a metaoutline at a central location and use it
to create multiple Hyperion Essbase outlines in multiple locations.

Allow you to create a Hyperion Essbase outline that is based on criteria that
you specify.

Allow you to create Hyperion Essbase databases on demand. You can create

or update a Hyperion Esshase database whenever you want, either on the spot
or by scheduling periodic updates.

Allow you to view sample Hyperion Essbase outlines before you build them.

Automatically generate the SQL necessary to retrieve data from an external
data source.

Allow youtofilter the datafrom therel ational datasource beforeyou build the
associated Hyperion Essbase outline.

Allow you to transform data as you create a Hyperion Essbase outline. You
can transform member names as you create a Hyperion Essbase outline or
transform data as you load it into a Hyperion Essbase database.
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Components of a Metaoutline

A metaoutline contains al of the following:

e Oneor moremeasures. The Hyperion Essbase database cal cul ates dataval ues,
or measures, for each dimension intersection of the associated metaoutline.
Measures include items such as SALES or COGS (cost of goods sold). Every
metaoutline that you use to build a Hyperion Essbase outline must include at
least one measure. For more information, see “ About Measures’ on page 3-6.

e Two or more dimensions. A dimension in a metaoutline creates a dimension
in theassociated Hyperion Essbase outline. For example, if you haveaProduct
dimension in a metaoutline, the Hyperion Essbase outline that you generate
from that metaoutline also has a Product dimension. You can drag dimensions
from the OLAP model or create your own dimensions. For moreinformation,
see “ About Measures’ on page 3-6.

e One or more member levels. A member level in a metaoutline creates one
or more membersat the samelevel in the associated Hyperion Essbase outline.
For example, if the Product dimension of a metaoutline contains a
PRODUCT_DESC member level, the Product dimension in the Hyperion
Essbase outline contains members, such as Birch Beer and Caffeine Free
Cola, that correspond to the values in the PRODUCT_DESC member in
the relational database.

Y ou can define a set of filters and transformation rules that determine
which members of amember level Hyperion Integration Server adds to
the associated Hyperion Essbhase outline and what transformations, if any,
Hyperion Integration Server performs on the members of a member level
asit builds the associated Hyperion Essbase outline. For more information,
see “ About Member Levels and Members’ on page 3-5.

Y ou can arrange member levelsinto a hierarchy. A hierarchy defines the
organizational structure of agroup of member levels. For example, astandard
time hierarchy in a metaoutline might contain the Year, Quarter, and Month
member levels. This hierarchy creates a Hyperion Essbase outline with
members such as 1999, Quarterl, and January.

Y ou can also create hierarchies for the metaoutline as you create an OLAP model.
See the Hyperion Integration Server Desktop OLAP Model User’s Guide.
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Tahle —

Figure 1-3 shows a sample metaoutline. Y ou can see the dimensions named

Market, Year, Scenario, and Product. The metaoutline also contains a dimension
named Measures that contains SALES and COGS measures. The Year dimension
contains a hierarchy—Quarter and Month.

* . Hyperion Integration Server Desktop - [TBC Metaoutline] M= 3
File Edit “iew Connections Outine Toolz ‘Window Help _|ﬁ||1|
ZH 8w & 2
I"Default J| W= W Wx
Bl TBC Madel ~||=-E TBC Metaoutine a| . )
I Ej Year B- Ej Market || Dimension
I Ej Accounts B- m LOOKUP_MaRKET.REGION ¥
'7 ember Levels
I Ej Market e FE LOOKUP_MARKET.STATE
=8 Ej Product - Year
B- . LOOKUP_PRODUCT = m Time. Quarter Hi
'7— ierarch
B DET BB Time Month Y
B... PRODUCT_DESC Measures
Pl PRODUCT_GROUP_ = Prafit

Pl PRODUCT_ID

=- B Scenaiin
| | >

.. PRODUCT_GROUP__|

%, Product Group 10, Product

-

User-defined Member

=0 Margln

- Total Expenzes -

| »

Faor Help, press F1

| Data Source: TEC

]—I IWeasures

|DLAF' Catalog: tbe_md

Figure 1-3: Sample Metaoutline

Workflow for Creating a Metaoutline

Before you can create a metaoutline, you must have the following in place:

1-12 |

An OLAP mode!.

See the Hyperion Integration Server Desktop OLAP Model User’s Guide.

A running and properly prepared external data source.

A server running OLAP Integration Server.

See the Hyperion Integration Server System Administrator’s Guide.

For more information, see “Working with Metaoutlines’ on page 2-3.

A running Hyperion Essbase server if you plan to load membersor datainto a

Hyperion Essbase.
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After you make the necessary connections, use the following workflow to create a
metaoutline, asillustrated in Figure 1-4:

1. Start Hyperion Integration Server Desktop and use OLAP Metaoutline
Assistant or the Hyperion Integration Server Desktop standard user interface
to create a metaoutline.

See “ Starting Hyperion Integration Server Desktop” on page 2-3 and
“Creating or Editing Metaoutlines” on page 2-4.

2. Add dimensions, member levels, and measures to the metaoutline.

See Chapter 3, “Adding Dimensions, Member Levels, and Measuresto a
Metaoutline.”

3. Setload properties, filters, and Hyperion Essbase properties on the
dimensions, member levels, and measures of the metaoutline.

See Chapter 4, “ Setting Load Properties,” Chapter 5, “Working with Filters,”
and Chapter 6, “ Setting Hyperion Essbase Properties.”

Asneeded, view sample dimensions or outlinesto check them before building
the Hyperion Essbase outline. See “Viewing Sample Dimensions, Members,
and Hyperion Essbase Outlines’ on page 3-30.

As needed, create Drill-Through reports. See Chapter 9, “ Creating
Drill-Through Reports.”

4. Load member levelsinto the Hyperion Essbase outline.
See Chapter 7, “Loading Dimensions and Members.”
5. Load datainto the Hyperion Essbase outline.
See Chapter 8, “Loading Data.”

Asneeded, view the data by using Hyperion Essbase Spreadsheet Add-in. See
the Hyperion Esshase Spreadsheet Add-in User’s Guide for Excel or the
Hyperion Essbase Spreadsheet Add-in User’s Guide for 1-2-3.
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6. Update the Hyperion Essbase database with new members and data.

Crecting ang

wiorking with
metaoutlines

E-E9 TEC_MODEL
B MARKETS
B-Ef SCENARID

\ Z

B 5 Market

) ) ) | MARKET REGION
Adding dimensions, member B 5 Measures

levels, and measures to a O Profit
metaoutline o Ratios

=

Load Properties
Filters

Setting load properties, filters : :
and Hyperion Esshase properties Hyper:jn Essbase Properties

W

Loading dimensions
and member levels

Loading data

Figure 1-4: Metaoutline Workflow

When you finish, you have created the following:

e A metaoutline that determines the structure of the associated Hyperion
Essbase outline

e A Hyperion Essbase database that contains both members and data
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Creating and Working with
Metaoutlines

This chapter describes how to create and work with metaoutlines—from opening
or creating ametaoutline through validating and saving a metaoutline. Before you
read this chapter, read Chapter 1, “ About Hyperion Integration Server” to
familiarize yourself with the definition for and components of a metaoutline.

This chapter contains the following topics:

“Understanding the Metaoutline Workflow” on page 2-2

“Working with Metaoutlines’ on page 2-3

“Working in OLAP Metaoutline Assistant” on page 2-7

“Working in the OLAP Metaoutline Standard User Interface” on page 2-11
“Validating Metaoutlines Manually” on page 2-19

“Saving Metaoutlines’ on page 2-21

“Printing Metaoutlines’ on page 2-28

“Deleting Metaoutlines’ on page 2-28

For information on adding dimensions, member levels, and measuresto a
metaoutline, see Chapter 3, “ Adding Dimensions, Member Levels, and M easures
to aMetaoutline.”
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Understanding the Metaoutline Workflow

Figure 2-1 illustrates the workflow for creating a metaoutline. This workflow
includes creating a metaoutline and using the metaoutline to create and load
members and data into a Hyperion Essbase database. This workflow includes the

22

following procedures:

e Creating and working with a metaoutline
e Adding dimensions, member levels, and measures to a metaoutline

e Setting load properties, filters, and Hyperion Essbase properties on
dimensions, member levels, and measures in a metaoutline

e Loading dimensionsand member levels from a metaoutline into the Hyperion

Essbase outline

e Loading datathat is specified in a metaoutline into a Hyperion Essbase

database

This chapter focuses on creating a metaoutline and on working with an existing

metaoutline.
Creating and

@ working with

vou Are Here @ metaoutline

Adding dimensions, member
levels, and measuresto a

C_MODEL

E"" TBC_
B MARKETS

4

metaoutline
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EE MARKET.REGIOMN
B & Measures
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Frofit
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L

Setting load properties, filters
and Hyperion Esshase properties
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Figure 2-1: Metaoutline Workflow
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Working with Metaoutlines

Before you start working with a metaoutline, make sure that the OLAP Metadata
Catalog where the associated OLAP model is stored, the server on which OLAP
Integration Server isrunning, and the data source are accessible. Theseitems can
be on servers on a network and do not need to be on your local computer to be
available to Hyperion Integration Server Desktop. For more information, see the
Hyperion Integration Server System Administrator’s Guide.

The Hyperion Esshase server must be running if you need to create, change, or
load data into a Hyperion Essbase database.

Towork with ametaoutline, start Hyperion I ntegration Server Desktop and choose
whether to use OLAP Metaoutline Assistant (to be guided through creating or
editing a metaoutline) or to use the OLAP Metaoutline standard user interface (to
create or edit ametaoutline without guidance). For more information, see” Starting
Hyperion Integration Server Desktop” on page 2-3 and “ Creating or Editing
Metaoutlines” on page 2-4.

Starting Hyperion Integration Server Desktop

To start Hyperion Integration Server Desktop, use any of the following methods:
e From the Windows Start menu, select Hyperion Integration Server Desktop.

B

e Double-click the Hyperion Integration Server Desktop icon, &k
e Onthe command line, type the executable name olapbldr.

For example, if Hyperion Integration Server Desktop isinstalled in
the \hyperion\is\bin directory, type the following path:

\hyperion\is\bin\olapbldr

Note: The default client directory, which is specified during
installation, is \hyperion\is. Your application may have a
different installation directory. Consult the person who installed
Hyperion Integration Server at your siteif you are not sure of the
directory specification.

Now you can start working on a metaoutline. See “ Creating or Editing
Metaoutlines’ on page 2-4.
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Creating or Editing Metaoutlines

To create or edit metaoutlines, start Hyperion Integration Server Desktop, connect
to OLAP Integration Server, an OLAP Metadata Catal og, and open ametaoutline.
Y ou are then prompted to connect to a data source.

For more information about connecting to OLAP Integration Server, OLAP
M etadata Catalog or a data source, see the Hyperion Integration Server
Installation Guide. If you have problems connecting, see “Correcting
Connection Problems” on page 2-6.

If you started Hyperion Integration Server Desktop, the Welcome dialog box that
you use to choose whether to create or edit a metaoutline opens automatically.

If you are already running Hyperion Integration Server Desktop and are connected
to OLAP Metadata Catal og, select File> New or File > Open to openthe Welcome
dialog box.

Using OLAP Metaoutline Assistant is the quickest, easiest way to create basic
metaoutlines or to edit metaoutlines. If, however, you want to perform more
complex tasks, you must use the OLAP Metaoutline standard user interface.
For more information, see “ Tasks That Cannot Be Performed Using OLAP
Metaoutline Assistant” on page 2-10.

» To use OLAP Metaoutline Assistant to create a metaoutline:

OLaP
Metaoutling

1. %Iect Azsistant |

2. From the drop-down list, select an existing model on which to base the
metaoutline.

Select the model the metaoutline should be based on.

3. If youwant to placewrite-lock privilegeson the metaoutline, select Exclusive
Access.

Exclusive Access enables you to modify and save the metaoutline. If
Exclusive Accessis not selectable, another user has write-lock privileges and
you have read-only privileges or no privileges.

4. Click Open.
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» To use the OLAP Metaoutline standard user interface to create a metaoutline:

oLap
1 . %I €Ct Metaoutine .

2. From the drop-down list box, select an existing model on which to base the
metaoutline.

Select the model the metaoutline should be based on.

3. If youwant to placewrite-lock privileges on the metaoutline, select Exclusive
Access.

Exclusive Access enables you to modify and save the metaoutline. If
Exclusive Access is not selectable, another user has write-lock privileges
and you have read-only privileges.

4. Click Open.

» To use OLAP Metaoutline Assistant to edit a metaoutline:
1. IntheWelcome dialog box, select the Existing or Recent tab.
2. Select the name of the metaoutline that you want to edit.
For more information about the metaoutline, look in the Details group box.
Select Open with Assistant.

4. If youwant to placewrite-lock privileges on the metaoutline, select Exclusive
Access.

Exclusive Access enables you to modify and save the metaoutline. If
Exclusive Access is not selectable, another user has write-lock privileges
and you have read-only privileges.

5. Click Open.
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» To use the OLAP Metaoutline standard user interface to edit a metaoutline:

In the Welcome dialog box, click the Existing or Recent tab.

Select the name of the metaoutline name that you want to edit.

For more information about the metaoutline, ook in the Details group box.
Make sure that Open with Assistant is not selected.

If you want to place write-lock privileges on the metaoutline, select Exclusive
Access.

Exclusive Access enables you to modify and save the metaoutline. If
Exclusive Access is not selectable, another user has write-lock privileges
and you have read-only privileges.

Click Open.

If necessary, log on to the appropriate data source.

Correcting Connection Problems

If you have problems connecting from Hyperion Integration Server Desktop to
OLAP Integration Server, OLAP Metadata Catal og, the Hyperion Essbase server,
or the data source, use the following checklist to help diagnose any problems:
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Was the server temporarily down or not available? Try to connect again.

Did you enter the correct server name? Depending on the network
configuration, you may need to enter a fully-qualified internet host name;
for example, myserver .mycompany . com.

Did you enter the correct username and password? Passwords are usually
case-sensitive. Make sure that the Caps Lock key is not activated.

Do you have a network connection to the server? Check the network
connection by using the ping command. See Microsoft Windows online help
for more information about using ping.

If the above steps do not resol ve the problem, contact your database administrator
or system administrator. For more information about troubleshooting server
connections, see the Hyperion Integration Server System Administrator’s Guide.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Chapter 2

Working in OLAP Metaoutline Assistant

OLAP Metaoutline Assistant isawizard that steps you through creating or editing
ametaoutline quickly and easily. OLAP Metaoutline Assistant contains multiple
tabs. If you are creating a metaoutline, you complete the tabs and their tasksin
order.

After you complete the required tasksin al tabs, you have avalid metaoutline that
you can use to create one or more Hyperion Essbase outlines.

If you are editing an existing metaoutline, you can work through the tabs in any
order to revise the metaoutline as needed. When you open OLAP Metaoutline
Assistant, it displays thefirst tab, as shown in Figure 2-2.

® .. OLAP Metaoutline Assistant - Modify TBC Metaoutline

Frocess
graphics

Select Dimensions & Members |
Select the dimensions and columns from the OLAP model ta use as dimension and member levels in this OLAP metaoutline. IF

Inline text desired, create a new dimension or member by selecting the location in the OLAP metaoutine and clicking the appropriate buttan.
OLAR Model OLAP Metaoutine M= = =
= TEC Model =S TEC Metaoutine
E“;’” Year 21 | ﬁ‘{‘ Scenario
Tasksto - Accounts +] | g Vear
complete —| E“;’” Market ﬁ‘{‘ M arket
E-Ef Product E-Ef Product
1 . g
BB Scenaro 3] | - Ef Measures
b
TIP: Dragging a hierarchy from OLAP Model to OLAP Metaoutiine Create Dimension | Create Member
automatically creates one in the metaoutline. — —

IScreen 1of9 Help | Save | Cancel

Help button 1

Buttons for sawing or canceling

< Back |

Manigation buttons

Figure 2-2: Select Dimensions & Members Tab in OLAP Metaoutline Assistant
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Process Graphics

The process graphics along the top of OLAP Metaoutline Assistant represent
related tasks. When you create ametaoutline, the tasks must be completed in order
from left to right. After you complete all the tabsthat a process graphic represents,
the next process graphic becomes accessible and you can begin work on tasks
within that task group. When you edit an existing metaoutline, all process graphics
are clearly displayed and all tabs are accessible.

Note: For best visibility of the OLAP Metaoutline Assistant process
buttons, a color palette of 65536 colorsis recommended. To set this
palette, select Start > Settings > Control Panel. Double-click the
Display icon, select 65536 from the Color Palette drop-down list,
click Apply, and then click OK. Your PC may not support a palette of
65536 colors.

Inline Help Text

Each tab contains brief descriptions of the tasks that you need to perform. If you
need additional information on atask, click the Help button.

Tasks to Complete
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Each tab contains tasks that you must complete to define a specific part of a
metaoutline. In the first tab, for example, you must select the dimensions and
columns of the OLAP mode that you want to use as dimensions and member
levelsin the metaoutline. For help on using any tab, click the Help button.

OLAP Metaoutline Assistant contains the following tabs:

Table 2-1: OLAP Metaoutline Assistant Tabs

Tab Name For more information, see...

Select Dimensions and “About Dimensions, Member Levels,

Members and Measures” on page 3-3

Set Dimension Properties “Specifying Dimension and Member Properties’
on page 6-3

Set Member Properties “Specifying Dimension and Member Properties’
on page 6-3
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Table 2-1: OLAP Metaoutline Assistant Tabs (Continued)

Tab Name For more information, see...
Set Account Properties “Specifying Account Properties’ on page 6-17
Name Filters “About Metaoutline Filters’ on page 5-4

Assign Member Filters

“About Metaoutline Filters’ on page 5-4

Assign Measures Filters

“About Measure Filters’ on page 5-7

Review Filters

“Viewing the Contents of a Metaoutline Filter” on
page 5-11

Preview Outline

“Viewing Sample Dimensions, Members, and
Hyperion Essbase Outlines” on page 3-30

Load Dataor Members into

Chapter 7, “Loading Dimensions and Members’

Hyperion Essbase Chapter 8, “Loading Data”
Finish “Saving Metaoutlines’ on page 2-21
Buttons

The following buttons are displayed aong the bottom of OLAP Metaoutline

Assistant:

e Help button. Click to view detailed help for the selected tab. The help
describes each field in the OLAP Metaoutline Assistant tabs and explains
what you must do to complete the tasks in the selected tab before moving to

the next tab.

e Save button. Click to save the metaoutline. You can save a metaoutline in any
tab and then continue to move through the other tabs. Changes that you made
to al previoustabs are saved.

When you save a metaoutline, it is validated automatically. Y ou can save a
metaoutline with validation problems, but you cannot use the metaoutline to
create a Hyperion Essbase outline.

e Cance button. Click to close the metaoutline without saving. Changes that
you saved in previous tabs are not discarded. Changesthat you did not savein
previous tabs are discarded, as are all changes in the current tab.
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Back button. Click to move to the previous tab. You can move back through
previous tabs and make changes at any time.

Next button. Click to move to the next tab. If you are creating a metaoutline
and have not completed all mandatory tasks (such as sel ecting dimensions and
members), you cannot move to the next tab.

Tasks That Cannot Be Performed Using
OLAP Metaoutline Assistant

Y ou cannot use OL AP Metaoutline Assistant to perform the following tasks.
If you need to perform these tasks in a metaoutline, use the OLAP Metaoutline
standard user interface.

2-10 H

Rename dimensions, members, and measures

Manually validate the metaoutline at any time during the creation or editing
process.

Set load properties for dimensions, members, and measures. These tasks
include the following:

— Handling duplicate member names

— Transforming a member name

— Removing spaces around a member level name

— Attaching a prefix or a suffix to amember level name

—  Sorting member levels a phanumerically within a dimension
—  Scaling measures

— Reversing the sign of ameasure

—  Changing the column of a measure

Set Dynamic Time Series

Set query governors

Create Drill-Through reports
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e View relational source table data.

Note: Thisuser’s guide provides detailed procedures for creating and
editing a metaoutline using the standard user interface. To create a
metaoutline using OLAP Metaoutline Assistant, refer to the assistant
overview information (or click Overview in the Welcome dialog
box), the online help, and the inline help that appears within each
assistant tab.

Working in the OLAP Metaoutline
Standard User Interface

To create a metaoutline using the standard user interface, you must connect to
OLAP Metadata Catalog and to the relational data source. For more information
on connecting, see“Working with Metaoutlines’ on page 2-3. After you click the
OLAP Metaoutline icon, the OLAP Metaoutline main window of Hyperion
Integration Server Desktop displays the OLAP Metaoutline main window, as
shown in Figure 2-3. The window displays the OLAP model in the left frame and
a blank metaoutline creation area in the right frame.

* . Hyperion Integration Server Desktop - [Metaoutline] [ |O] x|
henu bar File Edit “iew Connections Outine Toolz ‘Window Help 18] =l
Toolbar DEE & w s &%

Filters toolbar — "Defaut =l = = o
......
=

t——— Metoutline
area

| Drata Source: the
Faor Help, press F1 |DLAF' Catalog: tbe_md i

Status bar

Figure 2-3: OLAP Metaoutline Main Window
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Left Frame

The left frame lists the dimensions defined in the OLAP model. Y ou can use the
OLAP model dimensionsin the metaoutline.

Each OLAP model object or metaoutline object is displayed after a plus symboal,
[*, or aminus symbol, =1

e Theplussymbol, ?, indicates that you can expand the branch. For example,
clicking Market expands the branch to show REGION.

e Theminus symbol, =, indicates that you can collapse the branch. For
example, when Market is expanded, clicking on Market collapses the
dimension to show the dimension name but not the children of the dimension.

For information on selecting multiple dimensions, hierarchies, columns, and
measures in the left frame, see “ Selecting Multiple Objects in the Left Frame” on
page 2-15.

Right Frame

Theright frame is where you build a metaoutline. Drag a dimension, member,
hierarchy, or measure from the left frame into the right frame to create a
dimension, member level, hierarchy, or measure in the metaoutline.

For information on the OL AP model objectsthat you can draginto theright frame,
see “ Creating Dimensions, Member Levels, and Measures’ on page 3-11.

For information on selecting multiple dimensions, hierarchies, columns, and
measures in the right frame, see “ Selecting Multiple Objectsin the Right Frame”
on page 2-16.
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Tools and Toolbars

Y ou use the toolbar to perform commonly used functions. For more information
on individual toolbar buttons, click Help. To hide the toolbar, deselect View >
Toolbar. The check mark next to Toolbar in the menu is removed, and the toolbar
disappears. To redisplay the toolbar, select View > Toolbar.

The toolbar is not attached to the edge of the program window. Y ou can move it
by selecting it and dragging it to a new location. Y ou can also change the shape
and size of the toolbar.

Y ou usethefilterstoolbar to perform actions on metaoutlinefilters. Y ou can move
the toolbar by selecting it and dragging it to a new location. Y ou can also change
the shape and size of the filters toolbar.

Menus

Y ou use the menu bar to perform commonly used commands.

Y ou use the pop-up menu that opens when you right-click an object to perform
operations on the selected object.

Status Bar

The status bar displays the data source and the OL AP Metadata Catal og to which
you are connected and displays other status information. To hide the status bar,
deselect View > Status Bar. The check mark next to Status Bar in the menu is
removed, and the status bar disappears. To redisplay the status bar, select

View > Status Bar.

Viewing the OLAP Metaoutline Main Window

Y ou can customize the view of the OLAP Metaoutline main window to display
Hyperion Essbase propertiesin either columnar or condensed format. Columnar
format displays Hyperion Essbase properties under column headings as shown
in Figure 2-4. Condensed format displays Hyperion Essbase propertiesin
parentheses to the right of the dimension or member as they appear in aHyperion
Essbase outline. Default Hyperion Essbhase settings are not displayed.
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2-14 1

To customize the view of the OLAP Metaoutline main window, select View >
Display Essbase Properties. For more information on the specific menu items
listed on the Display Esshase Properties submenu, see*Viewing Hyperion Essbase
Properties’ on page 6-27.

Y ou can aso view the following filter and transformation iconsin the OLAP
Metaoutline main window by selecting View > Metaoutline | cons:

e Thefiltericon, ? indicatesthat afilter hasbeen set on amember level or on
ameasure.

e Thetransformation icon, H' indicates that amember level or ameasure has
been transformed.

To hide these icons, deselect View > Metaoutline | cons.

File Edit “iew Connections Outine Toolz ‘Window Help ;Iilll
DEE| &= (& 2 %
I"Default j| = W Wx
& | Type/Conzolidation | Aliaz/Member Properties
=+~ TBC Metacutine
Eﬁ'{‘ Year Time [Dynamic Calz)
E ~ =-FH TimeQuater 1 Transformation
B Product FB TimeMonth 1] [+] Addition lcon
- E Scenario ﬁ'{‘ Measures Accounts [Label Only)
= ﬁ'{‘ b4 [Sparze]
[+] Addition [UDAs: REGION_TYPE_
: Filter lcon
ﬁ'{‘ Product [Sparze]
ﬁ'{‘ Scenario [Sparze] [Label Only)
1] | [+
|Data Source: TBC
Faor Help, press F1 |DLAF' Catalog: tbe_md i

Figure 2-4: Viewing Hyperion Essbase Properties in Columnar Format

For further information on the icons displayed in the OLAP Metaoutline main
window, as shown in Figure 2-4, see “ Creating Dimensions Associated with an
OLAP Model” on page 3-12.
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Selecting Multiple Objects in the Left Frame

To select multiple, non-contiguous objects in the left frame of the OLAP
M etaoutline main window, select the name of the first object, press and hold Cirl,
and select the names of the other objects.

To select multiple, contiguous objects, use one of the following methods:
e Select afirst object, press and hold Ctrl, and select additional objects.

e Select afirst object, press Shift, and select afinal object. All objects between
the two selected objects are selected.

Y ou can perform any of the following actions to create dimensions and member
levelsin the right frame of the OLAP Metaoutline main window:

e Select multiple dimensionsin the left frame and drag the dimensionsinto the
right frame to create dimensions without member levels. You can then select
multiple members of one or more dimensions in the left frame and drag the
members into the right frame. Each member is placed under the correct
dimension automatically.

Note: You may need to organize the dimension membersinto a
hierarchy.

e Select multiple membersin theleft frame and drag the membersinto the right
frame to create dimensions and member levels automaticaly.

e Select multiple dimensions and membersin the left frame and drag the
dimensions and members into the right frame to create dimensions and
member levels automatically.
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As shown in Figure 2-5, if you drag the ADDITIONS, COGS, CITY, and
REGION members into the right frame, the Accounts and Market dimensions
are created automatically.

* . Hyperion Integration Server Desktop - [Metaoutline] [ |O] x|
Eile Edit Wiew Connections Dutline Tool: Window Help ;Iilll
DEHE|&| 0w s (= A%
I"Default j| V= W Ux
5@3 Accounts = E|--- Metaoutlinel
2-F1 A - E Accounts

ze ENDING_INVENTORY
2« MARKETING

za MISC

2e OPEMNING_INVENTORS
2. PAYROLL

2« SALES

| Drata Source: the

Faor Help, press F1 |DLAF' Catalog: tbe_md i

Figure 2-5: Selecting and Dragging Multiple Members into the Right Frame

Selecting Multiple Objects in the Right Frame

Y ou can select multiple dimensions, member levels, and measures to perform the
following actions:

e Set or change Hyperion Essbase properties
e Delete objects
e Create Drill-Through reports

To select multiple, non-contiguous objects in the right frame of the OLAP
Metaoutline main window, select the name of the first object, press and hold
Crtl, and click the names of the additional objects.
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To select multiple, contiguous objects, use one of the following methods:
e Select afirst object, press Crtl, and select the additional objects.

e Select afirst object, press Shift, and select afinal object. All objects between
the two selected objects are selected.

When you select multiple dimensions, member levels, measures, and UDAS, the
Edit and pop-up menu options vary, depending on your selection. The commands
available for each type of multiple selection are shown in Table 2-2.

Table 2-2: Multiple Selection and Menu Command Availability

Activates these commands on the
Selecting two or more... Edit or pop-up menu...

Dimensions Delete command
Properties command
Drill-Through command

Member levels Delete command
Properties command
Drill-Through command

Some combination of dimensions, Delete command
member levels, and measures Drill-Through command
M easures within the accounts Delete command
dimension, including the accounts Drill-Through command
dimension

UDASs Delete command

Properties command
Drill-Through command

Note: Selecting the metaoutline name along with a dimension, member
level, or measure activates the Drill-Through command on the Edit
menu. The pop-up menu is not selectable.
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When you select a combination of dimensions, member levels, or UDAS, only
specific tabs and commands are sel ectable on the Dimension Properties and
Member Properties dialog boxes, asindicated in Table 2-3.

If you select two or more objects with different Hyperion Essbase properties, the
default option in the dialog box is not displayed. For example, if you select two
dimensions, one dimension tagged as sparse and one dimension tagged as dense,
the Dimension Storage option on the Dimension Properties dialog box is
selectable. In this situation, you must choose what the new Dimension Storage
option should be for the selected dimensions.

Table 2-3: Multiple Selection and Tab and Command Availability

When you select
two or more...

Tabs that are
available on...

Commands that are not selectable

Dimensions

Dimension Properties
dialog box:

* Member Info tab

+ UDAstab

* Alias command

» Two-pass calculation is not selectableif a
selected dimension istagged as two-pass
calculation and another selected dimension is
not tagged as two-pass calculation

Member levels

Member Properties
dialog box:

* Member Info tab
+ UDAstab

¢ Alias command

» Two-pass calculation is not selectableif a
selected member level istagged as two-pass
calculation and another selected member level
is not tagged as two-pass cal culation

* Dynamic timeis not selectable if two or more
member levels belong to the time dimension
and atime member level istagged as dynamic
time and another time member level is not
tagged as dynamic time

2-18 |
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Table 2-3: Multiple Selection and Tab and Command Availability (Continued)

When you select
two or more...

Tabs that are
available on...

Commands that are not selectable

Measures Member Properties « Alias command
dialog box:
* Member Info tab
» Account Info tab
« UDAstab
UDAs Member Properties e Alias command
dialog box: « Two-pass calculation is not selectable when a
* Member Info tab selected member level is tagged as two-pass
« UDASstab calculation and another selected member level

is not tagged as two-pass cal culation

Note:

Changing specific properties for dimensions or for member levels
does not change the properties of other options. For example,

sel ecting multiple dimensions and tagging them with two-pass
calculation does not change the storage properties of the two-pass

dimensions.

Validating Metaoutlines Manually

When you save ametaoutline, OLAP Integration Server automatically validates it
and writesit to OLAP Metadata Catal og. If you prefer, you can manually validate
ametaoutline before saving it. Y ou can save a metaoutline that does not pass
validation, but you cannot use it to load member levels or datainto a Hyperion
Esshase database.

To validate a metaoutline manually, select File > Validate. If the metaoutline is
valid, adialog box informs you that the metaoutline contains no errors.
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If the metaoutlineisinvalid, Hyperion Integration Server displays adialog box,
similar to the onein Figure 2-6, that details the errorsin the metaoutline:

OLAP Metaoutline Yalidation Errors E

Errors and ‘Warnings:
ERROR: Mo measures are defined.

Figure 2-6: Invalid OLAP Metaoutline Validation Error Message Listing

If the metaoutline isinvalid, check to make sure that the following conditions are
met:

e The metaoutline contains at |east one dimension.

e The metaoutline contains at |east one measure. See “ About Measures’ on
page 3-6.

e The metaoutline contains only one dimension or no dimension tagged as
measure. See “Creating a Measure Dimension” on page 3-24.

e The metaoutline does not contain more measures than are allowed.

— If you do not have a dimension tagged as measure in the metaoutline, the
metaoutline can contain only one measure.

— If you have a dimension tagged as measure in the metaoutline, the
metaoutline can contain ameasure for each level O (leaf level) member of
the measure dimension.

For more information on measures, see “ About Measures’ on page 3-6.
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e Each dimension or user-defined dimension contains one or more member
levels.

e FEach user-defined dimension has a default load member. For more
information, see“ Defining the Load Member for a User-Defined Dimension”
on page 3-21.

To save amodel that does not pass validation, see “ Saving a Metaoutline
Manually” on page 2-23.

Saving Metaoutlines

When you save ametaoutline, Hyperion Integration Server automatically validates
it and writesit to OLAP Metadata Catalog. Y ou must store the metaoutline in the
OLAP Metadata Catal og that stores the OLAP model on which the metaoutlineis
based.

Y ou can save a metaoutline even if it does not pass validation, but you cannot use
an invalid metaoutline to load member levels or datainto a Hyperion Essbase
database.

Y ou can save a metaoutline even if multiple users are reading it by selecting
Exclusive Access on the Welcome screen. Opening an existing metaoutline with
Exclusive Access guarantees that no other user can modify the metaoutline.
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Figure 2-7: Selecting the Exclusive Access Option

When opening an existing metaoutline, select Exclusive Access to place
write-lock privileges on the metaoutline. This option allows you to do both
of thefollowing:

e Save an existing metaoutline.

e Modify and save an existing metaoutline. If you open aread-only metaoutline
and no other user has Exclusive Access, you can save the metaoutline to the
same name.

If Exclusive Accessis not selectable, another user has write-lock privileges, and
you have read-only privileges.
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If you want to modify and save a metaoutline but have read-only privileges,

use File > Save Asto save the metaoutline to a different name. See “ Saving a
Metaoutlineto aDifferent Name” on page 2-27. Also seethe Hyperion Integration
Server System Administrator’s Guide for information on unlocking metaoutlines.

This topic describes how to save a metaoutline. Thistopic contains the following
subtopics:

e “Saving aMetaoutline Manually” on page 2-23
e “Saving While Closing” on page 2-26
e “Saving aMetaoutline to a Different Name”’ on page 2-27

Note: You cannot save ametaoutlineif other users are reading it. Save it
later or use File> Save Asto save the metaoutline to adifferent name.
See “ Saving a Metaoutline to a Different Name™ on page 2-27.

Saving a Metaoutline Manually

If the metaoutline that you want to save has been previously saved and you do not
want to give the metaoutline a different name, select File > Save.

OLAP Integration Server writes the changes to the OL AP Metadata Catalog to
which you are connected.

If you have not previously saved the metaoutline or if you want to save the
metaoutline to a different name, you must use the Save New M etaoutline dialog
box.
» To use the Save New M etaoutline dialog box to save an outline manually:
1. Do one of thefollowing:
e If you are saving a metaoutline for the first time, select File > Save.

e If you are saving a previously saved metaoutline to a new name, select
File> Save As.
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The Save New M etaoutline dialog box, as shown in Figure 2-8, is displayed.

Save New Metaoutline E
Metaoutline name:
Cancel |

Existing metaoutlines:
TBC Metaoutline &I
Security:
Allows readdwrite access for other users. j
Drescription:

El

[~

Figure 2-8: Saving a Metaoutline

2. IntheMetaoutline name text box, enter the name of the metaoutline.

See “About Naming” on page 3-9.
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3. To determine who can access the metaoutline, from the Security drop-down
list box, select one of the following options:

Table 2-4: Read/Write Settings

Select...

To give other users permission to...

Allow read/write access
for other users

Both read and write to the metaoutline. This
setting is the defaullt.

Allow read access for
other users

Read the metaoutline but not write to the
metaoutline; that is, another user cannot save
changes to the metaoutline.

Disalow all access for
other users

Neither read nor write to the metaoutline. Only
you can read or write to the metaoutline.

Note: To change the permissions on a metaoutline after you create it,
you must use the tools provided with the relational database that
contains the OLAP Metadata Catalog or use File > Save Asto
save the metaoutline to a different name. See the Hyperion
Integration Server System Administrator’s Guide.

4. If you want to describe the metaoutline, in the Description text box, enter a

brief description.

The description can include up to 255 characters. Hyperion Integration Server
displays the description in the following places:

e The Save New M etaoutline dialog box, when you select File > Save As
(see “ Saving a Metaoutline to a Different Name” on page 2-27)

e TheOLAP Metaoutline Propertiesdialog box (Y ou can view or change
the metaoutline description in this dialog box at any time.)

e TheExisting tab of the Welcome dialog box (see “Working with
Metaoutlines’” on page 2-3)

e The Recent tab of the Welcome dialog box (see “Working with
Metaoutlines’ on page 2-3)
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5. Click OK.

If the metaoutlineisinvalid, Hyperion Integration Server displays an error
message. Y ou can save the metaoutline without correcting the error, but you
cannot use an invalid metaoutline to load member levels or datainto a
Hyperion Essbase database.

Note: If you attempt to save a metaoutline that another user currently has
open, a dialog box informs you that the metaoutline is currently
locked or open. You must wait to save until al other users close the
metaoutline.

Changing Read/Write Access

At any time after you save ametaoutline, you can change the accessrights that you
originally assigned by using File > Save As.

» To change read/write access to a metaoutline:

1. Select File> Save As.
The Save New Metaoutline dialog box is displayed.

2. Inthe Security drop-down list box, change the user access defined for the
model.

3. Click OK.

Saving While Closing

2-26 1

If you try to close ametaoutline without saving it, adial og box promptsyou to save
your changes.

Click Yesto save the metaoutline with changes or No to close the metaoutline
without saving changes. See “ Saving a Metaoutline Manually” on page 2-23.

CAUTION: If the metaoutline you are closing is a new metaoutline
that has never been saved, you will lose it if you click No.
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Saving a Metaoutline to a Different Name

Save ametaoutline to a different name if you want to accomplish any of the
following:

e Change the name of a metaoutline. (The original metaoutline retains the
origina name.)

e Change the access permissions of the metaoutline.

e Makeacopy of the metaoutline. You cannot copy a metaoutline by using the
Copy function that the operating system provides because the metaoutline
residesin an OLAP Metadata Catalog. Instead, you need to save the
metaoutline to a different name.

To save a metaoutline to a different name, select File > Save As. Hyperion
Integration Server displays the Save New M etaoutline dialog box. For more
information, see “ Saving a Metaoutline Manually” on page 2-23.

For information about naming metaoutlines, see “ About Naming” on page 3-9.
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Printing Metaoutlines

Y ou can print the metaoutline contained in the right frame of the OLAP

M etaoutline main window to use as a hard-copy reference or to retain on file.
The OLAP model information in theleft frame of the window does not print when
you print the metaputline. To print the OLAP model, see the Hyperion Integration
Server Desktop OLAP Model User’s Guide.

» To print ametaoutline:

1. Select File> Print or click the Print toolbar button, @ to open the standard
print dialog box.

2. Select the settings that you want.
3. Click OK.

Deleting Metaoutlines

When you delete a metaoutline, Hyperion Integration Server removes the
metaoutline from OLAP Metadata Catal og.

» To delete one or more metaoutlines:

1. Make surethat you are connected to the OLAP Metadata Catalog where the
metaoutline is stored.

If you are connected, the lower-right corner of the OL AP Metaoutline main
window containsthe appropriate OL AP M etadata Catal og name (for example,
TBC_MD inthe sample TBC database).

If you are not connected, select Connections > OLAP Metadata Catalog >
Connect and log on to the correct OLAP Metadata Catalog.
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2. Select File> Delete to display the Delete an OL AP M odel/M etaoutline

dialog box, shown in Figure 2-9.

Delete an OLAP Model/Metaoutline E

E---\G,Eﬁ TBC Mel . Close I
- 2L Meltaouthine Qe|8te
Help |

Drescription:

Sample TBC Metaoutine for Huperion Integration ;I
Server Release 1.9
e

Figure 2-9: Deleting a Metaoutline

Select the metaoutline to delete, and click Delete.

Note: To select multiple metaoutlinesto del ete, select one metaoutline,
hold the Ctrl key, and select each additional metaoutline.

Hyperion Integration Server displaysadial og box that promptsyou to confirm
that you want to del ete the metaoutline.

Note: If you delete a metaoutline that you used to build a Hyperion
Essbhase outline, you can no longer drill through on the Hyperion
Essbase outline. See Chapter 9, “ Creating Drill-Through
Reports.”

Click Yes.

CAUTION: Use caution when deleting. You cannot undo the
deletion of a metaoutline.
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OLAP Integration Server deletes the selected metaoutline from OLAP
Metadata Catal og.

Note: If you attempt to delete a metaoutline that you or another user
currently has open, adial og box informsyou that the metaoutline
is currently locked or open. If you have it open, close the
metaoutline and sel ect Connections > OL AP Metadata Catalog >
Delete Locks. If other users have the metaoutline open, you must
wait until they close it.
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Adding Dimensions, Member
Levels, and Measures to a
Metaoutline

This chapter begins by defining what the terms dimension, member level, and
measure mean in the context of a metaoutline and by explaining how dimensions,
member levels, and measures map to aHyperion Essbase outline. Next, the chapter
steps you through the process of creating, renaming, and del eting dimensions,
member levels, and measures. Finally, the chapter discusses how you can preview
the structures of dimensions, member levels, and measures before you create the
Hyperion Essbase outline.

This chapter contains the following topics:

“Understanding the Metaoutline Workflow” on page 3-2

“About Dimensions, Member Levels, and Measures’ on page 3-3
“Creating Dimensions, Member Levels, and Measures’ on page 3-11
“Renaming Dimensions, Member Levels, and Measures’ on page 3-25
“Deleting Dimensions, Member Levels, and Measures’ on page 3-29

“Viewing Sample Dimensions, Members, and Hyperion Essbase Outlines’ on
page 3-30

“Viewing Defined Measures’ on page 3-32

Note: For information on setting propertiesfor dimensions, member levels,

and measures, see Chapter 4, “ Setting Load Properties,” Chapter 5,
“Working with Filters,” and Chapter 6, “ Setting Hyperion Essbase
Properties.”
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Understanding the Metaoutline Workflow

Figure 3-1 illustrates the workflow for creating a metaoutline and using the
metaoutline to create and load members and data into a Hyperion Essbase
database. This workflow includes the following procedures:

e Creating and working with a metaoutline

e Adding dimensions, member levels, and measures to a metaoutline

e Setting load properties, filters, and Hyperion Essbase properties on
dimensions, member levels, and measures in a metaoutline

e Loading dimensions and member levels from a metaoutline into a Hyperion
Essbase outline

e Loading datathat is specified in a metaoutline into a Hyperion Essbase
database

This chapter focuses on adding dimensions, member levels, and measuresto a
metaoutline.

Creating and

wiorking with
I\

metaoutines |[E-E Tec_MODEL

-5 MARKETS
B-Ef SCENARID

-]

. . . Bl & Market
@ Adding dimensions, EE] MARKET REGION
B & Measures
member levels, et
You Are Here @and measures o Ratios

to a metaoutline

Load Properties
Filters
Hyperion Essbase Properties

C

Loading dimensions

and members 33 ab

Loading data

—

Setting load properties, filters
and Hyperion Esshase properties

Figure 3-1: Metaoutline Workflow
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About Dimensions, Member Levels,
and Measures

This topic describes how dimensions, member levels, and measures of a
metaoutline map to dimensions, members, and data values of arelated Hyperion
Essbase outline. The topic contains the following subtopics:

“About Dimensions’ on page 3-3

“About Member Levels and Members’ on page 3-5

“About Measures’ on page 3-6

“About User-Defined Dimensions and Members’ on page 3-7
“About Naming” on page 3-9

About Dimensions

In ametaoutline, the categories that represent the highest level of organization are
called dimensions. A metaoutline dimension can have one or more member levels.
Each dimension in a metaoutline corresponds exactly to adimension in arelated
Hyperion Essbase outline. For example, if ametaoutline has aProduct dimension,
the Hyperion Essbase outline has a Product dimension. Every dimension that you
create in ametaoutline becomes a dimension in the related Hyperion Esshase
outline.
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TBC Metaoutline, a sample metaoutline provided with Hyperion Integration
Server, containsthe following dimensions: Y ear, Measures, Product, Market, and
Scenario.

* . Hyperion Integration Server Desktop - [TBC Metaoutline] M= 3

Eile Edit Wiew Connections Dutline Tool: Window Help _|ﬁ||1|
DEHE& w: &7 2

I"Default j| = W Wx

= TBC Model =-E

==
B Measures

-Ef Scenario -Ef Scenario
/| | ¥
| Data Source: TEC
Faor Help, press F1 |DLAF' Catalog: tbe_md i

Figure 3-2: Dimensions in TBC Metaoutline
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About Member Levels and Members

A member level in ametaoutline is based upon a column of the related OLAP
model and is representative of the levels that are contained within a hierarchy of
the related Hyperion Essbase outline. A member is arelational value within an
OLAP model column, avalue within a metaoutline member level, and avalue
within a Hyperion Essbase Dimension. For example, in reference to the Market
dimension, theREGION, STATE, and CITY columnsof the OLAP model become
the REGION, STATE, and CITY member levels of the metaoutline. The members
of the member levels REGION, STATE, and CITY then become members of the
Hyperion Essbase outline (Central, East, South, West, Colorado, Illinois, and so
on).

For example, in the following hierarchy created in an OLAP model, the
Market dimension contains columns that become the metaoutline member
levels MARKET.REGION, MARKET.STATE, and MARKET.CITY.

Edit Hierarchy E
I ame:
IHegion, State, City

E---;Ej Market %% Region, State, City

Filter....
E-E LOOKUP_MARKET E--En_n LOOKUP MARKET REGION —I
- Enee LOOKUP_MARKET.STATE T —
“Plee LOOKUP_MARKET.CITY —I-
Wiew Table Data,. |
Wiew Sample... |

Cancel |
LI ] Help |

Figure 3-3: Example Hierarchy in an OLAP Model
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In the following sample Hyperion Essbase outline, the Central, East, South, and
West members of the Market dimension are based on values from the REGION
column of the OLAP model and thus on values from the relational data source:

@Market
A central
—|_|Colorado
linois
lowea
Missouri
Ohio
YWisconsin

@
o

Connecticut
Florida
Massachusetts
MNew_Hampshire
Mew_Work

Louisiana
Mew_Mexico
Oklahoma
Texas

5

California
MNevada
Cregon
Utah
YWashington

|
[T T2 T T T T T TR TTT]

Figure 3-4: Example Hyperion Essbase Outline

Note: A measure dimension contains actual members, even though it may
contain levels of the various members.

About Measures

The Hyperion Essbase database contains data values (measures) for each
dimension intersection. Measures include items such as SALES and COGS (cost
of goods sold). If you do not define at least one measure in a metaoutline, OLAP
Integration Server cannot vaidate the metaoutline or use the metaoutline to build
a Hyperion Essbase outline.

The Measures dimension in TBC Metaoutline contains the measures SALES and
COGS.
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About User-Defined Dimensions and Members

Y ou can create user-defined dimensions and members in a metaoutline.
User-defined dimensions and members correspond exactly to dimensions and
membersin arelated Hyperion Essbase outline. For example, if you have a
user-defined ACTUAL member in ametaoutline, you have an Actual member
in the Hyperion Esshase outline.

User-defined dimensions and members, however, are not associated with an
OLAP model. Create a user-defined dimension or member when you want to
add adimension or member that is not provided in the relevant OLAP model.

For example, a Hyperion Essbase database enables you to create a Scenario
dimension. The Scenario dimension contains both actual data, to track measures
such as revenue, and forecast data, to project values for revenue and profit. The
relational data source contains the actual data. A worksheet created by the
budgeting department contains the forecast data.

So how do you combine the actual and forecast datain one dimension in the
Hyperion Esshase database? Because thereisno ACTUAL or FORECAST
member inthe OLAP model, you must create Actual and Forecast as user-defined
members.
» To create Actual and Forecast as user-defined members:
1. Inthe metaoutling, create a Scenario dimension.
See “Creating Dimensions Associated with an OLAP Model” on page 3-12.

2. To the Scenario dimension, add the Actual and Forecast user-defined
members.

See “Creating User-Defined Dimensions and Members” on page 3-19.
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3. Tothe Actua member, add the 1996 and 1997 members from the OLAP

model.
See “ Creating Dimensions Associated with an OLAP Maodel” on page 3-12.

When Hyperion Integration Server builds the Hyperion Essbase outling, it
creates the Scenario dimension, as shown in Figure 3-5:

Scenano
[~ Actual
1995
199?
Figure 3-5: User-Defined Scenario Dimension

Because Actual receives its data from the data source, tag ACTUAL asthe
default load member.

See “ Defining the Load Member for a User-Defined Dimension” on
page 3-21.

L oad members and data from the forecasting worksheet into the Forecast
member of the Hyperion Essbase outline.

Thus, the Forecast member and the 1998 member are added to the Scenario
dimension in the Hyperion Essbase outline.

Scenano
ctual
1996
. 199?
Forecast
L1998

Figure 3-6: Final Hyperion Essbase Outline

See the Hyperion Essbase Database Administrator’s Guide for more
information about loading members and data from worksheets.
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About Naming

When naming metaoutlines, dimensions, member levels, aiases, UDAS, and
metaoutline filters in the metaoutline, follow these rules:

e Do not use more than 80 characters.

e Do use mixed uppercase and lowercase characters. Names are not
case-sensitive in Hyperion Essbase unless there is a check mark next to
the Settings > Case Sensitive Members menu item in Hyperion Essbase.

When naming dimensions, member levels, aliases, UDAS, and metaoutline filters,
observe the following rules:

e Do not use quotation marks () or tabs anywhere in a name.

e Do not use any of the following charactersin aname:

@ (atsign) () (parenthesis)
(backslash) . (period)

{} (brace) +  (plussign)

,  (comma) ! (single quotation mark)

- (dash, hyphen, or minus sign) _  (underscore)

=  (equa sign) | (vertical bar)

< (lessthan sign) /  (slash)
(asterisk) *  (double quotation mark)
tabs

e Do not place spaces at the beginning or end of aname. (Hyperion Essbase
ignores spaces at the beginning or end of a name.)

e Do not use any of the following words as a dimension or member level name:
— S$$SUNIVERSESSS
—  #MISSING Or #MI
— Cadc script commands, operators, and keywords.

For alist of commands, see the online Technical Referencein your
Hyperion\Essbase\DocCs directory.
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— Report script commands.

For alist of commands, see the online Technical Referencein your
Hyperion\Essbase\DoCS directory.

— Function names and function arguments.

For alist of functions, seethe online Technical Referencein your
Hyperion\Essbase\DoCS directory.

— The name of an existing dimension, member level (unlessthe member is
shared), alias, or combination alias; a generation name; or alevel name

Note: If you tag members as Dynamic Time Series, do not use the
associated generation names:. History, Year, Season, Period,
Quarter, Month, Week, or Day. See the Hyperion Essbase
Database Administrator’s Guide for more information.

When you use amember level namein acalc script, report script, or formula, you
must enclose the member level name in quotation marks (") in the following
situations:

e The name contains one or more numerals at the beginning of the name
(for example, 100-Blue).

e The name contains spaces anywhere in the name.

e The name contains any of the following characters:

*  (asterisk) 1 (exclamation point)

@ (atsign) >  (greater than sign)

{} (braces) < (lessthan sign)
(bracket) () (parenthesis)
(colon) s (percent sign)

. (comma) +  (plussign)

- (dash, hyphen, or minus sign) ; (semicolon)

= (equa sign) /  (dash)

\  (backslash)

e The name starts with an ampersand (&).
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In calc scripts and formulas, you must enclose the following member level
names in quotation marks (""):

AND ELSEIF IF OR
BEGIN END MACRO RANGE
DOUBLE ENDIF MEMBER STRING
ELSE FUNCTION NOT THEN

Creating Dimensions, Member Levels,
and Measures

As shown in Figure 3-7, the OLAP model in the left frame of the OLAP

M etaoutline main window can contain dimensions, hierarchies, columns, and
measures. These are the OLAP model objects that you can drag to the right frame
of the OL AP Metaoutline main window to create dimensions, member levels, and
measures in the metaoutline.

File Edit “iew Connections Outine Toolz ‘Window Help ;Iilll
DEHE|&| 0w s (= A%
I"Default j| V= W Ux
C Madel & | =3 TBC Metaoutiine
Dimension I 5§ Vear H-E Year
Dimension table ——=-& Time i Measures
A& Month B Product
Column A& Quarter B Market
A% Year -Ef Scenario
. %a Quarter, Month
Hierarchy - %, ‘Year, Quarter, Morth
% 1936 Quarter, Maonth
BB Accounts
E-F Accounts b
« ADDITIONS
Measure . COGS
« ENDING_INVENTORY
io-He MARKETING
e fle MIST =
4 | o xl | &
| Data Source: TEC
Faor Help, press F1 |DLAF' Catalog: tbe_md i

Figure 3-7: Objects in the OLAP Model

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide m 3-11



Chapter 3

This topic contains the following subtopics:

“Creating Dimensions Associated with an OLAP Model” on page 3-12
“Creating Member Levels Associated with an OLAP Model” on page 3-15
“Creating Recursive Dimensions” on page 3-17

“Creating User-Defined Dimensions and Members’ on page 3-19
“Defining the Load Member for a User-Defined Dimension” on page 3-21
“Creating a Measure Dimension” on page 3-24

“Creating a Measure Dimension” on page 3-24

Creating Dimensions Associated with an
OLAP Model

To use an OLAP model object to create a dimension in ametaoutline, drag a
dimension, hierarchy, column, or measure from the |eft frame of the OLAP
M etaoutline main window to the right frame of the OLAP Metaoutline main
window.

3-12 1

When you drag an object to the right frame, the object creates anew dimension at
the bottom of the metaoutline. The new dimension uses the OL AP model name of
the dimension in which the OLAP model object is located.
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For example, if you drag the SALES measure to the right frame, the SALES
measure creates the Accounts dimension with the SALES measure inserted

under it.
* . Hyperion Integration Server Desktop - [Metaoutline] [ |O] x|
File Edit “iew Connections Outine Toolz ‘Window Help ;Iilll
DEHE|&| 0w s (= A%
I"Default j| V= W Ux
5@3 Accounts =] E-E Metaoutinel
=B Accounts E-Ef Accounts

l

ADDITIONS

COGS

ENDING_INVENTORY
2« MARKETING

i MISC

s OPENING_INVENTOD
s PAYROLL

r. S

E-Ef Market
E-F] LOOKUP_MARKET

o B OTY

Bee REGION

----- Pl REGION_TYPE

s

Faor Help, press F1

©-fle. [SALES

| Drata Source: the
| OLA&P Catalog: the_md i

Figure 3-8: Using a Measure to Create a Dimension

If you drag a...

The selected object
creates a...

For example...

e
Dimension, EE

New dimension.

The Product dimension of the |eft frame
creates the Product dimension in the right
frame.

Hierarchy, %3'

New dimension that contains
the hierarchy.

The Quarter, Month hierarchy of the left
frame creates in the right frame the Year
dimension with the Quarter and Month
member levels arranged hierarchically.

Text column, Buee

New dimension that contains
amember level that is based
on the text column.

The PRODUCT_ID column of the
|eft frame creates in the right frame
the Product dimension with the
PRODUCT_ID member level.
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If you drag a...

The selected object
creates a...

For example...

Numeric column,

E123

New dimension that contains
amember level that is based
on the numeric column.

The STATE_TYPE_ID column of
the left frame createsin the right
frame the Market dimension with the
STATE_TYPE_ID member level.

Measure, B:.

New dimension that is
tagged as accounts and that
contains a measure based on
the accounts value.

The ADDITIONS column of the left
frame creates in the right frame the
Accounts dimension with the
ADDITIONS member level.

' A
Time column, H&

New dimension that is
tagged as time and that
contains a member level
based on the time column.

The Month column in the left frame
creates in the right frame the Year
dimension with the Month member level.

For information on selecting multiple dimensions, hierarchies, columns, and
measures in the left frame, see “ Selecting Multiple Objects in the Left Frame” on
page 2-15.

After adimension is created in the right frame, you can drag the dimension to
another location within the metaoutline and rename the dimension.

See “Renaming Dimensions, Member Levels, and Measures’ on page 3-25.

CAUTION: You must define at least one measure in each metaoutline.
If the metaoutline does not contain a measure, you cannot
use the metaoutline to build a Hyperion Essbase outline.
See “Creating a Measure Dimension” on page 3-24.

3-14 1
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Creating Member Levels Associated with an
OLAP Model

To create amember level from an OLAP model object, drag a column, hierarchy,
or measure from the left frame of the OL AP Metaoutline main window to the right
frame of the OLAP Metaoutline main window.

For example, if you drag the predefined 1996 Y ear, Quarter, Month hierarchy into
theright frame, the hierarchy createsaY ear dimension with the hierarchy inserted
under it, asillustrated in Figure 3-9.

* . Hyperion Integration Server Desktop - [Metaoutline] [ |O] x|
File Edit “iew Connections Outine Toolz ‘Window Help ;Iilll
DEHE|&| 0w s (= A%

I"Default j| W= W Wx

=1 TBC Model = Metaoutline

-5 Year E-Ef Vear

B Time =B Time.vear
T Cuarter, Month / =-E8 Time. Quarter
RN =i, Ouarter, Morith *-ER Time.Month

% 1996 Guarter, Month
Accounts

| Drata Source: the
Faor Help, press F1 |DLAF' Catalog: tbe_md i

Figure 3-9: Using a Hierarchy to Create a Dimension
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If you drag a column,

hierarchy, or measure

onto a... The selected object creates a... For example...

Blank space New dimension and inserts the Dragging the ADDITIONS
member level, the hierarchy of column onto a blank space
member levels, or the measure creates an Accounts
directly under the new dimension. dimension with an
This action creates the new ADDITIONS member level.
dimension at the bottom of the You can rename the
metaoutline and gives the new Accounts dimension to
dimension the name of the dimension | Measures.
in which the OLAP model object is
located.

Dimension New member level, hierarchy of new | Draggingthe PRODUCT _ID
member levels, or measure directly column onto the Product
under the selected dimension. dimension creates a
This action creates the new member | PRODUCT_ID member
level, hierarchy of new member level under the Product
levels, or new measure at the bottom | dimension.
of the selected dimension and gives
the new object or measure the name
that the object had in the OLAP
model.

Member level New member level, hierarchy of new | Dragging the DIET column
member levels, or new measure onto the PRODUCT _ID
directly under the selected member member level createsaDIET
level. member level under the
This action creates the new member | PRODUCT_ID member
level, hierarchy of new member level.
levels, or new measure at the bottom
of the selected member level and
gives the new object the name that
the object had in the OLAP model.

For information on selecting multiple dimensions, hierarchies, columns, and
measuresin theleft frame, see” Selecting Multiple Objectsin the Left Frame’
on page 2-15.
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After anew object iscreated in theright frame, you can as necessary, do one of the
following:

e Dragthe newly-created member level or measure to the appropriate location
in the dimension.

e Rename the newly-created member level or measure.
See “Renaming Dimensions, Member Levels, and Measures’ on page 3-25.

e Dedete unwanted member levels of ahierarchy, from the leaf level up, by
selecting an unwanted member level and pressing Delete.

Creating Recursive Dimensions

Y ou can create dimensions that contain member levels that are based on the
contents of the two columns of a parent-child relationship. These dimensions are
called recursive dimensions. For example, consider thefollowing parent-child data

source.

CHILD PARENT

Murphy Ave. Sunnyvale
Crossman Ave. Sunnyvale
Fremont Drive Mountain View
Java Drive Sunnyvale

Y ou can use the data source to create the following Hyperion Essbase outline:

[~ Sunnyvale
Murphy Ave.
Crossman Ave.

Java Drive
A Mountain View
L [CJFremont Drive

When creating arecursive dimension, follow these rules:
e Do not set transformations on member levelsin recursive dimensions.

e If youwant to assign aiases or UDASs to recursive member levels, you drag
from the left frame to the right frame the column to which the alias or UDA
column applies. For example, if the alias column applies to the child column,
use the child column in the metaoutline. If you are not sure to which column
(parent or child) the alias or UDA column applies, see the information on
creating aliasesin Hyperion Integration Server Desktop OLAP Model User’s
Guide.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide m 3-17



Chapter 3

If you create afilter on the parent member level of arecursive dimension,
OLAPIntegration Server appliesthefilter only to values of the parent member
level column. OLAP Integration Server returns both the parent member level
that satisfies the requirements of the filter and the immediate child of that
parent.

For example, if you apply afilter to retrieve only East on the
MARKET.PARENT column of TBC Metaoutline, OLAP Integration
Server retrieves only therowsthat havethe East in the parent column,
such as the rows that contain East, Florida and East, New Y ork.

If you create afilter on the child member level of arecursive dimension,
Hyperion Integration Server applies the filter only to valuesin the child
column. OLAP Integration Server returns both the child value that satisfiesthe
filter condition and the immediate parent of that child. If achild member level
is shared by multiple parents, OLAP Integration Server returns al immediate
parents of the child.

For example, if you apply afilter to retrieve only East on the
MARKET_CHILD column of TBC Metaoutline, OLAP Integration
Server retrievesonly the rows that have East in the child column, such as
the row that contains USA, East. If East is shared by multiple parents,
OLAP Integration Server also returns all parents, for example, England,
East or Canada, East.

» To create arecursive dimension:

3-18 W

1. Set up the parent-child data source for recursive dimensions.

See the Hyperion Integration Server Desktop OLAP Model User’s Guide.

Drag either the parent column or the child column (but not both) to the right
frame of the OLAP Metaoutline main window.

OLAP Integration Server creates the recursive hierarchy during the member
load.
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Creating User-Defined Dimensions and Members

User-defined dimensions and members are not associated with an OLAP model.
Y ou can create a user-defined dimension as a child of the metaoutline or as a
sibling of an existing dimension. Likewise, you can create a user-defined member
asachild of adimension (either a user-defined dimension or adimension
associated with an OLAP model) or as a sibling of an existing user-defined
member. Y ou cannot create a user-defined member as a child of a
database-defined member level. See “ About User-Defined Dimensions and
Members’ on page 3-7.

This topic contains the following subtopics:
e “Creating as Children” on page 3-19
e “Creating as Siblings’ on page 3-20

Creating as Children

» To create a user-defined dimension as a child of a metaoutline or a user-defined
member as a child of adimension:

1. Intheright frame of the OLAP Metaoutline main window, select one of the
following:

e To create adimension, select the metaoutline name, for example,
TBC Metaoutline, =+ E TBC Metaoutline.

e To create amember, select a dimension name, for example, Scenario,

== .
Ef Scenario

Note: You cannot create a user-defined member as achild of a
database-defined member level.
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To name the new dimension or member, select Edit > Add Member as Child,

or click the Add Child button, ﬂ. The Enter the new dimension’s name
dialog box is displayed.

Enter the new dimension’s name E

|
QK I Cancel | Help |

Figure 3-10: Naming a New Dimension

Enter the new dimension or member name, for example, Scenario.
See “About Naming” on page 3-9.
Click OK.

If you create adimension, it is displayed as the first dimension in the
metaoutline. If you create amember, it is displayed as the first member in
the dimension.

If necessary, drag the newly-created dimension or member to the appropriate
location in the metaoutline.

Creating as Siblings

» To create a user-defined dimension as asibling of an existing dimension or a

3-20 W

user-defined member as a sibling of a user-defined member:

In the right frame of the OL AP Metaoutline main window, do one of the
following:

e Select the dimension after which you want to add the new dimension, for
example, Year, B ear,

e Select the user-defined member after which you want to add the new
member, for example, Profit, =0 Prafit,

Note: You cannot create a user-defined member as achild of a
database-defined member level.
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2. Select Edit > Add Member as Sibling, or click the Add Sibling button, ]
The Enter the new dimension’s name dialog box is displayed.

Enter the new dimension’s name E

QK I Cancel | Help |

Figure 3-11: Naming a New Dimension

3. Enter the new dimension or member name, for example, Scenario.
See “About Naming” on page 3-9.
4. Click OK.

If you create a dimension, the new dimension is placed after the selected
dimension. If you create a member, the new member is placed after the
selected member.

5. If necessary, drag the newly-created dimension or member to the appropriate
location.

Defining the Load Member for a
User-Defined Dimension

A user-defined dimension is not connected to the related OLAP model. Because
thedimension isnot connected to the OLAP model, OL AP Integration Server does
not know into which member to load data. Therefore, you must select a member
in the user-defined dimension for OLAP Integration Server to load datainto. The
selected member is called theload member. Y ou must select oneload member for
each user-defined dimension.
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» To set the load member in a user-defined dimension:

1. Intheright frame of the OLAP Metaoutline main window, select the
metaoutline name, for example, TBC Metaoutline.

2. Right-click the metaoutline name, and, from the pop-up menu, select
Properties.

3. Select the User Defined Dimensions tab.

OLAP Metaoutline Properties E

Generall Database Measures  User Defined Dimensions | Govemorsl Dill-Through Heportsl

Dimension | Load kember |
Scenario

QK | Cancel Help

Figure 3-12: Viewing User-Defined Dimensions

4. Select the user-defined dimension for which you want to define the default
load member, for example, Scenario.
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5. Click Edit.

The Select aMember dialog box, which listsall user-defined members of the
selected dimension, is displayed.

Select a Member

[ ]
Select a member: ] |

El-E# Seenario
0 Actual Cancel

Figure 3-13: Setting the Default Load Member

6. Select the member to use as the default load member, for example, Actual.

Note: You can also set the default load member by right-clicking a
member of auser-defined dimension and selecting Default Load
Member from the pop-up menu. When you select Default Load
Member, a check mark is displayed next to Default Load
Member in the pop-up menu.

7. Click OK.

OLAP Integration Server loads data from the relational data source into the
default load member the next time you perform a data load.
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Creating a Measure Dimension

If ametaoutline contains more than one measure (data value), you must define a
measure dimension and add all measuresto that dimension. All measures that you
can use in the metaoutline are defined in the OLAP model.

Y ou can create a measure dimension by using the OLAP model dimension that is
tagged as accounts or by creating a new dimension and tagging it as measure. See
“About Measures’ on page 3-6.

All measures must be defined at level O (the leaf level) of the metaoutline. If you
want to group measures under a parent, create the parent as a user-defined
member. See “ Creating User-Defined Dimensions and Members’ on page 3-19.

» To create ameasure dimension from the OLAP model dimension tagged as
accounts:

1. Drag the dimension tagged as accounts from the OLAP model to the
metaoutline.

The selected dimension creates in the metaoutline a measure dimension
tagged as accounts.

2. Drag the appropriate measures, such as COGS, from the OLAP model to the
metaoutline dimension tagged as accounts.
» To create ameasure dimension without using the OLAP model dimension tagged
as accounts:
1. Create the dimension that you want to use as the measure dimension.
2. Select the dimension.

3. Right-click the dimension, and, from the pop-up menu, select Database
Measure Dimension.

4. Drag the appropriate measures, such as COGS, from the OLAP model to the
measure dimension.

Note: If the dimension is not tagged as accounts in the OLAP model,
the measures that you add do not use the standard measure

icon, Bz« Instead, they use the column icon, . Regardless of
the button, however, Hyperion Integration Server treats the
members as measures during member and data loads.
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Renaming Dimensions, Member Levels,
and Measures

Y ou can change the names of metaoutline dimensions, member levels, or measures
in the right frame of the OLAP Metaoutline main window or in the Properties
dialog box. This topic contains the following subtopics that describe how to
change names:

e “Renaming in the Right Frame” on page 3-25

e “Renaming in the Dimension Properties or Member Properties Dia og Box”
on page 3-26

e “Renaming a Single Measure” on page 3-27

Renaming in the Right Frame

» To rename adimension, member level, or measurein theright frame of the OLAP
M etaoutline main window:

1. Select the dimension, member level, or measure name, for example, Quarter.

2. Double l€eft-click the dimension, member level, or measure; for example,

3. Enter the new name.
See “About Naming” on page 3-9.
4. Do one of thefollowing:
e To save the new name, press Enter.

e Torename another dimension, member level, or measure in the
metaoutline, repeat steps 1 through 4.
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Renaming in the Dimension Properties or
Member Properties Dialog Box

» To rename a dimension, member level, or measure by using the Dimension
Properties or Member Properties dialog box:

1. Intheright frame of the OLAP Metaoutline main window, select the
dimension, member level, or measure name.

2. Right-click the dimension, member level, or measure, and, from the pop-up
menu, select Properties.

The Dimension Properties or the Member Propertiesdialog box is

displayed.

General | Member Infol Account Infol UDAs I Formulal

M ame:

IMeasuresl

Tupe:

|Dimensi0n

OLAP Model Dimensior:

lﬁccounts

QK I Cancel | Help |

Figure 3-14: Renaming a Dimension or Member Level

3. Inthe Nametext box, enter the new name.
See “About Naming” on page 3-9.
4. Click OK.
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Renaming a Single Measure

» Torenameasingle measure by using the OL AP Metaoutline Propertiesdial og box:

1. Intheright frame of the OLAP Metaoutline main window, select the
metaoutline name; for example, TBC Metaoutline.

2. Right-click the metaoutline name, and, from the pop-up menu, select
Properties.

The OLAP Metaoutline Properties dialog box is displayed.
3. Select the Database M easur es tab.

OLAP Metaoutline Properties E

General Database Measures | Uszer Defined Dimensionsl Govemorsl Dill-Through Heportsl

Dimension: Accounts

Mame | Fielational Colurnn | Member |
FACT_TABLE.SALES SALES Edit... |
Addl.
Delete |

QK I Cancel Help

Figure 3-15: Renaming a Single Measure
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4. Select ameasure and click Edit.

The Measure Properties dialog box is displayed.

Measure Properties E

General | Filters I Transformationsl

M ame:

[atabaze Properties:

0G5
ENDING_INVENTORY
MARKETING
MISC
OPENING_INVENTORY
PAYROLL
PRODUCT _KEY

L . R

I

Member:
SALES

Ll

QK I Cancel | Help |

Figure 3-16: Using the Measure Properties Dialog Box

5. Inthe Nametext box, enter the new name.
See “About Naming” on page 3-9.
6. Click OK.
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Deleting Dimensions, Member Levels,
and Measures

When you delete a dimension, member level, or measure from a metaoutline, you
delete all build and load operations associated with the dimension, member level,
or measure. You aso delete all member levelslocated below the dimension,
member level, or measure. For example, if you deletethe Y ear dimension from the
TBC Metaoutline, you delete all members of the Y ear dimension, that is,
Time.Quarter and Time.Month.

CAUTION: You cannot undo a delete operation.

To delete adimension, member level, or measure from a metaoutline, use one of
the following techniques:

e Select the dimension, member level, or measure and press the Delete key.

e Right-click the dimension, member level, or measure and select Delete from
the pop-up menu.

e Select the dimension, member level, or measure and, from the Edit menu,
select Delete.
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Viewing Sample Dimensions, Members, and
Hyperion Essbase Outlines

After you create a metaoutline, you may want to see what the dimensions and
memberswill look likein the Hyperion Essbase outline before you build the entire
Hyperion Essbase outline. Before you build the Hyperion Essbase outline, you
can view the metaoutline in Hyperion Essbase outline format to ensure that you
have defined the dimensions and the member levels correctly, set filters and
transformations correctly, and optimized the SQL generated by OLAP Integration
Server.

CAUTION: OLAP Integration Server truncates sample outlinesif
they contain more than 32,767 members.

» To view adimension, member, or metaoutlinein Hyperion Essbase outline format:

1. Besurethereisenough RAM on the computer on which Hyperion Integration
Server Desktop isinstalled to view the entire sample.

If you are not sure of the available RAM, set a query governor to control the
duration and the size of the query that OLAP Integration Server makesto the
relational data source.

2. Within theright frame of the OLAP Metaoutline main window, use one of the
following methods to preview a sample outline:

e For asample outline, select the metaoutline name—for example, TBC
Metaoutline—and select View > Sample.

e For asample dimension or member, right-click the dimension or member
level—for example, Product—and, from the pop-up menu, select Sample.

e For results of filtering or transformation operations on either the Edit
OL AP Metaoutline Transfor mations dialog box or the Member L oad
Filtering dialog box, select Preview Results.
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Hyperion Integration Server Desktop opens the appropriate dial og box: either
the Sample Outline dialog box, Preview Filter Results dialog box, or the
Preview Transformation Results dialog box.

Sample Outline <]
ple Dutline:

™
- e
[l Measures Help |

[ Market
[l Product
- Scenaria

Sarmple Build SOL:

SELECT {fin QUARTER[a. TRANSDATE]. {fn -
MONTH[a. TRANSDATE]}

FROM TBC.FACT_TABLE a

ORDER BY 1 ASC, 2 ASC

SELECT aREGIOM, a.STATE LI

Figure 3-17: Viewing a Sample Hyperion Essbase Outline

The sample outline contains the sample dimensions. Y ou can click dimension
and member names to expand dimensions and members and examine the
structure of the Hyperion Essbase outline; for example, you can examine the
Product dimension.

The Sample Build SQL box displays the SQL statements that OLAP
Integration Server generated to create the sample Hyperion Esshase
outline. Use the sample SQL to do any of the following:

e Make sure that the metaoutline refers to the intended data in the externa
data source.

e Tunetheexterna data sourceto speed the process of building and loading
datainto the Hyperion Essbase outline.

e Cut and paste the SQL statement to an external fileto view or print.

3. When you finish viewing the sasmple dimensions and the sample SQL,
click Close.
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Viewing Defined Measures

After you complete a metaoutline, you may want to review the measures it
contains.

» To view all measures defined in a metaoutline;

1. Intheright frame of the OLAP Metaoutline main window, select the
metaoutline name, for example, TBC Metaoutline.

2. Right-click the metaoutline name and, from the pop-up menu, select
Properties.

3. Select the Database M easur es tab.

OLAP Metaoutline Properties E

General Database Measures | Uszer Defined Dimensionsl Govemorsl Dill-Through Heportsl

Dimension: Measures

Mame | Fielational Colurnn | Member |

ADDITIONS FACT_TABLE.ADDI.. ADDITIONS Edit...
COGS FACT_TABLE.COGS — COGS _—I
ENDING_INVENTORY FACT_TABLE.ENDI.. ENDING_INVENTO.. Add
MARKETING FACT_TABLE.M&R... MARKETING e
MISC FACT_TABLE.MISC  MISC

OPEMIMG_INVENTO... FACT_TABLE.OPE.. OPENING_INVENT.. [IElEtE |
PavYROLL FACT_TABLE.P&Y.. PavROLL

SALES FACT_TABLE.SALES SALES

QK I Cancel | Help

Figure 3-18: List of Measures in the Metaoutline

A list of the measures defined in the metaoutline is displayed in the list box.

4. When you finish viewing the measures, click OK.
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Y ou can also use the Database M easur es tab of the OL AP M etaoutline
Properties dialog box to edit or delete ameasure. In the Database Measures tab,
select the measure—for example, COGS—and click Edit or Delete.

If you edit a measure, you can change any of the following:

The name of the measure. See “Renaming a Single Measure” on page 3-27.

The column on which the measure is based. Usethe same steps asfor creating
asingle measure. See “ Changing the Column Associated with aMeasure” on
page 4-29.

Transformations to perform on the measure. See “ Scaling Measures” on
page 4-27 and “Reversing Measure Signs’ on page 4-28.

Filters defined on the measure. See “Creating a Measure Filter Interactively”
on page 5-18.
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Setting Load Properties

This chapter describes how to set load properties for dimensions, member levels,
and measures. Load properties determine what actions OLAP Integration Server
performs on dimensions, member levels, and measures as it builds a Hyperion
Essbase outline or loads datainto a Hyperion Essbase outline. For example, OLAP
Integration Server can transform member level names as it loads them from the
relational data source to the related Hyperion Essbase outline.

Note: Before setting load properties, you should perform the following
transformationsin the OLAP model: splitting one columninto two or
more columns; creating new columns that are based on existing
columns; and fixing data inconsistencies, such as making sure that
Californiaisused as either aregion or astate, but not as both. Seethe
Hyperion Integration Server Desktop OLAP Model User’s Guide.

This chapter contains the following topics:

e “Understanding the Metaoutline Workflow” on page 4-2

e “Setting Load Properties for Dimensions’ on page 4-3

e “Setting Load Properties for Member Names' on page 4-11
e “Setting Load Properties for Members’ on page 4-22

e “Setting Load Properties for Measures’ on page 4-26

For information about setting other properties, see Chapter 5, “Working with
Filters” and Chapter 6, “ Setting Hyperion Essbase Properties.”
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Understanding the Metaoutline Workflow

Figure 4-1 illustrates the workflow for creating a metaoutline and using the
metaoutline to create and load members and data into a Hyperion Essbase
database. This workflow includes the following processes:

e Creating and working with a metaoutline
e Adding dimensions, member levels, and measures to a metaoutline

e Setting load properties, filters, and Hyperion Essbase properties on
dimensions, member levels, and measures in a metaoutline

e Loading dimensions and members from a metaoutline into a Hyperion
Essbase outline

e Loading the data specified in a metaoutline into a Hyperion Essbase database

This chapter focuses on setting load properties. Y ou can set |oad properties before
or after setting filters and Hyperion Essbhase properties.

Crecting ang

wiorking with
metaoutlines

E-E9 TEC_MODEL
B MARKETS
B-Ef SCENARID

-

f

Bl & Market
: : : MARKET REGION
Adding dimensions, member o % %asures
levels, and measures to a O Profit
metacutline o Ratios

@ Setting load properties, L Load Properties
filters, and Hyperion Filters

. Hyperion Essbase Properties
You Are Here ESsbase properties P - P

Loading dimensions

and members 33 ab

Loading data

Figure 4-1: Metaoutline Workflow
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Setting Load Properties for Dimensions

The following topics describe the load properties that you can set for dimensions,
such as determining what to do with duplicate member names and with new
member levels.

e “About Duplicate Member Names’ on page 4-3

e “Understanding Rules for Shared Members’ on page 4-6
e “Handling Duplicate Member Names’ on page 4-6

e “Handling New Members During Data Load” on page 4-8

About Duplicate Member Names

A data source and a metaoutline can contain duplicate member names. For
example, TBC Metaoutline uses the PRODUCT.PRODUCT _ID column twice,
once under PRODUCT_GROUP_ID and once under Diet.

e

= E# Product
=-ff LOOKUP_PRODUCT PRODUCT_GROUP_ID
- -fB LooKUP_PRODUCT.PRODUCT_ID
B0 Dist

Figure 4-2: PRODUCT.PRODUCT_ID Column

When OLAP Integration Server performs a member load, it performs one of the
following actions when it encounters the members under Diet:

e Ignores the duplicate members. OLAP Integration Server does not load the
members into the Hyperion Essbase outline.
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4-4 A

Creates the members under Diet as shared members, as shown in Figure 4-3.
The data associated with a shared member is stored in the real member. For
example, the datafor the second 100-20 member (under Diet) is stored in the

first 100-20 member (under Colas).

[~ Product

[~ Calas
1DD-1 0
100-20
100-30

[ Cream_Soda

M|Root Beer

I Diet
100-20 (Shared Member)
200-20 (Shared Mermber)
300-20 (Shared Mermber)

Figure 4-3: Shared Members

In arecursive hierarchy, moves duplicate members within the recursive

hierarchy.

In arecursive hierarchy, moves generation 2 members that have no existing

parent within the recursive hierarchy.

For example, suppose that you have the following manager-employee
organizational chart under the dimension People:

Manager Employee
Dotty Donna
Nancy Dotty
Dotty Linda
Nancy Jack
ABC Project Dotty
ABC Project Donna
XYZ Project Jack
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The hierarchy created by loading the first record is as follows:

HPeople Generation 1
[ DT%T Generation 2
Donna  Generation 3

Because the first hierarchy contains a generation 2 member without a parent,
thefirst hierarchy ismoved down alevel when the second record isloaded, as
shown in the following example:

AJPeople
L [A|Mancy
L [A]Datt
Danna

The following Hyperion Essbase outline is generated from the previously
described recursive hierarchy:

.F'eole
Nancy
[~ Datt
gDonna
Linda

[Jdack

[~JABC Project
Dotty (Shared Mermber)

Donna (Shared Mermber)
.XYZ Project
L [CJdack  (Shared Member)

For more information on recursive hierarchies, see “ Creating Recursive
Dimensions’ on page 3-17.

Y ou can prevent the creation of duplicate member names by transforming data
when you create an OLAP model. For more information, see the Hyperion
Integration Server Desktop OLAP Model User’s Guide.
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Understanding Rules for Shared Members

Hyperion Essbase follows these rules for shared members:

Shared members must be in the same dimension. For example, both 100-20
members are in the Product dimension.

A dimension can contain both shared and non-shared members.
Shared members cannot have children.
An unlimited number of shared members can have the same name.

User-defined attributes (UDAS), formul as, consolidation properties, and
account properties cannot be assigned to shared members.

Shared members can be assigned aliases.

In aHyperion Essbase outline, a shared member should not be located before
itsreal member. For exampl e, the 100-20 shared member (under Diet) must be
located after the 100-20 real member (under Colas) in the Hyperion Essbase
outline.

Any transformation performed on amember name must a so be performed on
the duplicate member name. For example, if you change the original member
level name from New York to NY, you must perform the same change on the
duplicate member name.

Handling Duplicate Member Names

4-6 W

» To handle duplicate names in a metaoutline:

1.

In the metaoutline, select a dimension that you expect to contain duplicate
names, for example, Product.

2. Right-click the dimension and, from the pop-up menu, select Propertiesto

open the Dimension Properties diaog box.

Y ou can also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.
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3. Select the Outline Build tab.

Dimenzion Properties - Product E

Generall Memberlnfol Accountlnfol UDAs I Formula ~ Outline Build |

%) Erefived|with Dimensiom Hame
) Suffirediwith Dimensiom Hames
) W prefiv on suffiz

— Duplicate Member Mame:

' |gnore

& 4dd as shared members

' Move members

' Share members/move if no parent{Gen 2)

QK I Cancel | Help |

Figure 4-4: Handling Duplicate Member Names

4. Fromthe Duplicate M ember Names group, do one of the following:

e Select Ignoreto ignore duplicate member names during the build of the
Hyperion Esshase outline.

OLAP Integration Server does not load the members into the Hyperion
Essbase outline.

e Select Add asshared membersto create the duplicate member names as
shared membersin the Hyperion Essbase outline.

e Select Move member sto move duplicate members of recursive
hierarchies.

e Select Share members/move if no parent(Gen2) to move, within
recursive hierarchies, generation 2 membersthat have no existing parent,
even if shareis specified.

For more information on this option, see “ About Duplicate Member
Names’ on page 4-3.
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Any transformation performed on a member name must aso be
performed on the duplicate member name. For example, if you changethe
original member level namefrom New Y ork to NY, you must perform the
same change on the duplicate member name.

If you are not sure which option to select, see “ About Duplicate Member
Names’ on page 4-3.

5. Click OK.
Tip:  You can also create shared members by setting the Shared

Member Hyperion Essbase property. See* Specifying Data
Storage Properties for Dimensions and Members™ on page 6-8.

Handling New Members During Data Load

4-8 H

During the time lapse between the build and the data load of a Hyperion Essbase
outline, the information on which the outline structure is based can change. For
example, someone may add a new member to the fact table or to areferencetable.

Assumethat the Hyperion Essbase outline build produces an outlinethat lookslike
the following:

[~ Product
] Calas
| Cream_Soda
Figure 4-5: Hyperion Essbase Outline

What if someone adds Root_Beer to the fact table and to a reference table of the
data source? When you perform the data load, the new member is available.

If the Hyperion Essbase outline includes miscellaneous members, OLAP
Integration Server adds the new member to the miscellaneous member of
the appropriate dimension. With the addition of the Root_Beer member,
for example, the Hyperion Essbase outline looks like the following:

[~ Product
] Calas
| Cream_Soda

|~ Mizcellaneous
L |Root_Beer

Figure 4-6: Miscellaneous Member Example
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After the dataload is complete, you can view the members of Miscellaneous.

During dataload, OLAP Integration Server ignores any new member whose
Hyperion Essbase dimension does not include amiscel laneous member. However,
OLAP Integration Server records that the new member exists and that it was
ignored. For more information on viewing the log file in which thisinformationis
recorded, see the Hyperion Integration Server System Administrator’s Guide.

» To add new members to a miscellaneous member level in a metaoutline:

1. Inthe metaoutline, select the dimension that you expect to contain new
member levels, for example, Product.

2. Right-click the dimension and, from the pop-up menu, select Propertiesto
open the Dimension Properties dialog box.

Y ou can aso open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

3. Select the Outline Build tab.

Dimenzion Properties - Product E

Generall Memberlnfol Accountlnfol UDAs I Formula ~ Outline Build |

— Default Miscellansous Member

e
I_Misc

& Prefired with Dimension Mame
" Suffived with Dimension Mame
' No prefiz or suffis

— Duplicate Member Mame:
' |gnore
& 4dd as shared members
' Move members
' Share members/move if no parent{Gen 2)

QK I Cancel | Help |

Figure 4-7: Setting the Miscellaneous Member

4. From the Default Miscellaneous Member group, select Enabled.
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4-10 1

5.

7.

In the Name box, enter the name of the miscellaneous member; for
example, Misc.

See “About Naming” on page 3-9.

Y ou may ignore the dimension name. However, it is recommended that you
includethe dimension name as aprefix or suffix of the miscellaneous member
name. Prefixing or suffixing a member name with the name of the related
dimension helps you to identify the dimension with which the member is
associated.

For example, if the new member Root_Beer isin the Product dimension and
you prefix the miscellaneous member name with the dimension name, the
Misc member looks like the following:

[~ Product
] Calas
| Cream_Soda

|~ Productiisc
L |Root_Beer

Figure 4-8: Miscellaneous Dimension

If you want to set amiscellaneous member on morethan onedimension, return
to step 1.

Note: If you set a miscellaneous member on more than one dimension,
you must prefix or suffix the dimension nameto the name of each
additional miscellaneous member so that each miscellaneous
member nameis unique. If you do not prefix or suffix the names
of subsequent miscellaneous members, you will have multiple
members named Miscellaneous, for example, one under Product
and one under Market.

Click OK.
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Setting Load Properties for Member Names

This topic describes how to set load properties for member names, including how
to replace parts of member names, drop spaces around member names, convert
spaces to underscores within member names, attach text stringsto member names,
and change the case of member names.

When setting load properties, follow these general guidelines:

e If you define load properties on areal member that you expect to be shared,
you must define the same load properties on each shared member.

e You cannot perform transformations on aliases.

e Do not set transformations on members of recursive dimensions. See
“Creating Recursive Dimensions’ on page 3-17.

This topic contains the following subtopics:

e “Transforming Member Names’ on page 4-11

e “Replacing Parts of Member Names® on page 4-13

e “Dropping Spaces From Around Member Names” on page 4-16

e “Converting Spaces Within Member Names to Underscores’ on page 4-16
e “Attaching Prefixes and Suffixes to Member Names® on page 4-17

e “Changing the Case of Member Names’ on page 4-21

Transforming Member Names

Y ou can transform a member name so that the member name loaded into the
Hyperion Essbase outline differs from the member name in the relational data
source. For example, suppose that the data source stores product stock unit
numbers.

[AJProduct
L[~ Colas
100-10
100-20
100-30

Figure 4-9: Product Dimension
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4-12 1

Y ou can prefix each number with SKU- so that the product codes are recognizable
as stock units.

[AJProduct
L[~ Colas
SKIU-100-10
SKIU-100-20
SKIU-100-30
Figure 4-10: Product Members with Prefixes

Note: If you sort members, they are sorted before OLAP Integration Server
applies transformations to member names. See “ Sorting Members”
on page 4-23.

OLAP Integration Server performs the specified transformations on member
names in the following order:

1. Drops spaces from around a member name.
See “Dropping Spaces From Around Member Names’ on page 4-16.
2. Converts spaces to underscores.

See “Converting Spaces Within Member Names to Underscores’ on
page 4-16.

3. Changes case.
See “Changing the Case of Member Names” on page 4-21.

4. Performsall replace operationsin the order that you created the operations. If
you are not sure of the order of the replace operations, right-click the member
level and, from the pop-up menu, select Transformation to open the Edit
OLAP Metaoutline Transformations dialog box.

See “Replacing Parts of Member Names” on page 4-13.
5. Applies prefix operations.

See “ Attaching Prefixes and Suffixes to Member Names” on page 4-17.
6. Applies prefix separator operations.
7. Applies suffix operations.

8. Applies suffix separator operations.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Chapter 4

Replacing Parts of Member Names

Asamember isloaded into a Hyperion Essbase outline, its name can be changed.
For example, assume that the data source abbreviates New York asNY. You can
direct OLAP Integration Server to replace each NY with New Y ork during the
build of the Hyperion Essbase outline.

» To change a member name during loading:

1. Inthe metaoutline, select the member level to change, for example,
MARKET.STATE.

2. Right-click the member level and, from the pop-up menu, select
Transformation to open the Edit OL AP M etaoutline Transfor mations
dialog box.

Y ou can also open the dialog box by selecting Edit > Transformation.

Edit OLAP MetaoutlineTransformations - LOOKUP_MARKET.STATE
Feplace | PrefisdSuffig
Search for —Case
INew York & Driginal
_ " Upper Case
Fieplace with @ v Cese
INY " Capitalize First Letters
™ Case Sensitive [C) — Space:
[T Match whale \wWard [w) V' Drop Leading/Trailing Spaces
¥ Beplace &l Dccurences (&) IV Corwert Spaces to Underscores
Add to List EdiDea | Deee |
Search | Feplace | Conditions
Freview Hesults...l QK I Cancel Help

Figure 4-11: Replacing Text Strings

3. Inthe Search for text box, enter the text string that you want to replace; for
example, New York.
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4. Inthe Replace with text box, enter the text with which to replace the text
string; for example, NY.

Note: Do not use double quotation marks (") in the Replace with text
box.

If you want to replace a text string with an empty string, leave the Replace
with text box empty.

Note: When replacing a member name, make sure that you do not use
any of the following characters at the beginning of the name:

(at sign) () (parenthesis)
(backslash) . (period)
{} (brace) +  (plussign)
. (comma) ' (single quotation mark)
- (dash, hyphen, or minus sign) _  (underscore)
= (equa sign) | (vertical bar)
< (lessthan sign) *  (double quotation mark)

5. Specify which of the following options the replacement operation should
observe:

e Becase-sensitive, that is, replace only text strings that match the
capitalization of the string in the Sear ch for text box.

e Replacethetext string only when it occurs asawholeword. For example,
toreplacethe1o inthestring100 10 1 withana, select theM atch Whole
Word option. If you do not select the Match Whole Word option, the
string ischangedto 20 10 1. By default, Hyperion Essbase changes only
the first occurrence.

e Replace all occurrences of the string. For example, if you replace every
occurrenceof 10 inthestring 100 10 1 with &, the string changes to
A0 A 1.

6. Click Add to List to add the replacement operation to the list.
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7. If youwant to change or delete an existing operation, complete the appropriate
action:

e To change an existing operation, select the operation and click Edit
Details.

e To delete an operation, select the operation and click Delete.

8. Click Preview Results to open the Preview Transformation Results dialog
box to view your changes in a sample Hyperion Essbase outline.

See “Viewing Sample Dimensions, Members, and Hyperion Essbase
Outlines’ on page 3-30.

9. Click OK.

Y ou can use the search and replace operation of the Edit OLAP Metaoutline
Transformation dialog box to sort months chronologically.
» To sort months chronologically:

1. Inthe metaoutline, select the appropriate member level, right-click the
member level, and, from the pop-up menu, select Transformation.

The Edit OLAP Metaoutline Transfor mation dialog box is displayed.

2. Replace each month namewith anumber (January=1, February=2, and so on).
See the Hyperion Integration Server Desktop OLAP Model User’s Guide.

3. Sort the month field in ascending order.
See “ Sorting Members’ on page 4-23.

4. Select the Match Whole Word option.

Replace the month number with the month name (1=January, 2=February,
and so on).

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide H 4-15



Chapter 4

Dropping Spaces From Around Member Names

Some relational data sources pad afield by adding spaces at the beginning or end
of thefield. Y ou must direct OLAP Integration Server to remove these spaces
during the build of the Hyperion Esshbase outline.

>» To remove spaces:

1.

In the metaoutline, select the member level that is surrounded by spaces, for
example, Month.

Right-click the member level and, from the pop-up menu, select
Transformation to open the Edit OL AP M etaoutline Transfor mations
dialog box, shown in Figure 4-11.

If the Drop Leading/Trailing option, ¥ Drop Leading/Traling Spaces | s not
selected, select it.

By default, the Drop Leading/Trailing Spaces box is selected.

Click OK.

Converting Spaces Within Member Names
to Underscores

In some relational data sources, the names of information categories contain
spaces. Y ou may want to direct OLAP Integration Server to change these spaces
to underscores during the build of the Hyperion Essbase outline.

4-16 |

» To convert spaces to underscores:

1.

In the metaoutline, select the member level that contains names that include
spaces, for example, PRODUCT_GROUP_DESC contains names with
spaces, such as Root Beer.

Right-click the member level and, from the pop-up menu, select
Transformation to open the Edit OL AP M etaoutline Transfor mations
dialog box, shown in Figure 4-11.

If the Convert Spaces to Under scores box, ¥ Convert Spaces to Underscores |
is not selected, select it.

By default, the Convert Spacesto Under scor es box is selected.
Click OK.
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Attaching Prefixes and Suffixes to
Member Names
Y ou can direct OLAP Integration Server to attach a prefix or asuffix to amember

name. For example, you can attach the prefix SKU_ to al member namesin the
Product dimension.

Note: When attaching aprefix to amember name, make sure that you do not
use any of the following characters at the beginning of the name:

@ (atsign) () (parentheses)

\  (backslash) . (period)

{} (brace) +  (plussign)

., (comma) ! (single quotation mark)
- (dash, hyphen, or minus sign) _  (underscore)

= (equa sign) | (vertical bar)

< (lessthan sign) *  (double quotation mark)

» To attach a prefix or suffix to a member name:
1. Select the member level to attach the prefix or suffix to, for example, STATE.

2. Right-click the member level and, from the pop-up menu, select
Transformation to open the Edit OLAP Metaoutline Transfor mations
dialog box.

Y ou can also open the dialog box by selecting Edit > Transformation.
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3. Select the Prefix/Suffix tab.

Edit OLAP MetaoutlineTransformations - LOOKUP_PRODUCT.PRODUCT_ID

Feplace Prefis/Suffiz

* Mone

= Parent Mame

" Grandparent Name
= Al Ancestors' Names
= Dimenszion MNarme

Prefix Separator

= Caret[ "]
= Mo separator

Custom Prefix F'rewew Prefix
ISKU SKU_10
— Suffi Suffis Separator—————————————
i+ Mone [w] = Underscare [ _ ]
= Parent Mame [Y] = Pipe[l]
" Grandparent Name [£] = Caret[ "]
= Al Ancestors' Names * Mo separator
= Dimenszion Marme

Custom Suffis [¥] Freview Sufflx—‘

Freview Hesults...l QK I Cancel | Help |

Figure 4-12: Adding Prefixes or Suffixes

4. Decide whether to use the Prefix option group or the Suffix option group.

e Prefix attaches the selected value in front of the member name; for
example, SKU_100-10.

e Suffix attaches the selected value after the member name; for example,
100-10_SKU.
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5. InthePrefix option group or the Suffix option group, as appropriate, select
the source of the value that Hyperion Essbase attaches to the member namein
the Hyperion Essbase outline.

Some of the following examples are based on transforming the member
PRODUCT_ID of the Product dimension, as shown in the following sample
TBC Metaoutline:

Eﬁj Product
Em LOOKUP_PRODUCT.PRODUCT_GROUP_DESC
=-ff LOOKUP_PRODUCT PRODUCT_GROUP_ID

e None uses the metaoutline name as the Hyperion Essbase outline name.
Nothing is attached.

e Parent Name attaches the name of the immediate parent; for example,
selecting Parent Name in the Prefix option group and Pipein the Prefix
Separator option group changes Colas to Product|Colas.

Hyperion Essbase requires every member name to be unique. To satisfy
thisreguirement, you can prefix the name of every member with the name
of the parent value of the member. For example, if you store information
for two years, you have two members named Quarterl. By prefixing the
name of every member with the name of the parent of the member, you
produce unique member names such as 1997Quarterl and 1998Quarterl.

e Grandparent Name attaches the name of the grandparent; that is, the
name of the parent of the parent. Using PRODUCT _ID as an example,
selecting Grandpar ent Namein the Suffix option group and Car et inthe
Suffix Separator option group changes Colas to 100-10"Colas.

e All Ancestors Names attachesthe names of all higher level generations.
For example, selecting All Ancestors' Namesin the Prefix option group
and Under scoreinthe Prefix Separator option group changes 100-10to
Product_Colas 100 _100-10.

e Dimension Name attaches the dimension name. For example, selecting
Dimension Name in the Suffix option group and Caret in the Suffix
Separator option group changes Colas to Colas™Product.
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6.

Custom Prefix and Custom Suffix attach, respectively, the prefix or
suffix that you enter in the appropriate text box. For example, typing SKU
in the Custom Prefix text box and selecting Under scor e in the Prefix
Separator option group changes Colasto SKU_Colas.

Note: Do not use double quotation marks (") inthe Custom Pr efix
and Custom Suffix text box.

Custom Prefix and Custom Suffix combined with a Prefix option or a
Suffix option attach, respectively, the prefix or suffix that you enter inthe
appropriate text box and the selected prefix or suffix. For example, typing
SKU in the Custom Prefix text box, selecting Par ent in the Prefix
Separator option group, and selecting Under scor e in the Prefix
Separator option group changes Colas to Product SKU_Colas.

Note: Do not use double quotation marks (") inthe Custom Pr efix
and Custom Suffix text box.

In the Prefix Separator or Suffix Separator option group, select the
separator character to insert between the member name and the attached value.

Underscore| _] inserts an underscore between the affix and the member
name; for example, SKU_100-10.

Pipe[ | ] inserts a pipe between the affix and the member name;
for example, Product|100-10.

Caret ["] inserts a caret between the affix and the member name;
for example, Product*100-10.

No separator does not insert a character separator.

Click Preview Results to open the Preview Transformation Results dialog
box to preview your changes in a sample Hyperion Essbase outline.

See “Viewing Sample Dimensions, Members, and Hyperion Esshase
Outlines’ on page 3-30.

8. Click OK.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Chapter 4

Changing the Case of Member Names

Y ou can direct OLAP Integration Server to change the case of member names. For
example, you can change the member name JANUARY to January.

» To change the case of a member name:

1. Inthe metaoutline, select the member level for which you want to change the
case, for example, Month.

OLAP Integration Server changes the case of all member names that the
selected member level maps to in the Hyperion Essbase outline, for example,
January, February, and so on.

2. Right-click the member level and, from the pop-up menu, select
Transformation to open the Edit OL AP M etaoutline Transfor mations
dialog box.

Y ou can also open the dialog box by selecting Edit > Transformation.

Edit OLAP Metaoutline Transformations - Time.Month

Feplace | PrefisdSuffig

Search for —Case
I ' Driginal
_ " Upper Case
Replace with ' Lower Case
| ' Capitalize First Letters
™ Case Sensitive [C) — Space:
[T Match whale \wWard [w) V' Drop Leading/Trailing Spaces
¥ Beplace &l Dccurences (&) IV Corwert Spaces to Underscores
s EdiDea | Deee |
Search | Feplace | Conditions
1 Jan A
2 Feb &
3 Mar A
Freview Hesults...l QK | Cancel Help

Figure 4-13: Capitalizing Member Names
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3. From the Case group, select the case to change the member name to:

Original does not change the case.

Upper Case makes all letters of the member name uppercase, for
example, january to JANUARY or January to JANUARY.

L ower Case makes all letters of the member name lowercase, for
example, JANUARY to january or January to january.

Capitalize First L etters makes thefirst letter of the member name and
thefirst letter following a space or an underscore uppercase and makes all
subsequent letters lowercase, for example, gtrl_january or
QTR1_JANUARY to Qtrl_January.

4. Click Preview Results to open the Preview Transformation Results dialog
box to view your changesin a sample Hyperion Esshase outline.

See “Viewing Sample Dimensions, Members, and Hyperion Essbhase
Outlines’ on page 3-30.

5. Click OK.

Setting Load Properties for Members

This topic describes how to set load properties that determine the order in which
members are displayed in the Hyperion Essbase outline and the level to which
OLAP Integration Server builds the outline. This topic contains the following
subtopics:

e “Sorting Members’ on page 4-23
e “Setting the Member and Data Load Build Level” on page 4-25

4-22 1
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Sorting Members

You can set OLAP Integration Server to sort member names alphanumerically
within adimension. For example, you can sort all states in the Market dimension
from A to Z so that a United States Market dimension starts with Alabama and
ends with Wyoming.

Note: Therelational database performs the sort. Some sorts may not work
theway you intend. For example, if you sort a phabetically by month,
you get April, August, December, and so on. To sort months
chronologicaly, see “Replacing Parts of Member Names” on
page 4-13.

Note: If you sort members, they are sorted before OL AP Integration Server
applies any transformations to the member names.

» To sort the membersin adimension:

1. Inthemetaoutline, select the member level that you want to sort, for example,
MARKET.REGION.

2. Right-click the member level and, from the pop-up menu, select Filter to open
the Member Load Filtering dialog box.

Y ou can also open the dialog box by selecting Edit > Filter.
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4-24 1

3. Select the Ordering tab.

Member Load Filtering - LOODKUP_MARKET.REGION E
Filters ~ Ordering |
Sort Order:

IAscending - l

QK I Cancel Help

Figure 4-14: Setting Member Ordering

From the Sort Order drop-down list, select a sort order.

You can select Ascending (A to Z, 0to 9), Descending (Z to A, 9to 0), or
None. Noneisthe default value. Selecting Ascending or Descending, instead
of None, improves member load performance.

5. Click OK.
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Setting the Member and Data Load Build Level

By default, when OLAP Integration Server creates a Hyperion Essbase outline, it
loads all member levels specified in the metaoutline. Y ou can, however, set OLAP
Integration Server to build only to a specified level. Building down to a specified
level produces asmaller Hyperion Essbase outline that contains less data. Smaller
outlines can be useful for users with limited disk space who do not need to see the
lowest level of detail.

For example, if the Market dimension in the metaoutline contains three levels—
REGION, STATE, and CITY, the Market dimension of the default Hyperion
Essbase outline contains three levels, as shown in Figure 4-15.

Iarket
REGION member — = entral

5 [~ Colorade

Aspen +———

STATE members — Derver +——

. Grand Junction +—
== [~]llinois

L [Jchicago

— CITY members

Figure 4-15: Members of the Market Dimension

If you set OLAP Integration Server to build only to the STATE member level,
none of the CITY members are displayed in the Hyperion Essbase outline, as
shown in Figure 4-16.

harket
REGION member — = entral

Caolarada
STATE mermbers —:—:Hlllinois

Figure 4-16: Reduced Number of Levels

Likewise, when you load data into the Hyperion Essbase outline, OLAP
Integration Server loads the measures only down to the specified build level.
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» To specify abuild level:

1.

In the metaoutline, select the member level that you want to use as the lowest
level member (leaf member), for example, STATE.

Right-click the member level and, from the pop-up menu, select Build down
to here.

In the pop-up menu, next to Build down to here, a check is displayed. In the
metaoutline, for all member levelsthat lie below the specified level, ared X
isdisplayed. During member and dataloads, OL AP Integration Server setsthe
specified member level (the member level with acheck) asthelevel 0 member
(that is, as the leaf member).

Eﬁj Market
Em LOOKUP_MARKET REGION
=-FB LOOKUP_MARKET STATE

Figure 4-17: Build Down to Here

Note: Setting the Build down to here function on alevel 0 member has
no effect. OLAP Integration Server builds down to level 0 by
defaullt.

Setting Load Properties for Measures

This topic describes how to set |oad properties for measures, including how to
change a measure, how to reverse the sign of ameasure, and how to change the
column that a measure is associated with. This topic contains the following
subtopics:

4-26 W

“Scaling Measures’ on page 4-27
“Reversing Measure Signs’ on page 4-28
“Changing the Column Associated with aMeasure” on page 4-29
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Scaling Measures

Y ou can direct OLAP I ntegration Server to scale measures (dataval ues) asit loads
them into the Hyperion Essbase database. For example, you may want to scale a
measureif the valuesin the data source and the valuesin the database use different
types of measurement, such as when the data source tracks sales in hundreds but
the Hyperion Essbase database tracks sales in units. In this case, you want to
multiply incoming values by 100.

» To scale an incoming measure:
1. Inthe metaoutline, select ameasure, for example, SALES.

2. From the pop-up menu, select Transformation to open the Measure
Properties dialog box.

Y ou can a'so open the dialog box by selecting Edit > Transformation.

Measure Properties E
Generall Filters ~ Transformations |
Scaling
Operator:
| (Muttiplication) =l

Walue:

['d

" Flip Sign

QK I Cancel Help

Figure 4-18: Scaling Measures

3. Fromthe Operator drop-down list, select the operator to use for scaling the
incoming measure; for example, * (Multiplication).

4. IntheValuetext box, enter the value to use; for example, type 10 to multiply
the incoming value by 10.

5. Click OK.

OLAP Integration Server scales the measures and loads the scaled valuesinto
the Hyperion Essbase database.
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Reversing Measure Signs

You can direct OLAP Integration Server to reverse the sign of ameasure (from
positiveto negative or vice versa). For example, the data source can track expenses
as negative numbers, but you can track them as positive numbersin the Hyperion
Essbase database.

» Toflip (reverse) the sign of an incoming measure:

1. Inthe metaoutline, select the measure to flip, for example, Expenses.

2. From the pop-up menu, select Transformation to open the Transformation
tab of the M easur e Properties dialog box.

Y ou can also open the tab by selecting Edit > Transformation.

Generall Filters ~ Transformations |
Scaling
Operator: |<N0ne> j
Walue: I

QK I Cancel Help

Figure 4-19: Reversing Signs for Measures

Select the Flip Sign box.
4. Click OK.

If you later decide to load values into the measure without reversing the sign,
deselect the Flip Sign box.
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Changing the Column Associated
with a Measure

When datais |loaded into a Hyperion Essbase database, every measurein
the related metaoutline retrieves its data values from the relational data
column with which it is associated. For example, assume that you have a
SALESINVACT.PRICE column in therelationa data source. The column
contains all pricesfor all products. The related OLAP model contains the
SALESINVACT.PRICE columninitsfact table. Whenyou createa PRICE
measure in the metaoutline, the Price measure is based on the
SALESINVACT.PRICE column of the relational data source.

Whenyouload data into the Hyperion Essbase database, OL AP Integration Server
retrievesthe datavaluesfor price from the SALESINVACT.PRICE column of the
relational data source and loads the retrieved val ues into the Price measure of the
Hyperion Essbase outline.

If the default column that is associated with a measure is not correct, you can
change the column.

» To change the column with which ameasure is associated:
1. Inthe metaoutline, select ameasure, for example, SALES.

2. Right-click the measure and, from the pop-up menu, select Filter or
Transformation to open the M easur e Properties dialog box.
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3. Select the General tab.

Measure Properties E

General | Filters I Transformationsl

QK I Cancel | Help |

Figure 4-20: Changing the Column Associated with a Measure

4. From the Database Propertieslist, select the desired column.
5. Click OK.
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This chapter describes how you set afilter on a member level and on a measure.
A filter determines what members or what data values OLAP Integration Server
loads from the external data source into the Hyperion Esshase database.

Note: A change that you make to afilter for amember level or ameasure
does not affect the Hyperion Essbase database until you perform a
member or dataload.

This chapter contains the following topics:

e “Understanding the Metaoutline Workflow” on page 5-2

e “About Filters’ on page 5-3

e ‘“Filteringin an OLAP Model or in a Metaoutling” on page 5-8
e “Working with Metaoutline Filters” on page 5-8

e “Creating aMember Filter Interactively” on page 5-13

e “Typing a Member Filter” on page 5-17

e “Creating aMeasure Filter Interactively” on page 5-18

e “Typing aMeasure Filter” on page 5-22

For information about setting other properties, see Chapter 4, “ Setting Load
Properties’ and Chapter 6, “ Setting Hyperion Essbase Properties.”
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Understanding the Metaoutline Workflow

Figure 5-1 illustrates the workflow for creating a metaoutline and for using
the metaoutline to create and load members and data into a Hyperion Esshase
database. This workflow includes the following processes:

e Creating and working with a metaoutline

e Adding dimensions, member levels, and measures to a metaoutline

e Setting load properties, filters, and Hyperion Essbase properties on
dimensions, member levels, and measures in a metaoutline

e Loading dimensions and members from the metaoutline into a Hyperion
Essbase outline

e Loading the data specified in the metaoutline into a Hyperion Essbase
database

This chapter focuses on setting filters. You can set filters before or after setting
load properties and Hyperion Essbase properties.

Crecting ang

wiorking with
I\

metaoutlines 5 B THC_MODEL

G- B MARKETS
B-Ef SCENARID

- [

Bl & Market
: : : MARKET REGION
Adding dimensions, member o % %asures
levels, and measures to a O Profit
metacutline o Ratios

@ Setting load properties, L Load Properties
filters, and Hyperion Filters

. Hyperion Essbase Properties
You Are Here ESsbase properties P - P

Loading dimensions

and members 33 ab

Loading data

Figure 5-1: Metaoutline Workflow
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About Filters

Y ou can filter members and data values when you load members and data values
into a Hyperion Essbase outline. For example, assume that an OLAP model
contains data for 1996 and 1997.

If you want to create a Hyperion Essbase outline that tracks the 1996 data, you
create afilter that |oads only the members related to 1996.

Any filter that you create becomes part of an automatically generated SQL
WHERE clause. For example, if you create the 1996 filter (described in the
previous paragraph) on TBC Metaoutline, the filter produces the following
WHERE clause:

SELECT DISTINCT a.YEAR
FROM hyperion.TIMESEASONS a
WHERE (a.YEAR IN (’1996'))

Note: You can also filter datain an OLAP model. See the Hyperion
Integration Server Desktop OLAP Model User’s Guide.

Y ou can createfilters on one or more member levels or measures of ametaoutline.
All filters defined on member levels and measures in a metaoutline are stored in
one or more metaoutline filters.

Metaoutline Filter

Member

Filter Member
Filter

IWeasure
Filter

Figure 5-2: Contents of a Metaoutline Filter
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About Metaoutline Filters

5-4 H

OLAP Integration Server automatically stores all member level and all measure
filtersin ametaoutline filter named * Default. Y ou can, however, create one or
more additional metaoutline filters and define a specific set of member level and
measure filtersto each filter. Then you can select a particular metaoutlinefilter to
determine what OLAP Integration Server loads into the Hyperion Essbase
database.

Defining multiple metaoutline filters enables you to create multiple Hyperion
Esshase databases from a single metaoutline—just select a different metaoutline
filter before performing the member and data load. See “ Selecting a Metaoutline
Filter” on page 5-8.

OLAP Integration Server loads into the Hyperion Essbase database only the
members and the data values that are specified by the metaoutline filter. For
example, you can create a metaoutline filter for each year—a 96 DATALOAD
filter and a97 DATALOAD filter. Then you can select the 96 DATALOAD filter
and build a Hyperion Essbase database that tracks only information for 1996, as
illustrated in Figure 5-3. Likewise, you can select the 97 DATALOAD filter and
build a Hyperion Esshase database that tracks only information for 1997.
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* . Hyperion Integration Server Desktop - [TBC_METAOUTLINE] [ |O] x|

File Edit “iew Connections Outline Tool: ‘Window Help ;Iilll
SH S| |
I"Default j| W= W Wx

Filter

Item Predicate Cloze I
FDE EEEIGREIEY SCENARIDYEAR IM (199,
Help | TBE

SCEMARIO.YEAR N [1936" ﬂ

Load
Highlighted
Iterm

l Filter and Build Information

Specific to 1996 Scenario
-

~1996 Scenario

Sample "1996 Scenario”
Hyperion Essbase Database

Figure 5-3: Metaoutline Filter Example
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About Member Filters

A member filter is applied to member names asthe member names areloaded from
the external data source into the Hyperion Essbase database.

Member Filter

Year= 1996

Figure 5-4: Member Filter Example

Y ou can create arow filter on amember name.

OLAP Integration Server appliesthe row filter to each row. The filter isbased on
amember name. For example, if you filter out al yearsthat are not 1996, OLAP
Integration Server loads the 1996 values but not the values from other years, such
as 1997.

Note: If you are creating afilter on a shared member, see “Handling
Duplicate Member Names’ on page 4-6.

When creating a member filter, keep the following guidelines in mind:
e You cannot use substitution variablesin afilter.

e When you type thefilter syntax, you can use the pattern-matching characters
that are supported by the relational database management system (RDBMS)
that you are using.

e If youdefineafilter onamember that you expect to be shared, you must define
the same filter on each shared member.

e If you define afilter on arecursive dimension, see “ Creating Recursive
Dimensions’ on page 3-17.
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About Measure Filters

A measure filter is applied to data values as the data values are loaded from the
external data source to the Hyperion Essbase database. For example, if you specify
afilter to load only SALES measures that have an aggregate value greater than
1000, OLAP Integration Server does not load into the Sales member of the
Hyperion Esshase database any data values that have an aggregate value equal to
or lessthan 1000. If no data value meets thefiltering condition, OLAP Integration
Server loads avalue of #MISSING into the Hyperion Essbase database.

Measure Filter

SALES = 1000

Figure 5-5: Measure Filter Example

Note: If you are creating afilter on a shared member, see “Handling
Duplicate Member Names’ on page 4-6.

When creating a measure filter, keep the following guidelinesin mind:
e You cannot use substitution variablesin afilter.

e When you type thefilter syntax, you can use the pattern-matching characters
supported by the RDBMS.
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Filtering in an OLAP Model or in a Metaoutline

Y ou can filter out unwanted datain an OLAP model or in ametaoutline. In
general, you should create high-level filtersin an OLAP model and more specific
filtersin ametaoutline.

Create afilter in an OLAP model to prevent data from appearing in either the
OLAP model or the metaoutline; for example, you might want to create an OLAP
model that includes only the last two years of data even though the related
warehouse contains five years of history. See the Hyperion Integration Server
Desktop OLAP Model User’s Guide.

Create filtersin ametaoutline to create specific Hyperion Essbase databases
(for example, apply a member filter to view the data for 1998) or to customize
aHyperion Esshase database for a certain set of users (for example, filter out
everything but sales and inventory).

Working with Metaoutline Filters

This topic describes how to use metaoutline filters. It contains the following
subtopics:

e “Selecting a Metaoutline Filter” on page 5-8
e “Creating a Metaoutline Filter” on page 5-10
e “Viewing the Contents of a Metaoutline Filter” on page 5-11
e “Deéleting aMetaoutline Filter” on page 5-12

Selecting a Metaoutline Filter

The currently selected metaoutline filter is the metaoutline filter to which OLAP
Integration Server adds new member and measurefilters and the metaoutlinefilter
that is used for member and data loads.
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The name of the currently selected metaoutline filter is displayed at the top of the
metaoutline filter drop-down list. The metaoutline filter drop-down list contains
the * Default filter, plus any metaoutline filters that you have created. If you have
not created any metaoutline filters, the only filter that you can select is* Default.
» To select ametaoutline filter:
1. Open the metaoutline.
See “Creating or Editing Metaoutlines’ on page 2-4.

2. Inthe OLAP Metaoutline main window, from the drop-down list, select a
filter, as shown in Figure 5-6.

“ . Hyperion OLAFP Builder - [TBC_METAOUTLINE] =1 E3
Eile Edit Wiew Servers Outine Toolz ‘Window Help _|ﬁ||1|
 DEE S ER =t 52N
Metaoutline
filters | Detaut = = w o

TBC_METAOUTLINE

56 DATALDAD %) SCEMARIO

97 DATALOAD
- ™ CHANHEL PRODUCTS
- MARKETS : PACKAGE
-4 PACKAGE -9 MARKETS
-4 PRODUCTS %) ACCOUNTS
-4 SCENARID -9 TIME
-4 TIME -4 CHANNEL
OL&P_TBC
Faor Help, press F1 |DLAF'_MD i

Figure 5-6: Setting a Metaoutline Filter

If no filter other than * Default is listed, you may want to define afilter. See
“Creating a Metaoutline Filter” on page 5-10.
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Creating a Metaoutline Filter

A metaoutline filter contains all member level and measure filters that are defined
whileit is selected. See“ About Metaoutline Filters’ on page 5-4.

When you create a new metaoutline filter, it inherits the member and measure
filters that are defined in the * Default metaoutline filter.
» To create a new metaoutline filter:
1. Open the metaoutline.
See “Creating or Editing Metaoutlines’ on page 2-4.

2. Click the Add Filter button, H

The Enter the new filter’sname dialog box, in which you can name the new
filter, is displayed.

Enter the new filter's name E

|95 DATALOAD]

QK I Cancel | Help |

Figure 5-7: Creating a New Metaoutline Filter

3. Typethe name of the new filter, for example, 96 Dataload.

See “About Naming” on page 3-9.
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4. Click OK.
OLAP Integration Server creates a new metaoutline filter and setsit asthe
current filter.
* . Hyperion Integration Server Desktop - [TBC Metaoutline] M= 3
File Edit “iew Connections Outine Toolz ‘Window Help _|ﬁ||1|
- e
Current DEH|S[w s[4
fitter 3 D afaioad 7] v
=1 TBC Model =~ E3 TBC Metacutline
- Vear - Year
B Accounts B Measures
B Market B Product
-Ef Product -5 Market
-Ef Scenario -Ef Scenario
2 | ™
| Data Source: TEC
Faor Help, press F1 |DLAF' Catalog: tbe_md i

Figure 5-8: Viewing the Current Filter Name

5. Inthe metaoutline, create member and measure filters.

See “ Creating a Member Filter Interactively” on page 5-13 and “Creating a

Measure Filter Interactively” on page 5-18.

Viewing the Contents of a Metaoutline Filter

Y ou can view all member and measure filters that are defined in the current

metaoutline filter.

» To view the contents of the current metaoutline filter:
1. Openthe metaoutline.

See “Creating or Editing Metaoutlines” on page 2-4.
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2. Click the View Filter button, ﬂ

TheView Filter dialog box isdisplayed. The diaog box lists all member and
measure filters that are defined in the current metaoutline filter.

Yiew Filter: 96 Dataload E
| Fredicate | Cloze I
TimeY'ear in [1996)
Help |

Time.Year in [1335) =]

-]

Figure 5-9: Viewing the Contents of the Current Metaoutline Filter

3. To view the conditions defined for a specific filter, select the filter, for
example, Time.Quarter.

The filter conditions are displayed in the bottom box.

4. When you finish viewing the filters, click Close.

Deleting a Metaoutline Filter

» To delete ametaoutline filter:
1. Open the metaoutline.
See “Creating or Editing Metaoutlines’ on page 2-4.
2. From thefilter drop-down list, select the filter to delete.
See “ Selecting a Metaoutline Filter” on page 5-8.
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3. Click the Delete Filter button, )
A dialog box prompts you to confirm deleting the filter.
4. Click Yes.

Creating a Member Filter Interactively

Y ou can select the parts of amember filter interactively from list boxes and dialog
boxes or you can type amember filter. This topic describes how to create a
member filter interactively. Totypeamember filter, see” Typing aMember Filter”
on page 5-17.

» To create amember filter interactively:

1. Inthe metaoutline, select the member level to attach to thefilter, for example,
MARKET.STATE.

2. Tocreatearow filter, right-click the member level and, from the pop-up menu,
select Filter to display the Member Load Filtering dialog box.

3. Select theFilterstab.

Member Load Filtering - LOOKUP_MARKET STATE E
Filters |Drdering|
Colurnm: Operator: Condition:
[sTatE =i =l
Add Type————
Add C And Werify |
& O —
Filters:
Freview Results... |
QK | Cancel | Help |

Figure 5-10: Setting a Member Load Filter Interactively
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4. From the Column drop-down list, select the column to which the condition
applies, for example, STATE.

5. From the Operator drop-down list, select the operator to use.

Table 5-1: Filter Operators

Operator Description

in Setting one or more condition. For example, REGION in
UNITED STATES or EUROPE selects both the UNITED
STATES and EURORPE regions.

not in Opposite of in. For example, REGION not in UNITED STATES
selects al regions except for the regions that are part of the
United States.

like Looking for similar characters. For example, if you want to select
all products that begin with P and do not want to specify other
characters of the product name, you can set the condition like"P"
(Different RDBM Ss may use different wildcards).

not like Opposite of 1ike. Selects conditions that exclude similar
characters.

= Equal to.

<> Not equal to.

> Greater than.

>= Greater than or equal to.

< Lessthan.

<= Less than or equal to.
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6. To enter acondition in the Condition text box, type the condition, for
example, 1996, or complete the following three steps:

a. To openthe Select Values From dialog box, click the _| button.

The Select Values From dialog box lists all possible values for the
selected column. OL AP Integration Server retrievesthelisted valuesfrom
the external data source. If the external data source contains many values,
adialog box is displayed. The dialog box asksif you want to view all

values.

Select ¥alues From LOOKUP_MARKET.STATE. E
Walue - ] I
Alazka
Alizoha Cancel |
Arkanzaz
Califorria Help |
Calorado
Connecticut
Florida
Georgia
Hawaii
Idaha
llinois
Indiana —
lowa
Karsas
Loviziana
Maine
Maszachusetts
Michigan
Minnesata
Miszouri
Mortana
M Carnlina i
il | _>l_I

Figure 5-11: Setting Values for Conditions

b. Select the desired value (such as California).
To select multiple values, hold down the Ctrl key and select each value.

Y ou can select more than one value only if you have selected in or
not in asthe operator. For a description of all operators, see Table 5-1.

c. Click OK.
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7. IntheMember Load Filtering dialog box, click Add to add the condition to
the Filterslist.

8. If you want to define an additional condition, do the following:
a. Repeat steps5 through 7.
b. Do one of thefollowing:

e |If youwant thefilter to apply when any one of thelisted conditionsis
met, in the Add Type box, select Or. Or isthe default.

e If youwant thefilter to apply only if al thelisted conditions are met,
in the Add Type box, select And.

e If you want to define the order in which the relational data source
executes the multiple conditions, in the Filter s box, enclose the
conditions in parentheses.

How you define ordering depends on the relational data source. Consullt
the documentation for the relational data source.

9. If you want to edit afilter, do the following:
a. Usethe SQL syntax required by the relational data source.

b. Inthe Member Load Filtering dialog box, click Verify to check the
SQL syntax.
10. Click Preview Results to open the Preview Filter Results dialog box.

Inthe Preview Filter Results dialog box, you can view your changesin a
sample Hyperion Essbase outline. See “Viewing Sample Dimensions,
Members, and Hyperion Essbase Outlines’ on page 3-30.

11. Click OK.
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Typing a Member Filter

Y ou can type amember filter or select the parts of a member filter interactively
from list boxes and dial og boxes. Thistopic describes how to type amember filter.
To create amember filter interactively, see “ Creating a Member Filter
Interactively” on page 5-13.

» To type amember filter:

1. Inthe metaoutline, select the member level to attach to thefilter, for example,
MARKET.STATE.

2. Tocreatearow filter, right-click the member level and, from the pop-up menu,
select Filter.

The Member L oad Filtering dialog box is displayed.
3. Select the Filterstab.

Member Load Filtering - LOOKUP_MARKET STATE E

Filters |Drdering|

Colurnm: Operator: Condition:

[sTatE =i =l

Add Type
Add C And Werify |
Filters:
Freview Results... |
QK | Cancel | Help |

Figure 5-12: Typing a Member Load Filter
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4. Toenter afilter, in the Filter sbox, type thefilter information according to the
following syntax:

TableName.ColumnName Operator Condition
For example, arow filter might be as follows:
LOOKUP_MARKET.STATE in (’California’)
For alist of valid operators, see the documentation for the data source.
5. Click Verify to check the SQL syntax.
6. If you want to define an additional condition on thefilter, do the following:
a. Repeat steps4 and 5.

b. Review step 8b of the previous procedure, “ Creating a Member Filter
Interactively” on page 5-13, and complete the steps appropriate to your
situation.

7. Click Preview Results to open the Preview Filter Results dialog box.

Inthe Preview Filter Results dialog box, you can view your changesin a
sample Hyperion Essbase outline. See “Viewing Sample Dimensions,
Members, and Hyperion Essbase Outlines’ on page 3-30.

8. Click OK.

Creating a Measure Filter Interactively

Y ou can interactively select the parts of ameasurefilter from list boxesand dialog
boxes or you can type a measure filter. This topic describes how to create a
measure filter interactively. To type a measure filter, see“ Typing a Measure
Filter” on page 5-22.

» To create ameasure filter interactively:

1. Inthe metaoutline, select the measure to apply to the filter, for example,
SALES.

2. Right-click the measure and, from the pop-up menu, select Filter.

The Measure Properties dialog box is displayed.

5-18 W Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



3. Select theFilterstab.

Measure Properties

[ ]
General  Filters | Transformationsl
Colurnm: Operator: Condition:
[seies G 5 —
Add Type————
Add C And Werify |
& O —
Filters:
SALESINVACT SALES » 1000 ;I

Preview Hesults...l

QK I Cancel | Help

Figure 5-13: Creating a Measure Filter Interactively
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4. From the Column drop-down list, select the column to which the condition
applies, for example, SALES.

5. From the Operator drop-down list, select the operator to use.

For adescription of all operators, see Table 5-1.
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6. To enter acondition, in the Condition text box, type the condition, for
example, 1000, or complete the following steps:

a. Clickthe _l button to open the Select Values From dialog box.

The Select Values From dialog box lists all possible values for the
selected column. OLAP Integration Server retrieves the values from the
external data source. If the external data source contains many values, a
dialog is displayed. The dialog box asksif you want to view them all.

Select Yalues From SALESINVACT SALES E
Walue B ok
50 — —I
£.0343052148177
E£.0686970231805
E.2881755832956 Help |
7.0
80
9.0639266525489
9.6034050721918
9.6274851604206
9.8128441858461
10.0
10.044907 274561
10.046605049627
10.100822091578
10.260039372708
10.277253993521
10.393762783156
1.0
12102683161414
12.662655255593
13.513767360092
1 1 n LIH
[l | [»

Figure 5-14: Setting Values for Conditions

b. Select the desired value (such as 1000).
To select multiple values, hold down the Ctrl key asyou select each value.

Y ou can select more than one value only if you have selected in or
not in asthe operator. For a description of all operators, see Table 5-1.

c. Click OK.
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7. IntheMeasure Properties dialog box, click Add to add the condition to the
Filterslist.

8. To define an additional condition on the filter, do the following:
a. Repeat steps5 through 7.
b. Do one of the following:

e If youwant thefilter to apply when any one of thelisted conditionsis
met, in the Add Type box, select Or. Or isthe default.

e If youwant thefilter to apply only if al thelisted conditions are met,
in the Add Type box, select And.

e If you want to define the order in which the relational data source
executes the multiple conditions, in the Filter s box, enclose the
conditions in parentheses.

How you define ordering depends on the relational data source. Consullt
the documentation for the relational data source.

9. If you want to edit afilter, do the following:
a. Usethe SQL syntax required by the relational data source.
b. Click Verify to check the SQL syntax.
10. Click Preview Results to open the Preview Filter Results dialog box.

Inthe Preview Filter Results dialog box, you can view your changesin a
sample Hyperion Essbase outline. See “Viewing Sample Dimensions,
Members, and Hyperion Essbase Outlines’ on page 3-30.

11. Click OK.
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Typing a Measure Filter

Y ou can type ameasure filter or select the parts of a measure filter interactively
from list boxes and dialog boxes. Thistopic describes how to type ameasurefilter.
To create ameasure filter interactively, see* Creating a Measure Filter
Interactively” on page 5-18.

» To type ameasure filter:
1. Select the measure to apply to the filter, for example, SALES.
2. Right-click the measure and, from the pop-up menu, select Filter.

The Measure Properties dialog box is displayed.
3. Select the Filterstab.

Measure Properties E

General  Filters | Transformations I

Colurnm: Operator: Condition:

[seies G 5 —
Add Type————

Add C And Werify |

& O —

Filters:

SALESINVACT SALES » 1000 ;I

Preview Hesults...l

QK I Cancel | Help |

Figure 5-15: Typing a Measure Filter
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4. Inthe Filtersbox, type thefilter information according to the following
syntax:

TableName.ColumnName Operator Condition

For example, type the following:

SALESINVACT.SALES > 1000

For alist of valid operators, see the documentation for the data source.
5. Click Verify to check the SQL syntax.
6. To definean additional condition on the filter, do the following:

a. Repeat steps4 and 5.

b. Do one of the following:

e |If youwant thefilter to apply when any one of thelisted conditionsis
met, in the Add Type box, select Or. Or isthe default.

e If youwant thefilter to apply only if al thelisted conditions are met,
in the Add Type box, select And.

e If you want to define the order in which the relational data source
executes the multiple conditions, in the Filter s box, enclose the
conditions in parentheses.

How you define ordering depends on the relational data source. Consullt
the documentation for the relational data source.

7. Click Preview Resultsto open the Preview Filter Results dialog box.

Inthe Preview Filter Results dialog box, you can view your changesin a
sample Hyperion Essbase outline. See “Viewing Sample Dimensions,
Members, and Hyperion Essbase Outlines’ on page 3-30.

8. Click OK.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide B 5-23



Chapter 5

5-24 A Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Setting Hyperion Essbase
Properties

Hyperion Integration Server enables you to set the properties of the dimensions
and members of a Hyperion Esshase outline; for example, you can determine how
members consolidate into adimension. Changes that you maketo the properties of
dimensions, members, and measures do not affect the Hyperion Essbase database
until you perform a member or data load.

Note: You cannot use the member levels of a metaoutline to create
partitions.

This chapter describes the Hyperion Essbase properties that you can set and
outlines the methods that you use to set them. For more detailed descriptions and
examples of Hyperion Essbase properties, see the Hyperion Essbase Database
Administrator’s Guide.

This chapter contains the following topics:

e “Understanding the Metaoutline Workflow” on page 6-2

e “Specifying Dimension and Member Properties’ on page 6-3

e “Specifying Account Properties’ on page 6-17

e “Specifying UDAS’ on page 6-23

e “Specifying Formulas’ on page 6-25

e “Viewing Hyperion Essbase Properties’ on page 6-27

Note: For information about setting load properties, see Chapter 4, “ Setting

Load Properties.” For information about setting filters, see Chapter 5,
“Working with Filters.”

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide H 6-1



Chapter 6

Understanding the Metaoutline Workflow

Figure 6-1 illustrates the workflow for creating a metaoutline and using the
metaoutline to create and load members and data into a Hyperion Essbase
database. This workflow includes the following processes:

6-2 |

Creating and working with a metaoutline

Adding dimensions, member levels, and measures to a metaoutline

Setting load properties, filters, and Hyperion Essbase properties on
dimensions, member levels, and measures in a metaoutline

L oading dimensions and members from the metaoutline into a Hyperion
Essbase outline

Loading the data specified in the metaoutline into a Hyperion Essbase

database

This chapter focuses on setting Hyperion Essbase properties. Y ou can set
Hyperion Esshase properties before or after setting load properties and filters.

L5

Creating and
wiorking with
metaoutlines

Bl & Market
: : : MARKET REGION
Adding dimensions, member o % %asures
levels, and measures to a O Profit
metacutline o Ratios

E-E9 TEC_MODEL
B MARKETS
B~ SCENARID
\ Z

Setting load properties, L Load Properties
; Filters
filters, and Hyperjlon Hyperion Esshase Properties
You Are Here ESsbase properties -

Loading dimensions

and members 33 ab

Loading data

Figure 6-1: Metaoutline Workflow
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Specifying Dimension and Member Properties

This topic describes how to set Hyperion Essbase properties for dimensions and
for member levels. It contains the following subtopics:

e “About Dimension Types’ on page 6-3

e “SettingaDimension Type” on page 6-5

e “Specifying Dimension Storage Properties’ on page 6-6

e “Specifying Data Storage Properties for Dimensions and Members’ on
page 6-8

e “Setting Aliases for Dimensions and Members’ on page 6-10

e “Specifying Two-Pass Calculation on Dimensions and Members’ on
page 6-12

e “Specifying Member Consolidation Properties” on page 6-14

e “Setting Members as Dynamic Time Series” on page 6-16

Note: You cannot use the member levels of a metaoutline to create
partitions.

About Dimension Types

When you tag adimension as aspecific Hyperion Essbase type, the dimension can
access the built-in functionality that is designed for that type. For example, if you
define a dimension as type accounts, you can specify accounting operations for
the member levels of the dimension. By default, OLAP Integration Server tags
dimensions tagged as time or accounts in the OLAP model as time or accountsin
the metaoutline. OLAP Integration Server tags all other dimensions as standard.

Note: Naming adimension time or accounts does not automatically tag the
dimension as type time or type accounts.

M easures values map to the accounts dimension in the OLAP model,

which maps to the measure dimension in the metaoutline, which in
turn maps to the accounts dimension in the Hyperion Essbase outline.
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Table 6-1 describes each dimension type.

Table 6-1: Dimension Types

Type

Description

standard

The dimension has no special type.

accounts

Containsitems that you want to measure, such as profit or inventory.
The dimension tagged as measure in a metaoutline corresponds to the
dimension tagged as accounts in the related Hyperion Essbase
database.

Follow these rules when tagging a measure (accounts) dimensionin a
metaoutline;

* You can tag only one dimension in a metaoutline as measure
(accounts).

» When you tag a dimension as measure (accounts), all membersin
the dimension inherit the accounts property.

* Y ou can create ametaoutline that does not have adimension tagged
as measure (accounts).

» Hyperion Esshase calculates the dimension tagged as time and the
dimension tagged as accounts before it cal cul ates other dimensions
in the database. For more information on calculation, see the
Hyperion Essbase Database Administrator’s Guide.

 To calculate members of the dimension tagged as accounts on the
second pass through the Hyperion Essbase outline, see “ Specifying
Two-Pass Calculation on Dimensions and Members’ on page 6-12.
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Table 6-1: Dimension Types (Continued)

Type Description

time Describes how often you collect and update data. The dimension
tagged as time enables several accounts dimension functions, such as
first time balance and last time balance.

Follow these rules when tagging a time dimension in a metaoutline:

 You can tag only one dimension in a metaoutline as time.

* When you tag a dimension astime, all membersin the dimension
inherit the time property.

* You can create multiple hierarchies inside the dimension tagged as

time; for example, you can specify a'Y ear, Quarter, Month
hierarchy and a'Y ear, Season hierarchy in the same time dimension.

* You can create ametaoutline that does not have adimension tagged
astime.

* You can add time membersto adimension that is not tagged astime.

» Hyperion Essbase cal culates the dimension tagged as time and the
dimension tagged as accounts before it cal cul ates other dimensions
in the database. For more information on calculation, see the
Hyperion Essbase Database Administrator’s Guide.

 To calculate members of the dimension tagged as time on the
second pass through the Hyperion Essbase outline, see “ Specifying
Two-Pass Calculation on Dimensions and Members® on page 6-12.

Setting a Dimension Type
Y ou can determine whether a dimension is tagged as standard, accounts, or time
by setting its dimension type.
» To set adimension type:

1. Inthe metaoutline, select the dimension for which you want to set the
dimension type.

2. Right-click the dimension and, from the pop-up menu, select Propertiesto
open the Dimension Properties dialog box.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.
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3. Select the Member Info tab.

5.

Dimension Properties - Measures E

General Member Info |Account|nfo| UDAs I Formulal

Alias:

— Dimension Type
' Standard
& Accounts
C Time

[T Two Pass Calculation

[rata Storage
" Store Data
' Dynamic Calc &nd Store
" Dynamic Calc

' Mever Share
& Label Only
— Dimension Storage
& Dense
" Sparze
QK I Cancel | Help

Figure 6-2: Setting a Dimension Type

From the Dimension Type group, select the type of dimension.

For more information about dimension types, see Table 6-1 and the Hyperion
Essbase Database Administrator’s Guide.

Click OK.

Specifying Dimension Storage Properties

Y ou can determine whether adimension is stored as sparse or dense.

6-6 B

Use sparse storage for a dimension in which alow percentage of available
datapositionsisfilled. For example, the sample application TBC Metaoutline
includes the Product and Market dimensions. Product represents product units
and Market represents geographical regions in which products are sold.
Because not every product is sold in every market, Product and Market are
sparse dimensions.

Use dense storage for adimension in which a high percentage of available
data positions are filled. For example, in the sample application TBC
Metaoutline, time data exists for almost all productsin al markets, so
Year is adense dimension.
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For more information about dimension storage properties, see the Hyperion
Essbase Database Administrator’s Guide.

Note: Inametaoutline, you must tag at least one dimension as dense and
one dimension as sparse.
» To set adimension storage property:
1. Inthe metaoutline, select adimension, for example, Measures.

2. Right-click the dimension and, from the pop-up menu, select Propertiesto
open the Dimension Properties diaog box.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

3. Select the Member Info tab.

Dimension Properties - Measures E
General Member Info |Account|nfo| UDAs I Formulal
Alias:
— Dimension Type .
" Standard I Two Pass Calculation
& Accounts [rata Storage
C Time " Store Data

' Dynamic Calc &nd Store
" Dynamic Calc

' Mever Share
& Label Only
— Dimension Storage
& Dense
" Sparze

QK I Cancel | Help

Figure 6-3: Setting Dense or Sparse Dimensions

4. Fromthe Dimension Storage group, select Dense or Spar se.
5. Click OK.
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Specifying Data Storage Properties for

Dimensions and Members
Y ou can determine how and when Hyperion Essbase stores data values for a
dimension and for a member. For example, you can tell Hyperion Essbase to

calculate the value for amember only when a user requestsit and then to discard
the value. Table 6-2 identifies and describes each storage property.

Table 6-2: Data Storage Properties

Property Description

Store data Stores the data val ue with the member. This property isthe
default.

Dynamic Calc Calculates the data value when a user requests it and then

And Store stores the data value.

Dynamic Calc Calculates the data value when a user requests it and then
discards the data value.

Never share Does not alow members to be shared implicitly.

Label only Createsamember that is used only for navigation. A label only
member contains no data value.

» To set adata storage property:

1. Inthe metaoutline, select adimension or amember level, for example,
Measures.

2. Right-click the dimension or the member level and, from the pop-up menu,
select Properties to open the Dimension Properties or M easure Properties
dialog box.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.
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3. Select the Member Info tab.

Dimension Properties - Measures E
General Member Info |Account|nfo| UDAs I Formulal
Alias:
— Dimension Type .
" Standard I Two Pass Calculation
& Accounts [rata Storage
C Time " Store Data

' Dynamic Calc &nd Store
" Dynamic Calc

' Mever Share
& Label Only
— Dimension Storage
& Dense
" Sparze

QK I Cancel | Help

Figure 6-4: Setting Storage Properties

4. From the Data Storage group, select the kind of storage to use.

Note: Do not set adimension or member as shared in the Dimension
Properties or Member Properties dialog box unlessyou are
certain that all members of the relevant dimension are shared
members.

For more information about data storage properties, see Table 6-2 and the
Hyperion Essbase Database Administrator’s Guide.

5. Click OK.
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Setting Aliases for Dimensions and Members

You can assign an alias (aternate name) to a dimension and to amember. The
use of aliases improves the readability of Hyperion Essbase outlines and reports.
For example, members in the Hyperion Essbase outline created by the Product
dimension of TBC Metaoutline are identified both by product codes, such as
100-20, and by descriptive aliases, such as Kool Cola.

Because a member level in a metaoutline corresponds to a column of member
namesin therelated OLAP model, an alias in a metaoutline must correspond to a
column of aliasnamesintherelated OLAP model. TBC Metaoutline, for example,
tells OLAP Integration Server to retrieve member namesfrom the PRODUCT _ID
column and member aliases from the PRODUCT_DESC column.

PRODUCT_ID PRODUCT_DESC
100-10 Kool Cola
100-20 Diet Cola
100-30 Caffeine Free Cola

Y ou must observe the following rules when creating an alias:

e You cannot perform transformations on members to which you assign aliases.
Use OLAP Model to perform needed transformations. See the Hyperion
Integration Server Desktop OLAP Model User’s Guide.

e Ifthecolumnintherelational datasourcethat containsthe alias nameshasany
value with more than 80 characters (the maximum allowed in Hyperion
Essbase naming rules), you can use the SUBSTRING function in OLAP
Model to extract the 80 or fewer characters that you want to use in the alias
name. See the Hyperion Integration Server Desktop OLAP Model User’s
Guide.

e You must create the alias column in the external data source in advance.
See the Hyperion Integration Server Desktop OLAP Model User’s Guide
and the documentation for the external data source.

e If youwant to assign diases to recursive members, the alias column must be
in the same physical table as the recursive members. For more information on
recursive members, see “Creating Recursive Dimensions’ on page 3-17.
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» To assign an aiasto adimension or member:
1. Inthe metaoutline, select the dimension or member level.

2. Right-click the dimension or member level and, from the pop-up menu, select

Properties to open the Dimension Properties or Member Propertiesdiaog

box.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

Member Properties - LOOKUP_PRODUCT PRODUCT_DESC [X]

3. Select the Member Info tab.

General Member Info |Account|nfo| UDAs I Outline BuiIdI

Alias:

PRODUCT GR

(.E:D:S[:E;tif; [T Two Pass Calculation
- [zubtraction] [rata Storage

0 [multiplication) & Store Data

7 [division) ' Dynamic Calc &nd Store
% [percent) " Dynamic Calc

 ~ [ignore) ' Mever Share

" From Database Column " Label Only

|<N0ne> 'l

QK I Cancel Help

Figure 6-5: Assigning Aliases
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4. Do one of thefollowing:

e If youareassigning an aliasto ametaoutlinemember level, fromtheAlias
drop-down list, select the column that contains the aliases.

e |If you areassigning an dliasto adimension or a user-defined member, in
the Alias text box, enter the alias hame.

When you assign an alias to a dimension or a user-defined member, the
Alias drop-down list box changes to atext box.

See “About Naming” on page 3-9.

Note: Do not set adimension or member as shared in the Dimension
Properties or Member Properties dialog box unless you are
certain that all members of the relevant dimension are shared
members.

5. Click OK.

Specifying Two-Pass Calculation on
Dimensions and Members

6-12

By default, Hyperion Essbase cal cul ates outlines from the bottom up—cal culating
first the values for the children and second the value for the parent. Sometimes,
however, the value of a child depends upon the value of the parent or the value of
another member in the Hyperion Essbase outline. To obtain the correct values for
dependent dimensions and members, Hyperion Essbase must cal cul ate the outline
and then recal culate the dimensions and members that are dependent on the
calculated values of other dimensions and members. Dimensions and members
that are calculated on the second pass through the Hyperion Essbase outline are
called two-pass calculations.

For example, to calculate the ratio between Sales and Margin, Hyperion Esshase
needsto calculate Margin (aparent member based onitschildren, including Sales).
To ensure that the ratio calculation is based on a newly calculated Margin figure,
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tag the Margin% ratio member as a two-pass calculation. Hyperion Essbase
calculates the database and then recal culates the Margin% member. The second
calculation produces the correct result.

Note: Although two-pass calculation is a property that you can give to any
member, it works only on members of accounts dimensions, dynamic
calc members, and dynamic calc and store members. If you assign
two-pass calculation to other members, Hyperion Essbase ignores it.

» To tag adimension or member to use two-pass cal cul ation:
1. Inthe metaoutline, select the dimension or member level.

2. Right-click the dimension or member level and, from the pop-up menu, select
Properties to open the Dimension Properties or Member Propertiesdiaog
box.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

3. Select the Member Info tab.

Member Properties - Profit E

General Member Info |Account|nfo| UDAs I Formulal Outline BuiIdI
Alias:

— Consolidation

& + [addition]
- [zubtraction] [rata Storage
0 [multiplication) " Store Data
7 [division) ' Dynamic Calc &nd Store
% [percent) &' Diynamic Calc
 ~ [ignore) ' Mever Share
" Label Only

QK I Cancel | Help |

Figure 6-6: Specifying Two-Pass Calculation
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4. Select Two Pass Calculation.

For more information about two-pass calculation, see the Hyperion Essbase
Database Administrator’s Guide.

5. Click OK.

Specifying Member Consolidation Properties

Member consolidation propertiesdetermine how children roll upinto their parents.
By default, new members are given the addition (+) operator, meaning that
Hyperion Essbase adds the members. For example, Hyperion Essbase adds
January, February, and March figures and stores the result in their parent, Qtrl.
Table 6-3 describes each consolidation operator.

Table 6-3: Member Consolidation Properties

Operator Description

+ Adds the member to theresult of cal culations performed on other
members. This operator is the default operator.

- Multipliesthe member by -1 and then adds the result to the result
of calculations performed on other members.

* Multiplies the member by the result of calculations performed on
other members.

/ Divides the member into the result of calculations performed on
other members.

% Divides the member into the result of previous calculations
performed on other members and multiplies the result by 100 to
yield a percentage value.

~ Does not use the member in the consolidation to its parent.

From Database | Usesthe consolidation value (+, -, *, /, %, ~) of the selected
Column column of the data source. This option is not selectable for
measure columnsin the metaoutline.
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» To set the consolidation operator of a member:
1.
2.

Chapter 6

In the metaoutline, select amember level, for example, PRODUCT_DESC.

Right-click the member level and, from the pop-up menu, select Properties.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

Select the M ember Info tab.

Member Properties - LOOKUP_PRODUCT PRODUCT_DESC [X]

General Member Info |Account|nfo| UDAs I Outline BuiIdI

Alias:

— Consolidation
& + [addition]
- [zubtraction]
0 [multiplication)

™ Twa Pass Caloulation

[rata Storage
& Store Data

7 [division) ' Dynamic Calc &nd Store
% [percent) " Dynamic Calc
 ~ [ignore) ' Mever Share
" From Database Column " Label Only
<Mone: s
()8 I Cancel | |

Figure 6-7: Choosing Member Consolidation

From the Consolidation group, select the appropriate consolidation operator.

For more information about member consolidation, see Table 6-3 and the

Hyperion Essbase Database Administrator’s Guide.

Click OK.
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Setting Members as Dynamic Time Series

Y ou can cal cul ate period-to-date values dynamically in a Hyperion Essbase
database by tagging specific members as Dynamic Time Series. For example, you
can enable dynamic calculation of Hyperion Essbase quarter-to-date values by
setting the Quarter member of the Year dimension of the related metaoutline as
Dynamic Time Series. For more information about Dynamic Time Series
members, see the Hyperion Essbase Database Administrator’s Guide.

Note: To tag valuesin ametaoutline as Dynamic Time Series, you must set
the date-part of the column that contains the time data of the related
OLAP Model. See the Hyperion Integration Server Desktop OLAP
Model User’s Guide.

Note: Dynamic Time Series members must be at level O (leaf level) of the
metaoutline.

» Totag amember as Dynamic Time Series:
1. Inthe metaoutline, select the member level, for example, Month.

2. Right-click the member level and, from the pop-up menu, select Properties.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.
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Select the M ember Info tab.

Member Properties - Time_Month E
General Member Info |Account|nfo| UDAs I Outline BuiIdI
Alias:
— Consolidation .
&+ [addition] [T Two Pass Calculation
- [zubtraction] [rata Storage
0 [multiplication) & Store Data

7 [division)
% [percent)
 ~ [ignore)
" From Database Column

' Dynamic Calc &nd Store
" Dynamic Calc

' Mever Share

" Label Only

Chapter 6

|<N0ne> 'l

¥ Dynanic Time

QK I Cancel | Help |

Figure 6-8: Setting a Member as Dynamic Time Series

4. Select Dynamic Time.
Click OK.

Specifying Account Properties

Only the dimension tagged as accounts and the members of the dimension tagged
as accounts can access the built-in accounting functionality provided by Hyperion
Essbase. Thistopic contains the following subtopics that describe accounts
dimension properties:

e “Specifying Time Balance Properties’ on page 6-18
e “Specifying Variance Reporting Properties’ on page 6-21
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Specifying Time Balance Properties

By default, Hyperion Essbase bases the calcul ation of a parent of the Y ear
dimension on the consolidation properties and formulas of the children of the
parent. For example, the Qtrl member is, by default, the sum of the children
January, February, and March.

If, instead of a sum, you need a beginning, ending, or average value for atime
period, you can select the appropriate time balance property for the appropriate
member of the accounts dimension. When you set atime balance property on a
member of the accounts dimension, the property affects how Hyperion Esshase
calculates the accounts member across the Y ear dimension.

For example, if you want Opening Inventory for Qtrl to reflect the beginning
inventory value for Qtrl, set atime balance property of first on the accounts
member Opening Inventory. When Opening Inventory is calculated across the

Y ear dimension, Qtrl becomes equal to Jan (the first child in the Qtrl hierarchy).

Table 6-4: Time Balance Properties

Property Description

None This property is the default value. When you set the time balance
property as none, Hyperion Essbase rolls up parentsin the time
dimension in the usual way—the value of a parent is based on the
formulas and consolidation properties of children of the parent.

First Set the time balance as first when you want the parent value to
represent the value of the first member in the branch (often at the
beginning of atime period).

Last Set the time balance as last when you want the parent value to
represent the value of the last member in the branch (often at the end
of atime period).

Average Set the time balance as average when you want the parent value to
represent the average of the children values.
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If you set the time balance asfirst, last, or average, you must set the skip property
to tell Hyperion Essbase what to do when it encounters missing values or values
of 0. Table 6-5 describes each skip property.

Table 6-5: Skip Properties

Property Description

None Does not skip datawhen cal culating the parent value. This property is
the default value.
However, if Hyperion Essbase encounters #MISSING data when
calculating an average, it does not divide by the total number of
members. It divides by the number of members with data values.
Therefore, setting the skip property to none or #MI1SSING does not
affect average (but does affect first and last).

Missing Skips #MISSING datawhen calculating the parent value.

Zeros Skips data that equals zero when calculating the parent value.

Missing Skips both #MISSING dataand datathat equals zero when

and zeros | calculating the parent value.

» To set atime balance property for amember:

1. Inthe metaoutline, select the member level, for example,
OPENING_INVENTORY.

2. Right-click the member level and, from the pop-up menu, select Properties.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

3. Select the Account Info tab.

If the options in the Account Info tab are not selectable, the dimension that
the member belongsto is not tagged as accounts. To tag a dimension as
accounts, see “ Setting a Dimension Type” on page 6-5.
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The Account Info tab is not selectable for non-account type dimensions and
members.

Member Properties - OPENING_INVYENTORY E

Generall Mermber Info  Account Infa | UDAs I Formulal Outline BuiIdI

— Time Balance

Skip

' Mone
' Last ' Missing

' Bverage " Zemes
& Migsing and Zeros

—Wariance Reporting
& Non Ezpenze
" Expense

QK I Cancel | Help |

Figure 6-9: Setting Time Balance Properties

4. From the Time Balance group, select the property that you want to use, for

example, First.

5. If you set the time balance asfirgt, last, or average, set the appropriate Skip
property.

6. Click OK.
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Specifying Variance Reporting Properties

Variance reporting properties determine how Hyperion Essbase calculates the
difference between actual and budget data for a member whose formulaincludes
a@VAR or @VARPER function. Any member that represents an expense to the
company requires an expense property. For more information about functionsin
formulas, see “ Specifying Formulas’ on page 6-25.

Table 6-6: Variance Reporting Properties

Property

Description

Expense

For expense items, actual expenses should be lower than budgeted
expenses. When actual expenses are greater than budgeted
expenses, variance is negative. The @VAR function calculates
BUDGET - ACTUAL. For example, if budgeted expenses are $100
and actual expenses are $110, the variance is -10.

Non-expense

For non-expense items, such as sales, actual should be higher than
budget. When actual isless than budget, variance is negative. The
@VAR function calculates ACTUAL - BUDGET. For example, if
budgeted sales are $100 and actual sales are $110, the variance is
10.

By default, members are non-expense.

» To set the variance reporting property of a member:

1. Inthe metaoutline, select the member level, for example, DISCOUNTS.

2. Right-click the member level and, from the pop-up menu, select Properties.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide H 6-21



Chapter 6

3. Select the Account Info tab.

If the options in the Account I nfo tab are not selectable, the dimension that
the member belongsto is not tagged as accounts. To tag adimension as
accounts, see “ Setting a Dimension Type” on page 6-5.

The Account Info tab is not selectable for non-account type dimensions and
members.

Member Properties - DISCOUNTS E

Generall Mermber Info  Account Infa | UDAs I Formulal Outline BuiIdI

— Time Balance

& Mone Skip
' First % Hone
' Last ) iissing

' Bverage ) Zemoes
) Wissing and 2erms

" Expense

QK I Cancel | Help |

Figure 6-10: Tagging Members as Expense or Non-Expense

4. From the Variance Reporting group, select Non Expense or Expense.

For more information about variance reporting, see Table 6-6 and the
Hyperion Essbase Database Administrator’s Guide.

5. Click OK.
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Specifying UDASs

Y ou can create your own UDAS (user-defined attributes) for members. A UDAis
aword or phrase about a member. For example, you might create a UDA called
Big Market to identify any market that sells more than a certain amount. Use
UDAs in calc scripts and report scripts. For more information, see the Hyperion
Essbase Database Administrator’s Guide.

Understanding Rules for UDAs
When creating UDAS, keep the following guidelines in mind:

You can define multiple UDASs on a single member.
You cannot define the same UDA twice on the same member.
You can define the same UDA on different members.

A UDA can usethe same name as amember, alias, level, or generation. When
you name UDAs, follow the same naming rules as for members. See “About
Naming” on page 3-9.

If you are using DB2 OL AP server, you can specify an anchor dimension by
setting a UDA of RELANCHOR on the appropriate dimension.

You cannot create a UDA on Hyperion Essbase shared members.

A UDA appliesto only aspecified member. Descendants and ancestors of the
member do not automatically receive the UDA.
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Defining a UDA

» TodefineaUDA:

1. Inthe metaoutling, select the member level for which to define the UDA, for
example, REGION.

2. Right-click the member level and, from the pop-up menu, select Properties.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.

3. Select the UDASs tab.

Member Properties - LOOKUP_MARKET _REGION E

Generall Member Infol Secauttlhfe) [ UDAs | Outline BuiIdI

| Add to List |

" From Database Column
|ATTRIBUTE_REGION_REGION_TYPE_~ |

Existing UDAs: EI

REGION_TYPE
REGION_TYPE_AGE

QK I Cancel Help

Figure 6-11: Defining UDAsS

4. If you want to define the UDA, select value and in the Value text box, enter
the UDA.
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If you want OLAP Integration Server to retrieve the UDA from acolumnin
the relational data source, select From Database Column and, from the
drop-down list, select the desired column.

If the UDA in the relational data source has more than 80 characters, you
can use the SUBSTRING function in OLAP Model to extract the characters
(amaximum of 80) that you want to usein the UDA. See the Hyperion
Integration Server Desktop OLAP Model User’s Guide.

Click Add to List to add the UDA to the Existing UDASs list.
The Existing UDAs box displays all UDAs for the selected member.
If you want to delete aUDA, in the Existing UDAsIist, select the UDA, and

dlick the delete button L2,
If you want to add another UDA to the member, repeat steps 4 through 6.
Click OK.

Specifying Formulas

Y ou can associate formulas with dimensions, user-defined members, and
measures. A formula determines how Hyperion Essbase calculates datain a
Hyperion Essbase database. For more information about formulas, see the
Hyperion Essbase Database Administrator’s Guide and the functions section
of the Hyperion Essbase Quick Technical Reference.

» To add aformulato a dimension or member:

1.

In the metaoutline, select the dimension or member level to which to add the
formula, for example, PROFIT%.

Right-click the member level and, from the pop-up menu, select Properties.

Y ou may also open the dialog box by clicking from the toolbar or by
selecting Properties from the Edit menu.
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3. Select the For mulatab.

Member Properties - Profit E
Generall Member Infol Account Infol UDAs  Formula | Outline BuiIdI
FROFIT % SaLES] ;l

QK I Cancel Help

Figure 6-12: Typing Formulas

4. Intheeditfield, enter theformula Besureto end the formulawith asemicolon
(;), for example, PROFIT % SALES,

Note: The % signin Hyperion Essbase formulas performs percentage
operations.

5. Click OK.

OLAP Integration Server does not validate the formula. Errorsin the formula
are not displayed in the log file until OLAP Integration Server calculates the
Hyperion Essbase database. See the Hyperion Integration Server System
Administrator’s Guide for more information on the OLAP Integration Server
log file. For more information about formula options and built-in functions,
see the Hyperion Essbase Database Administrator’s Guide.
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Viewing Hyperion Essbase Properties

Y ou can customize the view of the OLAP Metaoutline main window to display
Hyperion Essbase propertiesin either columnar or condensed format. Columnar
format places Hyperion Essbase properties under column headings, and condensed
format places propertiesin parentheses and to the right of the dimension or
member name. Default Hyperion Esshase settings are not displayed.

» To display Hyperion Essbase properties in column format:

1. Inthe metaoutline, select adimension, member level, or outline; for example
TBC Metaoutline.

2. Select View > Display Essbase Properties.

3. If Display as Columnsis not selected, select it.

The column view is the default.

4. Todetermine which propertiesto display, from the submenu, select any of the
following items:

Consolidation Objects. Displays consolidation properties, such as +, -,
and %.

Formula Objects: Displays the assigned formula.
Dimension Type: Displays the dimension type, time or accounts.
Alias. Displays aliases.

Member Properties. Displays member properties, such as storage type,
two-pass cal culation, dynamic time, time balance and variance reporting
properties, and UDAS.

The metaoutline is displayed in columnar format and the properties that you
selected are displayed.
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5. If you want to display all Hyperion Essbase properties, select All.

File Edit “iew Connections Outine Toolz ‘Window Help ;Iilll
DEE|&|w s (&2 %
I"Default j| = W Wx
& | Type/Conzolidation | Aliaz/Member Properties Formula
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m Time. Quarker [+] Addition [Dwnamic Calc)
FR Time Month [+] Addition
Elﬁ'{‘ Measures Accounts [Label Only)
O Profit [+] Addition [Dwnamic Calc)
Inventory Accounts [Label Only)
+- O Ratioz [~ lgnare [Label Only)
= ﬁ'{‘ Product [Sparze]
-EH LOOKUP_PRODUCT.PRO... [+ Addition [tlias: PRODUCT_GROUP...
FE LOOKUP_PRODUCT.PRO... [+ Addition [&lias: PRODUCT_DESC)
O Diet [~ Igrore [liaz: Diet Drinkz]
I'_—'lﬁ'g" Market [Sparze]
- - LOOKUP_MARKET.REGL..  [+] Addition [UD&s: REGION_TYPE_#,..
Eﬁ'{‘ Scenario [Sparze] [Label Only)
FE LOOKUP_SCEMARIOSCE... [~)lgnore
O Yarance [~] lgnare [Dwnamic Calc] [Two Pass .. @VAR[Actual, Budget);
O Yarance % [~] lgnare [Dynamic Calc] [Two Paszs .. @VARPER(Actual, Budget):
J | »
| Data Source: TEC
Faor Help, press F1 |DLAF' Catalog: tbe_md i

Figure 6-13: Viewing Hyperion Essbase Properties in Column Format

When the Display as Columns command is deselected, the column view is
replaced by the condensed format view, as shown in Figure 6-13. To return to the
column view, select Display as Columns.

» To display Hyperion Essbase properties in condensed format:
1. Select adimension, member level, or outline; for example TBC Metaoutline.
2. Select View > Display Esshase Properties.
3. If Display as Columnsis selected, deselect it.
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4. To determine which propertiesto display, from the submenu, select any of the
following items:

e Consolidation Objects: Displays consolidation properties, such as +, -,
and %.

e Formula Objects: Displays the assigned formula.
e Dimension Type: Displays the dimension type; time or accounts.
e Alias: Displays aliases.

e Member Properties: Displays member properties, such as storage type,
two-pass cal culation, dynamic time, time balance and variance reporting
properties, or UDAS.

The metaoutline is displayed in condensed format and the properties that you
selected are displayed.

5. If you want to display all Hyperion Essbase properties, select All.
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File Edit “iew Connections Outine Toolz ‘Window Help = |ﬁ'|1|
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Elﬁj “rear Time [Dynamic Calz)
Em Time.Quarter [+][Dpnamic Calz)

T = )
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[_]ﬁj Market [Sparse)
=61 LOOKUP_MARKET REGION (+](DAs: REGION_TYPE_AGE REGION_TYPE)

- Diet [~][Alias: Diet Drinks)
FH LOOKUP_PRODUCT PRODUCT_DESC [+)
FH LoDOKUP_PRODUCT PRODUCT_GROUP_ID [+)[4lias: PRODUCT_GROUF_DESC)

I'_—'lﬁj Measures Accounts [Label Only]
El- 0 Profit [+) [Dynamic Calc)
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= SALES [4)
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| 3

l

|Data Source: the
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Faor Help, press F1

Figure 6-14: Viewing Hyperion Essbase Properties in Condensed Format

To return to the column view, select Display as Columns.
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Loading Dimensions
and Members

This chapter describes how to use a metaoutline to add dimensions and members
to arelated Hyperion Essbase outline, a process also referred to as member [oad.
First, the chapter describes everything that you need to do before starting a

member load, such as connecting to the appropriate servers and setting query
governors. Then, the chapter steps you through the member load process that you
must follow to create or update the Hyperion Essbase outline.

This chapter contains the following topics:

“Understanding the Metaoutline Workflow” on page 7-2
“About Loading” on page 7-3

“About Naming Applications and Databases’ on page 7-4
“Procedure 1: Preparing to Load Members’ on page 7-4
“Procedure 2: Starting aMember Load” on page 7-8
“Procedure 3: Loading Members Immediately” on page 7-13
“Procedure 4: Scheduling aMember Load” on page 7-16
“Viewing Scheduled Member and Data Loads’ on page 7-18
“Deleting Scheduled Member and Data Loads’ on page 7-21

If you are not sure how to view a Hyperion Essbase outline, see the Hyperion
Essbase Database Administrator’s Guide.

To load data into a Hyperion Essbase outline, see Chapter 8, “Loading Data.”
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Understanding the Metaoutline Workflow

Figure 7-1 illustrates the workflow for creating a metaoutline and using the
metaoutline to create and load members and data into a Hyperion Essbase
database. This workflow includes the following processes:

e Creating and working with a metaoutline
e Adding dimensions, member levels, and measures to a metaoutline

e Setting load properties, filters, and Hyperion Essbase properties on
dimensions, member levels, and measures in a metaoutline

e Loading dimensions and members from the metaoutline into a Hyperion
Essbase outline

e Loading the data specified in the metaoutline into a Hyperion Essbase
database

This chapter focuses on loading dimensions and members from ametaoutlineinto
aHyperion Essbhase outline.

Crecting ang

wiorking with
metaoutlines

|
B 5 Market

) ) ) | MARKET REGION
Adding dimensions, member B 5 Measures

levels, and measures to a O Profit
metaoutline o Ratios

=-E9 TBC_MODEL
E-Ef MARKETS

E-E¥ SCENARID

-

=

Load Properties
Filters
Hyperion Essbase Properties

C

W

—

Setting load properties, filters
and Hyperion Esshase properties

@ Loading dimensions
and members

You Are Here

Loading data

Figure 7-1: Metaoutline Workflow
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About Loading

When you perform aload, OLAP Integration Server performs the following tasks:

Retrievesinformation from OLAP Metadata Catal og and usestheinformation
to generate SQL statements that specify how and what to retrieve from the
external data source.

Retrieves data from the external data source.

Performs on the retrieved data the transformations specified in the OLAP
model and the metaoutline.

Loads the transformed data into the specified Hyperion Essbase application
and database. If no Hyperion Esshase application and database exists for a
member load, OLAP Integration Server creates an application and database.

OLAP Integration Senver

®

® i1
[\_\ @ | B 5 Market .

FR markeTF| Load Properties
B & Measures Filters
o Froft Hyperion Esshase Properties
- L\—\ o Ratios | l
External % .

Data Source
Hyperion Esshase
Database

OLAP Metadata
Catalog

Figure 7-2: Loading Process
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About Naming Applications and Databases

When naming applications and databases, follow these rules:

Use no more than 8 characters.

Do not use the following special characters anywhere in the name:

*  (asterisk) < (lessthan sign)

\  (backslash) >  (greater than sign)

[1 (bracket) . (period)

: (colon) +  (plussign)

, (comma) ?  (question mark)

= (equa sign) " (double quotation mark)
i (semicolon) ’ (single quotation mark)

| (vertical bar)

Do not use spaces anywhere in the name.

Procedure 1. Preparing to Load Members

Before you start amember load, you must perform the following procedure:

1. Connect to the Hyperion Essbase server where you want to create or change

7-4 1

the Hyperion Essbase outline.

See the Hyperion Integration Server Installation Guide for information on
starting Hyperion Integration Server Desktop.

If needed, set query governors to control the duration and the size of the
gueries that Hyperion Integration Server makes to the data source.

See “Using Query Governors’ on page 7-5.
If needed, select a metaoutlinefilter to use for the load.
See “Viewing the Contents of a Metaoutline Filter” on page 5-11.
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Using Query Governors

A query governor controls the duration and the size of the queries that OLAP
Integration Server makes to the data source. A query governor prevents you from
retrieving more data from the external data source than you want or need. If you
set aquery governor, OLAP Integration Server stops the query if it istaking too
long or retrieving too much data.

For example, if you set the maximum rows to retrieve to 200, OLAP Integration
Server retrieves approximately 200 rows. If the query calls for more than 200
rows, OLAP Integration Server stops the query and displays an error message.
Remember that viewing more than 10,000 rows is difficult for spreadsheet users.

CAUTION: Whether OLAP Integration Server loads the retrieved
rows before stopping the query depends on the I solation
Level setting in the Hyperion Essbase database. For
more information, see the Hyperion Essbase Database
Administrator’s Guide.

» To set aquery governor:
1. Inthe metaoutline, select the metaoutline name.
2. Right-click the metaoutline name, and choose one of the following options:

e From the pop-up menu, select Properties.

e From thetoolbar, select the button.
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3. Select the Governorstab.

Generall Database Measuresl User Defined Dimenzsions  Governors | Dill-Through Heportsl
b aximum time per query (in seconds)
S
b aximum rows per query
|u

Wiew Sample

= Stop at first level O member for each dimension
£+ Build entire branch

QK I Cancel Help

Figure 7-3: Setting a Query Governor

4. Inthe Maximum time per query (in seconds) text box, enter the maximum
query time.

For example, to stop a query that takes longer than 100 seconds, type 100.

5. Inthe Maximum rows per query text box, enter the maximum number of
rowsto retrieve.

For example, to stop a query that retrieves more than 200 rows, type 200.

CAUTION: Whether or not Hyperion Integration Server loads the
retrieved rows before stopping the query depends on the
Isolation Level setting in the Hyperion Essbase database.
For more information, see the Hyperion Essbase
Database Administrator’s Guide.
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6. If you are setting a query governor to view a sample outline or dimension,
select one of the following:

e Stop at first level 0 member for each dimension to see the structure
of aHyperion Essbase outline or the structure of a dimension without
including all members. A level 0 member isaleaf level member, that is,
amember with no members below it in the hierarchy.

e Build entirebranch to view adimension asit is displayed in the
Hyperion Esshase outline. If the number that you enter for the duration or
the size of the query is smaller than the entire branch, OLAP Integration
Server stops when it reaches the duration or size limit.

OLAP Integration Server truncates sample outlinesif they contain more
than 32,767 members.

Note: If thereis ashared member in the dimension, set the query
governor to Build entire branch.

7. Click OK.
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Procedure 2: Starting a Member Load
When you have performed the appropriate preparation steps, you are ready to start

the member load.

» To load members:

1. Make surethat you perform the tasks described in “ Procedure 1: Preparing to
Load Members’ on page 7-4. From the menu bar, select Outline > Member

Load.

The Essbase Application and Database dialog box is displayed.

Essbase Application and Database

Essbaze Mame
Application Mame

Server

IDemo

D atabase Mame

j Ilocalhost

IBasic

j Server Connection... |

™ Delete all members first
™ Modify Esshase users
™ Incremental Update

Calc Script:
' None
' Use Default Calz Script
" Specify Calc Script

I vl Wi Senpt.. |

< Back I Mest » I

Cancel | Help

Figure 7-4: Choosing the Hyperion Essbase Application and Database
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2. Do one of thefollowing:

e If you are creating a new Hyperion Essbase application and database in
the Application Name and Database Name text boxes, enter the names
of the application and database.

See “ About Naming Applications and Databases’ on page 7-4.

Hyperion Essbase application and database names must be unique and
must consist of no more than 8 characters. It is recommended that
database and application names start with a capital letter.

e If you are using an existing Hyperion Essbase application or database,
select the names that you want from the appropriate lists.

3. If youwant to delete all dimensions and membersin an existing Hyperion
Essbase outline, select Delete all membersfirst.

When you delete all members, OLAP Integration Server removesall members
from the existing Hyperion Essbase outline and then uses the member levels
of the metaoutline to recreate the database. Because deleting all membersis
slower than creating or updating a Hyperion Essbase outline without deleting
al members, delete all membersfirst only if you have a specific reason to do
s0. You should delete all membersif, for example, you know that some
members have been removed from the OLAP model and you want to build a
smaller Hyperion Essbase outline that contains the smaller set of members.
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4. If you want to determine which Hyperion Essbase users can access the
Hyperion Essbase application and database into which you are loading
members, do the following:

a. Select Modify Essbase users.

When you select M odify Essbase user s, the Essbase User sdialog box is
displayed. The box shows all available and selected Hyperion Essbase
users:

Available: Selected:
Joe Salmozar Katherine Giza
Patty MclGee
”
=
[
[
< Back | Mest » | Cancel | Help |

Figure 7-5: Selecting Hyperion Essbase Users

OLAP Integration Server retrieves the list of available users from the
following places:

OLAP Integration Server retrieves the
For a(n) users from...

New application The Hyperion Essbase server. All of the users can
create new applications and databases on the
Hyperion Esshase server, for example, sys.

Existing application | The Hyperion Essbase application

New database The Hyperion Essbase application

Existing database The Hyperion Essbase database
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Inthe Available list box, select a user to whom you want to give access.

Click the _>| button to move the selected user to the Selected list box.

When the names of al users who should access the Hyperion Essbase

application and database are in the Selected list box, click Next.

Tip:

to click the ] button.

5.
Update.

If youwant to give accessto all available users, you need only

If you want to select specific dimensions not to update, select | ncremental

By default, OLAP Integration Server updates all dimensions and members.
Updating an existing Hyperion Essbase outline incrementally is faster than
updating all dimensions and members.

If you choose to update the Hyperion Essbase outline incrementally, the
Incremental Update dialog box is displayed:

Incremental Update

e

Don't Update. |

< Back I Mest » I

Cancel | Help

Figure 7-6: Updating Hyperion Essbase Outlines Incrementally

To prevent OLAP Integration Server from updating a dimension or

member, select the dimension or member and click Don’t Update.

When you have marked all dimensions and members that OLAP

Integration Server should not update, click Next.
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6. Proceed to “Procedure 3: Loading Members Immediately” on page 7-13 or to
“Procedure 4: Scheduling aMember Load” on page 7-16.

Y ou can use the LOADMEMBER command in OLAP Command
F Interface to load members. For more information about the
LOADMEMBER command, seethe Hyperion Integration Server
System Administrator’s Guide.

7. Select the calc script to use to calculate the Hyperion Essbase database.

If you select... | OLAP Integration Server...
None Does not run acalc script on the Hyperion Essbase database.
Default Runsthe default calc script that is specified for the Hyperion

Essbase database. If you have not specified a calc script to
use as the default, Hyperion Essbase uses standard
calculation order to cal culate the database.

Any other Runs the selected cal ¢ script on the Hyperion Esshbase
calc script database.

The calc script that you chooseisrun after OLAP Integration Server loads data
into the Hyperion Essbase database. The cal ¢ script determines how Hyperion
Essbase calculates the data val ues in the database.

For more information on calculation and on calc scripts, see the Hyperion
Essbase Database Administrator’s Guide.
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Procedure 3: Loading Members Immediately

Y ou can schedule a member load to start immediately or to start at a specific date
and time. If you choose to start a member load immediately, the Member Load
dialog box is displayed. The dialog box provides you with dynamic status
information about the member load and specific messages for any errors or
warnings that may occur. If you encounter an error during the load, you can stop
the member load. Hyperion Integration Server executes member |oads on the
computer that isrunning OLAP Integration Server.

» To load members immediately:

1. Make surethat you perform the tasks described in “ Procedure 2: Starting a
Member Load” on page 7-8.

After you complete the appropriate dial og boxes, as directed in “ Procedure 2:
Starting aMember Load” on page 7-8, and click Next, the Schedule Essbase
L oad dialog box is displayed:

Schedule Essbase Load E
 Load Essbase
............ Expart Optians
& How
' Only Save Load Script Save Scripts... |
' Scheduls

Date:
| danay . 17, 2000 =]

Time:

[11:5:00 PM =

Frequency:

IDnce j

< Back I Finizh I Cancel | Help |

Figure 7-7: Loading Members Immediately
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2.

If you want to save the script to a different name or change the name of the
script, click Save Scripts.

The Save Script Asdialog box is displayed:

Save Script As E

Enter script name

IDemo

o]

Cancel |

Figure 7-8: Saving a Script

a. Enter the new script name.

b. Click OK to return to the Schedule Essbase L oad dialog box.
Select Now.

Click Finish.

The Member L oad dialog box is displayed:

Member Load E
OLAP kodel: Application: Time Started:
TEC todel testing Mon Jan 17 11:23:40 Ak
IMetaoutline: D atabase:
TBC Metaoutline test
Load Type | Loaded | Rejected | Time Elapsed | Statuz |
000000 Load Initialization in Frogress
Member Load 4848 1] 00015 Member Load in Progress
000030 Load completed

Meszage Summary

1D | Meszage | Dimension | OLAP Metaoutline Me... | Fielational [ atat
Connecting to the metadata RDBMS...

Connecting to the source RDEMS. .

Connecting to the Essbaze server...

Feading the Metaoutline. ..

Feading the OLAP Maodel...

Creating the Ezsbase outline...

Successfully loaded isqad:testing:test.

| | B
Lloze I Help |

Figure 7-9: Displaying Member Load Information
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5. If you encounter an error and want to stop the member load, click Stop Load.
(The Stop Load button is displayed during the load.)

To start the member load again, return to Step 1 of this procedure.

If any dimension or member is not loaded into the Hyperion Essbase outline, a
reject text file for the rejected dimension or member is automatically created.
The name of argject text file consists of the name of the relevant dimension
followed by the leaf node number of the dimension or member that did not load.

For example, as shown in Figure 7-10, if the three member levels of the
Product dimension do not load, three. txt files are created: PRODUCT 0.txt
(PRODUCT.DIET), probuCT 1.txt (PRODUCT.PRODUCT_ID), and
PRODUCT 2.txt (PRODUCT.DESC).

25 Product Leaf Mode 0

[ LOOKUP_PRODUCT.PRODUCT_ID :P-eaf Mode 1

- Ff] LooKUP_PRODUCT.PRODUCT_DESC _ Leaf Mode 2

Figure 7-10: Leaf Node Example

For each reject file, a corresponding rulesfileis created. The rulesfiles
created for the rejected member levels of Figure 7-10 are PRODUCT 0.rul
(PRODUCT.DIET), proDUCT_1.rul (PRODUCT.PRODUCT_ID), and
PRODUCT 2.rul (PRODUCT.DESC). Both.txt and. rul files are located
in the 1sHOME\ 1oadinfo default directory. To place the filesin adirectory
other than the default directory, set the 1sLOADINFO environment variable to
point to adifferent directory.

For more information on rules files, see the Hyperion Essbase Database
Administrator’s Guide.

If amember does not load successfully, see “ Problems with Loading Members or
Data’ on page 10-6.

For information on starting an unscheduled data load, see * Procedure 3: Loading
Data Immediately” on page 8-8.
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Procedure 4. Scheduling a Member Load

7-16 W

Y ou can schedule a member load to start at a specific date and time. Y ou can
also schedule aload to be run regularly, for example, once aweek. Hyperion
Integration Server executes member |oads on the computer that is running OLAP
Integration Server.

» To schedule a member |oad:

1. Make surethat you perform the tasks described in “ Procedure 2: Starting a
Member Load” on page 7-8.

After you compl ete the appropriate dialog boxes as directed in “ Procedure 2:
Starting aMember Load” on page 7-8, the Schedule Essbase L oad dialog

box is displayed:
Schedule Essbase Load E
 Load Essbase
Export Options
' Now
' Only Save Load Script Save Scripts... |
& Scheduls

Date:
| danay . 17, 2000 =]

Time:

[11:5:00 PM =

Frequency:

wieekly
— [Monthly

< Back I Finizh I Cancel | Help |

Figure 7-11: Scheduling the Member Load

2. Select Schedule.

3. If Hyperion Integration Server is on a computer running UNIX, proceed to
step 5.

4. If Hyperion Integration Server ison acomputer running Windows NT, start
the Schedule service as described in “ Starting the Windows NT Schedule
Service Automatically” on page 7-17 and then proceed to step 5.
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5. Enter the time to run the member load:

a. IntheDate text box, enter the date. Use the mm/dd/yyyy format, for
example, January 17, 2000.

b. Inthe Time text box, enter thetime. Usethe hh:mm: ss format, for
example, 23 :59. To schedule aload to run a midnight, enter 00: 00, as
midnight is considered the first hour of a day, not the last hour of aday.

Note that Hyperion Integration Server uses a 24-hour clock.

c. FromtheFrequency drop-down list, select how frequently to performthe
member |oad.

Y ou can schedule a member load to be performed one time, every day,
every week, or every month. Y ou cannot schedule a member load more
than once on asingle day. To perform a member load more than once a
day, you must implement each load individually. See “Procedure 3:
Loading Members Immediately” on page 7-13.

6. Click Finish.
OLAP Integration Server loads the members into the Hyperion Essbase
outline as scheduled.

Note: If amember does not load successfully, see “Problems with
Loading Members or Data’ on page 10-6.

To view a scheduled member load, see “Viewing Scheduled Member and Data
Loads’ on page 7-18. To delete a scheduled member load, see “ Deleting
Scheduled Member and Data Loads” on page 7-21.

Starting the Windows NT Schedule
Service Automatically

OLAP Integration Server schedules loads by using the Windows NT Schedule
service. It isrecommended that you set the Schedule serviceto start automatically.
See the Windows NT documentation. For more information, refer to the Hyperion
Integration Server Installation Guide.
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Starting the Windows NT Schedule
Service Manually

Y ou may, on occasion, need to start the Windows NT Schedule service manually.

» To start the Windows NT Schedule service manually:
1. From the Windows NT taskbar, select Settings > Control Panels.

2. Double-click the Services button, seric=:, to open the Services dialog box.

Services E
Service Status Startup
Metwork DDE Manual ;I
Metwork DDE DSDM M anual Start |
MT LM Security Support Provider M anual
Flug and Flay Started Automatic Stop |
Femote Procedure Call [RPC) Locator M anual
Femote Procedure Call [RPC) Service Started Automnatic: ﬂl
‘Schedule b anual Bialiang |
Server Started Automatic —
Spooler Started Automatic Sl |
SOLExecutive Marual x| ==
Hiw! Profiles. .. |
Startup Parameters:
| Help |

Figure 7-12: Starting the Windows NT Schedule Service

Scroll down to the Schedule service and select it.
4. Click Start.
Click Close.

Viewing Scheduled Member and Data Loads

Y ou can view member and data loads after scheduling them. For information on
performing data loads, see Chapter 8, “Loading Data.”

Before you can view scheduled loads, start Hyperion Integration Server. See
the Hyperion Integration Server Installation Guide for information on starting
Hyperion Integration Server Desktop.
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If Hyperion Integration Server is on a computer running Windows NT, you must
start the Schedule service as described in “ Starting the Windows NT Schedule
Service Automatically” on page 7-17.

» To view all scheduled member and data loads:

1. From the OLAP Metaoutline main window menu bar, select Tools >
Scheduler.

The Scheduled Jobs dialog box is displayed. The dialog box listsall member
and data loads that are currently scheduled. The dialog box contains the
following columns:

e Job Id displays the identification number for the load.

e Essbase Target displays the name of the Hyperion Essbase application
and database into which OLAP Integration Server |oads members or data.

e M standsfor member load. A Y (yes) intheM columnidentifiesamember
load. D stands for dataload. A v (yes) in the D column identifies a data
load. A Y (yes) in each column indicates a combined member and data
load.

e Next Run displays the date of the next scheduled load.

e Frequency displays how frequently OLAP Integration Server performs
the load.

Scheduled Jobs E

Currently scheduled jobs

1

948138275 izqad:Sample:Basic Y Y 01AF/200012:59  Monthly T |

Ezzhase Target | b4 | 8] | Mext Fun | Frequency ﬂl

1§ izqadtesting Test Yoo 01ATA2000 2200 Once
izgad:Sample:Basic % Y 01/24/200005:00  ‘wWeekly

Delete...

Befresh

i

| _>| Cloze

Figure 7-13: Viewing a List of Scheduled Loads

Note: To update the list of scheduled loads, click Refresh.
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2. Toview moreinformation about aparticular load, inthe Job 1d column, select
the job number of the load and then click View.

OLAP Integration Server opens the View existing job window. The window
listsall properties for the selected load.

— Schedule P ‘
Date: Timne: Frequency:
[22:00 | =

Help |

— OLAF Catalog
Connection String:

I"DSN=tbc:_md;UID=tbC;PWD =paszword;"

Metaoutline:
ITBE Metaoutling

—Esshase
Server User: Password:
Iisqa4 Ihyperion *********
Application: Databaze:
Itesting ITest
¥ | Member laad ¥ | Data Load
Parameters:

I"AF'F':testing;DBN:T est;0TL=TBC Metaoutine:FLT_ID=1:0TL_C

— Source Database
Connection String:
I"DSN=tbc;UID=tbc;PWD=password;"

Figure 7-14: Viewing a Description of the Selected Load

3. When you finish viewing the load properties, click OK.
4. Inthe Scheduled Jobs dialog box, click Close.
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Deleting Scheduled Member and Data Loads

Y ou can delete member and data loads after you schedule them. For information
on performing data loads, see Chapter 8, “Loading Data.”

Before you can delete scheduled loads, you must start Hyperion Integration
Server. Seethe Hyperion Integration Server Installation Guide for information on
starting Hyperion Integration Server Desktop.

If Hyperion Integration Server is on a computer running Windows NT, you must
start the Schedule service as described in “ Starting the Windows NT Schedule
Service Automatically” on page 7-17.

» To delete a scheduled member or data load:

1. From the OLAP Metaoutline main window menu bar, select Tools >
Scheduler.

OLAP Integration Server opens the Scheduled Jobs dialog box. The dialog
box lists all member and data loads that are currently scheduled:

Scheduled Jobs E

Currently scheduled jobs

Ezzhase Target | b4 | 8] | Mext Fun | Frequency ﬂl

izqadtesting: Test Yoo 01ATA2000 2200 Once

48138229 izgad:Sample:Basic % Y 01/24/200005:00  ‘wWeekly

948138275 izqad:Sample:Basic Y Y 01AF/200012:59  Monthly .
Wiew... |
Delete... |
Befresh |

‘ o

Figure 7-15: Viewing a List of Scheduled Loads

Note: To update the list of scheduled loads, click Refresh.

2. IntheJob Id column, select ajob number.

3. Click Delete.
OLAP Integration Server prompts you to confirm your direction to delete the
scheduled load.

4. Click Yes.
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Loading Data

L oading datainto aHyperion Essbase databaseis aprocess also referred to asdata
load. This chapter describes how to prepare for a dataload, how to select acalc
script to execute after the data load finishes, and how to schedule the data load to
start immediately or at a specific time or date.

This chapter contains the following topics:

“Understanding the Metaoutline Workflow” on page 8-2
“Procedure 1: Preparing to Load Data’ on page 8-3
“Procedure 2: Starting a Data Load” on page 8-4
“Procedure 3: Loading Data Immediately” on page 8-8
“Procedure 4: Scheduling a Data Load” on page 8-11

Y ou can view the new and updated datain Hyperion Essbase Spreadsheet Add-in
to verify that the dataload was successful. If you need instruction, see the
Hyperion Essbase Soreadsheet Add-in User’s Guide for 1-2-3 or Hyperion
Essbase Sporeadsheet Add-in User’s Guide for Excel.
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Understanding the Metaoutline Workflow

Figure 8-1 illustrates the workflow for creating a metaoutline and using the
metaoutline to create and load members and data into a Hyperion Essbase
database. This workflow includes the following processes:

e Creating and managing a metaoutline
e Adding dimensions, member levels, and measures to the metaoutline

e Setting load properties, filters, and Hyperion Essbase properties on
dimensions, members, and measures in the metaoutline

e Loading dimensions and members from the metaoutline into the related
Hyperion Essbase outline

e Loading the data specified in the metaoutline into the related Hyperion
Essbase database

This chapter focuses on loading data into a Hyperion Essbase database from a
metaoutline.

Crecting ang

wiorking with
I\

metaoutlines 5 B THC_MODEL

G- B MARKETS
B-Ef SCENARID

- [

Bl & Market
: : : MARKET REGION
Adding dimensions, member o ﬁ% %asures
levels, and measures to a O Profit
metacutline o Ratios

Load Properties
Filters
Hyperion Essbase Properties

=

Loading dimensions

and members 33 ab
@ Loading data

You Are Here

—

Setting load properties, filters
and Hyperion Esshase properties

Figure 8-1: Metaoutline Workflow
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Procedure 1. Preparing to Load Data

Before you start a dataload, you must perform the following tasks:

1.

Open the metaoutline.

See the Hyperion Integration Server Installation Guide for information on
starting Hyperion Integration Server Desktop.

Connect to the Hyperion Essbase server where you want to load the data.

See the Hyperion Integration Server Installation Guide for information on
connecting to Hyperion Essbase servers.

If you want to control the duration and the size of the queries that OLAP
Integration Server makes to the data source, set query governors.

See “Using Query Governors’ on page 7-5.
If you want to filter data, select a metaoutline filter to use for the load.
See “Viewing the Contents of a Metaoutline Filter” on page 5-11.

If the Hyperion Essbase outline does not already exist, perform a member
load.

See Chapter 7, “Loading Dimensions and Members.”

Note: If the datain the fact table aggregates in more than one way,
such assales (which are additive) and percentage discount values
(which are not additive), you must load the different types of
data separately into the Hyperion Essbase outline. To load the
different types of data separately, create two metaoutlines from
one OLAP model and load the data of each metaoutline
separately into the Hyperion Essbase outline.

Now you are ready to start the data load. For more information about the steps
that Hyperion Integration Server follows when performing a load, see “ About
Loading” on page 7-3.
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Procedure 2: Starting a Data Load

» To start adataload:

1. Make surethat you perform the tasks described in “ Procedure 1: Preparing to
Load Data’ on page 8-3.

2. From the menu bar, select Outline > Data Load.
The Essbase Application and Database dialog box is displayed.

Essbase Application and Database

Essbaze Mame

Application Mame Server
W
D atabase Mame
IBasic j Server Connection... |
Calc Script:
' None
I Modify Esshase users ' Use Default Calz Script

| tal Lipdat
I™ Ineremental Update € Specify Calz Script

I vl Wi Senpt.. |

< Back I Mest » | Cancel | Help |

Figure 8-2: Choosing the Hyperion Essbase Application and Database

3. Fromthelist of applications, select the Hyperion Essbase application that
contains the database into which you want to load data.

4. Fromthelist of Hyperion Essbase databases, select the Hyperion Essbase
database into which you want to load data.
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5. Select Modify Essbase user sto determine which Hyperion Essbase users can
access the Hyperion Esshase application and database into which you are
loading data.

The Essbase Users dialog box is displayed:

Available: Selected:
Joe Salmozar Katherine Giza
Patty MclGee
”
=
[
[
< Back | Mest » | Cancel | Help |

Figure 8-3: Selecting Hyperion Essbase Users

OLAP Integration Server retrieves the list of available users from the
following places:

OLAP Integration Server retrieves the
For a(n) users from the...

New application Hyperion Essbase server. All users can create new
applications and databases on the Hyperion Essbase
server, for example, sys.

Existing application | Hyperion Essbase application

New database Hyperion Essbase application
Existing database Hyperion Essbase database
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6. To alow auser to access the Hyperion Essbase application and database, do
the following:

a. IntheAvailablelist box, select the user.

b. Click the _>| button to move the user to the Selected list box. To move
all users, click the ] button.

c. When the names of all users who should access the Hyperion Essbase
application and database are in the Selected list box, click Next.

7. If you want to select specific dimensions not to update, in the Essbase
Application and Database dialog box, select | ncremental Update.

By default, OLAP Integration Server updates all dimensions and members.
Updating an existing Hyperion Essbase outline incrementally is faster than
updating all dimensions and members.

During adataload, you can select to update or not to update only members of
the dimension tagged as accounts.

If you choose to update the Hyperion Essbase outline incrementally, the
Incremental Update dialog box is displayed:

Incremental Update E

1E3)

1E3)

[il-

Don't Update. |

O Toatal Expenzes
-1 Inventory
#-O Ratias

< Back I Mest » I Cancel | Help |

Figure 8-4: Updating a Hyperion Essbase Outline Incrementally
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a. To prevent OLAP Integration Server from updating a dimension or
member, select the dimension or member and click Don’t Update.

Note: You must update at least one member from each dimension
when performing adata load. If more than one hierarchy
exists in the Hyperion Esshase outline, you can perform an
incremental update.

b. After you mark al dimensionsor membersthat OL AP Integration Server
should not update, click Next.

Y ou can use the LOADDATA command in OLAP Command

ﬁ Interfaceto load data. For moreinformation about this command,
see the Hyperion Integration Server System Administrator’s
Guide.

8. Select the calc script to use to cal cul ate the Hyperion Essbase database.

If you select... OLAP Integration Server...

None Does not run a cal ¢ script on the Hyperion Esshase
database.

Default Runs the default calc script that is specified for the

Hyperion Essbase database. If you have not specified
acalc script to use as the default, Hyperion Essbase
uses standard calculation order to calculate the
database.

Any other calc script | Runsthe selected calc script on the Hyperion Essbase
database.

Thecalc script that you chooseisrun after OLAP Integration Server loads data
into the Hyperion Essbase database. The cal ¢ script determines how Hyperion
Essbase calculates the data val ues in the database.

For more information on calculation and on calc scripts, see the Hyperion
Essbase Database Administrator’s Guide.

9. Click Next and proceed to “Procedure 3: Loading Data Immediately” on
page 8-8.
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Procedure 3: Loading Data Immediately

Y ou can schedule a dataload to start immediately or to start at a specific date and
time. If you choose to start a dataload immediately, the Data Load dialog box is
displayed. The dialog box provides you with dynamic statusinformation about the
dataload and specific messages for any errors or warnings that may occur. If
you encounter an error during the load, you can stop the data load. Hyperion
Integration Server executes data loads on the computer that is running OLAP
Integration Server.

» To load dataimmediately:

1. Make surethat you perform the tasks described in “ Procedure 2: Starting a
Data Load” on page 8-4.

After you complete the appropriate dialog boxes (as directed in “ Procedure 2:
Starting a Data Load” on page 8-4) and click Next, the Schedule Essbase
L oad dialog box is displayed.

Schedule Essbase Load E
 Load Essbase
............ Expart Optians
& How
' Only Save Load Script Save Scripts... |
' Scheduls

D ate:

| danay . 17, 2000 =]
Time:

[11:5:00 PM =
Frequency:

IDnce j

< Back I Finizh I Cancel | Help

Figure 8-5: Loading Data Immediately
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script click Save Scripts.

The Save Script Asdialog box is displayed:

Save Script As

Enter script name

IDemo

o]

Cancel |

Figure 8-6: Saving a Script

a. Enter the new script name.

Chapter 8

If you want to save the script to a different name or change the name of the

b. Click OK to return to the Schedule Essbase L oad dialog box.
In the Schedule Essbase L oad dialog box, select Now.

Click Finish.
The Data L oad dialog box is displayed:

Data Load E
OLAP kodel: Application: Time Started:
TEC todel testing Mon Jan 17 07:08:19 P
IMetaoutline: D atabase:
TBC Metaoutline Test

Meszage Summary

Load Type | Loaded | Rejected | Time Elapsed | Statuz |
000000 Load Initialization in Frogress

[rata Load 960 R40 ooz Data Load in Progress
00021 Load completed.

1D | Meszage | Dimension

| OLAP Metaoutline Me... | Fielational [ atat

Connecting to the metadata RDBMS...
Connecting to the source RDEMS. .
Connecting to the Essbaze server...
Feading the Metaoutline. ..

Feading the OLAP Maodel...
Successfully loaded isqad:testing: T est.

1

Figure 8-7: Displaying Data Load Information
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5. If you encounter an error and want to stop the dataload, click Stop Load. (The
Stop Load button is displayed during the load.)

If you want to restart the data load, return to step 1 of this procedure.

If you load only datainto the Hyperion Essbase outline and the load fails, rejected
dimensions and members arelisted inadataload. txt file.

If you load both members and data into the Hyperion Essbase outline and the | oad
fails, argject text file for each rejected dimension and member is created. The
name of each file consists of the name of the relevant dimension followed by the
leaf node number of the dimension or member that did not load.

For example, as shown in Figure 8-8, if the three member levels of the
Product dimension do not load, three . txt files are created; for example,
PRODUCT 0.txt (PRODUCT.DIET), prODUCT 1.txt (PRODUCT_ID),
and PRODUCT 2.txt (PRODUCT_DESC).

E-Ef Product

£} LOOKUP_PRODUCT DIET Leaf Mode 0
FH LOOKUP_PRODUCT PRODUCT_ID Leaf MNode 1
“..f] LooKUP_PRODUCT PRODUCT_DESC _F Leaf MNode 2

Figure 8-8: Leaf Node Example

For each rejected file, a corresponding rulesfile is created. Therulesfile
created for the rejected member levelsin Figure 8-8 are PRODUCT 0.rul
(PRODUCT.DIET), proDUCT 1.rul (PRODUCT_ID), and PRODUCT 2.rul
(PRODUCT.DESC).

Both . txt and . rul files arelocated in the ISHOME\ loadinfo default
directory. To place the files in a directory other than the default directory, set the
ISLOADINFO environment variable to point to a different directory

e If the datadoes not load successfully, see “Problems with Loading Members
or Data’ on page 10-6.

e For information on starting an unscheduled member load, see “ Procedure 3:
Loading Members Immediately” on page 7-13.
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Procedure 4: Scheduling a Data Load

Y ou can schedule a dataload to start immediately or to start at a specific date and
time. Hyperion Integration Server executes scheduled dataloads on the computer
that isrunning OLAP Integration Server.

» To schedule adataload to run at a specific time and date:

1. Makesurethat you perform thetasksdescribed in “ Procedure 3: L oading Data
Immediately” on page 8-8.

The Load Essbase When dialog box is displayed:

Schedule Essbase Load E
 Load Essbase
Export Options
' Now
' Only Save Load Script Save Scripts... |
& Scheduls

Date:
| danay . 17, 2000 =]
Timne:
[11:5:00 PM =

Frequency:

wieekly
— [Monthly

< Back I Finizh I Cancel | Help

Figure 8-9: Scheduling a Data Load

2. Select Schedule.

3. If Hyperion Integration Server is on a computer running UNIX, proceed to
Step 5.

4. If Hyperion Integration Server ison acomputer running Windows NT, start
the Schedule service as described in “ Starting the Windows NT Schedule
Service Automatically” on page 7-17.
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8-12 |

5. Enter the timeto run the data load:

a. IntheDate text box, enter the date. Use the mm/dd/yyyy format, for
example, January 17, 2000.

b. Inthe Time text box, enter thetime. Usethe hh:mm: ss format, for
example, 23:59:00. To schedule aload to run at midnight, enter
00:00:00, asmidnight is considered the first hour of aday, not the last
hour of aday. Note that Hyperion Integration Server uses a 24-hour clock.

c. From the Frequency drop-down list box, select how frequently to
perform the data load. You can schedul e data loads to be performed one
time, every day, every week, or every month.

To perform a data load more than once a day, you must implement each
load individually.

6. Click Finish.

OLAP Integration Server loads the datainto the Hyperion Essbase database as
scheduled.

Note: |f the data does not load successfully, see “Failure of a Member
Load or Data L oad” on page 10-4.

To delete a scheduled data load, see “ Deleting Scheduled Member and Data
Loads’ on page 7-21. To view a scheduled data load, see “Viewing Scheduled
Member and Data Loads’ on page 7-18.
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Creating Drill-Through
Reports

This chapter describes how to create Drill-Through reports that users can access
using Hyperion Essbase Spreadsheet Add-in. This chapter contains the following
topics:

“About Drill-Through” on page 9-1

“Adding a Report” on page 9-2

“ Specifying the Contents of a Report” on page 9-5
“Specifying the Format of a Report” on page 9-15

“ Specifying Spreadsheet User Actions’ on page 9-20
“Working with Reports’ on page 9-25

About Drill-Through

When you create a Hyperion Essbase database, you do not use all of the data of
the associated relational data source. Instead you choose the data that spreadsheet
usersare most likely to want and summarize it in away that is useful to them. For
example, you might summarize the amount of root beer sold in each state. The
summaries enable spreadsheet users to compare sales across states and regions.
They can answer questions such as Which state sold the most root beer in January?
and Which state sold the most root beer in July?
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Some spreadsheet users may need more detailed information to create a strategy
toincrease root beer sales. They need to answer questions such asWhat aretheten
lowest performing storesin California? What are the addresses of the stores? What
are the store managers names? Thisinformation is not stored in the Hyperion
Essbase database, but it is stored in the relational data source.

To view the relevant data, spreadsheet users must drill through to the relational
data source and view therelationa datain the context of the datain the Hyperion
Esshase database.

Hyperion Integration Server enables you to define Drill-Through reports. A
Drill-Through report is based on an intersection level (member combination)
that spreadsheet users can double-click to start the drill-through process. Then
spreadsheet users view or customize pre-defined Drill-Through reports that
retrieve the relevant detail columns from the relational data source. Because
OLAP Integration Server captures the metadata necessary to create the Hyperion
Esshase outline, it returns the Drill-Through report in the context of the data that
spreadsheet users are viewing.

Adding a Report

Y ou can create a new Drill-Through report and then add intersection levels and
columns, or you can base a Drill-Through report on an existing report and vary
specific intersection levels and columns. Y ou can create multiple reports for a
single intersection, and spreadsheet users can select which report to view.

This topic contains the following subtopics:
e “Creating a New Report” on page 9-3
e “Copying an Existing Report” on page 9-5

For more information on intersection levels and columns, see “ About I ntersection
Levels’ on page 9-6.
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Creating a New Report

The Drill-Through report that you create is what spreadsheet users see when they
drill fromacell in Hyperion Essbase Spreadsheet Add-in through to the relational
data source.

» To create a new report:

1. From the menu toolbar, select Edit > Drill-Through Reportsto display the
Drill-Through Reports dialog box.

Dirill-Through Reports E
Cloze I
Help |
Eddif... |
Add...
Welete, |
ove llp |
Imve Mg |
Sort Wrder,... |

Figure 9-1: Drill-Through Reports Dialog Box

2. Click Add to add a new report.

A dialog box opens, prompting you to confirm that you want to add a new
report.
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3. Click Yes.

A new report is displayed in the Drill-Through Reports dialog box. By
default, the new report is named Report1.

Dirill-Through Reports E

=-E3 Repart 1 Claze

Help

[l
=
i
=
o
f=
=]
=
jun )
o
=]
=]
[w]
o
=
3
=3
E

Edit...

Delete...

ove llp

Imve Mg

[t
B
ETEN

Sort Order...

Figure 9-2: New Drill-Through Report

4. If youwant torenamethereport, see“Renaming aReport in the Drill-Through
Reports Dialog Box” on page 9-25.

5. If you want to add intersection levels and columns to the report, see “ Adding
Intersection Levels’ on page 9-10 and “ Adding Drill-Through Columns’ on
page 9-12.
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Copying an Existing Report

If you want to base a Drill-Through report on an existing report and vary afew
intersection levels and columns, you can save time by copying the existing report.

» To copy an existing report:

1.
2.

From the menu toolbar, select Edit > Drill-Through Reports.

Inthe Drill-Through Reportsdialog box, select the Drill-Through report that
you want to copy.

Click Add.

A dialog box opens, prompting you to confirm that you want to copy the
report.

Click Yes.

If you want to renamethe report, see“ Renaming aReport in the Drill-Through
Reports Dialog Box” on page 9-25.

If you want to add or change intersection levels and columnsin the report, see
“Adding Intersection Levels’ on page 9-10 and “ Adding Drill-Through
Columns” on page 9-12.

Specifying the Contents of a Report

Y ou must define the contents of a Drill-Through report. The defining process
includes adding intersection levels and columns and setting query governors to
control the amount of data retrieved from the relational data source. This topic
contains the following subtopics:

e “About Intersection Levels’ on page 9-6

e “Following the Rulesfor Intersection Levels’ on page 9-7

e “Determining Where to Set an Intersection Level” on page 9-7
e “Reviewing Sample Drill-Through Reports’ on page 9-8

e “Adding Intersection Levels’ on page 9-10

e “Adding Drill-Through Columns’ on page 9-12

e “Setting the Size of a Query” on page 9-14
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About Intersection Levels

96

A Drill-Through report is made up of intersection levels and columns. An
intersection level defines the point at which users drill through, that is, the value
that they double-click in Hyperion Essbase Spreadsheet Add-in to view the report.
For example, you can define areport for the intersections of the Quarter, SALES,
REGION, PRODUCT_ID, and Month member levels of TBC Metaoutline.

When a spreadsheet user double-clicks a data cell that correspondsto a
Drill-Through intersection level, OLAP Integration Server retrieves from the
relational data source the detail datathat is specified in the default Drill-Through
report. For example, to view areport defined on the intersection level described in
the previous paragraph, a spreadsheet user can select any of various intersections,
such asthe intersection of Qtrl, Profit, Retail, Connecticut, Bottles, 100-20, 1997
or the intersection of Qtr2, Sales, Retail, Florida, Cans, 100-30, 1996.

An intersection level affects al members of the specified dimension at

the specified level. For example, if you set an intersection level on
PRODUCT_GROUP_ID in the Product dimension, you are setting the
intersection level at level 1. (Levels are numbered from the leaf node, level
0, toward the root.) All members of the Product dimension at level 1 and
lower can access the Drill-Through report. Thus, both the members under
PRODUCT_GROUP_ID and the members under Diet (because Diet is also
alevel 1 member of the Product dimension) can access the report.

e

= E# Product
=-ff LOOKUP_PRODUCT PRODUCT_GROUP_ID
- -fB LooKUP_PRODUCT.PRODUCT_ID
B0 Dist

Figure 9-3: Intersection Levels
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Following the Rules for Intersection Levels

Use the following rules when setting intersection levels:

e Inasingle Drill-Through report, you can add only one intersection level for
each dimension. For example, in the Market dimension in TBC Metaoultline,
you can define an intersection level for REGION or for STATE but not for
both.

e You can select only one measure for each report. To create multiple reports,
each with a different measure, create the first report, make a copy of the first
report, and change the measure of the copied report.

To make areport applicable to all measures, select the dimension tagged as
accounts.

e Intersection levels are inherited. A child of adimension or member inherits
the Drill-Through level defined for its parent. Thus, to define a different
intersection level for the child of the dimension or member, you must create a
new report.

Determining Where to Set an Intersection Level

When, in a metaoutline, you define an intersection level, you determine the
Hyperion Essbase cells from which a spreadsheet user can drill through.

e Dimension: If you set an intersection level for a metaoutline dimension,
spreadsheet users can drill through from any intersection that contains the
related Hyperion Esshase dimension. For example, if you set an intersection
level at Product, spreadsheet users can drill through from any level in the
Product dimension. Thus, spreadsheet users can double-click any datavalue
that involves a member of the Product dimension, such as Colas or 100-10.

To make areport applicable to all measures, select the dimension tagged as
accounts.

e Member: If you set an intersection level for a metaoutline member level,
spreadsheet users can drill through from any intersection that contains a
Hyperion Essbase member that is based upon the designated metaoutline
member level. For example, if you set an intersection level at PRODUCT _ID,
spreadsheet users can double-click any data va ue that involves a member
based upon PRODUCT _ID, such as 100-10 or 100-20.
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e Neither adimension nor a member: If you do not set an intersection level
for adimension or for any member of the dimension, spreadsheet users can
drill through from any member of the dimension (assuming that you have
defined at Drill-Through report on at least one intersection level for the
Hyperion Esshase database).

Reviewing Sample Drill-Through Reports

-8

This topic uses a simple metaoutline of four dimensions and illustrates how the
setting of various intersection levels affects the reports that spreadsheet users see.

The sample metaoutline contains the following dimensions and member levels:

El-E3 TBC Metacutine
EI'# ear

B Time. Quarter

M
[

-5 Product
FE LOOKUP_PRODUCT PRODUCT_DESC

=-FB LOOKUP_PRODUCT PRODUCT_ID

g

E..

ﬁ; Market

=-FB LOOKUP_MARKET REGION
g

E..

E-Ef Measures
B0 Profi
B0 I argin
ofle SALES
e COGS

Figure 9-4: Simple Drill-Through Metaoutline

Now, suppose that you define the following reports:

e A demographics report on the intersection level of MONTH, PRODUCTS,
CHANNEL, and ACCOUNTS. To view the demographicsreport, spreadsheet
users drill down to any month under any quarter. Because the demographics
report is defined at the dimension level for all dimensions other than TIME,
spreadsheet users can view the report at any level of the Products, Channel
and Accounts dimensions. The worksheet excerpt in Figure 9-5 shows a
spreadsheet at the highest level from which spreadsheet users can view the
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demographics report. If users drill down on one of the dimensions, they can
still view the demographics report. If they drill up from one of the MONTH
members, they cannot view the demographics report.

ACCOUNTS
CHAMMEL PRODUCTS QTR_1Feb | 107573.2571
QTR_1Jan | 306131.7676
QTR_1Mar | 127575.3608

Figure 9-5: Simple Demographics Report

e Anadvertising report on the intersection level of MONTH and PRODUCTS.
If areport is not defined on adimension or on any member of the dimension,
spreadsheet users can view the report from any member of the dimension.
Therefore, spreadsheet users can view the advertising report from any member
of CHANNEL or Accounts as well as from any member of PRODUCTS and
any member of the TIME dimension that is located at or below the month
level.

e A financia report on the intersection level of MONTH and COGS. To view
the financia report, spreadsheet users drill down to any month under any
guarter and to the COGS member of the ACCOUNTS dimension. If areport
isnot defined on adimension or on any member of the dimension, spreadsheet
users can view the report from any member in the dimension. The worksheet
excerpt in Figure 9-6 shows a spreadsheet at the highest level from which
spreadsheet userscan view thefinancial report. If spreadsheet usersdrill down
on one of the dimensions, they can still view the financial report. If they drill
up from COGS or from one of the MONTH members, they cannot view the
financial report.

COGE CHAMMEL GTR_1Feb 25857.34
QTR_1Jan 81171.76
QTR_1Mar 30823.72

Figure 9-6: Simple Financial Report
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Adding Intersection Levels

An intersection level defines the point at which users drill through, that is, the
value that they double-click in Hyperion Essbase Spreadsheet Add-in to view
areport. For more information, see “ About Intersection Levels’ on page 9-6,
“Determining Where to Set an Intersection Level” on page 9-7, and “ Reviewing
Sample Drill-Through Reports’ on page 9-8.

» To add anintersection level to a Drill-Through report:
1. Create areport.
See “Adding a Report” on page 9-2.

2. IntheDrill-Through Reportsdialog box, select OL AP I nter section L evels,
and click Add.

The Add new intersection levels dialog box is displayed. The left list box
contains all dimensions and member levels defined in the metaoutline. Each
member level inthe metaoutline represents a set of members at the same level
in the Hyperion Essbase database. The right list box contains all intersection
levels defined in the Drill-Through report.

Add new intersection levels for Report "“TBC Drill- Through'.

;Ej w 0k
Efj Warket I_I
E“;’” Product Cancel |
E-Ef Measures
E-Ef Scenario > | ul=e |
[
v |
<€ |

Figure 9-7: Adding Intersection Levels

9-10 W Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Chapter 9

3. Click al ® signsto expand dimensions and see member levels.

4. Select the member level to add, and click _>| to movethe member level tothe

right list box.

To move al member levelsto the right list box, click |}

To remove a member level from the right list box, click .

To remove al member levels from the right list box, click 35

Figure 9-8 shows the set of intersection levels defined in the TBC

Drill-Through report.

Add new intersection levels for Report "“TBC Drill- Through'.

- Year

- @=-FB Time. Quarter

E-E Market

- =-E LOOKUP_MARKET.REGION

-5 Product
. E=-Ef LooKUP_PRODUCT.PRODUI
=B LOOKUP_PRODUCT FRO
ﬁ'{‘ Measures
o

= Scenario

1 ] ©

P

L4

[
[
[«

Time. Quart oK. |
i
Bl LOOKUP_MARKET STATE Lo |
EHLooKUP_PRODUCT.FRO..
- Help
B LOOKUP_SCENARIO.SEE. . —I

Figure 9-8: Intersection Levels

5. Click OK toreturn to the Drill-Through Reports dialog box.
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Adding Drill-Through Columns

A Drill-Through columnisthe relational database column that OLAP Integration
Server retrieves when a spreadsheet user double-clicks an intersection level.
Columns contain detail information that is not available in the Hyperion Esshase
database, for example, alist of store managers.

Y ou can usein the Drill-Through report any column of the OLAP model that is not
marked as Hidden, including columns marked as Drill-Through.
» To add columnsto a Drill-Through report:
1. Create areport.
See “Adding a Report” on page 9-2.
2. Addtheintersection levels.
See “Adding Intersection Levels’ on page 9-10.

3. IntheDrill-Through Reportsdiaog box, select Drill-Through Report
Columns, and click Add.

The Add new report columnsdialog box is displayed. Theleft list box
contains all tables and columns that are not marked as Hidden in the OLAP
model. The right list box contains all columns defined in the Drill-Through

report.
Add new report columns for report. ‘“TBC Drill-Through' E

R T TABLE 0K, |
B~ LOOKUP_MARKET
@  LOOKUP_PRODUCT Cancel |
B LOOKUP_SCENARIO
B Time > | _ Hee |
]
B |
<4 |

Figure 9-9: Adding Drill-Through Columns
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4. Click the * signsto expand the tables.

5. Sdlect the column to add and dlick | to move the column to the right list
box.

To add all columnsto the right list box, click >,
To remove a column from the right list box, click .

To remove al columns from theright list box, click 3

Figure 9-10 contains the set of columns for the TBC Drill-Through report.
These columns provide spreadsheet users aview of details on store
demographics and store managers.

Add new report columns for report. ‘“TBC Drill-Through' E
= FACT_TABLE =] FACT_TABLE.COGS oK |
-EH3 ADDITIONS BRI LOOKUP_MARKET.CITY_ID
% COGS EHLooKuUP_MeRKET POPUL... | Cancel |
] ENDING_INVENTORY EE|LOOKUP_M&RKET STATE
| . Help
~EE] MARKETING : | EE]LOOKUP_MARKET STATE... —l
3 Misc | |FElLooKUP_MARKET STATE..
-FH] OPENING_INVENTORY M
ime.Y'ear
- PavROLL
-FH saLEs e |
B~ LOOKUP_MARKET - « |

--EB ATTRIBUTE_REGION_RE
-F ATTRIBUTE_SIZE_SIZE_|
-FR ATTRIBUTE_STATE_STA
-E oy

-EH oTvDp

--F POPULATION
REGION

;|
P REGION_TYPE _l;l
4 I I »

Figure 9-10: Sample Drill-Through Report Columns

6. Click OK to return to the Drill-Through Reports dialog box.
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Setting the Size of a Query

A query governor controls the duration and the size of the queries that OLAP
Integration Server makesto the data sourceto retrieve columns. A query governor
prevents you from retrieving more data from the external data source than you
want or need. For example, a column in the relational data source may contain
10,000 rows, and you may not want to retrieve all rows. Morethan 10,000 rowsis
difficult for spreadsheet usersto view.

If you set aquery governor, OLAP Integration Server stopsthe query if it istaking
too long or retrieving too much data. For example, if you set 200 as the maximum
number of rowsto beretrieved, OLAP Integration Server retrieves approximately
200 rows. If the query triesto retrieve more than 200 rows, OLAP Integration
Server stops the query and displays an error message.

Note: If aquery stops because it reaches the time or row limit specified in
the query governor, the spreadsheet user views incomplete data.
» To set aquery governor:
1. IntheDrill-Through Reportsdialog box, select areport name.
2. Click Edit to open the Report properties dialog box.
3. IntheReport properties dialog box, select the Governors tab.

Report properties for ‘City Level Information’. E

General Governors |

b aximum time per query (in seconds)
|1 00

b aximum rows per query

|20q

QK I Cancel | Help

Figure 9-11: Setting a Query Governor
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4. Inthe Maximum time per query (in seconds) text box, enter the maximum
query time.

For example, to stop a query that takes longer than 100 seconds, type 100.

5. Inthe Maximum rows per query text box, enter the maximum number of
rowsto retrieve.

For example, to stop a query that retrieves more than 200 rows, type 200.
6. Click OK.

Specifying the Format of a Report

Y ou can define the format of areport by specifying the order of columns and rows.
This topic contains the following subtopics:

e “Specifying Column Ordering” on page 9-16
e “Specifying Row Ordering” on page 9-18

Y ou can, if you want, allow spreadsheet usersto specify the order of columns and
rowsin aDrill-Through report. See * Customizing a Report” on page 9-21.
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Specifying Column Ordering

Columns are displayed in areport left to right in the order in which they arelisted
top to bottom in the list box of the Drill-Through Reports dialog box. Arrange
the columnsin thelist box in the order in which you want them to be displayed in
the Drill-Through report; for example, in Figure 9-12, CITY isthefirst column,
MKTTY PE the second, and DEMOMI X the third.

X Microsoft Excel - Book1 =] E3

ﬁﬁile Edit Wiew Insert Format Tools Data ‘Window Essbase Help ;Iilﬂ
DEEERY I B I (n--a®[=r08u@[s
Arial <0 v B 7 U = 8%, % A
Al | =| CITY

A [ B | c | D E | F [T s [H [ 1 |=
CITY METTYPE DEMOMI INCOMEG PRODDES MANAGEFPHOME  YEAR |MONTH|
Mew Londe Test Mkt White, His S0K-75K. Kool Cola Aurora Be: 408-555-121997  Feb
Mew Londo Test Mkt White, His S0K-75K. Kool Cola Aurora Be: 408-555-121997  Mar
Mew Londc Test Mkt White, His S0K-75K Kool Cola | Aurora Be:408-555-121997  Jan
Mew Cana: Minor Mkt White, Asi 78K-100K Kool Cola Aurora Be: 408-555-121997  Feb
Mew Cana: Minor Mkt White, Asi 78K-100K Kool Cola Aurora Be: 408-555-121997  Mar
Mew Cana: Minor Mkt White, Asi 75K-100K Kool Cola Aurora Be:408-555-121997  Jan
Danbury  Major Mkt White, His 75K-100K Kool Cola Aurora Be: 408-555-121897  |Feb
Danbury  Major Mkt White, His 75K-100K Kool Cola Aurora Be: 408-555-121997 | Mar
Danbury  Major Mkt White, His 75K-100kK Kool Cola | Aurora Be:408-555-121997  Jan

LAJ|I\J

14| =
144 [»[pi]s,Sheet Shestl 7 Sheetz f Sheets /' 4] | | Jj
Ready [ e e e e e e

Figure 9-12: Column Order in TBC Drill-Through Report
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1. From the menu bar, select Edit > Drill-Through Reports to open the

Drill-Through Reports dialog box.

2. IntheDrill-Through Reportsdiaog box, click the [+ sign adjacent to the
Drill-Through report that you want to work with.

3. Fromthelist of the columnsin the report, select a column, for example,

MARKET.CITY.
El-E3 City Level Infarmation Cloze I
(-3 OLAP Intersection Levels
El-E3 Diil-Through Report Columns Help |
; m FACT_TABLE.SALES
Edif... |
Add... |
Delete... |
Move Up |
Move Down |
Sort Order... |

Figure 9-13: Positioning Columns

4. Click Move Up or Move Down to position the column.

5. When the columns are in the correct order, click Close.
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Specifying Row Ordering

Y ou can determine the order in which Hyperion Essbase Spreadsheet Add-in
displaystherowsit retrieves; for example, you can sort the contents of the
MARKET.CITY column in descending order (from highest to lowest value).
This sort presents the cities in reverse alphabetical order, from New London
to New Canaan to Danbury and produces the following report:

X Microsoft Excel - Book1 =] E3
ﬁﬁile Edit Wiew Insert Format Tools Data ‘Window Essbase Help _|ﬁ||1|
DEEERY s BT - A€ s 81 0D ||+
Arial 0w -BZUl=SE=E=E8 %, @8 E H.A LT

F2 | =| Aurora Bearsley
A [ B | ¢ [ o | E [ F I & | H [ 1 —
| 1 |CITY WKTTYPE DEMOMIX INCOMEG PRODDES MANAGEFPHONE  YEAR MONTH 7=
|2 [Mew London  Test Mkt ‘White, His 50K-75K Kool Cola [&urora Bed408-555-121996 Feh

| 3 |Mew London  Test Mkt White, His S0k-78kK Kool Cola Aurora Be: 405-555-121936 tlar

| 4 |Mew London  Test Mkt White, His S0k-78K Kool Cola Aurora Be: 405-555-121996 Jan

| & |Mew Canaan Minar Mkt White, Asi 78k-100K Kool Cola Aurora Be: 405-555-12 1996 Feh

| B |Mew Canaan Minar Mkt White, Asi 78k-100K Kool Cola Aurora Be: 405-555-12 1996 tlar

| 7 |Mew Canaan Minar Mkt White, Asi 78k-100K Kool Cola Aurora Be: 405-555-12 1996 Jan

| 8 |Danbury tajor Mkt White, His 78K-100K Kool Cala Aarara Be: 403-555-12 19596 Feh

| 9 |Danbury tajor Mkt White, His 78K-100K Kool Cala Aarara Be: 403-555-12 19596 tlar |

| 10 | Danbury tajor Mkt White, His 78K-100K Kool Cala Aarara Be: 403-555-12 19596 Jan

11

12

13
14 <

14 [ 4 [» [#f Shests 5 sheets & shestl £ Shestz £ Shests / 4] | [»]
Ready | ] ) o | o —) -

Figure 9-14: Row Sort Order in TBC Drill-Through Report

If you do not determine the sort order, spreadsheet users view datain the order
determined by therelational data source. SQL Server, for example, sorts members
in ascending order by default.
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» To determine the order of rows:

1. From the menu bar, select Edit > Drill-Through Reports to open the
Drill-Through Reports dialog box.

2. IntheDrill-Through Reportsdiaog box, select the Drill-Through report to
sort.

3. Click Sort Order to open the Set Sort Order dialog box.

The Set Sort Order dialog box displays in the left list box the columns
included in the report. Theright list box displays the columns for which you
want to set the row sort order.

Set Sort Order for "TBC Drill-Through'. E
Colurnn Colurnn | Order By | QK I
LOOKUP_MARKET.REGIOM. .. Time. Quarker Azcending

BB LOOKUP_MA&RKET REGION... EEILOOKUP_PROD...  Ascending G |

BBl LOOKUP_SCEMARIOD.SCENA... ;I EELOOKUR MARE. . Rt Help |
]

il Move Up |

iI [ve Do |

Order By... |

Figure 9-15: Setting Sort Order
4. Select the columnfor which you want to set the sort order and click > ltoadd
the column to the right list box.
To sort al columns, click 2] to add all columns to the right list box.
To remove a column from the right list box, click <.

To not sort any columns, click <! to remove all columns from the right
list box.
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5. Select acolumnintheright list box, and click Order By.
The Order By dialog box is displayed.

Order By E
Aszcending 0k I
Descending

Cancel |

Help |

Figure 9-16: Order By Dialog Box

6. Select the sort order: Ascending (A to Z, 0to 9) or Descending (Z to A,
9t00).

7. Click OK to return to the Set Sort Order dialog box.
8. If youwant to set the sort order for another column, repeat steps4, 5, 6, and 7.
9. Click OK to return to the Drill-Through Reports dialog box.

Specifying Spreadsheet User Actions

Y ou can specify the actions that spreadsheet users can perform after they open a
Drill-Through report. Y ou can determine whether spreadsheet users can customize
the report, use a specific server running OLAP Integration Server, and use a
database username and password to log on to the relational data source. Thistopic
contains the following subtopics:

e “Customizing a Report” on page 9-21
e “Specifying the OLAP Integration Server Name” on page 9-22
e “Specifying a Database Username and Password” on page 9-23
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Customizing a Report

Y ou can allow spreadsheet users to customize a Drill-Through report that they
seein their worksheet. For example, they can choose to exclude certain columns
or to change row and column ordering. If you do not allow spreadsheet users to
customize areport, they see all columns that you specify and use the row and
column ordering that you specify.

» To allow spreadsheet users to customize a report:

1. IntheDrill-Through Reportsdialog box, select the report that you want to
allow spreadsheet users to customize.

2. Click Edit to open the Report properties dialog box.

Report properties for ‘City Level Information’. E

General | Gaovernors I

¥ &llow spreadsheet users to customize this repart

QK I Cancel | Help |

Figure 9-17: Allowing Spreadsheet Users to Customize a Report

3. Select Allow spreadsheet usersto customizethisreport.

To prevent spreadsheet users from changing the report, deselect Allow
spreadsheet usersto customizethisreport.

4. Click OK.
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Specifying the OLAP Integration Server Name

Y ou can determine whether spreadsheet users must enter the name of the server
running OLAP Integration Server to which they want to connect. If spreadsheet
users do not enter the OLAP Integration Server name, Hyperion Essbase
Spreadsheet Add-in connects to the OLAP Integration Server specified in the
Drill-Through report. If you have many users, connecting them to different OLAP
Integration Servers enables you to balance the load across multiple OLAP
Integration Servers and increase performance.

If you use multiple servers, each server must use the Open Database Connectivity
(ODBC) data source name for the external data source and the ODBC data source
name for the OLAP Metadata Catal og that are specified in the OLAP model.

For exampl e, suppose that you create the OL AP model on Integration Serverl and
use OLAP_TBC as the ODBC data source name for the external data source and
OLAP_MD asthe ODBC data source name for the OLAP Metadata Catalog. On
Integration Server2, you must also use OLAP_TBC as the ODBC data source
namefor the external datasourceand OLAP_MD asthe ODBC data source names
for the OLAP Metadata Catal og.

» To aways prompt spreadsheet users for the name of the server running OLAP
Integration Server:

1. Inthe OLAP Metaoutline main window, select the metaoutline name, for
example, TBC Metaoutline.

2. Right-click the metaoutline name and, from the pop-up menu, select
Properties.

The OLAP Metaoutline Properties dialog box is displayed.
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3. Select the Drill-Through Reportstab.

OLAP Metaoutline Properties E

Generall D atabaze Measuresl Uzer Defined Dimensionsl Governars Dl Through Reports |

W Alwaps prompt for DLAP Integration server name

V¥ lways prompt for database username and password

QK I Cancel | Help |

Figure 9-18: Prompting for the Name of the Server Running
Hyperion Integration Server

4. Select Always prompt for OLAP Integration Server name.

To have spreadsheet users connect to the default OLAP Integration Server,
deselect Always prompt for OLAP Integration Server name.

5. Click OK.

Specifying a Database Username and Password

Y ou can determine whether spreadsheet users must enter ausername and password
to log on to the data source. This requirement can provide alayer of security by
determining who can access the relational data source.

If you do not choose to prompt for the database username and password,
spreadsheet users who connect to the relational database use the username and
password of the user who created the Drill-Through report. The user who created
the report may have higher access privileges than are appropriate for spreadsheet
users.
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» To require spreadsheet users to specify a username and a password:

1. Inthe OLAP Metaoutline main window, select the metaoutline name, for
example, TBC Metaoutline.

2. Right-click the metaoutline name and, from the pop-up menu, select
Properties.

The OLAP Metaoutline Properties dialog box is displayed.
3. Select the Drill-Through Reportstab.

OLAP Metaoutline Properties E

Generall D atabaze Measuresl Uzer Defined Dimensionsl Governars Dl Through Reports |

W Alwaps prompt for DLAP Integration server name

V¥ lways prompt for database username and password

QK I Cancel | Help |

Figure 9-19: Prompting for a Username and Password

4. Select Always prompt for database username and password.

To alow spreadsheet usersto use the database username and password of the
user who created the Drill-Through report, deselect Always prompt for
database username and password.

5. Click OK.
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Working with Reports

Y ou can rename reports, delete reports, and delete parts of areport. This topic
contains the following subtopics:

“Renaming a Report in the Drill-Through Reports Dialog Box” on page 9-25
“Renaming a Report in the Report Properties Dialog Box” on page 9-26

“Deleting an Individual Report, an Intersection Level,
or aDrill-Through Column” on page 9-27

“Deleting All Intersection Levels or Drill-Through Columnsin a Report” on
page 9-27

Renaming a Report in the Drill-Through
Reports Dialog Box

» Torename areport in the Drill-Through Reports dialog box:

1.

From the menu bar, select Edit > Drill-Through Reports to open the
Drill-Through Reports dialog box.

In the Drill-Through Reports dialog box, click the report name to put the
dialog box in edit mode, =- O o |

Type the new report name.

See “ About Naming” on page 3-9.

Press the Enter key, or select another object in the Drill-Through Reports
dialog box. Repeat steps 2, 3, and 4.
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Renaming a Report in the Report
Properties Dialog Box

» To rename areport in the Gener al tab of the Report properties dialog box:

1. From the menu bar, select Edit > Drill-Through Reports to open the
Drill-Through Reports dialog box.

2. IntheDrill-Through Reportsdialog box, select the report for which you
want to change the name.

3. Click Edit to open the Report properties dialog box.

Report properties for ‘City Level Information’. E

General | Gaovernors I

¥ &llow spreadsheet users to customize this repart

QK I Cancel | Help

Figure 9-20: Renaming a Report

4. Inthe Name text box, type the new name.
See “About Naming” on page 3-9.
5. Click OK.

9-26 W Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Chapter 9

Deleting an Individual Report, an Intersection
Level, or a Drill-Through Column

» To delete areport, an intersection level, or a Drill-Through column:

1.

From the menu bar, select Edit > Drill-Through Reports to open the
Drill-Through Reports dialog box.

Inthe Drill-Through Reportsdialog box, select thereport, intersection level,
or column to delete.

Click Delete.

A dialog box opens, prompting you to confirm that you want to delete the
report, intersection level, or column.

Click Yes.

Deleting All Intersection Levels or
Drill-Through Columns in a Report

» Todelete al intersection levels or Drill-Through columns:

1.

From the menu bar, select Edit > Drill-Through Reports to open the
Drill-Through Reports dialog box.

In the Drill-Through Reports dialog box, select the phrase OLAP
Intersection Levelsor the phrase Report Drill-Through Columns.

Click Delete.

A dialog box opens, prompting you to confirm that you want to delete &l
intersection levels or columns.

Click Yes.

Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide m 9-27



Chapter 9

9-28 W Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Troubleshooting

Thischapter suggests solutionsfor problemsthat you may discover while working
with Hyperion Integration Server Desktop. It contains the following topics:

“Problems with Creating, Validating, Saving, or Deleting Metaoutlines’ on
page 10-1

“Problems with Transformations’ on page 10-2
“Problems with Filters’ on page 10-3

“Failure of aMember Load or Data Load” on page 10-4
“Problems with Loading Members or Data’ on page 10-6

Problems with Creating, Validating, Saving, or
Deleting Metaoutlines

If you experience a problem while creating, validating, saving, or deleting a
metaoutline, consider the following:

If no OLAP model islisted inthe Existing tab of the Welcome dial og box, you
cannot create a metaoutline. Make sure that you are connected to the correct
OLAP Metadata Catalog. See the Hyperion Integration Server Installation
Guide for information on connecting to OLAP Metadata Catal og.

If you experience a problem with validating a metaoutline, check to be sure
that you are following the validation rules. (See “Validating M etaoutlines
Manually” on page 2-19.) If you are following the conditions for validating a
metaoutline, view eachinvalid dimension separately. Be surethat the structure
of each dimension looks appropriate. (See “Viewing Sample Dimensions,
Members, and Hyperion Essbase Outlines’ on page 3-30.)
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You cannot save or delete a metaoutline if other users are reading it; you
receive a message that the metaoutline iswrite locked. You can do any of the
following:

— Save or delete the metaoutline later.

— UseFile > Save Asto save the metaoutline to a different name. See
“Saving a Metaoutline to a Different Name” on page 2-27.

— Delete the locks. See the Hyperion Integration Server System
Administrator’s Guide for information on working with locks.

Are users unableto drill through? If you del ete a metaoutline that was used to
build a Hyperion Essbase outline, you can no longer drill through on the
Hyperion Essbase outline. See Chapter 9, “ Creating Drill-Through Reports.”

Problems with Transformations

If member names, dimension names, or data are not being transformed correctly,
consider the following:

10-2 W

If you set a member to use two-pass cal culation and the calculation is not
working, remember that, although two-pass calculation is a property that
you can give to any member, two-pass cd culation works only on members
of the accounts dimension, dynamic calc members, and dynamic calc and
store members. If you tag any other type of member as two-pass cal culation,
Hyperion Essbase ignores the tag. See the Hyperion Essbase Database
Administrator’s Guide.

If you cannot tag a member as dynamic time series, check to be sure that you
have set the date-part in the OLAP model. For information on defining
transformations for columns, see the Hyperion Integration Server Desktop
OLAP Model User’s Guide.

If aformulaisworking incorrectly, check the syntax carefully. OLAP
Integration Server does not validate formula syntax. Errorsin aformula do
not display until OLAP Integration Server cal culates the Hyperion Essbase
database. For more information about formula options and built-in functions,
see the Hyperion Essbase Database Administrator’s Guide.
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Problems with Filters

If member names, dimension names, or data are not being filtered correctly,
consider the following:

Areyou connected to OLAP I ntegration Server? Seethe Hyperion Integration
Server Installation Guide for information on starting Hyperion Integration
Server Desktop.

Isthe correct metaoutline filter selected for both the member |oad and the data
load? You must use the same metaoutline filter for the member load and the
dataload.

If the filter includes extra conditions, make sure that the filter did not inherit
conditions from the * Default filter. If thefilter did inherit conditions, deletethe
inherited conditions. See “Creating a Member Filter Interactively” on

page 5-13.

If you experience a syntax error, use the Verify button in the Member Load
Filtering or Measure Properties dialog box to check the syntax. View asample
of the dimension on which you defined thefilter and check the generated SQL.
See “Viewing Sample Dimensions, Members, and Hyperion Essbase
Outlines’ on page 3-30.

Is the generated SQL correct? Use the Sample command to check the
generated SQL to make surethat thefilter doeswhat you expect (see“ Viewing
Sample Dimensions, Members, and Hyperion Essbase Outlines’ on

page 3-30) or check the SQL statementsin the Hyperion Integration Server
log file (see the Hyperion Essbase Database Administrator’s Guide).

Many filter errors do not show up until you perform amember or adataload. See
also “Problems with Loading Members or Data’ on page 10-6.
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Failure of a Member Load or Data Load

If amember load or dataload isfailing, consider the following:
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Is the metaoutline valid? See “ Validating Metaoutlines Manually” on
page 2-19.

Are the external data source, OLAP Metadata Catalog, OLAP Integration
Server, and Hyperion Essbase all running correctly? See the Hyperion
Integration Server Installation Guide.

Can you connect to the external data source, OLAP Metadata Catalog, OLAP
Integration Server, and the Hyperion Essbase server without using Hyperion
Integration Server Desktop? See the Hyperion Integration Server Installation
Guide.

Are you experiencing a problem viewing a sample outline? Check to be sure
that you set the query governors appropriately, especialy if you have shared
members in the sample outline.

I's the Hyperion Essbase outline into which you are loading members or data
in use? See the Hyperion Esshase Database Administrator’s Guide.

Did you attempt to perform a transformation on members to which you
assigned aliases? You cannot perform transformations on members to which
you assign aliases. Use OLAP Model to perform needed transformations. For
information on defining transformations, see the Hyperion Integration Server
Desktop OLAP Model User’s Guide.

Did you receive atime-out error? See the Hyperion Integration Server System
Administrator’s Guide.

Doestheload run for along time and then stop? Set query governorsto control
the duration and size of the queriesthat OL AP Integration Server makesto the
external data source. See “Using Query Governors’ on page 7-5.

If you perform a member load and the Hyperion Essbase outline contains no
members, check to seeif you used an invalid member name, such as
#MISSING. See “About Naming” on page 3-9.
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e If aload stops after loading some members or some data, check the reject
text file that is automatically created. The reject text file lists all dimensions
and members that were not loaded into the Hyperion Essbase outline. See
“Procedure 3: Loading Data Immediately” on page 8-8. You can a so check
thelsolation Level settinginthe Hyperion Essbase database. Seethe Hyperion
Essbase Database Administrator’s Guide.

e Isascheduled load not appearing in the Scheduled Jobs dialog box? Make
sure that you started the Schedule service on Windows NT. See “ Starting the
Windows NT Schedule Service Automatically” on page 7-17.

e Do you receive an operating system error when you try to schedule aload?
Make sure that at . exe iscorrectly identified in the operating system path
(This program schedules programsto run at acertaintime.). If at . exe isnot
correctly identified, correct the problem, restart OL AP I ntegration Server, and
reschedule the load.

e Do some error messages contain error code numbers but no text? If so,
check themessage . txt fileinthe ISHOME\ess1ib\bin directory. Thefile
contains a column of error code numbers and a column containing the text of
error messages.

e View the OLAP Integration Server log file for information about why aload
failed. See the Hyperion Integration Server System Administrator’s Guide.

e View the Hyperion Essbase error log file for information about why aload
failed. See the Hyperion Essbase Database Administrator’s Guide.

e View the ODBC log of the data source that is experiencing a problem. If you
do not know how to view the ODBC log, see the ODBC documentation.

e Didyou try to schedule amember or data load after someone deleted the
Batch directory? You must have aBatch directory in the is directory to
schedule loads.

See also “Problems with Loading Members or Data” on page 10-6.

If you experience a problem with the external data source, OLAP Metadata
Catalog, OLAP Integration Server, or Hyperion Essbase, contact the appropriate
database administrator. After the problem is fixed, restart the load.
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Problems with Loading Members or Data

If you have problems loading members or data, check the following:
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If you perform a member load and the Hyperion Essbase outline contains no
members, check to seeif you used an invalid member name, such as
#MISSING. See “ About Naming” on page 3-9.

Did you perform the load correctly, but some members or data are missing?
Check the following:

— Didyouset thebuildlevel incorrectly? See* Setting the Member and Data
Load Build Level” on page 4-25.

— Isthefilter filtering out more than you want it to? View the dimensions
that contain the incorrect member levels. See “Viewing Sample
Dimensions, Members, and Hyperion Essbase Outlines’ on page 3-30.

— Did you specify that OLAP Integration Server should create duplicate
members as shared? See “Handling Duplicate Member Names® on

page 4-6.

— Isany nameinthe datasource longer than 80 characters? Aliasnamesand
UDAs must be fewer than 80 characters. You can use the SUBSTRING
function in OLAP Model to extract the 80 or fewer characters that
you want to use in a member name. For information on defining
transformations for string columns as substrings, see the Hyperion
Integration Server Desktop OLAP Model User’s Guide.

Did you get a shared member error during loading and are some shared
members not |loaded? Make sure that all load properties and filters defined on
real members are also defined on shared members. See Chapter 4, “ Setting
Load Properties,” Chapter 5, “Working with Filters,” and Chapter 6, “ Setting
Hyperion Essbase Properties.”

Did you perform the load correctly, but there is no datain the Hyperion
Essbase database? Check the filters. If afilter filters out all data, a value of
#MISSING is displayed in the Hyperion Essbase database. See “ Creating a
Member Filter Interactively” on page 5-13.
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e Didyouremember to calculate the databefore viewing it in Hyperion Essbase
Spreadsheet Add-in? See the Hyperion Essbase Database Administrator’s
Guide.

e Doestheload run for along time and stop? Set query governorsto control the
duration and the size of the queriesthat OLAP Integration Server makesto the
external data source. See “Using Query Governors’ on page 7-5.

e |If theload stops after loading some membersor data, check theregject text file
that is automatically created. The reject text filelists al dimensions and
members that were not loaded into the Hyperion Essbase outline. See
“Procedure 3: Loading Data Immediately” on page 8-8. You can also check
thelsolation Level setting in the Hyperion Essbase database. Seethe Hyperion
Essbase Database Administrator’s Guide.

e View the Hyperion Integration Server log file for information about the load.
For information on the log file, see the Hyperion Integration Server System
Administrator’s Guide.

e View the Hyperion Essbase error log file for information about the |oad.
For information on the log file, see the Hyperion Essbase Database
Administrator’s Guide.

See also “Failure of aMember Load or Data Load” on page 10-4.

Report any problem to the appropriate database administrator (DBA)—the DBA
for the external data source, the DBA for OLAP Metadata Catalog, the DBA for
OLAP Integration Server, or the DBA for Hyperion Essbase. After the problemis
fixed, restart the load.
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#MISSING. See missing data.

Accountsdimension. In Esshase, a dimension type that makes accounting
intelligence available. Y ou can tag only one dimension in adatabase as Accounts.
Esshase does not require an Accounts dimension. The Accounts dimension in
Hyperion Integration Server becomes the Accounts dimension in the Esshase
database that you create with Hyperion Integration Server.

In Hyperion Integration Server, an optional dimension you create asacontainer for
measures data values. See also M easure dimension, measures.

Add Joinsmode. In Hyperion Integration Server, an OLAP Architect statein
which you can draw lines to define joins between objects in the OLAP model.
See also Move mode.

administrator. Anindividual who installs and maintains the system, including
setting up user accounts and security. See also database administrator, system
administrator.

aggregate. See consolidate.
alias. In Essbase, an alternate name for a dimension or member.

alias column. In Hyperion Integration Server, acolumn in the data source that
contains the aliases for a member in the metaoutline.

aliastable. In Essbase, atable that stores aias names for members and
dimensions.

alternate name. Seeadlias.

ancestor. In Esshbase, amember or dimension that has members below it.
For example, in Sample Basic, Qtr2 and Y ear are ancestors of April.

M Glossary-1

©
o)
7))
7))
Q
=
<
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application. In Essbase, acontainer for one or more Essbase databases and files,
such as calc scripts and data load rules that are related to the databases. See also
Esshase database.

ARBORPATH. In Esshase, an environment variable that specifies the Essbase
root directory.

Architect. See OLAP Architect.

attribute. In Esshase, adimension or member property that determines
functionality. For example, a member that has the two-pass attribute is
recal culated on a second calculation pass through the outline.

block. In Essbase, the primary storage unit. A data block is a multidimensional
array representing the cells of all dense dimensions.

Builder. See OLAP Builder.

calc script. In Essbase, atext file containing a set of instructions telling Essbase
how to calculate a database.

Catalog. See OLAP Catalog

cell. In Esshase, aunit of data representing the intersection of each dimension
combination in amultidimensional database. Also, the intersection of arow and a
column in a spreadsheet. See also intersection level.

child. In Essbhase, amember that has aparent aboveit in the database outline.
See also sibling, parent.

cleansing. See datacleansing.

column. Inrelationa databases, avertical part of atable. Also known as afield.
A column contains all the values for a specific type of information. For example,
acolumn may contain the employee name or employee number for each employee.
Every column has a name and a particular datatype. Contrast with row.

Command Interface. See OLAP Command Interface.

concatenation. An operation that joins two characters or stringsin the order
specified, forming one string whose length is equal to the sum of the lengths of the
two characters or strings. For example, the strings New Y ork and Library, when
concatenated become New Y orkLibrary.

condition. Inrelational databases, a data extraction criterion. For example, you
can apply acondition to extract only the datathat starts with the letter A. See also
filter.
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consolidate. In Essbase, a method of computing the data relationships for all
parent/child combinations within a dimension. A consolidation is typicaly
additive, but can be any type, including multiplication or subtraction. For example,
in Sample Basic, the Y ear dimension hasfour children: Qtrl, Qtr2, Qtr3, and Qtr4.
Essbase consolidates these members by adding them to calculate Y ear. The term
“consolidate” is also known as “aggregate” and “roll up.”

consolidation level. In Essbase, the level in the database outline up to which
Essbase consolidates the database.

database. A collection of related information organized in such away that a
computer program can quickly select desired pieces of data. See also Essbase
database, relational database.

database administrator. Anindividua who administers databases, and may also
design, maintain, and create databases. See also administrator, See also system
administrator.

database outline. Seeoutline.
data block. See block.

data cleansing. The process of making inconsistent data consistent. Exampl es of
inconsistent data are data in which some values are incorrect or not of the correct
datatype.

datafile. In Essbase, afile containing data blocks. Essbase generates data files
upon loading data and stores them on disk. Datafiles are also known as pagefiles.

dataload. In Esshase, the process of populating an Esshase database with data.
Loading data establishes actual values for the cells defined by the database's
structural outline. Contrast with member load.

dataload rules. In Esshase, a set of operations that Essbase performs on data
from an external data source file as the data is loaded.

data point. Seecdll.

data source. External data, such as atext file, spreadsheet file, or relational
database, that is loaded into an Essbase database.

data value. Seecell, metadata

DateTimetransformation. A set of instructions that defines how to change or
reformat arelational database DateTime datatype to your choice of date format.

DBMS. See RDBMS.
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dense dimension. In Esshase, adimension likely to contain data for every
combination of dimension members, for example, the Time dimension in Sample
Basic. Contrast with sparse dimension.

descendant. In Essbase, any member below a parent.
detail member. Seeleaf member.

dimension. In Essbase, a data category. Sample Basic includes the dimensions
Time, Accounts, Product, Market, and Scenario. In an Esshbase database outline,
the dimensions represent the highest consolidation level. See also outline.

dimension member. In Essbase, the highest member in a dimension branch.
Dimension members define the dimension. For example, in Sample Basic, Time,
Accounts, Product, Market, and Scenario are dimension members. See also |eaf
member.

dimension branch. In Hyperion Integration Server, acollection of dimension
tables organized in a hierarchical structure, with one of the dimension tables
joining directly to the fact table. A dimension branch defines a single, potential
Essbase dimension in the metaoutline. See also dimension table.

dimension build rules. In Essbase, aset of operations similar to dataload rules.
But, instead of loading data, the dimension build rules modify the outline based on
datain the external data source file. See also member load.

dimension table. InHyperion Integration Server, acontainer inthe OLAP model
for one or more relational tables that define apotential Essbase dimension. When
adimension table joins to another dimension table, forming a dimension branch,
the dimension is composed of the columns of al of the dimension tablesin the
dimension branch. See also dimension branch.

dimension type. In Essbase, a dimension tag that allows a dimension to use
predefined functionality. For example, dimensions of the type Time have
predefined calendar functionality for accounting.

In Hyperion Integration Server, attributesin the OL AP model and metaoutline that
define which tables form the Essbase A ccounts, Time and standard (default)
dimensions.

duplicate member. In Hyperion Integration Server, the second occurrence of a
member namein adatasource. Y ou can determinewhether OLAP Builder ignores
duplicate members or adds them as shared members. See also shared member.

Glossary-4 W Hyperion Integration Server Desktop OLAP Metaoutline User’s Guide



Glossary

Dynamic Calc And Store members. In Essbase, members that Esshase
calculates when you first retrieve the values. Essbase then stores the calculated
valuesin the database. Subsequent retrieval s of Dynamic Calc And Store members
do not require calculating. See also Dynamic Calc members.

Dynamic Calc members. In Essbase, members that Essbase calculates at
retrieval time. Esshase discards calculated values after the retrieval request is
complete. See also Dynamic Calc And Store members.

dynamic calculation. In Essbase, a calculation that occurs when you retrieve
data on a member that has been tagged as Dynamic Calc or Dynamic Calc And
Store. The member’s values are calculated at retrieval time instead of being
precal culated during batch calculation.

Esshase database. A repository of data within Essbase that contains a
multidimensional data storage array. Each database consists of a defined storage
structure (a database outline), data, security definitions, and other associated files,
such as calc scripts or dataload rules. See also application.

Essbase outline. See outline.

Essbase server. A database server that locates and accesses multidimensional
data

fact table. In Hyperion Integration Server, a container for one or more relational
tables that define the data values for each dimension intersection in the OLAP
model. For example, if the OLAP model contains PRODUCTS, REGION, and

Y EAR dimensions, thefact table might include datavaluesfor the number of units
of Product A soldin New Y ork in January.

field. InEssbhase, avalueor iteminadatasourcefilethat isloaded into an Essbase
database.

In relational databases, a space allocated for a particular item of information.
Fields are the smallest units of information you can access. Most fields have
certain characteristics associated with them. For example, somefieldsare numeric
whereas others are textual. Every field has a name.

file delimiter. Oneor more characters, such asacommal(,), separating fieldsina
data source.

filter. In Essbase, amethod for controlling accessto database cells. A filter isthe
most detailed level of security, allowing you to define the varying access levels
that users can have to data.
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In Hyperion Integration Server and in relational databases, a method for
controlling which data you retrieve from arelational database. For example,

you can choose to retrieve only productsin the Product A product family. A filter
contains one or more conditions. See also condition.

foreign key. Inrelational databases, a column whose data values correspond to
the values of akey column in another relational table. See also key column,

primary key.

formula. In Essbase, a combination of operators and functions as well as
dimension names, member names, and numeric constants. Formulas are
used to calculate relationships between any members of an Essbase database.
@VAR (Actual, Budget) ; isan example of aformula.

generation. In Essbase, alayer of ahierarchical tree structure that defines
member relationships in an Essbase database. Essbase numbers generations
incrementally from the dimension member (generation 1) towards the leaf
members.

generation name. In Esshase, a unique name describing a generation.

header record. One or more records at the top of a data source. Header records
describe the contents of the data source.

hierarchy. In Essbase, atree structure relationship between membersin the
database outline, beginning with the dimension member and going down to the
leaf members.

In Hyperion Integration Server, a predefined tree-structure relationship for some
types of dimensionsinthe OLAP model and al dimensionsin the metaoutline. For
example, you can create a Time dimension hierarchy that contains YEAR, QTR,
and MONTH.

index. In Essbase, a method of retrieving Essbase data based on sparse
dimensions. Also refers to the index files, collectively.

In relational databases, pointersthat are logically arranged by the values of akey.
Indexes optimize access to relational data.

index cache. In Essbase, a buffer in memory that holds index pages.

index entry. In Essbase, a pointer to an intersection of sparse dimensions. Each
index entry pointsto ablock on disk and locates a particular cell within the block
by means of an offset.

index file. In Essbase, afile Essbase usesto store dataretrieval information.
It resides on disk and contains index pages.
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index page. InEsshase, asubdivision of anindex file containing entriesthat point
to data blocks.

input block. In Essbase, atype of data block that has at least one loaded data
value.

input data. In Essbase, any datathat isloaded from a data source and is not
generated by calculating the database.

Integration Server. The server component of the Hyperion Integration Server
product family. The Integration Server uses the information stored in the OLAP
Catalog to extract from the data source, the dimension names and member names
needed to build the Esshase outline. When the Essbase outline is compl ete,
Hyperion Integration Server extracts data from the data source, performs the
operations specified in the metaoutline, and loads the data into the Essbase
database.

integrity constraint. Inrelational databases, arule stating that each row should
have an entry for each required key column.

inter section level. In the Essbase Spreadsheet Add-in, an Essbase member
combination that defines a specific value. For example, the member combination
Actual, Root Beer, Sales, Jan, East represents the actual January sales value for
root beer in the Eastern region. See also cell.

join. Inrelational databases, arelationship between two tables based on matching
key column values.

join columns. In Hyperion Integration Server, two relationa table columns that
arejoined from onetableto another using, for example, the Table Propertiesdialog
box Physical Joins tab.

key column. Inrelational databases, a column or columns that form a unique
identifier for each row. For example, EMPLOY EE_ID might beakey column. See
also foreign key, primary key.

leaf member. InEssbase, amember that hasno children. Also referred to asdetail
member, level 0 member, and |eaf node. See also dimension member.

left pane. Inthe OLAP Builder main window, the area on the left that lets you
view alist of dimensions previously defined in the OLAP modd.

In the OLAP Architect main window, the area on the |eft that displays alist of the
tables and views available in your source relational database. See also right pane.
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level. In Essbase, alayer of ahierarchical tree structure that defines member
relationshipsin an Essbase database. Essbase numbers levels incrementally from
the leaf member (level 0) towards the dimension member.

In Hyperion Integration Server, the distance of a dimension table from the fact
tablein the OLAP model. For example, if atableislevel 2, it is separated from the
fact table by two links.

level 0 block. In Essbase, adatablock created for sparse member combinations
in which all sparse members are leaf members.

level 0 member. Seeleaf member.
level name. In Essbase, a unique name describing alevel, for example, Lev2.

linked reporting object (LRO). In Essbase, an externa filelinked to adata cell
in an Essbase database. LROs can be cell notes or files.

load attributes. InHyperion Integration Server, aset of rulesthat determinewhat
actions OLAP Builder performs on member names and data as they are loaded.

load data. See dataload.

load member. In Hyperion Integration Server, amember in a user-defined
dimensioninto which Integration Server |oads data. Only user-defined dimensions
need load members. For all non user-defined dimensions, Integration Server
knows how to load members and data into the Essbase database. See also member
load.

logical column. In Hyperion Integration Server, a column created by
mani pul ating the data in one or more physical columns. See also column.
Contrast with See also physical column.

logical table. Inrelational databases, atable created by manipulating columns
from one or more physical tables. Thelogical tableis only aview of the data; the
columns remain stored in the original tables and are not physically duplicated in
the logical table. See also view. Contrast with physical table.

MDDB. A multidimensional database, such as an Esshase database. See also
multidimensional.

Measure dimension. In Hyperion Integration Server, a dimension that, by
default, maps to the Accounts dimension in the Essbase outline. See also
Accounts dimension, measures.
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measures. In Hyperion Integration Server, the datavalues that you want to track,
such as UNIT_PRICE or DISCOUNT. By default, measures values map to the
Accounts dimension in the OLAP model, which maps to the Measure dimension
in the metaoutline, which in turn maps to the Accounts dimension in the Essbase
outline. See also Accounts dimension, Measure dimension.

member. In Essbase, a discrete component within adimension. For example,
in Sample Basic, Y ear, Profit, and Diet are members. Members can also be
dimensions; for example, Y ear isamember as well as adimension.

In Hyperion Integration Server, members in the metaoutline map to membersin
the Essbase outline. However, one member in the metaoutline can represent
multiple members in the Essbase outline.

member combination. In Essbase, alist of member names used to specify a set
of data at the intersection of two or more dimensions. Use the cross-dimensional
operator -> (a hyphen followed by aright-angle bracket) to specify a member
combination. For example, the actual sales data for the month of January in
Sample Basic is Sales->Jan->Actual.

member consolidation. See consolidate.

member load. The process of adding new dimensions or members (without data)
to an Essbase outline. See also load member. Contrast with dataload.

metadata. The datathat describesthe dataval ueswithin adatabase. For example,
in Essbase, dimension names and member names are metadata.

metaoutline. In Hyperion Integration Server, atemplate containing the structure
and rules for creating an Essbase outline from an OLAP model.

missing data. In Essbase, adatalabel (#M1SSING) indicating that no data exists
in the labeled location. The value labeled #MISSING issimilar to anull value but
not the same as zero.

model. See OLAP mode!.

Move mode. In Hyperion Integration Server, an OLAP Architect state in which
you can pick up, move, and drop objects in the OLAP model. See also Add Joins
mode.

multidimensional. A method of referencing data through three or more
dimensions. An individual data value is the intersection of one member from
each dimension. See also MDDB.
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normalization. The process of grouping and removing redundancy from data so
that each entity isinits appropriate placein the database and only in its appropiate
place.

numeric transformation. In Hyperion Integration Server, a set of instructions
that define how to change or reformat arelational database numericfield type. For
example, you may choose to divide numeric data by 100.

ODBC. Open Database Connectivity: standardized application programming
interface (API) technology that allows applications to access multiple third-party
databases.

OLAP. SeeOnline Analytical Processing (OLAP).

OLAP Architect. InHyperion Integration Server, atool used to design and create
an OLAP model based on arelationa data source.

OLAP Builder. InHyperion Integration Server, atool used to create one or more
metaoutlines from an OLAP model. The metaoutline determines the contents and
structure of your final Essbase database. Using the metaoutline, you can create an
Essbase outline and load datainto it.

OLAP Catalog. InHyperion Integration Server, arelational database containing
metadata describing the nature, source, location, and type of data that you are

pulling from therelational data source. The OLAP Catalog also generatesthe SQL
statements and the information required to generate an Essbase database outline.

OLAP Command Interface. In Hyperion Integration Server, acommand-line
tool that you can use to perform common OL AP Builder operations on the Essbase
outline and the data in the Essbase database. For example, you can use the
LOADDATA command to load data.

OLAP model. InHyperion Integration Server, alogical model (star schema) that
you create from tables and columnsin arelational database. Y ou can then use the
OLAP mode to generate the structure of a multidimensional database.

OLTP. SeeOnline Transaction Processing (OLTP).

Online Analytical Processing (OLAP). A method of multidimensional,
multi-user, client-server computing for users who need to analyze consolidated
enterprise datain real time. OLAP systems feature zooming, data pivoting,
complex calculations, trend analyses, and modeling.
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Online Transaction Processing (OLTP). OLTP applications are also
commonly referred to as data capture, data entry, or data collection applications.
OLTP applications allow an organization to capture the large amounts of data
resulting fromitsdaily activitiesbut provide limited capability for reporting on the
data.

outline. The structure that defines all elements of a database within Essbase. For
example, an outline contains definitions of dimensions, members, and formulas.

pagefile. Seedatafile.
parent. In Esshase, amember that has at |least one child. See also child.

pass-through transformations. In Hyperion Integration Server, afeature that
allows you to use functions specific to your relational database management
system (RDBMYS) to extract datavaluesfor columns. Y ou can provide a statement
that Hyperion Integration Server “passes through” to your RDBM Sas apart of the
SQL SELECT statement. Y ou provide the statement as a property of acolumn and
the pass-through feature returns a value for the column.

permissions. A user’saccess rightsto data.

physical column. Inrelational databases, a column that is stored in arelational
database. See also column. Contrast with logical column.

physical table. Inrelational databases, acombination of rowsand columns stored
in arelational database. Contrast with logical table.

pointer. Inrelationa databases, adata element that indicates the location of data
in storage.

predicate. See condition.

primary key. Inrelational databases, acolumn (key) that uniquely identifiesa
row, for example, Employee ID. See also foreign key, key column.

query governor. In Hyperion Integration Server, a parameter that you set to
control the time and size of the queries that OLAP Builder makes to the data
source.

RDBMS. relationa database management system: a system for accessing datain
arelational database.
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record. A set of information in a data source. Records are composed of fields,
each of which contains one item of information. A set of records constitutes
atable. A singlerecord constitutes arow in the table. For example, atable
containing personnel information might contain records (rows) that have three
fields: aNAME field, an ADDRESS field, and a PHONE_NUMBER field.

recursivetable. A source relational table that contains information in one
row that is aparent or child of information in another row. For example, in
arelational source table containing the columns EMPLOYEE_ID, NAME,
and MANAGER _ID, the columns EMPLOYEE_ID and MANAGER _ID are
recursive because MANAGER_ID refers back to the EMPLOYEE_ID. Using
Hyperion Integration Server, you can build an Essbase outline hierarchy from
arecursive source table.

relational database. A type of database that stores data in the form of related
tables. A single database can be spread across several tables, and can beviewed in
many different ways. Contrast with MDDB. See also database.

restructure. In Essbase, an operation to regenerate or rebuild the database index
and, in some cases, the datafiles.

right pane. Inthe OLAP Builder main window, the area on the right, in which
you build your metaoutline.

Inthe OLAP Architect main window, the areaon theright, in which you build your
OLAP model. See also left pane.

roll up. See consolidate.
root member. Seedimension member.
row. Seerecord. Contrast with column.

schema. Inrelational databases, alogical model that represents your relational
data. See also star schema, metadata

server. See Essbase server, Integration Server.

shared member. In Essbase, amember that shares storage space with another
member of the same name. This member has an attribute that designatesit as
shared. Shared members prevent Essbase from making extra calculations on a
member that appears in more than one location in the outline. See also duplicate
member.

sibling. In Essbhase, a child member that shares a common parent with another
child member (for example, in Sample Basic East and West are siblings). Seealso
child, parent.
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sparse dimension. In Esshase, adimensionwith alow probability that dataexists
for every combination of dimension members. For example, in Sample Basic, the
Product and Market dimensions are sparse. Contrast with dense dimension.

SQL. Structured Query Language. A computer language used to access datain
relational databases.

staging area. A database that you create to meet the needs of a specific
application. A staging areais a snapshot of one or more RDBM Ss.

star schema. InHyperionIntegration Server, alogical model that representsyour
relational datain aform that mirrors OLAP. A star schema contains a fact table
and one or more dimension tables.

Storage Manager. InEssbase, alayer of the Essbase server that handles mapping
of Essbase datato physical disk storage. The Storage Manager controls lock,
index, data, allocation, and transaction management functions.

string. A sequence of characters treated as a unit.

supervisor. In Essbase, atype of user who has full access to al applications,
databases, related files, and security mechanisms for a server.

system administrator. A person who maintains the hardware, software,
disk space distribution, and configurations for running software. See also
administrator, database administrator.

table. Inrelational databases, aform of data storage in which datais stored in
rows and columns.

Timedimension. In Essbase, adimensiontypethat defines how often you collect
and update data. Y ou may tag only one dimension as Time. Essbase does not
require a Time dimension.

In Hyperion Integration Server, an optional dimension you create asacontainer for
time-related and date-rel ated data.

transformation rules. In Hyperion Integration Server, a set of instructions that
define how to change or reformat the member names and data you extract from the
source relational database.

Two-Pass calculation. An Essbase attribute, used for recalculating an Accounts
member, aDynamic Calc member, or aDynamic Calc And Store member, after an
initial calculation.

unary operator. InEsshase, one of agroup of mathematical indicators (+, -, *, /,
%) that defines how Essbase consolidates the database outline.
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union. Inrelational databases, atype of join that combines the results of two
SELECT statements. A union is often used to merge lists of values contained in
two tables.

upper-level block. In Essbase, atype of datablock created for sparse dimension
member combinations, when at least one of the sparse dimension membersisa
parent.

user-defined attribute (UDA). In Essbase, a method you use to return, within
calc scripts and reports, lists of members with particular characteristics. You can
report on subsets of data values predefined in the database outline.

In Hyperion Integration Server, attributes you specify to create Essbase UDAS.
Y ou can explicitly add UDAs to the metaoutline, or you can derive UDASs from
the source relational table. For example, a PRODUCT _ID table may contain a

COLOR column from which you can obtain UDAS.

user-defined dimension. In Hyperion Integration Server, dimensions that you
explicitly createin OLAP Builder instead of obtaining and building them from the
relational data source.

user-defined member. In Hyperion Integration Server, members that you
explicitly createin the OLAP Builder instead of obtaining and building them from
the relational data source.

validation. In Essbase, a process of checking arules file against the outline to
make sure the rulesfileisvalid.

In Hyperion Integration Server, a process of checking the OLAP model and
metaoutine.

view. Inrelational databases, alogical table created by combining columns from
one or more tables. See also logical table.
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- (dashes)

consolidation property, 6-14
- (hyphens)

in names in scripts and formulas, 3-10, 4-17
- (minus signs), reversing, 4-28

Symbols

! (exclamation points), in names in scripts and
formulas, 3-10
" (double quotation marks)
for termsin scripts and formulas, 3-11
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in scripts and formulas, 3-10
#MISSING
aggregate filters and, 5-7
in Hyperion Esshase databases, 10-6
properties, time balance and, 6-19
reserved word, 10-4
skipping during calculations, 6-19
zeros, skip properties, 6-19
$SSUNIVERSESSS, reserved word, 10-4
% (percent signs)
consolidation property, 6-14
Hyperion Essbase formulas and, 6-26
in names in scripts and formulas, 3-10
() (parentheses)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
* (asterisks)
consolidation property, 6-14
in names in scripts and formulas, 3-10
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+ (plus signs)
consolidation property, 6-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
reversing, 4-28
. (periods)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
/ (slashes)
consolidation property, 6-14
in names in scripts and formulas, 3-10
: (colons), in names in scripts and formulas, 3-10
; (semicolons), in namesin scripts and formulas, 3-10
< (lessthan signs)
filter operator, 5-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
<= (lessthan or equal to), filter operator, 5-14
<>(not equa to) filter operator, 5-14
= (equal signs)
filter operator, 5-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
> (greater than signs)
filter operator, 5-14
in names in scripts and formulas, 3-10
>= (greater than or equal to), filter operator, 5-14
@ (at signs)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
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@VAR function, 6-21
@VARPER function, 6-21
[ 1 (brackets), in namesin scripts and formulas, 3-10
\ (backslashes)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
_ (underscores)
converting spacesto, 4-16
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
{ } (braces)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
| (vertical bars)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
~ (tilde), consolidation property, 6-14
- (dashes)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
' (single quotation marks)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
, (commas)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10

A

access

See also read access

setting, 2-25

specifying for OLAP models, 2-25
accessing

data sources, 2-4

help onling, xii
accounts dimensions

dense dimension, 6-6

dimension type, 6-4

measure tag, 3-24

properties, shared members and, 4-6

two-pass calculation and, 6-13, 10-2
Add New Intersection Levels dialog box, 9-10

Index-2 M

Add New Report Columns dialog box, 9-12
After, 2-11
aggregate filters, problems with, 10-6
aggregation options, defined, 1-3
aliases
assigning, 6-10
defined, 6-10
dimensions, setting, 6-10
members, setting, 6-10
reports and, 6-10
shared members and, 4-6
transformations and, 10-4
alphabetizing members, 4-23
applications
sample, xi
specifying, 7-9, 8-4
ascending sort, Drill-Through reports and, 9-18
assigning, aliases, 6-10
asterisks (*)
consolidation property, 6-14
in names in scripts and formulas, 3-10
at signs (@)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
at.exe, 10-5
automatic loads, scheduling, 7-16, 8-11
average, time balance property, 6-18

B

backslashes (\)

in dimension and member level names, 3-9

in dimension and member names, 4-14, 4-17
balance

beginning, 6-18

beginning and ending, 6-18
Batch directory, scheduled loads and, 10-5
batch processing, OLAP Command Interface, 1-9
beginning balance, 6-18
braces ({ })

in dimension and member level names, 3-9

in dimension and member names, 4-14, 4-17

in names in scripts and formulas, 3-10
brackets ([ ]), in names in scripts and formulas, 3-10
budgeting data, tracking, 3-7
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build level
problems with, 10-6
setting, 4-25

C

calc scripts
names with specia characters, 3-10, 3-11
setting default, 7-12, 8-7
UDAsand, 6-23
calculations
order of, 6-12
problems, 10-7
case
case-sensitive names, 3-9
case-sensitive searches, 4-14
changing, 4-21
characters
forbidden in aname, 3-9, 4-14, 4-17, 7-4
maximum in dimension names, 3-9
maximum in member names, 3-9
quoting in scripts and formulas, 3-10, 3-11
children
attaching a name to a parent, 4-19
shared members and, 4-6
chronological sorting, 4-15
closing balance, 6-18
collapsing, member branches, 2-12
colons(:), in namesin namesin scriptsand formulas,
3-10
columns
adding, 9-12
capitalization, xi
changing for measures, 4-29
creating dimensions from, 3-12
creating metaoutlines from, 3-12
deleting, 9-27
Drill-Through and, 9-2
example of, 9-16
ordering, 9-16
valid for Drill-Through reports, 9-12
command line, loading members from, 7-12
commas (,)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
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conditions
extra, problems, 10-3
measure filters and, 5-20
multiple, measure filters and, 5-20
multiple, member filters and, 5-15
selecting multiple, 5-15, 5-20
connecting
problems with, 2-6
to data sources, 2-4
to OLAP Metadata Catalog, 2-4
Connections menu
OLAP Metadata Catalog > Connect command,
2-28
OLAP Metadata Catalog > Delete Locks
command, 2-30
consolidation
defined, 1-3
drill down, 1-4
example, 1-3
members, 1-3
properties, list of, 6-14
properties, shared members and, 4-6
container filters, 5-3
converting, spaces to underscores, 4-16
copying
Drill-Through reports, 9-5
metaoutlines, 2-27
creating
calc scripts, 7-12, 8-7
dimensions from columns, 3-12
hierarchies, 3-11
hierarchies from columns, 3-12
Hyperion Essbase outlines, 7-1
Hyperion Essbase outlines using filters, 5-8
Hyperion Essbase users, 7-10, 8-5
measure dimensions, 3-24
measure filters, 5-7
measures, 3-11
measures from columns, 3-12
member filters, 5-6
member levels, 3-11
members, 3-7
metaoutline filters, 5-10
partitions, 6-1
row filters, 5-13, 5-17, 5-18, 5-22
UDAS, 6-24
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user-defined dimensions and members, 3-19
user-defined members, 3-19

curly braces. See braces

customer comparisons, 1-2

customizing, Drill-Through reports, 9-21

D

daily, member and dataload, 7-17
dashes (-)
consolidation property, 6-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
data
budget, tracking, 3-7
checking, 3-31
drill down, 1-4
drill up, 1-4
loading. See data loading
missing, in sample databases, xi
pivoting to change view, 1-4
storage properties, 6-8
Data L oad dialog box, 8-10
data loading
build level, setting, 4-25
calculation and, 10-7
daily, 7-16, 8-11
defined, 8-1
deleting scheduled loads, 7-18, 7-21
diagram, 7-3
failing, 10-4
Hyperion Essbase outlines, 7-1, 8-1
immediately, 8-8
load member and, 3-22
members, new, 4-8
metaoutline filters and, 5-4
OLAP Command Interface and, 7-12
other sources, 3-7
partia load, 10-5, 10-7
prerequisites for, 8-3
problems, 10-3, 10-6
rulesfile, 7-15, 8-10
scheduling, 8-11
scheduling problems, 10-5
starting, 8-4

Index-4 M

stopping, 8-10, 10-4
text file, 7-15, 8-10
viewing scheduled loads, 7-18, 7-21
weekly, 7-16, 8-11
data sources
accessing, 2-4
filtering data from, 5-1
Hyperion Essbase, specifying, 7-9, 8-4
names, OLAP Integration Server and, 9-22
OLTP databases, 1-5
sample, xi
security for Drill-Through reports, 9-23
spreadsheet files, 1-5
SQL, 1-5
text files, 1-5
tuning, 3-31
username, Drill-Through reports and, 9-23
workflow for transferring, 1-9
datavalues
See also measures
defined, 3-6
extracting from arelational data source, 7-3
filtering, 5-7
manipulating, 4-27
multiple in measure filters, 5-20
reversing signs, 4-28
scaling, 4-27
selecting multiplein filters, 5-15
databases. See data sources
dataload.txt, 8-10, 10-5, 10-7
date format, 7-17, 8-12
decimal points, moving, 4-27
default calc script, setting, 7-12, 8-7
Default metaoutline filter, 5-4

Delete an OLAP Model/Metaoutline dialog box, 2-29

Delete Locks command, 2-30

deleting
dimensions, 3-29
dimensions during loading, 7-9
measures, 3-29, 3-33
member levels, 3-29
member levels from hierarchies, 3-17
members during loading, 7-9
metaoutline filters, 5-12
metaoutlines, confirming, 2-29
metaoutlines, open by other users, 2-30
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metaoutlines, procedures, 2-28
OLAP models, open by other users, 2-26
problems with, 10-2
scheduled loads, 7-18, 7-21
dense dimensions
accounts, 6-6
defined, 6-6
time, 6-6
descending sort, Drill-Through reports and, 9-18
descriptions, of metaoutlines, 2-25
detail data
Drill-Through, 9-2
retrieving, 1-4
dialog boxes
Add New Intersection Levels, 9-10
Add New Report Columns, 9-12
DatalLoad, 8-10
Delete an OLAP Model/Metaoutline, 2-29
Dimension Properties, 4-7, 4-9, 6-6, 6-7, 6-9,
6-17, 6-24
Drill-Through Reports, 9-3
Edit Hierarchy, 3-5
Edit OLAP Metaoutline Transformations, 4-13,
4-18, 4-21
Enter the new dimension’s name, 3-20
Enter the new filter'sname, 5-10
Essbase Application and Database, 7-8, 8-4
Essbhase Users, 7-10, 8-5
Incremental Update, 7-11, 8-6
Measure Properties, 3-28, 4-27, 4-28, 4-30, 5-19,
5-22
Member Load, 7-14
Member Load Filtering, 4-24, 5-13, 5-17
Member Properties, 3-26, 6-11, 6-13, 6-15, 6-17,
6-20, 6-22, 6-24, 6-26
OLAP Metaoutline Properties, 3-22, 3-32, 7-6,
9-14
OLAP Model Properties, 2-26
Order By, 9-20
Preview Filter Results, 3-31
Preview Transformation Results, 3-31, 4-15
Report Properties, 9-14, 9-26
Sample Outline, 3-31
Save New Metaoutline, 2-24
Schedule Esshase Load, 7-13, 7-16, 8-8, 8-11
Scheduled Jobs, 7-19, 7-21
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Select aMember, 3-23
Select Values From, 5-15, 5-20
Services, 7-18
Set Sort Order, 9-19
View Existing Job, 7-20
View Filter, 5-12
dimension building. See member loading
dimension names, maximum length, 3-9
Dimension Properties dialog box
Account Info tab, 6-17
Member Info tab, 6-6, 6-7, 6-9
QOutline Build tab, 4-7, 4-9
UDA tab, 6-24
dimension storage, specifying, 6-6
dimension types
accounts, 6-4
standard, 6-4
time, 6-5
dimensions
adding, 3-1
aliases, setting, 6-10
creating, 3-12
creating extra, 3-7
defined, 1-3, 1-11, 3-3
deleting, 3-29
deleting during load, 7-9
dense, 6-6
Drill-Through reports, 9-7
examples, 1-3
extracting from arelational data source, 7-3
formulas on, 6-25
measures, creating, 3-24
members and, 1-3
minimum number in metaoutline, 2-20
naming rules, 3-9
OLAP model, not associated with, 3-7
ordering, 3-12
rejected, 7-15, 8-10, 10-5, 10-7
renaming, 3-25
sparse, 6-6
TBC Metaoutline and, 1-12
two-pass calculations, specifying, 6-12
types of, 6-3
use in consolidation, 1-3
user-defined, 3-7, 3-19
viewing sample, 3-30

W Index-5



Index

directories
default, 7-15, 8-10
default metaoutline, 2-3
is, 2-3
ISADMIN, 7-15, 8-10
dividing, values while loading, 4-27
documentation, xi, Xii
double quotation marks (")
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
termsin scripts and formulas, 3-10, 3-11
Drill, 9-12
drill down, 1-4
drill up, 1-4
Drill-Through columns
adding, 9-12
deleting, 9-27
deleting all, 9-27
example of, 9-16
ordering, 9-16
Drill-Through reports
copying, 9-5
creating, 9-1, 9-3
customizing, 9-21
database username and, 9-23
deleting, 9-27
deleting metaoutlines and, 2-29, 10-2
load balancing, 9-22
missing, 10-2
OLAP Integration Server name, 9-22
renaming, 9-25, 9-26
rows, sort order of, 9-18
security and, 9-23
valid columns for, 9-12
Drill-Through Reports dialog box, 9-3
Drill-Through, defined, 9-1
Drop leading/trailing spaces option, 4-16
dummy members, creating, 4-8
duplicate members
defined, 4-3
handling, 4-6
ignoring, 4-3
problems with, 10-6
dynamic calc and store, property, 6-8
dynamic calc, property, 6-8
Dynamic Time Series

Index-6 M

setting, 6-16
dynamic time series
problems with, 10-2

E

Edit Hierarchy dialog box, 3-5
Edit menu
Add Member as Child menu command, 3-20
Add Member as Sibling menu command, 3-21
Drill-Through Reports command, 9-3
Filter command, 4-23, 5-13, 5-17, 5-18, 5-22
Transformation command, 4-13
Edit OLAP Metaoutline Transformations dial og box,
4-13
Prefix/Suffix tab, 4-18
Replacetab, 4-21
ending balance, 6-18
Enter the new dimension’s name dialog box, 3-20
Enter the new filter's name dialog box, 5-10
equal signs (=)
filter operator, 5-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in names in scripts and formulas, 3-10
Essbase Application and Database dialog box, 7-8,
8-4
Essbase outlines. See Hyperion Esshase outlines
Essbase Users dialog box, 7-10, 8-5
Essbase. See Hyperion Esshase
exclamation points (1), in names in names in scripts
and formulas, 3-10
Exclusive Access
opening with, 2-5
saving with, 2-21
executable name
for Hyperion Integration Server Desktop, 2-3
expanding, member branches, 2-12
expense
property, 6-21
variance reporting property, 6-21
extra, dimensions and members, 3-7

F

fields, adding prefixes or suffixesto, 4-17
File menu
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Delete command, 2-29

New command, 2-4

Open command, 2-4

Print command, 2-28

Save As command, 2-23, 2-27

greater than or equal to (>=), filter operator, 5-14
greater than signs (>)

filter operator, 5-14

in names in names in scripts and formulas, 3-10

Validate command, 2-19 H
Filter command, 5-13, 5-17, 5-18, 5-22
filtering Help menu
data sources, 5-1 Help Topics command, xii
datavalues, 5-7 hierarchies
members, 5-6 consolidation and, 1-3

filters
See also metaoutline filters
conditions, creating multiple, 5-10
conditions, extra, 10-3
defined, 5-1
grouping, 5-4

Hyperion Essbase databases, creating multiple,

5-4

measure, example, 5-7

member, example, 5-3

metaoutline and dataloading, 5-3

naming rules, 3-9

operatorsin, 5-14

problems with, 10-6

row, creating, 5-13

row, defined, 5-6

shared members, problems and, 10-6

SQL, 5-3

viewing current metaoutline, 5-8

viewing in ametaoutline, 5-11
flipping, plus and minus signs, 4-28
forecast data, tracking, 3-7
forecasting, 1-4
formulas

dimensions and, 6-25

names with specia characters, 3-10, 3-11

problems with, 10-2

setting, 6-25

shared members and, 4-6

user-defined members and, 6-25

From Database Column, consolidation property, 6-14

G

generated SQL, viewing, 3-31
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creating dimensions from, 3-12

creating, example, 3-15

defined, 1-11

deleting member levels from, 3-17, 3-29

Hyperion Essbase

applications, specifying, 7-9, 8-4

data views supported, 1-2

database, no data loaded, 10-6

databases, creating multiple from asingle
metaoutline, 5-4

databases, specifying, 7-9, 8-4

databases, workflow for creating, 1-9

dimensions, defined, 3-3

displaying propertiesin main window, 2-13

example outline, 3-6

members, compared to metaoutline member
levels, 1-11

overview of, 1-3

properties, setting, 6-1

rejected dimensions or members, 7-15, 8-10,
10-5, 10-7

server, interaction with, 7-3

strategic planning, 1-4

users, creating, 7-10, 8-5

viewing properties, 6-27

viewing propertiesin columnar format, 2-14,
6-27, 6-28

viewing propertiesin condensed format, 6-27,
6-29

what if scenarios, 1-4

Hyperion Essbase outlines

building, x, 7-1

creating smaller, 4-25
loading, 7-1, 8-1
problems writing to, 10-4
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rejected dimensions or members, 7-15, 8-10,
10-5, 10-7
sample, problems with, 10-4
shared members, position of, 4-6
updating incrementally, 7-11, 8-6
viewing sample, 3-30
Hyperion Essbase server, uses, 1-3
Hyperion Integration Server
components, 1-8
defined, 1-5
OLAP Command Interface, defined, 1-9
OLAP Metadata Catalog, defined, 1-9
OLAP Modd, defined, 1-8
product family, defined, 1-5
product family, diagram, 1-7
standard user interface, defined, 1-8
workflow, 1-6, 1-9
Hyperion Integration Server Desktop
defined, 1-1
executable name, 2-3
hyphens
in dimension and member names, 4-14, 4-17
hyphens (-)
in dimension and member level names, 3-9
in names in scripts and formulas, 3-10

icons, 3-13
filter, 2-14
metaoutline startup, 2-3
transformation, 2-14
ignoring
duplicate members, 4-3
new members, 4-9
in, filter operator, 5-14
incremental member load, 7-11, 8-6
Incremental Update dialog box, 7-11, 8-6
intersection levels
adding, 9-6, 9-10
defined, 9-2
deleting, 9-27
deleting all, 9-27
rulesfor, 9-7
setting, 9-7
intersections, defined, 1-3

Index-8 M

invalid metaoutlines, saving, 2-19
isdirectory, 2-3
Isolation Level setting, 10-5, 10-7

J

jabs, viewing scheduled, 7-19, 7-21

L

label only property, 6-8
last time balance property, 6-18
leaf members, setting, 4-26
leaf node, exampl g, rejected dimensions or members,
7-15, 8-10
left frame
defined, 2-12
selecting multiple objects, 2-15
less than or equal to (<=), filter operator>, 5-14
less than signs (<)
filter operator>, 5-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
levels
Drill-Through reports and, 9-7
level 0 members, setting, 4-26
setting build, 4-25
linked partitions, 6-1, 6-3
load balancing, Drill-Through reports and, 9-22
load members
setting, 3-22
user-defined dimensions, 3-8
validation and, 2-21
load properties
build level, 4-25
columns, changing for measures, 4-29
defined, 4-1
dimensions, setting, 4-3
duplicate member names, 4-3
measures, manipulating, 4-27
measures, setting, 4-26
member names
converting spaces to underscores, 4-16
determining capitalization, 4-21
dropping spaces, 4-16
prefixes and suffixes, 4-17
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replacing, 4-13
Setting, 4-11
members, new, 4-8
reversing plus and minus signs, 4-28
shared members, 4-6
sorting members, 4-23
LOADDATA command, 8-7
loading
build level, setting, 4-25
daily, 7-16, 8-11
defined, 8-1
deleting scheduled loads, 7-18, 7-21
Hyperion Essbase outlines, 8-1
immediate data load, 8-8
immediate member load, 7-13
|load members and, 3-22
metaoutline filters and, 5-4
OLAP Command Interface and, 7-12
other sources, 3-7
scheduling, 7-16
scheduling data loads, 8-11
viewing scheduled loads, 7-21
weekly, 7-16, 8-11
loading process, 7-3
LOADMEMBER command
example of, 7-12
loads, viewing scheduled, 7-19
locking, Hyperion Essbase outlines and, 10-4

M

Match Whole Word option, in areplace operation,
4-14

maximum rows per query, setting, 7-6, 9-15
maximum time per query, setting, 7-6, 9-15
measure dimension, creating, 3-24
measure filters

See alsofilters

conditions and, 5-20

creating, 5-7

metaoutline filters and, 5-4

operatorsin, 5-14

typing directly, 5-23
Measure Properties dialog box

Filterstab, 5-19, 5-22

General tab, 3-28, 4-30

Transformations tab, 4-27, 4-28
measure tag, 2-20, 3-24
measures
adding, 3-1
column, changing, 4-29
creating dimensions from, 3-12
defined, 1-11, 3-6
deleting, 3-29, 3-33
Drill-Through reports and, 9-7
editing, 3-33
filtering, 5-7
maximum alowed, 2-20
metaoutlines, 3-14
ordering, 3-16
renaming, 3-25
renaming asingle, 3-27
required number in metaoutline, 2-20
user-defined members and, 3-7
viewing, 3-32
member filters
See also filters
creating, 5-6
metaoutline filters and, 5-4
operatorsin, 5-14
typing directly, 5-18
member levels
adding, 3-1
defined, 1-11, 3-5
example of, 3-5
ordering, 3-16
renaming, 3-25
Member Load dialog box, 7-14
Member Load Filtering dialog box
Filterstab, 5-13, 5-17
Ordering tab, 4-24
member |oad, stopping, 7-15
member |oading
build level, setting, 4-25
command line, 7-12
defined, 7-1
deleting scheduled loads, 7-18, 7-21
failing, 10-4
Hyperion Essbase outline, 8-1
immediately, 7-13
improving performance of, 7-11, 8-6
incomplete, 10-6
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incrementally, 7-11, 8-6

metaoutline filters and, 5-4

new members, 4-8

partia load, 10-5, 10-7

prerequisites for, 7-4

problems, 10-3, 10-6

rulesfile, 7-15, 8-10

scheduling, 7-16

scheduling problems, 10-5

sorting, performance and, 4-24

starting, 7-8

stopping, 8-10, 10-4

text file, 7-15, 8-10

user-defined load member, 3-8

viewing scheduled loads, 7-18, 7-21
member names, maximum length, 3-9
Member Properties dial og box

Account Info tab, 6-20, 6-22

Formulatab, 6-26

General tab, 3-26

Member Info tab, 6-11, 6-13, 6-15, 6-17

UDASstab, 6-24
members

aliases, setting, 6-10

alphabetizing, 4-23

branches, collapsing or expanding, 2-12

changing case of, 4-12, 4-21

checking before loading, 3-31

consolidation, 1-3

consolidation, operators, 6-14

creating. See creating, members

dataloading and, 4-8

defined, 1-3, 3-5

dimensions, 1-3

duplicate, defined, 4-3

examples, 1-3

extracting from arelational data source, 7-3

filtering, 5-6

ignoring duplicate, 4-3

loading. See member loading

missing, 10-4

names, filtering on, 5-6

naming rules, 3-9

OLAP model, not associated with, 3-7

ordering, 4-23

prefixesand, 4-17

rejected, 7-15, 8-10, 10-5, 10-7

sample, problems with, 10-4

shared. See shared members

sorting, 4-23

suffixesand, 4-17

transforming, 4-11

two-pass calculation, 6-12

user-defined, 3-19

viewing sample, 3-30
menu bar, defined, 2-13
menus, right-click, 2-13
metadata repository. See OLAP Catalog
metadata repository. See OLAP Metadata Catal og
metadata, defined, 1-9
metadata, OLAP Metadata Catal og storage, 1-9
metaoutline filters

Seealsofilters

creating, 5-10

creating multiple Hyperion Essbase databases

using, 5-4

defined, 5-1, 5-3

deleting, 5-12

measure filters and, 5-3

member filters and, 5-3

multiple conditionsin, 5-10

naming rules, 3-9

problems with, 10-3

setting current, 5-8

viewing the contents of, 5-11
M etaoutline main window

customizing view, 2-13, 6-27

defined, 2-11

example of, 2-11

multiple selection in |eft frame, 2-15

multiple selection in right frame, 2-16, 2-17

properties displayed in columnar format, 2-13

properties displayed in condensed format, 2-13
metaoutlines

advantages of, 1-10

components of, 1-11

confirming a deletion, 2-29

copying, 2-27

creating, 2-11

defined, 1-8

deleting, 2-28

deleting, problems with, 10-2
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description of, 2-25
filters, viewing, 5-11
Hyperion Esshase databases, creating multiple,
5-4
Hyperion Integration Server sample, Xi
introducing, 1-1
locks, deleting, 2-30
measures in, viewing, 3-32
navigating, 2-12
opening, 2-4
populating, 3-1
prerequisitesfor, 1-1
printing, 2-28
renaming, 2-27
sample, xi
saving invalid, 2-19
saving with Exclusive Access, 2-21
saving, problems with, 10-2
shared membersin, 4-3
using icon to start, 2-3
viewing current, 5-8
workflow to create a metaoutline, 1-12
working with, 2-3
minus signs (-)
consolidation property, 6-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
reversing, 4-28
Miscellaneous members, 4-8
missing
See also #MISSING
models. See OLAP models
monthly, member and dataload, 7-17
months, sorting chronologically, 4-15
multidimensional databases
defined, 1-3
source data, 1-5
uses, 1-3
workflow, 1-5, 1-9
multiple selection
|eft frame, 2-15
menu commands availability, 2-17
right frame, 2-16
multiplying, values while loading, 4-27
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naming conventions, case sensitivity, 3-9
naming rules
applications and databases, 7-4
members, 3-9
metaoutlines, 3-9
navigating metaoutlines, 2-12
negative data values, reversing signs, 4-28
never share property, 6-8
non expense, variance reporting property, 6-21
not equal to filter operator (< >), 5-14
not in filter operator, 5-14

O

ODBC
data sources, multiple OLAP Integration Servers
and, 9-22
SQL versions supported, 1-5
OLAP Architect. See OLAP Model
OLAP Builder. See metaoutlines
OLAP Catalog. See OLAP Metadata Catal og
OLAP Command Interface
batch processing, 1-9
defined, 1-9
loading members with, 7-12
OLAP Command Interface commands
LOADDATA, 8-7
LOADMEMBER, 7-12
OLAP Integration Server
connection problems, 2-6, 10-3
defined, 1-8
Drill-Through reports and, 9-22
ODBC data source names, 9-22
OLAP intersection levels
adding, 9-6, 9-10
defined, 9-2
deleting, 9-27
deleting all, 9-27
rulesfor, 9-7
setting, 9-7
OLAP Metadata Catal og
configuring for ODBC, 1-9
connecting to, 2-28
connection problems, 2-6
defined, 1-9
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locks, deleting, 2-30
OLAP Metaoutline Assistant, 1-8, 2-7
OLAP Metaoutline Properties dialog box
Database Measures tab, 3-32
Drill-Through Reports tab, 9-23, 9-24
Governorstab, 7-6, 9-14
User Defined Dimensions tab, 3-22
OLAP metaoutline. See metaoutlines
OLAP Modéd
defined, 1-8
startup programs necessary, 2-3
uses, 1-1
OLAP Model Assistant, 1-7
OLAP Model Properties dialog box
General tab, 2-26
OLAP models
dimensions associated with, 3-12
dimensions not associated with, 3-7, 3-19
members, 1-3
members associated with, 3-15
members not associated with, 3-7, 3-19
missing, 10-1
sample, xi
specifying user access permissions, 2-25
OLAP Server, defined, 1-2
olapbldr program, 2-3
OLTP data, defined, 1-5
Online Analytical Processing (OLAP), defined, 1-2
online guide, xii
online help, xii
Online Transaction Processing (OL TP), examples of
contents, 1-5
Open Database Connectivity. See ODBC
opening balance, 6-18
operational data, 1-5
operations, order of, 4-12
operators, 6-14
consolidation, 6-14
member and measure filters, 5-14
order
calculations and, 6-12
transformations performed, 4-12
Order By dialog box, 9-20
ordering
columnsin Drill-Through reports, 9-16
dimensions, 3-12

Index-12 M

measures, 3-16

member levels, 3-16

members, 4-23

rows in Drill-Through reports, 9-18
Other, reserved word, 10-4
Outline menu

Data Load command, 8-4

Member Load command, 7-8
outline tree, collapsing or expanding a member

branch, 2-12

outlines. See Hyperion Esshase outlines

P

parentheses
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
parents
attaching name to children, 4-19
rolling up into different, 4-4
two-pass calculation and, 6-12
partitions, 6-1, 6-3
percent signs (%)
consolidation property, 6-14
Hyperion Essbase formul as, 6-26
in names in scripts and formulas, 3-10
performance
build level and, 4-25
Drill-Through reports and, 9-22
sorting and, 4-24
tuning, data sources, 3-31
periods (.)
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
permissions
changing, 2-27
saving metaoutlines and, 2-25
pivoting
defined, 1-4
using to change data view, 1-4
plussigns (+)
consolidation property, 6-14
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
in names in scripts and formulas, 3-10
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reversing, 4-28 Q
populating, metaoutlines, 3-1, 7-1, 8-1

pop-up menu, defined, 2-13 query governors

positive data values, reversing sign, 4-28 defined, 7-5, 9-14
prefixes prol_alems with, 10-4
adding to fields, 4-17 setting, 7-5, 9-14

query size, controlling, 7-5, 9-14

example, 4-12 > h
query time, controlling, 7-5, 9-14

new member names and, 4-10

operations, order of, 4-12 quotation marks
prerequisites in dimension and member level names, 3-9

data, loading, 8-3 in dimension and member names, 3-9, 4-14, 4-17

metaoutlines, creating, 7-4 in scripts and formulas, 3-10, 3-11

Preview Filter Results dialog box, 3-31

Preview Transformation Results dialog box, 3-31, R
4-15 .
Print button, Metaoutline toolbar, 2-28 reed access, setting, 2-25
orinting read/vx_/rlte gccesg See read access
masatine 226 e 211
L, 3-31 .

_SeL, . defined, 4-4
privileges. See permissions o of 44
problems examp'e of,

reject text file, 7-15, 8-10, 10-5, 10-7
relational databases. See data sources
removing. See deleting
renaming
dimensions, 3-25
Drill-Through reports, 9-25, 9-26
measures, 3-25
member levels, 3-25
metaoutlines, 2-27
single measure, 3-27
repeated member names. See duplicate members
replace operations, order of, 4-12
replacing case-sensitive strings, 4-14
replicated partitions, 6-1, 6-3
Report Properties dialog box

connecting, 2-6

deleting metaoutlines, 2-29, 10-2

loading members and data, 10-6
product comparisons, 1-2
properties

accounts, 6-17

consolidation, 6-14

dimension storage, 6-6

dynamic calc, 6-8

dynamic calc and store, 6-8

expense, setting, 6-21

first time balance, 6-18

Hyperion Essbase, 6-1

label only, 6-8

|ast time balance, 6-18

load. See load properties General tab, 9-26
Governors tab, 9-14
never share, 6-8 .
report scripts

skip, 6-19
time balance, 6-18
two-pass calculation, 6-12

names with specia characters, 3-10, 3-11
user-defined attributes and, 6-23

i i reports
variance reporting, 6-21 -
zeros, 6-19 ali ases and, 6-10
copying, 9-5
creating, 9-1, 9-3

customizing, 9-21
database username and, 9-23
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deleting, 9-27
Drill-Through, missing, 10-2
load balancing, 9-22
OLAP Integration Server name, 9-22
renaming, 9-25, 9-26
security and, 9-23
valid columnsfor, 9-12
repository. See OLAP Metadata Catalog
reserved words, 3-9
restructure, incremental, 7-11, 8-6
result sets, controlling size of, 7-5, 9-14
reversing, plus and minus signs, 4-28
right frame
defined, 2-12
selecting multiple objects, 2-16, 2-17
right-click menus, xiv, 2-13
roll-ups
average property and, 6-18
defined, 1-3
last property and, 6-18
row filters
creating, 5-13, 5-17, 5-18, 5-22
defined, 5-6
rows
example of, 9-18
maximum in query, setting, 7-5, 9-14
none returned, 7-6
ordering, 9-18
rules
intersection levels and, 9-7
naming, 3-9
naming applications and databases, 7-4
shared members, 4-6
rulesfile, 7-15, 8-10

S

sample
applications, xi
Hyperion Essbase outlines, problems with, 10-4
Hyperion Essbase outlines, viewing, 3-30
members, viewing, 3-30

Sample command, 3-30

Sample Outline dialog box, 3-31

Save New Metaoutline dialog box, 2-24

saving
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metaoutlines, using a different name, 2-27

metaoutlines, using File > Save As, 2-27

problems with, 10-2
scaling, values, 4-27
scenarios, 1-4
Schedule Essbase Load dialog box, 7-13, 7-16, 8-8,

8-11

schedule service, starting, 7-18
Scheduled Jobs dialog box, 7-19, 7-21
scheduled loads

problems with, 10-5

unable to schedule, 10-5

viewing and deleting, 7-18, 7-21
scheduling

dataloads, 8-11

member loads, 7-16

problems with, 10-5

unable to complete, 10-5

Windows NT schedule service, 7-18
scripts

calc scripts, 7-12, 8-7
searches, case-sensitive, 4-14
security

Drill-Through reports and, 9-23

Hyperion Essbase users, creating, 8-5
Select a Member dialog box, 3-23
Select Vaues From dialog box, 5-15, 5-20
selecting

calc scripts, 7-12, 8-7

multiple conditions, 5-15, 5-20

multiple objects, 2-15, 2-16
semicolons (;)

in names in scripts and formulas, 3-10
servers, Hyperion Essbase users and, 8-5
Services diaog box, 7-18
Set Sort Order dialog box, 9-19
Setting

dliases, 6-10

build level, 4-25

calc scripts, 7-12, 8-7

expense property, 6-21

formulas, 6-25

Hyperion Esshase properties, 6-1

load member, 3-22

metaoutline filters, 5-8

OLAP intersection levels, 9-7
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query governors, 7-5, 9-14
Settings menu
Control Panels command, 7-18
shared members
adding, 4-3
children and, 4-6
filters, problems and, 10-6
formulas and, 4-6
missing, 10-6
rulesfor, 4-6
user-defined attributes and, 6-23
signs, reversing plus and minus, 4-28
single measure
renaming, 3-27
single quotation marks (')
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
size, query, controlling, 7-5, 9-14
skip property, 6-19
slashes (/)
consolidation property, 6-14
in names in scripts and formulas, 3-10
sorting
Drill-Through reports and, 9-18
members, 4-23
months, chronologicaly, 4-15
performance and, 4-24
source data, multidimensional databases, 1-5
sources. See data sources
spaces
converting to underscores, 4-16
dropping, 4-16
dropping and converting, order of, 4-12
in dimension and member names, 3-9
sparse dimensions, defined, 6-6
Spreadsheet Add-in, drilling through from, 9-1
spreadsheet files, data sources, 1-5
spreadsheet users, customizing Drill-Through
reports, 9-21
SQL
checking, 3-31
data sources, 1-5
filters, 5-1, 5-3
printing, 3-31
queries, controlling the size of, 7-5, 9-14
syntax, filter errors, 10-3
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versions supported, 1-5

viewing for adimension, 3-31
SQL 89, 1-5
SQL Drill-Through. See Drill-Through
star schemas. See OLAP models
starting

metaoutline, methods, 2-3

OLAP Model, programs necessary, 2-3
status bar, defined, 2-13
stopping, member or dataload, 7-15, 8-10, 10-4
storage

data properties, 6-8

dimensions, specifying, 6-6
store properties, 6-8
strategic planning, 1-4
SUBSTRING function, 10-6
suffixes

adding to fields, 4-17

new members and, 4-10

operations, order of, 4-12
syntax

filters, errors, 10-3

formulas, incorrect, 10-2

T

tab, in names, 3-9

tables
capitalization, xi

tagging
accounts dimension, 6-4
measure dimensions, 3-24
time dimension, 6-5

TBC Metaoutline, xi
dimensionsin, 3-4
measuresin, 3-6
parts of, 1-12

TBC Modd, xi

templates. See metaoutlines

text
datal oad.txt, 8-10, 10-5, 10-7
files, data sources, 1-5

tilde, consolidation property (~), 6-14

time
format, 7-17, 8-12
query, controlling, 7-5, 9-14
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time-out errors, 10-4
time balance
average, 6-18
first, 6-18
last, 6-18
missing properties, 6-19
properties, specifying, 6-18
skip, 6-19
time balance properties, 6-18
time dimension
dense dimension, 6-6
dimension type, 6-5
time-out errors, 10-4
timing, specifying for loads, 7-16, 8-11
toolbar, defined, 2-13
Tools menu, Scheduler command, 7-19, 7-21
tracking, budget data, 3-7
Transformation command, 4-13
transformations
dliases and, 10-4
order of, 4-12
transforming member names, 4-11
transparent partitions, 6-1, 6-3
tree editor, collapsing or expanding a member
branch, 2-12
troubleshooting
connecting, 2-6
dataload and, 10-4
filtersand, 10-3
member and dataloads, 10-6
member load and, 10-4
metaoutlines and, 10-1
transformations and, 10-2
tuning
data sources, 3-31
viewing SQL, 3-31
two-pass cal culations, specifying, 6-12
types of dimensions, 6-3

U

UDAs
calc scripts, 6-23
creating, 6-24
defined, 6-23
report scripts, 6-23
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shared members and, 4-6, 6-23
unary operators, 6-14
underscores ( _)
converting spacesto, 4-16
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
UNIVERSE reserved word, 10-4
unscheduled data loads, 8-8
unscheduled member loads, 7-13
updating
data. See also data loading
Hyperion Esshase outlines incrementally, 7-11,
8-6
incrementally, 8-6
members. See also member [oading
user names, specifying, 7-10, 8-5
user privileges. See permissions
user-defined dimensions
creating, 3-19
defined, 3-7
example, 3-7
load member for, 3-22
valid, 2-21
user-defined members
creating, 3-19
defined, 3-7
formulas on, 6-25
users, Hyperion Esshase, creating, 7-10, 8-5

Vv

validation
metaoutlines, 2-19
problems, 10-1
values. See datavalues
variance reporting properties, 6-21
vertical bars (])
in dimension and member level names, 3-9
in dimension and member names, 4-14, 4-17
View Existing Job dialog box, 7-20
View Filter dialog box, 5-12
View menu
Display Esshase Properties command, 2-14, 6-27
Metaoutline icons command, 2-14
Sample command, 3-30
Status bar command, 2-13
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Toolbar command, 2-13
viewing

columnar format, 6-27

condensed format, 6-27

displaying Hyperion Essbase properties, 6-27

filters, 5-11

generated SQL, 3-31

Hyperion Essbase propertiesin columnar format,
6-28

Hyperion Esshase properties in condensed
format, 6-29

measures, 3-32

sample dimensions, members, outlines, 3-30

sample dimensions, members, outlines, problems
with, 10-4

scheduled loads, 7-18

wW

weekly, member and dataload, 7-17
what if scenarios, example, 1-4
WHERE clauses. Seefilters
white space, in dimension and member names, 3-9
whitespace. See spaces
Windows NT schedule service, 7-18
Windows Start menu, using to start ametaoutline, 2-3
wizard. See OLAP Metaoutline Assistant;
OLAP Model Assistant
workflow
Hyperion Integration Server, 1-6
Hyperion Integration Server product family, 1-9
metaoutlines, creating, 1-12
write
access, setting, 2-25
access, specifying for OLAP models, 2-25
|ocked metaoutline, 10-2
write access. See read access

Y

year filter, example, 5-4

Z

zeros
property, 6-19
SKipping during calculation, 6-19
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	4. Decide whether to use the Prefix option group or the Suffix option group.
	5. In the Prefix option group or the Suffix option group, as appropriate, select the source of th...
	6. In the Prefix Separator or Suffix Separator option group, select the separator character to in...
	7. Click Preview Results to open the Preview Transformation Results dialog box to preview your ch...
	8. Click OK.


	Changing the Case of Member Names
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	2. Right-click the member level and, from the pop-up menu, select Filter to open the Member Load ...
	3. Select the Ordering tab.
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	4. From the Sort Order drop-down list, select a sort order.
	5. Click OK.
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	Figure 4-18: Scaling Measures

	3. From the Operator drop-down list, select the operator to use for scaling the incoming measure;...
	4. In the Value text box, enter the value to use; for example, type 10 to multiply the incoming v...
	5. Click OK.
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	Figure 4-19: Reversing Signs for Measures

	3. Select the Flip Sign box.
	4. Click OK.
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	Figure 4-20: Changing the Column Associated with a Measure

	4. From the Database Properties list, select the desired column.
	5. Click OK.
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	Figure 5-7: Creating a New Metaoutline Filter

	3. Type the name of the new filter, for example, 96 Dataload.
	4. Click OK.
	Figure 5-8: Viewing the Current Filter Name

	5. In the metaoutline, create member and measure filters.
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	Figure 5-9: Viewing the Contents of the Current Metaoutline Filter

	3. To view the conditions defined for a specific filter, select the filter, for example, Time.Qua...
	4. When you finish viewing the filters, click Close.


	Deleting a Metaoutline Filter
	To delete a metaoutline filter:
	1. Open the metaoutline.
	2. From the filter drop-down list, select the filter to delete.
	3. Click the Delete Filter button, .
	4. Click Yes.



	Creating a Member Filter Interactively
	To create a member filter interactively:
	1. In the metaoutline, select the member level to attach to the filter, for example, MARKET.STATE.
	2. To create a row filter, right-click the member level and, from the pop-up menu, select Filter ...
	3. Select the Filters tab.
	Figure 5-10: Setting a Member Load Filter Interactively

	4. From the Column drop-down list, select the column to which the condition applies, for example,...
	5. From the Operator drop-down list, select the operator to use.
	Table 5-1: Filter Operators �

	6. To enter a condition in the Condition text box, type the condition, for example, 1996, or comp...
	a. To open the Select Values From dialog box, click the button.
	Figure 5-11: Setting Values for Conditions

	b. Select the desired value (such as California).
	c. Click OK.
	7. In the Member Load Filtering dialog box, click Add to add the condition to the Filters list.
	8. If you want to define an additional condition, do the following:
	a. Repeat steps 5 through 7.
	b. Do one of the following:
	9. If you want to edit a filter, do the following:
	a. Use the SQL syntax required by the relational data source.
	b. In the Member Load Filtering dialog box, click Verify to check the SQL�syntax.
	10. Click Preview Results to open the Preview Filter Results dialog box.
	11. Click OK.


	Typing a Member Filter
	To type a member filter:
	1. In the metaoutline, select the member level to attach to the filter, for example, MARKET.STATE.
	2. To create a row filter, right-click the member level and, from the pop-up menu, select Filter.
	3. Select the Filters tab.
	Figure 5-12: Typing a Member Load Filter

	4. To enter a filter, in the Filters box, type the filter information according to the following ...
	5. Click Verify to check the SQL syntax.
	6. If you want to define an additional condition on the filter, do the following:
	a. Repeat steps 4 and 5.
	b. Review step 8b of the previous procedure, “Creating a Member Filter Interactively” on page�5�1...
	7. Click Preview Results to open the Preview Filter Results dialog box.
	8. Click OK.


	Creating a Measure Filter Interactively
	To create a measure filter interactively:
	1. In the metaoutline, select the measure to apply to the filter, for example, SALES.
	2. Right-click the measure and, from the pop-up menu, select Filter.
	3. Select the Filters tab.
	Figure 5-13: Creating a Measure Filter Interactively

	4. From the Column drop-down list, select the column to which the condition applies, for example,...
	5. From the Operator drop-down list, select the operator to use.
	6. To enter a condition, in the Condition text box, type the condition, for example, 1000, or com...
	a. Click the button to open the Select Values From dialog box.
	Figure 5-14: Setting Values for Conditions

	b. Select the desired value (such as 1000).
	c. Click OK.
	7. In the Measure Properties dialog box, click Add to add the condition to the Filters list.
	8. To define an additional condition on the filter, do the following:
	a. Repeat steps 5 through 7.
	b. Do one of the following:
	9. If you want to edit a filter, do the following:
	a. Use the SQL syntax required by the relational data source.
	b. Click Verify to check the SQL syntax.
	10. Click Preview Results to open the Preview Filter Results dialog box.
	11. Click OK.


	Typing a Measure Filter
	To type a measure filter:
	1. Select the measure to apply to the filter, for example, SALES.
	2. Right-click the measure and, from the pop-up menu, select Filter.
	3. Select the Filters tab.
	Figure 5-15: Typing a Measure Filter

	4. In the Filters box, type the filter information according to the following syntax:
	5. Click Verify to check the SQL syntax.
	6. To define an additional condition on the filter, do the following:
	a. Repeat steps 4 and 5.
	b. Do one of the following:
	7. Click Preview Results to open the Preview Filter Results dialog box.
	8. Click OK.



	Setting Hyperion Essbase Properties
	Understanding the Metaoutline Workflow
	Figure 6-1: Metaoutline Workflow

	Specifying Dimension and Member Properties
	About Dimension Types
	Table 6-1: Dimension Types �

	Setting a Dimension Type
	To set a dimension type:
	1. In the metaoutline, select the dimension for which you want to set the dimension type.
	2. Right-click the dimension and, from the pop-up menu, select Properties to open the Dimension P...
	3. Select the Member Info tab.
	Figure 6-2: Setting a Dimension Type

	4. From the Dimension Type group, select the type of dimension.
	5. Click OK.


	Specifying Dimension Storage Properties
	To set a dimension storage property:
	1. In the metaoutline, select a dimension, for example, Measures.
	2. Right-click the dimension and, from the pop-up menu, select Properties to open the Dimension P...
	3. Select the Member Info tab.
	Figure 6-3: Setting Dense or Sparse Dimensions

	4. From the Dimension Storage group, select Dense or Sparse.
	5. Click OK.


	Specifying Data Storage Properties for Dimensions and Members
	Table 6-2: Data Storage Properties
	To set a data storage property:
	1. In the metaoutline, select a dimension or a member level, for example, Measures.
	2. Right-click the dimension or the member level and, from the pop-up menu, select Properties to ...
	3. Select the Member Info tab.
	Figure 6-4: Setting Storage Properties

	4. From the Data Storage group, select the kind of storage to use.
	5. Click OK.


	Setting Aliases for Dimensions and Members
	To assign an alias to a dimension or member:
	1. In the metaoutline, select the dimension or member level.
	2. Right-click the dimension or member level and, from the pop-up menu, select Properties to open...
	3. Select the Member Info tab.
	Figure 6-5: Assigning Aliases

	4. Do one of the following:
	5. Click OK.


	Specifying Two-Pass Calculation on Dimensions and Members
	To tag a dimension or member to use two-pass calculation:
	1. In the metaoutline, select the dimension or member level.
	2. Right-click the dimension or member level and, from the pop-up menu, select Properties to open...
	3. Select the Member Info tab.
	Figure 6-6: Specifying Two-Pass Calculation

	4. Select Two Pass Calculation.
	5. Click OK.


	Specifying Member Consolidation Properties
	Table 6-3: Member Consolidation Properties
	To set the consolidation operator of a member:
	1. In the metaoutline, select a member level, for example, PRODUCT_DESC.
	2. Right-click the member level and, from the pop-up menu, select Properties.
	3. Select the Member Info tab.
	Figure 6-7: Choosing Member Consolidation

	4. From the Consolidation group, select the appropriate consolidation operator.
	5. Click OK.


	Setting Members as Dynamic Time Series
	To tag a member as Dynamic Time Series:
	1. In the metaoutline, select the member level, for example, Month.
	2. Right-click the member level and, from the pop-up menu, select Properties.
	3. Select the Member Info tab.
	Figure 6-8: Setting a Member as Dynamic Time Series

	4. Select Dynamic Time.
	5. Click OK.



	Specifying Account Properties
	Specifying Time Balance Properties
	Table 6-4: Time Balance Properties �
	Table 6-5: Skip Properties
	To set a time balance property for a member:
	1. In the metaoutline, select the member level, for example, OPENING_INVENTORY.
	2. Right-click the member level and, from the pop-up menu, select Properties.
	3. Select the Account Info tab.
	Figure 6-9: Setting Time Balance Properties

	4. From the Time Balance group, select the property that you want to use, for example, First.
	5. If you set the time balance as first, last, or average, set the appropriate Skip property.
	6. Click OK.


	Specifying Variance Reporting Properties
	Table 6-6: Variance Reporting Properties
	To set the variance reporting property of a member:
	1. In the metaoutline, select the member level, for example, DISCOUNTS.
	2. Right-click the member level and, from the pop-up menu, select Properties.
	3. Select the Account Info tab.
	Figure 6-10: Tagging Members as Expense or Non-Expense

	4. From the Variance Reporting group, select Non Expense or Expense.
	5. Click OK.



	Specifying UDAs
	Understanding Rules for UDAs
	Defining a UDA
	To define a UDA:
	1. In the metaoutline, select the member level for which to define the UDA, for example, REGION.
	2. Right-click the member level and, from the pop-up menu, select Properties.
	3. Select the UDAs tab.
	Figure 6-11: Defining UDAs

	4. If you want to define the UDA, select value and in the Value text box, enter the UDA.
	5. If you want OLAP Integration Server to retrieve the UDA from a column in the relational data s...
	6. Click Add to List to add the UDA to the Existing UDAs list.
	7. If you want to delete a UDA, in the Existing UDAs list, select the UDA, and click the delete b...
	8. If you want to add another UDA to the member, repeat steps 4 through 6.
	9. Click OK.



	Specifying Formulas
	To add a formula to a dimension or member:
	1. In the metaoutline, select the dimension or member level to which to add the formula, for exam...
	2. Right-click the member level and, from the pop-up menu, select Properties.
	3. Select the Formula tab.
	Figure 6-12: Typing Formulas

	4. In the edit field, enter the formula. Be sure to end the formula with a semicolon (;), for exa...
	5. Click OK.


	Viewing Hyperion Essbase Properties
	To display Hyperion Essbase properties in column format:
	1. In the metaoutline, select a dimension, member level, or outline; for example TBC METAOUTLINE.
	2. Select View > Display Essbase Properties.
	3. If Display as Columns is not selected, select it.
	4. To determine which properties to display, from the submenu, select any of the following items:
	5. If you want to display all Hyperion Essbase properties, select All.
	Figure 6-13: Viewing Hyperion Essbase Properties in Column Format


	To display Hyperion Essbase properties in condensed format:
	1. Select a dimension, member level, or outline; for example TBC METAOUTLINE.
	2. Select View > Display Essbase Properties.
	3. If Display as Columns is selected, deselect it.
	4. To determine which properties to display, from the submenu, select any of the following items:
	5. If you want to display all Hyperion Essbase properties, select All.
	Figure 6-14: Viewing Hyperion Essbase Properties in Condensed Format




	Loading Dimensions and�Members
	Understanding the Metaoutline Workflow
	Figure 7-1: Metaoutline Workflow

	About Loading
	Figure 7-2: Loading Process

	About Naming Applications and Databases
	Procedure 1: Preparing to Load Members
	1. Connect to the Hyperion Essbase server where you want to create or change the Hyperion Essbase...
	2. If needed, set query governors to control the duration and the size of the queries that Hyperi...
	3. If needed, select a metaoutline filter to use for the load.
	Using Query Governors
	To set a query governor:
	1. In the metaoutline, select the metaoutline name.
	2. Right-click the metaoutline name, and choose one of the following options:
	3. Select the Governors tab.
	Figure 7-3: Setting a Query Governor

	4. In the Maximum time per query (in seconds) text box, enter the maximum query time.
	5. In the Maximum rows per query text box, enter the maximum number of rows to retrieve.
	6. If you are setting a query governor to view a sample outline or dimension, select one of the f...
	7. Click OK.



	Procedure 2: Starting a Member Load
	To load members:
	1. Make sure that you perform the tasks described in “Procedure 1: Preparing to Load Members” on ...
	Figure 7-4: Choosing the Hyperion Essbase Application and Database

	2. Do one of the following:
	3. If you want to delete all dimensions and members in an existing Hyperion Essbase outline, sele...
	4. If you want to determine which Hyperion Essbase users can access the Hyperion Essbase applicat...
	a. Select Modify Essbase users.
	Figure 7-5: Selecting Hyperion Essbase Users

	b. In the Available list box, select a user to whom you want to give access.
	c. Click the button to move the selected user to the Selected list box.
	d. When the names of all users who should access the Hyperion Essbase application and database ar...
	5. If you want to select specific dimensions not to update, select Incremental Update.
	Figure 7-6: Updating Hyperion Essbase Outlines Incrementally

	a. To prevent OLAP Integration Server from updating a dimension or member, select the dimension o...
	b. When you have marked all dimensions and members that OLAP Integration Server should not update...
	6. Proceed to “Procedure 3: Loading Members Immediately” on page�7�13 or to “Procedure 4: Schedul...
	7. Select the calc script to use to calculate the Hyperion Essbase database.


	Procedure 3: Loading Members Immediately
	To load members immediately:
	1. Make sure that you perform the tasks described in “Procedure 2: Starting a Member Load” on pag...
	Figure 7-7: Loading Members Immediately

	2. If you want to save the script to a different name or change the name of the script, click Sav...
	Figure 7-8: Saving a Script

	a. Enter the new script name.
	b. Click OK to return to the Schedule Essbase Load dialog box.
	3. Select Now.
	4. Click Finish.
	Figure 7-9: Displaying Member Load Information

	5. If you encounter an error and want to stop the member load, click Stop Load. (The Stop Load bu...
	Figure 7-10: Leaf Node Example



	Procedure 4: Scheduling a Member Load
	To schedule a member load:
	1. Make sure that you perform the tasks described in “Procedure 2: Starting a Member Load” on pag...
	Figure 7-11: Scheduling the Member Load

	2. Select Schedule.
	3. If Hyperion Integration Server is on a computer running UNIX, proceed to step 5.
	4. If Hyperion Integration Server is on a computer running Windows NT, start the Schedule service...
	5. Enter the time to run the member load:
	a. In the Date text box, enter the date. Use the mm/dd/yyyy format, for example, January 17, 2000.
	b. In the Time text box, enter the time. Use the hh:mm:ss format, for example, 23:59. To schedule...
	c. From the Frequency drop-down list, select how frequently to perform the member load.
	6. Click Finish.

	Starting the Windows NT Schedule Service Automatically
	Starting the Windows NT Schedule Service Manually
	To start the Windows NT Schedule service manually:
	1. From the Windows NT taskbar, select Settings > Control Panels.
	2. Double-click the Services button, , to open the Services dialog box.
	Figure 7-12: Starting the Windows NT Schedule Service

	3. Scroll down to the Schedule service and select it.
	4. Click Start.
	5. Click Close.



	Viewing Scheduled Member and Data Loads
	To view all scheduled member and data loads:
	1. From the OLAP Metaoutline main window menu bar, select Tools > Scheduler.
	Figure 7-13: Viewing a List of Scheduled Loads

	2. To view more information about a particular load, in the Job Id column, select the job number ...
	Figure 7-14: Viewing a Description of the Selected Load

	3. When you finish viewing the load properties, click OK.
	4. In the Scheduled Jobs dialog box, click Close.


	Deleting Scheduled Member and Data Loads
	To delete a scheduled member or data load:
	1. From the OLAP Metaoutline main window menu bar, select Tools > Scheduler.
	Figure 7-15: Viewing a List of Scheduled Loads

	2. In the Job Id column, select a job number.
	3. Click Delete.
	4. Click Yes.



	Loading Data
	Understanding the Metaoutline Workflow
	Figure 8-1: Metaoutline Workflow

	Procedure 1: Preparing to Load Data
	1. Open the metaoutline.
	2. Connect to the Hyperion Essbase server where you want to load the data.
	3. If you want to control the duration and the size of the queries that OLAP Integration Server m...
	4. If you want to filter data, select a metaoutline filter to use for the load.
	5. If the Hyperion Essbase outline does not already exist, perform a member load.

	Procedure 2: Starting a Data Load
	To start a data load:
	1. Make sure that you perform the tasks described in “Procedure 1: Preparing to Load Data” on pag...
	2. From the menu bar, select Outline > Data Load.
	Figure 8-2: Choosing the Hyperion Essbase Application and Database

	3. From the list of applications, select the Hyperion Essbase application that contains the datab...
	4. From the list of Hyperion Essbase databases, select the Hyperion Essbase database into which y...
	5. Select Modify Essbase users to determine which Hyperion Essbase users can access the Hyperion ...
	Figure 8-3: Selecting Hyperion Essbase Users

	6. To allow a user to access the Hyperion Essbase application and database, do the following:
	a. In the Available list box, select the user.
	b. Click the button to move the user to the Selected list box. To move all users, click the button.
	c. When the names of all users who should access the Hyperion Essbase application and database ar...
	7. If you want to select specific dimensions not to update, in the Essbase Application and Databa...
	Figure 8-4: Updating a Hyperion Essbase Outline Incrementally

	a. To prevent OLAP Integration Server from updating a dimension or member, select the dimension o...
	b. After you mark all dimensions or members that OLAP Integration Server should not update, click...
	8. Select the calc script to use to calculate the Hyperion Essbase database.
	9. Click Next and proceed to “Procedure 3: Loading Data Immediately” on page�8�8.


	Procedure 3: Loading Data Immediately
	To load data immediately:
	1. Make sure that you perform the tasks described in “Procedure 2: Starting a Data Load” on page�...
	Figure 8-5: Loading Data Immediately

	2. If you want to save the script to a different name or change the name of the script click Save...
	Figure 8-6: Saving a Script

	a. Enter the new script name.
	b. Click OK to return to the Schedule Essbase Load dialog box.
	3. In the Schedule Essbase Load dialog box, select Now.
	4. Click Finish.
	Figure 8-7: Displaying Data Load Information

	5. If you encounter an error and want to stop the data load, click Stop Load. (The Stop Load butt...
	Figure 8-8: Leaf Node Example



	Procedure 4: Scheduling a Data Load
	To schedule a data load to run at a specific time and date:
	1. Make sure that you perform the tasks described in “Procedure 3: Loading Data Immediately” on p...
	Figure 8-9: Scheduling a Data Load

	2. Select Schedule.
	3. If Hyperion Integration Server is on a computer running UNIX, proceed to Step 5.
	4. If Hyperion Integration Server is on a computer running Windows NT, start the Schedule service...
	5. Enter the time to run the data load:
	a. In the Date text box, enter the date. Use the mm/dd/yyyy format, for example, January 17, 2000.
	b. In the Time text box, enter the time. Use the hh:mm:ss format, for example, 23:59:00. To sched...
	c. From the Frequency drop-down list box, select how frequently to perform the data load. You can...
	6. Click Finish.



	Creating Drill-Through Reports
	About Drill-Through
	Adding a Report
	Creating a New Report
	To create a new report:
	1. From the menu toolbar, select Edit > Drill-Through Reports to display the Drill-Through Report...
	Figure 9-1: Drill-Through Reports Dialog Box

	2. Click Add to add a new report.
	3. Click Yes.
	Figure 9-2: New Drill-Through Report

	4. If you want to rename the report, see “Renaming a Report in the Drill-Through Reports Dialog B...
	5. If you want to add intersection levels and columns to the report, see “Adding Intersection Lev...


	Copying an Existing Report
	To copy an existing report:
	1. From the menu toolbar, select Edit > Drill-Through Reports.
	2. In the Drill-Through Reports dialog box, select the Drill-Through report that you want to copy.
	3. Click Add.
	4. Click Yes.
	5. If you want to rename the report, see “Renaming a Report in the Drill-Through Reports Dialog B...
	6. If you want to add or change intersection levels and columns in the report, see “Adding Inters...



	Specifying the Contents of a Report
	About Intersection Levels
	Figure 9-3: Intersection Levels

	Following the Rules for Intersection Levels
	Determining Where to Set an Intersection Level
	Reviewing Sample Drill-Through Reports
	Figure 9-4: Simple Drill-Through Metaoutline
	Figure 9-5: Simple Demographics Report
	Figure 9-6: Simple Financial Report

	Adding Intersection Levels
	To add an intersection level to a Drill-Through report:
	1. Create a report.
	2. In the Drill-Through Reports dialog box, select OLAP Intersection Levels, and click Add.
	Figure 9-7: Adding Intersection Levels

	3. Click all signs to expand dimensions and see member levels.
	4. Select the member level to add, and click to move the member level to the right list box.
	Figure 9-8: Intersection Levels

	5. Click OK to return to the Drill-Through Reports dialog box.


	Adding Drill-Through Columns
	To add columns to a Drill-Through report:
	1. Create a report.
	2. Add the intersection levels.
	3. In the Drill-Through Reports dialog box, select Drill-Through Report Columns, and click Add.
	Figure 9-9: Adding Drill-Through Columns

	4. Click the signs to expand the tables.
	5. Select the column to add and click to move the column to the right list box.
	Figure 9-10: Sample Drill-Through Report Columns

	6. Click OK to return to the Drill-Through Reports dialog box.


	Setting the Size of a Query
	To set a query governor:
	1. In the Drill-Through Reports dialog box, select a report name.
	2. Click Edit to open the Report properties dialog box.
	3. In the Report properties dialog box, select the Governors tab.
	Figure 9-11: Setting a Query Governor

	4. In the Maximum time per query (in seconds) text box, enter the maximum query time.
	5. In the Maximum rows per query text box, enter the maximum number of rows to retrieve.
	6. Click OK.



	Specifying the Format of a Report
	Specifying Column Ordering
	Figure 9-12: Column Order in TBC Drill-Through Report
	To move a column:
	1. From the menu bar, select Edit > Drill-Through Reports to open the Drill-Through Reports dialo...
	2. In the Drill-Through Reports dialog box, click the sign adjacent to the Drill-Through report t...
	3. From the list of the columns in the report, select a column, for example, MARKET.CITY.
	Figure 9-13: Positioning Columns

	4. Click Move Up or Move Down to position the column.
	5. When the columns are in the correct order, click Close.


	Specifying Row Ordering
	Figure 9-14: Row Sort Order in TBC Drill-Through Report
	To determine the order of rows:
	1. From the menu bar, select Edit > Drill-Through Reports to open the Drill-Through Reports dialo...
	2. In the Drill-Through Reports dialog box, select the Drill-Through report to sort.
	3. Click Sort Order to open the Set Sort Order dialog box.
	Figure 9-15: Setting Sort Order

	4. Select the column for which you want to set the sort order and click to add the column to the ...
	5. Select a column in the right list box, and click Order By.
	Figure 9-16: Order By Dialog Box

	6. Select the sort order: Ascending (A to Z, 0 to 9) or Descending (Z to A, 9�to�0).
	7. Click OK to return to the Set Sort Order dialog box.
	8. If you want to set the sort order for another column, repeat steps 4, 5, 6, and 7.
	9. Click OK to return to the Drill-Through Reports dialog box.



	Specifying Spreadsheet User Actions
	Customizing a Report
	To allow spreadsheet users to customize a report:
	1. In the Drill-Through Reports dialog box, select the report that you want to allow spreadsheet ...
	2. Click Edit to open the Report properties dialog box.
	Figure 9-17: Allowing Spreadsheet Users to Customize a Report

	3. Select Allow spreadsheet users to customize this report.
	4. Click OK.


	Specifying the OLAP Integration Server Name
	To always prompt spreadsheet users for the name of the server running OLAP Integration Server:
	1. In the OLAP Metaoutline main window, select the metaoutline name, for example, TBC Metaoutline.
	2. Right-click the metaoutline name and, from the pop-up menu, select Properties.
	3. Select the Drill-Through Reports tab.
	Figure 9-18: Prompting for the Name of the Server Running Hyperion Integration Server

	4. Select Always prompt for OLAP Integration Server name.
	5. Click OK.


	Specifying a Database Username and Password
	To require spreadsheet users to specify a username and a password:
	1. In the OLAP Metaoutline main window, select the metaoutline name, for example, TBC Metaoutline.
	2. Right-click the metaoutline name and, from the pop-up menu, select Properties.
	3. Select the Drill-Through Reports tab.
	Figure 9-19: Prompting for a Username and Password

	4. Select Always prompt for database username and password.
	5. Click OK.



	Working with Reports
	Renaming a Report in the Drill-Through Reports Dialog Box
	To rename a report in the Drill-Through Reports dialog box:
	1. From the menu bar, select Edit > Drill-Through Reports to open the Drill-Through Reports dialo...
	2. In the Drill-Through Reports dialog box, click the report name to put the dialog box in edit m...
	3. Type the new report name.
	4. Press the Enter key, or select another object in the Drill-Through Reports dialog box. Repeat ...


	Renaming a Report in the Report Properties Dialog Box
	To rename a report in the General tab of the Report properties dialog box:
	1. From the menu bar, select Edit > Drill-Through Reports to open the Drill-Through Reports dialo...
	2. In the Drill-Through Reports dialog box, select the report for which you want to change the name.
	3. Click Edit to open the Report properties dialog box.
	Figure 9-20: Renaming a Report

	4. In the Name text box, type the new name.
	5. Click OK.


	Deleting an Individual Report, an Intersection Level, or�a�Drill-Through�Column
	To delete a report, an intersection level, or a Drill-Through column:
	1. From the menu bar, select Edit > Drill-Through Reports to open the Drill-Through Reports dialo...
	2. In the Drill-Through Reports dialog box, select the report, intersection level, or column to d...
	3. Click Delete.
	4. Click Yes.


	Deleting All Intersection Levels or Drill-Through�Columns in a Report
	To delete all intersection levels or Drill-Through columns:
	1. From the menu bar, select Edit > Drill-Through Reports to open the Drill-Through Reports dialo...
	2. In the Drill-Through Reports dialog box, select the phrase OLAP Intersection Levels or the phr...
	3. Click Delete.
	4. Click Yes.




	Troubleshooting
	Problems with Creating, Validating, Saving, or Deleting Metaoutlines
	Problems with Transformations
	Problems with Filters
	Failure of a Member Load or Data Load
	Problems with Loading Members or Data�
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