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Using the IBM Infoprint 2000 Printer

The IBM Infoprint 2000 printer is a multi-purpose solution designed for a multiplicity of
users. Whether you requiring the speed and precision of an Advanced Function Presentation
(AFP) printer, or the print quality of a PostScript or PCL commercial printer with finishing
capabilities, the Infoprint 2000 can meet your needs.

In addition, the Infoprint 2000 can be configured as a Xerox printer replacement that
supports both Xerox LCDS and Xerox Metacode as input. You can obtain an Infoprint 2000
printer and configure it with Infoprint Manager 3.1 software to support any of the following:

* anetwork printer

* an Infoprint Network system

» a Data Center system

For more information about this new print solution, see Configuring an IBM Infoprint 2000.

Configuring an IBM Infoprint 2000 Printer

By applying the July PTF U464746 (APAR 1Y00208), you will be able to print from the
Infoprint 2000 printer. In order to submit print jobs to the Infoprint 2000, you must use a
new destination support system (DSS) called Infoprint 2000 (specified as IP2000 on the
command line).

Note that if your print installation uses the Infoprint Manager Email feature and you have
applied APAR 1Y00208 and now need to reject that APAR, you must delete the Email
destination on your Infoprint AIX server before proceeding.

Review the following topics before attempting to use the Infoprint 2000 printer:

e Matching Media on the Printer and the Server

e Submitting Jobs to the IBM Infoprint 2000 Printer

* Limitations that Apply to the IBM Infoprint 2000
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Matching Media on the Printer and the Server

Before you can send jobs to the IBM Infoprint 2000 printer, you must ensure that the media
supported by the printer corresponds to the media specified by Infoprint Manager. You
must:

1. Make sure media objects are defined for each media you will be using on the printer.
2. Tell Infoprint Manager what media is ready at the printer.

The Infoprint Administration window displayed below shows a highlighted Infoprint 2000
printer defined in the Actual Destinations pane. By moving to the Other Objects pane
and selecting the letter media object, you can see the media attributes signified by 'letter' in
the View and Change Medium Properties window.
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The values specified in the View and Change Medium Properties window (displayed
below) must match the values specified on the IBM Infoprint 2000 printer. Be sure that
every field (type, size, color, etc..) match the values for the particular media at the printer
exactly. If you need to add a media object that is not yet defined, see "Chapter 12.
Configuring Media" in the IBM Infoprint Manager for AIX: Administrator’'s Guide, S544-5595.

Medium name
Server
Type

Untrimmed width and length (inches)
Weight (grams)

Color

Details

0K Apply Reset Search... Cancel ? Help
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Telling Infoprint Manager what Media is Ready at the Printer

The image below shows the media page of the View and Change Infoprint 2000
Destination Properties window.

Media =i

Media ready

Media supported

|

Add copy...

Modify...

l Delete

Default output bin

Qutput bins supported

Fold booklet

0K Apply Reset Search... Cancel ? Help

To see the current values for PSF tray characteristics for each item displayed in the Media
ready field, specify the following from the AIX command line:

pdls -cp -r psf-tray-characteristics ip2000

where ip2000 is the name of the actual destination used in this example.
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For this example, Infoprint Manager displays the following values:

i p2000: psf-tray-characteristics = 1l:letter:1l:1:true
2:legal:2:2:true
3:ledger:3:3:true
4: A4 4:4:true
5:A3:5:5:true
6: B5:6:6:true

The first three values in each line, e.g. 1l:letter:1, represent tray name, medium, and input
bin number. Tray name can be anything, but each one has to be unique. We used numbers
1 through 6 in this example for simplicity. The medium and bin humber should match the
actual setup on the printer. That is, if tabloid paper is loaded in bin 2, one line should be
"2:tabloid:2:2:true".

To set or change these values, you must use the pdset command at the AIX command line.
to set the psf-tray-characteristics attribute for all six bins on the printer to define which
of the supported paper sizes are loaded on the Infoprint 2000 printer.

For example, if you map "letter" paper to bin "1" through the psf-tray-characteristics
attribute, the form definition provided with the print job should call out bin "1". When you
update the psf-tray-characteristics attribute to change a paper size on the Infoprint
2000, the Infoprint AIX server will update the printer profile to reflect the change.

To complete this task from the command line of your Infoprint AIX server, use the following
procedure:

1. To change the media ready, you must first disable the printer.

2. To initially define complete set of media ready invoke the pdset command. The
following example sets the values shown above:

pdset -cp -x "psf-tray-characteristics=1:letter:1:1:
2:letter:2:2: 3:legal:3:3: 4:tabloid:4:4: 5:A3:5:5:
6: A4:6:6:" ip2000

where ip2000 is the name of the actual destination used in this example.
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You can change an individual media ready. See the following example:
Currently, you have these values for psf tray characteristics:
I p2000: psf-tray-characteristics =1:letter:1:1:true
2:legal:2:2:true
3:ledger: 3:3:true
4: A4:4:4:true
5:A3:5:5:true
6: B5:6:6:true
To change the paper in bin 3 from ledger to tabloid, invoke the following pdset command:
pdset -cp -x "psf-tray-characteristics+=3:tabl oid" ip2000

where ip2000 is the name of the actual destination used in this example.

adding a value to the list rather than replacing the whole list.

In this case, we specified tray name "3", so the previous setting for that tray is replaced. If
you specified a tray name that was not in the list, it would be added.

The Media ready field in the View and Change Infoprint 2000 Destination Properties
window will reflect the media changes you have made.

Submitting Jobs to the IBM Infoprint 2000 Printer

The Infoprint 2000 DSS allows you to submit jobs in two ways:

Passthru Mode

Infoprint Mode
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Passthru Mode

Passthru sends the job to the Infoprint 2000 through a special socket connection that

passes the job to Infoprint Manager spooler without ripping the job.

To submit a job as passthru, you must ensure that one of the following attributes has been

specified:

job-ripped-by-server=false

doc-formats-ripped-at-dest=postscript

doc-formats-ripped-at-dest=pcl

The jobs-ripped-by-server attribute is a job attribute that takes precedence over the doc-

formats-ripped-at-dest printer attribute.

When sending a job to the printer in passthru mode, you must not specify any of the

following attributes:

Attributes Not Supported in Passthru Mode:

ACCOUNT_TEXT

BASE_PRINTER
CARRIAGE_CONTROL_TYPE
CHARS

CONVERT_TO_EBCDIC
DEFAULT_CHARACTER_MAPPING
DEFAULT_MEDIUM
DEFAULT_FONT_FIDELITY_ACTION
FONT_FIDELITY_ACTION
FORM_DEFINITION

HALFTONE

IMAGE_FIT
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IMAGE_LENGTH
IMAGE_WIDTH

INPUT_EXIT

NEW_LINE_OPTION

NUMBER_UP
OTHER_TRANSFORM_OPTIONS
OUTPUT_BIN

OUTPUT_FORMAT

OVERLAY

PAGE_DEFINITION

PAGE_SELECT

PLEX

PRINTER_PASS_THROUGH
RESOURCE_CONTEXT
RESOURCE_CONTEXT_FONT
RESOURCE_CONTEXT_FORM_DEFINITION
RESOURCE_CONTEXT_PAGE_DEFINITION
RESOURCE_CONTEXT_PAGE_SEGMENT
RESOURCE_CONTEXT_OVERLAY
SHIFT_OUT_SHIFT_IN

SIDES

START_ON_NEW_SHEET

SUBJECT_TEXT
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TABLE_REFERENCE_CHARACTERS
TRANSFORM_MESSAGE_FILE_NAME
X_IMAGE_SHIFT

Y_IMAGE_SHIFT

Y_IMAGE_SHIFT_BACK

If these attributes or conditions are sent to an Actual Destination, the file will print as black-
and-white (MO:DCA-P) output.

Job Attribute Conditions Not Supported in Passthru Mode:

1. Any use of the JOB_FINISHING attribute.

2. If the job is a variable data job or contains:
* More than one printable document
* an insert sheet
¢ a file-reference document
¢ a document with docunent _f or mat =nodca

¢ adocument with job_rip_action=rip_and_hold or
job_rip_action=rip_only

e acopy_count attribute set higher than 1.

Infoprint Mode

Infoprint mode implies that the job is ripped by Infoprint Manager. In this mode you can
specify from a range of different calibration screens by using the Halftone Management System.
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Limitations that Apply to the IBM Infoprint 2000

Because the Infoprint 2000 printer allows you to print AFP files on IPDS printers, there are
some limitations to the printer and job commands that you can use. The Infoprint 2000

DSS does not support:

Task

Syntax

[Duplex printing of tab paper.

Note: While the Infoprint Manager GUIs allow you tojpdpr -x "si des=2
request this support, printing duplex with tabbed pl ex=si npl ex" Filel1l
paper causes output to be printed on the wrong side of
the page and can cause a printer jam.
. N pdspace -cd -f

Forward space the job printing si decount

. _— pdspace -cd -b
|Back space the job printing <i decount
Pausing a currently printing job pdpause -cp -]
Resuming a job that had been paused while printing
Note: This option is supported for jobs paused while pdresure - c|
ripping.
Synchronous shut down of a printer. pdshut down -cp -s
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Printing Color Email

If you have color Portable Document Format (PDF) or PostScript files, you can send these
files to target email address through Infoprint Manager and receive color output.

By applying the July PTF (APAR 1Y00208), you will obtain access to the color Email, provided
you have followed the directions for Configuring Email.

Note: Color Email is not supported if your Email job sent to an Actual Destination contains
any of the attributes specified in the lists that follow. If these attributes or conditions are
sent to an Actual Destination, the file will print as black-and-white (MO:DCA-P) output.

Document Attributes Not Supported for Color Email:

ACCOUNT_TEXT
ADDRESS1_TEXT
ADDRESS2_TEXT
ADDRESS3_TEXT
ADDRESS4_TEXT
CARRIAGE_CONTROL_TYPE
CHARS

CONVERT_TO_EBCDIC

DEFAULT _CHARACTER_MAPPING
FONT_FIDELITY_ACTION
FONT_RESOLUTION
FORM_DEFINITION

IMAGE_FIT

IMAGE_LENGTH

IMAGE_WIDTH

INPUT_EXIT
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Document Attributes Not Supported for Color Email (continued):

NEW_LINE_OPTION
NUMBER_UP

OUTPUT_FORMAT

PAGE_DEFINITION

PAGE_SELECT

PLEX

RESOURCE_CONTEXT
RESOURCE_CONTEXT_FONT
RESOURCE_CONTEXT_FORM_DEFINITION
RESOURCE_CONTEXT_PAGE_DEFINITION
RESOURCE_CONTEXT_PAGE_SEGMENT
RESOURCE_CONTEXT_OVERLAY
RESOURCE_CONTEXT_USER
SHIFT_OUT_SHIFT_IN

SIDES
TABLE_REFERENCE_CHARACTERS
TRANSFORM_MESSAGE_FILE_NAME

X_IMAGE_SHIFT
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Job Attribute Conditions Not Supported for Color Email:

1. Any use of the job_finishing attribute.

2. If the job is a variable data job or contains:
* More than one printable document
* aninsert sheet
* afile-reference document
* adocument with docunment _f or mat =npdca

e adocumentwithjob rip_action=rip_and_hold or
job_rip_action=rip_only

* acopy_count attribute set higher than 1.
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Managing Halftone Calibration of Your Infoprint Printers

The Halftone Management System allows you to manage calibrations across your business
enterprise. This interface gives you the ability to calibrate screens for each screen frequency
on all your printers. The result is consistent grayscale for each appearance selection. This
feature replaces the "Calibrating the Printer Device" function described in "Chapter 17.
Actual Destination Tasks for Operators™ in IBM Infoprint Manager for AIX Administrator's
Guide, S544-5595-00.

You can run three IBM Infoprint 4000 printers and calibrate for each one. The Halftone
Management System also allows you to calibrate each print engine separately, so one could
support Tag Image File Format (TIFF) files, while the other processed Joint Photographic
Experts Group (JPEG) files.

From the smallest network printer to the largest production printer, you can either use the
calibration provided (generic), or create your own (customized). You can calibrate for
different paper types to account for differences between supplies. Infoprint Manager will
save and manage these calibrations, allowing you to select them on a job-by-job basis.

To find out how to install this feature, see Configuring the Halftone Management System.

To find out how to begin using this feature, see Using the Halftone Management System.

Configuring the Halftone Management System

By applying the July PTF U464746 (APAR 1Y00208), you will obtain access to the Halftone
Management System interface, which replaces the Printer Calibration interface on Infoprint
Basic Configurations.

The Halftone Management System interface consists of two parts:
1. A daemon process that runs on the Infoprint AlIX server.
2. A client that also runs on the Infoprint AIX server.

You invoke the Halftone Management System through the Printer Calibration icon (the
page embossed with a lower-case | that is the fourth icon from the right) on the toolbar of
the Infoprint Manager desktop:

rili P2

ROLIE

Page 14 of 26 8/ 30/ 99



This page describes the following two procedures that you should ensure have been
completed before attempting to use the Halftone Management System:

1. Restarting the Halftone Management System

2. Calibrating a Densitometer

Restarting the Halftone Management System

If you find the Halftone Management System icon in the tool bar on your Infoprint Manager
desktop after applying this PTF and it starts, you do not need to perform this procedure and
should go to Calibrating a Densitometer. If you do not see the Halftone Management
System icon on your Infoprint Manager desktop or it does not start, you can use the
following procedure to start the Halftone Management System:

1. From your Infoprint AIX server's command line, ensure that your Infoprint AIX
server is running by specifying:

ps -ef | grep pdserver

You should see a response that shows the server running:

ID Process Time Process and Server Name
Number
r oot 26078... 11:24:36 ... pdserver Servername

Note that the server must be running before you start the calibration client.
2. From the root directory, start the Calibration daemon (runcalibd) by specifying:
[usr /| pp/pd/ipcal/bin/runcalibd
A return to the command prompt indicates that the daemon is properly connected.

3. Now, you must start the Halftone Management client, on either this Infoprint AIX
server or another AlX server by specifying the following at a command prompt, or
invoking the toolbar icon as described in Invoking the Halftone Management System:

/fusr/ | pp/pd/ipcal/bin/runcalib

From the client screen, a pop-up Halftone Management System window
announces Starting the Hal ftone Managenent System Cient.
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4. Then the Halftone Management System window opens.
The client has created a calibgui.db file in the directory from which you entered the command.

Note that starting from a different directory will mean you have to redefine the servers to which
you want to connect. Multiple clients can be started on the same AIX server, but they must be
started from different directories. Because the clients would try to share the calibgui.db file, you
cannot start two clients from the same directory.

Calibrating a Densitometer

The following procedure describes how to calibrate the XRITE 400B (1060) densitometer,
using the Reflection Reference Card (part number 400-62).

The Reflection Reference is the card that is used to calibrate the densitometer. You will use
only the circular patches labeled 1 (white reference) and 3 (black reference). The
densitometer should be calibrated periodically, or whenever the instrument displays

RECAL. You should store the Reflection Reference Card in its envelope. The following
presumes that the Serial Number B2844504E-02320 Reflection Reference is used.

1. Press the FUNCTION and ENTER keys in sequence, then release.

After the version and copyright notices appear, the display will show N cal O Y.
2. Press the ZERO key and release.

After the version and copyright notices appear, the display will show N gcal Y.
3. Press the FUNCTION key and release.

SET LO is displayed momentarily, followed by 0.09L. This is the white patch ORTHO
value from the Reflection Reference card.

4. If 0.09L displays, press the ENTER key.

SET HI is displayed momentarily, followed by 0.09L. This is the black patch ORTHO
value from the Reflection Reference card.

5. If O 1.78H displays, press the ENTER key.

6. When you see READ WHT displayed, center the circle on the base of the
densitometer over the white patch (the one labeled "1") on the Reflection Reference.
Push the head down and then release it to establish the white patch Optical Density.

If INVALID displays, repeat the measurement.
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7. When you see READ BLK displayed, center the circle on the base of the densitometer

over the white patch (the one labeled "3™) on the Reflection Reference. Push the
head down and then release it to establish the black patch Optical Density.

If INVALID displays, repeat the measurement.

The densitometer is now calibrated.

To find out how you can calibrate and set output appearances, see Using the Halftone
Management System.

Using the Halftone Management System

The Halftone Management System allows you to calibrate the output appearance of each of
your printers by providing a set of generic output screens (screen frequency combined with
output appearance) and allowing you to define additional calibrations for each printer's
specific paper types, colors, or any other environmental consideration.

To use this tool to calibrate your printers, perform the following procedures in sequence:

1.

N oo g Bk~ w DN

Invoking the Halftone Management System

Connecting to Your Infoprint AIX Server

Working with Patch Sets

Printing a Patch Set

Measuring Optical Density with a Densitometer

Calibrating a Halftone

Specifying a Halftone for Printing on the Infoprint AIX Server
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Invoking the Halftone Management System

The Halftone Management System can be invoked from the Basic Infoprint Administrator's

GUI:

1. Start the Infoprint AIX server Calibration daemon (runcalibd) has been started by
entering the following command from an AIX command line: .

/usr /| pp/pd/ipcal/bin/runcalibd.

After a few minutes, the command prompt should return.

2. Ensure that your Halftone Management System daemon is running by specifying:
ps -ef | grep runcali bd.
You should see a response that shows the runcalibd daemon running:

ID |Process Number Time Process and Server Name
root |26078... 11:24:36 ... ....runcalibd

3. From the toolbar that displays that the bottom of the Basic Infoprint Administrator's
GUI (displayed below), double-click on the Printer Calibration icon (fourth icon
from the right).

4. Double-click on the Halftone Management System that appears above the Printer

Calibration icon

(as dis
gl

played below).

This icon starts the Halftone Management System client.

If you press this icon before starting the Halftone Management System daemon,
Infoprint Manager provides an Error pop-up dialog with the following message:

Error in connecting to host fully _qualified_server_name -- A renote host
refused an attenpted connect operation.

To resolve this problem, you must close the Halftone Management System client

window and restart the daemon.

Once you have completed these steps, move to the procedure described in

Connecting to Your Infoprint AIX Server below.
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Connecting to Your Infoprint AIX Server

The first time you start the Halftone Management client, you will see a blank screen. You
must connect to the Infoprint AIX server to see a list of the printers that are available for
calibration:

1. From the Halftone Management System (or Main) window, select the Edit ->
Servers option.

2. From the Servers window, select the File -> Add Server option.

3. In the Server Properties window, fill in the Server Name field with the symbolic
server name, and the Hostname field with either the explicit name of the server or
the server's dotted decimal notation IP address.

For example, the Server Name field value could be sage. penn. boul der.i bm com
while the Hostname field value could be either sage or 9. 99. 43. 73.

4. Return to the Main window and either use left mouse button to double-click on each
printer or highlight the printer and press enter to display its output screens (as
displayed below). The Main window displays all printers defined to the Infoprint
server to which you are connected, but only the IPDS printers contain screens that
can be calibrated.

Page 19 of 26 8/ 30/ 99



Halftone Managemen

=
o
o
o
e
o
o
o
o
o
o
o
o
o
o

Page 20 of 26 8/ 30/ 99



Working with Patch Sets

In order to calibrate a particular printer for a particular paper type, you must first select a
patch set. A patch set is a file that displays patches in different shades of gray for all screen
frequencies.

To perform this task, use the following procedure:

1. From the Halftone Management System window, click on an output appearance
(such as i bml06l pi ), and select the Edit -> Patch Sets option.

2. From the Patch Sets window, click on a patch set (such as patches11) and select
the Edit -> Properties option.

3. From the Patch Set name window (where name indicates the patch set highlighted
in the previous step), use the left mouse button to select the patches that you would
like to modify in order to create a unique patch set.

4. Once you have defined the patch set, select the File -> Save as option and save
your patch set with a unique name.

Note that the shipped patch set patchesll cannot be modified. However, a user-
created patch set can be modified through the Save option. In the example below,
the Save option is greyed-out because no changes have been made to the file.

Fatch set patct

AaaAaan

e | A
el f e
aaAAIaNag
AAFAAIAAAE
aaaaaRANaS
AAAA AR
el f ]
dak A AaE
HERREANNE
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Printing a Patch Set

Once you have either created a customized patch set or settled on a standard patch set for
use, you must print it to the Infoprint printer so you can use the densitometer to measure
the density of each grey patch. To print a patch set, use the following procedure:

1. Select both the printer and the screen that you want to calibrate for a paper type.

2. Before printing, set the logical-destination-assigned attribute of the actual
destination (printer) to the name of the logical printer with which it is associated. If
you have not set this attribute, the system will prompt you to make a selection.

Note that this logical printer must not send jobs to any other actual destination
except the one that you are calibrating.

3. Using either the Infoprint Submit job ticket window or the pdpr Command from the
AlIX command line, print the patch set.

Measuring Optical Density with a Densitometer

The following procedure describes how you can measure optical density using the XRITE
400B Densitometer. While you can use other densitometers, this procedure has been
verified with this particular make and model. Ensure that the Status T density readings are
absolute, not paper reference.

1. Press the FUNCTION key until DEN appears. If DEN-R appears, press the ZERO key
and try again.

2. Center the circle on the base of the densitometer over the area to be measured.
3. Push the head down and release it to measure the Optical Density (OD).

The density reading will appear as X.XXD.
4. Record the X.XX value as it is displayed.

Several measurements should be taken at different representative locations on each
gray patch and averaged to obtain an accurate OD value.
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Calibrating a Halftone

Once you have either selected an existing patch set or created your own customized patch
set, you must print it out, use a densitometer to measure the density of each grey patch.
Once you have taken denistometer readings, you must enter the calibration values in the
Halftone Calibration Management System to create a calibration curve for the printer.

Note: Ensure that you use the Halftone Management System to both add and delete patch
files and Calibration files.

Use the following procedure to accomplish these tasks:

1. From the Halftone Management System window, select the Actions -> Print
Patches option.

2. From the pop-up window, specify yes.

3. Once you retrieve your output from the printer, use the densitometer to measure the
patches.

4. Select the same actual destination (printer) and screen that you selected before you
printed the patch set.

Note that the printed patch set identifies the screen, patch set, and printer, along
with a date/time stamp.

5. Once you have finished using the densitometer, return to the Halftone
Management System window and select the Actions -> Calibrate option.

6. From the Enter calibration values window (shown below), set The number of
entries to average field (it defaults to 3) to the number of measurements you took
for each patch.

7. To enter your densitometer readings, begin with the 0%6 field. Enter your first 0%
value and press Enter. Your value will be displayed under the columns Average,
Min, and Max.
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If you specified more than 1 in the number of entries to average field, the cursor will
remain in the field for your next reading. Otherwise, it will move on to the next patch
field. Continue until all your readings have been entered. The display below shows a
sample customized Calibration named first _run. Note that the 50% setting only
has two values submitted.

= calibration values

g 0000000000000
met uw |
-
E=a
Clear |
Clear |
E=a
Clear |
E=a
E=a
Clear |
E=a
Clear |
Clear |

RN

8. Once you have filled in your calibration values, press the Do button. Your calibration
is saved in the Zusr/local/Infoprint/config directory and ready for use.
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Specifying a Halftone for Printing on the Infoprint AIX Server

You can use a particular halftone for printing a greyscale file through either Infoprint Submit
interface (if the client GUI is running on a Windows 95 or Windows NT system) or the AIX
command line (if the client GUI is running on an AIX operating system).

Note: The Halftone Management System does not need to be running when you print the
job.

Printing from Infoprint Submit

You can print using a particular halftone for printing a greyscale file from a job ticket
(name.jtk file) in Infoprint Submit. Through this interface, you can specify a specific screen
and output appearance. Begin by selecting a value in the Screen Name field of the Look
tab. Note that all screen frequencies shipped with the product have the term ‘ibm'
prepended to their identifier. If you are accessing this interface for the first time after
applying this PTF, all your previous default calibrations will have 'ibm" attached to the name.

Infoprint Manager allows you to determine output appearance on a job-by-job basis by
setting a default screen and output appearance in a default document or job object. For
more information about creating default document or default job objects, see Chapter 11,
"Creating and Managing Default Job and Document Objects" in the IBM Infoprint Manager
for AIX Administrator's Guide, (S544-5495).

Printing from the AIX Command Line

You can submit a halftone calibration from the AIX command line by using some variation of
the following:

Command Printer

pdpr -p sip20-sage

Customized Calibration file

- X hal ft one=generi c106l pi : hi ghl i ght - m dt ones. nycal

File to Be Printed

gr eyscal e. ps

Note: When submitting a pdpr command from the AIX command line, you specify the
halftone attribute, rather than setting both frequency and output appearance as you do
when using the Infoprint Submit client interface.
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