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System i Access for Windows - Lab Worksheet
This worksheet contains names and addresses that you will need to complete the lab. Substitute the values
containing "xx" with your team number.  For example, caxx would be ca01 for Team 1.  Be sure to include a
leading zero if your team number is less than 10.

CAxxPRTPrint Session ID Name  PC5250  
CAxxDSPWorkstation ID Name  PC5250  
caxxpwdWindows Password  PC  
caxxWindows User Name  PC  
next to your PCTeam NumberPC  
\\<server name>\qibmInstall and Service directoryi5/OS
PRTCAxxPrinter queue (lib/name)  i5/OS
<provided by instructor>i5/OS NetServer Name  i5/OS
<provided by instructor>System (Server) Name  i5/OS  
caxxpwdPassword  i5/OS

caxx    
where "xx" is the number next to your PC.
Use two digits:  e.g. for "1", use "01". 

User ID  i5/OS  

Value  Variable  Environment  
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Introduction
IBM's Windows product for PC to IBM System iTM client/server computing applications is System i Access for
Windows. V5R4 and V6R1 System i Access for Windows is designed for Windows 2000, XP Professional,
Windows Server 2003, Vista, and later Microsoft operating systems to offer them TCP/IP connectivity to N +
or - two i5/OS releases.  This lab will introduce you to some of the basic functions and features of this client. 

Even if you are an experienced user of System i Access for Windows, you should still follow through the
sessions since the lab sessions may be interdependent. Occasionally we have you create something in one lab
and use it in a later lab.

Your lab administrators have prepared a worksheet with various system names and values that you will need to
complete the lab.  See "System i Access for Windows - Lab Worksheet" on page 2 at the beginning of this lab
guide.  The instructors will give you the values for each variable on the worksheet.  You will need the values on
this worksheet throughout the lab, so keep it handy! 

Please ask questions if you run into problems or need clarification at any time during the lab.

Good luck with the exercises!  

The exercises in this lab were originally developed by the IBM International Technical Support
Organization in Rochester, MN.  
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Lab 1. Setting Up and Getting Started
Before System i Access for Windows can be used, some iSeries licensed program products (LPPs)  need to be
installed on the iSeries. The following LPPs are required: 

w 5761TC1 or 5722TC1 - TCP/IP Connectivity Utilities for iSeries   

w 5761SS1 or 5722SS1 opt. 12 - Host Servers 

The following LPPs are optional, and do not need to be applied on the iSeries server for all applications:   

w 5761XE1 or 5722XE1 - System i Access for Windows 

Enables System i Access service pack PTF application on the iSeries server   
Allows System i Access for Windows to be installed from the iSeries server 

w 5761XW1 or 5722XW1 - System i Access Family 

Required for using System i Access for Windows licensed functions:  specifically, the PC5250
display and printer emulation and Data Transfer components.

These LPPs have already been installed on the IBM System i5TM servers available for the lab.  They are listed
only for your reference.

System i Access for Windows and i5/OS NetServer
System i Access for Windows relies on i5/OS NetServer for file and print serving functions. The full name of
this function is iSeries Support for Windows Network Neighborhood, although the name i5/OS NetServer is
used throughout this lab manual.

i5/OS NetServer has been available since V4R2 OS/400. It is part of OS/400 or i5/OS and not a part of System i
Access for Windows. It is also not a separately installable option or product but is included with i5/OS. 

i5/OS NetServer enables a System i to perform file and print serving in a Windows network without the need to
install additional hardware or software on the System i. i5/OS NetServer uses the Server Message Block (SMB)
protocol to communicate with the network. The underlying network protocol is NetBIOS over TCP/IP.  i5/OS
NetServer has already been configured and started by the instructor.  In a later lab, we will show you how to set
up NetServer shares through System i Navigator to share network drives and printers to your Windows PC
Network.

In addition, i5/OS NetServer can be used to install System i Access for Windows on the PC from an i5/OS file
share.  Tasks 2 and 3 show how you can also install System i Access for Windows subcomponents and  service
packs using i5/OS NetServer file shares.  

Task 1: Exploring the System i Access for Windows Welcome Wizard
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The System i Access for Windows Welcome Wizard is a useful tool for getting familiar with System i Access
for Windows.  It contains information for new users and what’s new in the release.  This lab shows you some of
the features of the Welcome Wizard and how it may be used to find information about System i Access for
Windows.

1.  The Welcome Wizard should have started automatically upon starting your PC.  If it is not displayed,
double click on the IBM System i Access for Windows icon on your desktop and then double click on
Welcome Wizard to display the welcome window.

2. If you are new to the product, select What is System i Access for Windows.  To see a summary of
functions in V5R4, select What’s New in V5R4.

3. Explore any other sections of the welcome wizard that you may find interesting.

Task 2: Using Selective Setup
In the interest of time, System i Access for Windows has already been installed on the PC you are using. The
Selective Setup application allows additional System i Access for Windows components to be installed or
existing components to be removed from your PC.  This following steps take you through the process of using
Selective Setup.  Components may be added or removed at any time after System i Access for Windows is
installed on the PC.

1. Double click on the IBM System i Access for Windows icon on your desktop.
2. Start Selective Setup by double clicking on Selective Setup.
3. On the Selective Setup dialog, click Next.
4. Make sure the Selective Setup install path location matches the Install and Service directory name as

provided on your lab worksheet.  This directory and the installation files within it are located on the
iSeries server and will be accessed using the i5/OS NetServer capability.  Click Next to continue
Selective Setup.  It may take a few minutes for Selective Setup to determine which components are
already installed on your PC.  

5. The Component Selection panel, as shown below, contains a listing of all the components available for
System i Access for Windows.  Those with a check mark next to them are already installed on your PC.
Those without a check mark are available to be installed on your PC.

6. Navigate the component listing to see the components installed for this lab.  Do not remove components
or add new components since all the components required for this lab are already installed.
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7. Select Cancel to exit Selective Setup.  On the Exit Setup dialog select Exit Setup to end Selective Setup.

Note: If Selective Setup is used to add additional System i Access for Windows components after a service
pack has been applied, the service pack must be reapplied to get fixes for the additional components.  In many
cases, the additional components may not work properly until the service pack is reapplied.  The next task
walks you through the service pack installation process.

Task 3: Service Pack Installation Options
Service Packs contain fixes for defects found in System i Access for Windows.  Service Pack installation files
are normally installed as PTFs on the iSeries server by the server administrator.  The IBM System iTM you are
using contains the latest Service Pack available for System i Access for Windows.  If the Service Pack PTFs are
installed on the System i, the Service Packs can then be installed automatically, after a PC is booted and a user
logged on to Windows, with a function called Check Service Level. 

When you install System i Access for Windows on your PC, an entry is added to the registry that automatically
starts Check Service Level.  Check Service Level determines whether or not the iSeries has a more recent
service pack available than what is installed on your PC.  To manage Check Service Level, do the following:

1. Open the System i Access for Windows Properties located in the System i Access for Windows Folder
or in the Windows Control Panel.

2. Select the page marked Service.
3. Look at the options When to check service level. You can specify how often Check Service Level runs

or completely disable Check Service Level from running automatically. You can also delay the Check
Service Level between 1 minute and 8 hours after PC startup. This helps to prevent Check Service Level
from running while Windows services and other applications are still starting on your PC. Change the
delay to 10 minutes.

4. Look at the Install Options. Perform silent installation allows a Service Pack installation without any
user intervention but requires a file that controls the silent install. Copy install image to PC before
installing is required if you try to install a Service Pack over a slow or unreliable communications link.
Both options are explained in the online users guide. Don't select any of these options.   

5. The Source directory may not be filled in with the path that should be used for Check Service Level.
Make sure the Source directory contains the Install and Service directory name as provided on your lab
worksheet.  Note:  Check Service Level will traverse the QIBM directory to find the System i Access for
Windows directories that it needs.

6. Click OK to close System i Access Properties.

Task 4: Installing an System i Access for Windows Service Pack
Like Selective Setup, service pack installation uses the i5/OS NetServer to access the files required to install the
Service Pack.  System i Access for Windows can be customized to install service packs manually or
automatically by checking the service pack level every specified number of days.  This task uses Check Service
Level to manually install a Service Pack on your PC.  The following steps walk you through how to manually
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run Check Service Level to see if your PC has the latest service pack.  If it doesn’t, Check Service Level will
allow you to install the latest service pack.

1. From the Start menu select Start -> Programs -> IBM System i Access for Windows -> Service ->
Check Service Level.  This will check your service source directory for a newer Service Pack level
than what is installed on your PC. 

2. If your PC has the latest service pack installed you should see a message indicating that you have
the same service level as the one installed on the iSeries.  If so, skip to the next lab.  Otherwise,
follow steps 3 and 4 to go through the process of installing the service pack.

3. Click Yes to install the Service Pack.   On the Welcome page, select the options View the
README file and Enable service pack uninstall.  Select Next.  The readme file will display
using WordPad.  The Service Pack readme file contains a list of fixes in the current service pack.
Review the readme file and close WordPad.  Select Next to start copying service pack files to your
PC.  This process may take a few minutes to complete.  Select Finish to end the service pack
install.

4. You may or may not be prompted to reboot your PC. This depends on what files needed to be
replaced by the Service Pack.  Reboot if necessary.  The Service Pack is now installed on your PC.

System i Access for Windows has now been successfully setup on your PC and you can continue with the next
Lab exercise. 
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Lab 2. Configuring an i5/OS Connection
Each System i Access for Windows function will establish a connection to the server if one does not already
exist. If an System i Access for Windows function is used for the first time for a System i server, the user needs
to specify an System i name that is known in the TCP/IP network, or type in the IP address. The connection
information is then stored in System i Navigator and is known to all System i Access for Windows functions.  

In this exercise you will learn how to create an iSeries connection using System i Navigator.   

Task 1: Configuring an i5/OS Connection
1. Double click on the System i Navigator icon on your PC desktop.   
2. A message box will appear and the Welcome to System i Navigator wizard may start. If so, close the

window.
3. If a connection to an System i hasn’t been previously made, you should see a dialog indicating that no

connections to System i exist.  If so, continue to step 4 to add a connection to a system.  If a connection
was already made to system, you will see the system names listed in the left pane of System i Navigator.
In this case, skip to the next Lab.

 
4. Select Yes in the message box to start creating a connection.
5. The Add Connection wizard starts. Enter the server name (from your lab worksheet) in the Server entry

on the first page. Then click Next. 
6. Select Use Windows user name and password, no prompting, as the user ID to sign on to the system,

then click Next. 
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7. Click on the Verify Connection button.   
8. A status windows display the progress of the connection verification. Once the connection is verified,

click OK.   
9. Connections to all the host servers should verify successfully. Click OK on the verify panel and Finish to

close the Add Connection wizard.  Your system should now display in the left pane of System i
Navigator.

This exercise is now complete. 
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Lab 3. Data Transfer
Data Transfer is an application provided in System i Access for Windows for transferring of data between the
client PC and the server. With the newest releases of System i Access for Windows, new enhancements include
support for Lotus WK4 files, downloading data into a HTML template, a new data transfer wizard, support for
tab delimited text files, 32K row size, and policy support have been added.

Task 1: Transferring Data from the System i
1. From the Desktop, double click on the IBM System i Access for Windows icon to bring up the folder,

then double click on the Data Transfer from iSeries Server icon. This brings up the Data Transfer from
iSeries window.   

2. Select your iSeries from the iSeries System Name drop-down. 
3. Enter QIWS/QCUSTCDT in the iSeries File Name field. You can also click on the Browse button to

locate the file on the iSeries system.
4. Select File from the PC Output Device drop-down list. Note that you can also download to Display,

Hyper Text Markup Language (HTML), or Printer.   
5. Enter c:\customer.csv in the PC File Name field. Click the Details button.   
6. In the File Details window, select the option to Create new file. Select file type Comma Separated

Variable (CSV). Leave the other settings as they are and click OK.   
7. Click on the Transfer data from iSeries button.  You should receive a message showing the number of

rows transferred when the transfer completed.
8. To save this transfer, click on File -> Save from the pull-down menu. Select Desktop as the Save in field

and enter the file name Task1. Click on Save.  This profile will be save as type: dtf (data transfer from).   

9. Close the Data Transfer from iSeries window. 

Note: Saving a transfer profile to the desktop creates an icon for the transfer request. This enables you to
reload the transfer request easily by just double-clicking on the desktop icon. However, you can also save
the transfer request to other folders and reload the request by locating it using the Windows Explorer
application and double-click on it once located. 

Task 2: Transferring Data to the iSeries
The Data Transfer to iSeries application allows you to replace the member data of an existing database file or
create a new iSeries database file based on an existing one. In this exercise, we are going to create a new iSeries
database file based on the QIWS/QCUSTCDT file, and transfer the data from the PC file created in Task 1 to
the iSeries system. 

1. Right mouse click on the Windows Desktop, select New->Data Transfer to iSeries. This brings up the
Data Transfer to iSeries wizard. Click Next.   

2. Enter c:\customer.csv in the PC File Name field, then click Next.   
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3. Select Yes to use a File Description File, then click Next.   
4. Enter c:\customer.fdf as file name and click Next. 
5. Select your iSeries system from the drop-down list and click Next.   
6. Enter CAxxLIB/QCUSTCDT1 (where xx is your team number) in the Library/File(Member) field. Click

the Next.   
7. For Create iSeries Object select Create new file and member. Click Next.   
8. Enter some member text and click Next.   
9. Click on the Details button.   
10. Select Data file type. Enter QIWS/QCUSTCDT in the Field reference file name field. This creates a

new iSeries database file based on the QCUSTCDT file in library QIWS. Leave the rest of the settings as
default and click OK, then click Next. 

11. Click Finish. This will end the wizard and bring you to the data transfer window.   
12. Click the Transfer data to iSeries button. You should receive the message showing the numbers of

rows transferred when finished.   
13. Save the transfer request by clicking File -> Save. This profile will be saved as type: dtt (data transfer

to).
14. Close the Data Transfer to iSeries window.   

Task 3: Using the Data Transfer Create Database File Wizard
In Task 2, we created a new iSeries database file based on an existing iSeries database file. The Data Transfer to
iSeries also offers a new wizard that allows you to create a new iSeries database file based on an existing PC
file. In this exercise, you are going to create a new iSeries database file based on the customer info PC file
created in Task 1. 

1. Open the IBM System i Access for Windows folder and double click on the Data Transfer to iSeries
Server icon.   

2. In the Data Transfer to iSeries window, you can invoke the wizard either by selecting Tools -> Create
iSeries Database File or clicking the Create iSeries Database File icon (the one that looks like a
spreadsheet) from the Toolbar. When the Create iSeries Database File Welcome panel opens, click on the
Next button to proceed.   

3. The wizard prompts you for the name of the PC file. Enter c:\customer.csv in the File name field. You
also can use the Browse button to locate the file. Click on Next.   

4. By default, the wizard will automatically sense the type of the PC file (in this case, it should be Comma
Separated Variable CSV).  You can change the file type by selecting the relevant type from the
drop-down list. Click Next.   
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5. You need to specify a file description file (FDF) name. By default, the wizard uses the existing
customer.fdf file. Click Next.   

6. If your PC file consists of date, time or decimal values, then it is important to ensure that the format used
in your PC file matches those used on the iSeries system. Click the Data Options button to view the type
of formats available. When done, click on OK to return to the previous panel and then click on Next to
proceed to the next panel.   

7. In order to create the database file, the iSeries needs information on the database layout. To get this
information necessitates scanning the PC file to obtain the number of fields and field types needed to
create the database. Click on the Start Scan button to begin scanning the PC file. When the scan is
completed, click on Next to proceed.   

8. A list of fields determined by the scanning is shown. You can change the field attributes by selecting the
field and click the Details button. For example, you could change the generic field names Fx to something
meaningful. (If you use the wizard on file types that contain headers, e. g. 1-2-3 or Excel, then the field
names would be extracted from the header of the PC files.) You can also add or remove fields by
right-clicking at the fields. Click Next.   

9. Click the arrow down button and select the iSeries system name from the drop-down list. Click Next.   
10. Enter CAxxLIB/QCUSTCDT2 (where xx is your team number) in the Library/File field. This will be

the file name of the new iSeries database file. Click Next.   
11. Enter a brief description for the new iSeries database file and click Next to proceed.   
12. Confirm your create options and click Next to create the database file on the iSeries system. If you need

to change any of the options shown, use the Back button.   
13. The wizard shows a message telling you that the database file was created successfully. Click Finish. If

you receive an error message, notify the instructor.   
14. You should now be back at the Data Transfer to iSeries window. Note that the values for each field are

automatically set to those specified in the wizard. Important! No data has been transferred to the iSeries
system at this point in time.   

15. Click Transfer data to iSeries button to complete the transfer request. Again, a message pops up
showing the number of rows transferred when the transfer completes.   

16. Click File -> Save. Select Desktop for the Save in field and enter the file name as Task3.
17. Close the Data Transfer to iSeries window.

Task 4: Downloading data with the Excel Add-in
This task shows you how to use the System i Access for Windows Data Transfer Add-in for Microsoft Excel to
transfer data directly from the iSeries into an Excel spreadsheet.  

1. On your Windows desktop, click ‘Start->Programs->Microsoft Excel’ to start Microsoft Excel.

2. Excel should have created a default workbook "Book1" when it was started, if not, select the File menu,
click New... and double-click on Workbook to create a new workbook.

3. Select the workbook by clicking on it.
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4. Click on the Data menu and select Transfer data from iSeries...  You'll see the following panel.

5. Notice that you can either create a new transfer request or use an existing request.  Choose to create a
new transfer request by clicking on Create new.

6. Click OK to start the create a new request.

7. On the system name panel choose the iSeries server name from your worksheet.  Click Next.

8. Enter QIWS/QCUSTCDT as the Library/File(Member) to download. Click Next.

9. Explore the options on the Customize File Transfer panel.  Notice the similarities between these options
and the options available in Data Transfer From iSeries.  Close any option windows you may have
opened.  Be sure to choose cancel if you changed any options, otherwise your transfer may not run
correctly.

10. Click Next.

11. On the Save request to file panel, leave the File name field empty since we do not need to store this
request.

12. Click Finish.   Data will be transferred directly into your Excel spreadsheet!

13. Close the Microsoft Excel application.  Choose not to save the worksheet.
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Lab 4. PC5250
The objective of this exercise is to familiarize you with the Personal Communications 5250 emulator that ships
with System i Access for Windows. Note that you are over half way through your lab exercises and just seeing
your first "green screen". Although there have been many functions added to System i Navigator, there are still
occasions you will need the use of 5250 emulation screens.   

Task 1: PC5250 Display Emulation Session

Configuring a session

1. Right mouse click on an empty spot on your Windows Desktop.   
2. Select New->iSeries Desktop Icon.   
3. In the pull down list, select PC5250 Emulator as application, then click Next.   
4. Select the name of your iSeries (if it is on the pull down list, otherwise enter the name or the IP address

of your iSeries). Click Next.   
5. For icon text, enter the iSeries system name.  Then click Next.   
6. On the last page, click Finish. This will create an icon your Windows Desktop that will start PC5250 

when you double click on it.   
7. Double click on the icon you just created. PC5250 will start, and a configuration screen will come up.   
8. The name of the system you will be connecting to should be in the System Name field. Click on

Properties. Properties allows you to set up your session to use Secure Sockets Layer (SSL) if SSL has
been installed on the PC. Select Not Secured.  Click OK to close the Properties window.   

9. Specify your Workstation ID that is given on the worksheet. The iSeries uses this Workstation ID to
create and assign a dedicated virtual display device description under TCP/IP.   

10. Select Display for the type of emulation. Then select the size of the emulation you desire. For this
exercise chose 27x132. This selection permits the session to dynamically adjust the size of the display to
either 80 or 132 column as needed. (Try displaying QPJOBLOG or other 132-column wide spool files
later on to see the dynamic adjustment of the session).   

11. Select the appropriate Host Code Page.  The default selection “37 United States” should already be
selected.

12. Select the Bypass Sign-on checkbox. This option will allow you to bypass the iSeries sign-on screen
after PC5250 establishes communications with the iSeries system. 

Note: The iSeries system value QRMTSIGN must be set to *VERIFY to enable this support.   
13. Select the Auto-reconnect checkbox. This option will allow PC5250 to automatically reconnect the

session to the iSeries should the session be disconnected.   
14. Review the Port number setting. The default telnet setting for UDP and TCP/IP is 23.   
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15. Click OK and PC5250 will establish the connection. Observe connection activity messages on the status
bar at the bottom of the session window.   

16. To save the session, select the File pulldown menu, then the Save option. 

Note: Another method of saving profiles is to use the Save on Exit feature. This method will allow any
session changes to be saved automatically on closing the session. To enable this feature, select the Edit
pulldown menu, then select Preferences->Exit. Under Save Settings on Exit, select Always to enable
this feature.  Another useful option is Confirm on Exit Session.  When this option is selected, PC5250
will confirm your decision to exit the session. 

Tips for using a session

Setting the PC5250 cursor to a blinking block will help you easily locate where it is. To do this: 
1. Select the Edit->Preferences->Appearance pulldown menu, then select Display Setup and the Display

Setup window will appear.   
2. Set Shape to Block and Blink to Yes. Click OK. 

You may have noticed when PC5250 established the connection above, the status bar located at the
bottom of the display window displayed a description of the connectivity activity. To display a
chronological listing of these activities, do step 3.    

3. Select the View pulldown menu, then select Status Bar History.   The Status Bar History window will
appear.  Review your Status Bar History log.   

There is an optional feature that allows the iSeries error message that normally is shown on line 24 of the
display to be shown on the Status bar. To enable this feature:   
1. Select the Edit->Preferences->Appearance pulldown menu, then select Window Setup. After the

Window Setup panel appears, see if 5250 line 25 under the Status Bar box is checked and click OK. Any
iSeries error messages you may receive during this session will now be displayed in the status bar of your
PC5250 display instead of overlaying line 24.   

2. Position the PC5250 cursor at the beginning of an input field in the display and press Backspace key.
You will notice an error message on the status bar saying "Cursor in protected area of display".   

3. Press the PC5250 Reset key (the left Ctrl key). 

Task 2: PC5250 Printer Emulation Session

Configuring a session 

1. Open the Emulator folder within the IBM System i Access for Windows folder on your desktop and
click on the Start or Configure Session icon. This will bring up the IBM Personal Communications
display.  Choose New session.   

2. Specify the name of the system you will be connecting to in the System Name field.   
3. As Workstation ID use the Print session ID name in your worksheet.   
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4. Select Printer for the type of emulation then select the Setup button. This will bring up the PC5250
Printer Emulation Setup panel.   

5. Review the settings on this panel. You can specify the location of the iSeries message queue to receive
iSeries printer messages; choose a font for printing iSeries print files or setup Transform Print Data
which enables Host Print Transform (HPR) to support printing iSeries data to PC printers. Click Cancel
to close the setup panel.   

6. Select the appropriate Host Page Code.   The default, 037 United States, should be selected.
7. Select the Auto-reconnect checkbox. This option will allow PC5250 to automatically reconnect the

session to the iSeries system should the session be disconnected.   
8. Review the Port number setting. The default telnet setting for UDP and TCP/IP is 23.   
9. Click OK and PC5250 will establish the connection.   
10. To save the session, select the File -> Save option. Specify a file name, e.g. caxxprt (where "xx" is your

workstation number), for the session profile and click Save.   
11. The first time you save a session, PC5250 will ask you if you want to create an icon for the session to

your desktop. Click Yes, then select the Desktop folder located under All Users and click OK. Click OK
on the last confirmation message.   

12. Notice that the icon created with this method looks different from the iSeries Desktop Icon we created

for the Display session.    

Note: You can set up other features of the printer session by selecting the File -> Printer Setup or Page
Setup option. 

Printer Setup Support 

PC5250 allows you to print your output to several destinations. You can: 
w Print to whatever printers you define under Windows.   

w Print to one file and append to the file each time (Print to Disk - Append)   

w Print to separate files with the same name but a running number extension (Print to Disk - Separate) 

During this exercise, we will explore Printer setup options.  First, we will add an iSeries printer share to the
printers defined for your PC.

1. On the Windows "Start" menu, select Printers and Faxes.  Double click on Add printer.  
2. On "Welcome to the Add Printer Wizard", click Next.   
3. On "Local or Network Printer", select A network printer, or a printer attached to another computer.

Click Next.
4. On "Specify a Printer", select 'Connect to this printer (or to browse for a printer..)' and for the Name,  

use \\<server name>\prtcaxx, entering your server name from your lab worksheet and where "xx" is
your workstation number. Click Next.
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5. If you get this dialog 

then click OK. (If you do not get this dialog, skip to step 6.)  Then on "Add Printer Wizard", for
Manufacturer and Printers, leave the first item in the list selected.  Click OK.  

6.  On "Default Printer", select No for "Do you want to use this printer as the default printer?". 
7.  Click Next. Click Finish.

Next you will associate the Printer Emulation Session that you created earlier in Task 2 with the iSeries shared
printer that you just defined for your PC.  

1. Double click on the icon you just created for your printer emulation session.
2. Select the File -> Printer Setup option from the pulldown menu.   
3. From the Printer Setup panel, select the shared iSeries printer \\<server name>\prtcaxx, where “xx” is

your workstation number.     
4. Click on Setup... and note the options you have. (They depend on the printer type, of course.)  Click

Cancel when you are finished looking at the setup options.   
5. Check the Use PDT checkbox. Note that the Setup... button is now gray. Instead the Select PDT button

is now active.   
6. Click on Select PDT and specify the correct PDT driver to use for your printer. For example, a IBM 4019

LaserPrinter that would be IBM4019.PDT. In this exercise, you can select any .PDT.  Then click OK to
finish setting up the printer.   

7. Select File->Page Setup.   
8. Look at the options available for page setup.   
9. Click OK and then close the PC5250 printer session. 

Task 3: Creating a PC5250 macro
In this task you will record a simple macro for use in a PC5250 emulation session.  A macro is a script that can
be run to perform various tasks.  A macro can, for example, take you through a sequence of screens with a click
of a button.  A macro can also be used for things such as saving a large OS/400 command for repeated reuse.
By recording a macro you are simply recording keystrokes sent to the PC5250 emulator.  A recorded macro is
the simplest of macros.  The macro language VBScript available in PC5250 allows for much more complex
operations.  The System i Access for Windows Advanced lab has an example of a much more complex macro.

Recording a macro
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1. Connect to the iSeries by opening the PC5250  you created in task 1.   
2. Sign on to the iSeries using the user ID and password from your worksheet, then hit Enter.
3. Get to the OS/400 Main Menu.
4. Click on the Actions menu and select Start Recording Macro...
5. Type runsql.mac as the file name of the macro to Record Macro/Script as.  Click OK.  You are now

recording a macro.
6. On the OS/400 Main Menu screen go to the top line of the Selection or command entry area and type

STRSQL and hit Enter.
7. On the SQL entry screen type the statement SELECT * FROM QIWS/QCUSTCDT and hit Enter.
8. Click on the Actions menu and select Stop Recording Macro.  Keystroke recording is now turned off

and your macro is complete.
9. Hit the F12 key to exit out of the SQL results screen.  Hit F3 to exit STRSQL.  Hit Enter to select the

default option to save and exit the SQL session.  

Running a macro

1. While on the OS/400 Main Menu, place your cursor on the first position of the selection or command
entry field on the bottom of your screen.

2. Click on the Actions menu and select Start Playing Macro/Script...
3. In the Macro/Script drop list choose runsql as the script to run and click OK.
4. Your script should now run STRSQL, enter the SQL statement, run the statement, and end up at the

results screen.
5. Exit out of STRSQL (like you did in step 9 above), sign off the system and close your PC5250 session.

System i Access for Windows Lab - Basic

                    Page 20



Lab 5. Using Remote Command
The objective of this exercise is to show you how easy it can be to run i5/OS or OS/400 commands right from your PC.
You can do this without using System i Navigator or PC5250 emulation screen.  It also shows you how to issue
commands from your iSeries server to run directly on your workstation by using incoming remote command.

Task 1: Issuing an OS/400 command from a command prompt
An OS/400 command can be easily run right from your workstation.  It can be run as part of a batch file, from a
program, from the 'Run...' option on your start menu, or from a command prompt.  The System i Access for Windows
command used to issue an OS/400 command is rmtcmd.exe.  It may be used to issue any OS/400 command where user
interaction is not required.

Running an OS/400 command from a command prompt

1. Using the Windows "Start" menu, select Start->Run...
2. In the "Open" field type cmd (the Windows command prompt) and click OK.
3. You should see a command prompt window open on your desktop with a flashing cursor after C:\>.
4. Type rmtcmd CRTLIB CAxxTMP  //<system name> (note that there is a blank space after CAxxTMP).

Where xx is your team number and <system name> is your iSeries server name.  Hit Enter to create a new
library on the system.  Sign on to the system with your iSeries user name and password if necessary.

5. You should see the message CPC2102 - Library CAxxTMP created.  This means that the library was
successfully created on the system.

6. Type exit to close the command prompt window.

Task 2: Enabling Incoming Remote Command (IRC) on Windows 
This task shows you how to enable your workstation to accept incoming remote commands from the iSeries server.
Enabling incoming remote commands allows you to issue a command from the iSeries to run on your workstation.
Follow these steps to enable the System i Access incoming remote command service on your Windows desktop.  Note:  
Other versions of Windows also support incoming remote command, but require different steps to get it enabled.  The
System i Access for Windows User's guide has information for enabling incoming remote command on the various
Windows platforms.  Search the User's guide for "Incoming Remote Command" for more information.

1. On the Windows "Start" menu select Settings then Control Panel.  The Windows control panel should display
on your desktop.

2. Open the Administrative Tools folder.
3. Double click on Services to open the services window.
4. Locate the System i Access for Windows Remote Command service in the right pane of the window.
5. Double click on it to display System i Access for Windows Remote Command Properties.
6. Click on the Log On tab.
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7. Check the box next to Allow service to interact with desktop.  This allows commands coming from the iSeries
to interact with your windows desktop.  The commands you normally issue may not require this option enabled.
You need to enable this option for the purpose of the lab.

8. Click on the General tab.
9. In Startup type, select Automatic.  This means that the Remote Command service will start each time Windows

starts.  Press the Apply button.
10. Click on the Start button to activate the service.  Service status should change from Stopped to Started.
11. Click OK.  Click the X button in the top right corner of the services window to close the window.
12. Your PC is now enabled to accept incoming remote commands.

Task 3: Issuing a remote command from the iSeries
This task shows you how to issue a command from the iSeries server to run on your workstation. To do this you must
know the IP name or address of your workstation.  It also requires that you enable System i Access Remote Command,
which you did in Task 2.  The steps below show you how to get the IP Address for your workstation. Follow these
steps to complete this task.

1. Using the Windows "Start" menu, select Start->Run...
2. In the "Open" field type cmd (the Windows command prompt) and click OK.
3. You should see a command prompt window open on your desktop with a flashing cursor after C:\>.
4. Type ipconfig to get your network configuration information.
5. Locate the line IP Address and write the "dotted decimal" address here: _____ . _____ . _____ . _____
6. Start an emulation session.  You may use the desktop icon you created in task 1 of the PC5250 lab.
7. Sign on to the iSeries with the user name and password from your worksheet.
8. From the OS/400 Main Menu, type runrmtcmd and hit F4 to prompt the command.
9. In the command field, enter (retaining the single quotes) 'C:\windows\system32\write.exe'.
10. In the remote location field, enter the IP Address you wrote down in step 5.  Include the decimal points between

the digits.  Your IP Address should look something like 10.10.10.50, although the numbers will be different.
11. In the "Type" field, enter *IP to use TCP/IP.
12. In the "Remote user ID" field, enter the PC user name from your worksheet.
13. Hit the Page Down key to see more options.
14. In the "Remote password" field, enter the PC password from your worksheet.  The password is case sensitive!
15. Hit the Enter key to run the remote command.  The WordPad application should have started on your PC.  You

have just used an OS/400 command to run a command on your Windows workstation!
16. Close the WordPad application and sign off and close your emulation session.
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Congratulations! 

You have finished the System i Access for Windows Basic lab.

Please delete any objects on your PC desktop that
you created during the lab.
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Appendix A. Installing System i Access for Windows

This section explains how to install System i Access for Windows on the PC using i5/OS NetServer.  This
section is for your reference only.  System i Access for Windows has already been installed on the PC you are
using for this lab, so you should NOT perform this install on your lab PC.

Prior to doing the install, you will need to make sure the LPPs listed on page 6 of your lab handout are installed
on your iSeries, and that NetServer is configured and running.  For information on configuring and starting
NetServer, see the i5/OS NetServer home page at:  http://www.ibm.com/eserver/iseries/netserver

1. On Windows 2000/XP: Click Start -> Search ->For Files or Folders.  Under Search for other items,
click on Computers.  In the Computer Name field, enter the i5/OS NetServer name of your iSeries.
Click on Search Now.  

2. Double click on the i5/OS NetServer that was found.  
3. Double click on each of the following directories: QIBM -> ProdData -> CA400->Express -> Install ->

Image.
4. Start the installation by double clicking on SETUP.EXE.   
5. After the installation wizard loads and the welcome screen is displayed, click the Next button.   
6. Then the licensing information for the System i Access for Windows product is displayed. Click the Yes

button to continue the install.   
7. Now the type of installation can be selected by clicking on the large button to the left of the install type

description. 
Note: that selecting a Typical install will not install all of the System i Access or System i Navigator
sub-components.  To select which pieces are installed, click the Custom button.
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8. Now you will be prompted for the destination folder to install System i Access for Windows in. Accept
the default and click the Next button to continue.   
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9. Since we chose a Custom install in step 7, the Component Selection window will now be displayed. Here
you will need to select the components of System i Access for Windows to be installed. 

10. To select a component for install, click to place a check mark in the box to the left of the component. To
view the sub components of a component, click the '+' to the left of the box to expand the view. Once
you have selected all the components to be installed, click the Next button to continue.   

11. If you are installing System i Access for Windows on a Windows 95/98 PC, and select to install PC5250
Emulation, the AUTOEXEC.BAT Changes dialog is displayed next. (Note that V5R1 Client Access
Express is the last release that supports Windows 95.  V5R2 System i Access for Windows is the last
release that supports Windows 98 and Me.)  Since the PC5250 Emulator was selected to be installed, the
Install Shield wants to add System i Access path statements. This screen is displayed to inform you that
changes will be made to your AUTOEXEC.BAT file. Just click the Next button to continue the install
and allow the AUTOEXEC.BAT file to be changed. If you are installing on Windows NT 4.0, Windows
2000, or a later Windows operating system, the path will be updated automatically. 
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12. You will now be asked for the name of the Program Menu Shortcut. Leave the default of IBM System i
Access for Windows and click the Next button to continue.   

13. Then you will be shown a synopsis of the install options you have selected up to this point. Click the
Next button to begin copying files to your PC.   

14. After all files have been successfully copied to your PC, you will be prompted with the options to Add
program folder shortcut to the desktop and view the README file. Leave both options checked and
click the Next button to continue.   

15. Quickly browse through the README file and then close it.   
16. Now you will be told that the setup is complete.  Click the Finish button to complete the install.  Note:

Normally, you must reboot the PC before using System i Access for Windows.  However, after a brand
new install on a PC, you can first install a Service Pack (if one is available) before rebooting the PC.  
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TRADEMARKS

The following are trademarks or registered trademarks of the IBM Corporation in the United States, other countries, or both:

IBM  AS/400  OS/400  System i System i5 iSeries  DB2 i5/OS

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United States, other countries,
or both. 

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the United States, other countries, or
both.

Lotus is a registered trademarks of Lotus Development Corporation and/or IBM Corporation.

Other company, product, and service names may be trademarks or service marks of others.
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