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Objectives
• Using a local Certificate Authority (CA)

– Create a local CA on your iSeries
– Create a system certificate
– Install server certificates
– Assign certificates to applications (iSeries Access Servers)
– Install the Local CA certificates

• On your PC
• In iSeries Access

• Setting up PC5250 Client Authentication
– Create a client certificate on your iSeries
– Export client certificate to client
– Enable telnet server for client authentication
– Configure prompting modes in iSeries Access
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Objectives (continued)

• Using a well-known Certificate Authority (CA)
– Obtain digital certificate
– Assign certificate to applications (iSeries Access Servers)
– Configure the iSeries Access functions to use SSL
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iSeries Access for 
Windows Clients

List of 
trusted 
signers

this           day of                         , 199   ,
by                                               

DIGITAL 
CERTIFICATE

OWNER

We appreciate your contributions 
to our organization. In recognition 
of valuable achievements and hard 

work, we gladly present this 
certificate of award.CA Express 

Server
IBM Corp

Server Authentication Secure Sockets Layer 
(SSL) Flow

1. The server is authenticated when 
1. iSeries Access Client sends a secure connection 

request to iSeries Access Server
2. Server sends Client its digital certificate
3. Client verifies the server's certificate and 

determines if it trusts the issuer of the certificate  
2. After server authentication is complete 

1. Session keys are negotiated and the rest of the 
flows are encrypted.  

iSeries Access 
Servers
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iSeries Access 
Servers

1. The client is authenticated when 
1. iSeries Access Client sends a secure 

connection request to Server.
2. Server sends its certificate, and requests a 

client certificate.
3. Client validates the server certificate, and 

sends its certificate to the Server.
4. Server validates the client certificate.  

2. After client authentication is complete
1. Session keys are negotiated and the rest of 

the flows are encrypted. 
iSeries Access for 
Windows Clients

List of 
trusted 
signers

this           day of                         , 199   ,
by                                                              

DIGITAL 
CERTIFICATE

OWNER

We appreciate your contributions 
to our organization. In recognition 
of valuable achievements and hard 

work, we gladly present this 
certificate of award.CA Express 

Server
IBM Corp

Client Authentication Secure Sockets Layer (SSL) 
Flow
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Creating a Local CA on your iSeries and creating 
a system (server) certificate...
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(2)

Digital Certificate 
Manager (DCM)

(1)

Create Local CA

Create Server Cert

Certificate 
stores

(3)

iSeries Server

Web Browser

Obtaining a server certificate from a local CA 
(the iSeries)
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Step 1:  Obtaining a server  certificate from a well-known CA - Details

• Logon to the iSeries Tasks page.   Enter the URL  
http://your_iSeries_name:2001

• Signon with your OS/400 userid and password (you must have 
*ALLOBJ and *SECADM)

• On the tasks page, click Digital Certificate Manager
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• Click on "Create a Certificate Authority" on the left
• Then, select "Local Certificate Authority" on the right

© 2004 IBM Corporation

• Complete the form page and click OK.
• Note: Each store has its own password

• Hint:  Don't forget this password.  You'll 
need it to work with this certificate store 
in the future.
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•The Install Certificate link 
allows you to install the CA 
certificate on your browser.   If 
you want your browser to 
recognize certificates issued 
by this intranet CA, you can 
download the intranet CA 
certificate now (or do it later.)
•You can go ahead and do 
this, especially if you are going 
to have web applications that 
use https.    However, putting 
the CA certificate in your 
browser won't help you with 
SSL and the Client Access 
Express servers.    You need 
to get this certificate in your 
Client Access Express key 
database, which defaults to 
cwbssldf.kdb
•To verify that it was installed 
on your browser, click on the 
Security icon, then click on 
Signers.

Note: Installing certificate with IE will start an IE wizard for
importing a certificate.
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• Select Yes if you want to allow the creation of user certificates from this 
CA.  This is needed for Client Authentication

• Click OK
• You have now created a local CA on your iSeries!!!
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• Policy data for CA was changed message will be shown along with a list of 
registered applications.

• Click on Continue button

© 2004 IBM Corporation

• Fill out the Create a System Certificate form.  Note: This password is different than the 
CA Store.

• Info on bottom cut off about IPV6 is for VPN.  Read help on VPN for info.  Ignore for now.
• Click OK
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Configuring an Application to Use a Server 
Certificate ...
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• System Certificate created 
message will be shown 
along with a list of 
registered applications.

• Choose the application that 
will use the certificate you 
just created.  This 
associates the digital 
certificate the server is 
going to use on the server 
authentication portion of the 
SSL-handshake.

• Click OK
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• Click on Continue enable your system to sign objects
• Note: This is not needed for iSeries Access, so could be done later. 

Object Signing

© 2004 IBM Corporation

* Fill in form
* Click on OK
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• You have now:
• enabled the iSeries to be a CA 
• created your first server (or system) certificate signed by your CA
• assigned that certificate to the iSeries Access servers

• After you have created your first certificate, the system creates a "*SYSTEM 
certificate store."   As you create more certificates or import them from well-known 
CAs, you will probably want to store them in the *SYSTEM certificate store.
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• If Application Administration is being used, then always enable Remote Command.  Also, 
Central may be required if translation tables need to be downloaded for other languages.

• There is no harm in using the same certificate for all applications
• There is no harm in assigning a certificate to applications even if you do not intend to 

enable them to use SSL.
• List of port numbers is in II12227 at: 

• http://www-1.ibm.com/servers/eserver/iseries/access/caiixe1.htm

Servers to enable for iSeries Access Functions

Sign-on, PrintAFP Viewer

Sign-on, Database, DDM, Remote Command, Data 
Queue

OLE DB

Sign-on, DatabaseODBC

Signon, Remote Command, File,Print, Database, 
Web Admin,Mgmt Central, Directory, Data Queue

All Ops Nav Function

Sign-on, Remote CommandBase Ops Nav

Sign-on, Central, DatabaseData Transfer

Sign-on, Central, Telnet5250 Display & Print

Servers to EnableiSeries Access Function
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Getting a CA certificate into the iSeries Access 
for Windows Client's list of trusted signers ...
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Installing SSL on your Client
• Click on Selective Setup in the IBM iSeries Access for Windows folder.
• Follow the wizard - specify where you are going to install from
• Look for, then expand the SSL choices.    Choose the encryption strength 

to install.
– Hints:  if SSL does not show up in the list of choices, you are either not 

authorized to the directory \QIBM\ProdData\CA400\Express\SSL or you need 
to install one of the encryption products (CE2 or CE3)

– The encryption products must be installed from an AS/400 directory - they are 
not on the iSeries Access install CD in V5R2 and earlier.

• For V5R3, the SSL component is shipped on that CD.

• Verify that Secure Sockets Layer (SSL) is under the "Added components" 
heading

• In the iSeries Access for Windows folder you will see a new IBM Key 
Management icon as well as a new tab Secure Sockets in the iSeries 
Access for Windows Properties dialog.
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Installing CA onto client PC
• A download button is 

available in iSeries Navigator 
to easily move the CA into the 
2 key databases used by 
iSeries Access:
− iSeries Access key 

database
− Java key database (used 

by Java components of 
iSeries Navigator)

• Right-click on system name in 
iSeries Navigator, and choose 
"Properties".

• From "Secure Sockets" tab, 
check box to enable SSL.

• Click on "Download" button.
• Restart iSeries Navigator for 

SSL to take effect for iSeries 
Navigator 
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• After restarting iSeries, notice the padlock on the iSeries you just configured to 
use SSL

• Also, once SSL is turned on in iSeries, all other iSeries Access applications that 
are started from that point on will also get SSL as the default (including 3rd-party 
apps that use iSeries Access APIs.)

Enabling iSeries Navigator for SSL...
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Enabling SSL on iSeries Access  functions
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• Open your 5250 
session.  From the 
menu bar, click 
Communication, then 
select Configure

• Select Properties
• Click on Secured with 

SSL
• Click on Apply or OK.

Enabling PC5250 Sessions for SSL...
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• Open the Data Transfer
you want to configure to 
use SSL.   From the 
menu bar, click File-
>Properties

• From Properties, click 
the Connection tab.

• From Connection, 
choose which option you 
want.

• Click OK
• You can save this data 

transfer by using File-
>Save

Enabling Data Transfer for SSL
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• Launch ODBC Administration
• Click on the User DSN tab
• Double-click on the user Data Source

you want to configure to use SSL.
• Click on Connection Options in the 

General tab.
• Select Use Secured Sockets Layer 

(SSL) under the Security heading
• Click OK
• Close the ODBC Setup.
• Current connections must be closed 

and re-opened to take effect

Enabling ODBC for SSL
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Creating Client Certificate for Client 
Authentication
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Enabling Client Authentication in DCM
• Client Authentication of the telnet server is available on V5R1 and later
• Start with the main DCM screen below, and click on "Create Certificate" 

in the left navigation pane.
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• Select "User Certificate" as the type of certificate.
• Click on the Continue button.

Creating User Certificate

© 2004 IBM Corporation

Certificate Information

Fill out the Certificate Information.  The Email address is not used by 
iSeries Access for Windows.
Bottom section will only be displayed to Netscape users
Click on Continue
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• If using Netscape, this screen is shown
• Click on OK
• With Internet Explorer, this screen will not appear

Private Key Generation

© 2004 IBM Corporation

Click on the Install Certificate link
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If using Netscape, then...

• With Netscape, click on Communicator->Tools-> Security  Info.  Netscape 
will prompt for key database password too.

Click on the certificate, then on the Export button             
When prompted, save the certificate as a PKCS12 file.          
Password protect the file.

© 2004 IBM Corporation

• From the toolbar, select Tools->Internet Options
• From the Content page, click on Certificates
• Highlight the certificate and select Export

If using Internet Explorer, then...
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•The certificate export wizard starts. Select 
Next
•Then select Yes, export the private key
and then Next
•Then select the Personal Information 
Exchange button and then Next

Exporting a certificate with IE continued...
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Exporting a certificate with IE continued...

• Next you will be prompted for a password to protect the file.  Enter a 
password and confirmation.

• Select a location to save the file, and select Next
• Select Finish to complete the export
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Enabling Telnet Server for Client Authentication

• Click on "Select a Certificate Store"
• Select *System
• Click on Continue

© 2004 IBM Corporation

• Under "Manage Applications", select "Update Application Definition"
• Select "Server" in the right pane.
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• Select OS/400 TCP/IP Server
• Click on "Update Application Definition" (bottom of dialog)

© 2004 IBM Corporation

Select "Yes" for Client Authentication Required.



22

© 2004 IBM Corporation

Click the Apply button

Note that this will take effect 
immediately.  Telnet does not 
have to be restarted. 

© 2004 IBM Corporation

Configuring Client Authentication on the PC 
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• Once the client certificate is stored in a PKCS12 file, it must be imported into the iSeries Access key 
database.

• The preferred way to start the IBM Key Database Management program is through Control Panel
− Start->Settings->Control Panel, then double-click on “iSeries Access".  Select the "Secure Sockets" 

tab, and then click on the IBM Key Management button
− If you start this program an alternate way, the key database name won't be filled in by default, and 

you will have to browse for it.
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Importing Personal Certificate

• From the pull-down, choose "Personal Certificates"
• Then click on the "Import" button on the right
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Importing Personal Certificate (continued)

• Specify the PKCS file you saved earlier
• Enter the password you saved for it.

© 2004 IBM Corporation

Setting Prompting for Key Database Password
• Set the prompting mode for the key database password (optional)

Specify how often you want to be 
prompted.
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Enabling Client Authentication on PC

• From PC5250 Config:
− Click on Properties
− Select "Use Default"
− This is optional
− Selecting "Select Certificate.." 

causes extra prompt.

© 2004 IBM Corporation

Connecting with Client Authentication

When attempting a PC5250 connection, the above dialog appears.  Enter 
your key database password (default password is "ca400"). 
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Obtaining a certificate from a 
well-known CA ...

© 2004 IBM Corporation

Obtaining a server certificate from a well-known 
CA

Certificate
Authority

Web 
Browser

(1)

Internet

(3) (2)

iSeries Server

Equifax ...

Digital 
Certificate 
Manager

(4)

Certificate 
store
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• Click on "Select a Certificate Store"
• Select "*System"
• Select "Create Certificate" on left
• Select "Server or client certificate"
• Click Continue
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• Select "Verisign or other Internet Certificate Authority"
• Click on Continue
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• Fill out form.  Hints:
− Server name is the TCP/IP 

host_name.domain_name of your iSeries.
− Spell out your state
− Don't specify the zip code

• Click OK
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• Copy the certificate request to 
the clipboard.  

• MAKE SURE you select the 
area that includes "BEGIN 
NEW CERTIFICATE 
REQUEST"  through the area 
that ends with "END NEW 
CERTIFICATE REQUEST ----
-"

• Some Internet CAs refer to 
this certificate request as 
Certificate Signing Request 
(CSR).
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• Example of 
requesting a 
certificate from 
VeriSign at 
www.verisign.com

© 2004 IBM Corporation

• Paste the certificate request from DCM into the box.
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• You will be sent a certificate to the e-mail address you specified in the server 
certificate request.

• Cut and paste the certificate into a .txt file on your PC.
• ftp or map a drive to your iSeries to store the file in IFS

Hints to this point ...
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• Back in DCM, click on "Select a Certificate Store", and select *System
• In the left panel, select "Manage Certificates", then Import Certificate
• On the Import Certificate form, specify the path name of the IFS file name where you 

placed the certificate sent back to you by the well-known CA
• Click OK
• Now DCM takes the VeriSign certificate and puts it in the *SYSTEM certificate store
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• Click on Update certificate assignment under "Manage Applications"
• Select the iSeries Access Servers that you need.
• Click on Update certificate assignment button at the bottom

© 2004 IBM Corporation

If you are using a well-known CA, configuration is 
complete and you are ready to go!!!



32

© 2004 IBM Corporation

Software Requirements

• OS/400 release V4R4 or later
• IBM HTTP Server for AS/400 (5769-DG1)
• Digital Certificate Manager (5769-SS1, option 34)
• IBM Cryptographic Access Provider (5722-AC2 or AC3) 
• iSeries Client Encryption (5722-CE2 or CE3)
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For More Information
• AS/400 Client Access Express for Windows:  Implementing V4R4, SG24-5191 (redbook)
• www.as400.ibm.com/clientaccess
• Webmaster's Guide, GC41-543
• Tips and Tools for Securing Your AS/400, SC41-5300
• AS/400 Internet Security:  Developing a Digital Certificate Infrastructure, SC24-5659 

(redbook)
• www.as400.ibm.com/infocenter
• www.as400.ibm.com/http
• www.software.ibm.com/network/hostondemand
• www.software.ibm.com/network/pcomm
• www.as400.ibm.com/tcpip
• www.as400.ibm.com/ebusiness/security
• www.rsa.com
• www.verisign.com
• www.entrust.com
• www.thawte.com
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Appendix:
How to manually copy CA to PC

(Alternative to using "Download" button)

© 2004 IBM Corporation

• Select  "Copy and Paste certificate" from DCM.  
• "Install Certificate" link will not work for iSeries Access
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• Copy certificate from the ---BEGIN through CERTIFICATE---
• In the menu bar, click Edit->Copy 
• In the task bar, click Start->Programs->Accessories->Notepad
• On the menu bar,  click Edit->Paste
• On the menu bar, click File->Save As.   Call the file 

your_iSeries_name-CA.arm.  Save in C:\Program 
Files\IBM\Client Access

© 2004 IBM Corporation

• Go to the iSeries Access for Windows program group
• Double click on the IBM Key Management shortcut (this may take a few 

minutes)
• Choose Signer Certificates from the drop down
• Click on Add
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• In the Location field, enter the pathname of the CA certificate 
you stored earlier  

• Hint:   If you use the Browse button to find the location and 
click Open, it will fill in the pathname for you.

• Click OK
• Now you will be asked to 

provide a name (label) for the 
certificate

• Click OK

© 2004 IBM Corporation

• The iSeries CA certificate now is in iSeries Access's list of 
trusted signers.

• Note: These steps do not put the certificate into the Java 
Toolbox key database, so parts of iSeries Navigator will not 
work over SSL.
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