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Introduction

This tutorial teaches you how to maintain a payroll application written in ILE
COBOL using the Remote System Explorer.

You will learn how to start the product and open the Remote System Explorer
perspective, use tools and views in this perspective to connect to an iSeries’"
system and edit, verify, compile and debug a payroll application.

Prerequisites

To complete this tutorial, you should be familiar with:

* Basic Microsoft® Windows® operations such as working with the desktop and
basic mouse operations such as opening folders and performing drag-and-drop
operations.

It will also help if you understand:
+ ILE COBOL
+ DDS

The file(s) required for this tutorial are available for download at
http:/ /ibm.com /software/awdtools/wdt400/library.

Time required

To complete the modules of this tutorial, you will need approximately 3 hours.
Learning objectives

This tutorial is divided into eight modules, each with its own learning objectives.
You can choose to skip modules 7 and 8 and you can complete modules 5, 6, 7 and

8 in any order after module 4. Each module contains several exercises that must be
completed in order for the tutorial to work properly.

Chapter 1, “Module 1. Starting the product and the Remote System Explorer,” on|
page 1] teaches you about the workbench, a perspective, and specifically the
Remote System Explorer perspective. In this module, you will:

e Start the product

* Specify the workspace for your project resources

* Open the iSeries default perspective

Chapter 2, “Module 2. Configuring a connection to an iSeries system and|
connecting to an iSeries,” on page 7] teaches you how to create a connection to an
iSeries server and select objects using the Remote System Explorer perspective. In
this module, you will:

* Create a connection to an iSeries system

* Connect to an iSeries system

* Add a library to your library list

* View libraries in your job’s library list from the Remote Systems view
* Find a source physical file in you library
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* View members in a source physical file using the iSeries Table view

* Customize the columns in the iSeries Table view

* Open a member for edit from the iSeries Table view or the Remote Systems view
* Maximize the editor window

* Open another member for edit

* Open multiple views of a source member

¢ Switch from one edit session to another edit session

* Display a structural outline of items defined in a source member

[Chapter 3, “Module 3. Editing source,” on page 25 teaches you how to use the
Remote Systems LPEX Editor to edit source. In this module, you will:

* Change the default settings of the LPEX Editor Parsers
* Change the color settings and font used by the Editor
¢ Change the default behavior of the Enter key

* Use SEU commands to edit source

* Undo and redo source changes

* View a list of all help contents

e Limit the search of help to specific documents

 Search the help

* Use the Find and Replace window to search for an item in your source
* Filter or subset your source

* Filter lines based on line type

* Search through members in a source physical file

* Compare different versions of a program and identify the differences
* Syntax check source by line

* View help on syntax errors

[Chapter 4, “Module 4. Verifying and compiling source,” on page 55| teaches you
how to verify and compile source in the Remote Systems LPEX Editor. In this
module, you will:

* Check for semantic errors on your workstation

e Start the Program Verifier tool

* Use the iSeries Error list to locate each error in the source

* Save your source

* Re-verify source

* Change compile preferences

* Invoke the compile command

* Change the current library using the Command field in the iSeries Table view
* Start an interactive connection

* Invoke the payroll program

[Chapter 5, “Module 5. Debugging a program,” on page 69| teaches you how to
debug your payroll program from the workstation. In this module, you will:

* Invoke the debugger from the Launch Configurations window
* Add a breakpoint

* Add a conditional breakpoint

 Edit a breakpoint
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Monitor a variable through the Monitors view
Step into your payroll program

Show a Listing view

List the call stack entries in the Debug view
View all breakpoints

Remove a breakpoint

Monitor storage

Set a Watch breakpoint

Close the Debugger

[Chapter 6, “Module 6: Exploring Remote System Explorer,” on page 99| teaches you

how easy it is to define filters, perform actions and define your own actions. In

this module, you will:

Know the features of Remote System Explorer
Create a filter to show specific iSeries libraries
Change the filter to add more iSeries libraries

Create a filter to show all the source files in a library
Access members to edit from your filter

Create a user action that copies a source file with data to a new source file in the

same library

Specify user action parameters
Specify a restriction on a user action
Try the user action

Run an 0OS/400® command from the iSeries Table view

[Chapter 7, “Module 7. Designing screens,” on page 117] teaches you how to use

CODE Designer to modify a display file. In this module, you will:

Open a DDS member for edit with CODE Designer

Show file-level keywords and record-level keywords

View the details of records, record-level keywords and field-level keywords
View the design of the payroll application main menu

Create a group from an existing record format

Create a new group and add a subfile record and a subfile control record
Add columns to the subfile record

Add fields to the subfile control record

Copy existing fields

Set indicators to handle field errors

View and update record and field properties

View keywords and the properties of a keyword

Insert a keyword

View help for a keyword

Check there are no semantic errors in the DDS source

View help for an error

Launch the editor in read mode from the error list

Launch the editor in write mode to fix the error

Find a keyword in the source

Introduction
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* Save source changes
* Compile your source changes
* Close the Designer

Chapter 8, “Module 8. Introducing the product and Remote System Explorer]
(optional),” on page 143[teaches you about IBM® WebSphere® Development Studio
Client for iSeries and describes its relationship to IBM WebSphere Development
Studio for iSeries. In this module, you will:

* Know the goals of the product
¢ Know the editions of the product
* Identify the host tools and the client tools

* List and describe the iSeries application development tools

When you are ready, begin |[Chapter 1, “Module 1. Starting the product and the
[Remote System Explorer,” on page 1)
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Chapter 1. Module 1. Starting the product and the Remote
System Explorer

This module teaches you about the workbench, the workspace, a perspective and
specifically the Remote System Explorer perspective.

In this module, you will:

* Start the product

* Set the default workspace

* Access unique tools and views targeted towards iSeries application development
tasks

Requirement: Before beginning this module, you should have the prerequisite
knowledge outlined in [“Introduction” on page v |

Exercises

The exercises within this module must be completed in order:

* [“Exercise 1.1: Starting the product”|

+ |“Exercise 1.2: Opening the Remote System Explorer perspective” on page 3|

Time required

This module will take approximately 10 minutes to complete.

Exercise 1.1: Starting the product

If you want to know more about the product before you get started you can read
Chapter 8, “Module 8. Introducing the product and Remote System Explorer|
(optional),” on page 143 |

First you must start the product. Follow these steps to start the product:
1. Click Start on the task bar of your desktop.

2. Select Programs > IBM Rational® > IBM WebSphere Development Studio
Client for iSeries V6.0 > WebSphere Development Studio Client for iSeries

nﬂ IEM WebSphere Development Studio Client For iSeries W60 M@  WebSphere Development Studio Client for iSeries

If you are working with the Advanced Edition of the product you will see the
words Advanced Edition in the product name.

If you are working with the WDSC Lite version you will see the following start
menu option.

E 1BM WebSphere Development Studio Client Lite technology preview Y6.0.1 &

3. A dialog will appear. Here you specify the directory of the workspace where
your projects and other resources such as folders, subfolders and files that you
are developing in the workbench will reside.
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Workspace Launcher

Select a workspace

16M Rational Software Development Platform stares your projects in a directory called a workspace.
Select the workspace directory to use for this session,

Workspace: I C:\Documents and Settings)Administrator|IEM\rationalsdpé, Oy selabed El Browse...

I Use this as the default and do not ask again

I A

4. (Optional) Change the field in this dialog and use a unique directory name, for
example, RSELABxx (where xx is a unique number).

5. Click OK to open the workbench.

6. Click the icon in the far right of the Welcome page to go to the Workbench.
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@ Remote System Explorer - IBM Rational Software Deyelopment Platiorm = |g| X[:

File Edit Mavigate Search Project Run  Window Help

opment Platform

Workbencn
Go to the workbench

7. Click the maximize button to maximize the workbench.

File Edit Mavigate Search Project Run Window Help

]rj' Al J%'O"%' ],’9 5 | EBremote Syste...
| 4

fngemoteS... XA Teaml =g| (S-?.\\:E

; 3 *“t? eb? Wel to the Rati |
not available.
- l 5 s | = elcome 1o the nationa

A v
5 & NewConnection Software Development

G-l Seris.. Platform
'_ ,j ¥ ] '\Aﬁndm\ls
©ome ) Lnux...
@y Power Linux... Dvemew
i UNiX, .‘)
By AIX., :
B Localic '
= I;? Local

8. Click the X in the Welcome tab to close the Welcome view.

The workbench refers to the desktop development environment. The workbench
aims to achieve seamless tool integration and controlled openness by providing a
common paradigm for the creation, management, and navigation of workbench
resources. Each workbench window contains one or more views and an editor.

You have started the product and now you are ready to begin
[Opening the Remote System Explorer perspective.”|

Exercise 1.2: Opening the Remote System Explorer perspective

Before you begin, you must complete [“Exercise 1.1: Starting the product” on page|

In these steps you will open the Remote System Explorer perspective.

1. Check for the name of the perspective.

File Edit Mavigate Search Project Run Window Help

[[RIIENE"RY, 37 | =
]&mtinezz =8
|nnouli'|eisndtavaiabls.
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A perspective defines the initial set and layout of views in the Workbench
window. Within the window, each perspective shares the same set of editors.
Each perspective provides a set of capabilities aimed at accomplishing a specific
type of task or working with specific types of resources. For example, the Java™
perspective combines views that you would commonly use while editing Java
source files, while the Debug perspective contains views that you would use
while debugging a program. Perspectives contain views and editors and control

what appears in certain menus and tool bars.

If you see a different perspective, not the Remote System Explorer open in the

workbench or no perspective:

2. Click Window > Open Perspective > Remote System Explorer from the

workbench menu.

2@:Remnte System Explorer - IEM Rational Software Developm
File Edit Mavigate Search Project Runfll Window |

|3 -0 - Q-

Help

T Window

Open Perspective

EEiSeries Projects
ahow Yigw

Reset Perspective
Close Perspective
Close All Perspectives

E - (B Windows, .

Cusktomize Perspective...
Save Perspective As..,

ﬁ Lirnee,..

- Y Power Linus..., Mavigation
i L Preferences
W ATY

=10l x|
| ERemote Syste...

U= Qutling 52 = O

n outline is not available,

The Remote System Explorer perspective opens.

You work in the Remote System Explorer perspective in the workbench. This
perspective is for an iSeries programmer to display the connections that you
have already configured, create a new connection, connect to and disconnect
from the connections that you have defined, work with iSeries files, commands,

jobs, and integrated file system files.

This perspective will be active when you start the product with a new
workspace. If you had used the workspace before then, the workbench would
come up with the perspective that you last opened. You will learn more about
the Remote System Explorer perspective in the coming exercises as this is
where you launch the iSeries programmer tools and use the views from the

workbench.

Now you are ready to review your knowledge of this module by taking the quiz.
You can also apply what you have learned in this module by completing the

practice tasks detailed in More practice.

Quiz

1. A workspace:

a. Aims to achieve seamless tool integration and controlled openness by
providing a common paradigm for the creation, management, and

navigation of workbench resources.

Defines the initial set and layout of views in the Workbench window.

Refers to the desktop development environment.

d. Specifies where your projects and other resources such as folders, subfolders
and files that you are developing in the workbench will reside.
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2. A workbench:

a. Aims to achieve seamless tool integration and controlled openness by
providing a common paradigm for the creation, management, and
navigation of workbench resources.

Defines the initial set and layout of views in the Workbench window.
C. Refers to the desktop development environment.

d. Specifies where your projects and other resources such as folders, subfolders
and files that you are developing in the workbench will reside.

e. Aand C
3. A perspective:

a. Aims to achieve seamless tool integration and controlled openness by
providing a common paradigm for the creation, management, and
navigation of workbench resources.

b. Defines the initial set and layout of views in the Workbench window.
Refers to the desktop development environment.

d. Specifies where your projects and other resources such as folders, subfolders
and files that you are developing in the workbench will reside.

4. Match the perspective with its correct definition:

a. Combines tools and views that you would commonly use while editing Java
source files

b. Contains tools and views that you would use while debugging programs

Contains tools and views that you would use while developing Web
applications

d. Contains tools and views that you would use while maintaining iSeries
applications.

Java perspective
Web perspective
Remote System Explorer perspective

aoop

Debug perspective

5. In the Remote System Explorer perspective you can:
a. Display configured connections

Create a new connection

Connect and disconnect defined connections

Work with iSeries files, commands, jobs, IFS files

All of the above

® oo o

More practice

Given your experience in opening the Remote System Explorer perspective, now
open the Web perspective. See the list of tools and views available to the Web
developer. Next open the Java perspective. See the list of tools and views available
to the Java developer. Now since you are supposedly in the Java perspective, open
the Web perspective. Be careful not to open another Web perspective.

Tip: Look in the workbench top-right frame for the Web perspective icon. Now
close both the Java perspective and the Web perspective.

Module recap
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You have completed [Chapter 1, “Module 1. Starting the product and the Remote]
[System Explorer,” on page 1]You have learned how to:

* Start the product
* Set the default workspace

* Access unique tools and views targeted towards iSeries application development
tasks

Now that you have started the product and have opened the Remote System

Explorer perspective, you can move on to getting connected to an iSeries system.
Continue to [Chapter 2, “Module 2. Configuring a connection to an iSeries system|
fand connecting to an iSeries,” on page 7.
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Chapter 2. Module 2. Configuring a connection to an iSeries
system and connecting to an iSeries

This module teaches you how to create a connection to an iSeries server, find a
library in your library list, select objects from a library and finally open a member
in the Remote Systems LPEX Editor. You also learn about several views such as the
Remote Systems view, iSeries Table view, and the Outline view.

In this module, you will:

* Create a connection to an iSeries system

* Connect to an iSeries system

e Add a library to your library list

* View libraries in your job’s library list from the Remote Systems view
* Find a source physical file in your library

¢ View members in a source physical file using the iSeries Table view

* Customize the columns in the iSeries Table view

* Open a member for edit from the iSeries Table view or the Remote Systems view
* Maximize the editor window

* Open another member for edit

* Switch from one edit session to another edit session

* Open multiple views of the same source member

* Display a structural outline of items defined in a source member

Exercises

The exercises within this module must be completed in order:

* |“Exercise 2.1: Configuring a connection to an iSeries system”]

* [“Exercise 2.2: Connecting to an iSeries system” on page 10|

* |“Exercise 2.3: Viewing and accessing objects in the Remote System Explorer|
perspective” on page 14|

* [“Exercise 2.4: Opening a second source member and multiple views” on page 19|

* |“Exercise 2.5: Displaying an outline of a source member” on page 21|

Time required

This module will take approximately 10 minutes to complete.

Exercise 2.1: Configuring a connection to an iSeries system

When you first open the Remote System Explorer, you are not connected to any
system except your local hard drive on your workstation. To connect to a remote
iSeries system, you need to define a connection. When you define a connection,
you specify the name or IP address of the remote system and you give your
connection a unique name that acts as a label in your workspace so that you can
easily connect and disconnect. When you connect to the iSeries system, the
workbench prompts you for your user ID and password on that host.

© Copyright IBM Corp. 2001, 2006 7



The first time you connect to an iSeries system, you need to specify a profile. All
connections, filters, and filter pools belong to profiles. Filters are described in a
later exercise. Profiles are discussed when you create your first connection.

Ok, let’s get started. Remember you have already opened the Remote System
Explorer perspective in the previous module.

1. In the Remote Systems view, New Connection is automatically expanded to
show the various remote systems types you can connect to through the Remote
System Explorer.

- ﬁ Power Linux...
Unix UNix. .,

By AR
. =B Local...
# E}' Local

Click the plus sign + beside iSeries to configure a connection to an iSeries
system.

The Name personal profile page opens.
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x

Name personal profile

Uniquely name user profile | I

Welcome to Remote Systems, Connections can be sharable by the team or private to
you. Enter a profile name to uniquely identify you from your team members. You wil
decide for each new connection whether it is owned by the team profile or your
prafile,

Profile; | msteckh7tp

< Back MNext = Finish | Cancel I

2. Click Next to accept the default value.
The profile defaults to the name of the workstation. Your profile will be

different from the one shown here.

The Remote iSeries System Connection page opens.

x

Remote iSeries System Connection

Define connection information | I

Parent profile: |m9tedd1?tp j

Connection name: |S4ﬂDa

Host name: | 54003 —ﬂ

Description: |

[V Werify host name

L

< Back I Next > t@, Cancel |

On this second page you specify the information for your connection. The
cursor on this page is positioned in the Host Name field.

In the Host name field, type the IP address or the name of your host system.

The Connection name is automatically filled with the host name. Leave it this
way. This name displays in your Remote Systems view and must be unique to

the profile.

4. Leave the Parent profile default value. You don’t need to change it.
5. Leave the Verify host name check box selected.

Chapter 2. Module 2. Configuring a connection to an iSeries system and connecting to an iSeries
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6. Click Finish to define your system.

You have configured a connection and now you are ready to begin |“Exercise 2.2;

[Connecting to an iSeries system.”]

Exercise 2.2: Connecting to an iSeries system

Before you begin, you must complete [“Exercise 2.1: Configuring a connection to an|
[iSeries system” on page 7/

After you configure a connection to an iSeries system, you can easily connect and
expand your new connection to reveal your subsystems. Subsystems are
pre-defined filters grouping the various types of remote resources that can be
explored in the remote system. There are four subsystems.

iSeries Objects
A PDM-like group, allowing access to libraries, objects and members.

iSeries Commands
Contains predefined commands and allows you to create command sets
each of which contain one or more often used commands. When run, all
commands in a command set are sent to the remote system and executed,
and the results are logged in the iSeries Commands log.

iSeries Jobs
Allow you to see various jobs, subset by job attributes, and to perform a
number of operations on those jobs.

IFS Files
Allow you to explore folders and files in the Integrated File System of the
remote iSeries system.

15 Remote Systems. X WL ==

it 1
3§ 8 | ¢ | @R -

I: _&” MNew Connection
=l rm iSeries..
lv| Connection created successfully.
= Qj’ windows...
- A Linux...
28 & Power Linux...
[#]--UNiE Uni, .,
(- e AIX..
== Local
[+ [__:j’ Local
=B s400a
=8 ﬁ?-
+J A_‘ Work Wll'h libraries..
= A7 work with objects. ..
- 2;.5 Work with members..
'_‘l ‘1 Library list
# E" User libraries
- B iSeries Commands
ﬁ iSeries Jobs
[ %% IFS Files
[ Qshells

< | i

To connect to an iSeries system:

1. In the Remote Systems view, your new connection is expanded to reveal your
subsystems. The iSeries Objects subsystem is the subsystem you will use most
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often! It is very similar to PDM, in that it allows you to access objects in the
QSYS file system, and perform actions on those objects.

Notice the first three entries under the iSeries Objects subsystem are named
after the PDM options, because they have similar capabilities:

* Work with libraries (similar to WRKLIBPDM)
* Work with objects (similar to WRKOBJPDM)
* Work with members (similar to WRKMBRPDM)
In addition there are entries for working with library lists and user libraries:

— Library list (to simulate PDMs WRKLIBPDM you can start with the
pre-defined Library list filter, that when expanded lists all libraries in your
library list.)

— User libraries (allows you to work with all user libraries you can access
on that iSeries server.)

You also have more entries to work with under the connection itself and you
can see from these entries that Remote System Explorer goes well beyond
PDM! It allows you to explore iSeries jobs and commands and the IFS file
system.

Now let’s work with a library in your library list and add the library that you'll
be using in this tutorial:

a. Right-click iSeries Objects and click Properties on the pop-up menu.

.15 Remote Systems. X Expand +
A== Collapse -
& 8] |
(= Mew Connection Change £ ord..
. BB iseries... Release Interactve Job
/] Connectior  Werify Connection, ..
[+ % Windows... Connect...
& A Linux... Clear Password
B ‘cl, Power Linux...
- unik Unix, .. Remote Servers L4
] ﬁ\D‘-’.u
i - B Show Log(E)
: El Local...
+] Ei) Local Run Command. ..
3 !'a s4u0a Properties
SR iScrics Objects
[+ Ay Work with libraries. ..
2| j:l" Work with objects. ..
[E2] -'E'g' ‘wark with members...
&) ﬁ Library lisk
= =0 User libraries
+-B, iSeries Commands 5
4| | v

b. Select Initial Library List on the left pane.

c. Type RSELABxx where XX is a unique number in the Library field and click
Add.
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_ioi x|
- Command Execution ‘ Initial Library List |
- Fradkansasg griables
-~ Initial Library List —Library list
oy

Library | Library Position
RSELABRR HLAST
Remoyve |
Move Up I
Mave Dewn
J {
Current fibrary: |“U5RPRF ;]
Initial command:
Restore Defaults | Apply I
KON

d. Click OK.

This will add the library RSELABxx to your library list every time you use
this connection.

Note: You can also change your library list using the pop-up menu items
Add Library List Entry or Change Current Library on the Library
list folder in the iSeries Objects subsystem. These changes are only
valid until you disconnect.

3. Expand the Library list folder.
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. -y iSeries...
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[+ @ Windows...
- ‘ﬁ Linus, ..
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[#]--UNIE Ui
[+ Gy AIZ...
- #-E Local...
IZ I;i’ Local
=B s4005
=@t B

ks

[ Ag Work with libraries. ..
@ A7 Work with objects...
- 455 Work with members. ..
ﬁ Library list

g User libraries

- B2 iSeries Commands

&) i iSeries Jobs

[ TF IFS Files

|:=: Qshells

‘| | o

Now the connection will be activated and you will be prompted for a user ID
and password.

@i Enter Password ] x|

System type: iSeries
Host name:  TORASO7M

User ID: | WLABxx

Password; | Hrerr
V' Save user ID

¥ Save password

[ o« | conca |

Enter your user ID and password.
Select the Save user ID check box.
Select the Save password check box.
Click OK.

As you know, you can use the properties of any of the subsystems to set
connection information such as adding a library to a library list.

No o~

Back in the workbench in the Remote Systems view you will see the libraries in
your job’s library list.
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. [B-m, QHLPSYS.*lib.prod-sys

© o [F-E, QUSRSYS Mib.prod-sys

LB %2 b, prod-usr

=R R SELA ib.prod-usr
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Notice that the s400a folder now has a small green arrow in the icon to indicate
it is an active connection.

For each library, you can right-click and select from a number of actions. For
example, there is an action to create a new source file within the selected
library. Common actions like delete, move, copy, etc. are valid for all kinds of
objects.

You have connected to an iSeries system and now you are ready to begin |”Exercis5|
[2.3: Viewing and accessing obijects in the Remote System Explorer perspective.”|

Exercise 2.3: Viewing and accessing objects in the Remote System
Explorer perspective

Before you begin, you must complete [“Exercise 2.2: Connecting to an iSeries|
[system” on page 10

Now you are ready to view and access objects in your library RSELABxx.

To view and access an object:

1. Expand library RSELABxx.
You will see all objects in this library appear in the Remote Systems view. For
each object you can right-click and select from a number of actions. The list of
actions depends on the object selected and whether you selected one or
multiple objects. For example, for a source file the pop-up menu has an action
to create a new member within the selected file.

2. Drill-down through the files in the Remote Systems view until you find
QDDSSRC source file and then expand it.

3. Scroll up through the files in the Remote Systems view until you find
QCBLLESRC source file and expand it as well.
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#-[4 STRCODECPP.*pam.clp 4|
[+ |5y COMPARE . *file. pf-src

35 EMPMST.*flle.pf-dta

@[5 EVFEVENT.*file.pf-dta

-6 MSTDSP. *file, dspf

[+ 6] MSTDSP2, *file.dspf

H - JI=]

PRIMST Hfile of -dta
BLLESRC. *file.pf-src
U PAYROLLC.cblle
T paYROLLC2.chlle

[y PAYROLLD.cblle
&[5 QCLSRC. *file pf-sre
) QCMDSRC. *file.pf-src
53 QDDSSRC *ile.pf-src
U EMPMST.pr
-0 MSTDSP. depf
0 PRIMST.pf
0 REFMST.pf
05 RSNMST.pf
503 QRPGLESRC *file pf-src
5 QRPGLESRCP. *file pf-src =

= B e -

Now you can see and access the members in these two source files. For each
member you can right-click and select from a number of actions. The exact list
of actions depends on whether the member is a data file or source file and
whether you select one or multiple members. For a COBOL source member,
the pop-up menu actions include:

¢ open with

* browse with

* verify

¢ compile

Before you go ahead and work with these members, let’s see the members in
the iSeries Table view as well because that is similar to the view you are used
to from PDM. You use this view to display a list of items, for example,

members or objects, in a table format similar to PDM. You can also perform
actions against these items such as editing and compiling.

Right-click the QDDSSRC file and then click Show in Table on the pop-up
menu.
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ﬁ PRIMST. *file. pf-dta :]
[ 5y QCBLLESRC, *file, pf-sn
- 56y QCLSRC *file.pf-src
-5 QCMDSRC *file. pf-src
ISBEY] QDDSSRC, *file pf-sre

0 EMPMST pf New 3
0y MSTDSP.dspf GoTo »
B PRIMST pf

B REFMST.pf & | Refresh

b By RSMMST.pF Espam i

=[5 QRPGLESRC. *ile.
O pAVROLL.rpgl
B PAYROLLG.rpr || Pename...

Collapse -

o [EL mmmem memme s

1] = Copy
e - ) I Pt
_IProperties &% . Remote Scratchpad
= .+ Move..,
E -2 i Delete
Property | value
attribute PF-SRC
Name QDDSSRC -
Nurber of cFio.. | § Cathe Fle Descristions
Saurce RSELABRY % Find String. ..
Status QK Change(B).”
Text Sav
Type *FILE i
Restore..,
: User Acti 4
|| Show children of selected objectin - "

The iSeries Table view takes the selected object in the Remote Systems view as
input, and displays the contents in the table. For source physical files, this
step displays the members inside, their names, types, attributes, text
descriptions, and status.

- [5 QCMDSRC. *file.pf-src
EREY] QDDSSRC. *file. pF-crc
iy ;
qg ﬂ?;g: gzpf {Remote System ... | Tasks | L, Series Table View 52 iSeries C
C‘D PRIMST.pf File: #afQDDSSRC (5 Members) &
-0 REFMST.pf
! ) P Name \ [ Type | Attribute |
P 0 RSMMST.pf ~le
- - I'-" s Ll_l C- EMPMST PF SRC
O msTDSP DSFF SRC
[ Properties 33\\,_ Remote 5aatd'pad| =8 G PRIMST PF i
= O REFMST PF SRC
B 5 ¥ || O psumst PF SRC
Property | value sl |
Attribute PF-SRC -
Name QDDSSRC
Wumber of chi... 5 sl Command INgrmal ;i I
Source RSELABXX
- IStatus QK | _P,:[ Messages | ':J Dekailsil

| | Show chidren of selected objsct in a table view |

The top of the iSeries Table view contains a lock icon E that controls the
correlation between the Remote Systems view and the iSeries Table view. If
the lock is disabled then whenever you click an object or library in the
Remote Systems view, the associated contents of that item automatically
populate the iSeries Table view. If the lock is enabled then when you click on
various items in the Remote Systems view, this view does not change the
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content of the iSeries Table view. To enable or disable the lock, you can click it
once to change its state. You can click on the columns heading to sort the
view by column.

5. In the iSeries Table view toolbar make sure the lock/unlock button i is in
the unlock position. Leave the mouse pointer over the tool button for a second
or two to display the flyover help. That way you can check if the view is
locked or unlocked.

This means now the table will automatically be updated when a different
object is selected in the Remote Systems view. This is a shortcut to open the

pop-up menu for an object in the Remote Systems view and to select Show in
Table.

You can also modify which specific columns you want to see in the iSeries
Table view.

6. To modify the iSeries Table properties:
a. Click Window > Preferences from the workbench menu.
The Preferences Window opens.

_ax
[+ Workbench | [ Table View ‘
E Ant
... Build Ordsr IV Re-open to previous state
Help ¥ Use the command ling for action parameters

[+ InstallfUpdate
[+ Internet
[+ igeries Projects Specify columns and column order

- J2EE Type: |Member :I
[+ Java

E):;:di;i; Available columns Mave Up | Selected columns
Remote ems
s Communications
¥ Debug
' File Cache
- Files
iSeries
- Cache
Command Executio
Command Subsyste™
- Jab Subsystems
LPEX Editor Parsers
- Objects

[+ Program Yerifiers
. Table Yie
Templates

‘l “-1 nnina I . RestoreDofaultsl apply I
mport... | Export... | ok | cancel |

MName

Move Down | Type
Attribute

Text
Status

|Al:|d the selected column in

In the left pane of the Preferences window, expand Remote Systems.
Expand iSeries under Remote Systems.
Click Table View under iSeries.

In the right pane of the Preferences window, select Last modified in the
Available columns list.

Click the Add button.
g. Click OK.
Now, let’s update the iSeries Table view.

® oo o

—h

h. Click the down arrow on the iSeries Table view title bar.
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Remote System ... | Tasks eries Table Yiew X
File RSELABXX/QDDSSRC (5 Members) taz

R i g -
Name | Type Latrbut  workwth > |
€.
& - EMPMST PF SRC Subset
HMSTDSP DSPF Shaw
G PRIMST PP Cu
o .
& REFMST PF [V Defauk Position to...
G rShmsT PR all

4| T

Print. ..

=

i. Click Show columns > Customized in the pop-up menu.

Now you'll see the extra column that you've added.

C EMPMST PF SRC oK December 15, 2005 10:59:00 AM
0 MsTDSP DSPF SRC oK December 15, 2005 10:5%:01 AM
€ PRIMST FF SRC oK December 15, 2005 10:59:03 AM
0 REFMST PF SRC oK December 15, 2005 10:53:04 AM
0 RSNMST PF SRC oK December 15, 2005 10:55:05 &AM

You can also sort the objects in the iSeries Table view by column.
j. To sort the objects in ascending order by Last modified, click on the

heading.
Tasks N (TR SN2 Remote System Details | 6F oD g v = Ch
File RSELABXK/QDDSSRC (5 Members) m,_
| Type [ attribute t | status  #Tast modified

PF SRC December 15, 2005 10:59:05 AM

PF SRC oK December 15, 2005 10:59:04 AM
T PRIMST PF SRC oK December 15, 2005 10:59:03 &M
& MsTDSP DSPF SRC oK December 15, 2005 10:59:01 AM
G empmsT FF SRC oK December 15, 2005 10:59:00 AM J

k. If you click the heading the second time, it will sort it in descending order.
7. In the Remote Systems view, select QCBLLESRC.
The table shows the members in QCBLLESRC.

=] (5 QCBLLESRC *file.pf-src
- 5 QCLSRC, *file.pf-src \ "
[ [55 QCMDSRC *file.pf-src ABNXQCBLLESRC (3 Members) 1 e L_iEJ -
P 1[5 QDDSSRC. *file.pf-src O
Bl ANDALECN S #dn nf e r:| Name Type | Attribute | Text [s..]L
4] E CLPAYROLLC  CBLLE  SRC with syntax & ... OK [
v N\ . o 3
EProperties £2 “_Remote Scratch... | =25 OoPAYROLLCZ  CBLLE  SRC with verify errors  ©OK T
SN quA‘f'ROLLD CBLLE 5SRC Mo errors OK | ]
k5P had
Property | Value |
Attribute PF-SRC
Marme QCBLLESRC
Mumber of ... 0
Source RSELABXH | | i
Status OK hd
Text
Type *FILE Command [Normal v |
Messages I _v_] Detalls,., | Show Lo

Now you are ready to use the Remote Systems LPEX Editor to edit the
member MSTDSP found in QDDSSRC.
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8. From the Remote Systems view double-click member MSTDSP in the
QDDSSRC source file.
You can do this in the Remote Systems view or in the iSeries Table view.

The Remote Systems LPEX Editor opens. It is built right into the workbench,
with rich editing functions and is iSeries aware! It is a superset of SEU! The
syntax checker is ported from SEU, and the reference manuals are built-in and
F1 cursor sensitive.

9. Double-click the MSTDSP tab to maximize the Editor window.

10. Double-click the MSTDSP tab again to return the view to its original size.

" Bremote Systems 52 Team| = O | I Tt B)(Szowine 2\ =0
. - S
£ 2| i Bs v Line 1 Column 1 r| m E5 MSTDSP.DSPF
vinkE¥a e akaeaa By
[ (5] PRIMST,*file.pf-dta | i =
2t ) 000001 L7%%TS DD 195&
- [5p QCBLLESRC *file.pf-src Sppandi
= 000002 A® 89/04/10 1
[+ 5y QCLSRC, *file. pf-src
- ) Dﬂouaa if;:**ﬂ't*?*f;ﬁ1*ﬁ
18§ QMDSRC. *e.pf e 000004 A®™ THIS DISPLA
= 5h QDDSSRC. *file. pf-src St
€ EMPMST. pf < | »
-, MSTDSP.dspf

You have viewed and accessed objects in your library and now you are ready to
begin [“Exercise 2.4: Opening a second source member and multiple views."|

Exercise 2.4: Opening a second source member and multiple views

Before you begin, you must complete [“Exercise 2.3: Viewing and accessing objects|
[in the Remote System Explorer perspective” on page 14

Next let’s open a second member in the editor.

To open a second source member:

1. In the Remote Systems view, double-click member PAYROLLC in the
QCBLLESRC source file.

This member will be loaded into the editor as well.

Your Editor window will look something like:

#ARemate Systems ﬁ\\jaam| =P SEE PAYROLLC.CBLLE X

£ 8| Al i Line 1 Column 1 Rep.
@-05] MSTDSP2. *file dspf |
53 PRIMST *file.pf-dta 000001 PROCESS APOST. -
= [5h QCBLLESRC. *file.pf-5 oooooz
-0 PAYROLLC.cblle 000003 IDENTIFICATION [

[.’L PaYROLLCZ. chlle J 000004

; : (.‘E PAYROLLD. chlle PROGRAM-ID
(5 QCLSRC. *file pf-src Al -

1[5y QCMDSRC, ¥ile.pf-sre D00006 AUTHOR.

=-[f QDDSSRC Hfile.pf-src 000007 INSTALLATION.
_ . By EMPMST.pf A >
Pl . -0y MSTDSP.dspf
4 1 o)

Notice the two tabs in the Editor window.

2. Click on each tab to switch from one edit session to another edit session.

Opening multiple views of a source member
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You can open multiple views of the same source member while editing in the
Remote Systems LPEX editor.

To see multiple views of your COBOL source:
1. Double-click the PAYROLLC tab in the editor to maximize the Editor window.
2. Right-click this source in the Editor view and click View > Open new view.

Note: You can open a maximum of five views of the same source.

VT rarauccoue < N 7)
Line 1 Column 1 Replace
000001 PROCESS APOST. ﬂ
gooooz
opooo3 IDENTIFICATION DIVISION.
poooo4 — =
0ooonons AYROLL.
opoooe Syrcicrach e rogrammer Name.
ooooo7 ot CErlHs BM Toronto Lab.
goooos Copy! Ctitlnsert letober 12, 1999.
opoong Paste ChrlHY
oooolo Selact »
000011 Selected r»--—-—-————
gpooiz Deselect Al
00oo13 ster file maintens
oooo014d . *leion processing
000015 Show all Chrl _______________'___
gooole Source ’
000017 h
: ' J Cirl+aleHRig

—I—" E Add to Snippets. .. Previous view  Corl+ale-Left
I Save Horizontal split

3. Right-click a source view and select View > Next view or View > Previous
view to navigate among the views.

& MSTDSP. DSPF &
apooo1 PROCESS @ﬂ 000001 PROCESS @il
000002 000002
ooooos IDENTIFICAT |000DD3 IDENTIFICAT
ooooo4 000004
goooos PROGRAM-ID. |000005 PROGRAM-ID.
000006 AUTHOR. 000006 AUTHOR.
0oooo7 INSTALLAT 000007 INSTALLAT
goooos DATE-WRIT |000008 DATE-WRIT
0o0oo9 DATE-COMP (000009 DATE-COME
ooooid 000010
00001l bttt ettt e goooll e e e
000012 * PROGRAM DE |[000012 * PROGRAM DE
000013 * - Time rep (000013 * - Time rep
000014 * describe |000014 * desorikea
oooois T R R 000015 Ao
000016 .1|000016 —~
I
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4. Right-click a source view and select View > Horizontal split to change from a
vertical split of the views to a horizontal split of the views.

#/ MSTDSP DSPF
CBLLESRC(PAYROLLC): 1

Line 6 Column 3 Replace
0oonos IDENTIFICATION DIVISION. ﬂ
0poood4
ooooos PROGRAM-ID. PAYROLL.
oooooe AUTHOR. Programmer Name.

=
4| | »

|

RSELABXX/QCELLESRC{PAYROLLC): 2

Column 3 Replace

000002 E‘
ooooo3 IDENTIFICATION DIVISION.

ooooog

goooos PROGRAM-ID. PAYROLL.

0?0006 AUTHOR. : Programmer Name. _Ij
4 3

5. Right-click the source view that you want to close (RSELABXX/
QCBLESRC(PAYROLLC): 2) and select View > Close view.

Note: This option is not available on the first view.

You have opened another member for edit and seen multiple views of a member

and now you are ready to begin [“Exercise 2.5: Displaying an outline of a source|

Exercise 2.5: Displaying an outline of a source member

Before you begin, you must complete [“Exercise 2.4: Opening a second source|
[member and multiple views” on page 19|

The Outline view acts as an excellent resource when you want to edit RPG,
COBOL and DDS source in the Remote Systems LPEX editor. The Outline view
displays a structural outline of items defined in the file that you currently have
open in the Remote Systems LPEX editor window. With the editor active, you can
expand the file structure in the Outline view, and click various elements in the
view to jump to that location in the source itself.

To see an Outline view of your COBOL source:
1. Look at the Outline view to the right of the editor window.

Note: If you have closed the Outline view, you can reset the perspective by
selecting Window > Reset perspective from the workbench menu or
Show view > Other then expand Basic and click Outline in the Show
view dialog.

The Outline view contains your source program in a tree view without the lines

containing logic.
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IDEMTIFICATION D M,
[#- ENVIRONMENT DIVISION,
[+~ DATA DIVISION,

[#]- PROCEDURE DIVISION,

Now you want to see more details of your source member.
Expand ENVIRONMENT DIVISION.

Expand the CONFIGURATION SECTION.

Expand DATA DIVISION.

Expand FILE SECTION.

Double-click on any of the entries in the Outline view.

oo~ 0D

This will position the source editor accordingly.

MMSTMP.DSW | B[ Szouwine 2\ &8 =0
. = : - =l
Line 73 Column 1 Replace = F_ILESECTION. _AJ

- P T B R 2 - 3 +l - FD MSTDSP-FILE. |
000073 01 EMPMST-REC. .ﬂ - 01 MSTDSP-REC,
ey 7 4 COPY DDS-ALL-FORMATS OF EI{I_I . COPY DDS-ALL-FOR
00o07s i - E i
000076 FD PRJIMST-FILE. : :

000077 01 PRJIMST-REC. : - COPY DDS-ALL-FOR
000078 COPY DDS-ALL-FORMATS OF PRC FD PRIMST-FILE.
000079 : D1 PRIMST-REC,
000080 FD RSHMST-FILE. -~ COPY DDS-ALL-FOR
000081 1 RSHMST-REC. -l : -+~ FD RSNMST-FILE.
‘| | » : 01 RSNMST-REC. |
. COPY DDS-ALL-FOR |
i M AMARETRE CTADACE © 2 |
I 1 | | » |

7. Stay in the PAYROLLC tab to get the PAYROLLC Editor window in focus for
the next exercise.

Now you are ready to review your knowledge of this module by taking the quiz.
You can also apply what you have learned in this module by completing the
practice tasks detailed in More practice.

Quiz

1. When you first open Remote System Explorer, you are not connected to any
system except your local workstation. To connect to a remote iSeries system,
you need to:

a. Start Remote System Explorer communication server
b. Start a 5250 session
c. Define a connection. Specify the name or IP address of a remote system.
d. Define a profile
2. Subsystems include:
a. iSeries Objects
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iSeries Jobs

IFS Files

iSeries Commands

All of the above

3. The subsystem iSeries objects includes:
Work with libraries

Work with objects

Work with members

® oo o

Library list
All of the above
4. The iSeries Table view is used to:

© o 0 T o

a. Display a list of items, for example, members or objects in a table format
similar to PDM
b. Perform actions against a list of items, such as editing and compiling
c. Both
5. The lock icon controls the correlation between the Remote Systems view and
the iSeries Table view. (T, F)

6. You can maximize the Editor window by double-clicking on its window
heading. You can get back to its original size, by double-clicking on the
heading again (T, F).

7. The Outline view:

a. Displays a structural outline of items defined in the file that you currently
have open in the editor

Lists structural elements
. Shows editor specific contents and toolbar
d. All of the above

More practice

Given that you have access to your own iSeries systems, configure a new
connection and connect to this iSeries system. Now rename the connection, move
the connection up or change the properties of the connection. Then use the iSeries
objects subsystem to list the libraries in your library list. Use the iSeries Table View
to see the objects in your library. Subset objects in the iSeries Table View. Open the
Remote Systems LPEX Editor from the iSeries Table view. Use the product online
help to assist you in these tasks.

Module recap

You have completed [Chapter 2, “Module 2. Configuring a connection to an iSeries|
[system and connecting to an iSeries,” on page 7.|You have learned how to:

* Create a connection to an iSeries system

* Connect to an iSeries system

* Add a library to your library list

* View libraries in your job’s library list from the Remote Systems view

 Find a source physical file in your library

¢ View members in a source physical file using the iSeries Table view

* Customize the columns in the iSeries Table view

¢ Open a member for edit from the iSeries Table view or the Remote Systems view
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* Maximize the editor window

* Open another member for edit

* Open multiple views of the same source member

* Switch from one edit session to another edit session

* Display a structural outline of items defined in a source member

Now that you have a connection to an iSeries server and have opened a source
member for edit, you can learn more about the Remote Systems LPEX Editor.
Continue to the next module [Chapter 3, “Module 3. Editing source,” on page 25|
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Chapter 3. Module 3. Editing source

This module teaches you how to edit ILE COBOL source member PAYROLLC,
which should already be open, and learn about some of the Remote Systems LPEX
Editor’s language features.

In this module, you will:

Change the default settings of the LPEX Editor Parsers

Change the color settings and font used by the Editor

Change the default behavior of the Enter key

Use SEU commands to edit source

Undo and redo source changes

View language sensitive help for the MOVE operation code

View a list of all help contents

Limit the search of help to specific documents

Search the help

Use the Find and Replace window to search for an item in your source
Filter or subset your source

Filter lines based on line type

Search through members in a source physical file

Compare different versions of a program and identify the differences
Syntax check source by line

View help on syntax errors

Exercises

The exercises within this module must be completed in order:

[“Exercise 3.1: Introducing the editor” on page 26]

[“Exercise 3.2: Changing default editor settings” on page 26|

[“Exercise 3.3: Entering SEU commands” on page 30|

[“Exercise 3.4: Requesting undo and redo operations” on page 31|

[“Exercise 3.5: Invoking language-sensitive help” on page 32|

[“Exercise 3.8: Finding and replacing text” on page 37

[“Exercise 3.9: Filtering lines by string” on page 39|

[“Exercise 3.10: Filtering lines by type” on page 39|

[“Exercise 3.11: Searching multiple files” on page 41|

“Exercise 3.12: Comparing file differences from the Remote Systems view” on|

page 42|

[“Exercise 3.13: Comparing files in the CODE Editor (optional)” on page 46

[“Exercise 3.14: Checking syntax” on page 48|

Note: Exercises 3.6 and 3.7 do not appear as they apply only to RPG.

Time required

This module will take approximately 45 minutes to complete.
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Tip: You might want to maximize the Editor window during this module.

Exercise 3.1: Introducing the editor

Your program editing tasks are simplified with the Remote Systems LPEX Editor.
The editor can access source files on your workstation or your iSeries system
directly. When a compilation results in errors, you can jump from the compiler
messages to an editor containing the source. The editor opens with the cursor
positioned at the offending source statements so that you can correct them.

Here is a list of some of the basic editor features that you would expect in a
workstation editor:

* Cut, copy, and paste

* Block marking of lines, characters, or rectangles with copy, move, and delete
operations

* Powerful find and replace function
* Unlimited undo and redo

In addition there are a few more functions that you may not have seen in a
workstation editor:

* Token highlighting where different language constructs are highlighted using
different colors to help identify them in a program

* SEU-like format-line rulers to show the purpose of each column for
column-sensitive languages like RPG and DDS. These rulers can automatically
update themselves to reflect the current specification.

* SEU-like specification prompting for RPG and DDS

* Sequence numbers, which allow SEU-style commands in the prefix area
* Intelligent tabbing between columns for column-sensitive languages

e Automatic uppercasing for languages that expect uppercase

* Settings for column-sensitive languages that simplify text insertions and
deletions

* On-line language reference

Now you know the features of the editor, you are ready to begin
[Changing default editor settings.”|

Exercise 3.2: Changing default editor settings

Before you begin, you must complete [“Exercise 3.1: Introducing the editor.”]

The LPEX Editor has predefined settings, but also has an associated preferences
page containing settings that you can modify. The name of the category is LPEX
Editor and it appears in the left pane of the Preferences window.
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& Preferences

- = .
[+ Ank

Build Order
[+ Help
[# InstalljUpdate
- Internet
[#)- iSeties Projects

J2EE
[+ Javs
S LPEX Editgrd
- Appearance
i Block.
- Compare
Contrals
Find Text
Parsers
“Prink
- Save
- Tabs
- User Actions b
User Commands
- User Key Actions
- User Mouse Actions
- User Profile
& C:\Documents and Sekt

- Ct\Documents and Sett vl
4 | | »

N -, R

You will change the default settings of Appearance and User Key Actions.

Changing the editor appearance

Change Font to 12.

o0k whd =

Select Appearance under LPEX Editor.
Select formatLine under the Styles list.
Change the Foreground color to dark green.

Change Background color to light green.

In the left pane of the Preferences window, expand LPEX Editor.

Notice how your changes are reflected in the sample edit view.
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_ioix

Workbench = !nppearance |
[+ Ant
- Buid Order Palette (ot ]
=
i hite ¥ - Change. ..
B} InstalfUpdate whi [Courier New-reqular-12 ge
Inkernet Styles
[ i5eties Projects vV Foreground
= JEEE messageline
Java parserDefault Background [
-~ ; parserMessage
FEX Editor prefixérea I™ Underline
prefixText ;
- Block selection I~ | outline
L Compare statusLine X
- Controls Preview
-Find Text 1
P Line 1 Column 1 Replace
[ Parsers
- Print
. Save Emphasis, current line, default te~
o Tabs *#* ERR001 Embedded parser message.
-User Actions SPRYeifWels) Text in parser default =
- User Commands =
- User Key Actions 4| | »
7~ tese Moues xclions LPEX 3.0.3 (build 16-Nov-2005)
- User Profile
| @ C:\Documents and Sett
[ C\Documents and Sett
’ L ! LILI Reset " Restore Defaults I Apphy I

mport... | Export... | ok | cancel |

7. Select currentLine under the Styles list.

This option highlights the line that the cursor is on. The option applies to all
source files opened in the editor area.

8. Change the Background color to light yellow.

9. If you don’t like the changes you made, you can click Restore Defaults to
return to the original settings.

Modifying the default behavior of the Enter key

To modify the default behavior of the Enter key to split the current line in the
source instead of creating a new line:

1. Expand LPEX Editor if not already expanded then select User Key Actions.
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_ioix

Workbench
[ Ant
- Build Order Key | action I
Help enter splicLine
Lﬂ- InstalliUpdate Delete I
[ Internet
[ i5etles Projects [::\f
- J2EE
Java
{5 pex editor
. - Appearance
© -Black
- Compare
-Controls b
- Find Text
E Parsers
- Print
- Save
- Tabs
- User Actions

oo >
- Usermonse Actions

- User Profile

[+~ C:\Documents and Sett

£ Ci\D ts and Sett
8-C-boxments 4 Llll Reset I Restore Defaultsl Apply I

]|

ji=" { User Key Actions ’

Key enter Erter

Action I splitLine

Irnport,.. | Expart... | K | Cancel I

2. Type enter in the Key field.

Note: The Key and Action fields are case sensitive. Make sure that the values
typed in the Key and Action fields are exactly as shown above.

3. Type splitLine in the Action field.

4. Click Set.

5. Click OK on the Preferences window.
Return to the Editor window.

Seeing the results of splitLine

To see what splitLine does:
1. Place the cursor somewhere on a line and press Enter.
The text to the right of the cursor is moved to the next line.

Autosaving while editing source

To enable or disable autosave while editing source in the Remote Systems LPEX
Editor, you need to change an editor preference. You use the Window >

Preferences > Remote Systems > LPEX Editor and click the check box Autosave.

The default value for the minutes is set to 5. You can specify a value between 1
and 60 minutes.
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- Files ;| inEx Editor
[=1-iSeries -
— Cache
Command Executio Minutes between saves (1 - 60) .
Command Subsyste
- Job Subsystems

[l LPEX Editor Parsers
L
- CoBOL
- DDs
-~ ILE RPG
- RPG[400
- Objects
Program Yerifiers
Table Yiew
-~ Templates

LUEEHE

You have changed the default editor settings and now you are ready to begin
[“Exercise 3.3: Entering SEU commands.”]

[+

Exercise 3.3: Entering SEU commands

Before you begin, you must complete [“Exercise 3.2: Changing default editor]
[settings” on page 26/

You can configure the LPEX Editor to adopt the keyboard and command
personalities of many popular editors. Most editor profiles differ only in the keys
and commands used to perform various editor tasks. Some base editor profiles,
listed below, also add prefix information and a command area at the start of each
line:

* ispf
* seu

* xedit

The editor recognizes prefix commands used by these editor profiles. Depending
on which profile you are using, you can enter SEU, XEDIT, or ISPF commands
when the prefix area is active.

If you are an SEU expert you will appreciate the ability to use SEU commands.

To enter SEU commands:
1. Move the cursor into the gray sequence number area to the left of the edit area.
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01 US-RSCDE PIC X(8). -]

01 WS-ACODE PIC K.
01 WS-ACREC PIC X. [—
01 WS-EMESS PIC X(50).
PROCEDUREIDIVISION.

000151

000152 0000-MATN.

000153 =
«| | »|

2. On any sequence number type dd.

3. Go down a few lines and type dd again and press Enter.
Notice that the lines have been deleted.
4. Now type 15 in the sequence number area.

o

Make sure the cursor is within the sequence number area.
6. Press Enter.

Five new lines are inserted.

You have learned how to use SEU commands in the editor and now you are ready
to begin [“Exercise 3.4: Requesting undo and redo operations.”|

Exercise 3.4: Requesting undo and redo operations

Before iou begin, you must complete [“Exercise 3.3: Entering SEU commands” on|
page 30.

The editor records each set of changes you make to a file in the Editor window.
The number of changes made since the last file save is displayed on the status line.
If you want to undo a set of changes made to a file you use the Undo operation.
You can also cancel the effects of an Undo operation by using the Redo operation.

Now you are going to undo some of the changes you just made to the file. Then
you will cancel the Undo operation by using the Redo operation. Finally you will
reload the source so that it is back to its original content.

To undo and redo edit changes:

1. Click Edit > Undo from the workbench menu.
Notice that the 5 new lines disappear.

2. Press Ctrl+Z to undo the last change.
Notice that the deleted lines reappear.

3. Click Edit > Redo from the workbench menu.
Notice that the lines are deleted again.

At this point you will reload the source from the iSeries to make sure that it is
back in its original form.

4. Click File > Close on the workbench menu.
Tip: You can also click the X on the PAYROLLC tab.
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Line 144 Columm 1 Feplace 1 change |
=———+—*A—1—B——+————2————+————3————+————4————+————5——-!
000140 05 IND-PROTECT PIC 9i2) VALUE ;”

Ammd A

A Save Resource dialog opens asking if you want to save the latest changes.

& Ssave Resource A 3_(_]

A
@ 'PAYROLLC,CBLLE' has been modified. Save changes?

@ |_cw |

5. Click No.

6. Go back to the workbench to the Remote Systems view and open the
PAYROLLC member in the QCBLLESRC file.

You have learned how to undo and redo changes that you made to a file and now
you are ready to begin [“Exercise 3.5: Invoking language-sensitive help.”|

Exercise 3.5: Invoking language-sensitive help

Before you begin, you must complete [“Exercise 3.4: Requesting undo and redo
[operations” on page 31

Inside the editor, there is cursor-sensitive language-reference help available.

To receive language sensitive help, press F1 in an Editor window. If the cursor is
on an operation code, you receive help for that operation code; otherwise, you
receive help for the current specification.

Accessing language sensitive help

To access language sensitive help:
1. Position the cursor over the word MOVE in line 231 of the ILE COBOL source.
2. Press F1.

Language-sensitive help for the MOVE operation code appears in a Help
window.

Text marked in blue in the Help window contains the link to detailed
information about the topic in blue.
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&/ Help - IBM Rational Software Development Platform

=10l x|

Search: |

| search scope: MyList

Contents &y O

Colwelg o

& Introduction to WebSp
e Installing and migratin
@ Navigating and custon
@ Connecting to Linux, U
@ YWorking in a team eny|
@ Developing iSeries ser
@ Developing Web applid
@ Developing Java applic
@ Developing data acces
@‘ Developing EGL applicg
@ Building XML applicatia
"2 Detecting and analyzir|
@ Testing and publishing
L Troubleshooting and s
$ Debugging application|
@ Reference
L3 Glossary

ILE COBOL Language Reference

MOVE Statement

The MOWE statement transfers data hetween areas of
storage.

The MQ abalas two formats:

ormat 1 - MOYES

CORRESFONDING

Related Information:
o MOVE Staternent Rules
e Elementary Moves
e Group Moves
o WHEN-COMPILED Special Register

[ Top of Page | Previous Page | Next Page | Table of
Contents | Index ]

(C) Copyright IEM Corporation 1932, 2005. All Rights Reserved.

3. Click the link Format 1- MOVE.

The Help page for Format 1- MOVE is displayed.

@i Help - IBM Rational Software Development Platform

=10l x|

Search: |

|EE  Search scope: Mylist

Contents &y 0

Colwelg o

& Introduction to WebSp
e Installing and migratin
@ Navigating and custon
@ Connecting to Linux, U
@ YWorking in a team eny|
@ Developing iSeries ser
@ Developing Web applid
@ Developing Java applid
@ Developing data acces
@‘ Developing EGL applicg
@ Building XML applicatia
"2 Detecting and analyzir|
@ Testing and publishing
L Troubleshooting and s
$ Debugging application|
@ Reference
L3 Glossary

ILE COBOL Language Reference

MOVE Statement - Format 1

HOVE Statement - Format 1

>r=MOVE-—+-identificr—i—+==TO-——=icdentif
'=litergl-1-——=!

[ Top of Page | Previous Page | Next Page | Table of
Contents | Index ]

(C) Copyright IEM Corporation 1932, 2005, All Rights Reserved.

« | 4

4. Play around in the Help window to see what else is available.
5. Minimize the Help window.
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Note: If you are using WDSC Lite, the following steps do not apply.

6. Select Help > Help Contents on the workbench menu to see a list of all help
that is available in the product.

@/ Help - IBM Rational Software Development Platform -'Iﬂ[ﬂ
Search: |[E  searchscope: ltopics
Contents % B

G| @ el @8

@ Introduction to WebSp
@ Installing and migratin
@ Navigating and custon
> Connecting to Linux, U
@ Working in a team eny|
@ Developing iSeries ser

@ Developing Web applic WFl.'_lchn;.le |tl:l the
. 3 . online help.

& Developing Java applic This information

@ Developing data acces center tells you

@ Developing EGL applica 3bg”§ Durttouls

P i 3 dan ow L0 use

@ Building XML applicatiq them to achieve

@ Detecting and analyzir| your

@ Testing and publishing dev:‘elnpment

@ Troubleshooting and s eSS

€ pebuaging application: )  Stay current Information for this

(& Reference) product is constantly being extended

- and improved. To download updated
~ Glossary information, go to Help > Software

Updates = IBM Rational Product

Updater,

@  Smart searches Learn how to use
the Help search engine effectively
4 | __P| and refine vour search scope. -

8 [T lu el

7. In the left pane of the Help window, click Reference.
8. Expand Language Reference.
9. Expand iSeries programming information.

10. Expand High-level languages.

11. Expand ILE COBOL

12. Select Language Reference.

13. Scroll down to MOVE Statement - Format 1.
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& Help - IBM Rational Software Development Platform

=10l x|

Search; | |m Search scope: Mylist
Contents #, B || Reference O o =] & O

@ Testing and publishing appil:atiuns;
@ Troubleshooting and support
@ Debugging applications
E Reference
@ [ ap1s
1+ [ Commands
# [ Debuggers
[ [ Files
|Language reference
iSeries programming information
(~§ 1] High-level languages
) PDF versions of the books
H L ILE Cfc++
&+ [ CoBOL{400

[ L1 pB2 UDB for iSeries SQL R
B Java S
& L ReGf400
# I 1LE RPG
[ [ pata Defintion documentation
[# [ Control language information  +
4] | _PI_I

g [ % | @

ILE COBOL Language =
Reference

Contents

e About this Reference
o Who Should Use this
Reference
o Prereguisite and Related
Information
o How to §

Comments

What's Mew

What's Mew This Release?
Changes to this Guide
Since VBR1

What's New in WERZ2?
What's Mew in VER17
What's Mew in V4R47?
What's Mew in YARZ2?
What's New in W3R7?
What's New in V3IREANVIRZ? o

o0

o]

00000

Having the latest version of the manuals at your fingertips will make it easier

to find programming information. There is also the option to search the help
by specifying a search string. By default, the complete help will be searched.

Limiting the search scope

Note: If you are using WDSC Lite, you can limit the search scope, however, you

must choose another topic instead of the Reference topic shown.

To limit the search to specific documents:

1. Click Search scope.

The Select Search Scope dialog opens.
2. Select Search only the following topics radio button.
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@ Help - IBM Rational Software Development Plal_:ft_lrm' = II:I[_)H
search: | | Go|
Contents i A | reference Ao e afl & 0
B © scictscarchseope Y .
€ Testing and pul lage
@ Troubleshootin < 5earch all topics
> Debugging app! arch only the Following topics:
| Reference
@ [ ap1s
1+ [ Commands
# [ Debuggers
# [ Files le
= [ Language refer e this %
=1 [ iseries prog
= I High-ler hd Related
B prol
mEALE @_I Edt527 I Remaye I Four
m@co
SIRER W
8|
®mE oK
®Bos
B -
& [ ReGfa00 o What's New in V6R1?
# e rpe 0 What's New in V4R4?
[# [ Data Definition documentation o What's New in VAR2?
® [ Control languags information o What's New in V3R7?
| > o What's New in V3REAIRZ? +
g | % | @ 4 | 3
3. Click New.
The New Search List dialog opens.
& x|

w Search List )

[Qame

O Detecting and analyzing run-time problems
= Testing and publishing applications to a server
O Troubleshooting and support

+ ing applications

=l IV Reference
5
™ Commands

™ Debuagers

™ Files
Sethings
[ User interface reference
[™ Crystal Reports
™ Miscellaneous
[T Accessibilty

[T clossary

4| & |

4. In the List name field, type MyList for example.
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5. Expand Reference.
6. Select the Language Reference check box.
7. Click OK on the New Search List dialog.
The Select Search Scope dialog reopens again with MyList selected in the topic
list.
& Select Search El:ope i _}_d_]

" search all topics
& Search only the Following topics:

Mew. .. | Edit... | Removel

Im Cancel I

8. Click OK on the Select Search Scope dialog.
9. In the Search field, type iSeries and programming for example.

& Help - IBM Rational Software Development Platform -0 x|
P sesrch ccope: altopis

10. Searching requires a help index and it takes approximately 10 minutes to
create the index in your workspace. If you want to complete the search query,
click GO.

The search results display.

Search Results ?‘&)

100% iSeries programming informaki =
24%. ILE CJ/C++ Programmer's Guide
23% DBZ Universal Database for iSer ¢
199 ILE COBOL Programmer's GuideJ

19% WebSphere(R) Development Sty
19% ILE CfC++ Compiler Reference
18% ILE CJC4+4 Compiler Reference
18% ILE CJC++ Programmer's Guide
15% ILE CJC++ Programmer's Guide
15% DBZ Universal Database for iSer
13% ILE COBOL Proarammer's Guide

You have accessed language sensitive help and now are ready to begin
[3.8: Finding and replacing text.”|

Exercise 3.8: Finding and replacing text

Before you begin, you must complete [“Exercise 3.5: Invoking language-sensitive|
[help” on page 32|

The LPEX Editor also has a powerful find and replace text feature. You use the
Find and Replace window to search for an item. You can search for a word, a
partial word, or a sequence of such. You can also enter a pattern you want to
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match, provided that the pattern follows the rules of regular expression. You can
replace the found search item. If the entered text or pattern is found, the cursor
moves to either the next or previous occurrence of the search item, according to
your chosen search direction, and replaces the found text according to your
selections.

To find and replace text:
1. Press Ctrl+Home to go to the top of the file.

Tip: When you press Ctrl+Home to go to the top of a file or Ctrl+End to go to
the bottom of a file, a quick mark is set at your cursor position. This allows
you to return to that line by pressing Alt+Q. Ctrl+Q will set a quick mark.

2. Click Edit > Find/Replace from the workbench menu or press Ctrl+F.
The Find/Replace window opens at the bottom of the Editor window.

4N/ PAYROLLC, CELLE. X g

Line 29 Column 14 Replace
————t=%p~1-B-f4 2 ; 3 ; 4 ; 5 ;

aoooze ¥ are! m‘ - maintenance display file ;l
000030 * EMPHST - employee master file g
000031 ® PRIMST - project master file
000032 * RSNMST - reason code master file
000033 I B e
00003 4
000035 FILE-CONTROL.
00003 6
000037 SELECT MSTDSP-FILE
000038 ASSIGH TO WORESTATICH-M3TDSP-3I
0ooose CRGANIZATICN IS TRANSACTICH
000040 ACCESS I8 SEQUENTIAL.
000041
00004z SELECT EMPMST-FILE
000043 ASSIGH TO DATABASE-ENPMST
000044 CRGANIZATICHN IS INDEXED
000045 RECORD EEY I8 EXTERMALLY-DESCRIBED-EEY
000046 ACCESS IS DYNAMIC -
4 | L[J
Flnd l@i‘ Previousl LIII
Replacel NLIace] Replace all
[ Case sensitive [ Wholeword [ Regular expression [v Wrap [ Select found text
I Restrict search to selection |~ Restrict search to columns  Start column [1_ End column IE_

At the bottom of this window, you will notice that you have some options to
select from, for example, search only in certain columns, etc. You want to find
the first occurrence of MSTDSP.

3. In the Find field, enter MSTDSP to find the start of a file section.
4. Make sure the Replace field is blank.

You would use this field for text replacement.
5. Click Next to go to the next location of MSTDSP in the file.

The Editor moves the active line to line 37, which contains the first MSTDSP
phrase in the file.

6. Click in the Editor window to close the Find/Replace window.

You have searched for an item in your source using the Find /Replace window and
now you are ready to begin [“Exercise 3.9: Filtering lines by string” on page 39
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Exercise 3.9: Filtering lines by string

Before iou begin, you must complete [“Exercise 3.8: Finding and replacing text” on|

The editor allows you to filter or subset your source so that you see only lines
containing a given string. Filtering lines makes it quick and easy to find lines
without having to scroll through your source.

To filter source by string:
1. Double-click the variable EMPNO in the Editor window.
2. Select Edit > Selected > Filter Selection from the workbench menu.

Va1 v/ PAYROLLC,CELLE. X g

Line 14z Column 11 Replace
————+—u-1IB—-: 2————4 3———4 4 : 5 T

000142 01 WS-EMENO PIC 5(6).
000302 MOVE EMPNO TO US-EMPNO.
000307 MOVE WS—-EMPNO TO EMPNO OF RCEMP
000320 MOVE US-EMPNO TO EMPNO OF EMPHMNT-C
000353 HMOVE WS-EMPNO TO EMPNO OF RCEMP.

3. Move the cursor down a few lines to line 302.
4. Expand line 302. This expands the section up to the next instance of EMPNO.

VA =R~ PAYROLLE CBLLE X &
Line 302 Column 1 Replace
B+ *A-1-B——+--—-2-———+-———3-——— === -5 ——
ooo014z2 01 WS-EMFNO PIC 9(6).
&000302. MOVE ENPNO TO WS-EMPNO.
000303 HMOVE ACODE OF EMPSEL-I TO WS-ACODE.
000304
000305 IF IND=-OFF (IND-MAINT) AND IND-OFF (IND-EQJ)
000306 SET IND-OFF (IND-NOT-FOUND) TO TRUE
000307 NOVE WS-EMFNO TO EMPNO OF RCEMP
ooo03zo0 HOVE WS-EMPHO TO EMPNC OF EMPMNT-C
E 000353 HOVE WS-EMPNO TO EMPNO OF RCEMP.

Now you want to show the entire source again.
5. Click Edit > Show all from the workbench menu or press Ctrl+W.

Your cursor is still positioned on the same line that you moved the cursor to,
even though all lines are now showing.

You have filtered your source so that you see only lines containing a given string
and now you are ready to begin [“Exercise 3.10: Filtering lines by type.”|

Exercise 3.10: Filtering lines by type

Before you begin, you must complete [“Exercise 3.9: Filtering lines by string.”]

To help you navigate quickly through your ILE COBOL source the editor allows
you to filter lines based on the line type. Imagine you want to see where all the
divisions are defined in your source.
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4 -1t PAYROLLC, CELLE, X
Line 317

Column 38 Replace

000304

000305 IF IND-OFF (IND-MAINT) AND IND-0O
0Doo0306 SET IND-OFF (IND-NOT-FOQUND) T
000307 MOVE WS-EMENO TO EMPFNC OF RC
0oo308 START EMPMST-FILE
000309 INVALID KEY
000310 Prompt F4 SET IND-ON (IND-NOT-
000311 Syntax Check Line T
pon3lz Copy Book } DFF (IND-NOT-FOUND)
000313 cut Cirlak EMPMST-FILE
000314 Cony Cilsineert  FALID KEY SET IND-ON (
ooo3is Paste Chrl4y READ
000316 ACREC OF RCEMP TO wg_
000317 e * |corr rcEMEffro Em
000318 Selected 3
0po31e Deseed i) [ALTIZE EMPMNT-0O
000320 rq
000321 Gl CErl+4 Chrl+G
oopo3zz L 3
000323 o ) Outine R
000324 Embedded SQL/CICS{OLI ~
000325 2 Add to Snippets... Errors
0oo3ze Gave WS-EMESS TO EMESS OF
000327 i WE-ACODE TO ACODE OF
000328 Show Date Area

Add Breakpaint v
K| I LI_I

To filter lines by type:
1. Right-click in the Editor window with the PAYROLLC program.
2. Click Filter view > Divisions on the pop-up menu.

All source lines with divisions are displayed allowing you to move quickly and
easily to the desired division in your file.

#/ MSTDSP.DSPF &
Line 150 Colwm 1 Feplace
H———+—*L—1—B— + —Zm———— =3 m——— —G————t -5
000003 IDENTIFICATION DIVISICH.
00ooos FROGRAN-ID. PAYROLL.
oo0o01s ENVIRCNMENT DIVISION.
0o0o0&4 DATA DIVISIOQN.
EIDEIJ.SEII PROCEDURE DIVISION.

3. Move your cursor to the line with the DATA DIVISION (line 64).
4. Expand the division to show all lines in this division.
Now you could work with the source inside this division.
5. Right-click in the Editor window and click Show all on the pop-up menu.

You have filter lines in your source by line type and now you are ready to begin
[“Exercise 3.11: Searching multiple files” on page 41
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Exercise 3.11: Searching multiple files

Before you begin, you must complete |“Exercise 3.10: Filtering lines by type” on|

If you would like to search through the members in a source physical file or
through the files in a local directory, you can use the Search tool. The Multi-File
Search utility allows you to search for a particular string of text in many members
on the host. This function can also be used on local files.

To search multiple files:
1. Click Search > iSeries from the workbench menu.

@ Remote System Explorer - PAYROLLC.CBLLE - IBM Rational Software
Flle Edit Source Compile Mavigate

19 - 5 , ¥ -0 - Q- ' Search... Ctri+H £ | Efremote syste...
| | @ o » | A 2 By o File., FRiseries Projects

B--—+-+a-1-B—— 2 } 3 ! 4 5 6
The Search window opens.
2. In the Search string field, type ENHRS.
Search ) x|
B iseries Search 7 File Search I <y dw Search ] %" Help Search | 27 Java Sem:Ll_’_
Search string§| EMHRS :_] J [~ Case sensitive
Connection; [s400a | new.. |

-~ Target ,—-'_'-\

Libraryf | RSELABIX ]| Browse...|
File: |QDDSSRC d J Browse. .. I
Membely | *ALL| _':I _-J Browse. .. I

¥ source members ™ Datamembers

- Columns

gl columns

" Between |1 andiG) | 0

" Between(H) I 1 and end of line

Custorice. . | [@] Cancel |

The Connection field should contain your iSeries server name, otherwise enter

it there.

3. Under Target in the Library field, type RSELABxx.

4. Under Target in the File field, type QDDSSRC to search all members in this
source physical file.

5. Under Target in the Member field, select *ALL.

6. Click Search.
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The Multi-File Search window lists all the lines in all the files that reference

ENHRS.
(- - =
'Tad&s’iﬁeries |iSerias A ]RamoteS... [iSerias... [iSeries L.
"ENHRS" - 3 Occurrences in 3 Members 0o 32 ;ji -
=1~y RSELABX%/QDDSSRC(EMPMST) (1 match)

{Line 18) A ENHRS R

=-0y RSELABXHQDDSSRC(MSTDSR) (1 match)

{Line 99) A EMHRS R B 11 37REFFLD(RCEMP/ENHRS *LIBL/EMPMST)

=y RSELABX®/QDDSSRC(REFMST) (1 match)

ine 27) A EMHRS 31 TEXT(EMPLOVEE NORMAL WEEK HOUR

7. Double-click the last line in the list.
A ENHRS 3 1 TEXT('EMPLOYEE NORMAL WEEK HOURS')

The member REFMST is automatically loaded into the editor and the cursor is
placed on the correct line.

& MSTDSP.DSPF lf PAYROLLC,CBLLE m g
Line 27 Column 1 Replace
I. e Namwe++++++RLen++TDpE. ... .. Functions+++++++
000023 A ELOCH 30 TEXT (' ENPLOYEE.4|
000024 i1 COLHDG { ' ENPLOY
00o0zs A EUSRI =1 TEXT (' EMPLOYEE
0000z & o COLHDG (! EMPLOY
000027 i ENHRS i1 TEXT (' EMPLOYEE]
000028 A COLHDG { ' NORMAL
000029 i1 EPHRC 5 1 TEXT('PROJECT
000030 A COLHDG('FRJ HE
000031 -8 EPHRY =7 A TEXT (' PROJECT
000032 L COLHDG (' PRI HE
000033 A EPHRP 7 A TEXT (' PROJECT
000034 i1 COLHDG {' PRI HF—
000035 A EPNRC T TEXT('NON PROJ
00003 6 A COLHDG ('NCN PR
000037 i1 EPNRY 7 & TEXT { JNON PROJ
000038 A COLHDG { 'NON PR
000039 i1 EFNRP 701 TEXT('NON PROJ
000040 A COLHDG('NCN PR
000041 -8 EHWREK 8 1 TEXT (' EMPLOYEE
00004z B COLHDG ('EMP HE
000043 A% PROJECT MASTER RELATED FIELDS
000044 i1 PRCDE 8 TEXT (' PROJECT
000045 i1 COLHDG { ' PROJEC »
«| | » |
|

8. Click the X in the REFMST tab to close the REFMST file.

You have searched through members in a source physical file and now you are
ready to begin [“Exercise 3.12: Comparing file differences from the Remote Systems|
iiew.”

Exercise 3.12: Comparing file differences from the Remote Systems
view

Before iou begin, you must complete [“Exercise 3.11: Searching multiple files” on|
page 41.

If your product undergoes many changes, you will find the Compare utility useful.
It allows you to compare different versions of a program and find the differences.
There are two ways to do a compare: use the Compare utility in the workbench or
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use the Compare utility in the CODE tool. The compare in the CODE tool is more
intuitive but requires you to start the CODE Editor outside of the workbench.

Using the compare utility in the workbench you can view the differences between
two files by comparing them. You can compare different files, and you can
compare versions in the Workbench with versions in the repository or with the
local edit history.

After a comparison is carried out, the Compare Editor opens in the editor area. In
the compare Editor, you can browse through all the differences and copy
highlighted differences between the compared resources. You can save changes to
resources that are made in the comparison editor.

Using the compare utility in CODE you can also view the differences between two
files by comparing them. You enter a name of a file to compare against the file in
the CODE Editor view. You can type the name of a file, or you can select one from
the list of files already open in the editor. If you type the name of the file that is
not already open in the editor, it is loaded into the editor. If no file is specified, the
current file is compared against a new, untitled file. The current file appears on the
left side of the Compare view, and the specified file on the right. You use the
Compare menu to view the next and previous mismatch and to select options such
as ignore case, font, protect view and show mismatches only.

Note: Make sure all lines show in the source before starting the Compare tool.

To compare files in the workbench:
1. Click Window > Preferences from the workbench menu.
The Preferences window opens.
2. In the left pane of the Preferences window, expand LPEX Editor.

~loix]
2 compare |

" Appearance

-~ Block Ignore case
gnore |eading blanks
; Clonhrols ignore trailing blanks
i~ Find Text
# Parsers gnore al blanks
i Print v Ignore sequence numbers
friniive [ Ignore comments %
- Tabs
-~ User Actions
- User Commands [~ Column restricted comparison
- User Key Actions start column I‘I_
- User Mouse Actions
i User Profile End column IGO

- C:\Documents and Sett
#- C\Documents and Sett
C\Documents and Sett
# Remoke Systems

[+ RunfDebug

[+ Server

[+ Yalidation

[+ Web and ¥ML

#- Web Diagram

[ [+

‘WebFacing I
‘ﬂl Welb Tods _’]; Reset | Restore Defaults | Apply I

mport... | Export... | [ (o) | conce |
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3. Click Compare under LPEX Editor.

In the right pane of the Preferences window make sure that the Ignore blanks
check boxes are selected.

4. Click OK in the Preferences window.

5. Back in the Editor window of the PAYROLLC member double-click the
PAYROLLC tab.

6. Click Edit > Compare > Compare to file on the workbench menu.

avalc _1n| 5]
Filz @ Source Compile Mawvigate Search Project Run  Window Help
£ 9 e sz =
l «~ Wy pedo Clrl4y
"‘?l of Cut Chrl+x g
W Cory Chri4Insert Replace
I ﬁ Paste CEA+Y.
C Al
[ % Delete Delete ENHRS LT
{ Select Al Chrl+A
€ FndiReplace... Chrl4F ERERE S
€ FindNext Shift+F4
C Erd Previoos EFHRY 7 1
C Find Other L4
E Show Al Chrlww BERES 71
[ AddBookmark... EENRC s a4
[ AddTask..
ki | EENRY oA |
€ selected >
E Deselect Ale+1 EPNRP 7 1 ==
C
E C ompare
C - BV Shift+1
C Show Tooltip Description F2 Crrl+Shift+p
C Content Assist Chrl+SPACE Refresh Crrl4+Shift+R.
0oo04s A Clear
gooo47 A
oooon4s A PRREP 320
opoo49 A
0oooso A PRSTR R
| | |
|| | | |

The Compare window opens.
7. Expand your connection.
8. Expand *LIBL.
9. Expand RSELABxx.
10. Expand QCBLLESRC.
11. Select member PAYROLLC2
12. Click OK.
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@ Compare File L x|

Select a member

|PavroLLC2

B3P LBl 2l

-, Q5YS2924. b prod-sys

B Q5YS. ¥ib.prod-sys

[, Q5YS2 Mib,prod-sys

-, QHLPSYS. *lib.prod-sys

[ m), QUSRSYS. ¥libprod-sys

g RSELABXY. *lib.prod-cur

=4, RSELABOD.*lb.prod-usr

[ i, WSSLABXK, ¥lib. prod-usr

(E)= rseLagxx ib.prod-usr N

v 5y COMPARE *file.pf-src

] EMPMST . *file. pf-dta

1[5l EVFEVENT. *file.pf-dta

B PRIMST *file.pf-dta -
QCBLLESRC. . *file.pf-src

- pAYROLLC.chlle

Ela Dile
1

i 5]
. [Eh A ene #Rile nF co-

The editor now will show the differences of these two members PAYROLLC
and PAYROLLC?2 .

You can move from mismatch to mismatch by using the Compare menu under
the Edit menu.

Mismatches in PAYROLLC and PAYROLLC2 are highlighted in different colors
so that you know where the mismatched lines are in each file.

Line 87 Column 1 Replace
B---+-7A-1-B-—4 2 | 3 : 4 : 5 6
000078 COPY DDS-ALL-FORMATS OF PRJMST. ;l
000079
00o0o0s0 FD RSNM3T-FILE.
000081 01 RENM3ST-REC. _l
oooosz COPY DDS-ALL-FORMATS OF RSNMST.
000083
000084 WORKING-STORAGE SECTICH.
000085
000086 01 ERROR-MESSAGES.
2 0c MSG-TLRELE
jooooss 10 HM3G-1 PIC X(50) VALUE
poooss 10 MS8G-1 PIC X50) VALUE
ML I I ENAICE SELECTION CODE MOl PouaL 1
000050 10 M3G-2 PIC X(50) VALTUE
000091 'MORE THAN ONE APPLICATION SELECTED FOR MA
oooosz 10 M3G-3 PIC X(50) VALUE
0000393 ! NO APPLICATION SELECTED FOR MAINTENA
000054 10 M3G-4 PIC X(50) VALUE
00o00ss J ACTION CODE NOT EQUAL TO "a"™, "C" CR
00008 e 10 M3G-5 PIC X (50) VALILTUE
oooos? ' ADD REQUESTED EBUT RECORD ALREADY EXISTS
000058 10 M8G-6 PIC X(50) VALUE
0000s9 ! WARMNING - RECORD WAS FREVIOUSLY DELETw
+ 1 | 2
One or more nmismatches found.

13. Click Ctrl + Shift + N to find the next mismatch.
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14.
15.

Next, end the compare session.
Click Edit > Compare > Clear from the workbench menu.

Double-click the PAYROLLC tab to return the Editor window to its original
size.

You have compared different versions of the program and found the differences
and now you are ready to begin [“Exercise 3.13: Comparing files in the CODE]

[Editor (optional).”|

Exercise 3.13: Comparing files in the CODE Editor (optional)

Before you begin, you must complete [“Exercise 3.12: Comparing file differences|

[from the Remote Systems view” on page 42

The CODE tool provides a side-by-side view of the members being compared. If
you prefer this type of view follow the steps described next. You might want to
skip this section if the Compare Tool you just used provides sufficient information
for you. Now you will open a couple of files and edit them and use the CODE
compare utility.

To compare files in the CODE Editor:

1.
2.

In the Remote Systems view, right-click member PAYROLLC in QCBLLESRC.
Click Open With > CODE Editor on the pop-up menu.

This opens the CODE Editor window with the member. It will open in browse
mode since it is locked by the LPEX Editor session.

In the CODE Editor, open the PAYROLLC2 member.
Click File > Open from the CODE Editor menu.
The Select file - Open for Edit dialog opens.

I‘ﬂSeIecl: file - Open for Edit - El

File name |<Flfﬁ-w[ﬂ)HSELAE*;’QCBLLESHE[PAYHDLLC?] j Source type ICBLLE "l
[ Contairis sequence numbers Subset by source type |< AllFiles > ¥ |

|<HGS4EIJA>HSELAB>¢UQCBLLESFI |Conten|3 of '“ROS4004>RSELABXX/QCBLLESRC()

#-<LOCAL>  C:AProgram Files' = | = with syntax & verify erors ;I
= <ROS4004> C
=+ QDEVTOOLS CBLLE no eMmors
# QGPL
- QHLPSYS
- OSYS
A QSYS2
5

& QUSRSYS
1 ASELABKA
L COMBAR

o — -
OCMDSAC | ;’_I

i~ QDDSSAC . ¥ Refresh ] Sort | Subset | Eirid: | |

. e
oK | open | oo | concel| Hep| N

I(Fl[IS4I]I]A)RSELAB}OQQCBLLESRC[PAYROLL02]

In the left pane of the Select file - Open for Edit dialog expand the R0S400A
connection (the Remote System Explorer connection).

Expand library RSELABxx.
Select file QCBLLESRC.

46 Development Studio Client: Maintain an ILE application using Remote System Explorer COBOL application



8. In the right pane of the Select file-Open for Edit dialog, select member

11.

12.

PAYROLLC2 from the member list.
Click OK.

Click Actions > Compare from the CODE Editor menu.

The Compare dialog opens:

x
<ROS400A>RSELABX{QCBLLESRC[PAYROLLC2)

Select or enter a file name

<F{[154l] DA>RSELABXX/QCBLLESRC[PAYROLLC

<ROS400A>RSELABXXIQCBLLESRC[PAYROLLC

Cancel

All entries are preloaded.
Click Compare.

The editor now has the PAYROLLC2 member loaded on the left and member

PAYROLLC loaded on the right. In between the two members are two long

vertical blue lines with horizontal yellow and red bars highlighting the

differences in these members.

E CODE - <R0OS400A>RSELABXX/QCBLLESRC(PAYROLLCZ): 2
Fil= Edit Wiew Actions Cumpare Optlnns Windows Help

Replﬁl "

B—-+-*A-1-B-—+———-2-——»

Bulumn 1 Repla

PROCESS APDST.

IDENTIFICATION

PROGRAM-ID.
AUTHOR .
INSTALLATION.
DATE-WRITTEN.
DATE-COMPILED

* PROGRAM DESCRI
* - Time reporti
* described wo

ENUIRONMENT DIU
CONFIGURATION S

SOURCE-COMPUT
OBJECT-COMPUT

| »

IBH Live Parsing Editor

Row 1 Enlumn 1 Row 1
B--+-*A-1-B--+-——-2———-4] |
aapen1 PROCESS APOST. fﬂ! saepB1
aapen2 | apepn2
fapen3 IDENTIFICATION | 0000en3
aepenYy annpBy
aeeens PROGRAM-ID. —| |esepAS
000806 AUTHOR . ‘ T
sapee7 INSTALLATION. anena?
fopenvs DATE-WRITTEN. 00pens
fonen9 DATE-COMPILED 000e0n9
aepB10 CELLEE)
saee11 et o s e aneni1
sane12 * PROGRAM DESCRI oaee12
8eee13 * - Time reporti BLLEE]
G TSR * described wo BLLLRET
a0ae1s e aneni1s
aeev16 | anen16
aeee17 i m WL F
fane18 ENUIRONMENT DIV | 000618
sapBe19 | aneni19
fope20 CONFIGURATION § 000620
000021 | 000021
fope22 SOURCE-COMPUT | 000022
sape23 0BJECT-COMPUT | 000023
bl |

«| [ > | 4|

IBH Live Parsing Editor
I =l

*|

Use the vertical scroll bars to move within the files.

As you scroll, you will see where the differences are in the members.
13. Click Ctrl + Shift + N to find the next mismatch.
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14. Click Compare > Exit compare from the CODE Editor menu (which was
inserted while performing this action).

The CODE Editor window re-opens.
Close the CODE Editor.

15. Click File > Exit from the CODE Editor menu. The workbench re-opens.
Continue working in the workbench.

You have compared files using the CODE Editor and now you are ready to begin
[“Exercise 3.14: Checking syntax.”|

Exercise 3.14: Checking syntax

Before you begin, you must complete [“Exercise 3.13: Comparing files in the CODE]
[Editor (optional)” on page 46

One of the powerful features that the LPEX Editor shares with SEU is its ability to
syntax check your source. Syntax checking can be done either when the cursor
leaves each line of source or all at once on either the currently selected source or
on the entire source member.

Now you will create a syntax error and watch for the prompt to correct it.

To syntax check the file:

1. Click the PAYROLLC Editor window, click Source and then click Syntax Check
All on the workbench menu.

48 Development Studio Client: Maintain an ILE application using Remote System Explorer COBOL application



& Remote System Explorer - PAYROLLC.CBLLE - IBM Rational Software

File Edit l Source  C

| w

L

Syntax C

ompile MNavigate Search Project Run  ‘Window Help

- 79 | EBremcte Syste...

L\

| [ Verify Curb+Shift+y TRiseries Projects

A/ msTDe £ Verify (Prompt)... & |
Line  ohoy felds o

o Bock s b—3-——-+—4 —+ 5 6

0o00" TS OF PRIHST. A
oooo” ILE COBOL Help >
000DE
ooops  Fromet i e
0000f  pesequence AllLines TS OF RSNHST.
0000E  pefrech Ctrl+FS
0000 TICN.
000085
000086 01 ERROR-NESSAGES.
000087 05 MSG-TABLE.
000088 10 MSG-1 PIC X50) WALUE
000089 ' HMAINTEMANCE SELECTION CODE MOT EQUAL T
000090 10 MSG-2 PIC X(50) VALUE
000091 'MORE THAN ONE APFLICATION SELECTED FOR M2
000092 10 MSG-3 PIC X(50) VALUE
000083 . NO APPLICATION SELECTED FOR MAINTENA
000094 10 MSG-4 PIC ¥{50) VALUE
000095 ' ACTION CODE NOT EQUAL TO "&", "C" OR
000096 10 MSG-5 PIC X(50) VALUE
000097 ' ADD REQUESTED BUT RECORD ALREADY EXISTS
000098 10 M3G-6 PIC X(50) VALUE
fufujulul=l=] ' WARMNING - RECORD W3 PREVIOUSLY DELET
000100 10 M3G-7 PIC E(50) VALUE -
4| | v
|

|

Error messages appear to draw attention to the errors.

<«

Line 88 Column 1 Replace
- *h-1-F 2 : 3 : 4 ; s &
0ooo7s CCOPY DDS-ALL-FOEMATS OF PRJM3T. ;I
000079
00o0o0s0 FD R3NMST-FILE.
000081 01 RSNMST-REC. _l
oooosz COPY DDS-ALL-FORMATS OF RSNMST.
0o000s83
000084 WORKING-STORAGE SECTICH.
000085
000086 01 ERROR-MESSAGES.
0ooose? 05 M3G-TABLE.
0oooss 10 M3G-1 PIC X50) VALUE
LMCZ2530E Unmatched right parenthesis. I}hght. parenthesis i
LNC1248E PICTURE string 'X50)' does not describe valid dav
000089 ] MAINTENANCE SELECTION CODE NOT EQUAL T
gooosa 10 M5G-2 PIC X(50) VALUE
oooos1 'MCRE THAN ONE APPLICATICN SELECTED FOR M2
0oo0sz 10 M3G-3 PIC X (50) VALUE
000083 ! NO APPLICATION SELECTED FOR MAINTENAL
000054 10 MEG-4 PIC X(50) VALUE
00oo0ss ! ACTION CODE NOT EQUAL TO ™ar, "C'" QR
ooooss 10 MSG-5 PIC X(50) VALUE
0ooos7? ' ADD REQUESTED EUT RECORD ALREADY EXISTS
0oooss 10

NSG-6 PIC ¥(50) VALUE -
| »

Syntax check action completed with informational and/or error me:g
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2. Move the cursor onto the pink error message.

3. Press F1.
& Help - IBM Rational Software Development Platform R = jI:I|£I
Szarch; | |m Search scope: Mylist
Contents % O GO oo | e & O

@ Introduction to websy. COBOL Messages
e Installing and migratin
@ Navigating and custon
@ Connecting to Linux, U LNC2530
@ Working in a teameny|
@ Developing iSeties ser|| |nmatched right parenthesis. Right parenthesis ignored.
@ Developing Web applid
@ Developing Java appli¢| 30
@ Developing data acces
> Developing EGL applica| Cause . .. .. : There is a right parenthesis in the picture
& Building XML applicatia string without 2 maiching left parenthesis.

@ Detecting and analyzir|
@ Testing and publishing
@ Troubleshooting and s
@ Debugging application|

Recovery . . . : Remove extra right parenthesis or supply
its matching left parenthesis.

@ Reference [ Top of Page | Previous Page | Next Page | Table of
@ Glossary Contents ]

(C) Copyright IBM Corporation 1992, 2005. All Rights Reserved.

This opens a window with second level help for the error.
4. Minimize the Help window.

o

Add the required left parenthesis to correct the error.
6. Move the cursor off the line you just fixed.
The error message is automatically removed from the editor.

Tip: You can toggle automatic syntax checking. Click Window > Preferences
from the workbench menu and then expand Remote Systems, iSeries, LPEX
Editor Parsers, select the language you want to change the settings for in the
left pane of the Preferences window and select the Automatic syntax checking
check box and then click OK.
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_ioi

3]
®
#
=

E2]
[

Workbench
Ant

- Build Order

Help

- Installiupdate
Internet
iSeries Projects

= J2EE

Java
- LPE¥ Editar

1) Remote Systems

- Communications
[#-Debug
File Cache
Files
iSeries
Cache

- Command Executio
Command Subsyste

Job Subsystems
i LPEX Editor Parsers

L

E COBOL [

¥ Automatic syntax checking

¥ Automatic syntax checking of SQL statements (iSeries connecl
I Automatic uppercasing
I™ User defined tabs

General

|+1+z+;—4

|
And every: I 4

Restare Defaults | Apply I

oK I Cancel I

Now you are ready to review your knowledge of this module by taking the quiz.

You can also apply what you have learned in this module by completing the
practice tasks detailed in More practice.

Quiz

1. The LPEX Editor has predefined settings, but also has an associated
preferences page containing settings that you can define. (T, F)

2. LPEX Editor preferences are set in the:

a.
b.
c.
d.

Preferences window

Editor window

New wizard

Remote Systems view

3. You can configure the LPEX Editor to adopt the keyboard and command
personalities of many popular editors. (T, F)

4. If you want to undo a set of changes made to a file you must use the
operation. Name the operation.

a.
b.
c.
d.

Insert
Replace
Redo
Undo

5. You can also cancel the effects of an undo operation by using the
operation. Name the operation.

a.

b.
c.
d

Insert
Replace
Redo
Undo
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6. To receive language sensitive help, press the key in an Editor window.
Name the key:

a. F2
b. F3
c. F1
d. F4
7. If the cursor is an operation code, you receive help for that operation
code; otherwise, you receive help for the current specification.
a. before
b. after
C. on
d. off
8. Instead of entering or changing code directly in the Editor window, you can
use
a. Prompts
b. Filters
c. SEU commands
d. Format line
e. All of the above

9. You use the window to search for an item in the current source.
Choose the best answer.

a. Search
b. Find
c. Edit

d. Find/Replace
10. You can search for:
A word
A partial word
A sequence of words
A pattern if it follows the rules of regular expression
. All of the above

11. The LPEX Editor allows you to or subset your source so that you see
only lines containing a given string.

©® a0 o

a. search
b. find
C. sort
d. filter
12. If you would like to search through the members in a source physical file or
through the files in a local directory, you can use the tool. Choose the

best answer.
a. Compare

b. Search
c. Find
d. Edit
13. The tool allows you to compare different versions of a program and

find the differences. Choose the best answer.
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14.

15.

a. Convert
b. Migrate
c. Compare
d. Search

There are two ways to compare files. They are Compare tool in the workbench
and the Compare tool in the CODE Editor. (T, F)

Syntax checking can be done either when the cursor leaves each line of source
or all at once on either the currently selected source or on the entire source
member. (T, F)

Module recap

You have completed [Chapter 3, “Module 3. Editing source,” on page 25| You have
learned how to:

Change the default settings of the LPEX Editor Parsers

Change the color settings and font used by the Editor

Change the default behavior of the Enter key

Use SEU commands to edit source

Undo and redo source changes

View language sensitive help for the MOVE operation code

View a list of all help contents

Limit the search of help to specific documents

Search the help

Use the Find and Replace window to search for an item in your source
Filter or subset your source

Filter lines based on line type

Search through members in a source physical file

Compare different versions of a program and identify the differences
Syntax check source by line

View help on syntax errors

Now that you have mastered editing source, you can move on to verifying your
source to ensure you have a clean compile on the iSeries system. This approach
saves you iSeries cycles! And you perform both verify and compile from the
Remote Systems view! Continue to [Chapter 4, “Module 4. Verifying and compiling|

lsource,” on page 55
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Chapter 4. Module 4. Verifying and compiling source

This module teaches you how to verify and compile RPG in the Remote Systems
LPEX Editor. When errors are found by either the verify or the compile step, the
iSeries Error List appears. The iSeries Error List is a powerful tool that manages

errors found by verify and compile utilities. You will become familiar with these
tools, the various capabilities of the iSeries Error List and the RPG program that
you have created.

In this module, you will:

Check for semantic errors on your workstation

Start the Program Verifier tool

Use the iSeries Error list to locate each error in the source

Save your source

Re-verify source

Change compile preferences

Invoke the compile command

Change the current library using the Command field in the iSeries Table view
Start an interactive connection

Invoke the payroll program

Exercises

The exercises within this module must be completed in order:

* |“Exercise 4.1: Verifying the source”|

* |“Exercise 4.2: Compiling source remotely” on page 57

“Exercise 4.3: Submitting iSeries commands in the iSeries Table view” on page|

61l

* [“Exercise 4.4: Running commands and programs” on page 63|

Time required

This module will take approximately 20 minutes to complete.

Exercise 4.1: Verifying the source

Now you get to play with one of the most powerful and unique features of the
Remote System Explorer — the Program Verifier. Before you compile your code on
an iSeries, you can make certain that there are no errors by invoking the Program
Verifier. The verifier checks for semantic (compile) errors on your workstation so
that you can guarantee a clean compile on the iSeries. Think of the host cycles
you'll save. It is especially handy when you are writing code but you are
disconnected from an iSeries. You can do this because Remote System Explorer
ported the parsing and checking code from the iSeries system compilers to the
workstation. The iSeries Error List view lists the errors that are found and their
severity, inserts the error messages directly into the source and helps you to
navigate between the errors.

To invoke the verifier:

© Copyright IBM Corp. 2001, 2006
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Click Source > Verify from the workbench menu. (Similarly, you can also use
the pop-up menu for the source member in the Remote Systems View or the
Verify tool button — you need the source in the editor for the button to
appear.)

You will need to open the COBOL source file named PAYROLLC2 to complete
this verify step.

After a moment the verifier will display an iSeries Error List below the Editor
window.

Tasks |i5&ries Table ... | iSeries Comm... | Remote Search | Remote Syste, .. =[E =&
<TORASO7FM =RSELABXSQCELLESRC(PAYROLLCZ) ® & & o w
[ 1D | Message [ Sewverity i Line | Location f cConn...

B (NC1304  Program PAYROLL ... 40 1 RSELABXX/QCBLLESRC(... s400a
O LNC1326 'PRCD OF PRISEL-T',., 30 402  RSELABx%/QCBLLESRC(... 54003
O LNC1329 Subscript value '14'.., 30 606  RSELABX#/QCBLLESRCL... s400a
[ LNC1463  'EMPNO'is notuig... 30 302 RSELABXX/QCBLLESRC(... s400a
3  LNCO407 AT END phrase mis.,. 20 399  RSELABns/QCBLLESRC(... s400a
@ LNCO407  ATEND phrase mis... 20 448 RSELABXX/QCBLLESRC(... s400a
@  LNCo407 AT END phrase mis.,, 20 499  RSELABX#/QCBLLESRC(... 54002
@ LNCo407 AT END phrase mis.,, 20 548  RSELABX®/QCBLLESRCL... s400a
@ LNC0407  ATEND phrase mis... 20 184  RSELABXX/QCBLLESRC(... s400a
@  LNCO407 AT END phrase mis.,. 20 299  RSELABn#/QCBLLESRC(... s400a
@ LNCO407  ATEND phrase mis... 20 348 RSELABXY/QCBLLESRC(... s400a

The error list shows you:
* The error message itself
* The severity

* The line number

* The source location

* The connection name

Fixing errors

Next you will fix the errors in your source.

To fix an error in your source go to the error list:

1.

Double-click the error LNC1463.

You are automatically brought back into the Editor window to the line where
the error occurred. The error is caused by EMPNO not being uniquely defined.
Go to line 302 where EMPNO is defined. The variable EMPNO should be
EMPNO OF EMPSEL-IL.

Make the change.

The next error is LNC1326.

Double-click LNC1326. Fix it in the editor.

PRCD should really be PRCDE.

Make the appropriate change on line 402.

Double-click LNC1329.

This error is because the array was declared with 4 elements. Go to line 606.
Change the index of the array from 14 to 4.

The next errors are LNC0407. You can ignore these errors as they are severity
20.

All severity 30 errors and above are now fixed. You can filter out different
severities by using the filter menu.
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7.
8.

9. Clear the severities you don’t want to see in the list (Warning for example).

Tasks | iSeties Table ... | iSeries Comm... I Remote Search | Remote Syste...
<TORASO7M>RSELABXA/QCELLESRC(PAYROLLCZ) ® b& B eh
| | | Message | severity |L v ; Information Shous
B LNC1904  Program PAYROLL ... 40 1, A Warning
v [ LMC1326  'PRCD OF PRISEL-T... 30 q
v'i_. : 0 # vV DEmor SRC{... |s400a
v [ LNC1463 v |30 = ¥ ] Severe SRC{.,. sd00a
@ LNC0407 AT END phrase mis,.. 20 2 v M Terminating SRC{...  s400a
@ LNCo407 AT END phrase mis.., 20 fere——reoeererrrrereen RO, 54002
@ LNCo407 AT END phrase mis.., 20 499 | RSELABWX/QCELLESRC(... s400a
@ LNCO407  ATEND phrase mis... 20 545 RSELABXM/QCELLESRC(... s400a
@ LNCo407 AT EMD phrase mis.,, 20 184  RSELABXX/QCBLLESRC{... s400a
@ LNCO407  ATEND phrase mis... 20 299 RSELABXX/QCBLLESRC(... s400a
@ LNCo407 AT END phrase mis.,, 20 348 | RSELABXY/QCELLESRC(... s400a

Click the arrow in the iSeries Error List title bar.
Click Show Severity on the pop-up menu.

Saving the source member

Now before you loose any of your changes, it's a good idea to save them. Make

sure the member is selected. You then verify the source again to make sure that all
the errors are fixed.

You can save the member using one of these ways:

1.
2.

You have verified your source and fixed any errors and now you are ready to

Click File > Save from the workbench menu.

Click the Save icon @ in the workbench toolbar.
Press Ctrl+S.
Changes are uploaded to the iSeries.

Verify your source again.

Tasks | iSeries Table .., I iSeries Comm, .. | Remote Search | Remote Syste..,
<TORASO7M >RSELABRK/QUBLLESRC{PAYROLLCZ)

[ | Message | severity | Line | Location
@ LNCD407 | AT END phrase mis.. |20 184 | RSELABXX/QCBLLESRCI...  s400a
@  LNCo407 AT END phrase mis... 20 299 REELABXXIQCBLLESRC(... s400a
@ LNCO407 AT END phrase mis... 20 348 RSELABXY/QCBLLESRC(...  s400a
@ LNCO407 AT END phrase mis... 20 399 RSELABMX/QCELLESRC(... s400a
@ LNCO407 AT END phrase mis... 20 448  RSELABXX/QCELLESRC(... sd00a
@ LNCO407 AT END phrase mis... 20 499  RSELABXY/QCBLLESRC(... s400a
@ LNCO407 AT END phrase mis... 20 548 RSELABX%/QCELLESRC(... s400a

Everything should be ok. You should see only severity 20 messages. You are

ready to compile the program.

begin [“Exercise 4.2: Compiling source remotely.”|

Exercise 4.2: Compiling source remotely

Before you begin, you must complete [“Exercise 4.1: Verifying the source” on page]
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The remote compile capability is part of the Remote System Explorer. It gives you
a workstation interface to submit requests to compile, bind, or build objects on the
iSeries host. It allows for easy access to all the compile options available for all the
supported CRTxxx commands.

If you used the local program verifier, then your host compiles should be
successful -- no wasted iSeries cycles. However, if there are errors, the host
compiler will send the error information back to the workstation and they will be
loaded into the iSeries Error List view, which behaves just as it did when you did
a program verify.

The default for compiling programs is to submit the compile to the batch job
queue. Here in this exercise you can run the compile interactive.

Changing compile preferences

To change the preferences to run the compile interactive:
1. Click Window > Preferences from the workbench menu.

_ialx]

Workbench = I Command Execution [
[+ Ant k
- Build Order Command Execut% Preferences
Help
B InstalfUpdate Preferences for compiles and user action variables
E_] Inkernet
[# iSeries Projects Object library: I*SRCLIB
i J2EE [¥ Replace object
Java :
- LPEX Editor ke
= Remate Systems
F z ;';Tm””mt'ons Preferences for batch compiles, commands, and user action variabl
+ ug
L. File Cache Job description library: I"‘"'- 16L
L _FSI:? Job description [*usrert
= I2EMNES
| - Cache SBMIOB additional parameters: |
: Eummanj Exm‘m [~ add batch compiles to the iSeries Job Status view
Ornnan uhsy‘stf
J0b Subsystems [ add batch commands to the iSeries Job Status view
=} LPEX Editor Parsers
b CL 7
gt Preferences only for compile commands
- DDS Compile member types in this order:
- ILERPG o
L RPGJ400 LF ﬂ Wavets
- Objects DSPF J_rl
[+ Program Yerifiers PRTF
Table Yiew ICFF Move Bovn |
- Templates E.PG.!' & -l
" Logaging ¥
4 . Restore

Irmport... | Expott... I 0K I Cancel I

In the left pane of the Preferences window, expand Remote Systems.
Expand iSeries under Remote Systems.
Click Command Execution under iSeries.

Al A

In the right pane of the Preferences window, clear the Compile in batch check
box.

6. Click OK to return to the Remote System Explorer perspective.
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Invoking the compile command

You will now use the prompt for the CRTBNDCBL command to specify your
compile parameters. All entry fields pertaining to names are already filled in with

the correct information.

To compile source:
Right-click the PAYROLLC2 member in QCBLLESRC.

1.

Mem[ = A) (f MSTDSP.DSPF fimmeLc.csLLE 52 =) =]
)| | EEs - Line 205 Column 1 o
%5 wstosez. fie.dsot ]|| A | - 1

I3l PRIMST *file.pf-dta 000204 &lff m-e
5y QCBLLESRC. *file.pf-s 000205 ELSE [+ C
B PAYROLLC.cblle 000206 = F
el A ROLLCZ. ch = R
- PAYROLLD.chlle S
QCLSRC.*file.pf-src  Open With »
QCMDSRC *fle.pf-st  Browse with » _‘.ll
QDDSSRC, *file.pf-sr . s
; E_] EMPMST.pF 'I—‘ Rename... mismatches foil
H : " &
ﬂ ACTHEN r'(-]- ’ l___Ej cw ﬂﬂ
e iSeries Table View &3 ==
Flproperties 52 . Remote Scr.. I = <f Move, et SR e \\_
3 Delete.. (3 Members)
ks —u o
Property | Value web Services »
Attrbute  SRC F— | Atribute | Text [=
Name PATROLLC2 FOR SRR | R
Mumber of ... O = Verify
Source RSELABXX/QUBLLESR .
S oK 2 Verify (Prompt)... 3 ]
Text with verify errors Compile L2
Type CELLE Compile (Prompt)

(A ST P

v [ CRTBMDCEL. [ 3
xrr \J

2. Click Compile (Prompt) > CRTBNDCBL on the pop-up menu.
The Create Bound COBOL Program (CRTBNDCBL) dialog opens.
3. In the Debug view list, select the *ALL parameter.
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@i Create Bound COBOL Program (CRTBNDCBL) N 5]
Program: > |PavROLLCZ | Name

Library: > | RsELABXX ~| Mame
Source file: > | QUBLLESRC Mame

Library: > | RSELABXYX = Mame
Source member: > | PAYROLLC2 = Mame
Source stream file!
Generation severity level: [30 0-30
Text 'description’: *SRCMBRTAT ~| character:

Advanced Parameters
Compiler options: > —_:I fidd
YEVENTF Remove
[ove up
Move dawn
[Debug i
Replace program:
[~ Advanced(1) " All Parameters(z) I Keywords(3)
CRTBMDCBL PGM(RSELABXX/PAVROLLC2) SRCFILE(RSELABX:/QCBLLESRC) SRCMBR{PAYROLLCZ) OPTION{*EVEMTF)
DBGYIEW(*ALL) REPLACE(*YES)
| | e I Restore defaults | Cancel

If you want to see the other parameters available, click Advanced.
4. Click OK when you are finished.
The progress bar on the workbench (bottom right corner) will indicate that the

compile runs. Then the error list will be shown, with no errors, just information
messages.

If you are not sure that the compile was successful, you can check the iSeries
Commands log.

Remote Search [ Remote Syster ... [iSerIas Error u;t( =g

Tacks | [Series Table Vi... L= Re= oI

b4

Lt

s400a |

CRTEBNDCEL PGM{RSELAEX/PAYROLLC2) SRCFILE(RSELABXX/QCBLLESRC) SRCMER{PAYROLLCZ) :]
OPTION(*EVENTF) DEGVIEW(*ALL) REPLACE(*YES)

Program PAYROLLC2 created in library RSELABXX on 01/11/05 at 14:14:42,

Cause . ....: Theprogram has been compiled and translated successfully and placed in the indicated

library on the stated date and time.

| 5
Command INormal j I :J Prampt, . | ;-‘J_unl
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5. Click the iSeries Commands log tab from the view at the bottom of the
workbench.

This log shows a list of all commands run on the remote system and the
messages returned for each command.

You have set compile preferences, invoked the compile command, checked for a
successful compile and now you are ready to begin [“Exercise 4.3: Submitting]|
iSeries commands in the iSeries Table view.”|

Exercise 4.3: Submitting iSeries commands in the iSeries Table view

Before iou begin, you must complete [“Exercise 4.2: Compiling source remotely” on|

You can use the iSeries Table view inside the Remote System Explorer to submit
commands to the iSeries. You can run commands from the Commands field
beneath the iSeries Table view, and view messages in the Messages field. After you
populate the table, you can enter a command and click either Prompt to specify
parameters and then Run or just click Run. When you run a command, the
Messages field is populated with the messages from the command. When you
select a message, the Details button is enabled. When you click this button, the
message and its help is displayed.

Also note that besides the iSeries Table view, you can also use the Remote Systems
view to run commands and programs. Which one you choose depends on your
personal preference. In the iSeries Table view, you can see the properties of all
items at the same time; they are displayed as rows across the table. In the Remote
Systems view, you have greater ease of navigation; you can work from your
Library list in the iSeries Objects subsystem, and you can see the contents of many
items before selecting the one you want to run.

In the Commands field, you select where you want to run the command. The
choices are Normal, which means that the command will run in the RSE
communication server job, Batch or Interactive.

To change the library list:

& @ v =0
File RSELABY%/QCBLLESRC (3 Members)
Name [ Type | Attribute | Text [ Status | Last modfied |
q_, PAYROLLC CBLLE  SRC with syntax & verify errors oK December ...
CoPaYROLLCZ  CBLLE  SRC with verify errors oK December ...
GUF'F\\"ROLLD CBLLE SRC no errors QK July 17, 20...
4 i
-
Command |Narmd LI |chgcurib rselabicx| j Frompt. .. | Run |
Messages | :] Detalis | Show Log |

1. Click the iSeries Table View tab from the views at the bottom of the
workbench.

2. In the Command field type, CHGCURLIB RSELABxx for example.

Note: Use a library that is on your iSeries system.
3. Click Run.
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If you haven’t used the iSeries Table view to show iSeries objects in this view
you will see an error message because the iSeries Table view is not linked to an

active connection.
If you see this message, click OK.
a. In the Remote Systems view, right-click QCBLLESRC.

£ | Refresh
Exparid i
Collapse -

C [ Rename. ..
.8

P |i=| Copy
.0 - Paste
Eige «}+ Mave..,

EF‘E % Delete...

EIRESR |

1e File Descriptions

b. Click Show in Table on the pop-up menu.
The iSeries Table view is now populated with the member in the selected
source file.

¢. Run the CHGCURLIB command again.

The command will run on the iSeries and after completion you will see the
completion message on the bottom of the iSeries Table view.

iSeries Commands Log Ml e e " Ry T o & o i
File RSELABXY/QCBLLESRC (3 Members)
Name [ Type | Attribute | Text | st | Last modified |
q’_]EPM"ROLLC CBLLE  SRC with syntax & verify errors oK December ...
CoPaYROLLCZ  CBLLE  SRC with verify errors oK December ...
%PF\\"ROLLD CBLLE SRC no errors QK July 17, 20..,
14| | 2l
-
Command |N0rmd :_l | j Frompt,.. | Rurn |
Messages ]Current library changed to RSELABKX. ;I Details. .. | Show Log |

4. Back in the workbench in the Remote Systems view, right-click Library list and
click Refresh.
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1]

i
4

3l _& New Connection
#-E Local
=B s400a
- @ iSeties Objects
[+ 1‘; ‘Whork with libraries. ..
& 12 Work with objects. ..
-4 Work with members. ..
~l, ae————
o y I

|»

[-m), Q5YS52924.*lib.prod-sys
[+-m, QSYS.*lib.prod-sys

[ B, Q5Y52.%lib.prod-sys
[#-m, QHLPSYS, *lib.prod-sys

[+ [# CLR1,*pgm.clle
[ [ MYCOMPILE, *pgm.clle
&[4 PAYROLL.*pgrm.rpgle LI

5. You will see a small green asterisk beside the RSELABxx library to indicate it as
your current library.

6. You can also connect to other than iSeries systems with the Remote System
Explorer and launch commands for these systems as well, for example, your
local system, or Linux .

You have submitted a command to change the current library in the command line
of the iSeries Table view now you are ready to begin [‘Exercise 4.4: Running]
fcommands and programs.”|

Exercise 4.4: Running commands and programs

Before you begin, you must complete [“Exercise 4.3: Submitting iSeries commands|
[in the iSeries Table view” on page 61|

As you know already, you can run programs and commands from the Remote
Systems view or the iSeries Table view in three ways:

1. In the Remote System Explorer communications server job.

This is the one you are using currently.
2. In a batch job.

3. In an interactive job (to test 5250 applications).
4. In a server job

Using the first option lets you run the program in the same job as the
communications server. With batch and interactive jobs, you cannot monitor the
status as easily, however, you do not tie up your communications server and you
are notified when the program command ends. Batch jobs work as you would
expect and do not require any initial setup. Interactive programs require a 5250
emulator, and you need to first run a STRRSESVR connectionName command to
associate the emulator with a particular connection in the Remote System Explorer
communications server. A multi-threaded debug session creates a new server job
and this way keeps the RSE communications server job free for other tasks.

Starting an interactive connection
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To start an interactive connection:
1. Start a 5250-emulation session.

2. Sign-on to the iSeries with your User ID and password.

Note: Instead of the Enter key, you may have to use the Ctrl key in your
5250-emulation session.

=¥ Session A - [24 x 80] =18] x|
File Edit Yiew Communication Actions indow  Help

B DD 2% BlE &) 5% M| 5] @

AN B Main Menu

(! 1
2} 1902 - Session successfully started

3. In the command line, type the command
STRRSESVR connectionName
4. Press Enter.

The connectionName parameter is the name of your connection defined in the
Remote Systems view. This associates the interactive job with the Remote
System Explorer communications server.

Running the payroll program

Now you are ready to run the program that you just compiled.

Return to the workbench.

To run the program:
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Team| = O|f Aeavrow., 22 B|[EEo.. B = H0
& 05 v ‘ Line 448 C| (55
| B
| - [£] MYCOMPILE, *par ~ | | Sl | oevtricaionc
- [F] PAYROLL *pam.rc 000437 2|l @ EMvIRONMENT DIV|
%)~ [E] AAnAD0 || B DATA DIVISION,
&-[F] PAYROLLD.  GeTo 7 || B PROCEDURE DIVIS |
- [F] PAYROLLG. —
B COMPARE A o5 Show in Table i
#-[F EMPMST. i T
+-[F EVFEVENT A frainach)
@69 mstosp+fl Expand + [fEC F
e | ollapse T
-6 MsTDSPZ. ¥ o
& PROMST il
-1l QCBLLESRC L Rename...
@y PAYROL = Copy [IE F
@ PAYROL B Foste :
Oy PAYROL vl
QCLSRC.*i i+ Move... ] |
QEMDSRC. 3¢ Delete... ograr o
QDDSSRC,* , o
Oy EMPMS]  Update... - ,._!_f |
B MSTDSF Change... 82 "\ Remote ...| 1 ]
B PRIMST  cave _ - -
Oy REFMST oo Shjetss -
- - RSNMST S
Kl User Actions r B |
= | e i |
~ ) = » e e
I Properties £3 . Remote Scra,. 0 iseries application in RSE Job
* = Run{Prompt){E) L4 % Batch
| B 5 Debug(Service Ertry) P
Property I Walue Debug As(F) » =
Attribute CBLLE Debug (Prompt)() b [k Multi-threaded
Marne PAYROLLE z | Li I
Murrber of children 0 Properties(K) ;
1. In the Remote Systems view, locate the PAYROLLC2 program that you

created.

2. Right-click the PAYROLLC2 program.
3. Click Run As > Interactive on the pop-up menu.
4. Switch to your 5250-emulation session.

You will see the payroll program menu.

ession A - [24 x 80]

File Edit Wiew Communication Actions ‘Window Help

B DD 2% BlE b &%)

2?3 @

=10/ x|

5. Type x beside Employee Master Maintenance.
6. Press Enter.
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10.
11.
12.
13.
14.

Type 234 for the Employee Number.

Type A for the Action Code to add employee 234.

Press Enter.

Type any information you like about the employee.

Press Enter.

Play in the application as much as you like.

Press F3 to end the applications.

To get control of the interactive job, right-click iSeries Objects and click
Release Interactive Job on the pop-up menu.

You can also choose to disconnect a session. You would right-click the
connection and click Disconnect on the pop-up menu.

Now you are ready to review your knowledge of this module by taking the quiz.
You can also apply what you have learned in this module by completing the
practice tasks detailed in More practice.

Quiz

1.

The tool checks for semantic (compile) errors on your workstation so
that you can guarantee a clean compile on the iSeries.

a. Compile

b. LPEX Editor

c. Program Generator
d. Program Verifier

The view identifies each error with the severity level of the error,
the ID of the error, the message, the severity, the line in the source member that
caused the error, the location of the source member that produced the error,
and the connection name.

a. Remote Systems

b. Outline

c. Navigator

d. iSeries Error List

You can sort the entries in the iSeries Error List view by:

a. ID

b. Message
c. Severity
d. Line

e. Location

f. Connection
g. All of the above

If you used the local program verifier, then your host compiles should be
successful; no wasted iSeries cycles. (T, F)

A compile command can be run on an iSeries server from the Remote System
Explorer, and you can retrieve error feedback from the compile. (T, F)

From the iSeries Table view you can:
a. List and sort libraries, objects, and members

b. Copy, rename, delete, edit, compile and run (for programs), open with and
browse (for members) in the view from the pop-up menu

c. Transfer files from one system to another
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d. All of the above

7. You can run programs and commands from the Remote Systems view or the
iSeries Table view in:

A Remote System Explorer communications server job
A batch job

An interactive job

Multi-threaded

All of the above

8. Interactive programs require a 5250 emulator, and you need to first run a
STRRSESVR connectionName command to associate the emulator with a
particular connection in the Remote System Explorer. (T, F)

© o0 oo

More practice

Given your experience using the Program Verifier and Compile command, and that
you have your own source on your own iSeries system, try these new tasks: Check
out Compile (Prompt) Work with Compile commands. Assuming you receive
errors in your source (add some errors into your source if you don’t have any)
when you verify your source, choose insert all error messages into the editor from
the Error list. Use the product online help to assist you in these tasks.

Module recap

You have completed [Chapter 4, “Module 4. Verifying and compiling source,” on|
page 55.| You have learned how to:

¢ Check for semantic errors on your workstation

* Start the Program Verifier tool

* Use the iSeries Error list to locate each error in the source

» Use content-assist to fix an error

* Save your source

¢ Re-verify source

¢ Change compile preferences

* Invoke the compile command

* Change the current library using the Command field in the iSeries Table view
* Start an interactive connection

* Invoke the payroll program

Now that you know how to verify and compile source from the Remote Systems
view and run the payroll program interactively, you can move onto debugging

our payroll program. Continue to [Chapter 5, “Module 5. Debugging a program,”|
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Chapter 5. Module 5. Debugging a program

This module teaches you how to debug a CL and ILE COBOL program.

You will learn how to start the debugger, set breakpoints, monitor variables, run
and step into a program, view the call stack in the Debug view, remove a
breakpoint, add a storage monitor, and set Watch breakpoints and all from the
Debug perspective.

In this module, you will:

* Invoke the debugger from the Launch Configurations window
e Add a breakpoint

* Add a conditional breakpoint

* Edit a breakpoint

* Monitor a variable through the Monitors view
 Step into your payroll program

* Show a Listing view

e List the call stack entries in the Debug view

* View all breakpoints

* Remove a breakpoint

* Monitor storage

* Set a Watch breakpoint

* Close the debugger

Exercises

The exercises within this module must be completed in order:

* [“Exercise 5.1: Introducing the Integrated iSeries Debugger” on page 70|

* |“Exercise 5.2: Starting the integrated debugger” on page 70|

* |“Exercise 5.3: Setting breakpoints” on page 75|

* [“Exercise 5.4: Monitoring variables” on page 78|

* |“Exercise 5.5: Stepping into a program” on page 84|

* [“Exercise 5.6: Listing call stack entries” on page 86|

* [“Exercise 5.7: Setting breakpoints in PAYROLLD” on page 87]

* |“Exercise 5.8: Removing a breakpoint in PAYROLLD” on page 8§
* [“Exercise 5.9: Monitoring variables in PAYROLLD” on page 90|

* [“Exercise 5.10: Adding a memory monitor” on page 91|

* |“Exercise 5.11: Setting Watch breakpoints” on page 93|

* [“Exercise 5.12: Closing the debug session” on page 96|

Time required

This module will take approximately 30 minutes to complete.
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Exercise 5.1: Introducing the Integrated iSeries Debugger

The Integrated iSeries Debugger is a source-level debugger that enables you to
debug and test an application that is running on an iSeries system. It provides a
functionally rich interactive graphical interface that allows you to:

* View source code or compiler listings, while the program is running on the
iSeries system.

* Set, change, delete, enable and disable line breakpoints in the application
program. You can easily manage all your breakpoints using the Breakpoints
view.

* Set Watch breakpoints to make the program stop whenever a specified variable
changes.

e View the call stack of your program in the Debug view. As you debug, the call
stack gets updated dynamically. You can view the source of any debug program
by clicking on its call stack entry.

* Step through your code one line at a time.
* Step into or step over program calls and ILE procedure calls.

* Display a variable and its value in the Monitors view. The value can easily be
changed to see the effect on the program’s execution.

* Locate procedure calls in a large program quickly and easily using the
Modules/Programs view.

* Debug multi-threaded applications, maintaining separate stacks for each thread
with the ability to enable and disable any individual thread.

* Load source from the workstation instead of the iSeries — useful if you don’t
want the source code on a production machine.

* Debug client/server and distributed applications.

The Debugger supports RPG/400® and ILE RPG, COBOL and ILE COBOL, C, C++
and CL.

In the following exercises you will be given the opportunity to learn about some of
the basic features of the Debugger. For the purpose of these exercises you will
debug a CL and an ILE RPG program. Don’t worry if you don’t know RPG.

You know the basic features of the debugger and now you are ready to begin
[“Exercise 5.2: Starting the integrated debugger.”|

Exercise 5.2: Starting the integrated debugger

Before you begin, you must complete [“Exercise 5.1: Introducing the Integrated|
[iSeries Debugger.”|

You will be working with the COBOL program PAYROLLD.

Note: PAYROLLD is the same COBOL program as PAYROLLC2 but without
compile errors. You are using it instead of PAYROLLC2 in this exercise, to
accommodate anyone who decided to skip right to this exercise without
completing the exercises in [Chapter 4, “Module 4. Verifying and compiling]
lsource,” on page 55/

You can start the Debugger in several ways: directly from the pop-up menu of a
program or service program in the Remote Systems view, or from a Launch
Configurations window. Starting directly from the Remote Systems view doesn’t
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allow you to specify parameters to be passed to the program. The Launch

Configurations window allows you to modify how the program is invoked and to
specify parameters.

To make the exercise interesting you will use CL program CLC1 to call PAYROLLD
and you will pass one parameter to CLCI.

This means you will use the Launch Configurations window.

To start the debugger:
1. In the Remote Systems view expand the Library list filter, if it isn't expanded
already.

@& Remote System Explorer - PAYROLLC.CBLLE

File Edt Source Complle Mavigate Search Pr

| |3 -0 ~Q -
| A= ~ Bk 1 New_configuration
| ; Debug &z L4

Organigavorles. '

@E, Q5VS2.Hlb.prod-sys o |
. B QHLPSYS *ib.prod-sys
[#-Ey, QUSRSYS. *lib.prod-sys
- E, WSSLABKY. b prad-usr J
 [=-m, RSELABXX, *lib. prod-usr
SR I CL. *pom.cle
[ CLR1 *pam.cle
[+ [5] MYCOMPILE. *pam.cllz
PAYROLL *pam.rpgle
- [ PAYROLLCZ, *parn. chlle

—_.

Expand library RSELABXx, if it isn't expanded already.
Select program CLC1 in library RSELABxx.

Click the arrow beside the DEBUG icon ﬁj on the workbench toolbar.
Select Debug from the list.

ok DN

The Debug Launch Configurations window opens.

6. Select iSeries: Debug Interactive Application under the Configurations list.
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Create, manage, and run configurations

A

Caonfigurations:

~|z% Apache Tomcat
5 Attach to a Running Pre
- f& Compiled Application
B Host Java application
~“ds HTML Seript Application
-3 iSeries: Debug Batch Ap
bug Interact

- % i5eties: Debug Job
[3¢ iseries: Debug Multi-Thr
37 Java and Mixed Langua
-] Java applet
3] Java Application
B 3ava application in iseri
:15 Java Bean
Ju JUnit
- rL‘: Remote Java Application
“#% Script Host Application
- 155 websphere v5.0 Applic.
% websphere v5.1 Applic,
15 Websphere v6.0 Applic.

] Perspectives

These settings associate a perspective with iSeries: Debug Interactive Application
launch configurations, & different perspective may be associated with each supported
launch mode, and can optionally be activated when a configuration is launched or
when a breakpoint is encountered via the Debug preferences. To indicate that a
perspective switch should not occur, select "Mone".

|Debug LI

Debug:

Restore Defaults |

KN I 2l
New I Oolete I Aoy I Revert I
Debug Close |
7. Click New.

Note: You could also use Debug(prompt) > Interactive from the pop-up

menu.

The right pane of the Debug Launch Configurations window opens.

Nama:®

‘What To Debug I | % Sowce|  Advanced | T Common |

Connection: Is4DUa

x| mew.., |

Programs to be debugged.
The checked program or service program will be used as initial debug object.
Library | Program | Type | Add... |
RSELABKY et *PGM [k = |
L
Remaye |
[V Step into

¥ Terminate debug session on program completion

®Jp-date production files

Apply I Revert

8. In the Name field, type the program name CLC1.
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9. Select the Update production files check box.
10. Click the How To Start tab.
The How To Start page opens.

Name: | CLC1

What To Debug How To Start | % sowee|  Advanced| =« ]

Command ko start application:
CALL PGM{RSELABEXCLCL) =]

{ Prompt..., I
g

N Apply | Revert I

By default, the page contains a call for the program selected in the Remote
Systems view.

11. Click Prompt.
The Call Program (CALL) window opens.

@& call Program (CALL) x|
Program: > |CLCL Name
Library: > | RSELABXR :J Mame
Parameters: ( 'xx') ;I add
I™ tdvanced [~ &l Parameters I™ Keywords
CALL PGM{RSELABXX/CLCT) PARM{EX) |
L4 OE} I R&sboredefa.lltsl Cancel I

12. In the Parameters field, type 'XX' where "XX’ is your workstation number.
Click Add.

The parameter value will appear in the lower list.

If you forget to click Add, the parameter will be missing from the CALL
program command and you will receive an error when the program tries to
call the payroll program.

13. Click OK.

The complete start command for the program appears.

Chapter 5. Module 5. Debugging a program 73



x

Create, manage, and run configurations

Configurations: Name: |CLC1
|2k Apache Tomcat
& Attachto a Running Prc § —
[, Compiled Application wihat To Debug How To Start I £ Source | Advanced I 1 Common ]
- 1{ Host Java application
&% HTML Script Application c S by st e Aeak

~[5¢ iSeries: Debug Batch Af - :
= Q: iSeries: Debug Interacti +~ALL PGM{RSELABXK/CLCL) PARM(:X) ;I

"B New_configuration

- ‘& iSeries: Debug Job I
[ iSeries: Debug Multi-Thr
- [3% Java and Mixed Langua
— i Java Applet
3 Java Application
[ 2ava application in iSeri
|48 JavaBean

Ju Junit ;|
-2, Remote Java Application

‘A Script Host Application Prompt. .. |
- iy websphere v5.0 applic.

(55 webSphere v5.1 Applic.

Iﬁ ‘WebSphere vé.0 Applic.

ine—— N

New | oDeete | aply | revert |

14. Click Debug.
The Debug perspective opens.
If not, you may see this error message.

@& EVFC50011 x|

@ Mo interactive job associated with this connection. Associate an interactive

job with this connection ko continue.
[ cawel | <<Detais |

# request to run an interactive command or program was recelved for the RSE ;]
connection s400a, but no interactive job is currently associated with this connection,
To associate an interactive job with this connection:
1. Open a 5250 emulator,
2. Runthe CL command STRRSESVR MAME(s400a)
3, This will associate the interactive job with this connection, causing this
dailog to close and your interactive command or program to run, ;l

I

The Remote System Explorer communications server has been shut down in
the meantime. Go to your 5250 emulator and restart the Remote System
Explorer communications server following the instructions in the message.
You don’t have to cancel the message. It will be removed as soon as the
connection between the Remote System Explorer communications server and
the interactive session has been established. Now the Debug perspective is
loaded in the workbench.

Now that the program is active on the iSeries and stopped at the first
executable statement, the debugger displays the source.
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@i Debug - CLC1.CLLE - IBM Rational Software Development Platform B -10] x|

Fil= Edit Source Comple MNavigate Search Project Run  ‘Window Help

It5e . @ |35-0-2-Q- | & 75 | #5Debug

J*n S | | & & | A ¥ 8 By THRemote Systs...

%% Debug 52N Sarvers[ S ) (variables (eo Breakpo... 52 Raglstersi = ='m
- X E@e Bl -

| = “| e [ 4|

ﬂ CLC1 [iSeties: Debug Interactive Application] &
= Gﬁ State: <stopped> Connection: iSeries(TM) (*
=5 Thread:1 (stopped)
- Bl ELELCLE]
= _CL_PEP:CLCH:CLCH
= QCMDEXC : OCMDEXIC : QCMDExc_r:I
»

<

(frawo... | Srawrois..,  [TERETED. B[Sz outine 82\ =6
Line 1 Column 1 Replace An outline is not available,
QB3
» 000100 - DGM BARM (&num) =
000200 DCL VAR (&num) !
000300 del &name *cha
gop4o00 del &lib *char
0oosoo DCL VAR (&count
00o0&s00 CHGVAR VAR (&NAME)
000700 LOOP: chgvar var (&count -
| | »|
|
Console | Tasks | iSeries Commands Log fﬁ Memory &2 . + % | v =0

You have started an interactive debug session and now you are ready to begin
[“Exercise 5.3: Setting breakpoints.”]

Exercise 5.3: Setting breakpoints

Before you begin, you must complete |“Exercise 5.2: Starting the integrated|
[debugger” on page 70

You can only set breakpoints at executable lines. All executable lines are displayed
in blue. One way to set a breakpoint is to right-click on the line in the Source view.

To set a breakpoint:
1. Position the cursor on line 11.
2. Right-click anywhere on line 11.
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= !
File Edit Source Compile Mavigate Search Proje Selected :
I L =) I F-D-Q-q - ] Deselect At
] e e Filter view »
] | B s p» | A ‘fé‘ _E[ E‘Iﬁé Show &l CEFI
[ A PAYROLLC2.CBLLE | // PRNROLLC. CBLLE E Source p
Line 11 Column 1 b 2
_ 75 Add ko Snippets. .,
0oolo0  BGM e
000zoo DCL
_— Show Dake A
000300 dcl ol i
000400 dcl W
oooson DCL Add Watch Breaadoint...
0o00eno CHGVAR fun To Lacation
000700 LOOP: chgvar
ooogeoon if (&cc Monitar Expression
000900 CHGVAR patlendie i X
001000 chgvar Swiikch View »
oo11o00 CALL TGN (& 1157 PAYROLLD)
001200
001300 ENDPGM

3. Click Add breakpoint on the pop-up menu.

A dot with a checkmark in the prefix area indicates that a breakpoint has been
set for that line. The prefix area is the small grey margin to the left of the
source lines.

Now you add a conditional breakpoint to stop in the loop when it loops the
99th time.

Adding a conditional breakpoint

To add a conditional breakpoint:

1. Position the cursor on line 8.

2. Right-click on line 8.

3. Click Add breakpoint on the pop-up menu.

JPAROLC2CBUE | ZPavROLC.COUE  [DATENIED, /WSO OsE | & |
Line 8 Column 2 Replace ]
000100 DGM 5 a) _
oopzo0 DCL VAR (&num) TYPE (*char
ooo0300 del &name *char 10
gop4o00 del &lib *char 10
0ooso00 DCL VAR (&count) TYPE (*DE
000600 CHGVAR VAR (&NAME) WVALUE ("C1l
000700 LOOP: chgvar var (ecount) value (&<

»oo0s00 | if (scount *1t 100) then(goto 1
000900 CHGVAR VAR (&NAME) VALUE ('Cl
golo000 chgvar var (&lib) wvalue ("RSE

A2 001100 CALL PGM (&1ik/ PAYROLLD)
gol1zoo
001300 ENDEGM

4. Click the Breakpoints tab in the upper right pane of the Debug perspective.
The Breakpoints view opens.
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Variables

RN TR el S S Registers | Memory Rendering

[4 .2 Line [CLC1.CLLE:11]

M»
= GO to File

Add Breakpoint ¥

Select All
M Enztie
|| Disable
¥ Remove
“5¢ Remove Al

5. In the Breakpoints view right-click the breakpoint for line 8.
6. Click Edit Breakpoint on the pop-up menu.

The Edit a Line Breakpoint window opens.

@ Edit a Line Breakpuintk x|

Required information

Sets a breakpoint to stop execution at a specific source line

Executable (Optional)
[l

Object (Optional)

I

Source;

|cLet.cue

Line:

e

< Bach | Finish I Cancel

7. Click Next.
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@& Edit a Line Breakpoint x|

Optional parameters

Make the breakpoint conditional upon the Following parameters

—Frequency

From:

To: | Infinity

Every: | 1

Expression: |

< Back I Mext = '@‘ Cancel I

You only want to stop in the loop when it executes for the 99th time or more.
You can do that by setting the From field of the Frequency group to 99.

8. Under Frequency in the From field, type 99.
9. Click Finish.

You have added a breakpoint including a conditional breakpoint to your source
and now you are ready to begin [“Exercise 5.4: Monitoring variables.”|

Exercise 5.4: Monitoring variables

Before you begin, you must complete [“Exercise 5.3: Setting breakpoints” on page|

You can monitor variables in the Monitors view. Now you will monitor the
variable &count.

To monitor a variable:
1. In the Source view, double-click the variable &count.
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3 Pl |
File Edit Source Comp Help
. Select L4 .
|09 -5 @ |35 seected b0 H
[= e = 7 Deselect A+ CE
35 Debug 52 . Servers Filter view ¥ | Breakp
Shiowal G|+ B
Source g
RS =FC
O = | Yiew r
IS :n
s | = . 5 Add to Snippets. ..
: = ac
i = n.c SEYE
<
Add Breakpoint =
f MSTDSP.DSPF Ii Ad\:IWabdk'lpo Breskpoint... 0
T LR
000400 N Al
000500 Mokt Memety i)
000600 Switch Yiew L
000700°: ChgVar TETIESa) -
J | '

2. Right-click &count.

3. Click Monitor Expression on the pop-up menu.

The Monitors view opens.

LB &

The variable appears in the Monitors v

iew. Its current value is zero.

Tip: If you quickly want to see the value of a variable without adding it to the

Monitor, leaving the mouse pointer on
display its value in a pop-up window.

a variable for a second or so will

Now that some breakpoints are set, you can start to run the application.

[ oeua > NEZTEH &5
-
EX-F IR
3
_CQL_PEP: CLC1 1 QLCL

QCMDEXC ; QCMDEXC ; QCMDEXC

L= main : QRSEMAIN : RSEMAIN

4

o

executeCommand : QRSEMAIN @ RSEMY

s
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4. Click the Resume “# icon from the Debug toolbar.

The program starts running and stops at the breakpoint at line 8. (Be patient,
the Debugger has to stop 98 times but because of the condition continues to
run until the 99th time.) Notice in the Monitors view, that &count now has the
value 99.

5. Click the Resume icon again.

The program stops at the breakpoint at line 8 again and &count now has the
value 100.

6. Click the Resume icon once more so that the program runs to the breakpoint at
line 11.

If you do not see the error message below, go to [“Exercise 5.5: Stepping into a|
[program” on page 84|

Error Handling

If you forget to add the parameter to the CALL program command when you
debug the program, you will see this error message.

& Debugger Message x|
/=" Program received unmonitored exception MCH3601: Painter not set For
location referenced.
a. Click OK.

b. Click the Terminate 1‘ icon on the Debug toolbar.

The debug session terminates on the workstation but the exception waits for
input from the 5250 emulation session.

If you closed the Debug view by mistake, you will need to re-open the
Debug view and then terminate the debug session on the workstation.
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-injx]
Fil= Edit Source Comple MNavigate Search Project Run  ‘Window Help
[t5e %0 -~ &5  mfBowe
I‘ = m EHRremate Syste. .,
| | = o> | A% R B
4k Servers 22 =l EB%‘WEIM & ==
< RO + R XG0 ||
Server e B . COUNT = 00100
4 | 3|
r‘ N7 ™
FPAYROLL... |/PMRDLL... r/CLCL.CLLEEE N I MsTD.... |E g2 \ 70
Line 10 Column 1 Replace An outling is
B e e e it
000&00 CHGVAR VAR (&MAME) =]
000700 LOOP: chgvar var (&count’
2000800 if (scount *1t 100) tl]
000900 CHGVAR VAR (& )
golo0o00 e : -
4 |
|
f g N
Console|Tasks|I59rias-CnmmmdsLog rﬂ Memary 23\\\_ - K I w0
I |

Click Window > Show View > Debug.

& Debug - CLC1.CLLE - IBM Rational Software Development Platiorm [ i

File Edit Source Compile MNavigate Search Project Run IWindcm Help

(T3 [l SGer Qe Quetl - | 1 e Wi
J S = @ = 1, . Open Perspective
R N‘t
4 servers &3 * _ I
95 Breakpoints Customize Perspective. ..
(T
Server Reset Perspective
851 webSphere #5-Debug Close Perspective
Debug Console Close All Perspectives
1J, Display Mavigation
4] " Expressions
= Preferences
=] AL

Remember to terminate the Debug view if you haven’t done so already.

Go to your 5250 emulator and press Enter until the program messages
complete and the Remote System Explorer communications server screen

appears again.
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—ioi x

File Edit ‘Yiew Communication Actions ‘Window Help

D 2% B =6 % & 9] @l

SPLFILE (*NO

| 1902 - Sessian successfully started 7

d. In the workbench, click the Remove all terminated launches icon on the
Debug toolbar to clean up the Debug view.

i = | ¢ & (=EF-}
MSamm! " G (DT | 89 | s .

rminated> CLC1 [[Series: Debug Interactive Appication]
@i State: <engine terminated= Connection: iSeties(TM) (TORAS1CE: 1044);
<terminated> Process: S89773/STECKHAM/QPADEVDOOT Program: null

[

e. Click the arrow beside the Debug icon on the workbench toolbar to start a
new debug session.

f. Select Debug from the list.

@i Debug - CLC1.CLLE - IBM Rational Softwar|
File Edit Source Compile MNavigate Search

- [%5 -0 -Q:-Q ~
| Sl * Briact
| *l By 2R

Debug \ _S_I Debug As »

Organize Favurlg. -

The Debug Launch Configurations window opens.
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g. Click the How To Start tab.
The How To Start page opens.

By default, the page contains a call for the program selected in the Remote
Systems view.

h. Click Prompt.
The Call Program (CALL) window opens.
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& Call Program (CALL) x|
Program: > |CLCL Name
Library: > | RSELABXX ;] Name
Parameters: ( 'xx') :I add
[”| advanced [~ &l Parameters [~ Keywords
CALL PGM{RSELABXX/CLCT) PARM{EX) |
@ I R&sboredefa.lltsl Cancel I

i. In the Parameters field, type 'XX' where XX’ is your workstation number.
Click Add.

The parameter value will appear in the lower list.
j. Click OK.
k. Click Debug.
If you did not terminate the debug session, you will see this error message.

_ x|

Q Host: CPF3801 Job s already being serviced, traced, or debuaged.

Complete the steps shown earlier in the section called Error Handling to
terminate the debug session then start the debug session again by clicking
the arrow beside the Debug icon on the workbench toolbar and selecting
CLC1 from the list. Breakpoints and monitors are restored.

You have monitored the variable &count and now you are ready to begin
[5.5: Stepping into a program.”|

Exercise 5.5: Stepping into a program

Before you begin, you must complete [“Exercise 5.4: Monitoring variables” on page]

The Debugger allows you to step over a program call or step into it. When you
step over a program call, the called program runs and the Debugger stops at the
next executable statement in the calling program. You are going to step into the
PAYROLLG program.

To step into a program:
1. Click the Step into icon on the Debug toolbar.
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Servers ] = El]

The source of PAYROLLD is displayed. Depending on the option you used to
compile the program (*SRCDBG or *LSTDBG for RPG, or *SOURCE, *LIST, or
*ALL for ILE RPG), this window displays either the Source or Listing View.

If you specified an incorrect parameter for the CALL program command, you
will see this error message.

@i Debugger Message x|
N
/ i Program received unmonitored exception CPFO001: Error found on CALL
command,

=]

Complete the same steps as covered in the section called Error Handling in
[“Exercise 5.4: Monitoring variables” on page 78

2. Right-click anywhere in the Source view and click Switch view > Show
*LISTING on the pop-up menu.

JPAYROLC.CBLE | FcLct.cUE M/MSTDSP.DSPF | &)
Line 178 Column 42 Replace Bros

000159 SET IND-OFF (IND-ERRCOR) TO TRUE. :I
00160 INITIALIZE METDSP-REC.
000161 S = | _
0oolez2 Syntax checklLine Selection until e1
0oole3
000164 o Chritx DCESS-MAIN THRU 011
000165 Copy Chrl+Insert :ND_EOJ) ;
000166 Paste Chrl+Y, J
000167 Select » FFILE
0Doo0les Selected » FFILE
000169 [Deselect Al 'FILE
000170 " , [FILE.
000171 Shiow all ChrlH4Y
popol72
000173 Source 4
0oo174 View *
000175 [Add to Snippets. .
000176 Sl ]
000177 Save e Belection screel
000178 Add Watch Breakpaint. . .
000178 T FORMAT IS '"SELECT
0po180 Monitor Expression INDICATORE ARE TII
00018l Manitor Memory »
ooolsz Swikch View [ v Show *SOURCE
000183 M BLECT_
o ( __Show *STATEMENT LlJ
|

3. Page down in the source and take a look at the expanded file descriptions.
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You don’t have any /Copy member in your PAYROLLD program but these
would also be shown in a Listing view. Switch back to the Source view.

4. Right-click anywhere in the Source view.
5. Click Switch view > Show *SOURCE on the pop-up menu.

You have stepped into PAYROLLD program, switched the view from source to
listing and back to source and now you are ready to begin [“Exercise 5.6: Listing]|
[call stack entries.”]

Exercise 5.6: Listing call stack entries

Before iou begin, you must complete [“Exercise 5.5: Stepping into a program” on|

The Debug view in the upper left pane, lists all call stack entries. It contains a tree
view for each thread. The thread can be expanded to show every program,
module, and procedure that is on the stack at the current execution point. If you
double-click on a stack entry you will display the corresponding source if it is
available. Otherwise the message No Debug data available appears in the Source
view.

In the Debug view, expand the stack entry of Thread1 if it is not expanded already.

M&Wars! P> DB RF

B ﬁk CLC1 [iSeries: Debug Interactive Application]
El I_@ State: <stopped> Connection: iSeries{TM) (toras1ch: 1044)
=4 Thread:1 {stopped)
=804 YROLL : PAYROLLD : PAYROLLD
: _Qln_pep : PAYROLLD : PAYROLLD
e CLCL : CLCE : CLCY
- _CL_PEP ! CLC1: CLCH
= QCMDEXC : QUMDEXC : QCMDEXC
: executeCommand | QRSEMAIN : RSEMAIN

|,£‘f’|iﬁ. v =8

main : QRSEMAIN : RSEMALIN
= _C_pep : QRSEMAIN : RSEMAIN

QUICMD : QUICMD : QUICMD
QUIMGFLW : QUIMGFLW : QUIMGFL'W
e QUIMNDRY : QUIMNDRY : QUIMNDRY
oo QUICMENU @ QUICMENU @ QUICMENU
; C = QCMD : QCMD : QCMD
g Process: 590774/STECKHAM/QPADEYODOD Program: CLCI
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The stack entry allows you to work with and switch between different programs
and/or ILE modules.

You have viewed the call stack entries of your program and now you are ready to
begin [“Exercise 5.7: Setting breakpoints in PAYROLLD.”|

Exercise 5.7: Setting breakpoints in PAYROLLD
Before iou begin, you must complete [“Exercise 5.6: Listing call stack entries” on|

Now you add some breakpoints in PAYROLLD.

To add breakpoints:

1. Select PAYROLLD in Thread1.

2. In the source view (also called the iSeries default editor) scroll to line 201.
3. Double-click the prefix area of line 201.

A breakpoint icon is added to the prefix area of this line to indicate that a
breakpoint is set.

4. Repeat the above step for line 206.

./ PAYROLLD CELLE X g
Line 206 Column 1 Replace Browse
B-——+-*A-1-B——+----2-———4-—---3-———t-————4-———4-——-5-
000198 * 0500-RSNMST-SELECT. I |
0ooi1ss
ooozoo IF IND-OFF (IND-ERROR)
2000201 IF (EMPAPL OF SELECT-I = "X")
npopzoz INITIALIZE EMPSEL-O
0oozo3 PERFORM 0300-EMPMST-SELECT THR
oooz04 UNTIL IND-ON(IND-MAINT) OR II
000205 ELSE
£ 000206 IF (PRJAPL OF SELECT-I = "X")
0o0oz07 INITIALIZE PRJSEL-0O _J
000208 PERFORM 0400-PRJMST-SELECT
ooozog UNTIL IND-ON(IND-MAINT)
oooz1io ELSE
oooz211 INITIALIZE RSNSEL-0O
opoziz PERFORM 0500-RENMST-SELECT
0ppz213 UNTIL IND-ON(IND-MAINT)
000214 END-IF
ooozis END-IF
0ooz1e END-IF.
000217
2000218 IF IND-ON (IND-MAINT)
oooz1ge SET IND-OFF (IND-ERROR) TO TRUE
ooozzo INITIALIZE MSTDSP-REC
000221 END-IF.
0pnz22z2
0nn223 0100-EXIT.
000224 EXIT.
ooozzs
«| | Ll_l
|

5. Repeat the above step for line 218.
To view all breakpoints, select the Breakpoints tab from the top left pane.
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Variables | Registers | Memary Rendering M\Wtors | Programs| =g

RE>G W[~

[ .2 CLC1.CLLE [line: 8]

[ .2 PAYROLLD,CBLLE [line: 201]
[ 2 PAVROLLD, CBLLE [line: 206]
[ .2 PAYROLLD.CBLLE [line: 218]

R

This view shows all breakpoints currently set in your Debug session. This is a
convenient place to work with breakpoints. You can remove, disable/enable,
add, or edit a breakpoint. These tasks are available from the pop-up menu
when you right-click in the view area. Double-click any entry to show the
source where the breakpoint is set.

You have added several breakpoints to PAYROLLD and now you are ready to
begin [“Exercise 5.8: Removing a breakpoint in PAYROLLD.”]

Exercise 5.8: Removing a breakpoint in PAYROLLD

Before you begin, you must complete [“Exercise 5.7: Setting breakpoints in|
[PAYROLLD” on page 87

It is also easy to remove breakpoints from the Source view.

To remove a breakpoint:
1. Right-click the prefix area of line 206.
2. Click Remove Breakpoint on the pop-up menu.
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[#eavroc.cele | Facr.cue pAYROLLD, CELI // MSTDSP DSPF =
| 1ine 218 Column 1 Replace Bros
I———-i-—*A—1—B——+-———2—-——+————3— + 4 +
000205 ELSE A
2000206 Tm fnnTApl, OF SELECT-I = '3 |
000207 Srompt _ bt 'TALIZE PRJISEL-0O
000208 S AR FORM 0400-PRIMET-SE]
pop209 ( NTIL IND-ON (IND-MATL
poo210 ritinsett
oooz211 Faste Sl TTALIZE RSNSEL-0O
000212 o » FORM 0500-RSNMST-SE] |
000213 TRy » NTIL IND-ON (IND-MAIL_|
000214 S
poo21s
000216 Filter view 3
000217 e
2000218 Source » MATHNT)
pooz219 Wigw » (IND-ERROR) TO TRUE
000220 : MSTDSE-REC
non221 {2 Add to Snippets. ..
popzz22
000223
000224 Edit Breakpoint...
g g ggg‘z Disable Braakpoint !
Add Watch Breakpoint. ..
000227 PTION.
oon2ese Run To Location
0op229 Monitor Expression - display fields ‘:m-.vi
‘i Monitor Memory » L'_, [
Swikch Yiew »

—

The icon is removed from the prefix area indicating that no breakpoint is set on

that line.
Now you are ready to run the PAYROLLD program.

Click the Resume “# icon from the Debug toolbar.
The program waits for input from the 5250-emulation session.

-ioix

File Edit ‘iew Communication Actions ‘Window Help

D 2% @Bl =8 vt & 8] @l

|z2f” (1902 - Session successfully started A
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4. Type an X beside the Project Master Maintenance option.

5. Press Enter in the emulation session.

The program runs to the breakpoint at line 201.

You have removed a breakpoint from PAYROLLD and now you are ready to begin

[“Exercise 5.9: Monitoring variables in PAYROLLD.”|

Exercise 5.9: Monitoring variables in PAYROLLD

Before you begin, you must complete [“Exercise 5.8: Removing a breakpoint in|

[PAYROLLD” on page 88

Now lets monitor variables and change them in PAYROLLD.

To monitor variables:
1. In the source view, double-click the variable EMPAPL on line 201.
2. Right-click the variable.
3. Click Monitor Expression on the pop-up menu.

000200
L2 000201
oonzoz
0ooz203
0oDz204
000205
000Z06
0oozZ07
poozos
0onz20%
oooZ1lo
pooz11
oooziz
0on213
000214
0p0ozZ1s
000216
000217
L 000218
opooZ1s
00DZZ0
000221
ooozzz2
000223
000224

EifE——

Line 201

Column 26

Syntax Check Selection

Replace

IF IND-OFF (IND-ERROR}

Tr (PUEINgl OF SELECT-I =

Chr|45%
Chri+Insert

Chrl+Y

COt

Copy

Haste

Select:
Selected

Deselect Alt+L

. w

Filter view

Shiow all el

Source
View

v w

£ Add to Snippets...

Save

Edit Ereakpoint...
Remave Breakpaint
Disable Breakpaint

&dd Watch Breakpoint...

Run To Location

Monitor Expression K
Monitor Memary

Swikch View

FPAROLLCCBLE | #/CLCILCLLE m'fMSTDSP.DSPF I =]

ATTZE EMPSEL-0O
RM 0300-EMPMET-SELECT
TL IND-ON (IND-MAINT)

RJAPL OF SELECT-I = ':
WNITIALIZE PRJSEL-O
ERFORM D‘IDD—PRJMST—SE]_I
UNTIL IND-ON (IND-MATIL

WNITIALIZE RSNSEL-O
ERFORM O0500-RSNMST-SE]

UNTIL IND-ON (IND-MATL
E

D-MATNT)
FF (IND-ERROR) TO TRUE
E MSTDSP-REC

s

||

4. Click the Monitors tab in the upper right pane.

The variable appears in the Monitors view. Its value is blank because you did

not select the Employee Master Maintenance option.

5. In the same way add the variables PRJAPL on line 206 and RSNAPL on line

244 to the monitor.
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Variable PRJAPL equals X because you did select the Project Master
Maintenance option.

6. In the Monitors view, double-click the variable RSNAPL.
The value changes into an entry field.
7. In the entry field, type in the new value X for the variable.

- @ HCOUNT = 00100,

L@ EMPAPL = I%
@ PRIAPL=%

RSMNAPL = &

Variables Registers | Memory Rendering | Programs | = ]

L. "GA

8. Press Enter.
The variable is successfully changed.

You have monitored several variables in PAYROLLD and now you are ready to
begin [“Exercise 5.10: Adding a memory monitor.”]

Exercise 5.10: Adding a memory monitor

Before you begin, you must complete [“Exercise 5.9: Monitoring variables in|
[PAYROLLD” on page 90,

Adding a memory monitor for a variable allows you to view the memory starting
with the address where the variable is located. The memory is displayed in
hexadecimal and text format.

To add a memory monitor:
1. In the Source view, double-click the variable IND-ERROR in line 219.
2. Right-click and select Monitor Memory > Memory on the pop-up menu.
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 // PAYROLLC CBLLE ]fCLCLCLLE M/MSTDSP‘DEPF | g
Line 219 Column 37 Replace Bros
2000218 IF IND-ON (IND-MAINT) ‘I
pooz21s SET IND-OQOFF (magpepaopsisielsli TO TRUE
0poz220 Syntax Check Selection P-REC
ooozz1 Ll Corls
000zz2 Copy Ctrl+Insert
000223 Paste Crrlsy
ooozz4
000225 Select ’
000226 Selected k
00022? Deselect Ale+U _ J
opozzs Filter view »
oopzze 3 Show & Gl play fields anc
0po0230 ol S
000231 i , | OF SELECT-O.
pooz3z OR) TO TRUE.
000233 14 Add to Snippets...
000234 3 combination cl
000235 2 iz ure that only ¢
000236 A Add Breakpoint
000237 Add Watch Breakpaint...
gooz3s 2 :
000239 J Run To Location
poo0240 Manitor Expression
oon241 Monitor Memory 1
Qoozdi Switch View » 2 ASCIJEBCDIC -
4| | 3 Signed Integer »
4 Unsigned Integer
|

A new page is added to the Memory view. The tab shows the name of the
variable.
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anrsoIe|Tasks|ISeﬁss CnmmandsLogm CEN | LgE~ =27
IND-ERROR : Oxdab1b390840021dc <Hex> |
Imaress |o -3 |4 -7 |s - B lc-r |a]
D i Ol B T [y 0 00 = 00000000
DAE1E Bl . Reset to Base Address EDD 00 | DOODODOD
54002 00 | DAB1B990 | 84002660
o y PO0 | DAB1BSSO | 54002660
100 ) 00000000
Reformat Afu]n] (win]nin]ulnfu]n]
* “= Copy To Clipboard oo OCOO14FE
E oo 39000080
/=) Print oo 00000000
Derefarancs Painker 00 00000000
oOO T ror I FOrirori 00000000
4040F0F0 | 40404040 40404040
40404040 40404040 40404040
40404040 40404040 40404040
40404040 40404040 40404040
40404040 = 40404040 40404040
40404040 @ 40404040 40404040
40404000 | DO0ODODOO 00000000
40404040 @ 40404040 40404040
40404040 40404040 40404040
40404040 40404040 40404040
40400000 00000000 00000000
20000000 | 00000000 0C001238
00000000 | 00000000 00000000
00000006 | 00000000 0onooooo
DAE1ES 00000000 | 00000000 00000000
DAB1ES 00000000 | 00000000 00000000
DAB1ESS 00000000 | 00000000 00000000
DAE1BS20 00000000 | DO000000 00000000
) AR1R9 4AN4NFAFN | 4M4n4n4n anan4nan X
o 1

3. Use the scroll bar on the right of the Memory view to scroll down.
You can see the current content of the memory.
4. Right-click in the view area.

5. Click Reset to Base Address on the pop-up menu to return to the starting
address.

6. Click the X on the Memory title bar to remove the memory monitor.
ﬁ:unsnlslTasleliSariesCmrdsLogm #lx' LU= :'Eq

You have added a memory monitor for the variable IND-ERROR and now you are
ready to begin [‘Exercise 5.11: Setting Watch breakpoints.”]

Exercise 5.11: Setting Watch breakpoints

Before you begin, you must complete |“Exercise 5.10: Adding a memory monitor”]
ﬂon page 91.

A Watch breakpoint provides a notification to the user when a variable changes. It
will suspend the execution of the program until an action is taken.

To set a Watch breakpoint:

1. Go to the Line number field at the bottom of the source area. In this field enter
118 to go to that line.
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Line 244 Column 1 Replace

000240 ‘I
oooz41 IF ((EMPAPL OF SELECT-I = 'X'")
0o0z4z (PRJAPL OF SELECT-I = 'X'")
000243 ( (EMPAPL OF SELECT-I = "¥')
000z44 {(RSNAPL OF SELECT-I = 'X'")
000zZ4s5 SET IND-ON (IND-ERROR) TO TR
oooz4e MOVE ERRMSG(Z) TO EMESS OF
nonz247 ELSE

000z48 SET IND-OFF (IND-ERROR) TO T:
000248 END-IF.

0oozs0

oooz2s1 * The following IF AND combination e
000252 * application has been selected.
000253

000254 IF ((EMPAPL OF SELECT-I = ' ')
000255 (PRJAPL OF SELECT-I = ' ')
ooozse (RSNAPL OF SELECT-I = " ')
goo0zs7 SET IND-ON (IND-ERROR) TO TR
0ooz2s58 MOVE ERRMSG(3) TO EMESS OF
000259 END-IF.

000260

000261 * The following code checks each app
ooozez * ensure that it ig either ' ' (blan,
000263

000264 IF ((EMPAPL OF SELECT-I NOT =
000265 (EMPAPL OF SELECT-I NOT =
000Z66 SET IND-ON (IND-ERROR) TO TR
< I LIJ

2. Double-click variable IND-TABLE to highlight it.
3. Right-click and click Add Watch Breakpoint on the pop-up menu.

The Add a Watch Breakpoint window opens. The Expression field is pre-filled
with the highlighted variable IND-TABLE.

By default the Number of bytes to watch field is set to zero, which means the
variable will be watched in its defined length.
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@ add a watch Breakpoint x|

Required information

Sets a breakpoint to stop execution when data changes at a specific address u: z s
N =

Address or expression: | {ND-TABLE

Number of bytes to watch: |EI j

ach MNext > | Finish I Cancel

Click Finish.

The Watch breakpoint is now set.

Click the Resume button on the Debug toolbar.

The application waits for input from the 5250-emulation session.

-ioi x

File Edit ‘Yiew Communication Actions ‘Window Help

B DD 2% BlE & 5% & o] @

sten

|z |Connected to remate server/host toras pd101 on psprintl:pd101

In the 5250 emulation session, type 123 for Project Code and D (for delete) in
the Action Code field.

Press Enter. A message is displayed indicating that the variable IND-TABLE
has changed.

@ pebugger Message ) x|

/ i  Variable IND-TABLE has changed in program PAYROLLD, module PAYROLLD,
\‘) which is running in job QPADEYODOF/STECKHAM [254603,
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8. Click OK.

9. In the Breakpoints view, right-click the Watch breakpoint and click Disable on
the pop-up menu.

You have added a Watch breakpoint for the variable IND-TABLE and run the
program to see the notification that the variable has changed and you are ready to
begin |“Exercise 5.12: Closing the debug session.”|

Exercise 5.12: Closing the debug session

Before you begin, you must complete [“Exercise 5.11: Setting Watch breakpoints” onl|
iae 93.

To close the debugger:
1. Click the Resume icon on the Debug toolbar.
The application waits for input from the 5250-emulation session.
2. Switch to the 5250 emulation session.
Press F3 to end the job.

4. A message Program terminated appears:

& Debug Engine Message x|

-

( \:E) Pragram terminated.

w

Click OK.
=lolx|

n Window Help

] i - - £ 5 nehn 2
{- 1
Close all .
[ ‘o —— =)
_\t'arlablesl '@ Breakpoints | e E|‘
v Show Text Ji -

5. Right-click the Debug icon on the top right of the workbench.
6. Click Close on the pop-up menu to close the Debug perspective.

Now you are ready to review your knowledge of this module by taking the quiz.
You can also apply what you have learned in this module by completing the
practice tasks detailed in More practice.

Quiz

1. You can start the debugger:
a. From the Remote Systems view
b. Launch Configurations window
c. Both

2. You can only set breakpoints at executable lines. (T, F)

3. To set a breakpoint you:
a. Right-click on the line and click Add Breakpoint on the pop-up menu.
b. Double-click in the prefix area.
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c. Right-click in the Breakpoints view and click Add Breakpoint on the
pop-up menu.
d. Right-click in the prefix area and click Add Breakpoint on the pop-up
menu.
e. All of the above
4. You can change variables and indicators in the:
Remote Systems view
Debug view
Monitors view
Source view
. All of the above
5. The debugger allows you to:

® a0 oD

a. Step over a program call
b. Step into a called program
c. Both

6. The Debug view lists all call stack entries. It contains a tree view for each
thread. (T, F)

7. You can perform which actions on breakpoints:

a. Delete

b. Add

c. Disable/Enable
d. Edit

e. All of the above

8. Adding a storage monitor for a variable allows you to view the storage
starting with the address where the variable is located. (T, F).

9. The storage monitor supports these display formats:

a. Hexadecimal and text
b. Character
c. Text only
d. Decimal
e. Aand B
10. A breakpoint provides a notification to a user when a variable

changes. It will suspend the execution of the program until an action is taken.
a. Watch

b. Line

c. Conditional

More practice

Given your experience in working with the debugger features, in your own source,
try setting, changing, deleting, enabling, disabling line breakpoints, setting Watch
breakpoints, displaying and changing variables and viewing the call stack as you

debug your program. Use the product online help to assist you in these tasks.

Module recap

You have completed [Chapter 5, “Module 5. Debugging a program,” on page 69
You have learned how to:
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* Invoke the debugger from the Launch Configurations window
* Add a breakpoint

* Add a conditional breakpoint

+ Edit a breakpoint

* Monitor a variable through the Monitors view

* Step into your payroll program

* Show a Listing view

* List the call stack entries in the Debug view

* View all breakpoints

* Remove a breakpoint

* Monitor storage

* Set a Watch breakpoint

* Close the debugger

You have mastered debugging your program and now you learn how to define

filters and perform actions. Continue with [Chapter 6, “Module 6: Exploring Remote|
[System Explorer,” on page 99|
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Chapter 6. Module 6: Exploring Remote System Explorer

This module teaches you how to use the Remote System Explorer perspective to
work with the iSeries objects that you used in the previous modules. You will learn
how easy it is to define filters, perform actions and define your own actions. In
short, you'll see how Remote System Explorer can organize and integrate your
work and make that work easier.

In this module, you will:

* Know the features of Remote System Explorer

* Create a filter to show specific iSeries libraries

¢ Change the filter to add more iSeries libraries

* Create a filter to show all the source files in a library
* Access members to edit from your filter

* Create a user action that copies a source file with data to a new source file in the
same library

* Specify user action parameters
* Specify a restriction on a user action
* Try the user action

¢ Run an OS/400 command from the iSeries Table view

Exercises

* [“Exercise 6.1: More about the Remote System Explorer”]

* |[“Exercise 6.2: Creating a library filter” on page 100|

* |“Exercise 6.3: Creating an object filter” on page 103

* |“Exercise 6.4: Creating a user action” on page 107

* |“Exercise 6.5: Running commands from the Remote System Explorer” on page
112

Time required

This module will take approximately 15 minutes to complete.

Exercise 6.1: More about the Remote System Explorer

Most of the functions of CODE Project Organizer have been replaced by
WebSphere Studio functions with the exception of accessing ADM parts. The
Remote System Explorer is replacing PDM (Program Development Manager) on
the workstation. It currently doesn’t have all the function of PDM but will over
time eventually be a full replacement for PDM.

Remote System Explorer allows you to:

1. Simplify your work by giving you quick access to lists of iSeries libraries,
objects, members, IFS files, UNIX® files, and local files.

2. Use the context-sensitive pop-up menus on these lists to perform actions such
as start the Remote Systems LPEX Editor, CODE Designer, or Integrated
Debugger or other common iSeries actions.
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3. Use the Work with User Actions option to create and manage your own
user-defined actions and have them appear in the pop-up menus.

4. Use the command support to increase your productivity by allowing you to
enter and repeat iSeries or local commands without switching to an emulator
session.

You have read the list of Remote System Explorer capabilities and you are ready to
begin [“Exercise 6.2: Creating a library filter.”|

Exercise 6.2: Creating a library filter

Before you begin, you must complete [“Exercise 6.1: More about the Remote System|
[Explorer” on page 99|

In the Remote System Explorer perspective, you now need to get to the iSeries
objects you want to work with.

In the previous modules you have worked with the Library list. Now you will
create your own library filter. Library filters list a set of libraries from your iSeries
system in the Remote Systems view. But first let’s understand what filters are all
about.

Filters allow you to easily organize elements within your system. You use the filter
function to list iSeries native file system objects (such as libraries, objects, or
members).

£ & | W | Bg v

-4 New Connection
#-E] Local
=B s400a
& iSeries Objects
[+ Ag Work with libraries. ..

i - A5 Work with objects. ..
-4 Work with members. ..

_Tla Library list
-0 User libraries
B iSeries Commands
B ﬁ iSeries Jobs
= T¥ IFS Files
[ Qshells

To create a library filter:

1. In the Remote Systems view expand the connection that connects to your
iSeries system if its not already expanded.

2. Expand iSeries Objects if its not already expanded.

3. Expand Work with Libraries. (You can also right-click iSeries Objects and click
New > Library Filter on the pop-up menu).

Expanding Work with libraries corresponds to the WRKLIBPDM command,
plus creates the filter in the Remote Systems view.

The Create a new iSeries library filter page opens:
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x|
Library Filter
L -,
Create a new [Series library fileer B

Library: |RSE“| 1 ;l J Browse. .. |

< Back I Mext > I Finish | Cancel I

You are going to create a filter to specify the libraries you want to work with,
so they will show in iSeries Objects. You want to create a filter that shows all
libraries on the iSeries with the name RSExxxxx and VARxxxxxxx, xxx being
any character.

Note: You may need to select different libraries that appear on your system if
libraries with the above names do not exist.

You specify the first filter string that selects the libraries starting with RSE.
4. Type RSE* into the Library field, using the * wild card character.
5. Click Next.

The Name the new filter page opens.

x
Library Filter
Mame the new Filter -}1 M
&>
= | l

Filters are saved for easy re-use. Specify a unique name For this filker, This name will
appear in the Remote Systems view, and will be expandable,

Filter name: &l RSE and YARPG libraries ’

I Orily create filter in this connection

Select a profile ko own the new Filker, This determines if it is unique to you, or
sharable by the team. It will be placed in the default filker pool for that profile.

Owner profile: |msteckh?tp ;]

< Back I Mext = ‘@, Cancel |

Note: You can choose between creating the filter for all connections or for this
specific one only.

6. In the Filter name field, type A11 RSE and VARPG Tibraries.
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You give your filters a name because the Remote System Explorer saves them
for future use, unlike PDM, which does not save filters.

7. Click Finish.

Back in the Remote Systems view under iSeries Objects you will see the new
filter expanded, listing all RSE* libraries.

Now you need to add the VARPG libraries.
Changing the library filter

To change the library filter:
1. Right-click the filter All RSE and VARPG libraries and click Change.

> P
Team =8| Ar 2\ O 5=o0
&£ 81 W | BB - Line 57
£ Mew Connection = _ - P
#-El Local 4 L[
=B s400a
=@ iseries Objects I— .
B 3 work with libraries, .. —1—

L % Filter created successf ||| | g iSeries... £3 "\ Remote
1‘ Workwith et File RSELABXY/ORPGLESRC (2
[ A5 Work with members. .,
1w Library list H ) o
e n 5
£2] ?Ii Userlbran - TR T
=R Al RSE and YARPG librag
@) RSELABXY. *ib.prod  New »
[#)-E, RSELABOD *ib.prod  Go Into
- RSELABDL *ib.test  GoTo »
[+-E, RSELABOZ, *lib.test
] m, RSELABOZ, ¥fib,test = Open in New Window
[, RSELABO4,*iib.prod
EE‘E RSELABOS, *iib.prod & | Refresh
4 | | Expand S
o e & Caollapse -
Propetties | . Remote Scrat... &3

| e
The Change Library Filter window opens.

@& change Library Filter x|
Filter name: Al RSE and YARPG libraries
Parent filter pool: Msteckh7tp Filter Pool

New Filter string:

Libra ‘@ - J Ernwse...l
Test | Revert |

D e |

2. Select New filter string from the Filter strings list.
3. In the Library field, type VAR=.
4. Click Create.

102 Development Studio Client: Maintain an ILE application using Remote System Explorer COBOL application



The VAR* filter string is added to the list.
5. Click OK.

You are now back in the Remote Systems view.

Al Work with objects... -

R Tt\ﬁ ‘whork with members, ..

B “ Library list

B~ ﬁ\ User libraties

S Al RSE and VARPG librarie
[, RSELABXX. *ib.prod
[+ @), RSELABOOD. *ib.prod
B\, RSELABO1.*ib.kest
[+ =, RSELABOZ.*ib.best
[+, RSELABOS. *ib.test
[ g, RSELABO4. *iib.prod

[+ B, RSELABOS, *lib.prod

[

[+

| g, RSELABZ4.*lib.prod
] f- B, VARLABOD. b prod
=B iSeries Commands
B ﬁ iSeries Jobs
@ TF IFS Files
[ Qshells =

‘| | o

You will see the list expanded to include your filter. Now you can work with
the libraries directly and can drill down to the object you want to work with.

You have created a filter to show a specific iSeries library and changed that filter to
add more iSeries libraries and you are ready to begin [‘Exercise 6.3: Creating an|

object filter.”]

Exercise 6.3: Creating an object filter

Before iou begin, you must complete [“Exercise 6.2: Creating a library filter” on|
page 100.

Now create an object filter. Object filters list a set of objects from your iSeries host
in the Remote Systems view.
To create an object filter:

1. In the Remote Systems view, expand your connection and then expand iSeries
Objects if not already expanded.

£ 8] | ¢ | B %
|

|

: [ - A Work with objects...
) h:) Wark with members. .
23] . Library list

B~ !_, User libraries

b

@ RSELABRX. *Ilb prod
£ = RSELABOD. *ib.prod
H = RSELABDL . ¥ib.test

2. Expand Work with objects. You can also right-click iSeries Objects and click
New > Object filter on the pop-up menu.

Note: Expanding Work with objects corresponds to the WRKOBJPDM
command.
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The Create a new iSeries object filter page opens:

Now create a filter to show all your source files in your RSELABxx library.

x4

Dbject Filter
Create a new iSeries object filter -yl
Library: RSELABx] =l eowse.. |
Object: b :j J Browse. ..
Object type: | =14
Object attribute: | * 14 Bropse s |
More Typess> I

< Back I MNext > I Finish | Cancel

3. In the Library field, type RSELABxx.
4. Click Browse beside the Object type field.
The Select Object Type window opens.

@& select Object Type x|

Select an object type:

*CTLD ]
*CRG

*CRQD

*DEWD

*DOC

DTAARA

*DTAQ

*EDTD

FEXITRG

*ECT

*FLR
*ENTTEL
*ENTSRC
*FORMDF
*ETR
*G55
HMGCLG
*IPYD
*J0BD
*J0BQ
*JOBSCD

*IRN ;I
FARKIRCY

[ ok | conce |

5. Select *FILE under the Select an object type list.
6. Click OK.

The Create a new iSeries object filter page displays with the object type
updated.
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@rew x|

Object Filter

Create a new [Series object fileer

-l

Library: | RSELABXx

dj Browse, .. |

Object: | ¥

:_I J Browse.., |

Object type: | *FILE

:'Jl Browse. .. I

Object attribute: |*

Mare Types==

B
|

= Back

I Mext > I Finish | Cancel I

7. Click Browse beside the Object attribute field.
The Select Object Attribute window opens.
8. Select PF-SRC under the Select an object attribute list.

9. Click OK.

@ select Dbject Attribute x|

Select an object attribute:

BSCF38
CMNF3E
DDMF
DFU
DFUEXC
DFUNOTEXC
DKTF
DSPF
DSPR3E
ICFF

LF

LF38
MXDF35
PF-DTA

| QK I Cancel

10. Click Next.

The Name the new filter page opens.
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@rew x|
Object Filter

Mame the new filter 41 M

-

Filters are saved for easy re-use. Specify a unique name For this filker, This name will
appear in the Remote Systems view, and will be expandable,

Filter name; | My source files|

[ Orily create filter in this connection

Select a profile ko own the new Filter, This determines if it is unique to you, or
sharable by the team. It will be placed in the default filker pool for that profile.

Owner profile: |msteckh?tp ;]

<Back | Nexr.>[k|| Fish |  Cancel |

11. In the Filter name field, type My source files.
12. Click Finish.

The new object filter displays in the Remote Systems view under iSeries
Objects:

£e)

b
e

HH-EE]EIH-HL-;}EI E-E-E-E-E

Bg v
=), RSELABOZ Mb.test 4|
‘B, RSELABO3. Mib.test

B, RSELABO4. *ib.prod

=, RSELABOS. *ib.prod

=i\, RSELAB24.¥lib.prod

=i, YARLABOD. *lib. prod

COMPARE. *file.pf-src
QCBLLESRC. *file.pf-st
[y QCLSRC . *file.pf-src
-5 QDDSSR.C, *File . pf-src
0 QRPGLESRC. *file.pf-s
‘ (5 QRPGLESRCP. *file.pf-
B iSeries Commands

] ﬁ iSeries Jobs

#-TF IFS Files

[ Qshells =

< | >

Note: If you end up with too many filters, you can create filter pools. They
allow you to group filters.

Now you know how to create filters and tailor your development

environment. Filters can also be specified for non iSeries servers and your

local system.

Now you can work with the objects you have in your Remote Systems view

like you worked in PDM with a subset of libraries, objects, or members.

Let’s assume you want to edit the member PAYROLL in the source file
QRPGLESRC using this object filter.
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Editing a member from your own object filter

To edit a member:

1. Expand QCBLLESRC.

2. Right-click member PAYROLLC.

3. Click Open With > Remote Systems LPEX Editor on the pop-up menu.
This will download the source member and open the editor with this member.
After you have edited the member you could save it and then compile it from

the Remote Systems view by using the pop-up menu options on this member.
You can also create your own actions in addition to the default actions.

You have created a filter to show all the source files in your library and accessed
members to edit from your filter and you are ready to begin |[“Exercise 6.4: Creating|

a user action.”

Exercise 6.4: Creating a user action

Before you begin, you must complete [“Exercise 6.3: Creating an object filter” on|

In PDM you can create user actions in addition to using the pre-supplied system
actions. In Remote System Explorer you can do the same. You define user actions
through the Work With User Actions window. User actions can be defined for
iSeries libraries, objects, members and jobs as well as folders and files in any
remote UNIX, Windows, Linux, Local, or IFS system.

To open the Work with User Actions wizard:
1. Expand your iSeries connection and expand iSeries Objects if not already

expanded.
1 Show in Table "'g; outline Sg"x\_. = E‘\
T ?;":‘ Find String. .. ) e .
H= & | Change ) <
| Eme Librar Save(B). .. -~ Press Refresh to update |
i ; : o Restore(d)... _
O o e
| B-BAC eate iSeries Project(K) — ; =3
| E-EAC “_Remote ... 73 = ml|
#-m, W  Properties(L) b (2; Objects)
[ == ~% - SE L AE:c. Fiib. prod-u %
| Eeme User libraries PR ) 7]

2. Expand the Library list filter if not already expanded.
Right-click RSELABxx.
4. Click User Actions > Work with User Actions on the pop-up menu.

w

The Work with User Actions window opens.
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@& Work With User Actions ! i]

5. In the right pane of the Work with User Actions window, expand New in the
list, if it is not expanded already.

6. Select Object action.

You want to create a user action that copies a source file with data to a new
source file called QJUNKSRC in the same library.

@& work With User Actions

Parent profile: |mstadd1?tp

& E; ey Action name;
ﬁ Object action
: lt:} Member action mment:

P

RTDUPOB]

4

Insert variable. .. | Edit... Browse. ., I

[ Prompt First I Refresh after ¥ Show action
[ single selection only | Invoke once

Resource types for which this action will appear

Defined Types Selected Types
Addz

=RemovelG)

Edit(H)...

| Create I Revert(1) I

Close |

7. In the Action field, type Copy source file for the user action name.

8. In the Comment field, type Copy source files with data.
9. In the Command field, type CRTDUPOBJ for the command to execute.
10. Click Prompt to open the command prompter for this command.
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& Create Duplicate Object (CRTDUPOBJ) _ x|

From object: BN j Mame, generic*
From library: &L _"_I Mame

Object type: I&T .:" add |
To lbrary: *FROMLIB > | Mame

New object: *0OB] 3 Name

From ASP device: * ~ | Hame

Tao ASP device: *ASPDEY :_l Nata
Duplicate data: "YES| :‘

I™ advanced ¥ all Parameters ™ Keywords
CRTDUPOB] OBI(&M) FROMLIB(EL) OBITYPE(ET) DATACRYES) |
£
oK I Restoredafwltsl Cancel I

This is the command you will be running:
CRTDUPOBJ 0BJ(&N) FROMLIB(&L) OBJTYPE(&T) NEWOBJ(QJUNKSRC) DATA(*YES)

Specifying user action parameters

To specify user action parameters:

1. In the From Object field, type &N to indicate to use the name of the selected
object in the Remote Systems view.

2. In the From Library field, type &L to pick up the library name from the selected
object.

3. In the Object Type field, type &T to pick up the object type from the selected
object.

4. In the New Object field, type QJUNKSRC.

5. Select the All parameters check box to see the additional Duplicate data
parameter.

Now the Duplicate data parameter is also shown on the prompt window.
6. Select *YES from the Duplicate data list.
7. Click OK.

You return to the Work with User Actions window.

8. Select the Refresh after check box, so that the Remote Systems view gets
refreshed after the action has been run.
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@& work With User Actions I x|

Parent profile: |msteckh?tp ‘j
& E; New Action name: ECupy source file
E Object action
: lt:} Member action Comment: qu:l',l' source file with data
Command: iNormaI command j

CRTDUIPOE] OBJ(&M) FROMLIB(&EL) OBITYPE(T) NEW - |

| | _»J;I

Insert variable. .. | Edit... | Browse. ., I
Prompt... |
[ Prompt: first by Refresh aftev Show action

[~ Single selection only | Invoke once

Resource types for which this action will appear

Defined Types Selected Types
FILE_SRC
FILE_SRC: *FILE:PF*-SRC
Create | Revert(1) I

Close |

Note: Clicking the Insert variable push button displays a list of valid
replacement variables with the explanation of what they do.

This user action is only valid for Source physical files. You need to specify this
restriction so this user action will only show in pop-up menus when you
right-click on a source physical file.

Specifying a restriction on a user action

To specify this restriction:
1. Under the Defined Types list box, click FILE_SRC.
2. Click Add beside the Defined Types list box.

FILE_SRC is now one of the selected types. Actually since you only selected
this one it is the only one.

3. Click Create then Close.

Now, only when you right-click on a source file, will this user action appear on
the pop-up menu. For any other object type it will not appear. Back in the
workbench and the Remote System view, give it a try.

Note: Remember to close the payroll source member if you opened it earlier.

Trying the user action

To try your user action:

110 Development Studio Client: Maintain an ILE application using Remote System Explorer COBOL application



1. Locate your filter My source files.

- Expand - e
-i5 Remote .iyrs.tcmi.?‘ Collapse - RB\3 m
o2 | L Column 1 || &
ol [ Rename. .. LA
| B-mh Q5VS2.Mib.prod :
| E-md QHLPSYS.*Mib.pn = Copy w ﬂ ®
| BB QUSRSYS.*ib.pr - Paste c
| B RSELABXCMDD 2 e, IDENTIFI | ¥
| [#-Ey RSELABOO,*ib.p o€ Delet
- " e.“
i o m*\;gf“’_‘axx”“b" DROGRAM-
[+ - r aries
o i, Al RSE e varpG i 5 Showin Table AUTHOR
| [#-E, RSELABCK.*ib.p Cache Fle Descriptions INSTAL
| [#-m, RSELABOD.Mb.p B Find String... DATE-T
| B RSELABOL.*lib.te Change(8)... DATE-C
[+, RSELABOZ, *lib.te 5
| E-mh RSELABOSHbbe oo el
-, RSELABO4.*ib.p S :
| E-m RSELABOS.ib.p I
[#-m, RSELABZ4.*ib.p
| [k VARLABOD.*ib.p #Add To iSeries Project. . 11 Work With User Actions...
o il"‘ My Sowwce Fles Make Avalable Offline
0 COMPARE.*iler  properties(d) 4
SCELLESRC, ¥Filerpn a1t - f
= QCLSP‘C'*EEF_'DH’ [ISerles Command. .. | L= iSeries Table view 52~ = [
£ L_ﬁ QCMDSRC. *file. pf-src :'I Fil= RSFI ARYYINCRI I FSRIC (3 Mambare)

2. Expand the filter My source files, if it is not already expanded.
Right-click the QCBLLESRC file.
4. Click User Actions > Copy source file on the pop-up menu.

The file gets duplicated and the list gets refreshed. Your new source file will
show in the list. You can check the messages of the CL commands you are
running in the RSE communications server job by looking at the iSeries
Commands log in the right hand side bottom pane of the workbench.

w

W [Series Commands Log X S S Search] Ve 1
s400a I
NEWOBJ(QIUNKSRC) DATA(*YES) 2]

Object QIUNKSRC in RSELABYXY bype *FILE created.

1 objects duplicated.

Cause.,.,.: &l the objects with supported object types specified on
the Create Duplicate Object (CRTODUPOB]) command were duplicated.
See low level messages o determing if any objects were not duplicated.

b

Command ll‘uormal ;l l ﬂ

5. To delete the source file QJUNKSRC that you just created, right-click
QJUNKSRC.

6. Click Delete on the pop-up menu.
The Delete Confirmation dialog opens.

7. Click Delete.

You have created a user action that copies a source file with data to a new source
file, specified user action parameters, specified restrictions on the user action and
tried the user action and you are ready to begin [“Exercise 6.2: Creating a library]|

[filter” on page 100.|
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Exercise 6.5: Running commands from the Remote System Explorer

Before iou begin, you must complete [“Exercise 6.4: Creating a user action” on|

The command entry is part of the Remote Systems view.

To run a command:

1. Check if you have an iSeries Table View tab in the bottom right pane where
your commands log appeared in the previous exercise.

2. If you have it, click on it.

3. If you don’t have it:
a. In the Remote Systems view, right-click My source files filter.
b. Click Show in table on the pop-up menu.

As you have seen already you can now run commands on the iSeries server
that the table is connected to. You can enter commands in the Commands field
beneath the iSeries Table view, and view messages in the Messages field. You
can enter a command and click either Prompt to specify parameters and then
Run, or just click Run. When you run a command, the Messages field is
populated with the messages from the command. When you select a message,
the Details button is enabled. When you click this button, the message and its
help is displayed.

4. Type an iSeries command, for example ?ADDLIBLE.

iSeries Commands Log [ s e e .o Remote System Details | ==
Filker "My source files' (7 Objects) ; :." ; 5_}.. = @ v
Name | Type | Attribute | Text
_?_[I}ECOMPF\RE *FILE PF-SRC
_?IGQCBLLESRC *FILE PF-SRC
SHQCLSRC *FILE PF-SRC
EIGQCMDSRC *FILE PF-SRC
5QDDSSRC *FILE FF-SR.C
flﬁQRPGLESRC *FILE PF-SRC
SHQRPGLESRCP *FILE PF-SRC
<J| | il
w
ey
Command |Normal > ||| ?ADDLIBLE | ~] Prompl
Messages |Libr’ar’}.r RSELABRY added to library list, :_I Details. .. | show Log |

The question mark is there to display a prompt screen.

Instead of specifying a question mark you could use the Prompt push button.
5. Click Run.

The Command Prompt window for the ADDLIBLE command opens.
6. In the Library field, type RSELABOO and click OK.
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& add Library List Entry (ADDLIBLE) il
Library: -RELnEiclnl Name
Library list position: ;

List position: *FIRST - I

Reference library: Name
I~ advarced I Al Parameters I~ Keywords
ADCLIBLE LIB{RSELABOO) ]

() | roetots| _ cont |

That will add this library to the library list of your Remote System Explorer job

on the iSeries server.

Note: You may need to add a different library if the library RSELABOO does

not exist on your iSeries system.

The Messages field will confirm the successful completion of this command. To
get to the command history, similar to F9 on the 5250 screen, select the
appropriate value from the Command list (down arrow beside the Messages

field.
iSeries Commands Log _Pz-.iSar'ies SR S Remote System Detaﬂs[ ='m
l — e
Filker My source files' (7 Objects) & & Q) -
Name | Type | Attribute | Text
SHCOMPARE *FILE PF-SRC
\SQCBLLESRC *FILE PF-SRC
_-?_(IBQCISRC *FILE PF-SR.C
_ZFIGQCMDISRC *FILE PF-SRC
50QDDSSRE *FILE PF-SRC
EIBQRPGI.ESRC *FILE PF-SRC
SIQRPGLESRCP *FILE PF-SRC
4] | 2
Command |N0rma| ;l | :j Prompt.. | R
| Messages [Library ReELABOD added to fbrary st | x| Detas... | Show Logl

You could also use the iSeries Commands subsystem in the Remote Systems
view underneath the iSeries Objects subsystem and run predefined commands
or define your own commands.

You have run an OS/400 command from the iSeries Table view.

Now you are ready to review your knowledge of this module by taking the quiz.
You can also apply what you have learned in this module by completing the

practice tasks detailed in More practice.

Quiz

1. The Remote System Explorer is replacing what ADTS tool:

a. Page Designer
b. CODE Designer
C. Screen Design Aid
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d. Program Development Manager

2. filters list a set of libraries from your iSeries system in the Remote
Systems view.
a. Object
b. Member
c. Library
d. Job

3. Filters allow you to easily organize elements within your system. You use the
filter function to list iSeries native file system objects (such as libraries, objects,
or members). (T, F)

4. Expanding Work with Libraries corresponds to the command.
a. WRKOBJPDM
b. WRKLIBPDM
c. WRKMEMPDM
d. All of the above
5. You can create filters for all connections or for a specific connection. (T, F)

6. You give your filters a specific name because the Remote System Explorer
saves them for future use, unlike PDM, which does not save filters. (T, F)

7. filters list a set of objects from your iSeries host in the Remote
Systems view.
a. Job
b. IFS
c. Object
d. Member
e. Library

8. If you end up with too many filters, you can create filter pools. (T F)
9. Filters can be specified for non iSeries servers and your local system. (T, F)
10. User actions can be defined for:
a. iSeries libraries
iSeries objects
iSeries members

iSeries jobs

©® oo o

files and folders in any remote UNIX, Windows, Linux, Local or IFS
system

f. All of the above
11. You can specify a restriction on a user action. (T, F)
12. You can run OS/400 commands from the:
a. iSeries Table view
b. iSeries Commands log
Tasks view
iSeries Error List
aand b
All of the above

~ 0o a0

More practice
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Given your own libraries on your iSeries system, create a member filter and a job
filter. Then move libraries up, down and within your library list. Finally create a
filter pool. Use the Development Studio Client for iSeries online help to assist you
in these tasks.

Recap

You have completed |[Chapter 6, “Module 6: Exploring Remote System Explorer,”|
You have learned how to:

* Know the features of Remote System Explorer

* Create a filter to show specific iSeries libraries

¢ Change the filter to add more iSeries libraries

* Create a filter to show all the source files in a library
* Access members to edit from your filter

* Create a user action that copies a source file with data to a new source file in the
same library

* Specify user action parameters

* Specify a restriction on a user action

* Try the user action

* Run an OS/400 command from the iSeries Table view

Now that you know how to create filters and actions to manage your iSeries
objects you can learn how to visually design screens. Continue with
[“Module 7. Designing screens,” on page 117|
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Chapter 7. Module 7. Designing screens

This module teaches you about the various aspects of the CODE Designer while
modifying a display file to add a screen. You will step through each part of the
CODE Designer tool interface and update some DDS as well. In the workbench, in
the Remote System Explorer perspective you will use the connection that you used
in the module before.

In this module, you will:

Open a DDS member for edit with CODE Designer
Show file-level keywords and record keywords

View the details of records, record-level keywords and field-level keywords
View the design of the payroll application main menu
Create a group from an existing record format

Create a new group and add a subfile record and a subfile control record
Add columns to the subfile record

Add fields to the subfile control record

Copy existing fields

Set indicators to handle field errors

View and update record and field properties

View keywords and the properties of a keyword
Insert a keyword

View help for a keyword

Check there are no semantic errors in the DDS source
View help for an error

Launch the editor in read mode from the error list
Launch the editor in write mode to fix the error

Find a keyword in the source

Save source changes

Compile your source changes

Close the Designer

Exercises

The exercises within this module must be completed in order:

[“Exercise 7.1: Opening a DDS member in the Remote Systems view” on page 118§|

[“Exercise 7.2: Viewing the DDS tree” on page 119
[“Exercise 7.3: Selecting the DDS object” on page 120|
[“Exercise 7.4: Designing the DDS screen” on page 121

[“Exercise 7.5: Creating groups from existing records” on page 122|

[“Exercise 7.6: Creating new screens” on page 124|
[“Exercise 7.7: Adding fields to the subfile record” on page 126
[“Exercise 7.8: Switching between multiple records” on page 129

[“Exercise 7.9: Adding field error handling” on page 131

[“Exercise 7.10: Accessing field properties” on page 133
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* |“Exercise 7.11: Adding new keywords” on page 135|

* [“Exercise 7.12: Verifying the source changes” on page 137|

* [“Exercise 7.13: Switching between designing and editing the screen” on page 139

* |“Exercise 7.14: Compiling your source changes and closing the Designer” on|

[page 140|

Time required

This module will take approximately 30 minutes to complete.

Exercise 7.1: Opening a DDS member in the Remote Systems view

Using an editor to create and maintain DDS source for your display, printer and
physical files can be a frustrating and difficult task. What would be great is a
graphical design tool that let’s you design your screens and reports visually and
then generate the DDS source for you. Well, that’s exactly what CODE Designer
does for you.

CODE Designer helps the novice DDS programmer create screens, reports and
databases quickly and easily without worrying about the details of the DDS
language, while at the same time letting the expert DDS programmer get access to
all the features and power of the language.

Note: Make sure MSTDSP is closed from the previous LPEX Editor exercises.

To open a DDS file member from the Remote Systems view:
1. Expand the Library list filter if it is not already expanded.
2. Expand the QDDSSRC file in library RSELABxx.

=0 SPAROLL.. |

&2 | B = - Line E
; o [ QODSERC *file.pf-src 4
i - EMPMST.pf ©[0opos7
: R RE 15 TDSP. dspi z
: B PRIMST.pf sale
/ Remote Systems LPEX Editor
i‘?iﬂ?l CODE Editor Browse YWith L4
"5 CODE Designer R 1 Rename...
=} (=2 o= -
- T5] RSNMST #file. pf- =) COPY
B MVCOMPILE *cm «f» Mave. ..

3. Right-click the MSTDSP member.
4. Click Open with > CODE Designer on the pop-up menu.

The member MSTDSP will be downloaded to the workstation and loaded into
CODE Designer. CODE Designer is a separate tool not integrated into the
workbench.

You have opened the DDS source member MSTDSP in the Remote Systems view
using CODE Designer and you are ready to begin |“Exercise 7.2: Viewing the DDS|
[tree” on page 119
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Exercise 7.2: Viewing the DDS tree

Before you begin, you must complete [“Exercise 7.1: Opening a DDS member in the|
[Remote Systems view” on page 118

What you are looking at now is basically an Explorer view of the DDS. The DDS
tree view on the left-hand side of the Designer displays the DDS source in its file,
record, field, and keyword hierarchy. It is a familiar and intuitive way to see the
overall structure of the DDS source and to navigate through it quickly. Don’t worry
if you're not a DDS expert, everything will be explained to you.

The DDS tree shows groups of records, which represent the screens or reports you
are designing, as peers of the file in the tree hierarchy.

In this view, you can create groups, and copy or move keys, keywords, fields, and
records. If any DDS object contains an error, the icon representing it displays a red
X.

To show file-level keywords and the record SELECT in the DDS tree:
1. Expand the <Servername>RSELABxx/QDDSSRC(MSTDSP) folder.
2. Expand the File Keywords folder.

Expand the SELECT record.

Expand the Record Keywords folder.

Expand the EMESS field.

ok w

EN -
[=1-fe= Fils Keywards
. e PRINT
e INDARA
e CAD3
e CADG
| B SELECT
[ Record Keywords
i - T BLINK
: O ALARM
. [#-A 'PRGOY
. @A TimeR...System’
- =@ roate
. @A Mainte, . .ection’
- (B rTvE
- B A Enter ...inkain’
. [ EMPAPL
- @A ‘Employ...enance’
L3 PRIAPL
- E-A Projec...enance’
[ RSNAPL
. #-A 'Reason...enance'
B EMESS
| Gae DSPATR
. @A F3-End of Job'
[#-48% EMPSEL
+1-4% EMPMNT
G-4@% PRISEL
-4 PRIMNT
| -4 RSNSEL
| B4 RSNMNT
-3 MaIn_MENU

The DDS tree now shows you a summary of the file-level keywords and of the
record SELECT.

Chapter 7. Module 7. Designing screens 119



You have seen the file-level keywords and the record SELECT in the DDS tree and
you are ready to begin [“Exercise 7.3: Selecting the DDS object.”|

Exercise 7.3: Selecting the DDS object

Before you begin, you must complete [“Exercise 7.2: Viewing the DDS tree” on page|
119.

In the upper right-hand side of the Designer is the Workbook with several different
tabbed pages. The Workbook is the area of the CODE Designer where you design
display files, printer or physical files. You can view this notebook on the top
right-hand side of the CODE Designer window. The top page is called Details and
it provides a detailed view of the DDS objects selected by the DDS tree. You can
view this page in either details mode or list mode by clicking View > List from the
CODE Designer menu.

In the Details page columns display information about the selected DDS object.
You can use this page to display for example, details of all the fields in the record
SELECT or keywords and conditions of a field or record.

The Listing page is a listing of the source statements generated by the Program
Verifier.

In the bottom right-hand side of the Designer is the Utility notebook. This
notebook contains several pages: Selected DDS, Web Settings, Comments and Error
List. The Selected DDS page in the notebook shows the actual DDS source for the
currently selected item.

Note: The Web Settings page allows you to specify attributes that are used by the
WebFacing tool.

To work with the DDS record SELECT:
1. In the DDS tree click the SELECT record.

The Details page lists all the fields in the record SELECT and summarizes some
of their properties. The Selected DDS page shows the DDS for the SELECT
record.

Detalls | MaIN_MENU | Source | Listing|

FRecord SELECT fields
Field | Positi. | Len.. | Type | Shift | Usa... | Sample -
A FRGOT 2.5 5 Text const... PRGOT
A Time R.. System’ 2,30 21 Text const... Time Reporting Spste
[@"DATE 270 6 Date const... MMODAY
A Mairite.._ection’ 33 A Text const... Maintenance Selectic
@"TIME 370 6 Time const... HH:MM:55
A Enter .intair 614 54 Text const... Enter an ¥ beside the
[ EMPAPL 9.25 1 Alphanumenc A - Alphanum... Both B
A Employ.. enance’ 9,28 27 Text const... Employee Master Mai
[ PRJAPL 10,25 1 Alphanumenc A -Alphanum.. Both B
A Piojec._enance' 10,28 26 Text const... Project Master Mairte
lﬁl RSNAPL 11,285 1 Alphahumeric A - Alphanum... | Both B . >

2. In the DDS tree click Record keywords immediately below SELECT.

The Details page shows the current record-level keywords. The Selected DDS
page still shows the DDS for the SELECT record.
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Detals IMAIN_MENLI I Source | Listing |
Record SELECT keywords

Kewword | Canditioni... | |
S~ BLINK
T pARM BD

Selected DDS | Create keywoids | Web Settings | Comments | Eror list |

A® 89-03-02 12:07:25 DOUG REL- -
A% THE SELECT FORMAT ALLOWS SELECTION OF
A* MASTER FILE THE OPERATOR WANTS TO MAIL

A R SELECT

A BL]

A& 60 ALZ

A 2 5'FF

A

2 30'Tie
4| | bI

3. In the DDS tree click the EMESS field.

The Details page shows its field-level keywords. The Selected DDS page now
shows the DDS for the EMESS field.

Selected DDS | Create kepwords | Web Settings | Comments | Eror lst |

]

A EMESS 502 0O 21 16 ..‘_I
4 B0 DSPATR(HI)

< o

Even this relatively small and simple DDS source member demonstrates how
much easier it is to use the Designer to navigate through your DDS source. The
syntax is being interpreted in intuitive graphical ways making it an ideal tool
for learning DDS. But to get orders of magnitude improvement in your
productivity what you really need is to work with your screens and reports in
a WYSIWYG fashion, completely independent of the DDS required to make
things appear the way they do. You need the Design page.

You have seen the details of the record SELECT, the record-level keywords and the
field-level keywords and you are ready to begin [“Exercise 7.4: Designing the DDS|

Exercise 7.4: Designing the DDS screen

Before iou begin, you must complete [“Exercise 7.3: Selecting the DDS object” on|
page 120.

You will spend most of your time creating, updating, and designing your DDS
screens and reports in the Design page. The Design pages allow you to design
your screens or reports visually using an intuitive graphical user interface. The
Design page shows the DDS source as it would appear on either a screen (for
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display files) or a printed page (for printer files). It allows you to design your
application’s screens or reports by laying out records and fields in a graphical user
interface.

On the Design page, you can easily create, edit, resize, and move DDS objects
graphically. You can create new records, fields, and constants directly on the
Design page by using the palette push buttons to the left of the Design area or
from the pop-up menus. The toolbar above the Design area allows quick access to
many of the editing features as well as information about the currently selected
object.

1. Click the MAIN-MENU tab in the workbook.

Detais AN MENDY Souce | Listing |
(&) Eserec MERD

| "/5! Ignore all indicators -

JLion you vant 1o naintain

E

In order to understand where MAIN_MENU came from, you need to understand
the concept of a group. A group is simply a collection of one or more DDS records
that represent how a screen or report would be assembled at runtime. It allows
you at development time to work with screens or reports as they would appear
when they get assembled by your programs at runtime. To work with groups in
CODE Designer you need to tell CODE Designer which record formats make up a
screen. In this case this has been done for the screen you see in the Design page. A
group MAIN_MENU has been created for you and CODE Designer has saved this
information in the DDS source in comment lines. Any groups that you create are
persisted as comment lines in the DDS so you can re-use these groups in
subsequent CODE Designer sessions.

The groups you create will appear in the tree view as well as in the workbook as a
Design page tab for each group defined, to allow quick access to each group of
records.

You have seen the concept of a group, specifically the MAIN_MENU group and
you are ready to begin [“Exercise 7.5: Creating groups from existing records.”]

Exercise 7.5: Creating groups from existing records

Before you begin, you must complete [“Exercise 7.4: Designing the DDS screen” on|
iae 121.

If you are working with existing DDS, you will want to create groups that will
correspond to how the records are being used. In this example you will create a
group for the next screen, where the user selects which employee in the payroll
database to maintain. The screen is made up of the record format EMPSEL.
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To create a new group:

1.

Scroll to the bottom of the DDS tree and expand the MAIN_MENU group.
The SELECT record appears as the only record in this group.

-8 MAIN_MENU

= @ B

Right-click the MAIN-MENU group.
Click Insert group on the pop-up menu.

A Group Properties notebook opens and a blank Design page for the group
SCREENT also opens.

|| Detas | mane_waen S SEREER P e | Liting |

Group |SEHEEN'I

Available

PRJSEL

Selected

Fat

PRJMNT
= |psN =
Selected DDS | Web Settings | Comment HENE{ENLT _I

o

i i i i

The Properties notebook lets you view and update the properties of the
currently selected DDS object. You can open this notebook from any view,
pop-up menu, or menu of the CODE Designer. The Properties notebook is
modeless. When you change an object’s properties, the selected object changes
immediately.

In the Group Properties notebook, select the EMPSEL record from the Available
list and click the il button.

For simplicity this is the only record you will add for now. The Design page
now shows you what the record EMPSEL looks like.

@EMPSEL EERD .

|gnore all ndicalors

5. In the group field, type EMPL_SELCT over SCREEN1 to rename the group.
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[ Group properties

Basics I Styles |

Group

|EMF‘L_SE LCT

Available

gy, Selected

21

SELECT
EMPMNT
PRJSEL
PRIMNT
RSNSEL
RSNMNT

EMPSELJ

6. Close the Group Properties notebook. Click the X in the top right corner of the

Group Properties notebook.

You have finished creating a group. You could now work in the Design page
with the record formats contained in this group. Instead you’ll create a new

record format.

It appears that this is one of those unusable applications where you have to
know the employee number ahead of time instead of being able to browse
what is in the database. What we really need is a subfile. But aren’t those
difficult to code, you ask? Not with CODE Designer.

You have inserted a new group using the existing record EMPSEL and you are
ready to begin [‘Exercise 7.6: Creating new screens.”|

Exercise 7.6: Creating new screens

Before you begin, you must complete [“Exercise 7.5: Creating groups from existing|

[records” on

page 122

To create a new record screen on the Design page you need to create a group that

will create an empty page you can work with.

To create a new group:

1. Right-click the new EMPL_SELCT group in the DDS tree.
2. Click Insert group on the pop-up menu.
A Group Properties notebook appears and a blank Design page for the group

SCREENT also appears.
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3. Rename the group to EMPL_LIST and close the Group Properties notebook.

4. You can create things on the Design page by selecting the appropriate tool from
the palette on the left-hand side and then click on the Design page where you
want it to be created. Right now, most things are disabled in the palette
because there is no record in which to create fields. The only two buttons
available are Create standard record and Create subfile record. If you leave
the mouse over a button for a second or two, flyover help will appear
describing the indicated button.

5. Click the Create subfile record button and then click in the dark gray area.
A subfile and a subfile control record pair are created.
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Details| MAIN_MENU | EMP_SELCT EMPL_UIST | Source | Listing |

(&) (Erecorot EERD ETE
@ Ignore all indicatars j

You have created a new record screen and you are ready to begin m
[Adding fields to the subfile record.”|

Exercise 7.7: Adding fields to the subfile record

Before you begin, you must complete [“Exercise 7.6: Creating new screens” on page]

Now you add some columns to the subfile using the Design page. The subfile
should be positioned on row eight. You use the cursor to specify the location of the
part you want to put on the screen, in this case your subfile.

To add fields on the subfile:

1. Click the Create named field button =] and then click somewhere on row 8.

Six fields appear in a vertical column. This is because the subfile you created,
currently specified a SFLPAGE (visible list size) of six.

2. Click the top field and hold the mouse button down and move it to row 8,
column 5.

Note the current row and column appear just above the field as you move it.

3. Move the cursor over to the right edge of the field. It turns into a
double-headed arrow. Hold down the mouse button and move it to the left.
The size of the field will be reduced. The current size will appear just above the
field. When the size is 3, let go of the mouse button.
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The toolbar at the top of the Design page is a very convenient place to monitor
and manipulate the currently selected parts.

4. Rename the record from RECORD1 to EMPLSTSFL and the field from FIELDI to
OPCODE by typing over the text in each list.

@ EERD N EleERE R
‘Z'Igmreall indicatars .El gg@ Y | 0 E Eaﬁﬁ. 4

5. Click the Color palette Bl button and select pink to change the color of the
field.

6. Click the [Z] button to change the usage of the field to input.

[

Now you will create an additional column in the subfile.
Creating an additional output column
Now you want to create an output column.

To create an additional output column:
1. Position the cursor at row 8, column 9.

Note: The bottom right of the CODE Designer window shows the current

83 .

If you can’t see the field with the cursor position on your screen, click the
Maximize button in the top right corner of the screen. You can use the cursor
keys or the mouse to move the cursor.

cursor position

2. If you are creating a long field with an exact length, the SDA syntax can be
easier. Type:

+0(30)

and then press the back arrow (not Backspace!) to select the text you created.
Notice from the Selected DDS page that you have created a text constant
containing +0(30).

3. Click the Convert string to field & button on the toolbar or press F11 to
convert the SDA syntax into a character output field of length 30.

JemPLSTSFL x|l <=

Ilgnue all indicators

|
4. Rename the new field to ENAME using the toolbar. This will show the name of
the employee.
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5. Position the cursor to 8, 41.

6. Now you will add a field for the employee’s salary. Type
$666,666.66

and then press the back arrow.

Now wouldn’t it be better if we could just tell the Designer what we wanted
the number to look like and then have Designer generate all the cryptic
EDTCDESs to make it happen?

7. Press F11 to convert this field into an output numeric field with comma
delimiters, two decimal positions, a currency symbol and no sign. Look at the
Selected DDS page to see what was generated for you. Impressive!

& @EMF‘L_STSFL MERLS
B

Yl larore allindicators

E elec{ed"DDg.l. ‘Wweb Settings I Eun'meris] Emor Iisl]

| EA SALARY 8Y 20 8 41EDTCDE(1 SE S

8. Rename the field to SALARY and change its color to yellow, using the toolbar.

9. The subfile seems compacted to the left. It would be better to space it out

evenly. Just select a field and click the space horizontally ¥ button on the far
right side of the toolbar. The other alignment buttons will align fields, left,
right, center and top.

[ BRSNS =R G ENER= M
Ellgmreallhdicaturs T E@E. | 2 E s ;
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Just below the palette on the left there are three spin buttons. The top one,
Subfile size, specifies the total number of entries in the list that will be filled
in by the application. The second one, Subfile page size, is how many entries
appear on the screen.

10. In the Subfile size field, type 300.

11. In the Subfile page size field, type 9.

12. Click in the Design page.

Delais | MAIN_MENLU | EMPL_SELCT EMPL_LIST iswme| Listing |

@E SEER s (B O
[Z;'Igwc-le all indicatons _'i__;l ’_E

SRR 4--

The Design page is updated accordingly.

You have added some columns to the new subfile record screen and now you are
ready to begin [“Exercise 7.8: Switching between multiple records.”|

Exercise 7.8: Switching between multiple records

Before you begin, you must complete [“Exercise 7.7: Adding fields to the subfile]
[record” on page 126

Now let’s fix up the subfile control record. The group you created contains 2
records. You can verify this by looking at the record list in the toolbar:

EMPLSTSFL

RECORD1CTL

1. Change the current record by selecting RECORDICTL from the record list or
click next record ﬂ or press Alt+End.

The fields in the subfile still appear so that column heading can be lined up,
but they appear at half-intensity so that they can be distinguished from the
fields of the current record.
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2. Rename the record to EMPLSTCTL using the toolbar. Let’s provide a "Position to’
entry in the subfile control header.

3. Position the cursor at 4, 9 and type:
Position to:

1 a2 CI

-

Now you need an employee name field.

You could create a named field with the right characteristics like you did in the
subfile, or you could create a source reference using the Create source reference

field 2] button in the palette, or you could reference the original database field
using either the Create database reference field button or the El Create
database reference field(s) by selection &% button. But there is an even simpler
way. Use copy and paste!

Copying the employee name field

To copy the employee name field:

1. In the DDS tree expand the EMPMNT record.
2. Click the ENAME field and press Ctrl+C.
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‘Project Related'

(The pop-up menu or Edit menu shows the Copy menu item as well).
3. Position the cursor to 4, 23 and press Ctrl+V. Now that was easy!
4. Click the field and change the name from ENAME to POS_TO.

Detas | MAIN_MENU | EMP?SELE’Fchl Listing |
mL’é!EMPLSTCTL =[=] =] Pos 1JJE3| o H([z]o (=1 i
- E[Z R [BE BT IC(EN |

You have fixed up the subfile records to add an employee name field with a
position to entry opposite this field and you are ready to begin
[Adding field error handling.”]

Exercise 7.9: Adding field error handling

Before you begin, you must complete [“Exercise 7.8: Switching between multiple]
[records” on page 129

Let’s put in some error handling for the ‘position to employee name’ field. If the
employee name is not found in the database, the program will set on indicator 60.
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In this case the field should turn red, reverse image and position the cursor to it.
Now wouldn’t it be better if you had something easier to remember than some
arbitrary number from 1 to 99.

To set indicators:

1. Click the Change named indicator sets %l button on the Design page toolbar
(or press F7.)
The Named indicator sets window opens.

2. In the Settings name field, type: Not Found.

3. Click Create.

x|
Indicators

IO G P20 8 T PG S0 FEATE | 7O T P BAI an

IE 0 E s R A E SE e E T = e = 3
It 22N 22 0 32T 42 (52 62T 72T 82 a2
el Eher mbel mliesl Bl e mlE ek |l ml sl 3 Es
Jo 040 4 24 T 134 T 44 T 64 G4 T |74 T 64T 194
IF s G E 2alE s a0 mE a7 R AEE 8h
- 05T 16 2636 46 560 66T 76 BT 96
Jo 07 8 7R 270w 300 4700 o7 G T |77 00 | 87 T 97,
[T 0B 18 28" 38 48[ 6B (6B I” 78| B[ 38
S rog = e 29 = 13 = g = 5 = 63 = | ¥ai = 8eiE | 9g

Checked indicatois are: & [n € 0ff

Seltings namé INotFauncI ) Create |
] Il indicatol Henam |
nore all in IG | _|'_ nane
Delete |

&pplyl Eancall Help I

4. Select the check box next to 60 and click OK.
The Not found indicator set is now in effect. The Design area is shown as if
indicator 60 was on and all other indicators were off. The Design page toolbar

shows the current indicator set in the Select named indicator set list on the
bottom left.

[&] [FevresTor :j|sﬁ|q|p|]ms_ﬂ3 ==
5. Now select the POS_TO field.

6. On the toolbar, select the color red and the display attributes reverse image
and position cursor. (The set of toolbar buttons representing the current
display attributes is found just below the Color button).

The toolbar should look as follows:

B SI(E) ()oE) [

7. Examine the DDS generated in the Selected DDS page.
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Selected DDS |W‘eb Settings | Comments | Erorlist |

A POS_TO R B 4 23
& 60 COLOR(RED)
& REFFLD ( RCEMP~ENAME *LIBL/El
& 90 DSPATR(FR)
& &0 DSPATR(RI)
i 60 DSPATR(PC)
Kl

Notice that all the new keywords were created with a condition of 60. (The
DSPATR(PR) was pasted with the field originally).

8. Now let’s try it out! From the Select named indicator sets list, select All
indicators are off.

@@EMPLSTCTL ~l[E«]#])Pos0 =[] [ & [z]o]8]
e E—-| A~ B |

Wow! This really works!
9. From the Select named indicator sets list, select Not found.

The field appears red and reverse imaged.

You have added error handling to the position to employee name field and you are
ready to begin [“Exercise 7.10: Accessing field properties.”|

Exercise 7.10: Accessing field properties

Before you begin, you must complete [“Exercise 7.9: Adding field error handling”]

Second to the direct manipulation and the toolbar on the Design page, the easiest
and quickest ways of getting access to the properties of a field, record, or entire file
is the Properties notebook.

The Properties notebook lets you view and update the properties of the currently
selected DDS object. You can open this notebook from any view, pop-up menu, or

menu of the CODE Designer.

The Properties notebook is modeless. When you change an object’s properties, the
selected object changes immediately.

You can get to a Properties notebook from the Selected menu, by pressing F4, or
double-click on anything in the DDS tree or the Details page or Design page.

To open the Properties notebook:
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1.

In the DDS tree, click the record SELECT and press F4 to see the Record
properties.

20X

| *€ Record properties

s | CA/CF | Styles |
Record |5ELECT
Type |Standard

Modified ||:BJ"291'92
Mumber of fields [T4 [ Inawindow
Description |

As you select different items, the Properties notebook will continuously update
itself to show you the properties of the selected item.

Click the *DATE field in the SELECT record. (You may have to move the
Properties notebook out of the way.) This field has a different set of pages
describing its properties.

= 1_-:_] <R154004 =R SELABKXIC
. 2 File Keywords
S s PRINT
G~ INDARA
Lo CADE
-~ Ome CADG
(=) 4% SELECT
=] Record Keyword:
O BLINKE
O BLARM
#-A 'PRGOL
A Time R...System
# @
#-A 'Mairte,,.ection’
() *TIME

3. Change the year from 2 to 4 digits. Select the Length of year check box.
4. Select 4 digits from the list.

i Field properties

Basics | Ntthutesl Colar | Ecﬁling| indicatusl

[~ Source of date
v Length of year (&N

Sample
MDD

~ Position
Size Row  Calumn

2axg0 [ 2E4[ 70
il Hl B

Description |

|

Notice how the sample is updated on the Properties notebook.

To test the Design page, click the MAIN_MENU tab in the workbook and look
at the upper right corner of the screen. The year now has 4 digits.

Click the EMPAPL field in the SELECT record. On the Field properties
notebook click the Basics tab.
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On this page you can change the field’s name, usage, length, type, and screen
position. The other pages give you quick access to other properties of this field.

g Field properties ) e B

Field
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e
Lizage Shift
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Length Position
Total Dec Size  Row  Column
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=

Width

Description |

l

You have seen the record properties for the record SELECT and changed the length

of year to 4 digits and you are ready to begin [“Exercise 7.11: Adding new|

Exercise 7.11: Adding new keywords

Before you begin, you must complete [“Exercise 7.10: Accessing field properties” onl|
iae 133.

CODE Designer helps you manage the visual aspects of your displays and reports.
But you also need to access the full power of DDS. You need to access keywords.

To add keywords:
1. Click the EMPAPL field in the DDS tree.
2. Press F5 or right-click and click Insert keywords on the pop-up menu.

[ (@) <ROS400A>RSELABRXQDDSSRC(MSTDSP o ||| Details |Mﬁ
[ pmleRiladiyyiords

Ler v

o Record Keywords Keypword
- E-A PRGOL

B A TimeR...System’

- @[y *oaTE

@A Mainte...ection'

e Insert figld 3
] PRIAP

i gcification  Alk+H
- ®-A Projed
. ) RSMAF
| B-A Reasa Chri+¥
L@ 1 EMESS Copy Chrl+C

You see the Details page for the EMPAPL field and the Create keywords tab is
added to the Utility notebook. This page shows you the subset of keywords
that are allowed for the selected file, record or field and it takes into account
the field’s type, usage, shift and what record it is in. It is very powerful to
know exactly what your options are. This information cannot be quickly
ascertained from the Reference manual.
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3. With the EMPAPL Properties notebook at the Basics page, click the numeric
field [& button to change the field to numeric type.
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Notice that the list of keywords in the Create keywords page has changed.

4. Click the el button to change the field back to alphanumeric.
Notice that the list of keywords in the Create keywords page has changed
again.

5. Click the ALIAS keyword and press F1.
The DDS Reference help for the ALIAS keyword appears.

Tip: CODE Designer has lots of on-line help. Press F1 anywhere you want to
see help for an item, icon or notebook. You will see help relevant to what you
are currently trying to do. From the Help menu you have quick access to the
DDS Language Reference as well as several other useful sources of information.
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ellemute System Explorer DDS Reference =

© Classic iseries tools inforr,
& Remote System Explorer

ALIAS (Alternative Name) Keyword for Display Files

Use this field-level keyword to specify an alternative name for a

field. When the program is compiled, the alternative name is

brought into the program instead of the DDS field name. The high-  —
level language compiler in use determines if the ALIAS name is 1
used. Refer to the appropriate high-level language reference manual
for information about ALIAS support for that language.

The format of the keywaord is:

ALILAS (alternative-name)

< | 2

B | =7 Referto DDS Syntax Rules for ALIAS naming conwventions. :l

6. Minimize the Help window.
7. In the Create keywords page, double-click the INDTXT keyword. (You may

have to scroll to the right to find it).

The keyword is created with default values which can be changed when you
want.

Double-click the INDTXT keyword again.

The keyword is created with the same default values creating a conflict.
_Keyword | Parame...| |

SwEDTCDE 3

Sw|NDTKT '
SwINDTKT '

9. Close the Keyword Properties dialog.

You have seen the help on the ALIAS keyword, added INDTXT keywords and you
are ready to begin [“Exercise 7.12: Verifying the source changes.”|

Exercise 7.12: Verifying the source changes

Before iou begin, you must complete [“Exercise 7.11: Adding new keywords” onl|
page 135.

You have just added a new record and some new fields to your DDS source.
Everything that the CODE Designer adds to your DDS source is certain to have the
correct syntax. Now you need to make sure that there are no semantic errors. You
just introduced one in the last exercise by creating two INDTXT keywords
describing the same indicator.

To verify your source:

1.

Click Tools > Verify file (or click the verify &/ button on the main toolbar) on
the CODE Designer menu.

m <R0OS400A >RSELABXX/QDDSSRC{MSTDSP) - CODE Designer

Fila Edit Wiew Insert Selected Tools Help

P E=0 @)
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The DDS source is checked using the same verifier that the CODE Editor or
LPEX Editor uses. A message appears on the status line at the bottom of the
Designer stating that the verify process completed with errors.

2. In the DDS tree, there is a trail of red X’s leading to the problem.

El @ BDS‘%UD?5\>F{SELABXXJ’QDDSSRC(MSTDSF"_I
T 0= File Keywords

- G EELECT
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@A PRGOL

- #-A Time R...System'
=3 *DaTE

. #-A 'Mainte...ection’

) e

i & A ploy...enance’
- PRIARL

The file icon has a red X, as does the SELECT record, the EMPAPL field and
finally the second INDTXT keyword.

3. Click the MAIN_MENU tab in the workbook.
The EMPAPL field is highlighted in red.

4. Click the Listing tab in the workbook.
This page shows you the listing generated by the most recent program verify. A
warning message is buried somewhere in the listing but it’s not easy to find.

5. If there are problems, they will show up in the Error list page in the Utility
notebook. It behaves exactly like the Error list in the CODE Editor or LPEX
Editor. Click the Error list tab.

6. Double-click the warning DDS7861 in the Error list. (Press F1 to see detailed
help on the message).

The Source page appears and the cursor is placed exactly where the error is in
the source. The Source page is a tokenized read-only view of the current state
of the DDS source. Read-only? Wouldn't it be great if you could just clear the
error right here. There are some things that are just plain faster in the editor
and many others that are faster in the visual environment. It would be great to
switch between the two modes at the push of a button. Well, let’s just do that.
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You have verified your DDS source and have identified an error in the source and
ou are ready to begin [“Exercise 7.13: Switching between designing and editing the]
_

Exercise 7.13: Switching between designing and editing the screen

Before iou begin, you must complete [“Exercise 7.12: Verifying the source changes”|

To switch between the Design mode and the Edit mode:

1. Click the Edit DDS source @l button or click File > Edit DDS source from the
Editor menu.
You now have access to the full power of the editor.

2. Explore the Edit and View menu items.

3. Press Ctrl-F to open the Find/Replace window.
4. In the Find field, type INDTXT and click Find.
Editor - Find and Replace _I __)ﬂ
Find £
Replace with |
' Replace this occurrence ¥ Case sensitive
" Replace, then find pext [~ Pattern match
" Replace all occurrences v ¥Yrap
ey
m Replace | Options... I Cancel I Help I

5. Press Ctrl-N to find the next occurrence.
6. Delete the second INDTXT line. Type D in the number column and press Enter.
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You have edited the source to fix the error by switching to the editor and you are
ready to begin [“Exercise 7.14: Compiling your source changes and closing the]

|Designer. ”|

Exercise 7.14: Compiling your source changes and closing the
Designer

Before you begin, you must complete [“Exercise 7.13: Switching between designing]
[and editing the screen” on page 139)

Now you will compile the source on the iSeries just as you did in the Remote
Systems LPEX Editor and then close the Designer.

To compile your source:
1. Click File > Save from the Designer menu to save your source to the iSeries.
2. Click Tools > Compile from the Designer menu and then click No prompt (or

click the compile | button on the CODE Designer toolbar).

3. A message indicates when the compile is complete. Click OK in the Message
dialog. If you re-compile and run the payroll program, you will see the 4 digit
year change you made to the opening screen of the program.

Note: You will also see the message CPD7886W Field overlaps another field
with no conditions specified. You can ignore this message.

To close the Designer:
1. Click File > Exit from the Designer menu.

Now you are ready to review your knowledge of this module by taking the quiz.
You can also apply what you have learned in this module by completing the
practice tasks detailed in More practice.

Quiz

1. There is a graphical design tool that let’s you design your screens and reports
visually and then generate the DDS source for you. This tool is named:
a. Page Designer
b. CODE Designer
C. Screen Design Aid
d. None of the above

2. Match the item with its correct description.

Utility notebook

Design page

Properties notebook

Group

Contains several different tabbed pages

For visually designing screens

o ow®oo o

A collection of one or more DDS records that make up a single screen or
report

d. Access properties of a field, record, or entire file
3. The Utility notebook contains:
a. Selected DDS page
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Error list page
Web Settings page
Comments page

. All of the above

4. On the Design page, you can easily:
Create DDS objects
Edit DDS objects
Resize DDS objects
Move DDS objects
Create records
Create fields
Create constants

h. All of the above

5. Grouping records together allows you to work on one record while still seeing
the related records in the background. (T, F)

6. The Properties notebook is modeless. When you change an object’s properties,
the selected object changes immediately. (T, F)

7. The DDS source is checked using the same verifier that the LPEX Editor or
CODE Editor uses. (T, F)

8. You can switch between Design mode and Edit mode in CODE Designer. (T F)
9. You can compile source on the iSeries just as you do in the LPEX Editor. (T, F)

©®aoo
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More practice

Given your experience in using the CODE Designer from the Remote Systems
view, try creating a printer report. You can use the physical file specification
REFMST in member QDDSSRC in library RSELABxx. Take time to explore the
fields and information for this physical file. You may want to refer back to the
exercises in this module as you create your report. When you are familiar with the
file REFMST, you can create your printer file. Use the product online help to assist
you in this task.

Module recap

You have completed [Chapter 7, “Module 7. Designing screens,” on page 117 You
have learned how to:

* Open a DDS member for edit with CODE Designer
* Show file-level keywords and record-level keywords

* View the details of records, record-level keywords and field-level keywords
* View the design of the payroll application main menu

¢ Create a group from an existing record format

* Create a new group and add a subfile record and a subfile control record

¢ Add columns to the subfile record

* Add fields to the subfile control record

» Copy existing fields

* Set indicators to handle field errors

* View and update record and field properties

* View keywords and the properties of a keyword
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* Insert a keyword

* View help for a keyword

¢ Check there are no semantic errors in the DDS source
* View help for an error

* Launch the editor in read mode from the error list

e Launch the editor in write mode to fix the error

* Find a keyword in the source

* Save source changes

* Compile your source changes

* Close the Designer

You have learned about various aspects of the CODE Designer while modifying a
display file and now can learn more about the product and how it is packaged.
This is an optional module. Continue to [Chapter 8, “Module 8. Introducing the]
[product and Remote System Explorer (optional),” on page 143
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Chapter 8. Module 8. Introducing the product and Remote
System Explorer (optional)

This modules teaches you about IBM WebSphere Development Studio for iSeries
and its relationship to IBM WebSphere Development Studio Client for iSeries. You
learn which product makes up the host components and which product makes up
the workstation components. You recognize the iSeries application development
tools included with Development Studio Client for iSeries programmers. You then
are introduced to Remote System Explorer the launching point for iSeries
application development tools.

In this module, you will:

* Know the goals of the product

* Know the editions of the product

* Identify the host tools and the client tools

 List and describe the iSeries application development tools

Exercises

The exercises within this module must be completed in order:

* |“Introducing Development Studio and Development Studio Client”]

* |[“Introducing iSeries Application Development Tools” on page 144|

Time required

This module will take approximately 15 minutes to complete.

Introducing Development Studio and Development Studio Client

Development Studio Client is the ideal set of workstation development tools for
creating, testing, deploying and maintaining traditional and e-business applications
for your iSeries server. Development Studio Client is included with the
compiler-based server product, WebSphere Development Studio. The following
diagram illustrates the interaction between host and client tools:
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Development Studio Client is designed to help you:

1. Develop and maintain iSeries applications using the Remote System Explorer.
2. Develop Web-enabled front-ends to iSeries business logic.

3. Create GUI front-ends to iSeries business logic.

Both Development Studio Client and Development Studio Client Advanced Edition
are built on the Rational Software Development Platform. This platform offers a
fresh look and feel for the Eclipse workbench, and helps make it easier for you to
build, integrate, and extend your applications. The Rational Software Development
Platform offers a tutorials gallery and a samples gallery, to help you get up and
running with the product as quickly as possible. The platform also offers user
roles, which you can select from bottom-right corner of the Welcome view, (and
from Window > Preferences > Workbench > Capabilities) that customize and
simplify the user interface according to your programming role. These are just
some of the new features provided in the Rational Software Development Platform.

The product comes in two editions for iSeries programmers. Both editions of the
product are packaged with an additional base Rational product:

* Development Studio Client is packaged with Rational Web Developer. Rational
Web Developer includes support for Web services, XML development tools, and
core support for Java and Web development tools.

* Development Studio Client Advanced Edition is packaged with Rational
Application Developer. This base product provides end-to-end support for the
creation and maintenance of J2EE applications and Web services. It also provides
extensive support for Enterprise JavaBeans, EGL, and for Java messaging
services

You have reviewed the goals of the product and the product editions and you are
ready to begin [“Introducing iSeries Application Development Tools.”]

Introducing iSeries Application Development Tools

Before you begin, you must complete [“Introducing Development Studio and|
[Development Studio Client” on page 143
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Now, you know what the two flavors are of Development Studio Client and why
you would want to use each one. Next let’s look at those next generation iSeries
server application development tools. What are they and what do they do?

Remote System Explorer

You can manage your development tasks in the Remote System Explorer. This is an
enhanced and more flexible workstation version of Program Development Manager
(PDM). You can create and manage development projects on your iSeries system
from your Windows-based workstation with the Remote System Explorer and
iSeries projects. With these tools, you can connect to an iSeries remote host, view
iSeries libraries, files, and members. You can also launch the host compilers, the
workstation editor, a program verifier and various debuggers all from the Remote
System Explorer. This tool also supports other system types, such as UNIX(R),
Linux, and Windows.

LPEX Editor

Your program editing tasks are simplified with the Remote Systems LPEX Editor.
This is a powerful language-sensitive editor that you can customize. Token
highlighting of source makes the various program elements stand out. It has
SEU-like specification prompts for RPG and DDS to help enter column-sensitive
fields. Local syntax checking and semantic verification for your RPG, COBOL and
DDS source makes sure it will compile without errors on an iSeries system. If there
are verification errors, an Error List lets you locate and resolve problems quickly.
On-line programming guides, language references, and context-sensitive help make
finding the information you need just a keystroke away.

Shells and commands in the Remote Commands view

You can use the Remote Commands view to run and interact with commands and
command shells on universal systems. A universal system includes Windows,
Linux, and UNIX system types. Specifically, you use the view to:

* Run commands in a command shell
 Display and interpret the output of a program
* Enter input to a program

¢ Display and manage different commands and shells from the same view.
Multiple commands can be run in a single shell (one command at a time per
shell), multiple shells may be run on a single system, and multiple systems may
be running shells.

Whenever a command shell is launched or a command is run from the Remote
System Explorer, the Remote Commands view displays the output and provides a
way to work with that output.

Program Verifier

One of the most powerful and unique features of the Remote System Explorer is
the Program Verifier. Before you compile your code on an iSeries system, you can
ensure that there are no errors by invoking the Program Verifier. The verifier
checks for semantic (compile) errors on your workstation so that you can
guarantee a clean compile on the iSeries. Think of the host cycles you'll save. It is
especially handy when you are writing code but you are disconnected from an
iSeries system. You can do this because Remote System Explorer ported the parsing
and checking code from the iSeries host compilers to the workstation. The Error
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List window lists the errors that are found and their severity, inserts the error
messages directly into the source and helps you to navigate between the errors.

iSeries Debugger

With the Integrated iSeries debugger you can debug an application that is running
on an iSeries system. It provides an interactive graphical interface that makes it
easy to debug and test your iSeries programs. It is fully integrated into the
workbench. You can also set breakpoints before running the debugger, by inserting
breakpoints directly in your source while editing. The Integrated iSeries debugger
client user interface also enables you to control program execution. For example,
you can run your program, set line, watch, and service entry point breakpoints,
step through program instructions, examine variables, and examine the call stack.
You can also debug multiple applications, which may be written in different
languages, from a single debug window. Each session you debug is listed
separately in the Debug view.

CODE Designer

Using an editor to create and maintain DDS source for your display and printer
files can be a frustrating and difficult task. What would be great is a graphical
design tool that lets you design your screens and reports visually and then
generate the DDS source for you. Well, that’s exactly what the CODE Designer
does for you.

The CODE Designer interface was designed to help the novice DDS programmer
create screens, reports and databases quickly and easily without worrying about
the details of the DDS language, while at the same time letting the expert DDS
programmer get access to all the features and power of the language. CODE
Designer is not fully integrated into the workbench, but you can launch it as a
separate tool from the workbench.

You have identified the host tools and the client tools as well as the iSeries
application development tools and now you are ready to review your knowledge
of this module by taking the quiz.

Quiz
1. WebSphere Development Studio for iSeries:
a. Includes all four host compilers

b. Includes all four host compilers and the workstation-based tools named
Development Studio Client

c. Includes only the workstation-based tools named Development Studio
Client

2. WebSphere Development Studio Client for iSeries includes:
a. Rational Web Developer

b. Cooperative development environment (CODE)
c. VisualAge® RPG

d. Java tools

e. Web tools

f. WebFacing tool
g. All of the above
3. WebSphere Development Studio Client for iSeries Advanced includes:
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10.

11.

a. Rational Application Developer

b. Cooperative development environment (CODE)
c. VisualAge RPG

d. Java tools

e. Web Tools

f. WebFacing Tool

g. All of the above

Rational Application Developer includes support for:
Creation and maintenance of J2EE applications
Creation and maintenance of Web services
Enterprise Java Beans

Java Messaging Services

All of the above

Rational Web Developer includes support for:

®© o 0 T o

. Web services
. XML development tools

. Web tools
. All of the above

The editor can access source files on your workstation or on your iSeries
system directly. When a compilation or verify action results in errors, you can
jump from the compiler messages to an editor containing the source. The
editor opens with the cursor positioned at the offending source statements so
that you can correct them. (T, F)

a
b
c. Java tools
d
e

You can debug your program running on the iSeries system from your
workstation using the Integrated iSeries Debugger. (T, F)

Before you compile your code on an iSeries system, you can ensure that there
are no errors by invoking the:

a. The Remote System Explorer

b. CODE Designer

c. The IBM WebFacing tool

d. The LPEX Editor

e. The Integrated iSeries Debugger

f. Program Verifier

You can use the Remote Commands view to:
. Run commands in a command shell

. Display and interpret the output of a program

. Display and manage different commands and shells from the same view
. All of the above
The Integrated iSeries Debugger enables you to run your program, set line,

watch, and service entry point breakpoints, step through program instructions,
examine variables, and examine the call stack. (T, F)

a
b
c. Enter input to a program
d
e

The graphical design tool that lets you design your screens and reports
visually and then generates DDS source for you is:

a. The Remote System Explorer
b. CODE Designer
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c. The IBM WebFacing tool
d. The LPEX Editor
e. The Integrated iSeries Debugger

Module recap

You have completed [Chapter 8, “Module 8. Introducing the product and Remote|
[System Explorer (optional),” on page 143 You should now understand:

* What components make up Development Studio and Development Studio Client

* What components are included in Rational Application Developer and Rational
Web Developer

* What tools you use to manage your development cycle tasks
* What the benefits are of Remote System Explorer

Finish your tutorial by reviewing the materials in [Chapter 9, “Summary,” on page|
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Chapter 9. Summary

This tutorial has taught you how to maintain a payroll application using the
Remote System Explorer. You learned how to start the product and open the
Remote System Explorer perspective and how to use tools and views in this

perspective to connect to an iSeries system and edit, verify, compile and debug the

payroll application.
Completed Learning Objectives

If you have completed all of the modules, you should now be able to:
e Start the product and open the Remote System Explorer perspective

* Create a connection to an iSeries and select iSeries objects from this connection

¢ Use the Remote Systems LPEX Editor to edit source

* Verify and compile source in the Remote Systems LPEX Editor

* Debug your interactive payroll application from the workstation
* Modify a display file

* Recognize the product features and packaging

More information

For more information on the product and the Remote System Explorer, see
http:/ /ibm.com/software/awdtools/iseries.

Quiz answers

Here are the answers to each module quiz.

1 2 3 4 5 6 7 8
1d 1c 1d 1d 1c 1d 1b 1b
2e 2e 2T 2d 2T 2¢c 2 aa, bb, |2g
cd, de
3b 3e 3a 3g 3e 3T 3e 3g
4 aa, bd, |4c 4T 4T 4c 4b 4h 4e
cb, dc
5e 5T 5d 5T 5¢ 5T 5T 5e
6T 6¢ 6d 6T 6T 6T 6T
7d 7b 7e 7e 7c 7T 7T
8c 8T 8T 8T 8T 8f
9c 9a 9T 9T 9e
10a 10a 10f 10T
11b 11T 11b
12T 12e
13d
14e
15d
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16c

17b

18c

19T

20T
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Appendix. Notices

Note to U.S. Government Users Restricted Rights — Use, duplication or disclosure
restricted by GSA ADP Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A.
IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

Lab Director

IBM Canada Ltd. Laboratory
8200 Warden Avenue
Markham, Ontario

Canada

L6G 1C7

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp.
Sample Programs. © Copyright IBM Corp. 1992, 2005. All rights reserved.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Programming interface information

Programming interface information is intended to help you create application
software using this program.

General-use programming interfaces allow you to write application software that
obtain the services of this program’s tools.
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However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.

Warning: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks

IBM

iSeries
0S/400
RPG/400
Rational
VisualAge
WebSphere

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

ActiveX, Microsoft, SourceSafe, Visual C++, Visual SourceSafe, Windows, Windows
NT®, Win32, Win32s and the Windows logo are trademarks of Microsoft
Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group.

Linux is a registered trademark of Linus Torvalds.

Other company, product, and service names may be trademarks or service marks
of others.
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