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The Challenge

= Tools from different companies do not work well together

= Developers had [and still do!] better things to do than
integrate tools

= Tool vendors had [and still do!] better things to do than
reinvent the wheel

= No one vendor could do it all
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The Solution

= Eclipse project originally created by OTI and IBM

= Framework on which a variety of tools can be built
— Wide range of operating systems: Windows, Linux, Unix _._.

= Extensible, seamless tool integration — new tools easily added by
writing plug-ins

= Language independent

= Attracted a community of tool developers
— Now over 100 active vendor participants

= Effort transitioned into open source project
— IBM donated initial Eclipse code base
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Eclipse Overview: On the outside

eclipse
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Eclipse Overview: On the inside

Defined as a set of
contributions, a plug-in is
the smallest unit of
Eclipse functionality.
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Benefits of Adopting Eclipse Platform\

Decreased

maintenance

s

Tool
interoperability

Decreased
integration
costs

Support for

many roles and
tasks

reach 1,000,000
downloads!

Eclipse 3.1 took 40 days to

Now, that's quick uptake.

Decreased
learning curve

Easy transition
to new
projects
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So, what's IBM got to do with Eclipse?

* |IBM is a founding member of Eclipse

= Actively participates on Eclipse.org board of stewards and its working
subcommittees

» |BM builds on Eclipse V3.0 for many products:
— IBM Rational Software Development Platform
Rational Software Architect (RSA)
— Rational Application Developer (RAD)
Rational Web Developer (RWD)
WebSphere Development Studio Client for iSeries
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This is what IBM’s got to do with Eclipse: Packaging

iSeries
extensions for
application
development

Generic
application
development

( mebSphere Development WebSphere Developmeh
Studio Client Studio Client Advanced

Edition

{
E WebFacing, HATS, RSE } E EGL, SSO, JCA }

Rational Web Developer\ Rational Application

Developer

Java, HTML, Servlets, XML,
JSP, JSF, Web services, Unit

Portal, EJB, J2EE, UML,
< \ Test environment, database J Profiling J

E IBM Rational Software Development Platform ]

¥

Eclipse Platform V3.0 ]
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Who's on Board?

» Wide range of software vendors on Eclipse board

= Represent various development tool markets
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Next...

» Eclipse, workbench history, & IBM

=¥ = Workbench basics
= Components
= Online help

= Applying updates
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T

What's an IDE?

4

IT Synonyms: Often when
people refer to the IDE they
often call it a “workbench”.
These two terms are used

interchangeably.

» Integrated Development Environment (IDE) is a set of tools that
developers work with every day to construct and maintain software

= Evolved dramatically in the past few years

= Eclipse is the first IDE that offers an enterprise development
environment for non-Microsoft technologies

L
Enterprise
Development
/ Environment:
Platforms evolve
(integration APlIs,
partner
Contain more ecosystems
tooling (wizards,
code assist)
1st integrated L —
IDEs
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IBM Rational Software Development Platform

IBM branded IDE

Based on a 4-pronged infrastructure: Eclipse, Eclipse Modeling
Framework (EMF), MDD platform, & standard modeling approaches
(e.g. UML)

Includes products from all IBM Software Group brands (Rational,

WebSphere, Tivoli, DB2 and Lotus)
— Advantage of unifying all IBM Software Group development tools within a

single platform
Open and modular workbench
— Can purchase and adopt it in parts

Spans all capabilities of software development cycle
— requirements & analysis = deployment management

13
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Workbench component

Workbench is the user interface

Implemented by the workbench Ul plug-in

Plug-in defines and manages all object that you se

— E.g. menu and toolbars, dialogs, wizards

Ul paradigm centered around
— Perspectives
— Views
— Editors
Each Ul element has a defined role

— Editors work on resources in the workspace
— Views share information about their defined ‘input’

— Perspectives organize views and the editor ‘space’ to support defined tasks

14
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Workbench responsibilities

» Manages windows and perspectives

Eclipse Platform creates menu and tool bars

— Labels and icons listed in plug-in manifest

— Contributing plug-ins not activated

Eclipse Platform creates views and editors

— Instantiated only as needed

= Scalable to large numbers of installed tools
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Perspective |

Workbench: Overview
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Workbench: Overview .

| @ Frmote System Laplorer - LD SS0W._FPGLL - M Kational Software Development Platform.

41 Remote
System
View

Outline
View

- Properties Error List View
View

Welcome
View
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Workbench: Overview .-

« Ctrl+F6: Next Editor
» Ctrl+F7: Next View

« Ctrl+F7: Next perspective

Remote
System
View

| Properties |
View

Outline
ws!
View
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L1

Workb

LPEX

Editor

Resource
Navigator
view

Perspective
indicator

Properties
view

« F10: Main menu bar
« Shift+F10: Context menu
« Ctrl+F10: Pull down menu

Perspective
and

Fast View
bar

Stacked
views
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Next...

» Eclipse, workbench history, & IBM

» Workbench basics
~F = Components
= Online help

= Applying updates
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Workspace component

Local directory where the workbench stores all your
projects, files, folders

Location is set in the dialog that first opens when you
start the Workbench
— Can modify location by selecting File > Switch
Workspace.... (Eclipse V3.0)
S —
Workspace holds 1 or more top-level projects
— Projects map to directories in file system

{Files, Folders, Projects} termed resources

Resources are displayed in a tree structure of folders
and files

ﬁ U5 Mavigakor

v X
Eh +-1z% able
nis Q‘J Example
% 4= bin
-l = src
% —|-{z= com
{ —|-{z= example
3 =G h
classpath
Jproject
1 Test

21

Session ID: 490122 26 Ml | Workbench Basics

© 2006 IBM Corporation

21



‘ IBM WebSphere Software

Perspectives

= Perspectives are collections of views s

P b Sere Cosle o

and editors in the workbench

B-0-Q- |4

Hisncrn e Tha

= Provides a set of functionality aimed |
at accomplishing a specific type of
task, or working with a specific type
of resource
— e.g. RSE perspective is for
managing and working with remote
file system objects

= Name of the active perspective is
shown in the title of the window

= Can open, customize, reset, save,
and close perspectives
— Window menu

Each preference dialog has a
Restore Defaults button. Click
this button, to restores the
default settings.

000000000000000 ¢

B Mommcoe Syutem Coain

B M srsems
Do

« »

I
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Switching perspectives

There are two ways to open another
perspective:

1. Click the Open a perspective icon
in the top right corner of the
Workbench working area and select
the appropriate perspective from the
list

2. Select Window > Open
Perspective.

In either case, there is also an
Other... option

9

Perspectives require memory,

so it’s good practice to cl

ose

perspectives when not being
used to improve performance!

Mjiseries Projects

& [HRemote System Explorer

E WebFacing

Other...

B EERamobe Syste...

iSeries Project Mavi... | — O1

|

[ con 3

New Window

Show View

Reset Perspective
Close Perspective
Close All Perspectives

Navigation

Preferences

Customize Perspective. ..
Save Perspective As...

| AgRe

Open Perspective i TRiseries Projects

»
L) EE Remate System Explarer
E WebFacing

Session ID: 490122 26 Ml | Workbench Basics

© 2006 IBM Corporation

23



‘ IBM WebSphere Software

Tailor made perspectives...

Flexibility of the IDE allows you to open, customize, reset, save, and close
perspectives
— Window > Customize Perspective....

Customize
— Add, close, move, and resize views

— Window > Show View and select the view you would like to add to the currently open
perspective

Move
— Move a view to another pane by using drag and drop
— Views are stacked > use the tabs at the top of the view to switch between them
— Select a view's title bar, drag the view, and drop it on top of another view

Drag
— While you drag the view, the mouse cursor changes into a drop cursor
— Drop cursor indicates what will happen when you release the view you are dragging

— In each case, the area that will be filled with the dragged view is highlighted with a
rectangular outline.

= E.g. 2 = The view will dock to the right of the view under the cursor.

24
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Saving customized perspectives
come in handy in situations
where a development is being
shared between several
developers.

1{‘

... Tailor made perspectives

4. Fast View
— Appears as a button in 3 docked locations in the IDE [left, bottom (default) and right]
— Click the button to toggle whether or not the view is displayed on top of the other
views in the perspective.
5. Maximize/minimize a view
— Maximize a view to fill the whole working area of the Workbench
= Double-click the title bar of the view, press Ctrl+M, or click the Maximize icon
— Minimize a view so that only the tab is visible

= Click the minimize button in the toolbar of a view
6. Save

— Save customizations as your own perspective

= Window > Save Perspective As....
7. Restore

— Restore the currently opened perspective to its original layout
= Select Window > Reset Perspective.
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Views

¢ Ctrl+O: Opens the
outline view for the
currently selected type

Views provide information on an
object

Support editors and provide
alternative presentations or
navigations of the information in the
Workbench

— Outline view summarizes editor
content

Views augment other views

arme ot
TR SR TR EACHWDSCSRY)
Lie | vapage

— Properties view describes selection
in outline view

Extmrral descrptcre for fie CUSTOM Jres |

Access from Window menu
— Window > Show view § o

Lirs | iasaten L gormess ~
R T T T —
EASITRE. . tra!
O VELSUORGE. sl

EEsaafy

WDSC standard views include:
— Remote System Explorer, Outline,
Properties, Error List

26
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while using the Outline view by
clicking the refresh button at the top
of the view.

, « Periodically refresh your source
<

Views: Outline

= Great resource when you want to edit ILE RPG, COBOL, or

3 Global Definibons

DDS source =L ries
® «% MSTDSP : WORKSTN (Externally Descrit
. B f = =] EMPMST : DISK (Externally Described )
— View is also available for Java = Reawe
. . 3 ) . ) # ff EMPNO : Packed Decimal (5,0)
= Displays a structural outline of items defined in the file currently e Emsc:charmarm
. . + EMAME : Character (30)
open in the editor 1 (1 EMCAT : Character (1)
N - . -1 EDEPT : Character (5)
— Icons are provided to indicate the type of element in the source, #1-1 ELOCN : Character (30)
such as a record (DDS), Fields (ILE RPG) - [} EUSRI : Character (3)

+-(1 ENHRS : Packed Decmal {3,1)

. . . . . . ape . - EPHRC : Packed De l (5, 1;
= Clicking an item in the outline will position you in the editor %Ewwp:@ i 0 1))

: H H 3 1 EPHRP ; Packed Decimal (7, 1)
view at the line where that structure element is defined st e i

1 EPNRY : Packed Decimal {7, 1)

= Uses: {1 EPNRP : Packed Decimal (7,1)
1. Check definitions in the Outline view instead of jumping back j,' if
and forth in the source between the calculations and the @ ;:;
definitions .o
. . . . *-<=| PRIMST : DISK (Externally Described )
2. If you notice that a definition is incorrect, click the definition in -::; RSNMST : DISK (Eita:vzl\y-f et )
the outline view to quickly jump to the appropriate place in i E ;‘Z‘tm
your source, without having to search for the definition. o G [
= Subroutines
3. Quickly view the return and resolved values listed beside your - B ACDESR
130
procedure prototypes G L
s s nen .

27 ‘ Session ID: 490122 26 MI | Workbench Basics © 2006 IBM Corporation




‘ IBM WebSphere Software

Views: Tasks

Displays system-generated

» Right-click in the gray border at the
left of the editor area, beside the line
of text or source code

» Select “Add Task”

errors, warnings, or
information associated with
a resource

Can also display manually
added tasks
— Optionally associated with
aresource

Ability to filter tasks:

— See only problems logged
by the Workbench,

— Tasks that you have

logged as reminders to
yourself

— According to which
resource or group of
resources they are
associated with, by text
string within the

Description field, by Priority

problem severity etc. indicator

Tasks view

28
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Views: Bookmark

» Right-click in the gray sidebar to the
left of your code in the editor

» Select “Add Bookmark”

« Enter the name of the bookmark and
click OK.

Bookmarks are another simple way to navigate to resources that you frequently use
Displays all bookmarks in the Workbench
— created bookmark is indicated by the symbol in the marker bar

Double-click the bookmark in the view to open the file and navigate to the line where the
bookmark has been created

£ - i b C] Ad 8 1 e-0-%- 9 RIS £l Hrerorsme.,.  *
® " =0 . [ mamow o x N [=]j[E T— % ~ -0
1 it
# ceadianitensadin ] Dooiplon | mesoree | 2 Folder Logaten
cacth 616260 | 010500000000 C.. PAROLA.  RemeteSpsioraTom. ke 105
s10300 013400000000 C... PATROLR.. HemcteSystenTem.. b 134
010400
= % 0l o20800
—_— 010600
T e ovi || Bilogoo
a. 71020800
010900
011000
o100
Liize0
011300
llo21400
611500 =
011600 ¢
011700 ¢
£ 4 > -
'3
® I
i
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Views: Navigator

= Navigator view provides a hierarchical view of the
resources in the Workbench

= Project type is noted by the icon

= From Navigator you can open files for editing or
select resources for operations such as exporting

— Right-click on any resource in the Navigator view to
open a pop-up menu that allows you to perform
operations

— e.g. copying, moving, creating new resources,
comparing resources with each other, or
performing team operations

iSeries Project.., [PENETTIEITEE] A

F ii=s
7 (29 AuctionVEOEAR %
- 5=% AuctionVE0ETE
=52 AuctionV60EIBClent
- bin
B2 src
=] .classpath
project

=] .runtime
128 AuctionVEOUser Admin
1123 AuctionVE0UserAdminEAR
= AuctionVeQiveb
&l = AuctionVe0WebService
-l Empty
41123 EmptyEAR
#-4=> OIDGenerator
- 52 OIDGeneratorClient
5= OrderEntryExample
4123 OrderEntryExampleEAR
Bl Test
il 23 TestEAR
GR= g T=cioroject]
== FILES
=2 iseries_srcpf_metadata
" |5 .iseries_srepf_properties
|=| Jiseries_project_properties
Z] .project
1 [22 WebAuction
523 WebAuctionEAR
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T

Projects

I
&

Unless otherwise specified,
projects are created in the
workspace directory. When
projects are deleted, you have the
choice of also deleting the
contents or not.

Top level of organization of your resources in the workbench

— Contains files and folders

Used for building, version management, sharing, and organizing

resources

May contain session and persistent properties, settings for
environmental variables, and references to other projects

You can create different kinds of projects with different structures

— e.g.Java, Web, WebFacing, iSeries
The type of project specifies its properties

To create a project:
— Select File > New > Project....

31
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You can upload all local
source physical files and
members created or imported
S into an iSeries project from
the Remote Actions menu.

iISeries projects

» An iSeries project represents the starting point for any development

» Two required properties (or attributes):

1. An iSeries connection: You must specify an iSeries connection that
you want to associate with the iSeries project

2. An associated library: The associated library is a single remote library
on the iSeries server that contains the build objects for a project

iSeries Projects perspective focuses on

disconnected development enionl i Q

Create a new iSeries project that maps to an iSeries
liorary.

» Projects are local containers for local source

Project name: ||

— Edit these resources locally projec contents

W Use default

— Push these changes to an iSeries | 5

server to submit a build of your project

| i concel |
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Editors

Editors appear in workbench editor
area

Contribute actions to workbench
menu and tool bars

Editor is dependent on type of file
being edited

— Open with >

Open editors are stacked and can
be activated by clicking the tab

Name of the file appears in the tab
of the editor

An asterisk (*) at the left side of
the tab this indicates that the
editor has unsaved changes.

« Ctrl+F6: Next Editor

« Ctrl+F5: Refresh

« Ctrl+Shift+V: Verify

« Ctrl+Shift+C: Compile

33
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Preferences

= Preference and properties
dialogs provide stored
values for workbench
components

— workbench, editors,
debug,

= You can change the default
settings to suit your tasks

= Accessed from
Window > Preferences

Each preference dialog
has a “Restore Defaults"
button. Click this button
to restores the default
settings.

Cacabites Exditor 1 postons
Colors and Fonts * Top ¢ Botiom
ComparePatch TR !
Maring Cempae & Top © Rotwom
Feftore
Fie Assocatorn Prrgestree stz et
Keys ket T Topleft = TopBight
Label Decorations.
Upkeed Arsacrees
Local Hatery |
Perspectves
sewch
Eartu onid Shutdos |
5 Ak ¥ Show text an the perspectve ber
Buld Orser
el I Show tradiional style tabs
Restore Defamits ey
===
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(a few of my favorite) Workbench preferences

1. Keys

— You can assign key
sequences & strokes to
many of the IDE
commands [shortcuts]

2. Editors

— Customize the
appearance and colors of
annotations, quick
differences, & structured
text editors

3. File Associations

— Add or remove file types
recognized by the
Workbench

— Associate editors with file
types in the file types list

& Preferences

© Preferences

= Warkbench A

File Associations

Appearance
Capabiities File types:
Colors and Fonts Bl may B
- Campare/Patch 5P+ reacine
=~ Editors o s R
- Annatations Moo
- Quick Diff Ve
- Structured Text Ed 2 S b
- Text Editor e
File Assodiations ‘I
Keys s
Label Decoratons & *maleinc
Linked Resources =t
Local History Fes
Perspectives Edrﬁ(
Search - b= sai @
Startup and Shutdomn - £
B Ant
" Buld Order Associated editors:
E-Help # Remote Systems LPEX Editor (default) Add..
- Install Update
i Interet >
i Iseries Projects 4]
- J2EE v Sf
< | B
Import... Expart... o

35 ‘ Session ID: 490122 26 Ml | Workbench Basics

© 2006 IBM Corporation

35



‘ IBM WebSphere Software

iISeries development preferences

1. iSeries Projects
— Specify logging options
for iSeries Projects
Perspective for tracing
and problem
determination

2. Build & compile

— Specify default build
style for all new projects
created

@
© preferences

Buid Order
Help
Instal fUndate
Internet
iseries Projects
Buid and Compie
JEE
[+ Java
- LPEX Editor
=-Remote Systems
Communications
=I- Debug
Host Java
Flle Cache
Flles
=l iSeries
Cathe
Command Executio
Command Subsyste
Job Subsystems
=] LPEX Editor Parsers
L
cosoL
DDS
1LERPG

< b

0EEE

Import... EXport...

[- B
RPG/400 |

W Automatic syntax checking
Iv Automatic uppercasing

Enter key behavior
M Repeat previous specification type
I Repeat previous operation code {if on fixed form C-Spedification)

I™ Set C-Spedfication cursor position
I™ User defined tabs

Restore Defaults Apply
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Capabilities not enabled will impact the
context of the IDE such as help system,
windows preferences, opening
perspectives, and the file new menus.

4

Capabilities

» Filtered slice of functionality, views, menus, and help based on task
— e.g. Java Developer, iSeries Developer

* The default setup does not enable a large proportion of the capabilities
such as team support for CVS, & Web Services development

r
& Select Perspective

» Enabled in a number of ways:

#5iDebug [k Vs Repository Exploring
FRjiseries Projects etz

1. Welcome view

This action requires the enablement of "Core Database Development”™.

Enable the required capability?

2. Window > Preferences
> Capabilities

I~ Biways enable capabiities and don't ask me again.

Details >>

3. Opening a perspective

{JResource
E07eam Synchronizing
@ web

[ WwebFadng

I~ showall
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User actions

= User defined server commands that run against resources such as files
and folders on your server

» Each user action has:
1. A unique name
2. A command (that might have substitution variables)

3. Substitution variables that are replaced with information from the resource
(such as its name) when the command is run

4. An optional comment used to describe the action in more detail
5. Various options to affect what happens when the command is run
— e.g. Prompt first
6. One or more file types that limit the action to specific types of remote
resources

» Expand the connection containing the kinds of resources you want to
act on, navigate to the subsystem that would contain those resources
— Select Work with > User actions > Work With User Actions window
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Team component

= Workbench provides tools to manage, share and
synchronize resources

= Eclipse platform includes CVS repository provider

= Share the folders and files of a project
— Each team member sends their changes to the
repository, and receives changes that were made by a
team member from the repository

= For iSeries, a single project is created for all the non-
remote resources managed by RSE

= Profiles are stored in that project; everything
belonging to a profile can be shared

= Profiles contain:

1. Connections -- including various subsystem
properties. User IDs and passwords are not
shared.

2. Filters, filter pools, and filters pool references

3. User-defined actions

4. Compile commands

Servers | Problems m’z =]

7| Team

-4 Connections
+ ﬁﬂ Filter pocls
= Bll, User actions

= fi#) dmarasco
=|=h= Connections
- Local
By torasifo
e 'ﬁo Filter pools
+ B—L User actions

== F'.emotes;,'stEmSComecboﬂs

@a-a iSeries Objects {iSeries)
ﬁ iSeries Jobg (iSeries)
‘ED IF5 Files (iSeries)
% Local Files (Local)
lED Files (Linux, Unix)
ll.Jn Files (Windows)
ll.Jn Files (Power Linux)
Ty Files (A1X)
+ @ Compile commands

*-[i4 Compile commg]

]
1

‘o,\

s )
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Next...

» Eclipse, workbench history, & IBM

» Workbench basics
= Components
=% = Online help

= Applying updates
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Help! The Information Center

Workbench provides a number of ways to provide help information
— Both inline and online

“Information Center” provides access to the documentation
— Eclipse-based help system

Able to browse, search, and print system documentation

Organized into sets of information that are analogous to books
— Includes a full text search engine for finding the information you need by keyword

Able to browse and print help content

= Remote Syssem Explocer Tiers. Slies posis, and iber gool
reterences

Help mechanisms available to all plug-ins
— All Eclipse based products including 3rd party tools
can contribute

Launch Information Center by:
1. Selecting Help > Help Contents —a== T

2. Pressing F1 [context sensitive help]

41

‘ Session ID: 490122 26 MI | Workbench Basics © 2006 IBM Corporation

41



‘ IBM WebSphere Software

Help! Context Sensitive Help and Infopops

= A small window of help associated with a particular workbench
component

= |t displays context-sensitive help and links to related help topics for the
component
» To use infopops:

1. Bring focus to the interface widget in question [by clicking on it or using the
Tab key

2. Press F1
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43

Help! Context Sensitive Help and Infopops

= A small window of help associated with a particular workbench

component

= |t displ

vs context-sensitive help and links to related helo topic

compo

Client workbench.
1. Br|

Presentation to provide you all the basics you need
. To use to know about the WebSphere Development Studio

for the

Tq

2 WebFacing - Advanced Topics
2. Prf

Introduction to IBM Web Tools and the iSeries

using the
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Help! Content Assist

» Provides a list of suggested completions for partially entered strings
= Available for ILE RPG, ILE COBOL, and C++, EGL and Java

= To use content assist:
1. Open a file you want to edit

2. From the Edit workbench menu, select Content Assist or press

Ctrl+Space

= Editor opens a list of valid code completions
3. Double-click on a possible completion from the list

D ALRRLY g

=)

DIM({numeric-constant)

or procedure-inkerface definition,

The DIM keyward defines the number of elements in an array; a
table; a prototyped parameter; or a return walue on a prototype

c

DIN(3)

T

¢ DATFMT(DATE-FORMAT {DATE-SEPARATOR])
e DESCEND
et DTAARA
W DTAARADATA-AREA-NAME)

T DTAARACYAR DATA-AREA-MAME]

SETON
OQSYSPRT T LR 11
o INSTALL 21
o z4 'OF'
o] 28 'THE'
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Help! Cheatsheets

= Special view that helps guide user through a series of complex tasks to

achieve an overall goal

e.g. create a hello world Java application

* Implement a task scenario spanning multiple smaller tasks and tools
used to create some application, object or code Includes actions and

text
=Launch from Help>Cheat Sheets
siSeries specific cheatsheets:

1.Edit, compile and run your RPG or
COBOL application

2.Debugging a 5250 RPG or COBOL
application
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Help! welcome view

First page shown when the product is first started
Provides information on a variety of getting started topics
Information offered in different formats

— Documentation

— Tutorials

— Samples

— Wizards
Maximized view within the

Remote System Explorer
perspective
Double-click tab

or click on arrow to
minimize Patomt St evspmant Patkem
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Help! Tutorials & Samples

= Number of tutorials & samples ship with the workbench
= Based on a variety of topics for a variety of skill levels
e.g. Create a connection [tutorial], WebFacing Order Entry [sample]

= Housed in “Tutorials Gallery” and “Samples Gallery”
1. Help > Tutorials gallery, Samples gallery

2. Welcome view > Tutorials, Samples
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Next...

» Eclipse, workbench history, & IBM

» Workbench basics
= Components
= Online help

~¥m Applying updates
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Get current: Rational Product Updater

» Rational Product Updater (RPU) is the new tool [V6.0] used for

updating all Rational based products
» Replaces Update Manager
» The RPU can be accessed in 2 ways:

1. Help menu in WDSC

IDE [t
i @ Welcome

2. Window’s Start menu

@ Help Contents

B o0 Rationdl

Tips and Tricks. ..

+ @ 1BM Rational Weh Developer V6.0 y
@ BM Webphere Development Studio Clhent for Beries V6.0
© Rational Product Updater

@ Ratianial Software Development latfarm

IBM Support Assistant

% Find and Install...

About IBM Rational Software Development PlatForm

33 Manage Configuration. ..
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‘ IBM WebSphere Software 18

Learn more about every
update and fix. Simply click
an update to display its

< corresponding ReadMe file in
the right hand panel.

RPU: Installed Products tab

» The RPU will display all Rational based products installed on the
machine
— Name, product version and install date for each

& Rational Software Development Platform Product Updates ~=1al x|

File Preferences Help

1BM Rational Product Updater

Search For updates far yaur installed products and instal the updates.

- Inetaled Praducts1 %, Updates | T optional Festures | () Rolbacks |

| product | verson | nstal Date | Detaled information
@ IBM Raational 'Web Developer 6.0.0.1 Jun 14, 2005 12:16 PM
"2 TEM WebSphere Development Studio Clent for eries 60,0 Jun 14, 2005 11:41 AM Select an iterm to see its detailed infarmation

Find Updates | Find Optional Features

- Description

Select an item to see its description,

50 Session ID: 490122 26 Ml | Workbench Basics © 2006 IBM Corporation




‘ IBM WebSphere Software

RPU: Updates tab

= Automatically searches for any missing updates for installed products

= Displays all fixes = including fixes that depend on other fixes

= Have control over which fixes to install

Fi Profermrces el

TBM Rational Praduct Updaters

& natinnal saltware Development Platfarm Peoduct Updates =100 %]

L it P | % st . [ Joptionsl Features | | ol |

[ | Proxxt | Wersiorn | treitod Dt

B = 5 108 Ravional web Developer %.0.0.1 Jun 14, 2005 1216 PM
=

=B
Bl # Inberin Fix 002 for Ruational Web Dev...

InstollUpdates | - | ror i Setestiors
Dmcrption

Interim Fox 0L For Rataonal Wi Devilopsr £.0.0.1

o
Dtaled Information
IEM Rational Web Developer Interim Fix :I
001

for Ratienal Web Developer, Version 6.0.0.1
@ Coppright TBM Carparstian 2004, 2005, All Bights Fessrvad

welcome to the IEM® Rationa® web Developer Inerim Fix 001
for Ratsorial Wirh Duiloper, Virsion 600 1

Table of contents
rarpquisie =
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RPU: Optional features tab

= Displays new functionality available for an installed product
= All listed items are ‘optional’

— Can continue to work effectively without the optional features

& natinnal saltware Development Platfarm Peoduct Updates =100 %]
Fin Prodermuce Hels

TBM Rational Praduct Updaters

)
.}‘"
Dtaled Information
IEM Rational Web Developer Version 6.0 :I

for IBM Rational Deployment Toolkit for
WebLogic feature - release notes

—
Instel Foatures | ='oot &7 | Clear Al Seloctions | @ Copyright IBM Corparstion 2000, 2005, All Rights Resarved
Description

A Rati " "
. v Prr—— o T BLA Vet S e :IechEJme;‘I?e IBIMo all ?‘:af_ﬂep oyr\:t?rl. Tolnllcu {nr o
Frature adds support For BEA WebLoge Server corfiguration, and depioying and testing 12EE obLogicl feature, powered by Echpse technology rebase
‘ppbeatiors on them, The featurs & deeply nbegrated with exstng I5M Fatonal Develogsn
‘Web tooks snd provides simlar unctionaity and ussbilty,

Table of contents

J 0 38 L[:]

52

Session ID: 490122 26 Ml | Workbench Basics © 2006 IBM Corporation

52



‘ IBM WebSphere Software

RPU: Rollback tab

= Allows you to remove [some] fixes already applied

= Some fixes are permanent, while others can be rolled back:

— As defined by development team

— e.g. some fixes are just too large and complex to allow rollback function

=10 x|
=
1 | verson | instal Dste ot et i
IEM Rational Web Developer Interim Fix :I
001
for Fatisnal Web Developer, Version 6.0.0.1
@ Capyright 1BM Carparition 2000, 200%. AN mights Ras.
L] L3
. = . > ‘Wiskcorns to the IBM® Rationar® Wb Doveloper Interim Fix 001
T T T for Rational Web Developer, Version 6.0.0.1

Table of contents

i Fix 001 For Raational Wl Dervslopes 6.000.1

=
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IBM WebSphere Software

Now that you know everythin
got any questions?

g,
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Trademarks and Disclaimers

© IBM Corporation 1994-2006. All rights reserved.
References in this document to IBM products or services do not imply that IBM intends to make them available in every country.

The following terms are trademarks of International Business Machines Corporation in the United States, other countries, or both:

Instruction: Refer to the following URL: http://iwww.ibm.com/legal/copytrade.shtml. Edit the list below, IBM subsidiary statement, and special attribution
companies which follow so they coincide with your presentation.

ASI400 e-business on demand i5/08
AS/400e 1BM 0S/400
eServer 1BM (logo) System i5

@W iSeries

Rational is a trademark of International Business Machines Corporation and Rational Software Corporation in the United States, other countries, or both.

Intel, Intel Logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo, Celeron, Intel Xeon, Intel SpeedStep, ltanium, and Pentium are trademarks or registered
of Intel C orits in the United States and other countries.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Java and all J based are of Sun , Inc. in the United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of others.

Information is provided "AS IS" without warranty of any kind.

All customer examples described are pi as of how those have used IBM products and the results they may have achieved. Actual environmental costs and
performance characteristics may vary by customer.

Information concerning non-IBM products was obtained from a supplier of these products, published announcement material, or other publicly available sources and does not constitute an
endorsement of such products by IBM. Sources for non-IBM list prices and performance numbers are taken from publicly available including vendor and vendor
worldwide homepages. IBM has not tested these products and cannot confirm the accuracy of performance, capability, or any other claims related to non-IBM products. Questions on the
capability of non-IBM products should be addressed to the supplier of those products.

All statements regarding IBM future direction and intent are subject to change or withdrawal without notice, and represent goals and objectives only. Contact your local IBM office or IBM
authorized reseller for the full text of the specific Statement of Direction.

Some i ici future Such ion is not intended as a definitive statement of a commitment to specific levels of performance, function or delivery
schedules with respect to any future products. Such commitments are only made in IBM product The ion is here to icate IBM's current
and development activities as a good faith effort to help with our customers' future planning.

is based on and projt using standard 1BM ina lled i The actual or that any user will experience will
vary depending upon considerations such as the amount of multiprogramming in the user's job stream, the I/O i ion, the storage i and the workload processed. Therefore,
no assurance can be given that an individual user will achieve or to the ratios stated here.
shown are of il Changes may be incorporated in production models.
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