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The Challenge

Tools from different companies do not work well together

Developers had [and still do!] better things to do than 
integrate tools

Tool vendors had [and still do!] better things to do than 
reinvent the wheel

No one vendor could do it all
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The Solution

Eclipse project originally created by OTI and IBM

Framework on which a variety of tools can be built 
– Wide range of operating systems: Windows, Linux, Unix etc.

Extensible, seamless tool integration – new tools easily added by 
writing plug-ins

Language independent

Attracted a community of tool developers
– Now over 100 active vendor participants

Effort transitioned into open source project
– IBM donated initial Eclipse code base
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Eclipse Overview: On the outside

If you only get to show one slide, this is the one that best captures “The Big Picture”.
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Platform Runtime

Workspace

Help

Team

Workbench

JFace

SWT

Eclipse Project

Java
Development

Tools
(JDT)

Their 
Tool

Your 
Tool

Another
Tool

Plug-in
Development
Environment

(PDE)

Eclipse Platform

Debug

Defined as a set of 
contributions, a plug-in is 
the smallest unit of 
Eclipse functionality.

Eclipse Overview: On the inside

If you only get to show one slide, this is the one that best captures “The Big Picture”.
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Benefits of Adopting Eclipse Platform

Tool 
interoperability

Tool 
interoperability

Decreased 
maintenance 

costs

Decreased 
maintenance 

costs

Decreased 
integration 

costs

Decreased 
integration 

costs

Support for 
many roles and 

tasks

Support for 
many roles and 

tasks

Easy transition 
to new 

projects

Easy transition 
to new 

projects

Decreased 
learning curve

Decreased 
learning curve

Eclipse 3.1 took 40 days to 
reach 1,000,000 
downloads!  

Now, that’s quick uptake.
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So, what’s IBM got to do with Eclipse?

IBM is a founding member of Eclipse

Actively participates on Eclipse.org board of stewards and its working 
subcommittees

IBM builds on Eclipse V3.0 for many products:
– IBM Rational Software Development Platform

– Rational Software Architect (RSA)

– Rational Application Developer (RAD)

– Rational Web Developer (RWD)

– WebSphere Development Studio Client for iSeries
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Eclipse Platform V3.0Eclipse Platform V3.0

IBM Rational Software Development PlatformIBM Rational Software Development Platform

WebSphere Development 
Studio Client

WebSphere Development 
Studio Client

Rational Web DeveloperRational Web Developer

Generic 
application 
development

iSeries 
extensions for 
application 
development

WebSphere Development 
Studio Client Advanced 

Edition

WebSphere Development 
Studio Client Advanced 

Edition

Rational Application 
Developer

Rational Application 
Developer

Java, HTML, Servlets, XML, 
JSP, JSF, Web services, Unit 
Test environment,  database

Portal, EJB, J2EE, UML, 
Profiling

EGL, SSO, JCAWebFacing, HATS, RSE 

This is what IBM’s got to do with Eclipse: Packaging
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Who’s on Board?

Wide range of software vendors on Eclipse board

Represent various development tool markets
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What’s an IDE?

Integrated Development Environment (IDE) is a set of tools that 
developers work with every day to construct and maintain software

Evolved dramatically in the past few years

Eclipse is the first IDE that offers an enterprise development 
environment for non-Microsoft technologies

1st integrated 
IDEs

1st integrated 
IDEs

Contain more 
tooling (wizards, 

code assist)

Contain more 
tooling (wizards, 

code assist)

Platforms evolve 
(integration APIs, 

partner 
ecosystems

Platforms evolve 
(integration APIs, 

partner 
ecosystems

Enterprise 
Development 
Environment:  

Enterprise 
Development 
Environment:  

1990 2005

IT Synonyms:  Often when 
people refer to the IDE they 
often call it a  “workbench”.  
These two terms are used 
interchangeably.  
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IBM Rational Software Development Platform

IBM branded IDE

Based on a 4-pronged infrastructure: Eclipse, Eclipse Modeling 
Framework (EMF), MDD platform, & standard modeling approaches 
(e.g. UML)

Includes products from all IBM Software Group brands (Rational, 
WebSphere, Tivoli, DB2 and Lotus)

– Advantage of unifying all IBM Software Group development tools within a 
single platform 

Open and modular workbench
– Can purchase and adopt it in parts

Spans all capabilities of software development cycle
– requirements & analysis deployment management 
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Workbench component

Workbench is the user interface

Implemented by the workbench UI plug-in

Plug-in defines and manages all object that you see 
– E.g. menu and toolbars, dialogs, wizards

UI paradigm centered around
– Perspectives

– Views

– Editors

Each UI element has a defined role
– Editors work on resources in the workspace

– Views share information about their defined ‘input’

– Perspectives organize views and the editor ‘space’ to support defined tasks
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Workbench responsibilities

Manages windows and perspectives

Eclipse Platform creates menu and tool bars
– Labels and icons listed in plug-in manifest

– Contributing plug-ins not activated

Eclipse Platform creates views and editors
– Instantiated only as needed

Scalable to large numbers of installed tools
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Workbench: Overview
PerspectivePerspective

[Contains animated elements]
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ViewView

Properties
View

Properties
View

Error List ViewError List View

Outline
View

Outline
View

Remote 
System

View

Remote 
System

View

Welcome
View

Welcome
View

PerspectivePerspective
Workbench: Overview

[Contains animated elements]
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ViewView

Properties
View

Properties
View

Error List ViewError List View

Outline
View

Outline
View

Remote 
System

View

Remote 
System

View

Welcome
View

Welcome
View

EditorEditor

• Ctrl+F6:  Next Editor
• Ctrl+F7:  Next View 
• Ctrl+F7:  Next perspective

PerspectivePerspective
Workbench: Overview

[Contains animated elements]
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Perspective
and
Fast View
bar

Perspective
and
Fast View
bar

Tool barTool bar

Resource
Navigator
view

Resource
Navigator
view

Stacked
views

Stacked
viewsProperties

view

Properties
view

Outline
view

Outline
view

Menu barMenu bar

LPEX
Editor

LPEX
Editor

Perspective 
indicator

Perspective 
indicator

• F10:  Main menu bar
• Shift+F10: Context menu
• Ctrl+F10: Pull down menuWorkbench: Overview

[Contains animated elements]
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Workspace component
Local directory where the workbench stores all your 
projects, files, folders

Location is set in the dialog that first opens when you 
start the Workbench

– Can modify location by selecting File > Switch 
Workspace.... (Eclipse V3.0)

Workspace holds 1 or more top-level projects
– Projects map to directories in file system

{Files, Folders, Projects} termed resources

Resources are displayed in a tree structure of folders
and files
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Perspectives

Perspectives are collections of views 
and editors in the workbench

Provides a set of functionality aimed 
at accomplishing a specific type of 
task, or working with a specific type 
of resource

– e.g. RSE perspective is for 
managing and working with remote 
file system objects

Name of the active perspective is 
shown in the title of the window

Can open, customize, reset, save, 
and close perspectives

– Window menu

Each preference dialog has a 
Restore Defaults button.  Click 
this button, to  restores the 
default settings.
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Switching perspectives

There are two ways to open another 
perspective: 

1. Click the Open a perspective icon 
in the top right corner of the 
Workbench working area and select 
the appropriate perspective from the 
list

2. Select Window > Open 
Perspective.

In either case, there is also an 
Other... option

Perspectives require memory, 
so it’s good practice to close 
perspectives when not being 
used to improve performance!
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Tailor made perspectives…

Flexibility of the IDE allows you to open, customize, reset, save, and close 
perspectives

– Window > Customize Perspective....

1. Customize
– Add, close, move, and resize views
– Window > Show View and select the view you would like to add to the currently open 

perspective

2. Move
− Move a view to another pane by using drag and drop
− Views are stacked >  use the tabs at the top of the view to switch between them
− Select a view’s title bar, drag the view, and drop it on top of another view

3. Drag
− While you drag the view, the mouse cursor changes into a drop cursor
− Drop cursor indicates what will happen when you release the view you are dragging
− In each case, the area that will be filled with the dragged view is highlighted with a 

rectangular outline.
E.g. = The view will dock to the right of the view under the cursor.
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…Tailor made perspectives

4. Fast View
− Appears as a button in 3 docked locations in the IDE [left, bottom (default) and right]

− Click the button to toggle whether or not the view is displayed on top of the other 
views in the perspective.

5. Maximize/minimize a view
− Maximize a view to fill the whole working area of the Workbench

Double-click the title bar of the view, press Ctrl+M, or click the Maximize icon
− Minimize a view so that only the tab is visible

Click the minimize button in the toolbar of a view 
6. Save

– Save customizations as your own perspective 
Window > Save Perspective As....

7. Restore
− Restore the currently opened perspective to its original layout

Select Window > Reset Perspective.

Saving customized perspectives 
come in handy in situations 
where a development is being 
shared between several 
developers.
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Views

Views provide information on an 
object

Support editors and provide 
alternative presentations or 
navigations of the information in the 
Workbench

– Outline view summarizes editor 
content

Views augment other views
– Properties view describes selection 

in outline view

Access from Window menu
– Window > Show view

WDSC standard views include:
– Remote System Explorer, Outline, 

Properties, Error List

• Ctrl+O:  Opens the 
outline view for the 
currently selected type
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Views:  Outline

Great resource when you want to edit ILE RPG, COBOL, or 
DDS source 

– View is also available for Java

Displays a structural outline of items defined in the file currently 
open in the editor

– Icons are provided to indicate the type of element in the source, 
such as a record (DDS), Fields (ILE RPG) 

Clicking an item in the outline will position you in the editor 
view at the line where that structure element is defined

Uses:
1. Check definitions in the Outline view instead of jumping back 

and forth in the source between the calculations and the 
definitions

2. If you notice that a definition is incorrect, click the definition in 
the outline view to quickly jump to the appropriate place in 
your source, without having to search for the definition. 

3. Quickly view the return and resolved values listed beside your 
procedure prototypes

• Periodically refresh your source 
while using the Outline view by 
clicking the refresh button  at the top 
of the view. 
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Views:  Tasks

Displays system-generated 
errors, warnings, or 
information associated with 
a resource

Can also display manually 
added tasks 

– Optionally associated with 
a resource

Ability to filter tasks: 
– See only problems logged 

by the Workbench,

– Tasks that you have 
logged as reminders to 
yourself

– According to which 
resource or group of 
resources they are 
associated with, by text 
string within the 
Description field, by 
problem severity etc.

• Right-click in the gray border at the 
left of the editor area, beside the line 
of text or source code 

• Select “Add Task”

Tasks view
Priority 
indicator

Task marker
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Views:  Bookmark

Bookmarks are another simple way to navigate to resources that you frequently use

Displays all bookmarks in the Workbench
– created bookmark is indicated by the symbol in the marker bar

Double-click the bookmark in the view to open the file and navigate to the line where the 
bookmark has been created

• Right-click in the gray sidebar to the 
left of your code in the editor

• Select “Add Bookmark”
• Enter the name of the bookmark and 

click OK.
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Navigator view provides a hierarchical view of the 
resources in the Workbench 

Project type is noted by the icon 

From Navigator you can open files for editing or 
select resources for operations such as exporting

– Right-click on any resource in the Navigator view to 
open a pop-up menu that allows you to perform 
operations

– e.g. copying, moving, creating new resources, 
comparing resources with each other, or 
performing team operations 

Views:  Navigator
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Projects

Top level of organization of your resources in the workbench
– Contains files and folders

Used for building, version management, sharing, and organizing 
resources

May contain session and persistent properties, settings for 
environmental variables, and references to other projects 

You can create different kinds of projects with different structures
– e.g. Java, Web, WebFacing, iSeries

The type of project specifies its properties

To create a project:
– Select File > New > Project....

Unless otherwise specified, 
projects are created in the 
workspace directory. When 
projects are deleted, you have the 
choice of also deleting the 
contents or not. 
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iSeries projects

An iSeries project represents the starting point for any development

Two required properties (or attributes): 
1. An iSeries connection: You must specify an iSeries connection that 

you want to associate with the iSeries project

2. An associated library: The associated library is a single remote library 
on the iSeries server that contains the build objects for a project

iSeries Projects perspective focuses on 
disconnected development

Projects are local containers for local source
– Edit these resources locally

– Push these changes to an iSeries 
server to submit a build of your project

You can upload all local 
source physical files and 
members created or imported 
into an iSeries project from 
the Remote Actions menu.
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Editors

Editors appear in workbench editor 
area

Contribute actions to workbench 
menu and tool bars

Editor is dependent on type of file 
being edited

– Open with >

Open editors are stacked and can 
be activated by clicking the tab

Name of the file appears in the tab 
of the editor

An asterisk (*) at the left side of 
the tab this indicates that the 
editor has unsaved changes.

• Ctrl+F6: Next Editor

• Ctrl+F5: Refresh 

• Ctrl+Shift+V: Verify

• Ctrl+Shift+C: Compile
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Preferences

Preference and properties 
dialogs provide stored 
values for workbench 
components

– workbench, editors, 
debug, 

You can change the default 
settings to suit your tasks

Accessed from
Window > Preferences

Each preference dialog 
has a “Restore Defaults" 
button.  Click this button 
to  restores the default 
settings.
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(a few of my favorite) Workbench preferences

1. Keys
− You can assign key 

sequences & strokes to 
many of the IDE 
commands [shortcuts]

2. Editors
− Customize the 

appearance and colors of 
annotations, quick 
differences, & structured 
text editors

3. File Associations
− Add or remove file types 

recognized by the 
Workbench

− Associate editors with file 
types in the file types list
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iSeries development preferences

1. iSeries Projects
– Specify logging options 

for iSeries Projects 
Perspective for tracing 
and problem 
determination 

2. Build & compile
− Specify default build 

style for all new projects 
created 
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Capabilities

Filtered slice of functionality, views, menus, and help based on task
– e.g. Java Developer, iSeries Developer

The default setup does not enable a large proportion of the capabilities 
such as team support for CVS, & Web Services development
Enabled in a number of ways: 

1. Welcome view

2. Window > Preferences 
> Capabilities

3. Opening a perspective

1. Welcome view

2. Window > Preferences 
> Capabilities

3. Opening a perspective

Capabilities not enabled will impact the 
context of the IDE such as help system, 
windows preferences, opening 
perspectives, and the file new menus.
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User actions

User defined server commands that run against resources such as files 
and folders on your server

Each user action has: 
1. A unique name 

2. A command (that might have substitution variables)

3. Substitution variables that are replaced with information from the resource 
(such as its name) when the command is run

4. An optional comment used to describe the action in more detail

5. Various options to affect what happens when the command is run
– e.g. Prompt first

6. One or more file types that limit the action to specific types of remote 
resources

Expand the connection containing the kinds of resources you want to 
act on, navigate to the subsystem that would contain those resources

– Select Work with > User actions > Work With User Actions window
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Team component

Workbench provides tools to manage, share and 
synchronize resources 

Eclipse platform includes CVS repository provider

Share the folders and files of a project
– Each team member sends their changes to the 

repository, and receives changes that were made by a 
team member from the repository 

For iSeries, a single project is created for all the non-
remote resources managed by RSE

Profiles are stored in that project; everything 
belonging to a profile can be shared 

Profiles contain: 
1. Connections -- including various subsystem 

properties. User IDs and passwords are not 
shared. 

2. Filters, filter pools, and filters pool references 
3. User-defined actions 
4. Compile commands 
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Help! The Information Center

Workbench provides a number of ways to provide help information
– Both inline and online

“Information Center” provides access to the documentation
– Eclipse-based help system

Able to browse, search, and print system documentation

Organized into sets of information that are analogous to books
– Includes a full text search engine for finding the information you need by keyword 

Able to browse and print help content

Help mechanisms available to all plug-ins
– All Eclipse based products including 3rd party tools

can contribute

Launch Information Center by:
1. Selecting Help > Help Contents 

2. Pressing F1 [context sensitive help]
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Help! Context Sensitive Help and Infopops

A small window of help associated with a particular workbench 
component 

It displays context-sensitive help and links to related help topics for the 
component 

To use infopops:
1. Bring focus to the interface widget in question [by clicking on it or using the 

Tab key

2. Press F1 



43

43

IBM WebSphere Software

© 2006 IBM CorporationSession ID: 490122 26 MI |  Workbench Basics  

Help! Context Sensitive Help and Infopops

A small window of help associated with a particular workbench 
component 

It displays context-sensitive help and links to related help topics for the 
component 

To use infopops:
1. Bring focus to the interface widget in question [by clicking on it or using the 

Tab key

2. Press F1 

Presentation to provide you all the basics you need 
to know about the WebSphere Development Studio 
Client workbench.

WebFacing - Advanced Topics

Introduction to IBM Web Tools and the iSeries
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Help! Content Assist

Provides a list of suggested completions for partially entered strings
Available for ILE RPG, ILE COBOL, and C++, EGL and Java
To use content assist:

1. Open a file you want to edit

2. From the Edit workbench menu, select Content Assist or press 
Ctrl+Space

Editor opens a list of valid code completions
3. Double-click on a possible completion from the list 
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Help! Cheatsheets

Special view that helps guide user through a series of complex tasks to 
achieve an overall goal 

e.g. create a hello world Java application

Implement a task scenario spanning multiple smaller tasks and tools 
used to create some application, object or code Includes actions and 
text

Launch from Help>Cheat Sheets
iSeries specific cheatsheets:

1.Edit, compile and run your RPG or 
COBOL application

2.Debugging a 5250 RPG or COBOL 
application
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Help! Welcome view

First page shown when the product is first started
Provides information on a variety of getting started topics
Information offered in different formats

– Documentation
– Tutorials
– Samples
– Wizards

Maximized view within the 
Remote System Explorer
perspective
Double-click tab 
or click on arrow to
minimize 
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Help! Tutorials & Samples

Number of tutorials & samples ship with the workbench
Based on a variety of topics for a variety of skill levels

e.g. Create a connection [tutorial], WebFacing Order Entry [sample]

Housed in “Tutorials Gallery” and “Samples Gallery”
1. Help > Tutorials gallery, Samples gallery
2. Welcome view > Tutorials, Samples
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Get current: Rational Product Updater

Rational Product Updater (RPU) is the new tool [V6.0] used for 
updating all Rational based products
Replaces Update Manager
The RPU can be accessed in 2 ways:

1. Help menu in WDSC 
IDE

2. Window’s Start menu

1. Help menu in WDSC 
IDE

2. Window’s Start menu
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RPU: Installed Products tab

The RPU will display all Rational based products installed on the 
machine

– Name, product version and install date for each

Learn more about every 
update and fix.  Simply click 
an update to display its 
corresponding ReadMe file in 
the right hand panel.  



51

51

IBM WebSphere Software

© 2006 IBM CorporationSession ID: 490122 26 MI |  Workbench Basics  

RPU: Updates tab

Automatically searches for any missing updates for installed products

Displays all fixes including fixes that depend on other fixes

Have control over which fixes to install 
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RPU: Optional features tab

Displays new functionality available for an installed product

All listed items are ‘optional’
– Can continue to work effectively without the optional features
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RPU: Rollback tab

Allows you to remove [some] fixes already applied

Some fixes are permanent, while others can be rolled back:
– As defined by development team

– e.g. some fixes are just too large and complex to allow rollback function
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Now that you know everything, 
got any questions?
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Intel, Intel Logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo, Celeron, Intel Xeon, Intel SpeedStep, Itanium, and Pentium are trademarks or registered

trademarks of Intel Corporation or its subsidiaries in the United States and other countries.
Linux is a trademark of Linus Torvalds in the United States, other countries, or both.
Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.
UNIX is a registered trademark of The Open Group in the United States and other countries.
Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.
Other company, product or service names may be trademarks or service marks of others. 

Information is provided "AS IS" without warranty of any kind.

All customer examples described are presented as illustrations of how those customers have used IBM products and the results they may have achieved.  Actual environmental costs and 
performance characteristics may vary by customer.

Information concerning non-IBM products was obtained from a supplier of these products, published announcement material, or other publicly available sources and does not constitute an 
endorsement of such products by IBM.  Sources for non-IBM list prices and performance numbers are taken from publicly available information, including vendor announcements and vendor
worldwide homepages.  IBM has not tested these products and cannot confirm the accuracy of performance, capability, or any other claims related to non-IBM products.  Questions on the 
capability of non-IBM products should be addressed to the supplier of those products.

All statements regarding IBM future direction and intent are subject to change or withdrawal without notice, and represent goals and objectives only.  Contact your local IBM office or IBM 
authorized reseller for the full text of the specific Statement of Direction.

Some information addresses anticipated future capabilities.  Such information is not intended as a definitive statement of a commitment to specific levels of performance, function or delivery 
schedules with respect to any future products.  Such commitments are only made in IBM product announcements.  The information is presented here to communicate IBM's current investment 
and development activities as a good faith effort to help with our customers' future planning. 

Performance is based on measurements and projections using standard IBM benchmarks in a controlled environment.  The actual throughput or performance that any user will experience will 
vary depending upon considerations such as the amount of multiprogramming in the user's job stream, the I/O configuration, the storage configuration, and the workload processed.  Therefore, 
no assurance can be given that an individual user will achieve throughput or performance improvements equivalent to the ratios stated here.

Photographs shown are of engineering prototypes.  Changes may be incorporated in production models.
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