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The Challenge

= Tools from different companies do not work well together

= Developers had [and still do!] better things to do than
integrate tools

= Tool vendors had [and still do!] better things to do than
reinvent the wheel

= No one vendor could do it all
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The Solution

= Eclipse project originally created by OTIl and IBM

= Framework on which a variety of tools can be built
— Wide range of operating systems: Windows, Linux, Unix ...

= Extensible, seamless tool integration — new tools easily added by
writing plug-ins

= Language independent

= Attracted a community of tool developers
— Now over 100 active vendor participants

= Effort transitioned into open source project
— IBM donated initial Eclipse code base
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Eclipse Overview: On the outside
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Defined as a set of
contributions, a plug-in is
the smallest unit of
Eclipse functionality.

Eclipse Overview: On the inside

rEclipse Platform
Another

Java (Workbench ) Tool
:  Development N
! Tools ( JFace

(JDT)
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3 Tool
: | Plug-in Workspace
: |Development

: Environment
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Their

[ Platform Runtime Tool

Eclipse Project

*
*
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Eclipse 3.1 took 40 days to
reach 1,000,000
Benefits of Adopting Eclipse Platfor o o ek untake,

Tool
interoperability

Decreased
integration
costs
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maintenance
costs

Decreased
learning curve

Support for
many roles and
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A
A

Easy transition
to new
projects
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So, what’s IBM got to do with Eclipse?

= |IBM is a founding member of Eclipse

= Actively participates on Eclipse.org board of stewards and its working
subcommittees

= IBM builds on Eclipse V3.0 for many products:
— |IBM Rational Software Development Platform
— Rational Software Architect (RSA)
— Rational Application Developer (RAD)
— Rational Web Developer (RWD)
— WebSphere Development Studio Client for iSeries
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This is what IBM’s got to do with Eclipse: Packaging

f WebSphere Development
Studio Client

iSeries
extensions for*

application
development WebFacing, HATS, RSE EGL, SSO, JCA

; lllllllllllllllllllllllllllllllllllllllllllllllllllllll
Rational Web Developer
Java, HTML, Servlets, XML,
JSP, JSF, Web services, Unit FELch E;FO’ﬁJ”iEE’ ——
Generic \ Test environment, database 9

application
development [

IBM Rational Software Development Platform J

\ Eclipse Platform V3.0
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Next...

Workbench basics
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What's an IDE?

12

IT Synonyms: Often when
people refer to the IDE they
often call ita “workbench”.
These two terms are used
interchangeably.

= Integrated Development Environment (IDE) is a set of tools that
developers work with every day to construct and maintain software

= Evolved dramatically in the past few years

= Eclipse is the first IDE that offers an enterprise development
environment for non-Microsoft technologies

IDEs

1st integrated —

Contain more
tooling (wizards,
code assist)

Platforms evolve
(integration APIs,
partner
ecosystems

/ Environment:

Enterprise
Development

>

1990
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IBM Rational Software Development Platform

= |BM branded IDE

= Based on a 4-pronged infrastructure: Eclipse, Eclipse Modeling
Framework (EMF), MDD platform, & standard modeling approaches
(e.g. UML)

= Includes products from all IBM Software Group brands (Rational,
WebSphere, Tivoli, DB2 and Lotus)

— Advantage of unifying all IBM Software Group development tools within a
single platform

= Open and modular workbench
— (Can purchase and adopt it in parts

= Spans all capabilities of software development cycle
— requirements & analysis - deployment management
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Workbench component

Workbench is the user interface

Implemented by the workbench Ul plug-in

Plug-in defines and manages all object that you see
— E.g. menu and toolbars, dialogs, wizards

Ul paradigm centered around
— Perspectives

— Views
— Editors

Each Ul element has a defined role
— Editors work on resources in the workspace

— Views share information about their defined ‘input’
— Perspectives organize views and the editor ‘space’ to support defined tasks
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Workbench responsibilities

Manages windows and perspectives

Eclipse Platform creates menu and tool bars

— Labels and icons listed in plug-in manifest

— Contributing plug-ins not activated

Eclipse Platform creates views and editors

— Instantiated only as needed

Scalable to large numbers of installed tools
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Software

Workbench: Overview
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« Ctrl+F6: Next Editor
e Ctrl+F7: Next View
« Ctrl+F7: Next perspective

Workbench: Overview
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« F10: Main menu bar
« Shift+F10: Context menu
o Ctrl+F10: Pull down menu

Perspective

Workbench: Overvie indicator
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= Components
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Workspace component

21

Local directory where the workbench stores all your
projects, files, folders

Location is set in the dialog that first opens when you
start the Workbench

— Can modify location by selecting File > Switch
Workspace.... (Eclipse V3.0)

|
1
T
BT |
T

't Mavigakar

G| x

& (P|| 6

W

Workspace holds 1 or more top-level projects
— Projects map to directories in file system

{Files, Folders, Projects} termed resources

Resources are displayed in a tree structure of folders
and files
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Each preference dialog has a
Restore Defaults button. Click
this button, to restores the
default settings.

Perspectives

u Pe rS pectives are CO | | eCti O nS Of Vi eWS & Remote System Explorer - PAYROLL.RPGLE - IBM Rr’:lFlic'na.I Software Development Platform
and editors in the workbench -

I-BE|$-0-Q- & [we-q
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' ' itv ai R T S el B i =
- PrOVIdeS a Set Of funCtlonaIIty almed : . EoVHOt tuce 000200 Reset Perspective Other... —
. . apn E;Ew?é:géf%ﬁ 000300 Close Perspective Fime reporting master file mainten:
at accomplishing a specific type of g neoras || QI | OmAreseve peeen ol
. . Y MYCDMI;ILEE;;nd 000600 Navgahcn 'b
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— e.g. RSE perspective is for

managing and working with remote
file system objects

= Name of the active perspective is
shown in the title of the window

= Can open, customize, reset, save,
and close perspectives

— Window menu
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Shorteuts i Commands i

Select the shortouts that you want to see added as cascade items to the following submenus. The selections made will only

affect the current perspective (Remote System Explorer).

Submenus: Shortcuts:
IShow View ;] Shortcut I Description
Shortcut Categories: 0 ©lremote Error List
Jant /% Remote Scratchpad
- [E Basic O %ﬂREmute Search
- [0 Cheat sheets @ Remote Shell
= D Debug J@Remob& System Details
- [Jiseries HARremote Systems
[ 1228 %5 Team
[ Java
[ 1ava Browsing
[ server
O struts
] SWT Examples
[ visualage RPG
- web
[ WebFadng a a8
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Perspectives require memory,
so it’s good practice to close
perspectives when not being
used to improve performance!

Switching perspectives

= There are two ways to open another

perspective:

1. Click the Open a perspective icon [ | EHRemote Syste...
in the ’[Op r|ght corner Of the Ffiseries Projects iSeries Project Navi... = H)
Workbench working area and select | ® EiRenote system Exglore B G
the appropriate perspective from the | =" - 4
Ne approp Persp — to the Rational [
I|St - M rmlAamma s

2. SeleCt WindOW > open Window JgEs]

Perspective. New Window 2k A YRR
= In either case, there is also an E — d  Eliseries Projects 1
Oth t L . EiF‘.emote System Explorer
er"' Op |On Customize Perspective... EWEbFadng 4
I Save Perspective As... "
Reset Perspective Other...

Close Perspective
Close All Perspectives

COH - Time reporting
externally descri

RO OO R R R R R W W W W ey

5 USED

ecord found on CHATN d

Mavigation 4

Preferences
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Tailor made perspectives...

24

Flexibility of the IDE allows you to open, customize, reset, save, and close
perspectives
— Window > Customize Perspective....

. Customize

— Add, close, move, and resize views

— Window > Show View and select the view you would like to add to the currently open
perspective

Move
— Move a view to another pane by using drag and drop

— Views are stacked > use the tabs at the top of the view to switch between them
— Select a view’s title bar, drag the view, and drop it on top of another view

Drag
— While you drag the view, the mouse cursor changes into a drop cursor

— Drop cursor indicates what will happen when you release the view you are dragging

— In each case, the area that will be filled with the dragged view is highlighted with a
rectangular outline.

= E.g. 2 = The view will dock to the right of the view under the cursor.
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Saving customized perspectives
come in handy in situations

: . where a development is being
... Taillor made PEers peCt|VeS shared between several
developers.
4. Fast View

— Appears as a button in 3 docked locations in the IDE [left, bottom (default) and right]

—  Click the button to toggle whether or not the view is displayed on top of the other
views in the perspective.

5. Maximize/minimize a view
— Maximize a view to fill the whole working area of the Workbench

= Double-click the title bar of the view, press Ctrl+M, or click the Maximize icon
— Minimize a view so that only the tab is visible

= (Click the minimize button in the toolbar of a view
6. Save

— Save customizations as your own perspective

=  Window > Save Perspective As....
7. Restore

— Restore the currently opened perspective to its original layout
= Select Window > Reset Perspective.
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« Ctrl+O: Opens the
outline view for the
currently selected type

= Views provide information on an
object

= Support editors and provide
alternative presentations or ttalh,
navigations of the information in the | < oy roirads
Workbench o [

eeeeeee
......

— Qutline view summarizes editor o o
content

= Views augment other views
— Properties view describes selection C
in outline view 1 48 Gosts Commcs

5l v 2ok B rrnx Extpral deecriptiony for flg CLETOMLI et F.. W 0 0 WERLANITGRAQE.. ol

B eFis Exterral descrpmon ke - N M OWELAIRORROE.. el

. 'ém B eram mmﬂu. o WESLAITORPOLE.. el

= Access from Window menu S WERR  Beee o MIERURL 0 G7 WEMREGL.

— Window > Show view

= WDSC standard views include:
— Remote System Explorer, Outline,
Properties, Error List
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« Periodically refresh your source
while using the Outline view by
clicking the refresh button at the top
of the view.

Great resource when you want to edit ILE RPG, COBOL, or
DDS source

— View is also available for Java

»— Cutline X

% Global Definitions -
1 [y Files

| @43 MSTDSP : WORKSTN (Externally Descrit

. =142 EMPMST : DISK (Externally Described )

. BB reemp

Displays a structural outline of items defined in the file currently
open in the editor

Icons are provided to indicate the type of element in the source,

. Bl EMPNO :
. -0 AcREC:
- - ENAME -
-0 EMCAT :
-0 EDEPT :

- mfoELOCN:
| m-fo USRI :

Packed Decimal {&,0)
Character (1)
Character (30)
Character (1)
Character (5)
Character {30)
Character (&)

such as a record (DDS), Fields (ILE RPG)

Clicking an item in the outline will position you in the editor
view at the line where that structure element is defined

Uses:

1. Check definitions in the Outline view instead of jumping back
and forth in the source between the calculations and the

definitions

2. If you notice that a definition is incorrect, click the definition in
the outline view to quickly jump to the appropriate place in
your source, without having to search for the definition.

3. Quickly view the return and resolved values listed beside your
procedure prototypes

|-Workbench-Basics |

. -0 ENHRS : Packed Decimal (3,1)
. -0 EPHRC : Packed Decimal (5,1)
-3 EPHRY : Packed Decimal {7, 1)
~-ff0 EPHRP : Packed Decimal {7, 1)
[0 EPNRC : Packed Decmal (5,1)
-0 EPNRY : Packed Decimal {7, 1)
-0 EPNRP : Packed Decimal {7, 1)
L@ 237
L@ 241
@ 245
@ 248
L @ 21
. -4 PRIMST : DISK {Externally Described )
i Er}-'@ RSNMST : DISK (Externally Described )~
. & = Fields
. @ L Indicators
=L
= Subroutines
=53 ACDESR
i@ 130
L@ 211

.. (3 O0

© 2005 IBM Corporation



IBM WebSphere Software

 Right-click in the gray border at the
left of the editor area, beside the line
of text or source code

» Select “Add Task”

Views: Tasks

Task marker

= Displays system-generated
errors, warnings, or damae i ‘
information associated with |r- o« =

Search  Project Run

- |A ¥ REE

MEERE - B A AL CR R & | BRemotesyste...

JEREmohe Systems 53 __Ieaml = w [E index.jsp | @ web Deployment Descriptor PATRL Lt 7 ] ‘Ei]Bc... 53 "’3 =]l
a resource Lz s v d  Line 111 Column 1 Replace | |2items WL ‘
s | I .. .CLONO1Factorl+++++++0Opcode (E) +Extended-factorZ++++++4+44+ 0404044401 | 0 |
| Ji New Connection Sl = 2 | Description ! Res|
C I d. I II & 8 Ll 7.| 1D§D’O C* Reason Code Maintenance. - 010500000000 C... PAY
u an a SO Isp ay man ua y RS LocaFies aneng (Do e e e e e R R R R e R R R R R R R S Eaoorone TRy
gt 0107 0 c
added tasks e Ebra:)l:l Shelz :EDIDE 0 C* Housekeeping, clear display fields and reset indicators.
& iseries Objects | Ei?f 0 E ______ -
- Work with libraries. .
H i i W work with objects...
— Optionally associated with 2 : o
p y £ ﬁ;:m:tmimbim”' g Description: IUll?UUUUUDUU c MOVE  *BLAMKS RSDSC
a resou rce % User libraries N g
fority: ] "G ted
iR g Friority :I;-Imal hd Comple:
HH H . CLR1.*pgm.clle it
= Ability to filter tasks: e, | o] onsoef G
PAYROLL. "pgm.rp¢ Gjo] InEolder: | RemoteSystemsTempFiles TORAS 1FB/QSYS.LIB/RSELABOS. LI /QRPGLESAC FILE
— PAYROLLD. "pgm.c E
See Only prObIemS logged PAYROLLG. pam.r| .‘,g Locaton:  [line 117
COMPARE. *file.pf- |4
by the Workbench, s
EVFEVENT, *fle of- 4 Cancel
£ MSTDSP, *file, dspf 3]
— Tasks that you have Tty |
. w0 [ PRIVST. fle.pfdt )
|Ogged as remi nders tO ; 1+ [Ely QCBLLESRC. *file.p Remote System Details | ¥ Tasks 52 . ISeries Table View | iSeries Commands. Log| & K v =0
r ”: i1 [Ely QoLsRe. *file.pfar | m“ihems = !
you Se L] I ] ] 'i l Description I Resource I In Folder | Loca... l ~
. . Elproperties 57 " RemoteS.. ! =5 TODO Ta change the template for ... Page java . . Auctionvaoweb(Ja, .. I?ne 25
—_— ACCO rdl ng to Wh | Ch “—ﬁ_'--:—_— TODQC To change the template for ...  SearchandDisplay.java  TestfJavaSourcefp... line 18
EFEE T TODO To change the template for ...  UserAdmin java WebAuctionflavas... line 12
resou rce Or group Of Property | value TODO To change the template for ... UserCreate,java WebAuctionfJavas... line 12
TODQC To change the template for ...  UserEdit.java WebAuctionJavas... line 12
resou rCeS they are TODO To change the template for ...  UserFacadelocalGet...  AuctionV60WebfJa... line 13
010800000000 C* Housekeepin... PAYROLL.RPGLE RemoteSystemsTe... ine ...
. . O = ke I
aSSOC|ated W|th , by text 011900000000 C= Display reas...  PAYROLL.RPGLE RemoteSystemsTe...  line ...
h h < | § 012100000000 C EXF... PAYROLL.RPGLE RemoteSystemsTe...  line... @ % 5
. . . i
string within the = : = = =

Description field, by

_ Priority
problem severity etc.

indicator Tasks view
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BT |
1

 Right-click in the gray sidebar to the
left of your code in the editor

» Select “Add Bookmark”

« Enter the name of the bookmark and
click OK.

Views: Bookmark

= Bookmarks are another simple way to navigate to resources that you frequently use

= Displays all bookmarks in the Workbench
— created bookmark is indicated by the symbol in the marker bar

= Double-click the bookmark in the view to open the file and navigate to the line where the
bookmark has been created

File Edit 5-:'--.-r-:e ompile  Mavigate Search  Froject Run \Window  Help
B R UG a e AYAEE B %00 P 0 o | etz syse..
R 33\\__»1. = O || B index.jsp |®Web Deployment Descripter | g7 i RPGLE X [lgookmarks &2 B o »y=0
- | Line 106 Column 1 Replace | |2items
& & | ; Description | Resource | In Folder | Location
& 010200 .|| 010500000000 C... PAYROLL.R... RemoteSystemsTem... line 105
,_| 010300 011400000000 C... PAYROLL.R... RemoteSystemsTem... line 114
T 7 ® 1 || einden
=R [l 010500
[ New Conr 4| glonnn
010700
=-E Lol _| 010800
| E%t::: 010900
i 011000
B ‘ torasifb
= EED |Ser|e: 011100 i
011200
011300
[l o11400 il
011500 C* start of error loop
011600 c Do not *IN6O
011700 c MCVE *BLANES RSD!
v'.
< | > m=
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Views: Navigator

30

= Navigator view provides a hierarchical view of the
resources in the Workbench

= Project type is noted by the icon

= From Navigator you can open files for editing or
select resources for operations such as exporting
— Right-click on any resource in the Navigator view to

open a pop-up menu that allows you to perform
operations

— €.g. copying, moving, creating new resources,
comparing resources with each other, or
performing team operations

|- Workbench Basics |

iSeries Project... =i

#-[28 AuctionVGOEAR %
= AuctionV&0EIB
142 AuctionVS0EIBClient
! - bin
2| .dasspath
@ Jproject
L @ runtime
#1298 AuctionVedUserAdmin
#1122 AuctionVE0User AdminEAR
&::3 AuctionVa0Web
I'iiag Auctionva0WebService
-l Empty
- 122 EmptyEAR
4= OIDGenerator
I'ii&:‘f- OIDGeneratorClient
&:ﬁ OrderEntryExample
( '@5 OrderEntryExampleEAR
&::3 Test
[ '(35 TestEAR
BRE=gTestproject
. (= FLES
P EI[E:- Jiseries_srcpf_metadata
: o |5| Jseries_srcpf_properties
E| Jseries_project_properties
H @ project
[ ng WebAuction
#-[22 WebAuctionEAR
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Unless otherwise specified,
projects are created in the
workspace directory. When

P rOJ eCtS projects are deleted, you have the

choice of also deleting the
contents or not.

= Top level of organization of your resources in the workbench
— Contains files and folders

= Used for building, version management, sharing, and organizing
resources

= May contain session and persistent properties, settings for
environmental variables, and references to other projects

= You can create different kinds of projects with different structures
— e.g. Java, Web, WebFacing, iSeries

= The type of project specifies its properties

= To create a project:
— Select File > New > Project....
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You can upload all local
source physical files and
members created or imported

i Se rl eS p I’Oj eCtS into an iSeries project from

the Remote Actions menu.

= An iSeries project represents the starting point for any development

= Two required properties (or attributes):

1. An iSeries connection: You must specify an iSeries connection that
you want to associate with the iSeries project

2. An associated library: The associated library is a single remote library
on the iSeries server that contains the build objects for a project

= iSeries Projects perspective focuses on © New
disconnected development iSeries Project

Create a new iSeries project that maps to an iSeries
library.

= Projects are local containers for local source

Project name: I |

— Edit these resources locally project contents

¥ Use default

— Push these changes to an iSeries
server to submit a build of your project
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Ctrl+F6: Next Editor
Ctrl+F5: Refresh
Ctrl+Shift+V: Verify
Ctrl+Shift+C: Compile

Editors

= Editors appear in workbench editor
area

@ Remote System Explorer - PAYROLL.RPGLE - IBM Rational Software Development Platform
File Edit Source Compile MNavigate Search Project Run  Window Help

= Contribute actions to workbench ~ |c-o (s-o-a-iv e 0 el E e

Team‘ = [ |[ # ANGC12R RPGLE | [JFACES CON2 |/ =PAYROLLRPGLE 52 ™ 8]

.:;F‘.Emcwte Systems X

menu and tool bars L8] T R[EG v Dt Comac Sepdace 1 chense
i i E] QRPGLESRC. *file. pfﬂrc -~ . 2 +I
= 000100 ~
. . . Lim PAYRDLLG‘ GoTo » p200 F* PROGRAM NAME - Payroll E
| | Ed t d p d t typ f f I £ _M300._____F+ DFSCRTPTION - Time reporting master file mainter
I Or IS e en en On e O I e H ::‘E'] S;:ﬁ;sfﬁcl:j : 5 X externally described workstation [
H H i . & [ RoNMST i BrOvSE WD en e R e
elng e Ite i i B MYCOMPLE. ‘G|I_|Rename l - . athl — s
; - m RSETELTMP. b, tes 700 r 5? - Mo Iec._erd found on CHAIN operation
: - m RSETBLVIEW. ib. pt EjCUDY 200 F* &0 - General errcf’ ccncl:l.t:t?n B
O .th > " mRSEI'ESI' “fib.prod Q&Moveu. 500 Fx ?0 - irccec:.dlspiay" on delete request
pen WI Bl- mRSEI'ESTOUl b te : 000 F f(C - _nd“cf job IEE(uESEEd .
i m RWOLIB. 5ib. test # Delete... 100 r f(D - Rettrn Ec appflcatlcn_seLectlcn
Bl- m SAMPATH. *iib.prod —1 ) 200 F f(E - Return to employee a?mact,lun
. -, SAMWAL 5b.prod % Find String... 300 F* KF - Return to project selection
400 F* KG - Return to rode selection
= Open editors are stacked and can S o v R
£, SATISH. 5ib.pro Verify (Prompt)... S 0 e
1 i I - M, SATSAVE. b, prod %Cnm e ’ ?gg ; SUBROUTINES USED
e activated by clicking the ta e Wl 5 o mcsiion avieciion Bissiew
(-, SCFUNG. b, pmd ompile (Prompt) s T S e s e kg
B mSCHWE\’ER b, pre User Actions » LS00 E BCDESR - Edit action code for all maintenance rf
| | N 'Il f h f.I 1 h b L % zgm;:glﬂ:bpmd Add To iSeries Project... Sgg ; This program uses all externally described file:
- ]
a e O t e I e appears In t e ta - mSDATEST ‘!lblprzr; Make Available Offine 200 F* used are - MSTDS5P - maintenance display file
. - Jffy SDATESTL,"b.pro¢  DebuglSenviceEntry) ¥ zgg ? = EQF‘MM;E 2 Erﬁfifem:“:iffff
iy bl - PRJMST - Jject
Of the ed|t0r ;%:giggf“:b;; Compare With * psoo F* - RSNMST - reason code master file =
[+-Jffl, SDATEST3. *ib.proc  Properties W | -
. * . [+-[ffl, 503302704, “ib.prod =
= An asterisk (*) at the left side of e
n asteris at tne left siae o 5 M, TS o grod v |
p—

the tab this indicates that the
editor has unsaved changes.
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Each preference dialog
has a “Restore Defaults"
button. Click this button
to restores the default
settings.

Preferences

= Preference and properties — [lEEEEs

1] . = [
dialogs provide stored T | Appeorance |
Capabilities —Editor tab positions
values for workbench - Colorsand Frts o |
=) ComparePatch View tab positions
components b e v [ 1 € ot |
- File Associations |' is’sfeéﬁ“; S-u:itd:aﬂp?fm:ns = |
. H i Keys Le opLeft t* TopRi
WOrkbenCh, edltOrS, ;:t?tl:zldD:mraﬁons A Tinrent B eenie o
d e bU g ; L::cal Hisi:::rces IDefauIt (current) :_!
-~ Perspectives Current Theme:
= You can change the default || _swessun e =
& Ant [+ Show text on the perspective bar

settings to suit your tasks oo
el

" Accessed from C%}-iSeries Projects

. ' Build and Compile

Window > Preferences =

- LPEX Editor
[+ Remote Systems |

[~ Show traditional style tabs

34

|- Workbench Basics |

Restore Defaults
<l _| @ estare Defau i Apply i
Import... Export... oK I Cancel |
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(a few of my favorite) Workbench preferences

1. Keys

& Preferences

@ Preferences

il
..“i
Im

— YOU Can aSSign key l:!--\".!’nrld::endﬂ ﬁ' |F|Ieﬂsesnciatinn5 ‘
sequences & strokes to Eiatisiuy e
many of the IDE iy o o=
commands [shortcuts] b e _ gemore |
2. EdItOFS gig;ﬁfmmm _ & "vg
. TextEditor | Lz
o Customlze the E----E:!Ehssociaﬁons r|:lg
- Keys ] el =
appearance and colors of i g:jﬁ'emc
annotations, quick -~ Local History és
. .- Perspectives *.8ac
differences, & structured search S e 8
. " Startup and Shutdown - o
text editors 1 Ant
. . . - Build Order Associated editors:
3. F|Ie ASSOCIatIOHS E;-::'I":S'F'E"diate # Remote Systems LPEX Editor (default) Add...
— Add or remove file types Eiijjfgjﬁg”;;mjm BT
i ] Drefatilt
recognized by the S & e
Workbench
_ _ o mport... | Export.. | oK | concel |
— Associate editors with file
types in the file types list e | e | o] _cwed |
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ISeries development preferences

36

1. iSeries Projects

— Specify logging options
for iSeries Projects
Perspective for tracing
and problem
determination

2. Build & compile

—  Specify default build
style for all new projects
created

|- Workbench Basics |

@ Preferences

BX

- Build Order
[#-Help
@ Install/Update
@ Internet
@ iSeries Projects

. Build and Compile
- Java
[+~ LPEX Editor |
= Remote Systems
- Communications
=] Debug
" Host Java
- File Cache =
. Files |
E' iSeries
. leCache |

- Command Executio

* Command Subsyste |
. - Job Subsystems
. 1 LPEX Editar Parsers
Ll ka

- COBOL
- DDS

L ILERPG

2

s |

¥ Automatic syntax checking
v Automatic uppercasing

Enter key behavior

¥ Repeat previous specification type

I Repeat previous operation code (if on fixed form C-Spedification)
[~ set C-Specification cursor position

Pasition

Restore Defaults | Apply |

[ o |

Cancel |
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Capabillities

Capabilities not enabled will impact the
context of the IDE such as help system,
windows preferences, opening
perspectives, and the file new menus.

Filtered slice of functionality, views, menus, and help based on task

— e.g. Java Developer, iSeries Developer

= Enabled in a number of ways:

1. Welcome view

Window > Preferences
> Capabilities

Opening a perspective

37 | Workbench Basics |

\ 4

@ Select Perspective

The default setup does not enable a large proportion of the capabilities
such as team support for CVS, & Web Services development

R

|£| @ Select Perspective

ﬁ‘DEbUQ %C\JS Repository Exploring
EiSEries Projects FEI Data
@ 12EE ;
[SESSVl © Confirm Enablement
E;,J Java Br : : . &
T:J Java Ty This action requires the enablement of "Core Database Development™.
EﬁRemnbe Enable the required capability?
Resourd ; ;
%Web [ Always enable capabilities and don't ask me again.
% WebFad
OK l Cancel ! Details == 1
ELINEMOLE Bystem crplarer (oefault)
[[‘;:]RESOIJFCE
EDTeam Synchronizing
@ web
FE WebFacdng
I~ Show al ¥ Ehow ali
6]8 I Cancel | QK I Cancel I
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User actions

= User defined server commands that run against resources such as files
and folders on your server

= Each user action has:
1. A unique name
2. A command (that might have substitution variables)

3. Substitution variables that are replaced with information from the resource
(such as its name) when the command is run

4. An optional comment used to describe the action in more detail
5. Various options to affect what happens when the command is run
— e.g. Prompit first
6. One or more file types that limit the action to specific types of remote
resources

= Expand the connection containing the kinds of resources you want to
act on, navigate to the subsystem that would contain those resources
— Select Work with > User actions > Work With User Actions window
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Team component

= Workbench provides tools to manage, share and servers Probiems fERECRN™  — O
synchronize resources BRIl
= Eclipse platform includes CVS repository provider
P == Connections
= Share the folders and files of a project :” %EE"W s
. ioEk ser actons
— Each team member sends their changes to the | T L iSeries Obijects (Series)
repository, and receives changes that were made by a ity iseries Jobs (Series)
team member from the repository B IFSFiles (Series)
ﬂ_, Local Files {Local)
= For iSeries, a single project is created for all the non- | EE b g
remote resources managed by RSE E‘E Files (Pawer Linux)
i Ty Files (AIX)
= Profiles are stored in that project; everything .J [sib Compile commands
. . =--f[2] dmarasco
belonging to a profile can be shared = 4 Comectons g
. . Local aeawn ration managem
= Profiles contain: % oras i [ S e
1. Connections -- including various subsystem - Be Filter pools 9
: = 2 U)o
properties. User IDs and passwords are not 3 1, User actions [—
shared. [+ 51y Compile comm .
2. Filters, filter pools, and filters pool references e
3. User-defined actions
4. Compile commands O s |
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= Online help
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Help! The Information Center

41

Workbench provides a number of ways to provide help information

— Both inline and online

“Information Center” provides access to the documentation

— Eclipse-based help system

Able to browse, search, and print system documentation

Organized into sets of information that are analogous to books
— Includes a full text search engine for finding the information you need by keyword

Able to browse and print help content

Help mechanisms available to all plug-ins

— All Eclipse based products including 3rd party tools W

can contribute

Launch Information Center by:
1. Selecting Help > Help Contents

2. Pressing F1 [context sensitive help]

|- Workbench Basics |

. | Connecting to Linux, U, Windows, and Series servers AN
Remote Sy Explorer filters, filter pools, and filter pool *
references

‘The Remote System Explorer is a set of local client tools you use to organize how you want to work with resources
s files and folders on your remote server. The folowing graphic serves as an introduction to some of the main
e Remote System Explorer:
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Help! Context Sensitive Help and Infopops

= A small window of help associated with a particular workbench
component

= |t displays context-sensitive help and links to related help topics for the
component
= To use infopops:

1. Bring focus to the interface widget in question [by clicking on it or using the
Tab key

2. Press F1

ssing.
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|
1
T
..Il
L

Help! Context Sensitive Help and Infopops

= A small window of help associated with a particular workbench
component

= |t displavs contexi-sensitive helb and links 1o related helo topics for the
compol Presentation to provide you all the basics you need
to know about the WebSphere Development Studio

" Touse Client workbench. ,
1. Br using the

Ta
2. Pr

WebFacing - Advanced Topics

Introduction to IBM Web Tools and the iSeries
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Help! Content Assist

= Provides a list of suggested completions for partially entered strings
= Available for ILE RPG, ILE COBOL, and C++, EGL and Java

= To use content assist:
1. Open a file you want to edit

2. From the Edit workbench menu, select Content Assist or press

Ctrl+Space

= Editor opens a list of valid code completions
3. Double-click on a possible completion from the list

I ARRAY =] =] DIM(S)
DIM{numeric-constant) P DM (MUMERTC-CONSTANT)
q
The DIM kewword defines the number of elements in an array; a mec DATFMT(DATE-FORMAT{DATE-SEPARATOR )
table; a protobvped parameter; of a return value on a prokobvpe e DESCEND
or procedure-interface definition, B OTAARA

et DTAARAIDATA-AREA-NAME)
e DTAARACYAR:DATA-AREA-MAME]

c SETON
OQ3TSPRT T LE

o IN3STALL
o

o

1 1
21
24 'OF!
28 'THE'
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Help! Cheatsheets

= Special view that helps guide user through a series of complex tasks to
achieve an overall goal

e.g. create a hello world Java application
= |Implement a task scenario spanning multiple smaller tasks and tools

used to create some application, object or code Includes actions and
te Xt IEM Rational Software Development Platform

h Projsct  Run av Help
=Launch from Help>Cheat Sheets |... ... '~ e
u p index jsp ‘ (@ web Deployment Descrptor | #/PATROLLRPGLE 53 B + =8
o b Lolumm I Heplace Edit, compile, and run... or COBOL application
. . . 1 (| - R s PSR RN SR R IR R SRR R e R SR RN
- . IRk @
I I I I . 000200 F* PROGRAM NAME — Payzoll Opering the Remate System Explorer perspective @
000300 F* DESCRIPTION - Time reporting master file maintenance using B e R e ey 2
000400 F* externally described workstation processing. R T e
. . goosoo Er= 1P address or hostname of your iSeries server, for example,
000600 F* INDICATORS USED PRODA00, and cick Finish. The value you enter for your hostrame is
- I y I u y u 000700 F* - No record found on CHAIN operation filed into the Connection name field by default.
gHUEHE o SOEmerRlL frTorchnoition When you cick Finish, the wizard automatically validates the name of
. . conzEs i Erotech AL DIRY-nE o T LREEIENY Your Series server and connects you to the server sa that you can
a " :a I ‘ ’ n 001000 F - End of job requested work on your iSeries appiications.
go1100 E* - Return te applicarion selection 3
001200 F* - Return to emplovee selection

001300 F* project selection B o
L] 001400 : dad rode selection LE o i ®
2.Debugging a 5250 RPG or COBOL |z -
. 001600 F
001700 F* fiters| Remote iSeries System Connection
. . 001800 F* Expaf]  Defie connection nformation
application - e S
002000 F reht.
002100 F* program uses all externally described files. Files Entry
002200 F* used ars — MSTDSP - maincenance display file lbrery parentprofle:  [dmarasco -
002300 F* — EMPMST - employee master file
002400 F* - PRIMST - project master file
002500 F* — RSNMST - reason code master file Lokt
g Host name: TORAS 1FE -
=] i | &l
Description:
| BRemote System Dietals 55 Tasks | iSeries Table View Series CommandsLog| | & ¢ |+~ o | = w =0
Back i Cancel
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Help! Welcome view

46

First page shown when the product is first started
Provides information on a variety of getting started topics
Information offered in different formats

— Documentation

— Tutorials

— Samples

— Wizards

Maximized view within the

Remote System Explorer
perspective

Double-click tab
or click on arrow to
minimize

|- Workbench Basics |

Ratwel, Softwnne Devehopmen] Patum

B Farma e Syt [npdorer - B Ratipnsl Sl epre Devdoparant PLSlore

Fir D3t Fadgy Sewch Promdt B BWdos D

&
WD-I'I'J:_-:II'_H:TI-

0 10 the wodkbonch -

---------

ba dils DOIDOCD By

188 18

Amamasiueriath

* EEARREE

1 | S e TR S RN wu_lm."hrunm' i

i it - i O P P —r e
! " L]
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Help! Tutorials & Samples

47

= Number of tutorials & samples ship with the workbench
= Based on a variety of topics for a variety of skill levels

e.g. Create a connection [tutorial], WebFacing Order Entry [sample]
= Housed in “Tutorials Gallery” and “Samples Gallery”

1. Help > Tutorials gallery, Samples gallery

2. Welcome view > Tutorials, Samples

I .
z

% watch and Lesm |
Coenazt i) " F2 Py and Leara
= 1E 0o md Lrwrn
I I 0 ] AT LS L Bl :
= * B work oftee wih Geres Frogects. | 4
i I Wiy gn LE COBOL applomton iy redy yous lem the Techolnghes i cond
7 B paresn an ILE RPG apoicaion sng AR Rstionad acftuinre develapren ook
I Pk Wik ey inberkece for m siie o Wisich sl Leam tubarals sre wiewed Bos 3 movis, Thl
o B eh-craik 4 5250 PG NG U Mg Mow vou o wah wask bamg parfed o e a i
o | RN tha product. Uss the plever bar st bw bottom
Dcraalap | 5 .;::T“;':;*:‘rw Tor o PG i U e cantrols on 3 VOE Lo@T at v oan 5
— S Fioy ard Lusm btarisl guice pou thiouch @ smulato]
r! ™ W Ay mn GEES WA DG T Ty e DI D O k) b O SO Tl At
# B pyghi e vkt wng the fam H S0ED I our WEdkapme You £an g the mpenis)
7 I i BT GaTeale LaNguagE ;"":“'L'"“:" "':"‘ "“"::"‘ [atn "'“"h
# I il v g e tht s Wek g h e T o e A
- TN Y BTG ARGy wih Ul eI 0 Wik
1 k) sk adcation using Facss (en i I resconces, bosve of these nutonials 3B orside 30e by
71 I Duemig e vyt s siacsre ol vour WAL e
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= Applying updates
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Get current: Rational Product Updater

= Rational Product Updater (RPU) is the new tool [V6.0] used for
updating all Rational based products

= Replaces Update Manager
= The RPU can be accessed in 2 ways:

1. Help menu in WDSC
IDE . Help
.@Welcnme

| (?) Help Contents
| Tips and Tricks...

g 1M Rationd @ I8 Rational Web Developer V6, 0 }
@ I8 WebSphere Development Studio Client for Series V6.0 1
© Rational Product Updater

2. Window’s Start menu

A 4

@ Rational Software Development Platform

IEM Suppaort Assistant =/ Find and Install...

@ Manage Configuratian. ..

Abiout IBM Rational Software Developrent Platform
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RPU: Installed Products tab

50

Learn more about every
update and fix. Simply click
an update to display its
corresponding ReadMe file in
the right hand panel.

= The RPU will display all Rational based products installed on the

machine
— Name, product version and install date for each
&!'Rational Software Development Platform Product Updates - |EI|5|
File Preferences Help
IBM Rational Product Updater
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Select an item to see its detailed information.
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IBM WebSphere Software

RPU: Updates tab

= Automatically searches for any missing updates for installed products
= Displays all fixes = including fixes that depend on other fixes

= Have control over which fixes to install
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RPU: Optional features tab

= Displays new functionality available for an installed product

= All listed items are ‘optional’
— Can continue to work effectively without the optional features
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RPU: Rollback tab

= Allows you to remove [some] fixes already applied

= Some fixes are permanent, while others can be rolled back:
— As defined by development team

— e.g. some fixes are just too large and complex to allow rollback function
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