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» This presentation looks at the Java Development Tools (JDT) included in WSSDa and the iSeries extensions added
to this tooling in WDSc.

» To get a high level overview of the tools and Workbench we first create a simple HelloWorld Java application. Then
we cover the Java editor, its accompanying views and the rest of the compile / run / debug development cycle.

» The presentation finishes off with a look at the iSeries extensions to the Java development tools.
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Agenda

iSeries AD, IBM Toronto

> Getting Started
® Creating a HelloWorld program

> The Java Editor

> Java Vliews

» Compile / Run / Debug
> iSeries Additions

> Reference

IBM @server. For the next generation of e-business.
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Java Development Tools

iSeries AD, IBM Toronto

» Quick Overview

IBM @server. For the next generation of e-business.
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WDSc: Java Tools

iSeries AD, IBM Toronto

v/ Java Development Tools UDT):

e Choice of Java level
»IBM JRE 1.3 built-in and offered as default
e Java projects
» Optimized for Java development
» Specialized views
v Package view and Hierarchy view;
v Outline view: many tools launchable from here!
» Java Editor
v Content Assist: Ctrl+Space bar to get list of classes or methods
v JavaDoc shown as hover help
v F3 to open selected class
» Refactoring support
v Rename updates all references
» Incremental compile
v When Ctrl+S pressed in editor
v Or on demand via Build Project action

IBM @server. For the next generation of e-business.

» By default JDT uses the IBM JRE 1.3 that is shipped with the Workbench however the user is able to switch this to any JDK that is installed
on the local system.

» Java projects have an associated builder that knows how to compile Java classes. Properties for a Java project include the build path
where the user specifies other projects, and jar files that are required for this project (i.e. sets up the classpath.)

» Refactoring support gives the user the ability to easily restructure their code without having to manually update other classes that are
affected by the changes.

» Whenever a Java class is saved, the source is automatically compiled.
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WDSc: Java Tools

iSeries AD, IBM Toronto

+/ Java Development Tools UDT):

|
in and offered as default

@ assertShing.boolean| void - Assert
@ azzert{boolean) wvoid - Aszzert

@ aszentEqualsObject Object] woid - Assert

@ aszentEquals(Sting, Object Object] woid - Aszert

@ agzertE quals(String boolean.boolean) woid - Assert

@ aszentEquals(Sting bytebyte]  void - Aszzert

@ aszentEquals(String.char,char] void - Assert f
3

«
v Package view 3 nd Hierarchv view;

a development

v Outline view: mj © BT EEEEER e

void - Azsel
@ AssertTest jurit. Azzerts that a condition is true. [F it isn't it throws an AssertionF ailedE ol
Java Editor

deprecatedguse aszert] e
v Content Assist: Ctrl+Space bar tg
v JavaDoc shown as hover help
v F3 to open selected class - o
» Refactoring support gt

CHE junit.extensions

v Rename updates all references % ik el
» Incremental compile it sl
. . extajava
v When Ctrl+S pressed in editor SingleTest ovs

ectarT est java

v Or on demand via Build Project action nm eeranine s

get list of classes or methods

3 Packages v X

IBM @server. For the next generation of e-business.

» This slide just shows examples of the content assist and JavaDoc hover help
available in the Java editor.
» The packages view is also shown. The packages view flags classes that
contain compile errors with a red x.
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Java Development Tools

iSeries AD, IBM Toronto

» Getting Started

IBM @server. For the next generation of e-business.
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Java Perspective

iSeries AD, IBM Toronto

» Open the Java perspective

® Perspectives
» Define which views are shown and their layout in the
Workbench
» Targeted towards a specific type of task
v Java, Help, Web, WebFacing, Remote Systems Explorer, XML, ...

e Java perspective contains Java related

views
» Packages
v Shows only the Java projects in your workspace
v Collapses package directories into a single folder in the tree view
» Outline (standard workbench view)
v High level view overview of the structure of your Java class
» Hierarchy
v Inheritance hierarchy of the Java class
» Tasks (standard workbench view)
v Shows compile errors and warnings
IBM @server. For the next generation of e-business.

» Perspectives are used in the Workbench to provide coherent selection and layout of views related to a specific type of development (Java,
XML, WebFacing, ...)

» By default the Java perspective shows the packages, outline, hierarchy and tasks views.

» The outline view is a standard Workbench view for showing the outline of the resource currently opened in the editor. It works for Java and
other resource types like XML and SQL scripts.

» The tasks view is another standard workbench view and shows all errors, warnings and tasks in the workspace not just Java errors.

» The packages and hierarchy views are Java specific. Each of the four views is outlined in more detail on the following slides.
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. ¥ Remote Systems Explorer - Development Studio Client

File Edit Perspactwe Project  ‘Window Help

iSeries AD, IBM Toronto

&k 3 Rencts 5ysms Exporer <
r Srowion Shortcuts to related
= ,@ Hide Editors .
[ |l aveas. Icome to WebSphere De...ment Stu perspectives
Customize.. .
: gi e [To get back to this page at any time, select "Welcome on the
Reset IThiz page tells pou what pou should know before you start us
. o leam more, read the Development Studio Client help or th
Erevious Alb+Up Arrawy
[t Llb+ Dot Arrony
Close 3 iSeries Development
Clase all The Remote Systems Explorer perspectiv %
25 [and other spstems) programmers. This pe oM Select FErSPECHES —I
a treerlike display of files, commands, and
wiew, and Properties view. Other views a; | Data -
U you e il the Pl Systens g %Debus
Help

All available perspectives

/

EE iSeries Projects

i Java Type Higrarchy
ﬁa-ﬁ, Flug-in Development

E‘??) Profiling

] Resaurce

% Scripts

Server

S Taam

|

% Remote Systems Explarer (default]

=l

IBM @server. For the next generation of e-business.

» This slide shows how to open any perspective in the workbench.

» Select the Perspective -> Open -> Other menu option. This displays a list of all available

perspectives. Select the desired perspective and click OK.
» Depending on the user preferences the perspective will either open in the same workbench
window or a new workbench window.
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Java specific wizards

iSeries AD, IBM Toronto

. ¥ Java - Development Studio Client _I_I- O 5‘
File Edit Perspective Project Debug Window Help
B o _ L | i
Open |B-lHBalEsis-I5 % -oece0d |7 &kEa
perspectives| & | @rekeses  ~ x| L x| o x
. % * Simple HelloWorld progam to illustratg = laz O 05 =]
T EG’, Java Samples : the featggis‘{grflti?va Development Tooling -8 combmiava
—>% EE} com. b, java.samples| = 0.91 J dt EG* Hellaw/orld
[ Hellcworld java * L @8 main[Sti
o public class HelloWorld { ava e I or

SRE

#* The main nethod iz invoked when by t
# JREE when the program iz run. Thi= m

#* =imply printsz out Hello World Outline
P k * args AE array Dé ?t_,rings pass A
*
aC ages x the command line. view
H public static woid main(String[] args)
VIeWS System.out . printlln{"Hello World"): —

¥
} -
4] | v 4] I B

Tasks [0 items) e :%E:> %
| Cl | | Desciiption Task VieW | Resouce | In Folder
(error list)
| | »
1 | » Tasks]SearcMConsole

IBM @server. For the next generation of e-business.

» This slide shows a screen shot of the Java perspective (default layout.)

» All open perspectives are shown in the left hand column of the workbench window. Simply click the perspectives
icon to switch to the open perspective (this applies to all perspectives not just the Java perspective.)

» Each perspective typically contributes shortcuts to the workbench toolbar. The Java perspective adds some icons
for creating a new Java project, package. class, interface and scrapbook page.
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Projects

iSeries AD, IBM Toronto

® Highest level of organization for resources
e Contains files and folders

® Projects have
» A type
v Java, iSeries, Server, Web, Simple (generic)
» Properties
» Associated builders
v Builders know how to convert source artifacts (files) to executables

w X

Web a5 DefaulEAR
e roect — | -1 e . . .

proj -3 foeries Frofot < iSeries project
Java pr0jeCt —p | -1 Java Samples

-1z RemateSystemeConnections
1@ RemoteSpstemsT empFiles

B Server: Server project
- WebSphere
- Tomcat

IBM @server. For the next generation of e-business.

» Projects provide the highest level of grouping resources (source files, graphics, executables, ...) in the workspace.

» Projects always have a type such as Java, WebFacing, Web. Those projects that are not linked to a specific type of development should
use the "Simple" type.

» The project type specifies what properties are associated with the project. For example Java projects have a build path property where
users can specify other projects and .jar files that this project requires.

» Projects also have an associated builder which knows how to build resources in the project (i.e. compile .java files into .class files.)

» By default projects map to a subdirectory of the workspace directory on the local file system with the same name as the project.
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iSeries AD, IBM Toronto

¥ Java - Development Studio Client

Enter a name for

Ele Edit Perspective Project Debug Window Help

S EE IR AT your project.
ﬁ ﬁﬁ v X E] Helloworld.java X
A * Sinple Helloh Java Project
’E -G Java Samples: : the featﬁzis‘) Create a new Java project
E) * 0.91
1Y ot . £ Java Project... Project name: IiSeriesJava Samples
o To
il; W t} EELoos V¥ Use default location

* JRE when . B T |
% =imply p: Location: ID.\W’DSC\W’S5D\workspaca\|58r|esJava Samples Browse. ..
®

at
*
*®
public =stati
i

Swsten. q
, e The workspace is where your
T — files (.java, .class, .properties, ...)
B are stored on disk.
ezcrphion

Recommendation: Use the default!

4
Tasks | Search) Conzole

< Back | Neut» | Finish I Cancel

IBM @server. For the next generation of e-business.

» This slide shows the first page of the new Java Project wizard. This page prompts the user for the project name which is the only required
piece of information for the project.

» The user can also override the default workspace directory for this project, but this is not recommended.

» Subsequent pages of the wizard gather additional Java project properties which we will look at later in this presentation.

» Note: There are many different ways to launch the new Java Project wizard (or any of the new wizards). The user can right click in the
packages view and select New -> Java Project ... (as shown in the screen shot) or they could click the new Java Project icon in the toolbar
or select File -> New -> Project...
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Shortcut to Java
package wizard

iSeries AD, IBM Toronto

Your Java Project! R
! va - Development Studio Client Java Package
Fi t Perspective Project Debug Window Help N Create a folder corresponding to a Java package. %
g | = | i ‘ :Xs ol | @( L h Folder: IJlSenesJava Samples Browse. ..
= Package: |com.\bm.\ava samples. iseries
A
2 I \
fro} . .
i) GaTo @ Llass.. Enter a name for your java
] Cpen Perspective  » C?: lnfﬁrfbatﬁl;-- package Typlca"y thIS
; Scrapbock Page... .
2 e starts with the reverse of
ebuild Projec 4 g
Refresh FromLocal 3 20 your companies TCP/IP
Rensme domain name.
Delete
Team 3 .
Comparewith v For example: com.ibm...
Replace With 3
Properties

Note: Right click to get popup menu
- or select shortcut icon |

- or select File -> Java Package

IBM @server. For the next generation of e-business.

» This slide shows the new Java Package wizard. The wizard requires the target folder (Java Project or source folder) and package name.
» The folder can be prefilled by selecting the project or source folder in the workspace before launching the wizard.

» The package name will map to folders in the workspace with each segment (separated by '.") mapping to an individual folder.

» For example com.ibm.iseries -> com/ibm/iseries

» Again there are many different ways to launch the new Java Package wizard.

» Source folders are covered later in this presentation.
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iSeries AD, IBM Toronto

Folder and

Rl
are prefilled Java Class

fl"0m Workbench Create a new Java class.

selection

\ Folder:

IKiSerias Java Samples

. Package: Icnm.lbm java.samples.iseries
Create thls [~ Enclosing type: I
class as an
Inner CIaSS Mame: IJDBES‘.ampIe .
Access modiiers: © public € defaut  ©private. © protected
I abstract [ final ™| static

Superclass: |iava.|ang.Dbiecl

Enter a name

Extended interfaces:

for the class

ich method stubs would pou like to create?
¥ ipublic: static: void main(String]] arosf

Enter any
interfaces you
want your class
to implement

™ Constructars from superclass

I Inherited abstract methods

ol

Select any
access modifiers
for the class

_ Enter the name
of a superclass
or click Browse
to select one
from your
workspace

The wizard can generate
some common methods

coca_|

methods if you want them

IBM @server. For the next generation of e-business.

» This slide shows the new Java Class wizard. This wizard will generate the structure for the new Java class allowing the developer to focus on writing the logic!

» Selecting the target package in the workspace before launching the wizard will prefill the folder and package fields in the wizard.
» To generate an inner class, select the "Enclosing type" checkbox and enter the name of the class in which the inner class is to be created (or click the Browse button to

select it from a list of classes.)

» The three checkboxes at the bottom will generate (if selected):
» The public static void main(String[] args) method for running this class as a standalone application
» Constructors with the same parameters as constructors in the super class. By default these generated constructors will just call the super class's equivalent constructor.

» Inherited abstract methods: These are methods that are defined in the interfaces which this class implements or methods marked as abstract in super classes.

WDT400
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iSeries AD, IBM Toronto

=
File Edit Petspective Project Debug  window  Help

N-lHRa|X% (G- #-X-ldsced @ s BkY 5

iz 4 Packages - X x ] :E Outline 22

’E EQ" iSeries Java Sampl ublic class JDBCSample {
EE} com.ibm java.s.
: JDBCSampl

5ol

R'-g Q" Java Samples
1]

=]

package com.ibm.jawa.samples.iseries:

20 & o

EE com.ibm.java. sam
=2 @* JOBCSample

public static void main{String[] args) { 95 main(Stingl]

|
1 | _»I_I « R
Tasks [0 iterns) o :%:D x
| El | | Description | Rezource | | Falder | Lo

4

4 | 3 Tasks]Saalch|Consola

IBM @server. For the next generation of e-business.

» After completing the new Java Class wizard the .java file is
created in the workspace and the file is opened in the Java

editor.

WDT400
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Java Development Tools

iSeries AD, IBM Toronto

» The Java Editor

IBM @server. For the next generation of e-business.

» The Java editor has basic editing features like cut, copy, paste and color
coding keywords and comments.

» The next few slides will cover some of the additional features of the
workbench Java editor.
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Code Assist - Java Gode
iSeries AD, IBM Toronto

=22 110 Double click on

File Edit Perspective Project Debug Window Help

B-HES X% |[E- -2 oade @ v EE ¥ & |title bar to make editors

x| & oS - and views full screen
- JPMETIT TOOT I 07 1T W0 TIT= T —
% * reads an iSeriesz data phwsical file u=ing JDEC and
* yrites the result to standard out.
@l -
* Toronto iSeries AD Tools team
T * 0.91
*
;‘E blic clas= JDBCSample
Connection jdbcConnection:
ﬁ Statement jdbcStatement:
static {
try[{) i H. terDri { AS400JDBCD (1)
riverManager . registerDriver{new river : .
} catch (SQLEzception e) { Ctl’| + Space bl’lngS Up
= primStaciacel); the code assist with a
¥ . .
- list of all possible
* Constructor.
* . matches based on
* hostnamne The TCP~IP hostnams of the iSeries .
* to be sccessed. what is already typed

*
public JDECSample(String hostnams) |
Connection = DriverManager. getCony
¥

@ getConnection(Sting,Properties]  Connection - Diivertan:
public static woid main(String(] args) | @ getConnection(Sting Properties,ClassLoader) Cannection
@ getConnection(Sting, String,Sting]  Connection - Driverbdz

4 q| | | |

IBM @server. For the next generation of e-business.

» Content assist provides a list of class names, interfaces, fields and methods that are available in the current scope.

» To invoke content assist press Ctrl + space (or right click and select content assist from the popup menu.

» The list of options is subsetted by what you have already typed. For example: entering get and then pressing Ctrl +
space will show only methods starting with get. If you keep typing then the list is further subsetted.

» Tip: When using the workbench the user can double click on the title bar of any editor or view to maximize the editor /
view to take up the entire workbench window.
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Code Assist - JavaDoc

iSeries AD, IBM Toronto

. ¥ Java - Development Studio Client =13l x|
File Edit Perspective FProject Debug ‘Window Help
S-HRA[X%[a- -t daceP e[| ERYE
= |IEEG: x
— DOFT Java. sl LOnHecCTIon: -
% inport java.sgl.Statement:
i o3 .=ql . SOLE; tion; H H
[ || "ot e sal-SOlException Code assist is also
inport com. ibm. as400. access. *; i i
o3 available in JavaDoc
i R .
@ * Sanple class to illustrate the features of the Comments for
EB * ¢h»Java Development Tooling<s in WDSC Thi= claz=
EE * reads an iSeries data phvsica)l ¢ </ooder L HTML
* yrites the result to standard o
—_— * < v IR \/<b> . </b>
* Toronto iSsriss AD Tof<» </ . .
s 0.91 & cipres v <i> ... <[i>
ublic claszs JDECSanple [ v ...
Connection jdbcConnection: u
Statement jdbcStatement: JaVaDOC keywords
static { v @param
try o
DriverHanager. registerDriver(new AS400JDECDriwer()): v @retu m
} catch (SQLEzception =) {
e.printStackTrace(): V..
1
SEE
* Constructor. =
*
* hostname The TCP-IP hostneme of the iSeries
* to be accessed.
*
public JDECSample{String hostname) {
Connection = DriverManager. getConn
4 hd
| | D

IBM @server. For the next generation of e-business.

» Content assist is also available for JavaDoc comments inside the Java editor.
Content assist for JavaDoc can provide suggestions for HTML tag names and
JavaDoc keywords.

» Again the list will be subsetted by what is already typed.
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JavaDoc Reference

iSeries AD, IBM Toronto

> javadoc JDBCSample.java

#3 : Class JDBCSample - Microsoft Internet Explorer 1ol =l

J File Edit Wiew Favorites Tools  Help ﬁ
J B L | m| @5earch (Gl Favorites £ Histd B S =1~ D8

J Address I@ Ditempcomiibmi javalsamplesiiseries| JDBCSample, html j @GD
-

|MEE] Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES MO FRAMES
SUNMARY: INNER | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

com.dhm.javasamples iseries

Class JDBCSample

Java. lang. Chject

|
+--com. ibm.java.samples.iseries.JDPBCSample

public class JDBCSample
extends java.lang Object

Sample class to dlustrate the features of the Java Development Tooling m "WDEC, This class reads an 13enes data
physical file using TDBC and writes the result to standard out.

N ER

|@ Done l_l_ |@. My Computer
IBM @server. For the next generation of e-business.

» This slide shows an example of generated Java Documentation (JavaDoc) from the previous slide.

» Generating JavaDoc is currently not integrated into the Workbench (next release) so the user
needs to export the .java source files and run the javadoc command shipped as part of the Java
SDK.
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Managing Your Imports .
iSeries AD, IBM Toronto

® Window -> Preferences
® Specify order imports should be listed

» For example: java, then javax, then com
» Add your own!!!

® Specify how many qualified imports to use
before importing everything

¥ Preferences x|
- Workbench Drganize Imports
- Build Order
- Data Preferences use d by the Organize Imparts action.
- Debug Define the sorting order of import statements. & package name prefis
- Help [e.g. org.eclipse] iz a walid entry
Internet
- iSeries Java Tools L)
- iSenes Projects col T —
=-Java =
- Clagspath Variables Up
- Code Farmnatter
- Installed JREs Down See next slide
i Java Editor
- Drganize Imports Murnber of gualified imports before .* is used [e.0. org.eclipse.”): |2 |
- Refactaring
- LPEX Editar

IBM @server. For the next generation of e-business.

» Java tools can also be configured to manage the import statements in Java classes.

» The first thing the user should do is open the Preferences dialog and set the number of qualified
imports that they want to have before the import is changed to a global import (i.e. java.sql.*;) By
default this value is set to 99. A value of 2 or 3 is recommended.

» The user can also specify in which order the Java tooling should list imports.
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Managing Your Imports

. ¥ Java - Development Studio Client ;IEIZI

iSeries AD, IBM Toronto

Ele Edit Perspective Project Debug Window Help

F-HEa(E%|a- -4 - daxcer| e s B i

5 ecoauie)

package com.ibm.java.samples. iseries; -

i<

=

’E import jawva.=sgl. DriverManager:
import jawva.=gl . Connection:

E) import jawva. =gl Statement:
import jawva.sgl. SOLException:

i

]

i)

import com.ibm.as400. access. *;

e
* Sample Undo ate the {Mgtures of the
*® (hxJava Redo ling<~b>» 1IRWDSC. Thisz class
* reads a Revert hy=zical filAu=zing JDEC and
* writes - andard out
. cut 4D Tool gy
Copy . ¥ Java - vevelopment Studio Client
Paste Fle Edt P#&spective Project Debug Window Help
Select Al . = . —_ T iU v iw W -
el 5-EEIN X% - B-%X-ddcer® 7Bk
Brint o \ = ]
Shift: Right: % ackage .ibm.java.=amples. i=series;
Shift: Leff: . .
e L= D—_El import java.sqgl.*;
Comment
Uncamment E) import com.ibm.as400.access. AS400JDECDriver;
Format P:J .
Cantent Assist EB *® Samnple cla== to illustrate the feature= of the
Adal " #® ¢hxJava Development Tooling<-h: in WDSC Thi= clas=
[por E:'E * reads an iSeries data phy=ical file using JDEC and
Organize Imparts i #* wyrites the result to standard out.
*
Exbract Method.., * Toronto iSeries AD Tools tean
*® 0.91
Eind/Replace. .. =
Go ko Ling... e B B LA | =L =R (P

IBM @server. For the next generation of e-business.

» Once the user's organize imports preferences are set they can use
the right click "Organize Imports" action from the Java editor. This will
format the import statements in the class according to the preferences
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Managing Your Imports

iSeries AD, IBM Toronto

. . ¥ Java - Development Studio Client =10 x|
To Import a Class File Edit Perspective Project Debug ‘Window Help
simply highlight the S HE8 (2% |e- - loacod ® v BF¢ I
class name and select & EEEEL L X[ L e e
* d 5 data ph 1 fil JDEC and =
"Add Import" from the ’% « writes the result to Standard out. o
popup menu. E) : T\S%glilto iSeries AD Tools team
r *
E; public class JDBCSanple |
EB Connection jdbeConnection;
EE Statement jdbcStatement i
Tip: Double clickingon — static { el
. . EyEr
a class name or ) catch (SOiEsopiion o 1 e [0
variable will highlight TprmeStasesty
Paste
|t S Select Al
* * Constructor.
* Print
* hostnane The TCP-IF hostna
. #* to be accessed. Shift: Right:
* )
Error In COde because public JDBCSample(String hostnams) { ithtLafL;
— 45400 400 = host Sz
the class AS400 has 2s400 = nov Bl hastnane
b Format:

not been imported yet.

Conkent Assist

public static void main(String[] arg: -
¥ Add Import

Organize Imports

Extract Method...

-
EindfReplace, .. 3 |
3o to Line...
Add 3

IBM @server. For the next generation of e-business.

» Another handy feature of the Java editor which is to automatically add the import statement for a class.

» In this screen shot and error is shown on the one line because the class AS400 has not been imported yet. To automatically import this class:

» Highlight the class name in the editor

» Select "Add Import" from the right click popup menu

» This will add the import to the class according to the user's organize import preferences. For example: If two classes had already been
specifically imported from the com.ibm.as400.access package and the user's preference was to globally import after 2 classes, then this action
would cause those first two imports to be removed and a global import to be added because the AS400 class is also part of this package.
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Formatting Your Code

iSeries AD, IBM Toronto

. ¥ Preferences x|
= The Java Editor can
. - Workbench Code Formatter
automatically format | -suidoe
your code however i Nawine | Lie spiting | Syle |
yOU WOUId I|ke - Help ™ Insert rew line FJefore opening brace
. . - Internet [ Insert rew line in contral statement
»Maximum line |ength igeries}ljava Tools I~ Clear al blank lines
- 15enes Projects s
»{} preferences o v v K "
v NeW |ines Classpath Variables empty block
, . - Cods Formatter
v Same line as code - Instaled JREs 1 =
> .. E""Ja\"aEd'tD' if {size « currentSize) |
i Organize Imports try { i nst 1ab1eQ)
: size = inStream.available();
5 L;-éieé‘;c:torlng } catch (IDException e) {
- tar
[ Plug-In Development I else 1f (size == currentiize} {
o +size;
. [#- Profiling }oelse |
1. First set your ié- Remote Systems
. [ Scripts H
preferences in the - Server ;
H - Team
preferences dialog N
- 'web Tools _ILI
5 XML Il ,
Then - Restore Dalaullsl Apply |
Carcel_|

IBM @server. For the next generation of e-business.

» There is another Java tooling preference that allows the user to specify how they would like their
code formatted. The user can specify things like the maximum line length, whether { } brackets
should start on a new line or not, tabbing, ...

» These preferences do not change what the user types in the editor until the format action is

explicitly invoked as shown on the next sl

WDT400

ide.
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Formatting Your Code

. ¥ Java - Development Studio Client
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iSeries AD, IBM Toronto

2. Right click in
the editor and
select "Format"

VOILA!

IBM @server. For the next generation of e-business.

» The "Format" popup menu action formats the current file as
outlined in the user's Java tooling code formatter preferences.

WDT400
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IBM @server. For the next generation of e-business.

» This slide just shows some other misc. Java editor functions for handling blocks of code

» Although fairly trivial, these functions can be quite useful. For example:

» To add a try ... catch around a block of code, select those lines and "shift right" so they are properly
indented

» To temporarily remove a block of code, use the "Comment" action to temporarily comment out those lines
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Java Development Tools

iSeries AD, IBM Toronto

> Nominees For Best Supporting
View

IBM @server. For the next generation of e-business.

» Within the workbench views can be used to greatly increase productivity when used in conjunction with the editor. The
Java tooling uses the following views which are outlined on the following slides:

» Packages View

» Hierarchy View

» QOutline View (this is a standard workbench view used by many perspectives)

» Tasks View (this is a standard workbench view used by all perspectives)
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Packages View X
iSeries AD, IBM Toronto

® The Eclipse tree view for managing all
resources in the workspace
e Shows Java classes in their package

directories
» This takes a lot of space in the tree view
» For example: com/ibm/java/samples

» Packages View

® Provides central place to manage your
Java resources

e Shows only Java related projects
» This includes Web projects!

e Packages shown as single entry in tree view

IBM @server. For the next generation of e-business.

» The Navigator view is the standard workbench view for managing (view, renaming, copying, deleting, ...) resources in the
workspace. There are a few things that make this view difficult to use when working with Java resources:

» The view shows all projects in the workspace whether they are Java or not

» Packages are shown as their corresponding folders (com / ibm / etools / iseries / ...) which takes up a lot of the room in the tree view

» The packages view addresses both of these issues by showing only Java projects (and those projects which have a Java nature like
Web projects) and showing Java packages as a single entry in the tree view.
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Packages View
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Projects
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E| Q iSenies Java Samplas Filters...
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Packages —— " [d] JOBCSample.java Show Yersion Info |
Source files
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. {_ﬁ'}; JRE_LIE - DWW DSCWSSDretlibit jar
=+ DWW DSCWWS S DY plugingcom.ibm.etaols.
FLE¥ Java Samples

Libraries referenced by
this project (more on this
later when we look at the
project build properties)

Tip: These can also be 3 | ,
expanded!

IBM @server. For the next generation of e-business.

» The packages view will also let the user see any referenced libraries directly

in the tree view.
» Reference libraries are setup in the properties for the Java project and will be

covered later in this presentation.
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Outline View
> Java Outline View

® Works in concert w/ Java Editor

® Shows imports, fields, methods
» Can subset what is shown
» Can sort by name " e
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in editor *2 O" |

iSeries AD, IBM Toronto
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IBM @server. For the next s siness.

» The outline view shows the structure of the Java class currently being edited.

> Its main function is to provide the user with a high level view of the structure of the class and provide easy navigation in the editor. Selecting a method / inner class in the outline view will automatically position the editor to the
corresponding source code.

= The outline view also provides many additional actions. These are available by right clicking on the different items (classes, methods, fields) in the outline view. For example:

» Right clicking on a field in the outline view will give you the option to generate standard getter and setter methods for the field.

» To remove a method simply right click on the method in the outline view and select "Delete". The method and its corresponding code will be deleted from the editor.

» The outline view also provides some additional functionality such as:

= Toggling showing fields on / off

» Toggling showing static methods on / off

» Sorting the list of fields / methods

» Showing only the selected field or method in the editor instead of the entire class file
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» Java Outline View
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Editor
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methods
» Can subset what is shown
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Hierarchy View
iSeries AD, IBM Toronto

® Provides 3 different ways to view a class in
its type hierarchy

» Show only supertype hierarchy

v This includes superclasses and interfaces!
» Show only subtype hierarchy
» Show class in its full hierarchy tree

v Includes both superclasses and subclasses

e Ability to perform actions
» Create copies of methods from superclasses in current
class

v Right click on method and select "Create in classname"

» Refactoring
v Rename methods and fields
v Rename parameters for methods
v Generate getter and setter methods for fields

IBM @server. For the next generation of e-business.

» The hierarchy view uses a tree view to show a class relative to its superclasses and subclasses. This is very
useful to search for a method in the superclasses of the class currently being edited.

» Using the hierarchy view the user can easily override a method in a superclass by selecting the method in the
superclass, right clicking and selecting "Create in ..." from the popup menu. This creates a method stub for
the selected method in the current class which you can then go and provide the new implementation for.
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Hierarchy View
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IBM @server. For the next generation of e-business.

» Here is a screen show of the hierarchy view with descriptions for the various features of the view.

» The first option (show selected members in hierarchy) will let you select a member from the list at
the bottom of the view and the tree view at the top will be updated to show which classes have
defined this method. This allows the user to quickly see where the method has been overridden
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® Shows:
1. All compile errors, warnings and information associated
with resources in the workspace
2. Tasks defined by the user
v Tasks can be set on a specific line in a resource or globally
v "Don't forget to add error checking here!"

e Not Java specific!
» Shows errors and tasks for Java, HTML, XML, RPG, ...

® Provides ability to filter by
» Type of problem
»Java problem, XML Schema problem, broken links in HTML or JSP
» Severity of the problem or priority of the task
» Problem / task description
» Based on what is selected in the navigator / packages view
» Status of the task

IBM @server. For the next generation of e-business.

» The tasks view is a standard workbench view showing all errors, warnings and user defined tasks
in the workspace.

» Because it shows contains all workspace tasks it provides filtering capabilities to scope what is
shown in the actual view by the type of problem / task or based on what is selected in the
navigator / packages view.
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Tasks View

Project and folder(s)

Resource where the
where the resource

problem / task occurs

is located
Global task
= No resources is specified .
Fil t\e r
\
Wa rnlng T-:«:::I::ilﬁ items) ORI x
C | | @D escription | Fesource | In Falder | Lacation |
:‘/_ | Finish Java Tooling Presentations
A The method getLogStreaml) from the type java...  JDBCSample..  iSeiesJava Samples/com/bmfa..  lne 27 ind... |
A5400 cannot be resolved or is not a bype JOBCSample.j..  iSeresJava Samples/comdibmia..  line 39 inJ..

a3
Error — % 2@

-

Completed task

Implement main method JDBCSample.j.. | iSeresJava Samples/comdbmia.. | line 45

Tip: Double click on the task / problem to open
the resource in the editor at the correct line!

IBM @server. For the next generation of e-business.

» This slide shows a screen shot of the tasks view with
descriptions for all the features / columns.
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Java Development Tools

iSeries AD, IBM Toronto

» Gompiling

IBM @server. For the next generation of e-business.
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Compiling Your Java Class
iSeries AD, IBM Toronto
> Done!

e Everytime you save your file it is
automatically compiled!

e Manually compiling
» Right click on the project, package or class and select
either:
v Build Project
v Incremental build
v Builds only resources that have changed
since the last build
v Rebuild Project
v Full build

v Discards previous build state and rebuilds
everything Delete.

Refresh From Local

IBM @server. For the next generation of e-business.

» When a user saves a Java class (.java file) it is automatically compiled
and all errors / warnings are shown in the tasks view. However we can
also force a recompile using either the build or rebuild project actions.
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Java Development Tools

iSeries AD, IBM Toronto

> Running

IBM @server. For the next generation of e-business.
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Running Your Java Class

iSeries AD, IBM Toronto

> How you run your class depends on
whatitis

e Standalone Java application
» Class implements method:
v public static void main(String[] args)
» Run locally using
v JDK shipped with the workbench
v Any locally installed JDK
» Run remotely using iSeries extensions

® Servlet
» Class extends javax.servlet.http.HttpServiet
» Servlet can be run in
v Local WebSphere Test Environment
v Local Tomcat Test Environment
v Local Tomcat Application Server
v Remote WebSphere Application Server

IBM @server. For the next generation of e-business.

» How the user runs a Java class will depend on what type of Java application it is.
» If it is a standalone Java application (i.e. it contains a public static void main(String[] args) method) then it can be run

locally using either the JDK shipped with the workbench (this is the default) or any JDK installed on the local PC. The

user can specify which JDK to use in the Java project properties.
» If the Java class is a servlet then it must be run in either the local WebSphere Test Environment (default) or any other

application server environment supported by the workbench. Currently this includes the 4 scenarios listed on this slide.
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2. Select Run -> Java Application
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IBM @server. For the next generation of e-business.

» This slide shows how to run the standalone JDBCSample Java application used through out this presentation.

» To run the application simply select the class in the packages view and from the Run icon in the toolbar select Run ->
Java Application. If the application writes any output to either System.out or System .err then the workbench console

view will appear with the output.

» If the Java class were a servlet then to run it in the local WTE you would select the class from the packages view and
select "Run on Server" from the popup menu.

WDT400



Java Development Tools

iSeries AD, IBM Toronto

> Java Debug
Not that you will need it!

IBM @server. For the next generation of e-business.
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Debug
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IBM @server. For the next generation of e-business.

» To debug the Java application select the class in the packages view and select Debug -> Java
Application from the Debug toolbar icon drop down menu.

» It is a good idea to set breakpoints in your source code before launching the application in debug
mode. This will cause the debugger to stop at the first breakpoint it hits in the application.

WDT400 Page (41)



» This slide just shows a screen shot of the overall debug

iSeries AD, IBM Toronto
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IBM @server. For the next generation of e-business.

perspective. The next couple of slides provide more details.
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IBM @server. For the next generation of e-business.

» The top view shown in the screen shot (Debug view) shows all applications that are currently being debugged in a tree
view. Below each application all threads are shown, and for each suspended thread the corresponding stack trace.

» The Debug view contains icons for resuming a suspended thread, suspending a thread, stopping an application and
for stepping into / over a line of code or running to the end of a method. These options are also available from the
Debug menu and have associated shortcut keys.

» Below the Debug view is the source view where source files are opened if a breakpoint is hit.
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iSeries AD, IBM Toronto

e Breakpoints View
» Manage breakpoints in the workspace
» Add Java exception breakpoints
v Stop when a NullPointerException is thrown

v This can be very handle in locating
problems!

e Inspector view
» Detailed view for inspecting variables

e Variables View

» Shows all variables that are visible in the
current stack frame

e Display View
» Displays result of executing an
expression in context of current stack
frame
» Highlight expression in editor and select
"Display" from the popup menu

IBM @server. For the next generation of e-business.

» To the right of the Debug view is another pane showing the 4 views listed on
this slide. The two main views are the Breakpoints view (used for managing

breakpoints) and the variables view (used for viewing and changing the

contents of variables in the application).

WDT400
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>Searching ...
Now where did that go?

IBM @server. For the next generation of e-business.
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® Global workspace searching
» Search the entire workspace

e Context sensitive searching
» Scope to workspace or class hierarchy
» Packages / Classes / Interfaces / Variables / Members
v Find all places where referenced

v Find all places where they are declared
v In workspace, or
v In class hierarchy

» Interfaces
v Find all implementors

® Results are shown in the ""Search' view

IBM @server. For the next generation of e-business.

» As outlined on this slide, there are two main ways to search for "things" in the workspace.

» The first is just a simple raw text search that will search for a string pattern in any type of file.

» The second is a "Java-aware" search that will let you search Java files for strings that are context specific. Such as
» Declarations of all methods that start with getA*

» References to all methods that start with getA*
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Java Aware Search
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IBM @server. For the next generation of e-business.

» This slide shows the "Java-aware" search dialog. Use the
radio buttons to define the context of the search.
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Context Searching
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For" and "Limit To" fields.

IBM @server. For the next generation of e-business.

» Instead of having to type the class / method name and select all the radio
buttons in the previous slide, the user can use the popup menu on fields /
methods in the outline view to also search for references and declarations.
This way the user will not be prompted.
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Java Build Path

iSeries AD, IBM Toronto

e Each Java project has a build path that

defines
» How resources are built
v Where output (.class files) are placed after a build
» \Where external resources are located
v Source from other projects in the workspace
v JAR files from other projects
v External JAR files

e Similar to setting the CLASSPATH when
running applications outside the
workbench

IBM @server. For the next generation of e-business.

» Each Java project has a build path property which specifies which projects and internal / external
(relative to the workspace) jar files this project requires in order to compile and run.

» This is very similar to setting the CLASSPATH environment variable for a JDK.

» To set the build path, right click on the Java project and select "Properties" from the popup menu.
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Java Build Path - Source
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. B-TaF Irtranst Application
project and Java packages [ERTE e Jnva Gamples

[-1a Java Samples

IBM @server. For the next generation of e-business.

» In the Java project properties dialog select "Java Build Path". This displays a four page notebook.
We will look at each page on the upcoming slides.
» The first page lets you specify whether or not this project uses source folders to organize Java

packages. For large projects, source folders give you an extra level of organization for your Java
code.

WDT400 Page (50)



Java Build Path - Projects

iSeries AD, IBM Toronto

x|
UUUUU = Projects | W, Litraries I Tl Order I
FRequired projects on the build path:
G Irtranet Application Select Al
& Java Samples Dieselect &l
Build output folder.
ASenes Java Samples Browse... |

m Projects
» Select all projects in the workspace that are required by
this project
vi.e. This project uses classes in the other project

IBM @server. For the next generation of e-business.

» The "Projects” page lets the user specify which other Java
projects in the workspace should be included in the build path
for the current Java project.
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Java Build Path - Libraries

iSeries AD, IBM Toronto
X

++ Beaninfo Path Java Build Path

= Suurcel 1= Projects Il Libraries | Tl Drderl

JABz and class folders on the build path:
:;"'Lfm:’;' ; 5 JRE_LIE - D:/WDSCAWSS D fe/ib At jor Creale Folder .
[ eeteness (il 400 ot - D AWDSCAVSSD /pluginfoombm etaols siss... | 4 Folders.. Add JAR file
AddJAFs.. L from another
Add Egternal JARs... project
Add Yariable...
Attach Source... Add JAR flle
E— from the local
filesystem

Build output folder:

AiSenes Java Samples Browsze |

mLibraries
» These are NOT OS/400 libraries!
» Specify all JAR files required by your Java project

vi.e. IBM Toolbox for Java
d:\WDSC\WSSD\plugins\com.ibm.etools.iseries.toolbox\runtime\jt400.jar

IBM @server. For the next generation of e-business.

» The "Libraries" page lets you specify which jar files should be included in the build path for the current project.

» Use the Add JARs button if the jar file is already located in the workspace.

» Use the Add External JARs button if the jar file is located somewhere else on your local hard disk.

» The Add variable button is similar to Add External JARs except that it lets you defined a variable for the source path
where the jar file is located. If you have multiple jar files in the same directory you can use a variable to point to the
directory. That way if the directory name changes you only have to update the variable not every single entry.

WDT400 Page (52)



Java Build Path - Order

iSeries AD, IBM Toronto
x|

ooooo | = P|o|ects| Wl Libiaries  TL Order |
Build clazs path:

J JRE_LIB - D: WD SCAWSSD Aredlib/ jar Up |
ﬁ}; {400 jar - D:AWDSCAWSS D plugins/com. bm. etools. iseries. bag D |

(25 fiSeries Java Samples

| |
Build output folder:

Ix’\SeriasJava Samples Broﬂse...l

m Order
» Specify the order the projects and libraries are included in the build path

» This is important if the different versions of the same class exists in to
different entries

IBM @server. For the next generation of e-business.

» The "Order" page lets you specify the order that other projects and
jar files should be included in the build path. Select the entry in
the list and use the move up / down buttons to change the order.
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Java Development Tools

iSeries AD, IBM Toronto

> iSeries Additions

IBM @server. For the next generation of e-business.

» So far this presentation has looked at the generic Java tooling provided by
WSSDa, nothing specific to the iSeries platform. Now we will look at iSeries
specific extensions to the Java tooling. This slide shows an overview of those
extensions. The following slides will look at each one in more details.

WDT400 Page (54)



Java Tools for iSeries

iSeries AD, IBM Toronto

» [Series extensions for Java

® Overview / Nutshell:
» Import and export from/to remote system
» Remote Compile and Run
» Remote Debug
» Program Call wizard
» Toolbox for Java built-in
v As an Eclipse Java project (i.e.: easy to add to classpath of your
project!)
v Integrated help
v Runnable samples
» Supplied Java-beans
v Swing GUI beans (dspf-like functionality)
v DFU beans (database access)
v Object list beans (library, object, member, field, record lists)

IBM @server. For the next generation of e-business.

» Export and import to/from IFS, via common remote system frame-work support

» Special Java "compile" actoin/view for remotely compiling Java classes

» Special Java run action/view for remotely running Java applications

» Special Java debug action/view for remotely debugging Java applications

» Program Call wizard to "wrapper" any *PGM/*SRVPGM as a Java Bean

» Previously supplied Java beans: datafile updates (DFU), objects lists (PDM), and Swing formatting
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Java Tools for iSeries
iSeries AD, IBM Toronto

® Import and export

» Builds on base support for import/exporting files/jars/zips
» Add support to import/export files from remote system

v Import any files from any remote system (iSeries/Unix/Linux/Windows)
v Eg: IFS on iSeries; Linux LPAR on iSeries

v Export files from any gro'ect to anﬁ remote sgstem

Fil: Edit Perspective Project  Window  Help Select 2
Hew b Expart rezources to a remate file spstem I
Close Chrl+F4
Close all Chrl+Shift+Fa Select an export destination:

Save HELLOWORLD, rpg Chrl+5 BAR file

i} .C‘ File system

[2], save HELLOWIORLD.rpg As... FeETR
& save Al Chr4Shift+S
& Print ChrHR
o . Ezipiie

1 MyProject/MYFILE/HELLOWORLD rpg

Exit

< Back I Mext » I Einish Cancel
IBM @server. For
= [ =)

» The workbench allows the user to import and export your code (Java and non-Java code) from / to
a variety of locations. To this list we added the ability to import from and export to a remote
system (iSeries or non-iSeries).

» Like all the other import / export wizards, this ability is not restricted to Java only.

» On the iSeries this wizard exports to and imports from the integrated filesystem (IFS).
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Java Tools for iSeries

#-[]& PhiDemo =-C2 400home

TR Prlovsemo Select files to 03 LiTest?
- E-EEE custamer
- [Flz= demo export

[0 wasservlets
DQ RemoteSystemsConnections l:l A00harne

----- O RemateSystemsTempFiles [:l alfonso
-G8 Servers -3 applets
[~ (23 cheng

L B = W 1

. ¥ Browse For Folder to
Select a folder
I.-"4DDh0me.-"zdem0
| |-  fov Comecir -
] E% My iSeries
Remote file system -2 /A0LS
Expart resources o a remote file spstem. E‘E?d JOFileSyr. 400
,._,—‘Ed AMetfare
Select the rezources to expart: ‘5% AUNTC
I._,—lf—d A0penSys
Dg Default_EAH Customer. clazs o ALOPT
-]k My Project [J] Customer.java By ADSYS.LIB

Select Tupes.. | Select Al Dezelect Al |

Select the export destination: Remembers
Folder: IMy iSeries: /400hame zdemn prEVious |
export folders

Options:
[T Owenwrite existing files withaut warking

[T Create directary stucture

IBM @server. For the next generation of e-business.

» This slide shows the next page of the export to remote file system wizard.
Here the user specifies which files to export from their workspace and to

which remote system and directory on that remote system.
» The import wizard has a similar page.

WDT400
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Java Tools for iSeries
iSeries AD, IBM Toronto

» After exporting Java files to iSeries, you:
v Transform them there using CRTJVAPGM
v Run them there, see results via Console

Perspective  Project  Window Help
Cpen 3 I
Shows View d 75 Navigator
Hide: Editors :m

= Bookmarks
5 As... o .
ave oS = Outline

Cuskomize, .. E 8 "
BESEt roperties

Tasks
Previous Alt+Up Arrowe
Texk Alt+Down Arrow

ok i Cancel |

IBM @server. For the next generation of e-business.

» This slide shows how to open the Remote Compile and Run View.
» Open the "iSeries Console and Run View" to natively compile (CRTJVAPGM),
run and debug your Java applications remotely on the iSeries.
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pile and Run iew *
Select home folder, and options N |
‘working folder. Brouse. |
Cierins |
Option set; IDption et / Fiun, debug remately iSeries Java program |
— Choose classe
Run, debug remaotely [Create iSeres Java programD‘ ®-E customer
Clags: I
Clazzpath: Ia’4DDhome£zdemofcustomer
CRTW ARG
Arguments; I Sion
Bun Stop | LClear LClear Log
Conzole out: | |
™ Allow JAR files
Carmpile | B E
Cahzale it - Option set 2 | u LI S
l_ - Option et 3 Optimization: 7 —T
- Option set 4
Statusinfol | i Dption set 5 Replace program: fvEs <
s Enable performance collection: I *NONE j
Taskz Search User profile: I"USEH j
User adopted authority: I N0 j
Directony subtree: I *NONE j
Target release: |"EU RRENT j
Licenzed intemal code optimization: I"UPT|M|ZE j
(=]

> At the top of the iSeries Compile and Run View the user needs to specify the remote system and directory (typically this is the same system and directory you specified on the export
wizard.)

» Before running or compiling the Java class the user can setup their options. For the compile action these options are the parameters that are passed to the CRTJVAPGM command.
For running these options we setup our library list and environment variables.

» On the Run, Debug remotely tab of the view the user can specify the Java class they want to run / debug along with the classpath and any command line arguments that need to be
passed to the application.

» Console out and in allow the user to view output from and send input to the remotely running Java application.

» Switching over the the Create iSeries Java Program tab allows the user to run the CRTJVAPGM command on the iSeries to natively compile the selected Java class to machine
instructions. These machine instructions are stored in a hidden object associated with the .class (or .jar) file and used by the JVM on the iSeries to increase runtime performance.
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Java Tools for iSeries
iSeries AD, IBM Toronto

» Launches debugger for iSeries Java
v Same debugger as RPG, CBL, CL, C, C++

ﬁIBM Distributed Debugger
File Vew Selecied  Debug  Source  Breakpoints  Monitors  Window  Help

9y YL ] oo |

-
# EwsTTESTOEGDEMO:D  §F EWJSBQThreadStartup: v[ Advancedgptions...|
: E Saurce
Stacks  Breakpoints IProgramsl n | .
hread 2*CLASS  /jsho/EWvISBGOZ
| o8 Breakpoints | =] 56 dof | M
=@ Line Breakpoints 67
----- @ Source: *CLASS  fjsha/EVWJSBQ0 68 temp+-
@ Source: *CLASS  Jjsho/EWISBQ0 59 temp += 5
@ Gource: *CLASS  Jjsho/EVWISBEQD a0
71 while [comnt+ <= ) ; (Clear Console |
72 1
73 /4 return statment
74 return;
75 }
76
‘I I v 77
78 =+ public woid changeSomething() !
79
Monitors I\_ocals | 30 /4 local to method, they are not me
81
| Expression Mo... | (=] 3z int a = Z;
-4 count=Java variable is not available. 83 @ String Saffering - "EWTSEQ0Z";
...‘ sh g4
L sZ5tng = null 85 AF implicit return 5 2
84
..... s sormromonegomerawndl) Of €-business.

S

» Instead of running the Java application remotely the user can
instead debug the Java application as it runs on the iSeries.
Clicking the Debug button launches the IBM Distributed Debugger.
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iSeries AD, IBM Toronto

+/ Program Gall Wizard

e Given signature of *PGM or *SRVPGM proc:
» Generate Java Bean to call it
e Steps:
» 1. Select Java/Web/WebFacing project
» 2. Select package
» 3. Use File->New->Other...
v ...ISeries Java Program Call Bean

IBM @server. For the next generation of e-business.

» Here we step through the very popular Program Call wizard, which has been significantly enhanced from its old VisualAge for Java days.

» Using this wizard is easy.

 First, within any view that lists projects, select a project to contain the generated Java code. You are allowed to select from Java, Web or WebFacing projects.
Only these types of projects support Java.

» Second, select the Java package within that project, into which the Java code will be generated. You must pre-create such a package if you don't have one

» Third, launch the program call wizard, by using the File->New->Other menu item. In the resulting wizard, select the iSeries Java and then Program Call Bean

~ Follow directions on the following slides.
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Java Tools for iSeries

Select X
Thig wizard generates Java beans to call iSeries programs or procedures, ﬁ
L5

- Java

Data
- Plug-in Development Program Call Wizard
- Remate File Transfer
- Server

iSeries AD, IBM Toronto

Define program definitions for your program or procedure g

- Simple
Wb
- \wieb Services
- ‘webFacing Add Program... | Add Parameter... | Add Structure. .
ML |
[]- i5 eries =i Edit Program
EE"" JaTa Java bean name: IMyProgram
o
i Eamples Program object: IGETDLVSTS Browse... |
Library: |PHILDEMO
| Frogram type: I “PGEM j
Entry point: I
Fieturmn type: I woid j
Thread safe: Ifalse j
Source location: I j Wiew..
Import PCRL... Synchronize All | Type Inof;’ press Ok Cancel

< Back |I Mewt » Finish I Cancel |

IBM @server. For the next generation of e-businéss.

» On the File->New->Other wizard selection page, select the Program Call Bean
wizard and press Next
» In the Program Call wizard, select the program or ILE procedure to be called
from Java. This must be a non-interactive program or procedure

WDT400
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Enter Parameter Info ,
»

iSeries AD, IBM Toronto

Add Program.... I Add Parameter... | Add Structure...

Define andiname
structure

Add Parameter

Parameter name: I Add Structure
Data type: Icharacter 'l Structure name: I
Structure name: Caount: |
Length: Usage: Iinput & output I
Frecizion: Output size: |
Count: > 0 for Min. version: I
|zage: array Max. version: |
Initial walue: Offset: I
Offset from: |
[ Advanced...

Specify databaze reference field Specify... Be sure to press OK for
Show database field definition Shov.. each parameter I structure

Frogiam call definitions

g3 nbrCodes

- divCodes
o o |

IBM @server. For the next generation of e-business.

» Use the Add Parameter and Add Structure buttons to describe all the parameters to the program
or procedure, including data type, length and decimals. Most importantly, specify if the parameters
are input, output or both with respect to what the program does with the parameters (read, write or
both)

» When all parameters are described, press Next to continue to the next page of the wizard
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Program Call Wizard

Create iSeries Program Call Java bean and PCML file
Specify the location where the Java bean and PCML file to be generated. g

e e o Where'to generate Javaiclass Biowse..|

Package: |customer.demo j Browse... |
L WL Where to generate PCML file M

Generate Java beans and a PCML file for:

v Java application

W Select \Web Services to generate Java code optimized for:
use in the Web Services wizard

These filez will be generated by the wizard: TO change parameters
MyProgram. pen Summary of files later:
MyProgram. mpeml . .
MyProgram$ ervices. java that WI" be [ J Retum tO leard
MyProgram.java
generated @ Use Import PCML...
The clazz path of the specified project will be automatically updated. button

Generated Java beans require the following JAR files at compile time and run time: Runtime files you
ECLIPSE_HOME /plugins/com. ibm. etoals. iseries. toolbow/runtime 400, jar Wi " need tO
ECLIPSE_HOME /plugine/com.ibm. etools. iseries. webtoolslibAvwdt4 005t jar )

ECLIPSE_HOME /plugine/com.ibm. etools. websphere. untimelib/werces. jar dep|0y Wlth yOUI'
ECLIPSE_HOME /plugins/com.ibm. etools. websphere. untimelib/j2ee. jar COde

< Back | Test > | Finish Cancel |

IBM @server. For the next generation of e-business.

» This slide shows the page where the user can confirm where they want the Java code to be generated, including the Program Call Markup
Language (PCML) file that is also generated.

» For the generated Java bean to be used as a Web Service, select the Web Services checkbox. This generates a Java bean that is easily
consumable by the Web Services wizard.

» Notice how the wizard will automatically update our project's classpath to include the necessary AS/400 Toolbox for Java jar files so that our
generated code will compile.

> Finally, press Finish to generate the Java bean!!
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@
m

dit Perspective Project Debug Window Help

|E% - -%- e @ sIERE ]

4
— |

)
g Packages: PhilavaDemo w3 || [9] MyProgram.java X ] :"—‘ Outtline: 20 & o x
% = package customer .demo: - customer.dema
g} =-F3 customer.demo import java math. = impart declarations
0] Customer java import com.ibm.as400. access . *; MyProgram
7] MyP import com.ibm.connector. as400. ProgramCallBsan; — - @  MyProgram(]
program.[ava import com.ibm.connector.as400.FrogramCallRecord @  getRetCodef)
n-@ ) MyProgramFiesul java import com.ibm.connector.as400.ProgramCallStruct @ gelNbiCodes()
’E = m MyPragramS ervices. java g -
i) [B) MyPragram mpeml public class MyProgram extends ProgramCallBean g .geleIondes[mt]
tdyPragram. poml e
. . @ setConnectionD atal45400]
Eg% ‘IJEFE’ZELTIL_EIii ED\LVE/?:EI\Q\::S./‘E;::[; public MyProgram() @  zetConnectionD ata[String, Sting, Sting)
(i, ECLIPSE_HOME /plugines /o super(); @ pelS400hiect]
. . =etPcmlNane( "custoner . demo . MyFrogran" ) : @  setlibraryList{String(])
[ ﬁh ECLIPSE_HOME /plugins/con = Do N
[]“ﬁ}\ ECLIPSE_HOME /piugins/co setProgranlane( "HyProgran" ) ; @ dizconnect()
- } - @  setTraceEnabled(boolean)
leard public Integer getRetCode() = >setconnecuonData('")
adds ‘r | _,lJ »to identify signon info
required BCRage 'u"\'lq-us oner . denv, »setLibraryList(...)

p
public class Test MyProgram

files to { ) S _ »to set runtime library list
project ?ubl ic static void main(String[] args) ’SetXXX(...)
P test = P ; H
S WEomantest Z ot MESKA0L e o, weassier | 10 Setinput parameters
test.setLibraryList(new String[] {"PH LDEMD'}); >|nvoke0
test.invoke();
Example int nbrResults = test.getNorCodes().intVal ue(); » {0 run program
ackag . t t.println("Nor Codes: " + nbrResults);
using fs'yorS (eimn?ui dgr:::)n ig§<<nb; Resuletss; idx2+; suls) >getxxx()
gen'd bean { Systemout.println(" code " + idx +": " + >to get OUtPUt parameters

test.get Dl vCodes(idx).trin());
}

IbM (@server. For the next generation ol e-business.

» Here we see the result of the Program Call wizard.

~ The selected Java package in the upper right now contains all the generated Java classes, one of which is shown in the editor in the middle view.

» To use the generated Java bean, we write Java code to instantiate it and call the important methods in it, which are listed in the information box in the lower left. An example of Java code to use the bean is shown in the lower middle information
box.

> The pattern for using the generated bean is this:

~ 1. Instantiate the bean using the New operator

» 2. Call the setLibraryList method with an array of library names to set up the library list

» 3. Call the setXXX methods to set the input parameter data. There will be one such method for each input parameter

» 4. Call the invoke method to call the program or procedure

~ 5. Test the boolean result of invoke for true or false to determine if the invoke was successful

» 6. Call the getXXX methods to rea the output parameter data that the program updated. There will be one such method for each output parameter

-
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Java Tools for iSeries
» GUI Beans for iSeries

iSeries AD, IBM Toronto

® Java Beans supplied for DDS-like field

error-checking and formatting:
» JFormattedTextField (smart entry field)
v Error checking based on data type, length, decimals
v DDS-like validity checking: range or comparison
v Editcode or editword formatting and masking(!)
v Auto-advance
» JFormattedLabel (smart label constant)
v Editcode or editword formatting
» JFormattedComboBox (smart dropdown)
v Combo of JFormattedTextField and JFormattedLabels
» JFormattedTable (smart multi-column list
v A "subfile" or multi-column list box
v Each cell is a JFormattedTextField or JFormattedLabel or
JFormattedComboBox

IBM @server. For the next generation of e-business.

» Included with the iSeries extensions to the Java tooling are some GUI and non-GUI Java beans that can be used in applications

developed by WDSc customers.

» This slide shows the GUI beans included with WDSc. These beans extend their Swing counterparts but add customizations that iSeries
developers are used to with display files such as:

» Restricting a value to numeric, string, ...

» Specifying the values length and precision

» Specifying formatting using edit codes / words

WDT400



WDT400

Java Tools for iSeries
» GUI Beans Examples

e File->New->Other->Examples->iSeries

iSeries AD, IBM Toronto

» J Form attedTable E‘%JFormattedTahleSample M= E3
IternMa Model Size Price
00001 2000-AE-1 |[small ¥ ||100
00002 2000-AF-2 1 E00. 50
00003 2000-AE-3 i um (369
00004 2000-AE-4 iy [Foo
00005 Z000-AE-5 SIA A05
00006 Z000-AE-6  |small 110
ooooy Z000-4E-7 small 230,49
00008 Z000-AB-5 medium 265
00009 Z000-AE-2  big 732
> JFormattedTeXt EEAEQUITY ORDER ENTRY [_ O] x|
Symbol: IEM

Price: ,gng
Account No.: ’W
Password: ’T

= Contact Phone: (555)1l1-2z22
IBM @server. For tiemextgencratonor c=oasiness.
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» DFU Beans for iSeries (non GUI)

® Java Beans supplied for querying data
from DB2/400, using direct record access
(versus SQL):

» RecordlOManager:
v Query, add, update or delete records in a database
v Vastly simplifies task of writing database access code using
Toolbox for Java classes
» ListManager:
v Maps list of records from RecordlOManager to a Swing GUI list
v Makes it easy to populate GUI list with DB2/400 data
» FormManager
v Maps details of a single row from RecordlOManager to a single
GUI dialog page
v Makes it easy to populate GUI form with DB2/400 data

IBM @server. For the next generation of e-business.

» This slide lists some non-GUI beans that can be used in a Java application to
assist the developer in reading records from and iSeries physical file. The
ListManager retrieves lists of records for display in a GUI list, where as the
FormManager can be used to retrieve a single record for display in a GUI form.
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Java Tools for iSeries

> DFU Beans Examples

® File->New->Other->Examples->iSeries

» ListManager

FormManager with a multiple record format logical file

Order:  |DEF456

Order Date

Customer Order

Customer

Ship Wia

Ship To

Price

Goods

1998-03-24

EEEEEEE]

hhhbbbhbhbbbbh

cCe

deddddd

5555633

BEBE

iSeries AD, IBM Toronto

PARTNO MODEL PARTPRI | PARTMSR | PARTDIS | PARTSHIP
00562 AR-10 Z6.10 Z9.00 T 1991-05-10
00562 BR-11 3Z.04 36.00 T 1992-12-02 |5
00562 AR-12 7.92 9.00 i) 1994-05-07
00562 BR-13 11.31 13.00 i) 1991-09-25
00074 R-1 35.64 36.00 i) 1990-07-07
00074 BR-11 31.15 35.00 i) 1990-01-05
00074 BR-12 Z9.92 34.00 i) 1994-03-19
00074 \BR-14 39.56 46.00 i) 1993-12-22
01507 AR-10 24,30 Z7.00 i) 1994-06-16
01507 BR-11 Z0.47 Z3.00 i) 1993-10-13| 4

readallRecords

» FormManager

IBM (@’server. F

or the next generation of e-business.




Java Tools for iSeries

iSeries AD, IBM Toronto

> List Beans for iSeries (non-GUl)

® For querying lists of libraries, objects,

members, records or fields
» AS400ListLibraries
v List libraries given simple or generic or special name
» AS400ListObjects
v List objects given simple or generic library and object name
v Can also subset by type and attr (one or multi, simple or generic)
» AS400ListMembers
v List members given simple or generic library, file, member name
v Can also subset by member type (one or multi, simple or generic)
» AS400ListRecords
v List records given simple or generic library, file, record name
» AS400ListFields
v List fields given simple or generic library, file, record, field name

e Four levels of detail possible per object

IBM @server. For the next generation of e-business.

» This slide shows some additional non-GUI beans for retrieving
lists of libraries, objects, members, records and fields from an

iSeries.

WDT400
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Java Development Tools

iSeries AD, IBM Toronto

» Summary

IBM @server. For the next generation of e-business.
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Java Tools Not There

iSeries AD, IBM Toronto

x Visual Composition Editor

x DataBase Beans
v Actually, there are replacements! Just no visual metaphor
v See com.ibm.db.beans: DBSelect, DBProcedureCall, DBModify
v There is also a Database access wizard in Web Tools

x SQLJ support
x Stored Procedure Builder
x Live editing while debugging

» For UAJava migration...

» www.ibm.com/software/wsdd

v "VisualAge for Java coexistence with WebSphere Studio Application Developer"
v http://lwww7b.boulder.ibm.com/wsdd/library/techarticles/0110_searle/searle.html

IBM @server. For the next generation of e-business.
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Summary

iSeries AD, IBM Toronto

» Java Development Tooling included in WDSC
e Part of WebSphere Studio Site Developer Advanced

» Java Perspective provides optimized view for Java

development
e Java Editor + Java Views = Easier Development
e Integrated Compile / Run / Debug
® iSeries Additions for using Java with iSeries
e Lots more ...
» Team development
» Integrated, online help system
» Extendable platform

v You can add your own tools
» Integrated Java, Web, XML, iSeries development

» Enjoy!

IBM @server. For the next generation of e-business.
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» Eclinse.ory

® Website for the open source Workbench

»WDSC

® ibm.com/software/ad/iseries/

» WehSphere Developer Domain

e ibm.com/websphere/developer

> 1BM Developer Domain

e ibm.com/developer

» Java

® java.sun.com

IBM @server. For the next generation of e-business.
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Domino is a trademark of Lotus Development Corporation and/or IBM Corporation.

C-bus is a trademark of Corollary, Inc. in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.
ActionMedia, LANDesk, MMX, Pentium and ProShare are trademarks of Intel Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

SET and the SET Logo are trademarks owned by SET Secure Electronic Transaction LLC.

Other company, product and service names may be trademarks or service marks of others.

Information is provided "AS IS" without warranty of any kind.

All customer examples described are presented as illustrations of how those customers have used IBM products and the results they may have achieved. Actual
environmental costs and performance characteristics may vary by customer.

Information in this presentation concerning non-IBM products was obtained from a supplier of these products, published announcement material, or other publicly
available sources and does not constitute an endorsement of such products by IBM. Sources for non-IBM list prices and performance numbers are taken from
publicly available information, including vendor announcements and vendor worldwide homepages. IBM has not tested these products and cannot confirm the
accuracy of performance, capability, or any other claims related to non-IBM products. Questions on the capability of non-IBM products should be addressed to the
supplier of those products.

All statements regarding IBM future direction and intent are subject to change or withdrawal without notice, and represent goals and objectives only. Contact your
local IBM office or IBM authorized reseller for the full text of the specific Statement of Direction.

Some information in this presentation addresses antici future it Suchii ion is not intended as a definitive statement of a commitment to specific
levels of performance, function or delivery schedules with respect to any future products. Such commitments are only made in IBM product announcements. The
information is presented here to communicate IBM's current investment and development activities as a good faith effort to help with our customers' future planning.

Performance is based on measurements and projections using standard IBM benchmarks in a controlled environment. The actual throughput or performance that any
user will experience will vary depending upon considerations such as the amount of multiprogramming in the user's job stream, the I/O configuration, the storage
configuration, and the workload processed. Therefore, no assurance can be given that an individual user will achieve throughput or performance improvements
equivalent to the ratios stated here.

Photographs shown are of engineering prototypes. Changes may be incorporated in production models.
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