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The Agenda

Remote Systems Explorer
Communications Console
Advanced Functions
Working Disconnected
Customizing the Editor 

REXX Macros
Editor profiles
LPEXLET

Demo
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WebSphere Development Studio client
WebSphere Studio Site Developer AdvancedWebSphere Studio Site Developer AdvancedWebSphere Studio Site Developer AdvancedWebSphere Studio Site Developer Advanced

Web tools
Java tools
XML tools
WebFacing
iSeries tools (Remote Systems Explorer)

Classic toolsClassic toolsClassic toolsClassic tools

For RPG, COBOL, CL, C, C++, DDS

VisualAge RPG
For RPG GUI

   CODE   CODE

WebSphere Development Studio for iSeriesWebSphere Development Studio for iSeriesWebSphere Development Studio for iSeriesWebSphere Development Studio for iSeries

Copyright International Business Machines Corporation, 2002



Remote Systems Explorer (RSE)

CODE -  integrated in WDScCODE -  integrated in WDScCODE -  integrated in WDScCODE -  integrated in WDSc

Editor Designer

Debugger Remote compile

Program
Verifier

Error List

CODE tools

WSSDA + iSeries tools

Work with
iSeries objects
Invoke any

iSeries
command

work with jobs
and more ....
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WDSc: RPG and Cobol ToolsWDSc: RPG and Cobol ToolsWDSc: RPG and Cobol ToolsWDSc: RPG and Cobol Tools

Remote Systems Explorer Perspective
Drill-down or filtered access to remote:

QSYS Libraries, Objects and MembersQSYS Libraries, Objects and Members
IFS Folders and FilesIFS Folders and Files
Linux, Unix, Windows and Local Folders and FilesLinux, Unix, Windows and Local Folders and Files

Remote command execution of 
QSYS Commands and QSHELL CommandsQSYS Commands and QSHELL Commands
Linux, Unix and Windows CommandsLinux, Unix and Windows Commands

Exploration of Jobs in QSYS

iSeries Projects 
For structured, project-based development
Local team-sharable project
Holds source files, members and save files
Each project associated with an iSeries and library

Push action to copy local files to associated libraryPush action to copy local files to associated library
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Remote Systems Explorer PerspectiveRemote Systems Explorer PerspectiveRemote Systems Explorer PerspectiveRemote Systems Explorer Perspective    

Manages connections to remote systems
Where you create/manage connection Where you create/manage connection 
informationinformation
Connections subsequently used in all Connections subsequently used in all 
iSeries toolsiSeries tools
Start by using the 'New Connection' Start by using the 'New Connection' 
wizardwizard

Connection appears in tree viewConnection appears in tree view
Expand it to see "subsystem" -> Expand it to see "subsystem" -> 
functional groupingsfunctional groupings
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RSE ConnectionsRSE ConnectionsRSE ConnectionsRSE Connections

New ConnectionNew Connection
WizardWizard
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Remote Systems PerspectiveRemote Systems PerspectiveRemote Systems PerspectiveRemote Systems Perspective

ExpandExpand filterfilter toto
see objectssee objects

resulting fromresulting from
resolution of filterresolution of filter

Actions available inActions available in
the context menuthe context menu
depend on objectdepend on object

typetype
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RSE  CustomizationRSE  CustomizationRSE  CustomizationRSE  Customization

Library Filters
To view groups of libraries.

Object Filters
To view one or more types of objects in one 
or more libraries.

Member Filters
To view one or more member types in one or 
more files in one or more libraries.

User Actions
Add an action to the popup menu for all 
objects or one specific object type.   
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STRCODE vs TCP/IP auto-connect serversSTRCODE vs TCP/IP auto-connect serversSTRCODE vs TCP/IP auto-connect serversSTRCODE vs TCP/IP auto-connect servers

Started from 5250 emulation Defined in Properties dialog or
generated by RSE
Started at first use

Libraries defined in
Communication Properties are
added to the ones set from user
profile

Libraries defined in
Communication Properties are
added to the ones set from user
profile

Shutdown for single session
from Communication Properties
Shutdown all from Editor,
Action bar, Daemon context
menu

Deleted from Properties
RSE servers deleted at shut
down

Use whenever iSeries screen I/O
is required: Prompting for
iSeries commands or CL , CL
Help
Program Generator
Debugging pgms with screen
I/O

Edit sessions, Program Verifier,
Designer, etc.
Debugging programs without
screen I/O

 STRCODE                               TCP/IP  STRCODE                               TCP/IP  STRCODE                               TCP/IP  STRCODE                               TCP/IP 
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Communication ConsoleCommunication ConsoleCommunication ConsoleCommunication Console

Available from:
Start menu -> Programs -> IBM WebSphere Development Tools for iSeries ->

Communications -> Communications Console
Editor -> Windows -> Communications -> Properties
CODE Daemon context menu -> Properties
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Comm. Properties - CODE Server ListComm. Properties - CODE Server ListComm. Properties - CODE Server ListComm. Properties - CODE Server List

Used to:
select to have STRCODE servers first in the list
reorder the servers - some functions like Verifier use first

available server
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Communication Properties - Server InfoCommunication Properties - Server InfoCommunication Properties - Server InfoCommunication Properties - Server Info

Used to:
add, modify or delete TCP/IP auto-connect servers
Shutdown the selected STRCODE or RSE server
Check PTFs for all installed components of WDS
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Communication PropertiesCommunication PropertiesCommunication PropertiesCommunication Properties

Library List
Set or change the library list for one  
specific server or all servers (*ALL).
Use Move Up and Move Down buttons 
to change the order.

Change Management Settings
*NONE or Application Development 
Manager/400

Communication Error Log
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HTML  SupportHTML  SupportHTML  SupportHTML  Support

Token highlighting
Ctrl+M, Ctrl+Shift+M to select
matching tag
Create tags from Actions
menu

Launch browser from
Actions menu
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CODE Editor - FiltersCODE Editor - FiltersCODE Editor - FiltersCODE Editor - Filters

To filter by text, select
'View'->'Filter'

To filter by line
type, select

'View'->'Show'

To filter by date, select
'View'->'Filter date'

Ctrl+A to show everything

Various Text Filters
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CODE Editor - SET DEFAULT.EXPANDHIDE ONCODE Editor - SET DEFAULT.EXPANDHIDE ONCODE Editor - SET DEFAULT.EXPANDHIDE ONCODE Editor - SET DEFAULT.EXPANDHIDE ON

Stays on until explicitly switched off. SET DEFAULT.EXPANDHIDE OFFCopyright International Business Machines Corporation, 2002



Field Cross Reference Field Cross Reference Field Cross Reference Field Cross Reference 

List of
fields

List of
indicators

Line #s
where

referenced

Select line # in list
Line positioned, highlighted in

editor

available for RPG and COBOL
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CODE Editor - RPG ConversionCODE Editor - RPG ConversionCODE Editor - RPG ConversionCODE Editor - RPG Conversion

Convert RPG III to ILE RPG
Actions -> Convert RPG Source

Converted RPG gets stored locally
Same result as iSeries command 
CVTRPGSRC

Convert ILE RPG free-form 
Actions -> Convert selection to C Free-Form
Actions -> Convert all to C Free-Form
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The NavigatorThe NavigatorThe NavigatorThe Navigator

To create a file that lists the called
and calling functions, select

'Services' ->'Topology'.
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CODE Program GeneratorCODE Program GeneratorCODE Program GeneratorCODE Program Generator

New label
Create Debuggable ILE RPG

module

Command

Command parameters

Debug view parameter *ALL
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Debugging batch jobsDebugging batch jobsDebugging batch jobsDebugging batch jobs

Submit job to the Jobq with the HOLD
option set to *YES:

SBMJOB CMD(CALL PGM(CODELAB01/TESTBATCH)) HOLD(*YES)

Start debugger from the Start menu or
command line or the CODE editor as
Running application.
Get job info of submitted job
Start debug session
Debugger will release the job and
display the source when the program
starts running.
Note: If you start from the CODE editor, you will
have to release the job yourself.
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Debugger Settings - Session SettingsDebugger Settings - Session SettingsDebugger Settings - Session SettingsDebugger Settings - Session Settings

Debugger Settings are
available from the Load
Program or Attach
dialog.

Check 'Update
Production Files' to
allow access to
production libraries
while debugging.

Set Local and IFS
Source Path for Java
and C++.

Debugger Settings are per host
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Debugger - Monitor Expression dialogDebugger - Monitor Expression dialogDebugger - Monitor Expression dialogDebugger - Monitor Expression dialog

Monitor variables:
Select Monitors -->

Monitor Expression
Type the variable name and optionally

add occurrence
Note: The dialog gets prefilled with any

selected variable.

monitored variables
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CODE Designer - Editing DDSCODE Designer - Editing DDSCODE Designer - Editing DDSCODE Designer - Editing DDS

Design Mode

When you verify DDS source in the
'Edit Mode', all errors go to the
integrated 'Error List' window.

NOTE: Some of the changes made in
the 'Edit Mode' may cause problems
going back to the 'Design Mode'!!!

e.g. Deleting the record line

You can switch between 'Design' and 'Edit'
modes. Use 'File'->'Edit DDS source' and
'File' -> 'Design DDS source' respectively

Edit Mode
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CODE Designer - CheckpointsCODE Designer - CheckpointsCODE Designer - CheckpointsCODE Designer - Checkpoints

Checkpoints
Snapshot of the entire DDS source at a given point in
time.
Two types: automatic and user-defined
User-defined checkpoints are saved between sessions.
You can 'revert' back to a checkpoint.

Checkpoints taken in
'Design Mode'

Checkpoints taken in
'Edit Mode'

Certain 'drastic' changes in 'Edit Mode' (e.g.
delete a record line) may get you in trouble!
Revert to previous checkpoint in such cases.
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CODE Designer, Named Indicators setsCODE Designer, Named Indicators setsCODE Designer, Named Indicators setsCODE Designer, Named Indicators sets

Name of set

Select which set is in effect

Check which
Indicators are
in set

'F7' brings up
the dialog
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CODE Designer,  Styles pageCODE Designer,  Styles pageCODE Designer,  Styles pageCODE Designer,  Styles page

Save the settings of an object as a style and then reset
other objects of the same type to that style.
Change creation defaults of objects.
Alternatively can use REF keyword for DB Reference
fields

New fields are created using:
REF keyword if checked
Otherwise Creation defaults

Change style to be like
the current DDS object

Change the DDS
object (record/field) to
be like selected style
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CODE Designer,  Convert to FieldCODE Designer,  Convert to FieldCODE Designer,  Convert to FieldCODE Designer,  Convert to Field
Convert text constant to field with F11.
All appropriate editing codes are created.

$999,999.99
Allows SDA syntax.

+B(10)

Before conversion After conversion
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Start CODE tools from PDMStart CODE tools from PDMStart CODE tools from PDMStart CODE tools from PDM

You can create user-defined options in
PDM to invoke CODE tools.
To invoke the CODE Editor on a source
member you would use the following
syntax:

CALL QDEVTOOLS/EVFCFDBK PARM('37' 'Y' 'OS400'
'<LOCAL> CODEEDIT "<server>&L/&F(&N)" ')

For V4R5 iSeries use:

CALL QCODE/EVFCFDBK PARM('37' 'Y' 'OS400'
'<LOCAL> CODEEDIT "<server>&L/&F(&N)" ')
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Working disconnectedWorking disconnectedWorking disconnectedWorking disconnected

Work with local source.
Syntax check RPG, ILE COBOL, and DDS
Prompt RPG, COBOL, and DDS.
Access language reference help for RPG, COBOL, and DDS.
Verify RPG, COBOL, and DDS (without caching, copy members
and information on database fields will not be available).

Edit, design, or compile host source.
Debug host programs.
Execute host commands.
Prompt CL statements.

What You CAN DO while
disconnected

What You CAN NOT DO while
disconnected
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CachingCachingCachingCaching

Information retrieved from the iSeries during your session is saved
locally. CODE searches locally for the host information. If all the
necessary information is cached, no host connection is needed.

In Program Verifiers, select 'Verify
program'->'Prompt', in Settings tab select
"Use cache".
Shortens verify times, since subsequent verifies
do not need to access the host.

If host information changes, you have
to "refresh" the contents of the cache.

In verifiers, select "Refresh cache".

The local files are saved in the
WDSC\CACHE directory

(Occasionally, you will want to clean up
this directory to free up space)Copyright International Business Machines Corporation, 2002



Editor Programming Editor Programming Editor Programming Editor Programming 
Why program it?

Need for a new editor function
Repetitive task, fastpath key for heavily used function
Tailor the editing environment for your shop

What can you do?
Specify editor default settings
Add editor functions and your own macros to the 
menus and toolbar
Assign/re-assign keys and/or line commands to
editor functions and your own macros
Interact with the host via the CODESRV command

How do you do it?
Write macros in REXX or Java + editor commands 
Use the 'profiles' to load in the macros.
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CODE Editor - Key shortcutsCODE Editor - Key shortcutsCODE Editor - Key shortcutsCODE Editor - Key shortcuts

Text manipulation example:
Ctrl+ Backspace - delete entire line
Ctrl+Delete -- delete to end of line

Block marking of lines, characters,
or rectangles with copy, move,
overlay, and delete operations
example: Alt+U -- unmark text

For more info select:
'Help' -> 'Keys help'

Unlimited undo and redo
Ctrl+Z Ctrl+Shift+Z
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To map file name to source types select:
Options -> Associations -> Name patterns

CODE Editor - AssociationsCODE Editor - AssociationsCODE Editor - AssociationsCODE Editor - Associations

To map source type to a specific
language profile select:
Options -> Associations ->
Source types
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Editor Programming - commandsEditor Programming - commandsEditor Programming - commandsEditor Programming - commands

Editor Commands
To issue a command, press ESC and enter the
command.
To position to line number 12.
FIND LINE 12

To insert a new line.
INSERT

To change the current line's text.
SET CONTENT this is new

To display message on message line.

MSG this is a message

Editor Command Line

Editor Source Editing Area
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Add function to the menubar
SET ACTIONBAR.pulldown.item command

Add function to the toolbar
SET TOOLBAR.button_text position command

Assign keyboard shortcut
SET ACTION.key command

Add function to the popup menu
SET POPUPMENU.menuitem command

Get help when editor command fails
Windows->Macro log to view messages.

Editor Programming - commandsEditor Programming - commandsEditor Programming - commandsEditor Programming - commands
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Editor Programming - ReferenceEditor Programming - ReferenceEditor Programming - ReferenceEditor Programming - Reference

'Editor Reference' online documentation
contains help for all editor commands,
sorted alphabetically!

'Editor Reference' is
available from the 'Help'
pulldown.
This information is
invaluable when writing
editor macros!
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Editor Programming - MacrosEditor Programming - MacrosEditor Programming - MacrosEditor Programming - Macros

Text files with extension .LX 
Contain REXX statements and embedded 
editor commands 
Query and set attributes of the editor
Use CODESRV command to invoke iSeries 
commands, retrieve lists, etc.
Invoked from editor by                     
"MACRO macro_name parameters"
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Editor Programming - EXTRASEditor Programming - EXTRASEditor Programming - EXTRASEditor Programming - EXTRAS

EXTRAS macro updates path the editor
searches when macros are executed.

Default is WDSC\MACROS
Add WDSC\EXTRAS (which contains
many example macros) to path
Actions -> Enable EXTRAS

Add your own directory to path
EXTRAS ON d:\mymacros

Use d:\mymacros to store your own macros
and profiles. This helps prevent changes
being lost on release upgrades.
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Editor Programming - EXTRASEditor Programming - EXTRASEditor Programming - EXTRASEditor Programming - EXTRAS

Remains on until disabled
EXTRAS OFF or EXTRAS -> Disable Extras

Change at any time
EXTRAS ON d:\myothermacros

Specify multiple directories
EXTRAS ON d:\mymacros;e:\workmacros

Open local files
The LX editor command used to open
files uses same search path for local files.
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Writing a REXX macro Writing a REXX macro Writing a REXX macro Writing a REXX macro 
Open a new ILE RPG file:

'testfile.rpg'

Execute macro rpgproc

Prompt for the name of the new
procedure.
User enters name and clicks OK.

Create a template for the
procedure MyProc (name,
entered by the user...)

1 3

Execute macro rpgproc

42
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REXX macros - creating promptsREXX macros - creating promptsREXX macros - creating promptsREXX macros - creating prompts

Every REXX program starts
with a comment. It is
customary to explain what
the macro is doing...

Setup the following parameters:
Prompt box title
Prompt box label
Size of the entry field

If the user did not enter any text,
or pressed 'Cancel', put up an
error message and bail out...

Retrieve the following
Text typed in the entry field
Which button was pressed

NOTE:The 'Cancel' button is
equivalent to 'ESC' key...
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REXX macros - creating templateREXX macros - creating templateREXX macros - creating templateREXX macros - creating template

Setup Procedure
declaration part.

Setup procedure end

The C specs of your
procedure will be inserted

here!

Setup procedure
beginning

Substitution variables are
placed outside the
quotes!

Pad procName with
blanks if needed to make
sure it is 10 characters
long!!!
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Setting up toolbar and menusSetting up toolbar and menusSetting up toolbar and menusSetting up toolbar and menus

Add rpgproc macro to the toolbar
SET TOOLBAR.RPGProc BITMAP _33 HELP "Proc template" 4 macro rpgproc

Add rpgproc macro to the 'Extras' menu
SET ACTIONBAR.E~xtras.~RPGTools.RPG~ProcTemplate\tCtrl+Z macro rpgproc

Add rpgproc macro to the popup menu
SET POPUPMENU.RPG~Proc rpgproc

Toolbar button

Menu option

Popup menu entry
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Editor ProfilesEditor ProfilesEditor ProfilesEditor Profiles

Profile When does it run? Can I change it?

PROFINIT.LXU When the editor starts. Yes

PROFSYS.LXU Just before each file is
loaded.

Yes

xxx.LXL
xxx = cbl,rpgle400, etc.

After PROFSYS.LXU,
but before a file of type
xxx is loaded.

No

xxx.LXU After xxx.LXL but before
the file is loaded.

Yes. Add your own xxx
specific commands
here.

PROFILE.LX The last profile run
before each file is
loaded.

Yes

xxx.LXS Whenever a file of type
xxx is saved.

Yes

Special editor macros run at specific times
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Editor Profiles: RPGLE400Editor Profiles: RPGLE400Editor Profiles: RPGLE400Editor Profiles: RPGLE400

'SET ACTIONBAR.LP_VIEW.Inden~t RPGIND '
'SET HELP. 12451'

/* Add Navigator */
'LXR NAVIG.LX'

'SET ACTIONBAR.LP_VIEW.~Match.~Select MACRO MATCH '
'SET HELP. 16154'
'SET ACCELERATOR. C-M'
'SET ACTIONBAR.LP_VIEW.~Match.~Jump MACRO MATCH JUMP'
'SET HELP. 16155'
'SET ACCELERATOR. C-S-M'

'SET ACTIONBAR.LP_VIEW.~Cross_reference macro runjava RPGXReference'
'SET HELP. 16196'

'SET ACTIONBAR.LP_VIEW.~/COPY_member_(SEE) MACRO RPGINC'

'SET ACTIONBAR.LP_ACTIONS.SEPARATOR ;'
'SET ACTIONBAR.LP_ACTIONS.Smart~Guides.Create_~procedure... macro runjava LpexRPGProcSG'
'SET GROUP. WRITEABLE'
'SET HELP. 16197'

Sample of the RPGLE400.LXL

/* Setup the menu, tollbar, and pop-up menu item */
'SET ACTIONBAR.E~xtras.~RPGTools.RPG~ProcTemplate\tCtrl+Z macro rpgproc'
'SET TOOLBAR.RPGProc BITMAP _33 HELP "Create RPG proc template" 4 macro rpgproc'
'SET POPUPMENU.RPG~Proc rpgproc'

User defined
sample of the

RPGLE400.LXU
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CODESRV commandCODESRV commandCODESRV commandCODESRV command

CODESRV is a workstation command
that can be used to:

Get a list of active host CODE servers.
CODESRV SERVER

Shutdown all or specific servers.
CODESRV SHUTDOWN

CODESRV /S OS400

Send commands to the iSeries.
CODESRV EXEC OS400 STRSEU OPTION(6)

SRCFILE(CODELAB01/QDDSSRC)
SRCMBR(MSTDSP)
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CODESRV command, cont'dCODESRV command, cont'dCODESRV command, cont'dCODESRV command, cont'd

Download source
CODESRV GET OS400

"CODELAB01/QDDSSRC(MSTDSP)" c:\mstdsp.dspf

Upload source
CODESRV PUT OS400 c:\mstdsp.dspf

"CODELAB01/QDDSSRC(MSTDSP)"

Get lists of objects that match a filter
CODESRV LIST OS400 "CODELAB01/QDDSSRC(*)"

You can imbed the command in your
macros.
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Using CODESRV in a macro Using CODESRV in a macro Using CODESRV in a macro Using CODESRV in a macro 

/* SEUPRINT - a macro to print the current member being edited on the host. It uses the */
/* SEU print option. */

/* Blank out the message line */
'msg' ' '
/* Get full name of file being edited */
'extract name'
/* Get the name of the server, file and member */
parse var name '<' server '>' fn '(' mn ')'
/* Drop /ADM from server name if it exists */
parse var server host '/' junk
/* Issue error if this is a LOCAL file... */
if host = 'LOCAL' then do
'msg Host Print is not valid for local files.'
'ALARM'
exit

end

/* Prompt user to save source, then print it on host... */
'SAVEALL PROMPT START CODESRV EXEC 'host' STRSEU SRCFILE('fn')
SRCMBR('mn') OPTION(6) (LOG'

'msg Member printed using STRSEU. See Command Shell for status.'

SEUPRINT macro prints the current member being
edited on the host. It is shipped with CODE.

Use the CODESRV command to save the
source and print it using SEU print option.
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Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets

Lpexlets
Use Java to customize the editor. Same capability as
REXX but with power to create graphical-user-interfaces
Classes that can access the editor inherit from the
LpexCommand class, the LPEX Java Programming
Interface. These classes are called "Lpexlets".
Invoke from editor by "RUNJAVA class_name". The
class file must be in the CLASSPATH and the class
name is case-sensitive.
Many samples in sample.jar in WDSC\JAVA.
The Java Development Kit (JDK1.2.2) is required to
develop Lpexlets. The JDK or Java Runtime
Environment (JRE) is required to run them. Both are
available from JavaSoft's web site www.javasoft.com.
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Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets

In addition to 'OK' and 'Cancel' we
will add a 'Clear' button

We are going to ask for the
Procedure Name
Programmer Name

We will enhance our RPGPROC macro with
the dialog written in Java - an Lpexlet
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Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets

import RPGProcFrame;

public class RPGProc extends LpexCommand
{

static RPGProcFrame rpgProcFrame = null;

/* lpexEntry() - main entry point from LPEX. Overrides LpexCommand's. */
public static int lpexEntry (String arg)
{

if( rpgProcFrame == null )
rpgProcFrame = new RPGProcFrame();

rpgProcFrame.setVisible(true);
return 0;

} // end lpexEntry()

// Once the Ok button is pressed, need to set DOCVARs
public static int setDocVars(String procName, String pgmrName)
{

lpexCommand("SET DOCVAR.PROCNAME " + procName);
lpexCommand("SET DOCVAR.PGMRNAME " + pgmrName);

lpexCommand("MACRO RPGPROCJAVA");
return 0;

} // end setDocVars()
} // end class RPGProc

Every Lpexlet must inherit from the LpexCommand class.
You will implement lpexEntry( ), main entry function.

Other LpexCommand members
to be implemented include
lpexNotify( ) and lpexExit( )

Create an RPGProcFrame object
and show the dialog box...

lpexCommand() function
executes editor commands.
We need to SET DOCVARs so
that these values can be read
later by the REXX macro.

Our Lpexlet will call REXX macro to
generate the procedure template codeCopyright International Business Machines Corporation, 2002



Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets

import javax.swing.*;
import javax.swing.event.*;
import java.awt.*;
import java.awt.event.*;

public class RPGProcFrame extends JFrame implements ActionListener
{

private JPanel contentPane = null;

private JButton cancelButton = null;
private JButton clearButton = null;
private JButton okButton = null;

private JLabel pgmrNameLabel = null;
private JLabel procNameLabel = null;
private JTextField pgmrNameTextField = null;
private JTextField procNameTextField = null;

...............................

...............................
} // end class RPGProcFrame

Data definitions for the RPGProcFrame class.
Every GUI control has a private data member associated with it.

JPanel object provides a 'home' for all
other GUI controls. In the literature,
people may call it a client canvas.

It is a good programming
practice to initialize all
data members to null.

RPGProcFrame class extends JFrame
class and implements ActionListener
interface.
Java's ideas of multiple inheritance!
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Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets
/* Class constructor */
public RPGProcFrame()
{

super();
setSize(426, 240);
setTitle("Vadim RPG Procedure Template");

// Create Ok button object
okButton = new JButton("Ok");
okButton.setBounds(42, 170, 85, 25);
okButton.addActionListener(this);

// Create text label for procedure nanme
procNameLabel = new JLabel("Procedure Name");
procNameLabel.setBounds(35, 27, 146, 20);
// Creating an entry field for procedure name
procNameTextField = new JTextField();
procNameTextField.setBounds(218, 27, 169, 19);

// Construct the JPanel object - client canvas and add all controls
contentPane = new JPanel();
contentPane.setLayout(null);

// Add all entry controls and corresponding Labels to the client pane
contentPane.add(procNameLabel, procNameLabel.getName());
contentPane.add(procNameTextField, procNameTextField.getName());
contentPane.add(okButton, okButton.getName());

// Now that everything is constructed, set the client pane to contentPane
setContentPane(contentPane);

..........

..........

} // end constructor()

Every class needs a constructor!

Creating an 'OK' button and
making the JFrame object listen to
the button clicks.

Creating a label and an entry
field for the Procedure Name

Adding freshly created GUI
controls to the JFrame.

A JPanel object that resides
inside the JFrame!
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Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets

/**
* Overwrite actionPerformed() method of the ActionListner interface
* If any registered button is pressed, this method gets invoked
*/
public void actionPerformed(ActionEvent evt)
{

// First of all figure which button was just pressed
String arg = evt.getActionCommand();

if( arg.equals("Ok") )
{

RPGProc.setDocVars(procNameTextField.getText(), pgmrNameTextField.getText());
dispose();

} // end if(Ok button is pressed)
else if( arg.equals("Cancel") )
{

dispose();
} // end if(Cancel button is pressed)
else if( arg.equals("Clear") )
{

procNameTextField.setText("");
pgmrNameTextField.setText("");

} // end if(Help button is pressed)
} // end actionPerformed()

actionPerformed() is defined by the ActionListener
interface. It has to be implemented by any class
that implements this interface!
Usually used for processing button and menu events...

Figure which button
was pressed.

In the case of 'OK' button,
call into the RPGProc class
to set the DOCVARS.

'Clear' button was pressed -
clear up all entry fields.

On 'Cancel' just dispose( )
of the dialog...
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Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets

/* Read in the DOCVARs that are set by the Lpexlet */
'EXTRACT DOCVAR.PROCNAME INTO 'procName
'EXTRACT DOCVAR.PGMRNAME INTO 'pgmrName

/* Pad procName with blanks to make it 10 characters long */
do procLength = length(procName) to 9

procName = procName' '
end

/* The procName is 10 characters long including blanks */
'insert D* ----------------------------------------'
'insert D* Prototype for procedure: 'procName
'insert D* ----------------------------------------'
'insert D 'procName' PR'
'insert '
'insert P* ----------------------------------------'
'insert P* Procedure Name: 'procName
'insert P* Purpose: '
'insert P* Written by: 'pgmrName
'insert P* ----------------------------------------'
'insert P 'procName' B'
'insert D 'procName' PI'
'insert '
'insert C* Your calculation code goes here'
'insert '
'insert C RETURN'
'insert P 'procName' E'

'trigger fullparse'

Lpexlet has set the DOCVARs. That
is how we retrieve the values of the
Procedure and Programmer Name

We will re-use the template
generation code from the

already written REXX macro
RPGPROC.LX

(Just add Programmer's name)
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Editor Programming - LpexletsEditor Programming - LpexletsEditor Programming - LpexletsEditor Programming - Lpexlets

The Prompt

The generated template

Compare to the template generated
by the REXX macro.
We added the Programmer's Name

Copyright International Business Machines Corporation, 2002



Creating Smart GuidesCreating Smart GuidesCreating Smart GuidesCreating Smart Guides

The ultimate RPG procedure template
Lpexlet. It is written based on the
Java Smart Guide Framework that is
shipped with CODE/400.
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Creating Smart GuidesCreating Smart GuidesCreating Smart GuidesCreating Smart Guides

To get help for the CODE SmartGuide
Framework, select 'Java help' -> 'SmartGuid
framework' from the Help menu.
NOTE: The 'Java help' option is only availabl

when editing Java source.

The resulting template

Suggestion
To unpack SmartGuide Framework
examples, read 'LPEX Java readme'. It is
available from: 'Help' -> 'Java help'.Copyright International Business Machines Corporation, 2002



SummarySummarySummarySummary

IIIIBM's follow-on to SEU, PDM, RLU, SDABM's follow-on to SEU, PDM, RLU, SDABM's follow-on to SEU, PDM, RLU, SDABM's follow-on to SEU, PDM, RLU, SDA
New world, new servers, new tools!New world, new servers, new tools!New world, new servers, new tools!New world, new servers, new tools!

Much higher productivity
Much more fun programming again
Much easier to attract/retain talent
Much more flexibility

Working disconnected, at home, on the roadWorking disconnected, at home, on the roadWorking disconnected, at home, on the roadWorking disconnected, at home, on the road

Tailor extensively to suit your needs
Much easier transition to future

Today: host applications, new toolsToday: host applications, new toolsToday: host applications, new toolsToday: host applications, new tools
Tomorrow: Web applications!Tomorrow: Web applications!Tomorrow: Web applications!Tomorrow: Web applications!

RPG IV, ILE, GUI, VisualAge, Java, WebSphere. . .
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Additional InformationAdditional InformationAdditional InformationAdditional Information

homepagehomepagehomepagehomepage
www.ibm.com/software/ad/iseries

EducationEducationEducationEducation
S6186 CODE/400 for iSeries  --  Basic (2 days)
S6205 CODE/400 for iSeries  --  Advanced (1 
day)

S6286 iSeries Application Development using      
WDSc for iSeries  --  Basic (2 days)

NewsgroupNewsgroupNewsgroupNewsgroup
news://news.software.ibm.com/ibm.software.code400
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iSeries & WebSphere Resources & DeliverablesiSeries & WebSphere Resources & Deliverables
WebSphere Development Studio for iSeries
http://www-3.ibm.com/software/ad/wds400/

iSeries site
www.iseries.ibm.com/

iSeries WebSphere Application Server
http://www-1.ibm.com/servers/eserver/iseries/software/websphere/wsappserver/

PartnerWorld for Developers, iSeries & WebSphere
http://www.iseries.ibm.com/developer/websphere/

IBM eServer Solutions
http://www-1.ibm.com/servers/eserver/iseries/solutions/

iSeries e-business Solutions
http://www-1.ibm.com/servers/eserver/iseries/ebusiness/

iSeries B2B Solutions
http://www-1.ibm.com/servers/eserver/iseries/btob/

Connect for iSeries
http://www-1.ibm.com/servers/eserver/iseries/btob/connect/v11high.html

WebSphere Commerce Suite for iSeries
http://www-1.ibm.com/servers/eserver/iseries/ebusiness/wcs51.html

iSeries and e-commerce
http://www-1.ibm.com/servers/eserver/iseries/ebusiness/ecommerce.htm

iSeries HTTP Server
http://www-1.ibm.com/servers/eserver/iseries/software/http/index.html

iSeries and WebSphere References
http://www.as400.ibm.com/developer/java/solutions/jjem.html
http://www2.software.ibm.com/casestudies/swcsweb.nsf/platform

iSeries Solution Finder
http://www.iseries.ibm.com/btobpartner/

iSeries & Domino
http://www-1.ibm.com/servers/eserver/iseries/domino/

Dedicated Server for Domino
http://www-1.ibm.com/servers/eserver/iseries/domino/dsd.htm

Workload Estimator for iSeries, WAS, WCS & Domino, HTTP Server, Java, etc.
http://as400service.ibm.com/estimator/

iSeries Custom Technology Center
http://www-1.ibm.com/servers/eserver/iseries/service/ctc/

iSeries Technical Support
http://as400service.ibm.com/

iSeries Technical Studio
http://www.as400.ibm.com/tstudio/

1st Install for iSeries & WebSphere Application Server
http://www.iseries.ibm.com/developer/websphere/assistance.html

iSeries ToolsNet (Tools & Middleware)
http://www.iseries.ibm.com/developer/tools/

iSeries & Services Network
http://as400service.ibm.com/supporthome.nsf/document/19251245

iSeries e-business Handbook (SG24-5694-01)
http://www.redbooks.ibm.com/abstracts/sg245694.html

WebSphere Commerce Suite With Back-End Order Mgmt.
http://ibm.com/redbooks

iSeries Technology Center
http://www.iseries.ibm.com/service/itc/ebiz.htm

iSeries University
http://www-3.ibm.com/services/learning/community/as400/
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iSeries & WebSphere Resources & DeliverablesiSeries & WebSphere Resources & Deliverables
WebSphere Application Server Overview
http://www-4.ibm.com/software/webservers/appserv/

WebSphere Commerce Suite
www-4.ibm.com/software/webservers/commerce/

WebSphere Payment Manager
www-4.ibm.com/software/webservers/paymgr/

MQSeries
www.ibm.com/software/ts/mqseries

iSeries & WebSphere Documentation

Redbooks & Red Pieces Form Numbers/Web Sites
Building iSeries Applications for WebSphere Advanced Edition SG24-5691
Building Java Applications for the iSeries with VisualAge for Java SG24-6245
Integrating WCS with Domino Back-End Applications

· http://ibm.com/redbooks (search for REDP0141)

Java & WebSphere Performance on iSeries
· http://publib-b.boulder.ibm.com/Redbooks.nsf/RedpieceAbstracts/sg246256.html?Open

iSeries Application Development Directions white paper is now available
· http://www.iseries.ibm.com/developer/tools/documents/addir/index.html

Connect for iSeries with WebSphere Commerce Suite Red Paper
· http://www.redbooks.ibm.com/redpapers/pdfs/redp0127.pdf

Tools for Application Reface and Redesign
· http://www.as400.ibm.com/developer/comm/pidtechpapers.html?Tools

Introduction to Enterprise JavaBeans for AS/400 SG24-5192-00
Web enabling AS/400 Applications with WebSphere Studio SG24-5634-00
Building AS/400 Applications with WebSphere Standard Edition 2.0 SG24-5635-00
Building AS/400 C/S Apps with Java SG24-2152-02
Building AS/400 Internet-based applications with Java SG24-5337-00

IBM Redbooks
http://www.redbooks.ibm.com/

iSeries Nation
http://www-1.ibm.com/servers/eserver/iseries/announce/form.html
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