From a command prompt, and while logged in as the root user (or a user with system authority), execute the commands:
# lslpp -hac | grep -i java
{Sample output when Java 6 32-bit or Java 6 64-bit is installed}
..
/usr/lib/objrepos:Java6.sdk:6.0.0.471::COMMIT:COMPLETE:07/15/15:08;57;18
/usr/lib/objrepos:Java6_64.sdk:6.0.0.474::COMMIT:COMPLETE:07/15/15:09:06;27
..
If no output is returned after executing the above command, IBM Java for AIX is not installed as part of the base operating system, and there is no need to continue with these instructions.
If there output similar to the above is displayed, then proceed with the remainder of these instructions.
B. Confirm if dependent software for IBM Java for AIX is installed on the system
From a command prompt, and while logged in as the root user (or a user with system authority), execute the command:
# lslpp -d "Java6_64.sdk"
{Sample output when there is Java6_64.sdk installed and it has dependent software}
Fileset Dependents
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
Java6_64.sdk 6.0.0.471
csm.gui.dcem 1.7.1.0
lwi.runtime 5.3.10.0
{Sample output when there is Java6_64.sdk installed and it has no dependent software}
Fileset Dependents
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
Java6.sdk 6.0.0.471 NONE
Java6_64.sdk 6.0.0.474 NONE
C. When in doubt, open an IBM support call to validate if and how to remove IBM Java for AIX for dependent software
Feature/Product Name | Matching Fileset Name | IBM Supprt Team |
WebSM pconsole (IBM System Director Console) |
pconsole: lwi.runtime WebSM: sysmgt.sguide.rte sysmgt.websm.framework sysmgtlib.framework.core |
AIX Install |
Cluster Systems Management (CSM) | csm.* cas.* |
Cluster Mgmt (ref: ZAIX,13A) |
Pegasus CIM Server and Provides | sysmgt.cim.* | Pegasus (ref: PEGCIM,163) |
System Management Services Library | sysmgtlib.framework.core | AIX Install |
AIXPert websm component | bos.aixpert.websm.* | AIX Commands and Libraries |
IPSEC websm component | bos.net.ipsec.websm | AIX Network Application |
Service Agent | bos.esagent | Service Agent (ref: ESER6,163) |
License Use Management | lum.base.gui ifor_ls.java.gui |
AIX Install |
General AIX uninstall Issues | Issues with uninstalling the Java5 filesets | AIX Install |
Solution Install | bos.installers.si | AIX Install |
Distributed Systems Management | dsm.core | AIX Install |
Eclipse Integrated Tool Platform (References not expected) |
eclipse2.rte | Not Available |
Lpar Deployment Wizard (HMC) | ios.ldw.* | AIX VIrtualization |
PowerVM / VIOS | No known fileset dependencies | AIX Virtualization |
Java 5 specific issues (unrelated to above components |
Java5* | AIX Java |
A. To begin the uninstall of IBM Java for AIX, from a command prompt, and while logged in as the root user, execute the command:
# smitty remove
{Follow these instructions to complete the uninstall using the SMIT utility}
1. On the panel "Remove Installed Software", scroll to the "SOFTWARE name" field, then press the F4 key (or ESC+4 keys) to view the list of installed software
2. Scroll down and select "JavaX.sdk" and/or "JavaX_64.sdk" filesets by pressing the F7 key (or ESC+7 keys). Once all Java5 filesets have been selected, press the ENTER key to return the previous panel
3. Scroll to the "PREVIEW only" field , then press the TAB key to change the value to "no"
4. Scroll to the "REMOVE dependent software?" field, then press the TAB key to change the vlaue to "yes" or "no" depending on whether or not the dependent software should be removed
5. In most cases, using the default values for the remainder of the items is adequate. However, do change the values that are appropriate for the situation.
6. Press the ENTER key twice to proceed with the uninstall of IBM Java for AIX
7. Once the uninstall process begins, monitor the "COMMAND STATUS" section (upper left corner of screen) for the progress of the uninstall
{Sample output for different stages of the uninstall process}
{While the process is running}
COMMAND STATUS
Command: Running stdout: yes stderr: no
.......
{Return message for a successful uninstall}
COMMAND STATUS
Command: OK stdout: yes stderr: no
.......
{Return message for an unsuccessful uninstall}
COMMAND STATUS
Command: Failed stdout: yes stderr: no
.......
8. Exit the smitty utility once the process has completed by pressing the F10 key (or ESC+0 keys)
9. Repeat Step 2.A.1 to Step 2.A.8 for other systems that have IBM Java for AIX installed.
Confirm the IBM Java for AIX has been successfully uninstalled
From a command prompt, and while logged in as the root user, execute the commands:
# lslpp -hac | grep -i javaX
No output should be displayed.
If the uninstall of IBM Java for AIX failed and the issue could not be resolved, it is recommended that the following data be collected and uploaded to a new IBM support call which has been routed to the "AIX Install" team or "AIX Java" team.
1. Collect and package the SMIT log files by executing the following commands from a command prompt using the user id used to run the SMIT in Step 2.A:
# mkdir -p /TMP_PATH/MM-DD/javaX_uninstall/data
# cd /TMP_PATH/MM-DD/javaX_uninstall/data
# cp ${HOME}/smit.* ./
# cd /TMP_PATH/MM-DD/javaX_uninstall
# tar -cf - data | gzip -c > PMR.MM-DD.tgz
2. Upload the packaged data using one of the IBM secure upload methods listed on the "IBM Java for AIX MustGather: How to upload diagnostic data and testcases to IBM" web page:
http://www-01.ibm.com/support/docview.wss?uid=isg3T1022619
A. Download the desired JRE and/or SDK filesets for the specific Service Release or Fix Pack release for the desired version(s) from the "IBM Java for AIX Reference: Service Information and Download Guide" web page:
http://www-01.ibm.com/support/docview.wss?uid=isg3T1022644
B. Create a temporary directory, then save a copy of the downloaded files into that directory:
# mkdir -p /TMP_PATH/java_install
{Save a copy of the downloaded files to /TMP_PATH/java_install directory}
C. Extract the contents of the download files in the temporary directory. In a command prompt, execute the commands:
# cd /TMP_PATH/java_install
# ls Java*.tar.gz
{For each file listed from the last command, execute the commands}
# gunzip -c < TAR_GZ_FILE | tar -xvf -
{Confirm the *.jre and/or *.sdk files have been extracted}
# ls Java*.sdk Java*.jre
A. Command line installation
1. From a command prompt, and while logged in as the root user, execute the commands:
# cd /TMP_PATH/java_install
# installp -agXYd . JavaX.jre JavaX.sdk 2>&1 | tee installp.log
or
# installp -agXYd . JavaX_64.jre JavaX_64.sdk 2>&1 | tee installp.log
B. SMIT (or smitty) installation
1. From a command prompt, and while logged in as the root user, execute the commands:
# cd /TMP_PATH/java_install
# smittty install_all
2. Follow these instructions while using the SMIT utility
a. Menu #1 (Install and Update from ALL Available Software)
Option::* INPUT device / directory for software
Input: Type "./" in the field
{Press the ENTER key to proceed to next menu}
b. Menu #2 (Install and Update from ALL Available Software)
Option: * SOFTWARE to install
Input: Press the F4 key (or ESC+4 keys) to view the list of installed software. Then scroll to the desired filesets and select the filesets by pressing the the F7 key (or ESC+7 keys) for each filesets. Press the ENTER key once all of the filesets have been selected.
Option: ACCEPT new license agreements?
Input: Press the TAB key to change the value from "no" to "yes"
{Press the ENTER twice to begin the installation}
{Press the F10 key (or ESC+0 keys) to exit the SMIT utility}
Confirm that IBM Java for AIX has been installed using the following methods.
A. From a command prompt, execute the command:
# lslpp -l "Java*"
In the output listed, the JavaX and/or JavaX_64 versions selected during the installation should be listed as COMMITTED.
B. From a command prompt, execute the command:
# /usr/javaX/jre/bin/java -version
and/or
# /usr/javaX_64/jre/bin/java -version
A. If the install of IBM Java for AIX failed and the issue could not be resolved, it is recommended that the following data be collected and uploaded to a new IBM support call which has been routed to the "AIX Install" team or "AIX Java" team.
1. Collect and package the SMIT log files or installp log file by executing the following commands from a command prompt using the user id used in Step 6.
Install:
# mkdir -p /TMP_PATH/MM-DD/java_install/data
# cd /TMP_PATH/MM-DD/java_install/data
# cp ${HOME}/smit.* /TMP_PATH/java_install/installp.log ./
# cd /TMP_PATH/MM-DD/java_uninstall
# tar -cf - data | gzip -c > PMR.MM-DD.tgz
2. Upload the packaged data using one of the IBM secure upload methods listed on the "IBM Java for AIX MustGather: How to upload diagnostic data and testcases to IBM" web page:
http://www-01.ibm.com/support/docview.wss?uid=isg3T1022619
Additional references are available to assist with the installation and/or uninstallation of IBM Java for AIX:
IBM Java for AIX HowTo: Install the FIRST or LATEST Release of an IBM Java
IBM Java for AIX HowTo: Install or upgrade IBM Java to a specific release (e.g., Service Refresh or Fix Pack)
IBM Java for AIX HowTo: Uninstall IBM Java