A. Download the desired JRE and/or SDK filesets for the specific Service Release or Fix Pack release for the desired version(s) from the "IBM Java for AIX Service Information and Download Guide" web page:
http://www-01.ibm.com/support/docview.wss?uid=isg3T1022644
B. Create a temporary directory, then save a copy of the downloaded files into that directory:
# mkdir -p /TMP_PATH/java_install
{Save a copy of the downloaded files to /TMP_PATH/java_install directory}
C. Extract the contents of the download files in the temporary directory. In a command prompt, execute the commands:
# cd /TMP_PATH/java_install
# ls Java*.tar.gz
{For each file listed from the last command, execute the commands}
# gunzip -c < TAR_GZ_FILE | tar -xvf -
{Confirm the *.jre and/or *.sdk files have been extracted}
# ls Java*.sdk Java*.jre
B. Examples of commands to be executed:
# mkdir -p /tmp/java_install
# ls *.tar.gz
Java7.jre.tar.gz
Java7.sdk.tar.gz
C. Examples of commands to be executed:
# cd /tmp/java_install
# ls Java*.tar.gz
Java7.jre.tar.gz
Java7.sdk.tar.gz
# gunzip -c < Java7.jre.tar.gz | tar -xvf -
# gunzip -c < Java7.sdk.tar.gz | tar -xvf -
# ls Java*.sdk Java*.jre
Java7.sdk
Java7.jre
A. Command line installation
1. From a command prompt, and while logged in as the root user, execute the commands:
#cd /TMP_PATH/java_install
# installp -agXYd . JavaX.jre JavaX.sdk 2>&1 | tee installp.log
or
# installp -agXYd . JavaX_64.jre JavaX_64.sdk 2>&1 | tee installp.log
B. SMIT (or smitty) installation
1. From a command prompt, and while logged in as the root user, execute the commands:
# cd /TMP_PATH/java_install
# smittty install_all
2. Follow these instructions while using the SMIT utility
a. Menu #1 (Install and Update from ALL Available Software)
Option::* INPUT device / directory for software
Input: Type "./" in the field
{Press the ENTER key to proceed to next menu}
b. Menu #2 (Install and Update from ALL Available Software)
Option: * SOFTWARE to install
Input: Press the F4 key (or ESC+4 keys) to view the list of installed software. Then scroll to the desired filesets and select the filesets by pressing the the F7 key (or ESC+7 keys) for each filesets. Press the ENTER key once all of the filesets have been selected.
Option: ACCEPT new license agreements?
Input: Press the TAB key to change the value from "no" to "yes"
{Press the ENTER twice to begin the installation}
{Press the F10 key (or ESC+0 keys) to exit the SMIT utility}
A. Examples of commands to be executed:
# cd /tmp/java_install
# installp -agXYD . Java7.jre Java7.sdk 2>&1 | tee installp.log
B. Examples of commands to be executed:
# cd /tmp/java_install
# smitty install_all
Confirm that IBM Java for AIX has been installed using the following methods.
A. From a command prompt, execute the command:
# lslpp -l "Java*"
In the output listed, the JavaX and/or JavaX_64 versions selected during the installation should be listed as COMMITTED.
B. From a command prompt, execute the command:
# /usr/javaX/jre/bin/java -version
and/or
# /usr/javaX_64/jre/bin/java -version
B. Examples of commands to execute:
# /usr/java7/jre/bin/java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build pap3270sr9fp1-20150602_01(SR9 FP1))
IBM J9 VM (build 2.6, JRE 1.7.0 AIX ppc32-64 Compressed References 20150406_242981 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR9_20150406_1443_B242981
JIT - tr.r11_20150401_88894
GC - R26_Java726_SR9_20150406_1443_B242981_CMPRSS
J9CL - 20150406_242981)
JCL - 20150601_01 based on Oracle 7u79-b14