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Overview
Welcome to the Safety Designer User's Guide.

This guide is intended for users who need to become quickly familiar with the Safety Designer product.

Safety Designer in a Nutshell

Safety Designer offers the following main features:

• Describing the behavior of systems, under nominal condition as well as under failure conditions thanks to the
AltaRica language.

• Organizing models in libraries for reuse.
• Simulating models using the integrated AltaRica simulator.
• Generating fault trees by selecting an unexpected event from the model.
• Generating failure scenarios leading to a selected unexpected event.

Getting the Most Out of this Guide

To get the most out of this guide, we suggest that you start reading and performing the step-by-step user tasks,
which cover all product functionality.

The Interface Description section describes the commands that are specific to Safety Designer. This will certainly
prove useful.
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Entering Safety Designer
There are two ways to enter the Safety Designer workbench.

To enter the Safety Designer workbench either:

• Double-click the shortcut added on the desktop, or
• Double-click the shortcut in the Start menu.

The Splash screen appears.

Figure 1: Splash screen

By default, Safety Designer starts the most recently used workspace.

At the very first start, no workspace is known. The Select a Workspace dialog box appears. For more
information, see Opening a Workspace on page 9.
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Using Workspaces
Safety Designer allows you to work with several workspaces and to switch easily between them. Workspaces are stored
in MS Access© or Oracle© 9 databases.

Creating a new Workspace on page 8

Opening a Workspace on page 9

Switching to another Workspace on page 12

Creating a new Workspace
You can create a new workspace based on MS Access database.

1. In the Select a Workspace dialog box, select Access in the list of database type.

2. Click the Create new database  button.

3. Set the destination directory and a file name to be used for the new MS Access database.

Figure 2: Creation of a new Access database

4. Click Save to validate the creation of the new database.

5. Click Validate.
The new workspace appears.
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Figure 3: Validating creation of a new workspace

To complete the workspace switch, the Connect to Workspace dialog box, asking for the appropriated login
and password.

Opening a Workspace
A workspace is a place where models are stored and versioned. The Workspace selection dialog box allows you to
specify which workspace to open and to create a new one.
A workspace can be based on:

• A MS Access database
• An Oracle database
• An ODBC data source.

Select a workspace based on a MS Access database
You can select a workspace from MS Access database.

1. In the Select a type of database list, select Access.
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Figure 4: Select a Workspace dialog box

2.

In the Access database (file*.mdb) box, type the path of the file or click the  button to search it from
an explorer.

Note: The file extension of MS Access database is .mdb.

3. Click Validate.
The Connect to Workspace dialog box appears.

Figure 5: Connect to Workspace dialog box

4. Set the login and password.

5. Click OK.
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Select a workspace based on an Oracle database
You can select a workspace on the basis of Oracle database.

Note: The setup of an Oracle database is not explained in this manual.

1. In the Select a type of database list, select Oracle.

Figure 6: Oracle database connection parameters

2. In the Connection parameters area, fill in the connection parameters to the Oracle database appropriately.

You can ask your Oracle database administrator for them.

3. Click Validate.
The Connect to Workspace dialog box appears.

4. Set the login and password.

5. Click OK.

Select a workspace stored in an ODBC data source
You can a workspace stored in an ODBC data source.

Note: The creation of an ODBC data source is not explained in this manual.

1. In the Select a type of database list, select ODBC.
The connection parameters of ODBC data source appears in the dialog box.
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2. In the Datasource box, type the name of the data source.

Figure 7: ODBC data source connection parameters

3. Click Validate.
The Connect to Workspace dialog box appears.

4. Set the login and password.

5. Click OK.

Switching to another Workspace
You can switch from one workspace to another.

1. Select File > Switch Workspace.
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Figure 8: File > Switch Workspace menu

2. Click Continue in the Switch Workspace dialog box.

Figure 9: Switch Workspace dialog box

The Select a Workspace dialog box appears. For more informaton, see Opening a Workspace on page 9.
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Working with Packages
This section describes how to work with packages and sub-packages.

Creating Packages on page 14

Removing a Package on page 18

Creating Packages
You can create packages. You can organize the models in hierarchies of packages.

The figure presents an example of packages and sub packages of model classes.

Figure 10: Example of component organization

Create a New Root Package
You can create a new root package of model classes, equipments or components, operators or types in the current
workspace.

1. Select corresponding tab in the model tree.

2. Right-click in an empty area (no existing package must be selected).
The Model edition and organization contextual menu appears.
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Figure 11: Model edition and organization contextual menu
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3. Select New > Package.
The Create classes package dialog box appears.

Figure 12: Create classes package dialog box

4. In the Package name box, type the name of the new package to be created.

If the owner belongs to several workgroups, he has to specify the owning group of the package.

5. Click Dependencies to select the group. Click Close to validate.
The Dependencies dialog box appears.

Figure 13: Dependencies dialog box

6. Click Close to validate.

7. Click OK to accept the creation of the new package.
A new root package is created in the workspace.
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Figure 14: A new root package

Create a New Sub-Package
You can create a new sub-package of model classes, equipments or components, operators or types in the current
workspace.

1. Select corresponding tab in the model tree.

2. Select the existing package in which a new sub-package to be created.

3. Right-click the existing package.
The Model edition and organization contextual menu appears.

4. Proceed as described in creating a new root.
A new sub-package is created under the selected existing package.
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Figure 15: A new sub-package

Removing a Package
You can remove a package.

Important:  It is not possible to remove a package that is not empty. You have to first move or remove any
contained sub-packages and models and then remove a package.

1. Right-click the package to be removed and select Remove package.

A message dialog box appears.
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Figure 16: Package removal confirmation dialog box

2. Click Continue to confirm the removal of the package.
The package is removed from the workspace.

Note: When attempting to remove a non-empty package, an error message is displayed.

Figure 17: Error when attempting to remove a non-empty package
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Working with Model Classes
This section describes how to create and modify the model classes.

About Model Class on page 20

Creating a New Model Class on page 20

Accessing an Existing Model Class on page 21

Duplicating a Model Class on page 22

Creating a New Version of a Model Class on page 24

Renaming a Model Class on page 27

Removing a Model Class Version on page 28

Freezing a Model Class on page 30

About Model Class
Before you begin with model class, you should be familiar with the concepts described in this section.

A model class corresponds to an AltaRica node. An AltaRica node is made of several clauses, which can be
grouped as follow:

• A declarative part (flow, state, event, sub, init and extern clauses);
• A behavioral part (trans and assert clauses)

Creating a New Model Class
You can create a new model class.

1. Click the Class tab of the model browser.

2. Right-click the package where to add a new model class and Create model.
The Create class dialog box appears.

Figure 18: Create class dialog box
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3. In the Model name box, type the name of a new model, and press Enter.

Important: The name of a model class must respect the constraints on identifiers described in the Appendix:
AltaRica Language Specification.

Accessing an Existing Model Class
You can access an existing model class.

Open an Existing Model Class
You can open an existing model class.

1. Access the Model class tab.

2. Select a model class in the package tree.

Here we selected BackupCoolingSystem/BackupCoolingSystem.

3. Double-click a version.

Here we clicked Version 1.

The Model Class Editor appears.

Figure 19: Model Class Editor
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Important:

• When a model is opened for edition, it is automatically locked so that several users cannot edit the
same model at the same time.

• A model class can remain locked after a system crash; access its properties to remove the lock manually.

Check a Model Class for Consistency
You can check a model class for consistency.

Click the Syntax and Consistency buttons at the bottom of the Model Class Editor.

Important: To save the changes made in the existing model class, click the Save button at the bottom of
the Model Class Editor.

Close an Existing Model Class
You can close an existing model class.

Click the Close button at the bottom of the Model Class Editor or the  icon on its top right corner.
If the model class has been modified, a confirmation dialog box appears.

Duplicating a Model Class
You can duplicate a model class.

1. Click the Class tab of the model browser.

2. Right-click the model class and select Model... > Duplicate.
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Figure 20: Model... > Duplicate

If the model has several versions, the last version is duplicated. To duplicate another version of the component,
select the version in the model tree structure and proceed as described

Creating a New Version of a Model Class
You can create a new version of a model class.

1. Click the Class tab of the model browser.

2. Select a model class.

3. Right-click a model class and select Model... > New version.

Safety Designer User Guide24



25



Figure 21: Model... > New version

The Create new version dialog box appears.

Figure 22: Create new version dialog box

4. In the Reference version list, select the version to derive.

The new version can be seen in the model structure.
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Figure 23: A new version

Renaming a Model Class
You can rename a model class.

:  Use this function with extreme care, as it can break the models using the model class.

1. Click the Class tab of the model browser.

2. Select a model class.

3. Right-click a model class and select Model... > Rename.
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Figure 24: Model... > Rename

4. Type a new name and press Enter.
If the name already exists, an error message is displayed. Click OK and enter another name.

Removing a Model Class Version
You can remove a model class version.

:  Use this function with extreme care, as it cannot be undone. The class and its instances are deleted, as well as the
links pointing at them.

Safety Designer User Guide28



1. Click the Class tab of the model browser.

2. In an appropriate model class, select a version.

3. Right-click a version and select Model... > Remove.

Figure 25: Model > Remove

A message dialog box appears to confirm the delition.

4. Click Continue to remove the model class.
Remove all the versions of a model class to remove it entirely.
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Freezing a Model Class
You can freeze a model class.

:  Use this function with extreme care, as it cannot be undone. A frozen model cannot be modified or duplicated.

1. Click the Class tab of the model browser.

2. In an appropriate model class, select a version.

3. Right-click the version and select Model... > Freeze.
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Managing Variables
This section describes how to create a new variable and edit the existing variables.

Working with Flow Variables on page 31

Working with State Variables on page 33

Working with Flow Variables
You can create a new flow variable for a model class. You can edit and delete an existing flow variable using the Flow
variables edition tab.

Refer to AltaRica Language Specification on page 149 for more information about the semantics of flow variables.

Create a New Flow Variable
You can create a new flow variable.

1. Click the Name column of the last blank line of the flow table.

Figure 26: Flow variables edition tab

2. Edit the name of the flow variable to be created .

Entering a valid name immediately creates a new flow variable with a type defaulting to bool and a direction
defaulting to in. For more information, refer to Modify the name of an Existing Flow Variable on page 32.

3. In the Type column, set the type of the flow variable.
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For more information, refer to Modify the type of an Existing Flow Variable on page 32.

4. In the Type column, select the direction of the flow.

For more information, refer to Modify the direction of an Existing Flow Variable on page 33.

Once a flow variable is created, an associated port is displayed on the graphic dialog box.

Important:

• An input flow variable is identified by a white rectangle; an output variable is identified by a black rectangle.
• By definition, internal variables are private and cannot be linked to variables of other elements; hence no

port is created for them.

Modify the position of a port
You can modify the position of a port.

1. Select the port to be moved:

• Select the associated flow variable in the flow table, or
• Click the shape of the port.

2. Move the port:

• Use the mouse to drag the shape of the port, or
• Click the top center button, or
• Click the bottom center button, or
• Click the left middle button, or
• Click the right middle button.

Edit an Existing Flow Variable
You can edit the name, type and direction of an existing flow variable.

Modify the name of an Existing Flow Variable
You can modify the name of an existing flow variable.

1. Click the Name column of the row describing the flow variable to be edited.

2. Enter a new name.

3. Press Enter.

Important: The name of a flow variable must respect the constraints on variable identifiers described in
the AltaRica Language Specification on page 149.

Modify the type of an Existing Flow Variable
You can modify the type of an existing flow variable.

1. Click the Type column of the row describing the flow variable to be edited.

2. Set the new type, either by writing it directly or by selecting it among the proposed ones:

• bool for the Boolean type (possible values are true and false).

• int for the integer type.
• float for the real type.
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• Range... for opening a wizard to write an integer range type.
• Predefined... for selecting a predefined type.

Important:  Enumerated types can only be written manually, by listing the possible values separated by
commas (whitespaces are forbidden), e.g.: null,low,high.

Modify the direction of an Existing Flow Variable
You can modify the direction of an existing flow variable.

1. Click the Direction column of the row describing the flow variable to be edited.

2. Select the direction of the flow (see Modifying the direction of an existing flow variable):

• in for input flows.
• out for output flows.
• local for internal flows.

Important:  Internal flow variables are typically used to store intermediate results in complex assertions.

Delete an Existing Flow Variable
You can delete an existing flow variable.

1. Select the flow variable to be deleted:

• Select the row describing it in the flow table, or
• Click the shape of its associated port if any.

2. Press Delete.

Working with State Variables
You can create a new state variable of a model class. You can edit and delete an existing state variable using the State
variables edition tab.

Refer to AltaRica Language Specification on page 149 for more information about the semantics of state variables.

Create a New State Variable
You can creating a new state variable.

1. Click the Name column of the last blank line of the state table.
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Figure 27: State variables edition tab

2. In the Name column, edit the name of the state variable to be created.

Entering a valid name immediately creates a new state variable with a type defaulting to bool and a default
value defaulting to false. For more information, refer to Modify the name of an Existing State Variable on
page 34.

3. In the Type column, set the type of the state variable.

For more information, refer to Modify the type of an Existing State Variable on page 35.

4. In the Default Value column, set the default value of the state variable.

For more information, refer to Modify the default value of an Existing State Variable on page 35.

Edit an Existing State Variable
You can edit the name, type and default value of an existing state variable.

Modify the name of an Existing State Variable
You can modify the name of an existing state variable.

1. Click the Name column of the row describing the state variable to be edited.

2. Enter a new name.

3. Press Enter.

Important: The name of a state variable must respect the constraints on variable identifiers described in
the AltaRica Language Specification on page 149.
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Modify the type of an Existing State Variable
You can modify the type of an existing state variable.

1. Click the Type column of the row describing the state variable to be edited.

2. Set the new type, either by writing it directly or by selecting it among the proposed ones:

• bool for the Boolean type (possible values are true and false).
• int for the integer type.
• float for the real type.
• Range... for opening a wizard to write an integer range type.
• Predefined... for selecting a predefined type.

Important:  Enumerated types can only be written manually, by listing the possible values separated by
commas (whitespaces are forbidden), e.g.: null,low,high.

Modify the default value of an Existing State Variable
You can modify the default value of an existing state variable.

1. Click the Default value column of the row describing the state variable to be edited.

2. Set the default value, either by writing it directly or by selecting it among the suggested ones.

Important:

• The suggestion panel only appears for variables with finite domains (Boolean, enumerations, integer
ranges, and possibly predefined types).

• Default values are used at the beginning of a simulation (in the general sense of the term, i.e. including
fault tree generation, event sequence generation, etc.) to initiate state variables when no initial configuration
has been specified.

Delete an Existing State Variable
You can delete an existing state variable.

1. Select the row describing the state variable to be removed in the state table.

2. Press the Delete key.
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Working with Events
You can create, remove and edit events of a model with the Event edition tab.

Create a New Event
You can create a new event.

1. Click the Name column of the last blank line of the event table.

Figure 28: Event edition tab

2. Edit the name of the event to be created.

Entering a valid name immediately creates a new event with no probability distribution, no comment and no
attributes. For more information, refer to Modify the name of an existing event on page 37.

3. In the Law column, set the probability distribution of the event.

4. In the Comment column, fill a comment.

5. In the Attributes column, add attributes.

Edit an Existing Event
You can edit an existing event.
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Modify the name of an existing event
You can modify the name of an existing event.

1. Click the Name column of the row describing the event to be edited.

2. Enter a new name.

3. Press Enter.

Important: The name of an event must respect the constraints on variable identifiers described in the
AltaRica Language Specification on page 149.

Modify the probability distribution of an existing event
You can modify the probability distribution of an existing event.

1. Click the Law column of the row describing the event to be edited.
The Event properties dialog box appears.

Figure 29: Event properties dialog box
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2. Set the probability distribution of the event:

• Type the probability distribution, or
• Browse to open the Probability distribution wizard.

The following probability distributions are supported:

ExampleSyntax and ParametersProbability Distribution

Constant (0.5)Constant (time)Constant

Exponential

GLM (0.5, 1e-6, 1e-3)GLM (gamma, lambda, mu)Gamma (exponential)

GLM_asymptotic (1e-6, 1e-3)GLM_asymptotic (lambda, mu)Gamma (asymptotic)

Weibull (0.5, 1.5)Weibull (alpha, beta)Weibull

Periodic_test (1e-3, 10, 0)Periodic_test (lambda, period, t0)Periodic test

CMT (1e-3, 72, 0)CMT (lambda, duration, probability)Constant Mission Time

Dirac (0.0)Dirac (time)Dirac

Note:  Failure Rate Banks, Inspection periodicity and Exposure time are not described in this manual.

Figure 30: Probability distribution wizard

The Probability distribution wizard is split into two parts; the first part let the user select a probability
distribution among the supported ones, the second part contains boxes to fill in the parameters on the selected
distribution.

Modify the comment of an existing event

1. Click the Comment column of the row describing the event to be edited.
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2. Type the comment.

3. Press Enter.

Important: The comments on events are included in the fault trees generated by Safety Designer when
selecting the Aralia file format; they can be seen in fault tree editors supporting the Aralia file format.

Delete an Existing Event
You can delete an existing event.

1. Select the row describing the state variable to be removed in the state table.

2. Press Delete.
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Working with Content
This section describes how to work with the Content edition tab.

About Editing Content on page 40

Inserting a New Model Class Instance on page 41

Modifying an Existing Instance on page 46

Creating a New Link on page 49

Editing Link Route on page 50

About Automatic Connections on page 51

Using Layers on page 55

About Editing Content
The topic provides information about the Content Edition tab.

A model class can compose – instantiate – other model classes. Such constituents can be added, removed and
linked with the Content Edition tab.

Figure 31: Content edition tab

The Content Edition tab consists of:

• A main central frame where the content edition takes place.
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• A layer manager.
• A filter on elements to display.

Filter the Labels to be displayed

In the Content Edition tab, you can use Display filter to select the labels to be displayed.

Figure 32: Display filter

In the Display list, select:

• All labels to display instances names and links names.
• Node label to display instances names only.
• Link labels to display links names only.
• None to hide all labels.

Align the Elements

You can align the elements. Right-click the group of components to be aligned and select:

•
 to align elements on their left.

•
 to align elements on their right.

•
 to align elements on their top.

•
 to align elements on their bottom.

•
 to align elements on their horizontal middle.

•
 to align elements on their vertical middle.

•
 to align elements on their center.

Inserting a New Model Class Instance
You can instantiate a new model class instance.

1. In the Model class tree, select the model class and version to instantiate.
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Figure 33: Selecting a model class

2. To instantiate it:

• drag the selected element and drop it into the main frame.
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Figure 34: Dragging a model class for instantiation

Important: A forbid sign is displayed when trying to drop a model class that cannot be instantiated
in the current one (this is relevant when using the system/equipment/component paradigm, as in
below image.
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Figure 35: Cannot drop for instantiation

• right-click the selected element and select Add.
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Figure 36: Instantiating through the Add menu item

The specified model class is instantiated with a default name.
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Figure 37: Instantiated model class

Modifying an Existing Instance
You can modify an existing instance.

Rename an Existing Instance
You can rename an existing instance.

To rename an existing instance, either:

• Double-click the model instance to rename and type the new name and press Enter or,
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Figure 38: Renaming an instance in content frame

• Right-click the model instance to rename and select Rename. Then type the new name and press Enter.

47



Figure 39: Content contextual menu

Replace a Model Instance by Another
You can replace a model instance with other existing model instance.

Right-click the model and select Replace.

If the new model class has the same interface as the previous one (same input and output flow variables, i.e.
with same names and types), the links present will be conserved, otherwise they are deleted.

More about Modifying an Existing Instance
The graphical representation of an existing model instance can be rotated, moved and accessed.
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Rotate the Graphical Representation of a Model Instance

You can use the following commands the corresponding icons of the Design toolbar to rotate the graphical
representation of a model instance:

•
Vertical mirror

•
Horizontal mirror

•
Rotate 90°

Move the Graphical Representation of a Model Instance

You can move the graphical representation of a model instance by selecting it and graging it around. You can
also use the arrow keys to move the graphical representation of a model instance.

Access the Model Class from an Instance

You can double-click the graphical representation of a model instance to open its class. You can also access the
model class, by right-clicking the graphical representation of a model and selecting Down.

Creating a New Link
Links can be drawn between two flow ports, to represent the fact that one end will emit a flow into the other end. You
can create a link between two flow ports.

Figure 40:The output of the tank is linked to the input of the manual valve

Create a New Link between Two Flow Ports
You can create a link between two flow ports.

1. Click the first flow port to connect.

2. Maintain the click and drag a link to the second flow port.

3. Release mouse button.
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Important: Two flow ports can be connected only if they have the same type and if their directions are
opposite.

Create links using Predefined Link Routes
You can create a new link using the predefined link routes.

1. Double-click the link route that must be modified.

2. Right-click the selected link route.

3. Select Link > Route, then click one of the following items:

•
 to make a straight line between the two ports.

•
 to make a two corners route between two ports.

•
 to make a two corners route between two ports.

•
 to make a route from a port on a right edge to another port on a bottom edge.

•
 to make a route from a port on a bottom edge to another port on a left edge.

•
 to make a route from a port on a right edge to another port on a top edge.

•
 to make a route from a port on a top edge to another port on a left edge.

Editing Link Route
You can edit the existing link route by inserting breakpoints and moving the breakpoints. You can also display the
arrows along a link route.

Insert a Breakpoint in a Link Route
You can insert a breakpoint in a link route.

1. Click the link route, where a breakpoint is to be inserted.

2. Drag the breakpoint as required.

Move a Breakpoint of a Link Route
You can move a breakpoint in a link route.

1. Double-click the link route is to be modified.
The route is displayed in blue and the breakpoints are shown.

2. Click the breakpoint to move and drag it to the desired location.

Display Arrows along a Link Route
You can display arrows along a link route.

1. Double-click the link route that is to modified.
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2.
Right-click the selected link route and select Links > Arrows .

Important:

•
To remove the arrows, proceed as described above but click the  instead.

The status line located at the bottom of the screen displays the synthesis_3.e_anna (bool)
information which gives the following indication:

• Equipment name: synthesys_3,
• Port: e_anna,
• Type: bool.

Important:  Note that when the mouse cursor is on a link, the display area located at the left lower part of
the architecture view indicates the link description: e.g. a.b <->c.d.

• The architecture view displays in the bottom left window some information about models when moving
the mouse cursor on them: the generic name in the library in brackets, and the instance name.

• When an existing architecture is opened or if modifications are carried out in the library and these
modifications concern an opened architecture, the tool executes a consistency control on all links in the
system. If a consistency error is detected (consistency between the architecture and the library: model,
type used in architecture), the link is deleted.

• When a link is deleted in architecture, a message indicates its deletion. Click the OK button.

Consult the system Information window.

Click with the mouse right button on the button corresponding to an opened architecture at the bottom of
the work area.

About Automatic Connections
You can automatically connect communication ports of components or equipments based on the name of the port. This
functionality is available by right-clicking the work area with no-object selected:

This functionality asks first for the kind of link to use, then reports the non-ambiguous connections and after the
validation from the user, do the non ambiguous connections. It reports also the following lists (with the possibility
to locate the communication port involved):

• List of connections with problem about type.
• List of outputs connected to the same input (fan-in problem).
• Inputs not connected without any related output found.
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• List of non-connected outputs which can connect to input already connected.

To end, you can interactively resolve non-connected inputs for the three first items listed above (we list outputs
with the same port name for the second item and outputs with the same port type for the third item).

Thus, the functionality Automatic connections processes in four steps:

The first dialog box describes the main rules about the port connections. You can also select the link type
which will be used for automatic connections:

Figure 41: Automatic connections: step 1 of 4

Step
1
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The second dialog box displays the list of non-ambiguous links (same name and same type):

Figure 42: Automatic connections: step 2 of 4

Step
2

The third dialog box displays a report about potential problems on automatic connections:Step
3 • List of connections having a same port name, but a different type.

• Multiple outputs which can be connected (same name) to a same non-connected input.
• List of Non-connected inputs because no output was found with a same port name.
• List of Non-connected outputs which can connect to an input already connected.

53



Figure 43: Automatic connections: step 3 of 4

You can select a port name in a list and click Locate to identify graphically the model in the current view.
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The last step consists in proposing you to connect interactively the remaining ports identified in step 3.

Figure 44: Automatic connections: step 4 of 4

Step
4

You can create the link by select ports to connect, and clicking Connect.

Using Layers
The graphical elements (model instances and links as well as pure graphical elements) can be dispatched onto
5 different layers. The Layer manager can then be used to set the visibility and the depth of these layers.

Send Graphical Elements to a Specific Layer
You can send the graphical elements to a specific layer.

1. Right-click a graphical element and select Layer.
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Figure 45: Layer/Layer number menu

2. Select any one of the 5 layers to send the element to it.

Figure 46:

Select the Active Layer
When dropped, the graphical elements are added to the current active layer. You can select the desired active layer.

1. In the Content edition tab, click the Layers button.

The Layer  dialog box appears. The active layer has a  next to it.
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Figure 47: Layer dialog box

2.
Click  next to a layer to make it the active one.

Hide and Show Layers
You can hide or show the layers.

1. In the Content edition tab, click the Layers button.
The Layer dialog box appears.

2.
Click  next to a layer to show it,  to hide it.

Organize Layers by Depth
Layers are drawn one after the other. You can change the depth of layers.

1. In the Content edition tab, click the Layers button.
The Layer dialog box appears.

2. Set the depth of a layer using the list next to it.
A layer with depth 1 is drawn first.
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Creating a New Synchronization between
Events

You can create a new synchronization between the events. Several events can be synchronized with the
Synchronization tab.

1. In the left text box, type the name of the synchronization.

Figure 48: Synchronization tab

2.
Click the left  icon to create a new empty synchronization.

3. Edit the vector of synchronized events:

a) Enter the name of an event in the right text field (press Ctrl+Space to open the name completion panel).
b)

Click the right  icon to add the event to the synchronization vector.

4. Select the synchronization type among the following ones:

• Common Cause Failure (CCF)
• Diffusion
• Synchronization.

5. In the Law box, set the probability distribution. (see Modify the probability distribution of an existing event
on page 37.)
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Note: At simulation time, synchronizations can be fired as any event.
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Editing AltaRica code
This section describes how to work with the AltaRica code.

About AltaRica Code on page 60

Copying, Cutting and Pasting AltaRica Code on page 62

Checking AltaRica code on page 62

Using the Code Completion on page 63

About AltaRica Code
This topic provides more information about the AltaRica code edition tab.

About AltaRica Code tab

The AltaRica code edition tab is used to edit the behavior of a model class using AltaRica language statements.
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Figure 49: AltaRica code edition tab

About the AltaRica Syntax Highlighting

The AltaRica syntax highlighting cannot be setup.

The syntax of AltaRica code is highlighted as follows:

StyleAltaRica construction

Bold blueKeywords (if, then, else, tran, etc.)

PurpleNumerical values

GreenOperator names
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StyleAltaRica construction

Bold redicon built-in variable

Important:  If operators are used in the AltaRica code, the Operators tab becomes available. It allows
selecting operator package and version, if different operators have the same name. If there is no ambiguity,
the only package containing the operator is selected, with its last version.

Refer AltaRica Language Specification on page 149 for more information about the AltaRica language.

Copying, Cutting and Pasting AltaRica Code
You can copy, cut aand paste AltaRica code.

Copy AltaRica code
You can copy AltaRica code.

1. Select the characters to be copied in the text editor.

2. Click the Copy button, or press Ctrl + C.

Cut AltaRica code
You can cut AltaRica code.

1. Select the characters to be copied in the text editor.

2. Click the Cut button, or press Ctrl + X.

Important:

• Cutting text copies it to the clipboard and suppress
it.

• The generated part (in gray) cannot be cut.

Paste AltaRica code
You can paste AltaRica code.

1. Move the caret to the point after which the text must be pasted from the clipboard.

2. Click the Paste button, or press Ctrl + V.

Important:

• The clipboard must contain text for this operation to be performed.
• The generated part (in gray) cannot be pasted in.

Checking AltaRica code
You can check the AltaRica code to detect the syntax and consistency errors.
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Check AltaRica code Syntax
You can check the syntax in the AltaRica code.

Click the Syntax  button.
If a syntax error is detected, an error window is displayed, describing the error and the line containing the
error.

Important: The most common errors are:

• Incorrect syntax in transition declaration (e.g. mixing up the = comparison operator and the :=
assignment operator).

• Assignments between variables of incompatible type (e.g. assigning an integer to a Boolean variable).
• Missing trans or assert keywords.
• Unbalanced parenthesis (not the same number of opening and closing parenthesis).

Check AltaRica code Semantics
You can check the semantics in the AltaRica code.

Click the Consistency button.
If a consistency error is detected, an error window is displayed describing the error and the line containing
the error.

Search in AltaRica code
You can make a search in the AltaRica code.

1. Move the caret to the point from where the search must start.

2. Click the Search button, or press Ctrl + F.

Using the Code Completion
You can insert a variable, an event or a record field to complete the AltaRica code.

Insert a Variable or an Event
You can insert a variable or an event in an AltaRica code.

1. Move the caret to the desired position.

2. Press Ctrl + Space.
The Atom insertion dialog box appears.
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Figure 50: Atom insertion dialog box

3. Double-click the element to be inserted.

Insert a Record Field
You can insert a record field in an AltaRica code.

1. Type the character ^ after a variable name.
The Field completion dialog box appears.

Figure 51: Field completion dialog box
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2. Double-click a field in the list to insert it.
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Using Icons
This section describes how to create icon library and associate icons with the model class.

Managing Icon Library on page 66

Adding and Removing Icons from Model Class on page 69

Managing Icon Library
You can create a new icon library. You can add and remove icons from the icon library.

Create a New Icon Library
You can create a new icon library.

1.
Click the  icon in the Icon management  tab.

Figure 52: Icon management tab

2. Enter the name of the new library.
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Figure 53: Creating a new icon library

3. Press Enter.
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Figure 54: Icon library selector

A new icon library is available in the Icon library selector.

Add Icons to a Library
You can add icons to an existing library.

1. In the icon library selector of the Icon management tab, select the library where to add a new icon.

2.
Click the  icon.
The Select dialog box appears.

Safety Designer User Guide68



Figure 55: Image file selection dialog box

3. Select the image file to add to the library and click Select.

Remove Icons from a Library
You can remove icons from an existing library.

1. In the Icon management tab, select the library to modify.

2. Select an icon.

3.

Click the  icon to remove it from the library.

Adding and Removing Icons from Model Class
You can add and remove icons from the model class.

Add Icons to a Model Class
You can add icons to the model class.

1. In the icon library selector of the Icon management tab, select the source library.

2. Select an icon.
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3.
Click the  icon to append it to the icon vector used by the class.

4.
Click the icon to move up and the icon in the vector, to move it down.

Important:

• In a class, an icon is associated to a number (its position in the icon vector) which is meant to be used
in the AltaRica code of the class.

• Using icons of the same size is a good practice to ensure that the model instance evolves nicely during
simulation

Remove Icons from a Model Class
You can remove icons from a model class.

1. In the icon library selector of the Icon management tab, select the source library.

2. Select an icon.

3.

Click the  icon to remove it from the icon vector used by the class.

To set the graphical representation of a model class independently of the model instance state, edit the general
properties of the class instead. The general properties of a model class can be edited with the General properties
tab.

Figure 56: General properties tab
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Working with Component Models
You can create a component model and edit the existing models.

A component model is a particular kind of model class, which can have flow and state variables, events, icons and
AltaRica code, but cannot compose instances of other models, hence cannot have synchronisation. A component model
can be considered as a flow processor which has an internal state, can react to events, and transform its inputs accordingly.

Create a New Component Model
You can create a component model.

1. Click the Component model tab.

2. Create a component model as you created a model class.

Opening an Existing Component Model Class
You can open an existing component model class.

1. Access the Componenet Model class tab.

2. Select a model class in the package tree.

Here we selected BackupCoolingSystem/BackupCoolingSystem.

3. Double-click a version.

Here we clicked Version 1.

The Model Class Editor appears.
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Figure 57: Model Class Editor

Important:

• When a model is opened for edition, it is automatically locked so that several users cannot edit the
same model at the same time.

• A model class can remain locked after a system crash; access its properties to remove the lock manually.

For more information about model class, refer to Working with Model Classes on page 20
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Working with Equipment Models
You can create an equipment model and edit the existing models.

An equipment model is a particular kind of model class, which can have flow variables, icons and AltaRica code, can
compose instances of other models and synchronize events, but cannot have state variables and independent events.

1. Click the Equipment model tab.

2. Create an equipment model as you created a Creating a New Model Class on page 20.

You can open the existing equipment class, perform consistency check on them, save the equipment model class,
etc similar to Model class. For more information about model class, refer to Working with Model Classes on
page 20.
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Working with System Models
You can create a system model and edit the existing models.

A system model is a particular kind of model class, which can compose instances of equipment and component models,
can synchronize events, and can have system assertions (made of assertions expressed in AltaRica code), but cannot
have state or flow variables, independent events or icons.

1. Click the System model tab.

2. Create a component model as you created a Creating a New Model Class on page 20.

You can open the existing system class, perform consistency check on them, save the system model class, etc
similar to Model class. For more information about model class, refer Working with Model Classes on page 20.
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Editing System Assertions
A system assertion is a link which has no graphical representation. You can edit system assertions.

1. Click the System assertions tab.
The following dialog box appears.

Figure 58: System assertions tab

2. In the left part of the dialog box, click the main hierarchical level, then double-click to display the hierarchical
levels.

3. Select a hierarchical level.
The Edition area displays the variable assignment in the System assertions.

Important:  System assertions are links which exist but are not displayed in the graphical view; they
concern only flow assignments.

4. The syntax for system assertions is:

Simple assignment between flow in and flow out with same type:

<component_i>.<In_Name> = < component j>.<OutName>;
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Simple assignment between flow in and a specific value defined with a same type:

<component_i>.<In_Name> = true;
<component_i>.<In_Name> = low;

Assignment using operators:

<component_i>.<In_Name> =
(<component_j>.<OutName> or <component_k>.<OutName>);
<component_i>.<In_Name> = my_operator(<component_j>.<OutName>,
                    <component_k>.<OutName>);

5. Right-click a port in the system model and select Copy port name.

The name of this port can be pasted in the equipment Altarica code.

You can edit system assertions using the following icons:

•

: Copy
•

: Cut
•

: Paste
•

: Zoom In
•

: Zoom Out

The validity of these system assertions will be checked by the system consistency control (activated with Check
properties from the System menu).

Important:  In system architecture, assertions can only be written at the system level (main node). For
hierarchical level associated to equipments, only a viewing of assertions defined in library is possible (in
equipment model editor).
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About System Links
A link defines an interconnection between two objects in architecture.

You can edit the system link:

1. Click the Links tab.;

The following window displays an exhaustive list of all the links which have a graphical representation in a
given hierarchical level.

Figure 59: System assertions > Links tab

2. In the left part of the dialog box, click the main hierarchical level, and then double-click to display the
hierarchical levels.

3. Select a hierarchical level.
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The Unknown models tab displays the list of unknown models.

Figure 60: Information > Unknown models tab

Unknown
models tab
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The Suppressed links tab indicates information for each of the following elements: component, component model, port, port type and
field of type.

Figure 61: Information > Suppressed links tab

Suppressed
links tab
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The Invalid links tab indicates information for each of the following elements: component, component model, port, port type and
field of type.

Figure 62: Information > Invalid links tab

Invalid
links tab

The Renamed components tab displays the following information concerning components which have been renamed in an architecture:Renamed
components
tab

• Localization
• Old name
• New name
• Type
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Figure 63: Information > Renamed components tab

Changed
models tab

The Changed models tab indicates the models, the ports and the states.
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Figure 64: Information > Changed Models tab
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Working with Operators
This section describes how to work with operators.

About Operators on page 83

Creating a New Operator on page 87

Editing an Operator on page 87

Renaming an Operator on page 88

Duplicating an Operator on page 88

Creating a New Version of an Operator on page 89

Freezing a Version of an Operator on page 89

Deleting an Operator Version on page 89

About Operators
Operators allow simplifying the writing of assertions in AltaRica code. An operator corresponds to a transfer function
between output flow(s) and input flow(s). Contrary to a component model, an operator doesn’t include behaviour
(represented by transitions).

Important: The operators can be used only within component (or equipment) assertion. Using operators in
transitions is currently forbidden.

The Operator editor dialog box consists three tabs:

• General
• Properties
• AltaRica code.

General tab

The General tab allows to filling in the following information:
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Figure 65: Operator editor - General tab

Name (in the top edit area): enter the operator name, e.g. o2by3.

In the Operands area, the first line corresponds to the operator result. The default name of the operator result
is the name of the name. It cannot be changed. The first line cannot be removed.

Name (in the bottom edit area): enter the operand name.

The Type list to select the operand type.

You can icon  or use the Enter key to add the operand in the list. To modify the type of an existing operand,
select it and click the Assign button.

Type of an operator/operands can be a record, but the orientation must be normal and without crossing.

Properties tab

The Properties tab displays:

• Creation date
• Last modification date
• Version
• The Comment box allows adding a comment describing the operator.

AltaRica code tab

The AltaRica code tab contains:

• A shortcut bar (Copy, Cut, Paste, Backward zoom, Forward zoom, Display extern clauses).
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•
Extern clauses is a no-editable area and the icon  is used to display/mask it.

• A variable declaration area below the edition bar displays information about the current operator: function
name, flow variables (I/O) and their type. The content of this area is generated automatically:

Figure 66: Operator – AltaRica code – Operands

• The AltaRica code area (assertions [assert]). The AltaRica code syntax of an operator is identical to component
assertions:

Figure 67: Operator editor - AltaRica code tab

Assertions allow specifying the values of the output flow (identified by the operator name: O2by3) according
to the input flows (operands: op1, op2, op3). In the previous example, the assertion can be defined by the following
expression: O2by3=((op1 and op2) or (op1 or op3) (op2 or op3)).

Operators can be used to define other operators:
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If operators are used in AltaRica code, the Operators tab is accessible. It allows selecting the package and the
version of the operator, if different operators have the same name. If there is no ambiguity, the only package
containing the operator is selected with the last version.

Figure 68: AtlaRica Code - Operator Tab

1. Click Syntax to check syntax of AltaRica code.

If a syntax error is detected, an error message appears and describes precisely the kind of error and the line
containing the error.

The most common syntax errors are: Assertions define affectation with variables having a type incompatible
(enumerate with Boolean, …).

Assertions define affectation with variables having a type incompatible (enumerate with Boolean, …)

Syntax of expressions between brackets is not respected.

2. Click Consistency to check consistency of AltaRica code.

If a consistency error is detected, an error window is displayed and describes precisely the kind of consistency
error and the line containing the error.

The most often consistency errors detected are:

• Existence of a combination of operand values (input flow variables) for which the result of the operator is
not defined.

• Existence of a combination of operand values (input flow variables) for which the result of the operator
(output flow variable) has two different values.
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Important:

• When the new operator is saved, it is saved in the version 1 and it depends on the user group of the package
it belongs to.

• When the new operator is saved, it is automatically inserted in the operator library (by alphabetical order).

Creating a New Operator
You can create a new operator model.

1. Click the Operators tab to display the list of operator families in the library.

2. Select an operator package.

3. Display the contextual menu with right-click or open the Library menu.

4. Select the Create new model command.

The Operator editor dialog box appears:

Figure 69: Operator editor - General tab

Editing an Operator
You can edit an operator.
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1. Click the Operators tab in the left part of the screen to display the operator package list.

2. Select the model.

3. Click to access the tree structure of versions.

Figure 70: Operators – Versions tree structure

4. Edit the operator:

• Double-click on the version number.
• Select the command Edit model in the Library menu or right-click the version number and select Edit

model.

The Operator edition dialog box appears.

Renaming an Operator
You can rename an operator.

1. In the Operators tab, click the model to be renamed.

2. Right-click the model and select Rename model.
The name box of the operator becomes available.

3. Type the new model name and validate with the Enter key.

Moreover, modifying name of an operator can have an impact on component models using this operator.

If the name already exists, an error message is displayed.

4. Click the OK button and enter another name, then validate with the Enter key.

Important: When an operator is renamed, the Altarica code must be modified because the output flow is
identified by the operator name.

Duplicating an Operator
You can duplicate an operator.

1. Click the Operators tab in the left part of the screen.
The operator package list appears.

2. Select the model to be duplicated .

3. Right-click the model and select Model … > Duplicate.

Note: The default name can be possibly changed.

4. You can change the package of an operator model:
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Copy the operator : command Model … > Copy.a)
b) Paste the operator in the destination package : command Model … > Paste.
c) Restore the original name of the operator (remove the extension « _copy ») in the destination package.

Important:  If the model has several versions, only in the last version is duplicated. To duplicate another
version of the operator, it is necessary to select the version in the model tree structure before launching the
command Model … > Duplicate.

Creating a New Version of an Operator
You can create a new version of an operator.

1. Click the Operators tab in the left part of the screen.
The operator package list appears.

2. Select the model.

3. Right-click the operator name and select Model … > New version.
When the new operator version has been created, it is inserted in the versions tree structure.

Freezing a Version of an Operator
You can freeze a version of an operator.

: This operation is very risky and must be used with extreme care, because it is irreversible: any ulterior modification
becomes impossible on a frozen model.

1. Click the Operators tab in the left part of the screen to display the operator package list.

2. Select the operator model.

3.
In the tree structure of the selected model, click  to display the versions.

4. Right-click the version munber and select Model … > Freeze.
The frozen versions are represented by the symbol: in the model library. This Frozen attribute can be also
visualized in the property editor. In the File menu, select Properties to dispaly the property editor.

Deleting an Operator Version
You can delete an operator version.

: This operation is very risky and must be used with extreme care, because it is irreversible.

1. Click Operators tab in the left part of the screen.
The operator package list appears.

2. Select the model.

3.
Click the  icon to display the version list of the model.

4. Right-click the version number and select Delete model.
A dialog box indicates that the operator will be removed.
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5. Click Continue to confirm deletion, or Cancel to abort deletion.
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Working with Types
This section describes how to work with type.

Creating a Type on page 91

Editing a Type on page 95

Renaming a Type on page 95

Duplicating a Type on page 96

Creating a New Version of a Type on page 96

Copying a Type on page 97

Freezing a Version of a Type on page 97

Deleting a Type on page 97

Searching a Type on page 98

Creating a Type
You can create various types.

Create an Enumerated Type
Creating an enumerated type in library allows avoiding defining several times a same type for state variables
and flowing variables.

1. Select in library the command Create new type… > Enumerate  or,

2. Click the Types tab in the left part of the screen.
The list of types appears.

3. Select the Library menu or right-click the type.

4. Select Create new type… > Enumerate.

5. Type a name for the new type in the Type name box.

6. In the Name box at the bottom of the window, enter a string value.

7.
Click the  icon or use the Enter key, the variable is added in the list.

8. Click the Save and Close buttons.

By default, a new type is created in version 1 and is linked to the package user group.
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Figure 71: Create enumerated type

Note:  In the Types tab in the left part of the screen, the enumerated type is represented by the symbol

.

Create a Structured Type
The structured type (or Record) allows including several flow information (record field) in a same link. In a model,
the enumerate type is a list of possible values for a variable (state or flow) whereas a structured type is a list of flow
variables.

1. Click the Types tab in the left part of the screen.
The list of types appears.

2. Select a package.

3. Right-click to display the contextual menu or use the Library menu.

4. Right-click the package and select Create new type…> Record .

5. Type a name for the new type in the Type name box.

6. In the Name area at the bottom of the window, enter a name for the record box.

7. Select the Type menu and choose a type.

8.
Click the  icon or use the Enter key, to add the record field in the list.
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9. Click the Assign button to modify the type, if necessary.
The type is displayed in the Type column.

10. Click in Orientation column; select the orientation: normal or inverse.

11. Click in the Crossfield column to define a flow crossing.

Figure 72: Cross field for Inputs/Outputs

12. Enter the cross field and validate with the Enter key.
A new type is created in version 1 and is linked to the package user group.

Figure 73: Create flow structured type
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More about Structured Type
A structured type can be compared to a bus allowing reducing the number of graphic links in equipments and architecture
systems. Only the flow variables (in or out) can be declared with a structured type.

The definition of the structured type flow generates two connection studs:

• a port in
• a port out.

Each connection stud is composed of n fields (flow parameters=field).

In general, the field has the same orientation as its reference stud. The clause inverse allows specifying if the
fields of the stud in or stud out have an inversed orientation.

The figure below shows the various relations of possible equality between the fields of the stud out and stud in
according to the cross fields and orientations defined for the flow parameters (A, B, C, D).

• Case 1 : A data structure with direct assignments,
• Case 2 : A data structure with cross field assignments,
• Case 3 : A data structure with inversed and cross field assignments.

In order to simplify the code interpretation presented below, the equality relations are oriented and thus defined
using the assignments.

To access a field, use the character '^'.
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The following icons are used for creating a type:

•

 to delete an Input/Output,
•

 to edit a parameter type if it is predefined (or double click on the Type cell),
•

 to move up the selected line in the list of Inputs/Outputs,
•

 to move down the selected line in the list of Inputs/Outputs.

These commands are also available in the contextual menu with a right-click.

Note:

•
In the Types tab in the left part of the screen, the record type is represented by the symbol .

• In the list of “predefined” types, only the list of enumerate types is displayed (the list of record types is
not displayed) because a record type cannot contain another record type.

Editing a Type
You can edit a type.

1. Click the Types tab in the left part of the screen to display.
The list of type package appears.

2. Select the model.

3.
Click  to access the tree structure of versions.

Figure 74:Types – Tree structure of versions

4. Edit the type:

• Double click on the version number.
• Select the command Edit model in the Library menu or right-click the type and select Edit model.

The Type edition dialog box appears.

Renaming a Type
You can rename a type.
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: This function is very risky and must be used with extreme care, because the renaming leads to a reference change
of the model in models using the type.

1. In the Types tab, click the model to be renamed.

2. Right-click the model and select Rename model.
The name box of the type becomes available.

3. Type the new model name and validate with the Enter key.

If the name already exists, an error message is displayed. Click OK and enter another name, then validate
with the Enter key.

Duplicating a Type
You can duplicate a type.

1. Click the Types tab in the left part of the screen.
A type package list appears.

2. Select the model to be duplicated.

3. Right-click the model and Model … > Duplicate.
The default name can be possibly changed.

Important:  If the model has several versions, only the last version is duplicated. To duplicate another
version of the type, it is necessary to select the version in the model tree structure before launching
Model … > Duplicate.

4. You can change the package of a type model:

a) Copy the type : command Model … > Copy.
The default name can be possibly changed.

Important:  If the model has several versions, only in the last version is duplicated. To duplicate
another version of the type, it is necessary to select the version in the model tree structure before
launching the command Model … > Duplicate.

b) Paste the type in the destination package : command Model … > Paste.
c) Restore the original name of the type (remove the extension _copy) in the destination package.

Creating a New Version of a Type
You can create a new version type.

1. Click the Types tab in the left part of the screen.
A type package list appears.

2. Select the model.

3. Right-click the type and select Model … > New version command.
A bar graph indicates that the new version is being created.

When the new type version has been created, it is inserted in the tree structure of versions.
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Copying a Type
You can copy a type.

1. Click the Types tab in the left part of the screen.
A type package list appears.

2. Select the model to copy.

3. Right-click the model and select the command Model … > Copy.
A bar graph indicates that the type is being copied.

4. Select the new target package for the copy.

5. Select the Paste command.

Important:  If the type has several versions, the copy is possible only for the last version.

Freezing a Version of a Type
You can freeze a version of a type.

: This operation is very risky and must be used with extreme care, because it is irreversible: any ulterior modification
becomes impossible on a frozen model.

1. Click the Types tab in the left part of the screen.
A type package list appears.

2. Select the type model.

3.
Click the  icon to display the versions in the tree structure of the selected model.

4. Select the version number.

5. Right-click it and select Model …  > Freeze.

Important: The frozen versions are represented by the symbol:  in the model library. This Frozen
attribute can be also visualized in the property editor: Properties command in the contextual menu or from
the general menu File.

Deleting a Type
You can delete a type.

Note: This operation is very risky and must be used with extreme care, because it is irreversible. The component
is deleted and all its associated links in equipments and architectures using it.

1. Click Types tab in the left part of the screen.
A type package list appears.

2. Select the model.
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3.
Click the  icon to display the version list of the model.

4. Select the version number.

5. Right-click the version and select Delete model.
A dialog box indicates that the type will be removed.

6. Click Continue to confirm deletion, or Cancel to abort deletion.

Searching a Type
You can search a type.

1.

Select the model, click the second icon .
The search model and the number of found instances appear at the bottom (result of search).

2. Double-click the model to unroll the list of model instances in the system.
It provides information about localization (in H_ELEC/Poste_EDF; 1).

3. Select an instance, click the Locate button in order to view on this instance.
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Setting Link colors
You can set the link colors.

1. Open a system architecture.

2. Use the Views > Colours menu to define the links colour in a system during simulation.
The Links colours dialog box appears. It contains in its right part a colour palette, and in the left part, an area
displaying the link colours according to their type.

3. When a new architecture is created, the boolean type is the default type with two colors.

False: red,

True: green

Figure 75: Boolean variable colors

4. If a new architecture contains links (non-boolean) which must be coloured, then:

a) Enter a type in the text edit zone (enum, bound or predefined).
b)

Click the  icon or use the Enter key to add the type in the list.

c) To select a predefined type variable, enter pressure in the enum box.
The following dialog box appears:
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Figure 76: Link color

d) Double-click the type in the list to display the possible values, e.g., pressure;
The four possible values for pressure are displayed.

• High

• Low
• Normal
• Null

e) Select a value, e.g. Normal.
f) In the colour palette, select a colour.

The grid on the right indicates the last selected colors.

g)
Click the  icon to assign the color to the value.

h) Repeat the same steps to define the colours for the three other values.

Important:

• The color assignment is specific for a system; the colors are saved with the system.
• An existing enumerated type can be deleted by clicking the corresponding icon.
• When a link is of the record type, the colors displayed during the simulation correspond to the first

flow box.
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Searching for a Model
You can search a model.

1.

Use the Edition > Search menu or type the CTRL + B command on the keyboard or use the  icon in
the Standard toolbar.
The Search dialog box appears.

2. Click the Component tab.

3. In the Filter box, enter the component name as follows : <Package_Name>/<Model_Name> .

Important: The character « * » can be used to decrease the search space (example: H*/val*) or to
complete a partially-known-name (examples: HYD*/val*, */valve).

4.

Click the  icon.
The component found (or the components having a name corresponding to the filter used) is displayed in the
middle part of the window.

101



Figure 77: Search dialog box
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Printing
This section describes how to set the print layout and print a model.

Setting Page Layout on page 103

Printing a Model on page 104

Setting Page Layout
You can set the page layout.

1. Select File > Print Setup.
The Page Setup dialog box appears.

2. In the Paper area, select:

• The size (A4 or A3),
• The source (manual feeding or automatic selection).

3. In the Orientation area, select the Portrait or Landscape mode.

4. Each format or orientation modification automatically updates the scale factor of the page displayed.

5. In the Margin area, enter the margins (left, right, up or down).

6. Click OK to save the new printing format, or click Cancel.
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Figure 78: Page Setup dialog box

Printing a Model
You can print the selected model or system.

Printing a Model
You can print the selected model.

1. Select the model version you want to print in the library:
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2. Edit model by right-clicking the versionand selecting Model > Edit.

3.
Select the File > Print  menu or click  icon.

Print a System Version
You can print the selected system version.

1. Select the system version you want to print.

2. Double-click the System.

3.
Select the File > Print  menu or click the  icon to print selected system.

4. Select the pages to be printed.

Figure 79: Print architecture dialog box

5. Click the Validate button, or click the Cancel button to abort the printing.
The Print dialog box appears.

6. In the Printing area, select the area to be printed (all, pages n to m or selection).
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Figure 80: Printing window

Note:  In the Preferences window > Options tab, it is possible to select a file containing a logo which will
be added.
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Exporting and Importing
This section describes how to export and import the model.

Exporting on page 107

Importing on page 108

Exporting
You can export the models.

1. In the File menu, select the Export command.
The Export dialog box appears.

Figure 81: Export dialog box

2.
In the Export file name box, click the  button to choose the export file name and the directory.

3. In the Items exported box, drag and drop the object or select an element in the library and use the File/Add
to Export menu.
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The element is added.

4. In the Comment box, add a description.

5. Select the Put a default law on events and synchronizations check box to add a default law on events and
synchronizations that have no law.

6. In the Default law box, specify the default law.

7. Click Validate to export or Cancel to abort exportation.

Important: The frozen and locked models cannot be exported.

Importing
You can import data from an XML import file (.exp extension) generated by Safety Designer.

1. In the File menu, select the Import command.
The Import dialog box appears.

Figure 82: Import dialog box
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2.
In the Import file name box, click the  to choose the export file (extension .exp) containing data.

The Properties tab display properties associated to the imported data (creation date, comment, and owner).

3. Click Control Import to launch validity check.

This check validate the XML Format. The detected errors are displayed as impossible imports.

Important:  Only ascendant compatibility is ensured.

Detecting Conflicts when Importing Data
While importing the validity of the XML Format is checked and the errors are detected.

When importing the data, some conflicts are detected. This detection is done essentially by comparing the last
modification date of each imported element with the model in database.

The detected conflicts are displayed in the following tabs:

• Systems
• Components
• Equipments
• Operators
• Types
• Images

By default, the data in database are not updated during data importation.

Nevertheless, the user can specify, for each conflict, a possible update of the database by clicking .
The All button allows updating (importing) all models in conflict displayed in the tab.
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Figure 83: XML Import – Detected conflict

You can click Validate to import or Cancel to abort importation.
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Managing Plugins
This section describes how to manage plugins.

About Plugins on page 111

Setting Plug-ins Preferences on page 112

Working with JAR files on page 114

Editing Actions on page 115

Inserting Plug-in Actions in Menus on page 118

About Plugins
This topic provides background information about plugins.

The Plugin manager allows the user to manage the compute plugins. The compute plugins are processing units
taking in input a model generated in Safety Designer. According to the treatment made, the user will obtain on
output event minimal cuts, event sequences, a step by step simulator by inference rules or a Java step by step
simulator.

You can create new plugins and add them inside Safety Designer by using the plugin manager. This chapter
does not show the plugin creation process. This theme is developed in details in another document.

From their use point of view, the user sees the plugins like treatment units contained in JAR files (in Java). A
JAR file can contain several plugins. These files are read by the plugin manager in order to load the plugins into
the application during its launch.

The Plugin manager dialog box contains three tabs:

• Plugins
• Actions
• Items.
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Figure 84: Plugin manager dialog box

The Plugins tab allows the user to manage the plugins. The Actions tab allows adding actions associated to the
plugins and the Items tab allows inserting inside the application user interface, plugin linked action launch point.

Setting Plug-ins Preferences
The Plugins tab allows the plugin management inside Safety Designer. Through this tab you can add, remove
plugin to/from the application and also view the plugin properties.

Plugin organization

Plugins are organized in a tree structure.
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Figure 85: Plugin manager – Plugin tree structure

• The first level shows the different JAR files from which the plugins are loaded into the application. The plugin
paths are expressed in relative from the location of the file named plugins.xml.

• The second level contains Action, Translate, Compiler and/or Stepper nodes. The nodes allow classifying
plugins into categories.

The Action nodes gather plugins that can be directly executed by the user if associated to an action and a launch
point in the application user interface.

The Translate nodes gather plugins used in treatment flows and are dedicated to the translation of some
languages into other languages.

The Compiler nodes gather plugins allowing compilation of models which accelerate its use by the simulation
engine.

The Stepper nodes gather the plugins that implement simulation engines.
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View plugin informations

In order to visualize plugin related information, the user selects a plugin in the tree structure. The information
then appears in the right part of the tab:

Figure 86: Plugin manager – Plugin information area

A plugin has a name, a class name and a description. This information is accessible to the user but is not editable
for write because it is to the plugin designer responsibility.

The class name is the complete name of the implementation Java class. It is the plugin entry point.

Working with JAR files
Plugins are only accessible throughout the JAR files. You can load the JAR files containing plugins and not
plugins directly.

Add JAR files
You can add JAR files.
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1. Click the Add button.
A file explorer dialog box appears.

2. Select the JAR files containing the plugins that are to be integrated into the application.

3. Click the Open button.
The plugins are registered in the application and then can be referenced by plugin actions.

Remove JAR files
You can remove JAR files.

1. Select the JAR files nodes that are to be deleted.

2. Click the Remove button.
A confirmation dialog box appears.

3. Click the Continue button to confirm the JAR files deletion or click the Cancel button to cancel the action.

If you click the Continue button, the selected JAR files nodes and all their content are removed from the
tree structure.

Editing Actions
The actions are plugin instantiations in the sense that they allow using the plugins with distinct parameters. The actions
only apply to the Action plugins and not to the others categories. When you select a plugin of Translate, Compiler or
Stepper type, the Action tab become inaccessible.

Add PlugIn Action
You can add plugin action.

1. Select if necessary the Plugin tab and then, in the tree structure, the plugin of Action type on which the new
action is to be created.

2. Select the Action tab.
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Figure 87: Plugin manager > Actions tab

3. Click the Add button.
The Add Plugin Action dialog box appears.
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Figure 88: Add Plugin Action dialog box

4. In the boxes, fill the desired parameters.

5. Click OK to confirm the plugin action creation or Cancel to do nothing.
If you clickOK, the new action is added to the already existing actions list.

Important: A default label is available in the corresponding box when the Add Plugin Action dialog
box appears. This label is provided by the plugin. It is the same for the Icon, Shortcut and Tooltip text
boxes.

Two different actions associated to the same plugin cannot have the same label. When an already existing
label is entered in the corresponding box, OK is then disabled.

The Parameters button gives write access to the plugin parameter list when the plugin has parameters. These
parameters and their viewing are provided by the plugin designer.

Edit Plugin Action
You can edit the plugin action.

1. Select if necessary the Actions tab to edit the action.

2. Click the Edit button.
The Edit Plugin Action dialog box appears.
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Figure 89: Edit Plugin Action dialog box

3. Modify the boxes in the dialog box.

4. ClickOK to confirm the modification or Cancel to cancel the operation.

Remove Plugin Action
You can remove the plugin action.

1. Select the Actions tab if needed.

2. Select the action nodes.

3. Click the Remove button.
A confirmation dialog box appears.

4. Click Continue to confirm the actions deletion or Cancel to do nothing.
If you click Continue, the selected actions then disappear from the action list.

Inserting Plug-in Actions in Menus
This section describes the various plug-in actions.

About Plugin Items Overview on page 119

Adding Plugin Item on page 120

Adding Separators on page 120

Adding Customized Menu on page 120
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Editing Customized Menu on page 121

Remove Graphic Item on page 122

About Plugin Items Overview
The Plugin items can be managed using the Items tab.

The Items tab allows the plugin item management. Note that the plugin items are user interface graphical objects
like buttons or menu items that provide a launch point for the Action typed plugins. By the other, a plugin item
action is an action defined or predefined in the Actions tab. When created on a tool bar, the plugin item is a
button and created on a menu bar, the plugin item is a menu item.

The Items tab is divided in two parts: a first part that shows all the application menu items and toolbar buttons
in a tree structure view and a second one that gather the commands accessible on the plugin items.

By navigating in the tree structure representation, the user can for instance reach a sub-menu in order to add a
plugin launch point. You can also create other type of objects like separators or new menu in existing ones. All
the supplementary graphic objects appear in the tree structure with bold text font.

Figure 90: Plugin manager > Items tab
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Adding Plugin Item
You can add plugin item.

1. Select the Plugins tab then a plugin of Action type if necessary.

2. Select the Action tab then an action in the list if necessary.

3. Select the Items tab if necessary.

4. Navigate in the tree structure until the insertion location.

5. Click the Add Item button.

The plugin item is created and added to the tree structure and in the application menubar or toolbars.

When the selected object for the item insertion is a menu, the item is inserted at the last position in that menu,
when it is a menu item the insertion is done at the preceding position of that menu item.

Adding Separators
You can add seperators.

1. Select the Items tab if necessary.

2. Navigate in the tree structure until the insertion location.

3. Click the Add Separator button.
The separator is created and inserted in the selected location.

When the selected object for the insertion is a menu, the separator is inserted at the last position in that menu,
when it is a menu item the insertion is done at the preceding position of that menu item. The separators
created by the user have all the same name:

<SEPARATOR>

Adding Customized Menu
You can add the customized menu.

1. Select the Items tab if needed.

2. Navigate in the tree structure until the insertion location.

3. Click the Add Menu button.
The Add menu dialog box then appears:
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Figure 91: Add menu dialog box

4. In the Label box, fill the label.

5. In the Icon box, fill the icon path.

6. Click OK to validate the creation or Cancel to cancel the operation.

If you click OK, the newly created menu is added at the selected location. When the selected object for the
insertion is a menu, the newly created menu is inserted at the last position in that menu, when it is a menu
item the insertion is done at the preceding position of that menu item.

Editing Customized Menu
You can edit the customized menu.

1. Select the Items tab if needed.

2. Select the menu to edit in the tree structure.

3. Click the Edit Menu button.
The Edit Menu dialog box appears:

Figure 92: Edit menu dialog box

4. Modify the boxes.
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5. Click OK to validate the modification or Cancel to cancel the operation.

If you click OK, the menu is then modified.

Remove Graphic Item
You can remove the graphic items. Only the graphic elements added by the user are removable. It can be plugin item,
supplementary separator or supplementary menus.

Important: When a menu is removed, all the graphic elements under this menu are also removed.

1. Select the Items tab if needed.

2. Select the graphic elements in the tree structure.

3. Click the Remove button.
A confirmation dialog box appears.

4. Click Continue to confirm the graphic element deletion.
The graphical element is removed.
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Setting Preferences
This section describes how to customize the setting of various preferences.

Opening the Preferences Panel on page 123

Setting Preferences on page 123

Opening the Preferences Panel
You can access the preferene panel.

Select Views > Preferences….
The Preferences dialog box appears.

Figure 93: Preferences dialog box

Setting Preferences
The various preferences enables you to customize the environment, desktop and toolbars.

Environment

Sub-rubric Memory is for maintenance only.

123



Figure 94: Memory management

The Save button has no effect in this rubric.

The Verification sub-rubric allows the user to choose the syntactic and consistency checking.

Figure 95: Syntax and consistency checking

Desktop

The Desktop Options sub-rubric allows background choice:
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• Display time and date,
• Display tools bars,
• Display task bar

Figure 96: Desktop options tab

Tools bars

The Tools bars tab allows customization of the tools bars with the following bars:

• Standard
• Edition
• Design
• Links
• Alignment
• Navigation
• Simulation

Validate by clicking Save and then Close.
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Figure 97:Toolbars tab

Important:  If the number of tools bars exceeds the window width, buttons located at both ends enable
access to the tools bars which are not displayed on the screen.
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Edit

In the Adjustment of font size in architecture view field, type any font size and adjust this size by

means of the  and icons.

Figure 98: Graphic editors font

Font

Safety Designer has an edition help for writing AltaRica code by given, during data acquisition, the
list of component which are present at corresponding level.

Help

Select the Activate edition helper check box to activate it.
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Figure 99: Activating Code Completion

The Graphics options sub-rubric allows customization of the tool with the following options:
Graphic
Options

• Open architecture when opening project
• Display components ports
• Display components over links
• Draw links with square angles
• Display links direction
• Print border around equipment
• Relief and color on equipment input
• Relief and color on equipment output.
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Figure 100: Graphics options sub-rubric

Select the Put default law on events and synchronizations check box to save events and
synchronizations with a default law. The default law is only put on events and synchronizations that
have no law. Use the Default Law area to define this law.

Figure 101: Save

Save
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Inputs / Output

The Inputs/Outputs rubric contains one sub-rubric: Printing logo.

In the File name box, type the pathname to a logo which will be printed in the page top left corner (the file
format containing the logo is of the .gif or .jpg type) or use the Select button to indicate the file containing the
logo.

Figure 102: Printing Logo

Validate by clicking the Save and Close buttons.

Important: The Save button must be used only if the modifications are to be saved in the preferences.dat
file.

Simulator

The Simulator rubric allows choosing simulator options.

The simulator behaviour depends on options that can be activated or not:

• Trigger Automatically event and change state off
• Number of automatic execution: to avoid endless simulation due to automatic triggering of instantaneous

transition, user must specify the maximum number of automatic.
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Figure 103: Simulator Options

Plug-in Preferences

The Plugins – Plugin Action and Plugins - PluginTranslate rubrics (Figure 102) allows to choose options
concerning the plugins.

For detailed explanations about these options, please see the plugin appendices.

Figure 104: Plugin option rubrics
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Quitting Safety Designer
When you have finished working in the Safety Designer workbench, you can exit it.

To exit the Safety Designer workbench, you can either:

• Select File > Quit.
• Press Ctrl+Q.

If models have been modified, a confirmation dialog box appears.

Figure 105: Saving modified models
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Interface Description
This section describes the menu and toolbar commands that are specific to the Safety Design workbench.

Safety Designer Menu Bar on page 133

Toolbars on page 137

Safety Designer Menu Bar
This section describes the menu bar that is visible at the top of Safety Designer.
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File Menu

New...

Creates new package, class, component, system, equipment, type,

operator

See Creating a New Model Class on page 20, Creating a Type on

page 91 and Creating a New Operator on page 87

Properties

Views properties of the current model

Save

Saves the models in the database

Save as

Renames and saves the current model

Close

Closes the current model

Freeze

Freezes the current model. See Freezing a Model Class on page 30

Export

Exports the model. See Exporting on page 107

Add to export

Adds the current model to the export. See Exporting on page 107

Import

Imports the models to the current workspace.

See Importing on page 108

Print Setup

See Setting Page Layout on page 103

Docbook Export

Exports models to DocBook format. See Appendix Docbook Export

Print

Prints the model. See Printing a Model on page 104

Switch Workspace

Changes the workspace.

See Switching to another Workspace on page 12

Administration

See Administration Dialog box on page 154

Quit
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Exits the application. See Quitting Safety Designer on page 132

Edit Menu

Cancel move

Removes last action

Cut

Cuts the selected objects

Copy

Copies the select objects

Paste

Pastes the selected objects

Search

Searches for a model, see Searching for a Model on page 101

Select All

Selects all objects in the diagram

Tools Menu

Initial states

Defines initial values for state variables

Simulation

Launches model simulation, see Appendix Simulation

Complile

Compiles to Java

Plug-ins Manager

Opens Plug-in Manager, see Managing Plugins on page 111

Task Manager

Opens Task Manager

Check syntax...

Check model syntax, see Check AltaRica code Syntax on page 63

Check properties...

Check model properties, see Check AltaRica code Semantics on page

63

Statistics…

Views model properties: number of classes, instances, links, events,

variables, etc.
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Translate model...

Translates model into other formalisms, see Appendix Translators

Fault Tree Compiler...

Compiles AltaRica model to a Fault Tree, see Appendix Fault Tree

Compiler(ABC)

Sequence generator...

Generates sequences of critical events from AltaRica models, see

Appendix Sequence Generator

Help to FMEA generartion...

Generates a FMEA from AltaRica model, see Appendix FMEA

generation

Other

See Tools > Other on page 136

Tools > Other

Tool MinCuts => Aralia

Generates minimal cutsets with Aralia from AltaRica models. You

should have Aralia Fault Tree Analyzer to be able to use this plugin,

see Appendix FT9 binding

MCS diff utility

Compares minimal cutsets, see Appendix Utilities

Temporel propagation…

Launches Temporal propagation plugin, see Appendix Sequence

Generator

Diff of FMEA generation…

Compares FMEA

Sequences verification…

Replays the generated sequences, see Appendix Sequence Generator

Safety Designer User Guide136



Views Menu

Colors

Defines link colors during simulation, see Setting Link colors on

page 99

Attribute manager

Defines and manage attributes, see Appendix Attributes and Named

Parameters

Named parameters Manager

Defines and manages named parameters, see Appendix Attributes

and Named Parameters

Images...

See Managing Icon Library on page 66

Preferences...

See Setting Preferences on page 123

Help Menu

About

Views software information

Toolbars
The Safety Designer workbench includes specific icon toolbars.

Standard Toolbar

New

File

See

Working

with

System

Models

on

page

74
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Save

Saves

the

current

model

Print

See

Printing

a

Model

on

page

104

Edition Toolbar

Cut

Cuts

the

selected

objects

Copy

Copies

the

selected

objects

Paste

Pastes

the

selected

objects

Find

See

Searching

for

a

Model

on

page

101
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Undo

Removes

the

last

action

Navigation Toolbar

Zoom

out

Zoom

in

Define

zoom

value

Up

Goes

up

in

the

model

hierarchy

Down

Goes

down

in

the

model

hierarchy

Down

in

Another

View

Switches

the

model

view

Simulation Toolbar
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Save

Saves

current

state

as

initial

state,

see

Appendix

Simulation

Initialize

Goes

back

to

the

initial

state,

see

Appendix

Simulation

Step

backward

Removes

the

last

event,

see

Appendix

Simulation

Stop

simulation

Stops

the

simulation,

see

Appendix

Simulation

Start

simulation

Starts

the

simulation,

see

Appendix

Simulation
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Step

forward

Triggers

the

last

undone

event,

see

Appendix

Simulation

Go

next

See

Appendix

Simulation

Debug

information

window

Opens

the

debug

information

window,

see

Appendix

Simulation

Event

selection

Opens

the

Event

selection

window,

see

Appendix

Simulation

Modify

a

state

value

Modifies

the

value

of

a

state

variable,

see
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Simulation

Data Toolbar

Attribute

manager

Opens

the

Attribute

manager

dialog

box

Named

parameter

manager

Opens

Named

parameter

manager

dialog

box

Design Toolbar

Vertical

mirror

Moves

the

selected

object

using

vertical

mirror

Horizontal

mirror

Moves

the

selected

object

using

horizontal

mirror
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Rotate

90

deg

Rotate

the

selected

object

Alignment Toolbar

Left

Aligns

the

selected

objects

to

left

,

see

Align

the

Elements

on

page

41

Right

Aligns

the

selected

objects

to

right,

see

Align

the

Elements

on

page

41

Top

Align

the

selected

objects

to

right,
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see

Align

the

Elements

on

page

41

Bottom

Aligns

the

selected

objects

to

bottom,

see

Align

the

Elements

on

page

41

Vertical

Aligns

the

selected

objects

vertically

,

see

Align

the

Elements

on

page

41

Horizontal

Aligns

the

selected

objects

horizontally,

see

Align

the

Elements

on

page

41
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Center

Aligns

the

selected

objects

to

center,see

Align

the

Elements

on

page

41

Link Style Toolbar

Direct

See

Editing

Link

Route

on

page

50

Right

angle

See

Create

links

using

Predefined

Link

Routes

on

page

50

Right

angle

See

Create

links

using

Predefined

Link

Routes

on
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page

50

Right

angle

from

right

to

bottom

See

Create

links

using

Predefined

Link

Routes

on

page

50

Right

angle

from

left

to

bottom

See

Create

links

using

Predefined

Link

Routes

on

page

50

Right

angle

from

right

to

top

See

Create

links

using

Predefined

Link

Routes

on
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page

50

Right

angle

from

left

to

top

See

Create

links

using

Predefined

Link

Routes

on

page

50

Do

not

display

direction

See

Editing

Link

Route

on

page

50

Display

direction

See

Editing

Link

Route

on

page

50

Single

line

See

Editing

Link

Route

on

page

50
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Multiple

line

See

Editing

Link

Route

on

page

50
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Appendix
This section contains the reference information.

AltaRica Language Specification on page 149

User Management on page 154

Probability Laws in Aralia Format on page 167

AltaRica Language Specification
This section describes AltaRica language specification.

Lexical considerations on page 149

Expressions on page 150

Transitions on page 152

Assertions on page 153

Lexical considerations
This section describes about the various lexical considerations.

With the trans clause of an AltaRica node, one can describe how a model react when a particular event occur, in
terms of a transition from one state to another. With the assert clause, one can describe how the output flow variables
are computed in function of the values of state variables and/or input flow variables.

Whitespaces

Blank characters (spaces, tabulation, etc.) and comments are ignored by the compiler. They can be used to make
a program more readable but do not modify the semantics of the model.

Comments

Two types of comments are available in AltaRica: long comments, and short ones.

• Long comments

The /* character sequence opens a long comment; it must be terminated by the */ character sequence. Long
comments cannot be nested.

/*
  This is a long comment
  ********
  on several lines.
*/

• Short comments

The // character sequence indicates the start of a one-line, short comment; it is delimited by the end of the line.

// This is a comment on one line.
// This is another one.
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Identifiers

An identifier is a made of uppercase and lowercase alphabetical letters, digits and ‘_’, and cannot start by a
number. Identifiers are case sensitive.

my_motor
my_Motor
valve_9

Qualified names are used to access elements of hierarchies; they are made of
identifiers separated by dots “.”:

block_1.p.v

Qualified names

Keywords

The following words are reserved words and have a specific meaning; they cannot be used as identifiers:

submaximplyelseand

syncminineventassert

termnodeinitexternbool

thennotintfalsecase

transorinversefloatcnuf

trueoutknilflowconst

#privatelinkfuncdomain

statelocalifedon

Literal constants

true and false are the two Boolean constants.Boolean literals

Members of enumerations are enumeration literals; they can be used as
constants, and cannot be used to identify anything else (flow or state variable,
event, etc).

Enumeration literals

Integers are written as sequences of digits, which cannot start by 0, except 0
itself.

0
42
2097

Integers literals

Expressions
This section presents the syntax of AltaRica expressions, which may appear in assertion and transition clauses.

The expressions below are presented in decreasing priority order (The logic OR is the lowest order priority).

Parenthesized Expressions

In order to facilitate interpretation of the expressions If-Then-Else and If-Then, the latter must be mandatory
between parentheses.

parenthesized-expression ::=
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“(” expression “)”
| “(” expression ? expression : expression “)”
| “(” “if” expression “then” expression [ “else” expression ] “)”

For an If-Then-Else expression, the first sub-expression is mandatory boolean; it is called the operation condition.
The two next sub-expressions make up the parts Then and Else of If-Then-Else.

Note:

• The expressions authorized in the parts Then and Else are the same as those authorized at the first level
of an assertion.

• ( if expression then expression else expression ) and ( expression ? expression : expression ) are equivalent.

Atomic Expressions

Atomic expressions are either pathnames to variables or constants or parenthesized expressions.

Depending on the context, a path can be interpreted as a variable identifier or an enumeration member or also a
declared constant identifier. In these conditions, a same identifier cannot be used for a declared constant, a
variable or an enumerate constant.

atomic-expression ::=
  parenthesized-expression
| hierarchy-path
| true
| false

Unary Operators

The unary operations are evaluated from right to left.

unary-expression ::=
  (“not” | “~”) unary-expression
| atomic-expression

The NOT operator has two identifiers, the not word or the tilde ~. The NOT operand must be of the boolean
type and the result of the expression is the inverted value of this operand.

Relational Operators

The relational operators are evaluated from left to right. Their operands must be of an arithmetic type because,
unlike some programming languages, neither the enumerate constants nor the boolean variables, are assimilated
to integers.

The operators < (less than), > (greater than), <= (less or equal to) and >= (greater or equal to) give the value
false if the given relation is not satisfied by the operands; otherwise, the value of the expression is true.

relational-expression ::=
  relational-expression < additive-expression
| relational-expression > additive-expression
| relational-expression <= additive-expression
| relational-expression >= additive-expression
| additive-expression

Equality Operators

These operators are = (equal to) and != (not equal to).
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The operands of the = and != operators are boolean, arithmetic or enumerate. The value of these expressions is
true if the expressed relation is satisfied by the values of the operands and false in the contrary. In the boolean
case, the equality corresponds to the equivalence between the operands and the difference with the Exclusive or
(XOR).

equality-expression ::=
  relational-expression = relational-expression
| relational-expression != relational-expression
| relational-expression

Logic AND Operator

The logic AND operator has two identifiers: & and and. Its operands must be of the boolean type. It is evaluated
from left to right. It is true if its two operands are true and otherwise it is false.

and-expression ::=
  and-expression ( “and” | “&” ) equality_expression
| equality-expression

Logic OR Operator

The logic OR operator has two identifiers: | or or. Its operands must be of the boolean type. It is evaluated from
left to right. It is false if its two operands are false and otherwise it is true.

or-expression ::=
  or-expression (“or” | “|” ) and-expression
| and-expression

Transitions
Transitions allow evolution of the state variables of components. Transitions are guarded by Boolean expressions;
when the guard is evaluated to true, the transition may be fired. It is effectively fired when an associated,
probabilistic event occurs.

The declaration of a model transitions starts with the trans keyword. This keyword is followed by a non-empty
list of transition specifications separated by semi-colons. The transitions declaration may eventually end by a
semi-colon.

transitions-definitions ::=
  “trans” transition { “;” transition }

A transition specification always starts with a boolean expression called the transition condition. The variables
which appear in these expressions are the model flow variables or state variables.

transition ::=
  boolean-expression transition-target { “;” transition-target }

The transition condition is then followed by a non-empty list of actions associated to events.

An action starts by the separator |- followed by a non-empty list of events previously declared in the model.

The list ends with the -> separator followed by an assignment list for the variables.

transition-target ::=
  “|-” event-name-list “->” assignment { “,” assignments }

Assignments of variables are separated by commas (,).
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An assignment consists in an identifier, typically the name of a state variable, followed by the assignment operator
:=, followed by an expression of the same type as the state variable. The expression assigned to the state variable
can contain flow variables and state variables.

assignment ::=
  variable-name “:=” expression

Example 1

trans
state = ok |- fail -> state := failed;

Example 2

trans
  state = not_distributed |- fail_locally -> state := failed;

  state = not_distributed |- fail_locally_untimely -> state 
:= unstable;

Example 3

trans
state = open and blocked = no
    |- unexpected_close -> state := closed, blocked := yes;
state = closed and blocked = no
    |- unexpected_open -> etat := open, blocked := yes;

Assertions
The computation of output flow-variables is described in assertion clauses.

Assertion clauses starts with the assert keyword. This keyword is followed by a non-empty list of Boolean
expressions separated by semi-colons (;). The declaration may eventually end with one semi-colon.

assertions-definition ::=
“assert” assertion { “;” assertion}

assertion ::=
  boolean-expression

The variables which appear in an assertion are the flow variable or state variables of the model in which the
assertion is defined.

Boolean expressions authorized at the first level in an assertion are the following:

• The parenthesized expressions such as if then else
• The assignments of the variables

An assignment is composed of the identifier of an output flow variable (out) for the model followed by the
separator = and ends with an expression of the same type as the flow variable. The expression assigned to the
flow variable can contain constants and input flow variables (in) or state variables for the model.

Example 1

assert
  (if state = ok and
      (true = (e_v1 and e_v2) or (e_v1 and e_v3) or (e_v1 and
 e_v4) or
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              (e_v1 and e_v5) or (e_v2 and e_v3) or (e_v2 and
 e_v4) or
              (e_v2 and e_v5) or (e_v3 and e_v4) or (e_v3 and
 e_v5) or
              (e_v4 and e_v5)) then
     s = true, validity = true);

Example 2

assert
 (if state = not_distributed or state = distributed then 
   (if e1 = normal or e2 = normal then 
s = normal
     else 
       (if (e1 = untimely) or (e2 = untimely) then 
          s = untimely 
else 
          s = absent
       )
    )
  );

Example 3

assert
  (if (right_engine_failure and (~auto_right_flag or 
~oversupply_left)) or
      (left_engine_failure and (~auto_left_flag or 
~oversupply_right)) then
     s = true
   else
     s = false);

  (if state=out_of_order then
     s = false, validity = false);

User Management
This section describes the user management tab.

Administration Dialog box on page 154

User Management on page 155

Workgroup Management on page 158

Printing Administration Information on page 160

Managing Permissions on page 161

Administration Dialog box
The User administration dialog box is available only for the administrator user or any user having administrator
rights.

Each administrator can manage access rights for users:
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• New user creation,
• Definition of user profile (user, administrator),
• Creation of User group.

Access on data (components, equipments, types, systems, operators) depends on user rights.

You can select File > Administration to open the administration console.

User Management
You can customize the setting of the User tab.

The User management is available through the Users tab in User administration dialog box.

Figure 106: Users administration dialog box > User tab

To create a new user:

1. Select Users or Administrators in the left part of the dialog box.
2. Click the New button.
3. In the User box, enter the logging name of the new user.
4. In the Password box, choose a password for the new user.
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5. In the Name box, enter a user name.
6. Select the Administrator box to allow this user to access user administration functions (Administrator

privileges).
7. Click Validate to validate creation of the new user profile, or Cancel to cancel the creation of this profile.

When the user is created, he is inserted in the Administration tree structure, either in the Users list as a
common user, or in Administrators list if he benefits of administrator privileges.

Figure 107: Creation of a new user

To modify an existing user:

1. In the Users or Administrators list, select the user to modify.
2. Click Modify.
3. Make all the necessary adjustments on user profile (User, password, name, rights).
4. Click Validate to validate the modifications, or Cancel to cancel modifications on this profile.

To remove an existing user:

1. In the Users or Administrators list, select the user to be removed.
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2. Click Remove.

The following dialog box appears:

Figure 108: Message for removing a user

3. Click Yes to delete the user profile or No to cancel the destruction.
4. If the removed user is the owner of object (models, systems, etc …), the administrator must specify the user

who will be the new owner of this object. During removal, a dialog box asks the Administrator for the new
owner.

Figure 109: New Owner

Important:  Only the Master Administrator profile created during the initialization of database (Access©,
Oracle©) cannot be deleted.
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Workgroup Management
You can customize the work group in the Group tab.

The user workgroup management is available through the Groups tab from the User administration dialog
box.

Figure 110: Users administration dialog box > Tab Groups

To create a new workgroup:

1. Click the New button.
2. In the Group name box, enter a group name.
3.

In the Users tab, select the users one by one belonging to this group. You can use the  arrow to move on
the left list.

4. In the Comment box, enter a comment for this group if required.
5. Click the Validate button to validate the creation of this group, or the Cancel button to cancel the creation.

When the group is created, it is displayed in the Groups list.
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Figure 111: Users group creation

To modify an existing group:

1. In the Groups list, select the group to modify.
2. Click Modify.
3. Make the required adjustments on this group. To remove a user, select in Users area the user in the left list

and use the  arrow to move it in right list. To add a user, proceed as described for the creation of a group.
4. Click Validate to validate the modifications, or Cancel to cancel the modification on this group.

To delete an existing group:

1. In the Groups list, select the group to be deleted.
2. Click Remove.

The following dialog box appears.
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Figure 112: Message of the user group destruction

3. Click Yes to valid, or No to cancel the deleting of this group.

Only empty groups can be deleted.

Important:  Only the Master Administrator profile created during the initialization of database (Access©,
Oracle©) cannot be deleted.

Printing Administration Information
You can print the information.

The administrator can print information contained in the Administration database by clicking Print from the
User administration dialog box:

• The user list,
• The workgroups.
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Figure 113: Printing Administration information

Managing Permissions
Safety Designer allows the access right management on data (generic models in library and System architectures)
by dependencies and visibility attributes defined on each object.

Dependencies

Any object, generic model in library or system architecture, owns to the user who created it. If this user belongs
to several Workgroups, this one must specify during the creation of an object, the Workgroup to which this
object must be linked.

Only the administrator of database or the owner of a given object can modify the dependencies by using the
property window.
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Figure 114: Editor of Properties – Dependencies tab

You can modify the owner of an object:

1. Select an object (model or system) in the tree.
2. Start the Property Editor by selecting File / Properties menu or with contextual menu.
3. Click the Dependencies tab.
4. In the Owner area, select the user who must be the new owner of this object.
5. If the new owner of this object belongs to several workgroups.
6. In the Group area, select the workgroup to which this object must be linked

Moreover, if the object is a project or a package, user can specify if the rights must be propagated to each included
object with Apply to included objects….
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Figure 115: Apply Dependencies to included objects

Access Rights (Attributes)

During the creation of an object, the default access rights are:

• Read Access Right for users of the workgroup to which this object is linked (only the owner of this object has
an Read/Write Access Right).

• No access for users of the other workgroups.

Only the administrator of a database or the owner of a given object can modify its attributes of access rights by
using the property editor.

To modify the access rights to a n object for workgroups:

1. Select the object.
2. Open the property editor by clicking Properties in File menu.
3. Click the Attribute tab.
4. In the Group access area, choose in the popup menu the new access rights for the workgroup to which this

object is linked.
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5. In the Other access area, choose in the popup menu the new access rights for the other workgroups.

Figure 116: Property edition - Attribute

If you edit a Project or a Package of Models, you can specify if the rights must be applied to all included elements
by clicking on Apply to included objects.
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Figure 117: Apply change to included Objects

Visibility Definition

The Visibility tab in Properties editor allows user to specify access rights to the object. Object (generic models
in library and system architectures) for each workgroup defined in the administration module (See Administration
Window). The access rights defined by default in the Visibilities tab are defined in the Attribute/Dependencies
tabs.

Only the administrator of database or the owner of a given object can modify attributes of access rights in the
property editor.

To modify the access rights to an object for a workgroup:

1. Select the object (model or architecture).
2. In the File Menu, click Properties to launch the Editor of properties.
3. Click the Visibilities tab.
4. In the Access Right area for this workgroup, select in the popup menu the new access rights for this workgroup

(no access, read only, read/write).
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Figure 118: Properties edition - Visibilities

If you edit a Project or a Package of Models, you can specify if the visibilities must be applied to all included

elements by clicking .

Configuration Definition Example

The following figure displays:

• Users with their rights
• User Groups
• Model families and attributes (dependencies, rights, visibilities)
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Figure 119: Rights, Dependencies, Visibilities

The definition of PACKAGE_B attributes associated with this configuration, are shown in the figure below:

Figure 120: Example: PACKAGE_B

Probability Laws in Aralia Format
This section contains the list of all probability laws in Aralia format.

Probability laws for Basic Events

LimitsDefinitionPar.ExpressionLaw

0 <= Probability <=1Failure probabilityqA(t)=qconstant
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Probability laws for Basic Events

LimitsDefinitionPar.ExpressionLaw

Rate >= 0Failure rate A(t)=1-e- .texponential

0 <= Probability <=1
Probability of initial start-up
refusal

 
A(t)= .e-( +μ).t + ( /( +μ)).e-( +μ).tGLM

Rate >= 0
Failure rate

 

 

Rate >= 0
Repair rate

μ

Rate >= 0
Failure rate

 A(t)= 1-e .e-( +μ).t + ( /( +μ)).e-( +μ).tGLM-asymptotic

Rate >= 0
Repair rate

μ

Factor > 0
Scale parameter

 A(t)= 1-e- (t)  with  (t)=((t- )/ ) Weibull

Factor > 0
Form parameter

 

Time > 0
Location parameter (    0 as
t-  must always be greater
than 0)

 

Rate >= 0Failure rate of the component
in operation or on stand-by

 A(t)={1- e- .t if t <=  

A(t)={1- e- .((t- )/ ) if t >  

periodic-test

Time > 0 

Time > 0First interval between tests 

rate >= 0Functioning failure rate Numeric integrationperiodic-test-2

rate >= 0Failure rate during test *

rate >= 0Repair rate (once failure is
detected)

μ

Time >= 0First interval between tests 

Time >= 0Interval between two tests 

0 <= Probability <= 1Failure probability because
of test ( 0 if test can’t create
failure)

 

Time >= 0Test duration 

0 or 1Availability during test (0 if
unavailable; 1 if available)

X

0 <= Probability <= 1Test coverage rate (the
probability that test detect
failure)

 

0 <= Probability <= 1reSetUp forgetfulness
probability (after test and
after repair)

 

Rate >= 0Failure rate dormant

Time >= 0Medium time to repairMTTR

Time >= 0interval between two
consecutive tests

T

Rate >= 0Failure rate A(t)=Q+1-e- .TCMT
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Probability laws for Basic Events

LimitsDefinitionPar.ExpressionLaw

Time >= 0Mission durationT

0 <= Probability <= 1ProbabilityQ

Rate >= 0Repair rateμA(t)=e-μ.dNRD

Time >= 0Delayd
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Safety Designer Glossary
This section introduces you to the concepts to understand the terms in Safety Designer.

AltaRica code allowing variation of the output flow variables of components.assert

Base is made up of three directories (icons, models and project) and contains all
the systems, equipment, components, operators and types of the tool library.

base

An identifier previously declared in an enumeration field.constant of an enumerated
type

An enumerated type consists of a single variable which can take several values,
e.g. power supply: {null, nominal}.

enumerated type

A hierarchical behavioral object which can be represented graphically. It is an
equipment type model.

equipment

A component input or output variable.flow variable

A string of characters containing letters (uppercase or lowercase), numbers or
underscore character (_). The string must start with a letter.

identifier

An integer constant is either zero or a string of numbers which do not start with
zero.

integer constant

Identifiers, keywords, integer constants, operators and separators in the AltaRica
code.

Lexemes

Package enables classification of models in the library.package

AltaRica code which enables evolution of the state variables of components.
transitions

A variable identifying a component internal state, e.g. a variable with the
following values “open/blocked”.

state variable

Structured type constitutes many variables and each variable can have many
values, for example voltage :{ null, nominal} and short-cut :{ yes, no}.

structured type

A link which is not displayed in the hardware architecture. It represents only
flow assignments and do not use operators, e.g., cst1.e = true.

system assertion
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