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Overview

Welcome to the 3D Insight User's Guide ! 
This guide is intended for users who need to become quickly familiar with the product. 

This overview provides the following information: 

●     3D Insight in a Nutshell 

●     Before Reading this Guide 

●     Getting the Most Out of this Guide 

●     Accessing Sample Documents 

●     Conventions Used in this Guide 

3D Insight in a Nutshell
3D Insight product is especially dedicated to collaborators who need to access and use the 3D product definition. It 
provides review capabilities (including 3D tolerancing and annotations review) and allows performing a precise analysis of 
the geometric product definition. 3D Insight does not allow to save and export the created/modified data in order to 
prevent any change of the 3D product definition.

3D Insight allows exact sectioning, exact measurement, sketch examination, construction and additional geometry creation 
for analysis, 3D Functional Tolerancing & Annotation (FTA) and 2D Layout for 3D Design (LO1) data review mark-up 
without the capability to save the created data and to export. It also allows performing geometric analysis of the product in 
context of the manufacturing/assembly/inspection tooling context.

Before Reading this Guide
Prior to reading the 3D Insight User's Guide, you are recommended to have a look at the Infrastructure User's Guide 
for information on the generic capabilities common to all products.

The present "3D Insight User's Guide" details and documents, in the "User Tasks" section, the scope of 3D Insight 
functionalities and features which are contractually part of the 3D Insight license to use. You acknowledge and agree 
that your license to use 3D Insight software product is strictly limited to the functionalities as documented in this 
User's Guide. Therefore, in the case, you might technically access to other functionalities and/or capabilities of 3D 
Insight software product than those documented in this User's Guide, you cannot pretend to any license to use right
(s) on such functionality and/or capability including, any right on Correction(s) and/or Release(s).

Getting the Most Out of this Guide
To make the most out of this book, we suggest that you start reading and performing the step-by-step scenarios 
described in the User Tasks. They give a quick description of the operating mode of the various actions.

Accessing Sample Documents
To perform the scenarios, sample documents are provided all along this documentation. For more information about this, 
refer to Accessing Sample Documents in the Infrastructure User's Guide.
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What's New?

3D Insight is a new product.
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User Tasks

The User Tasks section explains and illustrates how to create various kinds of features. 
The table below lists the information you will find.

Product Structure 
Interactive Drafting 

IGES and STEP Interfaces 
DMU Navigator, DMU Dimensioning and Tolerancing Review 

Wireframe and Surface 
V4 Integration
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Product Structure

3D Insight offers a subset of Product Structure product without the capability to save the created data.  
The table below lists the information you will find.

Entering the Product Structure Workbench 
About Modified Status When Editing a CATProduct 

Selecting Products Only 
Selection Modes 

Inserting a New Component 
Inserting a New Part 

Inserting a New Product 
Inserting Existing Components 

Inserting CATPart or CATProduct Documents From a Catalog 
Loading Components 

Unloading Components 
Using The Selective Load 

Setting Up The Design Mode 
Setting Up The Visualization Mode 
Deactivating / Activating a Node 

Deactivating / Activating a Terminal Node 
Managing Representations 

Reordering the Tree 
Isolating a Part 

Deactivating / Activating a Component 
Defining Contextual Links 

Using Flexible Sub-Products 
Moving the Components of a Sub-Product in the Parent Product 

Applying Overload Position on Reference During "Rigidification" Command 
Reusing Your Product Structure 

Replacing a Component 
Editing Components 

Modifying Component Properties 
Managing Graphic Properties in Products 

Naming or Renaming a product 
Generating Numbering 

Displaying the Bill of Material (BOM) 
Managing the Bill of Material (BOM) 

Capability Not To Take into Account A Component in BOM Extraction 
Searching on BOM Attributes 

Managing a Resource thanks to Resource Modeler
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Entering the Product Structure Workbench

This task shows you how to:
●     enter the Product Structure Workbench

●     create a new document

●     open an existing one with a Progress Bar activated by default.

 

Entering the Product Structure Workbench

Select Infrastructure > Product Structure from the Start menu.

The Product Structure workbench is displayed and a document like this appears:

Note that more toolbars may appear next to the Standard toolbar when you create a document.

For more information about this CATIA window, please refer to Workbench Description.
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Creating a New Document

 
1.  Select New from the File menu and a New dialog box is displayed:

2.  Select a type of document (Product for instance) in the list and click OK. A new CATProduct appears:
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Opening an Existing Document: a Progress Bar Appears

This task includes opening of a CATProduct step by step with a progress bar and giving the number of the 
activated shapes out of the total shapes.

With the progress bar, you can get an insight in the objects' downloading time, and in the meantime the screen 
is not frozen. This operation is activated by default (there is no setting).

Open the AnalyzingAssembly01.CATProduct document.
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1.  While the CATProduct is opening, there is a progress bar indicating the total shapes downloaded and to 

be opened. In this example, 4/6 means 4 shapes have been downloaded out of 6.

2.  When this dialog box disappears, the whole geometry (assembly) and the specification tree are 

displayed.

3.  When you insert an existing component, the same method is followed. The progress bar also appears 

during the downloading process.
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About Modified Status When Editing a CATProduct

This task shows you what can be described in the Save Management window according to the manipulation made on the Product (opening / 
inserting / creating / editing a Part / Product / Component, etc). 
This description on the Save Management also depends on the element that is UI active and on the propagation "parent / son" of the modifications.

This task is divided into 3 sections:

●     Modifying a Part' s Geometry,

●     Modifying several Parts' Geometry,

●     Moving Elements in the Assembly with the Compass,

●     Limitations.

The active object defines the design context: this objects and all its "sons" will appear as "modified" in the Save Management dialog box. This design 
context contains all the documents on which the user has write permission.

 

Modifying a Part' s Geometry
1.  Open a CATProduct with this arborescence:

●     Product1

�❍     Part1

The initial state in the Save Management window is:

2.  Modify the Part's geometry. For instance, add a hole in the pad:

You can compare the different results in the Save Management window, before and after R14:

Before R14:

After modifying the CATPart' s geometry: both Product1 and Part1 were seen as "modified" in the Save Management window.
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From R14:

After modifying the CATPart' s geometry: only Part1 is seen as "modified" in the Save Management window. 
Now you can save one Part after the other and independently from each other.

 

 

Modifying Several Parts' Geometry
1.  Open a CATProduct with this arborescence:

●     Product1

�❍     Product2

■     Part1

■     Part2.

The initial state in the Save Management window is as follows (before any modification: all components are "opened". Part1 is UI active.):

2.  Modify the Parts' geometry, for instance:
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After modifying the CATPart' s geometry, Part1 and Part2 are seen as "modified" in the Save Management window.

This behavior allows you to save time while saving your modifications because the "parent" elements are not impacted by the changes made on the Part. 
Only Part1 and Part2 need to be saved. 
The documents can be saved one after the other and independently. It means that you can save only Part1 or Part2, if you want. 
Moreover, if the user does not have write permission on Product1 and 2, he still can modify Part1 and Part2.

 

 

Moving Elements in the Assembly with the Compass

1.  Open a CATProduct with this arborescence:

●     Product1

�❍     Product2

■     Part1

2.  Set Product2 as UI active.

3.  Move Part1 with the compass.

Before any modification: all components 
are "opened". Product2 is UI active.

After moving the CATPart: only Product2 is seen as "modified" in the Save 
Management window.

Product2 is seen as "modified" because Part1 is moved according to the context of Product2. 
The behavior allows you to save time while saving your modifications because the "parent" elements are not impacted by the changes made on Product2. 
Only Product2 needs to be saved. 
Moreover, if you do not have written permission on Product1, you still can modify Product2.

 

Limitations:
 The common behavior is: the information (edition) is not moved to the upper levels. It means that the modification is limited to the Part's level.

But there are particular cases when the information is propagated to the upper levels when the UI activated object is changed (Product2 instead of Part1 
for instance). There is an upward propagation of the "modified" status (from the "son" to the "parent" product). 
For instance: if the modified geometry of a CATPart remains non-updated, the edition information will be propagated to the newly selected object (in the 
upper levels).
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 Selecting Products Only 

This task explains how you can apply a "Filter on Products", which enables you to select Products only within a CATIA document.

This Filter lets you select one or several products in a complex architecture.

It remains active whatever other functionality, except DMU commands, you are using to transform the CATIA document. However, it is only useful for and 
used by the Select command. When switching to another workbench within the Product Structure workshop, the state of this filter will remain the same. 
This state is kept in memory when you exit the Product Structure workshop, and is retrieved when returning to it.

When the architecture of a CATProduct is complex, this functionality allows you to select a particular Product more easily, only by selecting one of its 
components in the geometry.
Open the Articulation.CATProduct document.

1.  Click on the Products Selection in the Filter toolbar:

When the icon is activated, it looks like this:

2.  Click on a component belonging to the CATProduct of your choice. As a result, the whole Product is selected:

Only the Product (and not its Children) is selected. You can use the other commands to modify the Product (Edit-Properties... or Insert a New 

Component) and go into another workbench without deactivating the Filter. However, if you open a new Product, the Filter will not be activated by 

default, because a new instance of the CATProduct document is made and it can have its own filter for the Select command.
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3.  Put your cursor on any component of the Product and you can immediately modify the Product's properties (Graphic Colors for instance):

In this case, you modify the Product's properties and not the sub-components' characteristics.

4.  In order to apply the filter on several Products at the same time, click on the Product Selection.

5.  Select a Product of your choice and Ctrl-click on other Products to add them to your selection.

This filter can be used in many different ways, like selecting a Product and an Edge from another Product. To do so, click on the Product Selection, then 
select the Product. Click again Product Selection. The Product is kept in the selection. Then Ctrl-click on other objects (like an Edge) to add them to 
your selection.
For more information about selecting rules, please refer to Selecting Objects in CATIA - Infrastructure User's Guide.
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Selection Modes    

This task explains you how you can alternatively select:
●     all the Instances except the one that you first selected (Inversion Mode),

●     or the "Children" (sub-products) of one or several Part Numbers within the Specification Tree (Children Mode),

●     or all elements, except "Children", other than those you had selected first.

●     or "All" the CATIA products (All Mode).

Open the 16cubes.CATProduct document:

 
Selection Mode: Inversion

Close 16cubes.CATProduct without saving and re-open it.
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1.  Right-click 4cubes (4 cubes.1).

2.  Activate the Selection Mode > Inversion contextual command.

The result is: All instances except 4cubes (4 cubes.1) are selected.
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Selection Mode: Children

Close 16cubes.CATProduct without saving and re-open it.

1.  Right-click 4cubes (4 cubes.1)

2.  Activate the Selection Mode > Children contextual command.
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The result is: 4cubes (4 cubes.1) and all its "children" (sub-products) are selected.
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Selection Mode: Others

Close 16cubes.CATProduct without saving and re-open it.

1.  Select the first and the third occurrence of 4cubes (4 cubes.1).
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2.  Right-click the first selected 4cubes (4 cubes.1).

3.  Select the contextual command: Selection Mode > Others.
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The result is: All nodes are selected (product and sub-products) except those that were previously 

selected.
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4.  Right-click the second occurrence of 4cubes (4 cubes.2) (automatically selected thanks to the Others command).

5.  Select the Representation > Deactivate Node contextual command.
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The result is: the second and the fourth occurrences of 4cubes are no longer in the geometry space.
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If you want to restore all the occurrences of 4cubes in the Geometry space, you need to select the 
root product 16cubes and click the Activate Terminal Node contextual command.

 

 
Selection Mode: All

1.  Right-click 4cubes (4 cubes.1).

2.  Select the contextual command: Selection Mode > All.
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The result is: All nodes are selected.
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Inserting a New Component 

This task shows you how to insert a component into an existing assembly.

This command lets you perform the following:

●     create an instance from the reference component

●     use a context-specific representation inside it (see Managing Representations).

Open the ManagingComponents01.CATProduct document.

In the specification tree, select ManagingComponents01 and click the New Component icon .

The structure of your assembly now includes Product1(Product1.1).

If you want you can define the default part number of the component to be imported. To see how this is done refer 
to Customizing Product Structure Settings.
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Inserting a New Part 

This task shows you how to insert a new part in an existing assembly.

Open the ManagingComponents01.CATProduct document.

1.  In the specification tree, select ManagingComponents01 and click the New Part icon .

If a geometry exists in the assembly, the New Part: Origin Point dialog box is displayed, proposing two 
options to locate the part: 

�❍     Click Yes to locate the part origin point on a selected point, on another component for example.

�❍     Click No to define the origin point of a component based on the origin point of the parent component.

 

2.  For this task, click No to locate the part origin based on the Product1 origin point. The Part (Part8.1) is 

created in the specification tree:
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To edit Part8 or any other sub-elements of the CATPart document, double-click on the required component 
in the specification tree and you will access the Part Design workbench. See CATIA - Part Design User's 
Guide V5 for more information.

Do not mistake the Product document for the Part Design document: 

�❍     The Product document is identified by the Product document icon .

�❍     The Part Design document is identified by the Part Design document icon .

 

If you want you can define the default part number of the part to be imported. To see how this is done refer to 
Customizing Product Structure Settings.
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Inserting a New Product 

This task shows you how to insert a product in an existing assembly.

Open the ManagingComponents01.CATProduct document.

In the specification tree, select ManagingComponents01 and click the Product  icon. A new product is created 

in the specification tree: Product2 (Product2.1) in our example.

If you want you can define the default part number of the product to be inserted. To see how this is done refer to 
Customizing Product Structure Settings.
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Inserting Existing Components 

This task shows you how to import one or more components into an existing assembly and how to: 
●     Manage Part Number conflicts when inserting a model,

●     Manage Part Number conflicts when inserting a part,

●     Insert Existing Component or Part Version from ENOVIA V5 

●     If you insert a read-only document (a Part for instance) in a product, the read-only flag of this new document is only valid during the current session.

●     If you save this product, close it and reopen it, the read-only information on this Part is not maintained.

Open the ManagingComponents02.CATProduct document.

1.  In the Specification Tree, select ManagingComponents02 and click the Existing Component  icon. The Insert an Existing Component dialog box 

is displayed.

2.  Select CRIC_TOP.CATPart from the C:\Program Files\Dassault Systemes\B04doc\online\pstug\samples directory and click Open. The CRIC_TOP (CRIC_TOP.1) 

is created in the Specification Tree and the Part is displayed in the Geometry area.

Depending on the CATIA license you have, you can insert components (with or without Representation) in a CATProduct:

●     CATPart (*.CATPart),

●     CATProduct (*.CATProduct),

●     V4 CATIA Assembly (*.asm),

●     CATAnalysis (*.CATAnalysis),

●     V4 session (*.session),

●     V4 model (*.model),

●     cgr (.cgr; no specific license is required),

●     wrl (.wrl; no specific license is required).

 Moreover, under a cgr file, you can insert a component (with or without Representation) such as Product, Part, Component, Model, cgr. For this, you need 
to right-click the cgr file and select Components > New Component / Product / Part or Components > Existing Components...

If the Part, Product, model or cgr you insert into an assembly has the same Part Number as the one contained in the assembly, the Part Number conflict 
dialog box appears.

For more information about inserting and saving a component with the same name as another one, please refer to these Infrastructure User's Guide chapters:

●     Document: in a file-based environment, a document is identified by its name and an internal identifier.

●     Saving Existing Documents: if both files have the same UUID (Unique Universal IDentifier), and if one of them is already open, you will not be able to open 
the other.

If you see this warning when inserting an existing document in an assembly:

This means that the current settings, "Linked Document Localization" in Tools > Options > General > Document, cannot allow the insertion of this document.

To make the insertion of the existing document possible, please modify these Document Location parameters (in Tools > Options > General > 
Document: Linked Document Localization) so that the next opening of the assembly effectively allows to find back the inserted document.
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For more information about these settings, please refer to Customizing > Customizing Settings > General > Document: Linked Document Localization 
in the CATIA - Infrastructure User's Guide.

Part Number Conflicts When Inserting a Model

1.  Open PartNumberConflict1.CATProduct.

2.  Insert CARBODY.model into PartNumberConflict.CATProduct. The following dialog box is displayed:

There is a Part Number conflict because the new component you insert will be in the same document as CARBODY.model (since the component Body1 is not 

a document). CARBODY.model is directly under PartNumberConflict1.CATProduct.

This Part number conflicts window provides information about:

●     the Part number generating the conflict: CARBODY

●     the path of the document generating the name conflict: C:\TEMP\CARBODY.model

●     the path of the selected source: C:\TEMP\CARBODY.model

●     the Source already existing inside the root product: E:\www\PstEnglish\pstug.doc\src\samples\PartNumberConflict1.CATProduct
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You have three solutions:

●     Rename...: click the Rename button and the following dialog box is displayed. You can enter a new Part Number. Click OK.

Click OK. In the Specification Tree, you can see PLANEBODY.model under PartNumberConflict.CATProduct:

With this Rename option, you create a new reference of CARBODY.model with another Part Number.

●     Reconnect... : click the Reconnect button to reconnect the two entities of CARBODY.model.
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Both entities (CARBODY.model) are overlapping in the geometry space. As a consequence, there is only one instance of CARBODY.model in the Basic View 
window.

●     Automatic rename... : click the Automatic Rename button to have the Part Number changed into CARBODY.1.model.
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For our second example, close PartNumberConflict1.CATProduct without saving.

1.  Reopen it.

2.  Insert CARBODY.model into Landing_Gear.CATProduct. There is no Part Number conflict because CARBODY's reference is different from the one of CARBODY 

in Body1. A new local reference has been created.
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For our third example, close PartNumberConflict1.CATProduct without saving.

1.  Reopen it.

2.  Insert CARBODY.model into Body1.CATProduct. There is a Part Number conflict because there is the same Part Number within the same document Body1.

 

Part Number Conflicts When Inserting a Part

1.  Open PartNumberConflict1.CATProduct.

2.  Insert Landing_Gear_Piston1.CATPart into PartNumberConflict.CATProduct. The following dialog box is displayed:

The conflict is due to the presence of the same Part Number (Piston) in Piston and Landing_Gear_Piston1. You can Rename (or use the Automatic Rename 
option) the new instance Landing_Gear_Piston1.

You have the same conflict if you insert Landing_Gear_Piston1.CATPart into PartNumberConflict1 or in Body1.

If you want to insert the exact copy of this Part, Piston, the following window will be displayed:

You are not allowed to open the same Part in the same document.

For more information, another functionality is available in the Assembly workbench: Inserting an Existing Components with Positioning, in the CATIA - 
Assembly User's Guide.

Insert Existing Component or Part Version from ENOVIA V5
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 The Insert Component command allows you to select a document or a part version stored in the database when the 
VPM Navigator is connected to ENOVIA. This also allows you to instantiate a stored stand alone Part Version.

To enable the ENOVIA selection in the Insert component command, follow the steps:

1.  Go to the Tools > Options > General > Document tab.
2.  Select the ENOVIA V5 VPM option and set it as Allowed. 

3.  To run the Insert command, right-click the Product node, go to Components > Existing Component. 
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4.  You can also run the command from Insert menu > Existing Component. 
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5.  By selecting the command, if you have not already connected to the database, the File Selection dialog is displayed. There is no modification of the 
previous behavior of the command. 

6.  You have connected to the database, the Document Chooser dialog box opens. You can define the source of the CATPart or CATProduct and especially 
the ENOVIA dialog box appears to allow you to query if the object, the file or another kind of sources is available.

7.  Select the source. In this case select ENOVIA. 
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Check if the selected object is an instance under an ENOVIA Document and also that the associated part version is not a CATPart. 
Alternatively, the error message “You cannot insert a component under the selected object” appears.

The standard VPM Navigator dialog appears to allow you run a query and select the document revision or a part version to insert.

 8.  Click Open. The document type is checked and an error message is displayed if the document type is not a CATPart or a CATProduct.

If the document is OK, the selected object is instantiated under the current object in the product specification tree.

 
Limitations
●     No filter is applied for the type of document when the Document option is selected in the result list. But when we exit the Document Chooser, verification 

is done and if the document is not a CATPart or a CATProduct, an error is displayed.

●     The Document Chooser dialog allowing to select a CATPart or a CATProduct stored in ENOVIA is available only if you are connected; it means that you have 
the VPM Navigator license and you are connected to the database).

●     The Part Version selection is only available in the context of the Insert command. In other locations where the Document Chooser is available, only 
the document selection is possible.

●     If the selected object is a Publications Exposed document, a Part Version without a CATPart or a CATProduct cannot be used.

●     When a component is inserted using Existing Component command, a new instance is created under the given product. This newly created instance is rigid 
by default even if its reference instance is flexible.
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Inserting CATPart or CATProduct Documents From a Catalog

This task shows you how to copy CATPart or CATProduct documents from a catalog into an existing assembly.

Open the ManagingComponents01.CATProduct document.

1.  Open a catalog, for example the ALL FASTENERS.catalog that you created in the scenario "Creating a Catalog" in CATIA - Component Catalog Editor User's 

Guide.

2.  Double-click the main chapter, All FASTENERS if the entities of this chapter do not appear in the left-hand part of the catalog navigator.

3.  Find the chapter containing the entity you want to copy into the assembly.

4.  Double-click on this chapter, SCREWS for example. The following results appear in the right part of the dialog box :

The entities contained in the selected chapter appear in the form of a table on the right side of the navigator:

Two default icons are used:

●     the folder icon  identifies a chapter,

●     the sheet + arrow icon   identifies a family in another catalog.
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5.  Click the Preview tab to visualize the listed entities:

6.  You can open an entity in either the Reference or Preview tab by clicking the contextual command: Open document. If you want you can now edit the 

entity just like any other V5 document.

Or:
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To narrow the selection criteria using the keywords you originally chose see "Querying a Catalog" in CATIA - Component Catalog Editor User's Guide.

5.  Click on the entity you wish to copy and either click the Copy icon  or select the Edit > Copy command.

6.  Select the appropriate target i.e. the main product item or any CATProduct document in the specification tree and retrieve the entity from the clipboard by 

clicking the Paste icon  or selecting the Edit > Paste command.
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Loading Components 

This task will show you how to load a component into an assembly.

Loading a component means putting its geometry in memory. 
You can only load CATPart and CATProduct documents in an assembly. For a model document, you must use the activate representation functionalities, 
see Managing Representations.

●     Before unloading an object, you need to UI activate the root product, otherwise this message appears: "Unload action is not processed because the root 
product is not UI activated". 
To UI activate the root product, double-click it and then select the object you want to unload. You will see that the root product becomes blue-highlighted in 
the specification tree.

●     In Cache mode, the Load operation applied upon a CATPart Instance in Visualization mode, turns this CATPart in Prod Mode, and not in Design mode. With 
this partial loading, the geometry is not loaded and the CGR is displayed in the 3D view.

Open the ManagingComponents01.CATProduct document. 
This task can only be completed successfully if you have just unloaded the components (see Unloading Components).

Select CRIC_BRANCH_3 (CRIC_BRANCH_3.1) in the specification tree or in the geometry and click the Load Components icon .

CRIC_BRANCH_3 (CRIC_BRANCH_3.1) is loaded. The link symbol disappears from the document icon in the specification tree. The geometry of the component 
is displayed.

  
This task will show you the status of objects after loading files.

Open Product1_Ball_Joint.CATProduct and create a new product, for instance Product2.CATProduct:
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1.  Copy / Paste Product1_Ball_Joint.CATProduct in Product2.CATProduct and close Product2.

2.  Insert an existing Part, Ball_Joint_Housing.CATPart, in Product1_Ball_Joint.CATProduct:

3.  In Tools > Options > General, uncheck the option: "Load Referenced Documents".

4.  Reopen Product2 and you can see the Unload symbol in the Product1_Ball_Joint node.

5.  Right-Click Product1_Ball_Joint and select the Components > Load functionality. Note that Product2_assembly.CATProduct has been updated with 
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the additional part:

6.  In the menu, select the File > Save Management functionality and you have the following result:

The status of the product is "modified" whereas they have only been opened. It is normal because after a save / close / open / load, the status of this 

document is "modified".

The activation state is generated on instance at opening time and not updated when the related first instance 
is loaded. No systematic upgrade is done due to performance issue.
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Unloading Components 

This task shows you how to unload a component from an assembly. Unloading a component means removing the document containing the Reference of 
the Instance.

A second section explains that if you unload a CATPart, then add an existing component that has the same Part Number as the unloaded component, and 
finally you reload this component, a Part Number conflict occurs.

●     Unloading Components

●     Managing Part Number conflicts on reload

You can only unload CATPart and CATProduct documents in an assembly. For a model document, you must use the deactivate representation functionalities, 
see Managing Representations.

Unloading a CATIA document and reloading the same document after several modifications in the CATProduct may lead to Part Number conflicts. This aspect 
is explained in the second section of this scenario: Managing Part Number conflicts after a Reload.
When a .model (*MASTER) is under a Component, you can select it and press the Unload icon .

●     If the Cache is ON and you open a CATPart, it is not loaded (in Visualization mode) but its geometry is visible in the 3D view. Reload it (in Design mode) 
and then you activate the Unload functionality on this CATPart. This is unloaded (in Visualization mode) and its geometry is visible, which means that it 
goes back to the initial state. 
With the Cache status as ON, performing Unload command on a CATPart Instance will in fact switch it back to Visualization mode. The following scenario 
will explain you the effects of this command.

●     Actions performed after unloading components cannot be undone. The history of actions is cleared and the Undo icon is grayed out.

●     An object that is UI-Activated, cannot be unloaded. The UI-Activated object cannot deleted itself (cannot unload itself), this is why an error message appears:

Unloading Components
Open the 4cubes.CATProduct document. 
You are in Visualization mode and the CATParts are unloaded (see Picture 1 below).
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1.  Select CUBE.1 [Cuve.CATPart] in the Specification Tree or in the geometry and click the Load icon . CUBE.CATPart is loaded and it is reflected on all 

its Instances (see Picture 2).

2.  Unload CUBE.1. This component and all these instances return into Visualization mode (see Picture 3).

Picture 1: CATParts are not loaded (Visualization Mode)

Picture 2: Loaded CATParts

Picture 3: CATParts are not loaded (visualization Mode), the Cache is not activated).
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If you did not select the Cache option, the geometry of the CATPart disappears and its icon indicates the unloaded status . Then, to reload the 

same CATPart, select it and click the Load icon. Therefore, the Part re-appears in the Geometry space and, in the Specification Tree, its icon changes into 
the loaded status: .

●     Unload command launches the same window as Desk (Point 8. in Using the FileDesk Workbench, in the Infrastructure User's Guide).

●     The unload operation does not modify the model of the product from which a component is unloaded. In particular, the unload operation is not a 
persistent feature. The unloaded component is removed from the session, but its root product still references it. 
After saving (using Save As... menu command ) a product with unloaded components, the next open (using Open... menu command) loads the 
components. The root product does not contain information about previous unloads.

 

 
Managing Part Number conflicts on reload

Open the ManagingComponents01.CATProduct document.

1.  Select CRIC_SCREW.1 (CRIC_SCREW.CATPart) in the Specification Tree or in the geometry and click the Unload icon . CRIC_SCREW.CATPart 

has disappeared in the Geometry space:

2.  Insert another CATPart having the same Part Number as the one of CRIC_SCREW.1 (CRIC_SCREW.CATPart), for instance: CRIC_SCREW2.CATPart: 

And you obtain:
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3.  Select CRIC_SCREW.1 (CRIC_SCREW.CATPart) and click the Load icon . A Part number conflicts window appears because CRIC_SCREW.CATPart 

and CRIC_SCREW2.CATPart have the same Part Number CRIC_SCREW:

The OK button is dimmed because the second instance of CRIC_SCREW has already been inserted in the CATProduct and now you need to 
rename one of the Parts in order to resolve the conflict.

4.  Click the Rename or Automatic rename button. The Part Number window is displayed and you can rename the CATPart. Then click OK:

5.  The conflict is resolved because CRIC_SCREW2.CATPart has been renamed. Click OK and the window will disappear:

And you can see that both instances of CRIC_SCREW are visible in the Specification Tree and in the Geometry:
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Using The Selective Load 

This task shows you how to load some components partially in an assembly.

Launching a Selective Load means loading its geometry into the system memory.

The difference with the previous functionality, Loading Components, is that Selective Load is more precise and more selective. You 
can choose to load only a CATPart and/or a CATProduct in an assembly. It can be applied only when the option Load referenced 
documents, in Tools > Options > General is deactivated.

See also next task Specifying the Depth Level when opening Product Structure.

1.  The option Load referenced documents in Tools > Options > General must be deselected:

2.  Open the AnalyzingAssembly02.CATProduct document.
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1.  CRIC_FRAME.1, CRIC_SCREW.1, CRIC_TOP.1 and Set.1 are unloaded. A symbol appears in the up right corner on the 

document icon in the specification tree to indicate an unloaded document . The elements' geometry disappears. 

If you find a zebra symbol on the CATPart icon , it means that the document's reference cannot be found.

2.  Then, select the element(s) you want to download. To visualize CRIC_FRAME.1 for instance, select this CATPart and click the 

Selective Load icon  in the Product Structure toolbar. The Product Load Management dialog box appears:

3.  In this dialog box, press the Selective Load button  and the name of the component appears in the Delayed 

actions list. Click OK.
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The CRIC_FRAME.1 is loaded. Its CATPart symbol  comes back in the Specification Tree and its geometry appears as 

shown below:

4.  You can do the same with Set.1. In the following screen shot, you can see that this Selective Load functionality can only be 

applied to one level, there is no incident on the element's children. CRIC_BRANCH_1, CRIC_BRANCH_3.1 and CRIC_JOIN_1 

are not loaded:
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As opposed to Selective Load, the Product Initialization option allows you to download CATIA components individually. In 
order to have CRIC_BRANCH_1, CRIC_BRANCH_3 and/or CRIC_JOIN downloaded, it is necessary to proceed with the 
Selective Load.

5.  If you want to download the sub-elements of Subset1 as well, you need to select the option all in the Open depth level:

And you obtain:
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When the Assembly is more complex, you can also decide to load the elements until the second level, in this case you 
select the Open depth level number 2.

●     By the same way the user can put the component in the SHOW / NO SHOW mode by clicking on the icons:  for SHOW and 

 for NO SHOW.

●     As it is explained at the beginning of this document, when the Load Referenced Documents option is not selected, the CATParts 
or CATProducts "sons" are not loaded. But when the Cache is also activated, you can visualize CGR documents; therefore, the 
opening of such documents is allowed.

●     Edit > Links... does not load visualization for CGR and other associated documents unlike the CATPart. CATPart is handled 
through product instance-reference link and hence its visualization is restored after loading through Edit > Links... or File > 
Desk.. > Load. 
For CGR and other associated documents dedicated commands are available (Activate/Deactivate Node or Manage 
Representations). For more information, see Managing Representations.
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Specifying The Depth Level When Opening Product Structure

Several options drive the behavior of CATIA V5 in terms of loading and presentation. 

A command (Product Load Management / Selective Loading) allows to manage progressive load of a Product. This task shows you how to expand 1, 2, all 
levels in that command.
First of all, you need to use the following settings configuration:
●     The option Load referenced documents in Tools > Options > General must be deselected. For more information, please refer to Customizing 

General Settings.

1.  Open 16cubes.CATProduct.

2.  Download the CATProduct's components by using the Selective Load command.

The Product Load Management dialog box is displayed:

3.  In the Specification Tree, select the component(s) you want to download.

4.  Choose a depth level in the list: 1 level, 2 levels or all levels.
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You can specify the expected open depth using the dedicated combo box. Only 1, 2 and All options are accessible. Multi-selection capacity 
is available too.

 

 
5.  Click the Load icon in the command dialog box in order to validate the selection. You can see the loading notification in the Delayed 

actions field:

6.  Click OK (or Apply if you want to continue using Selective Load) to load your documents.
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Setting Up The Design Mode 

This task shows you how to set up the Design mode for components in Product Structure context.

The Design Mode command changes the .cgr format of the component into the original editable component document. In other words, geometric data 
is available. This explains why most of the commands are available if Design Mode is activated.

You may wish to use the other edition mode referred to as the Visualization Mode.

●     Make sure that the Work with the cache system setting is activated in Tools > Options > Infrastructure > Product Structure > Cache 
Management. For more information, see Customizing Cache Setting.

●     Open the ManagingComponents01.CATProduct document.

1.  Select CRIC_AXIS.1.

2.  Then select either:

●     the command Edit > Representation > Visualization Mode in the file-menu.

●     or select Representations > Visualization Mode from the contextual menu

●     or click the icon Design Mode .
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According to the mode you have chosen, you can see differences in the Specification Tree:
●     Design mode:

 

 ●     Visualization mode:

 

Moving a CATPart document from Visualization Mode to Design Mode may lead to Part Number conflicts if you had already inserted another element with 
the same Part Number. For more information, please refer to Setting up the Visualization Mode: Managing Part number conflicts when moving a CATIA 
document into Design Mode.
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Setting Up The Visualization Mode 

This task shows you how to set up the Visualization mode for components in Product Structure context and how to manage Part Number conflicts when you 
shift to the Design Mode:

Setting up the Visualization Mode 
Back into Design Mode 
Managing Part Number conflicts when moving a CATIA document into Design Mode

The Visualization Mode uses documents in .cgr format. Only the external appearance of the component is visualized. The geometry is not available, which may 
be useful when you deal with sophisticated assemblies with large amounts of data but only need a few components to work on.

As only the external appearance is loaded and not its document, visualization mode is used to visualize the design. The Edit > Links functionality implies 
that the document is not loaded for any types of links.

To edit the design or propagate the modification to the linked documents, you need to use the editor mode referred to as design mode.

By using the Edit > Links functionality, in the Status column, you can see the "not loaded" status of:

●     the Instance link:

 

 ●     the Copy / Cut / Paste link:

 

 You may wish to use the other edition mode referred to as the Design Mode.
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●     In Visualization Mode, the  button appears at all nodes' level and tree extension is possible, which allows partial load from the graph.

●     To accelerate the graph loading, the  button is displayed every time a representation is associated to the document corresponding to the node, no 
difference is made between a product with an associated representation and a product containing a Part.

●     The "plus" status is updated when you click it. This means that you are allowing the partial loading of the graph only when you are in Visualization mode. 
If finally there is no children in the graph, for instance a document with an unloaded reference, "plus" status disappears:

●     The node's state is between Visualization Mode and Design Mode. If you click the node, the  disappears and square brackets [] are replaced by parenthesis.

●     Double-Click again the same node,  button reappears at its child node. By clicking on this button, the node expands and the product is set in Design Mode.
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Setting Up The Visualization Mode
●     Make sure that the Work with the cache system setting is activated in Tools > Options > Infrastructure > Product Structure > Cache 

Management. For more information, see Customizing Cache Setting.

●     Open the ManagingComponents01.CATProduct document. 
You can recognize that the CATProduct is in Visualization Mode because its components are written like this:  

  Instance Name [Document Name].

Back into Design Mode
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1.  Select CRIC_SCREW.1 [CRIC_SCREW.CATPart].

2.  Then select either:

●     the command Edit > Representation > Design Mode in the file-menu.

●     or select Representations > Design Mode from the contextual menu

●     or click the icon Design Mode .

If you do not click the root Product in order to make it active, the compass does not turn green when you move and place it on any part under the product 
and the part cannot be manipulated.

 
CRIC_SCREW.1 [CRIC_SCREW.CATPart] has turned into CRIC_SCREW (CRIC_SCREW.1) and the geometrical elements in CRIC_SCREW.1 

can be seen, and therefore selected, in the Specification Tree because its branches are now expandable:

You can reapply the Visualization mode by selecting the CRIC_AXIS.1 for instance and clicking the Visualization Mode icon .

According to the mode you have chosen, you can see differences in the Specification Tree:
●     Design mode:

 

 ●     Visualization mode:

 

Managing Part Number Conflicts When Moving a CATIA document into Design Mode
Moving a CATPart document from Visualization Mode to Design Mode may lead to Part Number conflicts if you had already inserted another element with 
the same Part Number. This task shows you that you can solve this problem by renaming one of the conflicting Parts.
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●     Make sure that the Work with the cache system setting is activated in Tools > Options > Infrastructure > Product Structure > Cache 
Management. For more information, see Customizing Cache Setting.*

●     Open the ManagingComponents01.CATProduct document.

1.  Select ManagingComponents01.

2.  Click the Insert Existing Component icon .

3.  Choose CRIC_SCREWbis.CATPart and click Open and you obtain:

4.  Select CRIC_SCREW.1 [CRIC_SCREW.CATPart] and click the Design mode . A Part Number conflict window is displayed because both entities 

of CRIC_SCREW have the same Part Number:

Renaming one of the Part Number is mandatory because the OK button is inactive in the Part Number conflict window.

5.  Rename CRIC_SCREWbis.CATPart and click OK:

6.  The Part Number is renamed and the conflict is solved:
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The second Part Number, CRIC_SCREWbis.CATPart, can be inserted in ManagingComponents01.CATProduct:
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 Deactivating / Activating a Node  

This task shows you how to deactivate / activate a Node in the Product Structure context.

Open the CRIC_TERMINAL_NODE01.CATProduct document.

1.  Select the Product CRIC_SCREW.

2.  Either select the command Edit > Representation > Deactivate Node or select the Deactivate icon . 

This functionality allows you to mask an active representation from a particular node (at the level of CRIC_SCREW) in the specification tree and in the geometry :

3.  To make the elements re-appear both in the tree and geometry, re-select the same node, CRIC_SCREW, and select Edit > Representation > Activate Node 

or clicking the Activate icon , the elements re-appear both in the tree and in the geometry :
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With these functionalities, you can choose to visualize the geometric representation of CATIA elements, belonging to a CATProduct. With the Deactivate 
Node functionality, only the selected element is hidden. Whereas with the Deactivate Terminal Node functionality, the last node's elements of the selected 
node are masked. For more information, see the following chapter Deactivate / Activate Terminal Node.

While reopening your document, if you close a CATIA document containing deactivated CATParts or CATProducts, he deactivated elements are activated. 
As opposed to the SHOW / NO SHOW functionality, the entities in the NO SHOW mode remain in this mode when you reopen the document. 

Both functionalities, Deactivate / Activate Node and SHOW / NO SHOW, are very similar. However, with the deactivate option you liberate the geometrical 
space, a deactivated representation is unloaded and it is no longer stored. On the contrary, with the SHOW / NO SHOW mode there is a more important 
quantity of stored memory.

The activate / deactivate functionality allows a more precise selection and de-selection, especially with the Terminal Node deactivation.

You can activate or deactivate Shape representation in Tools > Options > Infrastructure, select the Product Structure tab and check the box entitled Do 
not activate default shapes on open. The entity representation disappears, it is a profit for memory space and its icon in the specification tree changes 

into: . You can work only on the tree. For more information about activate or deactivate Shape representation, see Specification Tree.

Since CATIA R16 SP4, it is not possible to undo after the Activate Node, Deactivate Node, Activate Terminal Node and Deactivate Terminal 
Node operations. They are session operations, non-persistent for the model, like the VisuMode/DesignMode switch.
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 Deactivating / Activating a Terminal Node  

This task shows you how to deactivate / activate a Terminal Node in the Product Structure context.

To improve the visualization capability, you can use the Visualization mode. In this 
mode only, the external appearance of the component is visualized and the 
geometry is non-selectable, which may be useful when you deal with sophisticated 
assemblies with large amounts of data but only need a few components to work on. 
In addition to that, using a Cache system (.cgr files) considerably reduces the time 
required to load your data. You can manage the parts you want to visualize thanks 
to the functions Activate / Deactivate a Node functions allow you to all the parts in a tree. 
When you use this function, a progress bar appears to show you how many objects 
are still to visualize. 
See also next task Activating a Terminal Node with a Progress Bar.

Open the CRIC_TERMINAL_NODE01.CATProduct document.

1.  Select CRIC_SCREW.

2.  Select the command Edit > Representation > Deactivate Terminal Node. 

The representation of Terminal Node (of CRIC_BRANCH_3 and CRIC_BRANCH_1) disappears from the 

specification tree and the geometry, and their icon in the specification tree changes into: .
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3.  By re-selecting the same node, CRIC_SCREW, and the command Edit > Representation > Activate Terminal 

Node, the elements re-appear both in the tree and in the geometry:

By this means, you can choose to visualize or hide CATIA elements. Under a selected node, the elements of the 

very last node are masked.
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Since CATIA R16 SP4, it is not possible to undo after the Activate Node, Deactivate Node, Activate Terminal Node and 

Deactivate Terminal Node operations. They are session operations, non-persistent for the model, like the VisuMode/

DesignMode switch.

In some cases, Activate a Terminal Node can take more time then expected or can be selected by error. In this case it 

could be useful to have an Interrupt button is available in the Progress Bar dialog box to stop the visualization but it will not 

go back to the state before.
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Activating a Terminal Node With a Progress Bar 

This task shows you how to visualize the activation of shapes (using the Activate Terminal Node Command) with a 
progress bar that gives the number of activated shapes out of the total deactivated shapes.

For more information about the progress bar, please refer to Opening an existing Document with a Progress Bar.

Open the AnalyzingAssembly01.CATProduct document.

●     Select the root product AnalyzingAssembly01 and the command Edit > Representation > Deactivate 
Terminal Node. All the shapes are deactivated.

●     Or you can deactivate shape representation in the Tools > Options > Infrastructure > Product Structure > 
Product Visualization tab, by checking the box entitled Do not activate default shapes on open. Then, 
open the AnalyzingAssembly01.CATProduct. All the shapes are deactivated:

For more information about this functionality, please refer to Deactivate Terminal Node.

Select the root product AnalyzingAssembly01 and the command Edit > Representation > Activate Terminal 

Node. The shapes are progressively downloaded.
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And you can see the progression of the downloading of shapes associated to a terminal node:

This operation is activated by default (there is no setting).

When this dialog box disappears, the whole geometry (assembly) and the Specification Tree are displayed.
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Managing Representations    

This task shows you how to use several documents (CATShapes) to describe one part.

Open the ManageRep.CATProduct document.

1.  Click Manage Representations  in the Representation toolbar or right-click Cylindre (Cylindre.1) and select the Representations > Manage 

Representations... contextual command. The Manage Representation dialog box appears:

It displays:

�❍     the Name of the representation,

�❍     the Source file of the representation,

�❍     the Type of the representation,

�❍     whether the representation is the Default representation of the product,

�❍     whether the representation is Activated or not.

In this window you can see one Shape: Cylindre_s.CATShape. 

The default name given for a .cgr and .CATShape file is Shape X (X=1, 2, …. Depending on the number of files you have created). For example, it could be 
Shape 1.

2.  Click Associate... and the Associate Representation dialog box appears.

3.  Select Cylindre_d.CATShape from the online\pstug\samples folder and click Open. 

A second CATShape appears in the Manage Representation dialog box:

4.  Select the Cylindre_d.CATShape line. As a result Cylindre_d.CATShape is visible in the Geometry space. 

The Rename button becomes active.

5.  Click Rename and enter Detailed in the Rename Representation box. Click OK. Cylindre_d.CATShape appears with the name Detailed, in the Manage 
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Representation dialog box:

6.  Cylindre_d.CATShape is still selected. Click Set As Default button. This representation is activated and set as the default representation. Therefore by 

default, Cylindre_d.CATShape is visible when opening Cylindre Product. 

You can associate as many representations as you need, but only one must be Set As Default. In this case other representations are not displayed in the 

Specification Tree and in the Geometry area.

●     To change the default representation of a product, select one of its representations and click the Set As Default button.

●     To deactivate a representation of a product, select a representation in the Manage Representations dialog box and click the Deactivate button. 
The representation is deactivated from Product in the specification tree and in the geometry area. The Activated column of the Manage Representations 
dialog box displays "No".

●     To activate a representation of a product, select a representation in the Manage Representations dialog box and click the Activate button. 
The representation is activated in the specification tree and in the geometry area. The Activated column of the Manage Representations dialog box 
displays "Yes".

●     To replace a representation, select a representation in the Manage Representations dialog box and click the Replace... button. The 
Replace Representation dialog box is displayed. Select the model document from the chosen directory and click Open. The representation is replaced 
in Product in the Specification Tree, in the geometry area and in the Manage Representations dialog box. 
When you replace a constrained representation, even if its constraints have been deleted, you are in the reconnect representation context. 
See Reconnecting a Replaced Representation, in CATIA - Assembly User's Guide. When you replace a deactivated representation, the replacing representation 
is automatically activated.

●     To rename a representation, select a representation in the Manage Representations dialog box and click the Rename... button. The 
Rename Representation dialog box is displayed. Define a new name or select an existing name in the combo box. The representation is renamed in 
the Manage Representations dialog box. However, this has no effect on the feature names in the specification tree as there is no relation 
between representation names and feature names.

●     Renaming the instance name of the Part with this character "!" breaks the Publication Links, a warning message appears and you cannot rename it.

●     To remove a representation, select a representation in the Manage Representations dialog box and click the Remove button. The representation is 
removed from the Product in the specification tree, in the geometry area and in the Manage Representations dialog box.

●     If you copy / paste a .model As Spec (Paste Special > As Spec) into a CATProduct in CATIA V5, it is the same like doing a Add New Representation 
that is to say adding this model as a New Representation in the CATProduct. Copying As Spec consists in transferring of the solid with the Geometry and 
History tree. For more information about the Copy / Paste Special > As Spec, please refer to Copying 3D from CATIA Version 4 to CATIA Version 5 in 
the CATIA - V4 Integration User's Guide.

●     .cgr, .model, .CATShape and some other 3D graphic formats can be associated to a product. A CATPart or a CATProduct cannot be associated as an 
alternate representation to a product.

●     Activate representation operation is not persistent.

If you want to know how to manage representations as alternate shapes automatically, in DMU Optimizer, see Customizing DMU Optimizer Settings in CATIA 
-  Infrastructure User's Guide.

From CATIA V5, new alternate shapes can be saved in ENOVIAVPM, directly in the database. When the dialog box entitled Synchronization is displayed, 
you can click on OK. For more information about alternate shapes in VPM, refer to Managing Alternate Shapes - Saving and Deleting Alternate Shapes in 
VPM User's Guide.

 

About CATParts and CATShapes
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CATPart / CATShape differences?

A part contains a "Product" description that does not exist in a CATShape:

What is a CATShape?

A CATShape is designed to be used as a representation in a Part, product or component, which CATParts cannot.

What is the CATShape's role?

The role of a CATShape is to give a description to a product.

You can use several documents to describe a product. These documents can be divided in two groups:

●     a document describing the geometry, for instance: Cylindre_s.CATShape in our exemple.

●     another document giving other specifications: cf. Cylindre_d.CATShape.

A CATPart contains both:
●     the CATProduct's data, that is to say the product definition of the CATPart,

●     and the CATShape's data or the geometry definition of the CATPart.

But there is a constraint: there is always a CATShape set as default. And the CATProduct (product definition of the CATPart) cannot have sons, it can have 
other Shapes but cannot set them as default. Moreover, the CATShape (geometry definition of the CATPart) can be considered as the second half of the 
CATPart and it has priority before the other Shapes.

CATShape is only available with a license for one of the following products: CNA.prd, EQT.prd, HGR.prd, HVA.prd, 
PIP.prd, RCD.prd, TUB.prd, WAV.prd (they are the shipbuilding products and you can find their full name under 
Equipment&Systems.
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Reordering the Tree

This task shows you how to reorder components within the specification tree.

Open the ManagingComponents01.CATProduct document.

1.  Select ManagingComponents01.

2.  Click Graph tree Reordering . The Graph tree reordering dialog box appears listing the components constituting ManagingComponents01. This 

dialog box provides three buttons for reordering these components.

The first button  moves the selected component up by one position in the list. 

The second button  moves the selected component down by one position in the list. 

The third button  moves the selected component to the place of another component you need to select.

3.  Select CRIC_FRAME and click the second arrow twice. CRIC_FRAME then appears after CRIC_TOP on the list.

4.  Click Apply to preview the result:

5.  Select CRIC_TOP and click the third button.

6.  Select CRIC_AXIS to determine the location of CRIC_TOP. CRIC_TOP is now on top of the list.

7.  Click OK to confirm the operation. The application closes the dialog box and updates the specification tree. The tree is reordered as follows:
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Isolating a Part

This task shows you how to isolate a part in an existing assembly in order to move it independently from the other 
contextual parts.

Contextual Links:

If you remark that there is such a Part with these symbols (brown gear and red flash) in your Assemby: , you 
can edit this Contextual Part. The brown gear and the red flash signify that the Part reference is contextual and that 
this instance is not used in the Part Definition. This symbol can appear when you copy / paste or insert a Contextual 
Part into another CATProduct without taking into account the contextual links.

In this case the user needs to resort to the Define Contextual Links or Isolate Part commands in order to 
redefine the context of the Part and this red flash will be turned into a blue chain or green arrow.

For more information about broken contextual links, please refer to Defining Contextual Links: Editing and Replacing 
Commands.
Open the IsolateFunction.CATProduct document.

The option "Keep link with selected object" must be selected in Tools > Options > Infrastructure > Part 
Infrastructure.

1.  Double-click Sketch1 in Skeleton.CATPart in order to edit it. 

For instance, move the left side of Ctx1.CATPart. And go back into Product Structure workbench.

Before the manipulation of Ctx1.CATPart:

After:
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2.  Go to Assembly Design workbench and click the Update icon  or go to Edit > Update and the Update 

contextual command. As a consequence, Part3 (Part3.1) moves in order to follow the movement of Ctx1 

(Part2.1) and the hole coincides between the two parts. If you modify one Part, the other one adapts itself 

to this change. This is due to the fact that both CATParts depend on the same document, Skeleton 

(Part1.1), and the option Keep link with selected object is activated.
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Ctx1 (Part2.1) and Part3 (Part3.1) are contextual parts. They depend on the Sketch1 in Skeleton (Part1.1) 

in which they were created.

3.  If you want to make modifications impacting only on Ctx1 (Part2.1), select in the contextual menu of Ctx1 

(Part2.1) Component > Isolate Part. When Ctx1 (Part2.1) is isolated, its symbol in the Specification Tree 

changes from  to  meaning that it is no longer a contextual part:

3D Insight Version 5 Release 19 Page 91 of 1379



4.  Modify again the CATPart within the Sketcher and return in the Assembly Workbench. Only Part3 (Part3.1) 

has turned red in the Geometry space.
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5.  Update the document. As a result, Part3 (Part3.1) has not moved to adjust to Ctx1 (Part2.1).
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You can move independently Ctx1.CATPart from Part3.CATPart. As a consequence, when CTX1 is displaced, 
Part3 does not move and the hole does not coincide between the two CATParts.
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Deactivating / Activating a Component 

This task shows you how to deactivate a component from an assembly. Deactivating a component means removing its geometry.

In the same CATIA session, open the following documents:
●     AnalyzingAssembly02.CATProduct

●     Subset1.CATProduct

●     Product3 that you have to create by selecting File > New... Product and by inserting the existing component, Subset1.CATProduct.

In the menu bar, select Window > Tile Vertically in order to be able to visualize the three documents in the same CATIA window.

Subset1.CATProduct exists in AnalyzingAssembly02.CATProduct, Subset1.CATProduct and Product4.

1.  In AnalyzingAssembly02.CATProduct, select CRIC_BRANCH_1.CATPart (in Subset1.CATProduct).

2.  Right-click it and select the CRIC_BRANCH_1.1 object > Activate/Deactivate Component contextual command.

Note that all the instances of CRIC_BRANCH_1.CATPart disappear in the geometry space and their symbol is transformed into: .
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CRIC_BRANCH_1.CATPart gets deleted in AnalyzingAssembly02.CATProduct, Subset1.CATProduct and Product4. Its shape is deactivated and there are no traces 

of its specifications in the Bill Of Material (Analyze > Bill Of Material).

Deactivating a Component means deleting its representation and instance. The operation is simultaneous in all the CATIA documents containing this element, 

CRIC_BRANCH_1.CATPart, because it is the reference document. This operation is shared by all the instances of this part. You can apply this functionality on 

CATProducts, CATParts and models. 

This command does not free the memory and the symbol in the specification tree shows that it is still possible for you to reactivate it by the reverse operation: 

Right click CRIC_BRANCH_1.CATPart and select the CRIC_BRANCH_1.1 object > Activate/Deactivate Component contextual command.  

 

3.  In AnalyzingAssembly02.CATProduct, select Subset1.CATProduct, right click it and select the Set.1 object > Activate/Deactivate Component contextual 

command.
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Only one component is deactivated in AnalyzingAssembly02.CATProduct because it is not a reference instance. 

Subset1.CATProduct is no longer referenced in the BOM: 

Note that this operation cannot be applied on a root product.
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Comparison with closely related functionalities (illustrated by the table below):

●     Hiding objects (No Show): does not free the memory. The object is no longer displayed: it has been transferred into the No Show space. But it is still visible 
in the BOM.

●     Unloading a component: geometry disappears, only the instance is left and the reference no longer exists, but you have access to its information in the BOM. 
It frees the memory.

●     Deactivating a Node: the representation is masked in the geometry and the specification tree, but you can find its data in the BOM.

●     Deactivating a Terminal Node: the representation of Terminal Nodes disappears from the specification tree and the geometry. Under a selected node, 
the elements of the very last node are masked.

 Visualization 
(Shape Representation)

BOM 
(Bill of Material)

Accessibility 
(possibility of applying constraints)

Effects on aggregated 
objects

NO SHOW 
Hiding Components NO YES

YES, you can apply constraints 
between the hidden object and the 

other components in the Show 
space.

NO, the No Show icon is not 
propagated on the aggregated 

objects.

UNLOAD 
Unloading a Part 

(activated Cache, Visualization mode)
YES YES YES The aggregated objects are 

neither visible nor loaded.

UNLOAD 
Unloading a Product 
(Visualization mode)

NO NO NO Unloaded

UNLOAD 
Unloading a Part or Product 

(Visualization mode)
NO NO NO Unloaded

Deactivating a Node NO YES YES, you can apply a constraint 
even if the shape is deactivated. N/A

Deactivating a Terminal Node NO YES YES N/A

Deactivating a Component NO NO NO
The children are not visible in 
the Specification tree and in 

the Geometry.
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Defining Contextual Links

This task shows you how to change the context of a part in an existing assembly and how to make it contextual or not (and make it depend or not on 
another document). This documentation is divided into 3 scenarios:
●     Defining Contextual Links Between 2 Instances of The Same Part,

●     Defining Contextual Links Between 2 Separate Instances (with no dependences),

●     Defining Contextual Links Between 2 Instances Belonging to Different Products.

See also next task Defining Contextual Links: Editing and Replacing Commands.

 

Defining Contextual Links Between 2 Instances of The Same Part
Open the ChangeCtx.CATProduct document.

1.  Copy Pic1.CATPart and paste it in Poteaux.CATProduct.

2.  Because it is a copy of Pic1 (Pic1.1), Pic1 (Pic1.2) remains hidden behind Pic1 (1.1) in the Geometry space. Before moving Pic1 (Pic1.2), you need to double-

click Poteaux (Poteaux.1) to make it active, then select Pic1 (Pic1.2) - Poteaux becomes UI active (blue) - and you can drag and drop the compass on 

Pic1 (Pic1.2) to move it.

3.  So that you can more easily recognize both Parts, give Pic1 (Pic1.2) the blue color via the Properties contextual command). Pic1 (Pic1.1) is the pink 

cylinder and Pic1 (Pic1.2) is the blue one.
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Pic1.CATPart is a Contextual Part. 

Pic1 (Pic1.1) is a contextual instance .

Pic1 (Pic1.2)  is the second or subsequent instance of this contextual Part.

If you want to be more familiar with the compass manipulation, you can read Manipulating Objects Using the Mouse and the Compass in CATIA - 
Infrastructure User's Guide. This tutorial will show you how to move and rotate viewpoints and non-constrained objects.

4.  Double-click ChangeCtx so that it is UI-active (in blue) and in the contextual menu of Pic1 (Pic1.2), select Components > Define Contextual Links.

The following dialog box is displayed:

5.  Click OK. For more information about this window, please refer to the Change Context window described below. 

With this command, Define Contextual Links, the user can specify the Contextual Instance. 

Pic1 (Pic1.1) is no longer a Contextual Part, it is a "regular" instance, its icon changes into: . 

As a consequence, Pic1 (Pic1.2) is now the Contextual Instance, its icon becomes: . 

The Contextual Part Pic1 has to be updated because the Contextual Instance has been changed.

6.  Select the Update command in the Edit menu and you obtain:
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There is only one Contextual Instance (a Contextual Instance for a Reference). The Define Contextual Links functionality replaces the former Contextual Part. 
Only Pic1 (Pic1.2) is set between the Upper and Lower surfaces, it keeps link with the Surfaces whereas Pic1 (Pic1.1) is no longer in contact with the Surface 
because it is no longer the Contextual Instance (its property has changed).

Defining Contextual Links Between 2 Separate Instances (with no dependences)

1.  The first demonstration is finished, close ChangeCtx.CATProduct without saving and reopen it.

2.  Copy Pic1 (Pic1.1), select Poteaux.CATProduct and the command Edit > Paste Special. The Paste Special dialog box is displayed: select Break link and 

click on OK.

3.  Copy (1) of Pic1 is hidden behind Pic1 (1.1) in the Geometry space, therefore double-click Poteaux so that it is UI-active (in blue) and drag and drop the 

compass on Copy (1) of Pic1 to move it.

4.  So that you can more easily recognize both Parts, give Copy (1) of Pic1 the blue color via the Properties contextual command). Pic1 (Pic1.1) is the pink 

cylinder and Copy (1) of Pic1 is the blue one.
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5.  Double-click ChangeCtx so that it is UI-active (in blue) and in the contextual menu of Copy (1) of Pic 1 (Copy (1) of Pic1.1), select Component > 

Define Contextual Links:

Pic1.1 remains the Contextual Instance of the Contextual Part Copy (1) of Pic1. Its symbol is .

6.  Click OK and you obtain:
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Copy (1) of Pic1.1 is now the Contextual Instance of the Contextual Part Copy (1) of Pic1 and it gets this symbol: . 

With the Copy / Paste Special Break Link, there are two distinct parts that is to say two References and two Contextual Parts: Pic1 (Pic1.1) and Copy (1) 

of Pic1 (Copy (1) of Pic1.1). These two References are contextual respect to this Instance Pic1 (pic1.1) and both get this symbol: .

7.  Update the document and you can see Copy (1) of Pic 1 is still green. It adapts itself to the Surfaces.

With the Define Contextual Links functionality, both Pic1 and Copy of Pic1 are contextual: they keep a link with their Instance belonging to ChangeCtx.
CATProduct.

Defining Contextual Links Between 2 Instances Belonging to Different Products

1.  Open the ChangeCtx.CATProduct document.

2.  Under Poteaux.CATProduct, insert a new product, Product1 (Product1.1).

3.  Copy the contextual Part, Pic1 (Pic1.1), and paste it into Product1. This copy of Pic1 is the second or subsequent instance of this contextual part. This copy 

of Pic1 is hidden behind Pic1 (1.1) in the Geometry space. 

4.  Double-click Poteaux so that it is UI-active (in blue) and drag and drop the compass on Pic1 (Pic1.1) in Product1 and move it.

5.  To make both the Parts recognizable easily, give Pic1 (Pic1.1) in Product1 the blue color via the Properties contextual command). Pic1 in Product1 is the 

blue cylinder and Pic1 in Poteaux is the pink one.
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Pic1.CATPart is a Contextual Part. 

Pic1 (Pic1.1) in Poteaux is a contextual instance .

Pic1 (Pic1.1) in Product1 is the second or subsequent instance  of this contextual Part.

6.  Double-click ChangeCtx so that it is UI-active (in blue) and in the contextual menu of Pic1 (under Product1), select Components > Define 

Contextual Links. The Change context dialog box appears:

By choosing the option Expected Status as To Solve, the Instance of Pic1 under Product1 becomes the contextual instance of the Part Pic1.

This window provides information about the context you want to change and the external references of the instance Pic1 (in Product1):

�❍     Expected status: To solve, meaning that the links have to be restored between the following references:
■     Pic1 and Surface.2 (belonging to the Previous pointed element Face and to the Previous pointed instance Upper.1) 

■     Pic1 and Surface.3 (belonging to the Previous pointed element Face and to the Previous pointed instance Lower.1) in External References.
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■     Publication path with Surface.2 is ..!..!Masters.1UpperSurface. But the Publication Path with Surface.3 should be ..!..!...!Masters.1LowerSurface.

■     New pointed elements and instances have not been selected yet.

7.  Select both lines and press the  button once, corresponding to the number of the missing levels: ..!..!...!Masters.1UpperSurface and click OK.

The Contextual Part Pic1 has to be updated because the Contextual Instance has been changed. Update the document and you can see:
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The links are converted into ..!..!..!Masters.1UpperSurface and ..!..!..!Masters.1LowerSurface.

Pic1 (Pic1.1) in Product1 is now the Contextual Instance, its icon becomes:  because there is only one Contextual Instance for a Reference (Pic1 in 

Product1 and Pic1 in Poteaux have the same Reference). Applying the Define Contextual Links functionality on Pic1 in Product1 means when you change its 

property, it becomes the Contextual Part.

Pic1 (Pic1.1) in Poteaux is no longer a Contextual Part, it is a "regular" instance, its icon changes into: .

When more than one contextual instance of the same CATPart Reference is present in a CATProduct, only one of them can be the Contextual Instance (with the 

green wheel and little chain) at a time, when the subsequent instance is "Copy/Paste Special as a Result With Link" of this contextual instance.

8.  To make Pic1 (in Poteaux) a Contextual Part, select the Components > Define Contextual Links contextual command. The Change context dialog box 

is displayed:

9.  To choose new pointed elements and instances, select both lines and press the  once, corresponding to the number of the previous levels and 

you obtain: ..!..!Masters.1UpperSurface and ..!..!Masters.1LowerSurface.
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Pic1 (in Poteaux) becomes a contextual part . Click OK and Update your document:
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Defining Contextual Links: Editing and Replacing Commands

This command called "Define Contextual Links" uses the existing panel of the "Change Context" command. Therefore, the command can be used in the 
Change Context command. New buttons have been created in the Change Context window: Edit and Replace. 

The Define Contextual Link command enables to define (change) all the contextual links before and during the Change Context command. You can also make 
the operation on contextual parts, to modify unsolved links. You have the possibility to:

●     re-root each link, using the Edit button, pointing in 3D space or in graph

●     re-root links, using the Replace button, changing one or many instance names

●     change the numbers of each link, using Replace.

Contextual Links:

For contextual parts, the reference keeps a link with the Original or Definition Instance (or Original Part).

For each part, every instance keeps a link with its reference. But the Contextual Reference (or Contextual Part) has only one link, with a single instance that 
is contextual. This unique link allows you to know the name of the document (CATProduct) on which the part 's external geometry rests.

There is a distinction between the Original Instance and the subsequent Contextual References because the geometrical definition of contextual Parts depends 
on neighboring components (support) in the Assembly. The Geometry of the Contextual Part depends on another instance in the same Assembly (second link).

Three Instances of Contextual Part exist:

  Definition Instance This icon shows that the Part Reference is contextual and this Instance is the Definition Instance. The green gear and the 
blue chain signify the "original" instance of a part that is contextual (driven by another part, built with another part's data) 
in a CATProduct.

  Instance of the Definition Instance This icon shows that the Part Reference is contextual to the sub-product which was activated at the time of instantiation 
and this Instance is the Definition Instance. Command Icon also signifies that part is contextual (driven by another part, 
built with another part's data) in an active sub-product.

  Other Instance of the Contextual Part The brown gear and the red flash signify that the Part reference is contextual and that this instance is not used in the Part 
Definition. Note that you can edit this Contextual Part. This symbol can appear when you copy / paste or insert a Contextual 
Part into another CATProduct without taking into account the contextual links.

In this case the user needs to resort to the "Define Contextual Links" or "Isolate Part" commands in order to redefine the 
context of the Part and this red flash will be turned into a blue chain or green arrow.

For more information, please read the following scenarios: Defining Contextual Links: Editing and Replacing 
Commands, and Isolating a Part in Product Structure User' Guide.

Open the DefineCtxLinks.CATProduct document.
 

How to Replace a Part or a Publication

1.  In the contextual menu of CtxPart (CtxPart.2), select Components > Define Contextual Links. The following dialog box is displayed:

2.  In the Change Context dialog box, select the Publication path of Solid.1 and click the Replace button.

3.  Select another component in the Specification Tree, for instance the Publication: PartBody, which will be the new pointed element.
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Only the selection of a Publication (not other element) is possible in the Specification Tree (not in 3D).

And you can immediately visualize the expected status: Connected.

4.  Before going to the next task, please close DefineCtxLinks.CATProduct without saving it.

How to Edit a Part or a Publication

First example:

Open the DefineCtxLinks.CATProduct document.

1.  In the contextual menu of CtxPart (CtxPart.2), select Components > Define Contextual Links.

2.  In the Change Context dialog box, select the Publication path of Solid.1 and click the Edit button, the following window appears displaying the graphical view of 

the external references, which you can compare with the product structure graph. The Edit button allows to re-root the external links of a contextual part 

with other elements.

The part Support2.1 and the Publications PartBody are highlighted in red because Support2.1 should be under Compo2.CATProduct. 

3.  On the contextual menu of Support2.1, select the Insert Node before command to add a node, SubCompo2.CATProduct between Compo2.1 and 

Support2.1. You can directly select SubCompo2.CATProduct in the Specification Tree.
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And you obtain:

Both the Part and the Publication are no longer highlighted. Their links are restored. Thanks to the creation of the new node SubCompo2.1. 

4.  Click OK. The Solid.1 is reconnected and it acquires a new pointed element, PartBody, and a new pointed instance, Support2.1:

5.  Click OK.

6.  Before going to the next example, please close DefineCtxLinks.CATProduct without saving it.

Second example:

Open the DefineCtxLinks.CATProduct document.

1.  In the contextual menu of CtxPart (CtxPart.2), select Components > Define Contextual Links.

2.  In the Change Context dialog box, select both Datum.1 and Curve.2 and click the Edit button:
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The following window appears:

The reference of Support4.1 cannot be found under Compo1.1 because it has been renamed: Support.1. 

3.  Select Support4.1 and the contextual command Replace Node:

4.  Select another component in the Specification Tree: Support1.1, which will be the new pointed element. And the link is restored.

5.  Click OK.

6.  The other solution is to Edit the node of Support4.1, as shown below:
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7.  And you can enter a new name, for instance: Support.1. Click OK.

And you obtain:

8.  Click OK. The new pointed instance is Support.1 and the new pointed elements are Sketch.1 and VDirection.

9.  Before going to the next example, please close DefineCtxLinks.CATProduct without saving it.

Third example:

Open the DefineCtxLinks.CATProduct document.
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1.  In the contextual menu of CtxPart (CtxPart.2), select Components > Define Contextual Links.

2.  In the Change Context dialog box, select Surface.2 and click the Edit button:

The following window appears:

The reference of Support1.1 cannot be found under SubCompo2 because its position has changed: it is under Compo2.1 and not under SubCompo2.1. 

3.  Select Support1.1 and the contextual command Replace Node.

4.  Select Support1.1 in the Specification Tree or select another Publication under Support1.1: Extrude2. And you obtain:

The other solution is to delete Subcompo2:

As a consequence, Support1.1 is directly under Compo2.1:

5.  Click OK and the links are reconnected between Support1.1 and Compo2.1.

6.  Finally, you can update your document.
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The Edit functionality is the same with Publications.

Always the top most Publication in the scope of the common reference product is used to define the Contextual Link. The top most Publication represents 
the better logical access to a given geometry while the internal path to this geometry is not exposed for the user point of view. When it exists, the Publication 
at the Assembly level is then selected.
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Using Flexible Sub-Products 

 In the previous versions of Product Structure, you could only move rigid components in the parent product. Now, in addition to this behavior, you 
can dissociate the mechanical structure of a product from the product structure, and this within the same CATProduct document. As a consequence, 
you can move the components of a sub-product in the parent product.

This task recalls the behavior of rigid products and illustrates how to make sub-products flexible. This task eventually shows you how to analyze the 
mechanical definition of a product whenever this product includes flexible sub-products (and components attached together). For more information 
about components attached together, see Fixing components together in CATIA Assembly User's Guide).

Open the Articulation.CATProduct document.

 
1.  The product "Articulation" includes one CATProduct and two CATPart documents as follows:

2.  Drag and drop the compass onto link (link.1) as shown in the figure below. Select link (link.1) and drag it. The whole chain -and not link.1 

only- is moved.

3.  Undo this action to return to the initial state.

4.  To make chain (chain.1) flexible, right-click it and select the Chain.1 object > Flexible/Rigid sub-assembly contextual command.

You can notice that the little wheel to the left corner of the chain icon has turned pink  and there is a light blue stroke to identify the 

flexible sub-product.
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5.  You can now move link (link.1) independently from  link (link.2). For example drag and drop the compass onto link (link.1) and move it in 

the direction of your choice.

When a sub-product is flexible, you can apply updates to it, move it when constrained and set constraints to it.

6.  Copy and paste chain (chain.1) within Articulation.CATProduct. You can notice that the property "flexible" is copied too.

7.  To make chain (chain.2) rigid, right-click it and select the Components > Flexible/Rigid sub-assembly contextual command. A 

message window appears. Click the OK button.

8.  Drag and drop chain (chain.2) to clearly see both instances of chain.CATProduct.
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9.  Open chain.CATProduct and move link (link.1) using the compass.

The role of the compass is to:

●     look for the flexible product

●     move the highest product that is rigid or the first flexible component.

You can notice that because chain (chain.2) is rigid, it inherits the new position of the original chain.CATProduct. 
Conversely, chain (chain.1) remains unchanged.
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What you need to keep in mind is that rigid sub-products are always synchronous with the original product, whatever mechanical modification you 
perform (new dimensions or new positions for the original product). 

Flexible sub-products can be moved individually, without considering the position of the original product. However, flexible sub-assemblies inherit 
mechanical modifications to the original product. This command works upwards in the Specification Tree whereas the "stiffening" command (rigid 
mode) operates downwards. 

A component's position is borne by its reference. In a rigid mode, the position is carried by the first instance, the father of which is a reference (or a 
root product). In a flexible mode, the position is carried by the instance. Making a component flexible means that you are overloading its children's 
position.

When you Copy/Paste a flexible Sub-product, all generated Sub-products keep the flexible property and its children their overloaded positions.

10.  Go to the Start > Mechanical Design > Assembly Design workbench, in the Analyze menu, select the Mechanical Structure... 

command to display the mechanical structure of Articulation.CATProduct. This mechanical structure looks different from the product 

structure.

This display is merely informative. Note that you can use the Reframe graph contextual command and the zoom capability to improve the 
visualization, but also the Print whole contextual command to obtain a paper document. For information on printing, please refer to Printing 
Documents in CATIA Infrastructure User's Guide.

You can save the CATProduct with its flexible sub-products and when you re-open the CATProduct, the modifications are visible, these flexible 
components are kept in memory.

It is a not possible to see Flexible / Rigid Sub-Assembly status (pink gear) in the main Assembly or Root Product if this functionality is applied in a 
new window, because it is an Instance's property (and not a Reference's Property).

  
 

Flexible Assembly and Contextual Design
  
 The behavior of Contextual Design (Contextual part, which keeps a link with the original geometry through a Definition Instance) in Flexible 

Assembly depends on the Definition Instance:
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 First case: The Definition Instance is under Product 1. Second case: The Definition Instance is under Product2. (not the same 
icon for ContextualCable.CATPart)

  
 It means that if you move the connector's instances under Product1, it will impact the Contextual Design (...) in the first case, and it will not impact 

it in the second case.

Move of Connector.1: As Product 2 is flexible, the move is performed under Product1.
  

As definition instance is under Product1, the move impacts the Contextual 
Design.

As definition instance is defined under Product2, the Contextual Design is 
not impacted by the move under Product1.

  
Result after Update: No Update need to be performed in this case:
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You can change the Definition Instance by using Define Contextual Links command on instance with 
the right UI active product (see documentation Product Structure / Defining Contextual Links).

For more information about Document References, please read:

●     Assembly Design / Product Structure Specification Tree 

●     Flexible Sub-Assemblies, in Assembly Design User Guide

●     Defining Contextual Links
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Moving the Components of a Sub-Product in the Parent Product

 This task illustrates how to move a component belonging to a rigid structure (the Parent Product is rigid). It implies that the instance of its parent 
product's reference is moved.

Open the Articulation.CATProduct document.

 The product "Articulation" includes one CATProduct and two CATPart documents (in rigid mode) as follows:

1.  Edit or double-click Articulation to make it UI Active (User Interface Active, in blue color).

2.  Select link.1 and move it with the compass:

The compass is not positioned on link.1 because the component is rigid and this is its instance within the product, 

Chain.1, which is taken into account.

3.  As a result, you cannot move link.1 independently from link.2. The whole assembly (Chain.1) moves because its sub-components (link.1 and 

link.2) are rigid.
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4.  Undo this action to return to the initial state.

5.  Edit or double-click Chain.1 to make it UI Active (in blue color) in order to be able to move the instance of the link.1 reference.

6.  Select link.1 and and move it with the compass: Note that if chain (chain.1) is UI-Active , you cannot move chain from Articulation. You can 

move the "sons" of the UI-Active object and not the object itself (the UI-Active "father"). You cannot move an object with respect to itself.
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Note that in this case, the compass is positioned on link.1.

7.  You can now move link (link.1) independently from link (link.2).

If you double-click link (link.1), it becomes highlighted in blue (UI-Active) and you will not be able to move its "father".

Therefore, to move a sub-product in a rigid structure, you need to edit its parent product. 

3D Insight Version 5 Release 19 Page 123 of 1379



Applying Overload Position on Reference During 
"Rigidification" Command 

This task consists of applying an overload position first on a Specific Instance, and subsequently on all the instances of a reference. 
The following aspects have been explained in this chapter:

Propagation 
No propagation with Multi-Instances

As it was described in the Flexible Sub-Products section, the user can dissociate the mechanical structure of a product from the 
product structure within the same CATProduct document.

Open the 16cubes.CATProduct document:

This document contains two identical CATProducts: 8 cubes (8 cubes.1) and 8 cubes (8 cubes.2). Both CATProducts have the same 
CATParts: Cube (Cube.1) and Cube (Cube.2).

Propagation 

1.  Right-click 2Cubes.1 in the specification tree and select the 2cubes.1 object > Flexible/Rigid sub-assembly 

contextual submenu to make 2Cubes.1 flexible.

You can notice that several icons in the specification tree have changed: . This identifies a flexible sub-

product.

2.  Select Cube.1 and move it with the compass. You can now move Cube.1 independently from the other cubes of 8Cubes.1. 

You have modified the position of Cube.1 (instance) within the 8cubes.1 instance, in the 16cubes.CATProduct document. 

However, within 2cubes.2, the position of Cube.1 has not changed.
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3.  Right-click 2Cubes.1 and select the 2cubes.1 object > Propagate position to reference contextual submenu to 

propagate the position of Cube.1 instance on the reference.

The flexible position has been propagated on all the instances of Cube.1. The position of Cube.1 has changed within 
2cubes.CATProduct, which explains why its position has been propagated on all the other Cube.1 within the 2cubes 
instances.

 

4.  Right-click 8Cubes.1 in the specification tree and select the 8cubes.1 object > Flexible/Rigid sub-assembly 
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contextual submenu to make 2Cubes.1 and all the elements above rigid. 

Note that the stiffening command (rigid mode) operates downwards.

And a warning message is displayed, explaining that the operation is transferred on the product's children as well:

Click OK. Note that the instances of Cube.1 do not have moved back to their initial position. There is synchronization 
between the first instance of Cube.1 within 2cubes.CATProduct and all the other instances of Cube.1 (for instance the 
instances in 16cubes.CATProduct: 8cubes\4cubes.1\2cubes.1\Cube.1 and 4cubes\2cubes.1\Cube.1 and 2cubes
\Cube.1).
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Advice: Do Not Use Propagation With Multi-Instances 

1.  To make 2cubes.1 flexible, right-click it and select the 2cubes.1 object > Flexible/Rigid sub-assembly contextual 

command to make its children Cube.1 and Cube.2 flexible.

It is possible to make 2cubes.1 and 2cubes.2 flexible simultaneously.  

For this, you need to click 2cubes.1 and 2cubes.2 by pressing and holding down the Ctrl key. Release the Ctrl key, right-click one of 
these two components and select the Selected objects > contextual command.

2.  Move Cube.1 in both Cubes.1 and in Cubes.2 (2 instances of Cube.1).
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You can apply the propagation of an overload position only on a product's instance but not on a Part and a root Product, otherwise 
the following message is displayed:

Select 8cubes.1, right-click it and select the 8cubes.1 object > Propagate position to reference contextual command. And the 

following message appears because 8cubes is the common root of Cube.1.

3.  Select 4cubes.1, right-click it and select the 4cubes.1 object > Propagate position to reference contextual command. 

And the Error Message appears because 4cubes is the common root of Cube.1. 

It is recommended not to use this propagation command with Multi-Instances because you need to have only one flexible 

instance (Cube.1 for instance) to propagate rigidification.

4.  Select 2cubes.1 or 2cubes.2 and the Propagate position to reference contextual command. The position is propagated 

on all the rigid instances: all the Cube.1 instances within 2cubes, except the flexible ones (16cubes\8cubes.1\4cubes.1

\2cubes.1\Cube.1), adopt the last applied position. 
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If you select 8cubes.1 and make it rigid, the other rigid elements are not modified. But Cube.1 in 2cube.2 becomes rigid and keeps 
the same position. And Cube.1 in 2cube.1 becomes rigid and retrieves its initial position that is to say the position of Cube.1 in 
2cubes.2.
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Reusing Your Product Structure 

Capabilities Purposes 

 Copy and  Paste

Provides a quick way of reusing the product structure 
between different assemblies or within an assembly. 
This command is to be used when you need to rework 
one specification or no specifications at all.

 Cut and  Paste

Provides a quick way of reusing the product structure. 
This command is to be used when you need to rework 
one specification or no specifications at all.

Drag and Drop Provides a quick way of copying the product structure 
at different locations.

Paste Special

Makes a Copy of an Instance independently (or not) 
from the Source that is to say using the following 
formats: Paste As Specified in Product Structure and 
Paste Break Link.

●     Paste as Specified in Product Structure This format enables to duplicate the Source Instance 
keeping the link to the Source Reference. A new 
Instance of the Source is created and it has the same 
Reference as the Source.

●     Paste Break Link

This format leads to the duplication of the Source 
Instance and its Reference. The Reference of the New 
Instance is the Copy of the Reference. The Source and 
the Copy are separated, that is to say if you modify the 
Source, there will be not impacts on the new Instance 
(Copy). The Source Instance and its Reference are 
duplicated.
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Cutting, Copying and Pasting Objects 

 The steps below describe how to cut and paste or how to copy and paste Product Structure features. The last task 
will show you how to use the Instance Copy functionality.

We recommend you to use these commands when you do not need to re-specify the features you paste. if you do 
so, these features should not require too many specifications.

The Copy / Paste purpose (Break Link or As Specified in Product Structure) is to make an accurate Copy of the 
Source and keep the Attributes and Applicative data.
When the Source is in Visualization Mode, the Copy command needs a partial load of the Source.

When cutting or deleting a modified object, a warning message is displayed:

●     Yes: This option will display an editor to be able to save the modified object.

●     No: This option means that the document is removed, but not totally lost. It can be retrieved with the Undo 
command.

 
1.   Select the object you want to cut or copy.

2.  To cut, you can either:

●     click the Cut icon 

●     select the Edit > Cut command

●     select the Cut command on the contextual menu, or

●     from the geometry area or the specification tree, drag the selection (although 
not a graphical cut, this is equivalent to the cut operation).

This places what you cut in the clipboard.
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 To copy, you can either: 

●     click the Copy icon 

●     select the Edit > Copy command

●     select the Copy command on the contextual menu or

●     from the geometry area or the specification tree, press and hold down the 
Ctrl key and drag the selection.

This places what you copy in the clipboard.

3.  To paste, you can either:

●     click the Paste icon 

●     select the Edit > Paste command

●     select the Paste command on the contextual menu (or Paste Special - Paste 
As Specified in Product Structure)

●     or from the geometry area or the specification tree, drop what you are 
dragging (see above).

 
Dragging and dropping objects (features or bodies) onto objects (products or components) is also quick way to copy 
objects too. Note however, that the option Enable Drag-Drop must be on to use the capability.

 About Product Structure Features Position

 When you Copy / Paste from a CATProduct in another CATProduct, the pasted object has the same position as the 
source object.

When you Copy / Paste from a CATPart in a CATProduct, the pasted object has the same position as the target 
object, that is, its father.

 About Graphical Properties

When you Copy/Paste from a CATProduct in another CATProduct, note the following two cases:

●     In case graphical properties are set on the copied object and these graphical properties are also set on the 
pasted object, any change made to the graphical properties of copied object is not reflected on the pasted 
object.

●     In case no graphical property is set (keeping default graphical properties) on the copied object, then any 
change in the graphical properties of copied object is reflected on the pasted object.

For more information, please refer to Managing Graphic Properties in Products.

 Instance Copy in Visualization Mode when the Cache option 
activated in CATIA
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 This command allows you to do an Instance Copy in Visualization mode without loading the product reference. It is 
available in the Product Structure workbench if Enovia VPM Navigator connection is available with CATIA installation.

Two modes for products representation are available in Product Structure product:

●     Visualization Mode: only the CGR is loaded

●     Design Mode: all the geometry specifications are loaded

To access the Instance Copy command from the contextual menu, you need to follow these steps.

1.  Start CATIA and open a Product.
2.  Right-click the Product node in the specification tree and select the Instance Copy command.

The Instance Copy appears activated only if the current object is a Product node in the specification tree. Part 
geometry nodes, Design tables, Drawings sheets, catalog chapters, etc. are not Product nodes, so therefore they do 
not show the Instance Copy menu

 The Instance Copy command is also available form the Edit menu.

3.  After selecting the command, you need to choose a destination object as explained in the status bar:

4.  Select a product instance and then the copy of the instance is created in 
Visualization mode and the new instance is displayed in the tree. 

After using the Instance Copy command, the instantiated 
product reference remains in the Visualization mode.

The Instance Copy works also for a standalone CATPart. 

Limitation

The multi-selection is not supported by this command. If several objects to copy are selected, only the copy of the 
first one is done.
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Paste Special 

 This task explains you how to use the Paste Special... command. This implies the understanding of the type of features you can paste using this command 
as well as the various formats available for pasting these features.

This document is divided into 2 parts:

●     Paste Special As Specified in Product Structure,

●     Paste Special Break Link.

 

Paste As Specified in Product Structure

Paste As Specified in Product Structure is the format by default (traditional Paste).

If you copy / paste an object in an assembly, only the selected Source Instance is copied. 

A new Instance of the Source object is created and it has the same Reference as the Source. 
Therefore, modifying the Source implies modifying the Copy and vice versa. 
And the Copy (new instance) has the same Reference. This schema illustrates this behavior:

 
●     Open AnalyzingAssembly02.CATProduct.

●     Create a new CATProduct: Product1 for example.
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1.  Select CRIC_TOP for instance and copy it.

2.  Right-click Product1 in the new CATProduct, select the Paste Special... command. The Paste Special window appears.

3.  Select the As specified in Product Structure line and click OK. You obtain this result:

4.  Edit the Reference of CRIC_TOP (open CRIC_TOP.CATPart). Note that if you modify this Reference, both Instances are also modified: Source and Copy.
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The behavior of Paste Special As specified in Product Structure is exactly the same as a simple Paste.

Paste Break Link

Contrary to the previous format, the Source Instance and its Reference are duplicated, because a new Instance and a new Reference are created. The 
Reference of the new Instance is the Copy of the Reference, which makes it independent from the Source. The Source and the Copy are separated, that is to 
say if you modify the Source, there will be no impacts on the new Instance (Copy). This schema illustrates this behavior:

 
●     Open AnalyzingAssembly02.CATProduct.

●     Create an empty CATProduct: Product1 for example.
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1.  Select CRIC_TOP for instance and copy it.

2.  Right-click Product1 and select the Paste Special... command. The Paste Special window appears.

3.  Select the Break Link option and click OK. And CRIC_TOP appears in Product1. Note that the Instance name of the copy is not the same as the one in our 

first example (As specified in Product Structure).

4.  Edit the Reference CRIC_TOP.CATPart. Note that if you modify this Reference, the new Instance of CRIC_TOP (the Copy) is not modified:

In an assembly, you cannot have two References with the same Part Number within a CATIA Session. If you copy / paste Beak 
Link a CATPart, CATProduct or a Component, the Copy is automatically renamed like this: Copy (n) of Source (Copy (n) of 
Source.1).

But If you copy / paste Beak Link an object in another CATProduct that does not contain the same Reference, the Copy is not 
renamed.
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Duplicating References:

Paste Break Link duplicates the Reference of the selected object and all references of aggregated children, if they are internal reference in the document as 
the selected object. Here is an example:

The Source References in the Source Assembly are Blue in color. The References in the Target document are in Pink color. 
P3 is a child of the copied component P2. However, since its Reference is in another document, so it won't be duplicated. 
You copy P2.1 under Target (Copy / Paste Break Link).

=> Instance / Reference Link:

This symbol identifies that this is a Product (not associated to any document). This is an Instance or Reference that follows the same behavior as its root (first 
"father" having an Associated Document).
This symbol identifies that this is a Product (Instance or Reference), whose Reference is associated to a Document. The Product has its own Copy / Cut / Paste 
behavior.

When you use the Paste with Break Link functionality, only the Instance chain within the document is duplicated. For instance:

●     If you copy / paste P1.1:
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●     If you copy / paste Root1:

When you copy / paste Break Link an Instance that has an External Reference, its Reference and its Document are duplicated (only when the original 
Document has an External Reference).

Duplicating Documents:

If copying / pasting Break Link an object in a CATProduct, its Reference is also duplicated (its document is duplicated). The action is somewhat like Inserting 
a New Product.

If you duplicate in CATIA V5 an ENOVIA document via the Paste Break Link, you only obtain a document File.

Limitations:

●     Cut: Break Link is the unique format when applied on Components, because Components have internal References (only Break Link is available in the Paste 
Special window). 

●     V4 models are often inserted in the product structure using Components, therefore cutting the V4 models is like cutting a Component, using break link format, i.
e. the reference is deleted as the instance. Reference and instances have to be re-created at the Paste (break link) operation. Because this could lead to 
inconsistent results at save, you 
cannot Cut/Paste V4 models when working in VPM context. The following panel is displayed.

 
 

●     When applied on several sources at the same time and if one of them is a Component, Break Link is also the only format available.

●     Drag and Drop: only the As specified in Product Structure is available.

●     Paste Special:
�❍     You cannot paste on two Targets at the same time
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�❍     You cannot make a multi-format Paste, but it is possible to select several Sources at the same time and paste it at the same format.

If you copy / paste a .model As Spec (Paste Special > As Spec) into a CATProduct in CATIA V5, the behavior is the same like doing a Add 
New Representation that is to say adding this model as a New Representation in the CATProduct. Copying As Spec consists in transferring the solid with 
the Geometry and History tree.

For more information about the Copy / Paste Special > As Spec, please refer to Copying 3D from CATIA Version 4 to CATIA Version 5 in the CATIA - 
V4 Integration User's Guide.
Copy Semantic:

Here we review how a pair (instance, reference) is copied from the origin document to the target document via the clipboard.

In these scenario types, we are copying the instance (I) that is attached either to a local reference (LR) or to an external reference (ER).
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Replacing a Component 

The first task, Replacing a Component by another one in Session, involves in replacing a component and showing the impacts of this action. Using 
the Replacement Component command means replacing one component with another.

The second task, The Impacts of the Replace Command, explains what can be the impacts of replacing a component whose Part Number is same as 
the replaced element, and what can be done to solve the conflict.

The third task Replacing a Specific Instance or All Instances of a Reference, shows you that you can replace several instances. The process is the same 
but when a component dialog box is displayed, you select the component of your choice and tick the MultiInstances box in order to replace all instances.

See also next task Replacing on a Specific Instance or All Instances.

Within an assembly, two components can have the same Part Number and be the Instances (1 and 2, in our example below) of two References only if 
their References are inserted in two different documents (in different assembly levels,  Local References). For instance:
●     occurrence 1 is an Instance of CARBODY Reference in Landing_Gear document.

●     occurrence 2 is an Instance of CARBODY Reference in PartNumberConflicts1 document.

A Local Reference is a Reference that can only be used in its own document. This is what we call an embedded Reference in a CATProduct. For more 
information about Local References, please refer to Naming or Renaming a product.  
Therefore, if the Replace All Instances functionality is applied to one of these instances (1), it will not replace both Instances and the behavior will be the 
same like the common Replace:

For more information about this example, please refer to Inserting Existing Components.

A V4 model is not a Product, therefore it is considered as a Representation, a CATShape. 
A model is inserted in a product structure by means of a local Reference created in this particular case. The model is a representation attached to this 
Reference. For more information, please refer to Managing Representations.

●     Replacing a component means that you are replacing a Reference by another Reference and you are also keeping the same Instance. The Instance Name is 
the data of an Instance. It is not changed after the Replace operation, so that links (External References) are not broken. You are allowed to reconnect the links 
with the new Reference. 
For more information about modifying Instance Name, please refer to Naming or Renaming a product (Instance or Reference).

●     Actions performed after replacing components cannot be undone. The history of actions is cleared and the Undo icon is grayed out.

Replacing a Component by another one in Session

3D Insight Version 5 Release 19 Page 141 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/pstug_C2/pstugbt0322.htm


If you want to replace your CATIA documents by downloaded ones, you need to activate the following option, in Tools > Options > General > Document 
> Document Environments - Loaded document: Allowed.

Open the AnalyzingAssembly02.CATProduct.

1.  Right-click CRIC_SCREW (CRIC_SCREW.1) and the Replace Component contextual command. The following windows are displayed:

2.  Click Cancel in the file Selection window. The Browse window is still available.

3.  Click the Loaded document icon. A Session document window appears:

4.  Select one of the downloaded documents, for instance: Subset1.CATProduct. An Impacts on Replace window is displayed, showing you what can interfere 

with the other downloaded documents. For more information about the impacts on replace, please refer to the following section.

5.  In the Impacts on Replace window, select Yes radio button and click OK if all the replacing impacts have resolved. And you obtain:
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The Impacts of the Replace Command
Open the ReplaceImpacts.CATProduct document.

Note: depending on the document environments you have allowed in the Document settings, an additional window may appear simultaneously to let you 
access your documents using an alternate method. For detailed information, refer to Opening Existing Documents Using the Browse Window.
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1.  Select PartWithImpacts (PartWithImpacts.1) and click the Replace Component icon . You can also right-click on PartWithImpacts (PartWithImpacts.1) 

and go to Components > Replace Component.

The File Selection and Browse windows are displayed:

To have the Browse window opened, go to Tools > Options > General. In the Document tab, select Loaded document in the Document Environments 
panel and click Allowed.

2.  Click Cancel in the File Selection window; the Browse window becomes activated. 

 

Or if you select Support1.CATPart for instance, in the File Selection window, and click Open, the Browse window disappears and, An Impacts on 

Replace window appears:

Therefore, you do not need to follow the steps 3 and 4.

3.  Click the File icon and another File Selection window appears.

4.  Select Support1.CATPart for instance in the File Selection window and click Open.  

An Impacts on Replace window appears:

This window shows you the impacts of the Replace command on PartWithImpacts.CATPart. You can see the impacted objects (2 Publications, 1 
External Reference and 1 Constraint) that can be re-connected or not. You have access to the following information: 
●     Type of the impacted objects (Publication, Contextual Design Connection)

●     Name of the impacted objects (which is connected to PartWithImpacts.CATPart)

●     Source or path of the impacted objects

You can interrupt the Replace operation by clicking the Cancel button.

5.  There is a question in the window:
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By default, the YES option is checked. It means that all the instances will be replaced (and the Part number conflict window does not appear because it is 

no longer needed). 

 
If you click NO, only the selected instance will be replaced but, in the case of a Part Number conflict, the Part Number Conflict dialog box appears. For 

more information about Part Number Conflict, please refer to the following scenario.

6.  Click OK and the Impacts on Replace dialog box disappears. You can visualize the impacts in the Geometry and in the Specification Tree.

7.  Update your document and the following warning points out the impacted objects: Surface.1 no longer has its External Reference.

You can however use the replace command on the objects that may be impacted. The links can be modified but not necessarily broken.
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8.  Click Close. The symbol next to the External Reference  means that the part is not connected with the correct External Reference. The other 

Publications with a broken link are represented with this yellow exclamation mark  meaning that the link with the root document has been lost.

●     When you replace a Product by another Product, the Instance path is broken (all links under this instance are broken), because you are destroying a Product 
and re-instantiating a different one. Therefore, you cannot map the Instance's links anymore. 
When you replace a Product by another Product, note that only the Part Number is modified, but the Instance Name never changes:

●     When you replace a Product by a copy of this Product, the process is successful because the Instance links are not modified, only the Reference is changing 
(all links are kept), because the Reference of the Copy of the Product belongs to the same family and Instance links can be re-mapped.

●     About Reference / Reference link: If the replaced Reference is pointed by a Reference / Reference link, this link is not impacted nor broken, as a consequence 
the replaced Reference will not be unloaded.

Replacing a Specific Instance or All Instances of a Reference
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This task consists in replacing All Instances of a reference and a Specific Instance. 
As it was described in the previous section the user activates the Replacement Component icon  to replace one component with another. This 

command automatically chooses the first instance of the object that is going to be replaced.

Open the 16cubes.CATProduct document:

This document contains two identical CATProducts: 8 cubes (8 cubes.1) and 8 cubes (8 cubes.2). Both CATProducts have the same CATParts: Cube (Cube.1) 
and Cube (Cube.2).

1.  First of all, select Cube (Cube.1) and click the Replace Component icon . The File Selection dialog box is displayed, select Cube2.CATPart and click Open:

2.  Click Open and the Impacts on Replace dialog box appears, with the following message:
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If you choose to replace Cube(Cube1.1) with Cube2(Cube1.1), there is a Part Number conflict because both entities have the same Part Number 
(Cube). Therefore, if you click:

●     YES, all the instances will be replaced (and the Part Number conflict window does not appear because there is no longer any conflict).

●     NO, only the selected instance will be replaced but, in the case of a Part Number conflict, the following dialog box appears:

 
3.  Select Yes. There is no Part Number conflicts window (no impact on Cube (Cube.1)) because the replacing component, Cube2.CATPart, does not create 

any conflict since all the "cube" Part Numbers have been replaced:

Wherever the element's instance is in the product, it is replaced by the new component. In our example, the Multi-Instances functionality looks for all 
the instances of the reference Cube (Cube.1) in the product and replaces them in the whole document.

4.  Close 16cubes.CATProduct without saving it. Re-open it.

5.  Repeat the same operation: select Cube (Cube.1) in 2cubes (2 cubes.1) and click the Replace Component icon .

6.  In the File Selection window, select Cube2.CATPart and click Open: the Impacts on Replace dialog box appears.

7.  Click No to replace only one instance:

8.  Click OK button. And two windows appear:

�❍     the Incident Report: it is a warning telling you that the component you are inserting is read-only. Click Close.

�❍     the Part number conflict window; you can Rename (or use the Automatic rename option) the new instance Cube2.CATPart so that there is no longer conflict 

with the other Part Numbers (you do not replace):

3D Insight Version 5 Release 19 Page 148 of 1379



9.  Select this line (Cube) and click the Rename button. The (New) Part Number window appears: enter a new Part Number (CubeBis).

10.  Click OK. In the Part number conflicts, you can see that the name of the Part Number is now CubeBis instead of Cube (for Cube2.CATPart).

11.  Click OK and you obtain:
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As a consequence, only a Specific Instance, Cube (Cube.1), is replaced by Cube2.CATPart (whose Part Number is different from the one of Cube (Cube.1)) 

in the Specification Tree and in the Geometry area. 

 
Note that the last entity of Cube (Cube.1) has not been replaced by Cube2.CATPart because the entity's instance is not at the same level:

For more information about Part Number conflict, please refer to Insert Existing Component.
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Editing Components 

This task lists the ways of editing components in an existing assembly:
●     The Cut command removes the selected component instance and puts it in the clipboard.

●     The Copy command puts a copy of the selected component instance into the clipboard.

●     The Paste command creates a new component instance from the clipboard.

●     The Delete command removes the selected component instance. Note that it is impossible to delete a deactivated component, it must be reactivated prior 
to deletion. For more information about the deletion of the instance of a contextual CATPart, please see below.

●     The drag and drop capability allows you to copy or move one component to another.

For each edition operation you must select the components in the specification tree.

Remember that the components you wish to move or paste may have one or more constraints. Once the component is moved or pasted, the constraints may be 
broken. See also Copying and Pasting Objects CATIA - Infrastructure User's Guide.

What happens when you delete the Instance of a Contextual Part

This task shows you how a contextual part can be modified by a Delete operation and it can be saved in the Save Management window.

Open the document: ChangeCtx.CATProduct.

You can display document links by selecting the Edit > Links... command. Click the Pointed documents tab to display only the documents pointed to by the 
current object. Select Poteaux.CATProduct and click Open.

And you can visualize both ChangeCtx.CATProduct and Poteaux.CATProduct:
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 This symbol next to Pic1 (Pic1.1) in the Specification Tree represents a part and the green gear  signifies the "original" instance of a part that is 

contextual (driven by another part, built with another part's data) in a CATProduct.

Pic1 (Pic1.1) is a contextual part and it has been built with Upper (Upper.1) and Lower (Lower.1). Upper (Upper.1) and Lower (Lower.1) are selection instances 
(External References) and Pic1 (Pic1.1) depends on them, which explains why the External References file appears under Pic1 (Pic1.1) in the Specification Tree. 
If you modify Upper (Upper.1) and/or Lower (Lower.1), there will be some impacts on the contextual part.

1.  In Masters.CATProduct, select Upper (Upper.1) and delete it. The following dialog box is displayed:

2.  Click the More >> button in order to see the names of the CATIA elements affected by deletion:

�❍     Pic1\PartBody\Pad.1\ : the pad will disappear because it has lost its External References.

�❍     Pic1\External References\Surfaces.2 : Surfaces.2 is impacted because Upper.1 is an External Reference, helping to build Pic1.CATPart.
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3.  Click OK. Pic1 has disappeared and it is no longer updated:

4.  If you want to save these CATProducts and CATParts, select the File > Save Management... command:
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If you want to keep the External References undamaged within Pic1.CATPart, select Component > Isolate Part in the contextual menu of the part (before the 
Delete operation) in order to isolate it in an existing assembly. Therefore you will be able to modify it independently from the other parts. External References 
become "Isolated":

●     For more information about this function, please refer to Isolate Part.

●     You cannot undo the Delete operation in case of multi-editor environment (i.e. when an instance and its reference are opened at least in two CATIA 
editors).
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Modifying Component Properties 

This task shows you how to access and edit component properties. You can redefine and even create new ones at any time.

Open the ManagingComponents01.CATProduct document.

1.  Right-click CRIC_AXIS (CRIC_AXIS.1) in the specification tree and select Properties.

You can select the component in the specification tree or in the geometry. This command is also 
available from the Edit menu.

The Properties dialog box is displayed. Four tabs are available:

�❍     Product

�❍     Graphic

�❍     Mechanical

�❍     Drafting

2.  Select the Product tab in the Properties dialog box.

�❍     his tab displays the Component properties, Link to reference, Product  properties and the Define other 

properties button.

�❍     On the right side, next to Instance Name and Part Number, you can see this symbol: .
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In a CATProduct, the Instance Name must be unique at one Assembly level. If you enter the same Instance Name as the 
existing one in the document, at the same level, there will be a red light in the Instance Name field: , with the following 

message : "The identifier xxx.n is already used".

Neither special characters "!" and ":" nor an empty name " " and blank character at end of the string should be used 
in the:

●     Instance Name

●     Part Number

●     Publication.

The Component frame displays:

●     Instance name, the name of the selected component

●     Description, the description of the selected component.

The Product frame displays:

●     Part Number, the name of the product

●     Revision

●     Definition

●     Nomenclature

●     Source

●     Description.

The combo box displays the following options:

●     unknown: for an unknown product

●     made: for a product made by the user

●     bought: for a product bought by the user.

The InstanceName attribute is only valuated on the first instance.

If the instance name is renamed, then the instance name for other copied instances is generated from this renamed instance 
name.

 
3.  Click the Define other properties button.

The dialog box that appears lets you add the properties of your choice.
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�❍     Real
�❍     Inertia

�❍     Integer
�❍     Massic Flow

�❍     String
�❍     Moment

�❍     Boolean
�❍     Pressure

�❍     Length
�❍     Angular Stiffness

�❍     Angle
�❍     Temperature

�❍     Time
�❍     Linear Mass

�❍     Mass
�❍     Linear Stiffness

�❍     Volume
�❍     Volumetric Flow

�❍     Density
�❍     Frequency 

�❍     Area
�❍     Electric Power

�❍     Inertia Moment
�❍     Voltage

�❍     Energy
�❍     Electric resistance

�❍     Force
�❍     Electric intensity
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4.  Select the parameter you need next to New Parameter of type. For example, select String, and then click New 

Parameter of type. This parameter is displayed in the property name frame.

5.  Rename the parameter as Manufacturer in the Edit and value field.

Be careful when choosing a name for a parameter, as some correspond to attributes shortcuts and/or attribute names and 
should not be used. For more information, refer to the Using the Search Language chapter in the CATIA Infrastructure User's 
Guide.

 
6.  Enter French Company in the value field. The dialog box now looks like this: 

7.  Clicking Delete property deletes the selected parameter.

The Delete property option is not available on the read only properties.

8.  Clicking External properties... accesses additional properties defined in a .txt or .xls file. The application can reuse 

these files provided they have a tabulated format.

9.  To do this, select the desired file, trame.txt for example, in the Open File dialog box that appears:

10.  Click Open and the information contained in trame.xls are stored in the Define other properties dialog box: 
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11.  Click OK in the Define other properties dialog box to validate the creation of the property. 

A new section Product: Added Properties appears in the Properties dialog box. This section displays all the 

properties you have created, even those described in the .txt or .xls files. 
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Once created, you can access these properties via the Bill of Material too.

12.  Click the Graphic tab in the Properties dialog box.

●     This tab lets you display the Graphic properties of the component. To know how to apply graphic properties, refer to 
CATIA- Infrastructure User's Guide.

●     You can add tolerances, Multiple values and Range to a parameters in Added properties using contextual menu. You can 
edit comments and lock parameter values; however you cannot edit formula using the contextual menu.

●     Define other parameters allows to define new parameters which will be persistent only after the transaction will have been 
committed (by OK or Apply button in Properties Dialog box).
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13.  Click the Mechanical tab to display the mechanical properties of the selected component:

�❍     Characteristics: Volume, Mass and Surface. The fields are not editable. Note that the mass is 0kg because no 
material has been applied. For more about materials, please refer to CATIA-Real Time Rendering User's Guide.

�❍     Inertia center. The corresponding fields are not editable.

�❍     Inertia Matrix. The corresponding fields are not editable.

 
14.  Click the Drafting tab in the Properties dialog box.

15.  Specify the properties that should be used for this component when generating views:

�❍     Do not cut in section views: the component will not be cut when projected in section views.

�❍     Do not use when projecting: the component will not be projected in views.

�❍     Represented with hidden lines: the component will be represented with hidden lines.

Note that these properties may be overloaded by editing view properties directly in the Drafting workbench.
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16.  Click OK to validate the operation.

You can keep links while renaming a publication or an instance. It 

 

1.  Checks and stores impacts of the change for publications pointing to this product instance or publication. 
2.  Sets new instance name or publication name. 
3.  Reconnects impacted elements (previously stored results).

Thus you can handle impacts on publication or product instance name modifications.
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Modifying product properties in the visualization mode may lead to a breaking of contextual link. It is recommended to modify 
properties in the design mode to maintain contextual links correctly.
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Managing Graphic Properties in Products 

This task shows you what are the effects when changing graphic properties such as Hide/Show, Colors, Opacity, Width and Line Types:

About Graphic Properties, 
Using Instance / Reference inheritance, 
Using Parent / Child inheritance, 
Combination of Instance / Reference and Parent / Child inheritance, 
New behavior of the Hide / Show functionality.

Modifications of the graphical properties on an assembly node (or on a root product) are not propagated on all children nodes in the Specification tree.

When an object has a specific graphical property, the property is only set on this object (assembly node or root product) and its children get the property 
of their parent by inheritance, which can be seen in the geometry.

For more information about this graphical changes, please refer to Displaying and Editing Graphic Properties, in the Infrastructure User's Guide.

 

About Graphic Properties

 Before:

No Instance / Reference inheritance:

Catia Product Model is a full instance reference model. When inserting a sub-assembly in a product, the structure, and graphic properties are 
duplicated. 
If a graphical property is then modified on the reference, it is not taken into account in the instance. If a graphical property is then set on the 
reference, it is not taken into account in the instance. 
Any modification of the graphical properties on an assembly node is propagated on all the children nodes.

Now:

Instance / Reference for All:

Graphical properties are not duplicated during instantiation, propagated on all children nodes (in the specification tree) and if a graphical 
property is then set on the reference, it is taken into account in the instance (if the instance has not properties set). Children inherit graphical 
properties, which can be seen in the geometry.

The behavior of all graphic properties is now kept and there is:

●     an instance / reference inheritance for all graphic properties.

●     a parent / child inheritance for all graphic properties. When an object has the Hide property, we set the property only on this object and 
its children inherit the property from its parent because of the parent/child inheritance. Therefore they are not displayed even though the 
property has not been set on them.

●     modification of the Hide/Show in order to answer the two previous inheritances.

 Here are examples with the Hide/Show graphic property. However, it is also true with the other properties available in the following toolbar:

 

More precisely, these graphic properties are:

●     Colors,

●     Opacity,

●     Width,

●     Line Types.

Like the Hide/Show property, these graphic properties have instance/reference and parent/child inheritance, and sometimes both.
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About Layers:

You cannot assign a layer number to a product. This property is unavailable in the graphic property toolbar:

Using Instance/Reference Inheritance

Instance / reference inheritance exists when a product (the instance) has been created from another product (the reference) and the instance keeps 
pointing to the reference.

Open Product1bis.CATroduct and Assembly.CATProduct.

The Assembly.CATProduct is made out of a root product called Assembly containing two products (Product1 is instantiated twice) and an Application node.

1.  In Product1bis.CATProduct, set the Hide property on Part1.1 in the context of Product1, the result is as follows:
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Product1 in Product1bis.CATProduct is the reference of the instance Product 1 in Assembly.CATProduct. As a consequence, both instances 
of Part1 (Part1.1) have inherited the Hide property of its reference. Both Part1 (Part1.2) have inherited the yellow color of the reference.  

2.  Set the color to green on Part1 (Part1.2) in Product1 (Product 1.1). 

The green color is not inherited by the reference:

3.  In Product1bis.CATProduct, set the color to purple on Part1 (Part1.2) in Product1 (Product 1.1), the result is as follows:
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 Part1 (Part1.2) in Product1 (Product1.2) inherits the color property of the reference (in Product1bis.CATProduct) because no color attributes were set. 
Yet, Part1 (Part1.2) in Product1 (Product1.1) does not turn into purple because the green color had already been set.

The Hide property has been propagated in Part1 (as shows its icon in the specification tree) and Part1 is not displayed in the geometry.  
In Assembly, Part1 is also instantiated in the second Product1 (Product1.2) and is also set to Hide. If you set Part1.1 to Show in Assembly.CATProduct, 
Part1.1 is displayed but not its reference in Product1.

●     There is an instance/reference inheritance: when the reference's graphic properties are changed, its instances automatically get the same property, 
only if no property has been set on the instance, and whatever the original graphic property of Product1 in Assembly is.

●     If a CATPart is UI active, it is possible to apply Show / No Show on it.

 

 

 

Using Parent/Child Inheritance

Parent/child inheritance is when sub-products inherit the graphic property of their root product or parent.

Open Assembly.CATProduct.

1.  Select Assembly and set it to Hide. 

You will note that there is no propagation of the Hide/Show property on the children in Specification Tree.
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●     The Hide/Show inheritance exists between the product and its sub-products. You cannot display the children geometry, if the parent is in No Show. If 
you want to bring the geometry in Show mode, you need to set the root product (that is the product that owns the Hide property) to Show.

●     Parent/child inheritance has priority on the local properties set on the instance. This is the same for other graphic properties: colors, opacity, etc.

●     When Show/No Show is applied on any object inside the CATPart (Tools, Features, etc), this modification is rejected in the 3D (and the SpecTree too) 
on all the instances of the same part, in all windows if :

�❍     the Product is the UIActivated object,

�❍     the instance of the Part containing the object on which the Show/No Show is applied is the UIActivated object,

�❍     the Part containing the object on which the Show/No Show is applied is the UIActivated object 
When a Part is the UIActivated object, the Show/No Show is not applied to the selected object but it is applied to the instance of the part 
containing the selected object.

2.  Select the first Product.1 and set it to Hide. You can only set this product to Hide and its geometry remains hidden.
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3.  Select Product1 and select Show.  

You will note that the geometry remains hidden:
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4.  If you want Product1 and all the sub-products to be in Show mode, you have to set the root product Assembly to Show.

The parent Hide property is not propagated on children (sub-products), including Application. For your information, you can set the Application node to 
Hide. Even if there is no icon in Hide mode in the specification tree, you can see that the Hide property is effective in the geometry since measures are 
not displayed anymore.
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In case you select a part from the geometry area or from the specification tree and modify its graphical properties, the modification is propagated to the 
product instance. 
For instance, set Part1 under Part1(Part 1.2) to Hide. 

You will note that the Hide property is set on Part1(Part1.2) since it is applied to the assembly, not to the selected geometry.
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Combination of Instance/Reference and Parent/Child Inheritance

This scenario will show you when both an instance/reference and parent/child inheritance is applied for Graphic Properties.

Open Assembly.CATProduct and Product1bis.CATProduct.

1.  In Product1bis (the reference), select Part1 and set it to Hide. Part1 in Product1bis is the Reference of Part1 in Assembly.CATProduct, therefore 

Part1 is now in No Show mode in both products.

The parent/children inheritance has always priority on local properties or on the property inherited from the reference.
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2.  Set Product1.1 (in Assembly) to Hide and you notice that everything is hidden under Product1.1. Part1.2 is also hidden as a result of the parent/

children inheritance.

3.  Select Part1.1 under Product1 in Assembly.CATProduct and set it to Show: the icon of Part1.1 is modified but you cannot see its Geometry 

because of the parent/children inheritance.

4.  In Assembly.CATProduct, set Product1.1 to Show: both instances of Part1.2 and Part1.1 are displayed in the geometry:
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New behavior of the Hide/Show functionality

The possible combinations are:
●     Three states:

�❍     Unset: (Show by default) allows instance/reference inheritance.

�❍     Two overloaded states:
■     No Show/Hide,

■     Show.

●     4 possible transitions:
�❍     Unset > Show,

�❍     Unset > No Show,

�❍     Show > No Show,

�❍     No Show > Show.

●     2 transitions that are not possible:
�❍     Show > Unset,

�❍     No Show > Unset.

The following table illustrates the result of all possible combinations.

Instance Reference Parent Icon 3D

Show

Show or unset

Show or unset

Not dimmed Available

Hide Dimmed Not available

Unset Not dimmed Available

Show

Hide

Not dimmed Available

Hide Dimmed Not available

Unset Dimmed Not available

Show Not dimmed Not available
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Show or unset

Hide

Hide Dimmed Not available

Unset Not dimmed Not available

Show

Hide

Not dimmed Not available

Hide Dimmed Not available

Unset Dimmed Not available
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Naming or Renaming a product 

The first section of this chapter explains about what are the renaming restrictions. The second section explains about how to rename a component (CATPart 
or CATProduct) after its insertion into an existing Assembly and how to solve name conflict.

Renaming Rules
User Interface

Manual Input
Part Number / File Name Differences 
     1st scenario: renaming the Part Number 
     2nd scenario: using Special Characters 
     3rd scenario: using the Backslash 
     4th scenario: unicity
Managing Part Number Conflicts

Renaming Rules

There are some situations in which the User cannot rename the Part Number:

●     Unicity: in a CATProduct, the Instance Name must be unique at one Assembly level. The Part Number must be unique within the complete assembly 
(with only one exception). You cannot enter the same Instance Name as the existing one in the document, at the same level.

�❍     Part Number Conflict window reveals unicity problems.

●     Influence of the Part Number on the name of the document: By definition, the File Name is the name of the Part Number. And if you rename the 
Root's Part Number (and the document is not saved as a file), CATIA V5 tries to change the name of the file that is going to be saved.

●     Neither these special characters "!" and ":" nor an empty name " " and blank character at end of the string should be used in the:
�❍     Instance Name

�❍     Part Number

�❍     Publication.

●     About special characters described in About File Names, in CATIA - Infrastructure User's Guide, you can use them in the Part Number but not in the 
File Name because:

�❍     a default name is attributed to the File,

�❍     or the File Name is automatically truncated before the backslash (backslash is not authorized in File Name), see exact list of restrictions: About File Names.

●     Specific Language characters like  and  (French) for instance cannot be used in the File Name. An error message appears when you try to 
save this File.

User Interface

These renaming rules intervene in:

●     Manual Input: for more information, please refer to Customizing Product Structure Settings.

●     Part Number Conflict window reveals unicity problems.

 
Manual Input

1.  Open a New Product in CATIA V5. Activate the Manual Input setting in Tools > Options > Infrastructure > Product Structure has been activated.

2.  Click on the Part icon and enter a name in the Part Number box. You can see that the name of the file is also Cube1.

3.  Change the Part Number to Parabola1 in the Properties contextual menu. You can notice that the name of the document becomes the same as the Part 

Number name; it is influenced by the Part Number name.
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Part Number / File Name Differences:

1st scenario: Renaming the Part Number

1.  Save this product Parabola1 under the name Cube1: the Part Number is different from the document's name.

2nd scenario: Using Special Characters

1.  Change the Part Number of Parabola1 in the Properties contextual menu into:  (special characters). And you can notice that the name of 

the document remains Cube1 and it no longer corresponds to the Part Number name. Special characters are not supported when saving the document as a file.

For more information about special characters when saving a document, please refer to About File Names, in CATIA - Infrastructure User's Guide.

 
2.  Open the Save Management window (File > Save Management): Cube1.CATProduct appears, the name of the document does not correspond to the name 

of the Part Number containing Special characters.

3rd scenario: Using the Backslash
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1.  Create a New product and give it a name with a backslash: "Cube2\Elementary Source".

2.  Save this product and you will see that all the words before the backslash, and the backslash, are not taken into account.

 

So that the Undo functionality can work properly, a deleted CATIA document remains available in Session.

As it is not possible to save two documents with the same name in the same directory, CATIA V5 sometimes prefers to make the File name 
different from the Part Number.

4th scenario: unicity

1.  Create a New CATProduct: Product1.CATProduct.

2.  Insert 2 New Parts in this CATProduct: Part1.CATPart and Part2.CATPart.

3.  Delete Part2.CATPart:
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4.  Insert a new part: Part3.

5.  Rename Part3 into Part2 via the Properties contextual menu, you will be able to change the part Number but not the Document name (Part3.CATPart). 

A warning appears reminding you that Part2.CATPart has disappeared from the assembly but it still exists in session.

6.  You can also check this by clicking in the menu: File > Save Management.

In one session, you cannot have two CATIA Documents having the same name. This is why the Document Name remains unchanged.

 

 

Managing Part Number Conflicts

Open the Assembly111.CATProduct  document.
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1.  Select Assembly in Assembly111.CATProduct and Insert Assembly222.CATProduct document. For more information about importing a document, see 

Inserting Existing Components.

 

In both Assembly111.CATProduct and Assembly222.CATProduct, some components (Assembly and Last-Component) have the same Part Number, 
which makes the insertion problematic because the entities' Part Number must be unique in the whole document (not only at one Assembly level).

Therefore, the Part Number Conflicts dialog box is displayed:
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This table exposes the name conflicts between Assembly111.CATProduct and Assembly222.CATProduct. It provides details about:

●     Part Number: the Part number of the component generating the conflict.

●     Selected File: references of the imported document.

●     Document generating the conflict: the position and name of the document generating the conflict.

●     Already imported file: source already existing (with the same Part Number as the imported component) inside the root product.

●     Status: not solved, when 2 components have the same Part number.

The Reconnect... button is activated when the imported component has the same geometry as the one in the original document.

In a CATProduct, the Part number must be unique at every level in the specification tree. The Part number's unicity is applied to the whole document.

2.  The solution is to rename the component generating the conflict: Select a line corresponding to a conflicting component and click the Rename... button 

to display the Part Number dialog box. You can enter a new name, for instance  "AssembElements" to replace "Assembly":

Once you have renamed this component, the Part number conflicts dialog box is updated; the status of "AssembElements" (former "Assembly") is 

then: Renamed. Thus the Part Number conflict with Assembly in assembly222.CATProduct is resolved:

You can do the same with the last two conflicts: Last-Component and Component3, and you will obtain for instance:
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3.  Click OK to validate the operation and the conflicting components does not exist anymore; the new Part Numbers are now displayed in the specification tree:
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The conflicting names are automatically changed in Assembly111.CATProduct.

There is an exception:

A local reference such as HANDLE (HANDLE.1) can have several occurrences with the same Part number, provided that both occurrences stand on a 
different assembly level. In our example, HANDLE (HANDLE.1) appears at 2 levels. For local references (.model, .cgr), the unicity rule is applied to one 
Assembly level only.

As for the Instance Name, it must be unique at one Assembly level. You can find the same instance name in a CATProduct, but not in an Assembly level.

4.  If you try to copy the HANDLE.model and paste it into the same document Assembly111.CATProduct, under AssembElements, its Instance Name 

is automatically converted into HANDLE (HANDLE.2).

However, its Part Number remains similar because it is a new instanciation of the local reference HANDLE.

It is possible for you to change again the Instance Name of this component, but you have to respect the unicity rule. For more information see 
Modifying Component Properties.
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5.  If you try to insert HANDLE.model in Assembly111.CATProduct, the following Part number dialog box appears:

You can either Rename or Reconnect Document generating conflict:

●     Rename the Document generating conflict : if the inserted component is different from the one in the already existing document. Therefore, 
you create a new local reference in the document.

●     Reconnect the Document generating conflict : if the inserted component is the same as the one in the already existing document. As a 
consequence, you create a new instanciation of the existing local reference. It is the same process as when copying and pasting HANDLE 
(HANDLE.1).

6.  If you choose the Rename... button, "HANDLE" can be renamed with "AXIS".

The status of the inserted document has been modified and the Part number conflict is resolved:
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You can visualize the adjustment in the Specification tree:

7.  If you click the Reconnect... button (instead of Renaming), it has the same effect as copying and pasting the .model, HANDLE (HANDLE.1), into the 

same document, Assembly111.CATProduct : you create a new instanciation of the existing local reference.

And its Instance Name is automatically converted into HANDLE (HANDLE.2). See the Assembly111.CATProduct picture above.

The process of renaming a CATPart is the exactly the same, except that you are not allowed to insert a CATProduct into a CATPart.
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For more information about the options for Part number definition (Manual Input), see Defining the Default Part Number of the Component to be Imported. 
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Generating Numbering 

This task shows you how to number the components of an assembly.

Numbering components is possible provided these components are associated to representations. 
Open the ManagingComponents01.CATProduct document.

Note that numbering is applied first on parts in the current product and then on parts in its sub products.

1.  In the specification tree, select ManagingComponents01.

2.  Click the Generate Numbering icon . The Generate Numbering dialog box is displayed.

There are two ways of numbering components:

�❍     either you check the Integer option

�❍     or the Letters option.

Moreover, if you need to number an assembly with already existing numbers, you can Keep or Replace 
these numbers by checking the corresponding options.

3.  Click OK to confirm the operation. 

Note that you can consult these numbers in the Product tab displayed by the Properties command, or in the 

Listing Report tab and in the Recapitulation of the Bill of Material.

Limitation for Generate Numbering for CATIA V5 ENOVIA LCA 
Interoperability.

 Generate Numbering functionality is not available when the product is saved in ENOVIA in Structure exposed storage 
mode.
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Displaying the Bill of Material (BOM) 

 This task shows you how to display the number and name of the components belonging to the active component as well as the properties of 
these components. It also shows you how to save this data.

 
You can display the bill of material of the active component only. 
Open the AnalyzingAssembly01.CATProduct document.

 
1.  Select Analyze > Bill of Material.

The Bill of Material dialog box is displayed. It is composed of two tabs:

�❍     Bill of Material,

�❍     Listing Report.

The Bill of Material tab shows the different parts and sub-assemblies of AnalyzingAssembly01 which is the active component.

When generating a BOM of a product containing more than 200 parts, the following information message is displayed:  
The BOM was voluntary restricted to the first 200 displayed results. You can retrieve the entire BOM by saving it as text for example. 
 

 The Bill of Material does not show the possible representations associated to the components.
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There are three main sections:

●     Bill of Material: lists all parts and sub-products one after the other,

●     Recapitulation: displays the total number of parts used in the product AnalyzingAssembly01.CATProduct,

●     Define formats.

2.  Click Save As... to save this data. The Save Bill of Material As dialog box is displayed. Three document formats are available: .txt as 

text format, .html as html format and .xls as Excel format.

3.  Select the appropriate directory and enter a name in the File name field. Note that the file generated will contain the date of 

generation. For instance, if you selected the .txt format, the document looks like this:

4.  Now click the Define formats button to customize the display of your bill of material. A new dialog box appears, indicating the 

default format, i.e. AP203 format.
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5.  To create the format of your choice, click on Add. Format.1 then appears in the Selected Format.

 
The Remove button is used for removing already existing formats.

 
6.  You can display the directories used for your assembly by clicking the Search order option. For more about the Search Order 

capability, please refer to CATIA- Infrastructure User's Guide.

7.  Now, choose the properties you wish to display in the Bill of Material section of the Bill of Material dialog box. To do so, for example, 

select Source from the list Hidden properties and click the show properties icon  to move Source into the Displayed properties 

section.

 Likewise, double-clicking a property moves this property into the section opposite.
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8.  Repeat the operation by adding Description to the Displayed properties section of the Properties for the Recapitulation frame.

The buttons you can use are the following: 

  moves the selected property to the right scroll list

  moves all properties to the right scroll list

  moves the selected property to the left scroll list

  moves all properties to the left scroll list

  moves the selected property within the scroll list.

 
9.  Click OK to validate the creation of the new format. The Bill of material: Display formats dialog box is closed.

 You cannot save the formats you create. Customized formats are specific to your CATIA session.

If you want to add numbers in the Bill of Materials, you need to:

●     open the CATProduct,

●     select the CATProduct after having launched the Generate Numbering functionality,

●     click OK to generate a standard Numbering,

●     then, open the Analyze > Bill of material. Select the Define formats button and the Bill of Material: Define formats dialog box is 
displayed,

●     in the section called Properties for the Recapitulation, add the "Number" property to the displayed properties.

The recapitulation list resulting in the Bill of Material is in the wrong order according to the number, because numbering is applied first on 
parts in the current product and then on parts in its sub products. 
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 The Bill of Material now looks like this:
 

 The Default Representation Source property is the source of the default shape document. This property allows to show the 
path to the file that contains the default shape associated to the product node.

The Type property allows you to discriminate products according to the following condition: if they are Assemblies or nodes with 
no son.

The Quantity property allows you to distinguish products according to the number of Instances that are contained in the 
Assembly.

In this case the Default Representation Source of an instance of a CATPart is the CATPart document file path.

Some nodes may have a default representation, others none. It can be void for nodes (assembly parts) without any attached 
representation, as in the example below:
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10.  Click the Listing Report tab. It displays the tree of the product using indents, just like in the application.
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11.  Check the Display search order option if you wish to display the directories where the different documents making up the 

assembly are located.

12.  To display other information in your report, select the properties of your choice in the Hidden properties scroll list and use the 

buttons as previously described to move these properties to the left.

13.  To see the result, click Refresh.

14.  Use Save As... to save the report in the directory of your choice. Only .txt format is available.

15.  Click OK in the Bill of Material dialog box to exit.

 To know how to use your bill of material in your CATDrawing documents, please refer to Adding a Generative Bill of Material in CATIA - 
Generative Drafting User's Guide.
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Managing the Bill of Material (BOM) 

 This task shows you how to customize the Bill of Material window. You can change the name of the buttons, the 
titles and the size of the columns. It also shows you how to save this data.

You can modify the structure of the Bill of Material window in the CATAsmBom.CATNls file and the size of the 
columns in the CATAsmBom.CATRsc file.

On Windows, both files are under your CATIA installation directory: ("n" is the number of the release level) 
...\DownloadofCXRnrel\intel_a\resources\msgcatalog\CATAsmBom.CATNls (on Windows)

On UNIX, the location of these files is under your CATIA installation directory as well : 
...\DownloadofCXRnrel\solaris_a\resources\msgcatalog\CATAsmBom.CATNls (for SUN) 
...\DownloadofCXRnrel\irix_a\resources\msgcatalog\CATAsmBom.CATNls (for SGI) 
...\DownloadofCXRnrel\aix_a\resources\msgcatalog\CATAsmBom.CATNls (for AIX)

1.  In CATIA contextual menu, click on Analyze > Bill of Material...:

The BOM dialog box appears:
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2.  Open  the CATAsmBom.CATNls file in WORDPAD or NOTEPAD.
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For instance, you can replace :

�❍     the title name "Bill of Material:" by "BOM:"

�❍     the title name "Total parts:" by "TOTAL:"

�❍     the title name "Quantity" by "Number"

�❍     the button name "Define formats" by "FORMATS"

Save the CATAsmBom.CATNls file with the same name and under the same directories.

Close the CATIA session in order to synchronize the last modifications and re-open it.

In CATIA contextual menu, click on Analyze > Bill of Material... :

In the BOM dialog box, you can visualize the changes:
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The modifications are saved in the CATAsmBom.CATNls file and they are visible in the BOM window.

3.  Open the CATAsmBom.CATRsc file.
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This file allows you to change the size of the columns (the number of characters per column) in the document (.txt 
document, for instance) generated by the Save as operation in the BOM window. It has no impact on the BOM 
window.
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4.  For instance, change the characters' number in the Part Number column: from 20 to 10. And reduce the 

size of the Type column : from 10 to 5 characters.

5.  Save the CATAsmBom.CATRsc file with the same name and under the same directories.

6.  Click on the Save as button in the BOM window in order to be able to read the information in a .txt 

document for example.

7.  Open the .txt document in which the last modifications are visible:

You can compare the size of the columns with the original document in Displaying the Bill of Material.

This operation allows you to adapt the table to the length of the data and to keep the information on a 

single line.
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Capability Not To Take into Account A Component in BOM 
Extraction 

 This task shows you how to not display the number and name of the components belonging to the active component in the Bill of 
Material.

Open the ExtractBOM.CATProduct document.

 
1.  Select subproduct2.CATProduct, right-click it and select the Properties contextual command. The Properties dialog box is 

displayed:
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2.  Uncheck the option Visualize in the Bill of Material so that subproduct2 and its child, Cube1, does not appear in the Bill of 

Material dialog box. This option is a means to choose the objects you want to visualize in the Bill of Material dialog box (in 

the Bill of Material and Listing Report tabs).

3.  Click in the menu bar: Analyze > Bill of Material and the Bill of Material dialog box is displayed:
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First of all, in the Bill of Material of RootProduct, you can see subproduct1, which is normal because RootProduct has only one 

child. 

 
Secondly, in the Bill of Material of subproduct1, you can only see Hole1 but not Cube1 because you had decided not to visualize 

subproduct1 and implicitly its child, Cube1. Subproduct1 has two direct components, subproduct2 and Hole1, but only Hole1 is 

present in the Bill of Material.

4.  Now check the option Visualize in the Bill of Material in subproduct2's properties to go back to the initial state.

5.  Select Cube1, right-click it and select the Properties contextual command. Uncheck the option Visualize in the Bill of 

Material so that Cube1 does not appear in the BOM of subproduct2.
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First, in the Bill of Material of RootProduct, you can see subproduct1. 

 
Secondly, in the Bill of Material of subproduct1, you can only see subproduct1 and Hole1 but not Cube1 because you had 

decided not to visualize Cube1. 

 
Thirdly, in the Bill of Material of subproduct2, you cannot see its child, Cube1, because it was specified in the Part's properties 

with the unchecked option: Visualize in the Bill of Material.

If you want a Product to be seen in the BOM but not its children, therefore this Product will appear in the summary list of the BOM 
because it becomes a Terminal Node.
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Searching on BOM Attributes

 This task shows you how to search information belonging to a CATIA document. It also shows you how to save some favorites 
containing the Search results.

Open the ChangeCtx.CATProduct document.

 
1.  Select Edit > Search. Press the Advanced tab. The Search operation works on the activated CATIA document.

In the Search dialog box, choose the following terms in the fields:
�❍     Workbench: Product Structure,

�❍     Type: Product,

�❍     Attribute: Part Number. The Attribute Criterion is displayed.

2.  Enter the data you are looking for in the Attribute Criterion dialog box (for example: Pic1) and click OK.
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3.  In the Search dialog box, the Search equation is automatically copied in the free text field: 'Product Structure'.

Product.'Part Number'=Pic1.

4.  Press the Search button  and the results are delivered, giving the name and path of the object(s) found:
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5.  If you want to visualize the element(s) found in the CATIA document, press the Select button at the bottom of the 

Search dialog box. As a consequence, Pic1 (Pic1.1) is highlighted in the specification tree:
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6.  If you want to look for an attribute that is not in the list, you can reiterate the selection of the terms Product 

Structure / Product / Part number. Enter the same Attribute's criterion: Pic1. Therefore, you have an equation that 

you can modify manually in the Search dialog box. 

For instance, to look for a Price, transform "Product Structure".Product."Part Number"=Pic1 by "Product Structure".

Product."Prix">5:
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7.  Click Search and you can see the Query results: 2 components have been found with the same particularity, they all 

have a price superior to 5.
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To find these elements in the Specification Tree, you can either press the Select button or click on the Upper.1 and/

or Pic1.1 lines.
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8.  You can create favorites for each search by clicking on the Add to favorites... button  and this window is 

displayed to confirm your choice:

Click OK. This is a means to keep in memory the Search results and to have access to them with you select the Edit  

Search command and press the Favorites tab. 

The favorites (name and equation of the query) are listed in this window and you have access to the object's 

characteristics (name and path) by double-clicking on the line of your choice.
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Managing a Resource thanks to Resource Modeler

This task consists in managing Resources within the CATProduct's properties, thanks to the Resource Modeler 
framework available in CATIA Version 5. This is a means for the user to get information about the interfaces' 
methods and functions.
You can create Resources within a CATProduct that is to say you can allot a particular behavior to the product. The 
product's behavior is therefore modified and adheres to new interfaces.

Open the Assembly01.CATProduct document:

1.  Select the icon Create a Resource  in the Resource toolbar:

The following dialog box is displayed:

2.  Choose the Type of the Resource in the following list and select the Category of the Resource : Physical or 

Organizational:

3.  Click on OK. This message confirms the operation:
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You can either activate  or deactivate  the Resource description. If you click on the activate icon, you will 

have access to an existing Resource within the Product's Properties dialog box. There is additional information in 
the Properties dialog box, in the Resource tab.

4.  Right-click the Product, select the Properties contextual command and the Properties dialog box appears.

5.  Click on the More button in the Product's Properties dialog box and the Resource tab appears:
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You can find precisions about the resource: the Product's name and the resource category.

It is possible to specify the name, category and the MTBF (Mean Time Between Failure) and MTTR (Mean Time To 
Repair) parameters within this window (Edit > Properties command). These parameters are attributes for the 
resource.

The access to the Resource properties activates the resource -whatever the status of the resource is: 
activated or deactivated- and shows its characteristics in a resource tab, in the properties window.
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Interactive Design

3D Insight offers a subset of Interactive Design product without the capability to save the imported data and to export in 
any 2D format.  
The table below lists the information you will find.

Copy/Paste a View in a Part

 A view copied from Drafting, then pasted to a Part, becomes a sketch.

●     If a 3D plane is selected before pasting the view, the sketch follows the 3D plane.

●     If no 3D plane is selected before pasting the view, the sketch follows the plane of the copied view.

Importing From Files
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Importing From Files 

This task explains how to import a file into a CATDrawing.

1.  Select Tools > Import From File... 

The Import dialog box is displayed.

2.  Define the path of the file in the Look in box.

3.  Select the convenient format in the Files of type box.

4.  Click Open.
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More About Import
You can import the following formats: 

●     .3dxml

●     .dwg

●     .dxf

●     .cgm

●     .ps

●     .svg 
 

3dxml 
●     The 3dxml file contains the description of the sheets and views (their name, position, angle and scale) but no semantic information 

about elements in the view. So, elements are displayed in a graphical format.

●     Imported generative views are converted into interactive views. 

●     All the new sheets that are added during the import are created with the same format as the current sheet (the one that is active 
when the command is executed). 

●     Pictures (bitmap or vector) are imported as an empty rectangle.

To know more about 3dxml format, you can refer to 3dxml in the Infrastructure User's Guide.   

 

DXF, IG2 (2D IGES)

The import of these formats is documented in the Data Exchange Interfaces User's Guide. 
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IGES and STEP Interfaces

3D Insight offers a subset of IGES and STEP Interfaces: you can import data but you cannot export data. The table below 
lists the information you will find.  
The table below lists the information you will find.

3D IGES Import

3D IGES Import 
Trouble Shooting 

Best Practices 
FAQ 

VBScript Macros 

STEP Import

STEP Import 
Trouble Shooting 

Best Practices 
FAQ 

VBScript Macros 

Customizing

IGES 
STEP 
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IGES: Import

This task shows you how to import into a CATPart document the data contained in an IGES file.

Once imported, the data can be handled just as if it were created as a CATPart.  
The main purpose of such an import is to be able to create shells from IGES faces but you may also find it  
useful for re-using face contours in the Sketcher application, deforming NURBs in Generative Shape Design or  
using faces in other V5 applications.
The table entitled What about the elements you import ? provides information on the entities you can import.  
You can find further information in the Advanced Tasks: 
●     Trouble Shooting,

●     Best Practices,

●     FAQ,

●     VBScript Macros.

and in the Customizing 3D IGES Settings chapter. 
Statistics about each import operation can be found in the report file created. 
The function "Insert / Existing Component" for IGES files is provided by the MULTICAx IGES plug-in  
and requires a MultiCad license.  

1.  Select the File > Open command. 

The File Selection dialog box is displayed. 

2.  If the directory contains many different types of files you may wish to set the .igs extension in the Files of type field.  

This displays all files with the extension "igs" contained in the selected directory.

●     In V5, both files with the extension "igs" and IGS can be imported to a CATPart document.

●     Whereas the path of an IGES file to import may contain non-ASCII characters, the name of the file itself must contain only ASCII characters.

 
3.  Select the .igs file of your choice and click Open.

A progress bar is displayed.

You can use the Cancel button to interrupt the transfer at any time. 
The conversion is then interrupted (after the processing of the current independent entity) and the partial conversion already performed is displayed in the 
V5 session.
This creates a new document similar to a CATPart document in all respects and containing all surfaces  
and 3D wireframe geometry. The data is now available in your session.
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�❍     Some invalid geometries may be detected.

�❍     The reference planes are hidden at import.

Several 3D IGES import options can be customized: 
●     Display of the Completion Dialog Box

●     Import mode to import large files containing 308/408 entities.

●     Join, to join surfaces in the model you import.

●     Continuity optimization of curves and curfaces to optimize curves and surfaces.

●     Detection of invalidity in input geometry.

●     Representation for boundaries of faces.

●     Import Groups to activate or de-activate the creation of Selection Sets.

Report File

After the recovery of 3D IGES files, V5 generates:

●     a report file (name_of_file.rpt) where you can find references about the quality of the transfer 

●     and an error file (name_of_file.err) .

These files are created in a location referenced by  

●     the USERPROFILE variable on NT. Its default value is  
Profiles\\user\\Local Settings\\Application \Data\\Dassault Systemes\\CATReport on NT (user being you logon id)

●     the HOME variable on UNIX. Its default value is $HOME/CATReport on UNIX. 

Always check the report and error files after a conversion !  
Some problems may have occurred without been visually highlighted.
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Example of a report file: 

Example of an error file: 
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Report messages
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 Here are some of the messages that may appear:
●     Too many cuts on face boundary.  

Tip : Use topological reduction option (in IGES) or curve optimization (in IGES or STEP) - see User's Guide 
These options are accessible via the Tools/Options/Compatibility/IGES or  
Tools/Options/Compatibility/STEP dialog boxes, in the Continuity optimization of curves and surfaces section.  
Select the Advanced optimization option and push the Parameters... button.  
For more information, click on the link on IGES above.

 When the Continuity optimization of curves and surfaces/Advanced optimization option  
in Tools/Options/Compatibility/IGES is active, the following warning messages may appear in the report file:
●     The BSpine Surface is not C1: Approximation of the surface is impossible! 

This is just a warning, the surface is imported but is not approximated.

●     The deformation found of the surface approximation (which is calculated by isoparameters) is : xx millimeters. 
This indicates that the real deformation found is higher than the Deformation value you have entered in  
the Parameters box and that the approximation could not be performed. When this occurs for several entities,  
you will find the following information message at the end of the report file:

●     For a better approximation of BSpline surfaces, you can use a "Curves and surfaces approximation"  
Deformation value of at least : xx millimeters 
You can enter this value in the Parameters box of the  
Continuity optimization of curves and surfaces/Advanced optimization option in Tools/Options/Compatibility/IGES. 

Invalidity in Input Geometry
 When invalidities are detected in the input geometry, all the invalid faces  

(and all the elements of their geometry)  
are put in a specific Geometrical set named invalid Input Geometry.  
These faces are shown as invalid in the report file. 
For each invalidity detected, a specific label points to the face concerned.   
These labels are put in an Annotation Set.xx. 

●     Deleting an invalid element does not automatically delete the corresponding Annotation Set.

●     Only one feature Annotation Set is created at the root of the specification tree, with all the invalidity descriptions.

●     Annotation Sets are not exported to IGES, but they can be saved in the CATPart.

What about the Elements You Import? 
The following points should be remembered: 
●     The IGES standards 5.2 and 5.3 are supported. The latter is year 2000-compliant. The IGES standard 5.3 is downloadable from http://www.uspro.org/

documents/.

●     Trimmed and bounded surfaces are transformed into faces.

●     Solids and volumes are imported as joined shells as well as text, annotations and 2D geometry are not converted.

●     The tolerance used is the default tolerance defined in the Part Design session.

●     Properties such as the original colors, the show status, names (if they exist) are maintained in your session.

●     IGES files must contain only ASCII 1-byte characters.

 

Processing of layers:
●     If the IGES file contains a layer 10000, this layer is tranlated into layer None in V5. 

●     A layer with a name greater or equal to 1000 is translated into a layer named with the last three digits, e.g. layer 3250 is translated into layer 250.

Processing of names: 
●     Non ASCII characters are replaced with 1-byte characters, either a similar one, e.g. a 'e' with an accent is replaced with a plain 'e' (with no accent), or by an 

em dash '_'.

●     If an IGES entity has a pointer to a "Property Name Entity",  
the value of this property will be assigned to the name of the V5 entity.

●     If the IGES entity has no pointer to a "Property Name Entity" and  
if its "Directory Entry" field #18 is not blank the V5 name will be computed  
by appending field #18 and #19 of the  "Directory Entry". 

●     If the entity has neither a "Property Pointer" nor a non-blank field #18 an automatic name will be generated.

 

●     Product Identification for Receiver (Global Section, Field #12) will be used as  
the Part Number in the Product Properties and as display and storage names in V5.  
For example, if the file MyFile.igs has a product identification IGES_Sample,  
the storage name will be IGES_Sample.CATPart (not MyFile.CATPart)
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Processing of Group Associativity: 

The Group Associativity, in the IGES Norm, is mapped with the type 402 (ASSOCIATIVITY INSTANCE ENTITY). 
There are four form numbers which specify group associativities :

Form Meaning

1 Unordered group with back pointers

7 Unordered group without back pointers

14 Ordered group with back pointers

15 Ordered group without back pointers

For each Group Associativity pointing to a list of entities in the IGES file, a selection set is created.  
This selection set is named with the name of the pointed GROUP entity and includes all pointed entities.

●     This applies to known Group Associativity forms (Type 402 - forms 1, 7, 14 and 15) only.   

●     A Selection set pointing to another Selection set cannot be created. 

●     When a group is pointed by a second group, the entities of the first group will be pointed by a first  
Selection set (mapping the first group) and by a second Selection set mapping the second group  
(including others entities of the second group). 

●     Only logically dependant IGES entities (Status Number 3-4 = "02" in D.E. section) can be mapped in a Selection set.

●     The Import Group option activates or de-activates the creation of Selection Sets.

Processing of 308/408 IGES entities
●     If the Map the 308/408 IGES entities onto a Product Structure is not selected, elements contained in  

dittos are imported as simple elements (dittos are exploded). 

●     If the Map the 308/408 IGES entities onto a Product Structure is selected, it creates a Product Structure.

●     In addition, when selected, it deactivates the mapping of groups to Selection Sets. 

Processing of trimmed surfaces 

IGES Trimmed surfaces are defined by a support surface and one or more boundaries. 

For Trimmed parametric surfaces, the curves of boundaries can have two representations: one in the model space (3D curves) and another in the 
parametric space (2D or P-Curves). 

3D Curves can be used on every type of surfaces.  
2D curves can be used on B-Spline surfaces (IGES type 128), Ruled surfaces (IGES type 118 - if the surface is continuous in curvature and not closed) 
and Revolution surfaces (IGES types 120/122);  
2D curves must be parametric lines (IGES type 110) or P-Nu(r)bs (IGES type 126). 

The choice of the curves representation to process depends on the user preferences and on the IGES file contents. In some IGES files, a representation can 
be incorrect. 

See Representation for Boundaries of Faces in IGES customizing section to learn more about the management of boundaries representations.

 

To make sure the elements you need to handle in your session are those you expected,  
here is a list presenting the IGES data supported when imported into a CATPart document:

 IGES Element V5 Element Notes

 null 0

 circular arc 100 circle

 composite curve 102 curve, line, circle

 conic arc - ellipse 104 form 1 curve

 copious data

106 forms 1-3 cloud of points 
The generic display name of such elements in V5 can be Geometrical 
Element106 forms 11-13, 

63 curve (polyline)

 unbounded plane 108 form 0 plane

From V5R12, even independent planes 108 form 0 are imported.

Independent planes 108 form 0 will be displayed as a small square in V5

 bounded plane 108 form 1 plane

 line 110 form 0 line

 semi-bounded line 110 form 1 line

 unbounded line 110 form 2 line

 parametric spline curve 112 curve

 parametric spline surface 114 surface
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 point 116 point

 ruled surface 118 surface

 surface of revolution 120 surface

 tabulated cylinder 122 surface

 direction entity 123 direction  

 transformation matrix 124 matrix

 rational B-spline curve 126 curve

 rational B-spline surface 128 surface Rational B-spline surfaces are also recognized as planes or cylinder 
according to their geometrical properties..

 offset curve 130 curve, line, circle

 offset surface 140 surface

 boundary (of skin) 141
either included in the translation of a bounded 
surface, or curve, line, circle if the transfer of 
the bounded surface has failed

If the surface is not of type BSpline and C2 continuous, only the Geometry 
type curves "Curve on a parametric surface" and "Boundary" are taken into 
account for face creation. 2D Parametric type curves are ignored.

 curve on parametric surface 142
either included in the translation of a trimmed 
surface, or curve, line, circle if the transfer of 
the trimmed surface has failed

If the surface is not of type BSpline and C2 continuous, only the Geometry 
type curves "Curve on a parametric surface" and "Boundary" are taken into 
account for face creation. 2D Parametric type curves are ignored.

 bounded surface (of skin) 143 surface

 trimmed (parametric) surface 144 surface

 

manifold solid B-rep 
(consisting of shell 

face 
loop 

edge list 
vertex list)

186 form 0 
(514 form 1 
510 form 1 
508 form 1 
504 form 1 
502 form 1)

joined shell

Creation of a geometrical set or PartBody per shell.

Creation of a PartBody if the shell is closed. 

 plane surface entity 190 form 0-1  All the surfaces are faces support surfaces : they must be used with entities 
of type 143, 144 and 510. 

Those surfaces are infinite (not limited). 

If a face, supported by one of those surfaces, cannot be correctly imported, 
the "invalidFace" created by V5 and containing surfaces and curves could 
present visualization problems on infinite surfaces graphic representation. 

 right circular cylindrical 
surface entity 192 form 0-1  

 right circular conical surface 
entity 194 form 0-1  

 toroidal surface entity 198 form 0-1  

 subfigure definition (detail) 308 see singular subfigure instance

 color definition 314 color

 associativity instance (group) 402 forms 
1,7,14,15 selection set See the Group Associativity

 singular subfigure instance 
(ditto) 408 simple elements or CATParts See the processing of 308/408 IGES entities.
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3D IGES: Trouble Shooting

Import
This task shows you how to recover on transfer failures or limitations after importing the data contained in an IGES file into a CATPart document.  
Once imported, the data can be handled just as if it were created as a CATPart. Sometimes, some entities are degenerated during the transfer and it is 
characterized by a loss of geometry. In this case, the missing geometry must be re-created.

In this tutorial you are going to learn how to: 

●     Open an IGES file

●     Repair KO Faces

The whole scenario is built up with IGES data but it can also be performed with a STEP file. And if you want to know more about STEP characteristics, see 
STEP: Trouble Shooting  

Open the IGES file
1.  Open the IGES file FaceKO.IGS into your desktop.

2.  When you open this document, the conversion of the IGES file is progressive and you can visualize the process through this panel:

3.  Eventually, once the transfer is completed (see Show/NoShow Completion Dialog Box for more details), a message similar to this one appears: 

4.  Click OK to continue.

5.  All the faces reported as KO are put in the geometrical set GeometryFailure.

For each face KO, you will find a FaceKO.xx geometrical set under GeometryFailure. This geometrical set contains the geometric elements of the face. 
By default it is sent to the NoShow. 
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Repair KO faces

1.  Recall FaceKO#BND_SRF1 from the NoShow and expand it if necessary.  It contains the support surface and boundary curves corresponding to the 

face.  

The reason of the failure is that the inner boundary is described before the outer boundary, in contradiction with the IGES standard.  

2.  In Generative Shape Design (for example), select the Join icon . 

3.  Select the curves of the outer boundary:

Click OK. A Join.1 is created under FaceKO.1.

4.  Repeat this step with the curves of the inner boundary:
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A Join.2 is created under FaceKO.1.

5.  Select the Split icon .

6.  Select the surface and Join.1

7.  Push the Other side button to keep the inside of the surface.
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8.  Click OK. The surface is split by the outer boundary. Split.1 is created under FaceKO.1.

9.  Repeat this step with Join.2 and Split.1
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Split.2 is created, corresponding to the repaired face.

Before splitting the surface, as no associativity is needed, you can use the Create Datum mode by selecting the Create Datum icon.  
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9.  If necessary, you can move the result surface Split.2 to another geometrical set: Right click the result surface and select Split.2 object > Change 

geometrical set... to move the resulting surface to another geometrical set.

The following dialog box opens. Choose the destination geometrical set: 

10.  Delete the FaceKO#BND_SRF1 geometrical set. All these elements are however present within the No Show space.

Another possible cause of failure:
The splitting operation has kept the wrong side of the boundary.

●     Recreate the correct face by Fill  (in datum mode).  

As a result, a Surface.xx is created. 

You may also extract the surface boundary and untrim the surface to use Split.

You are now ready to create the topology. For more information: 
●     please refer to the next chapter entitled IGES: Best Practices - How to create a topology

●     or use the application Healing Assistant for more complex cases.

Export:
Exporting V4 data does not provide the expected result: data placed in the NoShow in V5, or changes of colors or graphic attributes are not taken into account, 
e.g. if you have sent a V4 element to the NoShow, it will be kept since it is its V4 status that is taken into account. To make those changes effective, you need 
to make those changes in a V4 session, save the data in V4 and re-import them to V5. 
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3D IGES: Best Practices

Import

Quality of conversion
Always check the report and error files after a conversion !  
Some problems may have occurred without been visually highlighted.

 The Detection of Invalidity in Input Geometry  option is used to detect:

●     the 3D curves of the loop boundary do not map with the support surface. 

●     the single loop (boundary of the surface) presents a hole.
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●     two other cases of invalidity:
�❍     The boundary and the surface are not in the same plane (a transformation matrix is missing).  

Apply the required transformation, join the boundary and split the surface with the result join.

●     The single boundary is open (a curve is missing). Hide the surface and re-create the missing curve.  
Then join all the curves and project them on the surface to split the surface.
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How to Create a Topology
This task shows you how to generate the model topology if it is not contained in the CATPart corresponding to  
the original IGES file you have imported. 
You have seen how to recover a maximum of the face geometry and individual topology, when it failed during  
the import of either IGES. 
This scenario will show you how to create solids from IGES faces and also how to join the surfaces of an IGES  
model into a Part.  
It also shows you how to improve the quality of the geometry of the solid obtained thanks to the Healing operation  
in Generative Shape Design. I 
Therefore, this methodology allows you to improve IGES data interoperability and productivity (use of features). 
It can also be applied to a STEP file, when the failure of the topology transfer occurs (in rare cases) and  
to improve geometry quality.

Previously, you had 2 scenarios about the repairs of KO faces: 
●     Open an IGES file

●     Repair faces KO

Now, with the following steps you will learn how to close the topology: 
●     Create a topology

●     Analyze the topology

●     Healing

●     Create a solid

Create a topology
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1.  Open the file 01_FaceKOrepaired.CATPart. 

2.  Select all surfaces of GeometricalSet.1 in order to apply the Join operation upon all these elements.  

The Join operation allows to repair geometry whereas topological healing allows to close topology.

It is better to select the surfaces in the tree  
(select Surface.1, then select the last surface holding the Shift key)  
to have them ordered by their numbers in the Join Definition dialog box.

3.  Keep merging distance = 0.001mm and deactivate the connexity Check option.  

The problem is not yet to check whether the surface is closed or even connex.  

This will be analyzed in the following step.
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4.  Click Preview.  

An error message is displayed, saying that some surfaces cannot be integrated to the join.

The solution is to withdraw these surfaces. 

5.  The rejected surfaces are automatically selected in the list, in the Join Definition dialog  

box and you can use the Remove Mode button.

6.  Click Apply.

7.  Click OK. The resulting join surface includes all surfaces of GeometricalSet.1 except  

those that have been rejected.

8.  Insert a new Geometrical set and name it SurfacesToAnalyze (for example).

9.  Move the rejected surfaces to the new Geometrical set. For this, right click them in the  

No Show space and  

select the Change Geometrical set... contextual command.
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10.  Hide GeometricalSet.1 and display the other geometrical set SurfacesToAnalyze.

11.  Check the rejected surfaces. Usually rejected surfaces have a very sharp corner, for instance,  

a vertex where edges arrive tangent to each other.

12.  Reframe on the first surface to recreate (Surface.321 for instance):
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13.  Create its complete boundary by selecting the Boundary icon  in the Operations toolbar.

14.  Disassemble the boundary in order to be able to see the curves by using the Disassemble  

icon  in the Join-Healing toolbar. As a result, details about the curves contained in Surface.321  

are displayed in the Specification tree.

15.  Untrim the surface to process (Surface.321) by clicking on this icon   Click OK when this message appears : 

A new element is displayed : SurfaceUntrim.1
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16.  Recreate the face by Split between Surface.710 and Curve.1, Curve.2 and Curve.9.
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17.  Join Curve 4, 5, 6 into Join.2

18.  Split the surface (in datum mode) with:

�❍     Element to cut: Split.1.

�❍     Cutting element: Join 2.
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Repeat the same operations with the other rejected surfaces. You may also recreate only two of 
them  
and use asymmetry for the other two.

19.  Double click Join.1 (in GeometricalSet.1) to edit it and select the four corrected faces to add them  

to the list (Add Mode):

20.  Click OK.

All the surfaces are now inserted into the join: the topology is complete. You can now delete SurfacesToAnalyze.

Analyze the topology
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1.  Open the file 02_InitialTopology.CATPart.

2.  Activate the Surface boundary display option: select the Tools > Options... command,  

click General > Display in the list of objects to the left of the Options dialog box. Select the Visualization tab.

The Analysis is based on the free sides of the surface. Free sides may indicate: 
●     gaps between elements

●     missing elements (not converted or not available in original IGES file)

●     overlaps (duplicated elements)

●     invalid elements (with unexpected shapes)

 
3.  Double click the join surface Join.1 in the GeometricalSet.1 to change its merging distance parameter.  

Set it to 0.01mm (maximum possible value).

 

3D Insight Version 5 Release 19 Page 243 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/itfug_C2/samples/02_InitialTopology.CATPart


Increasing the merging distance will reduce the number of free sides due to gaps.  
It is a way to highlight the most important holes.

 
4.  Click Preview, then OK.

Few free sides remain: three on the top surface and two on the sides (symmetric to each other).  
Now you have to find the type of free side (gap, missing element, overlap, invalid shape). 

5.  Reframe on the side surface surrounded by a free side.

6.  Display the No Show space to see the original surfaces.
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7.  Use the Connect Checker  in the Analysis toolbar to measure the distance between  

the surface (Surface.707) and its neighbors. The maximum distance is 0. It means that the free side is not due to gap.

8.  Select the surface and send it to the visible space. Check it you see a hole instead.  

There is no hole, it means that this surface was duplicated. You have to delete one of the surfaces.

9.  Remove the surface 707 from Join.1, then delete it. 
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10.  Repeat these steps with surface 706.

11.  Reframe on the area shown below and display the No Show space to see the original surfaces  

(Surface.526, Surface.534).

They are obviously incorrect, their shapes look strange. The shaded display is typical of a problem 
in  
the definition of the boundaries (missing boundary curves, wrong order).

12.  Remove them from Join.1 into SurfacesToAnalyze. 
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Then for each of the three faces to rebuild,

13.  Create the full boundary of the surface.

14.  Disassemble the boundary.

15.  Untrim the surface.

16.  Check the boundary curves and create the missing ones

17.  Recreate the correct surfaces by Split (in datum mode).

18.  Add the recreated surfaces to Join.1.

The surface has now no visible free side, but there might be very small holes impossible to detect visually. 
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To make sure that the surface is closed: Select Join.1 and click the Boundary icon.  

If the selected surface is closed, you get an explicit message.

It means that the surface is closed within 0.1mm. 
You may now try to reduce the merging distance to find the minimum value that gives a closed surface. 

Change the merging distance to 0.01mm and check for free sides: The surface is closed within 0.01mm.  
Check with 0.005mm: The surface has visible free sides. 
Check with 0.008mm: The surface is closed within 0.008mm.  
This distance is a good evaluation of the model accuracy.

Healing
1.  You may open the file 03_ClosedTopology.CATPart. 

At that stage, you may decide that the evaluated accuracy is good enough but you may also create a solid  

and use the Healing to reduce the gaps between surfaces by actually modifying (deforming) the surfaces.

2.  Select the Healing icon .

3.  Select Join.1.

4.  Give the value of the tolerance found in the previous step (Merging distance is 0.008mm in this case).
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5.  Click OK.The surface is now both topologically and geometrically closed.

Create a solid
1.  Start a Part Design workbench.

2.  Select the Close Surface icon  in the Surface-Based Features toolbar.

3.  Select Join.1 or Healing.1. The following message confirms the operation:

5.  Click OK.
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The solid is created and ready for use. The process is now completed.

Export
 

Large Assemblies
To export a large V5 Assembly in IGES, we recommend that you open it with the Work with the cache system  
option active (Tools/Options/Infrastructure/Product Structure/Cache Management/Work with the cache 
system):  
When this option is active, the referenced CATPart documents are loaded only during their transfer.
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3D IGES: FAQ

Here is a non-exhaustive list of Frequently Asked Questions about the IGES export and import process.  
The most common problems are gathered here to help trouble-shooting.  

Import

 

●     Question :  
the application cannot open the IGES file and returns an "invalid input file" error message, what can I do?

●     Answer :  
As the error message suggests , the IGES file is indeed a poor quality IGES file that cannot be opened.   
The best thing to do is to contact the provider of the IGES file and ask for a more decent file.

 

 

●     Question:   
The application crashes when I open the IGES file with a "Run Time Exception", why ?

●     Answer :  
It is obviously a bug that was not fixed on the release you are using.  
If you do not use the latest release, you can consider upgrading or contact your local support.
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●     Question :  
I get a 'Low memory state' warning message and my IGES file is not totally converted.

●     Answer :  
there is not enough memory to convert the file completely and all the remaining entities are skipped.  
We recommend to use Windows NT4SP06 (and above) for big IGES files and use 

●     at least 1 GB of RAM and 2 GB of SWAP.

 

●     Question :  

I  opened my IGES file successfully but I have some KO faces that were moved to the NoShow section,  

what was wrong?

●     Answer :  

there could be many reasons why KO faces are returned but it is usually due to the fact  

that it  was not possible to recreate the geometry contained in the IGES file.  

To avoid those KO faces, you can try and import the IGES using a different import option for 

Representation for boundaries of trimmed and bounded surfaces.  

If you still have KO faces, you may consider repairing those faces using the  

methodology described in the chapter 3D IGES: Trouble Shooting
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●     Question :  

all the dimensions of my IGES file were multiplied by 25.4, why ?

●     Answer :  

the most common cause for this problem is a problem in the header of the IGES file which is not correct.  

Therefore,  the application can not read correctly the dimension system used by the user and takes  

the 'inch' as the default system. That explains why all the dimensions are multiplied by 25.4.  

Then you can either modify manually the IGES file to repair it or you can ask the provider of the IGES file  

to provide a good quality file

 

 

●     Question :  
I have a KO Face: in the KO-Body, I have only Surfaces (no curve); in the .err file, I can read. 

 

How can I repair my face ?

 

Answer:  
The Surface must be a C2 B-Spline. The reason of the problem is that there is not the 3D-representation for  
the curves in the IGES File. 
The Face type is 144. The Boundary type is 142. This Boundary should reference two Curves Representations : 
●     First, a 2D-Parametric Curves Representation: OK, in our case. 

●     Then, a 3D Curves Representation: Missing in our case! 

V5 only uses the 2D representation if the B-Spline Surface is C2-continuous.  
Here, the B-Spline Surface is not C2. V5 must cut it in C2 Surfaces and cannot use the 2D Curves 
Representation.  
With Continuity Optimization of Curves and Surfaces option, B-Spline Surfaces are approximated to be  
C2-continuous and 2D curves can be used (B-Spline Surfaces are C2).  
All Faces are OK ! 
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●     Question :  
Even with correct IGES Options, I still have a KO Face :  
n the KO-Body, I have only one not-cut B-Spline Surface (no curve);  
in the .err file, I can read There is no 3D curve.... 

How can I repair my face ?

 

●     Answer:  
The IGES File is invalid and has 2 problems:

�❍     First, There is NO 3D Curves Representation. 

�❍     and the 2D Curves Representation is incorrect :

For the 2D Curves, the Entity Use Flag, in the Status Number, should be "05" for "2D-
Parametric".   
In the IGES File, this flag is "00", which means 3D Curves! Replace the incorrect flag "00" by "05"  
for all 2D Curves in the IGES file.  

Export

●     Question :  

When examining my .rpt file, I see I have some KO faces , what should I do?

●     Answer :  

KO faces when exporting may be caused by a corrupted CATPart.  

You can try and use the CATDUA utility to see if there is nothing to be done on the CATPart itself.  

If, despite all, you still get KO faces when exporting to IGES, please contact your local support.
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●     Question :  

The IGES file created by my application is not correctly opened by my CAD package, what should I do?

●     Answer :  

You can try to use the export with the two available options for Curve and surface type :  

Standard and BSpline. 

The BSpline option may give better results with some CAD systems and the Standard option give  

better results with others.  

If the result is still bad with the receiving system, you may want to investigate i 

f the CATPart is not corrupted and  

use the CATDUA program to upgrade the CATPart. Finally, if the result is still not the expected one,  

it could be a problem with the CAD receiver system itself.  

●     Question :  

I am losing some parts of my assembly while exporting my CATProduct to IGES, why ?

 

●     Answer :  
Make sure that you do not have any foreign parts included in your CATProduct like STL files or Parasolid files...etc.  
Those files do not contain any V5 information except the visualization information and therefore it is impossible  
to export them as IGES file. If you have V4 .models in your CATProduct, make sure to have them migrated  
to V5 before exporting to IGES.
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3D IGES: VBScript macros

You can automate Data exchanges with IGES using VBScript macros, either at import or at export

Import 

1.  Create a RunTime window (window in which all runtime variables a set)

2.  Type the command:cnext -macro MyMacro.CATScript 

where MyMacro.CATScript is the VBScript macro you want to execute.

●     The input files must be writable (not read only). Otherwise the system will display an information box and wait 
for an acknowledge.

●     The output file must not exist in the output directory otherwise the system will ask for a confirmation to 
overwrite the file and wait for an acknowledge.

You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per 

VBScript macro.

Example
VBScript macro for implementing a IGES file

Language="VBScript"

Sub CATMain()

Dim Document0 As Document

' Reading an IGES file

Set Document0 = CATIA.Documents.Open( "E:\tmp\Box.igs" )

' Saving the corresponding CATPart

CATIA.ActiveDocument.SaveAs "E:\tmp\Box"

CATIA.Quit

End Sub 

 

Export 
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1.  Create a RunTime window (window in which all runtime variables are set):

2.  Type the command:cnext -macro MyMacro.CATScript 

where MyMacro. CATScript is the VBScript macro you want to execute.

●     The input files must be writable (not read only). Otherwise the system will display an information box and wait 
for an acknowledge.

●     The output file must not exist in the output directory otherwise the system will ask for a confirmation to 
overwrite the file and wait for an acknowledge.

You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per 
VBScript macro

Example

VBScript macro for exporting a file to IGES 

 

Language="VBScript" 
Sub CATMain() 
Dim PartDocument0 As Document 
' Reading a CATPart file 
Set PartDocument0 = CATIA.Documents.Open  ( "E:\tmp\Box.CATPart" )  
' Saving the part in a IGES file 
PartDocument0.ExportData "E:\tmp\Box2", "igs" 
CATIA.Quit 
End Sub 
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STEP: Import

This task shows you how to import to a CATPart or CATProduct document  
the data contained in a STEP AP203 / AP214 file.  

It is also possible to insert a STEP file as an existing component in a CATProduct. 
Regarding AP214, both STEP AP 214 IS and STEP AP 214 DIS files are read.

The level of Recommended Practices published by the CAx Implementor Forum applied by the translator at import and export are the following : 
 

●     Recommended Practices for External References with References to the PDM Schema Usage Guide 
Release 2.1 January 19, 2005  

●     Recommended Practices for Colours and Layers 
September 24th , 2001  

●     Recommended Practices for Geometric Validation Properties 
2nd Extension March 24, 2006  

●     Recommended Practices for Assembly Validation Properties  
August 17th, 2007 

●     See also: 
CAx Implementor Forum  
http://www.cax-if.de  
http://www.cax-if.org

The table entitled What about the elements you import ?  
provides information on the entities you can import.  
You can find further information in the Advanced Tasks: 
●     Trouble Shooting,

●     Best Practices,

●     FAQ,

●     VBScript Macros.

and in the Customizing STEP Settings chapter.

Statistics about each import operation can be found in the report file and the error file. 

 

1.  Depending on your configuration:

Click the Open icon   or select the File > Open command. 

The File Selection dialog box is displayed. 
or

Insert/Existing component command. 

The File Selection dialog box is displayed. 

2.  Set the .stp or .step extension in the Files of type field.  

This displays all .stp or .step files contained in the selected directory : 

3.  Select the .stp or .step file of your choice (MoldedPart.stp, in our example) and click Open.
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A progress bar is displayed.

You can use the Cancel button to interrupt the transfer at any time. 
The conversion is then interrupted (after the processing of the current independent entity) and the partial conversion already performed is displayed in the 
V5 session.

What is then displayed depends on the contents of the STEP file. 

●     For the File/Open command:
�❍     If the STEP file contains a normalized assembly structure,  

a CATProduct document is created. 

�❍     If the STEP file does not contain any geometrical and topological data,  
the components will be visible only  in the Specification Tree. 

�❍     If the STEP file contains also geometrical and topological data,  
all the components will be present in the Geometry Space and in the Specification Tree.  

�❍     If the STEP file contains only geometrical and topological data, a CATPart document is created. 

The geometrical elements of the faces, which could not be transferred,  
are created in the NO SHOW space. In the NO SHOW space, you can  
visualize the Surface supports and the 3D Curves).

●     For the Insert/Existing component command: 
�❍     if the STEP file contains no assembly information, it is converted to a CATPart,

�❍     if the STEP file contains assembly information, it is converted to a CATProduct  
referencing several CATPart documents.

The resulting document is inserted in the current CATProduct document,  
and the graphic window is updated (specification tree and geometry).

●     The reference to the STEP file is lost, so any update of the STEP file will have no effect  
in the CATProduct.

 
●     For both commands: 

�❍     The reference planes are hidden.

�❍     A Geometrical Set is always created. It may be empty:
■     it will contain the valid surfaces imported, if any.

■     it is empty if there is no valid surfaces, e.g. when the element imported is a solid,  
or when all surfaces are invalid.

■     invalid surfaces are sent to a specific Geometrical Set (FaceKO#xxx)

Several STEP options can be customized: 
●     Continuity optimization of curves and surfaces, to optimize curves and surfaces.

●     Validation Properties, to check the quality of the transfer.

●     Groups (Selection Sets), to activate/de-activate the transfer of groups mapped with Selection Sets.

●     Detailed report, to set the level of details of the transfer log.
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Report file

After the recovery of STEP files, the system generates:

●     a report file (name_of_step_file.rpt) where you can find references about the quality of the transfer 

●     and an error file (name_of_step_file.err) .

These files are created in a location referenced by the CATReport variable. Its default value is  

●     Profiles\user\Local Settings\Application Data\Dassault Systemes\CATReport on Windows (user being you logon id)

●     and  $HOME/CATReport on UNIX.

Always check the report and error files after a conversion !  
Some problems may have occurred without been visually highlighted.

 
Example of a report file 

Note that the conversion summary in the report file takes assemblies into account.

 

Legend

●     OK = Transferred

●     KO = Not Transferred

●     NS = Unsupported

●     OUT = Out Of Size
"OUT" entities are OUT of model size. Most of the time, these entities are 
curves  
and they are out of the V5 model space. These entities are not created.

●     DEG = Degenerated
�❍     "DEG" entities are degenerated entities. They are solids (MANIFOLD_SOLID_BREP) or  

Shells (OPEN_SHELL), or Curves (LINE, CIRCLE,...).  
Degenerated solids are incomplete solids (at least one Face misses)

●     INV = Invalid
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"INV" entities are Invalid entities, that is to say their description within the STEP 
file  
is invalid (STEP syntax rules are not respected,...). These entities are not created.

Example of error file: 

E:\Report\pm6-hc-214.err 
 
Input FileName : G:\Equipe_STEP\STEP\PDES-Prostep\Tr8\Prod\pm6-hc-214.stp 
Output FileName :  
 
 
============================================ 
*** = Processing new independent element 
* = Intermediate processing 
!! = Independent element K.O. 
! = Intermediate error 
-------------------------------------------- 
<I> = Information 
<W> = Warning 
<E> = Error 
-------------------------------------------- 
[0000] = Message identifier : 0000 
[T=xxx] = Entity Type Step : xxx 
[#0000] = Entity identifier number : 0000 
============================================ 
Actual display level : Customer 

 
Report messages

 Here are some of the messages that may appear:
●     Too many cuts on face boundary.  

Tip : Use topological reduction option (in IGES) or curve optimization (in IGES or STEP) - see User's Guide 
These options are accessible via Tools/Options/Compatibility/STEP dialog boxes, in  
the Continuity optimization of curves and surfaces section.  
Select the Advanced optimization option and push the Parameters... button.  
For more information, click on the link on STEP above.

●     <W> [0904] The face #xx was splitted into nn CATIA V5 faces 
This message indicates that a STEP face has been split into several V5 faces to comply with V5 data structure.

 When the Continuity optimization of curves and surfaces/Advanced optimization option in  
Tools/Options/Compatibility/STEP is active, the following warning messages may appear in the report file:
●     The BSpine Surface is not C1: Approximation of the surface is impossible! 

This is just a warning, the surface is imported but is not approximated.

●     The deformation found of the surface approximation (which is calculated by isoparameters) is : xx millimeters. 
This indicates that the real deformation found is higher than the Deformation value  
you have entered in the Parameters box and that the approximation could not be performed.  
When this occurs for several entities, you will find the following information message at the end of the report file:

●     For a better approximation of BSpline surfaces, you can use a "Curves and surfaces approximation"  
Deformation value of at least : xx millimeters 
You can enter this value in the Parameters box of the  
Continuity optimization of curves and surfaces/Advanced optimization option in Tools/Options/Compatibility/STEP. 

What About The Elements You Import ?
The attributes of products are taken into account as follows:
STEP  V5     
PRODUCT.ID  Part Number
PRODUCT.DEFINITION.ID  Definition
PRODUCT.NAME  Nomenclature
PRODUCT.DESCRIPTION  Description 
PRODUCT_DEFINITION_FORMATION_WITH_SPECIFIED_SOURCE.MAKE_OR_BUY Source
PRODUCT_DEFINITION_FORMATION.ID  Revision
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The attributes of instances of products are taken into account as follows:

STEP  V5
NEXT_ASSEMBLY_USAGE_OCCURRENCE.ID  Component/Instance name
NEXT_ASSEMBLY_USAGE_OCCURRENCE.DESCRIPTION Component/Description

 

Groups
●     For each APPLIED_GROUP_ASSIGNMENT pointing to a group and a list of entities in the STEP file,  

a Selection Set is created.  This Selection Set is named with the name of the pointed GROUP entity  
and includes all pointed entities.

●     The transfer of groups can be activated/de-activated via the Groups (Selection Sets) option.

Layers

The number of the layer imported is defined by STEP PRESENTATION_LAYER_ASSIGMENT.ID. This is a string representing an integer. If this integer is 
higher than 1000, the number of layer will be imported as 0.

Annotations

See About 3D Annotations in STEP.

STEP Part 42 Entities Imported into V5R6 and Higher 

 

I=Implemented NI=Not yet implemented N/A=Not applicable according to the standard

        

Shape Representation
geometrically  

bounded  
wireframe

geometrically  
bounded  
surface

edge-based  
wireframe

shell-based  
wireframe

manifold  
surface

faceted  
brep

advanced  
brep

High Level Entities geometric_curve_set geometric_set edge_based_ 
wireframe_model

shell_based_ 
wireframe_model

shell_based_ 
surface_model

faceted_brep 
brep_with_voids

manifold_solid_brep 
brep_with_voids
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                              Entity 

Point cartesian_point I I I I I NI I

point_on_curve NI NI N/A N/A NI N/A N/A

point_on_surface N/A N/A N/A N/A NI N/A NI

point_replica NI NI NI NI N/A N/A NI

degenerate_pcurve N/A N/A N/A N/A NI N/A NI
 

Curve line I I I I I N/A I

circle I I I I I N/A I

ellipse I I I I I N/A I

hyperbola I I I I I N/A I

parabola I I I I I N/A I

polyline I I I I I N/A I

b_spline_curve (+ rational) 
b_spline_curve_with_knots I I I I I N/A I

uniform_curve (+rational) NI NI NI NI NI N/A NI

quasi_uniform_curve (+rational) I I I I I N/A I

bezier_curve I I I I I N/A I

trimmed_curve I I N/A N/A N/A N/A N/A

composite_curve I I N/A N/A N/A N/A N/A

composite_curve_on_surface N/A NI N/A N/A N/A N/A N/A

boundary_curve 
outer_boundary_curve N/A NI N/A N/A N/A N/A N/A

pcurve NI N/A N/A N/A NI N/A NI

surface_curve I N/A N/A N/A  N/A  

offset_curve_3D NI N/A NI NI NI N/A NI

curve_replica NI N/A NI NI NI N/A NI
 

Surface plane N/A I N/A N/A I NI I

cylindrical_surface N/A I N/A N/A I N/A I

conical_surface N/A I N/A N/A I N/A I

spherical_surface N/A I N/A N/A I N/A I

toroidal_surface N/A I N/A N/A I N/A I

degenerate_toroidal_surface N/A I N/A N/A I N/A I

surface_of_linear_extrusion N/A I N/A N/A I N/A I

surface_of_revolution N/A I N/A N/A I N/A I

b_spline_surface 
b_spline_surface_with_knots N/A I N/A N/A I N/A I

uniform_surface N/A NI N/A N/A NI N/A NI

quasi_uniform_surface N/A I N/A N/A I N/A I

bezier_surface N/A I N/A N/A I N/A I

rectangular_trimmed_surface N/A I N/A N/A N/A N/A N/A

curve_bounded_surface N/A I N/A N/A N/A N/A N/A

rectangular_composite_surface N/A NI N/A N/A N/A N/A N/A

offset_surface N/A I N/A N/A I N/A N/A

surface_replica N/A NI N/A N/A NI N/A N/A

Topology vertex_point N/A N/A I I I N/A I

edge_curve N/A N/A I I I N/A I

oriented_edge N/A N/A N/A I I N/A I

vertex_loop N/A N/A N/A NI NI N/A NI

poly_loop N/A N/A N/A NI N/A NI N/A

edge_loop N/A N/A N/A I I N/A I

face_bound 
face_outer_bound N/A N/A N/A N/A I NI I

face_surface N/A N/A N/A N/A I I N/A

advanced_face N/A N/A N/A N/A I NI I

oriented_face N/A N/A N/A N/A NI N/A N/A

vertex_shell N/A N/A N/A NI N/A N/A N/A
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wire_shell N/A N/A N/A NI N/A N/A N/A

connected_edge_set N/A N/A I N/A N/A N/A N/A

open_shell N/A N/A N/A N/A I N/A N/A

oriented_open_shell N/A N/A N/A N/A N/A N/A N/A

closed_shell N/A N/A N/A N/A I NI I

oriented_closed_shell N/A N/A N/A N/A N/A NI I

manifold_solid_brep N/A N/A N/A N/A N/A N/A I

brep_with_voids N/A N/A N/A N/A N/A N/A I

faceted_brep N/A N/A N/A N/A N/A I N/A
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STEP: Trouble Shooting

Import
If you need to recover from transfer failures after importing the data contained in a STEP file into a CATPart document, please refer to the IGES: 
Trouble Shooting chapter because the repairing scenario is the same with IGES files.  
There are however some specificities for STEP data, they are detailed just below:

What you need to know

STEP files may describe assemblies that contain CATParts. The result of the conversion is a Product which contains several 
components.

 

=> If needed, each part can be analyzed and corrected individually.

If the components have links between them (for example instantiations), the links are recreated in the product.

 

=> Corrections on the source part are automatically reported to instances.

You are now ready to create the topology. For more information: 
●     please refer to the next chapter entitled STEP: Best Practices - How to create a topology

●     or use the application Healing Assistant for more complex cases.

 
STEP files with syntax errors

When a STEP file is syntactically invalid, there are error messages in the .err file describing those invalidities.  
Syntax errors are responsible for partial loss of STEP file data: all invalid entities and all entities pointing directly or not to invalid entities are ignored. In order 
to recover all the STEP entities, correct the STEP file before reading it in V5. 

 
STEP files with short names

Using short names in STEP files is an out-of-date way to reduce the size of STEP files (available in V4). Therefore V5 imports only STEP files with long names 
and does not support short names. Please ask your suppliers to send you only STEP files with long names.
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STEP Import from VPM

VPM sometimes exports assemblies positioned by scaling or mirroring to STEP, by using the STEP entity CARTESIAN_TRANSFORMATION_OPERATOR. This is 
not valid regarding the STEP standard and not managed by V5 STEP Interface. An error is detected and appears in the err file and the positioning is not 
correctly interpreted.

Export

Exporting V4 data

Exporting V4 data does not provide the expected result: data placed in the NoShow in V5, or changes of colors or graphic attributes are not taken into account, 
e.g. if you have sent a V4 element to the NoShow, it will be kept since it is its V4 status that is taken into account. To make those changes effective, you need 
to make those changes in a V4 session, save the data in V4 and re-import them to V5. 

 
Export from DMU

DMU allows scaling and mirroring while positioning assembly components. Such a position of instance of component cannot be exported to STEP (the position 
should be a translation and/or a rotation). This issue is detected when you export the assembly to STEP. Check the err file. If you find an error message like 
the one below, the export is wrong, one instance is not correctly positioned. 

<E> The instance '00200-411-21' of the product '00200-411-37' was incorrectly positioned by Mirroring  
<E> The instance '00200-411-21' of the product '00200-411-37' was incorrectly positioned by Scaling 

By-pass : Remove the components positioned by mirroring or scaling and replace them by standards products created in V5 before exporting. 
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STEP: Best Practices

Import
 

Large Assemblies
We recommend that you import large assemblies in batch mode:

●     In this mode the CATPart documents are unloaded once transferred. 

●     A maximum of the available memory is spared for the translation.

Quality of conversion
Always check the report and error files after a conversion ! Some problems may have occurred without been 
visually highlighted. 

We recommend also that you use the Geometric Validation Properties when they exist. When an error occurs in the 
comparison, you can locate the problem as follows :

●     An error at solid or shell level means that the geometric translation failed.

●     An error at product level means that a sub-assembly translation failed.

●     An error at instance level means that a component is misplaced.

Note that the error at the lowest level gives the relevant information. It is the first error that appears in the report 
file: 

●     An error at solid or shell level involves an error for corresponding product.

●     An error at product level involves an error for every product including instances of it.

How to Create a Topology
STEP files usually describe solids. It means that they contain the topology of the model. During the conversion of a 
part: 

●     If no problem, the geometry and the topology are imported and the result is a solid.

●     If there is a geometric problem, one or several faces of the solid cannot be recreated and the solid itself is 
degenerated.  
The resulting model contains: 

�❍     an empty PartBody,

�❍     an Geometrical set with a surface corresponding to all faces OK,

�❍     an Geometrical set for each face KO.
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=> The repairing methodology is the same as faces KO in IGES. 

●     There may also be a topological problem, when all the geometry has been converted OK but the topology 
could not be created. Then the resulting model contains: 

�❍     an empty PartBody,

�❍     an Geometrical set with the surfaces that could not be joined properly.

=>The repairing methodology is the same as in IGES: Best Practices - How to create a topology. 
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Export
 

Large Assemblies
To export a large V5 Assembly in STEP, we recommend that you open it with the Work with the cache system 
option active (Tools/Options/Infrastructure/Product Structure/Cache Management/Work with the cache 
system): When this option is active, the referenced CATPart documents are loaded only during their transfer.

External references
For the exchange of large assemblies, we recommend that you use external references, using several small files 
instead of one large file (this will reduce memory problems).   
See the settings for more information.
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STEP: FAQ

Import
●     Question:   

You successfully opened the STEP file, there is no KO faces, but the solid was not created.

●     Answer:  
Try an interactive Join on the Shell

●     Question:  
You successfully opened the STEP file, but the parts are not correctly placed.

●     Answer:  
Edit the STEP file with a text editor and look for MAPPED_ITEM entities.  
Those are old entities not used anymore and not supported. Ask the provider of the STEP file to use 
CONTEXT_DEPENDENT_SHAPE_REPRESENTATION entities instead.

●     Question:  
You successfully opened the STEP file, there is no KO faces,  
but there are some missing geometries.

●     Answer:  
Check in the .rpt for NS (Non supported) elements,  
and consult STEP documentation to have a comprehensive list of Supported Entities

 
●     Question :  

You receive a 'Low memory state' warning message and your STEP file is not totally converted.

●     Answer :  
There is not enough memory to convert the file completely and  
all the remaining entities are skipped.  
We recommend that you use Windows NT4SP06 (and above) for large STEP files  
and with at least 1 GB of RAM and 2 GB of SWAP.

Export
●     Question:  

The .rpt reported that there were one or many KO Faces or the .err reported that an invalid Body has been detected.

●     Answer:  
The problem might be due to two sources : a bad CATPart or a bug in the STEP code.  
To verify the CATPart is OK, use the usual tools : Cleaner, NCGM Workbench and  
make sure there is no major errors.  
A internal check is done while exporting and a line is added to the .err to warn if the Body is invalid
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●     Question :  
I am losing some parts of my assembly while exporting my CATProduct to STEP, why ?

 

 

●     Answer :  

Make sure that you do not have any foreign parts included in your CATProduct like STL files or Parasolid files...etc.  

Those files do not contain any V5 information except the visualization information and  

therefore it is impossible to export them as STEP file.  

If you have V4 .models in your CATProduct, make sure to have  

them migrated to V5 before exporting to STEP.
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STEP: VBScript Macros

You can automate Data exchanges between V5 and STEP using VBScript macros, either at import or export.

Import
1.  Create a RunTime window (window in which all runtime variables a set)

2.  Type the command: 

cnext -macro MyMacro.CATScript 
where MyMacro.CATScriptis the VBScript macro you want to execute. 

●     The input files must be writable (not read only).  
Otherwise the system will display an information box and wait for an acknowledge.

●     The output file must not exist in the output directory otherwise the system will ask  
for a confirmation to overwrite the file and wait for an acknowledge.

You can transfer several files within the same VBScript macro, but it is recommended  
to do only one transfer per VBScript macro.

Example:

VBScript macro for implementing a STEP AP203 file 

Language="VBScript" 

Sub CATMain() 

Dim Document0 As Document 

' Reading a STEP file 

Set Document0 = CATIA.Documents.Open( "E:\tmp\Box.stp) 

' Saving the corresponding CATPart   

CATIA.ActiveDocument.SaveAs "E:\tmp\Box"   

CATIA.Quit 

End Sub 

 

Export
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1.  Create a RunTime window (window in which all runtime variables are set):

2.  Type the command:cnext - macro MyMacro.CATScript  

where MyMacro. CATScript is the VBScript macro you want to execute.

●     The input files must be writable (not read only). Otherwise the system will display an information box  
nd wait for an acknowledge.

●     The output file must not exist in the output directory otherwise the system will ask for a confirmation  
to overwrite the file and wait for an acknowledge.

Examples

VBScript macro for exporting a file to STEP AP203 

Language="VBScript"   
Sub CATMain()   
Dim PartDocument0 As Document    
' Reading a CATPart file    
Set PartDocument0 = CATIA.Documents.Open( "E:\tmp\Box.CATPart" )    
' Saving the part in a STEP file    
PartDocument0.ExportData "E:\tmp\Box2", "stp"    
CATIA.Quit    
End Sub   

 
VBScript macro for exporting a Product file to STEP AP203  

Language="VBScript    
Sub CATMain()    
Dim ProductDocument0 As Document    
Set ProductDocument0 = CATIA.Documents.Open( "E:\tmp\Product1.CATProduct" )    
ProductDocument0.ExportData "E:\tmp\Product1", "stp"    
CATIA.Quit    
End Sub 
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IGES 

 

 

This task shows you how to customize IGES settings, that are divided in four sections:
●     General IGES options:

�❍     Show/NoShow dialog box

 
●     Import IGES options:

�❍     Import mode,

�❍     Join,

�❍     Continuity Optimization of Curves and Surfaces,

�❍     Detection of Invalidity in Input Geometry,

�❍     Representation for Boundaries of faces,

●     Export IGES options:
�❍     Save only shown entities,

�❍     Curve and surface type,

�❍     Representation mode,

�❍     Name of Author,

�❍     Author's Organization,

�❍     Export Unit as.

IGES supports Small scale files and Large scale files (as requested in Tools > Options > Parameters and Measure >Scale). Scales impact:
●     Advanced optimization,

●     Detection of invalidity.

The values impacted will be displayed with the unit of the V5 session.  
The range values will take into account the scale factor of the session.
●     When you modify the scale within a session, the values impacted are not automatically re-computeds. Either:

�❍     key-in the new values according to the messages displayed,

�❍     or click Default Values to update the parameters or tolerances according to the new scale,

�❍     or delete obsolete IGES settings files. 

●     The tolerance used in Automatic optimization takes the scale into account. 

 

General

Show/NoShow Completion Dialog Box

By default, the Show Completion Dialog Box option is not selected. 
Select this option to display the completion dialog box at the end of the transfer. 
 

 By default, the option is not selected

Import
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Import mode

When the Generate one CATPart option is selected, the IGES file is translated into one CATPart.

For large files containing a large number of 308/408 IGES entities, you can select the option Map the 308/408 IGES entities onto a Product Structure:

●     if the IGES file contains 308/408 entities, a root CATProduct is created in V5,

●     the 408 entities will be translated into CATParts or components under the root CATProduct as follows:
�❍     If the 408 entity references an intermediate 308 entity (i.e. one that contains 408 entities), a new component is created. It will contain components for each 

408 of the 308 (see first case below).

�❍     If the 408 entity references a leaf 308 entity (i.e. one that does not contain any 408 entity), a CATPart will be created. It will contain the geometry 
contained in this 308 (see second case below).

The uniqueness of the component name is ensured by adding a suffix corresponding to the DE (Directory Entry) number of the IGES 308 entity 
(subfigure definition).

  By default, the option is set to Generate one CATPart.

 

 
Join

 
Select the option Join surfaces of the model if you want to join the surfaces of your IGES model into a shell.    

If this option is active, the software will try to knit the surfaces from an importable file into a shell, even if the file contains Groups (402). 

●     If you select the join option, while importing IGES files to V5, make sure that model is constituted of one part.

●     The Join operation may fail in specific topological configurations.

●     This option does not apply to Manifold Solid Brep (IGES type 186): the faces are always imported into a join.

●     The previous option Join surfaces of each group is replaced by the Map the 308/408 IGES entities onto a Product Structure above. This option enables 
you to create several CATParts from one IGES file.

●     When the Map the 308/408 IGES entities onto a Product Structure option is active, the option Join surface of the model is selectable but has no effect.

  By default, this option is not selected.
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Continuity Optimization of Curves and Surfaces

V5 requires its geometry to be C2-continuous. When non C2-continuous geometry must be imported from a IGES file, this geometry (curves, surfaces) is 
broken down into a set of contiguous geometries, each of them being C2-continuous. This is what happens when the No Optimization option is chosen.  
 
However, this can produce an increase of the size of the resulting data, because more curves/surfaces are created. In order to limit this drawback, two 
other modes are optionally offered.  
 
In those modes, the IGES interface tries to limit the splitting of curves and surfaces by modifying their shape slightly, so that they become C2-continuous 
while remaining very close to their original shape. 

In order to guarantee that the deformation is not excessive, a maximum deviation (tolerance) parameter is used. When in Automatic optimization mode,  
the value read from the IGES file is corrected so that it remains lower than the default tolerance. This guarantees an optimization that remains compatible 
with the precision for the data that was set by the emitting system.  
 
Last, if this strategy is not enough, you can choose the Advanced optimization mode, in which an arbitrary deviation value can be entered. 

By default, the Automatic Optimization  is proposed:

●     No approximation , thus this option does not create a significant deformation and keeps the internal BSpline structure (equations and knots). 

●     A continuity optimization is performed within the default value for deformation tolerance on: 

�❍     BSpline surfaces,

�❍     all types of curves with the exception of canonical curves (3D and P-curves when available),

●     The parameters box cannot be activated 

This option soften the effect C2 cutting of faces and boundaries (which is mandatory in V5) without any significant geometric deformation 

If you select No optimization: 

●     No optimization is performed on BSplines (neither curves nor surfaces). 

●     Elements are cut at  discontinuity points to suit the modeler (exact mathematic continuity). This may result in a dramatic number of faces and boundary curves, 
data of poor quality and poor performances in further use in V5.

If you select Advanced optimization:

●     No approximation. The internal BSpline structure (equations and knots) is kept, 

●     A continuity optimization is performed on:

�❍     BSpline surfaces,

�❍     all types of curves (3D and P-curves when available),

●     but the deformation tolerance is set by the user (see Parameters). 

With this option, you can enter a larger tolerance value which may enhance the optimization impact (resulting in less C2 cutting on faces.

Click Parameters to access advanced optimization options and tolerances. 
The dialog box looks like this if you have selected Standard Scale:  
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User-defined Tolerances

Note that the tolerance is shared by the optimization process (in all cases), the Curves and surfaces approximation and the Topological reduction of boundaries 
if you have selected those check boxes. 
For example, you have a deformation tolerance of 0.001mm and you have selected Curves and surfaces approximation. 
The tolerance for the optimization will be 50%, i.e. 0.0005mm and that of the Curves and surfaces approximation will also be 50%.  
Thus, the number of cuts of the faces will vary according to the value entered, and according to the number of check boxes selected.

●     Deformation: maximum deformation (in millimeter) allowed in the optimization of curves and surfaces.  
For the Standard Scale, it ranges between 0.0005mm and 0.5mm. The default value is 0.001mm. 
For the Small Scale, it ranges between 5e-006mm and 0.005mm. The default value is 1e-005mm. 
For the Large Scale, it ranges between 0.05mm and 50mm. The default value is 0.1mm

●     Angle: angle (in degree) below which contiguous elements can be merged. Ranges between 0 and 10 degrees.

●     Click Default Values to revert to the default values.

The parameters values apply to all current options.

User-defined Advanced Options

By default, these options are not selected.

●     Curves and Surfaces Approximation alone: 

�❍     BSpline surfaces and curves continuity is optimized,

�❍     In addition, Bspline curves and surfaces approximation is performed,

�❍     It is possible to enter a user value for Deformation,

�❍     This option may change the internal structure of BSplines (equations and knots),

�❍     This option usually results in a significant decrease in the number of faces cuttings. 

●     Topological Reduction of Boundaries alone:

�❍     BSpline surfaces and curves continuity is optimized,

�❍     In addition, topological reduction is applied to boundaries,

�❍     The Angle value is used to select contiguous curves that can be merged into a smooth one (tangency criteria),

�❍     It is possible to edit the values for Deformation and Angle,
■     This combination of options usually results in a significant decrease in the number of boundary curves (especially on poor quality input data).

●     Curves and Surfaces Approximation and Topological Reduction of Boundaries together:

�❍     BSpline surfaces and curves continuity is optimized 

�❍     In addition, BSpline curves and surfaces approximation is performed and topological reduction is applied to boundaries 

�❍     It is possible to enter user values for Deformation Tolerance and tangency Angle. 

�❍     This combination of options allows the utmost optimization of curves and surfaces, while keeping geometric deformation under control. It results in reducing 
the number of faces and boundaries and ensures better performance in downstream use of the data. 

You can find useful information in the report file. Please see the Report file section in the IGES Import chapter in this User's Guide.
  By default, the option is set to Automatic Optimization.
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Detection of Invalidity in Input Geometry

The dialog box looks like this for the Standard Scale: 

You can choose to import IGES files with or without detecting discrepancies in geometry, by selecting the corresponding option. 
Detection enables you to enter the Tolerance value above which a geometry is considered as invalid:

●     size of a hole in an open boundary,

●     distance between the boundary loop and the surface.

The default Tolerance value is: 

●     3mm for the Standard Scale,

●     0.03 mm for the Small Scale, 

●     300 for the Large Scale.

For more information, please see the IGES Best Practices chapter in this User's Guide.

  By default, the option is set to Detection.

 

 
Representation for Boundaries of Faces

There are two type of IGES faces: types 144 and 143. The boundaries of those faces (respectively type 142 and 141) have two representations:

●     2D (parametric)

●     3D (spatial).

For each boundary, the IGES file contains a parameter defining the preferred representation:

●     3D,

●     2D,

●     none,

●     equal preference.

In the three last cases, V5 tries to import the 2D representation of the boundary. In case of failure, the 3D representation is imported. 

By default, the Keep File Preference option is active:

●     if the preference is set, the import will respect it.

●     if no preference is set, the 2D representation is preferred.

If you do not wish to use the 2D representation (i.e. override the preference set in the IGES file), select the Force 3D representation option. Only the 
3D representation will be imported.

  By default, the option is set to Keep file preference.

 

 
Import Groups

Imports IGES groups (Entity Type 402, Forms 1-7-14-15: Associativity Instance) as Selection Sets. 
You can de-select this option for a faster import. Note that Selection Sets will not be created.
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  By default, this option is selected.

 

Export
 

Save only shown entities

●     When selected, the Save only shown entities option allows you to save only the Part's entities which are in the Show mode.

  By default, this option is selected.

 

 
Curve and surface type

The default  Standard option and the BSpline option allow you to select which curve and surface types you want to be generated.   
If you leave the default  Standard option selected the curve and surface types created in the Part are kept as is.  
If you select the BSpline option all curves and surfaces are converted into B-splines.

  By default, the option is set to Standard.

 

Representation mode

If you select the default option Surface, solid decomposition will be identical in both the original model and the resulting file.  
Only the surfacic decomposition of the original model is stored. 

Wireframe should be used if you want 3D visualization of solid edges to be identical in both the original model and the resulting file.  
Only the wireframe decomposition of the original model is stored.  
This may be useful in cases where curves are the only form of input accepted. 

Solid-Shell lets you save Solids, Shells and Faces as IGES New Entities as follows:

V5  IGES 

Solid  Manifold Solid B-Rep Object Entity (Type 186, Form 
0) 

Solid (Closed) Shell  Closed Shell Entity (Type 514, Form 1) 
Independent Shell  Open Shell Entity (Type 514, Form 2) 
Face in a Shell  Face Entity (Type 510, Form 1) 
Face Loop  Loop Entity (Type 508, Form 1) 
List of Loop Edges  Edge Entity (type 504, Form 1) 
List of Start/End Loop Edges Vertices Vertex Entity (Type 502, Form 1) 
Plane Surface (support of Face)  Plane Surface Entity (Type 190, Form 0)

 

●     For Loops, only the 3D Representation is exported.

●     All those new IGES entities have not been "tested" (IGES Norm 5.3) and the IGES/PDES Organization recommends that special consideration be given when 
implementing certain untested entities. Therefore if you do not know whether the receiver system will recognize those entities, we recommend that you do not 
use this option.

●     The representation mode Solid-Shell requires IGES version 5.3 or higher. 

  By default, the option is set to Surface.

 

 
Author's Name and Organization

Enter here your name and the name of your organization. 
This information  will be transferred to the Global Section of the IGES file at export.
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Export Units as

Let's you define the unit to be used for export. This unit can be different from the V5 file. 
The default option is Keep User Unit, the IGES file unit will be : 

●     the unit defined in Tools > Options > General > Parameters and Measure / Units tab, if the IGES Norm recognizes it,  

●     the Millimeter (mm) otherwise. 

Units like the one named Feet, Inch, Decimal are not recognized by IGES Norm. If such Units are selected in Parameters and Measure / Units tab and if 
the option selected is Keep User Unit, the IGES file unit will be the Millimeter (mm). 

  By default, the option is set to Keep User Unit.
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STEP  

 

 This page deals with:
●     General STEP options:

�❍     Detailed report,

�❍     Validation Properties (VP),

�❍     Groups (Selection Sets).

●     Import STEP options:
�❍     Continuity optimization of curves and surfaces,

�❍     Assemblies physical structure,

�❍     Insert existing component,

●     Export STEP options:
�❍     Application Protocol (AP),

�❍     Units,

�❍     Show/NoShow,

�❍     Header of the STEP file,

�❍     Assemblies.

STEP supports Small scale files and Large scale files (as requested in Tools > Options > Parameters and Measure >Scale). 
Scales impact:
●     Validation Properties (VP),

●     Advanced optimization.

The values impacted will be displayed with the unit of the V5 session.  
The range values will take into account the scale factor of the session.

●     When you modify the scale within a session, the values impacted are not automatically re-computed. Either:
�❍     key-in the new values according to the messages displayed,

�❍     or click Default Values to update the parameters or tolerances according to the new scale,

�❍     or delete obsolete STEP settings files. 

●     The tolerance used in Automatic optimization takes the scale into account. 

 

General

Detailed report

By default, the report file contains a Detailed Conversion chapter. Click to clear the Detailed Report option to remove this chapter 
from the report file. 

  By default, this option is selected.
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Validation Properties (VP)

This functionality is available in STEP AP214 and AP203 ed2, i.e. Geometric Validation Properties are attached at product level, 
according to Recommended Practices for Geometric Validation Properties 2nd Extension March 24, 2006.

The assembly STEP exchange can be validated through Geometric Validation Properties (GVP) or Assembly Validation Properties 
(AVP). 

●     At import, the status for Validation Properties in the report file is done according to the selected option. 

●     At export, when the option Assembly Validation Properties is selected, the Geometric Validation Properties are not exported at 
assembly level. 

By default the option Geometric Validation Properties is selected. 

Geometric Validation Properties: 

●     At export : the volume, the wetted area and the centroid of each product, and the centroid of each instance of a product, are 
computed and stored in the STEP file as validation properties. 

●     At import: these properties are computed in the receiving system and checked vs values stored in the STEP files. 

Note that:

●     When the Geometric Validation Properties fail on a part (for instance, wrong centroid), the error will be propagated to the 
assembly level (all products containing an instance of the part will have a wrong centroid). 

●     Geometric Validation Properties are not computed when the geometry is exchanged under a native CATIA format. 

Example of a Geometric Validation Properties report:  

Assembly Validation Properties: 

●     For each product having instances, the number of instances and a notional centroid are stored in the STEP file as validation 
properties at export and checked at import. 

●     The process respects the Recommended Practices for AVP.

Example of a Assembly Validation Properties report: 
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●     At import, the status for Validation Properties in the report file takes into account the validation properties check at assembly 
level, done according to the option. 

●     At export, when the option Assembly Validation Properties is selected, the Geometric Validation Properties are not exported at 
assembly level. 

●     At import, when the option Assembly Validation Properties is selected, if these properties are not found in the STEP file, 
Geometric Validation Properties are searched and checked if any. 

 
When the Validation Properties (VP) option is selected, the Parameters button becomes available.  

It opens a dialog box where you can define the tolerances for the validation properties checking and decide what type of validation 

Properties you want to apply.

●     The dialog box looks like this if you have selected Standard Scale: 

●     If you switch to another scale, the current value may become invalid. 
When this happens, a warning message is issued and you are invited to define new values:
For Small Scale: 

�❍     for the centre of gravity, between 0.0001 and 0.05mm

�❍     for the SAG for COPS, between 0.0001 and 0.01 mm

�❍     for the COPS deviation, between 1e-005mm and 0.001mm

For Large Scale: 

�❍     for the centre of gravity, between 1 and 500 mm

�❍     for the SAG for COPS, between 1 and 1000 mm 

�❍     for the COPS deviation, between 0.1 and 10mm 

●     Tolerances for Geometric Validation Properties checking:  

 
They detect large errors during exchanges by comparing the centre of gravity, the volume and the area of the exchanged 
solids with their native properties:

�❍     Volume and area max. Deviation 
Percentage of variation of volume or area allowed. Default value: 1%. 
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�❍     Centre of gravity max. Deviation 
Maximum error for the center of gravity.  
Default value: 1mm for the Standard Scale, 0.01mm for the Small Scale and 100 mm for the Large Scale. 

�❍     Cloud Of Points Properties (COPS)

 

Standard validation properties may not be accurate enough, e.g. for aeronautic long term archiving.  
When this is the case, COPS ensure that the archived data are equivalent to the native data, within a given tolerance by 
comparing any face with any check point lying on it.

■     For export:
■     The STEP file is enriched with COPS properties (i.e. a cloud of points) for each exported face. 

■     These points are computed inside the face, on the support of the face. 

■     The syntax of the STEP file respects the Recommended Practices for Geometric Validation Properties published by 
the CAx Implementor Forum in 2006.

�❍     For import:
■     For each face, the COPS properties are read and the distance between each point of the cloud and the support surface 

of the face is computed. 

■     If the distance is greater than a user defined tolerance, there is an error message in the err file. And the global status 
of the geometric validation properties in the report file takes the COPS errors into account.

�❍     Example of error file at import: 
<W> [0905] For the face #16019, the COPS tolerance is not respected for the sampling point #16083 
(34.954117, 102.556562, 37.767650 ), the deviation is 1.14311 mm
�❍     Example of report file at import: 
The global status includes the COPS check : if a COPS deviation is found during the translation, then the global status of 
the GVP is KO.  
Geometric validation properties check: KO  
Maximum errors: Centroid : #22 : 0.003036 mm Volume : #22 : 0.001458 Area : #22 : 0.001282 COPS: 
#16019 : 1.14311 mm
�❍     SAG for COPS creation density: 
Controls the density of the cloud of points generated for each face; the cloud of point is created by tessellating the face 
according to the given SAG: a low value of SAG means a large number of points by face and a high value of SAG means 
few points by face.  
With a standard scale, the SAG must be defined between the following bounds: [ 0.01 - 10 ]; the default value is 0.1 mm. 
�❍     Tolerance for COPS deviation: 
Largest allowed gap between a point and the imported face.  
With a standard scale, the deviation must be defined between the following bounds: [ 0.0001 – 0.1 ]; the default value is 
0.01 mm.

Note:

■     Only smooth sampling points are taken into account at export or import, meaning that checks are carried out inside 
the faces but not on their boundaries.

■     The check at import is reported only in the report and error files. 

■     The repartition of the points in the face is automatic. A high curvature will generate many points.

■     You cannot define an area to be controlled by COPS. The whole product exported is checked.

●     Assemblies 

 

These options are available for exporting or importing assemblies, whatever the assembly mode (one file, external reference to 
STEP, external reference to V5).
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When Geometric Validation Properties (GVP) is selected:
●     For import:

�❍     Geometric validation properties are computed for each solid, shell, product or instance, and this information is written in 
the report file.

�❍     For each solid, shell, product or instance, the report file gives the computed geometric validation properties: 

■     Centroid: coordinates of the center of gravity (applies to solid, shell, product or instance),

■     Area: area of the entity (wetted area for solids) (applies to solid, shell or product),

■     Volume: volume of the entity (for solids only) (applies to solid or product).

●     If the imported STEP file contains geometric validation properties, these properties are read. This information is written in the 
report file.

●     For each read geometric validation properties, the report file gives the status of comparison between read and computed 
properties, with the following information: 

�❍     Centroid deviation error (distance measure) (applies to solid, shell, product or instance),

�❍     Surface area difference value and error ratio (applies to solid, shell or product),

�❍     Volume difference value and error ratio (applies to solid or product).

●     A global status for the conversion is given, together with the maximum deviations found. 

●     These properties are completed with the estimation of their computation errors for each solid and each shell:
�❍     The estimation of the computation error on the area or the volume is provided as a relative value. 

�❍     The estimation of the computation error on the centre of gravity is provided as an absolute value for each coordinate and 
a bounding box of the entity.

●     Example of a report file:  

●     Note:
�❍     The status of comparison for a given solid, shell, product or instance is ok if: 

■     ratios (Volume difference and Surface area difference) are lower than 1%.

■     and the centroid deviation is lower than 1 mm.

�❍     If all status are ok, the global status is ok too.

�❍     The maximum deviation found for each comparison (centroid, area and volume) is given in the report file with the 
corresponding entities (the maximum deviations found do not necessarily apply to a single object).

�❍     This functionality involves a slight performance loss, due to the properties computation cost.
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●     For export: 
●     The exported STEP file includes geometric validation properties for each solid, shell, product or instance, according to STEP 

AP214 and AP203 ed2 and the CAX-IF recommended practices.

●     For each solid, shell, product or instance, the report file gives the computed geometric validation properties: 

�❍     Centroid: coordinates of the center of gravity (applies to solid, shell, product or instance,

�❍     Area: area of the entity (wetted area for solids) (applies to solid, shell or product),

�❍     Volume: volume of the entity (for solids only) (applies to solid or product).

●     These properties are completed with the estimation of their computation errors for each solid and each shell:
�❍     The estimation of the computation error on the area or the volume is provided as a relative value. 

�❍     The estimation of the computation error on the centre of gravity is provided as an absolute value for each coordinate and 
a bounding box of the entity.

�❍     Example of a report file: 

 

When Assembly Validation Properties (AVP) is selected:
●     For export:

�❍     The Geometric Validation Properties are not computed at assembly level. 

�❍     For each product, 2 properties are stored in the STEP file according to the Recommended Practice for Assembly Validation 
Properties, August 2007: 

■     Its number of instances,

■     Its notional centroid (useful for checking the position of each instance of the product).

●     For import:
●     If product assembly properties are found, these properties are checked and Product/Instances geometric properties are 

ignored. 

●     If assembly properties are not found, and Product/Instances properties are found, Product/Instance properties are checked. 

●     When assembly properties are checked, the result of the comparison of the assembly properties appears in the report file for 
each product. 

●     The synthesis of the geometric validation properties check takes into account the check of the assembly properties for each 
product. 

●     Default Values: reverts to the default values.

●     The unit used for geometric validation properties is the STEP length user unit. See Unit option.

●     This functionality involves a slight performance loss, due to the properties computation cost.
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 By default, the option Validation Properties (VP) is not selected. 

●     In the Parameters dialog box:
�❍     By default, the option Cloud of points (COPS) is not selected.

�❍     By default, the option Geometric Validation Properties (GVP) is selected. 

 

 
Groups (Selection Sets)

By default, this option is selected: 

●     at import, Groups found in the STEP file are translated into Selection Sets.

●     at export, Selection Sets found in the V5 file are exported as Groups in the STEP file. Refer to the STEP: Export chapter for 
more information (Miscellaneous section).

However, importing or exporting Groups may be time consuming. Click to clear this option and de-activate the processing of 
Groups.

  By default, this option is selected.

 

Import
 

Continuity optimization of curves and surfaces

 

 

 

This setting allows a better user control over the number of curves and surfaces that are created during the process of importing 
STEP data into V5: 
 
V5 requires its geometry to be C2-continuous. When non C2-continuous geometry must be imported from a STEP file, this 
geometry (curves, surfaces) is broken down into a set of contiguous geometries, each of them being C2-continuous. This is what 
happens when the No Optimization option is chosen.  
 
However, this can produce an increase of the size of the resulting data, because more curves/surfaces are created. In order to limit 
this drawback, two other modes are optionally offered.  
 
In those modes, the STEP interface tries to limit the splitting of curves and surfaces by modifying their shape slightly, so that they 

3D Insight Version 5 Release 19 Page 287 of 1379



become C2-continuous while remaining very close to their original shape.  
 
In order to guarantee that the deformation is not excessive, a maximum deviation parameter is used. When in Automatic  
optimization mode, this maximum deviation is read into the STEP file itself, in the STEP parameter that documents the precision 
of points in the file. In this mode, the value read from the STEP file is then corrected so that it remains comprised between 10E-2 
and 10E-3. This guarantees an optimization that remains compatible with the precision for the data that was set by the emitting 
system.  
 
Last, if this strategy is not enough, you can choose the Advanced optimization mode, in which an arbitrary deviation value can 
be entered. 

You can find useful information in the report file. Please see the Report file section in the STEP Import chapter in this User's Guide.

The Automatic optimization proposes:

●     No approximation, thus this option does not create a significant deformation and keeps the internal BSpline structure (equations 
and knots). 

●     A continuity optimization is performed within the deformation tolerance used for optimizing BSplines, comprised between 
0.001mm and 0.01mm (depending on the tolerance value defined within the imported STEP file) on:

�❍     BSpline surfaces,

�❍     BSpline boundary curves (3D and P-curves when available),

�❍     BSpline independent 3D curves,

●     The parameters box cannot be activated 

This option softens the effect C2 cutting of faces and boundaries (which is mandatory in V5) without any significant geometric 
deformation.

If you select No optimization: 

●     No optimization is performed on BSplines (neither curves nor surfaces). 

●     Elements are cut at  discontinuity points to suit the modeler (exact mathematic continuity). This may result in a dramatic 
number of faces and boundary curves, data of poor quality and poor performances in further use in V5.

If you select Advanced optimization:

●     No approximation. The internal BSpline structure (equations and knots) is kept, 

●     A continuity optimization is performed on: 

�❍     BSpline surfaces,

�❍     BSpline boundary curves (3D and P-curves when available),

�❍     BSpline independent 3D curves,

●     but the deformation tolerance is set by the user (see Parameters). 

With this option, you can enter a larger tolerance value which may enhance the optimization impact (resulting in less C2 cutting on 
faces). 
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Click Parameters to access advanced optimization options and tolerances.  
The dialog box looks like this if you have selected Standard Scale: 

 
The default value is: 

●     0.3 mm for Large Scale,

●     0.003mm for Standard Scale,

●     3e-005 mm for Small Scale. 

User-defined Tolerancee

Note that the tolerance is shared by the optimization process (in all cases), the Curves and surfaces approximation and the 
Topological reduction of boundaries if you have selected those check boxes. 
For example, you have a deformation tolerance of 0.001mm and you have selected Curves and surfaces approximation. 
The tolerance for the optimization will be 50%, i.e. 0.0005mm and that of the Curves and surfaces approximation will also be 50%.  
Thus, the number of cuts of the faces will vary according to the value entered, and according to the number of check boxes 
selected.

●     Deformation: maximum deformation (in millimeter) allowed in the optimization of curves and surfaces:  
�❍     For the Standard Scale, it ranges between 0.0005 and 0.1mm. The default deformation is 0.003mm. 

�❍     For the Small Scale, it ranges between 5e-006mm and 0.001mm. The default deformation is 3e-005mm.

�❍     For the Large Scale, it ranges between 0.05mm and 10mm. The default deformation is 0.3mm.

Click Default Value to revert to the default value.

User-defined Advanced Option: Curves and surfaces approximation: 

●     By default, this option is not selected.

●     BSpline surfaces and curves continuity is optimized,

●     In addition, Bspline curves and surfaces approximation is performed,

●     It is possible to enter a user value for Deformation,

●     This option may change the internal structure of BSplines (equations and knots),

●     This option usually results in a significant decrease in the number of faces cuttings. 

  By default, this option is set to Automatic optimization.
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Assemblies physical structure

 
This option enables the processing of sub-assemblies of an imported assembly. 
By default, it is not selected. A CATProduct file containing the whole assembly structure and a CATPart file for each part of the 
assembly are created. 
If you select this option, a CATProduct file containing the sub-assembly structure is created for each node of the whole assembly 
while a CATPart file is created for each part of the whole assembly. 

 

STEP Filee One CATProduct for each 
product  

is not selected

One CATProduct for each 
product  

is selected
Assembly file containing  

the geometry of components

 

1 CATProduct + N CATPart P CATProduct + N CATPart

Assembly file referencing  
STEP files containing  

the geometry of components

1 CATProduct + N CATPart

 

P CATProduct + N CATPart

 
Assembly file referencing  

native files containing  
the geometry of components

1 CATProduct + N native files

 

P CATProduct + N native files

 

  By default, this option is not selected.
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Insert existing component

This option appears only if both the V5 - STEP AP203 Interface and the V5 -  
STEP AP214 Interface and the MULTICAx STEP Plug-in exist on the machine.  
By default it is not selected. Select it to activate the MultiCAD mode.

  By default, this option is not selected.

 

 

Export
 

Application Protocol (AP)

The data contained in a CATPart or CATProduct document will be saved in STEP AP203 or AP214 formats.  

For more information about STEP AP203, AP203 with extensions, AP203 edition 2 and STEP AP214,  

refer to Exporting CATPart or CATProduct Data to a STEP AP203 / AP214 File.  

  By default, this option is set to AP203 iso.

 

Units

Select the required unit to export a CATPart or a CATProduct in STEP format and in Inch or millimeter independently of the V5 
Session unit.

  By default, this option is set to mm.

 

 
Show/NoShow
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By default, those options are not active. 
A CATPart to export may contain:

●     visible entities placed in the Show space,

●     hidden entities placed in the NoShow space. By default, they are not exported.

●     hidden entities placed in layers that are not visualized (for more information, see Using Visualization Filters).  
Visualization filters are now taken into account: by default, entities placed in non-visualized layers are no longer exported. 

Select the Export also NoShow entities option to export all entities belonging to both the "Show" and the "NoShow" spaces.  
Select the Export non-visualized layers option to export also all entities belonging to those layers.

Note that the entities placed in the NoShow or in non-visualized layers are exported as if they were visible entities.  
This means that reading back a STEP file generated with the Export also NoShow entities or the Export also non-visualized 
layers option will make those previously hidden entities visible.

STEP export manages invisibility in assemblies as follows:

●     invisible instances of a product or a component are not exported,

●     an instance is considered as invisible for export in a given product or component if it is invisible in all instances of this given 
product or component. 

For example: 

Let's consider the instances of AAA in the products above:

●     AAA is considered as visible for export in Product10, because it is visible in at least on instance of Product10.

●     AAA is considered as invisible for export in Product9 as it is invisible in all instances of Product9.

If you export the whole Product1 to a STEP file and re-import it in V5, this is what you get: 
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●     AAA is visible in both instances of Product10, as AAA was considered as visible for export in the initial Product10.

●     There is no instance of AAA in Product9 as AAA was invisible in that product.

  By default, no option is selected.

 

 
Header of the STEP file

 

 
Click Define... to define the header of the STEP file: 

Fill in the form displayed as required. Click Default Values to revert to the Default Values of the header. 
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The header of the exported file looks like this:

 

Assemblies

 

 
Select the required option to select the export mode. 

●     One STEP file: one STEP file only containing the structure and geometry of the components.  

●     Links to V5: a STEP file containing structure and entities PRODUCT_DEFINITION_WITH_ASSOCIATED_DOCUMENT which have 
a link with CATPart files.

●     External references to STEP :  

�❍     one STEP file containing the structure

�❍     and a STEP file for each component  
The STEP file names, for each component, have the same name as the components. 
the structure and the component STEP files are generated in one shot, in the same location.

●     External references to V5: one STEP file containing the assembly structure with external links to CATPart, CATShape, model 
V4, .cgr, .wrl files, according to AP214 and AP203 edition 2 external references mechanism.

The External References functionality is available only with AP214 and AP203 edition 2.   
A STEP file cannot refer to a STEP assembly file.  
This summary table shows you all the possible combinations within the first two frames, Export : Application Protocol and Export : 
Assemblies.  

Frame Export AP  
--------- 

Frame Export Assemblies 

203 and 203+ext(1)203 edition2 (2)214 (2)

One STEP file (3) YES YES YES
External References to STEP (4) NO (inactive button) YES YES
External References to V5 (6) NO (inactive button) YES YES
Links to V5 (5) YES YES YES

 
(1) = reference of the Application Protocol Config Control Design (AP203) 
(2) = reference of the Application Protocol Core Data for Automotive Mechanical Design Processes (AP214) 
(3) = Export of the Structure and Geometry of a CATProduct into one file only 
(4) = Export of the Structure and Geometry of a CATProduct into different files 
(5) = Export of the Structure only of a CATProduct 
(6) = Export of the Structure of a CATProduct with links to V5 for the geometry. 
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If you have no STEP license, a CATProduct can be exported only in Links to V5 mode. 

  By default, this option is set to One STEP file.
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DMU Navigator 
DMU Dimensioning and Tolerancing Review

3D Insight offers a subset of DMU Navigator and DMU Dimensioning & Tolerancing Review products without the capability to 
save the data. 
The table below lists the information you will find.

DMU Navigator

Setting Up Your Session 
Navigating 
Annotating 

Using Camera Capabilities 
Using Generic Animation 

Managing Enhanced Scenes 
Spatial Query 

3D XML Compatibility with V6 
DMU 2D Workshop 

DMU Review 
DMU Presentation 

Measuring 
Sectioning 

Instant Collaboration  
Conferencing 

Managing Applicative Data 
DMU Data Flow Processes 
Running Batch Processes 

Writing and Running a Macro 
Inserting a Document from an HTML Page 

Directly Inserting a DMU document from the Windows Explorer

DMU Dimensioning and Tolerancing Review

Visualizing 3D Annotations 
Visualizing 2D Annotations 

Visualizing Annotation Related Surfaces 
Filtering Annotations 
Mirroring Annotations 
Going to Hyperlinks 

Managing 3D Annotations in 3D XML Files
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Setting Up Your Session

 

Entering the DMU Navigator Workbench: In the Start menu, select Digital Mockup  > DMU Navigator. 

Inserting Components: Select Insert  >  Existing Component..., then select desired components via the 
Insert an Existing Component dialog box.

Viewing the Current Selection: Select one or more products then click the Current Selection icon.

Activating the Cache: Select Tools  >  Options. Expand the Infrastructure category. Click the Cache 
Management tab. Check the Work with the cache system option.

Viewing the Cache Content: Select Tools  >  Cache Content.

Searching for Named Objects: Click the Search icon, enter search criteria in the Search dialog box and click 
Search.

Resetting Component Position: To reset the position of all elements, click the Reset Position icon. To reset the 
position of selected elements, select the elements then click the Reset Position icon.

Setting Current Position as Initial Position: To reset the current position as initial for all elements, click the Set 
Current Position as Initial icon. To set the current position as initial for  selected elements only, select the 
elements then click the Set Current Position as Initial icon.

 

Importing CAD parts into a CATProduct Document: Select Insert  > Existing Component..., then select .prt 
or .asm type files via the Insert an Existing Component dialog box.

 

Defining Groups: Select one or more products in the geometry area or specification tree, click the Group icon 
then click OK in the Edit Group dialog box.
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Visualizing CATIA V4 Layer Filters: Activate the model if necessary (right-click the model and, in the 
contextual menu,  Edit  >  Representations  >  Activate Node), set the model to design mode (right-click 
the model and, in the contextual menu,  Edit  >  Representations  >  Design Mode) and in the menu bar 
select Tools  >  CATIA V4 Layer Filters.

Accessing CATIA V4 Comment Pages: Load the model, select the model and in the menu bar select Edit  >  
Properties. In lower-right corner, click More button.

Modifying the Sag Value in Visualization Mode: Work with the Cache system in visualization mode. Select the 
object and then Tools  >  Modify Sag...

Creating a Point, Line, Plane or Axis System: Explains how to create a new point, line, plane or axis system.

Moving Components: Explains the use of the parameters in the Move dialog box. 

Translating Components: Click the Translate or Rotate icon, select a component and enter an offset value in 
the Move dialog box.

Rotating Components: Click the Translate or Rotate icon, then click the Rotation tab in the Move dialog 
box. Select a component, select the rotation axis and specify an angle.

Positioning Components: Click the Translation or Rotation icon.

Applying a Transformation: Click the Translate or Rotate icon, then click the Transformation tab in the 
Move dialog box. Select a component, then specify translation and rotation values.

Snapping Components: Click the Snap icon, select the component to be moved, select a  geometric element 
on to-be-moved component, then select a geometric element on the receiving component.

 

Snapping Components using Multiple Constraints: Click the Snap icon, select the component to be moved, 
select a  geometric element on to-be-moved component, then select a geometric element on the receiving 
component. Continue defining constraints as needed.

 

Performing a Symmetry on a Component: Click the Symmetry icon, select the element used as the reference 
of the symmetry,  define the symmetry parameters in the Assembly Symmetry Wizard dialog box and 
validate.

 

Rotating a Component by Using the Symmetry Command: Click the Symmetry icon, select the element used 
as the reference of the symmetry,  select the component to be moved, check the option Rotation, new 
instance or Rotation, same instance, select a plane (XY, YZ or XZ) and validate.
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Entering the DMU Navigator Workbench

This task shows you how to enter the DMU Navigator workbench and open a new document. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Select Digital Mockup > DMU Navigator from the Start menu.

The DMU Navigator workbench is loaded and a DMU Navigator document is opened. 

 

The DMU Navigator workbench comprises: 

●     a specification tree and a geometry area

●     specific toolbars

●     a number of contextual commands available in the both the specification tree and the geometry area
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Clicking off View  >  Specifications in the menu bar removes the specification tree and enables you to use the 
entire screen for the geometry. 
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Inserting Components

This task shows you how to insert components into a DMU Navigator document. 
 

 
1.  Select the Insert  >  Existing Component... command.

 
It is possible to insert a component via HTTP in visualization mode. The document will be visualized and a cgr file 

will be generated in the cache. Supported document types are:

●     CATPart

●     model

●     cgr

 

If the menu item cannot be selected, right-click product1 in the specification tree and select Components 
 > Existing Component... from the contextual menu. 
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2.  In the Insert an Existing Component dialog box, select the file location.

3.  Click the Files of type: list.

4.  Select the desired type from the following: 

Formats supported on all operating systems: 

●     CATIA V4 Assembly Modeling Files (*.asm)  (In CATIA Only)

●     BYU 

●     CATIA V5 Parts (*.CATPart)

●     CATIA V5 Products (*.CATProduct)

●     CATIA Graphical Representation Files (*.cgr)

●     DenebDevice (*.dev)

●     CV Graphic ASCII Format (*.gaf)

●     CV Graphic Binary Format (*.gbf)

●     Ideas Facetted Format (*.iff) 

●     CATIA V4 models (*.model)

●     CATIA V4 session (*.session)

●     NCGM (*.ncgm)

●     WaveFront OBJ (*.obj)

●     PDB files (*.pdb)

●     PS Optegra files (*._ps) 

●     SLP (*.slp)

●     STL (ASCII and binary) (*.stl)

●     Deneb Workcell (*.wcl)

●     VRML 2.0 Files (*.wrl)

●     iges

●     STRIM and STYLER models (*.tdg) 

●     N4D Scenes (*.wrl) (geometry and product references only)

●     HSF version 14.0 (*.hsf)  

Note: For Pro/Engineer, Ideas and Unigraphics Multi-CAD file types that can be inserted into DMU Navigator 
documents, see the corresponding documentation:

●     MULTICAx PD Plug-in (Pro/Engineer)

●     MULTICAx ID Plug-in (Ideas)

●     MULTICAx UD Plug-in (Unigraphics)
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●     3D XML

The following applicative data can now be saved in 3D XML format:

●     Annotated View 

●     Alternate View (Enhanced Scene)

●     Presentation

●     Section

●     Measure

●     Animation

For more information concerning the 3D XML format, see the following tasks in the Infrastructure 
Guide: 

●     Opening Existing Documents

●     Saving Documents In Other Formats

●     3D XML Format

●     Customizing, 3D XML 

 Formats supported on Windows only:

●     dxf3D Parts (*.dxf)

●     SolidEdge Parts (*.par)

●     Acis (SAT) (*.sat)

●     SolidWorks Assemblies (*.sldasm)

●     SolidWorks Assemblies (*.SLDASM)

●     SolidWorks Parts (*.sldprt)

●     SolidWorks Parts (*.SLDPRT)

●     ParaSolidX_B Parts (*.x_b)

●     ParaSolidX_T Parts (*.x_t)

 

 

Models, parts and products are loaded in visualization mode, i.e. without associated technological data (only 
visualization data is loaded). To access technological data, you must switch to design mode. This is done by 
selecting components inserted in the specification tree and then Edit  >  Representations  >  Design Mode 
from the menu bar. 

 

 

You can visualize the parts in your product structure using the function Edit  >  Representations  >  Activate 
terminal nodes.
●     A Loading in Progress dialog box indicates how many objects remain to be visualized. 

●     You can interrupt this loading process by clicking the Interrupt button. 
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The insert of the following document types depends on the Visu Format Unit setting (see External Formats):

●     SLP

●     STL

●     OBJ

●     BYU 

●     IFF

●     _PS

Note: For a file of type _PS, the Visu Format Unit must be set to 10. 

5.  Click Open in the dialog box. 

The DMU Navigator document now looks like this: 

 

 

Note: You can load the product structure only and then specify which 3D representations to insert.  
You need to check the option Do not activate default shapes on open. For more information, see Product 
Visualization in the Infrastructure User's guide. 
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Adding CDM Products: For more information, see the V4 Integration User's Guide, Adding a CDM Product to a 
Product on UNIX and Customizing CDMA Data in CATIA Version 5 on UNIX. 

 

 

Reading Parts and Assemblies from VPM: For information on reading parts and assemblies in VPM, see the V4 
Integration User's Guide, Building a V5 product from a VPM1-PSN Window.

Using File  > Open, you can open 2D documents in the following formats: 

●     cgm

●     V4 model (in ENOVIA-DMU Navigator only the draft tab is available)

●     AutoCAD files (*.dxf, *.dwg)

●     CATIA V4 drawings (*.model)

●     CATIA V4 image files (*.picture)

●     CATIA V5 CATDrawing (*.CATDrawing)

●     tiff, jpeg, bmp, picture (and other 2D Raster formats)

●     HPGL

●     HPGL2  (supports images and is printable)

Support of the 2D dxf format has been improved to provide the following: 
●     text support

●     color and line types attributes

●     polyline support

●     dimension support

Note: Some limitations remain in the current version:

●     strikethrough and underlined text attributes are not taken into account

●     polylines are not filled

●     hatching is not supported

●     vertex entities are not correctly transcribed

●     viewport is not supported 
 

For more information on working with 2D documents, see DMU 2D Workshop.
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Inserting Sample Documents

Sample documents installed along with the online help library are provided in many cases to support the scenario 
that explains how a specific command works.

In the online documentation filetree, there is one samples folder for each user's guide. For more information on 
where sample documents are installed by default, see Accessing Sample Documents in the Infrastructure User's 
Guide. 

When you insert a CATProduct containing applicative data, you will have the possibility of importing its applicative 
data. See Importing Applicative Data from an Inserted Component.
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Viewing the Current Selection 

The object or objects selected make up the current selection. The Current Selection command enables you to see the geometry and 
specification tree views of the current selection. For a description of the various selection techniques, see the Infrastructure User's Guide. 
 
The visualization in the Current Selection dialog box is now the same regardless of how you select the objects in step 1:
●     objects selected in the specification tree

●     objects selected in the geometry (the object displayed will be either the selected object itself or the selected object's first parent visible in 
the specification tree) 

●     objects selected in the geometry with products selection activated

●     objects selected while working in visualization mode

●     objects selected while working in design mode

It is also now possible to multi-select elements when using the View Related Objects option.

As of R15, Current Selection behavior has changed, it is now based on SELECTED objects only (highlighted objects are no longer included). 
 

Open the AIRPLANE.CATProduct file from the samples folder:

AIRPLANE.CATProduct

 

1.  In the geometry area or in the specification tree, select one or more objects (e.g. lower.1, upper.1 and rudder.1).

2.  Click the Current Selection icon  in the DMU Review Navigation toolbar. 

The Current Selection dialog box appears. It indicates all selected objects and contains two tabs, enabling you to visualize either the 

specification tree or 3D view of your current selection.  

Important: When you select objects, it is recommended that you select them in the main window, even though it is possible to select them in 
the Current Selection dialog box. 
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3.  Check the Freeze checkbox to freeze the contents of the dialog box on the current selection.

4.  In the Tree tab of the Current Selection dialog box, select an object (e.g. rudder.1). 

The object is highlighted in the specification tree. 

Note that the Current Selection dialog box content is not updated because the Freeze option is activated.

5.  Uncheck the Freeze checkbox. 

The dialog box is updated and now displays only the last object selected.

6.  Check the Reframe on selection checkbox to fit the selection into the available space in the geometry area. 

 

 

 

7.  Check the View related objects checkbox to navigate through objects linked to the current selection. 

 

 
 
Note: View Related Objects is available if and only if at least one of the selected objects has relationships. If the set of selected 

objects does not have a relationship, then the View Related Objects will be grayed out. The command Product Selection enables you to 

select an object that has such relationships.
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Relationships

Relationships identified are parents, any children or connected objects and relationships between objects. Products, groups, simulation, shuttles 
and AEC objects are all taken into account.

These relationships could sometimes be different from the parent relationships visible in the specification tree (e.g. for groups, there is no 
parent relationship in the specification tree). 
 

 Attribute Inheritance

The following scenario illustrates the rule that elements in the 3D tab of the Current Selection dialog box are displayed with their own attributes 
(e.g. color, texture, materials, position, etc.), that they do not inherit attributes from their fathers.

 
 

8.  Change lower.1 to design mode (right-click lower.1 and select Representations  >  Design Mode from the contextual menu) and 

then expand its product structure. 

 

 
 

9.  Modify the color property of lower.1 (e.g. to purple). 

Note that the modified color is reflected in the 3D tab of the Current Selection dialog box. 

 

 
 

3D Insight Version 5 Release 19 Page 310 of 1379



 
 

10.  In the specification tree, select the product root. 

The color modified in step 9 is still reflected in the Current Selection dialog box.

11.  In the specification tree, select the lower CATPart. 

Although the modified color of lower.1 is still displayed in the viewer geometry area, the Current Selection dialog box reflects that 

lower has not inherited the modified color. 
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Contextual menu commands are available in the Current Selection dialog box. 
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Activating the Cache

Working with a Cache System:

Two different modes are available when a component (V4 model, V5 CATPart, V5 CATProduct, etc.) is inserted into 
a DMU Navigator CATProduct document:

●     Design mode: in this mode, the exact geometry is available and the document is inserted as is.

●     Visualization mode: in this mode, a representation of the geometry only is available and the corresponding cgr 
file, if it exists, is inserted from the cache system. 
Using a cache system considerably reduces the time required to load your data.

The cache system is organized into two parts:

●     Local cache: a read/write directory located on your machine or on the network and used to store cgr files.  
The first time a component is inserted, it is tessellated. This means that the corresponding cgr file is computed 
and saved in the local cache as well as displayed in the document window. The next time this component is 
required, the cgr file which already exists (and not the original document) is automatically loaded from the local 
cache. The user is normally responsible for the local cache.

●     Released cache: a read-only cache which is not necessarily located locally on your machine. 
Several directories can be defined for the released cache. If the cgr file cannot be found in the local cache, the 
DMU Navigator browses released directories in the order listed to check whether it is located in one of them. If it 
is still not found, the component is tessellated and saved in the local cache. The site administrator is normally 
responsible for the released cache.

Reading Components from a Database: The cache system works in exactly the same way when components 
inserted into a CATProduct document come from a database. An additional check is run: if the cgr file is not found 
in the local or released caches, the DMU Navigator requests that, if the cgr file exists in the database, it be 
downloaded.

For more information, see the Infrastructure User's Guide, Cache Management.

1.  Select Tools > Options from the menu bar. 

The Options dialog box is displayed.

2.  Expand the Infrastructure category in the left-hand tree.

3.  Click the Cache Management tab.

4.  In the Cache Activation box, check the Work with the cache system option.

5.  Click Ok to confirm your operation.

6.  Restart the session.
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Viewing the Cache Content

This task shows you how to view the contents of the cache. 

For information on working with a cache system, see About Working with a Cache System.

The cache system is managed via the Cache Management tab in the Options dialog box. For more information, see Cache 
Management.

V4 cache is supported in V5 via symbolic links. 
 
A DMU Navigator document is open.

1.  Select the Tools  >  Cache Content command. 

The Cache Content dialog box appears listing the contents of the local cache.

Information such as whether or not the cache system is turned on, the current cache used and the maximum cache size is also 
given in the dialog box. 

2.  To select the cache directory whose contents you wish to review, click the Cache directory selection button and select 

the desired cache directory from the proposed list. 

By default, the contents of the local cache are shown.
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3.  To choose the file type of the viewed content, click one of the three radio buttons:

●     cgr

●     3dmap

●     NCGM

4.  To sort the cache contents on one of the attributes (reference file, last write access, file name in cache, cache 

timestamp), click the gray bar containing the attribute name.

5.  To delete files from the cache, select the files to be deleted (all multi-select possibilities can be used) and click the 

Delete Cache files button at the lower-left of the panel.

6.  Click Close when done.
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Searching for Named Objects 
(General Mode)

This task explains how to perform a quick search for and select a named object.

You can search for:

●     objects with a specific name, or of a specific type or color

●     product properties

●     objects created using a specific workbench, in the current document or throughout the whole product structure.

 

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

 

1.  Select the Edit > Search... command (shortcut: Ctrl+F). 

The Search dialog box appears. 

2.  Click the General tab.
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If the Select command was active before you selected the Search... command, it remains active. 

You can work with other commands while the Search dialog box remains open:

●     you can run commands using the menus and icons

●     you can apply commands in contextual menus to selected search results using the power input field: for example, you can 
manipulate selected specification tree elements using the "c:center on", "c:center graph", "c:cut" commands. 

 

3.  Enter the name body* in the Name text-entry field and click the Search button. 

The two body items are highlighted in the list in the Search dialog box, a query is generated in the Generated 

queries field and the body items are pre-selected in the geometry area.
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4.  Click the Select button to select the items. 

The body items are selected. 

5.  Click OK to close the Search dialog box. 

Note that clicking OK has the same effect as clicking both the Select and Close buttons.
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You can sort the results in the Search dialog box by Name or by Path by clicking the corresponding column header. 

For more detailed information, see Selecting Using the Search... Command (Favorites and Advanced Modes) in the 
Infrastructure User's Guide. 
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Resetting Component Position 

 

 This task will show you how to reset the position of all or selected elements. 
 

Open the Move.CATProduct document.

 
1.  Move some of the elements using the 3D Compass (see Moving Objects Using the 3D Compass in the Infrastructure User Guide).

2.  To reset the position of all elements that have been moved, click the Reset Position icon . 

 
All elements are reset to their initial position. 

3.  To reset the position of selected elements only, first select the elements, then click the Reset Position icon . 

 
The selected elements are reset to their initial position. 

In the above, the term initial position signifies the following: 
●     for an existing document - the position of a product when the document was opened

●     for an inserted document - the position of a product when the document was inserted

●     for a new document - the position of a product when the document was created
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Setting Current Position as Initial Position 

 

 This task will show you how to set the current position as the initial position for all or selected elements. 
 

Open  Move.CATProduct document.

 
1.  Move some of the elements using the 3D Compass (see Moving Objects Using the 3D Compass in the 

Infrastructure User Guide).

2.  To set the current position as initial for all elements, in the DMU Move toolbar, click the Set Current 

Position as Initial icon . 

 
The current position becomes the initial position for all elements. 

3.  To set the current position as initial for the selected elements, first select the elements, then, in the DMU 

Move toolbar, click the Set Current Position as Initial icon . 

 
The current position becomes the initial position for the selected elements. 

4.  Now change the position of  some elements of the document (using Translate, Rotate, Position, 

Transform).

5.  Click the Reset Position icon . 
 
The position of all elements is reset to the new initial position. 

In the above, the term initial position signifies the following: 
●     for an existing document - the position of a product when the document was opened

●     for an inserted document - the position of a product when the document was inserted

●     for a new document - the position of a product when the document was created
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Importing CAD Parts into a CATProduct Document

This task shows you how to import data contained in CAD Parts or Assemblies into a CATProduct document. The 
main objective of such an import is to be able to read data which remain synchronized with the most up-to-date 
level available. 
 

The DMU Navigator Solution is an open system capable of importing data from the most widely used data 
standards and CAD systems. You can easily preserve your CAD investment while still benefiting from the DMU 
Navigator Solution. 

Translation Modes 
Two translation modes are supported:

●     Batch mode

●     Associative mode

Imported Elements 
As the data contained in the parts you import are loaded in DMU Navigator, they are inserted as additional 
representations in the DMU product structure, along with any other representations previously inserted from 
another supported source. Once imported, the data can be managed just as if it were created in the session. 
 

prt and asm extensions are not natively supported in CATIA, therefore DUL and DPL licenses (ENOVIA) are required 
to import documents having these extensions. 

DMU Navigator P2.

1.  Select the Insert  >  Existing Component... command. 

 
Note: If the menu item cannot be selected, right-click product 1 in the specification tree and select 

Components  >  Existing Component... from the contextual menu. 
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2.  In the Insert an Existing Component dialog box, select the file location.

3.  Click the Files of type: list.

4.  Select the desired type from the following:

●     .prt

●     .asm 
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Models, parts and products are loaded in visualization mode, i.e. only visualization data is loaded, associated  
technological data is not loaded. To access technological data, you must switch to design mode. This is done by 
selecting components in the specification tree and then, in the menu bar, selecting  Edit  > Representations 
 > Design Mode.

To set external format import settings, see the Infrastructure User's Guide, External Formats. 
 

 
5.  Click Open in the dialog box.
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Defining Groups 

 

 

This task explains how to define groups of products. A group is a set of products explicitly defined by selecting products individually. Groups are persistent 
and can be stored in the document. 

Insert the following cgr files from the cfysm samples folder:

ATOMIZER.cgr 
BODY1.cgr 
BODY2.cgr 
LOCK.cgr 
NOZZLE1.cgr 
NOZZLE2.cgr 
REGULATOR.cgr 
REGULATION_COMMAND.cgr 
TRIGGER.cgr 
VALVE.cgr 

1.  In the specification tree or in the geometry area, select the products you wish to constitute the initial group content (you can use ctrl-click to multi-

select products).  

 

 
 
 

Creating a Group
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1.  To create a Group, in the DMU Review Creation toolbar, click Group  or, in the menu bar, select Insert > Group . 

The Edit Group dialog box and the Preview window appear. 

The Preview window displays the selected products. 

 

 
 

●     Product representations visualized in the Group Preview window do not take sticker representations into account.

●     When you select objects, it is recommended that you select them in the main window, even though it is possible to select them in the Preview dialog box. 

To customize the default display setting for the Preview window, see Customizing General DMU Settings in the DMU Navigator user guide.

1.  To add a product to the Group content, select the product in the specification tree or the geometry area. 

The product is added to the Group content listed in the Edit Group dialog box.

2.  To remove a product from the Group content, you can: 

 

�❍     de-select the product in the Specification Tree or in the Main window, or,

�❍     select the product in the Edit Group dialog box and click Remove from Group  , or, 

�❍     select the product in the Preview window, right-click and select Remove in the contextual menu.

 The multi-selection is now available in the Identifier list of the Edit Group dialog box. 
 

3.  In the Name text-entry field, enter a name for the group you wish to create.

4.  Click OK to create the group. The group is identified in the specification tree. Groups created in this manner are persistent and can be stored in the document. 
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 Editing a Group

1.  To edit a group, in the specification tree, double-click the group, or, right-click the group and select Group.1 object > Definition from the contextual menu. 

 
The Edit Group dialog box appears and lists the content of the group you just created. Products in the group are highlighted in the specification tree and in 

the geometry area.  

 

 
 

Note that although the group is selected and its content is highlighted in both the specification tree and in the geometry area, the group content is not 
considered selected. 

2.  Modify the Group content as desired.

3.  Click OK to confirm.

 
Selecting Group Content in the Main Viewer

1.  To select the Group content in the main viewer, right-click the Group in the specification tree and select Group.1 object > Select Content from the 

contextual menu. 

The group components are highlighted in both the specification tree and in the geometry area and the group content is considered selected. 

 

Hiding Group Content
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1.  To hide the Group content, click Hide/Show  . The group components are hidden and the icons are grayed out in the specification tree. 
 

If you then move individual components back into the show space, the group icon in the specification tree remains grayed out.

 

 Showing Hidden Components in the Preview Window 

1.  After having hidden the group content in the previous step, double-click the Group in the specification tree. The Edit Group dialog box and the Preview 

window appear. The group content is indicated in the specification tree, but the icons are still grayed, indicating that the products are hidden. The Edit 

Group dialog box will look as follows: 

 

 
 

2.  In the Edit Group dialog box, select all of the components (the multi-selection is now available) and click Show Hidden Objects . The Visibility 

attribute of each component will still be Hide, corresponding to the visibility status in the Main window. but the components will now be visible in the 

Preview window. 
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This functionality does not work for Manikins.

In the Edit Group dialog box, the value in the Visibility column corresponds to the value of the graphic property of the instance and is consistent with the 
visibility state of the icon in the specification tree. However, it is possible, due to inheritance, that it not be consistent with the product as displayed in the 
Main window. 
 

 Cross-Highlighting between the Edit Group dialog box and the Preview window

1.  In the Edit Group dialog box, de-select LOCK and NOZZLE_1_2. 

The components are also de-selected in the Preview window.

2.  In the Preview window, re-select LOCK and NOZZLE_1_2. 

The components are now selected in the Edit Group dialog box. 

 

The multi-selection is now available in the Identifier list of the Edit Group dialog box.

 Defining Groups of Groups
You can now define groups of groups. A group that contains sub-groups will be automatically updated upon any modification to the content of its sub-groups.

Note: When you expand a group in the specification tree, you will not see products belonging to any sub-groups in order to avoid possible confusion with 
the product structure tree content.

1.  Create Group.2 consisting of the components BODY_1_2 and BODY_2_2.

2.  Create Group.3 consisting of components VALVE and ATOMIZER.

3.  Click the title bar of the Edit Group dialog box to activate it.

4.  In the specification tree, click Group.2. 

Group.2 is added to the content of Group.1.

5.  In the specification tree, click Group.3. 

Group.3 is added to the content of Group.1.

6.  In the Edit Group dialog box, click OK to confirm. 

The content of Group.1 in the specification tree now includes Group.2 and Group.3 as sub-groups. 

7.  In the specification tree, select Group.1. 

The content of Group.1 is highlighted in the main window. Its content now includes its original content as defined above in the section Creating a Group plus 

the content of its sub-groups, Group.2 and Group.3.

 Replacing by highest common Father
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The objective of this command is to optimize group content by replacing a set of brother products by their common father when all of the brothers belong to 
the same group. This optimization is especially interesting when selecting a group and highlighting its content. 

Note: The optimization is not applied recursively on sub-groups.

With the following product structure, the composed groups would be transformed as presented by the application of the Replace content by higher 
father command.

1.  In Tools > Customize, add the Factorize Content command using a customized toolbar or access the command directly in Views > Commands List.

2.  If you added the command using a customized toolbar, click Replace content by higher father  . Brother products are accordingly replaced by 

their highest common father.

 Replacing Content by Terminal Nodes
This command explodes groups: products are replaced by their children.

Note: This command is not recursive on sub-groups, sub-groups will be not exploded.

With the following product structure, the composed groups would be transformed as presented by the application of the Replace content by terminal 
nodes command.

1.  In Tools > Customize, add the Explode Content command using a customized toolbar or access the command directly in Views > Commands List.

2.  If you added the command using a customized toolbar, then click Replace content by terminal nodes . 

Content is replaced by its terminal nodes accordingly. 

 

�❍     Alternatively to select a subset of components from the Edit Group dialog box select the 

corresponding Identifiers and click Select  .

�❍     You can also modify group properties (color, line type and weight). 
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Visualizing CATIA V4 Layer Filters

This task enables you to visualize layer filters that have been defined for CATIA V4 models.

Insert the document LayersV4.model from the samples folder:

LayersV4.model 

CATIA V4 layer filters can now be accessed in visualization mode. (You must have first generated a cgr file using the CATDMUUtility with the option -apps 
lnf. See Running the CATDMUUtility Batch Process.) 

 

1.  Select the V4 model in the specification tree.

2.  In the menu bar, select the Tools  >  CATIA V4 Layer Filters... command.

 

The Layer Filter dialog box appears. 
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4.  In the Available Filters column , select one of the filters and click Apply.

Only those layers that are defined for the selected filter will be displayed in the visualization space. The displayed layers are listed in the Visible Layers column.

 

5.  Click OK to confirm.

Note: The Create, Modify and Delete buttons at the upper-right of the Layer Filter panel are grayed out. It is not possible to execute any of these 
actions from the DMU Navigator.
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Accessing CATIA V4 Comment Pages

 This task will explain how you can access V4 comment pages in visualization mode. 

You must have first generated a cgr file using the CATDMUUtility with the option -apps com. See Running the 
CATDMUUtility Batch Process. 
 

 
1.  Load the model.

2.  Select the model and in the menu bar, select Edit  >  Properties.

The Properties panel appears.

3.  In the lower-right corner, click the More button.

The Comment tab appears and the comments are displayed.
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Modifying the Sag Value in Visualization Mode

This task shows you how to modify the sag value in order to obtain a finer mesh for an object, which can be useful when you check your document for 
clash, contact and clearance conflicts to determine whether document components interfere with each other. 

This functionality works with .model and CATParts documents. 
Note that the sag value cannot be modified for objects composed of multiple shapes. 
  

Open the MODIFY_SAG.CATProduct document. 
Be sure you work in visualization mode, with the Cache system on. To activate the cache system, see Activating the Cache.

1.  Double-click the Interference Results.1 in the specification tree. 

The Check Clash dialog box appears. 

There is a contact detected between MODIFY_SAG.1 and NOZZLE1.1.

You are  now going to modify the sag value of the two components involved in the clash detection to obtain a finer result. When done, you will run the 
clash detection again. 

2.  Select the components you need in the specification tree (e.g. NOZZLE1.1, NOZZLE2.1, ATOMIZER.1 and MODIFY_SAG.1).
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3.  Select the Tools  >  Modify Sag command. 

The Dynamic 3D Accuracy dialog box appears. The sag field provides information on the current sag applied to the selected component.

Note that all the documents in the 3D Accuracy dialog box are selected and that the Apply button is grayed out since no modification has been 
proposed. 

Note that 0.2 is the default sag value (see Tools  >  Options >  General  >  Display  >  Performances  >  3D accuracy  >  fixed).

Sag  

The sag corresponds to the fixed sag value for calculating tessellation on objects (3D fixed accuracy) set in the Performances tab of Tools  >  Options 
 >  General  >  Display. By default, this value is set to 0.2 mm. The sag value set in this tab is offset from the skin inwards on both selection 1 and selection 2.
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3D Accuracy: 

Managing 3D Accuracy allows you to modify sag value depending on the tasks performed (clash detection, review). 

The 3D Accuracy controls the tessellation of surfaces (the surfaces of your geometry are built using a mesh of polygons). You have two choices in the Tools 
 >  Options >  General  >  Display  >  Performances dialog box:

●     fixed sag value (values between 0 and 1) for calculating tessellation on all objects, which does not vary with object size

●     proportional sag value (values between 0 and 10) for calculating tessellation on all objects, which does vary with object size

A low value (close to 0) means that a very fine mesh is used to render surfaces, but the drawback is that geometry will be redrawn more slowly when using 
the viewing tools 

A high value (close to 1 for a fixed sag value, close to 10 for a proportional sag value) means that a very coarse mesh is used, but the advantage is 
that geometry will be redrawn much faster.

  

This command now enables you to select the documents to be re-tessellated within the Dynamic 3D Accuracy dialog box and to perform re-tessellate any 
number of times with different sag values and without exiting the dialog box. 

Note the following general behavior:

●     When the Dynamic 3D Accuracy dialog box is opened, all the documents are selected. You can select those documents in the list for which you wish to 
modify the SAG value.

●     If no document is selected or the selected ones already have the specified New 3D Accuracy value, the Apply button is not grayed out.

●     When you click the Apply button, the selected documents are re-tessellated with the specified New 3D Accuracy value. The values in the SAG column 
are updated accordingly.

●     The Apply command can be used multiple times in order to perform multiple re-tessellations with the 3D Accuracy values of your choice and without exiting 
the dialog box.

●     When you click the Close button, the Dynamic 3D Accuracy panel is closed. Note, however, that this does not have the effect of  an "undo"; the 
documents are not restored with the sag value that they had before you launched the Modify SAG command.

●     When you click the OK button, the selected documents are re-tessellated with the specified New 3D Accuracy value and the Dynamic 3D Accuracy dialog box 
is closed.

●     When the New 3D Accuracy is modified by entering a value with the keyboard (instead of using the spinner) the Apply button availability is not 
automatically updated. You must validate the entered value by typing Enter and then the Apply button will be available.

4.  Select MODIFY_SAG.1 and NOZZLE1.1 and modify the New 3D Accuracy value.

Note that Apply is no longer grayed out.

5.  Click Apply.
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The progress bar is activated during the re-tessellation process. The selected documents are re-tessellated with a SAG value of 0.02 and remain selected in 
the dialog box. The Apply button is now grayed out. 

You can repeat steps 4 and 5 as many times as you wish.

6.  Click Close  to exit the dialog box. 

The resulting mesh is now much finer:

 

7.  Double-click Interference.1 in the specification tree and click Apply.  

The calculation is launched. The new sag value has been taken into account. The contact has become a clash. 
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The SAG value cannot be recuperated for certain V4 models (e.g. solids), in which case the string "NOSAG" appears in the SAG column of the Dynamic 
3D Accuracy dialog box. 

For more information about the impact of sag value in the clash detection context, please refer to About Interference Analysis in the DMU Space Analysis 
User's Guide. 
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Creating a Point, Line, Plane  
or Axis System 

 

The goal is to allow the creation of geometrical elements in a Product context. 
A user will be able to create points, lines, planes and also to define new axis systems. To do that he will either 
directly provide the new element coordinates as input or use existing objects as a basis.

If you use an existing object as a basis, that object must be in design mode. 

If you wish to use an existing CATPart for the storage of the geometrical elements,  that CATPart must fulfill two 
conditions: 
●     it must be activated

●     it must be in design mode

 

1.  Click the appropriate icon in the DMU Geometry Creation toolbar:

  Create an Axis System

  Create a Point

  Create a Line

  Create a Plane

  Create Datum

The Geometry Creation dialog box appears.
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2.  If you wish to use an existing CATPart for the storage of the geometrical elements, in the specification 

tree, select the CATPart. 

The name of the selected CATPart appears in the Select an existing one text- entry field. 

3.  If you wish to create a new CATPart for the storage of the geometrical elements, click the Create a new 

CATPart under radio button and in the specification tree, select the CATProduct under which the new 

CATPart will be created.

The name of the selected CATProduct will appear in the Create a new CATPart under text-entry field. 

4.  Click OK to confirm.

The dialog box appropriate to the geometrical element you are creating will appear. See: 

Creating an Axis System

Creating Points

Creating Lines

Creating Planes 

Creating Datum

By default, the DMU Geometry Creation toolbar is not visible in your DMU Navigator workbench. To activate it, in 
the menu bar, select View  >  Toolbars  >  DMU Geometry Creation. 
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Moving Components 

 This task explains the parameters in the Move dialog box that determine the set of components that will be moved 
along with the specific object that you displace. 

Note: You no longer need to switch to Design mode as Visualization mode and cgr files now permit selection. You can 
select lines, points, axis and  planes. 

Open the ProductForReset.CATProduct document.

1.  Click the Translation or Rotation icon .

The Move dialog box is displayed. Translation, Rotation, Position and Transformation options are 
available:

●     to translate components, see Translating a Component

●     to rotate components, see Rotating Components

●     to position components, see Positioning Components

●     to apply transformations to components, see Applying a Transformation

About the Move parameters

Apply on leaf product: this parameter enables you to manage the positioning: 

●     if set, the transformation is performed between the selected component and its father

●     if unset, the transformation is performed between the UI-Active product and the son of the UI-Active product 
which is an ancestor of the selected component (by default, the UI-Active product is the root part, for information 
about re-defining the UI-Active product, see the Product Structure User's Guide, Moving the components of a sub-
product in the parent product).

Relative move: this parameter enables you to define the behavior of the transformation, i.e. the  reference from 
which the transformation is going to be performed: 

●     if set, the transformation is performed with respect to the father component of the selected object (relative move)

●     if unset, the transformation of the selected component is performed with respect to the root product and sub-
products (absolute move)

These two parameters are set to on by default to ease the moving operations, i.e. translation, rotation, positioning 
and transformation (a combination of translation and rotation).
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The following scenario attempts to illustrate the effects of the Apply on leaf product  and the Relative move 
options. The following color associations have been established for the different products: 
●     Product 1: Yellow

●     Product 2: Red

●     Product 3: Green

●     Product 4: Blue

●     Product 5: Purple 

2.  Select Product2 in the specification tree, select the Transformation tab in the Move dialog box, enter the 

following values and press the Apply button:
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3.  Select Product3 in the specification tree, select the Transformation tab in the Move dialog box, enter the 

following values and press the Apply button:
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4.  Double-click Product2 to make it the UI-Activated product, deselect the Apply on leaf product option and 

pass the cursor over the specification tree.
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You will notice that only descendants of Product2 can be moved (indicated by the icon in form of a hand 
with pointing finger) and that the selected product must be a direct child of Product2.

5.  Select Product3 in the specification tree, select the Translation tab in the Move dialog box, enter the 

following values and press the Apply button:
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Translating Components

This task will show how to translate a component:
●     by entering translation values

●     by selecting geometric elements to define a translation direction (not described in this scenario)

The component to be translated must belong to the active component.
Open the Move.CATProduct document, then select Digital Mockup > DMU Navigator from the Start menu.

1.  Click the Translation or Rotation icon .

The 3D compass is automatically snapped onto the referential axis of the father part (the Product1 axis system). 

The Move dialog box is displayed.

Either you specify an offset value between the element and the x, y or z axis, or you select a geometric element to define the direction you need (see 
Translate Components in the Assembly User's Guide). The move is defined in terms of an offset along x, y or z axes.
For an explanation of the parameters Apply on leaf product and Relative move, see Moving Components.

2.  Select the component to be translated, e.g. GARDENA,NOZZLE_2_2.1 

The 3D compass is automatically snapped onto the referential axis of Product3, the father of GARDENA,NOZZLE_2_2.1 .
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3.  To define the translation, enter an offset value for x, y or z in the Offset boxes e.g. 100 mm for y.

4.  Click Apply. 

The selected component is translated accordingly i.e. with respect to Part.2 (Product3 axis system).

  

5.  Click Invert to reverse the previous operation and translate the component in the opposite direction. 

The translation is reversed.

You can click Apply as many times as you wish to translate the component to the desired position.

Selecting elements:

The move is defined by selecting elements or selecting an element and entering a distance.

●     Click Selection to define your translation with respect to a element. The Translation tab contents is grayed.

●     If you select a line or a plane you also need to enter a distance value. The translation is then done along the selected line or normal to the selected 
plane. Selecting two faces or planes assumes these elements are parallel.  See Translate Components in the Assembly User's Guide.
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6.  Click OK to close the dialog box.

7.  Repeat steps 1 and 2; this time uncheck the Relative move option.

 

8.  Repeat step 3.
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9.  Click Apply. 

The selected component is translated accordingly with respect to Part.2 (Product1 axis system) this time.

Translation and rotation operations are synchronized which means the values entered in the Translation tab are kept in the Rotation tab.

10.  Now click the Invert button to reverse the previous operation.

11.  Uncheck the Apply on leaf product option.

12.  Repeat steps 2 and 3.

 

13.  Click Apply. 

The selected component is translated accordingly with respect to the Root product Product1.
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14.  Click OK to close the dialog box.

You can translate components for which geometric or assembly constraints have been defined using the Shift key and the compass.
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Rotating Components

 This task will show you how to rotate a component:
●     by entering the rotation angle and specifying the rotation axis

●     by selecting a geometric element to define the rotation axis and entering the angle value (not described in this scenario)

Open the Move.CATProduct document.

 
1.  Click the Translation or Rotation icon .

The Move dialog box is displayed.  

2.  Click the Rotation tab.

 

For an explanation of the parameters Apply on leaf product and Relative move, see Moving Components.

 

3.  Select the component to be rotated, GARDENA,NOZZLE_2_2.1
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4.  Click one of the Axis options to specify the axis of rotation, e.g. the y axis.

5.  Enter an angle of rotation in the Angle box , e.g. 90deg.

6.  Click Apply to rotate the component 

The selected component is rotated accordingly. 

Note: you can apply this translation to other components. Simply select them and click Apply.

Selecting elements: 
●     Click Selection to define your rotation with respect to an element.

●     Select an element to define the axis of rotation, e.g. an edge.

This procedure is not described in this scenario, please refer to Rotating Components in Assembly User's Guide. 
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7.  You can click Apply as many times as you wish to rotate the component to the desired position.

8.  Click OK to close the dialog box.

Note: You can rotate constrained components by means of the Shift key and the compass.

 

For more information about defining rotations with respect to a geometrical element, see Rotating Components in the Assembly User's Guide. 
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Positioning Components 

 

 This task will show you how to position a component:
●     by entering the position values and specifying the axis angle values

●     by selecting a geometric element to define the rotation axis and entering the angle value (not described in this scenario)

 
Open the Move.CATProduct document.

 
1.  Click the Translation or Rotation icon . 

The Move dialog box is displayed. 

For an explanation of the parameters Apply on leaf product and  Relative move, see Moving Components.

 
2.  Click the Position tab.

3.  Select the component to be positioned, i.e. GARDENA,NOZZLE_2_2.1
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4.  Enter values for x, y and/or z to define the position e.g. enter 0.

5.  Specify angle values for RotX (e.g. 0deg), RotY (e.g. 50deg) and RotZ (e.g. 0deg).

6.  Click Apply. 

The selected component is positioned accordingly.

7.  Click OK when satisfied.
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Applying a Transformation 

 

 This task will show you how to apply a transformation. This new capability enables you to combine rotation and translation operations. You can therefore apply 
complex transformations:
●     by entering the position values and specifying the axis angle values

●     by selecting a geometric element to define the rotation axis and entering the angle value (not described in this scenario)

 
Open  Move.CATProduct document.

 
1.  Click the Translation or Rotation icon .

2.  The Move dialog box is displayed. 

 
For an explanation of the parameters Apply on leaf product and Relative move, see Moving Components.

Case: You know the transformation to be applied to the component 

3.  Click the Transformation tab.

4.  Select the component to be applied a transformation, i.e. GARDENA,NOZZLE_2_2.1

3D Insight Version 5 Release 19 Page 360 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/dmnug_C2/samples/Move.CATProduct


 
5.  Enter values for dx (i.e. 0mm), dy (i.e. 100mm)  and dz (i.e.0mm)  to define the translation.

6.  Specify angle values for dRotX (i.e. 0deg), dRotY (i.e. 50deg) , dRotZ (i.e. 0deg) to define the rotation.

7.  Click Apply. 

The selected component is positioned accordingly (both translation and rotation are applied to the component).

8.  Click Undo.
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 Case: You do not know the transformation to be applied to the components 

3.  Click the Selection button.

4.  Select the GARDENA,NOZZLE_2_2.1. axis system. When done, select Part2 (Part2.1) axis system. 

The calculation to move from GARDENA,NOZZLE_2_2.1 axis system to  Part2 (Part2.1) axis system is automatically performed as shown below:

 

Note: The Relative move option is not available when using the Selection .

5.  In the specification tree, select the component to which you wish  to apply this transformation (e.g. Product2).

6.  Click Apply .

This is what you obtain: 
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7.  Click OK when satisfied.
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Snapping Components  

This task illustrates how to snap a component onto another component. 

●     The Snap makes only simple snaps, see the Assembly Snaps reference to know more about simple snaps 
capabilities. 
Using this command is a convenient way to translate or rotate components.

●     The Snap is able to work in visualization mode, which means the positioned component and the positioning 
parts are no longer need to be switched into design mode. However, in order to select lineic elements, you 
must be working in Design mode.

●     For DMU Navigator, this task is P1-only.

●     The element to be snapped must belong to the active component.

Open the Moving_Components_01.CATProduct document:

●     Make sure you work in Design mode (use Edit > Representations > Design Mode) 

1.  Click the Snap icon:  

2.  Select the red face as shown.

 

The element selected first is always the element that moves.
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3.  Select the blue face as shown.

 

 The red face is projected onto the plane defined by the blue face.

 A green arrow is displayed on the first face you selected.

 

4.  Click this arrow to reverse the orientation of the face.
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Snapping Components using Multiple Constraints 

 

 Multiple-Constraints Snap consists in creating a series of constraints on-the-fly, thereby reducing the 
degrees of freedom of the components. 

One distinguishes four states: 

●     selection of the component to be moved

●     selection of the 1st geometric element, belonging to the to-be-moved component

●     selection of the 2nd geometric element, belonging to the component to which the to-be-
moved component will be snapped (henceforth referred to as the receiving component) 

●     a state where the user is asked to accept the proposed solution or to invert the 
snapping direction

You can now choose among several input selection types in order to specify and filter the pre-selected geometries.
●     Any geometry: The behavior is the same as the default behavior provided in previous versions.

●     Point only: Only points can be selected. Notice that when switching from Design mode to Visualization mode, some points (in fact vertex) are no longer 
selectable (neither highlighted). To select those points (in fact edge limits), you will have to use the  Characteristic points option.

●     Line only: Only straight edges can be selected.

●     Plane only: Only planar surfaces can be selected. Notice that the plane representation displayed during pre-selection is now centered on the center of 
gravity.

●     Characteristic points: On curves (lines, circles and curves), you could want to select the mid-point or the extremity points. The pre-selected point is the 
closest point to the picking point.

●     Arc center: The center of the arc is selected.

●     Picking point: The point on geometry under the mouse cursor is selected.

●     Picking axis: An axis is built, with the picking point as origin and the normal of the picked face or the tangent of the picked edge as Z-axis. 
 

The following table summarizes the behavior:

Geometry type selected in combo Detected geometry

Any geometry

line: line 
plane: plane (origin in COG) 
axis system: axis system 
circle, cylinder, cone: line (axis) 
sphere: center 
curve, surface, volume: picking point

Point only point: point

Line only line: line 
circle, cylinder, cone: line (axis)

Plane only plane: plane (origin in COG) 
circle: plane containing the circle

Characteristic points

point: point 
line, circle, curve: start, middle, or endpoint (whichever is closest to 
picking point) 
plane: COG 
axis system: origin 
sphere: center 

Arc center circle: center
Picking point all geometry types: point

Picking axis

line: Z-axis 
plane, cylinder, cone, sphere, surface, volume: Z-axis normal at 
picking point 
axis system, circle, curve: Z-axis tangent at picking point

 

 Selected Geometry Type 
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Any 

geometry Point only Line 
only Plane only Character- 

istic points
Arc  

center
Picking 

point Picking axis
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Point point point   point  point  

Line

line  line  

start, middle 
or end point 

(the closest to 
the picking 

point)

 point z axis

Plane plane 
(origin in 

COG)
  

plane 
(origin in 

COG)
COG  point z axis normal at 

picking point

Axis 
system axis system    origin  point z axis tangent 

at picking point

Circle

line (axis)  line 
(axis)

plane 
containing 
the circle

start, middle 
or end point 

(the closest to 
the picking 

point)

centre point z axis tangent 
at picking point

Cylinder
line (axis)  line 

(axis)    point z axis normal at 
picking point

Cone
line (axis)  line 

(axis)    point z axis normal at 
picking point

Sphere
centre    centre  point z axis normal at 

picking point

Curve
picking 
point    

start, middle 
or end point 

(the closest to 
the picking 

point)

 point z axis tangent 
at picking point

Surface
picking 
point      point z axis normal at 

picking point

Volume
picking 
point      point z axis normal at 

picking point

Open the SMART_TARGET.CATProduct file from the cfysm samples folder:

SMART_TARGET.CATProduct 
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Before you launch the Snap command, you should be sure to select a component in the Specification Tree other than the root. 

1.  Click the Cumulative Snap icon .

The Cumulative Snap toolbar appears. 
The toolbar icons are grayed. If the two selected geometric elements are two lines, two planes, an axis system and a line or an axis system and a 
plane, the toolbar icons will be activated. 

The Cumulative Snap toolbar enables you to invert by rotation around two axes: around the U axis (as was proposed in previous releases) and 
around the V axis. 

 

The Cumulative Snap functionality does not take the UI-activated component into account. You must explicitly indicate the component to be moved. (If you 
wish to simulate the UI-activated behavior, you can select the UI-activated component in the specification tree.) 
 

2.  Select the component to be moved, e.g. the Disk cylinder.

 

3.  Select a geometric element (a point, line, plane or axis system) on the same to-be-moved component, e.g. a circle of which the center is the 

center of the entire Disk cylinder in the sample product.
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4.  Select a geometric element on the component to which the to-be-moved component will be snapped, e.g. a circle of which the center is the center 

of the entire Rim cylinder in the sample product (henceforth referred to as the receiving component). 
The first constraint is created. The Disk cylinder is displaced in accordance with the first constraint. You can continue directly to the creation of the 

second constraint.

 

  

5.  Select a geometric element on the to-be-moved component, e.g. the axe passing through one of the nuts of the Disk cylinder.
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6.  Select a  geometric element on the receiving component, e.g. the axe passing through one of the nut holes of the Rim cylinder. 

The second constraint is created. The Disk cylinder is displaced in accordance with the second constraint. You can continue directly to the creation 

of the third constraint.

 

7.  Select a geometric element on the to-be-moved component, e.g. the plane of the Disk cylinder containing the nuts.
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8.  Select a geometric element on the receiving component, e.g. the plane of the Rim cylinder containing the nut holes. 

The third constraint is created. The two components have been placed together as a function of the three constraints.
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9.  Rotate to verify that the snap has been implemented as desired.
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Multi-selecting Components
 The goal of this enhancement is to enable the selection of multiple components as input. You must the select all the components (in the product tree or in 

the 3D geometry) before launching the Cumulative Snap command. Once in the command, you will then be able to select the first geometry to snap from 
among any of the components belonging to the selected input. 

Note the following limitations:
●     Multi-selection is only available before you launch the Cumulative Snap command. If you do not make a selection before you launch the command, the 

multi-selection will not be available.

●     Other objects currently handled (e.g. shuttles) will not be supported for multi-selection. 

 
Multi-selecting Components with Ascendance Relation

Consider the following structure:
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If you select [P1.1, P1, P2], you will be able to select a first geometry belonging to P1 (geometry can belong to P1.1 or not) or P2, and a second geometry 
under P3. The transformation computed to snap the first geometry on the second geometry will then be applied to P1 only, highest father of the sub-set 
[P1, P1.1] and P2. This ensures that the set of components selected as input to the Cumulative Snap command will be kept as a rigid bloc along the 
definition of multiple constraints, which is a condition to the definition of a consistent constraints environment. 
Open the 5cubes_with_data.CATProduct file from the dmnug samples folder:

5cubes_with_data.CATProduct
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1.  Keeping the Ctrl key pressed, select Cube.Red, Cube.Blue and Shuttle.1 geometry using the selection trap (by dragging a rectangle to 

encompass the desired selection), select a face of Cube.Green in geometry, select Cube.Grey, Product2.1, Product1 and Camera 1 in the 

specification tree.  

You should have something like this: 

 

2.  Click the Cumulative Snap icon . 

The selection will be filtered and only the Cube.Green, Cube.Grey, and Product2.1 components will be highlighted. 

3.  Select the top face of Cube.Blue as the first geometry to snap. 

You will notice that selection of the first geometry is possible anywhere except on the yellow cube.

4.  Select the top face of Cube.Yellow as the second geometry to snap. 

You will notice that selection of the second geometry is possible only on the yellow cube. 

The highlighted components can now be moved as a rigid block.
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Performing a Symmetry 

This task teaches you how to obtain new parts, products or instances by means of symmetry operations. The Symmetry command also lets you obtain 
new instances by translation as explained at the end of the scenario.

●     The cache can remember the geometry options selected. So next time you launch the symmetry command, the Symmetry options are selected by default. 

●     In Tools > Options > Infrastructure > Part Infrastructure > General, if the option Restrict external selection with link to published elements 
is selected and locked by administrator, symmetry is created only for published elements. The symmetry creation is not affected by the publish status of 
the elements, if this option is selected and unlocked.    

The following part features can be involved in the Assembly Symmetry feature:
●     The Part Body (or Main Body)

●     The External View

●     All Axis Systems

●     All Bodies other than the Part Body.

●     All Geometrical Sets, ordered or not

●     Any combinations of the previous elements using the Customize option.  
In symmetry part, the Body, PartBody, GS or OGS would contain only result of the geometries corresponding to the tool in original part, with or without 
link (depending upon your preference). The number of features in the result will be the same as we get it using paste special as result.

 In this section, the following information is available:
●     Components Chosen for Duplication

●     More About the Mirror, new component Option

●     Translation

●     Keep Link Options

●     New Components or New Instances?

●     The Keep link in position and Keep link with geometry options are grayed out in the Assembly Wizard dialog box, while a Part Design license (PD1 
or GSD) is not granted.

●     Assembly features do not appear in the specification tree, while the Assembly Design license (ASD) is not granted.

Open the Assembly_03.CATProduct document.

1.  Click the Symmetry icon: 

The Assembly Symmetry Wizard dialog box displays, prompting you to select the reference plane.

2.  Select the element used as the reference of the symmetry: Plane.1.

This element can be a plane or any planar face that the system recognizes as a plane.

Components chosen for duplication

The component you select for duplication must be the child of the active product.

Example 1: the element to duplicate is not a symmetrical element

In this case, the symmetrical element is a new component.

3.  Select NewDoor (NewDoor.1) as the product to be duplicated.

NewDoor (NewDoor.1) is highlighted and the symmetry is previewed.
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�❍     The Assembly Symmetry Wizard dialog box appears: 
It displays the list of all elements that are duplicated, that is all components composing NewDoor product: Door.1 and Pane.1.

�❍     The three icons to the left of the window represent symmetries as well as the creation of new components.

The Rotation, same instance option moves the selected geometry symmetrically in relation to a plane. 
It does not create any new geometry. 
In short, the Bill of Material is not affected by the resulting geometry. 
For an example, please refer to Rotating a Component by Using the Symmetry Command.

�❍     If you want to preview the symmetry of the door only, select Symmetry of Door (Door.1). 
Likewise, if you prefer to preview the symmetry of the pane, simply select Symmetry of Pane (Pane.1).

�❍     Instead of new components, you can also create new instances for Symmetry of Door (Door.1) or Symmetry of Pane (Pane.1). 
To do so, select them and check the option Rotation (new instance). For more about this option, refer to Example 2.

4.  Click Finish to confirm the operation.

The Assembly Symmetry Result dialog box appears. Three new components have been created.

5.  Click Close.

You obtain a second door.

3D Insight Version 5 Release 19 Page 378 of 1379



�❍     The new component Symmetry of NewDoor (Symmetry of Door.1) is displayed as well as the parts it contains (Symmetry of 
Door and Symmetry of Pane).

�❍     A new entity Assembly features also appears in the specification tree. 
It contains the symmetry referred to as Assembly Symmetry.1 which in turn contains the symmetry plane and the affected 
component.

Editing of the assembly symmetry components is not available with the P1 license.

More About the Mirror, new component Option

Once you have created a symmetrical component using the Mirror, New component option, you cannot apply the Symmetry command with the Mirror, 
New component option to any instance of the initial component (even if the reference plane is distinct).

Example 2: the element to duplicate is a symmetrical element itself

In this case, the symmetrical element is the new instance.

6.  Click the Symmetry icon: 

7.  Select the element used as the reference of the symmetry: Plane.1.

8.  Select Wheel (Wheel.2).

The wheel is highlighted and the symmetry is previewed.

The Assembly Symmetry Wizard dialog box appears. It displays the list of all elements that are duplicated: all components composing Wheel 
Assembly product.

9.  Select Symmetry of Rim from the list. Only the symmetry of that component is now previewed in the geometry area.
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10.  Check the Rotation, new instance option.

A new icon reflects this change in the list.

11.  The object is positioned with respect to Plane.1. 

Now, as it is intrinsically symmetrical, you need to define which of its three reference planes must be symmetrical with respect to Plane.1. 

For example, check XY plane option.
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It is moved accordingly.

12.  Check YZ plane option.

It is re-positioned.

13.  Click Finish to confirm the operation.

The Assembly Symmetry Result dialog box appears. Two new components and one instance have been created.

14.  Click Close.
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�❍     The new component Symmetry of Wheel (Symmetry of Wheel.2.1) is displayed in the specification tree. 
It contains one new instance (Rim (symmetry of Rim.1.1) and one new component (Symmetry of Tire (Symmetry of Tire.1.1).

�❍     The Assembly features entity contains the new symmetry referred to as Assembly Symmetry.2 which in turn contains the symmetry plane and the 
affected component.

Translation

15.  Click the Symmetry icon: 

16.  Select the element used as the reference of the symmetry: Plane.1.

17.  Select Wheel (Wheel.1).

The wheel is highlighted and the symmetry is previewed.

18.  Check the Translation, new instance option.

A new icon reflects this change.

To calculate the translation, the application projects the center of the axis system onto the plane you selected. 
The distance between the center and the plane is repeated twice.
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19.  Click Finish to confirm the operation.

The Assembly Symmetry Result dialog box appears. One instance has been created.

�❍     The new instance Wheel (Symmetry of Wheel.1.1) is displayed in the specification tree.

�❍     The Assembly features entity contains the new symmetry referred to as Assembly Symmetry.3 which in turn contains the symmetry plane and the 
affected component.

20.  Click Close. The wheel is translated:

Keep Link Options
●     The Keep link in position option guarantees associativity with the initial part or product: if you edit their positions, symmetrical elements inherit 

these modifications and are therefore repositioned accordingly.

●     The Keep link with geometry option guarantees associativity with the geometry of the initial part: if you edit its shape, symmetrical elements inherit 
these modifications. However this type of associativity is restricted to elements made visible via the External View... command or to Part Bodies. For 
more information, refer to Generative Shape Design User's Guide and Part Design User's Guide respectively. 
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You can also use the Remove All Geometry Links contextual command on the symmetry object in the specification tree: right-click the symmetry_name 
object then select Remove All Geometry Links. The result is the same as if you unselect the Keep link with geometry option.

New Components or New Instances?

If you compare the symmetry obtained by using the Mirror, new component option to the symmetry obtained first using the Mirror, new component 
option, then the Rotation, new instance option, then reselect Mirror, new component, both results are different as indicated by the icons: 

 

 
The behavior is the following: after changing the symmetry type, that is Rotation, new instance, to reuse the Mirror, new component option, the children 
of the product to be mirrored remain as new instances whereas the product is assigned the new component definition.

What you need to do

To make sure that you obtain the same results for both operations, you need to use the Mirror, new component, all children contextual command available 
in the dialog box instead of checking Mirror, new component. 
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Result: 

 
For more information about the Symmetry command, refer to Modifying a Symmetry.

A link generated using Copy/Paste As Result With Link operation is not created in symmetric part in case of symmetry 
of CATShape. Instead, a rotated copied instance of the source CATShape is created.

●     CATIA does not automatically loads the required data from product which has symmetry, even if the 
option Compute exact update status at open is set to Automatic in Tools > Options > Mechanical Design > 

Assembly Design > General tab.

●     If the option Keep link in position is selected for creation of symmetric part, then it is not advised to move it in 3d space using Fix in space.

 

Assembly Symmetry Behavior for Broken Link 

The Mirror, new component option is available only when all the parts are loaded in the design mode. If there is any broken link (part is 
not loaded), a warning message is displayed, stating which part needs to be loaded. The Rotation and Translation options are available in case of broken link.
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Rotating a Component by Using the Symmetry Command

This task shows you how to rotate a component by using the Rotation, same instance option.

Open the Assembly_05.CATProduct document:

●     Be sure that the update mode is Automatic, see Assembly Design, General settings.

1.  Click the Symmetry icon  to move LeftDoor.

The Assembly Symmetry Wizard dialog box displays, prompting you to select the mirror plane.

2.  Select Plane.1 as the reference of the symmetry.

This plane is used to position the assembly.

Note that the local axes of the two products are superimposed, in our example, to make sure that the final products are in 
front of each other.

3.  Select LeftDoor (LeftDoor.1) as the component to be moved.

LeftDoor (LeftDoor.1) is highlighted and the symmetry is previewed.
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4.  Check the option Rotation, same instance and XZ plane.

This plane is specific to LeftDoor and is used to define the axis for the rotation. 
The axis is the intersection between this plane and the first plane you selected (see step 1).

When using the Rotation, same instance option, the associativity options Keep link in position and Keep link with 
geometry are not available. For more information, see Performing a Symmetry.

5.  Click Finish to confirm the operation.
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The Assembly Symmetry Result window appears, indicating that no component, nor any instance have been created.

6.  Click Close.

LeftDoor (LeftDoor.1) has been moved in relation to the selected plane. 
No geometry has been created so that the bill of material remains unchanged.
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Navigating

 

Navigating in Examine mode: See Activating Viewing Tools Using the Mouse in the Infrastructure User's Guide.

Navigating in Walk mode: Select View  >  Navigation Mode  >  Walk, press and hold down middle mouse button to define horizontal 
plane, drag to left or right to determine direction then click left mouse button to begin. Drag to left or right to change direction then 
bring cursor back towards center of view to continue walk forward in the new direction.

Navigating in Fly mode: Click the Fly Mode icon, press and hold down middle mouse button to define initial horizontal plane, drag to left 
or right to determine direction then click left mouse button to begin. Drag to left or right, up or down, to change direction then bring 
cursor back towards center of view to continue fly forward in the new direction.

Selecting standard views using the Viewpoint Palette: Select View  >  Viewpoint Palette..., click the target icon in the Viewpoint Palette 
dialog box, then select the desired view.

Panning, zooming, rotating and turning head using the Viewpoint Palette: Select View  >  Viewpoint Palette..., and experiment with pan 
and zoom (Translate box default position),  rotation (Rotate box default position) and turn head commands.

Changing Views: Click  to display the previous view or  to display the next view.

Viewing Objects against the Ground: Click the Horizontal Ground icon to display the ground plane. If necessary, drag ground up or 
down to position it.

Magnifying: Click the Magnifier icon and adjust magnifier viewport in your document window to display magnified section in the 
Magnifier window.

Looking at Objects: Click the Look At icon, click an object to select it and drag slowly to display and adjust viewport then release the 
button.

Setting Lighting Effects: Click the Lighting icon and vary ambient lighting effects using light source options and the brightness slider in 
the Light Source dialog box. Drag the handles to set the lighting direction.

Setting Depth Effects: Click the Depth Effects icon, then desired checkboxes in the Depth Effect dialog box to set depth effects, for 
example, the Foggy option to create fog effects.
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Navigating in Examine Mode

 

Examine Mode is the default navigation mode. You can examine your document as you would from the outside by 
moving around the document's perimeter, or as you would from within, modifying your orientation (turn head) or 
moving closer to different objects (zoom in, zoom out).

Note: When in Beginner's fly mode, click the Examine mode icon  in the View toolbar to return to the default 
navigation mode.

For more information, see Activating Viewing Tools Using the Mouse in the Infrastructure User's Guide.
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Navigating in Walk Mode

In Walk mode, you can walk forward and backward (backward in advanced mode only) as well as turn right or left as you walk along the horizontal plane.

Two walk modes are available: 
●     Beginner's mode

●     Advanced mode for experienced users.

Before using the Walk navigation mode, you must be in a perspective view (View > Render Style > Perspective). If you attempt to activate Walk mode, 
you will be prompted to switch to a perspective view. 

 

Beginners Walk Mode
This task shows you how to navigate through a document in beginner's walk mode.

Beginner's walk mode commands are single-action commands. Releasing the mouse button means you exit the command. You can only move forward 
in beginner's walk mode.

Insert the platform.model document from the samples folder.

1.  Select  View > Navigation Mode > Walk.

The icons used in the beginner's walk mode appear in the View toolbar. (These commands are also available via View > Modify in the menu bar.) 

 

2.  Click the Turn Head icon  in the View toolbar then drag (left mouse button) to define your starting position (the direction in which you look at the object).

3.  Release at desired location.

4.  Click the Walk icon , then click the left mouse button to begin to walk. 

You begin to walk straight forward in the chosen direction. A green arrow appears along with a circular target located at the center of the view. The 

number  below the arrow specifies the speed at which you are walking.

The speed at which you first approach the object depends on the initial distance from the object, and is calculated automatically. The speed is optimized so 
that you reach the point you target in approximately 10 seconds.

5.  Still holding the left button down, drag to the right or left to change direction.

You walk in the direction in which you drag. The further you drag away from the center of the view (represented by the circular symbol  ), the 

greater the change in direction.

Dragging to the left lets you view the object as if you had turned your head to the left; dragging to the right lets you view the object as if you had turned 
your head to the right. 

As you drag, the shape of the arrow changes to reflect the direction in which you are walking. 

6.  Drag the cursor back towards the center of the view to continue walking forward in the new direction.

7.  To modify your speed, click the Accelerate  or Decelerate   icon one or more times.

8.  To continue your walk, click the Walk icon  again and then click in the view. 

Notice the different speed at which you now walk.

9.  To return to the default navigation mode, click the Examine mode icon  in the View toolbar.

You can also set mouse sensitivity and collision detection using the appropriate options in the Visualization tab, accessed via the Tools > Options command. 
For more information, see the Infrastructure User's Guide. 

Advanced Walk Mode
This task shows you how to navigate through a document in Walk mode. 
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Insert the platform.model document from the samples folder. Before using the Walk navigation mode, you must be in a perspective view (View  >  
Render Style  >  Perspective). 

Note: It is easier to walk through documents in contexts where you would find a virtual ground, i.e. in buildings, planes or ships for example. 

1.  Select View  > Navigation Mode  > Walk.

2.  Press and hold down the Middle Mouse button to define the horizontal view plane.

3.  Still holding the button down, drag to the left or to the right to determine the direction in which you wish to walk.

4.  In the Walk mode, press and hold down the Middle Mouse button until you've finished navigating.

5.  When in the direction in which you wish to walk, click the left mouse button to begin walking. 

You begin to walk forward in the chosen direction.

A green arrow indicating the direction in which you are walking appears along with a circular target located at the center of the view, as in Beginner's walk mode. 

 

6.  Still holding the middle button down, drag left or right to change direction. 

Dragging to the left lets you view the object as if you had turned your head to the left; dragging to the right produces the same effect in the opposite direction.

7.  Drag the cursor back towards the center of the view to continue your walk forward in the new direction.
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Pressing the PageUp and PageDown keys modifies your speed. Speed is indicated in the status bar. 

 

8.  Click the Left Mouse button again to reverse direction.

You begin to walk backward, away from the target.

Note: The left and right are now defined as if you were walking away from the target with the your back towards it. 

You can also set mouse sensitivity and collision detection using the appropriate options in the Visualization tab, accessed via the Tools > Options command. 
For more information, see the Infrastructure User's Guide.

When a collision is detected, the green arrow turns red, whether you navigate in beginner's or advanced Walk mode:
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Navigating in Fly Mode 

In Fly mode you can move upward or downward on any horizontal view plane as you move forward or backward (backward in advanced 
mode only). 

Two fly modes are available:

●     Beginner's mode

●     Advanced mode for experienced users.

Before using the Fly navigation mode, you must be in a perspective view (View > Render Style > Perspective). If you attempt to 
activate Fly mode, you will be prompted to switch to a perspective view.

Beginner's Fly Mode

This task shows you how to navigate through a document in beginner's fly mode. 

Note: Beginner's fly mode commands are single-action commands. Releasing the mouse button means you exit the command. You can 
only move forward in beginner's fly mode.
Insert the platform.model document from the samples folder.

1.  Click the Fly Mode icon  in the View toolbar or select View > Navigation Mode > Fly. 

The icons used in the beginner's fly mode appear in the View toolbar.

These commands are also available via View  >  Modify in the menu bar.

2.  Click the Turn Head icon  in the View toolbar then drag (left mouse button) to define your starting position (the direction 

in which you look at the object).

3.  Release at desired location. 

4.  Click the Fly icon , then click the left mouse button to begin to flying. 

You begin to fly forward in the chosen direction.
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A green arrow appears along with a circular target located at the center of the view. 
The figure below the arrow specifies the speed at which you are flying. 

 

The speed at which you first approach the object depends on the initial distance from the object, and is calculated 
automatically. The speed is optimized so that you reach the point you target in approximately 10 seconds. 

5.  Still holding the left button down, drag to the right or left, or up or down, to change direction.

You fly in the direction in which you drag. The further you drag away from the center of the view (represented by the 

circular symbol ), the greater the change in direction. 

As you drag, the shape of the arrow changes to reflect the direction in which you are flying.

6.  Drag the cursor back towards the center of the view to continue flying forward in the new direction. 

7.  To modify your speed, click the Accelerate  or Decelerate  icon one or more times, then click the Fly icon again 

followed by the left mouse button to pursue your fly. 

Each click on the icon increases or decreases the speed by approximately 40%. 

When you collide with a solid object while flying, you will slide along the object's surface and not fly through the object, providing a 
realistic effect. This feature is also available in Advanced Fly mode. 

Pressing the Shift key and dragging lets you bank left or right. 

You can use the option "Gravitational effects when navigating" in the Visualization tab, accessed via the Tools > Options command, to 
fix the X, Y or Z axis during navigation. While turning in Fly mode, this creates the impression that the user viewpoint tilts or banks with 
respect to the fixed axis, as in a real plane.

You can also set mouse sensitivity and collision detection using the appropriate options in the Visualization tab, accessed via the 
Tools > Options command. For more information, see the Infrastructure User's Guide.
  

8.  To return to the default navigation mode, click the Examine mode icon  in the View toolbar.

Advanced Fly Mode
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This task shows you how to navigate through a document in advanced fly mode.

Insert the platform.model document from the samples folder.

In advanced fly mode, you can move upward or downward on any horizontal view plane as you move forward or backward.

1.  Click the Fly Mode  icon in the View toolbar or select View > Navigation Mode > Fly

2.  Press and hold down the middle mouse button to define the initial horizontal view plane.

3.  Still holding the button down, drag to the left or to the right to determine the direction in which you wish to fly.

4.  In the Fly mode, press and hold down the middle mouse button until you've finished navigating.

5.  When in the direction in which you wish to fly, click the left mouse button to begin flying:

You begin to fly forward in the chosen direction. 
A green arrow appears along with a circular target located at the center of the view, like when using the beginner's fly 
mode. 

The speed at which you first approach the object depends on the initial distance from the object, and is calculated 
automatically. The speed is optimized so that you reach the point you target in approximately 10 seconds.

 

6.  Still holding the middle button down, drag left or right, or up or down, to change direction. 

You fly in the direction in which you drag. The further you drag away from the center of the view, the greater the change in 

direction.

7.  Drag the cursor towards the center of the view to continue flying forward in the new direction.
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Pressing the PageUp and PageDown keys modifies your speed. Speed is indicated in the status bar.

Each press of the key increases or decreases the speed by approximately 40%.

8.  Click the left mouse button again to reverse direction:

You begin to fly backwards, away from the target. When flying backwards, the up and down are reversed. 

You can use the option "Gravitational effects when navigating" in the Visualization tab, accessed via the Tools > Options command, to 
fix the X, Y or Z axis during navigation. While turning in Fly mode, this creates the impression that the user viewpoint tilts or banks with 
respect to the fixed axis, as in a real plane. 

You can also set mouse sensitivity and collision detection using the appropriate options in the Visualization tab, accessed via the 
Tools > Options command. For more information, see the Infrastructure User's Guide. 
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Selecting Standard Views  
using the Viewpoint Palette

This task shows you how to obtain standard views of your document using the Viewpoint Palette. 
 

The Viewpoint Palette provides an easy and precise way to define your document views. 
It gives you access to a certain number of viewing tools that will let you fine-tune viewpoints. You can:
●     pan and rotate as well as turn your head to view or move closer to different objects in your document by 

predetermined increments (zoom in, zoom out) 

●     fine-tune a standard view 

●     retrieve stored viewpoints and combine them to produce an animation. 
 

For a diagram describing the meaning of the Eye, Target, Viewing Distance and Viewing Angle, see 3D Representation 
in the glossary. 
 
Insert the platform.model document from the samples folder.

1.  Select View  >  Viewpoint Palette... 

The Viewpoint Palette dialog box appears. 
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2.  In the Translate box, click  to activate the change view commands. 

The Translate box now offers a number of standard views (top, back, left, right, front and bottom) you can 

use to display the document: 

 
3.  Click the desired view.

For example, clicking the Top view icon obtains the top view: 

 
  

The other views are:  
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Bottom view

Left view Right view

Front view Back view
You can fine-tune your standard view using other viewing tools (pan, zoom, rotate and turn head) in the Viewpoint 
Palette.

You can also obtain standard views of your document using the View >  Named Views... command. 

 

 

 

3D Insight Version 5 Release 19 Page 400 of 1379



Panning, Zooming, Rotating and Turning Head using 
the Viewpoint Palette

 This task shows you how to pan, zoom, rotate and look at objects as if you are turning your head using the 
Viewpoint Palette.

The Viewpoint Palette provides an easy and precise way to define your document views. 
It gives you access to a certain number of viewing tools that will let you fine-tune viewpoints. You can:
●     pan and rotate as well as turn your head to view or move closer to different objects in your document by 

predetermined increments (zoom in, zoom out) 

●     fine-tune a standard view 

●     retrieve stored viewpoints and combine them to produce an animation. 
 

For a diagram describing the meaning of the Eye, Target, Viewing Distance and Viewing Angle, see 3D 
Representation in the glossary. 
 
Insert the platform.model document from the samples folder.

 
1.  Select View   >  Viewpoint Palette... 

The Viewpoint Palette dialog box appears. 
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The Translate box contains panning and zooming commands (default position).

Using these commands, you can move the current document contents by panning the viewpoint as well as zoom in/
out by predetermined increments.

 

  

 

 

2.  Enter a new step in the spin box and press Enter, or scroll to a new value with the up and down arrows.

3.  Try experimenting with the pan and zoom commands until you are satisfied with the viewpoint.

The Rotate box contains commands that enable you to rotate an object (default position) and turn 
your head to view the document.
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4.  Enter a new rotation step in the spin box and press Enter, or scroll to a new value with the up and down 

arrows.

5.  Try experimenting with rotation commands until you are satisfied with the viewpoint.

6.  Click the central icon to switch to turn head commands and simulate what happens when you turn your 

head to look at the document.

 

7.  Enter a new step in the spin box and press Enter, or scroll to a new value with the up and down arrows.

8.  Try experimenting with turn head commands until you are satisfied with the viewpoint.

Note: You can set the viewing distance and angle as well as the eye and target locations directly using spin boxes

You can obtain standard views of your document using the View >  Named Views... command.
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Changing Views

Individual views are created as you navigate through your design in examine, walk and fly modes. Views are stored and can be 
reviewed using previous and next icons in the DMU Viewing toolbar. 
In walk and fly modes, views are created each time you pause during your walkabout or fly around. 
Insert the platform.model document from the samples folder. 

This task shows you how to change views. 

1.  Navigate in Examine mode (zoom, pan, etc.) to create and save several different views.

2.  Click the Previous  icon in the DMU Viewing toolbar or select View  >  Modify  >  Previous View. 

The previous view is displayed in the geometry area.

3.  Click the Previous icon again. 

 

 
 

 

4.  Click the Next  icon, or select View  >  Modify  >  Next View. 

The next saved view is displayed in the geometry area.
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Viewing Objects against the Ground

 

Ground lets you visually insert a plane at the ground level of your document, thus enabling you to recognize when your 
document is viewed the right way up. 
By default, when you first access a document, the plane parallel or tangent to the bottom point of your document is 
considered to be the ground. You can, however, change the plane used to identify the ground. For more information, see 
the DMU Infrastructure User's Guide, Navigation. 

This task shows you how to show and hide the ground. 

Insert the platform.model document from the samples folder.

 

1.  Select View > Ground, or click the Horizontal Ground  icon in the DMU Viewing toolbar. 

The ground plane is displayed in the geometry area. 

To hide the ground, simply repeat the same step.

2.  Drag (left mouse button) the ground up or down to a new location, then release the mouse button. 

The ground is repositioned as defined.
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Magnifying

This tasks explains how to obtain a magnified view of your document in a separate window.

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

1.  Select the View > Magnifier... command or click the Magnifier icon  in the DMU Viewing toolbar. 

The Magnifier window opens containing a magnified section of your document.

 

 

 
 The section magnified is defined by the magnifier viewport which appears over the object in your document: 

  

Note that the magnifier viewport has handles: 

●     the "+" symbol lets you move the viewport

●     the arrows in the corners let you resize the viewport.
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2.  Point to the + symbol and drag it to move the viewport and magnify another area of the document: 

 

 

3.  Point to one of the arrows and drag it to size the magnified area up and down.  

While you drag, the symbol appears.

 All the viewing and manipulations performed in the document window are also reflected in the Magnifier window. For example, rotate the object to see how 
the object is also rotated in the Magnifier window. 
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Looking At Objects

During the course of your inspection, you may want to concentrate on a particular object and view it closer up. 
This task explains how to dynamically change the orientation (eye position, target and viewing distance) from which you look at your 
document. 
Insert the platform.model document from the samples folder. 

 
1.  Select the View > Modify > Look At command, or, in the DMU Viewing toolbar, click the Look At icon .

2.  Click on an object in the document to select it.

3.  Drag (still holding the left mouse button down) slowly to display the viewport. 

As you begin to drag, a rectangle with two diagonals appears and continues to grow as long as you continue to drag in the 

same direction. This rectangle represents the viewing window of the future view.

4.  Change the direction in which you drag . 

The viewport rectangle then becomes a pyramid-like shape that represents the view (your eyepoint is located at the vertex of 

the pyramid). Continue to drag, changing direction as you desire, to reposition the eyepoint and the viewport. 

5.  Still holding the left mouse button down, press the middle mouse button and drag to resize the viewport.  
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6.  Release the button. 

You now see what is targeted inside the viewport. 

You can press and hold down the Shift key and then press the middle mouse button to invoke the same functionality. 
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Setting Lighting Effects

This tasks explains how to vary ambient lighting effects.

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

 
1.  Select the View > Lighting... command or the Lighting icon in the DMU Viewing toolbar to display the 

Light Sources dialog box.

The default light source setting looks as follows:
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... and produces a lighting effect like this:
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Note that the One Light Source icon  is activated by default. The sphere indicates the current lighting 

direction. The handle on the sphere indicates the direction from which the light is being projected: by default, the 
light is coming from the top left. 
You can drag the handle around (using the left mouse button) to change the lighting direction. The new lighting 
effect is created instantaneously as you drag the handle. 
The first slider at the bottom of the dialog box lets you adjust light source brightness.

2.  Drag the handle down and towards the bottom right.  

The light is now coming from the bottom right.
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3.  Click the Two Light Source icon  to add another light source.
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In our example, using two light sources means that the lighting is now too bright.

4.  Drag the brightness slider (the first slider in the list) to the left to reduce the brightness.
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5.  Now drag the lower handle up towards the top left to change the direction of the corresponding light 

source.
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6.  Click the Neon Light icon  to produce a neon light effect.
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7.  Click the No Light Source icon  to switch off all light sources.
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The bottom two sliders control contrast and specular intensity of light sources respectively. 
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Setting Depth Effects

This tasks explains how to achieve 3D depth effects, namely, clipping geometry between clipping planes and creating fog 
effects.

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

 
1.  Select the View > Depth Effect... command or the Depth Effects icon in the DMU Viewing toolbar to display the 

Depth Effect dialog box.

The orange sphere completely encompasses the objects in your document. The white cross 
represents the center of the objects in the geometry area. 

The color of the area behind the orange sphere is the background color of your document.

The vertical lines represent the front (near) and back (far) clipping planes.
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By default, depth effects are deactivated: if you zoom in and out, you will see that for the moment the geometry is not clipped. 
 

 

You can keep the Depth Effect dialog box open and continue working with other commands. You will be able to understand the 
results obtained by setting depth effects by zooming in and out. 
 

2.  Set the Near Limit and Far Limit by checking the Fixed checkbox for each option, entering values and pressing Enter in 

each case. 

Note that location of the vertical lines representing the clipping planes has changed. 

 

 

3.  Zoom in progressively to see how the geometry is clipped by the near clipping plane. 

The back (far) section of the geometry is clipped. You now only see what is located between the near and far clipping 

planes.
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4.  Zoom out to see all the geometry.

5.  Click the Foggy option. 

The foggy option introduces a foggy effect.
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6.  Zoom out again. 

As you zoom out, the fog effect is increased. The fog gets thicker as you continue to zoom out beyond the back 

clipping plane.
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Annotating

 

Adding 3D Annotations: Click the 3D Annotation icon, click where you want to place the text, enter the text in 
the Annotation Text dialog box then click OK. 

Managing 3D Annotations: Move the 3D text with the manipulators (in Edit mode), add links to point other 
components with your 3D text using the contextual menu. Update your 3D text if the product moves 
(automatically: default option or manually)

Creating Annotated Views: Annotate the active view using commands in the DMU 2D Marker toolbar.

 Adding Pictures: Click the Create an Annotated View icon in the DMU Review Creation toolbar. Use the Insert a 
Picture marker icon from the 2D Marker toolbar. Select a file and click Ok.

 Adding  Audio Markers: Click the Create an Annotated View from the DMU Review Creation toolbar. Use the 
Create an Audio marker icon from the 2D Marker toolbar. Give a name to the to be recorded file. Record and 
click Ok 

Managing Annotated Views:  You can recover 2D views using the Managing Annotated Views  icon. Double-click 
the required view in the Annotated Views dialog box. 

Editing Annotated Views Properties: Right click the view you need to edit in the specification tree. Add 
comments, change the view name... in the Properties dialog box displayed. 

Using Temporary Markers: Select Analyze  > Graphic Messages  > Name or Coordinate and move the cursor 
over objects in your document. 

Displaying and Editing Links: Select Edit > Links... and display the information about one pointed document. 
Edit the path if necessary and click Ok.

 

Creating Hyperlinks: Select an object then click the Add Hyperlinks icon. Identify your hyperlink and select the 
destination file in the dialog box then click OK.

Jumping to Hyperlinks: Double-click the hyperlink in the specification tree. 
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Adding 3D Annotations

You can annotate your 3D document. Annotations are attached to the point selected to place the text. This task explains how to add 3D text. 
 

3D Annotations now move to no-show space when the associated part is moved to no-show space.

Case with one part:

●     When a part with linked 3D Annotation is hidden, the annotation is also hidden. 

●     When the part is shown, the linked 3D Annotation is also shown.

Case with several parts: 

●     If one of the parts is hidden, the line joining the part and the 3D Annotation will also be hidden. 

●     If all the parts linked to the annotation are hidden, the 3D Annotation is also hidden.

●     As soon as one of the linked parts is shown, the 3D Annotation is also shown.

 
Insert the platform.model document from the samples folder. 

 

1.  Select Insert  >  3D Annotation from the menu bar or, in the DMU Review Creation toolbar, click the 3D Annotation icon . 

 

2.  Click an object at the point you want to place the text. (Note: You can select the object first. ) 

The Annotation Text dialog box and the Text Properties toolbar appear.  

Inserting symbols (Windows only)

You can insert symbols in annotated views.

●     Choose the SymbC font. The symbol at the right of the Text Properties toolbar will now be selectable.

●     Click the arrow in Insert Symbol icon to select a symbol from those  proposed: 

Using symbols forces the font to change to SymbC and can create problems if text will be associated to the added symbol; the only font that can be used 
with symbol is SymbC.
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3.  Enter the desired text in the 3D Text field. 

Note: you can now change the font size and type if desired using the Text Properties toolbar.

4.  Use the green manipulator to position your 3D text.

5.  Click OK when satisfied. 

The text is added at the desired position. Annotations are attached to the point selected. You can move your document: annotations remain attached to the 

point at which you place them.

For more detailed information about moving annotations, please refer to Managing 3D annotations.

Note: Text annotations are identified in the specification tree.
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A text's drawing properties include its color. You can change the color of text that you've already added.  

You can add a frame, define properties for this frame ( line type and thickness), fill it with the desired color and even change the orientation of the 3D text.

6.  Right-click a text you've already added and select Properties from the contextual menu, or click the text and select Edit  >  Properties from the menu bar. 

The Properties dialog box appears.                                                                                                                                      Note: Dynamic highlighting 

as you move your cursor over objects helps you to locate them.

7.  Click the Text Properties tab.

8.  Make desired changes (e.g. add a Frame).

9.  Click OK when done.

�❍     If the background color is modified, the white color for annotations will not be automatically modified to accommodate the modified background. You 
must modify the annotation color manually.

�❍     Line thickness can only be modified for font type STROKE. For all other font types, modifying the line thickness will have no effect.

�❍     To modify text, double-click it.

To delete annotation text, right-click the object and then select Delete from the contextual menu.

�❍     Size of 2D annotation text and 3D annotation text can be different for same font size.
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Managing 3D Annotations

This task explains how to move a 3D text.

Open the Annotated_Gardena.CATProduct document.

 
1.  Double-click text.1  in the specification tree to edit the 3D annotation. 

The Annotation Text dialog box appears.

2.  Point the cursor over the 3D text. Green manipulators appear on the text, enabling you to move it.

3.  Drag the manipulators to the desired location.

      

3.  Click OK.

4.  Right-click the 3D text in the geometry area (Component to be modified for instance), select Text.2 definition > Add link.

5.  Select the component to be linked to the 3D text (for instance the valve).

6.  Deactivate the Update on product structure modification and scenes activation option in Tools > Options >  DMU Navigator. When 

done, click OK. 

The update will be done manually.
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7.  Move components using the 3D compass and mouse, e.g. NOZZLE1. Please refer to Manipulating Objects using the Mouse and Compass in the 

Infrastructure User's Guide. 

 

8.  Right-click the 3D text in the geometry and select Text.1 definition > Update. 

The 3D text is repositioned.

 

●     To modify text, double-click it. The size of the 3D text displayed on the screen is not zoom sensitive.

●     To delete annotation text, right-click the object and select Delete from the contextual menu.

The contextual menu enables you to do the following:
●     update on product move (contextual menu  >  Update item)  

Note: the default mode update is automatic (See Tools > Options >  DMU Navigator...)

●     possibility to add links to point to other components (contextual menu  >  Add link item)

●     possibility to remove links (contextual menu  >  Remove link item)
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Creating Annotated Views 

You can draw straight lines, freehand lines, circles, arrows and rectangles. You can create complex annotations by combining several 
objects as well as include text in document views. You can even insert pictures (tiff, jpg, bmp, rgb) and audio markers. 
This task explains how to annotate your documents. 

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

 
To annotate documents, you must be in an active view. Objects drawn are associated with the active view and , by default, will no longer 
be visible if the view is changed via rotate (translate and zoom are not considered changes to the view and therefore they do not impact 
the visibility of annotations).

However, there is a new option that allows you to "Unlink" the annotations of an annotated view, thereby enabling you to rotate the view 
without losing the associated annotations: 
●     Select the view in the Specification Tree

●     Right-click and select  Link / Unlink in the contextual menu. 
 

You can also add 2D annotations in active views in the Section viewer for example. Annotations are no longer visible if you change viewer. 

 

1.  Click the Create an Annotated View  icon in the DMU Review Creation toolbar.

The 2D view is created and identified in the specification tree.  
The DMU 2D Marker toolbar is activated.  
You can now annotate your view. 
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2.  Click the appropriate icon in the DMU 2D Marker toolbar to draw straight lines, freehand lines, circles, arrows or rectangles.

3.  Put the cursor where you want to start the object, then click and drag to draw the object:

●     To draw a straight line, click at the start of the line and drag from the beginning to the end of the 
line.

●     To draw a circle or a rectangle, click at the start of the object and drag diagonally across the area 
in which you want the object to appear.

●     To draw an arrow, click at the start of the arrow and drag from the beginning to the end of the 
arrow.

●     To draw a freehand line, click at the start of the line and drag the cursor along the path of the line.

You can move and resize 2D markers easily. All you need to do is drag the green manipulators attached to the marker 
selected. 

Note: It is possible to stack marker types:

●     If you activate a marker type (e.g. line, ellipse, rectangle) and then activate another marker type without having first 
drawn a marker of the first type, then the second marker type will become active and the first marker type will be grayed 
out (the second type is stacked on top of the first type)

●     After you create the marker of the second type, the first marker type will again become active and you can then create the 
corresponding marker (the second type has been removed from the stack and the first type is on top) 

Note: Annotated views created in the clash viewer cannot be moved or edited.

4.  In the Specification Tree, right-click View.1 and select View.1 object  >  Link / Unlink in the contextual menu. 

The annotations you just created will no longer be linked to the view. 
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5.  Rotate the view.

The annotations you created will still be visible.

6.  To link the annotations once again to the view, repeat step 4.

 

7.  Click the Text  icon to annotate your view with text.

8.  In the view, click where you want to place the text. 

The Annotation Text dialog box and the Text Properties toolbar appear:
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 You can configure your DMU Navigator so that, when creating 2D text annotations, the Part name will automatically be the default 

annotation.
●     In the menu bar, select Tools  >  Options and then select the DMU Navigator tab.

●     Click the 2D Marker Part Name Recognition radio button to activate the option.

●     In your DMU Navigator session, click the Text  icon to add a text annotation and click on a Part on which you wish to place the 

annotation (e.g. NOZZLE_1_2(NOZZLE_1_2.1).

 

That Part's name will automatically be the default annotation.

Inserting Symbols in Annotated Views (on Windows only)

You can insert symbols in annotated views.

●     Choose the SymbC font. The symbol at the right of the Text Properties toolbar will now be selectable.

●     Click the arrow and select a symbol from those  proposed: 
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Using symbols forces you to change the font to SymbC and can create problems if text will be associated to the added symbol; the only 

font that can be used with symbol is SymbC.

9.  Enter the desired text in the 2D text box and click Apply.

10.  Change the size and style of annotation text if desired and click Apply. 

11.  When done click OK. 

The text is added at the desired position.  

 

12.  To edit existing text, simply double-click. 

 

13.  To change the Text properties, right-click the 2D text in the geometry and select Properties from the contextual menu displayed. 

You can add more than one line of annotation text. 

Double-clicking the Text icon in step 7 above will cause the first annotation text that you define to be conserved by default at each 
successive point at which you click. You exit from the loop by clicking the Text icon with a simple-click.

 

3D Insight Version 5 Release 19 Page 437 of 1379



 
13.  Make the desired changes, e.g. add a frame or change the text orientation.

 

Line thickness can only be modified for font type STROKE. For all other font types, modifying the line thickness will have no effect.

 

 Rotating 2D Text Annotations

Define the Angle parameter to be the number of degrees you wish to rotate the text annotation by entering the value in the Angle text-
entry field or by clicking the value selection buttons.

 
14.  When satisfied, click OK.

 Modifying Annotation Properties
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15.  Select the Select  icon to enter the selection mode.

16.  Right-click another object you've already drawn and select Properties from the contextual menu, or click the object then select 

Edit  >  Properties from the menu bar. 

The Properties dialog box appears.

Note: Dynamic highlighting as you move your cursor over objects helps you locate 
them.

  

17.  Click the Graphic tab to display the graphic properties of the current object.

18.  Make desired changes (You can change the color, line type and line weight of the selected object.)

19.  Click OK when done.

 Defining the  2D default markers properties in the Tools > Options > DMU Navigator sets the selected properties as default properties 
and changes how new annotations will look when you create them. 
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Exporting and Importing 2D Annotations in an XML file

20.  To export 2D annotations, in the Specification Tree, right-click View.1 and select View.1 object  >  Annotated Views file 

export  in the contextual menu. 

The Annotated Views file export dialog box appears. 

 

21.  Browse to the folder in which you wish to save the xml file containing the annotations.

22.  In the File name text-entry field, enter the name of the file.
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23.  Click the Save button.

24.  To import 2D annotations, in the menu bar, select Insert  >  Annotated Views file  import. 

The Annotated Views file import dialog box appears. 

25.  Browse to the folder from which you wish to import an xml file containing  annotations.

26.  Select the desired file and click the Open button. 

The annotated view contained in the xml file will be added to the annotated views listed in the Specification Tree.

Copying an Annotated View

27.  To copy an annotated view, right-click the annotated view, select Copy in the contextual menu, right-click on the object in the 

specification tree under which you wish to copy the annotated view and select Paste in the contextual menu. 

Note: The copy of the annotated view will have the same name as the original annotated view.

Deleting Annotations 

28.  To delete all annotations in the current view, select the Delete All Annotations icon .

You can also delete individual markers by right-clicking the object and then selecting Delete from the contextual menu.
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Adding Pictures

This task explains how to add a Picture as 2D marker in your annotated view.

You can now insert resizable pictures from the following format list: 

●     tiff

●     jpg

●     bmp

●     rgb

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

To annotate documents, you must be in an active view. Objects drawn are associated with the active view and will 
no longer be visible if the view is changed.

You can also add 2D annotations in active views in the Section viewer for example. Annotations are no longer visible 
if you change viewer.

1.  Click the Create an Annotated View  from the DMU Review Creation Toolbar. 

The 2D view is created and identified in the specification tree.

The DMU 2D Marker toolbar is activated. You can now annotate your view.
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2.  Click the Insert a Picture Marker icon  in the DMU 2D Marker toolbar.

3.  Put the cursor on the valve and click. 

The Select Picture File dialog box appears:

4.  Select the valve.jpg document from the images folder.

The picture is inserted at the anchorage point selected in the annotated view. 

You can easily resize your inserted picture. All you need to do is drag the squared manipulators in the picture 
corners.
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An object's drawing properties include color, line type and weight. You can change drawing properties of objects 
that you've already drawn.
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Adding Audio Markers

This task explains how to insert audio markers in an annotated document using the 2D Marker toolbar

You need a microphone connected to your computer.

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

To annotate documents, you must be in an active view. Objects drawn are associated with the active view and will no longer be visible if the view is changed.

You can also add 2D annotations in active views in the Section viewer for example. Annotations are no longer visible if you change viewer.
 

1.  Click the Create an Annotated View  from the DMU Review Creation toolbar. 

The 2D view is created and identified in the specification tree.

 

The DMU 2D Marker toolbar is activated. You can now annotate your view.

 

2.  Click the Create an Audio marker icon  in the DMU 2D Marker toolbar. 

The Select audio file dialog is displayed.

3.  Select the location.

3D Insight Version 5 Release 19 Page 445 of 1379

file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/ATOMIZER.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/BODY_1_2.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/BODY_2_2.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/LOCK.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/NOZZLE_1_2.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/NOZZLE_2_2.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/REGULATION_COMMAND.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/REGULATOR.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/TRIGGER.cgr
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/DMUApplications/navigator/VALVE.cgr


4.  Give a meaningful name to the to-be recorded file and click Open. 

The Audio attributes dialog box and Audio Recorder dialog boxes appear: 

 

5.  Select the audio quality and click OK, e.g. select 22050Hz, 16-bit, Mono

6.  Start recording using the red button from the Audio Recorder dialog box.

7.  When done, click OK.  

The sound is identified in the specification tree.

8.  Double-click sound in the specification tree to play your audio recording (using the play button) or to edit it.
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Managing Annotated Views  

This task explains how to retrieve your 2D views using the  Manage Annotated Views icon. 
 

 It is possible to simultaneously view Annotated Views displayed in separate windows. When switching from one 
window A to another window B, the Annotated Views displayed in window A will remain on the screen and they will 
remain even if Annotated Views are activated in window B.

It will also be possible to display in the same window Annotated View 1 and Annotated View 2 (or more) if they 
share exactly the same viewpoint and if they are in the same context. 
Sharing the same context means that they are in the same DMU Review or that one Annotated view is in a DMU 
Review and that the other one is in the Annotated View container underneath the Applicative container.

Note: When multiple Annotated Views are simultaneously displayed in the same window, hitting the exit icon in the 
DMU 2D Marker toolbar exits the currently active view and those annotations associated to it will no longer be 
visible, whereas the annotations associated to the other Annotated Views sharing the same viewpoint will still be 
visible.   

Note: To manage annotated views under a Section, you must first activate the Section result window.
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Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

Create at least two views. These 2D views are identified in the specification tree. 

 
 

1.  Click the Manage Annotated Views icon . 

The Annotated Views dialog box appears.
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2.  In the Annotated Views dialog box, double-click View.1. 

View.1 is displayed and you can edit it.

3.  Double-click View.2. 

View.2 is displayed and you can edit it. 
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4.  To keep the selected view and exit the Annotated Views dialog box, click OK. 

The selected view is activated and you can edit it.

5.  To exit the Annotated Views dialog box without selecting a view, click Cancel . 
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Editing Annotated Views Properties

This task explains how to edit annotated views properties. This new capability eases collaborative work as you can now add information such as user 
name, creation or modification dates.

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

Create an Annotated View (see Creating Annotated Views). 
 

 
1.  Right click the view you need to edit in the specification tree.

2.  Select the  Properties item from the contextual menu displayed. The Properties dialog appears.
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3.  Enter the required information (creator name, comments, etc.).

4.  Click OK to confirm. 

The next views you create will be assigned the creator name you've just defined.
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Using Temporary Markers

You can visualize the names of objects as well as coordinates of points defined on objects in your document as you move 
your cursor over objects. Clicking turns the temporary marker into a 3D annotation. 
 
Using graphic messages you can apply a particular name, reference or description to a product (Definition, Nomenclature, 
Source, Instance Name, Description). 
 
For this: 
●     Select command Tools  >  Options  >  Infrastructure  >  Node Customization  

●     Check Customized Display

●     Then select different options : Part number (#PN#), Revision (#RE#), Definition, Nomenclature, Source, 
Instance Name, Description 

You can directly replace the diagram (PN, RE,...) between the two #  by the term of your choice and it will appear in the 
specification tree and in graphic messages.
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Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

 
1.  To activate the viewing of object names, in the menu bar, select Analyze  >  Graphic Messages  >  Name.

2.  Move your cursor over objects in your document. 

The name of the object is displayed.

3.  To de-activate the viewing of object names, re-select Analyze  >  Graphic Messages  >  Name.

4.  To activate the viewing of point coordinates, in the menu bar, select Analyze  >  Graphic Messages  >  

Coordinate.

5.  Move your cursor over objects in your document. 

The coordinates of the point under the cursor are displayed. Dynamic highlighting helps you identify points of 

interest.
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6.  To de-activate the viewing of point coordinates, re-select Analyze  >  Graphic Messages  >  Coordinate.

There is now a mechanism that enables you to transform temporary markers into persistent 3D annotations. You must do 
the following:

1.  Activate the mechanism in the DMU Navigator Settings (see DMU Navigator).

2.  Activate the viewing of object names and / or the viewing of point coordinates as above.

3.  Move the cursor over objects in the geometry area and when the temporary marker that you wish to display 

appears, then click.

4.  In the DMU Review Creation toolbar, click the 3D Annotation icon . 

The temporary marker will be transformed into a persistent 3D annotation at the  designated point.

Note that if the mechanism is activated in the DMU Navigator Settings but neither viewing of object names nor 
viewing of point coordinates are activated in your DMU session, then when you click on the 3D Annotation icon, 
the insertion of a 3D annotation will be proposed as would be the case if the mechanism had not been 
activated in the DMU Navigator Settings.
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Displaying and Editing Links  

Only direct links i.e. external links directly pointed to by the active document can be displayed using the Edit > Links... command. Other links, pointed to by 
an inactive document can be displayed by activating the inactive document.

This task shows how to display links on hyperlinks, audio markers and 2D pictures using the Edit > Links... 

Open an annotated document including hyperlinks, audio markers and 2D pictures.

 
1.  Select Edit  >  Links  from the menu bar.

The Links of document dialog box appears: 

Note: markers are displayed (pictures, audio markers, hyperlinks) in the Links of document dialog box. 

Under the Links tab, five (or six, depending on the type of element you opened) columns are displayed to provide link-related information:

●     "From element": the pointing element

●     "To element": the pointed element

●     "Pointed document": the document containing the pointed element 
 or  
"In Instance": the product instance in which the pointed element has been selected (this column is displayed for products only)

●     "Link type": the type of the link, e.g. ViewLink, Import, CCP and so on

●     "Owner": the element to which the link belongs to

●     "Status": the status of the link. A link may be assigned one of the following statuses: 
�❍     OK

�❍     Not synchronized

�❍     Reference not found

�❍     Document not found

�❍     Document not loaded

�❍     Isolated

 

2.  Use the Link type filter and the Owner Filter drop-down lists to filter the information to be displayed respectively in the Link type and Owner columns.  

By default, these lists contain the value All which means that no filter is applied and thus, all links are displayed regardless of their type and owner. 

3.  Click one of the lines showing the features pointing to the document you opened.

This activates the Replace button and provides you with file-related information below the file list: 
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The file-related information in the bottom left-hand corner of the Links dialog box indicates the Pointed document, i.e. the path and name of the 
document pointed to in the session. 
You can click the Pointed documents tab to display only the documents pointed to by the current object. 

4.  Select one of the displayed lines to activate Open : 

5.  Click Open. 

The Links of document dialog box disappears and the selected file valve.jpg , i.e. the file pointing to Product1.CATProduct, is displayed.

6.  To view the relationships between different documents and to obtain information about their properties you might find useful to select File > Desk... 

Hyperlinks, audio markers and 2D pictures are supported documents.
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For more detailed information please refer to Managing Documents Links in Version 5 in the Infrastructure User's Guide.
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Creating Hyperlinks

You can add hyperlinks to your document and then use them to jump to a variety of locations, for example to a marketing presentation, a Microsoft 
Excel spreadsheet or an HTML page. You can add hyperlinks to models, products and parts as well as to any constituent elements.

Note that in a given context, you can only have one hyperlink pointing to a given feature (model, product, part or constituent element). 
 

 Visualization Mode does not permit selection of individual model elements. To select these elements, switch to Design Mode 
(Edit > Representations > Design Mode).

 

Prepare a document that you want to see displayed via a hyperlink.

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

1.  In the menu bar, select Insert  >  Hyperlink, or, in the DMU Review Creation toolbar, click the Hyperlink icon . 

The Manage Hyperlink dialog box appears. 

 

2.  Select the object you want to represent the hyperlink. 

 
Note: You can also select the object first and then invoke the Hyperlink command.

3.  In the Name text-entry field, enter a name for your hyperlink.

4.  In the URL text-entry field, enter the path to the destination file and press Enter or click the Browse... button and select the destination file in the Link to 

File dialog box.
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You can add more than one link. Simply enter another path or click Browse... and select another file. All links created are listed in the Link to file or URL box.

To follow the link to the destination file, select a link then click Go to.

To remove existing links, select a link then click Remove.

 

5.  Click OK in the Manage Hyperlink dialog box when satisfied. 

The hyperlink is created and is identified in the specification tree. 

 

 

You can edit the Hyperlink URL, simply right-click the URL item in the specification tree and select URL object   >  Hyperlink from the contextual menu to 
edit the link. 
 
For example:
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Jumping to Hyperlinks

This task explains how to jump to hyperlinks. 

You have already added a hyperlink to your document. 

There are several ways to jump to hyperlinks:

  

 

 

 

 

 

 

 

 

 

 

 

1.  Double click the desired hyperlink in the specification tree.

                   or 

Click the Go to Hyperlinks icon  in the DMU Review Navigation toolbar, 

then select the object with the desired hyperlink or the desired hyperlink in the 
specification tree.

                   or

Select the object with the desired hyperlink or the desired hyperlink in the 
specification tree, then click the Go to Hyperlinks icon in the DMU Review 
Navigation toolbar.

                   or

Right-click the hyperlink  and select URL object > Definition... from the 
contextual menu. 

Note: The activated hyperlink will be the one corresponding to the active 
context. If the active context does not contain a hyperlink to the selected 
element, then nothing will happen.

Note: If more than one link has been created, the Open Hyperlink dialog box 
appears. 

2.  Select the link of interest, then click OK. 

The linked file is displayed.
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Note: As you point the cursor over a hyperlink object in the specification tree, a textual representation will be 
displayed indicating the URL associated to the hyperlink. You can deactivate this option at any time using 
Tools > Options > DMU Navigator... (see Customizing DMU Navigator, DMU Navigator). 
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Using Camera Capabilities

 

About Cameras: Gives background information on camera.

Creating and Displaying a Camera: Adjust view parameters (zoom, rotation, etc.) of the document, select View > 
Named Views.. then click Add. A camera appears in the list. Click OK to create a camera. 

Editing Camera Properties: right-click the camera to be edited. Perform changes, when satisfied, click Apply and OK.

Moving a Camera: Select a camera, attach the 3D compass to the 3D camera representation, then drag parts (axis, 
arc, etc.) of the compass to move the camera to a new position.

Selecting Standard Views: Select View  > Named Views... then double-click the desired view.

Creating, Modifying and Deleting User-defined Views: Customize the selected standard view then click Add. Use other 
options in the Named Views dialog box to manage views.
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About Cameras 

Cameras let you take still shots of views or viewpoints in your document. A series of views showing different 
viewpoints in succession can be combined to create an animation.

Cameras are identified by name in the specification tree and by a symbol in the geometry area .

A 3D representation helps you locate the viewpoint of interest by showing what the camera sees through a viewport:

Cameras are moved using the 3D compass or directly using the green manipulators. 

You can use cameras in two different modes: perspective or parallel, to obtain either a conical or a cylindrical 
projection. See Editing Camera Properties. 
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Perspective mode

 

  

Parallel mode 
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Creating and Displaying Camera

This task shows how to create and display cameras.

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

1.  Adjust the view parameters (zoom, rotation, etc.) of the document to define the desired camera location.

2.  Select  the View  >  Named View command from the menu bar. 

The Named Views dialog box displayed. 

 

 

3.  Click the Add button.  

A camera appears in the view list. 

 

4.  Click OK to create the camera. 

A camera is created at the current viewpoint. 

5.  Double-click Camera 1 in the specification tree. 
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6.  Zoom out and rotate the model to see the 3D representation. 

 

 

7.  Click anywhere in the geometry area to de-select the camera and see the camera symbol. 

You can create several cameras at different locations. The DMU Navigator offers you the possibility of visualizing the viewpoint of each camera in 
different windows.

8.  Select Window  >  Camera Window from the menu bar. 

All cameras created are listed.

9.  Select the cameras of interest from the list. 

A new window showing the camera viewpoint is opened for each camera selected.

10.  To organize the opened windows horizontally, select Window  >  Tile Horizontally from the menu bar.  

 

 

11.  To organize the opened windows vertically, select Window  >  Tile Vertically from the menu bar. 
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12.  To organize the opened windows so that they overlap one another, select Window  >  Cascade from the menu bar. 
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Editing Camera Properties

This task shows how to display and edit camera properties. 

Insert the following cgr files: 

ATOMIZER.cgr 
BODY_1_2.cgr 
BODY_2_2.cgr 
LOCK.cgr 
NOZZLE_1_2.cgr 
NOZZLE_2_2.cgr 
REGULATION_COMMAND.cgr 
REGULATOR.cgr 
TRIGGER.cgr 
VALVE.cgr

You have created a camera. 
 

1.  Right-click the camera in the specification tree and select the Properties item form the contextual menu. (You can also select the camera and use 

the Edit > Properties command.) 

The Properties dialog box is displayed. 

 

 

The Lens tab is active by default and enables you to edit the following:
●     Type (Perspective or Parallel, i.e. to obtain a conical or a cylindrical projection) 

Perspective Parallel
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 ●     Focal length (click and drag or use the spin box)

  

 ●     The Preview window lets you see the actions (zoom, new type...)  you perform and these actions are updated accordingly in the geometry area 

For more detailed information, please refer to Moving Cameras.

The Feature Properties tab provides general information on the currently selected camera, e.g. its name, its creation date.

2.  Click the Position tab to define the target and origin positions. 

You can define the Origin and the Target position in millimeters along the X, Y and Z axes.
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3.  Select values for the Origin and Target distances.

4.  When satisfied, click Apply.

It is now possible to have an active camera automatically updated from the current view, exactly as if you'd selected Update from View each time you change 

the view using any combination of translates, rotations and zooms. (A camera is considered "active" when it is selected or edited in a track.) 

5.  Click the Update camera from View radio button to have your camera automatically updated from the current view.

6.  Click OK to confirm. 
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Moving a Camera

This task shows how to move the camera you have just created to the desired position. 
You can move cameras in four different ways:
●     using the Pan, rotate, zoom commands directly in the camera window

●     using the 3D compass 

●     using the Edit >  Properties... on Cameras

●     using the Update camera from view option  

For more information on the 3D compass, see the Infrastructure User's Guide.

You defined a Camera.

 
Pan, rotate, zoom commands 

1.  Select Window  >  Camera Window and select the camera from the list to open a separate window showing the camera viewpoint.

2.  Select Window  >  Tile Vertically to organize opened windows vertically.

 

 

3.  Pan, rotate and/or zoom the camera in the camera window until satisfied with the camera position. 

The camera position in the document window is updated.
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3D Compass 

 
1.  Select the camera to be moved  in the specification tree. 

The 3D representation is shown in the geometry area.

Note: To move the camera, you will attach the 3D compass to the 3D camera representation. If you cannot see 
the 3D representation, click the camera in the specification tree and select Camera object  >  Hide / Show 
Representation from the contextual menu. 

 

2.  To attach the 3D compass to the 3D camera representation, press and hold down the left mouse button on the red square of the 3D 

compass, then drag the 3D compass to attach it to the camera representation.

Notice that the compass changes appearance as you drag it. 
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Pointing to a line coming from the eye automatically snaps the compass to the eye and pointing to one of the sides of the viewport snaps the 
compass to the target.

You can attach the 3D compass to two different positions of the camera representation as shown below: the eye and the target.

 

3.  Select Window  >  Camera Window and select the camera from the list to open a separate window showing the camera viewpoint.

4.  Select Window  >  Tile Vertically to organize opened windows vertically.
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5.  Click one of the translation axes of the 3D compass and drag to translate to the desired position.

As you move the camera in the document window, the camera viewpoint in the camera window is updated. 

6.  Click one of the rotation axes of the 3D compass and drag to rotate to the desired position.

7.  Continue experimenting until satisfied with the camera position. 

The camera viewpoint is automatically stored.
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Edit >  Properties... on Cameras 

1.  Right-click the Camera in the specification tree.

2.  Select the Properties item from the contextual menu displayed. 

The Properties dialog box is displayed. 

The Lens tab is active. 

. 
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3.  If you zoom, pan, rotate the camera within the Preview window, the camera position is updated accordingly  in the geometry area.
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4.  Continue experimenting until satisfied with the camera position.

5.  Click Apply and click OK. 

This is the new camera position you obtain :

 

 
 

Update camera from view option 

1.  Right-click the Camera in the specification tree.

2.  Select the Properties item from the contextual menu displayed. 

The Properties dialog box is displayed.
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3.  Select the Position tab.
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4.  Click the Update camera from view radio button and click the OK button in the Properties dialog box to confirm.

5.  Pan, rotate and zoom in the main window to define the view that the camera will represent. 

The camera is automatically updated from the view. 
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Selecting Standard Views

This task explains how to use standard views.

Insert the platform.model document from the samples folder.

 
1.  Select the View > Named Views... command. 

The Named Views dialog box appears.

The list provides a number of standard views you can use to display the 
document:

●     *front

●     *back

●     *left

●     *right

●     *top

●     *bottom

●     *iso
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2.  Double-click the desired view. 

For example, double-clicking *front obtains the front view:

 

The other views are:
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Creating, Modifying and Deleting User-defined Views

 This task explains how to create, modify and delete user-defined views.  
Note that user-defined views are stored with the document.

Insert the platform.model document from the samples folder.

 
1.  Select the View > Named Views... command and double-click the desired view.

2.  Adjust the different view parameters (zoom, rotation, etc.) as desired.

 

3.  Click the Add button to add the view to the list. 

The default name of the view is Camera 1.
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4.  Rename the view as required and press Enter.
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You now see a 3D viewpoint representation in the geometry area. The 3D representation is a viewport that helps you to define 
what you want to see in the view. What you see inside the viewport can then be stored in your view. 

 

 
Use the two spheres and the two squares displayed in green on the 3D representation to interactively manipulate and position 
the camera:
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●     the source point (1) rotates the camera around its target point

●     the target point (2) rotates the camera around its source point

●     the source green square translates and rotates the camera around its target point

●     the target green square translates and rotates the camera around its source point

 

 

 

5.  Manipulate the 3D representation to define your view parameters.

6.  In the Named Views dialog box, click the Properties button to access the Camera Properties dialog box.
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7.  Double-click anywhere on the 3D representation to apply the view parameters, and click Apply to perform the changes 

to your view.

8.  If you want to modify any customized view you have already saved, select it, modify the view parameters again, then 

click the Modify button.

You can delete views by selecting the view from the list and clicking the Delete button. 
You can view the object from the reverse angle by clicking the Reverse button. 
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Using Generic Animation

 

Player:  Provides detailed information about the player.

About Track Capabilities: Provides background information about tracks

Recording a Camera Track: Select a camera then click the Track icon. Set the automatic insert option. In 
Properties, activate Update camera from view option, click OK to save the track with camera viewpoints.

Track editor and recorder: Provides information about the DMU Fitting dedicated tools.

Copying and paste tracks: Right-click the track to be copied. Select Copy from the contextual menu, then right-
click tracks item in the specification tree and select Paste from the contextual menu. Double-click the pasted 
track to change the object selection. 

 About track operators: Provides detailed information on how to use operators.

Editing Time Line in Tracks: Select the track to be edited, click More, and either drag and drop the segment or 
enter a precise value in the shot time field. 

About Sequence Capabilities: provides background information about tracks

Sequence Editor: provides information about the sequence editor

Defining a Sequence: Click the Edit Sequence icon, add actions, sequence them, and modify the actions' 
duration, if necessary. Click the Edit Analysis tab, and add interferences and distances. When satisfied, click OK.

Detecting Interferences Automatically: Double-click the simulation object in the specification tree and click 
Clash Detection (On). Set options in the Edit Simulation dialog box and run your simulation.

Recording Viewpoint Animations: Click red start command in the Viewpoint Animation toolbar and move the 
geometry as desired to record viewpoints. Click stop command when satisfied.

Converting a Simulation into a Sequence: Select the simulation in the specification tree, select the menu 
Tools > Simulation > Convert Simulation ...
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Recording a Simulation: Select a camera then click the Simulation icon. Move the camera using the 3D 
compass, clicking Insert in the Edit Simulation dialog box to record shots and OK to save the simulation. 

Generating a Replay: Select the simulation object and select Tools > Simulation > Generate Replay.

Replaying: Select a replay object and select Tools > Simulation > Replay. Replay the recorded animation 

using buttons and options in the Replay dialog box.

Generating a Video  Tools > Simulation > Generate Video.
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About Player

The Player pop-up toolbar is available every time you create a track or a sequence, or when you simulate your 
track. You can undock the Player pop-up toolbar at any time.  When you use some of the commands from the 
Recorder or Manipulation pop-up toolbars, the Player toolbar becomes disabled.

You can access Player at any time (to generate a replay or publish a clash report for instance), by clicking 

Player  from the DMU Simulation toolbar or selecting Tools > Simulation > Player.

Player Pop-up Toolbar 

 The toolbar includes the following elements:
●     The loop mode

●     The slider

●     The time/shot mode

●     The VCR-like buttons

●     Parameters .

Loop Modes

Icon Explanation

Single loop (shows simulation once, from beginning to end).

Note:  This is the default value.  To see other loop options, click on this button.  The option that is 
visible is the one that will be operating.

Continuous loop, from beginning to end, then end to beginning.

Continuous loop, from beginning to end, then jumps back to beginning.

 

Slider
 As you drag the slider, you can see the data move as defined for the track (e.g., you can see a section attached 

to a track move along the track).

VCR-like Buttons
Use the buttons or the slider to simulate your track directly, or use the keyboard shortcuts.
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Icon Explanation

Skip to Beginning

Step Backward

Play Backward

Stop

Play Forward

Step Forward

Skip to End

 To access a recorded shot for modification purposes, use the Step Backward and Step Forward  

buttons from the Player toolbar.

 Keyboard Shortcuts

 When working in full screen, the Player toolbar is not accessible. You can use the following keyboard shortcuts 
to access Player capabilities: 

Use  This Keyboard Key/Combination To

Right arrow Play Forward

Left arrow Play Backward

Up arrow Step Forward

Down arrow Step Backward

l (i.e., a lowercase letter "L") Set the loop mode

p (for parameters in lower case) Access Speed and Pause settings

 Note: These shortcuts are also available in other screen modes

 

Time/Shot/Distance Mode
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For a track, you can play the simulation in one of two modes:
●     Time, in seconds (default) The time units (by default, seconds) are set in Tools > Options > Parameters 

and Measure > Units.

●     Shot (key frame). Selecting Shot makes the simulation jump from one shot to another, in sequence. Shot 
times have a minimum spacing of 0.00020 seconds. Shots must always be in sequential order, i.e., second, 
third, fourth, etc., shots must have a time at least 0.00020 seconds beyond the previous shot.

●     Distance allows you to interpolate along a track with a set distance. Each step is a constant distance unit 
(for example 1 mm). Users can move to a particular distance along the track (done with the step forward 
and backward buttons).

In the box, you can enter a precise value according to the mode selected in the list. The slider moves the 
simulation forward according to the mode selected.

When you open the Edit Sequence dialog box, as part of editing or defining a sequence, you can only access 
time mode. 

 

Parameters
 The track is replayed at a constant speed. Clicking Parameter  brings up the Player Parameters dialog 

box, which enables you to set a sampling size so that you see the simulation at steps of every 1, 2, or 5 
seconds.  You can also select an temporization option, which enables you to determine how quickly you see the 
simulation. If you want to view the simulation more quickly, you can set the temporization size smaller (e.g., 
to .25 s) and the sample size larger (e.g., 5 s).  

Persistency of player parameters between sessions is not supported but it is supported for one 
document session.

 

About Sampling Step

The sampling step corresponds to the sampling step value in seconds (the total duration is divided into intervals 
calculated in seconds)

By default, four sampling time steps are available, but you may edit these values whenever you need to.

About Temporization

Allows you introduce a short pause between sampling steps.
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About Track Capabilities

A track is a route of a moving object.

This document provides information on the following aspects of track capabilities:

●     Objects found on tracks

●     Creating tracks

●     Track properties (speed/duration)

●     Simulating a track

●     Changing the moving object

●     Copy/Paste capability

●     Break link

●     Clash reporting

●     About Journaling/Automation

●     Creating Tracks Using Parts with Context Links

Objects Found on Tracks 

Objects found on tracks include:

 ●     products

●     shuttles

●     lights

●     cameras

You may have an active camera automatically updated from the current view, exactly as if you 
had selected Update from View each time you changed the view using translations, rotations, 
and zooms. (A camera is considered "active" when it is selected or edited in a track.)

Please refer to the DMU Navigator's User Guide: User Guide: Using Camera Capabilities for 
information about to using camera capabilities and recording a camera track.

●     Inverse Kinematics (IK) points from Human Builder manikin

●     constrained .CATPart attached to a manikin (the part is moved as well as the manikin, with respect to the 
manikin's IK)
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The two capabilities above are available only if your configuration includes Human Builder. 

 

Creating Tracks
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 Two methods are now available to create tracks: 

●     Clicking Track  first and select the objects afterwards.

●     Selecting the objects first and clicking Track  after.

Tracks created in this manner are persistent and can be stored in the document. They are listed as separate 
entities in the specification tree and can be selected at any time and modified. 

 

Track Properties (Speed/Duration)

Tracks comprise defined positions associated with time parameter. The current time is designated with a green 
bullet.

You can insert, modify, delete a position with a dedicated tool.

See Using Track Editor and Recorder.

The track you create is a time-based trajectory. This trajectory can be interpolated with different interpolation 
types:
●     linear (default type for product, shuttles, section planes and lights)

●     spline (default for cameras and lights)

●     composite spline (enables to minimize the impact of position modifications on the entire trajectory)

The More button lets you access and edit the duration for each segment (between two positions) you can : 
●     edit segment duration within the Track dialog box using the More button

●     modify quickly the segment duration using drag and drop capability 

●     enter a precise value to modify this duration.

 
Keyboard Shortcut
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LMB + Ctrl key: lets you drag each and every segment of the time line representation without changing the 
global duration.

Please read:  Editing Time Line in Tracks.

 The Edit button lets you access an edit object dialog box (if the object is a shuttle, the Edit Shuttle dialog 
box appears; otherwise, for a section plane, a light or a camera, you see the Properties dialog box).

The Edit button is unavailable if the moving object is a product.

 

Track Operators 

Positions in the track are defined with respect to the moving object coordinates (i.e., if a track is defined for a 
light bulb and if the light bulb position is modified in the product definition, the track is updated accordingly and 
therefore remains consistent).

A track can be modified using a variety of operations referred to as track operators:  

●     Reverse time

●     Join

●     Split

●     Mirror track

●     Transform

●     Path finder
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●     Smooth

●     Swept volume

●     Update Position

The following track operators can be accessed through the track contextual menu:

●     Reverse time

●     Join

●     Split

●     Mirror track

●     Update Position
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Others can be accessed using standard commands: 
●     Transform (rotation/translation using 3D compass)

●     Path Finder  (DMU Check toolbar)

●     Smooth  (DMU Check toolbar)

●     Swept Volume  (DMU Simulation toolbar) 

See About Track Operators.

 

Simulating a Track 

You can simulate your track using the dedicated player (see About Player).  You can also generate an animation 
file ( AVI format) with DMU standard tools (using Tools > Image > Video...).

You can compile your track to generate a replay object (using Tools > Simulation > Generate Replay...)

You can validate your track using Clash Detection  available from Clash Mode toolbar as well as check 
interferences and calculate distances specifications. 

See Analyzing in Track Context.

Also, for more information about generating an animation file, see the V5 Infrastructure User's Guide :  Basic 
Tasks : Capturing and Managing Images for the Album : Recording Interactions in Video Format.

 

 Rotation at 180 Degrees

 ●     In Simulation during Rotation, the products will always be rotated by the minimum possible angle between 
two consecutive recordings (shots).

●     In the case of 180deg, when rotated using the compass panel, the direction of Rotation might not be 
consistent on consecutive rotations. The direction of Rotation could be either positive or negative.

●     However, once a Track is created for 180deg, the direction of rotation will be consistent on consecutive 
Replays of the Track.

 
Leaving the Product in a Modified Position
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When you exit Track , the product remains in its modified position. It can be useful to:

●     use it as starting position for a new simulation (e.g., open the front hood before dismounting the spark 
plugs)

●     save this position as a new product configuration.

If you need to go back to the initial product position, you can either:

●     play the simulation from the starting position (most useful when you have only one track) or 

●     use Reset  from the DMU Simulation toolbar.

 

Changing the Moving Object 

 You can change the moving object at any time using the Track dialog box (click in the Object field, then 
select a new object from the specification tree or geometry).  The track can be relocated on this new object 
or not. 

See Using Track Editor and Recorder.

Below are two examples that provide guidance on which option to select:
●     An example of Keep positioning being the better choice:  A track is defined to dismount various objects 

through a bottleneck. The track needs to remain at the same location with respect to the bottleneck 
whatever the object is, in this case, you should keep current track position. 

●     An example of Do not keep positioning being the better choice:  A track is defined to unscrew a spark 
plug. You want to make sure this track can be applied to another spark plug. In this case, changing the 
moving object along the track is valid only if you can unscrew the second spark plug from its current 
location, choose to relocate the track. 

 

Copy/Paste Capability
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You can copy and paste tracks to create instances of reference tracks. If you modify the "shot positions" of a 
track, the reference track is therefore modified and all the instances will be modified (either instance or 
reference tracks).

Then, you can apply track operators on instances  (e.g., to relocate them keeping the links existing between the 
references and instances).

For example: you defined a track to remove a spark plug. You create instances for the other spark plugs. You 
can modify the moving object along the track to move the other spark plugs with respect to the current position 
of the spark plug instance. All the spark plug instances will be moved with the same motion.

See Copying and Pasting Tracks.

 

Break Link 

This capability lets you break the link existing between the reference track and its instances. 

For instance, in the above example, one of the spark plug cannot be dismounted in the same manner, you can 
use break link to modify this particular instance track without impacting the others.

 

Clash Reporting 

Through the publish capability, you can obtain a concise clash .html report on a single track simulation 
(automatic clash detection + regular clash analysis).  The scenario below explains how to do this: 

1.  Interferences specifications are defined and linked to tracks in your document.

2.  Activate the publish functionality (select Tools > Publish > Start Publish...). 

The Publishing Tools toolbar appears.

3.  Click Player .

4.  Activate the automatic clash detection. 

5.  Click Play forward  button in the Player toolbar.  

The clash detection is launched.

6.  Click Stop Publish  or select Tools > Publish > Stop Publish.

 
7.  Read your published clash report.
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See Analyzing in Track Context.

See the sections on publishing in both the DMU Navigator User's Guide and in the DMU Fitting Simulators User's 
Guide.

 

About Journaling/Automation

Tracks are journalized. You can generate a macro using Tools > Macro > Record... 

See V5 Infrastructure User's Guide.

 

Creating Tracks Using Parts with Context Links 

 When you create a track using a part with context links, the part turns red. Once you have created the track, 
right-click the part and select the option that enables you to edit the part itself.  That is, right-click on the part, 
and select name_object > Definition. Once you are in a workbench (such as Part Design) that enables you to 
modify the part itself, right-click and select Local Update. 
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Recording a Camera Track

 This task shows how to create a camera track recording viewpoints through the simulation functionality. 

Open the SIMULATION_WITH_VIEWPOINTS.CATProduct document 
A camera and 3 viewpoints are already defined:

1.  Select camera.1 in the specification tree.

2.  Click  Track  . 

The Track dialog box and the Preview window, the Player, the Manipulation toolbar and the Recorder 

appear:

 

3.  In the Recorder toolbar, double-click  Record   to set the auto insert mode.
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The camera viewpoint is stored in the track object each time you click Insert. You can, in this way, record a series 
of viewpoints which when combined and compiled create your animation. 

Note: The default interpolator for camera tracks is Spline. 

Defining a track using the Update camera from view option

It is now possible to indicate that you wish to permanently update a camera from the current view. This enables 

you to create a camera track by simply navigating in the main window using the pan, rotate and zoom commands 

and clicking the record button of the track recorder each time you wish to insert the current view as a position in 

the recorded track. You no longer need to open a camera window. 

4.  In the Specification Tree, right-click the Camera 1 camera and select Properties in the contextual menu.  

The Properties dialog box appears. 
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5.  Click the Update camera from view radio button and click the OK button to confirm.

6.  Pan, rotate and zoom to define the next view you wish to insert in the camera track.

7.  In the Recorder toolbar, click the Modify(M) icon .

8.  When done, in the Track dialog box, click OK .  

The track is recorded and identified in the specification tree.

Replaying your simulation

9.  Open the camera window (Window > Camera Window) and tile the two windows. This will allow you to 

see the camera viewpoint better as you replay your track.
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10.  Replay your simulation, for this: double-click Track.2 in the specification tree. 

Use the dedicated DMU player. 

11.  Hide the simulation track using the Hide/Show capability. 

This is what you obtain (the track is in no show space):
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 Use track capabilities in this way to produce an animated inspection of your design.

For more information on track capabilities, see the DMU Fitting Simulator User's Guide.
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Using Track Editor and Recorder

Information follows about the track capability display, including the Recorder toolbar, and the track editor function.

About the Recorder Toolbar

Recorder Toolbar 

●     One click: Records shots one after another.

●     Double-click: Activates the auto insert mode (see Automatic Insert configuration using Tools > Options > Digital Mockup > DMU 
Fitting > DMU Manipulation). 

�❍     To deactivate this mode: Click once.

●     One click: Records modification(s) on one shot at a time. 

●     Double-click: Records modification(s) in continuous mode. You need to be positioned on the required shot. 

�❍     On the Player toolbar, use the Step Backward  and Step Forward  to position the manipulator on the required shot.

�❍     To deactivate this mode: Click once.

See Modifying a Track.

Deletes one shot after another. The cursor must be position on the shot to be deleted.

Note: In track edition context, if you need to delete multiple shots at a time, multi-select them (hold down Ctrl, and select with the left 
mouse button) and use Del.

Reorders shots. To use: 

1.  Select a track.

2.  Click Reorder . The Reorder Shots dialog box appears: 

�❍     To move a shot up one place in the list, select the shot, and click the Up button.

�❍     To move a shot down one place in the list, select the shot, and click the Down button.

�❍     To insert a selected shot after next clicked shot, select the shot, click on the shot you wish it to follow, and click After .
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3.  Once the reorder is complete, click OK.  (Clicking Cancel returns the shots to their original order).

Reuse enables you to use shots from another track while creating or editing a track.  

The Player pop-up toolbar disappears when you start using this command; it reappears once you have finished.

To use:

1.  Click Reuse .

2.  Select the track containing the shots you want to reuse. The Reuse Shots dialog box appears: 

3.  From the dialog box, select the shot you wish to reuse.  The data moves to the selected shot.

4.  On the Recorder toolbar, click Insert .

5.  Repeat Steps 3 and 4 to reuse more than one shot, then click the Done button.

 

 

When using the Recorder toolbar, you can use the Player toolbar to select shots. To do so, set the step unit to Shot (i.e., not Time), and that the value of 
the Player Parameters sampling step is set to 1. If this is done, the Player toolbar allows:

●     Step Backward  (lets you to jump to the previous shot -- e.g., to be modified). 

●     Step Forward  (lets you jump to the next shot).

 Alternatively, you can select a shot from the geometric data, if the Object field in the Track dialog box is not selected.  The shot is the initial point for 
each segment of track.

 Shot times have a minimum spacing of 0.000020 seconds. Shots must always be in sequential order, i.e., second, third, fourth, etc., shots must 
have a time at least 0.000020 seconds beyond the previous shot.

About the Track Editor 
 

The Track dialog boxes shown below show the Activate Analysis  and Sectioning  buttons deactivated.  

For a description of how to use Activate Analysis, see Analyzing in Track Context.

 For a description of how to use Sectioning with tracks, see DMU Fitting Simulator User's Guide : Basic Tasks : Tracks : Associating Sections 
with Tracks.
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Track Interpolator

A track is a time-based trajectory which can be interpolated with different interpolation types:
●     linear (default type for product, shuttles, and section planes)

●     spline (default for cameras and lights)

●     composite spline (enables users to minimize the impact of positions modifications on the entire trajectory)

Product track: Linear

Camera track : Spline

Product track: Composite spline
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Edit the track object clicking the Edit button.

 
Objects and the Dialog Boxes Associated with Editing Them

If the object is a shuttle, the Edit Shuttle dialog box is displayed.

 

  

If the object is a camera, the Properties dialog box is displayed.
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 If the object is a light, the Properties dialog box is displayed. 

A Real Time Rendering license is required to create lights.
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If the object is a section plane, the Properties dialog box  is displayed.
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The Edit button is unavailable if the moving object is a product.

 
Using the More Button

The More button lets you access and edit the duration of each segment (i.e., the amount of time it takes to travel between two positions). To alter the 
duration of each segment, you can: 
●     Edit segment duration within the Track dialog box.

●     Modify quickly the segment duration using drag and drop capability.

●     Enter a value to modify this duration.
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Please read Editing Time Line in Tracks.

 
Selecting an Object and Track Positioning

You can change the object selection during the track creation or while editing it:

●     Click on the Object field, and the Track positioning dialog box appears:

●     Keep positioning:  Lets you 
keep the current track position.

●     Do not keep positioning
(default):  Lets you locate the 
track on the new object.

 

●     Select a new object either in the geometry or in the specification tree.

 About Selecting in Editing Mode

Note: In edition mode, you can select objects to be applied only one track at a time.

Keyboard Shortcuts

Use this keyboard key (or 
combination) To

Insert Record

Shift + M Modify

Delete Key Delete

Page Up To go to the previous step

Page Down To go to the next step

Another useful shortcut

Clicking an icon lets you run the command associated with that icon only once. However, double-clicking an icon lets you use the associated command as 
many times as you want without having to click on the icon several times.
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Pop-up Toolbar Command Availability During Track Editing 

 When performing certain kinds of track editing, some of the Manipulation and Recorder pop-up toolbar commands are not available.  The table below 
shows what is available under which circumstances. 

 
Icon Command Available

 Expand Preview Window Shuttle modification

Reframe Shuttle modification

Smart Target Shuttle and track modification; all Recorder and Player commands are unavailable when using Smart Target

Dynamic Smart Target Shuttle and track modification; all Recorder and Player commands are unavailable when using Dynamic Smart 
Target

Invert Shuttle modification

Editor Shuttle and track modification

Reset Shuttle modification, after initial change made

Define Snapping Axis Shuttle and track modification

Attach/Detach Shuttle and track modification

Save Initial State Track modification (applies to DPM Assembly Process Simulation workbench only)

Record Track modification

Modify Track Track modification

Delete Track Track modification

Reorder Shot Track modification; all Player and all other Recorder commands are unavailable when using Reorder Shot

Reuse Shot Track modification
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Copying and Pasting Tracks 

This task illustrates the use of the copy/paste capability.  It can be very useful to apply the same track to another object 
which has the same dismounting path.

Open the COPY_PASTE_TRACKS.CATProduct document. A track is already defined on the 
DEMO_CGE_CHAINSAW_BODY_TANK_RSIDE.1 object.

1.  In the specification tree or in the geometry area, select the track you wish to copy. In our example, select Track.1.

2.  Put the data you have selected in the clipboard. To do this, select Edit > Copy.

3.  Select Tracks item under Applications in the specification tree.

4.  Select Edit > Paste. 

This operation recovers the data previously put in the clipboard. 

The track is pasted:
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5.  Double-click the pasted track -- in our example:Track.1(Track.2) -- to modify the object selection.

The Track dialog box along with the Recorder and Player pop-up toolbars are displayed.

6.  In the Track dialog box, click the Object field.

The Track positioning dialog box appears:

(For this example, keep the default option set.)

For more detailed information, please refer to Using Track Editor and Recorder.

7.  Select  DEMO_CGE_CHAINSAW_BODY_TANK_LSIDE.1 object either in the specification tree or in the geometry area.
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This is what you obtain:

The two tracks are linked together. For example, if you insert a new shot in the first track:

8.  Double-click Track.1(Track.1) in the specification tree.

9.  Select the Skip to end button  in the Player and insert a shot (moving the 3D compass).

10.  When done, select Record . 

The shot is automatically added in the second track. The two tracks are synchronized.
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11.  Select the OK button to confirm your operation.

The modified position is kept when exiting the track command (dismounted).

 If you need to restore the initial position, select Reset Position  from the DMU Simulation toolbar.

Remember you can break the link between the two tracks using Break link.

You can access it via the track contextual menu.

Be careful because the result depends on the track selection order.
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About Track Operators 

What Are Track Operators?

Operations that modify track are referred to as track operators.

These operations modify the original trajectory in different ways. The initial track is considered as an input specification and the operation output is a new track, 
which is considered a result. If the original specification is modified (because of design or packaging changes), you can automatically update the resulting track 
(using the Update command accessible from the track contextual menu).

This update command differs from the Update Position function that also appears on the track contextual menu. Update Position enables users to update the 
position of the track if the object associated with the track has moved. 

Some track operators are logged using a history displayed in the specification tree. The original track is considered a specification.  Track operators are applied 
to this initial  track. The new track defined is the final result (this is displayed in the specification tree and in the geometry area). 

The original tracks are hidden on the geometry. That is, they are visible in no show space. They are, however, displayed in the specification tree.

When you perform track operations on a track, the operations cannot be exported or imported.

Although the history can be deleted at any time, doing so causes you to lose the ability to update the resulting track as you wish when the original specifications 
change.

Also, not all track operators use this model. For reverse time, deleting the Reverse time node does not return the track to its original specification. In that case, 
the reverse time option must be selected again to return the track to its original order.

This is an example of a track operator history:

 

What Track Operators Are Available?
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 Various operations modify the track:
●     Reverse time

●     Join tracks

●     Split track

●     Mirror track

●     Transform

●     Path finder

●     Smooth

●     Swept volume

●     Update Position

Accessing Track Operators
The following operations can be accessed through the track contextual menu:
●     Reverse time

●     Join tracks

●     Split track

●     Mirror track

●     Update Position

 

For detailed information about Break link, please refer to Copying and Pasting Tracks.

Others can be accessed using standard commands: 
●     Transform (rotation/translation using 3D compass)

●     Path Finder  (DMU Check toolbar)

●     Smooth  (DMU Check toolbar)

●     Swept Volume  (DMU Simulation toolbar)
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About Reverse Time  

 Lets you modify the trajectory direction (by default, the direction is defined with respect to the creation order of the track positions). 
 
Use this functionality to simulate your track in reverse (i.e., a dismounting track becomes a mounting track). To simulate the track in its initial order, you should 
select the reverse time function a subsequent time.

Each reversal creates a sub-node on the specification tree. Deleting the sub-node does not alter the order of the track positions.

What you need to do

Right-click the track; on the geometry, select the track object item; on the contextual menu, select Reverse time.

About Joining Tracks 

 Lets you merge several tracks. You can select more than two tracks at a time.

What you need to do

Multi-select tracks, select Join tracks from the contextual menu: a new track is created. The initial tracks are swapped in no-show space. 

The result depends on the track selection order. See the examples below.

Two tracks to be merged

Result 1 Result 2

 

About Splitting a track 
 Lets you split a track into two new tracks. Two selections are available: 

●     if you select a point on the original track, the result will be two continuous tracks. 

●     if you select segments, the result will be two discontinuous tracks. 

What you need to do

Right-click the track; on the geometry, select the track object item; on the contextual menu, select Split track. Select a point or a segment: two new tracks are 
created. The initial track is swapped in no show space. 

Example 1: Selecting a point
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Example 2: Selecting a segment

About Mirroring a track 
 Lets you apply a symmetry on a track using a plane of your choice. Define the required plane using the 3D compass. See example below. 

Position the 3D compass wherever you want. This position defines the symmetry plane with respect to the uOv plane of the 3D compass.  

What you need to do

Right-click the track; on the geometry, the track object item; on the contextual menu, select Mirror track : 
a new symmetrical track is created and the initial track remains displayed in the geometry area

 

About Update Position
 Repositions the track relative to the object associated with the track, if the object has been moved. 

What you need to do

Right-click a track, and select Update Position.

About Transforming a Track 
 Lets you reposition the entire track (translate and/or rotate) as  if it were any other object, using the 3D compass.

Drag and drop the 3D compass handle onto a track, then move the compass as you wish.

You can select a track or multi-select tracks and their related objects.
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About Launching Path Finder on a track
Lets the system find automatically a dismounting path without any collisions.

This capability uses an input specification (that is the initial track) and results in a new track. 
The path finder uses the original positions on the track to optimize the path. 

What you need to do

Select a track, click Path Finder  in the DMU Check toolbar and click Apply: a new track is created, the initial track is swapped in no show space.

The Update track capability is very useful when performing a path finder. Any modification of the initial track launches a new path finder computation, the 
resulting track is updated accordingly.

For more information about path finder, please see: DMU Fitting Simulator User's Guide: Advanced Tasks: Using Path Finder.

About Smoothing
Lets the system automatically get rid of the unnecessary positions without introducing any collisions.

This capability uses an input specification (that is, the initial track) and results in a new track. 

What you need to do

Select a track, click Smooth  in the DMU Check toolbar and select the Apply button: a new track is created, the initial track is swapped in no show space.

The Update track capability is very useful when smoothing. Any modification of the initial track launches a new smooth computation, the resulting track is 
updated accordingly.

For more information about smooth, please see: DMU Fitting Simulator User's Guide: Basic Tasks: Mono-Shuttle Fitting Simulation: Using the Smooth Command.

About Swept Volume
Lets the system compute automatically the swept volume of a moving part along a track.

This capability uses an input specification (that is the initial track) and results in a new swept volume which can be saved in different format types. 

Select a track, click Swept Volume  in the DMU Simulation toolbar and select the Apply button: a new swept volume is created, the initial track is 
remains.

The Update track capability is very useful when performing a swept volume. Any modification of the initial track launches a new swept volume computation, the 
resulting swept volume is updated accordingly.

For more information about swept volume, please see: DMU Fitting Simulator User's Guide: Advanced Tasks: Using Swept Volume.
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Editing Time Line in Tracks

This task show you to edit  time line in track command for demo purposes. It can be useful to differentiate 
simulation segments editing each and every segment duration (i.e. speeding up or slowing down depending on 
the part you are being dismounting.

When creating a track, the duration of each segment is, by default, calculated to keep a uniform speed over the 
whole track. 

To change the duration of each segment, you can 

●     edit segment duration within the Track dialog box using the More button

●     modify quickly the segment duration using drag and drop capability 

●     enter a precise value to modify this duration.

Open the CHAINSAWAT.CATProduct document.

1.  Double-click Safety_Handle_Track (Track.1) either in the geometry area or in the specification tree.

The Track dialog box, Player and Recorder pop-up toolbars appear.

2.  Click Parameters  in the Player.

The Player Parameters dialog box is displayed.

3.  Enter 5 s in the Sampling Step field.
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4.  Play your track simulation using the Play forward  button from the Player.

5.  On the Track dialog box, click the More button.

The next set of steps reduce the last segment duration.

6.  Select Time in the Mode area.

7.  Select the last segment.

8.  Drag the last shot (its duration is 150.276 s) to approximately 220.
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9.  Drag the first shot from 24.34. to approximately 140.

(If you want greater precision, enter the value in the Shot time field and press Enter.)
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10.  Play your track simulation again using the Play forward  button from the Player.

If you are not satisfied with the result, modify the duration again.

The track simulation is slow at the beginning and speeds up in the end.

Keyboard Shortcut

 Left mouse button + Ctrl: lets you drag each and every segment of the time line representation without 
changing the global duration.
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About Sequence Capabilities  

What Is a Sequence?

A sequence is a way to put together and schedule actions to perform simulations.

Sequences are persistent and can be stored in your document. 

They are created with Edit Sequence .

What Is an Action?

Actions are entities of different nature organized within the sequence. They can be objects from the following list:

●     Tracks (i.e., camera tracks, product tracks, shuttle tracks, section plane tracks, light tracks).

Please read About Track Capabilities.

●     Color and transparency actions 

●     Visibility actions, i.e., Show/Hide 

●     Simulations

●     Sequences 

●     FEA Analysis

Please read DMU Engineering Analysis Review : User Tasks: Results Management: Animating Images.

●     Mechanisms that can be simulated with laws

Please read DMU Kinematics Simulator User's Guide: Basic Tasks: Running Simulations : Simulating with Laws.

About Action Duration

Actions are characterized by a duration, i.e., track duration is linked to the trajectory length.  Instantaneous actions have a duration equal to zero.  
Each segment of an action can have a different duration within a sequence. 

About Visibility and Color Actions

The model for actions within a sequence is based on the track model.  Using a a color/transparency action within a sequence, you can use the 
following capabilities: 

●     record multiple states for the same action using the standard graphic properties toolbar.

●     change the object on which the action is applied 

●     record using the same Recorder pop-up toolbar used for track definition

●     edit the time of the action (that is, you may change the duration of each segment within a sequence).

●     VB exposition 

●     visibility or color actions can be created in sequence context.

●     color and transparency actions have a duration within a sequence.  The sequence duration can override the duration set for the Properties of the object 
while the sequence is played on the Player.

●     visibility actions are instantaneous

Please read Defining a Sequence.

Initially the product looks like this: 
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when creating a color action in the sequence, it can become:

Depending on the effect you want to obtain, you can schedule the action using the Action Delay.

The picture below gives you the various results after action creation according to the option set:

This duration is recovered in the sequence but you can also apply a specific duration in sequence context. 

Example: 

Duration in the player of a sequence comprising two tracks: 
The two actions are scheduled to start one after the other (see About Sequencing) 

Beginning End

About Actions Affecting the Shuttle
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●     Creating a visualization action (i.e., to show or hide a shuttle) will affect the symbol in the geometry that represents the shuttle only.  It will 
not show or hide any objects associated with the shuttle.

●     Creating a color action will affect the color of the objects associated with the shuttle; it will not affect the geometry's symbol for the shuttle.

About Action Modification

You can modify the action duration, all you need to do is: 
●     Select the action in the Action in Sequence list

●     Enter the new value in the Action Duration(s) (i.e., 200)

●     If you need a delay, enter a value in the Action delay(s) (i.e. 400)

●     Use the Reset duration button to swap to the default action value (intrinsic duration).

 

About Sequencing

Sequencing defines a time frame within which the actions are scheduled.  
 
Two sequencing modes are available:

●     actions start together (simultaneous mode)

●     actions start right one after the other (consecutive mode)

Simultaneous mode 

Beginning Middle End 
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Consecutive mode

              Beginning Middle End

You can combine the two modes and modify the scheduling at any time. 

Sequences lets you put together existing actions. You can easily create a new action on the fly and add it in the current sequence. This capability lets you 
edit actions in context and synchronize meeting points in different actions.

The example below illustrates the two modes in combination:

Simultaneous mode 

Consecutive mode

About Journaling/Automation 

Sequences are journalized. You can generate a macro using Tools->Macro->Record... (see the Infrastructure User's Guide) 
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About Sequence Creation

Three methods are available to create sequences: 

●     When there are existing actions in your document (listed in Action in session), click Edit Sequence , and add them using the arrow into the Action 

in sequence list and schedule them, using the sequencing tools

Please read Using the Sequence Editor.

●     Open an empty sequence and create actions on the fly (the sequence editor remains opened)

●     A combination of the two methods above. 

Sequences created in this manner are persistent and can be stored in the document. They are listed as separate entities in the specification tree and can 
be selected at any time and modified.
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Using the Sequence Editor 

The sequence editor lets you manage and simulate the following types of actions: 

●     moving objects (part, camera, ...) 

●     graphic attributes ( show/hide, colors, transparency)

You can also manage time with Gantt chart. 
 
The Edit Sequence dialog box comprises two tabs:

●     Edit Action tab

●     Edit Analysis tab

Using the Edit Action Tab

Add Actions

Select an action in the Action in session list and click the Add button .  

The action is added in the Action in Sequence list.
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Remove Actions

Select an action in the Action in session list and click the Remove button .  

The action is removed from the Action in Sequence list.

 If you multi-select actions in the Action in session list and click the Add button, the actions are added in simultaneous mode.
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Customize the Action Add Mode Settings

Create last step and add option: creates a last step and adds the selected action into it.  This option is the default for the Action add mode settings.  
This option works in consecutive mode.

 

Add in last step option: lets you add an action in last step in simultaneous mode.

 

Iterative create last step and add option: lets you add the actions in consecutive steps (1-2-3...)

 

Sequence Actions

The method of sequencing actions depends on whether you want the actions create in simultaneous or consecutive mode.
●     For consecutive mode:

�❍     Move up:  moves up a selected action 

�❍     Move down:  moves down a selected action

●     For simultaneous mode:
�❍     Merge up: merges the selected action up

�❍     Merge down: merges the selected action down

 Remember you can combine the two modes within the same sequence. 

Please read About Sequence Capabilities.

Customize the Action Duration

●     Action duration: the numerical field lets you enter a specific duration for an action (this capability enables to simulate the same action with a different 
time scaling).

 

●     Reset duration lets you reset the selected action to its intrinsic duration

 

 You can enter a specific duration for all action types except visibility actions which are instantaneous (i.e., duration=0) 
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●     Action delay: lets you delay the starting time of an action (i.e., it is now possible to overlap two actions)

For instance, two tracks within the same sequence step can be synchronized, in order to achieve passing by specific way or via points simultaneously.

For all actions contained in the sequence, the delay is a time attribute, just like their duration. It means the action will start with respect to the specified 
delay with the theoretical beginning of the step, which the action belongs to. Valid delay values are zero or positive. 

When actions appear in the Action in sequence list, they are scheduled in steps and their duration and delays are displayed.

 To apply a delay to an action or modify a delay, select the required action in the Action in session list and enter a value in Action delay.

Please read About Action Duration.

Using the Edit Analysis Tab
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Add Interferences or Distances

Select an analysis in the Analyses in session list and click the Add button. 

The action is added in the sequence list.

Remove Interferences or Distances

Select an analysis in the Analyses in Sequence list and click the Remove button. 

You can add existing interferences or distances or create them on the fly (in this case they are automatically displayed in the Analyses in session list

Set the Clash Detection Mode

●     Set all inactive option: (default mode) as you simulate your sequence, the detection is set to off, the interferences and/or distances defined in your 
sequence are not taken into account

●     Set all active option: as you simulate your sequence the detection is set to on, the interferences and/or distances defined in your sequence are taken 
into account

●     Set all stop option: as you simulate your sequence, the detection is set to stop (on collision), the simulation stops when an interference defined in 
your sequence is detected. The distances defined remain active.

Editing Actions and Analysis
 Double-click actions, interferences, or distances to display the dedicated editor. Perform the required modifications. The modifications are automatically 

taken into account in the Edit Sequence dialog box. 

 

Player Pop-up Toolbar
The Simulation Player pop-up toolbar appears when the Edit Sequence dialog box opens.  Only the time mode is available for sequence editing.  

When you play the sequence, the action being performed is highlighted in the Edit Sequence dialog box. If you do not want the actions highlighted, clear 
the Highlight the Simulated Action(s) check box.  

If you have a delay as part of the sequence, you may see some overlap in the highlighting.
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Defining a Sequence  

This task shows you how to define a sequence.  In addition to describing how to create a basic sequence, this procedure describes:
●     Making Two Actions Start Simultaneously

●     Adding Analysis to a Sequence

Open the DEFINE_SEQUENCE.CATProduct document. Two tracks are already defined.

1.  Click Edit Sequence  in the DMU Simulation toolbar.

The Edit Sequence dialog box (see below) is displayed.

The Player toolbar appears when the Edit Sequence dialog box opens.  Only the time mode is available for sequence editing.

2.  Select Track.1 (Track.1) in the Action in session list and then click the Add button. 

3.  Select Track.1 (Track.2) in the Action in session list and then click the Add button. 

The tracks appear in the Action in Sequence list.

Sequence.1 is identified in the specification tree.
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In the next steps, you make the two tracks start simultaneously.

4.  Select the Merge Up button 

The two actions (in this case, tracks) start together.

Alternatively, when first creating the sequence, you could have selected both tracks simultaneously in the Action in session list, and then selected the 
Add button (in lieu of Steps 2 and 3).

5.  Check the Add in last step option in the Edit Sequence dialog box. 

Actions can be created on the fly.  The next step will provide an example by creating a Color Action.

6.  Click Color Action  in the DMU Simulation toolbar.

The Color Action dialog box and the Recorder pop-up toolbar appear.

3D Insight Version 5 Release 19 Page 540 of 1379



You can alter the name of the color action by entering one in the Name field, or you can accept the default name provided.  For more information about how 
the initial color of an object is determined, see About Color Determination.

7.  Select Handle.1 either in the specification tree or in the geometry area.

The Graphic Properties pop-up toolbar appears.

8.  Select a color of your choice using the arrow and combo list (e.g., blue).

The object changes to blue instantaneously.

9.  Click Record .

10.  Alter the opacity/transparency in one of two ways:

�❍     On the Graphics Properties toolbar, select a percentage of opacity (100%=completely opaque; 0%=completely transparent). 

�❍     Use the Color Action and Properties dialog boxes to alter the transparency:

a.  Select the Edit button in the Color Action dialog box. 

The Properties dialog box appears.

b.  Select the Graphic tab in the Properties dialog box.

c.  In the Properties dialog box, check the Transparency option (if it is not already checked), and move the slider as desired. 

In this case, 0 (i.e., the slider set to the left) equals completely opaque; and the largest number (i.e., the slider set to the right) equals completely transparent.

You can access the Properties dialog box at any time to change color or transparency. The Graphic Properties pop-up toolbar is a quicker way to modify 
graphic properties. 
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 Note that the color or transparency of geometric data is a graphic property of the data.  Therefore, if you delete a color action, the color or transparency selected 
in the color action remains a graphic property of the data.  To alter the color or transparency, alter the graphic properties.

11.  Click the Apply button to confirm that the settings are those desired.  

12.  When done, click the Close button to exit the Properties dialog box.

13.  Click Record  on the Recorder pop-up toolbar.

14.  Click OK in the Color Action dialog box.

The color action is automatically added in the action in the sequence and identified in the specification tree.
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15.  Modify the action duration by entering 200 in the Action duration(s) field (if the duration does not already equal 200).

For more detailed information, please read: About Action Modification.

16.  Select the Color Action.1 in the Action in Sequence list and enter 400 in the Action delay(s) field.

17.  Play your sequence using the Player.

In next section, you can add analysis to your sequence.

18.  Select the Edit Analysis tab on the Edit Sequence dialog box.

19.  Multi-select the existing analyses (i.e., Distance.1 and Interference.1) and click the Add button. 

You can create and add analysis specifications on the fly. You can also edit existing analysis specifications by double-clicking them in the Analyses in 
Sequence list.
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20.  Select the Set all active button.

21.  Click OK in the Edit Sequence dialog box.

22.  Select your sequence in the specification tree and click Player .

23.  Simulate your sequence using the Player buttons.

24.  If you need to restore the initial positions, click Reset .

25.  Open the DEFINE_SEQUENCE_RESULT.CATProduct to check your result.
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Detecting Interferences Automatically 

 This task shows you how to use the Interference Detection functionality while replaying a simulation. 
 

The Automatic Clash Detection is now available while moving an object with the 3D compass. 
 

 Open the document AUTO_CLASH_DETECTION.CATProduct, then select Digital Mockup  >  DMU Navigator from the Start menu. 
 

 

 

1.  Double-click Simulation.1 in the specification tree. 

The Kinematics Simulation and  Edit simulation dialog boxes appear.

 

2.  In the DMU Generic Animation toolbar, click the arrow within the clash detection icon. 

Undock the toolbar if necessary.

 

3.  Set the Clash detection to on .

4.  In the Edit Simulation dialog box, select 0.04 as the interpolation step.

 

 

5.  Run your simulation using the VCR buttons.

The products in clash are highlighted in the geometry area. 
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6.  Now select the Stop mode clash detection .

7.  Run your simulation. This time, the simulation stops at the first clash detected.

 

If you need to obtain a finer clash analysis, you need to define a interference, please refer to Space Analysis User's Guide. 
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Recording Viewpoint Animations

This task will show you how to record viewpoint animations either using the fly command or manipulating directly the 
geometry. A replay is automatically created for each new viewpoint recording. 
 

Open the cgr files from the samples folder. 
Use the Fit All In icon  to position the model geometry on the screen. 

 

1.  In the the DMU Generic Animation toolbar, click the Record Viewpoint Animations icon . 

The Viewpoint animation toolbar appears:

 

2.  Click the red button to start recording viewpoints.  

The Resulting Replay dialog box is displayed.

 

3.  Enter a meaningful name and click OK. 

The replay object is identified in the specification tree. 
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You are now in recording mode: 

The Viewpoint animation toolbar enables you to:

●     stop  the recording

●     pause  whenever you need to

●     have the status (record)

You are ready to start recording viewpoints.

4.  Move the geometry as desired, for instance:

3D Insight Version 5 Release 19 Page 548 of 1379



5.  When you are satisfied, click the  button and close the Viewpoint Animation toolbar.

6.  Double-click Replay.1 in the specification tree.
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The Replay dialog box is displayed: 

 

7.  Use the VCR buttons to run Replay.1 . 
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Converting a Simulation into a Sequence

 This task shows how to convert an existing simulation into a sequence.

In our example, there is one existing simulation to be converted. The result expected is a sequence containing a 
simulation action. 

Open the CONVERT_SIMULATION.CATProduct document. A camera and 3 viewpoints are already defined.

1.  Select  Simulation.1 either in the specification tree or in the geometry area.

 

 

2.  Select Tools > Simulation > Convert Simulation... 

The conversion is automatically launched.
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This is what you obtain:
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The convert simulation command is very useful to reuse old simulations.

3.  Open the CONVERT_SIMULATION_RESULT.CATProduct to check your result.
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Recording a Simulation 

 This task and the following task will show how to create an animation using one camera. This is done in two steps: 
●     Define a track 

For this, you will use the 3D compass. For more information on the 3D compass, see the Infrastructure User's 
Guide.

●     Create a film (a replay object) from your simulation.

This enables you to produce an animated inspection of your design. For more information, see the DMU Fitting 
Simulator User's Guide. 
 
You defined a Camera.

1.  Select the camera  in the specification tree.

2.  Select Insert > Simulation...

The Edit Simulation dialog box and the Preview window showing the object manipulated (in our case, 
the camera) appear.
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To change the default display setting for the Preview window, see Customizing DMU Navigator Settings. 

3.  Close the Preview window.

 

The camera viewpoint is stored in the Simulation object each time you click Insert in the Edit Simulation dialog box. 
You can, in this way, record a series of viewpoints which when combined and compiled create your animation.

Remember that the initial position is automatically recorded.

 

4.  Using the 3D compass, move the camera to a new location. 

By default, the 3D compass snaps to the eye when you clicked the Simulation icon if it wasn't attached before.

5.  Click Insert and record the desired shot.

6.  Move the camera as often as necessary, clicking Insert to record shots.

You may find it useful to open the camera window (Window > Camera Window) and tile the two windows. This will 
allow you to see the camera viewpoint better as you move the camera.

7.  Use the VCR buttons to position the camera in its original location and replay the recorded camera positions.

8.  Click OK to save the simulation.

Note: No simulation is displayed when defining a simulation recording camera viewpoints.

Generating a Replay

You are now ready to create a film. This is done by generating a replay. 

9.  Select the Simulation object in the specification tree.

10.  Select Tools > Simulation >  Generate Replay . 

The Generate Replay dialog box appears.
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11.  Enter a meaningful name for your film if desired.

12.  Click OK to generate the replay. 

You can see the results in the geometry area as the simulation is being compiled.
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Generating a Replay  

 You are now ready to create a film. This is done by generating a replay. 

You defined a Camera and you created a simulation object in the task Recording a Simulation.

1.  Select the Simulation object in the specification tree.

2.  Select Tools > Simulation >  Generate Replay . 

The Generate Replay dialog box appears.

 

 

3.  Enter a meaningful name for your film if desired.

4.  Click OK to generate the replay. 

You can see the results in the geometry area as the simulation is being compiled.
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Replaying 

This task shows you how to replay a recorded animation. 

You must have already recorded an animation. See Recording a Simulation. 

1.  Select the Replay object in the specification tree.

2.  Select Tools > Simulation >  Replay . 

The Replay dialog box is displayed.

 

 

3.  Open the camera window (Window > Camera Window) and tile the two windows to see the animation 

better.

4.  Click the Play Forward button to run a continuous replay of the recorded viewpoints  

or 

click the Step Forward button to run a step-by-step of the recorded viewpoints.

5.  Adjust the sampling step. 

Leaving the value at x1 replays the film in the number of steps defined when compiling the simulation. 

Increasing the value speeds up the animation, for example, setting the sampling step to x2 will replay the 

film at every second step.
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You can choose one of the loop modes to re-run the animation in a continuous way (either in one direction only or in 
one direction then the other). 

For more information on Replay capabilities, see the Fitting Simulator User's Guide. 
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Generating a Video Using DMU-Dedicated Tool

About Video Generation:

In the context of collaborative work, users often generate videos from simulations (e.g. Tracks, Sequences). They 
can use CATIA standard video capture tools but this implies more than 10 interactions.

Now, a dedicated tool is available in DMU Fitting workbench in the menu Tools  > Simulation  > Generate Video.  
The options for recording simulation include two moving formats (VFW Codec and DirectShowFilter) as well as 
still image snapshots (JPEG format) of each step in the recording.

The DMU Player is automatically displayed to check the consistency of the simulation before generating the video. 

The way the video has to be generated (format, file location, etc.) is defined in the standard Video Capture Tool. This 
tool makes the customization independent of the generation.
Open CHAINSAWAT.CATProduct document.

1.  Select Sequence.4 in the specification tree

2.  Open a camera window by selecting Window > Camera Window > Camera.1.

3.  Select Window > Tile Horizontally.
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4.  If the tracks are visible in the geometry, multi-select the tracks in the specification tree and click Hide/

Show , or select View > Hide/Show > Swap Hide/Show. 

The track objects are no longer displayed; they have been transferred into the No Show space.

5.  Select Sequence.4 again on the specification tree, then Tools > Simulation > Generate Video.
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The Video Generation dialog box and the Player are displayed:

Player

6.  Click the File name... button.

The File Selection dialog box is displayed

7.  Enter a name, choose the location of the video file to be recorded, and then click Save.
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8.  In the Player, click Parameters .

The Player Parameters dialog box is displayed.

9.  Enter 0.2 s in the Time Step field.

 

10.  Click OK in the Video Generation dialog box to launch the recording.
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11.  Open the recorded file.
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 Managing Enhanced Scenes

 

 About Enhanced Scenes

Creating an Enhanced Scene Select the products of the Assembly that will define the Enhanced Scene content 
and click the Enhanced Scene icon.

Generating an Enhanced Scene from an Old Scene  Select the Old Scene in the specification tree and click the 
Enhanced Scene icon. 

Browsing Enhanced Scenes using the Scenes Browser  In DMU Review Navigation toolbar, click Scenes Browser 
icon, then double-click the image of an Enhanced Scene.

Activating an Enhanced Scene In the specification tree, double-click the Enhanced Scene or in the Scenes 
Browser, double-click the image corresponding to the Enhanced Scene.

Exploding an Assembly Select the products to be exploded and click the Explode icon. In the Explode dialog box, 
set parameters and click Apply.

Overloading Attributes in Enhanced Scene Context Select products, click the icon corresponding to the attribute 
to be overloaded.

 Managing Attribute Overloads, Double-click Scene.1 in the specification tree, in specification tree, right-click 
Scene.1, select Scene.1 object  >  Manage Attributes Overloads in the contextual menu. 

 Adding, Replacing and Deleting Component in the Assembly

 Checking Component Position Select products, In the specification tree, right-click Scene.1 and select Scene.1 
object  >  Check Position.

Saving a Viewpoint in Enhanced Scene Context Modify viewpoint and click the Save Viewpoint icon.

 Creating an Enhanced Scene Macro 

Applying an Enhanced Scene Context to an Assembly Click Apply Scene on Assembly icon, select attributes to be 
applied, click OK or in the Scenes Browser, customize settings to apply scene context to assembly and double-
click the image of the scene to apply.

Applying an Assembly Context to an Enhanced Scene Click Apply Assembly on Scene icon, select attributes to be 
applied, click OK.

 Automating Enhanced Scene Context Application Using User-defined Attributes

 Saving a Enhanced Scene in ENOVIAVPM 

Exiting Enhanced Scene Context
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About Enhanced Scenes

 

 
Enhanced Scenes will extend the limited capabilities of Old Scenes. It will now be possible to create and edit applicative data. 

Enhanced Scenes

 An enhanced scene can be seen as an alternative view of an assembly in a defined state. It enables you to study a variant of your mock-
up by defining specific component positions and specific attributes. 

You can overload the following attributes:

●     Component Positioning (using compass manipulation, snap or explode commands)

●     Component Graphical attributes (color, transparency, line type, line thickness)

●     Node Activation state 

●     Component Hide / show state 

●     Viewpoint 

One of the major benefits of Enhanced Scenes is that the applicative data container will be available and functionalities associated with 
the applicative data will also be available in Enhanced Scene context. 

It will be possible to generate Enhanced Scenes from Old Scenes. 

Overloading of attributes (graphical, show / no show state, etc.) is limited to Products, i.e. these modifications are not replicated 
between scene and assembly for Products, however, for parts, models and manikins these modifications will be replicated (modifications 
on parts, models and manikins are always replicated in both directions). Likewise, modifications in Enhanced Scene context to Product 
attributes that are not in the above list (of attributes that can be overloaded) will be replicated on the assembly. 

Overload Modes in Enhanced Scenes
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When you work in Enhanced Scenes, there are two Overload Modes, Full and Partial.

Overload Mode Full

●     When you create a Enhanced Scene in Overload Mode Full, all attributes are immediately considered overloaded. 

●     All subsequent modifications to the Assembly will have no impact on the Enhanced Scene and vice-versa. 

●     If you choose to apply the Enhanced Scene context on the Assembly or to apply the Assembly context on the Enhanced Scene, after 
the operation, all attributes will still be considered overloaded and subsequent modifications to either the Enhanced Scene or the 
Assembly will continue to be independent, one from the other.

Overload Mode Partial

●     When you create a Enhanced Scene in Overload Mode Partial, by default, none of the attributes are considered overloaded.

●     Modifications to the Assembly will impact those attributes of the Enhanced Scene that are not overloaded (so, for example, if you 
make some modifications to the Assembly immediately following the Enhanced Scene creation, all of these modifications will impact 
the Enhanced Scene).

●     Modifications to the Enhanced Scene never impact the Assembly, the result of such modifications to the Enhanced Scene is to 
overload the modified attributes. 

●     Attributes in the Enhanced Scene are overloaded implicitly when you modify the attribute in Enhanced Scene context.

Graphical attributes, activation state, hide / show state, and viewpoint, once modified in the Enhanced Scene, will be 
considered overloaded. The overloaded values do not impact the Assembly. These overloaded attributes will subsequently be 
independent from the Assembly, i.e. modifications to the corresponding attributes in the Assembly will not impact the values 
of the attributes in the Enhanced Scene.

Position attributes are implicitly overloaded when modified in the Enhanced Scene, however, you can also overload them 
explicitly by selecting the components for which you wish to overload the position and then clicking the Overload Position 
icon in the Enhanced Scenes toolbar (see Overloading Product Attributes in Enhanced Scene Context).

●     If you choose to apply the Enhanced Scene context on the Assembly or to apply the Assembly context on the Enhanced Scene, after 
the operation, those attributes that were considered overloaded will continue to be considered so (even though they may 
momentarily have the same value as the corresponding attribute in the Assembly).

Subsequent modifications of these overloaded attributes in either the Enhanced Scene or the Assembly will continue to be 
independent, one from the other.

Subsequent modifications to the Assembly of those attributes that are not considered overloaded will continue to impact the 
Enhanced Scene. 
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Applicative Data Available in Enhanced Scene Context

The following applicative data are available in the Enhanced Scene context:

●     Annotated Views

●     3D Annotation

●     Hyperlinks

●     Group

●     Cumulative snap

●     Reset position

●     Init position

●     Current selection

●     Applicative data reordering

●     Apply material

●     Publish

●     Camera

●     Cache content

●     Modify sag

●     DMU Move

●     Measure 

●     Section

●     Clash

●     Rendering lights 

●     Rendering Environments 

Note: The automatic update of Enhanced Scene associated applicative data is managed by a variable in the DMU Navigator Settings. See 
Customizing DMU Navigator Settings. 
 

 
The Assembly is the Reference for Enhanced Scene Creation

Enhanced Scene creation always uses the Assembly as the reference. In Overload Mode Partial, any modifications to attributes in the 
Assembly will affect every Enhanced Scene that does not overload those attributes. 
 

Therefore, the command Apply Scene on Assembly will affect all of the Enhanced Scenes with Overload Mode Partial that have not 
overloaded the attributes corresponding to those that will be updated in the Assembly. 

 
Propagation of Overloaded Attributes in Enhanced Scene Context

The propagation of attributes in Enhanced Scene context will work exactly as in Assembly context. Note, however, that the propagation 
of the value of a Product's overloaded attribute to its children will not cause the child Product's attribute to be considered overloaded.

 
Save Command in Enhanced Scene Context
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The Save command will be enabled in Enhanced Scene context, but you should be warned that it is the Assembly that will be saved (it 
will be the equivalent of doing Exit Scene + Save in Assembly context + Double-clicking the Enhanced Scene in the specification tree to 
re-enter the Enhanced Scene).

 
Restrictions

●     In Enhanced Scene context, only products can be UI-Activated. 

●     Enhanced Scene context is NOT intended for assembly edit (add part, delete part, geometry modification), its intent is strictly review-
oriented.
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Creating an Enhanced Scene 

 

Enhanced Scenes enable you to work on an alternative state of a product.

Insert the following GARDENA model documents from the cfyug samples folder:

GARDENAATOMIZER.model 
GARDENABODY12.model 
GARDENABODY22.model 
GARDENALOCK.model 
GARDENANOZZLE12.model 
GARDENAREGULATOR.model 
GARDENATRIGGER.model 
GARDENAVALVE.model 
GARDENA_NOZZLE22.model 
GARDENA_REGULATION_COMMAND.model 
 

1.  In the specification tree, select the products of the Assembly that will define the Enhanced Scene content. 

 Selecting Enhanced Scene Content

Note that there are three ways to select Enhanced Scene content:

●     No selection: the entire Assembly will appear in the Enhanced Scene 

●     One or more products selected (a subset of the Assembly): only the components in the branches leading back to the 
Assembly root of these selected products will appear in the Enhanced Scene 

●     An existing Scene selected (Enhanced Scene or Old Scene): the new Enhanced Scene will be a copy of the selected one

If only a subset of the Assembly is selected, the Enhanced Scene will contain only the selected products and their 
components. Regardless of the level of the selected products, the branches leading back to the Assembly root will be 
displayed in the Enhanced Scene tree and all representations in the branches will appear in the Enhanced Scene.

 

2.  Click the Enhanced Scene icon . 

The  Scene dialog box appears. 
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3.  To define the name of the Enhanced Scene, clear the Automatic naming check box to deselect it and enter the name in the 

Name text-entry field. 

 
Note: Automatic naming enables you to automatically attribute names to Enhanced Scenes of the form Scene.1, Scene.2, 

Scene.3, etc. (The automatic naming mechanism is National-Language Supported.)

4.  To define the Overload Mode, click the Partial radio button or click the Full radio button. 

 
Overload Mode Partial: The scene will only overload attributes for a few products and  modifications to the main assembly of 

those attributes not overloaded in the scene will impact the scene. Overload Mode Partial favors performance as long as 

you don't overload too many attributes. An Enhanced Scene created with Overload Mode Partial will be indicated in the 

specification tree by the symbol . 

 
Overload Mode Full: All attributes supported for overloading of each element of the assembly (under the products selected at 

scene  creation) will be overloaded by the scene. Products overloaded by the scene will henceforth not be impacted by 

modifications to the main assembly regarding attributes supported for overloading. Overload Mode Full favors Enhanced 

Scene independence from the Assembly. An Enhanced Scene created with Overload Mode Full will be indicated in the 

specification tree by the symbol . 

 
For more information, see Overload Modes in Enhanced Scenes.

Once the scene is created, it is not possible to change the overload mode; nevertheless, it is possible to create a new 
Enhanced Scene from an existing Enhanced Scene and to affect a different overload mode to the new Enhanced Scene at its 
creation. 

 
5.  Click OK to validate. 

The Enhanced Scene is created. 

 
The Enhanced Scene appears. A background (the color of which you define in the Tools  >  Options  >  DMU  >  DMU Navigator 

settings)  indicates that you are now in Enhanced Scene context. The DMU Scenes toolbar appears.
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 Applicative Data in Enhanced Scene Context 
 

If the Assembly from which the Enhanced Scene was created had an Applicative Data container, this container will also be available in 
the Enhanced Scene. You will be able, therefore, to modify the existing applicative data and to create new applicative data.

 

Enhanced Scene Contextual Menu 
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The Enhanced Scene contextual menu is composed of the following commands:

 

Contextual Menu Entry Action

Definition activates the Enhanced Scene

Check Position
highlights all components for which the position attribute is different from the 
corresponding Assembly position attribute (see Checking Component Position)

Save Viewpoint
overloads the viewpoint attribute with the current viewpoint (see Saving a 
Viewpoint in New Scene Context)

Exit Scene exits the Enhanced Scene and return to Assembly context

Apply Scene on Assembly
applies the overloaded attributes of the Enhanced Scene context on the 
Assembly (see Applying a Enhanced Scene Context to an Assembly)

Apply Assembly on Scene 
applies the attributes of the Assembly context on the New Scene (see 
Applying an Assembly Context to a Enhanced Scene)

In Assembly context, the available commands are:

●     Definition

●     Apply Scene on Assembly

●     Apply Assembly on Scene

In Enhanced Scene context, when right-clicking an inactive Enhanced Scene, the available command is:

●     Definition 

In Enhanced Scene context, when right-clicking the active Enhanced Scene, the available commands are:

●     Definition 

●     Apply Scene on Assembly

●     Apply Assembly on Scene

●     Check Position

●     Save Viewpoint

●     Exit Scene 
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Generating an Enhanced Scene from an Old Scene 

 

There is currently no formal process for automatically converting Old Scenes to  Enhanced Scenes. The available solution consists of 
selecting the Old Scene in the specification tree and then creating an Enhanced Scene.  
 

You have created an Old Scene in which you've modified one or more attributes (e.g. you've modified the color of one of the components 
and you've modified the viewpoint of the Old Scene). 
 
 

1.  Open the GardenaScene.CATProduct.

2.  In the Specification Tree, select the Old Scene.

3.  Click the Enhanced Scene icon  and create the Enhanced Scene with the name and overload mode of your choice (see 

Creating an Enhanced Scene). 

Once created, the Enhanced Scene will be displayed and its state (the value of all possibly overloaded attributes) will be the 

same as that of the Old Scene from which it was created.

  

If you have chosen Overload Mode Partial, each attribute in the Enhanced Scene which is different from the corresponding attribute in 
the Assembly will now be considered overloaded.

The Old Scene will not be destroyed.

The Old Scene and the Enhanced Scene will be independent one from the other. 
 
Scripts can be written using VBScript for generating Enhanced Scenes from Old Scenes.
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Browsing Enhanced Scenes using the Scenes Browser 

 

You can browse your Enhanced Scenes visually using the Scenes Browser. Appropriate customization of the Scenes Browser settings 
enables you to:
●     activate a scene by simply double-clicking its image

●     apply a scene to the assembly by simply double-clicking its image 
 

1.  Click the Scenes Browser icon . 

The Scenes Browser appears. An image representation of all defined Enhanced Scenes associated to the current Assembly will 

be found in the Scenes Browser. 
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2.  To change to a list display of the Enhanced Scenes, click the Display List icon . 

The Enhanced Scenes are now displayed in list format. 

 

 
Customizing double-click behavior in the Scenes Browser

3.  In the Scenes Browser, click the Customize button. 
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4.  Check the radio button corresponding to the desired double-click behavior:

●     double-clicking will activate the Enhanced Scene

●     double-clicking will apply the whole Enhanced Scene to the Assembly

●     double-clicking will apply the user-defined attributes (see Automating Enhanced Scene Context Application Using User-
defined Attributes)

5.  Click OK to validate.

Implementing the chosen behavior (Activating an Enhanced Scene or Applying an Enhanced 
Scene to the Assembly)

6.  In the Scenes Browser, double-click the image of an Enhanced Scene to implement the chosen behavior.

The Enhanced Scene title associated to each image in the Scenes Browser also indicates whether the Enhanced Scene was created with 
overload mode Partial or Full.
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Activating an Enhanced Scene

 

An Enhanced Scene can be activated at any time by simply double-clicking its entry in the Specification Tree. 
 

 
1.  In the Specification Tree, expand the Applications node and then expand the Enhanced Scenes node. 

A list of all Enhanced Scenes will be displayed.

2.  In the Specification Tree, double-click the entry of the Enhanced Scene you wish to activate.  

The Enhanced Scene will be displayed. 

The background color will change to indicate that you are in Enhanced Scene context.

Even if you are working in Enhanced Scene context, you can activate a different Enhanced Scene by double-clicking its entry in the 
Specification Tree.

It is also possible to activate an Enhanced Scene by right-clicking it in the Specification Tree and selecting Scene.X object  >  
Definition in the contextual menu. 
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Exploding an Assembly 

You can explode a product in New Scene context without affecting the original product. 

You've created an Enhanced Scene. 

 
1.  Double-click Scene.1 either in the specification tree or in the geometry area. 

The context is changed to the Enhanced Scene context.

2.  Select Product.1 and click the Explode icon . 

The Explode dialog box appears. 

 

 
 
Note that if the assembly is assigned coincidence constraints (axis/axis, plane/plane), the Explode can take these constraints into account by use of the 

Explode type "Constrained". 

3.  Click the Apply button.

4.  Click the Exit Scene icon  to swap to Assembly context.

For more details about explode functionality, see the DMU Fitting Simulator User's Guide.
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Overloading Attributes in Enhanced Scene Context    

Overloading attributes enables you to declare independence for the attributes of selected products in an Enhanced Scene with respect to the attributes of 
the same products in the Assembly. The following attributes can be overloaded:
●     position

●     hide/show status

●     graphic properties

●     node activation

 
 Overload Mode Impact on Component Positioning 

 

In Overload Mode Partial, repositioning a product in Enhanced Scene context will implicitly overload the position attribute. However, if a modification was 
first made to the product position in the Assembly, the position would be modified correspondingly in the Enhanced Scene since the position attribute would 
not have been overloaded. 

 
 

1.  Either in the specification tree or in the geometry area, select the products for which you wish to overload an attribute. 

The selected components are highlighted in both the specification tree and the geometry area.

2.  To overload the position attributes of the selected products, click the Overload Positions icon . 

The position attributes of the selected products are now considered overloaded and will be independent from positioning modifications to the Assembly.

 

3.  To overload the hide/show status of the selected products, click the Overload Hide - Show icon . 

The hide/show attributes of the selected products are now considered overloaded and will be independent from hide/show status modifications to the Assembly.

4.  To overload the graphic properties of the selected products, click the Overload Graphic icon . 

The graphic attributes of the selected products are now considered overloaded and will be independent from graphic properties modifications to the Assembly.

5.  To overload the node activation of the selected products, click the Overload Node Activation icon . 

The node activation attributes of the selected products are now considered overloaded and will be independent from node activation modifications to the 

Assembly.

 
When you overload the position attribute using this command:
●     all child product position attributes will also be overloaded 

●     all ancestor product position attributes will also be overloaded

When you use move a product in Enhanced Scene context:

●     the moved product's position attribute will be overloaded

●     all ancestor product position attributes will also be overloaded

 
After you have overloaded different attributes of an Enhanced Scene, you can still modify the overloading of those attributes. See Managing Attributes Overloads.
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Managing Attributes Overloads 

 

When performing a design review, a user might create many scenes in order to study different variants of the mock-up. Sometimes a user might modify 
some attributes in the scene and then prefer to remove some of those modifications. Sometimes a user might want to save the current graphic properties 
or activation status in the scene without modifying them.

The ability to modify the attributes overloaded in the scene enables you to perform such scenarios.  
 
This functionality is only available for scenes in overload mode Partial.

 
1.  Double-click Scene.1 in the specification tree to activate the Enhanced Scene.

2.  In the specification tree, right-click Scene.1 in the specification tree and select Scene.1 object  >  Manage Attributes Overloads in the contextual menu. 

The Manage Attributes Overloads dialog box appears. 

 

3.  Click the OK button to close the dialog box.

4.  Modify one of the properties that is not yet indicated as overloaded, e.g. modify the graphic property Color for the product NOZZLE1.

5.  Re-open the Manage Attributes Overloads dialog box as in step 2 above. 

The graphic property for NOZZLE1 will now be indicated as overloaded. 

 

 
 

6.  To remove the overload, in the Products Selection area, select NOZZLE1 and in the Attributes Management area, click the Graphic checkbox. 

In the table, the corresponding X has now become the string Remove. 
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7.  To overload an attribute that is not yet considered overloaded (e.g. the Graphic attribute for the component BODY2), select the BODY2 line and check 

the Graphic checkbox. 

In the table, the corresponding attribute is now marked Overload. 

 

8.  Click the OK button to validate the modifications. 

The Graphic properties previously overloaded for NOZZLE1 are no longer considered to be overloaded. 

The modifications are immediately visible in the geometry area of the scene if you are in scene context.

You can customize the list of attribute types displayed in the Manage Attributes Overloads dialog box:
●     click the Customize button

●     check attribute types that you wish to be displayed

●     uncheck attribute types that you do not wish to be displayed

●     click the OK button to validate

 
You can also use the contextual menu to toggle the attribute overload state by right-clicking in the Manage Attributes Overloads dialog box. Note that 
the proposed actions in the contextual menu are a function of the current attribute overload states.

●     When overloading position or graphic properties using the Manage Attributes Overloads dialog box, the initial value of the parameter values are 
the corresponding values for the assembly. Attribute values for the components can then be modified at any time in scene context.

●     A typical scenario of overloading position, graphical properties might be: the user wants to capture in his scene the current values for position / 
graphical properties, so that if they are modified outside the scene, the scene itself is not impacted. It is similar to a full scene limited to some 
attributes. Overload position is identical to the command overload position.

●     When overloading position of a child product component, its parents are automatically overloaded (same behavior as when using the compass or 
move command: the branch becomes flexible). The Manage Attributes Overloads dialog box is updated accordingly. 

●     When removing position overload from a parent product component, its children will no longer be overloaded from a position point of view. The 
Manage Attributes Overloads dialog box is updated accordingly. 
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Adding, Replacing and Deleting Components in the Assembly

This task shows you how an Enhanced Scene is affected when you add, replace and delete components in the Assembly. 
 

The Add, Replace and Delete functionalities are not available in Enhanced Scene context, only in Assembly context. 
 

Insert the following sample model files in the cfyug samples folder:
●     ATOMIZER 

●     BODY1 

●     BODY2 

●     LOCK 

●     REGULATOR 

●     TRIGGER 

●     VALVE

●     REGULATION_COMMAND 

 

1.  Click the Enhanced Scene icon  and create an Enhanced Scene.

You are now in a scene window. 
The background color has turned to green and Scene.1 is added in the specification tree.

2.  Click the Exit Scene icon  to swap to the main window. 

You return to Assembly context.

Adding Components in the Assembly
In Overload Mode Full, components added in Assembly context will have not appear in the Enhanced Scene.

In Overload Mode Partial, the behavior will be as described below.
You will now add the NOZZLE:

3.  Right-click Product1 in the specification tree and select Components  >  Existing Component. 

4.  Shift-select NOZZLE1.model and NOZZLE2.model and then click Open. 

The added components (NOZZLE_1 _2 and NOZZLE_1_2) are identified in the specification tree and added in the geometry area. 

5.  In the specification tree, double-click Scene.1 to swap to the Enhanced Scene context. 

The newly-added components will appear in the specification tree and in the geometry area, assuming that, when they were added in the Assembly, they were 

added under the node that was selected for the creation of the Enhanced Scene. Otherwise, they will not appear.
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 For example, given the following Assembly configuration, 

if you created an Enhanced Scene that contained only product P1 and you add a product under product P1 in the Assembly, then the added product will 
appear under P1 in the Enhanced Scene. However, if you add a product under the Root in the Assembly, it will not appear in the Enhanced Scene. 

6.  Click the Exit Scene icon  to return to Assembly context.

Replacing Components in the Assembly

7.  Replace, for example, the BODY1 in the Assembly with the BODY2.model (right-click BODY1 in the specification tree, select Components  >  Replace 

Component from the contextual menu, then, in the File Selection dialog box, select BODY2.model and click Open.)

The Assembly is updated accordingly. 

8.  Double-click Scene.1 in the specification tree to enter the scene. 

Scene.1 has been updated in the same manner as the Assembly, assuming that Scene.1  is in Overload Mode Partial and that the replaced component was 

previously defined in  the Enhanced Scene.

Note: If the Enhanced Scene is in Overload Mode Full, the replacing component will appear in the product structure but will be deactivated.

 

9.  Click the Exit Scene icon  to return to Assembly context.

 

Deleting Components from the Assembly

10.  Delete, for example, the BODY2 from the Assembly (right-click it in the specification tree and select Delete from the contextual menu.) 

The Assembly is updated accordingly. 

11.  Double-click Scene.1 to enter the Enhanced Scene. 

Scene.1 has been updated in the same manner as the Assembly, assuming that the deleted product was previously visible in the Enhanced Scene.
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Checking Component Position 

 

This task shows you how to reset and check component position.

You've created an Enhanced Scene in which you've modified the position attributes. 

 
1.  Double-click Scene.1 either in the specification tree or in the geometry area. 

The context is changed to the Enhanced Scene context. 

2.  In the specification tree, right-click Scene.1 and select Scene.1 object  >  Check Position.  

All moved items are highlighted in the specification tree and in the geometry area.

 

To reset the position of the moved items, see Applying an Assembly Context to an Enhanced Scene.
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Saving a Viewpoint in Enhanced Scene  Context 

 

This task shows you how to save a viewpoint in Enhanced Scene context. 

You've created an Enhanced Scene. 

 
1.  Modify the viewpoint of the Enhanced Scene.

2.  In the Enhanced Scenes toolbar, click the Save Viewpoint icon .

3.  Click the Exit Scene icon  to return to the initial document window. 

You return to the main window.

4.  Double-click Scene.1 either in the specification tree or in the geometry area to swap to the scene window. 

The viewpoint you saved is now taken into account in the Enhanced Scene.
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Creating an Enhanced Scene Macro

 

If you perform a task repeatedly, you can take advantage of the macro mechanism to automate it. A macro is a series of functions, 
written in a scripting language, that you group in a single command in order to perform the requested task automatically. 

This task will show you how to create an Enhanced Scene macro.  
 

You stored your recorded macros in a text format file. For more detailed information about macros, see Recording, Running and editing 
Macros in the Infrastructure User's Guide.

 
 Here is an example of an Enhanced Scene macro in which you create a Enhanced Scene:

' COPYRIGHT DASSAULT SYSTEMES 2003 
Option Explicit 

' **************************************** ************** 
' Purpose: Create two new scenes. 
' Assumptions: A CATProduct document should be active. 
' Languages: VBScript 
' Locales: English  
' CATIA Level: V5R12 
' ******************************************************* 

Sub CATMain() 

' Get the root of the CATProduct 
Dim RootProduct As Product 
Set RootProduct = CATIA.ActiveDocument.Product 

' Retrieve the ProductScenes collection 
Dim TheScenes As ProductScenes 
Set TheScenes = RootProduct.GetTechnologicalObject("ScenesCollection") 

' Create a FULL product-scene on Root-Product 
Dim xProducts1(0) 
Set xProducts1(0) = RootProduct  
Dim oScene1 As ProductScene 
Set oScene1 = TheScenes.AddProductSceneFull ("", xProducts1) 

' Create a PARTIAL product-scene on Root-Product with "PartialScene" persistent name 
Dim xProducts2(0) 
Dim oScene2 As ProductScene 
Set oScene2 = TheScenes.AddProductScenePartial ("PartialScene", xProducts2) 

End Sub

 

●     Create the scene launches the scene creation.

●     Scene1 corresponds to the to-be-created scene.

●     RootProduct corresponds to Product1.
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Applying an Enhanced Scene Context  to an Assembly 

 

The command Apply Scene to Assembly enables you to reset the values of selected attributes of the Assembly with the values of the corresponding 
overloaded attributes in the Enhanced Scene. 
 

You've created an Enhanced Scene in which you've modified at least one of the following:
●     component position

●     component hide / show status 

●     component graphical properties

●     component activation status 

 

●     Enhanced Scene creation always uses the Assembly as the reference. Therefore, the command Apply Scene on Assembly will affect all of the Enhanced 
Scenes with Overload Mode Partial that have not overloaded the attributes corresponding to those that will be updated in the Assembly. 

●     Given that in an Enhanced Scene context the assembly is seen as flexible, applying positions of an Enhanced Scene to an Assembly will make this 
assembly flexible as well. 
 

1.  Double-click Scene.1 in the specification tree to activate the Enhanced Scene.

2.  Click the Apply Scene on Assembly icon . 

The Apply Scene.1 on Assembly dialog box is displayed. 

All differences between the Assembly and the Enhanced Scene are indicated by an "X" in the dialog box.

You can also access the Apply Scene on Assembly command by right-clicking Scene.1 in the specification tree and selecting Scene.1 object  >  Apply on 
Assembly in the contextual menu. 
 

 

3.  Select the products for which you wish to apply modifications. 

The rows corresponding to the products will be highlighted.  

In the Attributes management area, the attribute types that could potentially be applied as a function of the selected products will be un-grayed 

(in the above example, only the Position attribute has been modified for the selected products, so only the Position attribute type has been un-

grayed).

4.  In the Attributes management area, click the attribute types of the modifications you wish to apply. 

The entry in the table of the corresponding modification will change from "X" to "Apply".
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5.  Click OK to validate.

Using the Contextual Menu

You can use the contextual menu to:

●     select all product rows or to unselect all product rows

●     designate selected attributes as "Apply" or "X" (Do not apply)

As an example:

●     in step 3 above you would still select the product rows manually

●     in step 4 above you would right-click the selection, which would display the following contextual menu (because only position attributes are potentially 
applicable from the Enhanced Scene onto the Assembly):

●     you would select Apply Position (or Apply All) to designate the selected attributes to be applied:
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Customizing Displayed Attributes

You can customize the list of attribute types displayed in the Attributes management area:

●     click the Customize button

●     deselect the attribute types you don't wish to appear in the list

●     click OK to validate
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Applying an Assembly Context to an  Enhanced Scene 

The command Apply Assembly on Scene enables you to reset the values of selected overloaded attributes in the Enhanced Scene with the values of the 
corresponding attributes in the Assembly. 
 

You've created an Enhanced Scene in which you've modified at least one of the following:
●     component position

●     component hide / show status 

●     component graphical properties

●     component activation status 

 

1.  Double-click Scene.1 in specification tree to activate the Enhanced Scene. 

2.  Click the Apply Assembly on Scene icon . 

The Apply main assembly on Scene.1 dialog box is displayed. 

All differences between the Assembly and the Enhanced Scene are indicated by an "X" in the dialog box.

You can also access the Apply Scene on Assembly command by right-clicking Scene.1 in the specification tree and selecting Scene.1 object  >  Apply on 
Scene in the contextual menu. 
 

 

3.  Select the products for which you wish to apply  modifications. 

The rows corresponding to the products will be highlighted.  

In the Attributes management area, the attribute types that could potentially be applied as a function of the selected products will be un-grayed 

(in the above example, only the Position attribute has been modified for the selected products, so only the Position attribute type has been un-

grayed).

4.  In the Attributes management area, click the attribute types of the modifications you wish to apply. 

The entry in the table of the corresponding modification will change from "X" to "Apply" or vice-versa. 
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5.  Click OK to validate.

You can use the contextual menu to:
●     select all product rows or to unselect all product rows

●     designate selected attributes as "Apply" or "X" (Do not apply)

As an example:

●     in step 3 above you would still select the product rows manually

●     in step 4 above you would right-click the selection, which would display the following contextual menu (because only position attributes are potentially 
applicable from the Assembly onto the Enhanced Scene):

●     you would select Apply Position (or Apply All) to designate the selected attributes to be applied:
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You can customize the list of attribute types displayed in the Attributes management area:
●     click the Customize button

●     deselect the attribute types you don't wish to appear in the list

●     click OK to validate
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Automating Enhanced Scene Context Application Using User-
defined Attributes

 

This command enables you to streamline the application of an Enhanced Scene context to an Assembly by allowing you to pre-define those attributes that 
you would like to apply by default and then allowing you to apply those attributes from a contextual menu. 

You've created an Enhanced Scene in which you've modified at least one of the following:
●     component position

●     component hide / show status 

●     component graphical properties

●     component activation status 

 

Enhanced Scene creation always uses the Assembly as the reference. Therefore, the command Apply Scene on Assembly will affect all of the Enhanced 
Scenes with Overload Mode Partial that have not overloaded the attributes corresponding to those that will be updated in the Assembly.  
 

1.  In the specification tree, right-click Scene.1 and select Scene.1 object  >  Set User Defined Attributes... in the contextual menu.

 

2.  Select the products for which you wish to apply modifications. 

The rows corresponding to the products will be highlighted.  

In the Attributes management area, the attribute types that could potentially be applied as a function of the selected products will be un-grayed (in the 

above example, only the Position attribute has been modified for the selected products, so only the Position attribute type has been un-grayed).

3.  In the Attributes management area, click the attribute types of the modifications you wish to apply. 

The entry in the table of the corresponding modification will change from "X" to "Lock".

 

4.  Click OK to validate.

●     The use of the contextual menu is the same as in Applying an Enhanced Scene Context to an Assembly.

●     The customization of displayed attributes in the dialog box is the same as in Applying an Enhanced Scene Context to an Assembly.

The contextual menu command Set User Defined Attributes... is license specific. 
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Saving an Enhanced Scene in ENOVIAVPM

Enhanced Scenes can be saved in ENOVIAVPM, but only in the context of a DMU Review. See Saving DMU Applicative Data in 
ENOVIAVPM in the DMU Navigator User's Guide. 
 
The Enhanced Scenes saved in ENOVIAVPM cannot be used in a drafting scenario: it is not possible to create a drawing with a view from 
this scene. 
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Exiting Enhanced Scene Context 

 

You can exit Enhanced Scene context and return to Assembly context at any time. 
 

 

1.  In Enhanced Scenes toolbar, click the Exit Scene icon . 

You exit the Enhanced Scene context. 

You will now be back in Assembly context.

All modifications to your Enhanced Scenes are implicitly persistent, with the exception of viewpoint modification (see Saving a Viewpoint 
in Enhanced Scene Context).

If you hide the Enhanced Scenes toolbar, you will automatically exit Enhanced Scene context.
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Spatial Query

 

About Spatial Query : Click the icon, make your reference selection and set other options in the Proximity Query 
dialog box then click Apply. If desired, hide the products found. Note: the query is run on activated shape 
representations only.

Running a Proximity Query: Click the icon, make your reference selection and set other options in the Proximity 
Query dialog box then click Apply. Note: the query can be run on products inserted without shape 
representations. If desired, activate shape representations of products found.

Running a Proximity Query on a Large Assembly: Click the icon, make your reference selection and set other 
options in the Proximity Query dialog box then click Apply. Note: the query can be run on products inserted 
without shape representations. If desired, activate shape representations of products found.

Running a Zone Query: Click the icon, make your reference selection and set other options in the Proximity 
Query dialog box then click Apply. Note: the query can be run on products inserted without shape 
representations. If desired, activate shape representations of products found.
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About Spatial Query

Large assemblies can be complex, consisting of many products and sub-products. You can simplify a complex assembly by displaying only those products 
you want to work with. Spatial Query lets you do just that. 
 

How it works

The proximity query calculation is not based on the representation visualized in your session. Rather, it is based on a cubic representation of each part, the 
size of the cubes of which is designated by the accuracy parameter. Because of the way in which the detection algorithm is designed, the real distance 
between two parts in the visual representation could be greater than the clearance parameter you specify, yet the two parts could be sufficiently close as to 
be considered neighbors. An increase of the clearance value can be due to:

the cubic representation of the parts:  maximum increase=2*accuracy*sqrt(3)

the positioning error: maximum increase=0.5*accuracy*sqrt(3)

the clearance value transformed into cubes: maximum increase= accuracy*sqrt(3)

The sum of above three deltas gives a maximum increase= 3.5*accuracy*sqrt(3).

In the example below, the proximity query was made using an accuracy parameter=30mm and a clearance parameter=0 mm, yet two parts separated by 
a distance of ~46 mm were considered to be touching, therefore neighbors.

 

Cache Management and Accuracy: 
Setting an accuracy determines the size of the cubes used to represent the products in the calculation. For larger products, a lower setting will result in a 
slower computation time but a more precise result. 

Clicking  opposite Accuracy gives you access to the Cache Management and Accuracy dialog box which tells you how much cache is used, lets you free 
the cache, and if you have a DMU Navigator license only, will calculate the cache required for an accuracy setting you enter. 

 
Clearance: 
Setting a clearance defines an area around the reference selection within which all nearby products or outside of which all far away products are returned by 
the query depending on the Products to Select option chosen. 
What About Released Accuracy? 
 
The default value for released accuracy is 20mm. 
This value can also be defined by the administrator. 
 
How does the administrator define the release accuracy value?
●     he sets a precise and required value in the release Accuracy field.  

(see  Tools > Options > Digital Mockup > DMU Navigator > Spatial Query) 

●     then runs CATDMUUtility batch process without defining - vox  option, the release accuracy value is taken into account. The data is pre-tessellated.  

●     you as user can select this value checking the Release accuracy option when performing proximity query
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You can combine the Spatial Query command with other DMU commands, for example Comparing Products (in the DMU Space Analysis toolbar). 
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Running a Proximity Query

Large assemblies can be complex, consisting of many products and sub-products. You can simplify a complex assembly by displaying only 
those products you want to work with. Proximity Query lets you do just that. 
 

Insert all the GARDENA model documents from the cfysm samples folder:

GARDENAATOMIZER.model 
GARDENABODY12.model 
GARDENABODY22.model 
GARDENALOCK.model 
GARDENANOZZLE12.model 
GARDENA_NOZZLE22.model 
GARDENAREGULATOR.model 
GARDENA_REGULATION_COMMAND.model 
GARDENATRIGGER.model 
GARDENAVALVE.model 

 
1.  In the DMU Review Navigation toolbar, click the Spatial Query icon  .

The Spatial Query dialog box is displayed:
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A Filter option enables you to filter out certain elements from the query result: 
●     Shown products only: if checked, the no show products will not be taken into account

●     Activated products only: if checked, the inactivated products will not be taken into account

2.  Select one of the products you want to be the reference for the query, e.g. GARDENALOCK.1 .

3.  Set the accuracy by entering a value, e.g. 3mm.

Note: You can check the Released accuracy option to use pre-calculated data (from the Cache directory).

4.  Check the Far away products only option.

5.  Click Search. 

The results display in the Result list. Note that you can deselect products in the Result list using Crtl + Select.

As you use the Search and fill the Result list, your local cache will be filling up. At any time, you can click the Accuracy three points button 
to access the Cache Management and Accuracy dialog box.

To free the cache, click the Free total cache button.
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6.  Click Select to select the products listed in the Result list. 

The products found are highlighted both in the specification tree and geometry area:
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7.  Hide the products found.

You can now work with a simplified product.

 It is now possible to recuperate the initial product selection.

Click the Selection three points button.

The Input products dialog box appears. 
The listed selection corresponds to those products you selected before you executed a search.
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●     While the Input products dialog box is active, you can change the selection in your session and the listed selection in the Input 
products dialog box will be correspondingly modified .

●     Likewise, if you change the selection in the Input products dialog box, the selection in your session will be correspondingly modified.

●     You can check the Preview checkbox to see a preview of your product selection.
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Running a Proximity Query on a Large Assembly

Large assemblies can be complex, consisting of many products and sub-products. You can simplify a complex assembly by displaying only those products 
you want to work with. Proximity Query lets you do just that. 
 
This task shows how to run a proximity query based on components inserted without associated shape representations. You load the product structure only. 
 

1.  Make sure you work with the cache system on. To activate the cache system, see Activating the Cache.
2.  Make sure shape representations are deactivated before inserting your files. For this:

●     Select Tools > Options from the menu bar. 
The Options dialog box is displayed.

●     Expand the Infrastructure category in the left-hand tree.

●     Click the Product Visualization tab.

●     In the Representation field, check the Do not activate default shapes on open option.

●     Click OK to confirm your operation.

 

3.  Insert all the DEMO_CGE_CHAINSAW*.cgr documents from the cfyug samples folder.

 

1.  Click the Spatial Query icon . 

The Spatial Query dialog box appears: 
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2.  Select one of the products you want to be the reference for the query, e.g.  DEMO_CGE_CHAINSAW_BODY_FILTER

(DEMO_CGE_CHAINSAW_BODY_FILTER.1).

 

3.  Set the Clearance by entering a value. In our example, we will keep the default value of 0mm. 

4.  Set the Accuracy by entering 50mm, for example.
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5.  Keep the Nearby products including selection option set.

6.  Click Search. 

The result is displayed in the Result list. The products found are highlighted  in the specification tree. 

 

7.  Click Select to keep the selection of the products listed in the Result list and to close the Spatial Query dialog box. 

8.  To activate the shape representations of the items, right-click the highlighted items in the specification tree and select Representations  >  Activate Node .
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This is what you obtain: 
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Now you can work with a simplified product.
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Running a Zone Query

 

Whereas a proximity query enables you to find all of the neighbors of a chosen part, a zone query enables you to find all of the 
parts included within a designated bounding box. 
 

Insert all the GARDENA model documents from the cfysm samples folder:

GARDENAATOMIZER.model 
GARDENABODY12.model 
GARDENABODY22.model 
GARDENALOCK.model 
GARDENANOZZLE12.model 
GARDENA_NOZZLE22.model 
GARDENAREGULATOR.model 
GARDENA_REGULATION_COMMAND.model 
GARDENATRIGGER.model 
GARDENAVALVE.model 

 
1.  In the DMU Review Navigation toolbar, click the Spatial Query icon . 

The Spatial Query dialog box is displayed:
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A Filter option enables you to filter out certain elements from the query result: 
●     Shown products only: if checked, the no show products will not be taken into account

●     Activated products only: if checked, the inactivated products will not be taken into account
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2.  Click the Zone Query tab.

A bounding box appears surrounding the model.

 

 
The bounding box has two kinds of manipulators: 

●     the edges of the bounding box (depicted by dotted lines) enable you to translate  the bounding box 

●     the corners of the bounding box (depicted by solid lines) enable you to resize the bounding box 

 

3.  To translate the bounding box, move the mouse over one of the bounding box's edges. 

A double-headed green arrow appears along the selected edge, indicating the directions in which you can translate the 

bounding box.
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4.  Click and drag in the desired direction.

The bounding box is translated accordingly.  

  

5.  To resize the bounding box, move the mouse over one of the bounding box's corners.

A double-headed green arrow appears along the selected corner, indicating the directions in which you can resize the 

bounding box.

3D Insight Version 5 Release 19 Page 614 of 1379



 

6.  Click and drag in the desired direction.

The bounding box is resized accordingly. 

 

7.  Using any combination of translates and resizes, define the bounding box you wish to apply for your zone query.
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8.  In the Spatial Query dialog box, define which products you wish to select (only products completely included within the 

bounding box or products either completely included within or partially included within) by clicking the corresponding 

Products to select radio button.
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9.  Click the Search button to launch the query. 

The result is displayed in the Result zone of the dialog box.

10.  To keep the selection, click the Select button.
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11.  To keep only the selected parts in the show space, in the Specification Tree, right-click the selection and choose 

Selection Mode  >  Others in the contextual menu, then send this selection to the hide space by selecting Views  >  

Hide / Show  >  Hide / Show.

You can now work with a simplified product.
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In the Result list, you can deselect products you do not need using Crtl + Select. 

A Filter option enables you to filter out certain elements from the query result: 

●     Shown products only: if checked, the no show products will not be taken into account

●     Activated products only: if checked, the inactivated products will not be taken into account
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3D XML Compatibility with V6

This task explains compatibility rules when you open 3D XML files in R19 that were generated in 3DLive or V6.

The document in session will be saved as a 3D XML file with the indicated name according to the 
policies documented below:
●     General R19/3DLive model mapping general policy

●     Open / Insert 3D XML file generated by 3DLive 2008-1 

●     Open / Insert 3D XML file generated by 3DLive or V6 2009 

 
 

General R19/3DLive model mapping general policy

The following is an overview of the mapping policy used for the exchange of 3D XML files between R19 and 
3DLive. 

●     For each presentation, a Slide is created with a copy of every pointed object (except scenes). Information of 
the last-pointed scene (if there is one) is copied inside the Slide. Presentation information is also captured 
inside the Slide.

●     For each non-last-pointed scene, an empty slide with the scene information gets created.

●     Every non-pointed object (which is not a scene) gets created in a default slide.

Open / Insert 3D XML file generated by 3DLive in R2008-1

The DMU applicative data created in 3DLive will be reloaded in R19 with some changes:

●     Review
�❍     For each Review, a Review is created in R19.

●     Slide
�❍     For each slide, a Scene and a Presentation pointing this Scene are created.

�❍     Default Scenes and default Presentations can be created: even if there is no product structure overloading 
in a 3DLive Slide, an empty Scene is created is the corresponding Review in R19. For the same reason, a 
Presentation pointing to every object inside the Review is also created.

●     Close-Up
�❍     For each Close-Up, a Review is created in R19. This Review points the Scene corresponding to the Slide 

containing the Close-Up, and the objects pointed by the Close-Up.

�❍     If the Close-Up points to an external applicative data (as the result of a "Copy/paste as link" operation), 
then in R19, the pointed applicative data is duplicated in the Review.

●     Annotated View (2D Annotation)
�❍     If the Annotated View is in a Slide, the corresponding Annotated View and the Presentation and the Scene 

corresponding to the Slide are created in a Review. The Presentation points the Annotated View.

�❍     If the Annotated View is in a Close-Up, the corresponding Annotated View and a copy of the Scene 
corresponding to the Slide are created in a Review. 

�❍     Graphical properties of Markers contained in Annotated View are preserved.

�❍     The Spline Line Marker, Surfacic Marker, Arrow Bent Marker, Arrow Circular Marker and Picture Marker in 
an Annotated View are lost.
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●     Animation
�❍     An Animation is converted into a Replay of the same name.

�❍     Viewpoint animation in Animation is preserved.

�❍     Product positioning information in Animation is preserved.

�❍     Product color information in Animation is preserved.

�❍     Product opacity information in Animation is preserved.

�❍     Product visibility information in Animation is preserved.

Examples 

 Save in 3DLive Open in R19

Example 1 Review 1
●     Slide 1

�❍     2D annotation 1

Review 1
●     Presentation 1, points 2D annotation 1 

and Scene.1

●     2D annotation 1

●     Scene 1

Open / Insert 3D XML file generated by 3DLive or V6 in 
R2009

Important: Only DMU applicative data visible in a Slide (i.e. Show/Hide) can be reopened in R19. All data which 
are not visible in a Slide (including data only visible in the R2009 Review In-work state) will not be visible in the 
R19 data structure.

The DMU applicative data created in 3DLive or V6 will be reloaded in R19 with some changes:

●     Review
�❍     For each Review, a Review is created in R19.

●     Slide
�❍     For each slide, a Scene and a Presentation pointing this Scene are created.

�❍     Default Scenes and default Presentations can be created: even if there is no product structure overloading 
in a V6 Slide, an empty Scene is created is the corresponding Review in R19. For the same reason, a 
Presentation pointing to every object inside the Review is also created.

●     Annotated View (2D Annotation)
�❍     If there are 2D Markers in a Slide, an Annotated View containing the Markers and the Presentation and the 

Scene corresponding to the Slide are created in a Review. The Presentation points the Annotated View.

�❍     Graphical properties of 2D Markers are preserved.

�❍     The Spline Line Marker, Surfacic Marker, Arrow Bent Marker, Arrow Circular Marker and Picture Marker are 
lost.

●     Animation
�❍     An Animation is converted into a Replay of the same name.

�❍     Viewpoint animation in Animation is preserved.

�❍     Product positioning information in Animation is preserved.

�❍     Product color information in Animation is preserved.

�❍     Product opacity information in Animation is preserved.
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�❍     Product visibility information in Animation is preserved.

Examples 

 Save in V6 Open in R19

Example 1 Review 1
●     Slide 1

�❍     2D Marker 1

Review 1
●     Presentation 1, points 2D Annotated 

View 1 and Scene.1

●     2D Annotated View 1
�❍     2D Marker 1

●     Scene 1
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DMU 2D Workshop  

 

The Digital Mock-up 2D workshop enables you to: 
●     insert 2D documents

●     manipulate 2D documents (translate, zoom, rotate)

●     create annotated views

●     manage annotated views

●     export and import annotated views

●     compare 2D documents of the following type: 

●     cgm format (CATIA, ENOVIA-DMU Navigator)

●     CATDrawing format (ENOVIA-DMU Navigator only)

●     V4 model (ENOVIA-DMU Navigator only)

●     dxf/dwg format (ENOVIA-DMU Navigator only)

●     measure distance, angle and radius on 2D documents

●     save and print image captures

 
Some functionalities will not be available depending upon the type of document you open in the 2D Workshop.
●     The insert, manipulate and annotated views functionalities are not available when the document opened in 

the 2D Workshop is of the following document types: 

●     raster (bmp, tiff, jpeg, etc.)

●     cdd

●     model

●     CATDrawing

●     It is recommended that you not use the Open in New Window command in the DMU 2D Viewer.

 
The Print command will by default print the viewer content.
●     In Display mode, the viewer content is printed as is.

●     In Whole document mode, the viewer content is printed as if the entire document were visible in the viewer 
(equivalent to the Fit All In command). 
 

The tiff multi-page format is not supported.
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Entering the 2D Workshop: In the menu bar, select File  > Open , select a document and click Open button. 

Inserting 2D Documents: Click the icon. In the File Selection dialog box, select a file and click the Open button.

Manipulating 2D Documents: Click the document (the manipulators appear). To translate, press Left Mouse 
Button and drag. To zoom, click one of the corner manipulators (little squares) and drag. To rotate, click one of 
the arrow manipulators and drag.

Creating an Annotated View: Click the icon. Using the DMU 2D Marker toolbar, create your annotations (lines, 
circles, rectangles, text, etc.). Click the Exit icon.

Managing Annotated Views: Click the icon. In the Annotated Views dialog box, double-click the View you wish to 
re-invoke.

 
Exporting and Importing 2D Annotations: Click icon. Define file name to export or import. Click save button.

 Comparing Drawings: Open a drawing and click the Compare Drawing icon. Select the drawing you want to 
compare with the reference, the second drawing is opened and compared with the first one.

Measuring Distance, Angle and Radius on 2D Documents: Click the 2D Measure icon, calibrate, then make your 
measure.

 Publishing 2D Documents: Click the icon. Identify the path where you want to save the report as well as the 
report name then click Save.

Saving and Printing Image Captures In the menu bar, select Tools  >  Image  >  Capture.

Saving a 2D Document In the menu bar, select File  >  Save As. Click the selection button, select a file type and 
click OK to validate.

 

Overlaying 2D Drawings: Open a .model document, click the Browse button in the Overlay dialog box, select 
documents and click Open.
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Entering the 2D Workshop

To enter the 2D Workshop, you can either open a 2D document, which will switch you into the 2D Workshop.  
 

 You can now invoke the 2D Workshop from the Start menu, which will open an empty 2D  document, by selecting Start  >  DMU 2D Workshop 
in the menu bar.

You can also invoke the 2D Workshop by selecting File  >  New in the menu bar and then selecting cgm from the List of Types in the New 
dialog box. 
 

 
1.  Select File  > Open and open Comparedrawings1.cgm from the samples folder. 

You enter the 2D Workshop and the selected drawing is displayed.

  

2.  In the menu bar, select File  >  Close to close this document.

3.  To enter the 2D Workshop with an empty document as a departure point, in the menu bar, select Start  >  DMU 2D Workshop or 

select File  >  New and then select cgm from the List of Types in the New dialog box. 

You enter the 2D Workshop and an empty 2D drawing is displayed.
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Inserting 2D Documents 

 

The Insert 2D Document command enables you to load a 2D document into the current session. 

It is also possible to insert multiple documents. 

Only drawing elements in the associated sheet will appear in the cgm document that is opened in the viewer. 
 

 

 

1.  In the DMU 2D Tools toolbar, click the Insert 2D Document icon  . 

The Insert Document dialog box appears. 

  

2.  Select the CompleteDrawing.cgm file from samples folder and click the Open button.

The document is loaded into your session. 

You can insert multiple 2D documents of the following types: 
●     cgm

●     dxf, dwg (DMU Navigator only)

●     GL, GL2

●     HPGL

●     CATDrawing (DMU Navigator only)

●     V4 Drawing (.model) (DMU Navigator only)

 

 

 

3D Insight Version 5 Release 19 Page 626 of 1379



Manipulating 2D Drawings 

 

You can  translate, zoom and rotate your 2D documents.

You've opened CompleteDrawing.cgm from the samples folder.

 

1.  To translate, click the document and drag. 

 
2.  To stretch the document, click one of the square manipulators and drag.

3.  To zoom, press the middle mouse button, then click the left mouse button and drag upward to zoom in, downward to zoom out.

4.  To rotate, in the 2D Move toolbar, click the Rotate icon , then click one of the round manipulators and drag.

 
The number of degrees that you've rotated the drawing is interactively displayed as you rotate, just near the manipulator you chose 

to rotate the document.
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Translating and Rotating using the 2D Move dialog box

It is now possible to translate and rotate a 2D document via a dialog box based on the coordinates relative to the loaded document's origin point. 

1.  Click the Move icon  in the DMU 2D Move toolbar.

The 2D Move dialog box appears.

 

Note that clicking the Apply button will apply the values that you enter, clicking the OK button or hitting the Enter key will close the 
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dialog box. 

2.  To translate, in the Coordinates section of the dialog box, enter a new value in the Along X text-entry field and / or a new value in the 

Along Y text-entry field and click the Apply button.

The new coordinates are applied relative to the loaded document's origin point. 

3.  To translate relative to the current values defined in the Coordinates values, in the Increments section of the dialog box, enter a new 

value in the dX text-entry field and / or a new value in the Along dY text-entry field and click the Apply button.

The new coordinates are applied relative to the previously defined coordinate values. The new coordinate values relative to the loaded 

document's origin point now appear in the Coordinates values. 

4.  To rotate, in the Coordinates section of the dialog box, enter a new value in the Angle text-entry field and click the Apply button.

The new coordinates are applied relative to the loaded document's origin point. 

5.  To translate relative to the current angle defined in the Coordinates values, in the Increments section of the dialog box, enter a new 

value in the dRot text-entry field and click the Apply button.

The new angle is applied relative to the previously defined angle value. The new angle value relative to the loaded document's origin 

point now appears in the Coordinates values. 
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Creating an Annotated View

 

You create an annotated view by: 
●     invoking the dedicated toolbar

●     creating the desired annotations 

●     exiting the dedicated toolbar 

 

1.  In the DMU 2D Tools toolbar, click the Create an Annotated View icon . 

The DMU 2D Marker toolbar appears. 

 

2.  To create a line annotation, click the Draw Line icon  and drag a straight line in the 2D document from one endpoint to the other of 

the line you wish to create. 

3.  To create a free-line annotation, click the Draw Free Line icon  and drag freely in the 2D document along the path of the line you 

wish to create. 

4.  To create a circle annotation, click the Circle icon  and drag a straight line in the 2D document from the point that will be the center 

of the circle you wish to create to a point that will be on the circle's circumference. 

5.  To create an arrow annotation, click the Arrow icon  and drag a straight line in the 2D document from one endpoint to the other of 

the arrow you wish to create (the arrow's head will appear at the terminal point of the line you drag). 

6.  To create a rectangle annotation, click the Rectangle icon   and drag a straight  line in the 2D document whose endpoints will 

designate the diagonal of the rectangle you wish to create. 

7.  To create a text annotation, click the Text icon  and click in the 2D document at the point at which you wish to insert the text. 

The Annotation Text dialog box and the Text Properties toolbar appear: 
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●     Enter the desired text in the 2D text box and click Apply.

●     Change the size and style of annotation text if desired and click Apply. 

●     When done click OK.

The text is added at the designated point. The size of the text displayed on the screen is dependent on the current zoom factor.

8.  To insert a picture annotation, click the Picture icon   and click in the 2D document at the point at which you wish to insert the 

picture. 

The Select Picture File dialog box appears. 

●     Browse to the desired images folder.

●     Select the desired document from the images folder and click OK.

 

The picture is inserted at the designated point. 
For more details, see Adding Pictures. 

9.  To create an audio annotation, click the Audio icon   . 

The Select audio File dialog box is displayed. 

●     Browse to the desired  folder.

●     Give a meaningful name to the to-be recorded file and click Open. 
The Audio attributes dialog box and Audio Recorder dialog boxes appear.

●     Select the audio quality and click OK.

●     To start recording, in the Audio Recorder dialog box , click the red button.

●     To stop recording, click the stop button.

●     When done recording, click OK. 

●     To replay the audio annotation, click the Audio icon and click the Play button in the Audio Recorder dialog box.

For more details, see Adding  Audio Markers. 

10.  To erase all annotations, click the Erase icon   . 

11.  To exit your annotated view, click the Exit Annotated View icon  . 

An new annotated view is created. 

You can access all previously created annotated views by hitting the Manage Annotated Views icon  . See Managing 

Annotated Views. 
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Managing Annotated Views

 

At any time, you can access the different annotated views you've associated to your 2D document.  

Open the CompleteDrawing.cgm from the samples folder. 
You've already created one or more annotated views. 

 

 

1.  In the DMU 2D Tools toolbar, click the Manage Annotated Views icon  .

The Annotated Views dialog box appears. 

 

2.  Double-click the view you wish to work with.

The chosen view becomes the active view. All of the annotations that you previously created in that view will be visible. 
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Exporting and Importing 2D Annotations

 

You can export your 2D annotations to other users in an XML file. Likewise, you can import 2D annotations that other users have sent you. 

 
You have opened a 2D document and created an annotated view. 

 
To export 2D annotations

  

1.  In the DMU 2D Annotations toolbar, click the Import icon  .   

The Annotated Views file export dialog box appears. 

2.  Browse to the folder in which you wish to save the xml file containing the annotations.

3.  In the File name text-entry field, enter the name of the file.

4.  Click the Save button.

 

 

To import 2D annotations

 

1.  In the DMU 2D Annotations toolbar, click the Import icon  .   

The Annotated Views file import dialog box appears. 
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2.  Browse to the folder from which you wish to import an xml file containing  annotations.

3.  Select the desired file and click the Open button. 

The annotated view contained in the xml file will be added to the annotated views listed in the Specification Tree.
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Comparing Drawings

 

The Digital Mock-up 2D workshop lets you run a 2D comparison on the following document types: 
●     in ENOVIA:

�❍     cgm format 

�❍     CATDrawing format 

�❍     V4 model 

�❍     dxf/dwg format 

�❍     raster formats (bmp, jpg, tiff, rgb, pcx, etc.)

●     in CATIA:
�❍     cgm format 

�❍     raster formats (bmp, jpg, tiff, rgb, pcx, etc.)

This task explains how to compare two versions of the same drawing to highlight the differences and check for changes.

You can now compare and calibrate raster drawings. 
You can now compare vectorial drawings using resizing and offset values.

You can compare raster drawings using resizing and offset values. Calibration by superimposing option requires some line or axis 
selection in drawing. Superimposing option is disabled for raster drawings as Raster drawings can not be divided into separate 
entities like line.

The Compare Drawings window is pixel based even for input vector based formats like CGM. The precision of the comparison 
depends on the size of the window and the current zoom. 
You can now modify the colors used when comparing vectorial drawings.

●     Raster drawings of excessively large size (e.g. 100 megabytes) might not be able to be compared due to memory management 
limitations.

●     Compare of two CATdrawings may give some unexpected result due to some text property.  

Open the Comparedrawings1.cgm from the samples folder.

 

 

1.  Select File  > Open and open Comparedrawings1.cgm. 

The Digital Mock-up 2D workshop is opened and displays the selected drawing. This is the reference to which the second 

drawing will be compared.
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2.  Click the Compare Drawing  icon in the DMU 2D Tools toolbar. 

The Select Drawing dialog box appears letting you choose the drawing you want to compare with the reference drawing.

3.  Select the drawing you want to compare, for example Comparedrawings2.cgm and click Open.

The second drawing is opened and compared to the first. 
The Compare Drawing dialog box appears. Selected drawings are identified in the dialog box.
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Color coding: 
●     Elements in drawing 1 only appear in red

●     Elements in drawing 2 only appear in green

●     Elements common to both drawings appear in blue

These colors can be modified: 

●     click the corresponding selection button of the color you wish to modify 

●     choose a color from the proposed list

Note: Colors cannot be modified for raster format drawings.

4.  Click appropriate options in the dialog box to visualize drawing 1 or drawing 2 only, or to compare drawings.

5.  (Optional) Click Calibrate to align drawings for easier comparison. In our example, this is not necessary.

Note: You need to return to the Compare Drawing option before calibrating.

The Calibrate dialog box appears. 
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To calibrate by superimposing: 
●     Click the Calibration by superimposing radio button.

●     Select a reference line or axis in one of the drawings.

●     Select a line or axis in the other drawing that you want aligned to the reference.

●     Click Reverse to change the direction.

●     Click OK.

The two drawings are aligned as defined.
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To calibrate by resizing:

●     Click the Calibration by resizing radio button.

●     Modify the width and height of the drawings as desired.

●     Click OK.

The two drawings are resized as defined.
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To calibrate by offset:

●     Click the Calibration by resizing radio button.

●     Enter offset values for the X-axis and the Y-axis.

●     Click OK.

Drawing 2 is offset as designated.
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If you use File > Print... command when Compare Drawings window is active, Display and Selection options can be 

used as Print Area in the Print dialog box.

6.  Click Close in the Compare Drawing dialog box when done.
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Measuring Distance, Angle and Radius on 2D Documents

 This task explains how to measure distances, angles and radii on 2D documents of both vector  and pixel type.

Note: In the No Show space, this command is not accessible. 
 
 

1.  Select File > Open and open a 2D document. The Digital Mock-Up 2D workshop appears and displays the selected 

document. You can measure distance, angle and radius on documents in vector formats such as cgm, hpgl as well as in 

raster formats such as jpeg, bmp. 

For more information about:
�❍     2D documents you can open, see Inserting Components in the DMU Navigator User's Guide.

�❍     DMU 2D workshop, see the DMU Navigator User's Guide.

2.   Click 2D Measure  in the DMU 2D Tools toolbar.The 2D Measure dialog box appears.   

An automatic calibration, based on the width of the drawing, is proposed for vector type documents. The dialog box 
opens directly in the Measure mode. 

3.  Click Calibration to visualize the reference distance (green arrow) and adjust the calibration if necessary. 

All measures will be made with respect to this reference. For pixel type documents, calibrating is necessary to make 

measures and the dialog box appears in the Calibration mode.

�❍     To calibrate, click two points to define the reference, then enter a distance in the Calibration field.

�❍     Click the Measure check box to make your measure.

Note:The appearance of the cursor has changed to assist you. A number also helps you identify where you are in your 
measure or calibration.
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Angle and arc measure cursor:

Calibration and distance measure cursor:

 

4.  Set the desired Measure type in the Measure type drop-down list box.

Defining Measure Types

�❍     Distance: measures the distance between two points.

�❍     Angle: measures the angle defined by three points.

�❍     Arc: measures the angle and radius of an arc fitted through three points.

5.   Click to define the points between which the measure is made.

The dialog box is updated and gives the appropriate information depending on the type of measure made. The cursor 
snaps to vector elements in vector-type documents.

6.  Click Close when done. 

The calibration value and reference distance are stored in memory and are re-proposed if you enter the command again 
whilst in the same document.
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Publishing 2D Documents

 

You can publish the results of your annotated views and your comparisons between documents using the Start Publish  icon in the DMU 2D 

Tools toolbar. All publishing commands, except the VRML link command, are available. 

 
 

1.  In the DMU 2D Tools toolbar, click the Start Publish icon  . 

 

For details on using the Publish functionality, see Publishing.  
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Saving and Printing Image Captures

 

You can save and print image captures of your 2D documents. This enables you to save and eventually communicate your annotated views and 
your comparisons between 2D documents to other users. 

 
1.  In the menu bar, select Tools  >  Image  >  Capture. 

 

The Capture toolbar appears. 

 

  

2.  To save in pixel format, click Pixel Mode   and then click Save As  .

3.  To save in vectorial format, click Vectorial Mode    and then click  Save As  .

4.  To print your 2D document, click Print  .

For detailed information on using the Capture toolbar, including the save and print functionalities, see Capturing and Managing Images for the 
Album in the  Infrastructure User's Guide.
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Saving a 2D Document

 

 You can save 2d documents in any of the following formats:
●     cgm

●     gl

●     gl2

●     hpgl 

You must have opened a 2d document. See Entering the 2D Workshop.

 
1.  In the menu bar, select File  >  Save As. 

The File Selection dialog box appears.

2.  Optionally modify the name of the document.

3.  Click OK to validate. 

The file is saved. 

Note: The file can only be saved with the same file type as the opened document.
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Overlaying 2D Drawings 

 

In the 2D Workshop, you can now overlay the Draft of one or more models on a 2D documents.  

This functionality is only available when working with the drafts of .model documents.

You've opened AUXVIEW2.model from the samples folder.

1.  In the menu bar, select View  >  Add 2D Overlay .  

The 2DOverlay dialog box is displayed.
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2.  To overlay documents, in the 2DOverlay dialog box, click the BrowseFile button.  

The FileBox dialog box appears.

 

3.  Select one or more models and click the Open button. 

The drafts of the selected documents will overlay the original document. The selected documents now appear in the 2DOverlay dialog 

box.
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4.  To remove overlays, in the 2D Overlay dialog box, select the documents of which the overlays are to be removed and click the 

Remove button.

The draft of the selected document is removed. 
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DMU Review 

 

 About DMU Review

Creating a Review Select product root, in DMU Review Creation toolbar, click Create Review icon.

 Activating a Review Double-click the Review to activate or right-click the Review and select Review Activated 
from the contextual menu.

Creating a Child Review Click Create Review icon or right-click the review under which you wish to create a child 
review and select Create Child Review from the contextual menu.

 Creating Applicative Data in a Review Activate the Review in which to create applicative data, create the 
applicative data. 

Reordering DMU Reviews and Associated Applicative Data Click the Applicative Entities Reordering icon and 
reorder using the dialog box icons.

Viewing Review Content Double-click the Review.

 Activating a Parent Review Right-click review for which to activate the parent, select Activate Parent Review 
from contextual menu.

Copying Applicative Data Select applicative data to copy, right-click it and select Copy in contextual menu.

 Copying a Review Right-click Review you wish to copy, select Copy in the contextual menu. Right-click Review 
to which to copy and select Paste in the contextual menu.
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About DMU Review

 

The objective of the DMU Review is to optimize the DMU Navigator solution in terms of industrial processes for the following tasks:
●     Design Review processes (preparation, presentation and conferencing)

●     Management Follow-up processes (design validation)

The DMU Review can be seen as folder in which applicative data can be organized any way you want (e.g. by process). 

The DMU Review is linked to a product structure and only has meaning in the context of that product structure. It can contain: 

●     a hierarchy of Reviews 

●     applicative data at any level of the Review hierarchy 

  
Applicative data that can be created in a DMU Review 
●     3D Annotation 

●     Annotated View 

●     Camera 

●     Color Action 

●     Distance 

●     Environment (box, sphere, cylinder) 

●     Experiment 

●     Group 

●     Hyperlink 

●     Inertia 

●     Interference 

●     Light 

●     Measure 

●     Replay 

●     Section 

●     Sequence 

●     Shooting

●     Shuttle 

●     Simulation 

●     Track 

●     Visibility Action 

 
Guidelines

The number DMU Reviews you can create is unlimited.

The user explicitly activates a DMU Review and all subsequent actions (create applicative data, create DMU Review) will be in the context of the 
activated Review. 

If a DMU Review is activated, its applicative data as well as the applicative data of its parent DMU Reviews are displayed and can be accessed.

Applicative data can only reference applicative data contained in the same DMU Review or in an ancestor DMU Review. There is no restriction to 
the amount of applicative data that can be created in a DMU Review.

It is possible to copy/paste or cut/paste applicative data from the Applications node to a DMU Review and from a DMU Review to the applicative 
data containers under the Applications node.

It is also possible to copy/paste a DMU Review to another DMU Review. It will then appear as a child of the target DMU Review. 
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You cannot copy a review to the product node or to the application node, you can only copy it to another review. Likewise, you cannot copy a 
review to another product. For the functionality enabling you to import applicative data from one product to another, see Importing Applicative 
Data. 
 

 
VBScript support

Scripts can be written using VBScript for DMU Review processes.
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Creating a Review 

 

You begin creating a review hierarchy by creating reviews at the product root level. 

 

1.  In the DMU Review Creation toolbar, click the Review icon . 

A review is created. 

If no DMU Review is activated, the DMU Review will be created at the product root level.
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Activating a Review

 

You activate a review in order that it be defined as the recipient of subsequent applicative data you will create.

 
1.  Double-click the Review you wish to activate or right-click the Review and select Review Activated from the contextual menu.

The Review will now be activated, which you can verify by right-clicking it and noticing the checkmark next to the Review Activated 

status.
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Creating a Child Review

 

You can create any number of children reviews for a given review.  
The number of levels in your review hierarchy is unlimited.

You must first activate the review under which you wish to create a child review. See Activating a Review.

 

1.  Click the Review icon  or right-click the review under which you wish to create a child review and select Create Child Review 

from the contextual menu.

A child review is created.
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Creating Applicative Data in a Review

 

You can create applicative data of the following types in a review. (See About DMU Review for an exhaustive 
list). 
 
 

1.  Activate the Review in which you wish to create applicative data. (See Activating a Review).

2.  Create the applicative data.  

The applicative data is inserted in the activated Review.
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Reordering DMU Reviews and Associated  Applicative 
Data 

 

Reordering DMU Reviews and associated applicative data enables you to manually reorder DMU Reviews as well as 
their associated applicative data entities.  
 
For more details on reordering applicative data, see Reordering Applicative Data.

 Scripts for applicative data reordering can be written using VBScript. 
 

 
1.  Given the following configuration of DMU Reviews, double-click the  

DMU Review.1.1 review to activate it.  

 

2.  Click Applicative Entities Reordering . 

The Applicative Entities Reordering dialog box appears.  
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3.  To reorder applicative data entities, click the selection button and choose Reviews from the proposed list.

4.  You can now reorder sub-reviews of DMU Review.1.1 as in steps 4 through 7 above.

5.  To reorder applicative data entities, click the selection button and choose Entities from the proposed list. 
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You can now reorder entities of DMU Review.1.1 as in steps 4 through 7 above.

You can only reorder one level of reviews and applicative data at a time based upon the activated review.

You cannot reorder the reviews at the Product level.

 For a list of applicative data that can be imported, see the list of applicative data that can be inserted in a DMU 
Review in About DMU Review.
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Viewing Review Content

 

You can activate reviews to view their content. 

 
1.  Double-click DMUReview.1 . 

The Review folder is opened and expanded. 

All application data associated to the activated Review will be visible.

The applicative data of the parent DMU Reviews will also be displayed.

 

 

3D Insight Version 5 Release 19 Page 662 of 1379



Activating a Parent Review 

 

You activate a parent review in order that it be defined as the recipient of subsequent applicative data you will create.

 
1.  Right-click the review for which you wish to activate the parent and select Activate Parent Review from the contextual menu.

The Parent Review will now be activated, which you can verify by right-clicking it and noticing the checkmark next to the Review 

Activated status.

 

The Activate Parent Review command will only be available for an activated Review.
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Copying Applicative Data 

 

You can copy applicative data from one review to another. 
You can also copy applicative data that is independent of a review (under Applications in the specification tree) into a review

 
1.  Select the applicative data you wish to copy, right-click it and select Copy in the contextual menu.

2.  Right-click the Review to which you wish to copy the applicative data and select Paste in the contextual menu.

The applicative data is copied accordingly. 

 

 

 

When you copy applicative data, all applicative data referenced by the copied data will likewise be copied to the destination Review.
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Copying a Review

 

You can copy a review to another review. The copied review will then be a child review of the review to which it was copied. 
 

You cannot copy a review to the product node or to the application node, you can only copy it to another review. Likewise, you cannot copy a 
review to another product. For the functionality enabling you to import applicative data from one product to another, see Importing Applicative 
Data. 
 

 
1.  Right-click the Review you wish to copy and select Copy in the contextual menu.

2.  Right-click the Review to which you wish to copy the first Review and select Paste in the contextual menu.

The review is copied accordingly.
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DMU Presentation 

 

 About Presentations: Provides detailed information about Presentations.

Creating a Presentation: Activate a DMU Review, click the Presentation icon, modify the Presentation name as 
desired, in the Specification Tree, click the different applicative data items that you wish to be part of the 
Presentation, click OK to confirm creation.

 Opening a Presentation: In the Specification Tree, double-click the Presentation or right-click the Presentation 
and select Presentation. object  >  Definition from the contextual menu.

 Previewing a Presentation: In the Presentation dialog box, click the Show Preview checkbox.

Reordering Applicative Data Entities for a Presentation: In the Presentation dialog box, to move an entity up, 
select the entity and click the Move up icon. To move an entity down, select the entity and click the Move down 
icon. To swap positions of two entities, select the entity you wish to swap, click the Swap icon, then select the 
entity with which you wish to swap the first entity. 

 Modifying Visualization Settings for a Presentation: In the Presentation dialog box, click the Visualization tab 
and modify settings as desired.

Browsing Presentations: In the DMU Review Navigation toolbar, click the Presentations Browser icon, to activate 
a Presentation, double-click its representation or navigate from Presentation to Presentation using the player 
buttons.
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About Presentations 

 

The DMU Presentation enables an efficient review of issues on a mock-up by displaying the right level of information at the right time. A DMU 
Presentation can concurrently activate a list of applicative data entities combined with chosen visualization effects. You can easily navigate among 
your presentations using an intuitive browser, thus enabling you to coherently present the analysis performed on the mock-up during a design 
review meeting. 

 

Selecting and Organizing Applicative Data
●     A DMU Presentation can point to multiple applicative data entities. These applicative data entities will be displayed in the main viewer when 

you browse the DMU Presentations.

●     A DMU Presentation can only be created in a DMU Review (DMU Presentation creation in the Application node is not supported). 

●     It can point to DMU applicative data belonging to the current DMU Review or to the parent DMU reviews. 

●     A DMU Review can contain as many DMU Presentations as needed. 

Applicative Data Managed by a DMU Presentation 
●     Annotated view and attached 2D markers

●     3D Text

●     Hyperlinks

●     Group

●     Measure

●     Section

●     Distance or band analysis

●     Light

●     Camera

●     Environment

●     Scene

 
  

Presentation Activation Rules

The DMU Presentation introduces a new notion of activation for applicative data. Activating applicative data from a DMU Presentation point of 
view is to make visible the information held by the entity. (This is different from the habitual activation rule, which enables you to edit the 
applicative  data.)

When activating/browsing a DMU Presentation, only the applicative data pointed to by the DMU Presentation are activated, all other applicative 
data are deactivated.

It might not be possible to activate simultaneously all of the applicative data associated to the DMU Presentation, e.g. two annotated views 
cannot be activated at the same time because they have two different viewpoints. 

Cumulative applicative data types

For the following applicative data types, activation is cumulative, i.e. all of the applicative data these types can be simultaneously activated:

●     3D Text

●     Hyperlinks

●     Group

●     Measure

●     Section

●     Distance or band analysis

●     Light
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●     Environment

Exclusive applicative data types

For the following applicative data types, activation is exclusive, i.e. only the last applicative data entity of these types can be activated at a 
given time,  plus it is possible that there will be conflicts between them:

●     Annotated view

●     Camera

●     Scene

Rules for the simultaneous activation of multiple DMU Applicative data

The last applicative data entry in the list will have priority. You can reorder the applicative data of a DMU Presentation in order that the desired 
applicative data will be activated when you activate the Presentation.

Example 1

Given the following list of applicative data associated to the DMU Presentation:

Group.1 
Group.2 
Measure.1 
Measure.2 
Camera.1 
Camera.2 
AnnotatedView.1 
AnnotatedView.2 
Scene.1 
Scene.2

the activated applicative data will be:

Group.1 
Group.2 (groups are cumulative) 
Measure.1 
Measure.2 (measures are cumulative) 
Scene.2  
(the viewpoint of the scene supercedes the viewpoints of the Camera.2 and AnnotatedView.2) 

Example 2

Given the following list of applicative data associated to the DMU Presentation:

Group.1 
Group.2 
Measure.1 
Measure.2 
Camera.2 
AnnotatedView.1 
Scene.1 
Scene.2 
AnnotatedView.2 
Camera.1

the activated applicative data will be:

Group.1 
Group.2 (groups are cumulative) 
Measure.1 
Measure.2 (measures are cumulative) 
Scene.2  
Camera.1  
(the viewpoint of the Camera.1 supercedes the viewpoint of the Scene.2 and AnnotatedView.2) 
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VBScript support

Scripts can be written using VBScript for DMU Presentation processes.

 

Known Limitations
●     Only one action is available per applicative data type 

●     Only a limited number of applicative data types are managed by the DMU Presentation

●     If a scene is contained in a DMU Presentation and if scene-related attributes are modified during the browse, then the scene itself is modified
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Creating a Presentation

 

Presentations are created in the context of a DMU Review. You can create as many Presentations per DMU Review as needed.

You must first activate the DMU Review under which you wish to create a presentation. See Activating a Review.

 
1.  Open the PresentationProduct.CATProduct sample.

2.  Activate DMU Review.1 .

3.  Click Presentation . 

The Presentation dialog box appears.

 

4.  In the Name text-entry field, modify the Presentation name to be Presentation.7.

5.  In the Specification Tree, click the different applicative data items (groups, annotations, section cuts, measures, etc.) that you wish to 

be part of the Presentation. 

The designated applicative data items are added to the Presentation.
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6.  To remove an applicative data item from of the content of your Presentation, click the item in the Object list and then click Remove 

.  

The item is removed from the Presentation.

7.  To confirm the Presentation content, click OK. 

The Presentation is created and the dialog box is closed.
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Opening a Presentation

 

You open a presentation in order to modify its content.

 
1.  In the Specification Tree, in the DMU Review.3, double-click the Presentation.5 or  right-click the 

Presentation.5 and select Presentation. object  >  Definition from the contextual menu.

The Presentation will be opened.  
The Presentation dialog box will appear with its current content.

2.  To open another Presentation, click the Name selection button and choose a Presentation from the 

proposed list. 

The designated Presentation will be opened.
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Previewing a Presentation

 

Previewing a presentation enables you to preview the DMU Presentation in the main window as it would be activated. The Presentation Preview is a two-
state button (i.e. the preview remains active / inactive until the button is clicked again to explicitly change the state). 
 
 

1.  Open Presentation.5 in DMU Review.3 if it is not already opened (see Opening a Presentation). 

The Presentation is opened.

2.  In the Presentation dialog box, click the Show Preview checkbox to activate the preview.  

The Presentation is activated in the main window.
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Reordering Applicative Data Entities for a Presentation

 

Reordering applicative data in a Presentation enables you to redefine the entities that will be retained when the 
Presentation is activated.  
 
 
The Presentation.5 in the DMU Review.3 has been opened.

The applicative data is ordered as follows:

 
1.  In the Presentation dialog box, select the Group.1 object and click the Move up icon . 

The Group.1 object is moved up to the second position. 

The View.1 object is swapped with the Group.1 object and is now in the third position. 

 

 
 

2.  In the Presentation dialog box, select the View.2 object and click the Move down icon . 

The View.2 object is moved down to the second position. 

The Group.1 object is swapped with the View.2 object and is now in the first position. 

 

 
 

3.  In the Presentation dialog box, select the View.1 object, click the Change Position icon  and 

then click the the Group.1 object (the object whose position you wish to give to View.1). 

The View.1 object is moved up to the first position. 
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The Group.1 and all objects beneath it are pushed downward one position. 

 

4.  Click Cancel to cancel these modifications. 

The Presentation is closed and the modified order of the applicative data will not be taken into account.
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Modifying Visualization Settings for a Presentation

 

You can modify the visualization settings for a Presentation to be different from those of the current DMU Navigator session viewer. Those 
settings that are modified for a Presentation will be persistent. At any time, you can apply the current session viewer settings to a Presentation. 

 
 

1.  Open the Presentation.5 in DMU Review.3 . 

The Presentation is opened.

2.  In the Presentation dialog box, click the Visualization tab. 

The Visualization page appears. 

By default, the visualization settings of a Presentation are those of the main window. 

 

 
 

3.  To activate modifications to the lighting settings, check the Lighting Activate checkbox and click the Lighting icon .  

See Setting Lighting Effects in the Infrastructure User's Guide.

4.  To activate modifications to the render style settings, check the Render Style Activate checkbox, click the Render Style icon  

and select the desired render style from the list of proposed styles.  

See Using Rendering Styles in the Infrastructure User's Guide.

5.  To activate viewpoint overloading, check the Viewpoint  checkbox and click either Perspective radio button or the Parallel radio 

button.

6.  To activate background overloading, check the Background checkbox, click the Background color selection button and choose the 

desired color from the proposed list. (If you wish the background color to be graduated, then click the Graduated color checkbox.

7.  To import the visualization settings from the main viewer, click the Import visualization values from main viewer icon . 

All visualization settings of the Presentation will now correspond to the current settings of the main viewer. 
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Customizing Presentation Visualization Settings

You can customize the visualization settings of a DMU Presentation. 
The following is a list of customizable settings:

●     Render Style

●     Wireframe

●     Dynamic hidden line removal

●     Shading

●     Shading with edges

●     Shading with edges and hidden edges

●     Edges point (customize View option)

●     Outlines (customize View option)

●     Hidden edges points (customize View option)

●     Materials (customize View option)

●     Facet (customize View option)

●     Transparent (customize View option)

●     Perspective mode

●     Parallel mode

●     DMU Lighting:

●     No Light

●     Single Lights

●     Two Lights

●     Neon Lights

●     Brightness

●     Contrast

●     Highlights
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Browsing Presentations 

 

The objective of the Presentations Brower is to enable you to skip from one presentation to another with very few interactions. The specification tree drives 
the natural browse of DMU Presentations. You can, of course, re-order Presentations to suit your needs using Reordering Applicative Data. (Note: A 
DMU Presentation can be set to NoShow. It will then not be taken into account during the browse.)

The DMU Presentations Browser has:

●     a thumbnail mode to enable you to better visualize the different DMU Presentations

●     a list mode to reduce size of the panel on the screen 

●     a player-like mode to facilitate the browse

All presentations of all DMU Reviews will be presented sequentially. The browse is not limited to the current DMU Review. 
 
In addition to the player buttons, you can use the keyboard arrows to navigate from one Presentation to another. 
 

 

1.  In the DMU Review Navigation toolbar, click the Presentations  Browser icon . 

The Presentations Browser appears. An image representation of all defined Presentations in all DMU Reviews will be presented in the Scenes Browser.

 
 

2.  To activate a Presentation, double-click its representation or use the player buttons to navigate to the Presentation of your choice or click the Name 

selection button and choose the desired Presentation from the drop-down list. 

The selected Presentation is activated and previewed. 

 
The ordering of the Presentations is based on their ordering in the Specification Tree. The player buttons will move you as follows: 

●     the forward button  will move you to the next Presentation in the list
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●     the backward button  will move you forward and backward in the list as expected. 

●     The fast forward button  will move you to the first Presentation of the next Review

●     the fast backward button  will move you to the first Presentation of the previous Review

Note: In addition to the player buttons, you can use the keyboard arrows to navigate from one Presentation to another. The 
correspondence between the keyboard buttons and the player buttons is as follows: 
 

Keyboard buttons Player buttons

Page up key

Page down key 

up key

down key         

3.  To display the Presentation representations in list form with smaller icons, click the Display list icon  (the above display is in Display list format).

4.  To re-display the Presentation representations in the original format with larger icons, click the Display icons icon . 
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5.  To edit the Presentation currently active in the Presentation Browser, click the Edit... button. 

The Presentation dialog box appears with the context of the corresponding Presentation. You can then create new applicative data that will be 

automatically added to the Presentation. When you finish modifying the Presentation, you return to the Presentation Browser. For more information on 

editing a Presentation, see Reordering Applicative Data Entities for a Presentation and Modifying Visualization Settings for a Presentation.

Note: When you edit a Presentation and create annotated views, the selection of an annotation can have two different objectives:

●     Add the annotation to the list of Presentation entities.

●     Move the annotation. 

In order to distinguish between the two, a new Manipulation Mode button has been added (near the top of the Presentation dialog box):

●     The Manipulation Mode button is green  by default. The annotation can be added to the list of Presentation entities.

●     Click the Manipulation Mode button. The button will now be orange . The annotation can be moved by dragging. 
 

The following is the list of available commands when editing a DMU Presentation from the Presentation Browser:

●     Annotated View 

●     3D Annotation 

●     Hyperlink 

●     Group 

●     Section 

●     Measure 

●     Arc through three points

●     Manage Annotated Views 

●     Graphic Message 

●     Camera 

●     Environment 

●     Light 

All the other commands will be grayed out.
 

6.  To collapse the Presentations Browser, click the Less<< button. 

The dialog box is collapsed. When browsing through large product structures that could have a correspondingly large number of associated Presentations, 

the collapsed dialog box enables you to gain space, yet enables you to continue browsing your Presentations.  

 

 
7.  Click the Close button to exit the Presentations Browser.
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The guiding principle of the ordering of the browse is that the Reviews of highest hierarchical level are considered to be more general and therefore it is 
desirable to see their associated Presentations before seeing the Presentations of more detailed Reviews. 

 
 

 
 
 

The Reviews and Presentations of the above example would be ordered as follows: 
 

Ordering of Presentations with associated Review  

(for buttons , )

 
Ordering of Presentations without consideration 

of  associated Review  

(for buttons ,  ) 

 

 
     Review 1 
       Presentation 11 
       Presentation 12 
     Review 1.1 
       Presentation 5 
       Presentation 6 
     Review 1.1.1 
       Presentation 1 
       Presentation 2 
     Review 1.1.2 
       Presentation 3 
       Presentation 4 
     Review 1.2 
       Presentation 9 
       Presentation 10 
     Review 1.2.1 
       Presentation 7 
       Presentation 8 
     Review 2 
       Presentation 13

     Presentation 11   
     Presentation 12   
     Presentation 5   
     Presentation 6   
     Presentation 1   
     Presentation 2   
     Presentation 3   
     Presentation 4   
     Presentation 9   
     Presentation 10 
     Presentation 7 
     Presentation 8 
     Presentation 13
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The buttons in the Browser dialog box enable you to do the following:

Button Action

move to previous Presentation 

move to next Presentation 

move to first Presentation of previous Review

move to first Presentation of next Review 

 

For example,

Start Apply Button Result

   

 Presentation 1  Presentation 6

 Presentation 9  Presentation 4

 Presentation 13  Presentation 8

 Presentation 10  Presentation 9

   

 Presentation 12  Presentation 5

 Presentation 10  Presentation 7

 Presentation 2  Presentation 3

 Presentation 5  Presentation 6

   

 Presentation 4  Presentation 1

 Presentation 9  Presentation 3

 Presentation 6  Presentation 11

 Presentation 5  Presentation 11

   

 Presentation 1  Presentation 3

 Presentation 10  Presentation 7

 Presentation 5  Presentation 1

 Presentation 6  Presentation 1
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Note the following:

●     The browser can be initialized by selecting a DMU Presentation in the specification tree. If no Presentation is selected, the first Presentation in the tree order 
will be the starting point. 

●     There is no cyclic behavior: when the last presentation is activated, buttons  and  are deactivated. 

●     While going from one Presentation to another, an animation of viewpoint can occur (if the viewpoint changes). This is the same as the present behavior when 
going from one camera to another. 
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Measuring

Measuring Distances and Angles between Geometrical Entities: Click the Measure Between icon, set the measure type 
and mode in the Measure Between dialog box, then select two entities

Measuring Properties: Click the Measure Item icon, then select an item

Measuring Inertia: Click the Measure Inertia icon, then select an item
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Measuring Between       ( )

The Measure Between command lets you measure distance between geometrical entities.  

You can measure:

●     Minimum distance and, if applicable angles, between points, surfaces, edges, vertices and entire products

●     Maximum distance between two surfaces, two volumes or a surface and a volume.

 This section deals with the following topics: 

 

●     Measuring Distances between Geometrical Entities

●     Measuring Minimum Distance and Angles

●     Measuring Maximum Distance

●     Measuring Distances in a Local Axis System

●     Customizing Measure Between

●     More about the Measure between dialog box

●     Sections and Measures

●     Editing Measures

●     Creating geometry from measure results

●     Measuring Angles

●     Updating measures

●     Using measures in Knowledgeware

●     Measure cursors

●     Restrictions

●     Measure Between and 3D XML 
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 Measure Between and 3D XML 

3D XML format is supported, which means you can:

●     open and/or insert a 3D XML document containing measure between results.

●     save as in 3D XML format a product containing measure between results.

Notes:  
 

●     The text properties (i.e.; color, font and size) for the  
Measure Between in 3D XML are not retained when you save in 3D XML.

●     The angle measured cannot be displayed in the geometry area.

●     Associativity is not retrieved in 3D XML, when reopening the 3D XML file, the re-created measure between is broken and 
thus non associative. Its icon in the specification tree is one of the non-associative measures.

●     When opening a 3DXML file note that the maximum distance between A and B and/or B and A measures are not retrieved 
with the correct value, i.e. the value is null. This limitation exists because exact geometry is required to retrieve maximum 
distance measures but the 3D XML only contains tessellated geometry.

 Refer to 3D XML section in Customizing Settings in the Infrastructure User's Guide for detailed information.

Restrictions 
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●     Neither Visualization Mode nor cgr files permit selection of individual vertices.

●     In the No Show space, the Measure Between , Measure Item  and Measure Inertia  commands are 

not accessible.

●     Measures performed on sheet metal features provide wrong results. In unfolded view, volume elements are not taken into 

account when measuring Part Bodies.

●     Measures are not associative when switching between folded view and unfolded view (using the Fold/Unfold icon  in 

the Sheet Metal toolbar).

●     When measuring in exact mode, bodies are not taken into account inside a Part (PartBody, Openbody).

●     Measure Item and Measure Inertia do not permit exact measurement neither on inserted CGR files (created from CATIA 

V4 models, CATParts) nor on geometry in visualization mode .  

For more information, see Working with CGRs in DMU.

●     You cannot perform measurements between within a product located in a CATAnalysis document in Product Editor 

workbench.

●     You cannot perform measure on elements from the Current Selection Window nor from the Group Preview Window.

●     The selection of sketcher entity from Specification tree is restricted, when the sketch is not in edition and when the 

calculation mode is Approximate. To measure any sketcher entity in Approximate calculation mode, it has to be selected 

from the 3D area.

●     Copy/Paste of individual parameters of a Measure is not permitted. However, this does 
not hold when a parameter of a Measure is selected along with another entity.
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Measuring Item ( )    

 

The Measure Item command lets you measure the properties associated to a selected item (points, edges, surfaces 

and entire products). 

This following topics are covered: 

 

●     Measuring properties

●     Measuring in a local axis system

●     Customizing Measure Item

●     Editing measures

●     Create Geometry from measure results

●     Updating measures

●     Using measures in knowledgeware 

also read Measures and Knowledge

●     Measure cursors

●     Surfaces and Volumes (precisions)

●     Measure Item and 3D XML

●     Restrictions
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Measuring Inertia ( )  

The Measure Inertia command lets you measure:

●     3D inertia properties of surfaces and volumes (explained below)

●     2D inertia properties of plane surfaces.

This section deals with the following topics: 

 

●     Measuring 3D inertia

●     Measuring 2D inertia 

●     Customizing your measure

●     Exporting measure inertia results

●     Creating geometry from measure results

●     Notations used

●     Inertia equivalents

●     Principal axes

●     Inertia matrix with respect to the origin O

●     Inertia matrix with respect to a point P

●     Inertia matrix with respect to an axis system

●     Moment of inertia about an axis

●     Updating measures

●     Using measures in Knowledgeware

●     Restrictions

Measuring 3D Inertia

This task explains how to measure the 3D inertia properties of an object. 

Details about Inertia Measurements: 
 

You can measure the 3D inertia properties of both surfaces and volumes, as well as retrieve the density or surface density if valuated from V4 model 

type documents. You can also retrieve inertia equivalents set in Knowledgeware formulas. 

●     The area, density, mass and volume (volumes only) of the object are calculated.

●     The center of gravity G is expressed in the global axis system, it is not possible to express this value in the local axis system.

●     The center of gravity of a surface is meaningful only as long as the center of gravity of the equivalent volume 

corresponding to the surface with a unitary thickness is considered. 

●     The center of gravity of a closed surface (thin skin) is different from the equivalent volume included in the surface.

●     When there is no material applied to the selected items, the center of gravity corresponds to a geometrical center of gravity. In this case, it is recommended 

to use the Measure item tool where it is possible to select a secondary axis system. Thus the center of gravity coordinates will be expressed in 

this secondary axis system.

Insert the Valve.cgr document from the samples folder. It is to be found in the online documentation file tree in the common functionalities sample folder 
cfysm/samples.
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1.  Click Measure Inertia . In DMU, you can also select Analyze > Measure Inertia from the menu bar. The Measure Inertia dialog box appears. 

 By default, 3D inertia properties are measured.

The Measure 2D Inertia icon lets you measure 2D inertia properties of plane surfaces.

Dialog box options 
 

�❍     A Keep Measure option in the dialog box lets you keep current and subsequent measures as features in the specification tree. Some measures kept as 

features are associative and can be used as parameters.

�❍     A Create Geometry option lets you create the center of gravity and the axis system for principal axes in a part from inertia results.

�❍     An Export option lets you write results to a text file.

�❍     A Customize... option lets you define what will be computed and displayed in the dialog box.

In the Drafting workbench, the Keep Measure option is not available. Measures are done on-the-fly. They are not persistent. This means that they are 

not associative and cannot be used as parameters.

Note: When you move the cursor over the geometry or specification tree, its appearance changes to reflect the measure command you are in 

2.  Click to select the desired item in the specification tree, for example Valve. 

Selecting Items

In the geometry area, you can select individual faces and edges on cgr files and in Visualization mode. 
 

To... Then 

make a multiple selection Shift-click in the specification tree

add other items to the initial selection Ctrl-click in the geometry area or the specification tree

select items using the bounding outline Drag (using the left mouse button)

make your multiple selection.(P2 only) Use the Group command

Notes:

�❍     Only items of the same type can be included in a multiple selection or a bounding outline; you cannot mix volumes and 
surfaces.

�❍     Inertia measures made on a multiple selection of items are not associative.

Dialog Box

The Dialog Box expands to display the results for the selected item.  

The measure is made on the selection, geometry, assembly or part. To measure the inertia of individual sub-products making up an assembly and 

see the results in the document window, you must select the desired sub-product. 

 
In our example, the item selected has no sub-products. 
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The dialog box identifies the selected item and indicates whether the calculation is exact or approximate:  

 

�❍     In Design mode, measures (bounding box excluded) access exact data and wherever possible true values are given. Note that it is possible to 

obtain an exact measure for most items in design mode.

�❍     In Visualization mode, measures are made on tessellated items and approximate values are given.

In addition to the center of gravity G, the principal moments of inertia M and the matrix of inertia calculated with respect to the center of gravity, 

the dialog box also gives the area, volume (volumes only), density and mass of the selected item.

You can also compute and display the principal axes A. To do so, you must first activate the appropriate option in the Measure Inertia Customization 

dialog box.

The density is that of the material, if any, applied to a product, part or part body:

�❍     If no density is found, a default value (1000 kg/m3 for volumes and 10 kg/m2 for surfaces) is displayed.  

You can, if desired, edit this value to re-calculate all the other inertia values and display them in the dialog box. Note: re-calculated inertia 

values are not stored in the measure feature.

�❍     If sub-products or part bodies have different densities, the wording Not uniform is displayed in the Inertia Dialog Box and the Density parameter 

will have the value as -1 in the Specification tree.

To make sure, you retrieve the density on any possible selection (surface and / or volume), you must select the item (part or part body) in 

the specification tree and not in the geometry area.

Notes: 

 

�❍     The bounding box calculation accuracy depends on the one used for tessellation (SAG) on objects. This is set in the Performances tab 
page in Tools > Options > General > Display.  
By default, this value is set to 0.2 mm.

�❍     You can access the density of parts saved as CGR files and opened in visualization mode. This functionality is available in both a part and 

a product context. 

�❍     To do so:

■     Select the Save density in cgr option in the Cgr Management tab (Tools > Options > Infrastructure > Product Structure).

■     Open a part to which material has been applied and save as CGR type. 
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The density is stored in the CGR file.

 
Important: The material must be applied to the part node. If materials are applied to part bodies, no density is saved. 

3.  Close the Part document.

4.  Open the CGR file or switch to DMU Space Analysis and insert the part saved as CGR, then measure the inertia.

5.  You must be in design mode to access the density of part bodies to which materials have been applied.

6.  Unless specified otherwise, material inheritance is taken into account.

7.  Density is a measure of an item's mass per unit volume expressed in kg/m3; surface density is a measure of an item's mass per unit area 

expressed in kg/m2.

 
 

The number of decimal places, the display of trailing zeros and limits for exponential notation is controlled by the Units tab in the Options 

dialog box (Tools > Options, General  > Parameters and Measure).

Elements placed in No Show are taken into account in measure operation.

Geometry area

In the Geometry Area, axes of inertia are highlighted and a bounding box parallel to the axes and bounding the selected item also appears. 

Color coding of axes:

�❍     Red: axis corresponding to the first moment M1

�❍     Green: axis corresponding to the second moment M2

�❍     Blue: axis corresponding to third moment M3.

8.  Click Customize...  to customize the inertia computation and define what will be exported to the text file.

9.  Click OK when done.

10.  If you checked the Keep Measure option in the Measure Inertia dialog box, your measures are kept as features and your specification tree will look something 

like this.
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Some measures kept as features are associative and can be used as parameters.

 

Notes: 

●     You can write a macro script to automate your task. See Space Analysis on the Automation Documentation Home Page.

●     In interactive and automation modes (using CATScript), the inertia computation is always performed on the whole body. The ‘Only Main Body’ option 

from mechanical properties is not taken into account.

 

Customizing Your Measure

1.  Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dialog box opens.

Notes: 

�❍     The inertia properties check boxes selected here are also the properties exported to a text file.

�❍     You can, at any time, define what will be computed and displayed in the Measure Inertia dialog box.

2.  Click the appropriate options to compute and display in appropriate tabs of the Measure Inertia dialog box the:
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�❍     Inertia equivalents

�❍     Principal axes

�❍     Inertia matrix with respect to the origin O

�❍     Inertia matrix with respect to a point P

�❍     Inertia matrix with respect to an axis system

�❍     Moment of inertia about an axis

3.  Click Apply or OK in the Measure Inertia Customization dialog box when done.

 

 

Restrictions 
 
●     In the Drafting workbench, the Keep Measure option is not available. Measures are done on-the-fly. They are not persistent. This means that they are 

not associative and cannot be used as parameters.

●     You cannot measure inertia properties of either wire frame or infinite elements. 

For examples showing 3D inertia properties measured on surfaces.  

To find out more about notations used.

●     Measures performed on sheet metal features provide wrong results. In unfolded view, volume elements are not taken into account when measuring Part Bodies.

●     Measures are not associative when switching between folded view and unfolded view (using Fold/Unfold  in the Sheet Metal toolbar).

●     When an assembly contains objects with different dimensions (for example a solid -3D and a surface- 2D) only the object with the highest dimension (i.e. 

solid) is taken into account for the inertia measure calculation.

●     When measuring inertia on a feature (PartBody, Product, CATPart) on which a material is applied: 

�❍     if you modify the density value on the material or modify the material itself (adding a new one, modifying it or removing it), inertia measures previously 

created on this particular feature are not updated automatically and the Update icon on the measure is not displayed. Use the Force Measure Update 

command on the Measure or Inertia Volume object to update the measure result.

●     You cannot perform Measure Inertia within a product located in a CATAnalysis document in Product Editor workbench.

●     For elements such as Volume and Volume Extrude of Geometrical Set, material applied is not considered for density value during inertia calculation.
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Sectioning

 

Creating Section Planes Click the icon.

 Creating 3D Section Cuts:  Create a section plane then click the icon.

Manipulating Section Planes Directly: Create a section plane, drag plane edges to re-dimension, drag plane to move it 
along the normal vector, press and hold left and middle mouse buttons down to move plane in U, V plane or local axis 
system or drag plane axis to rotate plane.

 Positioning Planes with respect to a Geometrical Target: Create a section plane, click the icon then point to the target 
of interest.

 Positioning Planes Using the Edit Position and Dimensions Command: Create a section plane, click the icon and enter 
parameters defining the plane position in the dialog box.

 Using the Section Viewer: Create a section plane then click the icon.
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Creating Section Planes

This task shows how to create section planes and orient the normal vector of the plane.

●     About Section Planes 

●     Creating Section Planes (Step-by-step scenario)

●     Result Windows

●     Sectioning Definition Dialog Box

●     P2 functionalities

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, 

REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

About Section Planes 
 
The plane is created parallel to absolute coordinates Y, Z. The center of the plane is located at the center of the bounding 

sphere around the products in the selection you defined. 

Note: In clash context, the plane is not created parallel to absolute coordinates Y, Z as it  is collinear to the penetration 

vector of the clash specification. The penetration vector is identified by a white arrow in the 3D area:

●     Line segments represent the intersection of the plane with all surfaces and volumes in the selection. By default, line 

segments are the same color as the products sectioned. 
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●     Points represent the intersection of the plane with any wireframe elements in the selection.

A section plane has limits and its own local axis system. U, V and W represent the axes. The W-axis is the normal vector of the 

plane. The contour of the plane is red.

You can dynamically re-dimension and reposition the section plane. For more information, see Manipulating Section Planes 

Directly.

Using the Tools > Options... command (DMU Sectioning tab under Digital Mockup > DMU Space Analysis, you can change 

the following default settings: 

 

●     Location of the center of the plane

●     Orientation of the normal vector of the plane

●     Sectioning of wireframe elements.

 Creating Section Planes 

Before you begin 
 

When dealing with CATProducts containing a large amount of sections, for gain performances purposes, read carefully the 

Customization recommendations (follow the described procedure).

1.  Select Insert > Sectioning from the menu bar, or click Sectioning  in the DMU Space Analysis toolbar to 

generate a section plane.
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The section plane is automatically created. If no selection is made before entering the command, the plane sections all 

products. If products are selected, the plane sections selected products.

P1 Functionality

In DMU-P1, you cannot select products to be sectioned: the plane sections all products. 

2.  Click the Selection box to activate it.

3.  Click products of interest to make your selection, for example the TRIGGER and BODY1.Products selected are 

highlighted in the specification tree and geometry area.

Note: Simply continue clicking to select as many products as you want. Products will be placed in the active 

selection. To de-select products, reselect them in the specification tree or in the geometry area.
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The plane now sections only selected products 

You can change the current position of the section plane with respect to the absolute axis system of the document:

4.  Click the Positioning tab in the Sectioning Definition dialog box.

5.  Select X, Y or Z radio buttons to position the normal vector (W-axis) of the plane along the selected absolute system 

axis. Select Z for example. The plane is positioned perpendicular to the Z-axis. 
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6.  Double-click the normal vector of the plane (W-axis) or click Invert Normal  to invert it. 

7.  Click OK when done. The section plane definition and results are kept as a specification tree feature.
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8.  Click Close.

 By default, the plane is hidden when exiting the command. Use the Tools > Options, Digital Mockup > DMU 

Space Analysis command (DMU Sectioning tab) to change this setting.

�❍     To show the plane, select Hide/Show the plane representation in the contextual menu. 

Note: In this case, you cannot edit the plane.

�❍     To edit the plane again, double-click the specification tree feature.

 

Results Window 
 
A Section result window appears alongside the document window. If you want the Section result window to be tiled vertically 

alongside other document windows, go to Tools > Options > Digital Mockup > DMU Sectioning tab and select the 

appropriate option in the Results window area.

The section result window displays a front view of the generated section and is by default, locked in a 2D view.

Notice that the section view is a filled view. This is the default option. The fill capability generates surfaces for display and 

measurement purposes (area, center of gravity, etc.).
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Sectioning Definition Dialog Box 
 

The Sectioning Definition dialog box appears.

This dialog box contains a wide variety of tools letting you position, move and rotate the section plane as well as create slices, 

boxes and section cuts. For more information, see Positioning Planes with respect to a Geometrical Target, Positioning Planes 

Using the Edit Position Command, Creating Section Slices, Creating Section Boxes and Creating 3D Section Cuts.
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P2 Functionalities 
 
In DMU-P2, you can create as many independent section planes as you like.

Creating section slices and section boxes are DMU-P2 functionalities.
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Creating 3D Section Cuts

3D section cuts cut away the material from the plane, beyond the slice or outside the box to expose the cavity within the product.

 

This task explains how to create 3D section cuts: 

 

●     Creating 3D Section Cuts 

●     3D Section Cut Display

●     Hiding 3D Section Cuts

●     P2 Functionality

●     3D Section Cut in DMU Review

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.

cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

 

Creating 3D Section Cuts

1.  Select Insert > Sectioning from the menu bar, or click Sectioning  in the DMU Space Analysis toolbar and create a section plane. The 

Sectioning Definition dialog box appears.

2.  In the Definition tab, click Volume Cut  to obtain a section cut:

The material in the negative direction along the normal vector of the plane (W-axis) is cut away exposing the cavity within the product.
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Notes:

�❍     To give you the best view of the cut, the normal vector of the plane (W-axis) is inverted so that the cutting view is always visible on screen.

�❍     Partial clipping is not possible. Therefore if you select only one product in the Sectioning Definition dialog box, and click Volume Cut  to 

obtain a section cut:

■     In the document window the visual feedback shows a section cut that affects the entire product structure even if you have selected only one 

product.

■     In the Section viewer, the section cut only shows the selected product.

�❍     Sketches and lines are not cut by the clipping render.

3.  Double-click the normal vector of the plane to invert it, or click Invert Normal  in the Positioning tab of the Sectioning Definition dialog box.

 

4.  Re-click Invert Normal  to restore the material cut away.

5.  Click OK when done.

3D Section Cut Display
The 3D section cut display is different when the sectioning tool is a plane. To obtain the same display as for slices and boxes (see illustrations below) and 

make measures on the generated wireframe cut:

●     Select the Allow measures on a section created with a simple plane option in the DMU Sectioning tab (Tools > Options, Digital Mockup > DMU 

Space Analysis)
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●     Then, create your section cut based on a plane. 

 

When the Sectioning Tool is a Slice: When the Sectioning Tool is a Box:

About Sectioning solids which are intersecting

When using slice or box tools, note the visualization is not correct because the intersection between the two solids is not retrieved 
properly, i.e. it is not visualized and a cavity appears where material should be. Only each object specific section results are displayed.
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Hiding 3D Section Cuts
Hiding 3D Section Cuts will remove the clipping from the 3D Viewer as well as the section wireframe. The selection or un-selection of the option "Allow 

measures on a section created with a simple plan" does not have any impact on this behavior. 

P2 Functionality
In DMU-P2, you can turn up to six independent section planes into clipping planes using the Volume Cut command to focus on the part of the product 

that interests you most.

3D Section Cuts in DMU Review
Section cuts created during DMU Reviews are not persistent and are only valid for the duration of the review. If you exit the DMU Review, the section cut 

is lost.

For more information about DMU Review, refer to DMU Navigator User's Guide
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Manipulating Planes Directly

 

 

 

You can re-dimension, move and rotate section planes, or the master plane in the case of section slices and boxes, directly. As you move the cursor over the 

plane, the plane edge or the local axis system, its appearance changes and arrows appear to help you.

●     Re-dimensioning:
●     Moving along the normal vector 

of the plane:

●     Rotating:
●     Moving in the x,y plane of the 

local axis system:

Sectioning results are updated in the Section viewer as you manipulate the plane.  

To change this setting and have results updated when you release the mouse button only, de-activate the appropriate setting in the DMU Sectioning tab (Tools 

>Options..., Digital Mockup >DMU Space Analysis).

This task illustrates how to manipulate section planes directly.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, 

TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

1.  Select Insert > Sectioning from the menu bar, or click Sectioning  in the DMU Space Analysis toolbar and create a section plane.  

A Section viewer showing the generated section is automatically tiled vertically alongside the document window. The generated section is 

automatically updated to reflect any changes made to the section plane.You can re-dimension the section plane:

2.  Click and drag plane edges to re-dimension plane:
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Note: A dynamic plane dimension is indicated as you drag the plane edge.

You can view and edit plane dimensions in the Edit Position and Dimensions command. The plane height corresponds to its dimension along the local 

U-axis and the width to its dimension along the local V-axis.You can move the section plane along the normal vector of the plane:

3.  Move the cursor over the plane, click and drag  to move the plane to the desired location.You can move the section plane in the U, V plane of the local 

axis system:

4.  Press and hold down the left mouse button, then the middle mouse button and drag (still holding both buttons down) to move the plane to the desired 

location. You can rotate the section plane around its axes: 

5.  Move the cursor over the desired plane axis system axis, click and drag to rotate the plane around the selected axis.

6.  (Optional) Click Reset Position  in the Positioning tab of the Sectioning Definition dialog box to restore the center of the plane to its original 

position.

7.  Click OK in the Sectioning Definition dialog box when done. 
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Note: You cannot re-dimension, move or rotate the plane via the contextual menu command Hide/Show the plane 

representation. 
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Positioning Planes On a Geometric Target

You can position section planes, section slices and section boxes with respect to a geometrical target (a face, edge, reference plane or cylinder axis). In the 

case of section slices and boxes, it is the master plane that controls how the slice or box will be positioned.

 

This task illustrates how to position a section plane with respect to a geometrical target.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.

cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation file tree in the common functionalities sample folder cfysm/samples.

 

1.  Select Insert > Sectioning from the menu bar, or click Sectioning  in the DMU Space Analysis toolbar and create a section plane. The 

Sectioning Definition dialog box appears. 

A Section result window showing the generated section appears alongside the document 

window. 

The generated section is automatically updated to reflect any changes made to the section plane.

2.  Click the Positioning tab in the Sectioning Definition dialog box.

3.  Click Geometrical Target   to position the plane with respect to a geometrical target.

4.  Point to the target of interest:

A rectangle and vector representing the plane and the normal vector of the plane appear in the geometry area to assist you position the section plane. It 

moves as you move the cursor.

5.  When satisfied, click to position the section plane on the target.
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Notes: 

�❍     To position planes orthogonal to edges, simply click the desired edge.

�❍     A smart mode recognizes cylinders and snaps the plane directly to the cylinder axis. This lets you, for example, make a section cut normal to a hole 

centerline. To de-activate this mode, use the Ctrl key.

�❍     Selecting the Automatically reframe option in the DMU Sectioning tab (Tools > Options > Digital Mockup > DMU Space Analysis), reframes the 

Section result window and locates the point at the center of the target at the center of the Section viewer.

Zooming in lets youpinpointthe selected point. 
This is particularly useful when using snap capabilities in a complex DMU session containing a large number of objects.

6.  (Optional) Click Reset Position   to restore the center of the plane to its original position.

7.  Click OK in the Sectioning Definition dialog box when done.

P2 Functionality

In DMU-P2, you can move the plane along a curve, edge or surface: 

1.  Point to the target of interest

2.  Press and hold down the Ctrl key

3.  Still holding down the Ctrl key, move the cursor along the target. The plane is positioned tangent to the small target plane

4.  As you move the cursor, the plane moves along the curve or edge.
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Positioning Planes Using the Edit Position and dimensions 

 In addition to manipulating the plane directly in the geometry area, you can position the section plane more precisely using the Edit Position and Dimensions 

command. You can move the plane to a new location as well as rotate the plane. You can also re-dimension the section plane.

In the case of section slices and boxes, it is the master plane that controls how the slice or box will be positioned.

 

This task illustrates how to position and re-dimension the section plane using the Edit Position and Dimensions command.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, 

TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

1.  Select Insert > Sectioning from the menu bar, or click Sectioning  in the DMU Space Analysis toolbar and create a section plane.

A Section viewer showing the generated section is automatically tiled vertically alongside the document window. The generated section is 

automatically updated to reflect any changes made to the section plane.

The Sectioning Definition dialog box is also displayed.

2.  Click the Positioning tab in the Sectioning Definition dialog box.

3.  Click the Edit Position and Dimensions  to enter parameters defining the position of the plane.

The Edit Position and Dimensions dialog box appears.

 

4.  Enter values in Origin X, Y or Z boxes to position the center of the plane with respect to the absolute system coordinates entered. 

 By default, the center of the plane coincides with the center of the bounding sphere around the products in the current selection. 
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Notes:

�❍     Using the Tools > Options... command (DMU Sectioning tab under Digital Mockup > DMU Space Analysis), you can customize settings for 

both the normal vector and the origin of the plane

�❍     Units are current units set using Tools > Options.

5.  Enter the translation step directly in the Translation spin box or use spin box arrows to scroll to a new value, then click -Tu, +Tu, -Tv, +Tv, -Tw, +Tw, 

to move the plane along the selected axis by the defined step. 

 Note: Units are current units set using Tools > Options (Units tab under General > Parameters and Measure).

6.  Change the translation step to 25mm and click +Tw for example. The plane is translated 25 mm in the positive direction along the local W-axis.

You can rotate the section plane. Rotations are made with respect to the local plane axis system

You can move the section plane to a new location. Translations are made with respect to the local plane axis system.

7.  Enter the rotation step directly in the Rotation spin box or use spin box arrows to scroll to a new value, then click -Ru, +Ru, -Rv, +Rv, -Rw, +Rw, to 

rotate the plane around the selected axis by the defined step. 

With a rotation step of 45 degrees, click +Rv for example to rotate the plane by the specified amount in the positive direction around the local V-axis.
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You can edit plane dimensions. The plane height corresponds to its dimension along the local U-axis and the width to its dimension along the local V-
axis. You can also edit slice or box thickness.

8.  Enter new width, height and/or thickness values in the Dimensions box to re-dimension the plane. The plane is re-sized accordingly.

9.  Click Close in the Edit Position and Dimensions dialog box when satisfied.

10.  Click OK in the Sectioning Definition dialog box when done.

 

 

●     Click Undo and Redo in the Edit Position and Dimensions dialog box to cancel the last action or recover the last action undone respectively.

●     Click Reset Position  in the Positioning tab of the Sectioning Definition dialog box to restore the section plane to its original position.

●     You can also view and edit plane dimensions in the Properties dialog box (Edit > Properties or via the contextual menu). 

This command is not available when using the sectioning command.
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More About the Section Result Window 

This task illustrates how to make the most of section viewer capabilities: 

 

●     Accessing the Section Result Window capabilities

●     Step-by-Step Scenario

�❍     Section Results Window

�❍     About the Section Fill capability

�❍     Orienting the Section

�❍     Working with the 2D Grid

�❍     Working with a 3D View

●     Detecting Collisions (P2)

Accessing the Section Result Window capabilities
Most of the commands described in this task are to be found in the Result tab of the Sectioning Definition dialog box or in the Section result window 

contextual menu.

 

Step-by-Step Scenario

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.

cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.
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Before you begin

When dealing with CATProducts containing a large amount of sections, for performance gain purposes, read carefully the Customization recommendations 

(follow the described procedure).

1.  Select Insert > Sectioning from the menu bar, or click Sectioning  in the DMU Space Analysis toolbar and create the desired section plane, slice or 

box and corresponding section.

Section Results Window

The Section Results window appears alongside the document window (by default, it is automatically open). It displays a front view of the section, and is by 

default, locked in a 2D view. Points representing the intersection of the section plane with any wire frame elements are also visible in the Section result window. 

When performing multiple sections, you need to arrange (resizing and positioning) their section result windows in an appropriate way. From R17 onwards, 

you can customize the sectioning result window; 

the size and positioning of the result windows you specify are now kept and thus persistent.

●     Customizing the section result window size

●     Customizing the section result window positioning

●     Accessing the section result window

Customizing the section result window size

Select Tools > Options > Digital Mockup > DMU Sectioning tab.

In the Results window settings category, select the required categories of options and click Ok when satisfied.

Refer to the Customizing section for detailed information.
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You can also in session, resize your sectioning results window using the standard window manipulators:

Customizing the section result window positioning

You can position your section result windows as you wish in your session. 
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The positioning is now persistent, therefore after the saving operation when you reopen your document you retrieve your section result windows exactly as 
you saved them.

Note though that if you select the Tile vertically option in Windows Result area (Tools > Options > Digital Mockup > DMU Sectioning tab) the 
positioning is forced and automatically defined: 

Accessing the section windows

To access the dedicated section windows, simply double-click the sections of interest in the specification tree or right-click the sections and select 
Open associated viewers item from the contextual menu displayed. 
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About the Section Fill capability

 

Notice that the section view is a filled view. This is the default option. The fill capability generates surfaces for display and measurement purposes (area, 

center of gravity, etc.). To obtain a correct filled view, the section plane must completely envelop the product.  

Note: The filled view is not available when the plane sections surfaces.

To obtain an unfilled view, de-activate the Section Fill  in the Result tab of the Sectioning Definition dialog box.

 

 

●     In the Section viewer, the appearance of the cursor changes to attract your attention to the existence of the contextual menu.

●     You can change the default settings for this window using Tools > Options... command (DMU Sectioning tab under Digital Mockup > DMU Space 

Analysis). You can now define a specific size for the sectioning result window.

Orienting the Section
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2.  Orient the generated section.Flip and Rotate commands are to be found in the contextual menu. Right-click in the Section viewer and:

�❍     Select Flip Vertical  or Flip Horizontal  to flip the section vertically or horizontally 180 degrees.

�❍     Select Rotate Right  or Rotate Left  to rotate the section right or left 90 degrees.

Orienting the section using Flip and Rotate commands is not persistent. If you exit the section viewer, any flip and rotate settings are lost.

Working with the 2D Grid

3.  Click the Result tab in the Sectioning Definition dialog box, then select Grid  under Options to display a 2D grid. 

By default, grid dimensions are those of the generated section. Moving the section plane re-sizes the grid to results. To size the grid to the section plane, 

clear the Automatic grid re-sizing check box in the DMU Sectioning tab (Tools > Options..., Digital Mockup > DMU Space Analysis).

You can edit the grid step, style and mode using the Edit Grid command.

4.  Select Edit Grid  to adjust grid parameters: The Edit Grid dialog box appears: In the above example, the grid mode is absolute and the style is set to 
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lines.

In the absolute mode, grid coordinates are set with respect to the absolute axis system of the document.

The grid step is set to the default value of 100. The arrows let you scroll through a discrete set of logarithmically calculated values. You can also enter a 

grid step manually.

Units are current units set using Tools > Options (Units tab under General > Parameters and Measure).

5.  Scroll through grid width and height and set the grid step to 10 x 10.

6.  Click the Relative mode option button: In the relative mode, the center of the grid is placed on the center of section plane.

7.  Click the Crosses style.

Grid parameters are persistent: any changes to default parameters are kept and applied next time you open the viewer or re-edit the section.

8.  Click Automatic filtering check box to adjust the level of detail of grid display when you zoom in and out.

9.  Right-click the grid then select Coordinates to display the coordinates at selected intersections of grid lines. The Clean All command removes displayed grid 

coordinates.
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Notes: 

�❍     You can customize both grid and Section viewer settings using the Tools > Options... command (DMU Sectioning tab under Digital Mockup > 

DMU Space Analysis). 

�❍     Alternatively, select Analyze > Graphic Messages > Coordinate to display the coordinates of points, and/or  Name to identify products as your 

cursor moves over them. 

�❍     Clicking turns the temporary markers into 3D annotations.

10.  Click OK in the Edit Grid dialog box when done.

Working with a 3D View

By default, the Section viewer is locked in a 2D view. De-activating the 2D view lets you:

●     Work in a 3D view and gives you access to 3D viewing tools

●     Set the same viewpoint in the Section viewer as in the document window.

Returning to a 2D view snaps the viewpoint to the nearest orthogonal view defined in the Section viewer.

11.  Right-click in the Section viewer and select the 2D Lock command from the contextual menu. The Import Viewpoint command becomes available.

 

12.  Manipulate the section plane.

13.  Right-click in the Section viewer and select the Import Viewpoint command from the contextual menu. The viewpoint in the Section viewer is set to that of the 
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document window.

14.  Continue manipulating the section plane.

15.  Return to a locked 2D view.

The viewpoint in the Section viewer snaps to the nearest orthogonal viewpoint in this viewer and not to the viewpoint defined by the local axis system of 

the plane in the document window.

You can also save sectioning results in a variety of different formats using the Export As command in the Result tab of the Sectioning Definition dialog box 

or the Capture command (Tools > Image > Capture).

16.  Click OK in the Sectioning Definition dialog box when done. If you exit the Sectioning command with the Section viewer still active, this window is not closed 

and filled sections remain visible.
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P2 Functionality - Detecting Collisions

In DMU-P2, You can detect collisions between 2D sections. To do so, click Clash Detection  in the Result tab of the Sectioning Definition dialog box.

Clashes detected are highlighted in the Section viewer. 

Collision detection is dynamic: move the section plane and watch the Section viewer display being updated.

Note: Clash detection is not authorized when in the Section Freeze mode.
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Instant Collaboration

Client/Server Collaboration is available only if you have a VPM Navigator license.

Peer-to-Peer Collaboration is available to all users having a DMU Navigator, VPM Navigator or Collaborative Design 
license, with the exception of the functionalities Sharing the Mouse Pointer, Sharing Highlight and Sharing Annotated 
Views which require a DMU Navigator license.

 

About Instant Collaboration 
Accessing Instant Collaboration

Peer-to-Peer Collaboration 
Client/Server Collaboration

Toolbars Description
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About Instant Collaboration 

Instant Collaboration in a Nutshell

Instant Collaboration enables instant collaboration between all participants across the extended enterprise in order to promote the sharing of data and ideas 
that can result in a faster time-to-market and an increase in overall product innovation.

●     Instant collaboration from within DS products 

●     Collaboration between communities 

●     Secure collaborative environment 

●     Tracking and storage of information created during meetings 

●     Promote the sharing of data and ideas that can result in a faster time to market and an increase in overall product innovation 

●     Capitalization and re-use of meeting information 

●     Fast, real-time information sharing 

●     Easy access to collaboration tools 

●     Integration in DS products for collaboration access from any application

●     Connectivity: manage communities, awareness, meeting invitations and data sharing

●     Co-Review: share and synchronize information around the 3D product definition for all the attendees

 

 
Product Highlights

With Instant Collaboration, all designers and reviewers communicate around the 3D product definition, from the Engineering Hub data, at anytime they need. 

Connectivity

Instant Collaboration is fully scalable from peer-to-peer local communications (without server and special configuration) to extended enterprise scenarios, 
taking benefits from standard communication solutions integration. 
 
You can drastically shrink time-to-decision with advanced collaborative 3D conferencing. All Engineering Hub actors, from the designers or projects leaders 
to integrated suppliers will benefit from instant collaboration, reducing decision cycle times as they communicate at any time on an explicit and unified view 
of the developed products.

Co-Review 

Instant Collaboration Co-Review through 3D conferencing is a breakthrough versus simple display sharing:

●     Each participant is an actor and not a simple listener: Even during a review, interactions on the 3D rich product representation between participants are 
possible: publisher/listener roles can be switched. This is not the case in display sharing.

●     Less information is shared on the network: Only few events are shared within the network during the review: the co-review is more fluent for all participants 
in comparison with display sharing.

 

Search for a user or a group of users for real-time collaboration 

Users can enter keywords to query the collaboration user directory. They can query for people, groups or both. Regular expressions such as "*" are accepted 
by the search engine and the patterns for result-matching depend on the configuration of the Sametime server. People search results can be added to a 
user private group or added to a new meeting definition using the  integrated toolbar. On the group search result, it's possible to detail group content and add 
a reference to this group in the connect list. This reference will remain synchronized with the directory data. You can also choose to copy a public group to 
your contact list. Notice that user status is also displayed as part of the query result. 

 

Personal contact storage 

Users can store personal contacts regrouped by user-defined groups or public groups defined in the enterprise directory. The contact list displays all the 
groups defined in the user profile and their content. User status and user nickname are displayed. Multi-selection is allowed on groups and on people lists. 
A personal group can be renamed or removed. 

 

Awareness services to check the real-time availability of your contacts 

Awareness Services allow a connected user to know the connectivity status of the others and to handle his/her own status and associated message. For 
each user, an icon indicates the associated status (connected, away, do not disturb and not connected). When a user is connected, his/her name appears as 
a hypertext link. Selecting this link will launch an Instant Messaging dialog. The displayed status changes dynamically without need to reload the component. 
General awareness capabilities are available from ENOVIA - PPR Navigator and ENOVIA - Issue Management to enable integrated connectivity directly from 
these applications. 
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Place Base Awareness Services allow a connected user to know the number connected people connected to a pre-defined location (e.g. a web page). When a 
user enters the location, a counter appears indicating the number of people connected at that instant. Clicking the number will display details of who 
is connected. This list is totally dynamic and changes when people enter or leave the location. Clicking the text People in Place will start an N-way Chat 
with connected people.

 

Chat capabilities 

Instant messaging is the most direct way to chat with a connected person in one interaction. It also enables to receive invitation to  meetings. When clicking 
the name of an active person, an instant messaging window is displayed. From this window you can send and receive messages. You can invite other people 
to join the chat, change to an N-Way chat, or upgrade the chat meeting to a Collaboration meeting in a meeting room. A specific user interface is provided 
for inviting people using a search panel or a browse panel. Note that inviting people that are not connected will generate an information message. 
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Accessing Instant Collaboration 

Once you've accessed Instant Collaboration, the Instant Collaboration toolbar will appear in your session. This toolbar will also 
give you access to the Collaboration toolbar. 
 

1.  In the menu bar, select Views  >  Toolbars  >  Instant Collaboration. 

The Instant Collaboration toolbar, which consists of the Instant Collaboration icon, appears. 

 

2.  To visualize the Collaboration Toolbar, click the selection arrow.

3.  To detach the Collaboration Toolbar, click the selection arrow, then click the toolbar handle and drag.

The functionalities available via the Collaboration toolbars are as follows:

Icon Functionality

 Community

 Instant Messaging

 Snapshot Sharing

 Document Sharing

 Viewpoint Sharing

 Collaboration Settings

 Search for People

  
Note that all of the above functionalities can be accessed from the Community dialog box via contextual menus.  
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Peer-to-Peer Collaboration 

The functionalities Sharing the Mouse Pointer, Sharing Highlight and Sharing Annotated Views are available only if 
you have a DMU Navigator license.

 

Organizing a Peer-to-Peer 3D Conference

Creating a Business Card 
Connecting to the Community 

Disconnecting from the Community 
Searching for People in the Community 

Creating a Group 
Joining a Group 

Inviting other People to Join a Group 
Declaring your Availability Status 

Chatting with another Person  
Creating a 3D Conference 
Joining a 3D Conference  

 

Working in a Peer-to-Peer 3D Conference

Chatting with other People 
Publishing Viewpoints 
Receiving Viewpoints  
Sharing Documents 

Receiving Documents 
Publishing Snapshots 

Sharing the Mouse Pointer 
Sharing Highlight 

Sharing Annotated Views
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Client/Server Collaboration 

 

Client/Server Collaboration is available only if you have a VPM Navigator license.

 Creating and Working in a 3D Conference is available only if you also have a DMU Navigator license.

 

Organizing a Collaboration Meeting

Connecting to the Community 
Disconnecting from the Community 
Adding a Group to Your Community 

Adding Users to a Group 
Declaring your Availability Status 

Checking Availability of other People 
Chatting with another Person  

Creating a Collaboration Meeting 
Joining a Collaboration Meeting 

Working in a Collaboration Meeting 
 

Creating and Working in a 3D Conference

Creating a 3D Conference 
Joining a 3D Conference 

Inviting More People to the Current 3D Conference 
Leaving the Current 3D Conference 

Chatting with other People 
Publishing Viewpoints 
Receiving Viewpoints  

Sharing the Mouse Pointer 
Sharing Highlight 

Sharing Annotated Views
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Toolbars Description 

 

Peer-to-Peer Collaboration
 

Instant Collaboration Toolbar

 

See Connecting to the Community

See Chatting with another Person

See Publishing Viewpoints

 

 
 

Connectivity Toolbar

 

See Connecting to the Community

See Disconnecting from the Community

See Searching for People in the Community

 

 

3D Insight Version 5 Release 19 Page 733 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0002.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0022.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0008.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0002.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0015.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0003.htm


 
Instant Messaging Toolbar

 

See Chatting with another Person  

See Sharing Documents 

See Publishing Snapshots 

 

 

 
Client/Server Collaboration (Requires a VPM Navigator license)

 

Instant Collaboration Toolbar

 

See Connecting to the Community 

See Chatting with another Person

See Creating a Collaboration Meeting

See Publishing Viewpoints (Requires a DMU license)
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Connectivity Toolbar

 

See Connecting to the Community

See Disconnecting from the Community

 

 

 

Instant Messaging Toolbar

 

See Chatting with another Person

See Creating a Collaboration Meeting

See Creating a Collaboration Meeting

 

 

 

Meetings Toolbar

 

See Creating a Collaboration Meeting

See Creating a Collaboration Meeting

See Creating a Collaboration Meeting

See Creating a 3D Conference (Requires a DMU license)

3D Insight Version 5 Release 19 Page 735 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0002.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0015.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab0022.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab2107.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab2107.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab2107.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab2107.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab2107.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyugcollab_C2/cfyugcollab2109.htm


Conferencing

Initializing a Conference Infrastructure

Initializing a Conference on UNIX using the Backbone Driver As Backbone Manager, launch the backbone daemon on 
node1: "CATSysDemon -dm domain.lst -timeout 3000". Launch the Backbone daemon on both node2 and node3 as 
follows: "export CATBBDomainManager=node1 CATSysDemon -timeout 3000". Once initialized, all users must 
select the Backbone driver option using: Tools >  Options  >  General  >  General. In the Conferencing area, 
check the Backbone option.

Initializing a Conference on Windows using the Backbone Driver As Backbone Manager, launch the backbone daemon on 
node1: "CATSysDemon -dm domain.lst -timeout 3000". Launch the Backbone daemon on both node2 and node3 as 
follows: "export CATBBDomainManager=node1 CATSysDemon -timeout 3000". Once initialized, all users must 
select the Backbone driver option using: Tools >  Options  >  General  >  General. In the Conferencing area, 
check the Backbone option.

Initializing a Conference on Windows using the NetMeeting Driver All users must select the NetMeeting driver option 
using: Tools >  Options >  General  >  General. In the Conferencing area, check the NetMeeting option.

 Organizing a Conference

Launching a Conference as Host In the menu bar, select the Tools > Conferencing > Host

Joining a Conference as Guest In the menu bar, select the Tools > Conferencing > Guest

 Working in a Conference

Leading the Visual Conference

Sharing Documents

Transferring Files

Sending Messages to other Conference Participants

Customizing Conference Options

Consulting Conference History 

Leaving a Conference
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Initializing a Conference on UNIX using the Backbone Driver

This scenario describes how to initialize a conference on UNIX using the Backbone driver.

Conferencing enables people who are geographically separated to dialog and work together as if they were virtually in the same room. Audio, video or chat 
tools enable the conference members to dialog while whiteboard or any other application sharing capabilities enable them to share documents or 
even applications. Usually, one member has a leading role, he is named the host or the master member.

The conferencing functionality is available on both the Windows and UNIX platforms.

 

Backbone is a Dassault Systèmes component which enables the creation of information channels between various applications running on various machines. 

Backbone must be implemented on each computer that will be used by eventual conference members and on a reference server.

 

Applications do not communicate directly but through local servers (CATSysDemon servers), which communicate among themselves via a Domain 
Manager (which is itself CATSysDemon server)

As Backbone Manager, you must define the Domain that will enable the  CATSysDemon servers to communicate with one another.

 

1.  Select a machine which will be the Domain Manager (Backbone Manager), e.g. node1.

2.  Create a file containing the list of machines that will be allowed to connect to the Domain, e.g. domain.lst containing the following lines:

node2 
node3 
node4 
node5

3.  Launch the CATSysDemon command with the above list of machines as parameter:

CATSysDemon -dm domain.lst 

4.  Export the Domain Manager host name:

export CATBBDomainManager=node1

5.  All members of a conference must select the same conference driver, i.e. all members must select Backbone. To select the conference driver:

●     In the menu bar, select Tools->Options.

●     Click  the General category in the left-hand tree.

●     Click the General tab.

●     In the Conferencing area, check the Backbone option.

●     Click OK to confirm.

On UNIX

On UNIX it is possible to modify the default communication ports. The communication technology used for conferencing is socket-based. Your administrator 
must define the communication ports that will be used. On UNIX, the default ports are 6666 and 6667.

If these default ports are not available, you can modify their values in the file /etc/services by replacing 6666 and 6667 by the available ports in the 
following lines:

catiav5bb 55555/tcp 
catiav5run 55556/tcp

On UNIX it is possible to automatically launch the CATSysDemon server by adding the following line in the file  /etc/inetd.conf:

catiav5run stream tcp nowait nobody runCATSysDemon CATSysDemon
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where runCATSysDemon is a shell which will launch CATSysDemon as a Domain Manager, for which you also have the following options:

 

CATSysDemon server options

The -opendm option can also be added to enable ANY other machine to be connected. 

Ex: CATSysDemon -opendm -dm domain.lst

You can use -dmhost <hostname> option  instead, if the CATBBDomainManager environment variable is not set.

 Ex: CATSysDemon -dmhost nodehost

The "-h" option gives you a list of the available options. For instance:

-DebugL<n>, with n=1,2,3,4,10 provides information to follow communications between CATSysDemon servers. (Use it only if you encounter difficulties.)

-timeout <time in seconds> enables to leave the server running more than the default 300s when no client application is connected.

Ex: CATSysDemon -DebugL4 -timeout 3000

 

The Meta-Domain, How domains are linked together

A Domain Lister must be launched to enable a machine from domain A to communicate with a machine from domain B.

The domain Lister aims at providing a list of the domain managers. This consists in creating a meta-domain where the Domain Lister is Domain Manager, 
and where the Domain Managers are clients.

●     On the lister machine (let's call it node1), the CATSysDemon server must be launched using the "-dl <filepath>" option, <filepath> being a file containing 
the list of every (other) machine belonging to the meta-domain 

  Ex: CATSysDemon -dl domains.lst

●     Before running the other servers in the meta-domain, the Domain Lister host name must be specified via the CATBBDomainLister variable:

Ex: export CATBBDomainLister=nodelist
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Initializing a Conference on Windows using the Backbone Driver

This scenario describes how to initialize a conference on Windows using the Backbone driver. 

Conferencing enables people who are geographically separated to dialog and work together as if they were virtually in the same room. Audio, video or chat 
tools enable the conference members to dialog while whiteboard or any other application sharing capabilities enable them to share documents or 
even applications. Usually, one member has a leading role, he is named the host or the master member.

The conferencing functionality is available on both the Windows and UNIX platforms.

 

Backbone is a Dassault Systèmes component which enables the creation of information channels between various applications running on various machines. 

Backbone must be implemented on each computer that will be used by eventual conference members and on a reference server.

 

Applications do not communicate directly but through local servers (CATSysDemon servers), which communicate among themselves via a Domain 
Manager (which is itself CATSysDemon server)

As Backbone Manager, you must define the Domain that will enable the  CATSysDemon servers to communicate with one another.

 

1.  Select a machine which will be the Domain Manager (Backbone Manager), e.g. node1.

2.  Create a file containing the list of machines that will be allowed to connect to the Domain, e.g. domain.lst containing the following lines:

node2 
node3 
node4 
node5

3.  Launch the CATSysDemon command with the above list of machines as parameter:

CATSysDemon -dm domain.lst 

4.  Export the Domain Manager host name:

set CATBBDomainManager=node1

5.  All members of a conference must select the same conference driver, i.e. all members must select Backbone. To select the conference driver:

●     In the menu bar, select Tools->Options.

●     Click  the General category in the left-hand tree.

●     Click the General tab.

●     In the Conferencing area, check the Backbone option.

●     Click OK to confirm.
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CATSysDemon server options

The -opendm option can also be added to enable ANY other machine to be connected. 

Ex: CATSysDemon -opendm -dm domain.lst

You can use -dmhost <hostname> option  instead, if the CATBBDomainManager environment variable is not set.

 Ex: CATSysDemon -dmhost nodehost

The "-h" option gives you a list of the available options. For instance:

-DebugL<n>, with n=1,2,3,4,10 provides information to follow communications between CATSysDemon servers. (Use it only if you encounter difficulties.)

-timeout <time in seconds> enables to leave the server running more than the default 300s when no client application is connected.

Ex: CATSysDemon -DebugL4 -timeout 3000 
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Initializing a Conference on Windows using the NetMeeting Driver

This scenario describes how to initialize a conference on Windows using NetMeeting as conference driver.

Conferencing enables people who are geographically separated to dialog and work together as if they were virtually in the same room. Audio, video or chat 
tools enable the conference members to dialog while whiteboard or any other application sharing capabilities enable them to share documents or 
even applications. Usually, one member has a leading role, he is named the host or the master member.

The conferencing functionality is available on both the Windows and UNIX platforms.

 

 
1.  All members of a conference must select the same conference driver, i.e. all members must select NetMeeting. To select the conference driver:

●     In the menu bar, select Tools->Options.

●     Click  the General category in the left-hand tree.

●     Click the General tab.

●     In the Conferencing area, check the NetMeeting option.

●     Click OK to confirm.

 

2.  To host a conference, in the menu bar, select the Tools->Conferencing->Host.

3.  To join a conference as a guest, in the menu bar, select the Tools->Conferencing->Guest.

The NetMeeting and Conferencing dialog boxes appear. 

 

 If the NetMeeting interface is already on the desktop, you can use it to host a conference by selecting the Call/Host Meeting menu item, and then connect to 
that conference by selecting  Tools->Conferencing->Host from the menu bar. 
 
Likewise, guests already in a NetMeeting conference can connect to that conference by selecting the Tools->Conferencing->Guest from the menu bar.
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Launching a Conference as Host

The person who launches a conference is considered to be the conference host. The host, and only the host, can do the following:
●     invite other participants to the conference

●     start the visual conference

●     suspend the visual conference

●     grant requests by other participants to speak

 
You must have a DMU Navigator session running. 

You must have properly initialized the conferencing infrastructure. See:

●     Initializing a Conference on UNIX using the Backbone Driver

●     Initializing a Conference on Windows using the Backbone Driver

●     Initializing a Conference on Windows using the NetMeeting Driver

Each participant of the conference must have access privileges to all data that he will visualize and he must load the data manually. Information about 
which documents are open in the Host session is provided to all participants on the Document page.

The actions replicated during a conference are the following:

●     workbench transition

●     object selection

●     viewpoint modification (zoom, rotation)

●     3D annotations (creation, modification and deletion)

●     2D annotations (linked to cameras) creation, modification and deletion

●     move products (free hand or simulation context)

●     show/hide

●     specification tree status (if you expand a node as the host it is replicated in the guest session)

It is now possible to use the F3 key to toggle the visibility of the specification tree. the coherence of which is maintained for all member sessions of 
the conference.   
 

 
1.  To host a conference, in the menu bar, select the Tools->Conferencing->Host.

The Conferencing dialog box appears. 
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If you are using NetMeeting as driver, the NetMeeting dialog box will also appear. 

If the NetMeeting interface is already on the desktop, you can use it to host a conference by selecting the Call/Host Meeting menu item, and then connecting 
to that conference by selecting  Tools->Conferencing->Host from the menu bar.  
 
Likewise, guests already in a NetMeeting conference can connect to that conference by selecting the Tools->Conferencing->Guest from the menu bar.

As much as NetMeeting functionality would enable you to perform some of the conferencing actions, they will not be described in this documentation. 

Note, however, that even if you manage the conference completely from the Conferencing dialog box, you must leave the NetMeeting dialog box opened as it 
is serving as the conference driver.

2.  The host member then invites the other participants.

In the Conferencing dialog box:  

●     enter the name or the IP address of the participant's machine 

●     click the Call button

An information box appears indicating that you are waiting for a response to your call.
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 When your invitation has been accepted by a given guest, that guest's identification will appear in the Other participants area of the Setup page.

 As soon as the conference is organized (i.e. at least 2 members connected), the Visual Control page is accessible. 

The conference is suspended. Everybody can continue working, opening documents, annotating documents, etc. 
 

3.  At any moment, click the Who I am button to edit your personal identification information.  

The Business card dialog box is displayed.

 
 

Starting the Visual Conference

4.  Click the Start the Visual Conference button to start the visual conference.  

The conference status changes to In Progress. (The Start the Visual Conference button changes automatically to Suspend the Visual Conference.)
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Suspending the Visual Conference

5.  Click the Suspend the Visual Conference button to suspend the visual conference.  

The conference status changes to Suspended. (The Suspend the Visual Conference button changes automatically to Start the Visual Conference.)
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Joining a Conference as Guest

You can join a conference as a guest after having received a call from the Host inviting you to the conference.

You must have a DMU Navigator session running. 

You must have properly initialized the conferencing infrastructure. See:

●     Initializing a Conference on UNIX using the Backbone Driver

●     Initializing a Conference on Windows using the Backbone Driver

●     Initializing a Conference on Windows using the NetMeeting Driver

Each participant of the conference must have access privileges to all data that he will visualize and he must load the data manually. Information about 
which documents are open in the Host session is provided to all participants on the Document page.

The actions replicated during a conference are the following:

●     workbench transition

●     object selection

●     viewpoint modification (zoom, rotation)

●     3D annotations (creation, modification and deletion)

●     2D annotations (linked to cameras) creation, modification and deletion

●     move products (free hand or simulation context)

●     show/hide

●     specification tree status (if you expand a node as the host it is replicated in the guest session)

It is now possible to use the F3 key to toggle the visibility of the specification tree. the coherence of which is maintained for all member sessions of 
the conference.   
 
 

1.  To join the conference as a guest, in the menu bar, select the Tools->Conferencing->Guest.

The Conferencing dialog box appears.  

You must now wait until you receive a call from the Host inviting you to join the conference.
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If you are using NetMeeting as driver, the NetMeeting dialog box will also appear. 

If the NetMeeting interface is already on the desktop, you can use it to host a conference by selecting the Call/Host Meeting menu item, and then 
connecting  DMU to that conference by selecting  Tools->Conferencing->Host from the menu bar in the DMU window.  
 
Likewise, guests already in a NetMeeting conference can connect DMU to that conference by selecting the Tools->Conferencing->Guest from the menu bar 
in the DMU window.

As much as NetMeeting functionality would enable you to perform some of the conferencing actions, they will not be described in this documentation. 

Note, however, that even if you manage the conference completely from the Conferencing dialog box, you must leave the NetMeeting dialog box opened as it 
is serving as the conference driver.

2.  You must now wait until you receive a call from the Host inviting you to join the conference.

3.  When you receive the invitation, click Accept in the Incoming Call dialog box.

You are now a participant of the conference.

 As soon as the conference is active (i.e. at least 2 members connected), the Visual Control page is displayed. 

The conference is on hold. Everyone can go on working, opening documents, annotating documents, etc.

4.  At any moment, you can click the Who I am button to edit your personal identification information.  

The Business card dialog box is displayed.
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Leading the Visual Conference

During the visual conference, only the participant who is the designated speaker can speak. (The Host is the designated speaker by default.) Actions 
or commands performed by the speaker in his /her DMU session are replicated in the DMU sessions of the other participants. The other participants 
cannot perform actions or commands in their DMU sessions while someone else is speaker (unless that particular participant has switched from Listen mode 
to Work mode); they can, however, continue to perform actions in the Conferencing dialog box. 

Any participant can request to speak by clicking the Speak radio button on the  Visual Control page. The host grants the request to speak by double-
clicking the name of the requesting participant in the Speaking requests area of the Visual Control page. Of course, the host member can become speaker 
at any time by requesting to speak and granting his / her own request. 
 

 
Suspending the Visual Conference

The host member can suspend the visual conference at any time. All he needs to do is click the Suspend the Visual Conference button. Performing this 
action allows everybody to work on their own.

Only the host can suspend and start the visual conference.

 

Conference mode
●     Directed: the host manages the requests to speak

●     Free: any participant can speak at any moment 

 

Participant mode
●     Record on / Record off: participants can record events in order to visualize all of the events that transpired while they were in a break

●     Update: recorded events are replayed one by one 

●     Listen and Work: participants can either listen to the speaker or choose to momentarily disengage from the visual conference in order perform work not 
related to the conference

●     Speak: to request to speak, a participant clicks the Speak radio button (if the Conference mode is Free, then there is of course no need to request to speak)

 
 

Managing Who Speaks in a Directed Visual Conference

In a directed conference, the Host manages all speaking requests. 
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1.  A participant clicks the Speak radio button. 

The image of a person with raised hand appears, indicating the participant's request to speak. The requesting participant must now wait until the Host grants 

the request.

 

2.  The Host double-clicks the name of the participant requesting to speak.

3.  As soon as the request is granted, the requesting participant's Speak radio button becomes active, he / she is now the speaker.
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 When the speaker is performing actions in the interactive session, his / her name now appears under the arrow.
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Sharing Documents with other Conference Members

The Document page enables you to manage data sharing. It indicates the documents which are opened in the host member session. 

 Access permissions:  Each conference member wants to share some of his components  with some of the other members, but perhaps not 
with all of them. For this reason, he must be able to  define access permissions (visible or invisible) per component and per conference  
member. In practice, the shared document (often called the "Root product") belongs to the Host member, who calls the Guest members and 
chooses "who sees what". Guest members will receive only those files they are allowed to see. 

Component insertion: Afterwards, each member can add his own components in the shared document, having previously determined the 
permissions of other participants.

 
Host -> Guest
●     The host decides to hide, show or share his/her opened documents

●     Guests receive information about the host protected or public documents

●     Guest can download shared documents from the host session

Guest -> Host
●     Every member decides to hide, show or share his/her opened documents

●     The host receives information about Guests' protected (shown) or public (shared) documents

●     The host can download shared documents form the guests' sessions

 
 

Sharing Documents

At the bottom of the Document page, the upper line is meant to read as a sentence indicating your intention with regards to document 
sharing, e.g. "Set selected components visible for Jean Dupont".

1.  Click Set selected components combo-selection button and select the desired mode from the proposed list.

2.  Click the for combo-selection button and select the intended recipient of the share action from the proposed list.

3.  Click the Share button. 

The selected documents will now change to status Visible for the indicated recipients.
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Loading Shared Documents

At the bottom of the Document page, the lower line is meant to read as a sentence indicating your intention with regards to document 
loading, e.g. "Set selected components to load".

1.  Click Set selected components combo-selection button and select the desired mode from the proposed list.

2.  Click the Load button. 

The selected documents change to status Loaded and are inserted into the participant's DMU session.
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Document visibility modes
●     Invisible: the local documents are in a hidden state for the other participants

●     Visible: the documents can be downloaded by the other participants. If download is requested (Load selected components), both the 
document and its representation are downloaded.
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Transferring Files

Files can be transferred between users during the conference. This enables you to perform conferencing on VPM data, as one member of a conference 
can transfer the necessary PSN file that will enable another member of the conference to visualize the same ENOVIAVPM data. 

Note: Both users must have access to a VPM database. 
 

In the Send area of the File Transfer page, the Sender:

1.  Clicks on the To selection button and chooses the intended recipient from the proposed list of conference members.

2.  Enters the file name in the File text-entry field or clicks the Browse button to select the file by browsing his directories.

3.  Presses the Send button to send the file to the intended recipients.

 
 

 
In the Receive area of the File Transfer page, each Recipient:

4.  In order to specify the location at which he wishes to place the sent file, he enters the directory name in the Directory: text-entry field or clicks the Browse 

button to select the directory by browsing his directories.

5.  Presses the Accept button to accept the file at the specified location.
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Sending Messages to other Conference Participants

You can send messages to the other conference participants. 
 

1.  In the Conferencing dialog box, click the the Chat tab.

The Chat page is displayed.

2.  To send a message:

●     type the message in the Message text-entry field

●     click the To selection button and select the desired recipient of your message from the proposed list 
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Customizing Conference Options

The Options page enables you to manage conference settings. 

1.  In the Conferencing dialog box, click the the Options tab.

The Options page is displayed.
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Consulting Conference History

The History page provides a list of certain actions performed throughout the conference.

1.  In the Conferencing dialog box, click the the History tab.

The History page is displayed.
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Leaving a Conference

Any participant (host and guests) can leave the conference at any time. If the host leaves the conference, the conference is terminated for everyone.  
 

 
1.  To leave a conference, in the menu bar, select Tools -> Conferencing -> Stop.

The Conferencing dialog box is closed, you have left the conference.
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Managing Applicative Data 

Importing Applicative Data from an Inserted Component 
Importing Applicative Data from a Document in Session 

Reordering Applicative Data
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Importing Applicative Data from an Inserted Component

 

This task shows you how to insert applicative data from an inserted document. 

 You can now choose to always create imported applicative data in a DMU Review at highest level. See Customizing DMU Navigator, DMU Navigator.

When you insert a CATProduct, you can now recuperate its associated applicative data (see Customizing DMU Navigator, DMU Navigator for options to 
manage the insertion of applicative data).

One of the three results will occur when you insert a CATProduct containing applicative data:

●     if the option to import applicative data was not chosen in the DMU Navigator Settings, then no applicative data will be inserted when you click OK to insert 
your document in step 5 above.

●     if the option to import applicative data was chosen and the option to automatically insert all applicative data was chosen, then all applicative data will be inserted.

●     if the option to import applicative data was chosen and the option to present a user prompt was chosen, then a dialog box like the following will appear:

1.  To de-select any of the applicative data subsets or items, click the appropriate checkbox. 

2.  Click OK to confirm. 

The applicative data will be inserted in the form of a Review (to manage a Review, see DMU Review).

 Importing applicative data at a later moment 

3.  Click Cancel in the Import applicative data dialog box. 

The CATProduct will be inserted, but no applicative data will be imported. 

4.  At a later moment, select Edit  >  Import applicative data. 

The Import applicative data dialog box appears. You de-select the applicative data as above.

5.  Click OK to confirm. 

The selected applicative data will be inserted in the form of a Review.

For each CATProduct inserted containing applicative data, a review will be created to embed the newly inserted applicative data:

●     If the inserted CATProduct contains reviews, they will be copied and linked under R1.

●     If there is an active review when inserting the CATProduct, R1 will be created under that review. If not, R1 will be created at the review root level.

●     The life cycle of copied applicative data is linked to the review.

The importing of applicative data is one-shot only. 

The imported applicative data is a simple copy of the applicative data of the inserted component. Any subsequent modifications to the applicative data of 
the original document will not be reflected in the applicative data imported during the insert component command. 
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Imported applicative data can be re-ordered. See Reordering Applicative Data.

For a list of the types of applicative data that can be inserted, see About DMU Review, Applicative data that can be created in a DMU Review.   
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Importing Applicative Data from a Document in Session

 

This task shows you how to insert applicative data from a document in session. 

 You can now choose to always create imported applicative data in a DMU Review at highest level. See Customizing DMU Navigator, DMU Navigator.

1.  In the Insert menu bar, select Import Applicative Data. 

The Document selection dialog box appears.

 

2.  Click the selection button and select the document from which you wish to import applicative data from the proposed list.  

The Import applicative data dialog box appears, proposing the different applicative data that can be imported.

3.  To de-select any of the applicative data subsets or items, click the appropriate checkbox. 

4.  Click OK to confirm. 

The Mapping table dialog box is displayed. 

All the target links that have been automatically found are displayed.
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5.  You can fill in missing links or modify links by selecting the requested line and then clicking on the desired component, in the 3D or Specification Tree. Note 

that all applicative data selected in step 7 will be imported, even if there are missing links to the target product (i.e. you left some links unselected in 

the mapping table). 

 
The applicative data will be inserted in the form of a Review (to manage a Review, see DMU Review).

●     The log file is optionally activated by clicking the Log file checkbox. You can specify the path by clicking the "..." icon and navigating to the desired directory.

●     Import Applicative Data functionality may give improper result, if you are not using the same product structure in source and target product.
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Reordering Applicative Data 

Reordering applicative data enables you to manually reorder applicative data entities under their respective application node 
in the specification tree. 

Applicative data reordering is applicable to the following types of applicative data:

●     Annotated Views

●     Hyperlinks

●     Cameras

●     Groups

●     Lights

●     3D Annotations

●     Scenes

●     DMU Reviews

You can now select a multiple number of entities to be displaced, thus enabling you to reorder your applicative data more 
efficiently. Note that all multi-selected entities must be contiguous. 
 

 Scripts for applicative data reordering can be written using VBScript. 
 
Insert the following cgr files:

BODY_1_2.cgr 
BODY_2_2.cgr 
 

1.  Create four 3D Annotations.

2.  Expand the Applications node in the specification tree. The four annotations are represented as follows: 

 

3.  Either select the 3D Annotations category in the specification tree or any one of the annotations, e.g., Text.1 and 

click Applicative Entities Reordering  or,  

click Applicative Entities Reordering  and select the 3D Annotations category in the specification tree or 

any of the annotations. 

 
The Graph Tree Reordering dialog box appears. 
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4.  To move the Text.1 entity down in the list, press the down arrow . The Text.1 entity is swapped with the 

entity that was below it, Text.2. 

 

 
 

5.  To move the Text.4 entity up in the list, select the Text.4 entity and press the up arrow . The Text.4 

entity is swapped with the entity that was above it, Text.3. 
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6.  To move the Text.3 entity to an arbitrary place in the list, select the Text.3 entity, click the displace arrow  

and select the entity under which the Text.3 entity will now appear (e.g. Text.2).   

 
The Text.3 entity is placed under the Text.2 entity and all the entities that will be below it are moved down one 

position. 

 

 
 

7.  To save the modifications you have made to the ordering of the entities, click Apply.

8.  To change the applicative data category, click the selection button and choose the desired category from the list. 
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Note that you must have saved any modifications made to the ordering as in step 7 before you change 
categories, otherwise you will lose your modifications.

 

9.  To exit the dialog box without saving the modifications you have made to the ordering of the entities, click Cancel.

10.  To save the modifications you have made to the ordering of the entities and exit the dialog box, click OK.
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DMU Data Flow Processes

 

About DMU Data Flow Processes

Sharing a Mock-up with another Site: Select View  >  Commands List in the menu bar, select  DMUCacheExport  from 
the proposed list and click OK.

Studying a Variant: Select View  >  Commands List in the menu bar, select  SaveAsFrozen  from the proposed list and 
click OK.

Preparing a Design Review: Select View  >  Commands List in the menu bar, select  SaveAsFrozen  from the 
proposed list and click OK.

Archiving a CATProduct and related documents: Select View  >  Commands List in the menu bar, select  
SaveAsFrozen  from the proposed list and click OK.

Sharing a Stand-alone Light Copy of a Mock-up: Select View  >  Commands List in the menu bar, select  
SaveAsFrozen  from the proposed list and click OK.
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About DMU Data Flow Processes 

DMU Data Flow is a set of methodologies, tools and customizations that supports the necessary flow of data between 
applications during the following DMU industrial processes:
●     Design review (preparation, presentation, conferencing)

●     Packaging

●     Management follow-up

●     Documentation

●     Data administration

Tools in DMU Navigator supporting DMU Data Flow processes

The following are the current tools in DMU Navigator that support DMU Data Flow processes:

●     SaveAsFrozen command (see Studying a Variant, Preparing a Design Review, Archiving a CATProduct and Related 
Documents, Sharing a Stand-alone Light Copy of a Mock-up, Sharing a Mock-up with another Site)

●     DMUExport command (see Sharing a Mock-up with another Site)

●     DMUImport command (see Sharing a Mock-up with another Site)

●     CATDMUUtility batch process

●     CATDMUCacheSettings batch process

●     CATDMUBuilder batch process

●     CATDMUCacheLocator batch process

●     CATDMUDistributor batch process

●     CATDMUSaveAsFrozen batch process

 
 

DLName support

Directory options can be defined using DLNames, with the exception of cache directory definitions. For more information 
on DLNames, see the Infrastructure Guide, Administrating Data Using the DLName Mechanism.

VBScript support

Scripts can be written using VBScript for all DMU Data Flow processes.

Direct access to SaveAsFrozen, DMUExport and DMUImport commands via the 
Menu Bar

In the menu bar, select Tools  >  DMU Data Flow  >  SaveAsFrozen (or DMUCacheExport or DMUCacheImport).
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Save as Frozen 

Limitations

 When using the Save Products and data or Save Products, data and cache options, models and CATParts coming 
from a PDM are saved only if they are in design mode. If they are not in design mode, then the product might still point 
to data in the database. 
 

 

Save as Frozen does not save Technological Packages. Therefore, when a product referencing Technological Packages is 
saved using the Save As Frozen command, the Technological Packages in the session become unusable. It is 
recommended that you close the product and re-load it from the Save As Frozen result to continue working.  
 

 The Save As Frozen command does not add the prefix to the beginning of names of CATParts.

 
A product can be saved if and only if all documents to which it points are up-to-date (not dirty). If you modify a part 
belonging to the assembly, the Save As Frozen command will save the modified part on disk (and not in the database, if 
the data has been opened from a database) in order to save the product.

  

 

Save as only One Product 

Save as only one product is a new option that resolves links to external products and saves the result as one product 
containing all concerned components. 

This option is available when using the SaveAsFrozen command in the following DMU Data Flow processes:

●     Sharing a Mock-up with another Site

●     Studying a Variant

●     Sharing a Stand-alone Light Copy of a Mock-up 

 
Limitations

●     The Save as only One Product option does not take into account Instance data (e.g. graphic attributes and 
component flexibility). Only the Reference data is considered.

●     The Save as only One Product option cannot treat products having applicative data (DMU applicative data, 
constraints, tolerancing, etc.).

●     When a File-based or Blackbox product contains applicative data and the chosen option is Save as only One Product, 
an error message is displayed and the save is performed as when the chosen option is Save Products.
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Sharing a Mock-up with another Site  

The objective is to send a minimum quantity of data necessary in order for those working on the receiving end to 
work on the mock-up. 

The cache must be activated if you wish to export cache entities. To activate the cache system, see Activating the 
Cache.

 
1.  The sender builds the mock-up in a CATProduct. 

2.  The sender invokes the DMUCacheExport  command in order to copy the data of the mock-up onto a 

directory A: 

In the menu bar, select Tools  >  DMU Data Flow  >  DMUCacheExport.

 

The DMU Export dialog box appears.

  

3.  In the Save in text-entry field, enter the path of the directory in which you wish to save the data or click 

the Browse button to navigate to the desired directory.

4.  In the With the prefix text-entry field, enter a prefix that will distinguish your exported data from the 

actual data.

5.  Click the selection button and choose either Save Products or Save Products and data from the 

proposed save options list.
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6.  Click the OK button to confirm. 

 
Note: The name of the active window will now be prefixed by the string you designated in the above dialog 

box.

 
 When using the Save Products and data or Save Products, data and cache options, models and 

CATParts coming from a PDM are saved only if they are in design mode. If they are not in design mode, 
then the product might still point to data in the database.

 
7.  The sender sends the (flat) content of the directory A to the receiver.

8.  The receiver puts the (flat) content on a directory B. 

9.  The receiver invokes the DMUCacheImport command to build his environment from the content of the 

directory B:

In the menu bar, select Tools  >  DMU Data Flow  >  DMUCacheImport.

 

The DMU Import  dialog box appears.
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10.  In the Search in text-entry field, specify the directory from the mock-up is to be imported (the directory B 

mentioned above in step 9) or click the Browse button to navigate to the desired directory.

11.  Click OK to confirm.

 

The mock-up is imported into your local cache.

 This scenario imposes modifications on the receiver environment : he has to work without timestamp verification. 
On the other hand, the sent mock-up can be sent back to re-enter the design process. 
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Studying a Variant

The objective is to study a variant of a mock-up design in order to fix an incident without impacting the original 
design. It must be possible to load the original design and the associated variants in the same session.

Note the following limitations concerning the use of the Save as Frozen command.

 
1.  The user builds the mock-up in a CATProduct.

2.  The user invokes the SaveAsFrozen  command in order to duplicate the mock-up on a directory A, 

modifying the data names with a prefix: 

 

In the menu bar, select Tools  >  DMU Data Flow  >  SaveAsFrozen.

 

The SaveAsFrozen dialog box appears. 

 

3.  In the Save in text-entry field, enter the path of the directory in which you wish to save the data or click 

the Browse button to navigate to the desired directory.

4.  In the With the prefix text-entry field, enter a prefix that will distinguish your exported data from the 

actual data.

5.  Click the selection button and choose Save Products from the proposed save options list. 
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6.  Click OK to confirm.

The active window becomes that of the variant you've just created. 

Note: The name of the active window will now be prefixed by the string you designated in the above dialog 

box. 
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Preparing a Design Review

The objective is to save a given state of a mock-up on a high-end workstation in order to present all detected 
incidents to project leaders. It is crucial that none of the modifications done after the above save will impact the 
saved mock-up. It must be possible to load the exact data during the design review. 
 

The cache must be activated. To activate the cache system, see Activating the Cache. 
 

Note the following limitations concerning the use of the Save as Frozen command.

 

 

 

 

 

1.  The user builds the mock-up in a CATProduct.

2.  The user invokes the SaveAsFrozen  command in order to duplicate on a directory A on another 

workstation:

In the menu bar, select Tools  >  DMU Data Flow  >  SaveAsFrozen.

 

The SaveAsFrozen dialog box appears. 

 

3.  In the Save in text-entry field, enter the path of the directory in which you wish to save the data or click 

the Browse button to navigate to the desired directory.

4.  In the With the prefix text-entry field, enter a prefix that will distinguish your exported data from the 

actual data.

5.  Click the selection button and choose Save Products, data and cache or  

Save Products and cache from the proposed save options list. 
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 Note: It is important that the location of the local cache corresponds to the  directory indicated in the 
Save in text-entry field. 

6.  Click OK to confirm. 

 
Note: The name of the active window will now be prefixed by the string you designated in the above dialog 

box.

7.  The speaker of the design review meeting loads the new CATProduct to start his presentation. 
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Archiving a CATProduct and Related Documents

The objective is to archive a given state of a mock-up including its design data.

Note the following limitations concerning the use of the Save as Frozen command.

 

 

 

1.  The user builds the mock-up in a CATProduct.

2.  The sender invokes the SaveAsFrozen  command in order to archive the data of mock-up on a directory 

A:

In the menu bar, select Tools  >  DMU Data Flow  >  SaveAsFrozen.

The SaveAsFrozen dialog box appears. 

3.  In the Save in text-entry field, enter the path of the directory in which you wish to save the data or click 

the Browse button to navigate to the desired directory.

4.  In the With the prefix text-entry field, enter a prefix that will distinguish your exported data from the 

actual data.

5.  Click the selection button and choose Save Products and data from the proposed save options list. 
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6.  Click OK to confirm. 

The mock-up is archived to the designated directory.  

 
Note: The name of the active window will now be prefixed by the string you designated in the above dialog 

box.
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Sharing a Stand-alone Light Copy of a Mock-up

The objective is to send a minimum quantity of data necessary for those working on the receiving end to work on 
the mock-up without changing their environment. 
 
The cache must be activated. To activate the cache system, see Activating the Cache. 
 

Note the following limitations concerning the use of the Save as Frozen command.

   

1.  The sender builds the mock-up in a CATProduct.

2.  The sender invokes the SaveAsFrozen  command in order to copy the data of the mock-up on a directory 

A: 

 

In the menu bar, select Tools  >  DMU Data Flow  >  SaveAsFrozen.

 

The SaveAsFrozen dialog box appears. 

 

3.  In the Save in text-entry field, enter the path of the directory in which you wish to save the data or click 

the Browse button to navigate to the desired directory.

4.  In the With the prefix text-entry field, enter a prefix that will distinguish your exported data from the 

actual data.
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5.  Click the selection button and choose Save Products linked with cache from the proposed save options 

list. 

 

6.  Click the OK button to confirm. 

 
Note: The name of the active window will now be prefixed by the string you designated in the above dialog 

box.

7.  The sender sends the (flat) content of the directory A to the receiver.

8.  The receiver puts the (flat) content on a directory B.

9.  The receiver loads the CATProduct from the directory B to build the mock-up.

 

 The copy of the mockup in the specified directory A will contain: 

●     for references to models and CATParts, a copy of the corresponding cgr copied from the cache 

●     for references to cgrs, a reference to the original cgr (the cgr is not copied to the directory A)    
 

 Note : This scenario is the same as Share a mock-up with a distant site scenario, except that environment 
modifications are not required. On the other hand, the sent mock-up is a dead-end : it cannot re-enter the design 
process. 
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Running Batch Processes

 

Running the CATDMUUtility Batch Process 
Running the CATDMUUtility2d Batch Process 

Running the CATDMUCacheSettings Batch Process 
Running the CATDMUCacheLocator Batch Process 
Running the CATDMUCacheManager Batch Process 

Running the CATDMUBuilder Batch Process 
Running the CATDMUDistributor Batch Process 

Running the CATDMUV4CacheForV5 Batch Process 
Running the CATDMUSaveAsFrozen Batch Process 

 

 

3D Insight Version 5 Release 19 Page 784 of 1379



Running the CATDMUUtility  
Batch Process 

The CATDMUUtility is a batch process enabling the generation of cgr, 3dmap, hcg, wrl and NCGM formats from a CATIA file or from a MULTICAD file. It can 
also process files accessed in a PDM database, e.g. ENOVIAVPM or ENOVIA V5 VPM.  

All paths indicated in the CATDMUUtility command line must be absolute paths. 

When using input data that contains references to a PDM system, it is imperative that you be connected to that PDM system while the CATDMUUtility process 
is running. 

The -NavRep option enables you to generate Navigation Representations.

 The -3dxml option enables you to generate 3D XML files for CATParts.

1.  Prepare the Input file defining conversion parameters.

A typical computation parameters file looks like this: 
 
Example 1:

CATDMUUtility -f inputfile -cgr outputfile1 [-nolod] [-sag value] [-3dmap outputfile2] [-vox value2] [-unit value3] 

Example 2: 

CATDMUUtility   -l inputliste   -db VPM  -user username  -pwd password -server servername  
-cgr -cache 

Example 3: 

 CATDMUUtility   -l inputliste -cgr  -wrl  -cache   

Example of input file:

●     Under WINDOWS 

"e:\New A\CRIC_BRANCH_1.CATPart" 
e:\B15doc\online\dmnug\samples\CRIC_BRANCH_1.CATPart 
e:\B15doc\online\dmnug\samples\GARDENAATOMIZER.model 

 

●     Under UNIX

/usr/B05doc/online/dmnug/samples/CRIC_BRANCH_1.CATPart
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It is possible to use DLNames. The use of a DLName is indicated in the CATDMUUtility by the following string:  CATDLN:// 

Examples:

UNIX: 

●     CATDMUUtility -f CATDLN://TEST/model.model -cgr -cache

Windows:

●     CATDMUUtility -f CATDLN://TEST\model.model -cgr CATDLN://model.cgr

●     CATDMUUtility -f CATDLN://TEST\model.model -cgr e:\tmp\model.cgr

 DLNames are supported for CATIA file definition in the CATDMUUtility. For more information on DLNames, see the Infrastructure Guide, Administrating 
Data Using the DLName Mechanism.

 However, DLNames are supported only for CATIA files, i.e. in order to indicate a .txt file as an input parameter, it is necessary to supply an absolute path, e.g. 

CATDMUUtility -l /tmp/list.txt -cgr -cache 

(CATDMUUtility -l CATDLN://TEST/list.txt -cgr -cache would not work.)

 The .txt file, of course,  can contain DLNames, e.g. 

CATDLN://TESTDLN/model.model  
/tmp/users/mypart.CATPart  
CATDLN://DLN/mycgr.cgr

 

Note: Special characters [] identify optional parameters. 
Please find below the different options available input, output: 

 

If you specify an extension in the output file name which isn't the correct extension for the output  
option used, the correct extension is added to the output filename. The only exception to this feature is the -box output option, with which you can choose 
any extension you wish.

Example:  
  If you type: CATDMUUtility -f .../MyPart.CATPart -cgr .../MyResult.CATPart 
  the resulting output file will be: .../MyResult.CATPart.cgr 
 

 
Input Options

-f      : Input file with appropriate extension. A path must follow the option.  

It is now possible to convert a V4 cgr file to a V5 cgr file. The -f input file should be a V4 cgr file and the -cgr output file should specify the name of what will 
be the new V5 cgr file. The -f option is mandatory,  the -cache option cannot be used for the conversion of cgr files.  
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 -l      : Input list of model with -f, or database identifiers with -db option (note: the -cache option is mandatory in case the database identifiers are used). 

 -db  : Input database type: For processing data stored in a PDM database. For details on using the -db option, see Accessing Data in a PDM Database.

It is mandatory to use either: 

●     the -l option

●     for database type ENOVIAVPM, the -coid, -compid, -catenv and -cattab options

●     for database type ENOVIA V5 VPM, an appropriate identifier

You cannot use the -f option with the -db option.

Generic example for CATDMUUtility: 

CATDMUUtility -db VPM -user $user_db -pwd $pwd_db -server $server_name -coid $coid_nb -compid $compid_nb -cattab $table_name -catenv $env_name -
cgr (if you want to tessellate into a cgr) $output_file_path or -cache (if you want the outputfile to be placed in the cache) 

 

 -coid : Input identifier of the ENOVIAVPM data to convert.  
            The -db, -compid, -catenv and -cattab options are mandatory.

-compid : Input identifier of the ENOVIAVPM data to convert.  
                  The -db, -coid, -catenv and -cattab options are mandatory.

-catenv : Input identifier of the ENOVIAVPM data to convert.  
                 The -db, -coid, -compid and -cattab options are mandatory.

-cattab : Input identifier of the ENOVIAVPM data to convert.  
                The -db, -coid, -compid and -catenv options are mandatory.

 

 
Output Options

 -cgr        : Output file for cgr corresponding to the input file. A path must be indicated after the option. If no output file name is mentioned, output file will 
be generated in input file directory. 

 -jpg        : Output file for jpg corresponding to the input file. The input file can be of format CATPart, model or cgr. This option cannot be used with -db, -
cache or -mp options. If no output file name is mentioned, output file will be generated in input file directory.

 The following options are now available for specifying jpg output. These options can only be used with the -jpg option. 

-xsize : Specifies the horizontal size of the generated jpg file in pixels. An integer value is required. 
-ysize : Specifies the vertical size of the generated jpg file in pixels. An integer value is required.

Note: The default jpg size is 140 pixels * 120 pixels. Accordingly, if only one of the two parameters is specified, the other parameter be valuated to its 
default size.

-camera : Specifies the camera (viewpoint) used to generate the jpg file. A camera name is required. The specified viewpoint can be a standard view or 
a camera. A viewpoint name containing blanks should be surrounded by quotation marks, e.g. -camera "* iso".

Examples:

-camera "* iso" 
-camera "Camera 1"

-viewmode : Specifies the view mode {shading, shadingedges, wireframe, material}. A mode name is required.

- shading for display shading representation  
- shadingedges for display shading with edges representation 
- wireframe for display wireframe representation  
- material for display material representation

-bk : Specifies the background color of the generated jpg file. The color can be either white of the background color currently defined via Tools  >  Options 
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 >  General  >  Visualization:

Examples:

-bk 0 (specifies the currently defined background color) 
-bk 1 (specifies a white background)

 -hcg        : Output file for hcg corresponding to the input file.  A path must be indicated after the option, if no path is specified the output will be written 
into  the cache by using -cache option. If no output file name is mentioned, output file will be generated in input file directory.

 -NCGM  : Output file for NCGM corresponding to the input file. A path must be indicated after the option, if no path is specified the output will be written 
into the cache by using the  
-cache option. If no output file name is mentioned, output file will be generated in input file directory.

 -3dmap : Output file for 3dmap corresponding to the input file. A path must be indicated after the option,  if no path is specified the output will be written 
into the cache by using -cache option. If no output file name is mentioned, output file will be generated in input file directory.

 -wrl      : Output file for vrml corresponding to the input file. A path must be indicated after the option,  if no path is specified the output will be written into 
the cache by using -cache option. If no output file name is mentioned, output file will be generated in input file directory. Note: In batch mode, as there is 
no editor, the wrl file will not contain any viewpoints.

 -product : Output file for CATProduct documents generation from an assembly (MultiCAD or CATIA). The linked documents will be computed  if -cgr, -
3dmap ... options are specified. 
 
Example:   

CATDMUUtility -f E:\Assembly.asm -product E:\Assembly.CATProduct -cgr -cache 

 -box : Switch to generate the bounding box corresponding to the input file. The -f option is mandatory. If the input file is not a cgr file, then the -cgr option 
is necessary. This option is not compatible with the -cache option.

Examples: 

CATDMUUtility -f e:\tmp\mycgr.cgr -box e:\tmp\mycgr.cgr

 

 -vps : Output file for vps corresponding to the input file.

The voxel size value can be specified using the –vox option. If the option –vox is omitted, the voxel size value will be retrieved from the CATSettings 
(default value = 5mm). The minimum voxel size value is 1mm.

The vps files accuracy can be specified using the –vpssag option. If the –vpssag option is specified, vps files are generated with the voxel size and 
triangle accuracy. If the option is omitted, computation is performed with only voxel size.

Example:

CATDMUUtility -f e:\tmp\mypart.CATPart -vps –vox 10 –cache -vpssag

 -3dxml : Output file for 3D XML. The generation of a 3D XML file is only possible for input file of type .CATPart.

Example:

CATDMUUtility -f e:\tmp\mypart.CATPart -3dxml –cache
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 -NavRep        : Output file for Navigation Representations corresponding to the input file. A path must be indicated after the option. If no output file name 
is mentioned, output file will be generated in input file directory (NavReps cannot be generated into the cache). It is possible to use CATProducts and 
CATParts both from file and database. 

 
Computing Options

-mp      : CATDMUUtility batch will be launched in multi-process mode. Multi-process parameters must be set in : Tools  >  Options  >  Digital MockUp 
 >  Multiprocess Settings. The -l and -cache options are mandatory.  

Example: CATDMUUtility -l e:\tests\lists\list1.txt -cgr -cache -mp

 -timeout :  -timeout time: set the time out. After this time, child processes will be killed, on the assumption that they've entered a CPU loop. Available 
with multi-process mode (-mp) only. 
 

-process number_of_processes : set the number of child processes. Available with multi-process mode (-mp) only.

 -filter :  -filter <filter.txt> : . This option is only available if the input file is a model, CATPart or CATProduct. The output file must be a cgr, wrl or hcg. The 
file filter.txt is a list of filter rules. See Using Visualization Filters.

 -apps : Enables eventual access to V4 comment pages and V4 layers and filters in visualization mode : {com | lnf} 

The type of appended data must follow the -apps option:

●     com for V4 comment pages

●     lnf for V4 layers and filters

●     all for V4 comment pages, layers and filters

The -cgr and -cache options are mandatory.

 
-vox  : Switch to generate 3map with a specified voxel value. Its use is mandatory after -3dmap option. A float value is required. 
 -sag   :  Optional switch to generate cgr with a specified sag value. A float value is required. Default value is defined in the settings. 

Note: The sag option does not work with certain V4 models (e.g. solids). 
 

 -sagon: Optional switch enabling you to re-generate a cgr with a specified sag value. A float value is required. Available only with the -cache and -sag 
options. Works only for input files that are .CATPart or .model. The default value is defined in the settings.  
Previously, if you modified the sag value, the cgr was not updated in the cache.

Example:

CATDMUUtility -f e:\tmp\model.model -cgr -sag 0.2 -cache  
Then CATDMUUtility -f e:\tmp\model.model -cgr -sag 0.4 -cache  
In the cache, you would find your cgr still had a sag value of 0.2. 

Now, if you modify the sag value using the -sagon option, CATDMUUtility will take the new value into account. 
CATDMUUtility -f e:\tmp\model.model -cgr -sag 0.4 -sagon -cache  
In the cache, you will find your cgr now has a sag value of 0.4
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  -keepsag: Activate this switch to re-tessellate a cgr, keeping the same sag value. The -force option is mandatory when using -keepsag.  You should not use 
-sag option with -keepsag.

If cgr doesn't exist, it is created with default sag value ( settings ). 

Examples : 

CATDMUUtility -f e:\tests\CATPart\cylinder.CATPart -cgr e:\tmp\keepsag.cgr -keepsag -force  
CATDMUUtility -f e:\tests\CATPart\cylinder.CATPart -cgr -cache -keepsag -force  
CATDMUUtility -l e:\tests\list\list.txt -cgr -cache -keepsag -force

 -nolod  : Optional switch to generate CGR without Level Of Detail (LOD) 

 -unit      : Optional switch to compute in the appropriate unit { mm, cm, m, inch, foot } 
Default value is input millimeter : mm 

 -cache  : Optional switch to generate files directly in the cache directory (note: this option is mandatory if you are using the -l option).

 -log: Store all the error messages in a log file. If no log file is specified, CATDMUUtility creates one in the temporary directory 

Examples : 

CATDMUUtility -f e:\tmp\model.model -cgr -cache -log e:\tmp\logfile.txt CATDMUUtility -f e:\tmp\model.model -cgr -cache -log

 -force: Rebuild the output file if the option is activated (You have generated an output file, and you want to update it : use the -force option) Limitation : 
Only available with -cache option 

Examples : 

Test 1 : CATDMUUtility -f e:\tmp\model.model -cgr -cache  
It generates a cgr file in the cache, (at 12h00min). 
Then : CATDMUUtility -f e:\tmp\model.model -cgr -cache -force  
It rebuilds a cgr file in the cache (at 12h02min).

If the options are different, CATDMUUtility takes it into account : 

Test 2 : CATDMUUtility -f e:\tmp\model.model -cgr -sag 0.2 -cache  
This generates a cgr file in the cache, with a sag of 0.2   
Then CATDMUUtility -f e:\tmp\model.model -cgr -sag 0.6 -cache -force   
It forces the generation of a cgr file in the cache, with a sag of 0.6 

Test 3 : CATDMUUtility -f e:\tmp\model.model -3dmap -vox 20 -cache  
This generates a 3dmap file in the cache, with a voxel size of 20 mm. 
Then CATDMUUtility -f e:\tmp\model.model -3dmap -vox 10 -cache  
This forces the generation of a 3dmap file in the cache, with a voxel size of 10 mm.

Note: The contents of the input file list for the ENOVIAVPM database must be formatted as follows: 

COID1 COMPID1 CATENV1 CATAB1 
COID2 COMPID2 CATENV2 CATAB2 
... 

To use this option, make sure you work with the Cache system. For this:  

select Tools > Options > Infrastructure > Cache Management 
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For more detailed information, see the Infrastructure User's Guide, Cache Management.

2.  Run the following shell to start the batch process: 

On UNIX: 

●     Place yourself in the following directory: 
cd $install_path/code/command

●     Run the command: 
 ./catstart -run "CATDMUUtility -f inputfile -cgr outputfile1"

 

On Windows:

●     Write a shell script containing the following lines: 
cd $install_path\code\bin 
CATDMUUtility -f inputfile -cgr outputfile1

●     Run the shell.

 

Note: The $install_path is the path of the installation directory or folder. For more information on installing DMU, see the Installation User's Guide.

 

 A user interface is now available for running the CATDMUUtility batch.

1.  In the menu bar, select Tools  >  Utility. 

The Batch Monitor dialog box appears.

2.  Select the CATDMUUtility batch from the proposed list.
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A dialog box will appear in which you can enter the same information you would otherwise have entered in a line command:

●     Input documents

●     Output options

●     Output location

●     Advanced options (accessed by clicking Advanced button)

 

3.  Click the Save button to save all input data in an XML file for later use.

4.  Click the Run button to run the batch job immediately. 

5.  In the Batch Monitor dialog box, click the Processes tab to monitor the batch job execution.
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For more information on using the Batch Monitor, see the Infrastructure User's Guide, Basic Tasks, Running Batches, Running Batches Using the Batch Monitor.

 

 

  More About the Conversion Formats supported:

 

File Extensions  CONVERSION TO

   cgr 3dmap hcg hsf vps VRML CAT 
Product

CAT 
Part

CAT 
Drawing NCGM

CATIA            

.model  yes yes yes - yes yes - - - -

.CDMA.model  yes - - - - - - - - -

.cgr  - yes yes - yes yes - - - -

.CATPart  yes yes yes - yes yes - - - -

.CATProduct  yes - - yes - - yes - - -

CATPSLayout  - - - - - - yes - - -

Note: For supported Multi-CAD formats, see the sections Requirements and Methodologies and Advice in the corresponding documentation:

●     MULTICAx ID Plug-In User's Guide (IDEAS) 

●     MULTICAx PD Plug-In User's Guide (Pro/Engineer) 

●     MULTICAx UD Plug-In User's Guide (Unigraphics) 

●     MULTICAx D5 Plug-In User's Guide (DELMIA D5 Integration) 

●     MULTICAx Solidworks Plug-In User's Guide (Solidworks) 

●     MULTICAx SE Plug-In User's Guide (SolidEdge) 

●     MULTICAx AD Plug-In User's Guide (Acis/DXF3D) 

●     MULTICAx IGES Plug-In User's Guide (IGES)

●     MULTICAx STEP Plug-In User's Guide (STEP) 
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Running the CATDMUUtility2D Batch Process

 

The CATDMUUtility2D  is a batch process enabling the generation of cgm files from CATDrawing, DXF, DWG, CDD, .
model and 3D XML documents. 

Input 2d data can be file based or data based (ENOVIAVPM or ENOVIA V5 VPM). 

Output data is generated in a specified file. (Generation of output data into a cache is not supported).

 

All paths indicated in the CATDMUUtility2D  command line must be absolute paths. 

 

 The –3dxml option enables you to generate 3D XML files for CATDrawings.

1.  Prepare the Input file defining conversion parameters.

A typical computation parameters file looks like this: 
 
To retrieve help information

CATDMUUtility2D  -h

 

To export input data

CATDMUUtility2D    -id inputId -cgm outputlocation 
                                  [-sheet sheetName] 
                                  [-db VPM|ENOVIA5 -user user -spwd cryppwd -role role 
                                    -server server]

 

Windows Examples 

CATDMUUtility2D  -h CATDMUUtility2D  -id c:\u\input.model -cgm c:
\tmp\model.cgm
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Unix Examples 

CATDMUUtility2D  -h CATDMUUtility2D  -id /u/input2/model.model -
cgm c:\tmp\model.cgm -sheet Sheet.1

 
Input Options

-h     : Help. 

-id inputID  : The input identifier can be of type .model, CATDrawing, dxf, cdd or  dwg. It can also be:

●     a path (eventually a DLName preceded by 'CATDLN://')

●     a data base identifier (ENOVIAVPM or ENOVIA V5 VPM)

 

-db  Input database type : For processing data stored in a PDM database.

For details on using the -db option, see Accessing Data in a PDM Database.

 -sheet sheetName : To export a specific sheet from input data.

 
Output Options

-cgm        : Output file for cgm corresponding to the input file. A path must be indicated after the option. If no 
output file name is mentioned, output file will be generated in input file directory. 

 -3dxml : Output file for 3D XML. The generation of a 3D XML file is only possible for input file of type CATDrawing.

Example:

CATDMUUtility2D -id e:\tmp\mydrawing.CATDrawing -3dxml e:\tmp\mydrawing.3dxml 
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Running the CATDMUCacheSettings  
Batch Process

 

The CATDMUCacheSettings batch process functionalities are intended to set the configuration needed to work with 
the cache. This configuration can be implemented in different ways: 
●     Interactive use of CATIA or DMU Navigator

●     Interactive use of a Setting tool (equivalent to Tools Options)

●     Automation API for some parameters 

The CATDMUCacheSettings batch process provides the ability to set cache configuration in batch. 
 

On Windows, it is always necessary to specify the -env and -direnv options. Note also that these options should 
always be specified at the end of the command line. For more information, see the Infrastructure User's Guide, 
Starting a Session on Windows. 
 
 

1.  To retrieve the help information, run the command:

CATDMUCacheSettings -h 

2.  To read the current values of the cache settings, run the command:

CATDMUCacheSettings -r outputfile [-unit string] 

3.  To modify the values of the cache settings, run the command:

CATDMUCacheSettings [-r outputfile] [-a|-d] 

[-u localdir] [-g reldir1[ reldir2..]] 

[-tscheck|-notscheck] [-size value1] 

[-sag value2] [-vox value3] [-unit string] 
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Windows Examples 

CATDMUCacheSettings -h 
CATDMUCacheSettings -r c:\u\currentvalues.txt -unit INCH 
CATDMUCacheSettings -a 

Unix Examples 

CATDMUCacheSettings -h 
CATDMUCacheSettings -a -u /u/local -sag 0.1 
CATDMUCacheSettings -r /u/currentvalues -a -u /u/local -sag 0.1 

 

Arguments 

-h : Help. 

-r outputfile : To read settings (before modification if any). The command line format is used with same options. 

-a : To activate cache management. 

-d : To deactivate cache management. 

-u localdir : To define the local cache directory. 

-g reldir1 .. : To define the release cache directories. Using the -g option without any parameters will clean the 
release cache.

-tscheck : To check the time stamp. 

-notscheck : Not to check the time stamp. 

-size value1 : To define the local cache maximum size. The size is given in megabytes (mo). 

-sag value2 : To generate cgr with a specified sag value. 

-vox value3 : To generate 3dmap with a specified voxel value.

-unit string : To define the unit for length values. Note: The unit value for document storage is always MM. 

The unit can be: 

●     MM for millimeters

●     CM for centimeters

●     M for meters
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●     INCH for inches

●     FOOT for feet

By default the unit is millimeters (MM). 

 

Note that the unit value you specify affects only the values of the different parameters specified in the 
CATDMUCacheSettings command line. It does not affect the unit value specified in the general settings (Tools  >  
Options).

 

Diagnostics 

Possible exit status values are: 

●     0: Successful completion.

●     1: Failure due to any of the following:

●     missing arguments

●     invalid combination of options

●     missing parameter after an option

●     unable to find output file

●     unable to write in output file

●     invalid directory

●     2: Processing error. 

 

 Solutions per exit status value  
●     Exit status = 1: Modify the command line using information contained in the standard error file.

●     Exit status = 2: Contact you local support.
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Running the CATDMUCacheLocator  
Batch Process 

CATDMUCacheLocator locates the cache data corresponding to a list of documents. This batch process 
exists for administrators who wish to manipulate cache data.  

One mode, the default option, enables you to find the path of the file corresponding to a given cache element of the current cache. The other 
mode, the -p option, enables cache simulation and helps you to prepare copies, moves or distribution between caches. This simulation is purely 
hypothetical, it does not take into account the existence or non-existence of files in the specified cache directory. 
 

On Windows, it is always necessary to specify the -env and -direnv options. Note also that these options should always be specified at the end of 
the command line. For more information, see the Infrastructure User's Guide, Starting a Session on Windows. 
 

1.  To retrieve the help information:

CATDMUCacheLocator -h

2.  To locate the cache data:

CATDMUCacheLocator inputfile outputfile [-s char] [-t type] [-p dir]

 

Windows Examples 

CATDMUCacheLocator -h 
CATDMUCacheLocator c:\u\input.txt c:\u\output.txt 
CATDMUCacheLocator c:\u\input.txt c:\u\output.txt -p c:\cache -t 3dmap

  

Unix Examples 

CATDMUCacheLocator -h 
CATDMUCacheLocator /u/input /u/output 
CATDMUCacheLocator /u/input /u/output -p /u/cache -t 3dmap
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Arguments

-h : Help. 

inputfile : Input file containing a list of documents. Each line must contain the identifier of a 
document, a separator and the timestamp of the document. Timestamp is provided using YYYY-
mm-dd-HH.MM.SS format. If the document exists the timestamp can be replaced by the following 
string YYYY-mm-dd-HH.MM.SS (Note: If no timestamp is supplied, the default used will be 1970-01-

01-00.00.00).

outputfile : Output file that will contain the list of documents cache location. Each line will 
contain the identifier of a document, a  separator and the location of the cache data corresponding 
to the document.

-s char : To define the character used to separate field on a line within input or output file. By 
default blank character is used.

-t type : To define the type of cache (cgr, 3dmap, etc.). By default cgr is used.

-p dir : To define the cache directory to use instead of a directory from the settings. In this case, 
the directory can be a non-existing or a non accessible one, thus the files given in the list.

Diagnostics 

Possible exit status values are: 

●     0: Successful completion.

●     1: Failure due to any of the following:
�❍     license not available

�❍     cache management deactivated

�❍     missing arguments

�❍     invalid parameter

�❍     missing parameter after an option

�❍     missing input file

�❍     unable to find a file

�❍     unable to open an input file

●     2: Processing error. 

Solutions per exit status value  
●     Exit status = 1: Modify the command line using information contained in the standard error file.

●     Exit status = 2: Contact you local support.
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Running the CATDMUCacheManager  
Batch Process

The CATDMUCacheManager Utility is intended to list the content of one cache directory in order to perform several tasks in batch mode, e.g. 
purge, update and  purge least-recently-accessed files. 

Shells to perform the necessary operations will have to be written by customers based on the output of this utility.

The CATDMUCacheManager utility: 

●     Searches all cache data located in a given directory 

●     Retrieve their timestamp 

●     Seeks the related original 

●     Purges oldest files

 

On Windows, it is always necessary to specify the -env and -direnv options. Note also that these options should always be specified at the end of 
the command line. For more information, see the Infrastructure User's Guide, Starting a Session on Windows. 

1.  To retrieve the help information, run the command:

CATDMUCacheManager -h 

2.  To retrieve the content of a cache directory, run the command:

CATDMUCacheManager -content file [-g cachedir]  

[-s char] [-t type] 

3.  To purge a cache directory, run the command:

CATDMUCacheManager -purge value
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Windows Examples 

CATDMUCacheManager -h  
CATDMUCacheManager -content c:\u\output.txt  
CATDMUCacheManager -content c:\u\output.txt -t 3dmap  
CATDMUCacheManager -purge 10

Unix Examples 

CATDMUCacheManager -h  
CATDMUCacheManager -content /u/output  
CATDMUCacheManager -content /u/output -t 3dmap  
CATDMUCacheManager -purge 10

 

Arguments 

-h : Help. 

-content file : Output file that will contain the list of cache files. Each line will contain the identifier of the cache file, a separator, the identifier of 
the original file, a separator and the time-stamp using YYYY-mm-dd-HH.MM.SS format. 

-g cachedir : The cache directory to scan. If the -g option is specified but no directory parameter is specified, the local cache is used by default.

-s char : The character used to separate fields on a line of the input or output file. By default, the blank character is used. 

-t type : To define the type of cache (cgr, 3dmap, etc.). By default, cgr is used. 

-purge value : To purge the cache directory to a specified size (value). The size is given in Megabytes (Mo).

Diagnostics 

Possible exit status values are: 

●     0: Successful completion.

●     1: Failure due to any of the following:
�❍     license not available

�❍     cache management deactivated

�❍     missing arguments

�❍     invalid parameter

�❍     missing parameter after an option

�❍     unable to find output file

�❍     unable to open output file

●     2: Processing error. 
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Solutions per exit status value  
●     Exit status = 1: Modify the command line using information contained in the standard error file.

●     Exit status = 2: Contact you local support.
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Running the CATDMUBuilder 
Batch Process 

The CATDMUBuilder is intended to save DMU loading time by: 
●     Feeding the cache with tessellated data corresponding to given product structures

●     Creating CATProducts corresponding to these product structures and storing them on dedicated local directories

●     Using local machine resources when they are not used (night, week-end)

This capability fills the local cache with all necessary data to avoid tessellation or access to the PDM cache during interactive 
loading of given product structures. This loading will use only the local and release cache. 
 
The extracted CATProducts allow the user to quickly load working or predefined session without mandatory PDM connection while 
working in visualization mode. The loading of these CATProducts will benefit from the cache feeding.  
 
The product structure file can be any one of the following:  

●     a product (*.CATProduct) 

●     a Dynamic PSN (*.psn)

●     the identifier of an ENOVIAVPM node (*.CATVpm)

●     a Multi-CAD assembly 

●     a Navigator 4D file

●     a Clash file (*.xml)  Important: The interferences described in the xml file must point to a VPM V4 product structure and you 
must be connected to VPM V4. Interferences described in the xml file pointing to product structures in file format or to VPM V5 
product structures are not supported.

DLNames are now supported for the CATDMUBuilder batch process.

CATDMUBuilder can now generate 3D XML files.

When using input data that contains references to a PDM system, it is imperative that you be connected to that PDM system while 
the CATDMUBuilder process is running. 
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●     On Windows, it is always necessary to specify the -env and -direnv options. Note that, these options should always be 
specified at the end of the command line. For more information, see the Infrastructure User's Guide, Starting a Session on 
Windows.

●     When you build a product using CATDMUBuilder with a PSN file and the selected instances option, all documents attached to 
Parts on the branches of the selected leaves are taken into account. 
 

1.  To retrieve the help information, run the command:

CATDMUBuilder -h 

2.  To feed data to the cache, run the command:

CATDMUBuilder inputlocation 

[-user user -spwd cryppwd -role role -server srv] [-product dir] 

3.  To build the product, run the command:

CATDMUBuilder inputlocation 
-product dir -onlyone -nocache

4.  To feed the local cache, run the command:

CATDMUBuilder inputlocation -copycache

5.  To force re-calculation, run the command:

CATDMUBuilder inputlocation -force

 

Windows Examples

CATDMUBuilder -h 
CATDMUBuilder c:\u\input.txt -product c:\proddir

Unix Examples

Invoking the CATDMUBuilder help: 

CATDMUBuilder -h 

Feeding the cache with tessellated data corresponding to product structures contained in a directory /u/product

CATDMUBuilder /u/product
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Moving CATProducts corresponding to product structures contained in a distant directory /distant/product, storing them on a 
local directory /local/product and feeding the local cache:

CATDMUBuilder /distant/product -product /local/product

Feeding the cache with tessellated data corresponding to product structures contained in a directory /u/product, which refers to 
VPM documents:

CATDMUBuilder /u/product -user XXX -spwd YYY -role VPMDESIGNER  -server ZZZ

  

When using CATDMUBuilder in conjunction with ENOVIAVPM, it is necessary to first launch the ENOVIAVPM server: 

1.  When launched, the CATDMUBuilder will try to execute on the server side an ENOVIAVPM shell called 

StartVPMBatchFromV5Batch.sh . This shell name must not be changed. This shell must be in the $PATH variable of 

the ENOVIAVPM user declared in the mapping (Ex: /V15/vpmadm/code/bin).

2.  The StartVPMBatchFromV5Batch.sh shell has to be created by the ENOVIAVPM administrator and should look as 

follows:

!# /bin/ksh 
if [ -f $HOME/.profile ] ; then 
. $HOME/.profile 
fi 
. /V15/vpmadm/env/VPMWsUser.sh >/tmp/traces 2>&1 
VX0SERV >>/tmp/traces 2>&1 
 

3.  The following is an example of a command line used for treating a CATVpm file:

CATStartV5.sh -batch "CATDMUBuilder /tmp/CATVPM  
-db VPMServer -user vpmadm -spwd vpmadm -server server_name  
-role VPMADMIN -product /tmp"

where server_name is the name of the server defined in the ENOVIAVPM interoperability settings (Tools  >  Options 
 >  Infrastructure  >  Product Structure  >  ENOVIAVPM tab  >  click Database Administration icon). 
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 Arguments

-h : Help. 
inputlocation : To define the list of documents to process. It can be the path of: 

●     a file containing a list of documents. It must contain one path of document per line.

●     a directory containing documents 

Documents of the following types are treated: CATProduct, CATVpm, psn, xml. 
 
 
 

-product dir : To extract products and store them in the directory dir.  

-nocache : To run the batch without generating cache content. Note: This option has no effect when the product needs to be built 
from scratch.

-copycache : To copy all cache content from released caches to the local cache.

-force : To force re-calculation of cache content.

-onlyone dircgr : To resolve all links to external products and save the resulting product locally as one unique product.

 

-static : To open a psn file with static option (valid only for psn). By default it is open with dynamic option. 

-selins : To open a psn file with selected instances (valid only for psn). By default it is open with all instances. 

-replacebycgr dircgr : To replace all components by related cgr copied in the directory dircgr. 

-activate : To activate all shapes and save the activation state. 

-deactivate : To deactivate all shapes and save the activation state. 

-prefix prefix : To save all products with a prefix in their name.

 

 -db  : Input database type: For processing data stored in a PDM database.

For details on using the -db option, see Accessing Data in a PDM Database.
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 -mp : To enable multi-processing for product building. Multi-process parameters must be set in : Tools  >  Options  >  Digital 
MockUp  >  Multiprocess Settings.

-timeout :  -timeout time: set the time out. After this time, child processes will be killed, on the assumption that they've entered a 
CPU loop. Available with multi-process mode (-mp) only.

  
- outputformat wrl : To generate a VRML file as output. Note: In batch mode, as there is no editor, the wrl file will not contain 
any viewpoints.

 
- outputformat 3dxml : To generate a 3dxml file as output. 

CATDMUBuilder saves the geometry in the 3D XML format (Exact, Tessellation, and Compressed Tessellation) currently specified in 
the user settings (see the Infrastructure User's Guide, Compatibility, 3D XML).

  

-listcomp : To list all the components of each product. The directory will contain one text file per product, the name of which will 
be the same as the product. Each file has one component per line. 

-noreplace : During the running of the batch process, it could happen that a file has to be copied in a directory where it already 
exists. Without the noreplace option, the file will be overloaded. With the noreplace option, the file will not be  replaced.

-savedata: To save referenced data in the product directory (see -product above).

 
 A user interface is now available for running the CATDMUBuilder utility. 

1.  In the menu bar, select Tools  >  Utility. 

The Batch Monitor dialog box appears.

2.  Select the CATDMUBuilder batch from the proposed list.

A dialog box will appear in which you can enter the same information you would otherwise have entered in a line 
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command:

●     Input documents

●     Treatment: build products, prepare cache or both

●     Product options

●     Cache options

●     VPM options

●     Miscellaneous options (options for dedicated document types)

3.  Click the Save button to save all input data in an XML file for later use

4.  Click the Run button to run the batch job immediately. 

5.  In the Batch Monitor dialog box, click the Processes tab to monitor the batch job execution.

3D Insight Version 5 Release 19 Page 809 of 1379



 

For more information on using the Batch Monitor, see the Infrastructure User's Guide, Basic Tasks, Running Batches, Running 
Batches Using the Batch Monitor.
 

Diagnostics 
 
Possible exit status values are:

●     0: Successful completion.

●     1: Failure due to any of the following:
�❍     license not available

�❍     cache management deactivated

�❍     missing arguments

�❍     invalid parameter

�❍     missing parameter after an option

�❍     missing input file

�❍     unable to find a file

�❍     unable to open an input file

�❍     bad type of document

●     2 Processing error.

●     3 Partially processed.
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Solutions 
●     Exit status = 1: Modify the command line using information contained in the standard error file.

●     Exit status = 2: Contact you local support.

●     Exit status = 3: Fix the files that cause the problem: their names are contained in the  standard error file. An interactive use of 
files may inform about problem.

 

 

 

CATVpm 

The utility can open an ENOVIAVPM assembly corresponding to all nodes under a given root or a CATProduct stored as Black-box. 
This is done using a new type of document CATVpm. This document is a text file: 

●     First line: coid

●     Second line: compid

●     Third line: catenv

●     Fourth line: catab (part list or document)

●     Other lines: configuration information (one configuration handler per line) 

Example 1: a simple node 
3D3D8F8371EA6659 
3030303030303030 
VPMENV1 
PART_LIST 

Example 2: a simple node with two config handlers 
3D3D8F8371EA6659 
3030303030303030 
VPMENV1 
PART_LIST 
CONF1 
CONF2 

Example 3: a Black box 
3D3D976D89064C32 
3D3D976D89064C33 
VPMENV1 
DOCUMENT
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Running the CATDMUDistributor  
Batch Process

CATDMUDistributor copies DMU data (CATProduct, related cache data, etc.) given in a list from its 
current location to a distant location. 
On Windows, it is always necessary to specify the -env and -direnv options. Note also that these options should always be specified at the end of 
the command line. For more information, see the Infrastructure User's Guide, Starting a Session on Windows. 

1.  To retrieve the help information, run the command:

CATDMUDistributor -h 

2.  To copy DMU data from their current location to a distant location, run the command:

CATDMUDistributor inputdir cachedir docdir [-s char] 

3.  To compute a list of files to copy, run the command:

CATDMUDistributor inputdir cachedir docdir -list file [-s char] 

 

Windows Examples 

CATDMUDistributor -h 
CATDMUDistributor c:\input e:\cache e:\document

  

Unix Examples 

CATDMUDistributor -h 
CATDMUDistributor /u/input /v/cache /v/document

 

Arguments

-h : Help.

inputdir : To define the directory containing files which list documents. These files contain one 
document identifier per line.

cachedir : To define the distant cache directory.

docdir : To define the distance directory that will contain all documents except cache data.

-list file : Output file that will contains a list of documents to copy. Each line contains the path 
of original data and the path of the copy data separated by a blank.
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-s char : To define the character used to separate field on a line within input or output file. By 
default blank character is used.

Diagnostics 

Possible exit status values are: 

●     0: Successful completion.

●     1: Failure due to any of the following:

�❍     license not available
�❍     cache management deactivated

�❍     missing arguments

�❍     invalid parameter

�❍     missing parameter after an option

�❍     missing input directory

�❍     missing cache directory

�❍     missing document directory

�❍     invalid directory

�❍     unable to open an input file

�❍     unable to write in an output file

●     2: Processing error.

●     3: Partially processed.

 

Solutions per exit status value  
●     Exit status = 1: Modify the command line using information contained in the standard error file.

●     Exit status = 2: Contact you local support

●     Exit status = 3: Fix the files that cause the problem: their names are contained in the  standard error file. An interactive use of files may 
inform about problem.
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Running the CATDMUV4CacheForV5  
Batch Process

The objective is to allow the reading of the V4 Cache from a V5 session in order to avoid unnecessary duplication of cache data and thereby 
support a smooth transition from V4 4D Navigator to V5 DMU Navigator / 3d com. The operation is done in three steps:
●     Run the CATDMUV4CacheForV5 to export a V4 Cache Content file into a text file  

●     Run the CATSys4DcacheMigr , using the previously generated text file as input, to create symbolic links from the V5 cache to the tessellated 
documents in the V4 cache directory

●     Whenever new DLNames are added to the V4 Cache, run CATSysDLExport to update these DLNames for the V5 Cache 

 
This batch process is only available on Unix.

1.  Run CATDMUV4CacheForV5 each time the V4 cache is modified.

Usage: 

CATDMUV4CacheForV5 DataCacheContent MappingFile.txt

Arguments:

DataCacheContent: Complete path of the V4 Cache file to be mapped

MappingFile.txt: Output text file containing information that will be passed to the following command in the process, 
CATSys4DCacheMigr

Results:

It reads the DataCacheContent, retrieves the list of files, their location and location of reference files, and stores this information in the 
output file MappingFile.txt given as an argument. 

2.  Each time V4 cache is modified, run  CATSys4DCacheMigr using the output from CATDMUV4CacheForV5 .
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For a more accurate management of timestamps, you should define read access on all filename models before running 
CATSys4DCacheMigr .

Usage:

CATSys4DCacheMigr MappingFile.txt V4_Cache_Path V5_Cache_Path  ReportFile.txt [DLNames.txt]

Arguments:

MappingFile.txt: Output of CATDMUV4CacheForV5

V4_Cache_Path: Path of 4D Navigator Cache

V5_Cache_Path: Can be either an already filled cache path or a new one

ReportFile.txt: Output log file

DLNames.txt: Optional output, pre-formatted template file for V5 DLName definition. 

Results:

It creates symbolic links in the V5 cache and a template file (DLNames.txt) for CATSysDLExport (step 3 below).

 
Do not forget to reference the V5 Cache path in the V5 Tools  >  Options  >  Infrastructure  >  Cache Management tab.

3.  Each time there are new DLNames added in the V4 Cache

●     edit the DLNames.txt template to instantiate the location of the DLNames

●     run CATSysDLExport to update the DLNames

Usage:

CATSysDLExport -admin -i DLNames.txt -r ReportFile.txt

Arguments:

DLNames.txt: Output of CATSys4DCacheMigr

ReportFile.txt: Output log file

Behavior:

It creates or updates V5 DLNames to be compliant with V4 DLNames. 

For more information concerning DLNames, see the DMU Navigator Installation and Administration User's Guide, Administrating Data Using the 
DLName Mechanism. 
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Running the CATDMUSaveAsFrozen  
Batch Process 

The CATDMUSaveAsFrozen batch enables you to prepare / generate  DMU-related documents (products, geometries, cache data) for eventual use 
in a number of industrial processes: 
●     study variants

●     prepare design reviews

●     archive documents

●     share a light copy of a mock-up

For more information on the above processes, see Data Flow Processes.

 

1.  To retrieve the help information:

CATDMUSaveAsFrozen -h

2.  To save the documents related to a product in a directory: 

CATDMUSaveAsFrozen -save directory -product productpath [-prefix prefix][-data][-cache] [-user user -spwd cryppwd -

server srv]

3.  To export the documents related to a product in a directory:

CATDMUSaveAsFrozen -export directory -product productpath [-prefix prefix][-data] [-user user -spwd cryppwd -server 

srv] [-list listfile]

4.  To import the content of a directory in the cache: 

CATDMUSaveAsFrozen -import directory [-list listfile]

 
Windows Examples 

CATDMUSaveAsFrozen -h  
CATDMUSaveAsFrozen -import c:\u\input

Unix Examples 

CATDMUSaveAsFrozen -h 
CATDMUSaveAsFrozen -export /u/export1 -product /u/product/sample.CATProduct 
CATDMUSaveAsFrozen -save /u/save2 -product /u/product/sample.CATProduct
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Arguments

-h : Help. 

-save directory : To save the documents related to a product in a directory.

-export directory : To export the documents related to a product in a directory.

-import directory : To import the content of a directory in the cache.

-product productpath : To define the product to treat.

-prefix prefix : To save all products with a prefix in their name. This option is only valid for CATProducts and not for CATParts. 

-data : To save geometries.

-cache : To save cache data.

-user user : To define the ENOVIAVPM user.

-spwd cryppwd : To define the ENOVIAVPM password of the user. It is decrypted before use.

-server srv : to define the ENOVIAVPM server

-list listfile : to output file that will contains a list of documents to copy, each line contains the path of original data and the path of the copy data 
separated by a blank

 
Note: The parameters -user, -spwd and -server are required if documents refer to VPM.

Diagnostics 

Possible exit status values are: 

●     0: Successful completion

●     1: Failure due to any of the following:
�❍     license not available

�❍     cache management deactivated

�❍     missing arguments

�❍     invalid parameter

�❍     missing parameter after an option

�❍     missing input file

�❍     unable to find a file

�❍     unable to open an input file

�❍     bad document type

●     2: Processing error

●     3: Partially processed
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Solutions per exit status value  
●     Exit status = 1: Modify the command line using information contained in the standard error file.

●     Exit status = 2: Contact you local support.

●     Exit status = 3: Fix the files that cause the problem: their names are contained in the standard error file, an interactive use of these files could 
provide information about the cause of the problem.
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Writing and Running a Macro 

If you perform a task repeatedly, you can take advantage of a macro to automate it. A macro is a series of 
functions, written in a scripting language, that you group in a single command to perform the requested task 
automatically. 

Which Macros exist for DMU Navigator ?

Macros have been written for the following:

●     Group macro - creating a group from the currently selected products

●     Annotation macro - creating an annotation

●     Copy / Paste macro - cutting and pasting products or copying and pasting products in the Product Structure 
under a selected product

 

How to run a Macro ? 

For detailed information on running macros, see the DMU Infrastructure User's Guide, Recording, Running and 
Editing Macros:
●     Automating Repetitive Tasks Using Macros

●     Recording a Macro

●     Running a Macro

●     Editing a Macro

●     Creating a Macro From Scratch

 

How to write a Macro ? 

For detailed information on writing macros, you can access the Automation Documentation by clicking the icon  

at the top of the documentation homepage and selecting the DMU product for which you want to explore macros. 
You will find a list of available macros by product, as well as examples of code for each macro that you can use as is 
or modify as best fits your needs.
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Automating Repetitive Tasks Using Macros

If you perform a task repeatedly, you can take advantage of a macro to automate it. A macro is a series of 
functions, written in a scripting language, that you group in a single command to perform the requested task 
automatically.

You can, for example, use a macro to automate:

●     the creation of a series of holes in a part 

●     the extraction of bills of materials from an assembly 

●     the addition of a standard title block to a series of drawings 

●     the printing of a series of documents.

You can create macros either by recording an interaction sequence or by editing a file (written in a scripting 
language) to insert the functions you wish. You can also modify an existing macro, either recorded or created from 
scratch, to best fit your needs. Once the macro is created, you can run it by selecting Tools->Macro->Macros..., 
selecting the macro, and clicking Run.

Macros can be stored in the current document or in a file in an external library. If a macro is created while a 
document is current, either by means of recording an interaction sequence or editing a file, and is stored in an 
external file, a link is kept in the current document to the file containing the macro.

Note: you can use a setting to administer macro libraries opened by default using the Tools>Macro>Macros... 
tab. You administer this aspect using the Tools>Options>General>Macros>Default Macro Libraries tab. 
Macro libraries opened by a user and not belonging to administered settings are stored as preferences.

 

Script Development Tools and Languages
 You can use the following scripting tools and languages, depending on the platform you are running on.
 

On Windows 
●     CATScript: these macros are written in Basic Script, stored in CATScript-type documents, and can be run on 

both Windows and UNIX

●     Visual Basic Script (VB Script), at minimum level 5.0 , which is part of the operating system: macros written in 
Visual Basic can be run on both Windows and UNIX.  
The use of VB Script is recommended for developing Windows/UNIX-compatible macros. Although CATScript 
macros written in previous releases continue to work, we recommend that you prefer VB Script to CATScript

●     Visual Basic for Applications (VBA) Version 6.0: this product is installed with Version 5: macros written using 
VBA can only be run on Windows. Among the advantages of using VBA, note that: 

�❍     IntelliSense editing facilitates editing

�❍     VBA contains a debugger

�❍     you can develop graphic user interfaces using VBA (this is not possible with CATScript or VB Script macros).

On UNIX

Visual Basic Script 3.0 for UNIX (from Mainsoft) (shared libraries are installed when installing Version 5). 
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Recording a Macro

This task explains how to record a macro from a dialog sequence.

Note: you cannot record a macro involving the Tools->Options->Shareable tab.

You can store the recorded macro in the current document or in a file. Even if you choose to store the macro in a file, if a 
document was current when you began to record the macro, a link is created in this document to the file storing the 
macro, and the macro can afterwards be selected and run using this link from the document. If you want to record a 
macro that is not pointed to by any document, you need to store the macro in a file, and you can either start recording 
with no current document, or delete the created link from the current document when the macro is recorded.

1.  Select the Tools->Macro->Start Recording... command.

 
This displays the Record Macro dialog box: 

 

 

 
2.  Specify the current macro library or document.

This means deciding where the macro is going to be stored:

●     in a macro library: the macro will be stored in a directory (or a VBA project if it exists)

●     in a document: the macro will be stored in the current document.

What macro types you can store and where you can store them are summarized in the following table: 
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 Where Stored

Language Used Editor File Extension In Document In Directory In VBA Project

CATScript (Basic 
Script) Default or external .CATScript Yes Yes No

VB Script (Visual 
Basic) Default or external .catvbs Yes Yes No

VBA Visual Basic 
Editor only .catvba No No Yes

 Opening the list for this option displays the following by default: 

 

 

 By default, the only macro library library available is your E: folder. You can also choose to store the macro 
in the current document (a CATProduct document in our example). 

 
3.  Click the Macro libraries... button if you want to add, create or remove macro libraries.

The Macro libraries dialog box appears: 
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 Only the E: folder is available because you have not yet created any other macro libraries. 

 
4.  Click the Library type field to display the following:
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 The choices are: 

●     All libraries: displays all directories and VBA projects

●     Directories: displays only directories

●     VBA projects: displays only VBA projects.

 
5.  Click the Add existing library... button and navigate to select the library or VBA project, or click the Create new 

library... button and create the new macro directory of VBA project, and provide names when prompted.

You can also select a library from the list then click the Remove selected library button to delete it. 

 
6.  Make sure the Language used: option is set to the desired language.

 
7.  Provide a name for the macro.

8.  Click Start to begin recording the macro.

A Warning box is displayed if the macro already exists. Click Yes to start recording the macro while overriding 
the existing one. The dialog boxes related to the macro recording disappear and the Stop Recording dialog 
box appears. 

9.  Perform the dialog sequence you want to record.

10.  When this is complete, click Stop in the Stop Recording dialog box, or select the Tools->Macro->Stop 

Recording command. Your macro is now ready for replay.
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Running a Macro

This task explains the different methods of running a macro.

Method 1 

1.  Select the Tools->Macro->Macros... command to display the Macros dialog box:

 

 

 In our example, we already created "Macro1.vbs" using VB Script, which is preselected and listed in the 
available macros list. 

Use the "Current macro library or document" field or the "Macro libraries" button if you have other 
macros available. 

2.  Click the Run button to replay the selected macro.

 
Method 2 

1.  Explore your file system and locate the .CATScript file.

2.  Double-click the .CATScript file, or select the file and select the Open contextual command.

A session is started and the macro is executed. 
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Double-clicking a .catvbs macro does not run the macro. 

 
Method 3 

1.  On Windows, run a command like this:

cnext -env CATIA.V5R16.B16 -macro E:\tmp\Mymacro.CATScript 

or like this: 

cnext -env CATIA.V5R16.B16 -batch -macro E:\tmp\Mymacro.CATScript 

to run the macro in batch mode, where "Mymacro.CATScript" is the name of the macro file. 

On UNIX, run a command like this: 

CNEXT -macro "/tmp/Mymacro.CATScript" 

CNEXT -batch -macro "/tmp/Mymacro.CATScript" 

or like this: 

./catstart -d /CATEnv -env CATIA.V5R16.B16 -object "-macro /tmp/Mymacro.CATScript"

./catstart -d /CATEnv -env CATIA.V5R16.B16 -object "-batch -macro /tmp/Mymacro.CATScript"

to run the macro in batch mode, where "Mymacro.CATScript" is the name of the macro file. 

You can add macros to a toolbar using the Tools->Customize... command. Select the Commands tab, then the 
Macros category: all the macros will be detected and listed. You can then drag and drop them onto toolbars for 
convenient access.
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Editing a Macro

This task explains you how to edit a macro.

1.  Select the Tools->Macro->Macros... command to display the Macros dialog box.

 

 

 In our example, we already created "Macro1.vbs" using VB Script, which is preselected and listed in the available macros list. 

Use the "Current macro library or document" field or the "Macro libraries" button if you have other macros available. 

 
2.  Click the Edit... button to edit the macro.

 If the macro is a CATScript document or a VB Script file, the default editor is displayed like this: 
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You can change the editor for CATScript and VB Script macros by using the Macros tab. For more information, refer to Macros. 

 If the macro is a .catvba project module, the VBA editor is displayed like this: 
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 On UNIX   

By default the emacs is opened by default. You can always replace it by your favorite editor by exporting the EDITOR variable. 

Use the Rename... button to rename the selected macro, the Delete button to delete it. 

Use the Select... button and navigate to select a macro if it is not stored in a macro library. 

3.  Modify the macro instructions as you want, and save the macro, or cancel the modifications.
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Creating a Macro From Scratch

This task explains you how to create a macro from scratch.

1.  Select the Tools->Macro->Macros... command to display the Macros dialog box.

 

 

 
2.  Set the current macro library or document for storing the macro.

 
3.  Click the Create... button, select the type of macro to create and name it.

 
4.  Click the Edit... button to edit it.

Depending on which language you chose, the appropriate editor is displayed. 
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Inserting a Document from a Webpage 

 

You can now insert a 3D document that is referenced in a Webpage into the DMU Navigator. 

The visualization takes into account user-defined positions and the name of the product into which it will be inserted.  
 

This functionality is only supported for the following browsers:
●     Microsoft Internet Explorer 6 

●     Mozilla 1.4 with the Java Plug-in 1.3.1-08  

 
A DMU Navigator session and the backbone connection must be launched. 
A document to be inserted must be accessible from the DMU Navigator session, i.e. it must either be local to the session or accessible via HTTP.

 
Supported document types are those which can be inserted in a product (CATPart, model, cgr). 

 

Technical architecture 

The browser must contain:

●     Links with the appropriate syntax

●     A Java applet 

When the user clicks on a link, the java applet establishes a connection with DMU Navigator (using Backbone) in order to send all requested information. 

Link description 
●     Mandatory, Name of the document 

●     Mandatory, Path of the document :local path or HTTP URL 

●     Optional, ID of document: user-defined ID unique for each document, in order to differentiate the instances of the same document. If the same is always 
used, the instance of the previous loaded document is replaced.

●     Optional, Name of the product in DMU Navigator. If the product already exists in the DMU session, then the document is inserted in this product. If the 
product does not exist, then a new product is created with the appropriate name. If this option is not specified, the document is inserted in the product 
currently active in DMU. 

●     Optional, Position of the document : the position is defined by 12 doubles (3x3 matrix and 3x1 vector), identity matrix if nothing is specified. 

Java Applet Description 

Input:

1.  Port number for communication with local CATSysDeamon process (Backbone process). 

Behavior:

1.  Establish a Backbone connection with DMU Navigator (which is already launched)
2.  Insert the document in the appropriate product (target product or active product, depending on the link)
3.  Set the correct position (if necessary) 

 
 

A signed applet is delivered for the browsers: 

●     Microsoft Internet Explorer 6 or Mozilla 1.4 with the Java Plug-in 1.3.1-08 

 
Microsoft Internet Explorer 6 or Mozilla with the Java Plug-in 1.3.1-08 

The applet jar name is PPRCatiaV5LightApplet.jar.

Sample html page: 

<HTML> 
<APPLET code="com.dassault_systemes.catweb.ApplicationDriver.CATIAV5Services.light. 
DMUV5LoadAppletJ2" codebase="path" name="dmuload"> 
<PARAM NAME="PortNumber" VALUE="55555"> 
<PARAM NAME="dmuflag" VALUE="*local*"> 
<PARAM NAME="archive" VALUE="PPRCatiaV5LightApplet.jar"> 
</APPLET> 

<FORM> 
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<INPUT type="button" value="clickhere"  
onclick="dmuload.load('MyProduct', 'E:\\MyDoc.CATPart', 'mydocuid', 'mydocname',  
'[ 1 0 0 0 1 0 0 0 1 0 0 0 ]');"> 
</FORM> 
</HTML> 

 
 

Additional Information

The arguments in bold are the ones you have to specify to load a document. 

codebase is :

●     the relative path of the cab or the jar applet file (stored in the DMU installation directory) compared with the HTML page 

●     or the full path of the cab or the jar applet file (stored in the DMU installation directory)

●     or the http path of the cab or the jar applet file 

Note: 

●     For Internet Explorer, the full path has the following form: 'E:\MyInstall\intel_a\multios\intel_a\jar'

●     For Mozilla, the full path has the following form: 'file:///E:/MyInstall/intel_a/multios/intel_a/jar'

●     The PortNumber parameter is the TCP port on which the connection is established with the backbone. 
Generally, the port is 55555 but it could be different on some computers. If this is the case, for instance with Windows, you have to open the file 
system32\drivers\etc\Services  
in the Windows directory and specify in your HTML page the port actually affected to catiav5bb. 

 

 

3D Insight Version 5 Release 19 Page 832 of 1379



Directly Insert a DMU document from the Windows Explorer

 

It is now possible to double-click on your .model, .cgr and .CATPart documents in the  Windows Explorer and have your document automatically inserted into 
a DMU Navigator session. 

 
During the installation of ENOVIA DMU on Windows, registries are modified in order to offer the following options for data of types .model , .CATPart , and .cgr :

.model 

●     Open - open the 2D data in the DMU 2D workbench (default)

●     Insert - insert the 3D data under the root of the current Product (a CATProduct is created if no Product is currently open)

●     Print - applies default option and print 

.CATPart 

●     Open - not possible in ENOVIA DMU

●     Insert - insert the CATPart in the current product

●     Print - applies default option and print

.cgr 

●     Insert - insert the 3D data in the current product (default)

●     Print - applies default option and print 

Whereas before the default behavior activated when double-clicking an entity of the above three types was to open a new window in your DMU 
session containing the entity, it is now possible to implement Insert as the default behavior.

1.  To implement Insert as the default behavior for types .model and .CATPart ,  go to the directory %install_path%\code\bin and double-click the 

file DMUInsert.exe . 

The registry is updated accordingly.

2.  To insert an entity of one of the above data types into a DMU session, activate the DMU session window into which the entity should be inserted and double-

click the entity in your Windows Exploring window.
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Visualizing 3D Annotations 

This task shows you how to visualize the 3D annotations in a document.

Open the Review_Product_01.CATProduct document.

●     Improve the highlight of the related geometry, see Highlighting of the Related Geometry for 3D Annotation.

The following task has been performed using the cache system including the annotations. See Annotations and Cache 
System.

1.  Click the 3D Visualization option:  

3D annotations are displayed
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*TOLP4 set contains the dimensioning and tolerancing specifications of the part model.

2.  Select a dimension in the expanded specification tree.
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The tolerancing object of the specification tree and the surfaces used in the tolerancing annotation are 
highlighted. Selecting a tolerance is a way of querying the annotated model.
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Visualizing 2D Annotations 

This task shows you how to visualize the 2D annotations in a document.

The following task can be performed using the cache system option off only. See Annotations and Cache System.

Open the Review_Product_01.CATProduct document.

1.  Click the 2D Visualization option:  

A new window is displayed with the annotations created using CATIA V4 FD&T function presented in a table.
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2.  Select Window  >  Tile vertically from the menu bar to visualize the 2D and 3D windows.

3.  Select in the 3D window a dimension in the expanded specification tree.
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4.  Zoom in in the 2D window.

 The 2D Visualization command works exactly the same way as the 3D Visualization command. When an 
annotation is selected in the model the 2D table reframes on the corresponding annotation.
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 In a nutshell, there is a complete associativity between the 2D table, the specification tree and the 3D model.
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Visualizing Annotation Related Surfaces 

This task shows you how to visualize the surfaces which are referenced by annotations.

Open the Review_Product_01.CATProduct document:

1.  Un-select the 3D Visualization option if needed: 

2.  Select the Related Surfaces option:  

Nothing happens, this option is only available when the 3D Visualization option is 
activated.  
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3.  Select the 3D Visualization option: 

All the surfaces, which were referenced or toleranced using the CATIA V4 FD&T function, are 
highlighted. 
Note that the application lets you customize the color of related surfaces. 
For more information, please refer to Tolerancing settings.
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This function lets you:
�❍     Analyze the advancement of the dimensioning and the tolerancing.

�❍     Visualize the functional surfaces.

�❍     Have a quick glance at the advancement of the part.
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Filtering Annotations 

This task shows you how to filter the display of annotations. 

You can filter annotations display though the following features:
●     Views/annotation planes

●     Annotation sets

●     Geometrical elements

●     3D annotations

●     Any Part Design feature

●     Any Generative Shape Design feature

●     Restricted areas

 You can filter annotations in the Visualization mode context. See Annotations and Cache System.

In the case of Part Design or Generative Shape Design features, only the annotations that are directly or indirectly applied to the 
geometrical elements which compose the feature will be displayed when applying the filter. In the case of restricted areas, only the 
annotations that are directly or indirectly applied to the geometrical elements which compose the restricting part of the restricted 
area will be displayed when applying the filter.

Open the Annotations_Product_04.CATProduct document. 
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1.  Click the Filter icon:  

The Filter dialog box is displayed.

�❍     The Definition area allows you to filter the display of annotations in the 3D viewer using the following criteria:
■     All: displays all the geometrical tolerance annotations.

■     None: displays no geometrical tolerance annotation.

■     By type: non semantic.

■     By sub-type: text, datum, datum targets, geometrical tolerances, Note Object attributes.

■     By feature (Part Design or Generative Shape Design feature) or geometrical element.

■     By value  <,> , =,> =, <= functions against a specified value.

■     By capture.

�❍     The Refine filter option filters out tolerances still filtered: it allows you to filter from the current annotation filtering 
with another criteria in relation with. For example you can filter geometrical tolerances first, then select this option 
and filter these geometrical tolerances by values. This is equivalent to the AND Boolean operator.

�❍     The Show geometry attachments option displays the annotation leader if exists, and all the linked annotations 
between the leader and the filtered annotation if needed.

�❍     The Results area provides the following information:
■     Number of specified tolerances attached to the 3D model

■     Number of tolerances selected according to the choice indicated in the two previous fields

However, when default tolerances are specified, the number of tolerances displayed attached to the model does not 
correspond to the number of tolerances effectively specified. The default tolerance annotation is displayed once and the 
default tolerance specification is applied to several entities. These several specific toleranced entities are considered in 
the count of the Tolerances in the document field.
 

2.  Set the Filter choice field to By sub-type.

3.  Set the Simple Datum sub-type. 

4.  Click Apply. The Number of selected tolerances field displays 3. 
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Only simple datums are displayed.

5.  Click Cancel to cancel the operation. All annotations are visible again.
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Mirroring Annotations 

This task shows you how to mirror reversed annotation relative to the screen view.

Open the Annotations_Product_04.CATProduct document.

1.  Turn the part to show annotations reversed.

2.  Click Mirror Annotations   in the Visualization toolbar.

All reversed annotations are mirrored.
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●     In the CATProduct or CATProcess context, the Mirror command has no effect on annotations linked with parts in 
Visualisation mode. See Cache Management for CATProduct and CATProcess Document for more information on 
this mode.

●     When activating a 2D Layout window, mirrored annotations are automatically reinitialized to their creation position 
display.
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Going to Hyperlinks 

This task shows you how to trig hyperlinks referenced in a Version 5 flagnote annotation.

Open the Review_Product_02.CATProduct document.

 

The following task has been performed using the cache system including the annotations. See Annotations and Cache 
System.

1.  Click the 3D Visualization option: 

3D Flagnote annotations are displayed.
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2.  Click the Go to Hyperlinks icon:  

 
3.  Move the mouse over the flagnote.

Hyperlinks contain in the flagnote are displayed as tooltip.
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4.  Click the flagnote.

The Open Hyperlink dialog box appears. 
When the flagnote contains one link only, click the flagnote open the default browser with the link directly.

 

 
5.  Double-click a link to open the default browser with the link.

 
6.  Click OK to close the dialog box.
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Managing 3D Annotations in 3D XML Files 

This task explains you how to manage 3D Annotations in 3D XML files:
●     Save

●     Display

●     Query

●     Filter

 

Save
●     The Save as 3D XML capability is provided by File> Save as... or File> Save Management> Save as... 

For more information, please refer to Saving Documents in Other Formats in CATIA Infrastructure User's 
Guide.

●     The Save as 3D XML capability in batch mode is not provided.

●     To save 3D annotations in a 3D XML file, select the 3D annotation check box in Tools> Options> 
General> Compatibility> 3D XML.

●     The 3D annotation option is active for the Dynamic Tessellation and Static Tessellation geometry 
representation formats, selected in Tools> Options>  General> Compatibility> 3D XML, Geometry 
Representation area. The 3D annotations will be saved in 3D XML file for these geometry representations.

●     The XmlTessellation geometry representation format does not support saving of 3D annotations in a 3D 
XML file. The 3D annotations option will be inactive in this case.

●     3D annotations of CATParts are taken into account. 

●     3D annotations created at a product and process level are also taken into account, but cannot be visualized 
when opening 3DXML document in V5. Note, that 3D annotations will be visualized in future version of 
CATIA. 

●     Note that Datum Reference Frame and restricted area features are not saved in 3D XML files, as they are 
useless for review process.

●     The 3D annotations of .model and .cgr documents are not taken into account.

●     Both the check boxes Under Geometric Feature nodes and Under View/Annotation Plane nodes, in 
Tools> Options> Mechanical Design> Functional Tolerancing & Annotation> Display must be 
cleared before saving the document.

 

Display
When you open a 3D XML file containing 3D annotations, they are not displayed. 

 
When the 3D XML has been created from a CATProduct document, to display the 3D annotations both in the 3D 

window and in the specification tree:

1.  Activate the root product of your document.

2.  Switch to the Product Functional Tolerancing & Annotation workbench.

3.  Click List Annotation Set Switch On/Switch Off .

4.  Click Enable All.
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5.  Click OK.

When the 3D XML has been created from a CATPart document, to display the 3D annotations both in the 3D 

window and in the specification tree:

1.  Create a new CATProduct document.

2.  Insert under the root product the 3D XML document (Existing Component command).

3.  Be sure that the root product is activated.

4.  Switch to the Product Functional Tolerancing & Annotation workbench.

5.  Click List Annotation Set Switch On/Switch Off .

6.  Click Enable All.

7.  Click OK.

3D annotations contained in a 3D XML files have the following specificities:
●     they are not editable,

●     they cannot be moved,

●     they cannot be copied nor deleted.

●     their properties are not editable with the exception of their Lines and Curves properties (Color, Lintype, 
Thickness) that can be edited within the session but those modifications will not be saved.

 

Query

To access to the query capabilities:

Click 3D-Annotation-Query Switch On/Switch Off  in Functional Tolerancing & Annotation,  

Click Select   in DMU Dimensioning & Tolerance Review.

For both workbenches:

●     If you select a geometrical element, all the 3D annotations that are applied to it are highlighted. This 
capability is limited to 3D annotations defined at part level (leaf components of the product). 

●     If you select a 3D annotation or a constructed geometry or a restricted area, all the geometrical elements it 
is linked to are highlighted. This capability is limited to 3D annotations defined at part level (leaf components 
of the product).   
If frame dimensions are attached to it, they are highlighted too.  
If the 3D annotation is a geometrical tolerance with datum reference frame, the corresponding datum 
annotations are highlighted too. 

●     If you put the mouse pointer on top of a NOA annotation or a flagnote annotation, the hidden text and 
hyperlink paths that are attached to it are displayed in a tool tip. 
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●     If you put the mouse pointer on top of a dimension with a fitting tolerance or with a general tolerance, the 
corresponding numerical upper and lower tolerances are displayed in a tool tip.

●     If you select an Aligned/Offset Section Cut/View in specification tree or in 3D, the 3D Aligned/Offset clipping 
according to the profile of the part or product is displayed.

●     If you select a capture that has a component of an Aligned/Offset Section Cut/View feature as active view 
and its Clipping plane option selected (in the capture Properties dialog box) the corresponding 3D Aligned/
Offset clipping is displayed.

●     If you select a Text or Flag Note or Note Object Attribute annotation, all the geometric elements of the below 
listed geometric features it is applied to are highlighted. 
 

The following geometric features are highlighted:
�❍     All geometrical elements.

�❍     PartBody and Body features.

�❍     The following Part Design features: Pad, Pocket, Shaft, Groove, Hole and Rib.

�❍     Geometrical Sets and Ordered Geometrical Sets.

�❍     Axis systems.

�❍     User Features.

�❍     Technological Result features of Part Design Hole feature and User Features.

●     If you select one of the element of the above listed geometric features, all the Text, Flag Note and Note 
Object Attribute annotations that are applied to the geometric feature are highlighted.

●     If you select the By feature option in the Filter dialog box for least one geometric element of the listed 
geometric features, all the annotations that are directly applied to this geometric element or that are applied 
to its geometric feature, are put in show mode while all the other annotations are put in no show mode.

●     If you select a capture, the resulting display respects the show/hide mode selected for part bodies and 
geometrical sets (as in the Manage the visibility of Part instances, bodies and geometrical sets 
option in capture Properties dialog box). For more information, refer to 3D Functional Tolerancing & 
Annotation User's Guide: Managing Annotations Display: Managing Hide/Show in Captures.

●     Tolerancing Schema
�❍     If you select the Nx text in 3D or specification tree, all the geometric features, dimensions, tolerances 

and annotations that are linked to the tolerancing schema are highlighted. 
For more information on tolerancing user features, see 3D Functional Tolerancing & Annotation User's 
Guide: User Tasks: Using the Tolerancing Advisor: Tolerancing User Features Automatically.

�❍     If an annotation linked to Nx text is selected, the Nx text is also highlighted.

�❍     If you select the By feature option in the Filter dialog box for a annotation which belongs to Nx text, 
the Nx text and all the dimensions, tolerances and annotations that are linked to it are put in show mode.

For DMU Dimensioning & Tolerance Review:

●     Related Surfaces  displays all the geometrical elements at least a 3D annotation is applied to, in the 
color of your choice.

●     Go to Hyperlinks  opens the documents that are attached to flag notes or NOA.
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Filter

Click Filter  to filter the 3D annotations according to all the criteria that are proposed (note that only the 
ones that are relevant for the 3D annotations that are loaded in the V5 session are proposed): 

●     All 

●     None 

●     By type 

●     By sub-type 

●     By value 

●     By feature:
�❍     Annotation sets 

�❍     Views 

�❍     Geometrical elements 

●     By default annotation 

●     By capture (you can also display a capture by using the Display contextual menu command on capture 
feature).

Functional Tolerancing & Annotations features in 3D XML can be reviewed within 3D XML Player and 3D Live 

(without requiring the Live FTA Review license).
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Wireframe and Surface

3D Insight offers a subset of Wireframe & Surface product without the capability to save the created data. 
The table below lists the information you will find.

Defining an Axis System 
Sketcher User Tasks 

Creating Points 
Creating Multiple Points and Planes 

Creating Lines 
Creating an Axis 

Creating Polylines 
Creating Planes 

Creating Planes Between Other Planes 
Creating Circles 
Creating Splines 

Creating Projections 
Creating Intersections 

Creating Splines 
Creating Extruded Surfaces 

Creating Revolution Surfaces 
Creating Spherical Surfaces 
Creating Cylindrical Surfaces 

Creating Offset Surfaces 
Creating Filling Surfaces 

Creating Boundaries 
Extracting Geometry 
Rotating Geometry 

Translating Geometry 
Performing a Symmetry on Geometry 

Transforming Geometry by Scaling 
Transforming Geometry by Affinity 

Transforming Elements From an Axis to Another
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Defining an Axis System 

This task explains how to define a new three-axis system locally. There are two ways of defining it: either by selecting geometry 
or by entering coordinates.

Open the PowerCopyStart1.CATPart document.

1.  Select Insert > Axis System from the menu bar or click Axis System .

The Axis System Definition dialog box is displayed.

An axis system is composed of an origin point and three orthogonal axes. For instance, you can start by selecting the 
vertex as shown to position the origin of the axis system you wish to create. The application then computes the 
remaining coordinates. Both computed axes are then parallel to those of the current system. The axis system looks like 
this:

It can be right or left-handed. This information is displayed within the Axis System Definition dialog box.  
You can choose from different types of axis system:
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�❍     Standard: defined by a point of origin and three orthogonal directions.  

If an axis system is selected before launching the command, the new axis system is a copy of the pre-selected axis 

system. Moreover, if the compass is attached to the 3D geometry, the new axis system orientations are the same as 

the compass'. Otherwise, the new axis system orientations are as per the current axis system's.

Here only the point was selected and nothing specified for the axes.

�❍     Axis rotation: defined as a standard axis system and a angle computed from a selected reference.

Here the Y axis was set to the standard axis system Y axis, and a 15 degrees angle was set in relation to an edge 
parallel to the X axis.
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�❍     Euler angles: defined by three angle values as follows:

Angle 1= (X, N)
a rotation about Z transforming vector X into vector N.

Angle 2= (Z, W)
a rotation about vector N transforming vector Z into vector W.

Angle 3= (N, U)
a rotation about vector W

2.  Select the point as shown to position the origin of the axis system you wish to create. The application then computes the 

remaining coordinates. Both computed axes are then parallel to those of the current system. The axis system looks like 

this:

 
Instead of selecting the geometry to define the origin point, you can use one of the following contextual commands 
available from the Origin field:
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�❍     Create Point: for more information, refer to Points

�❍     Coordinates: for more information, refer to Points

�❍     Create Midpoint: the origin point is the midpoint detected by the application after selection of a geometrical 
element.

�❍     Create Endpoint: the origin point is the endpoint detected by the application after selection of a geometrical 
element.

3.  If you are not satisfied with x axis, for instance click the X Axis field and select a line to define a new direction for x axis.

The x axis becomes collinear with this line.
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�❍     It can be a line created along the surface edge, for example, using the Create Line contextual menu on the 
selection field, and selecting two surface vertices. 
Similarly you can create points, and planes.

�❍     You can also select the Rotation... contextual menu, and enter an angle value in the X Axis Rotation dialog 
box.

 

4.  Click the y axis in the geometry to reverse it.

Checking Reverse next to the Y Axis field reverses its direction too.

5.  You can also define axes through coordinates. Right-click the Z Axis field and select the Coordinates... contextual 

command. The Z Axis dialog box appears.
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6.  Key in X = -1, retain the Y and Z coordinates, and click Close.

The axis system is modified accordingly, and is now left-handed.

 
If you select one or more directions, the other inputs (directions and origin if not specified) are automatically 
computed. If you do not select any origin or directions, the system automatically computes them for the 
creation of the axis system. However, when editing the axis system, automatically computed origin or directions 
fields are filled with "Coordinates" as if they had been explicitly specified.

7.  Click More... to display the More... dialog box.

The first row contains the coordinates of the origin point. The coordinates of X axis are displayed in the second row. The 
coordinates of Y and Z axis are displayed in the third and fourth row respectively.
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�❍     If no value is selected, the new axis system matches the current one.

�❍     If the origin is selected, the new axis system origin is set to the origin.

�❍     The first specified axis defines the corresponding axis of new axis system. 
i.e., if the x-axis is specified by Line.1, then the x-axis of new system is a vector along Line.1.

�❍     The second specified axis defines the plane between the corresponding first and second axes of the new axis system. 
i.e., if the z-axis is specified by Line.2, then the xz plane is defined by the plane between vectors along Line.1 and 
Line.2.

�❍     The third specified axis defines the orientation of the corresponding axis of new axis system. 
i.e., if the y-axis is specified by Line.3, then Line.3 defines which side of the xz plane the y-axis of new system lies. 

�❍     The order of selection of the axes is important: to change the order, select the No Selection contextual item on the 
appropriate axes. 
For instance, if the axes have been selected in the order x, y, z and you wish to change the order to x, z, y, you 
must select the No Selection contextual item on y, and select it again.

8.  Uncheck Current if you do not want to set your axis as the reference. The absolute axis at the bottom right of the 

document then becomes the current three axis system.

9.  Uncheck Under the Axis Systems node if you do not want the axis system to be created within the Axis system node 

in the specification tree.

It will be created either in the current geometrical set or right after the current object in an ordered geometrical set. In 
this case, the axis system becomes the new current object.

This option is not persistent and not stored in the feature.

10.  Click OK.

The axis system is created. 
When it is set as current, it is highlighted in the specification tree.

11.  Right-click Axis System.1 from the specification tree and select the Axis System.1 object > Set As Current 

contextual command. Axis System.1 is now current. You can then select one of its plane, to define a sketch plane for 

example.
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�❍     You can change the location of the axis system and put it in a geometrical set. 
To do so, select it in the specification tree, right-click and select Axis System.1 object > Change 
Geometrical Set. Choose the destination of the axis system using the drop-down list.
Refer to the Managing Geometrical Sets chapter to have more information.

�❍     If you create a point using the coordinates method and an axis system is already defined and set as current, 
the point's coordinates are defined according to current the axis system. As a consequence, the point's 
coordinates are not displayed in the specification tree.

�❍     You can contextually retrieve the current local axis direction.
Refer to the Stacking Commands chapter to have more information.

�❍     You can use the Shift key while creating the axis system to select the implicit elements that belong to the 
axis system.
Refer to the Selecting Implicit Elements chapter to have more information.

�❍     There is an associativity between the feature being created and the current local axis system. Therefore when 
the local axis system is updated after a modification, all features based on the axis direction are updated as 
well.

�❍     Local axes are fixed. If you wish to constrain them, you need to isolate them (using Isolate contextual 
command) before setting constraints otherwise you would obtain over-constrained systems.

�❍     The display mode of the axes is different depending on whether the three-axis system is right-handed or left-
handed and current or not. 

Three-Axis System Current Axis Display Mode

right-handed yes solid

right-handed no dashed

left-handed yes dotted

left-handed no dot-dashed

 
 

Editing an Axis System
You can edit your axis system by double-clicking it and entering new values in the dialog box 
that appears. You can also use the compass to edit your axis system. 

Note that editing the geometrical elements selected for defining the axes or the origin point 
affects the definition of the axis system accordingly.

Right-clicking Axis System.X object in the specification tree lets you access the following 
contextual commands:

●     Definition...: redefines the axis system

●     Isolate: sets the axis system apart from the geometry

●     Set As Current/Set As Not Current: defines whether the axis system is the reference 
or not.

 
Under the Axis Systems node is not available when editing an axis system.
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User Tasks

The Sketcher workbench provides a simple method for creating and editing 2D geometry as well as creating relations 
between geometrical elements. Once created, you can set constraints between geometrical elements, if you need more 
complex sketches.

Before You Begin 
Entering the Sketcher Workbench 

Creating a Positioned Sketch 
Changing a Sketch Support 
Sketching Simple Profiles 

Sketching Pre-Defined Profiles 
Performing Operations on Profiles 

Editing Sketches 
Analyzing the Sketch 
Setting Constraints 

SmartPick 
Deactivating a Sketch
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Before You Begin

Before you begin designing sketches, you should be familiar with the tools and concepts presented in the tasks of this 
section. 

Use tools for sketching: Use the Sketch tools toolbar displayed in the bottom right part of the software 
screen which provides helpful  options

Use colors: Use colors to define either graphical properties or constraint diagnostics.

Cut the part by the sketch plane: Hides the portion of part you do not want to see in the Sketcher.

Define a Visualization Mode for Sketcher Elements: set the Sketcher elements visualization mode that 
best meets your needs

Defining a Visualization Mode for Wireframe Elements: set a visualization mode among several, for the 
wireframe elements you can see once in a sketch

 Convert standard into construction elements: Assign a new type of a line to an element for differentiating 
construction from non construction elements. 

Hide or Show the Sketch Absolute Axis
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Using the Sketcher Grid

The Sketcher application provides a certain number of tools which assist you for sketching elements. This page deals with the Grid 
capability.

 

1.  To display the Grid in the Sketcher session, just click Grid  in the Sketch tools toolbar. 

 
The grid is displayed. In case the grid spacing and graduations do not satisfy you, you can modify them in the Options 

dialog box as follows:

2.  Select Tools > Options... 

The Options dialog box opens.

2.  Select the Mechanical Design category in the left-hand box.

3.  Select the Sketcher sub-category. 

The Sketcher tab that appears lets you set different options. 

4.  Set the options according to your needs:

�❍     Display: Defines whether the grid is displayed. By default, this option is selected.

�❍     Snap to point: Defines whether annotations are snapped to the grid point. By default, this option is selected.

�❍     Allow Distortions: Defines whether grid spacing and graduations are the same horizontally and vertically. By 
default, this option is not selected.

Working with the Snap to Point Option 

If activated, Snap to Point  available in the Sketch tools toolbar, makes your sketch begin or end on the points of the grid. 
As you are sketching, the  points are snapped to the intersection points of the grid. Note that this option is also available in the 
Tools > Options, Mechanical Design > Sketcher option at the left of the dialog box (Sketcher tab). 

In the following example:

●     the black spline was created with Snap to Point on. The points are on the grid.

●     Conversely, the highlighted spline was created with the Snap to Point option deactivated. 
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Using Tools For Sketching 

 The Sketcher application can assist you when sketching elements. This page shows you the different capabilities available in the 
Sketch tools toolbar.

The Sketch tools toolbar is displayed at the bottom right part of the application.  

It provides the following options commands:

 
Working with the Grid Option  

Working with the Snap to Point Option  

Creating Construction/Standard Elements  

Creating Geometrical Constraints  

Creating Dimensional Constraints  

Value Fields

 You do not necessarily visualize the whole Sketch tools toolbar. Just undock it to display all the available options and 
fields.  

Working with the Grid Option 

The Grid option is directly available from the Sketch tools toolbar. Clicking Grid  displays the grid in your session. 

The grid spacing and graduations are defined using the Tools > Options > Mechanical Design > Sketcher command. For 
more information, refer to Customizing.

Working with the Snap to Point Option 

If activated, Snap to Point  makes your sketch begin or end on the points of the grid. As you are sketching the  points are 
snapped to the intersection points of the grid. Note that this option is also available in the Tools > Options, Mechanical Design 
> Sketcher option at the left of the dialog box (Sketcher tab). For more information, see Infrastructure user's guide 
(Customization Settings).

In the following example:

●     the black spline was created with Snap to Point on. The points are on the grid.

●     Conversely, the highlighted spline was created with the Snap to Point option deactivated. 
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Note that when you zoom in, snapping option remains active both on primary and secondary grids, even though the secondary 
grids are not visualized any more. 

When SmartPick is active, points may not snap at the intersection points of the grid. Care that they will necessarily snap on an 
horizontal or a vertical grid subdivision.

The SmartPick capability works even if this option is on. 

 

Creating Construction/Standard Elements 

You can create two types of elements: standard elements and construction elements. Note that creating standard or construction 
elements is based upon the same methodology. 

If standard elements represent the most commonly created elements, on some occasions, you will have to create a geometry just 
to facilitate your design. Construction elements aim at helping you in sketching the required profile. 

1.  Click Construction/Standard Element  in the Sketch tools toolbar so that the elements you are now going to 

create be either standard or construction element.  

As construction elements are not taken into account when creating features, note that they do not appear outside the 

Sketcher.
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●     When they are not used anymore, construction elements are automatically removed. 

●     Note that in the case of hexagons, construction element type is automatically used for secondary circles. This type of sketch is 
interesting in that it simplifies the creation and the ways in which it is constrained. Setting a radius constraint on the second 
circle is enough to constrain the whole hexagon. Just imagine what you would have to do to constrain hexagons sketched with 
no construction circles!

Creating Geometrical Constraints 

When selected, Geometrical Constraint  allows you to force a limitation between one or more geometry elements.

Creating Dimensional Constraints 

When selected, Dimensional Constraint  allows you to force a dimensional limitation on one or more profile type elements 
provided you use the value fields in the Sketch tools toolbar for creating this profile.

To know more about sketcher constraints, refer to Setting Constraints, and Infrastructure user's guide (Customization Settings).

 

 

Value Fields

 

 

The values of the elements you sketch appear in the Sketch tools toolbar as you move the cursor. In other words, as you are 
moving the cursor, the Horizontal (H), Vertical (V), Length (L) and Angle (A) fields display the coordinates corresponding to the 
cursor position.
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●     You can select the desired field of the Sketch tools toolbar and type in the desired values:
�❍     Using the mouse cursor.

�❍     Using the Tab key.

●     You can increment or decrement the value in a field using the Up key or Down key according to the grid options.

●     When you select another field, the value in the previously selected filed is locked.

●     Type any number fill by default the first field.

●     Press Enter to validate your values.

You can also use these fields for entering the values of your choice. In the following scenario, you are going to sketch a line by 
entering values in the appropriate fields.

1.  Click Line . 

The Sketch tools toolbar displays information in the four value fields. 

2.  Enter the coordinates of the First Point.

3.  Enter the coordinates of the Second Point.

or

2.  Enter the length (L) of the line.

3.  Enter the value of the angle (A) between the line to be created and the horizontal axis.

4.  Click the first point on the line. 

The line is created.

Depending on the number of fields available and the way you customize your toolbars, some fields may be truncated. What you 
need to do is just undock the Sketch tools toolbar.
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Using Colors

Two types of colors may be applied to sketched elements. These two types of colors correspond to colors illustrating:
●     Graphical properties 

Colors that can be modified. These colors can therefore be modified using the contextual menu (Properties option and Graphic tab).

OR 

●     Constraint diagnosis 
Colors that represent constraint diagnostics are colors that are imposed to elements whatever the graphical properties previously assigned to these elements 
and in accordance with given diagnostics. As a result, as soon as the diagnostic is solved, the element is assigned the color as defined in the Properties dialog 
box (Graphic tab).

COLORS and GRAPHICAL PROPERTIES 
   

 
Grey: Construction Element 

 Elements that are internal to, and only visualized by, the sketch. These elements are used as positioning references. These elements cannot be visualized in 
the 3D and therefore cannot be used to generate solid primitives.

 

 

 

 

 
Yellow: Non Modifiable Element 

 
For example, use edges, i.e. edges obtained by projections or intersections. You cannot modify the geometry of these elements unless you isolate them. 
For more information, see Isolating Projections and Intersections. 
 

 

 

 

 
Red Orange: Selected Element 

 A subgroup of elements actually selected (the Select icon  is similarly active).

 

 

 

 

 
COLORS And DIAGNOSIS  

 
White: Under-Constrained Element 

 Constrained geometry is displayed in white. All the relevant dimensions are satisfied but there are still some degrees of freedom remaining. 
For the purpose of the documentation, we have chosen to show under-constrained elements in black, as our application background color is white.

Add constraints.

 

 

 
 

 
Brown: Element Not Changed 

 Some geometrical elements are over-defined or not-consistent. As a result, geometry that depend(s) on the problematic area will not be recalculated. Remove one or more dimensional constraints.
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 Green: Fixed Element 
 The geometry has been fixed using the Constraint Definition dialog box or the contextual menu (right mouse button).  

 

 

 

 Green: Iso-Constrained Element 
 All the relevant dimensions are satisfied. The geometry is fixed and cannot be moved from its geometrical support.  
 Geometry before and after being moved:  

  

    
 Purple: Over-Constrained Element 
 The dimensioning scheme is over-constrained: too many dimensions were applied to the geometry. Remove one or more dimensional constraints.

 

 

 
 

 Red: Inconsistent Element 

 At least one dimension value needs to be changed. This is also the case when elements are under-constrained and the system proposes values by defaults 
that do not lead to a solution.

Add dimensions. Set dimension value(s) properly.

 

Inconsistent and Over-Constrained Elements: 

When leaving the sketcher, the software will only generate a warning for inconsistent and over-constrained elements if they belong to a sketch issued from 
the release 5 or releases before. Since release 6, the software generates an error. 
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Cutting the Part by the Sketch Plane 

This task shows how to make some edges visible. In other words, you are going to simplify the sketch plane view 
by hiding the portion of material you do not need for sketching.

Open the Intersection_Canonic.CATPart document.

1.  Select the plane on which you need to sketch a new profile and enter the Sketcher workbench.

Once in the Sketcher, you obtain this view, which does not show the edges you want to see. 

2.  Click Cut Part by Sketch Plane  in the Visualization toolbar to hide the portion of part you do not 

want to see in the Sketcher. 
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You obtain this view without the material existing above the sketch plane.

The edges corresponding to the shell are now visible. The edges resulting from the intersection are not 

visualized and therefore cannot be selected.

You can now sketch the required profile taking these edges into account.

About Sectioning Solids Which are Intersecting

When using slice or box tools, note the visualization is not correct because the intersection between the two solids 
is not retrieved properly, i.e. it is not visualized and a cavity appears where material should be. Only each object 
specific section results are displayed.
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Defining a Visualization Mode for Sketcher Elements 

This task shows you how to set the Sketcher elements visualization mode that best meets your needs. The Sketcher 
provides three different options, each of them dedicated to a particular need.

 In case you wish to set visualization modes for wireframe geometry, refer to Defining a Visualization Mode for 
Wireframe Elements which describes the different options available from the 2D Visualization toolbar 

.

Note that for efficiency purposes, it is recommended to use options dedicated to Sketcher elements visualization OR 
options dedicated to 3D elements visualization. Indeed, when working on a sketch, it is preferable not to use these 
two types of visualization simultaneously.

1.  From the Visualization toolbar, activate the Visu 3D sub-toolbar. 

2.  Set the visualization mode that best meets your needs:

�❍     Usual

�❍     Low Light

�❍     No 3D Background

Behavior Common to the Three Modes

Whatever mode you choose, you can always:

●     access and select features in the specification tree even when the 3D background is not visualized.

●     When editing a sketch, the visualization mode you defined for it is retrieved.

Working with the Usual Option

The Usual mode  is the default option. When activated, the 3D geometry is visible in the Sketcher.
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Working with the Low Light Option

If activated, the Low Light mode  introduces a low light for all geometrical elements and features that then 
appear as gray-colored, except for the current sketch. Additionally, although you can see them, you cannot select 
them. You can just handle Sketcher elements.
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Working with the No 3D Background Option

If activated, the No 3D Background mode hides all geometrical elements and features (products, parts, etc.) 
except for the current sketch. Even if geometrical elements are coplanar with the sketch plane, these elements are 
hidden.

3D Insight Version 5 Release 19 Page 880 of 1379



Defining a Visualization Mode for Wireframe Elements

 This task shows you how to set a visualization mode among several, for the wireframe elements you may see once 
in a sketch. The Sketcher provides different options, each of them dedicated to a particular need.

As a reminder, in case you prefer to set visualization modes restricted to the elements of the current sketch, refer to 
Defining a Visualization Mode for Sketcher Elements which describes the different options available from the Visu 3D 

toolbar .  

Note that for efficiency purposes, it is recommended to choose a visualization strategy once for all: Use options 
dedicated to Sketcher elements visualization OR options dedicated to 3D elements visualization. Indeed, when 
working on a sketch, it is preferable not to use these two types of visualization simultaneously.
To perform this task, create:
●     one intersection between zx and yz planes,

●     one intersection between yz and xy planes

then enter xy plane and sketch a profile. 

1.  From the Visualization toolbar, activate the 2D Visualization sub-toolbar:

2.  Set the visualization mode you prefer:

�❍      Pickable Visible Background

�❍      No 3D Background

�❍      Unpickable Background

�❍      Low Intensity Background

�❍      Unpickable Low Intensity Background

�❍      Lock

when performing the scenario, deselect the icon once you have seen the result.
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Pickable Visible Background

If activated, Pickable visible background  shows all geometric elements outside the sketch plane with a 
standard intensity. These elements can be picked, as illustrated below:

No 3D Background

If activated, No 3D background  hides all geometric elements outside the sketch plane.
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Unpickable Background

If activated, Unpickable background  shows all geometric elements outside the sketch plane with a standard 
intensity, but these elements cannot be picked.
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Low Intensity Background

If activated, Low intensity background  shows all geometric elements outside the sketch plane with a low 
intensity. These elements can be picked.
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Unpickable Low Intensity Background

If activated, Unpickable low intensity background  shows all geometric elements outside the sketch plane 
with a low intensity. These elements cannot be picked.
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Lock

If activated, Lock   locks the current view point is (provided a visualization mode is set).
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Converting Standard into Construction Elements 

This task shows how to convert standard elements into construction elements and vice versa.

Open the Construction_Standard.CATPart document.

1.  Select the line (standard type) you wish to convert into a construction line.

2.  Click Construction/Standard Element  from the Sketch tools toolbar. 

The line you previously selected appears dashed to show it is a new type of line.

3.  Click Construction/Standard Element  again. 

The construction line is converted into a standard line.
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Double-clicking on the line displays the Line Definition dialog box in which you can un-check the Construction 
element option if you want to convert the construction line into a standard line. For more information, refer to 
Modifying Element Coordinates.

●     In certain cases, construction elements are automatically created (e.g. when offsetting canonical elements, 
or when creating lines normal to a curve). If you subsequently delete the constraint or one of the elements, 
the construction element will be automatically removed.

●     Construction lines are not taken into account when entering another workbench.

●     Applying Construction/Standard Element  on axes has no effect.
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Hiding or Showing the Sketch Absolute Axis

This task shows you how to hide the sketch absolute axis outside and inside the Sketcher.

Open the CATPart document of your choice.

Outside the Sketcher

Outside the Sketcher, for example in Part Design or in Generative Shape Design, to hide your sketch absolute 
axis proceed as follows:

1.  Select the absolute axis or one of its sub-elements (origin, H or V direction) either in the specification 

tree or in the 3D Area. 

2.  Click Hide/Show  available in the View toolbar.  

The selected element is no longer displayed. It has been transferred into the No Show space. In our 

example, the whole absolute axis is now hidden.

As an alternative, you can right-click the absolute axis or one of its sub-elements and select Hide/

Show.

To restore the view, just select the hidden element and click Hide/Show  again. 
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Editing the Sketch

When editing the sketch, after applying the Hide command to the absolute axis, all elements remain visible in 

the Sketcher. The Absolute Axis icon remains gray in the specification tree to indicate that when leaving the 

Sketcher it will not be visible in the 3D Area.

Inside the Sketcher

To hide the whole sketch absolute axis once in the Sketcher proceed as follows:

1.  Multi-select all the sub-elements of the absolute axis either in the specification tree or in the geometry 

area. 

2.  Click Hide/Show .

Selecting the Absolute Axis node and then applying the Hide command on it has no effect.

To hide the one or all sub-elements of the whole sketch absolute axis once in the Sketcher proceed as follows:

1.  Select one of its sub-elements either in the specification tree or in the geometry area. 

2.  Click Hide/Show . 

Here, H direction has been hidden. 
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Exiting the Sketcher

3.  Click Exit workbench   to exit the Sketcher. 

When exiting the Sketcher, H direction is not visible in the 3D area. Its icon is gray in the specification 

tree meaning that whenever editing the sketch, H direction will not be visible in the Sketcher.
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Entering the Sketcher Workbench 

This task lists the different ways of entering the Sketcher workbench.

 To create a sketch, you have several possibilities: 
●     Select Start > Mechanical Design > Sketcher from the menu bar.

●     Select Sketch with Positioned Sketch  and specify the reference plane, and the origin and orientation of the axis system. This 
enables you to create a positioned sketch.  
 
This is the recommended method for creating a sketch, as it enables you to define explicitly the position of the axis system and ensures 
associativity with the 3D geometry.

●     Select Sketch  and click the desired reference plane either in the geometry area or in the specification tree, or select a planar surface. 
This creates a "non-positioned" sketch (i.e. a sketch for which you do not specify the origin and orientation of the absolute axis, which are 
not associative with the 3D geometry). The sketch absolute axis may "slide" on the reference plane when the part is updated.

 
●     Select one plane of the axis system. h and v are aligned to the main axes of this selected plane. Associativity is kept between both the 

plane and the sketch.

HV plane calculation in relation to selected plane: 

●     The normal of the working support is the same as the principal normal of the plane selected. You choose zx plane, the PRINCIPAL NORMAL 
is Y

●     The first vector H is define as follow : H= Z x N ( x means vectorial product). N is the normal vector y in our case. H = -X.

●     The second vector V is define as V = N x H Don't forget that H;V;N must make a direct trihedron. You can reorient the axis system in the 
work support but the axis system must be direct. So when changing one vector H, change the others too.

Orientation

Remember that depending on the plane you choose for your sketch, HV directions differ as follows: 

●     if the plane is selected from a user-defined axis system, h and v are aligned to the main axes of this selected plane.

●     otherwise, the sketch is positioned in relation to the origin of the part.

The Sketcher workbench appears as follows:

3D Insight Version 5 Release 19 Page 892 of 1379



 

Entering the Sketcher to edit an Existing Sketch

To edit an existing sketch, you have several possibilities: 

●     Double-click the sketch or an element of the sketch geometry, either in the geometry area or in the specification tree.

●     To do this from the 3D area, right-click the sketch in the specification tree, point to [sketch name] object in the contextual menu, and 
then select Edit.

Adding a Grid

To help you sketch your geometry, the application lets you add a grid. To know how to define and display a grid, Click here.
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Creating a Positioned Sketch 

 

 

 

 

In this task, you will learn how to create a positioned sketch, in which you specify the reference plane, and the 
origin and orientation of the absolute axis.

Creating a positioned sketch enables you to define (and later change) explicitly the position of the sketch 
absolute axis. This offers the following advantages:

●     You can use the absolute axis directions like external references for the sketched profile geometry.

●     When the geometry of the part evolves and the associated position of the sketch changes, the shape of the 
sketched profile (2D geometry of the sketch) remains unchanged (even if the sketched profile is under-
constrained). 

Creating a positioned sketch also ensures associativity with the 3D geometry.

Open the Positioned_sketch.CATPart document.

You will now create a positioned sketch that will enable you to design the retaining bracket for this part.  

You will position the sketch absolute axis as follows:

●     its origin will be on the axis of revolution,

●     its horizontal (H) direction will be parallel to the flat face,

●     its vertical (V) direction will be normal to the flat face.

1.  Click Positioned Sketch .  

The Sketch Positioning dialog box appears.
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In the Type field in the Sketch Positioning area, two options are available:

●     Positioned (pre-selected): creates a positioned sketch for which you specify the origin and 
orientation of the absolute axis.

●     Sliding: creates a "non-positioned" sketch, i.e. a sketch for which you do not specify the origin and 
orientation of the absolute axis. This option is mainly used for compatibility with non-positioned 
sketches, and to enable you to turn them into positioned sketches. With the Sliding option, the 
sketch absolute axis may "slide" on the reference plane when the part is updated.

2.  Keep the Positioned option selected. 

You will now specify the reference plane for the sketch.

3.  Make sure the Reference field is active, and select the blue surface (Shaft.1). 

The Sketch Positioning dialog box is updated: the Reference field now indicates the reference plane. 

Also, the Type fields of the Origin and Orientation areas are activated and the Implicit mode is pre-

selected.
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With the Implicit mode, the sketch origin point and the sketch orientation are positioned according to 
the geometry used for the sketch plane:

●     When the sketch support is a plane, the sketch origin point is a projection of the part origin point in 
the sketch plane, and the sketch orientation is parallel to the reference plane directions.

●     When the sketch support is defined by two secant lines, the origin is at the intersection of these. 
The H direction is co-linear to the first line, and its orientation directly depends on the orientation of 
this line. The V direction is deduced from the second line, which is not necessarily orthogonal to the 
first line. This second line simply defines, depending on its orientation, the side where the V 
direction will be positioned in relation to the H direction.

You will now specify the absolute axis origin so to make it coincident with the axis of revolution of the 
part.

4.  Select Curve intersection in the Type field of the Origin frame.  

The Reference field is activated.

The options available for defining an origin are:

�❍     Implicit

�❍     Part origin

�❍     Projection point

�❍     Intersection between 2 lines

�❍     Curve intersection

�❍     Middle point

�❍     Barycenter
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5.  Select the cylindrical surface to make its axis intersect with the absolute axis origin.

The absolute axis of the sketch is now positioned on this axis. Its orientation has not 
changed.

 

6.  You will now specify the absolute axis orientation according to an edge of the flat face. The options 

available for defining an orientation are:

�❍     Implicit

�❍     X Axis

�❍     Y Axis

�❍     Z Axis

�❍     Components

�❍     Through point

�❍     Parallel to line

�❍     Intersection plane

�❍     Normal to surface: you just need to select a surface intersecting the sketch plane.
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Select Parallel to line in the Type field of the Orientation frame.  

The Reference field is activated. 

7.  Select an edge of the flat face.

The absolute axis of the sketch is now oriented like the selected edge.
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 You will now invert the H direction and make the V direction normal to the flat face. To do this, start by 
selecting V Direction in the Orientation area to specify that you want the orientation to be defined 
according to the V direction.

8.  Select Reverse V to revert the V direction and select the Swap check box to swap H and V directions.

The sketch is now positioned as wanted.
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9.  Click OK to validate and exit the Sketch Positioning dialog box. 

You are now in the Sketcher workbench and ready to sketch a profile for the retaining bracket.

●     The absolute axis (its origin point, both its directions and the grid) can be used to specify the position and 
dimensions of the 2D geometry because it is associative with the part.

●     With positioned sketches, the origin and directions of the absolute axis are similar to external references 
(Use-Edges) obtained using additional projections or intersections when creating non-positioned sketches.

●     In this exercise, you did not create any constraints on 2D geometry: the geometry is under-constrained. Yet, 
if you move or resize the part (no matter how significantly), the profile you sketched will remain absolutely 
unchanged. Its shape will not be altered: thanks to the fact that the position of its absolute axis is explicitly 
defined, it is automatically pre-positioned in 3D before its 2D resolution.

●     At any time after creating a positioned sketch, you can change the reference plane, the origin and the 
orientation of the absolute axis by specifying the new geometry in the associated Reference field. To do this 
from the 3D, right-click the positioned sketch in the specification tree, point to [sketch name] object in 
the contextual menu, and then select Change sketch support.
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Changing a Sketch Support  

This task shows you how to change the position of a sketch by changing its support. Changing a sketch support 
amounts to editing the absolute axis definition of the sketch.

Open the Change_Sketch_Support.CATPart document. 

In this scenario, you will edit the absolute axis definition of Pocket.2/Sketch.3 by making it associative to 
Pocket.1. This will ensure that, when moving Pocket.1, Pocket.2 follows Pocket.1 without requiring you to edit 
the geometry of Sketch.3.

1.  From the specification tree, right-click Sketch.3. and select Sketch.3 object > Change Sketch 

Support.... 

If a message appears, informing you that if you change its position, the sketch may become inconsistent or 

over-constrained, simply click OK.  

The Sketch Positioning dialog box appears. 

2.  If the Move geometry option at the bottom of this dialog box is checked, uncheck it. This will prevent the 

geometry from moving when performing the next operations in the dialog box. 

In the Type field in the Sketch Support area, three options are available:
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�❍     Positioned: positions the sketch using the origin and orientation of the absolute axis.

�❍     Sliding: default type used for non-positioned sketches (i.e. when you edit a non-positioned sketch, this 
option will be selected by default, as is the case in our example). This option is mainly used for 
compatibility purposes, and to enable you to turn non-positioned sketches into positioned ones.  
With the Sliding option, the sketch is not positioned, i.e. the origin and orientation of the absolute axis 
is not specified. As a result, its absolute axis may "slide" on the reference plane when the part is 
updated.

�❍     Isolated: isolates the sketch in order to break all absolute axis links (support, origin and orientation 
links) with the 3D or to solve update errors. Only the 3D position will be kept, to ensure that the sketch 
does not move. With the Isolated option, you cannot define the sketch support, origin and orientation.

3.  Select the Positioned option, and make sure Pad.1/Face is selected as the reference element for the 

sketch support (Reference field).

4.  At this point, check the Move geometry option to specify that, from now on, the geometry should be 

moved when the sketch position is modified.

5.  Check the Swap box to swap H and V directions. The new sketch position is previewed in the geometry 

area. 

 
You are now going to make the absolute axis associative with Pocket.1.

6.  Uncheck Move geometry once again to ensure that the geometry does not move according to the newly 

defined axis.

7.  In the Type field in the Origin area, select Intersection 2 lines.

8.  You will now specify the reference element for the origin. To do this, make sure the Reference field is 

active, and select a horizontal edge of Pocket.1 as shown below. 
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9.  Now, select a vertical edge of Pocket.1 as shown below. 

10.  In the Orientation areas, leave the Type field set to Implicit and the Reference field set to No Selection. 

For more information on the other options available in the Origin and in the Orientation areas, refer to 

Creating a Positioned Sketch in the Sketcher User's Guide.

11.  Click OK.  

The absolute axis definition of Sketch.3 is modified and the position of the pocket is changed. 
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12.  From the specification tree, double-click Sketch.2 to edit it. 

13.  On the sketch, double-click the the offset value as shown: 

14.  In the Constraint Definition dialog box which is displayed, enter a new value, 90 for example, and click 

OK. The constraint is updated, and Sketch.2 is moved accordingly.
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15.  Exit the Sketcher workbench. As you can see, Pocket.1 has been moved, and Pocket.2 is still positioned 

according to the absolute axis you defined for Sketch.3. 

 

Positioning Sketch Created Using Copy/Paste As Result With 
Link Option 

If needed, you can modify the 3D position of a sketch feature obtained by copying and pasting using As Result 
With Link using the same positioning capabilities as with any sketch features. In this case, associativity between 
the original geometry and the geometrical result is kept but associativity with the position is lost.

Positioned as reference available in the Type field of the Sketch Positioning area restores the associativity of 
position with the sketch feature reference. If you select this support definition option, all the other fields are disabled 
and set to their default values.
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Move geometry is not available in the Sketch Positioning dialog box. If you isolate (using the Isolate contextual 
command) a sketch feature, its sketch positioning definition is not affected by default. You have to explicitly set an 
isolated sketch positioning definition using the Change Sketch Support... contextual command. But for a sketch 
obtained using Copy>Paste>As Result With Link with the Positioned as reference type, you need to set 
Isolated as the type of the sketch. In this case Positioned as reference is no more available in the support Type 
field.

Pre-R19 sketches need to be upgraded to use access these positioning functionalities.
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Sketching Simple Profiles

The Sketcher workbench provides a set of functionalities for creating 2D geometry and more precisely pre-defined 
profiles. 

Before you begin, make sure you are familiar with Tools For Sketching.

As soon as a profile is created, it appears in the specification tree. 

Note that if you position the cursor outside the zone that is allowed for creating a given element, the  symbol appears.

 

Creating a profile: Use the Sketch tools toolbar or click to define lines and arcs which the profile may be made of.

Creating a rectangle: Use the Sketch tools toolbar or click the rectangle extremity points one after the other.

Creating a circle: Use the Sketch tools toolbar or click to define the circle center and then one point on the circle.

Creating a three point circle: Use the Sketch tools toolbar or click to define the circle start point, second point and 
endpoint one after the other.

Creating a circle using coordinates: Use the Circle Definition dialog box to define the circle center point and radius.

Creating a tri-tangent circle: Click three elements one after the other to create a circle made of three tangent 
constraints.

Creating an arc: Use the Sketch tools toolbar or click to define the arc center and then the arc start point and 
endpoint.

Creating a three point arc: Use the Sketch tools toolbar or click to define the arc start point, second point and 
endpoint one after the other.

Creating a three point arc (using limits): Use the Sketch tools toolbar or click to define the arc start point, endpoint 
and second point one after the other.

Creating a spline: Click the points through which the spline will go.

Connecting curves with a spline: Click the first, and then the second element to connect.

 
Connecting curves with an arc: Click the first, and then the second element to connect.

Creating an ellipse: Use the Sketch tools toolbar or click to define the ellipse center, major semi-axis and minor semi-
axis endpoints one after the other.

Creating a parabola: Click the focus, apex and then the parabola two extremity points. 

Creating a hyperbola: Click the focus, center and apex, and then the hyperbola two extremity points. 

Creating a conic: Click the desired points and excentricity for creating an ellipse, a circle, a parabola or a hyperbola, 
using tangents, if needed. 

Creating a line: Use the Sketch tools toolbar or click the line first and second points.
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Creating an infinite line: Use the Sketch tools toolbar or click the infinite line first and second points.

Creating a bi-tangent line: Click two elements one after the other to create a line that is tangent to these two 
elements.

Creating a bisecting line: Click two lines.

 
Creating a line normal to a curve: Click a point and then the curve.

Creating a symmetrical extension: Use the Sketch tools toolbar or click the center point and then the extremity 
point of a line that is a symmetrical extension to an existing one.

Creating an axis: Use the Sketch tools toolbar or click the axis first and second points.

Creating a point: Use the Sketch tools toolbar or click the point horizontal and vertical coordinates.

Creating a point using coordinates: Enter in the Point Definition dialog box Cartesian or polar coordinates.

Creating an equidistant point: Enter in the Equidistant Point Definition dialog box the number and spacing of the 
points to be equidistantly created on a line or a curve-type element.

Creating a point using intersection: Create one or more points by intersecting curve type elements via selection. 

Creating a point using projection: Create one or more points by projecting points onto curve type elements.
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Creating Profiles 

This task shows how to create a closed profile. A profile may also be open (if you click the profile end point in 
the free space). Profiles may be composed of lines and arcs which you create either by clicking or using the 
Sketch tools toolbar.

1.  Click Profile .  

The Sketch tools toolbar displays values for defining the profile.

Three profile mode options are available:

●     Line:  (default mode)

●     Tangent Arc:  

●     Three Point Arc:  

 
2.  Type in the Sketcher tools toolbar for the first point: H=30mm, V=40mm and press Enter.

3.  Type in the Sketcher tools toolbar for the end point: H=70mm, V=40mm and press Enter.

The line appears as shown here, with the constraints corresponding to the line created via the Sketch 
tools toolbar options.
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 Note that at this step, you may also enter length L and angle A values.

4.  Select Tangent Arc . 

A rubberbanding arc follows the cursor, showing the tangent arc to be created.

When you sketch a profile using the cursor (in other words without using the Sketch tools toolbar and 

typically the Tangent Arc ) you can switch from the Line mode to the Tangent Arc mode by 
holding down the mouse left button, moving the cursor and then releasing the button to position the 
tangent arc end point. A rubberbanding rectangle appears representing the arc of circle.

Tangent arcs are always positioned in the direction of the element previously created.

 
5.  Click to indicate the arc end point.
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 The default mode is back to Line.

6.  Start drawing another line.

 
7.  Click to indicate the line end point.
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8.  Click Three Points Arc .

9.  Click to indicate a point which the profile is going to go through (arc second point).

10.  Click the start point of the line first created. 

You thus define the three point arc end point.
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The profile results as shown here:
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Creating Rectangles 

This task shows how to create a rectangle. In this task, we will use the Sketch tools toolbar but, of course you 
can create this rectangle manually. For this, move the cursor to activate SmartPick and click as soon as you get 
what you wish.

1.  Click Rectangle .  

The Sketch tools toolbar displays values for defining the rectangle. For more information, see Using 

Tools for Sketching in the Sketcher User's Guide

2.  Position the bottom-left point at: H=20mm, V=20mm.

3.  Position the top-right corner from the first point: Width=40mm, Height=25mm. 

The rectangle is created.
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Constraints are similarly assigned to this rectangle on the condition you previously activated the 

Dimensional Constraints option  in the Sketch tools toolbar. 
As a result, to modify the position of this rectangle, you will perform as follows:

4.  Double-click the constraint corresponding to the value to be modified. 

The Constraint Definition dialog box appears.

5.  Enter 50mm and click OK.
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Creating Circles 

This task shows how to create a circle. In this task, we will use the Sketch tools toolbar but, of course you can 
create this circle manually. For this, move the cursor to activate SmartPick and click as soon as you get what 
you wish.

By default, circle centers appear on the sketch. In case you create circles by clicking, if you do not need them, 
you can specify this.

1.  Click Circle .  

The Sketch tools toolbar displays values for defining the circle.

2.  Type in the Sketcher tools toolbar for the circle center: H=30mm, V=30mm and press Enter.

3.  Type in the Sketcher tools toolbar for the point on circle: R=20mm and press Enter.

The circle is created.
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Constraints are similarly assigned to this circle on the condition you previously activated the 

Dimensional Constraints option  in the Sketch tools toolbar.

 
4.  Double-click to edit the offset constraint corresponding to the radius. 

The Constraint Definition dialog box appears.

5.  Select Diameter in the Dimension combo list and click OK. 

The offset constraint type has been changed to diameter.
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Copying the Circle Radius Parameters

Once you have created one circle, you can create any other and in the meantime use the radius parameter from 
the circle first created. To do this:

6.  Click Circle .

7.  Right-click the first circle and select Parameter > Copy Radius from the contextual menu. 

The new circle is automatically created with the radius of the circle first created but not positioned.

8.  Click to indicate the second circle location or use the Sketch tools toolbars to specify the circle center. 

The new circle is positioned.

Changing the Circle Radius

Once you have created a circle, you can change its radius. To do this, you can:

●     If the offset constraint corresponding to the radius exists:

�❍     Double-click the offset constraint and modify the radius value in the Constraint Definition 
dialog box that appears.

Otherwise:

●     Double-click the circle and modify the radius value in the Circle Definition dialog box that appears.

●     Drag the circle until you are satisfied with its new radius.

If the circle center is fixed (or iso-constrained), you can change the circle radius by using one of the methods 
explained above. 
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Creating Three Point Circles 

This task shows you how to create a circle that goes through three points. In this task, we will use the Sketch tools toolbar but, of course you can create 
this circle manually. For this, move the cursor to activate SmartPick and click as soon as you get what you wish.

By default, circle centers appear on the sketch. In case you create circles by clicking, if you do not need them you can specify this in the Options dialog box. 
For this, go to Tools > Options, Mechanical Design > Sketcher option (Sketcher tab). 

1.  Click Three Point Circle  from the Profiles toolbar (Circle subtoolbar).

2.  The Sketch tools toolbar displays one after the other the values for defining the three points of the circle: values for defining the horizontal (H) and vertical 

(V) values of a point on the circle or else the radius of this circle.  

Position the cursor in the desired fields and key in the desired values. 

 

First Point (H: 10mm and V: 10mm) 

Second Point (H: 50mm and V: 20mm)

Last Point (H:30mm and V: 50mm)

The three point circle appears: 
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Creating Arcs 

This task shows how to create an arc. In this task, we will use the Sketch tools toolbar but, of course, you can  create this arc manually. For this, move 
the cursor to activate SmartPick and click as soon as you get what you wish.

By default, arc centers appear on the sketch and are associative. In case you create arcs by clicking, if you do not need them you can specify this in the 
Options dialog box. For this, go to Tools > Options, Mechanical Design > Sketcher option at the left of the dialog box (Sketcher tab). 

1.  Click Arc  from the Profiles toolbar (Circle subtoolbar).

 

 

2.  The Sketch tools toolbar now displays values for defining one after the other the arc center point, start point and end point. Position the cursor 

in the desired field (Sketch tools toolbar) and key in the desired values.

Arc Center 

Start Point 

 

For example, enter H: 18mm and V: 30mm (Circle Center) and then H: 40mm and V: 40mm 
(Start Point). 

The arc center and start point appear.

 

The arc will now appear according to the position you assign to the cursor. In this particular case, the cursor position is at the bottom extremity of the arc.

End Point 
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For example, enter S: -70deg (Angular Sector).

The arc appears as shown here.
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Creating Three Points Arcs 

This task shows how to create an arc using three reference points in order to define the required size and radius. In this task, we will use the 
Sketch tools toolbar but, of course you can create this arc manually. For this, move the cursor to activate SmartPick and click as soon as you 
get what you wish.

By default, arc centers appear on the sketch and are associative. In case you create arcs by clicking, if you do not need them you can specify 
this in the Tools > Options dialog box. For this, go to Tools > Options, Mechanical Design > Sketcher option at the left of the dialog box 
(Sketcher tab). 

1.  Click Three Point Arc  from the Profiles toolbar (Circle sub-

toolbar).

 

2.  The Sketch tools toolbar will display one after the other values for defining the three points of the circle: defining the horizontal (H) 

and vertical (V) values of three points on the arc. Position the cursor in the desired fields and key in the desired values.

Start Point (H: 12mm and V: 32mm) 

Second Point (H: 27mm and V: 17mm) 

End Point (H: 12mm and V: 7mm) 

The arc results as shown here.
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Creating Three Points Arcs Using Limits 

This task shows how to create a three point arc by starting creating the arc limits first. In this task, we will use the Sketch tools toolbar but, of course 
you can create this arc manually. For this, move the cursor to activate SmartPick and click as soon as you get what you wish.

By default, arc centers appear on the sketch and are associative. In case you create arcs by clicking, if you do not need them you can specify this in 
the Options dialog box. 

To do so, go to Tools > Options, Mechanical Design > Sketcher option at the left of the dialog box (Sketcher tab). 

1.  Click Three Point Arc Starting with Limits 

 from the Profiles toolbar (Circle sub-

toolbar). 

The Sketch tools toolbar will display one after 

the other values for defining the three points of 

the circle: values for defining the horizontal (H) 

and vertical (V), values for defining the arc start, 

end or second  points or else the radius of this 

arc. 

 

2.  Position the cursor in the desired fields and key in 

the desired values. 

 

 

 
 

 
 

 
 

Start Point (H: 25mm and V: 37mm)

End Point (H: 25mm and V: 7mm)

Second Point (R: 15.5mm)

 

3.  Drag the cursor and click to create the arc 

intermediate point (the point which the arc will go 

through).
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The three point arc appears:
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Creating Splines 

This task shows you how to create a spline and then modify the spline control points (coordinates or clicking).

1.  Click Spline  from the Profile 

toolbar.

 

 

2.  Click in the geometry to indicate the 

points through which the spline goes. 

3.  Double-click the last point you have 

created to finish the spline creation. 

(Clicking again on Spline  or 

another command also ends the spline 

creation.)

 
At any time when creating a spline, you can close 
it by right-clicking the last point and selecting 
Close spline from the contextual menu.
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The spline is closed in such a way that it is 
continuous in curvature.

●     Keep in mind that using the displayed Sketch 
tools toolbar also allows creating a spline. In 
addition, two constraints will be created (H 
and V).

 

Modifying the spline control points

1.  Double-click the control point you wish to edit.  

The Control Point Definition dialog box appears.

2.  Enter new coordinates. For example, v: 9mm (vertical).

3.  Check the Tangency option to impose a tangency on this control point. The point is moved and an arrow 

appears on this point to indicate a tangency.  
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You can invert the tangent direction clicking the Reverse tangent button.

4.  Click OK.

You can also check the Curvature option to activate the Curvature editor and impose a curvature on the 
previously selected control point. 

Keep in mind that selecting a point then dragging it will modify the spline shape.

Tangents can be constrained.
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 Connecting Curves with a Spline 

This task shows you how to connect two elements of the curve type, using a connecting curve (a spline) that 
goes through their end points. 

A connecting curve is associative, and it can be continuous in point, in curvature or in tangency with its support 
curves. You can define the tension value and the direction of the continuity at each connecting point, as well as 
add constraints to the connecting curve. Moving a connecting curve will change the shape of the support curves 
accordingly. 

Open the Connect_Curves.CATPart document.

1.  Click Connect . 

The Sketch tools toolbar now displays connection and continuity options for defining the connection:

Connection options are:  

�❍     Connect with an Arc: 

�❍     Connect with a Spline:  (selected by default).

Continuity options are (available with Connect with a Spline option only):

�❍     Continuity in point: 

�❍     Continuity in tangency: 

�❍     Continuity in curvature:  (selected by default.)

 Tension value corresponds to a multiplying coefficient applied to the tangent vector norm (available 
with Continuity in tangency and Continuity in curvature options only). The default value is 1 and 
the 0 value corresponds to a continuity in point.

2.  Select the first spline to be connected.
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3.  Select the second spline to be connected.
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Locations where you click to select the first and the second element are important: the closest point to 
where you click will be automatically used as the starting point and the end point of the connecting 
curve. Always click close to the point you want to connect, or click the point itself.

 A connecting spline appears: it is continuous in curvature to both selected elements.

 

 

4.  Click Connect .

5.  Select the Continuity in point option .

6.  Select the first spline to be connected.
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7.  Select the second spline to be connected.
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 A connecting spline appears: it is continuous in point to both selected elements.
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●     You can edit the connecting curve, as well as add constraints to it.

●     You can also move the connecting curve: in this case, the shape of the support elements will change 
accordingly, as shown here for example. 

●     You cannot trim  nor break  connecting curves. To workaround this restriction, you can project 
the connecting curve of interest onto another sketch, then trim the projected elements.
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Connecting Curves with an Arc  

This task shows you how to connect two elements of the curve type using an arc. 

Open the Connect_Spline.CATPart document. 

1.  Click Connect  from the Profile toolbar (Spline sub-toolbar).  

The connect options appear in the Sketch tools toolbar. By default, the Connect with a Spline option is 

active, and its related options are displayed. 

 

 

2.  Click the Connect with an Arc option .

3.  Select a first element to connect (starting point), and then a second element (ending point).

 

●     The point on which you click to select the first and the second element is important: the closest point to where 
you click will be used as the starting point and the end point of the connecting curve. Always click close to the 
point you want to connect, or click the point itself. 
A connecting arc appears, tangent to both selected elements.

 

 

●     You cannot trim  nor break  conic curves. To workaround this restriction, you can project the conic curve of interest onto another sketch, then trim 
the projected elements.
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Creating Ellipses 

This task shows how to create an ellipse (made of two infinite axes). In this task, we will use both the Sketch tools toolbar and clicking. In other words, you 
will move the cursor to activate SmartPick and click as soon as you get what you wish.

1.  Click Ellipse  from the Profiles toolbar. 

The Sketch tools toolbar displays values for defining the ellipse center point, major and then 

minor semi-axis endpoint. 

2.  Position the cursor in the desired fields and key in the desired values.

 

Center 

 For example, enter H: 9mm and V: 8mm. 

Note that you can also click to create a first point that corresponds to the ellipse center.

 

Major Semi-Axis Endpoint 

 

For example, enter H: 65mm and V: 8mm. 

You just created a point on the ellipse. This point allows defining the major semi-axis.

 

  

By default, centers are created and associative but if you do not need them you can specify this in the 

Tools > Options dialog box. For more information, see the Infrastructure user's guide.

3.  Move the cursor and click a point on the ellipse. 

You just created a point which allows defining both minor semi-axes.
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Creating a Parabola by Focus 

This task shows you how to create a Parabola by Focus by clicking the focus, apex and then the parabola two extremity points.

1.  Click Parabola by Focus  from the Profiles toolbar (Conic subtoolbar).

2.  Click to define the parabola focus and apex.

Focus:

Apex:

 

3.  Click two points that correspond to the parabola end points.  

 

First Point:
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Second Point:

4.  The parabola results as shown here:
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Creating a Hyperbola by Focus 

This task shows you how to create a hyperbola by clicking the focus, center and apex, and then the hyperbola two extremity points.

1.  Click Hyperbola by Focus  from the Profiles toolbar (Conic subtoolbar).

2.  Click to define the hyperbola focus, center and apex. 

Focus: 
Once you click, the focus is symbolized 
by a cross ( ).

Center (asympote intersection): 
The center is not associative to the hyperbola.

Apex:
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3.  Click two points that correspond to the hyperbola end points.  

 

First Point:

Second Point: 

The hyperbola results as shown here:

 

 

 

Note that, you can use the Sketch tools toolbar for defining the excentricity of the hyperbola. 
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Creating Conic Curves 

This task shows you the different methods you can apply to create conic curves which are either arcs of parabolas, hyperbolas or ellipses.

 The Sketch tools toolbar displays options for defining the conic:

 

 
●     Conic creation type options are:

 Two Points type allows you to create a conic from two points (the start and end points), two tangencies at these points and either a 
parameter or a passing point. 
This type is activated by default. See Using Two Points and Start and End Tangent and Using Two Points and Tangent Intersection Point.

Four Points type allows you to create a conic from four points (the start and end points, and two intermediate passing points) and one 
tangency at one of these points. Intermediates passing points have to be selected in logical order. 
See Using Four Points with a Tangency at Passing Point.

Five Points type allows you to create a conic from five passing points (the start and end points, and three intermediate passing points). 
You cannot define a tangency at any of these point. Intermediates passing points have to be selected in logical order. 
See Using Five Points.

●     Conic creation mode options are:

 Nearest End Point allows you to create a conic based on existing curved. If the selected points belong to a curve the tangent direction 
is directly read on the curve. 
This mode is activated by default. 
See Using Two Points with the Nearest End Point Mode.

Start and End Tangent mode allows you to define:
●     The tangencies at start and end points for Two Points type. For Two Points type, this mode is activated by default, see Using Two 

Points and Start and End Tangent.

●     The tangency at one point only for Four Points type, if you deactivate this mode for the three first created points, a tangency must 
be automatically defined for the last point. 
Each time you redefine a tangency at one point, the previous defined tangency is removed, see Using Four Points with a Tangency at 
Passing Point. 
For Four Points type, this mode is activated by default.

This mode is available with Two Points and Four Points types only, and for these types activated by default.

Tangent Intersection Point mode, available with Two Points type only, allows you to define the intersection point of the start and 
end tangents. 
The start and end tangents are defined from this point and the start and end points respectively. 
This mode deactivates the Start and End Tangent mode. 
See Using Two Points and Tangent Intersection Point.

 
●     The conic is variational and associative with the geometrical inputs, which means that it will be updated after every modification of a geometry 

input.

●     You can also edit the curve or add constraints to it.

●     You cannot trim  nor break  conic curves. To workaround this restriction, you can project the conic curve of interest onto another 
sketch, then trim the projected elements.

 

Using Two Points and Start and End Tangent

1.  Click Conic .

2.  Select the Two Points type .

3.  Click to indicate the start point: H=20mm, V=20mm.
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4.  Type in the Sketcher tools toolbar for the start tangent point: H=30mm, V=50mm and press Enter.

 

 The start point and tangent have been created.

 

 
5.  Click to indicate the end point: H=90mm, V=10mm
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6.  Type in the Sketcher tools toolbar for the end tangent point: Angle=120deg, and H=70mm, and press Enter.

 

 

With a Parameter

The parameter value is a ratio ranging from 0 to 1 (excluded), this value is used to define a passing point:

●     If parameter = 0.5, the resulting curve is a parabola.

●     If 0 < parameter < 0.5, the resulting curve is an arc of ellipse.

●     If 0.5 < parameter < 1, the resulting curve is a hyperbola.

 
7.  Type in the Sketcher tools toolbar for the parameter: Parameter=0.3 and press Enter.

 

 The conic is created.
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With a Passing Point

 
6.  Type in the Sketcher tools toolbar for the parameter: H=50mm, V=40mm and press Enter.

 

 The conic is created.

 

 

Using Two Points and Tangent Intersection Point
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1.  Click Conic .

2.  Select the Two Points type .

3.  Select Tangent Intersection Point .

4.  Click to indicate the start point:  H=20mm, V=20mm

 

 
5.  Click to indicate the end point: H=90mm, V=10mm
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6.  Click to indicate the tangent intersection point: H=60mm, V=60mm

 

 

With a Parameter

The parameter value is a ratio ranging from 0 to 1 (excluded), this value is used to define a passing point:

●     If parameter = 0.5, the resulting curve is a parabola.

●     If 0 < parameter < 0.5, the resulting curve is an arc of ellipse.

●     If 0.5 < parameter < 1, the resulting curve is a hyperbola.

 
7.  Type in the Sketcher tools toolbar for the parameter: Parameter=0.3 and press Enter.

 

 The conic is created.
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With a Passing Point

 
6.  Click to indicate the passing point: H=50mm, V=40mm. 

The conic is created.

 

Using Two Points with the Nearest End Point Mode

1.  Create two lines, the first between H=10mm, V=0mm and H=40mm, V=60mm, and the second between H=90mm, V=0mm and 

H=90mm, V=40mm 
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2.  Click Conic .

3.  Select the Two Points type .

4.  Select the Nearest End Point mode .

5.  Click to indicate the start point: H=20mm, V=20mm

 

 
6.  Click to indicate the end point: H=90mm, V=10mm
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7.  Click to indicate the passing point: H=60mm, V=40mm

 

The conic is created:

●     The tangents at the start and end points have been defined by the lines.

●     The start and end points taken into account are the nearest extremities of the lines during the selection.
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When you redo the previous steps deactivating the Nearest End Point mode:

●     The tangents at the start and end points have been defined by the lines.

●     The start and end points taken into account are the selected points on the lines.

 

 

Using Four Points with a Tangency at Passing Point

1.  Click Conic .

2.  Select the Four Points type .

3.  Click to indicate the start point: H=20mm, V=20mm
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4.  Type in the Sketcher tools toolbar for the start tangent point: H=30mm, V=50mm and press Enter.

 

 The start point and tangent have been created.

 

 
5.  Click to indicate the end point: H=90mm, V=10mm
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6.  Select the Start and End Tangent mode .

7.  Click to indicate the first passing point: H=60mm, V=50mm

 

 
8.  Type in the Sketcher tools toolbar for the first tangent point: H=90mm, V=50mm and press Enter.

 

 
9.  Click to indicate the second passing point: H=100mm, V=40mm
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The conic is created. The defined tangent at the start point has been released and the construction line representing the tangent has 
been removed.

 

Using Five Points

1.  Click Conic .

2.  Select the Five Points type .

3.  Click to indicate the start point: H=20mm, V=20mm
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4.  Click to indicate the end point: H=90mm, V=10mm

 

 
5.  Click to indicate the first passing point: H=30mm, V=50mm
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6.  Click to indicate the second passing point: H=60mm, V=50mm

 

 
7.  Click to indicate the third passing point: H=90mm, V=30mm
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 The conic is created.
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Creating Standard or Construction Elements

This task shows how to create standard elements or construction elements. Note that creating standard or construction elements is based upon the same 
methodology.

If standard elements represent the most commonly created elements, on some occasions, you will have to create geometry just to facilitate your design. Indeed, 
construction elements aim at helping you in sketching the required profile.

 

1.  Click Standard/Construction  from the Sketch tools toolbar so that the elements you are now going to create be either standard or 

construction element.

In this task, you will transform the newly created elements into construction elements.

As construction elements are not taken into account when creating features, note that they do not appear outside the Sketcher.

 

 

Here is an example of the use of both types of elements.  
The hexagon was sketched using three construction 
circles:

This type of sketch is interesting in that it simplifies the creation and the ways in which it is constrained. Setting a radius constraint on the second circle is 
enough to constrain the whole hexagon. Just imagine what you would have to do to constrain hexagons sketched with no construction circles!

Standard or Construction Points

Points are represented either by crosses or just by points, depending on the chosen creation mode.

●     In standard mode, which is the default mode, points created on a line, for instance, are represented by crosses. The points and the line are visible outside 
the Sketcher workbench.

●     Points generated by Break operations are created in construction mode, even if Standard/Construction  is set to Standard.
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Creating Lines

This task shows how to create a line. In this task, we will use the Sketch tools toolbar but, of course you can create this line manually. For this, move the 
cursor to activate SmartPick and click as soon as you get what you wish.

1.  Click Line .  

The Sketch tools toolbar now displays values for defining the line.

2.  Type in the Sketcher tools toolbar for the start point: H=18mm, V=18mm and press Enter.

3.  Type in the Sketcher tools toolbar for the end point: L=30mm, A=45deg and press Enter.

 
The line is created. 

Constraints are similarly assigned to this line on the condition you previously activated the Dimensional Constraints option  in the Sketch tools toolbar.

 
4.  Double-click to edit the angle constraint.

The Constraint Definition dialog box appears.

 

 
5.  Set the new angle Value to 30deg and click OK.
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Care when you assign graphical attributes to a line (for example, make it thick and red). 
When you turn this red thick line into a construction line (from the contextual menu: Object.Line > Definition..., Construction line option in the 
Line Definition dialog box), the line will become a dotted gray line.  Even though you then decide to make it a standard line back again (un-checking 
the Construction line option), the "red" and "thickness" attributes will not be assigned to the line. The line will be assigned its original attributes (white).

 

Defining Line Length/Angle Parameters

 Once you have created one line, you can create any other and in the meantime use the length from the line first created or set this first line as an angle 
reference. For this:

 

6.  Click Line .

7.  Right-click the first line and select Parameter > Copy Length from the contextual menu.

8.  Click to indicate the start point location.

 

        

 
9.  Click to indicate the end point location.
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 The new line is created with a length of 30mm.

 

        

 

10.  Click Line .

11.  Right-click the first line and select Parameter > Set As Angle Reference from the contextual menu. 

A red arrow symbolizing the reference orientation for the angle is displayed on the first line.

 

        

 
12.  Type in the Sketcher tools toolbar for the angle line: A=75deg and press Enter.
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13.  Click to indicate the start point location.

 

        

 
14.  Click to indicate the end point location.

 

        

 The new line is created with an angle of 75deg in relation to the first line reference orientation.
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Creating an Infinite Line  

This task shows how to create an infinite line either horizontal or vertical, or still according to two points you will 
specify using SmartPick. 

1.  Double-click 

Infinite Line 

  from the 

Profile toolbar 

(Line sub-

toolbar). 

Three options 

appear in the 

Sketch tools 

toolbar.  

Horizontal 

Line  is 

the default 

option.

 

 

2.  If you keep the 

Horizontal 

Line option 

active, as you 

go over the 

viewer with the 

cursor, an 

horizontal line 

automatically 

appears. Click 

to position the 

line.
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 3.  Activate Vertical Line  from the Sketch tools toolbar.

 

4.  As you go over 

the viewer with 

the mouse, a 

vertical line 

now 

automatically 

appears. Click 

to position the 

line.
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5.  Activate Line Through Two Points  from the Sketch tools toolbar. 

Note that the angle (A) now appears in the Sketch tools toolbar and can be valued at any time for 

defining the line. 

 

6.  Click to position 

a start point on 

the infinite line 

to be created.
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7.  Click to position 

an end point on 

the infinite line 

to be created.
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Creating a Bi-Tangent Line

This task shows how to create a bi-tangent line by creating two tangents (on two different elements).

Create two circles.

1.  Click Bi-Tangent Line  from the Profiles toolbar (Line subtoolbar).

2.  Click a first element (first tangent). For example, click a circle.

3.  Click a second element (second tangent). For example, click another circle. 

The bi-tangent line appears between both selected elements.

The bi-tangent line appears as well as the corresponding constraints provided you 

activated Geometrical Constraints .

●     Tangents are created as close as possible to where you clicked on the circle.

●     Ensure that your sketch is consistent before creating bi-tangent lines (you can use Sketch Analysis for this). Otherwise, the system will not 

compute the tangencies properly.

At this step, create a  point.

At any time, you can select a point type element. The line will go through this point and 
a coincidence constraint is created on this point.
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Creating a Bisecting Line  

This task shows how to create an infinite bisecting line by clicking two points on two existing lines. 

Open the Line_Bisecting.CATPart document.

1.  Double-click Bisecting Line   from the 

Profiles toolbar (Line sub-toolbar).

 

2.  Click two points on the two existing lines, 

one after the other.
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The infinite bisecting line automatically appears, in 
accordance with both points previously clicked.

 

 

 

Note that this bisecting line corresponds to a line symmetrically constrained to two lines (of course on the 

condition that Geometrical Constraint  is active in the Sketch tools toolbar). If both selected lines are 

parallel to each others, a new line will be created between these lines.
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Creating a Line Normal to a Curve  

This task shows how to create a line normal to a curve. As a perpendicularity constraint is created, the line remains 
perpendicular to the curve even when it is moved. 

Create a spline.

1.  Click Line Normal To Curve  in the Profile toolbar (Line sub-toolbar).

The Select a Curve before icon in the Sketch Tools toolbar is activated by default to select the 
curve from which a line is created.

2.  Select a point on a curve to define first end point of a line. 

 

 
 

3.  Select a point which does not lie on the curve to define second end point of a line. You are allowed to 

select this point only in a direction which is normal to the curve at the first selected point. The line is 

created, as well as a perpendicularity constraint (between the line and the curve). 

 

Click Select a Curve before icon to deactivate it. In this case, you can select first end point of a line outside a 
curve and then select second end point on a curve to create a line normal to it. You can observe that the lines 
normal to a curve are created as close as possible to where you clicked on the curve for selecting second point of a 
line. You will get better results if, before clicking the curve, you try to position the line as perpendicular to the curve 
as possible.  
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Creating Symmetrical Extensions 

This task shows how to create a symmetrical extension to a line. In other words, you are going to create a median to an existing line by clicking. Still, you 

can use the Sketch tools toolbar.

Create a line.

1.  Click Line  from the Profile toolbar.

2.  Click Symmetrical  that appears in the Sketch tools toolbar. 

 

 

3.  Click the center point of the line which is to be assigned a symmetrical extension.

4.  Drag the cursor to the desired location. 

The median appears. It is perpendicular to the line, at the line midpoint.

5.  Click to locate the symmetrical extension.

  

The median is created.

If needed, move the symmetrical extension to a new position.
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Creating an Axis 

This task shows how to create an axis. You will need axis whenever creating shafts and grooves. 

1.  Click Axis . 

2.  Click to indicate the start point: H=20mm, V=10mm

 

3.  Click to indicate the endpoint: H=20mm, V=50mm
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 The axis is created.

 

●     You can create only one axis per sketch, if you try to create a second axis, the first axis created is automatically 
transformed into a construction line.

●     If before you start Axis you have already selected a line, this line will automatically be transformed into an axis.

●     Axes cannot be converted into construction elements.
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Creating Points 

This task shows you how to create a point. In this task, we will use the Sketch tools toolbar but, of course you 
can create this point manually. For this, move the cursor to activate SmartPick and click as soon as you get 
what you wish.

1.  Click Point .  

The Sketch tools toolbar now displays values for defining the point.

2.  Type in the Sketcher tools toolbar for the start point: H=19.7mm, V=19.5mm and press Enter. 

The point is created.

 

Constraints are similarly assigned to this point on the condition you previously activated Dimensional 

Constraints  in the Sketch tools toolbar.

 
3.  Double-click to edit the 19.7mm offset constraint. 

The Constraint Definition dialog box appears.
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4.  Set the offset Value to 20mm and click OK.

For creating an isobarycenter, click (or multi-select) at least two points before clicking the Point command. Note 
that an isobarycenter can only be created between points. In other words, if you multi-select a rectangle, the 
four points of this rectangle, and only these four points, will be used for defining the isobarycenter. Associativity 
is no more valid.

 

Symbols Representing Points

Points are represented either by crosses or just by points, depending on the chosen creation mode.

●     In standard mode, which is the default mode, points created on a line, for instance, are represented 
by crosses. The points and the line are visible outside the Sketcher workbench.

●     Points generated by Break operations are created in construction mode, even if the Standard/

Construction  button is set to Standard. 
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Creating Points Using Coordinates 

This task shows you how to create a point by indicating coordinates. In this task, we will use an existing point as 
reference for creating another point.

1.  Click Point .

2.  Click to indicate the end point: H=20mm, V=20mm

3.  Click Point by Using Coordinates .  

The Point Definition dialog box appears. You can use either Cartesian (h and v) or Polar 

coordinates.

 
4.  Select the previously created point.
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5.  Select the Polar tab in the Point Definition dialog box and type in the fields: Radius=30mm, 

Angle=30deg. 

The point is created with a 30mm radius and 30deg angle relatively to the reference point. A 

construction line represents the angle direction.

 

        

The symbol used for points in the geometry area can be customized. For this, right click and select 
Properties (Graphic tab). 
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Creating Equidistant Points 

This task shows how to create a set of equidistant points on a line. You can create equidistant points on curves.

Open the Sketcher_02.CATPart document.

1.  Click Equidistant Points . 

2.  Select the line.

 

 The Equidistant Points Definition dialog box appears. By default 10 equidistant New Points are previewed. 
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The Reverse Direction button allows you to create the equidistant points in a reverse direction.

 
3.  Select one of the extremity points of the line as starting point.

 

 The Parameters and Spacing fields automatically become editable. By default, the Points & Spacing parameter 
option is displayed.

 
4.  Set New Points=2 and Spacing=25mm

 

●     If you use the spinners to modify any value, the point distribution is automatically updated.

●     If you type a value in a field, you have to press the Enter key to update the point distribution.

 The spacing value represents the distance between two consecutive new points.
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5.  Press Enter if needed.

 Two points are displayed and distributed along the line.

 

 
6.  Select Points & Length in the Parameters combo.

 
7.  Set Length=60mm

 

 The length value represents the distance between the starting point and the last new point created.
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8.  Press Enter if needed.

 The point distribution is modified.

 

 
9.  Select Spacing & Length in the Parameters combo.

10.  Keep Spacing=20mm and set Length=90mm

According to these values, 3 new points will be created.

 

 
11.  Press Enter if needed.

Three new points are now displayed, but the point distribution is not modified.
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12.  Click OK.

The points are created with their constraints and associated formulas.
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●     Constraints are similarly assigned to these points and distribution on the condition you previously activated the 

Dimensional Constraints option  and the Geometrical Constraints option   in the Sketch tools 
toolbar.

●     Formulas can be created. For more information about formulas, see Knowledge Advisor User's guide.

●     You can edit points one after the other. For this, double click one point and redefine either the Cartesian or the 
polar coordinates from the Point Definition dialog box that appears.

●     Modifications applied to the supporting element are not applied to points. The symbol used for points in the 
geometry area can be customized using the Edit > Properties command (Graphic tab).
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Creating Points Using Intersection  

This task shows you how to create one or more points by intersecting curve type elements.

Open the Intersection_Point.CATPart document.

    

1.  Multi-select the elements to be used 

for intersecting.

 

 

2.  Click Intersection Point from 

the Profile toolbar (Point sub-

toolbar).

3.  Select one curve type element with 

which the elements first selected will 

intersect and on which intersection 

points will be created.

 

The intersecting points automatically appear on 
the curve type element last selected.
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The constraints appear on the condition that Geometrical Constraint  is active in the Sketch tools toolbar. 

 

More About Intersection Points
 

The Intersection Point  command takes unbounded geometrical elements into account to compute intersection points. This is 

illustrated in the following example where the capability creates two intersection points between the line and the circle, and not only 
one: 
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Creating a Point Using Projection  

This task shows you how to create one or more points by projecting points onto curve type elements.

Open the Projection_Point.CATPart document.

1.  Multi-select the elements to be used for projection.

 

To multi-select several elements you have two possibilities either:

●     use the control key before selecting the command.

●     drag the cursor if the command is already activated.

 

2.  Click Projection Point . 

3.  Select one curve type element on which the element first selected will be projected and on which 

projection points will be created.
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 The projection points automatically appear on the curve type element last selected, as well as 
construction lines.

 

●     The constraints appear, of course on the condition the Geometrical Constraint option command 

 is active in the Sketch tools toolbar).

●     The points that are projected are perpendicular to the element last selected provided this element 
is a line. Note that both the selected points and the projected points are associative with the 
construction lines that are also created.

●     A construction line is created between the original points and the projected ones.

 

Creating Associative Projected Points
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1.  Create a spline and points.

2.  Click Projection Point .

The Sketch tools toolbar now displays values for defining the projection mode.

Two projection mode options are available:

●     Orthogonal Projection:  

●     Projection Along a Direction:  

Orthogonal Projection is the default mode.

 

Orthogonal Projection 

3.  Select Orthogonal Projection  .

4.  Select several  points.

5.  Select the spline.

 

 All the selected points have been projected onto the curve according to a normal direction at this curve.
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Projection Along a Direction

3.  Select Projection Along a Direction .

4.  Select one point.

5.  Select the spline.

 

 The selected point is projected along the given direction.
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Sketching Pre-Defined Profiles

The Sketcher workbench provides a set of functionalities for creating 2D geometry and more precisely pre-defined profiles.

Before you begin, make sure you are familiar with Tools For Sketching.

You can sketch pre-defined profiles either via the corresponding icons or via the menu bar (Insert > Operation > 
Predefined Profiles).

Creating Oriented Rectangles: Use the Sketch tools toolbar or click to define a first side for the rectangle and then 
a point corresponding to the rectangle length.

Creating Parallelograms: Use the Sketch tools toolbar or click to define a first side for the parallelogram and then 
a point corresponding to the parallelogram length.

Creating Elongated Hole: Use the Sketch tools toolbar or click two points to define the axis and then a point 
corresponding to the elongated hole width.

Creating Cylindrical Elongated Hole: Use the Sketch tools toolbar or click a point to define the center, two points 
to define the arc of circle as circular axis and then a point corresponding to the cylindrical elongated hole width.

Creating Keyhole Profiles: Use the Sketch tools toolbar or click to define the center to center axis and then both 
points corresponding to both radii.

Creating Hexagons: Use the Sketch tools toolbar or click to define the hexagon center and dimensions.

Creating Centered Rectangles: Use the Sketch tools toolbar to define the rectangle center and dimensions.

Creating centered Parallelograms: Use the Sketch tools toolbar to define a first side for the parallelogram and 
then a point corresponding to its length.
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Creating Oriented Rectangles 

This task shows how to create a rectangle in the direction of your choice by defining three extremity points of the rectangle. In this task, we will use the 
Sketch tools toolbar but, of course you can create this oriented rectangle manually. For this, move the cursor to activate SmartPick and click as soon as you 
get what you wish.

Enter the Sketcher workbench. This scenario assumes that Dimensional Constraints  and Geometrical Constraints  are on.

1.  Click Oriented Rectangle .  

The Sketch tools toolbar now displays values for defining the first side of the oriented rectangle (both points) and then either one point on the 

second side or directly the oriented rectangle height.

2.  Type in the Sketcher tools toolbar for the first corner: H=20mm, V=20mm and press Enter.

3.  Type in the Sketcher tools toolbar for the second corner: W=20mm, A=25deg and press Enter.

 
4.  Type in the Sketcher tools toolbar for the third corner: Height=-22mm and press Enter.

 
The oriented rectangle as well as its corresponding constraints are created.
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Creating Parallelograms 

This task shows how to create a parallelogram by clicking. In this task, we will use the Sketch tools toolbar but, of course you can create this 
parallelogram manually. For this, move the cursor to activate SmartPick and click as soon as you get what you wish.

1.  Click Parallelogram . 

 The Sketch tools toolbar now displays values for defining the first point of the parallelogram.

 
2.  Type in the Sketcher tools toolbar for the first corner: H=20mm, V=20mm and press Enter.

 

 

 
3.  Type in the Sketcher tools toolbar for the second corner: H=37mm, V=10mm and press Enter.

 

 

 
4.  Type in the Sketcher Tools toolbar for the third point: H=57mm, V=10mm and press Enter.

 

 The parallelogram and corresponding constraints appear as shown here.
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Creating Elongated Holes 

This task shows how to create an elongated hole by clicking. In this task, we will use the Sketch tools toolbar but, of course you can create this elongated 
hole manually. For this, move the cursor to activate SmartPick and click as soon as you get what you wish.

1.  Click Elongated Hole  from the Profiles toolbar (Predefined Profile sub-toolbar).

2.  The Sketch tools toolbar now displays values for defining the elongated hole center to center axis (first and second center point) and then either the 

elongated hole radius or a point on this elongated hole. Position the cursor in the desired field (Sketch tools toolbar) and key in the desired values. 

For example, key in the coordinates of both center points of the elongated hole: a first point  (H: 20mm and V: 18mm) and a second point (H: 50mm and V: 

18mm). 

You just defined the profile major axis using points. What you can also do is enter both the length and angle of this axis.

First Center

Second Center

Point on Oblong Profile 

 
For example, key in the coordinates of a point on the elongated hole (H: 53mm and V: 10mm). 

In other words, you just defined the profile minor axis or the  elongated hole width applying a given radius to the profile extremity.

At this step, what you can also do is enter the elongated hole radius.

The elongated hole appears as shown here.
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Creating Cylindrical Elongated Holes 

This task shows how to create a cylindrical elongated hole. A construction arc assists you in creating this element. In this task, we will use the Sketch tools 
toolbar but, of course you can create this cylindrical elongated hole manually. For this, move the cursor to activate SmartPick and click as soon as you get 
what you wish.

1.  Click Cylindrical Elongated .  

The Sketch tools toolbar now displays values for defining the cylindrical elongated hole.

2.  Type in the Sketcher tools toolbar for the circle center: H=20mm, V=20mm and press Enter.

The center point will be used to create both the big radius (radius and angle of the cylindrical elongated hole) and the small radius (circular 
extremities used to define the cylindrical elongated hole).

3.  Type in the Sketcher tools toolbar for the arc start point : H=30mm, V=10mm and press Enter.

The arc appears as a construction arc.

 

 At this step, you may also define the arc big radius R and angle A.

4.  Locate the cursor close to H=10mm and V=30mm

5.  Type in the Sketcher tools toolbar for the arc end point : H=10mm and press Enter.
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 At this step, you cannot define the arc big radius R and angle A.

6.  Type in the Sketcher tools toolbar for the point on cylindrical elongated hole: H=40mm, V=18mm and press Enter.

 

 In other words, you are defining what we call the small radius (Radius: 5.958mm). This small radius corresponds to the width of the cylindrical 
elongated hole, relatively to the circle center.
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Creating Keyhole Profiles 

This task shows how to create a keyhole profile. In this task, we will use the Sketch tools toolbar but, of course 
you can create this keyhole manually. For this, move the cursor to activate SmartPick and click as soon as you 
get what you wish.

1.  Click Keyhole Profile .  

The Sketch tools toolbar now displays values for defining the keyhole profile. See Using Tools for 

Sketching for more information.

2.  Position the stating point at H=20mm, V=20mm

3.  Position the small radius center point at H=20mm, V=40mm

4.  Click to define the small radius.
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5.  Click to define the large radius.

The resulting keyhole is as shown here.
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Creating Hexagons 

This task shows you how to create an hexagon. A construction circle assists you in creating this profile. In this task, 
we will use the Sketch tools toolbar but, of course you can create this hexagon manually. For this, move the cursor 
to activate SmartPick and click as soon as you get what you wish.

1.  Click Hexagon  from the Profiles toolbar (Predefined Profile subtoolbar).

 
The Sketch tools toolbar now displays values for defining the hexagon center and then either a point on 

this hexagon or the hexagon dimension and angle.

2.  Position the cursor in the desired field (Sketch tools toolbar) and key in the desired values.

For example, key in the coordinates of the center of the hexagon (H: 25mm and V: 25mm).

Hexagon Center

For example, key in the dimension (35mm) and Angle (10deg) of the hexagon.            

Point on Hexagon          
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The hexagon is created.

Be careful: if you fix one extremity of the hexagon and try to move the hexagon using another extremity point, this 
hexagon can result twisted. To avoid this, you must drag the hexagon step by step releasing the mouse button 
regularly.
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Creating Centered Rectangles 

This task shows you how to create:
●     a centered rectangle

●     a constrained centered rectangle

Creating a Centered Rectangle

1.  Ensure that the Geometrical Constraints  and the Dimensional Constraints  options are 

deactivated then click Centered Rectangle . 

2.  Click a point in the geometry area or select an existing one.

3.  Drag the cursor to create the centered rectangle, then click when you get the size you want.
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Creating a Constrained Centered Rectangle

To set constraints while creating a centered rectangle, first activate Geometrical Constraints  and 

Dimensional Constraints  (activated by default), then follow the same steps as explained above. 

Equidistant constraints are applied automatically on the opposed lines accordingly to the center point.
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Creating Centered Parallelograms 

This task shows you how to create a centered parallelogram.

Creating a centered 

Creating a constrained centered parallelogram

Creating a Centered Parallelogram

1.  Ensure that the Geometrical Constraints  and the Dimensional Constraints  options are deactivated then click Centered Parallelogram . 

2.  Select a first line (or an axis).

3.  Select a second line (or an axis).

4.  Move the cursor to specify the rectangle dimensions.

The parallelogram is created. It is centered on the intersection point of the two lines. Its edges are parallel to the selected lines.
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Creating a Constrained Centered Parallelogram

To set constraints while creating a centered parallelogram, first activate Geometrical Constraints  and Dimensional Constraints  (activated 
by default), then follow the same steps as explained above. 

Two parallelism constraints are created as long as two symmetrical constraints which are based on the two lines selected before the parallelogram creation.

3D Insight Version 5 Release 19 Page 1006 of 1379



Performing Operations on Profiles 

Before you begin, make sure you are familiar with Tools For Sketching.

The Sketcher workbench provides a set of functionalities for performing operations on profiles. Note that you can either 
click profile or use the Sketch tools toolbar.

Creating Corners: Creates a rounded corner (arc tangent to two curves) between two lines using trimming 
operation. 

Creating Chamfers: Creates a chamfer between two lines using trimming operation. 

 
Trimming Elements: Trims two lines (either one element or all the elements)

Trimming Multiple Elements: Trims a few elements using a curve type element.

Breaking & Trimming: Quickly deletes elements intersected by other Sketcher elements using breaking and 
trimming operation.

Closing Elements: Closes circles, ellipses or splines using relimiting operation.

Complementing an Arc  (circle or ellipse): Creates a complementary arc.

Breaking Elements: Breaks a line using a point on the line and then a point that does not belong to the line.

Creating Mirrored Elements: Duplicates existing Sketcher elements using a line, a construction line or an axis.

Moving Elements by Symmetry: Moves existing Sketcher elements using a line, a construction line or an axis.

 Translating Elements: Performs a translation on 2D elements by defining the duplicate mode and then selecting 
the element to be duplicated. Multi-selection is not available.

Rotating Elements: Rotates elements by defining the duplicate mode and then selecting the element to be 
duplicated.

 Scaling Elements: Scales elements by defining the duplicate mode and then selecting the element to be duplicated.

Offsetting Elements: Scales an entire profile. In other words, you are going to resize a profile to the dimension 
you specify.

Offsetting Elements: Duplicates a line, arc or circle type element.

Projecting 3D Elements onto the Sketch Plane : Projects edges (elements you select in the Part Design 
workbench) onto the sketch plane.

Creating Silhouette Edges: Creates silhouette edges to be used in sketches as geometry or reference elements. 
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Intersecting 3D Elements with the Sketch Plane: Intersects a face and the sketch plane.

Copying/pasting Elements: Explains how sketched elements behave when copying/pasting elements that were 
created via projection or intersection.

Isolating Projected/Intersected Elements: Isolates the elements resulting from the use of Project 3D Elements 

 or Intersect 3D Elements .

 
Performing a Quick Geometry Diagnosis: Displays a quick diagnosis of a sketch geometry.

Analyzing the Sketch: Displays a global or individual status on the sketch and correct any problem.

Creating Output Features: Creates an output of a selected sketch which can be published and updated 
independently in the 3D area.

Creating Profile Features: Creates a feature made of a set of curves, connected or not and made independent 
from the other elements defined in the same sketch.
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Creating Corners 

This task shows how to create a corner (arc tangent to two curves) between two lines using the different 
trimming options.

 

This page deals with the following information:
●     Trimming Both Lines

●     Trimming the First Line

●     No Trimming

●     Trimming Both Lines Until their Intersection

●     Trimming Both Lines and Creating Construction Lines Until their Intersection

●     Trimming Both Lines and Creating Construction Lines

●     Optimizing the Operation By Multi-Selection 

Open the Move_Corner.CATPart document.

 

1.  Click Corner .  

The possible corner options are displayed in the Sketch tools toolbar. The Trim All Elements option  

is selected by default.  

Trimming Both Lines

2.  Select the Trim All Elements option . 

3.  Select the two lines. 

The two lines are joined by the rounded corner which moves as you move the cursor. This lets you vary 
the dimensions of the corner.
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4.  Enter the corner radius value in the Sketch tools toolbar: 22mm

You can also click when you are satisfied with the corner dimensions. Both lines are trimmed at the 
points of tangency with the corner. 

 

 

Trimming the First Line 

2.  Select the Trim First Element option . 

3.  Select the two lines. 

The first line is trimmed. 

 

 
No Trimming  
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2.  Select the No trim option .  

3.  Select the two lines. 

The corner is created. No line is trimmed. 

 

 

Trimming Both Lines Until their Intersection 

2.  Select the Standard Lines Trim option . 

3.  Select the two lines. 

The corner is created. The trimmed lines are set as standard lines. 

 

 Trimming Both Lines and Creating Construction Lines Until 
their Intersection 
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2.  Select the Construction Lines Trim option . 

3.  Select the two lines.

The corner is created. The trimmed lines are set as construction lines. 

 

 
Trimming Both Lines and Creating Construction Lines

Enter the Sketcher workbench and create two intersecting lines.

 

2.  Select the Construction Lines No Trim option . 

3.  Select the two lines.

The corner is created. The trimmed lines are set as non-trimmed construction lines. 
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●     By default, centers are created but if you do not need them you can specify this in the Options 
dialog box. for this, go to Tools > Options > Mechanical Design > Sketcher option (Sketcher 
tab).).

●     You can create corners between curves.

 

 
Optimizing the Operation By Multi-Selection

 

You can create several corners just by multi-selecting for example, the rectangle endpoints and enter a radius 
value in the Radius field (Sketch tools toolbar). Four corners are created at the same time with the same 
radius value.

Double-clicking on Formula  displays the parameter driving the radius value of the corners you have just 

created.
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Creating Chamfers 

 This task shows how to create a chamfer between two lines trimming either all, the first or none of the elements, and more 
precisely using one of the following chamfer definitions:

 

●     Angle/Length (Hypotenuse)

●     Length1/Angle

●     Length1/Length2

 

 

This page deals with the following information to create chamfer:
●     Trimming Both Lines

●     Trimming the First Line

●     No Trimming

●     Trimming Both Lines until Their Intersection

●     Trimming Both Lines and Creating Construction Lines Until their Intersection

●     Trimming Both Lines and Creating Construction Lines

●     Dimensioning the Edge Intersection Point

You can create chamfers between any type of curves (lines, splines, arcs and so forth). Even if the curves are not consecutive, the 
chamfer will be created.

Open the Chamfer.CATPart document.

 

1.  Click Chamfer . 

The possible chamfer options are displayed in the Sketch tools toolbar. The Trim All Elements option is selected by 
default.

Six profile mode options are available:

●     Trim All Elements:  

●     Trim The First Element:  

●     No Trim:  
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●     Standard Lines Trim:  

●     Construction Lines Trim:  

●     Construction Lines No Trim:  

Three dimension mode options are available:

●     Angle and Hypotenuse:  

●     First and Second Length:  

●     Angle and First Length:  

 

Trimming Both Lines

2.  Select the Trim All Elements option . 

3.  Select the first line and the second line. 

The selected lines are highlighted.

 

 The second line is also highlighted, and the two elements are connected by a line representing the chamfer which moves as 
you move the cursor. This lets you vary the dimensions of the chamfer whose values appear in the Sketch tools toolbar.

 

4.  Click to indicate where to create the chamfer. 

The chamfer with both elements trimmed is created.
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Provided the Dimensional Constraint option command is active, the constraints will be created between what we call in 
the scenarios below the old intersection point and new end points of the lines.

 

 

Trimming the First Line

2.  Select the Trim The First Element option . 

3.  Select the first line and the second line. 

The chamfer with one element trimmed is created.

 

 

 

No Trimming

2.  Select the No Trim option . 

3.  Select the first line and the second line.

The chamfer with no element trimmed is created and the original lines are kept.
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Trimming Both Lines Until their Intersection

2.  Select the Standard Lines Trim option . 

3.  Select the first line and the second line. 

The chamfer is created and the two lines are trimmed up to the two lines intersection.

 

 

 

Trimming Both Lines and Creating Construction Lines Until their 
Intersection

2.  Select the Construction Lines Trim option . 

3.  Select the first line and the second line.

●     The chamfer is created and the two lines are trimmed.

●     Two new lines are created between the intersection and the trimmed extremity of the lines, and set as construction 
lines.
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Trimming Both Lines and Creating Construction Lines

2.  Select the Construction Lines No Trim option . 

3.  Select the first line and the second line.

●     The chamfer is created and the two lines are trimmed.

●     Two new lines are created between the previous extremities and the trimmed extremity of the lines, and set as 
construction lines.

 

 

 

Dimensioning the Edge Intersection Point

You can create several chamfers just by multi-selecting for example, the rectangle endpoints and entering the definition parameters 
in order to define these chamfers (Sketch tools toolbar). Four chamfers are created at the same time with the same parameter 
values.

Using the Length1/Length2 Option 
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 Between Perpendicular Lines

 

 Between Non-Perpendicular Lines 

 

 Between Crossing Lines
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 Between Non-Intersecting Lines

 

 Note: if the lines are parallels, the extremity points are used to compute the lengths because the virtual intersecting point does not 
exist.

Between Intersecting Curves

 

 Between Non-Intersecting Curves
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Using the Length1/Angle Option 

 

 Between Non-Perpendicular Lines

 

 Between Non-Intersecting Curves
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Trimming Elements  

 This task shows you how to trim geometrical elements:
●     Trimming Two Elements

●     Trimming One Element

Trimming Two Elements

Create two intersecting lines.

 

1.  Click Trim  in the Operations toolbar. 

Trim options are now displayed in the Sketch tools toolbar. The Trim All Elements option is the default 

option . 

2.  Select the first line.

3.  Position the cursor on the element to be trimmed. 

The second element is highlighted too, and both lines are trimmed.
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4.  Position the cursor on the same first element. 

The first element will be trimmed at the location where you click for the second time. The location of the 

relimitation depends on the location of the cursor.

5.  Click when you are satisfied with the relimitation of the two lines.

 

3D Insight Version 5 Release 19 Page 1024 of 1379



●     In multi-selection mode, no extrapolation is done by trimming command.

●     If you  trim an element created from a projection or an intersection, then this element's extremities are not 
constrained anymore to follow the extremities from the element they are issued from.

●     If the extremity point of the trimmed line is constrained, or if the extremity point of the trimmed line is a 
geometrical element (not a construction element), then a coincidence constraint will be created between this 
point and the trimmed line.

 

Trimming One Element

This task shows you how to trim just one element.

Create two intersecting lines.

 

1.  Click Trim . 

2.  Click the Trim First Element option .

3.  Select the first line.
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4.  Position the cursor to the second line. 

The first line selected is trimmed.

5.  Position the cursor on the same first element. 

The first element will be trimmed at the location of the second position. The location of the relimitation depends 

on the location of the cursor.
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6.  Click when you are satisfied with the relimitation of the first line.
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Breaking and Trimming 

 This task shows how to quickly delete elements intersected by other Sketcher elements using breaking and trimming 
operations.

Open the Sketcher_01.CATPart document and ensure that the Geometrical Constraints option is activated: 

 

1.  Click Quick Trim .  

The Quick Trim options are displayed in the Sketch tools toolbar.

2.  Select the Beak and Rubber In option . 

3.  Select the arc you wish to be deleted from Circle.2.

The arc of circle has been trimmed as shown here. Coincidence constraints have been created.
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4.  Click Quick Trim .

5.  Select the Beak and Rubber Out option . 

6.  Select the arc you wish not to be deleted from the Circle.3.

The arc of circle has been trimmed as shown here. Coincidence constraints have been created.
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7.  Click Quick Trim .

8.  Select the Break and Keep option . 

9.  Select Line.3 as the element you wish to be broken.
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Line.3 has been broken in three segments delimited by the other lines. Coincidence constraints have been 
created.

●     If you need to delete several elements, you can double-click the icon and delete the elements one after the 
other.

●     You cannot apply Quick Trim and/or Break to composite curves (which are projected/intersected elements 
composed of several curves). However, you can work around this functional restriction by using the Trim 
command (this enables you to get the same results for composite curves than by performing the Quick Trim 
and the Break operations).
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Closing Elements   

 This task shows how to close circles, ellipses or splines using relimiting operation.

 
Create a three point arc. 

 

 

1.  Click Close arc  in the Operation toolbar (Relimitations sub-toolbar).

2.  Select one or more elements to be trimmed. For example, a three point arc. 

 
The arc is now closed. 

In the case of a spline that was relimited by using Trim , the spline is set to its original limitation. 
 

        Spline after it was relimited                       
    Spline after you clicked Close arc 
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Complementing an Arc (Circle or Ellipse)

 This task shows you how to complement an arc (circle or an ellipse).

 Create a three point arc.

 
1.  Select the arc to be complemented.

2.  To complement the arc, chose one of the following methods:

�❍     Click Complement  from the Operation toolbar (Relimitations subtoolbar).

�❍     or right-click selected item and select Circle.1 object>Complement

�❍     or select Insert > Operation > Relimitations and select Complement.

The complementary arc appears.
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Breaking Elements 

Applying the Break command to intersecting lines creates a point at the geometry intersection.

This task shows how to break a line that does not intersect geometry, in different ways:

●     using a point on the line 

●     using a point belonging to another line

●     using a point

Break lets you break any type of curve, except for composite curves. You can use any Sketcher element to 
break curves.

Create two lines and a point and ensure that the Geometrical Constraints  is activated .

Use a Point on the Line

 

1.  Click Break  in the Operation toolbar (Relimitations sub-toolbar). 

2.  Select the line to be broken. 

3.  Indicate where to create the break. 

 
The line is broken at the indicated point. A point has been created. The line is now composed of two 

segments. Coincidence constraints have been created. 
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Use a Point Belonging to Another Line

 

1.  Click Break .

2.  Select the line to be broken. 

3.  Select the second line. 

 
The line is broken from the projection of the selected point: a projection point of the selected point has 

been created. The line is now composed of two segments. Coincidence constraints have been created. 
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Use a Point

 

1.  Click Break .

2.  Select the line to be broken. 

3.  Select the breaking point. 

 
The line is broken from the projection of the selected point: a projection point of the selected point has 

been created. The line is now composed of two segments. Coincidence constraints have been created. 
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More about the Break Command

Using the Break , you can also isolate points:

●     if you select a point that limits and is common to two elements, the point will be duplicated.

●     if you select a coincident point, this point becomes independent (it is no more assigned a coincidence 
constraint). 

In the following example, applying  Break  onto the circle center lets you therefore move the circle: 

       

Composite Curves

You cannot break composite curves (which are projected/intersected elements composed of several curves). 
However, you can work around this functional restriction by projecting or intersecting the composite curve 
elements and break these items using one another.
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Breaking/Trimming Use-Edges

This task shows you how to break or trim imported elements (projection, intersection, offset). The created use edge 
is only changed into construction mode but it is unchanged. 
For the purpose of this scenario an example of trimming element is used.

●     Create a conic.

●     Exit Sketcher and in the Part design workbench, create a new sketch based on the conic.

●     Project the conic.

●     Create two lines as shown here.

1.  Click Trim  from the Operations toolbar.
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2.  Select the Use Edge between the two lines.

3.  Select a first line.

An arc is created based on the use-edge and the original use-edge is put in construction mode as shown here.

4.  Click Trim .

5.  Select the arc between the two lines.

6.  Select the second line.

When trimming a curve the selected location on the curve is important as it determines the curve part that will be 
kept.

 

The mark, which is put in construction mode, and the arc are displayed in the specification tree.
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●     When deleting the use edge (projection, intersection, etc...), all the arcs related to it are deleted too.

●     The edition of an arc is only possible in the Sketcher workbench.

●     After a trim operation, for instance, the diagnosis is not modified and if the sketch is iso-constraint, it will stay 
iso-constraint.

3D Insight Version 5 Release 19 Page 1040 of 1379



Trimming Multiple Elements

This task shows you how to trim a few elements using a curve type element.

Create as many elements as you wish.

1.  Multi-select the elements to be trimmed.

 

2.  Click the Trim icon:  

3.  Select the trimming curve to be used.
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4.  Click to indicate the side of the elements will be kept according to the trimming curve.

 
Elements have been trimmed.

 

If one element does not intersect the trimming curve, this element will be either totally deleted or kept (in 
accordance with the location of this element). For instance, on the example above, the line above the trimming 
curve is kept, the line below the trimming curve is deleted.
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Creating Mirrored Elements 

This task shows you how to repeat existing Sketcher elements using a line or an axis.

Create a circle and an axis.

1.  Select the circle to be duplicated by symmetry. 

2.  Click Mirror  from the Operation toolbar.

3.  Select the axis you previously created. 

The selected circle is duplicated and a symmetry constraint is created on the condition you previously 

activated Geometrical Constraints . 
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You can also use multi-selection:

●     Drag the cursor and create a trap.

●     Select the symmetry axis.
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Moving Elements by Symmetry  

 This task shows you how to move existing Sketcher elements using a line, a construction line or an axis. In this 
particular case we will move a rectangle by symmetry.

 The former functionality associated to this command is available thru the Mirror  command, which duplicates 

elements by symmetry.

1.  Create a rectangle and an axis.

2.  Click Symmetry  from the Transformation sub-toolbar in the Operation toolbar.

3.  Select the rectangle you have created and click axis. 

The rectangle has been moved by symmetry according to the axis.

3D Insight Version 5 Release 19 Page 1045 of 1379



 

Two sides selection

1.  Create an axis.

2.  Create a rectangle on one side of the Axis and a circle on the other side.

 

 

3.  Click Symmetry  from the Transformation sub-toolbar in the Operation toolbar.

4.  Select the rectangle and the circle by trapping.

5.  Select the axis. 

In order to be able to multi-select elements, the axis length must be quite important.
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The symmetry is created and the two elements have been taken into account.

 

Applying constraints to symmetrical elements 

1.  Create a rectangle and an axis.

2.  Select Constraint  from the Constraint toolbar.
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3.  Select one of the rectangle element and the axis.

4.  Click to create the constraint. 

The constraint and its value are displayed in the geometry area.

 

 

 

5.  Click Symmetry  from the Transformation sub-toolbar in the Operation toolbar.

6.  Select the rectangle and then click axis. 

The rectangle has been moved by symmetry according to the axis. 

Note that as the constraint is applied on an axis, the constraint is kept after the symmetry.
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●     The constraint is also kept when it is applied to a fixed element.

●     In the case of Use Edges, the element becomes isolated.

  Only internal constraints are kept after a symmetry operation.
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Translating Elements 

 The application provides a powerful command for translating elements. You may either perform a simple 
translation (by moving elements) or create several copies of 2D elements.

This task shows you how to translate 2D elements by using the duplicate mode and then selecting the element 
to be duplicated. 

Open the Transform_replace01.CATPart document

 

1.  Click Translation .  

The Translation Definition dialog box appears. It will remain displayed all along your translation 

creation. The Duplicate mode option is activated by default, which means that the 2D elements you 

select will be copied. If you uncheck Duplicate mode, the element will be moved. 
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2.  Keep the Instance(s) field to 1 and the Duplicate mode option activated.

3.  Select the Keep internal constraints option. 

This option specifies that you want to preserve in the translation the internal constraints applied to the 

selected elements.

4.  Keep the Keep external constraints 1 option deactivated. 

Any external constraint existing between the selected elements and external elements will be 

disregarded in the translation.

5.  Select the elements to be translated using the trap selection. 

You may either select one 2D element, or multi-select the entire 2D geometry by trapping it with the 

mouse as shown below.

 
6.  Click to indicate the translation vector starting point. 

You can define the translation length in the geometry area, using the mouse. For more precise results, 

enter a specific value for the translation length in the Translation Definition dialog box.

 

 
7.  Type 30mm in the length field and press Enter.
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You can use SmartPick to keep lines horizontal.

You can enable the Snap mode option in the dialog box to increment 
translation value by steps. 
Note: To change the step value, right-click the value field and select Change 
step > xxx mm. For more information about parameter management which 
is common to all parameters used in CATIA products, see CATIA Infrastructure 
User's Guide: Using Knowledgeware Capabilities: Parameters.

 
8.  Click to indicate the translation vector ending point.

 

 
9.  Click OK. 

The translation has been performed.

 

 You can notice that the internal constraints were preserved in the translated element (four tangency 
constraints, and a parallelism constraint), whereas the external constraint (an offset constraint) was 
not.
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●     The Undo   command is available from the toolbar, while you are translating elements.

●     When translating external constraints:

�❍     geometrical constraints are deleted..

�❍     dimensional constraints are preserved but revalued.

More about the Translate Command

●     When you are using Translation , the top priority is to ensure the move of geometrical elements. This 
is the reason why some geometrical or dimensional constraints may be removed or modified in order to 
assure the move of selected geometrical elements according to the given vector of translation.

●     Translating elements also means re-computing distance, angle and/or length constraint values, if needed. Be 
careful: only non-fixed elements are updated.

●     Multi-selection is not available.

3D Insight Version 5 Release 19 Page 1053 of 1379



Rotating Elements

 

This task will show you how to rotate elements. 

In this scenario, the geometry is simply moved. But note that you can also duplicate elements with the Rotation 

command. You can de-activate the duplicate mode if needed by: De-activate Duplicate mode.

Rotating elements also means re-computing distance values into angle values, if needed. Be careful: only non-fixed 
elements are updated.

Open the Transform_replace01.CATPart document.

1.  Click Rotation  from the Operations toolbar (Transformation subtoolbar).

 

2.  The Rotation Definition dialog box appears and will remain displayed all along the rotation. De-activate 

the Duplicate mode, if needed. 

If you keep it active, you will be allowed to define the number of the instances you wish to create in the 

meantime.
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3.  Select the geometry to be rotated. Here, multi-select the entire profile.
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4.  Select or click the rotation center point. 

You can also enter a value in the fields displayed (Sketch tools toolbar). 

5.  Select or click a point to define the reference line that will be used for computing the angle.
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6.  Select or click a point to define an angle. 

 

●     If you have check snap mode in the dialog box and set the value to 5 degrees, then when you drag the cursor to 
rotate the element it rotates by 5 degrees steps.

●     You can also enter a value for the rotation angle in the Rotation Definition dialog box

7.  Click OK to end the rotation.  

Rotating elements also means re-computing distance values into angle values, if needed. Be careful: only 

non-fixed elements are updated.
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●     Internal constraints are preserved 

●     External constraints: 
�❍     geometrical constraints are killed

�❍     dimensional constraints are modified and revalued.

 

More about Snap Mode

You can enable the Snap mode option in the dialog box to increment rotation angle 
value by steps. 
Note: To change the step value, right-click the value field and select Change 
step > xxx mm. For more information about parameter management which is 
common to all parameters used in CATIA products, see CATIA Infrastructure 
User's Guide: Using Knowledgeware Capabilities: Parameters.
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Scaling Elements 

This task will show you how to scale an entire profile. In other words, you are going to resize a profile to the 
dimension you specify.

Scaling elements also means re-computing distance values, if needed. Note that angle values will not be 
modified. Be careful: only non-fixed elements are updated.

Open the Transform_replace01.CATPart document.

1.  Click Scale .  

You can first select either the geometry or icon. If you select the icon first, you cannot multi-select 

elements.

2.  Select the elements to be scaled.
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3.  Click to indicate the center point on the geometry. 

You can define the center point from its coordinates in the Sketch tools toolbar fields.

 
4.  In the Scale Definition dialog box, type 2 as the scale value you want.
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5.  Click OK. 

Internal constraints are preserved but revalued. As for external constraints, geometrical constraints are 

deleted, dimensional constraints are modified and revalued.

 

More about Snap Mode

You can enable the Snap mode option in the dialog box to increment scale 

value by steps. 
Note: To change the step value, right-click the value field and select Change 
step > xxx mm. For more information about parameter management which 
is common to all parameters used in CATIA products, see CATIA Infrastructure 
User's Guide: Using Knowledgeware Capabilities: Parameters.
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Offsetting Elements 

 This task shows you how to duplicate an element of the following type: line, arc or circle.

You can also duplicate by offset one of the following: an edge, a face (all the boundaries of this face are offset) or a geometrical feature (for example, 
by selecting a join or another sketch in the specification tree).

Select a topic:

●     Offset 2D geometry,

●     Use offset tools,

●     Offset 3D geometry,

●     Modify a 3D geometry offset.

Offsetting 2D Geometry
 
Create a line.

1.  Click Offset  from the Operations toolbar (Transformation subtoolbar). 

OR 

1.  Select the Insert >Operation>Transformation>Offset command from the menu bar.

2.  There are two possibilities, depending on whether the line you want to duplicate by offset is already selected or not: 

�❍     If the line is already selected, the line to be created appears immediately. 

�❍     If the line is not already selected, select it. The line to be created appears.

3.  Select a point or click where you want the new element to be located. 

The selected line is duplicated. Both lines are parallel. 

●     If you were offsetting circles or arcs, these two circles would be concentric.
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●     If Geometrical Constraints  and Dimensional Constraints  are active in the Sketch tools toolbar when offsetting an element, constraints 
are automatically created, based on the type of element you are offsetting.  Thus, if you move an element, or change its geometry, the other element will 
be moved or modified accordingly.

Using offset tools 

You can also apply one or more offset instances to profiles made of several elements: 

●     by using tangency propagation or point propagation,

●     by creating an offset element that is tangent to the first one,

●     by creating several offset instances.

 This is not true for generated elements (Generative Drafting workbench). 

If the multi-selected elements do not make up a closed profile, the offset will be applied to the selected elements only. As a result, you will have as many 
offset elements as the first multi-selected elements. 

Previews are not available when creating several offset instances (i.e. when the value in the Instance(s) field of the Sketch tools toolbar is higher than one).
 
Open the Offset.CATPart document.

1.  Click Offset  from the Operations toolbar (Transformation subtoolbar).

 

 

2.  Select the desired option from the displayed Sketch tools toolbar. (These options are described further down in this section). 

3.  Select the element you want to offset and if needed, enter the desired number of instances. The element to be created is previewed. 

4.  Select a point or click where you want the new element to be located.

To offset a single element: 

Activate No Propagation .

 

 

 

To offset an element and elements which are tangent to it: 

Activate Tangent Propagation . 

 

 

 

To offset an element using Point Propagation: 

Activate Point Propagation .
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To offset an element symmetrically to another: 

Activate Both Side Offset .

 

 

 

To offset and duplicate multiple elements: 

Type the number of elements you want to create in the Instances field.

 

●     Note that the Offset command is performed as soon as the Offset field is validated, by pressing Tab or Enter.

●     Note that if you position the cursor outside the zone that is allowed for creating a given element, the  symbol appears. 

 
 

Drafting Workbench

You can create offset geometry using 2D component elements and dress-up elements (axis lines, center lines and threads). Note that by doing this, you will 
not create offset 2D components or dress-up elements, but you will create offset geometry.  

 

●     You can offset them only element by element.

●     You cannot offset complex curves.

●     This will only work if you first select the command and then the element to offset.

 

Offsetting Geometrical Elements Other than Lines and Circles

Applying Offset to geometrical elements other than lines and circles generates:

●     Splines if Dimensional Constraints is selected.

●     Offset curves if Dimensional Constraints is not selected. In this case, associativity is maintained between the offset element and the initial geometry.

In Drafting workbenches, associativity is maintained if the offset operation was done with Create Detected Constraints on.

 

Offsetting 3D Geometry

You can create an associative offset with a 3D element.
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Open the Offsetpad.CATPart document.

 

1.  Click Offset  from the Operations toolbar (Transformation subtoolbar).

2.  Select the 3D surface to offset, Face.1 for example. The profile to be created is previewed. 

3.  You can do one of the following: 

●     specify the offset position or value in the Sketch tools toolbar and press Enter to validate.

 

 
●     Move the cursor till the correct offset appears in the sketch, then click to validate the position.

 

 

The offset is created, with the offset value displayed. 

 

It appears as Mark.1 in the specification tree: 

3D Insight Version 5 Release 19 Page 1065 of 1379

file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/Sketcher/Offsetpad.CATPart


 

If you want to edit the offset value, you can double-click it and enter a new value in the dialog box which is displayed.

 

 

●     When offsetting a face, if there is an intersection between the face and the sketch plane, by default, it is this intersection which is offset (rather than 
the projection of the face edges). In this case, if you want to offset the projection of the face edges, you can modify the offset as explained in the section below.

●     You can offset the intersection between a face and a sketch plane without explicitly creating this intersection.

●     lf you offset a multi-domain face, the face that is closer from the cursor is offset.

 

If you isolate a composite mark, as many simple geometry elements as the mark was containing are created, and associativity will not be available anymore. 

Modifying a 3D Geometry Offset  

1.  Double-click the offset in the specification tree or on the sketch. The Offset Definition dialog box is displayed. 

In this dialog box, you can modify the offset definition.

�❍     Parallel corner type: specifies whether corners should be round or sharp (when applicable). 

Note that this option applies only when the offset results in extrapolated curves (as is the case in our example, for instance).

3D Insight Version 5 Release 19 Page 1066 of 1379



 

Parameters

These options let you specify the offset parameters.

●     Object to offset: indicates which 3D element is offset. To offset another element, select this field and then select the new element in the sketch. 

●     Offset value: indicates the offset value. You can modify it by typing a new value in this field.

●     Offset mode: when offsetting a face, specify whether you want to intersect and offset or to project and offset the face by selecting the appropriate option 
from the list.

Propagation 

These options let you offset a 3D element using the propagation of an edge.

●     Type: specifies what type of offset propagation should be applied to the selected reference element: No propagation, Tangent propagation, or 
Point propagation. Click the appropriate icon.

●     Reference element: indicates which edge should be used as a reference for the propagation. Select this field and then select the reference edge in the sketch.

2.  In the Offset value field, type 20mm.

3.  Choose Project and offset from the Offset mode field.  

4.  Click OK to validate. The offset is modified.

 
●     Only 3D elements can be offset with associativity.

●     There is no propagation on 3D edges.

●     Typing a negative offset value reverses the offset direction.

●     Multi-domain elements cannot be offset in one shot.

●     If you apply the Parents/Children... command to a sketch containing an offset obtained after selecting a face or an edge, the Parents command shows the 
last solid feature that modified the offset geometry. To see an example of this, refer to Parents/Children paragraph of Projecting 3D Elements onto the 
Sketch Plane.
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Creating Spline Offsets 

 This task shows you how to create an associative offset based on an existing spline.

 Create a spline.

 

1.  Select the Offset command from the Transformation sub-toolbar in the Operation toolbar

2.  Click the spline.

3.  Click in the geometry area to create the offset.

 

The offset is created as long as a new feature OffsetCurve which is visible in the specification tree.

Note that: 

●     The visualization of the offset implies an automatic creation of elements, which are automatically put in no show and construction mode.

●     These elements are put in no show mode only if the Geometrical Constraint option in the Sketch tools toolbar is activated.

●     These elements are also deleted if the offset or the original spline are deleted.

●     The created offset will be associative with the original spline only if the Dimensional Constraint option in the Sketch tools toolbar is activated, see 
Editing Spline Offset.
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●     When creating an offset of a spline, a constraint is automatically created and the offset cannot be deleted.

●     Both the spline and the constraint can be edited.

Inconsistent Spline Offsets

If the reference spline is deleted, the spline offset becomes inconsistent (the spline offset color turns red). As a result, when you exit the Sketcher workbench 
the Update Diagnosis dialog box is displayed and an error message appears within the dialog box. Just double-click the spline offset to re-edit it. 
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Projecting 3D Elements onto the Sketch Plane 

 This task shows how to project edges (elements you select from the 3D area) onto the sketch plane.

 

1.  Click Project 3D Elements . 

2.  Multi-select the edges you wish to project onto the sketch plane. 

The edges are projected onto the sketch plane. These projections are yellow. You cannot move these 

elements. To move them, first use the Isolate command.

 

●     You can apply the Relimitation , Corner  and Chamfer  commands on projections.

●     If you select a face, its edges are projected.
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Parents/Children

If you apply the Parents/Children... command to a sketch containing a projected edge obtained after selecting 
a face or an edge, the Parents command shows the last solid feature that modified the projected geometry. 
In the example below, one of Pad1's edge has been projected and used in Sketch4. The capability shows a 
parent relationship with Pad1 but also with Chamfer1 that is the last feature in the part body.
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●     A canonicity detection is performed on projected curve according to the application tolerance, in other words 
the application tries to recognize sketcher elements like line or conic curves. 
Due to the canonicity approximation changes may occur in resulting projected curve types.

●     If no canonicity has been detected the curve is projected as is.

●     Projected elements are associative except in the case of multiple distinct marks.

●     A mark composed of several associated elements is managed as a single curve (you can constraint it).

●     In general, we recommend not to create projections from wireframe elements which lie on a plane 
orthogonal to the sketch. As a matter of fact, the orientation of the result of these projections in the sketch 
plane is not stable.

●     If you isolate a composite mark, as many simple geometry elements as the mark was containing are 
created, associativity will not be available anymore.

●     A multi-domain face projection does not create a single composite mark (in this case each edge is projected).
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Projecting 3D Silhouette Edges  

 This task shows how to create silhouette edges to be used in sketches as geometry or reference elements. 

 You can only create a silhouette edge from a canonical surface whose axis is parallel to the Sketch plane.

 Open the Silhouette_Edge.CATPart document.

 
1.  Select Plane1 and go into Sketcher workbench.

2.  Click 3D Silhouette Edges  from the 

Operation toolbar (3D Geometry sub-

toolbar).
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3.  Select the canonical surface. 

The silhouette edges are created onto the sketch plane. 

These silhouette edges are yellow if they are associative 
with the 3D. 

You cannot move or modify them but you can delete 
one of them which means deleting one trace 
independently from the other. 

You can select one of the two intersections 
and set it into the Construction mode: 

  

You can create geometry and constraints using this 
intersection: 
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You can re-limit this created silhouette edge 
using the geometry: 

The silhouette command generated one or two marks (edges) if one mark is made of more that one curves. If those 
curves do not have the same geometrical support, the resulting silhouette edges will not be associative (as for 
Projection/Intersection commands). 
●     Silhouette edges are associative except in the case of a multiple distinct marks.

●     A mark composed of several associated elements is managed as a single curve (you can constrain it).

●     If you apply the Parents/Children... command to a sketch containing a 3D silhouette, the Parents command 
shows the last solid feature that modified the silhouette. To see an example of this, refer to Parents/Children 
paragraph of Projecting 3D Elements onto the Sketch Plane.
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Intersecting 3D Elements with the Sketch Plane 

 This task shows how to intersect a face and the sketch plane.

Open the Intersection_Canonic.CATPart document.

 
1.  Select the face of interest. 

2.  Click Intersect 3D Elements  from the Operations toolbar (3D Geometry sub-toolbar).  

The application computes and displays the intersection between the face and the sketch plane. The 

intersection is yellow meaning that you cannot move it.
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●     You can apply the Relimitation , Corner  and Chamfer  commands on projections.

●     If you select a face, its edges are projected.

●     A canonicity detection is performed on projected curve according to the application tolerance, in other words 
the application tries to recognize sketcher elements like line or conic curves. 
Due to the canonicity approximation changes may occur in resulting projected curve types.

●     If no canonicity has been detected the curve is projected as is.

●     Intersected element are associative apart in the case of a multiple distinct marks.

●     A mark composed of several associated elements is managed as a single curve (you can constraint it).

●     If you apply the Parents/Children... command to a sketch containing an intersection obtained after 
selecting a face or an edge, the Parents command shows the last solid feature that modified the 
intersection geometry. To see an example of this, refer to Parents/Children paragraph of Projecting 3D 
Elements onto the Sketch Plane.

●     If you isolate a composite mark, as many simple geometry elements as the mark was containing are 
created, associativity will not be available anymore.

●     If the intersected geometry is a plane face and there is no intersection between this face and the sketcher 
plane, the resulting intersection is an infinite line.
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Copying/Pasting Elements

 This task shows how sketched elements behave when you copy and paste them. More specifically, you will learn 
about:
●     Copying/pasting elements with H and V constraints on their absolute axis

●     Copying/pasting projected or intersected elements

●     Copying Sketches

●     Explode

For general information on copy/paste, see the Infrastructure User's Guide.

Copying/Pasting Elements with H and V Constraints on Their 
Absolute Axis

This task shows you how to copy/paste elements along with the horizontal and vertical constraints on their 
absolute axis.

Open the Copy_paste_H_and_V.CATPart document.

 
1.  To duplicate the rectangle and its H and V directions: multi-select the rectangle and its origin, and copy 

the selected elements.

 

OR

1.  To duplicate the rectangle, its H and V directions, and the distance constraints which exist between the 

rectangle and its origin: multi-select the rectangle and the distance constraints (do not select the 

origin), and copy the selected elements.
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In other words, if you want to copy an element along with its H and V direction while keeping the 
constraints which exist between the copied element and its origin, you do not need to, and you should 
not, select the origin. Selecting the constraints is enough. If you select the origin, the constraints will 
not be kept.

2.  Paste these elements. 

The elements are pasted over the elements you copied. You can move the pasted elements (if you 

want to view them, for example).

Copying/Pasting Projected or Intersected Elements

This task shows how sketched elements that were created via projection or intersection behave when copying/
pasting them.

1.  Copy the projected or the intersected element, using the method described above.

2.  Paste this element. 

External references are deleted: 

●     Constraints on external geometry are deleted.

●     Projections/Intersections are deactivated when they have external references.

●     You cannot project or intersect the pasted element. 

●     The pasted element is not associative.
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Copying Sketches

This task shows how pasted sketches behave.

1.  Create a sketch then enter Part Design workbench.

2.  Copy and paste the sketch using the Paste Special contextual command and the As Result with Link 

option.

 

 The sketch is pasted. You can observe a blue symbol added to the image of the sketch in the 
specification tree, meaning that associativity is maintained between the reference geometry and the 
copy.

 

3D Insight Version 5 Release 19 Page 1080 of 1379



3.  Use this copied sketch to create a pad.

4.  Just edit the reference sketch the way you want: for example, change the shape. The pad reflects the 

change.

In the specification tree, sketches copied and pasted in documents different from the documents in 
which they were created are identified by a green point in target documents:

The green point is turned into a red cross when the copied sketch needs synchronizing with its 
reference:

 

Explode 
The Explode capability allows you to edit and modify a sketch obtained by Copy>Paste>As Result With Link. 

Exploding the sketch converts every wireframe geometry associated to the datum feature into a standard 2D geometry 

feature and the copy feature is then removed from the specification tree. Consequently, there is no more associativity 

between the exploded sketch and its reference sketch.

Exploding Sketches

To explode a sketch, right-click it from the specification tree and select Sketch.XXX object > Explode...

The specification tree is as shown after the explode operation:
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When done:

●     The sketch is not-up-to-date.

●     The order and the number of geometrical elements appearing in the specification tree after an explode operation 
may differ from what can be seen in the reference sketch. 

●     Exploded sketches used by Part Design or Generative Shape Design features appear in Update Error dialog boxes. 
You need to reroute them one by one.

More about Exploding Sketches

A sketch obtained by Copy>Paste>As Result With Link is a copy of its reference sketch. By default, the system keeps 

associativity between the resulting sketch and the original geometry as well as between resulting sketch position and the 

position of the sketch reference.

To manage this associativity, such sketches contain datum features which are the real features keeping associative links 

between the copies and reference sketches. 3D geometrical results associated to reference sketch features are duplicated 

and associated to these datum features. 

Thus associativity: 

With the original geometry is controlled by these datum features managing associative copies of the 3D geometrical 

results associated to reference sketches. Consequently they cannot take into account the following data that is included 

in reference sketches:
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●     Construction or axis line geometrical elements.

●     Geometrical elements on which output or output profile features exist.

●     Constraints and dimensions.

Associativity with the original geometry is always kept till it is not removed using Isolate. By the way, geometrical 

results can be different from reference sketches until datum features are not synchronized with reference sketches.

With the original sketch position is managed by the sketch absolute axis feature definition. By default it is defined as 

associative in position with its datum feature, thus with its reference sketch feature position. But you can break this 

associativity if needed by defining your own sketch position. Since V5R19, thanks to the Sketch As Result With Link 

positioning capability, associativity with original position is explicitly identified via Positioned as reference support 

definition mode or can be retrieved afterwards using this new definition mode.
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Isolating Projections and Intersections 

 This task shows how to isolate the elements resulting from the use of the Project 3D Elements  or  

Intersect 3D Elements operations.

 Open the Intersection_Canonic.CATPart document and create an intersection as explained in Intersecting 3D 
Elements with the Sketch Plane.

1.  Select any yellow element obtained from the projection or the intersection.

2.  Select Insert > Operation > 3D Geometry > Isolate command from the menu bar or right-click Mark.x 

> Isolate.

3.  The elements are no longer linked to the initial geometry, which means that you can edit them the way you 

wish. 

For example, drag and drop this curve to the location you want: 
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Once isolated, the elements are displayed in white. You can edit their graphical properties using the Edit > 
Properties command.
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Creating Output Features   

 This task shows you how to create an output feature from a geometrical element. When an output feature is 
created, its geometry is automatically removed from the sketch feature 3D result. In other words, output 
features are exposed and updated independently from the sketch within the 3D area. 

Open the Output_1.CATPart document.

 
1.  Double-click Sketch.1 to edit it.

2.  Click Output Feature . 

3.  Select Spline.1. 

Output.1 (Spline.1) is created.

An output feature is created as a standard element, but it is viewed with a thicker graphic property in 

the Sketcher. 

It is made available in the 3D area and you can update it independently from the sketch, once in the 

3D area. It is independent from the sketch 3D geometry. It is integrated as such both into the Parent/

Children view and the specification tree. 

In order to keep the user's properties, the thickness is modified only if the geometry has the 

same thickness as when the geometry was created. 

 

4.  Right-click Spline.1 and select Properties.

5.  Click the Graphic tab in the Properties dialog box that appears.

6.  Change the color and the line type to distinguish Spline.1 more easily from other elements.

7.  Exit the Sketcher workbench. 

Unlike in the Sketcher, the output feature can now be visualized with the spline properties it has been 
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applied to.

 

Multi-selecting Elements

8.  Go to the Generative Shape Design workbench.

9.  Click Multisections Surface . 

The Multi-sections Surface Definition dialog box appears.

10.  Select Sketch 4 and Sketch 5.

11.  Select the Spine tab.

12.  Select Output.1 from the specification tree.

13.  Click OK. 

The surface is created.
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Editing the Sketch

14.  Double-click Sketch.1 to edit it.

15.  Modify any of Spline.1 control points.

16.  Exit the Sketcher workbench. 

The modifications applied to the spline have no repercussions on the surface which is based on the 

output.
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●     You cannot create an output feature from a degenerated element.

●     You can only expose elements that belong to the same sketch.

●     It is not possible to copy, cut or paste an output feature in the Sketcher.

Hiding or Showing Output Features

If outside the Sketcher you apply the Hide/Show capability on a sketch node, the capability applies to all 
elements except for output elements.
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Creating Profile Features 

 This task shows you how to create a profile feature. A profile feature is made of a set of curves, connected or not.

When an output profile is created, its geometry is automatically removed from the sketch feature 3D result. In other 
words, output profiles are made available and updated independently from the sketch within the 3D area. 

You can use profile features for creating Part Design or Generative Shape Design features.

Open the Sketcher_03.CATPart document and double-click Sketch.2 to edit it.

 

 

1.  Click Profile Feature .  

From V5R17 onwards, as soon as Profile Feature is selected, the Profile Definition dialog box is displayed 

even if no geometry is selected. The name of the profile you are creating is displayed in the Name field.  

2.  Select the circle as shown:
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The geometry you selected is displayed in the Input Geometry field, the resulting geometry, that is all 
geometrical elements that eventually are exposed in the 3D area, in the Output Geometry field.

4.  Select the second circle as shown.
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Whenever you wish to remove elements from the selection, just right-click the element of interest and select 
Delete. Alternatively, just select the element in the geometry area again. 
 
A warning message is displayed in the dialog box because the application detects an ambiguity you need to 
solve: the two selected circles are not connex and the Check connexity option is selected. 

5.  Clear Check connexity.

6.  Use the Color combo list to assign the cyan color to the profile feature you are defining.
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8.  Click OK to confirm the creation. 

The parameters and options you defined for this profile are kept as default values for the next profile you will 

create later on. 

The output feature is displayed as Profile.2 in the Outputs node in the specification tree.

9.  Go into the Part Design workbench and use the profile to create a pad.
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 Note that the profile does not appear under Pad.2.

 

 

Profile Definition Dialog Box

Color 

The color helps you distinguish the elements that are part of the selection. Once in the 3D area, that color is kept. 
Indeed, unlike in the Sketcher, the profile feature is visualized in the 3D area with the color you assigned to it in the 
Sketcher. For the purpose of our scenario, set the blue color. The selected line as well as an additional line are now 
displayed in blue. Note that line thickness is also increased to help you view the selected elements that will be 
exposed in the 3D area.

Mode

Output profiles can be defined only from geometrical elements belonging to the same sketch. 
Three modes of selection are available:

●     Point (Explicit Definition): you need to select all the points of interest. In that case the Input 
Geometry field and the Output Geometry field show the same elements.

●     Wire (Automatic Propagation): after you selected a geometrical element, the application detects and 
selects all connex elements.

●     Wire (Explicit Definition): you need to select all the geometrical elements of interest. In that case the 
Input Geometry field and the Output Geometry field show the same elements.

Options

Four options let you validate the profile definition. Note that the connexity and the manifold property of the profile are 
checked by default. 

Once checks are performed, warning messages may be displayed to help you decide whether you keep your definition 
as such or if you need to modify it. Moreover, update errors appear for features causing trouble once you have left 
the Sketcher workbench. Several checks can be performed, you just need to select the appropriate option:

●     Check tangency

●     Check connexity

●     Check manifold

●     Check curvature

Reusing Input Geometry
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The geometry already used to define a profile feature can be reused for the definition of another profile. 
Using the sketch of our scenario, for example you can create a new profile feature as shown in magenta, and 
create a new pad: 
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Cutting, Copying and Pasting Output Profiles

In the Sketcher, you are not allowed to cut or copy then paste output profiles. Conversely, in the 3D area, you can 
use the Cut or Copy commands. In that case, you obtain datum features.

Deleting Output Profiles

You can delete output profiles in the Sketcher only. Deleting an output profile does not affect the geometry used to 
define that profile.

Hiding or Showing Output Profiles

If outside the Sketcher you apply the Hide/Show capability on a sketch node, the capability applies to all elements 
except for output profiles.
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Editing Constraint Tolerances

This task concerns only the dimension constraints of the sketcher and shows you how to edit the tolerance 
values of dimensional constraints.

In Sketcher workbench, tolerances are only displayed but are not taken into account when solving dimension 
values. Tolerance values displayed in the Sketcher can be managed by 3D Functional Tolerancing and 
Annotations product, which is dedicated to tolerance management. 

 
Create a sketch with dimensions.

1.  Click Edit Multi-Constraint  in the Constraint toolbar.

2.  Select the constraints for which you want to set the tolerances. Change the Maximum tolerance or 

Minimum tolerance editing field content with the spinners or enter a value. 

 

You can also add a tolerance directly from the geometry area. Double click the constraint and select Add 

tolerance in the contextual menu.
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3.  Click OK. Tolerances are displayed on the sketch with the corresponding dimension. 

Modify a tolerance

You can modify a tolerance either in the Edit Multi-Constraint dialog box or directly from the geometry area.

1.  In the geometry area, double click the constraint for which you want to modify the tolerance. The 

Constraint Definition dialog box is displayed.

2.  Right-click in the Value box and select Tolerance > Edit.

Delet a tolerance  

You can delete a tolerance either in the Edit Multi-Constraint dialog box or directly from the geometry area.

1.  In the geometry area, double click the constraint for which you want to delete the tolerance. The 

Constraint Definition dialog box is displayed.

2.  Right-click in the Value box and select Tolerance > Edit.

Restor a tolerance

In the Edit Multi-Constraint dialog box you can restore the tolerances. This applies to the selected constraint. 
It restores the tolerance to its initial state, when the multi-edit command was launched.
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1.  Select the constraint for which you want to restore the tolerance.

2.  Click Restore Initial Tolerances.

If tolerances did not exist, and were created later on, they will be deleted. 

 
If tolerances did exist, and were deleted or modified later on, they will be restored to their initial values.

Multi-select Constraints

You can multi-select constraints and thus apply the same tolerance for all of the selected constraints.

1.  Select the constraints for which you want to apply a tolerance.

2.  Enter a value in the Maximum tolerance and Minimum tolerance boxes.

         
 
The tolerances are displayed on the sketch with the corresponding dimension. 
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●     The display of the tolerances and their edition in the multi-edit command is done only for dimension 
constraints of the sketches.

●     The display of the tolerances is not done as in the standards, since it is just a way to have a global view of 
tolerances.
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Editing Sketches 

 The Sketcher workbench provides a set of functionalities for editing 2D geometry.

 

To edit an existing sketch:
●     Double-click the sketch or an element of the sketch geometry, either in the geometry area or in the 

specification tree.

●     To do this from the 3D, right-click the sketch in the specification tree, point to [sketch name] object in the 
contextual menu, and then select Edit.

 
Modifying Element Coordinates: Double-click to modify the sketch coordinates and thereby modify the feature 
defined on this sketch.

Performing Auto-Search on a Profile: Use the menu bar to auto-search for the different elements of a profile.

Transforming Profiles: Use selection to edit the profile shape and size, modify the profile location (via external 
constraints).

 Editing Conic Curves: Double-click the conic to edit it.

 Editing a Connecting Curve: Double-click the connecting curve to edit it.

 Editing a Spline: Double-click the spline to edit it.

 Editing Spline Offsets: Double-click the offset constraint to edit it.

 
Editing an element Parents/Children and Constraints: Right-click element end select Parents/Children... option 
in the contextual menu.

 
Editing Projection/Intersection Marks: Edit Projection/Intersection Marks definition and modify their import 
properties.

 Replacing Geometry: Replace geometry in the 2D and visualize it in the 3D area.

Deleting Sketcher Elements: Use selection to delete elements.
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Modifying Element Coordinates 

This task shows you how to modify a line. Modifying your sketch coordinates will affect the feature defined on this 
sketch. In other words, associativity remains valid.

Create a line.

 

Profiles are not considered as entities when it comes to editing them. To edit a profile, you will need to edit the sub-
elements composing it. 

Multi-selection is not allowed for editing Sketcher elements. 

 
1.  Double-click the line you wish to edit. 

The Line Definition dialog box appears indicating the line end point coordinates. 

2.  Enter new coordinates for changing the end points and/or the length and angle. 

3.  Check the Construction Elements option, if you wish to change the line type.

4.  Press OK. 

 

Remember that the Edit > Properties command, or the Properties contextual command let you access and edit 
sketch properties (Properties dialog box).
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Performing Auto-Search on Profiles 

This task  shows how to auto-search for the different elements of a profile.

Open the Auto_Search.CATPart document.  

1.  Select one element of the whole profile. 

2.  Select Edit > Auto Search from the menu bar.   

Element selected: Resulting auto-searched profile:

 

 

The unambiguous part of the profile is highlighted.
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More About Coincidence Constraints Automatically Added to Profiles

If the Geometrical Constraint  is activated when performing Auto Search, coincidence 
constraints are created automatically on the overlapping points of the profile. 
This way, the profile is interpreted as being closed.
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Transforming Profiles 

 This task shows you how to transform:

●     a profile shape and size using Selection .

●     a profile position according to a pre-defined solving mode.

●     a profile position using existing external constraints.

Open the Transform_replace01.CATPart document.

 

Transforming By Moving

Minimum Move

You can move as few elements as possible with respect of existing constraints, using the Minimum move 
option (default option).

Go to Tools > Options... > Sketcher (Solving mode switch button) and select Minimum move.

 

1.  Click Select . 
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2.  Drag the right line of the profile anywhere to the right. 

The profile is stretched to the right if you stretch it to the right.

3.  Click one corner of the profile and stretch this profile diagonally.
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Standard Mode

You can move as many elements as possible with respect of existing constraints, by using the Standard mode 
option.

Go to Tools > Options... > Sketcher (Solving Mode switch button) and select Standard mode.

1.  Click Select .

2.  Drag the right line of the profile anywhere to the right. 

The profile is stretched both to the right and to the top even if you stretch it to the right.

 

Relaxation

Relaxation moves elements by re-distributing them over the sketch, globally speaking. This method solves 
element moving by minimizing energy cost.

Go to Tools > Options > Sketcher (Solving mode switch button) and select Relaxation.

Miscellaneous

You can also edit the profile shape and size using commands such as Edit, Trim  and Break .
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If you want the profile to revert to its original shape, click Undo .

If the Grid option is on, you can also modify the profile using the grid. In this case, and for example if the Zoom 
is on, the point you select will be automatically repositioned at the closest grid intersection point. The profile 
new position may result awkward.

Transforming Using Constraints

1.  Click Select .

2.  Double-click the offset constraint.

 

 

 The Constraint Definition dialog box appears.

3.  Type 20mm as new value.
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The external constraint is re-computed and the geometry is re-positioned.
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Editing Conic Curves 

This task shows you how to edit conic curves.

1.  Double-click the conic you want to edit.

 

Changing the conic parameters

2.  The Conic Curve Definition dialog box is displayed. Enter the new parameters you wish to apply to the 

conic curve. You can edit the following options as displayed in the dialog box.
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Constraint Limits:
●     Start and 

EndPoints: the 
curve is defined from 
the start point to the 
endpoint.

●     Start and End 
Tangents: if needed 
the tangent at Start 
or Endpoints can be 
defined by selecting 
a curve.

●     Tangent 
intersection point: 
indicates the point 
used to define both 
Start and End 
tangents. These 
tangents are on 
construction lines 
passing through 
Start or Endpoints 
and the selected 
point.

●     Point: defines a 
point when checking 
the Tangent 
intersection point 
option.

Note that you will have 
to choose either a start 
and end tangents or a 
tangent intersection 
point.

 

 

Intermediate 
Constraints:
●     Parameter: defines 

the value of the 
parameter. Ratio 
ranging from 0 to 1 
(excluded), which 
value is used to 
define a passing 
point ( M in this 
figure) and 
corresponds to the 
OM distance/OT 
distance. 
If the parameter = 
0.5, then the 
resulting curve is a 
parabola. 
If 0 < parameter < 
0.5, then the 
resulting curve is a 
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an arc of ellipse. 
I 1 > parameter > 
0.5, then the 
resulting curve is a 
hyperbola.

●     Points 1, Point 2, 
Point 3: defines the 
possible passing 
points of the conic. 
These point have to 
be selected in logical 
order after having 
define the Start an 
Endpoints.

●     Tangent 1, Tangent 
2: defines the 
tangency when it is 
applied to one of the 
passing points.

 Applying constraints between the conic and another 
geometrical element
For instance, create a conic and a circle.

1.  Click Constraint  from the Constraint toolbar.

2.  Select the two elements.

3.  Right-click the second element and select Tangency.
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The tangency has been applied to the two selected elements.
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Inconsistent conics

If an element that belongs to the conic is deleted, the conic becomes inconsistent (the conic color turns red). 
As a result, when you exit the Sketcher workbench the Update Diagnosis dialog box is displayed and an error 
message appears within the dialog box. Just double-click the conic to re-edit it.
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Editing Connecting Curves

This task shows you how to edit a curve which connects two elements of the curve type. 

Open the Edit_Connecting_Curves.CATPart document. 

1.  Double-click the connecting curve you want to 

edit.  

Red arrows indicating tangency directions are 

now displayed at each extremity point.

 

The Connect Curve Definition dialog box is 
displayed. For each support curve, you can edit the 
following options as appropriate:
●     Point: defines the extremity point (on the support 

curve) of the connecting curve.

●     Curve: defines the support curve for the 
connecting curve.

●     Continuity: indicates whether the connecting 
curve is continuous in point, in curvature or in 
tangency with the support curves.

●     Tension: when the connecting curve is continuous 
in curvature or in tangency, specifies the tension 
which is applied to it. 
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●     Reverse Direction: when the connecting curve is 
continuous in curvature or in tangency, reverses its 
direction.

2.  For the first support curve, select Tangency 

from the Continuity field and set the tension 

to 3. 
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3.   To reverse tangency directions you can now click both red arrows available when editing. This is 

equivalent to clicking the Reverse Direction button from the dialog box. For the purpose of our 

scenario, click the left arrow. 

You must obtain this:

4.  For the second support curve, click the Point field, then select another extremity point (CtrlPoint.4 for 

example). 

5.  When you are satisfied with your modifications, click OK to validate and exit the dialog box.
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Inconsistent Connecting Curves

If an element that belongs to the connecting curve is deleted, the connecting curve becomes inconsistent (the 
connecting curve color turns red). As a result, when you exit the Sketcher workbench the Update Diagnosis dialog 
box is displayed and an error message appears within the dialog box. Just double-click the connecting curve to re-
edit it.
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Editing a Spline 

This task shows you how to edit spline properties and then modify, add or remove spline control points.

Create a spline.

 

Adding a point

To add a point, you have several possibilities, depending on whether you want to add an existing point, or create the point on the sketch 
while editing the spline. 

1.  Double-click spline, or go to Edit > Spline.1 object > Definition.... 

The Spline Definition dialog box appears. 

 

 

●     To add an existing point (i.e. a point created prior to editing the spline):
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In the dialog box, select the spline point after or before which you want to add a point. Select CtrlPoint.2 for example.  

Then, choose Add Point After or Add Point Before (depending on whether you want to add a point after or before the selected point). 
Select Add Point After for example. 

Finally, click existing point you want to add-in the spline. 

 

If you proceed as shown below, for example: 

 

You will get this result:

 
●     To create the point on the sketch while editing the spline:

In the dialog box, select the spline point after or before which you want to add a point. Select CtrlPoint.2 for example.  

Then, choose Add Point After or Add Point Before (depending on whether you want to add a point after or before the selected point). 
Select Add Point After for example. 

Finally, click sketch, at the location where you want to add the new point. 

If you proceed as shown below, for example: 
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 You will get this result:

 

Replacing a point

2.  To replace a point, select the spline point that you want to replace in the dialog box, then select the Replace Point option, and 

finally click sketch, at the location where you want to add the new point. 

If you proceed as shown below, for example:  
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You will get this result:

 

Closing a spline

2.  To close a spline, simply select the Close Spline option. 

The spline is closed in such a way that it is continuous in curvature at the closure point.  
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You can edit existing splines which are closed using a continuity in point at the closure point: selecting the Close spline option will make 
such splines continuous in curvature at the closure point. 

 

Removing a point

1.  Select the point that you want to remove in the dialog box.

2.  Click the Remove Point button.

3.   Click OK. 

Defining a tangent

1.  Select the point you want to add a tangent in the dialog box. 

2.  Check Tangency. 

A tangent appears, you can reverse it clicking on the Reverse Tangent button.

3.  If needed, check the Curvature Radius option and key in the value.
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Editing Spline Offsets 

 This task shows you how to edit an offset based on an existing spline, or even the offset constraint.

 
Create a Spline Offset.

 

Editing the Offset Constraint

1.  Double-click the constraint to change its value. 

The Parameter Definition dialog box is displayed.
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2.  Enter the value you want to apply for instance, enter 20.004.

3.  Click OK. 

The constraint value has been modified. The constraint cannot be deleted.

 

 

 

Editing the Spline Offset

1.  Double-click the spline offset. 

The Offset Definition dialog box is displayed.

3.  Change the parameter you want to apply.

 

The spline offset is associative to the original spline in such a way that for instance:
●     when deleting the spline, the offset spline is displayed in red to show that there is an update error.

●     when adding control point to the original spline, the offset spline is automatically updated.
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Editing Parents/Children and Constraints 

This task shows you how to edit an element Parents/Children and constraints.

Open the Analyse.CATPart document.

1.  Edit Sketch.2.

2.  Right-click the Offset.12 constraint and select Parents/Children... from the contextual menu. 

The Parents and Children dialog box appears.

3.  You can double-click an element to expand its parents.
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Contextual commands related to Parents and Children are available from any element.
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Editing Projection/Intersection Marks 

This task shows you how to edit Projection or Intersection marks.

Open the Analyse2.CATPart document.

1.  Double-click Mark.1.

The Import Definition dialog box appears and lets you change the element which is used as a 

reference for this mark.

2.  Make sure the Reference Element field is active, and select the arc as new reference element.
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3.  Click OK in the Import Definition dialog box. 

The mark reference and position are changed.
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Replacing Geometry 

 

 

This task shows you how to replace 2D geometry.

Replacing a geometrical element with another one in the Sketcher workbench and no modification occurs in the 
2D. Only the 3D geometrical elements which used the replaced 2D geometrical elements will be modified. 

You can visualize the modifications when entering Part Design  workbench.

Open the Replace.CATPart document.

1.  Edit Sketch.1. 

2.  Right-click the element to be replaced and select Line.2 object > Replace... 

The Replace dialog box appears.

4.  Select Line.1 as the replacing element.
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The Replace dialog box now appears as shown here: Line2 will be replaced with Line1. 

The geometry is unchanged.

5.  Click OK to confirm the change.

6.  Click Exit . 

The pad (created via the 2D geometry) is modified.
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7.  Close the document and reopen it.

8.  Create a three points arc on the sketch geometry.

9.  Select the Line.1 object > Replace... contextual command.

10.  Select the arc created.

11.  Select the Delete replaced elements and exclusive parents option in the Replace dialog box and 

click OK.
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12.  Click Exit . 

The pad is modified.
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Deleting Sketcher Elements 

This task shows you how to delete sketched elements.

Deleting sketched elements affects associated features. This what we call propagation:

●     If you delete a curve (assigned endpoints, by default), the endpoints will also be deleted on the condition 
they are not part of a constraint or common to another curve. Curves are assigned endpoints and circle or 
arcs are assigned center points, by default.

●     If you delete a curve and the endpoints/center point, these points will be actually deleted is they are not 
either part of a constraint or common to another element.

●     Propagation is not valid for constraints: if you delete a constraint, you will not delete the corresponding 
geometry.

Sketch a profile similar to the one below.

1.  Select the element you wish to delete.

2.  Select the Edit > Delete command. 

The element is deleted.
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2.  If you wish to delete a set of elements, just multi-select them and apply Delete.

 

●     You can also select the Delete command from the contextual menu. For this right-click the element to be 
deleted.

●     In case you created an element using the Sketch tools toolbar options, constraints are applied to this 
element:

�❍     If you delete this element, associated constraints will be too.

�❍     Conversely if you delete one, several or all the associated constraints, the element will be not delete.

You cannot delete elements that are not currently edited sketch elements. This is particularly true for the 
reference planes. You can multi-select these elements but they will not be deleted. 
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Deleting Points

Deleting sketched elements affects associated features. This is what we call 'propagation'. 
By default, the circles and arcs you create are assigned center points. If a point is defined as the center point of 
a circle or arc (explicitly or using concentricity constraints), when deleting the corresponding circle or arc, the 
center point is deleted along with it.

Drafting Workbenches

In Drafting workbenches, if you create a circle (or arc) with no constraint detection (for more information see 
the documentation about the Drafting Create detected and feature-based constraints option), when deleting the 
circle, the system does not delete the center point.
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Upgrading Features

This capability enables the activation of the last evolutions of the code available on the current level. It aims at 
improving the update of a feature by manually upgrading it. This capability is also applicable for part and sketch 
features.

  
 To upgrade a feature right-click it and select Upgrade. The orientation of the element may be modified: in this case, 

a warning message is issued and arrows are displayed in the 3D geometry:

However, if no dialog box is displayed, it means that the orientation of the geometry is unchanged.

Upgrading a feature enables to create its 3D parameters. See Editing Parameters.

●     It can lead to reroutes that are not managed by the command.

●     It can lead to slight changes in geometry. In this case, there is no warning message.

Upgrading Part and Sketch Features 

When improvements or corrections are linked to the update algorithm of a feature, these are always versioned in 
order to ensure CATIA update upward compatibility. This means that a feature will always be updated using update 
code linked to the CATIA release version used for its creation.

The Upgrade contextual command available from sketch features, allows you to activate on it and thus access all 
latest evolutions and improvements available on your current CATIA release.

To upgrade a Sketch feature right-click it and select Upgrade. Upgrade updates all versioning information which is 
stored in the sketch feature and its content before updating it to take into account all existing improvements and 
corrections. By the way, this automatic local update on the sketch feature is performed using a dedicated optimized 
algorithm trying to avoid as much as possible sub-element naming changes in order to minimize the number of 
reroute operations needed on impacted features when you will update your part data. Nevertheless, upgrade 
operations can lead to slight changes to geometry. In this case, there is no warning message. Upgrade operations 
can also require some reroute operations to take full benefit of upgrade operations and retrieve up-to-date part data.

Recommendations

We recommend you:

●     Perform upgrade operations on non-deactivated features

●     perform upgrade operations on up-to-date features (specially if they contain use-edge features)

●     Use Tools > Sketch Analysis before checking its use-edges status and if sketched geometry is solved (solving 
diagnosis). Due to data modification performed in V5R8, all existing use-edges created before this release cannot 
be upgraded. We advise you to remove them and create them again. If that is not possible, follow this scenario 
in order to ensure that the sketch data will be fully upgraded. Otherwise a partial upgrade is just possible and 
you will not access and take benefit of all available improvements and corrections:
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1.  Edit your Sketch feature.
2.  Select Tools > Sketch Analysis and click the Use-edges tab. You can check whether the sketch contains 

such type of use-edge data. In this case the Upgrade not possible message appears in the Comment 
field.

3.  Deactivate all old use-edges to fully upgrade your sketch.
4.  Exit Sketcher.
5.  Upgrade your sketch feature.
6.  Edit again you sketch feature.
7.  Using Tools > Sketch Analysis activate one by one each deactivated use-edges to see if these use-edges 

can be supported with the new release version. If not, use-edges have to be deleted and created again.

 

3D Insight Version 5 Release 19 Page 1139 of 1379



Analyzing the Sketch

Performing a Quick Geometry Diagnosis

Analyzing Sketched Geometry

Analyzing Projections and Intersections
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Performing a Quick Geometry Diagnosis   

This task explains how to display a quick diagnosis of a sketch geometry. You will be provided an overall status of 
the sketch geometry as a whole, so that can correct any constraint-related problem accordingly. 

Open the Sketch_Analysis.CATPart document. 

1.  Click Sketch Solving Status  in the Tools toolbar (2D Analysis Tools sub-toolbar). 

 . 

The Sketch Solving Status dialog box is displayed. It indicates the overall status of the sketch geometry. 

In this case, the sketch is under-constrained.

●     On the sketch as well as in the specification tree, under-constrained and over-constrained geometrical elements 
(lines, points, etc.) are highlighted, and iso-constrained elements are displayed in a different color. This enables 
you to see easily which items are under/ over-constrained, and which are iso-constrained.  

●     In our example, all geometrical items are under-constrained; they are therefore displayed in red. There is a 
tangency constraint which is iso-constrained; it is displayed in green. 

●     If you wish, you can click Sketch Analysis  in the dialog box to view a more in-depth diagnosis specifying 
which individual geometrical elements in the sketch are under-constrained (under-defined), over-constrained 
(over-defined) or iso-contrained (well defined). 
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2.  Click the Close button to close the Sketch Solving Status dialog box.

3.  From the specification tree, expand the Sketch.1 and then the Geometry nodes.

4.  Multi-select all items under the Geometry node, and right-click them.

5.  Select Selected objects > Fix from the contextual menu. All elements are now fixed.  

 

6.  Click Sketch Solving Status  again. The Sketch Solving Status dialog box now indicates that the 

sketch is iso-constrained.   
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Analyzing Sketched Geometry   

 

These tasks explain how to analyze sketched geometry, and how to diagnose geometry. You will be provided either a 
global or individual status and will be allowed to correct any problem stated in the status.

Open the Sketch_Analysis.CATPart document.

1.  Select Tools > Sketch Analysis from the menu bar.  

Or alternatively, click Sketch Analysis  in the Tools toolbar (2D Analysis Tools sub-toolbar).

The Sketch Analysis dialog box appears. It contains three tabs: Geometry, Projections / Intersections 

and Diagnostic.

 
Note that on the sketch, some geometrical items and constraints are highlighted so that you can see them 

easily. 
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The Geometry tab displays information helping you know whether the sketch geometry is valid. 

�❍     General Status: analyzes several elements globally. 

Note that "Implicit Profile" refers to all profiles except for profiles created via Output Feature  

and Profile Feature . For more information, see Creating Output Features and Creating Profile 
Features.

�❍     Detailed Information: provides a detailed status/comment on each geometrical element of the sketch.

�❍     Corrective Actions  : according to the analyzed element you select 
and which is not correct, you will be able to:

■     turn this element into a construction element,

■     close a profile that is not,

■     erase a disturbing element,

■     hide all constraints on the sketch,

■     hide all construction geometries on the sketch and in the detailed information area of the Geometry 
tab.
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2.  In the Detailed Information table, select Point.11.

3.  Click the Set in Construction mode icon to turn the standard mode point into a construction mode point 

and solve the problem.

Diagnosing Geometry 

4.  Click the Diagnostic tab.

The information on this tab displays a full diagnosis of a sketch geometry. It provides a global analysis of 

the sketch as a whole, and specifies whether individual geometrical elements in the sketch are  under-
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constrained (under-defined), over-constrained (over-defined) or iso-constrained (well defined):

�❍     Solving Status: provides a quick overall analysis of the sketch geometry.

�❍     Detailed Information: provides a detailed status on each constraint and geometrical element of the 
sketch, and lets you know what type of element it is (geometry, constraint).

�❍     Action : according to the analyzed element you select, you will be able to:
■     hide all constraints on the sketch and in the detailed information area,

■     hide all construction geometries on the sketch and in the detailed information area of the 
Diagnostic tab.

■     erase geometry

If you select items from the Detailed Information table, they will be highlighted on the sketch, which 
enables you to identify them easily. To solve constraint-based problems in the sketch, you need to edit the 
sketch directly. 

5.  Close the Sketch Analysis dialog box.

6.  Right-click the Point.3 item in the sketch or from the specification tree, and select Point.3 object > Fix.

7.  Repeat this operation for the Line.1, Circle.1, Line.2 and Point.8 items. 

8.  Re-open the Sketch Analysis dialog box and click the Diagnostic tab.  

You can notice that the items you fixed are now iso-constrained. 

3D Insight Version 5 Release 19 Page 1146 of 1379



More about the Reset Dependencies Option

If you created a complex fix together scenario in prior versions (from R14 to R17) by deselecting the Add/Remove 
Dependencies option of the Fix Together Definition dialog box, you can reset the dependencies removed using 
the Reset Fix Together Dependencies option of the Sketch Analysis dialog box.

When an inconsistency is detected in a fix together, a warning is displayed in the Detailed Information box and a 
new Reset Fix Together Dependencies command is available: 

 
 
You are free to either reset the dependencies or leave it as it is. To reset the dependencies, select all the items with 
a Non-standard fix together definition status and click Reset Fix Together Dependencies.

The Reset Fix Together Dependencies command only appears when at least one geometry is missing from the 
fix together.

 

About Coincidence Constraints Automatically Added to Profiles

Whenever you create a sketch-based feature from a profile, the system automatically creates coincidence 
constraints on the overlapping points of the profile to interpret it as closed. This is the reason why once the sketch-
based feature is created, coincidence constraints are visible in the detailed information list of the Sketch Analysis 

 results.
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Analyzing Projections and Intersections

 

This task shows you how to analyze the elements resulting projection and intersection operations you explicitly 
performed but also from implicit operations. 

You will be provided either a global or individual status and will be able to correct any problem stated in the status.

Open the Analyse.CATPart document.

1.  Select Tools > Sketch Analysis from the menu bar.  

Or alternatively, click Sketch Analysis  in the Tools toolbar (2D Analysis Tools sub-toolbar).

The Sketch Analysis dialog box appears. It contains three tabs: Geometry, Projections / Intersections 

and Diagnostic.

2.  Open the Sketch Analysis dialog box again.

3.  Click the Projections / Intersections tab.

 

3D Insight Version 5 Release 19 Page 1148 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/dysug_C2/samples/Analyse.CATPart


 
The information on this tab displays a full diagnosis of a sketch geometry. It provides a global analysis of 

the sketch as a whole, and specifies whether individual geometrical elements in the sketch are  under-

constrained (under-defined), over-constrained (over-defined) or iso-constrained (well defined):

�❍     Detailed Information: provides a detailed status/comment on each projection or intersection, on 
constraints and so forth.

�❍     Corrective Action  : according to the analyzed element you select 
and which is not correct, you will be able to:

■     isolate geometry

■     activate/deactivate a constraint

■     erase geometry

■     replace 3D geometry

■     hide all constraints on the sketch,

■     hide all construction geometries on the sketch and in the detailed information area of the 
Projections/Intersections tab.

You can see that all construction and intersection elements for this part have a valid status so you don't 
have to do anything.
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Setting Constraints 

You can set geometrical and dimensional constraints on various types of elements.

Before you Begin: You should be familiar with important concepts.

Create Quick Dimensional/Geometrical Constraints: Set constraints on elements or between two or three 
elements. The constraints are in priority dimensional. Use the contextual menu to get other types of constraints 
and to position this constraint as desired.

Define Constraint Measure Direction: Define the measure direction as you create a dimensional constraint.

 Create Contact Constraints: Apply a constraint with a relative positioning that can be compared to contact. You 
can either select the geometry or the command first. Use the contextual menu if you want to insert constraints 
that are not those created in priority.

Modify Constraint Definition: Double-click a constraint and modify the definition using the Constraint Definition 
dialog box.

Create Constraints Using a Dialog Box: Set various geometrical constraints between one or more elements using a 
dialog box and if needed, multi-selection.

Modify Constraints on/between Elements: Edit geometrical constraints defined on elements or between elements 
either in the Sketcher or in the 3D area.

Fixing Elements Together: Select the geometry to be attached and click the icon.

Auto-Constrain a Group of Elements: Detects possible constraints between selected elements and imposes these 
constraints once detected.

Animate Constraints: Assign a set of values to the same angular constraint and examine how the whole system is 
affected.

Edit Multi-Constraints: Click the icon and enter new values for the dimensional constraints displayed in the dialog 
box that appears. 

Analyze and Resolve Over-Constrained or Inconsistent Sketches
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Before You Begin 

What is SmartPick?

SmartPick is an intuitive, easy-to-use tool designed to make all your Sketcher creation and edition tasks as simple as possible. SmartPick dynamically detects 
the following geometrical constraints:

●     support lines and circles

●     alignment

●     parallelism

●     perpendicularity

●     tangency

●     concentricity

●     horizontality and verticality

●     midpoint

What are Constraints?

There are times when simple sketches are adequate for your design process, but you will often need to work on more complex sketches requiring a rich set 
of geometrical or dimensional constraints. The Sketcher workbench provides constraint commands which will allow you to fully sketch your profiles.

 When you apply constraint on curves, lines, circles and ellipses, the complete geometrical support is taken into account.  

As an example for this arc, the entire circle is taken into account when you apply constraints.

 
 The location you click when selecting the elements to constrain is taken into account to create the constraints (it is used to position the constraints 
accurately). Therefore, when selecting the elements to constrain, it is important that you click where you want the constraint to be positioned. The software 
will then position the constraint according to the area where you clicked.  
This is especially true when creating constraints on certain types of curves (complex curves like splines, for example). In some cases, if you don't click in 
the right place when selecting the curve to constrain, the constraint and the geometry will be inconsistent. 

Geometrical Constraints

A geometrical constraint is a relationship that forces a limitation between one or more geometric elements. For example, a geometrical constraint might 
require that two lines be parallel. If you select three lines, or two lines and a point, these elements will automatically result parallel to each others, as 
illustrated in the table further down. 

You can set a constraint on one element or between two or more elements.

 Number of Elements  
Corresponding Geometrical Constraints

 One Element

Fix 
Horizontal 
Vertical 

 

 Two Elements

Coincidence 
Concentricity 
Tangency 
Parallelism 
Midpoint 
Perpendicularity 

 

 Three Elements Symmetry 
Equidistant Point
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When creating your constraint, remember that a green constraint is a valid constraint by default. Conversely, a yellow constraint indicates that the definition 
is not valid. The software lets you customize the colors and more generally the style of the constraints you use. To have details about these capabilities, see 
Infrastructure User's guide.

When you position the cursor on constraint symbols, the software calls your attention on the elements involved in the constraint system. Here are two 
examples of what you may get.

Dimensional Constraints

A dimensional constraint is a constraint whose value determines geometric object measurement. For example, it might control the length of a line, or the 
distance between two points. 

You will use Constraint  to finalize your profile. The Constraint command allows you to set dimensional or geometrical constraints but you will mainly 
use it to set dimensional constraints.

You can combine dimensional constraints to constrain a feature or sketch.

You can set a dimensional constraint on one element or between two elements.

 Number of Elements
Corresponding Dimensional Constraints

 One Element

Length 
Radius/Diameter 
Semimajor axis 
Semiminor axis 

 

 Two Elements

Distance 
Angle 

 
 You can apply a diameter constraint between two lines provided one of these lines is an axis line.

 The application does not take into account negative values.

 

What About Constraining While Sketching?

Provided you previously activated Constraint , sketching certain elements automatically generates constraints although you did not specify that 
you wanted these elements to be actually constrained.

What About Constraint Visualization?

The table below lists the symbols used to identify the different constraint types:

 
Symbol Constraint Type

Perpendicular

Coincidence

Vertical

Horizontal

Fix/Unfix

Parallel

 /  Radius/Diameter
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Hiding or Showing Constraints

Three existing settings are available from the Visualization toolbar. They all let you adjust the visualization of constraints according to your needs. You can hide:

●     constraint diagnoses just by deselecting the Diagnosis  icon 

●     dimensional constraints just by deselecting the Dimensional Constraints  icon. 

●     geometrical constraints just by deselecting the Geometrical Constraints  icon 

To know more about these capabilities, refer to the Filter paragraph in Symbols. 
 
 The visualization mode of constraints is based on the 3D constraints visualization filter. 
 
The constraints visualization filter settings applied while editing a sketch are specific to this sketch and prevail over the settings defined in the 3D constraints 
visualization filter (Tools> Options> Parameters and Measure>  Constraints and Dimensions> Filter). 
 
These specific settings will be kept every time the sketch is edited.

What About Constraint Colors?
 

 

As soon as you detect a constraint problem, try to solve this problem. Otherwise, if you let the model be overloaded with diagnostics, it will soon become very 
hard for you to find the origin for each of these diagnostics.

For more information about over-defined or inconsistent sketches, see Analyzing and Resolving over-defined or inconsistent Sketches. 

 
COLOR and DIAGNOSTIC SOLUTION: 

   
 White: Under-Constrained Element 

 The geometry has been constrained: all the relevant dimensions are satisfied but there are still some degrees of 
freedom remaining.

Add constraints.

 

  

 
 Brown: Element Not Changed 

 

●     Some geometrical elements are over-defined or not-consistent,

●     or the geometry is fixed,

●     or there is either two free or one free and one fixed geometry in the same set. 

As a result, geometry that depends on the problematic area will not be recalculated.

Remove one or more dimensional constraints, or, in 
the case of fixed geometry, unfix it.
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 Green: Fixed Element

 The geometry has been fixed using the Constraint Definition dialog box or the contextual menu (right mouse 
button).

 

   

 Green: Iso-Constrained Element 

 All the relevant dimensions are satisfied. The geometry is fixed and cannot be moved from its geometrical 
support.  

 Geometry before and after being moved:  

  

    
 Purple: Over-Constrained Element 
 The dimensioning scheme is over-constrained: too many dimensions were applied to the geometry. Remove one or more dimensional constraints.

   

 Red: Inconsistent Element 

 At least one dimension value needs to be changed. This is also the case when elements are under-constrained 
and the system proposes defaults that do not lead to a solution.

Add dimensions. Set dimension value(s) properly.

  

Inconsistent and Over-Constrained Elements 

If a sketch contains inconsistent and over-constrained elements when leaving the Sketcher workbench a warning will be generated .

3D Insight Version 5 Release 19 Page 1154 of 1379



 Under-Constrained Elements 

If a sketch is under-constrained when leaving the Sketcher workbench, the application generates errors if Generate update errors when the sketch is 
under-constrained is active. For more information, refer to the section describing how to customize your Sketcher session and more precisely, see Update.

Creating a Constraint Between a 2D and a 3D Element

When you need to create a constraint between a 3D element and a line, for example, this creation may result impossible. This is the case when the projection 
or intersection resulting use-edge does not give a unique solution. In other words, the use-edge (projection of one side of a pad) corresponds to several limit 
edges of the side.

As a result, you will not be able to select this 3D element when creating the constraint. You will therefore have to use manually the projection operators.
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Quickly Creating Dimensional/Geometrical Constraints 

 This task shows you how to set dimensional or geometrical constraints between one, two or three elements. The 
constraints are in priority dimensional. Use the contextual menu to get other types of constraints and to position 
this constraint as desired.

In this particular case, we will set constraints between two elements by selecting the command and then a line 
and a circle. But what you can also do is set dimensional constraints by multi-selecting the circle and line, and 

then clicking the Constraint icon .

At any time, you may move the cursor: the distance value will vary accordingly. Click for positioning the newly 
created dimensional constraint.

Create a circle and a line.

 

1.  Click Constraint . 

2.  Select the circle. 

The circle diameter constraint is displayed.

3.  Select the line. 

The relation between the two elements is reconsidered. In other words, the circle diameter constraint is 

no longer displayed.
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4.  Right-click to display the contextual menu and select the Tangency command to set a tangency 

constraint between the line and the circle. 

A tangency constraint has been created between the circle and the line.

 

5.  Click Constraint .

6.  Right-click the line and select Line.x object > Fix  to prevent the line from moving. 

The line is fixed and the anchor, that is the fix symbol, is displayed.
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 To unfix the line, you can use Line.x object > Unfix from the contextual menu.

●     A Projection/Intersection edge created by a constraint is hidden till the software detects a problem with this 
constraint. In this case, it appears to indicate the error.

●     When creating a coincidence constraint between a point in the current sketch and a 3D element outside the 
sketch, by default the constraint is created on the projection of this 3D element whenever possible. (The 
constraint is created on the intersection of this 3D element with the sketch plane only when there is no 
projection for the 3D element.) So if you want to create a constraint on the intersection of the 3D element 
with the sketch plane, you need create an intersection between this 3D element and the sketch plane, and 
then create the coincidence constraint with the intersected point.

●     We recommend not to create constraints or projections from wireframe elements which lie on a plane 
orthogonal to the sketch. As a matter of fact, the orientation of the result of these projections in the sketch 
plane is not stable. (Constraints with external elements use projection first).

●     The Shift key lets you deactivate a constraint (auto-detected via SmartPick).  
The Ctrl key lets you lock the constraint currently created and lets you create others.

●     Selecting one element lets you create a dimensional constraint.  
Selecting two elements lets you create a distance or an angle constraint.

●     If you want to create a symmetry or equidistance constraints on three elements, you must select Allow 
symmetry line in the contextual menu after having selected the two first elements.

●     You can refer to Selecting Using a Filter and Selecting Using Other Selection... Command in the 
Infrastructure User's Guide to help you select the elements that you want to constrain.

 You can also define constraints using the Constraint Definition dialog box run via the Constraints Defined in 
Dialog Box  command, or by means of the contextual command.
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Defining Constraint Measure Direction 

This task shows you how to define the measure direction as you create a dimensional constraint. For example, 
you will assign the horizontal measure direction to a constraint to be created between two circles.

Create two circles as explained in Creating Circles.

1.  Create a distance constraint between the circles via Constraint . 

2.  Right-click the constraint and select the Horizontal Measure Direction. 

The constraint is now positioned according to the horizontal direction.
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3.  Click anywhere to create the constraint.
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Modifying Constraints 

In this task, you will find the following information:
●     Step-by-step Scenario showing you how to edit constraints defined in the Sketcher.

●     Modifying Constraint Values by Using the Shift Key

●     About Diameter and Radius Constraints

●     Deactivating or Activating Constraints

Open the Constraint_Definition.CATPart document.

1.  Double-click Sketch1 as the sketch to be edited. 

You are now in the Sketcher workbench.

 
2.  Double-click the Radius.6 constraint. 

The Constraint Definition dialog box appears.

3.  Select the Reference option to make the constraint a reference. 

The Radius field is deactivated, indicating that the value is now driven by modifications to the sketch. 

 
Using the Reference mode, the offset value is displayed between brackets indicating this mode and measured from the component locations. When the 

offset constraint supporting elements are two non-parallel lines or the offset constraint is over-constrained, the offset value cannot be measured, the 

constraint is invalid, any value is displayed and two pound signs are displayed between the brackets (##).

4.  Click OK to confirm. 

The radius value is displayed in brackets in the geometry area.
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If you drag the corner center point, you can check that the radius value is updated.

5.  Double-click the Angle.9 constraint. 

The Constraint Definition dialog box appears.

6.  Type 125deg and click OK. 

The new value is displayed in the geometry area.  It affects the angle. The sketch shape is also modified due to the radius previously converted into a measure.

 

7.  Double-click the Offset.14 constraint.

The Constraint Definition dialog box appears.

8.  Click the More button to access additional information.

 

3D Insight Version 5 Release 19 Page 1162 of 1379



9.  Click the Line.5 component. 

The related geometry is highlighted.

10.  Click Reconnect... to redefine the constraint component.

11.  Select Line.6 and type 52mm in the Value field.

12.  Click OK. 

The position of the profile is modified accordingly.

13.  Exit the Sketcher. 

The application has integrated the modifications to the sketch.

14.  Double-click Offset.3. 

The Constraint Definition dialog box appears.

15.  Type 30mm in the Value field and click OK. 

The offset is modified accordingly.
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In the 3D area, if you select the blue pad, the Edit Parameters contextual command allows you to display all parameters and constraints defined for that pad.

When you are in the Repeat mode (you double-clicked on the command for creating a constraint), if you try to edit an existing constraint while creating 
another constraint, the modification will only be taken into account when you have finished creating this other constraint.

 

Modifying Constraint Values by Using the Shift Key 

It is possible to edit dimensional constraint values just by dragging constrained geometry. This is a quick way of editing constraints without launching 
dialog boxes.

1.  Press the Shift key and drag the vertical line to the right as shown below.

 

 You can notice that the value of the angle constraint is not only modified as you are dragging the cursor, but it is also displayed between parentheses, 
meaning that it is temporarily converted into a reference. In other words, you can move the geometry freely, with respect to geometrical constraints.

2.  Press the Shift key and drag the vertical line to the right as shown below. 

The modified angle value is displayed (137.913), and is no longer a reference:
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If the Snap to Point  option is active, the geometry is moved according to the spacing you defined for the grid. For more information, refer to 
the customization for Sketcher).

 

About Diameter and Radius Constraints

●     You can obtain a radius constraint by editing a diameter constraint. You just need to double-click the diameter constraint and choose the radius option in 
the dialog box that appears.

●     If you need to create a formula remember that:

�❍     the parameter corresponding to the radius or diameter constraint is referred to as RadiusX.object

�❍     this parameter always contains the radius value. As a consequence you can only add a formula on the 
radius, not on the diameter (the diameter is a way to display the constraint, not the parameter itself).

For more information about formulas, refer to Knowledge Advisor User's Guide.

●     You can add a formula to the radius value of a diameter constraint by using Tools > Formula.

Deactivating or Activating Constraints

You can:

●     deactivate a constraint by right-clicking it and selecting XXX.N.object > Deactivate. In other words, this constraint will still appear on the sketch but will 
not behave as such. 
Deactivated constraints appear preceded by an open-close brackets symbol in the geometry and in the specification tree.

●     activate a constraint, use the Activate option from the contextual menu.
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Creating Constraints via a Dialog Box 

This task shows you how to set various geometrical constraintsusing a dialog box. For example, you can use the 
Constraint command to finalize your profile and set constraints consecutively.

You may define several constraints simultaneously using the Constraint Definition dialog box, or by means of the 
contextual command (right-click).

If you want the constraints to be created permanently, activate Dimensional constraints  and/or the 

Geometrical constraints (depending on the type of constraint you want to create) from the Sketch Tools 

toolbar. If you do not activate these icons, the constraints will only be created temporarily. 

Open the Constraint_DialBox.CATPart document.

1.  Multi-select the elements to be constrained. For example, two lines.

2.  Click Constraints Defined in Dialog Box  from the Constraint toolbar.

The Constraint Definition  dialog box appears, indicating the types of constraints you can set between 

the selected lines (selectable options).  
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These constraints may be constraints to be applied either one per element (Length, Fix, Horizontal, 

Vertical) or constraints between two selected elements (Distance, Angle, Coincidence, Parallelism 

or Perpendicular). 

Multi-selection is available. 

If constraints already exist, they are checked in the dialog box, by default.

Note that, by default, a diameter constraint is created on closed circles when checking the Radius/Diameter 
option. If you need a radius constraint, you just have to convert this constraint into a radius constraint by double-
clicking it and choosing the Radius option. 

3.  Check the Perpendicular option to specify that you 

want the lines to always remain perpendicular to 

each others, whatever ulterior modifications. 

4.  Click OK. 

The perpendicularity symbol appears.
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5.  Now, select the bottom line and click Constraints 

Defined in Dialog Box . 

The Constraint Definition  dialog box indicates you 

can set the line as a reference. 

6.  Check the Fix option in the dialog box and click OK.  

The anchor symbol appears indicating that the line is 

defined as a reference.

  

7.  Select the corner on the left of the profile and click Constraints Defined in Dialog Box . 

The Constraint Definition  dialog box indicates you can choose the Radius/Diameter or Fix option.

8.  Check Radius/Diameter in the Constraint Definition dialog box and click OK. 

The radius value appears.
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9.  Multi-select both vertical lines and click Constraints Defined in Dialog Box .

10.  Check the Distance option in the Constraint Definition  dialog box and click OK. 

The distance between both lines appears.

 

At any time after the constraint was created, you can modify the constraint measure direction and/or reference. See 
Defining Constraint Measure Direction for more details. 
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Modifying Constraints On/Between Elements

 This task shows you how to edit geometrical constraints defined in the Sketcher or in the 3D area.

Open the Constraint_Definition.CATPart document  and double-click Sketch1 in the specification tree. 

1.  Select the right vertical line and click Constraints Defined in Dialog Box  from the Constraint 

toolbar.

2.  The Constraint Definition dialog box appears. Select Length and Verticality. 

3.  Click OK to apply the modification. 

The line is vertical.

4.  Select the left vertical line and click Constraints Defined in Dialog Box . 

The Constraint Definition dialog box appears, indicating that a verticality constraint is already defined for 

the line. 

5.  Uncheck Vertical to remove the verticality constraint.
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6.  Click OK to apply the modification. 

The symbol for verticality is removed. The profile now looks like this: 

 

The order of selection of the elements defining the constraint influences the angular sector.
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Fixing Elements Together 

In this task, you are going to attach sketcher elements together by using the Fix Together command. This capability lets you constrain a set of 
geometric elements even if constraints or dimensions are already defined for some of them. Once constrained, the set is considered as rigid and can be 
easily moved just by dragging one of its elements.

One of the interest of this capability is that it also allows you to make 2D kinematics studies in the Sketcher.

This task shows you how to make two elongated holes perpendicular, then how to position them inside a rectangle, while using the Fix Together command.

●     Making Elongated Holes Perpendicular (scenario)

●     Selecting Geometrical Elements

●     Degrees of Freedom

●     Positioning Holes in the Rectangle (scenario)

●     Editing a Fix Together Constraint

●     Additional Constraints

●     Removing Geometrical Elements

●     Applying Operations onto a Fix Together Constraint

●     Methodology

Create a rectangle and two non-constrained elongated holes next to it.

Making Elongated Holes Perpendicular 

Prior to using the Fix Together command, consider the following scenario: to make both elongated holes perpendicular to each other, you could be tempted 
to select one oblong hole then drag it next to the second one, and eventually set a perpendicular constraint. The fact is that setting the constraint if no 
other constraints are set, deforms the holes. To quickly achieve the desired geometry, follow the steps as explained below.

1.  Click Fix Together .  

From V5R17 onwards, as soon as Fix Together is selected, the Fix Together Definition dialog box is displayed even if no geometry is selected.

2.  Select one elongated hole by using the selection trap.

The Fix Together Definition dialog box that appears displays all selected geometrical elements. 
 

 
 

Selecting Geometrical Elements

Dependencies

To assume that the rigid body behavior can be managed, by default the application includes element dependencies. When adding a spline for instance, all 
its control points and control point tangencies are automatically added even if they were not selected.

The following table lists geometric elements and their corresponding dependencies: 
 

 Geometric Element Dependency

 Line Start point + End point
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 Circle/Ellipse Center point

 Arc of Circle/Ellipse Enter point + Start point + End point

 Parabola/Hyperbola Start point + End point

 Conic by two points Start point + End point + (Start Tangent curve + End Tangent curve) or Tangent Intersection point +  (Passing point or Not)

 Conic by four points Four points + One Tangent curve

 Conic by five points Five points

 Connect Curve First point + Second point + First curve + Second curve

 Spline Control points + Tangent directions

  

From R14 to R17 the Add/Remove Dependencies option was available to allow the creation of complex fix together sketch scenarii. You can still revert to a 
fix together with all its dependencies. To do so, refer to the Analyzing Sketched Geometry chapter of this guide

Number of Elements

You can select as many geometrical elements as you wish, but just remember that a geometrical element can be used by only one Fix Together constraint.

Whenever you wish to remove elements from the selection, just right-click the element of interest and select Delete. Alternatively, just select the element in 
the geometry area again.

Absolute Axis

You can select the origin, the H or V Direction of the sketch absolute axis. These three elements cannot be selected at the same time by a selection trap. 
You need to explicitly select them one by one.

3.  Click OK to confirm.

The Fix together constraint is created as indicated by a green paper clip symbol. 
 

 
 

●     In case of Interactive Drafting and 2D layout for 3D Design, when using Fix Together constraint the 
following needs to be considered: 

�❍     The elements constrained together are added in the Fix Together Constraints node under the respective 
view node in the specification tree. Any new elements that are constrained using fixed together are added 
under this node. To view this node, select the Display features under views check box (using Tools 
> Options > Mechanical Design > Drafting > General tab, Tree area).

Interactive Drafting 2D Layout for 3D Design

�❍     The Fix Together Constraints node is created by default. To view it or not in the specification tree is 
your choice. Thus you can select the Display features under views option after the Fix Together command.

�❍     The Fix Together Constraints node is added to the specification tree when the one or more elements are 
fixed together using the Fix Together constraint. The node is removed from the specification tree when the 
last instance of fixed together constraint is removed.

�❍     The main family node Fix Together Constraints is not selectable as it is used to just group fixed 
together constraints. When trying to select a family node, the selected object will be the parent view of the node.

�❍     The contextual menu for the object in the specification tree is the same as when the object is selected in 
the view geometry.
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�❍     Objects created directly in the sheet or the sheet background, are not displayed in the specification tree.

�❍     The active sheet and view nodes are highlighted with blue background.

Degrees of Freedom

The set of geometric elements constrained by Fix Together has three degrees of freedom whatever the number of elements. In order to be fully defined, the 
set needs to be dimensioned to fix geometry taking up at least the three degrees of freedom (one rotation and two translations).

A geometric element included in a set of elements constrained via Fix Together  can also be constrained using . If, for instance, a Fix 
Together constraint contains a fixed line, the set of geometric elements has one single degree of freedom which is along the direction of the line.

4.  Repeat the operation for the second elongated hole.

Just to check that you can now manipulate each hole by keeping its rigid body.

5.  Select them and drag them to any location. 

 

 
 

6.  Set the perpendicular constraint. 

 

 
 

Positioning Holes in the Rectangle

7.  To position both holes inside the rectangle, delete the constraints you previously set.

8.  Create only one Fix Together for both holes. 

 

 
 

9.  Drag the holes all together inside the rectangle after selecting any of their geometrical element and add constraints between the rectangle and the holes 

to specify their exact positions. 
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10.  Select the Fix Together constraint attaching the holes and use the Fix-Together.x object > Deactivate contextual menu item. 

Note that if the Fix Together constraint is deactivated, the geometric elements are always seen by the application as belonging to a rigid set. So selecting 

them remains impossible for defining another Fix Together constraint. 

You can now modify the shapes of the holes as the constraint is deactivated.

11.  Enlarge the right hole. 

 

 
 

12.  Note that passing the cursor over an activated or not Fix Together constraint highlights the associated geometry. 

 

 
 

Editing a Fix Together Constraint

You can add a geometrical element to a Fix Together constraint provided it belongs to the current sketch and is not already included in another Fix 
Together constraint. The selection or the pre-selection of the elements to add depends on this verification during the Fix Together constraint creation and editing.

You can add several elements at the same time either by using the CTRL key or the selection trap. After a selection:

●     Geometrical elements not used for the definition are added

●     Geometrical elements that are already part of the definition are removed.

Additional Constraints 
 
●     Adding constraints between elements involved in a Fix Together constraint and other elements involved too in a distinct Fix Together constraint or free 

elements allows you to position the fixed together set.

●     Adding a constraint to a fixed together element brings about an over-constrained system. But unlike other types of constraints, when exiting the Sketcher, 
the application does not detect no inconsistency.

●     All existing or added constraints on geometric elements of a Fix Together constraints are seen as over-defined (in purple when solving status is displayed). 

Except for Fix constraints, no constraints are solved between geometric elements linked by the same Fix Together constraint. However, no update error 
appears on such over-defined constraints (between Fixed Together geometric elements) and the part is successfully updated.

Removing Geometrical Elements

You can remove geometrical elements from a Fix Together constraint by deleting the geometrical elements: dependencies are deleted too.

When the number of geometric elements in the set is less than two, the Fix Together constraint is NOT automatically deleted.

Applying Operations Onto Fix Together Constraint

Copy/Paste

You can copy and paste a fix together set (not the constraint alone). To do so:

1.  Select the paper clip.

2.  Use the Fix Together object > Select Geometrical Elements contextual menu item.

3.  Use Ctrl to include the paper clip in the selection.

or

1.  Use the selection trap to ensure that the paper clip and the associated constrained geometry are selected.

2.  Apply the Copy > Paste capability.
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Mirror

By switching off the Geometric constraints mode, the Fix Together constraint is taken into account like the other constraints when mirroring geometries 
and keeping the initial constraints: 
 

 
 
...otherwise, the application creates symmetry constraints as requested. 
 

 
 

Break/Trim/Corner/Chamfer

You can apply the Break , Trim , Corner  and Chamfer  commands onto elements attached by a fix together constraint.

When all the geometrical elements belong to the same Fix Together constraint, the constraint is updated accordingly. For instance, when breaking a curve, 
the new half curve is automatically added to the definition.

Methodology

Depending on your geometry and your needs, you will use the Fix Together  command or the the Auto Constraint command, bearing in mind that:

●     The Fix Together  command creates only one constraint for a group or elements.

●     The Auto Constraint  command detects all possible constraints between the selected elements then creates these constraints. This means that 
sometimes you may create a lot of unnecessary constraints just for imposing a rigid behavior. For more information, refer to Autoconstraining a Group 
of Elements in CATIA Sketcher User's Guide.

The Fix Together  command is a way of getting better solving performances as well as solving more complex systems including rigid sub-parts.
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Auto-Constraining a Group of Elements 

 The Auto Constraint command detects possible constraints between the selected elements and imposes these 
constraints once detected. This task shows you how to apply this command on a profile crossed by a vertical line.

Open the Constraint_Contact.CATPart document.

 
1.  Select the profile to be constrained.

 

2.  Click Auto Constraint . 

The Auto Constraint dialog box is displayed. The Elements to be constrained field indicates all the 
elements detected by the application after selecting the profile.

3.  Click the Symmetry lines field and select the vertical line in the geometry area.

All the elements in the profile that are symmetrical to the Line will be detected.
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The Reference elements option allows you to select references to be used to detect possible 
constraints between these references and the elements selected. Once the profile is fully constrained, 
the application displays it in green.

To know how to use the Constraint mode, refer to Stacked and Chained Modes.

4.  Click OK to constrain the sketch including the profile and the vertical line and, if needed, modify the 

location of the constraints.

The different constraint created are:

●     Parallelism

●     Symmetry

●     Tangency

●     Radius

●     Angle (two constraints)

●     Offset (two constraints)

The sketch is not displayed in green because it is not constrained in relation to external elements 
(edges, planes and so on). 
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Stacked and Chained Modes

When using the Auto-constraint command, there are two ways of considering what a reference is. 

●     You can decide that the element you explicitly select as the reference is not an absolute reference, which 
means that this element is used only once, just to compute the first constraint. Then, the system reuses the 
constrained element as a reference in turn, to compute the next constraint and so on. If you choose this 
computation mode, you then need to set the Chained constraint mode. 
 
In the following example, V axis is used as the first reference and it is used just once. You can notice that 
the other two offsets (70 and 50) are computed in relation to the lines. 
The picture shows them in red:
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●     If you decide that the element you select as the reference is an absolute reference for all the constraints 

that will be detected, you need to specify this by setting the Stacked constraint mode.  
 
In the following example, because V axis is set as the absolute reference, all offset constraints requiring a 
reference element are computed in relation to V. The picture shows them in red:
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Animating Constraints  

 This task shows you how constrained sketched elements react when you decide to make one constraint vary. In 
other words, you will assign a set of values to the same angular constraint and examine how the whole system 
is affected. You will actually see the piston working.

Open the Animating_Constraints.CATPart document.

 
1.  Select the Angle.54 constraint.

 

2.  Click Animate Constraints .  

The Animate Constraint dialog box appears.
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 ●     The First value and Last value fields let you define the maximum and minimum values for the 
constraint.

●     The Number of step field defines the number of values you wish to assign to the constraint 
between the first and last values.

3.  Type 15 as Number of steps value.

4.  Type 115deg for the First value. 

5.  Type 246deg for the Last value. 

6.  Check the Hide constraints option for hiding constraints. This can be useful when there are many 

elements in the sketch.
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7.  Select the Loop button .

8.  Click the Run Animation button  to see how the sketch is affected by the different values 

assigned to the constraint.

The command induces a clockwise rotation while moving the rectangle up and down.

8.  Unselect the Hide constraints option to display the constraints again.

Once the maximum value is reached, that is 360 degrees, the sketch looks like this:
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Actions

 Run Back Animation: shows the different constraint values starting from the last value. In our 
scenario, we saw a counterclockwise rotation.

Pause Animation: stops the animation on the current value.

Stop Animation: stops the animation and assigns the first value to the constraint.

Run Animation: starts the command using the option defined (see below).

 

Options

 

 One Shot: shows the animation only once.

Reverse: shows the animation from the first to the last value, then from the last to the first value.

Loop: shows the animation from the first to the last value, then from the last to the first and so on.

Repeat: repeats the animation many times from the beginning to the end.
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Edit Multi-Constraint 

This task shows you how to quickly edit all or some dimensional constraints contained in a sketch.  

When you are editing a dimensional constraint value, the whole sketch is re-evaluated. Using the new Edit Multi-
Constraint capability, the sketch behavior differs: the constraints values you modify are evaluated at the same 
time once you have click OK in the dialog box.

 
Open the Constraint_DialBox.CATPart document, select the whole geometry using the trap tool and apply the 
Auto-Constraint command.

1.  Click Edit Multi-Constraint  from the Constraint toolbar. 

The Edit Multi-Constraint dialog box that appears displays the whole dimensional constraints of the 

sketch.
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In case you wish to restrict the selection, that is access not all of the constraints but just a few of 

them, first select the constraints of interest, then click Edit Multi-Constraint . Once the dialog 
box is displayed, you still can add other constraints if needed.

2.  Enter a new value, for instance 70 to edit Offset.21, the selected constraint. 

3.  Select Radius.15 then enter 18 as its new value. 

Note that in the geometry area, Offset.21 is now displayed in light blue, indicating that its value is 

being edited. The new value is also displayed. 

Note that the dialog box displays initial values and current values. 

4.  Click Preview to get an idea of the result:
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5.  Assuming that you are not satisfied with the new value for Radius.15, just click the Restore Initial 

Value button. 

If you wish to restore several initial values, just use Ctrl while selecting the desired constraints, then 

click the Restore Initial Value button.

Diameter Dimensions

The Edit Multi-Constraint dialog box indicates diameter dimensions as radius dimensions with their 
corresponding values.

Contextual Commands

Standard contextual items, those you can get from any constraint definition dialog box, are available from the 
value field. These commands are:

●     Edit formula...: enables you to edit a formula.

●     Edit...: enables you to edit a parameter.

●     Add tolerance...: enables you to edit tolerances.

●     Change step: specifies an increment/decrement amount. 

●     Add Multiple Values...: enables you to add multiple values for the object.

●     Add Range...: enables you to add a range.
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●     Edit Comment...enables you to add a comment.

●     Lock: enables you to lock a parameter.
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Analyzing and Resolving Over-Constrained or Inconsistent Sketches  

In evaluating geometry, the system considers the degree of freedom that it has. In two dimensions, points and lines have two degrees of freedom, circles 
have three and ellipses have five degrees of freedom. Fixed geometry will never be moved by the system, and has no degree of freedom.

If all of the degrees of freedom of a geometry have been taken up by a consistent combination of dimensions and fixed geometry, that geometry is said to be 
iso-constrained (also known as well-defined). Geometry that still has some degrees of freedom is said to be under-constrained (also known as under-defined).

Status codes are given through a graphical way (colors) during the Sketch edition. The update error dialog box when returning in 3D explicitly gives them 
(check visualization of diagnosis in Tools > Options > Sketcher > Colors). 

Note that:

●     The system will mark all entities that are relevant to a problem rather than just the first item encountered. So, for instance, in the case of an 
inconsistent triangle with sides 10, 10 and 50, all three dimensions would be marked as INCONSISTENT.

●     The order in which the codes are listed below is significant. The system will test to see whether a geometry should have the status OVER-CONSTRAINED 
before considering whether it should be INCONSISTENT.

This chapter describes the over-constrained and inconsistent status codes calculated by the system and explain methods for solving any underlying 
problems with a Sketch.

You will find the following information:
●     Over-constrained

●     Resolving Over-constrained Cases

●     Inconsistent

●     Resolving Inconsistent Cases

●     Not Changed

●     Parametric Curves

Over-constrained

In many sketches, the user will specify more than the minimum required number of dimensions or constraints. In certain cases the system will ignore 
redundant constraints and solve the Sketch. In other cases it will mark parts of the Sketch as over-constrained.

The descriptions below refer to consistent constraints and dimensions. Dimensions are said to be consistent if their values are satisfied by the position of 
the geometries.

Geometry will be marked as over-constrained when it cannot be solved because there are too many dimensions acting on it for the degrees of freedom available.

A dimension will be marked as over-dimensioned if it conflicts with one or more other dimensions and it is not possible to vary the value of the dimension 
and still find a consistent solution. For example, the geometry and dimensions in the figure below will be over-constrained because the dimension values 
cannot be varied independently, even though they can all be satisfied by appropriate geometry positions. 
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However, the system is able to cope with certain over-constrained situations involving logical constraints. This is important because logical constraints such 
as parallelism are likely to be over-specified when a design is being built up interactively. For example, if two lines are defined to be parallel and then a 
distance is subsequently given between them the parallelism is then specified twice.

The following is a list of some of the over-constrained configurations that can be solved:

●     Multiple constraints between the same geometries. 
For instance, two circles can have several tangent constraints between them.

●     Multiple coincident constraints between geometries of the same type. 
For instance, three points can each be made coincident to the other two.

●     Multiple coincident constraints between lines and points. 
For instance, two lines can be made coincident, and their endpoints can be made coincident with the other line.

Parallel and perpendicular constraints. Any combination of parallel and perpendicular constraints will be reduced to the minimum set required, and any 
excess ones will be ignored. Note that a distance dimension between two lines is treated as a parallel constraint, except that it will never be one of 
the constraints that is ignored.

Symmetric constraints . There are many configurations where symmetric constraints will make other constraints redundant. These are recognized by the 
system. For example, if two lines are made symmetric two of the coincidence constraints between the points and the lines are redundant.

Resolving Over-constrained Cases

Over-constrained entities occur in loops where all of the entities in a loop conflict with each other.

Over-constrained entities can also occur when there are too many fixed geometries.

To resolve over-constrained problems, the user will need to:

●     Set as references dimensions

●     Deactivate or remove constraints

●     Unfix geometry

Note that the system will evaluate as much of the geometry as possible. It determines exactly which dimensions are contributing to the situation.

Inconsistent

This section describes when the inconsistent status codes can occur and how you can modify the Sketch to avoid them.

In general, the inconsistent status shows that the user is attempting to make a change to the Sketch that is too large. In this context, "large" is relative to 
the size of the Sketch.

Parts of a Sketch may become inconsistent as a result of a number of different operations.

The most common of these are as follows:

●     The user changes the value of a dimension. This will normally occur for cases where there would be large changes to one or more geometries.

●     The user adds a dimension or constraint to a Sketch, in order to move geometry.

●     When dragging geometries, the user attempts to input a large transformation.

●     When the geometric type of a use-edge is changed (geometry coming from the projection or intersection of a 3D geometry)

●     When there are use-edge large positions or orientations changes.

●     When an element of a geometry is deleted (especially in conic curves, connecting curves, spline offsets). 
 

The geometry has not been solved because:

●     No solution exists for the current values of dimensions.

●     The system cannot find a solution, even though a solution may exist with the current values of dimensions. This occurs when trying to make large changes 
to under-constrained sketches or to parametric curves (See section Over-constrained and Inconsistent on Parametric Curves below for further details).

●     The system has not find a solution that respects the previous chirality.

Chirality determines the way that geometry is positioned relative to the geometries to which it is dimensioned. A dimensioning scheme can often be satisfied by 
a number of different configurations. The system will always evaluate a new configuration that has the same chirality as the original geometry. It is important 
to realize that geometry in the system always has an original configuration, which is used for deciding the chirality.
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●     If a sketch contains inconsistent geometry, you cannot drag the geometry, nor change it in any way.

●     When a sketch is inconsistent, it may contain unresolved constraints (non-verified geometrical constraints). Make sure all the inconsistencies in the sketch are 
resolved before going any further.

Resolving Inconsistent Cases

If the inconsistent status code was a result of changing a dimension value, the problem will be resolved by changing the dimension back to its old 
value. However, in some cases the user may want to modify other parts of the Sketch to allow the change to be made. The following sections describe 
different ways that can be tried.

When attempting to solve a problem, the user should focus on the geometries and dimensions in the Sketch with the inconsistent status code.

In order to decide how to avoid the status code it is useful to check first if the problem comes from inconsistent dimensions.

An example of this is a triangle with sides of length 50, 50 and 120.

Not Changed

The not changed status is used in the following cases:
●     When geometry becomes over-constrained or inconsistent, the system will not be able to position any other geometries that depend on it. These 

dependent geometries and their associated dimensions (and any others that depend on them) will be marked not changed.

●     Dimensions between two fixed geometry will be given the status code not changed.

●     Dimension between two free or one free and one fixed geometry in the same set will be given the status code not changed.

Parametric Curves

This section is an overview of specific over-constrained and inconsistent problems on parametric curves. The Sketcher can manipulate points, lines, circles 
and ellipses but can also manage splines and nurbs.

These parametric curves can be created:

●     Through an Intersection or Projection of a 3D geometry in the Sketch. After isolating it, constraint can be used to change the position of the curve. The system 
is unable to directly modify the shape because the curve, which have no internal freedoms that the system can control, have only three degrees of freedom.

●     By the Spline command. The curve is defined from other geometries. The parametric curve is said dependent. It is constructed so it passes through a series 
of control points.

Constraints and dimensions can be added between a dependent parametric curve and other geometries in the sketch.

Solving problems will occur:

●     If the position of the defining geometry depends upon the position of the parametric curve, either directly or indirectly.

●     When the other geometry of the constraint or dimension is an other parametric curve or dependent parametric curve.

Always use the Constraint command without dialog box to specify where the constraint must be created on the curve . Through the Constraint Defines 
in Dialog Box command, the selection points are not taken into account.

On fully under-constrained sketches, the system can have difficulty choosing between changing the shape and/or moving its defining geometry especially when 
it supposes to make large changes. Moving the geometry will help the system find a consistent solution in that case. 
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Using SmartPick 

You can work with a higher productivity by using the Smart Pick cursor. 

 

Before you Begin: You should be familiar with important concepts.

SmartPicking a Point: Specify a location either for you to create geometry or for SmartPick to return information via 
symbols.

Creating Geometry Using SmartPick: Position geometry to be created according to existing geometry, if needed, and to 
internal parameters.
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Before You Begin

What is SmartPick ?

SmartPick is a smart and easy-to-use positioning tool that assists you when using most of the commands for creating Sketcher geometrical elements. 
SmartPick will give you higher productivity by decreasing the number of the interactions necessary for positioning these geometrical elements.

According to the various active options (available via Tools>Options>Sketcher ), you can create the geometrical constraints that are equivalent to the 
snapping you performed. SmartPick will return information via symbols. To do this, SmartPick uses the four following sources of information:

3D graphic window and SmartPick cursor:

Sketch tools toolbar (coordinates and parameters):

Contextual menu:

Ctrl or Shift keys.
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Specifying a Location

Using SmartPick, you will easily specify a location:

●     somewhere on the grid

●     using coordinates

●     on a point

●     at the extremity point of a curve

●     at the midpoint of a line

●     at the center of a circle or an ellipse

●     all over a curve

●     at the intersection point of two curves

●     aligned at a vertical/horizontal position

●     on the fictitious perpendicular line through a line end point

●     any of the above cases possibly combined together, whenever possible.

You will progressively specify this location by providing information using as above mentioned the blue cursor, coordinates, the contextual menu and Shift/Ctrl 
keys. Of course, as you will specify your needs, you will shorten the scope of the available possibilities for eventually locating the elements as desired.

Note

If you position the cursor outside the zone that is allowed for creating a given element, the  symbol appears.
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SmartPicking 

This task shows you how to specify the location of given geometry thanks to information that SmartPick returns 
via symbols.  
In other words, SmartPick returns feedback information (highlighted geometry or symbols) which you will or will 
not validate.

You will also learn how to progressively specify your needs using the blue cursor, the Sketch tools toolbar, the 
contextual menu, Shift key or Ctrl key.

Coordinates

When you move the cursor, H and V corresponding coordinates appear on the screen and also in the Sketch 
tools toolbar. Note that the coordinate at the top is H and the coordinate at the bottom is V.

 

SmartPicking Somewhere On the Grid

SmartPick displays the SmartPick blue cursor that can be snapped to the grid according the Snap to Point 

option  from the Sketch tools toolbar. This option is also available in the Sketcher settings (see Snap to 

point option in the Customizing section of this guide).

The SmartPick blue cursor is at the grid intersection point and far from the cursor, Snap to Point option 
activated:
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 The SmartPick blue cursor is close to the cursor, Snap to Point option deactivated:

 

 

SmartPicking Using Coordinates

As you move the cursor and try to assign the desired position to the SmartPick cursor, the Sketch tools toolbar 
similarly displays the corresponding horizontal and vertical coordinates of the SmartPick blue cursor.

You can use the Sketch tools toolbar fields for defining the point coordinates either independently from each 
other or not.

For example, enter H: 2mm. SmartPick is locked on this value. As you move the cursor the V coordinate 
appears in the Sketch tools toolbar. 
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 If you want to reset H or V coordinates you just entered in the Sketch tools toolbar, display the contextual 
menu (right-click background) and select the Reset command.

 

 

SmartPicking Hiding Coordinates

Unselect the Visualization of the cursor coordinates option in the Sketcher settings (see Visualization of the 
cursor coordinates in the Customizing section of this guide).

The cursor coordinates are automatically hidden as you move the cursor within the geometry area.
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SmartPicking On H and V Axes

As you move the cursor and try to assign the desired position to the SmartPick cursor, a horizontal fictitious 
blue dotted line appears when v is equal to zero, a vertical fictitious blue dotted line appears when h is equal to 
zero.
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SmartPicking On a Point

When a point is included in the tolerance zone of SmartPick cursor, SmartPick first snaps to the point and the 
point-to-point coincidence symbol appears.

 

 This symbol means that snapping suppresses both degrees of freedom available for a point.
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SmartPicking At a Curve Extremity Point

When a fictitious curve extremity point is included in the tolerance zone of SmartPick cursor, SmartPick snaps to 
the extremity of this curve.

The point-to-point coincidence symbol appears once the point is picked.

 

Be careful: by default, all the curves are assigned fictitious extremity points. This is why, and as you will 
probably expect, SmartPick detects first point-to-point coincidence with the curve existing end point. Care that 
in this case only the extremity point is highlighted whereas in the previous case the whole line is highlighted.

 

3D Insight Version 5 Release 19 Page 1200 of 1379



 

 You can also use the contextual menu (Nearest End Point option) while going over any curve type element 
with the cursor, and detect  first point-to-point coincidence with the curve existing end point.

 

 

SmartPicking At the Midpoint of a Line

When the midpoint of a line is included in the tolerance zone of SmartPick cursor, SmartPick snaps to the 
midpoint of this line. The point-to-point coincidence symbol appears once the midpoint is picked and the line is 
highlighted.

 

 For this, you can also use the Midpoint command from the contextual menu.
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SmartPicking At the Center of a Circle

When the fictitious center of a circle is included in the tolerance zone of SmartPick cursor, SmartPick snaps at 
the center of this circle. The point-to-point coincidence symbol appears once the circle center is picked and the 
circle is highlighted. For this, you can also use the Concentric command from the contextual menu on the circle.

 

Be careful: by default, circles are created with a center point, . As a result, SmartPick detects first point-to-point 
coincidence. 

 

SmartPicking All Over a Curve

When a curve is included in the tolerance zone of SmartPick cursor, SmartPick automatically snaps to the curve 
which is then highlighted. The curve coincidence symbol appears as you go all over the curve with the cursor. 
This symbol means the point is snapped and that there is still one degree of freedom left, except when two 
curves are detected at the same time.

This is also true in the case of curves that can be extrapolated, (segments, arcs of circles, re-limited splines or 
conic curves). SmartPick will snap to these curves on the condition they are included in the tolerance zone of 
SmartPick cursor.

For this, select the Support lines and circles option (see SmartPick options in the Customizing section of this 
guide).
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Any problem for detecting coincidence? Use the Ctrl key as is:

 
1.  Go over the element to be made coincident. For example, a line.

2.  Press and hold down the Ctrl key. 

SmartPick cursor remains positioned on the picked element.

3.  Move the cursor wherever you want.

 

3D Insight Version 5 Release 19 Page 1203 of 1379



 For more details on the Ctrl key, see Creating Geometry Using SmartPick.

SmartPicking At the Intersection Point of Two Curves

When the intersection point of two curves is included in the tolerance zone of SmartPick cursor, both curve-type 
elements are highlighted. The coincidence symbol appears  and SmartPick cursor snaps to the intersection.

 

 

 

 This type of detection illustrates SmartPick main functionality: combined detection. In fact, when two snapping 
can possibly be performed, SmartPick aims at satisfying both of them by trying to snap them at the same time. 
This smart behavior is a global behavior and is valid for any kind of detection recognized by SmartPick.
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Any problem for detecting intersection? Use the Ctrl key as is:

 
1.  Go over the element to be made coincident. For example, a line. 

The coincidence symbol appears to indicate that SmartPick snaps over the line.

 

 
2.  Press the Ctrl key. 

SmartPick automatically remains snapped whatever the position you assign to the cursor.

 

 
3.  As you press the Ctrl key, go over the second element to be intersected with the element already 

picked using the cursor. 

When SmartPick detects that the second line can possibly be snapped to, SmartPick tries to combine 

both snappings detected thanks to the Ctrl key. In this particular case, SmartPick snaps at the 

intersection of both lines.
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On Fictitious Perpendicular Line Through Line End Point

If the tolerance zone of SmartPick cursor goes over a fictitious perpendicular line that goes through the 
extremity point of a line, SmartPick snaps in order to remain on this fictitious perpendicular line.

Make sure you selected the Alignment option (see SmartPick options in the Customizing section of this guide). 
You will thus automatically detect the different elements along which the sketch is aligned.

 

 

SmartPicking At a Vertical/Horizontal Position

If the tolerance zone of SmartPick cursor crosses a fictitious horizontal line that would go through a point, 
SmartPick snaps in order to remain horizontal to this point.
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In this case, no constraint is created.

 Make sure you selected the Alignment option (see SmartPick options in the Customizing section of this guide). 
You will thus automatically detect the different elements along which the sketch is aligned.
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Creating Geometry Using SmartPick 

Using SmartPick, you will adapt the way you use the Sketcher so as to position geometry to be created according to 
existing geometry, if needed, and to internal parameters. As a result, you will use commands in accordance with the 
type of the element to be created: one command per element.

Unlike CATIA Version 4 (general 2D and 3D creation commands), to create one element, you no longer need to activate 
a group of specific commands (or creation scheme).

From Scratch

You can create geometrical elements by progressively specifying a given number of characteristic points. These 
characteristic points can be specified whatever the active Sketcher command. Characteristic points are pre-determined 
fictitious points managed by SmartPick which allow creating and manipulating geometrical elements whatever the 
complexity of the latter.

You will create some of these characteristic points with total freedom (both horizontal and vertical degrees of freedom 

are available ), and others with partial freedom (only one degree of freedom is available ). 

You will find here below a non-exhaustive list with Sketcher elementary geometrical elements and corresponding 
characteristic points. SmartPick lets you position these points using one of the following: the cursor, the Sketch tools 
toolbar, the contextual menu, Shift or Ctrl key.  

 

A line An arc (center radius) An arc of a circle using three 
points 
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An oriented rectangle A circle A parabola

 

The order in which the above mentioned characteristic points ( 1 , 2 , 3 , 4 ) will be specified cannot be modified. Still, 
you can choose the means to be used for positioning these points, as long as you exclusively take into account: 
●     positioning specifications (SmartPick cursor)

●     external geometry (for example, two lines parallel to each others, or two coincident points)

●     internal geometry characteristics (horizontal/vertical lines, quarter of arc of circles)

●     the externalized parameters of a geometrical element (length, angle, excentricity and so forth)

 

According to Existing Geometry

Reference Geometry

SmartPick finds out geometrical specifications according to geometrical elements that already exist in a sketch.

You will only detect geometrical specifications according to the current sketch elements that are visible in the 3D window 
in which the cursor is positioned. You will not need to perform any interaction and you will be returned a visual feedback 
as shown below in a non exhaustive way:
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parallel (two lines) tangent  
(a line and a circle)

perpendicular 
(two lines)

tangent 
(two circles)

concentric 
(a circle and an arc)

coincident 
(curve through point on line)

Consequently, when detecting a constraint, detection can result ambiguous. To remove this ambiguity, you can try to 
move the viewpoint so that the elements that imply ambiguity would disappear.

 

As you will see when using SmartPick, snapping ambiguities currently occur. Besides, the dimensional specifications of a 
part often depend on technological specifications. These dimensional specifications are defined as the part is being 
designed, they depend on the current application area and are, as a result, very hard to guess for SmartPick tool. In 
order to solve these ambiguities, SmartPick classifies possible snapping according to the geometrical constraints that are 
associated to these snapping. As such, a given cursor positioning will be only assigned one snapping. Unfortunately, this 
classification cannot be modified. It is provided in the table below.
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Constraints Decreasing Priority Order

1.  Point-to-point coincidence
2.  Point-to-extremity point coincidence
3.  Point-to-noticeable point coincidence (for example, the midpoint of a line)
4.  Curve-to-curve tangency
5.  Horizontal or vertical line, or else a quarter of an arc of a circle
6.  Parallelism
7.  Perpendicular curves
8.  Point-to-curve coincidence
9.  Curve-to-curve coincidence or point to curve support coincidence

10.  Point on a perpendicular line through a line end point
11.  Point at a vertical position
12.  Point at a horizontal position

 

Also to remove ambiguity during elements creation, the three options which are parallelism, perpendicular and tangency 
can be activated independently from each other. See SmartPick options in the Customizing section of this guide.

In addition to this classification, when several snapping are possible for a given type of geometrical constraint, 
SmartPick takes into account the distance between the snapped cursor and the geometrical element according to which 
the snapping is possible. In this case, SmartPick snaps to the nearest element. 

Still, there are some cases when SmartPick does not allow dimensioning as desired without additional interactions. This 
is why SmartPick therefore manages two means for applying a particular snapping relatively to the geometrical elements.

Forcing the Snapping

SmartPick allows forcing the snapping on a given geometrical element using either:

●     the contextual menu or 

●     the Ctrl key
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Contextual Menu

SmartPick allows forcing the snapping on a given geometrical element using the contextual menu. You will avoid 
ambiguities linked to the automatic detection of elements in the current 3D viewpoint by forcing: 

●     snapping detected at a distance: parallel, perpendicular, concentric, tangency and curve (line/circle) that goes 
through a point. 
At a distance means that these constraints are detected even though the cursor is not positioned on the reference 
element.

●     snapping at a given position that is relative to a geometrical element: line midpoint, circle center. 
At a given position means that both degrees of freedom are locked.

The contextual menu is therefore available when right-clicking most Sketcher geometrical elements. Of course, the 
contents of the contextual menu depends of the element that is being currently created. This contextual menu can be 
made of the below four sub-parts:

●     Option that belongs to the Base Infrastructure product.

●     Snapping the characteristic point that is being manipulated (see From scratch paragraph and table below).

●     Snapping the geometrical element that is being created (see table below).

●     Managing the parameters that are associated to the geometrical element that is being sketched.

 

 Deactivating Snapping

Any snapping that is imposed via the contextual menu can be de-activated. For this, right-click in the 3D window 
background and select Reset.

The table below lists the constraints that can be detected when snapping characteristic points which are being 
manipulated, relatively to existing geometrical elements, and thanks to the contextual menu.
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Popped-up Geometry Available Snapping

Line Line midpoint 

Circle Circle center 

Ellipse Ellipse center 

Curve Nearest end point 

 The table below indicates the possible snapping for geometrical element which are being created, relatively to existing 
geometry and thanks to the contextual menu.

 

 External 
Geometry       

Element 
currently 
created

 Point Line Circle Ellipse Conic Spline

 Point Midpoint 
Nearest end point

Center 
Nearest end point

Center 
Nearest end point No No

 Line
      

 
          

     

 

     

 

 Ellipse
    

      No No No

 

Example of snapping possibilities

In the example below, you can see the various snapping possibilities for a line that is being created (dotted lines in the 
example) relatively to the existing spline: 3 tangency possibilities and 2 perpendicularity possibilities. The point you 
right-click to display the contextual menu is used to determine which option will be offered in the contextual menu. So 
depending on where you click, you will not be offered the same options.

Note that the software takes into account what has already been specified (in this example, the first point of the line) to 
offer the various snapping options. For this reason, depending on the first point of the geometrical element that is being 
created, there may be cases in which no solution can be found or in which the solution offered does not correspond to 
what you want. In such a case, try to right-click before and/or after the point you want the software to choose. If you 
try both ways, one solution at least should be found.
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Ctrl Key

SmartPick also allows forcing the current snapping on an element using the Ctrl key:

●     You can force SmartPick to remain snapped on an element whatever the position of the cursor. For this, you will 
press the Ctrl key while the geometrical snapping you want to force is active (the element may be highlighted and 
symbols may appear) and keep the Ctrl key pressed.

●     This functionality is efficient if once the Ctrl key is pressed you can still move the cursor. In other words, Ctrl has no 
effect if the current snapping inhibits both degrees of freedom. This is often the case when given snapping 
combinations are possible (for example at the intersection of two lines) or when the cursor is close to a given point 
(explicit or implicit as for example the midpoint of a segment).

●     The Ctrl key is very useful when the sketch includes many geometrical elements because SmartPick takes into 
account the distance between the cursor and the geometrical element.
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This is the zone in which the line-circle tangency snapping (due to the circle proximity) has the first priority.

 

Apart from this zone, either the tangency snapping is meaningless or it interferes with closest geometries or still with 
possible constraints that are assigned higher priorities (see table).

De-activating SmartPick

If SmartPick cannot solve an ambiguity and returns a snapping that you are not satisfied with, you can de-activate 
SmartPick assistant by pressing the Shift key. 

Be careful: it can happen that either the Shift or Ctrl key do not behave as specified in the paragraphs above. In fact, 
sometimes the viewer loses the focus (selection priority). You can then perform a local transformation to recover the 
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focus: use the middle mouse button and manipulate the viewpoint. You will thus recover the focus.

Detecting Internal Geometry Characteristics

Certain geometrical elements are assigned internal peculiar geometrical characteristics. For example and as shown 
below, this is the case for horizontal/vertical lines and for quarters of arcs of circles. When such an internal specification 
is found out by SmartPick, the color of the currently created geometrical element becomes blue.

 

 

 

 

Managing Geometry Parameters

SmartPick also manages internal geometrical specifications such as a line length or a circle radius. Indeed, these 
specifications (further called parameters) decrease available degrees of freedom of a geometry characteristic point 
(refer to previous From Scratch paragraph). All these parameters are accessed through the Sketch tools toolbar which 
gathers all the available parameters that can be valuated for a given geometry creation command. Finally, while the 
SmartPick cursor moves, the Sketch tools toolbar displays the parameters value.
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Listed below is a non exhaustive list of the possible looks of Sketch tools toolbar parameter section:

 

 

Length and Angle to H axis are available 
for Line creation command.

Radius, Start Angle to H Axis or Angular 
sector are available for Arc Circle creation 
command.

Excentricity is available for Hyperbola 
creation command. 

Note that it is always possible to reset a parameter that have been valuated in the Sketch tools toolbar. For this, use 
contextual sub-menu Reset option that is available on 3D viewer background.

 

Relation Between Parameters and Characteristic Points

There exist a strong relation between the characteristic point of a geometrical element and some of  the parameters it 
supports. In fact, if a parameter value is modified by moving the cursor, it means that the parameter is linked to the 
current characteristic point and consequently validating the point will modify the parameter status.

Indeed, as when valuated a characteristic point can no longer be modified, associated parameters get frozen which is 
echoed by a grayed entry in the Sketch tools toolbar.

As an example, in Arc Circle creation command, when the arc start point is defined (at the sketch origin on this picture) 
both Radius and Start Angle to H Axis get frozen. Indeed, as the arc center is necessarily previously defined, to impose 
arc start point leaves no ambiguity on the radius and the start angle of the sector.
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Specific Parameters

Some parameters have a specific behavior. This behavior is common to all geometry creation commands that use these 
parameters. This is the case for Angle and Sector parameters.

Sector Parameter

This parameter is oriented so that no ambiguity is possible when defining an angular sector. In the standard units 
system, an angle range is from -360 to 360deg. Any other value is recomputed to this range. Positive values are for 
direct sectors (you go from the start direction to the end one the same way you go from H axis to V axis). Negative 
values are on the other end for reverse arcs (you go from the start direction to the end one the same way you go from 
V axis to H axis).

 

A direct angular sector A reverse angular sector 
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Note that an angular sector cannot be identically equal to zero. 

 Angle Parameter

 This parameter is also oriented, its range is from 0 to 360 deg. As a consequence, a -10 deg value is identically 
equivalent to a 350 deg value and a 0 deg value is definitely not equal to a 180 deg value.

 

A fixed 30 deg angle value imposed to a line
Note that when this angle is fixed, the cursor position is restricted 
to the half of the sketch plane. Indeed, otherwise a 30 deg angle 

would be equal to a 210 deg one which is excluded.

 By default, angle value are computed relatively to H-Axis. This can be modified any time you want to define an angle 
value using the contextual menu Parameter section 

 

 

When an angle value is available in the Sketch tools toolbar, any line that is contained in the current sketch can be 
defined as the angle computation basis. To issue out orientation, a red arrow is displayed to show the reference line 
orientation. In this example, a 25 deg angle is set relatively to an existing line 
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Copying Parameter Values

It is possible to copy some of parameters value from any existing geometrical element that can be defined with the 
same parameters. The Copy functionality is available through the contextual menu Parameter section for length and 
radius parameters.

Length can be copied from a line while radius from a circle or an arc.
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Deactivating a Sketch  

This task shows you how to deactivate (and then reactivate) a sketch as well as its related features (in order to avoid update errors). You will also learn 
how formulas let you view all activities and their status, as well as activate/deactivate activities. 

You can use the same method to deactivate absolute axes, projections, intersections. 

Open the Pinmounting.CATPart document. 

1.  From the specification tree, right-click Sketch.5 and select Sketch.5 object > Deactivate. 

The selected sketch, and the elements which are impacted by its deactivation, are highlighted in the specification tree and in the geometry area. 

The Deactivate dialog box is displayed.

2.  Make sure that the Deactivate all children option is checked in the dialog box: this ensures that there will be no update error when the sketch is 

deactivated.

3.  Click OK to validate and close the dialog box. 

The selected sketch and the impacted elements are deactivated. Specific icons are displayed in the specification tree for deactivated element to 

indicate that they have been deactivated. 

4.  If you now click the Formula icon  in the Knowledge toolbar to display the Formulas dialog box, you will be able to see that the Activity 

parameter corresponding to the selected item (Sketch.5, in this case) is set to "false" to indicate that this item is deactivated.
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Reactivating a Sketch

To reactivate the sketch, you have two possibilities:

●     In the Formulas dialog box, select the Activity parameter corresponding to the deactivated sketch (PartBody/Sketch.5/Activity), and select "true" 
from the Edit name or value of the current parameter drop-down list.

●     From the specification tree, right-click Sketch.5, and select Sketch.5 object > Activate from the contextual menu. The Activate dialog box is then 
displayed. Make sure the Activate all children is checked if you want to reactivate the related features, and then click OK.  
In some cases, not all elements will be reactivated when you use the second method. In this case, you will be able to reactivate impacted elements 
individually.

 

More about Deactivation
Deactivate contextual menu command mainly acts as a temporary deletion of geometric element. In Sketcher, for its absolute axis feature and all its use-

edge features (projection, intersection etc.), it is not possible to provide a regular temporary deletion behavior. 

If these features are deactivated, its geometry is still available and visible in the geometrical result associated to the sketch feature. Deactivation for these 
feature is applicable only to their associativity. All the other type of geometries contained in a sketch do not support this command.
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Creating Points

  
This task shows the various methods for creating points: 

 ●     coordinates

●     on curve

●     on plane

●     on surface

●     circle/sphere center

●     tangent on curve

●     between

  
 
Open the Points3D1.CATPart document.

 
A new lock button  is available besides the Point type to prevent an automatic change of the type while 

selecting the geometry. Simply click it so that the lock turns red .  

For instance, if you choose the Coordinates type, you are not able to select a curve. If you want to select a curve, 
choose another type in the combo list. The status of this button is stored as the default value: therefore, if it is red 
and you launch the same command again or another command owning this button, the button will be red too. 
This capability is not available in object-action mode and is not retained at edition.

 If the input is selected automatically, when we change the type, the input will not be transferred to the new type. 
For example, if we select On Curve in Point type, and a closed curve is selected as input, an extremum feature is 
created automatically. This extremum feature would not be transferred, if we change point type to coordinates.

 

Coordinates 
 

1.  Click Point .

The Point Definition dialog box appears.

2.  Select the Coordinates point type.
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3.  Enter the X, Y, Z coordinates in the current axis-system.

4.  Optionally, select a Reference Point.

When the command is launched at creation, the initial value in the Axis System field is the current local 
axis system. If no local axis system is current, the field is set to Default.  
Whenever you select a local axis system, the point's coordinates are changed with respect to the selected 
axis system so that the location of the point is not changed. This is not the case with points valuated by 
formulas: if you select an axis system, the defined formula remains unchanged.
 

If you create a point using the coordinates method and an axis system is already defined and set as 
current, the point's coordinates are defined according to current the axis system. 

The current local axis system must be different from the absolute axis.

5.  Click Compass Location. If the compass is lying on the geometry, the X, Y, and Z coordinates of the point 

are modified according to the location of the compass. However, if the compass is not lying on the 

geometry, i.e. it is at default location, clicking this button would display an error message, and the point 

would be created using existing specified coordinates.

The Compass Location button is disabled when any of the X, Y, or Z coordinate is specified using 
a formula.

6.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

 

On curve 
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1.  Click Point .

The Point Definition dialog box appears.

2.  Select the On curve point type.

3.  Select a curve.

4.  Optionally, select a reference point.

If this point is not on the curve, the minimum distance between the point and the curve is 
computed.

 
 
If no point is selected, the curve's extremity is used as reference.
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5.  Select an option point to determine where the new point is to be created: 

�❍     Distance on curve: Point is created at a given distance along the curve from the reference point. A 
distance value needs to be specified.

�❍     Ratio of curve length: Point is created at a given ratio between the reference point and the curve's 
extremity. A ratio value needs to be specified. 

6.  Enter the distance or ratio value.

If a distance is specified, it can be: 
�❍     a Geodesic distance: the distance is measured along the curve.

�❍     an Euclidean distance: the distance is measured in relation to the reference point (absolute value). 
Therefore, Distance on curve and Ratio of curve length are unavailable.

The corresponding point is displayed.

 

 

 

 

 

It is not possible to create a point with an euclidean distance if the distance or the ratio value is 
defined outside the curve.

7.  You can select either Nearest extremity to display the point at the nearest extremity of the curve or 

Middle point to display the mid-point of the curve.

Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not 
closed) when using the Middle Point option.

 

8.  Click Reverse Direction to display either the point on the other side of the reference point (if a point was 

selected originally) or the point from the other extremity (if no point was selected originally).

9.  Select the Repeat object after OK option to create equidistant points on the curve, using the currently 
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created point as the reference, as described in Creating Multiple Points and Planes.

10.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

�❍     If the curve is infinite and no reference point is explicitly given, by default, the reference point is 
the projection of the model's origin

�❍     If the curve is a closed curve, either the system detects a vertex on the curve that can be used 
as a reference point, or it creates an extremum point, and highlights it (you can then select 
another one if you wish) or the system prompts you to manually select a reference point. 
Extremum points created on a closed curve are aggregated under their parent command and put 
in no show in the specification tree.

 

�❍     If the input point is selected automatically and you change the type, it is not retained to the new 
type. For instance, an extremum feature would not be retained if you change its type from On 
curve to Coordinates. 

�❍     If the input for the curve is a feature, and an extremum point exits on this curve, this point is 
used as reference point.

�❍     If the input for the curve is a part of a geometric feature (here an edge), and even though an 
extremum point already exists on this geometric feature, a new extremum is created.

 

On plane 

1.  Click Point .

The Point Definition dialog box appears.

2.  Select the On plane point type.
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3.  Select a plane.

If you select one of the planes of any local axis system as the plane, the origin of this axis system is set as 
the reference point and featurized. If you modify the origin of the axis system, the reference point is 
modified accordingly.

4.  You can select a point to define a reference for computing coordinates in the plane.

If no point is selected, the projection of the model's origin on the plane is taken as reference.

5.  Optionally, select a surface on which the point is projected normally to the plane.

The reference direction (H and V vectors) is computed as follows:  
H and V are computed from the directions belonging to the geometrical plane.
Would the plane move, during an update for example, the reference direction would then be projected on 
the plane. 

6.  Click in the plane to display a point.

7.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

 

On surface 
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1.  Click Point .

The Point Definition dialog box appears.

2.  Select the On surface point type.

3.  Select the surface where the point is to be created.

4.  Optionally, select a reference point. By default, the surface's middle point is taken as reference. 

5.  You can select an element to take its orientation as reference direction or a plane to take its normal as 

reference direction. 

You can also use the contextual menu to specify the X, Y, Z components of the reference direction.

6.  Enter a distance along the reference direction to display a point.

7.  Choose the dynamic positioning of the point:

�❍     Coarse (default behavior): the distance computed between the reference point and the mouse click is 
an euclidean distance. Therefore the created point may not be located at the location of the mouse click 
(see picture below). 
The manipulator (symbolized by a red cross) is continually updated as you move the mouse over the 
surface.
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�❍     Fine: the distance computed between the reference point and the mouse click is a geodesic distance. 
Therefore the created point is located precisely at the location of the mouse click. 
The manipulator is not updated as you move the mouse over the surface, only when you click on the 
surface.

8.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

�❍     The dynamic positioning option is persistent but is not stored in the feature. Therefore at edition, 
the dynamic positioning may not be the one you selected.

 

�❍     Sometimes, the geodesic distance computation fails. In this case, an euclidean distance might be 
used and the created point might not be located at the location of the mouse click. This is the 
case with closed surfaces or surfaces with holes. We advise you to split these surfaces before 
creating the point.

 

Circle / Sphere / Ellipse center 
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1.  Click Point .

The Point Definition dialog box appears: 

2.  Select the Circle / Sphere / Ellipse center point type.

3.  Select a circle, circular arc, ellipse, or elliptical arc, or

4.  Select a sphere or a portion of sphere.

A point is displayed at the center of the selected element.

5.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

 

Tangent on curve 
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1.  Click Point .

The Point Definition dialog box appears.

2.  Select the Tangent on curve point type.

3.  Select a planar curve and a direction line.

The Multi-Result Management dialog box is displayed because several points are generated. Refer to the 
Managing Multi-Result Operations chapter.

4.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

 

Between
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1.  Click Point .

The Point Definition dialog box appears.

2.  Select the Between point type.

3.  Select any two points.

4.  Enter the ratio, that is the percentage of the distance from the first selected point, at which the new point is 

to be.

You can also click Middle Point to create a point at the exact midpoint (ratio = 0.5).
Be careful that the arrow is orientated towards the inside of the curve (providing the curve is not closed) 
when using the Middle Point option. 
If the curve is closed, the point is created along the orientation of the curve.

5.  Select an optional Support. It can be a surface or a curve.

If a support is selected, the point is created between the two points measured along the support.  
If the support is a curve, the distance along the curve is used. If the support is a surface, the created point 
lies on the computed geodesic curve between the two points on the surface.

�❍     If the ratio is less than 0 or greater than 1, the point is created along the extrapolated curve 
tangent to the support. In this case, the created point may not lie on the support.

�❍     For a closed curve, the point is created along the orientation of curve. If you want to create the 
point along another part of the closed curve, the input points should be selected in reverse order.

  

�❍     Points must lie on the support, otherwise an error message is issued.

�❍     In some cases, it may not be possible to create a point on a surface with a hole or a closed 
surface (for instance, if the geodesic curve encounters a hole).

6.  Click Reverse direction to measure the ratio from the second selected point.
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If the ratio value is greater than 1, the point is located on the virtual line beyond the selected points.

7.  Click OK to create the point.

The point (identified as Point.xxx) is added to the specification tree.

 
●     Parameters can be edited in the 3D geometry. For more information, refer to 

Editing Parameters.

●     You can isolate a point in order to cut the links it has with the geometry used to 
create it. To do so, use the Isolate contextual menu. For more information, refer 
to Isolating Geometric Elements.
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Creating Multiple Points and Planes 

 
This task shows you how to create several points and planes at a time.

 
Open the MultiplePoints1.CATPart document. 
Display the Points toolbar by clicking and holding the arrow from the Point icon.

 

1.  Click Point & Planes Repetition  in the Repetitions toolbar.. 

 

The Points & Planes Repetition dialog box appears:

2.  Select the First Point.

3.  Select the Curve.

�❍     If the First Point selected is of type On Curve, the Curve field is automatically updated with 
the underlying curve.

�❍     If only the curve is selected to create multiple points on it, the First Point field is updated with 
Default Extremity.

�❍     If the selected First Point is not of type On Curve (point created using the Datum mode for 
instance), you have to manually select a curve in the Curve field.

�❍     If Clear Selection is selected from the contextual menu for First Point, and the point type is 
On Curve, the default curve selection will also be cleared.

4.  Choose the side on which the points are to be created in relation to the initially selected point. Simply use 

the Reverse Direction button, or click on the arrow in the geometry.
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5.  Select the repetition Parameters: Instances or Instances & spacing.

6.  Define the number of points to be created in the Instance(s) field. Here we chose 5 instances.

When you select a point on a curve, Instances & spacing is available from the Parameters drop-down 
list. In this case, points will be created in the given direction and taking into account the Spacing value. 
For example, 3 instances spaced by 10mm.
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7.  Click Preview to view the point instances.

8.  Select a second point in the Second point field.

This capability lets you define the area of the curve where points should be created.

If the selected point on curve already has a reference point (as described in Creating Points - on 
curve), this reference point is automatically taken as the second point. By default, the Second 
point is one of the endpoints of the curve.

9.  Select the With end points, check box to define the last and first instances are the curve end points.

10.  Select the Create normal planes also check box to automatically generate planes at the point instances.
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11.  Select the Create in a new Body check box to create all object instances in a separate body. Otherwise 

the instances are created in the current body. A new geometrical feature set will be created automatically, 

depending on the type of body the points or planes to be repeated belong to.

In case an Ordered Geometrical Set is created, it is considered as private: it means that you 
cannot perform any modification on its elements (deleting, adding, reordering, etc., is forbidden).
If the option is not checked the instances are created, in the current body.

12.  Click OK to create the point instances, evenly spaced over the curve on the direction indicated by the arrow.

The points (identified as Point.xxx as for any other type of point) are added to the specification tree.

●     Selecting sub-elements of a feature (i.e. edges or faces) or of an axis system (i.e. xy plane) is not allowed.

●     Performing a local Undo is not available with this command.
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Creating Lines

This task shows the various methods for creating lines: 

●     point-point

●     point-direction

●     angle/normal to curve

●     tangent to curve

●     normal to surface

●     bisecting

 It also shows you how to create a line up to an element, define the length type and automatically reselect the second point.
  

 Open the Lines1.CATPart document.

 A new lock button  is available besides the Line type to prevent an automatic change of the type while selecting the geometry. Simply click it so that 

the lock turns red .  

For instance, if you choose the Point-Point type, you are not able to select a line. May you want to select a line, choose another type in the combo list. The 
status of this button is stored as the default value: therefore, if it is red and you launch the same command again or another command owning this 
button, the button will be red too.

 If the input is selected automatically, when we change the type, the input will not be transferred to the new type. For example, if we select Point-Point in 
Line type and Work on support is active, it is selected 
as input for support automatically. This support feature would not be transferred, if we change line type to Point-Direction.

 

Defining the line type

Point-Point 

1.  Click Line .

The Line Definition dialog box is 
displayed. 

2.  Select the Point-Point line type.

3.  Select two points.
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A line is displayed between the two points. 
 

4.  If needed, select a support surface.

In this case a geodesic line is created, i.e. going from one point to the other according to the shortest distance along the surface geometry (blue 
line in the illustration below). 
If no surface is selected, the line is created between the two points based on the shortest distance.

If you select two points on closed surface (a cylinder for example), the result may be unstable. Therefore, it is advised to split the surface 
and only keep the part on which the geodesic line will lie. 

5.  Specify the Start and End points of the new line, that is the line endpoint location in relation to the points initially selected.

These Start and End points are necessarily beyond the selected points, meaning the line cannot be shorter than the distance between the initial 
points.

6.  Check Mirrored extent to create a line symmetrically in relation to the selected Start and End points.

The projections of the 3D point(s) must already exist on the selected support. 

7.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

 

Point - Direction 
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1.  Click Line .

2.  Select the Point-Direction line type.

3.  Select a reference Point and a Direction line.

A vector parallel to the direction line is displayed at the reference 
point.  
Proposed Start and End points of the new line are shown.

4.  If needed, select a support surface. In this case a geodesic line is created, i.e. the direction of the 

created line corresponds to the projection of the given direction onto the support.

5.  Specify the Start and End points of the new line.

The corresponding line is displayed.
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6.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

 

Angle/Normal to curve 

1.  Click Line .

2.  Select the Angle/Normal to curve line type.

3.  Select a reference Curve and a Support surface containing that curve.

�❍     If the selected curve is planar, then the Support is set to Default (Plane).

�❍     If an explicit Support has been defined, a contextual menu is available to clear the selection.
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We advise you to avoid the creation of lines when the direction does not lie on the support, as well as the edition of the angle between 
the direction and the support in such cases.

4.  Select a Point.

5.  Enter an Angle value.

A line is displayed at the given angle with respect to the tangent to the reference curve at the selected point. These elements are displayed in the 
plane tangent to the surface at the selected point.  
You can click on the Normal to Curve button to specify an angle of 90 degrees.  
Proposed Start and End points of the line are shown. 

6.  Specify the Start and End points of the new line.

The corresponding line is displayed.

7.  Check Repeat object after OK if you wish to create more lines with the same definition as the currently created line. 

In this case, the Object Repetition dialog box is displayed, and you key in the number of instances to be created before pressing OK.

As many lines as indicated in the dialog box are created, each separated from the initial line by a multiple of the angle value.

You can check Geometry on Support if you want to create a geodesic line onto a support surface.  
The figure below illustrates this case.
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Geometry on support option not checked
 

Geometry on support option checked

This line type enables to edit the line's parameters. Refer to Editing Parameters to find out more.

8.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

 

Tangent to curve 

1.  Click Line .

2.  Select the Tangent to curve line type.
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3.  Select a reference Curve and a point or another Curve to define the tangency. 

�❍     if a point is selected (mono-tangent mode): a vector tangent to the curve is displayed at the selected point.

�❍     If a second curve is selected (or a point in bi-tangent mode), you need to select a support plane. The line will be tangent to both curves.
■     If an explicit Support has been defined, a contextual menu is available to clear the selection.

When several solutions are possible, you can choose one (displayed in red) directly in the geometry, or using the Next Solution button.

Line tangent to curve at a given point Line tangent to two curves

4.  Specify the Start and End points to define the new line.

5.  Click OK to create the line. 

 
In the image above we select a curve and a point as Element 2.
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The line (identified as Line.xxx) is added to the specification tree.

 
Normal to surface 

1.  Click Line .

2.  Select the Normal to surface line type.

3.  Select a reference Surface and a Point.

A vector normal to the surface is displayed at the reference point.  
Proposed Start and End points of the new line are shown.

If the point does not lie on the support surface, the minimum distance between the point and the surface is computed, and the vector normal to 
the surface is displayed at the resulted reference point.

4.  Specify Start and End points to define the new line.

The corresponding line is displayed.
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5.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

 

Bisecting 

1.  Click Line .

2.  Select the Bisecting line type.

3.  Select two lines. Their bisecting line is the line splitting in two equals parts the angle between these two lines. 

4.  Select a point as the starting point for the line. By default it is the intersection of the bisecting line and the first selected line.

5.  Select the support surface onto which the bisecting line is to be projected, if needed.

6.  Specify the line's length by defining Start and End values (these values are based onto the default start and end points of the line).

The corresponding bisecting line, is displayed.

7.  You can choose between two solutions, using the Next Solution button, or directly clicking the numbered arrows in the geometry.
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8.  Click OK to create the line.

The line (identified as Line.xxx) is added to the specification tree.

 
●     Regardless of the line type, Start and End values are specified by entering distance values or by using the graphic 

manipulators.

●     Start and End values should not be the same.

●     Check the Mirrored extent option to create a line symmetrically in relation to the selected Start point.  
It is only available with the Length Length type.

●     In most cases, you can select a support on which the line is to be created. In this case, the selected point(s) is 
projected onto this support.

●     You can reverse the direction of the line by either clicking the displayed vector or selecting the Reverse Direction 
button (not available with the point-point line type).

●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing Parameters.

●     You can isolate a line in order to cut the links it has with the geometry used to create it. To do so, use the Isolate 
contextual menu. For more information, refer to the Isolating Geometric Elements.

You cannot create a line of which points have a distance lower than the resolution.

 

Creating a line up to an element 
 This capability allows you to create a line up to a point, a curve, or a surface.
 

It is available with all line types, but the Tangent to curve type.

 

Up to a point
 

●     Select a point in the Up-to 1 and/or Up-to 2 fields.
Here is an example with the Bisecting line type, the Length Length type, and a point as Up-to 2 element.
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Up to a curve
 

●     Select a curve in the Up-to 1 and/or Up-to 2 fields.
Here is an example with the Point-Point line type, the Infinite End Length type, and a curve as the Up-to 1 element.

 

Up to a surface
 

●     Select a surface in the Up-to 1 and/or Up-to 2 fields.
Here is an example with the Point-Direction line type, the Length Length type, and the surface as the Up-to 2 element.
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●     If the selected Up-to element does not intersect with the line being created, then an extrapolation is performed. It is only possible if 

the element is linear and lies on the same plane as the line being created. 
However, no extrapolation is performed if the Up-to element is a curve or a surface.

●     The Up-to 1 and Up-to 2 fields are grayed out with the Infinite Length type, the Up-to 1 field is grayed out with the Infinite 
Start Length type, the Up-to 2 field is grayed out with the Infinite End Length type.

●     The Up-to 1 field is grayed out if the Mirrored extent option is checked.

 

Defining the length type
 ●     Select the Length Type: 

�❍     Length: the line will be defined according to the Start and End points values

�❍     Infinite: the line will be infinite

�❍     Infinite Start Point: the line will be infinite from the Start point

�❍     Infinite End Point: the line will be infinite from the End point

 
By default, the Length type is selected.
The Start and/or the End points values will be grayed out when one of the Infinite options is chosen.

 

Reselecting automatically a second point
 

This capability is only available with the Point-Point line method.

1.  Double-click Line .

The Line Definition dialog box is displayed.

2.  Create the first point.

The Reselect Second Point at next start option appears in the Line Definition dialog box.

3.  Check it to be able to later reuse the second point.

4.  Create the second point.

5.  Click OK to create the first line.

The Line Definition dialog box opens again with the first point initialized with the second point of the first line.

6.  Click OK to create the second line.
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To stop the repeat action, simply uncheck the option or click Cancel in the Line Definition dialog box.
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Creating An Axis

This task shows you how to create an axis feature.

 Open the Axis1.CATPart document.

1.  Click Axis .

The Axis Definition dialog box appears.

2.  Select an Element where to create the axis.

This element can be:
�❍     a circle or a portion of circle

�❍     an ellipse or a portion of ellipse

�❍     an oblong curve

�❍     a revolution surface or a portion of revolution surface

 
Circle

3.  Select the direction (here we chose the yz plane), when not normal to the surface.

4.  Select the axis type:

�❍     Aligned with reference direction

�❍     Normal to reference direction

�❍     Normal to circle
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Aligned with reference direction
 

Normal to reference direction
 

Normal to circle

 
Ellipse
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3.  Select the axis type:

�❍     Major axis

�❍     Minor axis

�❍     Normal to ellipse

Major axis
 

Minor axis
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Normal to ellipse

 
Oblong Curve

 

3.  Select the axis type:

�❍     Major axis

�❍     Minor axis

�❍     Normal to oblong

Major axis
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Minor axis
 

Normal to oblong

 
Revolution Surface

 

The revolution surface's axis is used, therefore the axis type combo list is 
disabled.
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5.  Click OK to create the axis.

The element (identified as Axis.xxx) is added to the specification tree.

 

The axis can be displayed in the 3D geometry, either infinite or limited to 
the geometry block of the input element. This option is to be 
parameterized in Tools > Options > Shape > Generative Shape 
Design > General. 
To have further information, refer to the General Settings chapter in the 
Customizing section.
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Creating Polylines

 This task shows how to create a polyline, which is a broken line made of several connected segments. 
These linear segments may be connected by blending radii. 
Polylines may be useful to create cylindrical shapes such as pipes, for example.
 
Open the Spline1.CATPart document.

 

1.  Click Polyline .

The Polyline Definition dialog box appears.

2.  Select several points in a row.

Here we selected Point.1, Point.3, Point.5 and Point.6 in this order.

The resulting polyline would look like this: 

3.  From the dialog box, select Point.3, click Add After and select Point.4.

4.  Select Point.5 and click Remove.
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The resulting polyline now looks like this:

5.  Still from the dialog box select Point.3, click Replace, and select Point.2 in the geometry.

The added point automatically becomes the current point in the dialog 
box. 

6.  Click OK in the dialog box to create the polyline.

The element (identified as Polyline.xxx) is added to the specification tree.

�❍     The polyline's orientation depends on the selection order of the points.

�❍     You can re-order selected points using Replace, Remove, Add, Add After, and Add Before.

�❍     You cannot select twice the same point to create a polyline. However, you can check the  Close 
polyline option to generate a closed contour.
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Creating Planes

 
This task shows the various methods for creating planes:

 

●     offset from plane

●     parallel through point

●     angle/normal to a plane

●     through three points

●     through two lines

●     through point and line

●     through planar curve

●     normal to curve

●     tangent to surface

●     equation

●     mean through points

  

 Open the Planes1.CATPart document.

 A new lock button  is available besides the Plane type to prevent an automatic change of the type while 

selecting the geometry. Simply click it so that the lock turns red .  

For instance, if you choose the Through two lines type, you are not able to select a plane. May you want to select a 
plane, choose another type in the combo list. The status of this button is stored as the default value: therefore, if it 
is red and you launch the same command again or another command owning this button, the button will be red too.

 

Offset from plane
 

1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Offset from plane plane type.

 

Once you have defined the plane, it is represented by a green square symbol, which you can move 
using the graphic manipulator.

3.  Select a reference Plane then enter an Offset value.

A plane is displayed offset from the reference plane.
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4.  Click Reverse Direction to reverse the change the offset direction, or simply click on the arrow in the 

geometry.

5.  Click Repeat object after OK if you wish to create more offset planes.

In this case, the Object Repetition dialog box is displayed, and you key in the number of instances to be 
created before pressing OK.

As many planes as indicated in the dialog box are created (including the one you were currently creating), 
each separated from the initial plane by a multiple of the Offset value. 

6.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 
Parallel through point 
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1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Parallel though point plane type.

3.  Select a reference Plane and a Point. A plane is displayed parallel to the reference plane and passing 

through the selected point.

4.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 
Angle/Normal to plane 
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1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Angle/Normal to plane plane type.

3.  Select a reference Plane and a Rotation axis.

This axis can be any line or an implicit element, such as a cylinder axis for example. To select the latter 
press and hold the Shift key while moving the pointer over the element, then click it.

4.  Enter an Angle value.

The plane is displayed such as its center corresponds to the projection of the center of the reference plane 
on the rotation axis. It is oriented at the specified angle to the reference plane. 

5.  Check Project rotation axis on reference plane if you wish to project the rotation axis onto the 

reference plane. If the reference plane is not parallel to the rotation axis, the created plane is rotated 

around the axis to have the appropriate angle with regard to reference plane.

6.  Check Repeat object after OK if you wish to create more planes at an angle from the initial plane. 

In this case, the Object Repetition dialog box is displayed, and you key in the number of instances to be 
created before pressing OK.
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As many planes as indicated in the dialog box are created (including the one you were currently creating), 
each separated from the initial plane by a multiple of the Angle value.
Here we created five planes at an angle of 20 degrees.

This plane type enables to edit the plane's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.

7.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 

Through three points 

1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Through three points plane type.

3.  Select three points. A plane passing through the three points is displayed. You can move it simply by 

dragging it to the desired location.
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4.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 

Through two lines 

1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Through two lines plane type.

3.  Select two lines.

The plane passing through the two line directions is displayed. 
When these two lines are not coplanar, the vector of the second line is moved to the first line location to 
define the plane's second direction. 
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4.  Check Forbid non coplanar lines to specify that both lines be in the same plane.

5.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 

Through point and line 

1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Through point and line plane type.

3.  Select a Point and a Line. A plane passing through the point and the line is displayed.

4.  Click OK to create the plane.
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The plane (identified as Plane.xxx) is added to the specification tree.

 

Through planar curve 

1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Through planar curve plane type.

3.  Select a planar Curve. A plane containing the curve is displayed.

4.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 
Normal to curve 
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1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Normal to curve plane type.

3.  Select a reference Curve.

4.  You can select a Point. By default, the curve's middle point is selected.

It can be selected outside the curve.

A plane is displayed normal to the curve with its origin at the specified point. The normal is computed at the 
point on the curve that is the nearest to the selected point.

5.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 

Tangent to surface 
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1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Tangent to surface plane type.

3.  Select a reference Surface and a Point. A plane is displayed tangent to the surface at the specified point.

4.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 
Equation 
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1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Equation plane type.

3.  Enter the A, B, C, D components of the Ax + By + Cz = D plane equation.

4.  Select a point to position the plane through this point, you are able to modify A, B, and C components, the 

D component becomes grayed.

When the command is launched at creation, the initial value in the Axis System field is the current local 
axis system. If no local axis system is current, the field is set to Default.  
Whenever you select a local axis system, A, B, C, and D values are changed with respect to the selected 
axis system so that the location of the plane is not changed. This is not the case with values valuated by 
formulas: if you select an axis system, the defined formula remains unchanged.

5.  Click Normal to compass to position the plane perpendicular to the compass direction.

6.  Click Parallel to screen to position the plane parallel to the screen current view.
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7.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 

Mean through points 

1.  Click Plane .

The Plane Definition dialog box appears.

2.  Select the Mean through points plane type.

3.  Select three or more points to display the mean plane through these points.
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It is possible to edit the plane by first selecting a point in the dialog box list then choosing an option to 
either:

�❍     Remove the selected point

�❍     Replace the selected point by another point.

4.  Click OK to create the plane.

The plane (identified as Plane.xxx) is added to the specification tree.

 
●     Parameters can be edited in the 3D geometry. For more information, refer to the Editing 

Parameters.

●     You can isolate a plane in order to cut the links it has with the geometry used to create it. To 
do so, use the Isolate contextual menu. For more information, refer to the Isolating 
Geometric Elements.
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Creating Planes Between Other Planes

 
This task shows how to create any number of planes between two existing planes, in only one operation.

 Open the Planes1.CATPart document.

 

1.  Click Planes Between .

The Planes Between dialog box appears:

2.  Select the two planes between which the new planes must be created.

3.  Specify the number of planes to be created between the two selected planes.

4.  Click Preview to view the multiple planes created.

5.  Click OK to create the planes.

The planes (identified as Plane.xxx) are added to the specification tree.

Check Create in a new Body to create a new geometrical set containing only the repeated planes.

●     Selecting of a feature (i.e. edges or faces) or of an axis system (i.e. xy plane) is not allowed.

●     Performing a local Undo is not available with this command.
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Creating Circles

This task shows the various methods for creating circles and circular arcs: 

 ●     center and radius

●     center and point

●     two points and radius

●     three points

●     center and axis

●     bitangent and radius

●     bitangent and point

●     tritangent

●     center and tangent

 It also shows you how to define the circle radius or diameter and create axes.
  

 Open the Circles1.CATPart document. 
Note that you need to put the desired geometrical set in current to be able to perform the corresponding scenario. 

 A new lock button  is available besides the Circle type to prevent an automatic change of the type while 

selecting the geometry. Simply click it so that the lock turns red .  

For instance, if you choose the Center and radius type, you are not able to select an axis. If  you want to select an 
axis, choose another type in the combo list. 
The status of this button is stored as the default value: therefore, if it is red and you launch the same command 
again or another command owning this button, the button will be red too.

 
If the input is selected automatically, when we change the type, the input will not be transferred to the new type. 
For example, if we select Center and radius in Circle type and Work on support is active, it is selected as input for 
support automatically. This support feature would not be transferred, if we change circle type to Center and point.

 
Defining the plane type

 
Center and radius 

1.  Click Circle .

The Circle Definition dialog box 
appears. 

2.  Select the Center and radius circle type.
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3.  Select a point as circle Center.

4.  Select the Support plane or surface where the circle is to be created.

5.  Enter a Radius value.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. 
For a circular arc, you can specify the Start and End angles of the arc.

If a support surface is selected, the circle lies on the plane tangent to the surface at the selected 
point.
Start and End angles can be specified by entering values or by using the graphic manipulators.

6.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.
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Center and point 

1.  Click Circle .

The Circle Definition dialog box 
appears. 

2.  Select the Center and point circle type.

3.  Select a point as Center.

4.  Select a Point where the circle is to be created.

5.  Select the Support plane or surface where the circle is to be created.

The circle, which center is the first selected point and passing through the second point or the projection of 
this second point on the plane tangent to the surface at the first point, is previewed.  
Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. 
For a circular arc, you can specify the Start and End angles of the arc.

6.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.
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Two points and radius   

1.  Click Circle .

The Circle Definition dialog box 
appears. 

2.  Select the Two points and radius circle type.

3.  Select two points on a surface or in the same plane.

4.  Select the Support plane or surface.

You can select a direction as the support. The support is calculated using this direction and the two 
input points. The plane passing through the two points and whose normal is closest to the given 
direction is computed as follows:

�❍     Let's take V1 as the vector P1P2, where P1 and P2 are the input points.

�❍     Let's take V2 as the user direction (which can be the compass direction).

�❍     Compute V3 = V1 X V2 (cross product).

�❍     Compute V4 = V3 X V1 (cross product).

�❍     The support plane is normal to V4 and passing through P1 and P2.

�❍     Note that if V2 is orthogonal to V1, V4 = V2 and the support plane is normal to V2 
(user direction).

5.  Enter a Radius value.
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The circle, passing through the first selected point and the second point or the projection of this second 
point on the plane tangent to the surface at the first point, is previewed.  
Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed.  
For a circular arc, you can specify the trimmed or complementary arc using the two selected points as end 
points. 
You can use the Next Solution button, to display the alternative arc.

With a plane as Support With a direction as Support (the computed plane is shown in 
blue)

6.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.

 
Three points 

1.  Click Circle .

The Circle Definition dialog box 
appears. 

2.  Select the Three points circle type.
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3.  Select three points where the circle is to be created.

Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed.  
For a circular arc, you can specify the trimmed or complementary arc using the two of the selected points 
as end points.

4.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.

 
Center and axis  
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1.  Click Circle .

The Circle Definition dialog box 
appears. 

2.  Select the Center and axis circle type.

3.  Select the axis/line.

It can be any linear curve.

4.  Select a point.

5.  Enter a Radius value.

6.  Set the Project point on axis/line option:

�❍     checked (with projection): the circle is centered on the reference point and projected onto the input axis/
line and lies in the plane normal to the axis/line passing through the reference point. The line will be 
extended to get the projection if required.

�❍     unchecked (without projection): the circle is centered on the reference point and lies in the plane 
normal to the axis/line passing through the reference point.

With projection Without projection

7.  Click OK to create the circle or circular arc.
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The circle (identified as Circle.xxx) is added to the specification tree.

 
Bitangent and radius 

1.  Click Circle .

The Circle Definition dialog box appears.

2.  Select the Bitangent and radius circle type.

3.  Select two Elements (point or curve) to which the circle is to be tangent.

4.  Select a Support surface.

If one of the selected inputs is a planar curve, then the Support is set to Default (Plane). 
If an explicit Support needs to be defined, a contextual menu is available to clear the selection in 
order to select the desired support. 
This automatic support definition saves you from performing useless selections.

5.  Enter a Radius value.

Several solutions may be possible, so click in the region where you want the circle to be. 
Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed.  
For a circular arc, you can specify the trimmed or complementary arc using the two tangent points as end 
points. 
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You can check the Trim Element 1 and Trim Element 2 options to trim the first element or the second 
element, or both elements. 
Here is an example with Element 1 trimmed.

The Trim Element 1 and Trim Element 2 options are only available with the Trimmed circle 
limitation.

6.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.

 
Bitangent and point 
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1.  Click Circle .

The Circle Definition dialog box appears.

2.  Select the Bitangent and point circle type.

3.  Select a point or a curve to which the circle is to be tangent.

4.  Select a Curve and a Point on this curve.

The point will be projected onto the curve.

5.  Select a Support plane or planar surface.

If one of the selected inputs is a planar curve, then the Support is set to Default (Plane). 
If an explicit Support needs to be defined, a contextual menu is available to clear the selection in 
order to select the desired support. 
This automatic support definition saves you from performing useless selections.

Several solutions may be possible, so click in the region where you want the circle to be. 
Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. 
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Complete circle
 

Trimmed circle
 

Complementary trimmed circle
You can check Trim Element 1 and Trim Element 2 to trim the first element or the second element, or 
both elements. 
Here is an example with both elements trimmed.
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Trim Element 1 and Trim Element 2 are only available with the Trimmed circle limitation.

6.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.

 
Tritangent 

1.  Click Circle .

The Circle Definition dialog box appears.

2.  Select the Tritangent circle type.

3.  Select three Elements to which the circle is to be tangent.

4.  Select a Support planar surface.
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If one of the selected inputs is a planar curve, then the Support is set to Default (Plane). 
If an explicit Support needs to be defined, a contextual menu is available to clear the selection in 
order to select the desired support. 
This automatic support definition saves you from performing useless selections.

Several solutions may be possible, so select the arc of circle that you wish to create. 
Depending on the active Circle Limitations icon, the corresponding circle or circular arc is displayed. The 
first and third elements define where the relimitation ends.  
For a circular arc, you can specify the trimmed or complementary arc using the two tangent points as end 
points.

You can check Trim Element 1 and Trim Element 3 to trim the first element or the third element, or both 
elements. 
Here is an example with Element 3 trimmed.

�❍     Trim Element 1 and Trim Element 3 are only available with the Trimmed circle limitation.

�❍     You cannot create a tritangent circle if an input point lies on an input wire. We advise you to use 
the bi-tangent and point circle type.

5.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.

 
Center and tangent 

3D Insight Version 5 Release 19 Page 1286 of 1379



1.  Click Circle .

The Circle Definition dialog box appears.

2.  Select the Center and tangent circle type.

The circle center will be located either on the center curve or point and will be tangent to the tangent curve. 
There are two ways to create a center and tangent circle:
Center curve and radius:

a.  Select a curve as the Center Element.

b.  Select a Tangent Curve.

c.  Enter a Radius value.
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Line tangent to curve definition:

a.  Select a point as the Center Element.

b.  Select a Tangent Curve.

�❍     If one of the selected inputs is a planar curve, then the Support is set to Default (Plane). 
If an explicit Support needs to be defined, a contextual menu is available to clear the selection 
in order to select the desired support. 
This automatic support definition saves you from performing useless selections.

�❍     Note that only full circles can be created.

3.  Click OK to create the circle or circular arc.

The circle (identified as Circle.xxx) is added to the specification tree.

 

Using the Diameter/Radius options
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 You can click the Radius button to switch to a Diameter value. Conversely, click the Diameter button to switch back 
to the Radius value.  
This option is available with the Center and radius, Two point and radius, Bi-tangent and radius, Center and 
tangent, and Center and axis circle types. 
Note that the value does not change when switching from Radius to Diameter and vice-versa.

 

Using the Axis Computation option
 

●     You can select the Axis computation check box to automatically create axes while creating or modifying a 

circle. Once the option is checked, the Axis direction field is enabled. 

�❍     If you do not select a direction, an axis normal to the circle will be created.

�❍     If you select a direction, two more axes features will be created: an axis aligned with the reference direction 

and an axis normal to the reference direction.

In the specification tree, the axes are aggregated under the Circle feature. You can edit their directions but 

cannot modify them. 

If the datum mode is active, the axes are not aggregated under the Circle features, but one ore three datum 

lines are created.

Axis normal to the circle
 

Axis aligned with the reference direction (yz plane)
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Axis normal to the reference direction (yz plane)

  

 

●     If you check Geometry on Support and the selected support is not planar, then the Axis 

Computation is not possible.

●     You can check Geometry on Support if you want the circle to be projected onto a support 

surface. 

In this case just select a support surface. 

This option is available with the Center and radius, Center and point, Two point and 

radius, and Three points circle types.

●     When several solutions are possible, click Next Solution to move to another arc of circle, or 

directly select the arc you want in the 3D geometry.

●     A circle may have several points as center if the selected element is made of various circle 

arcs with different centers.

●     Parameters can be edited in the 3D geometry. For more information, refer to Editing 
Parameters.

●     You can isolate a circle in order to cut the links it has with the geometry used to create it. To 
do so, use the Isolate contextual command. For more information, refer to Isolating 
Geometric Elements.
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Creating Projections

 This task shows you how to create geometry by projecting one or more elements onto a support. The projection may be 
normal or along a direction. 
You can project: 

●     a point onto a surface or wireframe support

●     wireframe geometry onto a surface support

●     any combination of points and wireframe onto a surface support.

Generally speaking, the projection operation has a derivative effect, meaning that there may be a continuity loss when 
projecting an element onto another. If the initial element presents a curvature continuity, the resulting projected element 
presents at least a tangency continuity. If the initial element presents a tangency continuity, the resulting projected 
element presents at least a point continuity.

Open the Projection1.CATPart document.

1.  Click Projection .

The Projection Definition dialog box appears as well as the Tools Palette. 
For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA Infrastructure 
User's Guide.

2.  Select the element to be Projected.

You can select several elements to be projected.  In this case, the Projected field indicates: x elements.
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3.  Select the Support element. 

4.  Use the combo to specify the direction type for  the projection:

�❍     Normal: the projection is done normal to the support element.

�❍     Along a direction: you need to select a line to take its orientation as the translation direction or a plane to 
take its normal as the translation direction.
You can also specify the direction by means of X, Y, Z vector components by using the contextual menu on the 
Direction field.
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5.  Whenever several projections are possible, the nearest projection can be kept by checking Nearest Solution. 

 
If this option is not checked, the Multi-Result Management dialog box opens to let you choose the solution. 

Check Keep all the sub-elements to have a complete solution.

If the elements have the same distance to the support, an error message is issued. This distance 
corresponds to the maximum distance between a point on the projected element and its projection onto the 
support. 
 

6.  Click OK to create the projection element.

The projection (identified as Project.xxx) is added to the specification 
tree. 

 
Smoothing Parameters

 You can smooth the element to be projected by checking either:  

●     None: deactivates the smoothing result
With support surface: the smoothing is performed according to the support. As a consequence, the resulting smoothed 
curve inherits support discontinuities.

●     Tangency: enhances the current continuity to tangent continuity

●     Curvature: enhances the current continuity to curvature continuity

●     You can specify the maximum deviation for G1 or G2 smoothing by entering a value or using the spinners. 

If the element cannot be smoothed correctly, a warning message is issued.

Moreover, a topology simplification is automatically performed for G2 vertices: cells with a curvature continuity are 

merged.
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Only small discontinuities are smoothed in order to keep the curve's sharp vertices.

 Without support surface:

●     3D Smoothing: the smoothing is performed without specifying any support surface. As a consequence, the resulting 

smoothed curve has a better continuity quality and is not exactly laid down on the surface. 

As a consequence, you may need to activate the Tolerant laydown option. Refer to the Customizing General Settings 

chapter. 

This option is available if you previously select the Tangency or Curvature smoothing type.

With 3D smoothing option checked With 3D smoothing option unchecked

 

The following capabilities are available: Stacking Commands and Selecting Using Multi-Output.
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Creating Intersections

This task shows you how to create wireframe geometry by intersecting elements.

You can intersect:

●     wireframe elements

●     solid elements

●     surfaces

Open the Intersection1.CATPart document.

 

1.  Click Intersection .

The Intersection Definition dialog box appears as well as the Tools Palette. 

For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA 

Infrastructure User's Guide.

2.  Select the two elements to be intersected.

The intersection is displayed.
Multi-selection is available on the first and second selection, meaning that you can select several 
elements to be intersected as well as several intersecting elements. For instance you can select a 
whole geometrical set.

3.  Choose the type of intersection to be displayed.

3D Insight Version 5 Release 19 Page 1295 of 1379

file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/Intersection1.CATPart


�❍     a Curve (when intersecting two curves):

 

�❍     Points (when intersecting two curves):

 

�❍     a Contour: when intersecting a solid element with a surface :

 

�❍     a Face: when intersecting a solid element with a surface (we increased the transparency degree on the 
pad and surface):
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4.  Click OK to create the intersection element.

This element (identified as Intersect.xxx) is added to the specification tree. 

 

The above example shows the line resulting 
from the intersection of a plane and a surface  The above example shows the curve resulting 

from the intersection of two surfaces

Additional Parameters

Several options can be defined to improve the preciseness of the intersection.

Open the Intersection2.CATPart document.
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●     Extend linear supports for intersection enables to extend the first, second or both elements. This option is 

especially useful if you work within an ordered geometrical set environment. In some confusing cases (for 
instance shallow angles), this option may give a more accurate result as it takes into account the geometry 
rather than the topology.
Both options are unchecked by default.
Here is an example with the option checked for both elements.

 

 ●     Extrapolate intersection on first element enables to perform an extrapolation on the first selected element, 
in the case of a surface-surface intersection. In all the other cases, the option will be grayed.

 

Intersection with the Extrapolation option unchecked Intersection with the Extrapolation option checked
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 ●     Intersect non coplanar line segments enables to perform an intersection on two non-intersecting lines. 
When selecting this option, both Extend linear supports for intersection options are selecting too.

 

Intersection between the light green line and the blue 
line: the intersection point is calculated after the blue 
line is extrapolated

 
Intersection between the pink line and the blue line: 
the intersection is calculated as the mid-point of 
minimum distance between the two lines

 
The following capabilities are available: Stacking Commands and Selecting Using Multi-Output.

●     If you select a body or a hybrid body containing both solid and wireframe elements as input, 
only the solid elements are taken into account to compute the intersection.

●     Avoid using input elements which are tangent to each other since this may result in geometric 
instabilities in the tangency zone.

●     If the intersection stops at an edge and providing the edge can be merged with the 
intersecting element (if the distance is less than 0.1mm), then it is projected onto the 
intersecting element. The projection is integrated to the intersection result.

 

3D Insight Version 5 Release 19 Page 1299 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyug_C2/cfyugstackingcommands.htm
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/cfyug_C2/cfyugmultioutput.htm


Creating Splines

 
This task shows the various methods for creating spline curves.

 Open the Spline1.CATPart document.

1.  Click Spline . 

The Spline Definition dialog box 
appears. 

2.  Select two or more points where the spline is to pass.

An updated spline is visualized each time a point is selected. 

3.  It is possible to edit the spline by first selecting a point in the dialog box list then choosing a button to either: 

�❍     Add a point after the selected point

�❍     Add a point before the selected point

�❍     Remove the selected point

�❍     Replace the selected point by another point.

4.  You can select  the Geometry on support check box, and select a support (plane, surface),  if you want the spline 

to be projected onto a support surface.

It is better when the tangent directions belong to the support, that is when a projection is possible.

In this case just select a surface or plane. Here, the spline was created on a planar grid.
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5.  Use the Close Spline option to create a closed curve, provided the geometric configuration allows it.

 

Spline with Close Spline option unchecked  Spline with Close Spline option checked

6.  Click Show Parameters to display further options. 

7.  To set tangency conditions onto any point of the spline, select the point and click in Tangent Dir. field.
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There are two ways of imposing tangency and curvature constraints:
1.  Explicit: select a line or plane to which the tangent on the spline is parallel at the selected point

2.  From curve: select a curve to which the spline is tangent at the selected point.
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Use the Remove Tgt., Reverse Tgt., or Remove Cur. to manage the different imposed tangency and curvature 
constraints.

Spline with a tangency constraint on endpoint (tension = 2)
 

Spline with reversed tangent
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8.  To specify a curvature constraint at any point of the spline, once a tangency constraint has been set, indicate a 

curvature direction and enter a radius value:

The curvature direction is projected onto a plane normal to the tangent direction.
If you use the Create line contextual menu, and want to select the same point as a point already used to 
define the tangent direction, you may have to select it from the specification tree, or use the pre-selection 
navigator.

Spline with tangency constraint
 

Spline with tangency constraint and curvature constraint (radius = 50mm)
 

Spline with tangency constraint and curvature constraint (radius = 2mm)
 
Note that for the Points Specifications, you must enter your information in the following order:

�❍     Tangent Dir. (tangent direction)

�❍     Tangent Tension

�❍     Curvature Dir. (curvature direction)

�❍     Curvature Radius (to select it, just click in the field).

The fields become active as you select values.

9.  Click OK to create the spline. 

The spline (identified as Spline.xxx) is added to the specification tree.
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To add a parameter to a point, select a line in the Points list. This list is highlighted. 
You have two possibilities:

�❍     extended parameters

�❍     select any line or plane for the direction.
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Creating Extruded Surfaces

 
This task shows how to create a surface by extruding a profile along a given direction.

 
Open the Extrude1.CATPart document.

1.  Click Extrude .

The Extruded Surface Definition dialog box appears.

2.  Select the Profile to be extruded (Sketch.1).

3.  Specify the desired extrusion Direction (xy plane).

�❍     You can select a line to take its orientation as the extrusion direction or a plane to take its 

normal as extrusion direction.

�❍     You can also specify the direction by means of X, Y, Z vector components by using the 

contextual menu on the Direction field.

4.  Define the Extrusion Limits for Limit 1 and Limit 2.

�❍     Dimension: enter length values or use the graphic manipulators to define the start and end limits of 

the extrusion. 

Here we defined a length of 30mm for Limit 1 and 80mm for Limit 2.
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Up-to element: select a geometric element. It can be a point, a plane or a surface (wires are not allowed). 
If a point is specified, the up-to element is the plane normal to the extrusion direction passing through the 
given point.
Here we selected Point.1 as Limit 1 and Plane.1 as Limit 2.

You can also select different extrusion limits, for instance a Dimension for Limit 1 and an Up-to element for 
Limit 2:
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�❍     The Up-to element can intersect the profile and the surface to be extruded. In the later case, it 
must completely cut the surface and there should not be any partial intersections of the up-to 
element with the surface.

�❍     If you select two up-to elements, they must not cut each other within the surface to be extruded.

5.  You can click Reverse Direction or the red arrow in the 3D geometry to display the extrusion on the other 

side of the selected profile.

6.  Click OK to create the surface.

The surface (identified as Extrude.xxx) is added to the specification tree.

Parameters can be edited in the 3D geometry. For further information, refer to Editing Parameters.
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Creating Revolution Surfaces

 
This task shows how to create a surface by revolving a planar profile about an axis.

 
Open the Revolution1.CATPart document.

 

 

1.  Click Revolve .

The Revolution Surface Definition dialog box 
appears. 

2.  Select the Profile and a line indicating the desired Revolution axis.

3.  Enter angle values or use the graphic manipulators to define the angular limits of the revolution surface.

3D Insight Version 5 Release 19 Page 1309 of 1379

file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfysm_C2/samples/Revolution1.CATPart


4.  Click OK to create the surface.

The surface (identified as Revolute.xxx) is added to the specification tree. 

�❍     There must be no intersection between the axis and the profile. However, if the result is 
topologically consistent, the surface will still be created.

�❍     If the profile is a sketch containing an axis, the latter is selected by default as the revolution 
axis. You can select another revolution axis simply by selecting a new line.

�❍     Parameters can be edited in the 3D geometry. To have further information, refer to the Editing 
Parameters chapter.
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Creating Spherical Surfaces

 This task shows how to create surfaces in the shape of a sphere. 
The spherical surface is based on a center point, an axis-system defining the meridian & parallel curves orientation, 
and angular limits.
 
Open the Sphere1.CATPart document.

 

1.  Click Sphere  from the Extrude-Revolution sub-toolbar.

The Sphere Surface Definition dialog box is displayed. 

2.  Select the center point of the sphere.

3.  Select an axis-system.

This axis-system determines the orientation of the meridian and parallel curves, and therefore of the 
sphere. 
By default, if no axis-system has been previously created in the document, the axis-system is the absolute 
axis-system. Otherwise the default axis-system is the current one.

4.  Click Preview to preview the surface.
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5.  Modify the Sphere radius and the Sphere Limitations as required. 

Here we choose -90° and 90° for the parallel curves, and 0 and 240° for the meridian curves, and left the 
radius at 20 mm.

 

�❍     Parallel angular limits are comprised within the -90° and 90° range.

�❍     Meridian angular limits are comprised within the -360° and 360° range.

6.  Click OK to create the spherical surface.

The spherical surface (identified as Sphere.xxx) is added to the specification tree.

You can also choose to create a whole sphere. In this case, simply click  from the dialog box to 

generate a complete sphere, based on the center point and the radius. The parallel and meridian 
angular values are then grayed.
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Parameters can be edited in the 3D geometry. To have further information, refer to the Editing 
Parameters chapter.
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Creating Cylindrical Surfaces

 
This task shows how to create a cylinder by extruding a circle along a given direction.

 Open the Cylinder1.CATPart document.

 

1.  Click Cylinder .

The Cylinder Surface Definition dialog box 
appears. 

2.  Select the Point that gives the center of the circle to be extruded and specify the desired Direction of the 

cylinder axis.

You can select a line to take its orientation as the direction or a plane to take its normal as direction. 

You can also specify the direction by means of X, Y, Z vector components by using the contextual menu on 

the Direction area.

3.  Select the Radius of the cylinder.

4.  Enter values or use the graphic manipulators to define the start and end limits of the extrusion.
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5.  Click Reverse Direction or the red arrow in the 3D geometry to display the direction of the cylinder on the 

other side of the selected point.

6.  Click OK to create the surface.

The surface (identified as Cylinder.xxx) is added to the specification tree.

 

 

3D Insight Version 5 Release 19 Page 1315 of 1379



Creating Offset Surfaces

This task shows how to create a surface by offsetting an existing surface.

Open the Offset1.CATPart document.

 

1.  Click Offset .

The Offset Surface Definition dialog box appears.

2.  Select the Surface to be offset. 

3.  Specify the Offset by entering a value or using the graphic manipulator.

4.  An arrow indicates the proposed direction for the offset.

The offset surface is displayed normal to the reference surface. 

5.  Click Preview to preview the offset surface.

The offset surface is displayed normal to the reference surface.
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Depending on the geometry configuration and the offset value, an offset may not be allowed as it 
would result in a debased geometry. In this case, you need to decrease the offset value or modify 
the initial geometry.

6.  You can display the offset surface on the other side of the reference surface by clicking either the arrow or 

the Reverse Direction button. 

7.  Check Both sides to generate two offset surfaces, one on each side of the reference surface.

8.  Check Repeat object after OK to create several offset surfaces, each separated from the initial surface by 

a multiple of the offset value. 

Simply indicate in the Object Repetition dialog box the number of instances that should be created and click 

OK. 

Remember however, that when repeating the offset it may not be allowed to create all the offset surfaces, 

if it leads to debased geometry.
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9.  Click OK to create the surfaces.

The surfaces (identified as Offset.xxx) are added to the specification tree. 
Would the value be inconsistent with the selected geometry, a warning message is displayed, along 
with a warning sign onto the geometry. If you move the pointer over this sign, a longer message is 
displayed to help you continue with the operation.

Furthermore, the manipulator is locked, and you need to modify the value within the dialog box and 
click Apply.

 

Parameters can be edited in the 3D geometry. To have further information, refer to the Editing 
Parameters.
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Creating Filling Surfaces

 
This task shows how to create fill surfaces between a number of boundary segments.

Open the Fill1.CATPart document.

 

1.  Click Fill .

The Fill Surface Definition dialog box appears.

2.  Select curves or surface edges to form a closed boundary.

You can select a support surface for each curve or edge. In this case continuity will be assured between the 
fill surface and selected support surfaces.

3.  Use the combo to specify the desired continuity type between any selected support surfaces and the fill 

surface: Point, Tangent, or Curvature.

The fill surface is displayed within the boundary. 

3D Insight Version 5 Release 19 Page 1319 of 1379

http://canezoudsy/AwsR20/AwsDocR20/Doc/online/wfsug_C2/samples/Fill1.CATPart


4.  You can edit the boundary by first selecting an element in the dialog box list then choosing a button to 

either:

�❍     Add a new element after or before the selected one

�❍     Remove the selected element

�❍     Replace the selected element by another curve

�❍     Replace the selected support element by another support surface

�❍     Remove the selected support element.

5.  Select the Deviation check box, and enter a value to fill the gaps present.

In the Tools > Options > Shape > Generative Shape Design > General tab,
�❍     If the Continuity Type is either Tangency or Curvature, the Deviation check box is selected 

by default.

�❍     The Maximum deviation value is taken as the deviation value for the fill.

�❍     If the gap between the two contours is greater than the maximum deviation, the gap is not 
filled, and the resulting surface still displays a gap.

6.  Click OK to create the fill surface.

The surface (identified as Fill.xxx) is added to the specification tree.
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Filling surface with specified supports

●     The selected curves or surfaces edges can intersect. Therefore a relimitation of the intersecting boundaries is 
performed to allow the creation of the fill surface. 

 Two consecutive boundaries must have only one intersection.
 ●     The selected curves or surface edges can have non-coincident boundaries. Therefore, an extrapolation is 

performed to allow the creation of the fill surface. 
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 The distance between non-coincident boundaries must be smaller than 0.1mm.
 ●     A two-side fill surface cannot be created in the following ambiguous cases:

�❍     one intersection and two distances below 0.1 mm

 

�❍     no true intersection (therefore there may be several distances below 0.1 mm)
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Creating Boundaries

 
This task shows how to create the boundary curve of a surface or the boundary point of a curve.

Open the Boundaries1.CATPart document.

1.  Click Boundary .

The Boundary Definition dialog box appears. 

2.  Use the combo to choose the Propagation type:

�❍     Complete boundary: the selected edge is propagated around the entire surface boundary.

�❍     Point continuity: the selected edge is propagated around the surface boundary until a point discontinuity is met.

�❍     Tangent continuity: the selected edge is propagated around the surface boundary until a tangent discontinuity is met.

�❍     No propagation: no propagation or continuity condition is imposed, only the selected edge is kept.

 

You can select the propagation type before selecting an edge.

3.  Select a Surface edge.

The boundary curve is displayed according to the selected propagation type.

No propagation Tangent continuity
  

Point continuity Complete boundary

4.  You can relimit the boundary curve by means of two elements.

If you relimit a closed curve by means of only one element, a point on curve for instance, the closure vertex will be 
moved to the relimitation point, allowing this point to be used by other features.
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5.  Click OK to create the boundary curve.

The curve (identified as Boundary.xxx) is added to the specification tree.

You cannot copy/paste a boundary from a document to another. If you wish to do so, you need to copy/paste the surface 
first into the second document then create the boundary.

About the Propagation Type
�❍     If you select the surface directly, the Propagation type no longer is available, as the complete boundary is automatically 

generated. 

Provided the generated boundary curve is continuous, you can still select a limiting point to limit the boundary. 

Using the red arrow, you can then invert the propagation of the limited boundary. 

�❍     If you select a curve which has an open contour, the Propagation type becomes available: choose the No Propagation type 
and select the curve again. The extremum points will define the boundary result.
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Extracting Geometry

 This task shows how to perform an extract from elements (curves, points, surfaces, solids, volumes and so forth). 

This may be especially useful when a generated element is composed of several non-connex sub-elements. Using the 
extract capability you can generate separate elements from these sub-elements, without deleting the initial element.
 
Open the Extract1.CATPart document.

1.  Click Extract .

The Extract Definition dialog box is displayed. 

In the Part Design workbench, the Extract capability is available as a contextual command named Create 
Extract that you can access from Sketch-based features dialog boxes.

2.  Select an edge or the face of an element.

The selected element is highlighted. 

Multi-selection is available to let you select several elements to be extracted.

3.  Choose the Propagation type: 

�❍     Point continuity: the extracted element will not have a hole.
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�❍     Tangent continuity: the extracted element will be created according to tangency conditions. 

�❍     Curvature continuity: the extracted element (necessarily a curve) will be created according to 
curvature conditions.

�❍     No propagation: only the selected element will be created.
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If either Intersection edges activation or Tangent Intersection edges activation icon is 
selected in the User Selection Filter toolbar before launching the Extract command, then the 
Geometrical Element Filter icon is automatically activated and the Propagation type set in 
the Extract Definition dialog box is applied.  
Deactivate the Geometrical Element Filter icon to take into account the behavior of 
the Intersection edges activation or Tangent Intersection edges activation capability. 
When you click OK in the Extract Definition dialog box, the status of the Geometrical 
Element Filter icon returns to normal.

4.  Click Show parameters>> to display further options. They are only valid for curves.

These options are only valid for curves.

 

�❍     Distance Threshold: specifies the distance value between 0.001mm and 0.1 mm below which the 
elements are to be extracted.

■     The default value is 0.1mm, except if a Merging Distance has been defined different from 
0.001mm in Tools > Options. In this case, the Distance Threshold value is initialized with 
the Merging Distance value. 
To have further information, refer to the General Settings chapter.

 ■     It is available with all propagation types, except for the No propagation type.

�❍     Angular Threshold: specify the angle value between 0.5 degree and 5 degree below which the 
elements are to be extracted (the default value is 0.5deg)

�❍     Curvature Threshold: specifies a ratio between 0 and 1 which is defined as follows:

if ||Rho1-Rho2|| / max (||Rho2||,||Rho1||) < (1-r)/r  
where Rho1 is the curvature vector on one side of the discontinuity, Rho2 the curvature vector on the 
other side, and r the ratio specified by the user; 
then the discontinuity is smoothed. 

For example, r=1 corresponds to a continuous curvature and r=0.98 to the model tolerance (default 
value). A great discontinuity will require a low r to be taken into account.
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Curvature Threshold = 0.98

 

 Curvature Threshold = 0.80

 

 Curvature Threshold = 0.50
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To sum up:
�❍     when Point continuity is selected, only the Distance Threshold is activated

�❍     when Tangent continuity is selected, both Distance and Angular Thresholds are activated

�❍     when Curvature continuity is selected, all Thresholds are activated.

5.  Click OK to extract the element.

The extracted element (identified as Extract.xxx) is added to the specification tree.

 
Additional Parameters

 
●     Checking Complementary mode highlights and therefore selects the 

elements that were not previously selected, while deselecting the elements 
that were explicitly selected.

●     Checking Federation generates groups of elements belonging to the 
resulting extracted element that will be detected together with the pointer 
when selecting one of its sub-elements. For further information, see Using 
the Federation Capability.

●     You can select a volume as the element to be extracted. 
To do so, you can either:

�❍     select the volume in the specification tree, or

�❍     use the User Selection Filter toolbar and select the Volume Filter mode. 
For further information, refer to the Selecting Using A Filter chapter in the 
CATIA Infrastructure User's Guide.

In both cases, the result of the extraction is the same whatever the 
chosen propagation type.
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●     If you extract an internal edge, you are advised to select a support element 
so that the orientation of the resulting extract feature remains the same even 
if the geometry is modified. 
If you extract an internal edge using the Point Propagation type and there 
is an ambiguity about the propagation side, a warning message is issued and 
you are prompted to select a support surface. In this case, the Support field 
becomes active.

 
Creating Contextual Extracts

 Some commands allow the creation of contextual extracts using the right-mouse button. They are aggregated to the 
feature using them and put in no show. 
Here is an example with the Parallel Curve command when right-clicking the Curve field:

 

 ●     If you select the Create Extract contextual command, the Extract Definition dialog box opens.
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●     If you select the Create Extract (in point) or Create Extract (in tangency) contextual command, no dialog 

box opens.
Both commands let you create extracts with a pre-defined propagation. You just need to select a sub-element 
such as wire edge, border edges, face, sub-elements of a volume or a solid.

You cannot select edges as a support is needed.

You need to leave the mouse on the pre-selected sub-element to preview and compute the propagation 
(in green):

 

 
Editing Extracts

 When editing extracts, the multi-selection capability is not available: if you select another element to be extracted, it 
is not appended to the list but replaces the former element.

 
Miscellaneous

 ●     In a .CATProduct document containing several parts, you can use the extract capability in the current part from 
the selection of an element in another part, provided the propagation type is set to No Propagation. 
In this case, a curve (respectively a surface or point) is created in the current part if the selected element is a 
curve (respectively a surface or point); the Extract parent therefore being the created curve (respectively the 
surface or point). 
Note: 

�❍     if another propagation type is selected, the extraction is impossible and an error message is issued.

�❍     when editing the extract, you can change the propagation type providing the parent belongs to the current 
part.

�❍     in the current part, if you select an element using the Tangent, Point or Curvature continuity as the 
propagation type, a warning is issued and you have to select No propagation instead.

●     If the selected element is not tangent continuous and the propagation type is set to Tangent continuity, an error 
message is issued.

●     If the selected element is a wire that is not curvature continuous and the propagation type is set to Curvature 
continuity, an error message is issued.

●     If the selected element has a support face and is not a surface, even though the Complementary mode option is 
checked, the Complementary mode will not be taken into account for the extraction and the option will therefore 
be inactive. After the extraction, the option will be available again.

●     If the selected element is a border edge, the propagation is done along the boundary of the support and does not 
take into account internal edges.
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●     When the result of an extract is not connex (during creation or edition) due to naming ambiguity, you can then 
select the part to keep to solve the ambiguity.

●     If two elements have a same name and their centers of gravity are at a distance of less than 0.1mm, the naming 
ambiguity mechanism fails and an error message is issued.

●     You cannot copy/paste an extracted element from a document to another. If you wish to do so, you need to copy/
paste the initial element first into the second document then perform the extraction.

●     If there is several solutions for the propagation, the computation of the extract stops at the junction point.
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Rotating Geometry

 
This task shows you how to rotate geometry about an axis.

Open the Transform1.CATPart document.

 

1.  Click Rotate .

The Rotate Definition dialog box appears as well as the Tools Palette. 
For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA 
Infrastructure User's Guide.

2.  Define the rotation type:

�❍     Axis-Angle (default mode): the rotation axis is defined by a linear element and the angle is defined by 
a value that can be modified in the dialog box or in the 3D geometry (by using the manipulators).

�❍     Axis-Two Elements: the rotation axis is defined by a linear element and the angle is defined by two 

geometric elements (point, line or plane)

■     Axis/point/point: the angle between the vectors is defined by the selected points and their 

orthogonal projection onto the rotation axis.
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■     Axis/point/line: the angle between the vector is defined by the selected point and its orthogonal 

projection onto the rotation axis and the selected line.

■     Axis/point/plane: the angle between the vector is defined by the selected point and its orthogonal 

projection onto the rotation axis and the normal to the selected plane.

3D Insight Version 5 Release 19 Page 1335 of 1379



■     Axis/line/line: the angle between the direction vectors of the projection is defined by the two 

selected lines in the plane normal to the rotation axis.

In case both lines are parallel to the rotation axis, the angle is defined by the intersection points of 
the plane normal to the rotation axis and these lines.

■     Axis/line/plane: the angle is defined between the selected line and the normal to the plane.
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■     Axis/plane/plane: the angle is defined between the normals to the two selected planes.

�❍     Three Points:  the rotation is defined by three points.

■     The rotation axis is defined by the normal of the plane created by the three points passing through 

the second point.

■     The rotation angle is defined by the two vectors created by the three points (between vector Point2-

Point1 and vector Point2-Point3):
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The orientation of the elements (lines or planes) is visualized in the 3D geometry by a red arrow. You can 

click the arrow to invert the orientation and the angle is automatically recomputed. By default, the arrow is 

displayed in the direction normal to the feature (line or plane). 

For instance, in the plane/plane mode, the arrow is displayed on each plane:

3.  Select the Element to be rotated.

4.  Select the inputs depending on the chosen rotation type.

5.  Click OK to create the rotated element.
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The element (identified as Rotate.xxx) is added to the specification tree.

Optional Parameters
 ●     Click Hide/Show initial element to hide or show the original element for the translation.

 ●     Choose whether you want the result of the transformation to be a surface or a volume by switching to either 
Surface or Volume option. 

This capability is only available with Generative Shape 
Optimizer. 

This switch only concerns volumes since the transformation of a surface can only be a surface. Thus in case of 
multi-selection of volumes and surfaces, the switch only affect volumes.
Note:

�❍     Replacing an input element does not change the result type,

�❍     The switch between surface and volume is grayed out when editing the feature.

To have further information about volumes, refer to the corresponding chapter.

●     Check the Repeat object after OK to create several rotated surfaces, each separated from the initial surface by 
a multiple of the Angle value.
Simply indicate in the Object Repetition dialog box the number of instances that should be created and click OK.

The Repeat object after OK capability is not available with the Axis-Two Elements and Three Points 
rotation types.

●     You can select an axis system as the Element to be rotated, providing it was previously created.
The element is identified as Rotate.xxx in the specification tree, however the associated icon is the axis system's 

.
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●     If you select a solid as the input element, the result will either be a surface or a volume.

●     Note that the selection of the feature prevails over the selection of the sub-element. 
To select a sub-element, you need to apply the ''Geometrical Element'' filter in the User 
Selection Filter toolbar. 
For further information, refer to the Selecting Using A Filter chapter in the CATIA 
Infrastructure User's Guide.

●     You can edit the rotated element's parameters. Refer to Editing Parameters to find out how to 
display these parameters in the 3D geometry.

●     The following capabilities are available: Stacking Commands,  Selecting Using Multi-Output, 
Measure Between and Measure Item.
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Translating Geometry

 
This task shows you how to translate one, or more, point, line or surface element.

Open the Translate1.CATPart document.

 

1.  Click Translate .

The Translate Definition dialog box appears as well as the Tools Palette. 
For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA 
Infrastructure User's Guide.

2.  Select the Element to be translated.

3.  Select the Vector Definition.

Direction, distance
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4.  Select a line to take its orientation as the translation direction or a plane to take its normal as the 

translation direction.

You can also specify the direction by means of X, Y, Z vector components by using the contextual menu on 
the Direction field. 

5.  Specify the translation Distance by entering a value or using the spinners.

Point to Point
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4.  Select the Start point.

5.  Select the End point.

 

Coordinates
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4.  Define the X, Y, and Z coordinates.

In the example besides, we chose 50mm as X, 0mm as Y, and -100 as Z.

5.  When the command is launched at creation, the initial value in the Axis System field is the current local 

axis system. If no local axis system is current, the field is set to Default.  

Whenever you select a local axis system, the translated element's coordinates are changed with respect to 

the selected axis system so that the location of the translated element is not changed. This is not the case 

with coordinates valuated by formulas: if you select an axis system, the defined formula remains 

unchanged.

6.  Click OK to create the translated element.

The element (identified as Translate.xxx) is added to the specification tree. 
The original element is unchanged.

●     You can select an axis system as the Element to be translated, 
providing it was previously created. 
The element is identified as Translate.xxx in the specification tree, 

however the associated icon is the axis system's .

●     Click Hide/Show initial element to hide or show the original 
element for the translation.

●     Choose whether you want the result of the transformation to be a 
surface or a volume by switching to either Surface or Volume option.  
This capability is only available with the Generative Shape Optimizer 
product. 
This switch only concerns volumes since the transformation of a 
surface can only be a surface. Thus in case of multi-selection of 
volumes and surfaces, the switch only affect volumes. 
Note:

�❍     Replacing an input element does not change the result type,

�❍     The switch between surface and volume is grayed out when 
editing the feature. 
To have further information about volumes, refer to the 
corresponding chapter.

●     Check Repeat object after OK to create several translated surfaces, 
each separated from the initial surface by a multiple of the Distance 
value.
Simply indicate in the Object Repetition dialog box the number of 
instances that should be created and click OK.
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●     If you select a solid as the input element, the result will either be a 
surface or a volume.

●     The selection of the feature prevails over the selection of the sub-
element. 
To select a sub-element, you need to apply the ''Geometrical Element'' 
filter in the User Selection Filter toolbar. 
For further information, refer to the Selecting using a Filter chapter in 
the CATIA Infrastructure User's Guide.

●     You can edit the translated element's parameters. Refer to Editing 
Parameters to find out how to display these parameters in the 3D 
geometry.

●     The following capabilities are available: Stacking Commands and 
Selecting Using Multi-Output.
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Performing a Symmetry on Geometry

 
This functionality is P2 for FreeStyle Shaper, Optimizer, and Profiler.

 
This task shows you how to transform geometry by means of a symmetry operation.

Open the Transform1.CATPart document.

 

1.  Click Symmetry .

The Symmetry Definition dialog box appears as well as the Tools Palette. 
For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA 
Infrastructure User's Guide.

2.  Select the Element to be transformed by symmetry.

3.  Select a point, line or plane as Reference element.
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The figure above illustrates the resulting symmetry when 
the line is used as reference element  

The figure above illustrates the resulting 
symmetry when the point is used as reference 
element

4.  Click OK to create the symmetrical element.

The element (identified as Symmetry.xxx) is added to the specification tree.
 

�❍     You can select an axis system as the Element to be transformed, providing it was previously 
created. 
The element is identified as Symmetry.xxx in the specification tree, however the associated icon 

is the axis system's .

�❍     Click Hide/Show initial element to hide or show the original element for the translation.

�❍     Choose whether you want the result of the transformation to be a surface or a volume by 
switching to either Surface or Volume option.  
This capability is only available with the Generative Shape Optimizer product. 
This switch only concerns volumes since the transformation of a surface can only be a surface. 
Thus in case of multi-selection of volumes and surfaces, the switch only affects volumes. 
Note:

■     Replacing an input element does not change the result type,

■     The switch between surface and volume is grayed out when editing the feature. 
To have further information about volumes, refer to the corresponding chapter.

�❍     If you select a solid as the input element, the result will either be a surface or a volume.

�❍     The selection of the feature prevails over the selection of the sub-element. 
To select a sub-element, you need to apply the ''Geometrical Element'' filter in the User Selection 
Filter toolbar. 
For further information, refer to the Selecting using a Filter chapter in the CATIA Infrastructure 
User's Guide.

The following capabilities are available: Stacking Commands and Selecting Using Multi-Output.
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Transforming Geometry by Scaling

 
This task shows you how to transform geometry by means of a scaling operation.

Open the Transform1.CATPart document.

 

1.  Click Scaling .

The Scaling Definition dialog box appears as well as the Tools Palette. 
For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA 
Infrastructure User's Guide.

2.  Select the Element to be transformed by scaling.

3.  Select the scaling Reference point, plane or planar surface.

4.  Specify the scaling Ratio by entering a value or using the drag manipulator.

The figure above illustrates the resulting 
scaled element when the plane is used as 
reference element (ratio = 2)

The figure above illustrates the resulting scaled element when 
the point is used as reference element (ratio = 2):

5.  Click OK to create the scaled element.
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The element (identified as Scaling.xxx) is added to the specification tree.
You can check Repeat object after OK to create several scaled surfaces, each separated from the initial 
surface by a multiple of the initial Ratio value.
Simply indicate in the Object Repetition dialog box the number of instances that should be created and click 
OK.

�❍     Click Hide/Show initial element to hide or show the original element for the translation.

�❍     Choose whether you want the result of the transformation to be a surface or a volume by 
switching to either Surface or Volume option.  
This capability is only available with the Generative Shape Optimizer product. 
This switch only concerns volumes since the transformation of a surface can only be a surface. 
Thus in case of multi-selection of volumes and surfaces, the switch only affects volumes. 
Note:

■     Replacing an input element does not change the result type,

■     The switch between surface and volume is grayed out when editing the feature. 
To have further information about volumes, refer to the corresponding chapter.

�❍     If you select a solid as the input element, the result will either be a surface or a volume.

�❍     The selection of the feature prevails over the selection of the sub-element. 
To select a sub-element, you need to apply the ''Geometrical Element'' filter in the User Selection 
Filter toolbar. 
For further information, refer to the Selecting using a Filter chapter in the CATIA Infrastructure 
User's Guide.

The following capabilities are available: Stacking Commands and Selecting Using Multi-Output.
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Transforming Geometry by Affinity 

 
This task shows you how to transform geometry by means of an affinity operation. 
The Affinity command applies to current bodies in case of Part Design workbench.

Open the Transform1.CATPart document. 
To perform this task in the Part Design workbench, open a CATPart of your choice.
 

1.  Click Affinity .

The Affinity Definition dialog box appears as well as the Tools Palette. 
For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA Infrastructure User's Guide.

The Affinity Definition dialog box displayed in the Part Design workbench is as shown:

2.  Select the Element to be transformed by affinity. This option is available only in the Generative Shape Design workbench.

3.  Specify the characteristics of the Axis system to be used for the affinity operation:

�❍     the Origin (Point.1 in the figures below)

�❍     the XY plane (the XY plane in the figures below)

�❍     the X axis (Line.1 in the figures below).

4.  Specify the affinity Ratios by entering the desired X, Y, Z values.
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Ratios X = 2, Y =1 and Z=1.
 

Ratios X = 2, Y =1 and Z=2.
 

Ratios X = 2, Y =2.5 and Z=2
 

5.  Click OK to create the affinity element.

The element (identified as Affinity.xxx) is added to the specification tree.
 

�❍     Use Hide/Show initial element to hide or show the original element for the translation. This option is available only in the Generative Shape 
Design workbench.

�❍     Choose whether you want the result of the transformation to be a surface or a volume by switching to either Surface or Volume option. This 
option is available only in the Generative Shape Design workbench. 
This capability is only available with the Generative Shape Optimizer product. 
This switch only concerns volumes since the transformation of a surface can only be a surface. Thus in case of multi-selection of volumes and 
surfaces, the switch only affects volumes. 
Note:

■     Replacing an input element does not change the result type,

■     The switch between surface and volume is grayed out when editing the feature. 
To have further information about volumes, refer to the corresponding chapter.

�❍     If you select a solid as the input element, the result will either be a surface or a volume.

�❍     The selection of the feature prevails over the selection of the sub-element. 
To select a sub-element, you need to apply the ''Geometrical Element'' filter in the User Selection Filter toolbar. 
For further information, refer to the Selecting using a Filter chapter in the CATIA Infrastructure User's Guide.
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The following capabilities are available: Stacking Commands and Selecting Using Multi-Output.
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Transforming Elements 
From an Axis to Another 

 This task shows you how to transform geometry positioned according to a given axis system into a new axis system. The geometry is duplicated and 
positioned according to the new axis system. One or more elements can be transformed at a time, using the standard multi-selection capabilities. 
See also Defining an Axis System. 
The Axis To Axis command applies to current bodies in case of Part Design and Generative Sheetmetal Design workbenches.

Open the Transform2.CATPart document. 
To perform this task in the Part Design and Generative Sheetmetal Design workbench, open a CATPart of your choice.
 

1.  Click Axis To Axis  in the Operations toolbar (Transformations sub-toolbar).

The Axis To Axis Definition dialog box appears as well as the Tools Palette. 
For further information about the Tools Palette, refer to Selecting Using Selection Traps in the CATIA Infrastructure User's Guide.

The Axis To Axis Definition dialog box displayed in the Generative Sheetmetal Design and Part Design workbenches is as shown: 

2.  Select the Element to be transformed into a new axis system. This option is available only in the Generative Shape Design workbench.

3.  Select the initial (Reference) axis system.
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4.  Select the Target axis system, that is, the one into which the element should be positioned.

5.  Click OK to create the transformed element.

The new geometry is now positioned into the new axis system.

The element (identified as Axis To axis transformation.xxx) is added to the specification tree.
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�❍     Click Hide/Show initial element to hide or show the original element for the translation. This option is available only in the Generative Shape 
Design workbench.

�❍     You can select an axis system as the Element to be transformed, providing it was previously created. 

The element is identified as Axis To axis transformation.xxx in the specification tree, however the associated icon is the axis system's .

�❍     Choose whether you want the result of the transformation to be a surface or a volume by switching to either Surface or Volume option. This 
option is available only in the Generative Shape Design workbench.  
This switch only concerns volumes since the transformation of a surface can only be a surface. Thus in case of multi-selection of volumes and 
surfaces, the switch only affects volumes. 
Note:

■     Replacing an input element does not change the result type,

■     The switch between surface and volume is grayed out when editing the feature. 
This capability is only available with Generative Shape Optimizer. To have further information about volumes, refer to the corresponding 
chapter.

�❍     If you select a solid as the input element, the result will either be a surface or a volume.

�❍     The selection of the feature prevails over the selection of the sub-element. 
To select a sub-element, you need to apply the ''Geometrical Element'' filter in the User Selection Filter toolbar. 
For further information, refer to the Selecting using a Filter chapter in the CATIA Infrastructure User's Guide.

The following capabilities are also available: Stacking Commands and Selecting Using Multi-Output.
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V4 Integration

3D Insight offers a subset of V4 Integration product. 
The table below lists the information you will find.

Migrating from CATIA V4 to CATIA V5  
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Migrating from CATIA V4 to CATIA V5 

Before migrating:

Warning Prerequisites 
Manipulating V4 Models in V5

Copying/Pasting AS RESULT or AS SPEC a V4 Document into CATIA V5:

Copying 3D Data from CATIA V4 to V5 Document 
Partial Paste: Diagnosis Feature 
Main PartBody is no longer used in conversion AS SPEC 
Conversion of SolidM entities as Result (migrated as a PartBody) 
Copy/Paste Solids: Use of Interactive Multi Copy/Paste As Result With Link within CATIA V5 
About V4/V5 Equivalences on Geometric Types and V5 Features

Migrating a V4 DETAIL:

Copying / Pasting a Model with Dittos in CATIA V5

Having access to V4 and V5 properties:

Information about V4 Attributes accessible in the Properties dialog box 
Comparison of Result Option in Batch: V4/V5 BREP Info Checker

Migrating in Batch Mode:

Migrating from V4 to V5 in Batch Mode

Opening a V4 Session in CATIA V5:

Opening a CATIA Version 4 Session in CATIA Version 5

Opening a CATIA Version 4 Session referencing CDM Models

V4/V5 Infrastructure:

Having Access to PRJ Files on NT 
Using CATIA Version 4 Libraries in CATIA Version 5
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Optimizing V4V5 Migration:

Optimizing V4V5 Migration 
How to migrate Application Data

Migrating 2D Elements into CATIA V5:

Migration of 2D Draw Elements and Views 
Managing AUXVIEW2 Defaults for Migration
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Workbench Description

This section shows the 3D Insight workbenches. All of the commands are discussed in greater details in other parts of the guide.

To perform 3D Functional Tolerancing and Annotation (FTA) and 2D Layout for 3D Design (LO1) data review refer to DMU 
Dimensioning and Tolerancing Review

To perform mark-up refer to DMU Navigator 

To perform exact sectioning, exact measurement or construction and additional geometry creation for analysis refer to Wireframe 
and Surface

To manage the product structure for additional geometry creation refer to Product Structure
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To perform sketch examination refer to Sketcher

To reuse V4 data refer to V4 Integration

To reuse 2D graphic or CAD data refer to Interactive Drafting
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::geometrical constraints;geometrical constraint, creating;commands::Geometrical Constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-using::grid option;grid option, using;commands::Grid
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0204.htm#ix-creating::hexagon;hexagon, creating;commands::Hexagon
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0317.htm#ix-commands::Hyperbola by Focus;creating::hyperbola by focus;hyperbola by focus, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0329.htm#ix-commands::Infinite Line;creating::infinite line;infinite line, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0511.htm#ix-commands::Intersect 3D Elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugintersections.htm#ix-commands::Intersection;intersecting elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0331.htm#ix-commands::Intersection Point;point using intersection, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0512.htm#ix-commands::Isolate;isolating:: projections;isolating::intersections;intersections, isolating;projections, isolating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0203.htm#ix-commands::Keyhole
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0203.htm#ix-commands::Keyhole Profile;keyhole profile, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0310.htm#ix-commands::Line
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugline3D.htm#ix-commands::Line;line
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0321.htm#ix-lines normal to curves, creating;commands::Line Normal to Curve
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0509.htm#ix-commands::Mirror;mirrored element, creating;creating::mirrored elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0332.htm#ix-using::no 3D background option;no 3D background option, using;commands::No 3D Background
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0204.htm#ix-commands::Offset;offsetting surfaces
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0326.htm#ix-commands::Oriented Rectangle
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0902.htm#ix-creating::output features;output features, creating;commands::Output Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0902.htm#ix-commands::Output Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0316.htm#ix-commands::Parabola by Focus;parabola by focus, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0308.htm#ix-commands::Parallelogram
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0109.htm#ix-commands::Parents/Children... (Contextual Menu)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0513.htm#ix-contextual command::paste special;commands::Paste Special (Contextual Menu)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugplane3D.htm#ix-commands::Plane;plane
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0119.htm#ix-commands::Planes Repetition;repeating planes
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0312.htm#ix-commands::Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugpoint3D.htm#ix-commands::Point;point
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugmultiple.htm#ix-commands::Point and Planes Repetition;multiple points and planes
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0322.htm#ix-commands::Point by Using Coordinates
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0122.htm#ix-commands::Polyline;polyline
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0315.htm#ix-commands::Profile
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0910.htm#ix-creating::profile features;profile features, creating;commands::Profile Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0910.htm#ix-commands::Profile Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0510.htm#ix-3D elements::projecting;yellow, colors;commands::Project 3D Elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0510.htm#ix-commands::Project 3D Elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugprojections.htm#ix-commands::Projection;projecting elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0333.htm#ix-commands::Projection Point;creating::a point using projection
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0333.htm#ix-commands::Projection Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0502.htm#ix-commands::Quick Trim;breaking;trimming
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0502.htm#ix-commands::Quick Trim
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0325.htm#ix-commands::Rectangle;rectangle, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0325.htm#ix-commands::Rectangle
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0107.htm#ix-commands::Replace...
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0107.htm#ix-commands::Replace...
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugrevolution.htm#ix-commands::Revolve;revolving surfaces
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugrotateGSD.htm#ix-commands::Rotate;rotating geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0707.htm#ix-commands::Scale
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugscaling.htm#ix-commands::Scaling;scaling geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0102.htm#ix-commands::Select
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0310.htm#ix-commands::Set As Angle Reference (contextual menu)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0900.htm#ix-commands::Sketch With Absolute Axis Definition
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys_grid.htm#ix-using::snap to point option;snap to point option, using;commands::Snap to Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-using::snap to point option;snap to point option, using;commands::Snap to Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugsphere.htm#ix-commands::Sphere;sphere
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0309.htm#ix-spline::creating;commands::Spline
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0102.htm#ix-commands::Spline;spline
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0318.htm#ix-commands::Symmetrical Extension;symmetrical extension, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0904.htm#ix- symmetrical elements::moving;commands::Symmetry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugsymmetryGSD.htm#ix-commands::Symmetry;symmetry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0324.htm#ix-three points arc, creating;commands::Three Point Arc
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0350.htm#ix-creating::three point circle;three point circle, creating;commands::Three Point Circle
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0327.htm#ix-three points arc using limits, creating;commands::Three Points Arc Using Limits
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugtranslateGSD.htm#ix-commands::Translate;translating geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0516.htm#ix-commands::Translation
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0501.htm#ix-trimming::elements;commands::Trim
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0501.htm#ix-commands::Trim
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0501.htm#ix-commands::Trim
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0519.htm#ix-commands::Trim
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-chamfer::with one element trimmed;chamfer::with no element trimmed;chamfer::with both elements trimmed;creating::chamfer with both elements trimmed;creating::chamfer with one element trimmed;creating::chamfer with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-chamfer::with one element trimmed;chamfer::with no element trimmed;chamfer::with both elements trimmed;creating::chamfer with both elements trimmed;creating::chamfer with one element trimmed;creating::chamfer with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-chamfer::with one element trimmed;chamfer::with no element trimmed;chamfer::with both elements trimmed;creating::chamfer with both elements trimmed;creating::chamfer with one element trimmed;creating::chamfer with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0603.htm#ix-commands::Unfix (Contextual Menu);contextual command::unfix
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugupgrade.htm#ix-commands::Upgrade;upgrading features
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0901.htm#ix-editing:conic curves
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0111.htm#ix-editing::connecting curves;connecting curves::editing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0340.htm#ix-commands::Connect (with an arc);connecting curves::with an arc;curves::connecting with an arc
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0619.htm#ix-constrained sketches
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0609.htm#ix-modifying, constraint definition;constraint definition, modifying
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0617.htm#ix-constraint measure direction, defining
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0616.htm#ix-constraints::dimensional;constraints::geometrical;constraints::colors;constraints::while sketching;constraints::visualization
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0616.htm#ix-constraints::dimensional;constraints::geometrical;constraints::colors;constraints::while sketching;constraints::visualization
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0616.htm#ix-constraints::dimensional;constraints::geometrical;constraints::colors;constraints::while sketching;constraints::visualization
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0609.htm#ix-constraints::reference
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0616.htm#ix-constraints::dimensional;constraints::geometrical;constraints::colors;constraints::while sketching;constraints::visualization
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0616.htm#ix-constraints::dimensional;constraints::geometrical;constraints::colors;constraints::while sketching;constraints::visualization
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0611.htm#ix-constraints (via dialog box), creating;constraints (via dialog box), creating;commands::Constraints (Via a Dialog Box)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0611.htm#ix-constraints (via dialog box), creating;constraints (via dialog box), creating;commands::Constraints (Via a Dialog Box)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0109.htm#ix-constraints, editing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt1010.htm#ix-constraints, editing;constraints, editing;commands::Edit Multi-Constraint
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt1010.htm#ix-constraints, editing;constraints, editing;commands::Edit Multi-Constraint
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0302.htm#ix-commands::Construction/Standard Elements;construction element, creating;hexagon;standard element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::construction elements;construction elements, creating;commands::Construction/Standard Elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0603.htm#ix-commands::Fix (Contextual Menu);contextual command::fix
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0513.htm#ix-contextual command::paste special;commands::Paste Special (Contextual Menu)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0603.htm#ix-commands::Unfix (Contextual Menu);contextual command::unfix
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0104.htm#ix-coordinates, modifying
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0513.htm#ix-copying/pasting elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0333.htm#ix-commands::Projection Point;creating::a point using projection
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0333.htm#ix-creating::a point using projection along a direction
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0307.htm#ix-creating::an arc; arc, creating;commands::Arc
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0330.htm#ix-creating::bisecting line;bisecting line, creating;commands::Bisecting Line
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-chamfer::with one element trimmed;chamfer::with no element trimmed;chamfer::with both elements trimmed;creating::chamfer with both elements trimmed;creating::chamfer with one element trimmed;creating::chamfer with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-chamfer::with one element trimmed;chamfer::with no element trimmed;chamfer::with both elements trimmed;creating::chamfer with both elements trimmed;creating::chamfer with one element trimmed;creating::chamfer with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-chamfer::with one element trimmed;chamfer::with no element trimmed;chamfer::with both elements trimmed;creating::chamfer with both elements trimmed;creating::chamfer with one element trimmed;creating::chamfer with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::construction elements;construction elements, creating;commands::Construction/Standard Elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-corner::with one element trimmed;corner::with no element trimmed;corner::with both elements trimmed;creating::corner with both elements trimmed;creating::corner with one element trimmed;creating::corner with no element trimmed;commands::Trim All Elements;commands::Trim First Element;commands::Trim No Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::dimensional constraints;dimensional constraint, creating;commands::Dimensional Constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0306.htm#ix-creating::ellipses;ellipse, creating;commands::Ellipse
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::geometrical constraints;geometrical constraint, creating;commands::Geometrical Constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0603.htm#ix-dimensional constraints, creating;creating::geometrical constraints;geometrical constraints, creating;commands::Constraints (Fixed / Unfixed)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0204.htm#ix-creating::hexagon;hexagon, creating;commands::Hexagon
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0317.htm#ix-commands::Hyperbola by Focus;creating::hyperbola by focus;hyperbola by focus, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0329.htm#ix-commands::Infinite Line;creating::infinite line;infinite line, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0509.htm#ix-commands::Mirror;mirrored element, creating;creating::mirrored elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0201.htm#ix-commands::Elongated Hole;creating::oblong profile;elongated hole, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0902.htm#ix-creating::output features;output features, creating;commands::Output Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0900.htm#ix-positioned sketch, starting;sketch::creating a positioned sketch;creating::positioned sketch
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0910.htm#ix-creating::profile features;profile features, creating;commands::Profile Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0703.htm#ix-sketch::starting;sketch::creating;creating::sketch
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0903.htm#ix-creating:spline offset
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::standard elemetns;standard elements, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0350.htm#ix-creating::three point circle;three point circle, creating;commands::Three Point Circle
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0340.htm#ix-commands::Connect (with an arc);connecting curves::with an arc;curves::connecting with an arc
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0304.htm#ix-cutting the part (by sketch plane);commands::Cut Part by Sketch Plane;sketch plane, cutting
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugcylinder.htm#ix-commands::Cylinder;cylinder
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0704.htm#ix-deactivating sketches;sketch::deactivating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::dimensional constraints;dimensional constraint, creating;commands::Dimensional Constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt1010.htm#ix-editing::dimensional constraints;dimensional constraint, editing;commands::Dimensional Constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0603.htm#ix-dimensional constraints, creating;creating::geometrical constraints;geometrical constraints, creating;commands::Constraints (Fixed / Unfixed)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0901.htm#ix-editing:conic curves
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0111.htm#ix-editing::connecting curves;connecting curves::editing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt1010.htm#ix-editing::dimensional constraints;dimensional constraint, editing;commands::Dimensional Constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0110.htm#ix-editing::projection marks;editing::intersection marks;projection marks, editing;intersection marks, editing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0110.htm#ix-editing::projection marks;editing::intersection marks;projection marks, editing;intersection marks, editing
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0108.htm#ix-editing:spline
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0905.htm#ix-editing:spline offset
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0100.htm#ix-profile::editing; editing, profile
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0515.htm#ix-commands::Close;closing elements;elements, closing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0306.htm#ix-creating::ellipses;ellipse, creating;commands::Ellipse
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0201.htm#ix-commands::Elongated Hole;creating::oblong profile;elongated hole, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugextract.htm#ix-commands::Extract;extracting geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugextrude.htm#ix-commands::Extrude;extruding surfaces
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0206.htm#ix-commands::Fill;filling surfaces
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::geometrical constraints;geometrical constraint, creating;commands::Geometrical Constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0603.htm#ix-dimensional constraints, creating;creating::geometrical constraints;geometrical constraints, creating;commands::Constraints (Fixed / Unfixed)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0520.htm#ix-geometry:analyzing;geometry::diagnosis;sketch:analyzing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0520.htm#ix-geometry:analyzing;geometry::diagnosis;sketch:analyzing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-using::grid option;grid option, using;commands::Grid
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cgr 

session 
importing existing component

commands 

importing from files 

inconsistent, sketch 

infinite line, creating 
inserting

component 
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inserting a new product

commands 

inserting CATPart or CATProduct documents from a catalog 

intersecting elements 

intersection marks, editing 

intersections, isolating 
isolating

intersections 

projections 
isolating Part

3D Insight Version 5 Release 19 Page 1372 of 1379

file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0302.htm#ix-commands::Construction/Standard Elements;construction element, creating;hexagon;standard element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0204.htm#ix-creating::hexagon;hexagon, creating;commands::Hexagon
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0317.htm#ix-commands::Hyperbola by Focus;creating::hyperbola by focus;hyperbola by focus, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0618.htm#ix-inconsistent, sketch;sketch::inconsistent
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0329.htm#ix-commands::Infinite Line;creating::infinite line;infinite line, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugintersections.htm#ix-commands::Intersection;intersecting elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0110.htm#ix-editing::projection marks;editing::intersection marks;projection marks, editing;intersection marks, editing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0512.htm#ix-commands::Isolate;isolating:: projections;isolating::intersections;intersections, isolating;projections, isolating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0512.htm#ix-commands::Isolate;isolating:: projections;isolating::intersections;intersections, isolating;projections, isolating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0512.htm#ix-commands::Isolate;isolating:: projections;isolating::intersections;intersections, isolating;projections, isolating
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L 
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0203.htm#ix-commands::Keyhole Profile;keyhole profile, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugline3D.htm#ix-commands::Line;line
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0321.htm#ix-lines normal to curves, creating;commands::Line Normal to Curve
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0509.htm#ix-commands::Mirror;mirrored element, creating;creating::mirrored elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0609.htm#ix-modifying, constraint definition;constraint definition, modifying
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugmultiple.htm#ix-commands::Point and Planes Repetition;multiple points and planes
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0332.htm#ix-using::no 3D background option;no 3D background option, using;commands::No 3D Background
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0514.htm#ix-offsetting
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0204.htm#ix-commands::Offset;offsetting surfaces
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0500.htm#ix-operations on profiles, performing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0502.htm#ix-option::Beak and Keep
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0502.htm#ix-option::Beak and Rubber In
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0502.htm#ix-option::Beak and Rubber Out
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-option::Construction Lines No Trim (chamfer)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-option::Construction Lines No Trim (corner)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-option::Construction Lines Trim (chamfer)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-option::Construction Lines Trim (corner)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-option::No Trim (chamfer)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-option::No trim (corner)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-option::Standard Lines Trim (chamfer)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-option::Standard Lines Trim (corner)
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0501.htm#ix-option::Trim All Elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-option::Trim All Elements (chamfer)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-option::Trim All Elements (corner)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0501.htm#ix-option::Trim First Element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0313.htm#ix-option::Trim First Element (corner)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0314.htm#ix-option::Trim the first Element (chamfer)
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0902.htm#ix-creating::output features;output features, creating;commands::Output Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0618.htm#ix-over-constrained sketches, analyzing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0316.htm#ix-commands::Parabola by Focus;parabola by focus, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugplane3D.htm#ix-commands::Plane;plane
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugpoint3D.htm#ix-commands::Point;point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0331.htm#ix-commands::Intersection Point;point using intersection, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0122.htm#ix-commands::Polyline;polyline
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0900.htm#ix-positioned sketch, starting;sketch::creating a positioned sketch;creating::positioned sketch
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0106.htm#ix- auto-search on a profile; profile::auto-search;commands::Auto Search
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0103.htm#ix-profile::deleting
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0100.htm#ix-profile::editing; editing, profile
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0102.htm#ix-transforming, profile;profile::transforming
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0910.htm#ix-creating::profile features;profile features, creating;commands::Profile Feature
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugprojections.htm#ix-commands::Projection;projecting elements
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0110.htm#ix-editing::projection marks;editing::intersection marks;projection marks, editing;intersection marks, editing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0512.htm#ix-commands::Isolate;isolating:: projections;isolating::intersections;intersections, isolating;projections, isolating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0518.htm#ix-quickly analyzing, geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0325.htm#ix-commands::Rectangle;rectangle, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0119.htm#ix-commands::Planes Repetition;repeating planes
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0107.htm#ix-replacing::geometry
http://canezoudsy/AwsR20/AwsDocR20/Doc/online/pstug_C2/pstugbt0322.htm#ix-replacing on a specific instance or all instances
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugrevolution.htm#ix-commands::Revolve;revolving surfaces
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugrotateGSD.htm#ix-commands::Rotate;rotating geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugscaling.htm#ix-commands::Scaling;scaling geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0300.htm#ix-simple profiles, sketching;sketching, simple profiles
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0520.htm#ix-geometry:analyzing;geometry::diagnosis;sketch:analyzing
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugprt_C2/cfyugprtchangesketchsupport.htm#ix-changing a sketch support;commands::Change a Sketch Support;sketch::changing the support;absolute axis definition
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0703.htm#ix-sketch::starting;sketch::creating;creating::sketch
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0900.htm#ix-positioned sketch, starting;sketch::creating a positioned sketch;creating::positioned sketch
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0704.htm#ix-deactivating sketches;sketch::deactivating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0618.htm#ix-inconsistent, sketch;sketch::inconsistent
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0703.htm#ix-sketch::starting;sketch::creating;creating::sketch
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0304.htm#ix-cutting the part (by sketch plane);commands::Cut Part by Sketch Plane;sketch plane, cutting
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0300.htm#ix-simple profiles, sketching;sketching, simple profiles
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0800.htm#ix-using smartpick;smartpick, using
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0801.htm#ix-smartpicking
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys_grid.htm#ix-using::snap to point option;snap to point option, using;commands::Snap to Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-using::snap to point option;snap to point option, using;commands::Snap to Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugsphere.htm#ix-commands::Sphere;sphere
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/wfsug_C2/wfsugbt0102.htm#ix-commands::Spline;spline
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0309.htm#ix-spline::creating;commands::Spline
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0108.htm#ix-editing:spline
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0903.htm#ix-creating:spline offset
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0905.htm#ix-editing:spline offset
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0302.htm#ix-commands::Construction/Standard Elements;construction element, creating;hexagon;standard element
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-creating::standard elemetns;standard elements, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0513.htm#ix-symbols
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0904.htm#ix-symmetrical elements::applying constraints
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0904.htm#ix- symmetrical elements::moving;commands::Symmetry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0318.htm#ix-commands::Symmetrical Extension;symmetrical extension, creating
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugsymmetryGSD.htm#ix-commands::Symmetry;symmetry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0350.htm#ix-creating::three point circle;three point circle, creating;commands::Three Point Circle
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0327.htm#ix-three points arc using limits, creating;commands::Three Points Arc Using Limits
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0324.htm#ix-three points arc, creating;commands::Three Point Arc
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0102.htm#ix-transforming, profile;profile::transforming
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugtranslateGSD.htm#ix-commands::Translate;translating geometry
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0502.htm#ix-commands::Quick Trim;breaking;trimming
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0501.htm#ix-trimming::elements;commands::Trim
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyug_C2/cfyugupgrade.htm#ix-commands::Upgrade;upgrading features
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file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-using::grid option;grid option, using;commands::Grid
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0332.htm#ix-using::no 3D background option;no 3D background option, using;commands::No 3D Background
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys_grid.htm#ix-using::snap to point option;snap to point option, using;commands::Snap to Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-using::snap to point option;snap to point option, using;commands::Snap to Point
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/cfyugdys_C2/cfyugdys0800.htm#ix-using smartpick;smartpick, using
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0303.htm#ix-using tools, sketching
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0332.htm#ix-using tools, sketching
file:////ds/dsy/CXR20rel/BSFDOCEN/./Doc/online/dysug_C2/dysugbt0510.htm#ix-3D elements::projecting;yellow, colors;commands::Project 3D Elements

	3D Insight

	Site Map 
	Overview
	What's New?
	User Tasks
	Product Structure
	Entering the Product Structure Workbench
	About Modified Status when editing a CATProduct
	Selecting Products only
	Selecting Modes
	Inserting a New Component
	Inserting a New Part
	Inserting a New Product
	Inserting Existing Components
	Inserting CATPart/CATProduct Documents from a Catalog
	Loading Components
	Unloading Components
	Using the Selective Load
	Specifying the Depth Level when opening Product Structure
	Setting up the Design Mode
	Setting up the Visualization Mode
	Deactivating / Activating Node
	Deactivating / Activating a Terminal Node
	Activating a Terminal Node with a Progress Bar
	Managing Representations
	Reordering the Tree
	Isolating Part
	Deactivating / Activating a Component
	Defining Contextual Links
	Defining Contextual Links: Editing and Replacing Commands
	Using Flexible Sub-Products
	Moving the Components of a Sub-Product in the Parent Product
	Applying Overload Position on Reference during Rigidification command 
	Reusing Your Product Structure
	Cutting, Copying, Pasting Objects
	Paste Special
	Replacing a Component
	Editing Components
	Modifying Component Properties
	Managing Graphic Properties in products
	Naming or Renaming a product
	Generating Numbering
	Displaying the Bill of Material (BOM)
	Managing the BOM
	Capacity not to take into account a component in BOM Extraction
	Searching on BOM Attributes
	Managing a Resource thanks to Resource Modeler
	Interactive Drafting
	Importing From Files
	IGES and STEP Interfaces
	3D IGES: Import
	3D IGES: Trouble Shooting
	3D IGES: Best Practices
	3D IGES: FAQ
	3D IGES: VBScript Macros
	STEP: Import
	STEP: Trouble Shooting
	STEP: Best Practices
	STEP: FAQ
	STEP: VBScript macros
	IGES
	STEP
	DMU Navigator, DMU Dimensioning and Tolerancing Review
	Setting Up Your Session
	Entering the DMU Navigator Workbench
	Inserting Components
	Viewing the Selection
	Activating the Cache
	Viewing the Cache Content
	Searching for Named Objects
	Resetting Component Position
	Setting Current Position as Initial Position
	Importing a CAD Part
	Defining Groups
	Visualizing CATIA V4 Layer Filters
	Accessing CATIA V4 Comment Pages
	Modifying the Sag Value
	Creating a Point, Line, Plane or Axis System
	Moving Components
	Translating Components
	Rotating Components
	Positioning Components
	Applying a Transformation
	Snapping Components
	Snapping Components using Multiple Constraints
	Performing a Symmetry
	Rotating a Component by Using the Symmetry Command
	Navigating
	Navigating in Examine Mode
	Navigating in Walk Mode
	Navigating in Fly Mode
	Selecting Standard Views using the Viewpoint Palette
	Panning, Zooming, Rotating and Turning Head using the Viewpoint Palette 
	Changing Views
	Viewing against Ground
	Magnifying
	Looking At Objects
	Setting Lighting Effects
	Setting Depth Effects
	Annotating
	Adding 3D Annotations
	Managing 3D Annotations
	Creating Annotated Views
	Adding Pictures
	Adding Audio Markers
	Managing Annotated Views
	Editing Annotated Views Properties
	Using Temporary Markers
	Displaying Links
	Creating Hyperlinks
	Jumping to Hyperlinks
	Using Camera Capabilities
	About Cameras
	Creating and Displaying a Camera
	Editing Camera Properties
	Moving a Camera
	Selecting Standard Views
	Creating, Modifying and Deleting User-defined Views
	Using Generic Animation
	About Player
	About Track Capabilities
	Recording a Camera Track
	Using Track Editor and Recorder
	Copying and Pasting Tracks
	About Track Operators
	Editing Time Line in Tracks
	About Sequence Capabilities
	Using the Sequence Editor
	Defining a Sequence
	Detecting Interferences Automatically
	Recording Viewpoint Animations
	Converting a Simulation into a Sequence
	Recording a Simulation
	Generating a Replay
	Replaying Animations
	Generating a Video Using DMU-Dedicated Tool
	Managing Enhanced Scenes
	About Enhanced Scenes
	Creating an Enhanced Scene
	Generating an Enhanced Scene from an Old Scene
	Browsing Enhanced Scenes using the Scenes Browser
	Activating an Enhanced Scene
	Exploding an Assembly
	Overloading Attributes in Enhanced Scene Context
	Managing Attributes Overloads
	Adding, Replacing and Deleting Components in the Assembly
	Checking Component Position
	Saving a Viewpoint in Enhanced Scene Context
	Creating an Enhanced Scene Macro
	Applying an Enhanced Scene Context to an Assembly
	Applying an Assembly Context to an Enhanced Scene
	Automating Enhanced Scene Context Application Using User-defined Attributes
	Saving an Enhanced Scene in ENOVIAVPM
	Exiting Enhanced Scene Context
	Spatial Query
	About Spatial Query
	Running a Proximity Query
	Running a Proximity Query on a Large Assembly
	Running a Zone Query
	3D XML Compatibility with V6
	DMU 2D Workshop
	Entering the 2D Workshop
	Inserting 2D Documents
	Manipulating 2D Drawings
	Creating an Annotated View
	Managing Annotated Views
	Exporting and Importing 2D Annotations
	Comparing Drawings
	Measuring Distance, Angle and Radius on 2D Documents
	Publishing 2D Documents
	Saving and Printing Image Captures
	Saving a 2D Document
	Overlaying 2D Drawings
	DMU Review
	About DMU Review
	Creating a Review
	Activating a Review
	Creating a Child Review
	Creating Applicative Data in a Review
	Reordering DMU Reviews and Associated Applicative Data
	Viewing Review Content
	Activating a Parent Review
	Copying Applicative Data
	Copying a Review
	DMU Presentation
	About Presentations
	Creating a Presentation
	Opening a Presentation
	Previewing a Presentation
	Reordering Applicative Data Entities for a Presentation
	Modifying Visualization Settings for a Presentation
	Browsing Presentations
	Measuring
	Measuring Between
	Measuring Item
	Measuring Inertia
	Sectioning
	Creating Section Planes
	Creating 3D Section Cuts
	Manipulating Planes Directly
	Positioning Planes On a Geometric Target
	Positioning Planes Using the Edit Position and Dimensions Command 
	More About the Section Results Window
	Instant Collaboration
	About Instant Collaboration
	Accessing Instant Collaboration
	Peer-to-Peer Collaboration
	Client/Server Collaboration
	Toolbars Description
	Conferencing
	Initializing a Conference on UNIX using the Backbone Driver
	Initializing a Conference on Windows using the Backbone Driver
	Initializing a Conference on Windows using the NetMeeting Driver
	Launching a Conference as Host
	Joining a Conference as Guest
	Leading a Conference
	Sharing Documents with other Conference Members
	Transferring Files
	Sending Messages to other Conference Members
	Customizing Conference Options
	Consulting Conference History
	Leaving a Conference
	Managing Applicative Data
	Importing Applicative Data from an Inserted Component
	Importing Applicative Data from a Document in Session
	Reordering Applicative Data
	DMU Data Flow Processes
	About DMU Data Flow Processes
	Sharing a Mock-up with another Site
	Studying a Variant
	Preparing a Design Review
	Archiving a CATProduct and Related Documents
	Sharing a Stand-alone Light Copy of a Mock-up
	Running Batch Processes
	Running the CATDMUUtility Batch Process
	Running the CATDMUUtility2D Batch Process
	Running the CATDMUCacheSettings Batch Process
	Running the CATDMUCacheLocator Batch Process
	Running the CATDMUCacheManager Batch Process
	Running the CATDMUBuilder Batch Process
	Running the CATDMUDistributor Batch Process
	Running the CATDMUV4CacheForV5 Batch Process
	Running the CATDMUSaveAsFrozen Batch Process
	Writing and Running a Macro
	Automating Repetitive Tasks Using Macros
	Recording a Macro
	Running a Macro
	Editing a Macro
	Creating a Macro From Scratch
	Inserting a Document from a Webpage
	Directly Inserting a DMU document from the Windows Explorer
	Visualizing 3D Annotations
	Visualizing 2D Annotations
	Visualizing Annotation Related Surfaces
	Filtering Annotations
	Mirroring Annotations
	Going to Hyperlinks
	Managing 3D Annotations in 3D XML Files
	Wireframe and Surface
	Defining an Axis System 
	User Tasks
	Before You Begin
	Using the Sketcher Grid
	Using Tools for Sketching
	Using Colors
	Cutting the Part by the Sketch Plane
	Defining a Visualization Mode for Sketcher Elements
	Defining a Visualization Mode for Wireframe Elements
	Converting Standard/Construction Elements
	Hiding or Showing the Sketch Absolute Axis
	Entering the Sketcher Workbench
	Creating a Positioned Sketch
	Changing a Sketch Support
	Sketching Simple Profiles
	Creating Profiles
	Creating Rectangles
	Creating Circles
	Creating Three Point Circles
	Creating Arcs
	Creating Three Points Arcs
	Creating Three Points Arcs Using Limits
	Creating Splines
	Connecting Curves with a Spline
	Connecting Curves with an Arc
	Creating Ellipses
	Creating Parabola by Focus
	Creating Hyperbola by Focus
	Creating Conic Curves
	Creating Standard or Construction Elements
	Creating Lines
	Creating an Infinite Line
	Creating a Bi-Tangent Line
	Creating a Bisecting Line
	Creating a Line Normal to a Curve
	Creating Symmetrical Extensions
	Creating an Axis
	Creating Points
	Creating Points Using Coordinates
	Creating Equidistant Points
	Creating Points Using Intersection
	Creating Points Using Projection
	Sketching Pre-Defined Profiles
	Creating Oriented Rectangles
	Creating Parallelograms
	Creating Elongated Holes
	Creating Cylindrical Elongated Holes
	Creating Keyhole profiles
	Creating Hexagons
	Creating Centered Rectangles
	Creating Centered Parallelograms
	Performing Operations on Profiles
	Creating Corners
	Creating Chamfers
	Trimming Elements
	Breaking and Trimming
	Closing Elements
	Complementing an Arc
	Breaking Elements
	Breaking/Trimming Use-Edges
	Trimming Multiple Elements
	Creating Mirrored Elements
	Moving Elements by Symmetry
	Translating Elements
	Rotating Elements
	Scaling Elements
	Offsetting Elements
	Creating Spline Offsets
	Projecting 3D Elements onto the Sketch Plane
	Projecting 3D Silhouette Edges
	Intersecting 3D Elements with the Sketch Plane
	Copying/Pasting Elements
	Isolating Projections and Intersections
	Creating Output Features
	Creating Profile Features
	Editing Constraint Tolerances
	Editing Sketches
	Modifying Element Coordinates
	Performing Auto-Search on Profiles
	Transforming Profiles
	Editing Conic Curves
	Editing Connecting Curves
	Editing a Spline
	Editing Spline Offsets
	Editing Parents/Children and Constraints
	Editing Projection/Intersection marks
	Replacing Geometry
	Deleting Sketcher Elements
	Upgrading Features 
	Analyzing the Sketch
	Performing a Quick Geometry Diagnosis
	Analyzing Sketched Geometry
	Analyzing Projections and Intersections
	Setting Constraints
	Before you Begin
	Quickly Creating Dimensional/Geometrical Constraints
	Defining Constraint Measure Direction
	Modifying Constraints
	Creating Constraints via a Dialog Box
	Modifying Constraints On/Between Elements
	Fixing Elements Together
	Auto-Constraining a Group of Elements
	Animating Constraints
	Edit Multi-Constraint
	Analyzing and Resolving Over-Constrained or Inconsistent Sketches 
	SmartPick
	Before You Begin
	SmartPicking ...
	Creating Geometry Using SmartPick
	Deactivating a Sketch
	Creating Points
	Creating Multiple Points and Planes 
	Creating Lines 
	Creating An Axis 
	Creating Polylines
	Creating Planes 
	Creating Planes between Other Planes
	Creating Circles 
	Creating Projections 
	Creating Intersections 
	Creating Splines
	Creating Extruded Surfaces 
	Creating Revolution Surfaces 
	Creating Spherical Surfaces 
	Creating Cylindrical Surfaces 
	Creating Offset Surfaces
	Creating Filling Surfaces
	Creating Boundaries 
	Extracting Geometry 
	Rotating Geometry 
	Translating Geometry 
	Performing a Symmetry on Geometry 
	Transforming Geometry by Scaling 
	Transforming Geometry by Affinity 
	Transforming Elements From an Axis to Another 
	V4 Integration
	User Tasks 
	Workbench Description
	Index 




