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Introduction
Cimmetry Systems Corp. has developed a family of products designed to meet all 
levels of business and engineering needs. Collectively, our products provide 
viewing and Markup capabilities and support the visualization of 2D engineering 
and office formats.

AutoVue
AutoVue is a viewing and Markup application that has been developed for both 
business and technical users.
AutoVue is capable of displaying over 450 different file formats without the 
authoring application. Supported file types include text, database, graphic and 
spreadsheet. Even contents of archive files can viewed in AutoVue. Moreover, 
when you view a file you do not need to specify the file type. AutoVue 
automatically detects the type of file you are requesting to view — even files 
with false extensions!

Marking Up Documents
AutoVue has the ability to create markups for all its readable file formats without 
the document's authoring application.  AutoVue creates markups for different 
formats without modifying the original file.
You can attach comments, notes and drawings to any file you display in 
AutoVue. This is called marking up a file, commonly known as annotating or 
redlining. A Markup is an object or entity that you attach to a file. All Markups 
are saved in a separate file called a Markup or a Markup file. However, when 
you display a file with its Markups, the Markups appear to be part of it.
AutoVue provides a variety of flexible, user-friendly entities. To name a few, 
there are circles, clouds, polygons and leaders. You can also attach text to 
entities, insert a note for longer comments or add a symbol such as a company 
logo. In addition, you can create measurement markup entities and hyperlinks 
that link between the current file and other associated files or applications.
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Starting AutoVue
1 From the Windows Start menu, select Programs > AutoVue, Desktop 

Edition > AutoVue....
or...
From the Windows Start menu, select Run.
The Run dialog appears.
Enter the path and filename for avwin.exe.
Example:  C:\Progra~l\av\avwin\avwin.exe
Click OK.
The main AutoVue window appears.

Note  After starting AutoVue, an AutoVue icon  appears in the system 
tray located on the far right side of the task bar. This icon is always 
accessible after exiting AutoVue since AutoVue continues running until you 

close AutoVue completely. Right-click the AutoVue icon  to access the 
system tray Quick Menu. To resume working with AutoVue, double-click 
the icon or right-click the icon and select Restore AutoVue from the 
Quick menu.

Exiting AutoVue
1 Select File > Exit from the AutoVue main menu.

or...

Click the Close icon  in the upper right corner of the window.
or...

From the system tray, right-click the AutoVue icon  and select Close 
AutoVue from the Quick Menu.
AutoVue closes completely and the icon disappears from the system tray.
Cimmetry Systems Corp.
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Help About
AutoVue provides a Help menu that allows you to easily access information on 
how to use AutoVue.
From the Help About dialog, you can see information about your current 
installation of AutoVue. Information such as the variation of AutoVue you are 
using, the version, the build number and the current language that AutoVue is 
running is displayed. You can also enter a new license key and/or change the 
localization of the AutoVue user interface.
Cimmetry Systems Corp.
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Changing the Locale of 
AutoVue
AutoVue supports different localizations for the User Interface. If you wish to 
switch to a different language, you can do so from the Help -> About dialog. 
AutoVue supports the following localizations: English, French, German, 
Chinese, Japanese and Korean. 
1 Select Help > About from the AutoVue main menu.

The About dialog appears.

2 Click Change Language. 
The Language Change dialog appears.

3 From the New Language drop-down list, select the language you want to 
change to.

4 Click OK.
5 Click OK in the About dialog. 
6 Restart AutoVue for the new localization to take effect.
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Entering a New License Key
You can specify a new license key from the Help > About dialog. If you have a 
DEMO or an EVAL installed and you would like to switch to a fully functional 
license, you can do so from this dialog, or if you would like to switch from one 
variation of AutoVue to another. 
1 Select Help > About from the AutoVue main menu.

The About dialog appears.

2 Click Enter New License Key. 
The License Key dialog appears.

3 Enter the New License Key.
4 Click OK.
5 Click OK in the About dialog.
6 Restart AutoVue for the new license key to take effect.
Cimmetry Systems Corp.
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Note  If you are switching from a 2D/Office variation of AutoVue to a 3D/
EDA variation, you will be prompted to re-run the installer for AutoVue. 
Rerun the installer and select Modify. AutoVue will install all required 
components as per your license.
Note  If your evaluation or Demo license expires, you will not be able to 
startup AutoVue. When you try to startup AutoVue, it will prompt you for a 
license key. Enter a license key in order to be able to continue working with 
AutoVue.
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Viewing and Exporting File 
Versions Information
From the Help About dialog, you can view the version, build number and date 
of the decoder dll files, as well as export the files into a text file.

Viewing File Versions
1 Select Help > About from the AutoVue main menu.

The About dialog appears.

2 Click Version Info....
Cimmetry Systems Corp.
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The File Versions dialog appears.

3 When you are finished viewing, Click OK.

Exporting File Versions
1 Select Help > About from the AutoVue main menu.

The About dialog appears.
2 Click Version Info....

The File Versions dialog appears.
3 Click Export....

The Export dialog appears.
4 Navigate and select the directory you want to export the file to.
5 Enter a File name with the extension .txt.

Note  The file can only be exported to text file.
6 Click Save.

The markup file is exported to the selected directory.
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AutoVue Basics
This section introduces you to the basics of working with AutoVue’s graphical 
user interface.

Menu Bar
The Menu bar is the main access to all the menu commands. The selection of 
commands changes according to the tasks being accomplished by AutoVue. In 
Cimmetry Systems Corp.
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addition, the Menu bar can be configured to include and exclude items via DDE 
scripting capabilities. For more information, see the AutoVue API Manual.

Toolbars
Toolbars are fully adaptable to individual work preferences and can be easily 
customized, moved or removed. The Toolbar icons offer easy access to the 
options presented in the drop-down menus found in the Menu bar.

Status Bar
In both View mode and Markup mode, there is a Status bar located at the 
bottom of the main window. The fields displayed from left to right on the Status 
bar are: marker, current active filename, file type, zoom factor, current page and 
total number of pages, current active file size, file creation date and cursor’s 
coordinate position.
In addition to the fields, there are two markers that may be present on the Status 
bar.

The red light bulb  indicates that the current active file has associated 
Markups. While in View mode, click the red light bulb to view the Markup 
Files dialog, then select a Markup file or group of Markup files to open. By 
opening a Markup file, Markup mode is automatically launched.

A red circle with an “i”  indicates that some main resources required to 
properly read the current active file are not available. To identify the missing 
resources, click the red circle to display the File Properties dialog.

Quick Menus
One of the quickest ways to access options is through Quick Menus  or 
context-sensitive shortcut menus. These are the menus you see when you right-
click in the workspace. The Quick Menu options available depend on the mode 
you are in and what is selected prior to right-clicking.
Cimmetry Systems Corp.
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Opening Files with AutoVue
How to open files depends on the current active mode in AutoVue. In View 
mode, you can open base files. In Markup mode, you can open a Markup file for 
a base file.
You can browse files in a directory, open files simultaneously and view the 
contents of archive files.

Opening a File
1 Select File > Open from the AutoVue main menu.

The Open dialog appears.
2 Enter a File name or browse to locate the file that you want to open. 
3 Click Open.

The file appears in the AutoVue workspace.

Opening Multiple Windows
By default, AutoVue keeps one file open at a time. If you open a new file, the 
currently opened file is replaced with the new file. However, it is possible to have 
multiple files open by creating windows within AutoVue.
1 Select Window > New from the AutoVue main menu.

A new window appears on top of the opened file.
2 Select File > Open.

The Open dialog box appears.
3 From the Look in drop-down list, select the file that you want to open or 

enter the File name. 
4 Click Open.

The file appears in the new window.
Note  You can open as many windows as you like by selecting Window > 
New and repeating steps 2 to 4.

Viewing Multiple Files at the Same 
Time
You can arrange the files so you can view them at the same time.
Cimmetry Systems Corp.
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Select Window > Cascade if you want the files to appear on top of each other.
Select Window > Tile Horizontally if you want the files to appear side by side.
Select Window > Tile Vertically if you want the files to appear above each 
other.

Browsing Files
When you use the Browse option, all files and folders in the current directory 
are displayed in the Browse dialog and the last file opened is highlighted.
1 Select File > Browse from the AutoVue main menu.

The Browse dialog appears listing the files located in the current active 
directory.

Note  You can also click the Browse icon  on the AutoVue toolbar.
2 To change the current active directory, type the full path of the directory in 

the text field at the top of the Browse dialog.
The list of files contained in the directory appear.

3  Select the file that you want to view.
The file is displayed in the AutoVue workspace.

4 Continue selecting and viewing files as often as you like since the Browse 
dialog box floats over the other AutoVue windows.

5 Click Close to close the Browse dialog.
The last file displayed remains open.
Note  You can also browse files in the current active directory by selecting 

File > Next File or Previous File or by clicking the Next File icon  or 

the Previous File icon  on the AutoVue toolbar.

Archive Files
The full archive file directory displays in the AutoVue window. It is not 
necessary to decompress the file. Double-click a file to display it within 
AutoVue. If you would like to markup an archive file, the file must be accessible 
for AutoVue in a format other than archive.
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Viewing File Properties
You can access the file properties from the File menu. The Properties dialog 
provides information specific to the current active file, such as filename, file size, 
date of creation and file type. The file properties that you can view are:

Note  The file properties can vary depending on the file format viewed.
1 Select File > Properties from the AutoVue main menu.

The Properties dialog appears.
2 To view file properties, click the File Properties tab.

To view resource information, click the Resource Information tab.
To view native properties, click the Native Properties tab.

3 Click OK to close the dialog.

Selecting
The Select option is available when viewing graphic and non-graphic files. For 
non-graphic files, you can only select text, click and drag to the select text.
1  Select Edit > Select from the Autovue main menu.

A checkmark appears beside Select.
2 In the graphic file, click and drag the area you want to select.
3 To select a block of text, database or spreadsheet cells, etc., position the 

cursor at the beginning of the block, then while pressing the Shift key click 
at the end of the block.

4 To copy the selected data, select Edit > Copy or press Ctrl+C.
The data is sent to the clipboard.
Note  To exit Select mode, select Edit > Select. The checkmark 
disappears.

Property Description

File Information specific to the current active file, such as filename, file 
size, date of creation, file type and x, y & z dimensions.

Resource 
Information

Resources specific to the current active file, such as text font, 
shape file, line style and external reference files.

Native Custom properties for file types, such as last person who saved the 
file, signature verification and author comments.
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Associations
Files of a particular file extension can be associated with an application other 
than AutoVue. These files can be opened by the associated application for 
viewing, editing and printing. For example, you can configure WordPerfect to 
open all .wpd files for viewing and printing,  while you are operating AutoVue. 
If you have a file with a non-standard extension, this option can associate that 
particular file with AutoVue. 
Note  Since only files and programs of the same type can be associated, select 
programs that use the same extensions for their files as the current active file.

Creating an Association
1 Select File > Associate from the AutoVue main menu.

A dialog appears with the full path of the current active file displayed in the 
title bar.

2 Enter a description for the association (optional).
3 In the Command Line, enter the full path or click Browse to locate the 

program that you want to associate with the current file.
4 Click OK.
5 To activate the association, select File > Launch.

The associated program is launched.

Removing an Association
1 Select File > Associate from the AutoVue main menu.

A dialog appears with the full path of the current active file displayed in the 
title bar.

2 Click Remove.
The associated program file disappears.

3 Click OK to close the dialog.

Activating an Association
1 Open the file that you want to activate an association, then select File > 

Launch from the AutoVue main menu.
The associated program is launched.
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Working With 2D Files
AutoVue provides easy access to entity information and displays color-coded 
comparative data for 2D drawings. You can instantly manipulate how the current 
active file is displayed. You can also modify AutoVue to suit your needs and 
preferences through a broad range of configuration options.

Searching Text
You can perform a text search on 2D vector and text-based documents.
Note  You can not perform a text search on raster files.
AutoVue provides search options that you can use to customize a search. These 
options are:

To perform a text search:
1 Select Edit > Search from the Autovue main menu.

The Find dialog appears.
2 In the Find What text box, enter the word or phrase that you want to find.

Note  If you are searching in a vector file, select a text string from the list.
3 Customize your search.
4 Click Find Next.

AutoVue highlights the text and zooms into the text area.
5 Click Cancel to close the Find dialog.

Note  To repeat the last search criteria, select Edit > Repeat Search from 
the AutoVue main menu.

Option Description

Match Whole Word Only Match a complete word.

Match Case Search for a word or text string with specific 
capitalization.

Up Search backward in the document.

Down Search forward in the document.
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Manipulating 2D Views
With the View options you can instantly manipulate how the current active file is 
displayed. You can rotate a file’s orientation counterclockwise by 90, 180 or 270 
degrees, flip a file’s orientation horizontally, vertically or both simultaneously.
AutoVue provides several ways to change the view size of a selected area of a 
file, display different views, layers and blocks of the current active file. You can 
also navigate from one page to another page of a multi-page file.
You can access these options from the View menu. The options are:

Menu Option Description

Zoom In Zoom in by a factor of 2.

From toolbar click  icon.

Out Zoom out by a factor of 2.

From toolbar click  icon.

Full  Resolution Display the file at full resolution.

From toolbar click  icon.

Fit Adjust the horizontal or vertical axis of a file to 
fully display within the current window.

Fit Both - AutoVue finds the best fit for the 
current file with respect to both its vertical and 
horizontal dimensions.
Note  This option is also known as Zoom Fit 
when right-clicking in the workspace.

Fit Vertical - Fit the image vertically in the 
active window. The horizontal dimensions of 
the image are zoomed proportionally but may 
be too large or small for the window.
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Fit Horizontal - Fit the image horizontally in 
the active window. The vertical dimensions of 
the image are zoomed proportionally but may 
be too large or small for the window.
Note  This option is also know as Zoom 
Page Width when right-clicking in the 
workspace.

Previous Revert to the previous selected zoom option.

Note  The Rotate option is disabled for text-based documents and spreadsheets.

Rotate 0 Set the file to its original position.

From toolbar click  icon.

90 Rotate the file 90 degrees anti-clockwise.

From toolbar click  icon.

180 Rotate the file 180 degrees anti-clockwise.

From toolbar click  icon.

270 Rotate the file 270 degrees anti-clockwise.

From toolbar click  icon.

Note  When in Markup mode, you can specify if the rotate is to be applied to the 
Markups only or to the base file and Markups.

Note  The Flip option is disabled for text-based documents and spreadsheets.

Flip None Reset the drawing to its original position.

Horizontal Axis Flip the drawing on its horizontal axis.

Vertical Axis Flip the drawing on its vertical axis.

Both Axes Flip the drawing on its vertical and horizontal 
axes.

Note  When in Markup mode, you can specify if the flip is to be applied to the 
Markups only or to the base file and Markups.

Menu Option Description
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Note  The Image option is used for black-and-white (monochrome) raster files.

Image Contrast Light, normal, dark and darkest.

Anti-alias Enhance the details of monochrome raster files.
Note  Also known as “Scale to Grey”.

Invert Reverse the background and foreground colors.

Page Next Page Go to the next page of a multi-page file. 

From toolbar click  icon.

Previous Page Go to the previous page of a multi-page file.

From toolbar click  icon.

Page Number Go to the specified page of a multi-page file.

From toolbar click  icon.

Special View 
Modes

Birds Eye Display a close-up view of a particular area of a 
file while maintaining a view of the entire file.

From toolbar click  icon.
Note  The Birds Eye option is disabled for 
text-based documents and spreadsheets.
See    Using Bird’s Eye View

Magnify Glass Magnify an area of the file that is specified by 
the cursor location.

From toolbar click  icon.
See  Using the Magnifying Glass

Magnify Window Magnify a selected area of a file and displays it 
in the Magnify Window.

From toolbar click  icon.
See   Using the Magnifying Window

Pan Click and drag to move the drawing. To exit 
right-click.

Menu Option Description
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Using Birds Eye View
The Birds Eye view option allows a close-up view of a particular area of a file 
while maintaining a full view of the file. The Birds Eye window displays a 
miniature version of the file. A movable box frame on top of the miniature 
indicates the area of the file displayed in the AutoVue workspace.
Note  The Birds Eye option is disabled for text-based documents and 
spreadsheets.
1 Select View > Special View Modes > Birds Eye from the AutoVue 

main menu. 
The Bird’s Eye window appears displaying a full view of the file.

2 To view the changes in “real time”, select Options > Dynamic from the 
Birds Eye menu.

3 To view a close-up of a specific area of the file in the AutoVue workspace, 
minimize the frame box by clicking and dragging the frame handles.
To view a different area of the file in the AutoVue workspace, click and drag 
the frame box to the area that you want to view.
Note  If you perform a zoom function in the AutoVue workspace, the area 
displayed in the workspace is highlighted by the frame box in the Birds 
Eye window.

4 Select Bird’s Eye > Exit to close the Bird’s Eye dialog.
The last view performed remains in the AutoVue workspace.

Using the Magnify Glass
The Magnify Glass view option zooms an area specified by the position of the 
Magnify Glass. You can view the details of a selected area of a file while 
maintaining a full view of the file.
1 Select View > Special View Modes > Magnify Glass from the 

AutoVue main menu.

Note  You can also click the Magnify Glass icon  on the AutoVue 
toolbar.

Show Tree Show/hide the Model tree of the current 
active file.

Menu Option Description
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2 Move the cursor to the area that you want to magnify.
3 Click and hold the left mouse button. 

The area is magnified in the Magnify Glass.
Note  To view different areas of the file, click and drag the mouse.

4 Right-click to exit Magnify Glass.

Using the Magnify Window
The Magnify Window option zooms an area specified by the position of the 
cursor. You can view the details of a select portion of the displayed file while 
maintaining the display of the full file.
1 Select View > Special View Modes > Magnify Window from the 

AutoVue main menu. 
The Magnify Window appears.

Note  You can also click the Magnify Window icon  on the AutoVue 
toolbar.

2 Move the cursor to the area that you want to magnify in the current active 
file.

3 Click once. 
The area appears magnified in the Magnify Window.

4 Right-click to exit the Magnify Window.

Conversion
Sometimes you need to translate a file to be able to use it with an application it 
was not created from. AutoVue provides several conversion file formats for you.
Cimmetry Systems Corp.



AutoVue 21
Conversion Options
Depending on the conversion type being performed, the available options in the 
Convert dialog will vary. These options are:

Option Description

Color Depth Select an option from the drop-down list:
• 1 = Black and white
• 4 = 16 colors
• 8 = 256 colors
• 24 = True color
• auto = AutoVue selects the color depth that best 

matches the original file.

Convert to Format A drop-down list of all the possible types of output file 
formats currently available for conversion. The available 
formats are:
• CALS GP4
• Encapsulated Postscript (Raster)
• HP Laserjet Printer (HLP)
• PCX Bitmap
• PDF
• Run Length RLC File
• TIFF
• Windows Bitmap 

Output Specify the name and path of the file in which the con-
version is to be stored.  This file is also known as the 
output file. You can use Browse to provide AutoVue 
with the file’s path.

Sub-Format The Sub-Format drop-down list appears when you 
selected HP Laserjet Print or TIFF from the 
Convert to Format drop-down list. Select a sub-
format from the drop-down list..
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PDF
With AutoVue it is possible to convert Office, 2D and EDA formats to PDF. 
When converted from Markup Mode, markups are “burned” onto the PDF. 
When you open the PDF, you will see the base file along with all markups.

X and Y
Three factors affect the resolution of an image:  the type of image you are 
scanning, the output device and the acceptable file size. High-resolution scans 
often require large files, causing longer processing and print time. Note that a 
high-resolution may not produce a better-quality printed image if your output 
device does not recognize the higher resolution information stored in the file. To 

Convert Region The area of the file to be converted. The available 
options are:
• Display - the area displayed in the workspace.

For example, if you zoomed in on a particular 
region of the file, the zoomed portion of the file is 
converted.

• Extent  - refers to the entire extents of the file.

Convert Pages The number of pages to be converted. The available 
options are:
• All - convert all pages
• Current  - convert the current page
• Range - convert the pages indicated in the range

X and Y Choose from pixels, inches and millimeters for the units.
Note  With raster files the units are preset as pixels:  
• X indicates the number of horizontal pixels
• Y is the number of vertical pixels for the current 

active file contents. 
At times, AutoVue will preset X and Y to match the 
specifications of the selected conversion file format. 
Other times, X and Y will be available and may be 
changed according to your preferences.  Your selection 
here will not affect the current display but will affect the 
conversion file’s resolution.

Option Description
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keep file sizes manageable, select the lowest resolution that provides acceptable 
quality on your output device.
With some file types, the Size option appears giving you a choice between 
millimeters and inches. Page sizes can be selected from the Size drop-down list 
or you can customize page sizes by configuring the Initialization file. For more 
information, see System Administration Guide.

Converting a File
1 Select File > Convert from the AutoVue main menu.

The Convert dialog appears.
Note  The Input area varies according to the type of file. A word-
processing file displays the file format; a raster file displays the file format 
and size;vector and database files display the size, file type and dimensions.

2 In the Save As text box, enter the path and filename or click Browse to 
locate the directory where you want to save the converted file.
Note  If writing on to an existing file, the contents of the output file will be 
overwritten.

3 Specify the conversion options.
See  Conversion Options

4 Click OK. The file is converted and appears in the specified directory.
Note  You can convert several selected pages of a multi-page file to a multi-
page TIFF.
See Also  Batch Conversion

Changing the Pen Settings
With AutoVue, you can specify a thickness for each pen color.

Technical Drawing Page Sizes ISO Paper Format

A8.5” X 11.0” (216 mm X 279 mm) A4  285 mm X 198 mm

B11.0” X 17.0” (279 mm X 432 mm) A3  396 mm X 273 mm

C17.0” X 22.0” (432 mm X 559 mm) A2  570 mm X 396 mm

D22.0” X 34.0” (559 mm X 864 mm) A1  817 mm X 570 mm

E34.0” X 44.0” (864 mm X 1118 mm) A0  1165 mm X 817 mm
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Note  This option only applies to vector files.
1 Select File > Convert from the AutoVue main menu.

The Convert dialog appears.
2 Click Pens.

The Pen Settings dialog appears.
3 In the From/To, select the Color Index for which you want to modify the 

thickness.
Note  To select more than one Color Index, click the Shift or Ctrl key 
while selecting.

4 From the Units drop-down list, select the unit in which you want to set the 
thickness.

5 Click Thickness.
The Modify Pen Thickness dialog appears.

6 Enter a thickness.
7 Click OK.

The new Thickness appears beside the selected Color Index.
8 To save the changes that you made, click Save As.

The Save As dialog appears.
9 Enter a Name for the new pen settings.
10 Click OK.

The new pen settings are saved and appear in the Current Pen Settings 
list.
Note  To modify an existing Pen Settings, select the pen settings from the 
Current Pen Settings drop-down list, make the changes, then click 
Save.

11 Click OK to close the Pen Settings dialog.

Batch Conversion
You can save time by simultaneously converting files with the same output file 
format.
1 Select File > Convert from the AutoVue main menu.

The Convert dialog appears.
2 Click Batch Convert.

The Batch Convert dialog appears.
3 Click Add. The Open dialog appears.
4 Enter the File name or browse to locate the file that you want to add, then 

click Open.
The file appears in the Input File List.
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Note  To add more files, repeat steps 3 to 4. To remove a file, select the file 
from the Input File List and click Remove.

5 Customize the convert options.
See   Converting a File

6 Click OK.
AutoVue stores the newly converted file(s) in the same directory as the first 
file you entered in the Input File List.

Measuring in 2D non-vector Files
AutoVue provides the ability to perform measurements in 2D files. Measure 
options vary between vector and non-vector files. For vector files, AutoVue 
provides the option to “snap” to fixed points on the drawing. For non-vector files, 
you can only “free snap”.
AutoVue provides several measure options that you can choose from.You can 
access the measure options from the Analysis > Measure menu. The options 
are:

Measuring Distance
Use the Distance option to measure the distance between two specific points.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Name Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure an arc.

From toolbar click  icon.

Area Measure a selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.
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Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure the distance.
Note  If you want to measure the distance along a path, select Cumulative.

4 Click a point on the drawing to define the starting point.
5 Click another point on the drawing to define the end point.

Note  If you selected Cumulative, continue clicking points along the path 
that you want to measure.

6 Right-click to complete the measurement.
The points are joined by a line. The measured distance, Delta-X and Delta-Y 
appear in the Measurement dialog.
Note  Click Reset to take another measurement.

7 Click Close to close the Measurement dialog.

Calibrating Distance
1 Measure distance between two points or measure cumulative distance.

See  Measuring Distance
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.

3 From the Measured Dist. drop-down list, select the unit to which you want 
to calibrate the distance.

4 Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

5 Click OK.
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
1 Select Analysis > Measure from the AutoVue main menu.The 

Measurement dialog appears.

Note  You can also click the Area icon  on the AutoVue toolbar.
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2 Click the Area tab.
3 From the Measured Area Units drop-down list, select the unit in which 

you want to measure the area.
From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.
Note  To cumulate a Net Area Result of different areas, select Add in the 
Measurement dialog. To subtract an area from the Net Area Result, 
select Subtract. Select Clear to clear the Net Area Result.

4 Click a point on the drawing to define the starting point.
5 Continue clicking points on the drawing to define the area you want to 

measure.
Each point is joined by a line. The area and perimeter measurements appear 
in the Measurement dialog.

6 Right-click to complete the measurement.
Note  Click Reset to take another measurement.

7 Click Close to close the Measurement dialog.

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the AutoVue toolbar.
2 Click the Angle tab.
3 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
4 Click points on the drawing to define the angle you want to measure.

Angle arms appear with an arc connecting them. The angle measurement 
appears in the Measurement dialog.
Note  Click Reset to take another measurement.

5 Click Close to close the Measurement dialog.

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.
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Note  You can also click the Arc icon  on the AutoVue toolbar.
2 Click the Arc tab.
3 From the Arc Info drop-down list, select the unit in which you want to 

measure the arc.
4 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
5 Click points on the drawing to define the arc.

The points are joined by an arc. The measurements for center point 
coordinates, radius, diameter, arc length, start and end of angle and sweep 
appear in the Measurement dialog.
Note  Click Reset to take another measurement.

6 Click Close to close the Measurement dialog.

Calibrating an Arc
1 Measure an arc in the drawing.

See  Measuring an Arc
2 In the Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
3 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate the distance.
4 Click Calibrate to and enter a value if you want to calibrate to a value.

Click Set Factor and enter a value if you want to calibrate by a factor.
5 Click OK. 

The calibration result appear in the Measurement dialog.
6 Click Close to close the Measurement dialog.

Working with 2D Vector Files
In addition to all features that are available for generic 2D files, AutoVue 
provides the ability to access entity information, access views saved in the 
drawing and the ability to “intelligent snap” when performing measurements.
AutoVue references various sources to obtain all data required to completely and 
accurately display vector files. These sources can be internal to the file, like 
layers and blocks or external reference files that are located outside the file.
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Manipulating 2D Vector Views
With the View options you can instantly manipulate how the current active file is 
displayed. You can rotate a file’s orientation counterclock-wise by 90, 180 or 270 
degrees, flip a file’s orientation horizontally, vertically or both simultaneously.
AutoVue provides several ways to change the view size of a selected area of a 
file, display different views, layers and blocks of the current active file. You can 
also navigate from one page to another page of a multi-page file. For more 
information on how to manipulate views, see Manipulating 2D Views.
For 2D vector files, there are additional View options:

Drawing Information
The Drawing Information option is available with AutoCAD and 
MicroStation drawings, and is accessed from Analysis of the AutoVue main 
menu in both View and Markup modes. The Drawing Information options 
available are: Select Single Entity, List Tags/Attributes and Entity 
Information.

Viewing Details of a Single Entity
Note  This feature is currently not supported with AutoVue Server running on 
Unix Platforms. 

Option Description

Views Select and display different views of a drawing.

From toolbar click  icon.
See   Selecting Views

Layers Select and display different layers of a drawing.

From toolbar click  icon.
See  Layers

Blocks Select and display a block from a drawing.

From toolbar click  icon.
See  Blocks
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1 Select Analysis > Drawing Information > Select Single Entity from 
the AutoVue main menu.

2 Click the entity for which you want to view information.
The Get Entity Info dialog appears displaying the information for the 
selected entity.
The XData button appears if additional information exists for that entity. 
Click XData to view the information.
Note  If you did not select an entity, a message appears informing you that 
no entities were found and prompts you to select again.

3 Click OK to close the Get Entity Info dialog.

Viewing information for a Set of Entities
Note  This feature is currently not supported with AutoVue Server running on 
Unix Platforms. 
The Entity Information option allows you to view information of a set of 
entities contained in a specific area of a file.
1 Select Analysis > Drawing Information > Entity Information from 

the AutoVue main menu.
2 Click and drag to draw a box around an area for which you want to view 

entity information for the list of entities contained inside the area.
The List Entities dialog appears displaying the information of all the 
selected entities.
Note  If there are no entities within the selected area, a message appears 
informing you that no entities were found and prompts you to select again.

3 Click OK to close the List Entities dialog.

Viewing Tags/Attributes
Note  This feature is currently not supported with AutoVue Server running on 
Unix Platforms. 
1 Select Analysis > Drawing Information > List Tags/Attributes from 

the AutoVue main menu.
2 Click in the area of the file for which you want to view information on block 

attributes and tags.
The Block Attributes dialog appears displaying the attributes/tags for the 
selected entity.
Note  If there are no entities within the selected box, a message appears 
informing you that no entities were found and prompts you to select again.
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3 Click OK to close the Block Attributes dialog.

Viewing XRefs
AutoVue references various sources to obtain all the data required to completely 
and correctly display files. These sources can be internal to the file, like layers 
and blocks. External reference files or Xrefs are located outside the file.
Use the XRefs option to display the external references of the current active file.
1 Select View > XRefs from the AutoVue main menu.

The Select the External References to display dialog appears listing 
the external reference files associated with the current active file.

2 Select the checkbox beside the XRefs that you want to display.
Clear the checkbox beside the XRefs that you want to hide.

3 Click OK.
The selected XRefs are displayed.

Displaying Details About Missing XRefs
If a file has missing resources, a red circle with an “i”  appears to the left of 
the AutoVue status bar.

1 Click the Resource icon  on the AutoVue status bar.
The Properties dialog appears.
Note  You can also select File > Properties from the AutoVue main 
menu.

2 Click the Resource Information tab to display details about missing 
resource information required to properly display this file.

A green check mark  indicates the resources that AutoVue is able to 
access.

A red  indicates the external reference files or components that are not 
accessible.

3 Click OK to close the Properties dialog.

Layers
Use this option to configure the current active file’s layers to display.
1 Select View > Layers from the AutoVue main menu.
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The Select the layers to display dialog appears listing the layers and 
layer visibility for the current active file.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 To sort the list of layers in the dialog, click Name to sort alphabetically or 

numerically, or click Status to sort by visibility.
3 Select the checkbox beside the layers that you want to set visible.

Clear the checkbox beside the layers that you want to hide.
4 Click OK.

The selected layers are displayed.

Blocks
Use this option to select a block to display from the current active file.
1 Select View > Blocks from the AutoVue main menu.

The Select a block to display dialog appears listing the blocks for the 
current active file.

Note  You can also click the Block icon  on the AutoVue toolbar.
2 From the drop-down list, select the block that you want to display.
3 Click OK.

The selected block is displayed.

Selecting Views
The Views option allows you to access different named views of a file.
1 Select View > Views from the AutoVue main menu.

The Select a named view dialog appears.

Note  You can also click the View icon  on the AutoVue toolbar.
2 From the drop-down list, select the view that you want to display.
3 Click OK.

The selected view is displayed.

Specifying a View Point
The View Point option allow you to render a drawing from a selected 
viewpoint. The default view point is the one used to create the file.
1 Select View > View Point from the AutoVue main menu.

The View Point dialog appears.
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2 Enter the X, Y and Z coordinates for the viewpoint with which you want to 
render the drawing.

3 Click OK.
The drawing is displayed from the selected viewpoint.

Comparing 2D Files
AutoVue provides the ability to visually compare two files and display color-
coded comparative data. When you compare two files, Autovue displays three 
windows, the first containing the original file, the second containing the file you 
compared the original against, and the third containing the comparison results.
In the Comparison Result window you can specify whether you want to 
display only the additions, deletions or unchanged, or any combination of the 
three. To access these options, right-click in any window and select an option 
from the pop-up menu.
The comparison results are displayed in different colors to differentiate the 
results of the file comparison. The comparison options and corresponding colors 
are:

1 View the base file in AutoVue.
2 Select Analysis > Compare from the Autovue main menu.

The File Open dialog appears.
3 Enter the File Name or click Browse to select the file that you want to 

compare with the current active file.
4 Click OK.

AutoVue displays three windows, the first displaying the original file, the 
second displaying the compare file and the third displaying the comparison 
results.
Note  If you apply a change from the View menu, all three windows display 
the synchronized change.

5 To access the Compare options, right-click in any of the windows.

Option Color Description

View Additions Green Indicates that something has been added.

View Deletions Red Indicates that something has been deleted.

View Unchanged Blue Indicates that there is no change.
Cimmetry Systems Corp.



34 AutoVue
A pop-up menu appears displaying the Compare options.
Note  To maximize any of the windows, double-click the title bar of the 
window that you want to maximize. To restore the window, double-click the 
title bar.

6 To exit Compare mode, select File > Exit Compare Mode from the 
AutoVue main menu.
The original file appears in the workspace.
Note  You can also exit Compare mode by right-clicking in any of the 
windows and selecting Exit Compare Mode from the pop-up menu.
See Also   Specifying Scale and Offset for a Compare File

Specifying Scale and Offset for a Compare File
You can scale or translate a file in order to compare files accurately. With the 
Scale and Offset option you can modify the coordinates (XOffset and 
YOffset) or enter a scaling factor for the second file.
Note  XOffset and YOffset are relative to the base drawing and all options are 
displayed at their current values.
1 In Compare mode, select View > Scale and Offset from the AutoVue 

Main window.
The Scale and Offset dialog appears.

2 In the Scale and Offset dialog, enter the required values for the Scale 
Options: XOffset, YOffset and Scale.

3 Click OK.
The scaling/offset modifications are applied to the file in the second window.

Overlays
When working with 2D files, you can overlay other files over the current active 
file. You can also adjust an overlay, move an overlay, and scale an overlay by 
defining the X and Y coordinates and the scaling factor.

Adding an Overlay
Note  When working with a raster file, it should be used as the base file because 
raster formats are opaque and would hide files underneath them.
1 View the file that you want to use as the base file for the overlay.
2 Select Analysis > Overlays > Select from AutoVue main menu.

The File Open dialog appears.
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3 Enter the File Name or click Browse to select the file you want to overlay.
4 Click OK.

The base file is displayed with the selected overlay file on top of it.
Note  To lay multiple files over one base file, repeat steps 2 to 4 using the 
same base file. Overlays are added one at a time.

Modifying an Overlay
1 Select Analysis > Overlays > Modify from AutoVue main menu.

The Modify Overlay dialog appears.
2 Select the Overlay that you want to modify.
3 Click the Action that you want to apply to the overlay.

•   Click Move if you want to move the overlay. 
Click a point on the base file where you want to set the lower left corner 
of the overlay. Click another point where you want to set the upper right 
corner of the overlay.
Note As you select the point to define the position of the upper right 
corner, you can resize the destination box.

•   Click Scale if you want to resize the overlay. 
Enter the XOffset and YOffset coordinates and/or the Scale factor.
Note XOffset and YOffset are relative to the base drawing and all 
options are displayed at their current values.

•   Click Warp to adjust the overlay. 
Click a point on the overlay and drag the cursor to where you want the 
overlay starting point. Click another point and drag the cursor to where 
you want the overlay to end.
Note The overlay’s size is scaled to accommodate the origin and 
destination points you defined.

4 Click OK.
The changes are applied to the selected overlay.
Note  To modify other overlays, repeat steps 2 to 4.

Removing an Overlay
1 Select Analysis > Overlays > Modify from AutoVue main menu.

The Modify Overlay dialog appears.
2 Select the Overlay that you want to remove.
3 Click Remove.

A confirmation dialog appears.
4 Click Yes.
Cimmetry Systems Corp.



36 AutoVue
The overlay is removed from the list in the Modify Overlay dialog and 
from the display.

Measuring in 2D Vector Files
AutoVue provides the ability to perform measurements in 2D files. Measurement 
options vary between vector and non-vector files. For vector files, AutoVue 
provides the option to “snap” to fixed points on the drawing. For non-vector files, 
you can only “free snap”.
You can access the measure options from the Analysis > Measure menu. 
These options are:

2D Vector Snapping Modes
The Snapping Modes available allow you to click to precise geometrical 
points on a drawing. For example, if you select Snap to end-point and you 
move the cursor over an end-point of a line, the end-point will be highlighted by 
a snap box. 

Name Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure an arc entity.

From toolbar click  icon.

Area Measure selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.
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The Snapping modes allow you to snap to the mid, center and end-points of 
an entity:

Measuring Distance
Use the Distance option to measure the distance between two specific points.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See  2D Vector Snapping Modes

4 From the Measured Distance Units drop-down list, select the unit in 
which you want to measure the distance.
Note  If you want to measure the distance along a path, select Cumulative.

5 Click a point on the drawing to define the starting point.
6 Click another point on the drawing to define the end point.

Note  If you selected Cumulative, continue clicking points along the path 
that you want to measure.

7 Right-click to complete the measurement.

Icon Snap to Description

End-point Geometric snap mode where a snap box appears 
when moving the cursor near a linear component’s 
end point.

Mid-point Geometric snap mode where a snap box appears 
when moving the cursor near the halfway point of a 
linear component.

Center-point Geometric snap mode where a snap box appears 
when moving the cursor near the center of an 
elliptical component.

Free snap Allow snapping at any point on the drawing.
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The points are joined by a line. The measured distance, Delta-X and Delta-Y 
appear in the Measurement dialog.
Note  Click Reset to take another measurement.

8 Click Close to close the Measurement dialog.

Calibrating Distance
1 Measure distance between two points or measure cumulative distance.

See  Measuring Distance
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.

3 From the Measured Dist. drop-down list, select the unit to which you want 
to calibrate the distance.

4 Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

5 Click OK. 
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
1 Select Analysis > Measure from the AutoVue main menu.The 

Measurement dialog appears.

Note  You can also click the Area icon  on the AutoVue toolbar.
2 Click the Area tab.
3 Select Between Points if you want to measure the area between points on 

a drawing. Snapping Modes are enabled.
4 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See  2D Vector Snapping Modes

5 Select Shape if you want to measure the area of a predefined shape on the 
drawing. Snapping Modes are disabled.

6 From the Measured Area Units drop-down list, select the unit in which 
you want to measure the area.
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7 From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.

8 To cumulate a Net Area Result of different areas, click Add. 
To subtract an area from the Net Area Result, click Subtract.
Select Clear to clear the Net Area Result.

9 If you selected Between Points, click points on the drawing to define the 
area. 
Each point is joined by a line. The area and perimeter measurements appear 
in the Measurement dialog.

10 Right-click to complete the measurement.
11 If you selected Shape, click the edge of the predefined shape.

The shape is highlighted and the area and perimeter measurements appear in 
the Measurement dialog.
Note  Click Reset to take another measurement.

12 Click Close to close the Measurement dialog.

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the AutoVue toolbar.
2 Click the Angle tab.
3 Select From 3 Points if you want to measure the angle between three 

points. Snapping Modes are enabled. 
4 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See  2D Vector Snapping Modes

5 Select Between 2 lines if you want to measure the angle between two 
lines. Snapping Modes are disabled.

6 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

7 If you selected From 3 Points, click three points on the drawing to define 
the angle.

8 If you selected Between 2 Lines, click two lines on the drawing to define 
the angle.
Angle arms appear with an arc connecting them. The angle measurement 
appears in the Measurement dialog.
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Note  Click Reset to take another measurement.
9 Click Close to close the Measurement dialog.

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the AutoVue toolbar.
2 Click the Arc tab.
3 Select From 3 Points if you want to measure the arc between three points. 

Snapping Modes are enabled. 
Click the Snapping Modes that you want to select as the points for the 
measurement.
See  2D Vector Snapping Modes
Note  To select all Snapping Modes click All On. To clear all 
Snapping Modes click All Off.

4 Select Arc Entity if you want to measure a predefined arc. Snapping 
Modes are disabled.

5 From the Arc Info drop-down list, select the unit in which you want to 
measure the distance.

6 From the Measure Angle Units drop-down list, select the unit in which 
you want to measure the angle.

7 If you selected From 3 Points, click three points on the drawing to define 
the arc.
The points are joined by an arc. The measurements for center point 
coordinates, radius, diameter, arc length, start and end of angle and sweep 
appear in the Measurement dialog. 

8 If you selected Arc Entity, click the edge of the arc that you want to 
measure.
The arc is highlighted. The measurements for center point coordinates, 
radius, diameter, arc length, start and end of angle and sweep appear in the 
Measurement dialog.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
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Calibrating an Arc
1 Measure an arc in the drawing.

See   Measuring an Arc
2 In the Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
3 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate.
4 Click Calibrate to and enter a value if you want to calibrate to a value.

Click Set Factor and enter a value if you want to calibrate by a factor.
5 Click OK. 

The calibration result appears in the Measurement dialog.
6 Click Close to close the Measurement dialog.

Configuring AutoVue for 2D Files
In AutoVue, there are configuration options that allow you to customize the work 
environment when working with 2D vector and non-vector files. You can access 
the configuration options from Options > Configuration under the General 
tab. 

All 2D Files
The Force to Black option can be configured for all 2D files:

Vector Files
The configuration options for vector files are:

Option Description

Force to Black • If selected, AutoVue forces all colors of a drawing to 
black

• If cleared, the file will be displayed in color

Option Description

Text • If selected, text entities are displayed
• If cleared, no text is displayed
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Raster Files
The configuration options for Raster files are:

Snap Settings
With the Snap Settings option, you can configure the snap options for 
measuring. When you move the cursor within a predetermined snap radius, the 
snap box appears for the entity to be selected. The snap radius is configured in 
pixels. You can access this option from Options > Configuration dialog under 
the 2D tab.

Fonts • If selected, native fonts are used
• If cleared, a quick system font is used as a default font 

for vector drawings

Line Style • If selected, dotted and dashed lines are displayed
• If cleared, all lines are displayed as solid

Dimensions • If selected, all dimensional entities are displayed
• If cleared, simple dimension entities are not displayed

Filling • If selected, displays filled entities as filled rather than 
just an outline

• If cleared, does not display filling for filled entities

Line Weights • If selected, displays varying line thicknesses
• If cleared, displays no line weights for any line (all lines 

appear equal)

Load External
References

• If selected Xrefs are automatically loaded
• If cleared, Xrefs are not loaded

Option Description

Full Resolution Displays the file at full resolution.

Fit to Window Displays the file to fit the current window.

Option Description
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Configuring AutoVue
1 Select Options > Configuration from the AutoVue main menu.
2 The Configuration dialog appears.
3 Click the General tab.
4 Configure the options that you want.
5 To configure the background color, click Background Color. The 

Background Color dialog appears.
Select the color that you want to set for the background.
Select the checkbox beside the Type of file format that you want to change.
Clear the checkmark beside the Type that you do not want to change, then 
click OK.
The color change is applied.
Note  The Type of file formats that you can select are Mono Raster, Color 
Raster, Database, Document, Spreadsheet, Default Archive and Vector.

6 Click OK to close the Configuration dialog.

Configuring the Base Font for Text Files
1 Configure the options that you want.

See   Configuring AutoVue for 2D Files
2 Click Base Font.
3 The Font dialog appears.
4 From the Font drop-down list, select the type of font.
5 From the Size drop-down list, select the size of font.
6 Select Bold, Italic or both for font Style.
7 Click OK.

The font change is applied.
8 Click OK to close the Configuration dialog.
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Configuring Paths
In AutoVue, you have the option to use the default directory or configure a 
directory path to store files. The types of files that you can configure a directory 
path are:

Configuring Font Paths
Font Paths are the directory paths for fonts required by AutoVue’s vector files.
1 Select Options > Configuration from the AutoVue main menu.

The Configuration dialog appears.
2 Click the General tab.
3 Click Paths.

The Paths dialog appears.
4 Click Font Paths.
5 Click Add.

The Browse for Folder dialog appears.
6 Enter the directory path or scroll up or down to locate the directory where 

the external reference files are located.
To browse all subdirectories below the current path,  type two asterisks ** at 
the end of the file path.
For example, C:\samples\** will result in browsing all subdirectories 
below “samples”.

File Description

XRefs The directory paths for any external reference files associated with vec-
tor files.
See   Configuring Xref Paths

Font The directory paths for fonts required by AutoVue’s vector files.
See   Configuring Font Paths

Symbol The directory path for symbol libraries used by AutoVue’s Markup enti-
ties.
See   Configuring Symbol Paths

Markup The directory paths for Markup files.
See   Configuring Markup Paths
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To browse one subdirectory below the current path, type one asterisk * at the 
end of the file path.
For example, C:\samples\* will result in browsing one subdirectory below 
“samples”.

7 Click OK.
The directory path appears in the Paths dialog.
Note  To add more than one path, repeat steps 5 to 7.

8 To change the order, select the path you want to move, then click Up or 
Down to move the path to where you want in the list.

9 To remove a path, select the path that you want to remove and click 
Remove.
The selected path disappears from the list.

10 Click OK to close the Paths dialog.
11 Click OK to close the Configuration dialog.

Configuring XRef Paths
Xref Paths are the directory paths for any external reference files associated 
with vector files.
1 Select Options > Configuration from the AutoVue main menu.

The Configuration dialog appears.
2 Click the General tab.
3 Click Paths.

The Paths dialog appears.
4 Click XRef Paths.
5 Click Add.

The Browse for Folder dialog appears.
6 Enter the directory path or scroll up or down to locate the directory where 

the external reference files are located.
To browse all subdirectories below the current path,  type two asterisks** at 
the end of the file path.
For example, C:\samples\** will result in browsing all subdirectories 
below “samples”.
To browse one subdirectory below the current path, type one asterisk * at the 
end of the file path.
For example, C:\samples\* will result in browsing one subdirectory below 
“samples”.

7 Click OK.
The directory path appears in the Paths dialog.
Note  To add more than one path, repeat steps 5 to 7.
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8 To change the order, select the path you want to move, then click Up or 
Down to move the path to where you want in the list.

9 To remove a path, select the path that you want to remove and click 
Remove.

10 Click OK to close the Paths dialog.
11 Click OK to close the Configuration dialog.

Configuring Markup Paths
Markup Paths are the directory paths for Markup files associated with the 
currently loaded document.
1 Select Options > Configuration from the AutoVue main menu.

The Configuration dialog appears.
2 Click the General tab.
3 Click Paths.

The Paths dialog appears.
4 Click Markup Paths.
5 Click Auto if you want to use the default directory to store Markup files.

Click User-Defined if you want to select a directory to store Markup files 
and enter the directory path to where you want to store the Markup files or 

click the ellipse key  to locate the directory.
6 Click OK.
7 Click OK to close the Configuration dialog.

Configuring Symbol Paths
Symbol Paths are the directory paths for symbols libraries used by AutoVue’s 
Markup entities. 
1 Select Options > Configuration from the AutoVue main menu.

The Configuration dialog appears.
2 Click the General tab.
3 Click Paths.

The Paths dialog appears.
4 Click Symbol Paths.
5 Click Auto if you want to use the default directory to store the Symbol 

libraries.
Click User-Defined if you want to select a directory to store the Symbol 
libraries and enter the directory path where you want to store the Symbol 

files or click the ellipse key  to locate the directory.
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6 Click OK.
7 Click OK to close the Configuration dialog.

Configuring AutoVue as a Quick 
Viewer for Windows
AutoVue can display or open files even when the AutoVue application is not 
running. You can designate AutoVue as the Quick Viewer for Windows rather 
than using the default Quick Viewer. You can direct AutoVue to open certain 
types of files by associating AutoVue with particular file types using File/Print 
Association.
Having AutoVue as the Quick Viewer, eliminates the need for the original file 
application. For example, if word files (.doc) are selected as a file association, 
then word files (.doc) files will be opened by AutoVue even when you are using 
Microsoft Word.
To configure AutoVue as a Quick Viewer:
1 Select Options > Configuration from the AutoVue main menu.

The Configuration dialog appears.
2 Click the General tab.
3 Click Registry.

The AutoVue File Registration dialog appears.
4 Click the Quick View or File/Print Association tab.

A list of standard file format extensions supported by AutoVue is displayed.
5 From the list of file extensions, select the file types for Quick View or File/

Print Association.
Note  For non-standard file extensions, use the Association option.
Note  To select more than one file extension, press the Shift or Ctrl key 
while selecting, or to select all file extensions, click Select All.

6 Click OK.
7 Click OK to close the Configuration dialog.

Using Quick View
1 Select the file or files to open from Windows Explorer, My Computer or 

Network Neighborhood.
2 Select File > Quick View from the menu.

AutoVue displays the selected file(s).
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Note  You can also right-click in the workspace and select Quick View 
from the pop-up menu.

Using the File/Print Association
1 Double-click a file from its directory listing in Windows Explorer, My 

Computer or Network Neighborhood.
AutoVue opens the selected file.

2 Right-click and select Quick View from the pop-up menu.
AutoVue displays the selected file(s).
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Working with EDA Files
In addition to all features that are available for generic 2D files, AutoVue 
provides intelligent querying for EDA files. You can create/modify layer sets, 
you can query entity information, generate BOM, verify EDA designs, cross-
probe and perform intelligent measurements.

Navigation Panel
The Navigation Panel is displayed on the left-hand side of the AutoVue 
workspace when you view an EDA drawing. The Navigation Panel allows you 
to navigate through a list of component instances, nets and the associated pins 
and net nodes (pins connected to a net) present in the current schematic drawing 
or PCB design.
The columns displayed in the Navigation Panel are determined by the profile 
of the entity types in the current schematic drawing or PCB design. Lists can be 
sorted in order to group similar component instances.
You can also use the Navigation Panel to select (highlight) a component or 
entity; zoom to a component or entity and query entity information.
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Components Tab
The Components tab lists component instances and the associated pins.The top 
portion of the panel lists all the instances of the currently displayed page of the 
drawing. The lower portion of the panel lists the associated pins for selected 
instance(s).
When you select a component, it appears highlighted on the drawing. To select 
more than one component, press Shift or Ctrl and then select the desired 
components.  All the components you selected are highlighted. The associated 
pins for the selected component(s) are displayed.

Nets Tab
The Nets tab lists nets and associated net nodes (pins connected to a net). The 
top portion of the panel lists all the nets of the currently displayed page of the 
drawing. The lower portion of the panel lists the associated net nodes for selected 
net(s).
When you select a net, it appears highlighted on the drawing. To select more than 
one net, press Shift or Ctrl and then select the desired nets. You can also click 
and drag in the Navigation Panel list to select multiple nets. All the nets you 
selected are highlighted. The associated net node list(s) for all the nets you 
selected are displayed.

Bookmarks Tab
The Bookmarks tab allows you to navigate between PCB and schematic pages 
or between the 2D and 3D view of a PCB design.

Customizing the Navigation Panel
In the Navigation Panel, you can sort a column, change column order, or hide 
or show a column.
1 To sort a column, click the column heading.
2 To change the column order or to show or hide a column, right-click a 

column heading and select Customize from the pop-up menu.
The Customize Columns dialog appears.
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3 To show or hide a column, select the checkbox beside the column(s) you 
want to show.
Clear the checkbox beside the column(s) you want to hide.
Note  To show all columns, click Show All. To hide all columns, click 
Hide All.

4 To change the column order, select the column you want to move, then click 
Move Up to move the column up in the list or click Move Down to move 
the column down in the list.

5 Click OK.
The changes appear in the Navigation Panel.

Selecting Entities
Selecting an entity or entities is often the first step to many of the operations that 
you will perform with EDA files. There are a few ways to select an entity or 
entities in a EDA file:  Selection Filters, Navigation Panel and Entity 
Browser.

Selecting Entities from the Navigation 
Panel
1 In the Navigation Panel, select any components, nets, associated pins or 

net nodes.
Note  To select more than one entity, press the Shift or Ctrl key while 
selecting.
The selected entity or entities appear highlighted in the workspace.
Note  If the selected entity is too small, a flash box appears indicating the 
location of the highlighted entity in the workspace.
See Also   Zooming to a Selected Entity

Selecting Entities in the Workspace
In AutoVue, you can apply selection filters when selecting entities in the 
workspace, see Filtering Entity Types.
1 Select the entity or entities in the workspace.

Note  To select more than one entity, press the Shift or Ctrl key while 
selecting.
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The selected entity or entities appear highlighted in the workspace and in the 
Navigation Panel.
Note  If the selected entity is too small, a flash box appears indicating the 
location of the highlighted entity in the workspace.
See Also   Zooming to a Selected Entity

Zooming to a Selected Entity
1 In the workspace or Navigation Panel select the entity, then right-click 

and select Zoom selected.
In the Entity Browser dialog, select the entity from the Entity Types list 
or the Attributes list, then right-click and select Zoom selected.
AutoVue zooms to the selected entity in the workspace.

Selecting Entities from the Entity Browser
1 Perform an attribute-based or entity type-based search using the Entity 

Browser.
See   Entity Browser

2 Select an entity or entities from the Entity Types list or the Attributes list 
of the Entity Browser dialog.
Note  To select more than one entity, press the Shift or Ctrl key while 
selecting.
The selected entity or entities appear highlighted in the workspace and in the 
Navigation Panel.
Note  If the selected entity is too small, a flash box appears indicating the 
location of the highlighted entity in the workspace.
See Also   Zooming to a Selected Entity

Filtering Entity Types
With the Entity Type Filter option, you can display certain entity types while 
hiding others, without having to hide an entire layer. For example, you might 
want to turn off all entities and display only the component instances.
You can also limit the types of entities you can select in the workspace.
1 Select View > Entity Type Filter from the AutoVue menu.

The Entity Type Filter dialog appears.
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Note  You can also click the Entity Type Filter icon  on the AutoVue 
toolbar.

2 Under the Visibility column, select the checkbox beside the entity types you 
want to display in the workspace.
Clear the checkbox to hide the entity types.

3 Under the Selection column, select the checkbox beside the entity types 
that you want to be able to select in the workspace.
Clear the checkbox beside the entity types that you do not want to select.
Note  To select all entity types, select the checkbox in the column header. 
Clear the checkbox to deselect all entity types.

4 Click Apply to apply the changes.
5 Close OK to close the Entity Type Filter dialog.

Only the selected entities types remain displayed in the workspace.
When you click in the workspace, only the entities types checked in the 
Entity Type Filter dialog will be highlighted.

Entity Properties
The Entity Properties dialog displays detailed information about any selected 
entity in the current schematic drawing or PCB design. You can right-click an 
entity in the workspace, Navigation Panel or in the Entity Browser dialog to 
open the Entity Properties dialog. 
On the left side of the Entity Properties dialog, a tree control displays all the 
entities associated with the entity you selected. The entity you selected is the tree 
node and all the associated entities (grouped by their type) are the entities that are 
directly connected to this entity. On the right, the attributes of the entity are 
displayed. In the tree, select any associated entity to display its attributes under 
Entity Info.

Viewing the Properties of an Entity
The Entity Properties dialog displays detailed information about any selected 
entity in the current schematic drawing or PCB design.
1 Select the entity in the workspace or from the Navigation Panel or Entity 

Browser.
2 Right-click and select Entity Properties from the pop-up menu.
Cimmetry Systems Corp.



54 AutoVue
The Entity Properties dialog appears displaying the selected entity and its 
associated entities under Associations, and its attributes under Entity 
Information.
Note  You can also double-click the entity in the workspace for which you 
want to view its entity information.

3 Select any associated entity in the tree to display its attributes under Entity 
Information.

4 To view all associated entities for any given entity in the tree, select the 
entity and click Expand.
Note  To view the entity properties for the previous entity, click the back 

 arrow. To return to the entity properties displayed before you clicked 
the back arrow, click the forward  arrow.

5 Click OK to close the Entity Properties dialog.

Showing Net Connectivity
1 From the Navigation Panel, right-click an entity such as a pin, via or trace 

for which you want to display the net connectivity and select Show Net 
Connectivity from the pop-up menu.
Note  Show Net Connectivity is disabled when more than one entity is 
selected.
The graphical entities belonging to the connected nets are highlighted.

Displaying the Entity Properties of a Net
It is possible to view properties of a net via Entity Properties.
Note  Entity Properties is disabled when more than one net entity is selected.
1 Select an entity such as a pin, via or trace from the workspace.

The corresponding net is highlighted in the workspace.
2 Right-click the net and select Entity Properties from the pop-up menu.

The Entity Properties dialog appears displaying the properties of the 
selected net.

3 Click OK to close the Entity Properties dialog.
Note  You can also select a net from the Navigation Panel, right-click 
and select Entity Properties.
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Showing Net Instances
In AutoVue, you can display the instances of a net in a multi-page file.
1 From the Navigation Panel, click the Nets tab and select the net you want 

to view.
The net is highlighted in the Navigation Panel and in the workspace.

2 Select View > Go To Net Instances from the AutoVue main menu or 
right-click the highlighted net from the Navigation Panel or workspace 
and select Go To Net Instances.
AutoVue highlights the instance(s) of the selected net.
If the selected net appears on multiple pages the Go to Net Instances 
dialog appears.

3 Select the page on which you want to view the net instance, then click OK.
The selected page is displayed and the instance of the selected net is high-
lighted.
Note  If there are no instances for the selected net the option is disabled.

Design Hierarchy Navigation
AutoVue supports navigation through the hierarchical structure of a schematic 
drawing. A hierarchical block in a schematic is a symbol that refers to a child 
schematic. With the Descend Hierarchy option, you can navigate to a child 
schematic. With the Ascend Hierarchy option, you can navigate from the child 
schematic to the parent page.
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Navigating using Descend Hierarchy
1 On the parent page, select any hierarchical block in the workspace, then 

right-click and select Descend Hierarchy from the pop-up menu.
AutoVue opens the page with the selected child schematic.
Note  You can also select the hierarchical block in the Navigation Panel 
or in the Entity Browser dialog, then right-click and select Descend 
Hierarchy.

Navigating using Ascend Hierarchy
1 On the child page of your schematic’s design hierarchy, right click an entity 

in the workspace and select Ascend Hierarchy from the pop-up menu.
AutoVue returns to the parent page.
If you select an entity that has multiple parents, the Ascend Hierarchy 
dialog appears displaying the parent pages.

Select the Parent page you want to go to, then click OK.
AutoVue returns to the selected parent page.
Note  You can also select the entity in the Navigation Panel or in the 
Entity Browser dialog, then right-click and select Ascend Hierarchy.

Layers
When working with EDA files, you can select which layers of the current active 
file you want to display or print. You can move layers up and down to change the 
z-order of the layers. You can modify layer colors.
Note  For drawings which do not contain layers, the Layer menu and icon are 
grayed out.
Cimmetry Systems Corp.



AutoVue 57
The Layers dialog displays a list of layers along with attributes: name, visibility, 
printability and color. You can sort the list of layers or group layers according to 
one of their attributes.

Changing Layer Color
You can modify the color of any layer from the Layers dialog.
1 Select View > Layers from the AutoVue main menu.

The Layers dialog appears.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 Select the layer or layers for which you want to change the color.

Note  To select more than one layer, press the Shift or Ctrl key while 
selecting.

3 Under Color, click Modify.
The Layer Color dialog appears.

4 From the Color drop-down list, select the color that you want.
5 Click OK.

The selected color appears in the  column.
6 Click Apply to save the changes.

The display is updated based on the changes to the layer color.
7 Click Close to close the Layers dialog.

Modifying Layer Visibility
You can select which layers you want to display from the Layers dialog.
1 Select View > Layers from the AutoVue main menu.

The Layers dialog appears.

Note  You can also click the Layers icon  on the AutoVue toolbar.

2 Under the column  select the checkbox beside the layers that you want 
visible.
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Clear the checkbox beside the layers that you do not want visible.
Note  To select more than one layer, press the Shift or Ctrl key while 
selecting. To select all layers, click All under Select.

3 Under Visibility, click On to display the selected layers.
To hide selected layers, click Off.

4 Click Apply to save the changes.
Only the layers selected in the Visibility column are displayed in the 
workspace.

5 Click OK to close the Layers dialog.

Changing the Order of Layers
You can change the order in which layers are displayed, i.e., you can change the 
z-order for layers.
1 Select View > Layers from the AutoVue main menu.

The Layers dialog appears.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 Select the layer or layers that you want to move.

Note  To select more than one layer, hold the Shift or Ctrl key and click.
3 Under Order, click Up to move the selected layers up in the list or Down to 

move the selected layers down in the list.
4 Click Apply to save the changes.

The file now displays according to the layer scheme you arranged.
5 Click Close to close the Layers dialog.

Setting Printability for Layers
Note  Invisible layers cannot be printed. Since visibility overrides printability, 
you cannot select Printability for a layer whose visibility is off.
1 Select View > Layers from the AutoVue main menu.

The Layers dialog appears.

Note  You can also click the Layers icon  on the AutoVue toolbar.

2 Under the column  select the checkbox beside the layers that you want to 
make printable.
Clear the checkbox beside the layers that you do not want printable.
Note  If you want all layers to be printable, click All under Select.
Cimmetry Systems Corp.



AutoVue 59
3 Click Apply to save the changes.
Only the layers you selected in the Printable column will be printed.

4 Click Close to close the Layers dialog.

Sorting Layers
In the Layers dialog, you can sort the list of layers by attribute name, visibility, 
printability, color or physical layer.
1 Select View > Layers from the AutoVue main menu.

The Layers dialog appears.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 Click the column header of the attribute that you want to sort by.

Note  To restore the original sort order, click the Order column header. 
3 Click Close to close the Layers dialog.

Layer Sets
A layer set is comprised of all the layers in the drawing. Layer sets differ in the 
attributes of the different layer(s): z-order, visibility, printability, color, etc.

Defining Layers Sets
You can define a layer set and save it. The layer set is saved for the duration of 
the session. The layer set you defined is added to the Layer Set list in the 
Layers dialog and to the Layers drop-down list on the AutoVue toolbar.
By default the Top, Bottom and Default layer sets and any other layer sets 
belonging to the file are listed in the Layer Set drop-down list.
1 Select View > Layers from the AutoVue main menu.

The Layers dialog appears.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 Click Add.

The Add Layer Set dialog appears.
3 Enter the Layer Set Name.
4 Click OK.

The new layer set appears in the Layer Set drop-down list.
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5 To modify the attributes of the new layer set, select one or more layers and 
change the Visibility, Printability, Order or Color.
See   Modify Layer Visibility

 Setting Printability for Layers
 Changing the Order of  Layers
 Changing Layer Color

6 Click Apply to save the changes and to display the new layer set in the 
workspace.
Note  To add more layers sets, repeat steps 2 to 6.

7 Click Close to close the Layers dialog.

The new layer set appears in the drop-down list beside the Layers icon  
on the AutoVue toolbar and is also displayed in the workspace.

Viewing Layer Sets
In AutoVue, you can display the default top and bottom layer set, layer sets saved 
with a file, as well as any user-defined layer sets, see Defining Layer Sets.
1 Select View > Layers Sets and the view you want to display from the 

AutoVue main menu.

Note  You can also click the Layers icon  on the AutoVue toolbar.
The selected layer set is displayed in the workspace.
Note  You can also select a layer set from thedrop-down list beside the 

Layer icon  on the AutoVue toolbar or from the Layer Set drop-down 
list in the Layers dialog.

2 To restore the default layer set, select View > Layer Sets > (Default) or 
(Default) from the toolbar or in the Layers dialog.

Deleting Layer Sets
1 Select View > Layers from the AutoVue main menu.

The Layers dialog appears.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 From the Layer Set drop-down list, select the layer set that you want to 

delete.
3 Click Delete.
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Note  The layer settings remain displayed on the screen until you select 
another layer set.

4 Click Apply to save the changes.
5 Click Close to close the Layers dialog.

Manipulating EDA Views
With the View options you can instantly manipulate how the current active file is 
displayed. You can rotate a file’s orientation counterclock-wise by 90, 180 or 270 
degrees, flip a file’s orientation horizontally, vertically or both simultaneously.
AutoVue provides several ways to change the view size of a selected area of a 
file, display different views, layers and blocks of the current active file. You can 
also navigate from one page to another page of a multi-page file.
For more information on how to manipulate views, see Manipulating 2D 
Views.

3D View
For some ECAD formats, AutoVue supports 3D views of PCB boards.
1 In the Navigation Panel, click the Bookmarks tab.
2 Select 3D View from the Bookmark Tree.

The 3D view of the PCB board is displayed in the workspace.
Note  You can also display a 3D view by selecting View > Page > Next 
Page or by clicking the Next Page icon  on the toolbar.

Cross Probing
Cross probing is the ability to select elements in the schematic and have them 
mapped to the corresponding components in the layout drawings and vice versa. 
You can also Cross Probe between the 2D and 3D view of the same file.

Cross Probing Between Two or More EDA 
Files
With Cross Probe you can select entities in the schematic drawing or the PCB 
and AutoVue highlights what you selected in all the open files.
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1 Select Analysis > Cross Probe from the AutoVue main menu.
The Cross Probe dialog appears.

Note  You can also click the Cross Probe icon  on the AutoVue toolbar.
2 Click Add File. The Open dialog appears.

Enter the File name or browse to locate the file you want to cross probe, 
then click Open.
Note  You can cross probe between more than one file, repeat step 2 for 
each file that you want to open.

3 In the Cross Probe dialog, click OK.
The selected file(s) appear in new AutoVue window(s).

4 Resize the windows so that you can see all the open files.
5 Select any entity in the schematic drawing.

The same entity is highlighted in the PCB design(s).

Zooming to a Selected Entity or Entities 
When Cross Probing
1 Select an entity or entities in any open file.

Note  The entities you selected can be from the schematic drawing or the 
PCB design.

2 Right-click and select Zoom Selected from the pop-up menu.
AutoVue zooms to the same entities in all the open files.

Showing the Net Connectivity when Cross 
Probing
1 Select an entity or entities in any open file.
2 Right-click and select Show Net Connectivity from the pop-up menu.

The net connectivity for the entity or entities that you selected are 
highlighted in all the files.

Cross Probing Between the 2D and 3D 
View of the Same File
1 Select Analysis > Cross Probe from the AutoVue main menu.

The Cross Probe dialog appears.

Note  You can also click the Cross Probe icon  on the AutoVue toolbar.
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2 Click Add File.The Open dialog appears.
Select the same file, then click Open.

3 In the Cross Probe dialog, click OK.
The file appears in a new AutoVue window.

4 Display the 3D view of the file.
Note  To display the 3D view use the Page buttons on the toolbar or select 
View > Page. You can also click Bookmarks in the Navigation Panel 
and select 3D View.

5 Resize the windows so that you can view both views of the file.
6 Select an entity in the 2D view.

The same entity is highlighted in the 3D view of this file.
Note  You can select entities in the 2D view or 3D view of the file. The 
entities you selected, are highlighted in both open views of this file.

Zooming to a Selected Entity or Entities in 
the 2D and 3D View of the Same File
1 Select an entity or entities in either one of the open views.
2 Right-click and select Zoom Selected from the pop-up menu.

AutoVue zooms to the same entities in both open views of the file.
Note  You can select entities in the 2D view or 3D view of the file. 

Comparing a PCB with Artwork
In AutoVue, you can visually compare PCB designs or schematic drawings. In 
Compare mode for EDA files, EDA options such as Select Entity, Entity 
Browser and Entity Type Filter are available.
For more information on how to compare files, see Comparing 2D Files.
To compare a PCB with artwork:
1 Open the PCB file that you want to compare with the artwork.
2 Select Analysis > Compare from the Autovue main menu.

The Open dialog appears.
3 Enter the File name or browse to locate the artwork file you want to 

compare with the PCB file.
4 Click Open.

The PCB-Artwork Comparison dialog is displayed.
5 From the drop-down list, select the PCB physical layer that represents the 

artwork. For example: TOP, BOTTOM or POWER.
Cimmetry Systems Corp.



64 AutoVue
6 Click OK.
AutoVue displays three windows, the first displaying the original PCB 
drawing, the second displaying the Artwork drawing and the third the 
Comparison Result window.

7 To exit Compare mode, select File > Exit Compare Mode from the 
AutoVue main menu.
The original file appears in the AutoVue workspace.
Note  You can right-click in any window and select Exit Compare Mode.
See Also   Specifying Scale and Offset for a Compare File

Generating a Bill of Material
For EDA files, you can obtain a list of the components and parts required for 
manufacturing the item featured in the schematic drawing or PCB design.
The Bill of Material (BOM) report produces a count of the unique components 
or parts needed for manufacturing. It lists the quantity required, component 
name, reference designators, value (for resistors and capacitors), size and 
descriptions. When determining a component’s uniqueness, the count considers 
only the attributes chosen for inclusion in the report output. It includes only those 
attributes that provide the most accurate, unique component quantities.
To generate a Bill of Material:
1 Select Analysis > BOM from the AutoVue main menu.

Note  You can also click the BOM icon  on the AutoVue toolbar.
If you are generating a BOM for a schematic with multiple pages, a dialog 
appears. 

Select if you want to generate a BOM for the Current page or the Entire 
design, then click OK.
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A dialog appears listing the attributes of the file.
2 Select the attributes that you want to appear in the report, then click 

Generate.
The Bill of Material dialog appears listing the Count for each component 
or part possessing the attributes you selected. There are also columns 
displaying the values of the attributes you selected.
Note  To sort a column by alphanumerical or alphabetical order, click on the 
column heading.

3 To save the Bill of Material, click Export. The Save As dialog appears.
Specify the directory where you want to store the file, the file name and 
extension, then click Save.
Note  You can specify either xml (Product Data Exchange) or csv 
(Common Separated Values) for the extension.
AutoVue automatically saves the results in a file with the format you 
specified.

4 Click Close to close the Bill of Material dialog.

Design Verification
Design verifications are operations that check the electrical design of a PCB 
against a set of rules defining physical and electrical design limitations. 
Performing these checks will prevent short circuits and process errors. The types 
of design rules are:
• Clearances - the minimum spacing (air gaps) allowed between two sets of 

entities in the design. These sets can belong to the same type of entity or to 
different types.

• Electrical - targets certain properties of the nets
• Manufacturing - targets the physical properties of a particular entity.
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Design Rule Checks
For design rule checks that have values, you can change the unit of measure and 
change the value of each check. The available design rule checks are:

Type # Design Rule 
Check Description

Clearance 1 Min.Clearance
(Pad > Pad)

Specify the minimum pad to pad clearance 
on the same physical layer.
Note  Only the pad outline is considered.

2 Min.Clearance
(Pad > Trace)

Specify the minimum pad to trace 
clearance and pads on the same physical 
layer.
Note  Only the pad outline is considered. 
Does not take into account traces 
connected to a pin (pad) on the same net.

3 Min.Clearance
(Trace > Trace)

Specify the minimum trace to trace 
clearance on the same physical layer.
Note  Does not take into account directly 
connected traces.

4 Min. Clearance
(Comp > Comp)

Specify the minimum component to 
component clearance on the same physical 
layer (component top side or component 
bottom side).
Note  Only the logical layer that defines 
the actual outline of the component is 
considered.
Note  A component entity is usually 
made up of geometrics on different logical 
layers (silkscreen, keepout, etc.), but only 
the logical layer that defines the actual 
outline of the component is considered.

Manufacturing 5 Min. Annular 
Ring

Specify the distance between the pad out-
line and the outline of its drill hole on all 
physical layers.
Note  The two outlines (geometries) are 
part of the pin (pad) entity but on different 
logical layers.
Cimmetry Systems Corp.



AutoVue 67
6 Min. Pad 
Diameter

Specify the minimum diameter of a pad.
Note  Only applicable to rounded pads.

8 Acute Angle
(in deg.)

Specify the minimum acute angle between  
connected traces on the same physical 
layer.
Note  Only two traces belonging to the 
same net should be considered.

9 Min. Drill Hole 
Size

Specify the minimum diameter of the drill 
hole size allowed.
Note  Only applicable to rounded pads.

10 Max. Drill Hole 
Size

Specify the maximum diameter of the drill 
hole size allowed.
Note  Only applicable to rounded pads.

Electrical 7 Max. Via Count Specify the maximum via count allowed 
for a net.

11 Min. Route 
Width

Specify the minimum route (trace) width 
allowed in the design.

12 Max. Route 
Width

Specify the maximum route (trace) width 
allowed in the design.

13 Min. Route 
Length

Specify the minimum route (trace) length 
allowed in the design.

14 Max. Route 
Length

Specify the maximum route (trace) length 
allowed in the design.

15 Empty Nets Select this checkbox if you want to check 
for any nets that are not connected to any 
pin, via, trace and power/ground plane.

16 Un-routed 
Traces

Select this checkbox if you want to check 
for any trace segment that is not connected 
to another trace segment, pin, via on either 
end.

Type # Design Rule 
Check Description
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Verifying a Design
1 Select Analysis > Verify Design from the AutoVue main menu.

A design dialog appears.

Note  You can also click the Verify Design icon  on the AutoVue toolbar
2 To enable a Design Rule, select the checkbox beside the Design Rule.

To disable a Design Rule, clear the checkmark.
Note  You can sort the Design Rules by Enabled, Description or 
Value by clicking the column heading.

3 To add a value to the selected Design Rules, double-click in the value box 
and enter a value.
Note  The Design Rule must be enabled to be able to add a value.

4 In the Maximum Violation text box, enter the maximum number of results 
you want to display in the Results text box.

5 From the Distance Units drop down list, select the unit you want to use as 
the unit of measure.

6 Click Verify.
Verify button changes to Stop.
Note  To stop the Design Verification process at any point, click Stop.

17 Single 
Connection

Select this checkbox if you want to check 
for a net connected to only one pin.
Exception:  power and ground nets.

18 Short Circuit Select this checkbox if you want to check 
for intersections (on the same layer) of 
traces that belong to different nets.
Note  Trace entities will be divided into 
n sets where n is the number of nets in the 
design.

19 Unconnected 
Pin

Select this checkbox if you want to check 
for any pin (pad) that is not graphically 
intersected with any traces on the same 
physical layer.

Type # Design Rule 
Check Description
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When the process is complete, the total number of errors found during the 
Design Verification process, up to the maximum number specified in the 
Maximum Violation text box, appear in the Results list.

7 To view the description of a violation result, select the violation from the 
Results list.
The description appears in the Description text box. The description 
includes information such as the type of violation, the location where it 
occurs (x- and y-coordinates), the component or entity it affects and the 
actual value measured.
Note  When you select a violation result, AutoVue zooms to the entity or set 
of entities that were affected and highlights them on the drawing.

8 Continue to select violation Results to view its description.
Note  Click Reset to restart a new check.

9 Click Close to close the dialog.

Exporting the Design Verification Results
You can export the Design Verification results into a text file.
1 Click Export in the design dialog.

An export dialog appears.
2 Navigate and select the directory that you want to export the results to.
3 Enter a File name.

Click Save.
AutoVue saves the Design Verification results in a txt (text) or csv 
(Common Separated Values) file listing each violation result and its 
description.

4 Click Close to close the design dialog.

Searching Using Entity Browser
You can search for an entity in a schematic drawing or a PCB design using the 
Entity Browser. You can apply attribute or entity type filters as search criteria 
to filter entities. You can select entities from the results list and have them appear 
highlighted in the workspace and in the Navigation Panel. You can also export 
the search results.
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Note  If the selected entity is too small, a flash box appears indicating the 
location of the highlighted entity in the workspace.

Performing an Entity Type-based Search
1 Select Analysis > Entity Browser from the AutoVue menu.

The Entity Browser dialog appears.

Note  You can also click the Entity Browser icon  on the AutoVue 
toolbar.

2 Click the Entity Types tab.
3 From the Entity Types drop-down list, select an entity type.

A list of attributes for the selected entity type appear.
Note  To sort the list by attribute, click the attribute column heading that 
you want to sort by.

4 If you want to search by attribute, select an attribute from the Attribute 
drop-down list.
If you want to search by value, select a value from the Value drop-down list.

5 Click Add Filter.
The Attribute and its Value appear in the list.

6  Repeat steps 4 and 5 until you have all the filters you want.
7 Click Apply Filter(s).
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A list of entities matching the search criteria appear showing the column 
headers for the entity’s available attributes.
Note  To remove a filter, select the line in the list containing the Attribute 
and Value you do not want to use as a filter, then click Remove Filter.

8 To save the results, click Export Result.
The Save As dialog appears.

9 Browse to locate the directory where you want to store the file and enter a 
File name. 

10 Click Save. 
AutoVue saves the results in a csv (Comma Separated Values) file.

11 To view the properties of an entity, select the entity from theTypes list or 
the Attributes list, then right-click and select Entity Properties.
The Entities Properties dialog appears displaying the properties for the 
selected entity.

12 To show the net connectivity, click the Attributes tab, select the entity from 
the list, then right-click and select Show Net Connectivity.
The net connectivity for the selected entity is highlighted.

13 Click Close to close the Entity Browser dialog.

Performing an Attribute-based Search
1 Select Analysis > Entity Browser from the AutoVue menu.

The Entity Browser dialog appears.

Note  You can also click the Entity Browser icon  on the AutoVue 
toolbar.

2 Click the Attributes tab.
3 From the Attributes drop-down list, select an attribute.

The Owner, Type and Value of the selected attribute appear in the list.
Note  To sort the list by Owner, Type or Value, click the column heading 
that you want to sort by.

4 If you want to search by owner, select an owner from the Owner filter 
drop-down list.
If you want to search by value, select a value from the Value Filter drop-
down list.
Note  You can also enter an Owner filter or Value Filter in the text box.

5 Click Apply Filter(s).
A list of entities matching the search criteria appear displaying the Owner, 
Type and Value columns.
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Note  Select an item in the result list and right-click to access options like 
Zoom Selected and Entity Properties.

6 To save the results, click Export Result.
The Save As dialog appears.

7 Specify the file name and the directory where you want to store the file, then 
click Save. 
AutoVue saves the results in a csv (Comma Separated Values) file.

8 Click Close to close the Entity Browser dialog.

Measuring in EDA Files
AutoVue provides the ability to perform measurements in EDA files. When 
measuring, AutoVue provides the option to “snap” to geometrical or electrical 
points on the drawing.
You can access the measure options from the Analysis > Measure menu. 
These options are:

Name Description

Angle Measure the angle between selected points.

From the toolbar click  icon.

Arc Measure an arc entity.

From the toolbar click  icon.

Area Measure a selected area.

From the toolbar click  icon.

Distance Measure the distance between two points.

From the toolbar click  icon.

Minimum Distance Measure the minimum distance between entities.

From the toolbar click  icon.
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EDA Snapping Modes
The Snapping Modes available allow you to click to precise geometrical or 
electrical points. For example, when you have selected Snap to pin, move the 
cursor over the pin you want to select until the pin appears highlighted. 
The Snapping modes allow you to snap to the mid, center and end-points of 
an entity, as well as a pin, via and symbol.:

Measuring Distance
Use the Distance option to measure the distance between two specific points.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

Icon Snap to Description

End-point Geometric snap mode where a snap box appears 
when moving the cursor near the component’s end 
point.

Mid-point Geometric snap mode where a snap box appears 
when moving the cursor near the halfway point of a 
linear component.

Center-point Geometric snap mode where a snap box appears 
when moving the cursor near the center of an 
elliptical component.

Pin Electrical snap mode where a snap box appears 
when the cursor touches a pin.

Via origin Electrical snap mode where a snap box appears 
when the cursor touches a via.

Symbol origin Electrical snap mode where a snap box appears 
when the cursor touches the entire component.

Free snap Allows snapping at any point on the drawing.
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To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

4 From the Measured Distance Units drop-down list, select the unit in 
which you want to measure the distance.
Note  If you want to measure the distance along a path, select Cumulative.

5 Click a point on the drawing to define the starting point.
6 Click another point on the drawing to define the end point.

Note  If you selected Cumulative, continue clicking points along the path 
that you want to measure.

7 Right-click to complete the measurement.
The points are joined by a line. The measured distance, Delta-X, Delta-Y 
and the “Manhattan Distance” appear in the Measurement dialog. 
Note  Click Reset to take another measurement.

8 Click Close to close the Measurement dialog.

Calibrating Distance
1 Measure the distance between two points or measure cumulative distance.

See    Measuring Distance
2 In the Measurement dialog, click Calibrate.
3 The Distance Calibration dialog appears displaying the measured 

distance.
4 From the Measured Dist. drop-down list, select the unit to which you want 

to calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate the distance to 

a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

6 Click OK. 
The calibration results appear in the Measurement dialog.

7 Click Close to close the Measurement dialog.

Measuring Minimum Distance
Use the Minimum Distance option to measure the minimum distance between 
entities. The available entities for snapping are nets, pins, vias and traces.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.
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Note  You can also click the Minimum Distance icon  on the AutoVue 
toolbar.

2 Click the Min.Distance tab.

3 Select  First Set to select the entities that you want to measure from.
4 Select the Snapping Modes that you want to select as the entities for the 

measurement.
See   EDA Snapping Modes
Note  If you select Net, you cannot select any other type of entity.

5 Click the first set of entities on the drawing.
The entities are highlighted.
Note  To clear the last set of entities you selected, click Clear Set.

6 Select  Second Set to select the entities that you want to measure to.
7 Click the second set of entities on the drawing.

The entities are highlighted in a different color.
8 From the Measured Min Distance drop-down list, select the unit in which 

you want to measure the distance.
9 Click Zoom to Result, if you want to zoom in to the measurement on the 

drawing.
10 Click Compute.

The minimum distance from the first set of entities to the second set is 
highlighted by a line. The minimum measured distance, Delta-X, Delta-Y 
and the Manhattan Distance appear in the Measure Minimum Distance 
dialog.

11 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
1 Select Analysis > Measure from the AutoVue main menu.The 

Measurement dialog appears.

Note  You can also click the Area icon  on the AutoVue toolbar.
2 Click the Area tab.
3 Select Between Points if you want to measure the area between points on 

a drawing. Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
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See   EDA Snapping Modes
4 Select Shape if you want to measure the area of a predefined shape on the 

drawing. Snapping Modes are disabled.
5 From the Measured Area Units drop-down list, select the unit in which 

you want to measure the area.
6 From the Perimeter Units drop-down list, select the unit in which you 

want to measure the perimeter.
7 To cumulate a Net Area Result of different areas, select Add in the 

Measurement dialog. 
To subtract an area from the Net Area Result, select Subtract. 
Select Clear to clear the Net Area Result.

8 If you selected Between Points, click points on the drawing to define the 
area.
Each point is joined by a line. The area and perimeter measurements appear 
in the Measurement dialog.

9 If you selected Shape, click the edge of the predefined shape that you want 
to measure.
The shape is highlighted. The area and perimeter measurements appear in 
the Measurement dialog.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the AutoVue toolbar.
2 Click the Angle tab.
3 Select From 3 Points if you want to measure the angle between three 

points. Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

4 Select Between 2 lines if you want to measure the angle between two 
lines. Snapping Modes are disabled.

5 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.
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6 If you selected From 3 Points, click three points to define the angle.
7 If you selected Between 2 Lines, click two lines to define the angle.

Angle arms appear with an arc connecting them. The angle measurement 
appears in the Measurement dialog.
Note  Click Reset to take another measurement.

8 Click Close to close the Measurement dialog.

Measuring an Arc
Use the Arc option to define or select an arc in the drawing and measure its 
radius, center and diameter.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the Autovue toolbar.
2 Click the Arc tab.
3 Select From 3 Points if you want to measure the arc between three points. 

Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

4 Select Arc Entity if you want to measure a predefined arc. Snapping 
Modes are disabled.

5 From the Arc Info drop-down list, select the unit in which you want to 
measure the distance of the arc.

6 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

7 If you selected From 3 Points, click three points to define the arc.
The points are joined by an arc. The measurements for center point 
coordinates, radius, diameter, arc length, start and end of angle and sweep 
appear in the Measurement dialog.

8 If you selected Arc Entity, click the edge of the arc that you want to 
measure.
The arc is highlighted. The measurements for center point coordinates, 
radius, diameter, arc length, start and end of angle and sweep appear in the 
Measurement dialog.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
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Calibrating an Arc
1 Measure an arc in the drawing.

See    Measuring an Arc
2 In the Measurement dialog, click Calibrate.
3 The Radius Calibration dialog appears displaying the measured distance.
4 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate to a value.

Click Set Factor and enter a value if you want to calibrate by a factor.
6 Click OK.

The calibration results appear in the Measurement dialog.
7 Click Close to close the Measurement dialog.

Configuring AutoVue for EDA 
Files
In AutoVue, there are configuration options that allow you to customize your 
work environment when working with EDA files. You can access the 
configuration options from Options > Configuration under the 2D tab. These 
options are:

Option Property Description

Snap Settings Snap Radius In measurement mode, when you move the 
cursor within a predetermined snap radius, 
the snap box appears for the entity to be 
selected. The snap radius is configured in 
pixels.
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Display Highlight 
Selection

Configure how you want selected 
components to be highlighted:
• Entity Color - Default Highlight 

Selection option. When making a 
selection, all entities you selected are 
highlighted.

• Dim Unselected - Selected entity 
retains original entity color and all 
non- selected entities are dimmed.

Note  The default highlight color is 
yellow.

3D View Default Board 
Thickness

Configure the board thickness by entering a 
value.
Note  To work with a different unit of 
length, select another unit from the 
Default Units drop-down list.

Default
Component 
Height

Configure the component height by enter-
ing a value. 
Note  To work with a different unit of 
length, select another unit from the 
Default Units drop-down list.

Default Units Configure the unit for the board thickness 
and component height. 

Note  Options apply to the 3D PCB view of EDA files.

Option Property Description
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Color Options
In the Color Options dialog, the options that you can configure are:

Compare
Synchronization

• Page Changes - when selecting this 
option, pages will be synchronized 
when comparing files.
Note  This option is only applicable 
for schematics.
Example If you navigate to page 2 
in the first file you opened, 
AutoVue automatically navigates 
to page 2 in the second file you 
opened.

• Layers Settings - when selecting 
this option, all layer settings will be 
synchronized when comparing files.
Note  This option is only applicable 
for PCB drawings.

Color Options Configure the color for measuring entities.

Select Option Description

Color Selection Configure the color used to highlight entities.

Measurement Configure the color used for measurements high-
lights and measurement selection.

Min. Dist. Set1 Configure the color of the first selection set point 
when measuring minimum distance.

Min. Dist. Set2 Configure the color of the second selection set 
point when measuring minimum distance.

3D View Default Color Configure the color of the board in 3D view.

Default 
Component

Configure the component color in 3D view.

Option Property Description
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To configure AutoVue for EDA files:
1 Select Options > Configuration from the Autovue main menu.

The Configuration dialog appears.
2 Click the 2D tab.
3 Configure the options that you want.
4 To configure the color, click Color Options. The Color Options dialog 

appears.
Select the Color option(s) that you want to configure, then select the color 
and click OK.
See  Color Options

5 Click OK to close the Configuration dialog.
See Also   Configuring Paths

Configuring AutoVue as a Quick Viewer for Windows

EDA Terms and Definitions
Annular ring
A circular strip of conductive material that remains after a hole has been drilled 
through the pad of a printed circuit board.

Anti-copper
An area within a fill zone in which copper cannot be placed.

Aperture
An opening, similar to the aperture of a camera, that is used for photo-plotting. 
Apertures are available in various sizes and shapes.

Aperture list
A text file containing the dimensions for each of the apertures used to photo-plot 
PCB artwork.
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Clusters
Components that are grouped according to their interrelationships and placed in 
close proximity on the board. This keeps the connections on the PCB short so 
that the board is easier to work with.

Component
An element or a part of a PCB.

Component density
The quantity of components on a unit area of a PCB.

Component hole
A hole in the printed circuit board that corresponds to a pin or wire of a 
component. This hole serves the dual function of attaching the component to the 
board and establishing the electrical connection between the pin or wire and the 
remainder of the board circuitry.

Component library
A computer data file that contains the footprint patterns for a number of 
components.

Component side
The uppermost or top layer of a board on which most components are placed.

Component silkscreen
The silkscreen markings of the printed circuit board that appear on the 
component side. The silkscreen is applied over the solder mask.

Component solder mask
The colored, usually translucent, coating applied to the board over the etched 
copper. It protects the selected areas from the soldering process.
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Connection
An unrouted, partially routed, or completely routed path between two pads. In a 
net with n pads, there are exactly n–1 connections.

Copper pour
A method by which a copper zone is filled with a specified pattern, with objects 
that cross the zone or lie within the zone being avoided.

Copper zone
An area on a board designed to be covered by a layer of copper when 
manufactured. Also known as a "metal zone."

Cross hatching
The breaking up of large conductive areas by the use of a pattern of lines and 
spaces in the conductive material.

Datum
A specific location (a point) that serves as a reference to locate a PCB  pattern or 
layer for manufacture.

Density
On a PCB, the degree to which components are packed on the board. Generally, 
the density is given as the number of square inches per equivalent, i.e., a lower 
number indicates a more dense board.

Discrete components
Components with three or fewer electrical connections (for example, resistors or 
capacitors).

Electrical check
The process of checking the PCB to ensure that the connections they are on 
match those specified in the net list.
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Fill zone
A zone that defines an area to be filled with copper.

Fine pitch
A class of surface-mount components that is characterized by pins measuring 
0.025 inches or less from pad center to pad center.

Footprint
The physical description of a component. It consists of three elements: 
padstacks, representing the pads of the component; obstacles, representing 
among other things, the physical outline of the component, silkscreens, keepouts/
keepins, and assembly drawing data; and text documenting the footprint 
information (for example, the component name). You may want each project to 
have its own footprint library containing all the footprints used in that project. 

Ground plane
A large area on the PCB, usually an entire layer, that provides a common ground 
connection for all component ground pins and other ground connections.

Heatsink
A mechanical device made of a high thermal conductivity material that dissipates 
heat generated by a component or assembly.

Heuristics
A method of routing that consists of repeated attempts to apply very simple 
routing patterns to unrouted connections in order to complete the routing quickly 
and cleanly. Typically, heuristics are used for memory and short point-to-point 
routing.

Hole
The area where board material must be removed by drilling or milling.
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Isolation
The clearance around a pad, track, zone, or via that defines the nearest approach 
allowed by conductors of another signal set.

Jumper wire
A discrete electrical component or wire used to make electrical connections 
between points that have no copper etch due to board density or some other 
factor. 

Keepout
An area fill within which no routing is allowed.

Land
The copper pad needed for a surface mount pin.

Layer
One in a series of planes in a PCB design on which tracks are arranged to connect 
components. Vias connect tracks and zones between layers.

Manual routing
Individual connections, in the form of traces, vertices, arcs, etc., which are 
entered manually into the PCB design.

Mounting hole
A hole used for the mechanical support of a PCB or for the mechanical 
attachment of components to a PCB.

Multi-layer board
A PCB that has multiple layers, separated by dielectric material, with 
connectivity between layers established by vias or through-holes. This term 
usually refers to a board with more than two layers.
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Net
A logical construct (circuit) that originates in a schematic and is transferred to a 
board to describe required electrical connections. The connections may be 
completed by using vias, tracks, or zones.

Net list
List of names of symbols or parts and their connection points which are logically 
connected in each net of a circuit. A net list can be extracted electronically on a 
computer from a properly prepared schematic.

Obstacle
An outline representing an object on the board. It must be taken into account 
during routing, placement, or copper pour.

Pad
On a PCB, a copper shape on one or more layers (there may be a hole and an 
isolation surrounding the copper) used for connecting a component pin to the 
PCB. The pad indicates where pins of a component are placed.

Padstack
A numbered list of pad descriptions. Each description contains a pad definition, 
including layer, style, drill diameter, size, offset, and solder mask guard width. 

PCB - Printed Circuit Board
A PCB is a board made up of components affixed to a common surface and 
connected by copper tracks.

Pin
The portion of a component to which an electrical connection can be made.

Ratsnest
A number of unrouted straight-line connections between two or more pads that 
represent the electrical connections in the netlist. The ratsnest serves as a 
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reminder that the pads must be connected, and that, currently, there is no track on 
the board to make that connection.

Reference designator
A character string denoting the type of component and a number that is specific 
to that component.

Routing
Placing conductive interconnects between components on a PCB layout. The 
process of turning nets into tracks.

Schematic
A graphical description of an electrical circuit.

Segment
The partial track that exists between two adjacent vertices or between a vertex 
and a pin. Sometimes the track between two pins is also called a segment, 
although connection is usually the more appropriate term here.

Signal
An electrical impulse of a predetermined voltage, current, polarity, and pulse 
width.

Silkscreen
Text or outlines (in ink) on the solder mask, on the top, and sometimes on the 
bottom of board modules. A silkscreen is used for component and identification 
placement on a PCB and usually includes component outlines, reference 
designators, polarity indicators, pin one markings, part numbers, the company 
name, and copyright info.

SMT - Surface Mount Technology
PCB technology whereby the leads on the chips and components are soldered 
onto the surface of the board rather than inserted into it. The use of SMT results 
in smaller and faster printed circuit boards.
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Solder mask
A negative plot of pads with a guard band around the pads. Also, a lacquer 
applied to prevent solder from adhering to unwanted areas on the PCB.

Solder paste
A pattern that serves as a template for solder paste application when the board is 
manufactured.

Solder side
The PCB surface opposite the one on which most components are mounted 
(component side). Also, the bottom layer of the board.

Test point
A special point of access to an electrical circuit that is used for electrical testing 
purposes.

Through-hole via
A via that connects the surface layers on a PCB.

Trace (Track)
The copper trails (electrical connection between two or more points) on the PCB 
and the onscreen representation of that copper.

Venting patterns
Patterns etched in the board that allow gases formed during fabrication to escape.

Vertex
A logical point at which a track is ended and restarted. A vertex is located at each 
change of direction on the track.
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Via (feed-through hole)
A hole connecting layers of a PCB. A through-hole via connects the surface 
layers of a board. On multilayer boards, a via not reaching a surface layer on one 
side is called a blind via, and a via not reaching a surface layer on either side, 
thus being externally invisible, is called a buried via.

Viastack
A numbered list of via descriptions. Each description contains a via definition, 
including layer, style, drill diameter, size, offset, and solder mask guard width.

Via stringer
The copper etch that exists between a SMT pad and a corresponding fanout via.

Zero-length connection
An unrouted connection between layers where the end points in the connection 
have the same X- and Y- coordinates.

Zone
An area on a PCB layer designated as copper or anti-copper. Copper zones may 
have net names, while anti-copper zones may not.
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Working with 3D Files
From AutoVue’s 3D mode, you can select model parts to transform independent 
of the rest of the model. You can import 3D models into the current window and 
export files to other formats. The Global Axes inform you of where the X, Y and 
Z axes are positioned throughout all the operations you perform in AutoVue.
The Perspective option shows objects in three dimension with distances, 
planes and curved surfaces adjusted to give a sense of depth. You have lighting 
options where you can adjust the overall lighting surrounding a model or just its 
source light.
In AutoVue’s 3D mode, you can customize operations to suit your needs. For 
example, you can create and save your own views. Define cross sections and cut-
throughs of 3D models. Create a customized three-axis coordinate system that 
you can set as the active coordinate system for your 3D files.
There are also features like Bill of Material (BOM), Interference Checking and 
Product and Manufacturing Information (PMI) Filtering.

Models Tab
The Models tab displays the model’s hierarchy, inter-relation of different parts, 
assemblies and bodies. With the Model tree, you can select different parts and 
modify their attributes such as color, visibility, render mode or transformation.

Views Tab
The Views tab lists all the standard and user-defined views. You can switch to a 
standard or user-defined view, as well as add or delete user-defined views.

Bookmarks Tab
The Bookmarks tab lists links to specific views (Draft views, 2D plans) or 
other files with information related to the model. Navigate between these files 
and views by clicking the appropriate link. Bookmarks lead to various views of 
CAD files such as CATIA file Model Space, the 3D model of a file and 
associated 2D engineering drafts.
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If a plus sign appears to the left of a bookmark, click it to expand and view the 
lower bookmark levels. If a minus sign appears to the left of the bookmark, click 
it to collapse the lower bookmark levels.
To go to a destination specified by a bookmark, click the bookmark text or the 
page icon located to the left of the bookmark text.

Global Axes
By default, there is a three-axis representation in the lower left corner of the 
workspace. The X-axis is red, the Y-axis is green and the Z-axis is yellow. 
When transforming a model or defining a viewpoint, all operations are applied 
with respect to these axes.

Selecting Model Parts
In AutoVue, you can select model parts from the Model Tree or from the 
workspace and have them appear highlighted in the Model Tree and on the 
model. You can also select a model part and have all its identical parts appear 
highlighted on the model and in the Model Tree.
Note  In AutoVue, you can configure the Selection Highlight, see 
Configuring AutoVue for 3D Files.

Selecting Model Parts from the Model Tree
1 Click the Models tab.
2 Select the part or parts from the Model Tree.

Note  To select more than one model part, press the Shift or Ctrl key while 
selecting.
The selected part(s) appear highlighted on the model and in the Model 
Tree.

Select Model Parts from the Workspace
1 Select a part or parts on the model in the workspace.

Note  To select more than one model part, press the Shift or Ctrl key while 
selecting.

2 To select the parent entities of a selected part, press the Shift key and select 
the part again.
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A pop-up appears listing the parent entities of the selected part. Select an 
entity from the pop-up list.
The selected part(s) appear highlighted on the model and in the Model 
Tree.

3 To select a group of parts, select Edit > Select, then click and drag the 
mouse around the parts. 
The entities within the box are selected and highlighted in the Model Tree.
Note  If the selected entity is hidden in the Model Tree, the Model Tree 
expands to display the selected entity.

Selecting All Identical Parts of a Model
1 Select a model part in the workspace or from the Model Tree, then right-

click and select Select Identical Parts from the pop-up menu.
All identical parts are highlighted on the model and in the Model Tree.
If there are no identical parts found, a message appears indicating No 
identical parts found.
Note  You can also select sub-assemblies and Select Identical Parts to 
display all identical sub-assemblies.

Hiding Model Parts
In AutoVue, you can hide specific parts of a model or display specific parts and 
hide the rest of the model.
1 Select the part or parts on the model or from the Model Tree.

Note  To select more than one model part, press the Shift or Ctrl key while 
selecting.
The selected part(s) appear highlighted on the model and in the Model 
Tree.

2 To hide the selected part(s), right-click a selected part on the model or from 
the Model Tree and select Hide from the pop-up menu.
The selected part(s) are hidden on the model.
To display the selected part(s) and hide the rest of the model, right-click a 
selected part on the model or from the Model Tree and select Hide Rest 
from the pop-up menu.
The selected parts are displayed in the workspace and the rest of the model is 
hidden.
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Re-centering
The Re-center option repositions the model back to the center of the View 
window. You can use a model part as a central reference point to reposition a 
model. You can select several model parts to use as one collective central 
reference point.

Re-centering a Model to a Selected Model 
Part
Note  The Re-Center > Selected option is only available when one or more 
model parts are selected. 
1 Select the model part or parts that you want to use.
2 Select View > Re-Center > Selected from the AutoVue main menu.

The model is repositioned using the selected model part or parts as the 
central reference point.

Re-center All
The Re-Center All option repositions the entire model back to the center of the 
AutoVue workspace.
1 Select View > Re-Center > All from the AutoVue main menu.

The model is repositioned to the center of the workspace.

Re-centering a Model to an Entity
You can use an entity as a central reference point to reposition a model. The 
entities are:

Entity Description

Vertex All vertices are highlighted. Select a vertex to use as the central refer-
ence point.
Note  A snap box appears when moving the mouse over a vertex.

Edge All edges are highlighted. Select an edge to use as the central reference 
point.
Note  A snap box appears when moving the mouse over an edge.
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1 Select View > Re-Center > Entity from the AutoVue main menu.
The Re-Center dialog appears.

2 Select the entity that you want to use as the central reference point.
All instances of the entity are highlighted.

3 Click an instance of the entity.
The model is repositioned using the selected entity as the central reference 
point.

4 Close the Re-Center dialog.

Expanding/Collapsing the Model 
Tree
In AutoVue, you can expand the Model Tree to display child entities of a 
selected node or nodes. 
Note  In AutoVue, you can also can configure the level you want to expand the  
Model Tree. To configure the Model Tree Level, see Configuring 
AutoVue for 3D Files.
1 Click the Models tab.
2 From the Model Tree, select the node or nodes that you want to expand, 

then right-click and select Expand All Children from the pop-up menu.
Note  To select more than one node, press the Shift or Ctrl key while 
selecting.
The selected entities are highlighted. The Model Tree expands displaying 
the child entities of the selected node(s).

Midedge Highlight all edges in the model. Select a mid-edge to use as the central 
reference point.

Arc Center Highlight all arcs and circles in the model. Select an arc center to use as 
the central reference point.
Note  A snap box appears when moving the mouse over an arc or 
circle, indicating the center of the arc.

Face Select a face to use as the central reference point.
Note  When moving the cursor along a model face, the face is 
highlighted.

Entity Description
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3 To collapse a node(s), select the node(s), then right-click and select 
Collapse All Children from the pop-up menu.
The Model Tree collapses the selected node(s).

Note  You can also expand a node by clicking . To collapse a node click 

.

Creating 3D Mockups
In AutoVue you can import other 3D Models into the current active file.
Note  The imported files must be 3D and have similar dimensions.
1 Select Analysis > DMU from the Autovue main menu.

The Import Design appears.
2 Click Add.

The Import Design Dialog appears.
3 Enter the File name or browse to locate the file you want to import.
4 Click Open.

The file appears in the Import Design dialog.
Note  To import more than one file, repeat steps 2 to 4.

5 Click OK.
The file(s) you imported appear in the workspace.
Note  Once open, you can position these models in the desired manner 
using the Transformation tool, or align the models using Part 
Alignment, or run Interference Checks. 
See Also   Transformation

  Part Alignment
 Performing Interference Checks

Deleting Models from a Mockup
1 Select Analysis > DMU from the Autovue main menu.

The Import Design dialog appears.
2 Select the file(s) that you want to remove.
3 Click Remove.

The file(s) are removed from the list.
4 Click OK.

The file(s) disappear from the workspace.
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Converting 3D Models to Other 
Formats
Sometimes you need to translate a 3D model to be able to use it with an 
application it was not created from. AutoVue provides several conversion file 
formats for you.

Conversion Options
Depending on the conversion type being performed, the available options in the 
Convert dialog will vary. These options are:

Option Description

Save As Specify the name and path of the file in which the con-
version is to be stored. This file is also known as the out-
put file. You can use Browse to provide AutoVue with 
the file’s path.

Convert to Format A drop-down list of all the possible types of output file 
formats currently available for conversion. The available 
formats are:
• CALS GP4
• Encapsulated Postscript (Raster)
• PCX Bitmap
• PDF
• Stereolithography (STL)
• TIFF
• Virtual Reality Modeling Language (VRML)
• Windows Bitmap

Sub-Format The Sub-Format drop-down list appears when you 
select TIFF or STL from the Convert to Format drop-
down list. 
Select the Sub-Format from the drop-down list.
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Color Depth Select an option from the drop-down list:
• 1 = Black and white
• 4 = 16 colors
• 8 = 256 colors
• 24 = True color
• auto = AutoVue selects the color depth that best 

matches the original file.
Note  Option is not available for STL and VRML 
formats.

Postive Triangle Values When selected, the model is translated so that all the ver-
tex coordinate values are positive.
Note  Option is only available when Convert  to 
Format is set to STL.

Convert Region The area of the file to be converted. The available 
options are:
• All  - converts the entire file
• Display - converts the image to fit on the output 

page
For example, if you zoomed in on a particular 
region of the file, the zoomed portion of the file is 
converted.

• Extent  - converts the entire extents of the file
• Selected  - converts the selected model parts in 

the file
Note  Options vary depending on the selected format.

Convert Pages The number of pages to be converted. The available 
options are:
• All - converts all pages of the file
• Current  - converts the current page of the file
• Range - converts the pages of the file indicated in 

the range
Note  Option is only enabled when converting to TIFF.

Option Description
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PDF
With AutoVue it is possible to convert Office, 2D and EDA formats to PDF. 
When converted from Markup Mode, markups are “burned” onto the PDF. 
When you open the PDF, you will see the base file along with all markups.

Converting a 3D Model
1 Select File > Convert from the Autovue main menu.

The Convert dialog appears.
2 In the Save As text box, enter the path and filename or click Browse to 

locate the directory where you want to convert the file to, then enter a file 
name.

3 From the Convert to Format drop-down list, select the format you want to 
convert the file to.
Note  The Output and Convert area options change according to the type 
of format you choose.

4 Select the output and convert options that you want to set for the file.
See  Conversion Options

5 Click OK.
The Conversion in progress dialog appears. The dialog disappears when 
the file is converted successfully.

Manipulating Views
AutoVue provides the flexibility to manipulate the display of a 3D model. You 
can rotate, scale or translate a model or any selection of model parts. You can 
also navigate from one page to another page of a multi-page file.

X and Y Specify X and Y to define the resolution for the con-
verted file.  Choose from pixels, inches and millimeters 
for the units.
• X indicates the number of horizontal pixels
• Y is the number of vertical pixels for the current 

active file contents
Note  At times, AutoVue presets X and Y to match the 
specifications of the selected conversion file format.

Option Description
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You can access these options from the View menu of the AutoVue main menu. 
The options are:

Select Description

Zoom In Zoom in by a factor of 2. 

Out Zoom out by a factor of 2. 

Fit Resize object to fit window.

From toolbar click the  icon or right-click 
in workspace and select from pop-up menu.

Previous Return to the previous zoom level.
Right-click in workspace and select from pop-
up menu.

Selected Resize the object so that the objects selected 
fill the window.

Box Mode Click and drag to draw a box around an object 
that you want to enlarge to fill the window.

From toolbar click  icon or right-click in 
workspace and select from pop-up menu.

Dynamic Mode Click and drag the cursor up to zoom in or 
down to zoom out.

From toolbar click  icon or right-click in 
workspace and select from pop-up menu.

Pan Click and drag to reposition the model, then 
release the mouse button.

From toolbar click  icon or right-click in 
the workspace and select from the pop-up 
menu

Rotate Mode Click and drag to rotate the model on all three 
axes, then release the mouse button.

From toolbar click  icon or right-click in 
workspace and select from pop-up menu.
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Spin Mode Click and drag the object in the direction you 
want the object to spin continuously, then 
release mouse button. To stop the object from 
spinning, click once anywhere in the work-
space.
Note   The spin velocity is determined by the 
speed at which you drag the mouse.

From toolbar click  icon.

Re-center Repositions the model.
Re-center All - reposition the entire model 
back to the center of the AutoVue workspace.
Selected - only available when one or more 
model parts are selected. The selected part or 
parts are considered as the central reference 
point by which the model is repositioned.
Entity - select a model part or entity as a 
central reference point to reposition a model.
See  Re-centering

Next Page Go to the next page of a multi-page file. 

Previous Page Go to the previous page of a multi-page file.

Page Number Go to the specified page of a multi-page file.

Perspective Show objects in three dimensions with the 
distances, planes and curved surfaces adjusted 
to give a sense of depth that reflects the 
desired perspective to the eye.

Views Display different views of 3D models or create 
your own.
Right-click in workspace and select the view 
from the pop-up menu.
See  3D Views

Display 
Attributes

Display a 3D model in different render modes.

From toolbar click  icon or right-click in 
workspace and select from pop-up menu.
See  Displaying Attributes

Select Description
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Display Attributes
AutoVue provides several different render methods to display a 3D CAD model. 
You can also adjust the degree of transparency, change color or visibility, to suit 
your preferences.

Render Modes
The choice of render mode varies between the level of detail and the render speed 
of the model. For example, a shaded model is three-dimensional and highly 
detailed but requires more time to render. The different render modes are:

Show Tree Show the Model Tree of the current active 
file.

From toolbar click  icon.

Method Description

Wireframe A skeletal model constructed using lines and curves that represent 
the model's "true" edges. All internal lines are visible.

Shaded A solid model constructed of planes and surfaces. These surfaces 
are shaded to increase the illusion of three dimensions.

Hidden Line A wireframe constructed with all internal lines hidden.

Silhouette A wireframe constructed with all internal lines visible but 
including additional silhouette edges. These are not "true" edges 
but help to visualize the model.

Wire Polygons A skeletal model constructed of unfilled polygons.

Shaded Wire An outlined solid model constructed of planes and surfaces. The 
outline is a solid line and the model's surfaces are shaded to 
increase the illusion of three dimensions.

Select Description
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Changing the Render Mode
Note  A checkmark beside the attribute indicates the current render mode.
1 From the AutoVue main menu, select View > Display Attributes and the 

render mode that you want to render the model in.
Note  You can also change the render mode for selected model parts.

Note  You can also click the Render Mode icon  on the AutoVue 
toolbar or right-click in the workspace and select Display Attributes. 
The model or selected model parts change to the selected render mode.

Changing the Visibility
In AutoVue, you can show or hide parts of a model.
1 From the Model Tree, clear the checkbox beside the model part(s) that you 

want to hide.
Select the checkbox beside the model part(s) that you want to set visible.
The selected model part(s) appear or disappear from the model.
Note  You can also hide model part(s) by selecting them on the model or 
from the Model Tree, then right-clicking and selecting Hide from the pop-
up menu. Selecting Hide Rest displays the selected model part(s) and hides 
the rest of the model.

Changing Model Color
In AutoVue, you can change the color of a specific model part or selected model 
parts.
1 Select the model or model parts whose color you want to change.

Note  If no part is selected, the change is applied to the entire model.
2 Select View > Display Attributes > Color from the AutoVue main menu.

The Color dialog appears.
3 Select the color that you want to change to.
4 Click OK.

The selected part(s) change to the selected color.
Note  To set the model color to its default color, repeat steps 1 to 2 and click 
Reset in the Color dialog.
Note  You can also right-click in the workspace and select Display 
Attributes > Color. In the Model Tree, you can select the model part(s), 
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then right-click and select Display Attributes > Color from the pop-up 
menu.

Adjusting the Transparency
You can adjust the degree of transparency of a model. This function only applies 
to shaded and shaded wire models.
1 Select the model or model parts whose transparency you want to adjust.
2 Select View > Display Attributes > Transparency from the AutoVue 

main menu.
The Set Transparency dialog appears.

3 To adjust the transparency, move the slider left or right.
Select Apply Dynamically if you want the transparency to simultaneously 
change with the movement of the slider.
Note  You can also adjust the transparency by entering a Value from 0 to 1:
0 = opaque
1 = transparent

4 Click Close to apply the changes and close the Set Transparency dialog.
Note  You can also right-click in the workspace and select Display 
Attributes > Transparency. In the Model Tree, you can select the 
model part(s), then right-click and select Display Attributes > 
Transparency from the pop-up menu.

Changing the Mesh Resolution
Note  A checkmark beside the mesh option indicates the current mesh 
resolution.
1 Select the parts that you want to change the mesh resolution.
2 From the AutoVue main menu, select View > Display Attributes > Mesh 

Resolution and then High, Medium or Low. 
Note  You can also change the mesh resolution by right-clicking in the 
workspace and selecting Display Attributes > Mesh Resolution. In the 
Model Tree, you can select the model part(s), then right-click and select 
Display Attributes > Mesh Resolution from the pop-up menu.
Note  Changing the mesh resolution will not affect the default Mesh 
Resolution set in the Configuration dialog.
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Light Settings
The default light setting consists of a white light positioned directly in front of 
the object as it is displayed. In the Lighting dialog it appears as a ball of white 
light in the center of the larger sphere.
Ambient lighting is the overall lighting that surrounds an object. It provides 
constant illumination to every surface of the model. This type of lighting is 
particularly effective as a fill-light for surfaces not directly illuminated by a 
directional light source. You can set the intensity or source position. Too high a 
setting tends to saturate the image and reduce its clarity.
Using the Directional lighting option, you can adjust the position of the light 
source on an object. 
In AutoVue, you can:
• set the intensity and source position of the ambient light
• set the direction of light
• add and remove light source
• change light color

See Also  Setting Ambient Lighting
Setting Directional Lighting
Adding a New Light Source
Changing the Light Color
Removing a Light Source

Setting Ambient Lighting
1 Select View > Set Light from the AutoVue main menu.

The Lighting dialog appears.

Note  You can also click the light bulb icon  on the AutoVue main 
toolbar. 

2 Click and drag the Ambient Light sliding bar until you achieve the desired 
lighting.
The lighting automatically changes with the movement of the sliding bar.
Note  To set the ambient lighting to its default setting, click Reset.

3 Click Close to close the Lighting dialog.
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Setting Directional Lighting
Setting the directional lighting adjusts the position of the light source on the 
model. You can also add a new light source.
1 Select View > Set Light from the AutoVue main menu.

The Lighting dialog appears.

Note  You can also click the light bulb icon  on the AutoVue main 
toolbar.

2 To change the direction of the light, click and drag the small ball until you 
achieve the desired lighting.
Note  You can also drag the white ball outside of the large ball.
The direction of the light reflected on the 3D model automatically changes 
with the movement of the white ball.
Note  To set the light direction to its default setting, click Reset.

3 Click Close to close the Lighting dialog.

Adding a New Light Source
1 Select View > Set Light from the AutoVue main menu.

The Lighting dialog appears.

Note  You can also click the light bulb icon  on the AutoVue main 
toolbar. 

2 Right-click inside the square surrounding the ball and select Create New 
Light source from the pop-up menu.
A second small ball appears.

3 Click and drag the small ball until you achieve the desired lighting.
Note  To restore the light source to its default setting, right-click inside the 
square and select Restore Default from the pop-up menu.

4 Click Close to close the Lighting dialog.
Note  You can add up to eight light sources.

Changing the Light Color
1 Select View > Set Light from the AutoVue main menu.

The Lighting dialog appears.

Note  You can also click the light bulb icon  on the AutoVue main 
toolbar.
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2 To change the color of the light source, right-click directly on the small ball 
and select Set Light Color.
The Color dialog appears.

3 Select a color.
4 Click OK.

The small ball changes color and the model reflects the selected light color.
Note  To set the light color to its default setting, click Reset in the 
Lighting dialog.

5 Click Close to close the Lighting dialog.

Removing a Light Source
1 Select View > Set Light from the AutoVue main menu.

The Lighting dialog appears.

Note  You can also click the light bulb icon  on the AutoVue main 
toolbar.

2 Right-click directly on the small ball that you want to remove and select 
Remove Light.
The small ball disappears and the light change is reflected.

3 Click Close to close the Lighting dialog.

3D Views
In AutoVue, you can display different views of 3D Models or create your own 
views.

Default View
The Default View is the isometric view for three-dimensional CAD models. 
This viewpoint has the viewing camera positioned at an equal distance from all 
three axes and pointing directly at the origin.

Setting Standard or Predefined Views
Rather than entering Rotation mode, you can view various predefined rotations 
with the Views option from View and Markup modes.
Note  A checkmark beside the view option indicates the current pre-defined 
view you want to display.
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1 From the AutoVue main menu, select View > Views and the pre-defined 
view you want to display. 
The model changes to the selected view.
The view options that you can select from are Isometric, Top, Bottom, Front, 
Back, Left and Right.
Note  You can also click the Views tab, then click the view from the 
Standard Views tree, or right-click in the workspace and select Views.

Setting Native Views
AutoVue displays views for a 3D file as saved in its native application. The views 
are listed under Native Views from the Views tab.
Note  Native views are present only if the file contains saved views.
1 From the AutoVue main menu, select View > Views > Native Views and 

the view you want to display.
The model re-orients to the selected view.
The view options vary depending on the file. Examples of the view options 
are Last Saved View, Presentation, Front, Back, Left, Right, Top, Bottom, 
Isometric, Trimetric and Dimetric.
Note  You can also right-click in the workspace and select Views > Native 
Views.

Creating a User-defined View
You may want to create and save your own views. AutoVue allows you to define 
a view and add it to the User Defined Views.
Note  You can define a user view in View or Markup mode. Any views you 
apply to displayed models during Markup mode are saved as part of the Markup.
1 Apply your own views or transformation to the displayed model.

Note  The view states that you can apply and save for your defined view are 
Extents, Rotation, Model Transformation, Explosion, Render Modes, Color, 
Transparency, Visibility, Sectioning, Camera Settings and views involving 
Mockups.

2 Select View > User Defined Views > Add from the AutoVue menu.
The Add User Defined View dialog appears.
Note  You can also click the Views tab, then right-click User Defined 
Views and select Add from the pop-up menu or right-click in the 
workspace and select Views > User Defined Views.

3 Enter a View Name for the view that you want to define.
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4 Click OK.
The view you defined is saved and appears in the Views tree under User 
Defined Views.
Note  To see the view you defined, click the Views tab and select it from 
the tree or select View > Views > User Defined Views. You can also 
alternate between User Defined Views and Standard Views without 
affecting your personalized views.

Deleting a User Defined View
1 Under the User Defined Views, select the view that you want to delete, 

then right-click and select Delete.
A Confirmation dialog appears.

2 Click OK.
The view disappears from the User Defined Views.

Displaying the Perspective Projection of a 
3D Model
The Perspective option shows objects in three dimensions with distances, 
planes and curved surfaces adjusted to give a sense of depth that reflects the 
desired perspective to the eye.
Note  You can use the Perspective option in any of the 3D Views since it is a 
projection mode rather than a viewpoint.
1 Select View > Perspective from the AutoVue main menu.

The depth of the model changes.
Note  A checkmark beside Perspective indicates the view is selected.

Viewing a Model from a Particular 
Viewpoint
To view a model from a particular point, you can specify a viewpoint.
1 Select View > Views > View Point from the AutoVue main menu.
2 The View Point dialog appears.

Note  You can also right-click in the workspace and select Views > View 
Point.

3 Enter the coordinates for X, Y and Z.
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For Camera Position, enter the coordinates to determine the position of 
the camera lens.
For Target Position, enter the coordinates to determine the position of the 
3D model viewed through the camera lens.
For Up Direction, change the coordinates to values between 0 and 1 to 
determine the upward orientation.

4 Click OK.
The entity moves to the defined viewpoint. The Global axes and the User 
Coordinates System change position to reflect the viewpoint.

Layers
Use this option to configure the current active file’s layers to display.
1 Select View > Layers from the AutoVue main menu.

The Select the layers to display dialog appears listing the layers and 
layer visibility for the current active file.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 To sort the list of layers in the dialog, click Name to sort alphabetically or 

numerically, or click Status to sort by visibility.
3 Select the checkbox beside the layers that you want to set visible.

Clear the checkbox beside the layers that you want to hide.
4 Click OK.

The selected layers are displayed.

Entity Properties
In AutoVue, you can view properties such as visibility, colors, transparency, mass 
properties and extents of a model or model parts.

Viewing Attributes
The Attributes tab displays a model or model part’s attributes. The list of  
attributes will vary depending on the model. Some of the viewable General 
attributes are:

Attribute Description

Color Color of the selected model part.
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If you are displaying the 3D view of an EDA, AutoVue displays the general 
attributes mentioned above. In addition, displays attributes specific to the Printed 
Circuit Board (PCB), such as component name, board side, component class and 
device type. 
If a 3D file has Product and Manufacturing Information (PMI) and a PMI entity 
is selected, the PMI attributes are displayed along with the above general 
attributes and attributes specific to the PCB board. Some of the viewable PMI 
attributes are X-Axis, Y-Axis, font color, text font name and tolerance type.
1 To view the attributes of specific model part(s), select the parts from the 

model.
To view the attributes of the entire 3D model, make sure that no parts are 
selected.

2 Select Analysis > Entity Properties form the AutoVue main menu.
The Entity Properties dialog appears.

Note  You can also click the Entity Properties icon  on the AutoVue 
toolbar or right-click in the workspace and select Entity Properties. In the 
Model Tree, select the model part(s), then right-click and select Entity 
Properties from the pop-up menu.

3 Click the Attributes tab.

Density The density of the model or selected model part(s).

Mesh Resolution The number of polygons drawn when displaying a model.

Name The model part name or the displayed page name of the  
model.

Render Mode The dynamic rendering used for displaying model or model 
part.  For example, Shaded, Shaded Wire and Wire-
frame.

Transparency The value between 0 and 1 representing the model or model 
part’s degree of transparency.
0 = opaque
1 = transparent

Visibility The value True (visible) or False (invisible) for a model or 
model part.

Attribute Description
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The attributes of the selected model part(s) are displayed in a hierarchical 
tree.

4 Click Close to close the Entity Properties dialog.

Viewing Mass Properties
The Mass Properties tab displays the precise measurements for mass, volume, 
area, center of gravity, moments of inertia and inertia tensor for any model or 
selection.
1 Select the part(s) for which you want to calculate the Mass Properties.

Note  To view the Mass Properties of the entire 3D model, make sure no 
parts are selected.

2 Select Analysis > Entity Properties from the AutoVue main menu.
The Entity Properties dialog appears.

Note  You can also click the Entity Properties icon  on the AutoVue 
toolbar or right-click in the workspace and select Entity Properties. In the 
Model Tree, select the model part or parts, then right-click and select 
Entity Properties from the pop-up menu.
Note  You can also right-click and select Entity Properties from the pop-
up menu.

3 Click the Mass Properties tab.
4 To change the density, or to change measurement units, or to configure 

computation of inertia tensor, click Options.
The Options dialog appears.
See   Configuring Mass Properties

5 Click Close to close the Entity Properties dialog.

Configuring Mass Properties
From the Mass Properties, you can change the density, the measurement units 
or configure the reference point of inertia tensor.
1 From the Mass Properties tab, click Options.

The Options dialog appears.
2 To change the Density, enter a value.

To change the Density units, select the unit for Mass and Length from 
their respective drop-down lists.

3 To apply the density to model parts with unknown density, select Use Only 
for Parts with Unknown Density.
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To apply the density to all model parts, select Use for All Parts.
4 To change the Display units, select the unit for Mass and Length from 

their respective drop-down lists.
5 To compute the inertia tensor based on output coordinate system, select 

Output Coordinate System Origin.
To compute the inertia tensor based on the center of gravity, select Center 
of Gravity. 

6 Click OK.
Mass properties are instantly calculated and displayed in the Mass 
Properties tab.

7 To save the changes, click Save As. The Save As dialog appears.
Specify the path where you want to store the file and enter the File name, 
then click Save. 
AutoVue saves the results in a csv (Comma Separated Values) file.

8 Click Close to close the Entity Properties dialog.

Viewing Extents
The Extents tab displays the orientation coordinates and center coordinates of 
the X, Y and Z axes for any model or selection, as well as the width, height and 
depth measurements.
1 Select the part(s) for which you want view Extents.

Note  To view the Extents of the entire 3D model, make sure no parts are 
selected.

2 Select Analysis > Entity Properties form the AutoVue main menu.
The Entity Properties dialog appears.

Note  You can also click the Entity Properties icon  on the AutoVue 
toolbar or right-click in the workspace and select Entity Properties. In the 
Model Tree, select the model part or parts, then right-click and select 
Entity Properties from the pop-up menu.

3 Click the Extents tab.
4 Click Transformed if you want to view the extents after you have 

transformed the model.
Click UnTransformed if you want to view the extents of the model 
without transformation.
Click Oriented if you want to view the X, Y and Z coordinates of the 
reoriented model or selection.

5 Click Close to close the Entity Properties dialog.
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PMI Filtering
A 3D file's Product and Manufacturing Information (PMI) is composed of 
annotations that are included in design files. These annotations indicate the limits 
and constraints that must be observed during the production of the object 
displayed in the 3D model.
At the highest level, PMI provides information about dimensions, feature control 
frames, weld specifications, and surface finishes. This information is based upon 
key design features which are specified through datum targets, measurement 
points, reference geometry (construction lines, surfaces, objects), or the geometry 
inherent in the object.
Use PMI Filtering to select which types of product and manufacturing 
information to display.
1 Select View > PMI Filtering from the AutoVue main menu.

The PMI Filtering dialog appears displaying all PMI types.

Note  You can also click the PMI Filtering icon  on the AutoVue 
toolbar.

2 In the Tree column, select the checkbox beside the items that you want to 
show in the Model Tree.
In the View column, select the checkbox beside the items that you want to 
show on the model.
Clear the checkbox beside the items that you want to hide.
Note  To show or hide all items, click All to show all or None to hide all.

3 Click OK.
Only items selected in the Tree column are displayed in the Model Tree.
Only items selected in the View column are visible on the 3D model.
Note  Visibility settings are saved and will be restored the next time you 
open the PMI filtering dialog. 

4 AutoVue supports default PMI visibility as saved in the file. To restore 
default PMI visibility, click Default in the PMI Filtering dialog.

Aligning to a PMI Entity
From the Model Tree, right-click the PMI item that you want to align to and 
select Align to from the pop-up menu.
AutoVue aligns to the selected PMI item.
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Go To a displayed PMI Entity
From the Model Tree, right-click the PMI item that you want to go to on the 
model and select Go To from the pop-up menu.
AutoVue zooms to the selected PMI item.

Manipulators
In AutoVue, you can rotate 3D CAD models along a specific axis. You can scale 
a model part up and down, as well as translate the model.
Using the Manipulators, you can resize, translate and/or rotate selected parts of 
the model. When you select one or more model parts, AutoVue displays a model-
size representation of the Global Axes going through the selected part(s) of the 
3D model.

Panning a Model Along the X, Y and Z-Axis
1 Select Analysis > Manipulators from the AutoVue main menu.

You are now in Manipulators mode.

Note  You can also click the Manipulators icon  on the AutoVue 
toolbar or right-click in the workspace and select Manipulators. In the 
Model Tree, you can select the model part(s), then right-click and select 
Manipulators from the pop-up menu.

2 Select the model part or parts that you want to move.
Note  To select more than one part, press the Shift or Ctrl key when 
selecting.
A model-size representation of the Global Axes appears through the model 
part or parts and are encased by a three-dimensional box.

3 Click and hold the mouse button on the arrow at the end of the axis that you 
want to pan.

4 Drag the mouse to where you want to move the part or parts.
Note  To remove the Manipulators, click the Manipulators icon. 

Rotating a Model Along the X, Y and Z-Axis
1 Select Analysis > Manipulators from the AutoVue main menu.

You are now in Manipulators mode.
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Note  You can also click the Manipulators icon  on the AutoVue 
toolbar or right-click in the workspace and select Manipulators. In the 
Model Tree, you can select the model part(s), then right-click and select 
Manipulators from the pop-up menu.

2 Select the model part or parts that you want to manipulate.
Note  To select more than one part, press the Shift or Ctrl key when 
selecting.
A model-size representation of the Global Axes appears through the model 
part or parts and are enclosed by a three-dimensional box.

3 Click and hold the mouse button on the sphere at the end of the axis you 
want to rotate. 
Clicking on an axis sphere allows rotation around one of the other two axes. 
Note  The initial mouse movement determines which of the two axes will 
mark the site of rotation. If the axis you chose does not rotate around the 
right axis for the rotation that you want to make, click the sphere again and 
move the mouse in a different direction.

4 Move the mouse to rotate the model by the selected axis. 
Note  If you want to rotate the selection freely, as done in Rotate Mode, 
press the Ctrl key during rotation.

5 To remove the Manipulators, click the Manipulators  icon.
Note  To remove Manipulators, you can also select Analysis > 
Manipulators. 
Mouse actions are restored to what they were prior to entering Manipulators 
mode.

Scaling a Model Along the X, Y and Z-Axis
1 Select Analysis > Manipulators from the AutoVue main menu.

You are now in Manipulators mode.

Note  You can also click the Manipulators icon  on the AutoVue 
toolbar or right-click in the workspace and select Manipulators. In the 
Model Tree, you can select the model part(s), then right-click and select 
Manipulators from the pop-up menu.

2 Select the model part or parts that you want to scale.
Note  To select more than one part, press the Shift or Ctrl key when 
selecting.
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A model-size representation of the Global Axes appears through the model 
part or parts and are encased by a three-dimensional box.

3 Click and drag a corner cube of the box up or down to scale the selected 
model part.
Note  To remove the Manipulators, click the Manipulators icon. 

Part Alignment
With the Part Alignment option in AutoVue, you can select a point on a 
model’s vertex, edge or face to align a model or model part to another model or 
part.
The Mobile point determines the precise point of alignment for the model part. 
The Fixed point on the model determines the precise fixed point to which the 
mobile part will align.
With the Show Preview option, you can visualize the part alignment before 
applying the change.
When aligning models parts, you can choose from one of the following 
Constraint Types.

Option Type Description

Constraint Coincident The Mobile part is positioned so that the 
selected point on the mobile part coincides 
with the selected part on the Fixed part.

Parallel Align the Mobile point so that it is parallel to 
the Fixed point.

Perpendicular Align the Mobile point so that it is 
perpendicular to the Fixed point.

Concentric Align the Mobile point so that it has the same 
center as the Fixed point
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Part Alignment Constraints
The table below list the available Constraint Types for different combinations 
of part alignment.

Note  The letters in the table indicate the Constraint Type:
Where:
Coin - Coincident
Par - Parallel
Per - Perpendicular
Con - Concentric

Aligning Model Parts
Note  To see a preview of the alignment before applying the change, click 
Show Preview.
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1 Select Analysis > Part Alignment from the AutoVue main menu.
The Part Alignment dialog appears.

Note  You can also click the Part Alignment icon  on the AutoVue 
toolbar or right-click in the workspace and select Part Alignment. In the 
Model Tree, you can select the model part(s), then right-click and select 
Part Alignment from the pop-up menu.

2 Select the Constraint Type that you want to perform.
See   Part Alignment Constraints

3 Select the Alignment Type.
Select Aligned if you want to align the Mobile point on the model part to 
the Fixed point on the model.
Select Anti-Aligned if you want to align the Mobile point on the model 
part so that it is opposite to the Fixed point on the model.

4 Select a model part. The Mobile arrow  is enabled.

5 Click Vertex , Edge  or Face  to select the type of 
geometrical point you want to click on the model part to be aligned.
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All instances of the selected geometrical point appear highlighted.
6 Click the geometrical point on the selected model part.

The geometrical point is highlighted. 

The Fixed arrow  is enabled.

7 Click Vertex , Edge  or Face  to select the type of 
geometrical point you want to click on the model part to remain fixed.

8 Click the geometrical point on the model.
9 Click Apply.

The model part is aligned according to the chosen options. The Constraint 
Type and the types of geometrical points aligned appear under 
Constraints.
Note  To remove a constraint, select the Constraint that you want to 
remove, then click Remove. To remove all part alignments, click Remove 
All.

10 Click Close to close the Part Alignment dialog.
Note  If you did not apply the changes before clicking Close, a message 
appears indicating Do you wish to apply the constraint(s)?

Transformation
With the Transformation option, you can rotate, scale or translate a model or 
any selection of model parts, by using the illustrated buttons or by entering X, Y 
or Z values.
To access the Transformation dialog, you can select Analysis > Transform 

> Apply from the AutoVue menu, or click the Transform icon  on the 
AutoVue toolbar. From the Model Tree, you can select the model part(s), then 
right-click and select Transform > Apply from the pop-up menu.
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The buttons on the left correspond to the rotational moves along the three axes. 
The buttons on the right correspond to the translational moves along the three 
axes and the scaling up and down.

Transforming a Model using Illustration 
Buttons
1 Select Analysis > Transform > Apply from the AutoVue main menu.

The Transformation dialog appears.

Note  You can also click the Transform icon  on the AutoVue toolbar. 
2 Select the model part or parts that you want to rotate, translate or scale.

Note  To select more than one model part, press the Shift or Ctrl key while 
selecting. 
Note  If no part is selected, transformation is applied to the entire model.
Cimmetry Systems Corp.



AutoVue 121
3 Click the direction buttons on the left-hand side to rotate the model in the 
direction that you want.
Click the translate buttons on the right-hand side to move the model in the 
direction that you want.

To scale the model, click  to scale up or click  to scale down.

Note  To repeat a transformation, continue clicking the illustrated button.
Note  Click Reset to set the model to its original transformation.

4 Click Close to close the Transformation dialog.
The transformation state remains displayed.
See Also   Resetting he Transformation of a 3D Model

Transforming a Model by Setting Values
1 Select Analysis > Transform > Apply from the AutoVue main menu.

The Transformation dialog appears.

Note  You can also click the Transform icon  on the AutoVue toolbar.
2 Select the model part or parts that you want to rotate, translate or scale.

Note  To select more than one model part, press the Shift or Ctrl key while 
selecting.

3 To rotate the model by set values, enter the X, Y and Z value.
To translate the model by set values, enter the X, Y and Z value.

4 To view a mirror image, select the checkbox beside the Mirror plane.
5 To scale the model by a factor, enter a Scale Factor. 
6 Click OK.

To apply absolute transformation instead of incremental, select Absolute.
7 Click Apply in the Transformation dialog.
8 To repeat a transformation, ensure that Absolute is cleared, then continue 

clicking Apply.
Note  Click Reset to set the model to its original transformation.

9 Click Close to close the Transformation dialog.
The transformation state remains displayed.
See Also   Resetting the Transformation of a 3D Model
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Resetting the Transformation of a 3D 
Model
In AutoVue, you can reset a model or selected parts to their original 
transformation. 
1 View the transformed 3D Model in AutoVue.
2 To reset the entire model to its original transformation, select Analysis > 

Transform > Reset All.
To reset selected model part(s) to their original transformation, select the 
part(s) on the model, then select Analysis Transform > Reset Selected.
The model or selected parts changes to their original transformation.
Note  You can also reset selected model part(s), by clearing the checkmark 
beside the part(s) in the Transformation column  of the Model Tree.

Cross Section/Cut-through
With Cross Section/Cut-through feature, you can view the cross-section and 
cut-through of 3D models. In the Define Section dialog you can define the 
section plane position, section plane orientation and the cut-through.

Section Plane Options
In the Define Section dialog, you can use below options to define the 
orientation of the section plane.

Option Description

XY Plane Section plane is oriented along the XY plane.

YZ Plane Section plane is oriented along the YZ plane.

XZ Plane Section plane is oriented along the XZ plane.

From 3 Vertices Select three vertices on the object to define the orienta-
tion of the section plane.

From Face Normal Select a face on the object to define the orientation of the 
section plane perpendicular to the face.
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Cut Options
In the Define Section dialog, you can use cut-options to define the cut-through 
of an object.

Defining the Section Plane and Cut-
through
1 Select Analysis > Section > Define from the AutoVue main menu.

The Define Section dialog appears.

Note  You can also click the Define Section icon  on the AutoVue 
toolbar. In the Model Tree, you can select model part(s), then right-click 
and select Section > Define from the pop-up menu.

2 From the Section Plane drop-down list, select the orientation for the 
section plane.
See  Section Plane Options

3 From the Cut Options drop-down list, select the cut option that you want.
See   Cut Options

From Edge Tangent Select an edge on the object to define the orientation of 
the section plane perpendicular to the edge’s tangent.

Define a Plane Define X, Y and Z coordinates to orient the section 
plane.

Option Description

Don’t Cut Display the object without a cut.

Cut Object displayed is cut along the section plane.

Invert Reverse the selection, display the other part of the 
object.

Show Both Restore the cut part of the object. 

Edges Only Display only the edges of the object along the section 
plane.

Option Description
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4 To define the plane position, click and drag the Plane Position slider to the 
position you want.
Click Dynamic, if you want the plane to move simultaneously with the 
slider.

5 Select Show Plane, if you want the section plane visible.
6 Select Fill, if you want the section plane filled.

The section plane is displayed as filled and the Section Area is calculated.
Note  Fill color can be set from the Configuration dialog.

7 From the Measured Units drop-down list, select the unit in which you 
want to measure the section surface.

8 Click Close to close the Define Section dialog.
9 Once you have defined the section plane and closed the Define Section 

dialog, you can access the cut options from the Section menu.
10 To remove a previously defined section, select Section > Remove from 

the AutoVue main menu. 
The section plane and cut section disappears instantly.

Exporting Section Edges
In AutoVue, you can export a copy of the section plane and save it as a .dxf or 
.dwg file.
1 Define a section plane.
2 Select Analysis > Section > Export from the AutoVue main menu or if 

the Define Section dialog is open, click Export.
The Export Section As dialog appears.

Note  You can also click the Define Section icon  on the AutoVue 
toolbar. From the Model Tree, you can select the model part(s), then right-
click and select Section > Export.

3 From the Save in drop-down list, select the directory where you want to 
export a copy to.

4 Enter the file name.
5 Select the Save as type from the drop-down list.

Note  You can only save the file in .dxf or .dwg format.
6 Click Save.

Note  To remove a section plane, select Section > Remove from the 
AutoVue main menu.
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Exploding
In AutoVue, users can use the Explode option to better understand the structure 
of an assembly and to analyze the dismount capability. The user can also save the 
exploded view, as well as obtain a printed document of the exploded product for 
further analysis.

Explode Options
From the Explode dialog, you can define how the explosion is to be performed 
and to visually explode or implode a model. The options that you can set are:

Option Description

Maximum Depth Define up to which level you want to explode. All entities 
from the root level to the specified level are exploded. All 
entities on the other levels will not be exploded. 
If you are exploding:
• Whole model - the number of available levels depends 

on how many explodable levels exist in the model. For 
example, if there are four levels, with level 2 being the 
first level under the main assembly, then level 3 and 
level 4 are added to the drop-down list.

• Selected parts - the number of available levels to be 
added to the drop-down list depends on the selected vir-
tual tree.

Animated When selected, animation is shown while exploding or 
imploding the model.

Show Arrows When selected, arrows are displayed in an explosion assem-
bly. The arrow starts from an exploded entity and points to the 
center point of its parent.
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Exploding a 3D Model
1 Select Analysis > Explode from the AutoVue main menu.
2 Select the parts that you want to explode.

Note  To select more than one model part, press the Shift or Ctrl key while 
selecting.
To explode the entire model, ensure that no parts are selected.

3 From the Maximum Depth drop-down list, select the level to which you 
want the model to explode.

4 Select Animated if you want to see an animated view of the explosion. Set 
by default.

5 Select Show Arrows if you want to display the arrows.

6 To explode the model, click the  button. 
The whole model or the select model parts explode.
See   Saving an Exploded View of a 3D Model

Note  To implode the model, click the  button. To manually change 
the explosion state, click and drag the scroll bar.

7 Click OK to close the Explode dialog.

The explode state remains displayed and theTransformation column  in 
the Model Tree is updated indicating the exploded parts.
See Also   Resetting the Transformation of a 3D Model

Saving an Exploded View of a 3D Model
From the Explode dialog, you can save the exploded view of the 3D model.

Scroll Explode Dragging the slider gradually displays the progression of the 
explosion to show the explosion dynamics.

• Explode - pressing the  button brings the 
explosion level to the (n-1) level if current explosion 
level is between n-1 (inclusive) and n level (exclusive).

• Implode - pressing the  button brings the 
explosion level to the n level if current explosion level is 
between n-1 (exclusive) and n level (inclusive).

Option Description
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1 Explode a 3D Model.
See   Exploding a 3D Model

2 Click Save View in the Explode dialog.
The Add User Defined View dialog appears.

3 Enter a View Name.
4 Click OK.

The view is saved and appears in the Views tree under User Defined 
Views.

5 Click OK to close the Explode dialog.
The exploded state is saved.
See Also   Resetting the Transformation of a 3D Model

User-defined Coordinate Systems
In AutoVue you have the option of creating customized three-axis coordinate 
systems. As with the Global Axes and the World Coordinate System, the 
user-defined axes are represented by a red X-axis, a green Y- axis and a yellow Z-
axis.
When you set a User-defined Coordinate System (UCS) as the active axes, 
operations such as measuring, transforming a model, or defining a viewpoint are 
applied with respect to these axes.
You can create multiple UCS’s for a 3D file. For multiple-page 3D files, you can 
even set active a different UCS for each page.

Position Options
When defining a UCS, you can define the point where you want to place the user 
coordinate system. The options are:

Position Description

(x, y, z) Coordinates If selected, enter a value to specify where the three axes 
are positioned.
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Vertex If selected, all vertices are highlighted on the model. A 
snap box appears when you move the cursor on a vertex. 
Click the vertex point where you want to place the user 
coordinate system. The x, y and z coordinate values for 
the vertex are displayed. The UCS axes move to the new 
position.

Edge If selected, all edges are highlighted on the model. A 
snap box appears when you move the cursor near an 
edge. Click at a point on an edge where you want to 
place the user coordinate system. The x, y and z 
coordinate values for the edge point are displayed. The 
UCS axes move to the new position.

Midedge If selected, all edges are highlighted on the model. A 
snap box appears when you move the cursor near the 
halfway point of an edge. Click at the mid-edge point 
where you want to place the user coordinate system. The 
x, y and z coordinate values for the mid-edge point are 
displayed. The UCS axes move to the new position.

Arc Center If selected, all arcs and circles are highlighted on the 
model. A snap box appears when you move the cursor 
near the center of a circle or arc. Click on the arc center 
where you want to place the user coordinate system. The 
x, y and z coordinate values for the arc center are 
displayed. The UCS axes move to the new position.

Face If selected, when you move the cursor along a model 
face, the face is highlighted. Click at a point on the face 
where you want to place the user coordinate system. The 
x, y and z coordinate values for the arc center are 
displayed. The UCS axes move to the new position.

Position Description
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Orientation Options
When defining a UCS, you can define the orientation for the coordinate system. 
The options are:

Position Description

(x, y, z) Coordinates If selected, enter a value to specify the UCS orientation 
according to one or more of the three axes.

Edge Tangent If selected, all edges are highlighted on the model. A 
snap box appears when you move the cursor near an 
edge. First select the axis that will determine the UCS 
orientation. Click at a point on an edge to define the 
orientation. The x, y and z values for the edge point are 
displayed. The UCS axes are reoriented to the selected 
edge.

Face Normal If selected, when you move the cursor along a model 
face, the face is highlighted. First select the axis that will 
determine the UCS orientation. Click at a point on an 
face to define the orientation. The x, y and z values for 
the face point are displayed. The UCS axes are reori-
ented to the selected face.

2 Vertices If selected, all vertices are highlighted on the model. A 
snap box appears when you move the cursor on a vertex. 
First select the axis that will determine the UCS 
orientation. Click two vertex points to define the 
orientation. The x, y and z values for the vertices are 
displayed. The UCS axes are reoriented to the selected 
vertices.

3 Vertices If selected, all vertices are highlighted on the model. A 
snap box appears when you move the cursor on a vertex. 
First select the axis that will determine the UCS orienta-
tion. Click three vertex points to define the orientation. 
The x, y and z values for the vertices are displayed. The 
UCS axes are reoriented to the selected vertices.
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Defining a User Coordinate System
1 Select Analysis > User Coordinate Systems from the AutoVue main 

menu.
The User Coordinate Systems dialog appears.

Note  You can also click the User Coordinate Systems icon  on the 
AutoVue toolbar.

2 Click New.
The name of the User-defined Coordinate System (UCS1 for the first one) 
appears in the Coordinate Systems box.

3 To change the name, type the new Name that you want for the UCS.
4 Click the Position tab to define the origin of the UCS.
5 From the Define from drop-down list, select the point where you want the 

UCS axes to appear.
See    Position Options

6 Click the Orientation tab to define the orientation of the UCS.
7 From the Define from drop-down list, select the point where you want to 

orient the UCS.
See   Orientation Options

8 To hide the UCS axes on the model, clear the checkbox beside Show 
Trihedron. Enabled by default. 

9 Click OK.
The newly active trihedral coordinate system appears bolder and larger and 
its name appears in the User Coordinate Systems drop-down list on the 
AutoVue toolbar.
Note  If there is more than one coordinate system for this file, select which 
coordinate system the new UCS will be Relative To. Otherwise, the new 
UCS will be calculated with respect to the World Coordinate System.

10 Click OK to close the User Coordinate Systems dialog.

Modifying a User-defined Coordinate 
System
1 Select Analysis > User Coordinate Systems from the AutoVue main 

menu.
The User Coordinate Systems dialog appears.
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Note  You can also click the User Coordinate Systems icon  on the 
AutoVue toolbar.

2 From the Coordinate Systems list, select the UCS that you want to 
modify.
The settings you configured for the UCS are displayed.

3 To change the Name, highlight the name and enter the new name.
4 To change the Position, click the Position tab, then select the point where 

you want the UCS axes to appear from the Define From drop-down list.
See    Position Options

5 To change the Orientation, click the Orientation tab, then select the point 
where you want to orient the UCS from the Define From drop-down list.
See   Orientation Options

6 To show the UCS axes, select Show Trihedron. To hide the UCS axes, 
clear the checkmark.

7 To change the UCS that it is relative to, select the UCS from the Relative 
To drop-down list.

8 Click OK to close the User Coordinate Systems dialog.
If you modified the Position or Orientation, the UCS axes dynamically 
move to the new position. A change in Show Trihedron, will make the 
UCS axes appear or disappear accordingly. A Name change, will display 
the new name in the Coordinate Systems list and in the drop-down list 
next to the UCS icon  on the toolbar.

Activating a Coordinate System
When you set a user-defined coordinate system (UCS) as the active axes, 
operations such as measuring, transforming a model or defining a viewpoint are 
applied with respect to these axes.
1 From the User Coordinate Systems dialog, select the Coordinate 

System that you want to use.
2 Click Set Active.
3 Click OK to close the User Coordinate Systems dialog.

The newly active trihedral coordinate system appears bolder and larger on 
the model and its name is displayed in the drop-down list next to the UCS 

icon  on the AutoVue toolbar.
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Note  You can also set a different coordinate system from the User 

Coordinate Systems drop-down list next to the UCS icon  on the 
toolbar.

Deleting a User Coordinate System
1 From the User Coordinate Systems dialog, select the Coordinate 

System that you want to delete.
2 Click Delete.

Note  The UCS disappears from the list and from the User Coordinate 

Systems drop-down list next to the UCS icon  on the toolbar.
3 Click OK to close the User Coordinate Systems dialog.

Interference Checks
In AutoVue, you can check for spatial interference of any two model parts.

Interference Check Options
With the Interference Checking option, you can perform different 
interference checks. These checks are: 

Performing an Interference Check
1 Select Analysis > Interference Checking from the AutoVue main 

menu.

Check Description

All Against All Check for interference of any of the parts in the model.

Set Against the Rest Check where a model part or set of model parts interfere 
with other model part(s).

Set Against Itself Check where a model part or set of model parts interfere 
with itself.

Set 1 Against Set 2 Check where a model part or set of model parts interfere 
with another model part or set of model parts.
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The Interference Checking dialog appears.

Note  You can also click the Interference Checking icon  on the 
AutoVue toolbar.

2 Click the type of interference check that you want to perform.
See  Interference Check Options

3 If you selected Set Against the Rest or Set Against Itself, select one or 
more model parts on the model or from the Model Tree.
Note  To select more than one model part, press the Shift or Ctrl key while 
selecting. 
The model part(s) appear in the Selected Set list and are highlighted on the 
model and in the Model Tree.
Note  To clear the last set of selected model part(s), click Clear.

4 If you selected Set 1 Against Set 2, click the Set 1 arrow , then select 
one or more model parts on the model or from the Model Tree.
The model part(s) appear in the Set 1 list and are highlighted on the model 
and in the Model Tree.
Note  To clear a selected part, press the Ctrl key and click on the part on the 
model. To clear the last set of selected model part(s), click Clear.
Click the Set 2 arrow  then select one or more model parts on the model 
or from the Model Tree.
The model part(s) appear in the Set 2 list and are highlighted in a different 
color on the model and in the Model Tree.

5 Enter a Minimum Clearance Distance. Default value is 0.
Note  Adding a Minimum Clearance Distance not only checks if the 
two model parts interfere, but also checks if they are located within a set 
minimum distance.

6 From the Units drop-down list, select the unit for the clearance distance.
7 To configure the interference check results, click Options.

The Options dialog appears.
See   Interference Check Results Options

8 Click Compute in the Interference Checking dialog.
Compute button changes to Stop.
Note  Section plane is not taken into consideration when computing an 
interface check.
Note  To stop the Interference Checking process at any point, click Stop.
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When the process is complete, all the instances of interfering pairs appear in 
the Results list. The number of interfering pairs found appears in the 
Description box.
Note  To view a pair’s interference information, click the corresponding 
Results line. The information appears in the Description box and 
AutoVue zooms into the interfering area.

9 To save the results, click Export.
The Export Results dialog appears.

10 Specify the file name and the directory where you want to save the file.
11 Click Save.

AutoVue saves the results in a csv (Comma Separated Values) file.
Note  To perform another interference check click Reset, then click the 
type of interference check.

12 Click Close to close the Interference Checking dialog.

Interference Check Results Options
With AutoVue, you can configure the results of an Interference Check. The 
configuration options are:
• Actions - provides a close-up look at how model parts interfere
• Selected Pair - configure if the selected pair from the Results list should 

display opaque, transparent or hidden
• The Rest - configure if the other parts of the model should display 

transparent or hidden while the selected pair is displayed

Option Select Description

Actions Zoom To Once the interference check is computed 
and a result set is selected  from the list of 
results, AutoVue zooms to the result.

Show Intersection Once the interference check is computed 
and a result set is selected  from the list of 
results, AutoVue shows where the 
intersection of model parts occur.

Selected Pair Opaque The selected pair from the list of results 
appear opaque.

Transparent The selected pair from the list of results 
appear transparent.
Cimmetry Systems Corp.



AutoVue 135
Comparing 3D Files
AutoVue provides the ability to compare two 3D files or two sets of entities from 
the same file or different files and display color-coded comparative data. When 
you compare two files, Autovue displays a Compare Tree and three windows, 
the first containing the base file, the second containing the file you compared the 
base against, and the third containing the comparison results.
The Compare Tree displays the model’s hierarchy with a State column 
displaying different icons representing the results of the file comparison. The 

icons indicate if an model part has been added , modified , moved  
deleted .
In the Comparison Result window, results are displayed in different colors to 
differentiate the results of the file comparison. The comparison options and 
corresponding colors are:

To compare files:
1 View the base file in AutoVue.
2 Select Analysis > Compare from the Autovue main menu.

The Open dialog appears.

Hide The selected pair from the list of results 
appear hidden.

The Rest Transparent The rest of the model appears transparent 
while the selected pair is displayed.

Hide The rest of the model is hidden while the 
selected pair is displayed.

Option Color Description

View Additions Green Indicates that something has been added.

View Deletions Red Indicates that something has been deleted.

View Unchanged Blue Indicates that there is no change.

Option Select Description
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3 Enter the File name or browse to locate the file you want to compare with 
the current active file.

4 Click Open.
AutoVue displays the Compare Tree and three windows. The first window 
displays the base file, the second displays the compare file and the third 
displays the comparison results.

5 To view the properties of a modified or moved entity in the base file and in 

the compare file, select the modified  or moved  entity from the 
Compare Tree, then right-click and select Entity 1 Properties.
The Entity Properties dialog appears displaying the properties of the 
entity in the base file.
See   Entity Properties
Select the entity again, then right-click and select Entity 2 Properties.
The Entity Properties dialog display the properties of the entity in the 
compare file.

6 To compare the results of the entity in the base file to the compare file, select 
the entity from Compare Tree, then right-click and select Compare 
results.
The Compare results dialog appears.
To view the attribute differences, click Attributes.
To view the transformation difference, click Transformation.
Note  If there are no attribute or transformation differences, the buttons are 
disabled.

7 Click OK to close the Compare results dialog.
8 To exit Compare mode, select File > Exit Compare Mode from the 

AutoVue main menu.
The base file appears in the workspace.
Note  You can also exit Compare mode by right-clicking in any of the 
windows and selecting Exit Compare Mode from the pop-up menu.

Comparing Entity Sets
From the file comparison, you can compare a set of entities from one file against 
a set of entities from the another file. You can also compare sets of entities from 
the same file.
1 Select the files you want to compare.

See   Comparing 3D Files
2 Select File > Compare Sets.

The Compare Sets dialog appears.
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3 Click  Set 1. Set by default.
4 Select the entities from either the tree on the left or the tree on the right.

Note  The tree on the left is the base file and the tree on the right is the 
compare file.
The selected entities appear in the Set 1 list.

5 Click  Set 2 point.
6 Select the entities from the other tree that you did not select for Set 1.

The selected entities appear in the Set 2 list.
Note  To compare entities from the same file, select the entities for Set 1 
and Set 2 from either the base file or the compare file.

7 Click OK.
The Compare Tree and the three windows are updated with the set 
comparison results.

8 To restore the comparison files, select File > Compare Files.
The files appear in the three windows.
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Generating a Bill of Material
For 3D files, you can obtain a list with a count of the parts required for 
manufacturing the item featured in the file.
To generate a Bill of Material:
1 Select Analysis > Bill of Material from the AutoVue main menu.

The Bill of Material dialog appears.

2 To sort the list numerically, click the Count column header. 
To sort the list alphabetically, click the Part Names column header.

3 To view a part or parts on the model, select the part(s) from the Part 
Names list. 
Note  To select more than one part, press the Shift or Ctrl key while 
selecting.
The parts are highlighted on the model and in the Model Tree.

4 To save the Bill of Material, click Export. The Save As dialog appears.
Enter a File name or browse to locate the directory where you want to store 
the file, then click Save.
AutoVue saves the results in a csv (Comma Separated Values) or xml file.

5 Click Close to close the Bill of Material dialog.
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Entity Search
AutoVue allows you to search for entities in a 3D Model using the Entity 
Search dialog. You can search the whole model or selected entities on the 
model, apply attributes, entity type or PMI filters as search criteria to filter 
entities. You can also search for entities by the size of an entity and location or 
select entities from the results list and have them appear highlighted in the 
workspace and in the Model Tree. 
The Search options are:

Where Option Description

3D Search 
tab

Selection Specify if you want to search the entire model or 
selected parts or parts that are not selected.

Type Specify the type of entity you want to search. For exam-
ple, part, body, assembly or PMI.

Show PMI 
parent entity 
in results

When selected, displays only the parent entity of a PMI 
entity that matches search criteria.
If cleared, displays PMI entities that match search crite-
ria in the Results dialog.
Note  Option is enabled if Type is set to PMI or All 
and file has PMI entities.

PMI Filter Filters the entities that have PMI information. 
Note  Option is enabled if Type is set to PMI or All.

PMI Type Specify the specific PMI attribute you want to search.
Note  Option is disabled if PMI Filter is set to All.
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Performing a Search
1 Select Analysis > Entity Search from the AutoVue menu.

The Entity Search dialog appears.

Note  You can also click the Entity Search icon  on the AutoVue 
toolbar.

Attribute 
Filter 
dialog

Name Specify the specific attribute you want to search. The 
available attributes are:
• Colour
• Density
• Display_Mode
• Filepath
• Layer_ID
• Mesh_Resolution
• Name
• Shading_Style
• Translucency
• Visibility
Note  Additional attributes may be available 
depending on the file selected.

Any Value When selected, AutoVue searches for any value of the 
selected attribute.
Note  The attribute value options are disabled.
If cleared, specify the values for the selected attribute 
you want to search.
Note  The attribute value options correspond to the 
selected attribute.

Advanced 
3D Search 
tab

Volume Specify the size of an entity, the minimum and 
maximum dimensions. The dimensions of an entity 
boundary box must be between the specified 
dimensions to meet the search criteria.

Location Specify an axes aligned boundary box. The boundary 
box of an entity must be inside it to meet the search cri-
teria.

Where Option Description
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2 Click the 3D Search tab.

3 From the Selection drop-down list, specify what parts of the model that 
you want to search.
To search the entire model, select All.
To search specific parts of a model, select Selected and then select the parts 
on the model.
To search the model parts that are not selected, select Not selected.

4 From the Type drop-down list, select the type of entity that you want to 
search.
Note  For 3D Models that have PMI information, the PMI search features 
are enabled.

5 Select the checkbox beside Show PMI parent entity in results if you 
want only the parent entity of the selected PMI entity or entities to appear in 
the Results list.
Clear the checkmark if you want all PMI entities to appear in the Results 
list. 
Note  Option is enabled if Type is set to PMI or All and files has PMI 
entities.

6 From the PMI filter drop-down list, select the type of entities that you want 
to search.
To search all entities, select All.
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To search entities with PMI, select With PMI.
To search entities without PMI, select Without PMI.

7 From the PMI type drop-down list, select the type of entity that you want to 
search.
Note  PMI type is disabled if PMI Filter is set to All.
See   Saving Search Results

8 Click Close to close the Entity Search dialog.

Performing an Attribute-based Search
From the 3D Search dialog, you can search for entities by their attributes, such 
as color, density, shading, etc.
1 Select Analysis > Entity Search from the AutoVue menu.

The Entity Search dialog appears.

Note  You can also click the 3D Entity Search icon  on the AutoVue 
toolbar.

2 Click the 3D Search tab.
3 Select the search criteria that you want to use for your search.

See   Performing a Search
4 Click Add. The Attribute Filter dialog appears.

5 From the Name drop-down list, select the attribute that you want to search.
The Value group box appears corresponding to the selected attribute.

6 Select the checkbox beside the Any Value if you want to search by any 
value. The Value options are disabled.
Cimmetry Systems Corp.



AutoVue 143
7 Clear the checkbox if you want to search by a specific value, then from the 
Value drop-down list(s), select the values that you want to search.

8 Click OK.
Note  To add more than one Attribute Filter, repeat steps 4 to 5.

9 To edit an Attribute Filter, select the filter and click Edit.
The Attribute Filter dialog box appears allowing you to edit the filter.

10 To disable an Attribute Filter, clear the checkbox beside the filter(s) that 
you want to disable.
To enable an Attribute Filter, select the checkbox beside the filter(s).

11 To remove an Attribute Filter, select the filter and click Remove in the 
Entity Search dialog.
The Attribute Filter disappears from the list.

12 In the Entity Browser, click Search.
A list of entities matching the search criteria appear in the Results list 
displaying the Type and Name.
See   Saving Search Results

13 Click Close to close the Entity Search dialog.

Performing an Advanced 3D Search
From the 3D Search dialog, you can search for entities using volume or 
location filters. Volume specifies the size of the entity: you can specify the 
minimum and maximum dimensions an entity must be between. Location 
specifies an axes aligned boundary box: you can specify the dimensions for an 
axes aligned boundary box that an entity must be inside.
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1 From the Entity Search dialog, click the Advanced 3D Search tab.

2 To search for entities by Volume, select the checkbox beside Enabled.
Note  If you want to search for entities that match all three dimensions, 
select the checkbox beside Completely contained. If the checkmark is 
cleared, then an entity only has to match one dimension in order to appear in 
the Results list.

3 Enter the Minimum and Maximum Dimensions.
4 From the Units drop-down list, select the unit you want to set for the 

Volume dimensions.
5 To search for entities by Location, select the checkbox beside Enabled.

Note  If you want to search for entities that match all three dimensions, 
select the checkbox beside Fits completely. If the checkmark is cleared, 
then an entity only has to match one dimension to appear in the Results list. 

6 From the Units drop-down list, select the unit you want to set for the 
Location dimensions.

7 Enter the dimensions for Point 1 and Point 2.
8 Click the 3D Search tab.
9 Click Search.

A list of entities matching the search criteria appears in the Results list.
See   Saving Search Results
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10 Click Close to close the 3D Search dialog.

Saving Search Results
1 Perform an 3D entity search.

See   Performing a Search
 Performing an Attribute-based Search
 Performing an Advanced Search

2 Click Search.
A list of entities matching the search criteria appear in the Results list 
displaying the Type and Name.

3 To save the results, click Export.
The Save As dialog appears.

4 Specify the path where you want to store the file and enter the File name, 
then click Save. 
AutoVue saves the results in a csv (Comma Separated Values) file.

Measuring in 3D Files
AutoVue provides the ability to perform measurements in 3D files. When 
measuring, AutoVue provides the option to “snap” to different entity types on the 
model.
You can access the measure options from the Analysis > Measure menu. The 
options are:

Name Description

Angle Measure the precise angle between any three vertices or   any 
two edges, planes, faces or any combination of these entity 
types.

From toolbar click  icon.

Arc Measure the precise radius, length and angle of any arc and 
calculate the center point.

From toolbar click  icon.
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3D Snapping Modes
The Snapping Modes available allow you to select or snap to different entity 
types on a model. For example, if you select Vertex, all vertices are highlighted 
and when you move the cursor over a vertex, a snap box appears.
The Snapping Modes allow you to snap to vertices, edges, faces, planes and 
arcs.

Distance Measure the precise distance between any two vertices, 
edges, mid-edges, arc centers, faces or any combination of 
these entity types.

From toolbar click  icon.

Minimum Distance Measure minimum distance between any two vertices, edges, 
mid-edges, arc centers, faces or any combination of these 
entity types.

From toolbar click  icon.

Edge Length Measure the precise length of a edge.

From toolbar click  icon.

Face Surface Measure the precise surface area.

From toolbar click  icon.

Vertex Coordinates Provide the coordinates of each vertex.

From toolbar click  icon.

Icon Snap to Description

Edge Edges are highlighted on the model.
When moving the cursor over an edge, a snap circle appears. 

Face Faces are highlighted when you move the cursor over a face 
and a snap triangle appears.

Name Description
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Measuring Distance
Use the Distance option to measure the precise distance between two vertices, 
edges, mid-edges, arc centers, faces or any combination of these entity types.
Note  When measuring the distance between faces, if the faces are parallel, 
AutoVue compares the shortest distance between the faces.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure.

4 Click the From arrow  to select the entity type that you want to measure 
from.

5 Select the Snapping Modes that you want to use for measuring.
See   3D Snapping Modes
All entities of the selected entity type are highlighted on the model.

6 On the model, select the entity you want to measure from.
Note  If you want to take more than one measurement from the same 
starting point, click Fix Position.

7 Click the To arrow  to select the entity type that you want to measure to.
8 Select the Snapping Modes that you want to select as the end point for the 

measurement.
All entities of the selected entity type are highlighted on the model.

9 On the model, select the entity you want to measure to.
The points are joined by a line. The measured distance, Delta X, Delta Y and 
Delta Z appear in the Measurement dialog.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.

Vertex Vertices are highlighted on the model.
When moving the cursor over a vertex, a snap box appears.

Icon Snap to Description
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Calibrating Distance
1 Measure a distance.

See    Measuring Distance
2 In the Measurement dialog, click Calibrate.
3 The Distance Calibration dialog appears displaying the measured 

distance.
4 In the Measured Dist drop-down list, select the unit to which you want to 

calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate the distance to 

a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

6 Click OK. 
The calibration result appears in the Measurement dialog.

7 Click Close to close the Measurement dialog.

Measuring Minimum Distance
With the Minimum Distance option you can measure the minimum distance 
between model parts, as well as any two points from the selection sets: vertices, 
edges, mid-edges, arc centers, faces or any combination of entity types.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Minimum Distance icon  on the AutoVue 
toolbar.

2 Click the Min. Distance tab.

3 Click  Set 1 point.
4 Click Entity if you want to measure the distance between model parts. 

Snapping Modes are disabled.
Click Geometry if you want to measure the distance between entity types. 
Snapping Modes are enabled.

5 If you selected Entity, select a part or parts on the model.
The model part(s) appears in the list under Set 1 and are highlighted on the 
model and in the Model Tree.
If you selected Geometry, select the Snapping Modes that you want to 
use for measuring.
See   3D Snapping Modes
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All entities of the selected entity type are highlighted on the model.
Select the entity or entities on the model.
The selected entities appears in the list under Set 1 and are highlighted on 
the model.
Note  To reset a Set, click Clear. To clear items from a Set, select the 
items and press the Delete key. To deselect a part or entity type on the 
model, press the Ctrl key and left-click the part or entity type.

6 Click  Set 2 point.
7 Repeat step 5.

The model part appears in the list under Set 2.
8 From the Measured Min Distance drop-down list, select the unit in which 

you want to measure the distance.
9 Click Compute.

The minimum distance from the first set of entities to the second set is 
highlighted by a line. The measured minimum distance, X, Y and Z 
coordinates for Position1 and X, Y and Z coordinates for Position2 
appear in the Measurement dialog.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.

Measuring an Angle
Use the Angle option to measure the precise angle between any three vertices or 
any two edges, planes, faces or any combination of these entity types.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the AutoVue toolbar.
2 Click the Angle tab.
3 Select the Snapping Modes that you want to use for measuring.

Entities of the selected types are highlighted on the model.
See   3D Snapping Modes

4 To measure the angle between an entity type and a plane, select the checkbox 
beside Plane, then from the drop-down list select the plane.

5 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

6 Click two points on the model to define the angle.
If you selected a Plane, click the vertex, edge or face whose angle you want 
to measure between the plane.
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Angle arms appears indicating the angle.The measurement appears in the 
Measurement dialog.
Note  Click Reset to take another measurement.

7 Click Close to close the Measurement dialog.

Measuring an Arc
Use the Arc option to measure the precise radius, length and angles of any arc on 
the model. You can also calculates the center point location.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the AutoVue toolbar.
2 Click the Arc tab.
3 Select Arc Entity if you want to measure a predefined arc.

All arc and circles are highlighted on the model. Snapping Modes are 
disabled.

4 Select From 3 Points if you want to measure the arc between three points. 
Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
See   3D Snapping Modes

5 From the Arc Info Dist. Units drop-down list, select the unit in which you 
want to measure the arc distance.

6 From the Angles Units drop-down list, select the unit in which you want to 
measure the angle.

7 If you selected From 3 Points, click three points to define the arc.
The points are joined by an arc. The measurements for center point 
coordinates, radius, diameter, arc length, start and end of angle and sweep 
appear in the Measurement dialog.
If you selected Arc Entity, click the edge of the arc that you want to 
measure.
The arc is highlighted. The measurements for center point coordinates, 
radius, ratio, arc length, angles start, end and sweep appear in the 
Measurement dialog.
Note  Click Reset to take another measurement.

8 Click Close to close the Measurement dialog.
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Calibrating an Arc
1 Measure an arc.

See    Measuring an Arc
2 In the Measurement dialog, click Calibrate.
3 The Radius Calibration dialog appears displaying the measured distance.
4 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate to a value.

Click Set Factor and enter a value if you want to calibrate by a factor.
6 Click OK. 

The calibration results appear in the Measurement dialog.
7 Click Close to close the Measurement dialog.

Measuring Vertex Coordinates
The Vertex Coordinates option provides the coordinates of vertices on the 
model.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Vertex Coordinates icon  on the AutoVue 
toolbar.

2 Click the Vertex tab.
All vertices on the model are highlighted.

3 From the Coordinates Units drop-down list, select the unit in which you 
want to measure.

4 Move the cursor over the highlighted vertex that you want to measure.
The X, Y and Z coordinates appear in a tooltip.

5 Select the vertex.
The X, Y an Z coordinates appear in the Measurement dialog.
Note  Click Reset to take another measurement.

6 Click Close the close the Measurement dialog.

Measuring the Length of an Edge
Use the Edge Length option to measure the length of any edge on the model.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.
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Note  You can also click the Edge Length icon  on the AutoVue toolbar.
2 Click the Edge Length tab.

All edges on the model are highlighted.
3 From the Units drop-down list, select the unit in which you want to measure 

the edge length.
Note  If you want to cumulate the measurement of more than one edge, 
click Cumulative.

4 Click the edge that you want to measure.
The edge length measurement appears in the Measurement dialog.
Note  Click Reset to take another measurement.

5 Click Close to close the Measurement dialog.

Measuring Face Surface
Use the Surface option to measure the surface area of a entity face or an entire 
entity on the model.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Face Surface icon  on the AutoVue 
toolbar.

2 Click the Surface tab.
Select Face Surface if you want to measure the surface area of a face on an 
entity.
Select Entity Surface if you want to measure the surface area of an entire 
entity.

3 From the Measure Surface Units drop-down list, select the unit in which 
you want to measure the surface.
Note  If you want to cumulate the measurement of more than one surface, 
click Cumulative.

4 If you selected Face Surface, move the cursor on the model to highlight a 
face surface, then click the face surface that you want to measure.
The face surface is highlighted. The measured surface appears in the 
Measurement dialog.

5 If you selected Entity Surface, click the entity that you want to measure.
The entity, as well as all the faces belonging to the body are highlighted. The 
measured surface of the body appears in the Measurement dialog.

6 To measure the face surface of the entity, click on the highlighted body.
A pop-up list appears displaying the entity and its parents.
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Select the entity or a parent from the pop-up list.
The selected entity is highlighted and the measured surface appears in the 
Measurement dialog.
Note  To measure the face surface of a parent, select the parent from the 
pop-up list.
Note  Click Reset to take another measurement.

7 Click Close to close the Measurement dialog.

Configuring AutoVue for 3D Files
In AutoVue, there are configuration options that you can set to customize the 
work environment when working with 3D files. You can access the configuration 
options from the Options > Configuration menu, under the 3D tab in the 
Configuration dialog. 

Display
With the Display options, you can modify the manner in which the model is 
rendered. Changing these options affects the render time needed for the model, as 
well as the level of detailed displayed. The Display options are:

Option Description

Smooth Shading Set by default. Turning this option off, renders curved surfaces of 
shaded models as a series of flat surfaces. The level of detail is 
thus reduced but render speed is increased.
Note  Only affects shaded models.

Back-Face 
Removal

If selected, instructs AutoVue not to render the back faces of the 
model being displayed. This increases the render speed but the 
model appears less realistic while in motion. 
Note  Only affects shaded models.

Precise Hidden Instruct AutoVue to precisely calculate and render all hidden lines 
in a model.
Note  Selecting this option decreases render speed.

Show Global 
Axes

Set by default. Turning this option off, removes the colored axes 
displayed  in the lower left-hand corner of the View window.
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Measurement
With the Measurement options, you can define the defaults units as well as the 
number of decimal places. The options are:

Highlight 
Selection

Defines how AutoVue will indicate that an object is selected.
• Bounding Box - Selection is enclosed in a wireframe box.
• Entity Color - Selection is indicated by changing color.

Dynamic 
Rendering

Rendering while the model is in motion. 
• Current Render Mode - Model is rendered in the same 

mode whether moving or static.
• Flat Shading - Smooth shading is not performed on 

curved surfaces while the model is in motion.
• Wire Polygons - Render the model in wire polygon mode 

while in motion.
• Wire Frame - Model is displayed as wire framed during 

rotation or spinning.
• Vertex cloud - Model is displayed as a skeleton of vertices 

when in motion.
• Fast Frame - Model spins or rotates at a fast rate.
• Bounding Box - Model parts are enclosed by bounding 

boxes when the model is in motion.

Default Mesh 
Resolution

Alters the number of polygons drawn when displaying a model. 
The settings are Low, Medium and High.
A low setting means fewer polygons are drawn giving lower detail 
and higher render speed.
Note  Option only affects shaded models and wire polygon 
mode.

PMI Text 
Rendering Style

Defines the style for PMI text.
• Native Setting - PMI text is displayed with the default set-

ting
• 3D - PMI text  is displayed in 3 dimension
• Flat-to-screen - PMI text  is displayed in 2 dimension

Option Description
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Model Tree
With the Model Tree option, you can define what level to expand the Model 
Tree to by entering a Tree level.

Manipulator
With the Manipulator option, you can aligned a 3D Model to the current User-
defined Coordinate System by selecting Align with current UCS.

PMI Filtering
With the PMI Filtering option, you can configure which types of product and 
manufacturing information to display.
For more information on PMI Filtering, see PMI Filtering.

Color Options
With the Color Options, you can configure the color to allow easier viewing of 
3D file details. The options are:

Option Description

Decimal Digits Changes the number of decimal units calculated for each 
measurement, select a number from 1 to 18.

Defaults Units Changes the default units for measuring.

Option Description

Background Set the background color for 3D files.

Entity Default Set the default color to use when the model color is not readable.

Selection Set the color when selecting a model or model parts.

Section Edges Set the color for the section edges when defining Section Cut 
Options.
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Configuring AutoVue
1 Select Options > Configuration from the Autovue main menu.
2 The Configuration dialog appears.
3 Select the 3D tab.
4 Configure the options that you want.
5 To configure the color, click Color Options. 

The Color Options dialog appears. Select the Color option that you want 
to configure, select the color, then click OK.
See  Color Options

6 To configure which types of product and manufacturing information you 
want to display, click PMI Filtering. 
The PMI Filtering dialog appears.
See  PMI Filtering

7 Click OK in the Configuration dialog.
The configuration changes are applied.
See Also   Configuring Paths

Configuring AutoVue as a Quick Viewer for Windows

Section Fill 
Hatch

Set the hatch pattern for the fill color when defining Cut Options.

Section Fill Set the fill color when defining Section Cut Options.

Measurement Set the color for measurements.

Vertex Highlight Set the color for vertices when highlighted during measurement 
and markup.

Edge Highlight Set the color for edges when highlighted during measurement and 
markup.

Face Highlight Set the color for faces when highlighted during measurement and 
markup.

Min. Dist. Set1 Set the color of the first set-point when measuring minimum 
distance.

Min. Dist. Set2 Set the color of the second set-point when measuring minimum 
distance.

Option Description
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Markups
AutoVue has the ability to view over 450 different file formats and to create 
markups for all its readable file formats without the document's authoring 
application.
Marking up refers to drawing and writing on an electronic document. AutoVue 
provides the ability to markup different formats without modifying the original 
file. When you create a markup for a file, the markup is created on top of the 
original file. Markups are saved in separate files.

If a file has existing markup files, a red light bulb  appears on the status bar at 
the bottom of the AutoVue workspace. Clicking this icon opens the Open 
Markup dialog allowing you to select markup files to open or create a new 
markup file. When opening a markup file, AutoVue lays the markup over the 
original file.
In Markup mode you can:
• create entities such as arcs, boxes, circles, clouds, lines and polygons
• add a symbol, add information to an entity by adding text or a note
• create, name and color layers to organize your work
• create a new markup file that combines copies of selected layers of different 

markup files
• create measurement markup entities that can be moved or resized
• navigate markups through a hierarchy tree, view markup properties and sort 

the tree according to each property
• view markup layers individually or in combination
Note  Markup capability is only available in the Professional versions of the 
AutoVue product: AutoVue Professional and AutoVue SolidModel Professional.

Markup Navigation Tree
When opening a file in Markup mode, a Markup Navigation Tree appears to 
the left of the document. If the Markup Navigation Tree does not appear, 
select View > Show Model Tree.
The Markup Navigation Tree displays a hierarchy tree of markups or 
comments created by a user. The user can navigate through the markups. A set of 
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properties are generated for each markup and the tree can be sorted according to 
each property. These properties are:

When a markup entity is created, it appears in the Markup Navigation Tree 
and the information is recorded and saved in the markup file.
Note  To see more markup properties or to expand the tree, click and drag the 
Markup Navigation Tree window.

Working with Markup Files
Markup files are divided into uniquely named layers. Create, name and color 
layers to organize your work. For example, different colors can indicate time 
priorities and each layer can contain Markups related to a common purpose.

Property Description

Entity Type Type of markup entity created.

Page Page number of the original document on which the markup entity 
is created.

Layer Markup layer on which the markup entity is created.

Author The name of the user who created the markup.

Modified The date and time the markup was modified.
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Saved States
When you create Markup entities in a file, you can save the view state. For 
example, the zoom level at which you are working. If you save the Markup while 
you are working at your preferred zoom level, the next time you open the 
Markup, it is displayed at the same zoom level. Some examples of view states 
include zoom level (extents), rotation and flip settings, transformation, section 
plane and visibility. When creating Markups for 3D files containing imported 
models, the imported design becomes part of the view state. For more 
information on 3D view states, see Creating a User-defined View.
State information is also saved with each markup entity. For instance, if you were 
at a certain zoom level when you created a markup entity, AutoVue saves the 
information with the markup entity. To “Go To” the state you were at when you 
created or modified the markup entity, select the markup entity and select Go To.

Creating a Markup File
1 View a file that you want to markup.
2 Select File > Markup from the AutoVue main menu. 

Note  You can also click the Markup icon  from the AutoVue main 
toolbar.

3 AutoVue enters Markup mode.
See Also  Creating a Markup Layer

Entering Markup Information
In AutoVue, when creating a Markup you can provide user information that you 
can save with the Markup.
1 Select Markup > Information from the Markup menu.

The Markup Information dialog appears.
2 Enter a User name.
3 Enter a Department.
4 Enter a Company name.
5 Enter the Location of the Company.
6 Enter a Telephone number.
7 Click OK.

The Markup Information is saved.
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Saving a New Markup File
1 Select File > Save As from the AutoVue main menu.

The Save Markup File As dialog appears.
The Markup Information that you entered when creating the Markup is 
display in the dialog.

2 Enter a Markup ID consisting of any combination of characters or numbers.
3 Click OK.

The Markup file is saved and remains displayed in the workspace.

Opening Markup Files
1 View the file that has existing markups.
2 Select File > Markup from AutoVue main menu.

The Open markup dialog appears.

Note  You can also click the Markup icon  from the Markup toolbar or 

click the red light bulb  at the bottom left corner of the status bar.
3 From the Markup list, select the checkbox beside the markup(s) that you 

want to open.
Note  If you selected more than one Markup, the Active Markup option 
appears.

4 Click OK. 
The selected markup(s) appear in the workspace on top of the original file.
Note  When you select more than one markup file, the markups are 
displayed simultaneously.
See Also   Setting the Active Markup File

Saving an Existing Markup File
1 Modify the markup file.
2 Select File > Save from the AutoVue main menu.

Note  If you have multiple markups open that you have modified and want 
to save them all, select File > Save All.
Note  To save an existing Markup as a new Markup, select File > Save 
As.
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Importing a Markup File
1 Select File > Open from Markup mode.
2 The Open markup dialog appears.

Note  You can also click the Markup icon  from the Markup toolbar.
3 Click Import.

The Select markup file to import dialog appears.
4 Navigate to the markup file that you want to import and select it.
5 Click Open.

The imported Markup file appears in the workspace on top of the original 
file.

Exporting a Markup File
1 Select File > Save As from the Markup menu.

Note  For a new Markup file, select File > Save.
2 Click Export.

The Select markup file export to dialog appears.
3 Navigate and select the directory you want to export the markup file to.
4 Enter File name.
5 Click Save.

The markup file is exported to the selected directory.
Note  The default format saved is Markup Files (*.*), but you can select 
another one. In the Save as type drop-down list, there are six formats to 
choose from: Markup Files (*.*), DXF Output (*.dfx), AutoCAD DWG R12 
(.dwg), AutoCAD DWG R13 (.dwg), AutoCAD DWG 14 (.dwg) and 
Microstation DGN Output (*.dgn).

Setting the Active Markup File
A file can have several markup files. When you open several markup files 
simultaneously, you can set one of the markups as the active markup. Any 
changes you make is applied to the current active markup.
1 Select File > Open from the Markup menu.

The Open markup dialog appears.
2 Click the checkbox beside the markups you want to open.

The Active Markup drop-down list appears when you select more than one 
markup.
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3 From the Active Markup drop-down list, select the markup you want to 
make active.

4 Click OK.
The selected markup appears in the AutoVue workspace.

Changing the Active Markup File
When you have multiple markup files open, you can change the active markup.
1 Select File > Set Active from the Markup menu.

The Set Active Markup dialog appears.
2 From the Select Active Markup drop-down list, select the markup you 

want to make active.
3 Click OK.

Note  You can set the active markup by selecting a markup from the drop-
down list on the Markup too1bar.

Markup Layers
Markup files can be divided into layers with each layer having its own unique 
name. You can create, name and color layers to organize your work. For example, 
different colors can indicate time priorities and each layer can contain markups 
relating to a common purpose. 
When working with markup layers, you can view layers individually or in 
combination, add, rename or delete layers. You can also specify a different color 
for each layer; default layer color is red.
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Creating a Markup Layer
Note  Ensure that no markup entity is selected when creating a markup layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  on the Markup 
toolbar.

2 In the Markup Layers dialog, click New.
The New Markup Layer dialog appears.

3 Enter the name that you want for the markup layer.
4 Click OK.

The new markup layer is added to the list in the Markup Layers dialog.
5 To change the color of the new layer, click Color in the Markup Layer 

dialog. 
The Layer Color dialog appears. Select a Color, then click OK.

6 Click OK to close the Markup Layers dialog.

Setting the Active Markup Layer
A markup can have several layers and you can set a layer as the active markup 
layer. When a markup layer is active, all modifications you make are applied to 
that markup layer.
Note  Ensure that no markup entity is selected when setting the active markup 
layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  on the Markup 
toolbar.

2 From the Markup Layers list, select the checkbox beside the layer you 
want to make active.

3 Click OK.
The selected Markup layer appears in the workspace.
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Changing the Active Markup Layer
When you have multiple markup layers, you can change the active layer to 
another layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog box appears.
2 From the Currently Active Layer drop-down list, select the layer you 

want to make active.
3 Click OK.

The selected layer appears in the workspace.
You can also change the active layer by selecting the layer from the drop-down 
list on the Markup too1bar.

Changing the Color of a Markup Layer
Note  Ensure that no markup entity is selected when changing the color of a 
markup layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 Select the markup layer that you want to change the color.
3 Click Color.

The Layer Color dialog appears.
4 Select a Color.
5 Click OK.

Note  Only the entities that were created with the by-layer  color 
defined in the Markup Layers dialog will change color. Any entities that 
were created using the color options from the Markup toolbar, will override 
the by-layer color and will not change color.

6 Click OK to close the Markup Layers dialog.
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Renaming a Markup Layer
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 Under Markup Layers, select the checkbox beside the markup layer you 
want to rename.

3 Click Rename.
The New Markup Layer dialog appears.

4 Enter the new layer name.
5 Click OK. 

The markup layer is assigned the new name.
6 Click OK to close the Markup Layers dialog.

Toggling Markup Layers
From the Markup Layers dialog, you can turn a layer’s visibility on and off, 
even if there is only one layer.Turning a layer’s visibility off, hides all markups 
belonging to that layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 Under Markup Layers, select the layer(s) you want visible.
3 Click Toggle.

A checkmark appears beside the selected layers.
4 To hide a layer, select the layer(s) with a checkmark, then click Toggle 

again.
Note  You can also view a layer by selecting the checkbox beside it. To hide 
a layer, clear the checkmark. To view all the Markup layers, click All On. To 
hide all Markup layers click All Off.

5 Click OK.
The markup entities belonging to the selected layer(s) appear in the 
workspace on top of the original file.

Deleting a Markup Layer
1 Select Markup > Markup Layers from the Markup menu.
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The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 From the Markup Layers list, select the checkbox beside the markup layer 
you want to delete.
Note  You can select more than one layer to delete at the same time.

3 Click Delete.
4 Click OK.

The layer is deleted along with all entities belonging to the layer.

Moving a Markup Entity to Another Layer
1 Select the entity or entities that you want to move.
2 Select Markup > Markup Layers from the Markup menu.

The Move to Layer dialog appears.

Note  You can also click the Layer icon  on the Markup toolbar.
3 Select the Layer you want to move the entity or entities to.
4 Click OK. 

The selected entity or entities are moved to the selected layer.

Note  Only the entities that were created with the  By Layer color 
defined in the Markup Layers dialog will change color. Any entities that 
were created using the color options from the Markup toolbar, will override 
the by-layer color and will not change color.

Consolidating Markup Files
The Consolidate option allows you to create a new markup file that combines 
copies of selected layers of different markup files. During the review cycle, 
consolidation simplifies document revisions by providing the author with one 
combined markup file instead of several markup files.
Note  The Consolidate option is only active when more than one markup file 
is opened.
1 Open the markup files that you want to consolidate.
2 Select File > Consolidate from the Markup menu.

The Consolidate Markups dialog appears.
3 Select the markup layers that you want to consolidate into one file.
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4 Enter a Markup ID for the new markup file.
5 Click OK.

The consolidated markup file is saved.

Modifying Markup Entities
With AutoVue, you can assign an entity its own color, the same color as the 
current active layer or create a custom color. You also have the option of 
grouping Markup entities. When you group Markup entities, you can manage the 
group as you would a single entity. 
In Markup mode, there are several options for modifying an entity. You can apply 
these options to selected entities while you specify the change or new entities that 
you add. The modify options can be accessed from the Markup menu in Markup 
mode. The options are:

Option Description

Delete Delete a selected markup entity or entities.

Delete All Delete all markup entities.

Delete Dimensions Delete all markup measure entities.

Hide Dimensions Hide all markup measure entities.

Entity Color Change the line color, fill color and fill type for a selected 
markup entity or entities.

From toolbar click  icon to change the Fill Color.
See   Changing the Fill Color of An Entity

From toolbar click  icon to change the Line Color.
See   Changing the Line Color of An Entity

Fill Type Change the transparency for selected markup entity or enti-
ties.

From toolbar click  icon.
See  Changing the Fill Type of An Entity

Hide Markups Hide all markup entities.
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“Go To” a Markup Entity
Go To restores the view state when a created entity is saved. Opening an existing 
markup for a file also restores the last saved view state.
1 From the Markup Navigation Tree, select the markup entity that you 

want to view.
2 Right-click and select Go To from the drop-down menu.

Autovue displays the markup page containing the entity.
Note  If you selected a Markup entity that is on another page of the Markup, 
the page containing that entity will be displayed.

Selecting Markup Entities
1 Click the Select icon  from the Markup toolbar, then from the workspace 

click the entity’s outer edge.
Note  You can also select the entity from the Markup Navigation Tree.
Note  To select multiple entities, press the Shift or Ctrl key while selecting.

Moving a Markup Entity
1 In the Markup Navigation Tree or from the workspace, select the entity 

or entities that you want to move.
See   Selecting Markup Entities

2 Move the cursor over the selected entity or entities until the cursor changes 
to a hand.

3 Click and drag the selected entity or entities to anywhere in the workspace. 

Line Style Change the line style for a selected markup entity or entities.

From toolbar click  icon.
See   Changing the Line Style

Line Thickness Change the line thickness for a selected markup entity or enti-
ties.

From toolbar click  icon.
See   Changing the Line Thickness

Option Description
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Editing a Markup Entity
The entities that you can edit are notes, text, dimensions, leaders and hyperlinks.
1 In the Markup Navigation Tree or from the workspace, double-click the 

entity that you want to edit.
Autovue zooms in on the entity and the appropriate dialog appears allowing 
you to make changes to the entity.
Note  You can also edit an entity by right-clicking it in the Markup 
Navigation Tree and selecting Edit from the pop-up menu.

Grouping Markup Entities
When you group markup entities, you can move, delete, copy and paste, hide, 
resize, or perform any modification on the group of entities that you would on a 
single markup entity.
1 In the Markup Navigation Tree or from the workspace, select the entities 

that you want to group.
See   Selecting Markup Entities

2 Select Markup > Group from the Markup menu.
The group of entities appear on the Markup Navigation Tree as a Group.

3 Perform any modifications.
The modifications are applied to all the entities in the group.

Ungrouping Markup Entities
1 In the Markup Navigation Tree or the workspace, select the Group that 

you want to ungroup.
2 Select Markup > Ungroup from the Markup menu.

The group of entities appear on the markup as individual entities.

Hiding Markup Entities
1 Select Markup > Hide Markups from the Markup menu.

The markups are hidden on the markup file.
Note  To “unhide” markups, select Markup > Hide Markups from the 
Markup menu.
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Changing Line Thickness of an Entity
Note  A checkmark beside the thickness option indicates the current line 
thickness.
1 Select the entity or entities for which you want to change the line thickness.

See   Selecting Markup Entities
2 From the Markup menu, select Markup > Line Thickness and the line 

thickness that you want.
The line thickness changes for the selected entity or entities.

Note  You can also click the Line Thickness icon  on the Markup 
toolbar.

3 To define a custom line thickness, select Modify > Custom Thickness 
from the Markup menu.
The Custom Thickness dialog appears.

4 Enter an integer value in pixels.
5 Click OK to close the Custom Thickness dialog.

Note  Any new entities that you create will have the new line thickness.

Changing Line Style of a Entity
Note  A checkmark beside the style option indicates the current line style.
1 Select the entity or entities for which you want to change the line style.

See   Selecting Markup Entities
2 From the Markup menu, select Markup > Line Style and the line style that 

you want.
The line style changes for the selected entity or entities.

Note  You can also click the Line Style icon  on the Markup toolbar.
Note  Any new entities that you create will have the new line style.

Changing Line Color of an Entity
1 Select the entity or entities for which you want to change the line color.

See   Selecting Markup Entities
2 Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.

Note  You can also click the Line Color icon  on the Markup toolbar.
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3 From the Line Color drop-down list, select the color that you want for the 
entity.

Note  Selecting  By Layer changes the entity color to the color of the 
layer.

4 To define a custom line color, select  CUSTOM from the Line Color 
drop-down list.

5 From the Color dialog that appears, select a color and click OK.
6 Click OK to close the Entity Color dialog.

The line color changes for the selected entity or entities.
Note  Any new entities that you create will have the new line color.

Changing Fill Color of an Entity
1 Select the entity or entities for which you want to change the fill color.

See   Selecting Markup Entities
2 Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.

Note  You can also click the Fill Color icon  on the Markup toolbar.
3 From the Fill Color drop-down list, select the color that you want for the 

entity.

Note  Selecting  By Layer changes the entity color to the color of the 
layer.

4 To define you own color, select  CUSTOM from the Fill Color drop-
down list.

5 From the Color dialog that appears, select a color and click OK.
The fill color changes for the selected entity or entities.

6 Click OK to close the Entity Color dialog.
Note  Any new entities that you create will have the new fill color.

Changing Fill Type of an Entity
1 Select the entity or entities for which you want to change the fill type.

See   Selecting Markup Entities
2 Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.

Note  You can also click the Fill Type icon  on the Markup toolbar.
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3 From the Fill Type drop-down list, select the fill type that you want for the 
entity.
Select Solid Fill, if you want the fill color to be solid.
Select Transparent Fill, if you want the fill color to be transparent.
Select No Fill, if you do not want any fill color.

4 Click OK. 
The fill type changes for the selected entity or entities.
Note  Any new entities that you create will have the new fill type.

Assigning an Entity the Same Color as the 
Layer
1 Select the entity or entities for which you want to assign the color of the 

layer that they belong to.
See   Selecting Markup Entities

2 Select Markup > Entity Color from the Markup menu.
The Entity Color dialog appears.

3 To assign the line color, select the  BYLAYER from the Line Color 
drop-down list.

Note  You can also click the Line Color icon  from the Markup toolbar.

4 To assign the fill color, select the  BYLAYER from the Fill Color drop-
down list.

Note  You can also click the Fill Color icon  from the Markup toolbar.
5 Click OK.

The selected entity or entities change to the color of the layer that the entity 
belongs to.

Deleting Markup Entities
1 Select the entity or entities that you want to delete.

See   Selecting Markup Entities
2 Select Markup > Delete from the Markup menu.

The selected entity or entities are deleted from the current active file.
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Note  To delete all entities, select Markup > Delete All from the Markup 
menu. Delete All will delete all existing entities from the active markup, 
whether they are visible or not. 

Modifying Measurement Markup Entities
In AutoVue, you can modify the font of a measurement.
1 Create the markup measure entity that you want.

See   Creating 2D non-vector Markup Measure Entities
 Creating 2D Vector Markup Measure Entities
 Creating EDA Markup Measure Entities
 Creating 3D Markup Measure Entities

2 Double-click the measurement for which you want to modify the font.
The appropriate Measure dialog appears.

3 Click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the font Style(s), then click OK. 

4 Click OK to close the appropriate Measure dialog.
The measurement font is modified.

Changing Measurement Units and 
Symbols
In AutoVue, you can change the unit of measure and add a symbol to a 
measurement and have it appear on the drawing.
1 Create the markup measure entity that you want.

See   Creating 2D non-vector Markup Measure Entities
 Creating 2D Vector Markup Measure Entities
 Creating EDA Markup Measure Entities
 Creating 3D Markup Measure Entities

2 Double-click the measurement that you want to change the unit of measure 
or add a symbol to.
The appropriate Measure dialog appears.

3 Clear the checkmark beside Display Unit if you want to hide the unit on the 
drawing. Unit appears by default.

4 From the Units drop-down list, select the unit that you want to change the 
measurement to.
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5 From the Symbol drop-down list, select the symbol that you want to add to 
the measurement.

6 Click OK.
The unit of measure changes and the selected symbol is added to the 
measurement and appears in the workspace.

Hiding Markup Measure Entities
Select Markup > Hide Dimensions from the Markup menu.
The markup measurements are hidden on the markup file.
To “unhide” markups, select Markup > Hide Markups from the Markup menu.

Deleting Markup Measure Entities
Select Markup > Delete Dimensions from the Markup menu.
The markup measurements are deleted on the markup file.

Marking Up 2D Files
AutoVue provides a variety of user-friendly markup options that you can use 
when marking up 2D files. You can create entities such as arcs, boxes, circles, 
clouds, lines and polygons. You can draw a leader with multi-line segments and 
add text to it. You can also add a symbol, add text to an entity or add information 
by adding a note. 

2D Markup Entities
In AutoVue, you can drawing many different types of entities. You can access the 
entities from the Entities menu in Markup mode. The entities are:

Option Description

Note  Right click to complete an entity.

Arc Click and drag the mouse to draw an arc.

From the toolbar click  icon.
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Box Click and drag to draw a rectangle.

From the toolbar click  icon.
Note  To draw a square instead of a rectangle, press and 
hold the Shift key while you click and drag.

Closed Polyline Click and drag to draw a closed Polyline.

From the toolbar click  icon.

Cloud Click and drag to draw a cloud.

From the toolbar click  icon.

Circle Click and drag to draw a ellipse.

From the toolbar click  icon.
Note  To draw a circle instead of an ellipse, press and hold 
the Shift key while you click and drag.

Filled Box Click and drag to draw a filled box. The box is filled with a 
solid color.

From the toolbar click  icon.
Note  To draw a square Filled Box instead of a rectangular 
Filled Box, press and hold the Shift key while you click and 
drag.

Freestyle Click, release mouse button, then drag to draw an entity.

From the toolbar click  icon.
Note  You can create a contiguous or non-contiguous 
freestyle entity.
See   Creating a Non-contiguous Freestyle Entity
          Creating a Contiguous Freestyle Entity

Highlight Click and drag to highlight a boxed area.

From the toolbar click  icon.
Note  The highlighted box will be filled with a transparent 
color.

Option Description
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Leader Click and drag to draw a leader. 

From the toolbar click  icon.
Note  To force a line segment in a Leader entity to be 
aligned to the closer axis, horizontal or vertical axis, hold the 
Shift key while you click and drag for that line segment.
See    Adding a Leader
          Forcing a Line Segment

Line Click and drag to draw a line.

From the toolbar click  icon.
Note  To draw a line and force it to be aligned to the closer 
axis, horizontal or vertical, press and hold the Shift key 
while you click and drag.
See    Forcing a Line Segment

Note Add a note to the Markup.

From the toolbar click  icon.
See    Adding a Note

OLE Insert a new or existing OLE entity to the Markup.
See    Creating an OLE Markup Entity

Polyline Click and drag to draw a polyline.

From the toolbar click  icon.
Note  To force a line segment in a Polyline entity to be 
aligned to the closer axis, horizontal or vertical, press and 
hold the Shift key while you click and drag for that line 
segment.
See    Forcing a Line Segment

Signoff Create an approval stamp containing information about the 
Markup author, date and time of creation.

From the toolbar click  icon.
See   Creating Signoff Entities

Option Description
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Creating a Non-contiguous Freestyle 
Entity
1 Select Entities > FreeStyle from the Markup menu.

Note  You can also click the Freestyle icon  from the Markup toolbar.
2 Click a point on the drawing where you want to start the freestyle entity.
3 Move the cursor to create the freestyle entity.
4 Click a point on the drawing where you want to interrupt the freestyle entity.
5 Click another point on the drawing where you want to restart the freestyle 

entity.
Note  You can interrupt the freestyle entity as many times as you like by 
repeating steps 4 and 5.

6 Right-click to end the freestyle entity.

Creating a Contiguous Freestyle Entity
1 Select Entities > FreeStyle from the Markup menu.

Note  You can also click the Freestyle icon  on the Markup toolbar.
2 Click a point on the drawing where you want to start the freestyle entity.
3 Move the cursor to create the freestyle entity.
4 Right-click to end the freestyle entity.

Adding a Leader
1 Select Entities > Leader from the Markup menu.

Note  You can also click the Leader icon  from the Markup toolbar.

Symbol Click and drag a symbol to the Markup.

From the toolbar click  icon.
See    Creating Symbols

Text Add text to the Markup.

From the toolbar click  icon.

See    Adding Text

Option Description
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2 Click a point on the document where you want the leader to start.
3 Move the cursor to draw the leader.

Note  To draw a leader and force it to be aligned to the closest axis, vertical 
or horizontal, hold the Shift key while moving the cursor.

4 To draw a leader with multiple line segments, repeat steps 2 and 3 as often as 
you like. You can click, then drag as often as you like. 

5 Right-click to end the leader.
The Text dialog appears.

6 To change the font, click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the checkbox beside the font style(s).
Type the text that you want to attach to the leader, then click OK.

7 Right-click outside the text area to complete the modification.
The leader appears on the drawing and in the Markup Navigation Tree.
Note  To edit the leader text, double-click the leader in the Markup 
Navigation Tree or in the workspace to open the Text dialog.
See Also   Forcing a Line Segment

Forcing a Line Segment to Become 
Horizontal or Vertical
You can draw a line segment and force it to be aligned with the closer axis, 
horizontal or vertical. You can also take an existing line segment and have it align 
with the closer axis. The types of line segments that you can align are lines, line 
segments of leaders and polylines, and measure entities.
Note  This procedure only works for measure entities that are drawn using Free 
snap. 
1 To draw and force a line segment, press and hold the Shift key while you 

click and drag for that line segment.
To force an existing line segment, click and hold the left mouse button on the 
line segment, then press and hold the Shift key.

2 When you see that the line segment is horizontal or vertical, release the left 
mouse button, then release the Shift key.

Adding Text
With AutoVue, you can add text entities to a markup.
1 Select Entities > Text from the Markup menu.
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Note  You can also click the Text icon  from the Markup toolbar.
2 Click a point on the drawing where you want to add text.

The Text dialog appears.
3 To change the font, click Font. The Font dialog appears.

From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the checkbox beside the font style(s).
Type the text that you want to add, then click OK.

4 Right-click outside the text area to complete the modification.
The text appears on the drawing and in the Markup Navigation Tree.

5 To move the text box click and drag it. 
6 Click and drag the frame handles to enlarge the text box.

Note  To edit text, double-click the text in the Markup Navigation Tree 
or in the workspace to open the Text dialog.

Adding a Note
You can attach longer comments and notes to a markup with AutoVue’s Markup 
Control Note Editor. A note is represented by a standard size graphical symbol 
labelled Note. To read the text inside, double-click the entity to open it or move 
the mouse over the entity to display the tooltip.
1 Select Entities > Note from the Markup menu.

Note  You can also click the Note icon  from the Markup toolbar.
2 Click a point on the document where you want to insert the note. 

The Markup Control Note Editor dialog appears.
3 Enter the text that you want in the note.
4 To modify the text, select Formatting and the format you want to apply.
5 Select File > Information.

The Note Information dialog appears.
Enter a Name, Author and Key Words for the note, then click OK.

6 Close the Markup Control Note Editor dialog.
The note appears on the drawing and in the Markup Navigation Tree.

7 Right-click outside the note area to complete the modification.
8 To move the note, click and drag it.

Note  To edit a note, double-click the note symbol  in the workspace. 
You can also select the note in the Markup Navigation Tree, right-click 
and select Edit, or double-click the note.
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Viewing the List of Notes
You can view a list of the notes you added to a file. You can also print the notes 
or find a note in the workspace.
1 Select Markup > List Notes from the Markup menu.

The List Notes dialog appears.
2 To find a note, select the note from the list and click Go To.

AutoVue zooms into the selected note in the workspace.
Note  You can also select the note from the Markup Navigation Tree, 
right-click and select Go To.

3 To print a note, select the note from the list.
Note  To print more than one note, press the Shift or Ctrl key while 
selecting. To print all the notes in the list, click Select All.
Click Print. The Note print options dialog appears.
Note  To print each selected note on a separate page, select One note per 
page.
Configure the print options, then click OK. The selected notes are printed.

4 Click OK to close the List Notes dialog.

Creating Signoff Entities
The signoff entity is an approval stamp containing information about the Markup 
author, date and time of creation. You create a signoff entity when the Markup 
file is finalized.
Note  If you create an entity after the Signoff, the signoff entity disappears. The 
Signoff should be the last entity added to a Markup.
1 Select Entities > Signoff from the Markup menu.

Note  You can also click the Signoff icon  on the Markup toolbar.
2 Click and drag to create a box on the drawing where you want the signoff.

The Signoff dialog appears displaying details of the signoff.
3 Click OK.

The signoff entity is created and appears on the drawing and in the Markup 
Navigation Tree.

Rescinding the Signoff
You can rescind a signoff on a drawing.
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1 Double-click the Signoff on the drawing or from the Markup Navigation 
Tree.
Note  You can also select Entities > Signoff from the Markup menu.
The Signoff dialog appears.

2 Click Rescind.
The signoff disappears from the drawing but remains in the Markup 
Navigation Tree.
Note  To have the signoff re-appear on the drawing, double-click it from the 
Markup Navigation Tree, then click Approve in the Signoff dialog.

Viewing the History of a Signoff
1 Double-click the Signoff on the drawing or from the Markup Navigation 

Tree.
Note  You can also select Entities > Signoff from the Markup menu.
The Signoff dialog appears.

2 Click History.
The Signoff History dialog appears displaying the author, date and time 
the signoff was created.

3 Click OK.
4 Click Cancel to close the Signoff dialog.

Creating an OLE Markup Entity
In AutoVue, you can insert a new or an existing OLE object.
1 Select Entities > OLE from the Markup menu.

Note  You can also click the OLE icon  on the Markup toolbar.
2 Click and drag to select the area on the drawing where you want to insert an 

OLE object.
The Insert Object dialog appears.

3 Click Create New to insert a new object and select the Object Type from 
the list.

4 Click Create from File to insert an existing object and enter the filename 
and path or click Browse to locate the file.

5 To display the object as an icon, click Display As Icon.
The icon that the object will be displayed as appears and the Change Icon 
button.
To change the icon, click Change Icon. The Change Icon dialog appears.
Select the icon that you want to change to, then click OK.
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Note  The Change Icon button is only enabled if icons are available.
6 Click OK in the Insert Object dialog.

The object appears on the Markup.
Note  If you selected Display as Icon, the selected icon appears as the 
object on the Markup.

7 Select Entities > OLE to exit or right-click in the workspace.
Note  To open the object, double-click on it.

Symbols
A Symbol is a graphical entity, such as a company logo. Before a graphic entity 
can be used as a symbol, it must be added to a Symbol Library. 
In AutoVue, you can create a Symbol Library and add symbols to it. You can also 
add or remove symbols from existing libraries.

Adding a Symbol
A symbol is a graphical entity, such as a company logo. With AutoVue, you can 
add a symbol to a markup.
1 Select Entities > Symbol from the Markup menu.

The Symbols dialog appears.

Note  You can also click the  icon in the Markup toolbar.
2 Click the Symbols tab.
3 From the Symbol Library drop-down list, select the library that you want 

to select a symbol from.
The symbols appear under Drag and drop a Symbol onto AutoVue.

4 Click Isotropic if you want to scale the symbol proportionately. 
Click Anisotropic if you want to scale the symbol disproportionately.

5 Click and drag the symbol onto the workspace.
6 Release the mouse button. 

The symbol appears on the drawing and in the Markup Navigation Tree.
Note  To add more symbols, repeat steps 3 to 5.

7 Close the Symbols dialog.

Creating a New Symbol Library
1 Select Entities > Symbol from the Markup menu.

The Symbols dialog appears.
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Note  You can also click the  icon in the Markup toolbar.
2 Click the Libraries tab.
3 Click Create.

The Symbol Library dialog appears.
4 Enter the Library Name, Description, Author and Keywords.
5 To add a symbol to the library, click Add.

The Open dialog appears.
6 Browse to locate the symbol you want to add, then click Open.

The file appears in the Symbol Files list.
Note  To add more symbols, repeat steps 4 and 5. To remove a symbol, 
select the symbol and click Remove.

7 Close the Symbols dialog.

Adding a Symbol to a Library
1 Select Entities > Symbol from the Markup menu.

The Symbols dialog appears.

Note  You can also click the  icon in the Markup toolbar.
2 Click the Symbols tab.
3 From the Symbol Library drop-down list, select the library that you want 

to add a symbol.
4 Click Add Symbol.

The Symbol Definition dialog appears.
Enter the Source file, Symbol Name and Description or click Browse 
to locate the source file. 

5 Click OK.
The symbol appears under Drag and drop a Symbol onto AutoVue in 
the Symbols dialog.
Note  To add more than one symbol, repeat steps 4 and 5.

6 Close the Symbols dialog.

Deleting a Symbol from a Library
1 In the Symbols dialog, click the Symbols tab.
2 From the Symbol Library drop-down list, select the library that you want 

to delete a symbol.
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3 The symbols appear Drag and drop a Symbol onto AutoVue.
4 Select the symbol you want to delete, then click Delete.

The library disappears from the list and from the Symbol Library drop-
down list under the Symbols tab.

5 Close the Symbols dialog.

Editing a Symbol Library Information
1 Select Entities > Symbol from the Markup menu.

The Symbols dialog appears.

Note  You can also click the  icon in the Markup toolbar.
2 Click the Libraries tab.
3 From the Symbol Libraries list, select the library that you want edit the 

information.
4 Click Edit.

The Symbol Library dialog appears.
5 Edit the information.
6 Click OK.
7 Close the Symbols dialog.

Deleting a Symbol Library
1 In the Symbols dialog, click the Libraries tab.
2 From the Symbol Libraries list, select the library that you want to delete.
3 Click Delete.

The library disappears from the list and from the Symbol Library drop-
down list under the Symbols tab.

4 Close the Symbols dialog.

Working with Hyperlinks
A hyperlink is a link between the current file and the new file or application. You 
can create hyperlinks within your current file so that your files and applications 
outside AutoVue are only a click away. The main benefit of adding hyperlinks to 
a file is that you can gather all files of related information into one file with the 
files kept separate. In other words, the files may be accessible from one location 
but the information is referenced, not duplicated. This ensures a manageable file 
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size when loading. If changes need to be made to a linked file, they need to be 
done in one location — to the linked file itself.

Creating a Hyperlink
1 Select Markup > Hyperlink > Establish from the Markup menu.
2 Click a point on the document where you want to place the hyperlink.

The Establish Hyperlink dialog appears.
3 Enter a Link Name.
4 Enter a Link Description (optional).
5 From the Link to drop-down list, select the type of link.

For example, Data File opens a document file, whereas Application open 
an application other than AutoVue.
The link change according to the selected link.

6 Click Browse to locate the Data file or application and its path that you 
want to link to or enter the information manually.
Note  For Application, ensure that the executable file is selected. For 
example, mspaint.exe.

7 To change the hyperlink icon, click Set Icon. The Open dialog appears.
Enter the file name or browse to locate the bitmap file that you want to use 
as the icon, then click Open.

8 Click OK in the Establish Hyperlink dialog.
The hyperlink appears on the Markup.
Note  If you changed the icon, the selected icon appears as the hyperlink on 
the Markup.

Firing a Hyperlink
1 To fire a hyperlink, double-click on it from the workspace.

The hyperlink file opens in the window you selected in the Establish 
Hyperlink dialog.
Note  You can also fire a hyperlink by selecting it, then right-clicking and 
selecting Hyperlinks > Fire from the pop-up menu or selecting Hyperlink 
> Fire from the Markup menu.

Editing a Hyperlink
1 In the Markup Navigation Tree or from the workspace, select the 

hyperlink that you want to edit.
2 Select Markup > Hyperlink > Edit from the Markup menu.
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The Establish Hyperlink dialog appears.
Note  You can right-click a hyperlink in the Markup Navigation Tree 
and select Edit from the pop-up menu.

3 Edit the information that you want.
4 Click OK.

The changes are saved.

Deleting a Hyperlink
1 In the Markup Navigation Tree or from the workspace, select the 

hyperlink that you want to delete.
2 Select Markup > Hyperlink > Break or Markup > Delete from the 

Markup menu.
The hyperlink is deleted from the file.
Note  You can also delete a hyperlink by right-clicking it in the Markup 
Navigation Tree and selecting Delete from the pop-up menu.

Viewing List of Hyperlinks
1 Select Markup > Hyperlink > List from the Markup menu.

The List Hyperlinks dialog appears listing the hyperlinks.
Note  You can right-click in the workspace and select Hyperlinks > List 
from the pop-up menu.
Note  You can fire a hyperlink by selecting the hyperlink and clicking Fire.

2 Click OK. 

Viewing History of a Hyperlink
AutoVue lets you view information about a hyperlink’s path. From a file that is 
launched from a hyperlink, you can see what document invoked the hyperlink.
1 From the hyperlink file, select File > Markup from the AutoVue main 

menu.
2 Select Markup > Hyperlink > History from the Markup menu.

The Hyperlink History dialog appears listing the path linking the 
hyperlink file to the file that invoked the hyperlink.

3 To jump to the file where you fired the hyperlink from, select the path in the 
Hyperlinks History dialog.

4 Click Jump to.
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Note  You can also go back by right-clicking in the hyperlink file and 
selecting Go Back from the pop-up menu.

Creating 2D non-vector Markup 
Measure Entities
When marking up 2D non-vector files, in addition to all the markup options 
available for 2D files, you can create markup measure entities. The measure 
options in Markup mode work slightly different than in View mode. For 
information on marking up 2D files, see Marking Up 2D Files.
When measuring in Markup mode, the specified measurement lines and values 
are displayed on the current active markup layer as entities. These entities can be 
moved, resized, hidden or deleted. You can also modify the font of a measure 
entity, align a “free snap” measure entity to the horizontal or vertical axis, as well 
as add units of measure and symbols to a measurement and have them appear on 
the drawing.
Measure options vary between vector and non-vector files. For vector files, 
AutoVue provides the option to “snap” to fixed points on the drawing. For non-
vector files, you can only “free snap”.
In Markup mode, you can choose from several measure options to create markup 
measure entities. You can access the measure options from the Analysis > 
Measure menu. The options are:

Option Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure an arc entity.

From toolbar click  icon.

Area Measure a selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.
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Measuring Distance
Use the Distance option to measure the distance between two specific points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure the distance.
4 Click a point on the drawing to define the starting point.
5 Click another point on the drawing to define the end point.

The measured line path appears as an entity on the current active markup.
6 Drag to move the measured line path.
7 Click on the measured line path.

The measurement and unit appear as an entity on the current active markup 
layer. The measured distance, Delta-X and Delta-Y appear in the 
Measurement dialog.

8 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring Cumulative Distance
Use the Cumulative Distance option to measure the distance along a path of 
multi-faceted (adjoining) points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure the distance.
4 Select Cumulative.
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5 Click a point on the drawing to define the starting point.
6 Continue clicking points along the path that you want to measure.

Each point is joined by a line. 
7 Right-click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The cumulated measured distance, Delta-X and 
Delta-Y appear in the Measurement dialog.

8 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Calibrating Distance
1 Measure the distance between two points or measure cumulative distance.

See   Measuring Distance
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.

3 In the Distance drop-down list, select the unit to which you want to 
calibrate the distance.

4 Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

5 Click OK. 
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Area is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.The Measurement 

dialog appears.

Note  You can also click the Area icon  on the Markup toolbar.
2 Click the Area tab.
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3 From the Measured Area Units drop-down list, select the unit in which 
you want to measure the area.
From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.

4 To cumulate a Net Area Result of different areas, select Add in the 
Measurement dialog. 
To subtract an area from the Net Area Result, select Subtract. 
Select Clear to clear the Net Area Result.

5 Click a point on the drawing to define the starting point.
6 Continue clicking points on the drawing to define the area you want to 

measure.
Each point is joined by a line. 

7 Right click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The area and perimeter measurements appear in 
the Measurement dialog.

8 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the Markup toolbar.
2 Click the Angle tab.
3 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
4 Click points on the drawing to define the angle you want to measure.

The points are joined by angle arms with an arc connecting them. 
5 Click again to complete the measurement. 

The measured line path, angle measurement and unit appear as an entity on 
the current active markup layer and in the Measurement dialog.

6 Click and drag to change the size of the arc.
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7 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

8 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Radius or Add Diameter is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the Markup toolbar.
2 Click the Arc tab.
3 From the Arc Info drop-down list, select the unit in which you want to 

measure the arc.
4 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
5 Select Add Radius if you want to measure the radius of the arc.

Select Add Diameter if you want to measure the diameter of the arc.
6 Click points on the drawing to define the arc you want to measure.

The points are joined by an arc. 
7 Click again to complete the measurement.

The measured line path, arc measurement and unit appear as an entity on the 
current active markup layer and in the Measurement dialog.

8 Click and drag the box anywhere on the drawing.
Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Calibrating an Arc
1 Measure an arc in the drawing.

See   Measuring an Arc
2 In the Measurement dialog, click Calibrate.
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The Distance Calibration dialog appears displaying the measured 
distance.

3 From the Distance drop-down list, select the unit to which you want to 
calibrate the distance.

4 Click Calibrate to and enter a value if you want to calibrate to a value.
Click Set Factor and enter a value if you want to calibrate by a factor.

5 Click OK. 
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Creating 2D Vector Markup 
Measure Entities
When marking up 2D vector files, in addition to all the markup options available 
for 2D files, you can create markup measure entities. The measure options in 
Markup mode work slightly different than in View mode. For information on 
marking up 2D files, see Marking Up 2D Files.
Measure options vary between vector and non-vector files. For vector files, 
AutoVue provides the option to “snap” to fixed points on the drawing. For non-
vector files, you can only “free snap”.
When measuring in Markup mode, the specified measurement lines and values 
are displayed on the current active markup layer as entities. These entities can be 
moved, resized, hidden or deleted. You can also modify the font of a measure 
entity, align a “free snap” measure entity to the horizontal or vertical axis, as well 
as add units of measure and symbols to a measurement and have them appear on 
the drawing.
In Markup mode, you can choose from several measure options to create markup 
measure entities. You can access the measure options from the Analysis > 
Measure menu. The options are:

Option Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure an arc entity.

From toolbar click  icon.
Cimmetry Systems Corp.



AutoVue 193
2D Vector Snapping Modes
The Snapping Modes available allow you to click to precise geometrical 
points on a drawing. For example, if you select Snap to end-point and you 
move the cursor over an end-point of a line, the end-point will be highlighted by 
a snap box. 
The Snapping modes allow you to snap to the mid, center and end-points of 
an entity:

Measuring Distance
Use the Distance option to measure the distance between two specific points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.

Area Measure selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.

Icon Snap to Description

End-point Geometric snap mode where a snap box appears 
when moving the cursor near a linear component’s 
end point.

Mid-point Geometric snap mode where a snap box appears 
when moving the cursor near the halfway point of a 
linear component.

Center-point Geometric snap mode where a snap box appears 
when moving the cursor near the center of an 
elliptical component.

Free snap Allow snapping at any point on the drawing.

Option Description
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1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

4 From the Measure Distance Units drop-down list, select the unit in 
which you want to measure the distance.

5 Click a point on the drawing to define the starting point.
6 Click another point on the drawing to define the end point.

The measured line path appears as an entity on the current active markup.
7 Drag to move the measured line path.
8 Click on the measured line path.

The measurement and unit appear as an entity on the current active markup 
layer. The measured distance, Delta-X and Delta-Y appear in the 
Measurement dialog.

9 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring Cumulative Distance
Use the Cumulative Distance option to measure the distance along a path of 
multi-faceted (adjoining) points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes
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4 From the Measured Distance Units drop-down list, select the unit in 
which you want to measure the distance.

5 Select Cumulative. 
6 Click a point on the drawing to define the starting point.
7 Continue clicking points along the path that you want to measure.

Each point is joined by a line. 
8 Right-click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The cumulated measured distance, Delta-X and 
Delta-Y appear in the Measurement dialog.

9 Click and drag the frame handle to change the size of the box.
Note  Click Reset to take another measurement.

10 Click Close to close the Measure Distance dialog.
See Also   Modifying Measurement Markup Entities

Calibrating Distance
1 Measure the distance between two points or measure cumulative distance.

See   Measuring Distance
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.

3 In the Measured Distance drop-down list, select the unit to which you 
want to calibrate the distance.

4 Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

5 Click OK. 
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Area is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.
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Note  You can also click the Area icon  on the Markup toolbar.
2 Click the Area tab.
3 Select Between Points if you want to measure the area between points on 

a drawing. Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

4 Select Shape if you want to measure the area of a predefined shape on the 
drawing. Snapping Modes are disabled.

5 From the Measured Area Units drop-down list, select the unit in which 
you want to measure the area.

6 From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.

7 To cumulate a Net Area Result of different areas, select Add in the 
Measurement dialog. 
To subtract an area from the Net Area Result, select Subtract. 
Select Clear to clear the Net Area Result.

8 If you selected Between Points, click points on the drawing to define the 
area, then right click to complete the measurement.
Each point is joined by a line. The measured line path, measurement and unit 
appear as an entity on the current active markup layer. The area and 
perimeter measurements appear in the Measurement dialog.

9 If you selected Shape, click the edge of a predefined shape on the drawing.
The shape is highlighted. The measured line path, measurement and unit 
appear as an entity on the current active markup layer. The area and 
perimeter measurements appear in the Measurement dialog.

10 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

11 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.
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The Measurement dialog appears.

Note  You can also click the Angle icon  on the Markup toolbar.
2 Click the Angle tab.

Select From 3 Points if you want to measure the angle between three 
points. Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

3 Select Between 2 lines if you want to measure the angle between two 
lines. Snapping Modes are disabled.

4 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

5 If you selected From 3 Points, click three points on the drawing to define 
the angle.
If you selected Between 2 Lines, click two lines on the drawing to define 
the angle.
Angle arms appear with an arc connecting them. 

6 Click to complete the measurement. 
The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The measured angle appears in the 
Measurement dialog.

7 Click and drag to change the size of the arc.
8 Click and drag the box anywhere on the drawing.
9 Click and drag the frame handles to change the size of the box.

Note  Click Reset to take another measurement.
10 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
Note  To create a markup entity for the measurement, you must ensure that Add 
Radius or Add Diameter is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.
Cimmetry Systems Corp.



198 AutoVue
Note  You can also click the Arc icon  on the Markup toolbar.
2 Click the Arc tab.
3 Select From 3 Points if you want to measure the arc between three points. 

Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

4 Select Arc Entity if you want to measure a predefined arc. Snapping 
Modes are disabled.

5 From the Arc Info drop-down list, select the unit in which you want to 
measure the distance.

6 From the Measure Angle Units drop-down list, select the unit in which 
you want to measure the angle.

7 Select Add Radius if you want to measure the radius.
Select Add Diameter if you want to measure the diameter

8 If you selected From 3 Points, click three points to define the arc, then 
click to complete the measurement
The points are joined by an arc. 
If you selected Arc Entity, click the edge of the arc that you want to 
measure.
The arc is highlighted.

9 Click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer.The measurements for center point coordinates, 
radius, diameter, arc length, start and end of angle and sweep appear in the 
Measurement dialog.

10 Click and drag the box anywhere on the drawing.
11 Click and drag the frame handles to change the size of the box.

Note  Click Reset to take another measurement.
12 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities

Calibrating an Arc
1 Measure an arc in the drawing.

See   Measuring an Arc
2 In the Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
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3 From the Measured Rad. drop-down list, select the unit to which you want 
to calibrate the distance.

4 Click Calibrate to and enter a value if you want to calibrate to a value.
Click Set Factor and enter a value if you want to calibrate by a factor.

5 Click OK. 
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Creating EDA Markup Measure 
Entities
When marking up EDA files, in addition to all the markup options available for 
2D files, you can create markup measure entities. The measure options in 
Markup mode work slightly different than in View mode. For information on 
marking up 2D files, see  Marking Up 2D Files.
When measuring in Markup mode, the specified measurement lines and values 
are displayed on the current active markup layer as entities. These entities can be 
moved, resized, hidden or deleted. You can also modify the font of a measure 
entity, align a “free snap” measure entity to the horizontal or vertical axis, as well 
as add units of measure and symbols to a measurement and have them appear on 
the drawing.
AutoVue provides the option to “snap” to geometrical or electrical points on the 
drawing.
In Markup mode, you can choose from several measure options to create markup 
measure entities. You can access the measure options from the Analysis > 
Measure menu. The options are:

Option Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure arc entity.

From toolbar click  icon.

Area Measure a selected area.

From toolbar click  icon.
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EDA Snapping Modes
The Snapping Modes available allow you to click to precise geometrical or 
electrical points. For example, when you have selected Snap to pin, move the 
cursor over the pin you want to select until the pin appears highlighted. 
The Snapping modes allow you to snap to the mid, center and end-points of 
an entity, as well as a pin, via and symbol.:

Distance Measures the distance between two points.

From toolbar click  icon.

Minimum Distance Measure the minimum distance between entities.

From toolbar click  icon.

Icon Snap to Description

End-point Geometric snap mode where a snap box appears 
when moving the cursor near the component’s end 
point.

Mid-point Geometric snap mode where a snap box appears 
when moving the cursor near the halfway point of a 
linear component.

Center-point Geometric snap mode where a snap box appears 
when moving the cursor near the center of an 
elliptical component.

Pin Electrical snap mode where a snap box appears 
when the cursor touches a pin.

Via origin Electrical snap mode where a snap box appears 
when the cursor touches a via.

Symbol origin Electrical snap mode where a snap box appears 
when the cursor touches the entire component.

Free snap Allows snapping at any point on the drawing.

Option Description
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Measuring Distance
Use the Distance option to measure the distance between two specific points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

4 From the Measured Distance Units drop-down list, select the unit in 
which you want to measure the distance.

5 Click a point on the drawing to define the starting point.
6 Click another point on the drawing to define the end point.

The points are joined by a line. The measured line path appears as an entity 
on the current active markup.

7 Drag to move the measured line path.
8 Click on the measured line path.

The measurement and unit appear as an entity on the current active markup 
layer. The measured distance, Delta-X, Delta-Y and the “Manhattan 
Distance” appear in the Measurement dialog. 

9 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring Cumulative Distance
Use the Cumulative Distance option to measure the distance along a path of 
multi-faceted (adjoining) points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
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11 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
12 Click the Distance tab.
13 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

14 From the Measured Distance Units drop-down list, select the unit that 
you want to measure the distance.

15 Select Cumulative.
16 Click the first entity to define the starting point.
17 Continue clicking points along the path that you want to measure.

Each point is joined by a line. 
18 Right-click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The measured distance, Delta-X, Delta-Y and 
the “Manhattan Distance” appear in the Measurement dialog. 

19 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

20 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Calibrating Distance
1 Measure the distance between two points or measure cumulative distance.

See   Measuring Distance
2 In the Measurement dialog, click Calibrate.
3 The Distance Calibration dialog appears displaying the measured 

distance.
4 In the Measured Distance drop-down list, select the unit to which you 

want to calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate the distance to 

a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

6 Click OK. 
The calibration result appears in the Measurement dialog.
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7 Click Close to close the Measurement dialog.

Measuring Minimum Distance
Use the Minimum Distance option to measure the minimum distance between 
entities. The available entities for snapping are nets, pins, vias and traces.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Minimum Distance icon  on the Markup 
toolbar.

2 Click the Min. Distance tab.

3 Click  First Set to select the entities that you want to measure from.
4 Select the Snapping Modes that you want to use for measuring.

See   EDA Snapping Modes
Note  If you select Net, you cannot select any other type of entity.

5 Click the first set of entities on the drawing.
The entities are highlighted.
Note  To clear the last set of entities you selected, click Clear Set.

6 Click  Second Set to select the entities that you want to measure to.
7 Click the second set of entities on the drawing.

The entities are highlighted in a different color.
8 From the Measured Min Distance drop-down list, select the unit in which 

you want to measure the distance.
9 Click Zoom to Result, if you want to zoom in on the measured value on 

the drawing.
10 Click Compute.

The minimum distance from the first set of entities to the second set is 
highlighted by a line. The measured line path, measurement and unit appear 
as an entity on the current active markup layer. The measurement, delta-X, 
delta-Y and the “Manhattan Distance” appear in the Measurement dialog.
Note  Click Reset to take another measurement.

11 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities
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Measuring Area
Use the Area option to measure the area and perimeter of a region.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Area is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Area icon  on the Markup toolbar.
2 Click the Area tab.
3 Select Between Points if you want to measure the area between points on 

a drawing. Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

4 Select Shape if you want to measure the area of a predefined shape on the 
drawing. Snapping Modes are disabled.

5 From the Measured Area Units drop-down list, select the unit in which 
you want to measure the area.

6 From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.

7 To cumulate a Net Area Result of different areas, select Add in the 
Measurement dialog. 
To subtract an area from the Net Area Result, select Subtract. 
Select Clear to clear the Net Area Result.

8 If you selected Between Points, click points on the drawing to define the 
area. 
Each point is joined by a line and the measurement appears in the 
Measurement dialog.

9 If you selected Shape, click the edge of a predefined shape on the drawing.
The shape is highlighted.

10 Right-click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The area and perimeter measurements appear in 
the Measurement dialog.
Note  Click Reset to take another measurement.

11 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities
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Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the Markup toolbar.
2 Click the Angle tab.
3 Select From 3 Points if you want to measure the angle between three 

points. Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

4 Select Between 2 lines if you want to measure the angle between two 
lines. Snapping Modes are disabled.

5 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

6 If you selected From 3 Points, click three points to define the angle.
If you selected Between 2 Lines, click two lines to define the angle.
Angle arms appear with an arc connecting them. 

7 Right-click to complete the measurement. 
The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The measured angle appears in the 
Measurement dialog.

8 Click and drag to change the size of the arc.
9 Click and drag the box anywhere on the drawing.
10 Click and drag the frame handles to change the size of the box.

Note  Click Reset to take another measurement.
11 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
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Note  To create a markup entity for the measurement, you must ensure that Add 
Radius or Add Diameter is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the Markup toolbar.
2 Click the Arc tab.
3 Select From 3 Points if you want to measure the arc between three points. 

Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   EDA Snapping Modes

4 Select Arc Entity if you want to measure a predefined arc. Snapping 
Modes are disabled.

5 From the Arc Info drop-down list, select the unit in which you want to 
measure the distance of the arc.

6 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

7 Select Add Radius if you want measure the radius.
Select Add Diameter if you want to measure the diameter.

8 If you selected From 3 Points, click three points to define the arc.
The points are joined by an arc.
If you selected an Arc Entity, click an edge of the arc.
The arc is highlighted.

9 Click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer.The measurements for center point coordinates, 
radius, diameter, arc length, start and end of angle and sweep appear in the 
Measurement dialog.

10 Click and drag the box anywhere on the drawing.
11 Click and drag the frame handles to change the size of the box.

Note   Click Reset to take another measurement.
12 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities

Calibrating an Arc
1 Measure an arc in the drawing.
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See   Measuring an Arc
2 In the Measurement dialog, click Calibrate.
3 The Distance Calibration dialog appears displaying the measured 

distance.
4 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate to a value.

Click Set Factor and enter a value if you want to calibrate by a factor.
6 Click OK. 

The calibration result appears in the Measurement dialog.
7 Click Close to close the Measurement dialog.

Marking up 3D Files
When marking up 3D files, you can attach text or a note, as well as create markup 
measure entities. The measure options in Markup mode work slightly different 
than in View mode.

3D Snapping Modes
The Snapping Modes available allow you to select or snap to different entity 
types on a model. For example, if you select Vertex, all vertices are highlighted 
and when you move the cursor over a vertex, a snap box appears.
The Snapping Modes allow you to snap to vertices, edges, faces, planes and arcs.

Attaching a Note
1 Select Entities > Note from the Markup menu.

Icon Snap to Description

Edge Edges are highlighted on the model.
When moving the cursor over an edge, a snap circle appears. 

Face Faces are highlighted when you move the cursor over a face 
and a snap triangle appears.

Vertex Vertices are highlighted on the model.
When moving the cursor over a vertex, a snap box appears.
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The Attach to dialog appears.

Note  You can also click the Note icon  from the Markup toolbar.
2 In the Attach to dialog, click the entity type that you want to attach the note 

to.
See   3D Snapping Modes

3 Select the entity on the model that you want to attach a note to. 
The Note dialog appears.

4 Type the text that you want in the note.
5 To change the font, select Font and font type.
6 Close the Note dialog.

The note symbol appears on the entity and in the Markup Navigation 
Tree.

7 Right-click outside the note area to complete the modification.
Note  To edit a note, double-click on the note to open the Note dialog.

Note  Whenever an entity is attached to a 3D model, the anchor point (the point 
at which the entity is attached) is highlighted by a small square. The square is 
visible only when the anchor point is visible. This feature allows you to precisely 
identify the location of the anchor point and whether the associated entities are 
visible or hidden.

Attaching Text
1 Select Entities > Text from the Markup menu.

The Attach to dialog appears.

Note  You can also click the Text icon  from the Markup toolbar.
2 In the Attach to dialog, click the entity type that you want to attach the text.

See   3D Snapping Modes
3 Click the entity on the drawing that you want to attach text. 

The Text dialog appears.
4 To change the font, click Font. The Font dialog appears.

From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the font style and type the text that you want to attach, then click OK.
The text appears on the entity and in the Markup Navigation Tree.

5 Right-click outside the text area to complete the modification.
Note  To edit text, double-click on the text to open the Text dialog.

Note  Whenever an entity is attached to a 3D model, the anchor point (the point 
at which the entity is attached) is highlighted by a small square. The square is 
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visible only when the anchor point is visible. This feature allows you to precisely 
identify the location of the anchor point and whether the associated entities are 
visible or hidden.

Creating 3D Markup Measure Enti-
ties
When marking up 3D files, you can create markup measure entities. The measure 
options in Markup mode work slightly different than in View mode.
When measuring in Markup mode, the specified measurement lines and values 
are displayed on the current active markup layer as entities. These entities can be 
moved, resized, hidden or deleted.
AutoVue provides the option to “snap” to different entity types on the model.
In Markup mode, you can choose from several measurement options to create 
markup measure entities. You can access the measurement options from the 
Analysis > Measure menu. The options are:

Name Description

Angle Measure the precise angle between three vertices or any two 
edges, planes or faces.

From toolbar click  icon.

Arc Measure the precise radius, length and angle of any arc and 
calculate the center point location.

From toolbar click  icon.

Distance Measure the precise distance between any two Vertex, Edge, 
Midedge, Arc Center or Face.

From toolbar click  icon.

Minimum Distance Measure minimum distance between any two Vertex, Edge, 
Midedge, Arc Center or Face.

From toolbar click  icon.
Note  You cannot create a Markup measure entity when 
measuring minimum distance.
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Measuring Distance
Use the Distance option to measure the precise distance between two vertices, 
edges, mid-edges, arc centers, faces or any combination of entity types.
Note  When measuring the distance between faces, if the faces are parallel, 
AutoVue compares the shortest distance between the parallel faces.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure the distance.

4 Click the From arrow  to select the entity type that you want to measure 
from.

5 Select the Snapping Modes that you want to use for measuring.
See   3D Snapping Modes
All entities of the selected entity types are highlighted on the model.

6 On the model, select the entity you want to measure from.

Edge Length Measure the precise length of a edge.

From toolbar click  icon.
Note  You cannot create a Markup measure entity when 
measuring the length of an edge.

Face Surface Measure the precise surface area.

From the toolbar click  icon.
Note  You cannot create a Markup measure entity when 
measuring surface area.

Vertex Coordinates Provide the coordinates of each vertex.

From the toolbar click  icon.

Name Description
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Note  If you want to take more than one measurement from the same 
starting point, click Fix Position.

7 Click the To arrow  to select the entity type that you want to measure to.
8 Select the Snapping Modes that you want to select as the end point for the 

measurement.
All entities of the selected entity types are highlighted on the model.

9 On the model, select the entity you want to measure to.
10 Click again to complete the measurement.

The measured line path appears as an entity on the current active markup.
11 Drag to move the measured line path.
12 Click on the measured line path.

The measurement and unit appear as an entity on the current active markup 
layer. The measured distance, Delta-X, Delta-Y and Delta-Z appear in the 
Measurement dialog.

13 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

14 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Calibrating Distance
1 Measure the distance between to points.

See    Measuring Distance
2 In the Measurement dialog, click Calibrate.
3 The Distance Calibration dialog appears displaying the measured 

distance.
4 In the Measured Distance drop-down list, select the unit to which you 

want to calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate the distance to 

a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

6 Click OK. 
The calibration result appears in the Measurement dialog.

7 Click Close to close the Measurement dialog.
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Measuring Minimum Distance
With the Minimum Distance option you can measure the minimum distance 
between model parts, as well as any two points from the selection sets: vertices, 
edges, mid-edges, arc centers, faces or any combination of entity types.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Minimum Distance icon  on the AutoVue 
toolbar.

2 Click the Min. Distance tab.

3 Click  Set 1 point.
4 Click Entity if you want to measure the distance between model parts. 

Snapping Modes are disabled.
Click Geometry if you want to measure the distance between entity types. 
Snapping Modes are enabled.

5 If you selected Entity, select a part or parts on the model.
The model part(s) appears in the list under Set 1 and are highlighted on the 
model and in the Model Tree.
If you selected Geometry, select the Snapping Modes that you want to 
use for measuring.
See   3D Snapping Modes
All entities of the selected entity type are highlighted on the model.
Select the entity or entities on the model.
The selected entities appears in the list under Set 1 and are highlighted on 
the model.
Note  To reset a Set, click Clear. To clear items from a Set, select the 
items and press the Delete key. To deselect a part or entity type on the 
model, press the Ctrl key and left-click the part or entity type.

6 Click  Set 2 point.
7 Repeat step 5.

The model part appears in the list under Set 2.
8 From the Measured Min Distance Units drop-down list, select the unit in 

which you want to measure the distance.
9 Click Compute.
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The minimum distance from the first set of entities to the second set is 
highlighted by a line. The measured line path, measurement and unit appear 
as an entity on the current active markup layer. The X, Y and Z coordinates 
for Position1 and X, Y and Z coordinates for Position2 appear in the 
Measurement dialog.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring an Angle
Use the Angle option to measure the precise angle between three vertices, any 
two edges, planes or faces or any combination of entity types.
If you want a markup entity for the measurement, you must ensure that Add 
dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the Markup toolbar.
2 Click the Angle tab.
3 Select the Snapping Modes that you want to use for measuring.

See   3D Snapping Modes
All entities of the selected entity types are highlighted on the model.

4 To measure the angle between an entity type and a plane, select the checkbox 
beside Plane, then from the drop-down list select the plane.

5 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

6 On the model, click points to define the angle.
Angle arms appear with an arc connecting them. 

7 Click again to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The measurement appears in the 
Measurement dialog.

8 Drag to change the size of the arc.
9 Click and drag the frame handles to change the size of the box.

Note  Click Reset to take another measurement.
10 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities
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Measuring an Arc
Use the Arc option to measure the precise radius, length and angles of any arc on 
the model. It also calculates the center point location.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the Markup toolbar.
2 Click the Arc tab.
3 Select Arc Entity if you want to measure a predefined arc.

All arc and circles are highlighted on the model. Snapping Modes are 
disabled.

4 Select From 3 Points if you want to measure the arc between three points. 
Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
See   3D Snapping Modes
All entities of the selected entity types are highlighted on the model.

5 From the Arc Info Dist. Units drop-down list, select the unit in which you 
want to measure the arc distance.

6 From the Angles Units drop-down list, select the unit in which you want to 
measure the angle.

7 If you selected From 3 Points, click three points to define the arc.
The points are joined by an arc.
If you selected Arc Entity, click the edge of an arc.
The arc is highlighted.

8 Click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer.The measurements for center point coordinates, 
radius, diameter, arc length, start and end of angle and sweep appear in the 
Measurement dialog.

9 Click and drag the box anywhere on the markup.
Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities
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Calibrating an Arc
1 Measure an arc on the model.

See    Measuring an Arc
2 In the Measurement dialog, click Calibrate.
3 The Calibration dialog appears displaying the measured distance.
4 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate the distance.
5 Click Calibrate to and enter a value if you want to calibrate to a value.

Click Set Factor and enter a value if you want to calibrate by a factor.
6 Click OK. 

The calibration result appears in the Measurement dialog.
7 Click Close to close the Measurement dialog.

Measuring Vertex Coordinates
The Vertex Coordinates option provides the coordinates of vertices on the 
model.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Vertex Coordinates icon  on the AutoVue 
toolbar.

2 Click the Vertex tab.
All vertices on the model are highlighted.

3 Double-click the vertex whose coordinates you want to add to the Markup.
The X, Y and Z coordinates appear in a tooltip.

4 Select the vertex.
The X, Y an Z coordinates and unit appear as an entity on the current active 
markup layer and in the Measurement dialog.

5 Click and drag the box anywhere on the markup.
Click and drag the frame handles to enlarge the box.

6 To remove the highlighted vertices on the model, click Close in the 
Measurement dialog. 
Note  You can also remove the highlighted vertices by selecting Analysis 
> Measure > Vertex again.
See Also   Modifying Measurement Markup Entities
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Printing
With AutoVue, you can print and preview files. Original files can be printed on 
their own or with associated Markups and Overlays. You can also choose which 
Markup layers to make visible so that they can print. 
With the Batch Print option, you can send a list of files to print at the same 
time. 
When printing a file, there are print properties that you can define. The properties 
are:

Print Options
With the Options tab, you can define print options for the printed file. The 
options are:

Option Description

Print Define the print options.
See   Configuring the Print Options

Margins Define the margin settings.
See   Setting the Print Margins

Headers/Footers Define the headers/footers to be included on every page 
printed.
See   Adding a Header/Footer

Watermark Define the watermark to be included on every page printed.
See   Adding a Watermark

Stamps Define the stamp to be included on every page printed.
See   Adding a Stamp

Pen Settings Change the thickness assigned to a pen.
See   Assigning Pen Settings

Option Type Description

Print to File Click to print to file and not to a printer. 
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Modify Sets printer properties, such as printer, paper 
size, orientation, etc.

Scaling Fit to page Scales the image to fit on the output page.

Factor Scales the image according to the scaling fac-
tors that you have manually entered in the 
input fields.
Note   Units can be entered as inches, 
millimeters or pixels.

Scale Scales the image according to percentage. You 
can select a predefined scaling factor or manu-
ally enter a customer scaling factor.
Note  Decimal places are excepted.

Document Pages Sets the document pages to print: All, Cur-
rent or Range.

Alignment/Offset Specifies where the drawing will appear on the 
print out.

Page Area Extents Prints the extents of the document.

Displayed Prints the area displayed in the View window.

Limits Limits printing to one page when the scaling 
options selected causes a single document 
page to span over multiple printer pages.
Note  Option is only enabled when 
Current is selected for Document Pages.

Selected Prints the area selected in the View window.
Note  Option will only be enabled when 
Current is selected for Document Pages.

Force to Black Forces all colors to black.

Output a single page Prints file on a single page.

Print Row Headers Prints row headers.
Note  Option is only enabled for 
spreadsheets, archive and database files.

Option Type Description
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Configuring the Print Options
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Options tab.
3 Configure the print options.

See   Print Options
4 Configure other print options.

See   Adding a Header/Footer
 Setting the Print Margins
 Adding a Watermark
 Adding a Stamp
 Assigning Pen Settings

5 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

6 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Print Column Head-
ers

Prints column headers.
Note  Option is only enabled for 
spreadsheets, archive and database files.

Partial Preview Displays a view of the printer page, highlight-
ing the printable area.

Number of Copies Select the number of copies you want to print 
of the file.

Option Type Description
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Print Margins
With the Margin tab, you can define the top, bottom, right and left margins for 
the printed file. You can define:

Setting the Margins
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears displaying the Options tab.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Margins tab.
3 Enter the margin size that you want for Left, Top, Right and Bottom or 

click Minimum if you want to set the margins to the minimum acceptable 
for the selected printer.
Select the checkbox Override printer-minimum margins if you want to 
override the minimum margins set for the printer.
Note  When you click Minimum, the minimum margins allowable 
automatically appear in the Margins.

4 From the Units drop-down list, select the unit in which you want to set the 
margins at.

5 Configure other print options.
See   Configuring the Print Options

 Adding a Header/Footer
 Adding a Watermark
 Adding a Stamp
 Assigning Pen Settings

6 To view a partial view of the file, click Partial Preview. 

Option Description

Margins Set the value for the Left, Top, Right and Bottom 
margins.

Minimum Sets the acceptable minimum margins for the selected printer.

Override printer-
minimum margins

If selected, overrides the minimum margins for the selected 
printer. 

Units Specify the unit for the margins.
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The Partial Preview dialog appears.
See   Partial Preview of a File

7 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Header/Footer
From the Headers/Footers tab of the Print Properties dialog, you can 
define the headers and footers that you want to print on every page of the 
document. You can enter the text manually or choose from a list of Insert 
Codes.
The list of insert codes are:
• %f: Full path of document
• %v: Document Drive
• %d: Document Directory
• %b: Document Base name
• %e: Document file extension
• %n: Total document pages
• %p: Current page number
• %N: Total tiled-pages
• %P: Current tile number
• %Y: Date: Year
• %M: Date: Month
• %D: Date: Day
• %W: Date: Day of week
• %H: Time: Hour
• %U: Time: Minute
• %S: Time: Seconds
• %r: New line
• %F: Native Print Settings (Excel)
Note  A literal percentage mark is entered manually as %%.

Adding a Header and Footer
In the Headers/Footers tab, you can manually enter text or choose from a list 
of Insert Codes to appear in the headers and footers. You can also print system 
variables. 
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1 Select File > Print from the AutoVue main menu.
The Print Properties dialog appears displaying the Options tab.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Headers/Footers tab.
3 Click in the Left, Center or Right text box to specify where you want the 

text to appear in the header and footer, then enter the text.
Note  You can have text appear in the Left, Center and Right of a header 
and footer.

4 To Insert Code in the header or footer, click Left, Center or Right, then 
select a code from the drop-down list.
For example, if you select %n: Total document pages the total number 
of pages for the selected file will appear in the header and footer.

5 To change the Font, click Font. The Font dialog appears.
Configure the font, then click OK.

6 In the Print Properties dialog, configure other print properties.
See   Configuring the Print Options

 Setting the Print Margins
 Adding a Watermark
 Adding a Stamp
 Assigning Pen Settings

7 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

8 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Native Print Settings
You can choose to included predefined headers and footers when printing an 
Excel file from AutoVue. 
1 From the Print Properties dialog, click the Headers/Footers tab.
2 Under Headers and Footers, click inside the Left, Center and Right 

boxes corresponding to the header or footer position in the original file.
3 Select %F: Native Print Settings (Excel) from the Insert Code drop-

down list.
4 Click OK to print.

The Excel file’s headers and footers are printed.
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Watermarks
With the Watermark tab, you can specify a watermark that will appear on a 
printed file. When printing a watermark, it appears transparent on the file 
contents. You can choose a horizontally or vertically oriented watermark.
In addition to entering text, you can:
• set the type, size and style of font
• insert Watermark information
• print system variables
To insert Watermark information, AutoVue provides a list of codes that you can 
choose from. These codes are:
• %f: Full path of document
• %v: Document Drive
• %d: Document Directory
• %b: Document Base name
• %e: Document file extension
• %n: Total document pages
• %p: Current page number
• %N: Total tiled-pages
• %P: Current tile number
• %Y: Date: Year
• %M: Date: Month
• %D: Date: Day
• %W: Date: Day of week
• %H: Time: Hour
• %U: Time: Minute
• %S: Time: seconds
• %r: New line
Note  A literal percentage mark is entered manually as %%.

Adding a Watermark
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears displaying the Options tab.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Watermark tab.
3 Enter the Watermark Text that you want to appear on the file.
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To insert a code in the watermark, select a code from the Insert Code drop-
down list.
For example, if you select %n: Total document pages, the total number 
of pages for the selected file will appear in the Watermark.
Note  You can insert more than one code.

4 To set the orientation of the watermark, click Diagonal, Horizontal or 
Vertical.

5 To change the Font, click Font. The Font dialog appears.
Configure the font, then click OK.

6 In the Print Properties dialog, configure other print properties.
See  Configuring the Print Options

 Setting the Print Margins
 Adding a Header/Footer
 Adding a Stamp
 Assigning Pen Settings

7 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

8 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Assigning Pen Settings
From the Pen Settings tab of the Print Properties dialog, you can set the 
thickness of the color indices for the print file.
Note  AutoVue uses the default pen color indices of the native document for the 
vector file being viewed. You will not be able to change the color assigned to a 
pen with AutoVue.
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears displaying the Options tab.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Pen Settings tab.
3 Under From/To, select the Color Index that you want to assign a new pen 

thickness.
Note  To change more than one color indices, press the Shift or Ctrl key 
while selecting.
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4 From the Units drop-down list, select the unit of measure that you want to 
set the thickness.

5 Enter the new thickness.
The new Thickness appears beside the Color Index.

6 In the Print Properties dialog, configure other print properties
7 Configure other print options.

See   Configuring the Print Options
 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Adding a Stamp

8 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

9 Click OK to print.
The Print dialog appears indicating the document is printing.
Note  Pen settings are stored in *c2t files. The Current Pen Settings 
drop-down list displays all existing *.c2t files for the current file. The default 
pen settings are stored in default.c2t and alternate pen settings are stored in 
alt.c2t.
See Also   Previewing a File Before Printing

Creating a New Pen Setting
1 Set the thickness for the color indices that you want.

See   Assigning Pen Settings
2 Click Save As. The Save As dialog appears.

Enter a File Name with a .c2t extension, then click OK.
The new pen setting appears in the Current Pen Settings drop-down list.

3 In the Print Properties dialog, click OK to print.
The Print dialog appears indicating the document is printing.

Deleting a Pen Setting
1 Select the pen setting that you want to delete from the Current Pen 

Settings.
2 Click Delete.

The pen setting disappears from the list.
3 Click Cancel to close the Print Properties dialog.
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Partial Preview of a File
The Partial Preview dialog displays the printable area on top of the page area 
so that users can have a clear idea of what will be printed.
Note  Option is only enabled when Current is selected from Document 
Pages.
1 Configure the print properties.

See   Configuring the Print Options
 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Adding a Stamp
 Assigning Pen Settings

2 Click Partial Preview in the Print Properties dialog.
The Partial Print Preview dialog appears.The Partial Preview dialog 
highlights the area that will be printed. The Paper size, Printable Area 
and Drawing Area are displayed.

3 Click OK to close the Partial Preview dialog.
See Also  Previewing a File Before Printing

Previewing a File Before Printing
You can preview a print copy of the current active file on screen according to 
your printer’s capabilities and the print property settings.
1 View the file in AutoVue.
2 Select File > Print Preview from the AutoVue main menu.

The Print Properties dialog appears.

Note  You can also click the Print Preview icon  on the AutoVue 
toolbar.

3 Configure the print properties.
See   Configuring the Print Options

 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Adding a Stamp
 Assigning Pen Settings
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4 Click OK.
The file appears in Print Preview Mode in the Print Preview window.
Note  You can print the file from the Print Preview window by clicking 
Print. You can also zoom in and out of a file, as well as navigate from one 
page to another of a multi-page file.

5 Click Close to close the Print Preview window.

Printing a File
In AutoVue you can print original files along with their Markup files and selected 
Markup layers together so that they appear as one file.
1 Open the file you want to print in AutoVue.

To print the associated Markups, open the Markup file(s) you want to print.
If you are printing Markup file(s) and you want to print the visible layers, 
select Modify > Markup Layers from the Markup menu, then from the 
Markup Layers dialog select the Markup layers you want visible.

2 Select File > Print from the AutoVue main menu.
The Print Properties dialog appears displaying the Options tab.

Note  You can also click the Print icon  on the AutoVue toolbar.
3 Configure the print properties.

See   Configuring the Print Options
 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Adding a Stamp
 Assigning Pen Settings

4 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

5 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing
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Batch Printing
With the Batch Print option you can send a list of files to print at the same time. 
You can also generate a batch by simultaneously opening all the files included in 
the batch print.
1 Select File > Batch Print from the AutoVue main menu.

The Batch Print dialog appears.
2 To add a file to the List of files to be printed, click Add. The Open 

dialog appears.
Enter the File name or browse to locate the file(s) that you want to add, 
then click Open.
The file(s) appears in the List of files to be printed.
Note  To add more files to the list, repeat steps 2 to 4. To remove a file(s), 
select the file from the List of files to be printed and click Remove.

3 Click OK in the Batch Print dialog.
The Print Properties dialog appears.

4 Configure the print properties.
See   Configuring the Print Options

 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Adding a Stamp
 Assigning Pen Settings

5 Click OK to print.
The Print dialog appears indicating the document is printing.
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Customizing AutoVue
There are configuration options that allow you to customize the AutoVue work 
environment. You can define the type of information copied to the clipboard, 
create tools to automate a variety of functions, including creating a hot key or 
access key. You can also customize toolbars and thumbnails to display according 
to your preferences. You can access the configuration options from the Options 
menu.

Defining the Clipboard
With the Clipboard Options you can define the type of information copied to 
the clipboard for later transfer to other applications.
The types of information that you can copy for raster, vector, spreadsheet, 
document and database files are:

To define clipboard options:
1 Select Options > Clipboard from the AutoVue main menu.

Type Description

DIB The acronym for Device Independent Bitmap and refers to the 
hardware information that is used to create a conversion 
bitmap.

Bitmap A rectangular array of colors representing a pixel bit map 
image.

Palette Refers to color image information.

Metafile A file storing the commands necessary for a Windows 
application to recreate a vector format image.

Text Refers to ASCII formatted text.

RTF Acronym for Rich Text Format and refers to the formatting 
information found in documents that allow fonts, margins and 
tabs to remain in documents.

Include Headings Refers to displaying the row and column titles for databases 
and spreadsheets.
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2 The Clipboard Options dialog appears.
3 Under the different file types, click the type of information that you want to 

copy to the clipboard.
4 Click OK.

Copying Information
1 Select Edit > Select from the AutoVue main menu.
2 Click and drag to select the area you want to copy.
3 Select Edit > Copy.

The information is copied to the clipboard.
4 Launch the application that you want to copy the information to.
5 Paste the information.

Tools
Tools are shortcuts for commonly repeated tasks. You can create tools to 
automate a variety of function such as importing objects, files and applications 
into the user interface; running a script file; connecting AutoVue to Dynamic 
Data Exchange (DDE) servers and linking to Dynamic Link Library (DLL) 
loads.

Adding a Tools Menu Item
1 Select Options > Customize Tools from the AutoVue main menu.

The Add Tool Menu Item dialog appears.
2 Click Add.

The Configure Tools Menu Item dialog appears.
3 Enter a Menu Item Name.
4 Click a Menu Item Action.
5 Click Application to launch an outside application.

Click Script File to launch a script file.
Click DDE Server to send DDE commands to a server application.
Click DLL to invoke a DLL.

6 Enter the name and path of the executable file, or click Browse to locate the 
specific file or application.
If you selected Application, click Configure. The Link to Application 
dialog appears. Enter the Command Line to launch an application, then 
click OK.
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If you selected Script File, click OK.
If you selected DDE Server, click Configure. The Link to DDE dialog 
appears. Enter the Topic and Commands, click Start Application, then 
click OK.
If you selected DLL Load, click Configure. The Link to DLL dialog 
appears. Enter the Entry Function to invoke a DLL, then click OK.

7 Enter a Menu Item Description.
8 Click OK.

The Menu Item appears under Options > Customize Tools.
9 Click OK to close the Add Tool Menu Item dialog.

Creating a Hot Key
1 Select Options > Customize Tools from the AutoVue main menu.

The Add Tool Menu Item dialog appears.
2 Click Add.

The Configure Tools Menu Item dialog appears.
3 Enter an ampersand & before the Menu Item Name.

For example, if you entered the menu item name &Application. The letter 
A after the & will be the hotkey.

4 Click OK.
The menu item appears under Options > Customize Tools with the letter 
A underlined.

5 Click OK to close the Add Tool Menu Item dialog.
Note  To activate the hotkey, hold the Alt key while pressing T and then A.

Modifying a Tools Menu Item
1 Select Options > Customize Tools from the AutoVue main menu.

The Add Tool Menu Item dialog appears.
2 Under Menu Contents, select the item that you want to modify.
3 Click Modify.

The Configure Tools Menu Item dialog appears.
4 Make the necessary changes.
5 Click OK.
6 Click OK to close the Add Tool Menu Item dialog.

Moving a Tools Menu Item
1 Select Options > Customize Tools from the AutoVue main menu.
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The Add Tool Menu Item dialog appears.
2 From the Menu Contents list, select the item that you want to move.
3 Click Up or Down to move the item to where you want in the list.
4 Click OK to close the Add Tool Menu Item dialog.

Deleting a Tools Menu Item
1 Select Options > Customize Tools from the AutoVue main menu.

The Add Tool Menu Item dialog appears.
2 From the Menu Contents list, select the item that you want to delete.
3 Click Delete.

The item disappears from the list.
4 Click OK to close the Add Tool Menu Item dialog.

Customizing Toolbars
In AutoVue, you can customize the toolbars to have them float freely or docked 
to the window frame. You can also change the background color of the toolbars.
To customize toolbars:
1 Select Options > Customize Toolbars from the AutoVue main menu.

The Toolbar Settings dialog appears.
2 Click the checkbox beside the toolbars that you want to display or clear the 

checkmark beside the toolbars that you want to hide.
3 Click the Toolbar button size that you want the buttons to appear on the 

toolbars.
4 Click OK.

The selected toolbars are changed.

Configuring the Mail Utility
At the time of installation, AutoVue integrates with MAPI compliant mail 
utilities that are installed on your computer, such as Microsoft Outlook. 
Electronic mail can then be accessed from within AutoVue, with the option to 
send a message only, send a message with links to Markup files or send a 
message with copies of Markup files.
The graphical interface and mailing options that are available to you are 
determined by the MAPI compliant mail utility you are using. AutoVue 
automatically attaches the current active file to messages when the Mail option is 
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activated. However, Markup files associated with the original file are left for you 
to select and attached to your mail message.
To configure the mail utility:
1 Select Options > Configure Mail from the AutoVue main menu.

The Mail Options dialog appears.
2 From the Mail using drop-down list, select the type of MAPI compliant 

mail utility you are using.
3 Click the Mailing Preferences that you want.
4 Click OK to close the Mail Options dialog.

Activating the Mail Utility
At the time of installation, AutoVue integrates with MAPI compliant mail 
utilities that are installed on your computer, such as Microsoft Outlook.
From AutoVue, you can access electronic mail with the option to send a message 
only, send a message with links to Markup files or send a message with copies of 
Markup files, for more information see Configuring the Mail Utility.
To access electronic mail:
1 Select File > Mail from the AutoVue main menu.

The mail utility installed on your computer is launched.
Note  When saving a Markup file, you can click Notify from the Save or 
Save As dialog to launch the mail utility.
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Thumbnails
Thumbnails allow you to build a visual representation of the entire contents of a 
directory in a thumbnails folder. Miniature visuals of the thumbnails folder file 
contents is created to help you preview files. 
Also available is a generic customized icon that is particularly helpful for 
identifying files that are more readily acknowledged by their file type. For 
example, a word-processing document located in a directory where the majority 
of the files are graphic formats. As files are modified, their thumbnails can be 
updated quickly and easily. AutoVue stores thumbnails information in the 
avwin/folders directory.

Customizing Thumbnails
You can customize thumbnails to display according to your preferences.
1 Select Options > Configure Thumbnails from the AutoVue main menu.

The Configure Thumbnails dialog appears.
Note  You can also configure thumbnails by selecting Thumbnails > 
Configuration from the Thumbnails window.

2 Select the Size in pixels of the thumbnails.
Note  You can customize the size of the thumbnails by clicking Custom 
and entering a value.

3 Enter the Space between thumbnails.
Note  The space between thumbnails must be between 2 and 20.

4 Click the File Details that you want to display in the thumbnail.
Click Full if you want to display the filename, size, date and time of 
creation.
Click Partial if you want to only display the filename.

5 Click OK.
6 To close the Thumbnails window, select Thumbnail > Exit 

Thumbnails or click the Exit Thumbnails  icon.

Creating a Thumbnail Folder
Note  If a thumbnails folder already exists for the current directory, the 
Thumbnails window will appear displaying the thumbnails.
1 Select Options > Display Thumbnails from the AutoVue main menu.
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The New Folder dialog appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.

2 Click Create.
Autovue creates the thumbnails folder for the current directory and the 
Thumbnails window appears displaying the thumbnails for that folder.
Note  This may take a few minutes depending on the size and number of 
files in the folder. If the thumbnails folder is taking to long to create, you can 
skip it by clicking Skip in the New Folder dialog. To resume creating the 
folder, select Thumbnail > Update All.

Viewing a Thumbnail Folder
You can display thumbnail folders from View or Markup mode.
Note  If a thumbnails folder does not exist for the current directory, the New 
Folder dialog appears with the option to create a new folder.
1 Select Options > Display Thumbnails from the AutoVue main menu.

The Thumbnails window appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.

2 Select Thumbnail > Folder.
The Browse for Folder dialog appears.

3 Browse to locate the thumbnails folder that you want to view.
4 Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
5 To close the Thumbnails window, select Thumbnail > Exit 

Thumbnails or click the Exit Thumbnails  icon.

Sorting a Thumbnail Folder
1 Select Options > Display Thumbnails from the AutoVue main menu.

The Thumbnails window appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.

2 Select Thumbnail > Folder.
The Browse for Folder dialog appears. 
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3 Browse to locate the thumbnails folder that you want to sort.
4 Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
5 Select Thumbnail > Sort and the option that you want to sort by.

Note  A checkmark beside the sort option indicates the current sort order.
6 To sort the thumbnails in ascending or descending order, select Thumbnail 

> Sort Order then Ascending or Descending.
7 To close the Thumbnails window, select Thumbnail > Exit 

Thumbnails or click the Exit Thumbnails  icon.

Viewing a Thumbnail
Files are instantly accessible from the Thumbnails window.
1 Select Options > Display Thumbnails from the AutoVue main menu.

The Thumbnails window appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.

2 Select Thumbnail > Folder.
The Browse for Folder dialog appears. 

3 Browse to locate the thumbnails folder that you want to view.
4 Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
5 Select the thumbnail that you want to view.

6 Select Thumbnail > Load File or click the Load File  icon.
The thumbnail is launched in the AutoVue workspace.
Note  You can also launch a thumbnail by double-clicking on the 
thumbnail.

Updating Thumbnails
You can update all the thumbnails in the current folder or update one or more 
thumbnails in the current folder.
1 Select Options > Display Thumbnails from the AutoVue main menu.

The Thumbnails window appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.
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2 Select Thumbnail > Folder.
The Browse for Folder dialog appears. 

3 Browse to locate the thumbnails folder that you want to view.
4 Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
5 Select the thumbnail(s) that you want update.

Note  To select more than one thumbnail, press the Shift or Ctrl key while 
selecting.

6 Select Thumbnail > Updated Selected.
The selected thumbnails are updated in the current folder.
Note  To update all thumbnails, select Thumbnail > Update All or click 

the Update All icon  on the Thumbnails toolbar.
7 To close the Thumbnails window, select Thumbnail > Exit 

Thumbnails or click the Exit Thumbnails  icon.

Viewing the Properties of a 
Thumbnail
1 Select Options > Display Thumbnails from the AutoVue main menu.

The Thumbnails window appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.

2 Select Thumbnail > Folder.
The Browse for Folder dialog appears. 

3 Browse to locate the thumbnails folder that you want to view.
4 Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
5 Select the thumbnail that you want to view the properties.
6 Select Thumbnail > Properties.

The Properties dialog appears.
7 Click Close.
8 To close the Thumbnails window, select Thumbnail > Exit 

Thumbnails or click the Exit Thumbnails  icon.
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Converting Thumbnails
1 Select Options > Display Thumbnails from the AutoVue main menu.

The Thumbnails window appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.

2 Select Thumbnail > Folder.
The Browse for Folder dialog appears.

3 Scroll to locate the thumbnails folder that you want to print.
4 Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
5 Select the thumbnail(s) that you want to convert.

Note  To select more than one thumbnail, press the Shift or Ctrl key while 
selecting.

6 Select Thumbnail > Convert.
The Batch Convert dialog appears.

7 Customize the conversion options.
See   Batch Conversion

8 Click OK.
9 To close the Thumbnails window, select Thumbnail > Exit 

Thumbnails or click the Exit Thumbnails  icon.

Printing Thumbnails
1 Select Options > Display Thumbnails from the AutoVue main menu.

The Thumbnails window appears.

Note  You can also click the Display Thumbnails icon  on the AutoVue 
toolbar.

2 Select Thumbnail > Folder.
The Browse for Folder dialog appears. 

3 Scroll to locate the thumbnails folder that you want to print.
4 Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
5 Select the thumbnail(s) that you want to print.

Note  To select more than one thumbnail, press the Shift or Ctrl key while 
selecting.

6 Select Thumbnail > Print.
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The Print Properties dialog appears.
7 Customize the print properties.

See   Printing
8 Click OK.
9 To close the Thumbnails window, select Thumbnail > Exit 

Thumbnails or click the Exit Thumbnails  icon.
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Full Text Extraction
The Full Text Extraction application provides a facility for obtaining all the 
textual information from a selected file. This may be used by a search engine to 
provide document indexing services. It eliminates duplicates and enables the 
search for all type of documents, including CAD.

Using the Full Text Extraction 
Utility
1 Select File > Tools > Auto Text Extraction from the AutoVue main 

menu.
The Automatic Text Extraction dialog appears.
Note  You can also open the Auto Text Extraction dialog by opening the 
file Outtext.exe located in the directory C:\Program 
Files\av\avwin.

2 In the From text box, enter the path and filename of the file from which the 
text is to be extracted. 

3 In the To text box, enter the path and filename or click Browse to locate the 
file to which the text is to be copied.
Note  File extensions include .txt and .out. The default is text.out 
located in the temp directory. If the file does not exist, the file will be 
created for you.

4 Click Display Output Contents if you want to preview the extracted text 
under Contents.

5 Click Extract.
The path and filename, and the text appears in the Output Contents.

6 Click Close to close the Automatic Text Extraction dialog.

CAD Information Extraction
This utility allows users to extract XRef information from a CAD file. This is 
useful for batch importing AutoCAD, MicroStation and various other types of 
CAD files into a document management system. 
1 Select File > Tools > Auto Text Extraction from the AutoVue main 

menu.
The CAD/Doc Text Extraction dialog appears.
Cimmetry Systems Corp.



240 AutoVue
2 In the From text box, enter the path and filename of the file from which the 
text is to be extracted. 

3 In the To text box, enter the path and filename or click Browse to locate the 
file to which the text is to be copied.
Note  File extensions include .txt and .out. The default is text.out 
located in the temp directory. If the file does not exist, the file will be 
created for you.

4 Click Display Output Contents if you want to preview the extracted text 
under Contents.

5 Click Extract.
The path and filename, and the text appears in the Output Contents.

6 Click Close to close the CAD/Doc Text Extraction dialog.
Note  Examples of integrations can be found in the Integrat directory of the 
AutoVue CD.
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Package Files
AutoVue can retrieve files stored in Package File Format and then load them in 
AutoVue. The Package File Format includes the base file, external references and 
Markups. All the basic Markup capabilities are supported: adding a new Markup 
for a base file, consolidating multiple Markups into a Markup, modifying an 
existing Markup and saving it as a new one.
AutoVue provides Package File functionality through a:
• Package File Creation Tool
• Markup Import Tool
• Package File DMAPI Component
• Package File Library

Package File Creation Tool
When a package file is created, the base file’s identity is obtained, along with the 
list of associated files, e.g. Xrefs and Markups. Users have the option to choose 
which of the associated files to include in the output file.
Note  The Package File Creation Tool is only available with Vuelink for 
Documentum.

Markup Import Tool
Users have the option of choosing which Markup files to import for a package 
file or whether a file to be imported is to keep its default identity or be imported 
under another user ID.
Note  Markup Import Tool is only available with Vuelink for Documentum.

DMAPI Component
The key component in the package file creation facility is a DMAPI component. 
This component enables AutoVue to treat package files as DMSes containing one 
viewable file.
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Viewing
Package files are opened in the same way as ordinary files. Users have access to 
all the external references and Markups bundled with the base file. Users have 
the option to modify existing Markups or create new ones to be associated with 
the package file.
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