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Part 1: Mastering Impromptu Reports

Welcome
What Is In This Document
This book is intended for advanced report authors who create complex reports. It provides
report authors with in-depth knowledge of the powerful features found in Impromptu.
This book contains information about
• advanced reporting techniques, including conditional highlighting, advanced filters and
calculations, and prompts
• how to work with templates and frames
• how to create crosstab reports, drill through reports, and sub-reports
• integrating Impromptu with other applications
• setting up your reporting environment
• optimizing performance

What You Need to Know to Use This Book Effectively
This book is aimed at advanced report authors who already know how to sort, group, associate,
and filter data. To learn these skills, you should read
• Discovering Impromptu
• the Impromptu online help

Other Information
Our documentation includes user guides, tutorial guides, reference books, and other pieces to
meet the needs of our varied audience.
All information is available in online help. Online help is available from the Help menu and Help
button in Windows products.
The information in each online help system is available in online book format (PDF). However,
the information from a given help system may be divided into more than one online book. Use
online books when you want a printed version of a document or when you want to search the
whole document. You can print selected pages, a section, or the whole book. Cognos grants you
a non-exclusive, non-transferable license to use, copy, and reproduce the copyright materials, in
printed or electronic format, solely for the purpose of providing internal training on, operating,
and maintaining the Cognos software.
In Windows products, online books are available from the Windows Start menu (Cognos) and
from the product Help menu (Books for Printing). All online books are available on the Cognos
documentation CD. You can also read the product readme files and the installation guides
directly from the Cognos product CDs.
Only the installation guides are available as printed documents.
An annotated list of other documentation, the Documentation Roadmap, is available from the
Windows Start menu or the Impromptu Help menu.

Questions or Comments?
For additional technical information about using Impromptu, visit the Cognos support Web site
(http://support.cognos.com).
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Chapter 1: Report Data
You use Impromptu’s powerful tools to create effective reports. You can shape your report by
customizing
• the data source
• data that appears in the report
• security features

Getting the Results You Want
You use Impromptu to answer business questions, such as
• Which sales representative sold the most products?
• How do sales representatives rank in terms of their total sales?
• Which product sells best?
To get the results you want, you need to understand how Impromptu generates what you see in
your reports.
Your administrator develops and implements a data model by
• defining information in the database
• creating a catalog that presents a business view of the data and defines what information
from the database you see and how the information in the database is structured
You then use the catalog to access the database and create the reports you need. You can
adjust the information that appears in your report by
• creating groups
• defining filters
• defining prompts
• creating summary fields
• adding calculated fields
• highlighting data

Specify the Catalog for Your Reports
You can specify, change or clear the catalog to which a report is attached. This enables you to
create and test a new report while attached to a small catalog, and then move the report to a
production catalog once your testing is complete.
You can also create and test a report at one location, then ship the report to another site with a
similar catalog and database.

Steps
1. Select the report.
2. From the Report menu, click General.
3. In the Catalog box, type the path and name of the new catalog to which you want to attach
the report. You can also click Browse to locate and select the new catalog.
4. Click OK.

Tip
•

You can also disconnect the report from the catalog to which it is attached by saving the
report with a snapshot of the data. However, you must reconnect to the catalog if you want
to refresh the data.

Mastering Impromptu Reports 9

Chapter 1: Report Data

Group Automatically
If a report does not include a grouped data item and you add a summary data item, Impromptu
automatically groups all data items in the report. This is called Auto-Grouping. Use this default
to quickly produce a summary report.
When auto-grouping is enabled, Impromptu assumes full control of grouping and association:
• the Group and Associate buttons are unavailable (unless you select a data item)
• any previously grouped data items become ungrouped
• data items are grouped in the order in which they appear in the Group tab (Query dialog
box)
• summaries are automatically associated with the last group listed in the Group Order box of
the Group tab (Query dialog box)
For example, you create a report that consists of Branch, Rep Name, and the Total Sale Amount
summary. Impromptu automatically groups Branch and Rep Name, and associates the
summary with Rep Name, the lowest-level grouped data item.

Steps
1. From the Report menu, click Query, and click the Group tab.
2. Select the Auto-Group check box and click OK.
If you include a summary data item in the query and click the Auto-Group check box, then
the data items are grouped in the order that they appear in the Group Order box of the
Group tab (Query dialog box).

Notes
•
•
•

Selecting the Auto-Group check box has no effect until a summary data item is included in
the query data.
By default, the auto-group checkbox is selected whenever you create a new report.
The Auto-Group check box is cleared if you select and group a data item or if you change
the automatic association of a summary data item.

Define Filters
You use filters to focus a report and minimize processing time by excluding any data that is
irrelevant to the report. For example, you can filter a report to show only the customers who
placed orders with a total sales amount greater than $500 during the past year.
You can create detail and summary filters.
Note: You cannot use text BLOBs (Binary Large Object) in filters.

Detail and Summary Filters
Your report can contain a combination of detail and summary filters.
A detail filter applies one or more specified conditions to each row of data. If the conditions are
true for a row, the row is retrieved and appears in the report; if the conditions are not true, the
row is not retrieved and does not appear in the report. For example, here is a report with a detail
filter that includes only branches that start with the letter ‘M’.
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You can filter summary data items that you select from a report query or the catalog. For
example, here is the same report listing branches and total sale amounts. Instead of a detail
filter, this report uses a summary filter that retrieves only the rows where total sale amount is
greater than $100,000.

Unlike a detail filter, which can include only detail data items, a summary filter can include both
summary and detail data items.
If you’re familiar with SQL, you can think of a detail filter as having a predicate in the WHERE
clause and a summary filter as having a predicate in the HAVING clause. The WHERE clause is
processed first, followed by any grouping and summarization, and then the HAVING clause is
processed.
For information about creating summaries, see "Summaries" (p. 24).

Create Filters
You can create filters by using filter definitions in the Filter tab (Query dialog box, Report menu).

Steps
1. From the Report menu, click Query.
2. Click the Filter tab.
3. Select either Detail or Summary in the Filter Type box.
4. From the Available Components box, insert the components into the Filter Definition box to
build your filter.
5. Click OK.
Note: You can only include crosstab filters in crosstab reports. For information about crosstab
filters, see "Filter Data in Crosstab Reports" (p. 77).

Use Filter Expressions
Use the OR operator and the AND operator to create the filter expressions you need. Follow
these guidelines when using filter expressions.
• Use the OR operator to indicate that a row must meet at least one of the conditions on either
side of the OR operator.
• Use the AND operator to indicate that a row must meet both of the conditions on either side
of the AND operator.
For example, retrieve only the rows of data where the product price is less than $10.00 or the
product margin is less than or equal $5.00, use this expression.
Product Price < 10 OR Product Margin <= 5

To retrieve only the rows of data where the product price is less than $10.00 and the product
margin is less than or equal to $5.00, use this expression:
Product Price < 10 AND Product Margin <= 5

Tip
•

To enhance performance, use limited local processing (Client/Server tab, Query dialog box)
instead of flexible processing.

For information about performance issues, see "Optimize Performance in Impromptu" (p. 115).
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For Example
You want to filter a report to show only those products from the GO Sport Line. Of the rows that
meet this condition, you want to retrieve only the rows in which the product price is less than or
equal to $10.00 or the product margin is less than or equal to $5.00.
Because expressions that use the AND operator are processed before expressions that use the
OR operator, the following filter returns results that you do not expect:
Product Type = ‘GO Sport Line’ AND Product Price <= 10 OR Product Margin <= 5

Impromptu retrieves rows that meet the condition "Product Type = ‘GO Sport Line’ AND Product
Price < 10." Impromptu then retrieves rows that meet the condition "Product Margin <= 5,"
regardless of their Product Type.
Instead, you use parentheses to indicate which expressions to evaluate first. The following
expression returns the correct results:
Product Type = ‘GO Sport Line’ AND (Product Price < 10 OR Product Margin <=5)

Because parentheses are processed before other operators, Impromptu first evaluates the
expression in the parentheses and retrieves all the products with a product price less than
$10.00 and a product margin less than or equal to $5.00. Impromptu then checks these
products for those that are from the GO Sport Line.
There is often more than one way to filter data and get the same results. Depending on how
your database processes requests, one method may be more efficient than another.

For Example
You want to retrieve only the rows for three product lines: Recycled Products, Sport Wear, and
Back Packs. You define this filter:
Product Line = 'Recycled Products' OR Product Line = 'Sport Wear' OR Product Line = 'Back
Packs'

Because the values in the example are from the same column of data, you can use the IN
operator to achieve the same results:
Product Line IN ('Recycled Products', 'Sport Wear', 'Back Packs')

Filter Without Changing Your Summaries
You can filter values from your report without affecting the summaries that are based on those
values.
For example, a summary in your report shows that the total number of orders is 1,122. When
you filter to show only orders with a total sale amount over $25,000, the total number of orders is
reduced to 39. You can calculate the summary first, then filter, so that the total number remains
at 1,122.

To specify that a summary is calculated before the summary filter is applied, do one of the
following:
• Click the Calculate Before the Summary Filter Is Applied check box in the Data Definition
dialog box of the summary data item. The summary calculation is prefiltered in this instance,
but not if you use it elsewhere.
• Add a Prefilter component to the summary expression. The calculation is always
automatically applied before the summary filter.
You can add the Prefilter component to a summary expression even when there is no summary
filter in the report. When you add or delete a summary filter, you do not change the summary
expression.
12 Impromptu ( R )
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Steps
1. From the Report menu, click Query, and click the Data tab.
2. In the Query Data box, select the summary data item that you want to calculate before the
summary filter is applied.
3. Click Edit Definition.
4. In the Data Definition dialog box, select the Calculate Before the Summary Filter Is Applied
check box or double-click Prefilter in the Available Components box to add it to the
Expression box.
If you add the Prefilter component to the Expression box, the data definition in the
Expression box becomes: "<summary data item> prefilter".
5. Click OK to return to the Query dialog box.

What You Can Do Using Filters
This section covers some of the things you can do using filters. You can retrieve data:
• that contains missing values
• that starts with or contains a specific value
• using another report
• using a filter based on a rolling time period
• that matches a pattern of characters

Retrieving Data that Contains Missing Values
You can limit your report to retrieve just those rows of data that contain missing values for a
specified data item. Missing values can be a blank, a variable length character field with a length
of 0, or a null value (a cell that contains nothing and is marked with a flag in the database).
For example, you want to determine which customers have not paid their invoices. You create
the following filter:
Payment is missing

Steps
1. In the Available Components box (Filter tab, Query dialog box), add the data item from the
Report column or the Catalog column.
2. In the Available Components box, double-click Is Missing and click OK.

Note
•

If no rows appear in the report, there are no missing values.

Tip
•

To show null values when you filter on another condition, you must include the null value
condition in the filter expression. For example, the following filter retrieves all product types
except Outdoor Products.
Product Type not in (‘Outdoor Products’) OR Product Type is missing

If the product type is a null value, the filter retrieves the row.

Retrieve Data that Contains a Specific String or Value
You can retrieve data that begins with or contains a specified string or value. For example, the
following filter retrieves only the rows in which the postal code or zip code begins with 3 specific
characters:
Postal Code Starts With 'K2G'

You can also filter a report to retrieve only the product numbers that contain a specific value. The
filter expression looks like this:
Product Number Contains '60'
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Steps
1. In the Available Components box (Filter tab, Query dialog box), add the data item from the
Report Columns or the Catalog Columns.
2. In the Available Components box, double-click Starts With or Contains.
3. Double-click String or Value.
4. In the Filter Definition box, type the string or value in the highlighted location and click OK.

Retrieve Data Using Another Report or Snapshot
You can filter a report using the data from
• another report. Impromptu re-runs the report that stores the dataset to ensure that it
contains the most current information.
• a snapshot. Impromptu filters on a fixed dataset and does not query the database. This
ensures that users working with the same report filter the same dataset.
For example, you have a report that contains customer details for your customers from Mexico.
You want to create a new report that contains only the order information for those customers, so
you create your new report, and then filter it using the customer details report. This restricts the
data available for your new report to orders made by customers in the customer details report.
Filters that rely on another report or snapshot always end with the filter expressions In, All, or
Any.

Steps
1. In the Available Components box (Filter tab, Query dialog box), add the data item from the
Report Columns or the Catalog Columns.
2. Create a filter expression ending with In, All or Any.
3. Double-click Dataset.
4. Click the report that contains the dataset and select the column on which you want to base
your filter.
5. Click Open.
6. Click OK.

Filter Using a Rolling Time Period
You can retrieve data for a time period that has a fixed range, where both dates continuously
move (a rolling time period). To create an expression for a rolling time period, you set the current
date from either:
• the database using the Now function
• your computer using the Today function.
Impromptu’s date functions, such as Add-years, work with date formats. If your database uses
DateTime formats, you must precede a date function in the filter with the DateTime-To-Date
function to convert the format.

For Example
You filter a report to retrieve the information for orders placed in the last year. Instead of
including the dates in the filter and changing them each time you run the report, you use the
following functions in the filter definition:
Order Date >= add-years ((now ( )), -1) and Order Date < now ( )

The first part of the expression restricts the data to records dated one year earlier than the
current date according to your PC, while the second part restricts the data to records from the
previous day or earlier.
When you apply the filter, Impromptu captures current information for use in the expression. For
example, if the now function returns a date of September 7, 1998, this expression will return all
records dated between September 7, 1997 and September 6, 1998.
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Steps
1. In the Available Components box (Filter tab, Query dialog box), add the data item from the
Report Columns or the Catalog Columns.
2. In the Available Components box, double-click
•

a comparative operator (>,>=,<,<=,=, and so on)

•

Functions and Add-years( )

•

Functions and Today( )

•

the minus sign -

•

Number

3. Do the following in the Filter Definition box:
•

Type 1 in the highlighted area between quotation marks.

•

Double-click the ellipse (...).

4. In the Available Components box, double-click
•

AND

•

the report or catalog column

•

a comparative operator (>,>=,<,<=,=, and so on)

•

Functions and double-click Today( )

5. Click OK.

Retrieve Data that Matches a Pattern of Characters
You can create an expression that retrieves data that matches a specific pattern. The pattern
can include wildcard characters as follows:
• the percent sign (%) represents any number of characters
• the underscore (_) represents one character
For example, you want to mail out flyers to specific regions of the city. You filter a report to
retrieve customer addresses that match a postal code or zip code pattern.
Postal Code Like 'H_Y%'

Impromptu retrieves only the codes that begin with "H," followed by any single character, a "Y,"
and any number of characters to complete the sequence. For example, Impromptu retrieves
"H2Y 2W2," "H8Y 2R5," and so on.
When you use the Like function to retrieve data that ends with a specific value, use the
Trim-Trailing function to remove blanks at the end of the data. For example, the following
expression removes blanks at the end of each Customer Name value and retrieves rows where
the last character of the customer name is ‘n’:
TRIM-TRAILING (Customer Name) LIKE ‘%n’

Steps
1. In the Available Components box (Filter tab, Query dialog box), add the data item from the
Report Columns or the Catalog Columns.
2. In the Available Components box, double-click
•

Like

•

String, then type the string including any wildcard characters

3. Click OK.

Note
•

Impromptu is case-sensitive. Be sure the case of the characters you enter is correct.
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Tips for Filters
•
•
•

To filter out repetitive information in the database and retrieve only unique rows of data,
select the Eliminate Duplicate Rows check box on the Filter tab (Query dialog box).
To remove all filters from a report, press Esc to ensure that nothing is selected in your
report, click the Filter button, and confirm that you want to delete the existing filter.
To provide the report user with a description of the report content, you can include filter
definitions or values in a report title or text frame. For example, a report is filtered to show
only the rows for North America. In the report title, you include the filter expression "Country
= 'North America'". You insert filter definitions using the More Objects dialog box.

Use Prompts to Select Report Data
You can use prompts to filter data when you open a report. The types of prompts are
• type-in
• picklist
• catalog
Each prompt type appears when you open a report. The report uses your response to filter the
data. When you open a report that contains more than one prompt, Impromptu presents the
prompts in the order they are listed in the Available Prompts list (Prompt Manager dialog box,
from the Report menu, Prompt Manager). Drag the prompts in this list to change their order.
Only prompts that are used in the report appear in the Available Prompts list in the Prompt
Manager box. If the prompt is used in a filter, calculation, or condition, its uses are also listed in
the reference box.

Tips
•
•

Impromptu runs prompts for sub-reports once at the same time as the parent query.
To include the prompt data in a report, click More Objects (Insert menu) and select the
Prompt Variables item.

Type-in Prompts
A type-in prompt captures information that you enter into the prompt. However, you cannot enter
multiple values in a type-in prompt except when you want to define a range or time period.
Because Impromptu is case-sensitive, type-in prompts are best suited for capturing dates or
numeric values that do not require familiarity with the contents of the database.
For example, a report on order information uses a type-in prompt to capture two dates.

Impromptu filters the report to show only the orders placed within a specific time period.

Ensure Case Compatibility
If you want your report to include a type-in prompt that requires text, you can control the text
case entered by the user. To do so, you add a filter that converts the text to all upper case (LIKE
THIS), or all lower case (like this).
This expression in the Filter tab of the Query dialog box converts the user-entered response to
the Customer Status prompt to upper case:
Customer Status in

( upper (

?What type?

)

)

You can also force the text to lower case by replacing the "upper" function with "lower."
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Picklist Prompts
A picklist prompt presents you with a list of data items from which you select one or more values,
so you need not be familiar with the database.
The values listed in picklist prompts can be retrieved from
• a database via a catalog when you want to select information that often changes.
• a column in another saved Impromptu report, a snapshot, or a HotFile, when you want to
select values from a subset of those available in the database. For example, a report picklist
prompt based on the Customer Name data item in another report lists only the customer
names included in the referenced report. When you open the new report, you are prompted
to select one of the customer names.
• a text file saved in a comma delimited ASCII format when you want to base a prompt on
information from another application. If the text file has a single column of values, the value
in the Prompts dialog box is the filter value. If the text file has two columns, the value in the
Prompts dialog box comes from the second column and the corresponding value from the
first column is the filter value. Use two columns in the text file to provide descriptive text for
the filter values.
For example, a report can include a prompt that asks you to select a product type from a list of
those available in the database. Only the products belonging to the product type you select are
retrieved and displayed in your report.

Tip
•

•

By default, the maximum number of items in a picklist is 100 items. Although you should
avoid using large picklists because they can be confusing to users, you can change this limit
in the Impromptu.ini file. Increasing the limit may have a negative impact on performance.
To change the prompt separator for a file picklist, modify the Impromptu.ini file. For
information, see the Impromptu Administrator online help. In the Index tab, type
• startup options
For information about performance issues, see "Optimize Performance in
Impromptu" (p. 115).

Picklist Prompts that Allow Multiple Selections
To create picklist prompts that let you select more than one value, use the In operator and put
the prompt in parentheses. For example, the filter expression
Product Type in (?Product Type?)

brings up the following prompt dialog box:

This prompt enables you to select multiple items from the list using Ctrl+click.
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Catalog Prompts
The administrator can create catalog prompts stored in a folder within the catalog. Users can
also create their own catalog prompts if they have the access rights or are working with a
personal distributed copy of the catalog (Folders in the Catalog menu).
Because the catalog prompts reside in the catalog, they are available to any report that attaches
to the catalog. You can access catalog prompts from the Filter tab (Query dialog box). A folder
for catalog prompts appears under the Catalog Columns in the Available Components box.
The catalog prompt symbol identifies a catalog prompt.
You can move, copy or delete catalog prompts just as you can any other catalog folder item
using OLE automation.
For information on OLE automation, see the Macro Online Help (CognosScript Editor).

When to Use the Types of Prompts
The type of prompt you create depends on factors such as the function of the prompt, the
amount of processing required, and the nature of the data (static or dynamic). Follow the
guidelines listed below to choose the appropriate type of prompt for your reports.
Use

If

Your report consists of a simple
A catalog picklist prompt. This
type of prompt does not require a list of dynamic values.
detailed knowledge of the
database.
A report picklist with a snapshot
or a HotFile report as the data
source. Because the report has
already been generated and
saved with the required data,
when you run the prompt you do
not have to query the database.
This can save time.

Additional processing is required
for filtering or calculations.

A type-in prompt. This type of
prompt can speed up processing
time because the report does not
need to reference the catalog.

Your audience has a detailed
knowledge of the database or you
want the report to be filtered on a
range of values.

A cascading report prompt. For
information about cascading
prompts, see "Calculating Data
Items" (p. 22).

Your reports consist of a hierarchy
of values.

Using the Prompt Manager
The Prompt Manager (Report menu) allows you to easily manage prompts in the current report.
You can
• create prompts
• edit prompts
• remove prompts
• store prompts
The Prompt Manager verifies links between prompts. If you attempt to create a circular link
between two reports in which Report A has a report picklist prompt that references Report B
and you attempt to set up a prompt for Report B that references Report A, the OK button
(Prompt Definition dialog box) becomes unavailable.
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Creating Prompts Using the Prompt Manager
You can create your own prompts using the Prompt Manager, or you can use prompts from the
catalog.
For catalog and report picklists, you can use one data item as the source for the prompt, and
display a different data item in the prompt.

For example, you can prompt users for a data item such as product name, but use Product
Number in the query that generates the report. This may affect performance.
For information about performance issues, see "Optimize Performance in Impromptu" (p. 115).
You can create prompts for single values and multiple values, and you can create cascading
prompts.

Steps to Create a Prompt for a Single Value
1. From the Report menu, click Prompt Manager.
2. Click New.
The Prompt Definition dialog box appears.

3. In the Name box, type a prompt name.
4. In the Type box, select the type of prompt.
5. In the Message box, type the instructions users see in the Prompts dialog box when you
open the report.
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6. Do one of the following:
To create this
type of prompt

Do this

Type-in

•

•

File Picklist

•
•
•

Report Picklist

•
•

•

Catalog Picklist

•

•

In the Data Type box, select the type of
data you will enter. Depending on the
expression, Impromptu may select a
default data type.
If you want a default value to appear in
the Type-in Prompt box when the report is
opened, type a default value in the
Default Value box.
Locate and select the desired file, and
click OK.
In the Data Type box, select the
appropriate data type.
Depending on the expression, Impromptu
may select a default data type.
Locate and select the desired report, and
click OK.
In the Report Data box, select the data
item you want to use to filter your report
and click Use.
If you want the Report Picklist to show a
different data item in the prompt, select a
data item and click Display.
In the Catalog Columns box, select the
data item you want to use to filter your
report and click Use.
If you want the Catalog Picklist to show a
different data item in the prompt, select a
data item and click Display.

7. Click OK.
If more than one prompt is defined, the new prompt appears highlighted in the Available
Prompts box.

Steps to Create Prompts for Multiple Values
1. Create more than one prompt.
2. From the Report menu, click Query.
3. Click the Filter tab.
4. In the Available Components box, add the required data item from the Report Columns or
Catalog Columns folder.
5. In the Available Components box, click the desired operator and then double-click Prompt
Manager
6. Click the prompt you want to appear as the first prompt, and click OK.
7. In the Available Components box, click the operator you want to use (either And or Or).
8. Repeat steps 4 to 7 until all the prompts you want to use are included.
9. Click OK.

Notes
•
•
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Creating and Using Cascading Prompts
You can create a series of prompts that show only the values that correspond to the value
selected for the previous prompt. These are called cascading prompts. To do so, you create a
series of linked reports, each of which contains a filter prompt.
Because Impromptu runs each report, the size of the reports affects performance. If you use a
large report as the source for a prompt, Impromptu must run the report and read through the
dataset to apply the filter. If the information contained in the database does not change very
often, it is more efficient to create a HotFile with the data that you want in your picklist, and then
use the HotFile in your Query.
For example, you open a report, and a prompt appears asking you to select a product type from
a list of product types. You select the Environmental Line. The next prompt asks you to select a
product line from a list showing only the product lines belonging to the Environmental Line. You
select the Sun Block product line, and the report appears showing only the data for the Sun
Block products.

Steps
1. Create the report that you want the user to open.
2. Save, but do not close, the report. For each cascading prompt you require, save the report
again with a different name for each.
3. Go back to the first report you created.
4. From the Report menu, click Query, and click the Filter tab.
5. In the Available Components box, double click the Report Columns folder to open it.
6. Double-click the data item you want to appear in the filter expression.
7. In the Available Components box, click "In" or "=", and click the left parenthesis.
For example, Product in (
8. Double-click Prompt Manager in the Available Filter Components box.
9. Click New to create a prompt.
10. In the Prompt Definition dialog box, type a Name and a Message for the prompt.
11. In the Type box, click Report Picklist.
12. Locate and select one of the reports you saved in step 2.
13. In the Report Data box, select the data item that the current report prompts for, click Use,
click Display and click OK.
14. Click OK to close the Prompt Manager.
15. Complete the filter definition by double-clicking ")" in the Available Components box, and
click OK.
For example, Product in (?Product Name?)
16. Open each of the reports you saved (other than the first report you created in step 1), and
edit each report so it contains the required data items, and the appropriate filter definition
containing the desired prompt.
17. Open the last report and edit it so it is a simple list containing the data item for which the
user is prompted.
18. Save the report.
When you open the report you created for users, you are presented with the series of prompts
and lists of filtered values.
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Notes
•

•

If a prompt in the current report is based on a report that also contains a prompt, you must
respond to the prompt in the referenced report before you can respond to the prompt in your
current report.
Impromptu comes with two sample reports with cascading prompts, Product Sales
Quantities Prompt.imr and All Country Sales Prompt.imr. Look at the Prompt Definition
dialog box (Prompt Manager, Report menu) in these reports to see how the prompts are
created. Look in the Filter Definition box (Filter tab, Query dialog box) to see how the filters
are set up.

What You Can Do Using Prompts
You can use prompts to
• filter reports
• calculate data items
• format data

Filter Reports
Prompts are often used to filter reports. For example, a filter retrieves product information based
on the product line captured by the prompt:
Product Line = ?Product Line Prompt?

Each time you open the report, you can enter a different product line, but the filter itself stays the
same.
Filters that use prompts are more efficient than other filtering methods. A prompt filter is applied
when data is retrieved from the database on the first query. Other types of filters apply to
existing queries, so Impromptu must access the database again.
For information about performance issues, see "Optimize Performance in Impromptu" (p. 115).

Steps
1. From the Report menu, click Query, then click the Filter tab.
2. Create a filter expression up to the point where you want to include the prompt.
For information about creating filter expressions, see (p. 11).
3. Do one of the following:
•

To use an existing prompt or create a new prompt, double-click Prompt Manager, select
or create the prompt, and then click OK.

•

To use a prompt stored in the catalog, double-click Catalog Columns, select the prompt,
and then click OK.
The path for the prompt location and the prompt name appears in the Filter Definition box.
For example, a prompt called Sales Over the Catalog Prompts folder would look like this:
Sale Amount >= ?\Catalog Prompts\Sales Over?

4. Complete the filter expression, if necessary.
5. Click OK.

Calculating Data Items
Prompts can capture values that are used in calculations. For example, a calculation determines
new product prices based on a markup value captured by the prompt:
New Product Price = Product Price + (Product Price * ?Markup?)

Each time you open or run the report, you can enter a different markup value without modifying
the calculation itself.

Steps
1. From the Report menu, click Query, and click the Data tab.
2. Click the Calculate button.

22 Impromptu ( R )

Chapter 1: Report Data
3. In the Calculation Definition dialog box, create a calculation expression up to the point
where you want to include the prompt.
For information about creating calculation expressions, see "Create Calculated
Fields" (p. 32).
4. Do one of the following:
•

To use an existing prompt or create a new prompt, double-click Prompt Manager, select
or create the prompt, and then click OK.

•

To use a prompt stored in the catalog, double-click Catalog Columns, select the prompt,
and then click OK.

5. Click OK to close the Prompt Manager dialog box.
Your prompt name appears in the Expression box. For example, a prompt called Sales Over
looks like this:
Sale Amount >= ?Sales Over?

6. Complete the calculation expression, if necessary.
7. Click OK.
Impromptu shows the Prompts dialog box where you can select a value.

Format Data
Prompts can capture values used in conditions that format data. Every time you run a report,
you can change the condition description without modifying the condition itself.
For example, you create a condition that applies a green background color to all sales amounts
greater than the number entered in a prompt. You could enter "500" in the prompt as follows:

The resulting list would have all sale amounts greater than $500 conditionally formatted.
All sale amounts
over $500 are
highlighted.

Steps
1. Select a data item in the report to which you want to add conditional formatting.
2. From the Format menu, click Conditional Formats.
3. From the Conditional Formats dialog box, click Conditions.
4. From the Conditions dialog box, click Add Custom Condition.
Mastering Impromptu Reports 23

Chapter 1: Report Data
5. Create a condition expression up to the point where you want to include the prompt.
For information about conditional text, see "Conditionally Format Data" (p. 42).
6. Double-click Prompt Manager and do one of the following:
•

If the prompt already exists, select it from the Prompt Manager dialog box.

•

If the prompt doesn’t exist, click New and create it. Click OK to close the Prompt
Manager dialog box.
Your prompt name appears in the Expressions box. For example:
Sale Amount >= ?Sales Over?
7. Complete the condition expression, if necessary.
8. Click OK.
9. Click Close.
10. In the Change Style To box, select the style you want to apply.
11. Click OK.
Impromptu shows the Prompts dialog box where you can select a value.

Summaries
Summaries, like functions, are predefined calculations that perform an operation on one or more
values and return a value such as total, count, or average, that summarizes the data. You can
use summaries on their own or as part of a larger expression.
You can create summaries based on either the report data or the catalog to which the report is
attached. If your report contains grouping, and you want your summary to take into account the
groups, create the summary based on the report. This ensures that the results returned by the
summary reflect the report organization.
The key difference between these summary types is that summaries based on a report include
an appropriate function (for example the "distinct" clause in SQL) to ensure that only one
instance of each value is counted for grouped items.
For example, you have a list report of your customers’ addresses that is grouped by Country,
City, and Customer. You want a count of the number of customers supported by each of your
distribution centers, which are organized by Country. You create a Count summary of
Customers based on your report. The result is an accurate count of the customers supported by
your distribution centers in each country.
Note: If you had created the Count summary based on the catalog, the summary would have
returned a count of how often the Customer field was not empty, including all recurrences of the
same customer name.
For information about creating simple summaries, see the Impromptu online Help. In the Index
tab, type
• summaries
You can create more complex summaries using the summaries listed in the Available
Components box.
All the summaries are available in the Calculation Definition dialog box. You can access this
dialog box with the Calculate button (Query dialog box) or the Calculation command (Insert
menu).

Summarize Data
Some types of summaries calculate a value for each row in the report. By default, individual row
summaries appear in a column of their own. For example, you create the following summary:
Running-total (Total Sale Amount)
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The Running-total summary takes the value of a row in the report, adds it to the total of all of the
previous rows in the group, and creates a new total in the new calculated column.

Running summaries produce a sorted result that relies on the report sorting. You shouldn’t apply
further sorting on running summary columns on a report.
Some types of summaries calculate a single value for a group of rows. By default, these
summaries appear in a group footer. For example, you calculate the average quota for all sales
reps within a country. The summary looks like
average (Quota 95) for [Country]

The summary values appear in a separate column, but you move the result into the group footer.

You can also place summary values in the group header, however, this can slow down
Impromptu’s performance.
For information about performance issues, see "Optimize Performance in Impromptu" (p. 115).
Each summary is associated with one of the following:
• its location in the report, called automatic association
• a specific data item, called fixed association

Automatic Association
The value of a summary with automatic association changes with the summary’s current
location in the report. When you add a summary to a report, the summary has automatic
association by default.
You can tell that a summary has automatic association by its icon in the Group tab (Query dialog
box).
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For Example
This report displays sales amounts for Canada and Sweden and shows the totals that
Impromptu automatically calculates when you add Total (Sale Amount) to your report using the
Summary button on the toolbar.

Total (Sale Amount) [for Customer No.]

Total (Sale Amount) [for Customer No.]
Total (Sale Amount) [for Country]
Total (Sale Amount) [for Report]

If you drag and drop a summary to a different location in the same report, the summary’s value
changes. For example, if you move Total (Sale Amount) [for Country] to the page header area,
the summary becomes Total (Sale Amount) [for Report] and the report no longer contains a
Total (Sale Amount) for [Country].
Total (Sale Amount) [for Report]

Total (Sale Amount) [for Customer
No.]

Total (Sale Amount) [for Customer
No.]
Total (Sale Amount) [for Report]
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Fixed Association
When you add a summary to a query, you can associate the summary to a specific data item in
the report or catalog, or to the entire report. If you move the summary, the value does not
change.
You can tell that a summary has fixed association by its icon in the Group tab (Query dialog
box). The lower portion of a fixed summary’s icon is blank.

For Example
You include a summary to calculate the Total Sale Amount and you manually specify that the
summary is for the customer name. This ‘for’ clause is hard-coded or fixed in the summary
expression, so the summary does not change when you change its location in the report.
The value of this summary does
not change when you copy or move
it here from its original location.

The summary’s association is fixed
with Customer Name, regardless of
where you copy or move the
summary.

Different Summary Results for Grouped Columns
In a grouped report, summary results can be different if the user selects a column from the
catalog, when the same column is available in the report. If the catalog column is selected, the
summary is applied against all rows in the table disregarding some grouping at the report level.
In the first example, the grouping makes the summary results between the two columns
different. The first count (Product No.) column is selected from Report Columns and is returning
the count of Product No. from the report which is 35. (The screen capture only shows the first
four rows). The second count (Product No.) column is selected from Catalog Columns and is
returning the count of all Product No. from the catalog which isn't affected by the grouping.

In the second example, the grouping has been removed and both results are the same.

Create a Summary
Steps
1. From the Report menu, click Query, and click the Data tab.
2. Click the Calculate button.
3. In the Calculation Definition dialog box, type a name for the summary in the Name box.
This name appears in the Data tab.
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4. In the Available Components box
•

double-click Summaries

•

double-click the appropriate summary option

•

add the required data item from the Report Columns or Catalog Columns folder

5. To create an automatic association, skip to Step 7. To create a fixed association,
double-click For.
6. Do one of the following:
Double-click

To associate the summary to

Report Columns, and
double-click the data item.

A data item that is in your report.

Catalog Columns to locate
and select the data item,
and click OK.

A data item that is not in your
report.

Report.

The entire report.

7. Continue to add the necessary expression components, and when the summary is
complete, click OK.

Tip
•

To add a summary directly into your report, click Calculation (Insert menu), position the
pointer where you want to insert the calculation, and click the mouse button. The
Calculation Definition dialog box appears and you can create a summary.

Choose a Group Level for a Fixed Summary
The group level associated with a fixed summary determines whether one or multiple summary
values appear for a group.

For Example
The following report has an Average Product Price for Product Line. There is one summary per
Product Line. Because there are multiple Product Lines per Product Type, there are multiple
Average Product Price summaries per Product Type.
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If you want only one Average Product Price summary per Product Type, you can change the
association of Average Product Price so that it is fixed with Product Type. There is now only one
summary per Product Type and the value reflects the Average Product Price for Product Type

Changing a Summary’s Association
You can change a summary’s association at any time from fixed to automatic and vice versa.
You can also change a summary that has fixed association so that it is associated with a
different group.
When you change its association, you are changing
• how the summary column appears in the list report. In list frames, the summary appears
once for each occurrence of its associated data item.
• the summarization results. The summary is calculated for its current associated data item.
• calculations performed on the associated data item. A summary operation, such as count,
ignores data repeated within that group. Only one summary for each group of the
associated data item is counted.
• the association of the summary in the Group tab (Query dialog box).
• the association in the Association box of the Data Definition dialog box.
• the order of the report data. The sort order in your report varies depending on the
associations you set for the data items in your report.
When you sort on

The report is sorted

An associated data item

By the grouped data item with
which it is associated
For example, if Product Line is a
grouped data item and Product
is associated to Product Line,
Impromptu sorts Product first
and Product Line second.

A detail data item that is not
associated with the grouped
data item

By the detail data item
For example, if Product Type is
a grouped data item and
Product Price is a detail data
item, the details within Product
Type are sorted in the order of
Product Price. The order of the
groups, however, remains
unchanged.

You can change a summary’s association by selecting the summary in the Query Data box
(Query dialog box) and clicking Edit Definition.

Note
You can only change the association of a summary that is predefined in the catalog if you have
the necessary permissions.
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Steps
1. Select a value in the report’s summary column, right-click, and click Data Definition.
2. In the Association box (Data Definition dialog box), do one of the following:
Select

To calculate the summary

Automatic

Based on its location in the report

Report

For the entire report

A data item

For a specific data item

3. Click OK.

Tip
•

To view the association of a selected summary in your report, look in the status line. For
example, Total (Sale Amount) [for Product Type].

Create or Copy a Summary
There is an important difference between making copies of a summary and creating a summary.
When a summary has automatic association (its value reflects its location in the report), you get
a different result depending on whether you copy the summary or create a new summary.
For information about automatic association, see (p. 25).

Copy Summaries
When you copy a summary that has automatic association, and you paste it in another location
in your report, you actually copy the text frame within the report. If there is a conflict between the
copied summary’s group levels, Impromptu calculates the summary for the highest group level.
For example, you have a summary, Total Sale Amount, in the City group footer. You make a copy
of Total Sale Amount and paste it in the Country group footer (which is higher than the City
group). The summary calculates Total Sale Amount for the Country, and both text frames show
the Total Sale amount, for the Country. Therefore, the wrong summary value appears in each
City group footer.

Create Summaries
When you create a summary, Impromptu inserts a discrete calculation in the query. You must
create a new summary for each discrete summary in your report.
For example, you have a summary, Total Sale Amount, in the City group footer. You want the
Country group footer to have a Total Sale Amount, so you create a new summary data item and
you associate it with Country. Two summaries appear in your query; each one calculated for a
discrete group in your report. The labels following the summary name in the Query Data box
(Query dialog box) and the Group Order box (Group tab, Query dialog box) identify these two
discrete groups.

Change a Detailed Data Item into a Summary
You may require a summary of a data item in your report rather than the details. Instead of
adding a new, summarized data item to the query, you can change the definition of a data item
that is already in the report.
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For example, a report contains the Sale Amount for each Product in an order. You create the
summary Total (Sale Amount). This summary shows the total sale amount for each order, rather
than the sale amount for each item in an order.
The Sale Amount column
contains details.

If you add a summary, the
report contains both details
and a summary for Sale
Amount and the report
takes longer to process.

If you change Sale Amount from
a detailed data item to a
summary, Impromptu does not
have to retrieve the details from
the database.

Steps
1. In the report, select the data item you want to change into a Summary.
2. Right-click and click Data Definition.
The data item you selected in the report appears in the Expression box.
3. In the Expression box, select the data item to highlight it.
4. In the Available Components box, double-click the Summaries folder.
5. Double-click the type of summary you want to create and click OK.
Impromptu changes the original definition of the data item into a summary based on the
type of summary you chose. By default, the summary has automatic association.

Tips
•

•

To insert a catalog summary that has an automatic association into a list footer and a group
footer, add the summary data item twice to the Query data (once for each location in the
report).
To re-use a calculated data item that contains a summary in another report, or to enable
other users to use a calculated data item that contains a summary, you can add the
calculated data item to the catalog.
For information about adding calculated data items to a catalog, see your administrator.
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Calculated Fields
A calculated field is a new data item based on a formula that you define. You can use calculated
fields created by the administrator or you can create calculated fields of your own
You can create
• simple calculated fields with simple mathematical calculations, such as Product Price *
Quantity = Total Cost
• complex calculations, which may combine existing columns with summaries, functions, and
value constants
The number and complexity of the calculated fields in your report may affect performance.
For information about performance issues, see "Optimize Performance in Impromptu" (p. 115).
For example, you are creating an invoice report that contains the order number, the product
names, and the quantity of each product ordered. You add some simple calculated fields:
• Total Sale Amount multiplies the product price by the quantity ordered.
• Total Profit subtracts the Product Cost column from the Total Sale Amount.

You also create a calculation called Profit Margin Ranges that uses a conditional expression and
a data item as follows:
if (Profit < 500) then ('Low') else if (Profit > 500 and Profit < 1000) then (‘Medium’)
else ( 'High’).

Create Calculated Fields
Use calculated fields to include information in your report that is based on a formula.
A calculated field can include any combination of the following:
• data from your report
• functions
• summaries
• values that you enter
• data from the catalog
• mathematical operations
Calculated fields are identified by their icon.
For information about summaries, see "Summaries" (p. 24).
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To create a calculated field, you build an expression using the available components in the
Calculation Definition dialog box.

Note: You can add calculated fields to the catalog for use in other reports or by other users of
the catalog.
For information about adding calculations to a catalog, see "Store Calculated Data Items and
Summaries in Catalogs" (p. 110).

Steps to Create a Calculated Field
1. Do one of the following to access the Calculation Definition dialog box:
Do this

If

From the Insert menu, click
Calculation, then click the
mouse pointer in the report
where you want to insert the
calculated field.

You ran the report and you know
where you want to place the
calculated field in the report

From the Report menu, click You do not know where you want
Query, click the Data tab, and to place the calculated field in the
click the Calculate button.
report, or you just want to add the
calculated field to the query
Click the Data tab and click
the Calculate button.

You are in the Query dialog box

2. Type a name for the new calculation in the Name box (Calculation Definition dialog box).
3. From the Available Components box, double-click the components to add them to the
Expression box and build your calculation.
4. Click OK to return to the Query dialog box.
Note: The types of components that appear at any given time in the Available Components box
depend on the previous selection.

Steps to Insert a Predefined Calculated Field from a Catalog
1. Open a report or template.
2. From the Report menu, click Query, and click the Data tab.
3. In the Catalog box, select the calculated field you want to use.
4. Click the Add button to add the calculated field to the Query Data box, and click OK.

What You Can Do Using Calculations
You can use calculations to compare or combine values, or to summarize information.
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The following examples begin with creating a calculation. For detailed steps, see (p. 33).

Calculating the Interval Between Two Dates
You can calculate the interval between two dates by subtracting one date from the other. For
example, you calculate the number of days between the closed date and the order date in order
to track the average number of days it takes to close a sale.

Steps
1. Do one of the following to add the first date to the expression:
Double-click

If

Report Columns, and
double-click a date.

You want to use a date from
your report

Catalog Columns, double-click
the date from the Catalog
Folders box, and click OK.

You want to use a date that is
not in your report

2. From the Available Components box, double-click "-".
3. Do one of the following to add the second date to the expression:
Double-click

If

Report Columns, and then
double-click the a date.

The date is in your report

Catalog Columns, double-click The date is not in your report
a date from the Catalog Folders
box, and click OK.
The expression looks something like this:
Closed Date - Order Date

4. Click OK to close the Calculation Definition dialog box and if necessary, click OK to close
the Data tab (Query dialog box).

Find the Rank and Percentile of Calculated Fields
You can calculate the rank and percentile of calculated fields in order. For example, you find the
rank and percentile of branches based on their total sales. You then sort the report on the rank
column to see the branches with the best sales performance.
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Steps
1. Double-click Summaries and double-click Rank.
2. Double-click Report Columns and select the calculated field you want to rank.
For example: rank (Total Sale Amount)
Note:=If you’re ranking a summarized data item, you must do the summarization before you
rank the data item. For information about summaries, see "Summaries" (p. 24).
3. Click OK.
4. In the Data tab (Query dialog box), click Calculate.
5. In the Name box (Calculation Definition dialog box), type a name for the new calculated
field.
6. Double-click Summaries and double-click Percentile.
7. Double-click Report Columns and select the calculated field.
For example: percentile (Total Sales)
8. Change the data format of the percentile column if necessary:
•

Select the column and click the right mouse button.

•

Click Format and specify the required format.

•

Click OK

9. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Tip
•

You can perform these operations directly in your report by selecting the column and clicking
the appropriate button on the toolbar. If the required button is not on the toolbar, you can
customize the toolbar.
For information about customizing toolbars, see (p. 125).

Find the Average of Totals for Groups
You can calculate a summary on a summarized data item. For example, you find the total
quantity of sales per product as well as the average total quantity of sales per product type. The
average total quantity of sales per product type is an example of a summary within a summary.
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Steps
1. Double-click Summaries and double-click Average.
2. Double-click Summaries and double-click Total.
3. In the Available Components box, add the required data item from the Report Columns or
Catalog Columns folder.
4. Delete the text <numeric column or calculation>.
The calculated field looks like this:
average (total(Qty))

5. Position the pointer outside the parenthesis and double-click "for" (Available Components
box).
6. Double-click "report" (Available Components box).
The calculated field looks something like this:
average (total(Qty)) for product type

7. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Extract Years, Months, or Days from a Date
When you want to display only the year, month or day portion of a date, you can extract the
information you need. For example, this function shows only the month portion of order dates
month (order date)

Steps
1. In the report, select the date column from which you want to extract the years, months,
and/or days.
2. Right-click and then click Data Definition.
The Data Definition dialog box appears with the selected column in the Expression box.
3. In the Expression box, click the column to highlight it.
4. In the Available Components box, double click Functions, and select one of the following:
•

Day to show the day portion of a date

•

Month to show the month portion of a date

•

Year to show the year portion of a date

5. Click OK to close the Data Definition dialog box.

Extract Years, Months, or Days from an Interval
In order to make information easier to interpret, you can round the year, month or day portion of
an interval. For example, you can convert a shipping time of 62 days into 2 months using this
function:
month-of-ymd-interval(ymdint-between(Date Shipped, Date Received))

Steps
1. In the Available Components box, double click Functions, and select one of the following:
•

Day-of-ymd-interval to show the day portion of the interval

•

Month-of-ymd-interval to show the month portion of a date

• Year-of-ymd-interval to show the year portion of a date
Note:=The ymd interval expression only shows the interval in date-time format.
2. To change the interval from a date-time format into the year/month/date format, double-click
Functions, and then double-click ymdint-between.
3. In the Available Components box, replace the first date with the required date item from the
Report Columns or Catalog Columns folder.
4. In the Available Components box, replace the second date with the required date item from
the Report Columns or Catalog Columns folder.
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5. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Find the Average Interval Between Two Dates
You can calculate the average interval between two dates by subtracting one date from the other
and applying the average summary. To make the information easier to interpret, you can use the
year, month or day function. For example, you can calculate the average time it takes to collect
payments on invoices using the following function:
average (day (InvSent - Payment))

Steps
1. In the Available Components box, double-click Summaries and double-click Average.
2. In the Available Components box, double click Functions, and select one of the following:
•

Day to show the day portion of a date

•

Month to show the month portion of a date

•

Year to show the year portion of a date

3. Position the pointer after the first date.
4. In the Available Components box, double-click "-".
5. In the Available Components box, add the required data item from the Report Columns or
Catalog Columns folder.
6. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Create a Date from a Number
You can create a date from a number. For example, you calculate a date by combining numbers
signifying year, month, and date in order to determine the number of outstanding orders to your
year end. You calculate the number of days from the order date until year end, which is your
anticipated final billing date for all outstanding invoices.

Steps
1. Double-click Functions and double-click Make-datetime.
2. Double-click Number and type the year into the expression.
3. Select <integer_exp2>, double-click Number in the Components box, and type the month
into the expression.
4. Select <integer_exp3>, double-click Number in the Components box, and type the day into
the expression.
5. Position the pointer outside the parenthesis.
6. In the Available Components box, double-click "-".
7. Double-click Report Columns and double-click Order Date.
The expression now looks something like this:
make-datetime (1995,12,31) - Order Date

8. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Use the Current Date in a Calculation
You can use the current date in calculations. You can capture the current date to use in
calculations from either
• the database (Now function)
• your computer (Today function).
For example, you calculate the number of days between the due date for current invoices and
today’s date in order to determine how many days payment is overdue.
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Steps
1. Double-click Functions and double-click Now or Today.
2. In the Available Components box, double-click "-".
3. Double-click Report Columns and double-click the required column.
The expression looks something like this
now ( ) - Closed Date

4. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Find the Number of Days to the End of the Month
You can determine the number of days left in a specific time period. For example, to establish
how many days remain in the current sales period, you calculate the number of days remaining
to the end of the current month.

Steps
1. Double-click Functions and double-click Last-of-month.
2. Select <date_exp> and double-click Value in the Available Components box.
3. Double-click Date, and overwrite the default date with the date representing the end of the
current month.
4. In the Available Components box, double-click "-".
5. Double-click Functions and double-click Now.
The expression now looks something like this
last-of-month (1998-12-01) - now ( )

6. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Combine Data Items
You can combine two data items into a single data item. This procedure is called concatenation.
For example, to create a report that lists both the current address and the mailing address for
each customer, you combine two strings, CurrentAddress1 with MailingAddress2, into a single
string called All Addresses.

Steps
1. In the Available Components box, add the first required string from the Report Columns or
Catalog Columns folder.
2. From the Available Components box, double-click "+".
3. In the Available Components box, add the next required string from the Report Columns or
Catalog Columns folder.
4. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Note
•
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When Impromptu performs string concatenation locally, the result of the operation is an
empty cell (or ‘null value’) if any of the strings involved contain null values. This occurs
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Many databases ignore any null string when performing concatenation. For example, if you
are concatenating string A, string B, and string C, and string B is a null value, the database
may concatenate only string A and string C.
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Create a Character Data Item from a Number Using If/Then/Else Statement
You can create a character data item from a numeric value using an If/Then/Else statement. For
example, you convert a coded number into the days of the week or into the applicable
department name.
1. From the Available Components box, double-click If.
2. In the Available Components box, add the first required data item from the Report Columns
or Catalog Columns folder.
3. In the Available Components box, double-click "=".
4. Double-click Number.
5. Type the applicable number value into the Expression box and press Enter.
6. In the Available Components box, double-click ")".
7. Double-click Value and double-click String.
8. Type the applicable string into the Expression box and press Enter.
9. In the Available Components box, double-click ")".
The expression now looks something like this
if (Dept = 02) then (‘Marketing’) else

10. Double-click NULL.
11. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Use a Predefined Filter Condition with an If/Then Statement
You can use an if/then statement to set a specific criterion for filtering. For example, you create a
calculation to convert prices to Canadian currency without changing the original American
prices:
if Country=Canada then price *1.43 else price

"Country=Canada" is a filter condition, because the action (multiply price by 1.43) is only
performed if the country is Canada.

Steps
1. In the Available Components box, double-click Catalog Columns.
2. In the Catalog Folders box, select a condition.
Conditions have this icon
3. Build the rest of the expression and click OK.

Create a Character Data Item from a Number Using Lookup
You can create a character data item from a number when you need to make report information
more meaningful. For example, you need to indicate gender type on the personnel forms used
within your company. Gender types are coded as: 1 (female), 2 (male), and 3 (unknown). You
convert the gender code to the appropriate gender type using the following calculation:
lookup (Gender Code) in (‘1’ --> ‘female’, ‘2’ --> ‘male’) default (‘unknown’ )

Steps
1. From the Available Components box, double-click Lookup.
2. In the Available Components box, add the required data item from the Report Columns or
Catalog Columns folder.
3. In the Available Components box, double-click ")".
4. Double-click Number.
5. Type a number to overwrite the default 0 value and press Enter.
6. From the Available Components box, double-click -->.
7. Double-click Value and double-click String.
8. Type a string between the quotation marks and press Enter.
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9. In the Available Components box, double-click ")".
Impromptu adds ‘default’ to the end of your expression.
10. Double-click NULL.
The expression now looks something like this
lookup (Line No) in (4 ->‘Naturals’)default NULL

11. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Create a Character Data Item from a Number Using Number-to-String
You can convert a number to a character data item. For example, you convert a telephone
number into a string.

Steps
1. From the Available Components box, double-click Functions and double-click
Number-to-string.
2. In the Available Components box, add the required data item from the Report Columns or
Catalog Columns folder.
The expression now looks something like this
number-to-string (Phone Number)

3. Click OK to close the Calculation Definition dialog box and click OK to close the Data tab
(Query dialog box).

Highlight Data
You can format your report to highlight interesting data:
• Define conditions for formatting that is unique to your report.
• Create styles that you can use to format data.
• Assign a style to a condition.
• Apply a conditional format.
• Enhance the appearance of your report with 3-dimensional formatting techniques.
• Use predefined conditions from the catalog.
• Change the order of conditions.
• Conditionally show and hide headers, footers and rows.

Create Styles
A style is a defined set of formatting characteristics that you can apply to report objects such as
font, size, color, borders, patterns, and data formatting.
For example, you want to set up a style that formats numeric values with a dollar sign and two
decimal places. You want the column titles to be Arial font, size 14, bold, and have a pattern.
Your report now looks like this.

40 Impromptu ( R )

Chapter 1: Report Data
Once you create a style, you can apply it to objects in any of your reports. Styles are not saved
with a report but are saved in the Impromptu.ini file.

Tip
•

To distribute a report containing custom styles, send users the Impromptu.ini file along with
the report. For users to see the custom styles, they must replace the Impromptu.ini file on
their computer with the Impromptu.ini file sent with the report.

Steps
1. From the Format menu, click Styles.
2. In the Styles dialog box, click Add to add a new style.
3. In the Style Definition dialog box, type a new name in the Style Name box.
4. Select the style features you want to set up: Data, Font, Borders, Patterns.
Note: The tabs for Data, Font, Borders, and Patterns are only available if you select the
corresponding check box on the Content tab.
5. When you finish selecting the formats in the tabs, click OK.
6. To apply this style to selected report objects, click Apply. Otherwise, click Close.
You can apply one or more styles to a report object. For information about applying styles, see
the Impromptu online Help. In the Index tab, type
• styles

Applying 3-Dimensional Formatting Techniques
You can combine patterns and borders for report objects to give a three-dimensional
appearance. For example, in the following report
• the frame appears raised because its borders are dark on the right and bottom, and light on
the left and top, and it is filled with a light color
• the text frames appear recessed because their borders are light on the right and bottom,
and dark border on the left and top, and they are filled with a dark color

Steps to Make an Object Appear Raised
1. Select the object you want to format.
2. Right-click and click Format.
3. Click the Patterns tab.
4. In the Pattern box, select the solid pattern.
5. Under Foreground or Background, click Customize, and then, in the Color dialog box, select
a light color.
6. Click the Borders tab.
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7. In the Border box, click the right line in the border.

8. In the Line box, select a style, such as a thick line, and then click Customize.
9. In the Color dialog box, select a dark color, such as gray or black, and click OK.
10. Click the lower line in the Border box and select the same style and color.
11. Click the left line in the Border box and select a thin style and a light color in the Line box.
Repeat the steps for the top line in the Border box.
12. Click OK.

Steps to Make an Object Appear Recessed
1. Click Customize for either the Foreground or the Background box.
2. In the Color dialog box, select a color and click OK.
3. Click the Borders tab.
4. In the Border box, click the right line in the border.
5. In the Line box, select a style, such as a thin line, and then click Customize.
6. In the Color dialog box, select a light color, such as white, and click OK.
7. Click the lower line in the Border box and select the same style and color.
8. Click the left line in the Border box and select a thick style and a dark color, such as gray or
black, in the Line box. Repeat these steps for the top line in the Border box.
9. Click OK.

Conditionally Format Data
You can use conditional formatting to identify exceptional data in your report. You can use
predefined conditions or create your own conditions.
Once you have a condition, you need to assign a style to the condition. Impromptu then formats
selected report objects that meet the condition’s criteria.

For Example
You want to identify sales representatives who have not met their quota. You create a condition
that checks whether each representative’s sales for the year is less than their quota for the year:
Sales 95 < Quota 95.
If the representative’s sales are less than the representative’s quota, you want the
representative’s name automatically bolded and highlighted with a border.
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Create a Condition
You can create and apply a style to data that meets certain conditions.

Steps
1. Select one or more report objects that you want to format conditionally.
2. From the Format menu, click Conditional Formats.
3. Click Conditions.
4. In the Conditions dialog box, click Add Custom Condition to show the Condition Definition
dialog box.
5. In the Name box, type a name for the condition.
6. Use the options in the Available Components box to build an expression.
7. Click OK to close the Condition Definition dialog box.
8. Click Close to close the Conditions dialog box.
The custom condition appears in the Condition box. The None standard style is assigned to
the condition by default.
9. In the Change Style To box, select the style you want for this condition.
Note: If the style you want does not exist, you can create it.
For information about creating styles, see (p. 40).
10. Click OK.

Change a Condition
You can modify existing conditions in your reports. If you do not have the appropriate privileges
to change a predefined condition, you can make a copy and modify the copy.

Steps
1. Select one or more report objects.
2. From the Format menu, click Conditional Formats.
3. Click Conditions.
4. In the Conditions dialog box, do one of the following:
•

To create and modify a copy of a catalog condition, click Add Catalog Condition, select
a condition, and then click OK.

•

To modify a condition in the report, select the required condition.

5. Click Edit in the Conditions dialog box.
The Condition Definition dialog box appears.
6. If you are creating a new condition, type a name for the new condition. Then define the
condition and click OK.

Assign a Style to a Condition
You can assign a style to a catalog condition or to a custom condition. When you apply the
condition, any data that meets the condition is automatically formatted with the style you
assigned so that the results stand out. For example, you assign a style to a condition called
"Low Margin". It formats low sales with a large green font. You also assign a style to a condition
called "High Margin" to format high sales with a large red font.

Steps
1. Select one or more report objects.
2. From the Format menu, click Conditional Formats.
3. Select the condition to which you want to assign a style.
4. In the Change Style To box, select the style, and click OK.
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Tips
•

•

To remove a style from a condition, select the condition you want to remove. In the Change
Style To box, select the None style and click OK.
Impromptu applies the None style to the selected report objects.
To remove all styles assigned to conditions, click Clear (Conditional Formats dialog box) and
click OK. The None style appears in the Style box beside the conditions.

Applying a Conditional Format
You can apply a conditional format to one or more report objects after you create a condition
and assign a style to it. For example, you want to highlight high sales for the month of
December. You select the Sale Amount column in the report, and create the condition: Sale
Amount > 500. You then assign a style to this condition that makes all Sale Amounts greater
than 500 display in a red font.

Step
•

Select one or more report objects and then select the condition to apply from the Condition
dialog box (Format menu, Conditional formats).

Change the Order of Conditions
When more than one conditional format is applied to a report object, the formatting assigned to
the first condition in the list takes precedence over the formats assigned to subsequent
conditions in the list.
The order of your conditions can be important, especially if you have conditions with similar
expressions. For example, the Qty data item in your report has two conditions:
• "Greater than Two" has the style Blue Font
• "Greater Than Three" has the style Red Font
If "Greater than Two" is at the top of the Conditions box, then all the Qty data is formatted with
the style "Blue Font" because "Greater than Two" takes precedence.
You change the order of the conditions so that "Greater than Three" becomes the top condition
in the list. The effect of the change is that all quantities that are greater than three are formatted
with the style "Red Font", and all the quantities that are greater than two are formatted with the
style "Blue Font."

Step
•

Move the required conditions in the Condition dialog box (Format menu, Conditional
Formats).

Conditionally Hide and Show Report Objects
For reports that include sensitive or irrelevant data, you can hide report objects and show them
when you want. This is useful when you distribute printed reports. However, when you distribute
reports electronically, the users can show any objects you’ve hidden. Therefore, do not
electronically distribute sensitive information as hidden.
For information about hiding, showing, and unhiding report objects, see the Impromptu online
Help. In the Index tab, type
• hiding, part of a report
• showing, part of a report
You can define conditional formats that automatically hide headers, footers, or entire rows.

For Example
You have a grouped report that contains details and a summary for each group. For some
groups with only one row of details, the summary in the group footer is the same value as the
value in the detail row. You set up conditional formatting that hides the group footer if there is
only one row in a group.
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The Total Sale Amount and the total in the group footer are the same when there is only one
order number for a customer, so you conditionally hide the group footer when there is only one
row in the group. The expression for this condition is
(count (Order No.) for Customer No.)=1

The row and
group footer
display the same
totals.

The conditionally
hiding the group
footer eliminates
the repetition.

Steps
1. Select the header, footer, or any rows that you want to hide based on a condition.
2. Right-click and click Conditional Formats.
3. In the Conditional Formats dialog box, click Conditions.
4. Do one of the following:
Do This

If

Click the condition and click Close The condition you want to
apply to the selection is in
the Conditions box
Add Catalog Condition.
Click the predefined condition,
click OK, and Click Close

The condition you want to
apply to the selection exists
in the catalog

In the Change Style To box, click
the Hidden style, and click OK
Add Custom Condition
Create the expression, click OK,
and click Close

The condition you want to
apply to the selection does
not exist

In the Change Style To box, click
the Hidden style, and click OK.
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This chapter discusses some of the advanced formatting techniques you can use to
• make your reports more readable
• highlight important findings

Formatting Techniques
There are several ways to add formatting to your reports to enhance their readability and their
general appearance. You can
• customize data and object formats
• apply templates
• add frames to your reports

Customize Data and Objects
The default format applied to report data is based on the format the data has in the database
and your locale settings. For more information about locale settings, see the Administrator’s
Guide.
You can also customize the data formats for your reports.
Use This

To Set

Data type

A data type to format.

Positive

A format to apply to positive numbers.

Negative

A format to apply to negative numbers and
intervals.

Zero

A format to apply to numbers and intervals
that are zero.

Missing

A format to apply to numbers, characters,
dates, times, date-times, and intervals that are
missing.

Currency Symbol

An explicit currency symbol for numeric values
that persist with the data or set the currency
symbol to default to the user’s locale setting.
For information about modifying locale
settings, see the Configuration Manager
documentation.
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You can:
• set a default format for numeric values. For example, use the format "0,000", to show the
data "1234.56" as "1,235."
• set a default currency format for numeric values. For example, use the symbol, £, to show
numeric values as £250,00 or 250.00£. Or, set the currency symbol to default to the user’s
the locale using the Default option in the Currency Symbol list.
• set a default format for character values. For example, use the format ""Today is" DDDD,
MMMM, D" to show the date as "Today is Wednesday, January 1."
• set a default format for date values. For example, use the format "D.MMM.YY DDDD" to
show the date as "15.Jan.98 Wednesday."
• set a default format for time values. For example, use the format "HH.MM.SS am/pm" to
show the time as "01.23.45 PM."
• set a default format for date-time values. For example, use the format "DDD, HH:MM
am/pm" to show the date as "Wednesday, 11:30 am."
• set a default format for interval values. For example, use the format "DD "Days" HH:MM:SS"
to show the date as "123 Days 04:30:28."

Default Object Formats
To customize objects in your report, you can
• set a default font so that text in a text frame is always formatted the same way.
• set a default border for report objects. By default, all objects (except text frames) have a
border. You can set a different border, or have no border by default.
• set a default pattern for report objects. You cannot add a pattern to chart frames, OLE
objects, or picture frames.
Use This

To Set

Object types

The object type to use as the default format

Font

The type, style, size, effects, and color of the
font

Borders

The location, line style and color or a border

Patterns

The pattern, foreground, and background
colors

Define Report Layouts with Templates
A template is a pattern you can use to build reports. It is like a report without any actual data.
Using templates to create new reports can save time and effort, particularly when you or other
template users frequently need the same type of report.
A template can contain any or all of the following report objects:
• formatting
• placeholders
• text
• pictures
• frames
• macros
• report variables, such as the date or time that the report was created
• calculations
• summaries
• OLE (Object Linking and Embedding) objects
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You cannot include the following items in a template:
• sub-reports
• calculated data items that are stored in the catalog
• filter conditions that are stored in the catalog
• any prompts (picklist or type-in), whether or not they are stored in the catalog
Templates can
• increase productivity for the users because the design work is already done
• facilitate standardized reporting by applying pre-defined formatting
• enable users to create sophisticated reports that might otherwise be beyond their skill level
For information about using templates to create reports, see the Impromptu online Help. In the
Index tab, type
• creating, reports with templates

What are Placeholders?
Templates use placeholders to represent the data items that should appear in the report. For
example, a mailing labels template can contain placeholders for name and address. This helps
those who use a template to understand how to complete the report.
You can group and sort placeholders in a template, just like data items in a report.
Placeholders are data independent and allow you to assign a specific data type to each
placeholder. As a result, they are useful when you use one template to create different reports
based on data from different catalogs.
Placeholders can accept data items of any data type or of a particular data type. Placeholders
can be defined as
• no specific type
• numeric
• character
• date
• time
• date-time
• interval
• text-blob
• required (they must be filled), or optional
• accepting only one data item, or accepting one or more data items
You can also define a placeholder so that it does not appear in a report but remains in the query.

Required
placeholder

For information about adding placeholders to a template, see (p. 53).
For information about filling placeholders in templates, see the Impromptu online Help. In the
Index tab, type
• templates, creating reports with
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Set a Default Template
You can select the template that you use most often and click the Set as Default button (New
dialog box). Then when you click the New toolbar button or create a new report using the Report
Wizard, this template automatically appears.

Customize the Template’s Preview Image
In the Open dialog box, by default, Impromptu generates a preview image based on what the
selected template looks like. You can customize the preview image, to more easily distinguish
templates.

For Example
Each preview image includes an icon that shows the data source, such as a database or a
snapshot.
The following preview image shows a list style report that uses a snapshot (as indicated by the
snapshot icon in the lower right corner) as its data source:

data source

The following preview image shows a list style report that uses a database (as indicated by the
database icon in the lower right corner) as its data source:

data source

You can customize the preview image so it shows a different image, such as the report title:

Steps
1. Open the template (or report) for which you want to customize the preview image.
2. From the Report menu, click Preview.
3. Clear the Automatic Image Generation check box.
4. Do one of the following:
Do this

To

In the Preview tab, click Copy
and click OK. Paste the image
into a graphics application and
edit it.

Modify the existing preview
image

In a graphics application, create Create a new preview image
a new image.
5. Select and copy the new image to the Clipboard (Ctrl+C).
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6. In Impromptu (Report Properties dialog box), click Paste, and click OK.
Save the report and close it.
Impromptu now uses the new preview image for this report in the Open dialog box.

Notes
•
•

You can use a graphics program to customize a preview image. You can either alter the
default image or create a new image.
You can follow the same steps to customize a report’s preview image.

Set the View for Templates
You can specify the default view for a template (page layout or screen layout).
Use screen layout for screen-only reports. The advantages of the screen layout view are that
you can move a column from one page to the next if your report is too wide to fit on one page
(which cannot be done in page layout view) and that there are no margins to reduce the visibility
of the report.
Use page layout view for reports that are destined for the printer.

Create Effective Templates
You can create a template for
• a list report
• a chart report
• forms, such as form letters and mailing labels
• a crosstab report
A crosstab template contains placeholders for the rows, columns, and cells. When you fill in the
placeholders, Impromptu groups the data items in the rows and columns, and summarizes the
data items in the cells. You can create a nested crosstab report by allowing each placeholder to
accept more than one data item.
For a step-by-step tutorial on creating a nested crosstab, see Discovering Impromptu.
Template file names end with the extension .imt rather than the .imr extension that Impromptu
uses for reports. Impromptu automatically adds the .imt extension when you create and name a
template.
There are different ways to create a template. You can
• create a template from scratch
• save a report as a template

Create a New Template
When you create a new template, you begin with an existing template or the Blank template. You
can then add placeholders, frames, objects, and formatting. If the template upon which you base
the new template contains placeholders, objects, or formatting, you can edit or delete them as
necessary.

Steps
1. From the File menu, click New.
2. Click the Template option button in the Create New box.
3. Select a template, and then click OK. If the template you select contains placeholders, they
appear on the screen.
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4. Customize your template.
•

Add, calculate, edit, remove, or insert placeholders. For information about creating
placeholders, see (p. 53).

•

Add frames, format frames, or remove frames in a template. For information about
frames, see "Create Complex Layouts with Frames" (p. 57).

•

Format the template.

•

Set the layout of the template.

5. From the File menu, click Save to save the template with the same name, or click Save As to
save the template with a different name.

Tip
•

To save time when you create a template, begin by selecting an existing template that
closely resembles the template you want to create. For example, to create a mailing labels
template, you can start with an existing mailing labels template and modify it to meet your
needs. This is faster than starting with the Blank template.

Save Reports as Templates
As well as creating a template from scratch, you can turn any report into a template. All the data
items in the report automatically become placeholders and the template has the same
formatting, grouping, sorting, and filtering that the report had.

Steps to Save Reports as Templates
1. Open a report.
2. From the File menu, click Save As.
The File Name box shows a default file name.
3. If you do not want to use the default file name, type a new name in the File Name box.
4. Select Templates (*.imt) from the Save as Type box, and click Save.
You can edit a list template (.imt) and change it into a crosstab template. This can save you time
if you already have a template that contains all or most of the placeholders and formatting you
require.
When you create a crosstab template, you can specify the placeholder locations on the
Template tab by selecting each placeholder and clicking the Rows, Columns, or Cells button.

Steps to Change a List into a Crosstab Template
1. From the File menu, click Open.
2. In the Files of Type box (Open dialog box), select Templates (*.imt).
3. Select the list template you want to change and click Open.
4. From the Report menu, click Query.
5. Click the Crosstab Template button.
Note: All the placeholders from the list template appear in the crosstab rows, columns and
cells.
6. The following steps are optional:
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Do this

To

Ensure that the Summaries
check box is selected for the
columns

Include column summaries

Ensure that the Summaries
check box is selected for rows

Include row summaries
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Do this

To

Click Placeholder in the Select
a Type box and move it into the
row, column or cells box

Create a new placeholder

Click Calculation in the Select a Create a calculated
Type box and move it into the
placeholder.
row, column or cells box
For information about creating
calculated placeholders, see
(p. 56).
7. Click OK.

Notes
•
•
•
•

You cannot use either multi-column or optional placeholders in filters.
You can only use one multi-column placeholder in calculations.
You can drag and drop a placeholder from the Select a Type box to the Rows, Columns, or
Cells box.
You must have at least one required placeholder in the Columns box and the Cells box.
All required placeholders appear in bold. To check the properties of a placeholder, select it
and click Edit. Ensure that the Optional Placeholder check box (Placeholder Definition
dialog box) is cleared for all required placeholders.

Create Placeholders
Placeholders are markers in a template that tell users what data items they should add to the
report.
A placeholder can show which data item the user should fill it with. It can also perform a
calculation using the data item the user fills it with, and show the result in the report.
You can set up a placeholder to
• be optional or required
• accept only one data item, or one or more
The user can fill the placeholders in any order and skip optional placeholders altogether.
If you do not want the data item that a placeholder contains to appear in the final report
(because, for example, you need the item for a calculation, but it is otherwise irrelevant to the
report) you can choose not to generate the placeholder in the report.
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Steps
1. Open the template.
2. From the Report menu, click Query.
The following Template tab appears.

3. Click Add.
The Placeholder Definition dialog box appears.

4. Type a label in the Label box.
The label appears in the Query Data box (Data tab, Query dialog box) or the Rows,
Columns, or Cells boxes (Crosstab tab, Query dialog box).
The Label box is required when you create a filter or calculation that uses the placeholder.
5. Type the prompt text in the Prompt box.
When you create a report using this template, Impromptu shows the prompt in the Data tab
(Query dialog box) to indicate which data item should replace the placeholder.
The Prompt box is optional. If you leave it blank, Impromptu shows the text you entered in
the Label box.
6. Select a data type from the Data Type box.
Note: You cannot use placeholders with the No Specific Type data type in calculated data
items or filters.
7. Define the placeholder as required:

54 Impromptu ( R )

•

If you want the placeholder to be optional, select the Optional Placeholder check box.

•

If you want the placeholder to accept more than one data item, select the Can Be Filled
By More Than One Column check box.

•

If you don’t want the data item that the placeholder contains to be displayed in the report
nor added to the query, select the For Calculations Only check box.
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8. Click OK.
9. Repeat steps 3 to 9 to add more placeholders to your template.
10. Click OK.

Notes
•
•

You cannot use either multi-column or optional placeholders in filters.
You can only use one multi-column placeholder in calculations.

Placement of Multi-Column Placeholders and Associated Summaries
How Impromptu inserts multi-column placeholders depends on the type of frame.
If you insert a multi-column
placeholder into a
Impromptu
Text frame contained in a
form frame

Duplicates the text frame for each data
item contained in the placeholder. If
the form frame is scoped on a grouped
data item, then only the data item used
to scope the data will be inserted.

List frame

Inserts each data item contained in
the placeholder as a column to the
right of the original.

Group header or footer in a
list frame

Duplicates the header or footer and all
formatting associated with it for each
data item contained in the placeholder.
Note: If the placeholder is aligned with
a list column, all the inserted columns
will have the same alignment.

Chart frame

Displays each column contained in the
placeholder.
Note: Data items that cannot be
displayed in a chart are not added to
the chart data.

Picture frame

Duplicates the picture frame for each
data item contained in the placeholder.

When you insert a multi-column placeholder and its associated summary into a report, a
summary is created for each data item contained in the placeholder. Each summary is aligned
with its respective data item.

Modifying Existing Placeholders
You can change a placeholder in a template. For example, you change the prompt text that
appears in the Data tab (Query dialog box) by changing the prompt you specified for the
placeholder.

Steps
1. From the Report menu, click Query, and click the Template tab.
2. Select the placeholder you want to change, and click Edit.
3. Make the changes you want in the Placeholder Definition dialog box, and click OK.
For information about the Placeholder Definition dialog box, see (p. 53).
4. Click OK.

Mastering Impromptu Reports 55

Chapter 2: Report Formats

Create Calculated Placeholders
Calculated placeholders enable you to include standardized calculations in your reports. You
can create placeholders for numeric data and complete a calculation using these values. The
results appear in the report. The template user cannot fill in calculated placeholders with data
items.
For example, a Margin by Product report contains the following placeholders:
• product
• cost
• price
• margin, which is the calculation: "price - cost"
• % margin, which is the calculation: "((price - cost) / price)
When report creators use this template, they only have to replace the following placeholders
with data items:
• product
• cost
• price
Impromptu automatically adds the margin and % margin calculations to the query.

Steps
1. Open a template.
2. From the Report menu, click Query.
3. In the Template tab, click Calculate to show the Calculation Definition dialog box.
4. Type a name for the calculated placeholder in the Name box.
5. Build a calculation expression.
6. Click OK to close the Calculation Definition dialog box.
7. Click OK to close the Query dialog box.

Notes
•
•

You cannot use placeholders of the No Specific Type data type in calculations.
Calculations can only reference one multi-column placeholder (a placeholder with the Can
Be Filled By More Than One Column check box selected in the Placeholder Definition
dialog box).
For information about building calculated data items, see "Create Calculated Fields" (p. 32).

Insert Placeholders
Once you create a placeholder, you can insert it on the report where you want the real data to
appear.

Steps
1. From the Insert menu, click Data.
Your pointer changes.
2. On the template, position the pointer where you want the upper-left corner of the
placeholder.
3. Click and drag the mouse diagonally until the placeholder is the size you want. Release the
mouse button to show the Template tab (Query dialog box).
4. Click the placeholder.
A placeholder is identified by a placeholder icon.
5. Click Mark for Insertion.
A placeholder that is marked for insertion is identified by an insertion icon.
6. Click OK.
Impromptu shows the placeholder in the location you specified.
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Note: By default, the label in the Label box appears as the column header in list reports. The
prompt in the Prompt box appears in the template's Query Data box.

Link Column Titles to the Name of Query Data Items
When you create a placeholder, the name you give that placeholder appears in the report
column title. You can also set up the placeholder so the name of the query data item appears in
the report column title.
For example, you create placeholders called Name and Description. Each user of this template
fills the placeholders with different data items. For example, if a user fills the Name placeholder
with Customer Name, and the Description placeholder with Customer Note, the report column
titles are Customer Name and Customer Note.
When you link the column title to the name of the data items, the column title is automatically
updated if the name of the data changes. When you enter a name for the column, the title
remains the same until you change it.

Steps
1. Select the column title.
2. From the Format menu, click Properties.
3. Click the Column Title tab.
4. Select the Link the Column Title Text to the Name of the Query Data Item check box.
5. Click OK.

Create Complex Layouts with Frames
Frames are containers for report objects such as data, text, pictures, and charts. You can use
frames in your reports to organize complex data into a more readable form.
You can use the following types of frames to create reports:
This type of
frame
Contains

For more
information

List frame

Data items and other report objects in a See (p. 62)
tabular row and column format.

Form frame

Other report objects, including other
See (p. 63)
frames. You can create a form frame
report or insert a form frame in another
frame.

Chart frame

A visual representation of data such as See (p. 66)
a pie chart.

Text frame

Data items or text that you enter. You
can edit the text that you enter into a
text frame but you cannot edit a text
frame that contains a data item.

Picture
frame

See (p. 69)
A static graphic (such as a company
logo that doesn’t change) or a dynamic
graphic (such as a unique product
photo for each product number).

See (p. 67)
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This type of
frame
Contains
Object
Linking and
Embedding
(OLE) frame

For more
information

See (p. 89)
An object such as data, pictures,
charts, and so on from an
OLE-compliant application. If the OLE
frame is linked to the source application
then the information in the frame
automatically reflects changes made in
the source application.
Impromptu treats an OLE object as a
default frame.

Sub-report
frame

The results of several reports combined See (p. 79)
into one report.

The Annual Product Sales report below includes several types of frames.
Form Frame
Text Frame
Picture Frame
List Frames
Chart Frame

Frame Properties
The properties of a frame determine the format, size, alignment of data within the frame,
location of the frame, and how much data is displayed in each frame. Refer to the table below for
a description of each frame property available in the Properties dialog box (Format menu).
Use the

To

Align tab

Set the vertical and horizontal position of the
frame.

Size tab

Set the vertical and horizontal size of the frame.

Layout tab

Set the scope of data in a form frame and
position the frame on the page.
Set the justification and the line control for a
text frame.
Add or remove headers and footers, set page
breaks, control page numbering, and show or
hide scroll bars for a list frame.
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Use the
Printing tab

To
Hide frames on the printed page.
You can also use the Printing tab to see which
columns in a list frame are repeated on every
printed page.

Data tab

Determine which data is displayed and how it is
displayed.

Format tab

Select a chart style and format the appearance
of a chart.

Source tab

Select a source for a picture frame, or load
picture files using file names from your
database.

Crosstab tab

Sort crosstab rows and columns in the order
specified in the Query dialog box.

The Parent/Child Relationship
When you insert frames into a report or into other frames, Impromptu keeps track of which
frames belong to which frame. A frame that contains another frame is the parent frame. The
child frame only uses the data available to the parent frame. You can use this relationship to
control the data that is available to subordinate frames and report objects.
For example, you create a chart frame, picture frame and a list frame that are contained within a
form frame. The form frame is the parent and the chart, picture and list frames are each child
frames.

Parent Frame

Child Frames

This is useful for building reports like invoices or orders where data in one section of the report
depends on the values in other sections of the report.

Designate a Primary Frame
Impromptu automatically inserts data into the primary frame if no other frame is selected. By
default, the first form frame, list frame, or text frame that you insert into a report is designated as
the primary frame. When you work with templates the primary frame is the default container for
any placeholders.
For information about templates, see (p. 48).
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If you set a report to have no primary frame, Impromptu disassociates the report from the
database query. That is, when you create a query, Impromptu does not automatically insert the
data items in the query into your report. Instead, you must select the frame into which you want
to insert data items. This can be useful when you want total control over where data is placed
when you insert it into the report from the query, or when you do not know which frame should
contain the data.
A list frame should be the primary frame for a crosstab report.

Steps
1. From the Report menu, click General.
2. In the Primary Frame box on the General tab (Report Properties dialog box), select a frame
as the primary frame and click OK.
To set a report to have no primary frame, select (none) in the Primary Frame box.

Insert a Frame
Inserting one or more frames is the first step to create a template or new report.

Where Impromptu Inserts the Data in Frames
The following table describes how Impromptu inserts data items into frames:
If you insert
data into a

Impromptu adds the data

Form frame

At the position where you clicked the mouse button.

List frame

At the highlighted position.
• If the space between two adjacent columns is
highlighted then Impromptu adds the data item
as a new column.
• If the group header or footer is highlighted, then
Impromptu adds the data item to the group
header or footer.
• If you position the pointer over a page header or
footer, then Impromptu adds the data item to
that page header or footer.

Chart frame

Into the list of data items for the chart frame.
Note:=To add new data items, from the Format
menu, click Properties. In the Chart Data box (Query
tab), add the new data items.

Text frame

At the beginning of the text frame.

Tip
•

To identify a frame type, click Boundary Lines (View menu).

You can insert frames or report variables such as Date and Time, into
• form frames
• list frames
Not all frames can contain other frames. You cannot insert frames into
• chart frames
• picture frames
• text frames
Although you cannot insert frames and report objects into text frames, you can combine text
frames with one another.
For information, see "Combining Text Frames" (p. 68).
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Note: For information on modifying the different SQL queries that can appear in frames, see
"Edit Sub-Report Queries" (p. 81).

Steps
1. From the Insert menu, click a frame type.
2. On the report position the pointer where you want to locate the upper-left corner of the
frame.
Your pointer changes according to the frame type you selected.
3. While holding down the mouse button, drag the mouse diagonally until the frame is the size
you want, and then release the mouse button.
One of the following occurs:
Icon

Inserts

This happens

Form frame

An empty form frame appears.

List frame

An empty list frame appears.

Text frame

The flashing I-beam appears where
you can begin inserting text.

Picture frame The Source tab (Picture Properties
dialog box) appears. You can use this
tab to select the image (.bmp,.dib) to
include in the frame.
Chart frame

The Data tab (Chart Properties dialog
box) appears. You can use this tab to
select the data item to include in the
chart. For information about using this
tab, see (p. 66).

OLE Object

The Insert Object dialog box appears
where you can locate and select the
file you want to insert, or you can
create a new object using the software
listed in the Object Type box.

For information about creating a freestyle report, see chapter 9 in Discovering Impromptu.

Select a Frame
You may want to select a frame so that you can
• move or resize it
• add a border or pattern to it
• insert data items or placeholders
• change its basic properties (such as its name)
• change its stacking order within the current report
• control the vertical and horizontal alignment and position
• set printing characteristics that hide the frame on specific pages in a multi-page report
Note: Page header and footer frames are always hidden in Screen Layout view
• view the query for a sub-report
For information about sub-report queries, see (p. 81).
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Step to Select an Individual Frame
•

Click anywhere in the frame.
Handles appear indicating that the frame is selected.

Steps to Select Multiple Frames
1. Position the pointer on the frames you want to select. While holding down the left mouse
button, drag the mouse until all the frames you want to select are partially crossed by the
selection rectangle.
2. Release the mouse button.
All the report objects whose borders were touched by the selection rectangle are now
selected.

Step to Select All the Frames and Objects in a Report
•

From the Edit menu, click Select All.
Impromptu selects all of the frames and report objects.

Tips
•

To select a parent list frame or a form frame that is completely filled with subordinate report
objects, click anywhere within the parent object. Then click Select Parent (Edit menu), or
click the Select Parent button.

Assign Names to Frames
Reports and templates can contain a large number of frames and other report objects. At any
time, you can view the names of the frames in your current report.
When you insert new frames into a report, Impromptu assigns names based on the frame type
such as "List Frame," "Text Frame," and so on. For example, you insert the first chart frame into
a report and Impromptu assigns the name "Chart Frame." When you insert a second chart
frame Impromptu assigns the name "Chart Frame 1."
You can view the names of the frames in your current report at any time. You can also give each
frame in your report a more meaningful name.

Step to Show Frame Names for all Frames in a Report
•

From the View menu, click Boundary Lines.
Impromptu shows the frame name in the upper-left corner of each frame in your report.

Steps to Change the Name of a Frame
1. Select the frame whose name you want to change.
2. From the Format menu, click Properties.
3. In the Name box, enter a meaningful name for the frame and click OK.

List Frames
Using list frames, you can create many different types of reports. For example, you can use list
frames to create detailed reports such as Product Inventory or to create summary reports such
as Total Sales Per Product Line.
A list frame can
• make up the entire report. To see an example, open the "All Country Sales" sample.
• be inserted into other frames. To see an example, open the "Annual Product Sales" sample
report.
• be inserted as a sub-report.
For information about sub-report list frames, see "Link Sub-Reports" (p. 81).
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List frames can be resized, moved, and formatted. You can sort, filter, group, or perform
calculations on the data in a list frame. You can also
• specify custom formatting for all report objects in the list
• insert other frames (such as form frames, chart frames, text frames, or picture frames) and
report objects into a list frame
• link column titles in a list frame to the names of query data items
• perform summary operations on the columns in a list frame

Insert Data
You can insert data items into a list frame to present your report data in rows and columns.

Steps
1. From the Insert menu, click Data.
Your pointer changes.
2. Click the mouse button anywhere in the list frame.
The Data tab (Query dialog box) appears.
3. In the Query Data box, select the data items that you want to add to the list frame.
4. Click the Mark for Insertion button.
Data items marked for insertion are identified by an insertion icon.
5. Click OK.

Insert Report Objects
You can insert any type of report object into a list frame.

Step to Insert a Report Object in a List Frame
•

Drag and drop the existing report object onto the list frame.

Steps to Insert a New Report Object in a List Frame
1. From the Insert menu, click the report object that you want to add to the list frame.
The pointer changes depending on the type of report object you chose.
2. Within the boundaries of the parent list frame, but not over any existing cells, position the
pointer where you want the upper-left corner of the report object you are inserting.
3. Hold down the mouse button and drag the mouse diagonally within the boundaries of the
parent frame until the new report object is the size you want and release the mouse button.

Notes
•

•

If you want Impromptu to set the size of the new report object, click the mouse button where
you want the upper-left corner of the report object.
Impromptu inserts the new report object at the point where you click the mouse.
Avoid inserting a frame or report object into the detail area of a list frame because the frame
or report object is repeated for each row in the list.

Form Frames
Form frames are the basic building blocks for many common reports such as invoices, order
forms, checks, mailing labels, and packing slips. A form frame can also be inserted into a report
as a sub-report.
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With a form frame, you can
• insert any type of data item or report object, including placeholders and other frames (child
report objects)
• align child report objects with one another and with the boundaries of the form frame
• limit the scope of data
• logically group related data items such as customer address, product descriptions and
product codes
• repeat the form frame horizontally and vertically to show or print multiple copies of the form
frame
• format the form frame with borders and patterns
• hide form frames on specific pages of a report
For information about hiding frames on specific pages of a printed report, see "Conditionally
Hide and Show Report Objects" (p. 44).

Notes
•
•

The Blank template consists of one form frame called the Report Body.
Impromptu uses form frames for the headers and footers it automatically creates.

Insert Data
You can insert data into a form frame when you want to limit the scope of data, or logically group
related data.

Steps
1. From the Insert menu, click Data.
Your pointer changes.
2. Click the mouse button anywhere in the frame.
The Data tab (Query dialog box) appears.
3. In the Query Data box, select the data items that you want to add to the form frame.
4. Click the Mark for Insertion button.
Data items marked for insertion are identified by an insertion icon.
5. Click OK.
Note: By default, you see only the first data item in the form frame.

Tip
•

To make the form scrollable, set the scope of the form frame to Single Row of Data or Data
in a Group (Layout tab, Form Properties dialog box).
For information about setting the scope of a form frame, see (p. 65).

Insert Report Objects
You can insert any type of report object into a form frame. You can also use a form frame to
group existing report objects. To do this, drag and drop the selected report objects into the form
frame. Impromptu makes the existing form frame the parent frame of the selected report objects.

Step to Insert a Report Object into a Form Frame
•

Drag and drop the existing report object into the form frame.

Steps to Insert a New Frame into a Form Frame
1. From the Insert menu, click a frame type.
The pointer changes to reflect the type of frame or report object you chose.
2. Within the boundaries of the form frame, position the pointer where you want the upper-left
corner of the report object.
3. Hold down the mouse button, and drag the mouse diagonally until the form frame is the size
you want and then release the mouse button.
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Notes
•
•

You can align report objects to one another or to the boundaries of the parent frame.
When you group report objects, a form frame is inserted around the grouped report objects.
For information on aligning and grouping report objects, see the online Help. In the Index
tab, type
•

aligning, parts of a report

•

grouping, parts of a report

Set the Scope of the Data for a Form Frame
The scope of data determines what data appears in a form frame. Scope of data is a powerful
property that you can use to create form frames that automatically show specific subsets of
data.
By scoping the data, the child frames within the parent form frame can access only the data
specified in the properties of the parent form frame.
For example, when you put a list frame inside a form frame, you can limit data values in the list
to the current row of data in the query.

You can also restrict data items in a form frame to the values for a specific grouped data item
such as Customer Name. Setting the scope of data to a specific grouped data item limits the
data that appears in the form frame to just the grouped data items.

If you do not want to establish any special relationship between the form frame and the values it
shows, you can set the scope to All Data.

Steps
1. Select the form frame for which you want to set the scope of data.
2. From the Format menu, click Properties, and click the Layout tab.
3. In the Scope of Data box, do one of the following
Click

To

Single Row of Data

Show one row of data at a time
in each form as you scroll
through the report.

Data in the Group and select a
grouped data item from the
Data in the Group box

Show all rows that are
associated with the grouped
data item, such as a Product.

All Data

Show all the data that the form
frame can access.
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4. Click OK.

Repeated Form Frames
You can repeat a form frame horizontally and vertically across the screen or page to view or
print multiple copies of a form frame. This is useful when you create a report where a specific
number of form frames must fit within the boundaries of the report body.
For example, you create a single form for address labels. The single form occupies the entire
height and width of the report body, and you have Impromptu partition it into a 3 x 4 matrix of
identically sized form images that fit exactly within the boundaries of the form. You can
automatically generate multiple, identical form frames within the selected form boundary.

Note
•

You cannot repeat a form frame that has been scoped to All Data.

Steps
1. Create a form frame in the report within which you want to show multiple form images.
2. Select the form frame that you created in step 1.
3. From the Format menu, click Size.
4. In the Width box, select Snap to Parent.
5. In the Height box, select Snap to Parent.
6. Click the Layout tab (Form Properties dialog box).
7. In the Scope of Data box, click Single Row of Data.
8. In the Tile box, do one of the following:
•

Indicate the number of times that you want to repeat the form by clicking the form image
buttons.

• Type the number of horizontal and vertical forms underneath the form image buttons.
For example, if you click the button in the fourth row, third column, or enter 4 by 3, then the
form repeats 12 times in a 4 by 3 matrix. You can repeat a form up to 4 times horizontally
and 4 times vertically for a maximum of 16 form images using the form image buttons.

Note: The number you type for the horizontal and vertical forms can exceed the number of
form image buttons. For example, you can type 6 by 6.
9. Click OK.
Impromptu automatically tiles the form frame to repeat the number of times you specified
and fit exactly within the boundaries of the parent frame.

Chart Frames
A chart is a visual representation of data that enables you to quickly and easily evaluate
information. Use charts to uncover trends, correlations, and exceptions. The chart changes
automatically when the data changes.
For a step-by-step example of inserting a chart frame, see chapter 8 in Discovering Impromptu.
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Assign Data
Using the Data tab, you pick the available data from the Query Data box that you want to appear
in the chart. You can also customize the chart by pivoting the data in the chart or changing the
data mode to present a different perspective of your data. For example, you create a chart to
report your company’s sales over the last four years.

Steps
1. From the Insert menu, click Chart Frame.
2. Position the pointer where you want to locate the upper-left corner of the frame.
3. While holding down the mouse button, drag the mouse diagonally until the frame is the size
you want and then release the mouse button.
4. In the Data tab (Chart Properties dialog box), do one or more of the following:
Click

To

The Add button

Move the selected data items from the
Query Data box to the Chart Data box.

The Remove button

Move the selected data items from the
Chart Data box to the Query Data box.

By Column in the Mode Display a bar for each value in a
box
grouped data item.
By Row in the Mode box Display a chart of the first row in a
grouped data item.
Pivot Data

Swap rows and columns.
To pivot data, you must have at least
one grouped data item.
For example, if you pivot a chart that is
grouped by rows, it becomes grouped
by columns.

5. Click OK.

Notes
•
•
•

Only numeric data items appear in the Query Data box.
The first grouped data item in a report query is displayed in a chart.
You must have a grouped data item in the report query if you format the chart by column
mode.

Format a Chart
You can format a chart to improve readability and presentation by changing the chart style,
background color, and adding grid lines. You can also add and remove labels for the data in a
chart, and specify the format for the labels, such as bold, font type, and size.
For information about these topics, see the online Help. In the Index tab, type
• formatting, chart color
• formatting, chart legends
• formatting, chart titles and labels

Text Frames
You use text frames to add text or data items to a report. A list frame is made up of rows of text
frames.
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For information about inserting text into your report, refer to the online Help. In the Index tab,
type
• adding, text

Sorting or Grouping on Binary Large Objects (BLOBs)
When you put BLOBs in text frames you cannot view the text when you sort or group on your
computer rather than in the database. When this occurs, the words "Text not available" appear in
the text frame for the BLOB.
For information about grouping locally and on the server, see "Client/Server Balancing" (p. 116).

Format the Contents of a Text Frame
You can make text in a text frame either appear
• on a single line
• on more than one line
You can also truncate the text to the size of the text frame, or automatically wrap the text in a text
frame.

Steps
1. Select the text frame.
2. From the Format menu, click Properties, and click the Layout tab.
3. In the Layout tab, do one of the following:
Click the

To

Single Line option button

Show text on a single line,
truncating the text to the width
of the text frame

Multi-Line option button

Show text on more than one
line, but truncate it to the width
of the text frame

Multi-Line with Word Wrap
option button

Automatically wrap text in the
text frame.
Tip: To have large amounts of
text span multiple pages, in the
Size tab, set the height to
dynamic.

4. Click OK.

Tip
•

To quickly make text in a text frame appear on a single line, select and drag one of the sizing
handles to size the frame.

Combining Text Frames
You cannot insert other frames into a text frame. However, you can
• combine two text frames into one text frame (Impromptu removes all trailing blank spaces in
the data before showing the data in text frames)
• copy and paste one text frame into another (when you paste a text frame into a list frame,
the text is pasted as a new column and is repeated for each row)
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Steps
1. Select one of the text frames.
2. While holding down the mouse button, drag the frame into the other text frame.
Your pointer changes to the following:
3. Release the mouse button.
Impromptu combines the two text frames.

Picture Frames
You use picture frames to add bitmap graphics, such as company logos and product pictures, to
your reports.
With picture frames, you can
• insert any Windows bitmap (.bmp), Joint Photographic Experts Group (.jpeg or .jpg),
Portable Network Graphics (.png) or Device Independent Bitmap (.dib).
• scale the image to fit within a specific area in the report, or use the image’s original size and
crop it to meet your needs.
• insert pictures in list frames. When you insert a picture in the detail area of a list frame, the
picture repeats once for every row in the list frame. When you insert a picture in a header or
footer in a list frame, the picture appears in that header or footer.
• insert pictures into form frames. You can use scope of data to control how the pictures are
displayed.
For information about scope of data, see (p. 65).
You cannot insert a picture frame in a text frame, a chart frame, or another picture frame.

Note
•

You can create a static graphic by inserting an OLE Object containing a bitmap that you
create using Microsoft Paint.
For information about inserting report objects, see the Impromptu online Help. In the Index
tab, type
•

inserting, report variables

By default, Impromptu inserts pictures linked to their source so that if the source picture
changes, the picture in the report changes. You can also have Impromptu make a copy of the
picture in the report so that changes to the original bitmap file are not reflected in the report.
For information about inserting a picture frame, see the Impromptu online Help. In the Index tab,
type
• inserting, pictures
You can add a picture that changes based on the values for a data item or a calculation called a
dynamic picture.
For an example of a report that contains a dynamic picture
• based on a data item, see sample report "Annual Product Sales"
• based on a calculation, see the sample report "Margin by Product"

Steps to Insert a Dynamic Picture
1. From the Insert menu, click Picture Frame.
2. Position the pointer where you want to locate the upper-left corner of the frame.
3. While holding down the mouse button, drag the mouse diagonally until the frame is the size
you want and then release the mouse button.
4. Click the Load Using File Name in Column option button (Picture Properties dialog box).
5. Select the name of the column that contains the names of the picture files from the Load
Using File Name in Column box.
Note: The column must contain only the names of the pictures. For example, the Product
Picture data item has "Tent-A" as the value in the first record. Impromptu looks for a file
name such as Tent-A.bmp or Tent-A.png and shows the picture for the first record.
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6. Select the Prefix with Path check box, and enter the location of the picture files.
7. In the Select the Default Image Type list, click the default file type of your picture files.
8. Click OK.

Note
•

When creating a picture frame by referencing an image stored in a database column, the
name of the image can include the file extension, such as .jpg. If the extension is missing,
Impromptu defaults to the format selected in the Source tab of the Picture Properties dialog
box.

Scale and Crop a Picture
By default, Impromptu adjusts the size of a picture to a best fit within a picture frame, while
maintaining the proportions of the picture.

Steps
1. Select the picture frame that contains the picture you want to scale or crop.
2. From the Format menu, click Size.
3. Do one of the following:
Do this

To

Select the Scale Image to Fit check
box.

Scale a picture to fit within
a picture frame

Impromptu resizes the picture to the
same size as the picture frame.
Clear the Scale Image to Fit check
box.

Crop a picture

Impromptu returns the picture to its
original size and crops the picture
using the frame’s dimensions.
Select the Scale Image to Fit and the Maintain the aspect ratio
when you resize a picture
Maintain Height/Width Ratio check
boxes if they are not already selected.
Impromptu adjusts the size of the
picture in the picture frame so that the
ratio matches that of the original
picture size. Generally, the picture
does not fit exactly within the picture
frame.
4. Click OK.
5. While holding down the pointer over one of the handles for the selected picture frame, drag
to size the picture frame and then release the mouse button.
Note: You can scale or re-shape a picture to fit a picture frame even if the dimensions of the
picture differ from those of the picture frame. You can squash or stretch the picture to produce a
desired effect, or to fit it within the boundaries of a picture frame.
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This chapter discusses techniques for presenting complex data in a report.

Present Complex Data
You can present complex data in several ways, including
• crosstab reports
• sub-reports and drill-through reports

Crosstab Reports
A crosstab report is a compact table of rows and columns that shows the value for the
combination of each row and column. In a typical crosstab report, the rows and columns are
grouped, and the cells are summarized.
You can use crosstab reports to summarize and present complex data.
Both the crosstab report and the list report contain rows, columns, cells and summaries.
However, in the crosstab report, the rows, columns, and cells are interrelated. For example, in
the first report the data is presented in a list while in the second report the data is presented in a
crosstab.
List report

Crosstab
report

You cannot edit the SQL (Structured Query Language) for a crosstab report.
For more information about creating crosstabs, see the Impromptu online Help. In the index tab,
type
• crosstabs, creating
• templates, creating reports with
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Quickly Change a List Report into a Crosstab Report
You can quickly change a list report into a crosstab report by dragging one or more columns into
the row titles area. However, you should be aware of the following:
• Because all the columns in the list report must appear in the crosstab, you have less control
over the contents of the column headers and cells of the crosstab than you do when you use
other crosstab creation methods
• Any detail data items in the list report query, even if they are not in the list report, will appear
in the crosstab
You can also create a crosstab from a chart or form frame if the frame is the primary frame in
your report. The crosstab retains all the properties of the primary frame.
For information about designating a frame as the primary frame, see (p. 59).
To restore the list report
• use the Undo command (Edit menu) or the Undo button
• pivot the data again
• use the Build List Report button (Query dialog box)

Steps
1. Select one or more columns or column values in the list report.
You must summarize the data item you use for the cells, or the crosstab shows only the first
occurrence of a value.
2. Drag the selected item(s) into the column titles area. The pointer changes to indicate valid
drop locations.
Note: The selected items are inserted at the position indicated by the highlighting.
3. Drop the selected item(s). The report becomes a crosstab.
4. Repeat steps 1 to 3 to create a nested crosstab.
Note: You determine the order of nesting with the drop position of the selected item(s).

Tip
•

To reduce the number of empty cells in the crosstab, select a data item for the columns with
a many-to-many relationship with the data item in the rows.
For example, Customer and Product, Sales Rep and Product, Year and Product, Region
and Product all have a many-to-many relationship. A one-to-one relationship, such as
Customer and Customer Number, results in a crosstab with many empty cells.

Build Crosstabs from a List Query
You can create a crosstab report directly or build a crosstab after you added data items to a list
query or list report. This method requires a more in-depth understanding of crosstabs.
Use the Build Crosstab button (Query dialog box) to view the Crosstab tab. This tab contains all
the options you need to create a sophisticated crosstab report.
When you add a data item to the Cells box (Crosstab tab, Query dialog box), Impromptu adds
the default summary. For example, Sale Amount becomes Total Sale Amount when you add it to
the Cells box (if Total is the default). If you drag Total Sale Amount from the Cells box back to the
Rows box or the Columns box, the default summary is retained.
You can create simple crosstabs or nested crosstabs. A simple crosstab has one data item in
the rows and one data item in the columns. A nested crosstab has more than one data item in
rows and/or columns. When you create crosstabs, you specify where you want summaries in the
crosstab and what types of summaries you want.
Turning a list report into a crosstab report works best if the data items you want as rows and
columns in the crosstab are already grouped. Impromptu uses the grouping to decide where to
put columns, and if there is no grouping you may end up with a crosstab that doesn't make
sense.
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Here is an example of a simple crosstab report with both a row summary and a column
summary.

Here is an example of a nested crosstab. Again, the report has both a row summary and a
column summary.

When you build a crosstab, you can include calculations using the columns generated by the
crosstab. If you decide to build a crosstab after you have created a list query, you can include
any columns from the existing list query in the crosstab query.

Steps
1. From the Report menu, click Query.
2. In the Query dialog box, click the Build Crosstab button.
The Crosstab tab appears.

Row Summary
checkbox
Column Summary
checkbox

3. Add data items to the crosstab and include summaries as required.
4. Click OK.
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Notes
•
•

•

For a step-by-step tutorial on how to add data items to a crosstab and how to include
summaries, see Discovering Impromptu.
When you select the summary check box in the Crosstab tab (Query dialog box) to include
the row or column summaries, the default summary type matches the summary type of the
cell data.
For example, if the cell data is averaged, then the row and column summaries will be
average. Once you run the query, you can modify the data definition for any row or column
summaries to show a different summary type than the cell data summary.
You cannot edit the generated crosstab titles.

Add Summaries to Crosstabs
In a crosstab report, you can add summaries to
• rows
• columns
• footers
For example, the following report contains summaries in the rows, columns, and footers.

You add row and column summaries by selecting one of the summary check boxes. A summary
check box can be cleared, selected, or shaded (it contains a grayed check mark).

This check box is
selected.
Summarization
exists at all
grouping levels.
This check box is
shaded.
Summarization
exists at some but
not all grouping
levels.

You can clear or select a shaded checkbox to change the summarization.

Change Summarization Types for Crosstab Cells
Each cell data item has a default summarization type that depends on the data type of the cell
data item. If the data type is Number, the default summarization type is Total. For all other data
types, the summarization type is Count. You can change the summarization type.
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Steps
1. From the Report menu, click Query and ensure that the Crosstab tab is selected.
2. Select a summarized data item in the Cells box and click Edit.
The Data Definition dialog box appears. The summarized data item you selected appears in
the Expression box.

3. Edit the summarized data item in the Expression box and Click OK.

Summarization for Crosstab Columns and Footers
The default type of summarization for numeric values in crosstab columns and footers is Total.
You can change the type of summarization using the Summarization dialog box and specify the
levels of grouping to summarize in the columns and footers.

Steps
1. From the Report menu, click Query and ensure that the Crosstab tab is selected.
2. Select a summarized data item in the Cells box and click Summarize.
The Crosstab Summarization dialog box appears.

3. In the Summary Type list box, select the type of summarization you want to apply.
4. In the Column <summary> box, select one or more data items to which you want to apply
the summary.
5. In the Footer <summary> box, select one or more data items to which you want to apply the
summary.
6. Click OK.
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Tips
•

To apply more than one summary to column totals, add the column you want to summarize
once for each summary you want.
For example, if you want both the Total Sale Amount and the Average Sale amount, add the
Sale Amount data item to your report twice. Apply the summary you want to each column
and delete the unwanted columns from your report.

Create Calculated Columns
You create calculated columns in a crosstab report the same way you create them in a list
report.

Steps
1. From the Report menu, click Query.
2. In the Crosstab tab (Query dialog box), click the Calculate button.
3. In the Calculation Definition dialog box, create the calculation you want and click OK.
4. In the Calculation Placement dialog box, specify whether you want the calculation you
created to appear in the rows, columns, or cells, and click OK.
For information about defining calculations, see "Create Calculated Fields" (p. 32).

Use Columns Generated by the Crosstab
You can create calculated columns using columns generated by the crosstab. You can do this
only after the crosstab query runs, since Impromptu must know which columns are generated.
For example, you create a new sales quota for each sales representative by calculating an
amount that is 25% over the sales each representative made last year. Then, you calculate the
net change between the total sale amount and the sale quota for each representative. To do
this, you create a calculation using columns generated by the crosstab.
Total Net Change = total (Sales Quota - Total Sales)

See also the sample report "Proposed Sales Rep. Quotas."

Steps
1. From the Report menu, click Query.
2. In the Crosstab tab (Query dialog box), click the Advanced button.
Note: If you have not run the crosstab query when you click the Advanced button, you are
prompted to run the query. This ensures that the crosstab columns are generated and
available for use.
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3. Do one of the following:
Do this

To

Select the Show All Crosstab
Columns check box.

See all the crosstab columns
(not just the calculated
columns)

Click New.

Add a new calculation

Select the calculation and click
Edit.

Edit a calculation

Select the calculation and click
Remove.

Delete a calculation

4. In the Calculation Definition dialog box, create your calculation and click OK.
New calculations are added as columns at the end of the report.

Filter Data in Crosstab Reports
You can filter data in a crosstab report by applying one or more of the following types of filters:
• detail
• summary
• crosstab detail
• crosstab summary
For information about detail and summary filters, see (p. 10).
If you're familiar with SQL, you can think of a crosstab filter as having a predicate in the WHERE
clause on the second SQL pass.
Crosstab filters are used with only crosstab reports. If you change the crosstab back to a list
report, the crosstab filters are removed from the list report.

For Example
You create a crosstab report that displays the sales totals across the Great Outdoors line of
products for all customers.

You apply the following four filters to the report.
You apply

That looks like this

The detail filter

(Product Line =‘Alert Devices‘ and
(Customer Type = ‘Camping Chain‘
and Customer Name starts with
‘F‘)) or (Product Line = ‘Alert
Devices‘ and (Customer Type =
‘Sports Chain‘ and Customer
Name starts with ‘A‘))

The summary filter

Total Sale Amount < 5000
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You apply

That looks like this

The crosstab detail filter

Alert Devices Microwave Detective
> 200

The crosstab summary filter

Total < 10000

The report now looks like this.

Steps
1. Create the crosstab report.
2. From the Report menu, click Query and then click the Filter tab.
3. In the Filter Type box, select either the Crosstab Detail filter or the Crosstab Summary filter.
4. Create a filter expression using the components in the Available Components box.
5. Click OK.

Tip
•

To quickly apply a filter to a crosstab report, use the Filter button on the toolbar. For
example, if the cells in your crosstab report are values of Average Margin and you select a
cell value of 25 and click the Filter button, the crosstab filter is Average Margin = 25.

Swap Rows and Columns
You can swap rows and columns in the Crosstab tab or you can swap them directly on the
crosstab report by dragging one or more columns to the row titles area. For example, if the rows
are products, and the columns are countries, you can swap them to change the rows to
countries and the columns to products.
For a step-by-step tutorial of how to swap rows and columns, see chapter 5 in Discovering
Impromptu.

Change a Crosstab to a List Report
You can change any crosstab report to a list report. When you do so, you lose the crosstab
filters. Any data items you added to the crosstab now appear in the list report.

Steps
1. Position the pointer over a column.
The pointer looks like this.
2. Click the mouse once to select the column. Click the mouse a second time to select all the
columns.
3. Drag the selection into the row titles area.
The pointer looks like this.
The crosstab becomes a list report.

Tip
You can also change a crosstab to a list report by clicking Build List Report in the Crosstab tab
(Query dialog box).
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Work With Sub-Reports
Sub-reports are multiple Impromptu queries contained in a single report, so that you can deliver
information that would otherwise only be available with two or more reports.
Sub-reports offer more flexibility for grouping and sorting data than a regular report. Sub-reports
use the same catalog, but you can group each sub-report on different columns; with a regular
report, you can only group data in different frames on the same columns. You can also apply
different sort and filter conditions to each sub-report.
For example, you create a report that compares annual sales. You want to see the total sale
amount for each year by both product and by product type. You use sub-reports and display
them side by side.

You can also create reports that display information in a vertical list. For example, you create a
report that lists sales information. In order to sort, group, and filter on different data items, you
use sub-reports.

sub-reports

The creation of sub-reports is best suited to report authors who have a good understanding of
the database that the catalog uses, and who are creating standard reports for use without
modification by the user community.
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What You Can Do With Sub-Reports
You can
• schedule sub-reports with Scheduler and print the results
• export the main sub-report query data to other applications using the Save As command
• drill through to a sub-report from PowerPlay or Impromptu; however, the filters that are
automatically applied from the source report to the drill-through report are always applied to
the main query but never applied to the sub-report queries
For information on setting up drill-through reports, see (p. 82).
• publish a report with multiple queries as HTML (HyperText Markup Language) and view it
with a Web browser
For information about publishing reports for use with Web browsers, see "Using HTML to Create
Reports on the Web" (p. 93).

What You Can’t Do With Sub-Reports
You cannot
• save a sub-report as a local snapshot
• schedule sub-reports with Request Server; sub-reports cannot be saved as remote
snapshots
• insert a sub-report into a list frame
• sort, group, or filter two different queries simultaneously

Create Reports Containing Sub-Reports
A new report automatically has a main query. When you add a sub-report, you must define its
query as well.
You can add a sub-report to a report by
• adding a new frame as a sub-report
• changing an empty frame into a sub-report
A frame can be changed to a sub-report or added to the report as a sub-report as long as it can
be associated with a query. This excludes only OLE objects and picture frames.

Steps to Change an Empty Frame into a Sub-Report
1. Select the empty frame that you want to change into a sub-report.
2. From the Report menu, click Change to Sub-Report.

Note
•

If the Change to Sub-Report command (Report menu) is unavailable, ensure you selected a
frame, that the selected frame is not already a sub-report, and that the frame is not an OLE
object or a picture frame.

Steps to Insert a New Frame as a Sub-Report
1. Select the frame into which you want to insert a sub-report, such as a form frame.
2. From the Insert menu, click Sub-Report, then click the type of frame you want to insert
(Chart, Form, List, Crosstab, or Text Frame).
3. Position the pointer where you want the upper-left corner of the frame.
4. Hold down the mouse button and drag the mouse diagonally until the frame is the size you
want and then release the mouse button.
The Query dialog box appears.
5. Add the data items you want in this sub-report and click OK.
If you add a chart sub-report, the Chart Properties dialog box appears.
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Edit Sub-Report Queries
When you add a sub-report, the Query dialog box appears. You can define a query for the
sub-report that is completely independent of the main query, with it’s own sorting, grouping, and
filtering.
When a report contains more than one query, the Report menu changes to enable you to select
a specific query from a flyout menu.

Step to Select a Query to Edit
•

From the Report menu, click Query, and select the query you want to edit.
If

Then

No frame is selected

The Main Query appears first on
the list, followed by the name of
each sub-report.

A frame is selected

The frame’s sub-report appears
at the top of the list, followed by
any parent queries the sub-report
may have, then the Main Query.

Tip
•

To see all the queries in the report in a hierarchical structure, from the Report menu click
Query, then All Queries.

Link Sub-Reports
By default, the main query and sub-report queries are independent of each other. However, you
can link them by including data items from the main query in the sub-report filter expression.

For Example
You filter a sub-report query so that it shows only order information for the current customer
name in the main query.

main report
sub-report

The filter expression that links a sub-report to a main report looks like this:
<column name>=Main Query.<column name>

<Column name> is the data item you use to link the queries. The example above uses the
Customer Name column to link the queries. When the sub-report query runs, it checks for the
first row in the Customer Name column and shows only information for that customer.
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If you want a sub-report to show information for another row in the column, place the main report
in a form frame that shows only one row at a time. When you insert the sub-report into the form
frame as well, it changes as you click through the rows in the main report. For example, the main
and sub-reports above are both in a form frame that shows only one row of the Customer Name
column at a time. Each time you scroll to another customer name, the sub-report shows only
information for that customer.

Steps to Create the Main Report
1. Create a new report using the Blank template.
The Blank template uses a form frame to create a report.
2. In the Data tab (Query dialog box), double-click the data items you want to include in the
main query.
To recreate the example above, open the Customers folder, double-click Customer Name,
and click OK.
3. Click the empty report.
4. From the Format menu, click Properties, and click the Layout tab.
5. In the Scope of Data box, click Single Row of Data, and click OK.
6. From the Report menu, click Query.
7. In the Query Data box, click the Data items, and click Mark for Insertion. Click OK.

Steps to Add a Linked Sub-report
1. From the Insert menu, click Sub-Report, and click List Frame.
The cursor shows a List Frame icon. Use to drag and size a list frame anywhere in the
report.
2. In the Data tab (Query dialog box), double-click the data items you want to include in the
sub-report query.
To recreate the example above, open the Orders folder, and double-click Order Date and
Closed Date.
3. Click the Filter tab, and use data items from the main query to create a filter expression.
To recreate the example above
•

double-click Catalog Columns, open the Customers folder, and double-click Customer
Name

•

double-click =

•

double-click Report Columns, Main Query, and Customer Name

4. Click OK.
Use the scroll buttons on the top right of the report to scroll through the data items in the main
query. Each time you scroll, the report frame is recreated, and the sub-report query runs. The
sub-report then shows information for the current row in the main query.
For more information about creating filter expressions, see (p. 11).

Use Drill-Through Reports
You can use drill-through reports to create a report that better meets the needs of its primary
audience while still providing an easy to access link to related information. A report user who
wants to see related or more detailed information selects a value in the report and drills through
to an associated report.
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For example, you have a report that lists customer names, order numbers, and the total sale
amount for each order. You want to see the transaction details for order number 160. You select
this value and click the Drill-Through button. The associated drill-through report opens and is
filtered on order number 160.
Parent Report

Child Report

You can set up drill-through associations for the following types of reports:
• list reports
• crosstab reports
• reports containing multiple queries (sub-reports)
• reports using snapshots or outflows
• reports including chart frames
You can also drill through to Cognos Query. For more information, see the Impromptu online
Help. In the index tab, type
• Cognos Query

Notes
•
•
•

You can only drill through from a value in the parent’s main query to a main query in the
child report.
To drill through from a chart, the chart must contain summary values for one data item (for
example, a bar chart that shows the total sale amount for each country).
Both reports must be from the same catalog.

Associate Reports for Drill-Through
To set up a drill-through report association, you
• select the report from which you want users to start. This is called the parent report
• select a report that you want users to drill to. This is called the child report
• specify the parent report column(s) from which a child report can be accessed
• specify the columns from the parent report that are to be included in the filter expression of
the child report
When you select a value in one of the specified columns in the parent report and click the
Drill-Through button, the following occurs:
• Filter information for this value is passed to the filter expression of the child report.
• Any other columns that you selected for inclusion in the child filter are passed to the filter
expression of the child report.
• The child report’s query runs and the report appears.
• Both the parent and child reports must be from the same catalog.
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Notes
•
•
•

To have a column value included in the filter of the drill-through report, the column must exist
in both the parent and the child query, but not necessarily in the child report.
You can include more than one column in a drill-through filter.
You can verify the drill-through filter using the Drill-Through Filters command (Report menu)
when you are viewing the child report.

Steps
Before you begin, ensure that you have a parent report, and at least one report that is going to
be the drill-through or child report.
1. Open the parent report (the one from which users will drill), and click any data item.
2. From the Report menu, click Drill Through, and then click Properties. The Drill Through
Properties dialog box appears.

Note: If the Drill Through Properties command (Report menu) is unavailable, click Options
(Tools menu), select the Drill Through tab, and then select the Enable Drill Through
Properties check box.
3. Select a column for which you want to add a drill-through report and click Add. The Add Drill
Through Query/Report dialog box appears.
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4. Select the column(s) to be included in the drill-through filter. Clear the column(s) you do not
want included in the drill-through filter.
For example, if you select Product for the drill-through column Product Cost, then when the
user drills through on a value of Product Cost, the filter information passed to the child
report includes the value of Product that is in the same row as the selected value of Product
Cost. For example, the filter passed to the child report could be Product Cost = 500 AND
Product = Star Lite.
Note: The column you add a drill-through report for is included by default in the drill-through
filter, along with any grouped columns. You can clear the check box for these columns if you
do not want them in the filter of the child report.
5. Type the drill-through report name and path, or click Browse to find it.
While browsing, select Enable Filter by Catalog to see only reports that use the same
catalog as the parent report. Select Enable Filter by Columns to see only reports that
contain columns you are using in the drill-through filter.
6. Click OK. Impromptu validates the child report’s path and file name, and verifies whether the
selected columns exist in the child report.
Note: If one or more selected columns do not exist in the child report, Impromptu grays
them and shows you a message. You can then choose whether you want to leave the
columns in the drill-through filter or clear the selection from the columns and remove them
from the drill-through filter. However, if you do not add the missing columns to the child
report, the user will be unable to drill through from the parent to the child report.
7. In the Drill-Through Properties dialog box, click OK to set the drill- through association and
close the dialog box.

Notes
•

•

If there is a conflict between the parent and the child filters, the drill-through (child) report
may contain no data. For example, if the selected value in the parent report results in the
filter Country = ‘Canada’ being passed to the child report, and the child report already has a
filter Country = ‘Germany’, the filter becomes Country =’Canada’ AND Country = ‘Germany’.
The result is that no rows meet these filter conditions and no data is shown in the
drill-through report.
If you remove or rename a column in the parent or child report, or if the data type of a
column changes in the database, when you drill through an error message appears and the
drill-through operation fails.

Tips
•

•

To set a drill-through report as the default report that opens when a user selects a value and
clicks the Drill Through button, drag the report name to the top of the list under its
associated column in the Drill-Through Properties dialog box.
To provide the report users with added flexibility, you can include a prompt in the
drill-through report. When the user drills through from the parent report, a prompt appears.
The values the user enters or selects are added to the filter expression in the drill-through
report.
For information about creating prompts, see (p. 16).

Test Drill-Through Reports
Before you deploy drill-through reports, test the associations you created to ensure that
• the drill-through works and the expected result appears
• the default drill-through report is the first report under the data item if more than one report
is associated with a data item. The default report is the report that appears when the user
selects a value and clicks the Drill-Through button without selecting the drill-through report
from the Drill-Through button drop-down list.

Steps
1. Open the parent report.
2. Press Esc to clear any selections in the report.
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3. Click and hold down the Drill-Through button on the toolbar to highlight all the report
hotspots from which you can drill through. (When you release the Drill-Through button, the
highlighting disappears).

4. Select a value in the report that was highlighted in step 3.
5. Click the Drill Through drop-down button on the toolbar.
6. Verify whether the correct report or reports appear in the drop-down list. Select a report or
click the Drill-Through button to open the child report.
7. From the Drill-Through button drop-down list, click Filters.
8. Verify that the filter expression shows the filter conditions you want passed from the parent
report.
Note: The Impromptu Drill-Through Filters dialog box displays only valid drill-through filter
expressions. The final filter expression applied to the child report is a combination of valid
drill-through filters and both the detail and summary filters (or crosstab filters) in the child
report.
9. If you associated more than one report with the parent report’s column, verify that the
drill-through report that appears is the report you want as the default report. If not, drag the
report you want as the default to the top of the list for the column in the Drill-Through
Properties dialog box.
If you are satisfied with the test results, you are ready to deploy the report and its associated
drill-through reports.
For information about deploying reports, see "Present Results with Other Applications" (p. 86).
Note: The drill-through filter is not saved when you exit the child report.

Present Results with Other Applications
You can present the results of your Impromptu reports outside of Impromptu using
• OLE (object linking and embedding)
• HTML (web-based report publishing)
You can also use OLE to embed objects from other applications into Impromptu reports.

Using OLE to Present Impromptu Reports
Information created in one application and linked or embedded in another application is called
an OLE object.
When you link and embed objects from one application to another, you maintain a link to the
original application so you can take advantage of its features.
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The primary difference between linking and embedding is where the OLE object is stored:
• A linked object is like a pointer from one application to information stored in another
application.
• An embedded OLE object is a copy of the information from one application inserted and
stored in another application.
Note: If you regularly copy report objects to another application, you can set up a Launch button
on the toolbar. When you click the Launch button, Impromptu automatically copies information
from the active report to the Clipboard before running the application.
For information about Launch buttons, see (p. 125).

Link Information From Another Application to Impromptu Reports
You can create a link to include information from other applications in an Impromptu report. This
information can appear in the Impromptu report either as data or as an icon. When the
information in the source application changes, the Impromptu report is automatically updated
with the changed information.
For example, you prepare an Impromptu report that shows target sales quotas. Next, you link
the company sales figures that are in an OLE spreadsheet application to the report, and
distribute the report to your sales force. This ensures that the sales figures are automatically
kept as current as the information in the spreadsheet.

Steps to Link Information From Another Application
1. In the source application, select the information that you want to appear in the Impromptu
report.
2. Copy the selected information to the Clipboard.
3. From the Impromptu Edit menu, click Paste Special to show the Paste Special dialog box.
4. Click the Paste Link option button.
Note: If the Paste Link option button is unavailable, save the source file.
5. If you want the linked information to appear as an icon rather than as data, select the
Display as Icon check box.
Note: When you select the Display as Icon check box, Impromptu inserts a shortcut that
points to the location of the source file.
6. Click OK.
Your pointer changes.
7. Position the pointer where you want the upper-left corner of the linked object.

Steps to Link to Another Application Without Leaving Impromptu
1. From the Insert menu, click OLE Object.
Your pointer changes.
2. Position the pointer where you want the upper-left corner of the new OLE object.
3. Click the mouse button.
4. Click the Create from File option button.
5. In the File box, type the name of the file to link to your report.
If you are not sure of the name or the location of the file to which you want to link, click
Browse to locate and select the file.
6. Select the Link check box to link the selected file to your report.
7. If you want the linked information to appear as an icon rather than as data, select the
Display as Icon check box.
Note: When you select the Display as Icon check box, Impromptu inserts a shortcut that
points to the location of the source file.
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8. Click OK.
Impromptu creates a link between the file you specified and the current report. Whenever
the information in the linked file changes, the Impromptu report is updated with the changed
information.
Note: Deleting a linked object does not delete the information in the source document. It
merely removes the link to that object from the Impromptu report.

Edit Linked Report Objects
When an Impromptu report includes a linked object, you can open the object’s source
application.

Steps
1. Double-click the linked object to open the source application.
2. In the source application, make the required editing changes.
3. In the source application, save the changes.
4. Exit the source application and return to Impromptu.

Update Links
By default, Impromptu sets links to be updated automatically when the information in the source
document changes. If you do not want changes in linked objects automatically reflected in your
Impromptu reports, you can turn off automatic updating, complete manual updates, and then
turn automatic updating back on again. You can also change a link to retrieve information from a
different file.
For example, you link an Impromptu report to a very large and complex spreadsheet that was
created in an OLE compliant application. This spreadsheet frequently performs a forecasting
calculation using the last period’s sales data. You want to manually update the link monthly so
that performance is not affected by frequent link updates.

Steps
1. Select the linked object you want to change.
2. From the Edit menu, click Links.
In the Links box, the linked object that you selected in step 1 is highlighted.
3. Do one of the following:
Click

To

The Manual option button

Turn off automatic updating

Update Now

Update the link now

The Automatic option button

Update the link whenever the
source document changes

Change Source

To show the Change Source
dialog box. Use to select a new
file to base the OLE object on

Open Source

To edit the object using the
application in which it was
created

Break Link

To change the object into a
Windows Metafile that can no
longer be edited

You can click Cancel until you change the object’s link settings. When you change the link
settings, the Cancel button changes to a Close button.
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4. Click Close.

Note
•

When you link objects that frequently change, there may be an impact on performance.
For information about performance issues, see "Optimize Performance in
Impromptu" (p. 115).

Convert Linked Objects
Windows automatically tracks all the OLE objects that are available for use in your system. You
can convert an OLE object to a different format. Impromptu cannot perform conversions on
some types of linked objects.
When you convert OLE objects, you must perform conversions completely within a source
application before you create the link in your report.
For example, you linked an object created with an OLE compliant drawing application to your
report. To speed up the report, you now eliminate the link and store the object in the report as a
picture so you can edit it using another software package. You convert the object in the
Impromptu report to a new type.

Steps
1. Select the object that you want to convert.
2. From the Edit menu, click Linked Document Object, and then click Convert.
3. From the Object Type box, click the type you want the object converted to and then click OK.

Embed Objects In Impromptu
You can embed all or part of the information from another application in your Impromptu reports
so that the information appears as part of the report.
You can
• embed information in a report by copying the information from the source
• embed an object in a report
• embed a newly created object in a report

Embed Objects By Copying
When you embed information, you make a copy, so that changes in the source do not appear in
the report, and changes you make do not appear in the source file.
When you create a new object or edit an object and the application you’re embedding supports
in-place editing, the application menus and toolbars temporarily replace Impromptu’s menus
and toolbars. When it does not support in-place editing, Impromptu opens the other application.

Steps
1. In the source application, select the information you want to embed and then copy it to the
Clipboard.
2. To insert the OLE objects into a frame other than the primary frame, select the appropriate
form or list frame in Impromptu.
3. From the Edit menu, click Paste Special.
4. In the As box, select the object type that corresponds to the application in which the object
was created.
5. If you want the embedded information to appear as an icon rather than as data, click the
Display as Icon check box.
Note: When you select the Display as Icon check box, Impromptu inserts a shortcut that
points to the location of the source file.
6. Click OK.
Impromptu inserts an OLE object containing the data from the other application into the
frame you selected in Step 2.
Mastering Impromptu Reports 89

Chapter 3: Complex Reports

Embed Existing Objects in Reports
You can embed entire files, as either data or as an icon, that you created in an OLE-compliant
application into an Impromptu report. For example, you have a spreadsheet that outlines major
sales campaign expenditures during the past year. You embed the spreadsheet in a sales report
so you can correlate sales costs with revenues.

Steps
1. From the Insert menu, click OLE Object.
2. Position the pointer where you want the upper-left corner of the new OLE object. Your
pointer changes.
3. Click the mouse button to show the Insert Object dialog box.
4. Click the Create From File option button.
5. In the File box, type the name of the file to embed in your report.
6. If you want the embedded information to appear as an icon rather than as data, click the
Display as Icon check box.
Note: When you select the Display as Icon check box, Impromptu inserts a shortcut that
points to the location of the source file.
7. Click OK.
Impromptu embeds the file you specified into the current report.

Create Embedded Objects in Reports
You can create new OLE objects in an Impromptu report. For example, you want to embed a
spreadsheet that was created in an OLE compliant application in an Impromptu report. You
insert an OLE object, select the type, and then edit the new object—all without leaving
Impromptu.

Steps
1. From the Insert menu, click OLE Object.
2. Position the pointer where you want the upper-left corner of the new OLE object. Your
pointer changes.
3. Click the mouse button to show the Insert Object dialog box.
4. Click the Create New option button.
5. If you want the embedded information to appear as an icon rather than as data, select the
Display as Icon check box.
6. In the Object Type box, double-click the type of object to insert.
7. Work within the application as you would normally to create the new object.
8. Do one of the following:
•

If the embedded object was created in Impromptu, click the mouse button anywhere
outside of the embedded object to return control to Impromptu.

•

If the embedded object was created in another application that was launched from
Impromptu, click Exit from the File menu. If you are prompted to save the changes you
made, click Yes.

Edit Embedded Objects
You can edit an embedded object by editing the object within Impromptu or by launching the
source application. Many applications support in-place editing of embedded OLE objects. If an
application does not support in-place editing, Impromptu automatically launches the application
when you edit the OLE object.

Steps
1. In Impromptu, select the embedded object that you want to edit.
2. From the Edit menu, select the embedded object.
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3. Do one of the following:
• If the source application supports in-place editing, click Edit from the cascading menu.
Impromptu’s menus are replaced by the menus of the application in which the OLE object
was created.
•

If the source application does not support in-place editing, click Open from the
cascading menu.
Impromptu launches the application in which the OLE object was created.
4. Make the changes to the embedded object.
5. Do one of the following:
•

If the source application supports in-place editing, click the mouse button anywhere
outside the embedded object to return control to Impromptu.

•

If the source application does not support in-place editing, click Exit from the File menu.

6. If you are prompted to save the changes you made, click Yes.

Format Linked or Embedded Objects
Once you have linked or embedded an OLE object in a report, you can change the properties of
the object and format it as you would any other report object. A linked or embedded object has
many of the same physical properties as frames. For example, you can change the size of an
embedded object or add a border to a linked object.
For information about changing the format and properties of a report object, see the Impromptu
online Help. In the Index tab, type
• borders
• patterns
• styles, applying
• resizing parts of a report

Embed Impromptu Objects in Other Applications
You can embed Impromptu report data in other applications that support OLE. For example,
your department uses a programming application to manage an order tracking system. You
embed Impromptu reports in the order forms to create order reports.

Steps
1. From the Impromptu Edit menu, click Select All, and click Copy.
Note: You can also click Copy Special from the Edit menu. When the Copy Special dialog
box appears, click the Copy Report Image option button and then click Copy.
2. From the Edit menu in the target application, click Paste Special.
3. Click the Paste option button.
4. In the As box, ensure that the Impromptu Report Object type is selected.
5. If you want the Impromptu report to appear as an icon rather than as data, select the
Display as Icon check box.
Note: When you select the Display as Icon check box, Impromptu inserts a shortcut that
points to the location of the source file.
6. Click OK.
The Impromptu report is embedded in the current application. You can edit the report by
double-clicking the report or the report icon.
Note: It is not possible to document all the methods for embedding an Impromptu report in all
other applications here. Generally, applications that support OLE do so through commands
such as
• the Paste Special command in the Edit menu (copy either the Impromptu report image or
report data using the Copy Special command)
• the Object command in the Insert menu
• the Insert Object in the Edit menu
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Copy Subsets of Data to Other Applications
You can use the Copy Special command to paste or link information in another application or to
copy data to another application.

For Example
You use the Copy Special command to copy the first 40 rows for 5 specific data items in the
query to the Clipboard. You can either select the data values that you want to copy, or you can
specify which columns and rows to copy as part of the Copy Special command.

Steps
1. Select the data that you want to copy.
2. From the Edit menu, click Copy Special.
Because you selected a range of data values to copy, the Copy Special dialog box is set to
Copy Query Data rather than Copy Report Image.
3. Make any changes to the data you have selected for the copy operation as follows:
Do this

If you want to

Click to add or remove data
items.

Change the data items copied

Select either
• The Copy All Rows option
button to copy all data
values
• the Copy Rows option
button to copy a specific
number of rows

Change the number of rows
used in the copy operation

In the Copy Rows boxes, type
the numbers for the first and last
row that you want to copy.
Select or clear the Include Data Include or exclude the labels for
Labels check box.
each data item in the copy
operation
4. Click Copy.
Impromptu copies the data values to the Clipboard based on the settings you chose.
5. Launch the application into which you want to copy the data, and position the cursor where
you want to insert the copied data.
6. From the Edit menu, click either the Paste or Paste Special option button.
Note: If you click Paste, the data values are pasted into the target application as
unformatted text. If you click Paste Special, the Paste Special dialog box appears, and you
can choose whether to paste or paste and link the data into the target application.

Link Impromptu Reports in Other Applications
You can link Impromptu reports in other applications so that whenever the report is run in
Impromptu, the information in the other application is updated. For example, you include an
Impromptu report that shows the most recent sales data in a sales analysis document. You
create a link to the Impromptu report, and the linked report appears in the sales document
exactly as it appears in Impromptu.
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Steps
1. Within Impromptu, select the data items whose values you want to link to another
application.
2. From the Edit menu, click Copy Special.
3. Click the Copy Query Data option button.
4. Do one of the following:
•

To copy data items other than those selected, Ctrl+click each additional item you want
to copy.

•

To copy all of the data that was retrieved in the query, click the Copy All Rows option
button.

•

To copy a specific number of rows from the query, click the Copy Rows option button,
and type the numbers that correspond to the first and last rows you want to copy.

5. If you want to include labels for the data items you copy, select the Include Data Labels
check box.
6. Click Copy.
7. Within the target application, click Paste Special from the Edit menu.
8. Click the Paste Link option button.
9. In the As box, ensure that Impromptu Report Object type is selected and click OK.
The Impromptu report data is linked to the target application, so that the information in the
target application changes with the report.

Notes
•

It is not possible to fully document all of the methods for linking. Generally, applications that
support OLE do so through commands such as
•

the Paste Special command in the Edit menu (copy either the Impromptu report image
or report data using the Copy Special command)

•

the Object command in the Insert menu

•

the Insert Object command in the Edit menu

Tip
•

To quickly select the Impromptu report data you want to link, use the Select All command
(Edit menu) before you copy the report data to the Clipboard.

Using HTML to Create Reports on the Web
A HyperText Markup Language (HTML) report is a read-only report that users can view in a Web
browser. You can save and distribute Impromptu reports in HTML format, such as, from your
intranet or Internet Web site or by email. You can view and run Impromptu HTML report output in
Impromptu Web Reports (IWR).
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HTML report output contains a Report Navigator, which means you can jump to a grouped
column value or a specific page number in the HTML report. In the following HTML report,
values in the Report Navigator show as pictures. You click a picture to jump to a page in the
report.

For more tips and techniques on how to design Impromptu reports for HTML output, see the
Cognos support Web site (http://support.cognos.com).

Set Report HTML Properties
You can control how reports are generated in HTML. Use the HTML tab of the Report Properties
dialog box to set the HTML properties of a report.
Impromptu creates different file types when you save a report as HTML. The quantity and types
of files depend on the size of the report, the number of graphics, and the options you include.
When you distribute the HTML report, you must provide all the associated files.

Steps
1. With a report open, from the Report menu, click HTML.
2. Specify the HTML format properties that you want.
Select

To

The Include the Report
Navigator check box

Include a Report Navigator.
Note: Applicable only to
Layout 1.

One or more of the grouped or Specify the grouped or
associated columns that appear associated columns you want in
the Report Navigator.
in the Available Columns to
Include box
The In a Frame button
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Chapter 3: Complex Reports

Select

To

The On a Separate Page button Show the Report Navigator on a
separate page from the report
body.
The Include Page Numbers
check box

Include a list of page numbers
in the Report Navigator, which
link to specific pages in the
report body.

The Suppress Duplicate Entries Remove duplicate entries in the
check box
Report Navigator caused by
horizontal page breaks in
Layout 1.
The rendering style in the
Rendering Option box

Specify the rendering style. We
recommend
• Layout 1 for older browsers
with limited frame support,
such as, Netscape 4.76
• Layout 2 for browsers
supporting I-frames and
JavaScript, such as, IE 5.5
and higher and
Netscape 6.0 and higher

3. Click OK.

Upgrading Existing Reports
You can choose different rendering formats when you generate reports in HTML. By default,
reports retain their original format. If the report was created in earlier versions of Impromptu, the
Rendering Option property automatically updates the report to Layout 2.

Save Reports as HTML
Use the Save As command to save reports in HTML format.

Steps
1. If you selected Layout 1 as the rendering option for your report, from the View menu, select
Page Layout view.
2. From the File menu, click Save As.
3. In the Save as Type box, click Hypertext Markup Language (*.HTM).
4. In the File Name box, specify the name of the report.
Each report you save as HTML requires its own folder.
5. Click Options.
6. In the Save as HTML Options dialog box, specify the page options for the report and click
OK.
7. In the Save As dialog box, click Save.

HTML Files
The Save as HTML command generates a number of related files. The set of files generated
depends whether you specify the Layout 1 or Layout 2 rendering option.
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Create a separate folder for each report to more easily manage the files that Impromptu
generates. This ensures also that the files from one report do not affect the files from another. If
you distribute an HTML report by email, ensure that you send all the files for that report.

Layout 2 File Set
The following files are created when you save a report as HTML using Layout 2.
This File
Main HTML page

Has These Characteristics
Is created for each report saved as HTML.
Is used to launch the HTML report output.
Tip: Each report requires its own folder to
ensure that index.htm file is not overwritten.
Filename: index.htm

Report body pages

Is created for each page of the report body. If
a report has 50 pages, there will be 50 files of
this type.
Has the prefix you provide, followed a letter,
number or alphanumeric value, and the
extension .htm.
For example: MyFile1.htm, MyFilea.htm, or
Myfile1a.htm.

Report StyleSheet
Files

Specifies the layout attributes of a report.
Has the prefix you provide, followed by a letter,
number or alphanumeric value, and the
extension .css.
For example: MyFile1.css, MyFileb.css, or
MyFile1b.css

Report Navigator
Button Files

Is created for each report saved as HTML.
Links the navigation buttons to the pages.
For example: htmlnavbuttons.html.

Report Navigation
Buttons Frame

Is created for each report saved as HTML.
Contains the report navigation buttons.
Filename: htmlnavbuttons.js

Report Content
Frame

Is created for each report saved as HTML.
Displays report content.
Filename: htmlcontent.js

Report Table of
Contents Frame

Is created for each report saved as HTML.
Contains links for navigation.
Filename: htmltoc.js

Image Files

Is created for each OLE object and graph.
Filename: Myfile0.png
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This File

Has These Characteristics

Navigation Buttons

Is created for each navigation option if you
include a Report Navigator. There will be a
8.gif files for the top, bottom, up, and down
buttons in both the available and unavailable
state.
For example, CG47DN.gif

Log Report

Is created for each report saved as HTML.
Has the prefix you provide, followed by a
number and the extension .log.
For example: MyFile1.log

Layout 1 File Set
The following files are created when you save a report as HTML using Layout 1:
This File

Has These Characteristics

Main HTML page

Is created for each report saved as HTML.
Is used to launch the HTML report output.
Has the prefix you provide, and the extension
.htm.
For example: Myfile.htm.

Report body pages

Is created for each page of the report body. If
a report has 50 pages, there will be 50 files of
this type.
Has the prefix you provide, followed by ‘b’, a
sequential number, and the extension .htm.
For example: MyfileB1.htm.

Report Navigator
Button Files

Is created for each report page if you include a
Report Navigator.
Links the navigation buttons to the pages.
For example: MyfileN1.htm.

Report Navigator

Is created if you include a Report Navigator.
For example: Myfile_TOC.htm.

Report Navigator
Columns

Is created if you include columns in the Report
Navigator.
For example: Myfile_CTOC.htm.

Report Navigator
Page Numbers

Is created if you include page numbers in the
Report Navigator.
For example: Myfile_PTOC.htm.
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This File
Image Files

Has These Characteristics
Is created for each OLE object and graph.
For example: Myfile0.jpg.

Navigation Buttons

Is created for each navigation option if you
include a Report Navigator. There will be up to
8 .gif files, one per direction (up, down, left,
right) and for available and unavailable
buttons.
For example: CG47DN.gif.

Distributing HTML Report Output
After you save a report as HTML, you can make it available to report viewers in a Web browser.
Be sure to include all files associated with the HTML report. You can distribute HTML report
output
• on an Internet Web site
Follow your organization’s procedures for linking reports to your Web page.
• on the intranet Web site for your organization
Follow your organization’s procedures for linking reports to your Web page.
• by sending it to specific users by email
Ensure that all of the HTML files are compressed and mailed to recipients according to your
organization’s email procedures.
• on a network for your organization
Ensure that all the HTML files are in the appropriate folder on the network, and provide
access to the folder according to your organization’s procedures.
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Chapter 4: Data and Databases
This chapter discusses how Impromptu uses data in creating reports. It includes a discussion of
• how Impromptu retrieves data
• your options in choosing data sources

Choose Your Data Source
You have several choices in working with the data from which you create reports in Impromptu.
To make the best decisions about how to maintain the report data, you must first understand
how
• Impromptu retrieves data
• a database is attached to your catalogs
• copies of the data can be used
• you can format the data

How Impromptu Retrieves Data
Your Impromptu reports show information retrieved from the database. When a report requires
information, Impromptu accesses the database via a catalog.

You run
a query
You open a catalog
that points to your
view of the data in the
database

Impromptu
generates
SQL
Impromptu retrieves data
from the database

The resulting report shows your data in a
meaningful format

A catalog insulates you from the complexities of the database, letting you focus on analyzing the
data that drives your business. As the bridge to the database, a catalog
• points to the data (name, location, contents)
• controls what data can be accessed by each class of catalog user
• presents a business view of the information in the database
When you request information from the database, Impromptu generates a Structured Query
Language (SQL) query based on your request and passes it to the database. The database
then selects the data for your report and sends the result set back to Impromptu.
Your Impromptu administrator creates the catalogs you use. An administrator can create a
catalog that meets different user requirements.
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Take Advantage of a Cache Query
A cache query is a temporary cache on your personal computer that Impromptu uses to store
report results. When you use the Cache Query checkbox (Access tab, Query box), Impromptu
uses the cache query results stored locally and will only query the database when required. This
improves Impromptu’s performance when your reports tend to require the same information
from report to report.

Tip
You can usually achieve the same performance results by using the Cache Query check box as
you can by using thumbnails.
For information about thumbnails, see (p. 102).

Steps
1. From the Report menu, click Query and click the Access tab.
2. Select Database as the data source.
Select the Cache Query Results check box and the Limit Data To check box, and specify the
number of rows.

How Databases are Attached to Catalogs
By default, when you open a report, Impromptu automatically attaches to the associated
database to retrieve the report data, and you can not use the report until data retrieval is
complete. To avoid waiting for large amounts of data to be retrieved, you can disable the option
that automatically attaches Impromptu to the database.
For information about how to open reports, see the Impromptu online Help.

Disable the Auto-Attach to the Database Option
You can turn off the Auto-attach to the Database option (for all databases or for one database) to
view a report without any data. This enables you to verify that you’ve selected the correct report
and check the layout and formatting in the report.
Once you verify the report, you can connect to the database to retrieve the data using the
Connect and Retrieve commands. For information about these commands, see the Impromptu
online Help. In the Index tab, type either
• connecting to the database
• retrieving data

Step to Turn Off Automatic Retrieval
•

Clear the Auto-Attach to the Database When the Catalog is Opened check box in the
General tab of the Options dialog box (Tools menu).

Step to Turn Off Automatic Retrieval for a Specific Database
•

Clear the Connect to the Database check box (Catalog Logon dialog box) when you log on
to a catalog.

Note: If the auto-attach option is turned off for all databases, you can use the Catalog Logon
dialog box to turn the auto-attach option back on for the database.
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Your Copy of the Database
When you create reports for distribution, it is important that reports run efficiently. To enhance
the performance of your reports, you can distribute the copies of the data in any of the following
formats:
• local snapshots
• remote snapshots
• thumbnails
• HotFiles
HotFiles remain linked to the source database and can be updated with changes to the
database. Snapshots and thumbnails are independent of the source, and so are not updated.

Local Snapshots
A local snapshot is a permanent copy of the data stored as part of your report. Like a
photograph, it captures the data as it existed when you created the snapshot. However, because
the data is part of the report, it cannot be used to generate new reports.
Use local snapshots when you
• want to run reports without opening a catalog
• want a static view of the data at a particular point in time
• want to be able to view the report without access to the source database
• do not need to add new tables or data to your report
You can use local snapshots when you want to compare the state of the database at different
times, but do not need to be able to run new reports against the data.
For example, you run a query to generate a report of the current monthly sales. The information
in the report changes daily, but you want to preserve the current results for comparison. You
save the data in this report as a snapshot so you can compare this data to future monthly sales
reports.
For information about creating local snapshots, see the Impromptu online Help. In the Index tab,
type one of
• snapshots
• creating, a local copy of report data

Remote Snapshots
To create a remote snapshot, you run a report against the database using Request Server.
Request Server then saves the results of the query as a result set in the database instead of
locally.
The key differences between remote snapshots and local snapshots are as follows:
• A report based on a remote snapshot does not contain any data. Instead, a reference or
pointer points to the results table in the database.
• A remote snapshot requires access to the database, often on a network, and so is not as
portable as a local snapshot.
• You must have Request Server to create the result set in the database.
Remote snapshots offer many of the same benefits as local snapshots. In addition,
• they can be created unattended during off-peak hours.
• they are created by running a query directly on the database server, and so build much
more quickly than tables built locally. As the size of the database increases, so too does the
performance advantage of a remote snapshot.
• where the result set is particularly large, a remote snapshot maintains a relatively small file
size compared to the local snapshot, because the report does not actually contain any data.
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Save Remote Snapshots as Local Snapshots
You can save a remote snapshot as a local snapshot on your computer so that you can work
without a network connection when you are travelling or when you want to send the snapshot to
other Impromptu users via email.

Steps
1. With the remote snapshot open, from the File menu, click Save As.
2. Specify the Save In location, and the File Name.
3. Click the Save Data with Report option, and click OK.
The snapshot is saved locally and you can modify the report.

Notes
•

•

•

The icon in the Preview box (Open dialog box) and in the lower right corner of the screen
indicates the type of snapshot:
Remote Snapshot
Local Snapshot
You cannot save a remote snapshot as a HotFile. You can reconnect a remote snapshot to
the database by clicking Database (Access tab, Query dialog box). This action is
irreversible.
For information about creating HotFiles, see (p. 103). For information about using HotFiles
to improve performance, see (p. 121).

Tips
•
•

To quickly save a remote snapshot as a local snapshot, click the Snapshot button on the
toolbar.
To update the local snapshot with the most recent data available, refresh it periodically from
the latest remote snapshot.
For information about refreshing local snapshots, see the Impromptu online Help. In the
Index tab, type
•

refreshing snapshots

Thumbnails
When you use thumbnails, Impromptu retrieves only the number of rows you specify and then
saves them temporarily on your computer.
Impromptu attempts to use only the data in the thumbnail when you run a query. If your query
requires information that is not in the thumbnail, Impromptu accesses the database and
retrieves the information required. When you close the current report, the thumbnail is
discarded.
For example, if you work with a thumbnail of 30 rows, Impromptu retrieves the first 30 rows from
the database and then uses the 30 rows as the data source for your queries. If you add a
column to the query, Impromptu must retrieve the new data from the database.
A thumbnail is an efficient way to test your report before running the query against a large
database.
For information about performance and thumbnails, see (p. 120).

Steps to Create Thumbnails
1. From the Report menu, click Query and then click the Access tab.
Note: If you do not see the Access tab, select the Show Advanced Tabs in the Query Dialog
Box check box (Options tab, Tools menu).
2. In the Data Source box, click Thumbnail Of and enter the number of rows you want in the
thumbnail (the default is 30).
3. Click OK.
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Tip
•

To quickly create or remove thumbnails, use the thumbnail toolbar button.

Use HotFiles
A HotFile is a separate locally saved data table that you can use in a report. When you use
HotFiles, Impromptu accesses the data contained in the HotFile and does not go to the
database to retrieve the required information. You can use a HotFile
• as the data source for your report when you want to work without being connected to the
database. For example, if you generate daily reports based on the sales made on the
previous day, you create a HotFile automatically every day that you use as the data source
for the daily reports.
• in your report so that you can include data items that are only available in a separate
database but are not in your catalog. For example, you want to test a theory that expenses
are proportional to salary, and the salary data item is in a separate database. You create a
HotFile for use in your report that contains the salary data item.
If you have the Administrator version of Impromptu, you can join Hotfiles to database tables.
Doing so, however, may have a negative impact on performance.
For information about performance issues, see "Optimize Performance in Impromptu" (p. 115).
Saving historical data using HotFiles offers a number of advantages over independent copies of
the data like thumbnails or snapshots.
Use a HotFile when you want to
• create new reports with the data
• cut, paste, calculate, and filter the data as required
• join to database tables in the catalog
• use it exactly like a database table
• save the data with your catalog

Steps to Create a Hotfile
1. Create or open the report with the data items you want in your HotFile.
2. In the File menu, click Save As.
3. In the Save As Type box, select HotFile.
4. Type the file name and click OK.
Impromptu creates a HotFile with the name you chose, and assigns the extension .ims to
the HotFile.

Tip
•

To update the data or change the data in a HotFile, connect to the database and open the
report with the data items you require. Save the report to replace the existing HotFile.

Steps to Use a HotFile in a Report
1. Open a report, or create a new report with the data items you need.
2. From the Report menu, click Query.
3. In the Data Source box, click HotFile.
4. Click Browse to locate and select the folder that contains the HotFile, and click OK.
All HotFiles in the folder appear in the Data tab (Query dialog box).
5. Double-click the HotFile folder to open it, and double-click the HotFile data items you want
to add to the Query Data box.
6. Click OK.
Impromptu adds the data items you selected from the HotFile to your report.

Mastering Impromptu Reports 103

Chapter 4: Data and Databases

Share HotFiles on the LAN
You can share a HotFile on the LAN. For example, if you just created a report with data that you
think other people can use, you can save the report as a HotFile and copy it to the LAN for
others to use.
Sharing HotFiles on the LAN means everyone can use the same HotFile. For example, if you
have a sales account HotFile created every morning when you open the sales report, and
several people in your department ask you for your daily HotFile, you can copy the HotFile to the
LAN for everyone to use.

Create a HotFile Automatically
You can set up a macro that automatically creates a HotFile each night to save time on lengthy
report execution during business hours. For example, you have a report that contains a
complicated calculation for profit margin that takes 45 minutes to execute. You have to create
this calculation with new data each day. You create a macro in Impromptu that creates a profit
margin report with the new data and saves it as a HotFile overnight using the Cognos
Scheduler.
For information on macros, see the Macro online Help.
You can also use Scheduler to automatically run a report and save it as a HotFile.
For information about using Scheduler to automatically create a HotFile, see the Scheduler
online Help. In the Index tab, type either
• running, remote tasks
• running, unattended tasks
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This chapter discusses catalogs. It tells you
• how catalogs work
• how to make your own catalogs
• what you can modify or customize

What Can You Do with Catalogs?
You can use catalogs to
• view, run, and print reports
• export reports to other applications
• disconnect from and connect to the database
You may also be able to
• create reports
• change the contents of the catalog
• add user classes
If you are the creator of the catalog, you can modify any of the folders and their contents. If you
are not the creator and you are working with a personal copy of a distributed catalog, you may
be able to add folders to your copy and add data items to your folders.

Use Catalogs
The administrator sets up and manages the master distributed catalog and assigns certain
attributes to the catalog. These attributes include
• catalog access
• catalog permissions that define the tasks a particular user class can perform
You will have permission to perform certain tasks according to your user class. For example, the
administrator stores the master distributed catalog on a LAN and gives the Sales user class
access to the catalog, but denies the Sales user class permission to modify the catalog. In this
case, all individuals who are part of the Sales user class share access to the catalog on the
LAN. They can create reports but cannot change the catalog.
The catalog you use will be either a shared catalog or a personal distributed catalog.

Shared Catalogs
A shared catalog is created and maintained by an administrator. Typically, it is stored on the LAN
and is shared by all users with access permission. You cannot edit catalog folders within a
shared catalog; however, depending on your user profile, you may be able to create and edit
reports, or you may be able to view reports.

Personal Distributed Catalogs
A personal distributed catalog is a copy of a master distributed catalog set up and managed by
your administrator. All users with access to the master distributed catalog can create a personal
distributed catalog.
A personal distributed catalog maintains links to the master distributed catalog. When the
administrator changes the master distributed catalog, Impromptu uses these links to
automatically update your personal distributed catalog the next time it is opened. Any changes
you made to your copy are retained when the update occurs.
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If you have a copy of a catalog on your computer, you can disconnect from the LAN and
continue to work with the catalog (for example, on business trips). By default, when you work
with a personal distributed catalog, Impromptu automatically updates your copy when you
reconnect to the LAN.
For information about modifying catalogs, see (p. 107).
Note: Your administrator may have given you permission to make changes to a catalog. The
scope of the changes that you can make depends on the privileges assigned to your user class.

How Catalogs Open
To create or run Impromptu reports other than snapshot reports, you must first open a catalog.
For information about opening catalogs, see the Impromptu online Help.
When you routinely use a specific catalog, you can
• automatically open it using a shortcut on your desktop. Impromptu must not be running
when you use this shortcut
• use a command line start-up switch to start Impromptu and open a catalog
• define the catalog to be automatically loaded when you start Impromptu (Start-up tab,
Options dialog box)

Create a Personal Distributed Catalog
To work with a personal distributed catalog for the first time, you must create it from the master
distributed catalog. In subsequent Impromptu sessions, you open the personal distributed
catalog directly.

Steps
1. Open a master distributed catalog.
2. In the Catalog Logon dialog box, click OK.
The Make a Copy of This Distributed Catalog checkbox (Catalog Logon dialog box) is
automatically selected and grayed out if you are not the creator of the catalog.
3. Specify a name and location for your personal distributed catalog in the File Name box
(Name Your Copy of the Catalog dialog box) and click OK.

How Catalogs You Create are Updated
By default, Impromptu automatically updates your personal distributed catalog each time it is
opened. Tables, joins, user classes, folders, columns, calculations, conditions, and prompts that
are updated from the master distributed catalog are
• overwritten, in the case of tables and joins
• merged, in the case of folders and user classes
• added if they don't already exist
• removed if they were copied from the master distributed catalog in a previous update and no
longer exist in the current master distributed catalog.

Disable Automatic Catalog Updating
You may want to turn off automatic catalog updating to increase your work efficiency. For
example, when you work disconnected from the network, Impromptu displays the message that
it cannot locate the master catalog to update your personal distributed catalog. If you disable
automatic updating, this message does not appear.
You may also want to turn off automatic updating to retain your copy of the master distributed
catalog without updating it with the new master distributed catalog. For example, if the
administrator is making changes to the master distributed catalog over a period of days, rather
than update your copy of the catalog each time you open it, you can turn off automatic updating
until the administrator notifies you that the master distributed catalog is ready. Then you can
update your copy.
If you disabled automatic updating, and you are connected to the LAN, you can manually update
the catalog when it is open.
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Steps to Change Automatic Catalog Updating
1. Open your personal distributed catalog.
2. From the Catalog menu, click Properties.
3. Select or Clear the Update Automatically check box.
4. Click OK.

Step to Manually Update a Personal Distributed Catalog
•

From the Catalog menu, click Update Catalog.

What Can You Change?
If your administrator enabled the Folders command and gave you the required permissions, you
can change the catalog by
• renaming folders and data items
• creating new folders in the catalog
• moving folders and data items to new locations in the catalog
• sorting folders and data items
• storing filters, calculated data items, summaries, and prompts in the catalog
• adding user subclasses and modifying their profiles
You can only change the catalog when all reports are closed.
The types of changes you can make depend on whether you use a shared or distributed
catalog.

Note
•

Many of the features in the following sections are available only if you have administrator
privileges or if your administrator has enabled them for you.

Changes to Shared Catalogs
For a shared catalog, you may be permitted to change any of the existing content and add
content. For example, you may be able to rename a folder, move data items from one folder to
another, and add a new folder. Because the administrator and other users may also have
permission to make changes to the catalog, be careful not to overwrite other users’ changes.

Changes to Personal Distributed Catalogs
For a personal distributed catalog, do not worry about affecting other users’ work. You can only
add content and change the content that you added. You cannot change content copied from
the master distributed catalog, so you do not make changes that will be overwritten when the
catalog is updated.

Upgrade and Update Personal Distributed Catalogs
If you upgrade or change the location of a master copy of a distributed catalog, the personal
copy won't be able to recognize or find it. When you open the personal copy you will get the
Source Catalog Not Found message. If you click Change and select the correct master catalog,
Impromptu will both update and upgrade your personal copy, even if the Update Automatically
On Open checkbox is cleared. If you do not want to upgrade distributed copies of a catalog,
make a backup of your personal copy of the catalog before you upgrade it.

Rename Folders and their Contents
You can rename folders and data items to make their names more intuitive to the catalog users.
For example, you rename the "Qty" data item to "Quantity."
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Steps
1. Make sure that the catalog is open and all reports are closed.
2. From the Catalog menu, click Folders.
Note: If the Folders command is not available, contact your administrator.
3. In the Folders dialog box, select the folder or data item you want to rename.
4. Click Edit. If you selected a calculation or filter condition, the Edit Calculation or Edit
Condition dialog box appears in which you can edit the name and expression for the
selected item.
For information about filters, see (p. 10). For information about editing calculation
expressions, see "Create Calculated Fields" (p. 32).
5. Click OK to close the dialog box, and click OK again to close the Folders dialog box.

Note
•

Any folders and data items that you do not have permission to modify are marked with the
Denied icon.

Create Catalog Folders
You can reorganize the contents of your catalog by creating new folders.

Ways to Create Catalog Folders
To add folders to a catalog, you can create either
• an empty folder from scratch
• a folder from a report
If you have a report that contains complex calculated data items, summaries, and filters, you
can save time by generating a folder from the report.
Note: You can also copy a folder using the Copy button (Folders dialog box).

Examples
•
•

You create a folder called "Favorite Data Items" that contains the 20 data items you use
frequently. You can put data items from different folders in your new folder.
You have a report that contains some columns, including a summary and a complex
calculation. The report is filtered. You create a folder from this report and the folder contains
all the data items in the report.

Steps to Create an Empty Folder
1. Make sure that the catalog is open and all reports are closed.
2. From the Catalog menu, click Folders.
Note: You can move folders any time. If you want the new folder to appear in a specific
location, select a folder, and the new folder appears before the selected one. Otherwise, the
new folder appears at the end of the list.
3. In the Folders dialog box, click New Folder.
4. In the New Folder dialog box, type the name of the new folder in the Name box, and click
OK.

Steps to Generate a Folder from a Report
1. Make sure that the catalog is open and all reports are closed.
2. From the Catalog menu, click Folders.
Note: The Folders command is available if you are the creator of the catalog or if your
administrator gave you the required permission. If the Folders command is unavailable,
contact your administrator.
3. If you want to store the new folder in a specific folder, double-click that folder to open it.
4. Click Generate.
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5. In the Generate Folder Based On box, click Report and then click OK.
6. In the Select Report dialog box, locate and select the report containing the desired columns
and conditions and click Open.
7. Click OK.

Tip
•

To remove unnecessary folders and items, click Folders from the Catalog menu. Then select
the folder or data item you want to remove. Click Cut and click OK.

Move Folders and their Contents
You can move folders and data items to new locations. For example, you move the Sale Amount
item from the Order Details folder to the Orders folder.

Steps
1. Make sure that the catalog is open and all reports are closed.
2. From the Catalog menu, click Folders.
Note: You can move folders any time. If you want the new folder to appear in a specific
location, select a folder, and the new folder appears before the selected one. Otherwise, the
new folder appears at the end of the list.
3. In the Folders dialog box, do one of the following:
•

If you are moving a folder, select the folder you want to move.

•

If you are moving a data item in a folder, double-click the folder where the data item is
located, and then select the data item you want to move.

4. Click Cut.
5. Do one of the following:
•

If you are moving a folder, select the folder above which you want to paste the cut folder.

•

If you are moving a data item, select the folder into which you want to paste the item.

6. Click Paste and click OK.

Tips
•
•
•

To copy a folder or data item rather than move it, select it and click Copy. Then open the
destination folder and click Paste.
To better view long lists of folders and data items, resize the Folders dialog box.
To sort folders and folder items, click the Sort icon above the Catalog folders box. You can
sort in ascending or descending alphabetical order, or restore the default sort order.

Store Filters in Catalogs
You store complex or frequently-used filter conditions in the catalog. When you need to use a
filter, you can select it from the catalog rather than recreate it. You also control the definition of
the filter, so all users of this catalog have the correct filter definition.
For information about creating filters, see (p. 11).
For example, you create a condition so you see only data for your sales region when you use the
condition. If a new area is added to the region, add the new area to the condition once, and all
reports change to show the new area in the region.

Steps
1. From the Catalog menu, click Folders.
2. If you want the new filter to appear in a specific location, select a folder, and the new filter is
added to it. Otherwise, the new filter appears at the end of the list.
Note: You can move filters any time.
3. In the New box (Folders dialog box), click Condition.
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4. In the New Condition dialog box, type a name for the condition in the Name box.
Note:=Use this name to identify the condition when you use it in reports.
5. Build an expression.
6. Click OK to close the New Condition dialog box.
7. The new filter appears in the Catalog folders box.
8. Click OK.

Tip
•

To remove a catalog condition, select the condition you want to remove in the Folders dialog
box, and click Cut.
For information about creating conditions, see (p. 43). If you are responsible for deploying
catalogs and want more information about including conditions in catalogs, see the
administrator.

Change a Predefined Filter Condition
If you have the necessary permissions, you can edit or rename predefined filter conditions.

Steps
1. Close any open reports.
2. From the Catalog menu, click Folders.
3. Select the condition you want to change, and click Edit.
4. Do one of the following:
•

If you want to change the condition, select the part of the condition you want to change,
and click OK.

•

If you want to change the name of the condition, type a new name for the condition in
the Name box.

5. Click OK to close the Edit Condition dialog box, and click OK again.
All reports that use this condition will automatically change when you change the condition.

Store Calculated Data Items and Summaries in Catalogs
You can save time by storing complex or frequently-used calculations and summaries in the
catalog. When you need to use a calculation or summary, you can select it from the catalog
rather than recreate it. You also control the definition of the calculation, so that users of this
catalog who need this calculation or summary in their query have the correct calculation
definition. You can use these predefined calculations or summaries on their own or as part of the
definition of another calculated data item you create.
You can store calculated data items and summaries in a catalog as follows:
• If a calculated data item or summary exists in a saved report, save the entire report as a
catalog folder, then delete the data items you do not want in the folder.
• Create a new calculated data item or summary directly in a catalog folder.
For information about creating calculated data items, see "Create Calculated Fields" (p. 32). For
information about creating summaries, see (p. 24).
For example, you have a report that contains a calculated data item called Profit. This calculated
data item subtracts Prod Cost from Prod Price for each product. You want to store this
calculated data item in the catalog for use in other reports you create with the same catalog.

Steps to Store Existing Calculated Data Items and Summaries
1. Make sure that the catalog is open and all reports are closed.
2. From the Catalog menu, click Folders.
3. If you want the item to appear in a specific location, select a folder, and the item is added to
it. Otherwise, the item appears at the end of the list.
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4. In the Folders dialog box, click Generate.
5. In the Generate Folder dialog box, click Report, and click OK.
6. Select the report that contains the calculated data item or summary you want to add to the
catalog, and click Open.
Note:=A new folder containing the report you selected appears in the Catalog Folders box.
The folder name contains the report path and file name.
7. In the Catalog Folders box, double-click the new folder.
8. Select the data items you do not want to add to the catalog.
9. Click Cut to delete the unwanted data items, and click OK.

Tip
•

To rename the new folder, select it in the Catalog Folders box (Folder dialog box) and click
Edit. Type the name in the Name box (Edit Name dialog box) and click OK.

Steps to Create and Store Calculated Data Items and Summaries
1. Make sure that the catalog is open and all reports are closed.
2. From the Catalog menu, click Folders.
3. If you want the item to appear in a specific location, select a folder, and the item is added to
it. Otherwise, the item appears at the end of the list.
4. In the New box (Folders dialog box), click Calculation.
5. Type a name for the calculation in the Name box (New Calculation dialog box).
6. Build an expression.
For information about creating expressions for calculated data items, see "Create
Calculated Fields" (p. 32).
7. Click OK to close the New Calculation dialog box, and click OK again.

Note
•

If you are responsible for deploying catalogs and want more information on including
calculations in catalogs, see your administrator.

Tips
•

•

To rename the calculated data item or summary you stored in the catalog, select it in the
Catalog Folders box (Folders dialog box) and click Edit. Type the name in the Name box
(Edit Calculation dialog box) and click OK.
To change a calculation you stored in the catalog, select the calculated data item you want
to change, click Edit, change the expression in the Edit Calculation dialog box, and click OK.
Click OK again to exit from the Folders dialog box. When you change the calculation, all
reports that use this calculation automatically change.

Create and Store Prompts in Catalogs
You can create prompts in a catalog and reuse them in different reports you create with the
catalog. Each time you want to include a prompt in a report, select it from the catalog rather than
re-create it. You can store prompts in a catalog by creating a prompt directly in a catalog folder.
For information on types of prompts, creating and editing prompts, and organizing prompts
within a report, see (p. 16).
For example, you have a report containing a picklist prompt that requires you to select a branch
from a list of all branches in the database. You frequently filter reports by branch, so you decide
to store this prompt in the catalog. You can later add this prompt to any report so you can quickly
filter on a branch.

Steps to Create and Store Prompts
1. Make sure that the catalog is open and all reports are closed.
2. From the Catalog menu, click Folders.
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3. If you want the prompt to appear in a specific location, select a folder, and the prompt is
added to it. Otherwise, the prompt appears at the end of the list.
4. In the New box (Folders dialog box), click Prompt.
5. Type a name for the prompt in the Name box (Prompt Definition dialog box).
Note:=You will use this name to identify the prompt when you use the prompt in reports.
6. In the Data Type box, select the type of prompt you want.
The lower half of the dialog box changes depending on the type of prompt you select.
7. Type a message in the Message box.
This is the message that appears with the prompt.
8. Complete the lower portion of the dialog box, click OK, and click OK again to close the
Folders dialog box.
The prompt is now in the catalog. You can use it in any report that you create with this
catalog.
For information about creating different types of prompts, see (p. 16).

Note
•

If you are responsible for deploying catalogs and want more information on including
calculations in catalogs, see your administrator.

Tips
•

•

To rename the prompt you stored in the catalog, select it in the Catalog Folders box (Folders
dialog box) and click Edit. Type the name you want in the Name box (Prompt Definition
dialog box), and click OK.
To change a prompt you stored in the catalog, select the prompt you want to change in the
Folders dialog box, click Edit, change the prompt and click OK. Click OK again to exit from
the Folders dialog box. When you change a prompt, all reports that use this calculation
automatically change.

Add User Classes
A user class is a group of users who need access to the same data and have the same access
privileges. The administrator creates the catalog and user classes. Other people in an
organization may also create and maintain user classes for the employees in their own
department or area.
You can add user classes to a catalog if you created the catalog or you are working with a
personal copy of a distributed catalog and your administrator gave you the privilege to add and
modify user classes.

For Example
You create a personal copy of a distributed catalog. You did not create the master distributed
catalog, so you can only add users as subclasses of your user class. Subclasses inherit the set
of privileges and restrictions from the immediate parent class. This set of privileges is known as
the user profile.
Suppose you are in the user class called Marketing that enables you to see marketing
information for all countries. You decide to add the user classes Europe, North America, and
Asia-Pacific. You set up the user classes so users in each class can only see regional
information. Each user class is added to the User Class tab as a subclass.
Europe inherits the privileges and restrictions from Marketing, so if Marketing is denied access
to a particular catalog folder, then Europe is also denied access to the folder. You can modify the
user profile for any user class you create.

Steps
1. Close all open reports.
2. From the Catalog menu, click User Profiles.
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3. In the User Classes tab (User Profiles dialog box), select the user class to which you want to
add a subclass, and then click Add. For example, if you want to add a user class under
Marketing, select Marketing.
4. In the Class Name box, type a meaningful name for the user class.
5. If you want the users of this user class to enter a password in order to access the catalog,
type a password in the User Class Password box.
6. Click OK.
For information about editing the user profile for a user class, see the Impromptu Administrator
version online Help or contact your administrator.

Notes
•
•

You can add user classes with the Impromptu User version or the Impromptu Administrator
version.
If you did not create the catalog, you can only add subclasses.

Tips
•
•
•

To edit the name or password of a user class, select the user class, and then click Edit.
To remove a user class, select it and click Remove. You cannot remove or rename the
Creator user class but you can change the password for it.
To better view a long list of users, resize the User Profiles dialog box.

Add User Profiles to Distributed Catalogs
User profiles inherited from the master catalog are read-only in the distributed copy. When you
update the master catalog, user profiles inherited from the master catalog are destroyed in the
copy and replaced by those in the master catalog.
User profiles that users add to the distributed catalog are retained provided that the parent user
profile inherited from the master catalog still exists. The settings in these local user profiles are
retained, provided that they don't conflict with their parent user profile settings. Conflicts arise
when the constraints, table/column access, or client-server balancing options applied to the
parent profile are more restrictive than the child. In these cases, the child user profile is changed
to match the more restrictive configuration of the parent. Conflicts also arise when a user adds a
new user profile to the distributed copy that has the same name as a new user profile in the
master catalog. When you update the master catalog, the user profile in the users copy is
overwritten by the user profile from the master catalog.
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This chapter discusses some of the ways you can improve the performance of your Impromptu
reports, whether you are updating a report or building a new one.

Create Efficient Reports
To maximize the performance of Impromptu, you try to create the most efficient reports possible
by optimizing
• queries and reports
• the balance between client and server processing
• summaries
• filters
• sorting
• If/Then/Else and Lookup statements
• OLE (Object Linking and Embedding)
• report formatting commands
• the use of alternative data sources
• the use of outer joins
• data retrieval limits
• connection time to the data server
• the use of accessible reports for disabled users
When you query the database, Impromptu generates one or more SQL statements and sends
them to the database. Where required, Impromptu complements the capabilities of the database
with its own local SQL-92 based query engine.
To optimize performance, you must
• run the query as few times as possible
• make the database do most of the query processing

The Difference Between Queries and Reports
A query is a question you define and send to the data source to retrieve the data.
A report is an organized and formatted view of the data the query retrieved.
The report does not have to include all of the data items you specify in the query. You indicate
which query data items you want to appear in the report by selecting the items and clicking the
Mark for Insertion button (Query dialog box, Report menu).
For example, you create a query that includes the data items Product, Product Price, Product
Margin, and Total Sales Amount. You create a report that only shows Product, Product Price,
and Product Margin by hiding the Total Sales Amount column. You then create a report for your
manager that shows only Product and Total Sales Amount by hiding the Product Price and
Product Margin columns. You saved time because you only had to run the query once to retrieve
all the data items.
When you first add data items to the query, this icon indicates they will appear in the report.
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After you run the query, data items in the query have this icon whether or not they are included
in the report.

Click to specify
whether you
want the
selected data
item to appear in
the report.

Select all the data items and group, sort, and filter in the Query dialog box before you run the
query. This reduces the amount of data retrieved from the database, the amount of processing
that takes place locally, and the number of times Impromptu queries the database.

Notes
•
•

If you are using the Blank template, none of the data items in the query appear in the report
until you add a frame to the report and mark the data items for insertion into the frame.
If you are using any template other than the Blank template, all of the data items in the
query appear in the report by default. The data items are added to the primary frame, which
by default is a form frame, unless you select a frame.

Client/Server Balancing
The overall goal of performance is to provide the best response time with the least impact on
available resources. To achieve this goal, process as much as possible on the database server,
and avoid local processing on your computer. Consider all of the performance issues and
guidelines described in this chapter when you query the database.
Impromptu has three client/serving balancing options:
This option

Does this

Database only

Runs queries completely on the
database.

Limited Local Processing

Runs queries with some
processing on your computer.

Flexible Processing

Processes on the database only,
or on the database and on your
computer depending on how
Impromptu decides to optimize
the processing.
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Note
•

The Query Processing options (Client/Server tab, Query dialog box) are only available if you
are connecting to a database server, such as Oracle or Sybase. If you are not connecting to
a database server, the Client/Server tab shows the message "Local database. Flexible
Processing assumed."

Which Client/Server Options are Most Efficient?
The Database Only or Limited Local Processing options are the most efficient options because
they force processing as much as possible on to the database and prohibit these activities:
• sorting on your computer
• using extended summaries
For information about extended summaries, see the Chapter 10 in the Administrator’s
Guide.

Who Sets the Client/Server Balancing Option?
Your administrator sets the client/server balancing option for your user class. The client/server
balancing option can also be defined in templates you use. For the standard templates supplied
with Impromptu, the client/server balancing option is set to Limited Local Processing
(Client/Server tab, Query dialog box).
If you have appropriate access, you can change the client/server balancing option in the
Client/Server tab (Query dialog box). If the Client/Server tab (Query dialog box) is unavailable,
from the Tools menu, click Options, and select the Show Advanced Tabs in the Query Dialog
Box check box (General tab).

Note
•

If your administrator gave you the privilege to add or modify user classes, you can change
the client/server balancing option for subordinate user classes. You can make these
changes using the Client/Server tab (User Profiles dialog box).
When you use this tab, you can only change the client/server balancing option for your own
user class if you created the catalog (user class: Creator).
For information about user classes, see (p. 112).

Summaries
Retrieve Summary Data Items
If you create a summary report, retrieve less data by only including summary data items (not
details) in the query.
For example, you need a report that shows the total sales amount for each country. Rather than
retrieving all of the details, then summarizing, you can include only the grouped data item
Country and the summary data item Total Sales Amount in the query. Only the summarized
values are retrieved from the database.

Put Summaries in Footers
To reduce the amount of processing on your computer, put summaries in footers. Avoid putting
summaries in headers. Summaries in headers are called extended summaries and they are
processed on your computer.
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Notes
•
•

Running summaries, such as Running-Total, and moving summaries, such as Moving-Total,
are special cases. You can put them in a separate column without affecting performance.
Anytime a report has footers that contain summaries, one of the following occurs:
•

processing takes place on your computer

•

•

Impromptu sends multiple queries to the database, since the database may not be able
to handle the query in a single pass.
If you set the Flexible processing option, Impromptu makes two passes and combines the
results. If you set the Limited Local processing option, Impromptu retrieves the minimum
required data from the database and summarizes on your computer.
Depending on how the governors are set by your administrator, you may be able to change
the processing options.

Sorting on Database Summaries
Sort on summaries that can be processed by the database, such as total, average, count,
maximum, and minimum.
The following summaries are available in Impromptu only, which means they are processed on
your computer:
•

moving-average

•

moving-total

•

percentage of the total

•

percentile

•

quantile

•

rank

•

running-total

•

running-average

•

running-count

•

running-difference

•

running-maximum

•

running-minimum

•

tertile

Associating Summaries with Data Items
Associate a summary with a specific data item rather than using Automatic (location-dependent)
association. To do this, edit the summary’s definition and add the FOR clause.
For information about changing a summary’s association, see (p. 29).

Filters
Changes to the Filter
To optimize performance, minimize the number of changes you make to the filter. If you use a
database as the data source, each time you modify the filter, the query runs against the entire
database.
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Database Summaries
Filter on summarized data items that are processed in the database, such as total, average,
count, maximum, and minimum. When you filter on summaries that are processed on your
computer, the summaries are usually processed locally. However, adding a filter may change
where the summary is processed. Selecting the client/server option (Client/Server tab, Query
dialog box) also impacts the processing location of the summary filter.
For example, you define a summary filter that is processed on your computer when the Flexible
Processing option (Client/Server tab, Query dialog box) is set. You can split the same summary
filter into two queries and the queries process on the database when the Limited Local
Processing option (Client/Server tab) is set.

Impromptu Functions
Avoid filtering on calculated data items that use Impromptu functions.

Non-Indexed Columns
Avoid sorting on non-indexed columns because it requires processing on your computer. Your
administrator can set an option for your user class in the Governor tab that prohibits sorting on
non-indexed columns.
Avoid filtering on non-indexed columns as processing is longer than when you filter on indexed
columns. To know whether columns are non-indexed, refer to your database schema, or see
your administrator.

Impromptu Functions
Avoid sorting on calculated data items that use Impromptu functions because it requires
processing on your computer.

If/Then/Else and Lookup Statements
Avoid using If/Then/Else or Lookup statements because processing takes place on your
computer.

Notes
•
•

If you use a database that supports CASE structure, using If/Then/Else or Lookup
statements is not a performance issue because processing takes place on the database.
If you use a database that supports CASE structure, but you include Impromptu functions in
the filter expression, the filter is processed on your computer.

To find out if your database server supports CASE expressions, see your database
documentation.

Functions
A calculated data item is processed on your computer if it uses Impromptu functions. Avoid
filtering and sorting on any calculated data item that is processed locally because the sort or
filter takes place on your computer along with the processing of the calculated data item.
You can see the type of function and where it is processed by looking at its icon in the Available
Components box (Calculation dialog box):
• Impromptu functions are processed locally on your computer.
• Database-only functions are processed on the database.
• Combination functions are processed on the database whenever possible.
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Notes
•
•

If your catalog uses a local database, you only see Impromptu functions in the Available
Components box.
Only the functions that your database supports appear in the Available Components box.

If Impromptu processes functions locally that are not supported by the database, then the
database results and the results processed on your computer must be merged before
Impromptu can produce the report. This impacts performance.

Report Formatting Commands
Scan Data for Best Fit
You may notice a performance decrease when you use the Scan Data for Best Fit option (Size
command, Format menu). Each time the query runs, Impromptu must scan the number of rows
you specify to set the width of the frame to the widest data value within the specified number of
rows. Instead, specify a width size.

Fit to Page
If you use this feature and the data changes, the dynamic nature of this option may affect
performance.
For information on using the Fit to Page feature, see the Impromptu online Help. In the Index
tab, type
• fit to page

Use Alternative Data Sources
Instead of querying the entire database, you can use a thumbnail, snapshot, or HotFile as the
data source to test your query. Once you are satisfied with the results, you can return the data
source back to the database.

Test Your Queries Using Thumbnails
A thumbnail is the most efficient method for testing your query. A thumbnail is a temporary
cache or file of the retrieved data on your computer. You can create a thumbnail when you open
or create a report. A thumbnail can include all the report data or you can limit it to a certain
number of rows.
For example, you specify that the thumbnail should retrieve the first 500 rows from the database.
Once the thumbnail contains the set number of rows, it stops querying the database.
If you perform local calculations, sort, group, or apply a more restrictive filter, Impromptu
performs these actions locally without accessing the database.

Notes
•
•

•

•
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The default number of rows that the thumbnail retrieves is 30.
If you add a new database column, add a calculated column that uses database functions,
or if you make the filter less restrictive, Impromptu moves the processing back to the
database.
Impromptu does not retrieve more rows than your administrator has specified in the
governor limit for your profile. For example, if you set a thumbnail to retrieve 500 rows, but
your administrator has set a governor limit of 30 rows, Impromptu presents a message
indicating that you exceeded the governor restrictions for your profile, and only retrieves 30
rows.
When you close a report that uses a thumbnail, the data is discarded.
For information about creating thumbnails, see (p. 102).
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Improve Performance Using Snapshots
You can improve performance by following these guidelines for snapshots:
• Do not create huge snapshots. While the number of rows varies, depending on the
database and the network you use, 5,000 to 8,000 rows is generally the maximum practical
limit for a snapshot, especially if you are sorting. Also, if the snapshot contains a lot of data,
it will require more local disk space.
• Check your other data access settings to ensure that they reflect the amount of data that
you want, before you create a snapshot. For example, if you select the Limit Data To check
box and set a limit of 20 rows in the Access tab (Query dialog box), your snapshot will only
access 20 rows.
• Before you create a snapshot, use the Filter tab (Query dialog box) to filter out any data you
do not need.
• Perform all the sorting and grouping you require for a report before you create a snapshot.
Because of the indexing method used in snapshots, operations such as sorting are not as
efficient when a snapshot is the data source as they are when the database is the data
source. You may want to perform these operations while you are still attached to the
database rather than with the snapshot.
• Ensure you have all the data you need to perform any action you are planning. You will not
be able to access any data that is not in the snapshot.
• A report that uses a snapshot as its data source no longer has access to the database, so
your data is not updated until you re-create the snapshot or redirect your query to the
database.
Note: In snapshots, the numeric data is encoded, not encrypted, and character data can be
read in some text editors. If security is an issue, you should take extra precautions when using
snapshots. You may choose to use HotFiles instead, which have an encrypt and decrypt
function.

Improve Performance Using HotFiles
A HotFile is a separate local data table you can use in a report. You can use a HotFile as the
data source by attaching a HotFile to a report. Since a HotFile resides on your computer, you
can reduce network traffic and improve the report’s execution time.
Use a HotFile only if you do not have direct access to the data; that is, when the data is not in
the same database that your catalog accesses.
You can
• improve query performance and report execution using HotFiles.
For example, if you use a large static dataset for many of the reports you create, you can
create a HotFile with this data, and use the HotFile data rather than querying the data on
the database.
• improve report execution using precalculated HotFile tables. Precalculated HotFile tables
contain complex calculations that obtain certain calculated values.
For example, if you use complicated calculations for your reports that only change on a
monthly basis, you can create precalculated HotFile tables at the beginning of the month,
and use the HotFile data during the month rather than recalculating the data over and over
again.
For information about creating HotFiles, see (p. 103).
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How Outer Joins Affect Your Work
Joins link related data contained in separate tables. Your administrator can provide information
about the various types of joins. The type of join that is most likely to affect your work is the outer
join. You may notice
• unexpected results. A report that retrieves data from a particular table may, as a result of an
outer join, also retrieve data from some other table. This means you could run a report and
get more or different data than what you expected.
• that expressions and filters are affected. An outer join can cause a Null value to be returned
when data is not retrieved from a table. Null is not the same as zero. For example
Null + 10 = Null
zero + 10 = 10.
• changes in performance. More SQL statements may be generated. An outer join could
cause more local processing at the client.
•
that you must carefully select the columns for the desired result if your catalog includes
outer joins between tables because the order in which you select columns for your query
affects the SQL that Impromptu generates.
Joins are defined by your administrator. For more information about joins, see your
administrator.

What is an Outer Join?
An outer join causes data to be retrieved from one table even if there are no matching rows in its
related table.
The results of a query will differ depending on whether or not there is an outer join relationship
between two tables.
For example, you have two tables called "Employees" and "Expenses." You run a query to get a
list of employee expenses for the past month.
Outer Join
exists?

Results of the above query

No

A list of employees who had expenses this past
month.

Yes

A list of all employees, regardless of whether
they had expenses this past month. The
expenses for any employees who did not
actually have expenses will appear as Null.

When Not to Use Outer Joins
Your administrator may choose not to use outer joins if
• the data model never has optional relationships between tables
• it doesn’t matter if rows are discarded when no matches are found in another table

Override Outer Joins
If your administrator has made the option available, you can override all outer joins in a report.

Step
•

122 Impromptu (R)

Select the Include the Missing Table Join Values (Outer Join) check box (Access tab, Query
dialog box).
All rows will be displayed even when there is no corresponding data in each table.
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You may be able to accomplish the work of an outer join by using
• sub-reports, to link data between a parent query and a child query.
• drill-throughs, to link two reports together and make it easy to move back and forth.
• alias tables, to create an alias table (instead of setting up an outer join to the original table)
and link to it when the request for that data is an exception.

Outer Joins Examples
Suppose your database contains two tables.
Table 1
Sales Rep.

Table 2
Sales Rep. No.

Sales Rep. Name Total Sales

Bjorn Flertjan 1

Bjorn Flertjan

$115,138.83

Gus Grovlin

Bill Smertal

$28,707.31

2

Left Outer Join
To get a report that shows all the sales representatives who have a Sales Rep. No., including
those who didn’t make any sales, your administrator could set up a left outer join and define
Table 1 as the left outer table. The report shows all the sales representatives from Table 1.
Sales Rep.

Sales Rep. No.

Total Sales

Bjorn Flertjan

1

$115, 138.83

Gus Grovlin

2

NULL

Right Outer Join
To get a report that shows the sales representatives who actually made sales, your
administrator could set up a right outer join and define Table 2 as the right outer table. The
report shows all the sales representatives from Table 2.
Sales Rep.

Sales Rep. No.

Total Sales

Bjorn Flertjan

1

$115,138.83

Bill Smertal

NULL

$28,707.31

Full Outer Join
To get a report that shows all sales representatives, your administrator could set up a full outer
join between the Table 1 and Table 2. The report shows all sales representatives from both
tables.
Sales Rep.

Sales Rep. No.

Total Sales

Bjorn Flertjan

1

$115,138.83

Gus Grovlin

2

NULL

Bill Smertal

NULL

$28,707.31

Limit the Data
When you use the Limit Data To check box (Access tab, Query dialog box), Impromptu retrieves
only the specified number of rows.
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Minimize Connection Time
Another option available to the administrator is the "Minimize Connection Time to the Database"
check box (Client/Server tab, User Profiles dialog box). When this check box is selected,
Impromptu creates a temporary cache for query results and disconnects from the database as
soon as the report is run.

Create Separate Accessible Reports
Impromptu can generate reports that contain accessible information for disabled users.
However, this can degrade performance. To reduce performance issues, create two instances of
the report, one with and one without accessible information. Provide accessible reports only to
those users who require them.
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Customize Impromptu to suit your everyday reporting needs, and save valuable time for yourself
and other users in your organization. You can customize menus, toolbars, and toolbar buttons.
You can also set up launch buttons and launch menu commands.
You can distribute your customized menus and toolbars to other users in your organization.

Customize Menus
You can create your own menus and add the commands you need. When you change default
menus or create new ones, the changes are stored in an .mnu file, which is updated each time
you make a change.
Note: Customized menus appear only when a report is open.

Steps
1. From the Tools menu, click Customize.
2. Click the Menus tab.
A list of menu commands appears in the Available Commands box. The Menu Layout box
shows the current menu structure.
3. You can do any of the following.
Goal

Action

Add menus, submenus, menu
separators, or menu
commands

Drag what you want to add from
the Available Commands box to
the Menu Layout box.

Show only those menu
In the Category box, click the
commands found on a specific name of the menu. For example,
menu
click File to show only those
commands found on the File
menu.
Rearrange menu commands

In the Menu Layout box, drag
menu commands from one
menu to another.

Delete a menu or menu
command

In the Menu Layout box, click the
menu or command and then
click Remove.

Change the name of a menu
command

In the Menu Layout box, click the
menu command. Under Menu
Item Properties, in the Name
box, type a new name.
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Goal

Action

Change the shortcut key
combination of a menu
command

In the Menu Layout box, click the
menu command. Under Item
Properties, in the Shortcut box,
enter a new combination of keys.
If a combination of keys is
currently assigned to another
menu command, a message will
appear in the message pane that
the shortcut is in use.

Create a menu accelerator key In the Menu Layout box, click the
menu command. Under Item
Properties, in the Name box,
type an ampersand (&) and the
name of the menu command.
For example, &New makes N the
accelerator key.
4. Click OK.

Tips
•
•

You can add a separator line between groups of related commands to organize a menu.
To restore the default menus, click the Reset button.

Set Up a Launch Menu Command
You can add a launch command to any menu. You can configure each launch menu command
to run a different program or macro.

Steps
1. From the Tools menu, click Customize.
2. Click the Menus tab.
3. Click New.
The New Launch Item dialog box appears.
4. In the Name box, type a name for the launch menu command.
5. In the Description box, type a tooltip for the menu command.
6. In the Type box, click Macro or Application.
7. In the Command box, browse to the location of the macro or application.
8. In the Parameters box, enter any parameters you want to add to the macro or program.
9. If you want to minimize the current window when you run the program or macro, select the
Minimize Application Before Launching check box.
10. Click OK.
Tip: To edit a launch menu command, click it in the Menu Layout box, then click Modify.

Customize Toolbars and Buttons
You can show, hide, create, delete, and modify toolbars. Any changes you make are stored in an
initialization file on your computer, for the current user.

Show or Hide Toolbars
You can show or hide toolbars so that you see only what you need.
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Steps
1. From the Tools menu, click Customize.
2. Click the Toolbars tab.
A list of toolbars appears in the Available Toolbars box.
3. Select the check box beside each toolbar that you want to appear.
Tip: You can remove a toolbar from the Available Toolbars box by clicking the toolbar name,
and then clicking Remove.
4. Click OK.
The settings are saved for your computer.

Tips
•
•

To show tooltips for each toolbar, select Show Tooltips.
To show flat-style toolbars, select Show Flat Style.

Create a Custom Toolbar
You can create a custom toolbar that contains only the tools you need.

Steps
1. From the Tools menu, click Customize.
2. Click the Toolbars tab.
3. Click New.
4. In the Toolbar Name box, type a name for the toolbar.
5. In the Initial Location box, click a default location for the toolbar.
6. Click OK.
The name of the new toolbar appears in the Available Toolbars box. You can now add
buttons to the new toolbar.
Tip: To reset the toolbars to the default settings and delete any custom toolbars, on the Menus
tab, click Reset. You can also reset the toolbars by deleting the tbinfo.ini file or moving it to
another folder.

Customize Toolbar Buttons
You can change the buttons on a default toolbar or add buttons to a custom toolbar. You can
also remove buttons from any toolbar.
Tip: To learn what a button does, select its name in the Available Buttons box, then look under
Button Description.
For example, you are in charge of imports for a governmental department. You regularly
distribute reports to offices in Great Britain, which requires that you convert your reports so that
they use British pounds. You want to customize your toolbar to include the Currency button.

Steps
1. From the Tools menu, click Customize.
2. Click the Toolbar Buttons tab.
3. Drag the buttons you want to add from the Available Buttons box to a toolbar.
Tips
•

To change the selection of buttons use the Category box. For example, click File to
show only those buttons found on the File toolbar.

•

To add a space between buttons, add a separator button (found under the
Miscellaneous category).

4. Drag the buttons you want to remove off an existing toolbar.
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5. Click OK.
Tip: To return to the original settings, click Reset on the Toolbars tab.

Set Up a Launch Button
You can add up to 64 launch buttons to a custom toolbar. You can configure each button to run a
different program or macro.
For example, you are the manager of a government department. You keep the data source files
for your reports in Microsoft Excel spreadsheets. While reviewing your reports, you want to look
at your data source files. You customize your toolbar to run Excel directly from PowerPlay,
Impromptu, or Transformer.

Steps
1. From the Tools menu, click Customize.
2. Click the Toolbar Buttons tab.
3. In the Category box, click Miscellaneous.
The buttons in the Miscellaneous category appear in the Available Buttons box.
4. Click Toolbar Launch Button, and drag it to a toolbar.
5. Double-click the new launch button.
The New Launch Item dialog box appears.
6. In the Name box, type a name for the launch button.
7. In the Description box, type a brief description of what the button does.
The tooltip appears when you pause the pointer over the button.
8. In the Type box, click Macro or Application.
9. In the Command box, browse to the location of the macro or program.
10. In the Parameters box, enter any parameters you want to add to the macro or program.
11. If you want to minimize the current window when you run the program or macro, select the
Minimize Application Before Launching check box.
12. In the Image box, click the image you want to appear on the new launch button.
13. In the Path box, browse to the location of the button image.
14. Click OK.
Tip: To change the settings of a launch button, ensure the Customize dialog box is closed, and
Ctrl+click the launch button and then make changes in the Modify Launch Item dialog box.

Distribute Custom Menus and Toolbars
You can distribute custom menus and toolbars to other users.
Toolbars are stored in the tbinfo.ini file, and menus are stored in the menuinfo.mnu file in the
following location:
<install_dir>\Documents and Settings\<user_id>\Application
Data\Cognos\cern\<filename.exe>.

For example, if you are running Impromptu you would find tbinfo.ini and menuinfo.mnu in the
following location:
<install_dir>\Document Settings\<user_id>\Application Data\Cognos\cern\impadmin

Example
You are the director of a government department that oversees transportation policy. You
worked closely with your systems analyst to build customized menus and toolbars that suit your
departmental needs. You want to distribute these menus and toolbars to others in your
department.
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Steps
1. Place a copy of the files that contain the settings for the custom toolbars and menus in a
location that users can access.
2. From the Tools menu, click Customize.
3. Click Load.
4. Browse to the location of the tbinfo.ini file or the menuinfo.mnu file to be imported.
5. Click OK.
The custom menus or toolbars appear.
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Index
Symbols
.ini files, 128
.mnu files, 125, 128

A
Access tab, viewing, 102
accessing databases, 99
adding
dynamic picture frames, 69
user classes, 112
apply conditional formatting, 44
association
automatic, 25
changing, 29
fixed, 27
auto-grouping, 10
automatic
association, changing, 30
catalog updating, 106
creation of HotFiles, 104
data retrieval, 100
grouping, 10

B
Binary Large Objects (BLOBs), 68
blanks, removing, 15
buttons
customizing, 126, 127

C
calculated columns, 76
calculated data items
adding to catalogs, 32
complex, 32
creating, 32
description, 32
overview, 32
simple, 32
storing in catalogs, 110
using prompts, 22
calculated placeholders, creating, 56
calculation
average of two dates, 37
average totals for groups, 35
creating characters items from numbers, 39
creating dates, 37
date intervals, 34
extracting years, months, days, 36
if/then, 39
if/then/else, 39, 119
lookup, 119
number of days remaining in period, 38
percentile, 34
rank, 34
summary, 13

calculation (cont'd)
summary before applying a filter, 13
using, 33
using the current date, 37
cascading prompts, creating, 21
case sensitivity, type-in prompts, 16
catalog
attributes, 105
changing, 9, 107
creating and storing prompts in, 111
folders, copying, 109
folders, creating, 108
folders, moving, 109
opening, 106
permissions, 105
personal distributed, 105
personal distributed, changing, 107
prompts, 18
purpose, 99
shared, 105
storing calculated data items in, 110
storing filters in, 109
storing summaries, 110
storing summaries in, 110
types, 105
updating, 106
updating automatically, 106
using, 99, 105
changing
a crosstab to a list report, 78
summary association, 29
character items, creating from a number, 40
chart frames
adding data, 67
changing data, 67
description, 57
formatting, 67
child frame, description, 59
client/server balancing
overview, 116
tune for efficiency, 117
column titles, linking to query, 57
conditionally format data, 44
conditions
applying, 44
applying styles to, 43
changing the order, 44
creating, 43
including pre-defined conditions, 43
predefined, 39
use to format data, 42
using to hide/show report objects, 44
copying
catalog folders, 109
data to other applications, 92
summaries, 30
copyright, 2
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Index
creating
a character item from a number, 39
a date from a number, 37
a distributed catalog, 106
calculated columns, 76
cascading prompts, 21
conditions, 43
filters, 11
HTML report output, 93
new crosstab reports, 72
prompts, 19
reports with sub-reports, 80
snapshots, 101
styles, 40
summaries, 30
summaries from detailed data, 30
thumbnails, 102
cropping picture frames, 70
crosstab reports
adding summaries, 74
changing into a list report, 78
creating calculated columns, 76
creating new, 72
editing SQL, 71
filter data, 77
nested, 72
pivoting list reports, 72
summaries for cells, 74
summaries for columns and footers, 75
swapping data, 78
using calculated columns, 76
using more than one summary, 75
customizing
buttons, 126
launch buttons, 126, 128
launch menu commands, 126
menus, 125
toolbar buttons, 126, 127
toolbars, 126, 127

D
data
adding to chart frames, 67
inserting into frames, 60, 64
sources and performance, 120
data items
calculated, 32
changing, 30
combining, 38
copying to other applications, 92
formatting using prompts, 23
grouping, 10
data retrieval
automatic, 100
limiting, 102
using thumbnails, 102
database, accessing via the catalog, 99
dates, creating from a number, 37
detailed data items, changing, 30
disabling
automatic catalog updating, 106
automatic data retrieval, 100
displaying values in prompts, 19
distributing
custom menus, 128
custom toolbars, 128
HTML report output, 98
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distributing (cont'd)
reports using styles, 41
document
version, 2
drill-through reports
setting up, 82, 83
testing, 85
using, 82

E
editing
embedded objects, 90
main queries, 81
predefined conditions, 110
embedding
compared to linking, 86
report objects, 89
report objects in other applications, 91
evaluating prompt requirements, 18
expressions, using in filters, 11
extracting years, months, days
from a date, 36

F
file picklist prompts, changing the prompt separator, 17
files, in HTML report output, 95
filter
changing, performance issues, 118
creating, 11
creating detail filters, 11
data in a crosstab, 77
drill-through, 83
If/Then/Else, 119
performance issues, 118
removing, 16
rolling time period, 14
storing in catalogs, 109
tips, 16
types, 77
using, 11, 13
using database summaries, 119
filter expressions
applying after summaries, 12
containing prompts, 20
overview, 11
prefilter component, 12
tips, 16
fixed association, 27
footers, putting summaries in, 117
form frames
description, 57
inserting data, 64
inserting report objects, 64
overview, 63
repeating, 66
scoping data, 65
formatting
3-Dimensional, 41
charts, 67
data using conditions, 42
HTML report output, 95
linked or embedded objects, 91
using conditions, 42
frames
and sub-reports, 80
designating the primary frame, 59

Index
frames (cont'd)
form, 63
inserting, 60
inserting data into, 60
naming, 62
parent/child relationship, 59
picture, 69
properties, 58
selecting, 61
text, 67
types, 57
viewing frame types, 60, 62
full outer join, example, 123
functions
filtering, 119
performance issues, 119

G
grouping
automatically, 10
report objects, 65

H
hiding
report objects, 44
toolbars, 126
HotFiles
as data sources, 103
creating automatically, 104
performance issues, 121
sharing, 104
updating, 103
using in reports, 103
using instead of snapshots, 103
how to
create an interval, 34
filter using a rolling time period, 14
find the average of totals for groups, 36
find the rank and percentile of calculated values, 35
insert a calculated data item, 33
HTML files, 95
HTML report output
creating, 93
distributing, 98
files created, 95
formatting, 95

I
if/then calculation, 39
Impromptu
architecture, 115
SQL, 99
Impromptu options
data format tab, 47
inserting
data into frames, 60
frames, 60
placeholders, 56
intervals
calculating between two dates, 34
finding the average, 37

J
joins
described, 122
effects on report, 122
full outer join, example, 123
left outer join, example, 123
overriding, 122
right outer join, example, 123
when not to use, 122

L
launch buttons
setting up, 128
launch menu commands
setting up, 126
left outer join, example, 123
linking
column titles to query, 57
compared to embedding, 86
from another application, 87
links
breaking, 88
converting linked objects, 87, 89
editing, 88
updating, 88
list frames
description, 57
inserting data, 63
inserting report objects, 63
list reports
changing a crosstab into, 78
pivoting data, 72
local snapshots
compared to remote snapshots, 101
local snapshots, description, 101

M
macros
using a menu command, 126
using a toolbar button, 128
using with catalog prompts, 18
manually updating catalogs, 107
menus
adding commands, 125
creating, 125
customizing, 125
distributing, 128
resetting, 125
missing values
retrieving, 13
missing values, retrieving, 13
modifying
catalogs, 107
placeholders, 55
moving catalog folders, 109
multi-column placeholders
alignment, 55
placement, 55
multiple queries, what you can do, 80

N
nested crosstab reports, 72
non-indexed columns
sorting, 119
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Index
null values
description, 13
in filters, 13

O
OLE frame, description, 57
opening, catalogs, 106
outer joins
described, 122
effect on reports, 122
examples, 123
full outer join, example, 123
left outer join, example, 123
overriding, 122
right outer join, example, 123
when not to use, 122

P
page view, templates, 51
parent frame, description, 59
parent/child relationship, 59
percentile, 34
performance issues
associating, 118
client/server balancing, 116
data, 120
filtering, 118
functions, 119
HotFiles, 121
printing reports, 120
sizing frames, 120
snapshots, 121
sorting, 118, 119
summaries, 117
thumbnails, 120
using cascading prompts, 21
using if/then/else, 119
using lookup, 119
permissions for catalogs, 105
personal distributed catalogs
changing, 107
overview, 105
updating, 105, 106
updating manually, 107
picklist prompts
changing prompt separator, 17
creating for multiple selections, 17
creating in Prompt Manager, 19
picture frames
description, 57
dynamic, 69
scaling and cropping, 70
using, 69
pivoting data in list reports, 72
placeholders
alignment, 55
creating, 53
creating calculated, 56
description, 49
inserting, 56
modifying, 55
multi-column, 55
placement, 55
predefined calculations, 24
predefined conditions
editing, 110
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predefined conditions (cont'd)
renaming, 110
using, 43
preview image, customizing, 50
primary frames, 59
printing reports, performance issues, 120
product
version, 2
prompt manager, 16, 18
prompt separator, changing, 17
prompts
case sensitivity, 16
catalog, 18
changing prompt separator, 17
creating, 19
creating and storing in catalogs, 111
creating cascading, 21
creating for a single selection, 19
creating picklists for multiple selections, 17
displaying values in, 19
formatting data with, 23
in calculated data items, 22
in filter expressions, 20
managing, 18
picklist, 17
re-ordering, 16
requirements, 18
type-in, 16
types, 16
unreferenced, 18
using to filter reports, 22
using values in, 19
with multiple selections, 20
properties, of frames, 58
publishing
reports to Upfront, 93

Q
queries
compared to reports, 115
editing, 81
linking column titles to, 57
SQL, 115
versus reports, 115
what you can do with, 80
what you cannot do with, 80
query results
column order, 122

R
ranking calculated data items, 34
remote snapshots
compared to local snapshots, 101
save as local snapshots, 102
using, 101
removing
duplicate rows, 16
styles from conditions, 44
repeating form frames, 66
reports
changing catalogs, 9
compared to queries, 115
converting linked objects, 87, 89
create accessible, 124
editing embedding objects, 90
editing object links, 88

Index
reports (cont'd)
embedding in other applications, 91
embedding objects, 89
formatting linked or embedded objects, 91
grouping objects, 65
incorporating in other applications, 92
inserting objects into frames, 64
inserting objects into list frames, 63
linking from another application, 87
linking objects, 87
linking versus embedding objects, 86
outer joins, 122
publishing to Upfront, 93
saving as HTML, 95
saving as templates, 52
updating object links, 88
using drill-through, 82
using HotFiles, 103
versus queries, 115
requirements, prompt, 18
resetting
menus, 125
toolbars, 126
retrieving data
containing missing values, 13
that matches a pattern, 15
that starts with or contains a specific value, 13
using a snapshot, 14
using another report, 14
right outer join,example, 123
rolling time period, 14
running totals, 24

S
scaling picture frames, 70
scoping data, 65
selecting frames, 61
setting default templates, 50
setting up
launch buttons, 128
launch menu commands, 126
shared catalog
changing, 107
overview, 105
showing
report objects, 44
toolbars, 126
snapshots
local, 101
performance issues, 121
remote, 101
retrieving data using, 14
using instead of HotFiles, 103
sorting
performance issues, 118, 119
Structured Query Language, 99
styles
applying 3D formatting, 41
applying to a condition, 43
creating, 40
distributing reports using, 41
removing from conditions, 44
using conditions, 43
sub-reports
and frames, 80
converting an empty frame into, 80
creating, 80

sub-reports (cont'd)
frames, description, 57
queries, 81
types, 81
what you can do, 80
what you cannot do, 80
summaries
adding to crosstab reports, 74
applying more than one to crosstabs, 75
automatic association, 25, 30
complex, 24
copying, 30
creating, 30
creating from detailed data, 30, 31
creating versus copying, 30
database, 118
description, 24
fixed association, 27
for crosstab columns and footers, 75
for groups, 24
in a crosstab, 74
performance issues, 117, 118
row, 24
running totals, 24
storing in catalogs, 110
summary association
automatic, 25
changing, 29
fixed, 27
performance issues, 118
summary filters
applying before filters, 12
when to use, 10
swapping data in a crosstab report, 78

T
templates
benefits, 48
changing a list to a crosstab, 52
customizing preview image, 50
limitations, 48
page view, 51
placeholders, 49
saving reports as, 52
setting default, 50
setting the view, 51
testing drill-through reports, 85
text frames
and binary large objects, 68
combining, 68
description, 57
formatting, 68
using, 67
thumbnails
creating, 102
description, 102
performance issues, 120
tips for filters, 16
toolbar buttons
customizing, 126
toolbars
changing buttons, 127
customizing, 126, 127
distributing, 128
resetting, 126
setting up buttons, 127
showing or hiding, 126
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Index
types
of catalogs, 105

U
unreferenced prompts, 18
updating
HotFiles, 103
links, 88
personal distributed catalogs, 105, 106
user classes
adding, 112
effects of, 105
using
calculations, 33
detail filters, 10
filters, 11, 13
HotFiles, 103
snapshots, 103
summary filters, 10
values in prompts, 19

V
version
product, 2
viewing
Access tab, 102
frame types, 62
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