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4 Impromptu (R)

Welcome
What Is in This Document
Discovering Impromptu shows you how to create different kinds of Impromptu reports, and
teaches you the essential skills you need to be successful with Impromptu.

Other Information
Our documentation includes user guides, tutorial guides, reference books, and other pieces to
meet the needs of our varied audience.
All information is available in online help. Online help is available from the Help menu and Help
button in Windows products.
The information in each online help system is available in online book format (PDF). However,
the information from a given help system may be divided into more than one online book. Use
online books when you want a printed version of a document or when you want to search the
whole document. You can print selected pages, a section, or the whole book. Cognos grants you
a non-exclusive, non-transferable license to use, copy, and reproduce the copyright materials, in
printed or electronic format, solely for the purpose of providing internal training on, operating,
and maintaining the Cognos software.
In Windows products, online books are available from the Windows Start menu (Cognos) and
from the product Help menu (Books for Printing). All online books are available on the Cognos
documentation CD. You can also read the product readme files and the installation guides
directly from the Cognos product CDs.
Only the installation guides are available as printed documents.
An annotated list of other documentation, the Documentation Roadmap, is available from the
Windows Start menu or the Impromptu Help menu.

Questions or Comments?
For the fastest response to questions about using Impromptu, contact customer support.
For information about customer support locations and programs, see Cognos on the Web on the
Help menu or visit the Cognos Support Web site (http://support.cognos.com).

Discovering Impromptu 5

Welcome

6 Impromptu (R)

Chapter 1: Essential Skills
This chapter covers the essential skills you need to produce high-quality reports with
Impromptu. In this chapter, you will learn about:
• opening a catalog
• opening and printing a report
• creating and filtering a report

Start Impromptu
You can start Impromptu by double-clicking the Impromptu icon on your desktop, or by clicking
the Start button.
You see the Welcome dialog box when you start Impromptu.
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Select a Catalog
To use Impromptu to create or open reports for your business, you must select an existing
catalog. Catalogs are usually created by an administrator. You can open a different catalog at
any time during your Impromptu session, but you can only open one catalog at a time.

Open the Great Outdoors Sales Data Catalog
To do the tutorials in this book you need The Great Outdoors Sales Data catalog (Great
Outdoors Sales Data.cat). You get this catalog when you do a typical installation of Impromptu.

Try This...
To open the Great Outdoors Sales Data catalog
1. If you have just started Impromptu, click Close to close the Welcome dialog box.
2. If you do not have the Great Outdoors Sales Data catalog open, from the Catalog menu,
click Open to show the Open Catalog dialog box.

Available catalogs are
indicated by
this icon.

3. Locate and double-click the Great Outdoors Sales Data catalog.
4. If the Cognos Common Logon dialog box appears, click Cancel.
5. In the Catalog Logon dialog box, click OK to accept your catalog User Class and open the
catalog.

The dialog box title
identifies the catalog
you open.

When working with the Great Outdoors Sales Data catalog, your user class is User if you
have the User version of Impromptu, and Creator if you have the Administrator version of
Impromptu.
Tip: Check the message in the status line. When it says "Sales data for The Great Outdoors
Co.," this catalog is open.
Note: If a Catalog Upgrade dialog box appears, select Upgrade this catalog and click OK to
close the dialog box.
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Open an Existing Report
In this tutorial, you are the Sales Manager for a camping equipment company called the Great
Outdoors. You are completing your annual performance reviews for your sales staff, and you
need a report detailing all the sales made by each sales representative.
You’ll need to open a report you’ve already created called Sales Totals for Representative that
shows all the sales each representative made.

Open the Report
You can open an Impromptu report by
• using the Welcome dialog box when you start Impromptu
• clicking the Open button on the toolbar
• clicking the Open command from the File menu.

Try This...
To open an existing report
1. From the File menu, click Open.
If the Reports folder isn’t open, double-click the Reports folder to open it.

2. Locate and double-click the SalesRep Sales Totals report.
Impromptu prompts you to select one or more sales representatives.

Do not click OK yet.
Note: If a Report Upgrade dialog box appears, select Upgrade this report and click OK to
close the dialog box.

Respond to a Prompt
Your report may prompt you for information before retrieving the data. Your response to a prompt
determines what is included in the report. The prompt acts as a filter for the data so that only the
information you require appears in the report.
One or more prompt dialog boxes may appear when you open a report. Each prompt dialog box
further refines the data you will see in your report.
You may be prompted to select one or more values from a list, or you may be required to type in
a value.

Discovering Impromptu 9

Chapter 1: Essential Skills
For example, this report requires you to select a sales representative from a list. You can select
one or more values from the Prompts dialog box.

Try This...
To respond to a prompt
1. Click OK to accept Bill Gibbons and to open the report.

You can see the details of Bill Gibbons’ sales this year, including sales by customer and
maximum and minimum sales. You can use this report during your performance review of
Bill Gibbons.
2. From the Report menu, click Prompt to show the Prompts dialog box.

3. Click Bill Smertal, and Ctrl+click Charles Loo Nam, then click OK to show the Sales Totals
for Representative report for Bill Smertal and Charles Loo Nam.

Click to switch to the Sales Totals report for Charles Loo Nam.

Now you can print these reports to use when you complete your annual performance review.

Print Your Report
Impromptu lets you print your report.
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Try This...
To print a report
1. From the File menu, click Print.
2. In the Print dialog box, select the appropriate print settings, and then click OK to send the
report to the printer.
3. From the File menu, click Close to close the report.

Create a List Report Using the Report Wizard
Using Impromptu’s Report Wizard is an easy way to create simple reports.
For example, you buy several GO Sport Line products, and the policy is to sell the products from
that manufacturer at cost plus 50%. When you review the product cost and product price for the
GO Small Waist Pack, the product margin seems low.
You can make a report that lists the cost, price, and margin information for the GO Sport Line
products to check their margins. You can use this information to help you decide whether to
raise the prices on GO Sport Line products to keep the margins in line with the policy.

Try This...
To create a list report using the Report Wizard
1. Click the New button to show the Report Wizard.
Note: Do not click New from the File menu. This will open the New dialog box instead of the
Report Wizard.
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2. Type GO Product Margins, and click Next to show the list/crosstab choice page.
For more information on crosstab reports, see "Create a Crosstab Report" (p. 51).

3. Click List Report and then click Next to show the data item selection page.

Select the Data
On the data item selection page you select data for your report. Each data item is presented as
a column in your report.

Try This...
To select data for your list report
1. Double-click the Products folder to open it.
2. Double-click the Product Line data item to add it to the Report Columns box.
3. Double-click the Product data item to add it.
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4. Double-click the Price and Cost folder to open it and then double-click these data items:
•

Product Cost

•

Product Price

•

Product % Margin

5. Click the Next button to group the report data.

6. Click the check box beside Product Line.
By grouping Product Line, Impromptu sorts the information in the product line, removing any
duplicate values.
Note: Ensure the Automatically Generate Totals check box is selected.
When you select Automatically Generate Totals, the Wizard adds the totals for the numeric
columns in the report to the overall list footer. If the report is grouped, the Wizard also adds
footers at each change in the value of the grouped data item and inserts totals for the group
in the group footers.
7. Click the Next button to show the filter page.
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Filter the Data
On the filter page you filter the data contained in your report.

Try This...
To filter data in your list report
1. To create a filter to look at all products with margins less than or equal to 50%, double-click
Product % Margin in the Available Components box.

2. Double-click <=.
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3. Double-click number, type 50 in the Enter Value dialog box, and then click OK.

4. Click Finish to retrieve the data and show the report.

You can now see all the information you need to compare the product margins, and you can
focus the report further to see only the margins on GO products.
5. From the File menu, click Save As.
6. Type GO Product Margins Tutorial in the File Name box and click Save.

Improve Your Report
You can make changes to an existing report. For example, you can add an additional filter to
narrow the focus of your report. You can also organize the information in the report to make the
report more usable.

Filter Your Data to See Only What You Need
Filtering lets you report only the information you require. You can filter the report on one or more
data items.
An easy way to apply additional filtering is to use the Filter toolbar button. You can filter the
report on one or more data items from columns or rows.
For example, using the Wizard, you focused on products with a margin equal to or less than
50%. Now you want to filter out this data to show only the GO Sport Line.
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Try This...
To filter report information using the Filter button
1. Click the GO Small Waist Pack product to select it.
2. Scroll down the report and Ctrl+click each of the products that start with "GO."

3. Click the Filter button.
Tip: If you inadvertently filter too much or too little information from the report, click the Filter
button again. Impromptu shows you a message box warning you that the filter will be
cleared from the report. Click OK to return the report to its unfiltered state.
4. Scroll up to see the filtered report.

When you compare the product margins for the GO products, you see that both Back Packs
and Cooking Equipment are only cost plus 33.33% instead of cost plus 50%. You can use
this information to decide if you want to raise the price of the GO products to meet product
margin policy.

Add Headers
While the Report Wizard can automatically add group footers, you can add headers to your
report to organize the information logically and improve usability.
Using the Header button on the toolbar is an easy way to create headers in your report. When
you select a column or data item and click the Header button on the toolbar, Impromptu removes
the column or data item from the report and adds it as a header.

16 Impromptu ( R )

Chapter 1: Essential Skills
For example, you can move the Product Line data into a header.

Try This...
To add a header using the Header button on the toolbar
1. Move your pointer to the top of the Product Line column.
The pointer becomes a downward pointing arrow.
2. Click to select the Product Line column, and click the Header toolbar button.
The Product Line column is replaced by a Product Line header.

The products are now grouped under the product line header, making the report easier to
read.
3. From the File menu, click Save.

Make the Report Easier to Read and Understand
You can change the order of the columns in a report, and you can change the way Impromptu
shows the report on the screen.
When you look at the GO Product Margin by Product report, you see it would be better
organized with the Product Price and Product Cost columns reversed.

Try This...
To move a column
1. Select the Product Price column.
2. Move your pointer over the selected area.
The pointer turns into a four-headed arrow.
3. Click and drag the column to the left of the Product Cost column.
The pointer turns into a clear arrow with a box (indicating an attachment).
The dotted line highlight indicates where the column would be placed if you dropped it.
4. Drop the column (release the mouse button), and press Esc to
clear the highlighting from the column.
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5. From the File menu, click Save.
To compare your report to our version, open the GO Product Margins report in
installation_location\cern\Samples\Impromptu\Reports.

What’s Next?
This chapter showed you the essential skills you need to open existing reports, respond to
prompts, and create reports using the Report Wizard.
You also saw how to print your report, filter information from your report, add headers and
footers, and organize the information in your report to make it easier to use.
For more information about the topics in this chapter, see the online Help. In the Index tab, type
• catalogs
• filtering
• headers, adding
• columns
• Report Wizard
The next chapter teaches you how to create a list report without using the Report Wizard and
how to focus the information using a filter expression.
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The list report shows detailed information that you want from your corporate database. It can
help you answer specific questions, such as whether there’s room to lower prices for products
priced over $100. In this chapter, you will learn about:
• creating a list report
• filtering a list report
• adding new data items and a title to a list report
• changing a report view

You can see that the product margins for products priced over $100 are already at 33%, and
in one case under 33%. Since anything less than 33% profit margin is close to being
unprofitable given your volume of sales, this report indicates that you cannot lower the prices
unless your supplier lowers the cost to you.

What Is a List Report?
A list report is a report that shows data in rows and columns. It is useful when you want to show
detailed information from your corporate database, such as product lists, customer lists, and so
on. The default template for new list reports is called Simple List.
You can use a Simple List report as a base for grouping, summarizing, filtering, and formatting
your data. The list report is a building block on which you can create more complex reports.

Create a List Report Using a Template
You already know how to
• open a catalog
• create a report using the Report Wizard
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By creating a list report, you’ll also learn how to
• use the Simple List template
• select data items to include in the report
• create a filter to focus the report
• add more data items to the report
• add a title to the report
• change views in a report
In this chapter, you acquired market research that forecasts increased sales of camping and
outdoor-related products in the under $150 range. By reviewing the margins you’re achieving,
you can determine if it’s worthwhile reducing margins slightly to place products within the under
$150 range.
Tip: You can also create new list reports using the Report Wizard, as you learned in "Chapter 1:
Essential Skills."

Try This...
To create a list report using the Simple List template
1. Start Impromptu and click Create a Report Using a Template in the Welcome dialog box.
Note: If the Welcome dialog box does not appear, click New from the File menu.
2. Double-click the Simple List template.
3. In the Catalog dialog box, locate and double-click the Great Outdoors Sales Data catalog.
4. If the Cognos Common Logon dialog box appears, click Cancel.
5. Click OK to accept your user class.
Impromptu shows the Query dialog box where you can add data items to your query.

Catalog folders provide a logical
list of the columns in the
corporate database.

Data items will appear here as you add
them to form your query.

You have completed the preliminary steps for creating the report.

Select Data Items to Include in the Report
You can easily choose the data items from the corporate database you want to include in your
query. These data items are set up by your Impromptu administrator as columns in your catalog.
Impromptu enables you to select your data by clicking the data items and adding them to the
query. The data items appear in the report in the order you select them.
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For example, you can select data items to list products and product margins and create a filter
for your report that removes all products that sell for more than $165.00. You can use $165.00
as the cut-off price to ensure that you only see products whose price is already low enough to
allow you to find room in the margin to lower the price.

Try This...
To select data items to include in your report
1. In the Catalog box, double-click the Products folder to open it.
The contents are different for each folder.
You can double-click a folder to show the
columns, and double-click the folder again to
close it.

2. Double-click Product to add it to the Query Data box.
This icon indicates that this data item
will be included in the report.

Tip: Instead of double-clicking, you can also add data items to the Query Data box in two
steps by clicking the data item, and clicking the Add button.
3. Double-click the Price and Cost folder to open it.

4. Double-click Product Cost to add it to the Query Data box.

5. Double-click Product Price to add it to the Query Data box.
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6. Double-click Product Margin to add it to the Query Data box.

Query data items are catalog items you want Impromptu to retrieve from the
database. Each query data item is marked for insertion into the report as you add it
to the query.

Your data items are now selected.
7. Click OK to show your Report.

Create a Filter to Focus the Report
List reports can contain a great deal of detail that makes it difficult to see the information you
need right away. Including extraneous information in the report can unnecessarily increase
database processing time, and can make the report less usable. To build a report that focuses
on the critical information, you can create filters.
An efficient way of filtering information in your report is to use the Filter drop-down button.
Impromptu simplifies the process of creating filters by providing you with a menu of available
filter operators. The filter operators that are available on the menu depend on whether you’re
filtering a value, string, number, date, time, or date-time. Impromptu shows you only the filter
operators that create a logical expression.
For example, you can create a simple filter for your report to specify that you want to include
only products costing less than $165.00.
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Try This...
To focus your report using a filter
1. Click any value in the Product Price column.

2. Click the arrow next to the Filter button to see a list of filter operators.

The filter operators that are
available on the menu depend on
the column item you selected.

3. Click the < operator and click Select Values to show the Select Values dialog box.

Impromptu gets these values from the database. The
values change depending on which data item you
selected.
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4. Click 165, and click OK to show the report.

Your report contains only the products you sell for less than $165.00. When you compare
product cost and product margin, you see that reducing the product margin on MoonBeam,
MoonGlow, and Dover-2 could bring the prices under $100. However, the Great Outdoors
has a policy that product margins must be no lower
than 33%.

Add New Data Items to the Report
You can add new data items to your report. This enables you to fine-tune your report if you find
you need more information than you originally planned.
You should note, however, that Impromptu sends the entire query to the database every time
you request new or different information. If you have a large database, re-sending the query can
be time-consuming. It’s more efficient to include all the data items you require the first time you
build the query.
For example, you can add Product % Margin to the report to check that the product margin
percentages on MoonBeam, MoonGlow, and Dover-2 are high enough to provide some room to
lower their prices.

Try This...
To add new data items to your report
1. From the Report menu, click Query, and then click the Data tab.
2. Double-click the Products folder to open it.
3. Double-click the Price and Cost folder to open it.
4. Double-click Product % Margin to add it to the Query Data box.

Note the icon beside the Product %
Margin data item. This indicates that this
new data item will be included in the
report.
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5. Click OK to show the report containing the Product % Margin information.

You can see that the product margins for MoonBeam, MoonGlow, and Dover-2 are already
at 33.33%. The only way you can bring their prices under $100 and maintain the 33% profit
margin policy, is to ask the manufacturer to lower the cost of the products.

Add a Title to the Report
Impromptu provides a space for you to add a title to every new list report. You can add a title to
describe or identify the report contents.

Try This...
To add a title to your report:
1. Double-click the text area marked <Type here to customize title>.
Impromptu inserts a flashing I-beam in the title area.
Tip: If you click only once in the text area, Impromptu selects the entire text frame in which
the title is placed. You can press Esc to clear the highlighting and then double-click the title
to see the flashing I-beam.
2. Click and drag to select the title text.
3. Type Products Less Than $165.00, and press Esc to accept
the title.

Note: As you type the title, parts of it may disappear from the screen. This happens
because the text is in a frame with a limited size. When you press Esc, all of your text
appears.
4. Click any data item in the Product Cost column.
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5. Position your pointer over any data item in the Product Margin column and press Shift+click.
Your selection should look something like this

6. Click the Currency button to add currency formatting to the columns.

Impromptu adds currency formatting to the selected columns.

7. Press Esc to clear the highlighting from the data items.
8. From the File menu, click Save As.
9. Type ProdPrice Under 165 Tutorial in the File Name box, and click Save.
To compare your report to our version, open the ProdPrice Under 165 report in
installation_location\cern\Samples\Impromptu\Reports.

Change Views to See the Report in a Different Way
Impromptu provides two report views for all reports: Screen Layout and Page Layout. You can
choose to view reports in Screen Layout, for reports meant to be viewed on your computer, or in
Page Layout, for reports meant to be printed.
Impromptu opens reports in either Screen Layout or Page Layout view, depending on the
purpose of its template. Since the Simple List template is intended to be printed, Impromptu
uses the Page Layout view by default.
When you save reports, Impromptu stores the view with the report, and when you open a saved
report, Impromptu uses the view you saved last with the report.
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Each view has its advantages.
In this view ... You see ...
Page Layout

•
•
•
•

Screen Layout •
•

all the information that fits on the defined page
size (the default is 8.5 x 11 inches).
the page margins using the defined page size.
buttons to scroll through the information.
the headers and footers for the report.
all the information in the report, regardless of
how it fits on the printed page.
scroll bars to scroll through the information in the
report.

For example, you can check the information in your new report before you print it. Notice that
because this report is intended for printing, it’s not optimized for screen viewing.

Try This...
To change to the Screen Layout view
• From the View menu, click Screen Layout.

In Screen Layout view, Impromptu shows only the report data, not the layout objects (such
as page margins, report title, date, and
so on).
You can change back to Page Layout view before you print
the report.

What’s Next?
In this chapter, you learned how to create a report using a template, add data items to your
report, filter the information, add a title, and change the view.
For more information about the topics in this chapter, see the online Help. In the Index tab, type
• templates
• adding, data to reports
• filtering
The next chapter shows you how to use a Grouped List template to compare information on a
customer-by-customer basis.
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A grouped list report shows detailed information grouped by common values. This report can
help you answer specific questions about groupings of data. In this chapter, you will learn about:
• creating grouped list reports
• suppressing redundant data
• filtering with predefined conditions
• adding headers and footers
• adding calculations to your report
• adding column totals and group totals

a group of data

another group
of data

What Is a Grouped List Report?
A grouped list report shows detailed information grouped by common values, and is useful when
you want to see details by groupings. You can use the Grouped List template to create new
grouped list reports.

Create a Grouped List Report Using a Template
You already know how to
• open a catalog
• create a report
• select data items to include in the report
• add more data items to the report
• add headers or footers using the Header or Footer tools
• add a title to the report
By creating a grouped list report, you’ll also learn how to
• use a Grouped List template
• change the order of the data
• group and associate the data
• use a predefined condition to filter your report
• add headers and footers without removing a report column
• create calculations
• add column totals
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In this chapter, in an effort to increase profit, you are considering reviewing the discount policy
for the Great Outdoors Company. You want to check the discount each customer received for
each product type.

Start Creating the Report
You’ll use the Grouped List template to create your report.

Try This...
To start creating a grouped list report
1. If you have just started Impromptu, click Close to cancel the Welcome dialog box.
Note: If the dialog box on your screen says Report Wizard, you are in the wrong place. Click
Cancel and return to the blank screen.
2. If you are already in Impromptu and do not have the Great Outdoors Sales Data catalog
open
•

From the Catalog menu, click Open.

•

In the Open Catalog dialog box, locate and double-click the Great Outdoors Sales Data
catalog.

•

If the Cognos Common Logon dialog box appears, click Cancel.

• Click OK to accept your user class.
Tip: Check the message in thestatus line. When it says "Sales data for The Great Outdoors
Co.," this catalog is open.
3. From the File menu, click New.
4. Click the Grouped List template, and click OK to show the Query dialog box.

Select data items for
your report

Select the Data
On the Data tab of the Query dialog box you select data items for your report. The first data item
you select determines how the report will be sorted and grouped.
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Try This...
To select data for your grouped list report
1. Double-click the Customers folder to open it.
2. Double-click Customer No. to add it to the Query Data box.
Customer No. is placed under the Grouped Item placeholder in the Query Data box. This
means that your report will be sorted and grouped by Customer No.
Tip: You can also drag data items from the Catalog box to the Query Data box.

3. Double-click Customer Name to add it to the Query Data box.
4. Double-click the Products folder and then double-click Product Type and Product to add
them to the Query Data box.
5. Double-click the Price and Cost folder and then double-click Product Price to add it to the
Query Data box.
6. Double-click the Orders and then Order Details folders to open them.
7. Double-click Qty and Sale Amount.
The Query Data box contains these data items:

Note: The Data tab is the only tab where you can expand the Grouped Item placeholder.

Change the Order of the Data Items
The data items will appear in your report in the same order as you selected them. If you want to
rearrange your columns of information, change the order of the data items.

Try This...
To change the order of the data items
1. In the Query Data box, click the Qty data item.
2. To change the order of the data items for the report, hold down the mouse button and drag
the Qty data item above the Product Price data item.
The Query Data box looks like the example below:
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3. Click OK to show the grouped list report.

In a grouped report, the column titles form a report header that
stays at the top of the screen as you scroll through the report.

Your report contains all the information you need to check the discounts for each customer.
However, the report could be improved with additional grouping.

Group the Data in the Report
You can group more than just the Grouped Item placeholder in your grouped list report. For
example, you can remove unnecessary details from the report by grouping on Product Type.

Try This...
To group data items in your report
1. From the Report menu, click Query, and then click the Group tab.
2. Click Product Type and click Group.
Grouping a data item
moves it to the top of the
list. Grouped data items
have a solid bar across
the top of the data item
icon.

Note: You’ll notice that Customer No. is grouped. When you placed Customer No. under the
Grouped Item placeholder, Customer No. was automatically grouped for this report.
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3. Click OK to show the report.

Product Type shows only one instance of each product type
for each customer.

You can see that Customer No. 1001 bought more Environmental Line and Outdoor
Products product types than GO Sport Line product types.

Suppress Redundant Data Using the Associate Button
You can associate data with grouped data in the report to suppress redundant information and
make your report more logical and easier to read.
Once data is grouped, you can associate any report column that has a one-to-one relationship
with that grouped column. The associated column then shows data only once and other
instances of the data are removed from the report.
For example, you can remove any repeated customer names from the report by associating the
Customer Name with the Customer No. The customer number has a one-to-one relationship
with the customer name (since there’s only one customer number per customer name).

Try This...
To associate columns in your report
1. From the Report menu, click Query, and ensure the Group tab is selected.
2. In the Group Order box, click Customer Name.
3. Click the Associate button.
Impromptu marks Customer Name with a half bar, indicating that it’s an associated item.
Customer Name is an
associated item. It is
associated with Product
Type because of its position
in the Group Order box.
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4. To associate Customer Name with Customer No., click Customer Name, hold down the
mouse button, and then drag it under Customer No.
Impromptu now associates Customer Name with Customer No. The Group Order box looks
like the example below:

5. Click OK to show the report.

You can see that Customer No. 1001 is GO Outlet Montreal, and the report is easier to read.

Where Do You Want the Customer Name?
You can change the position of report objects to increase the readability
of the report by dragging and dropping the object in a new position. If you’re moving the
information from a column, Impromptu removes the column from the report.
For example, you can move the Customer Name beside the customer number in your report.

Try This...
To move an object in your report
1. Click Customer No. 1001 to check its position and size.

Notice that the highlighted area extends to the right edge of your screen. If you drag the
Customer Name into this area without first modifying its size, Impromptu will combine the
two objects. To avoid this, change the size of the highlighted text.
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2. Select the right side handle of the highlighted area and drag it to the left until it
approximately matches the following.

3. Click GO Outlet Montreal.
4. Drag GO Outlet Montreal beside Customer No. 1001 until it approximately matches the
example below, and press Esc to clear the highlighting.

You can now easily see that Customer No. 1001 is GO Outlet Montreal.

Use a Predefined Condition to Filter the Report
The catalog can contain predefined conditions that you can use to filter out the information you
don’t want in your report. While the most efficient way to apply a filter is to apply it before you
retrieve the data from your database, you can also apply a filter to your report after the data is
retrieved.
For example, you can use a predefined condition to include just the active customers in your
report.

Try This...
To use a predefined filter in your report
1. From the Report menu, click Query, and then click the Filter tab.
2. Double-click the Catalog Columns component to show the Catalog dialog box.
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3. Double-click the Customers and Conditions folders to open them.

These are predefined conditions
you can use to filter the
information in your report.

4. Double-click the Active Customer condition to add it to the Filter Definition box.

5. Click OK to apply the filter to the report.

The inactive customers are removed from the report.

Add Headers and Footers for the Grouped Data
Once you group data, you can add headers and footers to your report at every change in the
value of the grouped column data. Headers and footers are used to organize the information in
your report into logical sections, and can make your report easier to read.
When you add headers and footers using the Layout tab (List Properties dialog box), Impromptu
leaves the column in the report.
For example, you can add a Product Type header to the report.
Tip: You can also add headers and footers using the Header and Footer buttons on the toolbar.
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Try This...
To add a header to your report
1. Click the blank area to the right of the report to select the entire report.
2. From the Format menu, click Properties, and then click the Layout tab.

The information in
this box depends on
the information in
the report.
Check marks indicate
which headers and
footers will be shown
in the report.

3. Select the Product Type Header check box.
4. Click OK to add the Product Type headers to the report, and press Esc to clear the
highlighting from the report.

Environmental Line header.
You created this using the
Environmental Line product type.

Environmental Line product type. You
used this to create the Environmental
Line header.
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5. Click the Environmental Line text in the Product Type column, and press the Delete key to
remove the Product Type column from the report.

The report organization is better, but you could see more of it if you reduce the height of the
Customer Number row and the Product Type Header row.
6. Click 1001 to select it, and Shift+click GO Outlet Montreal to
select it.

Tip: If you inadvertently select the entire header frame, press Esc
to clear the highlighting and try again.
7. Drag the objects in the frame, until they are in approximately the same position as the
example below.

8. Click just below the 1001 title to select the entire header area.

9. Position your pointer over the bottom handle, and drag the handle up until the size
approximately matches the example below.

Notice that when you change the Customer No. header, all Customer No. headers change.
10. Click the Environmental Line header area to select the entire frame.
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11. Drag the bottom handle up until the position approximately matches the example below.

12. Press Esc to clear the highlighting from the header frame.

Customer No. 1001 (GO Outlet Montreal) has bought more Environmental Line items than
any other product type. However, it would be helpful to see the discount amount for each of
these items.

Add New Data Using Calculations
Calculations enable you to add new data that is not available in the catalog to make your report
more meaningful.
When you define calculations, Impromptu provides you with a list of available expression
components you can use to create your calculation expression.
The most efficient way to add new data to your report is to add the calculation before you query
the database. This eliminates extra database processing. However, you can add the calculation
after you query the database.
For example, you can create a calculation to multiply Product Price and Quantity to get sale
price. Then you can subtract Sale Amount from the sale price to discover the amount of the
customer Discount.
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Try This...
To add a calculation to your report
1. From the Report menu, click Query, and then click the Data tab.
2. Click Calculate to show the Calculation Definition dialog box.

Calculate button

3. Type Discount in the Name box.
4. Double-click the ( component to add it to the Expression box.

5. Double-click Report Columns in the Available Components box to show the columns in the
report.

6. Double-click Product Price to add it to the Expression box.

7. Double-click the * component in the Available Components box to add it to the Expression
box.

8. Double-click the Report Columns folder to open it.
9. Double-click Qty to add it to the Expression box.
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10. Double-click the ) component to add it to the Expression box.

This expression results in the sale price of a product.
11. Double-click the - component to add it to the Expression box.

12. Double-click the Report Columns folder to open it.
13. Double-click Sale Amount to add it to the Expression box.

This expression calculates the discount for each product, enabling you to compare the
discount to the sale amount.
14. Click OK to add the calculation to your query.
15. Click OK to add the calculated item to your report.

You can format the Discount column to two decimal places.

16. Click 7.92 in the Discount column.
17. From the Format menu, click Data to show the Format dialog box.
18. In the Positive box, click 0.00 to format the values in the Discount column with two decimal
places. Click OK to format the Discount column, and press Esc to clear the highlighting.

Now you can see the discount Customer No. 1001 received for each product type.

Discovering Impromptu 41

Chapter 3: Create a Grouped List Report

Add a Column Total
You can add a total to the bottom of a numeric column, or to each group in a column by using
the Total button on the toolbar. Impromptu calculates the total each time the data for the report is
retrieved.
For example, you can add a total discount amount for each product type to clearly see how
much discount each customer received for each product type over the year.

Try This...
To add a total to a group column
1. Click 7.92 in the Discount column to select it.
2. On the toolbar, click the Total button.

Discount Total
for each
product type

You can see the total discount for each product type. It seems that the discount amounts are
related to the quantities, and you should take this into account when you review the discount
policy for active customers.
3. Click 1080.36 in the Discount column to select it.
4. Drag 1080.36 above 7.92 and into the Environmental Line header.
5. Click the blank area to the right of the report to select the entire report.
6. From the Format menu, click Properties, and then click the Layout tab.
7. Clear the three Footer check boxes, click OK to remove all the footers, and then press Esc
to clear the highlighting.
8. From the File menu, click Save As.
9. Type Customer Discount Tutorial in the File Name box, and click Save.
To compare your report to our version, open the Customer Discount report in
installation_location\cern\Samples\Impromptu\Reports.

What’s Next?
In this chapter, you learned how to create a grouped list report, use a predefined condition to
filter your report, group data, create calculations, add column totals, and move data around in
the report.
For more information about the topics in this chapter, see the online Help. In the Index tab, type
• templates
• grouping
• conditions
• headers, adding
The next chapter shows you how to create a summary report containing summary information
without details.
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The summary report shows a synopsis of your data, and is useful when you want to see an
overview without the details. You can tailor the amount and level of information in the summary
report.
For example, a summary report helps you develop an overall picture that you can use to decide
which product lines are generating the highest total sales for each product type. In this chapter,
you will learn about:
• adding a summary column to a list report
• removing a data item from a report
• organizing the data in a report
• sorting summary data

This summary column shows that Water Purifiers are generating the highest total
sales for the Environmental Line product type.

What Is a Summary Report?
A summary report uses the information from the database to provide summarized (or "rolled
up") numbers.

Create a Summary Report
You already know how to
• open a catalog
• create a list report
• add data items to the report
• group data items
By creating a summary report, you’ll also learn how to
• create a list report
• summarize data items in the list report
• remove detail data from the report
• organize the remaining summary columns
• sort the data
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In this chapter, the Great Outdoors sales manager asked you to create a report that answers the

question "Which product lines are generating the highest total sales?"

Create a List Report
You can create a report to help you decide which products are performing the best based on
sales.

Try This...
To create a list report and add the sales data
1. If you have just started Impromptu, click Close to cancel the Welcome dialog box.
Note: If the dialog box on your screen says Report Wizard, you are in the wrong place. Click
Cancel and return to the blank screen.
2. If you are already in Impromptu and do not have the Great Outdoors Sales Data catalog
open
•

From the Catalog menu, click Open.

•

In the Open Catalog dialog box, locate and double-click the Great Outdoors Sales Data
catalog.

•

If the Cognos Common Logon dialog box appears, click Cancel.

• Click OK to accept your user class.
Tip: Check the message in thestatus line. When it says "Sales data for The Great Outdoors
Co.," this catalog is open.
3. From the File menu, click New, and then click OK to accept the Simple List default template.
4. In the Catalog box, double-click the Products folder to open it and show its contents.

5. Double-click Product Line to add it to the Query Data box.
6. Double-click Product Type to add it to the Query Data box.
7. Double-click the Price and Cost folder to open it.
8. Double-click Product Price to add it to the Query Data box.
The Query Data box contains three data items.

Do not click OK yet—there is more to do.

Add a Summary to the Report
You can create summaries in Impromptu to show high level information in your report.
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If you want your report to contain only summarized information without details, you can add a
summary using the Data tab (Query dialog box) as you create your report. Impromptu performs
the summary when the report data is retrieved. Since the data is only retrieved once, this is
more efficient, particularly when you have a large database.
When you use the Summary button in the Data tab, you can add one or more of the following
summaries to a report
• a total
• a minimum
• a maximum
• an average
• a count
• a percent of the total
Additional summarizing capabilities, such as running-total and rank, are available using the
Calculate button. You learned about adding calculated data items in "Chapter 3: Create a
Grouped List Report."
You can add a new summary column such as a Total Sale Amount column that calculates the
totals for the product lines.

Try This...
To add a summary column to the report
1. Double-click the Orders and Order Details folders to open them.
2. Click the Sale Amount calculated data item, and click the Summary button to show the
Summary dialog box.

The dialog box title changes
depending on the data item
you’re using to create a
summary.

Summary button

Total button

3. Click the Total button, and click OK to add Total Sale Amount to the Query Data box.

Note: Impromptu automatically names the summary data item by combining the summary
function and the data item name.
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4. Click OK to show the report containing the summarized data.

Note: Summaries are associated with a location. The total changes according to where the
summary is placed in your report.
5. Double-click the <Type here to customize title> text to place the flashing I-beam in the text
area.
Tip: If you click the title once, Impromptu selects the entire title text frame. You can press
Esc to clear the highlighting and try again.
6. Click and drag the I-beam to select the entire line of text.
7. Type Total Sales Per Product Line and press Esc to add this title to the report.

You can see that Bio-Friendly Soaps has a high Total Sale Amount compared with the rest
of the products, and has a relatively low Product Price, making it a high selling item. It would
be a good decision to consider focusing marketing on Bio-Friendly soaps.
You can now fine-tune your report to improve the usability and to ensure you include only
the relevant information.
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Remove a Data Item From the Report
You can easily remove unnecessary information from an Impromptu report using the Delete key.
When you press the Delete key, the information is no longer in the report. However, the query
you created in the Query dialog box still contains the data item. If you want to permanently
remove the data item from the query, you have to remove the data item using the Remove
button in the Data tab (Query dialog box).
Database information request

Database information retrieval
Corporate
database

Database query

Database report

For example, since you only need to see the total sale amount for each product line, you can
remove Product Price from the query.

Try This...
To remove a data item from the query
1. From the Report menu, click Query, and ensure the Data tab is selected.
2. In the Query Data box, click Product Price, and then click the Remove button.

Remove button
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3. Click OK to recreate the report without the Product Price column.

All the data items in the query are used in the report.

Organize the Data in the Report
You can change the order and appearance of the columns to organize the data in your report
and make the report clearer and easier to read.
Tip: You can resize the column width by clicking the column heading and dragging the selection
handles left or right.

Reordering the Columns
You can change the column order in the report to make it easier to get the information you need
from the report.
For example, your report would be more logical if the Product Line and Product Type column
positions were reversed. You can also change the sequence in which the data items are
grouped for the report.

Try This...
To move the Product Type column
1. Click a data item in the Product Type column.
2. Drag the column horizontally to the dotted line to the left of the Product Line column and
drop it.
As you drag a column, a vertical dotted line indicates the new location of the column.

A vertical dotted line indicates the new location of the column.

Impromptu reverses the order of the columns in the report.
Note: If you inadvertently place the column in the wrong place, you can click the Undo
command from the Edit menu.
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3. Press Esc to clear the highlighting from the column.

You can now organize the data so that you can easily compare salesfor each product type.
4. From the Report menu, click Query, and then click the Group tab.

5. Click and drag Product Type above Product Line.
6. Click OK to show the re-grouped report.

7. Click any value in the Total Sale Amount column, and click the Currency button to add
currency formatting to the Total Sale Amount column.

Dollar signs and currency formatting are added to the
values.

Adding currency formatting improves the report by making the sale amounts easier to read.
8. Press Esc to clear the highlighting.
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Sort Your Summary Data
You can sort your summary data to gain insight into trends in your business by using the Sort
Ascending button on the toolbar. Impromptu sorts numeric and alphabetic columns in ascending
order by default.
For example, to quickly see which product lines have low sales, you can sort the Total Sale
Amount column.

Try This...
To sort the Total Sale Amount column
1. Click any value in the Total Sale Amount column, and click the Sort Ascending button to
show the report with the Total Sale Amount sorted in ascending order by product type.

Now you can see that Recycled Products, Sport Wear, and Back Packs generate the lowest
sale amounts across all Product Type groups.
2. From the File menu, click Save As.
3. Type Total Sales Per Product Tutorial in the File Name box, and click Save.
To compare your report to our version, open the Total Sales Per Product report in
installation_location\cern\Samples\Impromptu\Reports.

What’s Next?
In this chapter, you summarized the data to show the total sale amount per product line.
For more information about the topics in this chapter, see the online Help. In the Index tab, type
• removing, data
• summaries
• grouping
• columns
• sorting
The next chapter shows you how to see your data from a different perspective using a Crosstab
report. You might use a Crosstab report to evaluate the performance of your sales
representatives.
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The crosstab report shows your corporate data from a new perspective. It enables you to show
values at the intersection points of rows and columns, and is useful when you need to compare
information using one or more criteria in one report. In this chapter, you will learn about:
• creating crosstab reports
• swapping rows and columns
• formatting values and adding data
• creating nested crosstabs
• changing a report from crosstab to list

The sales figures for the Ultra Sports 4 customer indicate that Bill Gibbons is a good
prospect for promotion to managing sales for the Ultra Sports chain of customers.
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What Is a Crosstab Report?
Crosstab reports provide a different perspective on your data. One of the advantages of using
the crosstab report is that you can change your view of the data by changing its presentation. A
crosstab report summarizes information in a concise table of rows and columns that shows the
value at the intersection point of each row and column.
In the list report, the rows
and columns show the
business data details in
columnar format.

In the crosstab report, the
intersection points of the
rows and columns show
the summarized business
data.

A crosstab report is made up of grouped data items shown on the left side and across the top of
the report, with summarized data items shown within the cells.

Create a Crosstab Report Using the Report Wizard
You already know how to
• open a catalog
• create a report using a template
• create a list report using the Report Wizard
• add data items to the report
By creating a crosstab report, you’ll also learn how to
• swap rows and columns in a crosstab
• add new data items to your crosstab report
• create a nested crosstab report
• change the crosstab report to a list report
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With Impromptu you can produce three types of crosstab reports: simple, grouped, and nested.

Simple crosstab report

Grouped crosstab
report

Nested crosstab report

You can create a crosstab report from scratch, or you can start with an existing report, such as a
list report. For example, if you see that a list report should be a crosstab report, you don’t have
to start again. You can change the list report into a crosstab report using the Query command
from the Report menu.
In this chapter, you want to discover which sales representative has the highest sales for each
product line.

Try This...
To create a crosstab report using the Report Wizard
1. If you have just started Impromptu, click Close to cancel the Welcome dialog box.
2. If you are already in Impromptu and do not have the Great Outdoors Sales Data catalog
open
•

From the Catalog menu, click Open.

•

In the Open Catalog dialog box, locate and double-click the Great Outdoors Sales Data
catalog.

•

If the Cognos Common Logon dialog box appears, click Cancel.

• Click OK to accept your user class.
Tip: Check the message in the status line. When it says "Sales data for The Great Outdoors
Co.," this catalog is open.
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3. Click the New button to show the Report Wizard.
Note: Do not click New from the File menu. This will open the New dialog box instead of the
Report Wizard.

4. Type Sales Rep. Results, and click Next to show the list/crosstab choice page.

5. Click Crosstab Report, and click Next to show the crosstab page.
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Select the Data
On the crosstab page you select data for your report. Each data item is presented as a row,
column, or cell in your report.

Try This...
To select the data for your crosstab report
1. In the Available Data box, double-click the Products folder to open it.
2. Drag Product Type into the Rows box.
Tip: You can also move Product Type by clicking it and then clicking the Rows button.

Rows button

When you place an item in the Rows box, it
appears as a row in your crosstab report.

3. Double-click the Orders and Additional Info. folders to open them.
4. Drag Sales Rep. Name into the Columns box.
5. Double-click the Order Details folder.
6. Drag Sale Amount into the Cells box.
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7. Clear the Sum check box under the Cells box.
You can add or remove Summary Totals for your Columns and Rows by selecting or clearing
the Sum check boxes.

Sum check box for Columns

Sum check box for Rows

8. Click Finish to retrieve the data and show the report.

You can see that Bill Gibbons has the highest Environmental Line sales. However, it’s
difficult to compare all the sales representatives’ figures for the Environmental Line, since
most of them are off the screen.

Get a Different View of Your Data
You can get a different perspective on your data in a crosstab by swapping the rows and
columns or by changing the data.

Swap Crosstab Rows and Columns
You can learn new things about your data when you look at the information in a different way.
You can use crosstab reports to spot high and low points in the data that you hadn’t previously
noticed.
For example, you can swap the Sales Representative and Product Type information to more
easily compare the sales representatives’ performance for the Environmental Line product type.

Try This...
To swap crosstab rows and columns
1. Click Environmental Line and move your pointer over the selected area.
The pointer turns into a four-headed arrow.
2. Click and drag the pointer up towards Product Type.
The dotted line changes from a vertical angle to a horizontal angle and the Pivot pointer
appears.
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3. Drop the dotted line at the bottom of the Product Type cell.

Note: You can also drop the dotted line at the top of the cell.
4. Click Bill Gibbons and move your pointer over the selected area.
5. Click and drag the column to the left side of the 61959.52 cell until the Pivot pointer appears.

Dotted line

Pivot pointer

Note: Do not release the mouse button until the Pivot pointer appears. If you do release the
mouse button, click Undo Drag and Drop from the Edit menu, and then try again.
6. Drop the dotted line to complete the swap.

Here you see that Bill Gibbons has the highest sales figures for the Environmental Line, and
could be a good candidate for a promotion; however, it’s difficult to compare the figures
since they use different formatting. Some of the values have one decimal place, and some
have two. For example, the first two items in GO Sport Line are "20631.44" and "1912.8."

Format the Values in Your Report
You can format the sales figures in your report to improve readability.
Depending on your database values, you can also specify different formats for positive and
negative numbers, as well as for zeros and missing values.
For example, to more easily compare the values in your report, you can format them to have two
decimal places.

Try This...
To format the values in the report
1. Move your pointer to the top of the Environmental Line column.
The pointer becomes a downward pointing arrow.
2. Click once and then click again to select all three Product Type columns.
3. From the Format menu, click Data to show the Format dialog box.
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4. In the Positive box, click 0.00.
5. In the Missing box, type "0.00" with the quotation marks, and then click OK to format the
data in the report.
Note: You can type a numeric value or text in the Missing box to replace empty cells in your
crosstab report.
6. Press Esc to clear the highlighting from the report.

Add a New Data Item to the Crosstab Report
Impromptu enables you to add more information to your crosstab report to change your view of
the corporate data. This helps you to compare the information by using more than one criterion.
To add more data to your crosstab report, you must add the data item to the query and then
retrieve the new data from the database.
For example, you’re reviewing the sales for each sales representative on a
customer-by-customer basis. This will help identify which sales representatives tend to focus on
a narrow range of accounts or products.

Try This...
To add a data item to a crosstab report
1. From the Report menu, click Query, and ensure that the Crosstab tab is selected.
2. In the Catalog box, double-click the Customers folder to openit.
3. Drag Customer Name into the Rows box and click OK to show the report.
4. From the View menu, click Screen Layout to view the entire report.

You can see that the bulk of Bill Gibbons’ sales are to Ultra Sports 4. This could indicate that
he’s a good candidate for managing the Ultra Sports chain of customers.
5. From the File menu, click Save As.
6. Type Product Type Sales Tutorial in the File Name box, and click Save.

Create a Nested Crosstab Report
You can also change the data you see in a crosstab report without removing any of the data
from the query. Creating a nested crosstab report makes it easier to compare your information
using more than one data item in a column.
For example, you know Bill Gibbons’ sales to Ultra Sports 4 are profitable. But you would like to
see what his sales are for each product line in the Ultra chain. You can add product lines to your
report and compare Bill’s sales with those of the other sales reps.

Try This...
To create a nested crosstab report
1. From the Report menu, click Query, and ensure that the Crosstab tab is selected.
2. Double-click the Products folder to openit.
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3. Drag Product Line into the Columns box and click OK to show the nested crosstab report.

Here you see that Bill Gibbons sells a lot of water purifiers and carry-bags. You can also see
that Bjorn Flertjan’s sales to the Over the Top Cycles chain seem to be more consistent for
all the product lines. The nested crosstab report indicates that Bjorn Flertjan’s sales are
more consistent than Bill Gibbon’s across the Great Outdoors line of products.

Change the Crosstab Report to a List Report
There are times when you want to work with the report data further to add special formatting,
more detail, and so on. Since adding more data items to a crosstab report can change the intent
of the report, it can be easier to work with the data in a list report instead of a crosstab report.
Impromptu enables you to easily change the crosstab report to a list report using the Query
dialog box.

Try This...
To change the crosstab report to a list report
1. From the Report menu, click Query, and ensure that the Crosstab tab is selected.
2. Click Build List Report.

The Crosstab Query dialog box is replaced by the List Query dialog box.
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3. Click OK to show the new list report.

You can now easily work with the report information.
Note: You can also use the Pivot pointer to change a crosstab report to a list report.
4. From the File menu, click Save.
To compare your report to our version, open the Product Type Sales report in
installation_location\cern\Samples\Impromptu\Reports.

What’s Next?
This chapter showed you how to use a crosstab report to view your corporate data from a
different perspective. You saw how to create a crosstab report, swap rows and columns, add
data, create a nested crosstab report and change a crosstab report into a list report.
The next chapter shows you how to use your corporate database to create, format, and print
mailing labels.
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The mailing labels template can save you time by formatting information such as each
customer’s name and address. In this chapter, you will learn about:
• mailing labels and how to create them
• formatting the data on a mailing label
• previewing your labels

You can use corporate data to create mailing labels for your new product brochure mailing.

What Is a Mailing Label Report?
Mailing labels are a different type of report than the crosstab and list reports you created so far.
A mailing label report is a set of frames, each of which contains a mailing address. This report
provides a quick and easy way to print mailing labels based on customer information in a
database. With the mailing label report, you no longer need to use the complex mail merge
equations available in word processing packages.

Create Mailing Labels Using a Template
You already know how to
• open a catalog
• create a new report using a template
• add data items to the report
• print a report
By creating mailing labels, you’ll also learn how to
• format a specific data item
• create and apply styles
• preview your mailing labels before printing them
In this chapter, you need mailing labels for all your customers so you can send them the latest
product brochure.
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Since the mailing labels are intended to be printed, they appear in Page Layout view rather than
in Screen Layout view. You learned about the different views in "Chapter 2: Create a List
Report."

Try This...
To create mailing labels using a template
1. If you have just started Impromptu, click Close to cancel the Welcome dialog box.
Note: If the dialog box on your screen says Impromptu Report Wizard, you are in the wrong
place. Click Cancel and return to the blank screen.
2. If you are already in Impromptu and do not have the Great Outdoors Sales Data catalog
open
•

From the Catalog menu, click Open.

•

In the Open Catalog dialog box, locate and double-click the Great Outdoors Sales Data
catalog.

•

If the Cognos Common Logon dialog box appears, click Cancel.

• Click OK to accept your user class.
Tip: Check the message in the status line. When it says "Sales data for The Great Outdoors
Co.," this catalog is open.
3. From the File menu, click New, and then double-click the Mailing Labels template to show
the Query dialog box.

Add and Remove buttons

These are placeholders for data
items in the mailing labels.

Note: If you put the wrong item in a placeholder, click the item and then click the Remove
button.
4. Double-click the Customers and Customer Sites folders to open them.
5. Double-click Customer Contact to add it to the Query Data box.
Notice that Customer Contact is placed under the Name placeholder.

6. Double-click Customer Name to place it under the Address Line 1 placeholder in the Query
Data box.
7. Double-click the Address folder to open it.
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8. Double-click the following data items to add them to the Query Data box:
•

Address

•

City

•

Province/State

•

Postal/Zip Code

•

Country

9. Click OK to show the mailing labels.
Impromptu formats the mailing labels to the standard page size.

You can see that your mailing labels contain all the information you require. However, you
want to ensure that the company name and the receiver name are highlighted.

Highlight the Critical Information
You can use formatting to highlight the critical information in your mailing labels. Highlighting
specific information enhances the look of the labels, and decreases the possibility of the
important information being overlooked.
You can format the data directly, or you can format data using a style. A style is a collection of
information about the type of font, color, background and pattern, border, and so on, that can be
stored and applied at once to a block of text, or a frame, and so on.
Styles are a fast way of applying common formatting to objects in your report. You can apply an
existing style, or you can create a style to adhere to a particular style convention that you want
to apply in more than one report. You can also use styles to conditionally format selected
information.

Select Multiple Objects to Change
You can select more than one object in your report to apply changes quickly. For example, you
can change the size of the address lines on your mailing labels to make them bigger and easier
to read. A change made to a single frame in your report affects all related frames in the report.
When you apply individual format changes to the address lines on one label, Impromptu applies
this change to all the address lines in your report.
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Try This...
To change multiple objects in the mailing labels
1. Click the first address line on one of the mailing labels.

This address line is selected

2. Move your pointer over Sydney, NSW, and Ctrl+click the address line.
3. Move your pointer over 2255, Australia, and Ctrl+click the address line.

4. From the Format menu, click Font to show the Format dialog box.
Tip: You can also change the appearance of the text by using the standard Windows
options on the toolbar (font, font size, font style, and color).
5. Click Times New Roman in the Font box, 11 in the Size box, click OK to show the mailing
labels, and then press Esc to clear the highlighting.

Impromptu changes the font and size of all the address lines in the report.

Changing the font and increasing the size of the address lines by one point makes them
easier to read.

Achieve Consistency Using Styles
You can define styles for your mailing label reports to ensure your reports remain consistent with
your corporate standards. You can use these styles in subsequent reports as well, to ensure
that you achieve corporate consistency across reports.
Styles can include fonts, borders, patterns, and data formatting. Once you define the styles, it’s
easy to apply them to selected objects in your report. Styles combine individual format changes
into a single step.
For example, you can add a "Company" style to format the company name on your mailing
labels.
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Try This...
To add styles to your mailing labels
1. Select a company name in the mailing label, for example, Backwoods Equipment Pty.
2. From the Format menu, click Styles.
3. Click Add to show the Style Definition dialog box.

The Content
tab identifies the
components of
the style.

4. Type Company in the Style Name box.
5. Click the Font and Borders check boxes to activate the Font and Borders tabs.
6. Click the Font tab.
7. In the Font Style box, click Bold.
8. In the Size box, click 12, and then click the Borders tab.

Clicking the horizontal or vertical arrows defines specific borders.

9. In the Border box, click the upper horizontal arrows.
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10. In the Line Style box, click the first line selection.

11. In the Borders box, click the lower horizontal arrows, and then click OK to add the Company
style to the Style list in the Styles dialog box.
12. Click Apply to apply the Company style to the mailing labels, and click Close to show the
report.

Although the company name is easier to see, it runs into the
address lines.
Leave the selection highlighted, since you have more to do.
13. Position your pointer over the selected company name, and click and drag the name higher
up on the label until it approximately matches the example. Press Esc to clear the
highlighting from the object.

The company name is noticeable and complies with your company standards.
14. From the File menu, click Save As.
15. Type Customer Labels Tutorial in the File Name box, and click Save. To compare your report
to our version, open the Customer Labels report in
installation_location\cern\Samples\Impromptu\Reports.
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Preview Your Labels
You are currently in Page Layout view which you can use to preview your report before printing.
This enables you to check the placement of the information on the labels and to check any
measurements you need to match pre-printed corporate labels.
To change the size, alignment, or number of labels on each page, click one of the labels and:
• From the Format menu, click Properties and then use the three tabs to edit your labels

Check the Measurements in Your Mailing Labels
Impromptu enables you to check measurements using the ruler.
For example, you finished checking the content of the mailing labels, and you want to ensure
that the labels line up properly with your company’s pre-printed labels. They need a 1.25 in. by
1.25 in. (3.2 cm by 3.2 cm) blank square in the upper-left corner to accommodate the Great
Outdoors logo.

Try This...
To show the rulers
• From the View menu, click Ruler.

Your labels have a 1.25 in. by 1.25 in. (3.2 cm by 3.2 cm) white square in the upper-left
corner so there’s enough room to accommodate your company’s pre-printed company
labels.
Tip: You can change the ruler measure to inches or centimeters. From the Tools menu, click
Options and select Inches or Centimeters in the Grid Interval box.

Get the Big Picture
Impromptu provides a zoom feature to enable you to see the entire page before you print it.
For example, you want to count the number of the pages of mailing labels you’ll need to put into
the printer tray.
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Try This...
To zoom in and out on your mailing labels
1. From the View menu, click Zoom.
2. Click Whole Page and click OK to see the entire page of mailing labels on your screen.

3. Click the Next Page button to scroll to the end of the report.
Next Page button—located under the vertical scroll bar.
Count the pages. You’ll need 15 pages of labels.

What’s Next?
In this chapter, you used your corporate data to create mailing labels, you formatted the labels,
and you previewed your mailing labels before printing them.
For more information about the topics in this chapter, see the online Help. In the Index tab, type
• formatting
• patterns
• borders
• changing
• styles
• previewing reports
The next chapter shows you how to create form letters to advertise sales events, and how to
create company templates.
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Creating form letters in Impromptu can be as easy as selecting the company name and address
information, then letting Impromptu do all the work. In this chapter, you will learn about:
• creating form letters
• filtering the data for each form letter
• changing the form letter template

Including data from the corporate database in your form letters is straightforward and
can make your form letters highly effective.

What Is a Form Letter?
A form letter is a letter that uses the same body content, but is personalized with each recipient’s
name, address, company, and other information. It can be an effective marketing tool.
It is easy to create form letters using Impromptu’s predefined Form Letter template. You simply
create a letter and then indicate the data items that you want to appear in the letter. Impromptu
automatically fills in the blanks.

Create a Form Letter Using a Template
You already know how to
• open a catalog
• create a new report using a template
• add data items to the report
• print a report
By creating a form letter, you’ll also learn how to
• use a rank summary filter to order the data
• add a data item to the body of the letter
• add a picture
• create a template
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In this chapter, you’re sending letters to all your customers to promote your new mail order
catalog. These letters will contain personalized address information as well as the customer’s
favorite product. You can include a discount voucher for the favorite product with these letters.

Try This...
To create a form letter using a template
1. If you have just started Impromptu, click Close to cancel the Welcome dialog box.
Note: If the dialog box on your screen says Impromptu Report Wizard, you are in the wrong
place. Click Cancel and return to the blank screen.
2. If you are already in Impromptu and do not have the Great Outdoors Sales Data catalog
open
•

From the Catalog menu, click Open.

•

In the Open Catalog dialog box, locate and double-click the Great Outdoors Sales Data
catalog.

•

If the Cognos Common Logon dialog box appears, click Cancel.

• Click OK to accept your user class.
Tip: Check the message in the status line. When it says "Sales data for The Great Outdoors
Co.," this catalog is open.
3. From the File menu, click New, and then double-click the Form Letter template to show the
Query dialog box.

You will replace
these
placeholders
with data items
from the
catalog.

Add and Remove buttons

Note: If you put the wrong item in a placeholder, click the item and then click the Remove
button.
4. Double-click the Customers and Customer Sites folders to open them.
5. Double-click Customer Contact to add it to the Query Data box.
Notice that Customer Contact is placed under the Contact Name placeholder.

6. Double-click Customer Name to place it under the Address Line 1 placeholder in the Query
Data box.
7. Double-click the Address folder to open it.
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8. Double-click the following data items to add them to the Query Data box:
•

Address

•

City

•

Province/State

•

Postal/Zip Code

•

Country

9. Click OK to show the letters.

The letters contain the personalized address information. Now you can add the product data
item to the query to use when you add the favorite product information to the letters.
10. From the Report menu, click Query.
11. In the Catalog box, double-click the Products folder to open it.
12. Double-click Product to add it to the Query Data box.
The Query Data box should look like this:

The Query Data box contains all the information you need for the personalized letter, as well
as the Product data you will need to find the customer’s favorite product.
13. In the Query Data box, click Product.
14. Click the Mark for Insertion button.
You removed the arrow from the Product data item. This means that Product is in the query,
but is not inserted into the report.
Do not click OK yet—there’s more to do.

Filter the Data to Show Only the Favorite Product
You can filter your report data to include only the customer’s favorite product in your form letter.
You learned about filters in "Chapter 1: Essential Skills."
The filter you will add ranks the data and shows only the top-ranked data item. Each group of
data is ranked. For example, in your database, you might have these rows:
Cust. No. 2123 Fitness Pty Ltd.Tents 4
Cust. No. 2123 Fitness Pty Ltd.BackPacks 6
Cust. No. 2123 Fitness Pty Ltd.Sunscreen 16
Using the summary filter Rank (Qty) for Customer Name, Impromptu sorts these rows in the
following order:
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Cust. No. 2123 Fitness Pty Ltd.Sunscreen 16
Cust. No. 2123 Fitness Pty Ltd.BackPacks 6
Cust. No. 2123 Fitness Pty Ltd.Tents 4
For example, you can add a filter to the query that retrieves each customer’s favorite (that is,
highest ranking) product purchases, and insert the product name into the form letter.

Try This...
To add a filter to your form letter
1. Click the Filter tab.

The Available

Components box shows
the available filter
components.

The Filter Definition
box shows the filter as
you create it.

The Filter Options
box allows you to set the
filter options you need.

2. In the Filter Type box, click Summary to eliminate data from the report based on a summary
data item.
3. In the Available Components box, double-click Summaries.
4. Double-click Rank to add it to the Filter Definition box.

Tip: If you select the wrong summary, click Clear to clear everything from the Expression
box.
5. In the Available Components box, double-click Catalog Columns to open it.
6. Double-click the Orders and Order Details folders to open them.
7. Double-click Qty to add it to the Filter Definition box.
8. In the Available Components box, double-click the for component to add it to the Definition
box.
9. In the Available Components box, double-click Report Columns.
10. Double-click Customer Name to add it to the Filter Definition box.
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11. In the Available Components box, double-click the = component to add it to the Filter
Definition box.
12. Double-click the number component.
Impromptu places a 0 in the Filter Definition box.
13. Type 1 and click OK to create the letter.
You can see that the form letter contains the contact and address for the first customer in
the list. The report query now contains the data item and filter for the customer’s favorite
product, which you can add to your letter.

Complete the Form Letter Content
You can modify the body of the form letter to suit your requirements. When you change the body
of the letter, Impromptu automatically changes all the other form letters to match. The only
information that remains unique to each form letter is your selection of data items, such as
contact name, company, and address information.
For example, you can change the existing form letter text to include a paragraph promoting the
new mail order catalog and describing the discount voucher.

Add the Product to Your Letter
You can add the product information to your letter by inserting the data into the letter.

Try This...
To add the product to your letter
1. In the body of the letter, double-click
"Please accept this letter... <double-click to edit text>"
to place a flashing I-beam in the text area.
Tip: If you click only once in the text area, Impromptu selects the entire body text frame.
Double-click on the body of the letter to see the flashing I-beam.
2. Click and drag the I-beam over the entire first line in the body of the letter and press Delete
to remove it.
3. Type We’re enclosing a discount voucher for.
Press Esc to remove the flashing I-beam from the text.
4. From the Insert menu, click Data.
Your pointer changes to the following:
5. Click to the right of the address.
Impromptu shows the Query dialog box.
6. In the Query Data box, click Product, click the Mark for Insertion button, and then click OK.
Impromptu places the product name into the letter.

Note: You may need to adjust the size of the frame containing the product name to see all
the name text. To do this, click to select the product name, and drag one of the handles to
increase the size of the frame containing the product name.
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Move the Favorite Product to the Body of the Letter
You can add the product name to the body of your letter from the data you placed on the letter.

Try This...
To add the favorite product to the letter
1. Click the RiverKind Soap product name.
2. Press Ctrl+X to cut the product name.
Impromptu removes it from the letter and places it on the Clipboard.
3. Double-click in the body of the letter to place the flashing I-beam in the text body.
4. Click to place the I-beam after the word "for".
5. Press Ctrl+V to paste the product name RiverKind Soap into the body of the letter.

6. Click to place the I-beam after RiverKind Soap in the letter body, and type when you place
your order using our new 24-hour toll-free mail order number 1-800-555-9999.
7. Scroll down the page, and replace <sender’s name> with your name, press Enter, and type
Sales Director.
8. Press Esc.

Your letter now contains personalized information for each customer and promotes your new
mail order catalog.

Change the Form Letter to Meet Corporate Standards
Impromptu enables you to change the Form Letter template to better reflect your company’s
standards.
For example, you want to add the corporate logo to the letter.

74 Impromptu ( R )

Chapter 7: Create a Form Letter

Try This...
To add the corporate logo to the letter
1. From the Insert menu, click Picture Frame.
Your pointer changes to the following:
2. Click and drag a box to the right of the address in the letter to show the Picture Properties
dialog box.
3. Ensure that the Load From File option button is selected, and click Browse.
4. Locate installation_location\cern\Samples\Impromptu\Samples Support on the drive where
you installed Impromptu, and click Greatout.bmp.
5. Click Open.
Tip: If you want to copy the picture into the form letter report instead of referencing the
bitmap file, click the Make a Copy Within the Report check box. Anyone can then use the
letter, even if they don’t have access to the bitmap file.
6. Click OK to load the picture into the report.

7. Click the picture frame to select the picture, drag the handles to change the size of the
picture to fit it into the space, and then move the frame around until it fits into the space in
the letter.

8. From the Format menu, click Borders.
9. In the Defaults box, click None, and then click OK to remove the borders from around the
picture.
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10. Press Esc to clear the highlighting from the picture.

Your form letters all have the company logo on the top and are ready to print and send.
11. From the File menu, click Save As.
12. Type Voucher Letter Tutorial in the File Name box, and click Save.
To compare your report to our version, open the Voucher Letter report in
installation_location\cern\Samples\Impromptu\Reports.

Save as a Template
You can save any report as a template. Because templates only store formatting and
placeholders, they can save you time and help you produce reports and letters that are
consistent with company standards.
Templates also simplify the process for creating new reports. If Impromptu contained no
templates, you would start with a blank report and add frames every time you wanted to create a
report.
You can add new corporate templates to the New dialog box by saving them in a common
directory in the \templates\standard folder.
For example, you know you’ll be sending out follow-up letters over the course of the next two
years as part of a marketing strategy for the mail order catalog. You plan to use this letter as a
template for next month’s follow-up letter. You can save this letter as a template to make it easier
to update the letter next month.

Try This...
To save the letter as a template
1. Use Microsoft Explorer to create a new folder called Corporate Templates in
installation_location\cern\Samples\Impromptu\Templates\.
2. In Impromptu, click Save As from the File menu.
3. In the Save As Type box, click Templates (*.imt).
4. Locate installation_location\cern\Samples\Impromptu\Templates\Corporate Templates.
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5. Ensure that Voucher Letter.imt appears in the File Name box, and click Save.

The personalized information in the letters returns to general information. You can replace
the general information with personalized data from the corporate database when you
generate these form letters.
6. From the File menu, click Close.
7. From the File menu, click New.
8. Click the Corporate Templates tab to see the template you just created.
9. Click the Voucher Letter template and click OK to open the template’s Query dialog box.
10. Click Cancel to close the template.

What’s Next?
In this chapter, you created a form letter that contains personalized information for each
customer. You also created and saved a template.
For more information about the topics in this chapter, see the online Help. In the Index tab, type
• templates
• pictures
• rank summary
• calculations
• text, frames
The next chapter shows you how to add charts to your report to get a graphical overview of the
information in your report.
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Presentation
Charts are a graphical way of presenting information. You can use a chart to help you see
relationships and trends in your business. In this chapter, you will learn about:
• creating a chart
• showing overview information in a chart
• adding a chart to a report
• modifying a chart

Your charts show that the bulk of the Day Tripper sales are through the Mail Sales
channel, making Day Tripper a good candidate for a mail order catalog.

When Do You Use a Chart?
Use a chart to present information graphically. Charts usually work best with summary
information since details tend to be hard to read in charts.You can use a chart to help you see
trends in your business.

Create a Chart
You already know how to
• open a catalog
• create a new report using a template
• add data items to the report
• print a report
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By creating a chart, you’ll also learn how to
• add a chart to a blank report
• change the chart type
• change the chart’s appearance

Select the Data Items to Include in the Chart
In this chapter, the Great Outdoors company is starting a mail order catalog, and you’re deciding
which products should be included in the catalog. You need a chart showing the total sale
amount per sales channel for each product, and the proportion of the total sales amount
generated by each sales channel.
The blank report is a special type of report that is actually a form frame.
Form frames are very versatile. You can use a form frame to create a mailing label report, as
you learned in "Chapter 6: Create Mailing Labels," or a form letter, as you learned in "Chapter 7:
Create a Form Letter."

Try This...
To create a chart report using a blank template
1. If you have just started Impromptu, click Close to cancel the Welcome dialog box.
Note: You cannot create this report using the Report Wizard. If the dialog box on your
screen says Impromptu Report Wizard, you are in the wrong place. Click Cancel and return
to the blank screen.
2. If you are already in Impromptu and do not have the Great Outdoors Sales Data catalog
open
•

From the Catalog menu, click Open.

•

In the Open Catalog dialog box, locate and double-click the Great Outdoors Sales Data
catalog.

•

If the Cognos Common Logon dialog box appears, click Cancel.

• Click OK to accept your user class.
Tip: Check the message in the status line. When it says "Sales data for The Great Outdoors
Co.," this catalog is open.
3. From the File menu, click New, and then double-click Blank since you want to create a
report from scratch.
4. In the Catalog box, double-click the Products folder to open it.
5. Double-click Product to add it to the Query Data box.
6. Double-click the Orders and Additional Info. folders to open them.
7. Double-click Sales Channel to add it to the Query Data box.
8. Double-click the Order Details folder to open it.
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9. Click Sale Amount, and click the Summary button to show the Summary dialog box.

Summary button

Total button

10. Click the Total button.
11. Click OK to close the Summary dialog box and add the Total Sale Amount summary to the
Query Data box.

You added all the data items for the query.
Do not click OK yet—there’s more to do.

Group the Data Items to Show Overview Information in Your Chart
Charts are more useful if they show overview information instead of details, which can be
overwhelming in a chart. For example, you can group the product and sales channel data items
so the chart will show the total sale amount per group.

Try This...
To group data items for your chart
1. Click the Group tab.
2. Click Product and click Group.
3. Click Sales Channel and click Group.
4. Click OK.

Your report is blank. Don’t worry—it’s supposed to be that way. You can add your report
objects to this blank report.
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Add a Chart to the Blank Report
Once your data items are selected, you can add the chart to the blank report. For example, you
can add a bar chart to show the total sale amount per channel for each product.

Try This...
To add a chart to the report
1. From the Insert menu, click Chart Frame.
Your pointer changes to the following:
2. Position your pointer about a third of the way down the screen, and click and drag a box
about half-way across the screen and about half-way down.
Impromptu shows the Chart Properties dialog box.
3. Click OK.

Note: A chart shows the first grouped data item. In this example, the first grouped data item
is Product.

Scope Data in the Chart
Form frames, by default, show the first row of data from a database. You can change this default
and set the form frame so that it has multiple images that show either a single row of data or the
data for a single group. For example, you can show the data for each product in a single frame.

Try This...
To show the data in a single frame
1. Click outside the chart frame to select the entire report.
2. Right-click, click Properties, and then click the Layout tab.
3. In the Scope of Data box, click Data in the Group to group the data according to the data
item you select.
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4. Click OK to accept the Product group, and press Esc to clear the highlighting from the
report.
Impromptu shows the chart with the data grouped by product.

Click to view the chart for the next product.

Your report now has multiple pages and each page shows the total sale amount per sales
channel for each product.
Note: Sales channel appears in the chart by default because it is the next available grouped
data.
You can see that the Mail Sales channel has higher total sales for this product, indicating
that it’s a good candidate for a product catalog. However, you can’t tell which product this
represents. As well, it’s difficult to see any exact numbers, and you can’t see percentages.

Add a Title to the Report Using Query Data
You can add a text item to help you identify the product your chart represents. For example, you
can add the product name to the report.

Try This...
To add a product name to the report
1. From the Insert menu, click Text Frame.
Your pointer changes to the following:
2. Position your pointer at the top of the screen, and click and drag a box above the chart about
two-thirds across the screen.
Impromptu places a flashing I-beam where you can begin entering text.
3. Press Esc to clear the highlighting from the text frame.
Note: When you clear the highlighting from the frame, it looks like the frame disappears.
Don’t worry—it’s still there.
4. Click the text frame.
5. From the Insert menu, click Data, and then click inside the text box.
6. In the Query Data box, click Product, and then click the Mark for Insertion button.
Tip: The Mark for Insertion button acts as a toggle. It can mark and unmark items for
insertion in a report. The arrow on a data item indicates that the item will be inserted in the
report.
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7. Click OK.

Tip: You can make the font of the Product name bold and size 14 to improve the usability of
the report. As well, you can click the scroll buttons to scroll through the product list. Notice
that the product changes as you scroll.

Add a Different Chart Type
You can add different types of charts to your report to highlight different information.
For example, you can add a percentage pie chart to your report to show the proportion of each
sales channel in the total sales of a product.

Try This...
To add a pie chart
1. From the Insert menu, click Chart Frame.
Your pointer changes to the following:
2. Position your pointer under the other chart, and click and drag a box about two-thirds across
the screen and to the bottom of the screen.
Impromptu shows the Chart Properties dialog box.
3. Click the Format tab, and click the 2D Pie button.
4. Click the Percent check box.
Impromptu changes the callouts in the Sample box from values
to percentages.
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5. Click OK.

You can see that Direct Sales make up only 29.2% of the sales for the Day Tripper product,
while Mail Sales make up 35.7%, and Telephone Sales make up 35.2% of the sales. The
relatively high sales percentage for Mail Sales could indicate that the Day Tripper is a good
candidate for your mail order catalog.

Change the Chart’s Appearance
As well as changing the chart type, you can alter the appearance of the report to make it easier
to read. You can change chart elements, such as scale settings, colors, titles, and legends.
For example, you can add a title and legend to the chart, and highlight the Mail Sales portion of
the chart.

Try This...
To change the chart’s appearance
1. Right-click inside the pie chart, click Properties, and then click the Format tab.
Shows the Chart

Title box.

Shows the Chart

Legend box.

Shows the X
Shows the Chart

Data (axis) box.

Style box.

2. In the Select box, click the Chart Title section.
3. Type Product Amount per Channel in the Chart Title box.
4. In the Select box, click the Chart Style section.
5. Click the Pullout check box, and select Mail Sales from the Pullout list box.
6. Click the Chart Legend box in the Select box.
7. Click the Customize Color box.
8. In the Legend Color box, click Mail Sales and then click Custom List.
9. In the Palette dialog box, click Red, and then click OK.
10. In the Legend Color drop down list, click Red.
11. Click OK to make the Mail Sales section of the pie chart red.
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12. Press Esc to clear the highlighting from the chart.

Now the pie chart showcases the figures for Mail Sales for each product. The highest
percentage of Day Tripper’s sales are made through the Mail Sales channel. You should
include it in the mail order catalog.
13. From the File menu, click Save As.
14. Type Product Sales Chart Tutorial into the File Name box, and click Save.
To compare your report to our version, open the Prod Sales Chart report in
installation_location\cern\Samples\Impromptu\Reports.

What’s Next?
In this chapter, you created a chart report that combines two types of charts. You also changed
the appearance of the charts to increase their usability.
For more information about the topics in this chapter, see the online Help. In the Index tab, type
• charts
• text, inserting
The next chapter shows you how to use the charts and list reports to create freestyle reports
that combine many report frames.
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Impromptu gives you the flexibility of combining popular reports in a freestyle report. A freestyle
report is any report that combines frames, such as lists, charts, and pictures. You can create a
freestyle report that shows total sales per sales channel using a list frame, a bar chart, and a
picture of each product. In this chapter, you will learn about:
• creating a freestyle report
• adding a list frame, a form frame and a picture frame
• adding a chart

List frame—use the exact
sales figures for each
product in each sales
channel to show how much
each channel contributes to
product sales.

Chart frame—use a graphical
comparison of the sales amounts
for each sales channel to help you
decide whether you should market
a product more heavily in one
channel or another.

Picture frame—use a
picture of each
product to identify the
product.

What Is a Freestyle Report?
A freestyle report is any report that combines frames, such as charts, lists, and pictures. This
enables you to graphically highlight critical information, and show the details in a variety of
formats.
You can combine these frames in one report. When you insert frames into a report, or into other
frames, Impromptu keeps track of which frames belong together. A frame that contains
subordinate frames is called the parent frame, and when you move or format the parent frame,
all the frames within its boundaries (the subordinate frames) move with it and are formatted like
the parent frame.
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Impromptu hassix types of frames, each of which contains different types of data and is
represented by a different menu item or toolbar button:
This frame ...

Contains ...

Chart frame

A chart. It is a visual representation of your
data that enables you to quickly and easily
evaluate your data.

Form frame

Any report objects, including other frames.

List frame

Data items and other report objects in a
tabular row and column format similar to a
spreadsheet.

OLE Object

An OLE object. It can include information
from other OLE applications.

Picture frame

A graphic. It can be a static graphic file (such
as a logo that doesn’t change) or a dynamic
graphic file (such as a product photo that
changes with the changing product).

Text frame

Any text. It can be text that you enter, or text
from the database.

Create a Freestyle Report
You already know how to
• open a catalog
• create a report using a template
• add data items to the report
• group data items
• create a chart frame
By creating a freestyle report, you’ll also learn how to
• insert frames in a form frame
• add a picture data item
• add text
• add and remove scroll bars
• work with navigational buttons in the report
In this chapter, you will use a blank form frame as the basis for a freestyle report.
For example, you can create a report that contains a list report showing the product sales by
sales channel. As you scroll through the products, the product picture changes, and a bar chart
showing sales by channel changes to match the product.

Try This...
To create your freestyle report
1. If you have just started Impromptu, click Close to cancel the Welcome dialog box.
Note: If the dialog box on your screen says Impromptu Report Wizard, you are in the wrong
place. Click Cancel and return to the blank screen.
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2. If you are already in Impromptu and do not have the Great Outdoors Sales Data catalog
open
•

From the Catalog menu, click Open.

•

In the Open Catalog dialog box, locate and double-click the Great Outdoors Sales Data
catalog.

•

If the Cognos Common Logon dialog box appears, click Cancel.

• Click OK to accept your user class.
Tip: Check the message in the status line. When it says "Sales Data for The Great Outdoors
Co.," this catalog is open.
3. From the File menu, click New, and then double-click Blank.
4. In the Data tab, double-click the Products folder to open it.
5. Double-click Product and Product Picture to add them to the Query Data box.
Note: You need the Product Picture data item to add pictures to your freestyle report later in
this chapter.
6. Double-click the Orders and Additional Info. folders to open them.
7. Double-click Sales Channel to add it to the Query Data box.
8. Double-click the Order Details folder to open it.
9. Click Sale Amount, and click the Summary button to show the Summary dialog box.

Summary button

Total button

10. In the Summary dialog box, click the Total button, and then click OK to add the Total Sale
Amount to the Query Data box.
Your Query Data should look like this.

11. Click the Group tab, click Product, and then click the Group button to group the report on
Product.
12. Click Sales Channel, and click the Group button.
Your Group tab should look like this.
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13. Click OK to show the report.

Note: Your report is blank. Don’t worry—it’s supposed to be that way. You will add frames to
this blank report.

Add New Types of Information to the Report
After you select the data for the report, you can begin adding data in frames to your report.

Add a List Frame to the Report
You can add a list frame to your freestyle report to show the details of your data.
For example, you can add a list frame showing the total sales per product for each sales
channel.

Try This...
To add a list frame
1. From the Insert menu, click List Frame.
Your pointer changes to the following:
2. Leaving about 0.5 in. (about 1.25 cm) at the top of the screen for a title, click and drag a box
about half way across the screen, and about one-quarter of the way down the screen inside
the form frame, and release to create the frame.

Scroll bars appear by default in list frame reports when the list report is in Screen Layout
view.
3. Click inside the list frame.
4. From the Insert menu, click Data.
Your pointer changes to the following.
5. Click inside the selected frame to show the Query dialog box with the query information you
already selected.
6. In the Query Data box, click the Product data item.
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7. Ctrl+click the following:
•

Sales Channel

•

Total Sale Amount [for Sales Channel]

8. Click the Mark for Insertion button.
Impromptu marks each data item with an arrow to indicate that these data items are
selected for inclusion in the report.

9. Click OK to show the data in the list frame.

Note: Your list report may look slightly different than the example, depending on the size of
list frame you created.

Change the Scope of the Data in the Form Frame
A form frame can contain any report objects, including other frames.
By default, a form frame accesses the data, showing the first row of information from the
database. You can change the default settings and add pages to a report. You do this by setting
the scope of the data to show a single row or group.
For example, in your report, you can change the scope of the data to show the data for each
product which is a grouped data item. These data values change as you scroll to a new product.
When you change the scope of the data to a single row or data in a group in the form frame,
Impromptu adds navigation buttons to help you scroll between the pages.
Returns to first data value.
Moves to previous data value.
Moves to next data value.
Moves to last data value.

For example, you can change the scope of the data in your form frame to show data values for
each product.

Try This...
To change the scope of data in your form frame
1. Click anywhere outside the list report to select the form frame.
2. From the Format menu, click Properties, and then click the Layout tab.
3. In the Scope of Data box, click the Data in the Group button, and then select Product from
the list.
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4. Click OK to show the report with pages added.

You changed the form frame in the report to show grouped information instead of individual
information.
When you add new data to your report, it will be grouped according to product instead of
showing either one row of information at a time, or showing all the information at once.
5. Click the bottom right corner of the list frame to select the entire frame.
6. Right-click inside the highlighted frame, click Properties, and ensure the Layout tab is
selected.
7. From the List Frame Scrollbars box select None, and click OK.
8. Use the selection handles to adjust the frame size to approximately match the example, and
press Esc to clear the highlighting from the frame.

You can now see the total sales per channel for each product. By scrolling through the
product list using the navigation buttons in Screen Layout view, you can see that the Mail
Sales channel generates the lowest sale amount for almost every product. You can use this
information to make sales strategy decisions for the products.
Tip: You can remove the border around the list box by clicking Borders from the Format
menu, and clicking None.

Add a Chart to the Report
A chart is a graphical representation of your data that enables you to quickly and easily evaluate
your data.
For example, you can add a dynamic bar chart to your report that shows the sales per sales
channel for the product in the list report.

Try This...
To add a chart to the report:
1. From the Insert menu, click Chart Frame.
Your pointer changes to the following:
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2. Click and drag a box beneath the existing list frame about two-thirds across the screen and
about half way down the screen inside the form frame.
The Chart Properties dialog box appears.

3. Click OK to generate the report with the chart.

You can see a graphical comparison of the sale amount per sales channel for each product.
Some of the products are selling significantly higher amounts than others.
You can click the navigation buttons to move from one product to the next. The list and chart
change to reflect the current product.

Add a Picture Frame to the Report
You can add pictures to your report to enhance the report details.For example, you can add
dynamically linked product pictures that change to match the product in the list report.

Try This...
To add a dynamic picture to the report
1. From the Insert menu, click Picture Frame.
The pointer changes to the following:
2. Click and drag a box beside the existing list and chart frames in the form frame.
The Picture Properties dialog box appears.
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3. Click Load Using File Name in Column, and select Product Picture from the list.
4. Click the Prefix With Path check box, and click Browse to show the Browse dialog box.
5. Locate installation_location\cern\Samples\Impromptu\Samples Support on the drive where
you installed Impromptu, and click OK.
6. Click the picture frame, use the selection handles to adjust the size to approximately match
the position and size of the example, and press Esc to clear the highlighting from the
picture.

The picture of the Day Tripper makes it obvious, at a glance, that this product is a mid-size
day pack.

Add a Text Frame to the Report
You can add text to the report. The text can be a title, to describe the contents of the report, or
the text can be report data in a text frame.

Try This...
To add a text frame to the report
1. From the Insert menu, click Text Frame.
Your pointer changes to the following:
2. At the top of the frame, click and drag a rectangle about one-half of the way across the
screen, and about one-eighth of the way down the screen.
Impromptu inserts a flashing I-beam at the beginning of the area you defined.
Note: If you create a text frame that’s too large, it will cover the other frames in your report.
To correct this, click Undo from the Edit menu and complete step 2 again.
3. Type Sales by Sales Channel, and press Esc to accept the title.
4. Position the pointer over the text frame and click to select it.
5. From the Format menu, click Font to show the Format dialog box.
6. Select Arial, Bold, Size 18, and click OK to apply the formatting to the title.
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7. Adjust the size and position of the text frame to approximately match the example, and
press Esc to clear the highlighting from the text frame.
Tip: If your text frame is positioned incorrectly, you can select it, then click and drag the
frame to any position you want.

The title accurately reflects the report’s contents. You can click the navigation buttons to
scroll through the product list.
8. From the File menu, click Save As.
9. Type Sales by Channel Tutorial in the File Name box, and click Save.
To compare your report to our version, open the Sales by Channel report in
installation_location\cern\Samples\Impromptu\Reports.
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Index
A
adding
borders, 64
calculations, 39
chart legends, 85
charts, 82, 92
data to crosstabs, 58
data to reports, 24
footers, 16, 36
formatting to report values, 25
headers, 16, 36
list frames to form frames, 90-91
picture frames, 74
pictures, 74, 93
pullouts to chart frames, 85
query data to reports, 73
summaries, 42, 44
summary totals to crosstabs, 55
text frames, 94
titles, 25, 85
titles using query data, 83
totals, 42
adjusting
list frame size, 91
picture frame size, 74
applying styles, 63-64
associating
data in reports, 33
description, 33

B
blank reports
adding charts, 80-85
description, 80
borders
adding, 64
removing, 74

C
calculation expressions
clearing, 71
component list, 39
calculations
adding, 39
description, 39
callouts, changing for charts, 84
catalog folders
description, 19
using conditions, 35
catalogs
opening, 8
selecting, 8
centimeters, setting for rulers, 67
changing
borders, 64
chart callouts, 84

changing (cont'd)
chart legends, 85
chart types, 84
crosstabs to lists, 59
data in crosstabs, 56-58
fonts, 64
frame size, 73
list frame size, 91
picture frame size, 74
row width, 34
ruler scale, 67
size of mailing labels, 67
chart frames
inserting, 92
scoping data, 82
charts, 84
adding, 82, 92
adding pullouts, 85
adding titles, 85
changing callouts, 84
changing legends, 85
changing types, 84
creating, 80-85
description, 79, 92
formatting, 85
frame description, 87
grouping data, 81
inserting frames, 82
selecting data items, 80
clearing calculation expression box, 71
column total, 42
columns
moving, 17
reordering, 48
resizing, 48
select pointer, 16
selecting, 16
swapping in crosstabs, 56
conditions
description, 35
using to filter a report, 35
copying, pictures into reports, 74
copyright, 2
creating
calculations, 39
charts, 80-85
crosstab reports with the Report Wizard, 52-55
filters, 22
form letter reports, 69-74
freestyle reports, 88-94
grouped list reports, 30-36
list reports from crosstab reports, 59
list reports with a template, 19-20
list reports with the Report Wizard, 11-14
mailing label reports, 61-64
nested crosstabs, 58
new reports using templates, 76
styles, 64
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Index
creating (cont'd)
summary reports, 43-44
crosstab reports
adding data, 58
adding summary totals, 55
changing data, 56-58
changing to list reports, 59
creating nested crosstabs, 58
creating with the Report Wizard, 52-55
description, 52
selecting data, 55
swapping rows and columns, 56
currency formatting, 25, 48

D
data items
adding, 24
adding to crosstabs, 58
associating, 33
changing in crosstabs, 56-58
description, 20
formatting, 39, 57
formatting with styles, 63
grouping in charts, 81
inserting in list frames, 90
inserting in text frames, 83
inserting into form letters, 74
inserting under placeholders, 61, 69
removing from queries, 47
removing from reports, 47
selecting, 20
selecting for charts, 80
selecting for crosstab reports, 55
data scope
changing in chart frames, 82
changing in form frames, 91
deleting data from reports, 47
document
version, 2
dragging report objects to new position, 34
dynamic pictures
adding to freestyle report, 93
description, 87

E
expression components, for calculations, 39

F
Filter, 14
filter expressions
creating, 71
filter operators
description, 22
filtering
creating new filters, 22
description, 15, 22
using conditions, 35
using Filter buttons, 15
filters
creating, 22
fonts, changing for styles, 64
footers
adding, 16, 36
description, 36
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form frames
adding list frames, 90-91
changing size, 73
description, 82, 87, 91
in blank reports, 80
in freestyle reports, 88
in mailing label reports, 61
moving, 64
scoping, 91
form letter reports
creating, 69-74
description, 69
inserting data items, 74
formatting
charts, 85
data, 39
data as currency, 25, 48
report values, 25, 39, 48
report values in crosstabs, 57
row height, 36
using styles, 63, 83
frames
changing data scope, 91
changing size, 73
chart, 87
form, 80, 87
in mailing label reports, 61
inserting charts, 82
list, 87
OLE object, 87
picture, 74, 87
removing borders, 74
text, 83, 87
freestyle reports
adding charts, 92
adding list frames, 90-91
adding pictures, 93
adding text frames, 94
creating, 88-94
description, 87

G
group column, totals, 42
grouped list reports
creating, 30-36
description, 29
grouping
data in charts, 81
data in reports, 32

H
headers
adding, 16, 36
description, 36
resizing, 36

I
inches, setting for rulers, 67
inserting
chart frames, 82, 92
data into form letters, 74
data into list frames, 90
data into text frames, 83
list frames, 90
picture frames, 74, 93

Index
inserting (cont'd)
pie charts, 84
text frames, 83, 94

L
legends, changing for charts, 85
list frames, 91
adding to freestyle reports, 90-91
description, 87
inserting, 90
inserting data, 90
removing scroll bars, 91
list reports
creating from crosstabs, 59
creating with a template, 19-20
creating with the Report Wizard, 11-14
description, 19

M
mailing label reports
changing size, 67
creating, 61-64
description, 61
using frames, 61
Mark for Insertion, 83
measuring report objects, 67
move pointer, 17, 56
moving
columns, 17, 48
report objects, 34, 64
multiple report objects, selecting, 63

N
nested crosstabs, creating, 58

O
OLE objects description, 87
opening
catalogs, 8
existing reports, 9

P
Page Layout view
description, 26
previewing reports, 67
zooming, 67
pictures
adding dynamic, 93
adding static, 74
adjusting frame size, 74
copying into reports, 74
frame description, 87
inserting frames, 74, 93
referencing in reports, 74
pie charts, inserting, 84
pivot pointer, 56
placeholders
inserting data, 61, 69
pointers
chart frame, 82, 84, 92
drag and drop, 17
insert data, 90
list frame, 90
move, 17, 56

pointers (cont'd)
picture frame, 74, 93
pivot, 56
select column, 16
text frame, 83, 94
predefined filters. See conditions.
previewing reports, 67
zooming, 67
printing reports, 10
product
version, 2
prompts
description, 9
responding, 9
pullouts, adding to charts, 85

Q
queries
adding text to reports, 73
removing data items, 47
query data items
adding to titles, 83
description, 19

R
rank summary, 71
referencing pictures in reports, 74
removing
borders, 64, 74
data from queries, 47
data from reports, 47
scroll bars from list frames, 91
summary totals from crosstabs, 55
reordering columns, 48
report objects
moving, 34
report values
formatting, 48
report views
changing, 26
description, 26
Report Wizard
creating crosstab reports, 52-55
creating list reports, 11-14
reports
creating, 11
resizing
columns, 48
headers, 36
rows
changing width, 34
formatting height, 36
swapping with columns in crosstab reports, 56
rulers
changing scale, 67
turning on, 67

S
saving
reports, 14
reports as templates, 76-77
scoping data
in chart frames, 82
showing specified data in frames, 91
Screen Layout view, description, 26
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Index
scroll bars, removing from list frames, 91
selecting
catalogs, 8
columns, 16
data items, 20
data items for crosstab reports, 55
multiple report objects, 63
Simple List template, 19
sorting
data in reports, 50
static pictures
adding to reports, 74
description, 87
styles
defining, 64
description, 63
formatting data, 63
highlighting critical information, 63-64
summaries
adding, 42
adding to reports, 44
summary
description, 44
summary reports
creating, 43-44
description, 43
summary totals
adding to crosstabs, 55
suppressing redundant data, 33
swapping rows and columns, description, 56
switching crosstabs to lists, 59

T
templates
description, 76
Form Letter, 69
Grouped List, 29
Mailing Labels, 61
saving a new, 76-77
Simple List, 19
using to create list reports, 19-20
using to create reports, 76
text frames
adding to freestyle reports, 94
changing size, 73
description, 83, 87
formatting text, 83
inserting, 83, 94
inserting data, 83
titles
adding to chart frames, 85
adding to reports, 25, 94
adding using query data, 83
description, 25
total, column, 42
totals, adding, 42

U
using
this book, 5

V
version
product, 2
viewing rulers, 67
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views
changing, 26
description, 26
Page Layout, 67
Screen Layout, 26

W
Welcome dialog box
creating a report using a template, 19

Z
zooming reports, 67

