IBM Cognos Controller
Last updated: 2017-03-08

Getting Started with Controller
Product Information

This document applies to IBM Cognos Controller Version 10.3.0 and may also apply to subsequent releases.

Licensed Materials - Property of IBM

US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
Contents

Introduction .................................................. v

Chapter 1. Setting up the environment ......................... 1
Review supported environments .................................. 1
Create two empty databases .................................. 1
Verify that Microsoft .NET Framework is installed .......... 2
Verify that Microsoft Visual C++ 2005 Redistributable is installed ...... 2
Enable Access to the COM+ Server .......................... 2

Chapter 2. Installing and configuring IBM Cognos Controller on one computer ......... 3
Install the server components .................................. 3
Install Framework Manager .................................. 3
Connect to the content store database .......................... 4
Save your settings and start the IBM Cognos services .......... 4
Configure the web server .................................. 5
Test your access to the portal .......................... 6

Chapter 3. Configure IBM Cognos Controller components ................. 9
Configure Microsoft ASP.NET .................................. 9
Configure Microsoft .NET Framework ........................ 9
Install a database driver .................................. 10
Configure the Controller database .......................... 10
Configure your web browser .................................. 11
Test IBM Cognos Controller .................................. 12
Import the IBM Cognos Controller Standard Reports Package .......... 12

Appendix. Accessibility features .................. 15
Keyboard Shortcuts for the Installation Wizard .............. 15

Notices .......................................................... 17

Index .......................................................... 21
Introduction

IBM® Cognos® Controller is a Web-based financial consolidation tool that provides standard reports to support both statutory and management reporting.

This document is intended for use with IBM Cognos Controller. It provides the information you need to install and configure IBM Cognos Controller on a Microsoft Windows 2008 server using default settings. This type of installation is suitable for a test or evaluation environment or for a small production environment.

This document allows you to install IBM Cognos Controller
• On a single computer running Microsoft Windows 2008 Server
• Using Microsoft SQL Server for the content store and controller databases
• Using Microsoft Internet Information Services (IIS) as your Web server
• Without additional security

For information about customizing the installation, distributing the components, using other databases, or upgrading an existing installation, see the IBM Cognos Controller Installation and Configuration Guide.

Audience

To use this guide, you must be familiar with:
• Some database administration
• Basic Microsoft Windows operating system administration
• Web server configuration, specifically Microsoft IIS version 7 or later

Finding information

To find product documentation on the web, including all translated documentation, access IBM Knowledge Center (http://www.ibm.com/support/knowledgecenter).

Accessibility features

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products. This product has accessibility features. For information on these features, see “Accessibility features,” on page 15.

Forward-looking statements

This documentation describes the current functionality of the product. References to items that are not currently available may be included. No implication of any future availability should be inferred. Any such references are not a commitment, promise, or legal obligation to deliver any material, code, or functionality. The development, release, and timing of features or functionality remain at the sole discretion of IBM.

© Copyright IBM Corp. 2004, 2017
Chapter 1. Setting up the environment

This section guides you through setting up your environment so that you can install IBM Cognos Controller.

Review supported environments

To ensure your product works properly, apply all required operating system patches and use only the versions of other software that are supported for your IBM Cognos product.

To review an up-to-date list of environments supported by IBM Cognos Controller 10.3.0, such as operating systems, patches, browsers, web servers, directory servers, database servers, and application servers, see IBM Cognos Controller 10.3 Supported Software Environments (http://www.ibm.com/support/docview.wss?uid=swg27048987).

Create two empty databases

You must create two empty databases for IBM Cognos Controller. One database is for the content store database. The second is for the Controller database.

Use the following checklist to help you create a database for your content store in Microsoft SQL Server.

• Ensure that the collation sequence is case-insensitive.
  In a Custom installation, you choose a collation, which includes character sets and sort order, during the SQL Server setup. In a typical installation, the installation uses the locale identified by the installation program for the collation. You cannot change this setting later.

• For Microsoft SQL Server 2008, grant EXECUTE permission to the user account that accesses the database.

  Under Security for the new database, create a schema and assign a name to it.
  Under Security for the new database, create a user with the following settings:
  – For Login name, specify the new login that you created for the user account.
  – For Default schema, specify the new schema.
  – For Owned Schemas, select the new schema.
  – For Role Members, select db_datareader, db_datawriter, and db_ddladmin.

Procedure

1. If you performed a typical installation of Microsoft SQL Server, after you install you must change the authentication mode to SQL Server and Windows.

2. Create a database to be used as your content store.

   Ensure that the database collation sequence is case insensitive.

   For Microsoft SQL Server 2005, if you do not specifically make another selection, dbo is the default table owner. Controller tables owned by dbo are not supported. If dbo is the default table owner you must change it to another user.

   The content store database is used when you install the IBM Cognos Controller server components in chapter 2.

3. Create a second database to be used as the Controller database.
The controller database is used when you configure the IBM Cognos Controller components in chapter 3.

**Verify that Microsoft .NET Framework is installed**

Microsoft .NET Framework supports smart client technology that allows applications to be started using a URL and downloaded from a server. Microsoft .NET Framework must be installed on the computer where you install IBM Cognos Controller.

**Important:** You must perform this task on each computer from where you access the IBM Cognos Controller client.

**Procedure**

1. Click Start > Control Panel > Programs and Features.
2. Click Turn Windows features on or off.
3. Click Server Manager > Roles.
4. Under Role Services, verify that .NET Extensibility appears in the list of installed programs.
5. If you do not have it installed, go to the Microsoft website (http://www.microsoft.com). Open the downloads page and search for Microsoft.NET Framework. Follow the download and installation instructions.

**Verify that Microsoft Visual C++ 2005 Redistributable is installed**

Microsoft Visual C++ 2005 Redistributable must be installed on the computer where you install the Controller server components.

**Procedure**

1. Click Start > Control Panel > Programs and Features.
2. Verify that Microsoft Visual C++ 2005 Redistributable appears in the list of installed programs.
3. If you do not have it installed, go to the Microsoft website (http://www.microsoft.com) and open the download page. Search for Microsoft Visual C++ 2005 Redistributable. Follow the download and installation instructions.

**Enable Access to the COM+ Server**

When you install IBM Cognos Controller, a Controller COM+ application is created. After you install IBM Cognos Controller, you must confirm that network access to the COM+ Server is enabled.

By default, installations of Windows Server 2008 restrict the functionality of network and communication components. You must enable the COM+ Server before IBM Cognos Controller can operate.

**Procedure**

1. In the Windows Control Panel, click Add or Remove Programs, and then click Add/Remove Windows Components.
2. Click Application Server, and then click Details.
3. Click Enable network COM+ Access, and then click OK.
4. Click Next, and then click Finish.
Chapter 2. Installing and configuring IBM Cognos Controller on one computer

This chapter provides the information you need to install and configure IBM Cognos Controller on one computer using default settings. This type of installation is suitable for a test or evaluation environment or for a small production environment. This installation is the quickest and easiest way to get started using the product.

Install the server components

The installation wizard for IBM Cognos Controller is provided on the installation CD or as a download from Passport Advantage®.

Procedure

1. Insert the IBM Cognos Controller product disk or go to the location where the installation files were downloaded and extracted.
2. The installation wizard starts automatically from the product disk. If you are installing from a download, go to the operating system directory and then double-click issetup.exe.
3. Select the language to use for the installation wizard, and click Next.
4. Accept the license agreement, and click Next.
5. Enter the directory into which you want to install the product, and click Next.
6. Click Next on the Component Selection page to install all the components.
7. Click Next on the Shortcut Folder page.
8. Click Next on the Installation Summary page to start the installation.
9. In the Finish page of the installation wizard, click Finish.

Install Framework Manager

To deploy the Publish to Data Mart Framework Manager model that is provided with IBM Cognos Controller, you must install Framework Manager.

You install Framework Manager from the IBM Cognos Business Intelligence (BI) Modeling CD provided with IBM Cognos Controller.

Procedure

1. Insert the IBM Cognos BI Modeling product disk or go to the location where the installation files were downloaded and extracted.
2. The installation wizard starts automatically from the product disk. If you are installing from a download, go to the operating system directory and then double-click issetup.exe.
3. Select the language to use for the installation wizard, and click Next.
4. Accept the license agreement, and click Next.
5. Enter the directory into which you want to install the product, and click Next.
   For a demonstration environment, install Framework Manager to the same directory as the IBM Cognos Controller components. This means you do not have to configure Framework Manager separately from the server components.
Click Yes to messages about installing to a location where other products are installed and to create backups of replaced files.

6. Click Next on the Component Selection page to install all the components.
7. Click Next on the Shortcut Folder page.
8. Click Next on the Installation Summary page to start the installation.
9. In the Finish page of the installation wizard, click Finish.

Connect to the content store database

You must specify the database server information to connect to the content store database you created.

Procedure
1. From the Start menu, click Programs > IBM Cognos 10 > IBM Cognos Configuration.
2. In the Explorer window, under Data Access, Content Manager, right-click Content Store and click Delete.
3. Right-click Content Manager, and then click New resource, Database.
4. In the Name box, type a name for the resource.
   For example, type Content Store.
5. In the Type box, select Microsoft SQL Server database, and click OK.
   If your database server uses Windows authentication, select SQL Server database (Windows Authentication).
6. In Database server and port number, enter the name of the computer where your database server is running and the port number on which it is running. For example, enter servername:1433, where 1433 is the default port number used by Microsoft SQL Server. If you are using a different port number, use that value.
7. If you are using SQL Server Authentication, click the Value box next to the User ID and password property and then click the edit button when it appears. Type the appropriate values and click OK.
8. In the Properties window, for the Database name property, type the name of the database.
9. Right-click the database connection you created, and click Test.

Results

After you test your connection to the content store database is working, you can start the IBM Cognos services.

Save your settings and start the IBM Cognos services

You must save your configuration settings and start the IBM Cognos service.

Procedure
1. In IBM Cognos Configuration, click File > Save to save your configuration settings.
2. Click Actions > Start.
   It may take a few minutes for the IBM Cognos service to start.
When you receive a warning during the Testing the mail server connection process, click OK and Continue to continue starting the services. A mail server connection is not required.

3. After the services have started, click Close.

Configure the web server

Before you can access the IBM Cognos Controller portal, you must configure your web server. You must set up virtual directories, also known as web aliases, for the directories that contain the HTML and web files for IBM Cognos Controller.

**Before you begin**

You must use Microsoft Internet Information Services (IIS) version 7 or later. To enable the required permissions for the cgi-bin directory, you must first enable CGI applications for your web server.

**Procedure**

1. Click Start > Control Panel > Programs and Features.
2. Click Turn Windows features on or off.
3. Click Server Manager > Roles > Web Server (IIS).
4. In Role Services, if HTTP Redirection is set to Not installed, select HTTP Redirection and click Add Role Service.
5. If CGI is set to Not installed, select CGI and click Add Role Service.
6. In the Internet Information Services (IIS) Manager, select your server name.
7. Double-click ISAPI and CGI Restrictions, and click Add.
8. Enter the path to the cognos.cgi file. The file is located in the ccr_location\cgi-bin directory.

   **Note:** The variable ccr_location/ refers to the installation location of IBM Cognos Controller. The default Controller installation location is C:\Program Files\IBM\Cognos\ccr_64

   You must enter the full path including the filename. If the path includes spaces, ensure that the path is enclosed in quotation marks; for example, use quotation marks as shown in the following path:

   "C:\Program Files\IBM\Cognos\ccr_64\cgi-bin\cognos.cgi"

9. Select Allow extension path to execute, and click OK.
10. Select Application Pools.
11. Select Add Application Pool.
13. Enter a name for the application pool and click OK.
14. Click Advanced Settings.
15. Ensure that the .Net Framework Version value is set to v2.0.
16. Ensure that the Enable 32-Bit Applications value is set to False (the default setting).
17. Set the Identity value to LocalSystem.
18. Click OK.
19. Expand Sites and, under your web site, create the following virtual directories as shown in the table.
Table 1. Required virtual directories

<table>
<thead>
<tr>
<th>Alias</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>ibmcognos</td>
<td>ccr_location/webcontent</td>
</tr>
<tr>
<td>ibmcognos/cgi-bin</td>
<td>ccr_location/cgi-bin</td>
</tr>
<tr>
<td>ibmcognos/controller</td>
<td>ccr_location/ccrvdir</td>
</tr>
<tr>
<td>ibmcognos/controllerbin</td>
<td>ccr_location/webcontent/ccr</td>
</tr>
<tr>
<td>ibmcognos/controllerhelp</td>
<td>ccr_location/webcontent</td>
</tr>
</tbody>
</table>

You can use a name other than ibmcognos in the aliases. However, you must use cgi-bin as the second part of the alias, including the virtual directory in the Gateway URI property to match the new Cognos alias.

**Remember:** If you use ibmcognos in the web aliases and embed the aliases within other applications, such as Microsoft Excel reports, should you upgrade to a future version of IBM Cognos Controller, you must also update the embedded aliases.

20. Select the cgi-bin virtual directory you created.
21. Double-click **Handler Mappings**.
22. Under **Actions**, click **Add Module Mapping**.
   a. In **Request Path**, type cognos.cgi.
   b. In **Module**, type CgiModule.
   c. Leave **Executable (optional)** blank.
   d. In **Name**, enter a name for the entry, such as CognosCGI.
   e. Click OK.
23. Right-click the ibmcognos virtual directory, and click **Add Application**.
   a. In the **Alias** box, type controllerserver.
   b. In the **Physical path** box, enter ccr_location/ControllerProxyServer
24. Select the controller virtual directory.
   a. Double-click **HTTP Redirect**.
   b. Select **Redirect requests to this destination**, and enter the following path:
      /ibmcognos/controllerbin/ccr.exe
25. Click **Apply** and click **OK**.

**Test your access to the portal**

You can test your access to the portal using your Web browser. Accessing the portal, will also verify whether the server components are running.

**Procedure**

1. Open Microsoft Internet Explorer.
2. In the Address bar, type the following:
   http://localhost/ibmcognos
   This value is the Gateway URI value from IBM Cognos Configuration.
   If you are not on the computer where your Web server is installed, you must enter the server name instead of localhost. ibmcognos is the root virtual directory you created when you configured the Web server.
   When you see the Welcome page of IBM Cognos Connection, your IBM Cognos Controller server components are running.

6   Getting Started with Controller
What to do next

You must now configure your Controller database and enable access for the Microsoft .Net components and COM+ Server components.
8 Getting Started with Controller
Chapter 3. Configure IBM Cognos Controller components

Configuring the IBM Cognos Controller components requires you to configure your Controller database and to configure the Microsoft .Net Framework and COM+ Server components.

Configure Microsoft ASP.NET

Microsoft ASP.NET is a Microsoft Internet Information Services (IIS) extension that is bundled with the Microsoft .NET Framework. You must configure ASP.NET on all computers running Controller components.

Procedure
1. In a command window, go to the c:/Windows/Microsoft.NET/Framework64/v2.0.50727 directory.
2. Enter the following command:
   aspnet_regiis.exe /i

Configure Microsoft .NET Framework

You must configure the Microsoft .NET Framework to create a trust between the Controller components. On a 64-bit computer, you must also set Microsoft .NET to use the 32-bit libraries.

The Microsoft .NET Framework security policy is configured using a hierarchy of code groups at the machine policy level.

You can create this trust using the Code Access Security Policy tool (CasPol.exe). This Microsoft .NET tool is a command-line interface for working with security policy. For more information about using the Microsoft .NET Code Access Security Policy tool, see the Microsoft .NET Framework documentation.

Important: You must perform this task on each computer from where you will access the IBM Cognos Controller client.

Procedure
1. In a command window, go to the C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727 directory.
2. Type the following command, and press Enter:
   Ldr64.exe SetWow
   This command will enable the 32-bit Microsoft libraries.
3. Change to the C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727 directory.
4. Type the following command, and press Enter:
   CasPol.exe -m -q -ag "All_Code" -url http://servername/* FullTrust -n Controller
   Where servername is the name of the computer where you are installing IBM Cognos Controller.

Important: The command is case sensitive.
Install a database driver

The IBM Cognos Controller Database Conversion Utility requires a database driver. For Microsoft SQL Server, the driver is sqljdbc4.jar. The driver file must be in the same location as the Database Conversion Utility (dbconv.exe).

Procedure
1. In a Web browser, go to the Microsoft website (http://microsoft.com) and open the download page. Search for Microsoft JDBC Driver for SQL Server and download the driver.
   The driver is provided in a self extracting archive.
2. Double-click the archive to uncompress it, and locate the sqljdbc4.jar file in the uncompressed folder.
3. Copy the sqljdbc4.jar file to the root c10_location.

Configure the Controller database

Before you can run IBM Cognos Controller, you must configure the Controller database.

You configure the Controller database using Controller Configuration.

Important: Controller Configuration is not the same tool as was used to configure and start the server components. Ensure that you start Controller Configuration rather than IBM Cognos Configuration.

Procedure
1. From the Start menu, start Controller Configuration.
   If you are using a Windows 7 or Windows 2008 computer, installed the product to the Program Files directory, and the User Account Control (UAC) is turned on, IBM Cognos Controller Configuration is identified as an administrative application; therefore, you must run it with elevated administrative privileges. To properly save the configuration settings, the UAC prompts for credentials if you are using a standard account.
2. In the Explorer window, click Database Connections, and then click File > New.
3. In the Properties window, click the Database type box, and then use the drop-down arrow to select the database type.
   You can choose DB2, Oracle or SQL Server.
4. In the Name box, type a name for the database connection.
5. In the Provider box, type the name of the database provider.
   To obtain the database provider information, see the DB2®, Oracle or SQL Server documentation.
6. In the User ID and Password boxes, type the user name and password for the Controller database.
7. In the Initial catalog box, type the Controller database name.
8. In the Data source box, type the database server computer name.
   Do not use localhost.
9. Click File > Save.
10. In the Explorer window, expand Database Connections.
11. Select the database you want to upgrade.
12. Click Actions > Run.
13. If no Java™ is found, browse to and select the Java 7 JRE in the \installdir\bin64\jre\7.0\ directory.
14. If you have more than one Oracle version installed a message appears, select the same Oracle version that you are using with Controller.
15. If this is an empty Controller database, in the Database Conversion Utility window, click Create Db.
   The Database Conversion Utility initializes the database.
   
   **Note:** When you create a new database, by default the database version is 813. You then need to perform database upgrade to the latest version of IBM Cognos Controller.
16. In the Database Conversion Utility dialog box, click Connect and then click Upgrade.
   The Database Conversion Utility upgrades the existing database.
   
   **Note:** To upgrade database versions lower than 789 use the old Database Conversion Utility tool in the c10\legacy directory.
17. Click Close.
18. From the Actions menu, click Check.
   If the database connection validation fails, review the database connection properties and fix any errors.
19. From the File menu, click Save.
20. In the Explorer window, under Web Services Server, click Report Server.
   The new database is now configured as a data source for Report Server, and is listed as a data source in IBM Cognos Connection.

---

**Configure your web browser**

To allow you to access Controller from your web browser, you must add your Controller server as a Trusted Site.

**Important:** You must perform this task on each computer from where you will access the IBM Cognos Controller client.

**Procedure**

1. Open Microsoft Internet Explorer.
2. Click Tools > Internet options.
3. Click the Security tab.
4. Select Trusted Sites, and click Sites.
5. Clear the Require server verification (https) for all sites in this zone check box.
6. Enter the root URL of your Controller server, and click Add.
   For example, enter http://servername.
7. Click Close.
8. Set the security level for the Trusted Sites to Medium-low.
9. Click OK.
Test IBM Cognos Controller

You can test your IBM Cognos Controller installation by accessing the Controller application from the portal.

Procedure
1. In the Microsoft Internet Explorer Address bar, type:
   http://localhost/ibmcognos
   This value is the Gateway URI value from IBM Cognos Configuration.
   If you are not on the computer where your Web server is installed, you must enter the server name instead of localhost. ibmcognos is the root virtual directory you created when you configured the Web server.
2. On the Welcome page, click Consolidate my financial information.
   The Select Database window opens.
3. Select a database in the list, and click the check mark.
4. Enter your logon credentials:
   In the IBM Cognos Controller - Login window, type the User ID, Password, Actuality, and Period, and then click the check mark.
   For new databases, the default user ID is ADM and the default password is kbs.
   You must select an Actuality and Period before you can log in.
   For more information about using the product, see Using Controller.

Import the IBM Cognos Controller Standard Reports Package

Before you can run IBM Cognos Controller and view reports in Cognos Viewer, you must import the IBM Cognos Controller standard reports package into Content Manager.

Procedure
1. Launch IBM Cognos Administration.
2. Click the Configuration tab, and then click Content Administration.
3. On the toolbar, click the New Import button. The New Import wizard appears.
4. In the Deployment archive box, click the Controller package, and then click Next.
5. Type the name and an optional description and screen tip for the deployment specification, select the folder where you want to save it, and then click Next.
6. Select the content that you want to include in the import.
7. Select the options you want, along with your conflict resolution choice for options that you select.
8. In the Specify the general options page, select whether to include access permissions and references to external namespaces, and who should own the entries after they are imported in the target environment.
9. Click Next.
   The summary information appears.
10. Review the summary information and click Next.
11. In the Select an action page, select Save and run once, and then click Finish.
Results

After you run the import, the IBM Cognos Controller reports package appears in your IBM Cognos Connection content.
Appendix. Accessibility features

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products.

See the IBM Accessibility Center (http://www.ibm.com/able) for more information about the commitment that IBM has to accessibility.

Keyboard Shortcuts for the Installation Wizard

Keyboard shortcuts, or shortcut keys, provide you with an easier and often faster method of navigating and using software. The installation wizard uses standard Microsoft Windows operating system navigation keys in addition to application-specific keys.

Note: The following keyboard shortcuts are based in US standard keyboards. The following table lists the keyboard shortcuts that you can use to perform some of the main tasks in the installation wizard on the Windows operating system.

Table 2. Keyboard shortcuts for main tasks in the installation wizard on the Windows operating system

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next field on a page</td>
<td>Tab</td>
</tr>
<tr>
<td>Return to the previous field on a page</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Close the installation wizard</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Move to the next configuration step</td>
<td>Alt+N</td>
</tr>
<tr>
<td>Return to the previous configuration step</td>
<td>Alt+B</td>
</tr>
<tr>
<td>Move to the next selection in a list</td>
<td>Down arrow</td>
</tr>
<tr>
<td>Move to the previous selection in a list</td>
<td>Up arrow</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts you can use to perform some of the main tasks in the installation wizard on the UNIX or Linux operating system.

Table 3. Keyboard shortcuts for main tasks in the installation wizard on the UNIX or Linux operating system

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next field on a page</td>
<td>Tab</td>
</tr>
<tr>
<td>Return to the previous field on a page</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Close the installation wizard</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Move to the next selection in a list</td>
<td>Down arrow</td>
</tr>
<tr>
<td>Move to the previous selection in a list</td>
<td>Up arrow</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts you can use to perform some of the main tasks in the License Agreement page of the installation wizard.
Table 4. Keyboard shortcuts for main tasks in the License Agreement page of the installation wizard

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept the license agreement</td>
<td>Alt+A</td>
</tr>
<tr>
<td>Decline the license agreement</td>
<td>Alt+D</td>
</tr>
<tr>
<td>Quit the installation wizard</td>
<td>Alt+x</td>
</tr>
</tbody>
</table>
Notices

This information was developed for products and services offered worldwide.

This material may be available from IBM in other languages. However, you may be required to own a copy of the product or product version in that language in order to access it.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service. This document may describe products, services, or features that are not included in the Program or license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.
Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Software Group
Attention: Licensing
3755 Riverside Dr.
Ottawa, ON
K1V 1B7
Canada

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.
This Software Offering does not use cookies or other technologies to collect personally identifiable information.

Trademarks

IBM, the IBM logo and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:

- Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.
- Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.
- UNIX is a registered trademark of The Open Group in the United States and other countries.
- Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.
Index

A
accessibility features 15
aliases configuring on web servers 5
application servers enabling network COM+ access 2
ASP.NET 9 installing 9

C
COM+ Server enabling 2 configuration testing 6
configuring content store 4 Controller database connections 10
web servers 5 connecting to IBM Cognos Controller from IBM Cognos Connection 12
connections Controller database 10
content store configuring 4 Controller database connections configuring 10
Controller databases creating Microsoft SQL Server 1

D
databases configuring content store 4

E
enabling COM+ Server 2
environments supported 1

F
Framework Manager installing 3

I
IBM Cognos Controller connecting from IBM Cognos Connection 12
standard reports package 12
IBM Cognos service starting from IBM Cognos Configuration 4
importing Controller standard reports package 12
installation testing 6

installing
ASP.NET 9
Framework Manager 3
Microsoft .NET Framework 2
Microsoft Visual C++ 2005 Redistributable 2
server components 3

M
Microsoft .NET Framework 2 installing 2
Microsoft SQL Server creating Controller databases 1
Microsoft Visual C++ 2005 Redistributable 2
installing 2

N
network COM+ access enabling 2

R
reporting package importing 12

S
server components installing 3
SQL Server databases creating Controller databases 1
standard reports package importing 12
starting the IBM Cognos service from IBM Cognos Configuration 4
supported environments 1

testing
server components configuration 6
server components installation 6

V
virtual directories setting up 5

W
web aliases setting up 5
web server configuring 5

© Copyright IBM Corp. 2004, 2017

21