Product Information
This document applies to IBM Cognos Business Intelligence Version 10.2.0 and may also apply to subsequent releases. To check for newer versions of this document, visit the IBM Cognos Information Centers [http://publib.boulder.ibm.com/infocenter/cogic/v1r0m0/index.jsp].

US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
Contents

Introduction .......................................................... vii

Chapter 1. PowerPlay ......................................................... 1
- How is IBM Cognos PowerPlay Client Different from IBM Cognos Series 7 PowerPlay? .................. 1
- Getting Started with PowerPlay ....................................... 3
  - Open a Local PowerCube ........................................... 4
  - Open a Remote Package ........................................... 4
  - Open a Report .................................................... 5
- Replace Categories in a Report ....................................... 6
- Add Nested Categories to a Report ................................ 7
- Selecting Nested Categories ......................................... 9
- Add Intersected Categories to a Reporter Report .............. 10
- Working with layers ................................................. 11
- Duplicate a Report .................................................. 11
- Copy Information Between Reports ................................ 12
- Show Summary Categories .......................................... 12
- Hide Categories ..................................................... 12
- Swap Rows, Columns, and Layers .................................. 13
- Insert Blank Rows and Columns .................................... 13
- Move a Row or Column .............................................. 14
- Set the Prompting and PDF Properties for Published Reports .................................................. 14
- Suppress Unnecessary Information ................................ 15
- Remove Unwanted Information ..................................... 16
- Considerations to Improve Report Accessibility ............. 17

Chapter 2. Maintaining Standard Reports ......................... 19
- Share the Dimension Line ........................................... 19
- Create a Report Template .......................................... 20
- Control when data is updated ...................................... 20
- Subset Definitions .................................................. 21
  - Create a Parentage Subset Definition .......................... 21
  - Create a Find-in-Cube Subset Definition ..................... 21
  - Create an Advanced Subset Definition ......................... 23
  - Create an Advanced Subset Definition with Restriction by Parent ........................................ 24
  - Create an Advanced Subset Definition with Restriction by Name or Description (Find) ............. 25
  - Create an Advanced Subset Definition with Restriction by Value .................................. 25
  - Open a Subset Definition ....................................... 26
  - Change a Subset Definition .................................... 26
  - Delete a Subset Definition .................................... 27
  - Highlight Subsets ............................................... 27
  - Subset Calculations ............................................. 27
  - Break or Delete a Subset ...................................... 28

Chapter 3. Dimensions ..................................................... 29
- Drill Down ....................................................... 29
- Drill Up ......................................................... 31
- Drilling Down and Up on Nested Categories .................. 32
- Filter Data ....................................................... 32
- Remove Filters .................................................... 33
- Search for Data .................................................. 33
  - Search in a report ............................................... 33
  - Search in a cube ................................................ 33

Chapter 4. Measures ...................................................... 35
Table of Contents

Change the Measure ................................ 35
Show Multiple Measures as Rows, Columns, or Layers ..................... 35
Change the Format for a Measure ................................ 36
Working with Currency Values ................................ 36

Chapter 5. Drill Through ........................................ 39
Drill Through to PowerPlay ..................................... 39

Chapter 6. Rank and Sort Data in Reports .......................... 43
Rank Data .................................................................. 43
  Rank categories using the default settings .......................... 43
  Rank categories using custom settings ............................ 44
  Hide or remove ranking ............................................ 44
  Rank Identical Values ............................................ 44
  Rank Nested Data .................................................. 44
  Manually Re-Ranking in Reporter Reports ....................... 45
Sort Data .................................................................. 45
  Sort using default settings ...................................... 46
  Sort using custom settings ..................................... 46

Chapter 7. Highlight Exceptions .................................... 47
Automatic Exception Highlighting .................................. 47
  Apply automatic exception highlighting ....................... 47
  Change automatic exception sensitivity for the active report .. 47
  Modify the automatic exception styles .......................... 48
Custom Exception Definitions ................................... 48
  Create a custom exception definition ......................... 48
  Apply a Custom Exception Definition ......................... 49
  Shared Custom Exception Definitions .......................... 50

Chapter 8. Calculations .............................................. 53
View Information About Calculations .................................. 53
Calculate Percentage Growth ..................................... 54
Calculate the Percentage of a Total ................................. 54
Calculate an Average ................................................. 54
Calculate a Running Total ........................................... 55
  Calculating running totals as numeric values ................. 55
  Calculating running totals as percentage values ............ 55
Rollup Calculations .................................................. 55
Perform Calculations on Nested Categories ....................... 56
Perform Calculations When You Add Categories ................. 57
Add Calculated Categories to a Report ............................ 58
Perform Group Calculations ....................................... 59
Setting Calculation Precedence ................................... 59
Forecasting Methods ................................................ 60
  Trend (Linear or Straight Line) ................................. 61
  Growth (Curved or Curved Line) ............................... 61
  Autoregression (Seasonal) ....................................... 61
  Create a Forecast .................................................. 62
Financial Ratios ....................................................... 62

Chapter 9. Graphical Displays ...................................... 65
Compare Variables, Show Variance, or Track Performance ........... 65
Compare Two Measures .............................................. 65
Show the Mix in a Pie or Clustered Bar Display .................... 66
Find a Trend in a Display .......................................... 66
Show More than One Type of Display .............................. 67
Show Multiple Charts in One Display ............................... 67
View Large Amounts of Data ..................................... 68
Show Values in a Display ......................................... 68
Chapter 10. Formatting Reports ........................................... 75
  Choose a Layout for a Crosstab Report ......................... 75
  Show Short or Long Names for Dimensions and Categories .... 75
  Create and Apply a Style to Data ..................................... 75
    Creating and editing styles ........................................ 76
    Applying styles .................................................. 76
    Removing styles .................................................. 76
  Apply a Background Pattern and Color to an Entire Report ... 76
  Add a Title, Header, or Footer ...................................... 77
  Formatting Labels and Values ....................................... 78
    Rename Labels .................................................. 78
    Format Labels and Values in Crosstabs ....................... 78
    Format Labels in Graphical Displays ......................... 79
  Change Summary Labels .............................................. 80
  Show Data as Relative Values ...................................... 80
  Show Blank Cells For Zero and Missing Values .................. 81

Chapter 11. Distributing Reports ....................................... 83
  Save Reports in PDF Format .......................................... 83
  Publish Reports to IBM Cognos Connection ...................... 83
    Publishing new reports ........................................... 84
    Work with previously published reports .................... 84
  Print Reports ..................................................... 84
  Attach Reports to Email ............................................ 85
  Export a Report to a Different File Format ..................... 85
    Delimited ASCII Text Files ...................................... 86

Chapter 12. Customizing PowerPlay .................................. 87
  Setting Preferences ................................................ 87
  Customize Menus .................................................. 87
    Set Up a Launch Menu Command ................................ 88
  Customize Toolbars and Buttons .................................. 89
    Show or Hide Toolbars ......................................... 89
    Create a Custom Toolbar ....................................... 89
    Customize Toolbar Buttons ................................... 89
    Set Up a Launch Button ........................................ 90
  Distribute Custom Menus and Toolbars ......................... 91
  Customize the Dimension Viewer Toolbox ....................... 91

Chapter 13. Working Offline ........................................... 95
  Turn Off Sub-Cube Refresh ......................................... 95
  Save a Sub-Cube .................................................. 95
  Set a Report to Use a Sub-Cube .................................. 95
  Automatically Refresh a Sub-Cube ................................ 96
## Chapter 14. Command-line Options

- No Title Screen .......................................... 97
- Explorer Report ........................................ 97
- Reporter Report .......................................... 98
- Cube Name .................................................. 98
- Remote Package Name ..................................... 98
- Report Name ............................................... 98

## Chapter 15. Specifications

## Chapter 16. Forecast Formulas

- Trend Forecast Formula .................................... 101
- Growth Forecast Formula .................................. 102
- Autoregression Forecast Formula ......................... 102

## Chapter 17. PowerPlay Samples

## Appendix. Troubleshooting

- IBM CognosScript Editor is Not Included With IBM Cognos PowerPlay Client .................. 105
- Cognos Application Firewall Error When Publishing a Report ....................................... 105
- Avoiding Blank Extra Lines in Report Titles ................................................................. 105
- Hebrew Text Displayed in Chart Elements ................................................................. 105
- Calculation is Not Dynamically Updated After a Cube Update ..................................... 105
- Opening an Exported XLS File in Microsoft Excel 2007 ................................................ 106
- Only the First Page of a Multiple-page Report Prints ................................................... 106
- Dimension Viewer Does Not Appear ................................................................................ 106
- Report Looks Different After the Cube is Updated .......................................................... 106
- Advanced Subset Value Restriction is Not Available ....................................................... 106
- Categories Do Not Appear After Changing to Explorer Mode ........................................ 107
- Summary Values Appear to be Incorrect .......................................................................... 107
- Calculated Values Appear in a Different Format ............................................................... 107
- Calculated Values Appear as /0 ..................................................................................... 108
- Labels for Calculated Categories Do Not Display Correctly .......................................... 108
- Allocated Measures ........................................................................................................ 108
- Unexpected Zeros Appear in the Report .......................................................................... 108
- Values Appear as "error" .................................................................................................. 109
- Values Appear as Number Signs (###) ............................................................................ 109
- Values Appear as Question Marks (???) ......................................................................... 109
- No Values for a Measure in Some Dimensions ................................................................ 109
- Time Period Differences ................................................................................................ 109
- Unable to Drill Through to a Cube or Report .................................................................. 110
- Saved Report Looks Different ....................................................................................... 110
- Unable to Move a Column or Row ................................................................................... 110
- Unable to Open the Page Setup or Print Dialog Box ......................................................... 110
- Report Does Not Fit on One Printed Page ...................................................................... 110
- Unable to Print White on Black ...................................................................................... 110
- Text Prints on Top of Graphics ...................................................................................... 111
- Restore the Default Toolbars and Menus ...................................................................... 111
- Errors After Moving Reports or Cubes to a New Location ............................................. 111
- Correct Performance Issues .......................................................................................... 111
- Unable to Email a Report ............................................................................................... 112
- Unable to Open a Remote Report .................................................................................... 112
- Unable to Save a Report .................................................................................................. 112
- Unable to Add a Launch Button for a Macro ................................................................... 112
- Unable to Refresh a Sub-Cube ....................................................................................... 112

## Notices

## Index
Introduction

This document is intended for use with IBM® Cognos® PowerPlay® Client.

Audience

To use this document, you should have

- Knowledge of business analysis concepts
- Knowledge of your business requirements

Finding information

To find IBM Cognos product documentation on the web, including all translated documentation, access one of the IBM Cognos Information Centers (http://publib.boulder.ibm.com/infocenter/cogic/v1r0m0/index.jsp). Release Notes are published directly to Information Centers, and include links to the latest technotes and APARs.

You can also read PDF versions of the product release notes and installation guides directly from IBM Cognos product disks.

Accessibility features

IBM Cognos PowerPlay Client does not currently support accessibility features that help users with a physical disability, such as restricted mobility or limited vision, to use this product.

Forward-looking statements

This documentation describes the current functionality of the product. References to items that are not currently available may be included. No implication of any future availability should be inferred. Any such references are not a commitment, promise, or legal obligation to deliver any material, code, or functionality. The development, release, and timing of features or functionality remain at the sole discretion of IBM.

Samples disclaimer

The Great Outdoors Company, GO Sales, any variation of the Great Outdoors name, and Planning Sample depict fictitious business operations with sample data used to develop sample applications for IBM and IBM customers. These fictitious records include sample data for sales transactions, product distribution, finance, and human resources. Any resemblance to actual names, addresses, contact numbers, or transaction values is coincidental. Other sample files may contain fictional data manually or machine generated, factual data compiled from academic or public sources, or data used with permission of the copyright holder, for use as sample data to develop sample applications. Product names referenced may be the trademarks of their respective owners. Unauthorized duplication is prohibited.
Chapter 1. PowerPlay

IBM Cognos PowerPlay lets you analyze critical corporate data from any angle, in any combination. PowerPlay helps you to quickly grasp business issues, manage performance, and focus your actions through the strength of multidimensional analysis.

How is IBM Cognos PowerPlay Client Different from IBM Cognos Series 7 PowerPlay?

You use IBM Cognos PowerPlay Client to view, explore, format, and distribute reports, just as you did with IBM Cognos Series 7 PowerPlay.

The following information describes the differences in PowerPlay between IBM Cognos Business Intelligence and IBM Cognos Series 7.

Supported Data Sources

PowerCubes are the only OLAP data source supported for IBM Cognos PowerPlay. Compressed PowerCubes are not supported. You can open local PowerCubes directly, as you do in IBM Cognos Series 7. To access data in a remote PowerCube you connect to a package that administrators or modelers create using a data source connection to the PowerCube.

Opening Reports from the IBM Cognos Portal

In IBM Cognos Series 7, several run options are available for PowerPlay reports that are published to Upfront. The Run Report in Windows option opens the report in PowerPlay Client. To use this option you must have PowerPlay Client installed on your computer, and your administrator must enable the run option.

In IBM Cognos BI, the run options in Cognos Connection for a PowerPlay report do not include the option to open the report in PowerPlay Client. However, you can open remote reports directly from PowerPlay Client. After you open and modify a remote report you can either replace the existing report on the portal to make the updates available to all users or publish a new report.

PowerPlay Report (.PPR) Format

IBM Cognos Series 7 PowerPlay reports in .ppr format must first be converted to .ppx format to use the report in IBM Cognos PowerPlay. The IBM Cognos PowerPlay Client installation includes a macro that converts .ppr format reports to .ppx format.

For more information about the conversion macro, see the IBM Cognos PowerPlay Migration and Administration Guide.

Publishing Reports as HTML

In IBM Cognos Series 7 PowerPlay Client, you can save reports locally in HTML format so that users can view these reports in a web browser without installing PowerPlay.
IBM Cognos PowerPlay does not include functionality equivalent to the publish as HTML option.

**Offline Access to Data**

You can work offline IBM Cognos PowerPlay Client using local unsecured or password protected PowerCubes (.mdc files). Also, you can work offline with a PowerPlay report by saving it as a sub-cube. This option is useful if you can not obtain a copy of the original cube, if the original cube is very large and includes more data than you need for your offline work, or if the original cube is secured by a namespace. For more information about creating and working with sub-cubes, see the IBM Cognos PowerPlay Client User Guide.

If you require security for local cubes, we recommend that you use password protection.

**PowerPlay Connect Is No Longer Used**

In IBM Cognos Series 7 PowerPlay, you used PowerPlay Connect to provide access to other OLAP cubes by specifying the server and database information required to access data in an OLAP server database.

In IBM Cognos BI, you use IBM Cognos Administration or Framework Manager to create data source connections to PowerCubes.

**The MDC File Name in Titles, Headers, and Footers**

In IBM Cognos PowerPlay, the name specified in the PowerCube name property in Transformer is used when you insert the MDC File Name into a title, header, or footer.

In IBM Cognos Series 7, when working with a remote cube, the MDC File Name is based on the name that was set when the cube was inserted in PowerPlay Enterprise Server Administration. For local cubes, the MDC File Name is the cube file name without the .mdc file extension.

**Working with Data Secured by Different Namespaces**

IBM Cognos PowerPlay Client includes new options on the File menu: Log On and Log Off. If packages are secured using different namespaces, you must log on to each namespace separately. When you select Log Off or Log On, you will be prompted to save open reports because your security credentials will change.

**Supported Graphic Types**

In IBM Cognos Series 7, you can use either .bmp or .wmf file types when inserting a picture into a display, for example in a title.

IBM Cognos PowerPlay does not support the .wmf graphic type. If you use .wmf graphics in IBM Cognos Series 7, convert them to a supported format for use in IBM Cognos BI: .bmp, .gif, .jpg, or .png.

**Communication with the Gateway and Servers**

In IBM Cognos Series 7, you can connect to many different servers because PowerPlay Client communicates with the dispatcher. You add connections to the
PowerPlay Enterprise Server dispatchers by specifying the name of the dispatcher computer and the port it uses to listen for requests for each connection.

In IBM Cognos BI, you can configure PowerPlay Client to point to only one gateway.

---

**Getting Started with PowerPlay**

To create a new report, you connect to a data source and then select the data, display type, and formatting that meets your business needs.

When you build the report, you can choose the information you want to show. You can add
- categories
- nested categories
- intersected categories
- layers

You can duplicate reports and choose how you want the report information displayed. You can hide categories, show summary categories, suppress unnecessary information, and remove unwanted data. If you are distributing reports to other users by publishing reports to the IBM Cognos Business Intelligence portal, you may also want to add prompts that let users customize the report before opening it.

**Explorer Mode and Reporter Mode**

You choose to work in either Explorer mode or Reporter mode. While Explorer and Reporter reports are similar in many respects, they have basic differences. When you understand the differences, you can select the appropriate report type for the task.

In an Explorer report, the row and column areas can contain multiple levels from one dimension or, by using nesting, multiple dimensions. The category structure in the report matches the structure in the data source.

When you create a new Explorer report, the initial display shows the categories from the first two dimensions in the dimension line. By default, an Explorer report includes summaries. You can choose to hide the summary information in Explorer reports.

In a Reporter report, you have complete control over the information in a report. You don't need to use the same dimension structure as the data source. You can start with a blank report and then add the categories that you want.

Both Explorer mode and Reporter mode offer many options for working with the available categories and measures. For example,
- You can filter the report by changing the dimension line.
- You can drag items from the dimension viewer to the report to change categories or create nested categories.
- You drill up and down on categories in the report to see different levels of detail.
After you become familiar with IBM Cognos PowerPlay, you can change the default preferences to match the way you work. For example, you can change the default display type from crosstab to simple bar or choose to work in Reporter mode instead of Explorer mode when you create a new report.

Open a Local PowerCube
You can use PowerCubes located on your own computer or a shared network location as your data source.

This type of data source is appropriate for creating reports for your own use, for distribution to other IBM Cognos PowerPlay Client users, or for standard reports that you will distribute in PDF format. You cannot publish a report based on a local cube to IBM Cognos Connection.

Procedure
1. From the File menu, click New.
2. Select Local, locate the PowerCube that you want to use, and then click Open.
3. If prompted, provide the required authentication information.

Open a Remote Package
If available in IBM Cognos Connection, you can use a package based on a PowerCube as your data source.

You must use this type of data source if you plan to publish reports to IBM Cognos Connection or to work with a PowerCube that is secured using a namespace.

Before you can access packages, you must specify the location of the IBM Cognos BI gateway using the instance of IBM Cognos Configuration installed with PowerPlay. You start IBM Cognos Configuration from the same Start, Programs location as PowerPlay.

Procedure
1. From the File menu, click New.
2. Select Remote.
   
   All available packages are displayed, even packages that use an unsupported data source such as a relational data source. However, from PowerPlay Client, you can only select packages that use a PowerCube data source.
3. Select the package that you want to use, and then click OK.
   
   Some packages use data source connections to more than one PowerCube. When you open this type of package you are prompted to select a single data source connection to work with.
4. If prompted, provide the required authentication information.

Results

If PowerPlay uses the default startup preferences, a new Explorer report appears that uses the first two items from the dimension line as the rows and columns. If the PowerPlay startup preferences are set to use Reporter mode when creating new reports, a blank report appears.
Open a Report

You can open an existing local or remote report to refresh the data before distributing an update to a standard report, to modify the report, or to use the report as the starting point for the creation of a new report.

IBM Cognos PowerPlay Client can open remote reports that were created in PowerPlay Studio. Because of feature differences between PowerPlay Studio and PowerPlay Client, a PowerPlay Studio report may look different when you open the report in PowerPlay Client. For example, some chart formatting applied in PowerPlay Studio, such as patterns and gradients, axis placement, and titles, will not appear in the report in PowerPlay Client. Percentile calculations and custom subsets are other examples of PowerPlay Studio features that do not appear in the report in PowerPlay Client.

When you open an existing report you can choose to be prompted to select a data source that is different from the data source used to create the original report. This option is useful if you know the original data source was moved or renamed, or if you want to use a report as a template for a new report based on a data source with a similar data structure.

Open local reports

You can open reports saved to your computer or a shared network location. If the data source used to create the report is not available, you are prompted to select a data source.

Procedure
1. From the File menu, click Open.
2. Click the Local button.
   To associate the report with a different local or remote data source, select Prompt for a data source.
3. Locate the report and click Open.

Open remote reports

You can open reports that are available in the IBM Cognos Connection.

In addition to opening reports originally created in PowerPlay Client, you can also open reports created in PowerPlay Studio.

To access remote reports, you must configure a connection to the IBM Cognos BI gateway and you must have sufficient privileges to access the reports and associated data sources.

Procedure
1. From the File menu, click Open.
2. Click the Remote button.
   To associate the report with a different local or remote data source, select Prompt for a data source.
3. Navigate to the folder that contains the report, select the report and then click OK.
   If the data source used to create the report is not available, you are prompted to select a data source.
If the package used to build the report uses data source connections to more than one PowerCube, you are prompted to select a PowerCube data source connection to work with.

**Replace Categories in a Report**

In Explorer mode, new reports show categories from the first two dimension folders on the dimension line in the rows and columns of the report. The values are based on the first measure in the cube.

In Explorer mode, when you replace a category, child categories and a summary level appear in the report. For example, in the following Explorer mode report, Years and Products are the first two dimensions in the dimension line.

<table>
<thead>
<tr>
<th>Years</th>
<th>Camping Equipment</th>
<th>Golf Equipment</th>
<th>Mountaineering Equipment</th>
<th>Outdoor Protection</th>
<th>Personal Protection</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004</td>
<td>333,299,825</td>
<td>153,642,931</td>
<td>0</td>
<td>36,163,824</td>
<td>361,632,197</td>
<td>914,737,467</td>
</tr>
<tr>
<td>2005</td>
<td>403,130,131</td>
<td>161,200,103</td>
<td>107,140,704</td>
<td>25,000,709</td>
<td>456,359,025</td>
<td>1,153,913,737</td>
</tr>
<tr>
<td>2007</td>
<td>363,361,292</td>
<td>176,748,575</td>
<td>141,528,413</td>
<td>4,473,913</td>
<td>443,312,970</td>
<td>1,113,944,631</td>
</tr>
</tbody>
</table>

**Figure 1. Default layout for Explorer report**

If you drag the dimension folder Sales regions from the dimension viewer to the rows, its child categories (Americas, Asia Pacific, Central Europe, Northern Europe, and Southern Europe) replace the current categories (2004, 2005, 2006, and 2007) in the rows. Sales regions replaces Years as the summary row.

<table>
<thead>
<tr>
<th>Years</th>
<th>Camping Equipment</th>
<th>Golf Equipment</th>
<th>Mountaineering Equipment</th>
<th>Outdoor Protection</th>
<th>Personal Protection</th>
<th>Products</th>
</tr>
</thead>
<tbody>
<tr>
<td>Americas</td>
<td>461,321,344</td>
<td>217,892,249</td>
<td>123,140,579</td>
<td>23,005,042</td>
<td>132,350,158</td>
<td>973,309,972</td>
</tr>
<tr>
<td>Asia Pacific</td>
<td>422,074,311</td>
<td>194,682,442</td>
<td>107,529,958</td>
<td>18,716,208</td>
<td>116,791,606</td>
<td>880,794,525</td>
</tr>
<tr>
<td>Central Europe</td>
<td>344,081,732</td>
<td>154,184,819</td>
<td>86,063,201</td>
<td>17,491,871</td>
<td>1,540,757,653</td>
<td>2,144,579,336</td>
</tr>
<tr>
<td>Northern Europe</td>
<td>161,045,496</td>
<td>64,701,953</td>
<td>46,095,152</td>
<td>8,346,107</td>
<td>48,889,275</td>
<td>370,057,985</td>
</tr>
<tr>
<td>Southern Europe</td>
<td>161,007,082</td>
<td>77,582,741</td>
<td>44,386,741</td>
<td>7,443,110</td>
<td>46,268,543</td>
<td>337,783,217</td>
</tr>
</tbody>
</table>

**Figure 2. Explorer report with categories added from the dimension viewer**

If you change the default preferences to use Reporter mode for new reports, new reports are empty. After you open a cube, you add information from different dimensions or from different levels of the same dimension.

You can add categories to reports in different ways.
- You select a category and then use the toolbar buttons in the dimension viewer.
- You can drag categories to a report from the dimension viewer or dimension line.
To add the next level of the selected category in a Reporter report, click the **Next Level Children** button in the toolbox, and then drag the category to a drop zone in the report.

To add the lowest level of the selected category in a Reporter report, click the **Lowest Level Children** button, and then drag the category to a drop zone in the report. This is faster than drilling down to the lowest level and adding all categories at that level.

To replace existing categories in an Explorer report, drag a category from the dimension line or dimension viewer to a row or column label.

You can switch between the long and short versions of the category names that were set up by the administrator.

**Procedure**

1. From the **View** menu, click **Dimension Viewer**.
2. In the dimension viewer, select the category that you want to add to your report.
   - In an Explorer report, select the parent category of the categories that you want to add.
3. Do one of the following:
   - For Explorer reports, on the dimension viewer toolbar, click the **Replace Rows** or **Replace Columns** button.
   - For Reporter reports, on the dimension viewer toolbar, click the **Add As Rows** or **Add As Columns** button.
     - To remove a category or level, right-click a category, and then choose to delete the category or level.

**Add Nested Categories to a Report**

You can add nested categories to a report to see another level of information about your business.

In an Explorer or Reporter report, you can nest:

- multiple levels from one dimension
- levels from different dimensions
- levels from a dimension nested with multiple measures

In Explorer reports, you can nest levels from the same dimension so that child categories appear directly below parent categories. When you drag a child category on a nested category, the child replaces the nested category and its siblings.

In Reporter mode, when you drag a category on a nested category, you add the category to the report. You can also nest levels from alternate paths of the same dimension.

To nest categories, you can drag categories from:

- the dimension viewer
- the dimension line
- the rows, columns, or layers of the report
- another report

Two drop zones, long bar and short bar, govern how categories are nested.
Long bar drop zones are available for both Explorer and Reporter reports. You can use these drop zones to add categories to rows or columns as a higher or lower level.

For example, an Explorer report shows Sales regions in the columns and Years in the rows. To add the children of Years as nested categories in all the rows of the report, you drag the Years dimension to a long bar drop zone.

<table>
<thead>
<tr>
<th></th>
<th>Americas</th>
<th>Asia Pacific</th>
<th>Central Europe</th>
<th>Northern Europe</th>
<th>Southern Europe</th>
<th>Sales regions</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004</td>
<td>102,342,219</td>
<td>166,061,915</td>
<td>420,993,362</td>
<td>70,276,517</td>
<td>66,351,554</td>
<td>914,737,487</td>
</tr>
<tr>
<td>2005</td>
<td>209,401,452</td>
<td>274,446,436</td>
<td>639,441,398</td>
<td>90,254,735</td>
<td>78,230,833</td>
<td>1,159,916,737</td>
</tr>
<tr>
<td>2006</td>
<td>312,665,726</td>
<td>276,316,000</td>
<td>676,044,507</td>
<td>117,370,877</td>
<td>115,823,290</td>
<td>1,497,932,200</td>
</tr>
<tr>
<td>2007</td>
<td>234,000,576</td>
<td>206,165,272</td>
<td>500,200,108</td>
<td>92,104,996</td>
<td>87,473,890</td>
<td>1,118,944,831</td>
</tr>
<tr>
<td>Years</td>
<td>978,300,972</td>
<td>860,709,525</td>
<td>2,144,579,336</td>
<td>370,057,985</td>
<td>337,789,217</td>
<td>4,691,531,035</td>
</tr>
</tbody>
</table>

Figure 3. Drop zone for nesting categories in an Explorer report

In the resulting report, quarters, the children of the Years dimension, are nested in all of the rows.

<table>
<thead>
<tr>
<th></th>
<th>Americas</th>
<th>Asia Pacific</th>
<th>Central Europe</th>
<th>Northern Europe</th>
<th>Southern Europe</th>
<th>Sales regions</th>
</tr>
</thead>
<tbody>
<tr>
<td>2004</td>
<td>47,302,280</td>
<td>41,557,116</td>
<td>101,797,806</td>
<td>17,176,597</td>
<td>13,765,154</td>
<td>221,711,013</td>
</tr>
<tr>
<td>2004 Q.1</td>
<td>48,467,364</td>
<td>40,703,086</td>
<td>105,181,738</td>
<td>17,126,720</td>
<td>13,736,715</td>
<td>222,216,515</td>
</tr>
<tr>
<td>2004 Q.2</td>
<td>50,170,797</td>
<td>43,923,316</td>
<td>109,611,564</td>
<td>17,876,518</td>
<td>14,306,831</td>
<td>235,888,826</td>
</tr>
<tr>
<td>2004 Q.3</td>
<td>48,321,778</td>
<td>41,677,345</td>
<td>112,302,254</td>
<td>18,056,682</td>
<td>14,553,054</td>
<td>234,921,113</td>
</tr>
<tr>
<td>2004 Q.4</td>
<td>102,342,219</td>
<td>100,651,915</td>
<td>428,803,302</td>
<td>70,276,517</td>
<td>56,301,554</td>
<td>914,737,467</td>
</tr>
</tbody>
</table>

Figure 4. Explorer report with categories nested in rows

Short bar drop zones are available for only Reporter reports. You can use short bar drop zones to add categories to individual rows or columns as lower levels.

For example, a Reporter report shows Sales regions in the columns and Years in the rows. Using the short bar drop zone, you nest Direct Marketing in the Americas column to quickly filter the data on a specific retailer type.
After you nest the category, the data in the Americas column is filtered on Direct Marketing.

**Procedure**
1. In the dimension viewer, select the category you want to add.
   - In an Explorer report, select the parent category of the categories that you want to add.
2. Drag the category to the appropriate drop zone in your report.

**Results**

**Tips:** In a Reporter report, you can nest a parent/child relationship in the same row or column. Select the categories, click the Create Nesting Levels button, and then use the dimension viewer toolbar to add the categories as a row or column. To delete a category or level, right-click a category, and then choose to delete the category or level.

**Selecting Nested Categories**

If you add a nested category to all rows or columns in a level using a long bar drop zone, all changes apply to all occurrences of that category.

For example, in the following report, sales regions are nested under products. When you select a sales region, IBM Cognos PowerPlay highlights all instances of the category.
Because all occurrences of the category are selected, any action you perform on one occurrence such as moving, removing, and formatting applies to all occurrences of that category.

If you used short bar drop zones to add more than one instance of a category, you must select each instance separately to apply a change.

Add Intersected Categories to a Reporter Report

In Reporter reports, you can add new intersected categories.

These appear as a single, unified category instead of their component categories.

By combining categories with measures or with time-related categories, you can create intersected categories that reveal important information about your business.

Procedure

1. From the View menu, click Dimension Viewer.
2. In the dimension viewer, Ctrl+click to select two or more categories to combine.
   The categories must come from different dimensions. If you select categories from the same dimension, IBM Cognos PowerPlay adds them as individual categories.
3. Click the intersect button.
4. Click the add as rows button or the add as columns button.
Related tasks:
“Add Nested Categories to a Report” on page 7

You can add nested categories to a report to see another level of information about your business.

Working with layers
You can use layers to show data for each category on a separate page.

For example, a report shows how many products were sold each quarter. By adding the Locations dimension as a layer, you can see how many products were sold in the Americas, in Europe, and in the Far East.

When you add layers to an Explorer report, a summary layer and its child categories are added as layers. In a Reporter report, only the selected category is added as a layer. You can drill down on this layer to add lower-level categories.

You can change the label name for a layer, drill down a layer, or drill up a layer.

Procedure
1. To add a new layer, drag a dimension folder, or a folder from the dimension viewer, to the layer target in the dimension line.
2. To change an existing layer, use the appropriate action for the report type:
   • In Explorer reports, drag a different dimension folder to the layer target.
   • In Reporter reports, remove the layer and drag a different dimension folder to the layer target.
3. To move between layers, do one of the following:
   • click one of the arrows in the layer.
   • right-click the layer label and click Go To Layer. Click the layer where you want to move and click OK.
4. To remove layers, choose whether to remove one layer from a Reporter report or all layers from a Reporter or Explorer report:
   • To remove a layer from a Reporter report, select a layer and click Delete Current Layer.
   • To remove all the layers from a report, right-click any layer and click Delete All Layers.

Duplicate a Report
To maintain a copy of a report or take advantage of features that are offered by one report type over another and still keep the current report type, you can duplicate a report. You can also copy information between reports that use the same data source.

By default, duplicated reports have a shared dimension line. You can turn this feature off.

If an Explorer report shows values as a percentage of a total or subtotal and you duplicate the report as a Reporter report, the Show Values As setting reverts to the default setting, Value.
Procedure

From the File menu, click Duplicate As and select the alternative report type.

Copy Information Between Reports

To maintain a copy of a report or take advantage of features that are offered by one report type over another and still keep the current report type, you can copy information between reports that use the same data source.

When you copy categories between reports, formatting applied to the category in one report is not carried over to the other report.

Procedure

1. Open the reports between which you want to copy information.
2. From the Window menu, click one of the tile commands.
3. Select the categories to copy.
4. Drag the categories from one report to the other.

Hide Categories

You can hide categories to make it easier to focus on important information. You can choose to hide the categories you select or the categories that are not selected.

You can hide categories in both Explorer and Reporter reports. In Reporter reports, you can hide the rank category and delete hidden categories.

Data is hidden temporarily. For example, if you are looking at sales during 2008 for Europe, the Americas, and the Far East, you might hide the Americas. When you drill down, you do not see data for the Americas. If you drill up to the top, you see data for Europe, the Americas, and the Far East again.

To hide categories completely, apply the Hidden style or remove the categories if a Reporter report is active.

If the current display includes the rank category, you can hide this category. This option is not available if Nested Charts is selected on the Explore menu. By default, ranked categories are hidden in scatter displays.

You cannot hide layers; you must remove them from the report.

When you unhide categories, the following categories remain hidden:

- Categories hidden by applying a custom exception definition.
- Categories hidden because of ranking. For example, if you rank the report to show the top ten products for the past month, the Unhide command does not show the other products.
- Categories hidden by suppressing values. For example, if you specify that missing values should not be shown, the Unhide command does not show missing values.

Procedure

1. Select one or more categories in your report.
2. Choose whether to hide selected or unselected categories:
   a. To hide selected categories, from the Format menu, click Hide, Selected Categories.
To hide unselected categories, from the Format menu, click Hide, Unselected Categories.

Results

To unhide categories, from the Format menu, click Unhide.

Tip: To quickly hide one category in Explorer crosstab displays, size a category until it has a zero width (for a column) or zero height (for a row).

Show Summary Categories

In Explorer reports, you can hide or show the summary categories.

Procedure

1. To show summary categories for the entire report:
   - From the Format menu, click Display Options.
   - On the General tab, in the Summary Options box, select one of the summary options and click OK.
2. To show the summary category for a specific level in the report, right-click a row or column category in a crosstab, and click Show Summaries at this Level.

Swap Rows, Columns, and Layers

You can swap rows and columns, rows and layers, or columns and layers to analyze your information differently.

For example, if the rows contain quarters of the fiscal year and the columns contain products, you can swap them so rows contain products, and columns contain quarters. That way, you can track trends over time more easily, particularly in single line or multiline displays.

For example, a report with products in the rows, quarters in the columns, and locations in the layers compares performance by region. If you swap rows and layers, you can see how well each product sold. If you swap columns and layers instead, you can compare quarterly sales figures.

Procedure

From the Explore menu, click Swap, and click Rows and Columns, Rows and Layers, or Columns and Layers.

The names of the items available from the Swap command change depending on the type of display selected. For example, in a pie display, the Rows and Columns command is called Displays and Slices, and the Rows and Layers command is called Displays and Layers.

Results

Tip: To swap rows and columns in Explorer reports, you can also use drag and drop. For example, to swap a row and column, select any row category and drag it to the column area.

Insert Blank Rows and Columns

You can add blank rows or columns to a Reporter crosstab.
This is useful for separating groups of information. For example, you prepared a IBM Cognos PowerPlay report that outlines the types of mutual funds that your company sells. You want to distinguish the individual funds from the funds summary, so you add a blank row and column before the summaries.

You can format and resize any blank row or column. For example, to add a background pattern to a blank row or column, select the blank, and from the Format menu, click Categories, and click Labels and Values.

You can not have a blank row or column at the beginning of a level. You can not have blank layers. If you swap rows or columns with layers, or change to a graphical display, the blanks do not appear.

**Procedure**

1. In a Reporter report, click the row above or column to the left of where you want the blank to appear.
2. From the Insert menu, click Blank(s).

**Move a Row or Column**

In Reporter reports, you can move rows or columns to change the order in which they appear.

In an Explorer report, if you drag a row to the column area, or drag a column to the row area, you swap all rows and columns.

**Procedure**

1. Select the row or column label that you want to move.
2. Drag the row or column label to the new location.
   - To preserve the original arrangement of a category or group of categories in a nested crosstab display, press the Ctrl key when you drop them.
   - To make the row labels appear in the middle of the report, drag the columns to the left of the row labels.

   The pointer changes and a thick black line indicates where you can drag the row or column.

**Set the Prompting and PDF Properties for Published Reports**

As a report author, you can select the items that you want the report consumer to be prompted for when they open the report in PDF format from IBM Cognos Connection. You can also limit how much data appears in the report.

By default, reports are published with no prompting. You can change the default prompting properties prior to publishing or republishing a report to IBM Cognos Connection.

**Procedure**

1. Open the report that you want to publish to IBM Cognos Connection.
   The report must be based on a remote package, not a local cube.
2. From the File menu, click Run Options.
3. On the Prompts tab, in the Prompt Report Consumer For box, specify the prompting options available to the consumer when opening the published report.
4. On the **PDF Options** tab, in the **Save** box, specify the part of the report that you want the consumer to see when opening the published report.

5. In the **Selected Display Saving Options** box, specify the report properties that you want to save with the published report.
   - Depending on the option you selected in the **Save** box, some items are not available.
6. Click **OK**.

### Suppress Unnecessary Information

You can suppress unnecessary information such as zeros, missing values that appear as ‘na’ or zeros, and the result of dividing by zero. For example, if a row contains all zeros, you may want to suppress that row.

The rank category doesn't interfere with value suppression when you rank data. For example, you add a rank category and want to suppress zero values. One row contains all zeros, except for the last cell, which contains the value from the rank category. IBM Cognos PowerPlay ignores the rank category and suppresses the row of zeros.

### Suppress Zeros

You can control how zeros are suppressed in reports.

For best performance, suppress zero values but not computed zeros (aggregations or calculations whose result is zero).

You can change the preferences for suppressing values to determine which values are suppressed in new reports by default.

In Explorer reports, zero suppression is applied to the visible data. PowerPlay does not consider hidden categories when applying zero suppression.

When you apply zero suppression to a chart that supports multiple measures, the suppression is only applied to the first measure. You cannot apply suppression to a second measure, such as the line of a correlation chart, or to conditions when both measures are zero.

### Procedure

1. From the **File** menu, click **Preferences**.
2. On the **Suppress** tab, in the **Suppression Options** box, do the following:
   - To suppress a row or column containing all zero values, select **Zero Values**.
   - To suppress a row or column where all cells contain values as a result of dividing by zeros, select **Division by Zero**.
   - To suppress a row or column where all cells contain missing values, select **Missing Values**.
   - To suppress a row or column where all cells contain values larger than the measure's storage type allows, select **Overflow Values**.
3. From the **Explore** menu, click **Suppress, Zeros**, and click **Rows and Columns**, **Rows Only**, or **Columns Only**.

### 80/20 Suppression

With 80/20 suppression, you can remove the rows and columns with values that are not significant contributors to your Explorer report.
Values are ordered largest to smallest. Those values that contribute to at least 80% of the overall total are considered significant and appear in the report. The remaining values that are not required to attain 80% of the overall total are suppressed, and these categories are grouped into an "Other" category. The label of the "Other" category is italicized.

In nested reports, each value in the report is considered individually against the Grand Total. This can result in multiple "Other" categories appearing at different levels.

If you swap rows and columns when you selected an 80/20 suppression option, the suppression remains on the selected option. For example, a crosstab shows Products as columns, and Years as rows. You apply 80/20 suppression on the columns, and then swap rows and columns. 80/20 suppression remains on the columns.

All "Other" categories along an axis (that is, along rows, columns, or layers) share formatting, name, and hidden state characteristics. For example, a report has two levels of nesting in rows, and three "Other" categories appear along the rows. If you change the font color to red for one "Other" category, all "Other" categories in the rows become red.

You cannot rename, rank or perform calculations on the "Other" category.

You can use the drill cursor to drill down on the "Other" category when one of the two categories in the intersection is drillable. However, you cannot drill down on the "Other" category from the context menu. This is because these category types are not drillable.

If you select 80/20 suppression and then switch to Reporter mode, 80/20 suppression is no longer applied. If you then save the Reporter mode report, 80/20 suppression is not saved with the report.

Before you begin

80/20 suppression is available only if rows, columns, or layers contain only one measure.

Procedure

From the Explore menu, click Suppress, By 80/20 Rule, and click Rows and Columns, Rows Only, or Columns Only.

Results

To view the categories that have been grouped together in the Other category, open the Explain dialog box.

Remove Unwanted Information

In Reporter reports, you can remove unwanted information by deleting it.

In a crosstab, you can delete any level at any time without deleting the children of the deleted level. For example, a crosstab shows three levels of nesting based on Years, Quarters, and Months. You can delete the Quarters level, and the report
shows two levels of nesting: Years and Months. Removing the middle level (Quarters) does not delete the lowest level (Months).

You can also remove information by temporarily hiding a category.

If you hide categories by ranking the top or bottom number of categories, by applying a custom exception definition, or by suppressing zeros, you can delete these hidden categories to speed up the performance of IBM Cognos PowerPlay. Hidden categories are still part of the report and use up available memory. When you delete hidden categories, PowerPlay performs more quickly.

You can't delete hidden categories when there are layers in the report, because the criteria for ranking or suppressing values for one layer may not apply to another layer.

Except for ranked or calculated categories, you can't remove a category from an Explorer report. You can only hide information.

**Procedure**

1. To remove a category or level in a Reporter report:
   - Select the category or level that you want to remove.
   - From the **Edit** menu, click **Delete, Category(s)** or **Level**.

2. To remove hidden categories in a Reporter report:
   - From the **Edit** menu, click **Delete, Hidden Categories**.
   - In the **Delete Hidden Categories** dialog box, select one or more check boxes that correspond to the hidden categories you want to delete and click **OK**.

**Considerations to Improve Report Accessibility**

Creating accessible reports ensures access of information to all users, with all levels of ability.

For example, people with a visual impairment may use screen reading technology to access the information in a report.

The following are some design considerations for creating accessible reports:

- Avoid using visual cues, such as bold text or color, to convey important information.
- Avoid using pictures and OLE Objects in PDF documents, as these items are tagged as artifacts and ignored by the screen reader.
- Avoid using conditional formatting to convey important information.
- Ensure that there is a table corresponding to chart types that are rendered as images because the screen reader ignores this information.
- Ensure that the report has a title.
- Gain an understanding for screen reading technology.
- Avoid spelling and grammatical errors, as they cause the screen reading software to misinterpret the information.
- Avoid using features like calendar boxes and up and down selections on time controls. Instead use prompts such as check boxes, radio buttons, combo boxes, and multi-select boxes.
- Ensure that the target application is accessible when using embedded Web applications or drill-through paths.
- Avoid using large, complex list or crosstab reports.
  Displaying the information in multiple simple lists or crosstab reports is more manageable for assistive technology users.
Chapter 2. Maintaining Standard Reports

With your data sources constantly changing, it is important to maintain standard reports. By doing so, you save time and increase your reporting capabilities.

You can
• share the dimension line between two reports
• set up and use reports as templates
• update information automatically
  Every time you open an existing report, or drill up and down, the information is updated with the most current information.
• update information manually
  If you work from a large data source, updates can be time-consuming. If you update manually, you can format your rows, columns and layers, drill down to the levels of information that you want, and then bring in the most current data at your convenience.
• use dynamic subsets that are updated every time there is a data source change that affects the categories in the subset

Share the Dimension Line

A shared dimension line is useful for simultaneously exploring related information in more than one report. When you have more than one report open, and the reports share a dimension line, all changes to dimensions in one report automatically appear in the other report.

For example, you create two reports based on the same data source to help you analyze the sales performance of your product line. One report shows trends in products for 2005 and 2006, and the other shows revenue for each customer type in each location. When you drill down on 2006 to show revenue by quarter, the other report is filtered to show data for the same time period.

You can use different measures in each report. If you change the measure in one report, the other reports is not affected.

By default, all reports created from the same data source share the dimension line. If you want to drill down and filter in one report without affecting other open reports, change the default preference for sharing a dimension line.

Procedure
1. Open the reports you want to work with.
2. From the Window menu, select a tile option to view all reports.
3. From the File menu, ensure that Shared Dimensions is selected.
4. Use exploration options such as drill down or filtering in one report.

Results

The exploration option you apply to one report is automatically applied to the other open reports.
Create a Report Template

Templates allow report authors to create new reports in less time and help to ensure data is presented in a consistent way.

For example, you are the Human Resources manager for a nationwide company that sells camping equipment. You have three core product groups that each operate as strategic business units, Environmental Line, GO Sports Line, and Outdoor Products. Each unit has its own cube for analysis. You create a report template so that the manager of each unit presents the data in the same way.

You can use a template with a different data source if the data source has the same top-level dimensions. You administrator can provide more information about available data sources and creating templates that can be used with more than one data source.

Procedure
1. Set up the information to appear in the report. For example, add categories, drill down, or filter.
2. Format the report. For example, add a title, resize rows and columns, and change the font and style of labels and values.
3. Save the report.

Results
Other report authors can now use the report as a template for creating new reports. You should make your template read-only so users don’t overwrite it when saving their new reports.

Control when data is updated

By default, when you open or make changes to a report, IBM Cognos PowerPlay automatically updates the data so that you see the most current values for the categories in your report.

There are some circumstances where you may prefer to manually update your reports. One example is when you work with very large cubes. In this case, if it takes an unacceptable amount of time to refresh the data as you build a new report or navigate to a specific location in a report, you can choose to refresh the data manually to view the data as needed.

When automatic update is disabled, a question mark (?) appears in the report’s cells until you manually update the report.

Procedure
1. Change the default settings to disable automatic data updates:
   • To turn off automatic updating for all reports, from the File menu, click Preferences. On the Options tab, clear the Get Data Automatically check box.
   • To turn off automatic updating for a specific report, from the Explore menu, clear Get Data, Automatically.
2. To update the data when automatic data updates is disabled, from the Explore menu, click Get Data, Now.
**Subset Definitions**

A subset definition is a query that defines a new set of categories based on specified criteria.

Subset definitions are most useful in Reporter mode reports. For example, you create a subset definition to show all sales representatives of a certain region in your report. When the region hires a new sales representative, the change will appear in the report when you refresh the data. If the Reporter mode report didn't include this subset, the new sales representative would not appear in the report after you refresh the data.

In Explore mode reports, category changes are reflected in the report when you refresh the data.

You can create three types of subset definitions:
- Parentage Subset
- Find in Cube Subset
- Advanced Subset

After you create a subset definition, it is displayed in the subset viewer of the report.

**Create a Parentage Subset Definition**

You can create a subset definition based on a level or levels in a dimension.

For example, you are one of the regional managers for a company that sells camping equipment around the world. Every year, you need to present a report that includes the last two years revenue for all the sales representatives in the Americas. Sales representatives are the lowest level children of America. To create the required report, you create a parentage subset definition that includes the lowest level children of the Americas.

**Procedure**

1. In the dimension viewer of a Reporter report, click the dimension folder you want to use to create the definition.
2. Click the create parentage subset definition button in the toolbox.
3. In the **Qualifier** box, do one of the following:
   - To use the children of the selected level, click **Next Level Children**.
   - To use the children of the selected level as well as the children of those categories, click **Next Two Levels' Children**.
   - To use the lowest level children in the dimension, click **Lowest Level Children**.
4. Click **Save Subset** and click **Close**.

**Results**

IBM Cognos PowerPlay shows the subset definition in the subset viewer.

**Create a Find-in-Cube Subset Definition**

You can create a subset definition based on all categories in the cube that meet specified criteria.
Procedure
1. In the dimension viewer toolbox of a report, click the create find-in-cube subset definition button.
2. Specify the search settings.
3. Click the Find All button.
4. Click Save Subset and click Close.

Results
The subset definition appears in the subset viewer.

Wildcards
You can use wildcards in a find-in-cube subset definitions or for searching for data.

Table 1. Wildcard characters

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>^</td>
<td>The beginning of a string. For example, &quot;^inter&quot; finds &quot;interesting&quot; and &quot;interfere&quot;, but not &quot;splinters&quot;</td>
</tr>
<tr>
<td>$</td>
<td>The end of a string. For example, &quot;in$&quot; finds &quot;in&quot; and &quot;within&quot;, but not &quot;interfere&quot;</td>
</tr>
<tr>
<td>?</td>
<td>Any single character (except newline). For example, &quot;to?&quot; finds &quot;top&quot; and &quot;ton&quot;, but not &quot;to&quot;</td>
</tr>
<tr>
<td>~</td>
<td>Zero or one occurrence of the preceding character (or sub-expression). For example, &quot;files~&quot; finds &quot;file&quot; and &quot;files&quot;, but not &quot;filed&quot;</td>
</tr>
<tr>
<td>*</td>
<td>Zero or more occurrences of any characters (except newline). For example, &quot;can*&quot; finds &quot;can&quot; and &quot;Canada&quot;</td>
</tr>
<tr>
<td>#</td>
<td>Zero or more occurrences of the preceding character (or sub-expression) For example, &quot;filex#&quot; finds &quot;file&quot; and &quot;filexx&quot;</td>
</tr>
<tr>
<td>@</td>
<td>One or more occurrences of the preceding character (or sub-expression). For example, &quot;filex@&quot; finds &quot;filex&quot; and &quot;filexxx&quot;, but not &quot;file&quot;</td>
</tr>
<tr>
<td></td>
<td>Either the preceding character (or sub-expression) or the following one. For example, &quot;localis</td>
</tr>
<tr>
<td>[ ]</td>
<td>Any character within the brackets. Ranges of characters can be specified using a hyphen (a hyphen at the start matches itself). An exclamation point at the beginning causes the set of characters to be inverted. For example, [!a-m] matches everything except a through m. For example, p[iu]ck&quot; finds &quot;pick&quot; and &quot;puck&quot;</td>
</tr>
</tbody>
</table>
Table 1. Wildcard characters (continued)

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>()</td>
<td>Sub-expressions, so that repetition and alternative wildcard characters can be applied more generally. For example, &quot;ab(cd)#e&quot; finds &quot;ab&quot; followed by zero or more &quot;cd&quot; combinations followed by &quot;e&quot;</td>
</tr>
<tr>
<td>\</td>
<td>The next character literally. Allows wildcard characters to be treated as normal characters. For example, &quot;what?&quot; finds &quot;what?&quot;</td>
</tr>
</tbody>
</table>

Create an Advanced Subset Definition

You can define a subset that matches specified criteria. For example, you may want to define a subset that includes only sporting good products sold in Canada and the U.S. Like all subsets, advanced subset definitions are saved with the report so that you can reuse them even if the cube changes.

You create an advanced subset definition by first determining the dimension that you want to use. For example, if you want your subset to focus on the top sales branches by revenue, you select the Locations dimension because sales branches are contained within the Locations dimension. If you want to also include the country or region level in your definition, you can select more than one level to appear. You may need to choose an alternate drill-down path if the levels that you want are not in the primary drill-down path.

You can further restrict the definition by including or excluding restrictions by parent category, by name or description using a find-in-cube definition, or by value. A subset definition can include one or all of these restrictions.

For example, you are in charge of Finance for a company that sells camping equipment. Every month, you need to present a report that shows revenue for one of your company's channels. You need to see only those products that are sold in Canada and the U.S. and that are part of the Sports Line, so you create an advanced subset definition that includes only these categories.

When you sort categories in an advanced subset, categories with missing values are sorted at the end of the list regardless of the sort order.

You cannot create an advanced subset definition that includes levels or categories from more than one dimension. Advanced subset definitions are always dimension specific because you focus on one type of object at a time. You can apply filters from other dimensions to limit the data returned. For example, you create a subset definition on the products dimension and apply a filter to return only data for products sold in Europe.

You can use Measures as the dimension only if the selected measure contains more than one level. If you create an advanced subset using Measures as the dimension, you cannot create an advanced subset definition with restriction by value.

If you include a level in your subset definition that is subsequently removed from the cube, your results may be incorrect.
Procedure

1. In a Reporter report, click the create advanced subset definition button.
2. Specify the advanced subset settings.
   - If there are no alternate drill-down paths, the only choice is Primary.
   - If you select more than one level, your subset appears as nested levels.
   - To see a list of some of the categories that are included in a level in the Level(s) box, right-click the level label and click Sample Categories.
3. Click Save Subset and click Close.

Results

The subset definition appears in the subset viewer.

Create an Advanced Subset Definition with Restriction by Parent

Restricting an advanced subset definition by parent enables you to include or exclude specific levels in the subset.

Although a category must meet all restrictions to be returned in the results of an advanced subset definition, if you include two restrictions from the same parent, the results only need to meet one of these restrictions. For example, if you include both Canada and the United States from the Americas dimension, then the resulting categories may come from either Canada or the United States.

If you want to include the majority of your categories in the subset, you can just exclude the few categories you do not want.

For example, you are one of the regional managers for a company that sells camping equipment around the world. Every year, you need to present a report that includes the last two years revenue for all sales people in Canada and the United States, but Canada, the United States, and Mexico are all included in the Americas category. You create an advanced subset definition with parent category restrictions that includes only these lowest level children for Canada and the United States and excludes the lowest level children for Mexico.

Procedure

1. In a Reporter report, click the create advanced subset definition button.
2. Specify the name, dimension, and categories settings.
   - If there are no alternate drill-down paths, the only choice is Primary.
   - If you select more than one level, your subset appears as nested levels.
   - To see a list of some of the categories that are included in a level in the Level(s) box, right-click the level label and click Sample Categories.
3. On the Parent tab, click the drill-down path that contains the restrictions you want to use.
   - You can qualify a subset definition using restrictions from both primary and alternate drill-down paths. If there are no alternate drill-down paths, the only choice is Primary.
4. Add categories to the Selected Restrictions box.
   - To include a category, select it and click Include.
   - To exclude a category, select it and click Exclude.
5. Click **Save Subset** and click **Close**.

**Results**

IBM Cognos PowerPlay shows the subset definition in the subset viewer.

**Create an Advanced Subset Definition with Restriction by Name or Description (Find)**

Restricting an advanced subset definition by name or description enables you to include categories in the subset that contain a specific text string.

For example, you are in marketing for a company that sells many different camping products. You need to present a report each month that contains all of the product lines using the word GO. You create a subset definition that returns all of the product line categories that contain this word.

**Procedure**

1. In a Reporter report, click the create advanced subset definition button.
2. Specify the name, dimension, and categories settings.
   - If there are no alternate drill-down paths, the only choice is **Primary**.
   - If you select more than one level, your subset appears as nested levels.
   - To see a list of some of the categories that are included in a level in the Level(s) box, right-click the level label and click **Sample Categories**.
3. On the **Find** tab, click **New**.
   - The **Restrict by Find Definition** box contains only definitions that are already defined for the dimension selected in the **Dimension** box.
4. Specify the search settings.
5. Click **Save Subset** and click **Close**.
6. In the **Advanced Subset** dialog box, click **Save Subset** and click **Close**.

**Results**

The subset definition appears in the subset viewer.

**Create an Advanced Subset Definition with Restriction by Value**

Restricting an advanced subset definition by value enables you to include categories in the subset that represent the largest or smallest values or values that are greater than, less than, or between specific values in a level.

For example, you are in charge of Finance for a company that sells camping equipment. Every month, you need to present a report that shows the ten best selling products for one of your company’s channels. You need to see only those products that are sold through the camping chain channel, so you create an advanced subset definition that includes only these categories.

If you select Measures as the dimension, you cannot create an advanced subset definition with restriction by value.
Procedure

1. In a Reporter report, click the create advanced subset definition button.
2. Specify the name, dimension, and categories settings.
   - If there are no alternate drill-down paths, the only choice is Primary.
   - If you select more than one level, your subset appears as nested levels.
   - To see a list of some of the categories that are included in a level in the Level(s) box, right-click the level label and click Sample Categories.
3. On the Value tab, click New.
   - You can also choose an existing value restriction subset definition from the Restrict by Value box.
4. Select the measure you want to use.
5. Specify the value restrictions.
   - If you are using values from a measure based on a percentage, you must use the decimal format when entering a value. For example, if you are restricting an advanced subset to profit margin values greater than 20 percent, enter .20.
6. To specify a category for a dimension other than the default dimensions of the report, in the Based on the Dimension Setting box, select a dimension and click the Edit button. Select a category and click OK.
   - Changing a category for a dimension applies only to the subset and does not affect the dimension line settings for the report. You can only change the categories for dimensions that have not yet been set. For example, the dimensions selected in previous steps are not available in the Based on the Dimension Setting box.
7. In the Restrict by Value box, click OK.
8. In the Advanced Subset dialog box, click Save Subset and click Close.

Results

The subset definition appears in the subset viewer.

Open a Subset Definition

To see the results of a subset definition, you can open it in the subset viewer.

Procedure

In the subset viewer, click the Expand button beside the subset definition.

Results

The items in the subset appear below the subset definition name. If the subset definition does not retrieve any resulting categories, the expand button disappears.

Change a Subset Definition

You can edit any subset definition that appears in the subset viewer. When you edit a subset definition that is already added to a report, the categories in the subset are updated to meet the new results of the definition.

Procedure

1. From the subset viewer, right-click the subset definition you want to modify, and click Edit.
2. Make the changes to the definition and click OK.
Results

Tip: To see the details of a subset definition, right-click it, and click Explain. To rename a subset definition, right-click it, and click Rename.

Delete a Subset Definition
When you no longer need a subset definition, you can delete it from the list of subset definitions.

Procedure
Right-click the subset and click Delete.

Results
If the subset was used in the report, IBM Cognos PowerPlay prompts you to choose whether to delete the categories from the report or leave the categories in the report while breaking the association with the subset. If you chose to leave the categories in the report, the next time the data is refreshed, the categories added using the subset are not updated.

Highlight Subsets
If you want to see the categories that belong to a subset in a report, you can add a background pattern to a crosstab display.

You can change the default display settings in Preferences to automatically highlight subsets in all reports and to change the default pattern used to highlight subsets.

Procedure
1. In a crosstab display, from the Format menu, click Display Options.
2. On the General tab, select Highlight Subsets.
3. To change the background pattern, click Subset Patterns, select a different pattern, and click OK.
4. Click OK.

Results
You can also highlight subsets using the default pattern by clicking Highlight Subsets from the View menu.

Subset Calculations
In order to perform a subset calculation, you must have only one entire subset selected. If you attempt to perform a calculation on items from a subset and other items in the report, you will receive a message indicating you are about to break the subset.

You can perform the following non-group calculations on a subset:
• add
• multiply
• maximum
• minimum
• average
• rollup

A subset calculation always appears directly after the subset in the report. Although a subset calculation is not highlighted with the rest of the subset, it is recalculated if the subset changes.

You can also perform calculations on individual categories in a subset, however the new calculation does not become a member of the subset and is not updated if the subset changes.

In Reporter mode, you should not use the Select Subset menu to create a calculation while the suppress zeros option is activated. Instead, first create the subset calculation without zero suppression, and then apply zero suppression.

**Break or Delete a Subset**

You can break a subset if you no longer want the subset categories to be updated. For example, if you are preparing a report to present at the end of the Quarter, you do not want it updated after the Quarter is over.

In addition to the steps in this procedure, other events that break a subset include:

• if an individual category in the subset is deleted
• if one or more categories are added between two categories in the subset
• if you add a nested category to only one category in a subset (using short bar drop zones)
• if you drill down on a category in a subset
• if you rank or sort a report that results in categories being removed from or inserted between categories in a subset

When you break a subset in one of these ways, you receive a warning to confirm that you want the subset broken. You can choose to show this message every time a subset is broken or you can turn the message off.

When you save a report in which a subset is broken, a list of the broken subsets appears. If you save a report with broken subsets, the categories from the broken subset are not updated, however the subset definition remains in the subset viewer.

**Procedure**

Choose whether you want to break or delete the subset:

• Right-click the subset and click **Break Subset**.
• Right-click a category in the subset, click **Delete**, and click **Subset**.
Chapter 3. Dimensions

The administrator who creates the cubes that you use as data sources in IBM Cognos PowerPlay organizes different aspects of your business into dimensions. Each dimension has its own folder on the dimension line, such as Years, Locations, Products, and Channels.

PowerPlay lets you explore dimensions by slicing and dicing. You can
- drill down and up
- filter information
- search for information
- change the information appearing in rows, columns, or layers

To support specialized reporting requirements, the Transformer modeler can add scenario dimensions to a cube. In the dimension viewer, a scenario dimension is distinguished from other dimensions by the scenario dimension icon 

Scenario dimensions are often used when budgeting and forecasting, or for planning-related applications. Unlike regular dimensions, scenario dimensions do not roll up to a single root category, because that value would not be useful.

Contact your Transformer modeler for more information about using existing scenario dimensions or to determine if new scenario dimensions would be useful to you.

Drill Down

You drill down on a parent category to see its child categories. Drilling down has different results in Explorer and Reporter reports.

In Explorer mode, when you drill down, you replace parent categories with the child categories of the item you drilled down on. For example, you are working in a report where Locations is the summary level and Americas is a child of Locations. When you drill down on Americas, the child categories, Brazil, Canada, Mexico, and United States appear in the report. Americas replaces Locations as the summary level. The associated dimension line folder appears open and shows Americas to indicate the current summary level for that dimension.
The following considerations apply when drilling down in Explorer reports.

- When you drill down on a nested level, you preserve the number of levels until you reach the bottom of the hierarchy. At this point, the parent level is temporarily removed until you drill up again.
- You can drill down on a rank or calculation.
- You cannot drill down on an 'Other' category (80/20 suppression).
- If you double-click the summary category, you are drilling up to a higher level of categories, not drilling down.

In Reporter mode, when you drill down, you add the child categories to the report. The original parent categories remain in the report. The associated dimension folder does not appear open and its name shows the top level of the dimension. The following report shows the results when you drill down on Americas in Reporter mode.

You can use alternate drill paths in both Explorer and Reporter reports if the IBM Cognos Transformer modeler has set them up. An alternate path is another path within the same dimension that leads to the same categories. For example, two paths are available in the Channels dimension: the primary path is by Channel...
Type, and the alternate path is by Region. If you drill down the primary path, you drill down from Channel Type to Customer. If you drill down in the alternate path, you drill down from Region to Customer.

Alternate paths and special categories appear italicized in the dimension menu (dimension line). Alternate paths and special categories appear with a folder with splitting arrows in the dimension viewer.

**Procedure**

Where the pointer appears as a plus sign, double-click one of the following:

- a label to drill down on the row, column or layer only
- a value to drill down on both the row and the column

**Tip:** To drill up or down levels in a dimension, you can also use the dimension line. Click on a dimension line folder for a dimension that appears in the report and then click on a category.

**Results**

To reset all dimensions, from the **Explore** menu, click **Reset Dimensions**. In Explorer reports, IBM Cognos PowerPlay resets the dimension line to the top level for the current categories and removes filters. PowerPlay does not remove nested categories. In Reporter reports, PowerPlay resets the dimension line to the top level for the current categories and removes filters. The report still contains all the categories that you added.

---

### Drill Up

You can drill up in any hierarchy where you have drilled down. For example, you can drill up to Locations from its child category Americas. Drilling up gives you a broader perspective of your dimension.

In an Explorer report, you can drill up on the summary category.

In a Reporter report, when you drill down on a column IBM Cognos PowerPlay adds its child categories to the right. If you double-click the column again, you drill up and the child categories disappear. However, if you move the column after drilling down, you can no longer drill up by double-clicking. This also applies to drilling down on a row.

You can drill up in alternate paths. If you drill up using the right-click menu, you drill up the path you drilled down. To drill up in an alternate path, click on the arrow and select an alternate parent.

**Procedure**

Where the pointer appears as a plus sign with a caret or up arrow, double-click the category, label, or value. If you double-click a label, you drill up on the row or the column only. If you double-click a value, you drill up on both the row and the column.
Results

When you reach the top of the hierarchy in a report, the pointer changes to a plus sign (+).

To reset all dimensions to the top level, from the Explore menu, click Reset Dimensions. In Explorer reports, PowerPlay resets the dimension line, removes filters, and changes the categories in the report to the top-level categories in the current dimensions. PowerPlay does not remove nested categories. In Reporter reports, PowerPlay resets the dimension line to the top level for the current categories and removes filters. The report still contains all the categories that you added.

Drilling Down and Up on Nested Categories

The same rules that govern drilling down and up in regular crosstabs apply to nested crosstabs. Drilling down on a category in a nested Explorer report replaces the drill category level with the child categories. Drilling down on a category in a nested Reporter report adds the children of that category as new categories at the same level.

Filter Data

You can use the dimension menu to quickly explore and filter data.

When you click on a dimension folder, the dimension menu appears.

![Dimension menu](image)

Figure 10. Dimension menu

The current filter category appears in bold and is separated from its parent and child categories by horizontal lines. A down arrow identifies the parent of the current filter category. When you move your pointer over a parent category, its siblings appear. If a dimension contains more than ten categories, scroll bars appear at the top and bottom of the dimension menu.

You can filter a category that is not in the report but is part of the cube. In an Explorer report, if you filter a category that is in the report, the results are the same as if you had drilled down on that category.

When you filter, the dimension line changes to reflect the filtered categories.

When you filter, whole rows, columns, or layers may change to zeros because you filtered out information for these categories. You can suppress zeros in the report.
**Procedure**

1. Click the dimension folder for the dimension you want to filter.
2. Click the category you want to filter.

**Results**

**Tips**

- To see the siblings of the category you selected, move your pointer over the dimension folder.
- To filter deeper than a single level at a time, use the dimension viewer rather than the dimension line. If you want to filter as you select categories in the dimension viewer, select the category to filter by, and click the Filter button.

---

**Remove Filters**

You can remove all filters in a report or only one filter. When you remove a filter, the dimension line changes.

**Procedure**

Choose how you want to remove filters:

- To remove all filters, from the Explore menu, click Reset Dimensions.
- To change one filter, in the dimension viewer, select a different category in the dimension to which the filter category belongs and click the filter button.
  
  For example, if you filtered to show information only for 2008, select the Years dimension because 2008 belongs to Years.

- To remove filters one level at a time, on the dimension line, click the dimension folder to which the filter category belongs and then select the category immediately above the current filter category.

---

**Search for Data**

You can search for data in either the report or the cube used by the report.

**Related concepts:**

"Wildcards" on page 22

You can use wildcards in a find-in-cube subset definitions or for searching for data.

**Search in a report**

When you search for data in the report, IBM Cognos PowerPlay searches the labels as they appear in the report. If the report author renamed any of the labels from the cube, the search includes only the renamed labels, not the original labels.

**Procedure**

From the Edit menu, click Find.

**Search in a cube**

When you search for data in the cube, you have the option to save the search results as a find-in-cube subset. If you save the search results as a subset, the results are the same as if you created the subset using the dimension viewer toolbox.
Procedure
1. From the Edit menu, click Find.
2. Specify the search settings, including the dimension and name settings on the Cube tab.
3. Click Find All.
4. To save the results as a find-in-cube subset definition, click Save Subset.
   The new subset appears in the subset definitions list in the dimension viewer.
5. Click Close.
Chapter 4. Measures

A measure determines how well a business is operating. Examples of measures include
- a simple summary of available information, such as number of units shipped, revenue, expenses, inventory levels, or quotas
- a calculated value, such as forecast revenue minus actual revenue

The IBM Cognos Transformer modeler defines the order of measures when building the cube. In PowerPlay, a new report uses the first measure in the list of measures. You can select a different measure from the dimension line or dimension viewer.

Most measures apply to all dimensions. However, depending on how the Transformer modeler built the cube, some measures may not apply to the categories you selected for a report. For example, a cube includes measures for revenue, inventory, and head count. While revenue and inventory apply to all dimensions, the head count measure applies only to years and locations.

If you try to use a measure in a location where it does not apply, you see na in the report. The presentation of zeros or constant values may reflect the way that a measure was allocated when the Transformer modeler created the cube. Also, the modeler may have defined missing values to show as zeros.

Change the Measure

By default, a report uses the first measure in the list of measures. You can change measures to compare data using different quantitative values. You add measure to the report using the same techniques as you use for adding categories.

Procedure

On the dimension line, click the Measures folder and select a measure from the list.

Show Multiple Measures as Rows, Columns, or Layers

You can show multiple measures as rows, columns, or layers.

For example, you can nest measures in a report when you need to see multiple measures for a dimension, as shown in the following report.
Procedure

Add additional measures to the row, column, or layer area of the report.

- To add a single measure, drag the measure from the dimension viewer into the report.
- To add all measures, drag the measures folder from the dimension line or dimension viewer into the report.

In Reporter reports, the Measures folder is added to the report beside or below existing categories. Drill down to show all measures.

Related tasks:
- "Add Nested Categories to a Report" on page 7
  You can add nested categories to a report to see another level of information about your business.
- "Format Labels and Values in Crosstabs" on page 78
  You can format labels and values in a crosstab display to make them easier to understand.

Change the Format for a Measure

You can choose the format used to show values for measures.

You can specify a default format for your measures using the Format settings in Preferences. If the IBM Cognos Transformer modeler defined a specific format for values, it takes precedence over your preference settings.

Procedure

1. In the dimension viewer, select the measure.
2. Click the format measure button.
3. On the Format tab, select the format and click OK.

Working with Currency Values

The most common measures represent currency values, such as revenue, product cost, and gross profit. IBM Cognos PowerPlay includes options that you use to show currency values in the most appropriate way. You can

- convert values to a different currency
  When you create reports that will be used in a different region or county, you can convert values to show the most appropriate currency for the report consumer.
- format values

<table>
<thead>
<tr>
<th></th>
<th>2004</th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
<th>Years</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camping Equipment</td>
<td>Product Cost</td>
<td>215,026,298</td>
<td>254,664,345</td>
<td>311,436,026</td>
<td>220,319,251</td>
</tr>
<tr>
<td></td>
<td>Quantity Sold</td>
<td>588,563</td>
<td>890,376</td>
<td>839,156</td>
<td>610,317</td>
</tr>
<tr>
<td></td>
<td>Revenue</td>
<td>333,280,256</td>
<td>493,190,481</td>
<td>500,919,729</td>
<td>353,381,282</td>
</tr>
<tr>
<td></td>
<td>Quantity Sold</td>
<td>158,282</td>
<td>128,793</td>
<td>153,672</td>
<td>118,854</td>
</tr>
<tr>
<td></td>
<td>Revenue</td>
<td>153,842,831</td>
<td>188,280,109</td>
<td>231,372,589</td>
<td>175,748,675</td>
</tr>
</tbody>
</table>

Figure 11. Report with nested measures
You can change the format of values to use a different accounting standard, or to help reports consumers understand the data. For example, you can choose to show the currency symbol so report consumers can accurately compare data in different reports that may not show the same currency.

The following information will help you to understand how PowerPlay determines which currency symbol to use. Both the cube settings defined by the Transformer modeler and the language specified in the Microsoft Windows Regional Settings of the computer where PowerPlay is installed can affect which currency symbol is used by default.

If there is more than one currency symbol defined for a country or region, the currency symbol is determined by the language specified in the Microsoft Windows Regional Settings of the computer where PowerPlay is installed.

When the language specified on the user's system is not associated with the country or region defined in the cube, the currency symbol for the first occurrence of that country or region is used.

If a specific currency is not defined in the cube and you subsequently format the data as money in your PowerPlay report, the currency symbol used is the currency symbol defined in your Microsoft Windows Regional Settings. This can result in misleading results if the values in the cube are, in fact, based on a different currency. To ensure that your report shows the correct currency, ask the IBM Cognos Transformer modeler to define the required currency in the cube, or ensure that the Regional Setting for each PowerPlay user matches the data stored in your cube.

**Note:** Not all measures represent currency values. You can not select an alternate currency or apply currency formatting to a measure that is not a currency value.

**Before you begin**

The Transformer modeler defines the alternate currencies when building the cube. If you need additional currencies, contact your Transformer modeler.

**Procedure**

1. From the **Explore** menu, click **Convert Currency**.
2. In the **Measures** box, select the measures that you want to convert.
3. In the **Currency** box, select an alternate currency.
4. Click **Apply**.
5. To format the currency, click the **Format** button.
6. In the **Number Format** dialog box, specify the format, and click **OK**.
   - If you selected multiple measures that currently use different currencies, formatting is disabled.
7. In the **Currency Conversion** dialog box, click **OK**.
   - **Tip:** To reset a measure to its original currency setting, select the measure in the **Measures** box, click **Default**, and click **Apply**.
Chapter 5. Drill Through

You can drill through from a IBM Cognos PowerPlay report to other reports, cubes, or working files. For example, one cube contains revenue information about all products in the Americas and another cube contains revenue information about all products in Europe. As the product manager for the European office, you use the European cube most often. Occasionally you need to compare revenue in the Americas and Europe, and this is when you drill through from one cube to another.

Your modeler sets up drill-through access for PowerCubes in IBM Cognos Transformer. The modeler also identifies other content, such as PowerPlay reports and cubes for you to drill through to.

Drill Through to PowerPlay

When you want to explore information in another cube, you can either drill through to another Explorer or Reporter report that uses a different cube or drill through to a different cube than the one you are using in your report.

For example, one cube contains the summary sales information about all regions. As vice-president of sales, you explore and analyze the high-level information in that cube. Other cubes contain detailed information about each region. The regional managers work with those cubes. You can drill through from the summary sales information to see the details of how a particular region is doing, perhaps to check that a new manager is having a positive effect.

Drill through to another IBM Cognos PowerPlay report when

- the other report contains data from another cube that you need to analyze and compare to the data in your open report
- you want to link the reports for your current PowerPlay session so that you can explore the data in one report and see the effects in the other report
- When you change the dimension line in one report, the dimension line and data change in the drill-through report when you click the drill through button.
- you are unfamiliar with the structure of data in the other cube
- Since the administrator has set up the report for you, you don't need to start from scratch with unfamiliar data.
- the administrator has performed calculations

Drill through to a cube when

- you want to explore the data in the other cube without a predefined view of the data set up by the administrator
- the administrator has not set up reports for you to drill through to, only cubes

If you drill through to PowerPlay but the dimensions are not filtered in the target cube or report, the dimensions in the report or cube you drilled through to may not be compatible with the dimensions in the report you drilled from. Contact your administrator for more information about the differences in the dimensions and categories.
If you open a report and later drill through to this report from another report, two copies of the same report are open. However, only the copy of the report that you drilled through to is linked.

For example, you open a report called Q4-Sales and a report called 2007-Sales. You drill through from 2007-Sales to Q4-Sales. You now have two copies of the Q4-Sales report open. Only the copy that was opened by drilling through from the 2007-Sales report is linked to 2007-Sales. When you change the dimension line in 2007-Sales and click the Drill Through button, only the copy of Q4-Sales that you drilled through to is updated, unless shared dimensions is turned on.

If you drill through to a time-based partitioned cube that contains data that is categorized differently among the PowerCubes that form the time-based partitioned cube, you may receive data that appears inconsistent.

For example, you drill through to a time-based partitioned cube that contains data on the top ten sales staff in San Francisco for 2008. Dave Mustaine, a sales representative in San Francisco, shows total sales for 2008 of $60,000. When you drill further to isolate Dave Mustaine without a regional context, you see total sales of $72,000 for 2008, a value which is inconsistent with the original total sales reported. Because Dave Mustaine joined the Denver sales office for two months during 2008, his $12,000 in total sales for those months were not returned in the original view which showed Dave Mustaine for San Francisco only. Isolating Dave Mustaine with no context of San Francisco or Denver returns data for both regions for 2008.

Procedure

1. To drill through to a report or cube associated with a measure, ensure that the common measure appears in the report.
   If you add the measure as a row, column, or layer, you must select a context that includes the measure that you want to use for the drill-through. The names of the intersecting categories appear in the lower left of the PowerPlay window to show the current context. If the selected context does not use the common measure, PowerPlay uses the measure shown in the measures folder.

2. Select the cell or category label from which you want to drill through.
   PowerPlay uses the selected cell or label as the basis for the report or cube you are drilling through. For example, if your report shows 2006, 2007, and 2008 in the rows, and the selected cell is 2008, PowerPlay filters the drill-through report to show 2008 data.

3. From the Explore menu, click Drill Through.

4. If the Drill Through dialog box appears, double-click the drill-through target you want to view.
   If the report or cube you need does not appear in the Drill Through dialog box, ensure that the common measure appears in the report. If the common measure is in the report, the name or location of the drill through target may have changed. Contact your administrator to resolve drill through problems. You may need to change the default report location on the Query tab in Preferences.

Results

If you selected a report, PowerPlay opens the target report filtered to match, as much as possible, the context and dimension line of the first report. If you selected a cube, PowerPlay creates a new Explorer report, filtered to match, as much as
possible, the context and dimension line of the first report. In both cases, if no categories match, the target report shows categories in the first two dimensions and uses the first measure in the cube.

After you drill through to a different report or cube, you can go back to the original report, make changes, and then click the drill through button to update the target report. To drill through to a different target from original report, use the Drill Through option on the Explore menu to select a different target.
Chapter 6. Rank and Sort Data in Reports

Ranking helps you compare categories. You can rank categories by their value in a specific row or column. For example, a report outlines revenue for all your products. When you rank this report, IBM Cognos PowerPlay adds a rank category to identify the place each product came in, by revenue.

Sorting arranges categories in ascending or descending order. For example, a report lists all of your salespeople. You sort this report to list the salespeople in alphabetical order.

**Rank Data**

You can rank the categories in the rows or columns of a report. When you rank the rows or columns of a report, each row or column value is assigned an ordinal that shows how it performed in relation to the other rows or columns.

The rank ordinals appear in a new row or column. In Explorer reports, the label and values of the rank category are italicized. The italic formatting is removed when you switch to a Reporter report.

You choose whether the highest or lowest value in a category receives a rank ordinal of 1, and how many of the top or bottom results to view. You can sort or hide the rank category. By default, rank categories are hidden in scatter displays.

You can change the default rank settings in Preferences.

By default, rank categories are automatically regenerated when the report data changes. If you clear the Automatically re-rank setting when defining a rank, you can manually re-rank at any time after changing the report. Using manual re-ranking can save time when working with a large data source because the ranking is not updated with every change to the report.

The following constraints for ranking may apply to your report.

- If you hide categories, they are not ranked.
- If you nest categories, ranked categories do not appear in the chart display.
- You cannot rank the "Other" category when using 80/20 suppression.
- Summary values do not receive rank ordinals in Explorer reports.

**Rank categories using the default settings**

The rank settings in Preferences determines how the category is ranked when you use the rank button.

**Procedure**

1. Select one row or column by which you want to rank and click the rank button.
2. If the categories in a report change, right-click the rank category and click Re-Rank.
Rank categories using custom settings
You can specify custom rank settings instead of using the default settings.

Procedure
1. From the Explore menu, click Rank.
2. Specify the rank settings.
3. Select Automatically Re-Rank to update the ranking when the report changes.
   If you do not select Automatically Re-Rank, to update ranking in a report, right-click the rank category and click Re-Rank.
4. Click OK.

Hide or remove ranking
You can hide a rank category or delete it from the report.

Procedure
Choose whether you want to temporarily hide the rank category or permanently delete it from the report:
- To hide the ranking, right-click the rank column or row and click Hide.
  IBM Cognos PowerPlay hides the rank column or row. To show hidden categories, from the Format menu, click Unhide.
- To delete the ranking, right-click the rank category label and click Delete Rank.

Rank Identical Values
Categories with the same value receive the same rank ordinal. For example, if two categories have the same value and the value is the second highest value in the ranked group, both categories receive a ordinal of 2. In this case the third highest value receives an ordinal of 4.

Rank Nested Data
You can rank the lowest level categories of nested reports. If you add a lower level of nested categories to the rows or columns where a rank category appears, the rank category is removed.

For example, in the following report columns are ranked based on the nested Camping Equipment category.

<table>
<thead>
<tr>
<th>Products</th>
<th>2004</th>
<th>2005</th>
<th>2006</th>
<th>2007</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camping Equipment</td>
<td>313,795,625</td>
<td>403,130,191</td>
<td>500,919,729</td>
<td>353,361,282</td>
</tr>
<tr>
<td>Rank (Camping Equipment)</td>
<td>4</td>
<td>2</td>
<td>1</td>
<td>3</td>
</tr>
<tr>
<td>Golf Equipment</td>
<td>153,642,831</td>
<td>160,260,109</td>
<td>231,372,589</td>
<td>175,740,575</td>
</tr>
<tr>
<td>Mountaineering Equipment</td>
<td>0</td>
<td>107,143,704</td>
<td>161,045,514</td>
<td>141,528,413</td>
</tr>
</tbody>
</table>

Figure 12. Report with columns ranked based on a nested category
Manually Re-Ranking in Reporter Reports

In addition to improving performance when working with a large data set, you may want to use manual re-ranking to retain the original rank ordinals after changing the categories in a report. This ensures that values from a different level are not included in the ranking.

For example, in the following Reporter report, you ranked Years, clearing the Automatically re-rank option in the Rank dialog box. When you drill down on Camping Equipment, the children are not included in the ranking. If you did not clear the Automatically re-rank option when adding the ranking, the children would be ranked at the same level as the product categories, which would not be an accurate representation of the data.

<table>
<thead>
<tr>
<th></th>
<th>2006</th>
<th>2007</th>
<th>Years</th>
<th>Rank (Years)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camping Equipment</td>
<td>500,919,720</td>
<td>352,361,282</td>
<td>1,530,730,027</td>
<td>2</td>
</tr>
<tr>
<td>Cooking Gear</td>
<td>83,916,612</td>
<td>56,317,366</td>
<td>272,983,426</td>
<td>na</td>
</tr>
<tr>
<td>Lanterns</td>
<td>45,438,446</td>
<td>26,043,199</td>
<td>126,938,264</td>
<td>na</td>
</tr>
<tr>
<td>Packs</td>
<td>111,130,289</td>
<td>83,219,058</td>
<td>352,187,273</td>
<td>na</td>
</tr>
<tr>
<td>Sleeping Bags</td>
<td>98,320,445</td>
<td>66,658,534</td>
<td>309,483,561</td>
<td>na</td>
</tr>
<tr>
<td>Tents</td>
<td>167,111,737</td>
<td>114,953,065</td>
<td>529,129,421</td>
<td>na</td>
</tr>
<tr>
<td>Golf Equipment</td>
<td>231,372,880</td>
<td>175,748,576</td>
<td>729,944,204</td>
<td>3</td>
</tr>
<tr>
<td>Mountaineering Equipment</td>
<td>161,046,514</td>
<td>141,528,413</td>
<td>409,715,631</td>
<td>4</td>
</tr>
<tr>
<td>Outdoor Protection</td>
<td>10,359,215</td>
<td>4,473,391</td>
<td>76,002,238</td>
<td>5</td>
</tr>
<tr>
<td>Personal Accessories</td>
<td>594,234,053</td>
<td>443,812,970</td>
<td>1,886,038,235</td>
<td>1</td>
</tr>
</tbody>
</table>

Figure 13. Report showing effect of drill down on ranking

Sort Data

When you sort data, the rows or columns are arranged in ascending or descending order. You can sort

- rows, columns, or layers in alphabetical order
- rows or columns in numerical order

If your report includes nested categories, you can not sort by value. For example, in the following report, the nested category Retailers is sorted alphabetically. You can not sort the rows in this report by value.
By default, sort categories are automatically regenerated when the report data changes. If you clear the automatic sorting setting when defining the sort, you can manually re-sort at any time after changing the report. Using manual re-sorting can save time when working with a large data source because the sorting is not updated with every change to the report.

Hidden categories are not sorted.

### Sort using default settings

The sort settings in Preferences determines how the category is sorted when you use the sort button.

**Procedure**

1. Select one row or column you want to sort and click the sort button on the toolbar.
2. If the categories in a report change, from the Explore menu, click Re-Sort.

### Sort using custom settings

You can specify custom sort settings instead of using the default settings.

**Procedure**

1. From the Explore menu, click Sort.
2. Specify the sort settings. If you do not select Automatically re-sort, to re-sort after a report changes, from the Explore menu, click Re-Sort.
3. 
4. Click OK.
Chapter 7. Highlight Exceptions

You can use two types of exception highlighting to identify information that may need further exploration.

- Automatic exception highlighting quickly shows unusually high and low values in Explorer reports.
- Custom exception highlighting shows a specific range of data. You can create one or more custom exception definitions that can be applied to reports or distributed to others. You can also use a macro to apply a custom exception definition.

For information about creating a macro to highlight exceptions, see the IBM Cognos PowerPlayMacro Reference Guide.

Automatic Exception Highlighting

You can automatically highlight exceptions in your Explorer reports. When you enable this feature, exceptionally low values appear in a red, bold font, and exceptionally high values appear in a green, bold font. You can use the exceptional values as starting points for further investigation.

You can adjust the sensitivity of the automatic exception highlighting. The higher the sensitivity, the more data is highlighted. You can also change the styles used to highlight high and low automatic exceptions.

You can change the default automatic exception sensitivity using the Options preferences.

Automatic exception highlighting is not available if you are in a Reporter report.

If you use automatic exception highlighting frequently, you may want to add the automatic exceptions button to the toolbar.

Related concepts:
- "Customize Toolbars and Buttons" on page 89

You can show, hide, create, delete, and modify toolbars. For example, you can create a toolbar that contains only the buttons you use.

Apply automatic exception highlighting

The automatic exception highlighting setting in Preferences, Options determines default sensitivity for identifying exceptional data.

Procedure

In an Explorer report, from the Explore menu, click Automatic Exceptions, Highlight.

Change automatic exception sensitivity for the active report

You can override the default exception sensitivity for the active report.
Procedure
1. In an Explorer report, from the Explore menu, click Automatic Exceptions, Set Sensitivity.
2. Drag the control bar to specify how exceptional a value has to be for IBM Cognos PowerPlay to highlight it.
3. Click OK.

Modify the automatic exception styles
You can modify the default automatic exception styles. Changes to styles affects all reports.

Procedure
1. From the Format menu, click Styles.
2. Select High Automatic Exceptions or Low Automatic Exceptions.
3. Click Modify and change the style definition.
4. Click OK.

Custom Exception Definitions
A custom exception definition highlights data that falls within value ranges that you specify. After you create the custom definition, you must apply it to highlight exceptional data. If a report uses a custom exception definition, the exception highlighting is updated when you open the report after a cube update.

You can save the custom exception definition to share with other reports or with other users.

When you create a shared custom exception definition, the exception definition is saved to the Ppexcept.ini file and the styles are saved to the Ppstyles.ini file. These files are stored in the installation_location/configuration/powerplay folder.

Create a custom exception definition
You can define up to five value ranges in one custom exception definition, and attach a formatting style to each range. IBM Cognos PowerPlay applies corresponding formatting styles to all data that falls within the defined ranges.

Procedure
1. From the Explore menu, click Custom Exceptions.
2. Specify the custom exception settings. To modify an existing custom exception definition, select the custom exception definition in the Exception Name box, make the changes, and click Add.
3. To save the custom exception definition for use in other reports or to share with other users, select the Shared check box.
4. Click the Add button and click Close.

Delete a custom exception definition
You can delete custom exception definitions.

Procedure
1. Select a report.
2. From the Explore menu, click Custom Exceptions.
3. In the **Exception Name** box, select the custom exception definition.
4. Click **Delete** and click **Yes**.
5. Click **Close**.

**Apply a Custom Exception Definition**

You can apply a custom exception definition to highlight

- exceptional values in a report
  IBM Cognos PowerPlay compares each value in the report to the range of values in the custom exception definition. If a value in the report falls in the range, it is highlighted.

- entire rows or columns that contain exceptional values
  PowerPlay compares the values in a driving category to the range of values in the custom exception definition. If a value in the driving category falls in the range, the entire row or column that contains the value is highlighted.
  If, in a Reporter report, you created a custom exception definition based on a particular category that doesn't apply in an Explorer report, then that category doesn't appear in an Explorer report custom exception definition. For example, if you base a custom exception definition on All Years and then switch to an Explorer report, the All Years parent category doesn't exist in the custom exception definition.

- only values in the rows and columns you selected
  PowerPlay compares the values in the selected rows and columns to the range of values in the custom exception definition. If a value in the selected rows and columns falls in the range, it is highlighted.
  For example, you create a revenue report with products in the rows and months in the columns. You can highlight all negative values in red so you can see which products lost money in which months. Because March is a critical month for selling backpacks, you select the March column as the driving category. If a product lost money in March, the entire product row is highlighted in red.

When you drill down on data after the custom exception definition is applied, data that falls within the specified ranges is highlighted as you drill down and up.

When you apply a custom exception to the entire report, all rows, or all columns, PowerPlay highlights any new data that is added when the cube is refreshed. This is particularly useful for identifying subsets and new categories that are added to the cube when the data is refreshed.

Custom exception definitions are based on the measure being used. If you applied custom exception highlighting and then change the measure, the custom exception highlighting is not visible. However, if you change the measure back to the one that was used with the custom exception definition, the custom exception highlighting is visible again.

Only one custom exception definition can be applied at a time. The one that was applied most recently to the report is the active custom exception definition.

**Before you begin**

You must create a custom definition before you can apply it.
Procedure

1. Select the report, the rows or columns, or the information in the report to which you want to apply the custom exception definition.
   
   You can click a value to select both a row and a column. You can click a label to select either a row or a column.

2. From the Explore menu, click Custom Exceptions.

3. In the Exception name box, select a custom exception definition.

4. Choose where you want to apply the definition.
   • To apply the definition to all the values in the report, click All.
   • To apply the definition to rows or columns, click All Rows or All Columns.
     If you select All Rows or All Columns, you may select a driving category in the Based on Category box. If you apply the custom exception definition to rows, the driving category is a column, and if you apply it to columns, the driving category is a row.
   • To apply the definition to selected information, click Selection.

5. Click Apply and click Close.

Results

Data that meets the criteria specified in the custom exception definition is highlighted. If no data is highlighted, then none of the data fit the specified criteria.

Clear a custom exception definition from data

You can clear data highlighting related to a custom exception definition without deleting the definition.

Procedure

1. From the Explore menu, click Custom Exceptions.

2. In the Exception name box, select a custom exception definition.

3. Click Clear and click Close.

Shared Custom Exception Definitions

To ensure that all IBM Cognos PowerPlay users highlight exceptions in the same way, you can distribute a custom exception definition to other users.

For example, you create a custom exception definition called Year End that shows losses in red and profits in green. Your manager asks you to share the custom exception definition with everyone else in the department. The custom exception definitions are stored in the Ppexcept.ini file, and the styles are stored in the Ppstyles.ini file. Your colleagues can either use your copies of the files, or they can cut and paste the appropriate lines into their copies of the files if they have already created styles and exceptions they want to keep.

Distribute custom exception definitions

IBM Cognos PowerPlay adds custom exception definition information to the Ppexcept.ini and Ppstyles.ini files. To distribute custom exception definitions, you share these files with other users.

Procedure

1. If necessary, create new custom exception definitions.
Ensure the **Shared** check box is selected when you create the custom exception definitions.

2. Locate the Ppexcept.ini and Ppstyles.ini files on your computer.

3. Send the files to other users or put the files in a shared network location.

**Results**

If you create new shared custom exception definitions after you distribute the Ppexcept.ini and Ppstyles.ini files, you must send users updated copies of the files.

**Use shared custom exception definitions**

When you receive files that contain shared custom exception definitions, you can choose to use all shared definitions or only specific shared definitions.

**Procedure**

Choose one of the following options to use the shared custom exception definition.

- To delete your existing definitions and use all definitions in the shared file, replace your existing Ppexcept.ini and Ppstyles.ini files with the shared files.
- To add individual definitions from the shared files to your existing Ppexcept.ini and Ppstyles.ini files, copy definition and style information from the shared .ini files to your .ini files.

The following is an example of a custom exception definition in a ppexcept.ini file.

```
Exception3=Year End, 0, 3, 0, 0,\nException3Range1=Bad News,0..Minimum
Exception3Range2=Good News,Maximum,20000.
Exception3Range3=,0,0.
Exception3Range4=,0,0.
Exception3Range5=,0,0.
```

The following is an example of a style definition in a ppstyles.ini file.

```
[Style -Good News]
numformat=9,0
numformattext=$1,000,000
font=Arial, 700, 1, 10, 0, 0, 0, 0, 0, 0, 0, 0, 128, 0
pattern=0, 0, 0, 0, 255, 255, 255
alignment=0, 1, 2
```

**Results**

The shared definitions are now available for use in new and existing reports.
Chapter 8. Calculations

IBM Cognos PowerPlay includes basic and advanced calculation options to support data analysis. In addition to basic calculations, such as determining the average of a row or column, you can create calculations to show standard financial ratios such as the liquidity ratio or debt ratio. The predefined forecasting methods offer another valuable way to analyze data in some situations.

The IBM Cognos Transformer modeler can add calculated categories to a cube to eliminate the need for report authors to recreate common calculations in different reports. Calculated categories appear in the dimension viewer with a calculator icon.

The following differences exist for calculations in Explorer versus Reporter reports:
- In Explorer, you can perform all calculations except minimum, maximum and average.
- In Reporter, you can perform all calculations except forecast.
- In Reporter, you can perform group calculations when you want to repeat the same calculation for many categories.
- In Reporter, you can specify a precedence order for calculations.
- In Explorer, the position of the calculation is automatically determined based on the operands. You cannot change the location of the calculation.
- In Reporter, the calculation is inserted after the pointer position. You can delete or move categories that are part of the calculation, or the calculation, without affecting the calculation.
- In Explorer, the label and values of the calculation are italicized. The italic formatting is removed when you switch to a Reporter report.
- In Explorer, if you drill down to the lowest level, a single category appears. You cannot perform calculations on this category.

For both Explorer and Reporter reports, you cannot perform calculations on the ‘Other’ category (80/20 suppression).

The following size limits apply to values you specify when using calculations:
- maximum 1.7976931348623158e+308
- minimum 2.2250738585072014e-308

After adding calculations to reports, you may want to format the labels and values. For example, you can change the default label.

View Information About Calculations

You can view the categories or formula that makes up a calculation in a report.

Procedure

Right-click any cell in the calculation and click Explain.
Calculate Percentage Growth

Percentage growth is the percentage change between two categories or measures.

**Procedure**
1. Select the two rows or columns that you want to find the percentage growth for.
2. From the **Calculate** menu, click **Percent Growth**.
3. In the **Order** box, select the order of the calculation.
4. In the **Label** box, type a name for the category and click **OK**.

Calculate the Percentage of a Total

You can convert values to a percentage of the total to analyze income statements and other financial statements.

You cannot perform a percentage calculation on a rank category.

**Procedure**
1. If the report does not have a total, select the categories to sum. From the **Calculate** menu, click **Add**.
2. Select the categories to convert to a percentage of a total.
   - **Tip**: To add child categories that show as a percentage of their parent category, click the **Share of** button in the dimension viewer toolbox (Reporter mode).
3. From the **Calculate** menu, click **Percent of Base**.
4. In the **Select a Base Value** box, select the total to base the percentage on.
   - If you select a row in the report, this box lists all columns; if you select a column, it lists all rows.
5. In the **Label** box, type a name for the category.
6. Click **OK**.

Calculate an Average

To help plan future or current events, you can calculate an average.

For example, you can calculate the average revenue of a product line for the first quarter of the year and compare it to average revenue for the second quarter of the same year.

**Procedure**
1. In a Reporter report, select one or more categories.
2. From the **Calculate** menu, click **Average**.
3. Do one of the following:
   - In the **Label** box, type a name for the category.
   - If you want to do more than one calculation of the same type at a time, select the **Group** check box and select a category in the **Operand** box.
     - You can do more than one calculation only if you selected two or more categories.
4. Click **OK**.
Calculate a Running Total

You can include a column or row in your report that shows a running total. The running total can be expressed as a numeric or percentage value. In Reporter reports, you can calculate a running total for more than one category.

For example, you create a report that shows the revenue in each of the past four quarters. The running total shows the total revenue by the end of each quarter. If you add a running total as a percentage of the total sold, you can see the percentage of the full year’s sales achieved by the end of the quarter.

You can delete the category representing the base value from the report after creating the cumulative percent of base value.

In Explorer mode, you can select only one category on which to perform a running total as a numeric or cumulative percent of base value.

You cannot perform a cumulative percent of base calculation on a rank category.

Note: In Reporter mode, if the selected category includes an existing calculation the calculation value is included in the running total.

Calculating running totals as numeric values

You can show running totals as a numeric values.

Procedure
1. Select one or more categories.
2. From the Calculate menu, click Accumulate.

Calculating runnings total as percentage values

You can show running totals as percentage values

Procedure
1. Select one or more categories.
2. From the Calculate menu, click Cumulative Percent of Base.
3. In the Select a Base Value box, select the total that you want to base the percentage on.
   - If you select a row in the report, this box lists all columns; if you select a column, it lists all rows.
4. In the Label box, type a name for the category and click OK.

Rollup Calculations

By rolling up calculations, you can more easily analyze groups of categories within the same dimension. When you apply the rollup function, you create a new calculation that applies the rollup function (either add, minimum, maximum, or weighted average) defined for the measure used by the selected categories.

For example, the Course Pro line includes products from more than one category in Golf Equipment. You create a report that includes only the Course Pro products and then add a rollup calculation to determine the overall profit margin for each quarter.
When you drill up or drill down on one of the selected categories included in the rollup calculation, the calculation is recalculated. You can perform rollup calculations on subsets.

**Procedure**

1. Select the categories to include in the rollup calculation.
   - Selected categories must be from the same dimension and must all be of the same display type (that is, all rows, all columns, or all layers).
   - If the selected categories involve more than one measure, the function defined for the first measure is used in the rollup calculation.

2. From the Calculate menu, click Rollup.

3. In the Label box, type a name for the category and click OK.

**Perform Calculations on Nested Categories**

When you perform a calculation on nested categories, the new calculation is added at the same level as the last selected category. If you move the calculation to a different level in a report, the result will be different compared to the original location. To ensure that a calculation on nested categories produces the expected results even if you move the calculated category to a different location, include the parent category in the calculation.

For example, the following report nests the separate product groups under Outdoor Protection. The report also shows actual and target revenue. To create a calculation to show the revenue variance, select Outdoor Protection, then Revenue and Sales Target. By selecting the categories in this order, you ensure that the calculation is specific to Outdoor Protection products. The calculation appears at the same level as the parent, Outdoor Protection.
When you perform calculations on nested categories that have been added using short bar drop zones, you must follow two rules or your results may be incorrect:

- You must select the parent of the category you want to use in the calculation. If you use categories that are nested in two different parents, you must select both parents.
- If the last category you select is a parent, your calculation appears at the same level as the parent. Conversely, if the last category you select is a child, your calculation appears nested beside that child.

### Perform Calculations When You Add Categories

In Reporter reports, if you know that you want to perform certain calculations on certain data, you can have IBM Cognos PowerPlay generate the calculations when you add categories to the report. PowerPlay adds the calculations as new categories.

You can show
- the selected category individually and the calculation
- the sum of selected categories
- the average of selected categories
- the selected categories as a percentage of their parent categories

#### Procedure

1. Open a Reporter report.
2. In the dimension viewer, select two or more categories.
3. In the dimension viewer toolbox, do one of the following:
   - To show the selected categories individually in addition to the calculation, click the **Each** button.
   - To show the sum of the selected categories as a new category, click the **Sum of** button.
   - To show the average of the selected categories as a new category, click the **Average** button.
   - To show the selected categories as a percentage of their parent categories, click the **Share of** button.
4. Click the **Add as Row**, **Add as Column**, or **Add as Layer** toolbox button to add the categories to your report.

---

**Figure 16. Report with actual-planned calculation**

When you perform calculations on nested categories that have been added using short bar drop zones, you must follow two rules or your results may be incorrect:

- You must select the parent of the category you want to use in the calculation. If you use categories that are nested in two different parents, you must select both parents.
- If the last category you select is a parent, your calculation appears at the same level as the parent. Conversely, if the last category you select is a child, your calculation appears nested beside that child.
Add Calculated Categories to a Report

The IBM Cognos Transformer modeler may have already added pre-set calculations to the cube. These calculations appear as categories in the dimension viewer and are identified by the calculate icon.

For example, you want to see the growth in revenue between the current quarter of 2008 and the same quarter of 2007 for each product. You create an Explorer report with Quarter to Date (QTD) in the rows and Products in the columns. The QTD Growth is a calculated category included in the Great Outdoors cube. QTD Growth appears in the report when you select the Calculated Categories command from the View menu.

Before you begin

You can add calculated categories to Explorer or Reporter reports.

Procedure

1. In the dimension viewer, select a calculated category.
   If calculated categories do not appear in the dimension viewer, from the View menu, click Calculated Categories. Repeat to hide the calculated categories again. In an Explorer report, the calculated category is removed from the report.
2. Do one of the following:
   * In a Reporter report, click the Add as Rows, Add as Columns, or Add as Layers button.
In an Explorer report, click the **Replace Rows**, **Replace Columns**, or **Replace Layers** button. If you want calculated categories in only the rows or only the columns, you must hide the calculated categories that you don't want to see. From the **Format** menu, click **Hide**.

**Perform Group Calculations**

In Reporter reports, you can perform group calculations when you want to repeat the same calculation for many categories. Group calculations can use the following operations: addition, subtraction, multiplication, division, percentages, maximum or minimum value, average, and exponentiate.

For example, you want to calculate a projected 10% increase in sales for each product line for the coming year. Instead of performing the calculation on each product line separately, you select all product lines and use the group option when you create the multiplication calculation. The grouped calculation adds a projected sales category to the report for each product line.

You can also perform group calculations on subsets.

**Procedure**

1. In a Reporter report, select the categories that you want to include in the calculation.
2. From the **Calculate** menu, select an operation.
3. Select the **Group** check box.
4. If required, do any of the following:
   - In the **Order** box, select the order of the calculation.
   - In the **Number** box, type a value to use in the group calculation.
   - In the **Category** box, select the category to use in the group calculation.
5. Click **OK**.

**Setting Calculation Precedence**

When calculations in the rows and columns of a report intersect, IBM Cognos PowerPlay performs the calculations in the following order:

- business functions (accumulate, percent of base, and cumulative percent of base)
- basic functions (percent, average, minimum, maximum)
- division or multiplication
- addition or subtraction

If both calculations have the same precedence (for example, if they are both business functions), the row calculation takes precedence. You can override the order of precedence, such as performing addition before multiplication.

**Procedure**

1. In a Reporter report, right-click the selected calculation that you want to grant precedence to.
2. Click **Override Precedence**.

When you click a business function that intersects another calculation, the **Override Precedence** command is disabled. Business functions take precedence over all other calculations.
You can make predictions about the future performance of your business based on historic data using one of three time series forecasting methods: Trend, Growth, or Autoregression.

Before creating a forecast, you must include the time period as either rows or columns in your crosstab.

Forecasts do not include any rankings that were included in the crosstab.

If you convert the currency in your crosstab, IBM Cognos PowerPlay creates the forecast on the currency-converted values.

If you nest multiple levels of time in your crosstab, PowerPlay produces the forecast only at the highest level of time.

For example, in this report, you nest quarters within years for revenue and then choose Forecast from the Calculate menu, PowerPlay generates the forecast only at the years level.

<table>
<thead>
<tr>
<th></th>
<th>2006 Q 1</th>
<th>2006 Q 2</th>
<th>2006 Q 3</th>
<th>2006 Q 4</th>
<th>2006 Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>2006</td>
<td>73,137,515</td>
<td>63,008,019</td>
<td>79,688,200</td>
<td>76,731,992</td>
<td>312,565,726</td>
</tr>
<tr>
<td>2007</td>
<td>99,805,945</td>
<td>88,949,474</td>
<td>35,145,159</td>
<td>0</td>
<td>234,000,575</td>
</tr>
<tr>
<td>Forecast 2008</td>
<td>298,297,965</td>
<td>264,016,302</td>
<td>627,965,834</td>
<td>119,033,256</td>
<td></td>
</tr>
<tr>
<td>Years</td>
<td>978,309,972</td>
<td>860,794,525</td>
<td>2,144,579,336</td>
<td>370,057,985</td>
<td></td>
</tr>
</tbody>
</table>

To generate your forecast at the quarters level, delete the years level before you generate the forecast.

**TERMS OF USE**

The forecasting methods used in the Forecasting Function are based on the statistical analysis of historical information drawn from underlying data sources. The accuracy of the forecasted values is subject to many variables. These variables include the accuracy of the underlying historical data and external events which could affect the validity of that underlying historical data for forecasting purposes. The Forecasting Function is to be used only as a guide of the future values for the measures being forecasted and is not intended to be used as the basis for complex financial or business decisions.
IBM makes no representations as to the accuracy of the actual future values and does not guarantee any specific results. You use the Forecasting Function and the data it generates at your own risk. The Forecasting Function may contain errors or produce inaccurate calculations. You accept the Forecasting Function and the documentation "AS IS". IN NO EVENT SHALL IBM BE LIABLE FOR DAMAGES OF ANY KIND INCLUDING, WITHOUT LIMITATION, DIRECT, INDIRECT, INCIDENTAL, PUNITIVE OR CONSEQUENTIAL DAMAGES, RESULTING FROM THE USE OF THE FORECASTING FUNCTION OR THE INTERPRETATION OF THE DATA RESULTING THEREFROM.

**Trend (Linear or Straight Line)**

The trend forecasting method is based on the linear regression technique of time series forecasting. Trend forecasting gives the best forecasting reliability when the driving factors of your business affect your measures in a linear fashion. For example, when your historic revenue increases or decreases at a constant rate, you are seeing a linear effect.

A multiline plot of historic data should look linear or close to linear for greatest reliability. For example, if you are forecasting revenue for the next two quarters based on revenue for the past four quarters, and if the multiline plot of past quarterly revenue is linear or close to linear, then the Trend method gives you the best forecasting reliability.

Use the Trend forecasting method when only two data values represent two time periods in your historic data.

**Growth (Curved or Curved Line)**

The Growth forecasting method is based on the exponential regression technique of time series forecasting. Growth forecasting gives you the best forecasting reliability when the driving factors of your business affect your measures exponentially. For example, when your historic revenue increases or decreases at an increasingly higher rate, you are seeing an exponential effect.

A multi-line plot of historic data should look exponential for best accuracy. For example, if your revenues are growing exponentially due to the introduction of a best selling product, then Growth forecasting provide a more reliable forecast than the Trend method. Similarly, if you hire two additional sales representatives for your company, you can use Growth forecasting to determine which product line has the greatest growth potential to allocate your new resources effectively.

**Autoregression (Seasonal)**

The Autoregression forecasting method is based on the auto-correlational approach to time series forecasting. Autoregression forecasting detects the linear, non-linear, and seasonal fluctuations in historic data and projects these trends into the future. Autoregression provides the best forecasting reliability when the driving factors underlying your business are affected by seasonal fluctuations.

A multi-line plot of time and revenue shows up-and-down fluctuations that may reflect seasonal variations. For example, if your revenues are growing exponentially due to the introduction of a best selling product, but sales of that product are also seasonal, then Autoregression forecasting provides a more reliable forecast than the Growth method.
Use the Autoregression method when historic data represents a large number of time periods (for example, more than 24 monthly periods) and when seasonal variations may occur in it.

Create a Forecast

You can make predictions about the future performance of your business based on past data by using one of these time series forecasting methods: Trend, Growth, or Autoregression.

Your time dimension must appear as either rows or columns.

Before you begin

You must be using Explorer mode to create forecast calculations.

Procedure

1. From the Calculate menu, click Forecast.
2. Select the forecasting method you require.
3. In the Enter the Forecast Horizon box, type the number of time periods to forecast.
   The number of time periods to forecast cannot exceed the number of periods in your data.
4. Click OK.

Financial Ratios

You can calculate financial ratios, such as liquidity ratios, debt ratios, and profitability ratios, to determine how well a company is doing. For example, you create a report that shows cost, the average inventory, and the liquidity of inventory for each product.

The following table shows common financial ratios and the corresponding formula. Because each calculation can contain only one operand, you must use two calculations to determine some of the financial ratios.

Table 2. Financial ratios

<table>
<thead>
<tr>
<th>Ratio type</th>
<th>Ratio</th>
</tr>
</thead>
<tbody>
<tr>
<td>Liquidity</td>
<td>Current ratio</td>
</tr>
<tr>
<td></td>
<td>Current Assets / Current Liabilities</td>
</tr>
<tr>
<td></td>
<td>Average collection period</td>
</tr>
<tr>
<td></td>
<td>((Receivables * Number of Days in Year) / Annual Credit Sales)</td>
</tr>
<tr>
<td></td>
<td>Accounts receivable turnover</td>
</tr>
<tr>
<td></td>
<td>(Net Sales / Average Receivables)</td>
</tr>
<tr>
<td></td>
<td>Liquidity of inventories</td>
</tr>
<tr>
<td></td>
<td>(Cost of Goods Sold / Average Inventory)</td>
</tr>
<tr>
<td>Ratio type</td>
<td>Ratio</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Debt</td>
<td>Debt/equity&lt;br&gt;(Total Debt / Total Equity)</td>
</tr>
<tr>
<td>Profitability</td>
<td>Gross profit margin percentage&lt;br&gt;((Sales - Cost of Goods Sold) / Sales)&lt;br&gt;Net profit margin percentage&lt;br&gt;(Net Income / Sales)&lt;br&gt;Pre-tax margin percentage&lt;br&gt;(Pre-tax Income / Sales)&lt;br&gt;Return on equity percentage&lt;br&gt;((Net Income - Preferred Dividends) / Average Total Common Shareholders Equity)&lt;br&gt;Earnings per share&lt;br&gt;((Net Income - Preferred Dividends) / Number of Common shares Outstanding)</td>
</tr>
<tr>
<td>Other</td>
<td>Average revenue per employee&lt;br&gt;(Total Sales / Total Number of Employees)&lt;br&gt;Average revenue per salesperson&lt;br&gt;(Total Sales / Number of Salespeople)&lt;br&gt;Average profit per salesperson&lt;br&gt;(Profit / Number of Salespeople)</td>
</tr>
</tbody>
</table>
Chapter 9. Graphical Displays

Graphical displays communicate comparisons, relationships, and trends. They emphasize and clarify numbers. To choose the appropriate type of display, first define the purpose of the report, and then identify the most effective display to suit that purpose. For example, you can use a multiline display to show trends.

For some display types, the data for each row appears in a separate display. A box appears at the bottom of the report window that shows the name of the current row. If the report includes more than one row, this box includes an option to select a different row. Click on the box to see a list of the available rows.

Compare Variables, Show Variance, or Track Performance

You can compare variables, show variance, or track performance by using a simple bar, stacked bar, or 3-D bar display.

Use a
- simple bar display to show change over a specific time period and to compare and contrast two or more variables in one time period
- stacked bar display to show the parts that contribute to the total and to compare change over time
- 3-D bar display to show relationships between several variables and to analyze large quantities of information that are difficult to interpret otherwise

Procedure

From the Explore menu, click Change Display, and click the Simple Bar, Stacked Bar, or 3-D Bar button.

Compare Two Measures

You can compare two measures by using a correlation or scatter display. At least two measures must be in the cube. By default, IBM Cognos PowerPlay uses the first two measures in the cube for the display. You can change the measures being compared. Use a
- correlation display to show the first measure in the cube as bars and the second measure as lines
- scatter display to show the first measure in the Y-axis and the second measure in the X-axis

The measures do not have to correspond to the nested measures in your crosstab. Changing correlation and scatter measures affects the measures in your crosstab report.
To compare two or more measures, you can also add them as nested categories to a crosstab report.

If the cube you are using contains only one measure, the correlation and scatter display buttons are not available since these displays require at least two measures in the cube.

**Procedure**

1. From the **Explore** menu, click **Change Display**, and click **Correlation** or **Scatter**.
   A Graph box appears at the bottom of the report window. The Graph box shows the names of all the rows that are available for the display. Use the Graph box to select a different row to examine.
2. Select the measures you want to compare from the **Measures** dimension menu. Two measures folders are available because the correlation and scatter displays use two measures.

---

### Show the Mix in a Pie or Clustered Bar Display

Pie charts and clustered bar displays are useful for showing the relative relationship between categories.

You can use
- a pie display to show the relationship of the parts to the whole, with percentages translated into proportional sections
- a clustered bar display to show groups of related information, to compare the groups over a period of time

To see two pie displays that show different mixes of information, create two reports and tile the report windows. The same report can’t contain two pie displays that show different mixes.

**Procedure**

1. From the **Explore** menu, click **Change Display**.
2. Click **Pie** or **Clustered Bar**.

---

### Find a Trend in a Display

A line display or a stacked bar display is useful for showing trends in data.

You can use
- a single line display to show how a single variable is performing over time
- a multiline display for time series analysis, to compare trends and cycles, and to infer relationships between variables
- a stacked bar display to show the parts that contribute to the total and compare change over time

**Procedure**

From the **Explore** menu, click **Change Display**, and click **Single Line**, **Multiline**, or **Stacked Bar**.
Show More than One Type of Display

You can look at information from the same report in different ways by showing more than one display.

When you select a category in one display, that category is also selected in the other displays. For example, you can see the effect in the other displays when you select a category in a crosstab.

When you drill down to lower levels of information in one display, you also see these levels of information in the other displays.

For example, to track how your products sold in relation to each other, and also in relation to the previous year, use a pie display to compare product sales for 2008, and a clustered bar display to compare 2008 sales to 2007 sales.

You can arrange multiple displays by resizing, moving, and tiling them.

Procedure

From the Insert menu, click Display, and click the display to add.

Results

The report window shows the additional display.

Tip: To add another display quickly, Ctrl+click the toolbar button for that display. For example, Ctrl+click the pie button to add a pie display.

In a single report with multiline and crosstab displays, you can use a multiline display to track trends over time and still see summary columns in the crosstab display. Show both displays and click the multiline display. From the Format menu, click Display Options. On the Display tab, clear the Show Summary Columns check box and click OK.

To remove a display, right-click the display and click Delete Display.

Show Multiple Charts in One Display

In Explorer reports, you can show nested data in a series of single charts, or switch to nested charts and view all of the nested data in one multiple chart display.

Nested charts are summary row based charts. If a measure is the lowest level category in your row, the results of the first measure are shown when you select nested charts in a vertical simple bar, single line, or correlation chart. The row legend layout shows all measure labels.

You cannot nest a horizontal simple bar chart or a scatter chart.

Procedure

1. In an Explorer report, select a chart display.
2. From the Explore menu, click Nested Charts.
Results

The report window shows the multiple displays.

View Large Amounts of Data

When you work with large amounts of data, it can be difficult to see all the data in one graphical display. Too many columns can clutter the display, making accurate interpretation difficult. To resolve this problem, a scroll bar appears by default in any display that has more than eight columns. You can change this default at any time.

For example, you prepare a IBM Cognos PowerPlay report using the simple bar display that includes all the tents in your product line. Because there are several tents, your display appears cluttered. You want to adjust the number of columns that appear on each page so the data is more easily understood.

You can also define whether to show summary categories for nested crosstabs.

You cannot add scroll bars to a pie display, 3-D bar display, or a scatter display.

Procedure

1. Select the chart display that you want to change.
2. From the Format menu, click Display Options, and click the Scrolling tab.
3. In the Scrolling Options box, select the Use a Scrollbar If Required check box.
   Tip: If you want to see all the data in one display, clear the Use a Scrollbar if Required check box. If you reach the maximum limit of bars (500 rows or columns) in PowerPlay, an error message appears warning that the data will be truncated.
4. In the Maximum Columns Displayed box, specify the number of columns that you want to appear in the display.
   You can show between 5 and 52 columns on one page of a display.
5. In the Maximum Columns Printed box, specify the number of columns that you want to print.
6. Click OK.

Show Values in a Display

You can show values on or above the bars in simple or clustered bar displays, and above the markers in single line displays. You can also show values on or above the bars of correlation displays, and next to the slices of a pie chart.

You can change the default show values option for new reports using the display options in preferences.

Related tasks:
“Setting Preferences” on page 87
There are many options you can set to customize the settings for all new reports. For example, you can specify the default directories to use for reports and cubes.

Showing values in simple or clustered bar displays

You can show values in simple or clustered bar displays.
Procedure
1. Select a simple or clustered bar display.
2. From the Format menu, click Display Options.
3. On the Display tab, in the Values on Bars box, select the Show check box.
4. Click OK.

Results
If the bars in a bar display appear as zeros, ensure that the scale of the grid is accurate. For example, if the largest value in the report is 37 million and you set the maximum value in the manual scale of the primary axis to 1 billion, the scale dwarfs the actual values and causes the bars to appear as zeros.

Showing values in single line displays
You can show values in single line displays.

Procedure
1. Select the single line display.
2. From the Format menu, click Display Options.
3. On the Display tab, in the Values Above Markers box, select the Show check box.
4. Click OK.

Add Statistical Lines to a Chart Display
You can add up to three statistical lines to a chart display. Statistical lines can show minimum, maximum, mean, standard deviation, logarithmic regression, and linear regression values. You can also add custom statistical lines to a display.

For example, the regression line is useful for fitting a curve to a set of data with a logarithmic relationship. A logarithmic regression line is not displayed if a row contains all negative numbers.

When you select linear regression line, IBM Cognos PowerPlay displays a straight line calculated using the least-squares method. The equation used is: \( y = mx + b \), where \( m \) = slope, and \( b \) is the y-axis intercept (the value of \( y \) when \( x \) is zero).

When you select logarithmic regression line, PowerPlay displays a logarithmic curve calculated using the least-squares method. The equation used is: \( y = a\ln(x) + b \), where \( a \) and \( b \) are constants, and \( \ln \) is the natural logarithm function.

When you add statistical lines to a display, the statistical lines for a single selected row are shown.

You cannot add statistical lines to pie displays, 3-D bar displays, and stacked bar displays.

Procedure
1. Select the chart display to which you want to add statistical lines.
2. From the Format menu, click Display Options, and click the Statistics tab.
3. In the Line box, select the lines you want to show.
4. In the Settings box, change the format of the lines you want to add.
5. Click OK.

Results

Tip: To show the statistical lines for a specific row, select the row in the Legend.

Formatting Graphical Displays

Formatting displays improves the overall appearance of a display and makes it easier to read.

For example, you can

- change the patterns and colors
- change angles and rotations
- show or hide gridlines
- scale axes

Change the Colors and Patterns Settings

For graphical displays, you can change the palette settings to specify the order that colors or patterns are used in a display. The palette settings ensure that the same order of color or pattern is used in all graphical displays. For example, the first bar in a bar chart will be blue, the second red, the third yellow, and so on based on the way the colors are ordered in the palette settings. This predictable pattern is useful when comparing different views of the same data. The same color represents the same category in each view.

The palette settings also associate a color with a pattern. When you chose to show colors as patterns, which is useful when you don’t have access to a color printer, each color is replaced by an associated pattern. You can change settings to associate a pattern with a different color.

To change the color and pattern settings for all reports, change palette settings in preferences.

Procedure

1. From the Format menu, click Palette.
2. To change the order of a color or pattern, or to associate a color with a different pattern, drag a color or pattern to a new location.
3. To customize a color, select the color and then click Customize Colors.
4. To use patterns instead of colors in displays, select Show colors as patterns.
5. Click OK.

Results

The new settings are applied to the current report.

Apply a Background to a Display

To apply a background to a display, you can use

- pictures, such as a company logo
- colors and patterns
- blend options, so that there is a gradual change from the start to the end of the background color
The background applies to the current display, and is not applied when you change display type.

You can also apply a background to an entire report.

**Before you begin**

You cannot apply a background to a pie or crosstab display.

**Procedure**
1. Select a display.
2. From the Format menu, click Display Options.
3. Click the Background tab.
4. Specify the background settings. There is a 126-character limit (including backslashes and underscores) for the location and file name of the picture used in the background.
5. Click OK.

**Arrange Displays**

If you are viewing more than one display at the same time, you can arrange the position of the displays. By default, displays are tiled for best fit.

To tile separate reports, from the Windows menu click Tile Horizontally or Tile Vertically.

If the report includes a single crosstab display, the crosstab will always appear at the bottom.

**Procedure**
1. From the View menu, click Page Width or Page Layout.
2. Tile and move displays until they appear as you want.
   - To arrange displays within the same report, from the Format menu, click Tile Displays and select an option.
   - To move a display, click to select the display, and grab the hash marks border.

**Change the Angle of a Display**

You can change the angle of a display. For example, you can angle a simple bar display to show bars on a vertical axis instead of the horizontal axis.

You can set the default angle for new displays using the display option in Preferences.

**Changing the angle of pie displays**

You can change the angle of a pie display.

**Procedure**
1. From the Format menu, click Display Options.
2. On the Display tab, select the Show check box.
3. In the Angle box, type the number of degrees of tilt.
4. From the Thickness box, select a thickness for the pie and click OK.
Changing bar charts from vertical to horizontal layout
You can change the orientation of bar charts.

Procedure
1. From the Format menu, click Display Options.
2. Click the Display tab.
3. Select the Horizontal Orientation check box.
   You can also change the angle and thickness of the shadow.
4. Click OK.

Rotate a Display
You can rotate pie and 3-D displays. This option is useful for emphasizing specific data or to improve the appearance of a display that includes many categories.

You can set the default rotation for new pie and 3-D bar displays using the Display options in Preferences.

Rotating pie displays
You can rotate pie displays.

Procedure
1. From the Format menu, click Display Options.
2. Select the Clockwise check box.
3. In the Angle box, type a number for the start of the first pie slice, and click OK.

Rotating 3-D bar displays
You can rotate 3-D bar displays.

Procedure
1. From the Format menu, click Display Options.
2. Click the Display tab.
3. Click the 3-D View Tool.
4. Click the arrows in the 3-D View Tool box until the display appears at the desired angle, and click Close.
5. Click OK.

Change Markers in a Display
You can change the size and shape of the markers used in some types of graphical displays.

Markers are optional in line, multiline, and correlation displays.

Procedure
1. From the Format menu, click Display Options.
2. On the Display tab, under the Marker box, select the Show check box.
3. Select a shape to use as the marker.
4. To set the size of the marker, type a number in the Size box.
5. Click OK.
Change the Appearance of Pie Displays

You can change several display settings for pie displays.

For example, you can label pie slices with either values or category names. If you label pie slices with values, the legend contains only category names. If you label the pie slices with category names, the legend contains both category names and values.

Tip: To highlight a category in a pie display, click a pie slice.

Procedure
1. From the Format menu, click Display Options.
2. Modify the displays options.
3. Click OK.

Highlight a Line in a Multiline Display

You can make one or more lines stand out in a multiline display by applying a bold format. For example, in a report showing revenue for product lines over the past three years, the Years line is represented with a bold line.

Procedure
1. Select the line that you want to apply a bold format.
2. From the Explore menu, click Change Display and click the crosstab display.
3. From the Format menu, click Categories, and click Labels and Values.
4. On the Font tab, click Bold and click OK.
5. From the Explore menu, click Change Display and click the multiline display.

Hide Report Gridlines

You can hide or show some or all of the gridlines in a crosstab report.

Procedure
1. If you have more than one crosstab in your report, click the crosstab you want to change.
2. From the Format menu, click Display Options and click the General tab.
3. Select the Gridline Options you want to use.
   The report must include nested categories to use Show Row Detail Gridlines and Show Column Detail Gridlines.
4. Click OK.

Scale an Axis

You can scale the axis for a display by setting the highest and lowest values to appear in the axis. If you are using a correlation or scatter display, you can scale a secondary axis.

By default, the scale shows the full range of values in the selected data, positive and negative. You can change the default axis scaling properties for all reports in Preferences. If you change your axis settings, you may not be able to see some of your data or statistical lines.
**Procedure**

1. Select a display.
2. From the **Format** menu, click **Display Options**.
3. Click the **Primary Axis** tab.
   - This tab is not available for crosstab and pie displays.
4. Select the **Manual** check box.
   - To return to automatic axis scaling at a later time, clear the **Manual** check box.
5. Set the primary axis properties you want to use.
6. Do one of the following:
   - If you are using a correlation or scatter display and you want to scale the secondary axis, click **Apply** and continue with the next step.
   - Click **OK** to complete axis scaling.
7. On the **Secondary Axis** tab, select the **Manual** check box.
   - **Tip:** To scale the secondary axis using the same settings as the primary axis, select the **Use Primary Axis Settings** check box.
   - To return to automatic axis scaling at a later time, clear the **Manual** check box.
8. Set the secondary axis properties you want to use.
9. Click **OK**.

**Make Bars Transparent in a 3-D Bar Display**

You can make bars transparent in 3-D bar displays. Transparency is useful when you want to see the background lines in the display.

**Procedure**

1. Select the bars that you want to make transparent.
2. From the right-click menu, click **Transparency**, **Make Bars Transparent**.

**Results**

To remove transparency at a later time, use the **Transparency**, **Make Bars Opaque** or **Remove all Transparency** options.
Chapter 10. Formatting Reports

Formatting reports improves the overall appearance of a report and makes it easier to understand the data. Some of the ways you can format a report include:
- changing the layout
- adding titles, headers, and footers
- applying colors, patterns, and backgrounds
- formatting labels and values

Choose a Layout for a Crosstab Report

You can choose different layout styles for nested crosstab reports.
- In standard layout, nested levels appear beside one another for rows and below one another for columns.
- In indented layout, nested rows are distinguished by indentation. The report does not include a summary level for the nested categories.
- In indented 2 layout, nested rows are distinguished by indentation. Summary labels are in bold type and the lowest level is underlined. The Indented 2 Layout is available for only Explorer reports.

Procedure

From the Format menu, click Crosstab Layout and click a layout.

Show Short or Long Names for Dimensions and Categories

If the cube modeler defined both short and long dimension or category names in the cube, you can choose the format you want to show in the dimension line and dimension viewer of your report. You can set short or long names for each individual dimension.

For example, a dimension has the long name "2008 Products" and the short name "08 Prods". You choose to show the short dimension name in your report.

To show short names when you open the report in IBM Cognos PowerPlay Studio, you must set all dimensions to show short names before publishing the report.

Procedure

Right-click the dimension or category in the dimension line and clear or select Long Names.

Create and Apply a Style to Data

You can create and apply styles to emphasize key information and for use in a custom exception definition.

For example, you want to create different styles to apply to higher sales values and lower sales values. You can create a style for the higher values that shows them in green, and another style for the lower values that shows them in red.
Creating and editing styles

You must create a custom style before you apply it to data in the report.

Procedure
1. From the Format menu, click Styles.
2. Choose whether to create a new style or edit an existing style:
   - To create a style, type a name for the new style and click Add.
   - To edit an existing style, select the style name and click Modify.
3. Select the style settings.
4. If you want to make the style available for others to use, select Shared.
   The Shared check box is not available for the default styles, Hidden and Default.
5. Click OK.

Results

The new style is available for use in the current and other reports. You can share styles that you create with other IBM Cognos PowerPlay users.

Related concepts:
“Shared Custom Exception Definitions” on page 50
To ensure that all IBM Cognos PowerPlay users highlight exceptions in the same way, you can distribute a custom exception definition to other users.

Applying styles

After you create a custom style you can apply it to data in the report.

Procedure
1. Select the information to format.
2. From the Format menu, click Styles.
3. In the Style Name box, select the style and click OK.

Removing styles

You can remove a custom style by applying the default style.

Procedure
1. Select the information that has a style applied.
2. From the Format menu, click Styles.
3. In the Style Name box, select Default style and click OK.

Apply a Background Pattern and Color to an Entire Report

To enhance the appearance of a report, you can apply patterns and colors to the report background.

You can apply a different background to each display in a multi-display report.

Procedure
1. If the report includes more than one display, use Ctrl+click and select each display.
2. From the Format menu, click Display Background.
3. Select the foreground and background colors, and pattern.
   To set the background pattern and color as a default for the active report, click Set As Default.
4. Click OK.

Add a Title, Header, or Footer

You can make reports more meaningful by adding descriptive titles, headers, and footers.

Within these elements, you can include text, picture objects, and variables. Add
• titles that describe the contents of the report.
• headers and footers that contain important information such as the cube name, the report name, the names of dimensions, and page numbers. The cube name is the name specified in IBM Cognos Transformer, which may be different from the cube file name.

You can also make standardized reports by adding default titles, headers, and footers that apply to all new reports.

For example, you create a standard header that appears above the report title. The header contains the report creation date and the total number of pages in the report, and you create a standard footer that includes the report file name and the cube file name.

You also add the name of the report, your company logo, and the current row label to the report title. The text in the title that shows the current row label changes depending on what is selected in the report.

Procedure
1. From the Format menu, click Title, Header, and Footer, and click Title, Header, or Footer.
2. Type and format the text.
3. To insert a variable, click the Insert button, and do one of the following:
   • To insert the report file name, date or time, click Report.
   • To insert the cube name, date, time or description, click MDC.
   • To insert a variable such as the current default measure, row, column, date or time, click Variable. When you insert a date or time variable, the Date and Time dialog box appears. Use it to select a format for dates and times in the title. Most variables are dynamic and change depending on the state of the current report.
   • To insert page numbers, the current and total number of displays for the current layer, or the current and total number of layers for the current report, click Numbers.
   • To insert an individual dimension name or the names on the dimension line, click Dimension.
   • To insert a picture, click Picture Object. Click the image you want to insert, click Open, and then move or resize the picture as required.
4. Click OK.
5. If you cannot see the header or the footer, switch the page view or display arrangement.
• From the View menu, click Page Layout or Page Width.
• From the Format menu, click Tile Displays, Best Fit.

Formatting Labels and Values
Formatting labels and values makes your report easier to read. For example, you can rename labels if they are too long. You can also format labels to include currency or other symbols that clarify data.

Rename Labels
You can change the names of labels for rows, columns, or layers in reports. For example, you create a calculated category by adding three categories. You change the default label of the calculated category to a name that describes what the category represents.

Procedure
1. Select the row, column, or layer.
2. From the Edit menu, click Rename Label.
   Tip: F2 is the keyboard shortcut to rename a label.
3. Type the new name and click OK.
   Tip: To restore the default label, click Reset.

Format Labels and Values in Crosstabs
You can format labels and values in a crosstab display to make them easier to understand.

You can determine the font, alignment, and background pattern for labels and values. You can also choose from several preset value formats, including currency signs, commas, and percentage signs. You can apply formats to labels only, values only, or both labels and values. You can also choose default settings for your report.

If you want to place parentheses around negative values, in the Windows Control Panel, set the format for negative values in Regional Settings.

You can set the default font, format, alignment, and patterns for all reports in Preferences.

Several rules determine the number format that is applied in a crosstab cell. You cannot format an individual cell in the crosstab. However, you can format an entire column or an entire row, or both an entire column and an entire row. You can select all rows and all columns or just a subset of them.

Generally, the last format applied overrides the previous format. However, this is not always the case. If you format a column and a cell in the column contains a row format where the number of decimals is greater than the number of decimals in the new column format, the new number format is not applied. The same rule applies if you format a row where there was a previous column format. The exception to this rule is if you are apply a percent format. Percent formats generally always take precedence.
**Procedure**

1. Select the rows and columns that you want to format.

2. From the **Format** menu, click **Categories**, and then choose the format option:
   - To format the labels in your selection, click **Labels Only**.
   - To format the values in your selection, click **Values Only**.
   - To format your entire selection, click **Labels and Values**.
   - To select default settings for your report, click **Default**.
   
   This does not apply to previously formatted categories.

3. Specify the **Font**, **Format**, **Alignment**, and **Patterns** settings.
   
   There is no **Format** tab when you click **Labels Only**.

4. If you want to enable word wrapping for row labels that exceed the cell width, from the **Format** menu, click **Display Options**. In the **Word wrap** box, select **Standard layout** or **Indented layout** and click **OK**. Increase the height of the row label cell(s) to accommodate the additional lines of the label.
   
   You can apply word wrap independently to either Standard or Indented crosstab layout.
   
   Column labels always word wrap.

5. Click **OK**.

**Results**

If you increase the size of a font in a crosstab display, or change to a font that is larger than the one you are using, IBM Cognos PowerPlay automatically adjusts the cell width and height to accommodate the new font size. However, if you apply an exception definition that increases the font size or uses a larger font, PowerPlay does not automatically adjust to the new size.

If you add underlining, you may need to increase the size of the row or column for the underlining to be visible.

**Format Labels in Graphical Displays**

You format labels to determine whether word wrapping is applied or text is truncated. You can also specify whether to autofit labels along one or both axes.

You can set the default display options for new reports using the Display preferences.

You cannot format labels using the following procedure for a pie display.

**Procedure**

1. Select a display.

2. From the **Format** menu, click **Display Options** and click the **Titles** tab.
   
   Depending on the display type, you can change labels for row axes, column axes, and one or two measure axes.

3. Do one of the following:
   
   • To set the layout of labels, select the appropriate option button in the **Bar Labels** box.
     
     The name of the box changes depending on the type of display.
   
   • To size labels to fit automatically within the bar or measure axis, select the appropriate **Autofit Labels** check box.
To give the labels a group name, type a name in the appropriate box.
To change the font, style, size, effects, and color, click Font.

4. Click OK.

Related tasks:
“Setting Preferences” on page 87
There are many options you can set to customize the settings for all new reports.
For example, you can specify the default directories to use for reports and cubes.

Change Summary Labels
You can change the text and font of the labels for the summary rows or columns in a nested crosstab report.

For example, you prepared IBM Cognos PowerPlay reports that contain year-to-date earnings for each of your company's mutual funds. You want to add the fund name to the summary label.

Procedure
1. Open your Explorer report, and click the crosstab you want to change.
2. From the Format menu, click Display Options, and click the Totals tab.
3. To rename a label, select Use row summary label or Use column summary label and type the new label.
4. Select other label settings.
5. Click OK.

Show Data as Relative Values
By default, measures appear as the actual values from the data source. To make it easier to compare the relative contribution of values in Explorer reports, you can show values as a percentage of totals. For example, you are working with a report that shows products as columns and regions as rows. To show the sales contribution of each product by region, you change the display to show values as a percentage of the row total.

The options for values changes depending on the type of display you are using. The names % of Row Total, % of Row Subtotal, % of Column Total, and % of Column Subtotal change depending on the display. For example, in a pie display, the % of Column Subtotal command is named % of Slice Subtotal.

Procedure
1. In an Explorer report, from the Explore menu, click Show Values As.
2. Do one of the following:
   • To show the actual numbers, click Value.
   • To show how each value in a row contributed to the total for the row, click % of Row Total.
   • To show how each value in a row contributed to the subtotal for the row, click % of Row Subtotal.
     The report must include nested columns to show values as a percent of row subtotal.
   • To show how each value in a column contributed to the total for the column, click % of Column Total.
   • To show how each value in a column contributed to the subtotal for the column, click % of Column Subtotal.
The report must include nested rows to show values as a percent of column subtotal.

- To show how each value in a layer contributed to the total for the layer, click % of Layer Total.
- To show how each value in the report contributed to the total for the whole report, click % of Grand Total.

The report must include layers to show values as a percent of grand total.

**Results**

**Tip:** To show data as a percentage of the total in a Reporter report, from the Calculate menu, click Percent of Base.

**Show Blank Cells For Zero and Missing Values**

You can format the measures in your report to show blank cells for the following values in crosstab displays:

- zero values
- divisions by zero
- missing values

For example, you prepared an IBM Cognos PowerPlay report that outlines the five-year return for all your mutual funds. Because some funds are only three years old, there is no data for the first two years. This missing data appears as zeros, which incorrectly implies a zero return for these funds. You change these values to blanks.

Zero and missing values appear as blanks in only crosstab displays. In all other displays, zero values appear as n/a unless specified otherwise by your administrator.

**Procedure**

1. In the dimension viewer, click the measures you want to format.
2. From the toolbox, click the Format Measures button.
3. On the Blank tab, select the Show As Blank behavior you want to use in the report.
4. Click OK.
Chapter 11. Distributing Reports

After you create a report, you can distribute it to others. You can
- save the report in PDF format
- publish the report to IBM Cognos Connection
- print the report
- attach the report to an email message
- export a report to a different file format

Save Reports in PDF Format

You can save reports in PDF format. A PDF file is useful for distributing standard reports to people who do not have IBM Cognos PowerPlay installed on their computer.

**Procedure**
1. Open the report.
2. From the **File** menu, click **Save As**.
3. In the **Save As Type** box, select **PDF File (*.pdf)**.
4. Click **Options** and select **Save and Rows and Layers** settings.
   - Rows and layers that are suppressed or hidden cannot be selected for saving with the PDF.
5. Click **OK** and click **Save**.

Publish Reports to IBM Cognos Connection

When you work with a remote package as your data source you can publish IBM Cognos PowerPlay reports to IBM Cognos Connection. When you publish a report, you can specify run options, such as enabling prompting to provide report consumers with filtering options and specifying details for the PDF format output.

Each time you open and change an existing remote report you must republish to update the report in IBM Cognos Connection. When you republish the report you have the option to update the existing report or create a new report. To avoid having out-of-date reports with duplicate report names, to change the location of a report, use the move option for the report entry in IBM Cognos Connection. If you use the **Publish a new report** option in PowerPlay Client to chose a different location, and use the same report name, you will have reports with the same name in more than one location.

**Before you begin**

To work with reports in IBM Cognos Connection, users must have read and traverse permissions for the folder that contains the report, and execute permission to run a report.

**Publishing new reports**

When you use a remote package as a data source, you can publish reports to IBM Cognos Connection.
Procedure
1. Create a report based on a remote package.
2. From the File menu, click Publish.
3. On the Publish Report page, specify the name, description and run options for the report, and then click Next.
   A description or screen tip can provide valuable information for some types of reports. For example, you create a report based on a package that uses data source connections to more than one PowerCube. When you publish the report, specify the PowerCube connection name in the description or screen tip so report consumers know what connection to select when they open the report.
4. On the Save As page, select the location for the report, and then click OK.

Results
IBM Cognos PowerPlay publishes the report to IBM Cognos Connection.

Work with previously published reports
When you work with existing remote reports, you can update the existing report or create a new report.

Procedure
1. Open an existing remote report.
2. Update the report, and then from the File menu, click Publish.
   • To update the existing report, click OK.
   • To create a new report, select Publish a New Report, specify the name, description and run options for the new report, and then click Next. On the Save As page, select the location for the report, and then click OK.

Print Reports
You can print an entire report, or parts of a report. For example, if a report contains large amounts of data, you can choose to print only selected portions of the report.

Before you begin
Before printing reports that include a legend, position the legend so it does not cover your data.

Procedure
1. From the File menu, click Print.
2. In the Print dialog box, do the following:
   • To show colors in displays as patterns when printing in black and white, select Colors as patterns.
   • To show the report on one page, select Fit to Page.
   • To specify the maximum number of pages to print, type a number in the Threshold box.
3. Click Options.
4. On the Print tab, do the following:
   • In the Print box, click the part of the report that you want to print.
In the **Selected display printing options** box, select the report properties that you want to print. Depending on the option you selected in the **Print** box, some report properties are not available.

5. If you clicked **Page Layout View** or **Selected Display(s)** in the **Print** box, click the **Rows and Layers** tab, and specify the rows and layers that you want to print.

   Rows and layers that are suppressed or hidden do not appear in the **Rows and Layers** boxes and can't be selected for printing.

6. Click **OK**.

---

**Attach Reports to Email**

You can send a report as an attachment to an email message to users who have access to the cube on which the report is based.

**Procedure**

From the **File** menu, click **Send**.

**Results**

The report appears as an attachment in your default email program.

---

**Export a Report to a Different File Format**

Another way to integrate IBM Cognos PowerPlay with other application environments is to export your PowerPlay reports to other formats. You can export a PowerPlay report in the following formats.

- Delimited ASCII text file
- Microsoft Excel
- PDF

When you export a report in delimited ASCII or Microsoft Excel format, the top of the text file or the first few rows of the Microsoft Excel worksheet show the date and time of export, the report file name, the name of the associated cube, and the report type (Explorer or Reporter). The folder names in the dimension line and the data appear below this information.

If your PowerPlay report includes layers, a separate Microsoft Excel worksheet is created for each layer.

When you export a report in delimited ASCII or Microsoft Excel format, you can export only the level of data you see in the report.

**Procedure**

1. From the **File** menu, click **Save As**.
2. Select a folder and type a name for the file.
3. In the **Save As Type** box, click the file format, and click **OK**.
**Delimited ASCII Text Files**

Delimited text format is one of the most popular export formats, because you can use the file as an import source in many applications. IBM Cognos PowerPlay uses the following format conversions when creating the .asc file.

*Table 3. Conversion formats for ASCII files*

<table>
<thead>
<tr>
<th>Format</th>
<th>Conversion Details</th>
</tr>
</thead>
</table>
| Numeric data    | The decimal symbol for the locale is used, even if the format or pattern of the number contains an explicit decimal that differs from the locale.  
The digit grouping symbol (the symbol used to group large numbers such as thousands in the US locale) is not used in the CSV export.  
The negative sign symbol but not the format of the locale is used. This may also be different than the explicit format used for that number. The negative symbol is always leading.  
For example, for a German locale of DE_DE, a number that was formatted as "(765 000.45)" is exported to CSV format as "-765000,45". |
| Currency data   | Currency values follow the same rules as numbers. The currency symbol is not exported.  
For example, if the locale is EN_US, and the format of the number in a PowerPlay report is "$123,456.00", then PowerPlay exports "123456.00". |
| Character data  | In some products, you can optionally allow quotes to be put around the text. This technique ensures that a text field containing the list separator (such as a comma) is not interpreted as multiple fields in the exported file. |
| Date and time data | Dates are exported in ISO format, `YYYY-MM-DD`  
Time is exported as ISO format, `hh:mm:ss`. The hour value (`hh`) uses the 24-hour clock.  
In PowerPlay, the date is defined in the Transformer model and is exported as text. |
Chapter 12. Customizing PowerPlay

You can customize IBM Cognos PowerPlay so that it suits your everyday reporting needs. For example, you can set preferences to specify whether to create new reports as Reporter or Explorer reports by default.

You can also customize menus, toolbars, and toolbar buttons to organize them in a way that helps you work effectively. For example, you can create a custom toolbar that includes the buttons you use most frequently. You can distribute custom menus and toolbars to other users. For example, you can load menus that contain only the commands that your department uses.

Setting Preferences

There are many options you can set to customize the settings for all new reports. For example, you can specify the default directories to use for reports and cubes.

Procedure

From the File menu, click Preferences.

Customize Menus

You can create your own menus and add the commands you need. You can restore all menus to the original settings at any time.

You can distribute customized menus and toolbars to other IBM Cognos PowerPlay users.

Procedure

1. From the Tools menu, click Customize.
2. Click the Menus tab.

   A list of menu commands appears in the Available Commands box. The Menu Layout box shows the current menu structure.
3. You can do any of the following.

   Table 4. Menu customization options

<table>
<thead>
<tr>
<th>Goal</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add menus, submenus, menu separators, or menu commands</td>
<td>Drag what you want to add from the Available Commands box to the Menu Layout box.</td>
</tr>
<tr>
<td>Show only those menu commands found on a specific menu</td>
<td>In the Category box, click the name of the menu. For example, click File to show only those commands found on the File menu.</td>
</tr>
<tr>
<td>Rearrange menu commands</td>
<td>In the Menu Layout box, drag menu commands from one menu to another.</td>
</tr>
<tr>
<td>Goal</td>
<td>Action</td>
</tr>
<tr>
<td>------</td>
<td>--------</td>
</tr>
<tr>
<td>Delete a menu or menu command</td>
<td>In the <strong>Menu Layout</strong> box, click the menu or command and click <strong>Remove</strong>.</td>
</tr>
<tr>
<td>Change the name of a menu command</td>
<td>In the <strong>Menu Layout</strong> box, click the menu command. Under <strong>Item Properties</strong>, in the <strong>Name</strong> box, type a new name.</td>
</tr>
<tr>
<td>Change the shortcut key combination of a menu command</td>
<td>In the <strong>Menu Layout</strong> box, click the menu command. Under <strong>Item Properties</strong>, in the <strong>Shortcut</strong> box, enter a new combination of keys. If a combination of keys is currently assigned to another menu command, a message appears in the message pane that the shortcut is in use.</td>
</tr>
<tr>
<td>Create a menu accelerator key</td>
<td>In the <strong>Menu Layout</strong> box, click the menu command. Under <strong>Item Properties</strong>, in the <strong>Name</strong> box, type an ampersand (&amp;) and the name of the menu command. For example, &amp;New makes N the accelerator key.</td>
</tr>
</tbody>
</table>

4. Click **OK**.

**Results**

To reset the menus to the default settings on the **Menus** tab, click **Reset**.

**Related tasks:**

[Distribute Custom Menus and Toolbars](page_91) on page 91

You can distribute custom menus and toolbars to other users.

**Set Up a Launch Menu Command**

You can add a launch command to any menu to run an application. For example, if you frequently copy and paste reports into a different application for presentations, you can create a launch item that automatically copies the report to the clipboard and launches the presentation application. After the application opens you can paste the report into the presentation.

**Procedure**

1. From the **Tools** menu, click **Customize**.
2. Click the **Menus** tab.
   - To edit an existing launch menu command, click the command in the **Menu Layout** box.
3. Click **New**.
   - The **New Launch Item** dialog box appears.
4. Select the options for the launch item.
5. Click **OK**.
Customize Toolbars and Buttons

You can show, hide, create, delete, and modify toolbars. For example, you can create a toolbar that contains only the buttons you use.

You can distribute customized menus and toolbars to other IBM Cognos PowerPlay users.

Related tasks:
“Distribute Custom Menus and Toolbars” on page 91
You can distribute custom menus and toolbars to other users.

Show or Hide Toolbars

You can show or hide toolbars so that you see only what you need.

Procedure
1. From the Tools menu, click Customize.
2. Click the Toolbars tab.
3. Select the check box beside each toolbar that you want to appear.
   Tip: To remove a toolbar from the Available Toolbars box, click the toolbar name and click Remove.
4. If you want to show tooltips for each toolbar, select Show Tooltips.
5. Click OK.

Results
To reset the toolbars on the Toolbars tab, click Reset.

Create a Custom Toolbar

You can create a custom toolbar that contains only the tools you need.

Procedure
1. From the Tools menu, click Customize.
2. On the Toolbars tab, click New.
3. In the Toolbar Name box, type a name for the toolbar.
4. In the Initial Location box, type a default location for the toolbar and click OK.

Results
The name of the new toolbar appears in the Available Toolbars box. You can now add buttons to the new toolbar.

Customize Toolbar Buttons

You can change the buttons on a default toolbar or add buttons to a custom toolbar. You can also remove buttons from any toolbar.

For example, you are in charge of imports for a governmental department. You regularly distribute reports to offices in Great Britain, which requires that you convert your reports so that they use British pounds. You want to customize your toolbar by creating and adding a Currency button.
Procedure

1. From the Tools menu, click Customize.
2. Click the Toolbar Buttons tab.
3. Drag the buttons you want to add from the Available Buttons box to a toolbar.
   
   Tips
   • To learn what a button does, select its name in the Available Buttons box, then look under Button Description.
   • To change the selection of buttons, use the Category box. For example, click File to show only those buttons found on the File toolbar.
   • To add a space between buttons, add a separator button. This button is listed under the Miscellaneous category.
4. Drag the buttons you want to remove off an existing toolbar.
5. Click OK.
   
   Tip: To return to the original settings, click Reset on the Toolbars tab.

Set Up a Launch Button

You can add up to 64 launch buttons to a custom toolbar. You can configure each button to run a different program.

For example, you are the manager of a government department. You keep the data source files for your reports in Microsoft Excel spreadsheets. While reviewing your reports, you want to look at your data source files. You customize your toolbar to run Microsoft Excel directly from IBM Cognos PowerPlay Client.

Procedure

1. From the Tools menu, click Customize.
2. On the Toolbar Buttons tab, in the Category box, click Miscellaneous.
3. Click Toolbar Launch Button, and drag it to a toolbar.
4. Click OK to close the Customize dialog box.
5. Click the new launch button.
6. In the New Launch Item dialog box, in the Name box, type a name for the launch button.
7. In the Description box, type a brief description of what the button does.
   The tooltip appears when you pause the pointer over the button.
8. In the Command box, browse to the location of the program.
9. In the Parameters box, type any parameters you want to add to the program.
10. If you want to minimize the current window when you run the program, select the Minimize Application Before Launching check box.
11. In the Image box, click the image you want to appear on the new launch button.
12. In the Path box, browse to the location of the button image.
13. Click OK.

Results

The launch button is now configured. If you want to change the settings of a launch button, ensure the Customize dialog box is closed, and Ctrl+click the launch button and then make changes in the Modify Launch Item dialog box.
Distribute Custom Menus and Toolbars

You can distribute custom menus and toolbars to other users.

For example, you are the director of a government department that oversees transportation policy. You worked closely with your systems analyst to build customized menus and toolbars that suit your departmental needs. You want to distribute these menus and toolbars to others in your department.

Custom toolbar settings are stored in the tbinfo.ini file, and custom menu settings are stored in the menuinfo.mnu file in the following location:

C:\Documents and Settings\user_ID\Application Data\IBM Cognos\c10dotn\PwrPlay

**Procedure**

1. Place a copy of the files that contain the settings for the custom toolbars and menus in a location that users can access.
2. From the Tools menu, click Customize.
3. Click Load.
4. Browse to the location of the tbinfo.ini file or the menuinfo.mnu file to be imported.
5. Click OK.

**Results**

The custom menus or toolbars appear.

Customize the Dimension Viewer Toolbox

You can customize the buttons that appear in the dimension viewer toolbox.

For example, you can show the three buttons that you use most often. You can also choose to position the toolbox on the left, right, top, or bottom of the pane.

The following toolbox buttons are available for only Explorer reports:

*Table 5. Toolbox buttons for Explorer reports*

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Replace the rows with the selected categories.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Replace the columns with the selected categories.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Replace the layers with the selected categories.</td>
</tr>
</tbody>
</table>

The following toolbox buttons are available for only Reporter reports:
### Table 6. Toolbox buttons for Reporter reports

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="icon" /></td>
<td>Add the selected categories as rows.</td>
</tr>
<tr>
<td><img src="image2" alt="icon" /></td>
<td>Add the selected categories as columns.</td>
</tr>
<tr>
<td><img src="image3" alt="icon" /></td>
<td>Add the selected categories as layers.</td>
</tr>
<tr>
<td><img src="image4" alt="icon" /></td>
<td>Show the average of the selected categories in a new category.</td>
</tr>
<tr>
<td><img src="image5" alt="icon" /></td>
<td>Show the values of the selected categories as a percentage of their higher-level category.</td>
</tr>
<tr>
<td><img src="image6" alt="icon" /></td>
<td>Show the sum of the selected categories in a new category.</td>
</tr>
<tr>
<td><img src="image7" alt="icon" /></td>
<td>Add categories at the next level down from the selected category.</td>
</tr>
<tr>
<td><img src="image8" alt="icon" /></td>
<td>Add all categories at the lowest level from the selected category.</td>
</tr>
<tr>
<td><img src="image9" alt="icon" /></td>
<td>Show the selected categories as new individual categories in the report.</td>
</tr>
<tr>
<td><img src="image10" alt="icon" /></td>
<td>Show the intersection between two categories.</td>
</tr>
<tr>
<td><img src="image11" alt="icon" /></td>
<td>Preserve parent/child relationship when nesting levels from a dimension.</td>
</tr>
<tr>
<td><img src="image12" alt="icon" /></td>
<td>Open the Advanced Subset dialog box where you can create an advanced subset definition.</td>
</tr>
<tr>
<td><img src="image13" alt="icon" /></td>
<td>Open the Parentage dialog box where you can create a level subset definition.</td>
</tr>
</tbody>
</table>

The following toolbox buttons are available for both Explorer and Reporter reports:

### Table 7. Toolbox buttons for Reporter and Explorer reports

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image14" alt="icon" /></td>
<td>Filter data using the selected category.</td>
</tr>
<tr>
<td><img src="image15" alt="icon" /></td>
<td>Switch between short and long versions of the category names.</td>
</tr>
</tbody>
</table>
Table 7. Toolbox buttons for Reporter and Explorer reports (continued)

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Image]</td>
<td>Open the <strong>Number Format</strong> dialog box, where you can format the measures in your report.</td>
</tr>
<tr>
<td>![Image]</td>
<td>Open the <strong>Find In Cube</strong> dialog box where you can create a find-in-cube subset definition.</td>
</tr>
</tbody>
</table>

**Procedure**

1. Right-click the toolbox and click **Customize**.
2. Do one the following:
   - To add a new button, click it in the **Available Toolbar Buttons** box, and click **Add**.
   - To remove a button, click it in the **Current Toolbar Buttons** box, and click **Remove**.
   - To reset the toolbox to the default settings, click **Reset**.
3. If you want to change the order of the buttons, click an enabled button, and click the **Move Up** or **Move Down** button until the button is positioned where you want.
4. If you want to add a space before a button in the toolbox, click an enabled button, and then add a **Separator** button.
5. Click **OK**.
6. To chance the location of the toolbox, right-click the toolbox and click **Location**.
7. Click one of the four docking positions.
Chapter 13. Working Offline

You can continue to work with IBM Cognos PowerPlay even when you are not connected to the original cube or the network on which the cube is stored.

You can prepare a report containing a subset of the cube data and save the data for this report as a sub-cube (.mdc). When you save only the information used to create the report, you are limited to using the dimensions that were saved.

When you are finished working offline, you can automatically update the sub-cube with data from the original cube.

Turn Off Sub-Cube Refresh

Sub-cubes that you create automatically refresh by default. To work offline, you must turn off the automatic refresh option. This setting applies to all sub-cubes.

Procedure
1. From the File menu, click Preferences.
2. Click the Options tab.
3. Clear the Refresh Sub-Cubes check box.
4. Click OK.

Save a Sub-Cube

You can work offline with a IBM Cognos PowerPlay report by saving it as a sub-cube.

This option is useful if you cannot obtain a copy of the original cube, if the original cube is very large and includes more data than you need for your offline work, or if the original cube is secured by a namespace.

Your PowerPlay administrator must enable save as sub-cube before you can create a sub-cube based on a remote package. Contact your administrator if the save as .mdc option is not available.

You cannot save a sub-cube filtered on a dimension other than date if the cube you are using is a time-based partitioned (or member) cube. If you try to do so, you receive the following message, "The dimension line of the sub-cube is invalid (subcube)."

Procedure
1. Prepare the report by drilling down or drilling up to the level of information you need.
2. From the File menu, click Save As.
3. In the Save As Type box, select PowerPlay Cube (*.mdc).

Set a Report to Use a Sub-Cube

Once you save the report and the sub-cube, you must open the report using the sub-cube, and then save the report.
This sets the report to always access the sub-cube rather than the original cube. You only have to set a report to use a sub-cube once.

**Procedure**
1. From the File menu, click **Open**.
2. Select the **Prompt for Cube** check box.
3. Locate and select the report.
4. Click **Open**.
5. In the **Access** box, click **Local**.
6. Locate and select the sub-cube.
7. Click **Open**.
8. From the File menu, click **Save** to set the report to use the sub-cube.

**Results**
When you open the report in another IBM Cognos PowerPlay session, the report automatically connects to the sub-cube.

If you want the report to access the original cube or another cube, follow the above procedures and select the original cube or another cube.

---

**Automatically Refresh a Sub-Cube**

When you reconnect to the network on which the original cube is stored, you can set IBM Cognos PowerPlay to automatically refresh the sub-cube the next time you open the report. When you want to work offline, you can turn off this option.

**Procedure**
1. Close the report or sub-cube that you want to refresh.
2. From the File menu, click **Preferences**.
3. Click the **Options** tab.
4. Select the **Refresh sub-cubes** check box.
5. Open the sub-cube or a report based on the sub-cube.
   - If the original cube is a secure cube, you may be prompted for authentication information depending on the type of security specified for the cube.

**Results**

The sub-cube is updated with new information from the original cube.

If you see the word *error* in a category of a report, either this category has been removed from the cube or you connected to the wrong cube and the categories don't match.
Chapter 14. Command-line Options

You can use command-line options to

- start IBM Cognos PowerPlay without showing the title screen
- create a new Explorer report using a specific cube
- create a new Reporter report using a specific cube
- create a new report using a specific cube
- open a specific report

You run commands from the bin folder of your PowerPlay installation. All of the examples in this chapter assume you have navigated to the bin folder before entering the command. If you used the default installation, the path to the bin folder is C:\Program Files\IBM\Cognos\c10\bin.

The syntax is

PWRPLAY.EXE
[/nologo]
[/e=name.mdc]
[/r=name.mdc]
[mdc_file_name]
[report_name]
/remote=package_searchpath [/timeout=timeout_value]

Command-line syntax is not case-sensitive.

You can combine command-line options. For example, the following command starts PowerPlay, opens a new Explorer report based on the Inventory cube (inventory.mdc), opens a new Reporter report based on the Accounts cube (accts.mdc), opens a report called Year-End, and bypasses the title screen:

PWRPLAY.EXE /e=inventory.mdc /r=accts.mdc year-end.ppx
/nologo

No Title Screen

The /nologo option starts IBM Cognos PowerPlay without showing the title screen or Welcome dialog box.

For example, the following command starts PowerPlay, but bypasses the title screen:

PWRPLAY.EXE /nologo

Explorer Report

The /e=name.mdc option opens a new Explorer report.

The following command starts IBM Cognos PowerPlay and opens a new Explorer report using the Inventory cube (inventory.mdc) in the c:\reports folder:

PWRPLAY.EXE /e=C:\reports\inventory.mdc
**Reporter Report**

The `/r=name.mdc` command opens a new Reporter report.

The following command starts IBM Cognos PowerPlay and opens a new Reporter report using the Inventory cube (inventry.mdc) in the c:\reports folder:

```
PWRPLAY.EXE /r=C:\reports\inventory.mdc
```

---

**Cube Name**

The `mdc_file_name` option opens a new report based on a specified cube.

The following command starts IBM Cognos PowerPlay and opens the Inventory cube from the c:\reports folder:

```
PWRPLAY.EXE C:\reports\inventory.mdc
```

---

**Remote Package Name**

The `/remote=package [/timeout=timeout_value]` command opens a remote package where

- `/remote` indicates that you want to open a remote package
- `package` specifies the package search path or store ID. You can obtain the search path or store ID from the package properties in IBM Cognos Connection.
- `/timeout=` specifies a connection timeout in seconds

This entry is optional.

For example, the following command starts IBM Cognos PowerPlay and opens the Great Outdoors package, using the package search path, with a timeout of 60 seconds:

```
PWRPLAY.EXE /remote="/content/package[@name='Great Outdoors']" /timeout=60
```

---

**Report Name**

The `report_name` option opens the specified report.

The following command starts IBM Cognos PowerPlay and opens the Year-End report in the c:\reports folder:

```
PWRPLAY.EXE C:\reports\year-end.ppx
```
Chapter 15. Specifications

This table lists the specifications for IBM Cognos PowerPlay attributes, such as minimum and maximum values.

Table 8. Specifications for PowerPlay attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Restrictions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bars in a display (without scrolling)</td>
<td>Maximum: 500</td>
</tr>
<tr>
<td>Bitmap size</td>
<td>Limited only by available memory</td>
</tr>
<tr>
<td>Custom color settings (minimum-maximum)</td>
<td>Red, green, blue: 0-255 H u e: 0-40 S aturation: 0-80 Luminosity: 0-240</td>
</tr>
<tr>
<td>Largest allowed negative number</td>
<td>Defined in the cube</td>
</tr>
<tr>
<td>Largest allowed positive number</td>
<td>Defined in the cube</td>
</tr>
<tr>
<td>Margins for the page</td>
<td>Determined by the page setup settings in PowerPlay</td>
</tr>
<tr>
<td>Number of categories in a report (rows, columns, or layers)</td>
<td>The limit for the number of categories is 6,442,450,940. While this is possible, depending on your computer's memory, you may find that 100,000 is a more reasonable limit.</td>
</tr>
<tr>
<td>Number of characters for the location and filename of the picture added to the background of a display</td>
<td>Maximum: 126</td>
</tr>
<tr>
<td>Number of characters in a category label</td>
<td>Maximum: 255</td>
</tr>
<tr>
<td>Number of colors available</td>
<td>Limited by the number of colors supported by your monitor or printer</td>
</tr>
<tr>
<td>Number of digits in an operand (add, subtract, multiply, divide, percent, maximum, minimum, average, exponentiate)</td>
<td>Maximum: 11</td>
</tr>
<tr>
<td>Number of dimensions in the dimension line</td>
<td>Maximum: 255</td>
</tr>
<tr>
<td>Number of displays in a report</td>
<td>Limited only by available memory</td>
</tr>
<tr>
<td>Number of files in the recent file list</td>
<td>Maximum: 9</td>
</tr>
<tr>
<td>Attribute</td>
<td>Restrictions</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Number of fonts per report</td>
<td>Limited by available memory and by the number of fonts supported on your system</td>
</tr>
<tr>
<td>Number of open reports</td>
<td>Limited only by available memory</td>
</tr>
<tr>
<td>Number of nested category levels</td>
<td>Limited only by available memory</td>
</tr>
<tr>
<td>Number of toolbars</td>
<td>Maximum: 20</td>
</tr>
<tr>
<td>Number of Undo Actions</td>
<td>Maximum: 5000</td>
</tr>
<tr>
<td>Smallest allowed negative number</td>
<td>Defined in the cube</td>
</tr>
<tr>
<td>Smallest allowed positive number</td>
<td>Defined in the cube</td>
</tr>
</tbody>
</table>
Chapter 16. Forecast Formulas

You can make predictions about the future performance of your business based on past data by using one of these time series forecasting methods: Trend, Growth, or Autoregression.

All IBM Cognos PowerPlay forecasting methods use univariate techniques, which means that each category, whether a row, a column, or a summary row or column, is treated as a separate time series.

Trend Forecast Formula

The formula for Trend forecasting is

\[ y = at + b \]

where \( y \) is the dependent variable (for example, revenue), \( t \) is the independent time variable,

\[
a = \frac{\frac{N}{\sum_{i=1}^{N} t_i^2} \left( \sum_{i=1}^{N} t_i \sum_{i=1}^{N} y_i \right) - \left( \sum_{i=1}^{N} t_i \right) \left( \sum_{i=1}^{N} y_i \right)}{N \left( \sum_{i=1}^{N} t_i^2 \right) - \left( \sum_{i=1}^{N} t_i \right)^2}\]  

(the slope of the trend line)

and

\[
b = \frac{\frac{1}{N} \left( \sum_{i=1}^{N} t_i \right) \left( \sum_{i=1}^{N} t_i^2 \right) - \left( \sum_{i=1}^{N} t_i \right) \left( \sum_{i=1}^{N} t_i^2 \right) \sum_{i=1}^{N} t_i y_i}{N \left( \sum_{i=1}^{N} t_i^2 \right) - \left( \sum_{i=1}^{N} t_i \right)^2}\]  

(the intercept)

The coefficient of determination, a measure of how closely the trend line corresponds to your historic data, is defined by the following equation:

\[ R^2 = 1 - \frac{SSE}{SST} \]

where

\[ SSE = \sum_{i=1}^{N} (y_i - \hat{y}_i)^2 \]  (sum square of residual errors)

and

\[ SST = \sum_{i=1}^{N} (y_i - \hat{y}) \]  (sum of squared total)
Growth Forecast Formula

The formula for Growth forecasting is

\[ y = ba^t \]

where \( b \) is the intercept and \( a \) is the constant growth rate.

IBM Cognos PowerPlay uses a logarithmic transformed regression model to solve this equation.

Autoregression Forecast Formula

The formula for Autoregression forecasting is

\[ y_t = \sum_{j=1}^{M} d_j y_{t-j} \]

where

\[ \sum_{j=1}^{M} \phi_{j-t} \rho_j = \phi_k \quad (k = 1, \ldots, M) \]

\( (d_j \) are the linear prediction (LP) coefficients) and

\[ \phi_j = \left< y_t, y_{t+j} \right> \approx \frac{1}{N-j} \sum_{i=1}^{N-j} y_i y_{i+j} \]

\( \) (auto-correlation of the historic series)

IBM Cognos PowerPlay uses Burg’s algorithm and a data window \( M \) equal to half the number of data points to solve these equations.
Chapter 17. PowerPlay Samples

The following IBM Cognos PowerPlay samples are available on the IBM Cognos Business Intelligence Samples CD. For information about installing the samples, see the PowerPlay Client Installation Guide.

Table 9. PowerPlay samples

<table>
<thead>
<tr>
<th>File name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>great_outdoors_sales_en.mdc</td>
<td>All sample reports are based on the great_outdoors_sales_en.mdc cube. This cube was build with IBM Cognos Transformer.</td>
</tr>
<tr>
<td>3D-multiline.ppx</td>
<td>Explorer report showing multiple displays in a single report: 3D bar, multiline, and crosstab.</td>
</tr>
<tr>
<td>advanced_subset.ppx</td>
<td>Reporter report with an advanced subset definition and find-in-cube subset definition. The advanced subset definition is used as rows for the report.</td>
</tr>
<tr>
<td>charting options.ppx</td>
<td>Reporter report showing a simple bar display with statistical lines.</td>
</tr>
<tr>
<td>currency_explorer.ppx</td>
<td>Explorer report showing a crosstab display with nested rows and an alternate currency.</td>
</tr>
<tr>
<td>currency_reporter.ppx</td>
<td>Reporter report showing a crosstab display with nested rows and an alternate currency.</td>
</tr>
<tr>
<td>external_rollup.ppx</td>
<td>Reporter report showing a crosstab display with nested rows and an external rollup.</td>
</tr>
<tr>
<td>forecasting.ppx</td>
<td>Explorer report showing a crosstab display with indented 2 layout and a forecast calculation.</td>
</tr>
<tr>
<td>nested_crosstab_1.ppx</td>
<td>Reporter report showing a crosstab with indented 1 layout. The report includes zero values as blanks, blank rows and columns, and the use of variables in the report title.</td>
</tr>
<tr>
<td>nested_crosstab_2.ppx</td>
<td>Reporter report showing a crosstab display with standard layout. The report includes categories from an alternate drill-down path nested with categories from primary drill-down path, and multiple measure intersections.</td>
</tr>
<tr>
<td>nested_crosstab_3.ppx</td>
<td>Explorer report showing a crosstab display with indented 2 layout and ranking.</td>
</tr>
<tr>
<td>nested_crosstab_4.ppx</td>
<td>Explorer report showing a crosstab display with indented 2 layout. The report shows hidden gridlines and formatting of the labels for the summary rows.</td>
</tr>
<tr>
<td>parentage_subset.ppx</td>
<td>Reporter reporter showing crosstab display with a parentage subset definition added as rows. A pattern is used to highlight the subset.</td>
</tr>
</tbody>
</table>
Table 9. PowerPlay samples (continued)

<table>
<thead>
<tr>
<th>File name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>percentage_sales.ppx</td>
<td>Explorer report showing a crosstab display with 80/20 suppression and custom formatting of the label for the other category.</td>
</tr>
<tr>
<td>ranking_1.ppx</td>
<td>Reporter report showing a crosstab display with two ranked columns, one sorted, and the other unsorted.</td>
</tr>
<tr>
<td>ranking_2.ppx</td>
<td>Reporter report showing a crosstab display with ranking calculation.</td>
</tr>
<tr>
<td>ranking_3.ppx</td>
<td>Reporter report showing a crosstab display with nested rows. The report includes a formatted rank category.</td>
</tr>
<tr>
<td>sales_target_correlation.ppx</td>
<td>Explorer report showing a correlation and crosstab display.</td>
</tr>
<tr>
<td>stacked_bar.ppx</td>
<td>Explorer report showing stacked bar and crosstab displays and sorting by value.</td>
</tr>
<tr>
<td>top_sales_staff.ppx</td>
<td>Reporter report showing a filter, calculation, rank, and the use of a graphic in the report title.</td>
</tr>
</tbody>
</table>
Appendix. Troubleshooting

This chapter describes some common problems you may encounter.

IBM CognosScript Editor is Not Included With IBM Cognos PowerPlay Client

IBM Cognos PowerPlay Client does not include IBM CognosScript Editor.

You can use IBM Cognos Series 7 CognosScript Editor, or another supported tool such as Microsoft Visual Basic, for macros in PowerPlay Client.

Cognos Application Firewall Error When Publishing a Report

If the Gateway URI setting in IBM Cognos Configuration is not the same format for both the IBM Cognos PowerPlay Client installation and the PowerPlay Server installation, you may receive an IBM Cognos Application Firewall (CAF) error when you attempt to publish a report from PowerPlay Client to the IBM Cognos Business Intelligence portal.

To prevent this error ensure that same format is used for the Gateway URI setting in both configurations. For example, use a fully qualified domain name in both Gateway URI settings. Do not use a machine name in one configuration and a fully qualified domain name in the other configuration.

Avoiding Blank Extra Lines in Report Titles

If you type a title with a first line that is longer than the width of your Report Title window, and you insert a carriage return to start the next line, the automatic wrap feature may insert an extra blank line between your first and second title lines when you click OK.

To avoid this unwanted activation of the automatic wrap feature, press the Enter key before the first line of your title reaches the end of the Report Title window.

Hebrew Text Displayed in Chart Elements

In some chart elements, bi-directional Hebrew text may be displayed in a "logical" order rather than the expected "visual" order.

For more information, go to http://people.w3.org/rishida/scripts/bidi/

Calculation is Not Dynamically Updated After a Cube Update

After a cube update, when you open an existing report that includes a calculation based on members of a subset, items that were not in the earlier version of the cube are not included in the calculation. This can occur when the calculation is created in a report where zero suppression is applied. The calculation will include only items that are present in the report. After a cube update, the calculation will not dynamically update to include new items.
If the intention is to create a true sub-set calculation, which will dynamically update, before you create a calculation based on members of a subset, ensure that zero suppression is not activated. Apply zero suppression after you create the calculation.

Opening an Exported XLS File in Microsoft Excel 2007

In Microsoft Excel 2007, if you open an .xls file that was exported from IBM Cognos PowerPlay, you may see a warning that the file is of a different format than specified in the extension. You can ignore this message and open the file without error.

Only the First Page of a Multiple-page Report Prints

To specify the parts of the report to print, from the File menu, click Print and click the Options button. On the Print tab, click the Selected Display(s) check box or the Entire Report check box.

Dimension Viewer Does Not Appear

In some cases, the dimension viewer does not appear although the icon indicates that it is active. The dimension viewer may have been resized to have a width of zero. Place the pointer at the extreme left border of the application. When it changes to a two-way pointer, click and drag to the right. The dimension viewer appears beside it.

Report Looks Different After the Cube is Updated

In most cases, you can use existing reports with an updated cube. You may have problems if

- the administrator removed a category from the cube. You can open the report, but the category shows the word error instead of showing values. Remove the category from your report.
- the administrator removed a dimension. You may want to recreate the report.

Advanced Subset Value Restriction is Not Available

After you create value filters and save your report, the value filters might become invalid when the report is opened again. This results in a changed report. IBM Cognos PowerPlay processes these value filter situations:

- Invalid Dimension
  If a dimension becomes invalid because it was deleted, renamed, or became invisible due to security restrictions, any value filters based on the dimension are removed from the report.
- Invalid Dimension Setting
  If an invalid dimension forms part of a value filter, the invalid dimension is removed from the value filter. The filter functions based on the remaining dimension settings. You may not notice that one or more dimensions are missing from the dimension settings when you edit them.
- New Dimension Added
  If a new dimension is added to the cube, a value filter based on the previous cube becomes invalid. The filter has "Not Valid" appended to its name. When you edit the filter, "<New Dimension> - Not Valid" appears in the Based on the Dimension Setting box in the Restrict by Value dialog box. The order of the
new dimension in the settings is the same as on the dimension line. Select the new dimension and click Edit to choose a category available in the new dimension. You must choose a category for each invalid dimension before you can click OK to accept your changes.

- **Invalid Category**
  If one or more categories in a dimension are deleted, but their corresponding dimension remains valid, the value filter becomes invalid. The filter has "Not Valid" appended to its name. When you edit this filter, the invalid categories appear in the **Based on the Dimension Setting** box in the **Restrict by Value** dialog box with "Not Valid" appended to their category names. Select the category and click Edit to choose a valid category. You must choose a category to replace each invalid category before you can click OK to accept your changes.

- **Invalid Measure**
  If the measure that the value filter is based on is deleted or renamed, the value filter becomes invalid. The filter has "Not Valid" appended to its name. When you edit this filter, "Not Valid" is appended to the measure name in the **Restrict by Value** dialog box. You can then choose a valid measure, and the invalid measure is deleted. You must choose a measure to replace the invalid measure before you can click OK to accept your changes.

- **Invalid Value Filter**
  If an invalid value filter is attached to an advanced subset, that filter does not run. Click OK to remove the invalid value filter from the subset.

---

### Categories Do Not Appear After Changing to Explorer Mode

In a Reporter report, if you created a custom exception definition based on a particular category that doesn't apply in an Explorer report, then that category doesn't appear in an Explorer report custom exception definition.

For example, if you base a custom exception definition on **All Years**, and then switch to an Explorer report, the **All Years** parent category doesn't exist in the custom exception definition.

---

### Summary Values Appear to be Incorrect

If measures are allocated either proportionally (based on other measures) or as constant values, then the values shown in IBM Cognos PowerPlay do not necessarily add up to the values shown in the summary rows, columns, or layers.

Contact your IBM Cognos Transformer modeler for more information.

---

### Calculated Values Appear in a Different Format

Calculated values may appear as number signs (###), na, or in scientific notation (for example, 1.7976931348623158e+308).

If the values appear as number signs (###), it is because the width of the cell is too narrow. To see the values, increase the width of the cell.

If the values appear as na, it is because your calculation contains a category with a null value. For forecast calculations, IBM Cognos PowerPlay does not have appropriate values on which to base a forecast.
If the values appear in scientific notation, it is because the result is larger than 15 digits.

**Calculated Values Appear as /0**

If you divide by 0, the values appear as backslash zero (/0). This format is the expected behavior.

**Labels for Calculated Categories Do Not Display Correctly**

Resize the category label or decrease the font size.

**Allocated Measures**

If a measure doesn’t apply to all dimensions, or to all levels and categories within a dimension, the administrator can allocate the values of the measure to the appropriate categories.

When the measure is allocated as a constant, the same value (or zeros) appears in all levels and totals.

When the measure is allocated based on another measure, values appear in proportion to the values of the other measure. For example, you can base a regional sales forecast measure on a measure such as last year’s actual sales.

For example, a report shows Revenue, Number of Employees, and Revenue per Employee for each Quarter. The number of employees is a constant that doesn’t add up, because there are only 10 employees. The measure Number of Employees is allocated as a constant (in this case, the number 10) in the Years dimension.

**Table 10. Report showing allocated measures**

<table>
<thead>
<tr>
<th>Period</th>
<th>Revenue</th>
<th>Number of employees</th>
<th>Revenue per employee</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q1</td>
<td>200k</td>
<td>10</td>
<td>20k</td>
</tr>
<tr>
<td>Q2</td>
<td>300k</td>
<td>10</td>
<td>30k</td>
</tr>
<tr>
<td>Q3</td>
<td>250k</td>
<td>10</td>
<td>25k</td>
</tr>
<tr>
<td>Q4</td>
<td>450k</td>
<td>10</td>
<td>45k</td>
</tr>
<tr>
<td>2007</td>
<td>1200k</td>
<td>10</td>
<td>120k</td>
</tr>
</tbody>
</table>

**Unexpected Zeros Appear in the Report**

You filtered out categories that appear in the report. The categories are still there, but they show zeros. For example, three categories from the Products dimension (Outdoor Products, Go Sports, and Environmental Line) are in the columns. Using the dimension menus, you filter the Product dimension to Go Sports. The other two columns remain in the report, but they show zeros.
You filtered in a Reporter report that still shows other categories in the filtered dimension. You can delete the categories that show zeros, or you can suppress them. From the Explore menu, choose a Suppress option.

**Values Appear as "error"**

This can be for several reasons:
- You may not be connected to the right cube. See the administrator if the problem continues.
- A category or a dimension may have been removed from the cube.
- Calculations are combined in an illogical manner.

**Values Appear as Number Signs (###)**

The cells are too small to show the numbers.

Select the categories and resize them, or change the number format.

**Values Appear as Question Marks (???)**

If IBM Cognos PowerPlay is not retrieving data automatically, then, when you drill down, rank, or do anything that requires new data, you see question marks instead of values.

From the Explore menu, ensure that Get Data, Automatically is selected, or select Get Data, Now.

**No Values for a Measure in Some Dimensions**

Values may be missing in IBM Cognos PowerPlay because
- The source data lacks values for the measure. IBM Cognos Transformer writes the value 0 to the cube.
- The measure applies only to a portion of a dimension. Transformer does not allocate the measure to lower levels.

Ask the administrator to try these remedies:
- Clean the source data so that records with missing values are excluded from the query.
- Omit the measure from the cube if it is not necessary.
- Allocate the measure values to lower levels either proportionally, based on other measure values, or as a constant value. If you allocate as a constant, note that the same value appears in all cells of a crosstab for the categories to which you allocated the constant value.

**Time Period Differences**

You can set up a special category for a year to have 13 months.

The IBM Cognos Transformer modeler can create a model that uses your company's fiscal year, a lunar year, industry-specific periods such as 13-week manufacturing periods, and relative time periods such as year-to-date.
Unable to Drill Through to a Cube or Report

IBM Cognos Transformer modelers can associate drill-through targets only with the lower levels of a dimension, avoiding the need to deal with large, unwieldy reports. This ensures that end users drill through only to reports that are in scope. Frequently, because of data volume, you do not want to drill from the top levels of a dimension.

If you require access to data in the top levels of a cube, contact your Transformer modeler.

Saved Report Looks Different

If you saved a report with Shared Dimensions switched on, then any subsequent report that you create using the same cube applies its filters to the saved report.

From the File menu, clear Shared Dimensions before saving a report.

To change the default settings so that all new reports do not share the dimension line, from the File menu, click Preferences. On the Dimensions tab, clear the Share the Dimension Line check box.

Unable to Move a Column or Row

You can't move a column or row in an Explorer report. If you try, the rows and columns are swapped.

You can switch to a Reporter report or duplicate your report as a Reporter report.

Unable to Open the Page Setup or Print Dialog Box

IBM Cognos PowerPlay can't locate a default printer. Use Print Manager to install and select a default printer.

Report Does Not Fit on One Printed Page

Try one or more of the following adjustments:

• From the File menu, click Print. Select the Fit to Page check box. This check box is available only if the Print Selected Display(s) or Entire Report on the Print Options dialog box is selected, and the Print to File check box is cleared.

• Swap rows and columns.

• Make the page margins smaller.

• Change the page orientation.

• If your report is a nested crosstab, use the an indented crosstab layout.

Unable to Print White on Black

If you use a printer with the HPPCL Level 4 driver and you use TrueType fonts, choose Dark Blue for the background and foreground colors instead of Black. You must choose the Print TrueType As Graphics printer option for the white text to appear on black background.
Text Prints on Top of Graphics

Try formatting the report with a font other than Times New Roman, Courier New, or Arial, or try turning off the Download True Type as Bitmap Soft Fonts printer option.

Restore the Default Toolbars and Menus

If you created custom toolbars and menus using the Customize command from the Tools menu, you can click Reset on the Toolbars or Menus tab to get the default toolbars or menus back.

Errors After Moving Reports or Cubes to a New Location

You can move reports and cubes without rebuilding them. Drag or copy the reports and cubes to the new location. You cannot use the Recent File command. From the File menu, click either Open or New.

You do not have to move both the reports and the cube that the reports use. You can move only the reports or only the cube. If you move a report or the cube or both, IBM Cognos PowerPlay may not be able to find the cube when it opens the report.

When you are opening a report whose cube you moved, select the Prompt for MDC File check box in the Open dialog box.

You cannot move the PowerPlay application itself to a new location by dragging or copying it. If you want PowerPlay in a different location, you must re-install it.

Correct Performance Issues

To improve performance, try one or more of the following techniques:

- Switch off automatic retrieval of data until you are ready to update the information in your report.
- Switch off automatic retrieval of data while you are drilling down, slicing and dicing, formatting, and so on. When the report looks the way you want, from the Explore menu, click Get Data, Now to retrieve data.
- Reduce the number of undo actions that IBM Cognos PowerPlay stores. From the File menu, click Preferences. On the Options tab reduce the value of the Maximum number of Undo actions option. More memory is then available.
- Switch off suppression of zeros. From the File menu, click Preferences. On the Suppress tab, set the suppression options.
- Limit the number of categories in a Reporter report by removing unnecessary categories.
- Delete hidden categories.
- Divide a large cube into smaller, more manageable cubes. The administrator can do this for you, or ask the administrator about changing the ReadCacheSize setting. Increasing the value for ReadCacheSize increases PowerPlay's performance.
- Summarize the details and sort the remaining categories to your specifications. The administrator can do this for you. For example, if the cube contains more levels of detail than you need, and the categories are not sorted logically, you may not be able to analyze your business quickly. The administrator can change the model so that you can more quickly find the information you need.
• Limit the number of rank calculations. Use manual ranks instead of automatic ranks.
• Tune Windows performance in general. See your Microsoft Windows documentation for more information.

Unable to Email a Report

Ensure that you are using a supported mail server such as Microsoft Mail or Microsoft Exchange.

Unable to Open a Remote Report

In IBM Cognos PowerPlay Client, you can not open a remote report if the report name includes characters that are not supported by the regional and language options of the computer where PowerPlay Client is installed. After you select a report that uses unsupported characters and click OK, the report does not open and you are returned to the Select the report page.

Unable to Save a Report

Microsoft Windows does not allow the following characters in file names.

< > : " / \ | ? *

These characters are permitted for object names in IBM Cognos Connection. For example, IBM Cognos Connection includes a IBM Cognos PowerPlay report named sales:Q1.

In PowerPlay Client, you can open a remote report that includes restricted characters in the report name, such as sales:Q1. However, if you attempt to save a local copy of the report the Save As dialog box does not appear and you are unable to save the report.

Unable to Add a Launch Button for a Macro

In IBM Cognos Series 7 PowerPlay, you can create a launch button to run a macro. IBM Cognos PowerPlay Client does not have the same capability.

If you have IBM Cognos Series 7 installed on the same computer you can configure a launch button to run a batch file that uses runmac32.exe to execute the macro. The default installation location for the runmac32.exe file is cer5\bin.

Unable to Refresh a Sub-Cube

The default preferences setting is to automatically refresh the data from the original cube when you open a sub-cube. There are some situations that will cause an error when IBM Cognos PowerPlay attempts to refresh the data.
• the original cube was moved or renamed
• dimensions were removed from the original cube since the last data refresh
• PowerPlay Client is unable to connect to the IBM Cognos BI gateway or the PowerPlay service

In some cases PowerPlay will notify you that the data was not refreshed and then open the sub-cube. If the sub-cube does not open, disabling the Refresh sub-cubes setting may allow you to continue to work with the sub-cube.
Notices

This information was developed for products and services offered worldwide.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service. This document may describe products, services, or features that are not included in the Program or license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.
IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Software Group
Attention: Licensing
3755 Riverside Dr
Ottawa, ON K1V 1B7
Canada

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.
Trademarks

IBM, the IBM logo, ibm.com, PowerPlay, Impromptu, and Cognos are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at “Copyright and trademark information” at www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:
- Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States, and/or other countries.
- Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.
Index

Special characters
-.bmp files 2
-.gif files 2
-.ini files 91
-.jpg files 2
-.mnu files 87, 91
-.png files 2
-.ppr 1
-.wmf files 2

Numerics
3-D bar displays
- making bars transparent 74
- rotating 72
- suppression 15, 16

A
- accessible reports 17
- accumulate
  - calculating 55
- adding
  - calculated categories 58
  - categories 7, 29
  - categories as layers 11
  - columns 57
  - footers 77
  - headers 77
  - layers 11, 57
  - nested categories 9
  - nested columns 9
  - nested rows 9
  - ranked categories 43
  - rows 57
  - titles 77
- types of displays 67
- values to graphical displays 68
- advanced subset definitions
  - creating 21, 24
- advanced subsets
  - creating with find-in-cube restrictions 25
  - creating with parent restrictions 24
  - creating with value restrictions 26
  - value restrictions 106
- aligning
  - labels and values 79
- alternate
  - paths 31
- analyzing
  - scenario dimensions 29
- applying
  - automatic exception highlighting 47
  - background patterns 76
  - backgrounds 71
  - custom exception definitions 49
  - styles 76
- arranging
  - displays 71

ASC files 86
- automatic exception highlighting
  - applying 47
  - using 47
- automatically
  - retrieving data 109
  - updating reports 20
- autoregression forecasting
  - definition 61
- averages
  - calculating 54

B
- backgrounds
  - applying patterns 76
  - applying patterns to reports 76
  - applying to displays 71
  - patterns 76
- bar graphs
  - changing displays 71
- blanks
  - showing zero values 81
- bolding
  - one line in a multiline display 73
- break-down of outer rows
  - summaries 13
- breaking
  - subsets 28
- Burg algorithm
  - forecasting 102
- buttons
  - customizing 89, 90

C
- calculated categories
  - adding 58
- calculation precedence
  - controlling 59
- calculations
  - accumulate 55
  - adding as new categories 57
  - appearing as formulas 107
  - appearing as na 107
  - appearing as number signs 107
  - average 54
  - controlling precedence 59
  - creating 53
  - cumulative percentage 59
  - divide 54
  - division 62
  - financial ratios 62
  - forecast 60
  - grouping 59
  - nested reports 53
  - on subsets 27
  - percent growth 54
  - percentage of totals 54
  - rollup 56

© Copyright IBM Corp. 2005, 2012
calculations (continued)
  running totals 55
  share of 54
  showing categories as percentage of parent categories 57
  showing categories individually 57
  showing the average of categories 57
  subtract 54
  troubleshooting 107, 108
  values appear as /0 108

callouts
  adding lines to pie displays 73
  categories 15
    add intersected categories 10
    adding 7, 29, 58
    adding as layers 11
    adding nested 9
    combining 10
    copying 12
    drilling down 31
    filtering 33
    hiding 12, 13, 17
    names 75
    nested 9
    ranking 43
    removing 17
    share of another 54
    showing 13
    sorting 43
    special 109
    totalling 57
    troubleshooting 17
    truncated labels 108
    unhiding 12

category labels
  troubleshooting 108

category names
  labels in nested charts 73
cerlocale.xml 107

changing
  angle of displays 71
  colors 70
  labels 79
  markers in displays 72
  measures 35
  patterns 70
  styles 76
  subset definitions 26
  summary labels 80

charts
  adding statistical lines 69
  bar 71
  displaying Hebrew text 105
  displaying mix 66
  large amounts of data 68
  nested 67
  pie 71
  swapping columns 13
  swapping layers 13
  swapping rows 13

clearing
  highlighting 48
  coefficient of determination 101

colors
  applying to report backgrounds 76
  changing 70

columns
  adding 7
  adding as calculations 57
  copying 12
  drilling down and up 31
  floating 14
  formatting labels 79
  inserting blanks 14
  moving 14, 110
  ranking 43
  showing multiple measures as 36
  showing summaries 13
  sorting 43
  swapping 13
  totals 80

combining
  categories 10
  comma separated value files 86

command-line options 97
  cube 98
  Explorer report 97
  no title screen 97
  report name 98
  Reporter report 98

comparing
  measures 66
  variables 65, 66

compound charts
  see nested charts 73

conditional
  formatting 48

configuring
  data formats 107
  calculation precedence 59
  conversion
    currency 37
    reports 106
  copying
    between reports 12
  correlation
    displays 74
    scaling each measure in displays 74
    showing markers in displays 72

creating
  advanced subset definitions 24, 25, 26
  calculations 53
  custom exception definitions 48
  find in cube subset definitions 22
  forecasts 60
  parentage subset definitions 21
  report templates 20
  reports 3
  reports using remote cubes 4
  styles 76
  subset definitions 21

crosstabs
  adding nested categories 9
  choosing a layout 75
  formatting labels and values 79
  ranking 45

CSV files 86
cubes
  command-line options 98
  creating a find in cube subset definition 22
  drilling through 40
  finding data in 33
E

earnings
  calculating per share  62
email
  sending reports  85
errors
  appearing in cells  109
  updating reports  106
exceptions
  applying  47, 49
  automatic highlighting  47
  creating  48
  custom definitions  48, 50, 107
  defaults  50
  highlighting  47, 49
  highlighting with macros  47
  troubleshooting  49, 107
Explorer mode  3
Explorer reports
  adding categories  7
  command-line options  97
  copying  12
  showing data as percentages  80
exploring
  information  39
exporting
  reports  85

F

feelers
  showing  73
files
  exporting  85
filtering
  categories  33
  data  29
  on values  26
filters
  applying to reports  110
  creating  33
  removing  33
  using to explore information  29
values  106
financial ratios
  calculating  62
find-in-cube subset definitions
  using wildcards  22
finding
  data in cubes  22, 25, 33
  data in reports  33
  exceptions  47
  trends  66
fiscal years
  length  109
floating
  columns and rows  14
folders
  dimensions  29
footers
  adding  77
  setting defaults  77
forecasts
  autoregression (seasonal)  61
  autoregression formula  102
  coefficient of determination formula  101
forecasts (continued)
  creating  60
  formulas  101
  growth (curved or curved line)  61
  growth formula  102
  terms of use  60
  trend (linear or straight line)  61
  trend example  61
  trend formula  101
formats
  data  107
formatting  79
  applying automatic exception highlighting  47
  applying custom exception definitions  49
  axis titles  79
  column labels  79
  currency  37
  data  78
  exceptional data  48
  labels  79
  reports  70, 75, 78
formulae
  autoregression  102
  Burg algorithm  102
  growth  102
  trend  101
formulas
  creating  53
  forecasting  101

G

generating
  create reports  3
graphic types
  supported  2
graphs
  displaying mix  66
  statistical lines  69
  swapping columns, layers, or rows  13
gridlines
  hiding in reports  73
grouping
  calculations  59
growth forecasting
  definition  61

H

headers
  adding  77
  setting defaults  77
Hebrew text
  displaying in charts  105
hidden
  data  12
hiding
  categories  12, 13, 17
  data  12
  rank category  43
  report gridlines  73
  toolbars  89
highlighting
  automatic exceptions  47
  clearing  48
  custom exceptions  47, 50
highlighting (continued)
  exceptional data 47, 48, 49
  exceptions with macros 47
  subsets 27

IBM Cognos PowerPlay
  compared to IBM Cognos Series 7 PowerPlay 1
Impromptu
  drill through to 39
indicators
  performance 35, 36
information
  removing 17
  suppressing 15
inserting
  blank columns or rows 14
invalid characters
  PDF files 83

labels
  changing 79, 80
  formatting 79
  pie displays 73
  renaming 79
  summary 80
launch buttons
  setting up 90
launch menu commands
  setting up 88
layers
  adding as calculations 57
  adding to a report 11
  changing contents 11
  copying 12
  drilling down and up 11, 31
  formatting labels 79
  navigation 11
  showing multiple measures as 36
  swapping 13
  totals 80
layouts
  crosstabs 75
legends
  pie displays 73
limits
  product 99
linear
  statistical lines 69
lines
  adding callouts to pie displays 73
local cubes
  using to create reports 4
locale
  settings 107
locale settings
  configuring 107
  logarithmic
    statistical lines 69
long
  dimension or category name 75

M
  macros
    highlighting exceptional data 47
    using a menu command 88
mailing
  reports 112
maintaining
  standard reports 19
manual
  exception highlighting 47
  manually
    updating reports 20
markers
  displays 72
measures
  changing 35, 109
  changing formats 36
  comparing 66
  definition 35
  formatting labels 79
  multiple 36
  nested 36
  no values in dimensions 109
  numbers 108
  scaling 74
  values 108
menus
  adding commands 87
  creating 87, 93
  customizing 87, 111
  distributing 91
  resetting 87, 111
missing
  values 15, 81
months
  using 13 in a year 109
moving
  columns or rows 14, 110
  reports and cubes 111
multiline
  bold lines 73
  bolding 73
  displays 73
  showing markers in displays 72
multiple
  displays 67
multiple measures
  as columns 36
  as layers 36
  as rows 36

N
  names
    dimension and category 75
navigation
  reports that use layers 11
nested categories
  changing 9
  ranking 45
sorted 46
nested charts
  selecting 67
  showing labels and legends 73
nested crosstabs
  ranking 45
nested crosstabs (continued)
  sorting  46
no title screen
  command-line options  97
number signs
  calculations  107
  values  109
numbers
  changing formats for measures  36
  errors  108
  zeros  109

O
offline
  data access  2
  working  95
opening
  reports  5, 110
  subset definitions  26
organizing
  displays  71

P
parent restrictions
  creating subsets  24
parentage subset definitions
  creating  21
paths
  alternate  31
  drill down  31
  drill up  31
  primary  31
patterns
  applying  76, 79
  changing  70
PDFs
  invalid characters  83
  setting options  14
percent growth
  calculate  54
percentages
  of totals  54
  running totals  55
  showing data as  80
performance
  formatting indicators  36
  indicators  35, 36
  of Explorer and Reporter reports  111
  tracking  65
  troubleshooting  111
performing
  calculations  53
pie displays
  showing labels and legends  73
pie graphs
  adding feelers to displays  73
  changing displays  71
  rotating displays  72
  showing labels and legends  73
PowerPlay
  customizing  87
  drill through to  40
  product specifications  99
PowerPlay Client
  opening remote reports  1
PowerPlay Connect  2
preferences
  creating menus  93
  dimension viewer toolbox  93
PowerPlay  87
  setting  87
primary
  paths  31
printing
  fitting report on one page  110
  problems  110, 111
  reports  110, 111
  reports with large amounts of data  84
products
  showing mix  66
profits
  calculating per employee  62
prompts
  setting in reports  14

Q
question marks
  values  109

R
ranking
  categories  43
  columns or rows  43
  identical values  44
  nested categories  45
  nested crosstabs  45
  reports  44
  ties in a report  44
refreshing
  sub-cubes  95, 96
regression
  statistical lines  69
remote cubes
  using to create a report  4
remote reports
  opening in PowerPlay Client  1
  unable to open  112
  unable to save  112
removing
  categories  17
  displays  67
  filters  33
  information  17
  layers  11
  styles  76
  subsets  28
  unwanted information  33
renaming
  labels  79
report format
  .ppr files  1
  report name
    command-line options  98
report titles
  blank lines  105
Reporter mode  3
Index

Reporter reports
  adding categories 7
  command-line options 98
  copying 12
  performing calculations 57
  showing data as percentages 80
reports 106, 110, 111, 112
  adding nested categories 9
  advanced 19
  applying backgrounds 76
  changing types 12
  creating using a local cube 4
  creating using a remote cube 4
  differences between PowerPlay Client and PowerPlay Studio 5
  distributing 83
  duplicating 12
  exporting 85
  filters 110
  finding data in 33
  fitting on one printed page 110
  formatting 75, 78
  getting started 3
  hiding gridlines 73
  improving performance 111
  mailing 112
  maintaining standard 19
  moving 111
  opening 5, 110
  printing 84, 110, 111
  saving 110
  sending via email 85
  setting deployment options 14
  setting up as templates 20
  settings to use a sub-cube 96
  troubleshooting 112
  upgrading 5.x to 6.x 106
  using sub-cubes 96
resetting
  menus 87, 111
  toolbars 89, 111
resizing
  displays 67
  rollup calculations 56
rows
  adding 7, 43
  adding as calculations 57
  copying 12
  drilling down and up 31
  floating 14
  formatting labels 79
  inserting blanks 14
  moving 14, 110
  ranking 43
  showing multiple measures as 36
  showing summaries 13
  sorting 43
  swapping 13
  totals 80
S
  saving (continued)
    reports 110
  scaling
    measures 74
  scatter displays 74
    scaling each measure in displays 74
    showing markers in displays 72
  scenario dimensions
    analyzing 29
  scrollbars
    using with large amounts of data 68
  sending reports 112
    via email 85
  setting up
    launch buttons 90
    launch menu commands 88
    preferences 87
  settings
    locale 107
  Share the Dimension Line 19
  sharing
    custom exception definitions 50
    dimensions 110
  short dimension or category name 75
  showing
    a mix of information 66
    bold line in multiline displays 73
    categories 13
    data as percentages 80
    feelers in pie displays 73
    headers and footers 77
    markers 72
    multiple displays 67
    toolbars 89
    values in displays 68
    zeros as blanks 81
  single line
    showing markers in displays 72
  slice and dice
    swapping rows, columns, layers 13
  sorting
    categories 43
    columns 43
    data 43
    layers 43
    nested categories 46
    nested crosstabs 46
    reports 46
    rows 43
  specifications
    product 99
  statistical lines
    adding 69
    linear 69
    logarithmic 69
    regression 69
  styles
    creating and applying 76
    defining for custom exception definitions 50
  sub-cubes
    refreshing 95, 96
    saving 95
    setting a report to use 96
    unable to refresh data 112
subset calculations 27
subset definitions 26
creating 26
opening a subset 26
parentage 21
subsets 26
breaking 28
changing a definition 26
creating 19
creating an advanced subset definition 24
creating find in cube subset definitions 22
deleting 28
highlighting 27
opening a subset definition 26
removing 28
summaries
troubleshooting 107
summary
categories 13
displaying categories 68
labels 80
supported
data sources 1
suppressing
by 80/20 rule 15, 16
swapping
columns 13
dimensions 29
layers 13
rows 13

templates
report 20
terms of use
forecasting 60
tiling
displays 71
tilting
angle of displays 71
time periods
months in a year 109
titles
adding 77
formatting 79
setting defaults 77
toolbar buttons
customizing 89
toolbars
changing buttons 89
customizing 89, 111
distributing 91
resetting 89, 111
setting up buttons 89
showing or hiding 89
toolbox
customizing 93
totals
adding to reports 13, 57
percentage of 54
tracking
performance 65
transparent
3-D bar displays 74
trend forecasting
definition 61
example 61
trends
finding 66
troubleshooting
advanced subsets 106
calculations 107, 108
categories 17, 107
category labels 108
custom exceptions 49
default menus 111
default toolbars 111
dimension viewer 106
events 109
hiding data 12
moving columns or rows 110
numbers 108, 109
performance of reports 111
printing 110, 111
reports 110, 112
summaries 107
updated cubes 106
upgrading report versions 106
value filters 106
values 109

U
unable to open a remote report 112
unable to refresh data in a sub-cube 112
unable to save a remote report 112
unhiding
categories 12
updating
reports 106
reports manually 20
Upfront
setting prompts 14
upgrading
reports 106
using
wildcards 22

V
value restrictions
advanced subsets 106
values
appearing as number signs 109
appearing as question marks 109
labels in nested charts 73
measures 108
showing as percentages 80
showing in graphical displays 68
showing zeros as blanks 81
suppressing 15
variance
analysis 54
showing 65
tracking 65
viewing
displays 71
large amounts of data in a chart display 68
W  
wildcards  22
    using when finding data  33
working offline  2
    overview  95

Y  
years
    fiscal  109

Z  
zeros
    all numbers  109
    showing values as blanks  81
    suppressing values  15
    values  81