Before using this information and the product it supports, read the information in "Notices" on page 217.
# Contents

**Introduction** .................................. ix

**Chapter 1. What's New?** ...................................................... 1

New features in version 10.2.0 .................................................. 1
IBM Cognos Mobile available for IBM BI for z/OS ............................ 1
IBM Cognos Workspace installed with IBM BI Server .......................... 1
IBM Cognos Connection Installer for Cognos Insight .......................... 2
64-bit IBM Cognos gateway ..................................................... 2
IBM Cognos Dynamic Cubes installation ....................................... 3
IBM Cognos Dynamic Query Analyzer .......................................... 3
Predefined LDAP authentication namespace configurations ................... 3
Configuration of multi-tenant applications in IBM Cognos Configuration .......... 3
Option to view the status of silent installations on the screen .................. 4
Option to initialize Cognos Configuration from a different file ............... 4
IBM Cognos content archival .................................................... 4
JDBC connectivity to data sources and the dynamic query mode .................. 4
Index search capabilities ....................................................... 5
Interactive dashboards merged with IBM Cognos Viewer features ............... 5

**Changed Features in Version 10.2.0** ....................................... 5
Changes to the default installation location and the web alias ................ 5
Changes to the FMIDs .................................................................. 5
Enhanced support for RACF authentication provider .............................. 6
Secure access when monitoring system metrics externally .................... 6

**Chapter 2. Quick reference: installation checklist** ................................ 7
Preinstallation checklist ................................................................ 7
Installation checklist .................................................................... 10
Post-installation checklist .......................................................... 10
Configuration checklist for server components on the z/OS system .......... 12
Testing checklist for server components on the z/OS system ................. 14
Installation and configuration checklist for Windows components ........ 14
Checklist for installing IBM Cognos Mobile on z/OS to an existing IBM Cognos BI instance ................................................................. 15

**Chapter 3. Overview: IBM Cognos Business Intelligence for z/OS installations** ...................................................... 17

**Chapter 4. Installation planning for the IBM Cognos BI server components on the z/OS system** ...................................................... 19
IBM Cognos Business Intelligence installations .................................. 19
Base installation software components .......................................... 19
Optional software components ..................................................... 20
Capacity planning for z/OS installations ........................................ 21
Reviewing software and hardware requirements for z/OS components ......... 22
Memory settings ................................................................. 24
Verifying supported software versions and hardware requirements .......... 24
Product data sets ....................................................................... 25
Use of the Cognos Content Database as the content store .................... 26

**Chapter 5. Preparation of the z/OS system for installation** ...................................................... 29
User accounts for the installation and running the product ..................... 29
Verifying user account settings .................................................... 30
Environment variables settings on the z/OS system ............................. 30
Use of z/OS UNIX System Services shells to set environment variables ........ 32
Using a .tcshrc file to set environment variables ................................ 33
Edit your .profile file to set environment variables ............................ 34

© Copyright IBM Corp. 2011, 2013
| Verifying environment variable settings                      | 35 |
| Guidelines for initial settings for DB2 subsystems          | 36 |
| Setting initialization parameters for z/OS UNIX System Services | 37 |

### Chapter 6. Installation of IBM Cognos BI components on the z/OS system

1. IBM Custom-Build Product Delivery Offering
   - The IBM Cognos BI for z/OS Program Directory
   - Product file system
2. Manually mounting the IBM Cognos BI server target file system
3. Response files
   - Modifying a response file
   - Running the IBM Cognos installation program in silent mode
4. Installing IBM Cognos Mobile
   - Add a base installation for IBM Cognos Mobile
   - Generate and modify the response file for IBM Cognos Mobile
   - Install IBM Cognos Mobile in silent mode
5. Verifying the installation of IBM Cognos server components and file permissions
6. Adding server components to an existing installation on the z/OS system
7. Uninstalling IBM Cognos BI server components on the z/OS system

### Chapter 7. Post-installation tasks on the z/OS UNIX System Services

1. Updating the Java environment on the z/OS system after installation
2. Configuring an X Windows System for remote access
3. Starting IBM Cognos Configuration on z/OS UNIX System Services
4. Content store database
   - Creating a content store database on DB2 for z/OS
   - Creating tablespaces for a content store on DB2 for z/OS
   - Setting up connectivity for the content store database
   - Verifying JDBC connectivity to the content store
5. IBM Cognos Mobile database
   - Creating tablespaces for the Cognos Mobile database on DB2 for z/OS
6. Setting up JDBC connectivity to relational databases
7. IBM Cognos Business Intelligence for z/OS and the IBM Sub-Capacity Reporting Tool

### Chapter 8. Configuration of the IBM Cognos BI components on the z/OS system after installation

1. Basic installations
2. Configuration changes

### Chapter 9. Configuration considerations for deploying IBM Cognos BI for z/OS to WebSphere Application Server

1. Web communication in an application server environment
2. Adjusting the default connection time-out value for IBM Cognos Business Intelligence
3. Configuration tasks in IBM Cognos Configuration
   - Creating the application files to deploy to WebSphere Application Server
   - Changing the IBM Cognos server configuration properties
   - Configuring the connection to a DB2 content store database for WebSphere Application Server
   - Configure a connection to the IBM Cognos Mobile database
   - Configuring a connection to a mail server for WebSphere Application Server
   - Configuring a servlet gateway
4. Creating a separate JVM instance in IBM WebSphere
5. Setting environment variables to run IBM Cognos BI in WebSphere Application Server
6. Verifying environment variable settings configured in WebSphere Application server
7. Registering Cognos Business Intelligence applications in WebSphere Application Server
8. Configuring WebSphere Application Server properties
9. Connecting to the IBM Cognos BI portal after deploying to WebSphere Application Server
10. Unregistering dispatchers
Chapter 10. Configuration tasks for deploying IBM Cognos BI for z/OS to Apache

Tomcat servlet container ......................................................... 83
  Configuring IBM HTTP Web Server to view IBM Cognos BI static content .................. 83
  Configuring IBM Cognos server components to run in Tomcat servlet container .......... 84
    Configuring the connection to a DB2 content store database for Tomcat servlet container ................................................................. 85
    Configure a connection to the IBM Cognos Mobile database ............................................ 86
    Configuring a connection to a mail server for Tomcat servlet container ...................... 87
    Configuring the connection to the Cognos Content Database ........................................ 87
    Starting the IBM Cognos services .................................................................................. 88
  Verifying the installation and configuration of server components in Tomcat servlet container ................................................................. 88
  Changing the deployment from Tomcat servlet container to WebSphere Application Server ... 89
  Adjusting the memory resources for the IBM Cognos service ........................................ 90

Chapter 11. Multiple instances of server components ............................................ 91
  Content Manager configurations .................................................................................. 91
    Active and standby Content Manager instances .......................................................... 92
    Configuring the connection to a DB2 content store database for each Content Manager instance ................................................................. 92
    Configuring environment properties for the default active Content Manager instance ........ 94
    Configuring environment properties for the standby Content Manager instances ............ 95
    Starting multiple Content Manager instances ............................................................. 95
    Configuring environment properties for multiple instances of Application Tier Components ................................................................. 96
  Configuring the gateway for multiple server instances .................................................. 97
  Configuring multiple instances of the index services for index search ......................... 98

Chapter 12. Installation of Windows components .................................................... 99
  Reviewing the hardware and software requirements for Windows components ................ 99
  Installing Cognos Framework Manager on a Windows computer ................................ 100
    Default settings for Cognos Framework Manager ..................................................... 101
    Configuring Cognos Framework Manager to communicate with server components on the z/OS system ................................................................. 101
    Testing the Cognos Framework Manager installation ................................................. 102
  Installing IBM Cognos Cube Designer ..................................................................... 102
  Installing Cognos Insight from Cognos Connection ................................................. 103
  Installing the Cognos Transformer client on a Windows computer ................................ 104
    Default settings for the Cognos Transformer client ................................................ 105
    Configuring the Cognos Transformer client to communicate with server components on z/OS ................................................................. 105
    Testing the Cognos Transformer client installation .................................................. 106
  Installing the IBM Cognos Software Development Kit on Cognos Framework Manager computers ................................................................. 107
  Installing the translated product documentation on Windows computers .................... 108
  Uninstalling Windows components ............................................................................. 108

Chapter 13. Optional configuration tasks for Framework Manager ................................ 111
  Updating the file location properties for Cognos Framework Manager on Windows Vista computers ................................................................. 111
  Updating the Cognos Transformer sample preferences file for Windows Vista computers ................................................................. 112
  Creating a network installation location for Cognos Transformer modelers .................. 113
    Exporting IBM Cognos Transformer configuration files ............................................ 114
    Deploying Cognos Transformer to modelers .............................................................. 114

Chapter 14. Configuration options and examples for server components .................... 117
  Creating tablespaces for a notification database on DB2 for z/OS ............................... 117
  Configuring IBM Cognos Dynamic Cubes installation on the z/OS system .................... 118
  Changing default configuration settings ................................................................... 119
    Structure of URI settings ......................................................................................... 119
    Configuring the location for report output ................................................................ 121
    Changing the location of map charts for IBM Cognos Report Studio ....................... 122
    Cookie settings used by the IBM Cognos components ............................................. 122
    Internet Protocol versions ...................................................................................... 123
    Enabling the IPv6 option when starting IBM Cognos Configuration ....................... 124
    Creating another instance of Cognos Content Database ......................................... 124
    Fonts in PDF and HTML report ............................................................................. 126
      Adding fonts ........................................................................................................ 126

Contents

v
Chapter 15. Configuration requirements for authentication providers .......................... 153
Disabling anonymous access ................................................................................. 153
Restricting user access to the Cognos namespace .............................................. 154
Configuration requirements for LDAP ............................................................... 155
  Configuring an LDAP namespace using a template ....................................... 155
  LDAP mapping .................................................................................................. 155
  Configuring an LDAP namespace ................................................................... 156
  Configuring an LDAP namespace for an IBM Directory Server ....................... 157
  Configuring custom user properties for an LDAP namespace ....................... 159
  Enabling secure communication to an LDAP server ..................................... 159
  Single signon between an LDAP server and IBM Cognos BI components ...... 160
  Replace operation ............................................................................................ 161
Custom authentication provider configuration requirements ............................. 161
  Configuring a namespace for a custom authentication provider .................... 162
RACF authentication requirements ....................................................................... 163
  Configuring a RACF namespace .................................................................... 163
  Enabling single signon between RACF and IBM Cognos BI components ...... 164
  Deleting an authentication provider ............................................................... 164

Chapter 16. IBM Cognos Workspace configuration .............................................. 167
Testing IBM Cognos Workspace ........................................................................ 167
Configuring access to IBM Cognos Workspace ................................................ 167
Human tasks and annotation services database ............................................... 168
  Creating a human tasks and annotation database on DB2 for z/OS .............. 168
  Creating tablespaces for the human task and annotation database on DB2 on z/OS 169
Index .................................... 221
Introduction

This document is intended for use with IBM® Cognos® Business Intelligence for
z/OS®. The information includes planning, preparing for, completing, and
maintaining product installations, configuring the product after installation, setting
up samples, and some troubleshooting tips and techniques.

Audience

The following are the recommended skills necessary to support a basic
configuration:

- z/OS UNIX System Services (USS)
- SMP/E and JCL
- Secure Sockets Layer (SSL) to enable security if desired
- Access to a DB2® database administrator who can create the content store
database and if desired, the samples database.
- Security Server (RACF®), to authenticate IBM Cognos BI for z/OS clients and
  servers, and authorize access to resources

Related documentation

Our documentation includes user guides, getting started guides, new features
guides, release notes, and other materials to meet the needs of our varied audience.

Documentation is available on the z/OS basic skills information center
(publib.boulder.ibm.com/infocenter/zos/basics).

Finding Information

Product documentation is available with the product, in Information Centers, and
in techdocs.

To find the most current product documentation, including all translated
documentation, access the IBM Cognos Information Center (pic.dhe.ibm.com/
infocenter/cbi/v10r2m0).

You can also read PDF versions of the product online help files by clicking the
PDF links at the top of each HTML page, or access the PDFs from the IBM Cognos
product documentation web page (www.ibm.com/support/
docview.wss?uid=swg27024067).

IBM Cognos Software Development Kit product documentation

After you install the IBM Cognos Software Development Kit, developer
documentation is available from within the product.

You can access the documentation by the following methods:

- On Cognos Framework Manager computers, from the Start menu, click the IBM
  Cognos documentation shortcut folder.
- In Cognos Administration, click Help > More Documentation, and under Product Documentation you can open IBM Cognos Software Development Kit documents in PDF or HTML format.
- In the language directory of your installation. For example, c10_location/webcontent/documentation/en directory.

The following documentation is available:

<table>
<thead>
<tr>
<th>Documentation title</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM Cognos Software Development Kit Developer Guide (dg_sdk.pdf)</td>
<td>Managing IBM Cognos processes and implementing custom reporting solutions by using a collection of cross-platform web services, libraries, and programming interfaces provided with the IBM Cognos Software Development Kit</td>
</tr>
<tr>
<td>Framework Manager Developer Guide (dg_fm_sdk.pdf)</td>
<td>Creating and publishing models using the Cognos Framework Manager API</td>
</tr>
<tr>
<td>Mashup Service Developer Guide (dg_cms.pdf)</td>
<td>Developing applications with the IBM Cognos Mashup Service that expose IBM Cognos outputs, such as reports and analyses, as web services (both SOAP and REST)</td>
</tr>
<tr>
<td>IBM Cognos Custom Authentication Provider Developer Guide (dg_auth.pdf)</td>
<td>Creating a custom authentication provider or a trusted signon provider using the Custom Authentication Provider API</td>
</tr>
</tbody>
</table>

**Accessibility features**

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products.

The IBM Cognos installation program and IBM Cognos Configuration have accessibility features. For information on these features, see the Appendix A, “Accessibility features,” on page 183 section in this document.

IBM Cognos HTML documentation has accessibility features. PDF documents are supplemental and, as such, include no added accessibility features.

**Forward-looking statements**

This documentation describes the current functionality of the product. References to items that are not currently available may be included. No implication of any future availability should be inferred. Any such references are not a commitment, promise, or legal obligation to deliver any material, code, or functionality. The development, release, and timing of features or functionality remain at the sole discretion of IBM.

**Samples disclaimer**

The Great Outdoors Company, GO Sales, any variation of the Great Outdoors name, and Planning Sample depict fictitious business operations with sample data used to develop sample applications for IBM and IBM customers. These fictitious records include sample data for sales transactions, product distribution, finance, and human resources. Any resemblance to actual names, addresses, contact
numbers, or transaction values is coincidental. Other sample files may contain fictional data manually or machine generated, factual data compiled from academic or public sources, or data used with permission of the copyright holder, for use as sample data to develop sample applications. Product names referenced may be the trademarks of their respective owners. Unauthorized duplication is prohibited.
Chapter 1. What's New?

This section contains a list of new, changed, deprecated, and removed features that affect installation and configuration for this release. It helps you plan your upgrade and application deployment strategies and the training requirements for your users.

For information about upgrading, see the Installation and Configuration Guide for your product.

For information about other new features for this release, see the New Features Guide.

To review an up-to-date list of environments supported by IBM Cognos products, such as operating systems, patches, browsers, Web servers, database servers, and application servers, visit the Cognos Customer Center web site (http://www.ibm.com/software/data/cognos/customercenter).

New features in version 10.2.0

The following topics describe the new features for IBM Cognos Business Intelligence for z/OS version 10.2.0.

IBM Cognos Mobile available for IBM BI for z/OS

IBM Cognos Mobile is available for installation with IBM Cognos Business Intelligence on the z/OS operating system.

IBM Cognos Mobile extends your existing Cognos BI installation so that users can view and interact with IBM Cognos BI reports on their tablet computers or smartphone devices, including the Apple iPhone and the Research in Motion BlackBerry.

Related concepts:
- [Installing IBM Cognos Mobile](#) on page 49
- IBM Cognos Mobile must be installed to the same location as IBM Cognos Business Intelligence server.

IBM Cognos Workspace installed with IBM BI Server

IBM Cognos Workspace is included with IBM Cognos Business Intelligence server.

IBM Cognos Workspace allows you to quickly and easily assemble interactive workspaces using IBM Cognos content or external data sources. After you test that Cognos Workspace is running, configure access to the secured functions and features.
IBM Cognos Workspace is installed with IBM Cognos BI Server. After installation, some configuration is required. In addition, you can do optional configuration tasks.

**IBM Cognos Connection Installer for Cognos Insight**

Use IBM Cognos Connection Installer for Cognos Insight to install provisioning software on Cognos Business Intelligence servers. Multiple users can then install Cognos Insight on their computers from the Cognos Business Intelligence interface.

Users who are assigned the Enhanced Consumer role by the Cognos BI administrator can install Cognos Insight to their computers from Cognos Connection.

With IBM Cognos Insight, you can analyze data, explore scenarios, and influence decisions by creating managed workspaces. Use these interactive workspaces to communicate results to managers. Because Cognos Insight supports write-back, you can also use these workspaces to gather and consolidate management targets, commitments, and forecasts.

**Related tasks:**

- "Running the IBM Cognos installation program in silent mode" on page 46
  Run the IBM Cognos installer in silent mode. Record the answers to the installation options in the response file.
- "Installing Cognos Insight from Cognos Connection" on page 103
  End users can install IBM Cognos Insight on their computers from the Welcome to IBM Cognos software page. Cognos Insight starts after the installation has completed.

**64-bit IBM Cognos gateway**

In earlier versions, if you installed 64-bit versions of IBM Cognos Business Intelligence, only 32-bit versions of the gateway component were available. In this version, 64-bit versions of the gateway are also available. You can take advantage of the 64-bit hardware and the new 64-bit libraries.

When you configure the web server to view static IBM Cognos content, additional configuration is required to use the 64-bit libraries.

**Related tasks:**

- "Configuring IBM HTTP Web Server to view IBM Cognos BI static content" on page 83
  To view IBM Cognos BI web pages, you configure virtual directories on the web server. To use the 64-bit version of the IBM Cognos BI gateway, use a script to copy the required files.

**IBM Cognos Dynamic Cubes installation**

IBM Dynamic Cubes are databases optimized to provide high speed query performance over large data sets of metadata for business intelligence reporting and analysis.

In IBM Cognos Configuration, enable the 64-bit version of the report server. Install the IBM Dynamic Cubes Designer software in the same location as Framework Manager.
Related tasks:

“Configuring IBM Cognos Dynamic Cubes installation on the z/OS system” on page 118

To use IBM Cognos Dynamic Cubes, select the 64-bit version for the report server execution mode for the Application Tier Components. Install IBM Cognos Dynamic Query Analyzer on a Windows computer and configure it to communicate with the IBM Cognos Business Intelligence server components on the z/OS system.

“Installing IBM Cognos Cube Designer” on page 102

Install IBM Cognos Cube Designer in the same location as IBM Cognos Framework Manager. The IBM Cognos Cube Designer is the application that you use to model dimensional metadata and dynamic cubes.

IBM Cognos Dynamic Query Analyzer

IBM Cognos Dynamic Query Analyzer (DQA) provides a graphical interface for the execution tree logs produced by the dynamic query mode queries.

DQA allows a report administrator to easily identify all the individual pieces of a dynamic query mode query and allows you to troubleshoot your query performance.

To use DQA, install it on the Linux operating system or on a Windows computer. Then, configure DQA to communicate with the IBM Cognos server components on the z/OS system.

Related tasks:

“Configuring IBM Cognos Dynamic Cubes installation on the z/OS system” on page 118

To use IBM Cognos Dynamic Cubes, select the 64-bit version for the report server execution mode for the Application Tier Components. Install IBM Cognos Dynamic Query Analyzer on a Windows computer and configure it to communicate with the IBM Cognos Business Intelligence server components on the z/OS system.

Predefined LDAP authentication namespace configurations

In IBM Cognos Configuration, you can easily configure an LDAP namespace for IBM Cognos components by selecting a template for an LDAP provider.

Related tasks:

“Configuring an LDAP namespace using a template” on page 155

To easily configure an LDAP namespace, choose from a set of pre-configured templates for each type of LDAP authentication provider.

Configuration of multi-tenant applications in IBM Cognos Configuration

You can use new properties in IBM Cognos Configuration to configure Business Intelligence environments supporting multi-tenant applications.

Depending on your environment, you can apply the multitenancy.TenantPattern or multitenancy.ITenantProvider advanced properties to individual namespaces or to all namespaces in your environment.
Option to view the status of silent installations on the screen

You can use the -displayLog option to view the status of the silent installation on the screen.

For example, the following command runs the installation program in silent mode. The installation program uses the test.ats as the response file and displays the status of the installation on the screen.

```
./isssetup -s test.ats -displayLog
```

Related tasks:

- "Running the IBM Cognos installation program in silent mode" on page 46
  Run the IBM Cognos installer in silent mode. Record the answers to the installation options in the response file.

Option to initialize Cognos Configuration from a different file

You can use the -startupfile path/filename.xml option to specify a startup file other than the cogstartup.xml file when starting the IBM Cognos configuration tool.

The cogstartup.xml file must still exist in the Configuration directory.

For example, the following command runs the installation program in silent mode using the test.xml file located in the Configuration directory to set the configuration parameters.

```
cogconfig.sh -s -startupfile <c10_location>/configuration/test.xml
```

Related concepts:

- Appendix B, “IBM Cognos Configuration command-line options,” on page 185
  Use command-line options with the configuration command to modify the behavior of IBM Cognos Configuration when it starts.

IBM Cognos content archival

Use IBM Cognos content archival to store report output versions and their source report specifications to an external content archival repository.

Related concepts:

- “IBM Cognos content archival configuration” on page 142
  To enhance system performance and extend scalability, use IBM Cognos content archival to store report output versions and their source report specifications to your file system. Archiving reduces the size of the content store database.

JDBC connectivity to data sources and the dynamic query mode

You can connect to supported data sources by using Java Database Connectivity (JDBC) connectivity. When you use JDBC connectivity, the dynamic query mode is available and provides query optimization and improved performance.

Before you can use the dynamic query mode, some configuration is required.
For IBM Cognos Business Intelligence on z/OS, you must use the dynamic query mode to connect to relational databases. Install type 4 JDBC drivers in each location where the Application Tier Components are installed. Alternatively, you can modify a configuration file to point to the JDBC driver files.

**Index search capabilities**

Index search capability is now the default search mode in the IBM Cognos Business Intelligence server product. However, some configuration is required to enable index services and to configure scalability. You must create the index before using the index search capability.

For information about creating the index and about configuring user permissions for index search, see the Administration and Security Guide.

**Interactive dashboards merged with IBM Cognos Viewer features**

An interactive dashboard is available when you install the Cognos Business Intelligence Server.

The dashboard and IBM Cognos Viewer features are now merged into one user interface.

---

**Changed Features in Version 10.2.0**

The following topics describe changes to features since the last release.

**Changes to the default installation location and the web alias**

Changes to the installation location and the web alias might affect upgrade strategies.

The default installation location is represented by `c10_location`.

For components installed on Windows computers, the default location is `C:\Program Files\IBM\cognos\c10`.

For server components installed on UNIX System Services, the default location to which the product will be installed after running the installation program is `/pathprefix/usr/lpp/cognos/HCGCA20/IBM`.

The default Web alias in IBM Cognos Configuration is changed from `cognos8` to `ibmcognos`.

**Changes to the FMIDs**

One FMID is used to install IBM Cognos Business Intelligence for z/OS software components.
The SMP/E utility is used to install and maintain software on your z/OS system.

During the first part of the installation process, you use the SMP/E utility to install the product onto the z/OS UNIX System Services system.

There are six installation kits included in one Functional Modifier Identifiers (FMID). Install the HCGCA20 FMID by using the SMP/E utility.

**Related concepts:**

[Chapter 6, “Installation of IBM Cognos BI components on the z/OS system,” on page 41](#)

A complete installation on the z/OS system requires two distinct programs. Use the SMP/E (System Modification Program Extended) installation program to install the IBM Cognos Business Intelligence server components on the z/OS system. Then, to finish installing the components into the locations from which they run, use the IBM Cognos installer.

**Enhanced support for RACF authentication provider**

In earlier releases, if you wanted to use a Resource Access Control Facility (RACF) provider for authentication, you created a custom Java™ provider namespace. In IBM Cognos BI server, version 10.2.0, you can configure a RACF namespace directly in IBM Cognos Configuration.

**Related tasks:**

[“Configuring a RACF namespace” on page 163](#)

Use IBM Cognos Configuration to configure a Resource Access Control Facility (RACF) namespace for authentication.

**Secure access when monitoring system metrics externally**

In earlier releases, it was possible for you to monitor system metrics externally by using Java Management Extensions (JMX). IBM Cognos Configuration now provides two new properties that you can use for secure access to the metrics in the Java environment.

**Related tasks:**

[“Monitoring system metrics with JMX” on page 180](#)

You can monitor system metrics outside of IBM Cognos Administration by using industry standard Java Management Extensions (JMX).
Chapter 2. Quick reference: installation checklist

Use the installation checklist as a quick reference for required installation tasks.

Preinstallation checklist

Before you install the product, plan your infrastructure and prepare the z/OS system:

- **Plan the installation architecture**
  Review the “IBM Cognos Business Intelligence installations” on page 19 to understand the base components and optional functions, and to determine where to install them.

- **Review minimum hardware requirements**

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system</td>
<td>z/OS</td>
</tr>
<tr>
<td></td>
<td>z/OS UNIX System Services (z/OS UNIX) with an HFS or ZFS file system</td>
</tr>
<tr>
<td>Number of central processors</td>
<td>Minimum: 2</td>
</tr>
<tr>
<td>Disk space</td>
<td>See the Program Directory for disk space requirements</td>
</tr>
<tr>
<td></td>
<td>Allocate enough disk space for the installation files, temp, and logs directories. Because the directories under the main installation directory can be mounted to different volumes, ensure that each mounted directory has sufficient free disk space.</td>
</tr>
<tr>
<td></td>
<td>Allocate an additional 20% disk space to allow for growth for temp and log files.</td>
</tr>
<tr>
<td></td>
<td>Allocate enough disk space for the WebSphere® Application Server profile directory. The directory must accommodate at least 500 MB for the deployment of IBM Cognos web content files.</td>
</tr>
</tbody>
</table>

- **Review mandatory prerequisite software requirements**

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Java Runtime Environment (JRE)</td>
<td>If you are using WebSphere Application Server, use the JRE that is installed with it, if it is supported in IBM Cognos.</td>
</tr>
<tr>
<td>Web browser</td>
<td>For all supported web browsers, the following are enabled:</td>
</tr>
<tr>
<td></td>
<td>• cookies</td>
</tr>
<tr>
<td></td>
<td>• JavaScript</td>
</tr>
</tbody>
</table>
Table 3. Mandatory software requirements for IBM Cognos BI server components (continued)

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database (content store)</td>
<td>You must have one of the following databases available to store IBM Cognos data:</td>
</tr>
<tr>
<td></td>
<td>• IBM DB2 for z/OS</td>
</tr>
<tr>
<td></td>
<td>The database must be configured to use a Unicode character set.</td>
</tr>
<tr>
<td></td>
<td>• Cognos Content Database</td>
</tr>
<tr>
<td></td>
<td>Cognos Content Database is available with the product, but is not automatically installed during customization unless specified in the response.ats file.</td>
</tr>
</tbody>
</table>

Review optional software requirements.

Table 4. Optional software requirements

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web server</td>
<td>IBM HTTP Server</td>
</tr>
<tr>
<td>Application server</td>
<td>WebSphere Application Server (requires 64-bit single servant deployment)</td>
</tr>
<tr>
<td>Database (query)</td>
<td>IBM DB2 for z/OS</td>
</tr>
<tr>
<td></td>
<td>The query database must be installed in the same sysplex as IBM Cognos BI Server. Additional DB2 setup is required if the query database is located on a separate LPAR than IBM Cognos BI Server (Application Tier Components).</td>
</tr>
<tr>
<td>Database (IBM Cognos product samples)</td>
<td>IBM DB2 for z/OS</td>
</tr>
<tr>
<td>LDAP version 3 compliant</td>
<td>IBM Tivoli® Directory Server</td>
</tr>
<tr>
<td></td>
<td>By default IBM Cognos BI for z/OS is installed with anonymous access enabled.</td>
</tr>
<tr>
<td>Mail server</td>
<td>Required for notifications.</td>
</tr>
<tr>
<td></td>
<td>Must be accessible through a firewall.</td>
</tr>
<tr>
<td></td>
<td>The z/OS system administration must configure the firewall to enable SMTP traffic between the IBM Cognos BI server and the mail server that is used for Notifications.</td>
</tr>
</tbody>
</table>

Create an installation user account.

Ensure that the user account has full access permissions for the IBM Cognos Business Intelligence installation. If using WebSphere Application Server, this group must contain the user that starts the application server and the user that owns the IBM BI files.

For simplicity, you can also use the application server user account to install and run IBM Cognos components.

Table 5. Summary of user accounts and description of the accounts

<table>
<thead>
<tr>
<th>User account</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installer user account for IBM Cognos</td>
<td>This account owns the IBM Cognos installation files.</td>
</tr>
</tbody>
</table>
Table 5. Summary of user accounts and description of the accounts (continued)

<table>
<thead>
<tr>
<th>User account</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User account that runs IBM Cognos BI for z/OS</td>
<td>This account must be granted the privilege to run programs that use the DSNACLI plan.</td>
</tr>
<tr>
<td>User account that will run the application server</td>
<td>The user that starts the application server and the user that owns the IBM Cognos files must belong to the same group.</td>
</tr>
</tbody>
</table>

- Set the environment variables on the z/OS system.

Table 6. List of preinstallation environment variables for IBM Cognos BI for z/OS

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Values or examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>_BPXK_AUTOCVT</td>
<td>ON</td>
<td>This runtime environment variable must be set to ON to automatically convert ASCII-tagged files to EBCDIC as the IBM Cognos installer reads the files.</td>
</tr>
<tr>
<td>_CEE_RUNOPTS</td>
<td>POSIX(ON), FILETAG(AUTOCVT,AUTOTAG)</td>
<td>Set this variable for the IBM Cognos installer which creates files that must be tagged properly.</td>
</tr>
<tr>
<td>JAVA_HOME</td>
<td>${WASHOME}/java64</td>
<td>Points to the installation location of your Java Runtime Environment (JRE). For example, if you are using WebSphere Application Server, set the JAVA_HOME environment variable to use the JVM that is provided with WebSphere Application Server.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The IBM Cognos installer requires the x1m_31d11 file.</td>
</tr>
<tr>
<td>PATH</td>
<td>$JAVA_HOME/bin</td>
<td></td>
</tr>
<tr>
<td>LIBPATH</td>
<td>/usr/lib:${LIBPATH}</td>
<td></td>
</tr>
<tr>
<td>JDBC connectivity</td>
<td>JDBC variables</td>
<td>Set these environment variables to enable JDBC connectivity to the DB2 content store. If applicable, set in the servant region in the WebSphere administrative console.</td>
</tr>
<tr>
<td></td>
<td>$[DB2HOME]/db2910_jdbc</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$[JDBCHOME]/classes</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$CLASSPATH: $[JDBCCLASSES]/db2jccjavax.jar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$CLASSPATH: $[JDBCCLASSES]/db2jcc4.jar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$CLASSPATH: $[JDBCCLASSES]/db2jcc_license_cisuz.jar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$CLASSPATH: $[JDBCCLASSES]/sqlj4.zip</td>
<td></td>
</tr>
</tbody>
</table>
Table 6. List of preinstallation environment variables for IBM Cognos BI for z/OS (continued)

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Values or examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ODBC connectivity</td>
<td>ODBC variables</td>
<td>Set ODBC environment variables to enable your system to use the DB2 command line processor and to specify the location of the DB2 ODBC initialization file. If applicable, set in the servant region in the WebSphere administrative console.</td>
</tr>
<tr>
<td>• DSNAOINI</td>
<td>/u/user1/db2odbc/odbcini</td>
<td></td>
</tr>
<tr>
<td>• STEPLIB</td>
<td>prefix.SDSNEXIT:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>prefix.SDSNLOAD:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>prefix.SDSNL002</td>
<td></td>
</tr>
<tr>
<td>Note:</td>
<td>The line continuation for this value.</td>
<td></td>
</tr>
</tbody>
</table>

__• Verify user account settings and __verify environment variable settings

Installation checklist

You install server components on the z/OS system and modeling components on Microsoft Windows computers. You can install optional components on both systems:

__• Locate the Program Directory.
 __• Use the SMP/E installation program to install the base and optional components on the z/OS system.
 __• Modify the /pathprefix/usr/lpp/ibm/cognos/BI_installer_10.2.1/response.ats file to record your installation choices.
 __• Use the IBM Cognos installation program to complete the installation by running the ./issetup -s location/response.ats command.
 __• Verify the installation of the z/OS components and the file permissions

Post-installation checklist

Set up your environment after installation and before you configure product components:

Creating DB2 tablespaces for the content store database

__• If using DB2 on z/OS for the content store database, create a content store in DB2 for z/OS. The database must have a buffer pool with a page size of 32 KB, and a second one with a page size of 16 KB for the database instance.

__• For a DB2 content store, create tablespace for a DB2 content store on the z/OS system by running the c10_location/configuration/schemas/content/db2z0s/tablespace_db2z0s.sql script and the following table to help you to replace the generic parameters with ones appropriate for your environment.

Table 7. Parameter names and description for the content store tablespace script

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_STOGROUP</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>CMSCRIPT_DATABASE</td>
<td>Specifies the name of the content store database.</td>
</tr>
</tbody>
</table>
Table 7. Parameter names and description for the content store tablespace script (continued)

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_CS_ID</td>
<td>Specifies the subsystem identification for the content store database. The ID must not be longer than 2 characters.</td>
</tr>
<tr>
<td>CMSCRIPT_TABLESPACE</td>
<td>Specifies the name of the tablespace that contains all of the base tables in the content store. Auxiliary tables are not included. The name cannot be longer than 6 characters.</td>
</tr>
<tr>
<td>CMSCRIPT_LARGE_BP</td>
<td>Specifies the name of the large buffer pool allocated for especially large objects. This bufferpool is the 32 KB buffer pool that was created when the database administrator created the content store database on the z/OS system.</td>
</tr>
<tr>
<td>CMSCRIPT_REGULAR_BP</td>
<td>Specifies the name of the regular size buffer pool allocated for regular and large objects. This bufferpool is the 16 KB buffer pool that was created when the database administrator created the content store database on the z/OS system.</td>
</tr>
<tr>
<td>CMSCRIPT_USERNAME</td>
<td>Specifies the user account that accesses the content store database.</td>
</tr>
</tbody>
</table>

• Edit then run the c10_location/configuration/schemas/content/db2zOS/rightsGrant_db2zOS.sql script file by replacing the generic parameters with ones appropriate for your environment.

• Edit and then run the c10_location/configuration/schemas/delivery/zosdb2/NC_TABLESPACES.sql script file by using the following table to replace the generic parameters with ones appropriate for your environment.

Table 8. Tablespace parameter names and descriptions for the DB2 notification database on z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCCOG</td>
<td>Specifies the name of the notification database.</td>
</tr>
<tr>
<td>DSN8G810</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>Specifies the name of the buffer pool.</td>
</tr>
</tbody>
</table>

• Edit and then run the c10_location/configuration/schemas/hts/zosdb2/HTS_tablespaces.sql script file by using the following table to replace the generic parameters with ones appropriate for your environment.

Table 9. Tablespace parameter names and descriptions for human tasks on DB2 for z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCCOG</td>
<td>Specifies the name of the database.</td>
</tr>
<tr>
<td>DSN8G810</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>Specifies name of the 32 k buffer pool.</td>
</tr>
</tbody>
</table>

• Edit and then run the HTS2_CREATE_Db2zos.sql script file.
**Setting up JDBC connections to data sources**

- Edit and then run the `c10_location/configuration/schemas/ans/zosdb2/ANN_TABLESPACES.sql` script file.
- Edit and run the `ANS2_CREATE_Db2zos.sql` script file.
- For a DB2 content store, copy or create a symbolic link for the JDBC driver and license files from the DB2 installation to the IBM Cognos BI installation.
- Verify JDBC connectivity to the content store.

**Configuration checklist for server components on the z/OS system**

Complete the mandatory configuration tasks before you customize the product installation to better suit your environment.

- **Configure an X Windows System for remote access**
  
  Set the following environment variable on z/OS: export 
  
  `DISPLAY=host_name:display_number`. The `host_name` is the IP address of the computer that will show the graphical user interface

- **Start Cognos Configuration**
  
  Go to the `c10_location/bin64` directory and type the following command:
  
  `./c10_location/bin64/cogconfig.sh`

- **Configure the connection to a DB2 content store database**
  
  In the Explorer panel, under Data Access, Content Manager, click Content Store and set the properties.
  
  In the Explorer panel, click Local Configuration, and add the following Advanced properties:

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Value (examples)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_CREATE_IN</td>
<td>COGUCST1.T1TSCS</td>
</tr>
<tr>
<td>CMSCRIPT_STOGROUP</td>
<td>DBOIUSR</td>
</tr>
<tr>
<td>CMSCRIPT_DATABASE</td>
<td>COGUCS</td>
</tr>
<tr>
<td>CMSCRIPT_CS_ID</td>
<td>T1</td>
</tr>
<tr>
<td>CMSCRIPT_TABLESPACE</td>
<td>TSCS</td>
</tr>
<tr>
<td>CMSCRIPT_LARGE_BP</td>
<td>BP32K</td>
</tr>
<tr>
<td>CMSCRIPT_REGULAR_BP</td>
<td>BP16K0</td>
</tr>
</tbody>
</table>

- **Configure environment properties**
  
  In the Explorer panel, click Environment. In the Properties panel, change the localhost portion of all URI properties to the host name or IP address of your IBM Cognos BI server.
Configure a connection to a mail server (to avoid warnings in IBM Cognos Configuration).

In the Explorer panel, under Data Access, click Notification. In the Properties panel, for the SMTP mail server property, type the host name and port of your SMTP (outgoing) mail server.

Configuring WebSphere Application Server

Configure IBM Cognos server components in IBM Cognos Configuration.

Create a single 64-bit servant instance for the IBM Cognos BI for z/OS application.

In the WebSphere administrative console Set environment variables to run IBM Cognos BI in WebSphere Application Server.

**Table 11. Environment variables for IBM Cognos Business Intelligence for z/OS**

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>_BPX_JOBNAME</td>
<td>CGC</td>
</tr>
<tr>
<td>_BPXK_AUTOCVT</td>
<td>ON</td>
</tr>
<tr>
<td>_CEE_RUNOPTS</td>
<td>POSIX(ON),FILETAG(AUTOCVT,AUTOTAG),HEAPPOLS(ALIGN),HEAPPOLS64(ALIGN)</td>
</tr>
<tr>
<td>Note:</td>
<td>The line continuation for this value.</td>
</tr>
<tr>
<td>STEPLIB</td>
<td>prefix.SDSNEXIT:prefix.SDSNLOAD:prefix.SDSNL0D2</td>
</tr>
<tr>
<td>DSNAOINI</td>
<td>/u/user1/db2odbc/odbcini</td>
</tr>
<tr>
<td></td>
<td>Specifies an ODBC initialization file for the ODBC subsystem (DSN) and plan (DSNACLI).</td>
</tr>
<tr>
<td>IBM_JAVA_ENABLE.ASCII_FILETAG</td>
<td>Set to ON because z/OS uses the EBCDIC character encoding and IBM Cognos BI Java applications use ASCII encoding.</td>
</tr>
<tr>
<td>LIBPATH</td>
<td>c10_location/bin64:c10_location/bin:/bin</td>
</tr>
<tr>
<td></td>
<td>Include the /bin directory to ensure keystores are tagged correctly at startup.</td>
</tr>
<tr>
<td>PATH</td>
<td>c10_location/bin64:c10_location/bin:/bin</td>
</tr>
<tr>
<td></td>
<td>Include the /bin directory to ensure keystores are tagged correctly at startup.</td>
</tr>
</tbody>
</table>

Configure WebSphere Application Server

Install a new Enterprise Application using the application file that was built by IBM Cognos Configuration (the default context root is p2pd).

Set the following properties:

**Table 12. Parameter settings and values**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>JVM heap size</td>
<td>greater than 256 MB</td>
</tr>
<tr>
<td>(-Xms)</td>
<td>756 MB</td>
</tr>
<tr>
<td>(-Xmx)</td>
<td>756 MB</td>
</tr>
</tbody>
</table>
Table 12. Parameter settings and values (continued)

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>In WebSphere Administration, in Environment &gt; Websphere variables</td>
<td>Create the following two WebSphere name-value pairs</td>
</tr>
<tr>
<td></td>
<td>• name=protocol_http_timeout_output_recovery</td>
</tr>
<tr>
<td></td>
<td>value=session</td>
</tr>
<tr>
<td></td>
<td>• name=protocol_https_timeout_output_recovery</td>
</tr>
<tr>
<td></td>
<td>value=session</td>
</tr>
</tbody>
</table>

- Set the minimum number of instances and the maximum number of instances for the IBM Cognos server instances to 1.
- Stop and then restart the WebSphere application server instance used for IBM Cognos BI components.

Testing checklist for server components on the z/OS system

Verify your installation and configuration of IBM Cognos BI server components by testing the installation and configuration:

- Use the Test feature in IBM Cognos Configuration as you configure components to ensure that the configuration is valid.
- Test that content store was successfully created and Content Manager started by opening a web browser and typing http://host_name:port/p2pd/servlet.
- Test the availability of the dispatcher by opening a web browser and typing http://host_name:port/p2pd/servlet/dispatch.
- Connect to the IBM Cognos portal by opening a web browser and typing http://host_name:port/ibmcognos if using a CGI gateway, or http://host_name:port/context_root/servlet/Gateway if using a servlet gateway.

Installation and configuration checklist for Windows components

Before you can create reports, you must install Cognos Framework Manager and use it to model and package your data:

- Review the hardware and software requirements for the Windows components.

Table 13. System requirements for Cognos Framework Manager

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system (32-bit)</td>
<td>Windows</td>
</tr>
<tr>
<td>Disk space</td>
<td>Minimum: 500 MB of free space on the drive that contains the temporary directory used by IBM Cognos Business Intelligence components</td>
</tr>
<tr>
<td>Database</td>
<td>If required, database client software installed on the same computer as Cognos Framework Manager</td>
</tr>
<tr>
<td></td>
<td>Database connectivity set up</td>
</tr>
</tbody>
</table>

- Use the installation wizard to install Cognos Framework Manager on a Windows computer.
- Configure Cognos Framework Manager to communicate with server components on the z/OS system.
Use IBM Cognos Configuration to configure the Gateway URI and the Dispatcher URI for external applications to ensure that Cognos Framework Manager can communicate with the IBM Cognos BI server components.

- Test the Cognos Framework Manager installation by starting IBM Cognos Framework Manager from the Windows shortcut menu.
  If you see the Welcome page of Cognos Framework Manager, your installation is working.

---

**Checklist for installing IBM Cognos Mobile on z/OS to an existing IBM Cognos BI instance**

You install IBM Cognos Mobile over an existing installation of IBM Cognos BI.

Use the following steps to install IBM Cognos Mobile on z/OS to an existing IBM Cognos BI instance:

- Stop your IBM Cognos BI services.
- Edit the `uninst.ini` file in your IBM Cognos BI installation directory to add a base installation value for IBM Cognos Mobile.
- Edit the response file to enable the IBM Cognos Mobile components for installation.
- Install IBM Cognos Mobile to the same location as your IBM Cognos BI server components.
- Run scripts to create the tablespaces for IBM Cognos Mobile in your content store database.
- Add the mobile database as a resource for IBM Cognos Mobile in IBM Cognos Configuration. If you are using the content store database, you must add the content store database as the mobile database.
- Restart your services.
  If you are using IBM WebSphere Application Server, you must generate a new EAR file, and redeploy IBM Cognos BI application.
Chapter 3. Overview: IBM Cognos Business Intelligence for z/OS installations

Follow these shortcuts to get a basic IBM Cognos Business Intelligence for z/OS installation working.

Procedure

1. Plan the installation of the server components on the z/OS system.
   a. Ensure that you meet the minimum software and hardware requirements for your target and distribution systems.
   b. Create user accounts for the installation and running the product
   c. Set environment variables

2. Install the required components, which includes installing the server components on the z/OS system and installing Cognos Framework Manager on a Windows computer.

   A basic installation includes required components that must be installed before your IBM Cognos BI for z/OS system is operational. The required components include: a gateway, Application Tier Components, Content Manager and Cognos Framework Manager. Other optional components, such as samples and Cognos Transformer can be added at the same time as the initial installation, or later, after your basic installation is running.
   a. Use the SMP/E to install the components on the z/OS UNIX system.
   b. Use the IBM Cognos installer and the response files to complete the installation of the IBM Cognos BI for z/OS components.

3. To provide communication between IBM Cognos components and other software, some post installation tasks on the z/OS system are required.

   After installation and before configuration, you must set up communication between the resources in your environment and IBM Cognos BI server components on z/OS.

4. Configure a basic installation so that the product runs.

   Very few configuration tasks are required to run a basic installation of IBM Cognos components. IBM Cognos must have access to the content store database. Additional, common tasks include enabling security and setting up a mail server account.

   You use the graphical user interface of IBM Cognos Configuration to interactively configure IBM Cognos components. Because this requires X server graphical display routine, you must have the X libraries installed on your z/OS system. You must be able to connect to an X server, a PC or UNIX system running the X server software. (The X server is the client and the X client is the z/OS server).

   IBM Cognos Configuration is a Java application that you use to configure both server components on the z/OS system and modeling component on Windows computers.

5. Test the installation.

   Use the test feature in the configuration tool to test connectivity to resources in your environment from IBM Cognos for z/OS components. You can also test the connection to the IBM Cognos components from the web by typing the
URL of the dispatcher and Content Manager. Also, if you can log on to access IBM Cognos Connection, your installation is working.

To help troubleshoot problems, test a basic installation to ensure that the product is working before you customize your settings.

6. Customize settings to leverage your corporate assets, improve performance, or enhance security

You can configure the product to use your existing corporate assets, such as your security providers, application servers, or portals. You can also tune it for better performance, and enhanced security.

What to do next

During the lifecycle of the product, you might be required to apply service. IBM provides the tool to help you keep your software up-to-date.
Chapter 4. Installation planning for the IBM Cognos BI server components on the z/OS system

The key to a successful installation is planning.

When installing IBM Cognos Business Intelligence for z/OS decide how you will install and configure it to provide the best possible performance. The installation and configuration choices that you make depend on your requirements, resources, and preferences.

IBM Cognos Business Intelligence installations

The simplest and quickest way to get IBM Cognos Business Intelligence for z/OS running in your environment is to ensure that a basic installation works before you add or configure optional components. A basic installation of IBM Cognos BI requires a web server, a content store, and IBM Cognos BI server components (gateway, application tier and Content Manager).

You can install all server components together on a single server or on multiple servers. However, you must install the Cognos Transformer utility for building PowerCubes in a different directory than the IBM Cognos BI server components.

Base installation software components

IBM Cognos BI for z/OS requires that you install at least once instance of each BI server component. You must install the IBM Cognos gateway, Application Tier Components, and Content Manager on the z/OS UNIX System. You must also install Cognos Framework Manager on a Windows computer.

The following diagram shows the mandatory installation components that comprise the base functionality of the product.
Optional software components

After you verify that the basic installation is working, you can add optional components to your system. You must install optional components in specific locations to ensure that the product works.

The following diagram shows optional components that you can install to extend the functionality of the product.
Capacity planning for z/OS installations

Planning for capacity on the z/OS system means determining the hardware needed for your system to perform well under its anticipated workload.

Capacity planning is the science of measuring known variables and developing an educated estimate of resource requirements on the basis of those measurements. It is also the art of allowing for unknown variables and assessing their impact on the estimates derived from the known variables.

To determine your requirements, work with your IBM Cognos representative to gather information about the following attributes:

- IBM Cognos users
  Estimate the number of IBM Cognos users that you expect to have, and when you expect them to use IBM Cognos Business Intelligence.
- Application complexity
Assess the complexity of the processing that your users will demand of IBM Cognos Business Intelligence.

- Your infrastructure
  The characteristics of your z/OS, Unix System Services, data source, application server, and security environments and infrastructure.

Capacity planning is an ongoing process. After implementing IBM Cognos Business Intelligence, monitor and modify your capacity as necessary to meet your performance expectations.

### Reviewing software and hardware requirements for z/OS components

Review the minimum hardware and prerequisite software requirements to install and run IBM Cognos Business Intelligence for z/OS on the mainframe computer. Additional resources might be required for larger or production environments.

### Before you begin


Review the release notes file in the IBM Cognos BI Information Center for details about late-breaking information about known issues.

### Procedure

1. Use the following table to check the minimum hardware requirements to install and run IBM Cognos BI components on the z/OS operating system. Additional resources may be required for production environments.

   **Table 14. Minimum hardware requirements for IBM Cognos BI server components**

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system</td>
<td>z/OS</td>
</tr>
<tr>
<td></td>
<td>z/OS UNIX System Services (z/OS UNIX) with an HFS or ZFS file system</td>
</tr>
<tr>
<td>Number of central processors</td>
<td>Minimum: 2</td>
</tr>
<tr>
<td>Disk space</td>
<td>See the Program Directory for disk space requirements</td>
</tr>
<tr>
<td></td>
<td>Allocate enough disk space for the installation files, temp, and logs directories. Because the directories under the main installation directory can be mounted to different volumes, ensure that each mounted directory has sufficient free disk space.</td>
</tr>
<tr>
<td></td>
<td>Allocate an additional 20% disk space to allow for growth for temp and log files.</td>
</tr>
<tr>
<td></td>
<td>Allocate enough disk space for the WebSphere Application Server profile directory. The directory must accommodate at least 500 MB for the deployment of IBM Cognos web content files.</td>
</tr>
</tbody>
</table>

2. Depending on the output you choose to produce, such as tracing, ensure that one of the following conditions are met:

   - Have sufficient spool space.
   - Direct output records to a dataset or USS (Unix System Services) file.
3. Use the following table to check the mandatory software requirements to install and run IBM Cognos BI target libraries on the z/OS operating system.

**Table 15. Mandatory software requirements for IBM Cognos BI server components**

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Java Runtime Environment (JRE)</td>
<td>If you are using WebSphere Application Server, use the JRE that is installed with it, if it is supported in IBM Cognos.</td>
</tr>
<tr>
<td>Web browser</td>
<td>For all supported web browsers, the following are enabled:</td>
</tr>
<tr>
<td></td>
<td>• cookies</td>
</tr>
<tr>
<td></td>
<td>• JavaScript</td>
</tr>
<tr>
<td>Database (content store)</td>
<td>You must have one of the following databases available to store IBM Cognos data:</td>
</tr>
<tr>
<td></td>
<td>• IBM DB2 for z/OS</td>
</tr>
<tr>
<td></td>
<td>The database must be configured to use a Unicode character set.</td>
</tr>
<tr>
<td></td>
<td>• Cognos Content Database</td>
</tr>
<tr>
<td></td>
<td>Cognos Content Database is available with the product, but is not automatically installed during customization unless specified in the response.ats file.</td>
</tr>
</tbody>
</table>

4. Use the following table to check the optional software requirements to install and run IBM Cognos BI for z/OS.

**Table 16. Optional software requirements**

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web server</td>
<td>IBM HTTP Server</td>
</tr>
<tr>
<td>Application server</td>
<td>WebSphere Application Server (requires 64-bit single servant deployment)</td>
</tr>
<tr>
<td>Database (query)</td>
<td>IBM DB2 for z/OS</td>
</tr>
<tr>
<td></td>
<td>The query database must be installed in the same sysplex as IBM Cognos BI Server. Additional DB2 setup is required if the query database is located on a separate LPAR than IBM Cognos BI Server (Application Tier Components).</td>
</tr>
<tr>
<td>Database (IBM Cognos product samples)</td>
<td>IBM DB2 for z/OS</td>
</tr>
<tr>
<td>LDAP version 3 compliant</td>
<td>IBM Tivoli Directory Server</td>
</tr>
<tr>
<td></td>
<td>By default IBM Cognos BI for z/OS is installed with anonymous access enabled.</td>
</tr>
<tr>
<td>Mail server</td>
<td>Required for notifications.</td>
</tr>
<tr>
<td></td>
<td>Must be accessible through a firewall.</td>
</tr>
<tr>
<td></td>
<td>The z/OS system administration must configure the firewall to enable SMTP traffic between the IBM Cognos BI server and the mail server that is used for Notifications.</td>
</tr>
</tbody>
</table>
Related tasks:

“Reviewing the hardware and software requirements for Windows components” on page 99

Before you install Windows components, ensure that you have adequate system resources in your environment for your models.

**Memory settings**

Memory settings depend on many factors, such as the level of activity expected on the server, the complexity of the IBM Cognos applications, the number of users and requests, and acceptable response times.

If your environment supports more than 100 named users, is complex, experiences high peak usage periods, or includes any combination of these factors, consider completing a capacity plan. For more information, see IBM Software Services for Cognos (http://www.ibm.com/software/analytics/cognos/services/).

To determine the settings that are best suited for your environment, performance testing is advised.

Use the following memory settings as a starting point and adjust them based on the memory usage of your system.

- 2 GB for the base operating system and accompanying software, such as antivirus, back up, and enterprise management software
- 4 GB for a 64-bit Content Manager JVM
- 4 GB for a 64-bit Application Tier JVM
- 2 GB for the graphics JVM (IBM Cognos Workspace)
- 2-4 GB for the query service (dynamic query mode) JVM
- 1 GB per core for the report services processes (dynamic query mode) (JVM)
- 2 GB per core for the report services processes (compatible query mode) (BlBuS)

The following table shows the suggested memory settings by architectural tier for a 64-bit operating system.

<table>
<thead>
<tr>
<th>Architectural Tier</th>
<th>Memory settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM Cognos Gateway Tier</td>
<td>2 GB</td>
</tr>
<tr>
<td>IBM Cognos Application Tier (compatible query mode)</td>
<td>2 GB per core</td>
</tr>
<tr>
<td>IBM Cognos Application Tier (dynamic query mode)</td>
<td>4 GB + 1 GB per core</td>
</tr>
<tr>
<td>IBM Cognos Content Manager Tier</td>
<td>4 GB</td>
</tr>
</tbody>
</table>

More resources might be required when installing additional software.

**Verifying supported software versions and hardware requirements**

To ensure that the correct supported software versions are available and that sufficient space is allocated for the IBM Cognos Business Intelligence server components, test the space allocations for IBM Cognos Business Intelligence and the target location for deployed applications and test the versions of the installed software.
**Procedure**

1. Ensure that the allocated disk space meets the requirements provided in the Program Directory, and allocate an additional 20% to allow for growth for temp and log files.
   - To list all mounted disks, type the following command:
     `df -k`
   - To provide details for a specific mount point, type the following command:
     `df -v mount_point`
   - To review volume information, in TSO/ISPF, type the following command:
     `LISTC ENT('HFS or zFS dataset') ALL`

2. The z/OS system administrator must allocate at least 500 MB for the deployment of IBM Cognos web content files to the WebSphere Application Server profile directory.

3. To verify if the appropriate updates have been applied to IBM DB2, you can use the following JCL job example against the SMPROC procedure.
   a. To verify that a particular SYSMOD has been applied, for example, to verify that APAR PK93123 and PTF UK52962 for IBM DB2 version 9 have been applied, you can use a JCL command like the following:
      ```
      //LIST JOB 'accounting info',MSGLEVEL=(1,1)
      //LIST EXEC SMPPROC
      //SMPCNTL DD *
      SET BDY(db2_target_data_set) /* Set to target zone. */.
      LIST
      SYMSMOD(UK52962) /* and this SYSMOD. */.
      /* */.
      /* */.
      ```
   b. To verify that an FMID has been installed for IBM DB2 version 9, you can use a JCL command like the following:
      ```
      //LIST JOB 'accounting info',MSGLEVEL=(1,1)
      //LIST EXEC SMPPROC
      //SMPCNTL DD *
      SET BDY(db2_target_data_set) /* Set to target zone. */.
      LIST
      FORFMID(HDB9910) /* and this FMID. */.
      /* */.
      /* */.
      ```

4. Log on to UNIX System Services as the user running the IBM Cognos application in WebSphere Application Server.
   a. Go to the `$/WASHOME/bin` directory.
   b. Type the following command:
      ```
      ./versionInfo.sh
      ```
      You must have at least version 7.0.0.15 installed.

**Product data sets**

IBM Cognos Business Intelligence for z/OS product code resides in data sets which contain the product functions and the UNIX System Services HFS (hierarchical file systems) The default high-level qualifier for the product data sets is CGC.

**Product data set content**

The IBM Cognos BI for z/OS product has two types of data sets.
- Distribution sets
These data sets are used as input when installing product code and are also used for backup in case a recovery is required in a production environment.

**Table 18. IBM Cognos Business Intelligence Server distribution libraries**

<table>
<thead>
<tr>
<th>Description</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>executable shell scripts</td>
<td>ACGCBASE</td>
</tr>
<tr>
<td>distribution file system</td>
<td>ACGCZTAR</td>
</tr>
<tr>
<td>sample JCL</td>
<td>ACGCSAMP</td>
</tr>
</tbody>
</table>

- Target data sets
  These data sets are used during product execution and customization. Target data sets contain the executable code that is required to run IBM Cognos BI for z/OS.

**Table 19. IBM Cognos Business Intelligence Server target libraries**

<table>
<thead>
<tr>
<th>Description</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>executable shell scripts</td>
<td>SCGCBASE</td>
</tr>
<tr>
<td>target file system</td>
<td>SCGCZTAR</td>
</tr>
<tr>
<td>sample JCL</td>
<td>SCGCSAMP</td>
</tr>
</tbody>
</table>

**Product data sets naming conventions**

Be sure to choose a product dataset naming convention that allows you to keep and maintain at least two copies of product libraries for maintenance purposes.

Certain product data sets must have the same high-level dataset name qualifier in order for the product to function correctly. Product maintenance is easier if all product data sets have the same high-level qualifier. On the other hand, in order to continue to run the product while applying maintenance, you must have at least two copies of the product data sets:

- One copy for running IBM Cognos BI for z/OS execution environment
- One copy to which maintenance (service) is applied

Choose a middle level qualifier for each separate release and maintenance level of the product. This middle level qualifier can reflect a simple test and production environment distinction, such as with CGC.VPROD.* or CGC.VTEST.*, or can include specific service level information CGC..BLDXXX.*

There are many places where you must specify the product dataset names. To avoid confusion, use the simplest dataset naming scheme that accomplishes your maintenance goals.

**Use of the Cognos Content Database as the content store**

The Cognos Content Database is provided for convenience with the product. However, by default it is not installed. You must choose to install it as a component when you install IBM Cognos BI server components.

The Cognos Content Database might be useful in proof of concept or test environments.
Related tasks:

“Configuring the connection to the Cognos Content Database” on page 87

If Cognos Content Database and Content Manager are not collocated, you must set the database connection properties for Cognos Content Database. If Cognos Content Database and Content Manager are collocated, Content Manager uses default settings to communicate with Cognos Content Database.
Chapter 5. Preparation of the z/OS system for installation

Preinstallation tasks are required on the z/OS system before you install the product code.

User accounts for the installation and running the product

The z/OS administrator must create the required users and groups on the z/OS system.

For most installations IBM Cognos Business Intelligence for z/OS should be installed under its own unique operating system user identity. In addition, the installation requires the nobody account.

The nobody account, which is assigned to users or processes, should not have any special permissions.

Requirements for the installation user account

To install IBM Cognos BI for z/OS on UNIX System Services, create a group for the installation user. This group is used to control access to directories and files in the configuration directory created in the HFS file system.

When you create a group, it must contain the user who owns the IBM Cognos files. For example, if you create a group named "cognos" and a user named "cognos", you must change the group ownership of the IBM Cognos installation files to the "cognos" group and change the file permissions for all IBM Cognos files to GROUP READABLE/WRITABLE/EXECUTABLE.

You can install using either root or non-root authority.

IBM Cognos respects the file mode creation mask (umask) of the account running the installation program. This affects only the installation directories. It does not affect the file permissions within the directories. However, run-time generated files, such as logs, respect the mask. Use umask 022 on the installation directory.

Requirements for the user account that runs IBM Cognos

The account under which IBM Cognos BI runs must have the following characteristics:

- To use DB2 data sources, be granted the privilege to run programs that use the DSNACLI plan
  - For example, grant EXECUTE on plan DSNACLI to cognos.
  - Ensure that the user account has sufficient authority to bind the CLI.
- Have access to all required resources, such as printers
- Have the rights to log on as a service and act as part of the operating system
- Be a member of the local administration group

For example, to print reports using a network printer, the account must have access to the network printer, or you must assign a logon account to the IBM Cognos process.
The WebSphere Application server user account

This user account has full access permissions for the IBM Cognos installation. On UNIX System Services, the operating system group must contain the user that starts the application server and the user that owns the IBM Cognos files (for example, the cognos group. Change the group ownership of the IBM Cognos files to the cognos group and change the file permissions for all IBM Cognos files to GROUP READABLE/WRITABLE/EXECUTABLE. For simplicity, you can also use the application server user account to install and run IBM Cognos components.

Verifying user account settings

To verify user account information, you can use TSO to view the user and group settings.

Procedure

1. In TSO, log on as the user that runs the IBM Cognos BI application.
   Typically, the application server user account also runs the IBM Cognos components.
2. Ensure that the user account has the SPECIAL privilege in RACF.
3. Use the following command to verify group settings:
   LISTGRP GROUPNAME
   For example, if the group name is OMVS, type the following command:
   LISTGRP OMVS
   The output will show all subgroups and all users belonging to this group.
   Ensure that your WebSphere and Cognos users appear in the list.
   If the user account does not have the SPECIAL attribute, an authorization error will display.
4. You can also verify an individual user's group memberships using the following command:
   LISTUSER USERNAME
   For example, if the user name is OMVS, type the following command:
   LISTUSER OMVS
   The output will list memberships in all groups and settings unique to this user.

Environment variables settings on the z/OS system

IBM Cognos Business Intelligence components use the values of environment variables for configuration purposes. Some of these variables must also be set in WebSphere Application Server administrative console.

You must set environment variables for the user profile that runs the IBM Cognos BI product. Sample .tcshrc and .profile scripts installed as part of the CGCSAMP data set.

Note: Typically, you use the application server user account to run IBM Cognos components.
Table 20. List of preinstallation environment variables for IBM Cognos BI for z/OS

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Values or examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>_BPXK_AUTOCVT</td>
<td>ON</td>
<td>This runtime environment variable must be set to ON to automatically convert ASCII-tagged files to EBCDIC as the IBM Cognos installer reads the files.</td>
</tr>
<tr>
<td>_CEE_RUNOPTS</td>
<td>POSIX(ON), FILETAG(AUTOCVT, AUTOTAG)</td>
<td>Set this variable for the IBM Cognos installer which creates files that must be tagged properly.</td>
</tr>
<tr>
<td>JAVA_HOME</td>
<td>${WASHOME}/java64</td>
<td>Points to the installation location of your Java Runtime Environment (JRE). For example, if you are using WebSphere Application Server, set the JAVA_HOME environment variable to use the JVM that is provided with WebSphere Application Server.</td>
</tr>
<tr>
<td>PATH</td>
<td>$JAVA_HOME/bin</td>
<td>The IBM Cognos installer requires the Xm_31d11 file.</td>
</tr>
<tr>
<td>LIBPATH</td>
<td>/usr/lib:$[LIBPATH]</td>
<td>Set these environment variables to enable JDBC connectivity to the DB2 content store. If applicable, set in the servant region in the WebSphere administrative console.</td>
</tr>
<tr>
<td>JDBC connectivity</td>
<td>JDBC variables</td>
<td>Set ODBC environment variables to enable your system to use the DB2 command line processor and to specify the location of the DB2 ODBC initialization file. If applicable, set in the servant region in the WebSphere administrative console.</td>
</tr>
<tr>
<td>• JDBCHOME</td>
<td>$[DB2HOME]/db2910_jdbc</td>
<td></td>
</tr>
<tr>
<td>• JDBCCLASSES</td>
<td>$[JDBCHOME]/classes</td>
<td></td>
</tr>
<tr>
<td>• CLASSPATH</td>
<td>$CLASSPATH: $[JDBCCLASSES]/db2jcc_javax.jar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$CLASSPATH: $[JDBCCLASSES]/db2jcc4.jar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$CLASSPATH: $[JDBCCLASSES]/db2jcc_license_cisuz.jar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$CLASSPATH: $[JDBCCLASSES]/sqlj4.zip</td>
<td></td>
</tr>
<tr>
<td>ODBC connectivity</td>
<td>ODBC variables</td>
<td></td>
</tr>
<tr>
<td>• DSNAOINI</td>
<td>/u/user1/db2odbc/odbcini</td>
<td></td>
</tr>
<tr>
<td>• STEPLIB</td>
<td>prefix.SDSNE11: prefix.SDSNLOAD: prefix.SDSNL002</td>
<td></td>
</tr>
<tr>
<td>Note:</td>
<td>The line continuation for this value.</td>
<td></td>
</tr>
</tbody>
</table>

Chapter 5. Preparation of the z/OS system for installation  31
Table 21. List of post-installation environment variables for IBM Cognos BI for z/OS

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Values or examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM_JAVA_ENABLE.ASCII_FILETAG</td>
<td>ON</td>
<td>Set to ON because z/OS uses the EBCDIC character encoding and IBM Cognos BI Java applications use ASCII encoding.</td>
</tr>
<tr>
<td>LIBPATH</td>
<td>${JDBCHOME}/lib/bin:</td>
<td>Points to the c10_location/bin64 and c10_location/bin directories</td>
</tr>
<tr>
<td></td>
<td>${COGROOT}/bin64:</td>
<td>Add the location of the JDBC libraries.</td>
</tr>
<tr>
<td></td>
<td>${COGROOT}/bin:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$JAVA_HOME/bin:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$LIBPATH</td>
<td></td>
</tr>
<tr>
<td>Note:</td>
<td>The line continuation for this value.</td>
<td></td>
</tr>
<tr>
<td>PATH</td>
<td>If COGROOT is the top level directory for the IBM Cognos BI server installation:</td>
<td>Points to the c10_location/bin64 and c10_location/bin directories</td>
</tr>
<tr>
<td></td>
<td>/bin:${COGROOT}/bin64:</td>
<td>Add the JAVA_HOME/bin directory.</td>
</tr>
<tr>
<td></td>
<td>/bin64:${COGROOT}/bin:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>$JAVA_HOME/bin:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>${PATH}</td>
<td></td>
</tr>
<tr>
<td>_BPX_JOBNAME</td>
<td>CGC</td>
<td>Set in WebSphere Application Server.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Identifies the address space extensions running under WebSphere Application Server as Cognos processes.</td>
</tr>
<tr>
<td>DISPLAY</td>
<td>host_name:display_number</td>
<td>For IBM Cognos Configuration on z/OS, allows it to display its user interface.</td>
</tr>
<tr>
<td>LANG</td>
<td>C</td>
<td>This environment variable must be set to C to ensure that the operating system can locate the set of language utilities which contain the X11 cat file.</td>
</tr>
</tbody>
</table>

Related tasks:
“Setting the JDBC environment variables for a DB2 content store” on page 211

IBM Cognos Business Intelligence for z/OS uses JDBC connectivity to communicate with the content store. You must set up the appropriate environment variables to enable the classes used by the JDBC driver.

Use of z/OS UNIX System Services shells to set environment variables

Both the z/OS shell and the tcsh shell provide commands that gives you an efficient way to request a range of services, such as setting environment variables.
There are two shells available on z/OS UNIX System Services:

- The z/OS shell
  Most of the examples in the guide use this shell.
- The tcsh shell
  Tcsh is a Unix shell that is based on and compatible with the C shell (csh).

**Using a .tcshrc file to set environment variables**

Use the sample .tcshrc file as a guide to help you set shell variables for the user that runs IBM Cognos Business Intelligence.

**About this task**

If you want to review and edit the sample on the z/OS system, locate the CGCTCSH member in the CGCSAMP data set and then copy it to the home directory on UNIX System Services of the user who will run the IBM Cognos installation. On UNIX System Services, use the file that you copied to append the content to the existing .tcshrc file for the user, or if required, create a new .tcshrc file.

If you want to review and edit the sample on UNIX System Services, log on as the user that runs IBM Cognos Business Intelligence, and open the .tcshrc file for editing.

**Procedure**

1. Review and edit the sample.

   ```bash
   #!/bin/tcsh
   umask 022
   
   setenv EDITOR vi
   setenv TMPDIR ${HOME}/temp
   setenv TERM vt100
   
   # X client machine
   setenv DISPLAY .ip.address:0.0
   
   # DB2 variables
   setenv DB2HOME /usr/lpp/dsn910
   setenv DB2BASE /usr/lpp/dsn810
   setenv DB2BASE ${DB2HOME}/db2910_base
   setenv DB2BASE /usr/lpp/db2/db2810
   setenv CLPPROPERTIESFILE /u/coguser/clp.properties
   alias db2="java com.ibm.db2.clp.db2"
   
   # JDBC variables
   setenv JDBCHOME ${DB2HOME}/db2910_jdbc
   setenv JDBCHOME /usr/lpp/db2/db2810/jcc
   setenv JDBCCLASSES ${JDBCHOME}/classes
   setenv CLASSPATH $CLASSPATH:${JDBCHOME}/db2jcc_javax.jar
   setenv CLASSPATH $CLASSPATH:${JDBCHOME}/sqlj4.zip
   setenv CLASSPATH $CLASSPATH:${JDBCHOME}/db2jcc4.jar
   setenv CLASSPATH $CLASSPATH:${JDBCHOME}/db2jcc_license_cisuz.jar
   setenv CLASSPATH ${DB2BASE}/lib/clp.jar:${CLASSPATH}
   
   # ASCII Application variables
   setenv _BPXK_AUTOCVT ON
   setenv _CEE_RUNOPTS "POSIX(ON), FILETAG(AUTOCVT, AUTOTAG)"
   
   # JAVA variables
   setenv WASHOME /usr/lpp/zWebSphere/V7R0
   ```
setenv JAVA_HOME ${WASHOME}/java64
setenv IBM_JAVA_ENABLE_ASCII_FILETAG ON

#ODBC variables
setenv DSNAOINI /u/user1/db2odbc/odbcini
setenv STEPLIB /prefix.SDNSEXIT:prefix.SDNSLOAD:prefix.SDNSLOAD2

#Command Path
setenv COGROOT "/pathprefix/usr/lpp/ibm/cognos/BI_10.2.0"
setenv PATH "/bin:${COGROOT}/bin64:${COGROOT}/bin:${PATH}"

2. Check that the values are appropriate for your environment.
   For example, uncomment or comment out environment variables for versions
   of software that you are not using.

3. For the DISPLAY environment variable, change the .ip.address:0.0 value to suit
   your environment.
   This variable helps to ensure that the graphical user interface of IBM Cognos
   Configuration displays.

4. To set the CLPPROPERTIESFILE environment variable, change the directory to
   include the full path name where the properties file is located.

5. To set the STEPLIB environment variable, change the prefix option to suit your
   environment.

6. To set the COGROOT environment variable, change the pathprefix option to suit
   your environment.

7. Save and close the file.

Edit your .profile file to set environment variables

Use the sample .profile file as a guide to help you set shell variables for the user
that runs IBM Cognos Business Intelligence.

About this task

If you want to review and edit the sample on the z/OS system, locate the
CGCPROFL member in the CGCSAMP data set and then copy it to the home
directory on UNIX System Services of the user who will run the IBM Cognos
installation. On UNIX System Services, use the file that you copied to append the
content to the existing .profile file for the user, or if required, create a new
.profile file.

If you want to review and edit the sample on UNIX System Services, log on as the
user that runs IBM Cognos Business Intelligence, and open the .profile file for
editing.

Procedure

1. On UNIX System Services, log on as the user that runs IBM Cognos Business
   Intelligence, and open the .profile file for editing.

   #!/bin/tcsh
   umask 022
   export EDITOR=vi
   export TMPDIR=${HOME}/temp
   export TERM=vt100
   export DISPLAY=.ip.address:0.0
   # DB2 variables

34 IBM Cognos Business Intelligence Version 10.2.0: Installation and Configuration Guide for z/OS
export DB2HOME=/usr/lpp/dsn910
export DB2BASE=${DB2HOME}/db2910_base
export CLPPROPERTIESFILE=/u/conuser/clp.properties
alias db2="java com.ibm.db2.clp.db2"

# JDBC variables
export JDBCHOME=${DB2HOME}/db2910_jdbc
export JDBCCLASSES=${JDBCHOME}/classes
export PATH=$JDBCHOME/bin:$PATH
export CLASSPATH=${JDBCHOME}/classes/db2jcc_javax.jar
export CLASSPATH=${JDBCHOME}/classes/sqlj4.zip
export CLASSPATH=${JDBCHOME}/classes/db2jcc4.jar
export CLASSPATH=${JDBCHOME}/classes/db2jcc_license_cisuz.jar
export CLASSPATH=${DB2BASE}/lib/clp.jar:${CLASSPATH}

# ASCII Application variables
export _BPXK_AUTOCVT=ON
export _CEE_RUNOPTS="POSIX(ON), FILETAG(AUTOCVT, AUTOTAG)"

# JAVA variables
export JAVA_HOME=/usr/lpp/java64
export IBM_JAVA_ENABLE_ASCII_FILETAG=ON

#ODBC variables
export DSNAOINI=/u/user1/db2odbc/odbcini
export STEPLIB=/pathprefix/ibm/cognos/BI_10.2.0
export PATH="/bin:${PATH}"

2. Check that the values are appropriate for your environment.
   For example, uncomment or comment out environment variables for versions of software that you are not using.

3. For the DISPLAY environment variable, change the .ip.address:0.0 value to suit your environment.
   This variable helps to ensure that the graphical user interface of IBM Cognos Configuration displays.

4. To set the CLP PROPERTIESFILE environment variable, change the directory to include the full path name where the properties file is located.

5. To set the STEPLIB environment variable, change the prefix option to suit your environment.

6. To set the COGROOT environment variable, change the pathprefix option to suit your environment.

7. To set the DSNAOINI environment variable, change the directory to include the full path name where the ODBC initialization fie is located.

8. Save and close the file.

Verifying environment variable settings

To ensure that the z/OS UNIX System Services environment is properly prepared for the installation of IBM Cognos Business Intelligence for z/OS, you can use UNIX System Services to test that the environment variables are set.

Procedure
1. Log on to UNIX System Services as the user that runs IBM Cognos.
The account under which IBM Cognos runs must have specific environment variables configured.

2. In the UNIX System Services shell, test that the environment variables are set.

**Table 22. Preinstallation environment variable settings**

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Values or examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>_BPXK_AUTOCVT</td>
<td>ON</td>
</tr>
<tr>
<td>_CEE_RUNOPTS</td>
<td>“POSIX(ON), FILETAG(AUTOCVT, AUTOTAG)”</td>
</tr>
<tr>
<td>JAVA_HOME</td>
<td>${WASHOME}/java64</td>
</tr>
<tr>
<td>PATH</td>
<td>$JAVA_HOME/bin:/bin:</td>
</tr>
<tr>
<td></td>
<td>${COGROOT}/bin64:${COGROOT}/bin:</td>
</tr>
<tr>
<td></td>
<td>$JAVA_HOME/bin:${PATH}</td>
</tr>
<tr>
<td>IBM_JAVA_ENABLE_ASCII_FILETAG</td>
<td>ON</td>
</tr>
<tr>
<td>STEPLIB</td>
<td>prefix,SDSNEXIT:prefix,SDSNLOAD:</td>
</tr>
<tr>
<td></td>
<td>prefix,SDSNLOAD2</td>
</tr>
<tr>
<td>Note:</td>
<td>The line continuation for this value.</td>
</tr>
<tr>
<td>DSNAOINI</td>
<td>/u/user1/db2odbc/odbcini</td>
</tr>
<tr>
<td>LIBPATH</td>
<td>${JDBCHOME}/lib:/bin:${COGROOT}/bin64:${COGROOT}/bin:</td>
</tr>
<tr>
<td></td>
<td>$JAVA_HOME/bin:${LIBPATH}</td>
</tr>
<tr>
<td>Note:</td>
<td>The line continuation for this value.</td>
</tr>
<tr>
<td>DISPLAY</td>
<td>host_name:display_number</td>
</tr>
<tr>
<td>LANG</td>
<td>C</td>
</tr>
</tbody>
</table>

- To view a list of the environment variables set in your shell, type the following command:
  ```bash
dev
  env
  ```
- Test each of the environment variables one by one by using the following command:
  ```bash
dev
  env | grep environment_variable
  ```

**Guidelines for initial settings for DB2 subsystems**

In the DB2 Installation Guide, follow the guidance that is provided to system and database administrators about planning for and installing DB2 subsystems. Review your DB2 subsystem parameters before you install IBM Cognos Business Intelligence for z/OS. Because of the use of ODBC threads to connect to IBM Cognos data sources and the use of JDBC connections to access the content store database, additional considerations might apply.

IBM Cognos Business Intelligence for z/OS uses a multithreaded architecture to run as many user requests as possible, concurrently. It also reuses database connections to avoid the overhead associated with establishing them. Some user actions might leave connections to DB2 idle for an extended period of time. If IBM Cognos applications run collocated with other applications, agreement on an acceptable balance for some of the suggested settings, such as IDTHTION, is required because those settings are at the DB2 subsystem level.

To accommodate this level of high concurrency and connection re-use, use the suggested initial settings in the following table.
Table 23. Suggested initial settings for DB2 subsystem parameters

<table>
<thead>
<tr>
<th>DB2 subsystem parameter</th>
<th>Suggested initial Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDBACK</td>
<td>800</td>
<td>Determines the maximum number of concurrent ODBC connections. This parameter is an important sizing parameter for access to data stores.</td>
</tr>
<tr>
<td>MAXDBAT</td>
<td>800</td>
<td>Determines the maximum number of concurrent remote threads. This parameter involves sizing the content store for access by Content Manager.</td>
</tr>
<tr>
<td>CONDBAT</td>
<td>10000</td>
<td>Specifies the maximum number of inbound distributed data facility (DDF) connections.</td>
</tr>
<tr>
<td>CTHREAD</td>
<td>800</td>
<td>Controls the number of allied threads that are started on the local system. The value of this parameter includes ODBC connections, but you should make allowance for other users of threads, such as utilities or monitors.</td>
</tr>
<tr>
<td>IDTHTOIN</td>
<td>0</td>
<td>To ensure that threads are not terminated before IBM Cognos Business Intelligence for z/OS finishes processing reports, consider setting the idle thread timeout value to zero. Doing this keeps threads active until for IBM Cognos Business Intelligence for z/OS users are finished using reports.</td>
</tr>
<tr>
<td>NUMLKTUS</td>
<td>2000</td>
<td>Determines the maximum number of locks per tablespace. Potentially, a higher number of threads might be added by the use of the ODBC connector. A higher value for this parameter might help to avoid lock-related errors.</td>
</tr>
<tr>
<td>NUMLKUS</td>
<td>10000</td>
<td>Sets the maximum number of locks per user.</td>
</tr>
<tr>
<td>EDMPOOL</td>
<td>144175</td>
<td>Specifies the size of the environmental descriptor manager (EDM) pool. The value of the parameter should be reviewed. More EDM objects can be created with the implementation of Cognos and ODBC threads.</td>
</tr>
</tbody>
</table>

As you test the IBM Cognos Business Intelligence reports that are deployed, you can continue to customize DB2 settings for your environment.

Setting initialization parameters for z/OS UNIX System Services

Configure initialization parameter values for IBM Cognos components directly in SYS1.PARMLIB
Each member in the PARMLIB data set provides the configuration settings that you control. You can change many of these values dynamically, without the need to restart the system.

For more information, see the [z/OS V1R10 MVS Initialization and Tuning Reference (SA22-7592)](http://www.ibm.com/support/docview.wss?uid=pub1sa22759217).

SYS1.SAMPLIB provides a sample parmlib member BPXPRMXX. Use the following table to set z/OS parameters.

*Table 24. List of z/OS USS parameters and their suggested settings.*

<table>
<thead>
<tr>
<th>z/OS USS Parameter</th>
<th>Definition and Suggested or required settings</th>
</tr>
</thead>
</table>
| AUTOCVT            | Enables automatic conversion of data between EBCDIC and ASCII encoding.  
Default: OFF  
Required setting: ON except when starting the IBM HTTP Web server to view static content.  
You can use the SETOMVS or SET OMVS commands to change the value of AUTOCVT between ON and OFF. |
| IPCSEMNOPS         | Specifies the maximum number of operations for each semaphore operation call.  
Default: 25  
Suggested setting: 25 |
| IPCSEMNSEMS        | Specifies the maximum number of semaphores for each semaphore set.  
Default: 1000  
Suggested setting: 1000 |
| MAXASSIZE          | Specifies the maximum address space memory.  
Default: 209715200  
Suggested setting: 2147483647 |
| MAXCORESIZE        | Specifies the maximum core dump file size a process can create.  
Default: 4194304  
Suggested setting: 2147483647 |
| MAXCPUTIME         | Specifies the maximum CPU in seconds per address space created by rlogind, telnetd, and daemons.  
Suggested setting: 86400 |
| MAXFILESIZE        | Specifies the maximum files size.  
Default: 1000  
Suggested setting: NOLIMIT, 2147483647, or omit parameter equivalents |
Table 24. List of z/OS USS parameters and their suggested settings. (continued)

<table>
<thead>
<tr>
<th>z/OS USS Parameter</th>
<th>Definition and Suggested or required settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>MAXMMAPAREA</td>
<td>Specifies the maximum number of 4K pages of memory for memory mapping of UNIX files (mmap).&lt;br&gt;Default: 40960&lt;br&gt;Suggested setting: 204800</td>
</tr>
<tr>
<td>MAXPROCUSER</td>
<td>Specifies the maximum number of processes that a single z/OS UNIX user ID can have concurrently active.&lt;br&gt;Default: 25&lt;br&gt;Suggested setting: 32767</td>
</tr>
<tr>
<td>MAXQUEUEDSIGS</td>
<td>Specifies the maximum number of signals that z/OS UNIX allows to be concurrently queued within a single process.&lt;br&gt;Suggested setting: 32767</td>
</tr>
<tr>
<td>MAXSHAREPAGES</td>
<td>Specifies the maximum number of 4K pages of shared memory for memory mapping of UNIX files (mmap and shmat calls only)&lt;br&gt;Default: 131072&lt;br&gt;Suggested setting: 32768000</td>
</tr>
<tr>
<td>MAXTHREADS</td>
<td>Specifies the maximum number of threads that a single process can have currently active.&lt;br&gt;Default: 200&lt;br&gt;Suggested setting: 10000</td>
</tr>
<tr>
<td>MAXTHREADTASKS</td>
<td>Specifies the maximum number of MVS tasks that a single process might have concurrently active.&lt;br&gt;Default: 1000&lt;br&gt;Suggested setting: 32768</td>
</tr>
<tr>
<td>SHRLIBRGNFSIZE</td>
<td>Identifies maximum amount of system shared library space for all address spaces that use system shared libraries.&lt;br&gt;Default: 67108864&lt;br&gt;Suggested setting: no more than 100 MB</td>
</tr>
</tbody>
</table>

Related concepts:
“Problems creating an ODBC connection to a DB2 data source on the z/OS system” on page 215
You might encounter problems, such as a failed connection error in IBM Cognos Administration, when you configure a connection to DB2 data sources because of encoding and file tagging settings.

Related tasks:
“Configuring IBM HTTP Web Server to view IBM Cognos BI static content” on page 83
To view IBM Cognos BI web pages, you configure virtual directories on the web server. To use the 64-bit version of the IBM Cognos BI gateway, use a script to copy the required files.
Chapter 6. Installation of IBM Cognos BI components on the z/OS system

A complete installation on the z/OS system requires two distinct programs. Use the SMP/E (System Modification Program Extended) installation program to install the IBM Cognos Business Intelligence server components on the z/OS system. Then, to finish installing the components into the locations from which they run, use the IBM Cognos installer.

SMP/E and IBM Cognos BI server components

The SMP/E utility is used to install and maintain software on your z/OS system.

During the first part of the installation process, you use the SMP/E utility to install the product functions onto the z/OS UNIX System Services system.

There are multiple installation kits included in one Functional Modifier Identifiers (FMID). Install the HCGCA20 FMID by using the SMP/E utility.

The following table lists the installation components included in the HCGCA20 FMID.

Table 25. Descriptions for the IBM Cognos BI for z/OS FMIDs

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM Cognos Business Intelligence Server 64-bit 10.2.0 for z/OS Multilingual</td>
<td>Required: Provides core server components.</td>
</tr>
<tr>
<td>IBM Cognos Business Intelligence Transformer 10.2.0 for z/OS Multilingual</td>
<td>Optional: Provides utility for building PowerCubes.</td>
</tr>
<tr>
<td>IBM Cognos Business Intelligence Samples 10.2.0</td>
<td>Optional: Provides product samples for testing product features and for troubleshooting.</td>
</tr>
<tr>
<td>IBM Cognos Software Development Kit 64-bit 10.2.0 English</td>
<td>Optional: Provides a collection of cross-platform web services, libraries, and programming interfaces.</td>
</tr>
<tr>
<td>IBM Cognos Supplementary Languages Documentation 10.2.0</td>
<td>Optional: Provides translated product documentation,</td>
</tr>
<tr>
<td>IBM Cognos Mobile 10.2.0.2</td>
<td>Optional: Allows users to view and interact with IBM Cognos BI reports on tablet computers and smartphone devices.</td>
</tr>
</tbody>
</table>

IBM Cognos installer and IBM Cognos BI server components

The IBM Cognos installer utility copies the server components into a single deployment location from which the product runs.

If you install Cognos Transformer, the installer uses a second deployment location. The BI server components, samples, IBM Cognos Insight, the IBM Cognos Software Development Kit, IBM Cognos Mobile, and the translated documentation are separate from Cognos Transformer.
IBM Custom-Build Product Delivery Offering

To install the IBM Cognos Business Intelligence for z/OS product code you must use an IBM Custom-Build Product Delivery Option (CBPDO). A CBPDO loads the contents of the installation media onto the z/OS system.

A CBPDO contains both the product and cumulative service for the product. The CBPDO Memo to Users Extension contains information about the CBPDO and the features and service it includes. It also contains CBPDO installation information.

The IBM Cognos BI for z/OS Program Directory

The Program Directory for IBM Cognos Business Intelligence for z/OS provides instructions for installing the product to the SMP/E (System Modification Program Extended) libraries.

The installation directory is created by the System Administrator and the file format is in zFS format to allow the space allocation to grow.

Sample installation jobs

The Program Directory (GI10-8938-00) provides information about sample installation jobs that the SMP/E uses to install the product and service on your z/OS system. By default, SMP/E installs all the elements included on the Custom Build Product Delivery Option tape into new SMP/E global, target, and distribution zones.

There is detailed information about the installation jobs in the IBM Cognos Business Intelligence for z/OS Program Directory, and also in the comments at the start of each job.

One of the parameters that you are required to specify in many of the installation jobs is the high-level qualifier (HLQ). Some jobs also require that you provide the path prefix for the installation location.

Results of running the SMP/E installation jobs

After you have run a job, check its output before proceeding to the next job. If a job terminates abnormally, find out why it failed (the job log lists the error messages produced on each run). Correct the error, and then proceed as advised in the job description. Do not attempt to run the next job until the previous job has run successfully.

On completion of the installation jobs, you have all of the elements installed in new SMP/E global, target, and distribution zones.

Product file system

The IBM Cognos Business Intelligence product directory and all of its subdirectories reside in the same hierarchical file system (HFS).

Installation product file system

During the installation process all IBM Cognos Business Intelligence for z/OS product files are copied into their own product directory within two parent directories. The following list describes the content of the parent directories.

- `/pathprefix/usr/lpp/cognos/HCGCA20/installer/IBM`
This directory contains the uncompressed product and updater files. These files are used to invoke the IBM Cognos installation program (issetup.sh) to either customize the installation for the product, or to update the customization with fixes during maintenance.

* `/pathprefix/usr/lpp/cognos/HCGCA20/IBM`

This directory is empty and is the default location to which the product will be installed after running the IBM Cognos installation program.

Before customization, you must mount the target file system.

Use a zFS or HFS file system for each of the two directories.

**Uncompressed installation files**

Each installation kit is installed into uncompressed files in its own product directory. For example, IBM Cognos BI server for z/OS is installed in its own directory that is separate from IBM Cognos BI Samples. From within these directories, you run the customization installer that installs the product components into the required locations.

The following table lists the product functions and the directory from which the customization installer is located.

*Table 26. Uncompressed product files and directory locations*

<table>
<thead>
<tr>
<th>Component</th>
<th>Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM Cognos Business Intelligence server for z/OS</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_bisrvr/IBM/</code></td>
</tr>
<tr>
<td>IBM Cognos Software Development Kit</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_bisdka/IBM/</code></td>
</tr>
<tr>
<td>IBM Cognos BI Transformer</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_bitrsfrmr/IBM/</code></td>
</tr>
<tr>
<td>IBM Cognos Business Intelligence Supplementary Languages Documentation</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_lp/IBM/</code></td>
</tr>
<tr>
<td>IBM Cognos Business Intelligence Samples</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_bisamples/IBM/</code></td>
</tr>
<tr>
<td>IBM Cognos Connection Installer for Cognos Insight</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_cdbiint/IBM/</code></td>
</tr>
<tr>
<td>IBM Cognos Mobile</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_biem/IBM/</code></td>
</tr>
</tbody>
</table>

**Uncompressed updater installation files**

Updater installation files are installed with each product component. You invoke the installer for the updater when maintenance is available.

*Table 27. Uncompressed updater files and directory locations*

<table>
<thead>
<tr>
<th>FMID</th>
<th>Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Updater - IBM Cognos Business Intelligence server for z/OS</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_upbisrvr/IBM/</code></td>
</tr>
<tr>
<td>Updater - IBM Cognos Software Development Kit</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_upbisdk/IBM/</code></td>
</tr>
<tr>
<td>Updater - IBM Cognos BI Transformer</td>
<td><code>/usr/lpp/cognos/HCGCA20/installer/cgc_upbitrsfrmr/IBM/</code></td>
</tr>
</tbody>
</table>
Table 27. Uncompressed updater files and directory locations (continued)

<table>
<thead>
<tr>
<th>FMID</th>
<th>Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Updater - IBM Cognos Business Intelligence Supplementary Languages Documentation</td>
<td>/usr/lpp/cognos/HCGCA20/installer/cgc_uplp/IBM/</td>
</tr>
<tr>
<td>Updater - IBM Cognos Business Intelligence Samples</td>
<td>/usr/lpp/cognos/HCGCA20/installer/cgc_upbisamples/IBM/</td>
</tr>
<tr>
<td>IBM Cognos Connection Installer for Cognos Insight</td>
<td>/usr/lpp/cognos/HCGCA20/installer/cgc_upcibiint/IBM/</td>
</tr>
</tbody>
</table>

**Customization product file system**

The SMP/E creates the HFS structure for the product files. After the HFS structure is created, you must complete the customization of the installation by running the IBM Cognos installer. The IBM Cognos installer creates the file structure and copies the product files to specific locations. The product runs from this location.

In this documentation, the term `c10_location` is used to represent the installation location of the IBM Cognos BI for z/OS product components.

**Manually mounting the IBM Cognos BI server target file system**

Before you can access the target file system that contains the base function for IBM Cognos Business Intelligence server components, you must mount the file system. You can manually mount the target file system, or use a JCL job.

**Procedure**

1. Go to the `/pathprefix/usr/lpp/cognos/HCGCA20/IBM` directory.
   - The SMP/E created this directory. This is the directory to which the product is installed after running the IBM Cognos installation program during customization.
2. Ensure that the directory has `ug+rwx` permissions.
3. To mount the z/OS UNIX file system that was created by the optional CGCZAL job, use the following command:
   ```bash
   /usr/bin/mount -v -tZFS -f HLQ.SCGCZFS /pathprefix/usr/lpp/cognos/HCGCA20/IBM
   ```

**Response files**

IBM Cognos Business Intelligence for z/OS uses a silent installation to customize the installation. Instead of prompting for installation options, the installation program installs the software using a predefined set of options, which are stored in a response file.

**Product response files**

Each product function has a response file. Not all sections are present in the response files for each product function. For example, the response file for IBM Cognos BI Server contains more installation options than the response file for IBM Cognos BI Supplementary Languages.
Sections in a response file

The response file is divided into sections. Each section has a specific purpose and variables that you can define. Each section of a response file corresponds to a dialog box in an interactive installation session.

Each section of a response file begins with a line, in brackets, that specifies the dialog number, and is followed by a title that specifies the name of the section, as shown in the following example:

```
[Dialog1]
Title=Welcome to the Installation Wizard
```

Values for installation options

Values for variables are specified in the following format:

```
<variable name>=<value>
```

There should be no space on either side of the equal sign.

Each value in the response file is one of the types listed in the following table

<table>
<thead>
<tr>
<th>Type</th>
<th>Examples</th>
</tr>
</thead>
</table>
| Boolean  | For all variables except the license acceptance terms  
|          | • 0 = no or false      
|          | • 1= yes or true       
|          | For license acceptance terms              
|          | y = yes                             
|          | n = no                             |
| String   | /                                 |

Modifying a response file

Generate and modify a response file to specify and record your installation preferences.

Before you begin

Set the following environment variables to ensure that files are tagged correctly:

- `_BPXK_AUTOCVT`
- `_CEE_RUNOPTS`
- `JAVA_HOME`

About this task

Edit the response files for each server function (also referred to as server component) to suit your environment before you use it as input for a silent installation. The response file for each server function might not have all of the
sections described in the following procedure.

**Procedure**

1. Ensure that filesystem used to store the IBM Cognos Business Intelligence server components is mounted.

2. To generate a response file for an unattended installation, go to the installation root directory and type the following command:

   ```bash
   ./issetup -ats <filename>
   ```

   For example, go to the `pathprefix/usr/lpp/cognos/BI_installer_10.2.0/cgcbisrv/IBM/zos64` directory, and type the following command:

   ```bash
   /user/lpp/home/response.ats
   ```

   **Note:** The location of the issetup file depends on the server function that you are installing. The preceding example uses IBM Cognos BI server. To generate a response file for the IBM Cognos BI Samples, the location of the issetup file is `pathprefix/usr/lpp/cognos/BI_installer_10.2.0/cgcbismp/IBM/zos64`

3. Open the response file that you generate in a text editor.

   Each section of the response file corresponds to a dialog box in an interactive installation session. Each section of a response file begins with a line, in brackets, that specifies the dialog box number, and is followed by a title that specifies the name of the section.

4. In the `[Dialog1]` section, check that "1" is next to the language code that you want to use.

5. In the `[Dialog2]` and `[Dialog3]` sections, next to the `I Agree` variable, check that the accept the license agreement and non-IBM terms, if any, is set to "y".

   By modifying or ensuring that the value of `I Agree` to "y", you agree to the terms of the license agreement and non-IBM terms.

   For example, `I Agree=y`

6. In the `[Dialog4]` section, next to the `APPDIR` variable, enter the installation location where the product will be installed.

   Some software, such as IBM Cognos BI Samples, and IBM Cognos Supplementary Languages Documentation, must be installed in the same location as the IBM Cognos BI server gateway component. The IBM Cognos Software Development Kit must be installed in each location where an IBM Cognos server component exists. For example, `APPDIR=/pathprefix/usr/lpp/cognos/BI_10.2.0`

7. If you are installing into the same directory as existing IBM Cognos BI software and you want to create a backup, next to the `Backup` variable, enter "1"

   For example, `Backup=1`

8. In the `[Component List]` section, enter ‘1’ next to the components you want to install.

   If you do not want to install a component, set the value to "0".

9. Save the changes you made to the response file.

**Running the IBM Cognos installation program in silent mode**

Run the IBM Cognos installer in silent mode. Record the answers to the installation options in the response file.

**Before you begin**

Ensure that you did the following tasks:
For each installation, you generated and modified a response file to suit your environment.

- Set the _BPXK_AUTOCVT environment variable to ON.
- Set the _CEE_RUNOPTS environment variable to the following value:
  POSIX(ON), FILETAG(AUTOCVT, AUTOTAG).
- Ensure that the LIBPATH environment variable contains the /usr/lib directory.
  For example, /usr/lib:{$LIBPATH}

The IBM Cognos installer requires the Xm_31.dll file. Otherwise, you might see the following error message.

CEE3501S The module Xm_31.dll was not found.
The traceback information could not be determined

**About this task**

Each of the IBM Cognos server functions has an installation program and a response file. The response file is used as input for the silent installation.

**Procedure**

1. Go to the HFS where the SMP/E installed the installation files for IBM Cognos BI Server.
   For example, the default HFS is the following location:
   /pathprefix/usr/lpp/cognos/BI_installer_10.2.0/cgcbisrv/
2. Locate the response.ats file at the root of the installation folder.
3. At the command prompt, type the following command:
   - To run the installation program using a response file, type the following command:
     ./issetup -s location/response.ats
   - To display the results of the installation progress on the screen, type the following command:
     ./issetup -s location/response.ats -displayLog

   To view the options for running the installation program in silent mode, type the following command:
   ./issetup -h.

   The location variable is the directory where you copied the response file (response.ats) that you want to use. For example, to use a test.ats file in the home directory of the cogadmin user, type the following command:
   ./issetup -s /user/lpp/home/cogadmin/test.ats

**Results**

The exit code (return status) indicates the success of the installation program.

- Return status zero (0).
  The installation was successful
- Return status other than zero (0).
  If a return status other than zero (0) is returned, check the log files for error messages. Errors are recorded in the c10_location/instlog directory in a summary error log file. The file name format is tl-product_code-version-yyyyymmd-hhmm_summary-error.txt.
If errors occur before sufficient initialization occurs, log messages are sent to a log file in the Temp directory. The file format is $t1$-product_code-version-yyyyymmd-hhmm.txt.

- License not accepted error message.

If you see the following error message, ensure that the file is tagged as ASCII.

```
DS_MSG_PREFIXIDS_COPYRIGHT_LOGOIDS_MSG_START_INSTALL_UNATTENDED
IDS_MSG_PREFIXIDS_MSG_READ_ARCHIVE License not accepted inside response file "/u/cognos/c10/response.ats".
```

Setup cannot continue.

For example, to tag the file, use the following command:
```
chtag -t -c ISO8859-1 /u/cognos/c10/response.ats
```

What to do next

Repeat these steps for the other installations by using the appropriate response files. Ensure that you install the components in the required locations:

- Install IBM Cognos Software Development Kit in the same directory as each IBM Cognos BI server component.
- Install IBM Cognos Samples and IBM Cognos Supplementary Languages Documentation in the same directory as the IBM Cognos BI server gateway component.
- Install IBM Cognos Transformer is installed in a different directory than other IBM Cognos BI server components.
- Install Cognos Connection Installer for Insight in the same location as IBM Cognos Application Tier Components and gateway component.

Install the **Cognos Insight BI Integration** component where the application tier components are installed. Install the **Cognos Insight BI Integration Gateway** component where the gateway component is installed.

Ensure that your BI administrator assigns all users who must install Cognos Insight to the Enhanced Consumer role. The Enhanced Consumer role corresponds to the Executive Dashboard capability that is assigned in IBM Cognos Administration. For more information about assigning capabilities, see the **IBM Cognos Business Intelligence Administration and Security Guide**.

After the installations are complete, some post installation tasks are required before you configure the product.
**Installing IBM Cognos Mobile**

IBM Cognos Mobile must be installed to the same location as IBM Cognos Business Intelligence server.

Before you install the component, you must modify a file in the BI server installation.

**Add a base installation for IBM Cognos Mobile**

Before you can install IBM Cognos Mobile, you must add a base installation to the uninist.ini file in your IBM Cognos BI installation directory.

**Procedure**

1. Go to the `c10_location/uninstall` directory.
2. Edit the uninist.ini file to include IBM Cognos Mobile components in the [Component List] section.
   
   ```ini
   COGMOB_APP=1
   COGMOB_SRVR=1
   COGMOB_CLIENT=1
   MOBILESERVER_VERC=1
   MOBILECLIENT_VERC=1
   ```
3. Save and close the file.

**Generate and modify the response file for IBM Cognos Mobile**

Generate and modify a response file to specify and record your installation preferences.

**Procedure**

1. Ensure that filesystem that is used to store the IBM Cognos Mobile components is mounted.
2. To generate a response file for an unattended installation, go to the installation root directory: `/pathprefix/usr/lpp/cognos/HCGCA20/installer/cgc_bext/IBM/zos64`. 
3. type the following command:
   `./issetup -ats <filename>`

4. Open the response file that you generated in a text editor.
   Each section of the response file corresponds to a dialog box in an interactive
   installation session. Each section of a response file begins with a line, in
   brackets, that specifies the dialog box number, and is followed by a title that
   specifies the name of the section.

5. In the [Dialog1] section, check that "1" is next to the language code that you
   want to use.

6. In the [Dialog2] and [Dialog3] sections, next to the I Agree variable, ensure
   that the value is set to "y".
   By modifying or ensuring that the value of I Agree to "y", you agree to the
   terms of the license agreement and non-IBM terms.
   For example, I Agree=y

7. In the [Dialog4] section, next to the APPDIR variable, enter the installation
   location where IBM Cognos BI server is already installed.
   IBM Cognos Mobile includes Application Tier Components and gateway
   components. If you are distributing components, ensure that you install the
   IBM Cognos Mobile gateway to the location where you installed the IBM
   Cognos BI server gateway, and the IBM Cognos Mobile Application Tier
   Components to the location where you installed the IBM Cognos BI
   Application Tier Components. For example, APPDIR=/pathprefix/usr/1pp/
   cognos/BI_10.2.0

8. If you are installing into the same directory as existing IBM Cognos BI
   software and you want to create a backup, next to the Backup variable, enter
   "1"
   For example, Backup=1

9. In the [Component List] section, enter "1" next to the components you want to
   install.
   If you do not want to install a component, set the value to "0".
   IBM Cognos Mobile includes the following components:
   • COGMOB_APP
   • COGMOB_SRVR
   • COGMOB_CLIENT
   In a distributed installation, you must install the COGMOB_APP to the location
   where you installed the IBM Cognos BI server Application Tier Components.
   The COGMOB_SRVR and COGMOB_CLIENT components must be installed where you
   installed the IBM Cognos BI server gateway component.

10. Save the changes and close the file.

**Install IBM Cognos Mobile in silent mode**

Run the IBM Cognos installer in silent mode.

**Procedure**

1. Go to the HFS where the SMP/E installed the installation files for IBM Cognos
   Mobile. For example, the default HFS is the following location:
   /pathprefix/usr/1pp/cognos/HCGCA20/installer/cgc_bietext/IBM/zos64

2. At the command prompt, type the following command:
   • To run the installation program using the response file you created, type the
     following command:
To display the results of the installation progress on the screen, type the following command:

```
./issetup -s location/response.ats -displayLog
```

**Verifying the installation of IBM Cognos server components and file permissions**

To ensure that IBM Cognos Business Intelligence server components are successfully installed, you can view the installation directory structure and the file permissions on UNIX System Services. Confirm that the user privileges for directories where content is deployed or where temporary files will be located are appropriate.

**Procedure**

1. On UNIX System Services, log on as the user who runs the IBM Cognos installation.
   For simplicity, usually the application server user account is also used to run the IBM Cognos components.
2. Go to the `c10_location` directory.
3. To view the ownership and permissions of all of the sub-directories, type the following command:
   
   ```
   ls -al
   ```
4. Verify that the group shown is the `cognos` group.
5. Check that the directory has `drwxrwxr-x` permissions.
6. Verify the version of Java that is being used for IBM Cognos BI for z/OS.
   a. Ensure that your `JAVA_HOME/bin` directory is included in your PATH variable.
   b. Type the following command:
      
      ```
      java -version
      ```

**Adding server components to an existing installation on the z/OS system**

You can add IBM Cognos components to an existing installation. For example, after you verified that a basic installation works, you can install optional software, such as IBM Cognos Dynamic Cubes or the IBM Cognos Software Development Kit. In some situations, for performance or security reasons, you might want to install additional instances of IBM Cognos Business Intelligence server components, such as the gateway or standby Content Manager.

**Procedure**

1. If your IBM Cognos Business Intelligence product is running, stop IBM Cognos services.
2. Go to the HFS where the SMP/E installed the installation files for IBM Cognos BI Server.
   For example, the default HFS is
   
   ```
   /pathprefix/usr/lpp/cognos/BI_installer_10.2.0/cgcbisrv/
   ```
3. Locate the `response.ats` file at the root of the installation folder.
4. At the command prompt, type the following command:

   ```
   ./issetup -s location/response.ats
   ```
The `location` parameter is the directory where you copied the response file (`response.ats`) that you want to use.

5. If required, configure the component to communicate with the existing server components.
   For more information, see the configuration steps for the component.

6. To return the IBM Cognos Business Intelligence product to service, save the configuration and start the IBM Cognos service.

---

**Uninstalling IBM Cognos BI server components on the z/OS system**

To remove IBM Cognos Business Intelligence server components from UNIX System Services, use the uninstallation program.

**Before you begin**

If you are running IBM Cognos BI applications in WebSphere Application Server, use the administrative console to stop the application if it is running, and undeploy the Java portion of IBM Cognos BI components. The application server might not completely remove all deployed application files or directories during an undeployment; therefore, you might have to perform this action manually.

**Procedure**

1. Stop the IBM Cognos BI processes.
   - Determine the process identification (pid) of the IBM Cognos BI process by typing the following command: `ps -ef | grep cogbootstrapservice`.
   - Type the following command: `kill -TERM pid`

2. Go to the `c10_location/uninstall` directory.

3. Open the file named `uninst.ini` in a text editor.

4. In the section named `[Package List]`, enter 1 for each component you want to uninstall. Enter 0 if you want to leave the component installed. By default, all installed components are set to be removed.

<table>
<thead>
<tr>
<th>Package code</th>
<th>Product</th>
</tr>
</thead>
<tbody>
<tr>
<td>BISRVR</td>
<td>IBM Cognos BI server</td>
</tr>
<tr>
<td>BISAMPLES</td>
<td>Samples</td>
</tr>
<tr>
<td>LP</td>
<td>Supplementary Languages Documentation</td>
</tr>
<tr>
<td>BITRSFRMR</td>
<td>IBM Cognos BI Transformer</td>
</tr>
<tr>
<td>SDK</td>
<td>IBM Cognos Software Development Kit</td>
</tr>
</tbody>
</table>

5. **Save** and **close** the file.

6. Go to the `c10_location/uninstall` directory, and run the following command: `./uninst -u -s`

**Results**

Uninstalling does not remove any files that changed since the installation, such as configuration and user data files. Your installation location remains, and you retain these files until you delete them.
Chapter 7. Post-installation tasks on the z/OS UNIX System Services

After you install, but before you can configure, you must set up your z/OS UNIX System Services environment to ensure that the resources or other software that you use on the z/OS system can communicate with IBM Cognos Business Intelligence components.

Updating the Java environment on the z/OS system after installation

After installation of IBM Cognos Business Intelligence Server on the z/OS system, ensure that the environment variables that are related to the Java environment are defined.

Procedure

1. Ensure that you set the IBM_JAVA_ENABLE_ASCII_FILETAG environment variable to ON.
   The z/OS system uses EBCDIC character encoding. However, IBM Cognos BI creates files, such as log messages, that must be tagged as ASCII text files.
2. Ensure that the JAVA_HOME environment variable is set to the JRE location.
   If you are using WebSphere Application Server, set JAVA_HOME to the JRE shipped with it.

Configuring an X Windows System for remote access

IBM Cognos Configuration is a graphical configuration tool. You must have X Windows System software capable of rendering a graphical user interface in order to use IBM Cognos Configuration to configure IBM Cognos BI for z/OS.

About this task

Unless you intend to complete a manual configuration where you edit configuration files, you must configure IBM Cognos BI server components from a computer where X server software is installed. You must enable the remote host (the z/OS system) to direct its output to the local display.

Procedure

1. Log on to the display system (that is, the one that will display the graphical user interface).
2. Open a terminal window and use Telnet or SSH to connect to the z/OS system where IBM Cognos BI server components are installed.
3. To access IBM Cognos Configuration on z/OS and allow it to display its user interface, set the DISPLAY environment variable.
   For example, type export DISPLAY=host_name:display_number.
   The host_name is the IP address of the computer that will show the graphical user interface.
4. Set the LANG environment variable to C.
   For example, type export LANG=C.
The environment variable ensures that the operating system can locate the set of language utilities which contain the X11 cat file.

**Results**

The remote X client (the z/OS system) makes a connection to your local computer (X server) and provides the display.

**Starting IBM Cognos Configuration on z/OS UNIX System**

**Services**

Use the IBM Cognos Configuration to configure components and to start and stop services.

**Before you begin**

Ensure that you set all of the environment variables, such as JAVA_HOME. Ensure that you copied all of the required files, such as the JDBC driver files, to the IBM Cognos installation.

**Procedure**

1. To connect to the IBM Cognos Business Intelligence installation use a program that provides remote graphical (GUI) logins.
   IBM Cognos Configuration is UI-based.
2. Log on as the user that owns the installation files.
3. Go to the `c10_location/bin64` directory and type `.cogconfig.sh`
   If IBM Cognos Configuration does not open, ensure that you set the DISPLAY environment variable.
   If you see a `JAVA.Lang.unsatisfied link` message, verify that you are using a supported version of Java.
   If you see a `Java.lang.unsupportedClassVersionError` message, ensure that you are using a 64-bit version of Java.

**Content store database**

The content store is a database that Content Manager uses to store global configuration data and settings, such as the language and currency formats shown in the user interface, data source connection information, and product-specific content.

Design models and log files are not stored in the content store.

**Database types for the content store**

You must create the content store before you can use the product. You can use one of the following databases for the content store:

<table>
<thead>
<tr>
<th>Database</th>
<th>Character encoding</th>
<th>Coded character set identifier (CCSID)</th>
<th>Protocol</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB2 for z/OS</td>
<td>UTF-8</td>
<td>Unicode</td>
<td>TCP/IP</td>
</tr>
<tr>
<td>Cognos Content Database</td>
<td>preconfigured</td>
<td>n/a</td>
<td>preconfigured</td>
</tr>
</tbody>
</table>
Cognos Content Database can be installed and configured as the default content store database in a test or proof-of-concept system only. If you plan to use the Cognos Content Database as your content store in a test environment, you must select it during the installation. Upon completion of the installation, a database is created and configured.

Do not use Cognos Content Database in a production environment.

**Collation sequence**

IBM Cognos Business Intelligence for z/OS uses a single sort order that specifies the rules used by the database to interpret, collect, compare, and present character data. For example, a sort order defines whether the letter A is less than, equal to, or greater than the letter B; whether the collation is case sensitive; and whether the collation is accent sensitive. For more information about collation and collation sequences, see the database documentation.

**Creating a content store database on DB2 for z/OS**

The DB2 database that you create on the z/OS system for the content store must contain the specified configuration settings.

Alternatively, you can create a content store using data definition language (DDL) script that you generate from within IBM Cognos Configuration. You can generate the DDL file when you create tablespaces for the DB2 content store.

**Procedure**

1. Create a database, storage group, and user account for the content store.
   - To create the database, you must have System Administrator (SYSADM) or System Control (SYSTCTRL) authority.
2. Ensure that the database system has the following virtual storage:
   - A buffer pool with a page size of 32 KB.
   - A second buffer pool with a page size of 16 KB
3. Ensure that the database has UNICODE as the CCSID.
4. Ensure that the database administrator grants CONNECT, CREATEIN, and CREATE TABLE rights or grants DBADM to the user who manages the content store database.
   - For example, to grant CREATETAB to a user CGCUSER
     \[\text{GRANT CREATETAB ON DATABASE CMDB101 TO CGCUSER}\]
   - a. Ensure that the user has privileges to create an index on buffer pools that were created and reserved when creating the content store database.
      - For example,
        \[\text{GRANT USE OF BUFFERPOOL BP2 TO CGCUSER}\]
   - b. Ensure that the user has privileges to create an index on a storage group that was created when creating the content store database.
      - For example,
        \[\text{GRANT USE OF STOGROUP SGDBT1DT TO CGCUSER}\]

**What to do next**

The database administrator must back up the content store regularly because it contains the IBM Cognos Business Intelligence data application and security information. To ensure the security and integrity of the content store database,
Create tablespaces for a content store on DB2 for z/OS

A database administrator must run scripts to create a set of tablespaces required for the content store database. Modify the scripts to replace the placeholder parameters with ones that are appropriate for your environment.

By default, the content store is used for notifications, human tasks, and annotations. You can create separate databases for each.

About this task

Ensure that you use the naming conventions for DB2 on z/OS. For example, all names of parameters must start with a letter and the length must not exceed eight characters. There are two exceptions to the character length limit:

- CMSCRIPT_CS_ID is no more than 2 characters.
- CMSCRIPT_TABLESPACE is no more than 6 characters.

The reason for the exception is that when the two parameters are concatenated the character length can be no more than 8.

For more information, see the IBM DB2 Information Center.

Procedure

1. Connect to the database as a user that has privileges to create and drop tablespaces and to allow execution of SQL statements.
2. Go to the directory that contains the scripts:
   
   c10_location/configuration/schemas/content/db2zOS

3. Make a backup copy of the tablespace_db2zOS.sql script file and save the file to another location.
4. Open the original tablespace_db2zOS.sql script file.
   
   a. Add a connection statement to the beginning of the script.

      For example,

      connect to databasename;

   b. Use the following table to help you to replace the generic parameters with ones appropriate for your environment.

      Not all of the parameters listed are in the script, but some might be added in the future.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_STOGROUP</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>CMSCRIPT_DATABASE</td>
<td>Specifies the name of the content store database.</td>
</tr>
<tr>
<td>CMSCRIPT_CS_ID</td>
<td>Specifies the subsystem identification for the content store database.</td>
</tr>
<tr>
<td></td>
<td>The ID must not be longer than 2 characters.</td>
</tr>
</tbody>
</table>
Table 31. Parameter names and description for the content store tablespace script (continued)

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_TABLESPACE</td>
<td>Specifies the name of the tablespace that contains all of the base tables in the content store. Auxiliary tables are not included. The name cannot be longer than 6 characters.</td>
</tr>
<tr>
<td>CMSCRIPT_LARGE_BP</td>
<td>Specifies the name of the large buffer pool allocated for especially large objects. This bufferpool is the 32 KB buffer pool that was created when the database administrator created the content store database on the z/OS system.</td>
</tr>
<tr>
<td>CMSCRIPT_REGULAR_BP</td>
<td>Specifies the name of the regular size buffer pool allocated for regular and large objects. This bufferpool is the 16 KB buffer pool that was created when the database administrator created the content store database on the z/OS system.</td>
</tr>
<tr>
<td>CMSCRIPT_USERNAME</td>
<td>Specifies the user account that accesses the content store database.</td>
</tr>
</tbody>
</table>

5. Save and run the script.
   For example, if you set up your clp.properties file and your DB2 alias in your profile or tcshrc script file, type the following command to run the script:
   `db2 -tvf tablespace_db2zOS.sql`

6. Grant the IBM Cognos user rights to the tablespaces that were created when you ran the tablespace_db2zOS.sql file script:
   a. Make a copy of the rightsGrant_db2zOS.sql script file and store it in another location.
   b. In the remote access tool, open the original rightsGrant_db2zOS.sql script file and replace the placeholder parameters with values that are appropriate for your environment. Ensure that you use the same values that you used when you allocated resources to the buffer pools and user account.
   c. Add a connection statement to the beginning of the script.
      For example,
      ```connect to databasename;```  
   d. Save and then run the script.
      For example,
      `db2 -tvf rightsGrant_db2zOS.sql`

7. To create the notification tablespaces, go to the c10_location/configuration/schemas/delivery/zosdb2 directory.
   a. Make a backup copy of the NC_TABLESPACES.sql script file and save the file to another location.
   b. Open the original NC_TABLESPACES.sql script file and use the following table to help you to replace the placeholder parameters with ones appropriate for your environment.
Table 32. Tablespace parameter names and descriptions for the DB2 notification database on z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>Specifies the name of the notification database.</td>
</tr>
<tr>
<td>DSN8G810</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>Specifies the name of the buffer pool.</td>
</tr>
</tbody>
</table>

Not all of the parameters listed are in the script, but might be added in the future.

3. Save and run the script.

For example,

db2 -tvf NC_TABLESPACES.sql

d. Open the NC_CREATE_DB2.sql script file and replace the NCCOG placeholder parameter with the name of the notification database.

4. Save the script.

The Job and Scheduling Monitor services will automatically run the script. However, you may choose to run it yourself.

8. To create the human tasks tablespaces, go to the c10_location/configuration/schemas/hts/zosdb2 directory.

   a. Make a backup copy of the HTS_tablespaces.sql script file and save the file to another location.
   
   b. Open the original HTS_TABLESPACES.sql script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

   Table 33. Tablespace parameter names and descriptions for human tasks on DB2 for z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>Specifies the name of the database.</td>
</tr>
<tr>
<td>DSN8G810</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>Specifies name of the 32 k buffer pool.</td>
</tr>
</tbody>
</table>

See the script for a complete list of the parameters required.

5. Save and run the script.

   d. Open the HTS2_CREATE_Db2zos.sql script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

   Table 34. Tablespace parameter names and descriptions for human tasks on DB2 for z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>The name of the database.</td>
</tr>
</tbody>
</table>

See the script for a complete list of the parameters required.

6. Save and run the script.

9. To create the annotations tablespaces, go to the c10_location/configuration/schemas/ans/zosdb2 directory.

   a. Make a backup copy of the ANN_TABLESPACES.sql script file and save the file to another location.
b. Open the original ANN_TABLESPACES.sql script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>The name of the database.</td>
</tr>
<tr>
<td>DSN8G8I0</td>
<td>The name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>The name of the 32 k buffer pool.</td>
</tr>
</tbody>
</table>

See the script for a complete list of the parameters required.

c. Save and run the script.
d. Open the ANS2_CREATE_Db2zos.sql script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>The name of the database.</td>
</tr>
</tbody>
</table>

See the script for a complete list of the parameters required.
e. Save and run the script.

Related tasks:
- "Creating tablespaces for a notification database on DB2 for z/OS" on page 117
- "Creating tablespaces for the human task and annotation database on DB2 on z/OS" on page 169

Setting up connectivity for the content store database

For Content Manager to access a DB2 content store database, you must install type 4 JDBC drivers in each location where Content Manager is installed.

Procedure
1. If you want to create a symbolic link to the driver and license files, ensure that you have write permission in the directory where the link will reside.
   a. To create a symbolic link to the universal driver file, db2jcc.jar, type the following command:
      ```bash
      ln -s $JDBCCLASSES/db2jcc.jar /c10_location/webapps/p2pd/WEB-INF/lib/db2jcc.jar
      ```
   b. To create a symbolic link to the license file, db2jcc_license_cisuz.jar, type the following command:
      ```bash
      ln -s $JDBCCLASSES/db2jcc_license_cisuz.jar /c10_location/webapps/p2pd/WEB-INF/lib/db2jcc_license_cisuz.jar
      ```
2. If you want to copy the driver and license files, in your DB2 installation, go to the directory where the JDBC driver and license files are located.
For example, $DB2HOME/db2910_jdbc/classes directory.

3. Copy the following files to the c10_location/webapps/p2pd/WEB-INF/lib directory.
   - the universal driver file, db2jcc.jar
   - the license file, db2jcc_license_cisuz.jar for DB2 on z/OS

**Verifying JDBC connectivity to the content store**

To ensure that the JDBC connection to the DB2 content store is successful, you can test the connectivity.

**Procedure**

1. To verify the version of the JDBC driver that you are using is correct, type the following command:

   ```bash
   java -cp $JDBCCLASSES/db2jcc.jar com.ibm.db2.jcc.DB2Jcc -version
   ```

   The version is displayed.

   An following examples shows an example of the response:

   IBM DB2 JDBC Universal Driver Architecture 3.63.107

2. Modify the CLASSPATH variable in your .profile file to include the clp.jar file.

   For example, if you install the command line processor into the /usr/lpp/db2910_base directory, you can issue the following command to modify your CLASSPATH variable:

   ```bash
   export CLASSPATH=$CLASSPATH:/usr/lpp/db2910_base/lib/clp.jar
   ```

3. Optionally, you can define the CLPPROPERTIESFILE environment variable in your .profile file to include the full path name where the properties file is located.

   You can copy the CLPPROPERTIES file into cognos home directory and use it. A sample properties file is in the directory where the command line processor is installed.

   Issue the following command to define the CLPPROPERTIESFILE environment variable in your .profile file:

   ```bash
   export CLPPROPERTIESFILE=/usr/lpp/db2910_base/samples/clp.properties
   ```

   a. If you installed the command line processor into the /usr/lpp/db2910_base directory, copy the default clp.properties file from /usr/lpp/db2_root_inst_dir/db2vers-dir_base/samples/clp.properties directory into your home directory.

      For example, copy the clp.properties file from the following location:

      /usr/lpp/db2/db2910/db2910_base/samples

      to the following location:

      /u/user1/

   b. To customize the clp.properties file for your system, open the file in an editor and change the following lines of code:

      ```
      #Create your own alias name for DB2 servers
      #SERVER1=<URL>,<username>,<password>
      The URL variable is in a format similar to the following:
      IPaddress:port/LOCATION_NAME
      CGCSAMP=<IPaddress>:4741/<DB2LOC>,user-1,password-2
      ```

   c. To define the CLPPROPERTIESFILE environment variable in your .profile file, issue the following command:
export CLPPROPERTIESFILE=/u/user1/clp.properties
d. At the command prompt, test the connection by typing `db2`.
   For example, if you have the alias `db2` set up in your `.profile` or `.tcshrc` file, use the following command:
   `connect to CGCSAMP`
   You should see a message similar to the following if the connection succeeded:
   `DSNC101I: The "CONNECT" command completed successfully`
e. Remember to remove your database credentials from the `clp.properties` file after you test your connection.
   The database credentials are temporarily stored in plain text in the file.

Related tasks:

[“Setting the JDBC environment variables for a DB2 content store” on page 211](#)

IBM Cognos Business Intelligence for z/OS uses JDBC connectivity to communicate with the content store. You must set up the appropriate environment variables to enable the classes used by the JDBC driver.

---

**IBM Cognos Mobile database**

You can use the content store database as your IBM Cognos Mobile database or you can use another database. If you do not use the content store database as the IBM Cognos Mobile database, use the same settings as you used for the content store database when you create the IBM Cognos Mobile database.

IBM Cognos Mobile requires a separate database connection in IBM Cognos Configuration from the content store database.

**Creating tablespaces for the Cognos Mobile database on DB2 for z/OS**

A database administrator must run scripts to create a set of tablespaces required for the mobile database. The scripts must be modified to replace the placeholder parameters with ones that are appropriate for your environment.

Ensure that you use the naming conventions for DB2 on z/OS. For example, all names of parameters must start with a letter and the length must not exceed eight characters.

For more information, see the IBM DB2 Information Center.

**Procedure**

1. Connect to the database as a user that has privileges to create and drop tablespaces and to allow execution of SQL statements.
2. Go to the directory that contains the scripts:
   `c10_location/configuration/schemas/mobile/db2zOS`.
3. Open the `tablespace_db2zOS.sql` script file.
4. Add a connection statement to the beginning of the script.
   For example,
   `connect to databasename/`
5. Use the following information to help you replace the generic parameters with ones appropriate for your environment.
COGMOBDB
Specifies the name of the mobile database.

DB0AUSR
Specifies the name of the storage group.

BP32K
Specifies the name of the buffer pool.

6. Save and run the script `tablespace_db2zOS.sql`.
   For example:
   ```
   db2 -td/ -vf tablespace_db2zOS.sql
   ```

7. Open the `rightsGrant_db2zOS.sql` script file and replace the COGMOBDB and MOBUSR placeholder parameters with the required database name and user name respectively.

8. Add a connection statement to the beginning of the script.
   For example:
   ```
   connect to databasename/
   ```

9. Save and run the script `rightsGrant_db2zOS.sql`.
   For example:
   ```
   db2 -td/ -vf rightsGrant_db2zOS.sql
   ```

10. Open the `initialize-schema-version-table.sql` script file, replace the COGMOBDB placeholder parameter with the required database name, and save the script.

11. Open the `upgrade-lock-object-init.sql` script file, replace the COGMOBDB, DB0AUSR, and BP32K placeholder parameters with the required database, storage group, and buffer pool names, and save the script.

12. Open the remaining script files starting with `upgrade`, and replace the COGMOBDB and DB0AUSR placeholder parameters with the required database name and storage group name respectively.

13. Save the scripts, but do not run them manually.
    The scripts will run automatically when the Mobile Service is started.

Results
The Cognos Mobile database is created. You can now specify the Cognos Mobile database in IBM Cognos Configuration.

Setting up JDBC connectivity to relational databases
For IBM Cognos Business Intelligence on z/OS, you must use the dynamic query mode to connect to relational databases. Install type 4 JDBC drivers in each location where the Application Tier Components are installed. Alternatively, you can modify a configuration file to point to the JDBC driver files.

Before you begin
To review an up-to-date list of environments supported by the IBM Cognos Business Intelligence, see the supported software environments page on the IBM Cognos Customer Center website (http://www.ibm.com/software/data/cognos/customercenter/).

The following table lists the data source type and the location of the JDBC driver files.
**Procedure**

1. If the IBM Cognos service is running, stop the service.

2. If you do not want to modify the properties file, but instead install JDBC driver files, copy the JDBC driver files to the `c10_location/v5dataserver/11b` directory.
   - For DB2 for z/OS, go to the `$DB2HOME/db2910_jdbc/classes` directory, and copy the universal driver file, `db2jcc4.jar` and the license file, `db2jcc_license_cisuz.jar`.
   - For information about connecting to other data sources, see the *Dynamic Query User Guide*.

3. If you do not want to install the JDBC driver files, you can instead modify the properties file with the location of the JDBC driver files.
   a. Find the `c10_installation/v5dataserver/databaseDriverLocations.properties.sample` file.
   b. Rename the file to `databaseDriverLocations.properties`.
   c. In a text editor, open the `databaseDriverLocations.properties` file.
   d. Follow the directions in the file to point to the JDBC driver files.

4. Start the IBM Cognos service.

**What to do next**

Create data source connections that use JDBC connectivity to the relational databases. Publish packages with the option to use dynamic query mode. For more information, see the *IBM Cognos Administration and Security Guide*. Enable Framework Manager models and packages to use the dynamic query mode.

**Related concepts:**

“JDBC connectivity to data sources and the dynamic query mode” on page 4

You can connect to supported data sources by using Java Database Connectivity (JDBC) connectivity. When you use JDBC connectivity, the dynamic query mode is available and provides query optimization and improved performance.

---

**IBM Cognos Business Intelligence for z/OS and the IBM Sub-Capacity Reporting Tool**

The IBM Sub-Capacity Reporting Tool (SCRT) is a no-charge IBM tool that reports required license capacity for subcapacity eligible products that run on the z/OS system.

For information about SCRT, see [Sub-Capacity Reporting Tool (SCRT)](http://www.ibm.com/systems/z/resources/swprice/subcap/scrt/). For information about zSeries® software pricing, see [IBM System z Software Pricing](http://www.ibm.com/servers/eserver/zseries/swprice/).

At startup, IBM Cognos Business Intelligence for z/OS writes a string into System Management Facility (SMF). When the SCRT processes the SMF records, it recognizes that Cognos BI for z/OS is installed and is eligible for subcapacity pricing. In the SMF records, all Cognos instances that are running within an LPAR are identified under the same ID.

To use SCRT with the product, it must be already installed on your z/OS base environment. The string provided by the product to the tool for SMF 89 records includes the following information:
To enable the product for SCRT, configure the z/OS system to record SMF 89 records.

**Related tasks:**

[“Registering Cognos Business Intelligence applications in WebSphere Application Server” on page 77](#)

Enable System Management Facility (SMF) to collect information about IBM Cognos Business Intelligence for z/OS applications that run within WebSphere Application Server.
Chapter 8. Configuration of the IBM Cognos BI components on the z/OS system after installation

To complete the installation, configuration, and verification of the IBM Cognos Business Intelligence components in the minimum amount of time, make only essential changes to the default settings. Your first objective is a fast and error-free installation. Later you can change the settings to better suit your environment.

Basic installations

Before you customize the product, configure a basic installation. Install, configure, and start one instance of each of the gateway, Application Tier Components, and Content Manager on the z/OS system, and install and configure Cognos Framework Manager on a Windows computer.

After you install the required components, but before you configure them, additional steps are required so that IBM Cognos components can communicate with the software in your environment. Initially, configure only the mandatory settings to ensure that the product functions.

The sequence in which you start the services is important. You must first configure and then start the services where you installed Content Manager.

Configuration changes

You can monitor configuration changes that you make to the IBM Cognos Business Intelligence components.

Each time that you save a configuration after making changes, date-stamped versions of the following configuration files are automatically saved in the $c10_location/configuration directory:

The following files record changes:

- cogstartup.xml
  This file records configuration settings. An example file name is cogstartup_200211231540.xml.
- coglocale.xml
  This file records locale settings that are used for multilingual reporting. An example file name is coglocale_200211261401.xml.

If you are unable to save a configuration, or you have problems with a configuration, you can revert to a previous configuration file. You can use the configuration files to review your configuration history.
Chapter 9. Configuration considerations for deploying IBM Cognos BI for z/OS to WebSphere Application Server

IBM Cognos Business Intelligence for z/OS test installations use Tomcat as a servlet container. In production or enterprise deployments, use IBM WebSphere Application Server. Some additional configuration and set up is required.

After you apply service to the environment, IBM Cognos applications must be redeployed to WebSphere Application Server.

Disk space allocation for the WebSphere profile directory

The z/OS system administrator must allocate enough disk space for the $WAS_INSTALL_ROOT/profiles/default/installedApps directory. The directory must accommodate at least 500 MB for the deployment of IBM Cognos web content files.

WebSphere Application Server instances

Each WebSphere Application Server instance is separated into two regions:
• Controller region
  This Java Virtual Machine (JVM) receives HTTP requests from clients and then routes these requests to a workload manager.
• Servant region
  This JVM selects and executes the work from the workload manager. The Workload Manager starts and stops the servant. The servant contains the IBM Cognos BI servlets.

The Workload Manager dispatches the requests to the servant JVM that contains the IBM Cognos BI application code.

The servant relies on the controller region for numerous services, such as communication, security, and transaction control.

Scaling applications - Workload Manager and IBM Cognos dispatchers

IBM Cognos dispatchers manage the distribution of requests. The dispatcher starts the IBM Cognos services that process requests and route the requests to the appropriate service. The dispatcher is a multithreaded application that uses one or more threads per request.

The dispatcher load-balancing scheme is a static algorithm. You can specify a weight for each dispatcher. A dispatcher with a weight of 2 can do twice the work of a dispatcher with a weight of 1, and so on. Each dispatcher spreads work among all the dispatchers using a weighted round-robin algorithm. For more information, see the Administration and Security Guide.

Although the Workload Manager usually manages the number of servant processes dynamically, conflicts will arise if you use Workload Manager to manage the load for IBM Cognos BI requests. IBM Cognos BI dispatchers are designed to load-balance incoming requests.
Important: Set the minimum and maximum number of servants that the Workload Manager manages to 1.

**Single IBM Cognos BI instance deployed to WebSphere Application Server**

Each WebSphere Application Server instance has one controller region and one servant region and listens for IBM Cognos BI requests on a dedicated port.

If you require multiple IBM Cognos report server processes to handle requests, the IBM Cognos dispatcher starts the processes.

You must prevent WebSphere Application Server and Workload Manager from scaling and starting another servant region during configuration.

The following diagram shows a single IBM Cognos instance deployed to WebSphere Application Server.

---

**Multiple instances of IBM Cognos BI deployed to WebSphere Application Server**

You can configure additional WebSphere Application Server instances, which each have one controller region that manages one servant.

Each servant region contains an IBM Cognos BI component.

Each WebSphere Application Server instance uses a unique port.

Ensure that WebSphere Application Server is installed and operational in each location where IBM Cognos BI components are installed.

The following diagram shows multiple instances of IBM Cognos applications deployed to WebSphere Application Server.
Web communication in an application server environment

Use WebSphere Application Server as a web server to handle requests.

Servlet gateway

You can run the IBM Cognos Servlet Gateway on WebSphere Application Server instead of using a web server. When using the servlet gateway, your environment does not require a web server. The application server and the servlet gateway replace the functions provided by the web server and other IBM Cognos gateways.

The servlet gateway is deployed to a different instance of the application server than the dispatcher and Content Manager servlets. The servlet gateway handles portal navigation and static content separate from the main application server.

IBM Cognos external dispatcher

The dispatcher is a servlet that handles requests and hosts a set of services. The services are registered to, and controlled by, the dispatcher. Routing of the request begins when a request reaches a dispatcher for the first time. The dispatcher that you configure as the first, or front, dispatcher receives the request and then can forward the request to other dispatchers. For more information, see the IBM Cognos Administration and Security Guide, and the proven practices document IBM Cognos Proven Practices: IBM Cognos 8 BI Dispatcher Routing Explained.
Adjusting the default connection time-out value for IBM Cognos Business Intelligence

The default setting for the connection time-out value used in IBM Cognos Business Intelligence is 25 seconds. Some application servers, such as IBM WebSphere, use a shorter value. To avoid conflicts between the connection time-out settings, change the connection time-out value in IBM Cognos BI. The value must be smaller than the setting that is configured in the application server.

Procedure
1. Open the \c10_location/configuration/BIBusTK_Config.xml file in a text editor.
2. Find the following string:
   `<BIBUSTK_CONNECTION_TIMEOUT>25000</BIBUSTK_CONNECTION_TIMEOUT>`
3. Change the value to 90% of the value specified for the application server. For example, WebSphere uses a default connection time-out value of 30 seconds. Calculate 90% of 30 seconds, which is 27 seconds. Change the string to:
   `<BIBUSTK_CONNECTION_TIMEOUT>27000</BIBUSTK_CONNECTION_TIMEOUT>`
4. Save the file.
5. Repeat these steps in each location where you installed IBM Cognos BI.

Configuration tasks in IBM Cognos Configuration

Some updates to the default configuration settings in IBM Cognos Configuration are required before IBM Cognos Business Intelligence can run within an application server.

Creating the application files to deploy to WebSphere Application Server

Use the Build Application Wizard in IBM Cognos Configuration to create the application file.

Procedure
1. Ensure that you allocate enough disk space for the WebSphere Application Server profile directory. The directory must accommodate at least 500 MB for the deployment of IBM Cognos web content files.
2. Open IBM Cognos Configuration.
3. Stop the IBM Cognos service if it is running.
   If the IBM Cognos service is running on Tomcat and you try to build the p2pd application by using the build application wizard, you will see the following error message:
   ```
   [ ERROR ] Unable to generate the application file filepath/p2pd.ear'.
   Problem creating war: The process cannot access the file because another process has locked a portion of the file.
   ```
4. Click Action > Build Application Files.
You must build the application file on the computer on which you will be deploying the file.

5. Follow the instructions in the wizard.

If you require more information about the choices or settings in the wizard, click the help button in the wizard.

The wizard allows you to select the type of application to build and the context root used to access the application.

The context root value entered in the wizard must be the same as is entered in the Environment tab and used to deploy to the application server. For IBM Cognos Business Intelligence, the default context root and application directory name is p2pd, which can be used in most cases. For the IBM Cognos Servlet Gateway, the default context root and application directory name is ServletGateway. Other default application deployment values, such as the application name, can be changed to better suit your environment.

6. If you are using the dispatcher as the gateway, ensure that you select to include static content in the deployment file.

Results

It is not necessary to rebuild or redeploy the archive file when you make configuration changes because configuration information is stored outside of the application. However, after you apply service, you must redeploy IBM Cognos applications to WebSphere Application Server.

Changing the IBM Cognos server configuration properties

If you did not use the Build Application wizard to configure environment properties, you must manually update the server property settings. You must update the environment properties with the host name or IP address of the computer where the IBM Cognos Business Intelligence components are installed. To avoid conflicts with other applications, assign unique port numbers for the Cognos BI application.

In a sysplex, disks are owned by a z/OS image. When an application performs an I/O operation on a disk that is not owned by the application, performance might be slow. By default, WebSphere Application Server sets the current working directory to the user's home directory. If disk ownership is different between the user's home directory and the Cognos installation directory, the I/O performance issue can occur. By setting the template root, the administrator ensures that WebSphere Application Server and Cognos BI use the same working directory.

Procedure

1. Start IBM Cognos Configuration.
2. Ensure that the fully qualified installation location of all fonts is specified for the Application Tier Components.
   By default, the installation location does not use a fully qualified path.
3. In the Explorer panel, click Environment.
4. In the Properties panel, change the localhost portion of the URIs property for each component.
   Use the computer name or IP address of the computer where the component is located and assign a port number.
The application server must be configured to listen on the host name or IP address entered in the URI. If you change the context root from the default value of p2pd, you must also change the context root portion of the URI.

- For Content Manager URIs, click the value and then click the edit icon. Change the value and then click OK.
- For all other URI properties, click the value to change it.

5. For the Gateway URI value, type the URI to the external dispatcher by using the following syntax:

   http[s]://host_name:port/p2pd/servlet/dispatch/ext

   For performance, direct requests to the external dispatcher for processing instead of using a gateway.

6. Click File > Save.

7. For improved performance, change the template.root parameter setting.
   a. Go to the c10_location/webapps/p2pd/WEB-INF/ directory.
   b. Open the xts.properties file in a text editor,
   c. To avoid performance issues during startup because of zFS disk ownership, you must change the template.root parameter to point to the absolute path of the Cognos BI installation root directory.

```
template.root=C10_location/templates/ps
```

### Configuring the connection to a DB2 content store database for WebSphere Application Server

You must specify the database server information to ensure that Content Manager can connect to the database you use for the content store. Content Manager uses the database logon to access the DB2 content store.

**Procedure**

1. In the location where you installed Content Manager, start IBM Cognos Configuration.

2. In the Explorer panel, under Data Access > Content Manager, click Content Store.

3. In the Properties panel, for the Database name property, type the name of the database or the database alias.

4. Change the logon credentials to specify a valid user ID and password:
   a. Click the Value box next to the User ID and password property and then click the edit button when it appears.
      Ensure that you specify the same user ID that you specified for CMSCRIPT_USERNAME when you created the tablespaces.
   b. Type the appropriate values and click OK.

5. For the Database server and port number property, type a value, using host:port syntax.

6. In the Properties panel, next to Advanced properties, click inside the Value box, and then click the edit button.

7. Click Add to add all of the parameters except, CMSCRIPT_USERNAME, that you used to create the tablespaces.

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Value (examples)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_CREATE_IN</td>
<td>COGUCST1.T1TSCS</td>
</tr>
</tbody>
</table>
Table 37. Parameter names and values (continued)

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Value (examples)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_STOGROUP</td>
<td>DBOIUSR</td>
</tr>
<tr>
<td>CMSCRIPT_DATABASE</td>
<td>COGUCS</td>
</tr>
<tr>
<td>CMSCRIPT_CS_ID</td>
<td>T1</td>
</tr>
<tr>
<td>CMSCRIPT_TABLESPACE</td>
<td>TSCS</td>
</tr>
<tr>
<td>CMSCRIPT_LARGE_BP</td>
<td>BP32K</td>
</tr>
<tr>
<td>CMSCRIPT_REGULAR_BP</td>
<td>BP16K0</td>
</tr>
</tbody>
</table>

8. Click File > Save.
   The logon credentials are immediately encrypted.

9. To test the connection between Content Manager and the content store database, click Actions > Test.

**Configure a connection to the IBM Cognos Mobile database**

In IBM Cognos Configuration, you must add the database that you are using as your IBM Cognos Mobile database. You must add the database if you are using the content store database or a separate database.

**Procedure**

1. Open IBM Cognos Configuration.
2. In the Explorer panel, under Data Access, right-click Mobile, and click New Resource > Database.
3. Enter a Name for the database, and ensure that DB2 database is selected in Type.
4. Click OK.
5. For the Database server and port number property, type a value, using host:port syntax.
6. Change the logon credentials to specify a valid user ID and password:
   a. Click the Value box next to the User ID and password property and then click the edit button when it appears.
   b. Type the appropriate values and click OK.
7. For the Database name property, type the name of the database or the database alias.
   If you are using the content store database, enter the name or alias of the content store database.
8. Click File > Save.

**Configuring a connection to a mail server for WebSphere Application Server**

If you want to send reports by email, you must configure a connection to a mail server account.

**About this task**

If you do not plan to send reports by email, or do not want to set up a mail server account immediately, you are not required to configure a connection. However, when you save the configuration and then you start the services in IBM Cognos Configuration, you will see a warning message when the mail server connection is
tested. You can safely ignore the warning.

**Procedure**

1. In the **Explorer** panel, under **Data Access**, click **Notification**.

2. In the **Properties** panel, for the **SMTP mail server** property, type the host name and port of your SMTP (outgoing) mail server.

   To open reports that are sent by email, you must change the host name portion of the **Gateway URI** from localhost to either the IP address of the computer or the computer name. Otherwise, the URL the email will contain localhost and remote users will not be able to open the report.

   To be able to open reports that are sent as links, ensure that the **Gateway URI** on report servers and notification servers specifies an accessible web server hosting IBM Cognos content.

3. Click the **Value** box next to the **Account and password** property and then click the edit button.

4. Type the appropriate values in the **Value - Account and password** dialog box and then click **OK**.

   If logon credentials are not required for the SMTP server, remove the default information for the **Account and password** property. When you are prompted for confirmation to leave this property blank, click **Yes**. Ensure that the default user name has been removed. Otherwise, the default account is used and notifications will not work properly.

5. In the **Properties** panel, type the appropriate value for the default sender account.

6. To test the mail server connection, in the **Explorer** panel right-click **Notification > Test**.

**Configuring a servlet gateway**

If you configure a IBM Cognos servlet gateway, the application server and the IBM Cognos servlet gateway replace the functions provided by a web server. Deploying a servlet gateway is useful when using single signon between WebSphere Application Server and IBM Cognos Business Intelligence components.

**Before you begin**

Ensure the following tasks are complete:

- WebSphere Application Server is running.
  
  On each computer where you plan to install the servlet gateway, WebSphere Application Server must be installed and running.

- IBM Cognos BI gateway components are installed on the same system as WebSphere Application Server.

- The IBM Cognos BI dispatcher and Content Manager components are installed and running in the environment.

- The WebSphere Application Server user account has full access permission for the IBM Cognos installation.

**About this task**

Instead of routing requests directly to the dispatcher, you deploy the servlet gateway to a different JVM instance than the JVM instances that run the IBM Cognos BI dispatcher and Content Manager servlets. Doing this type of
deployment separates the load for serving static content from the main applications.

Procedure
1. If necessary, create a separate JVM instance.
   If you plan to run IBM Cognos BI and the IBM Cognos Servlet Gateway on the same application server, the servlet gateway must be deployed to a separate JVM instance.
2. Check that IBM Cognos components are properly set up.
3. Set environment variables.
4. Configure IBM Cognos Servlet Gateway to run in WebSphere Application Server.
5. If necessary, change the application server startup script.
6. Configure application server properties and deploy IBM Cognos Servlet Gateway.
7. If required, enable SSL.

Results
You can now access IBM Cognos BI components using the IBM Cognos Servlet Gateway, by entering the gateway URI. For example, http[s]:host_name:port/ServletGateway

The IBM Cognos Servlet Gateway URI is case-sensitive.

Creating a separate JVM instance in IBM WebSphere
To eliminate potential Java class or system resource conflicts, run IBM Cognos Business Intelligence for z/OS in a Java Virtual Machine (JVM) instance that is isolated from other applications. This ensures that IBM Cognos BI for z/OS does not affect existing applications.

About this task
When possible, install IBM Cognos BI for z/OS in a JVM instance that is separate from the WebSphere Application Server administrative processes to isolate both IBM Cognos and the administrative functions of the application server.

If you are using the IBM Cognos Servlet Gateway, ensure that you run it in an instance that is separate from IBM Cognos BI for z/OS.

On the z/OS system, a WebSphere Application servant is the address space in which the JVM resides and the IBM Cognos BI application runs in the servant.

Procedure
Create a separate server instance in IBM WebSphere.
When you create a separate server instance, an isolated JVM is also created. For more information, see the WebSphere Application Server documentation.
Setting environment variables to run IBM Cognos BI in Websphere Application Server

You must set environment variables to identify the location of the Java Virtual Machine (JVM) and the location of the IBM Cognos installation.

About this task

You set environment variables for the servant region in the WebSphere administrative console.

Procedure

Set the following environment variables for the servant region in the WebSphere administrative console:

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>_BPX_JOBNAME</td>
<td>CGC</td>
</tr>
<tr>
<td>_BPXK_AUTOCVT</td>
<td>ON</td>
</tr>
<tr>
<td>_CEE_RUNOPTS</td>
<td>POSIX(ON),FILETAG(AUTOCVT,AUTOTAG),HEAPPOOLS(ALIGN),HEAPPOOLS64(ALIGN)</td>
</tr>
</tbody>
</table>

Note: The line continuation for this value.

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>STEPLIB</td>
<td>prefix.SDSNEXIT:prefix.SDSNLOAD:prefix.SDSNLOAD2</td>
</tr>
<tr>
<td>DSNAOINI</td>
<td>/u/user1/db2odbc/odbcini</td>
</tr>
</tbody>
</table>

Specifies an ODBC initialization file for the ODBC subsystem (DSN) and plan (DSNACL).

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM_JAVA_ENABLE.ASCII_FILETAG</td>
<td>Set to ON because z/OS uses the EBCDIC character encoding and IBM Cognos BI Java applications use ASCII encoding.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIBPATH</td>
<td>/c10_location/bin64:/c10_location/bin:/bin</td>
</tr>
</tbody>
</table>

Include the /bin directory to ensure keystores are tagged correctly at startup.

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>PATH</td>
<td>/c10_location/bin64:/c10_location/bin:/bin</td>
</tr>
</tbody>
</table>

Include the /bin directory to ensure keystores are tagged correctly at startup.

To install multiple instances of IBM Cognos BI, set the LIBPATH and PATH variables within the application server instance scope and not as a global variable to ensure that each instance has a unique value.
You must configure WebSphere application server properties and deploy the IBM Cognos Business Intelligence components.

**Verifying environment variable settings configured in WebSphere Application server**

To ensure that WebSphere Application Server is properly configured for the deployment of IBM Cognos Business Intelligence for z/OS applications, you can use UNIX System Services to test that the environment variables are set.

**Procedure**

1. Log on to UNIX System Services as the user that runs IBM Cognos.
   The account under which IBM Cognos BI runs must have specific environment variables configured in WebSphere Application Server.

2. In the UNIX System Services shell, test that the environment variables are set.

**Table 39. Environment variables for WebSphere Application Server**

<table>
<thead>
<tr>
<th>Environment variable</th>
<th>Values or examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>BPXK_AUTOCVT</td>
<td>ON</td>
</tr>
</tbody>
</table>
| _CEE_RUNOPTS         | POSIX(ON), FILETAG(AUTOCVT, AUTOTAG)  
  **Note:** The only space character in this string is before the word AUTOTAG. |
| JAVA_HOME            | ${WASHOME}/java64 |
| PATH                 | $JAVA_HOME/bin:/bin:  
  ${COGROOT}/bin64:  
  ${COGROOT}/bin:$JAVA_HOME/bin:$PATH |
| IBM_JAVA_ENABLE_ASCII_FILETAG | ON |
| STEPLIB              | prefix.SDSNEXIT:  
  prefix.SDSNLOAD:  
  prefix.SDSNL0D2 |
| DSNAOINI             | /u/user1/db2odbc/odbcini |
| LIBPATH              | ${JDBCHOME}/lib/bin:  
  ${COGROOT}/bin64:$COGROOT/bin:  
  ${JAVA_HOME}/bin:$PATH:$LIBPATH |
| DISPLAY              | host_name:display_number |
| LANG                 | C |

- To view a list of the environment variables set in you shell, type the following command:
  ```
  env
  ```
- To test each of the environment variables one-by-one, use the following command:
  ```
  env | grep <environment variable>
  ```

**Registering Cognos Business Intelligence applications in WebSphere Application Server**

Enable System Management Facility (SMF) to collect information about IBM Cognos Business Intelligence for z/OS applications that run within WebSphere Application Server.
For example, use this information to monitor report system reliability, identify system resource usage, and execute performance-related tasks that your organization might require.

**Procedure**

1. Go to the c10_location/configuration/samples directory.
2. Locate the CognosSCRT.registrar.xml file in the WAS_instance/AppServer/properties/version directory.
   The file must be in the WebSphere Application Server instance under which IBM Cognos BI runs.
3. Remove the .xml extension.
   The .xml file extension is used to ensure ASCII file tagging. To be registered under WebSphere Application Server, the file must use a .registrar file extension.
   The program automatically recognizes the .registrar file extension.

Related concepts:

"IBM Cognos Business Intelligence for z/OS and the IBM Sub-Capacity Reporting Tool" on page 63

The IBM Sub-Capacity Reporting Tool (SCRT) is a no-charge IBM tool that reports required license capacity for subcapacity eligible products that run on the z/OS system.

**Configuring WebSphere Application Server properties**

You must configure WebSphere application server properties and deploy the IBM Cognos Business Intelligence components.

**Before you begin**

Performance is dependent upon efficient spool access. Depending on the output you choose to produce, such as tracing, ensure that one of the following conditions are met:

- Have sufficient spool space.
- Direct output records to a dataset or USS (Unix System Services) file.

For example, for information about how to redirect SYSPRINT to HFS files so that they can be viewed with common editors, see *Directing SYSPRINT Output to an HFS File in WebSphere for z/OS, TD101087*, on the IBM Techdocs Web site:


WebSphere Application Server for z/OS address spaces can produce a large number of trace records when tracing is activated.

**Procedure**

1. Start WebSphere Application Server, and then open the WebSphere Administrative Console.
2. Install a new Enterprise Application using the application file that was built by IBM Cognos Configuration.

For IBM Cognos BI, the default context root is **p2pd**, which can be used in most cases. For the IBM Cognos Servlet Gateway, the default context root is **ServletGateway**. Other default application deployment values, such as the application name, can be changed to better suit your environment. The context...
root value used to deploy the application must be the same as the context root
value entered in IBM Cognos Configuration when running the Build
Application wizard.

3. Change the default memory used by the JVM.
   Usually, the memory is set by adding or changing the initial and maximum
Java heap size. For information about these parameters, see the JVM or
WebSphere application server documentation.
   Set the JVM heap size to larger than 256 MB. For the consistent throughput, set
the -Xms starting minimum and -Xmx maximum to the same size.
   a. Set the (-Xms) starting minimum to 756 MB.
   b. Set the (-Xmx) maximum to 756 MB.

4. In WebSphere Administration, in Environment > Websphere variables, create
the following two WebSphere name-value pairs, and save them to the master
configuration:
   • name = protocol_http_timeout_output_recovery
     value = SESSION
   • name = protocol_https_timeout_output_recovery
     value = SESSION

5. To specify the number of application threads that are used in each of the
servants that are running in an application server, set the
servant_region_custom_thread_count to 500.
   If you specify a value for this custom property, you must set the Workload
profile property on the ORB services z/OS additional settings page in the
administrative console to CUSTOM before this setting becomes effective. For
more information, see the WebSphere Application Server Information Center.

6. Set the minimum number of instances and the maximum number of instances
for the IBM Cognos server instances to 1.
   This ensures that the IBM Cognos dispatchers are used for scaling the
application.

7. Stop and then restart the WebSphere application server instance used for IBM
Cognos Business Intelligence components.

8. Verify that IBM Cognos BI components are running by looking for the
following message in the application server admin console or in the application
server log file:
   The dispatcher is ready to process requests.

---

**Connecting to the IBM Cognos BI portal after deploying to WebSphere Application Server**

You run all your web-based IBM Cognos applications from IBM Cognos
Connection. After you have completed the configuration, you can test that your
installation is successful by connecting to the IBM Cognos Business Intelligence portal.

**Procedure**

1. Open a web browser.
2. Type the gateway URL.
   • If you are using the dispatcher as a gateway, type
     http://host_name:port/p2pd/servlet/dispatch/ext.
     For example,
http://myserver:9080/p2pd/servlet/dispatch/ext

• If you are using a servlet gateway, type
  http://host_name:port/ServletGateway,

It might take a few minutes for the web page to open. If you see the IBM
Cognos portal, your installation is working.

Enabling SSL in the application server environment

If you use the Secure Socket Layer (SSL) for IBM Cognos components, you must
also enable SSL in the application server environment. You then identify the SSL
server certificate to IBM Cognos components.

Procedure
1. Configure the application server to use SSL.
   An SSL server certificate is generated by another Certificate Authority (CA).
   The certificate of the CA that generated the SSL server certificate is also
   provided.
   For more information about configuring the application server to use SSL, refer
to the application server documentation. For information about using CA
certificates with your application server, see the CA documentation.
2. Copy the CA certificate to the c10_location/bin directory and rename the file
to ca.cer.
   This file must be Base-64 encoded X.509 format.
3. From the c10_location/bin directory, type: ThirdPartyCertificateTool.sh -T
   -i -r ca.cer -k ../configuration/signkeypair/jCIAkeystore -p password
   You must type jCIAkeystore as the name of the CA key store.

Unregistering dispatchers

You must unregister any IBM Cognos Business Intelligence dispatchers that were
previously registered and that are no longer used. For example, if you initially
configured and started the product to run in Tomcat, and are now using
WebSphere Application Server, you must unregister any Tomcat dispatchers that
are currently running.

Procedure
1. Open IBM Cognos Connection by connecting to the IBM Cognos BI portal and
clicking IBM Cognos Content on the Welcome page.
2. In the upper-right corner, click Launch > IBM Cognos Administration.
   You remove dispatchers using IBM Cognos Administration. To access this tool,
you must have execute permissions for the Administration secured function.
3. On the Configuration tab, click Dispatchers and Services.
4. For the dispatcher you want to unregister, click Actions > More > Unregister.
5. In the confirmation dialog box, click OK.

Results

The dispatcher information is removed from Content Manager.
What to do next

If you exported the content store before setting up IBM Cognos BI components to run in WebSphere Application Server, import the deployment to restore and encrypt the data using the new encryption keys. For more information, see the topic about importing to a target environment in the Administration and Security Guide.
Chapter 10. Configuration tasks for deploying IBM Cognos BI for z/OS to Apache Tomcat servlet container

By default, IBM Cognos Business Intelligence for z/OS installs and uses Tomcat as the servlet container.

Use Tomcat as a servlet container for test or proof of concept installations, or for troubleshooting installation issues. Few configuration changes are required to get a basic installation of IBM Cognos Business Intelligence for z/OS running quickly.

Configuring IBM HTTP Web Server to view IBM Cognos BI static content

To view IBM Cognos BI web pages, you configure virtual directories on the web server. To use the 64-bit version of the IBM Cognos BI gateway, use a script to copy the required files.

Note: Use a web server for Tomcat application server. For WebSphere Application Server, directly connect to the dispatcher to view online content.

Procedure

1. Ensure that the file `c10_location/configuration/cogstartup.xml` file belongs to the same group as the web server.
   The account under which the web server runs must have READ access to the `cogstartup.xml` file. By default the `cogstartup.xml` file has READ permission for OTHER

2. Ensure that the environment variable `_BPXK_AUTOCVT` is set to off.
   For example,
   ```sh
   _BPXK_AUTOCVT=OFF
   export _BPXK_AUTOCVT
   ```

3. To use the 64-bit CGI gateway, go to the `c10_location/cgi-bin` and type the following command:
   ```sh
   ./copyGateMod.sh 64bit
   ```
   The 64-bit gateway files are copied from the `cgi-bin/lib64` directory to the `cgi-bin` directory.

4. Go to the `IHS_DIR/conf` directory and make a backup copy of the `httpd.conf` file.
   Creating a backup of the configuration file makes it easier to recover from editing errors.

5. Open the `httpd.conf` file in a text editor

6. Create two virtual directories.
   a. Add the following text to the `httpd.conf` file to specify where the CGI scripts are located.
      ```conf
      ScriptAlias /ibmcognos/cgi-bin `c10_location/cgi-bin`
      ```
      The `ScriptAlias` defines where CGI scripts are located. You must define the `ScriptAlias` before the `Alias`.
      The directory must have EXECUTE permission.
b. Add the following to the text file to configure a map between URLs and the file system directory:
   
   ```
   Alias /ibmcognos c10_location/webcontent
   
   The directory must have READ permission.
   ```

   7. If you want to use the image browser for Report Studio, enable web Distributed Authoring and Versioning (webDAV).

   8. Save the file and restart the web server.

   9. Set the `_BPXK_AUTOCVT` environment variable to `ON` For example,

   ```
   _BPXK_AUTOCVT=ON
   export _BPXK_AUTOCVT
   ```

   Related concepts:

   "64-bit IBM Cognos gateway" on page 2

   In earlier versions, if you installed 64-bit versions of IBM Cognos Business Intelligence, only 32-bit versions of the gateway component were available. In this version, 64-bit versions of the gateway are also available. You can take advantage of the 64-bit hardware and the new 64-bit libraries.

   Related tasks:

   "Changing the IBM Cognos server configuration properties" on page 71

   If you did not use the Build Application wizard to configure environment properties, you must manually update the server property settings. You must update the environment properties with the host name or IP address of the computer where the IBM Cognos Business Intelligence components are installed. To avoid conflicts with other applications, assign unique port numbers for the Cognos BI application.

   "Configuring the gateway for multiple server instances" on page 97

   If you install the gateway component in a different location than Content Manager or Application Tier Components, you must configure the gateway to ensure that it can locate a dispatcher.

---

**Configuring IBM Cognos server components to run in Tomcat servlet container**

You must update the environment properties with the host name or IP address of the computer where the IBM Cognos Business Intelligence components are installed to ensure that the components can communicate with each other. You must assign port numbers for the IBM Cognos application that will not conflict with existing applications.

**Procedure**

1. Start IBM Cognos Configuration.

2. Ensure that the fully qualified installation location of all fonts is specified for the Application Tier Component components.

3. In the Explorer panel, click Environment.

4. In the Properties panel, change the localhost portion of all URI properties to the name or IP address of your IBM Cognos server.

   a. For Dispatcher URIs for gateway and Content Manager URIs, click the value and then click the edit button.

   b. Change the localhost portion and then click OK.

   c. For all other URI properties, click the value and change it.
5. To configure a mail server account, in the Explorer panel, under Data Access, click Notification.

To send reports by email, you must configure a connection to a mail server account. If you do not plan to send reports by email, or do not want to set up a mail server account immediately, you are not required to configure a connection. However, when you save the configuration and then you start the services in IBM Cognos Configuration, you will see a warning message when the mail server connection is tested. You can safely ignore the warning.

a. In the Properties panel, for the SMTP mail server property, type the host name and port of your SMTP (outgoing) mail server.

To open reports that are sent by email, you must change the host name portion of the Gateway URI from localhost to either the IP address of the computer or the computer name. Otherwise, the URL in the email will contain localhost and remote users will not be able to open the report.

To be able to open reports that are sent as links, ensure that the Gateway URI on report servers and notification servers specifies an accessible Web server hosting IBM Cognos content.

b. Click the Value box next to the Account and password property and then click the edit button.

c. Type the appropriate values in the Value - Account and password dialog box and then click OK.

If logon credentials are not required for the SMTP server, remove the default information for the Account and password property. When you are prompted for confirmation to leave this property blank, click Yes. Ensure that the default user name has been removed. Otherwise, the default account is used and notifications will not work properly.

d. In the Properties panel, type the appropriate value for the default sender account.

e. Test the mail server connection, in the Explorer panel right-click Notification > Test.

6. Click File > Save.

Configuring the connection to a DB2 content store database for Tomcat servlet container

You must specify the database server information to ensure that Content Manager can connect to the database you use for the content store. Content Manager uses the database logon to access the DB2 content store.

Procedure

1. In the location where you installed Content Manager, start IBM Cognos Configuration.

2. In the Explorer panel, under Data Access > Content Manager, click Content Store.

3. In the Properties panel, for the Database name property, type the name of the database or the database alias.

4. Change the logon credentials to specify a valid user ID and password:
   a. Click the Value box next to the User ID and password property and then click the edit button when it appears.

   Ensure that you specify the same user ID that you specified for CMSCRIPT_USERNAME when you created the tablespaces.

   b. Type the appropriate values and click OK.
5. For the **Database server and port number** property, type a value, using `host:port` syntax.

6. In the **Properties** panel, next to **Advanced properties**, click inside the **Value** box, and then click the edit button.

7. Click **Add** to add all of the parameters except, CMSCRIPT_USERNAME, that you used to create the tablespaces.

### Table 40. Parameter names and values

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Value (examples)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_CREATE_IN</td>
<td>COGUCST1.T1TSCS</td>
</tr>
<tr>
<td>CMSCRIPT_STOGROUP</td>
<td>DBOIUSR</td>
</tr>
<tr>
<td>CMSCRIPT_DATABASE</td>
<td>COGUCS</td>
</tr>
<tr>
<td>CMSCRIPT_CS_ID</td>
<td>T1</td>
</tr>
<tr>
<td>CMSCRIPT_TABLESPACE</td>
<td>TSCS</td>
</tr>
<tr>
<td>CMSCRIPT_LARGE_BP</td>
<td>BP32K</td>
</tr>
<tr>
<td>CMSCRIPT_REGULAR_BP</td>
<td>BP16K0</td>
</tr>
</tbody>
</table>

8. Click **File > Save**. The logon credentials are immediately encrypted.

9. To test the connection between Content Manager and the content store database, click **Actions > Test**.

**Related tasks:**

"Creating tablespaces for a content store on DB2 for z/OS" on page 56

A database administrator must run scripts to create a set of tablespaces required for the content store database. Modify the scripts to replace the placeholder parameters with ones that are appropriate for your environment.

### Configure a connection to the IBM Cognos Mobile database

In IBM Cognos Configuration, you must add the database that you are using as your IBM Cognos Mobile database. You must add the database if you are using the content store database or a separate database.

**Procedure**

1. Open IBM Cognos Configuration.

2. In the **Explorer** panel, under **Data Access**, right-click **Mobile**, and click **New Resource > Database**.

3. Enter a **Name** for the database, and ensure that **DB2 database** is selected in **Type**.

4. Click **OK**.

5. For the **Database server and port number** property, type a value, using `host:port` syntax.

6. Change the logon credentials to specify a valid user ID and password:
   a. Click the **Value** box next to the **User ID and password** property and then click the edit button when it appears.
   b. Type the appropriate values and click **OK**.

7. For the **Database name** property, type the name of the database or the database alias.
   If you are using the content store database, enter the name or alias of the content store database.
8. Click File > Save.

**Configuring a connection to a mail server for Tomcat servlet container**

If you want to send reports by email, you must configure a connection to a mail server account.

**About this task**

If you do not plan to send reports by email, or do not want to set up a mail server account immediately, you are not required to configure a connection. However, when you save the configuration and then you start the services in IBM Cognos Configuration, you will see a warning message when the mail server connection is tested. You can safely ignore the warning.

**Procedure**

1. In the **Explorer** panel, under **Data Access**, click **Notification**.
2. In the **Properties** panel, for the **SMTP mail server** property, type the host name and port of your SMTP (outgoing) mail server.
   
   To open reports that are sent by email, you must change the host name portion of the Gateway URI from localhost to either the IP address of the computer or the computer name. Otherwise, the URL in the email will contain localhost and remote users will not be able to open the report.

   To be able to open reports that are sent as links, ensure that the Gateway URI on report servers and notification servers specifies an accessible Web server hosting IBM Cognos content.
3. Click the **Value** box next to the **Account and password** property and then click the edit button.
4. Type the appropriate values in the **Value - Account and password** dialog box and then click **OK**.

   If logon credentials are not required for the SMTP server, remove the default information for the Account and password property. When you are prompted for confirmation to leave this property blank, click **Yes**. Ensure that the default user name has been removed. Otherwise, the default account is used and notifications will not work properly.
5. In the **Properties** panel, type the appropriate value for the default sender account.
6. Test the mail server connection, in the **Explorer** panel right-click **Notification** > Test.

**Configuring the connection to the Cognos Content Database**

If Cognos Content Database and Content Manager are not collocated, you must set the database connection properties for Cognos Content Database. If Cognos Content Database and Content Manager are collocated, Content Manager uses default settings to communicate with Cognos Content Database.

In a production environment, you must use an enterprise-level database, such as DB2 for z/OS, for your content store.

**Procedure**

1. In the location where you installed Content Manager, start IBM Cognos Configuration.
2. In the Explorer panel, under Data Access > Content Manager, right-click Content Store > Delete.
   This deletes the connection to the default resource.
3. Right-click Content Manager > New resource > Database.
4. In the Properties panel, configure IBM Cognos Business Intelligence server components to use Cognos Content Database as the content store:
   a. For Name, type cm.
   b. For Database server and port number, type the name of the computer where you installed Cognos Content Database.
   c. For User ID and password, click the edit button and type cognos for both the userid and password to access Cognos Content Database.
5. Click File > Save.
   The logon credentials are immediately encrypted.
6. To start the Cognos Content Database service, right-click IBM Cognos content database > Start.
   You must start the Cognos Content Database service before you test
7. To test the connection between Content Manager and the content store database, click Actions > Test.

Related tasks:
"Creating another instance of Cognos Content Database" on page 124
You can create another content store database in Cognos Content Database.

Starting the IBM Cognos services
You must register the IBM Cognos Business Intelligence service so that users can access it through IBM Cognos Connection. To register the service, start the service in IBM Cognos Configuration.

Procedure
1. Start IBM Cognos Configuration.
2. Save the configuration.
3. Click Actions > Test.
4. If the test fails, reconfigure the affected properties and then test again.
   You can test some components individually by right-clicking the component in the Explorer panel and selecting Test.
   Do not start the service until all tests pass.
5. Click Actions > Start.
   It might take a few minutes for the IBM Cognos service to start.
   This action starts all installed services.

Verifying the installation and configuration of server components in Tomcat servlet container
Test the installation and configuration to verify that the IBM Cognos Business Intelligence server components are using supported software, can connect to the supported software, and are working.
Procedure

1. Use the Test feature in IBM Cognos Configuration as you configure components to ensure the configuration is valid and that components are configured to use supported software products.
   a. In the Explorer panel, click the node that you want to test or click Local Configuration to test all of the settings at once.
   b. Click Actions > Test.
      Fix any errors and retest.
   c. Click File > Save to save the configuration.

2. Test that the content store was successfully created and that Content Manager started.
   a. Open a web browser.
   b. Type http://host_name:port/p2pd/servlet
      If Content Manager is running, a web page will display that shows the current time and State: Running.
      Content Manager will not start if the content store was not created or if there are errors in the connection properties to the content store database.

3. Test the availability of the dispatcher.
   a. Open a web browser.
   b. Type http://host_name:port/p2pd/servlet/dispatch
      If the dispatcher, a web page will display that shows the IBM Cognos portal without the images.

4. Connect to the IBM Cognos BI portal by typing the following, where ibmcognos is the virtual directory you created when you configured the Web server.
   http://host_name:port/ibmcognos
   When you see the Welcome page in the IBM Cognos BI portal, your installation is working.

Changing the deployment from Tomcat servlet container to WebSphere Application Server

If IBM Cognos Business Intelligence components are running in the Tomcat servlet container, and you want to deploy to WebSphere Application Server, you must also back up existing IBM Cognos information.

Procedure

1. If data exists in the content store, start the IBM Cognos service and export the entire content store using the Deployment tool.
   For more information, see the topic about creating an export deployment specification in the Administration and Security Guide.

2. In IBM Cognos Configuration, click File > Export As and save the configuration information in a decrypted format.

3. In IBM Cognos Configuration, stop the IBM Cognos service.

4. Back up the following cryptographic keys by saving the appropriate files and directories to an different file location.
   a. Back up the following files:
      - c10_location/configuration/cogstartup.xml
      - c10_location/configuration/caSerial
      - c10_location/configuration/cogconfig.prefs
b. Back up the following directories:
   • c10_location/configuration/csk
   • c10_location/configuration/encryptkeypair
   • c10_location/configuration/signkeypair

5. Delete the caSerial and the cogconfig.prefs files.

6. Replace the c10_location/configuration/cogstartup.xml file with the file that contains the decrypted data exported from IBM Cognos Configuration.
   In the c10_location/configuration directory, the file must use the name cogstartup.xml.
   The information in this file will be automatically re-encrypted using new cryptographic keys when you save the configuration in IBM Cognos Configuration.

**Adjusting the memory resources for the IBM Cognos service**

You can change the amount of resources that the IBM Cognos service uses. By default, the IBM Cognos service is configured to use minimal memory resources to optimize startup time.

The configuration settings for the IBM Cognos service apply only to Tomcat servlet container. If you want to configure IBM Cognos BI to run in WebSphere Application Server, configure the memory resources within that application server environment.

The IBM Cognos service is available you installed Content Manager or the Application Tier Components.

**Procedure**

1. Start IBM Cognos Configuration.
2. In the Explorer panel, expand Environment > IBM Cognos services, and then click IBM Cognos.
3. In the Properties panel, change the value for Maximum memory in MB.
   • To reduce the startup time, memory footprint, and resources used, use the default setting.
   • To balance between fast startup time and quick operating speeds, type a value about 1.5 times the default value, such as 1152.
   • To maximize operating speeds and if performance is more important than fast startup time, and if your computer has a lot of resources, type a value about double the default value, such as 1536.
4. Click File >Save.
Chapter 11. Multiple instances of server components

You can install multiple instances of the gateway, Application Tier Components and Content Manager on the z/OS system, and you can also install each component or combination of components into separate locations. You might choose these installation preferences for performance, security, or other reasons.

Basic installation for multiple instances of a component

When you install more than one instance of a server component, there are many options for customizing IBM Cognos BI. However, to minimize the time required to ensure a successful installation, first perform a basic installation. Install one instance of each of the required server components on the z/OS system and install Cognos Framework Manager on a Windows computer. After you configure the components to communicate with each other, and verify that the installation works, you can customize settings and add optional components.

Installation sequence

In a distributed installation, the sequence in which you configure and start components is important. Start the services for Content Manager before you start the services for other server components.

You must configure the gateway component last to ensure that cryptographic keys are shared and secure communication can take place among the server components. The server specified in the external dispatcher URI property on the gateway computer must be the last server component that you start.

Install and configure all server components before you install the Windows components.

Sequence to stop services

The sequence in which you stop the services is important. Stop the Application Tier Components first, followed by the standby Content Manager, and then the active Content Manager.

It is important to also stop the following services or components:

- Web servers that host IBM Cognos content.
- Applications that are related to the IBM Cognos service.
- IBM Cognos Software Development Kit applications.

Content Manager configurations

In an installation where you have more than one Content Manager, or where Content Manager is located in a separate location from other components, at least one Content Manager must be configured, running, and accessible before you configure other IBM Cognos components. This ensures that the certificate authority service, which is installed with Content Manager, is available to issue certificates to other components.
Active and standby Content Manager instances

You can install any number of installations of Content Manager, although only one is active at any time. Each of the other installations acts as a standby Content Manager.

A standby Content Manager is for failover protection. If the active Content Manager is not available because of a software or hardware failure, a standby Content Manager becomes active and requests are directed to it.

When the active Content Manager fails, unsaved session data is lost. When another Content Manager becomes active, users might be prompted to log on.

By default, the first Content Manager installed with IBM Cognos BI server is the active one. An IBM Cognos server administrator can change the default Content Manager and the active Content Manager at any time. When IBM Cognos is started, the default Content Manager locks the content store so that it cannot be accessed by installations of Content Manager. All other Content Manager installations enter standby mode.

This failover mechanism works because dispatchers and the active Content Manager routinely communicate with each other. If a dispatcher can no longer reach Content Manager, the dispatcher signals a standby Content Manager, which becomes the active Content Manager. The other installations of Content Manager remain in standby mode for continued failover support. The standby Content Managers retrieve cryptographic settings, such as the common symmetric key (used to encrypt and decrypt data), from the active Content Manager.

Configuring the connection to a DB2 content store database for each Content Manager instance

You must specify the database server information to ensure that the active and standby Content Manager components can connect to the database that you use for the content store.

Procedure

1. In the location where you installed Content Manager, start IBM Cognos Configuration.
2. In the Explorer panel, under Data Access > Content Manager, click Content Store.
3. In the Properties panel, for the Database name property, type the name of the database or the database alias.
4. Change the logon credentials to specify a valid user ID and password:
   a. Click the Value box next to the User ID and password property and then click the edit button when it appears.
      Ensure that you specify the same user ID that you specified for CMSCRIPT_USERNAME when you created the tablespaces.
   b. Type the appropriate values and click OK.
5. For the Database server and password property, type a value, using host:port syntax.
6. In the Properties panel, next to Advanced properties, click inside the Value box, and then click the edit button.
7. Click Add to add all of the parameters except, CMSCRIPT_USERNAME, that you used to create the tablespaces.
Table 41. Parameter names and values

<table>
<thead>
<tr>
<th>Parameter name</th>
<th>Value (examples)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMSCRIPT_CREATE_IN</td>
<td>COGUCST1.T1TSCS</td>
</tr>
<tr>
<td>CMSCRIPT_STOGROUP</td>
<td>DBOIUSR</td>
</tr>
<tr>
<td>CMSCRIPT_DATABASE</td>
<td>COGUCS</td>
</tr>
<tr>
<td>CMSCRIPT_CS_ID</td>
<td>T1</td>
</tr>
<tr>
<td>CMSCRIPT_TABLESPACE</td>
<td>TSCS</td>
</tr>
<tr>
<td>CMSCRIPT_LARGE_BP</td>
<td>BP32K</td>
</tr>
<tr>
<td>CMSCRIPT_REGULAR_BP</td>
<td>BP16K0</td>
</tr>
</tbody>
</table>

8. Click File > Save. The logon credentials are immediately encrypted.

9. To test the connection between Content Manager and the content store database, click Actions > Test.

Development environments: Configuring Cognos Content Database

If you installed Cognos Content Database in a different location than Content Manager, you must set the database connection properties for Cognos Content Database.

About this task

If you installed Cognos Content Database in the same location as Content Manager, Content Manager is configured to use Cognos Content Database using the default values.

In a production environment, you must use an enterprise-level database for your content store. If you have been using Cognos Content Database in a test or proof-of-concept system, you can use the features in the administration portal to back up and archive the data before moving to an enterprise-level database in your production environment. For more information, see the topic about deploying the entire content store in the Administration and Security Guide.

Procedure

1. In the location where you installed Content Manager, start IBM Cognos Configuration.

2. In the Explorer panel, under Data Access, Content Manager click Content Store.

3. In the Properties panel, change the following properties:
   a. For the Name property, type cm.
   b. For the Database server and port number property, type the name of the computer where you installed Cognos Content Database.
   c. For the User ID and password property, click the edit button and type cognos for both the userid and password to access Cognos Content Database.

4. Change the default user ID and password after configuring the new resource.

4. Click File > Save.
The logon credentials are immediately encrypted.

5. Start the Cognos Content Database service in the location where it is installed.

6. To test the connection between Content Manager and the content store, click **Actions > Test**

Content Manager connects to the database, checks the database permissions, and creates and populates a table. The table is not deleted and is used each time that the test is repeated.

**Results**

Content Manager can now create the required tables in the content store when you start the IBM Cognos service for the first time. If the connection properties are not specified correctly, the tables are not created and you cannot connect to IBM Cognos Connection.

**Configuring environment properties for the default active Content Manager instance**

Content Manager must know the locations of the content store and the other Content Manager components. It must also be configured to store the symmetric key locally.

**About this task**

If you install multiple Content Manager components for failover, you must designate one as the active one. By default, the first one that you configure is the active Content Manager.

**Procedure**

1. In the location where you installed the Content Manager that you want designated as the active Content Manager, start IBM Cognos Configuration.

2. In the **Explorer** panel, click **Environment**.

3. In the **Properties** panel, click the value for **Content Manager URIs** and then click the edit button.

4. Specify the URIs for the other Content Manager components.

   a. In the **Value - Content Manager URIs** dialog box, click **Add**.

   b. In the blank row of the table, click and then type the full URI of the Content Manager instance.

      Do not delete the first value in the table. This value identifies the local Content Manager instance and is required.

   c. Repeat the previous steps for each URI that you want to add.

      You must include all Content Manager URIs in the list.

   d. Click **OK**.

5. In the **Explorer** panel, under **Security**, click **Cryptography**.

6. In the **Properties** panel, under **CSK settings**, set **Store symmetric key locally** to **True**.

7. Click **File > Save**.
Configuring environment properties for the standby Content Manager instances

The standby Content Manager is used for failover in the case of a software or hardware failure. The standby Content Manager must know the locations of the content store and the other Content Manager components. It must also be configured to store the symmetric key locally.

Before you begin

Ensure that you already configured at least one instance of Content Manager and that it is running. This ensures that the CA authority issues the standby Content Manager a security certificate.

Procedure

1. In the location where you installed the Content Manager that you want designated as a standby Content Manager, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, click the value for Content Manager URIs and then click the edit button.
4. Specify the URIs for the other Content Manager components.
   a. In the Value - Content Manager URIs dialog box, click Add.
   b. In the blank row of the table, click and then type the full URI of the Content Manager instance.
      Do not delete the first value in the table. This value identifies the local Content Manager instance and is required.
   c. Repeat the previous steps for each URI that you want to add.
      You must include all Content Manager URIs in the list.
   d. Click OK.
5. In the Explorer panel, under Security, click Cryptography.
6. Ensure that all cryptographic settings match what you configured for the default active Content Manager.
7. In the Explorer panel, under Data Access > Content Manager, click Content Store.
8. Ensure that the values for all of the properties match what you configured for the default active Content Manager.
9. Click File > Save.

What to do next

For failover, ensure that you configure authentication providers in all locations where you installed Content Manager. When the default active Content Manager fails, the system automatically switches to a Standby Content Manager and requests are directed to it.

Starting multiple Content Manager instances

The service for the active Content Manager must be started before the services for any other component.
Procedure
1. In the location where you installed the active Content Manager, start IBM Cognos Configuration using the group and user account that owns the installation files.
2. Ensure that you save your configuration, otherwise you cannot start the IBM Cognos BI service.
3. Click Actions > Test.
   IBM Cognos Configuration checks the common symmetric keys (CSK) availability, tests the namespace configuration, and tests the connections to the content store and logging database. If you are using the notification database and the mail server, they are tested as well.
   If Test is not available for selection, in the Explorer panel, click Local Configuration.
4. If the test fails, reconfigure the affected properties and then test again.
   You can test some components individually by right-clicking the component in the Explorer panel and selecting Test.
   Do not start the service until all tests pass.
5. Click Actions > Start.
   It might take a few minutes for the IBM Cognos BI service to start.
6. Test that Content Manager is running by typing the Content Manager URI from IBM Cognos Configuration.
   For example, in a Web browser, type http://host_name:port/p2pd/servlet.
   The State value should be Running.

Configuring environment properties for multiple instances of Application Tier Components

The Application Tier Components must know the locations of the gateway, Content Manager, and notification database.

About this task

If you install the Application Tier Components in a different location than Content Manager, you must configure each Application Tier Components installation to ensure it can locate and communicate with Content Manager.

The Application Tier Components must also know the location of the notification database to use for job and schedule information. The Application Tier Components must use the same notification database that the Content Manager uses.

Procedure
1. In each Application Tier Components location, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, change the localhost portion of the Content Manager URIs property to match the host name or IP address of the Content Manager instance.
   a. In the Value - Content Manager URIs dialog box, click Add.
   b. In the blank row of the table, click and then type the full URI of the Content Manager.
   c. Click OK.
4. If you are using Tomcat application server, change the localhost portion of the Gateway URI property to the host name or IP address of the gateway instance.
5. Click File > Save.
6. Start the services by clicking Actions > Start.

---

**Configuring the gateway for multiple server instances**

If you install the gateway component in a different location than Content Manager or Application Tier Components, you must configure the gateway to ensure that it can locate a dispatcher.

**Before you begin**

Ensure that the active Content Manager is running and available.

**About this task**

A dispatcher is installed with every Content Manager and Application Tier Components instance.

For failover protection, you can configure more than one dispatcher for a gateway. When multiple dispatchers are configured, requests are normally routed to the first dispatcher in the list. If this dispatcher becomes unavailable, the gateway determines the next functioning dispatcher on the list and routes requests there. The primary dispatcher status is monitored by the gateway, and requests are routed back to this component when it returns to service.

To protect your data, configure the gateway to use the dispatcher that is installed with an Application Tier Components instance.

**Procedure**

1. In each gateway location, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, under Gateway Settings, type the values for Dispatcher URIs for the gateway property.
   a. Click in the value column.
   b. Click in the edit column.
   c. Change the localhost portion of the URI to the name or IP address of the Application Tier Components location.

To send requests to the dispatcher from an IBM Cognos Software Development Kit application or an IBM Cognos modeling tool that is outside of a network firewall, use a dedicated gateway that is configured to connect to the dispatcher using the internal dispatcher URI. For example `http://localhost:9300/p2pd/servlet/dispatch`.

For security reasons, the default setting for the Dispatcher URI for gateway property prevents the dispatcher from accepting requests for an IBM Cognos Software Development Kit application or modeling tool that is outside the firewall.

Ensure that you configure appropriate security for this dedicated gateway, such as SSL. Do not change your main gateway to use the internal dispatcher URI. Doing so will reduce the security of the IBM Cognos portal and studios.

4. In the Explorer panel, under Security, Cryptography, click Cognos, the default cryptographic provider.
5. Under the Certificate Authority settings property group, set the Password property to match the configuration on the default active Content Manager.
6. Ensure that all other cryptographic settings match those that you set for the default active Content Manager.
7. To test that the symmetric key can be retrieved, in the Explorer panel, right-click Cryptography > Test.
8. Click File > Save.

Related tasks:
"Configuring IBM HTTP Web Server to view IBM Cognos BI static content" on page 83

To view IBM Cognos BI web pages, you configure virtual directories on the web server. To use the 64-bit version of the IBM Cognos BI gateway, use a script to copy the required files.

## Configuring multiple instances of the index services for index search

In an environment in which there is a large volume of report requests, you can install multiple instances of the Application Tier Components. You can configure multiple instances of the index services for index search.

### About this task

The following diagram shows the index search service and index update service in the applications tier, and the index data services in the data tier.

![Diagram showing index services configuration for application and data tiers](image-url)

*Figure 5. Example of index services configuration for application and data tiers*

### Procedure

1. Install one instance of Application Tier Components in the applications tier.
2. In the application tier, enable the index search service and index update service.
3. Install an instance of Application Tier Components in the data tier.
4. In the data tier, enable index search service.
5. If required, install additional Application Tier Components instances in the application tier.
6. For each additional instance in the application tier, enable the index search service.
7. Install an instance of Application Tier Components in the data tier.
8. For the additional instance in data tier, enable the index data service.
Chapter 12. Installation of Windows components

For a working product, you must install Windows components, such as Framework Manager. You are not required to install optional Windows components, such as Cognos Transformer.

IBM Cognos Business Intelligence for z/OS cannot use data for reporting, querying, analyzing or other business intelligence capabilities unless the data is first packaged in and published from Cognos Framework Manager. You must install and configure Cognos Framework Manager to communicate with the server components as part of a basic installation.

Optionally, you might want to install
• Cognos Transformer, the OLAP modeling component that models and builds PowerCubes,
• IBM Cognos Business Intelligence Supplementary Languages Documentation for translated documentation
• IBM Cognos Software Development Kit

Reviewing the hardware and software requirements for Windows components

Before you install Windows components, ensure that you have adequate system resources in your environment for your models.

Review the minimum hardware and software prerequisites that are required to install and run the Windows components. Additional resources might be required for larger or production environments. The size of your models determines the hardware requirements, such as disk space

Procedure
1. Use the following table to check the hardware and software requirements to install and run the Cognos Framework Manager on Windows.

   Table 42. System requirements for Cognos Framework Manager
   
<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system (32-bit)</td>
<td>Windows</td>
</tr>
<tr>
<td>Disk space</td>
<td>Minimum: 500 MB of free space on the drive that contains the temporary directory used by IBM Cognos Business Intelligence components</td>
</tr>
<tr>
<td>Database</td>
<td>If required, database client software installed on the same computer as Cognos Framework Manager</td>
</tr>
<tr>
<td></td>
<td>Database connectivity set up</td>
</tr>
</tbody>
</table>

2. Review an up-to-date list of environments supported by IBM Cognos products, such as operating systems, patches, browsers, Web servers, directory servers, database servers, and application servers on the IBM Cognos Resource Center Web site [http://www.ibm.com/software/data/support/cognos_crc.html].

© Copyright IBM Corp. 2011, 2013
3. Use the following table to check the hardware and software requirements to install and run the Cognos Transformer on Windows.

Table 43. System requirements for Cognos Transformer

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating system (32-bit)</td>
<td>Windows</td>
</tr>
<tr>
<td>Disk space</td>
<td>Minimum: 500 MB of free space on the drive that contains the temporary directory used by IBM Cognos Business Intelligence components.</td>
</tr>
<tr>
<td>Database</td>
<td>If required, database client software installed on the same computer as Cognos Transformer; Database connectivity set up</td>
</tr>
<tr>
<td>Other</td>
<td>Microsoft Data Access Component (MDAC) 2.6 or later for use with product samples</td>
</tr>
</tbody>
</table>

**Installing Cognos Framework Manager on a Windows computer**

For a complete installation of IBM Cognos Business Intelligence for z/OS, you must install Cognos Framework Manager on a Windows computer. Framework Manager is a 32-bit metadata modeling tool.

**Procedure**

1. Start the installation program:
   - Insert the Cognos Framework Manager disk (IBM Cognos Business Intelligence Modeling).
     If the installation wizard does not open automatically, go to the operating system directory, and double-click the iSetup.exe file.
   - Go to the location where the installation files were downloaded and extracted and then double-click the iSetup.exe file.

2. Follow the directions in the installation wizard to copy the required files to your computer.
   - Install in a directory that contains only ASCII characters in the path name. Some servers do not support non-ASCII characters in directory names. Installing Cognos Framework Manager in directory that has an apostrophe in the path name might result in the help not opening properly.

3. When notified with an information message about installing the Supplementary Languages Documentation, click OK.
   - The Supplementary Languages Documentation contains translated versions of Guidelines for Modeling Metadata. If you want this guide available in languages in addition to English, install the contents of the disk. Otherwise your installation includes only the English version of the guide.

4. On the last page of the installation wizard, select Start IBM Cognos Configuration to configure Cognos Framework Manager immediately.
   - You can choose to configure Cognos Framework Manager later by starting the configuration tool from the Windows Start menu shortcut in the IBM Cognos program folder.

5. Secure the installation directory from unauthorized access.
What to do next

Default settings are used for the configuration. You can change these default settings during the installation or later, to better suit your environment.

Related tasks:

“Configuring Cognos Framework Manager to communicate with server components on the z/OS system”

To ensure that Cognos Framework Manager can communicate with the IBM Cognos Business Intelligence server components on the z/OS system, you must environment properties.

Default settings for Cognos Framework Manager

The installation program installs IBM Cognos Framework Manager using default values. After installation, use the configuration tool to change the settings to suit your environment.

The following table lists the default settings for Cognos Framework Manager.

<table>
<thead>
<tr>
<th>Property</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gateway URI</td>
<td><a href="http://localhost:80/ibmcognos/cgi-bin/cognos.cgi">http://localhost:80/ibmcognos/cgi-bin/cognos.cgi</a></td>
</tr>
<tr>
<td>Dispatcher URI for external applications</td>
<td><a href="http://localhost:9300/p2pd/servlet/dispatch">http://localhost:9300/p2pd/servlet/dispatch</a></td>
</tr>
</tbody>
</table>

Related tasks:

“Configuring Cognos Framework Manager to communicate with server components on the z/OS system”

To ensure that Cognos Framework Manager can communicate with the IBM Cognos Business Intelligence server components on the z/OS system, you must environment properties.

Configuring Cognos Framework Manager to communicate with server components on the z/OS system

To ensure that Cognos Framework Manager can communicate with the IBM Cognos Business Intelligence server components on the z/OS system, you must environment properties.

Before you begin

Ensure that the server components are installed and configured and running.

About this task

To communicate the server components, Cognos Framework Manager uses one the following routes:

- Through the gateway
- Directly to the Application Tier Components dispatcher
  
  Use this communication route for WebSphere Application Server.

The property settings that you configure for Cognos Framework Manager computers depends upon the communication route.
Procedure

1. On the computer where you installed Cognos Framework Manager, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, in the Gateway URI box, change the host name portion of the Gateway URI from localhost to either the IP address of the computer or the computer name.
   - To use a servlet gateway, type the following syntax:
     \[http[s]://host_name:port/context_root/servlet/Gateway\]
     where context_root is the value you assigned to the ServletGateway Web application when you deployed the ServletGateway application.
   - If you are not using a Web server, to use the dispatcher as the gateway, type the following syntax:
     \[http[s]://host_name:port/p2pd/servlet/dispatch/ext\]
4. Specify the value for the Dispatcher URI for external applications.
   - If your web server is configured not to allow anonymous access, type the URI of the dispatcher.
     Ensuring that you change the host name in the URI from localhost.
   - If your web server supports chunked transfer encoding and Cognos Framework Manager is inside the firewall, type the URI of the dispatcher.
     Ensure that you change the host name in the URI from localhost.
   - If you are using a dedicated gateway for modeling tool communication, type the external dispatcher URI.
5. In the Explorer panel, under Cryptography > Cognos, the default cryptographic provider.
6. Under the Certificate Authority settings property group, for the Password property, type the password you configured for the default active Content Manager.
7. Click File > Save.

Testing the Cognos Framework Manager installation

Verify that the installation of Cognos Framework Manager is working to ensure that Cognos Framework Manager can communicate with the IBM Cognos Business Intelligence server components on z/OS.

Procedure

To start Cognos Framework Manager, from the Start menu, click Programs, IBM Cognos, IBM Cognos Framework Manager If you see the Welcome page of Cognos Framework Manager, your installation is working. If your installation is not working, check your network connection to ensure you can communicate with the IBM Cognos server components on the z/OS system.

Installing IBM Cognos Cube Designer

Install IBM Cognos Cube Designer in the same location as IBM Cognos Framework Manager. The IBM Cognos Cube Designer is the application that you use to model dimensional metadata and dynamic cubes.
Procedure

1. Start the installation program:
   - Insert the IBM Cognos Cognos Cube Designer disk.
     If the installation wizard does not open automatically, go to the operating system directory, and double-click the issetup.exe file.
   - Go to the location where the installation files were downloaded and extracted and then double-click the issetup.exe file.

2. Follow the directions in the installation wizard to copy the required files to the same location as Framework Manager.

Related concepts:

“IBM Cognos Dynamic Cubes installation” on page 2
IBM Dynamic Cubes are databases optimized to provide high speed query performance over large data sets of metadata for business intelligence reporting and analysis.

Installing Cognos Insight from Cognos Connection

End users can install IBM Cognos Insight on their computers from the Welcome to IBM Cognos software page. Cognos Insight starts after the installation has completed.

Before you begin

Ensure that the BI administrator assigns all users who need to install Cognos Insight to the Advanced Business Author role. For more information about assigning capabilities, see the IBM Cognos Business Intelligence Administration and Security Guide.

Procedure

1. In a web browser, type the Cognos BI Gateway web address.
   For example, type http://localhost/ibmcognos where localhost is the name of the computer where the Cognos BI portal is installed.

2. On the Welcome to IBM Cognos software page, in the My Actions pane, click Install and launch desktop workspace software on my computer.
   Tip: Alternatively, on the IBM Cognos Connection page, from the Launch menu, click IBM Cognos Insight.

3. If this is the first time you have used Cognos Insight, do the following steps.
   a. Click Install Now. The installer file, CognosInsight.msi, is downloaded to your computer. This may take a few minutes.
   b. If the file CognosInsight.msi does not run automatically after being downloaded, click Run if prompted, or double-click the file to run it.
   c. If prompted, open the provagent.cogrcp_insight file.
Installing the Cognos Transformer client on a Windows computer

IBM Cognos Transformer, the metadata modeling tool for creating PowerCubes, is an optional installation component.

Before you begin

The IBM Cognos Business Intelligence server components and the Cognos Transformer server utility for building PowerCubes on the z/OS system must be installed and running.

About this task

For a complete installation of Cognos Transformer, you must install it on both a Windows computer and on the z/OS system. Cognos Transformer components are installed in both environments and you then use the features and tools that are appropriate for each environment. For example, Cognos Transformer client provides a graphical user interface for designing models on Windows computers. You then build cubes on the z/OS system.

The Cognos Transformer client must be installed on a 32-bit Windows computer.

Procedure

1. Start the installation program:
   - Insert the Cognos Transformer disk.
     If the installation wizard does not open automatically, go to the operating system directory, and double-click `issetup.exe`.
   - Go to the location where the installation files were downloaded and extracted and then double-click `issetup.exe`.

2. Follow the directions in the installation wizard to copy the required files to your computer.
   Install in a directory that contains only ASCII characters in the path name.
   Some servers do not support non-ASCII characters in directory names.
   Installing Cognos Transformer in a directory that has an apostrophe in the path name might result in the help not opening properly.

3. Select a language for the installation.
   When you select a language in the installation wizard, it determines the language of the user interface. Only that language is installed. You cannot change the language properties after installation. If you want to change the language of the user interface, you must reinstall Cognos Transformer.

4. On the last page of the installation wizard, select Start IBM Cognos Configuration to configure Cognos Transformer immediately.
   You can choose to configure Cognos Transformer later by starting the configuration tool from the Windows Start menu shortcut in the IBM Cognos program folder.
   When Cognos Transformer is installed on Windows Vista, if you do not have Administrator privileges on the computer and you make changes to the
cogtr.xml file, the updated file is saved by default to a Virtual Store directory and not to the c10_location/configuration directory.

5. Secure the installation directory from unauthorized access.

What to do next

Default settings are used for the configuration. You can change these default settings during the installation or later, to better suit your environment.

Related tasks:
“Updating the Cognos Transformer sample preferences file for Windows Vista computers” on page 112

If you want to use the cogtr.xml.samples file as a template, you must edit the default preferences settings.

Default settings for the Cognos Transformer client

The installation program installs the Cognos Transformer client using default values. After installation, use the configuration tool to change the settings to suit your environment.

The following table lists the default settings for Cognos Transformer.

Table 45. Default settings for Cognos Transformer

<table>
<thead>
<tr>
<th>Property</th>
<th>Default value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gateway URI</td>
<td><a href="http://localhost:80/ibmcognos/cgi-bin/cognos.cgi">http://localhost:80/ibmcognos/cgi-bin/cognos.cgi</a></td>
</tr>
<tr>
<td>Dispatcher URI for external applications</td>
<td><a href="http://localhost:9300/p2pd/servlet/dispatch">http://localhost:9300/p2pd/servlet/dispatch</a></td>
</tr>
</tbody>
</table>

Related tasks:
“Configuring the Cognos Transformer client to communicate with server components on z/OS”

To enable the Cognos Transformer client to communicate with the server components on z/OS you must configure the environment properties for Cognos Transformer in IBM Cognos Configuration.

Configuring the Cognos Transformer client to communicate with server components on z/OS

To enable the Cognos Transformer client to communicate with the server components on z/OS you must configure the environment properties for Cognos Transformer in IBM Cognos Configuration.

Before you begin

Ensure that IBM Cognos Business Intelligence server components, including Cognos Transformer are installed, configured and running. This ensures that the certificate authority service issues a certificate to Cognos Transformer. Ensure that the Web server is configured and running.

Procedure

1. On the computer where you installed Cognos Transformer, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, in the Gateway URI box, change the host name portion of the Gateway URI from localhost to either the IP address of the computer or the computer name.
   - To use a servlet gateway, type the following syntax:
     http[s]://host_name:port/context_root/servlet/Gateway
     where context_root is the value you assigned to the ServletGateway Web application when you deployed the ServletGateway application.
   - If you are not using a Web server, to use the dispatcher as the gateway, type the following syntax:
     http[s]://host_name:port/p2pd/servlet/dispatch

4. Specify the value for the Dispatcher URI for external applications.
   - If your Web server is configured to not allow anonymous access, type the URI of the dispatcher.
     Ensure that you change the host name in the URI from localhost.
   - If your Web server supports chunked transfer encoding and Cognos Framework Manager is inside the firewall, type the URI of the dispatcher.
     Ensure that you change the host name in the URI from localhost.
   - If you are using a dedicated gateway for modeling tool communication, type the dispatcher URI.

5. In the Explorer panel, under Cryptography, click Cognos, the default cryptographic provider.

6. Under the Certificate Authority settings property group, for the Password property, type the password you configured for the default active Content Manager.

7. Click File > Save.

8. If you installed Cognos Transformer on a Windows Vista computer, update your file location properties.
   a. Log on as an administrator.
   b. In the c10_location\configuration directory, open the cogtr.xml.sample file in a text editor.
   c. Locate all values that use a relative path, "..\directory".
   d. Replace the relative path element, ",", with the same environment variable and root directory that you use for file locations on the other IBM Cognos BI computers.
   e. Save the file as cogtr.xml.
   f. In the c10_location\CS7Gateways\bin directory, open the cs7g.ini file in a text editor.
   g. Add the locations for your IBM Cognos Series 7 data sources to the file.
   h. Save the file.

Changes are applied the next time you open Cognos Transformer.

**Testing the Cognos Transformer client installation**
Verify that the installation of Cognos Transformer is working to ensure that Cognos Transformer can communicate with the IBM Cognos Business Intelligence server components on z/OS.
Procedure

To start IBM Cognos Transformer, from the Start menu, click Programs > IBM Cognos > Transformer.
To start IBM Cognos Transformer manually, double-click the cogtr.exe file in the c10_location\bin directory.
If you see the Cognos Transformer window, your installation is working.

Installing the IBM Cognos Software Development Kit on Cognos Framework Manager computers

If you plan to create and publish models using the Cognos Framework Manager API, you must install the IBM Cognos Software Development Kit.

Before you begin

Ensure that IBM Cognos BI components, including Cognos Framework Manager, are installed.

If you plan to use the Microsoft Excel plug-in demo, you must have the MSINET.OCX file installed in the System32 sub-folder of your Windows folder.

About this task

Install the Software Development Kit files from the IBM Cognos Software Development Kit CD on every computer where IBM Cognos Software Development Kit applications are developed, and in the same installation location as Cognos Framework Manager.

Procedure

1. Start the installation program:
   - Insert the IBM Cognos Software Development Kit disk on each computer where you installed Cognos Framework Manager.
     If the installation wizard does not open automatically, go to the operating system directory, and double-click issetup.exe.
   - Go to the location where the installation files were downloaded and extracted and then double-click issetup.exe.
2. Follow the instructions in the installation wizard to copy the required files to the location where you installed Cognos Framework Manager.
    After the installation is complete, you can access the IBM Cognos Software Development Kit documentation using the shortcut in the Windows Start menu.
3. If you want to run the Cognos Framework Manager script player from outside the c10_location\bin directory, configure the FM_INI_FILE_PATH environment variable as a system variable on Windows.
    The environment variable must point to the c10_location\configuration\fm.ini directory.
4. To allow the browsing or import of system objects such as tables, views, synonyms, stored procedures, or functions from a relational database in Cognos Framework Manager, edit the entry for ImportDatabaseSystemObjects in your fm.ini file.
By default, ImportDatabaseSystemObjects is set to FALSE. Users can see only the user tables in the import and expression editor dialog boxes. To allow browsing or import of system objects, set the preference to TRUE.

Installing the translated product documentation on Windows computers

The product installation on Windows includes a limited set of translated documentation for some languages. To access a complete set of translated documentation on the computers where Cognos Framework Manager or Cognos Transformer are installed, you must install the documentation from IBM Cognos Business Intelligence Supplementary Languages Documentation.

Before you begin

Ensure that the following tasks are completed:

- The Windows components are installed.
  You cannot install the Supplementary Languages Documentation into a new location. The documentation must be installed on top of an existing installation.
- Adequate disk space is available.
  You need at least 220 MB of disk space.

Procedure

1. Start the installation program:
   - Insert the IBM Cognos Supplementary Languages Documentation disk on each computer where you installed Cognos Framework Manager and the Cognos Transformer client.
     If the installation wizard does not open automatically, go to the operating system directory, and double-click the issetup.exe file.
   - Go to the location where the installation files were downloaded and extracted and then double-click the issetup.exe file.

2. Follow the instructions in the installation wizard to copy the required files to the location where you installed Cognos Framework Manager and the Cognos Transformer client.

3. When prompted to choose the components to install, ensure that Additional Language Fonts is not selected.
   To add support for the Japanese Yen or Korean Won character, you must install additional fonts on the z/OS system where the application tier components are installed.

4. In the Finish page of the installation wizard, choose the option you want.
   Translated product documentation is available locally.

Uninstalling Windows components

Use the uninstallation program to remove Windows components.

Before you begin

Close all programs before you uninstall. Otherwise, some files might not be removed.
Procedure

1. From the Start menu, click Programs > IBM Cognos > Uninstall IBM Cognos > Uninstall IBM Cognos.

2. Follow the instructions in the uninstall wizard to uninstall the components.
   The cognos_uninst_log.htm file records the activities that the Uninstall wizard performs while uninstalling files. To find the log file, look in the Temp directory.

3. Delete all temporary Internet files from the web browser computers.
   For more information, see your web browser documentation.

Results

Uninstalling does not remove any files that changed since the installation, such as configuration and user data files. Your installation location remains on your computer, and you retain these files until you delete them using Windows Explorer program.
Chapter 13. Optional configuration tasks for Framework Manager

Framework Manager is designed to operate in many environments. A number of default configuration properties are initially set to allow them to work with minimal changes. Change the default behaviour after you completed a successful basic installation.

Updating the file location properties for Cognos Framework Manager on Windows Vista computers

If you install IBM Cognos client components on Windows Vista computers, you must change file locations properties in IBM Cognos Configuration to ensure that the product uses a single data location for all users.

About this task

Windows Vista has a security enhancement that restricts multiple users from sharing data locations. You can define environment variables and use them in IBM Cognos Configuration when specifying file locations. This allows you to direct applicable files to an area that will be accessible by IBM Cognos users. On Windows, two environment variables are preset for users: one for all users and one for the specific user.

Because the environment variables represent system root locations, you can include the root directory name of the installation location when you specify file locations in IBM Cognos Configuration.

In addition, if you install Cognos Transformer on a Windows Vista computer, and you plan to use the cogtr.xml samples file as a template, you must update the default preferences in the Cognos Transformer configuration file.

Procedure

1. On all computers where IBM Cognos modeling components are installed, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, click Deployment files location.
4. Replace the relative path element, "..", with the appropriate environment variable and root directory:
   - For a single file location per user, use %LOCALAPPDATA% 
   - For a single file location for all users on the computer, use %PUBLIC%
5. Repeat step 4 for the following properties:

<table>
<thead>
<tr>
<th>Explorer functional group</th>
<th>Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Environment</td>
<td>Data files location</td>
</tr>
<tr>
<td></td>
<td>Map files location</td>
</tr>
<tr>
<td></td>
<td>Temporary files location</td>
</tr>
</tbody>
</table>
Table 46. Properties and functional group (continued)

<table>
<thead>
<tr>
<th>Explorer functional group</th>
<th>Property</th>
</tr>
</thead>
<tbody>
<tr>
<td>Environment, Logging, File</td>
<td>Log file location</td>
</tr>
<tr>
<td>Cryptography</td>
<td>Common symmetric key store location</td>
</tr>
<tr>
<td>Cryptography, Cognos</td>
<td>Certificate location</td>
</tr>
<tr>
<td></td>
<td>Signing key store location</td>
</tr>
<tr>
<td></td>
<td>Encryption key store location</td>
</tr>
</tbody>
</table>

6. Click **File > Save**.

**Results**

The environment variables are resolved when the file locations are accessed during system activities.

**Updating the Cognos Transformer sample preferences file for Windows Vista computers**

If you want to use the cogtr.xml.samples file as a template, you must edit the default preferences settings.

**About this task**

With security enhancements in Windows Vista, Microsoft changed the structure of user directories. If you want all users to have the same default directories, you must change the default preferences to a common location to which users have access. If you want users to have the Windows Vista directories, you can delete the default preferences for the directories.

**Procedure**

1. Log on as the administrator.
2. In the `c10_location\configuration` directory, open the `cogtr.xml.sample` file in a text editor in elevated mode by right-clicking on the text editor and selecting **Run as Administrator**.
3. If you want all users to have the same default directories, change the directories to a location to which all users have read and write access.
   
   The directories to change are as follows:
   - `<Preference Name="CubeSaveDirectory" Type="string" Value="..\temp"/>
   - `<Preference Name="DataSourceDirectory" Type="string" Value="..\temp"/>
   - `<Preference Name="DataWorkDirectory" Type="string" Value="..\temp"/>
   - `<Preference Name="LogFileDirectory" Type="string" Value="..\logs"/>
   - `<Preference Name="ModelSaveDirectory" Type="string" Value="..\temp"/>
   - `<Preference Name="ModelWorkDirectory" Type="string" Value="..\temp"/>

4. If you want users to have the Windows Vista default directories, delete the preferences specified in step 3 from the file.

   The default directories for Cognos Transformer on the Windows Vista operating system are listed in the following table.
### Creating a network installation location for Cognos Transformer modelers

Your organization might have specialized business or power users who want to build PowerCubes that are modeled on a combination of corporate and personal data sources. These users might want to do their own analysis of the data for their line of business or a small group of users. An installer or administrator can download an executable file to a web or LAN location, where modelers can run the file to launch the IBM Cognos Transformer installation wizard.

#### Before you begin

Modelers must have privileges to create a data source in IBM Cognos Administration. Modelers do not need direct access to IBM Cognos Administration. They can create and update data sources by using Cognos Transformer or command line tools. You can provide modelers with a secured folder in IBM Cognos Connection in which to publish PowerCube packages.

Modelers must have access to a location in which to store the PowerCube after building it. This location must also be accessible to the IBM Cognos BI service and can be a secured share on a LAN.

To build PowerCubes on a specific Cognos Transformer server, modelers should have FTP privileges to transfer models and execute privileges to build cubes on that server. Modelers can transfer models and execute cube builds using scripts. Modelers can also use automated methods to build PowerCubes.

#### Procedure

1. Insert the disk for IBM Cognos Transformer modeling product, or go to the location where the installation files are downloaded and extracted.
2. If the **Welcome** page of the installation wizard appears, exit the wizard.
3. On the disk, locate the **c8transformerinstall.exe** file.
4. Copy the file to a secure location to which your Cognos Transformer modelers have access.

---

**Table 47. The default directories and locations for Cognos Transformer**

<table>
<thead>
<tr>
<th>Directory</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>CubeSaveDirectory</td>
<td>Documents\Transformer\PowerCubes</td>
</tr>
<tr>
<td>DataSourceDirectory</td>
<td>In IBM Cognos Configuration, under <strong>Environment</strong>, <strong>Data files location</strong> property</td>
</tr>
<tr>
<td>LogFileDirectory</td>
<td>Documents\Transformer\Logs</td>
</tr>
<tr>
<td>ModelSaveDirectory</td>
<td>Documents\Transformer\Models</td>
</tr>
<tr>
<td>ModelWorkDirectory</td>
<td>In IBM Cognos Configuration, under <strong>Environment</strong> &gt; <strong>Temporary files location</strong> property</td>
</tr>
</tbody>
</table>

5. Change other settings as required.
6. Save the file as cogtr.xml.

The changes are applied the next time you open Cognos Transformer.

**Related concepts:**

[“Internet Protocol versions” on page 123](#)

IBM Cognos Business Intelligence for z/OS supports IPv4 and IPv6.
Exporting IBM Cognos Transformer configuration files

To configure the IBM Cognos Transformer installation files for modelers, copy an exported configuration file from one Cognos Transformer computer for use with all other Cognos Transformer computers and then run a silent configuration.

About this task

To export the configuration, the source computer must have the same IBM Cognos Business Intelligence components as the target Cognos Transformer computers.

If some modelers install on Windows Vista computers, you must create an export file from a Windows Vista computer. Create separate folders on the Web or LAN location for Windows and Windows Vista.

Procedure

1. In IBM Cognos Configuration, click File > Export as.
2. If you want to export the current configuration to a different folder, in the Look in box, locate and open the folder.
   Ensure that the folder is protected from unauthorized access.
3. In the File name box, type a name for the configuration file.
4. Click Save.
5. Rename the exported file to cogstartup.xml.
6. Copy the exported cogstartup.xml file from the source computer to the same web or LAN location as the Cognos Transformer installation file.
7. If you changed the global configuration on the source computer, copy the coglocale.xml file from the source computer to the same web or LAN location as the Cognos Transformer installation file.
   The default location of the coglocale.xml file is c10_location/configuration.
8. If you updated the cogtr.xml file, copy it from the c10_location/configuration directory to the same web or LAN location as the Cognos Transformer installation file.
9. If you updated the cs7g.ini file, copy it from the c10_location\CS7Gateways\bin directory to the same web or LAN location as the Cognos Transformer installation file.

Deploying Cognos Transformer to modelers

A business specialist or a Cognos Transformer modeler deploys Cognos Transformer to build PowerCubes and publish them to selected users or groups.

Before you begin

If IBM Cognos Connection is secured, you must have privileges to create data sources and publish packages in IBM Cognos Connection.

Procedure

1. From the web or LAN location that the administrator provided, run the C8transformerinstall.exe file.
   The contents are expanded to the Documents and Settings\username\Local settings\Temp directory and then the Cognos Transformer installation wizard opens.
2. Follow the directions in the installation wizard and copy the required files to your computer.

3. In the Finish page of the wizard, select View the Release Notes and then click Finish.

4. Create a MANPATH environment variable and configure it with the following value:
   
   `/c10_location/webcontent/documentation/en/cogtr_a.html`

   The cogtr_a.html document provides the syntax for UNIX command line options that are supported by IBM Cognos Transformer. The man page for IBM Cognos Transformer is accessible in UNIX by typing `cogtr man` from the `c10_location/bin` directory.

5. Go to the same web or LAN location as the Cognos Transformer installation file.

6. If any .xml files are present, copy them to the Transformer_location\configuration directory.

7. Go to the Transformer_location\bin directory.

8. Type the configuration command:

   `./cogconfig.bat -s`

   IBM Cognos Configuration applies the configuration settings specified in the local copy of cogstartup.xml, encrypts credentials, generates digital certificates, and starts the IBM Cognos BI service.

9. To test IBM Cognos Transformer, from the Start menu, click Programs, IBM Cognos BI, Transformer.

   If you see the Transformer window, your installation is working.
Chapter 14. Configuration options and examples for server components

Originally, default property settings chosen by IBM Cognos are used to configure the components. After you install and configure a basic installation, you can change a number of settings if existing conditions make the default choices inappropriate, or to better suit your environment. You can configure your system over time, as conditions change.

Creating tablespaces for a notification database on DB2 for z/OS

If you are using DB2 for z/OS, a database administrator must run scripts to create a set of tablespaces required for the notification database. The scripts must be modified to replace the placeholder parameters with ones that are appropriate for your environment.

Ensure that you use the naming conventions for DB2 for z/OS. For example, all names of parameters must start with a letter and the length must not exceed 6 characters. For more information, see the IBM DB2 Information Center.

Procedure

1. Connect to the database as a user with privileges to create and drop tablespaces and to allow execution of SQL statements.
2. Go to the \c10\location/configuration/schemas/delivery/zosdb2 directory.
3. Open the \NC\_TABLESPACES.sql script file and use the following table to help you to replace the placeholder parameters with ones appropriate for your environment.

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>Specifies the name of the notification database.</td>
</tr>
<tr>
<td>DSN8G810</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>Specifies the name of the buffer pool.</td>
</tr>
</tbody>
</table>

Not all of the parameters listed are in the script, but may be added in the future.

4. Save and run the script.
5. Open the \NC\_CREATE\_DB2.sql script file and replace the NCCOG placeholder parameter with the name of the notification database.
6. Save the script.

The Job and Scheduling Monitor services will automatically run the script. However, you may choose to run it yourself.
Configuring IBM Cognos Dynamic Cubes installation on the z/OS system

To use IBM Cognos Dynamic Cubes, select the 64-bit version for the report server execution mode for the Application Tier Components. Install IBM Cognos Dynamic Query Analyzer on a Windows computer and configure it to communicate with the IBM Cognos Business Intelligence server components on the z/OS system.

Procedure
1. In each Application Tier Component installation, select the 64-bit version of the report server.
   a. In the IBM Cognos Configuration Explorer panel, click Environment.
   b. Click the Value box for Report server execution mode, and select 64-bit.
   c. Click File > Save.
2. Install IBM Cognos Dynamic Query Analyzer on a Windows computer.
   a. Insert the disk or go to the location where you downloaded and extracted the installation files.
   b. On the disk or in the download location, go to the win32 directory, and double-click the issetup.exe file
   c. Follow the directions in the installation wizard.
      You can install Dynamic Query Analyzer to the same location as your other products or to a different location.
3. On the Windows computer, configure Dynamic Query Analyzer to communicate with the IBM Cognos Business Intelligence server components.
   a. From the Start menu, click Programs > IBM Cognos 10 > IBM Cognos Dynamic Query Analyzer.
   b. Click Window > Preferences.
   c. In the navigation pane, click Server.
   d. Change the Dispatcher URI to point to the location and port of the IBM Cognos BI server running on the z/OS system.
   e. If you are using Tomcat servlet container, change the Gateway URI to point to the location and port used by IBM HTTP Server.
   f. If you are using WebSphere Application server, change the Gateway URI to use the same value as the Dispatcher URI setting.
   g. If IBM Cognos Business Intelligence is secured, enter your user name in the Name box and password in the Password box, and select an appropriate Namespace. If you changed server settings, click Refresh to get a list of namespaces for the server.
   h. In the Logs directory URL box, enter the path to the <install_location>/logs/XQE directory on your server. This link can be an http:// or a file:// protocol link. The server administrator must share this location since it is not shared by default.
   i. If the Logs directory URL link is secured, enter the required user name in the Name box and password in the Password box.
   j. Click OK.
4. Test the configuration of Dynamic Query Analyzer.
   a. In Dynamic Query Analyzer, click Windows > Show View.
   b. In the Show View dialog box, click Navigation > Content Store, and click OK.
If the configuration is correct, in the **Content Store** pane, the IBM Cognos content from the specified server displays.

**Related concepts:**

- "IBM Cognos Dynamic Cubes installation" on page 2
  IBM Dynamic Cubes are databases optimized to provide high speed query performance over large data sets of metadata for business intelligence reporting and analysis.

- "IBM Cognos Dynamic Query Analyzer" on page 3
  IBM Cognos Dynamic Query Analyzer (DQA) provides a graphical interface for the execution tree logs produced by the dynamic query mode queries.

---

### Changing default configuration settings

To better suit your environment, you can change a property value from the default value, or from one that you previously set, by using IBM Cognos Configuration.

When you change the value of a property, IBM Cognos Configuration checks whether you typed the correct data type and, if applicable, whether the value is in the required range. Before you can save a configuration, you must specify values for mandatory properties, as denoted by a red asterisk.

**Procedure**

1. Start IBM Cognos Configuration.
2. In the **Explorer** panel, click the group, component, or resource you want.
   - The **Properties** panel shows property values for the selected object.
3. Click the value you want to change.
4. Type the new property value and press Enter.
   - If the value is valid, the setting changes to the new value. Otherwise, an error message displays indicating the source of the error.
5. If you change a property value while the IBM Cognos service is running, you must restart the service before the change is applied to your computer.

### Structure of URI settings

The elements in a an IBM Cognos URI depends on the IBM Cognos component.

For example, the URI for IBM Cognos components use the following structure:

- For a Content Manager URI, Dispatcher URI for external applications, or dispatcher URI,
  ```plaintext
  protocol://host_name_or_IP:port/context_root/alias_path
  ```

- For a Gateway URI or a web content URI, structure of the URL
  ```plaintext
  protocol://host_name_or_IP:port/virtual_directory/gateway_application
  ```
## URI elements

The elements are described in the following table:

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>protocol</td>
<td>Specifies the protocol used to request and transmit information, either Hyper Text Transfer Protocol or Hyper Text Transfer Protocol (Secure). Example: http or https</td>
</tr>
<tr>
<td>host name or IP</td>
<td>Specifies the identity of the host on the network. You can use an IP address, a computer name, or a fully qualified domain name. In a distributed installation, you must change the localhost element of a URI. In a mixed environment of UNIX and Windows servers, ensure that host names can be resolved to IP addresses by all servers in the environment. Example: localhost or 192.168.0.1 or [2001:0db8:0000:0000:0000:148:57ab]:80</td>
</tr>
<tr>
<td>port</td>
<td>Specifies the port on which the host system listens for requests. The default port for Tomcat is 9300. The default port for a Web server is 80. Example: 9300 or 80</td>
</tr>
<tr>
<td>context root</td>
<td>Used by Tomcat or an application server to determine the context of the application so that the request can be routed to the correct Web application for processing. Example: p2pd</td>
</tr>
<tr>
<td>alias path</td>
<td>Used by the application server to route a request to the correct component within a Web application. The alias path must not be modified or IBM Cognos BI components will not function properly. Example: servlet/dispatch</td>
</tr>
<tr>
<td>virtual directory</td>
<td>Used by the Web server to map a virtual directory or alias to a physical location. For example, in the default Gateway URI of <a href="http://localhost:80/ibmcognos/cgi-bin/cognos.cgi">http://localhost:80/ibmcognos/cgi-bin/cognos.cgi</a>, the virtual directory is ibmcognos/cgi-bin. Example: ibmcognos/</td>
</tr>
<tr>
<td>gateway application</td>
<td>Specifies the name of the Cognos gateway application that is used. For example, if you are accessing IBM Cognos BI components using a Common Gateway Interface (CGI), then the default gateway application would be cognos.cgi. Example: cognos.cgi</td>
</tr>
</tbody>
</table>
Changing a port or URI setting
Depending on your environment, you might need to change certain elements in a URI, such as the port or host name.

Procedure
1. Start IBM Cognos Configuration.
2. In the Explorer panel click the appropriate group or component:
   - To change an element for the dispatcher, click Environment.
   - To change an element for the local log server, under Environment, click Logging.
3. In the Properties panel, click the Value box next to the URI property that you want to change.
4. Select the element and type the new information.
   - To change the port used by the local dispatcher, change the value of the internal dispatcher URI property.
     Because the change affects all the URIs that are based on the local dispatcher, you must change the URIs of all local components.
   - If you change the dispatcher port in the dispatcher URI, ensure that you specify the new port number when you configure remote computers that use the dispatcher, Content Manager, or IBM Cognos Software Development Kit services on this system.
5. Click File > Save.

Configuring the location for report output
By default, report output files are saved in the content store. You can save a copy of the report output to another file location. If you use this option, a descriptor file with an _descr extension is also saved. Saved files are not managed by IBM Cognos.

About this task
If you configure a file system location that is inside of IBM Cognos, you can then use the report output again. This might also be useful for archive purposes, because files that are saved in the content store might be deleted regularly due to retention rules.

To share the report output with external applications or users who don't have IBM Cognos software, you configure a file system location that is outside of IBM Cognos.

Procedure
1. Create a directory for your file system.
   Ensure that the directory is accessible to authorized users only.
2. In the Content Manager installation location, start IBM Cognos Configuration.
3. To save report output outside of the product do the following steps:
   a. In the Explorer panel, click Data Access > Content Manager.
   b. For the Save report outputs to a file system property, click True.
   c. To test the connection to the report output directory, click Actions > Test.
4. To save report output inside of the product, do the following steps:
   a. Click Actions > Edit Global Configuration.
b. In the **Global Configuration** dialog box, click the **General** tab.

c. For **Archive Location File System Root**, type a URI using the format
   
   `file://directory`
   
   where `directory` is the directory that you created in step 1.
   
   The `file://` portion of the URI is required.

d. To confirm that the correct location will be used, click **Test**.

5. Click **File > Save**.

### What to do next

If you save the report output inside of the product, an administrator must configure the file location using the **CM.OutputLocation** parameter in IBM Cognos Administration. For more information, see the topic about setting a file location for report output saved inside IBM Cognos, in the *Administration and Security Guide*.

---

### Changing the location of map charts for IBM Cognos Report Studio

IBM Cognos BI comes with a set of sample map charts that you can use in Cognos Report Studio. By default, the map charts are stored in the `c10_location/maps` directory on the Application Tier Components computer. You can change the location of the map charts by using IBM Cognos Configuration.

#### Procedure

1. On the Application Tier Components computer, start IBM Cognos Configuration.
2. In the **Explorer** panel, click **Environment**.
3. In the **Properties** panel, click the value for **Map files location**.
4. Click the edit button.
5. In the **Select Folder** dialog box, navigate to the directory you want and then click **Select**.
6. Click **File > Save**.

---

### Cookie settings used by the IBM Cognos components

IBM Cognos components determine the cookie domain from the HTTP request submitted by the client, which is typically a web browser.

In most network configurations, HTTP requests pass through intermediaries such as proxy servers and firewalls as they travel from the browser to IBM Cognos components. Some intermediaries modify the information that IBM Cognos components use to calculate the cookie domain, and IBM Cognos components then cannot set cookies. The usual symptom of this problem is that users are repeatedly prompted to log on. To avoid this problem, configure the cookie domain.

To set the correct value for the cookie domain, use the format and value that represents the widest coverage for the host as suggested in the following table.

#### Table 50. Host and host formats for domains

<table>
<thead>
<tr>
<th>Host</th>
<th>Host Format for domain</th>
</tr>
</thead>
<tbody>
<tr>
<td>computer or server</td>
<td>computer or server name (no dots)</td>
</tr>
<tr>
<td></td>
<td>Example: mycompany</td>
</tr>
</tbody>
</table>
### Customizing cookie settings

Based on the requirements of your IBM Cognos environment, you might need to modify the settings that IBM Cognos components use to create cookies.

**Procedure**

1. In each Content Manager installation location, start IBM Cognos Configuration.
2. Click **Actions > Edit Global Configuration**.
3. Click the **General** tab.
4. Click in the **Value** column under **Cookie Settings** for each property that you want to change and type the new value.
   
   If you leave the **Domain** property blank, the dispatcher derives the domain from the host name of the request.
5. Click **OK**.

### Internet Protocol versions

IBM Cognos Business Intelligence for z/OS supports IPv4 and IPv6.

In IBM Cognos Configuration, you can select IPv4 or IPv6 for IBM Cognos BI communication using the **IP Version for Host Name Resolution** property. For example,

- IPv4: 192.168.0.1:80
- IPv6: [2001:0db8:0000:0000:0000:148:57ab]:80

The setting applies only to the installation where it is set. If you select **Use IPv4 addresses**, all outgoing IBM Cognos BI connections on that computer are established using IPv4 and the dispatcher accepts only incoming IPv4 connections. If you select **Use IPv6 addresses**, all outgoing IBM Cognos connections on that computer are established using IPv6 and the dispatcher accepts both incoming IPv4 and IPv6 connections.

IPv4 client installations can communicate with dispatcher in IBM Cognos installations that are configured for IPv6.

Hostnames specified within a URI are resolved based on the value of the **IP Version for Host Name Resolution** property. However, if a URI has been specified with a numeric address, it has precedence over this setting and communication takes place using IPv4.
For IBM Cognos Configuration to accept IPv6 addresses in the local URI properties, you must start IBM Cognos Configuration with the -ipv6 option. You can specify the option each time you open IBM Cognos Configuration from the command line.

On Windows computers, you can set the option permanently by adding the option to the Start menu shortcut.

Related tasks:
“Updating the Cognos Transformer sample preferences file for Windows Vista computers” on page 112
If you want to use the cogtr.xml.samples file as a template, you must edit the default preferences settings.

Changing the Internet Protocol version to IPv6
IBM Cognos BI supports two IP address versions: IPv4 and IPv6. IPv4 uses 32-bit IP addresses (and IPv6 uses 128-bit IP addresses. By default IPv4 is used.

Procedure
1. Start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. Click the Value box for IP Version for Host Name Resolution and click Use IPv4 addresses or Use IPv6 addresses.
4. Click File > Save.

Enabling the IPv6 option when starting IBM Cognos Configuration
For IBM Cognos Configuration to accept IPv6 addresses in the local URI properties, you must start IBM Cognos Configuration with the -ipv6 option. You can specify the option each time you open IBM Cognos Configuration from the command line.

Procedure
1. Go to the c10_location/bin directory.
2. Start IBM Cognos Configuration by including the IPv6 option in the command:
   ./cogconfig.sh -ipv6
   For Windows components, type cogconfig.bat -ipv6
3. Edit the URI properties that use IPv6 format, type the values.
4. Click File > Save.

Creating another instance of Cognos Content Database
You can create another content store database in Cognos Content Database.

About this task
During Cognos Content Database installation, a database is created and IBM Cognos is already configured to use that database. If you want to install another instance of Cognos you must do so before you configure Content Manager.
Procedure

1. In the location where you installed the new instance of Cognos Content Database, in the `c10_location/derby10.1.2.1/bin` directory, use the `ij.bat` or `ij.ksh` script to create a new database.

Use the following syntax: `connect 'jdbc:derby://host:port/db_name;create=true;user=username;password=password';`

The database files are located in the `c10_location/contentstore` directory.

   a. Ensure that you use a different name, user, and password for the new content store.

   For example, to create a database named `contentstore2` on port number 1527 as a user named `cognos2` with a password of `cognos2`, you would type:

   `connect 'jdbc:derby://localhost:1527/contentstore2;create=true;user=cognos2;password=cognos2';`

   The database name is case-sensitive.

2. When you are finished with the `ij` utility, disconnect by using the following command: `disconnect;`

Changing the default username and password for the Cognos Content Database

If you install Cognos Content Database, the default database that is created is given a user ID and password. You will want to change this user ID and password.

About this task

Administration tasks for Cognos Content Database are performed using a utility named `ij`. For information about this utility, see the Apache Derby documentation. The documentation is available in the `c10_location/derby10.1.2.1/docs` directory where you installed Cognos Content Database.

Procedure

1. In the location where you installed Cognos Content Database, go to the `c10_location/derby10.1.2.1/bin` directory.

2. Start the `ij` utility using the `ij.ksh` script file.

3. Connect to the default database by typing the following `ij` utility command:

   `connect 'jdbc:derby://localhost:1527/cm;user=cognos;password=cognos';`

   If you changed the port number from the default 1527, use the correct port number for your Cognos Content Database.

   The default database name is `cm`, and it is case sensitive.

4. Change the default password for the `cognos` user by typing the following `ij` utility command:

   `CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.user.cognos','NewPassword');`

   The new password must be used for the next connection to the database.

5. Close the `ij` utility by typing the following command: `disconnect;`

Creating a new default username and password for the Cognos Content Database

If you install the Cognos Content Database, you can create a new username and password.
Procedure
1. In the location where you installed Cognos Content Database, go to the
   c10_location/derby10.1.2.1/bin directory.
2. Start the ij utility using the ij.ksh script file.
3. Connect to the default database by typing the following ij utility command:
   ```
   connect 'jdbc:derby://localhost:1527/cm;user=cognos;password=cognos';
   
   If you changed the port number from the default 1527, use the correct port
   number for your Cognos Content Database.
   The default database is named cm. The database name is case sensitive.
   ```
4. Create a new user by typing the following ij utility command:
   ```
   CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY('derby.user.NewUser',
   'NewUserPassword');
   ```
5. Give the new user full access to the database by typing the following ij utility
   command: CALL SYSCS_UTIL.SYSCS_SET_DATABASE_PROPERTY
   (derby.database.fullAccessUsers','cognos, NewUser');
   The property that you are changing, the list of users, is a comma-delimited
   field. In this step, you are including the new user in the list of users with full
   access. The default user, cognos, is still part of the list of users with full access.
   You can remove the cognos user.
6. Close the ij utility by typing the following command: disconnect;

Fonts in PDF and HTML report
IBM Cognos components use fonts to render PDF reports on the IBM Cognos
server. IBM Cognos components also use fonts to render charts used in PDF and
HTML reports.

To show output correctly, fonts must be available where the report or chart is
rendered. In the case of charts and PDF reports, the fonts must be installed on the
IBM Cognos server. If a requested font is not available, IBM Cognos components
substitute a different font.

Because HTML reports are rendered on a browser, the required fonts must be
installed on the computer of each IBM Cognos user who will read the HTML
report. If a requested font is not available, the browser substitutes a different font.

Adding fonts
You can add missing fonts to the list of supported fonts.

By default, IBM Cognos BI components use a set of global fonts, which are
available in all IBM Cognos server locations.

Procedure
1. In each Content Manager location, start IBM Cognos Configuration.
2. Click Actions > Edit Global Configuration.
3. Click the Fonts tab.
4. Click Add.
5. In the Supported Font Name box, type the font name and then click OK.
6. Click File > Save.
7. Instal new fonts in each IBM Cognos component location.
All global fonts, including new fonts that you add, must be installed on all IBM Cognos computers in your environment.

8. If a global font is not installed on all IBM Cognos computers, you must map the global font to an installed, physical font.

**Specifying the location of available fonts**

You must specify the installation location of all fonts, including fonts that you add, to the list of supported fonts.

**About this task**

By default, the list of fonts consists of fonts installed in the `c10_location/bin/fonts` directory.

**Procedure**

1. In each location where Application Tier Components are installed, start IBM Cognos Configuration.
2. In the **Explorer** panel, click **Environment**.
3. In the **Properties** panel, for the **Physical fonts locations** property, type the location of the fonts.
   - If there are multiple font paths, separate each path by a semicolon (;
   - If you are using an application server other than Tomcat, type the fully qualified path to the font location. For example: `c10_location/bin/fonts`.
4. Click **File > Save**.

**Mapping supported fonts to installed fonts**

You can substitute global fonts, which are not installed on the computer, for physical fonts.

**About this task**

If you add a font to the list of supported fonts that is not installed on the IBM Cognos computer, you can specify which font to use as a substitute.

If you want to print reports faster by using the built-in PDF fonts, you can map a global font, such as Arial, to one of the built-in PDF fonts, such as Helvetica-PDF.

**Procedure**

1. In each location where Application Tier Components are installed, start IBM Cognos Configuration.
2. In the **Explorer** panel, click **Environment**.
3. In the **Properties** panel, click the **Value** box next to the **Physical fonts map** property, and then click the edit button.
   - The **Value - Physical fonts map** dialog box appears.
4. Click **Add**.
5. In the **Global Font Name** box, type the name of the font you added to the supported font list.
6. Click the **Physical Font Name** box.
   - If you know the physical font name, type it.
Changing embedded fonts for PDF reports

When a PDF report opens in Adobe Reader, all of the fonts that are used in that report must be available. Fonts must be either embedded in the report or installed on the user's computer. If a font is not available in either of these locations, Adobe Reader tries to substitute an appropriate font. This substitution might cause changes in the presentation of the report or some characters might not be displayed.

About this task

To ensure that PDF reports appear correctly in Adobe Reader, IBM Cognos BI embeds required fonts in reports by default. To minimize the file size, IBM Cognos Business Intelligence embeds only the characters (also called glyphs) used in the report rather than all characters in the font set. IBM Cognos BI embeds fonts only if they are licensed for embedding. The license information is stored in the font itself and is read by IBM Cognos BI.

If you are confident that the fonts used in reports are available on all client computers, you can limit or eliminate embedded fonts to reduce the size of PDF reports. When limiting fonts, you specify whether a font is always or never embedded, using an embedded fonts list in IBM Cognos Configuration.

Procedure

1. In the location where Content Manager is installed, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, under Font Settings, click the value for Fonts to embed (Batch report service) or Fonts to embed (Report service), and then click the edit button.
4. If you are not using the default fonts directory or if you want to add a path to an additional directory, in the Fonts to Embed in PDF Reports dialog box, type the new path in the font paths field.
   Click Search Now to get a list of the available fonts in the specified path or paths.
5. For a font that will always be available on client computers, scroll to the font name, and click the Never check box.
   IBM Cognos does not embed the font with any reports. Adobe Reader picks up the font from the user's computer when the report is opened.
6. For a font that might not always be available on the client computers, scroll to the font name and click the Always check box.
   IBM Cognos embeds the font with all reports that use it. Adobe Reader uses the embedded font when the report is opened.
7. Click OK.
Changing the default font for PDF reports

You can change the default font that IBM Cognos components use for PDF reports. You see this default font when you open a report.

About this task

You change the default font in the location where Content Manager is installed. After you make the change, the font becomes the default for all computers in your installation.

Procedure

1. In each location where Content Manager is installed, start IBM Cognos Configuration.
2. From the Actions menu, click Edit Global Configuration.
3. Click the General tab.
4. In the Value box, for Default font, type the font you want to use as the default for reports.
5. Click OK.
6. Click File > Save.
7. On all Application Tier Components computers, ensure that the installation location of the default font is specified in the Physical fonts locations property (under Environment in the Explorer panel) or that the font is in the Windows font directory.
8. Ensure that the default font is installed on all computers in your IBM Cognos installation.

Security settings

There are many properties that you can change to enhance security, including properties related to encryption, authentication and SSL protocol.

Some security settings are set and maintained when IBM Cognos is running. For information about these settings, see the IBM Cognos Administration and Security Guide.

Cryptographic settings

IBM Cognos components require a cryptographic provider; otherwise they will not run. If you delete the default cryptographic provider, you must configure another provider to replace it.

You can configure the following cryptographic settings:

- General cryptographic settings
- Settings for the default cryptographic provider

In a distributed installation, IBM Cognos computers communicate with Content Manager to establish trust and obtain some cryptographic keys from Content Manager. If you change the cryptographic keys in Content Manager, such as by changing application servers or reinstalling Content Manager, you must delete the cryptographic keys in the other IBM Cognos installations. You must then save the configuration in each location to ensure the IBM Cognos components can obtain the new cryptographic keys from Content Manager.
components in a distributed installation must use the same cryptographic provider settings.

**Secure Sockets Layer (SSL)**

The Secure Sockets Layer (SSL) protocol is used to secure communication between IBM Cognos components.

In addition, you can set up SSL connections between IBM Cognos components and other servers. You must ensure that SSL is set up for the other servers before you set up a shared trust between IBM Cognos components and the other servers.

**Configuring cryptographic settings**

IBM Cognos BI components require a cryptographic provider; otherwise they will not run. If you delete the default cryptographic provider, you must configure another provider to replace it.

**Procedure**

1. Start IBM Cognos Configuration.
2. In the **Explorer** panel, under **Security**, click **Cryptography**.
3. In the **Properties** panel, change the default values by clicking the **Value** box and then selecting the appropriate value:
   - In installations that do not contain Content Manager, if you do not want to store the CSKs locally, under **CSK settings**, change **Store symmetric key locally** to **False**.
     When **Store symmetric key locally** is **False**, the key is retrieved from Content Manager when required. The **Common symmetric key store location** property is ignored.
   - If you want the components at both ends of a transmission to prove their identity, under **SSL Settings**, change **Use mutual authentication** to **True**
     Do not change the **Use confidentiality** setting.
   - If you want to change the digest algorithm, for the **Digest algorithm** property, select another value.
4. Click **File > Save**.

**IBM Cognos Application Firewall**

IBM Cognos Application Firewall (CAF) analyzes and validates HTTP and XML requests before they are processed. IBM Cognos Application Firewall might modify these HTTP and XML requests.

IBM Cognos Application Firewall protects IBM Cognos web products from malicious data. The most common forms of malicious data are buffer overflows and cross-site scripting (XSS) attacks, either through script injection in valid pages or redirection to another web site. Using IBM Cognos Configuration, you can change settings for other XSS tool support, and you can add host and domain names to the IBM Cognos list of valid names.

You can track firewall activity by checking the log file, which contains rejected requests. By default, log messages are stored in the **c10_location/logs/cogserver.log** file. All CAF settings must be the same for IBM Cognos BI Application Tier Components installations within a distributed environment. For example, if CAF is disabled in some locations and enabled on others, unexpected behavior and product errors can result.
Configuring IBM Cognos components to use IBM Cognos Application Firewall

All IBM Cognos Application Firewall (CAF) settings must be the same for all instances where IBM Cognos BI Application Tier Components are installed.

About this task

The following types of URLs are accepted by CAF validation:

- Fully qualified (absolute) URLs
  in the format `protocol://host:port/path`, where protocol is http or https and host is validated against the valid domain list
- URLs relative to the web installation directory
  in the format `/web_installation_root/*` where `web_installation_root` is the gateway web directory, based on the alias that you configured on your web server.
- Specific allowed URLs, including the following (all case-insensitive)
  about:blank
  JavaScript:window.close( )
  JavaScript:parent.close( )
  JavaScript:history.back( )
  parent.cancelErrorPage( )
  doCancel( )

Procedure

1. In each location where IBM Cognos BI Application Tier Components are installed, start IBM Cognos Configuration.
2. In the Explorer panel, under Security, click IBM Cognos Application Firewall.
3. In the Properties panel, for the Enable CAF validation property, set the appropriate values.
   By default, IBM Cognos Application Firewall is enabled.
   The IBM Cognos Application Firewall is an essential component of IBM Cognos security, helping to provide protection against penetration vulnerabilities.
   Disabling the IBM Cognos Application Firewall will remove this protection.
   Under normal circumstances, do not disable the IBM Cognos Application Firewall.
4. If you are using another XSS tool that checks for specific characters in GET request parameters, in the Properties panel, for the Is third party XSS checking enabled property, change the value to True.
   The default characters that are prohibited include >, <, and '.
5. Add host and domain names to the IBM Cognos list of valid names:
   a. For the Valid domains and hosts property, click the value and then click the edit button.
   b. In the Value - Valid domains or hosts dialog box, click Add.
      You must include the domains from all hyperlinks that are added in IBM Cognos Connection. For more information, see the topic about creating a URL in the Administration and Security Guide.
   c. In the blank row of the table, click and then type the host or domain name.
      To allow a domain and all its sub-domains, use a wildcard character at the beginning of the domain name.
      For example, *.mycompany.com
d. Click **OK**.

IBM Cognos Application Firewall validates domain and host names to protect URLs that are created. By default, IBM Cognos Application Firewall considers domain names derived from the environment configuration properties to be safe domain names. Adding names to the list of valid names and hosts is useful when you need to redirect requests to non-IBM Cognos computers using the Back or Cancel functions or when using drill-through to different IBM Cognos product installations.

6. Save the configuration.
7. Restart the services.

**Encrypting temporary file properties**

Temporary files store recently viewed reports and to store data used by the services during processing. You can change the location of the temporary files and you can choose to encrypt their content.

**About this task**

By default, IBM Cognos Business Intelligence components store temporary files in the `c10_location/temp` directory and the files are not encrypted.

For optimum security, deny all access to the temp directory, except for the service account used to start the IBM Cognos BI service.

**Procedure**

1. Start IBM Cognos Configuration.
2. In the Explorer panel, click **Environment**.
3. In the Properties panel, for the Temporary files location property, type the new location.
4. If you require the content of temporary files to be encrypted, set the Encrypt temporary files property to **True**.
5. Ensure that the user account under which IBM Cognos BI components run have the read-write privileges to the temporary files location.

**Trusted communications between IBM Cognos components**

Use Secure Sockets Layer (SSL) protocol to ensure trusted communication between IBM Cognos components and between IBM Cognos components and other software.

**Internal connections only**

If you configure SSL for internal connections, IBM Cognos components installed locally use this protocol. The dispatcher listens for secure connections on a different port than for remote, http requests. Therefore, you must configure two dispatcher URIs.

If you configure SSL for all connections, the dispatcher can use the same port for internal and external connections. Similarly, if you do not use SSL for local or remote communication, the dispatcher can use the same port for all communications.
You must also update the Content Manager URIs, dispatcher URI for external applications, and gateway URI to use SSL, if required.

**Tomcat connectors**

If the internal dispatcher URI is prefixed with http but the external dispatcher URI is prefixed with https, or vice versa, both the non-SSL Coyote HTTP/1.1 and SSL Coyote HTTP/1.1 connectors are enabled in the server.xml file.

If the internal and external dispatcher URIs use different protocol or ports, the internal dispatcher port is accessible only to the components on the local computer. The internal dispatcher URI must also specify localhost.

**Single location installations**

In single location installations, if you are running IBM Cognos Business Intelligence without SSL, you must stop the service before adding SSL to your configuration. After you save the configuration with SSL settings, you can restart the service.

**Distributed installations**

In distributed installations, if you are using the IBM Cognos certificate authority service, you must do the following tasks:

- Configure all IBM Cognos computers to use the non-secure (http) protocol
- Establish trust
  Also, ensure that you follow the required order of configuring components in a distributed environment. That means that you must first configure the active Content Manager and then start the services before you configure other components or start services in other locations. By first configuring the default active Content Manager computer and starting the services, you ensure that the certificate authority service on the default active Content Manager computer can issue certificates to other components in the IBM Cognos environment.
- Test the installation
  After you configure all computers in the distributed installation to use the default, non-secure protocol, we recommend that you test your installation to ensure that IBM Cognos components are working properly. After you test your installation, you can configure the SSL protocol.
- Configure IBM Cognos components to use the SSL protocol
  When you configure IBM Cognos Business Intelligence to use the SSL protocol, ensure that you first configure the default active Content Manager computer to use the protocol and start the services on the default active Content Manager computer. After you do this, you can configure the SSL protocol on other IBM Cognos computers in your environment.

**Add a component in another location to an installation**

If you add a computer to an SSL-enabled environment, you will be prompted to temporarily accept trust for a certificate when you save the configuration. Accepting the temporary certificate will allow permanent trust to be established with the Content Manager computer.
Configuring SSL

To ensure secure communication among IBM Cognos BI components, configure the dispatcher and gateway to use SSL.

About this task

If you configure SSL for internal connections only, IBM Cognos components in the same location communicate using this protocol. The dispatcher listens for secure connections on a different port than for remote, http requests. Therefore, you must configure two dispatcher URIs.

If you configure SSL for external connections only, communications from remote IBM Cognos components to the local installation use the SSL protocol. You must configure the dispatcher to listen for secure, remote requests on a different port than local, HTTP requests. You must also configure the Content Manager URIs and the dispatcher URI for external applications to use the same protocol and port as the external dispatcher.

Procedure

1. Start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, type the appropriate values for the Internal dispatcher URI and External dispatcher URI values:
   - To configure SSL for internal connections only, for the Internal dispatcher URI property, type https and a port for SSL communication.
     For the External dispatcher URI property, type http and use the default or another available port.
     If you use Tomcat, the Internal dispatcher URI property must specify localhost.
   - The ports in the two dispatcher URIs must be different.
   - To configure SSL for external connections only, for the External dispatcher URI property, type https and a secure port.
     For the Internal dispatcher URI property, type http and use the default or another available port.
     If you use Tomcat, the Internal dispatcher URI property must also specify localhost.
   - The ports in the two dispatcher URIs must be different.
   - To configure SSL for all connections, type the same URI for both the Internal dispatcher URI and External dispatcher URI properties. Type https and a secure port.
4. Configure the SSL protocol for the other environment URIs, including the Content Manager URIs, the Dispatcher URI for external applications, and Gateway URI.
   - For internal connections only, type https in the URIs that contain localhost.
   - For external connections only, type https in the URIs that do not contain localhost.
   - For all connections, type https in all the URIs.
5. In the Explorer panel, click Security > Cryptography.
   To use SSL protocol, you must specify passwords for the IBM Cognos BI encryption key stores. There are more settings under Security > Cryptography > Cognos.
6. Click File > Save.

Cipher suites for SSL
An SSL connection begins with a negotiation in which the client and server present a list of supported cipher suites in a priority sequence. A cipher suite provides the quality of protection for the connection. It contains cryptographic, authentication, hash, and key exchange algorithms. The SSL protocol selects the highest priority suite that the client and the server both support.

A list of supported cipher suites for SSL is provided. You can eliminate cipher suites that do not meet your requirements and then assign a priority, or preference, to the remaining cipher suites. The selected cipher suites are presented in priority sequence for the client and server sides of the negotiation. At least one of the selected cipher suites between the client and server platforms must match.

The list of supported cipher suites is dynamically generated in each installation, and depends on the Java Runtime Environment (JRE) or whether you have other cryptographic software installed. If you have made changes, such as upgraded the JRE or installed software that has upgraded the JRE, this can affect the supported cipher suites available. If you no longer have a supported cipher suite that matches the other computers in your environment, you might have to change the JRE to match the other computers.

Ranking cipher suites for SSL
You can eliminate cipher suites that do not meet your requirements and then assign a priority, or preference, to the remaining cipher suites.

Procedure
1. Start IBM Cognos Configuration.
2. In the Explorer panel, click Cryptography > Cognos.
3. In the Properties panel, click the Value column for the Supported ciphersuites property.
4. Click the edit button.
   - To move a cipher suite to the Current values list, click the check box in the Available values list and then click Add.
   - To move a cipher suite up or down in the Current values list, click the check box and then click the up or down arrows.
   - To remove a cipher suite from the Current values list, click the check box and then click Remove.
5. Click OK.
6. Click File > Save.

Configuring IBM Cognos components for SSL enabled web servers
If using SSL protocol, to access the IBM Cognos portal, you must change the Gateway URI values in IBM Cognos Configuration for each computer where the Application Tier Components and Framework Manager are installed.

Before you begin
To enable SSL on your web server, you must obtain a web server certificate signed by a Certificate Authority and install it into your web server. The certificate must
not be self-signed, because self-signed certificates will not be trusted by IBM Cognos components.

Procedure
1. In each Application Tier Components installation and on each Framework Manager computer, start IBM Cognos Configuration.
2. Under Local Configuration, click Environment, and change the Gateway URI value from http to https.
3. In the Gateway URI value field, change the port number to the SSL port number defined for your Web server.
   For example, the default port number for SSL connections is usually 443.
4. To verify trust, access the portal by typing https://servername:443/ibmcognos. You should be prompted to install a certificate.
   To avoid being prompted by a security alert for each new session, install the certificate into one of your web browser's certificate stores.

Configuring the gateway to use a namespace
If IBM Cognos Business Intelligence components use multiple namespaces, or if anonymous access is enabled and IBM Cognos components use one namespace, you can configure the gateway to connect to one namespace.

Procedure
1. On the computer where the gateway is located, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, in the Value box next to the Gateway namespace property, type the Namespace ID of the namespace that you want to use.
4. Click File > Save.
5. Restart your web server.

Configuration process for log message repositories
Log messages are an important diagnostic tool for investigating the behavior of IBM Cognos Business Intelligence for z/OS. In addition to error messages, log messages provide information about the status of components and a high-level view of important events.

For example, log messages can provide information about attempts to start and stop services, completion of processing requests, and indicators for fatal errors. Audit logs, which are available from a logging database, provide information about user and report activity.

The IBM Cognos BI services on each computer send information about errors and events to a local log server. A local log server is installed in the c10_location/logs folder on every IBM Cognos BI computer that contains Content Manager or Application Tier Components. Because the log server uses a different port from the other IBM Cognos BI components, it continues to process events even if other services on the local computer, such as the dispatcher, are disabled.

The following workflow shows the tasks that are required to prepare for logging.

Planning phase

---

IBM Cognos Business Intelligence Version 10.2.0: Installation and Configuration Guide for z/OS
During planning, determine the logging configuration that is suitable for your environment. For example, evaluate various log message repositories, such as remote log servers and log files, such as the UNIX or Linux syslog or the Windows NT Event log, in addition to the local log file. You can also send only audit logging information to a database. Consider security, such as methods available for protecting log files from system failures and user tampering. For information about planning, see the Architecture and Deployment Guide.

**Configuration phase**

During configuration, define the startup properties for logging, such as connection settings for databases. You must also create a logging database if you plan to collect audit logs. If communication between a local log server and a remote log server must be secured, make the appropriate configuration changes on both IBM Cognos BI computers. You can also enable certain logging features, such as user-specific logging. For information about configuring logging, see the Installation and Configuration Guide.

**Administration phase**

When setting up logging, specify the level of detail to log to focus messages on the information that is relevant in your organization. Audit reports can also be set up to track user and report activity. For information about setting up logging, see the Administration and Security Guide.

**Log message repositories**

A local log server is automatically installed when you install Content Manager or the Application Tier Components. You can specify one or more repositories where the local log server sends log messages.

You can specify that log messages be stored in the UNIX syslog. Messages related to startup processes are automatically shown on the z/OS console.

**Remote log server**

In a distributed installation, you can configure the log server in each IBM Cognos BI installation to send log messages to a single remote log server, which acts as a common log server. You can then configure the common log server to send the log messages to a local file or database in the same or different location.

If the remote log server becomes unavailable, log messages are redirected to recovery files in the local installation location in the \c10\_location/\logs/recovery/remote directory. These recovery files have timestamp information in their file names, and are not readable like regular log files. When the remote log server becomes available, an automatic recovery process moves all log information to the remote log server and deletes the local log files.

**The cogserver.log file**

The log server is configured by default to send log messages to the \c10\_location/\logs/cogserver.log file. If the default log file does not exist when the IBM Cognos BI service starts, it is created automatically.

You can configure the log server to send log messages to a different file. If you configure a different log file, IBM Cognos BI attempts to automatically create this file on startup, in addition to the default log file. If the location for the configured
log file is different from the \texttt{c10\_location/\texttt{logs}} directory, you must ensure the path to the log file exists before starting the IBM Cognos BI service.

For example, if you configure the log server to send messages to the \texttt{/usr/lpp/log\_files/cognos.log} file, IBM Cognos BI attempts to automatically create the \texttt{cognos.log} file in the \texttt{/usr/lpp/log\_files} folder. If this folder does not exist, IBM Cognos BI does not create the \texttt{cognos.log} file and no log messages can be recorded in it. Note that these log messages are not recorded in the default log file. Although IBM Cognos BI automatically creates the default log file even when another log file is configured, the default log file is not used as a backup.

**Database**

The log server can also send audit logs to a database in the same or another installation location. Audit logs provide information about user and report activity.

The logging database has the same configuration and user account requirements as the content store database. After you configure IBM Cognos BI components to send messages to a logging database, and restart the IBM Cognos BI service, IBM Cognos BI components create the required tables and table fields. You can test the connection to the logging database before you restart the IBM Cognos BI service.

**Guidelines for creating a logging database on DB2 for z/OS**

The database you create for logging must contain some required configuration settings.

Use the following checklist to help you set up the logging database on DB2.

- Log on to the z/OS system as a user with administrator privileges in DB2 (DBADM authority) on z/OS.
- Create a database instance, storage group, and a user account for the logging database. IBM Cognos uses the credentials of the user account to communicate with the database server.
- Ensure that you allocate a buffer pool with a page size of 16 KB for the database instance.
- For a logging database in DB2 on z/OS, administrators must run a tablespace script to create tablespaces to hold large objects and other data for the logging database, and then grant user rights to the table.

**Creating tablespaces for a logging database on DB2 for z/OS**

A user with database administrator authority (DBADM) must run a script to create a set of tablespaces required for the logging database. The script must be modified to replace the placeholder parameters with ones that are appropriate for your environment.

**About this task**

Ensure that you use the name convention for DB2 on z/OS. For example, all names of parameters must start with a letter and the length must not exceed eight characters. For more information, see the IBM DB2 Information Center.
Procedure
1. Connect to the database as a user with privileges to create and drop tablespaces and to allow execution of SQL statements.
2. Open the Ls_tablespace_db2zOS.sql script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IPFSCRIPT_DATABASE</td>
<td>Specifies the name of the logging database.</td>
</tr>
<tr>
<td>IPFSCRIPT_STOGROUP</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>IPFSCRIPT_TABLESPACE</td>
<td>Specifies the name of the tablespace that contains the base tables in the logging database. This tablespace is not for Auxiliary tables.</td>
</tr>
<tr>
<td>IPFSCRIPT_LOB_TABLESPACE</td>
<td>Specifies the name of the tablespace that is allocated for auxiliary tables.</td>
</tr>
<tr>
<td>IPFSCRIPT_BP</td>
<td>Specifies the name of the 8 k buffer pool that is allocated for regular objects.</td>
</tr>
<tr>
<td>IPFSCRIPT_USERNAME</td>
<td>Specifies the user account that accesses the logging database.</td>
</tr>
</tbody>
</table>

Not all of the parameters listed are in the script, but might be added in the future.
3. Save and run the script.
4. Grant the IBM Cognos user rights to the tablespaces that were created when you ran the Ls_tablespace_db2zOS.sql script file:
   a. Open the Ls_rightsGrant_db2zOS.sql script file, which is located in the c10_location/configuration/schemas/logging/db2zOS directory.
   b. Replace the parameter values with those that are appropriate for your environment.
      Ensure you use the same values that you used when you created the buffer pools and user account.
   c. Save and run the Ls_rightsGrant_db2zOS.sql script.

Specifying the repository type for log messages
You can configure a type of repository for the log messages, and then configure properties for the specific repository. You can also configure more than one repository.

Procedure
1. In the installations where you installed Content Manager or the Application Tier Components, start IBM Cognos Configuration.
2. In the Explorer panel, under Environment, click Logging.
3. In the Properties panel, use the following table to help set the log server properties.
Table 52. Tasks to set log server properties

<table>
<thead>
<tr>
<th>Task</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use TCP between IBM Cognos BI components on a computer and its local log server</td>
<td>Set the Enable TCP property to True. UDP provides faster communication with a lower risk of lost connections than TCP. TCP is used for communication between a local log server and a remote log server.</td>
</tr>
<tr>
<td>Change the number of threads available to the local log server</td>
<td>Type the value in the Local log server worker threads property. Keep the default value of 10. The range is between 1 and 20. However, if you have a high number of log messages, you can allocate more threads to improve performance.</td>
</tr>
<tr>
<td>Apply UTF-8 encoding for log messages written to a file</td>
<td>Set the Use UTF8 encoding property to True. If the IBM Cognos BI component is using multibyte encoding, you must set this property to True and use a UTF-8 editor to view the log file. Otherwise, the log file might contain unreadable characters.</td>
</tr>
</tbody>
</table>

4. In the Explorer panel, under Environment, right-click Logging > New resource > Destination.
   a. In the Name box, type the name of the repository.
   b. In the Type list, click Database and then click OK.
5. In the Explorer panel, under Logging, right-click the database name, and click New resource > Database.
   a. In the Name box, type the name of the repository.
   b. In the Type list, click DB2 database and then click OK.
6. In the Properties panel, type the Database server and port number, User ID and password, and the z/OS Database name.
   Ensure that the User ID is the same as the value you specified for the IPFSCRIPT_USERNAME parameter in the LS_tablespace_db2z05.sql script file.
7. In the Explorer panel, click Local Configuration.
8. In the Properties panel, next to Advanced properties, click inside the Value box, and then click the edit button.
9. Click Add, and then add the configuration parameter names and values from the following table:

Table 53. Parameter names and values

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>IPFSCRIPT_CREATE_IN</td>
<td>The base tables location.</td>
</tr>
<tr>
<td></td>
<td>For example, databaseNameCMID.baseTableSpaceName</td>
</tr>
<tr>
<td>IPFSCRIPT_STOGROUP</td>
<td>The name of the storage group.</td>
</tr>
<tr>
<td>IPFSCRIPT_DATABASE</td>
<td>The name of logging database.</td>
</tr>
</tbody>
</table>
Table 53. Parameter names and values (continued)

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>IPFSCRIPT_LOB_TABLESPACE</td>
<td>The name of the tablespace that is reserved for auxiliary tables in the logging database.</td>
</tr>
</tbody>
</table>

10. Click File > Save.
11. Test the connection to the new database. In the Explorer panel, under Environment, right-click Logging > Test.

IBM Cognos BI components connect to the database. If you configured more than one database for logging messages, IBM Cognos BI components test all the databases.

Results

If the repository was a remote log server, configure and start the remote log server. Then restart the IBM Cognos BI service on the local computer.

If the repository was a database, you can use IBM Cognos BI components to run log reports from the database.

You can also set the logging level, which controls the amount of detail and type of messages that are sent to a log file or database. For instructions, see the Administration and Security Guide.

Setting up the connectivity to the logging database

After you create a database for log messages, you must copy JDBC drivers to the IBM Cognos installation to ensure that you can connect to the database.

About this task

In distributed installations, the local log server in an Application Tier Component installation can send log messages to a remote log server, which then sends messages to the logging database. For DB2 the appropriate JDBC driver and license file are required only on the Application Tier Components computer with the remote log server that connects to the logging database.

You must copy the JDBC driver and license file to the Content Manager computer, unless you are using the same type of database for the log messages as you use for the content store.

Procedure

1. In your DB2 installation, go to the directory where the JDBC driver and license files are located.
   For example, $DB2HOME/db2910_jdbc/classes directory.
2. Copy or create symbolic links for the following files in the c10_location/webapps/p2pd/WEB-INF/lib directory and c10_location/bin directories.
   • The universal driver file, db2jcc.jar
   • The license file, for example, db2jcc_license_cisuz.jar
IBM Cognos content archival configuration

To enhance system performance and extend scalability, use IBM Cognos content archival to store report output versions and their source report specifications to your file system. Archiving reduces the size of the content store database.

Users can search on an element in a report name or a data element in a report. The results depend on the settings used to build the search index. The archived content can be viewed by clicking the links in the search results.

Your archived content can be viewed in IBM Cognos Connection or in your external repository.

After your content is moved and archived, it is stored in the location specified when you created the data source connection to your external repository.

Creating a file location for a file system repository

To archive reports or report specifications to an IBM Cognos content archival file system repository, you must create an alias root that points to a file location on a local drive or network share.

Before you begin

You must be an administrator and have access to the file location. Content Manager and Application Tier Components must be able to access this location by using a file URI.

About this task

The file system repository is designed for a test or development environment where the use of an Enterprise Content Management (ECM) repository is not possible. Although the file system for the IBM Cognos content archival provides the same functionality as an ECM repository, it does not provide the same level of optimization, and therefore, performance might be affected in a production environment.

Procedure

1. If running, stop the IBM Cognos service.
2. Start IBM Cognos Configuration.
3. Click Actions > Edit Global Configuration.
4. On the General tab, select Alias Roots, click inside the value field, click the edit button, and when the Value - Alias Roots dialog box appears, click Add.
5. In the Alias root name column, type a unique name for the file system repository.
6. Type the path to your file system location.
7. Click OK.
8. Restart the IBM Cognos service.
   This might take a few minutes.
Results

Use this file system repository name to create a data source connection to use with the Cognos Content Archival software. For more information, see the Administration and Security Guide.

Specifying an available time to run the archival process

To maintain high system performance during peak hours, you can configure a blackout period to specify when the archive or delete tasks run.

A blackout period is a temporary period in which the movement of data is denied. By default, a blackout period is not defined when the software is installed.

Procedure

1. Go to the $c10_location/webapps/p2pd/WEB-INF/cm/tasks/manager$ directory.
2. Using an XML text editor, open the $tasksManager.xml$ file.
3. For example, to specify a weekly blackout period from 8:00 a.m. to 5 p.m., Tuesday through Friday, add the following $<blackoutPeriods>$ element as a child element of the $<backgroundTasksManager>$ element.
   - start time = $<hour>08</hour>$
   - stop time = $<hour>17</hour>$
   - days =
     - $<day>Tuesday</day>$
     - $<day>Wednesday</day>$
     - $<day>Thursday</day>$
     - $<day>Friday</day>$
4. If required, decrease the number of threads available to the archiving and deletion processes. The maximum number of threads is 7.
5. Save and close the file.
6. Restart background activities on the Content Manager service.

Specifying thread execution time

You can use threads to schedule operating system processing time.

The archive and delete background tasks use threads to move content. Threads are units of processing time that are scheduled by the operating system.

Procedure

1. Go to the $c10_location/webapps/p2pd/WEB-INF/cm/tasks/config$ directory.
2. Using an XML text editor, open the $archiveTask.xml$ file.
3. For example, to configure three threads that execute from midnight to 8:00 a.m., one thread that executes from 8:00 a.m. to 5:00 p.m., no threads that execute from 5:00 p.m. to midnight, and all threads that run every day of the week, add the following $<executionPeriods>$ XML element as a child element of the $<backgroundTask>$ element.
   <executionPeriods>
     <executionPeriod>
       <threads>3</threads>
       <startTime>
         <hour>00</hour>
         <minute>00</minute>
       </startTime>
     </executionPeriod>
     <executionPeriod>
       <threads>1</threads>
       <startTime>
         <hour>08</hour>
         <minute>00</minute>
       </startTime>
     </executionPeriod>
   </executionPeriods>
<hour>08</hour>
<minute>00</minute>
</stopTime>
<days>
<day>Monday</day>
<day>Tuesday</day>
<day>Wednesday</day>
<day>Thursday</day>
<day>Friday</day>
<day>Saturday</day>
<day>Sunday</day>
</days>
</executionPeriod>
</executionPeriod>
<startTime>
<hour>08</hour>
<minute>00</minute>
</startTime>
<stopTime>
<hour>17</hour>
<minute>00</minute>
</stopTime>
<days>
<day>Monday</day>
<day>Tuesday</day>
<day>Wednesday</day>
<day>Thursday</day>
<day>Friday</day>
<day>Saturday</day>
<day>Sunday</day>
</days>
</executionPeriod>
</executionPeriods>
4. Save and close the file.

Archiving selected formats of report outputs

You can limit archiving to limit archiving to specific output formats. By default outputs of any given format, including PDF, XML, HTML and Excel, are archived.

You can limit archiving of specific output formats to the repository.

Procedure

1. Go to the c10_location/webapps/p2pd/WEB-INF/cm/tasks/config directory.
2. Using an XML text editor, open the archiveTask.xml file.
3. For example, to define the archiving of only PDF report output versions, add the following <outputFormats> XML element as a child element of the runOptions XML element.

   <outputFormats>
   <outputFormat>PDF</outputFormat>
   </outputFormats>

   You can use the existing sample outputFormats element and modify the list to specify output formats to be archived.

   You cannot selectively archive multiple file report output versions, for example HTML with graphics.

   Save and close the file.

Removal of marked version objects from the queue

The deleteTask.xml file is a configuration file for the background task that retrieves and deletes marked version objects from the queue.
There are two content maintenance tasks that mark and move version content into a queue:

- Retention Rules Updater that updates and applies retention rules on reports, queries, analysis, and document objects
- Content Removal that marks versions and histories.

The deleteTask.xml file is in the c10_location/webapps/p2pd/WEB-INF/cm/tasks/config directory.

For more information about retention rules, see the IBM Cognos Administration and Security Guide.

## Configuring multitenancy settings

Multitenancy provides the capability to support multiple customers or organizations (tenants) by using a single deployment of an application, while ensuring that the users belonging to each tenant can access only the data that they are authorized to use. Such applications are called multi-tenant applications.

IBM Cognos Business Intelligence (BI) provides capabilities that make it easier to administer and secure multi-tenant applications.

The following diagram shows how the Cognos BI multitenancy capabilities isolate access to objects in your content store. Users can access only the objects that they are authorized to access within each tenant grouping.

![Content store configured to use the Cognos BI multitenancy capabilities](image)

*Figure 6. Content store configured to use the Cognos BI multitenancy capabilities*

In this example, the users would have access to the following objects:

- Users belonging to Tenant 1 can access object_1, object_2, and object_3.
- Users belonging to Tenant 2 can access object_3, object_4, object_5, and object_6.

**Note:** The system administrator can access all objects in the content store.

Before you can use IBM Cognos multitenancy, you must modify your configuration. Multitenancy properties that you specify for a specific namespace override any multitenancy properties that you set globally.
To configure multitenancy, you must perform the following tasks:
1. “Identify tenancy information”
2. “Enabling multitenancy” on page 147

Related concepts:
“Configuration of multi-tenant applications in IBM Cognos Configuration” on page 3

You can use new properties in IBM Cognos Configuration to configure Business Intelligence environments supporting multi-tenant applications.

**Identify tenancy information**

Before you can modify your configuration for multi-tenant applications, you need to identify how tenancy information (grouping) is determined in your environment for the individual users. Then, you associate the tenancy information to specific multitenancy properties.

To identify tenancy information, you can use the position of a user within a hierarchy, or you can use the properties associated with user objects. You can also create custom code that is invoked during the user authentication process.

**Use hierarchies to determine tenancy information**

One way to determine tenancy information is to reuse the node structure information within a hierarchy.

When reusing the node structure information, you can use the information provided by the ancestors user attribute, which represents the hierarchical path to a user account in the form of an array. The following table shows how you could map the ancestors attribute to a hierarchy to identify the tenancy information:

<table>
<thead>
<tr>
<th>Ancestors information</th>
<th>Hierarchy</th>
<th>LDAP example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ancestors[0]</td>
<td>Directory node</td>
<td></td>
</tr>
<tr>
<td>ancestors[1]</td>
<td>Namespace ID</td>
<td>base DN</td>
</tr>
<tr>
<td>ancestors[2]</td>
<td>Tenant grouping, such as folders</td>
<td>organizational units</td>
</tr>
</tbody>
</table>

For example, if users are stored in an LDAP directory and tenants are directly under the base Distinguished Name (DN) as organizational units, set the multitenancy.TenantPattern advanced property to the following value:

```
multitenancy.TenantPattern = ~/ancestors[2]/defaultName
```

**Note:** In addition to defaultName, the following ancestors qualifiers can return tenancy information:
- `name/locale`, where `locale` is based on the mapping in the namespace configuration. If no locale is given, the name is the title of the object. For example, you could specify:
  ```
multitenancy.TenantPattern = ~/ancestors[2]/name/EN-ca.
```
- `searchPath/objectID`. For example, you could specify:
  ```
multitenancy.TenantPattern = ~/ancestors[2]/searchPath/objectId.
```
Use object attributes to determine tenancy information

If you cannot use the node structure hierarchy to determine the tenancy information, you can use specific object attributes from your authentication provider. This method requires that you also identify any additional properties to be queried during the user authentication process.

For example, if the departmentNumber attribute of an LDAP user object identifies the user’s tenant, set the multitenancy.TenantPattern and the AdditionalUserPropertiesToQuery advanced properties as follows:

```java
multitenancy.TenantPattern = ~/parameters/parameter_name
AdditionalUserPropertiesToQuery = parameters
```

In this example, you must also set the following LDAP custom property:

`parameter_name = departmentNumber`

Use custom code to determine tenancy information

When the tenancy information cannot be obtained through a hierarchy or a user attribute, you must create a custom class that is invoked during the user authentication process to determine the tenancy information. For example, you might need to join data from multiple authentication sources, or from an authentication source and a relational database.

In such cases, you create a custom Java class using the IBM Cognos Software Development Kit and specify its name during the BI configuration. In this scenario, set the multitenancy.ITenantProvider property as follows:

```java
multitenancy.ITenantProvider = custom_class_name
```

where `custom_class_name` represents the name of your custom class, for example, `com.example.Class`.

IBM Cognos Software Development Kit includes a sample custom class to determine tenancy information. You can find the sample files in the `c10_location/sdk/java\AuthenticationProvider\MultiTenancyTenantProviderSample` directory.

Enabling multitenancy

To enable Cognos multitenancy capabilities, you set advanced authentication properties on all the computers where the Content Manager is configured, and then restart the IBM Cognos service.

Before you begin

- Identify how tenant information is determined for individual users in your environment. For more information, see "Identify tenancy information" on page 146.
- Compile any required custom Java class files into JAR files and either place them into the `c10_location/webapps/p2pd/WEB-INF/lib` directory along with any associated files, or update the CLASSPATH environment variable to include the path to these files.
- Determine whether you must apply the multitenancy settings to all configured namespaces or to individual namespaces. Multitenancy properties for a specific namespace override any multitenancy properties that are set globally. If a
namespace is not configured to use multitenancy, then policies and permissions for objects are used to determine who can access the objects.

Procedure

1. Open IBM Cognos Configuration.
2. To configure tenancy settings globally or for individual namespaces, use the following steps:
   - To configure the tenancy information for all namespaces: In the Explorer window, under Security, click Authentication.
   - To configure the tenancy information for one namespace: In the Explorer window, under Security, click Authentication. Click the namespace that you want to configure.
3. Click the Edit button in the Value column for Advanced properties.
4. Click Add.
5. Add the multitenancy properties that you need.
   The following scenarios illustrate possible combinations of the multitenancy properties:
   - To use hierarchy information, you could set the following property:
     multitenancy.TenantPattern = ~/ancestors[2]/defaultName

     Note: If you use Active Directory namespaces, you must also set the MultiDomainTree advanced property to true to map tenants to domains.
   - To use specific object attributes from your authentication provider, such as a department number (departmentNumber), you would follow these steps:
     a. Set the following advanced properties:
        multitenancy.TenantPattern = ~/parameters/parameter_name
        AdditionalUserPropertiesToQuery = parameters
     b. Set the following namespace custom property:
        parameter_name = departmentNumber
   - To use a custom Java class, you would set the following property:
     multitenancy.ITenantProvider = custom_class_name

     where custom_class_name represents the name of a Java class that you created.
6. Click OK.
7. Test the changes. In the Explorer window, right-click Authentication, and click Test. A message showing that multitenancy is enabled appears in the log.
8. From the File menu, click Save.
9. Restart the IBM Cognos service for the changes to take effect.

What to do next

After multitenancy is enabled, the system administrator must set the tenancy information for the objects in the content store. For more information, see the Administration and Security Guide.

To track tenant activities, you can use a logging database.

Disabling multitenancy

To disable multitenancy, you must remove all multitenancy advanced authentication properties on all the computers where the Content Manager is configured.
Procedure
1. Open IBM Cognos Configuration.
2. To disable tenancy settings that are set globally or to specific namespaces, use the following steps:
   - To disable the tenancy settings for all namespaces: In the Explorer window, under Security, click **Authentication**.
   - To disable tenancy settings for one namespace: In the Explorer window, under Security, click **Authentication**. Click the namespace that you want to configure.

   **Note:** If multitenancy properties are set globally and individually, the properties for a specific namespace override any global multitenancy properties.
3. Click the **Edit** button in the Value column for Advanced properties.
4. Select the multitenancy properties that you want to remove.
5. Click the **Remove** button.
6. Click **OK**.
7. Test the changes. In the Explorer window, right-click **Authentication**, and click **Test**.
8. From the **File** menu, click **Save**.
9. Restart the IBM Cognos service.

What to do next
After multitenancy is disabled, the system administrator must review and update the policies on objects and then update the tenancy to public.

Global settings for multicultural requirements
Change system-wide settings for language, locale, font, and server settings.

The Global Configuration dialog box is available where Content Manager is installed. Important: If you change global settings in one Content Manager installation, you must make the same changes on the other Content Manager installations.

By default, IBM Cognos components ensure that all locales, which might come from different sources and in various formats, use a normalized form. That means that all expanded locales conform to a language and regional code setting. Each computer has a default system locale and one user locale per user. The user locales might be different from the default system locale. If you change global settings in one Content Manager installation, you must make the same changes in the other Content Manager installations.

Mapping product locales
Use the Product Locale Mappings table to specify the language used in the user interface when the language specified in the user’s locale is not available.

About this task
You can ensure that all regions for a locale use the same language, or that a specific, complete locale (language-region) uses a particular language.
By default, the user sees the product interface in the language that matches the language setting of the user locale.

**Procedure**

1. In each Content Manager installation, start IBM Cognos Configuration.
2. Click Actions > Edit Global Configuration.
3. Click the Product Locale Mappings tab.
4. Click Add.
5. In the Key box, type the user locale:
   - To ensure all regions for a locale see the user interface in a specific language, type the language portion of the locale, followed by a dash (-) and an asterisk (*).
     For example, type es-*
   - To ensure a complete locale (language-region) see the user interface in a specific language, type the complete locale.
     For example, type es-es
   - To map a preferred language to another language, type the preferred language portion of the locale.
     For example, type zh

   **Tip:** To specify which locale to use as the default, use the wildcard character (*) for the Key value and then, in the Locale Mapping box type the locale.
6. In the Locale Mapping box, type the language portion of the locale.
   User locales specified in the Key box will see content in this language.
7. Repeat the preceding steps for other mappings you want to do.
8. Click OK.
9. Click File > Save.

**Reports in a preferred language**

You can map user locales to a complete (language-region) or partial (language) locale. You can also map a user's preferred language to another language if content is not available in the user's preferred language.

For example, if a report or is not available in a preferred language, for example Vietnamese, but is available in French and German, you can use the Content Mappings table to map the preferred language (Vietnamese) to another language (French or German). This way, you see the report in the mapped language.

The following examples show the method that IBM Cognos BI components use to determine which report the user sees if the multiple language versions are available.

**Example - Report is available in two locales**

A report is available in Content Manager in two locales, such as en-us (English-United States) and fr-fr (French-France), but the user locale is set to fr-ca (French-Canadian). IBM Cognos BI uses the locale mapping to determine which report the user sees.

First, IBM Cognos BI checks to see if the report is available in Content Manager in the user's locale. If it is not available in the user's locale, IBM Cognos BI maps the
user's locale to a normalized locale configured on the Content Locale Mapping tab. Because the user's locale is fr-ca, it is mapped to fr. IBM Cognos BI uses the mapped value to see if the report is available in fr. In this case, the report is available in en-us and fr-fr, not fr.

Next, IBM Cognos BI maps each of the available reports to a normalized locale. Therefore, en-us becomes en and fr-fr becomes fr.

Because both report and the user locale maps to fr, the user having the user locale fr-ca will see the report saved with the locale fr-fr.

**Example - Report and user locale maps to the same language**

The user locale and the report locales all map to the same language. IBM Cognos BI chooses which locale to use. For example, if a user's locale is en-ca (English-Canada) and the reports are available in en-us (English-United States) and en-gb (English-United Kingdom), IBM Cognos BI maps each locale to en. The user will see the report in the locale setting that IBM Cognos BI chooses.

**Example - Report and user locales do not map to a common language**

The report and the user locales do not map to a common language. IBM Cognos BI chooses the language. In this case, you might want to configure a mapping. For example, if a report is available in en-us (English-United States) and fr-fr (French-France), but the user locale is es-es (Spanish-Spain), IBM Cognos BI chooses the language.

**Mapping content locales**

Use the Content Locale Mappings table to map user locales to a complete (language-region) or partial (language) locale. You can also map a user's preferred language to another language if content is not available in the user's preferred language.

**About this task**

By default, the Content Locale Mappings table includes locales that do not contain the region. This allows you to use only the language portion of the locale when you specify locale settings and ensures that you always see the correct information. For example, in a multilingual database, data is usually available in different languages, such as French (fr), Spanish (es) and English (en), rather than being available in different locales, such as English Canada (en-ca), English United States (en-us), or French France (fr-fr).

**Procedure**

1. In each Content Manager installation, start IBM Cognos Configuration.
2. Click Actions > Edit Global Configuration.
3. Click the Content Locale Mapping tab.
4. Click Add.
5. In the Key box, type the user locale:
   - To ensure all regions for a user locale see content in a specific language, type the language portion of the locale, followed by a dash (-) and an asterisk (*).
     For example, type fr-*
To ensure a user locale (language-region) sees content in a specific language, type the complete locale. For example, type fr-ch.

To map a preferred language to another language, type the preferred language portion of the locale. For example, type zh.

Tip: To specify the locale to use for a range of keys, use the wildcard character (*) with the Key value and then, in the Locale Mapping box, type the locale. For example, if you want all the German keys to use the German locale, type in the Key box and type in the Locale Mapping box.

6. In the Locale Mapping box, type the language portion of the locale. User locales specified in the Key box will see content in this language.

7. Repeat steps the preceding steps for the other mappings you want to do.

8. Click OK.

9. Click File > Save.

Changing the server time zone

You can change the time zone used by Content Manager by selecting a different server time zone in IBM Cognos Configuration.

About this task

Content Manager is configured to use the time zone of your operating system by default. All scheduled activities in IBM Cognos are set using this time zone. In addition, users in IBM Cognos Connection use this time zone if they set their preferences for the default time zone.

Procedure

1. Start IBM Cognos Configuration.

2. Click Actions > Edit Global Configuration.

3. In the Global Configuration dialog box, click the General tab.

4. Click the Value column for Server time zone and select another time zone from the list.

5. Click File > Save.
Chapter 15. Configuration requirements for authentication providers

You can configure IBM Cognos Business Intelligence for z/OS to use an LDAP version 3 compliant authentication provider. IBM Cognos BI can use the centralized and automated data protection and storage management solutions that your organization uses for other applications and resources.

Single signon

After you configure an authentication provider, you can enable single signon for IBM Cognos components. This allows a user to log on once, and then be able to switch to another application without being prompted to log on again.

Authentication

IBM Cognos BI components run with two levels of logon:

- Anonymous logon
  By default, anonymous access is enabled.
- Authenticated logon
  You must configure IBM Cognos BI components with an appropriate namespace for the type of authentication provider in your environment.
  You can configure multiple namespaces for authentication and then choose, at run time, which namespace you want to use. For more information, see the Administration and Security Guide.

Namespace security

Do not disable security after you enable it. If you delete a namespace, the user preferences, My Folders, and My Pages entries are permanently lost. Existing permission settings will refer to users, groups, or roles that no longer exist. While this does not affect how the permissions work, a user administering the permission settings might see "unknown" entries. Because these entries refer to users, groups, and roles which no longer exist, you can safely delete them.

Disabling anonymous access

If you want to use authenticated logon only, you can use IBM Cognos Configuration to disable anonymous access.

About this task

By default, IBM Cognos Business Intelligence components do not require user authentication. Users can log on anonymously.

Procedure

1. In each location where Content Manager is installed, start IBM Cognos Configuration.
2. In the Explorer panel, click Security > Authentication > Cognos.
The IBM Cognos resource represents the Cognos namespace. The Cognos namespace stores information about IBM Cognos groups, such as the Anonymous User, contacts, and distribution lists, and refers to objects in other security namespaces.

3. In the Properties panel, click the box next to the Allow anonymous access property and then select False.

4. Click File > Save.

**What to do next**

Now, you must configure a namespace so that users are required to provide logon credentials when they access IBM Cognos resources.

**Related concepts:**
- “Configuration requirements for LDAP” on page 155
- You can configure IBM Cognos Business Intelligence for z/OS to use an LDAP namespace as the authentication provider.

**Related tasks:**
- “Configuring a RACF namespace” on page 163
- Use IBM Cognos Configuration to configure a Resource Access Control Facility (RACF) namespace for authentication.

---

**Restricting user access to the Cognos namespace**

You can restrict access to users belonging to any group or role defined in the Cognos built-in namespace.

**About this task**

By default, all users belong to several built-in groups or roles. To restrict access, you must do the following tasks:

- Enable the property to restrict access, using IBM Cognos Configuration.
- Remove the Everyone group from the IBM Cognos built-in roles and groups, using IBM Cognos Administration.
- Ensure that authorized users belong to at least one IBM Cognos role or group, using IBM Cognos Administration.

**Procedure**

1. In each Content Manager location, start IBM Cognos Configuration.
2. In the Explorer panel, under Security, click Authentication.
3. In the Properties panel, change the value of Restrict access to members of the built-in namespace to True.
4. Click File > Save.

**What to do next**

You must now use the portal to remove the Everyone group and ensure that authorized users belong to at least one IBM Cognos built-in role or group. For information about adding or removing members of an IBM Cognos group or role, see the Administration and Security Guide.
Configuration requirements for LDAP

You can configure IBM Cognos Business Intelligence for z/OS to use an LDAP namespace as the authentication provider.

If you install more than one Content Manager component, you must configure identical authentication providers in each Content Manager location. The type of authentication provider you select and the way you configure it must be identical in all instances. The configuration must contain information that is accessible by all Content Manager components.

Configuring an LDAP namespace using a template

To easily configure an LDAP namespace, choose from a set of pre-configured templates for each type of LDAP authentication provider.

Procedure

1. Start IBM Cognos Configuration.
2. In the Explorer panel, under Security, right click Authentication > New resource > Namespace.
3. In the Name field, type a name for the namespace.
4. From the Type list, choose the appropriate LDAP template.
   The template is denoted by LDAP - Authentication provider type. For example, LDAP - IBM Tivoli is a template that you can use to help you configure IBM Cognos components to use IBM Tivoli Directory Server.
5. In the Properties panel, enter an appropriate value for the settings.
6. To test the connection to the authentication provider and verify that the provider is supported, in the Explorer panel, right-click the provider and click Test.
   View the results of the test. If the results show that the LDAP provider might not be support or is not supported, review the supported software environments on the IBM Cognos Customer Center (http://www.ibm.com/software/data/cognos/customercenter/).
7. To save the configuration, click File > Save.

LDAP mapping

Before you can use IBM Cognos Business Intelligence for z/OS with an LDAP server, the LDAP user registry must have some minimal user and group information already populated.

Binding users to the LDAP server

To bind a user to the LDAP server, the LDAP authentication provider must construct the distinguished name (DN). If the Use external identity property is set to True, it uses the External identity mapping property to try to resolve the user’s DN. If it cannot find the environment variable or the DN in the LDAP server, it attempts to use the User lookup property to construct the DN.

External identity mapping

If users are stored hierarchically within the directory server, you can configure the User lookup and External identity mapping properties to use search filters. When the LDAP authentication provider performs these searches, it uses the filters you specify for the User lookup and External identity mapping properties. It also
binds to the directory server using the value you specify for the **Bind user DN and password** property or using anonymous if no value is specified.

When an LDAP namespace has been configured to use the **External identity mapping** property for authentication, the LDAP provider binds to the directory server using the **Bind user DN and password** or using anonymous if no value is specified. All users who log on to IBM Cognos BI using external identity mapping see the same users, groups, and folders as the Bind user.

**Searches that do not use external identity mapping**

If you do not use external identity mapping, you can specify whether to use bind credentials to search the LDAP directory server by configuring the **Use bind credentials for search** property. When the property is enabled, searches are performed using the bind user credentials or using anonymous if no value is specified. When the property is disabled, which is the default setting, searches are performed using the credentials of the logged-on user. The benefit of using bind credentials is that instead of changing administrative rights for multiple users, you can change the administrative rights for the bind user only.

If you use a DN syntax, such as `uid=${userID}, ou=mycompany.com`, for the properties **User lookup**, **External identity mapping**, or **Bind user DN and password**, you must escape all special characters that are used in the DN.

If you use a search syntax, such as `(uid=${userID})`, for the properties **User lookup** or **External identity mapping**, you must not escape special characters that are used in the DN.

**Configuring an LDAP namespace**

When users are stored in an LDAP user directory, you can configure IBM Cognos Business Intelligence for z/OS components to use an LDAP namespace.

**Procedure**

1. In each location where you installed Content Manager, open IBM Cognos Configuration.
2. In the **Explorer** panel, under **Security**, right-click **Authentication** > **New resource** > **Namespace**.
   a. In the **Name** box, type a name for your authentication namespace.
   b. In the **Type** list, click the appropriate namespace and then click **OK**.
   The new authentication provider resource appears in the **Explorer** panel, under the **Authentication** component.
3. In the **Properties** panel, for the **Namespace ID** property, specify a unique identifier for the namespace.
4. Specify the values for all other required properties to ensure that IBM Cognos components can locate and use your existing authentication provider.
5. If you want the LDAP authentication provider to bind to the directory server using a specific **Bind user DN and password** when performing searches, then specify these values.
   If no values are specified, the LDAP authentication provider binds as anonymous.
   If external identity mapping is enabled, **Bind user DN and password** are used for all LDAP access.
If external identity mapping is not enabled, **Bind user DN and password** are used only when a search filter is specified for the **User lookup** property. In that case, when the user DN is established, subsequent requests to the LDAP server are executed under the authentication context of the end user.

6. If you do not use external identity mapping, use bind credentials for searching the LDAP directory server by doing the following:
   a. Ensure that **Use external identity** is set to **False**
   b. Set **Use bind credentials for search** to **True**.
   c. Specify the user ID and password for **Bind user DN and password**.
       If you do not specify a user ID and password, and anonymous access is enabled, the search is done using anonymous.

7. Check the mapping settings for required objects and attributes
   Depending on the LDAP configuration, you might have to change some default values to ensure successful communication between IBM Cognos Business Intelligence components and the LDAP server.
   LDAP attributes that are mapped to the **Name** property in **Folder mappings**, **Group mappings**, and **Account mappings** must be accessible to all authenticated users. In addition, the **Name** property must not be blank.

8. Click **File > Save**.
   IBM Cognos Business Intelligence loads, initializes, and configures the provider libraries for the namespace.

**Configuring an LDAP namespace for an IBM Directory Server**

You can configure a new LDAP namespace to use with an IBM Directory Server.

**Procedure**

1. In each location where you installed Content Manager, open IBM Cognos Configuration.
2. In the **Explorer** panel, under **Security**, right-click **Authentication > New resource > Namespace**.
3. In the **Name** box, type a name for your authentication namespace.
4. In the **Type** list, click **LDAP**, and then click **OK**.
   The new authentication namespace resource appears in the **Explorer** panel, under the **Authentication** component.
5. In the **Properties** panel, for the **NamespaceID** property, type a unique identifier for the namespace.
   Do not use colons (:) in the Namespace ID property.
6. Specify the values for all other required properties to ensure that IBM Cognos Business Intelligence for z/OS can locate and use your existing authentication namespace.
   a. For the **User lookup** property, type (cn=${userID})
   b. For the **Bind user DN and password** property, type cn=root
7. If you want the LDAP authentication provider to bind to the directory server using a specific **Bind user DN and password** when performing searches, then specify these values.
   If no values are specified, the LDAP authentication namespace binds as anonymous.
8. If you do not use external identity mapping, use bind credentials for searching the LDAP directory server by doing the following:
a. Ensure that Use external identity is set to False.
b. Set Use bind credentials for search to True.
c. Specify the user ID and password for Bind user DN and password.

9. To configure the LDAP advanced mapping properties for use with IBM Directory Server objects, use the values specified in the following table.

Table 55. LDAP advanced mapping properties

<table>
<thead>
<tr>
<th>Mappings</th>
<th>LDAP property</th>
<th>LDAP value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder</td>
<td>Object class</td>
<td>organizationalunit,organization,container</td>
</tr>
<tr>
<td></td>
<td>Description</td>
<td>description</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>ou,o,cn</td>
</tr>
<tr>
<td>Group</td>
<td>Object class</td>
<td>groupofnames</td>
</tr>
<tr>
<td></td>
<td>Description</td>
<td>description</td>
</tr>
<tr>
<td></td>
<td>Member</td>
<td>member</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>cn</td>
</tr>
<tr>
<td>Account</td>
<td>Object class</td>
<td>inetorgperson</td>
</tr>
<tr>
<td></td>
<td>Business phone</td>
<td>telephonenumber</td>
</tr>
<tr>
<td></td>
<td>Content locale</td>
<td>(leave blank)</td>
</tr>
<tr>
<td></td>
<td>Description</td>
<td>description</td>
</tr>
<tr>
<td></td>
<td>Email</td>
<td>mail</td>
</tr>
<tr>
<td></td>
<td>Fax/Phone</td>
<td>facsimiletelephonenumber</td>
</tr>
<tr>
<td></td>
<td>Given name</td>
<td>givenname</td>
</tr>
<tr>
<td></td>
<td>Home phone</td>
<td>homephone</td>
</tr>
<tr>
<td></td>
<td>Mobile phone</td>
<td>mobile</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>cn</td>
</tr>
<tr>
<td></td>
<td>Pager phone</td>
<td>pager</td>
</tr>
<tr>
<td></td>
<td>Password</td>
<td>userPassword</td>
</tr>
<tr>
<td></td>
<td>Postal address</td>
<td>postaladdress</td>
</tr>
<tr>
<td></td>
<td>Product locale</td>
<td>(leave blank)</td>
</tr>
<tr>
<td></td>
<td>Surname</td>
<td>sn</td>
</tr>
<tr>
<td></td>
<td>Username</td>
<td>uid</td>
</tr>
</tbody>
</table>

These mapping properties represent changes based on a default IBM Directory Server installation. If you have modified the schema, you might have to make additional mapping changes.

LDAP attributes that are mapped to the Name property in Folder mappings, Group mappings, and Account mappings must be accessible to all authenticated users.

The Name property must not be blank.

10. Click File > Save.
**Configuring custom user properties for an LDAP namespace**

You can use any user properties from your LDAP authentication provider and make them available to IBM Cognos Business Intelligence for z/OS components.

**About this task**

To configure custom user properties, you must add these attributes as custom properties for the LDAP namespace. The custom properties are available as session parameters through Cognos Framework Manager.

**Procedure**

1. In each location where you installed Content Manager, open Cognos Configuration.
2. In the Explorer panel, under Security > Authentication, click the LDAP namespace.
3. In the Properties panel, click in the Value column for Custom properties, and click the edit button.
4. In the Value - Custom properties box, click Add.
5. Click the Name column, and type the name you want IBM Cognos BI components to use for the session parameter.
6. Click the Value column, and type the name of the account parameter in your LDAP authentication provider.
7. Repeat the preceding two steps for each custom parameter.
8. Click OK.
9. Click File > Save.

**Enabling secure communication to an LDAP server**

You can enable LDAP over SSL (LDAPS) by installing a properly formatted certificate.

To enable LDAPS, install a server certificate that is signed by a certificate authority in the directory server. The server certificate must be a copy of either one of the following certificates:

- The trusted root certificate and all other certificates that make up the chain of trust for the directory server certificate
  - The trusted root certificate is the certificate of the root certificate authority that signed the directory server certificate.
- The directory server certificate only

The certificates must be Base64 encoded in ASCII (PEM) format. All certificates, except the trusted root certificate, must not be self-signed.

**Procedure**

1. Create a directory for the certificate database.
2. Create the certificate database by typing
   ```
   certutil -N -d certificate_directory
   ```
   where `certificate_directory` is the directory that you created in step 1.
   This command creates a cert8.db file and a key3.db file in the new directory.
3. Add the certificate authority (CA) certificate or the directory server certificate to the certificate database by typing the appropriate command for the type of certificate:
   - For a CA certificate, type
     
     `certutil -A -n certificate_name -d certificate_directory -i CA.cert -t C,C,C`
   - For a directory server certificate, type
     
     `certutil -A -n certificate_name -d certificate_name -i server_certificate.cert -t P`

   where `certificate_name` is an alias that you assign, such as the CA name or host name; and `server_certificate` is the prefix of the directory server certificate file.

4. Copy the certificate database directory to the `c10_location/configuration` directory in each Content Manager installation.

5. Configure the directory server to use LDAPS and restart the directory server.
   For more information, see the documentation for the directory server.

6. In each Content Manager location where you configured the LDAP namespace to use the directory server, start Cognos Configuration.

7. In the **Explorer** panel, under **Security, Authentication**, click the LDAP namespace.

8. In the **Properties** panel, for the **Host and port** property, change the port to the secure LDAPS port.
   For the **SSL certificate database** property, specify the path to the `cert7.db` file.

9. In the **Explorer** panel, right-click the LDAP namespace and click **Test**.
   If the test fails, revise the properties, ensuring that the correct certificate is used.

10. Click **File > Save**.

11. Click **Actions > Restart**.

12. Repeat steps 6 to 11 in each Content Manager installation.

---

**Single signon between an LDAP server and IBM Cognos BI components**

To simplify the authentication process for users, enable single signon between LDAP and IBM Cognos Business Intelligence for z/OS components.

You configure the **External Identity mapping** property to enable single signon between IBM Cognos BI components and LDAP. The **External Identity mapping** property can refer to a CGI environment variable or an HTTP header variable.

**Application server environments**

For an application server gateway or a dispatcher entry pointing to IBM Cognos BI components, the **External Identity mapping** property can refer to the `userPrincipalName` session variable. The resolved value of the **External Identity mapping** property at runtime must be a valid user DN.

**LDAP namespaces**

When an LDAP namespace is configured to use the **External Identity mapping** property for authentication, the LDAP provider binds to the directory server using the **Bind user DN and password** or using anonymous if no value is specified. All users who log on to IBM Cognos BI using external identity mapping see the same
users, groups, and folders as the Bind user.

**Java security**

If you want IBM Cognos BI components to work with applications that use Java or application server security, you can configure the External identity mapping property to obtain the user ID from the Java user principal. Include the token `${environment("USER_PRINCIPAL")}` in the value for the property.

**Replace operation**

You can apply limited expression editing to the External identity mapping property using the replace operation.

**Purpose**

The replace operation returns a copy of the string with all occurrences of the old substring replaced by the new substring.

The following rules apply:

- The character \ escapes the characters in the function parameters. Characters such as \ and " need escaping.
- Nested function calls are not supported.
- Special characters are not supported.

**Syntax**

`${replace(str , old , new)}`

**Parameters for the replace operation**

The following table lists the parameter descriptions for the replace operation.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>str</td>
<td>The string to search.</td>
</tr>
<tr>
<td>old</td>
<td>The substring to be replaced by the new substring.</td>
</tr>
<tr>
<td>new</td>
<td>The substring that replaces the old substring.</td>
</tr>
</tbody>
</table>

`${replace(${environment("REMOTE_USER")},"NAMERICA\","})`

`${replace(${environment("REMOTE_USER")},"NAMERICA\",",")}`

**Custom authentication provider configuration requirements**

You can configure IBM Cognos Business Intelligence for z/OS components to use a custom Java authentication provider.

If you implemented a Java authentication provider, you can do the following:

- Configure IBM Cognos BI components to use it
- Use a custom authentication provider to access and authenticate users to an alternate authentication source
Use the customer authentication provider as a single signon mechanism to integrate IBM Cognos BI components with your security infrastructure.

Any additional configuration for authentication source access, single signon, or custom attributes is dependent on the custom authentication provider implementation.

For more information, see the Custom Authentication Provider Developer Guide.

Configuring a namespace for a custom authentication provider

You can configure IBM Cognos Business Intelligence of z/OS components to use a custom authentication namespace.

Before you begin

Ensure that the versions of the Java runtime environment (JRE) and Java SDK that you use are compatible with each other. If you use supported versions of the JRE and Java SDK that are not compatible with each other, the custom Java authentication provider that you configure will not display in the list of namespaces in IBM Cognos Configuration.

Procedure

1. In each Content Manager location, open IBM Cognos Configuration.
2. In the Explorer panel, under Security, right-click Authentication > New resource > Namespace.
3. In the Name box, type a name for your authentication namespace.
4. In the Type list, select Custom Java Provider and then click OK.
   The new authentication provider resource appears in the Explorer panel, under the Authentication component.
5. In the Properties panel, for the NamespaceID property, type a unique identifier for the namespace.
   Do not use colons (:) in the Namespace ID property.
6. Click File > Save.
7. In the Explorer panel, under Authentication, right-click the new authentication resource and click Test to ensure that IBM Cognos BI can connect to the new namespace.

Results

IBM Cognos BI loads, initializes, and configures the provider libraries for the namespace.

Hiding the namespace from users during login

You can hide the customer authentication provider namespace from users during login. You can have trusted signon namespaces without showing them on the namespace selection list that is displayed when users log in.

For example, you can integrate single signon across systems but maintain the ability for customers to authenticate directly to IBM Cognos Business Intelligence without being prompted to choose a namespace.
Procedure

1. In each location where you configured a custom Java authentication provider, open IBM Cognos Configuration.
2. In the Explorer panel, under Security > Authentication, click custom Java authentication provider.
3. In the Properties panel, click the box next to Selectable for authentication and select False.
4. Click File > Save.

RACF authentication requirements

Some configuration is required before you can use Resource Access Control Facility (RACF) as the authentication provider for IBM Cognos Business Intelligence for z/OS.

Configuring a RACF namespace

Use IBM Cognos Configuration to configure a Resource Access Control Facility (RACF) namespace for authentication.

Before you begin

Ensure you disable anonymous access.

To use RACF, Tivoli directory server is required.

To avoid compromising the security and integrity of the system, a program must be authorized by the APF (authorized program facility) before it can access restricted functions and sensitive system functions. The JVM under which IBM Cognos Business Intelligence runs in WebSphere Application Server is not an authorized program. However, Tivoli Directory Server is an authorized program. IBM Cognos Business Intelligence for z/OS components communicate with Tivoli Directory Server by using a JAVA custom authentication provider, and Tivoli Directory Server uses SDBM (secured database management) to communicate with RACF.

Procedure

1. In the location where you installed Content Manager, open IBM Cognos Configuration.
2. Create a RACF namespace.
   a. In the Explorer panel, under Security, right-click Authentication > New resource > Namespace.
   b. In the Name field, type a name for your authentication namespace.
   c. From the Type list, select RACF and then click OK.
      The new authentication provider resource appears in the Explorer panel, under the Authentication component.
3. In the Properties panel, for the Namespace ID property, specify a unique identifier for the namespace.
   Do not use colons (:) in the Namespace ID property.
4. For the Host and port property, type the value that corresponds to the Tivoli Directory Server.
5. For the Base Distinguished Name property, type the value that matches the suffix that is configured for SDBM in the Tivoli Directory Server.
6. If you are using an SSL connection to the RACF provider, set the Enable SSL property to true.
7. To map to RACF account properties such as email and phone number, for the Base segment DATA and the TSO segment USERDATA properties under Account mappings, click in the value column and select the value from the drop-down list.
8. From the File menu, click Save.
9. In the Explorer panel, under Authentication, right-click the new authentication resource and click Test.
   If the test is successful, the product can connect to the new provider.

### Enabling single signon between RACF and IBM Cognos BI components

Enable single signon between RACF and IBM Cognos BI components to simplify the authentication process for users, to avoid the need for multiple signons, and to simplify user identity management across the network.

**About this task**

You enable single signon between the RACF provider and IBM Cognos BI components by configuring identity mapping in IBM Cognos Configuration, configuring IBM WebSphere Application Server to set the REMOTE_USER, and then configuring WebSphere to authenticate against RACF.

When you configure a RACF namespace to use identity mapping for authentication, the RACF namespace binds to the RACF provider using the binding credentials or using anonymous if no binding credentials are specified. All users who log on to IBM Cognos BI using identity mapping see the same users, groups, and folders as the binding user.

**Procedure**

1. Ensure that you configured a RACF authentication provider in IBM Cognos Configuration.
2. Using the WebSphere documentation, configure WebSphere to set REMOTE_USER.
3. Using the WebSphere documentation, configure WebSphere to authenticate using the RACF provider.

### Deleting an authentication provider

If a namespace for an authentication provider is no longer required, you can delete it. You can unconfigure a namespace that IBM Cognos Business Intelligence for z/OS components detected.

You must not delete the Cognos namespace. It contains authentication data that pertains to all users and is required to save the configuration.

When you delete a namespace, you can no longer log on to the namespace. Security data for the namespace remains in Content Manager until you permanently delete it in the portal. For more information, see the *Administration and Security Guide*. 

---

164  IBM Cognos Business Intelligence Version 10.2.0: Installation and Configuration Guide for z/OS
Procedure
1. In each location where you installed Content Manager, open Cognos Configuration.
2. In the Explorer panel, under Security > Authentication, right-click the namespace and click Delete.
3. Click Yes to confirm.
   The namespace disappears from the Explorer panel and you can no longer log on to the namespace on that computer.
4. Click File > Save.
5. Repeat the previous steps 1 to 4 in each location where you installed Content Manager.
   You must now log on to the portal and permanently delete the data for the namespace. For more information, see the Administration and Security Guide

Results
After you delete a namespace, it appears as inactive in the portal.
Chapter 16. IBM Cognos Workspace configuration

IBM Cognos Workspace is installed with IBM Cognos BI Server. After installation, some configuration is required. In addition, you can do optional configuration tasks.

For example, to learn more about Cognos Workspace, you can set up and then use the product samples.

Cognos Workspace samples are included with the IBM Cognos Business Intelligence samples.

Testing IBM Cognos Workspace

You can test IBM Cognos Workspace any time after the IBM Cognos service is started.

Procedure
1. Open a browser and log in to IBM Cognos Connection.
2. Click the new workspace button in the toolbar.
   If an IBM Cognos Workspace blank workspace canvas appears, the service started successfully.
3. If reports are available, expand a report folder into parts and drag a part onto the canvas.
   If the report opens, IBM Cognos Workspace is running properly.

Configuring access to IBM Cognos Workspace

Configure access to IBM Cognos Workspace by granting required permissions for the Executive Dashboard capability to specified namespaces, users, groups, or roles.

About this task
You can grant full access to IBM Cognos Workspace or you can grant access only to the publishing function.

IBM Cognos BI must be configured and operating before you can configure access for IBM Cognos Workspace.

Procedure
1. In IBM Cognos Connection, in the upper-right corner, click Launch, IBM Cognos Administration.
2. On the Security tab, click Capabilities.
3. Find the Executive Dashboard capability.
4. To grant access to IBM Cognos Workspace and all its functionality, grant execute and traverse permissions for the Executive Dashboard capability.
   a. Click the actions button next to the capability name, and then select Set properties.
b. Select the **Permissions** tab.
c. Grant Execute permission to all user groups that should have access to IBM Cognos Workspace, and then click **OK**.

5. To grant access only to the publishing function within IBM Cognos Workspace, grant traverse permissions for the Executive Dashboard capability and execute permissions for the Publish Dashboards to Collaboration Spaces secured function.

   a. Click the actions button next to **Use Advanced Dashboard Feature**, and click **Set properties**.
   b. To set access permissions explicitly for each entry, select the **Override the access permissions acquired from the parent entry**.
   c. For each user group, select the check box beside the entry, and in the box next to the list, select the check boxes to grant permissions for the entry.
   d. To add new entries to the list, click **Add** and choose how to select entries.
      • To choose from available entries, click the appropriate namespace, and then select the check boxes next to the users, groups, or roles.
      • To search for entries, click **Search** and in the Search string box, type the phrase you want to search for. For search options, click **Edit**. Find and click the entry that you want.
      • To type the name of entries that you want to add, click **Type** and type the names of groups, roles, or users using the following format, where a semicolon (;) separates each entry: namespace/group_name;namespace/role_name;namespace/user_name;
      Grant the appropriate permissions for each new entry.
   e. Click **OK**.

---

**Human tasks and annotation services database**

By default, the data used for the human tasks and annotation services in IBM Cognos Workspace is stored in the same database as the content store. You can use a separate database for human tasks and annotation services.

**Creating a human tasks and annotation database on DB2 for z/OS**

The DB2 database that you create on the z/OS system for the human tasks and annotation services must contain the specified configuration settings.

**Procedure**

1. Create a database subsytem, storage group, and user account for the content store.
   To create the database, you must have System Administrator (**SYSADM**) or System Control (**SYSCtrl**) authority.
2. Ensure that the database has the following features:
   • UNICODE as the CCSID.
   • A buffer pool with a page size of 32 KB.
   • A second buffer pool with a page size of 16 KB for the database subsytem
3. Ensure that the database administrator grants CONNECT, CREATEIN, and CREATE TABLE rights or grants DBADM to the user who manages the content store database.
For example, to grant CREATETAB to a user CGCUSER:

\begin{verbatim}
GRANT CREATETAB ON DATABASE CMDB101 TO CGCUSER
\end{verbatim}

a. Ensure that the user has privileges to create an index on buffer pools that were created and reserved when creating the content store database.

For example,

\begin{verbatim}
GRANT USE OF BUFFERPOOL BP2 TO CGCUSER
\end{verbatim}

b. Ensure that the user has privileges to create an index on a storage group that was created when creating the content store database.

For example,

\begin{verbatim}
GRANT USE OF STOGROUP SGDBT1DT TO CGCUSER
\end{verbatim}

### Creating table spaces for the human task and annotation database on DB2 on z/OS

If you are using DB2 on z/OS, a database administrator must run scripts to create the table spaces required for the human task and annotation database. The script must be modified to replace the placeholder parameters with ones that are appropriate for your environment.

Ensure that you use the name convention for DB2 on z/OS. For example, all names of parameters must start with a letter and the length must not exceed six characters. For more information, see the IBM DB2 Information Center.

You can use your content store database or a separate database for the human task and annotation database. In either case, you must run the scripts to create the table spaces.

**Procedure**

1. Connect to the database as a user with privileges to create and drop table spaces and to allow execution of SQL statements.

2. To create the human tasks table spaces, go to the \texttt{c10\_location/configuration/schemas/hts/zosdb2} directory.

   a. Make a backup copy of the \texttt{HTS\_tablespaces.sql} script file and save the file to another location.

   b. Open the original \texttt{HTS\_TABLESPACES.sql} script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>Specifies the name of the database.</td>
</tr>
<tr>
<td>DSN8G810</td>
<td>Specifies the name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>Specifies name of the 32 k buffer pool.</td>
</tr>
</tbody>
</table>

   See the script for a complete list of the parameters required.

   c. Save and run the script.

   d. Open the \texttt{HTS2\_CREATE\_Db2zos.sql} script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.
Table 58. Tablespace parameter names and descriptions for human tasks on DB2 for z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>The name of the database.</td>
</tr>
</tbody>
</table>

See the script for a complete list of the parameters required.

e. Save and run the script.

3. To create the annotations tables, go to the c10_location/configuration/schemas/ans/zosdb2 directory.

   a. Make a backup copy of the ANN_TABLESPACES.sql script file and save the file to another location.

   b. Open the original ANN_TABLESPACES.sql script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

Table 59. Tablespace parameter names and descriptions for annotations on DB2 for z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>The name of the database.</td>
</tr>
<tr>
<td>DSN8G810</td>
<td>The name of the storage group.</td>
</tr>
<tr>
<td>BP32K</td>
<td>The name of the 32 k buffer pool.</td>
</tr>
</tbody>
</table>

See the script for a complete list of the parameters required.

c. Save and run the script.

d. Open the ANS2_CREATE_Db2zos.sql script file and use the following table to help you to replace the generic parameters with ones appropriate for your environment.

Table 60. Tablespace parameter names and descriptions for annotations on DB2 for z/OS

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCCOG</td>
<td>The name of the database.</td>
</tr>
</tbody>
</table>

See the script for a complete list of the parameters required.

e. Save and run the script.

Related tasks:
“Creating tablespaces for a content store on DB2 for z/OS” on page 56

A database administrator must run scripts to create a set of tablespaces required for the content store database. Modify the scripts to replace the placeholder parameters with ones that are appropriate for your environment.

Configuring the human tasks and annotation services database

By default, the data used for the human tasks and annotations feature in IBM Cognos Workspace is stored in the same database as the content store. You can configure a separate database for human tasks and annotations services.

Procedure
1. In each location where Application Tier Components is installed, start IBM Cognos Configuration.

2. In the Explorer panel, right-click Human Task and Annotation Services and select New resource > Database.
3. In the **New Resource - Database** dialog box, type a name for the database, select **DB2 database** for the type, and then click **OK**.
4. In the database resource properties window, configure the required settings.
5. Click **File > Save**.
6. To test the connection to the new database, click **Actions > Test**.
7. Repeat these steps for each Application Tier Components and Content Manager instance.

### Changing the style of report objects in IBM Cognos Workspace

When you drag a report object onto a workspace, it appears in the silver and blue gradient style of your product. You can configure the report object appear in the original authored style by changing a global property in the IBM Cognos Viewer configuration file.

Report objects that are affected by the global setting include queries, analyses, reports, and report parts that were authored using IBM Cognos Version 1.x style, Version 8.x style, and financial (balance sheet) style. These objects pick up the global setting even if you saved them before changing the global setting. Workspace thumbnails are affected by the global setting only if you rerun the thumbnail.

Some report objects are not affected by the global setting and will always render in the authored style, such as PowerPlay® reports and report object thumbnails.

### Procedure

1. For each Content Manager and Application Tier Components instance, go to `the10_location/webapps/p2pd/WEB-INF/classes` directory.
2. Open the `viewerconfig.properties` file in a text editor.
3. To make report objects appear in the original authored style, change the value for `useAuthoredReportStyles` to `true`.
4. Save the file and then restart the services.
Chapter 17. Configuration options for third-party certificate authority support

By default, IBM Cognos Business Intelligence for z/OS components use an internal certificate authority (CA) service to establish the root of trust in the IBM Cognos security infrastructure. If you are already using an external certificate authority, you can configure the IBM Cognos BI components to use it instead.

Command line options for the third party certificate script

Several command-line options are available to use with the third party certificate script. The script is used to generate the keys and the certificate signing requests (CSR) that IBM Cognos Business Intelligence for z/OS components require.

The following tables list the options for the command-line tool used to generate keys and signing requests.

Table 61. Command line options and their description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-c</td>
<td>Create a new CSR</td>
</tr>
<tr>
<td>-i</td>
<td>Import a certificate</td>
</tr>
</tbody>
</table>

Table 62. Operation modifiers and their description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-s</td>
<td>Work with the signing identity</td>
</tr>
<tr>
<td>-e</td>
<td>Work with the encryption identity</td>
</tr>
<tr>
<td>-T</td>
<td>Work with the trust store (only with -i)</td>
</tr>
</tbody>
</table>

Table 63. Information flags and their descriptions

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-d</td>
<td>DN to use for certificate</td>
</tr>
<tr>
<td>-r</td>
<td>CSR or certificate file location (depends on mode)</td>
</tr>
<tr>
<td>-t</td>
<td>certificate authority certificate file (only with -i)</td>
</tr>
<tr>
<td>-p</td>
<td>Key Store password (must be provided)</td>
</tr>
<tr>
<td>-a</td>
<td>Key pair algorithm. RSA or DSA.</td>
</tr>
<tr>
<td></td>
<td>Default: RSA</td>
</tr>
<tr>
<td></td>
<td>-a Key pair algorithm. RSA or DSA.</td>
</tr>
<tr>
<td></td>
<td>Default: RSA</td>
</tr>
<tr>
<td>-D</td>
<td>Directory location</td>
</tr>
</tbody>
</table>
Table 64. Sample properties and their values

<table>
<thead>
<tr>
<th>Property</th>
<th>Sample value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Signing certificate DN</td>
<td>CN=SignCert,O=MyCompany,C=CA</td>
</tr>
<tr>
<td>Encryption certificate DN</td>
<td>CN=EncryptCert,O=MyCompany,C=CA</td>
</tr>
<tr>
<td>Key store password</td>
<td>password</td>
</tr>
</tbody>
</table>

Generating keys and certificate signing requests using a script

Use the command line utility to generate all the keys for the IBM Cognos key stores and to generate the certificate signing requests (CSR).

Before you begin

Back up the following files or directories:
- `c10_location/configuration/cogstartup.xml`
- `c10_location/configuration/signkeypair`
- `c10_location/configuration/encryptkeypair`

Procedure

1. Using IBM Cognos Configuration, export the configuration in clear text.
   a. Click File > Export As.
   b. When prompted about exporting decrypted content, click Yes.
   c. In the Export As dialog box, select cogstartup.xml and then click Save.
   d. When prompted about replacing the existing file, click Yes.
   e. When the tasks are complete, close the IBM Cognos Configuration dialog box.
   f. Save the configuration.
   g. Close IBM Cognos Configuration.
2. Go to the `c10_location/bin` directory.
3. Create the certificate signing request for the signing keys by typing the following command:
   ```
   ThirdPartyCertificateTool.sh -c -s -d "CN=SignCert,O=MyCompany,C=CA" -r signRequest.csr -D ../configuration/signkeypair -p password
   ```
   The command creates the jSignKeystore file in the signkeypair directory, sets the specified password, creates a new keypair and stores it in the keystore, and exports the `signRequest.csr` file to the `c10_location/bin` directory.
4. Create the certificate signing request for the encryption keys by typing the following command:
   ```
   ThirdPartyCertificateTool.sh -c -e -d "CN=EncryptCert,O=MyCompany,C=CA" -r encryptRequest.csr -D ../configuration/encryptkeypair -p password
   ```
   You can safely ignore any warnings about logging.
   The command creates the jEncKeystore file in the encryptkeypair directory, sets the specified password, creates a new keypair and stores it in the keystore, and exports the `encryptRequest.csr` file to the `c10_location/bin` directory.
5. Copy the `signRequest.csr` and `encryptRequest.csr` files that were generated in to a directory that is accessible by your certificate authority.
6. Input the signRequest.csr and encryptRequest.csr files into the certificate authority.
   For more information, see your Certificate Authority documentation.
   The certificate authority produces a signing certificate and an encryption certificate.

7. Copy the contents of the certificates into the certificate files.
   a. Copy the contents of the signing certificate into a signCertificate.cer file.
   b. Find the root CA certificate for the certificate authority and copy the contents into ca.cer file.
   c. Copy ca.cer, signCertificate.cer, and encryptCertificate.cer to
      c10_location/bin directory.
      These files must be PEM (Base-64 encoded ASCII) format.

8. Import the signing certificate into the IBM Cognos signing key store by typing the following command:
   ThirdPartyCertificateTool.sh -i -s -r signCertificate.cer -D
   ../configuration/signkeypair -p password -t ca.cer

9. Import the encryption certificate from step 11 into the IBM Cognos encryption key store by typing the following command:
   ThirdPartyCertificateTool.sh -i -e -r encryptCertificate.cer -D
   ../configuration/encryptkeypair -p password -t ca.cer
   The command reads the encryptCertificate.cer and ca.cer files in the
   c10_location/bin directory and imports the certificates from both files into
   the jEncKeystore file in the encryptkeypair directory using the specified password.

10. Import the CA certificate from step 12 into the IBM Cognos trust store by typing the following command:
    ThirdPartyCertificateTool.sh -i -T -r ca.cer -D ../configuration/s
    ignkeypair -p password
    The command reads the ca.cer file and imports the contents into the
    jCAKeystore file in the signkeypair directory using the specified password.

---

**Configuring IBM Cognos components to use an external certificate authority**

You must configure each IBM Cognos Business Intelligence for z/OS component installation to use an external certificate authority.

**Procedure**

1. Start IBM Cognos Configuration.
2. In the **Explorer** panel, under **Security, Cryptography**, click **Cognos**.
3. In the **Properties** panel, under **Certificate Authority settings** property group, click the **Value** box next to the **Use third party CA** property and then click **True**.

   **Note:** When you set this property to true, all properties for the certificate authority and identity name are ignored.

4. Configure the following properties to match the ones you typed in the command line utility:
   - **Signing key store location**
   - **Signing key store password**
5. Click File > Save.
6. To start the IBM Cognos BI service, click Actions > Start.
   This action starts all installed services that are not running. If you want to start
   a particular service, select the service node in the Explorer panel and then click
   Actions > Start.
Chapter 18. Performance monitoring

Use IBM Cognos Administration console and other tools to help you to maintain performance during the product lifecycle.

For more information about IBM Cognos Administration, see the Administration and Security Guide.

Controlling performance by using Work Load Manager functions

The performance requirements of an installation in a sysplex depends on the elements that WLM uses to manage the workloads. These elements include workloads, service classes, classification rules and classification groups.

About this task

You can define service classes, which are groupings of work that have similar performance goals, resource requirements or operational goals. You can also associate the service classes with the workloads that have already been created. You assign each service class with a relative importance and one of the following goals:

- Average response time
- Response time with percentile
- Execution velocity
- Discretionary

For more information about WLM settings, see System Programmer's Guide to Workload Manager.

Procedure

1. To begin the WLM definitions, group the components of work into workloads that allow you to easily monitor them.

   For example, the following chart shows an example of the list of workloads for an IBM Cognos Business Intelligence installation that runs inside of a WebSphere Application Server instance.

   ![Workload Selection List](image)

   Action Codes: 1=Create, 2=Copy, 3=Modify, 4=Browse, 5=Print, 6=Delete,
   /=Menu Bar

   Command ===> ______________________________________________________________

   Action | Name     | Description                          | User   | Date    
   ------ | -------- | ------------------------------------ | ------ | ------- 
   ______ | -------- | ------------------------------------ | ------ | ------- 
   ___    | DB2ADDR  | DB2 WORKLOAD                         | SYSADM | 1996/10/03
   ___    | DB2SPAS  | DB2 STORED PROCEDURE WORKLOAD        | SYSADM | 1996/09/04
   ___    | DDF      | DB2 DDF WORKLOAD                    | SYSADM | 1996/09/04
   ___    | IRLM     | IRLM WORKLOAD                       | SYSADM | 1996/09/04
   ___    | OMVS     | OMVS WORKLOAD                       | SYSADM | 2010/05/26
   ___    | WAS_WKLD | WebSphere Workloads                 | SYSADM | 2010/05/12

2. Use the description field notations in the following list of service classes to help you define the initial service class settings for a typical IBM Cognos Business Intelligence installation that is deployed to Websphere Application Server.
Action Class  Description  Workload
---  --------------------  -------
  DB2ADDR  DB2 ADDRS VEL60 IMP2  DB2ADDR
  DB2SPAS  DB2 SPAS ADDR VEL25 IMP4  DB2SPAS
  DDF  DDF LUNAME AVG R010 IMP3  DDF
  OMVSSRV  OMVS SERVICE CLASS vel 70  OMVS
  WAS7CB  WAS CB 0.5 Resp  WAS_WKLD
  WAS7CR  WAS V7 CR Vel 40  WAS_WKLD
  WAS7SR  WAS V7 SR Vel 55  WAS_WKLD
  WAS7STC  WAS V7 STC Vel 40  WAS_WKLD

These settings should be adjusted as needed.

Generally, you should give DB2 the highest velocity (for the content store and/or the data warehouse), followed by the WebSphere Application Server servant region. The WebSphere Application Server servant region should have a higher velocity than the control region and the STC (started task subsystem type) service class. However, all of the WebSphere Application Server service classes should be set lower than DB2. Finally, provide the Component Broker class with a valid response time objective.

3. Define the classifications rules, which map the work that is coming into the system to specific service and report classes.

For example, as shown in the following chart, update the default subsystem types CB (Component Broker), OMVS, and STC.

Action Type  Description  Service  Report
---  --------------------  ------  ------
  ASCH  not used  ASCH  ASCH
  CB  Component Broker Requests  WAS7CB  WAS7CB
  CICS  CICS TRANSACTION GROUP  CICSTRN  CICSRPT
  DB2  not used  DB2  DB2
  DDF  DDF threads  DDF  DDF
  IMS  not used  IMS  IMS
  IWAT  not used  IWAT  IWAT
  JES  JES2 JOBS  DEFAULTJ  DEFAULTJ
  LSFM  not used  LSFM  LSFM
  OMVS  OMVS  OMVS  OMVS
  SOM  not used  SOM  SOM
  STC  STARTED TASKS  STC  STC
  TSO  TSO TASKS  TSO  TSO

a. Add an accurate transaction qualifier name, a service, and reporting classes to the existing subsystem rules for Component Broker.

For example,
b. Add an accurate transaction qualifier name, a service, and reporting classes to the existing subsystem rules for OMVS.

For example,

```
Command ==> ___________________________________________ Scroll ==> PAGE

Modify Rules for the Subsystem Type Row 1 to 4 of 4

Subsystem Type .: OMVS Fold qualifier names? Y (Y or N)
Description . . . OMVS
Action codes: A=After C=Copy M=Move I=Insert rule
B=Before D=Delete row R=Repeat IS=Insert Sub-rule
More ===> 

--------Qualifier-------- -------Class--------
DEFAULTS: OMVSSRV
____ 1 TN CGC ___ OMVSSRV CGC
____ 1 TN CGC% ___ OMVSSRV CGCN
____ 1 TN HTTP% ___ OMVSSRV HTTPN
____ 1 UI * ___ OMVSSRV OMVSRT
```

c. Add an accurate transaction qualifier name, a service, and reporting classes to the existing subsystem rules for STC.

For example,

```
Command ==> ___________________________________________ Scroll ==> PAGE

Modify Rules for the Subsystem Type Row 20 to 23 of 23

Subsystem Type .: STC Fold qualifier names? Y (Y or N)
Description . . . STARTED TASKS
Action codes: A=After C=Copy M=Move I=Insert rule
B=Before D=Delete row R=Repeat IS=Insert Sub-rule
More ===> 

--------Qualifier-------- -------Class--------
DEFAULTS: OMVSSRV
____ 1 TN BBOD% ___ SYSSTC WAS7AS
____ 1 TN BBOS% ___ SYSSTC WAS7AS
____ 1 TN BBOS% ___ WAS7SR WAS7SR
____ 1 TN BBOS% ___ WAS7SR WAS7CR
```

4. Define appropriate reporting classes for reporting and analysis.

For example, you can do separate RMF™ workload summary reporting for specific groups of activity based on the report class name, and what has been assigned to each class.

For reporting by address space, you can use the following definitions as guidelines.

```
Command ==> ___________________________________________ Scroll ==> PAGE

Report Class Selection List Row 1 to 15 of 46

Action Codes: 1=Create, 2=Copy, 3=Modify, 4=Browse, 5=Print, 6=Delete,
/=Menu Bar

Action Name Description User Date
--- Last Change ---
CGC CGC REPORT CLASS SYSADM 2010/06/14
CGCN CGC REPORT CLASS SYSADM 2010/06/15
DB2RPT DB2 REPORT CLASS SYSADM 1996/09/04
DDFRPT DDF REPORT CLASS SYSADM 1996/09/04
HTTPN HTTPN REPORT CLASS SYSADM 2010/07/06
OMVSSRT omvs report class SYSADM 2005/11/22
TCPRPT tcpip addr space report class SYSADM 2005/11/16
WASCB WAS CB Report Class SYSADM 2010/09/27
```
Monitoring system metrics with JMX

You can monitor system metrics outside of IBM Cognos Administration by using industry standard Java Management Extensions (JMX).

Before you begin

To use the external monitoring feature, you must install the Java Software Development Kit from IBM.

About this task

First, you configure two JMX properties in IBM Cognos Configuration to enable secure access to the metrics in the Java environment. Then you use a secure user ID and password to connect to the metrics through a JMX connection tool.

Procedure

1. In the location where Content Manager is installed, start IBM Cognos Configuration.
2. In the Explorer panel, click Environment.
3. In the Properties panel, under Dispatcher Settings, click External JMX port.
4. In the Value box, type an available port number.
5. For the External JMX credential property, in the Value box, click the edit icon, type a user ID and password, and then click OK.
6. The user ID and password ensure that only an authorized user can connect to the system metrics data in the Java environment, using the port specified in External JMX port.
7. Save the changes and restart the service.
8. To access the system metrics data, specify the following information in the JMX connection tool:
   - the URL to connect to the system metrics data
     For example,

   ```
   service:jmx:rmi:///Content_Manager_server/jndi/rmi://monitoring_server:<JMXport>/proxyserver
   ```
   where JMXport is the value that you typed for External JMX port, and Content_Manager_server and monitoring_server are machine names. Do not use localhost, even if connecting locally.
   - the user ID and password to secure the connection
     Use the same values that you configured for External JMX credential.
Chapter 19. Product maintenance

Interim maintenance fixes contain updates to one or more components in the IBM Cognos Business Intelligence for z/OS product and are applied after you install the base product.

Preventive Service Planning buckets

You must review the Preventive Service Planning (PSP) bucket information for a product when applying maintenance.

Visit the IBM Software Support Center for information about PSP upgrades for IBM Cognos Business Intelligence for z/OS, or see the Program Directory. Although the Program Directory contains a list of required program temporary fixes (PTFs), the most current information is available from the IBM Software Support Center.

Program Temporary Fixes

A PTF contains a fix or group of fixes that repair a known issue. PTFs can be applied individually and are usually made available as part of a fix package that includes a number of PTFs.

Fix packs

Fix packs are not standalone installations. You must install them in the same location as existing IBM Cognos Business Intelligence components.

Fix packs are cumulative, therefore, if multiple fix packs are available, you do not have to install a previous fix pack before you install the latest available. However, you must first install the GA (General Availability) code.

When you apply the fix pack, the new level of the product overwrites the existing level.

If you are using Websphere Application Server, the IBM Cognos application must be redeployed after applying service.

Applying a service level to an existing installation

Service that is applied to the product data sets and product file systems requires that you run the z/OS System Modification Program Extended (SMP/E) utility and then the IBM Cognos installation program.

Before you begin

- Stop services
  
  If IBM Cognos BI product is running, open IBM Cognos Configuration and stop the IBM Cognos service.
- Back up the content store database.
- Back up any customized files from the current installation.
About this task

The SMP/E program is used to install the updater data sets and provide the product files system for the IBM Cognos installation program. A set of scripts are used as part of the post-installation process to install changes to target file system changes that are required as a consequence of product-maintenance.

After you apply service to an existing installation, you cannot uninstall it. To remove the maintenance fixes that are in an updater installation, you must uninstall the base product.

Procedure

1. To install the updater files, run the required SMP/E installation jobs.
2. To customize the installation, generate and modify the response file for the IBM Cognos updater installation program.
3. Run the IBM Cognos installer using the modified response file.

Completing post-installation tasks after applying a new service level

Post installation tasks are required after applying a new service level.

Procedure

1. To return a deployed IBM Cognos Business Intelligence product to operation, open IBM Cognos Configuration, save the configuration, and then start the IBM Cognos service.
2. If IBM Cognos BI applications are running in WebSphere Application Server, redeploy them to the application server.
Appendix A. Accessibility features

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products.

See the IBM Accessibility Center for more information about the commitment that IBM has to accessibility.

The IBM Accessibility Center is available online at [http://www.ibm.com/able](http://www.ibm.com/able).

Keyboard shortcuts for the IBM Cognos installation wizard

The IBM Cognos installation wizard provides keyboard shortcuts, or shortcut keys.

The installation wizard uses standard Microsoft Windows operating system navigation keys in addition to application-specific keys.

**Note:** The following keyboard shortcuts are based on US standard keyboards.

The following table lists the keyboard shortcuts that you can use to perform some of the main tasks in the installation wizard on the Windows operating system.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next field on a page</td>
<td>Tab</td>
</tr>
<tr>
<td>Return to the previous field on a page</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Close the installation wizard</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Move to the next configuration step</td>
<td>Alt+N</td>
</tr>
<tr>
<td>Return to the previous configuration step</td>
<td>Alt+B</td>
</tr>
<tr>
<td>Move to the next selection in a list</td>
<td>Down arrow</td>
</tr>
<tr>
<td>Move to the previous selection in a list</td>
<td>Up arrow</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts you can use to perform some of the main tasks in the License Agreement page of the installation wizard.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept the license agreement</td>
<td>Alt+A</td>
</tr>
<tr>
<td>Decline the license agreement</td>
<td>Alt+D</td>
</tr>
<tr>
<td>Quit the installation wizard</td>
<td>Alt+x</td>
</tr>
</tbody>
</table>

Keyboard shortcuts for IBM Cognos Configuration

IBM Cognos Configuration provides keyboard shortcuts, or shortcut keys.
The following table lists the keyboard shortcuts that you can use to perform some of the main tasks in IBM Cognos Configuration on the Windows operating system.

**Note:** The following keyboard shortcuts are based on US standard keyboards.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save the current configuration</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Close IBM Cognos Configuration</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Rename the selected item</td>
<td>F2</td>
</tr>
<tr>
<td>Display the File menu</td>
<td>Alt+F</td>
</tr>
<tr>
<td>Display the Edit menuAlt+H</td>
<td>Alt+E</td>
</tr>
<tr>
<td>Display the View menu</td>
<td>Alt+V</td>
</tr>
<tr>
<td>Display the Actions menu</td>
<td>Alt+A</td>
</tr>
<tr>
<td>Display the Help menu</td>
<td>Alt+H</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts you can use to perform some of the main tasks in IBM Cognos Configuration on z/OS UNIX System Services.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save the current configuration</td>
<td>Tab</td>
</tr>
<tr>
<td>Close IBM Cognos Configuration</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Rename the selected item</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>
### Appendix B. IBM Cognos Configuration command-line options

Use command-line options with the configuration command to modify the behavior of IBM Cognos Configuration when it starts.

#### Table 67. Command line options and descriptions

<table>
<thead>
<tr>
<th>Option</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>-h</td>
<td>Displays commands for IBM Cognos Configuration.</td>
</tr>
<tr>
<td>-s</td>
<td>Runs IBM Cognos Configuration in silent mode.</td>
</tr>
<tr>
<td></td>
<td>Uses property values specified in the cogstartup.xml file to configure installed components and then starts all services.</td>
</tr>
<tr>
<td></td>
<td>./cogconfig.sh -s</td>
</tr>
<tr>
<td></td>
<td>cogconfig.bat -s</td>
</tr>
<tr>
<td>-stop</td>
<td>Stops all IBM Cognos services.</td>
</tr>
<tr>
<td></td>
<td>./cogconfig.sh -stop</td>
</tr>
<tr>
<td></td>
<td>cogconfig.bat -stop</td>
</tr>
<tr>
<td>-startupfile path/filename.xml</td>
<td>Runs IBM Cognos Configuration using a file other than the cogstartup.xml file in the c10_location/configuration directory.</td>
</tr>
<tr>
<td>-test</td>
<td>Uses property values specified in the cogstartup.xml file to test configuration settings.</td>
</tr>
<tr>
<td></td>
<td>./cogconfig.sh -test</td>
</tr>
<tr>
<td></td>
<td>cogconfig.bat -test</td>
</tr>
<tr>
<td>-notest</td>
<td>Starts IBM Cognos Configuration with the automatic testing tasks disabled.</td>
</tr>
<tr>
<td></td>
<td>./cogconfig.sh -notest</td>
</tr>
<tr>
<td></td>
<td>cogconfig.bat -notest</td>
</tr>
<tr>
<td></td>
<td>This option should not be used for the first time you start the product or if you are making configuration changes.</td>
</tr>
<tr>
<td>-utf8</td>
<td>Saves the configuration in UTF-8 encoding.</td>
</tr>
<tr>
<td></td>
<td>./cogconfig.sh -s -utf8</td>
</tr>
<tr>
<td></td>
<td>cogconfig.bat -s -utf8</td>
</tr>
</tbody>
</table>
Table 67. Command line options and descriptions (continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Descriptions</th>
</tr>
</thead>
</table>
| -l language ID | Runs IBM Cognos Configuration using the language specified by the language identifier.  
To run the configuration tool in silent mode using Simplified Chinese  
./cogconfig.sh -l zh-cn  
cogconfig.bat -l zh-cn |
| -e filename.xml | Exports the current configuration settings to the specified file.  
./cogconfig.sh -e filename.xml  
cogconfig.bat -e filename.xml |
| -log           | Creates a cogconfig.timestamp.log error log file in the cognos_location/logs directory.  
./cogconfig.sh -log  
cogconfig.bat -log |
| -java:{local|env} | Runs IBM Cognos Configuration on Microsoft Windows operating systems using the Java Runtime Environment version that is defined as either  
• env: environmentally using the JAVA_HOME environment variable  
• local: locally from the cli_location/bin/jre directory  
If you do not set this flag, IBM Cognos uses the JAVA_HOME environment variable setting.  
To run IBM Cognos Configuration in silent mode, using the local JVM, type the following command:  
./cogconfig.sh -s -java:local  
cogconfig.bat -s -java:local |

You can use more than one command-line option at a time. For example, you can run IBM Cognos Configuration in silent mode and send all error messages to a log file.
Appendix C. IBM Cognos BI samples

The IBM Cognos Business Intelligence samples illustrate product features and technical and business best practices. You can also use them for experimenting with and sharing report design techniques and for troubleshooting.

For examples related to different kinds of businesses, see the product blueprints at http://www.ibm.com. For information about specific installation choices and environments, see the IBM Cognos Architecture and Deployment Guide, or the Proven Practices and the IBM Cognos Implementation Roadmaps on http://www.ibm.com. For information about audit samples, see the IBM Cognos Administration and Security Guide.

Where to find the samples

The samples are included as an optional component with the product. Samples for each studio are described in the related user guide and online help. To use the samples, you must set up and configure them.

What samples exist

The samples consist of the following features:

- A database that contain all corporate data, the related sample models for query and analysis, and sample cubes, reports, queries, and query templates.
- Interactive reports that let you hover over report features to learn how the features work and why they were included

Security

You can add security to the samples using an employee list included with the product. The list is in the form of an LDIF file that can be imported into any directory server.

Restoring backup files for the samples database

Before you can use the samples, you must restore backup files for the samples database. This action recreates multilingual versions of the samples database.

Before you begin

You must have System Administrator (SYSADM) or System Control (SYSCTRL) authority to create the database, stored procedures and views.

About this task

You use the scripts that are provided to do the following tasks:

- Create a database named CGCGSDB
- Create a tablespace named GSDBTS
- Create and load the tables into the GOSALES GOSALESRT GOSALESMR GOSALESHR GOSALESDW schemas
Procedure

1. Create or use existing users with select privileges for tables in the schema.
   For example, setup for the GO Sales packages specifies a single connection object and user signon. This requires a single user named with the select privilege to tables in the GOSALES schema.

2. Ensure that no other CGCGSDB database or the GSDBTS tablespace exist in the DB2 subsystem.
   If the database or tablespace already exists, clean the database subsystem by dropping the tables. Otherwise, when creating the database or tablespace, you will encounter errors similar to the following:
   THE NAME (VERSION OR VOLUME SERIAL NUMBER) OF THE OBJECT TO BE DEFINED OR THE TARGET
   • When creating the database, you might see the following message:
     THE NAME (VERSION OR VOLUME SERIAL NUMBER) OF THE OBJECT TO BE DEFINED OR THE TARGET OF A RENAME STATEMENT IS IDENTICAL TO THE EXITING NAME (VERSION OR VOLUME SERIAL NUMBER) CGCGSDB OF THE OBJECT TYPE DATABASE.
     SQLCODE=-601, SQLSTATE=E=42710, DRIVER=3.57.9
   • When creating the tablespace, you might see the following message:
     THE NAME (VERSION OR VOLUME SERIAL NUMBER) OF THE OBJECT TO BE DEFINED OR THE TARGET OF A RENAME STATEMENT IS IDENTICAL TO THE EXITING NAME (VERSION OR VOLUME SERIAL NUMBER) CGCGSDB.GSDBTS OF THE OBJECT TYPE TABLESPACE.
     SQLCODE=-601, SQLSTATE=42710, DRIVER=3.57.91

3. Go to the c10_location/webcontent/samples/datasources/db2zos directory and extract the CGCGSDB.tar.gz file.
   For example, use the following command:
   tar -xf cogbisrvr_zos64_.tar
   Use the -o option to ensure that the ownership of the user who passed the command is used.

4. In the location where you extracted the files, go to the CGCGSDB/unix directory:
   a. Change the file access permissions on the setupGSDB.sh file to ensure that the owner has execute access.
      chmod u+x setupGSDB.sh
   b. Change the file tagging on the setupGSDB.sh file to ASCII.
      ctag -t -c ISO8859-1 setupGSDB.sh

5. Locate the clp.properties file in the DB2 subsystem where you want to install the sample database.
   For example,../usr/lpp/db2xxx_base/samples/clp.properties
   a. Add an alias named CGCSAMP to the clp.properties file
      If an alias for CGCSAMP already exists, check the following settings:
      • The server URL to ensure that it is correct
      • The server login credentials to ensure that the user has sufficient privileges
      If the connection to the database fails when running the script, go to the c10_location/logs directory and review the GOSALES_DB.log file. For example, if you see a message similar to the following, the user does not have sufficient privileges:
DSNC109I: An error occurred while establishing a new connection.
Error code: -4214
sqlstate: 28000
ERRORCODE=-4214, SQLSTATE=28000

6. In the location where you extracted the files, go to the CGCGSDB/unix/GS_SCRIPTS directory and edit the SQL script files to use the appropriate information for your environment.
   a. Open the GOSALES_SP.sql file in an editor and change the WLM value.
   b. Open the GOSALES_DB.sql file, and change the storage group name in the create database and the create tablespace statements.

7. Run the setupGSDB.sh script.

   **Note:** It might take a considerable amount of time for the script to run.

**Results**

If the script runs successfully, the CGCGSDB database and GSDBTS tablespace are created.

If the script does not run successfully, go to the c10_location/logs directory and review the GOSALES_DB.log file.

Users with **DBADM** authority can create the database, but will not be able to create stored procedure or views. Users with **DBADM** authority will see an error similar to the following in the results log that is created:

```bash
<USER> DOES NOT HAVE THE PRIVILEGE TO CREATE A VIEW WITH QUALIFICATION GOSALESDW. SQLCODE=-164, SQLSTATE=42502, DRIVER=3.57.91
```

If this error occurs, users should request that a user with **SYSADM** or **SYSCTRL** authority edit and run the GOSALES_VIEWS_SP.sql script using the following command:
```
db2 -td@ -f <location>/GOSALES_VIEWS_SP.sql > results.log
```

The "@" symbol is required and specifies the termination character of the SQL statements.

Do this if default settings are not used or if you must change the WLM setting.

---

**Sample reports for the dynamic query mode**

Sample models and reports that are optimized for the dynamic query mode are included with IBM Cognos Business Intelligence.

When installed and deployed, you can find the updated samples in the Public Folders tab in IBM Cognos Connection, in a folder named **Samples_DQ**. The updated reports were also renamed with the suffix _DQ.

The samples were modified slightly to benefit from the key improvements of the dynamic query mode. For example, reports were updated to apply a specific sorting order and to specify an aggregation mode.

To access the dynamic query mode samples, you must modify the data source connections to two sample data sources to enable JDBC connections and then import the updated samples deployment archive.
Modify the data source connections to the sample data sources

To import and then use the dynamic query sample reports, you must modify the existing data source connections to two sample relational databases to enable a JDBC connection.

For more information about setting up the IBM Cognos samples and creating data source connections, see the IBM Cognos Administration and Security Guide.

Procedure

1. In IBM Cognos Administration, click the Configuration tab and click Data Source Connections.
   
   Note: To access this area in IBM Cognos Administration, you must have the required permissions for the Administration tasks secured feature.

2. Click the great_outdoors_sales sample data source.

3. In the Actions columns, click the set properties button for the great_outdoors_sales data source connection.

4. On the Connection tab, under Connection string, click the Edit the connection string icon.

5. On the JDBC tab, select the Enable JDBC connection check box.

6. Specify the JDBC connection parameters for the data source.

7. Click Test the connection and click Test.
   
   On the results page of the connection test, notice the JDBC results under the Type / Query Mode column.

8. Repeat steps 1 to 6 with the great_outdoors_warehouse sample data source connection.

Import the dynamic query samples content (packages) into the content store

After you have modified the data source connections to the sample data sources, you must import the dynamic query samples content, or packages from the sample deployment archive.

The dynamic query samples are in the deployment archive named IBM_Cognos_Samples_DQ.zip.

For more information about setting up the IBM Cognos samples and importing content, see the IBM Cognos Administration and Security Guide.

Procedure

1. Copy the IBM_Cognos_Samples_DQ.zip file from the c10_location/webcontent/samples/content directory to the directory where your deployment archives are saved. The default location is c10_location/deployment. The location is set in the configuration tool. For information about changing the location, see the configuration tool online help.

2. In IBM Cognos Administration, click the Configuration tab and click Content Administration.
   
   Note: To access this area in IBM Cognos Administration, you must have the required permissions for the Administration tasks secured feature.
3. On the toolbar, click the **New Import** button. The **New Import** wizard appears.

4. In the **Deployment Archive** box select the archive **IBM_Cognos_Samples_DQ** and click **Next**.

5. Type a unique name and an optional description and screen tip for the deployment archive, select the folder where you want to save it, and then click **Next**.

6. In the **Public Folders Content** box, select the **Samples_DQ** folder.

7. Select the options you want, along with your conflict resolution choice for options that you select, and then click **Next**.

8. In the **Specify the general options** page, select whether to include access permissions and references to external namespaces, and who should own the entries after they are imported.

9. Click **Next**. The summary information appears.

10. Review the summary information and click **Next**.

11. Click **Save and run once**.

12. Click **Finish**, specify the time and date for the run, then click **Run**.

13. Review the run time and click **OK**.

14. When the import is submitted, click **Finish**.

**Results**

You can now use the dynamic query sample package to create reports and to run the sample reports that are available in the **Samples_DQ** folder on the **Public Folders** tab in the portal.
Appendix D. Troubleshooting a problem

Troubleshooting is a systematic approach to solving a problem. The goal of troubleshooting is to determine why something does not work as expected and how to resolve the problem.

Review the following table to help you or customer support resolve a problem.

Table 68. Troubleshooting actions and to fix problems

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply all known fix packs, or service levels, or program temporary fixes (PTF).</td>
<td>A product fix might be available to fix the problem.</td>
</tr>
<tr>
<td>Ensure that the configuration is supported.</td>
<td>Review the supported software environments web page.</td>
</tr>
<tr>
<td>Look up error message codes by selecting the product from the IBM Support Portal and then typing the error message code into the Search support box on the right vertical menu bar.</td>
<td>Error messages give important information to help you identify the component that is causing the problem.</td>
</tr>
<tr>
<td>Reproduce the problem to ensure that it is not just a simple error.</td>
<td>If samples are available with the product, you might try to reproduce the problem by using the sample data.</td>
</tr>
<tr>
<td>Check the installation directory structure and file permissions.</td>
<td>The installation location must contain the appropriate file structure and the file permissions. For example, if the product requires write access to log files, ensure that the directory has the correct permission.</td>
</tr>
<tr>
<td>Review relevant documentation, including release notes, technotes, and proven practices documentation.</td>
<td>Search the IBM knowledge bases to determine whether your problem is known, has a workaround, or if it is already resolved and documented.</td>
</tr>
<tr>
<td>Review recent changes in your computing environment.</td>
<td>Sometimes installing new software might cause compatibility issues.</td>
</tr>
</tbody>
</table>

If the items on the checklist did not guide you to a resolution, you might need to collect diagnostic data. This data is necessary for an IBM technical-support representative to effectively troubleshoot and assist you in resolving the problem. You can also collect diagnostic data and analyze it yourself.

Troubleshooting resources

Troubleshooting resources are sources of information that can help you resolve a problem that you are having with a Cognos product. Many of the resource links provided in this section can also be viewed in a short video demonstration.

To view the video version, search for "Cognos troubleshooting" through either Google search engine or YouTube video community.
Support Portal

The IBM Support Portal is a unified, centralized view of all technical support tools and information for all IBM systems, software, and services.

The IBM Support Portal lets you access all the IBM support resources from one place. You can tailor the pages to focus on the information and resources that you need for problem prevention and faster problem resolution. Familiarize yourself with the IBM Support Portal by viewing the demo videos.

Find the Cognos content that you need by selecting your products from the IBM Support Portal.

Searching and navigating Cognos products

Access to IBM Cognos product information can now be configured in the IBM Support Portal, which provides the ability to see all of your links on a single page.

Best practices for searching and navigating for Cognos product information are available on the IBM Cognos Support Portal and Technote Search Best Practices page.

Gathering information

Before contacting IBM Support, you will need to collect diagnostic data (system information, symptoms, log files, traces, and so on) that is required to resolve a problem. Gathering this information will help to familiarize you with the troubleshooting process and save you time.

Information on what data to collect is available in the form of MustGather technotes.

Service requests

Service requests are also known as Problem Management Reports (PMRs). Several methods exist to submit diagnostic information to IBM Software Technical Support.

To open a PMR or to exchange information with technical support, view the IBM Software Support Exchanging information with Technical Support page. PMRs can also be submitted directly by using the Service requests (PMRs) tool or one of the other supported methods detailed on the exchanging information page.

Problem determination tools

Several IBM Cognos problem determination tools are available to diagnose and troubleshoot common problems.

These tools can be downloaded from the Cognos Diagnostic Utilities page. IBM Education Assistant provides video and other training resources on some of these diagnostic tools on the IBM Education Assistant Problem Determination website.

Cognos Customer Center

The IBM Cognos Customer Center provides Cognos-specific information, updates, and troubleshooting resources.

To view Cognos troubleshooting information, access the Cognos Customer Center and view the information under "Contacting Support" or "Troubleshooting Resources".
Products and maintenance through Shop zSeries

You can use the Shop zSeries web site to order mainframe products and maintenance (also known as program temporary fixes or PTFs). The primary product fulfillment mechanism is physical media, but electronic CBPDOs (Custom-Built Product Delivery Offerings) are available.

For more information about ordering products and maintenance, and how to register, see the Ordering Products and Maintenance through Shop zSeries technote.

Knowledge bases

You can find solutions to problems by searching IBM knowledge bases.

You can use the IBM masthead search by typing your search string into the Search field at the top of any ibm.com page.

Cognos Information Centers

IBM Cognos Information Centers include documentation for each release. This documentation is also available through product help menus.

Cognos Information Centers, including translated documentation, are available at IBM Cognos Business Intelligence and Performance Management.

To find links to the latest known problems and APARs, access the Release Notes available in each Information Center.

IBM Redbooks

IBM Redbooks® are developed and published by IBM's International Technical Support Organization, the ITSO.

IBM Redbooks provide in-depth guidance about such topics as installation and configuration and solution implementation.

Proven Practices documentation

Created by Cognos experts from customer experiences, Cognos Proven Practices provides verified technical information in specific technology environments.

As a troubleshooting resource, Proven Practices provides easy access to the top ten most popular practices for Business Intelligence and Financial Performance Management, in addition to videos and other information: Cognos Proven Practice documentation.

Software support and RSS feeds

IBM Software Support RSS feeds are a quick, easy, and lightweight format for monitoring new content added to websites.

After you download an RSS reader or browser plug-in, you can subscribe to IBM product feeds at IBM Software Support RSS feeds.

Forums and communities

IBM Cognos product forums offer a place to share ideas and solutions with your peers in the IBM Cognos community.

Active Cognos forums are available at Cognos forums and communities.
Log files

Log files can help you troubleshoot problems by recording the activities that take place when you work with a product.

Operations performed in the product are recorded in various log files for tracking purposes. For example, if you experienced problems installing, consult the transfer log file to learn what activities the installation wizard performed while transferring files.

Before you begin viewing log files, ensure that they contain the information that you need. The number of log files and the information they contain are set by parameters in IBM Cognos Connection and in IBM Cognos Configuration.

Use IBM Cognos Administration to learn about logging categories and how to set the level of detail to log for each category.

The transfer log file

This file records the activities that the installation wizard performed while transferring files. The transfer log file is located in the $c10_location/instlog$ directory. The file name identifies the product name, version, and build number, and includes a time stamp. The following is an example of the file name format:

tl-BISRVR-10.2-0.0-20120901_1122.txt

The transfer summary-error log file

This file records the components you installed, disk space information, the selections you made in the transfer dialogs, and any errors the installation program encountered while transferring components. The transfer summary-error log file is located in the $c10_location/instlog$ directory. The file name identifies the product name, version, and build number, and includes a time stamp. The following is an example of the file name format:

tl-CBISRVR-10.2-0.0-20120901_1122_summary_error.txt

The startup configuration file

This file records your configuration choices each time you save your property settings. The file name is cogstartup.xml. If you are unable to save your configuration or are having other problems with the file, you can revert to a previously saved configuration file. The backup configuration files are located in the $c10_location/configuration$ directory. The following is an example of the file name format for backup configuration files:

cogstartup_201211231540.xml

The startup configuration lock file

This file is created each time you open IBM Cognos Configuration. It prevents you from opening more than one IBM Cognos Configuration window. If you experience problems opening IBM Cognos Configuration, you can check the $c10_location/configuration$ directory for the cogstartup.lock file. If the file exists and IBM Cognos Configuration is not open, it means that IBM Cognos Configuration did not shut down properly the last time you used it. You can delete
the lock file and then open IBM Cognos Configuration.

**The locale configuration file**

This file records the configuration choices you make in IBM Cognos Configuration for product and content locales, locale mapping, and currency support. If you experience problems with language support in the user interface or in reports, use these files to track your changes. The backup configuration files are located in the `c10_location/configuration` directory. The following is an example of the file name format:

```
coglocale_201211231540.xml
```

**The runtime log file (cogserver.log)**

The default IBM Cognos log file named cogserver.log file, or other log files that you configure to receive log messages from the log server, record information after you start the IBM Cognos service. They are located in the `c10_location/logs` directory. If you configured another destination for log messages, check the appropriate file or database.

Some log messages indicate problems. Most messages provide information only, but others can help you to diagnose problems in your runtime environment.

**The gateway log file**

Gateway errors are recorded in the gateway log file, which is located in the `c10_location/logs` directory. You can use the gateway log file to troubleshoot problems that prevent the gateway from processing requests or from using encryption. Symptoms of these problems are user IDs and passwords do not work, single signon does not work, and the dispatcher is running but users receive the following error message:

The IBM Cognos BI server is not available.

The gateway log file uses the following naming format, where gateway_interface is `cgi`,

```
gwcgi.log
```

**The uninstallation log file**

This file records the activities that the uninstallation program performed while uninstalling files. The log file is named `cognos_uninst_log.htm` and is located in the `Temp` directory. You can use the log file to troubleshoot problems related to uninstalling IBM Cognos components.

**Core dump files**

If you receive an error message about the report server not responding, IBM Cognos wrote a core dump (.dmp) file to the file system. Core dump files indicate a serious problem with the program, such as an unhandled exception or an IBM Cognos process that terminated abnormally. Core dump files create a complete memory dump of the current state of the program when the problem occurs. The core file usually indicates a bug that requires a software fix.
If you see the report server not responding message, immediately check the c10_location/bin directory of the IBM Cognos server installation for any core dump files.

In Windows, these files are named processID.dmp, such as BIBusTKServerMain seh_3524_3208.dmp. In z/OS UNIX, the files are named core. These binary files must be viewed with a debugging program.

If your server administrator cannot solve the problem, contact IBM Cognos Resource Center and provide them with a test case, if possible, and the core files. Core files can be 300 MB or more, and a new one of the same size is created each time that the problem occurs.

**Running database and index cleanup scripts**

In some troubleshooting situations, you might be advised to start with new configuration data. You can run SQL scripts to delete all the tables in any of the databases that IBM Cognos Business Intelligence components use. When you delete a table, its structural definition and data are deleted permanently from the database.

You can delete tables in the following databases by using SQL scripts:

- Content store
- Delivery database for report notifications
- Human tasks
- Annotations

You can run SQL scripts to delete all the tables and indexes in the logging database for log messages.

**Procedure**

1. On each location where Content Manager is installed, stop the IBM Cognos service.
2. Go to the appropriate directory:
   - To delete tables and indexes from the logging database, go to c10_location/configuration/schemas/logging directory.
   - To delete tables from the content store, go to c10_location/configuration/schemas/content directory.
   - To delete tables from the notification database, go to c10_location/configuration/schemas/delivery directory.
   - To delete tables from the human task database, go to c10_location/configuration/schemas/hts directory.
   - To delete tables from the annotations database, go to c10_location/configuration/schemas/ans directory.
3. Go to the appropriate database directory.
4. Run the following scripts to delete the tables.

The following table lists the script names for each database.

<table>
<thead>
<tr>
<th>Database</th>
<th>Script name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Content store</td>
<td>dbClean_db2zOS.sql</td>
</tr>
</tbody>
</table>
5. Start the IBM Cognos service.
   A new set of required database tables and indexes are created automatically.

### Console messages

Installation messages for IBM Cognos Business Intelligence for z/OS are an important troubleshooting tool.

The following topics provide descriptions of the messages that are issued by the product during installation, with explanations and suggested user responses.

#### How to interpret message numbers

The product issues messages to communicate system status and processing results. Messages are identifiable by unique message numbers. The format of a message number can help you understand what the message applies to and, in some cases, its severity.

Messages are identifiable by unique message numbers, which are eight to ten characters long. Message identifiers have the following format:

CGC0001I

- **CGC** The first three characters are CGC, which is the IBM Cognos component prefix
- **209** The numeric identifier is three to five characters long and begins at the fourth character in the message. The numeric identifier is unique within the subcomponent
- **I** The last character of the message identifier is the message type code.

The following table describes the message codes.

<table>
<thead>
<tr>
<th>Message type code</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>E</td>
<td>Action is required immediately. An error occurred. The associated task does not continue until the requested action is taken.</td>
</tr>
<tr>
<td>W</td>
<td>Action might be required immediately or in the future. A warning message. Usually the associated task completes but possible problems were detected.</td>
</tr>
<tr>
<td>I</td>
<td>No action is required. The message is informational only.</td>
</tr>
</tbody>
</table>

---

**Table 70. IBM Cognos message type codes**
Character set limitations for messages in the z/OS system console

A limited set of characters can be displayed on the z/OS system console. For example, alphabetic characters containing diacritics, such as umlauts, display as a space or blank.

IBM Cognos log messages

Messages in the IBM Cognos log files are not affected because multiple languages are supported. The messages are written in the language specified by the server locale setting. The server locale is determined by the language that is specified at the time of installation in the `response.ats` file. You can change the server locale setting after installation in IBM Cognos Configuration (Actions > Edit Global Configuration).

Console messages

The z/OS system console displays messages in English only. If the language specified by the server locale setting is non-English, the system displays the corresponding English text.

CGC0001I
DPR-SYS-6000 The product is ready to use.

Explanation
The services started successfully and the product is ready to accept requests.

User Response
No action is required.

CGC0002I
DPR-SYS-6001 The product is shutting down.

Explanation
The services are shutting down and this can take a few minutes. Requests can no longer be processed.

User Response
No action is required.

CGC0003E
CAM-AAA-0044 The call to ldap_init failed. Check the following parameters: %1 and %2.

Explanation
The LDAP server used to authenticate users could not be reached and requests cannot be processed.
User Response
In the configuration tool, verify that the LDAP host name and port is correct and is specified using the host:port syntax. For the host name, use the IP address or the fully qualified name for your computer.

CGC0004E
CM-SYS-5003 Content Manager is unable to access the content store. Verify your database connection parameters, and then contact your database administrator for assistance.

Explanation
Content Manager is unable to connect to the content store.

User Response
Check that the database server is running. Verify that the database connection properties in the configuration tool are correct and that when you test the connection, the test is successful.

CGC0005I
CM-SYS-5090 Content Manager %1 started %2.

Explanation
This messages lists the build and schema versions of the Content Manager component that is starting.

User Response
No action is required

CGC0006I
CM-SYS-5094 Content Manager stopped.

Explanation
This messages lists the build and schema versions of the Content Manager component that is shutting down.

User Response
No action is required.

CGC0007I
DPR-DPR-1002 Successfully registered the %1 in Content Manager.

Explanation
When a local or remote dispatcher starts, it registers with Content Manager.
User Response

No action is required.

CGC0008I

CM-SYS-5159 Content Manager is running in active mode.

Explanation

This is the active Content Manager and will process requests. Any other Content Manager components that are running will be in standby mode.

User Response

No action is required.

CGC0009I

CM-SYS-5160 Content Manager is running in standby mode. The active Content Manager URL is %1.

Explanation

This Content Manager is in standby mode and will not process requests unless the active Content Manager becomes unavailable.

User Response

No action is required.

CGC0010E

RSVP-SRV-0040 An application error has occurred. Contact your Administrator.

Explanation

The report server encountered an internal error.

User Response

Check if the error produces core files in the product bin directory or CEEDUMP files. If possible, increase the logging level in the IBM Cognos administration tool and reproduce the conditions that caused the error.

CGC0011E

DPR-ERR-2077 The request failed because the associated report service process with pid %1 is unavailable.

Explanation

This can occur for the following reasons.

• A report includes a graph object that uses a query that has the processing set to database only.
• The application pool is configured incorrectly.
• An incorrect setting for the number of report or batch processes is set in IBM Cognos Configuration
• There are connection errors for the dispatcher

**User Response**

Ensure that all services, fixes, or updates have been applied to the product. Check the status of the report service in the administration user interface to determine if the service is available. Check the status of the BIBusTKServerMain processes. For additional information, check the product logs in the log directory, and the dump files in the bin directory.

**CGC0012E**

RSV-DST-0014 An error occurred. See the run history details for more information.

**Explanation**

Unable to finish running the scheduled report. The report server cannot update the execution status of the report.

**User Response**

Ensure that the event and delivery service is started. Ensure that the user account has full access permissions for the installation. If using WebSphere Application Server, this group must contain the user that starts the application server and the user that owns the IBM Cognos files. For simplicity, you can also use the application server user account to install and run IBM Cognos components.

**CGC0013E**

CNC-DS-0031 Cannot find the alias with the search path %1

**Explanation**

The report cannot be saved or scheduled because there is a problem with the access permissions for the entry. Access permissions specify the users who have access to entries such as reports. Trusted credentials can be used to authorize other users to use your credentials when those users do not have sufficient access permissions to perform specific tasks.

**User Response**

Check the ownership of the report, and ensure that the user account has sufficient access permissions to perform the task.

**CGC0014E**

CM-REQ-4158 The search path %1 is invalid.

**Explanation**

There is an issue accessing an object in Content Manager. The object might contain invalid syntax, or an unsupported character, or the user account in the namespace might not have sufficient privileges.
**User Response**

Ensure that groups and users in the namespace have sufficient privileges to traverse the directory entry. Check the syntax of the object to ensure that it is correct.

**CGC0015E**

CM-REQ-4098 The syntax of the search path is incorrect. The search path predicate is invalid because the closing square bracket (]) character is missing.

**Explanation**

There is an issue accessing an object in Content Manager. The object might contain invalid syntax or an unsupported character. For example, if there is an umlaut character (ä, ö, ü) or Asian character in the path to the folder of the object, you might see this error.

**User Response**

Check the object to ensure that the target destination location does not contain special characters.

**CGC0016E**

UDA-SQL-0031 Unable to access the %1 database.

**Explanation**

The product is unable to connect to the data source.

**User Response**

Check that the connection parameters to the database are configured correctly. For example, ensure that the data source connection contains the signon information, such as a password, to connect to the database. Ensure that the database is available.

**CGC0017E**

UDA-SQL-0107 A general exception has occurred during the operation %1.

**Explanation**

An unspecified error occurred during an SQL operation.

**User Response**

Check the log files to identify the report that caused the error. In the log files, check for error codes that provide more specific information about the problem.

**CGC0018E**

QFS-ERR-0139 The request has multiple errors.
Explanation
A problem occurred with a report query. There might be errors in the prompt or drill definition.

User Response
Check the log files to determine the report that caused the error. In the log files, check for error codes that provide more specific information about the problem. Fix the prompt or drill definitions in the report. For example, remove any trailing spaces in the prompt name.

CGC0019E
RQP-DEF-0354 The query contains one or more unresolved prompts.

Explanation
A report ran without an expected prompt value being defined. This error can occur after upgrading.

User Response
Check the prompt definition for the report. Run the report in Cognos Report Studio to reproduce the error and check the syntax and definition of each prompt.

CGC0020E
RQP-DEF-0177 An error occurred while performing operation %1 %2.

Explanation
An error occurred executing an SQL operation. The error codes and function listed in the error are internal to the product.

User Response
Examine the queries in the report that caused the error.

CGC0021E
UDA-SQL-0114 The cursor supplied to the operation %1 is inactive.

Explanation
The database object used by the product to manipulate data did not return any results.

User Response
Check that there is sufficient temp space for the database to perform the query and that the database server has enough memory to dump temporary files.

CGC0022E
CAM-AAA-0134 Unable to retrieve information for the user %1.
Explanation

The user is successfully authenticated, but the requested object cannot be found.

User Response

Check the authentication provider for the information requested. Verify the mappings for groups, folder and user entries, and verify that the user has sufficient permissions.

CGC0023E
CAM-AAA-0048 Unable to retrieve the CAMID for the object %1.

Explanation

The user is successfully authenticated, but the CAMID of the object cannot be found. The CAMID is an internal representation of the object, and is constructed by the authentication provider for each object that is retrieved by the external provider. The CAMID of objects in the user identity is compared to the permissions that are assigned to the object. If the permissions match, the privileges are granted or denied.

User Response

Check the authentication provider for the information requested. For example, check whether the bind user has sufficient access to browse the complete directory, or that the BaseDN is configured at the correct level.

CGC0024E
RQP-DEF-0182 The queries for the set operation are incompatible.

Explanation

This occurs when the results of two queries are joined together by a UNION command and their types are incompatible. Because the UNION command combines the results of two queries, the source queries are matched column for column to produce a single result. If the data types in the columns do not match, the merged result cannot be created. For example, if the first query contains "Date" data in the first column and the second query contains "Character" data in the first column then there is no way to merge these. There is no way to preserve both the character and date data types in the first column of the result.

User Response

Examine the queries in the report that caused the error and ensure that the queries are suitable to be joined together.

CGC0025E
CAM-AAA-0022 The provider %1 could not load.

Explanation

The authentication component cannot find a library file that it requires.
User Response

Check that the shared library file is in the installation_location/bin directory and that the user account doing the installation belongs to a group that has the appropriate permissions to load the file. If the library file is in a location outside of installation_location/bin, ensure that the path exists in the LIBPATH environment variable.

CGC0026E

CAM-AAA-0145 There is no namespace that is properly configured for authentication.

Explanation

Anonymous access is disabled. However, either an authentication provider is not configured or there are errors in the configuration. The product cannot run without an authentication provider when anonymous access is disabled.

User Response

Ensure that a namespace is configured for the authentication provider in the configuration tool. Check and test the connection for syntax or other errors.

CGC0027E

CM-SYS-5173 Content Manager failed while processing a database transaction because of a database deadlock.

Explanation

Content Manager cannot access one of the content store database tables because another database transaction has locked the same table. This can happen when another Content Manager process or an external program is accessing the content store database.

User Response

Check for any scripts that are running, such as a Content Manager clean up script or IBM Cognos Software Development Kit scripts, that might result in a heavy volume of updates to the content store. Check with the database administrator about other programs that might be updating the database.

CGC0028E

CM-CFG-5051 Content Manager failed to initialize the cache subsystem.

Explanation

Content Manager maintains a cache for IBM Cognos objects, and that cache did not initialize. The product cannot run.

User Response

If you use a content store database that requires JDBC driver files, check that the driver files and any required license files are copied to the IBM Cognos installation.
location (webapps/p2pd/web-inf/lib directory). Ensure that the content store database is configured and available.

CGC0029E
DPR-ERR-2074 The Report Server with pid %1 is not responding.

Explanation
The report server might not respond when a connection to it closes prematurely and causes it to shut down.

User Response
Check the status of the report service and the BIBusTKServerMain processes in the system administration interface of the product for additional information about the error condition.

CGC0030E
CM-SYS-5149 Content Manager is unable to process your request because a data error occurred in the content store database subsystem.

Explanation
Content Manager data is stored in a number of fields in content store database tables. Each field has a maximum length. An attempt was made to read or write to a field with data but the data length is too long. The data type can also vary. The error can occur when executing a report or when importing a deployment.

User Response
Try to determine the report or action that triggered the error by checking log files in the ./logs directory.

CGC0031E
DPR-ERR-2072 The request failed. It was directed to a server that is not reachable.

Explanation
The dispatcher settings might not match or be compatible with the other components in the installation.

User Response
Ensure that all of the components share the same version and maintenance level. Also check that the CAF (Cognos Application Firewall) settings are consistent for all installed components. For security reasons, the Cognos Application Firewall should be enabled in IBM Cognos Configuration for all server components.

CGC0033E
CM-SYS-5195 Content Manager cannot configure the content store database. Review the content store database configuration in IBM Cognos Configuration.
**Explanation**

The product cannot access the database to configure it to use as a content store.

**User Response**

Review and test the configuration for the content store database in the configuration tool to ensure that the settings are valid. Verify that the account used to access the content store is still valid by checking the status of password and account permissions.

**CGC0034E**

CM-CFG-5023 Content Manager is unable to initialize the content store by using the initialization file %1.

**Explanation**

The SQL script that is causing the error is responsible for creating the content store database for the first time or for upgrading the existing content store database. The error occurs because the script can not be executed.

**User Response**

Review the configuration for the content store database in IBM Cognos Configuration to ensure that the settings are correct. Verify that the account used to access the content store is still valid by checking the status of the password and account permissions. Verify that the account that Content Manager uses has sufficient permissions to create, to connect to, and to initialize the file contents in the database.

**CGC0035E**

DPR-ERR-2068 The administration request failed. Cannot connect to dispatcher.

**Explanation**

The dispatcher might be offline.

**User Response**

Check that the dispatcher is available on the network by copying the external dispatcher URL from the configuration tool to a web browser and reviewing the result. Check that the dispatcher is available on the network in the product system administration interface. If the dispatcher is running but there is a connectivity problem, check the status of the dispatcher port by using netstat or other network diagnostics tools.

**CGC0036E**

CCL-BIT-0006 The HTTP message is unexpectedly short.

**Explanation**

On a heavily loaded system, some connections might terminate before IBM Cognos Business Intelligence finishes processing a request. When the connection closes...
before the request is processed, the request is lost and the user must resubmit the request.

**User Response**

If you are using WebSphere Application Server, to reduce the frequency of this error, increase the **Persistent Timeout** parameter for the web container transport chains in the WebSphere administrative console. Increase the time in 10-15 second intervals until the error no longer or rarely occurs.

**CGC0037E**

DPR-BUS-1500 %1 with pid %2 was started with stderr %3

**Explanation**

%1 represents the process name and %2 represents the process ID (PID). The System Management Facility (SMF) collects the system resource usage data (IFAUSAGE) for an application. When the IBM Cognos product starts a new process, for example BiBusTKServerMain, the process registers itself to enable usage tracking. If the registration fails, the message displays.

**User Response**

The action required depends on the error code that is reported.

Error codes 8, 12, or 20 represent an internal error and should be reported to IBM Cognos.

Error code 16 indicates that IFAUSAGE is not enabled on this system. You can choose not to use IFAUSAGE, otherwise, you must enable it on your system.

Error code 4 can occur under a number of failure conditions. Check with your z/OS administrator to ensure that the installation is configured to collect type 89 records. If it is configured, the error might be due to an internal error and should be reported to IBM Cognos.

---

**Problems starting the product**

You might encounter problems when trying to start the services or opening the IBM Cognos portal for the first time.

The following table shows some common symptoms and their solutions.

<table>
<thead>
<tr>
<th>Symptoms</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>You do not see the splash screen for the IBM Cognos BI portal when you start IBM Cognos BI.</td>
<td>Check your web server configuration.</td>
</tr>
<tr>
<td>The service starts, but no tables are created in the content store database.</td>
<td>Check your content store configuration.</td>
</tr>
<tr>
<td>The service does not start.</td>
<td>After you start the service, ensure that you wait a few moments before submitting a request.</td>
</tr>
</tbody>
</table>
### Symptoms

<table>
<thead>
<tr>
<th>Symptoms</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>The application server does not start.</td>
<td>Check the file permissions and directory names of the application server installation location.</td>
</tr>
<tr>
<td>The authentication provider does not start.</td>
<td>Some authentication providers require libraries external to the IBM Cognos environment to be available. If these libraries are not available on the z/OS system, the authentication provider cannot be initialized.</td>
</tr>
</tbody>
</table>

Ensure that you use other software that is supported by IBM Cognos components.

### Setting the JDBC environment variables for a DB2 content store

IBM Cognos Business Intelligence for z/OS uses JDBC connectivity to communicate with the content store. You must set up the appropriate environment variables to enable the classes used by the JDBC driver.

#### About this task

To avoid having to reenter the environment variables each time you log on, you can set the environment variables in the cognos installation user .profile file.

In the examples below, **DB2_BASE** is used. The value of **DB2_BASE** is the highest-level directory in the set of HFS directories that contain DB2 for z/OS code. For example: 

```
DB2_BASE=/usr/lpp/db2/db2910_base
```

The default is `/usr/lpp/db2910_base`.

#### Procedure

1. Logged on as the Cognos installation user, use the following example to add entries to the .profile script:

```
#-Set JDBC_HOME to HFS directory for DB2 JDBC driver
export JDBC_HOME=/usr/lpp/db2910_jdbc
#
#-Classpath for DB2 JDBC
export JDBCCLASSES=${JDBCHOME}/classes
export CLASSPATH=${CLASSPATH}:${JDBCHOME}/db2jcc_javax.jar
export CLASSPATH=${CLASSPATH}:${JDBCHOME}/db2jcc4.jar
export CLASSPATH=${CLASSPATH}:${JDBCHOME}/db2jcc_license_cisuz.jar
export CLASSPATH=${CLASSPATH}:${JDBCHOME}/sqlj4.zip
#
#-Add DB2 JDBC to Path
export PATH=${JDBCHOME}/bin:${PATH}
#
#-Add DB2 JDBC to Libpath
export LIBPATH=${JDBCHOME}/lib:${LIBPATH}
#
#-Add DB2 JDBC to Steplib
export STEPLIB=SYS1.DB1I.SDSNLOAD:SYS1.DB1I.TESTLIB:SYS1.DB1I.SDSNEXIT
```

Appends D. Troubleshooting a problem 211
2. Set the JDBCHOME environment variable to point to the location of the JDBC driver that might already be installed with DB2 on your system.

The location of the installation is typically under the HFS directory, such as /usr/lpp/db2910_jdbc. For example, for DB2 version 9.1, the JDBC driver is in the following location.

```bash
export JDBCHOME=/usr/lpp/db2910_jdbc
```

For DB2 version 8.1, the JDBC driver is in the following location.

```bash
export JDBCHOME=/usr/lpp/db2/db2810/jcc
```

3. Set the JDBCCLASSES environment variable to point to the location of the required files for the JDBC universal driver.

The following files are required:

- db2jcc.jar
- db2jcc_license_cisuz.jar
- db2jcc_javax.jar
- sqlj.zip

The following command sets the JDBCCLASSES environment variable to point to the `$(JDBCHOME)/classes` directory.

```bash
export JDBCCLASSES=$(JDBCHOME)/classes
```

4. Modify the CLASSPATH to ensure that the Java compiler and the JVM know where to look for the Java class files for the JDBC driver.

```bash
export CLASSPATH=$CLASSPATH:${JDBCCLASSES}/db2jcc_javax.jar
export CLASSPATH=$CLASSPATH:${JDBCCLASSES}/db2jcc4.jar
export CLASSPATH=$CLASSPATH:${JDBCCLASSES}/db2jcc_license_cisuz.jar
export CLASSPATH=$CLASSPATH:${JDBCCLASSES}/sqlj4.zip
```

5. Add the JDBC drivers for DB2 to the PATH variable.

```bash
export PATH=${JDBCHOME}/bin:${PATH}
```

6. Modify the LIBPATH to include the libraries the JDBC driver needs.

For example,

```bash
export LIBPATH=${JDBCHOME}/lib:${LIBPATH}
```

---

**IBM Cognos BI service does not start or fails after starting**

You start the IBM Cognos BI service but services either do not start correctly or are very slow to start.

**About this task**

After services start, the system fails a short time afterwards. While services are starting, Java uses 100 percent of the CPU time. You might also receive multiple occurrences of error messages such as the following:

- DPR-DPR-1035 Dispatcher detected an error.
- CAM-CRP-1157 Unable to synchronize the local common symmetric keystore with Content Manager.

If you use a DB2 database for the content store, ensure that the database version and Java version are compatible.

To review an up-to-date list of environments supported by IBM Cognos products, such as operating systems, patches, browsers, Web servers, directory servers, database servers, and application servers, visit the IBM Cognos Customer Center [http://www.ibm.com/software/data/cognos/customercenter/](http://www.ibm.com/software/data/cognos/customercenter/).
Unable to Start the IBM Cognos service because the port is used by another process

You might not be able to start the IBM Cognos service or process if one of the default ports is used by another process.

About this task

When you change the port used by the local dispatcher, you must change the value of the Dispatcher URI properties. Because the change affects all the URIs that are based on the local dispatcher, you must change the URIs of all local components. By default, local components contain localhost in the URI.

For example, if you install all components in one location and you want to change the dispatcher port, you must replace 9300 in all of the dispatcher and Content Manager URIs with the new port number.

Procedure

1. Start IBM Cognos Configuration.
2. In the Explorer panel, click the appropriate group or component:

<table>
<thead>
<tr>
<th>Port setting (URI)</th>
<th>Navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dispatcher URI</td>
<td>Environment</td>
</tr>
<tr>
<td>Content Manager URI</td>
<td>Environment</td>
</tr>
<tr>
<td>local log server</td>
<td>Environment &gt; Logging</td>
</tr>
<tr>
<td>Tomcat shutdown port number</td>
<td>Environment &gt; IBM Cognos services &gt; IBM Cognos</td>
</tr>
<tr>
<td>Portal Services</td>
<td>Environment &gt; Portal Services</td>
</tr>
</tbody>
</table>

3. In the Properties panel, click the Value box next to the property that you want to change and change the value from current value to the new value.

Ensure that you change the ports in all URIs that contain localhost:port

4. Click File > Save.
5. Click Actions > Start.

Content Manager error when starting IBM Cognos services

After starting IBM Cognos BI, no BIBUSTKSERVMA process is started. There are errors listed in the pogo******.log and cogserver.log files. Users receive errors in the web browser when connecting to the IBM Cognos portal.

In the pogo******.log file, an error related to Content Manager displays.

In the cogserver.log file, the following error displays:

An attempt to register the dispatcher in Content Manager was unsuccessful
Will retry periodically.

The following error messages display in the browser:

DPR-ERR-2058 The dispatcher cannot service the request at this time.
The dispatcher is still initializing.
SoapSocketException: Connection Refused.
IBM Cognos Configuration uses a user ID to bind to the LDAP database. If this user ID is moved to another group, IBM Cognos Configuration can no longer locate it.

To correct the problem, move the user ID back to the original group.

**DPR-ERR-2014 error displays in log file in Content Manager installation**

The cogserver.log file might show a DPR-ERR-2014 error if the event management service is disabled.

If Content Manager is installed in a separate location and the event management service in the Content Manager installation is disabled, the following error message can occur in the cogserver.log file:

DPR-ERR-2014 Unable to load balance the request because no
nodes in the cluster are available,
or no nodes are configured for the service:
eventManagementService

To correct the problem, use IBM Cognos Configuration to set the Event management services enabled property to False in the Content Manager installation.

**IBM Cognos Report Studio does not start**

You might not be able to start Cognos Report Studio if you are using pop-up blocking software on your computer.

When you start Cognos Report Studio, it opens in a new browser window. In addition, a new browser window opens when you run a report and when an error is detected.

To correct the problem, disable any pop-up blocking software when working in Report Studio.

**DPR-ERR-2022 error displays in web browser when opening the IBM Cognos portal page**

After you start the services in IBM Cognos Configuration and then try to open the portal, an error message displays.

The following error message displays when you open the IBM Cognos portal page too soon, or if there are errors in the system.xml file.

DPR-ERR-2022 No response generated.
This may be due to an incorrect configuration, a damaged installation,
or the dispatcher not having finished initializing

To avoid this problem, after you start the services in IBM Cognos Configuration and the configuration tool shows that the services are running, wait a few minutes for all services to start before you open the portal.

The system.xml file might have been edited for custom configuration options, replace the system.xml file in the c10_location/templates/ps/portal directory with the original or backup copy, or use an XML editor to fix the error.
Problems configuring the product

After you install IBM Cognos components, you might encounter problems when you save changes in IBM Cognos Configuration.

Ensure that you configure and start the services in the Content Manager installation before you configure and start the services in other locations. You must also restart the IBM Cognos services after you make any configuration changes.

Error trying to encrypt information when saving the configuration

When you save your configuration using the configuration tool, you might see an error message indicating that the cryptographic information cannot be encrypted.

If an error occurs when requesting a certificate from the Certificate Authority, you might see the following error message.

The cryptographic information cannot be encrypted.

Do you want to save the configuration in plain text?

Before you can encrypt configuration settings, Content Manager must be configured and running. Ensure that you copied the appropriate .jar files to the installation location of your Java Runtime Environment. In addition, ensure that your Java environment is configured correctly, the URIs are correct, and the same certificate authority password is configured for all Content Manager installations.

If the Java environment is not configured correctly, you might see an error message similar to the following:


Ensure that the JAVA_HOME environment variable is set correctly and the appropriate security providers are installed.

Deploying IBM Cognos BI applications to IBM WebSphere Application Server fails

If the IBM Cognos Business Intelligence application file that you are trying to deploy to IBM WebSphere Application Server is too large, the deployment might fail with any of the following errors:

Browser timeout in administration console
HTTP 500 Internal Error
Return to application file selection page

To solve this problem, if you are using the Build Application Wizard, clear the Include static files from the Webcontent folder check box when you select the application to build. This will reduce the size of the application file. If static content is required, you can manually copy it to the deployed application location after you have successfully deployed IBM Cognos BI into the application server.

Problems creating an ODBC connection to a DB2 data source on the z/OS system

You might encounter problems, such as a failed connection error in IBM Cognos Administration, when you configure a connection to DB2 data sources because of encoding and file tagging settings.
ODBC connections require an EBCDIC ini file. The contents of the odbcini file must be EBCDIC, and users must know that the contents are EBCDIC.

Ensure that the following parameters are set:

- DB2 ODBC initialization file, odbcini, which is read at application run time, is tagged as EBCDIC
- The `chtag -t` option is turned off to ensure that the file is not a candidate for automatic conversion when automatic codeset conversion is enabled.

The following example shows that the odbcini file uses EBCDIC (IBM-1047) file encoding and that automatic conversion will not occur (T=off)

```bash
chtag -c IBM-1047 odbcini
ls -al -T odbcini
m IBM-1047 T=off -rw-rw-r--
```

**DB2 for z/OS subsystem parameter IDLE THREAD TIMEOUT (IDTHTOIN) causes report server connections to timeout**

On the z/OS system, workloads that have long running threads might time out when the IDLE THREAD TIMEOUT (IDTHTOIN) is set to the default setting of 120. This might be more noticeable when a thread is reused.

If extended dormant periods exist for individual connections that hold database resources, and if the timeout is set too low, the DB2 server cancels the connection that the IBM Cognos needs.

To avoid this problem, you can either increase the value of the DB2 subsystem parameter IDLE THREAD TIMEOUT (IDTHTOIN), or you can reset the value to 0.

**Reports fail with multiple UDA-SQL-0114, UDA-SQL-0107, RQP-DEF-0177, and logon failure errors**

If WebSphere Application Server instances are not shutdown properly, the servant regions might hold on to some orphan step jobs which causes the DB2 connection threads to be depleted. Reports might fail intermittently or all of the time.

To resolve this problem, ensure that you shutdown WebSphere Application Server on the z/OS system correctly when the `stop` command fails in UNIX System Services.
Notices

This information was developed for products and services offered worldwide.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service. This document may describe products, services, or features that are not included in the Program or license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

© Copyright IBM Corp. 2011, 2013
IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Software Group
Attention: Licensing
3755 Riverside Dr
Ottawa, ON K1V 1B7
Canada

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.
Trademarks

IBM, the IBM logo and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at "Copyright and

The following terms are trademarks or registered trademarks of other companies:
• Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered
  trademarks or trademarks of Adobe Systems Incorporated in the United States,
  and/or other countries.
• Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
  Microsoft Corporation in the United States, other countries, or both.
• Linux is a registered trademark of Linus Torvalds in the United States, other
  countries, or both.
• UNIX is a registered trademark of The Open Group in the United States and
  other countries.
• Java and all Java-based trademarks and logos are trademarks or registered
  trademarks of Oracle and/or its affiliates.
Index

Special characters

_BPXK_AUTOCVT  
data source connection problems 216  
-displayLog  
new feature description for version 10.2  4  
.profile file 34  
.registrar file  
WebSphere Application Server 78  
.tcshrc file 33

Numerics

31-bit installations  
components 19  
32-bit installations  
components 19  
64-bit Cognos gateway  
new feature description version 10.2  2  
64-bit gateway 83  
64-bit installations  
components 19  
64-bit operating system  
memory 24  
64-bit report sever  
configuring 84

A  
accessibility features 183  
an active Content Manager 92  
configuring 94  
analysis styles  
in workspaces 171  
anonymous logon  
disabling 153  
Apache Tomcat  
See Tomcat  
Application Tier Components  
64-bit report sever  
configuring 96  
configuring in distributed installations 96  
report server  
enabling 64-bit version 96  
archival times  
specifying 143  
archives  
creating a file location of a file system repository 142  
audience ix  
authentication  
disabling anonymous logon 153  
enabling 153  
using namespaces 153  
authentication providers  
deleting 165  
hiding from users during login 163

B  
blackout periods  
specifying 143  
building using the Build Application wizard 70

C  
CAF  
See Cognos Application Firewall  
CAM-AAA-0022 error 206  
CAM-AAA-0044 error 200  
CAM-AAA-0048 error 206  
CAM-AAA-0134 error 206  
CAM-AAA-0145 error 207  
CAM-CRP-1157 error 212  
capacity planning 21  
CBPDO 42  
CCL-BIT-0006 error 209  
certificate authority  
command line tool 173  
configuring 173, 175  
certificate signing requests  
generating 174  
CGC  
message codes 199  
CGC0001I  
DPR-SYS-6000 200  
CGC0002I  
DPR-SYS-6001 message 200  
CGC0003E  
CAM-AAA-0044 error 200  
CGC0004E  
CM-SYS-5003 error 201  
CGC0005I  
CM-SYS-5090 message 201  
CGC0006I  
CM-SYS-5094 message 201  
CGC0007I  
DPR-DPR-1002 message 201  
CGC0008I  
CM-SYS-5159 message 202  
CGC0009I  
CM-SYS-5160 message 202  
CGC00010E  
RSVP-SRV-0040 error 202  
CGC00011E  
DPR-ERR-2077 error 202  
CGC00012E  
RSV-DST-0014 error 203  
CGC00013E  
CNC-DS-0031 error 203  
CGC00014E  
CM-REQ-4138 error 203  
CGC00015E  
CM-REQ-4098 error 204  
CGC00016E  
UDA-SQL-0031 error 204  
UDA-SQL-0107 error 204  
CGC00018E  
QFS-ERR-0139 error 205

© Copyright IBM Corp. 2011, 2013 221
IBM Cognos Business Intelligence Version 10.2.0: Installation and Configuration Guide for z/OS
Index

Content Manager (continued)
- configuring as standby 95
- configuring in multiple server installations 92
- starting in distributed installations 96
- unable to register dispatchers 213

content store
- Cognos Content Database 26
- configuring a connection to Cognos Content Database 93
- configuring a connection to DB2 database 72, 85, 92
- configuring Cognos Content Database 87
- creating a DB2 database 55
- creating tablespaces 56
- database types 54
- deleting tables from the database 198
- JDBC drivers 59
- cookie settings 122
- configuring 123
- cryptographic keys
  - generating for other certificate authorities 174
- cryptographic services
  - updating JAR files 53
- cryptographic settings
  - configuring 130
- custom authentication providers
  - configuring a namespace 162
- Custom-Build Product Delivery Option
  - See CBPDO

customization
- product file systems 42

D

data sets
- naming conventions 25

data sources
- ODBC connectivity errors 216
- database cleanup scripts 198

database connectivity
- JDBC connections 62
- relational data sources for the dynamic query mode 62
- databases
  - creating for log messages 138
  - deleting tables 198
- IBM Cognos Mobile 61
- DB2
  - configuring a connection to content store 72, 85, 92
  - content store 54
  - creating a content store database 55
  - creating a human tasks and annotation services database 168
  - initial settings 36
  - db2jcc_license_cisuz.jar 59
  - db2jcc.jar 59
  - default connection pool time-out
  - conflicts between IBM Cognos BI and some application servers 70
  - deleteTask 145
  - dispatchers
    - unregistering 80
  - distribution libraries 25
  - documentation
    - related information ix
  - DPR-BUS-1500 error 210
  - DPR-DPR-1002 message 201
  - DPR-DPR-1035 212
  - DPR-ERR-2068 error 209
  - DPR-ERR-2072 error 208
  - DPR-ERR-2074 error 208
  - DPR-ERR-2077 error 202
  - DPR-SYS-6000 message 200
  - DPR-SYS-6001 message 200
  - dynamic query mode
    - memory 24
    - new feature description 4

E

EAR files
- building using the Build Application wizard 70
- encrypting
  - temporary file locations 132
- encryption
  - configuration errors 215
- environment variables 33, 35
  - JAVA_HOME 76
  - JDBC driver 211
  - LIBPATH 76
  - PATH 76
  - setting 30
  - setting using the sample .profile file 34
  - verifying 35
  - verifying for WebSphere Application Server 77

error messages
- cryptographic information cannot be encrypted 215
  - DPR-ERR-2014 214
  - DPR-ERR-2022 error 214
  - DPR-ERR-2058 error 213
  - SoapSocketException 213
- errors
  - cryptographic information cannot be encrypted 215
  - External identify mapping property
    - replace operation 161

F

file system repository
- creating a file location 142

file systems 42

fix packs
- applying maintenance 181

fixes
- Shop zSeries 195
- updater installation files 42

FMID
- product features 41
- fonts
  - adding new fonts 126
  - changing default fonts in PDF reports 129
  - changing embedded fonts in PDF reports 128
  - rendering in reports 126
  - specifying the location 127
  - substitutions and mappings 127

forums and communities 195

Framework Manager
- See Cognos Framework Manager
- function system modification
  - See FMID

G

gateway
- using the 64-bit gateway 83
gateways
  configuring in distributed installations 97
configuring to use a namespace 136
global settings
  multicultural requirements 149
glyphs
  changing embedded fonts in PDF reports 128

httpd.conf file 83
human task and annotation database
  tablespaces on DB2 on z/OS 169
human tasks and annotation services
  configuring database 170
  configuring for IBM Cognos Workspace 168
  creating a DB2 database 168

IBM Cognos BI Supplementary Documentation
  installing translated documentation 108
IBM Cognos Business Workspace
  configuration requirements 167
IBM Cognos Configuration
  command line options 185
  starting 54
IBM Cognos Dynamic Query Analyzer installation
  new feature description version 10.2.0 3
IBM Cognos Insight
  new feature description version 10.2.0 2
IBM Cognos Mobile
  database 61
IBM Cognos service
  configuring 90
  starting from IBM Cognos Configuration 88
IBM Cognos Software Development Kit
  installing with Cognos Framework Manager 107
IBM Cognos Workspace
  configuring access 167
  human tasks and annotation services database 168
  new feature description version 10.2.0 1
  report styles 171
  testing 167
IBM Dynamic Cubes installation
  new feature description version 10.2.0 2
IBM HTTP Server
  viewing static content 83
IBM Redbooks 195
IBM_JAVA_ENABLE_ASCII_FILETAG 53
IHS
  See IBM HTTP Server
index services
  configuring multiple instances 98
installation
  testing server components 89
installation checklist 7
installation location
  change for version 10.2 5
installing
  Cognos Cube Designer 103
  component locations 19
  creating a group and user 29
  fixes 181
  multiple instances of components 91
  overview 17
installing (continued)
  product file systems 42
  response files 46, 50
  sample jobs 42
  server components 41
internet protocol
  changing versions 124
  enabling IPv6 for Cognos Configuration 124
  versions 123
IPv4 123
  changing to IPv6 124
IPv6 123
  enabling at startup 124

java archive (.jar) files
  updating 53
Java Management Extensions
  configuring JMX properties for remote monitoring of system metrics 180
JAVA_HOME 53
  setting for WebSphere Application Server 76
JDBC connections 62
JDBC connectivity
  setting environment variables 211
  verifying 60
JDBC drivers
  content store 59
JVM instance
  changing 89
  WebSphere Application Server 75

keyboard shortcuts 183
IBM Cognos Configuration 184
IBM Cognos installation program 183
knowledge bases 195

languages
  configuring for report content 150
  configuring substitutions 149
launching Cognos Insight from Cognos BI 103
LDAP
  binding users 155
  configuring a namespace 156
  configuring a namespace for IBM Directory Server 157
  configuring customer user properties 159
  considerations for distributed installations 155
  enabling secure communications 159
  external identity mapping property 155
  mappings 155
LDAP templates
  new feature description version 10.2.0 3
LIBPATH
  setting for WebSphere Application Server 76
log database
  created tables for DB2 on z/OS 138
  creating for messages 138
  deleting tables 198
  setting up connections 141
log messages
  repositories 136
log servers 137

M
mail server
  configuring connection properties 73, 87
maintenance
  fixes 181
map charts
  changing the location 122
memory
  requirements 24
messages
  See also specifying repository type
  character set limitations 200
databases 137
  error codes 199
  files 137
  interpreting 199
remote log server 137
migrating
  See upgrading
models
  samples 189
mounting
  target filesystem 44
multitenancy applications configurations
  disabling multitenancy settings 149
  enabling multitenancy settings 147
  identifying tenant information 146
new feature description version 10.2 3
  overview 145

N
namespaces
  authentication 153
  configuring custom user properties for an LDAP server 159
  configuring for custom authentication providers 162
deleting 165
  enabling secure communication to LDAP servers 159
gateway configurations 136
  hiding from users during login 163
new features
  installation and configuration 1
  version 10.2.0 1
notification database
  creating tablespaces 56
deleting tables 198
  tablespaces for DB2 for z/OS 117

O
ODBC connectivity
  errors 216
output formats
  restricting 144

P
packages
  samples 189
parameters
  SYSI.PARMLIB 38
PATH
  setting for WebSphere Application Server 76
PDF reports
  changing default fonts 129
  changing embedded fonts 128
performance
  spool space 78
tuning 177
portal
  errors in starting 214
ports
  changing in the configuration tool 121
post-installation
  tasks 53
preventive service planning buckets
  See PSP
Problem Management Reports
  logging 194
  PMR
    See Problem Management Reports
problems
  browser timeout in WebSphere Application Server administration console 215
data error when encrypting information 215
  ports used by another process 213
troubleshooting installation issues 210
product locales
  mapping to preferred language 149
Program Directory
  sample jobs 42
program temporary fixes
  See PTF
properties
  changing in the configuration tool 117, 119
PSP
  applying maintenance 181
PTF
  applying maintenance 181

Q
QFS-ERR-0139 error 205
query styles
  in workspaces 171

R
RACF
  configuring 163
  enabling single signon 164
RACF namespace
  configuring 163
replace operation
  External identify mapping property 161
report server
  enabling 64-bit version 84
report styles
  in workspaces 171
reports
  configuring location of output 121
  samples 189
reports fail
  UDA-SQL-0114 errors 216
troubleshooting (continued)
diagnostic tools 194
fixes 195
forums and communities 195
IBM Redbooks 195
identifying problems 193
MustGather information 194
ports used by another process 213
problems starting the product 210
proven practices documentation 195
software support and RSS feeds 195
Support Portal 194

U
UDA-SQL-0031 error 204
UDA-SQL-0107 error 204
UDA-SQL-0114 error 205
umask 29
uninstalling
  Windows components 108
upgrading 19
URI settings
  changing in the configuration tool 121
structure 119
user accounts
  restricting access to Cognos namespace 154
user and group for installation files 29
verifying settings in TSO 30

V
verifying 35
JDBC connectivity to the content store database 60
user account settings 30
video documentation
  YouTube 195

W
WAR files 70
web alias
  change for version 10.2 5
web server gateway
  configuring to run on WebSphere Application Server 69
web servers
  enabling SSL 135
  viewing static content 83
WebSphere Application Server
  configuring 78
  configuring a servlet gateway 74
  creating a JVM instance 75
Windows components
  installing 99
  installing translated documentation 108
  uninstalling 108
Windows Vista
  configuring modeling components 111
WLM
  settings 177
Work Load Manager
  Srv WLM
workspaces
  report styles 171

Z
z/OS
  creating tablespaces for the DB2 mobile database 61